MET/CAL Introduction

MET/CAL Plus Calibration Management software provides you with all the tools you need to:

  • Perform automated calibration on all kinds of test and measurement tools and equipment, including dc/lf, RF and microwave instruments.
  • Create, edit, test, and document calibration procedures, quickly and easily.
  • Configure and report a wider range of measurement uncertainty parameters and include verification data to provide an audit trail and support further analysis.
  • Track asset information including calibration and maintenance history and status, traceability, users, customers, and location.
  • Analyze and report asset information; produce customized printed certificates and reports.
  • Make data available to other corporate systems.
  • Import asset and calibration data into MET/CAL Plus software
  • Help meet the requirements of quality standards like ISO 9000, ISO/IEC 17025, NRC 10 CFR, ANSI Z540.3, and others.

With all of these capabilities, Fluke MET/CAL Plus software offers the most comprehensive calibration automation solution available. And we back it up with the MET/SUPPORT Gold software support program to help keep you as productive as possible. Join the worldwide community of calibration professionals who have discovered the value of MET/CAL Plus for increasing throughput and managing calibration assets more efficiently.

Fluke MET/CAL® Plus calibration management software helps you to meet today's challenges by managing and calibrating your workload more efficiently. The product includes three key elements:

  • MET/CAL Runtime® – The industry-leading software for automated calibration. The MET/CAL Runtime application runs procedures to automate calibrations.
  • MET/CAL Editor – Application designed to create, edit, debug and manage calibration procedures executed by the MET/CAL Runtime.
  • MET/TEAM® – Dedicated browser based asset management system to manage your test and measurement assets.

Reference the Quick Start and Trial Overview sections for samples on using the various tools included in the package.

MET/CAL Plus is the most complete software solution available to calibration professionals. MET/CAL Plus supports the way your lab operates:

  • Add new items to MET/TEAM just by typing information into a form.
  • Generate recall reports.
  • Perform fast, repeatable, and powerful automated calibrations using the MET/CAL Runtime
  • Store all parameters for every calibration test step for future reporting or analysis and a clear audit trail.
  • Create and print ad hoc reports in Quick Report Builder or build your own reports using Crystal Reports Professional (included).

With all of these capabilities, Fluke MET/CAL Plus offers the most comprehensive calibration automation solution available. In addition, MET/SUPPORT Silver and Gold plans are provided to help you get up and running and keep you as productive as possible. Join the worldwide community of calibration professionals who have discovered the value of MET/CAL Plus in increasing throughput and managing their calibration assets more efficiently.

© 2015 Fluke Corporation


About This Manual

About This Manual

This is the Fluke Calibration Software Users Manual; its purpose is to assist users who have already installed the base package and one or more licenses. There is no installation information in this manual. It provides specific information about the calibration of instruments and management of metrology assets.

This application help was developed for two types of users: those who set up, administer, and maintain the system and those who use the software to perform calibrations or tracking.

Fluke's long-standing experience with calibration and metrology management software has proven that a solid conceptual model of the product gives users many advantages. Those who develop a clear picture of how the product works are better equipped to answer many of their own questions once they begin working with it.

Terminology Clarification

  • The 5500/CAL product is a subset of MET/CAL. Occasionally, the term MET/CAL is used when the text is applicable to both. When the term MET/CAL is used it is assumed that 5500/CAL operates identically. When there are differences between MET/CAL and 5500/CAL operation, the difference is clearly stated.
  • This help system was not designed for cover-to-cover reading, but for random access use. Some unfamiliar terms may be used in early topics. Further use of the software will increase terminology familiarity. It is recommended that terms or concepts be researched by using this help system or other sources to supplement information found here.
  • Several resources are available:
    • These online help files
    • The MET/TEAM help system
    • SQL Server Help
  • Always review the Read Me section of this manual for details of changes between releases

This Manual Describes Only Database Mode

Some older versions of MET/CAL and 5500/CAL could be operated in one of two modes, either Legacy Mode or Database Mode. Legacy mode is no longer available or supported as of MET/CAL 7.3. All upgraded installations will operate only in Database mode.

Intended Product Usage

The software application was designed to provide time-saving functions and features to the calibration laboratory environment. The traceability documentation requirements defined by current quality standards are making software solutions necessary for daily operation, regardless of the lab size.

Documentation may include:

  • Lists of instruments due for calibration.
  • Traceability reports for instruments used to calibrate other instruments.
  • Calibration certificates for use in an ISO-9000 compliant organization.
  • Calibration results reports and calibration summary reports as defined by ISO/IEC 17025.

Traceability

Proof of traceability of calibration may be required, for example, to maintain ISO-9000 certification. For a metrology lab, this means that the calibration documentation must be able to demonstrate an unbroken chain of comparisons. These comparisons must be traceable between a given asset and a certified standard, such as one maintained by a national standards body.

To review traceability details for an asset, launch MET/TEAM, select the asset and find the desired calibration Work Order by using the History/Notes tab. When the Work Order is open, select the Standards tab and use the RT or the FT options at the bottom of the tab for reverse or forward traceability respectively

When a calibration event is entered into the database, information about one link in the traceability chain is recorded. When a traceability report is printed, the entire chain of comparisons is documented in one of two specified directions.

A forward traceability report provides information about a particular asset and a particular calibration event. It is a listing of all the standards in the chain used to calibrate that asset relative to a specific cal event. The standards used in the current calibration are called the first tier. The standards used to calibrate those standards are the second tier. Those standards used to calibrate the second tier are in the third tier, and so on. The depth of the chain is selected when the report is run.

A reverse traceability report documents all the assets calibrated directly or indirectly by a specified standard asset during a specified period. Again, the standard asset is the first tier. Instruments that the standard asset calibrated are the second tier. Instruments that the second tier calibrated are in the third tier, and so on. Traceability reports are discussed in more detail later in this manual.


Technical Support

Fluke Calibration Software is supported by a highly skilled and conscientious team of professionals who are available to answer questions, help solve unique problems, and assist in troubleshooting in the event you run into difficulties.

Before Calling Technical Support

You may be able to discover the answer for yourself, so take the following steps before calling for support:

  • Check the online help. Use the search and index features to find the necessary information.
  • Check for help in the on-line community forum: community.flukecal.com

Please Have the Following Information Available

If you do find it necessary to call for assistance, take a few moments to jot down some information. If this information is readily available, the support person can more quickly get to the exact details of the difficulty you are having, and will be able to resolve the issue more efficiently.

  • Product name, applicable licenses, version and serial numbers. Use the About dialog for version details
  • Manual title, part number and version
  • Operating system and version
  • Network information if applicable
  • List of steps necessary to recreate the problem
  • Always note changes to the system or setup that may have occurred before or during the issue.

Telephone Support

Some free telephone support is available, but only to registered users of Fluke software. Be sure to register your software as soon as possible so you can make use of this service should the need arise.

Within the United States, toll free telephone support is available from 8:00 AM to 4:30 PM, Pacific Standard Time at 1-800-825-7411.

Priority support is available to any current Met/Support Gold customer. A special-access line is included in the Gold program information pamphlet.

To call Fluke from anywhere in the world, call 1-425-446-5400.

Web Support

Fluke provides a web site exclusively for the Metrology Software user. This site provides the most current phone numbers, downloadable procedures, reports, application notes, and other pertinent information. To access this support site:

  1. Enter http://support.fluke.com/register in your browser's URL address input box.
  2. Enter met-support in the "Name of the Site where you want to go:" box.
  3. Click Register.
  4. Complete the registration questionnaire.

Approval of your registration should be complete within one or two days. You will receive an email notice of your Web/Support user name, password and the Web/Support site address.

Worldwide Support

For more information on worldwide MET/SUPPORT™, please contact the Fluke office nearest you or your local representative.

LOCATION | TELEPHONE | FAX
Canada | 1-905-890-7600 | 1-905-890-6866
China | 86-10-6-512-3435 | 86-10-6-516-3437
UK/Europe | 44 1603-256600 | 44-1603-256688
Japan | 81-3-3434-0181 | 81-3-3434-0170
Singapore | 65-276-5161 | 65-276-5759
United States | 1-800-825-7411 | 1-425-446-5992
All other locations | 1-425-446-6476 | 1-425-446-5992

Mail, E-mail, and FAX

You may also contact us by mail, E-mail, and FAX:

FLUKE Corporation
PO Box 9090
Everett, WA 98206-9090
Attention: MET/SUPPORT, M/S 275G

E-mail metsupport@fluke.com

FAX 1-425-446-5992


Safety Information

Calibration systems may generate or measure dangerous voltages as required by the instrument calibration process. Both the operator and the procedure writer must be aware of possible hazards.

Warning

To prevent possible electrical shock, fire, or personal injury:

  • Never use a screen saver when using the MET/CAL Runtime or MET/CAL Editor applications. Screen savers will hide the high voltage safety symbol. The MET/CAL Runtime and MET/CAL Editor programs control test instruments and can cause them to output dangerous voltage levels. The high voltage safety symbol indicates when dangerous voltage is present.
  • Use interconnect wiring and adapters rated for the highest voltage and current levels carried.
  • Never touch exposed conductive portions of signal interconnect wiring, even after instruments have been turned off.
  • Only touch the insulated portion of a connector. First disconnect the interconnect wiring at the source, then at the measurement side.
  • Always use insulated adjustment tools.
  • If the calibration program is abnormally terminated, verify that the front panels of source instruments indicate standby mode.
  • When writing procedures, make sure that procedures minimize the time during which dangerous voltages are applied.


Read Me Overview

"Read Me" files are distributed with each version of Fluke Metrology software to highlight the specific changes in the software between versions. In some cases details on new functionality is also included in the "Read Me" files. For convenience, the read me files from the most recent several releases are embedded in this help system. Follow the links below other sections in the Read Me contents page to review the read me files.

The Issue# listed with the some Read Me sections is included to link the change to Fluke's internal issue tracking software. If you would like more detail regarding a specific change, use this issue# when communicating with the support team.


Read Me MET/CAL 9.0

This section includes a list of modifications to MET/CAL 9.0 relative to MET/CAL 8.3.2. This version of MET/CAL is compatible with MET/TEAM only.

What's new in version 9.0?

  • All new MET/CAL Runtime interface with an updated, modern look and feel.
    • Provides a workflow for configuring the test station, setting up a calibration, and running the calibration.
    • Export test results to a CSV file for analysis outside of MET/CAL
    • Integration with MET/TEAM asset manager
      • Control procedure selection by type of DUT, as-defined within MET/TEAM.
      • Reduced program access time by improving the login process for MET/CAL Runtime and MET/CAL Editor.
    • User Group based security
      • Security similar to MET/TEAM user interface.
      • Configure access to MET/CAL Runtime user interface controls based on user roles.
      • Administrator can control who can configure the test station, who can setup a calibration, and who can run a calibration.
    • MET/CAL Editor interface improvements provide users with an updated, modern look and feel for features tied to the MET/CAL Runtime, namely test results data and configuration options.
    • Click here for an introduction to the new Runtime display.
  • Significantly improved performance when writing MET/CAL Runtime results to MET/TEAM.
  • Updated MET/CAL Help System
    • Includes documentation on new MET/CAL Runtime and MET/CAL Editor interface.
    • Updated Table of Contents for easier navigation, making it easier to find application and feature information.
    • Removed redundant material and consolidated several topics.
    • Updated searching and cross-linking to related topics.
    • Brand new Tutorials section

This release of MET/CAL only supports English. Support for other languages will be added in the future.

MET/CAL Runtime and MET/CAL Editor

Issue | Type | Description
MCR-888 | FIX | Resolved an issue that prevented characters such as the ohms symbol from appearing correctly in the Test Results window.
MCR-1563 | FIX | Addressed an issue where running the same PXE multiple times in a row without closing the runtime between runs may yield an erroneous validation error message.
MCR-1709 | FIX | Addressed a font initialization error in module win (E2372).
MCR-1951 | ADDED | Added Portuguese to the language selection options on the MET/CAL installation. Set the UI language to use based on this selection.
MCR-2003 | FIX | Unicode characters embedded in a procedure will always display properly when the procedure is ran.
MCR-2108 | CHANGE | Updated the DELAY special construction documentation for the following FSCs: DISP, EVAL, HEAD, IEEE, IEEE2, SCPI, MEMI, OPBR, PORT, RESET, RSLT, SET, VISA, and WAIT.
MCR-2110 | FIX | Fixed a bug with the work order screen not closing the embedded browser when applicable.
MCR-2165 | FIX | Resolved an issue with MCRHT.EXE that was preventing full error message text from being displayed.
MCR-2168 | FIX | Resolved an issue that prevented the pre-prompt and post-prompt dialogs from being suppressed when the prompt, pass_prompt and/or fail_prompt settings were set to "None".
MCR-2274 | FIX | When a 96270A FSC statement is executed that includes PowerSensor1 and/or PowerSensor2, the asset of the configured power sensor(s) is included as a standard in the work order.
MCR-2281 | FIX | Significantly improved performance when writing MET/CAL Runtime results to MET/TEAM.
MCR-2315 | FIX | Resolved an issue that would crash MET/CAL Runtime or MET/CAL Editor when trying to delete a variable using MATH DEL(var)
MCR-2319 | FIX | Resolved an issue where the Please Wait window did not close if an exception occurred when starting a procedure.
MCR-2328 | ADDED | Added a refresh/reload button to the upper left corner of the embedded browser window (except on Sign In window).
MCE-693 | FIX | Fixed an unhandled exception error when attempting a test run in the MET/CAL Editor with the MET/CAL Runtime open.
MCE-691 | FIX | Addressed an issue with error messages related to procedure sectioning where the referenced file may not be shown correctly in the error window.
MCE-677 | FIX | Resolved an issue that allowed breakpoints on header, blank, and comment lines. Resolved an issue that prevented toggling breakpoints during a Test Run using Ctrl+B. Resolved an issue that was causing invalid breakpoints to appear in procedure files that were not in a project.
MCE-663 | FIX | Resolved an issue creating the URL protocol handler during installation on Windows 8 and later operating systems.
MCE-662 | FIX | An EPM FSC statement with Frequencych value taken from a register or name variable will now compile without error.
MCE-643 | FIX | 9500 amplitude is now correctly converted from Vrms and Vp to Vpp for accuracy lookup when MOD2 = SQ, ZQ, and ZN.
MCE-642 | FIX | The 9500 driver now correctly converts from Vrms and Vp to Vpp when MOD2 is SQ, ZQ, and ZN.
MCE-641 | FIX | 9500 amplitude is now correctly converted from Vrms and Vp to Vpp when MOD2 = SQ, ZQ, and ZN.
MCE-639 | FIX | Fixed upper limit for Volts LR in 5080a.acc accuracy file.
MCE-638 | FIX | Fixed lower limit for MOD1 in 4950.acc accuracy file.
MCE-637 | FIX | Fixed lower limit for E9300H Power Sensors in 4418.acc and 4419.acc accuracy files.
MCE-636 | FIX | Fixed lower limit for E4412A and E4113A Power Sensors in 4418.acc and 4419.acc accuracy files.
MCE-635 | FIX | Fixed lower limit for Hertz D4 in 4050.acc accuracy file.
MCE-634 | FIX | Added 5 kHz to 10 kHz specification for mode Amps Medium to 4050.acc accuracy file.
MCE-633 | FIX | Added 5 kHz to 10 kHz specification for mode Amps Medium to 4040.acc accuracy file.
MCE-632 | FIX | Fixed resolution for 10MOhm E 2W in 1281.acc and 1281_95.1yr accuracy files.
MCE-631 | FIX | Fixed resolution for 10V E in 1281.acc and 1281_95.1yr accuracy files.
MCE-630 | FIX | The 9500 driver now correctly converted from Vrms to Vpp for the following functions: Voltage, Edge, Fast Edge, Leveled Sine
MCE-629 | FIX | 9500 accuracy file lookup modes are now correctly generated when Nominal units are Ap or Vpp for the following functions: Current, Voltage, Edge, Fast Edge, Leveled Sine
MCE-628 | FIX | 9500 amplitude is now correctly converted from Vrms to Vpp for limits checking for the following functions: Voltage, Edge, Fast Edge, Leveled Sine
MCE-627 | FIX | 9500 amplitude is now correctly converted from Vrms to Vpp for accuracy lookup for the following functions: Voltage, Edge, Fast Edge, Leveled Sine
MCE-626 | FIX | 8901 statements with Nominal units of 'D' dBm and MOD3 = TL (Tuned RF Level) are now checked against the correct limits of the instrument (-20 dBm to +30 dBm).
MCE-625 | FIX | M8902 statement with MOD3 = L1 paired with a 8902 statement with MOD3 = AF no longer generates an accuracy file lookup error.
MCE-624 | FIX | 8902 frequency statements with MOD1 > 3 V no longer generate an accuracy file lookup error.
MCE-622 | FIX | 8505 statements with voltage or current in the Nominal field and MOD3 = FE n longer causes an accuracy lookup error.
MCE-621 | FIX | 395 statements with MOD1 > 5 Vpp no longer generate an accuracy lookup error.
MCE-620 | FIX | Unspec'd readings in the range -1E-13 to +1E-13 will no longer generate an accuracy lookup error.
MCE-619 | FIX | Unspec'd readings in the range -1E-13 to +1E-13 will no longer generate an accuracy lookup error.
MCE-618 | FIX | The 5820A AC Current Output is now correctly converted for accuracy file lookup when Nominal units are amps peak (Ap).
MCE-613 | FIX | Long 6100, 6100B, and 6105A statements that exceed the maximum number of continued lines, now generate: "E203: fsc FSC: Continued statement too long."
MCE-598 | FIX | Resolved an issue when compiling a procedure in the Editor that caused actual errors to be reported as warnings when preceded by a warning about a statement exceeding the legacy line length limit.
MCE-573 | FIX | COM5502A and COM5502E added to PORT FSC help topic.
MCE-554 | ADDED | Updated the 5730A accuracy files to support 50 MHz Wideband ACV option.
MTM-5467 | CHANGE | The MET/TEAM Server installer handles merging the contents of the libraryfsc.xml and datatypemap.xml files on the server with the same files being deployed by the installer. These files are used by the Library (LIB) FSC.
MCR-2337 | FIX | MET/CAL now stores the TUR in PointExNumerics.nField030 as well, so that it can be accessed as a numeric value.
MCR-2328 | CHANGE | Added a refresh/reload button to the upper left corner of the embedded browser window (except on Sign In window).
MCR-2293 | FIX | Addressed an issue with the TUR display when running from the MET/CAL Editor with an instrument that returns an overload condition, which may lead to an abnormal termination of the MET/CAL Editor.
MCR-2284 | FIX | Addressed an issue with calibration results stored in the MET/TEAM database, where the determined format to use may render a value as an integer, when it should have been formatted as an exponential value with five or more digits after the decimal.
MCE-703 | FIX | When intending to use extended character data in the MET/CAL Editor, source files created outside of the Editor must have the UTF-8 byte order mark.


Read Me MET/CAL 8.3.2 Update 1a

This section includes a list of modifications to MET/CAL 8.3.2 Update 1a relative to MET/CAL 8.3.2.

MET/CAL 8.3.2 Update 1a includes all changes from 8.3.2 Update 1. As a result, this ReadMe includes all issues from Update 1 and 1a.

What's new in version 8.3.2 Update 1a?

MET/CAL Runtime and MET/CAL Editor

Key | Issue Type | Release Note
MCR-1017 | FIX | The VSET and TSET FSC's IEEE2_SRE_RQS parameter now works as described in the help topic.
MCR-1662 | FIX | Addressed an issue with the MET/CAL Editor where publishing a PXE may fail if the external frequency reference configured on the workstation is not included in the config.dat file attached to the project.
MCR-1703 | FIX | The IEEE2 and SCPI FSCs no longer set bit 6 in the *SRE command automatically sent to the instrument.
MCR-1711 | FIX | 5502A and 5522A FSCs now calculate the correct harmonic amplitude accuracy for harmonics 2 through 50.
MCR-1719 | CHANGE | Updated floor accuracy on 5522A, 5502A, 5502E accuracy files.
MCR-1729 | FIX | Addressed an issue with the procedure selector where procedures with a MET/CAL version of 8.2 and later may not load if they utilize the standard line length used by procedures prior to 8.2. It is recommended to empty your proc.dir file and rebuild it with the procedure selector to add any missing entries.
MCR-1730 | FIX | Addressed an issue where the temporary variable storage in MET/CAL may not encode strings correctly, preventing a user name containing extended characters from displaying correctly.
MCR-1894 | FIX | Resolved an issue that prevented 7526A statements with Temperature numeric value taken from a register or named variable from compiling.
MCE-331 | ADDED | Enabled 96040A NVI FSC for the Fluke 96040A RF Reference Source.
MCE-559 | FIX | The metcal.ini parameter "tag_ui_show" now persists properly after running sectioned procedures in the MET/CAL Editor.
MCE-563 | FIX | Addressed an issue with MET/CAL Editor where an abandoned test run due to a configuration error may not reset the test run state.
MCE-564 | FIX | The 5502A, 5502E, and 5522A FSCs now allow Voltage to be specified to full extent of the range when Mode = TC_Source; TC_Type = _10µVdegC.
MCE-565 | FIX | The 5502A, 5502E, and 5522A FSCs now report the correct reference accuracy when Mode = TC_Source; TC_Type = _10µVdegC, and the evaluation quantity is Voltage (i.e. +Voltage).
MCE-567 | FIX | 96270A Frequency Counter statement with an invalid range now produces a valid error message.
MCE-568 | FIX | 9640, LPN, LPNX, 96040A, & 96270A FSC Frequency Counter statements now generate accuracy output when DEBUG=>Trace=>Accuracy is enabled.
MCE-574 | FIX | Addressed an issue with the MET/CAL Editor where converting a *.pkm to a project may ignore picture files included in it.
MCE-581 | CHANGE | 5790 FSC statements with CON = XF (Transfer Mode) will compile when NOMINAL voltage is greater than 1000 and less than or equal to 1050.
MCE-584 | FIX | The maximum allowed test voltage when ResistanceMultiplierOn is specified has been increased from 5.5 kV to 10 kV.
MCE-590 | FIX | A 5522A statement containing the ExternalGuard parameter now compiles and executes without error.
MCE-591 FIX

Resolved an issue that prevented the following FSCs from compiling:

  • 4418 FSC: HP/Agilent EPM-441A, E4418A, E4418B Power Meters
  • 4419 FSC: HP/Agilent EPM-442A, E4419A, E4419B Power Meters
  • 5205 FSC: Fluke 5205A, 5215A Amplifiers controlled by a 5100B, 5101B, 5102B, or 5130A, also 5215A controlled by 5200A
  • 5220 FSC: Fluke 5220A Transconductance Amplifier controller by a 5100B, 5101B, 5102B, or 5130A
  • RESF FSC: Fluke 5100B, 5101B, 5102B, or 5130A resistance
  • P525 FSC: Fluke 525A Series pressure module connected to a 525A or 525B
  • P700 FSC: Fluke 700 Series pressure module connected to a 525A or 525B
  • WIDE FSC: Fluke 5100B, 5101B, 5102B Wideband


Read Me MET/CAL 8.3.2 Update 1

This section includes a list of modifications to MET/CAL 8.3.2 Update 1 relative to MET/CAL 8.3.2.

What's new in version 8.3.2 Update 1?

MET/CAL Runtime and MET/CAL Editor

Key | Issue Type | Release Note
MCR-1017 | FIX | The VSET and TSET FSC's IEEE2_SRE_RQS parameter now works as described in the help topic.
MCR-1662 | FIX | Addressed an issue with the MET/CAL Editor where publishing a PXE may fail if the external frequency reference configured on the workstation is not included in the config.dat file attached to the project.
MCR-1703 | FIX | The IEEE2 and SCPI FSCs no longer set bit 6 in the *SRE command automatically sent to the instrument.
MCR-1711 | FIX | 5502A and 5522A FSCs now calculate the correct harmonic amplitude accuracy for harmonics 2 through 50.
MCR-1719 | CHANGE | Updated floor accuracy on 5522A, 5502A, 5502E accuracy files.
MCR-1729 | FIX | Addressed an issue with the procedure selector where procedures with a MET/CAL version of 8.2 and later may not load if they utilize the standard line length used by procedures prior to 8.2. It is recommended to empty your proc.dir file and rebuild it with the procedure selector to add any missing entries.
MCR-1730 | FIX | Addressed an issue where the temporary variable storage in MET/CAL may not encode strings correctly, preventing a user name containing extended characters from displaying correctly.
MCE-331 | ADDED | Enabled 96040A NVI FSC for the Fluke 96040A RF Reference Source.
MCE-559 | FIX | The metcal.ini parameter "tag_ui_show" now persists properly after running sectioned procedures in the MET/CAL Editor.
MCE-563 | FIX | Addressed an issue with MET/CAL Editor where an abandoned test run due to a configuration error may not reset the test run state.
MCE-564 | FIX | The 5502A, 5502E, and 5522A FSCs now allow Voltage to be specified to full extent of the range when Mode = TC_Source; TC_Type = _10µVdegC.
MCE-565 | FIX | The 5502A, 5502E, and 5522A FSCs now report the correct reference accuracy when Mode = TC_Source; TC_Type = _10µVdegC, and the evaluation quantity is Voltage (i.e. +Voltage).
MCE-567 | FIX | 96270A Frequency Counter statement with an invalid range now produces a valid error message.
MCE-568 | FIX | 9640, LPN, LPNX, 96040A, & 96270A FSC Frequency Counter statements now generate accuracy output when DEBUG=>Trace=>Accuracy is enabled.
MCE-581 | CHANGE | 5790 FSC statements with CON = XF (Transfer Mode) will compile when NOMINAL voltage is greater than 1000 and less than or equal to 1050.


Read Me MET/CAL 8.3.2

This section includes a list of modifications to MET/CAL 8.3.2 relative to MET/CAL 8.3.1. This version of MET/CAL is compatible with both MET/TEAM and MET/TRACK.

What's new in version 8.3.2?

MET/CAL Runtime and MET/CAL Editor

Issue | Type | Description
MCR-1622 | FIX | Resolved an issue where the install location would get appended to the PATH environment variable following every installation regardless of whether the folder was already in the PATH.
MCR-1631 | FIX | Resolved an issue that prevented string literals from being passed to a Win32 function using the LIB FSC.
MCR-1638 | FIX | Resolved an issue where the first two characters of each line were being omitted when opening a .pro file in a new project in the Editor and when running a .pro file.
MCR-1643 | FIX | Resolved an issue that caused a failure when deploying MET/CAL Runtime as an upgrade to a previous version.


Read Me MET/CAL 8.3.1

This section includes a list of modifications to MET/CAL 8.3.1 relative to MET/CAL 8.3. This version of MET/CAL is compatible with both MET/TEAM and MET/TRACK, however MET/CAL Runtime and MET/CAL Editor now only work exclusively with one database or the other. Some of the new features and changes listed below are either not supported by MET/TRACK or they are supported in a limited capacity.

What's new in version 8.3.1?

MET/CAL Runtime and MET/CAL Editor

Issue | Type | Description
MCE-508 | ADDED | The PORT FSC now supports a [CLOSE] special construction.
MCR-1475 | ADDED | Added support for new MATH FSC Functions:
 |  | ACCVA - look up accuracy data (DC) for specified auxiliary instrument
 |  | ACCV2A - look up accuracy data (AC) for specified auxiliary instrument
 |  | ACCVFA - look up accuracy data floor (DC) for specified auxiliary instrument
 |  | ACCVF2A - look up accuracy data floor (AC) for specified auxiliary instrument
 |  | ACCVGA - look up accuracy data gain error in base units (DC) for specified auxiliary instrument
 |  | ACCVGPA - look up accuracy data gain error as entered (DC) for specified auxiliary instrument
 |  | ACCVG2A - look up accuracy data gain error in base units (AC) for specified auxiliary instrument
 |  | ACCVGP2A - look up accuracy data gain error as entered (AC) for specified auxiliary instrument
 |  | CONFA - look up confidence for specified auxiliary instrument
MCR-1540 | CHANGE | Changed MET/CAL Runtime and MET/CAL Editor installers to work with either MET/BASE or MET/TEAM exclusively.
MCR-82 | FIX | Fixed a problem with 'µ' character in BASE and ENGR.
MCE-291 | FIX | Found an issue where special characters are not properly converted to UTF8 when updating an existing variable. This has been resolved and updating variables works properly.
MCR-1508 | FIX | General Resistance RTD-100X accuracy file upper limit has been corrected: 111.110 changed to 1111.110
MCR-1499 | FIX | Resolved an issue that caused units that contained extended ASCII characters to be displayed and stored incorrectly for the ACC and MEMC/MEMCX FSCs when NMEAS > 1.
MCR-1436 | FIX | Instruments with a corresponding MET/CAL device code (Ex. “Fluke 5500A/COIL”) can now be configured as a Manual Standard and used with the MATH functions ACCV and ACCV2.
MCR-1431 | FIX | The N5531 FSC Power Meter Cal and Zero timeouts have been increased from 15 s to 30 s.
MCR-1416 | FIX | Resolved an issue where the 5700A and 5720A were not successfully put in standby following procedure execution.
MCR-954 | FIX | The 4419 FSC no longer times out when taking a measurement.


Read Me MET/CAL 8.3

This section includes a list of modifications to MET/CAL 8.3 relative to MET/CAL 8.2.3. This version of MET/CAL is compatible with both MET/TEAM and MET/TRACK. Some of the new features and changes listed below are either not supported by MET/TRACK or they are supported in a limited capacity.

What's new in version 8.3?

  • New 96270A and LPN FSCs, plus updated 9640 and LPNX FSCs.
  • Convert an entire compiled procedure directory (proc.dir) to projects in bulk, and optionally produce PXEs for all selected procedures. The MET/CAL Editor's File > New Project from Existing Procedure menu item now supports multiple procedure selections.
  • Validate and control which MET/CAL client versions can be used.
  • Fluke 5502A oscilloscope calibrator options are now supported by the O_CAL FSC.
  • Specify the directory where PXE procedures reside, and retain the last selected PXE directory (persists after the application is closed).
  • Optionally increment the PXE version during an Automated Build.
  • Major updates throughout the MET/CAL User and Reference Guides.

MET/CAL Runtime

Issue | Type | Description
MCR-698 | ADD | Improved the error handling when MET/CAL writes calibration data after a fatal error. It will now display the message after writing the data to ensure the data is there when the message is shown.
MCR-719 | ADD | Restored the ability to launch compiled procedures from MET/TEAM. Launching compiled procedures via MET/TEAM is not recommended for numerous reasons, and should be avoided.
MCR-742 | ADD | The browser embedded into MET/CAL for interfacing with MET/TEAM has been replaced. The new browser is based on Chromium and replaces the Internet Explorer browser that was used before. The previous browser leveraged the version of IE that was installed on the client PC, so the version was variable and could be very old. This allows MET/CAL to use a known browser version, that is modern and meets the requirement of MET/TEAM regardless of the browser versions installed.
MCR-763 | ADD | All dates sent to a MET/TEAM server are now sent in UTC time.
MCR-765 | ADD | Updated 5700A and 5720A accuracy files to match updated specifications for 2-wire Resistance.
MCR-769 | ADD | Updated MET/CAL online help to indicate a requirement for a PDF reader utility to be installed on the MET/CAL workstation.
MCR-788 | ADD | Update 5730A accuracy files' Resistance sections to include Active Compensation adders and Current Derating Factors.
MCR-834 | ADD | Added a new help topic for the pxedir parameter in metcal.ini.
MCR-837 | ADD | Added the capability to validate and control which MET/CAL client versions can be used. This can be done by adding the parameter "MetcalVersion=X.X.X" to the startup.ini file in the server's shared directory.When MET/CAL runs it will abort if its version is not the same as the version specified in the file.
MCR-810 | CHANGE | The language selection on the MET/CAL installer now controls the language the MET/TEAM screens that are displayed in the MET/CAL embedded browser.
MCR-238 | FIX | Repeated calls to the same subprocedure will now be included in the failed test counts for the calibration. Prior to this, the subprocedure was only counted once, even though multiple failing tests were written to the results in the database.
MCR-240 | FIX | Fixed incorrect accuracy lookup mode string for 5500A-SC300 marker function.
MCR-677 | FIX | Found an issue where selecting break while running a subprocedure would cause MET/CAL to crash at the end of the calibration. This has been resolved, and Break now works properly in subprocedures.
MCR-683 | FIX | The O_CAL FSC now works with the 5502A Oscilloscope Calibration Options.
MCR-705 | FIX | 5320 FSC now sends the correct remote command for Mode = GBR; Open.
MCR-706 | FIX | Fixed multiple long line display issue in OPBR
MCR-711 | FIX | The 5522A FSC now allows the parameter TemperatureStandard in RTD Source Mode.
MCR-712 | FIX | The 5502A FSC now allows the parameter TemperatureStandard in RTD Source Mode.
MCR-713 | FIX | The 5502E FSC now allows the parameter TemperatureStandard in RTD Source Mode.
MCR-715 | FIX | The PORT FSC [Pport,baud rate,parity,data bits,stop bits,handshake] special construction now works with COM5500, COM5502A, COM5502E, COM5520, COM5522, COM5800, and COM5820.
MCR-721 | FIX | Found a GIGO issue where having values with embedded line feeds in the runtime prompts will cause MET/CAL to crash. This issue has been resolved, any values with line feeds will have the line feed characters replaced with spaces before adding the value to the variable cache.
MCR-723 | FIX | Fixed an issue with pass/fail determination on the work order result, where failed points were repeated and passed the second time, and therefore should not fail the work order result.
MCR-725 | FIX | Found an issue where messages in operator prompts do not respect the newline characters embedded in them by using line continuations. The text was wrapping based on the entire concatenated message, and not the individual components of the message. The messages in operator prompts now take the embedded newlines into account when determining message wrapping.
MCR-726 | FIX | Found an "issue" where the PIC FSC window was respecting the DPI settings of images when they are displayed. This causes images with high DPI settings to display smaller than the raw pixel value. This has been "fixed" so the DPI settings of the image are ignored, and the image is displayed according to the raw pixel value instead of being appropriately scaled via the DPI settings in the image.
MCR-730 | FIX | The legacy long line length warning has been changed to not warn on single line compile (hitting enter on the statement) but will still display on a full compile.
MCR-731 | FIX | Found an issue with the compiled procedure selector where the cache was not being properly populated with the procedure header data with procedures built and published in the 8.2 editor. This is caused by the long line length changes in the compiled procedure format. This has been resolved, but the procedure cache must be rebuilt to see the correct values. Navigate to your proc.dir, and delete the procedures.cache file that is in the directory with it. In the procedure selector check "Validate procedures on load" to rebuild the cache. You should now see the correct header data in the procedure selector.
MCR-735 | FIX | Found an issue where the automated build would load all the projects in it's parent solution. This has been fixed so only the appropriate project is loaded.
MCR-736 | FIX | FSCs 5502A, 5502E, and 5522A. TC Source mode 10 µV/°C and 1 mV/°C now programs the calibrator correctly. An execution error is no longer generated.
MCR-738 | FIX | Resolved a problem in which compiled procedures created with older versions of MET/CAL may incorrectly display deleted lines from the procedure in a display or user prompt.
MCR-749 | FIX | The DISP and OPBR FSCs were updated to better handle double byte languages.
MCR-759 | FIX | Removed incorrect instrument configuration note from the 4418 and 4419 FSC help topics. Instruments should be configured to match their real model numbers.
MCR-761 | FIX | 8508 FSC Ohms Ratio Mode now sets "LOI ON" when a previously executed M8508 specifies "LOI".
MCR-764 | FIX | Updated Guildline 6520 accuracy file specifications.
MCR-767 | FIX | Found an issue that was limiting the size of the content of a named variable. The size limit has been restored to previous limits.
MCR-771 | FIX | Fixed an issue where characters reserved for URLs would break the pre and post prompt screens when running MET/CAL with MET/TEAM. These characters are now encoded by MET/CAL and decoded by MET/TEAM so they can be used in text fields in the prompt screens.
MCR-782 | FIX | An adjustment was made to the recording of PointReadings.tReadingDateTime, to match the point's date/time.
MCR-784 | FIX | The 9640 driver now correctly restores the external reference oscillator to the state it was in before the procedure was executed.
MCR-789 | FIX | 9640 and LPNX FSC run time driver now properly restricts frequency slewing to a maximum of 125.75 MHz when the level is greater than 20 dBm, per instrument capability.
MCR-790 | FIX | 9640 and LPNX FSC run time driver now properly displays the slewed power in watts at the minimum.
MCR-795 | FIX | Addressed an issue where the MET/CAL login to MET/TEAM may not auto-focus on the user name field.
MCR-818 | FIX | Fixed an issue where list boxes were not sized correctly, causing text to be cut off and scroll bars to be displayed where they did not need to be.
MCR-819 | FIX | Found an issue with the OPBR [NO] special construction not setting the focus to the "NO" button. This has been resolved and this special construction works properly again.
MCR-823 | FIX | The 6100 FSC again works with the 9100 Option 10 & 50-turn coil.
MCR-831 | FIX | Dimensioned numbers displayed in engineering notation in error messages no longer contain a space between the SI prefix symbol and the units symbol.
MCR-833 | FIX | 5522A FSC: TC Source limits now correctly computed for °F
MCR-835 | FIX | 5502A FSC: TC Source limits now correctly computed for °F
MCR-836 | FIX | 5502E FSC: TC Source limits now correctly computed for °F
MCR-852 | FIX | Found an issue where writing large amounts of points to MET/TEAM took an unacceptable amount of time. The processing of results has been optimized to remove the bottleneck that was causing this.

Editor

Issue | Type | Description
MCE-306 | ADD | MATH FSC help topic: added table of content links for ACCFGP, ACCFGP2, ACCVGP, and ACCVGP2 functions. Fixed DBTOPCTV_D example's return value. Fixed formatting of the STRIPL and STRIPT entries for better readability.
MCE-314 | ADD | The 52120A FSC now allows Frequency as the evaluation quantity. When +Frequency is specified in a 52120A statement the reference accuracy is unspecified (NA in accuracy file). A subsequent FSC for the "driving" calibrator must be used to establish the frequency accuracy for the test.
MCE-315 | ADD | The 52120A 1 year accuracy file now contains "Mode: Hertz" to support 52120A statements with Frequency as the evaluation quantity. Note, the entries are NA since the driving calibrator establishes the frequency accuracy for the test.
MCE-318 | ADD | MATH FSC help topic now includes information about which file I/O functions will attempt to create the file where it does not already exist.
MCE-341 | ADD | A new FSC for the Fluke 9640A-LPN is now available.
MCE-403 | ADD | Added functionality to increment the PXE version during an automated build. This can be turned on with a new metcal.ini parameter "IncrementProjVer = yes". Refer to the Project Properties topic in the help system for more details.
MCE-406 | ADD | Functionality has been added to convert the compiled procedures in an existing proc.dir to projects in bulk, and to optionally produce PXEs for all selected procedures.The MET/CAL Editor File, New Project from Existing Procedure option now supports multiple procedure selections.A user can select all main procedures in a Proc.dir and generate PXEs for all of them at the same time.Please see the associated help topic for more information.
MCE-299 | ADD | Added the ability to cancel an automated build process. When this process is canceled, the automated build stops after the project build in progress is complete.
MCE-297 | ADD | Documented command line syntax for using correct.exe.
MCE-296 | ADD | Added an error message to indicate why a project failed to build when a file in the project does not exist in the location the project points to.
MCE-285 | ADD | The 5522A FSC now accepts TemperatureScale or TemperatureStandard.
MCE-284 | ADD | The 5502A and 5502E FSCs now accept TemperatureScale or TemperatureStandard.
MCE-280 | ADD | Added documentation for Device Mapping.
MCE-278 | ADD | Documented how an instrument configuration file (config.dat) can be added to a project.
MCE-34 | ADD | An option to show the test results window has been added to the test run tool bar of the Editor.Use the option to bring the MET/CAL Results window to the foreground in the event the window is stuck in the back ground.
MCE-288 | CHANGE | Removed all references to F7 (Learn Mode) from MET/CAL Editor documentation. Learn mode is currently not supported by the MET/CAL Editor.
MCE-279 | CHANGE | Support for the MCZ package format has been removed from the MET/CAL Editor as it has been obsoleted by text based procedure source and PXE procedure packages.Creating new MCZ packages is no longer supported.The Bin file in a procedure Project directory includes a Zip file with all dependencies required to build the PXE.
MCE-316 | CHANGE | Change VS2012's default behavior for File > Save procedure As... to support making a basic copy of a file at the specified path, without affecting the original file or the open project's pointer to the original file.
MCE-317 | CHANGE | Resume debugging now clears the MATH REFACC() function static data.
MCE-362 | CHANGE | Changed the warning message W14218 associated with long line lengths and DISP/OPBR FSCs to error E14234.
MCE-410 | CHANGE | The 9640 FSC now requires AMDepth when Mode = AM.
MCE-411 | CHANGE | The 9640 FSC now requires FMDeviation when Mode = FM.
MCE-412 | CHANGE | The 9640 FSC now requires PMDeviation when Mode = PM.
MCE-413 | CHANGE | The LPNX FSC now requires AMDepth when Mode = AM.
MCE-414 | CHANGE | The LPNX FSC now requires FMDeviation when Mode = FM.
MCE-415 | CHANGE | The LPNX FSC now requires PMDeviation when Mode = PM.
MCE-301 | FIX | Updated the 9500 FSC help topic examples and formatting.
MCE-303 | FIX | The 5502A FSC now correctly computes power factor accuracy.
MCE-304 | FIX | The 5522A FSC now correctly computes power factor accuracy.
MCE-307 | FIX | The 5080A FSC now correctly computes power factor accuracy.
MCE-320 | FIX | The Long line length warning in the MET/CAL Editor only displays when lines exceed 256 characters.The procedure statements are no longer truncated when this occurs.
MCE-321 | FIX | 'M' is no longer automatically converted to 'm" when units of "MZ/Z" are entered in the 8508 FSC Nominal field.
MCE-342 | FIX | 9640 and LPNX minimum frequency is now correct: 1 mHz
MCE-368 | FIX | The LPNX FSC now works in Editor Simulation Mode with no asset number configured for "Fluke 9640A-LPNX".
MCE-300 | FIX | The 5502A FSC now allows Power in negative VAR. Example:26.001 5502A Coil = 5500A/COIL; NonToroidalUUT26.001 5502A CurrentTerminal = Aux; InductanceComp = On26.001 5502A Voltage = 21.9595 V; Current = 100 A; Phase = -73 deg26.001 5502A +Power = -2100 VAR; Frequency = 50 Hz
MCE-298 | FIX | The MET/CAL Editor installer incorrectly deleted the user profile settings from the previous version when performing an upgrade to prevent startup failures.
MCE-295 | FIX | 6100, 6100B, & 6105A FSC now allow phaselegFlickerDepth up to and including 60 %.
MCE-291 | FIX | Found an issue where special characters are not properly converted to UTF8 when updating an existing variable. This has been resolved and updating variables works properly.
MCE-286 | FIX | Removed non-applicable ReferenceClock entries from 5502A and 5502E help topic.
MCE-263 | FIX | Addressed an issue where starting Test Run in Editor right after closing MET/CAL Runtime may lead to a memory access violation shutting down the Editor.
MCE-224 | FIX | Resolved an issue where performing a Test Run generated an exception after the 2nd execution.


Read Me MET/CAL 8.2.3

This section includes a list of modifications to MET/CAL 8.2.3 relative to MET/CAL 8.2.2. This version of MET/CAL is compatible with both MET/TEAM and MET/TRACK. Some of the new features and changes listed below are either not supported by MET/TRACK or they are supported in a limited capacity.

What's new in version 8.2.3?

  • Using MET/CAL Runtime with MET/TEAM now requires PDF viewer software to be installed on the workstation to view reports. A PDF viewer is not automatically installed with the MET/CAL Client installer. However, Adobe Reader is included on the MET/TEAM distribution media.

MET/CAL Runtime

Issue | Type | Description
MCR-742 | CHANGE | The browser embedded into MET/CAL for interfacing with MET/TEAM has been replaced. The new browser is based on Chromium and replaces the Internet Explorer browser that was used before. The previous browser leveraged the version of IE that was installed on the client PC, so the version was variable and could be very old. This allows MET/CAL to use a known browser version, that is modern and meets the requirement of MET/TEAM regardless of the browser versions installed.
MCR-719 | CHANGE | Restored the ability to launch compiled procedures from MET/TEAM. However, launching compiled procedures via MET/TEAM is not recommended for numerous reasons, and should be avoided.
MCR-698 | CHANGE | Improved the error handling when MET/CAL writes calibration data after a fatal error. It will now display the message after writing the data to ensure the data is there when the message is shown.
MCR-761 | FIX | 8508 FSC Ohms Ratio Mode now sets "LOI ON" when a previously executed M8508 specifies "LOI".
MCR-759 | FIX | Removed incorrect instrument configuration note from the 4418 and 4419 FSC help topics. Instruments should be configured to match their real model numbers.
MCR-738 | FIX | Fixed an issue running a compiled procedure built from 7.3.
MCR-737 | FIX | Fixed an issue with the MESS FSC when running a compiled procedure built from 7.3.
MCR-736 | FIX | FSCs 5502A, 5502E, and 5522A. TC Source mode 10 µV/°C> and 1 mV/°C now programs the calibrator correctly. An execution error is no longer generated.
MCR-735 | FIX | Found an issue where the automated build would load all the projects in its parent solution. This has been fixed so only the appropriate project is loaded.
MCR-731 | FIX | Found an issue with the compiled procedure selector where the cache was not being properly populated with the procedure header data with procedures built and published in the 8.2 editor. This is caused by the long line length changes in the compiled procedure format. This has been resolved, but the procedure cache must be rebuilt to see the correct values. Navigate to your proc.dir>, and delete the procedures.cache file that is in the directory with it. In the procedure selector check "Validate procedures on load" to rebuild the cache. You should now see the correct header data in the procedure selector.
MCR-730 | FIX | The legacy long line length warning has been changed to not warn on single line compile (hitting ENTER on the statement) but will still display on a full compile.
MCR-726 | FIX | Found an issue where the PIC FSC window was respecting the DPI settings of images when they are displayed. This causes images with high DPI settings to display smaller than the raw pixel value. This has been fixed so the DPI settings of the image are ignored, and the image is displayed according the raw pixel value instead of being appropriately scaled via the DPI settings in the image.
MCR-725 | FIX | Found an issue where messages in operator prompts do not respect the newline characters embedded in them by using line continuations. The text was wrapping based on the entire concatenated message, and not the individual components of the message. The messages in operator prompts now take the embedded newlines into account when determining message wrapping.
MCR-723 | FIX | Fixed an issue with pass/fail determination on the work order result, where failed points were repeated and passed the second time, and therefore should not fail the work order result.
MCR-721 | FIX | Found a GIGO issue where having values with embedded line feeds in the runtime prompts will cause MET/CAL to crash. This issue has been resolved, any values with line feeds will have the line feed characters replaced with spaces before adding the value to the variable cache.
MCR-713 | FIX | The 5502E FSC now allows the parameter TemperatureStandard> in RTD Source Mode.
MCR-712 | FIX | The 5502A FSC now allows the parameter TemperatureStandard> in RTD Source Mode.
MCR-711 | FIX | The 5522A FSC now allows the parameter TemperatureStandard> in RTD Source Mode.
MCR-706 | FIX | Fixed multiple long line length display issue in OPBR.
MCR-705 | FIX | 5320 FSC now sends the correct remote command for Mode = GBR; Open.
MCR-683 | FIX | The O_CAL FSC now works with the 5502A Oscilloscope Calibration Options.
MCR-678 | FIX | Fixed an issue with the MATH FSC when running a compiled procedure built from 7.3.
MCR-677 | FIX | Found an issue where selecting break while running a subprocedure would cause MET/CAL to crash at the end of the calibration. This has been resolved, and Break now works properly in subprocedures.
MCR-771 | FIX | Fixed an issue where characters reserved for URLs would break the pre and post prompt screens when running MET/CAL with MET/TEAM. These characters are now encoded by MET/CAL and decoded by MET/TEAM so they can be used in text fields in the prompt screens.
MCR-767 | FIX | Found an issue that was limiting the size of the content of a named variable. The size limit has been restored to previous limits.

MET/CAL Editor

Issue | Type | Description
MCE-285 | ADDED | The 5522A FSC now accepts TemperatureScale or TemperatureStandard.
MCE-284 | ADDED | The 5502A and 5502E FSCs now accept TemperatureScale or TemperatureStandard.
MCE-318 | CHANGE | MATH FSC help topic now includes information about which file I/O functions will attempt to create the file where it does not already exist.
MCE-315 | CHANGE | The 52120A 1 year accuracy file now contains "Mode: Hertz" to support 52120A statements with Frequency as the evaluation quantity. Note, the entries are NA since the driving calibrator establishes the frequency accuracy for the test.
MCE-314 | CHANGE | The 52120A FSC now allows Frequency as the evaluation quantity. When +Frequency is specified in a 52120A statement the reference accuracy is unspecified (NA in accuracy file). A subsequent FSC for the "driving" calibrator must be used to establish the frequency accuracy for the test.
MCE-297 | CHANGE | Documented command line syntax for using correct.exe.
MCE-280 | CHANGE | Added documentation for Device Mapping.
MCE-278 | CHANGE | Documented support for adding instrument configuration file (config.dat) to a project.
MCE-321 | FIX | 'M' is no longer automatically converted to 'm" when units of "MZ/Z" are entered in the 8508 FSC Nominal field.
MCE-317 | FIX | Resume debugging now clears the MATH REFACC() function static data.
MCE-316 | FIX | Changed the default behavior for File > Save <procedure> As... to support making a basic copy of a file at the specified path, without affecting the original file or the open project's pointer to the original file.
MCE-307 | FIX | The 5080A FSC now correctly computes power factor accuracy.
MCE-306 | FIX | MATH FSC help topic: added table of content links for ACCFGP, ACCFGP2, ACCVGP, and ACCVGP2 functions. Fixed DBTOPCTV_D example's return value. Fixed formatting of the STRIPL and STRIPT entries for better readability.
MCE-304 | FIX | The 5522A FSC now correctly computes power factor accuracy.
MCE-303 | FIX | The 5502A FSC now correctly computes power factor accuracy.
MCE-302 | FIX | The 5522A FSC now accepts Power specified in negative VAR.
MCE-301 | FIX | Updated the 9500 FSC help topic examples and formatting.
MCE-300 FIX

The 5502A FSC now allows Power in negative VAR.

Example:

  26.001 5502A Coil = 5500A/COIL; NonToroidalUUT
  26.001 5502A CurrentTerminal = Aux; InductanceComp = On
  26.001 5502A Voltage = 21.9595 V; Current = 100 A; Phase = -73 deg
  26.001 5502A +Power = -2100 VAR; Frequency = 50 Hz
MCE-298 | FIX | The MET/CAL Editor installer deletes the user profile settings from the previous version when performing an upgrade to prevent startup failures.
MCE-295 | FIX | 6100, 6100B, & 6105A FSC now allow <phase><leg>FlickerDepth up to and including 60 %.
MCE-294 | FIX | Prevented the 6100B and 6105A FSCs from compiling with the OutputRampMode parameter.
MCE-291 | FIX | Found an issue where special characters are not properly converted to UTF8 when updating an existing variable. This has been resolved and updating variables works properly.
MCE-288 | FIX | Removed all references to F7 (Learn Mode) from MET/CAL Editor documentation.
MCE-283 | FIX | The 5522A FSC now supports TemperatureScale.
MCE-282 | FIX | The 5502E FSC now supports TemperatureScale.
MCE-281 | FIX | The 5502A FSC now supports TemperatureScale.
MCE-279 | FIX | Support for the MCZ package format has been removed from the MET/CAL Editor as it has been obsoleted by text based procedure source and PXE procedure packages.
MCE-263 | FIX | Addressed an issue where starting Test Run in Editor right after closing MET/CAL Runtime may lead to a memory access violation shutting down the Editor.
MCE-321 | FIX | 'M' is no longer automatically converted to 'm" when units of "MZ/Z" are entered in the 8508 FSC Nominal field.
MCE-296 | CHANGE | Added an error message to indicate why a project failed to build when a file in the project does not exist in the location the project points to.


Read Me MET/CAL 8.2.2

This section includes a list of modifications to MET/CAL 8.2.2 relative to MET/CAL 8.2.1. This version of MET/CAL is compatible with both MET/TEAM and MET/TRACK. Some of the new features and changes listed below are either not supported by MET/TRACK or they are supported in a limited capacity.

What's new in version 8.2.2?

MET/CAL Changes

Issue | Type | Description
MCR-730 | FIX | The legacy long line length warning has been changed to not warn on single line compile (hitting enter on the statement) but will still display on a full compile.
MCR-726 | FIX | Found an "issue" where the PIC FSC window was respecting the DPI settings of images when they are displayed. This causes images with high DPI settings to display smaller than the raw pixel value. This has been "fixed" so the DPI settings of the image are ignored, and the image is displayed according the raw pixel value instead of being appropriately scaled via the DPI settings in the image.
MCR-721 | FIX | Found a GIGO issue where having values with embedded line feeds in the runtime prompts will cause MET/CAL to crash. This issue has been resolved, any values with line feeds will have the line feed characters replaced with spaces before adding the value to the variable cache.
MCE-295 | FIX | 6100, 6100B, & 6105A FSC now allow <phase><leg>FlickerDepth up to and including 60 %.


Read Me MET/CAL 8.2.1

This section includes a list of modifications to MET/CAL 8.2.1 relative to MET/CAL 8.2.0. This version of MET/CAL is compatible with both MET/TEAM and MET/TRACK. Some of the new features and changes listed below are either not supported by MET/TRACK or they are supported in a limited capacity.

What's new in version 8.2.1?

  • Support for launching a compiled procedure from MET/TEAM.
  • Updated Installation Notes document which supersedes the Installation Guide.
  • Miscellaneous bug fixes.

MET/CAL Changes

Issue | Type | Description
MCR-723 | FIX | Fixed an issue with pass/fail determination on the work order result, where failed points were repeated and passed the second time, and therefore should not fail the work order result.
MCR-291 | FIX | Found an issue where special characters are not properly converted to UTF8 when updating an existing variable. This has been resolved and updating variables works properly.
MCR-719 | CHANGE | Restored the ability to launch compiled procedures from MET/TEAM. Launching compiled procedures via MET/TEAM is not recommended for numerous reasons, and should be avoided.
MCR-658 | CHANGE | Installation Notes document updated to reflect current installation process for version 8.2.


Read Me MET/CAL 8.2.0

This section includes a list of modifications to MET/CAL 8.2.0 relative to MET/CAL 8.1.9. This version of MET/CAL is compatible with both MET/TEAM and MET/TRACK. Some of the new features and changes listed below are either not supported by MET/TRACK or they are supported in a limited capacity.

What's new in version 8.2.0?

  • MET/CAL with MET/TEAM now officially supports Windows 8 (both 32-bit and 64-bit) and Windows Server 2012. Due to a Sybase limitation, MET/CAL with MET/BASE does not officially work with Windows 8.1 or Windows Server 2012.
  • Procedure Sectioning support allows a procedure to be sectioned so the user can decide which sections to run at runtime.
  • Support for up to 256 characters on a procedure line.
  • FSC for the Fluke 5730A calibrator.
  • Automated build feature in MET/CAL Editor builds all projects in a given directory tree.
  • MCZ file installation has been removed from the MET/CAL installation and a stand-alone installer has been created.

Key Changes

  • New Procedure Sectioning feature to support user defined sections and selection within a procedure.
  • The compiled procedure format has changed to support long line lengths
    • Procedures created in all prior versions of MET/CAL remain compatible with 8.2.
    • Compiled procedures created in 8.2 are not compatible with prior versions of MET/CAL.
      • PXE procedure packages created in 8.2 will still run in older versions, as long as the PXE does not make use of 8.2 or newer features.
      • ZIP procedure project packages created in 8.2 can still be opened in 8.0 and 8.1, but may fail to compile and require edits if the project uses 8.2 or newer features.
    • Many FSCs now support up to 256 characters on one line.
    • Legacy instrument FSCs and the procedure header are not affected and must still conform to line length rules.
    • Text in all message-related FSCs will automatically wrap in the message box.
  • The MET/CAL Editor has been upgraded to use the Microsoft Visual Studio 2012 Shell (Isolated), providing several upgrades and new features for the Editor:
    • Quick Launch - quickly and easily find and use Editor features
    • Find and Replace - new functionality with minimalist design
    • Solution Explorer (SE) enhancements:
      • Search within the SE
      • Browser-like movement and navigation
      • Preview Tab to allow quick inspection of file contents
      • Multiple SE instances and scoping of items to the SE
      • Collapse All button to collapse the view of all projects within the solution
    • Improved status reporting for lengthy operations (e.g. loading large solutions)
    • Reload All button when projects are edited outside of the Editor

MET/CAL Changes

Issue | Type | Description
MCR-606 | ADD | MET/TEAM prompt file mechanism now contains the ability to cause a field to be blank instead of displaying the previously saved value. This is done in the same method as the MET/BASE prompt screens, by putting the blank flag ":B:" at the end of the line for the appropriate entry in the prompt file.
MCR-501 | ADD | 1 year accuracy file for the Agilent 34411A DMM.
MCR-498 | ADD | 1 year accuracy file for the Agilent 34410A DMM.
MCR-384 | ADD | Added 5730A NVI FSC for the 5730A Multifunction Calibrator.
MCR-99 | ADD | Created installer for MCZ Installer application that can be downloaded from MET/SUPPORT Gold web site.
MCR-59 | ADD | Support redefine LIB array object.
MCR-58 | ADD | Added a setting to the metcal.ini file (tag_ui_show) that dictates whether or not to display the section selection dialog when running a sectioned procedure.
MCR-29 | ADD | Support for creating and running sectioned procedures has been added to MET/CAL Editor.
MCR-7 | ADD | Implemented procedure sectioning support.
MCE-285 | ADD | 5522A FSC now accepts TemperatureScale or TemperatureStandard.
MCE-284 | ADD | 5502A and 5502E FSCs now accept TemperatureScale or TemperatureStandard.
MCE-2 | ADD | New automated build feature has been added to the MET/CAL Editor. This feature will allow you do pick an input directory and build all MET/CAL projects (.mcproj) in the initial directory and all subdirectories. All builds are then output to a flat structure of the users choosing. See the help file for more info.
MCR-664 | CHANGE | Only procedures of type Calibration or Cal/Repair are influencing the work order overall pass/fail status.
MCR-662 | CHANGE | Changed wording on error message generated when FSC line exceeds maximum length allowable to be more clear.
MCR-656 | CHANGE | Long line length support for MEMI, OPBR, MESS, RSLT FSCs.
MCR-503 | CHANGE | Added flexible driver support for "Fluke 9640A-LPNX" to user_config_instr.ini.
MCR-493 | CHANGE | Support long length procedure statement.

MCR-475

 CHANGE Pass/Fail status now determined and stored on a per-work order result level.
MCR-470 | CHANGE | Editor debugging and Run Time properly "Device Map" procedures that require the 600 MHz Oscilloscope Calibration Option (-SC600) to 5520A and 5522A Calibrators with the 1.1 GHz Oscilloscope Calibration Option (-SC1100) installed.
MCR-444 | CHANGE | Visual C runtimes used by MET/CAL have been updated to the latest version. This has changed the install requirements to require Windows 7 or later, and Windows Installer 4.5.
MCR-365

CHANGE

 MET/CAL has been changed to use the cBarcode field instead of cID to retrieve asset information from a given asset number. This resolves a number of issues for users that use different values for cBarcode and cID.
MCR-343

CHANGE

 Post-test dialog is no longer modal in the editor, allowing the user to interact with the editor when the dialog is displayed
MCR-301

CHANGE

 52120A FSC statement containing "Coil = <coil model>, now causes CONFIGURATION: Fluke <coil model> to be inserted in the procedure header when the procedure is compiled.
MCR-198 | CHANGE | Support long string length in EVAL dialog.
MCR-196 | CHANGE | Support DISP with long strings that generated from MATH variables.
MCR-150 | CHANGE | Allow LIB variable names that hold COM objects to be reused.
MCR-139 | CHANGE | Procedures written using the 5720/M5720 FSCs execute without modification with a 5730A configured and connected.
MCR-114 | CHANGE | LIB FSC array variables can now be reused.
MCR-100 | CHANGE | Support for installing .MCZ files has been removed from the MET/CAL installer.
MCE-252 | CHANGE | Improved build time error reporting. Any compile time errors or warnings generated during a project build are put in the "Build" output window as well as the "MET/CAL" output window.
MCE-247 | CHANGE | Procedure AUTHOR field gets populated with the full name instead of the user name of the logged in user.
MCE-244 | CHANGE | Resolved issue where custom menu and toolbar items appeared using programmatic names instead of "friendly" names in Customize dialog.
MCE-168 | CHANGE | MET/CAL Editor installer has been updated to distribute the Microsoft Visual Studio 2012 Shell (Isolated) and Microsoft Visual Studio 2012 Update 3. The Microsoft Visual Studio 2010 Shell (Isolated) and other related prerequisites have been removed from the installer.
MCE-15 | CHANGE | MET/CAL Editor has been upgraded to use the Microsoft Visual Studio 2012 Shell (Isolated).
MCR-713 | FIX | 5502E FSC now allows the parameter TemperatureStandard in RTD Source Mode.
MCR-712 | FIX | 5502A FSC now allows the parameter TemperatureStandard in RTD Source Mode.
MCR-705 | FIX | 5320 FSC now sends the correct remote command for Mode = GBR; Open.
MCR-698 | FIX | Improved the error handling when MET/CAL writes calibration data after a fatal error. It will now display the message after writing the data to ensure the data is there when the message is shown.
MCR-683 | FIX | The O_CAL FSC now works with the 5502A Oscilloscope Calibration Options.
MCR-677 | FIX | Resolved an issue where selecting break while running a subprocedure would cause MET/CAL to crash at the end of the calibration.
MCR-673 | FIX | Resolved an issue causing long write times to a MET/TEAM back end. The Units table was not being cached, causing it to be repeatedly queried while writing results. This has been resolved.
MCR-670 | FIX | Updated confidence to 2 sigma in the accuracy files for the Fluke 6100A, 6100B, and 6105A.
MCR-668 | FIX | Addressed an issue where converting a PKM to a project in the MET/CAL Editor may present an empty procedure selection dialog.
MCR-659 | FIX | Resolved an issue with running long procedures in MET/CAL that would cause graphical glitches and windows disappearing or not displaying. This issue has been traced to the way the test results window was drawing, and not releasing resources on procedures with a large amount of results. This window now properly handles graphical resources properly, and will not cause graphical issues on procedures that generate a large amount of result rows.
MCR-629 | FIX | Resolved an issue where a MET/CAL procedure launched from MET/TEAM will not use the Procedure Name from MET/TEAM, instead using the instrument line from the main procedure as the Procedure Name in the Work Order results.
MCR-625 | FIX | Fixed an issue where images larger than the current screen size were not being resized to fit the PIC FSC window. This has been resolved so the image is scaled so that the entire image is visible on-screen. However you should still probably reformat that 20MB BMP.
MCR-607 | FIX | MATH FSC VERSIONCHECK() function will now only compare the first three sections of a version, ignoring the last section. For example, 8.2.0, 8.2.0.1 and 8.2.0.2 would all be seen as identical versions since only the first three numbers in the version string are compared.
MCR-547 | FIX | 9640 FSC statement that specifies ExternalReferenceFrequency will now "Device Map" to a "Fluke 9640A-LPNX" at run time.
MCR-545 | FIX | 5522A statement with Frequency or Period as the evaluation quantity and ReferenceClock = External, now uses the Frequency Reference accuracy as the system accuracy for the test.
MCR-544 | FIX | Instrument selected using "TOOLS=>Configure Frequency Reference..." is now included in the list of Standards Used when a 5522A FSC statement contains ReferenceClock = External.
MCR-543 | FIX | 5522A FSC statement with "ReferenceClock = External" now causes (XREF) to be included in the "CONFIGURATION: Fluke 5522A" line in procedure header.
MCR-531 | FIX | Addressed an issue where unit prefixes were not recognized correctly in the procedure language, when running on MET/TEAM
MCR-502 | FIX | Correct device options are now displayed in the "REQUIRED SYSTEMS INSTRUMENTS" prompt for procedures that use the O_CAL FSC.
MCR-483 | FIX | Resolved an issue writing special characters to the MET/TEAM back end when writing points. Values in points data is now properly encoded for sending via HTTP, and properly decoded on the MET/TEAM side.
MCR-470 | FIX | Editor debugging and Run Time properly "Device Map" procedures that require the 600 MHz Oscilloscope Calibration Option (-SC600) to 5520A and 5522A Calibrators with the 1.1 GHz Oscilloscope Calibration Option (-SC1100) installed.
MCR-455 | FIX | Fixed asset-specific acc files bug when running with MET/TEAM.
MCR-442 | FIX | Addressed an issue with unintended re-loading of procedure information by the procedure selector, when the MET/CAL Runtime was not closed between runs.
MCR-434 | FIX | Reference accuracy for a 5522A statement which specifies the 5500A/COIL and is "Device Mapped" to "Fluke 5520A" configured is now calculated correctly.
MCR-349 | FIX | Resolved an issue where MET/CAL could not display an empty string correctly in the DISP FSC.
MCR-301 | FIX | 52120A FSC statement containing "Coil = <coil model>, now causes CONFIGURATION: Fluke <coil model> to be inserted in the procedure header when the procedure is compiled.
MCR-300 | FIX | Resolved an issue where special characters in the test description field would cause invalid characters to be introduced into the string.
MCR-272 | FIX | Resolved an issue with the MATH FSC commands that pull data from a MET/TEAM database. If there were more than 25 calibration records for the asset, and a request for data was beyond these first 25 records, the Work Order ID could not be determined.
MCR-261 | FIX | Resolved an issue where decimal values were not displayed correctly via MET/TEAM on non-English operating systems. The values were persisted to the database correctly, however the resolution of the values were not stored correctly, causing the values to be displayed as whole numbers.
MCR-231 | FIX | Calibration can be completed even if MET/TEAM session was expired and re-launched.
MCR-201 | FIX | Fixed an issue where the decimal separator was being removed in systems where the culture settings use a comma separator on values stored as numeric values in the MET/TEAM database. These values now correctly store the decimal separator.
MCR-188 | FIX | Resolved an issue regarding the procedure translator stopping while translating a long procedure file.
MCR-183 FIX

Connectivity between MET/CAL and MET/TEAM has been made more robust. MET/CAL will now keep track of the connectivity to the MET/TEAM server, as well as the session state of the logged in user. If there is a network issue, the connection will not be restored until a connection is required. This will allow the procedure to run without user intervention until the time a connection is needed. The following improvements have been made:

  1. MET/CAL will detect if the MET/TEAM server is reachable before displaying the login screen, and display an appropriate error
  2. MET/CAL will not attempt to restore a lost connection until database connectivity is needed. This will allow a procedure to run until the point it needs a connection
  3. If the MET/TEAM server is not reachable, MET/CAL will inform the user and allow them to retry the connection, or cancel the calibration. If the calibration is canceled all cal data is lost
  4. If the MET/TEAM user session timed out due to a long period of disconnect, MET/CAL will inform the user and allow them to sign in again, or cancel the calibration. If the calibration is canceled all cal data is lost
MCR-82 | FIX | Fixed a problem with 'µ' character in BASE and ENGR.
MCR-78 | FIX | Fixed non-standard chars in Post Run Results window.
MCR-75 | FIX | Fixed a non-standard character problem in MATH FSCs.
MCR-74 | FIX | Fixed a display problem with extended-character in List Box dialog.
MCR-61 | FIX | Use PXE contained config file at compile time and the user station config file during run time.
MCE-283 | FIX | 5522A FSC now supports TemperatureScale.
MCE-282 | FIX | 5502E FSC now supports TemperatureScale.
MCE-281 | FIX | 5502A FSC now supports TemperatureScale.
MCE-279 | FIX | Support for the MCZ package format has been removed from the MET/CAL Editor as it has been obsoleted by text based procedure source and PXE procedure packages.
MCE-261 | FIX | Resolved an issue where doing a build of a project that does not have a document open would not perform the build with the instrument configuration attached to the project. Instead it would default to the project with a currently open document.
MCE-251 | FIX | Resolved inconsistent line endings warning message when creating a new procedure.
MCE-241 | FIX | Resolved an issue where an EVAL statement with a large number of tolerance fields would cash the editor. While this is not a valid state, this has been addressed to properly error instead of causing a crash.
MCE-37 | FIX | Resolved an issue with the file format produced by the procedure translator.
MCE-22 | FIX | Fixed a problem with "local named variable list".


Read Me MET/CAL 8.1.9

This section includes a list of modifications to MET/TEAM 1.0.8 and MET/CAL 8.1.9 relative to versions 1.0.7 and 8.1.7 respectively. MET/CAL 8.1.9 is an incremental update to MET/CAL 8.1 designed to function with both MET/TEAM and MET/BASE. Features are provided to use MET/TEAM or MET/TRACK as the asset manager. Refer to the new Storage parameter of the metcal.ini file for details on switching asset managers.

What’s new in MET/TEAM version 1.0.8?

  • MET/TEAM is not intended to be installed on "Home" editions of Windows®. Although the installer does not prevent it, installing MET/TEAM on a "Home" edition of Windows® may generate some installation errors and Technical Support will not attempt to resolve any issues that arise.
  • The MET/TEAM Server installer will perform new installations as well as prepare a system for an upgrade from versions 1.0.3 to 1.0.7. IMPORTANT: Be sure to read all of the information in the Upgrading from version 1.0.x section below before attempting to upgrade an existing installation!
  • The MET/TEAM Server installer includes a new prerequisite for SQL Server Native Client. This prerequisite is necessary to support custom reports.
  • Refer to the table below for a complete list of fixes in this release.

Upgrading from version 1.0.x

When upgrading an existing installation of MET/TEAM, make a note of what version you are upgrading from before beginning.

Upgrading MET/TEAM to version 1.0.8 automatically uninstalls the previous version and installs version 1.0.8, maintaining the database, licenses and all paths, ports, share names, and all other settings consistent with the previous installation. To upgrade, simply run the MET/TEAM Server v1.0.8 installer. If you manually uninstall the previous version before attempting to install this version, you will be required to request new licenses for your software!

Once the installation is complete, you must manually update the database using the database update scripts provided. These update scripts are typically located in the %ProgramFiles%\Fluke\METTEAM\METTEAM Database Scripts folder. Be sure to read the ReadMe file(s) included in this folder that are specific to the version of MET/TEAM you upgraded from. Those files contain specific instructions on how to successfully update your database. Note that if you have customized the MET/TEAM database in any way, you must contact Technical Support for assistance as running the update scripts provided may leave your database in an unusable state!

If you have installed MET/CAL Runtime and/or Editor on any workstations, be sure to run the MET/CAL Client installer on all MET/CAL workstations to update them to the latest version.

If you have installed Customer Portal on a separate server, be sure to run the Customer Portal installer on that server to upgrade the Customer Portal web site to version 1.0.8. The Customer Portal installer is found in the Installers folder on the MET/TEAM share (typically \\<servername>\metteam\Installers).

There has not been a change to the MET/TEAM Mobile Prerequisites installer in this release, so there is no need to reinstall that on mobile workstations. However, you must make sure all mobile workstations are checked in prior to upgrading MET/TEAM Server!

Running MET/TEAM

Once MET/TEAM is successfully installed, you may run MET/TEAM by double-clicking the shortcut created on the desktop and log in using the following built-in administrator account:

  • User name: admin
  • Password: admin

It is highly recommended that you change the password on this administrator user account immediately and create individual user accounts for all users of the system.

MET/TEAM Changes

Key | Issue Type | Description
MTM-3760 FIX

Found an issue where MET/CAL sessions were being incorrectly expired. When users log out of MET/TEAM, any MET/CAL sessions with creation times greater than the session timeout period set in IIS (default of 15 minutes) were seen as expired and cleaned up.

This was due to the MET/CAL ping back to the MET/TEAM server not correctly updating the session's last activity time. This has been resolved, and the session will now persist as long as MET/CAL is open, even if idle.
MTM-3757 | FIX | Fixed an issue where the number of assets when creating a new facility was more than 0.
MTM-3730 | FIX | Increased the timeout applied when viewing results on a work order to 15 minutes.
MTM-3711 | FIX | Fixed an issue where the system default setting Receiving – Allow Multiple Work Orders was not working.
MTM-3638 | FIX | Fixed a problem with receiving and work order screens if the Category and Sub Category fields are not visible.
MTM-3620 | FIX | Addressed an issue where a truncation error was encountered when attempting to import available combo data that exceeded 50 in length. The data is now truncated at 50 on export.
MTM-3618 | FIX | Fixed an issue where exporting service type PM records may be caught in a infinite loop, trying to export the same record over and over again. Fixed an issue where migration may stop with an error that cLaborAccount data would be truncated.
MTM-3599 | CHANGE | MET/CAL will now perform a version check to determine if the MET/TEAM API is a version that MET/CAL can connect to. If MET/TEAM is a version not supported by MET/CAL, and error will be displayed.
MTM-3513 | FIX | Fixed an issue with rt_report_of_cal_ver_8.rpt, where work order notes may be truncated to less than 254 characters.
MTM-3504 | FIX | Fixed an issue with the MET/CAL communication layer where files were unable to be uploaded to MET/TEAM under certain circumstances.
MTM-3459 | FIX | Removed \Reports folder from MET/CAL shared files directory. These reports are not useable with MET/TEAM.
MTM-2852 | FIX | Some flag indicators defaulted to NULL when not specified in the import. These now default to 0.
MTM-2667 | CHANGE | Column label changed to "Cost" from "Dollars".
MTM-1491 | CHANGE | System defaults for reporting paths are set as active by default.

MET/CAL Changes

Key | Issue Type | Release Note
MCR-606 | FIX | The MET/TEAM prompt file mechanism now contains the ability to cause a field to be blank instead of displaying the previously saved value. This is done in the same method as the MET/BASE prompt screens, by putting the blank flag ":B:" at the end of the line for the appropriate entry in the prompt file.


Read Me MET/CAL 8.1.7

This section includes a list of modifications to MET/TEAM 1.0.7 and MET/CAL 8.1.7 relative to versions 1.0.6 and 8.1.6 respectively. MET/CAL 8.1.7 is an incremental update to MET/CAL 8.1 designed to function with both MET/TEAM and MET/BASE. Features are provided to use MET/TEAM or MET/TRACK as the asset manager. Refer to the new Storage parameter of the metcal.ini file for details on switching asset managers.

What’s new in MET/TEAM version 1.0.7?

  • MET/TEAM is not intended to be installed on "Home" editions of Windows®. Although the installer does not prevent it, installing MET/TEAM on a "Home" edition of Windows® may generate some installation errors and Technical Support will not attempt to resolve any issues that arise.
  • The MET/TEAM Server installer will perform new installations as well as prepare a system for an upgrade from versions 1.0.3 to 1.0.6. IMPORTANT: Be sure to read all of the information in the Upgrading from version 1.0.x section below before attempting to upgrade an existing installation!
  • The MET/TEAM Server installer includes a new prerequisite for SQL Server Native Client. This prerequisite is necessary to support custom reports.

Upgrading from version 1.0.x

When upgrading an existing installation of MET/TEAM, make a note of what version you are upgrading from before beginning.

Upgrading MET/TEAM to version 1.0.7 automatically uninstalls the previous version and installs version 1.0.7, maintaining the database, licenses and all paths, ports, share names, and all other settings consistent with the previous installation. To upgrade, simply run the MET/TEAM Server v1.0.7 installer. If you manually uninstall the previous version before attempting to install this version, you will be required to request new licenses for your software!

Once the installation is complete, you must manually update the database using the database update scripts provided. These update scripts are typically located in the %ProgramFiles%\Fluke\METTEAM Database Scripts folder. Be sure to read the ReadMe file(s) included in this folder that are specific to the version of MET/TEAM you upgraded from. Those files contain specific instructions on how to successfully update your database. Note that if you have customized the MET/TEAM database in any way, you must contact Technical Support for assistance as running the update scripts provided may leave your database in an unusable state!

If you have installed MET/CAL Runtime and/or Editor on any workstations, be sure to run the MET/CAL Client installer on all MET/CAL workstations to update them to the latest version.

If you have installed Customer Portal on a separate server, be sure to run the Customer Portal installer on that server to upgrade the Customer Portal web site to version 1.0.7. The Customer Portal installer is found in the Installers folder on the MET/TEAM share (typically \\<servername>\metteam\Installers).

There has not been a change to the MET/TEAM Mobile Prerequisites installer in this release, so there is no need to reinstall that on mobile workstations. However, you must make sure all mobile workstations are checked in prior to upgrading MET/TEAM Server!

Running MET/TEAM

Once MET/TEAM is successfully installed, you may run MET/TEAM by double-clicking the shortcut created on the desktop and log in using the following built-in administrator account:

  • User name: admin
  • Password: admin

It is highly recommended that you change the password on this administrator user account immediately and create individual user accounts for all users of the system.

MET/TEAM Changes

Key | Issue Type | Description
MTM-3363 | CHANGE | Greatly improved error logging capabilities all throughout the application.
MTM-3353 | FIX | Fixed a bug with receiving when it is used by more than one person at a time.
MTM-3146 | FIX | Addressed an issue with the job number lookup control not always working during receiving.

MET/CAL Changes

Key | Issue Type | Description
MCR-483 | FIX | Found an issue writing special characters to the MET/TEAM back end when writing points. Values in points data is now properly encoded for sending via HTTP, and properly decoded on the MET/TEAM side.
MCR-470 | FIX | Editor debugging and Run Time properly "Device Map" procedures that require the 600 MHz Oscilloscope Calibration Option (-SC600) to 5520A and 5522A Calibrators with the 1.1 GHz Oscilloscope Calibration Option (-SC1100) installed.


Read Me MET/CAL 8.1.6

This section includes a list of modifications to MET/TEAM 1.0.6 and MET/CAL 8.1.6 relative to versions 1.0.5 and 8.1.5 respectively. MET/CAL 8.1.6 is an incremental update to MET/CAL 8.1 designed to function with both MET/TEAM and MET/BASE. Features are provided to use MET/TEAM or MET/TRACK as the asset manager. Refer to the new Storage parameter of the metcal.ini file for details on switching asset managers.

What’s new in MET/TEAM version 1.0.6?

  • MET/TEAM is not intended to be installed on "Home" editions of Windows®. Although the installer does not prevent it, installing MET/TEAM on a "Home" edition of Windows® may generate some installation errors and Technical Support will not attempt to resolve any issues that arise.
  • The MET/TEAM Server installer will perform new installations as well as prepare a system for an upgrade from versions 1.0.3 to 1.0.5. IMPORTANT: Be sure to read all of the information in the Upgrading from version 1.0.x section below before attempting to upgrade an existing installation!
  • The MET/TEAM Server installer includes a new prerequisite for SQL Server Native Client. This prerequisite is necessary to support custom reports.

Upgrading from version 1.0.x

When upgrading an existing installation of MET/TEAM, make a note of what version you are upgrading from before beginning.

Upgrading MET/TEAM to version 1.0.6 automatically uninstalls the previous version and installs version 1.0.6, maintaining the database, licenses and all paths, ports, share names, and all other settings consistent with the previous installation. To upgrade, simply run the MET/TEAM Server v1.0.6 installer. If you manually uninstall the previous version before attempting to install this version, you will be required to request new licenses for your software!

Once the installation is complete, you must manually update the database using the database update scripts provided. These update scripts are typically located in the %ProgramFiles%\Fluke\METTEAM Database Scripts folder. Be sure to read the ReadMe file(s) included in this folder that are specific to the version of MET/TEAM you upgraded from. Those files contain specific instructions on how to successfully update your database. Note that if you have customized the MET/TEAM database in any way, you must contact Technical Support for assistance as running the update scripts provided may leave your database in an unusable state!

If you have installed MET/CAL Runtime and/or Editor on any workstations, be sure to run the MET/CAL Client installer on all MET/CAL workstations to update them to the latest version.

If you have installed Customer Portal on a separate server, be sure to run the Customer Portal installer on that server to upgrade the Customer Portal web site to version 1.0.6. The Customer Portal installer is found in the Installers folder on the MET/TEAM share (typically \\<servername>\metteam\Installers).

There has not been a change to the MET/TEAM Mobile Prerequisites installer in this release, so there is no need to reinstall that on mobile workstations. However, you must make sure all mobile workstations are checked in prior to upgrading MET/TEAM Server!

Running MET/TEAM

Once MET/TEAM is successfully installed, you may run MET/TEAM by double-clicking the shortcut created on the desktop and log in using the following built-in administrator account:

  • User name: admin
  • Password: admin

It is highly recommended that you change the password on this administrator user account immediately and create individual user accounts for all users of the system.

MET/TEAM Changes

Key | Issue Type | Description
MTM-3251 | FIX | Resolved a memory leak related to the usage of Crystal Reports.
MTM-3248 | FIX | Fixed a variety of bugs with the Alerting Engine when using parameter-based reports.
MTM-3238 | FIX | Fixed an issue with file type associations of migrated MET/BASE memo field data for repair and location records.
MTM-3232 | FIX | "Latest" option is chosen on the export side (DataMigration.exe).
MTM-3225 | FIX | Changed the alerting "add contact" find screen to allow multiple selections at one time.
MTM-3169 | FIX | Resolved an issue with the Email Alert Schedule system to allow more contacts to be associated.
MTM-3168 | FIX | Resolved an issue with the Alerting Engine to better address dynamic reporting scenarios.
MTM-3146 | FIX | Addressed an issue with the job number lookup control not always working during receiving.
MTM-3144 | FIX | Addressed a bug with MET/TEAM Mobile where it failed installation when a shortcut couldn't be created.

MET/CAL Changes

Key | Issue Type | Release Note
MCR-455 | FIX | Fixed issue related to using asset-specific accuracy files.
MCR-442 | FIX | Addressed an issue with unintended re-loading of procedure information by the procedure selector, when the MET/CAL Runtime was not closed between runs.
MCR-434 | FIX | Reference accuracy for a 5522A statement which specifies the 5500A/COIL and is "Device Mapped" to "Fluke 5520A" configured is now calculated correctly.


Read Me MET/CAL 8.1.5

This section includes a list of modifications to MET/TEAM 1.0.5 and MET/CAL 8.1.5 relative to versions 1.0.4 and 8.1.4 respectively. MET/CAL 8.1.5 is an incremental update to MET/CAL 8.1 designed to function with both MET/TEAM and MET/BASE. Features are provided to use MET/TEAM or MET/TRACK as the asset manager. Refer to the new Storage parameter of the metcal.ini file for details on switching asset managers.

What’s new in MET/TEAM version 1.0.5?

  • MET/TEAM is not intended to be installed on "Home" editions of Windows®. Although the installer does not prevent it, installing MET/TEAM on a "Home" edition of Windows® may generate some installation errors and Technical Support will not attempt to resolve any issues that arise.
  • The MET/TEAM Server installer will perform new installations as well as prepare a system for an upgrade from version 1.0.3 or 1.0.4. IMPORTANT: Be sure to read all of the information in the Upgrading from version 1.0.x section below before attempting to upgrade an existing installation!
  • The MET/TEAM Server installer includes a new prerequisite for SQL Server Native Client. This prerequisite is necessary to support custom reports.

Upgrading from version 1.0.x

When upgrading an existing installation of MET/TEAM, make a note of what version you are upgrading from before beginning.

Upgrading MET/TEAM to version 1.0.5 automatically uninstalls the previous version and installs version 1.0.5, maintaining the database, licenses and all paths, ports, share names, and all other settings consistent with the previous installation. To upgrade, simply run the MET/TEAM Server v1.0.5 installer. If you manually uninstall the previous version before attempting to install this version, you will be required to request new licenses for your software!

Once the installation is complete, you must manually update the database using the database update scripts provided. These update scripts are typically located in the %ProgramFiles%\Fluke\METTEAM Database Scripts folder. Be sure to read the ReadMe file(s) included in this folder that are specific to the version of MET/TEAM you upgraded from. Those files contain specific instructions on how to successfully update your database. Note that if you have customized the MET/TEAM database in any way, you must contact Technical Support for assistance as running the update scripts provided may leave your database in an unusable state!

If you have installed MET/CAL Runtime and/or Editor on any workstations, be sure to run the MET/CAL Client installer on all MET/CAL workstations to update them to the latest version.

If you have installed Customer Portal on a separate server, be sure to run the Customer Portal installer on that server to upgrade the Customer Portal web site to version 1.0.5. The Customer Portal installer is found in the Installers folder on the MET/TEAM share (typically \\<servername>\metteam\Installers).

There has not been a change to the MET/TEAM Mobile Prerequisites installer in this release, so there is no need to reinstall that on mobile workstations. However, you must make sure all mobile workstations are checked in prior to upgrading MET/TEAM Server!

Running MET/TEAM

Once MET/TEAM is successfully installed, you may run MET/TEAM by double-clicking the shortcut created on the desktop and log in using the following built-in administrator account:

  • User name: admin
  • Password: admin

It is highly recommended that you change the password on this administrator user account immediately and create individual user accounts for all users of the system.

MET/TEAM 1.0.5 Changes

Key | Issue Type | Description
MTM-2921 | CHANGE | Added a print button to the 'History Log' screen.
MTM-2910 | CHANGE | Removed paging from Tech Assignment grids.
MTM-2906 | CHANGE | Location field L2801 is now migrated to Contacts.cEmail2, the Contact ID.
MTM-2905 | CHANGE | CHANGE Unique identifier field for contacts is now cEmail2 field, relabled to 'Contact ID'. The field must be filled in for every contact and carry a unique value, to distinguish one contact from another.
MTM-2883 | CHANGE | Enhanced the auditing system so it would properly filter the history logs. Added a new window button for viewing the audit history of a given page.
MTM-2846 | CHANGE | Incorporated Data-Checks into the Tool Assignment page.
MTM-2764 | CHANGE | Added additional facility-based filtering options to the Recall Screen.
MTM-2654 | CHANGE | When importing contacts, the records are now based off of the unique Contact ID value specified in the cEmail2 column. If a contact with that ID is found, it is referenced, otherwise a new contact will be added. This resolves an issue with importing multiple contacts with the same name.
MTM-2996 | FIX | Resolved an issue preventing asset creation when the barcode already exists in the database.
MTM-2993 | FIX | Fixed an issue with the MET/CAL Results Viewer when using a non-English browser.
MTM-2992 | FIX | Fixed an issue with Priority on My Work screen not being displayed.
MTM-2991 | FIX | QC Approved By button on work order now protected by password prompt.
MTM-2893 | FIX | Resolved issue that prevented custom reports from being generated when SQL Server is not installed on the MET/TEAM Server machine by adding the SQL Server Native Client prerequisite to the installation.
MTM-2875 | FIX | Printing on Recall screen disabled when grid is empty.
MTM-2858 | FIX | Drafted a default data check for the Tool Assignment screen which verifies that assets will still be in-calibration when returned.
MTM-2823 | FIX | Made the CSV delimiter a 'semi-colon' for outputted excel files.
MTM-2820 | FIX | Added an 'active' check-box to the procedures screen.
MTM-2819 | FIX | Fixed a Crystal Report issue with the Alerting Engine.
MTM-2817 | FIX | Fixed an issue with adding an asset from MET/CAL Runtime running on MET/TEAM, where the type selection would yield ## ERROR ## for the description.
MTM-2808 | FIX | Resolved an issue with a missing library file that prevented Crystal Reports from working.
MTM-2803 | FIX | Fixed a bug with the on-site flag not defaulting properly on receiving.
MTM-2801 | FIX | Updated numeric input fields for non-US inputs.
MTM-2800 | FIX | Unexpected error does not occur when attempting to add a Category with invisible SubCategory.
MTM-2798 | FIX | Fixed an issue in import, where the manager reference linked to users rather than contacts.
MTM-2797 | FIX | Fixed a bug with the Extended Data currency field.
MTM-2779 | FIX | Addressed an issue with importing extended asset data.
MTM-2763 | FIX | Reports -> Recall screen code modified to include Start and End date.
MTM-2659 | FIX | Fixed an issue with Due Date calculations when running MET/TEAM from a non-US operating system.
MTM-2640 | FIX | Fixed a time scheduling bug with the Alerting Engine.
MTM-2311 | FIX | In Recall Escalation if Email Group selected is "All", it will trigger emails to all groups like "Monthly".
MTM-2298 | FIX | Comma is allowed as decimal separator in Hourly Rate field.

MET/CAL Changes

Key | Issue Type | Release Note
MCR-343 | CHANGE | The post-test dialog is no longer modal in the editor, allowing the user to interact with the editor when the dialog is displayed.
MCR-183 CHANGE

The connectivity between MET/CAL and MET/TEAM has been made more robust. MET/CAL will now keep track of the connectivity to the MET/TEAM server, as well as the session state of the logged in user. If there is a network issue, the connection will not be restored until a connection is required. This will allow the procedure to run without user intervention until the time a connection is needed. The following improvements have been made:

  1. MET/CAL will detect if the MET/TEAM server is reachable before displaying the login screen, and display an appropriate error
  2. MET/CAL will not attempt to restore a lost connection until database connectivity is needed. This will allow a procedure to run until the point it needs a connection
  3. If the MET/TEAM server is not reachable, MET/CAL will inform the user and allow them to retry the connection, or cancel the calibration. If the calibration is canceled all cal data is lost
  4. If the MET/TEAM user session timed out due to a long period of disconnect, MET/CAL will inform the user and allow them to sign in again, or cancel the calibration. If the calibration is canceled all cal data is lost
MCR-349 | FIX | Found an issue where MET/CAL could not display an empty string correctly in the DISP FSC. This has been resolved and empty strings will be displayed correctly.
MCR-300 | FIX | Found an issue where special characters in the test description field would cause invalid characters to be introduced into the string. this has been fixed and special characters in the test description field will no longer generate invalid characters.
MCR-272 | FIX | Found an issue with the MATH FSC commands that pull data from a MET/TEAM database. If there were more than 25 calibration records for the asset, and a request for data was beyond these first 25 records, the Work Order ID could not be determined. This has been resolved so the proper data can be returned with these commands.
MCR-261 | FIX | Found an issue where decimal values were not displayed correctly via MET/TEAM on non-English operating systems. The values were persisted to the database correctly, however the resolution of the values were not stored correctly, causing the values to be displayed as whole numbers. This has been fixed and decimal values now display correctly.
MCR-201 | FIX | Fixed an issue where the decimal separator was being removed in systems where the culture settings use a comma separator on values stored as numeric values in the MET/TEAM database. These values now correctly store the decimal separator.
MCR-82 | FIX | Fixed an issue related to displaying the 'µ' character using BASE and ENGR.
MCR-78 | FIX | Fixed non-standard chars in Post Run Results window.
MCR-75 | FIX | Fixed a non-standard character problem in MATH FSCs.
MCR-74 | FIX | Fixed an issue related to displaying extended characters in the List Box dialog.


Read Me MET/CAL 8.1.4

This section includes a list of modifications to MET/TEAM 1.0.4 and MET/CAL 8.1.4 relative to versions 1.0.3 and 8.1.3 respectively. MET/CAL 8.1.4 is an incremental update to MET/CAL 8.1 designed to function with both MET/TEAM and MET/BASE. Features are provided to use MET/TEAM or MET/TRACK as the asset manager. Refer to the new Storage parameter of the metcal.ini file for details on switching asset managers.

What’s new in MET/TEAM version 1.0.4?

  • MET/TEAM is not intended to be installed on "Home" editions of Windows®. Although the installer does not prevent it, installing MET/TEAM on a "Home" edition of Windows® may generate some installation errors and Technical Support will not attempt to resolve any issues that arise.
  • The MET/TEAM Server installer will perform new installations as well as prepare a system for an upgrade from version 1.0.0, 1.0.1 or 1.0.3. IMPORTANT: Be sure to read all of the information in the Upgrading from version 1.0.x section below before attempting to upgrade an existing installation!
  • The MET/CAL Client installer includes a new prerequisite for Visual Studio 2010 Isolated Shell SP1. This prerequisite is necessary to support launching the MET/CAL Editor from the MET/CAL Runtime Tools menu.
  • The MET/TEAM Server installer includes two new prerequisites for SQL Server Management Objects. These prerequisites are necessary to support installing the MET/TEAM database on a SQL Server instance that is located on a separate server.
    • An Import feature has been added to the File menu in MET/TEAM for importing data from other sources.
  • The Email Alerts web site has been removed. This feature has been incorporated into the MET/TEAM web site.

Upgrading from version 1.0.x

When upgrading an existing installation of MET/TEAM, make a note of what version you are upgrading from before beginning.

Upgrading MET/TEAM to version 1.0.4 requires the previous version to be uninstalled. To upgrade, simply run the MET/TEAM Server v1.0.4 installer. It will detect the existence of a previous version and attempt to automatically uninstall it for you. If you uninstall the previous version before attempting to install this version, you will be required to request new licenses for your software!

When uninstalling the previous version, you only need to uninstall the Fluke MET/TEAM Server product. You do not need to uninstall any other product as long as you use the same settings (destination paths, shared folder names, TCP ports, etc.).

Uninstalling the previous version will not delete your current database. When installing this version, you may either choose to use the existing database or create a new database.

If you choose to use the existing database, you must manually update the database after the installation is complete using the database update scripts provided. These update scripts are typically located in the %ProgramFiles%\Fluke\METTEAM Database Scripts folder. Be sure to read the ReadMe file(s) included in this folder that are specific to the version of MET/TEAM you upgraded from. Those files contain specific instructions on how to successfully update your database. Note that if you have customized the MET/TEAM database in any way, you must contact Technical Support for assistance as running the update scripts provided may leave your database in an unusable state!

After updating the MET/TEAM database, you need to set the Import – Data Directory and Import – Files Directory system defaults before attempting to use the Import feature. Also, if the installation paths were customized, make sure the Mobile – Check Out Directory, Mobile – Check In Directory, Mobile – METCAL Shared Files Path, Reports – Default Reports directory, and Reports – Default System directory system default settings are all correct.

If you have installed MET/CAL Runtime and/or Editor 8.1.x on any workstations, be sure to run the MET/CAL Client installer on all MET/CAL workstations to update the MET/CAL Runtime and Editor to the latest version and to install the new prerequisite mentioned in the previous section.

Running MET/TEAM

Once MET/TEAM is successfully installed, you may run MET/TEAM by double-clicking the shortcut created on the desktop and log in using the following built-in administrator account:

  • User name: admin
  • Password: admin

It is highly recommended that you change the password on this administrator user account immediately and create individual user accounts for all users of the system.

MET/TEAM 1.0.4 Changes

Key | Issue Type | Description
MTM-2291 | CHANGE | Resolved an issue regarding importing standards that caused long delays.
MTM-1505 | CHANGE | Resolved an issue regarding storing memo fields as Files during migration.
MTM-1505 | CHANGE | Import Setup Date Format 1 now populated with a default value.
MTM-2346 | FIX | Corrected formatting issues for some numeric data in the MET/CAL Full Data view.
MTM-2363 | FIX | The report calcertlong.rpt was modified to display both MET/CAL & MET/TEAM generated data sheet results. The calcertlong.rpt is intended to be the basis for customers to use for creating their own customized certificates.
MTM-2284 | FIX | Resolved an issue with data migration not creating asset services.
MTM-2281 | FIX | Resolved an issue regarding too many 0s on the Cost field on Returning dialog.
MTM-2279 | FIX | Resolved issue with not being able to save a returning tool assignment.
MTM-2278 | FIX | Resolved a calculation error on the My Work dialog for labor.
MTM-2276 | FIX | Resolved an issue in alerting of incorrectly sending more than one report per contact.
MTM-2271 | FIX | Resolved an issue on Work Orders regarding the source of Due Date for 'non calibration' work orders.
MTM-2270 | FIX | Resolved an issue on Work Orders where Due Date used deleted asset service data.
MTM-2269 | FIX | Resolved an issue where Recall Escalation was not triggering emails.
MTM-2267 | FIX | Resolved an issue with endless looping when exporting data.
MTM-2263 | FIX | Resolved an issue where Reports - Default Reports directory system setting was not being used.
MTM-1513 | FIX | Resolved an issue regarding setting the Calibration and Due dates when running a procedure in MET/CAL Runtime.
MTM-1501 | FIX | Resolved an issue regarding creating an asset service based on tMainDate on import.
MTM-1477 | FIX | Migration may abort with error message when encountering a pound sign (#) in the data.
MTM-1460 | FIX | Resolved an issue regarding the calculation of the alerting schedule.
MTM-1448 | FIX | Resolved an issue where importing asset service information would require the data to contain work order information as well.
MTM-1447 | FIX | Facilities created as referenced items are now adorned with the appropriate flags for lab, customer, manufacturer and sub contractor.
MTM-1446 | FIX | Import definition screen was missing some table fields in tree of selectable tables and fields, like the active record flag.
MTM-1436 | FIX | Enhanced logging to include dependent objects that are created when referenced by the main item, for example the manufacturer of an asset that is imported.
MTM-1407 | FIX | Resolved an issue regarding the ability to delete imports.
MTM-1338 | FIX | Resolved an issue regarding disabling the ellipse button on the Data Sheet field on the Work Order screen when the work order is closed.
MTM-1295 INFO

How to run an update on migration:

For example, to update assets with the latest from MET/BASE, rename Assets.tmp to 1Assets.tmp, or some other name. Do not change or delete Assets.key.

Run DataMigration.exe and do the Assets step. Since the data already processed is found in the *.key file, only records added after the last run are exported.

Now rename Assets.Assets.done, Assets.AssetEx.done and Assets.tmp.reject in the same fashion. Run MetTeamMigration.exe and do the Assets step.

MET/CAL Changes

Key | Issue Type | Release Note
MC-9601 | ADD | A 5522A Statement with AC amplitude as the evaluation quantity and an offset, now returns a reference accuracy that is the RSS of the amplitude and offset accuracy.
MC-9583 | ADD | A 5502A or 5502E Statement with AC amplitude as the evaluation quantity and an offset, now returns a reference accuracy that is the RSS of the amplitude and offset accuracy.
MC-9661 | FIX | Now a 5502E statement that specifies a coil will correctly compute the total reference accuracy when the FSC is "device mapped" (i.e. a 5502A, 5520A, or 5522A is used).
MC-9662 | FIX | Now a 5502A statement that specifies a coil will correctly compute the total reference accuracy when the FSC is "device mapped" (i.e. a 5520A or 5522A is used).
MC-9664 | FIX | Fixed an issue where standards used a procedure may not be written to MET/TEAM work orders correctly.


Read Me MET/CAL 8.1.3

This read me file includes a list of modifications to MET/TEAM 1.0.3 and MET/CAL 8.1.3 relative to versions 1.0.1 and 8.1.1 respectively. MET/CAL 8.1.3 is the third updated of MET/CAL that directly interacts with MET/TEAM, the new browser based asset manager. Features are provided to use MET/TEAM or MET/TRACK as the asset manager. Refer to the new Storage parameter of the metcal.ini file for details on switching asset managers.

What’s new in MET/TEAM version 1.0.3?

  • MET/TEAM is not intended to be installed on "Home" editions of Windows®. Although the installer does not prevent it, installing MET/TEAM on a "Home" edition of Windows® may generate some installation errors and Technical Support will not attempt to resolve any issues that arise.
  • The MET/TEAM Server installer will perform new installations as well as prepare a system for an upgrade from version 1.0.0 or 1.0.1. IMPORTANT: Be sure to read all of the information in the Upgrading from version 1.0.0 or 1.0.1 section below before attempting to upgrade an existing installation!
  • The MET/CAL Client installer includes a new prerequisite for Visual Studio 2010 Isolated Shell SP1. This prerequisite is necessary to support launching the MET/CAL Editor from the MET/CAL Runtime Tools menu.
  • The MET/TEAM Server installer includes two new prerequisites for SQL Server Management Objects. These prerequisites are necessary to support installing the MET/TEAM database on a SQL Server instance that is located on a separate server.
  • The Email Alerts web site has been removed. This feature has been incorporated into the MET/TEAM web site.

Upgrading from version 1.0.0 or 1.0.1

  • When upgrading an existing installation of MET/TEAM, make a note of what version you are upgrading from before beginning.
  • Upgrading MET/TEAM to version 1.0.3 requires the previous version to be uninstalled. However, before attempting to uninstall the previous version, run the installer for this version first! This will detect that a previous version is installed and save some existing configuration information. You will then be prompted to uninstall the previous version and re-run setup. Failure to do this will require you to request new licenses for your software!
  • When uninstalling the previous version, you only need to uninstall the Fluke MET/TEAM Server product. You do not need to uninstall any other product as long as you use the same settings (destination paths, shared folder names, TCP ports, etc.).
  • Uninstalling the previous version will not delete your current database. When installing this version, you may either choose to use the existing database or create a new database.
  • If you choose to use the existing database, you must manually update the database after the installation is complete using the database update scripts provided. These update scripts are typically located in the %ProgramFiles%\Fluke\METTEAM Database Scripts folder. Be sure to read the ReadMe file included in this folder that is specific to the version of MET/TEAM you upgraded from. That file contains specific instructions on how to successfully update your database.
  • If you have installed MET/CAL Runtime and/or Editor 8.1.x on any workstations, be sure to run the MET/CAL Client installer on all MET/CAL workstations to update the MET/CAL Runtime and Editor to the latest version and to install the new prerequisite mentioned in the previous section.

Running MET/TEAM

Once MET/TEAM is successfully installed, you may run MET/TEAM by double-clicking the shortcut created on the desktop and log in using the following built-in administrator account:

  • User name: admin
  • Password: admin

It is highly recommended that you change the password on this administrator user account immediately and create individual user accounts for all users of the system.

MET/TEAM 1.0.3 Changes

Key | Issue Type | Description
MTM-1439 | ADD | Import Setup Date Format 1 now populated with a default value.
MTM-1241 | ADD | Added menu security group for data checks.
MTM-1222 | ADD | Added the First and Last names to the Log Notes grid on the work order page.
MTM-1221 | ADD | Added import functionality to MET/TEAM, available under the File menu. MET/TRACK *.def files can be used to assist in creating MET/TEAM import definitions.
MTM-1215 | ADD | Email Alerts is now fully integrated into MET/TEAM. The option is located in the Reports menu. Reference the MET/TEAM help system for additional details.
MTM-1199 | ADD | MET/CAL procedure duration is used to update the labor hours for the logged in user.
MTM-987 | ADD | Many toolbar buttons and buttons in dialogs can now be secured by doing a right-click and using one of the choices in the resulting pop-up menu.
MTM-1412 | ADD | Added the ability to search for Work Orders using the fields "Working Lab" and "Administrative Lab".
MTM-1230 | Change | PXE files must be stored in the Data Sheet field on the Procedure dialog. Previously the files were stored in the Procedure File field. The Procedure File field can be used in parallel with the data sheet field to store documentation associated with the procedure.
MTM-1403 | Change | Changed the encoding for drop-down fields to support specific locale settings.
MTM-1315 | Change | Changed MET/TEAM web site configuration to allow file uploads of up to 50MB
MTM-1428 | FIX | Fixed an issue where on the data migration tool where a partial button may appear on the initial screen.
MTM-1413 | FIX | When calibrating an asset using MET/CAL, multiple extended work order data records may be created when re-using the open work order.
MTM-1404 | FIX | Resolved issue launching MET/CAL from the Work Order dialog in MET/TEAM on a client computer when a PXE procedure is being used.
MTM-1402 | FIX | Test result on report heading page now comes straight out of work order results on the work order.
MTM-1397 | FIX | Fixed an issue where points data that contains base units (i.e. units without any prefix) may be interpreted as being unit less.
MTM-1392 | FIX | If an unrecognized function name is encountered in the pre-processed data to be migrated into MET/TEAM, the process will now abort, so the situation can be remedied.
MTM-1372 | FIX | Fixed support for installing MET/TEAM Server on one computer and selecting a SQL Server instance located on another computer. Note that you must setup logins in SQL Server both for the machine that MET/TEAM is being installed on as well as the user that is running the MET/TEAM Server installation, and grant those logins system admin rights. For the machine login, use the syntax DOMAIN\COMPUTER$ for the login name.
MTM-1359 | FIX | English locale files for Australia and Canada have been added to MET/TEAM for proper regional settings formatting.
MTM-1318 | FIX | Changes done to set the correct Title of "Edit Asset" window after closing the message window.
MTM-1316 | FIX | Resolved an unhandled exception error when attempting to create a new alert and update the date.
MTM-1292 | FIX | TabPanel Height issue fixed for viewing Extended Data correctly.
MTM-1224 | FIX | The focus of a main window could be lost when returning from a selection window. For example using the Quick Link for a procedure in a Work Order then closing the procedure could return program focus to a screen other than the original Work Order.
MTM-1223 | FIX | Fixed type-o on Tool Assignments.
MTM-1211 | FIX | Changed the title on the Create Estimate Item dialog.
MTM-1210 | FIX | Some labels on the Quote screen have been changed.
MTM-1183 | FIX | Fixed an issue where MET/CAL Runtime may not automatically run a procedure when called from MET/TEAM on Firefox.
MTM-1167 | FIX | Checking the Accepted checkbox on the Quote dialog now properly sets the Accepted date.

MET/CAL 8.1.3

Key | Issue Type | Release Note
MC-9548 | ADD | The "Check Compile" (F9) function will now use the instrument configuration attached to the project, if one exists, instead of using the workstation configuration. This behavior now matches the package build operation. Test run will continue to use the workstation configuration. Review the help topic for additional details.
MC-9511 | ADD | The LIB FSC now supports System.Object parameters in COM collection objects with dynamic index types.
MC-9452 ADD

Updated the Fluke 5500A 90 day and 1 year accuracy files to fix bugs and match the current specification documents:

  • Product Specifications for 5500A, Rev D, 07/12/2011
  • Product Specifications for 5500A-SC300, Rev D, 06/22/2011
  • Product Specifications for 5500A-SC600, Rev F, 04/25/2011
  • Instruction Sheet Model 5500A/COIL, PN 600616, August 1995, Rev.8, 1/09
  • 7405A-4207T AC Divider Instruction Sheet, PN 881826, February 1992
MC-9432 | ADD | The 5502E FSC TC Measurement mode now supports the Monitor action. This is the same as a 5520 FSC with MOD3 = "TM", and MOD4 = "S" (UUT Setup).
MC-9431 | ADD | The 5502A FSC TC Measurement mode now supports the Monitor action. This is the same as a 5520 FSC with MOD3 = "TM", and MOD4 = "S" (UUT Setup).
MC-9422 | ADD | Procedure project properties have been expanded and reorganized. There are now many more properties and categories of properties to better define and organize the procedure package.
MC-9387 | ADD | "Multi" is now supported as a package output type. This will allow the build to output the MCZ, PXE, a ZIP of the project, and a manifest describing the items in this build.
MC-9384 | ADD | The .mcz package format is now a supported output type of the MET/CAL Editor. This file format is currently used by MET/CAL Gold procedures.
MC-9369 | ADD | The MET/CAL Runtime now displays a message at the beginning of procedure execution to indicate the load status of procedures. In cases of large procedures, the load time can be longer than expected giving the impression that the nothing is happening. The message now provides the status.
MC-9351 | ADD | Procedures written using the P700 FSCs execute without modification with a 7526A configured and connected.
MC-9350 | ADD | Procedures written using the 525/M525 FSCs execute without modification with a 7526A configured and connected.
MC-9349 | ADD | Fluke 700 Series and 525A-Pxx Series pressure modules can now be configured on the 7526A LEMO pressure port.
MC-9339 | ADD | The full version number is now displayed in the About dialog. The MET/CAL version has 4 fields: Major, Minor, Rev and Build. 8.1.3.13 for example.
MC-9331 | ADD | New message "Can't find procedure ..." is added if the specified procedure cannot be located when launching the MET/CAL Runtime from MET/TEAM. This only applies to compiled procedures. PXEs are automatically downloaded prior to execution.
MC-9317 | ADD | Changed the behavior of the TUR reporting for MEMC and MEMCX statements when compiling a procedure. The old behavior was to stop on the first warning, it has been changed to show all TUR warnings in the file.
MC-9310 | ADD | Added installation of Visual Studio 2010 SP1 update as a prerequisite to the MET/CAL Editor when running the consolidated installer.
MC-8964 | ADD | Keep the Test Result Window open after Finishing Debug Operation
MC-8884 | ADD | Procedure selector grid may display foreign language characters incorrectly.
MC-5775 | ADD | 5522A TC Measure mode now supports the Monitor action. This is the same as the 5520 FSC with MOD3 = "TM" and MOD4 = "S" (UUT Setup).
MC-8887 | ADD | Added a new FSC for the 5502E Calibrator.
MC-8693 | ADD | Added a new FSC for the Fluke 5502A Calibrator.
MC-8216 | ADD | 7526A NVI FSC for the Fluke 7526A Precision Process Calibrator
MC-1553 | ADD | Fluke 5500A accuracy files: added edge mode rise and fall time entries for compatibility. However, since the published specifications are asymmetrical, accuracy lookups will return "NA".
MC-9531 | Change | The LIB FSC will no longer check the definition for COM objects if the definition requirement is not set. The check was removed to minimize possible errors created by incorrect definitions. The details of the COM object parameters and argument data types are now dynamically determined by default.
MC-9392 | Change | MET/CAL will now write the PXE file to the "Data Sheet" field when creating a Procedure record in MET/TEAM. Additionally, MET/CAL will not overwrite the procedure used when launched from MET/TEAM.
MC-9554 | FIX | After running a TUR report, double clicking a TUR warning in the Error List did not jump to the line in the procedure that generated the error.
MC-9563 | FIX | PXE's compiled with Chinese characters in the instrument lines did not function properly.
MC-9569 | FIX | Some values written to the RHT.ini file were not always used in the pre and post test prompts.
MC-9543 | FIX | Fixed an issue displaying Spanish menus. Selecting the Spanish language option will now allow MET/CAL to display Spanish menu translations.
MC-9542 | FIX | PXE's launched from MET/TEAM that aborted early could leave the MET/CAL Runtime menu in a disabled state. This problem is now resolved.
MC-9536 | FIX | Resolved Unicode character display issues in the Stimulus, Head and other related windows.
MC-9535 | FIX | Fixed an issue with running a PXE from MET/TEAM when the client is on a separate machine than the server. This issue would cause the PXE to be downloaded to the server instead of the client machine. This has been fixed, and the PXE will properly be saved to the client PC before execution in MET/CAL.
MC-9526 | FIX | Fixed an issue where MET/CAL would sometimes crash when using a MET/TEAM instance that contains more than 25 Unit objects. The error prevented MET/CAL data from being properly written to MET/TEAM.
MC-9510 | FIX | On the Procedure Selector, pressing CTRL-V on the keyboard may inadvertently trigger the Validate Procedures on Load check box and reload prompt. Now CTRL+V will paste text as this is the default Windows behavior.
MC-9499 | FIX | Fixed an issue where images were displayed in a fixed size when using the PIC FSC. The window that displays images now uses the image size to determine the window size.
MC-9488 | FIX | Resolved Unicode character problems in the MATH FSC PSCALE. The micro units symbol would not work properly.
MC-9487 | FIX | Resolved Unicode character problems in the MATH FSC IS_DIM. The micro units symbol would not work properly.
MC-9486 | FIX | Resolved Unicode character problems in the MATH FSC IS_UNIT. The micro units symbol would not work properly.
MC-9485 | FIX | Resolved Unicode character problems in the MATH FSC ENGR_NSD. The micro units symbol would not work properly.
MC-9484 | FIX | Resolved Unicode character problems in the MATH FSC ENGR_ZCMP. The micro units symbol would not work properly.
MC-9482 | FIX | Error messages associated with unsupported procedure features in the 5500 Cal were not properly displayed. If a procedure with an unsupported feature was selected, the procedure would not run and there were no associated error messages. Now error appropriate messages will display.
MC-9480 | FIX | Resolved Unicode character problems in the MATH FSC UPREFIX. The micro units symbol would not work properly.
MC-9429 | FIX | 5522A FSC statements with Mode = TC_Source and +Voltage now properly outputs DC voltage at the TC terminals, not NORMAL HI and LO
MC-9428 | FIX | 5522A FSC statements with Mode = TC_Source and +Voltage now properly output DC voltage at the TC terminals, not NORMAL HI and LO
MC-9427 | FIX | 5522A FSC statements with Mode = TC_Source and +Voltage now properly outputs DC voltage at the TC terminals, not NORMAL HI and LO
MC-9415 | FIX | Each 5502A and 5502E Read action now waits for, and returns a new measurement.
MC-9414 | FIX | Each 5522A FSC Read Action now waits for, and then returns a new measurement.
MC-9410 | FIX | Some procedure line length error messages incorrectly display "bytes bytes" instead of just "bytes".
MC-9406 | FIX | 5080A FSC now works with MET/CAL 8.1.
MC-9390 | FIX | Fixed floor values in 52120A accuracy file for modes that do not use coils.
MC-9389 | FIX | Fixed an issue with the 52120A accuracy file, which did not contain all the information needed.
MC-9368 | FIX | Resolved an error that prevented the ability to set the Default Serial Port to "None".
MC-9364 | FIX | Fixed an issue that caused an error when saving calibration results from a passing calibration using Dutch locale settings. This was due to an error in the due date calculation.
MC-9363 | FIX | Fixed an issue with debugging procedures that use the scope options of the 5522A FSC. This issue caused the procedure to not work in debug mode.
MC-9361 | FIX | The 5502E FSC driver now correctly programs compensation when the statement specifies LeadCompensation = 2Wire or LeadCompensation = 4Wire.
MC-9360 | FIX | The 5502A FSC driver now correctly programs compensation when the statement specifies LeadCompensation = 2Wire or LeadCompensation = 4Wire.
MC-9359 | FIX | The 5522A FSC driver now correctly programs compensation when the statement specifies LeadCompensation = 2Wire or LeadCompensation = 4Wire.
MC-9356 | FIX | The 5502A FSC now device maps properly to the 5520A or 5522A when slewing.
MC-9354 | FIX | The 5502A and 5502E FSCs now device map properly to "Fluke 5520A" or "Fluke 5522A".
MC-9341 | FIX | Fixed Post Test Summary window display problem in Chinese and Japanese windows
MC-9323 | FIX | A 9640 FSC statement with the ExternalReferenceFrequency parameter specified now "Device Maps" without error when a 9640A-LPNX is configured and connected.
MC-9289 | FIX | Fixed an issue where the incorrect accuracy file could be used when generating TUR reports.
MC-9242 | FIX | If DutyCycle is specified in a 5522A without Waveform = Square an error message is now generated, instead of an unhandled exception.
MC-9234 | FIX | Derived AC units (Ex. Vp) are now correctly converted to calibrator units (Ex. Vrms) for accuracy file lookup.
MC-9229 | FIX | Resolved issue using device mapping in 5502A FSC for calculations that call accv or accv2.
MC-9228 | FIX | Resolved issue using device mapping in 5502E FSC for calculations that call accv or accv2.
MC-9227 | FIX | The 5522A FSC now "Device Maps" correctly to the 5520A for the following modes: TC_Source & TC Measurement (10 µV/°C & 1 mV/°C), DC Power, and AC Power, and when the Evaluation Quantity is DutyCycle or Current using a coil.
MC-9216 | FIX | Resolved an issue with the accuracy calculation in the 5502A FSC.
MC-9137 | FIX | The 5502E FSC now correctly "Device maps" to the 5502A, 5520A, and 5522A.
MC-9091 | FIX | Resolved an issue when running PXE with MET/TEAM
MC-9065 | FIX | Instrument FSC slew mode now displays the "At slew limit" message, like MET/CAL 7.3.38 and earlier.
MC-9039 | FIX | There was an issue with the calculation of calibration due dates from MET/CAL where dates set as non-working dates were not being taken into account. This has been resolved and both non-working days as well as non-working dates are taken into account when determining the calibration due dates.
MC-8941 | FIX | Resolved a security issue when attempting to debug procedure using LIB FSC.
MC-8720 FIX 6100, 6100B, and 6105A FSCs no longer attempt compile time validation of a parameter value that is a dimensioned number from a list, if the value comes from a register or named variable.

Example:

6105A +L1VAC = [M36] V; Freq = [M4] Hz; L1VRange = [M37] V

will compile without error. The validation of L1VRange parameter value is postponed until run time.
MC-8719 FIX Fixed Fluke 5500A accuracy file frequency entries for:

Mode: Vpp LS SC
0.005 5.5 50E+3 50E+3 2.0 200E-6 NA
0.005 5.5 50E+3 100E+6 3.5 300E-6 NA
0.005 5.5 100E+6 250E+6 4 300E-6 NA
0.005 3.0 250E+6 300E+6 4 300E-6 NA
0.005 3.0 300E+6 350E+6 NA NA NA
MC-8470 FIX Updated Fluke 5500A accuracy files (90 day and 1 year) to the most recent specifications:
Product Specifications for 5500A, Rev D, 07/12/2011
Product Specifications for 5500A-SC300, Rev D, 06/22/2011
Product Specifications for 5500A-SC600, Rev F, 04/25/2011
Instruction Sheet Model 5500A/COIL, PN 600616, August 1995, Rev.8, 1/09
7405A-4207T AC Divider Instruction Sheet, PN 881826, February 1992
MC-8212 | FIX | Fixed a localization issue with RHT that was causing decimal values to be parsed incorrectly. This would cause the value coming from the RHT to not pass validation in the prompts.
MC-8163 | FIX | Support French Special Characters in Revision Output.
MC-4121 | FIX | The ESA/PSA run time driver now handles *IDN? response when the individual fields are padded with leading and/or trailing whitespace. Basically, leading and trailing whitespace is removed before the individual fields: <manufacturer>,<model>,<serial number>,<firmware revision> are validated.
MC-9031 | FIX | Launching the MET/CAL Editor from MET/CAL Runtime no longer requires the user to enter login credentials.
MC-8970 | FIX | In 8.0, when a user did not have correct permissions to do something in MET/CAL Runtime, an error was not displayed. The error message is not displayed in 8.1.
MC-8829 | FIX | 5522A FSC CurrentTerminal parameter error message now reports only "20A", "Aux", and "Auxiliary" as legal values.


Read Me MET/CAL 8.1

This section includes a list of modifications to MET/CAL 8.1 relative to 8.0.51.

MET/CAL 8.1 is the first release of MET/CAL that directly interacts with MET/TEAM, the new browser based asset manager. Features are provided to use MET/TEAM or MET/TRACK as the asset manager. Refer to the new Storage parameter of the metcal.ini file for details on switching asset managers.

MET/CAL Changes

Issue | Type | Description
MC-3083 | ADD | A new FSC has been added for the Agilent N5531S Measuring Receiver.
MC-3881 | ADD | Added support for the Fluke 5080A via the 5080A NVI FSC and 1 year accuracy file. Refer to the help file for the 5080A FSC for more information.
MC-8000 | ADD | MET/CAL is now distributing Crystal Reports runtime engine v13.0 SP3 (13.0.3)
MC-8226 | ADD | Implemented an new backend for MET/CAL to run with the new asset manager, MET/TEAM.
MC-8230 | ADD | A migration tool is available to port MET/BASE data to MET/TEAM. There are three options for carrying forward results data: all, latest cal or none.
MC-8448 | ADD | New filter option for customer assignment dropdown when adding assets. Leaving the filter blank yields the prior behavior. The filter represents the WHERE clause of the SELECT statement that returns the customers in the dropdown. For example, K4602 LIKE 'A%' limits the records in the dropdown to those where the customer name starts with 'A' or 'a'. K4601 = 'ABC' limits the records in the dropdown to the one where the customer id is 'ABC'.
MC-8451 | ADD | LIB FSC documentation has been updated to clarify usage in certain situations.
MC-8612 | ADD | Compatibility report, called rt_report_of_cal_ver_8.rpt, for printing v7 and v8 certs is available for MET/TEAM.
MC-8628 | ADD | Added accuracy file for HP/Agilent 5701A Primary Frequency Standard
MC-8693 | ADD | FSC for the Fluke 5502A Calibrator
MC-8712 | ADD | Accfile for Fluke52120A Transconductance Amplifier has been added to the installer.
MC-8740 | ADD | Added SWR data for 8487A power sensor to the following power meter acc files: EPM-441A, EPM-442A, E4418A, E4418B, E4419A, and E4419B.
MC-8741 | ADD | Added accuracy file for Agilent 11667C power splitter.
MC-8771 | ADD | Added flexible driver support for the Tektronix FCA3000, FCA3100, and MCA3000 Series frequency counters.
MC-8772 | ADD | Created accuracy files for Tektronix FCA3100, FCA3100, and MCA3100 Series frequency counters for flexible driver support. Includes timebase specifications.
MC-8887 | ADD | FSC for the 5502E Calibrator
MC-8966 | ADD | The help file now includes a keyboard short-cut Quick Reference section. Search for Quick Reference in the help file or access the Contents menu of the help system and select the Procedure Editor, Quick Reference section.
MC-9029 | ADD | Removed GPIB Board Type selection from the IEEE-488 Board Configuration dialogs. This setting was unused.
MC-9123 | ADD | Default configuration for tool/debug windows in Editor has been updated to show Error List, Output and Test Run Status simultaneously across the bottom of the Editor window.
MC-9248 | ADD | Trial license generation process improved to be compatible with more machines.
MC-9259 | ADD | The 5080A FSC now supports CurrentTerminal = Aux | 20A, like the 5502A, 5502E, and 5522A FSCs.
MC-8981 | FIX | Resolved an issue with the Library FSC Component Definition Wizard regarding reading in a large number of exported functions from Win32 DLLs.
MC-8993 | FIX | Extended ASCII characters used with the MEMI FSC now display properly.
MC-3549 | FIX | Crystal Reports now lists assets under "Standards Used" even if they are out of cal.
MC-7931 | FIX | Resolved issue where LPSTR data type for Win32 DLL function arguments were not being saved properly using the Library FSC Component Definition Wizard.
MC-8648 | FIX | Resolved an isssue where the Test Run Status Stimulus displayed a voltage after an instrument FSC had reset the instrument.
MC-8707 | FIX | MET/TRACK may not run on MET/CAL license when all MET/CAL licenses in use on MET/CAL side.
MC-8921 | FIX | Interval and Interval Units are editable MET/TEAM version 0.1.127
MC-8947 | FIX | Several issues were resolved in this fix: 1) Scrolling in the text view while debugging is much faster 2) Fixed an issue where debugging cannot be started if a read-only procedure source differs from the compiled procedure. The text view for this procedure is updated to reflect the compiled procedure, but since the source cannot be updated, debugging would fail. This is now a warning instead of an error. 3) Restored the behavior where header changes caused by building a procedure package are not saved to text source. The compiled procedure will have the header changes, and the header can be updated and saved with a "Check Compile". 4) When debugging, if the compiled procedure differs from a read only text source, the compiled version of the procedure is used to update the text view. At the end of a test run, the updated procedure is left open, and the changes can be saved to text source, or discarded.
MC-8979 | FIX | Fixed issue displaying Russian characters in ptitle_l and ptitle_r.
MC-8996 | FIX | Support LibraryFsc.xml from remote location
MC-9015 | FIX | Added accuracy file for Agilent E4413A Power Sensor.
MC-9031 | FIX | Launching the MET/CAL Editor from MET/CAL Runtime no longer requires the user to enter login credentials.
MC-9072 | FIX | Resolved an issue with the slew resolution at 330 Mohms and 1100 Mohms ranges for the 5502A/5502E FSC.
MC-9073 | FIX | Resolved an issue with the maximum resistance with 2 or 4 wire compensation for the 5502A/5502E FSC.
MC-9074 | FIX | Resolved an issue where 5502A/5502E FSC was sending a command for the External Guard.
MC-9078 | FIX | Resolved an issue with the 5502A/5502E capacitance resolution.
MC-9079 | FIX | Removed the ReferenceClock and ReferencePhase parameters from the 5502A/5502E FSC (not supported).
MC-9131 | FIX | Added support to the LIB FSC for the unmanaged data type bool32 which is required by the NI DAQ API.
MC-9137 | FIX | Resolved an issue with using device mapping with the Fluke 5502E.
MC-9139 | FIX | support Editor login command line
MC-9152 | FIX | Added support for Type U thermocouples to the 5522A FSC for TC Source and TC Measure functions.
MC-9153 | FIX | Added support for Type U thermocouples to the 5502A/5502E FSC for TC Source and TC Measure functions.
MC-9154 | FIX | Resolved an issue with the 5502A/5502E FSC not converting a temperature to voltage for accuracy file lookup.
MC-9155 | FIX | Resolved an issue with the 5522A FSC not converting a temperature to voltage for accuracy file lookup.
MC-9158 | FIX | Resolved an issue with the LIB FSC not handling constant pointers in Win32 DLL functions.
MC-9159 | FIX | Added support to LIB FSC for unmanaged data types constchar[] and void*.
MC-9163 | FIX | Resolved an issue with the LIB FSC using a named variable that contained the word "new".
MC-9166 | FIX | Resolved LIB FSC issue related to assigning values to an array using a variable and then attempting to pass that array as a numeric array to a Win32 DLL function.
MC-9172 | FIX | Resolved an issue when using extended ASCII characters in field C2501.
MC-9177 | FIX | Resolved an issue that prevented images larger than 1MB from being displayed.
MC-9207 | FIX | Resolved an issue with backward compatibility with the encoding of STD names.
MC-9216 | FIX | Resolved an issue with the accuracy calculation in the 5502A FSC.
MC-9227 | FIX | The 5522A FSC now "Device Maps" correctly to the 5520A for the following modes: TC_Source & TC Measurement (10 µV/°C & 1 mV/°C), DC Power, and AC Power, and when the Evaluation Quantity is DutyCycle or Current using a coil.
MC-9228 | FIX | Resolved issue using device mapping in 5502E FSC for calculations that call accv or accv2.
MC-9229 | FIX | Resolved issue using device mapping in 5502A FSC for calculations that call accv or accv2.
MC-9231 | FIX | Fixed an issue where MET/BASE users of level 1, 2, and 3 could not discard calibration data at the end of a calibration in MET/CAL Runtime. This has been fixed, and now all levels of users can discard a calibration at the end of a run.
MC-9232 | FIX | Implemented a missing function in 5502A FSC.
MC-9233 | FIX | Implemented a missing function in 5502E FSC.
MC-9234 | FIX | Derived AC units (Ex. Vp) are now corrertly converted to calibrator units (Ex. Vrms) for accuracy file lookup.
MC-9242 | FIX | If DutyCycle is specified in a 5522A without Waveform = Square an error message is now generated, instead of an unhandled exception.
MC-9244 | FIX | Resolved an issue with the µ symbol not being properly recorded in the database.


Read Me MET/CAL 8.0 Build 50

This update to MET/CAL Plus Software is provided as a patch relative to MET/CAL 8.0 build 46. The patch can only be applied if build 46 was previously installed on the host system. The patch will also work if interim patches between 46 and build 51 were previously installed.

The changes associated with the update are listed in the tables below. Reference the Read Me sections of the help system for changes related to prior version of MET/CAL.

MET/CAL Changes

Issue# | Type | Description
MC-8833 ADD

The LIB FSC now supports a PATH with a DLL declaration statement. The syntax below is now supported:

LIB DLL myDll = "T:\MetCal\TestDlls\7paklib.dll";

MC-8882 | ADD | Previously, when a message was displayed in the Editor while debugging a procedure, the Editor was not available for interaction. Now the Editor can be accessed by the user when a message is displayed, allowing the user to set breakpoints, view registers, and interact with other enabled functions within the MET/CAL Editor.
MC-8194 | ADD | Loading procedures from proc.dir can now be canceled on the Procedure Selector dialog. This is useful when a large procedure directory is being accessed and a user wishes to abort the process. Note that after the selector loads the procedures it will not reload procedures until the application that launched the selector is closed ore the user specifically selects the re-load option in the Procedure Selector.
MC-8687 | ADD | The EPM FSC was updated to also support a power meter as a readout device for a UUT power sensor.
MC-8643 | ADD | Alt+F5 is now supported as the short-cut key for the Debug > Debug From Cursor menu option.
MC-8859 | ADD | The validation of proc.dir and procedures on the Procedure Selector are now optional, to improve load performance.
MC-8971 | ADD | The last Windows path used to select a PXE in the MET/CAL Runtime is now preserved until MET/CAL Runtime closes. The default location used by MET/CAL Runtime is the currently configured procedure directory; proc_dir in the metcal.ini file.
MC-8870 | ADD | The 2024 FSC now accepts both the IFR 2023 AND Aeroflex 2023.
MC-9000 | ADD | If an invalid proc.dir path is entered in metcal.ini a prompt to select a new proc.dir will be generated when selecting a procedure. Previously an error message was generated requiring the user to manually edit the metcal.ini file.
MC-8937 | FIX | The PIC FSC did not support picture files with multiple dots and/or spaces in the same fashion as prior versions of MET/CAL. Currently the previously supported formats are again supported.
MC-8886 | FIX | The use of extended characters such as the © symbol in the ptitle_l and ptitle_r metcal.ini file parameters prevented a procedure from compiling. The problem is now resolved.
MC-8954 | FIX | Path and file name support for the DOS FSC was limited preventing some combinations of spaces and characters that were previously supported. The previously supported combinations are now supported. Note that it is necessary to use quotes with paths and file names that include spaces, especially when command line arguments will be used.
MC-8873 | FIX | A new section named "Tolerance Computations" was added to the MET/CAL Reference guide. This section provides details on the various tolerance calculation scenarios.
MC-8852 | FIX | The documentation for the newly released 52120A FSC was not linked with the editor Intellisense features. This has been resolved and this FSC will display in both auto-completion dialogs as well as in the F1 help.
MC-8846 | FIX | Multiple manual standards like the Fluke 742A, could not be configured using the Instrument Configuration dialog. The work around was to manually edit the config.dat file for a particular MET/CAL station. The problem has since been resolved.
MC-8839 | FIX | Added the ability to launch the MET/CAL Runtime and execute a Procedure Executable (PXE) by double clicking the PXE file. The MET/CAL Runtime must be closed to support this behavior. It allows a user to locate PXE files on a network and execute the corresponding MET/CAL procedure by double clicking them similar to executable programs or program short-cuts.
MC-8909 | FIX | Using the LIB FSC with a DLL did not properly present DLL error messages to the Post Test dialog. When a DLL error occurs that prevents execution the Post Test screen now includes the corresponding error information associated with the problem.
MC-8855 | FIX | Special characters in the procedure instrument lines were not supported in MET/CAL 8.0 build 46.
MC-8963 | FIX | Resolved issue that would generate an exception when using the Procedure Selector to access a read-only procedure directory.
MC-8985 | FIX | The procedure selector could not access a procedure directory if a corrupt file were present in the directory. The error was caused by the caching mechanism that occurs during the initial load of a procedure directory.
MC-9038 | FIX | Compiling a procedure that includes a configured standard that has an asset number requires access to the database. When compiling in MET/CAL 8.0, the database was initialized and accessed for each line in the procedure that referenced the standard. In a typical LAN scenario the performance change was unnoticed. When connected to a remote database via VPN, the performance was very noticeable. In extreme cases it could take several minutes for a single procedure to compile. The issue was resolved by accessing the database only for unique instances of configured standards that include asset numbers.
MC-8907 | FIX | An issue was resolved regarding merging the LIB FSC XML files using the Tools > Library FSC > Merge Workstation/Solution Definition Files menu option. If conflicting definitions are found in the files being merged, the user is prompted with the Select Definition To Use dialog and must select which definition to use in the merged file.
MC-8961 FIX

If the LIB FSC was used to access an array element that was not initialized, a hard error occurred that would close the MET/CAL Editor. The item below did not work unless a statement that set element 0 was previously used. The issue is now resolved.

1.001 LIB ARRAY NEW myArry[10];
1.002 LIB val = myArray[0];
MC-8793 | FIX | The F6 line continuation mechanism did not work properly on PCs configured to use the comma as a decimal separator. The problem is now resolved.
MC-9039 | FIX | There was an issue with the calculation of calibration due dates from MET/CAL where dates set as non-working dates were not being taken into account. This has been resolved and both non-working days as well as non-working dates are taken into account when determining the calibration due dates.
MC-8993 | FIX | Extended ASCII characters used with the MEMI FSC now display properly. The problem was also encountered when using non English code pages such as Swedish and Japanese.
MC-8845 | FIX | Fixed an issue where the O_CAL FSC documentation would not display with the F1 key. The FSC will now correctly display with the F1 key.
MC-8953 | FIX | The MET/CAL Runtime could not execute a PXE with a large picture associated with a procedure PIC FSC statement. The issue is now resolved. There are no specific size limitations.
MC-8773 FIX

Double clicking an error in the error list that was not associated with procedure source code generated a warning message below. The issue is now resolved:

"The parameter is incorrect. (Exception from HRESULT: 0x80070057 (E_INVALIDARG))"
MC-8812 | FIX | Resolved incorrect instrument ranges listed in the M8845 and M8846 FSC Help file.
MC-8823 | FIX | 52120A/COIL6KA upper current limit for 1 kHz to 3 kHz and 6 kHz to 10 kHz have been corrected.
MC-9063 | FIX | EPM FSC now computes accuracy based on the reading (System Actual) not the nominal value (evaluation quantity).
MC-8914 | FIX | Some extended ASCII characters were not properly stored in the Test_Desc field of the database. The micro and ohms symbols were common examples.
MC-8885 | FIX | The Auto macro configuration (not pass or fail) picks up the configuration of the auto macro fail option and would not allow the item to be changed. The issue is now resolved.
MC-8822 | FIX | 52120A/COIL3KA upper current limit for 3 kHz to 6 kHz and 6 kHz to 10 kHz have been corrected.
MC-8774 | FIX | Chinese characters accessed by the LIB FSC in an Excel Spreadsheet then stored in MET/CAL variables did not display properly. The issue was related to the translation of UTF-8 and ANSI characters when accessing files. The problem is now resolved.
MC-8942 | FIX | The MET/CAL Runtime allowed a second PXE to be selected when a procedure was currently being executed. This behavior is not supported so the ability to select a new procedure when a procedure was currently executing has been removed.
MC-8938 | FIX | The INSTRUMENT line in the Test Run Status Window of the MET/CAL Editor always displayed the first INSTRUMENT line in a procedure, regardless of whether a subsequent INSTRUMENT line was actually called. The problem is now resolved.
MC-8920 | FIX | The LIB FSC generated a confusing error message when there was a mismatch between the number of arguments in the definition of a DLL function and the actual DLL function. A new verbose error message was created.
MC-8797 | FIX | O_CAL FSC was not properly linked to the F1 help system. Users were required to manually navigate to the O_CAL topic after the help system displayed.
MC-8977 | FIX | There was an issue with the continue line function in some locale settings where the line number was parsed using the user's locale settings, causing an incorrect line number. This has been fixed and the line number will be parsed with a period as the decimal separator regardless of locale settings.
MC-9012 | FIX | Exclude Hidden Procedures check box on the Procedure Selector may be inaccessible (partially obscured) on some screen resolutions. The option is now available regardless of the screen resolution selection.
MC-9006 | FIX | Users could receive the error "Index of the row to copy is out of range. Parameter name: indexSource" when trying to open a procedure in the Editor if one of the procedure files or the procedure selector *.cache files were corrupt.
MC-9001 | FIX | Rebuilding the procedure directory may yield errors and an invalid proc.dir file.
MC-9041 | FIX | The 4418 and 4419 FSCs would time out when the average count is set to 256 or higher. The time limit was previously hard coded to 10s. The count is now based on the average count parameter.
MC-8879 | FIX | Text in a HEAD statement was colorized if the text included an FSC key word (IF, WHILE, DO, etc). The issue did not prevent head statements from functioning properly. The issue is now resolved.
MC-9026 | FIX | Extended ASCII characters and characters defined in non English regional settings used with the STD FSC now display properly.

MET/TRACK Changes

Issue# | Type | Description
MC-8707 | FIX | MET/TRACK may not run on MET/CAL license when all MET/CAL licenses are in use by instances of MET/CAL side.
MC-8848 | FIX | MET/TRACK would not store non English characters on some screens. The problem was related to the database configuration and the handling of Unicode by the MET/CAL database layer. The issue is now resolved.


Read Me MET/CAL 8.0 Update 4/2012

This update to MET/CAL Plus Software is provided to improve the Procedure Selector and installation process, resolve problems reported in prior versions of MET/CAL and to support the FLUKE 52120A Transconductance Amplifier. The update was made available 4/2012. Install the update as an upgrade to prior versions of MET/CAL or as a new installation of MET/CAL. Refer to the upgrade requirements section of the help system for details on supported upgrade versions.

The changes associated with the update are listed in the tables below. Reference the Read Me sections of the help system for changes related to prior version of MET/CAL.

MET/CAL Changes

Issue # | Type | Description
MC-7449 | ADD | A new FSC was created for the 52120A Transconductance Amplifier.
MC-8699 | ADD | The MET/CAL Editor's performance has been improved when displaying the Procedure Selector dialog, especially with large proc.dir files.
MC-8425 | ADD | Procedure selector does not auto-reload anymore. To get the latest version of proc.dir, a reload button is available if proc.dir has changed.
MC-8415 | ADD | Trial/Demo installation CD AutoRun splash screen indicates the number of days the trial license will be valid for.
MC-8426 | ADD | CD AutoRun splash screen is properly sized independent of font settings on computer.
MC-8416 | ADD | CD AutoRun splash screen no longer waits for installation process to complete before being able to be closed.
MC-8736 | FIX | Editor Tools menu item to launch MET/CAL Runtime spelling fixed.
MC-8214 | FIX | Fixed an issue where abeyance interval was not always applied correctly.
MC-8754 | FIX | The TUR Report generated in the MET/CAL Editor was incorrectly writing two lines of TUR information The second line was incorrect. Now only one line is generated.
MC-8622 | FIX | Creating a "MET/CAL Text" file, defaults to ANSI instead of UTF-8. This is the same behavior as Notepad.
MC-8582 | FIX | Fixed an issue where reports were not showing up in the macro configuration screens.
MC-8627 | FIX | The MET/CAL Runtime now supports loading procedures from directories with special characters in the directory name. The proc_dir is still limited to characters supported by the default encoding for metcal.ini.
MC-8756 | FIX | Changing the line numbers of LIB FSC statements in the procedure editor could lead to scenarios where the procedure compiled correctly but could not run. The compile process was changed to handle the various line number changing scenarios.
MC-8668 | FIX | Corrected a problem where breakpoints would not pause procedure execution. This was due to a situation where the test run was not giving control to the editor after executing a test step. This issue has been resolved.
MC-8234 | FIX | Invalid path characters in the procedure name would crash MET/CAL Runtime when the procedure was selected for running in MET/CAL Runtime. Common invalid characters include: \ / : * ? " < > |
MC-8535 | FIX | The pass prompt now supports special characters being used in both the prompt text and the combo box. The prompt files and database fields are still limited to default encoding and do not support Unicode.
MC-8635 | FIX | The file paths in metcal.ini support special characters again. The metcal.ini does not support Unicode. The filenames may contain Unicode such as .mc, .png, and .bat files, unless you are building .pkm files.
MC-8630 | FIX | The MATH FSC help file was not properly formatted. Some of the MATH FSC statements within the file were incorrectly listed in tables and mixed with other statements.
MC-8709 | FIX | If an asset number contained special characters, Run Time would crash when trying to save the calibration data to the database.
MC-8718 | FIX | The issues should be resolved in build 44. The correct syntax for LIB STRUCT should be: LIB ARRAY NEW myArray[100];
MC-8405 | FIX | Fluke 525A, 700, 742A, A40/A40A, A40B, A55, and Hart 512x Instruments can be configured now.
MC-8178 | FIX | Adding comments above the procedure header will display error message.
MC-8179 | FIX | Allow comment lines in procedure header.
MC-8389 | FIX | Support Non-Standard Characters in Instrument Line in Main Procedure.
MC-8735 | FIX | There was an issue with range messages not being populated correctly on non-English languages. Instead of the range message, the user would receive an error. This has been resolved.
MC-8578 | FIX | Compiling an empty procedure (F9) would leave the procedure in an uneditable state. This has been resolved by making sure there is always a blank line at the end of the procedure.
MC-8652 | FIX | MET/CAL Editor now supports the uppercase version of the file extensions ".MC" and ".TXT".
MC-8579 | FIX | Author name is now populated automatically when creating a new procedure.
MC-8580 | FIX | Fixed an issue with client only upgrades unable to find components on login.
MC-8419 | FIX | MATH READ can read ASCII files, but special characters were not displaying correctly. The special characters now display correctly. All Unicode characters are not supported.
MC-8737 | FIX | Procedure window background color did not reset after debugging stopped for non-main procedure windows that were open prior to starting the debugging process.
MC-8584 | FIX | Pressing F1 on the 5520 FSC in the MET/CAL Editor incorrectly displayed the help for the 5220 FSC. The help file link has been resolved.
MC-8413 | FIX | The MET/CAL 8.0 Readme guide located in the help file did not specify the correct version for the release build of MET/CAL 8.0. Build 42 was displayed while build 43 was the actual release build.
MC-8414 | FIX | Trial license generation is no longer dependent on a network adapter (NIC).
MC-8301 | FIX | Fixed an issue where text was not displayed correctly in the RHT dialog.
MC-8657 | FIX | dBm is now correctly converted to watts for the following statement: EPM +PowerRefPower = 0.00 dBm; PowerRefFreq = 50 MHz; Apply
MC-8423 | FIX | Legacy calibration results (mt.CalResults.C2501) now support special characters again. The database fields do not support all Unicode characters.
MC-8711 | FIX | The 8100 FSC help file had a type-o related to the range of legal values. 0 Deg to 100 A instead of 0 A to 100 A.
MC-8211 | FIX | Specifying a register with the TOL FSC now makes a copy of the current register value instead of setting up a reference to the register.
MC-8725 | FIX | F11 key would sometimes quit working during debugging.
MC-8424 | FIX | Fixed an issue with localization handling doubles.
MC-8732 | FIX | In the MET/CAL 8.0.44 update, the MATH FSC CSV file reading did not terminate correctly at the end of a file and would stay stuck in a endless loop. This only occurred when the matched line was not found.
MC-8688 | FIX | F11 key (step) would sometimes quit working when debugging a procedure in the MET/CAL Editor.
MC-8600 | FIX | Standards defined in sub procedures were not detected when executing the main procedure that calls the sub procedure containing the standard. As a result the procedure would not execute and a "... Standard not found error.." was generated. The issue is now resolved.
MC-8129 | FIX | Values entered via the prompt file mechanism were not being used to calculate the calibration due date. The values used came from the asset's calibration interval. This issue has been resolved and values entered in the prompts will override the default behavior.
MC-8220 | FIX | The asset number of configured instruments could not be removed.
MC-8210 | FIX | Using a variable as the file name with the PIC or PICE FSCs incorrectly generated a build error when attempting to test run a procedure project.
MC-8591 | FIX | Local variables with the same name across multiple subprocedures were being removed from the string register window in the wrong order when the subprocedure ends and the variables go out of scope. This was a display issue and the display now correctly reflects the state of the variables internally.
MC-8637 | FIX | The 4418 FSC can time out when waiting for an operation to complete after the driver sends the "INIT:IMM" command.
MC-8167 | FIX | 5500A/Coil does not show up as a standard used in a procedure when used with the 6100A, 6100B, or 6105A.
MC-8668 | FIX | In some scenarios break points were not pausing procedure execution when debugging in the MET/CAL Editor.
MC-8656 | FIX | While debugging, if a large picture file is used in a PIC FSC statement, the debugger would exit with the error "Unable to start debugging". This was due to an issue in the way large picture files were being handled internally. This issue has been fixed, and the error statement has been updated to better reflect the state of the debugger. Also logging has been added to provide more information when a debugging error occurs.
MC-8641 | FIX | Building a solution with multiple projects did not always work properly even when the individual projects could build properly.
MC-8215 | FIX | Each TUR warning incorrectly beeped and there was no ability to shut off the "Beeping".
MC-8683 | FIX | The publish procedure operation would fail when publishing procedures without having any procedure open in the editor and the procedure had a warning message. This was due to the editor not being able to determine the active project when reporting the warning to the user. This has been resolved and warnings now display properly and do not block the publishing of a procedure.
MC-8723 | FIX | Due to the way local variables were updated, there was an issue where similarly named local variables would overwrite each other in the S-REG window. This was only a display issue, internally the variable handling was working correctly. This issue has been resolved, local variables are now updated and removed properly.
MC-8721 | FIX | The uncertainty values were not written to the database properly when non-standard units were used with a user specified prefix format. Example: 1.002 VSET UFMT = PREFIX

MET/TRACK Changes

Issue # | Type | Description
MC-8425 | ADD | Procedure selector does not auto-reload anymore. To get the latest version of proc.dir, a reload button is available if proc.dir has changed.
MC-8606 | FIX | Improper shutdown of MET/TRACK may prevent logging on again, saying no license available for connection.
MC-8577 | FIX | Fixed an issue with users changing their own passwords.
MC-8487 | FIX | May receive Error 13 - type mismatch when selecting "Limits" values from dropdowns on Quick Reports.
MC-8634 | FIX | May receive "Object reference not set to an instance of an object" error on the Data Importation dialog when the date format field is left blank.
MC-8659 | FIX | Command line import tool imp2.exe now supports exiting when done via the -exit switch.
MC-8402 | FIX | Error 13 - Type Mismatch when selecting a standard from the dropdown on the calibration screen. Error 13 - Type Mismatch when adding a link on the linked validation screen.
MC-8448 | FIX | New filter option for customer assignment dropdown when adding assets. Leaving the filter blank yields the prior behavior. The filter represents the WHERE clause of the SELECT statement that returns the customers in the dropdown. For example, K4602 LIKE 'A%' limits the records in the dropdown to those where the customer name starts with 'A' or 'a'. K4601 = 'ABC' limits the records in the dropdown to the one where the customer id is 'ABC'.
MC-8717 | FIX | The license report indicates the wrong MET/CAL version. The report outputs MET/CAL 7.3 SP1 instead of MET/CAL 8.0
MC-8629 | FIX | Calibrate menu did not support PXE. Running PXE from Calibration screen would attempt to call 5500 runtime.


Read Me MET/CAL 8.0

This section includes a list of modifications to MET/CAL 8.0 relative to the previous build 7.3 SP1 build 38. Build 43 is the official release build of MET/CAL 8.0. Specifically 8.0.43 for both MET/CAL and MET/TRACK.

What’s new in version 8.0?

  • New expanded Procedure Editor with flexible user interface and enhanced functionality
    • Customizable windows can be docked and linked in any way desired.
    • Enhanced procedure debug options including break points, intellisense, and pop-up help.
    • New procedure Project and Solution Option
    • Compile procedures into single file Procedure Executables (PXE's)
    • Full Unicode Support for all languages.
  • Increased security for accredited procedures
  • Ability to automate a wider variety of references
  • Compliance to Z540.3 decision rules by guard banding. A new Z540.3 report is included in the installation.
  • Greater flexibility and expanded support of RF power meters and sensors
  • New LIB FSC that allows procedure access to external programs
    • Access to National Instruments DLLS, enabling calibration of PXI instruments with MET/CAL software
    • Option to use Excel for customized plotting and calculations
  • Broader instrument support
  • Linked help system to simplify document navigation
  • No changes to the database are required when upgrading from 7.3 SP1.

Key Changes

  • Users upgrading from prior versions of MET/CAL should read the Migrating Procedures from 7.X to 8.0 section of the help file.
  • Read the Unicode Encoding section of the help file for details on how unicode can affect existing procedures. In general existing procedures will run, however editing the procedure may require adjusting line lengths when multiple extended characters are used.
  • Quick Sort can no longer be used to manipulate procedure directories used by MET/CAL 8.0. After MET/CAL 8.0 has modified a procedure directory, Quick Sort should not be used. Use the Search features and the column sort options in the Procedure Selector to quickly navigate to a new compiled procedure.
  • MET/TRACK has a new Import User Interface that provides the ability to create a custom import definition file.

MET/CAL Changes

Key | Issue Type | Release Note
MC-7166 | ADD | When opening a compiled procedure, a source file is opened in the current procedure directory, in a sub-folder called MCFiles, where it can be edited, tested and published from. This is now standard functionality using the new MET/CAL Editor.
MC-6225 | ADD | Added "Mode: Vpp LS G3" for Leveled Sine flatness specifications into 1 Mohm input impedance . Updated Leveled Sine specifications to source Revision A, dated 11/19/07.
MC-6334 | ADD | O_CAL is now listed in the 5800A and 5820A instrument configuration dialog FSC list. It is also listed in the 5080A, 5500A, 5520A, and 5522A instrument configuration dialogs, when an oscilloscope calibration option is specified.
MC-6451 | ADD | New MATH FSC function: MismatchSWR calculates mismatch uncertainty using source and sensor SWR
MC-7899 | ADD | New MATH FSC function: PXETEMP is used to locate the temp directory used by PXEs.
MC-7404 | ADD | MET/CAL Trial Version is avialable. The program is fully functional but limited to 50 assets in the database.
MC-6770 | ADD | The 9640 FSC now allows the full range of modulation frequencies supported by the current 9640A hardware.
MC-7138 | ADD | Compiled procedures can be published to any procedure directory or to a new empty procedure directory.
MC-7149 | CHANGE | The MET/CAL 8 Run Time requires the .NET 4 Runtime. It is included as a pre-requisite with the installation programs.
MC-7008 | CHANGE | Changing the procedure directory now prompts for proc.dir file, instead of a folder name. The new Procedure Selector supports the selection of a new proc.dir file location.
MC-7888 | CHANGE | dBm is now always displayed as "dBm" in the Post Test dialog. In previous versions of MET/CAL it was displayed as "D".
MC-7892 | CHANGE | Siemens are now always displayed as "S" in the Post Test dialog. In previous versions of MET/CAL they were displayed as "Y".
MC-7893 | CHANGE | Seconds are now always displayed as "s" in the Post Test dialog. In previous versions of MET/CAL they were displayed as "T".
MC-6279 | CHANGE | 9640A and 9640A-LPN AM modulation frequency lower limit has been changed from 20 Hz to 1 Hz to agree with new hardware.
MC-7849 | FIX | Resolved an issue introduced in 7.3 SP1 (7.3.36) that prevented configuring an asset number for N5531S sensor modules has been fixed.
MC-6236 | FIX | Restored the previous behaviour of MET/CAL to vary the calibration due date based on non-working days.
MC-7957 | FIX | O_CAL FSC controlling a calibrator configured for RS-232 causes a timeout. This was due to the LF terminator not being appended to the command string to the calibrator.
MC-5298 | FIX | N5531S Relative TRFL measurement with NMEAS > 1 and no power meter no longer causes "Statement terminated by SRQ.".
MC-6943 | FIX | 9100 FSC with duty cycle in the Nominal field now returns accuracy information in the same format as MET/CAL 7.2 and before.
MC-6768 | FIX | Under certain conditions, the MATH CSV statements would fail with a memory corruption error. The code has been updated so this no longer happens.
MC-7866 | FIX | Corrected the following issue introduced in MET/CAL 7.3.27: Test Tolerance and System Accuracy are not converted to linear units for TUR calculation when an NVI FSC is paired with a MEMC or MEMCX statement.
MC-7902 | FIX | The VSET MFILE output file now contains the Start Date and Start Time values for each row. This feature was unintentionally removed from v7.3.
MC-6213 | FIX | The 5500E port labelled "Serial 2 to UUT" (on rear panel) can now be used to control the UUT, when "Default Serial Port" is set to COM5500.
MC-6442 | FIX | The 5080A driver now causes the serial number returned in the *IDN? response to be checked against the serial number in the inventory record for the asset configured as "Fluke 5080A".
MC-6524 | FIX | The PSA (N5531S) run time driver now displays the instrument generated error when a power meter is required, but not connected.
MC-6953 | FIX | An issue introduced in MET/CAL version 7.3 that caused 6101A, 6101B, and 6106A auxiliary units not to be recognized, has been fixed.
MC-8128 | FIX | The reliability field (C2362) is did not properly increment upon completion of a calibration. The database trigger used to updated the field did not handle NULL field values. MET/CAL now uses an empty string to allow the existing trigger to work properly.
MC-4004 | FIX | E100 was generated when attempting to save a procedure using a FSC with FSC code > 255. For example compiling the 525 FSC generated an error.

MET/TRACK Changes

Key | Issue Type | Release Note
MC-6741 | ADD | Procedure Executables can now be selected from the Calibration Form. Note the full path and file name to the PXE is stored in the field. The field is still limited to 80 characters so it is important to use a path that does not exceed this length.
MC-6797 | ADD | Import definition files can now be created from the MET/TRACK UI. Access this feature through the Tools, Data Importation option.
MC-6798 | ADD | Prompt files can now be created for imports from the MET/TRACK UI.
MC-7126 | ADD | Trial versions of Fluke Metrology Software are now available.
MC-6789 | CHANGE | MET/TRACK now uses the import command line tool introduced with 7.3 from the Data Importation menu. A UI guides through the import process. Definition and prompt files, as well as whole import configurations can be saved to disc and later re-used.
MC-6203 | CHANGE | To import customer data only, use CUSTOMER or CUSTOMERS keyword in DEF file. The import no longer requires an asset assignment during customer import. For import + assignment, use keyword FORMSDATA. See Help on Import.
MC-6715 | FIX | Trace report may yield -121 Sybase error when using user segregates.
MC-7105 | FIX | Application may stop responding when searching for due date and other fields.
MC-6559 | FIX | Searching from the Search Engine may lead to "Invalid Procedure Call or Argument" error.
MC-7592 | FIX | Fixed a variety of issues with the Search Engine.
MC-6793 | FIX | Single quotes (') in field-defaults may be saved as double-single quotes ('').
MC-5477 | FIX | May receive generic automation error if Crystal Reports runtime is not installed. A more specific error is now presented.
MC-5830 | FIX | A warning is now posted when updating a validation picklist with values from the database. The warning is prevent other custom entries from being erased.
MC-5984 | FIX | Linked validation screen now stays open if entries fail validation upon closing the dialog.
MC-6022 | FIX | Adding a segregate using invalid characters may yield errors although creating a segregate entry with invalid characters did work. However the segregate in this case would then be non-functional.
MC-4475 | FIX | French translation enabled for asset error messages.
MC-6822 | FIX | MET/TRACK didn't allow which pages to print from a report, it was all or nothing.
MC-5871 | FIX | Max entry length for desktops other than Default are now updated along with changing the max. entry length for the Default desktop.
MC-4549 | FIX | Loading an asset / customer with a default-on-update setup may not enable the save button although the screen was updated.
MC-5907 | FIX | The Field Title on the Field Properties dialog may not change when the Field property changed.
MC-6632 | FIX | Saving a cloned asset may leave the Save button enabled.
MC-6994 | FIX | MET/TRACK may yield a 380 error if the temperature value stored in the database (in C2311) is greater than 212.
MC-7260 | FIX | Fixed searching for date fields on the search toolbar.
MC-6717 | FIX | Search engine fields cannot be typed into.
MC-7406 | FIX | File paths entered into fields like notes or procedure executable may be stored incorrectly, stripping out characters.


Read Me MET/CAL 7.3 SP1 Build 40

Build 40 was provided as an incremental update to MET/CAL 7.3 SP1. The significant modifications are listed below.

Quick Sort

Issue Number | Description
FIX(MC-7996) | QuickSort 7.x is not suitable for version 8 procedure directories.
FIX(MC-7431) | Speed enhancements for QuickSort.
FIX(MC-6965) | If proc.dir contains lines indicating "entry to be ignored", QuickSort may indicate the file has been corrupted and offer to rebuild the procedure directory.
FIX(MC-6786) | Rebuilding proc.dir with an empty *.pro file in the directory may lead to an error.
FIX(MC-6769) | *.pro files with names longer than 12 characters may lead to 'Invalid Procedure Directory' message when attempting to rebuild proc.dir.

MET/TRACK

Issue Number | Description
FIX(MTRK-6) | Addressed an issue where standards could be used for a calibration in MET/TRACK when the current calibration record was expired.
FIX(MC-8199) | Cannot add a default value to a column on a Merge table.
FIX(MC-8084) | May receive bogus error message when adding merge or user columns.
FIX(MC-7840) | Cannot assign customer that does not have a customer name to an asset.
FIX(MC-7837) | New option to default a search with no results to the nearest match in the dropdown. The functionality existed in prior versions, but can now be turned off (the default setting).
FIX(MC-7830) | Enhanced recovery of lost database connection.
FIX(MC-7655) | May receive error 91 when searching.
FIX(MC-7592) | Fixed a variety of issues with the Search Engine.
FIX(MC-7582) | May receive Error 5 Invalid procedure call or argument error when searching from the main toolbar.
FIX(MC-7433) | Combining calibrations may yield odd row_num entries in the combined record.
FIX(MC-7105) | Application may stop responding when searching for due date and other fields.
FIX(MC-6822) | MET/TRACK didn't allow which pages to print from a report, it was all or nothing.
FIX(MC-6717) | Search engine fields cannot be typed into.
FIX(MC-6715) | Trace report may yield -121 Sybase error when using user segregates.
FIX(MC-6559) | Searching from the Search Engine may lead to "Invalid Procedure Call or Argument" error.

MET/CAL

Issue Number | Description
FIX(MC-5298) | N5531S Relative TRFL measurement with NMEAS > 1 and no power meter no longer causes "Statement terminated by SRQ.".
FIX(MC-6523) | psa_read would only program ratio reference and ratio units on the first invocation of the function when NMEAS > 1.
FIX(MC-6524) | The PSA (N5531S) run time driver now displays the instrument generated error when a power meter is required, but not connected.
FIX(MC-6541) | Add "Timeout" parameter to the ESA, PSA, & N5531 FSCs
FIX(MC-7055) | If a picture doesn't exist, an error message is not displayed.
FIX(MC-7837) | New option to default a search with no results to the nearest match in the dropdown. The functionality existed in prior versions, but can now be turned off (the default setting).
FIX(MTM-2320) | Resolved guardbanding table lookup issue.


Read Me MET/CAL 7.3 SP1 Build 38

Build 38 was provided as an incremental update to MET/CAL 7.3 SP1. The significant modifications are listed below. .

Quick Sort

Issue Number | Desciption
ADD(MC-6439) | Quick Sort now detects a corrupt proc.dir on startup
ADD(MC-6438) | Quicksort will now create a proc.dir file if it is missing in the chosen procedure directory, rather than terminating.
FIX(MC-6452) | Procedure names shorter than 4 characters may throw unhandled exception when hiding sub procedures.
FIX(MC-5758) | Procedures might get missed when rebuilding the procedure directory, or when saving changes. This results in a "corrupt" proc.dir. Errors E906 occur in MET/CAL Editor.

MET/TRACK

Issue Number | Desciption
FIX(MC-6457) | Labels do not print properly with a Zebra label printer.
FIX(MC-6453) | Combined results now includes test_step2 column.
FIX(MC-6431) | Odd screen flicker may occur on high resolution graphics and/or multiple monitors, with errant dropdown behavior on the search form.
FIX(MC-6410) | Customizing i4202 to not have a title may result in a database error when attempting to delete an asset. The error prevents the asset from being deleted.
FIX(MC-6379) | Import prompt data might not be saved without a warning, if the data type is invalid.
FIX(MC-6374) | Values entered on import prompts may not be saved to Inventory and/or Calibration.
FIX(MC-6293) | Missing rpt file may yield error "Load Report Failed.", rather than indicating the file is missing.
FIX(MC-6226) | Fix to restore file import capability via 2501 field (calresults). New (optional) command parameter is available in for the imp2.exe program.
FIX(MC-6171) | Combining calibrations may not assign FAIL status automatically, if the failed calibration is not the last calibration executed.
FIX(MC-6140) | Type mismatch error occurs when launching Desktops item on Asian operating systems.
FIX(MC-6512) | Printing a report may cause an InvalidPrinterException.

MET/CAL

Issue Number | Desciption
FIX(MC-6499) | The 6100A/6100B/6105A Reference Oscillator did not work properly.
FIX(MC-6476) | 9100 FSC with NOMINAL units of "pct" no longer causes an accuracy file lookup error.
FIX(MC-6395) | The asset entry runtime screen does not properly show Japanese words or Kanji characters.
FIX(MC-6433) | Using the [I>FILE] special construction in 7.3 SP1 causes a buffer overflow which corrupts memory. It only occurs if the file is a relative path. Sometimes, this results in an error stating "System.AccessViolationException: Attempted to read or write protected memory. This is often an indication that other memory is corrupt."
FIX(MC-6413) | 9500 FSC time markers M1, M2, M3, M4 now function properly.
FIX(MC-6342) | Zerbra label printing now functions properly.
FIX(MC-6339) | Brother P-Touch 3600 font incorrectly printed very thin.
FIX(MC-6237) | 6100A/6100B/6105A 2 wire sense did not work properly.
FIX(MC-6236) | Restored the previous behavior of MET/CAL to vary the calibration due date based on non-working days.
FIX(MC-6218) | Using the [O<FILE] special construction in 7.3 SP1 causes a buffer overflow which corrupts memory. It only occurs if the file is a relative path. Sometimes, this results in an error stating "System.AccessViolationException: Attempted to read or write protected memory. This is often an indication that other memory is corrupt."
FIX(MC-6212) | 5522A FSC now properly supports conductance as the evaluation quantity (+Conductance = ...).
FIX(MC-6164) | The printer preferences were not applied when attempting to print from the preview window at the Post-Run dialog.
FIX(MC-6512) | Printing a report may cause an InvalidPrinterException.


Read Me MET/CAL 7.3 SP1

This guide includes additional installation instructions, improvements, and bug fixes associated with the release of Fluke Metrology Software 7.3 SP1. The installation files below are part of 7.3 SP1 distribution.

Installation File | Revision
Fluke-METCAL-7.3.36.msi | 7.3.36
Fluke-METTRACK-7.3.36.msi | 7.3.36
Fluke-METBASE-7.3.36.msi | 7.3.36
Crystal Reports 2008 Runtime SP3 12.3.3.812.msi | 12.3.3.812
Microsoft .NET Framework 3.5 SP1.exe | 3.5.30729.1

Installation Instructions

The installation splash screen has changed, however the installation process has not changed. Refer to the instructions in the Getting Started Guide for new installations. Click the links on the CD Splash screen to launch the various installation programs. Make sure to complete each installation step before initiating the next installation step. Installations cannot run concurrently.

New CD Splash Screen

Upgrades

MET/CAL users upgrading versions prior to 7.3 should follow the installation instructions provided by the installation guide.

Upgrading 7.3 to 7.3SP1

The Microsoft .NET Framework installation has not changed since the release of MET/CAL 7.3. Users that upgrade from version 7.3 can skip this installation step.

As of the time of the release of this MET/CAL service pack, the latest version of the Crystal Reports Runtime is required only to resolve issues associated with Zebra printers. Other issues resolved by the new runtime have not been reported to impact the function of MET/CAL or MET/TRACK. Therefore, upgrade users may choose not to install the new Crystal Reports Runtime unless a Zebra printer is in use. The new Crystal Reports Runtime requires that the previous runtime be uninstalled before installing the new version. Use the Windows Control Panel Uninstall or Add/Remove Programs tool to uninstall the existing version of the Crystal Runtime before a new version is installed.

Specifically upgrading from 7.3 to 7.3 SP1 requires an additional step of running "DB Update for 7.3 to 7.3 SP1" after the MET/BASE installation is complete. This application is included in the Fluke Calibration program group next to the "DB Update" shortcut. The program runs a SQL script to modify MET/BASE to resolve a problem found in earlier versions of MET/CAL. Unlike the main "DB Update" program, the 7.3 to 7.3 SP1 update does not require the MET/BASE database service to be deactivated. Run the program and specify the DSN name and the "mt" user and corresponding password (see figure). Press the Update button to begin the process. The field below the Update button populates with relevant status information. The process takes a couple of minutes depending on the size of the database. The Update button will remain disabled until the process is complete. A completed status message displays in the status window when the update is complete. Close the program and resume with normal MET/CAL operation.

Advanced users can manually execute the SQL script without using the tool. The script file is installed in the MET\BASE programs directory on the MET\BASE server PC. The default path and file name are listed below. Custom installations may differ from the default.

"C:\Program Files\Fluke\METBASE\dbupdate\ metbase-7.3-3.sql "

DBUpdate 7.3 to 7.3 SP1

New Features

MET/CAL

Issue Number | Description
MC-5559 | Procedure packing can now be performed on procedures that are not in the current procedure directory defined by the metcal.ini file.
MC-3932 | A new NVI FSC for the Fluke 5522A Calibrator was created. Refer to the MET/CAL FSC help for information on the feature.
MC-4425 | The following baud rates are now supported: 57600, 230400, and 256000.
MC-5749 | A new version of Quick Sort has been released to work with the changes made in MET/CAL 7.3.
MC-5653 | O_CAL NVI FSC to control the 5080A/SC200, 5500A-SC, 5500A-SC300, 5500A-SC600, 5520A-SC1100, 5800A, and 5820A.
MC-5468 | The 9640 FSC now supports Option 9600FC "Frequency Counter". Refer to the MET/CAL 9640 FSC help for details.
MC-5515 | The DOS program correct.exe now displays a console Window when executing
MC-5449 | 5080A FSC now supports 5080A option 5080A/MEG Megometer Calibration.
MC-5256 | A new FSC for the Fluke 9640A-LPNX RF Reference Source was created. Refer to the MET/CAL FSC help for operational details.
MC-1554 | Add edge rise time specifications to 5520A accuracy files for use with ACCV MATH function
MC-5490 | The 9640 FSC now supports Option 9600FC "Frequency Counter".

MET/TRACK

Issue Number | Description
MC-5749 | A new version of Quick Sort has been released to work with the changes made in MET/CAL 7.3
MC-5747 | Screen customization form displays a hint to switch to the default desktop for full customization options, if user is not running on default desktop.
MC-5321 | Entering RETURN on new password field accepts changes and closes the dialog.
MC-4657 | Add, delete and search features were added to the Linked validation setup screen.
MC-4559 | Updated text on label set selection screen, to match language selections.
MC-5963 | New command line import utility. The command line arguments and examples of use are documented at the end of this readme guide.
MC-5705 | Import now supports the import of assets assigned to a customer already entered into MET/TRACK. The customer record is matched on Name (K4602). Review the Import section of this document for details.

MET/BASE

Issue Number | Description
MC-5909 | 9640A accuracy file was updated with Mode blocks for Firmware < 3 and >= 3
MC-5851 | The 5520A 90 day accuracy file now contains 5520A-SC600 and 5520A-SC1100 pulse width accuracy.
MC-5850 | The 5820A accuracy file now contains pulse width accuracy.
MC-5849 | The 5800A accuracy file now contains pulse width accuracy.
MC-5848 | The 5500A 1 year and 90 day accuracy files now contains 5500A-SC600 pulse width accuracy.
MC-5670 | The 9640A is now supported by the SWPG flexible driver.
MC-5654 | 1 year and 90 day accuracy file for the Fluke 5522A Calibrator.
MC-5628 | 5080A accuracy files now contain specifications for the 5080A/SC200 Oscilloscope Calibration Option.
MC-5546 | Cloned the 6681.acc to 901.acc so procedures executing with LFCTR aliased to configured instrument "Wavetek 901" do not generate an error
MC-5448 | 5080A accuracy files now contain specifications for the 5080A/MEG Megohm Meter Calibration option.
MC-5257 | 1 year accuracy file for the 9640A-LPNX

Corrections

MET/CAL

Issue Number | Description
MC-5736 | Mod1 fields in the database are now populated when the MOD1 in a MEMC/MEMCX cannot be parsed into numeric, prefix, and unit.
MC-5479 | A "Cannot commit cal summary" error could occur at the end of a calibration preventing calibration data from being saved. The error was caused when MET/CAL did not add fields that were required defined to the database. The problem has been resolved.
MC-5480 | Windows ODBC tracing did not function properly when the MET/CAL Runtime was active.
MC-5513 | The correct.exe program did not properly handle paths provided by the metcal.ini file. All related issues have been resolved.
MC-5520 | User defined units were not properly written to the database.
MC-5548 | Users assigned to specific segregates were not able to add assets in their segregates. The issue is now resolved.
MC-5719 | Losing a Network connection during runtime no longer crashes MET/CAL. MET/CAL will now check the database connection before attempting to write the results. If the connection is invalid, it will prompt the user to reconnect.
MC-5679 | The 5520A FSC Line w/coil did not change the output of the calibrator. The following line now functions properly: 1.008 5520 1000 20.0A 2% 0.5U 50H SI LFX
MC-5751 | The 6100A FSC did not function properly on +Frequency. The problem is now resolved.
MC-5473 | MET/CAL would close while saving a standard that was incorrectly listed twice, once in the instrument configuration, and once as a manual standard. The problem is now resolved.
MC-5504 | Fixed an issue where MET/CAL would close if the Crystal Reports run times was not installed. The runtime is still required, however the error message is more descriptive of the problem.
MC-5451 | MET/CAL would close when a report that does not exist is selected at the end of calibration. The problem was resolved.
MC-5785 | Requiring 2340 on the Calibration Entry Screen no longer causes MET/CAL Runtime to fail validation when completing a calibration.
MC-5529 | Linked validation data with invalid information would cause MET/CAL to close. The issue is now resolved.
MC-5655 | The DFile() Math function did not return a DOS consumable path. This caused some DOS applications not to function properly when using the results of DFILE as a command line argument. DFILE now returns a DOS consumable path.
MC-5483 | Using the "mt" user would cause MET/CAL to close during login. The issue is now resolved.
MC-5481 | The RSLT statement with curly braces, 1.001 RSLT ={a} did not function properly. The issue is now resolved.
MC-5727 | Validation values are no longer forced to uppercase.
MC-5804 | MET/CAL Editor no longer shows "Change password" as hint when pointing to Window menu.
MC-5735 | The help file description for PSUBI is incorrect. It should say "PSUBI is case-insensitive". Reference the MET/CAL FSC help for more details.
MC-5495 | Required fields that are already populated by defaults or source copies will not be prompted for at the end of a calibration.
MC-5486 | Fixed an issue that was not allowing MET/CAL to write errors to the event viewer in Windows 7.
MC-5458 | Import now supports adding "standards used" records, consisting of I4201, C2301, C2333 and I4201 of the asset that represents the standard used. With the -incal option, only standards in cal at the provided date and time (C2301/C2333) are accepted.
MC-5530 | Fixed an issue where bad fixed validation data causes assets to not be saved
MC-6007 | Characters outside the regular alphabet (like German Umlaute) might not import correctly.
MC-5511 | Procedures that are open now properly display under the Window menu in the MET/CAL Editor.
MC-5522 | Test results were not written in the proper order when a Post Test Repeat option was used from the MET/CAL Runtime.
MC-5527 | Multiple line text overlays are now properly supported in the PIC FSC.
MC-5482 | Resolved a problem that would cause a failed calibration to get a calibration due date set to the future.
MC-5686 | The 6100 FSC L1IUUTCurrClamp did not function properly.
MC-5744 | Labels using Zebra Printers did not print correctly with Crystal Reports 2008SP3. Changes to MET/CAL and a new version of the Crystal Reports runtime are required to resolve the problem.
MC-6014 | Corrected the spelling of COM port. In some error messages the text was displayed as "COMM".

MET/TRACK

Issue Number | Description
MC-5988 | Adding a field to linked validation may cause the dropdown to show duplicates of the fields available.
MC-5906 | Fast double-clicking a field in forms layout may lead to 381 error.
MC-5892 | Internal changes in the MET/TRACK calls to Crystal Reports, to address label printing issues.
MC-5826 | Core tab on Data Browser did not get updated when inventory data was modified and saved
MC-5824 | Unique key violation error when combining calibrations.
MC-5765 | Warning when turning on duplicate serial number check feature - manufacturer and model required on save.
MC-5760 | Advanced Global Change option did not function properly.
MC-5744 | Labels using Zebra Printers did not print correctly with Crystal Reports 2008SP3. Changes to MET/CAL and a new version of the Crystal Reports runtime are required to resolve the problem.
MC-5739 | MET/TRACK did not memorize screen sizes when editing layouts in the admin menu.
MC-5706 | Menu item "Limit toolbar results to 500" made translatable.
MC-5699 | Assigning only selected columns on Data Importation may fail with an import error.
MC-5698 | Fixed an issue where the import utility cannot run on a client only install.
MC-5693 | MET/TRACK database tags now created in same fashion as MET/CAL Runtime asset tags.
MC-5690 | Crystal Reports without a title in the summary information may fail to install.
MC-5677 | Editing validation data might result in 'out of storage space' message or unexpected shutdown of the application.
MC-5676 | Standards list view may display duplicate entries in standards column.
MC-5674 | Inventory record might not save if the serial number is blank and the option to warn about duplicate serial numbers is turned on.
MC-5673 | May receive error message when combining calibrations.
MC-5664 | Blank source copy value in data validation might be read as if a default value of <BLANK> is to be added to the field.
MC-5660 | A restored field was not immediately available for linked validation.
MC-5568 | Quick Reports might not properly link-in data from the customers table.
MC-5567 | The license report has been updated for 7.3.
MC-5566 | >SPEC field suppressed on rt_report_of_cal_with_exp_uncert.rpt.
MC-5564 | Syntax error near FROM when searching by customer ID or name from toolbar.
MC-5560 | Inserting a cal record on a custom segregate might yield a bogus permissions error.
MC-5558 | May receive error 94 - invalid use of NULL when adding standard to cal record.
MC-5553 | Cloning an asset on the STD segregate may yield 'asset not found' errors
MC-5551 | When trying to edit inventory without permission, the inventory form might load and become inaccessible.
MC-5550 | Unable to add a standard from a user segregate
MC-5526 | Input focus not on first field when creating new records.
MC-5525 | Cannot add "no cal required" standards to a calibration record.
MC-5510 | May receive "..Operation was canceled.." error when viewing an attached PDF and skipping records
MC-5509 | May receive unique index violation on Description, when installing reports.
MC-5506 | Clicking the STD Table button on the calibration screen may yield error 94 - Invalid use of null.
MC-5500 | On certain screens, like editing merge data, a period (.) is interpreted as if the delete key was pressed.
MC-5499 | May receive database error 3021 when moving sliders to resize fields on field customization admin menu.
MC-5488 | May receive SQL error when modifying tab order on non-default desktop.
MC-5485 | Might encounter type mismatch error when dropping connections in admin menu.
MC-5477 | May receive generic automation error if Crystal Reports runtime not installed. A more specific error is now presented.
MC-5445 | May receive bogus error message insert of STD "x" failed, when adding standards to an existing calibration record.
MC-5349 | Licenses in use screen wording corrected. Consumed MET/CAL LITE licenses were not correctly accounted for on License tab.
MC-4501 | Disallow duplicate validation entries

Changes

MET/CAL

Issue Number | Description
MC-5733 | Crystal Reports was upgraded from 10 to 2008 for MET/CAL 7.3 in order to support Crystal Reports on Windows Vista and Windows 7. Unfortunately, the Crystal Reports viewer that comes with CR 2008 no longer has the ability to email PDF files using MAPI. To email a file, first export to PDF, then send those files out as attachments.
MC-3845 | Removed (changed to NA) 5500/CAL DC accuracy for torroidal UUTs, from 5500A and 5520A accuracy files
MC-5557 | The CTAG identifier was changed to a globally unique identifier (GUID) encoded in 32 characters. The value was previously created by using I4201 + ":" + timestamp. Be advised that this change may impact reports and custom queries.
MC-5554 | Crystal Reports 2008 will run slower when accessing reports that have a DSN that differs from the active DSN in use by MET/CAL or MET/TRACK. All reports shipped with MET/CAL include the DSN "Calibration Data". If a single DSN is used that differs from the default, reporting performance can be increased by opening the affected reports in the Crystal Designer and re-saving them with the new DSN. In a multi-DSN environment, it's recommended to create reports specific to the DSN and store them with unique names or in an alternate directory structure.
MC-5711 | Users below level 5 cannot run a MET/CAL procedure. Although this is the documented behavior of the program, previous versions of MET/CAL did not enforce this limitation. If a user cannot run a procedure please use MET/TRACK and assign the proper user level.
MC-3003 | Updated 5520 Accuracy Files As Needed Per FPM_SPECS Report #26999
MC-5844 | To fix printing issues on label printers, users should upgrade to the latest Crystal Report Runtime distributed with MET/CAL 7.3 SP1.

MET/TRACK

Issue Number | Description
MC-5743 | The MET/TRACK search toolbar returns values that best match the searched text. Instead of providing an empty form indicating "no record", a search item is returned even when a specific match is not found. Prior to displaying the form, the search toolbar text field highlights red when a match is not found.

Command Line Import

The imp2.exe program was added to the Fluke Calibration Software installation in version 7.3 SP1. See the import section for specific details on the import tool.


Read Me MET/CAL 7.3

-------------------------------------------------------------------------------

-------------------------------------------------------------------------------

Fluke Calibration Software 7.3

MET/CAL 7.3.18

Released: 2010-08

-------------------------------------------------------------------------------

Section 1: Table of Contents -------------------------------------------------

-------------------------------------------------------------------------------

1. Table of Contents

2. Introduction

3. Installation/Upgrade

4. What's New

Describe new features and changes relative to prior versions

5. Bug Fixes

6. Documentation

Overview of product documentation

7. Accuracy and Help File Information

8. Contacting Fluke

How to contact Fluke with MET/CAL questions, problems,

or suggestions.

-------------------------------------------------------------------------------

Section 2: Introduction ------------------------------------------------------

-------------------------------------------------------------------------------

The Fluke Calibration Software distribution version 7.3 is a major upgrade

to prior versions. A long list of enhancements and improvements are

detailed below. The most significant changes are the support of Sybase 11,

Crystal Reports 12, and newer Microsoft operating systems. In particular

particular, Windows Vista and Windows 7. Supporting the new operating

systems requires a different default directory structure and that the

metcal.ini file no longer be placed in the root of the Windows directory.

A detailed map of the new file locations is listed in the Getting Started/

Installation Guide.

Refer to the previous "readme" files for changes in interim versions of

MET/CAL.

-------------------------------------------------------------------------------

Section 3: Installation/Upgrade

-------------------------------------------------------------------------------

Reference the Getting Started/Installation guide for details on how to

upgrade MET/CAL. Follow the same steps to upgrading MET/CAL or

install a version for the first time.

Prior to installing, ensure that the PC has the minimum system

requirements. The .NET Framework 3.5 SP1 must be installed. A link

to the installation is included with the Fluke Calibration Software

Installer. Ensure that MET/BASE is installed and active on the server

system (or the local PC if a server is not in use). The MET/BASE shared

directory must be known during the installation. Stop any active programs

from running, then install MET/CAL. Follow the prompts to complete the

process then install the Crystal Reports Runtime unless it has already been

installed.

-------------------------------------------------------------------------------

Section 4: Enhancements/Changes

-------------------------------------------------------------------------------

---->Crystal Reports 12 Runtime

Report Number:MC-5330

Added support for Crystal Reports 12 also known as and 2008.

---->Procedure Record Author... to Company Name...

Report Number:MC-5236

The screen that prompts the user for metcal.ini "ptitlel" in the

installer has been changed to "Company Name" and the text has been

changed to "Enter your company name."

---->Simplify upgrade process

Report Number:MC-5227

The installer has been updated to simplify the upgrade process.

---->Move all start menu items to a single folder

Report Number:MC-5089

All products now install under a single Start Menu entry, "Fluke Calibration"

---->Pre-load the path in compiled procedure related UI (pack, unpack,

copy,...) with procdir path

Report Number:MC-5058

The Save, Pack, and Unpack paths are now set to the procdir

directory by default.

---->Short cut names are inconsistent

Report Number:MC-5005

The shortcut naming for the products have been changed for clarity

and consistency.

---->Move Prompt and Form Files

Report Number:MC-4984

All form (*.frm) and database prompt files are now stored in the

MET/BASE shared location by default. Reference the Getting Started/

Installation guide for a map of all file locations.

---->Move metcal.ini to %ProgramData%\Fluke

Report Number:MC-4983

To facilitate Windows Vista and Windows 7, the metcal.ini file has

been moved out of the Windows directory. It is now stored in

%ProgramData%\Fluke.

---->First time install should have defaults for temperature, humidity,

and 2322 in pre-run "Enter Data" dialog

Report Number:MC-4951

The pre-run prompt screen in the MET/CAL Runtime now includes

defaults for temperature and humidity.

---->Unhide %ProgramData% during installation

Report Number:MC-4944

A shortcut to the Fluke Program Data has been added to the Start

Menu "Fluke Calibration" program short-cut.

---->Allow "Video" as a value for PSA FSC Averaging parameter and map to

"Log Power"

Report Number:MC-4853

PSA FSC now supports "Averaging = Video". Refer to the FSC help

for more details.

---->Add support to set the Frequency Counter Resolution to PSA FSC

Report Number:MC-4819

The PSA FSC now supports Frequency Counter Resolution.

---->Add "Local" action to 5320 FSC

Report Number:MC-4818

5320 FSC now supports the "Local" action.

---->Add support to set the Amplitude Scale to PSA FSC

Report Number:MC-4813

PSA FSC now supports setting the amplitude scale.

---->Change output sense default from 2-wire to 4-wire in

6100A/6100B/6105A driver

Report Number:MC-4801

6100 FSC default has changed from 2-wire to 4-wire, when

OutputSense is not specified.

---->About Windows overhaul

Report Number:MC-4744

The about window has been replaced with one that shows additional

information. It now shows user details, user permissions, and

workstation information.

---->Capture Stack Trace to Event Log

Report Number:MC-4740

If an unhandled error occurs and MET/CAL crashes, the error details

are logged to the event log. The event log is viewed using the

event viewer (start -> run -> eventvwr.msc). In the Application

log, look for an Error event with a Source of "MET/CAL". Open the

event and click the button to copy everything to your clipboard,

the send an email to MET/SUPPORT with the details.

---->MET/CAL reports E9922: 53131A: OPTION 050 not installed

Report Number:MC-4596

The firmware in the HP 53132A has been updated to correctly report

option 50. MET/CAL has been updated to match this change.

---->New Username/Password Dialog

Report Number:MC-4434

The default MS ODBC login screen has been replaced with a custom

login screen to support database layer changes.

---->Added support for the following baud rates: 57600, 230400, & 256000

Report Number:MC-4425

The following baud rates are now supported: 57600, 230400, and

256000.

---->Add ability to access an accuracy file for a System Instrument

configured as an auxiliary device, which is separate from the

accuracy file of the primary device

Report Number:MC-4422

Added ability to access an accuracy file for a System Instrument

configured as an auxiliary device which is separate from the

accuracy file of the primary device. For example the reference

accuracy calculation for the Fluke 5080A with a 5500A/COIL, will

entail an accuracy lookup from the a 5080A accuracy file, and a

5500A/COIL accuracy file.

---->Device map "9100 COIL" to "Datron 9100 Opt200" and vice-versa

Report Number:MC-4420

The System Instrument name "9100 COIL" has been mapped to "Datron

9100 Opt200" and vice versa.

---->Device map "Fluke 5500A-COIL" to "Fluke 5500A/COIL" and vice-versa

Report Number:MC-4419

The System Instrument name "Fluke 5500A-COIL" has been mapped to

"Fluke 5500A/COIL" and vice versa.

---->MATH VersionCheck for 7.3

Report Number:MC-4223

The version format has been changed from the alphanumeric format

(i.e. 7.20x) to a pure numeric format (i.e. 7.2.51). This allows

the user to more easily see when the version has been increased.

The MATH FSC VersionCheck() has been updated to handle the new

version format as well as the check between the old format style.

---->Beep ini file parameter does not work with PIC or PICE

Report Number:MC-4044

MET/CAL will now beep on the PIC and PICE FSC statements if beeping

is turned on. To support different configurations, both the PC

speaker and sound card will attempt to beep. The PC speaker and

soundcard can be enabled or disabled in Device Manager. The

"Default Beep" for Windows that plays on the sound card can also

be modified in Control Panel > Sounds and Audio Devices.

---->Add .png Image Support

Report Number:MC-3415

The PIC and PICE FSCs now support PNG and TIFF file formats. PNG is

a good default choice for a saving your pictures. The .wmf and .emf

Windows Metatfile formats are no longer supported due to security

vulnerabilities. The ampersand character '&' no longer underlines

the next character in the text overlays. It will be displayed in

the text.

-------------------------------------------------------------------------------

Section 5: Bug Fixes

-------------------------------------------------------------------------------

---->MET/CAL Lite: Configuring a 5500A with the 5725A check box selected

causes E2915: Unknown device code: 11.

Report Number:MC-5338

MET/CAL Lite now supports the 5725A connected to a 5500A.

---->ODBC DSN removed on uninstall

Report Number:MC-5326

The Calibration Data DSN now persists after all Fluke products are

removed in order to preserve customer data.

---->Large pictures do not on screen

Report Number:MC-5310

For PIC and PICE FSC statements, if a picture is too big for the

display, it will be automatically resized to fit in the display.

The picture will keep its aspect ratio within the window.

---->Compiling N5531 Relative Tuned RF Level statement causes an

accuracy lookup error due to invalid mode string

Report Number:MC-5304

N5531 FSC Tuned RF Level statements now compile without error, when

all values are specified (i.e. no values are taken from a register

or named variable), and a PSA asset number is specified in the

instrument configuration.

---->6100 +L1Power = -93.97VAR generates E7587: FSC 6100: Parameter

"L1Power", value -93.97. Limits are 0 to 1.0332e+006.

Report Number:MC-5295

6100 FSC again allows negative power when units are

Volts-Amps-Reactive. V7.20 SP3 only allowed positive power in VAR.

Prior to SP3 the check was not performed.

---->mcz-wrap.exe doesn't pass --install to mcz.exe

Report Number:MC-5294

The .mcz file association is now made by MET/CAL at install time.

---->Non admin users can not install procedures from CD

Report Number:MC-5262

The MCZ file association is now installed as a part of the MET/CAL

installer.

---->Update _9640_tst, in 9640_r.cpp, to recognize a Fluke 9640A-LPNX

Report Number:MC-5255

MET/CAL 7.3 allows a 9640A-LPNX to be configured as a "Fluke

9640A", and controlled using the 9640 FSC. However, this only

allows access to 9640A-LPNX functions also supported by the 9640A.

In addition, 9640A accuracy will be used.

---->MATH FSC functions WIF and RIF write and read to/from the Windows

directory when RifWifDir is not specified in the MET/CAL

iniitialization file

Report Number:MC-5249

Added the following items to a new install:

1) Two new directories in %ProgramData%\Fluke, IniFiles and

MathFiles

2) Add the following params to the metcal.ini for a new install:

- RifWifDir pointing to %ProgramData%\Fluke\IniFiles

- MathFileDir pointing to %ProgramData%\Fluke\MathFiles

---->Correct issue with .new files

Report Number:MC-5235

The .new files have been moved to the shared file location in the

MET/BASE install and are now installed under

%ProgramData%\Fluke\METBASE\shared\CorTemplates

---->Install Failed Due to ODBC / Sybase Problem

Report Number:MC-5218

ODBC settings are not removed during an update.

---->Can't do a 7.3 install without uninstalling 7.2

Report Number:MC-5199

The 7.3 install can be run with older versions of the software

installed, so user data is not removed during the uninstall of the

old version and the old version can be more easily rolled back.

---->The INI function in the MATH FSC should provide a DOS compatible

path in return when a new "ini" file parameter is active.

Report Number:MC-5161

The MATH INI function will now return the short DOS 8.3 path string

for paths (files and directories) in the "startup" section. This is

done to avoid problems with spaces in path names being passed to

DOS/DOSE FSCs.

---->The IFILE function in the MATH FSC should provide a DOS compatible

path in return when a new "ini" file parameter is active.

Report Number:MC-5139

The IFILE MATH FSC function returns the DOS 8.3 path format in

order to support paths with spaces and the existing utility

executables.

---->9640 FSC Operate statement causes run time error

Report Number:MC-5103

"Operate" action now works properly for the 9640 FSC.

---->6100/6100B/6105A FSC Learn modes generates error if Line Locking is

enabled

Report Number:MC-5087

6100 FSC Learn modes no longer generates an error if Line Locking

is enabled.

---->6100B Learn Mode (F7) creates invalid parameter value for

OutputSense

Report Number:MC-5083

6100B Learn Mode (F7) no longer creates an invalid parameter value

for OutputSense.

---->Microsoft .NET Framework 3.5 SP1 is required

Report Number:MC-5056

The .NET 3.5 SP1 framework is now required and included in the installation

options.

---->Data Sources (ODBC) 32-bit

Report Number:MC-5040

Shortcuts for the Windows 32-bit ODBC manager are now installed by

default.

---->6100, 6100B, & 6105A FSCs do not restrict <ph>PowerFactor to be the

evaluation quantity

Report Number:MC-5031

6100 FSC no longer restricts <ph>PowerFactor to be the evaluation

quantity.

---->6101A with HC attribute in subprocedure CONFIGURATION line does not

cause HC option to be included in REQUIRED SYSTEM INSTRUMENTS

prompt

Report Number:MC-5028

Required equipment dialog now includes "High Current Option" for

6101A L2, L3, and N, when applicable.

---->Move FSC Help and Manuals to %ProgramData%Fluke\Help

Report Number:MC-4988

All manuals, program help, and FSC help are now installed with the

clients to facilitate the new Windows help format.

---->MCRHT.exe for 5000A-RH/T does not work without dll

Report Number:MC-4982

MCRHT.exe is used to get the relative humidity and temperature from

a 5000A-RH/T. It does not work without installing Spectrum.dll

0.3.0.5 from MET/SUPPORT. MET/CAL now ships with that dll and

downloading it is no longer required.

---->Safety symbol not displayed for 5320A Voltage Calibrator AC Output

between 29.99 and 59.99 Vrms

Report Number:MC-4974

Safety symbol is now displayed for 5320A Voltage Calibrator AC

Output down to 29.99 Vrms

---->6100A/6100B/6105A Power/Voltage/Current/Offset accuracy incorrectly

determined when Flicker, Fluctuating Harmonics, Dip/Swell or

Interharmonics are applied.

Report Number:MC-4930

6100A Power/Voltage/Current/Offset accuracy is now correctly

determined when Flicker, Fluctuating Harmonics, Dip/Swell or

Interharmonics are applied.

---->MATH IFILE() should return quoted metcal.ini location

Report Number:MC-4917

The MATH IFILE function returns new metcal.ini file location.

The file location is quoted to support spaces. It also returns

slashes rather that backslashes. In this example:

1.001 MATH s[1] = ifile()

1.002 DOS -x correct.exe [s1] 5700 init

S[1] evaluates to this on Windows XP:

"C:/Documents and Settings/All Users/Application

Data/Fluke/COMMON/metcal.ini"

---->DOS FSC not working if user_prog_dir has spaces

Report Number:MC-4912

The DOS FSC now works if the user_prog_dir has spaces.

---->Copy forward fails at the end of runtime

Report Number:MC-4905

Fixed an issue in MET/CAL Runtime where a copy forward value

containing a single quote causes a SQL error, and a the

calibration fails to save. Calibrations now save properly when a

copy forward value with a single quote is used.

---->61xx Power accuracy incorrectly determined when power units are VAR

Report Number:MC-4886

6100A Power accuracy is now correctly determined when power units

are VAR.

---->MC-4826

METCAL - Add OS check to installer

Report Number:MC-4873

Windows 2000 is no longer supported for the 7.3 products.

---->PSA FSC statement with AverageCount = 10 causes Operation Complete

(OPC) error

Report Number:MC-4856

PSA FSC statement with AverageCount = 10 no longer causes Operation

Complete (OPC) error.

---->Sybase SQL Anywhere 11

Report Number:MC-4790

Sybase SQL Anywhere has been upgraded from version 8 to version 11.

This enables us to support Windows Vista, 7, 2008 and 64-bit

platforms.

---->Customer fields do not "Scopy"

Report Number:MC-4789

Source copy (scopy) for customer fields are now properly supported

by MET/CAL.

---->Failure to draw High Voltage bitmap results in crashing program and

losing all progress.

Report Number:MC-4743

The safety window code that gets displayed during high voltage has

been replaced. Under certain obscure conditions, the bitmap image

in the window would fail to draw and crash MET/CAL.

---->TUR report causes E4991: Internal Error: T.U.R. report line too

long, when reference accuracy is very small or test tolerance is

very large

Report Number:MC-4739

E4991: Internal Error: T.U.R. report line too long, is no longer

generated when reference accuracy is very small or test tolerance

is very large.

---->PSA FSC does not accept short form of parameter RFCoupling

Report Number:MC-4736

PSA FSC now accepts short form of the parameter RFCoupling.

---->Entering a 31 character variable name in the Editor causes a GPF

Report Number:MC-4718

Entering a 31 character variable name in the Editor no longer

causes a GPF

---->Linked validation does not work correctly when entering new asset

from Run Time

Report Number:MC-4656

Linked validation where there are duplicates in the root field are

now handled by showing a prompt of all valid entries for linked

fields. The user can select the linked values from a list instead

of the first entry being chosen by default.

---->MET/CAL Runtime copyright years off, out of sync

Report Number:MC-4645

MET/CAL has a new splash screen that will dynamically display the

specific version when launching.

---->Single procedure with over 999 tests causes buffer overflow in

function fmt_step in fmt_rslt.cpp

Report Number:MC-4626

Single procedures with over 999 tests no longer cause a legacy

results formatting error.

---->Error at end of MET/CAL Runtime after previewing a report.

Report Number:MC-4625

Fixed an issue with the Crystal Reports viewer causing an error

after MET/CAL is closed.

---->Discard Calibration Data radio button does not work

Report Number:MC-4599

In 7.2 SP3, the Post Run Results dialog allows you to select

"Discard Calibration Data" or "Discard All Data for UUT", but it

does not discard the saved data. This has been fixed and those

radio buttons now discard the saved data.

---->Adding Instrument Alias then pressing cancel gives error and bails

totally

Report Number:MC-4597

Fixed an issue creating an instrument alias.

---->NVI FSC w/code > 255 (V3 compiled format) and STD FSC in same

procedure causes E100: Unspecified error (cp_storeproc_V3 : FSC

size less than zero).

Report Number:MC-4435

NVI FSC causes E100: Unspecified error (cp_storeproc_V3 : FSC size

less than zero).

Fixed an issue with the NVI FSC.

---->Add 2Wire and 4Wire as legal values for 5320 FSC Sense parameter

Report Number:MC-4432

The values "2Wire" and "4Wire" are now legal parameters for the

5320 FSC sense parameter.

---->Incorrect description of parameter name short form in NVI FSC help

files

Report Number:MC-4431

Incorrect description of parameter name short form in NVI FSC help

files.

Corrected the help file for parameter name requirements.

---->Device map Agilent ESA-E and ESA-L Series Spectrum Analzers

Report Number:MC-4421

Device mapped Agilent ESA-E and ESA-L series spectrum analyzers.

---->365 day accuracy file for 9100 Option 200 (10- and 50-turn coil)

Report Number:MC-4415

Added alternative 365 day accuracy file for 9100 Option 200 (10-

and 50-turn coil) for use with the 5080A FSC, and other NVI FSC do

be released in the future.

---->SP3 breaks 8508 procedure

Report Number:MC-4411

The accuracy files shipped with 7.2 SP3 breaks 8508 procedure. The

affected files have been fixed.

---->Legacy Results Not Written / Written Incorrectly

Report Number:MC-4408

Fixed an issue with legacy results not being written to the

database correctly.

---->Add VAR (Volt-Amps Reactive) to UnitsList, which is used by the

MATH FSC UNITS function and NVI FSCs (except 6100)

Report Number:MC-4404

Added the unit VAR (Volt-Amps Reactive) to the units list, which is

used by the MATH FSC UNITS function and NVI FSCs (except 6100).

---->5800 FSC does not allow MOD2 = FE (Fast Edge) when 5800A-GHz option

is configured

Report Number:MC-4400

The 5800 FSC now correctly supports the Fast Edge feature.

---->5820 FSC statement with MOD2 = FE (Fast Edge) does NOT cause

attribute G2 (5800A-GHz Option) to be included in CONFIGURATION:

Fluke 5820A in procedure header

Report Number:MC-4399

5820 FSC statement with MOD2 = FE (Fast Edge) does NOT cause

attribute G2 (5800A-GHz Option) to be included in CONFIGURATION:

Fluke 5820A in procedure header. Using the Fast Edge statement now

correctly adds the G2 attribute in the configuration in the

procedure header.

---->PSA FSC defaults Option 123 "µW Preselector Bypass" to enabled (on)

for center frequencies greater than 3 GHz. The default should be

off.

Report Number:MC-4390

PSA FSC now defaults Option 123 "µW Preselector Bypass" to disabled

(off) for center frequencies greater than 3 GHz.

---->PSA FSC unconditionally requires Option 123 "µW Preselector Bypass"

for center frequencies greater than 3 GHz

Report Number:MC-4389

PSA FSC no longer unconditionally requires Option 123 "µW

Preselector Bypass" for center frequencies greater than 3 GHz.

---->Memory leak starting MET/CAL Editor

Report Number:MC-4368

Fixed a memory leak when starting the MET/CAL Editor.

---->Add support for the Fluke 6105A Electrical Power Standard

Report Number:MC-4268

FSC for the Fluke 6105A Electrical Power Standard

---->Add support for the Fluke 5080A Calibrator (Pan Gu)

Report Number:MC-3881

Added support for the Fluke 5080A via the 5080A NVI FSC and 1 year

accuracy file. Refer to the help file for the 5080A FSC for more

information.

---->Add support for the Fluke 6100B Electrical Power Standard

Report Number:MC-3876

FSC for the Fluke 6100B Electrical Power Standard

---->Add support for the Fluke 6100A/6100B/6105A Energy Counting Option

Report Number:MC-3870

The 6100A Energy Counting Option is now supported for 6100A's with

firmware revision 5.06 or later.

---->Writing to the database is slow from MET/CAL Runtime sometimes

Report Number:MC-3601

Improved database performance for in the 7.3 branch of MET/CAL.

---->bug in linked validation when adding asset with MET/CAL Runtime

Report Number:MC-3563

Linked validation where there are duplicates in the root field are

now handled by showing a prompt of all valid entries for linked

fields. The user can select the linked values from a list instead

of the first entry being chosen by default.

---->DISP FSC causes E1901: "Not enough space for evaluated message." at

run time

Report Number:MC-3455

If the max 56 character line length is exceeded, the line will be

truncated to 56 characters and "..." is appended to indicate there

were more characters that are not being displayed.

---->Required field "C2303" - conflict with MET/CAL, cal int "0", int

type "N"

Report Number:MC-3427

There is no longer an issue saving calibrations when the C2303 is

required.

---->Modify MET/CAL to Allow "metcal.ini" Not To Be in Windows Directory

Report Number:MC-3064

In order to support the Windows standard directory structure,

metcal.ini is has been moved from %windir%\metcal.ini to

%ProgramData%\Fluke\metcal.ini.

---->Add support for the Clarke-Hess 8100 Transconductance Amplifier

Report Number:MC-2475

FSC for the Clarke-Hess 8100 Transconductance Amplifier

---->Add support for the Agilent ESA (Economy Spectrum Analyzer) Series

Report Number:MC-2433

Added support for the Agilent ESA-E and ESA-L Series Spectrum

Analyzers via the ESA NVI FSC as well as a 1 year accuracy file.

Refer to the help file for the ESA for more information.

-------------------------------------------------------------------------------

Section 6: Documentation -----------------------------------------------------

-------------------------------------------------------------------------------

FlexibleStandards.pdf

This document provides an overview of the MET/CAL

implementation of procedure-based flexible standards.

"Flexible standards" is a technique which allows

a procedure to be written in a manner independent

of the particular reference instruments used to

calibrate the unit under test (UUT).

GettingStarted.pdf

This is the MET/CAL Getting Started Guide.

Guardbanding.pdf

Describes MET/CAL support for guardbanding.

QuickReference.pdf

This is the one-page hot keys sheet which shows the

hot keys used by MET/TRACK and the MET/CAL Editor.

ReferenceManual.pdf

This is the MET/CAL Reference Manual.

Please use the MET/CAL Editor's on-line help for the

new FSCs not included in the MET/CAL Reference

Manual.

In some cases the Editor's on-line help files may differ

from the PDF reference manual. In this case please rely on

the Editor's on-line help files.

ResultsTable.pdf

This document lists the MET/CAL result quantities

and shows the new database Results Table column names.

RHT-HartScientific-1620A.pdf

This document explains how to use the Hart 1620-H,

Hart 1620-S, Fluke 5020A, and Fluke 5020A-S

Thermo-Hygrometers with MET/CAL V6.11 and later

(including MET/CAL V7.00, V7.01, V7.10, V7.11,

and V7.20).

RHT-Fluke-5000A.pdf

This document explains how to use the Fluke 5000A

RH/T Precision Humidity and Temperature Data Logger

with MET/CAL V6.11 and later (including MET/CAL V7.00,

V7.01, V7.10, V7.11, and V7.20).

METCAL_Users_Manual.pdf

This is the MET/CAL Users Manual.

METTRACK_Users_Manual.pdf

This is the MET/TRACK Users Manual.

-------------------------------------------------------------------------------

Section 7: Accuracy and Help Files -------------------------------------------

-------------------------------------------------------------------------------

This release includes a number of updated and new accuracy files.

If you have customized accuracy files on your system please backup

your accuracy files before installing.

Help files for all new FSCs are included.

-------------------------------------------------------------------------------

Section 8: Contacting Fluke -------------------------------------------------

-------------------------------------------------------------------------------

For assistance and questions regarding Fluke Calibration Software

please contact MET/SUPPORT at:

phone: 1 (800) 825-7411

email: MetSupport@fluke.com

European customers may contact the MET/SUPPORT group in

Europe via email at:

email: MetSupport@fluke.nl


Read Me MET/CAL 7.2 SP3

-------------------------------------------------------------------------------

-------------------------------------------------------------------------------

Fluke Calibration Software 7.2 SP3

MET/CAL 7.2.51 (7.20Z)

Released: 2009-10

-------------------------------------------------------------------------------

Section 1: Table of Contents -------------------------------------------------

-------------------------------------------------------------------------------

1. Table of Contents

2. Introduction

3. Enhancements

4. Bug Fixes

-------------------------------------------------------------------------------

Section 2: Introduction ------------------------------------------------------

-------------------------------------------------------------------------------

The Fluke Calibration Software distribution version 7.2 SP3 is a service pack

that includes an updated MET/CAL with a number of product enhancements and

bug fixes.

-------------------------------------------------------------------------------

Section 3: Enhancements ------------------------------------------------------

-------------------------------------------------------------------------------

----> FSC for the Clarke-Hess 5500 Phase Standard

Issue Number: MC-1685

A new FSC, "CH5500", has been added to support the Clarke-Hess

5500 Phase Standard. Refer to the help file for details.

----> FSC for the Anritsu ML2530A Calibration Receiver

Issue Number: MC-3338

A new FSC, "ML2530", has been added to support the Anritsu

ML2530A Calibration Receiver. Refer to the help file for details.

----> FSCs for the Tektronix DMM40XX Series Digital Multimeters

Issue Number: MC-4046

New FSCs, "4020" and "M4020", have been added to support the Tektronix

DMM4020 Digital Multimeter. Refer to the help file for details.

New FSCs, "4040" and "M4040", have been added to support the Tektronix

DMM4040 Digital Multimeter. Refer to the help file for details.

New FSCs, "4050" and "M4050", have been added to support the Tektronix

DMM4050 Digital Multimeter. Refer to the help file for details.

Note

Procedures written using the 8845/M8845 FSCs will execute without

modification when a Tektronix DMM4040 is configured and connected.

Procedures written using the 8845/M8845, 8846/M8846, or 4040/M4040

FSCs will execute without modification when a Tektronix DMM4050 is

configured and connected.

----> Add support for the 700P27 Pressure Module to the P700 FSC

Issue Number: MC-4117

The P700 FSC can now be used to control a Fluke 700P27 Gage Pressure

Module connected to a Fluke 525A or 525B Temperature/Pressure

Calibrator, or a Fluke 5520A Calibrator.

----> Add support for the 700P00 Pressure Module to the P700 FSC

Issue Number: MC-4166

The P700 FSC can now be used to control a Fluke 700P00 Differential

Pressure Module connected to a Fluke 525A or 525B Temperature/Pressure

Calibrator, or a Fluke 5520A Calibrator.

-------------------------------------------------------------------------------

Section 3: Bug Fixes ---------------------------------------------------------

-------------------------------------------------------------------------------

----> Licenses Manufactured since 2009-07-01

Issue Number: MC-4169

Fluke changed the serial number format for all Fluke instruments on

2009-07-01. This version restores compatibility with any licenses

manufactured since then.

----> M4418/M4419 FSC Allowable Cal Factor Limits are Incorrect

Issue Number: MC-4170

The cal factor limits in the M4418 and M4419 FSCs have been changed

from 0 to 100 %, to 1 to 150 %, per the Agilient manual.

----> M4418/M4419 FSC with HP8484A specified selects "DEFAULT" cal factor table

Issue Number: MC-4171

The E4418B/E4419B run time driver now selects the "8481D" cal factor

table, per Agilent documentation, when a 8484A is specified, and

connected.

----> Add support for Rohde&Schwarz SMF100A Signal Generator to "user_config_instr.ini".

Issue Number: MC-4193

The R&S SMF100 Signal Generator is now supported by the applicable

Flexible Drivers.

----> DOS/DOSE FSCs use latest "correct.exe" shipped with MET/CAL

Issue Number: MC-4241

correct.exe shares code with the MET/CAL Editor and Run Time. That

executable is now located in the same folder as the Editor and Run Time.

If you use the DOS/DOSE FSCs with "correct.exe", the Editor and Run Time

will find it in that folder.

-------------------------------------------------------------------------------

-------------------------------------------------------------------------------


Read Me MET/CAL 7.2 SP2

-------------------------------------------------------------------------------

-------------------------------------------------------------------------------

Fluke Calibration Software 7.2 SP2

MET/CAL 7.2.45 (7.20T)

Released: 2009-06

-------------------------------------------------------------------------------

Section 1: Table of Contents -------------------------------------------------

-------------------------------------------------------------------------------

1. Table of Contents

2. Introduction

3. Enhancements

4. Bug Fixes

-------------------------------------------------------------------------------

Section 2: Introduction ------------------------------------------------------

-------------------------------------------------------------------------------

The Fluke Calibration Software distribution version 7.2 SP2 is a service pack

that includes an updated MET/CAL with a number of product enhancements and

bug fixes.

-------------------------------------------------------------------------------

Section 3: Enhancements ------------------------------------------------------

-------------------------------------------------------------------------------

----> Windows Installer

Issue Number: MC-3576

MET/CAL is now distributed as a Windows Installer installation package.

Please see the new Installation & Upgrade Guide.

----> VISA FSC

Issue Number: MC-3701

The VISA FSC is used to control UUT's that can be accessed using the

National Instruments VISA (NI-VISA). Refer to the VISA help file for

details.

----> Default "workstation" to computer name

Issue Number: MC-3698

The metcal.ini "workstation" setting is no longer required. If not set,

the computer name will be used. To see the computer name, enter this

in the Commmand Prompt:

echo %COMPUTERNAME%

----> 1 Year Accuracy File for the Fluke 8508A-7000K 1 GOhm Resistance

Standard

Issue Number: MC-3559

----> 1 Year Accuracy File for the Guildline 9211A

Issue Number: MC-3401

----> FSC for Anritsu ML2438A Power Meter

Issue Number: MC-3331

A new FSC, "ML2438", has been added to support the Anritsu

ML2438A Power Meter. Refer to the help file for details.

----> FSC for Anritsu ML2437A Power Meter

Issue Number: MC-3330

A new FSC, "ML2437", has been added to support the Anritsu

ML2437A Power Meter. Refer to the help file for details.

----> Fluke 5500A Coil Specifications Added to Fluke 6100A Accuracy

File

Issue Number: MC-3566

The addition of 5500A/COIL specifications to the 6100A accuracy

file allows procedure writers to configure the coil as an

auxiliary device attached to the 6100A, then use the ACCV

and/or ACCV2 MATH functions to retrieve necessary accuracy

data from the 6100A accuracy file and combine the accuracy

components as needed at the procedure level for subsequent

inclusion in an ACC procedure statement. The 6100A accuracy

can be retrieved using the MATH FSC REFACC function following

the 6100 FSC setup statement.

This distribution includes an updated 6100A accuracy file

("6100.acc").

----> Fluke 9100 Coil Specifications Added to Fluke 6100A Accuracy File

Issue Number: MC-3567

The addition of 9100Coil specifications to the 6100A accuracy

file allows procedure writers to configure the coil as an

auxiliary device attached to the 6100A, then use the ACCV

and/or ACCV2 MATH functions to retrieve necessary accuracy

data from the 6100A accuracy file and combine the accuracy

components as needed at the procedure level for subsequent

inclusion in an ACC procedure statement. The 6100A accuracy

can be retrieved using the MATH FSC REFACC function following

the 6100 FSC setup statement.

This distribution includes an updated 6100A accuracy file

("6100.acc").

----> Capability to Specify more than two Aliases for Configured Devices

Issue Number: MC-827

In MET/CAL 7.2 SP1, and earlier versions, a configured,

remotely controlled, reference instrument could have at most

two aliases.

In this distribution MET/CAL has been modified to allow

additional aliases. There is no longer a specific limit on

the number of aliases that may be assigned to an instrument.

The primary purpose of this change is to allow

multi-function instruments to be used in different roles

in the procedure-based flexible standards implementation

supported by MET/CAL.

----> DMM Flexible Standards Support for Fluke 8508A

Issue Number: MC-3545

This distribution includes an updated flexible standards

initialization file that adds the Fluke 8508A to the list

of instruments supported by the flexible DMM driver.

----> MET/CAL On-Line Help Updated to Describe Instrument FSC

MOD4 Field

Issue Number: MC-3125

This distribution includes an updated general MET/CAL help

file ("metcal.hlp") that provides a detailed description of

the MOD4 field in traditional instrument FSCs. The general

MET/CAL help file may be viewed in the MET/CAL Editor by typing

F1 when the current line in the active edit window does not

contain a specific FSC code (for example, a blank line).

----> DMM Flexible Standards Support for Frequency Measurement

Issue Number: MC-3552

This distribution includes an updated flexible standards

initialization file that adds frequency measurement support

to the DMM flexible driver.

----> MET/CAL Config Editor Supports Fluke 8508A-7000K 1 GOhm

Resistance Standard

Issue Number: MC-3560

The "Add Instrument" dialog in the MET/CAL Config Editor

(F12) has been updated to support the Fluke 8508A-7000K 1

GOhm Resistance Standard.

----> MET/CAL Config Editor Supports Fluke A40B Precision Current Shunts

Issue Number: MC-3558

The following Fluke A40B Precision Current Shunts have been

added to the "Add Instrument" dialog in the MET/CAL Config

Editor (F12):

Fluke A40B_1mA

Fluke A40B_10mA

Fluke A40B_20mA

Fluke A40B-50mA

Fluke A40B-100mA

Fluke A40B-200mA

Fluke A40B-500mA

Fluke A40B-1A

Fluke A40B-2A

Fluke A40B-5A

Fluke A40B-10A

Fluke A40B-20A

Fluke A40B-50A

Fluke A40B-100A

----> DMM Flexible Standards Support for Agilent/HP 3458A

Issue Number: MC-3546

This distribution includes an updated flexible standards

initialization file that adds the Agilent/HP 3458A to the

list of instruments supported by the flexible DMM driver.

----> Config Editor Dialog for Agilent PSA Updated for Option 123

Issue Number: MC_3530

In MET/CAL 7.2 SP1, and earlier versions that support the

Agilent PSA, the MET/CAL Config Editor dialog for the PSA

grays out the checkbox for Option 123 (Switchable Microwave

Preselector Bypass) for models E4446A, E4447A, and E4448A.

In this distribution the dialog has been updated so that

the Option 123 checkbox is always enabled.

----> 5230 FSC Changed to Allow Frequency As Evaluation Quantity in

Voltage Calibrator Mode

Issue Number: MC-3519

In this distribution the 5320 FSC has been modified to allow

frequency to be designated as the evaluation quantity in

Voltage Calibrator mode.

This change allows the 5320A to be used as a frequency

reference when verifying instruments such as the Fluke 1625

Advanced Earth/Ground Tester.

This change also involved modifying the 5320A accuracy file

by adding a "Hertz Cal" section. The updated accuracy file

is included in this distribution.

----> VSET/TSET Specification of Default UUT COM Port

Issue Number: MC-3509

In MET/CAL 7.2 SP1, and earlier versions, the MET/CAL

default UUT serial port is specified using the "PORT"

initialization file parameter.

There's now a corresponding VSET/TSET parameter that may be

used to override the default UUT serial port in the procedure.

Refer to help for the VSET FSC for details.

See the following enhancement (#46578) for a procedure

example that makes use of the VSET "PORT" parameter.

----> MATH Function to Generate List of COM Ports on PC

Issue Number: MC-3508

There's a new MATH FSC function named "ComList" that returns

a comma-separated list of the names of the COM ports on

the PC. The list includes virtual COM ports that appear when

serial-to-USB adapters are used. The list does not include

"UUT" ports on Fluke 55XX calibrators.

Refer to help for the MATH FSC for additional information.

In order to make use of the information returned by "ComList"

it's usually necessary to dynamically assign the UUT serial

port in the procedure by using the VSET/TSET "PORT" parameter.

Refer to the VSET help for additional information about the

"PORT" parameter.

Here's an example procedure using the Fluke 289 that shows

how to use the "ComList" function and the "PORT" parameter

to dynamically determine the serial port to which the UUT

is connected:

INSTRUMENT: ComList / PORT Example

1.001 MATH list = ComList()

1.002 MATH id = lbNew("COM Port List")

1.003 MATH txt = "Choose the COM port";

1.004 MATH txt = txt & " to which the Fluke 289 is connected:"

1.005 MATH lbText(id, txt)

1.006 MATH lbAddList(id, list)

1.007 MATH lbConf(id, "+selreq,-sel")

1.008 MATH op = lbShow(id)

1.009 MATH port = lbGetSel(id, 1)

1.010 VSET PORT = [v port]

1.011 PORT [oterm cr]

1.012 PORT [term cr]

1.013 PORT [P115200,n,8,1,n]

1.014 PORT [T5000]

1.015 PORT ID[I!][I$]

1.016 MATH ID = MEM2

1.017 DISP ID Response = [v ID]

----> New List Box Window Option to Remove Border from Multi-Line

Edit Control

Issue Number: MC-3506

The list box functions added to the MATH FSC in 7.2 SP1

allow the procedure writer to configure a list box window

that optionally includes a multiline readonly edit control

above the list box itself.

As implemented, the edit control includes a thin border line

around the control.

In this distribution there's a new list box window

configuration option to suppress the border line around

the control.

Refer to the help of the MATH FSC function "lbConf" for details.

----> Vertical Tiling Added to MET/CAL Editor

Issue Number: MC-3507

In 7.2 SP1, and prior versions, the MET/CAL Editor has a

menu item named "Tile" int top-level "Windows" menu.

When chosen, "Tile" causes the MDI child windows to be

tiled horizontally.

In this distribution the "Tile" item in the Editor's top-level

"Window" menu has been replaced by two items, "Tile Horizontal"

and "Tile Vertical".

"Tile Horizontal" is equivalent to the old "Tile" menu item,

and "Tile Vertical" is a new menu item that causes the edit

windows to be arranged side-by-side, left to right.

----> Procedure Override of Standard PICE FSC Result Message

Issue Number: MC-3505

The PICE FSC now optionally allows "-s <expr> :" at the

beginning of the line, where <expr> is a string-valued

MATH FSC-compatible expression.

The evaluated string expression is written to the "Remark"

column in the Results Table, and also shown at run time in

the Test Results window.

Refer to help for the PICE FSC for details.

----> Functions to Find Lines in CSV Files

Issue Number: MC-3485

7.2 SP1 included a group of line-oriented file I/O functions.

These functions implement basic operations such as:

(a) read a line

(b) write a line after a specified line

(c) insert a line before a specified line

(d) replace a specified line

(e) append a line

This distribution includes 4 new MATH FSC functions used to

find lines in CSV files:

FindCSV - find line matching specified

comma-separated values

FindCSVi - case-insensitive version of FindCSV

FindCSVn - find line matching specified

comma-separated values at specified indices

FindCSVni - case-insensitive version of FindCSVn

The basic idea is to start with a file containing multiple

text lines, where each line contains a list of comma separated

values. For example, the file may have been created from

a Microsoft Excel spreadsheet. "FindCSV" may then be used

to search the file to find a line that matches a specified

list of values. The full contents of the matching line,

and the line number, are returned to the calling procedure.

Here's a simple example. Suppose you have the following file

("data.txt"):

5 V, 10 kHz, 0.002

10 V, 10 kHz, 0.003

20 V, 10 kHz, 0.001

50 V, 10 kHz, 0.0023

5 V, 20 kHz, 0.0021

10 V, 20 kHz, 0.0019

20 V, 20 kHz, 0.0027

50 V, 20 kHz, 0.0022

If you make the call:

MATH ln = FindCSV("data.txt", "10 V, 20 kHz", 1, "line")

"FindCSV" will set the line number ("ln") to 6 and set the

value of the variable "line" to "10 V, 20 kHz, 0.0019".

That's because line 6 is the first line where the first

value is "10 V" and the second value is "20 kHz".

Refer to help for the MATH FSC for details.

----> Override Test Step 2

Issue Number: MC-3483

This distribution supports a new VSET/TSET parameter named

"TStep".

"TStep" allows the procedure writer to override the value

of Test Step 2 in the database results table.

The "TStep" value is an arbitrary string between 1 and

16 characters.

Test Step 2 is the last column in the Results Table.

The column header shown in MET/TRACK is "test_step2".

The "TStep" parameter provides a mechanism to allow a

procedure writer to assign a unique tag to an individual test.

The assigned tag may then be used for "data mining" purposes,

extracting data for a particular test across a sequence of

calibration records for a particular asset, or more generally

for assets of the same model.

Using the automatically generated values for "Test Step" or

"Test Step 2" for this purpose may be unreliable due to the

fact that procedure changes that add, remove, or reorder

tests cause MET/CAL to renumber the test steps.

The full MET/CAL test step number is stored in the Results

Table in the "Test Step" field (label "test_step").

Test Step 2 was intended primarily for "legacy results"

compatibility when MET/CAL 7.0 was released. Because the

"Test Step" field contains all the information (and more)

that the "Test Step 2" field contains, "Test Step 2" may be

safely overridden, except in cases where reports have been

written specifically to use the "Test Step 2" field.

Refer to help for the VSET FSC for documentation

of the "TStep" parameter.

----> VSET Parameter to Use Nominal as Correction Lookup for Fixed

Resistance

Issue Number: MC-3484

When using a calibrator that has fixed resistance values,

and stores its own internal corrections for those resistance

values, the internally corrected value becomes the reference

value (System Actual) for the test. When corrections are

enabled (ASK+ C) MET/CAL has always used the reference value

as the correction lookup value.

Using a correction file indicates that the calibrator has

been externally characterized. The calibrator's internal

corrections should therefore be largely irrelevant. In most

cases it is more convenient to characterize the calibrator at

cardinal point values, rather than at values that represent

the calibrator's internal corrections.

This distribution supports a new VSET/TSET parameter named

"NomCor". "NomCor" applies only to calibrators that have

discrete resistance values, and store internally corrected

resistance values. The following calibrators are in

this group:

Datron 4000, 4000A, 4700, 4705, 4707, 4708, 4800,

4800A, 4805, 4808

Fluke 5450A, 5700A, 5720A

When "NomCor = Yes" MET/CAL uses the Nominal value of the test,

not the calibrator's corrected value, for correction lookup.

For compatibility with previous versions of MET/CAL, the

default value for "NomCor" is "No".

The "NomCor" parameter is documented in the VSET help file.

----> Linear Regression Capability Added to MET/CAL

Issue Number: MC-3480

This distribution includes a new MATH function, "LinReg",

that calculates the linear regression from a set of (X,Y)

data points.

The 1st argument is a comma-separated list of X-values.

The 2nd argument is a comma-separated list of Y-values.

The slope and intercept of the line are stored in the

variables specified in the 3rd and 4th function arguments.

Example:

MATH x = "1, 2, 3"

MATH y = "1.3, 1.9, 3.1"

MATH LinReg(x, y, "SlopeVar", "InterceptVar")

The call to "LinReg" performs a least-squares fit

to determine the line that best fits the specified

data points ((1,1.3), (2,1.9), and (3,3.1)).

Refer to the MATH FSC help file for additional information.

----> Functions to Convert Numeric Registers to CSV Lists

Issue Number: MC-3476

This distribution includes two new MATH functions, "CSV"

and "CSV_L", that may be used to convert a specified group

of M-registers or L-registers into a string containing a

comma-separated list of values.

Refer to on-line help for the MATH FSC for details.

----> Function to Close a File

Issue Number: MC-3478

MET/CAL 7.2 SP1 included a group of line-oriented file

I/O functions. Files are opened automatically when certain

functions are called to read or write lines to files.

For example, "append", "insert", "replace", "read", and

"write" all trigger the opening of a file that's not yet open.

Because these functions use buffered file I/O, file contents

may not be written to disk until the file is closed. In the

7.2 SP1 implementation, all open files are automatically

closed when the procedure terminates.

This approach is sufficient in most cases, but in order to

provide a means for the procedure writer to force the closing

of a file before procedure termination this distribution

includes a new MATH FSC function named "close".

By calling "close" the procedure writer may allow other

processes, external to MET/CAL, to access a file before the

procedure that created or updated the file has terminated.

Refer to on-line help for the MATH FSC for details.

----> Function to Check for Required MET/CAL Version

Issue Number: MC-3477

In this distribution there's a new MATH function that allows

a procedure writer to check the currently running version of

MET/CAL (Run Time or Editor Test Run) against a specified

version to make sure that the running version is the same

as, or more recent than, the specified version.

The name of the function is "VersionCheck".

Prior to the implementation of "VersionCheck" this operation

was done by calling a subprocedure. That approach had

several disadvantages:

(1) It takes more lines of procedure code to set up and make

the subprocedure call.

(2) It requires that the version check subprocedure be

included in all procedure packages.

(3) It encodes the MET/CAL version numbering scheme into

a subprocedure external to the MET/CAL application.

This is the most significant disadvantage because it

constrains MET/CAL's ability to revise the version

numbering scheme.

The new function is "VersionCheck". If the specified version

is later than the executing version, an error message is

generated, and the system returns to the

"Procedure Step Terminated" PostTest window.

----> File-Based Accuracy Confidence Lookup Function

Issue Number: MC-3474

File-based accuracy lookup functions were recently added

to MET/CAL.

The new file-based functions are:

ACCF - 1-param accuracy spec lookup

ACCF2 - 2-param accuracy spec lookup

ACCFF - 1-param accuracy floor spec lookup

ACCFF2 - 2-param accuracy floor spec lookup

ACCFG - 1-param accuracy gain spec lookup

ACCFG2 - 2-param accuracy gain spec lookup

Refer to report #45731 for a description of the functions

listed above.

There is now an additional file-based function that returns the

confidence value from the header of a specified accuracy file.

The name of the new function is "CONFF".

Refer to on-line help for the MATH FSC for details.

----> Capability to Change List Box Item Names

Issue Number: MC-3472

MET/CAL 7.2 SP1 includes a family of new MATH functions

that allow a procedure writer to configure and display a

window containing one or more of the following:

(a) multi-line readonly text control

(b) list box

(c) single-line edit control

(d) button row

In the 7.2 SP1 implementation list box windows can be

modified and subsequently re-used, but supported list box

modifications are limited to adding new list box items.

Therefore, in 7.2 SP1 the only way to change or remove an

existing list box item is to close the existing list box window

and then create a new list box window with the changed item (or

without the item at all if the intent is to remove the item).

To make it easier to modify or remove list box item, there

are now two new functions, "lbRepl" and "lbReplV".

"lbRepl" changes a specified list box item. If the replacement

string is an empty string, the specified item is removed

from the list box.

"lbReplV" is similar to "lbRepl", with the difference

that the item to be changed is specified not by the item

name, but rather by the name of an associated variable.

The association must initially have been made by calling

"lbAddV". As with "lbRepl", if the replacement string is

empty, the list box item is removed.

Refer to on-line help for the MATH FSC for details.

----> MATH Functions to Convert Formatted Dates to Elapsed Time

Since Jan 01 1970

Issue Number: MC-3467

In the MET/CAL procedure language it is difficult to compare

formatted dates to determine the proper date order.

This distribution includes two new MATH functions designed

to make it easier to compare dates:

ugdate - convert formatted date (UTC) to elapsed

seconds since Jan 01 1970 (UTC)

uldate - convert formatted date (local) to elapsed

seconds since Jan 01 1970 (UTC)

Refer to the MATH FSC help file for details.

----> File-Based Accuracy Lookup Functions

Issue Number: MC-3459

In MET/CAL 7.2 SP1, and earlier versions, the ACCF FSC

cannot be used to lookup values in accuracy files associated

with user-configured instruments. This is because ACCF is

tied directly to MET/CAL's built-in instrument FSCs.

The MATH functions "ACCV", "ACCV2", "ACCVF", "ACCVF2", "ACCVG",

and "ACCVG2" exist for looking up accuracy values in accuracy

files for configured instruments, including user-configured,

but the lookup algorithm automatically associates an accuracy

file with a configured device by matching the file to the

device name and the cal interval for that device in the

inventory record in the database. This works well in most

cases, however, there are cases where a special accuracy

file with a different cal interval is needed.

To provide this capability this distribution includes a

group of six new MATH FSC functions that operate in a manner

similar to the "ACCV", "ACCV2", "ACCVF", "ACCVF2", "ACCVG",

and "ACCVG2" functions, but take the accuracy file name,

rather than the name of a configured instrument, as the

first argument.

The new functions are:

ACCF - 1-param accuracy spec lookup

ACCF2 - 2-param accuracy spec lookup

ACCFF - 1-param accuracy floor spec lookup

ACCFF2 - 2-param accuracy floor spec lookup

ACCFG - 1-param accuracy gain spec lookup

ACCFG2 - 2-param accuracy gain spec lookup

There's also a new, optional initialization file parameter,

"AccfDir", that can be used to specify the directory where the

ACCF-functions look for accuracy files. (If the procedure

specifies the full path name of a file, that specification

takes precedence.)

If the procedure does not specify the full path name, and

"AccfDir" is not specified in the initialization file,

MET/CAL uses the normal MET/CAL accuracy directory (as

specified by the "accdir" initialization file parameter).

Refer to the MATH FSC help file for details.

----> MATH FSC Functions to Access Fluke 792 Data

Issue Number: MC-3457

In this distribution ease of use of the Fluke 792A Thermal

Transfer Standard by MET/CAL procedure writers has been

improved by the addition of a group of MATH FSC functions

design to retrieve information from Fluke 792A AC-DC difference

data files.

The supported file format is the format used by the Fluke

Standards Lab.

The following functions have been implemented:

Open792 - open, read, and check specified Fluke

792 data file

Get792 - get interpolated AC-DC difference value

from Fluke 792 data file

CalDate792 - get calibration date from Fluke 792

data file

SN792 - get serial number from Fluke 792 data file

Refer to the MATH FSC help file for details.

----> Modify MATH Function "RefAcc" to Suppress Error Message When

Accuracy is Zero

Issue Number: MC-3458

MET/CAL 7.2 SP1 introduced a new MATH function named

"RefAcc".

The purpose of "RefAcc" is to retrieve the reference accuracy

determined in a preceding setup statement in the current test.

Prior to the introduction of "RefAcc" MET/CAL was forgiving

about the situation where the reference accuracy is zero.

The TSR calculation ignores a reference accuracy of zero.

Since the reference accuracy is the denominator of the

TSR, the rationale is that the TSR must be greater than 4,

because an "infinitely accurate" reference has to be much

more accurate than the UUT.

The measurement uncertainty calculation doesn't ignore

the reference accuracy, but it's inconsequential in the

sense that it simply contributes nothing to the overall

measurement uncertainty calculation. That is,

RSS(0, v1, v2, ...) is the same as RSS(v1, v2, ...).

However, "RefAcc" regards a zero reference accuracy as an

error condition. This error condition is detected regardless

of whether the procedure includes calls to the MATH "RefAcc"

function.

This can be problematic when looking up the accuracy in a

MET/CAL accuracy file where the reference instrument is a

sensor (meter), the NOMINAL value is zero, and the instrument's

specification does not include a floor component.

An example of this problem occurs when using an Agilent 4418B

power meter. A 4418 statement with "0pct" in the NOMINAL

field causes an error message to be generated when MET/CAL

attempts to lookup the accuracy of the 4418 at 0%.

In this distribution there's a new initialization file

parameter called "RefAccAllowZero" that can be set to "yes"

to cause MET/CAL to suppress the error message generated

when the reference accuracy is zero.

"RefAccAllowZero" defaults to "no".

----> Inter-Address Delay for IEEE-488 Port 0 "Find Listeners" Search

Issue Number: MC-3456

In MET/CAL 7.2 SP1, and earlier versions, MET/CAL searches

the IEEE-488 bus (port 0) before initial procedure execution

to determine the addresses of instruments on the bus, and

to cross-check against the instrument configuration for

the workstation.

For some devices, the IEEE-488 address search does not work

correctly, because the instrument is too slow to correctly

handle the IEEE-488.2 "Find Listeners" protocol.

In particular, the Data Proof 160B Scanner answers at multiple

IEEE-488 addresses if the "Find Listeners" check is allowed

to run too quickly.

In MET/CAL this distribution there's a new MET/CAL

initialization file parameter named "FindListenDelay".

Legal values are 0 to 10000 milliseconds.

The parameter is optional.

The default value is zero.

Example:

FindListenDelay = 150

----> 8901 FSC Help File Does Not State That an HP 8901A Must Be

Configured As An 8901B

Issue Number: MC-3454

In MET/CAL 7.2 SP1, and earlier versions, the 8901 FSC

help file states that the FSC supports the 8901A, but fails

to state that the instrument must be configured as an 8901B.

This distribution includes an updated 8901 FSC help file

that clarifies this point.

----> Add Ability to Specify Button with Input Focus in List Box Window

Issue Number: MC-3450

MET/CAL 7.2 SP1 includes a family of MATH FSC functions

used to configure and display list box window.

Most components of a list box window are optional. It is

therefore possible to construct a list box window that does

not include an actual list box, and also lacks a line where

the user can enter text.

A list box window configured that way is limited to an

optional title, optional scrollable read-only text, and a

group of one to eight buttons.

For a window of that type it would be useful to be able to

configure which button becomes the default button, receiving

the input focus when the window is first displayed.

In this distribution there's a new MATH function named

"lbButtonFocus" that can be used to control the default

button in a list box window.

"lbButtonFocus" works only in a list box window that contain

neither a list box nor a text-entry line. In other words,

it works in list boxes limited to one or more of the following:

(a) a window title

(b) a read-only text line

(c) buttons

Refer to on-line help for the MATH FSC for details.

----> 39A and 195 FSCs Now Control Fluke 280 Series Arbitrary

Waveform Generators

Issue Number: MC-3443

In MET/CAL 7.2 SP1, and earlier versions, the 39A and 195

FSCs cannot be used to control Fluke 280 Series arbs.

The following table shows the compatibility relationship:

Fluke 281 <--> Wavetek 39A

Fluke 282 <--> Wavetek 195 without Option 001

Fluke 284 <--> Wavetek 195 with Option 001

In this distribution the 39A FSC may be used to control

channel 1 of the following:

Fluke 281 1 Channel 40 MS/s Arbitrary Waveform Generator

Fluke 282 2 Channel 40 MS/s Arbitrary Waveform Generator

Fluke 284 4 Channel 40 MS/s Arbitrary Waveform Generator

In this distribution the 195 FSC may be used to control

the following:

Fluke 282 2 Channel 40 MS/s Arbitrary Waveform Generator

Fluke 284 4 Channel 40 MS/s Arbitrary Waveform Generator

Since the Fluke 280 Series instruments are controlled using

FSCs developed for the older models, it is necessary to

configure the older model (using the MET/CAL Config Editor).

In the database Inventory Table, however, the correct name

may be used for reporting purposes.

More specifically, the Fluke 281 must be configured as a

Wavetek 39A, and the Fluke 282 and 284 must be configured

as a Wavetek 195.

A run time error is generated if a procedure incorrectly

attempts to control channel 3 or 4 of a Fluke 282 (because

the 282 has only 2 channels).

-------------------------------------------------------------------------------

Section 3: Bug Fixes ---------------------------------------------------------

-------------------------------------------------------------------------------

----> 6100 FSC Accuracy Calculation for Voltage Fails to Include

2-Wire Adder

Issue Number: MC-3419

The 6100 FSC in MET/CAL 7.2 SP1, and earlier versions

that support the 6100 FSC, fail to include the 2-wire adder

for ACV and DCV when the reference accuracy is determined.

For example, both of the following statements generate the

same T.U.R.:

1.005 6100 OutputSense = On

1.005 6100 L1VRange = 168 V

1.005 6100 +L1VAC = 150.000 V

1.005 6100 Frequency = 60 Hz

1.006 MEMI Enter UUT Reading

1.007 MEMCX 200 V 0.05%

#! WARNING: Test Tol 0.075, Sys Tol 0.0212 V, TUR 3.5377

2.001 6100 OutputSense = Off

2.001 6100 L1VRange = 168 V

2.001 6100 +L1VAC = 150.000 V

2.001 6100 Frequency = 60 Hz

2.002 MEMI Enter UUT Reading

2.003 MEMCX 200 V 0.05%

#! WARNING: Test Tol 0.075, Sys Tol 0.0212 V, TUR 3.5377

The calculation for the first statement is correct (4-wire),

but the calculation for the second statement is incorrect

because it does not include the 2-wire adder.

----> 6100 FSC Does Not Allow Voltage Offsets To Be Specified As

Percentages

Issue Number: MC-2458

In MET/CAL 7.2 SP1, and previous versions that include the

6100 FSC, the 6100 FSC "learn mode" is capable of generating

lines like:

6100 L1VOffset = 12%

but the 6100 FSC compiler rejects the line as illegal due

to the units ("%").

In this distribution the 6100 FSC has been updated to allow

voltage offsets to be specified as percentages.

----> 6100 FSC AC Power Limits Incorrect When 5500A/COIL Used

Issue Number: MC-3568

In MET/CAL 7.2 SP1, and previous versions that include

the 6100 FSC, the compile time AC power limits are incorrect

when used with the 5500A/COIL.

This prevents certain procedure statements that should be legal

from compiling. For example, the following statement cannot be

compiled due to the incorrect limits enforced by the 6100 FSC:

1.001 6100 L1VAC=220V L1IAC=400A L1IRange=10A

1.001 6100 +L1Power=88.0kW Freq=50Hz L1IPhase=0deg

1.001 6100 L1ICoil=5500A/Coil L1IBandwidth= 1.5 kHz

1.001 6100 L1IUUTCurrClamp=Toroidal

The problem has been corrected in this distribution.

----> PSA FSC Fails to Require Center Frequency and Span, or Start

Frequency & Stop Frequency, in Spectrum Analysis Mode

Issue Number: MC-3534

In 7.2 SP1, and earlier versions that support the PSA

FSC, there MET/CAL procedure compiler fails to detect an

error condition when the procedure writer enters a spectrum

analysis mode statement that does not specify at least one

of center frequency, span, start frequency, and stop frequency.

In this distribution the PSA FSC has been updated to proprly

detect this error condition.

----> DMM Flexible Drivers May Generate "*TRG/GET Trigger Ignored" Error

Issue Number: MC-3554

In 7.2 SP1, when the DMM flexible driver is used to

control a DMM for which a MET/CAL FSC exists, certain series

of events may cause the error:

*TRG/GET trigger ignored

For example, when using the DMM flexible driver to control the

Fluke 8846A the following steps cause this problem to occur:

1. The 8846A is configured as "Fluke 8846A".

(This is System Instrument name assigned to the

8846/M8846 FSCs.)

2. A procedure calls "Sub Reset /DMM".

"*RST;TRIG:SOUR BUS" is sent to the 8846A.

3. The operator terminates the procedure in Test Run.

The 8845A/46A driver sends "*RST", which switches

the DMM to internal trigger.

4. The operator resumes the procedure using

"Test Run->Go".

5. The procedure calls "Sub Read /DMM". "INIT;*TRG"

is sent to the 8846A.

6. "*TRG/GET trigger ignored" error is generated,

since the 8846A is no longer in bus trigger mode.

The following "ProgSecName" entries in "user_config_instr.ini"

are affected:

[2000]

[34401A]

[8845/46]

This distribution includes and updated flexible standards

initialization file ("user_config_instr.ini") that corrects

the problem.

----> Config Editor Does Not Prevent Adding an Auxiliary Device as

a Manual Standard

Issue Number: MC-3550

In 7.2 SP1, and earlier versions, the MET/CAL Config

Editor fails to generate an error if the instrument name

entered in the "Add Instrument" dialog matches the name of

an auxiliary device.

Example:

1. Select Configure=>Instruments.

2. Select Add.

3. Type "Fluke 5725A" in the editor control.

4. Select OK.

At this point the general instrument configuration

dialog is displayed with the title:

System Instrument: Fluke 5725A

"Remote Interface" is set to IEEE-488 and the radio

buttons are grayed out. "Remote Interface: None"

cannot be selected.

The problem is corrected in this distribution. It is no longer

possible to configure an auxiliary device as a manual standard.

----> Config Editor Allows IEEE-488 Address for Fluke 80K-40 HV Probe

Issue Number: MC-3403

In MET/CAL 7.2 SP1, and earlier versions, if you configure a

Fluke 80K-40 HV probe using the Config Editor the configuration

dialog sets the remote interface to IEEE-488, and allows the

user to specify an IEEE-488 address. However, the 80K-40 HV

is a manual device.

In this distribution it is no longer possible to incorrectly

configure the Fluke 80K-40 HV Probe as an IEEE-488 device.

----> MET/CAL "Humidity and Temperature Sensor" Configuration Dialog

Incorrectly Limits Humidity Delta to 25%

Issue Number: MC-3399

In MET/CAL 7.2 SP1, and earlier versions, the MET/CAL

"Relative Humidity / Temperature Sensor" configuration dialog

incorrectly limits the maximum "Humidity Delta" value to 25 %.

The problem has been corrected in this distribution.

The maximum "Humidity Delta" value is now 100 %.

----> Power Meter Not Listed in "Standards Used" for N5531S RF

Power Measurement

Issue Number: MC-3252

In 7.2 SP1, and earlier versions of MET/CAL that support

the N5531 FSC, the power meter is not listed in the "Standards

Used" database table associated with the calibration results

when the N5531 FSC is used for RF Power or Tuned RF Level

measurement.

The problem has been corrected in this distribution.

----> "LCOMP Off" Not Supported for Custom 10-Turn Coil Above 440 Hz

Issue Number: MC-3264

In MET/CAL 7.2 SP1, and earlier versions, the procedure

compiler in some cases incorrectly generates the message:

E496: FSC 5520: The CON field cannot be T1 in AC

Current mode.

The Fluke 80i-110s AC/DC Current Probe Instruction Sheet

calls out a 5520A and custom built 10-Turn Toroid Coil

for performance verification. The following tests points

are listed:

Table 2. Performance Test Points

Current range 0 to 10 A (100 mV/A)

5520A RMS AMPS

SETTING MEASURED

-------------- --------------

0.5 A, 2 kHz 5 A

0.6 A, 4 kHz 6 A

Table 3. Performance Test Points

Current range 0 to 100 A (10 mV/A)

5520A RMS AMPS

SETTING MEASURED

-------------- --------------

1 A, 5 kHz 10 A

2 A, 1 kHz 20 A

The MET/CAL 5520A accuracy file has modes to support a custom

10-Turn Coil above 440 Hz with LCOMP off. No accuracy is

specified, however. It is expected that the end user will

modify the accuracy file to reflect the specifications of

their custom coil when used with the 5520A.

I.e., the following sections of the accuracy file must

be modified:

# AC Current (Sine) w/10-turn Toroid

# NOMINAL MOD1 Tol. Floor Res.

# ----------------------- --------------- ----- ------- -----

...

Mode: Amps SI T10

# Auxiliary Output, LCOMP OFF

0.2900E-3 3.2999E-3 10 30E3 NA NA 100E-9

3.3000E-3 32.9999E-3 10 30E3 NA NA 100E-9

33.000E-3 329.999E-3 10 30E3 NA NA 1E-6

0.33000 3.29999 10 30E3 NA NA 10E-6

3.3000 29.9999 10 10E3 NA NA 100E-6

Mode: Amps SI HC T10

# 20A Output, LCOMP OFF

30.000 109.999 45 5E3 NA NA 1E-3

110.000 205.000 45 5E3 NA NA 1E-3

The specific problem in 7.2 SP1, and and prior versions,

is that the procedure compiler does not support the accuracy

file modes shown above, and therefore does not properly

utilize the end user-specified coil accuracy data.

The problem has been corrected in this distribution.

----> Flexible Standards Initialization File Modified for Compatibility

with Changes to LFCTR, HFSG, and SWPG Flexible Drives

Issue Number: MC-3311

In MET/CAL 7.2 SP1, when using the LFCTR flexible driver

(Revision 1.3) with counters whose INT/EXT selection of

the reference oscillator is manual, i.e., not programmable,

an error is reported at run time.

The same problem arises when using the SWPG and HFSG flexible

drivers (Revision 1.2) with generators whose INT/EXT selection

of the reference oscillator is manual, i.e., not programmable,

an error is reported at runtime.

This distribution includes and updated flexible standards

initialization file ("user_config_instr.ini") that corrects

the problem.

----> MET/CAL FSC for Agilent PSA Sends Option-Specific Commands

When Option Not Configured

Issue Number: MC-3531, MC-3532

In MET/CAL 7.2 SP1, and earlier versions that support

the Agilent PSA, the MET/CAL driver in some cases sends

option-specific commands to the instrument even when the

corresponding option is not installed. This results in the

following error:

Error 201 Option Not Installed

The problem is present for options 123, 1DS, and 110.

In this distribution the PSA FSC has been corrected so

that it does not send option-specific commands unless the

corresponding option is installed.

----> 55XX Statements with Dual Volts and "AX" in Main FSC MOD3 May

Program Incorrect Normal Voltage

Issue Number: MC-3462

In MET/CAL 7.2 SP1, and earlier versions, 55XX Dual Voltage

statements, with AX in 55XX MOD3, may incorrectly program the

normal output voltage to a value equal to (2 * SQRT(2) * V),

where V is the voltage specified in the procedure statement.

For example, the following statements may result in the

normal voltage being programmed to 14.1421 V, rather than 5 V.

M550 5V 0.0deg SI EL

5500 30mV 60H SI AX S 2W

The problem is intermittent and may not be repeatable.

The error has been corrected in this distribution, as well as

in earlier distributions that include the required version,

or later, of the MET/CAL Editor and Run Time applications.

----> Incorrect Frequency Specification in 39A and 195 Accuracy Files

Issue Number: MC-3499

In MET/CAL 7.2 SP1, and earlier versions that support

the 39A and 195 FSCs, there's an error in the frequency

specifications in the 39A and 195 accuracy files.

The incorrect specification is written as follows:

Mode: Hertz SI

0.1e-3 16e+6 -10 10 30e-4 0 NA

20e+6 10e+6 -10 10 100e-4 0 NA

The correct specification is:

Mode: Hertz SI

0.1e-3 16e+6 -10 10 10e-4 0 NA

This distribution includes updated accuracy files to correct

the error. The files are "39a.acc" (revision 1.2) and

"195.acc" (revision 1.2).

----> N5531 and PSA FSC Fail with Agilent PSA Firmware Rev. A.01.19

Issue Number: MC-3488

In 7.2 SP1, and earlier versions of MET/CAL that support

the N5531 and PSA FSCs, MET/CAL's internal PSA test

function expects the response to the "*IDN?" query not to

be CR-LF-terminated. However, in firmware revision A.01.19

Agilent modified the "*IDN?" response format to include a

CR-LF terminator. That change, in turn, prevented the N5531

and PSA FSCs from being used with firmware revision A.01.19.

In this distribution MET/CAL's PSA FSC test function has

been modified to accept "*IDN?" responses with or without

a CR-LF termination.

----> List Box Termination Fails With More Than Two User-Configured

Buttons

Issue Number: MC-3475

Using the MATH FSC list box functions introduced in 7.2 SP1,

when non-default buttons are configured, and there are more

than two buttons, choosing the 2nd button from the left causes

MET/CAL to operate as if the window has been user-terminated.

The problem does not arise when the default buttons ("Advance"

and "Terminate") are used.

The problem also does not arise when the "+ok" configuration

option to configure "Ok" and "Cancel" buttons is used.

The distribution corrects the implementation so that it

operates as follows:

(1) If "+term" is configured, and there are two

or more buttons, the list box window is

operator-terminated when the right-most button,

other than "Search", is chosen.

(2) If "-term" is configured, or there's

only one button, the list box is never

operator-terminated.

----> Fluke 8845A and 8846A Cannot Be Configured with 5500/CAL

Issue Number: MC-3473

In 7.2 SP1, and earlier versions that support the Fluke 8845A

and Fluke 8846A, 5500/CAL does not allow the 8845A or 8846A to

be configured. This prevents the 8845 and 8846 FSCs from being

used with 5500/CAL.

The problem does not affect MET/CAL.

The problem is resolved in this distribution.

----> 6100 Reference Accuracy Calculation Does Not Handle "NA" Correctly

Issue Number: MC-3469

In MET/CAL 7.2 SP1, and prior versions of MET/CAL that

support the "6100" FSC, the calculation of the reference

accuracy is not handled correctly in cases where the required

specifications (floor and/or gain) are set to "NA" in the

6100A accuracy file.

The underlying problem is that "NA" is not handled as a

special case. That causes the calculated reference accuracy

to be zero. The error was essentially hidden prior to the

release of 7.2 SP1, because both the test uncertainty ratio

and measurement uncertainty calculations effectively ignore

a reference accuracy of zero.

However, with the addition of the MATH FSC "RefAcc" function

in 7.2 SP1, the case where the reference accuracy is zero

is specifically handled as an error condition. That change

caused the problem in the 6100 FSC to be noticed.

In this distribution the 6100 FSC has been updated to properly

handle the case where required 6100A specifications are set to

"NA" in the MET/CAL accuracy file for the Fluke 6100A.

----> 9100 Test with CO or HV in MOD3 and Nominal Units = ohms

Incorrectly Viewed As Measurement

Issue Number: MC-3464

In order to distinguish the variable quantity in a test

(VARQ) from the fixed quantity (FIXQ) MET/CAL uses an internal

function that analyzes an instrument statement to determine

if the reference instrument is being used as measurement

device or a source device.

For many reference instruments the decision is simple,

because the instrument can only be used in one mode (i.e.,

it's always a measurement device or always a source device).

For certain instruments, however, some tests involve using

the instrument in a measurement mode and other tests involve

using the instrument in a source mode.

For the Fluke 9100, the algorithm has been this:

If the MOD3 field specifies CO (continuity) or HV

(insulation), the instrument is being used as a

measurement device.

For all other 9100 statements the instrument is

being used as a source device.

The problem with this algorithm is that it doesn't correctly

handle all cases where the MOD3 field is "CO".

In particular, when MOD3 is "CO", and the NOMINAL units

are "Z" (ohms), the 9100 is being used as a source device,

not a measurement device.

For example, in a test like this:

1.001 ASK- R N P F W

1.002 ASK+ K

1.003 VSET RSM = Last

1.004 9100 10.0Z 1.0U CO 4W

MET/CAL incorrectly concludes that the 9100 is being used as

a measurement device. This causes the VARQ and FIXQ result

quantities to be incorrectly swapped.

The same problem is also present in insulation mode

(MOD3 = "HV"). In insulation mode, when NOMINAL units are

ohms ("Z") the 9100 is being used as a source device, not

a measurement device.

This distribution resolves the problem.

----> 8508 FSC Incorrectly Allows MOD3 = D4 for DC Voltage

Issue Number: MC-3465

The 8508 FSC help file documents the MOD3 field as follows:

The MOD3 field Specifies the measurement resolution

or input zero.

o D4 4.5 digit resolution

o D5 5.5 digit resolution

o D6 6.5 digit resolution

o D7 7.5 digit resolution

o D8 8.5 digit resolution

o ZR Perform input zero

Function D4 D5 D6 D7 D8

-------------------------------

DC Voltage x x x x

AC Voltage x x

DC Current x x x

AC Current x x

Normal Ohms x x x x

True Ohms x x x x

HV Ohms x x x x

Temperature x x x x

Frequency x x

However, the following statement compiles without

error:

8508 190.00mV D4 N 2W

This distribution resolves the problem. It is no longer

possible to compile the unsupported statement shown above.

----> MATH Functions "Strip", "StripL", and "StripT" Corrupt Memory

When Argument is Empty or NULL

Issue Number: MC-3468

The MATH FSC functions "Strip", "StripL", and "StripT",

which were included in 7.2 SP1, cause an internal memory

problem when the argument passed in is a NULL or empty string.

The procedure-level work-around is to test to make sure the

length of the argument is greater than one before calling

"Strip", "StripL", or "StripT".

This distribution resolves the problem.

----> Error in 100 Ohm 385 RTD Specs in Fluke 8846A Accuracy File

Issue Number: MC-3463

In MET/CAL 7.2 SP1, and prior versions that support the

Fluke 8846A, there are errors in the gain specification in

the accuracy file sections that apply to the 100 ohm 385 RTD.

The error affects the following sections of the accuracy file:

(1) RTD Pt 385 100Ohm NPLC 100

(2) RTD Pt 385 100Ohm NPLC 10

(3) RTD Pt 385 100Ohm NPLC 1

(4) RTD Pt 385 100Ohm NPLC 0.2

(5) RTD Pt 385 100Ohm NPLC 0.02

The gain specification is incorrectly stated as 1.000 on lines

3, 4, 5, and 6 in each section listed above. The correct gain

specification value is 0.000.

This distribution includes an updated 8846A accuracy file

("8846.acc") that corrects this problem.

----> MATH FSC Does Not Trap Illegal Floating-Point Values In

Some Cases

Issue Number: MC-3575

In 7.2 SP1 and prior versions the MATH FSC does not

properly handle illegal double-precision floating-point

values in some cases.

The following case is handled in an acceptable manner:

MATH MEM = 1e307 * 1e3

The product of 1e307 and 1e3 is a number larger than the

maximum double-precision floating-point value (per IEEE 754).

When MET/CAL executes the statement above a floating-point

exception (FPE) occurs, terminating the MATH statement.

However, two cases that are not handled properly are:

(1) MATH MEM = 1e400

This statement directly assigns a value greater

than the maximum double-precision floating-point

value to a numeric register. This assignment

should generate an error message but, in fact,

the bit pattern representing "infinity" (printed as

"1.#INF") is assigned to MEM.

Allowing this bit pattern to be assigned may have

unacceptable consequences when the value is used in

subsequent expressions. For example, a relational

expression like:

IF (MEM == 1)

always succeeds when MEM is set to 1.#INF. (This is

a side-effect of MET/CAL's built-in epsilon-based

comparison designed to protect users from the

side-effects of floating-point rounding.)

In this case MET/CAL should be able to catch the

error at compile time.

(2) MEMI Enter the value 1e400

MATH MEM1 = MEM

This is a similar problem, but the 1.#INF value is

entered by a different means. I.e., rather than direct

assignment of a literal value, the illegal value is

entered indirectly. In this example MEMI is used,

but it could as well be IEEE, or any other procedure

statement that assigns a value to a numeric register

that is then directly accessed by the MATH FSC parser.

In this example, the error should be detected at

run time.

The problems described above are resolved in this distribution.

The MATH parser has been modified to check for illegal literal

floating-point numeric values in procedure statements, and

also prevent pushing an illegal floating-point numeric value

onto the runtime stack.

----> MATH Function "lbText" Fails to Force Inclusion of Static Text

in List Box Window

Issue Number: MC-3449

MET/CAL 7.2 SP1 included a family of new MATH FSC functions

used to configure and display list boxes.

A list box window optionally includes a scrollable static

text area above the list box. The optional static text area

may be enabled using the "lbConf" function with the argument

"+text". The default is "-text" (i.e., not enabled).

However, per the on-line help file for the MATH FSC:

"+text" configures the list box window to include

a scrollable, read-only text area above the list box.

The default is "-text". However, adding text lines to

the list box window automatically configures "+text".

I.e, making a call to "lbText" is supposed to override

the default and make it unnecessary to also include an

'lbConf("+text")' configuration call.

In 7.2 SP1 this does not work as intended. A call to

"lbText" does not, by itself, enable the read-only text

area above the list box. It is necessary to include an

'lbConf("+text")' call to display the text lines.

This distribution resolves the problem.

----> MATH Function Call "Uncv(0)" Fails When NMEAS = 1

Issue Number: MC-3448

The MATH FSC function "UNCV" is designed to retrieve individual

measurements in a sequence of one or more measurements taken

when measurement uncertainty is enabled.

The argument passed to "UNCV" specifies the index of the

measurement. The index is 1-based, so "UNCV(1)" gets the

1st measurement, "UNCV(2)" gets the 2nd measurement, and so on.

As a special case, "UNCV(0)" returns the average of the

measurements.

However, when the number of measurements is 1 (NMEAS = 1),

"UNCV(0)" always returns zero. It should return the average

of the measurements. I.e., since there's only one measurement,

it should return the same value that "UNCV(1)" returns.

This problem is present in 7.2 SP1 and earlier versions

that support the "UNCV" function.

This distribution resolves the problem.

----> MATH FSC List Box Function "lbShow" Fails When Window Has

Only Buttons

Issue Number: MC-3447

MET/CAL 7.2 SP1 included a family of new MATH FSC functions

used to configure and display list boxes:

lbAdd - add item to list box

lbAddList - add list of items to list box

lbAddV - add item to list box, with assoc. variable

lbButton - add button to list box window

lbClose - close list box window

lbConf - configure list box window

lbGetSel - get name of n-th selected list box item

lbGetSelX - get index of n-th selected list box item

lbNew - create new list box window

lbResp - get user's text response

lbSel - initially select list box item (by name)

lbSelCount - get count of selected list box items

lbSelX - initially select list box item (by index)

lbShow - display list box window

lbText - add text line to list box window

lbUnSel - remove initial selection of item (by name)

lbUnSelX - remove initial selection of item (by index)

In 7.2 SP1 "lbShow" fails when an attempt is made to

configure a list box that contains only a title and buttons

(i.e., does not contain read-only static text, does not contain

a list box, and does not contain a single line edit control).

The problem is resolved in this distribution.

----> Error in MATH FSC Functions "Insert", "Replace", "Write", and

"Delete"

Issue Number: MC-3446

MET/CAL 7.2 SP1 includes a family of new line-oriented

file functions:

Append - append line to file

Delete - delete line from file

EOF - determine if file is at end of file

Insert - insert line in file before specified line

LineCount - count lines of specified file

Read - read specified line from file

Replace - replace line in file

Write - write line to file after specified line

Four of the functions in this group (Append, Delete, Insert,

and Replace), depend on the creation and subsequent renaming

of a temporary file.

These four functions do not work correctly in 7.2 SP1

because the temporary file is removed before it can be renamed.

Any attempt to use one of these four functions results in

an error message indicating that the temporary file does

not exist. This aborts the intended change, and leaves the

original file as it was prior to the function call.

The problem is resolved in this distribution.

----> 4950 Test Function Fails in Demo Mode

Issue Number: MC-3445

In MET/CAL 7.2 and 7.2 SP1 the 4950 FSC test function

fails in demo mode.

This error is present in 7.2 and 7.2 SP1, but is not

present in earlier versions.

The underlying problem is that the test function parses

and checks the response to the STANDBY? query, but fails to

pre-load the buffer in demo mode with a valid response.

This problem does not affect the 4950A in real mode, and

does not affect the 1271A, 1281A, or 8508A in demo mode or

real mode.

A valid 4950A STANDBY? response is:

"00:00"

(The STANDBY? query is used to determine the time remaining

until the 4950A has stabilized and is ready for use.)

The problem is resolved in this distribution.

----> Second HEAD Statement Not Cleared When Procedure User-Terminated

Issue Number: MC-3444

7.2 SP1 includes support for a 2nd HEAD line on the Run

Time and Test Run main windows. The syntax used to specify

a 2nd HEAD line is:

HEAD -2 <text>

In 7.2 SP1, when the user terminates the procedure abnormally

by choosing "Terminate" in a prompt window (for example a

DISP statement), then choosing "Terminate" again in the Post

Test window, MET/CAL fails to clear the 2nd HEAD line.

The problem is resolved in this distribution.

-------------------------------------------------------------------------------

-------------------------------------------------------------------------------


Read Me MET/CAL 7.2 SP1

-------------------------------------------------------------------------------

-------------------------------------------------------------------------------

Fluke Calibration Software 7.2 SP1

MET/CAL 7.2.31 (7.20x)

Released: 2008-01

-------------------------------------------------------------------------------

Section 1: Table of Contents -------------------------------------------------

-------------------------------------------------------------------------------

1. Table of Contents

2. Introduction

3. Problem Reports

4. Enhancements

-------------------------------------------------------------------------------

Section 2: Introduction ------------------------------------------------------

-------------------------------------------------------------------------------

MET/CAL 7.2 SP1 is a service pack that corrects a number of defects

in MET/CAL 7.2. In addition, MET/CAL 7.2 SP1 implements a number

of product enhancements.

-------------------------------------------------------------------------------

Section 3: Problem Reports --------------------------------------------------

-------------------------------------------------------------------------------

----> 8920 FSC Readings Not Valid with NMEAS > 0 (with MOD4 blank,

'N', or 'C')

Report Number: 45445

Resolved: Jan 09 2008

Application: MET/CAL

In MET/CAL V7.20, and prior versions, the 8920 FSC does not

store valid readings in memory register MEM when NMEAS is

greater than 0 and the MOD4 field contains any code other than

'S'.

This error has been present since July 2002.

The only easy work-around is to use the 8920 FSC with NMEAS

set to zero.

V7.20 SP1 corrects this problem.

----> P525 FSC Automatic Connection Message Fails with P03 Pressure Module

Report Number: 45443

Resolved: Jan 09 2008

Application: MET/CAL

In MET/CAL V7.20 automatic connection messages for the 525

FSC with the P03 pressure module do not work.

For example:

P525 0.300psi 4% P03

fails due to a missing connection message.

The error message generated is:

E3186: No connection message for pressure module

525A-P03 (device code 176).

V7.20 SP1 corrects this problem.

----> 8845 FSC Generates Accuracy Lookup Error When Range Locked To

750 VAC In Fast Mode ("D4") With Configured 8846A

Report Number: MC-3437, MC-3438

Resolved: Jan 03 2008

Application: MET/CAL

In MET/CAL V7.20, when the 8845 FSC is used with a configured

Fluke 8846A an accuracy lookup error occurs in the 750 VAC

range in "fast" mode.

For example, the following statements cause this error to

occur when used with an 8846A:

1.001 M8845 RNGLK 750V

1.002 8845 230.0V 50H D4 N 2W

V7.20 SP1 corrects this problem. The driver now uses the

"1000V" section of the accuracy file for both the 750 and

1000 VAC ranges, and the 8845 accuracy file has also been

updated to accommodate this driver change. An updated 8845

accuracy file ("8845.acc") in included in V7.20 SP1.

----> 5320 Driver Reports Operation Complete (OPC) Timeout When

Line/Loop Scan Or Manual Mode Selected

Report Number: MC-3356

Resolved: Jan 02 2008

Application: MET/CAL

When the 5320A performs a scan it may take up to 38 seconds

when Line/Loop mode is selected, and Line/Loop is set to

SCAN or MAN.

In MET/CAL V7.20 the OPC setup timeout is set to 10 seconds

unconditionally. This means that an OPC timeout will occur

if the 5320A performs a scan that takes longer than 10 seconds.

V7.20 SP1 increases the timeout to correct the problem.

----> 5320 FSC High Resistance Upper Limit Incorrect

Report Number: MC-3433

Resolved: Jan 02 2007

Application: MET/CAL

In MET/CAL V7.20 the high resistance upper limit enforced

by the 5320 FSC is incorrectly set to 100 GOhm. V7.20 SP1

corrects the limit. The limit is now set to 10 GOhm.

----> 5320 Driver Fails When Action is "Slew"

Report Number: MC-3435

Resolved: Dec 07 2007

Application: MET/CAL

In MET/CAL V7.20 statements that specify "Slew" as the action

fail to execute correctly. The 5320A reports the error:

-113,"Header error"

The underlying problem was that the 5320A run time driver

did not include "SAFety" in the SCPI command header.

V7.20 SP1 corrects this problem.

----> 5320 Slew Dialog Shows Incorrect Resolution When Using

Resistance Multiplier

Report Number: MC-3434

Resolved: Dec 07 2007

Application: MET/CAL

In MET/CAL V7.20 the 5320 driver's slew dialog does not

display the correct resolution when the procedure statement

includes the parameter "ResistanceMultiplierOn".

V7.20 SP1 corrects this problem.

----> VSET Help File Does Not Document "Tol_Ref = System_Actual"

Report Number: 44250

Resolved: Nov 26 2007

Application: MET/CAL (Documentation)

MET/CAL V7.20 added support for the specification of

"System_Actual" as a valid value for the VSET "tol_ref"

parameter. However, the on-line help for the VSET FSC failed

to document this change.

V7.20 SP1 includes an updated VSET help file that documents

the change.

----> Table Permissions Displayed Incorrectly for Segregate User

Report Number: MC-3429

Resolved: Nov 16 2007

Application: MET/TRACK

In MET/TRACK V7.20, if a user is assigned to a segregate,

it is possible for the table permissions to be displayed

incorrectly. The problem is that the query issued to the

database to retrieve table permissions does not filter based

on the user's segregate. Permissions for the base tables

may appear to "randomly" reset privileges for segregate views.

V7.20 SP1 includes an updated version of MET/TRACK that

corrects this problem.

MET/TRACK Build #444 or later is required.

----> 5500 & 5520 Evaluations in Some Measurement Modes

Fail When NMEAS > 1

Report Number: 44800

Resolved: Nov 06 2007

Application: MET/CAL

In MET/CAL V7.20, and earlier versions, 5500 and 5520 FSC

evaluations in certain measurement modes fail when measurement

uncertainty is enabled and NMEAS > 1.

The problem affects the following modes:

5500A

MOD3 Mode

---- ----

TN Thermocouple Measurement (open TC detection off)

ZM SC600 UUT Input Impedance Measurement

5520A

MOD3 Mode

---- ----

HM Humidity Measurement

TN Thermocouple Measurement (open TC detection off)

ZM SC600 or SC1100 UUT Input Impedance Measurement

For example:

ASK+ K U

VSET NMEAS = 2

5520 50.00Z 1.0% ZM 2W

demonstrates the problem. The problem is that the UUT value

("UUT Indicated") is reported as zero.

The problem has been corrected in V7.20 SP1. V7.20w or

later is required.

----> 8901 & 8902 FSCs Updated for AM/FM Residual Specs

Report Number: MC-3420,MC-3421,MC-3422,MC-3423,MC-3424,MC-3425

Resolved: Nov 05 2007

Application: MET/CAL

In MET/CAL V7.20 SP1 the 8901 and 8902 FSCs have been modified

so that:

(1) When the M8901 FSC Nominal field specifies a Modulation

Frequency of 0 Hz, and the 8901 MOD3 field is "AM",

Residual AM accuracy is returned for the measurement.

(2) When the M8901 FSC Nominal field specifies a Modulation

Frequency of 0 Hz, and the 8901 MOD3 field is "FM",

Residual FM accuracy is returned for the measurement.

(3) When the M8902 FSC Nominal field specifies a Modulation

Frequency of 0 Hz, and the 8902 MOD3 field is "AM",

Residual AM accuracy is returned for the measurement.

(4) When the M8902 FSC Nominal field specifies a Modulation

Frequency of 0 Hz, and the 8902 MOD3 field is "FM",

Residual FM accuracy is returned for the measurement.

This enhancement involved changes to both the 8901 and 8902

FSCs, as well as changes to the corresponding accuracy files.

V7.20w or later is required.

----> VSET On-Line Help Fails to Document TOL_REF = SYSTEM_ACTUAL

Report Number: 44676

Resolved: Oct 31 2007

Application: MET/CAL

In MET/CAL V7.20 the VSET/TSET/INI parameter TOL_REF was

enhanced to support a new value ("SYSTEM_ACTUAL"). This was

documented in the V7.20 readme file, but was not documented

in the on-line help for the VSET FSC.

V7.20 SP1 includes updated on-line help for the VSET FSC

that covers TOL_REF = SYSTEM_ACTUAL.

----> No Error Message for Invalid NVI FSC Dimensionless Numeric Value

Report Number: 44559

Resolved: Oct 25 2007

Application: MET/CAL

In MET/CAL V7.20, and earlier versions that support NVI FSCs

(not including the 6100 FSC), NVI statements that specify an

illegal value for a parameter that requires a dimensionless

numeric value fail to generate an error message. The error

is detected -- MET/CAL does not compile the statement,

but it's confusing due to the lack of an error message.

For example, the statement:

5320 TripCurrentMultiplier = TCM

cannot be compiled, but no error message is generated.

FSCs affected are 5320, 9640, N5531, and PSA.

V7.20 SP1 corrects this problem.

Requires V7.20v or later.

----> High Voltage Danger Window ("Safety Symbol") May Be Off-Screen

Report Number: 44556

Resolved: Oct 25 2007

Application: MET/CAL

In MET/CAL V7.20, and earlier versions, the safety symbol

(i.e., the high voltage lightning bolt warning) is positioned

close to the upper right corner of the parent window (Run

Time or Test Run).

This means that if the user positions the parent window so

that the upper right corner is substantially off-screen,

the safety symbol window may be either partly or entirely

off-screen when it pops up.

In MET/CAL V7.20 SP1 the initial position of the "Safety

Symbol" window has been adjusted to prevent the window

from being off-screen, regardless of the position of the

parent window.

V7.20v or later is required.

----> Due Date Calculated Incorrectly When Invalid Cal Interval

Type Specified

Report Number: MC-3270

Resolved: Oct 15 2007

Application: MET/TRACK

In MET/TRACK V7.20 (Build #434) is a user enters an invalid

cal interval type (for example, "Y"), MET/TRACK calculates

an incorrect due date.

In V7.20 SP1 MET/TRACK has been changed so that if a user

enters an invalid interval type, a pop-up error dialog

is displayed.

Build #443 or later is required.

----> MET/CAL Fails To Close Package File After Unpack Operation

Report Number: 43811

Resolved: Oct 11 2007

Application: MET/CAL

In MET/CAL V7.20, the Editor does not close a package file

(<file>.pkm) after completing an unpack operation.

Not closing the package file prevents it from being deleted

until the Editor is closed.

MET/CAL V7.20 SP1 resolves this problem.

V7.20u or later is required.

----> Leakage Current Documented Incorrectly for Differential and

Passive Modes in 5320 FSC On-Line Help

Report Number: MC-3407

Resolved: Oct 11 2007

Application: MET/CAL Documentation

In MET/CAL V7.20 the "LeakageCurrent" section of the 5320

help file does not correctly describe the way the FSC

(driver) functions.

V7.20 SP1 includes an updated 5320 help file that corrects

the documentation.

----> 5320 Statement Using Ground Bond Resistance Mode Generates

Accuracy Lookup Error When Evaluation Quantity is "MaxCurrent"

Report Number: MC-3406

Resolved: Oct 11 2007

Application: MET/CAL

In MET/CAL V7.20 there's an accuracy file lookup error when

using the 5320 FSC in ground bond resistance mode when the

evaluation quantity is "MaxCurrent".

An example of a statement that generates the error is:

5320 Mode=GBR; Res=0.025 Ohm +MaxCurrent=10 A; Oper

The error message generated is:

E132: FSC 5320 required accuracy data not found in

Accuracy file.

V7.20 SP1 resolves this problem.

The solution required a change to the MET/CAL FSC, not the

5320 accuracy file.

V7.20v or later is required.

----> 5320 Statement Using High Resistance Mode Generates Accuracy

Lookup Error When Evaluation Quantity is "MaxVoltage"

Report Number: MC-3405

Resolved: Oct 11 2007

Application: MET/CAL

In MET/CAL V7.20 there's an accuracy file lookup error when

using the 5320 FSC in high resistance mode when the evaluation

quantity is "MaxVoltage".

An example of a statement that generates the error is:

5320 Mode=HR; Res=0.5 MOhm; +MaxVoltage=500 V; Operate

The error message generated is:

E132: FSC 5320 required accuracy data not found in

Accuracy file.

V7.20 SP1 resolves this problem.

The solution required a change to the MET/CAL FSC, not the

5320 accuracy file.

V7.20v or later is required.

----> Copy To C2376 Using Dutch Regional Settings Fails

Report Number: MC-3398

Resolved: Oct 02 2007

Application: MET/TRACK

In MET/CAL V7.20, using MET/TRACK build #434, copying field

C2376 may fail when using Dutch regional settings.

The fractional part of a numeric price value, when using a

comma (',') as the decimal symbol, is omitted when the copy

is performed.

V7.20 SP1 resolves this problem. MET/TRACK build #442 or

later is required.

----> PM 6306 Capacitance Measurement At 100 Hz Fails

Report Number: 42218

Resolved: Sep 10 2007

Application: MET/CAL

In MET/CAL V7.20 the 6306 FSC fails when a 1 microfarad

capacitance measurement at 1 V, 100 Hz is attempted.

The MET/CAL procedure statements that generate the error are:

M6306 1V

6306 1.0000uF 100H N 4W

The commands the MET/CAL driver sends to the PM 6306 to

implement the MET/CAL statements shown above are:

*CLS;SIN;MEA_FAST OFF;RNG_HOLD OFF;FRE 100;AC_LEV 1;

DC_BIAS OFF;PARAM IMP;POS_FIX C;MODE AUTO

After this command sequence is sent the driver queries the

PM 6306 to check for errors. The driver always detects an

error at that point:

ERROR 170/ILLEGAL PARMETER.

On investigation it was discovered that, due to firmware

differences between the PM 6034 and the PM 6306, the command

shown above fail due to the inclusion of "POS_FIX C" in the

command sequence.

The limitation on the use of the POS_FIX command applies to

"SIN" mode. Changing "SIN" to "CONTIN" removes the "ILLEGAL

PARMETER" error. However, continuous measurement mode is

not appropriate for MET/CAL's purpose.

The PM 6304 and PM 6304C do not have this issue, because they

don't support the POS_FIX command. Instead, the "LOCK C"

command is used with the 6304[C].

This problem is resolved in MET/CAL V7.20 SP1. The 6306 FSC

no longer includes the "POS_FIX" command in command strings

sent to the instrument. This change does not affect the

capacitance value read from the instrument by MET/CAL.

----> Source Copy To Memo Field Fails

Report Number: MC-3266

Resolved: Aug 28 2007

Application: MET/TRACK

In MET/CAL V7.20 (MET/TRACK build #434) a source copy from

any field into a memo field fails because the updated value

is not saved when the record is saved.

An example is a source copy from I4260 to C2384.

The underlying problem is that when copying from one field

to a memo field, an internal status flag indicating that

the value of the copied-to field has changed is not set.

This causes the field to be omitted when the SQL "INSERT"

statement is constructed to save the record.

V7.20 SP1 corrects this problem. MET/TRACK build #441 or

later is required.

----> Error Configuring Default Serial Port In Chinese Windows

Report Number: MC-3380

Resolved: Aug 27 2007

Application: MET/CAL

In MET/CAL V7.20, when running under Chinese Windows, the

following error may be generated when using the MET/CAL

"Configuration" menu to set the default serial port to "None":

E2194: Internal Error: Can't get index for "None"

in COMM port combo box.

V7.20 SP1 corrects this problem.

----> Segregate User May Encounter Error When Deleting Location Record

Report Number: MC-3379

Resolved: Aug 23 2007

Application: MET/TRACK

In MET/CAL V7.20, a MET/TRACK error may be generated in the

following way:

1) Create a new segregate (such as "test").

2) Assign an asset with location history to this

new segregate.

3) Associate a user with the new segregate, making

sure the security level is 4 or 5 for this user.

5) Login to MET/TRACK as this segregate user.

6) Attempt to delete a location record for an asset

in the user's segregate.

V7.20 SP1 corrects this problem. MET/TRACK build #440 or

later is required.

----> MET/TRACK Fails When Customer List Exceeds 32767 Customers

Report Number: MC-3375

Resolved: Aug 16 2007

Application: MET/TRACK

In MET/CAL V2.0 MET/TRACK generates an overflow error

when editing the customer list if the number of customers

exceeds 32767.

V7.20 SP1 corrects this problem. MET/TRACK build #438

is required.

----> 5320 FSC RCDC With Evaluation Quantity "MaxCurrent" Causes

Limits Error

Report Number: MC-3373

Resolved: Aug 15 2007

Application: MET/CAL

In MET/CAL V7.20 the following "5320" statement:

1.001 5320 Mode = RCDC; +MaxCurrent = 10 mA;

1.001 5320 TripCurrent = 10 mA

1.001 5320 Setup

generates the error message:

E1407: FSC 5320: Cannot determine limits for

+MaxCurrent in amps.

V7.20 SP1 corrects this problem.

----> 9640A FSC Amplitude Modulation Limits Error With Triangle Wave

Report Number: MC-3369

Resolved: Aug 08 2007

Application: MET/CAL

In MET/CAL V7.20, due to a mistake in the manual, the 9640 FSC

did not support the true capabilities of the instrument in AM,

specifically, when using an internal triangle wave. Using an

otherwise legal setting for the instrument, MET/CAL returns:

E7743: FSC 9640: "Modulation Frequency = 200 kHz"

is outside the legal range. Limits are 20Hz

to 10kHz.

In actuality, the limits are:

When carrier frequency < 125 MHz, the allowed

(triangle) rate is 20 Hz to 220 kHz.

When carrier frequency >= 125 MHz, the allowed

(triangle) rate is 20 Hz to 100 kHz.

The AM limits check has been corrected in MET/CAL V7.20 SP1.

----> "ZR" Cannot Be Specified in P525 Statement with PA5

Report Number: 42894

Resolved: Aug 07 2007

Application: MET/CAL

In MET/CAL V7.20 a problem in the P525 FSC prevents the

following statement from being compiled:

P525 1.000bar N ZR PA5

MET/CAL generates the following error message when an attempt

to compile the above statement is made:

E4387: FSC P525: Pressure (NOMINAL Value) must be

zero when MOD3 is "ZR".

This error message is valid for non-absolute pressure modules,

but is not valid for the PA5, which is an absolute module.

V7.20 SP1 resolves this problem. (V7.20r or later is

required.)

----> P525 Statement Generates "Connection Message Not Valid" Error

Report Number: 42883

Resolved: Aug 07 2007

Application: MET/CAL

In MET/CAL V7.20 there's an error in the P525 FSC when a

525A-PA5 pressure module is used. For example, executing

a statement like this:

P525 1.000bar 0.2U PA5

generates the error:

E2705: Connection message number (<n>) is not valid.

(The value displayed as <n> in the error message may be any

integer value.)

This problem cannot be worked around by disabling automatic

connection messages.

V7.20 SP1 resolves this problem. (V7.20r or later is

required.)

----> 5320 High Resistance Mode Maximum Test Voltage Incorrectly

Calculated When Multiplier Specified

Report Number: MC-3366

Resolved: Jul 17 2007

Application: MET/CAL

In MET/CAL V7.20 the 5320 FSC incorrectly calculates the

maximum test voltage when the multiplier is used.

For example, the 5320 statement:

1.001 5320 Mode = HR; TestVolt = 5000 V

1.001 5320 +Res = 1.00 GOhm; ResMultOn

incorrectly generates the error message:

E7743: FSC 5320: "TestVolt = 5000 V" is outside the

legal range. Limits are 0V to 1.575 kV.

V7.20 SP1 corrects this problem.

----> Error in 5320 FSC Line/Loop Resistance Accuracy Calculation

Report Number: MC-3365

Resolved: Jul 17 2007

Application: MET/CAL

In V7.20 the 5320 FSC accuracy calculation fails to include

the 1% + 15 mOhm adder when using line/loop impedance source

in "correction scan" and "correction COMP" modes.

V7.20 SP1 corrects the accuracy calculation by including

the required adder.

----> Error in 5320 FSC High Resistance Accuracy Calculation

Report Number: MC-3364

Resolved: Jul 17 2007

Application: MET/CAL

In MET/CAL V7.20 the 5320 FSC high resistance mode accuracy

calculation failed to account for footnote #1 (in the

extended specifications).

The footnote states:

[1] Uncertainty is valid to 500 volts. For test

voltages above 500 V, add 0.1 % for each 200 V above

500 V.

In V7.20 SP1 the 5320 FSC now includes the additional

uncertainty for voltages above 500 V in high resistance mode.

----> 5320 FSC Accuracy Lookup Error in Meter Mode

Report Number: MC-3363

Resolved: Jul 17 2007

Application: MET/CAL

In MET/CAL V7.20 the following statements:

1.001 5320 Mode = Meter; +Volt = 5 V; Measure

1.002 MEMC 5.0V 1%

incorrectly generate the following accuracy lookup error:

E1699: Error determining reference accuracy from

"5320" statement.

V7.20 SP1 corrects the problem.

----> NVI FSCs Fail To Prevent Multiple Parameters When Action Is

"Reset"

Report Number: 42415

Resolved: Jul 13 2007

Application: MET/CAL

Due to a missing compile-time error check in the NVI FSCs

(name/value instrument FSCs) the V7.20 MET/CAL Editor allows

statements with the action specifier equal to "Reset" and

with one additional parameter to be specified.

In fact, when the action is "Reset" no other parameters

should be allowed in the NVI statement.

Example:

N5531 Reset; Freq = 100 MHz

In V7.20 the Editor compiles the statement shown above

without errors. However, an error message should be generated

indicating that when "Reset" is specified no other parameters

are allowed.

This problem does not affect the "6100" FSC, but it affects

all other NVI FSCs in V7.20: 5320, 9640, N5531, and PSA.

V7.20 SP1 resolves this problem by adding the missing

error check. (V7.20o or later is required.)

----> M4419 FSC Does Not Allow Default On Channel A & Table Name On

Channel B

Report Number: 42332

Resolved: Jul 05 2007

Application: MET/CAL

In all versions of MET/CAL that support the Agilent E4418B

or E4419B, up through and including V7.20m, the M4419 FSC

does not allow the procedure to specify that the default

calibration table is to be used for channel A and a non-default

calibration table is to be used for channel B.

The problem is that in order to specify that the default

calibration table is to be used on channel A it is necessary

to leave the TOLERANCE field in the M4419 statement blank.

To specify a non-default table for channel B it is necessary

to specify the table name, in quotes, in the MOD2-through-CON

fields of the M4419 statements, However, since the field

recognition and parsing code in the M4419 FSC implements

exactly the same rules for the channel A and channel B table

names, it always recognizes the name specified for channel

B as a valid channel A table name, and moves the table name

to the TOLERANCE field.

Therefore, for example, if the procedure writer enters:

FSC RANGE NOMINAL TOLERANCE MOD1 MOD2 3 4 CON

M4419 F256 8481A 8484A "t1"

MET/CAL compiles the statement as:

FSC RANGE NOMINAL TOLERANCE MOD1 MOD2 3 4 CON

M4419 F256 8481A "t1" 8484A

This problem is resolved in V7.20 SP1. (V7.20n or later

is required.)

The M4419 FSC now allows the word "Default" to be optionally

entered into the TOLERANCE field. "Default" is equivalent

to <blank> in that it indicates that the default cal table

for the sensor is to be used. However, since it occupies

the field, it allows MET/CAL to realize that a subsequently

entered table name must be a channel B calibration table.

Using the example shown above, the statement should now be

entered as:

FSC RANGE NOMINAL TOLERANCE MOD1 MOD2 3 4 CON

M4419 F256 8481A Default 8484A "t1"

----> Case Changed in Unrecognized Discrete String Parameter Values

in Name/Value Instrument FSCs

Report Number: 42165

Resolved: Jun 21 2007

Application: MET/CAL

In MET/CAL V7.20, MET/CAL alters the case of unrecognized

discrete string values in name/value instrument FSC statements.

The following FSCs are affected:

5320

6100

9640

N5531

PSA

If the discrete string value is recognized by doing a

case-insensitive comparison against values stored in an

internal table, then the value string is converted to the

representation in the external table.

Example 1:

As-entered text: 9640 ModulationWaveForm = sine

As-printed test: 9640 ModulationWaveForm = Sine

(This is correct.)

However, when the value string is not recognized, MET/CAL

reprints it with the first character upper-case, and the

remaining characters lower-case.

This algorithm may cause a problem when the value string

contains an embedded construction that references a

MET/CAL variable. The problem does not occur with MET/CAL

"registers" because register names are case-insensitive.

Named variables, however, are case-sensitive, so changing

the case to lower-case invalidates the reference if the name

contains upper-case characters after the 1st character.

Example 2:

As-entered text: MATH @Waveform = "Sine"

9640 ModulationWaveForm = [V @Waveform]

As-printed text: MATH @Waveform = "Sine"

9640 ModulationWaveForm = [v @waveform]

(This is not correct. The variable name "@Waveform"

has been changed to "@waveform".)

Work-arounds for this problem are:

(1) Use a lower-case variable name.

(2) Transfer the variable value to a string

register and specify the register name in the

[v ...] construction in the NVI FSC discrete

string value specification.

This problem is not specific to V7.20. All NVI FSCs in all

versions up to and including V7.20k are affected. The 6100

FSC is affected as well.

V7.20 SP1 resolves this problem. (V7.20l or later is

required.) When a discrete string parameter value in an

NVI FSC statement contains embedded special constructions

it is now left unchanged when the line is reprinted by the

procedure compiler.

----> 9640 Expanded Uncertainty Incorrect When Units are dBm or dBuV

Report Number: 39994

Resolved: Jun 21 2007

Application: MET/CAL

MET/CAL V7.20 does not correctly calculate the expanded

uncertainty for 9640 statements in which the evaluation

quantity is specified in dBm or dBuV.

The calculation is done properly in linearized units

(watts). The problem arises in the last step when MET/CAL

back-converts the uncertainty to logarithmic units (in this

case dBm or dBuV).

V7.20 SP1 resolves this problem.

----> Safety Symbol Not Displayed In Some Cases

Report Number: 40951

Resolved: Jun 20 2007

Application: MET/CAL

In V7.20, and earlier versions, in certain situations MET/CAL

fails to display the "Safety Symbol" high voltage warning.

The problem occurs when there are multiple signals present,

and one or more signals involving non-voltage units are set

up prior to the unsafe signal.

For example, a procedure that does the following:

525 1Z S

5520 100V S

exhibits this problem.

As a practical matter, this situation was unlikely to arise

prior to the addition of the MATH FSC "SafeOn" and "SafeOff"

functions. However, with the release of V7.20, which included

"SafeOn" and "SafeOff", tests where the system reference is

sourcing a safe non-voltage signal, and the UUT is sourcing

a dangerous voltage, may occur.

V7.20 SP1 corrects this problem.

----> Incorrect Value for User-Defined Date Field Returned by

"metgendb.dll"

Report Number: 42118 (MC-3344)

Resolved: Jun 19 2007

Application: MET/CAL Runtime

In MET/CAL V7.20, and probably in earlier versions as well,

when "metgendb.dll" is called to retrieve the value of a

user-defined date field, the returned value is invalid.

For example, the value returned is like this:

'2007-06-19'

The surrounding single quotes shown above are part of the

returned value, but should not be. The returned value

should be:

2007-06-19

It's likely that the same problem exists for all database

date fields, but that has not been confirmed. The specific

problem reported affected the user-defined field 2372.

The problem is compounded by the fact that when "metgendb.dll"

is queried to determine the maximum length of field 2372,

it reports that the maximum length is 10 characters. If the

calling program provides a buffer of exactly the required

length, then, when the query for the value is performed,

"metgendb.dll" reports that the return value is too small

for the provided buffer. (That's true, but only because

"metgendb.dll" is attempting to return an invalid value.)

This problem manifests itself in the MET/CAL Runtime

application a reference to a user-defined date field is

included in one of the prompt files (pre-prompt, pass-prompt,

or fail-prompt).

For example, adding this line to the pass-prompt file:

Field 2372 :D: F2372$ 2372

suffices to generate the problem.

V7.20 SP1 corrects this problem. (Any version of

"metgendb.dll" dated June 19 2007 20:55 or later corrects

this problem.)

----> Measurement Uncertainty Parameters Not Reliably Retrieved

from Database

Report Number: 41960 (MC-3341)

Resolved: Jun 08 2007

Application: MET/CAL

In MET/CAL V7.20 the database-specified measurement uncertainty

parameters are not reliably retrieved by MET/CAL.

The parameters in question are:

"Coverage Factor"

"Number of significant digits for output"

"Use Student's T"

"Number of Measurements"

Specifying these parameters in the MET/CAL initialization

file or in a procedure (using VSET or TSET) works reliably.

This problem is probably present in all versions of MET/CAL

that support measurement uncertainty (up to and including

V7.20i).

The reason the problem has not been reported previously is

most likely a combination of:

(a) Since measurement uncertainty may not work

out of the box for all procedures, it generally

makes sense to enable it selectively in individual

procedures that have been reviewed and tested

for measurement uncertainty compliance.

(b) The operation of retrieving the parameters listed

above from the database operates properly some

of the time. (The internal source of the problem

was traced back to an unset integer variable.

If the initial value of the variable happened to

be non-zero, the parameters were retrieved from

the database properly. If the initial value of

the variable happened to be zero, the default

values of the parameters were used.)

The problem is resolved in V7.20 SP1. (V7.20j or later

are required.)

----> Run Time Post Run Prompt Data Not Reset After Database Error

Report Number: 41906 (MC-3340)

Resolved: Jun 06 2007

Application: MET/CAL Runtime

In MET/CAL Runtime V7.20, and probably prior versions, a

problem related to theMET/CAL Runtime pre-prompt and post-prompt

windows occurs as a side-effect of a database related error.

The initial problem, which leads to the problem reported here,

is that when a Post Run prompt for a user-defined

date field (like 2372) is added, "metgendb.dll" reports that the

maximum length for the field is some value, N, but then

attempts to send back N+2 bytes. (This happens because

it surrounds the date with single quotes.) Since MET/CAL

allocates a buffer of exactly N+1 bytes, not N+3 bytes,

"metgendb" then generates an error indicating that the

value to be returned is too long for the buffer provided.

MET/CAL traps the error in the Post Run prompt module,

generates an error message, and aborts the procedure. The

secondary problem is that when MET/CAL aborts the procedure

it fails to free the internal prompt data built up for the

post prompt window. This leads to a situation where, when

another procedure is run, without having exited from the Run

Time application, the pre-run prompts are appended to the

left-over post-run prompts, and things get thoroughly confused.

Resolved in V7.20 SP1. the MET/CAL Runtime application now releases

internal memory used for prompt window data after a database

error occurs. (Requires V7.20h or later.)

----> Missing Error Check When M5520 Nominal Units are Ohms

Report Number: 41904 (MC-3339)

Resolved: Jun 06 2007

Application: MET/CAL Editor

In V7.20 and prior the M5520 FSC compile time checks

incorrectly allow the statement:

M5520 1kZ

to be compiled.

In fact, it should be necessary to specify "IMPED" in the M5520

RANGE field when M5520 NOMINAL field units are ohms ("Z").

This leads to a floating point exception when the subsequent

associated statement is checked:

5520 -3D 0.1U 1kH SI

Resolved in V7.20 SP1. Requires V7.20i or later.

----> Erroneous ACV-to-ACV Settings Conflict Determination in 9100 FSC

Report Number: MC-3336

Resolved: Jun 05 2007

Application: MET/CAL

In MET/CAL V7.20, and prior versions, the 9100 FSC incorrectly

determines that a possible settings conflict exists in a

transition from:

(FUNC SIN, VOLT 60, FREQ 50)

to:

(FUNC SIN, VOLT 70, FREQ 50)

Because the FSC run time believes there may a settings

confict, it therefore programs the 9100 to 1 V @ 60 Hz,

before attempting to send the commands to program the

instrument to 70 V @ 50 Hz.

This prevents the following procedure from operating as

designed. The UUT is a low impedance device that must be

ramped up from 20 V to 70 V. Transitioning directly from 1

V to 70 V causes an overload condition.

9100 20V 50H SI S 2W

SCPI [@9100]func sin;:volt 40

SCPI [@9100]func sin;:volt 60

SCPI [@9100]func sin;:volt 70

9100 600 70.0V 1.5% 0.005U 50H SI 2W

In V7.20 SP1 the 9100 FSC run time has been updated so that

it no longer incorrectly concludes that a transition from

60 V @ 50 Hz (sine) to 70 V @ 50 Hz (sine) represents a

possible settings conflict.

----> Port Configuration Construction Fails with 55XX & 58XX

Pass-Through Ports

Report Number: 41535 (MC-3332)

Resolved: May 18 2007

Application: MET/CAL

In MET/CAL V7.20 there's an error in the Port Configuration

construction that prevents making a direct reference to a

pass-through serial port on a Fluke calibrator.

The problem applies to the following COM ports:

COM5500

COM5520

COM5800

COM5820

An example of a construction that no longer operates correctly

in V7.20 is:

PORT [PCOM5500,300,N,8,1,N]

The problem does not occur when the COM port specifier

is omitted. This means that the problem does not generally

affect procedures where the UUT is on the pass-through port.

For example, it's still ok to configure COM5500 as the

default serial port, and then include a construction like:

PORT [P300,N,8,1,N]

in the procedure.

The problem is therefore really specific to cases where a

reference instrument is being accessed on the pass-through

port.

The underlying problem was introduced when support for

COM ports COM5 to COM16 was added to MET/CAL. Due to a

parsing error, the designators COM5500, COM5520, COM5800,

and COM5820 were taken to be the same as COM5.

Resolved in V7.20 SP1. (Requires V7.20g or later.)

----> 5320 FSC Run Time Does Not Set IDS UUT Output Resistance

Report Number: MC-3329

Resolved: May 14 2007

Application: MET/CAL

In MET/CAL V7.20 when a 5320-based leakage current test like

the following:

1.001 5320 Mode = IDS; +LeakageCurrent = 3.50 mA

1.002 5320 UUTOutputResistance = 1000 Ohms

1.003 TARGET -m

1.004 MEMI Enter UUT reading in milliamps:

1.005 MEMCX 20 3.50mA 2.5% 0.05U

is executed, the 5320 FSC run time fails to set the UUT

output resistance to the value specified.

V7.20 SP1 corrects this problem.

----> 5320 Statement Specifying High Resistance Short Causes Run

Time Error

Report Number: MC-3324

Resolved: May 03 2007

Application: MET/CAL

In MET/CAL V7.20 the following statement:

5320 Mode=HR; +Res=0 Ohm; Short

generates the following error message when executed:

E2075: Fluke 5320A: -220,Invalid parameter

In V7.20 SP1 the 5320 FSC run time has been updated to

correctly implement the specified operation.

----> 5320 FSC Missing Error Check To Prevent Measuring Test Voltage

when High Resistance Source Short Selected

Report Number: MC-3323

Resolved: May 03 2007

Application: MET/CAL Editor

In MET/CAL V7.20 the 5320 FSC compile time checks fail to

generate an appropriate error message for the following

statement:

5320 Mode=HR; +TestVolt=0 V; Res=0 Ohm; Short; Setup

The 5320A cannot measure the test voltage when

"High Resistance Source Short" is selected.

V7.20 SP1 corrects this problem.

----> 5320A Accuracy File Specifies NA for GBR & Line/Loop Current

Measurement Accuracy

Report Number: MC-3322

Resolved: Apr 25 2007

Application: MET/CAL (Accuracy File)

In MET/CAL V7.20 the 5320 accuracy file fails to specify

specifications for ground bond resistance and line/loop

current.

V7.20 SP1 includes an updated 5320 accuracy file that includes

the proper specifications.

----> 8845 FSC Frequency Upper Limit Incorrect

Report Number: MC-3321

Resolved: Apr 19 2007

Application: MET/CAL

In MET/CAL V7.20 the 8845 FSC allows frequencies up to

300 MHz to be specified. This upper limit is incorrect.

The limit should be 300 kHz.

V7.20 SP1 corrects the frequency upper limit.

----> 5320 FSC LowResistance TestCurrent Limits are Incorrect

Report Number: MC-3315

Resolved: Apr 11 2007

Application: MET/CAL

In MET/CAL V7.20 the following statement:

5320 Mode=LR; Res=5 Ohm; +TestCurrent=200 mA; Setup

generates the error message:

E7743: FSC 5320: "+TestCurrent = 200 mA" is outside

the legal range. Limits are 0A to 5 mA.

This error message is not valid. The maximum test current

at 5 ohms is 250 mA.

V7.20 SP1 corrects this problem.

----> Fluke 80K-40 Not in List of Standards Used When 5320 Statement

Specifies "Probe = 40 kV"

Report Number: MC-3314

Resolved: Apr 09 2007

Application: MET/CAL Runtime

In MET/CAL V7.20, when a 5320 FSC statement specifies

"Probe = 40 kV", the 5320A is programmed to expect the

Fluke 80K-40 "40 kV" probe to be connected to the 5320A

METER INPUT V and COM terminals. The 80K-40 is a traceable

reference used for the measurement and should be included

in the list of standards used written to the database when

the calibration results are saved. However, the MET/CAL Runtime

application fails to include the 80K-40 in the list of

standards used.

V7.20 SP1 corrects this problem.

----> Standards Table Update Fails with Multiple Aux Devices &

Dynamic Asset Prompt

Report Number: 40210 (MC-3292)

Resolved: Feb 26 2007

Application: MET/CAL

In MET/CAL Runtime V7.20 there are some situations in which

the application fails to successfully update the Standards

Table in the database at the end of a calibration.

The failure scenario occurs in the following circumstance:

(1) Multiple secondary devices of the same model

are configured.

(2) The asset number of the secondary device required

by the procedure is not specified in the system

configuration information. (In this case the

Run Time application prompts for the asset number

just prior to procedure execution.)

(3) The secondary device used by the procedure is

not the first occurrence of that model listed in

the system configuration information.

If the three conditions described above are met MET/CAL

prompts for the asset number of the secondary device,

but then associates the entered asset number string with

the wrong secondary device. Then, at the conclusion of

the calibration, the application has an empty asset number

string for the secondary device. That, in turned, causes the

operation which updates the database Standards Table to fail.

This generates the error:

E5490: Can't add standard () to cal event information

in database. Function error.

The problem is resolved in V7.20 SP1. (A MET/CAL Runtime

build later than Feb 26 2007 4:06 PST is required to obtain

the correction.)

----> Error When Changing the Number of Configured IEEE-488 Boards

Report Number: 40103 (MC-3289)

Resolved: Feb 20 2007

Application: MET/CAL

In MET/CAL V7.20 attempting to change the number of configured

IEEE-488 boards from 1 to 2 causes the following error

message to be generated:

E596 : The address of the second IEEE-488 board must

be specified when the number of IEEE-488 boards is 2.

A work-around is to manually edit the MET/CAL initialization

file and change the value of "ib_ioaddr" from "210" to

"210, 220".

It's not entirely clear what triggered the problem. Probably

the MET/CAL Install Program performed an invalid upgrade

step by causing 2-board systems to revert to "ib_nport=1 and

ib_ioaddr=210". Then, when the "Configure":"IEEE-488 Boards"

window is used to correct the problem, error 596 is generated.

Since the error check applies only to Ziatech and NI PC2B

boards, neither of which is supported in Win32, there is no

reason to continue to do the check. V7.20 SP1 resolves the

problem by removing the error check.

----> Lookup of Cal Table Values Fails When CTAG Length Exceeds 15

Report Number: 39612 (MC-3268)

Resolved: Feb 16 2007

Application: MET/CAL

In V7.20 when the CTAG for a database calibration record

exceeds 15 characters attempts to read calibration table

field values fail.

This problem causes the MATH FSC function "CAL" to fail.

The underlying problem involves calls to the "metgendb.dll"

function "M_DB_GetCTAGs_4_MTAG".

For example, when the CTAG string for a cal record is

"A1234567890:1168000975", calling "M_DB_GetCTAGs_4_MTAG"

causes the CTAG "A1234567890:116" to be returned. Note that

only the first 15 characters have been preserved.

V7.20 SP1 resolves this problem. (Actually, V7.20a with build

date 2007-02-16, or later, is required.) Updated versions of

"metgendb.dll", "mcr32.exe", "mce32.exe", and "mctext.mdb"

are all required.

----> 9500B/3200 Dual Leveled-Sine with 2 9530 Active Heads Incorrectly

Limited to 1.1 GHz

Report Number: 39988 (MC-3281)

Resolved: Feb 12 2007

Application: MET/CAL

In V7.20, and all previous versions that support the Fluke

9500B, the 9500 FSC incorrectly limits the frequency upper

limit to 1.1 GHz for dual leveled sine tests in which two

9530 active heads are used.

The 9500B/3200 with two 9530 Active Heads is specified as:

0.1 Hz to 550 MHz

5 mVpp to 2.5 Vpp

550 MHz to 2.5 GHz

5 mVpp to 1.5 Vpp

2.5 GHz to 3.2 GHz

5 mV to 1 Vpp

V7.20 SP1 includes an updated 9500 FSC that implements the

correct frequency limit.

----> MEMC/MEMCX Tests with Dimensionless Evaluation Quantity May

Crash MET/CAL

Report Number: 40009 (MC-3284)

Resolved: Feb 09 2007

Application: MET/CAL Editor and Run Time

In V7.20 a MET/CAL crash is caused by any test where:

(a) there's an instrument setup statement in which

the evaluation quantity is dimensionless and

no pseudo-units string (e.g. "V/V") is used to

annotate the dimensionless value, and

(b) the ASK 'U' flag is set (i.e., "ASK+ U"), and

(c) there's a MEMC or MEMCX evaluation in the test.

As a practical matter, there's no way to cause this situation

when using a traditional instrument FSC (like "5700"), because

a units string must always be part of the NOMINAL field.

However, with name/value instrument FSCs, the situation

described above may arise.

Below is an example of a 6100-based test (discovered by a

customer) that causes the Editor and Run Time to crash when

the MEMCX statement is executed:

1.001 6100 L1VRange = 336 V

1.001 6100 L1VAC = 230 V

1.001 6100 L1VFlickerDepth = 0.402 %

1.001 6100 L1VFlickerFrequency = 13.5 Hz

1.001 6100 L1VFlickerShape = Square

1.001 6100 +L1VFlickerPST = 1

1.001 6100 Frequency = 50 Hz

1.002 MEMCX 1.00 TOL

Notice that the evaluation quantity in the 6100 statement

is "L1VFlickerPST". This is a dimensionless quantity.

The value is 1, without any units.

MET/CAL V7.20 SP1 corrects this problem.

----> MEMC/MEMCX Help File Does Not Correctly Describe Units Quoting

Report Number: 40008 (MC-3283)

Resolved: Feb 08 2007

Application: MET/CAL Documentation

Beginning with V7.00, MET/CAL has supported a syntax for

quoting the units string in the NOMINAL field of a MEMC or

MEMCX statement in order to override the standard parsing

algorithm. The override is used where the first letter of the

units name is a valid SI units prefix. For example, "mmHg"

is interpreted by MET/CAL as milli-mHg. In other words,

the base unit is meters of mercury, and the units prefix is

milli ('m'). In order to force MET/CAL to interpret "mmHg"

as a base unit itself it's necessary to surround the units

string with single quotes. For example:

MEMC 100'mmHg' 1%

In V7.20 and prior the MEMC/MEMCX help file does not correctly

document this. It states that double quotes should be used,

rather than single quotes. Furthermore, the help file states

that an alternate method is to precede the units string with

an underscore ('_'). The software does not implement the

underscore mechanism.

V7.20 SP1 resolves this problem. The service pack includes

an updated MEMC/MEMCX help file that should be placed in

the MET/CAL help directory in place of the file distributed

with V7.20.

----> Marginal Pass Count in Calibration Table Incorrect with

Guardbanding Enabled

Report Number: 39974 (MC-3279)

Resolved: Feb 06 2007

Application: MET/CAL

In V7.20 the marginal pass count (field 2350 in the Calibration

Table) is not correctly determined when procedure execution

results in one or more FAIL test results, and guardbanding

is enabled.

The problem is that, when guardbanding is enabled, MET/CAL

V7.20 marks any test result for which the error as a percentage

of the test tolerance exceeds the marginal pass threshold as

a Marginal Pass. In fact, no result which is a Fail or Fail

Indeterminate result should be considered a Marginal Pass,

even though the error exceeds the threshold. This error is

present for both MEMC/MEMCX and instrument FSC evaluations.

The error is not present when guardbanding is not enabled.

The error does not depend on the specific guardbanding

method.

The error is present in all versions of MET/CAL that support

guardbanding. (Guardbanding was introduced in V7.10.)

V7.20 SP1 corrects the problem.

----> RESET FSC Error When UUT RESET Statement Follows Other RESET

Statements

Report Number: 39932 (MC-3278)

Resolved: Feb 02 2007

Application: MET/CAL

In V7.20 there's an error in the execution of RESET

statement-specified commands when a RESET command for the UUT

precedes one or more other RESET commands for user-configured

references.

On the second and subsequent execution of the RESET commands,

knowledge of the IEEE-488 or serial address of user-configured

references to which RESET commands are directed has been lost.

This causes MET/CAL to attempt to send those commands to

the UUT.

This problem has been present since support for using RESET to

reset the UUT was added (V6.10).

To summarize, the problem appears in procedures which:

(1) contain RESET statements for both the UUT and

at least one user-configured reference, and

(2) the execution of the RESET statement for the

UUT precedes the execution of at least one RESET

statement for a user-configured reference.

A work-around is to specify the UUT RESET command after

the RESET commands for the user-configured references have

been specified.

V7.20 SP1 corrects this problem.

----> [V ...] Construction Fails in WAIT FSC When One or More Spaces

Follow 'V'

Report Number: 39931 (MC-3277)

Resolved: Feb 02 2007

Application: MET/CAL

In V7.20 the [V ...] special construction fails in the WAIT

FSC when:

(a) The construction appears in the time specification

portion of the statement, and

(b) one or more spaces appear after the 'V'.

For example:

math x = 10

wait -t [v x] message

fails, but this:

math x = 10

wait -t [vx] message

succeeds.

The underlying issue is that the first white-space delimited

word after the "-t" is taken to be the entire <time>

specification. Therefore, in the first example shown above

the problem is that the <time> specification is taken to be

"[v", rather than "[v x]".

V7.20 SP1 corrects this parsing problem.

----> HP60 and HP63 Statements Cannot Be Compiled

Report Number: 39910 (MC-3274)

Resolved: Feb 01 2007

Application: MET/CAL Editor

In V7.20, the MET/CAL Editor can no longer compile HP60 and

HP63 statements.

This prevents using V7.20 to write or modify HP60-based or

HP63-based procedures.

This error was introduced after V7.11 SP1.

V7.20 SP1 corrects this problem.

----> 5320 FSC Voltage Cal Incorrectly Accepts Negative DCV Values

Report Number: 39873 (MC-3273)

Resolved: Jan 31 2007

Application: MET/CAL

In MET/CAL V7.20 the procedure compiler incorrectly accepts

statements which specify a negative DC voltage.

For example, the statement:

5320 +Voltage = -10 V

is accepted as valid. When executed, the following run time

error is generated:

E2075: Fluke 5320A: -220,Invalid parameter

V7.20 SP1 corrects this problem.

----> N5531S, PSA-Based, HP 8657B Verification Causes GPF Due to dBc/Hz

Report Number: 39188 (MC-3250)

Resolved: Jan 05 2007

Application: MET/CAL Editor & Run Time

In MET/CAL V7.20 a problem exists in N5531 and/or PSA-based

procedures which specify the units symbol "dBc/Hz".

For example, the following procedure generates a run time

crash when the MEMC statement executes:

INSTRUMENT: dBc/Hz Test

CONFIGURATION: Agilent PSA (6.7 GHz,226)

1.001 MATH @FreqMHz = 10

1.002 MATH @dBc_Hz = 5

1.003 LABEL PHASE_NOISE

1.004 TSET TDESC = [V @FreqMHz] MHz

1.005 TARGET -p

1.006 IEEE [SDC]FR[V @FreqMHz]MZAP0DMR3

1.007 TARGET -m

1.008 PSA Mode = PhaseNoiseLogPlot

1.008 PSA ExtRefFreq = 10 MHz; TimebaseAccOff

1.008 PSA CenterFreq = [V @FreqMHz] MHz;

1.008 PSA FreqSpan = 50 kHz

1.008 PSA FreqOffset = 20 kHz; RFCoupling = DC

1.008 PSA +PhaseNoise = [V @dBc_Hz] dBc/Hz

1.009 MATH MEM1 = @dBc_Hz

1.010 MEMC dBc/Hz -0U +1000%

V7.20 SP1 corrects the problem.

----> VSET "UFMT" Parameter Not Documented in On-Line Help

Report Number: 39431 (MC-3263)

Resolved: Dec 14 2006

Application: MET/CAL Documentation

In MET/CAL V7.20 the on-line help for the VSET FSC failed

to include a description of the "UFMT" parameter.

The "UFMT" parameter, which controls the formatting of

measurement uncertainty-related result values, first became

available in MET/CAL V7.20.

V7.20 SP1 includes an updated help file, "vset.hlp",

containing a description of the "UFMT" parameter.

Place "vset.hlp" in your MET/CAL help directory. (You can

find the location of the MET/CAL help directory by looking

at the value of the "helpdir" parameter in the [Startup]

section of the MET/CAL initialization file, "metcal.ini".)

----> VSET CORREQ=EXACT Causes Instrument FSC Reset Statements

to Require Correction

Report Number: 39428 (MC-3262)

Resolved: Dec 14 2006

Application: MET/CAL Editor & Run Time

In MET/CAL V7.20, when corrections are enabled, and the VSET

"CORREQ" parameter is used to specify that all corrections

must be "exact", an error occurs when an instrument FSC

reset statement is executed.

The "CORREQ" parameter, which controls run time warnings

associated with automatic corrections applied to the reference

value in a test, first became available in MET/CAL V7.20.

For example, the following procedure:

1.001 VSET CORREQ = EXACT

1.002 ASK+ C

1.003 5520 * S

generates the error message:

E2758: The test step just completed requires that a

correction be performed. However, the correction

file does not contain data required to perform

the correction.

V7.20 SP1 includes updated Editor and Run Time executables

which correct this problem.

----> MET/CAL Editor GPF While Generating TUR Report on 9640-Based

Procedure

Report Number: 39280 (MC-3256)

Resolved: Dec 12 2006

Application: MET/CAL Editor

In V7.20 the MET/CAL Editor crashes in some cases when

generating a T.U.R. report for a 9640-based procedure.

The problem occurs only when the procedure contains 9640

statements in which the evaluation quantity is Modulation

Frequency.

An example of a 9640 statement which causes the problem is:

1.001 9640 Freq = 100 MHz; Level = -16 dBm;

1.001 9640 OutputImp = 50 Ohms; Mode = AM;

1.001 9640 AMDepth = 70 %; ModWav = Triangle

1.001 9640 +ModFreq = 200 Hz

V7.20 SP1 corrects the problem.

-------------------------------------------------------------------------------

Section 4: Enhancements ------------------------------------------------------

-------------------------------------------------------------------------------

----> 5320 FSC Modified to Support Rescan

Report Number: MC-3430 (1/3)

Resolved: Jan 02 2008

Application: MET/CAL

In MET/CAL V7.20 the 5320 FSC does not support Rescan in

loop/line source mode.

Rescan is used to force the 5320 to re-measure the mains

impedance. (Note that there is a time limit that prevents

Rescan from being used too frequently. This is determined

internally by the 5320A.)

V7.20 SP1 support Rescan. Refer to on-line help for the

5320 FSC for additional information.

----> 5320 FSC Modified to Support Transfer Ground Bond Resistance Mode

Report Number: MC-3430 (2/3)

Resolved: Jan 02 2008

Application: MET/CAL

In MET/CAL V7.20 the 5320 FSC does not support Transfer

Ground Bond Resistance mode.

In V7.20 SP1 the 5320 FSC supports Transfer Ground Bond

Resistance mode. There are six new resistance values,

each with its own accuracy, dependent upon UUT current

stimulus level.

Refer to on-line help for the 5320 FSC for additional

information.

----> 5320 FSC Modified to Support Serial Resistance

Report Number: MC-3430 (3/3)

Resolved: Jan 02 2008

Application: MET/CAL

In MET/CAL V7.20, when setting up a 5320 test in loop or line

impedance mode, the 5320 FSC does not allow the resistance of

the leads used to connect the 5320A to the UUT to be specified.

In V7.20 SP1 there's a new parameter, "SerialResistance",

used to specify the line or loop impedance serial resistance.

The specified value must be between 0 and 2 ohms.

There is no accuracy value per se. It is up to the user to

enter an appropriate value for the measurement uncertainty

calculation.

----> Unpack Dialog Modified to Allow Resizing and Direct File

Name Entry

Report Number: 45279

Resolved: Dec 13 2007

Application: MET/CAL

In MET/CAL V7.20 SP1 the dialog that appears when a user

chooses "File" : "Unpack" to allow choosing the file to be

unpacked has been enhanced so that the window can be resized,

and also allows direct text entry of the file name.

Requires V7.20x or later.

----> File I/O Utility Functions

Report Number: 45276

Resolved: Dec 13 2007

Application: MET/CAL

MET/CAL V7.20 SP1 includes the following general purpose

line-oriented file I/O utility functions:

APPEND - append line to file

DELETE - delete line from file

INSERT - insert line in file before specified line

READ - read specified line from file

REPLACE - replace line in file

WRITE - write line to file after specified line

Refer to the MATH FSC on-line help for details.

----> Support for "Leakage Current Active" Added to 5320 FSC

Report Number: MC-3408

Resolved: Nov 20 2007

Application: MET/CAL

In MET/CAL V7.20 SP1 the 5320 FSC has been enhanced to support

a new mode "LeakageCurrentActive" (or, equivalently, "IDA").

Refer to on-line help for the 5320 FSC for details.

Requires V7.20w or later.

----> Function to Get Reference Accuracy from Last Setup

Report Number: 20525

Resolved: Nov 16 2007

Application: MET/CAL

MET/CAL V7.20 SP1 includes a new MATH FSC function to

retrieve the reference accuracy from the last instrument

setup in the same test.

The name of the function is "RefAcc".

"RefAcc" returns the reference accuracy in base units (for

example, volts, not millivolts).

Calls to "RefAcc" must be placed after a setup statement,

but before the corresponding evaluation (MEMC or MEMCX).

In order to use "RefAcc" T.U.R. checking (ASK+ U) must

be enabled.

Example:

5700 1.000V S 2W

MATH Acc = RefAcc()

The call to "RefAcc" in this example will returns the

reference accuracy determined by the MET/CAL 5700A FSC

(driver) when the 5700 setup statement was executed.

Refer to on-line help for the MATH FSC for details.

Requires V7.20w or later.

----> MATH Function To Indicate Whether MET/CAL Is In Demo Mode

Report Number: 44562

Resolved: Oct 25 2007

Application: MET/CAL

MET/CAL V7.20 SP1 includes a new MATH function that indicates

whether or not MET/CAL is running in demo mode.

The function name is "DEMO".

Refer to the on-line help for the MATH FSC for details.

Requires V7.20v or later.

----> Asset Number Added to Run Time Header Information

Report Number: 25794

Resolved: Oct 15 2007

Application: MET/CAL

In MET/CAL V7.20 SP1 the main window of the MET/CAL Runtime

application shows the asset number of the UUT. The asset

number is shown below the procedure name.

----> Second Line for HEAD Messages

Report Number: 11411

Resolved: Oct 15 2007

Application: MET/CAL

In MET/CAL V7.20 SP1 the MET/CAL Runtime and Test Run main windows

have been modified to make space for a second HEAD message.

To access the second HEAD message line use a HEAD procedure

statement where the body of the statement begins with "-2".

To clear the line use "HEAD -2".

Example:

HEAD DC Voltage Tests

HEAD -2 1 V Test

...

HEAD -2 10 V Test

...

HEAD -2 100 V Test

HEAD AC Voltage Tests

HEAD -2 1 V @ 1 kHz Test

...

Rules for a "HEAD -2" lines are the same as for a regular HEAD

statement. See the on-line help for the HEAD FSC for details.

----> Modify RESET FSC To Not Mark Instrument As "Used" (By Default)

Report Number: 42782

Resolved: Oct 11 2007

Application: MET/CAL

In MET/CAL V7.20 SP1 a change has been made to the way

MET/CAL handles commands specified in RESET statements.

By default, the execution of a RESET-specified command no

longer causes the MET/CAL Runtime application to mark the instrument

as having been used by the procedure. This means that if the

execution of the RESET-specified command is the only use of

the instrument in a procedure, the instrument will no longer

appear in the "standards used" list in the database results

associated with the calibration record.

Example:

RESET [@UDEV1]xyz

5700 1.00V 1%

END

Before this change (V7.20q and previous) MET/CAL would

report the instrument referred to by the alias "UDEV1" in the

"standards used" table. After the change it no longer

appears in the table (by default).

Of course, changing the example to:

RESET [@UDEV1]xyz

5700 1.00V 1%

IEEE [@UDEV1]abc

END

causes MET/CAL to continue to include the instrument referred

to by the alias as one of the standards used.

This behavior can be configured on a per-workstation basis

using the "ResetStandardUsed" optional initialization file

parameter.

The default is "No". Setting "ResetStandardUsed = Yes"

causes MET/CAL to continue to operate in the old mode -- i.e.,

execution of a RESET FSC-specified command is sufficient to

cause an instrument to appear in the "standards used" table.

V7.20r or later is required.

----> Allow Required Instruments To Be Connected After Procedure Starts

Report Number: 42789

Resolved: Oct 11 2007

Application: MET/CAL

In V7.20, and previous versions, MET/CAL's design is to scan

a procedure just before execution to determine the list

of required instruments. ("Required", here, really means

"might be required" -- MET/CAL cannot determine the actual

flow of a procedure based on an up front static analysis,

and therefore does not know whether particular statements

will or will not be executed.)

After constructing the list of required instruments,

each "system" instrument is tested and cleared by calling

FSC-specific test and clear functions. This happens prior

to the start of procedure execution.

If, when an instrument's test function is called, the

instrument is not there, or not responding properly, MET/CAL

displays a dialog with 3 choices: Abort, Retry, Ignore.

"Abort" terminates the procedure execution (before it

really starts).

"Retry" allows the user to hook up the instrument and re-test,

but it does not allow procedure execution to commence until

the test function succeeds.

"Ignore" removes the instrument from an internal table of

configured instruments. Once "Ignore" has been chosen,

thereafter, it's not possible to access the instrument

without either (a) manually reconfiguring the instrument,

or (b) closing and restarting the application.

In MET/CAL V7.20 SP1 there's a new initialization file

parameter named "InstrTest" that can be used to configure

the operation of MET/CAL with respect to the execution of

the built-in test and clear functions for required system

instruments.

There are now 3 modes of operation:

(1) InstrTest = Legacy

In this mode MET/CAL operates as in V7.20 and prior

versions. The description above explains this mode

in detail.

(2) InstrTest = Standard

In this mode MET/CAL continues to test required system

instrument before commencing procedure execution but,

when a test function fails (because the instrument is

not there, or turned off, or not operating correctly),

choosing "Ignore" does not cause the instrument to

be removed from the internal table of configured

instruments.

If and when the procedure reaches a statement

that requires the instrument, the test function

is re-executed. If, by that time, the instrument

is properly connected and operating properly,

the test function will succeed and procedure

execution continues normally. Or if, at that time,

the instrument is not yet connected and operating

properly, the user may connect the instrument and

choose "Retry". The process may be repeated as

needed until the instrument test function succeeds.

The procedure continue normally from that point.

This mode is the default mode (beginning with

V7.20 SP1).

(3) InstrTest = Deferred

In this mode MET/CAL defers execution of the instrument

test functions entirely until the procedure requires

the use of the instrument.

If the instrument is never used, the test function

will never be executed.

If and when the procedure reaches a statement

that requires the instrument, the test function

is re-executed. If, by that time, the instrument

is properly connected and operating properly,

the test function will succeed and procedure

execution continues normally. Or if, at that time,

the instrument is not yet connected and operating

properly, the user may connect the instrument and

choose "Retry". The process may be repeated as

needed until the instrument test function succeeds.

The procedure continue normally from that point.

Users should be aware that none of these modes change the

requirement that reference instruments referred to by the

procedure must be configured.

Proper operation of the traceability and accuracy lookup

functions require that the instruments referred to by the

procedure be configured on the workstation using the Config

Editor (F12).

----> MATH Function for Linear Interpolation

Report Number: 43067

Resolved: Oct 11 2007

Application: MET/CAL

MET/CAL V7.20 SP1 includes a new MATH function for linear

interpolation and extrapolation.

The name of the function is "INTERP".

INTERP linearly interpolates between 2 specified points at

a specified x-value.

The formula for linear interpolation is:

y = y1 + (x-x1) * ((y2-y1) / (x2-x1))

INTERP may also be used to extrapolate values on the line

defined by (x1,y1) and (x2,y2).

Refer to MATH FSC on-line help for details.

Requires V7.20t or later.

----> Function to Round to Nearest Multiple of Specified Increment

Report Number: 42760

Resolved: Oct 11 2007

Application: MET/CAL

MET/CAL V7.20 SP1 includes a new MATH FSC function that

rounds a specified numeric value to the nearest multiple of

a specified increment.

There's an existing function, "FRND", that can be used to

round to a specified number of significant digits, but that

is not the same thing as rounding to the closest multiple

of a specified increment.

The name of the new function is "CRND".

The following example shows the difference between FRND

and CRND:

FRND( 1.234, 3) generates 1.23

FRND(12.345, 3) generates 12.3

CRND( 1.234, 0.01) generates 1.23

CRND(12.345, 0.01) generates 12.34

Both results generated by FRND have 3 significant digits,

but they do not have the same number of digits to the right

of the decimal point.

On the other hand, the results generated by CRND both have

the same number of digits to the right of the decimal point.

Refer to MATH FSC on-line help for details.

Requires V7.20r or later.

----> Allow Configuring the Setting of RQS in the SRE Register with

IEEE & SCPI FSCs

Report Number: 44187

Resolved: Oct 10 2007

Application: MET/CAL

It has been found that some instruments regard setting RQS

in the SRE register as an error condition.

This prevents using the IEEE2 and SCPI FSCs to control

those instruments.

Technically such instruments are not in compliance with

the IEEE-488.2 standard, because the standard requires that

instruments ignore the state of the RQS bit (bit 6) in the

SRE register.

Nevertheless, since there is no particular reason for MET/CAL

to set the RQS bit in the first place, in V7.20 SP1 MET/CAL

has been modified so that, by default, it does not set RQS in

the SRE register when an IEEE2 or SCPI statement is executed.

A new VSET / TSET parameter named "IEEE2_SRE_RQS" has been

implemented. The default is "No", but procedure writers may

now specify "IEEE2_SRE_RQS = Yes" to force RQS to be set in

the SRE register prior to commands and queries initiated by

the IEEE2 and SCPI FSCs.

See on-line help for the VSET FSC for details.

Requires V7.20v or later.

----> Accuracy Files for Guildline Instruments

Report Numbers: 44058, 44059, 44060, 44061, 44062, 44063,

44064, 44065, 44066, 44067, 44025

Resolved: Oct 04 2007

Application: MET/CAL

MET/CAL V7.20 SP1 includes accuracy files for the following

Guildline instruments:

Guildline Instruments Limited / Model 9211A

Guildline Instruments Limited / Model 9336-100G

Guildline Instruments Limited / Model 9336-100M

Guildline Instruments Limited / Model 9336-100T

Guildline Instruments Limited / Model 9336-10G

Guildline Instruments Limited / Model 9336-10M

Guildline Instruments Limited / Model 9336-10P

Guildline Instruments Limited / Model 9336-10T

Guildline Instruments Limited / Model 9336-1G

Guildline Instruments Limited / Model 9336-1P

Guildline Instruments Limited / Model 9336-1T

The 9211A is a current shunt.

The 9336 series are resistance standards.

----> Allow the Guardband Table Name To Be Specified with VSET/TSET

Report Number: 44033

Resolved: Oct 03 2007

Application: MET/CAL

In MET/CAL V7.20, and previous versions that support

guardbanding, the guardband table name (parameter "gb_table")

can be specified in the MET/CAL initialization file, or the

guardbanding initialization file, but not in a procedure

(using a VSET or TSET statement).

In some cases it may be convenient to specify the table name

in the procedure.

In V7.20 SP1 the VSET and TSET FSCs support the "gb_table"

parameter used to specify the name of the guardband table.

----> Dropping Licenses Difficult Due To Short Refresh Rate of List

Report Number: MC-3249

Resolved: Oct 03 2007

Application: MET/TRACK

In MET/CAL V7.20, using MET/TRACK build #434, dropping licenses

can be difficult to the short refresh rate of the list.

When you login to MET/TRACK as the MT user and choose

"Setup/Licenses", then select the "Connections" tab, a list

of connected applications is presented.

The list is refreshed every 2 to 3 seconds. If the list is

long, there may be insufficient time to locate and select

the connection to be dropped before the list is refreshed.

When the list is refreshed, the cursor moves to the top of

the list. This can lead the user to drop the wrong connection.

V7.20 SP1 resolves this problem. The list refresh rate

has been slowed down to allow sufficient time to drop the

desired connection.

----> MET/TRACK Modified to Reread MET/CAL Default Procedure Directory

on Each Access

Report Number: MC-3258

Resolved: Oct 03 2007

Application: MET/TRACK

In the MET/CAL V7.20 release (MET/TRACK build #434), MET/TRACK

MET/TRACK reads the value of the MET/CAL default procedure

directory once when MET/TRACK starts. If the directory is

changed (using the MET/CAL Runtime or Editor applications)

while MET/TRACK is running, it is necessary to close and

restart MET/TRACK in order for it to know about the new value.

In V7.20 SP1, MET/TRAK has been modified so that it rereads

the MET/CAL initialization file parameter value specifying

the default procedure directory prior to each use of the value.

----> MET/CAL Changed To Ignore ASK+ P For MEMC & MEMCX Statements

Report Number: 43955

Resolved: Sep 28 2007

Application: MET/CAL

In V7.20 (and prior) it's too easy to fall into a procedure

coding trap by forgetting to set ASK- P before executing a

MEMC or MEMCX statement.

Up to and including V7.20u MET/CAL always rigidly followed

the definition of the ASK 'P' flag, regardless of the type

of the evaluation statement.

The problem with this approach is that because MEMC and MEMCX

always just compare two numeric values, there's never any

utility in repeating the comparison without having had an

opportunity to modify one or both of the values being compared.

Another complication of the this approach is the fact that by

not re-establishing the reference output, MET/CAL resets it's

internal memory of the reference accuracy. This has the effect

of disabling the TSR and measurement uncertainty calculations.

In MET/CAL V7.20 SP1 the default operation of Post Test

"Repeat" and "Cancel" have been altered so that when ASK+

P is set and the evaluation statement is MEMC or MEMCX,

MET/CAL ignores the ASK+ P setting and behaves as if ASK-

P is set. In other words, procedure control jumps back to

the first line of the test (X.001) or to a TARGET or TARGET

-p statement (if any) in the test.

As an override, users may set "ask_p_memc_memcx = yes" in

their initialization file to cause MET/CAL to revert to the

old method.

V7.20v or later is required.

----> Functions To Generate SI Prefix / Engineering Units Format

from Dimensioned Value

Report Number: 43951

Resolved: Sep 28 2007

Application: MET/CAL

In MET/CAL V7.20 SP1 there are two new MATH functions that

may be used to format dimensioned values in SI prefix /

engineering units format:

(1) ENGR - reformat dimensioned quantity to SI prefix /

engineering units format.

Example:

ENGR("12345.6 kV") generates "12.3456 MV".

(2) ENGR_NSD - format number, units, NSD, to dimensioned

quantity in SI prefix / engineering units format.

Example:

ENGR_NSD(1234.5, "mV", 4) generates "1.234 V".

Refer to on-line help for the MATH FSC for details.

V7.20v or later is required.

----> Functions To Extract Numeric Values From Strings

Report Number: 43904

Resolved: Sep 26 2007

Application: MET/CAL

MET/CAL V7.20 SP1 includes two new MATH FSC functions used

to extract embedded numeric values from strings:

NUM - extract 1st numeric value from string

NUMN - extract n-th numeric value from string,

or count numeric values in string

Refer to the MATH FSC help file for additional information.

V7.20u or later is required.

----> Functions to Strip Leading And/Or Trailing Spaces From Strings

Report Number: 43903

Resolved: Sep 26 2007

Application: MET/CAL

MET/CAL V7.20 SP1 includes 3 new MATH functions to strip

spaces from strings:

STRIP - strip leading and trailing white space

from string

STRIPL - strip leading white space from string

STRIPT - strip trailing white space from string

Refer to the MATH FSC help file for additional information.

V7.20u or later is required.

----> Beep Enhanced to Support Trip On Operator Response

Report Number: 43872

Resolved: Sep 25 2007

Application: MET/CAL

In V7.20 (and previous versions) there's an optional "beep"

parameter that may be used to cause MET/CAL to beep when

certain operator prompts appear.

The beep parameter covers many of the standard prompts:

DISP FSC

EVAL FSC

OPBR FSC

SET FSC

connection message prompts

prompt for UUT value

range message prompt

Editor prompt on file save operation

Editor overwrite prompt

... and several others

The beep is controlled by an initialization file parameter

with this format:

beep = off | none | <delay>[,<count>]

Setting "beep" to "off" or "none", or setting the count to

zero, disables the beep.

<delay> specifies the inter-beep delay, in seconds. (It is

also the delay before the initial beep.)

<count> is optional and defaults to 1.

When the beep parameter was first supported, it was

anticipated that most users would set the count to 1 (or

perhaps a small number like 2 or 3). The idea was to set

the delay to a relatively large number (like 10 seconds),

so as not to annoy the user.

This use is valid, and is probably preferred by some users.

However, in noisy environments, or where operators are

multi-tasking, one might want a more or less continuous beep.

One can achieve something like a continuous beep in the

current implementation by specifying a large <count>, but

there's a problem with this. The problem is that MET/CAL

completes the beep sequence regardless of when the user

responds to the prompt.

In V7.20 SP1 the "beep" initialization file parameter has

been enhanced. The new syntax is:

beep = off | none | <delay>[,<count>][, trip]

This is the same as before except that you can now include

"trip".

For example:

beep = 0.5, 50, trip

indicates that there should be an inter-beep delay of 0.5

seconds, there should be at most 50 beeps, and the beep

sequence should be terminated when the user responds to

the prompt.

Specifying "trip" without a count indicates that beeping

should continue until the user responds to the prompt,

without any maximum number of beeps.

----> New MATH Function to Get Name of Accuracy File

Report Number: 43817

Resolved: Sep 24 2007

Application: MET/CAL

MET/CAL V7.20 SP1 includes a new function, "AccName", that

can be used to find the name of an accuracy file.

For example:

MATH InstrName = "Fluke 5700A"

MATH AccFileName = AccName(InstrName)

The name returned is the name of the accuracy file that

will be used in calls to "ACCV", "ACCV2", etc. when the

same instrument name is specified. It is also the same as

the file that will be used by built-in FSCs, as long as the

accuracy file name has not been overridden using ACCF.

----> 8560, 8566, and 8590 FSCs Modified To Support Delta Marker

Measurement

Report Number: MC-3384, MC-3385, MC-3386

Resolved: Sep 18 2007

Application: MET/CAL

In MET/CAL V7.20 SP1 the FSCs for the HP 856x and 859x

spectrums analyzers have been updated to support delta

marker measurement.

Refer to on-line help for the 8560, 8566, and 8590 FSCs

for details.

----> Guardbanded Tolerance Error Calculation Enhanced

Report Number: 43702

Resolved: Sep 18 2007

Application: MET/CAL

MET/CAL V7.20, and earlier versions that support guardbanding,

calculate the Tolerance Error based on the guardbanded

pass limits. (In other words, if the UUT value in a test is

exactly at the crossover point between a "pass" and a "pass

indeterminate", the Tolerance Error will be reported as 100 %.)

A number of users have indicated that they would prefer to

base the calculation on the UUT's specified limits.

MET/CAL V7.20 SP1 supports a new guardbanding parameter

"gb_tol_err" that allows the procedure writer to configure

how the Tolerance Error calculation is performed.

If "gb_tol_err = spec" the Tolerance Error calculation is

based on the UUT's specified limits. (With this setting the

calculation is the same as the non-guardbanded calculation.)

If "gb_tol_err = gb_pass" the Tolerance Error calculation

is based on the guardbanded pass limits. This setting is

compatible with MET/CAL V7.20.

The default "gb_tol_err" parameter value is "spec".

Refer to the VSET help file and the guardbanding manual

("Guardbanding.pdf") for additional information.

MET/CAL V7.20t or later is required.

----> New MATH FSC Function To Determine If File Is Positioned At EOF

Report Number: 43518

Resolved: Sep 07 2007

Application: MET/CAL

In V7.20 SP1 there's a new MATH FSC function named "EOF".

"EOF" determines if a specified file is currently positioned

at end of file (EOF).

(This function requires V7.20t or later.)

Refer to on-line help for the MATH FSC for details.

----> New MATH FSC Function to Count Lines of File

Report Number: 43517

Resolved: Sep 07 2007

Application: MET/CAL

In V7.20 SP1 there's a new MATH FSC function named "LineCount".

"LineCount" counts the lines in a specified file.

(This function requires V7.20t or later.)

Refer to on-line help for the MATH FSC for details.

----> 5320 FSC Modified To Support New HIPOT Timer Function

Report Number: MC-3320

Resolved: Aug 30 2007

Application: MET/CAL

At the time of the MET/CAL V7.20 release the 5320A did

not support the HIPOT timer function. Subsequent hardware

and/or firmware updates to the 5320A added this capability.

In HIPOT timer mode the 5320A calibrator can now measure

the time interval for which a HIPOT tester delivers the

output voltage. The 5320A senses the voltage presented on

(V - COM) and displays the time interval in seconds.

In V7.20 SP1 the 5320 FSC supports the HIPOT timer function.

----> 5320 FSC Modified To Support New HIPOT Leakage Current Function

Report Number: MC-3319

Resolved: Aug 30 2007

Application: MET/CAL

When the submenu "HIPOT LC" is chosen, the 5320A calibrator

can simultaneously measure the output voltage and leakage

current of HIPOT testers. Option 5320A LOAD is necessary

for leakage current calibrations.

In V7.20 SP1 the 5320 FSC supports the HIPOT leakage current

function.

----> Support For Voltage Calibrator Load Current Measurement Added

to 5320 FSC

Report Number: MC-3374

Resolved: Aug 15 2007

Application: MET/CAL

In MET/CAL V7.20 the 5320 FSC did not support voltage

calibrator load current measurement.

For example, the following PORT statement that communicates

directly with the 5320A on the serial interface has no

equivalent in V7.20 using the 5320 FSC:

PORT SAF:VOLT:CURR?;:Outp:Stat On [13])

In MET/CAL V7.20 SP1 the 5320 FSC has been enhanced to

support this measurement function.

----> Fluke (Datron) 9100 Accuracy File Updated

Report Number: 42246

Resolved: Jun 28 2007

Application: MET/CAL

V7.20 SP1 includes an updated version of the 9100 accuracy

file ("9100.acc").

The floor spec on two ranges in the DC power, where aux

output is voltage, has been increased.

The change was made because the floor spec on Aux DCV O/P

was incorrectly listed in the published specifications as

tighter than main DCV O/P.

The accuracy file section to be modified is:

# DC Power (auxiliary output is voltage)

# Scale Factor >= 1mV/A

Mode: Amps AX >=1mV/A

# NOMINAL MOD1 Tol. Floor Res.

# ---------------------- --------- ----- ------ ----

-32.00 32.00 NA NA 0.012 0.003 0.01

-320.0 320.0 NA NA 0.006 0.005 0.1

-3.200e+3 3.200e+3 NA NA 0.006 0.042 1

After the change this section is:

# DC Power (auxiliary output is voltage)

# Scale Factor >= 1mV/A

Mode: Amps AX >=1mV/A

# NOMINAL MOD1 Tol. Floor Res.

# ---------------------- --------- ----- ------ ----

-32.00 32.00 NA NA 0.012 0.006 0.01

-320.0 320.0 NA NA 0.006 0.006 0.1

-3.200e+3 3.200e+3 NA NA 0.006 0.042 1

----> Support Improved for Test Uncertainty Ratio and Measurement

Uncertainty Calculations with Non-Linear Units

Report Number: 21334

Resolved: Jun 21 2007

Application: MET/CAL

In MET/CAL V7.20 SP1 the test uncertainty ratio and measurement

uncertainty calculations have been modified to implement

linearization of logarithmic units for all logarithmic units

known to MET/CAL. Previously linearization was performed only

for dBm, and then only when a built-in instrument driver was

used (i.e., not when an ACC statement was used to specify the

reference accuracy in dBm for a user-configured instrument).

In cases where MET/CAL has no built-in knowledge about how

to linearize a logarithmic value, it may be necessary for

the procedure writer to use the ACC and/or VSET FSCs to

specify how the linearization is to be done.

----> List Box Capability Added to MET/CAL Procedure Language

Report Number: 42096

Resolved: Jun 20 2007

Application: MET/CAL

MET/CAL V7.20 SP1 includes a suite of new MATH functions

to allow the procedure writer to construct and display list

box windows to present choices to the operator.

A list box window has 4 major components:

(1) a read-only text area

(2) a list box

(3) a text-entry area

(4) buttons

The first 3 components are optional.

Features provided include:

(a) specifying window title

(b) adding text to read-only text area

(c) including MESS message in text area

(d) adding items to list box

(e) choosing multi-selection list box

(f) controlling initial highlight

(g) resizing window

(h) customizing buttons

(i) determining user's list box selection

(j) re-using list box windows

(k) sorting list box items

(l) searching list box items

The new MATH functions are:

lbAdd - add item to list box

lbAddList - add list of items to list box

lbButton - add button to list box window

lbClose - close list box window

lbConf - list box window attribute configuration

lbGetSel - get name of selected item from list box

lbGetSelX - get index of selected item from list box

lbNew - create new list box window

lbResp - get user's response

lbSel - select item in list box (by name)

lbSelCount - get count of selected items in list box

lbSelX - select item in list box (by index)

lbShow - display list box window

lbText - add line to multiline edit control

lbUnSel - remove selection of item (by name)

lbUnSelX - remove selection of item (by index)

Refer to on-line help for the MATH FSC for additional

information.

----> VSET Parameters to Specify Linearization Method and Impedance

Report Number: 40956

Resolved: Jun 20 2007

Application: MET/CAL

For all versions of MET/CAL up to and including V7.20,

automatic linearization of values with logarithmic units in

an ACC statement for purposes of the test specification ratio

and measurement uncertainty calculations was not performed.

However, with the addition of support for linearization

of log units in ACC statements (e.g., dB, dBm, dBuV, ...),

a method to allow the procedure writer to indicate how the

linearization should be done, would be useful.

For example, in the case of dBm, the system has know way of

knowing if linearization should be to watts or to volts.

When dBm are linearized to volts it is also necessary to

know the impedance value.

V7.20 SP1 includes two new VSET parameters to allow the

specification of the linearization method and the impedance

value.

The new parameters are:

(1) "LogLin" specifies the linearization method.

Choices are:

DV - delta voltage

DW - delta power

V - voltage

W - power

(2) "Imped" specifies the impedance. The impedance

is required for dBm to V linearization only.

Refer to on-line help for the VSET FSC for details.

----> MATH Functions to Convert Percentage Deltas to dB

Deltas & Vice Versa

Report Number: 40366

Resolved: Jun 20 2007

Application: MET/CAL

MET/CAL V7.20 already includes functions which convert back and

forth between percentages and decibels. These functions are:

PCTTODBV - % to dB (voltage)

DBTOPCTV - dB to % (voltage)

PCTTODBW - % to dB (power)

DBTOPCTW - dB to % (power)

In some cases, however, it is necessary to work with

percentages which represent deltas relative to a starting

value. A percentage delta can be converted to a corresponding

gain or loss in decibels. Therefore, MET/CAL V7.20 SP1

provides 4 new functions: MET/CAL provided 4 new functions:

DBTOPCTV_D - dB to % (voltage ratio delta)

DBTOPCTW_D - dB to % (power ratio delta)

PCTTODBV_D - % to dB (voltage ratio delta)

PCTTODBW_D - % to dB (power ratio delta)

Refer to on-line help for the MATH FSC for details.

----> Modify ACC FSC to Allow Specification of Linearization Flag

and Impedance

Report Number: 40954

Resolved: Jun 20 2007

Application: MET/CAL

In V7.20, and prior versions, MET/CAL does not automatically

linearize logarithmic units that appear in ACC statements

in order to perform test specification ratio and measurement

uncertainty calculations.

However, with the addition of support for linearization

of log units in ACC statements (e.g., dB, dBm, dBuV, ...),

a method to allow the procedure writer to indicate how the

linearization should be done was required.

Without this capability, in the case of dBm, for example,

MET/CAL would have no way of knowing if linearization should

be to watts or to volts.

When dBm are linearized to volts it is also necessary to

know the impedance value.

In V7.20 SP1 the ACC FSC has been enhanced to allow a

linearization method to be specified in the CON field, and, if

required, an impedance value to be specified in the MOD1 field.

Refer to on-line help for the ACC FSC for details.

MET/CAL also allows the linearization method and impedance

to be specified using VSET parameters. See report number

40956 above. The two method, ACC and VSET, are alternate

methods. For each test only one method should be used.

The advantage of ACC is that it allows the compile time

T.U.R. calculation to be performed. The advantage of VSET

is that it allows the values to be dynamically determined

under procedure control. Procedure writers must choose the

best method based on procedure requirements.

The virtue of supporting the specification of the linearization

method and the impedance value in an ACC statement is that

the method is static. Static data may be used at compile

time in the generation of a T.U.R. report.

----> Support Added for 5320A-LOAD

Report Number: MC-3306

Resolved: Mar 28 2007

Application: MET/CAL

MET/CAL V7.20 does not support the 5320A-LOAD.

Support is included in V7.20 SP1.

Note that the 5320A-LOAD is a manual standard. It is not

directly supported by the 5320 FSC. A procedure writer

must use the STD and ACCV FSCs to establish traceability

and accuracy for 5320A-LOAD resistance values. V7.20 SP1

includes an accuracy file for the 5320A-LOAD.

----> Add Support for Selecting Series Resistance of RCD Function

in 5320 FSC

Report Number: MC-3304

Resolved: Mar 19 2007

Application: MET/CAL

In MET/CAL V7.20 the 5320 FSC does not allow series resistance

to be selected in RCD functions.

In MET/CAL V7.20 SP1 "SeriesResistance" has been added as

a legal parameter for the RCDC and RCDT modes. Legal and

default values are listed in the updated 5320 FSC help file

("5320.hlp").

----> Add Support for 5320A HV ADAPTER /R MULTIPLIER

Report Number: 39912 (MC-3275)

Resolved: Feb 28 2007

Application: MET/CAL

MET/CAL V7.20 SP1 supports the Fluke 5320A HV ADAPTER /R

MULTIPLIER.

The multiplier was unavailable at the time of the V7.20

release and therefore was not included in V7.20.

----> 5320 FSC High Resistance Multiplier Enabled

Report Number: 39024 (MC-3242)

Resolved: Feb 28 2007

Application: MET/CAL

Due to lack of hardware availability, the 5320A high

resistance multiplier was not support by the 5320 FSC in

the V7.20 release.

In V7.20 SP1 the high resistance multiplier is now supported.

Refer to on-line help for the 5320 FSC for details.

----> Provide Option to Disable Post Test "Repeat" Button

Report Number: 22557 (MC-2396)

Resolved: Jan 08 2007

Application: MET/CAL

In V7.20 SP1 there's new ASK 'Z' flag which controls the

Post Test "Repeat" button.

Specifying "ASK+ Z" causes the Post Test "Repeat" button to

be enabled.

Specifying "ASK- Z" causes the Post Test "Repeat" button to

be disabled (grayed out).

The default is controlled by the optional initialization file

parameter "ask_z_default". For compatibility with previous

versions of MET/CAL, "ask_z_default", if not specified,

defaults to "yes".

----> Construction to Allow Specification of Binary Values in Hex

Report Number: 39369 (MC-3260)

Resolved: Dec 12 2006

Application: MET/CAL

MET/CAL V7.20 SP1 supports a new special construction, 'X',

used to cause the output of binary values specified in ASCII

hex format.

The 'X' construction is intended primarily to assist in

controlling instruments which must be programmed by sending

binary values, and that document their remote commands in

hexadecimal format.

The format of the construction is:

[X<hex list>]

where <hex list> is a sequence of one or more hex bytes in

ASCII format.

Example 1:

IEEE [XFF]

This is equivalent to "IEEE [255]" (using the existing

construction that specifies output values in ASCII

decimal format.)

Example 2:

PORT [@COM1][X0D0A]

This causes MET/CAL to write two characters, a

Carriage Return and a Linefeed, to COM1.

Rules for the 'X' construction:

(1) ASCII hex specifications are case-insensitive.

(2) One or more hex bytes may be specified in the list.

Each byte requires 2 ASCII hex characters.

(3) Spaces are allowed between hex bytes, but not between

the 2 ASCII hex digits which represent a single byte.

Although the 'X' construction is designed primarily for use

with the IEEE, IEEE2, SCPI, PORT, and RESET FSCs, all of

the following FSCs support the 'X' construction:

DISP

EVAL

HEAD

IEEE

IEEE2

MEM2

MEMI

MESS

NVI FSCs (5320, 6100, 9640, N5531, PSA)

OPBR

PORT

RESET

RSLT

SCPI

SET

VSET

WAIT

-------------------------------------------------------------------------------

-------------------------------------------------------------------------------


Read Me MET/CAL 7.20

-------------------------------------------------------------------------------

-------------------------------------------------------------------------------

Fluke Calibration Software 7.2

MET/CAL 7.2 (7.20)

Released: 2006-11

-------------------------------------------------------------------------------

Section 1: Table of Contents -------------------------------------------------

-------------------------------------------------------------------------------

1. Table of Contents

2. Introduction

3. Installation Instructions

4. What's New in V7.20

Description of significant new features in V7.20.

5. Minor Enhancements in V7.20

Post-V7.11 SP1 minor enhancements included in V7.20

6. Enhancements in V7.11 SP1

Post-V7.11 enhancements included in V7.11 SP1. The enhancement

reports in this section are also included in the V7.11 SP1

readme file ("readme711sp1.txt").

7. Crystal Reports

Reports provided with MET/CAL V7.20.

8. Documentation

Overview of product documentation.

9. Accuracy and Help File Information

10. Contacting Fluke

How to contact Fluke with MET/CAL questions, problems,

or suggestions.

11. Bonus CD

12. V7.20 Problem Reports

Corrections made between V7.11 SP1 and V7.20.

13. V7.11 SP1 Problem Reports

Corrections made between V7.11 and V7.11 SP1. The enhancements

reports in this section are also included in the V7.11 SP1

readme file ("readme711sp1.txt").

14. Additional V7.11 Problem Reports

Problems fixed in V7.11, but not documented in the V7.11

readme file ("readme711.txt").

15. On Time Support Products

On Time Support products which work with the MET/CAL database.

-------------------------------------------------------------------------------

Section 2: Introduction ------------------------------------------------------

-------------------------------------------------------------------------------

MET/CAL V7.20 includes a variety of new features not present in V7.11.

In addition, MET/CAL V7.20 incorporates all maintenance updates

released in V7.11 Service Pack 1.

V7.20 includes:

(1) New instrument FSCs.

(2) New features.

(3) Bug fixes.

"readme720.txt" includes all information contained in

"readme711sp1.txt", as well as additional information (in sections

4 and 5) describing changes made after V7.11 SP1.

Refer to "readme711.txt" for a descriptions of enhancements and

corrections in V7.11.

Refer to "readme710.txt" for a descriptions of enhancements and

corrections in V7.10.

Applications:

The MET/CAL V7.20 distribution includes the following versions

of the major applications in the MET/CAL suite:

(1) MET/CAL Editor V7.20

(2) MET/CAL Runtime V7.20

(3) MET/TRACK V7.20 Build #434

-------------------------------------------------------------------------------

Section 3: Installation Instructions -----------------------------------------

-------------------------------------------------------------------------------

Please see the Installation and Upgrade Guide.

-------------------------------------------------------------------------------

Section 4: What's New in V7.20? ----------------------------------------------

-------------------------------------------------------------------------------

----> FSC for Fluke 5320A Multifunction Electrical Tester Calibrator

Report Number: 38334

Application: MET/CAL

MET/CAL V7.20 includes an FSC for the Fluke 5320A Multifunction

Electrical Tester Calibrator.

An accuracy file with 1-year specifications is included.

The 5320 FSC uses a non-traditional name/value syntax.

Refer to on-line help for the 5320 FSC for further information.

----> FSCs for Fluke 8845A and Fluke 8846A

Report Number: 38329

Application: MET/CAL

MET/CAL V7.20 includes FSCs for the Fluke 8845A and Fluke

8846A high-precision multimeters.

Accuracy files with 1-year specifications are included.

Refer to on-line help for the 8845, M8845, 8846, and M8846

FSCs for further information.

----> FSC for Fluke 9640A RF Reference Source

Report Number: 38328

Application: MET/CAL

MET/CAL V7.20 includes and FSC for the Fluke 9640A RF

Reference Source.

An accuracy file with 1-year specifications is included.

The 9640 FSC uses a non-traditional name/value syntax.

The 9640 FSC supports Learn Mode (invoked by typing F7 in

the MET/CAL Editor) to assist with procedure generation.

Refer to on-line help for the 9640 FSC for further information.

----> Binary Serial Read Capability to MET/CAL

Report Number: 34832

Application: MET/CAL

MET/CAL V7.20 has been improved to better support reading data

from serial (RS232) instrument which send binary data messages.

(The Anritsu MS2711D (Spectrum Master) is an example of an

RS232 instrument which sends binary data.)

There are two components to the new support for binary

serial instruments:

(1) A new construction in the PORT FSC:

The PORT FSC now supports a new construction named "IB"

with the following syntax:

[IB <count> <timeout>]]

Refer to on-line help for the PORT FSC for details.

(2) A family of new MATH FSC functions which provide procedure

access to binary data. The new functions are:

brb - convert 1 byte to 32-bit integer at specified

byte offset

bri - convert 4 bytes to 32-bit integer starting at

specified byte offset

brn - return current binary buffer byte count

brs - convert specified range of bytes to a string

brw - convert 2 bytes to 16-bit integer starting at

specified byte offset

brx - convert specified range of bytes in binary

buffer to printable hex

Refer to on-line help for the MATH FSC for additional

information.

Data read from an instrument using the IB construction are

written to an internal data buffer reserved for that purpose.

The size of the data buffer is 4096 bytes.

----> FSC for the Agilent PSA Series Spectrum Analyzers

Report Number: 31767

Application: MET/CAL

MET/CAL V7.20 includes an FSC for the Agilent PSA Series

Spectrum Analyzers.

The PSA FSC supports the following measurement modes:

(1) Spectrum Analysis

(2) Phase Noise (Requires Option 226)

Refer to on-line help for the PSA FSC for further

information.

----> FSC for the Agilent N5531S Measuring Receiver

Report Number: 31765

Application: MET/CAL

MET/CAL V7.20 includes an FSC for the Agilent N5531S

Measuring Receiver.

Refer to on-line help for the N5531 FSC for further

information.

----> FSC for the Fluke PM 6690 Timer/Counter

Report Number: 29821

Application: MET/CAL

MET/CAL V7.20 includes an FSC for the Fluke PM 6690

Timer/Counter.

Refer to on-line help for the 6690 and M6690 FSCs for

further information.

----> FSCs for HP 5350B/51B/52B Microwave Frequency Counters

Report Number: 29146

Application: MET/CAL

MET/CAL V7.20 includes FSCs for the HP 5350B, 5351B, and

5352B Microwave Frequency Counters.

Refer to on-line help for the 5350, M5350, 5351, M5351,

5352, and M5352 FSCs for further information.

----> "Slew" Capability for User-Configured Sources

Report Number: 28317

Application: MET/CAL

MET/CAL V7.20 includes a group of MATH FSC functions which

allow the procedure writer to use MET/CAL's standard "slew"

dialog to slew a user-configured reference instrument.

The new functions are:

SLEW invoke slew dialog

SLEWINIT initialize slew dialog

SLEWMSG specify messages for slew dialog

SLEWOP get last slew operation

SLEWSCALE specify scale factor for slew dialog

SLEWSTART specify highlighted digit for slew dialog

Refer to the MATH FSC on-line help file for details.

----> Named Variables

Report Number: 28112

Application: MET/CAL

In V7.20 the MATH FSC, and other FSCs which accept math

expressions, support named variables.

The addition of named variables to the MATH FSC expression

parser makes it easier to read, write, and maintain procedures,

and removes the current limitations on the number of available

registers.

Both local and global variables are supported.

Refer to on-line help for the MATH FSC for details.

----> Number of Supported Serial Ports Increased

Report Number: 21188

Application: MET/CAL

In V7.20 the number of supported serial ports has been

increased from 4 to 16. The supported ports are now COM1,

COM2, COM3, COM4, COM5, ..., COM16.

The new capability is useful when USB-to-serial adapters

are used.

----> Add Pack & Unpack Functions to the MET/CAL Editor

Report Number: 19237

Application: MET/CAL Editor

To make it easier to transport procedures the V7.20 MET/CAL

Editor supports new "Pack" and "Unpack" operations.

"Pack" is used to generate a package file containing one or

more main procedures, together with all required subprocedure,

pictures, and user programs.

"Unpack" is the inverse of "Pack". "Unpack" is used to

extract procedures from a package, and reinstall selected

main procedures, required subprocedures, pictures, and user

programs on a MET/CAL workstation.

MET/CAL package files use the file extension ".pkm".

A procedure package cannot be created until the main procedure

and all required subprocedures are executable. Packages are

built from compiled procedure (extension ".pro"), not from

text procedures.

Packages are not compressed. When emailing packages or

archiving package files it's generally a good idea to compress

them first using a utility program such as WinZip. A package

compressed with WinZip must be unzipped before being unpacked.

The Pack and Unpack procedure selection windows are

multi-selection list boxes. Press the Ctrl key while

left-clicking the mouse button to select more than one

main procedure.

"Pack" and "Unpack" are located in the Editor's top-level

"File" menu.

-------------------------------------------------------------------------------

Section 5: Minor Enhancements in V7.20 ---------------------------------------

-------------------------------------------------------------------------------

----> Support Setting "tol_ref" to "System_Actual"

Report Number: 38611

Application: MET/CAL

In V7.11 SP1, and previous versions, MET/CAL supports two

"tol_ref" values:

Nominal

UUT_Indicated

In cases where the System Actual value differs from the

Nominal value it is useful to allow "tol_ref" to be set to

"System_Actual".

In V7.20, "System_Actual" is a legal value for "tol_ref".

For most tests setting "tol_ref" to "System_Actual" is the

same as setting it to "Nominal". However, in cases where

the System Actual value in a test differs from the Nominal

value, setting "tol_ref" to "System_Actual" is preferred.

----> Allow Inhibiting RESET FSC-Specified UUT Reset

Report Number: 38561

Application: MET/CAL

In some cases it is helpful to inhibit a RESET FSC-specified

reset of the UUT.

The situation where this is useful arises when:

(a) automatic connection messages are being used,

(b) the UUT is a source device capable of generating

dangerous voltages,

(c) the procedure is written to use ASK- Q,

(d) the software is automatically determining when

to switch certain devices, and

(e) the procedure writer does not wish to forgo the

RESET FSC's capability to reset the UUT when

the Post Test window appears, and when the

procedure terminates.

In V7.20, there's a new VSET/TEST parameter named "ResetUUT".

Refer to the V7.20 VSET help file for details.

Note: In V7.20 this capability is primarily intended for

use in conjunction with the N5531 FSC.

----> New MATH Functions to Retrieve Accuracy Floor and Gain Values

Report Number: 38505

Application: MET/CAL

In some cases it is useful to be able to retrieve accuracy

floor and gain values from MET/CAL accuracy files.

In V7.20 the following new MATH functions have been added:

ACCVF - one-parameter accuracy lookup of accuracy floor

ACCVF2 - two-parameter accuracy lookup of accuracy floor

ACCVG - one-parameter accuracy lookup of accuracy gain

ACCVG2 - two-parameter accuracy lookup of accuracy gain

Refer to on-line help for the MATH FSC for additional

information.

----> Support for "House" Frequency Reference for RF Calibration

Report Number: 38499

Application: MET/CAL

V7.20 includes a facility to specify and utilize a "house"

frequency reference for RF calibration. Typically the "house"

frequency reference is connected to the external reference

input on the applicable instruments in the calibration station.

The external reference then contributes to the timebase

accuracy of those instruments when "External Reference

Frequency" is selected.

In V7.20 this capability is used with the 9640, N5531, and PSA FSCs.

To specify the frequency reference choose "Frequency Reference"

in the "Configure" menu of the MET/CAL Editor or MET/CAL Runtime.

Choose the name of the configured instrument which is to be

used as the house frequency standard.

If necessary, you may also specify a non-default accuracy

file lookup mode string. The default is "Timebase" but, for

instruments which have multiple timebases, it may be necessary

to modify the lookup string. For example, in the PM 6681

accuracy file the following timebase mode strings are defined:

Mode: Timebase

Mode: Timebase PM9678B

Mode: Timebase PM9691

Mode: Timebase PM9692

Mode: Timebase PM6681R

If you are using a PM 6681 as a frequency standard the default

timebase accuracy is given in the "Mode: Timebase" section.

If you have a PM 6681 with one of the other timebase options,

modify the mode string shown in the "Frequency Reference"

dialog.

----> RDS Guardbanding Modified to Handle One-Sided Tolerances

Report Number: 38053

Application: MET/CAL

In V7.11 SP1, and earlier versions supporting guardbanding,

the implementation of the RDS guardbanding method disables

guardbanding whenever the expanded measurement uncertainty

exceeds either the upper or lower nominal test tolerance.

The rationale for this is that the RDS method requires that

the calculation:

SQRT(Tolerance^2 - Uncertainty^2)

be performed. An uncertainty which exceeds the tolerance

therefore requires that the square root of a negative number

be calculated.

However, an argument can be made that a totally one-sided

tolerance is really a different case. I.e., if the UUT value

falls on the zero tolerance side, it really indicates that

the instrument is not simply out of tolerance but, rather,

is non-functional.

In V7.20 the RDS method has been changed so that a one-sided

tolerance causes the pass and fail deviations on the zero

side to be set to zero. Previously, in this case, since the

expanded uncertainty (presumably always greater than zero)

always exceeded a zero deviation, MET/CAL simply turned

off RDS guardbanding. This was necessary to avoid taking

the square root of a negative number. (Note, however,

that if a tolerance deviation is non-zero, regardless of

how small it is, MET/CAL still turns off RDS guardbanding

whenever the expanded uncertainty exceeds the deviation.

I.e., only the case where a deviation is exactly zero is

special-cased in this way.) The effect of setting the pass

and fail deviations both to zero on the zero side is that

if the UUT value falls on that side of the reference value,

the test can never pass, and can never be indeterminate.

----> Functions to Provide Procedure Control of Safety Symbol

Report Number: 38007

Application: MET/CAL

To deal with unsafe signals generated by user-configured

references and/or the UUT MET/CAL V7.20 includes functions

to display and remove the OSHA lightning bolt warning symbol

under procedure control.

New MATH FSC functions named "SafeOn" and "SafeOff" have

been added.

These functions interact with the RESET FSC in this way:

When a RESET-specified command is executed, MET/CAL

presumes that the referenced instrument is being

reset to a safe state. Therefore, if the safety

symbol is currently displayed, based on a signal

generated by that instrument, the safety symbol

will be automatically removed when the reset command

executes. When this mechanism is relied upon it is

therefore not necessary to call "SafeOff" to remove

the safety symbol.

Calls to SafeOn have this form:

SafeOn(<device name>, <dimensioned quantity>, <waveform>)

<device name> is the name of a configured instrument, or it

can be literally "UUT".

<dimensioned quantity> is a value, with units symbol and

optional units prefix. For example, "1 kV", "90 Vpp", etc.

Waveform is used with AC voltages to specify the waveform type.

For example, "sine", "square", "+ramp", etc. For DC voltages

specify "" as the waveform.

If the procedure is working with user-configured references,

accessed via address alias, the instrument name corresponding

to a particular alias may be obtained by calling MATH function

"Instr".

Calls to SafeOff have this form:

SaveOff(<device name>)

Refer to the on-line help for the MATH FSC for additional

information.

----> Procedure-Specified Substrings Supported in Automatic Connection

Messages

Report Number: 37285

Application: MET/CAL

The utility of automatic connection messages has been

enhanced by the addition of support for procedure-based

specification of UUT-specific substrings to be inserted at

designated positions in connection messages.

This capability is used in the N5531 FSC to support automatic

switching of power sensors at frequencies not directly

specified in the procedure.

A new MATH function has been implemented to allow the

procedure writer to specify UUT-specific substrings (i.e.,

phrases) which are inserted at designated places in automatic

connection messages.

The name of the function is "CM".

The first argument is the connection message substring number.

The number must be between 1 and 8, or, as a special case,

0 to refer to all connection message substrings.

Example:

When autmatic connection messages are enabled a procedure

statement like this:

5700 1.000V 1%

generates a pop-up connection message which says:

Connect: UUT to 5700A Output Terminals

Internally, this message is stored as:

UUT @1 to 5700A Output Terminals

In this message the "@1" is a descriptor which will be

replaced by a procedure-specified replacement string.

Thus, if the procedure includes a statement like this:

MATH CM(1, "Input HI")

The displayed connection message will appear as:

Connect: UUT Input HI to 5700A Output Terminals

If a connection message substring is not specified, the

corresponding descriptor (including trailing space) is

removed from the message before display. This causes the

message to be just as it was prior to the implementation of

the "CM" function.

To remove a connection message substring specification simply

assign an empty string. For example:

MATH CM(1, "")

To remove all substring specifications:

MATH CM(0, "")

Automatic disconnection messages are generated whenever a

message changes. For example:

MATH CM(1, "Input HI")

5700 1.000V 1%

MATH CM(1, "Input LO")

5700 1.000V 1%

will generate the sequence of messages:

Connect: UUT Input HI to 5700A Output Terminals

Disconnect: UUT Input HI from 5700A Output Terminals

Connect: UUT Input LO to 5700A Output Terminals

Note that this feature is not yet fully enabled in MET/CAL

because most internal automatic connection messages have

not been updated to include descriptors at appropriate places.

In V7.20 this feature is retricted to use with the N5531 FSC.

----> Add Support for 115200 Baud to PORT FSC

Report Number: 36514

Application: MET/CAL

In V7.20 the PORT FSC has been enhanced to support 115200 baud.

----> Accuracy File for Raytek (Fluke) BB4000 BlackBody Source

Report Number: 36207

Application: MET/CAL

An accuracy file for the BB4000 has been created. The name

of the file is "bb4000.acc". The following example shows

how the accuracy file can be used in a MET/CAL procedure:

INSTRUMENT: Example - Raytek BB4000 Accuracy Lookup

STANDARD: Raytek BB4000

STD Raytek BB4000

HEAD TEMPERATURE: Degrees C

MATH L[1] = ACCV("Raytek BB4000", "DegC", 21.0)

ACC 21degC L1U

MEMI Enter UUT reading in degrees C.

MEMCX 21degC 3U

MATH L[1] = ACCV("Raytek BB4000", "DegC", 100.0)

ACC 100degC L1U

MEMI Enter UUT reading in degrees C.

MEMCX 100degC 3U

Note that the BB4000 is a manual standard, so no FSC is needed.

----> Function to Delete a Named Variable

Report Number: 35675

Application: MET/CAL

A named variable is created when the first assignment to

the variable occurs.

In some cases (but not too many) it may be useful to remove

a variable which was previously created.

MET/CAL V7.20 includes a new MATH FSC function named "DEL"

which deletes a named variable.

----> Function to Determine if Named Variable Exists

Report Number: 35673

Application: MET/CAL

MET/CAL V7.20 allows users to create variables with arbitrary

names (subject to some restrictions on name syntax). These

variables are different from the "registers" which MET/CAL

has supported previously (MEM, MEM1, MEM2, 'S' Registers,

'M' Registers, 'L' Registers) in that named variables, unlike

registers, do not exist until a value is assigned to them.

In some cases it is useful to test the variable name to

determine if the named variable exists.

V7.20 includes a new MATH FSC function named "IsVar" which

can be used to test a variable name to determine if the

variable exists.

Refer to the MATH FSC on-line help file for further information.

----> Function to Determine If Value of String Variable is Null

Report Number: 35672

Application: MET/CAL

In some cases it is useful to test the value of a MET/CAL

string variable to determine if the value is null.

In V7.20 there's a new MATH FSC function "NULL" which tests

a string variable to determine if it is null.

An example of a null string variable is an 'S' register

which has not had a value assigned to it.

(Note that named variables which have not been assigned

to are undefined, not null. Therefore, the NULL function

cannot be used to test unassigned named variables.)

Refer to on-line help for the MATH FSC for additional

information.

----> Function to Determine if Value of String Variable is Empty String

Report Number: 35671

Application: MET/CAL

In MET/CAL V7.20 there's a new MATH function named "EMPTY"

which tests a string variable to determine if the value is

the empty string.

Refer to the MATH FSC on-line help file for details.

----> Boolean Inverse Function Added to MATH FSC

Report Number: 35513

Application: MET/CAL

In V7.20 the MATH FSC includes a new function named "NOT".

"NOT" is a numeric function which returns zero if the value

of its argument is non-zero. "NOT" returns 1 if the value

of its argument is zero.

In some situations procedure readability may be improved by

using the "NOT" function.

Example:

IF (NOT(ZCMP("A", "B")))

...

ENDIF

----> Support for PM6690/8xx 0.3 - 20 GHz Channel C Pre-Scaler

Report Number: 35477

Application: MET/CAL

In V7.20 the 6690 and M6690 FSCs have been updated to support

the PM6690/811 0.3 - 20 GHz Channel C pre-scaler.

----> Test Run "Go" Modified to Preserve RESET Statements

Report Number: 35420

Application: MET/CAL

In V7.11 SP1 and prior the implementation of Test Run clears

all memory of executed RESET statements upon procedure

termination.

The effect of this design is that when the procedure

is re-executed RESET statements must be re-executed

to re-establish the reset commands to be executed when

instruments are reset after an evaluation step, and when

the procedure terminates.

The necessity of re-executing RESET statements is therefore

present regardless of whether Test Run is started using

"Restart" (F2) or "Go" (Alt+F2).

In this respect the RESET commands are therefore handled

differently from MET/CAL registers and variables. Registers

and variables are cleared when "Restart" is used, but not when

"Go" is used.

In V7.20 MET/CAL has been modified so that RESET commands

are not cleared on procedure termination.

----> MET/CAL Runtime Remembers Size & Position of Main Window

Report Number: 35318

Application: MET/CAL

In V7.20 the MET/CAL Runtime application's main window

has been modified so that the size and the position of the

window are remembered from one invocation of the application

to the next.

If any of the remembered size and position values are

unavailable or not valid, or if any part of the window is

off screen, the system reverts to default size and position

parameters.

The default is:

width = 640 pixels

height = 360 pixels

position = centered

----> 8508A Accuracy File Now Has Specs Between 1 Hz and 10 Hz

Report Number: 35290

Application: Accuracy File

When the instrument was first release the Fluke 8508A was

not specified between 1 Hz and 10 Hz. Specifications in this

frequency range have been added. In V7.20 MET/CAL's accuracy

file for the 8508A has therefore been updated so that MET/CAL

calculates the Test Accuracy Ratio for affected tests.

----> New 6100 FSC Parameter to Inhibit Reset in Instrument Setup

Report Number: 33295

Application: MET/CAL

In V7.20 a new parameter has been added to the 6100 FSC to

cause the reset of the 6100A to be inhibited at the beginning

of an instrument setup operation.

The name of the new parameter is "SetupReset". Legal values

are "Off" and "On". Setting "SetupReset" to "Off" inhibits

the reset of the 6100A.

(Note: 6100A firmware design limits the utility of the

"SetupReset" parameter.)

----> New MATH FSC Functions to Access Database Calibration Table

Report Number: 33245

Application: MET/CAL

V7.20 includes two new MATH FSC functions to provide read

access to the database Calibration Table:

(1) CAL

Given an asset number, a record number, and a

Calibration Table field number, CAL returns the

value of the specified field in the specified record.

Records are numbered from 1 to N, where N is the

most recent record.

If the record number passed to CAL is a negative

number, the number is taken to be relative to the

current record. (-1) refers to the most recent record,

(-2) refers to the 2nd most recent record, and so on.

(2) NCAL

Given an asset number, NCAL returns the number of

cal records for the specified asset.

----> Non-Standard Variant of X-ON/X-OFF RS232 Communications

Report Number: 33209

Application: MET/CAL

Investigation of the Fluke Biomed ESA601 Electrical Safety

Analyzer reveals that the instrument implements a non-standard

method of serial (RS232C) communication.

It implements X-ON/X-OFF communication, but with the additional

requirement that the RTS interface line must be held high

at all times.

It's not too uncommon to use the DTR line (Data Terminal

Ready) in this fashion, and MET/CAL has supported devices

which expect DTR to be held high since V4.

HyperTerminal is able to talk to the ESA601. Thus, it appears

that HyperTerminal holds the RTS line high when the protocol

is X-ON/X-OFF or None.

The Windows serial driver supports holding RTS high in

certain modes. (Note that RTS cannot be held high when

normal hardware handshaking is used because, in that mode,

the devices toggle the CTS and RTS lines as needed.)

Therefore, to facilitate communication with the ESA601,

and perhaps other instruments with the same sort of serial

interface, it would be very useful if MET/CAL supported a

new handshaking code, 'R', which would be the same as 'X'

(X-ON/X-OFF), but with RTS held high.

Resolved in V7.20.

The PORT construction now supports 'R' as a handshaking code.

This can be used with the ESA601, as well as other serial

devices which implement non-standard X-ON/X-OFF RS232

communications.

----> New VSET Parameters to Control Wait-for-SRQ Timing and Retries

Report Number: 33107

Application: MET/CAL

In MET/CAL V7.11 SP1 and prior problems due to timing

idiosyncrasies sometimes occurs when using the IEEE2 and

SCPI FSCs.

In some cases instruments are unable to respond quickly

enough when serial polled after an SRQ has been generated.

Errors which may be observed are:

"E558: Unexpected SRQ while waiting for SRQ from

instrument on board <b> at IEEE-488 address <n>."

and

"E2109: Unexpected SRQ (board=<b>, IEEE-488

address=<n>, status byte=<sb>)."

In V7.20 there are three new VSET parameters which may be

used to optionally configure the timing when MET/CAL is

waiting for an SRQ, and then serial polling to determine

the source of the SRQ. (Internally the same code is used

for this purpose in the IEEE2 FSC, the SCPI FSC, and the

[SRQ] construction in an IEEE statement.)

The new parameters are:

SRQDELAY

SRQDELAY is used to specify the delay, in milliseconds,

to be used in MET/CAL's wait-for-SRQ retry loop.

The specified delay must be between 0 and 1000

milliseconds.

The delay affects both IEEE statements which use

an SRQ construction and the built-in wait-for-SRQ

operation used in the IEEE2 and SCPI FSCs.

SRQHOLDOFF

SRQHOLDOFF is used to specify the delay, in

milliseconds, to be used prior to the initial serial

poll in MET/CAL's wait-for-SRQ operation.

The specified delay must be between 0 and 1000

milliseconds.

The holdoff delay affects both IEEE statements which

use an SRQ construction and the built-in wait-for-SRQ

operation used in the IEEE2 and SCPI FSCs.

SRQRETRY

SRQRETRY is used to specify the maximum number of serial

poll retries in MET/CAL's wait-for-SRQ operation.

SRQRETRY affects both IEEE statements which use an SRQ

construction and the built-in wait-for-SRQ operation used

in the IEEE2 and SCPI FSCs.

The general approach used by MET/CAL when it waits for an

SRQ is as follows:

(1) Wait (up to a specified timeout) for the system

to detect an SRQ. Any SRQ terminates this

operation.

(2) As soon as an SRQ has been detected, serial poll

the device from which the SRQ was expected.

MET/CAL expects the device to respond, per the

IEEE-488 standard, by returning a status byte

in which the RQS bit is set.

Specifying an SRQRETRY value greater than zero

instructs MET/CAL to retry step (2), as needed,

up to SRQRETRY times.

SRQRETRY must be between 0 and 100.

Refer to the VSET on-line help file for additional information

on the new parameters.

These parameters may be specified in the MET/CAL initialization

file, if desired.

It is important to remember that problems with the IEEE2 and

SCPI FSCs are usually caused by procedure programming errors.

The parameters documented above may be tried as a

"last resort" after other attempts to troubleshoot the

problem have been tried.

----> Show Procedure Status (Hidden or Visible) in Editor's Procedure

Selection Window

Report Number: 31162

Application: MET/CAL Editor

In V7.20 the MET/CAL Editor has been modified so that it

visually distinguishes hidden procedures in the procedure

selection window.

In addition, non-executable procedures are also visually

distinguished.

Hidden procedures are shown as follows:

(a) If the line is not selected, the background

is yellow.

(b) If the line is selected, the text is yellow.

Non-exectuable procedures are shown as follows:

(a) If the line is not selected, the background is red.

(b) If the line is selected, the text is red.

This feature may be disabled by setting the optional

initialization file parameter "ShowProcSelWinColor" to "No".

The default value for "ShowProcSelWinColor" is "Yes".

This change affects only the MET/CAL Editor's procedure

selection window. It does not affect Copy Procedures, Delete

Procedures, or Hide Procedures. It also has no effect in

MET/CAL Runtime because MET/CAL Runtime does not show hidden or

non-executable procedures in its procedure selection window.

----> Stability Check Added to 4950 FSC

Report Number: 31163

Application: MET/CAL

In MET/CAL V7.11 SP2 a warning message has been added to the

4950 FSC to inform the operator of the need to wait for the

instrument to warm up. The message shows the remaining time

(hours and minutes) until stabilization.

----> Add Destination and Source Directories to "Confirm Procedure

Copy" Window

Report Number: 31161

Application: MET/CAL Editor

To reduce possible confusion when copying procedures,

MET/CAL V7.11 SP2 Editor has been modified so that the

"Confirm Procedure Copy" dialog displayes the source and

destination directories.

For a procedure with exactly one name the "Confirm Procedure

Copy" dialog is now structured like this:

Copy Procedure:

<procedure name>

From: <source directory>

To: <destination directory>

[Yes] [Yes to All] [No] [Cancel]

For a procedure with six names the "Confirm Procedure Copy"

dialog is structured like this:

Copy Procedure:

<procedure name #1>

<procedure name #2>

<procedure name #3>

<procedure name #4>

<procedure name #5>

<procedure name #6>

From: <source directory>

To: <destination directory>

[Yes] [Yes to All] [No] [Cancel]

----> Formatting Measurement Uncertainty Data in Specified Units

Report Number: 22586

Application: MET/CAL

MET/CAL V7.20 supports a new VSET parameter which allows

the procedure writer to control the formatting of measure

uncertainty-related result data.

The name of the new VSET/TSET parameter is "UFMT".

There are 4 legal values for the UFMT parameter:

(1) SCI - scientific notation

(2) ENGR - engineering format

(3) PREFIX - prefix and units

(4) NOM - prefix and units, based on NOMINAL

SCI is equivalent to the formatting used in V7.11 SP1 and

prior versions.

Refer to the VSET on-line help file for details.

----> VSET Parameter to Generate Error When Correction Not Performed

Report Number: 19616

Application: MET/CAL

In MET/CAL V7.20 there's a new VSET parameter which may

be used to cause a test to be aborted when corrections are

enabled but no correction is performed.

The parameter name is "CORREQ". Legal values are "YES",

"NO", and "EXACT". Interpretation is as follows:

(1) VSET CORREQ = YES

If the ASK 'C' flag is enabled and a non-go/nogo

instrument test is performed, and the System Actual

value is not corrected, an error message is generated,

terminating the test step with an error condition,

and presenting the usual Post Test dialog. At that

point the user may in most cases attempt to correct the

problem and repeat the test, or may accept the failure

and continue with the next test in the procedure.

(2) VSET CORREQ = EXACT

If the ASK 'C' flag is enabled and a non-go/nogo

instrument test is performed, and the System Actual

value is not corrected based on an exact match in

the correction file, an error message is generated,

terminating the test step with an error condition,

and presenting the usual Post Test dialog. At that

point the user may in most cases attempt to correct the

problem and repeat the test, or may accept the failure

and continue with the next test in the procedure.

(3) VSET CORREQ = NO

If the ASK 'C' flag is enabled and a non-go/nogo

instrument test is performed, and the System Actual

value is not corrected, MET/CAL simply performs the

test using the uncorrected system actual.

CORREQ = NO is the default setting, and corresponds

to the way MET/CAL has handled corrections since

product inception.

As with most VSET parameters, CORREQ may also be used

with the TSET FSC to restrict the effect of the setting to

individual tests.

If CORREQ is set to YES or EXACT, and an error is generated

indicating that a correction was not performed, it is not

possible to correct the problem on the fly unless the source

of the problem is missing or incorrect correction data in the

correction file. If the reason that the correction was not

performed is that the MET/CAL initialization file does not

specify a correction directory, then it is not possible to

correct the problem on the fly and repeat the test. In this

case it is necessary to close the application, update the

initialization file, and re-perform the verification procedure.

-------------------------------------------------------------------------------

Section 6: V7.11 SP1 Enhancements --------------------------------------------

-------------------------------------------------------------------------------

----> Temp & Humidity Don't Accept Comma Decimal Symbol

Report Number: 30748

Application: MET/CAL Runtime (metgendb.dll)

In MET/CAL Runtime V7.11 the pre-prompt and post-prompt

windows do not accept commas as decimal symbols in numeric

values written to database fields.

This problem is typically experienced when entering temperature

and humidity values to be associated with a calibration event.

V7.11 SP1 includes a new version of "metgendb.dll" which

corrects this problem.

----> Due Date Not Calculated When Importing Maintenance Records

Report Number: 30746

Application: MET/TRACK, Import Tool

In V7.11 the import function fails to calculate due dates

for imported maintenance records. No error message is

generated when the due date is required but not provided in

the import data. This problem applies both to the built-in

import function of MET/TRACK and to the external Import

Tool application.

V7.11 SP1 provides an updated version of the library

"metgendb.dll" which generates an error message in this

situation.

----> MET/TRACK License Information Updated for Remote Pipeline

Compatibility

Report Number: 30428

Application: MET/TRACK

In MET/TRACK V7.11, when a license is marked as "in use"

by On Time Support's Remote Pipeline application MET/TRACK

is unaware of that fact and therefore reports the license

as available.

In V7.11 SP1 MET/TRACK has been updated to be aware of the

"in use" designation applied by Remote Pipeline, and no

longer shows the license as "available".

----> Add Flag to OPBR FSC to Set MEM1 to Zero Rather Than (-1) When

User Chooses "No"

Report Number: 30315

Application: MET/CAL

In V7.11 SP1 a new, optional flag has been added to the

OPBR FSC. Specifying "-z" at the beginning of the first

line of an OPBR statement causes MEM1 to be set to zero,

rather than (-1), when the operator choose "No" in response

to the OPBR prompts.

There is a small backwards compatibility problem with this

change. Any existing OPBR statement in which the first

line begins with "-z " will be changed by this enhancement.

However, it was felt that the risk is quite small, and

therefore the change has been implemented.

The "-z" flag is case-sensitive, and there must be a space

after the 'z'.

----> Remember State of Test Results Window

Report Number: 30197

Application: MET/CAL

In V7.11 SP1 MET/CAL has been changed to remember the state

of the Test Results window.

Previously MET/CAL remembered size and position information

for the window but did not remember whether or not the window

was minimized.

The change applies to both the MET/CAL Runtime application and the

Editor Test Run application.

The remembered state is either "minimized" or "normal".

The maximized state is not remembered because when the window

is maximized it prevents interaction with MET/CAL Runtime and

Test Run applications.

----> Increase Maximum Number of Lines Per DISP Statement to 32

Report Number: 30186

Application: MET/CAL

In V7.11 SP1 the maximum number of lines per DISP statement

has been increaded from 8 to 32.

----> Increase Maximum Number of Lines Per OPBR Statement to 32

Report Number: 30185

Application: MET/CAL

In V7.11 SP1 the maximum number of lines per OPBR statement

has been increaded from 8 to 32.

----> Add MATH FSC Function to Get Asset Number of UUT

Report Number: 29819

Application: MET/CAL

A number of MET/CAL users have requested that there should

be a MATH FSC function to return the asset number of the

UUT during calibration procedure execution.

In V7.11 SP1, there's now a new MATH FSC function named "UUT".

The return value is an empty string when using Test Run.

----> Inhibit Reset of Meter System Instruments in Post Test Processing

Report Number: 29519

Application: MET/CAL

In V7.11 and prior an instrument-specific driver

"reset" function is called for a

System Instrument whenever the Post Test window is displayed.

For example, if a Keithley 2001 is configured and used by a

procedure, whenever the Post Test window is displayed, the

Keithley 2001 "reset" function in the 2001 driver is called.

Currently, the reset function sends the following command:

*CLS;FUNC "VOLT:DC";:VOLT:DC:RANGE 1000

A problem one customer encountered is as follows:

2001 is set to DC amps.

UUT is set to source amps.

An error occurred which caused the post test dialog

to be displayed.

2001 is set to DC volts by the reset function.

UUT went to over compliance.

There are two reasons one might not want the driver to reset

a meter system instrument after a test:

1. Problems like the one described above.

2. In the case of an evaluation failure, the reading

that just contributed to the evaluation is removed

from the meter display.

The underlying purpose of the driver reset function is

to put the System Instrument in a safe state. For source

devices, the instrument, typically, is put in standby, and the

output is programmed to a safe value (voltage output only).

For meter-type System Instruments however, it is not clear

that resetting or setting to DCV is always the safest state.

In V7.11 SP1 MET/CAL has been changed to inhibit, by default,

the normal Post Test "reset" operation for the following

instruments:

F45

F5790A

F8505A

F8506A

F8842A

F8920A

HP34401A

HP34420A

HP3458A

K2000

K2001

K2002

PM6666

The call to the driver-specific "reset" function is not

inhibited in cases where the procedure step was terminated

by the operator or terminated due to an error condition.

Here's an example of a case where the Post Test "reset"

function is inhibited. Suppose you execute a 3458 statement,

and the result of the test is that the UUT is out of tolerance

(i.e., the test fails). In that case the Post Test window

will be shown, and MET/CAL will call driver-specific reset

functions for all system instruments which are in use, but it

will skip the call to the HP 3458A driver's "reset" function.

The inhibition of the "reset" function can be overridden using

the follwing new VSET / TSET / initialization file parameters:

PTF_F45

PTF_F5790A

PTF_F8505A

PTF_F8506A

PTF_F8842A

PTF_F8920A

PTF_HP34401A

PTF_HP34420A

PTF_HP3458A

PTF_K2000

PTF_K2001

PTF_K2002

PTF_PM6666

Legal values for these parameters are "Yes", "1", "No", and

"0". "Yes" is the same as "1". "No" is the same as "0".

The default value used in the absence of a VSET/TSET or

initialization file specification is "No".

It's conceivable that the change described here could

introduce minor timing changes in existing procedures.

If negative side-effects due to the inhibition of the Post

Test "reset" function appear the procedure writer may set

the corresponding PTF parameter (as shown in the list above)

to "No" to cause MET/CAL to revert to the approach used in

V7.11 and prior where the Post Test "reset" function was

unconditionally invoked.

----> Show Current Procedure Directory in Editor

Report Number: 29411

Application: MET/CAL Editor

In V7.11 SP1 the Editor has been updated to show the current

procedure directory in the window title of the main window.

----> Add Support for Fluke 525A-PA5 Pressure Module to 525 FSC

Report Number: 29401

Application: MET/CAL

In V7.11 and prior the 525 FSC does not support the new

Fluke 525A-PA5 Pressure Module.

V7.11 SP1 provides updates versions of MET/CAL Runtime and

Editor applications which support the 525A-PA5.

----> Add Support for Fluke 525A-P03 Pressure Module to 525 FSC

Report Number: 29400

Application: MET/CAL

In V7.11 and prior the 525 FSC does not support the new

Fluke 525A-P03 Pressure Module.

V7.11 SP1 provides updates versions of MET/CAL Runtime and

Editor applications which support the 525A-P03.

----> Verify Serial Number of Reference

Report Number: 29160

Application: MET/CAL Runtime

V7.11 SP1 includes an improvement to cross-check the serial

number of a connected system instrument against the serial

number of the asset configured in the database.

This feature is optional. It is controlled by a new

initialization file parameter named "SerialNumberCheck".

The serial number check applies only to system references

which allow the serial number to be remotely queried.

It does not apply to user-configured references (i.e.,

references for which there's no MET/CAL FSC).

The serial number check is not performed in Test Run.

The serial number check is not performed in demo mode.

The "SerialNumberCheck" parameter has 3 legal values:

"Yes" - Cross-check the serial number and abort the

procedure if a serial number mismatch is

detected.

"No" - Do not cross-check the serial number.

(This is the way V7.11 and prior versions

work.)

"Warn" - Cross-check the serial number. If a

mismatch is detected present a dialog to

give the user the option of aborting the

procedure or ignoring the mismatch.

The default value is "Yes". If you do not want MET/CAL to

perform this check you must add:

SerialNumberCheck = No

to the [Startup] section of "metcal.ini" on each MET/CAL

workstation.

The following drivers report serial numbers to enable

cross-checking against the configuration:

1281

2000

2001

2002

2024

2620t

33120

33220

3325

33250

34401

34420

395

39a

437

4418

45

525

53100

5500

5790

6304

6520

6680

6685

8648

8846

9100

9500

hp60

smy02

----> Improve SCPI & IEEE2 Error Handling with Non-Compliant

Instruments

Report Number: 28967

Application: Runtime, Editor

There are instruments that claim to be IEEE-488.2 and /

or SCPI compliant, but are not fully compliant.

V7.11 SP1 includes minor improvements in the IEEE2 and SCPI

FSCs to better handle such instruments.

(1) IEEE2 / SCPI Queries:

When setting up a query the IEEE2 and SCPI FSCs

send a "*SRE" command to enable the CME, EXE, DDE,

and QYE error flags.

They also send a "*ESE" command to configure the

instrument so that ESB will be set in the status

byte if, and only if, one or more of the CME, EXE,

DDE, and QYE error flags become true.

The IEEE2 and SCPI FSCs therefore do not expect an

instrument to set ESB in the status byte, but then

fail to set at least one of CME, EXE, DDE, and QYE.

Nevertheless, some instruments do not adhere to the

scenario outlined above.

For example, the HP / Agilent 34401A sets ESB in

the status byte after certain "cal adjust" errors,

but does not set any of CME, EXE, DDE, and QYE in

the ESR (Event Status Register).

In V7.11 (and prior versions which have the IEEE2

and SCPI FSCs), MET/CAL handles this situation by

generating a general message:

The ESB (Event Status Bit) is set for an

unknown reason in the status byte returned

by the instrument on board %u at IEEE-488

address %u. The instrument generated an SRQ,

and acknowledged the SRQ, but none of QYE

(Query Error), DDE (Device Dependent Error),

EXE (Execution Error), or CME (Command Error)

are set.

In V7.11 SP1 the following two changes have been

made to improve the error handling in the IEEE2 and

SCPI FSCs after a query error:

(a) The values of the Status Byte and

the Event Status Register have been

added to the error message.

(b) If the instrument is a SCPI instrument,

queued up system errors (if any) are

displayed, even though none of CME, EXE,

DDE, and QYE are set.

(2) IEEE2 / SCPI Commands:

The IEEE2 and SCPI FSCs handle commands (as opposed

to queries) in essentially the same manner described

above, with the difference being that OPC is also

enabled as one of the conditions which can cause

ESB to be set.

For a command, in V7.11 (and prior versions which

have the IEEE2 and SCPI FSCs), MET/CAL handles the

situation where ESB is set but none of OPC, CME, EXE,

DDE, and QYE are set by generating a general message:

The ESB (Event Status Bit) is set for an

unknown reason in the status byte returned

by the instrument on board %u at IEEE-488

address %u. The instrument generated an SRQ,

and acknowledged the SRQ, but none of OPC

(Operation Complete), QYE (Query Error),

DDE (Device Dependent Error), EXE (Execution

Error), or CME (Command Error) are set.

In V7.11 SP1 the following two changes have been

made to improve the error handling in the IEEE2 and

SCPI FSCs after a command error:

(1) The values of the Status Byte and

the Event Status Register have been

added to the error message.

(2) If the instrument is a SCPI instrument,

queued up system errors (if any) are

displayed, even though none of OPC, CME,

EXE, DDE, and QYE are set.

----> Add Ini Param to Cause MET/TRACK to Revert to V6 Update

Default Handling

Report Number: 28966

Application: MET/TRACK

In MET/TRACK V7.11 (and earlier V7 versions), when an update

default value is specified for an Inventory Table field and

the field already has a value, editing the record does not

overwrite or change the existing value.

This is different from previous versions.

In previous versions (6.11 and prior) the default value

was used. This behavior was used by customers to update the

arrive date, change status, etc., but does not work in V7.00,

V7.01, V7.10, and V7.11.

To demonstrate the problem:

Put an Inventory Table field on the edit form

(e.g., I4225) with an "Adding" default of "AAA"

and an updating default of "BBB". Login as a

non-administrator user and create a new asset.

Note that the value "AAA" is placed in the field.

Now edit the same record and note that the value

"AAA" remains in the field.

Although some users feel that the manner in which V7 implements

the "update default" feature renders the feature useless,

the "update default" feature as implemented in V6 is really

a design flaw in MET/TRACK.

As an example of why this is a design flaw in V6 consider

this scenario:

1. You have a table with 2 fields, F1, and F2.

2. You set the "update default" value for F1 to "a".

3. You edit a record and change the F1 value to "b".

4. You edit the record again and assign a value to

field F2.

5. At this point why would a user want the F1 value

to be changed from "b" to "a"?

Nevertheless, to provide a solution for customers who became

accustomed to the V6 operation, V7.11 SP1 supports an optional

initialization file parameter which causes MET/TRACK to

implement V7 "update default" handling.

By default, MET/TRACK continues to operate as it does in

versions 7.00 through 7.11.

To cause MET/TRACK to handle update defaults as V6 did specify:

Inventory_Field_Over_Write = 1

in the [MetTrack] section of the MET/CAL initialization file

("metcal.ini").

----> Allow Configuration of Post Test Summary Display for

Indeterminate Guardband Results

Report Number: 28845

Application: MET/CAL

The display of the MET/CAL Post Test Summary dialog after

a test is controlled by a number of factors. The factors

include:

(1) the ASK 'A', 'F', and 'J' flags

(2) the FSC

(3) whether or not the test is a go / no-go test

(4) whether or not the procedure contains an

adjustment block

(5) the pass/fail status of the test

(6) the adjustment threshold

Condition (5) in the list above applies when the instrument

is a numeric (non-go / no-go) instrument, MEMC, or MEMCX

evaluation, ASK 'J' is not set, there's no adjustment block,

the ASK 'A' flag is not set, and the ASK 'F' flag is set.

In that case, when guardbanding is enabled, the implementation

in V7.10 and V7.11 is to display the Post Test Summary

dialog if the result of the test is fail, fail indeterminate,

or pass indeterminate.

In other words, any result other than an outright pass causes

the dialog to be displayed.

V7.11 SP1 supports a new guardbanding parameter, "gb_pts",

which allows the procedure writer or site administrator

to configure the software with respect to when the Post

Test Summary is shown after a guardbanded test with an

indeterminate result.

Refer to on-line help for the VSET FSC or to the updated

"Guardbanding.pdf" document for a full explanation of the

"gb_pts" parameter.

----> Add Ability to Turn Off Guardbanding

Report Number: 28833

Application: MET/CAL

In MET/CAL V7.10 and V7.11 if a guardbanding method is

specified in the MET/CAL initialization file or in the

guardbanding initialization file, then there's no way to

turn off guardbanding in a particular procedure.

Specifying "gb = *" in a VSET statement resets the value of

"gb" to the initialization file-specified value.

This is a general aspect of VSET-specified parameters which

also support initialization file specifications.

In V7.11 SP1 the list of legal values for the "gb" parameter

(guardbanding method) has been expanded to include "off".

This allows a customer to specify a workstation or site

default, but then selectively turn off guardbanding for

particular procedures, or particular tests within a procedure.

----> Provide Method to Reset All VSET Parameters At Once

Report Number: 28002

Application: MET/CAL

MET/CAL V7.11 SP1 allows the procedure writer to reset all

VSET parameters at once by specifying:

VSET ALL = *

It's also legal, though not very useful, to specify:

TSET ALL = *

(Any version equal to or later than V7.11h supports the VSET

"ALL" parameter.)

Refer to the on-line help for the VSET and TSET FSCs for

details.

----> Add dB-to-% and %-to-dB Conversion Functions to MATH FSC

Report Number: 24213

Application: MET/CAL

In V7.11 SP1 there are 4 new functions in the MATH FSC for

converting between dB values to percentages and vice versa:

dbtopctw - given power ratio in dB, convert to

percentage

dbtopctv - given voltage ratio in dB, convert to

percentage

pcttodbw - given power ratio expressed as percentage,

convert to dB

pcttodbv - given voltage ratio expressed as percentage,

convert to dB

-------------------------------------------------------------------------------

Section 7: Crystal Reports ---------------------------------------------------

-------------------------------------------------------------------------------

MET/CAL V7.20 includes the following reports:

( 1) basic_inventory.rpt

( 2) basic_report_template.rpt

( 3) cal_due_by_asset_for_xxx_days.rpt

( 4) cal_due_by_asset_through_date.rpt

( 5) cal_due_by_dept_by_status_for_xxx_days.rpt

( 6) cal_due_by_location_by_status_thru_date.rpt

( 7) cal_due_by_tech_by_status_for_xxx_days.rpt

( 8) cal_due_by_tech_by_status_thru_date.rpt

( 9) cal_procedures_and_revs_for_eqpt.rpt

(10) cal_summary_for_asset_number.rpt

(11) cal_summary_for_work_order.rpt

(12) field_customization.rpt

(13) field_properties.rpt

(14) license.rpt

(15) master_inventory_for_asset_number.rpt

(16) rt_certificate_of_cal_or_failed_cal.rpt

(17) rt_report_of_cal_ver_7.rpt

(18) rt_report_of_cal_ver_7_color_coded.rpt

(19) rt_report_of_cal_ver_7_failures.rpt

(20) rt_report_of_cal_with_exp_uncert.rpt

(21) screen_customizing.rpt

(22) trace.rpt

The list above shows the report file names.

To install reports use MET/TRACK. Login as "MT", and choose first

"Install Reports", then "Configure Reports" in the top-level

"Set-Up" menu.

Additional reports are included on the MET/CAL Bonus Disk.

A brief description of each report on the MET/CAL 7.20 CD (not the

Bonus Disk) is provided below:

basic_inventory.rpt

A basic report that shows just inventory data. This

report can be used as a template for other reports.

basic_report_template.rpt

A basic report that shows inventory data.

Specifically designed to be used as a template.

Has the joins set to left outer.

cal_due_by_asset_for_xxx_days.rpt

Prompts the operator for the number of days from today

and shows assets with calibration due and overdue.

cal_due_by_asset_through_date.rpt

Prompts the operator for the date and shows assets

with calibration due and overdue.

cal_due_by_dept_by_status_for_xxx_days.rpt

Prompts the operator for the number of days from today

and groups the calibration due data by department

and by status.

cal_due_by_location_by_status_thru_date.rpt

Prompts the operator for a date and groups the

calibration due data by status and location.

cal_due_by_tech_by_status_for_xxx_days.rpt

Prompts the operator for number of days from today

and groups the calibration due data by technician

and status.

cal_due_by_tech_by_status_thru_date.rpt

Prompts the operator for a date and groups the

calibration due data by status and technician.

cal_procedures_and_revs_for_eqpt.rpt

Lists all calibration procedures listed in field

C2320 and shows the revisions.

cal_summary_for_asset_number.rpt

Prompts the operator for an asset number and gives

the summary data for the asset.

cal_summary_for_work_order.rpt

Prompts the operator for a work order number and

gives the summary data for the asset.

field_customization.rpt

Shows the current customization of the database fields.

field_properties.rpt

Shows the current customization of the properties

for the database fields.

license.rpt

Lists all of the licenses assigned to the database

and shows the version and serial numbers.

master_inventory_for_asset_number.rpt

Provides all inventory information for a specified

asset number.

rt_certificate_of_cal_or_failed_cal.rpt

Generates a calibration certificate. Usually invoked

from the MET/CAL Runtime application after a calibration

has completed. Covers both PASS and FAIL calibrations.

rt_report_of_cal_ver_7.rpt

This is the basic report used to show full results

generated by the MET/CAL Runtime application.

This report uses result data from the new V7.00

Results Table. It is not a legacy report, so the

"rslt_db.frm" file has no effect on the information

presented by this report.

rt_report_of_cal_ver_7_color_coded.rpt

Similar to "report_of_calibration_ver_7.rpt", but

shows failures with a red background and marginal

passes with a yellow background. (The color coding

is similar to MET/CAL's Test Results window.)

rt_report_of_cal_ver_7_failures.rpt

Similar to "report_of_calibration_ver_7.rpt", but

shows only tests which failed.

rt_report_of_cal_with_exp_uncert.rpt

Similar to "report_of_calibration_ver_7.rpt" but

shows expanded measurement uncertainty rather than

test uncertainty ratio.

screen_customizing.rpt

This report shows the current customization of

the screens.

trace.rpt

This report is used with the forward trace and

reverse trace functions of the MET/TRACK.

-------------------------------------------------------------------------------

Section 8: Documentation -----------------------------------------------------

-------------------------------------------------------------------------------

FlexibleStandards.pdf

This document provides an overview of the MET/CAL

implementation of procedure-based flexible standards.

"Flexible standards" is a technique which allows

a procedure to be written in a manner independent

of the particular reference instruments used to

calibrate the unit under test (UUT).

GettingStarted.pdf

This is the MET/CAL Getting Started Guide.

Guardbanding.pdf

Describes MET/CAL support for guardbanding.

ImportTool.pdf

Describes the MET/CAL V7 Import Tool.

QuickReference.pdf

This is the one-page hot keys sheet which shows the

hot keys used by MET/TRACK and the MET/CAL Editor.

ReferenceManual.pdf

This is the MET/CAL V7.2 Reference Manual.

Please use the MET/CAL Editor's on-line help for the

new FSCs not included in the MET/CAL Reference

Manual.

In a few cases the Editor's on-line help files were

updated after the PDF reference manual was produced.

Therefore, in case of conflict, please rely on the

Editor's on-line help files.

ResultsTable.pdf

This document lists the MET/CAL result quantities

and shows the new database Results Table column names.

RHT-HartScientific-1620A.pdf

This document explains how to use the Hart 1620-H,

Hart 1620-S, Fluke 5020A, and Fluke 5020A-S

Thermo-Hygrometers with MET/CAL V6.11 and later

(including MET/CAL V7.00, V7.01, V7.10, V7.11,

and V7.20).

RHT-Fluke-5000A.pdf

This document explains how to use the Fluke 5000A

RH/T Precision Humidity and Temperature Data Logger

with MET/CAL V6.11 and later (including MET/CAL V7.00,

V7.01, V7.10, V7.11, and V7.20).

UsersManual.pdf

This is the MET/CAL Users Manual.

-------------------------------------------------------------------------------

Section 9: Accuracy and Help Files -------------------------------------------

-------------------------------------------------------------------------------

V7.20 includes a number of updated and new accuracy files.

All updates included in V7.11 SP1 are included in V7.20.

If you have customized accuracy files on your system please backup

your accuracy files before installing V7.20.

On-line help files for all new FSCs are included in V7.20.

In addition, some help files for FSCs which existed in V7.11 have

been updated.

-------------------------------------------------------------------------------

Section 10: Contacting Fluke -------------------------------------------------

-------------------------------------------------------------------------------

For assistance and questions regarding Fluke Calibration Software

please contact MET/SUPPORT at:

phone: 1 (800) 825-7411

email: MetSupport@fluke.com

European customers may contact the MET/SUPPORT group in

Europe via email at:

MetSupport@fluke.nl

-------------------------------------------------------------------------------

Section 11: Bonus CD ---------------------------------------------------------

-------------------------------------------------------------------------------

The Bonus CD is no longer distributed. The CD included:

* application notes

* example reports

* picture files

* user-contributed procedures

* utility programs

Material from the CD may now be found:

* distributed with the updated application

* available for download from the MET/SUPPORT website

-------------------------------------------------------------------------------

Section 12: V7.20 Problem Reports --------------------------------------------

-------------------------------------------------------------------------------

----> Text Overrun in "Confirm Procedure Copy" Window in Editor

Report Number: 38713

Application: Editor

In MET/CAL Editor V7.11 SP1, and previous versions, there's

a problem in some cases with text overrun in the "Confirm

Procedure Copy" window displayed by the MET/CAL Editor as

part of a procedure copy operation.

When the name of a procedure to be copied is sufficiently

long, the name wraps around when displayed in the "Confirm

Procedure Copy" window. This shifts subsequent lines down,

causing the last line, showing the destination for the copy

operation, to be unreadable.

Corrected in V7.20.

----> "Correction Amount" Incorrectly Stored as "Error" in DB

Results Table

Report Number: 38624

Application: MET/CAL

In MET/CAL versions V7.00 through V7.11 SP1, when corrections

are enabled (ASK+ C) and corrections are performed, the

calculated Correction Amount is incorrectly stored in the

Error field of the database Result Table. This overwrites

the actual Error value.

The Error result quantity is unaffected when corrections

are not enabled.

The Relative Error and Deviation are unaffected.

The Error is equal to Measurement - Expected Value.

Measurement and Expected Value are valid, so it's possible

to overcome this defect by directly calculating the Error

when corrections are enabled.

V7.20 corrects this problem.

----> Add Reference Accuracy Units to TUR Report-Generated Lines

Report Number: 38399

Application: MET/CAL

In V7.11 SP1, and earlier versions, the T.U.R. report lines

generated by the MET/CAL Editor do not show units associated

with the reference accuracy and UUT test tolerance.

For example, this procedure statement:

5700 13.01D 0.05U 1MH W 2W

generates this warning:

Test Tol 0.0057397, Sys Tol 0.0039029, TUR 1.4706

(< 4.00).

In V7.20 the units are shown with the reference accuracy

("Sys Tol").

For example, these procedure statements:

9640 +Level = 13.01 dBm; Freq = 1 MHz; OutpImp = 50 Ohm

MEMCX 13.01dBm 0.05U

generate this report line:

Test Tol 0.00022892, Sys Tol 0.00023157 W, TUR 0.9886

(< 4.00).

----> Changes to the Agilent 33220A Accuracy File

Report Number: 38002

Application: MET/CAL

In the frequency section the gain error value ("tol")

has been changed from 1.044e-4 % to 2.0e-3 %.

Also, a number of comments in the file have been updated.

The updated file ("33220.acc") is included with the V7.20

distribution.

----> Edit Merge Table Does Not Allow Default Value To Be Changed

Report Number: 36717

Application: MET/TRACK

In V7.11 SP1, and earlier versions, if you login to MET/TRACK

as "MT", select Database/Edit Merge, then select a table,

you cannot edit the default value. The value is grayed out.

V7.20 corrects this problem.

----> Searching on Field 4236 Causes Disconnect

Report Number: 36337

Application: MET/TRACK

In MET/TRACK build #430 initiating a search based on field

4236 ("Date/Time Entered") causes MET/TRACK to loose the

connection to the database and terminate.

Resolved in V7.20. (Any MET/TRACK build later than #430

resolves the problem.)

----> Delay Construction in PIC Statement Causes Compile Problem

Report Number: 36095

Application: MET/CAL

In V7.11 SP1 and prior a problem occurs in the PIC and PICE

FSCs when the procedure writer includes a delay special

construction (for example, "D[1000]") in the procedure

statement.

The underlying problem is that PIC and PICE do not support

the delay construction, but the Editor fails to generate an

error message.

V7.20 resolves the problem. PIC and PICE statements now

generate the standard message:

"Incorrect special construction or message too long."

This problem has existed since Jan 2002, when MET/CAL was

modified to allow certain "special constructions" in PIC

and PICE file name specifications.

In addtion, the PIC and PICE help files have been updated

to provide a more detailed description of the "special

constructions" supported by these FSCs.

----> 53132 FSC Incorrectly Limits Reading Resolution to 4 Digits

Report Number: 35916

Application: MET/CAL

In V7.11 SP1 a problem was introduced in the 53131,

53132, and 53181 FSCs which incorrectly limited the reading

resolution to 4 digits. The problem is not present in V7.11.

The underlying problem is that V7.11 SP1 changed from using

the FUNC command (as in V7.11) to using the CONF command.

An overlooked side-effect of this change was that the FUNC

and CONF commands select different defaults for measurement

resolution when programming an Agilient 53100A series counter.

For these counters, the FUNC command defaults to the maximum

resolution. The CONF command, however, defaults to the

minimum resolution.

V7.20 corrects the problem. The FSCs have been changed back

to use the FUNC command.

----> Errors C-Type Thermocouple Spec in Fluke 525A Accuracy File

Report Number: 35882

Application: MET/CAL Accuracy File

The 1-year accuracy file for the Fluke 525A has been updated

per the currently published specifications. The updated

file is included with V7.20.

----> Guardbanding with Method "MU" Fails When Uncertainty Exceeds

Test Tolerance

Report Number: 35785

Application: MET/CAL

In V7.11 SP1, and prior versions, MET/CAL's guardbanding

calculation calculates incorrect results when the expanded

measurement uncertainty exceeds the tolerance of the test.

Such tests do not arise often in practice because good

metrology is compromised when the reference instrument is less

accurate than the UUT, or when a sequence of measurements has

such large variation that the standard deviation causes the

measurement uncertainty to be abnormally large, and these

are the two conditions which can cause this result.

In V7.20 MET/CAL should be modified so that it detects this

condition and handles it gracefully.

A new VSET/TSET/INI parameter, "gb_overflow", has been

implemented to resolve this issue.

Here's the parameter description from the VSET help file:

GB_OVERFLOW

GB_OVERFLOW configures the handling of a guardbanding

"overflow" condition when the guardbanding method is

"MU".

An overflow condition occurs when the calculated

uncertainty of the measurement exceeds the tolerance

of the test.

Recall that when the method is MU the guardbanded test

limits are determined by tightening the specification

limits by an amount equal to the expanded measurement

uncertainty. Therefore, if the expanded measurement

uncertainty exceeds the test tolerance it is not

possible to tighten the test limits by the required

amount. This is because a test cannot have a test

tolerance less than zero.

There are two situations which, individually or in

combination, may give rise to an overflow condition:

(a) If NMEAS is greater than 1 and the UUT values

vary excessively the standard deviation will

be large. A large standard deviation causes a

large measurement uncertainty.

(b) If the reference is inadequate relative to the UUT,

the reference accuracy may dominate the calculated

measurement uncertainty. In this case the test

is not metrologically sound. I.e., the Test

Uncertainty Ratio is close to 1 (or even less

than 1).

GB_OVERFLOW allows the procedure writer or system

administator to configure how MET/CAL handles an

overflow condition. There are 4 choices for the

GB_OVERFLOW value:

LIMIT

When GB_OVERFLOW is set to LIMIT, an overflow

condition causes MET/CAL to set the guardbanded

test tolerance to zero. This prevents the

test from passing outright, but allows Pass

Indeterminate, Fail Indeterminate, and Fail

as possible test results.

LIMIT_W

LIMIT_W is the same as LIMIT, except that

a run time warning is generated to notify

the operator that a guardbanding overflow

condition has occurred.

DISABLE

When GB_OVERFLOW is set to DISABLE, MET/CAL

handles an overflow condition by turning

guardbanding off for the test.

DISABLE_W

DISABLE_W is the same as DISABLE, except that

a run time warning is generated to notify the

operator that a guardband overflow condition

has occurred.

The default value of GB_OVERFLOW is LIMIT_W.

In addition to being specified in the procedure in

a VSET or TSET statement, GB_OVERFLOW may also be

specified in the MET/CAL initialization file or in

the guardbanding initialization file.

When a guardbanding overflow condition occurs, MET/CAL

annotates the guardbanding method name in the database

Results Table by appending the overflow indicator "*".

In other words, the method name in the Results Table

will be "MU *" instead of "MU". Report writers may

make use of the "*" annotation to flag test results

which are doubtful due to a guardbanding overflow.

Compatibility: GB_OVERFLOW is not supported in

V7.11 SP1 or prior versions. The first released

version of MET/CAL which supports GB_OVERFLOW is V7.20.

----> Data in R3253 Propagate to Other Assets on Browser Form

Report Number: 35474

Application: MET/TRACK

In MET/TRACK V7.11 SP1, and prior versions, data in

Maintenance Table field R3253 ("Comments") for an asset

displayed on the browser form will be displayed for other

assets for which there is no data in R3253. The problem is

present even when those other assets don't have maintenance

records at all . This is only a display problem. The data

in the database are correct.

V7.20 corrects this problem.

----> Error in PORT FSC Help File

Report Number: 35450

Application: Documentation

In V7.11 SP1 and prior there's a typo in the PORT FSC

help file.

Where the help file refers to the "Edit : Continue" menu item,

it says the accelerator key associated with the function

is F7. It should say F6. V7.20 includes an updated PORT

help file which corrects this problem.

----> Keithley 2000 FSC Generates Error During Frequency Measurement

Report Number: 35418

Application: MET/CAL

In V7.11 SP1 the

Keithley 2000 FSC generates the error:

E566: -113, "Undefined header"

when a procedure statement which measures frequency is

executed.

V7.20 corrects this problem.

----> Leaving Cursor in Quick Search Field Causes Inefficient

Performance

Report Number: 34529

Application: MET/TRACK

In V7.11 SP1, and earlier versions, if the cursor is left

in the MET/TRACK quick search dropdown control, and other

operations are performed in MET/TRACK, then the control

refreshes itself each time another operation is performed.

The constant refresh cycle causes excessive delays between

operations.

V7.20 corrects this problem.

----> 6100 Learn Mode Generates Incorrect Value String for %

of Fundamental

Report Number: 33520

Application: MET/CAL

In MET/CAL V7.20 there's an error in the 6100 FSC's learn

mode there's an error when voltage or current harmonic units

are set to "% of Fundamental". In this case Learn Mode (F7)

generates an incorrect string for the associated parameter.

Example:

1. Set L1 mode to harmonic.

2. Set the voltage harmonic units to % of fundamental.

3. Press F7.

Learn Mode generates the procedure line:

VoltageHarmonicUnits = PFun

The MET/CAL compiler cannot compile this line.

The line should be:

VoltageHarmonicUnits = PFund

V7.20 corrects this problem.

----> Error in MEMC/MEMCX Help File

Report Number: 33465

Application: MET/CAL

In V7.11 SP1 and prior there's an error in the MEMC/MEMCX

help file. The text in the help file which shows the examples:

MEMC 1.00meter 1%

MEMC 1.00_meter 1%

MEMC 1.00"meter" 1%

is intended to show how the leading 'm' in "meter" may be

interpretted as a units prefix.

Unfortunately the example is poorly chosen, because the 'r'

at the end of "meter" causes MET/CAL to interpret the field

as a RANGE field. (This aspect of the parsing is a legacy

aspect which dates all the way back to the 7411 product.)

In V7.20 the MEMC/MEMX help file has been modified to use

a better example.

----> 8902 FSC Does Not Allow 8902A Measurements Greater Than or

Equal To 9 GHz

Report Number: 33422

Application: MET/CAL

In MET/CAL V7.11 SP1, and earlier versions, there's a problem

in the 8902 FSC which prevents frequency measurements greater

than or equal to 9 GHz. The problem occurs in Frequency

Offset mode.

For example, the following statements:

M8902 10120.53MH 27.3SP H0 L0

8902 10000MH 0D FA N

cause MET/CAL to generate the error:

E6239 8902A: Unidentified error number 99

This problem is corrected in V7.20.

----> Problem After Canceling Print Memo Field Operation

Report Number: 33403

Application: MET/TRACK

In V7.11 SP1, and earlier versions, an internal error is

generated if the user searches for an asset, chooses a memo

field (e.g., I4260), and uses the right mouse button to select

"print memo field", then cancels the operation.

The print job is visible in the print spooler, but cannot

be removed without rebooting the PC.

V7.20 corrects this problem.

----> 6100 FSC Help File Does Not Document Effect of Statement on MEM1

Report Number: 33076

Application: MET/CAL

In V7.11 SP1 and prior the 6100 FSC help file does not state

that execution of a 6100 statement causes the value of the

parameter designated as the Nominal value to be copied to

memory register MEM1.

In V7.20 the 6100 help file has been updated to correct

the oversight.

----> Inconsistent Reset of I4225 Makes Report Writing Difficult

Report Number: 32650

Application: MET/TRACK

In V7.11 SP1, and prior versions, if you set up the software

to clear I4225 when new cal record and new maintenance records

are created, one will set I4225 to NULL and the other will

set it to a blank. This makes report writing difficult.

V7.20 includes an updated patch file, "patch3.sql", which

corrects this inconsistency in the handling of I4225.

Execute "dbupdate.exe" to apply the patch.

----> Numeric Values with Comma as Decimal Symbol Not Shown Correctly

in Maintenance Browser Form When Dutch Regional Settings Are Used

Report Number: 32185

Application: MET/TRACK

In MET/TRACK V7.11 SP1, and earlier versions, when the PC

is configured for Dutch regional settings, the Maintenance

Browser form does not correctly display currency values

(in euros). Values which are entered using a comma as a

decimal symbol are not displayed properly.

V7.20 corrects this problem.

----> Trailing Backslash in Value for "user_prog_dir" Causes Error

Report Number: 31921

Application: MET/CAL

In MET/CAL V7.11 SP1 and prior MET/CAL Runtime and Editor

applications not allow a trailing backslash to be included in

the value of the "user_prog_dir" initialization file parameter.

For example:

user_prog_dir = c:\metcal\

causes the MET/CAL Runtime application to generate the error:

E552: Specified directory for user programs not found:

"c:\metcal\".

V7.20 resolves this problem.

----> 6100 "HC" Not Removed from Procedure Header Configuration Line

Report Number: 31906

Application: MET/CAL Editor

In some versions of MET/CAL between V7.11 and V7.11 SP1,

when modifying a 6100-based procedure in such a way as to

remove the requirement for the 80A option, the procedure

compiler failed to remove the "HC" annotation from the Fluke

6100A configuration line in the procedure header.

V7.20 corrects this error.

----> 6100 Range Value Changed from 21 A to 20 A

Report Number: 31905

Application: MET/CAL

In MET/CAL V7.11 SP1 there's a problem in the 6100 FSC

with statements that specify a current value of 21 A.

The statements cannot be compiled by the MET/CAL Editor.

This problem is not present in V7.11.

V7.20 corrects the problem.

----> 6100 FSC Does Not Allow Setting L1VRange to 1008V Range

Report Number: 31836

Application: MET/CAL

In MET/CAL V7.11 and/or V7.11 SP1 errors are generated by

the following 6100 FSC procedure line:

6100 L1VRange = 1008 V

The errors are:

E2378: FSC 6100: Parameter "L1VRange", value 1008.

Value must be 16.0 V, 33.0 V,

78.0 V, 168.0 V, or 336.0 V.

E7529: FSC 6100: For parameter "L1VRange", the value

"1008V" is not valid.

V7.20 resolves this problem.

----> Adding New Record Causes an Error When C2320 Validation List

is Empty

Report Number: 31768

Application: MET/TRACK

In V7.11 SP1, and prior versions, when a user adds field

C2320 with an empty required validation, pick list and/or

linked validation to a form, then attempts to add a new

record via that form, an error is generated.

V7.20 corrects this problem.

----> Customer List Window Does Not Remember Size

Report Number: 31749

Application: MET/TRACK

In MET/TRACK V7.11 SP1, and prior versions, MET/TRACK does not

remember the user-specified size of the Customer List window.

In V7.20 MET/TRACK remembers the size of the Customer List

window.

----> MATH Function "CTOI" Crashes When Input String is NULL

Report Number: 31746

Application: MET/CAL

In MET/CAL V7.20 and prior there's a problem in the MATH FSC

"CTOI" function.

The function crashes when the value of the input argument

is a NULL pointer.

The underlying cause of this problem, when it occurs, is a

procedure-level programming error. The immediate solution,

therefore, is to correct the MET/CAL procedure.

However, MET/CAL should detect the error and prevent the

application from crashing.

V7.20 resolves this problem with "CTOI" by handling a NULL

string in the same manner as an empty string, resulting in a

"CTOI" return value of zero.

----> Fluke 5500A Times Out Waiting for OPC During TC Simulation

Report Number: 31692

Application: MET/CAL

In MET/CAL V7.11 SP1, and prior versions, the 5500A wait for

Operation Complete (OPC) loop has been found to timeout when

using TC simulation with certain UUTs.

In V7.11 SP2 the timeout in the wait for OPC loop has been

increased to resolve the problem.

----> Adding Location Records Incorrectly Resets Field I4230

Report Number: 31675

Application: MET/TRACK

In MET/TRACK V7.11 SP1, and prior versions, when adding a

location record for an asset that has a "use-based" interval

type, the value of I4230 (number of uses) is reset based on

the sum of L2808 (use count - location) and does not take

into account any "uses" from calibration.

If a standard has been used 3 times to calibrate UUTs, and

you add a new location record, then the current value of

I4230 is reset based on the total number of uses in location

since the standard's last calibration.

This problem has been corrected in V7.20.

----> Default Copy from 4230 to 2332 is Missing

Report Number: 31625

Application: MET/TRACK

Version 6 of MET/TRACK would, by default, copy the value

of field 4230 (the Use Count) to field 2332 (Uuse) when a

calibration record was added.

The manual for version 7 does not mention this behavior,

but the on-line help documentation does.

By default, MET/TRACK should copy this value forward.

A workaround is to manually configure 2332 with a source

copy of 4230. This replicates the behavior of verion 6.

Corrected in V7.20.

----> Use Count Not Reset After PASS Calibration of Asset with

Use-Based Interval

Report Number: 31624

Application: MET/TRACK

In V7.11 SP1, and prior versions, for use-based intervals,

when the instrument is calibrated, and the result of the

calibration is PASS, the use count (I4230) is not reset.

As a workaround, the operator may manually reset I4230 when

the instrument successfully passes verification.

V7.20 corrects this problem.

----> Invalid Interval Copy Forward with Use-Based Recall Intervals

Report Number: 31623

Application: MET/TRACK

In V7.11 SP1, and prior versions, if you set an instrument

to have a recall interval based on the use count, then,

when adding a calibration record for this instrument, the

interval (4229) is copied forward to the new calibration

record, generating the error:

"Interval type 'U' must have interval of zero."

In fact, MET/TRACK should set the interval in the new

calibration record to zer when the interval type is 'U'.

The value of field 4229 should be ignored.

A workaround is to acknowledge the error, reset the interval

to zero, and continue creating the new record.

This problem has been resolved in V7.20.

----> 8508 FSC Frequency Measurement Below 200 Hz with MOD3 Equal to

"D4" Generates Accuracy Lookup Error

Report Number: 31587

Application: MET/CAL

In MET/CAL V7.11 SP1, and prior versions, an 8508 FSC statement

with a nominal frequency less than 200 Hz and MOD3 equal to

"D4" (Fast Gate) causes the following error:

E132: FSC 8508: Required accuracy data not found in

Accuracy File.

In fact, there is no accuracy. The 8508A is not specified

below 200 Hz in Fast Gate mode. A compile time rule is

missing. The Editor should not allow an 8508 statement with

a nominal value less than 200 Hz with MOD3 set to "D4" or

"FE" to compile.

V7.11 SP2 corrects this problem by adding the missing compile

time error checks.

----> Post Test Adjustment Block Processing Fails for MEMC & MEMCX Evaluations

Report Number: 31586

Application: MET/CAL

MET/CAL's implementation of adjustment blocks does not

function correctly in V7.11 for MEMC and MEMCX statements.

The problem is also present in V7.11 SP1. (The problem is

not present in V7.01. V7.10 was not tested.)

The problem is that in some cases the Post Test "Adjust"

button is not enabled when it should be, and in some cases

the statements in an adjustment block are not executed when

they should be.

V7.20 resolves this problem.

----> Certain Inventory Table Numeric Field Values Cannot Be Retrieved

By MET/CAL Runtime

Report Number: 31539

Application: MET/CAL Runtime

When a numeric Inventory Table field, such as 4254, is

included in a MET/CAL Runtime prompt, or queried using the MATH

FSC "INV" function, the value returned to MET/CAL is empty,

even though the field has a non-empty value.

For example, if the following line is included in the Run

Time pre-prompt file (default name "promptdb.txt"):

Inventory 4254 :RD: I4254$ 4254

MET/CAL Runtime pre-prompt dialog will show a blank (empty)

value for field 4254, even when I4254 has a non-empty value

in the Inventory Table (for the specified asset).

V7.11 SP2 includes an updated library ("metgendb.dll") which

resolves this problem. The fields affected are I4219, I4254,

I4255, I4256 and I4257.

----> Fluke 45 May Time Out When Using RS-232 Inteface

Report Number: 31450

Application: MET/CAL

In MET/CAL V7.11 SP1, and earlier versions, the 5 second

RS-232 timeout for the Fluke 45 driver is too short for

some operations.

In V7.11 SP2 the serial interface timeout in the "45" FSC

has been increased.

----> "45" FSC Generates Accuracy Lookup Error with ACV and Frequency

Less than 20 Hz.

Report Number: 31447

Application: MET/CAL

In MET/CAL V7.11 SP1, and earlier versions, the following

procedure statements:

45 1V 10H N

45 1V 19.99H N

generate the following error:

E132: FSC 45: Required accuracy data not found in

Accuracy file.

Although the Fluke 45 is not spec'd below 20 Hz, a warning

message should be generated, not an error message.

V7.11 SP2 includes an update for the Fluke 45 accuracy file

to correct this problem.

----> MET/TRACK Task Permissions Don't Apply to Level 5 Users

Report Number: 31429

Application: MET/TRACK

In V7.11 SP1, and prior versions, level 5 users can edit

validation and merge files even if task permissions for this

operations are unchecked. All other task permission check

boxes work as designed.

V7.20 resolves this problem.

----> "6100" FSC Does Not Allow Use of 5500A/COIL

Report Number: 31428

Application: MET/CAL

In MET/CAL V7.11 SP1, and earlier versions, mutually

exclusive error checks prevent the use of the 6100 FSC with

the 5500A/COIL.

This statement:

1.003 6100 L1IRange = 20A L1ICoil = 5500A/COIL

1.003 6100 L1IBandwidth = 1.5kHz

1.003 6100 +L1IAC = 10A Freq = 60Hz

generates this error message:

E7702: FSC 6100: For L1 I, with coil, not 80A range,

bandwidth must be 3.0 kHz.

However, this statement:

1.003 6100 L1IRange = 20A L1ICoil = 5500A/COIL

1.003 6100 L1IBandwidth = 3.0kHz

1.003 6100 +L1IAC = 10A Freq = 60Hz

generates this error message:

E7596: FSC 6100: Phase 0: If range upper limit <=

20 A, bandwidth must be 1.5 kHz or 6 kHz.

V7.11 SP2 resolves this problem by removing the error check

which caused error E7702 to be generated.

----> 5700 & 5720 FSC 2.2 A AC Range Lower Frequency Limit Incorrect

Report Number: 31419

Application: MET/CAL

In MET/CAL V7.11 SP1, and earlier versions, the 2.2 A AC

current lower frequency limit for the 5700 and 5720 FSCs

should be 10 Hz, not 20 Hz. Even though the 5700A and 5720A

are not spec'd below 20 Hz, the instrument is able to source

a signal down to and including 10 Hz.

V7.11 SP2 resolves this problem. Note, however, that

accuracy file warnings are generated below 20 Hz, because

the instruments are not spec'd in that region.

----> 6100 FSC L2IRange, L3IRange, or NIRange = 80A Generates

Incorrect Procedure Header

Report Number: 31311

Application: MET/CAL

In MET/CAL V7.11 SP1, and earlier versions, when a 6100

statement contains any of the following parameters and values,

the High Current (HC) attribute is incorrectly associated

with the 6100A:

L2IRange = 80A

L3IRange = 80A

NIRange = 80A

Inclusion of the above parameters and values causes the

following procedure header entries:

CONFIGURATION: Fluke 6100A (HC)

CONFIGURATION: Fluke 6100A [L2]

CONFIGURATION: Fluke 6100A [L3]

CONFIGURATION: Fluke 6100A [N]

This is incorrect. The High Current (HC) attribute should

be associated with the 6101A, not the 6100A. The correct

procedure header entries are:

CONFIGURATION: Fluke 6100A

CONFIGURATION: Fluke 6100A [L2] (HC)

CONFIGURATION: Fluke 6100A [L3] (HC)

CONFIGURATION: Fluke 6100A [N] (HC)

V7.11 SP2 updates the 6100 FSC to resolve this problem.

----> Asynchronous Queries May Cause Intermittent MET/TRACK Disconnects

Report Number: 31214

Application: MET/TRACK

In MET/TRACK V7.11 SP1 (Build #423), in some cases asynchronous

database queries may cause disconnection from the database.

For example, it is sometimes possible to trigger a disconnect

from the database by selecting the "values" dropdown list

in the toolbar search.

The disconnection problems appear to be specific to certain

databases. It has not been possibly to reliably duplicate

the reported disconnection problems.

In V7.11 SP2 (Build #425) a new command-line option, "-sync",

has been added to cause MET/TRACK to use synchronous queries,

rather than asynchronous queries.

Note that using the "-sync" command-line option may reduce

overall MET/TRACK performance.

----> "Sort by" List in Search Window Lists Entry Fields Instead of

Browse Fields

Report Number: 31088

Application: MET/TRACK

In MET/TRACK V7.11 SP1, and prior versions, the "Sort by:"

dropdown list in MET/TRACK's "Search Engine..." window shows

fields based on the inventory entry form rather than the

inventory browse form.

This means that if the browse form is set up to show fields

not included in the entry form, or use field titles different

from the entry form field titles, it's not possible to order

the results of a search based on the browse form fields.

V7.20 corrects this problem.

----> Core and Browse Screens Not Synchronizing

Report Number: 30910

Application: MET/TRACK

In V7.11 SP1, and earlier versions, a problem exists where

in some cases the core and browse screens for a maintenance

record are unsynchronized.

To duplicate:

(1) Do not enable the "Location" screen.

(2) Browse to a maintenance record. Then, using the

quick browse (binocular icon), go to another asset,

but leave the maintenance tab with the focus.

(3) The core screen will show the new asset number,

but the maintenance tab will show the record

from the previous asset.

(4) Note that it doesn't refresh.

(5) Enabling the location tab will give you the

correct maintenance records for the asset number

showing on the core side of the screen.

This problem has been fixed in MET/TRACK V7.20.

----> Correction to Chinese Field Titles

Report Number: 29925

Application: MET/TRACK

In V7.11 there's an error in the Chinese translation of the

title of field C2334. V7.20 corrects the error.

----> Test Limits Incorrect for Some MEMC Tests with Asymmetrical

Tolerances

Report Number: 29840

Application: MET/CAL

In V7.11 SP1, and prior versions, in certain cases involving

MEMC evaluations MET/CAL calculates the lower and upper test

limits, as written to the database Results Table, incorrectly.

The problem arises when all of the following are true:

(1) The test tolerance is asymmetrical.

(2) The MEMC statement does not specify a literal

numeric value in the NOMINAL field.

(3) The UUT Indicated value is the non-varying

quantity in the test.

V7.20 corrects the problem.

----> Print Screen Button Disabled in Instrument Browser Window

Report Number: 29520

Application: MET/TRACK

In V7.11 SP1, and prior versions, the print button in the

MET/TRACK instrument browser window is sometimes disabled

when it should be enabled.

V7.20 corrects this problem.

----> Misplaced Prompt to Set UUT to Standby in 531XX FSCs When NMEAS > 1

Report Number: 28854

Application: MET/CAL

In MET/CAL V7.11 SP1 and prior the FSCs for the Agilent/HP

53100 series counters fail to prompt the operator to turn

off the UUT when measurement uncertainty is enabled and the

last measurement of a test has been completed.

The problem is that the prompt to set the UUT to standby

occurs after the first measurement, rather than after the

last measurement of the test.

V7.20 corrects the problem.

----> Sybase Upgrade May Fail on WinXP

Report Number: 28604

Application: MET/BASE

In V7.11, in some cases, when using WinXP, part of the Sybase

database upgrade process may fail when upgrading MET/BASE.

DBISQL fails during the reload process when altering

tables during the reload phase of the database upgrade.

This typically occurs during the creation of <user>.trace

or <user>.reports. Less frequently, it occurs when adding

foreign keys to very large tables.

The problem happens only when moving from a database which is

SQLA ver 5.5 or earlier to version 8.03. It does not occur

when moving to 8.02 which was the case for MetBase v7.01

and earlier. MET/SUPPORT has been successful in moving from

SQLA v5.5 to v8.02 and then to v803 without error.

The failure does not appear to occur on WinNT4 or Win2K.

On failure an ASSERTION FAILURE error is displayed in the SQLA

events window.

MET/BASE V7.20 resolves this problem.

----> MET/TRACK Edit Controls with Maximum-Length Values Do Not

Allow Modification by "Type-Over"

Report Number: 20781

Application: MET/TRACK

In V7.11 SP1, and prior versions, various forms displayed

by MET/TRACK do not allow a field value to be modified by

"type-over" when the existing value in the field is a

maximum-length value.

This problem has been noticed in connection with field C2307

(C-Tech), but can arise with many other fields as well.

To exhibit the problem go to the Edit Calibration window, and

enter the value "abcdefghijklmnopqrst" into the C-Tech field.

(This example assumes you have C-Tech on the form, and that

the maximum is set to 20 characters).

Now double-click on the C-Tech value to highlight the text.

At this point if you type a letter (e.g., "x") it does

not replace the highlighted text with an "x". You have to

first delete the highlighted text (by pressing "Delete"),

then enter the new text.

Note that had you typed 19 characters (one less than the

maximum), you could have highlighted all 19, then typed "x"

and replaced them with an "x".

V7.20 corrects this problem.

-------------------------------------------------------------------------------

Section 13: V7.11 SP1 Problem Reports ----------------------------------------

-------------------------------------------------------------------------------

----> MET/TRACK Import Fails When Import Data File is Tab-Delimited

Report Number: 31143

Application: MET/TRACK

In V7.11, when using the built-in import function of

MET/TRACK, an error occurs when using the command line

directive to specify that the import file is tab-delimited.

The command line directive is "-sepa".

A work-around for this problem exists. In the MET/CAL

initialization file ("metcal.ini") change the line:

separator = Delimiter

to

separator = <TAB>

V7.11 SP1 corrects the problem by supplying an updated

import executable ("imp.exe"). This makes the work-around

unnecessary.

----> Modifying the Data Length of a Linked Validation Field Causes

an Error

Report Number: 31081

Application: MET/TRACK

In MET/TRACK V7.11 changing the length of linked validation

field causes an error if the linked table has null data fields.

----> Operation Complete (OPC) Timeout Not Set Properly for 53100

Series Counters

Report Number: 31053

Application: MET/CAL

In MET/CAL V7.11 the timeout value used for the wait for

measurement complete (using OPC) loop is not properly

calculated for the 53131A, 53132A, and 53181A counters.

This causes a "Please wait" dialog to be displayed reguardless

of the period of the input signal or the gate time setting.

It also means that the timeout is always exactly 100 seconds.

For short duration measurements the timeout is therefore too

long, and it's not possible to complete measurements which

take longer than 100 seconds.

V7.11 SP1 corrects this problem.

----> Printer Button Disabled in MET/TRACK Data Browser

Report Number: 30990

Application: MET/TRACK

In MET/TRACK V7.11 a problem occurs when navigating

from a record without any information to a record which

has information. The problem is that the "Printer" button

remains disabled. This problem affects Inventory, Calibration,

Location, Maintenance, and Customer records.

This problem is resolved in V7.11 SP1.

----> Problems Configuring Layout for Printing in Data Browser

Report Number: 30989

Application: MET/TRACK

In MET/TRACK V7.11 it is not possible to use the data

browser to configure the page orientation to landscape mode

for printing. Printing is always done in normal mode.

V7.11 SP1 corrects this problem. It is now possible to

print in landscape mode.

----> Reports Using User-Defined Stored Procedure Parameters Do Not Run

Report Number: 30898

Application: Reports (MET/TRACK and MET/CAL)

In the V7.11 release a problem occurs when attempting to

run a Crystal Reports report which makes use of one or more

user-defined stored procedure parameters.

V7.11 SP1 includes an updated version of the library

"genrpt.dll" to resolve this problem. (Any version of

"genrpt.dll" dated Sep 30 2005 or later is sufficient.)

----> Segregate Members Incorrectly Allowed to Modify Records in

STD Segregate

Report Number: 30882

Application: MET/TRACK

In MET/TRACK V7.11 a problem exists where members of a

segregate are incorrectly allowed to insert, modify, and

delete records for all assets in the STD segregate.

Segregate members should not have permission to perform

these operations on the STD segregate.

Corrected in V7.11 SP1.

----> Required Guardbanding Initialization File Section Header

Not Documented

Report Number: 30803

Application: Documentation

In V7.11 the guardbanding manual does not describe the

required section header in a guardbanding initialization file.

The required section header is:

[ MET/CAL Guardbanding Initialization ]

In V7.11 SP1 the guardbanding manual ("Guardbanding.pdf") has

been updated to state the required guardbanding initialization

file section header.

A detailed example of how to set up a system using a

guardbanding initialization file has also been added.

----> Error in MET/TRACK "Combine Cal" Function

Report Number: 30736

Application: MET/TRACK

In MET/TRACK V7.11 there are two problems with the Combine

Cal function.

First, if a string written to any column in the

Results Table contains a single quote character,

Combine Cal fails.

Second, if C2501 in the legacy results table (Cal Results)

is NULL, Combine Cal fails.

V7.11 SP1 corrects both problems.

----> Error in RDS Example in Guardbanding Manual

Report Number: 30602

Application: Guardbanding Documentation

In V7.11 there's an error in the worked example at the

end of the guardbanding manual ("Guardbanding.pdf").

The second number under the first square root sign in the

example is 0.00004883721, but it should be 0.000034883721.

(Subsequent steps in the example are correct.)

V7.11 SP1 includes an update to "Guardbanding.pdf" which

correct this mistake.

----> 5700 and 5720 FSCs Do Not Check for Wideband Option Until

Hardware is Required

Report Number: 30576

Application: MET/CAL

In MET/CAL V7.11, and all prior versions, if a 5700 or 5720

procedure statement specifies wideband (MOD3 = "W"), and

a 5700A-03 is configured, MET/CAL does not verify that the

required wideband hardware is present until the statement

is executed. This means that a procedure may be minutes or

hours into execution before the problem is detected.

On the other hand, if a 5700 or 5720 procedure statement

specifies a 5725A (MOD3 = "B1") and the 5725A is configured,

MET/CAL checks the hardware prior to execution of the first

statement in the procedure.

V7.11 SP1 includes a 5700/5720 driver with a modified test

function to verify that wideband is present at procedure

startup time.

----> Advanced Global Change Difficult to Use

Report Number: 30572

Application: MET/TRACK

The Advanced Global Change function provided in MET/TRACK

V7.11 is difficult to use, non-intuitive, and often requires

extensive consultation with MET/SUPPORT personnel in order

to be successfully used.

Since it is usually much simpler to use ISQL, MET/TRACK V7.11

SP1 disables the Advanced Global Change feature, unless the

user explicitly enables it by starting MET/TRACK with the

"advsql" command line argument.

----> MET/TRACK Internal Import Fails to Parse Input Data Correctly

Report Number: 30456

Application: MET/TRACK

In V7.11 MET/TRACK was changed so that the Internal Import

function made use of the same underlying software as the

standalone External Import application. Unfortunately, a

problem was introduced when the redesign was implemented.

Therefore, in the V7.11 release, only the External Import

tool can be used to import data.

The V7.11 problem with the Internal Import function was

not present in the V7.10 release of MET/TRACK. However,

there were other problems with V7.10's Internal Import,

which motivated the redesign in V7.11.

The problem has been corrected in V7.11 SP1.

----> Dropdown Arrow in Entry and Edit Forms Hides Portions of

Some Fields

Report Number: 30455

Application: MET/TRACK

In MET/TRACK V7.11, when configuring a "small" field (such

as I4218) to utilize linked validation, the drop-down arrow

displayed during entry/edit partially hides the contents of

the field. The field is not resized to take into account

the space taken by the arrow.

Resolved in V7.11 SP1.

----> KTAG Incorrectly Shown in Browse Form Customer Tab After "+"

Report Number: 30454

Application: MET/TRACK

In MET/TRACK V7.11 there's a problem in the Browse From when

the Customer Tab is selected and the user clicks on the "+".

The column on the right incorrectly shows the KTAG value,

with the label "GETFIELDTITLEFAILURE". This column should

not have been shown.

V7.11 SP1 corrects the problem.

----> MOD1 Voltage Not Converted to Vpp for Accuracy Lookup Using

Frequency "C" with 5335, 6666, 6680, 6681, and 6681 FSCs

Report Number: 30443

Application: MET/CAL

For the 5335, 6666, 6680, 6681, and 6681 FSCs, a MOD1 value

entered as volts ("V") is incorrectly converted to Vpp for the

accuracy file lookup when the MOD3 field is "FC" (Frequency C).

V7.11 SP1 corrects the problem.

(This change is, in practice, of little consequence.

Before the correction MET/CAL displayed an error message

about missing accuracy data. After the correction MET/CAL

now displays a warning indicating that the TUR cannot be

calculated because required accuracy data are unavailable.)

----> Legacy Results Sorting Fails in Certain Cases

Report Number: 30037

Application: MET/CAL

In V7.11 and prior the legacy results sorting algorithm in

MET/CAL fails in certain cases.

The conditions required to cause a failure are:

(1) Call a subprocedure which contains more

result-generating steps than the calling procedure.

(2) Immediately on return from the subprocedure

terminate a step and add a remark (using the

Post Test "Remark" function).

It appears that this flaw in the result sorting logic has

been present in MET/CAL since the initial version of the

application (1988).

This implies that the situation which generates this error does

not occur very often. It isn't unusual to generate more result

data lines in a subprocedure than in the calling procedure.

The explanation is most likely that the Post Test "Remark"

facility is little-used.

This problem is not present in the full results generation

and sorting. Therefore, despite the cascade of legacy

results error message, MET/CAL nevertheless succeeds in

saving a valid result data set (but not legacy results).

V7.11 SP1 corrects this problem. (Any version of the Run

Time equal to or more recent than V7.11h is sufficient to

correct the problem.)

----> V7.11 M856X FSCs Incompatible With Previous Versions

Report Number: 29740

Application: MET/CAL

Changes made to the M8560 FSC in the V7.11 release are

incompatible with previous versions.

Using V7.11 (up to and including V7.11f) to load a procedure

containing M8560 statements and compiled with a version

earlier than V7.11 crashes the V7.11 MET/CAL Editor.

The problem also applies to the M8566, M8568, and M8590 FSCs,

because M8560, M8566, M8568, and M8590 share the same internal

data structure.

V7.11 SP1 resolves this problem. (Any version greater than

or equal to V7.11g resolves this problem.)

Any procedures written and compiled using V7.11 through

V7.11f and containing any of the FSCs: M8560, M8566, M8568,

or M8590 must be reloaded and saved as text USING THE SAME

VERSION of MET/CAL with which they were compiled.

The new version (V7.11g or later) must then be used to load

the text procedures, recompile, and re-save in compiled form.

----> IEEE2/SCPI Query Processing Incorrectly Documented in Help File

Report Number: 29518

Application: MET/CAL Documentation

In V7.11 the sequence of events performed for an IEEE2 or

SCPI FSC query is incorrectly documented in the IEEE2/SCPI

help file. Specifically, "*ESR?" is sent to check for errors

after the contents of the output buffer are read from the

device, not before, as stated in the V7.11 help file.

V7.11 SP1 includes an update help file ("ieee2.hlp") which

corrects this error.

----> 6100 "Learned" MET/CAL Statement Causes "Data Out of Range"

Run Time Error

Report Number: 29496

Application: MET/CAL

In MET/CAL V7.11, and earlier versions which support the

"6100" FSC, a problem arises with certain statements which

program interharmonics.

The problem may appear in "learn mode", but it is also

possible to cause the problem by directly entering a 6100

procedure statement.

Here's an example of a 6100 statement which generates

the error:

1.003 6100 L1VRange = 168 V

1.003 6100 +L1VAC = 120 V

1.003 6100 L1VIharmonicAmplitudeA = 6 V

1.003 6100 L1VIharmonicFrequencyA = 132 Hz

1.003 6100 Frequency = 60 Hz

Executing the statement shown above causes MET/CAL to generate

the errors:

E2075: 6100A: -222,"Data out of range".

E2071: Error sending command to 6100A.

V7.11 SP1 corrects this problem. (Any version equal to or

later than V6.11f corrects the problem.)

----> PIC and PICE Help Files Do Not Explain Rules for Ampersands

in Overlaid Text

Report Number: 29458

Application: MET/CAL Documentation

Beginning with V7.00 MET/CAL used a different system to

display pictures. The reason for this was to be able to

handle formats other than ".bmp" (for example ".jpg").

An undetected side-effect of the change was that when an

ampersand is included in text to be overlaid, rather than

causing a literal '&' to appear on the picture, it causes

the character following the ampersand to be underlined.

For V7.00 and later the proper way to display an amperand

in text overlaid on a picture is two specify two ampersands

("&&") in the text of the procedure statement.

This presents a minor procedure compatibility issue.

In V7.11 SP1 the PIC and PICE FSC on-line help files have

been updated to correctly describe how to handle ampersands

in overlaid text.

----> Extra Character in "Create Merge Table" Caption

Report Number: 29424

Application: MET/TRACK

In MET/TRACK V7.11 there's an extra character in the "Create

Merge Table" caption. The caption is shown as "Create &Merge

Table", but should be just "Create Merge Table".

The problem is corrected in V7.11 SP1.

----> Combine Cal Fails After Full Results Row Deleted

Report Number: 29280

Application: MET/TRACK

In MET/TRACK V7.11, if a full results row is deleted from

a calibration in such a way that the highest row number

does not equal the number of rows, Combine Cal will fail by

attempting to insert a second row in the Results Table with

the same primary key.

V7.11 SP1 corrects this problem.

----> Incorrect 53132A Frequency Measurement Following Period

Measurement

Report Number: 29272

Application: MET/CAL

In MET/CAL V7.11, using the 53132 FSC, if a frequency

measurement immediately follows a period measurement,

the reported reading is incorrect. For example, if you

first perform a 10 ms time measurement, then attempt a 100

Hz frequency measurement, the report System Actual value is

a time value (seconds) but is reported as a frequency value

(mHz).

Investigation indicates that the Agilent documentation is

unclear. There may be a firmware design problem. In any

case, MET/CAL V7.11 SP1 has been changed to use the SCPI

"CONFigure" command, rather than the "FUNCtion" command to

avoid the problem.

----> MATH FSC Function UPREFIX Does Not Support Greek MU as Micro

Symbol

Report Number: 29261

Application: MET/CAL

The MATH FSC function UPREFIX does not accept the Greek MU

(decimal 181) as valid units prefix in the input string

(representing a dimensioned number).

Resolved in V7.11 SP1. (Any version greater than or equal

to V7.11e contains this correction.)

----> MATH FSC Function IS_UNIT Documented Incorrectly

Report Number: 29259

Application: Editor (On-Line Help)

The MATH FSC help file documents the IS_UNIT function

incorrectly.

The function is documented as having one parameter. However,

it actually has two parameters.

The function is designed to determine if the units specifier

in a dimensioned number is valid and matches a specified

units specifier (the 2nd parameter).

Furthermore, the documentation does not make it clear that

IS_UNIT generates a run time error if the dimensioned number

(the 1st argument) is invalid.

V7.11 SP1 includes a corrected MATH FSC help file.

----> Browse Screen Fields Shown Maximum Length on First Search

Report Number: 29255

Application: MET/TRACK

In certain situations MET/TRACK V7.11 shows fields at maximum

length in the Browse Screen. The fields should be shown

using the configured display length.

The problem is not present when the search engine is first

used to find an asset, or when the Edit or Add screen is

opened first, or when the Browse screen is being opened for

the second (or subsequent) time.

V7.11 SP1 corrects the problem.

----> Quick Search Value Field Dropdown not Updated when Tabbed Into

Report Number: 29254

Application: MET/TRACK

In MET/TRACK V7.11 a problem occurs when using the tab

key to go to a value field in the Quick Search Toolbar.

It's not possible to select an entry with the cursor keys,

because the item list is not populated.

V7.11 SP1 corrects the problem.

----> Merge Table Fields with Datatype "Date" Incorrectly Changed

to Datatype "Money"

Report Number: 29248

Application: MET/TRACK

In V7.11 a problem occurs when adding a field of type "Date"

to a Merge Table. The problem is that when a subsequent

attempt to alter the merge table is performed, the datatype

of the field is changed to "Money", making it impossible to

use the field.

V7.11 SP1 corrects this problem.

----> Fields with "Pick List" Ignore Forcecase Setting

Report Number: 29222

Application: MET/TRACK

In MET/TRACK V7.11, with "forcecase" set to disallow lower-case

characters, it is nevertheless possible to enter lower-case

letters into a field when the field has a pick list.

V7.11 SP1 corrects this problem.

----> SSET Example Incorrect in MATH FSC Help File

Report Number: 29233

Application: Editor (On-Line Help)

In V7.11 the SSET example in the MATH FSC help file incorrectly

uses the MSET function instead of SSET.

V7.11 SP1 includes a corrected MATH FSC help file.

----> 6100A Driver Requires Unreleased Firmware Version

Report Number: 29210

Application: MET/CAL Runtime and MET/CAL Editor Test Run

The 6100A driver in MET/CAL V7.10 and V7.11 requires 6100A

firmware version 3.2. This firmware version does not exist.

This problem arose as a result of miscommunication between the

6100A firmware engineers and the MET/CAL development team.

Beta versions of the 6100 FSC which appeared before the

V7.10 release do not have this problem. V7.11 SP1 corrects

the problem (V7.11d or later).

----> Standards List Box Incorrectly Displayed

Report Number: 29184

Application: MET/TRACK

In MET/TRACK V7.11 there's a problem in some cases when

displaying the Standards listbox in the Table Form.

When more standards are selected for display in the MET/TRACK

Standards listbox than are on the Table Form, the display

may become distorted on a line, or unreadable characters

may be displayed on the last visible line.

V7.11 SP1 resolves this problem.

----> 8508 Resistance Statement with MOD3 D4 Generates Invalid

Error Message

Report Number: 29128

Application: Editor

In MET/CAL V7.11, and prior versions which support the

8508 FSC, there's a missing compile time error check in the

8508 FSC. This causes the following statement:

8508 1 1.00000kZ 400P% NO D4 4W

to generate the invalid error message:

E9719: FSC 8508: NOMINAL resistance out of range

(0 Ohm to -9.2559631349318e+061 Ohm).

V7.11 SP1 corrects the error message so that it indicates

that MOD3 must be "D5", "D6", "D7", "D8", "E", "F", "FE",

"ZR", or blank in resistance mode.

(Any version of the Editor built on or after May 19 2005

includes this correction.)

----> On New Installation ODBC Administrator Uses Japanese Fonts

Report Number: 29099

Application: Install

A new installation of the MET/BASE V7.11 client (as opposed

to an upgrade) configures ODBC to use Japanese language fonts,

regardless of the local language.

When a database connection problem occurs and it becomes

necessary to use the ODBC Administrator, text strings shown by

the ODBC Administrator application are unreadable due to the

fact that the application is attempting to use a Japanese font.

This problem affects all Windows platforms and all languages

except Japanese.

The problem can be corrected by installing the latest version

of Microsoft's MDAC.

To download the MDAC go to this site:

http://www.microsoft.com/downloads/

details.aspx?FamilyID=

78cac895-efc2-4f8e-a9e0-3a1afbd5922e&DisplayLang=en

This Microsoft web page allows languages other than English

to be selected as well.

----> Long Procedures, Especially with Extensive Looping, Cause

Test Run Resource Loss

Report Number: 29098

Application: Test Run

In MET/CAL V7.11 there's a Windows resource management

problem in the Editor Test Run S-Reg window.

The problem occurs when running long procedures, especially

with extensive use of WHILE and/or DO loops.

Symptoms vary, depending on operating system and available

memory.

On a WinNT system Windows may lose its ability to correctly

render the display. Because windows are not being drawn

correctly it may become difficult to terminate Test Run.

On a WinXP system the problem may manifest itself as an

error message:

E2223: Internal Error: "GetDC" failed (tr_sreg_show).

Although the problem is related to Test Run's S-Reg window, the

S-Reg window does not have to be open for the problem to occur.

The problem is not present in the V7.11 Run Time application,

and the problem is not present in V7.10.

V7.11 SP1 resolves this problem. (Editor build V7.11c or

later is required.)

----> Pass/Fail Determination Incorrect with Guardbanding &

Non-Base Units

Report Number: 28847

Application: Run Time, Editor

The implementation of guardbanding in MET/CAL V7.10 and V7.11

is incorrect when certain guarbanding methods are selected

and the specified units of the test are not base units.

The affected guardbanding methods are:

(1) mu

(2) ntur

(3) rds

(4) tur

The underlying problem is that MET/CAL applies the calculated

expanded measurement uncertainty, expressed in base units,

to the tolerance deviations, expressed in specified units.

This leads to an invalid determination of the guardbanded

test limits.

The calculation is incorrect whenever the specified units

are not base units. The problem occurs with instrument FSC

evaluation steps, instrument setup + MEMC/MEMCX tests, and,

as in the example below, ACC + MEMC/MEMCX tests.

This problem is corrected in MET/CAL V7.11 SP1. (Run Time

and Editor builds V7.11b or later include this correction.)

----> VSET / TSET NMEAS Sequencing Error

Report Number: 28825

Application: Run Time, Editor

In V7.11 (and earlier versions supporting the TSET FSC)

there's an error which causes invalid results for Fixed

Quantity and Variable Quantity in certain procedures which

implement measurement uncertainty (with NMEAS set to a value

greater than 1), and which use the TSET FSC to change NMEAS

for certain tests to a value other than the value established

previously using the VSET FSC.

UUT Indicated and System Actual are correctly determined,

so this problem does not affect the result of the test.

However, reports which use FIXQ and VARQ will show incorrect

values in the report columns.

Here's an example which illustrates the general form of a

procedure which exhibits this problem:

VSET NMEAS = 5

# Test 1

...

MEMCX ...

# Test 2

TSET NMEAS = 0

...

MEMCX ...

# Test 3

...

MEMCX ...

# Test 4

TSET NMEAS = 0

...

MEMCX ...

In the example above reported values for Fixed Quantity

(FIXQ) and Variable Quantity (VARQ) will be incorrect for

Test 2 and Test 4.

V7.11 SP1 corrects this problem.

----> ELAPSED_TIME_MIN$ Should Not Be Written to C2324

Report Number: 28824

Application: Run Time

The MET/CAL variable ELAPSED_TIME$ is not suitable for

writing to C2324 (via the usual prompt file mechanism).

The reason it isn't suitable is that the ELAPSED_TIME$ value

contains non-numeric characters, but C2324 is a numeric-only

database field.

The proper solution is not to specify ELAPSED_TIME$ as the

source for C2324 in a prompt file. Both ELAPSED_TIME_HR$

and ELAPSED_TIME_MIN$ are numeric-only values.

However, beginning with V7.01s, MET/CAL attempted to protect

the user from making this error by silently substituting a

numeric-only value in place of the ELAPSED_TIME$ value

when non-numeric characters are detected in the value which

to be written to C2324.

Unfortunately, MET/CAL used ELAPSED_TIME_MIN$ as the "fallback"

value. The problem is that other uses of C2324 (in MET/TRACK)

assume that the value has units of hours, not units of minutes.

Therefore, in V7.11 SP1 the MET/CAL Runtime application has

been changed to use ELAPSED_TIME_HR$ as the fallback value,

rather than ELAPSED_TIME_MIN$.

This change has no effect, however, unless the MET/CAL Runtime

application detects non-numeric characters in the value

string to be written to field C2324.

----> 8508 DCV with CON = "DIV" Not Clearly Disallowed in Help File

Report Number: 28788

Application: Editor

The procedure line:

8508 10.0000V 2% DIV

generates the error:

E9700: FSC 8508: If NOMINAL specifies voltage,

CON must be "2W", "4W", "2WR", "SUB", or "SU4".

The Nominal field rules state that the units for voltage

ratio are "V/V" or "pct". Therefore the error message is

valid when the Nominal units are "V". However the 8508 help

file could be clearer in this area. The help file has been

updated to include the following table:

Function Nominal MOD1 CON

--------------------------------------------------

DC Voltage V 2W|4W|2WR

DC Voltage Ratio V/V|pct DIV|DI4*

DC Voltage Difference V SUB|SU4*

DC Voltage Deviation pct DEV|DE4*

AC Voltage V|D H 2W|4W|2WR

AC Voltage Ratio V/V|pct H DIV|DI4*

AC Voltage Difference V H SUB|SU4*

AC Voltage Deviation pct H DEV|DE4*

Frequency H V 2W|4W|2WR

Frequency H A 2W|2WR

Period T V 2W|4W|2WR

Period T A 2W|2WR

Normal Ohms Z 2W|4W|2WR|4WR

Normal Ohms Ratio Z/Z|pct DIV|DI4*

Normal Ohms Difference Z SUB|SU4*

Normal Ohms Deviation pct DEV|DE4*

HV Ohms Z 2W|4W|2WR|4WR

HV Ohms Ratio Z/Z|pct DIV|DI4*

HV Ohms Difference Z SUB|SU4*

HV Ohms Deviation pct DEV|DE4*

True Ohms Z 4W|4WR

True Ohms Ratio Z/Z|pct DI4*

True Ohms Difference Z SU4*

True Ohms Deviation pct DE4*

DC Current A 2W|2WR

AC Current A H 2W|2WR

Temperature degC|degF|K 2W|3W|4W|2WR|

3WR|4WR

* 4-wire front, 2-wire rear

Resolved in V7.11 SP1.

----> Maintenance Records Sorted Incorrectly in MET/TRACK Browse Screen

Report Number: 28785

Application: MET/TRACK

In MET/TRACK V7.11 there's a problem with the sort order

used to display maintenance records in the browse form.

The problem is resolved in V7.11 SP1. The sort order is now:

R3246, R3251, R3230, and R3241.

----> Editor Crashes on WinXP After Clipboard Copy

Report Number: 28666

Application: Editor

In V7.11 five scenarios which terminate the MET/CAL Editor

immediately have been reported. All involve WinXP and require

that a copy to the clipboard has been previously done using

the MET/CAL Editor:

(1) Type Ctrl+F to bring up the Save As common dialog,

then click on the Create New Folder icon.

(2) Type Ctrl+F to bring up the Save As common dialog,

then click on the blank space in the client area

of the dialog.

(3) Use the "Windows" key to invoke the Windows

Explorer. A keyboard with a "Windows" key

is required.

(4) Use the Microsoft Office Toolbar to invoke an

office application. It is necessary to install

the Office Toolbar in order to cause the problem

in this manner.

(5) It has been reported that simply switching to

Excel terminates the MET/CAL Editor.

Although it was not possible to reproduce all of the reported

problems, V7.11 SP1 includes a change to the Editor which

resolves the reported issues which were reproducible, and

probably resolves all of the issues listed above.

----> "Non-working" Days Ignored in German

Report Number: 28664

Application: MET/TRACK

In MET/TRACK V7.11 running on non-English Windows systems

a problem occurs when designating days (by name) as

"non-working" days. For example, if "Saturday" and "Sunday"

are designated as non-working days on a German Windows PC,

the software nevertheless allows calibration due dates to

fall on non-working days.

V7.11 SP1 corrects the problem. The correction required

a change to the stored procedure "mt.mt_calc_due_date".

To apply the correction copy the V7.11 SP1 files "patch1.sql"

and "patch2.sql" into the MET/CAL directory and execute

"dbupdate.exe".

----> Running Report With Multiple Parameters Causes Incorrect Display

Report Number: 28581

Application: MET/TRACK

When using MET/TRACK V7.11 to run a report with two or more

parameters, where one of the parameters is a tag (e.g.,

CTag, MTag, KTag, LTag, or RTag), the report is not correctly

displayed.

This problem is caused by a bug in the library "genrpt.dll",

which processes the report with a tag as a parameter, but

then fails to prompt for the remaining parameters.

The result of this is that the expected data (i.e., the

parameter values) are not available when the report is

generated.

Resolved in V7.11 SP1.

----> Pasting Results into Calibration Results Fails When Using Mouse

Report Number: 22312

Application: MET/TRACK

In V7.11 there's a problem in MET/TRACK when adding data

to Calibration Results (legacy results) using cut and paste

with the mouse interface.

The problem is not present when the keyboard interface (Ctrl+C,

Ctrl+V) is used to perform the cut and paste operation.

V7.11 SP1 resolves this problem.

-------------------------------------------------------------------------------

Section 14: Additional V7.11 Problem Reports ---------------------------------

-------------------------------------------------------------------------------

----> Inventory Table Fields 4231, 4233, 4242, and 4243 Sometimes

Not Fully Displayed

Report Number: 28573

Application: MET/TRACK

Prior to V7.11 the controls used to display Inventory Table

fields 4231, 4233, 4242, and 4243 were sometimes too short

to contain the entire field value.

Resolved in V7.11 (MET/TRACK build #410).

The controls are now being sized using a 'U' as a typical

letter, rather than an 'o'. The problem is therefore now

much less likely to occur.

-------------------------------------------------------------------------------

Section 15: On Time Support Products -----------------------------------------

-------------------------------------------------------------------------------

On Time Support, Inc. provides software products to enhance or

augment the functioning of your MET/CAL and MET/TRACK software.

The following On Time Support programs may be purchased directly

from Fluke. Contact your local Fluke representative for specific

details, options, and prices. Additional information is also provided

on Fluke's WEB site:

http://www.fluke.com

Metrology/Xplorer

Metrology/Xplorer is a web-based query tool used to retrieve

MET/CAL and MET/TRACK data with your browser, over the

internet or your company's intranet.

Barcode Magician

Barcode Magician (BCM) is a product from On Time Support

Inc. which allows you to automate repetitive database

entry tasks such as checking in/out equipment, or changing

equipment status simply and consistently for quantities of

assets using a simple barcode tool or keyboard.

BCM provides a simple, easy to use interface that allows

your calibration technicians and instrument custodians

a way to update your Fluke MET/BASE database quickly and

efficiently while at the same time drastically reducing

data entry errors and substantially increasing productivity.

By using a barcode scanner in conjunction with this software,

you can automate such tasks as:

(1) Checking in/out equipment from a tool crib or

instrument impound area.

(2) Updating in-process status descriptors.

(3) Changing location and association of assets.

(4) Accepting instrumentation for repair work.

(5) Virtually any database function other than

calibration data entry, repair record creation,

or addition of instruments.

There are two versions of Barcode Magician: BCM Basic and

BCM Plus. BCM Plus provides additional functionality beyond

BCM Basic. Contact On Time Support for details.

Barcode Magician Plus

Barcode Magician Plus incorporates the standard features of

Barcode Magician, but adds a few additional features:

(1) New Calibration record with options to include

(2) Standards Used and the New Full Cal Results.

(3) New Maintenance record.

(4) New Location record.

(5) Comment field of your choice into any major table.

The above functions are interactively entered per asset

to allow processing different categories of instruments

in the same transaction. You can process one asset at a

time or a batch. The new record forms (default workstation

only)include all the unsuppressed fields and look and function

very similar to MET/TRACK 7.x. Only required fields need

to be entered. Includes copy forwards, defaults, validated

lists, pick lists, and calculated Due Date. Here are some

more features:

(1) New Instruments can be added while executing an

Action Code. Each Action Code can be configured

to allow/not allow new instruments.

(2) This product allows manually entering CAL Results

into the NEW Results table.

New Batch Calibration Feature (BCM Plus):

We added a new feature for creating calibration

records quickly with two new variables, System

Variable $INSERTCALRECORD$ and Custom Mod Variable

@STDSUSED, that do not use up dialog boxes and

allows entering an unlimited number of standards

used per transaction. The prompt will occur right

after the Dialog box prompts. Great for creating

calibration records without the actual measurement

results. One of the most requested functions has been

batch calibration. Many labs calibrate several of the

same type of instrument at the same time, for example

thread gages. Another example is the calibration

of radiation dosimeters that do not require actual

instrument data, just Pass/Fail. Or, the lab manager

may want to enter calibration records for instruments

that were calibrated by an outside lab. This method

will allow these instruments to be processed in a

fraction of the time that it would normally take.

EMail Notification

EMail Notification is a product from On Time Support which

allows you to schedule the automated delivery of EMail to

your customers or other personnel. Messages may include

notifications of various metrology activities such as

the notification that instruments are due for calibration,

escalation reports, instruments significantly out of tolerance,

instruments due for pickup, or customer feedback surveys. These

messages are automatically sent via a schedule which you

determine using a simple web-based interface.

Change/Log

On Time Support has created a plug-in for the MET/TRACK

database (version 6.x, 7.x) that keeps track of changes to

the Inventory, Calibration, Location, Maintenance, Customer,

and Standards tables. No front end program is required to

configure the Change/Log option. Change/Log tracks database

changes regardless of the application which makes the change.

You can update your database using MET/TRACK Manual Entry,

MET/CAL Runtime, Barcode Magician, ISQL, or any other

application and Change/Log will maintain a full record of

the change history. Change/Log is particularly useful for

customers who may be subject to FDA regulatory requirements.

An archive function is included.

On Time Support has developed additional programs which enhance

the benefits of MET/CAL Plus. The following applications

may be obtained directly from On Time Support. Please see

"http://www.ontimesupport.com" for full information, or contact On

Time Support at:

ON TIME SUPPORT Inc.

Voice - 281.296.6066;

Fax - 281.465.9478;

E-mail - inquiries@ontimesupport.com;

U.S. Mail - 25132 Oakhurst Drive, Suite 185

Spring, Texas 77386-1443

Process/Track

Process/Track allows users to create, download, and upload

procedures and data from Fluke 702, 743B, and 744 documenting

calibrators, using the MET/CAL-Plus database. The software

is fully automated. Process/Track will combine metrology and

process calibrations into one system with complete forward

and reverse traceability.

(1) Data from every calibrator is stored in one database,

providing complete traceability.

(2) Calibration records are created automatically in your

existing Fluke MET/BASE system expediting calibration

record recording and eliminating data entry errors.

(3) Calibration data is immediately accessible in the Fluke

MET/BASE system after upload.

(4) Existing calibration reports and test result certificates

may be used with newly created calibration data.

Remote Pipeline

Remote Pipeline allows calibration lab supervisors/technicians

to operate multiple workstations in remote locations where

a continuous connection to a master server is difficult

or impossible - and operate using the same database at

every site. Remote Pipeline is a conduit that enables each

remote system to share or replicate data with a master,

consolidated Fluke MET/CAL database. Fluke MET/CAL customers

can simultaneously operate many MET/CAL, 5500/CAL, MET/TRACK,

Barcode Magician, and Process/Track workstations to calibrate

instrumentation, perform process calibrations, or inventory

instrument locations.

-------------------------------------------------------------------------------

-------------------------------------------------------------------------------


System Requirements

A number of required frameworks and other software packages must be installed on the client and server computers in order for the system to operate properly. The MET/CAL installation media contains a copy of all the necessary prerequisite software packages. Installation files that you download from the web, however, do not contain all of the prerequisite software packages. In this case, you can use Microsoft Update (http://www.update.microsoft.com) to download and install some of the prerequisites, like the .NET frameworks, and download the other prerequisites from the same website where you downloaded the MET/CAL installation files. Use the manual options in Microsoft Update to specifically select the framework for installation.

The Microsoft .NET Framework is not automatically installed with security patches.

Fluke Calibration Software runs on a variety of platforms:

MET/CAL System Requirements

  • Windows Vista
  • Windows 7 (32 and 64-bit)
  • Windows 8
  • Windows Server 2003
  • Windows Server 2008 (32 and 64-bit)
  • Windows Server 2012

MET/TEAM Server System Requirements

  • Windows 7 64-bit
  • Windows Server 2008 64-bit
  • Windows Server 2008 R2 64-bit
Prior versions of Windows are no longer supported.

MET/TEAM Client (without MET/CAL)

  • No specific OS requirements
  • Must support HTML5 Compliant Web Browser

Hardware Requirements

In addition to the operating system support mentioned above, the minimum recommended PC requirements are:

MET/CAL Client

  • 1 GHz Pentium 4 processor or equivalent
  • 1 GB of RAM
  • 1 GB of available hard drive space

The optional General Purpose Interface Bus (GPIB) connects a PC to a programmable instrument. Before installation, check that the optional GPIB (IEEE 488) Interface is installed. Fluke Calibration Software only supports GPIB controllers from National Instruments.

You can download hardware drivers from the National Instruments website: http://www.ni.com/support/.

If you plan to use or calibrate National Instruments PXI cards, the PXI chassis must be connected to the workstation computer before the computer is powered up. Also, any time you need to insert or remove cards from the PXI chassis, the workstation computer that the PXI chassis is connected to must be powered down first. For more information on this process, refer to the National Instruments website: http://www.ni.com/pxi/.


File Locations

The table below is a cross-reference for file locations between program versions. As you compare the directory structures, you will see that the Version 7.3 and later structures are very different than the previous versions. The table includes the default file locations. Custom installations may differ and file locations can change after installation.

Refer to the MET/TEAM installation guide for details on paths specific to the MET/TEAM Server. The paths listed are the default MET/CAL paths regardless of the asset manager used (MET/TRACK or MET/TEAM).

File Type | MET/BASE, MET/CAL, MET/TRACK 7.20 | MET/BASE 7.2 SP3 | MET/BASE 7.3 & 8.X[1]
Database | C:\metdata | C:\metbase | %ProgramFiles%\Fluke\METBASE
Reports | C:\metcal | C:\metbase\shared\reports | %ProgramFiles%\Fluke\METBASE\shared\reports
Accuracy Files | C:\metcal\acc | C:\metbase\shared\acc | %ProgramFiles%\Fluke\METBASE\shared\acc
FSC Help | C:\metcal\help | C:\metbase\shared\help | %ProgramFiles%\Fluke\help[2]
Procedures | C:\metcal\proc | C:\metbase\shared\proc | %ProgramFiles%\Fluke\METBASE\shared\proc
Pictures | C:\metcal\pic | C:\metbase\shared\pic | %ProgramFiles%\Fluke\METBASE\shared\pic
SQL Files (for dbupdate) | C:\metcal | C:\metbase\shared\utilities | %ProgramFiles%\Fluke\METBASE\shared\dbupdate
User Program | C:\metcal | c:\metcal | %ProgramFiles%\Fluke\METBASE\shared\UserPrograms

MET/BASE, MET/CAL, MET/TRACK 7.20 | MET/CAL 7.2 SP3 | MET/TRACK 7.2 SP3 | MET/CAL 7.3 & 8.X | MET/TRACK 7.3 & 8.X
Executables C:\metcal C:\metcal %ProgramFiles%\ Fluke\METTRACK[3]

%ProgramFiles%\ Fluke\METCAL

%ProgramData%\ Fluke\METCAL[4]

%ProgramFiles%\ Fluke\METTRACK
DLLs | C:\metcal | C:\metcal | %ProgramFiles%\ Fluke\METTRACK | %ProgramFiles%\ Fluke\METCAL | %ProgramFiles%\ Fluke\METTRACK
Manuals | C:\metcal\manuals | C:\metcal\manuals | %ProgramData%\ Fluke\Help | %ProgramData%\ Fluke\Help | %ProgramData%\ Fluke\Help
DATs C:\metcal\station C:\metcal\station %ProgramFiles%\ Fluke\METTRACK

%ProgramFiles%\ Fluke\METCAL\station

%ProgramData%\ Fluke\

%ProgramFiles%\ Fluke\METTRACK
Client Install Files | C:\metcal\client
  1. All items associated with MET/BASE 7.3 are file paths on the MET/BASE server PC. These paths cannot be changed during the installation.
  2. This file is installed with MET/CAL and not MET/BASE.
  3. %ProgramData%
    • Windows XP – c:\Documents and Settings\All Users\Application Data\
    • Windows Vista – c:\ProgramData\
    • Windows 7 – c:\ProgramData\
  4. %ProgramFiles% All OS – c:\Program Files\

In the Start Menu, "Fluke Program Data" is a shortcut to the %ProgramData% folder for Version 7.3 and later.

MET/CAL Version 8.X Specific Files

*.MC Files

*.MC files created from existing compiled procedures are automatically saved in a "MCFiles" sub directory relative to the procedure directory that contained the compiled procedure. The files can be moved and maintained in any user accessible directory.

*.MC files created by a project default to the active project file directory. The files can be moved and maintained in any user accessible directory.

Projects & Solutions

A new installation stores sample procedure projects and solutions in a "Projects" sub directory relative to the default procedure directory. The last directory used to save a project or solution becomes the default directory to store a project or solution. Regardless of the default location, projects and solutions can be created and maintained in any directory.


Legacy Applications

There are many applications that support Fluke Metrology software that directly refer to the metcal.ini file in the Windows directory. These programs should be modified to use the path described in File Locations to properly function with MET/CAL 7.3 and later. In the interim, a copy of the metcal.ini file can be maintained in the Windows directory to allow these programs to work. In this case, the information in the metcal.ini file located in the Windows directory is not updated based on operations within MET/CAL and MET/TEAM. It is up to the user to copy the file from the MET/CAL maintained location to the Windows directory if a relevant edit is made. A shortcut to the %ProgramData% folder is provided in the Fluke Calibration program group.


Upgrading Fluke Calibration Software

Before you do an upgrade, it is recommended that all database files, procedures, accuracy files, correction files and other support files are properly archived.

Not all files and menus created by a previous installation are removed when you upgrade. This allows applications not related to Fluke Calibration Software to function unaltered by the upgrade. Directories specific to MET/CAL Runtime and MET/TEAM are also left intact. These directories can be deleted only after all references to these folders are removed from the Files and Folders MET/CAL Configuration setting. The default file locations are different for version 7.3 and later compared to previous versions.

Not all versions can be upgraded. The table below summarizes the version upgrade requirements and restrictions.

Starting with version 8.2.3, using MET/CAL Runtime with MET/TEAM now requires PDF viewer software to be installed on the workstation to view reports. A PDF viewer is not automatically installed with the MET/CAL Client installer. However, Adobe Reader is included on the MET/TEAM distribution media.

MET/CAL Version | Upgrade
8.1 | Direct upgrade to MET/CAL 8.2.
8.0
7.3 SP1 Build 38
7.3 SP1 Build 37
7.3 SP1 | Direct upgrade to MET/CAL 8.2. After the installation the DB update to 7.3 SP1 patch must be executed. A shortcut to this database update patch update is located in the Fluke Calibration program group.
7.3
7.2 SP3 | Direct upgrade support in 8.2. After installation, the Sybase 8 database service must be manually disabled to prevent it from launching when the server PC is rebooted. See How to Start and Stop the Database Engine on page 35 for more information.
7.2 SP1 | Direct upgrade support in 8.2. No special requirements. Existing folders and files specific to the current version are not automatically removed by the installation. Custom application shortcuts must be removed manually.
7.2
7.1.1 SP1
7.1
7.0.1 | An upgrade to an intermediate version is required. For example, upgrade to 7.1 or 7.2 SP3. Follow the upgrade steps for the selected upgrade version. Then run the 8.2 installation.
7.0
6.1.1A
6.1.1 and less | Upgrade is not supported.


How to Apply a License

The About MET/TEAM dialog contains features to view Logged in Users, process a license registration request, or apply a license registration request. Applying a license involves two steps: 1) Registration details must be entered into MET/TEAM to generate a license request email. 2)The response to the license request email must be applied to MET/TEAM. The registration process is the same regardless of the number and/or type of licenses that are being applied.

Enter Registration Code

Press the Enter Registration Code button to access the Register dialog. Enter the company specific information: Company Name, Mailing Address, Zip, Country, Contact Name, and Phone. Press the Add button at the bottom of the Product Codes frame to add a license. Enter the Product Code(s) appropriate for the desired licenses. The Product Codes are printed on an insert card including with the installation media of MET/TEAM. You may also contact the original purchasing agent or MET/SUPPORT to gain access to product codes that have been lost.

After a Product Code is used, it cannot be re-used on a separate server. If the Server PC changes you must contact Technical Support to reset the product code. Only after the code is reset can the registration process be completed.

After all Product Codes have been entered, press the Generate Request button. The information provided is translated into a License Request and presented in the Register dialog.

Copy the information exactly as is into an email addressed to licenserequest@flukecal.com. Enter MET/TEAM Registration as the email subject. Do not add additional information to the license registration request. Once your license request is processed and assuming the license request information was valid, you will receive an email reply from licenserequest@flukecal.com.

The email to and from licenserequest@flukecal.com can be performed on any PC. The license request and registration details can be pasted into a text document and transferred between systems if necessary.

Enter Registration Code

To complete the registration process the response to the license request email must be applied to MET/TEAM. Launch MET/TEAM and access the MET/TEAM Help, About dialog and select the Enter Registration code button. Paste the license request information from the email into the you were sent via email, into the box and select the Save button. Copy all text (inclusive) between the "---Begin License Data ---" and the "---End License Data---" sections of the email. Do not include other portions of the email or add any additional text. If everything is done correctly, pressing the Save button will close the dialog and update the About dialog with the appropriate license details.


Logging In

When launching any of the Fluke Calibration Software applications, the first step is to log into the application. Refer to the Adding Users and Passwords section for details on changing passwords and creating new users.

The default installation is designed to use "admin" as both the user name and password. A browser screen is used to support the log in process regardless of the application in use (MET/CAL, MET/TEAM or the MET/CAL Editor).


Sample Procedures

The installation process automatically installs several sample procedures. Some of these procedures are referenced in the Quick Start and the Trial Version tutorials and others are included for general operation. Use these samples to better understand how procedures work. The files included in the PKM Section below represent current, fully functional MET/CAL Gold procedures.

MET/CAL 8 Example Projects

These are projects that can be directly opened in the MET/CAL Editor using the File, Open Procedure menu option. By default these files are located in the \proc\projects sub directory of the MET/BASE Shared folder specified during installation. Open the project by using File > Open > Project/Solution menu. Navigate to the project directory and select the project file, all project dependencies will open in the MET/CAL Editor. Test the procedure Debug Mode to verify operation. These files must be Published to support operation in the MET/CAL Runtime.

  • Editor 8 Sample DMM Procedure
  • Editor 8 Sample Procedure
  • Excel OEM Uncertainty Calculator
  • Excel Simulated Frequency Response Graph
  • NI PXI-4130 Verification Procedure
  • WIN32 System Information Functions

MET/CAL Gold Procedures

Several MET/CAL Gold procedures are included in the \proc\Fluke-METCAL-Example-Procedures sub directory of the MET/BASE Shared folder selected during installation. Each procedure is stored as a package in PKM format. A PKM file must be converted to a project and published before it can be used in the MET/CAL Runtime. Use the File, New, Project From Existing *.pkm menu choice to import the PKM into a project. Once the project is created, test run as desired to verify functionality then use the Build > Publish Package menu to create a PXE that can be used by MET/CAL Runtime.

  • fluke_1520_1yr_ver_9100_opt135_dmm_80k-40.pkm
  • fluke_165xb_1yr_ver_rs232_5320_vlc_ResBox.pkm
  • fluke_175_1yr_ver_5500.pkm
  • fluke_177_1yr_ver_5500.pkm
  • fluke_179_1yr_ver_5500.pkm
  • fluke_190-104_1yr_ver_rs232_5500_sc600.pkm
  • fluke_190-104_1yr_ver_rs232_5520_sc600.pkm
  • fluke_2635a_hydra_2635a_hydra_ii_1yr_ver_rs232_5520_dmm.pkm
  • fluke_287_1yr_ver_rs232_5520.pkm
  • fluke_32_cal_5500_5500coil.pkm
  • fluke_39_41b_cal_5520.pkm
  • fluke_45_1yr_ver_rs232_5520.pkm
  • fluke_51_52_53_54_ii_cal_525.pkm
  • fluke_6500_au_nl_uk_1yr_ver_5320_8845.pkm
  • fluke_714_1yr_ver_525.pkm
  • fluke_83_1yr_ver_5520.pkm
  • fluke_87_1yr_ver_5520.pkm
  • fluke_884xa_1yr_ver_ieee_5700.pkm
  • hp_33120a_1yr_ver_ieee_8845a_5790a_psa_lfctr.pkm
  • hp_8495a_8496a_1yr_ver_9640a_n5531s.pkm
  • hp_8648a_1yr_ver_ieee_8902_8903_8560_6680.pkm
  • hp_8648b_2yr_ver_8902_8903_8560_lo_lfctr_hfctr.pkm
  • hp_8648c_2yr_ver_8902_8903_8560_lo_lfctr_hfctr.pkm
  • hp_8648d_2yr_ver_8902_8903_8560_lo_lfctr_hfctr.pkm
  • hp_8657b_8657d_1yr_ver_n5531s_psa_lfctr.pkm
  • quadtech_sentry_10_plus_1yr_ver_5320_5320load_dmm.pkm
  • tegam_esi_db62-111k_2yr_ver_8508.pkm
  • tegam_esi_db62-11k_2yr_ver_8508.pkm
  • tegam_esi_db62-11M_2yr_ver_8508.pkm
  • tegam_esi_db62-1M_2yr_ver_8508.pkm
  • tek_rsa3408b_1yr_ver_ieee_9640a-lpn_lfctr_swpg.pkm
  • tek_tds2004_1yr_ver_ieee_5800_5ch.pkm
  • tek_tds2014_1yr_ver_ieee_5800_5ch.pkm
  • tek_tds2024_1yr_ver_ieee_5800_5ch.pkm
  • tek_tds5000_1yr_ver_ieee_9500.pkm
  • tek_tds5104b_1yr_ver_ieee_9500_4hd.pkm

MET/CAL Legacy Procedures

Legacy procedures are stored in the compiled procedure format. The procedures are installed to the \proc\sample subdirectory of the shared folder selected during installation. Run the procedures from the MET/CAL Runtime. To edit the procedure in the MET/CAL Editor, use the File > Open > Procedure menu option. After the file is modified, it must be Published to be used by the MET/CAL Runtime.

  • Sample
  • Simple Test of 5500A Operation
  • Simple Test of 5700A Operation
  • Simple Test of 5800A Operation
  • Simple Test of 5820A Operation
  • Simple Test of 5520A Operation
  • Simple Test of 5720A Operation


Quick Start: MET/CAL with MET/TEAM

This section is a tutorial that takes users through the steps of the initial MET/TEAM database setup required to work with MET/CAL. Refer to the MET/TEAM documentation for full details on customizing and using MET/TEAM. The help icon ("?") on the top right of any MET/TEAM display will launch the MET/TEAM help specific to the active dialog. After the help is open, you may freely navigate to other topics within the help system.

After the initial setup of MET/TEAM, any number of calibrations can be performed using the defined assets. For a general overview of the calibration process refer to the Overview of the MET/CAL Runtime application and the Sequence of Events topics. This section does not include information necessary to create and edit procedures. Refer to the MET/CAL Editor Basics topic and the MET/CAL Reference Guide for details on editing procedures.

The steps below are a general guideline to the initial setup of MET/TEAM. The subsequent sections provide additional detail for each step.

  1. Launch MET/TEAM
  2. Define a Facility
  3. Define users with rights to run a calibration
  4. Create reference and UUT asset records in the MET/TEAM database
  5. Customize MET/CAL prompts
  6. Configure MET/CAL to use MET/TEAM
  7. Configure the standard in MET/CAL
  8. Run a calibration procedure and generate a report

Launching MET/TEAM

The MET/TEAM server PC has a desktop shortcut available for launching the program. Client PCs do not have a short-cut because there is no installation on client systems. To launch MET/TEAM on the client requires knowledge of the IP details of the MET/TEAM website hosted by the server PC. The path to the website is available by checking with the person that installed MET/TEAM or by checking the properties of the desktop shortcut on the server PC. It is also available by looking in the startup.ini file that is located in the METCAL\Shared folder created during the MET/TEAM server installation. The details of this file are used to configure MET/CAL to use MET/TEAM when MET/CAL is first launched.

In all cases enter the path to the website in the browser to activate the MET/TEAM login screen. Bookmark the page or make a desktop shortcut to simplify future access to MET/TEAM.

Creating a Facility

To simplify the creation of the UUT and Reference assets, a facility will be created first and later associated with the asset records. To create a facility access the MET/TEAM Maintenance, Facilities menu choice. When selected a Find Screen will display. Press the Add button to open the Add Facility dialog. An entry is not required in all fields. Define a Facility Name and a Facility Number. Ensure that the Active checkbox is selected so that the facility is available for selection.

After the Facility is saved, add the address by using the add icon on the right of the address field. Enter address details and press the Save option. An address is not required to run a calibration in MET/CAL.

Use the Add button to create additional facilities.

Users and Login

The default user name and password for MET/TEAM is "admin". After logging into MET/TEAM add users with rights to run and/or configure MET/CAL. MET/TEAM users are created using the Setup, Users menu. Associate the new user with the facility created in the previous step. The User Profiles topic contains additional details related to adding users with MET/CAL specific rights.

Creating a Type

Creating types is not required to run a MET/CAL procedure. Types are defined as a collection of basic characteristics for an asset, typically a specific model and manufacturer. Types are used to simplify the definition of an asset. A type references basic functionality, specifications, and calibration requirements of an asset. The Type definition screen supports the association of multiple default calibration procedures. Both PXE's and compiled procedures can be associated with a type. When default procedures are associated with a type, the Work Order screen lists the associated procedures defined by the type.

Creating Standards and UUTs

The general process of creating a standard and a UUT is the same. Repeat the steps below to create both a standard and a UUT. MET/CAL can be used to calibrate devices only after they are created in the MET/TEAM database.

  • To create an asset access the MET/TEAM Maintenance menu, then select the Assets sub menu. The Find Asset dialog will display. Press the Add button to access the Add Asset dialog.
  • Prior to entering other details press the ellipsis button next to the Type Description field. Select a Type that corresponds to the instrument. The Type selection will automatically update several asset details that are specific to the Type. Types are used by MET/TEAM to store common characteristics for an instrument.

The arrow icon [image] next to many of the fields is called a Quick Link. When the Asset is saved, the quick link can be used to view the editor screen that created selected field. This is a useful way to view additional details associated with a selected value.

  • Enter and select relevant details in the other areas of the Asset tab. Fields that have a red squiggle below them are required fields. These fields must be completed prior to saving the asset. By default, there are no required selections on the Asset Characteristics or History/Notes tabs.
  • Check the Active box to make the asset available for selection. When defining the reference device check the Standard box as well. Note that a Standard can also be used as a UUT.
  • Entry fields that have an ellipsis next them require a selection from a MET/TEAM Find Screen. Find screens are used by MET/TEAM to provide easy access to other user created elements. Press Find to list the available selections based on the search criteria. All possible selections are returned when search details are empty.
  • In the Owner field select the facility that owns the asset.
  • Select the lab that will perform the calibration, in the Service Facility field on the bottom right of the display.
  • Press the Save option on the top of the display.

  • After saving the asset, add a calibration service. MET/CAL requires a Calibration service to be associated with an asset prior to running a calibration. The service defines the calibration interval and due date of an asset. To create a service press the add icon in the Scheduled Services Frame.

  • The Add Asset Service screen will display. Enter the last calibration date in the Service Date field. Then enter the Due Date, Interval and the interval unit of measure (UOM).

  • Define a calibration service by pressing the ellipsis next to the Service Type text box. Press Find to view all available services, then select "Calibration" and press OK. Only 1 calibration service can be associated with an asset. The due date of the service is adjusted when a completed calibration work orders is returned at the end of the calibration process.

  • After the service details are fully populated press the Save option add the service to the asset.
  • At this point the asset is created and ready for use by MET/CAL. Note the ID field for the standard. The ID value will be used to configure the standard in MET/CAL.

Customizing Prompts

MET/CAL supports customizable user prompts before and after a calibration. These are not prompts created by the procedure itself. These are prompts defined by the File and Folders MET/CAL Configuration settings. The post test prompts can change depending on whether or not the test passed or failed. The prompts are a useful way to ensure that the operator updates specific Work Order information at the appropriate time in the calibration process. The rules of the prompt file are detailed in the Prompt File Description topic. Default prompts are installed with MET/CAL.

To disable a prompt, enter "None" in place of the path and file name of the prompt.

Configuring MET/CAL to use MET/TEAM

MET/CAL is self-configured by the startup.ini file installed by the MET/TEAM server. Changing the MET/TEAM Server URL setting will alter the website used when MET/TEAM is the active asset manager.

Launch MET/CAL using the desktop short-cut or the link created in the Fluke Calibration program group. Login using user credentials created at the beginning of this section.

Configuring a Standard

The asset record of the standard created earlier in this section is provided to add traceability information for the Calibrator in the database. Next, the individual workstation must be configured to tell MET/CAL that the calibration instrument at a specific workstation corresponds to a standard in the database.

To understand why this is necessary, consider a network that includes two or more workstations, each with a Fluke 5500A that does calibrations. The procedure that follows would inform MET/CAL which 5500A was connected to which workstation. Additional details are available in the Programming Configurable Standards Topic.

  1. Start the MET/CAL Runtime application and log into the software.

  2. From the Configure view, select Instruments (or press F12). The dialog box displays the currently configured instruments for the workstation, and provides the opportunity to edit the configuration, add a new instrument, delete an instrument, and to specify the I/O location where the instrument is connected to the computer.

  3. Configure the specific calibrator to be used.

    1. If the Current Configuration contains the calibrator attached to the system, use the mouse (or Up or Down arrow key) to select the calibrator and click Edit or double-click the mouse. A System Instrument dialog box for your calibrator opens.

    2. If the Current Configuration window does not contain the calibrator attached to the system, click Add,. A new instrument list displays. Use the mouse (or Up or Down arrow key) to select the calibrator and click OK or double-click the mouse. The System Instrument dialog box will display.

  4. Enter data that corresponds to the selected calibrator. Enter the MET/TEAM Asset ID in the Asset Number field of this dialog.

  5. Close the System Instrument dialog box.

The instrument is now configured in MET/CAL for this workstation. Refer to the IEEE Board(s) topic for details on configuring multiple IEEE-488 interfaces.

Run a Calibration Procedure

MET/CAL can be launched as a stand-alone program or run from a MET/TEAM work order. When the UUT and Reference assets exist in the DB and the MET/CAL station is properly configured, running a test is as simple as selecting a calibration procedure from the MET/CAL Calibrate menu. See See "Sample Exercise: MET/CAL Runtime Basics" for additional details on running a calibration procedure.

Reference the MET/CAL Procedures in MET/TEAM topic for details on how to run MET/CAL Runtime from MET/TEAM.


MET/CAL Procedures in MET/TEAM

Both MET/CAL and MET/TEAM have "procedures". MET/CAL procedures are created by using the MET/CAL Editor. These procedures can be directly executed by MET/CAL. MET/TEAM procedures are created by using the MET/TEAM Maintenance, Procedures menu choice. These procedures are designed to support a variety of calibration scenarios. For example, a MET/TEAM procedure can be based on a PDF, Excel Spreadsheet, Word Document, as well as a MET/CAL procedure. When viewing a Work Order, the ellipsis button next to the Data Sheet field will automatically launch the associated procedure file or MET/TEAM Data Sheet to collect the calibration data. You can also launch the associated procedure file by clicking the "+" button below the grid on the Results tab. Review the MET/TEAM documentation for additional details on launching a MET/TEAM procedure.

MET/CAL automatically creates MET/TEAM procedures associated with MET/CAL procedures each time a MET/CAL calibration is performed. Duplicate procedures are not created. When manually creating a MET/TEAM procedure, there are a few rules required to properly associate it with a MET/CAL procedure.

  • The procedure Category must be "MET/CAL". Any other Category selection is treated like a typical MET/TEAM procedure
  • When using a compiled MET/CAL procedure, the Data Sheet field must be left blank. The Instrument Line of the compiled procedure must be entered into the Procedure Name field.
    • For compiled procedures, there are no other required selections. All other fields are user defined.
    • It is recommended to associate any procedure document with the Procedure File field. Use the MET/TEAM Maintenance, Files menu to upload the procedure document. Then select it by using the ellipsis button next to the Procedure File field.
    • When using compiled procedures each workstation must be setup to point to the proper procedure directory by editing the Procedure Folder (Compiled) MET/CAL Configuration setting. If the workstation cannot locate the desired procedure an error message is generated when the procedure is launched from MET/TEAM.

  • When using a PXE, the Procedure Name should still reference the instrument line of the procedure. The Data Sheet field must reference the actual PXE file.
    • The PXE file is uploaded to MET/TEAM by using the Maintenance, Files menu. When the Find Files dialog displays press Add to access the Add File dialog. Select the Active checkbox and select Procedure as the File Type. Press the ellipsis button next to the File Name field to select the actual PXE file.
    • Note that when running a PXE from the desktop, the PXE will be automatically uploaded to MET/TEAM if the MET/TEAM procedure does not already exist.

    • After the file is saved, it will be available for selection in the Data Sheet list. Press the ellipsis button to select the PXE.

    • There are no other required selections for PXE based procedures. All other fields are user defined. It is recommended to attach any document associated with the procedure to the Procedure File field.
  • The benefit to using a PXE over a compiled procedure is that the PXE resides in the MET/TEAM database. When launching the procedure from MET/TEAM, the procedure information is passed to the MET/CAL Runtime which then downloads the PXE from the MET/TEAM database to a temporary folder on the local PC and executes it. As a result, there is no workstation specific setup required to use the procedure (outside of configuring the required standards).

Launching MET/CAL from a Work Order

If the rules for creating a MET/TEAM procedure associated with a MET/CAL procedure are properly followed, any Work Order can be configured to launch MET/CAL. Use the MET/TEAM Workflow menu to receive an asset to create a Work Order. The Procedure Used field should be populated with the MET/CAL enabled procedure. Keep in mind that the list of available procedures is based on the Type selection for the asset. It may be necessary to use the Maintenance, Types menu to edit the Type to add the procedure.

To launch MET/CAL, select the Results tab on the Work Order screen and click the "+" button below the grid (to add results). Alternatively, if there are currently no results (if the Data Sheet box on the Service tab is empty), you can press the ellipsis button next to the Data Sheet box to launch MET/CAL. Multiple sets of results can be generated for the same Work Order either using the same procedure or by using multiple procedures by simply clicking the "+" button below the Results grid again. Each set of results will be listed in the Results grid.

Depending on the browser and security settings a warning message may be displayed. In most cases the warning can be automatically ignored for future launches of MET/CAL by unchecking the "Always ask..." checkbox. For security purposes it is necessary to log into MET/CAL each time it launches.

After logging in, the procedure immediately runs without requiring the selection of an asset or a procedure. If the procedure being launched is a PXE that implements Procedure Sectioning and MET/CAL is configured to show the section selector user interface, the section selector window is displayed.

Use this dialog to select which sections of the procedure to run and which sections to skip. Click OK to proceed with executing the procedure.


MET/CAL Trial Overiew

Welcome to the trial version of MET/CAL Plus Software. This section details exercises and information useful to all users of MET/CAL including trial and full version users.

MET/CAL Plus is the complete software solution for calibration professionals. It includes MET/CAL® – the industry-leading software for automated calibration and MET/TEAM® – a dedicated, browser-based system to manage your test and measurement assets.

Designed for evaluation purposes, the trial software provides full functions of MET/CAL and MET/TEAM, with the following limitations:

  • The trial licenses expire in 60 days.
  • The trial version can be upgraded by applying licenses, without a re-installation.
  • The Crystal Reports Designer is not included with the Trial Version, but is provided with the Full Version.

Click the links below to start exploring the full functions of MET/CAL and MET/TEAM. To come back to this demo guide while using the trial software, click on Help menu, then go to the Getting Started, Trial Guide section in the contents page of the Help System.

  • See the MET/CAL Plus Introduction for an overview of the programs included in MET/CAL Plus.

For more resources on MET/CAL Plus Software, including application notes, videos, and ordering information, please visit www.flukecal.com/metcal.


Trial Version Exercises

To get the most of the sample version, a series of exercises will help you to learn about each program. Additional help is available, use the search capabilities to explore other topics.

The best way to demonstrate the capabilities of MET/CAL is to assume that a new Fluke model 179 has just been purchased from a local Fluke distributor. The vendor has calibrated the meter and has included a traceable certificate of calibration.

Exercises

  1. Add the new DMM to the database.
  2. Add a calibration record for the meter.
  3. Use the MET/CAL Editor to create a calibration procedure for the DMM.
  4. Use the MET/CAL Runtime program to calibrate the meter and print a certificate.


Configuring Programmable Standards

Calibration procedures are written for use with a specific calibration standard. When testing and debugging a procedure, MET/CAL requires that calibration standards be configured before they can be used in a calibration procedure.

There are benefits of configuring a standard:

  • Traceability: The standards used in a calibration can be identified.
  • Calibrated: The calibration status of the standard can be checked to be sure it is in calibration.
  • Communications: The IEEE address or serial port can be used for communication.

To add a standard to the configuration list, select Tools > Configure Instruments. Click add and select a standard that will be used.

The standard must be identified by adding its asset number. Follow the controls in the screen to configure the interface type and address or port number. Some standards use accessories. These can be identified as well.

Configuring Non-Supported Calibration Standards

MET/CAL includes support for over 70 different calibration standards. Non MET/CAL supported standards should also be configured. These may be manual or programmable standards. Simply enter the name of the standard in the text box, and click OK.

Then enter the asset number and set the remote interface. Remember that MET/CAL expects that each calibration standard to be included in the database. As new assets are added, use MET/TEAM to add a new entry for the standard.


Sample Exercise: MET/CAL Editor Basics

The MET/CAL Editor is used to create or edit MET/CAL procedures. Click the MET/CAL editor icon to start the program. If the desktop icons were not installed, click the Start button and navigate to Fluke Calibration, where the icon can be found. More detailed information about the MET/CAL Editor is available in the Introduction to the MET/CAL Editor help topic.

Log in using "admin" as both the user ID and the password.

In this exercise, we will create a procedure for the Fluke 179. The procedure will not be a complete procedure, but is intended to be used as a learning tool. The MET/CAL Editor has a debug mode where procedure can be tested. There is also a simulation mode that can be used when calibration standards are not available.

The sample procedure

The procedure that we will write is based on the model 179 calibration manual dated March 2001, Rev. 5 2/08 that can be downloaded from

http://www.fluke.com/fluke/usen/support/manuals/default.htm

The sample procedure will perform the following steps

  1. Replace the battery with a new one.
  2. Check the meters fuses.
  3. Check AC Voltage at three points.
  4. Check 2 DC Voltage ranges.

Writing the sample procedure

When the MET/CAL Editor begins, it starts with an empty development environment.

Creating the Project

The project will be a complete calibration solution that will contain the procedure and the required images. Projects were introduced in version 8.0 and simplify security, back-up and procedure distribution to other users or workstations.

To create a new solution, select File > New > Project from the main menu. Set the procedure name to "Fluke 179 Sample Procedure" on the next screen, then click OK to create an empty project. The procedure writer then adds procedures, files, images and other items that are used to perform the calibration.

Adding the Procedure

The next step is to add the procedure itself. Select Project > Add New Item from the main menu. Select MET/CAL Procedure. Enter the file name of the procedure. For this example, call it "Main Procedure.mc". Then click Add.

The Editor Screen

After the procedure has been added, the MET/CAL Editor screen should look like the screen below. Should any of the windows such as the Solution Explorer, Properties, Output or Error List not be visible, they can be selected from the View menu. The procedure contains only the header. Enter the procedure name on the Instrument: line. For this example, use the name "Fluke 179 Sample Procedure".

.

Navigating the Editor Screen

The Solution Explorer, Properties, Output or Error List are a series of core docked windows that generally are always visible and are used during the development and debugging of the procedure.

Each item in the project can be opened by clicking the item name in the Solution Explorer. Each open window has a tab, and can be brought forward by clicking the tab. The file can be closed by clicking the "X" in the tab.

Building the Procedure

So far, the procedure only contains the procedure header. To finish the procedure, commands will be added that will perform the tests. MET/CAL has a procedure language that uses key words called Function Select Codes or FSC's.

The procedure we will use is listed below, to save time, it can be copied and pasted into the procedure window below the header.

Help for each MET/CAL FSC is available by placing the mouse over the FSC to show the tooltip which contains a summary of the help information, or place the mouse pointer on a line and press F1 to open the help file in a new window.

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON

# =====================================================================
# System commands
# Suppress automatic range and connection messages.
# Suppress post test display unless there is a failure.
  1.001  ASK-   R                                                 F        W

# =====================================================================
# Measurement Uncertainty
# If you are planning to have MET/CAL report measurement uncertainty or have
# the procedure comply with Z540.3, the following steps set the minimum
# information MET/CAL needs.
  1.002  VSET         NMEAS = 1
  1.003  VSET         GB = MU
  1.004  VSET         UFMT = Prefix
  1.005  VSET         ACCRED = Yes
  1.006  VSET         GB = MU
  1.007  VSET         GBF = .8

# =====================================================================
# Replace the battery (instructions are from the 179 manual)
# These instructions are displayed using a DISP (display) statement.
# All step numbers are the same, which displays everything at the same time.
  1.008  DISP         Battery Replacement Instructions:
  1.008  DISP
  1.008  DISP         1. Turn the Rotary Switch to OFF and remove any leads.
  1.008  DISP
  1.008  DISP         2. Remove the two screws from the Battery Door
  1.008  DISP         and remove it from the Case Bottom.
  1.008  DISP
  1.008  DISP         3. Remove the Battery from the battery connector.
  1.008  DISP
  1.008  DISP         4. Replace the Battery with a new 9 V battery
  1.008  DISP
  1.008  DISP         5. Reattach the Battery Compartment Door
  1.008  DISP         and reinstall the two screws.

# =====================================================================
# Check the fuses
  1.009  DISP         Fuse Check Instructions:
  1.009  DISP
  1.009  DISP         1.  Set the Rotary Switch to Ohms.
  1.009  DISP
  1.009  DISP         2.  Plug a test lead into the Volts/Ohms terminal
  1.009  DISP         and touch the probe to the 400 mA to test the ma
  1.009  DISP         Fuse and then the 10 A terminal to test the 11 A Fuse.
  1.009  DISP
  1.009  DISP         If the display shows a resistance value
  1.009  DISP         other than OL, the fuse is good.
  1.009  DISP
  1.009  DISP         If the display reads OL, replace the fuse.

# =====================================================================
# The DISP FSC is used again, this time is to provide connection
# instructions to the technician.
  1.010  DISP         Connect the 5500A and the 179 as follows:
  1.010  DISP
  1.010  DISP         [32] [32] 5500A NORMAL HI ------> UUT V/Ohm/Diode
  1.010  DISP         [32] [32] 5500A NORMAL LO ------> UUT COM

# =====================================================================
# AC Voltage tests
# The 5500A calibrator is used to source the AC voltage.
  1.011  DISP         Set the rotary switch {AC Volts}
  1.012  5500         300mV          3.3U          45H            SI       2W
  2.001  5500         5.000V         0.053U        500H           SI       2W
  3.001  5500         5.000V         0.103U        1kH            SI       2W

# =====================================================================
# DC Voltage tests
  4.001  DISP         Set the rotary switch {DC Volts}
  4.002  5500         5.000V         0.007U                                2W
  5.001  5500         300.0V         0.5U                                  2W

# =====================================================================
# Instructions on Procedure Exit.
# These DISP statement step nubmers are sequential; each line will display
# one at a time.
  6.001  DISP         Disconnect all leads from the UUT.
  6.002  DISP         Print a cal cert and a sticker.
  6.003  END

After adding the procedure, the editor screen should look like the following.

Adding Other Items to a Project

Other procedures or Images can be added to a project. Select Project > Add New Item to create a new project item or select Project > Add Existing Item to include an existing procedure or image to the project.

For example, the procedure includes the following instructions for changing the model 179's battery.

  1.001  DISP         Replace the Battery
  1.001  DISP
  1.001  DISP         1. Turn the Rotary Switch to OFF and remove any leads.
  1.001  DISP
  1.001  DISP         2. Remove the two screws from the Battery Door and
  1.001  DISP         remove it from the Case Bottom.
  1.001  DISP
  1.001  DISP         3. Remove the Battery from the battery connector.
  1.001  DISP
  1.001  DISP         4. Replace the Battery with a new 9 V battery
  1.001  DISP
  1.001  DISP         5. Reattach the Battery Compartment Door and reinstall
  1.001  DISP         the two screws.

The procedure could be simplified by replacing these lines with an image. The image was captured from the calibration manual and edited in Microsoft Paint.

If this image was added to the project and named "Fluke 79 change battery.BMP", the procedure could display it with the statement PIC "Fluke 79 change battery.BMP".

The MET/CAL Test Numbering system

MET/CAL numbers each test line. The test number is the integer or left side of the decimal point number. The decimal portion or right side of the decimal is the step number.

The test number increments after a test is evaluated and a pass/fail decision has been made. When this happens, the step number resets to 1. So, 2.001 is the first step of the second test.

Procedure Comments

Procedure writers are encouraged to add comments to their procedures. Comment lines begin with the "#"character, and are displayed in green.

# =====================================================================
# System commands
# Suppress automatic range and connection messages.
# Suppress post test display unless there is a failure.
  1.001  ASK-   R                                                 F        W

How to Find Procedure Errors

The MET/CAL Editor can identify syntax errors with its Compile Check tools. Press F12 or select Debug>Compile Check Procedure from the program menu.

Errors will be identified in the Error Window. In this example, the keyword DISP was misspelled. This error was identified and displayed in the Error List window. Double-click an error in the Error List to highlight it in the procedure window.

How to Test Run a Procedure

The test and debug tools are available from both the Debug menu and the Debug toolbar.

First, to be sure that the procedure syntax is correct and that the test values for the calibration standards is within their range, select Debug > Compile Check Procedure from the program menu, or press F9.

Enable the Simulation Mode if the procedure is being run without the calibration standards connected.

To test the procedure, use the following steps

  • Start Debugging (F5) - F5 will start the debugger at the beginning of the procedure.
  • Debug from Cursor (Alt+F5) - Alt+F5 starts the debugger at the current cursor location.
  • Run (Ctrl+F5) - Once the debugger has started, press Ctrl+F5 to run the procedure.

The procedure will run until it is completed or terminated. Calibration results information is not saved when test running.

The Debug toolbar can also be used.

  • Button 1 - Starts the debugger (F5)
  • Button 2 - Starts debugging from the current cursor location (Alt+F5)
  • Button 3 - Stops debugging (Shift+F5)
  • Button 4 - Runs the procedure (Ctrl+F5)
  • Button 5 - Single steps the procedure (F11)

How to view the MET/CAL Memory Registers

The MET/CAL memory registers show the inner workings of MET/CAL while the procedure is running. They can be made visible by selecting them from the Debug > Windows menu.

The windows can be shown individually or stacked as a group.

How to Set a Projects Properties

To document information about a project, select Project > Fluke 179 Sample Procedure Properties from the main menu.

Complete the fields on the form and click OK.

How to Save a Project

Click the Save all icon on the toolbar, press CTL+S, or choose File > Save All from the File menu.

Building a Solution

After debugging and saving the project, select Build > Build Solution from the main menu.

This process will pull everything together into a Procedure Executable or PXE file. The process can be followed by viewing the Output window.

How to Publish a Package

Select Build > Publish Package from the program menu. Publishing will move the Procedure Executable file to the MET/CAL procedure folder where it can be used by the MET/CAL Runtime program to perform a calibration

Loading and Editing Existing Projects

Existing MET/CAL projects can be reloaded for updating or viewing. Select File > Open > Project/Solution from the main menu. Click the solution folder to be opened. Select the solution file with the .mcsln extension. Press Enter or click Open

Project's that have edited recently may be found by selecting File > Recent Projects and Solutions from the main menu.

After editing, remember to save the changes to the project files by selecting File > Save All from the main menu. Remember to Publish the package to make it available to the MET/CAL Runtime program.

Editing Existing Procedures

MET/CAL is delivered with several sample procedures. Existing users could have a large number of procedures. These can be edited without creating a procedure project. Select File > Open > Procedure from the main menu.

Use the Procedure Selector to select the procedure. After testing and debugging the procedure, it must be published. Select Build > Publish Selected Procedures from the main menu.


Sample Exercise: MET/CAL Runtime Basics

The MET/CAL Runtime program is used to execute calibration procedures. During a calibration, the procedure can control both the calibration standard and item being calibrated (UUT). During a test, UUT readings are collected and measurement uncertainty and guardband values are computed. Based on this information, MET/CAL can determine the pass/fail status of each test. When the procedure has finished, the calibration results are saved in the database. Calibration certificates and reports can then be printed. MET/CAL complies with ISO STD Z540.3. The Sequence of Events section also includes details on the MET/CAL Runtime process.

Click the MET/CAL Runtime icon to start the program. If the calibration standard is unavailable or not connected, Click the Live/Simulation control until "SIMULATION" is displayed.

Performing a Calibration

Before running a procedure, two pieces of information must be supplied using the SETUP view:

  1. UUT Asset - click the SELECT button under the UUT column to select the asset being calibrated

  2. Procedure - Up to three types of procedures may be selected using the drop-down menu in the Procedure column. Your configuration may not display all three choices, and the drop-down will not be present if your configuration only allows one choice.

    1. SELECT MET/TEAM PROCEDURE
    2. SELECT PXE
    3. SELECT FROM PROC.DIR

Selecting the Asset

Click the SELECT button to display the MET/TEAM Find Asset dialog and search for the UUT asset. The asset must be present in MET/TEAM before the calibration process can continue.

Use the search criteria of the Select Asset screen to narrow the asset search. Pressing Cancel at this point aborts the calibration.

Selecting the Procedure

Depending on your configuration, up to three methods may be available for selecting the procedure.

SELECT MET/TEAM PROCEDURE

This method allows you to select a procedure as-configured in MET/TEAM. Some pre-requisites must be met:

  • The UUT Asset must be selected before clicking this button
  • A valid MET/CAL procedure must be configured in MET/TEAM, as described here.

SELECT PXE

Navigate to the Procedure Executable file.

SELECT FROM PROC.DIR

If you are using a legacy procedure (SELECT FROM PROC.DIR), use the Procedure Selector to select the procedure.

Pre -Test Prompts

The Pre-Test prompts screen is used to define pre-test information. Ambient conditions and user notes are common pre-test data entry fields. The prompts are fully customizable and can be disabled if desired. Press Save after the prompt details have been updated.

Data Entry

It the UUT does not have a programmable interface, MET/CAL can collect the UUT readings manually. The Go-No-Go method is the fastest method, but the actual UUT reading is not captured. Slew entry is the most accurate, but the slowest. Keyboard entry must be used if the procedure uses any measurement uncertainty or guardband methods.

The input method used is determined by the settings of the ASK command.

Go-No-Go input

Slew Input

The slew method uses the keyboard arrow keys to slew the calibration standard up or down until the UUT display equals the nominal test value.

Keyboard Data Entry

If the measurement uncertainty and guardband capabilities are enabled, MET/CAL would compute the uncertainty for a test, apply a guardband and then determine if the test passed or failed. If measurement uncertainty is off, MET/CAL would simply make a pass or fail decision by comparing the UUT reading to the test limits.

This input method must be used to compute measurement uncertainty and guardbanding.

Test Results

As the testing progresses, the results can be viewed in the test results grid.

  • A green check icon indicates a passing test result.
  • A yellow check icon is marginal test result. By default, a reading > 70 % of tolerance.
  • A red X icon is a failed test result.

A procedure with guardbanding enabled may display slightly different results.

Post-Test Prompt

When the procedure is complete, the post cal screen is available to set the found-left flag and enter comments. This information will be added to the database.

Post Test Processing

When the test is complete, the Work Order for the completed calibration is available. Use the features on the Work Order to:

  • Create a calibration certificate
  • Print calibration stickers
  • View the calibration results
  • Change the Status of the Work Order
  • Define the next Calibration Due Date
  • Delete the Work Order to discard the data
  • Return the Work Order to complete the MET/TEAM Work Flow process.

Remember to press Save to preserve any changes made to the Work Order. To complete the test, Close the embedded browser window that is hosting the Work Order display.

Viewing a Calibration Record in MET/TEAM

At any time, the calibration record can be viewed in MET/TEAM. Launch MET/TEAM and search for the asset. Click the History/Notes tab to view the available calibration records. Double-click any Work Order from the list to view the Work Order details. Use the Quick Link icon next to the Data Sheet to view the results. Select the standards tab to view the calibration standards associated with the calibration event.

Should you be audited, this method can be followed to provide the details of a calibration.

Traceability Reports

Quality standards require documented proof of traceability for an item that has been calibrated. The forward traceability report shows an unbroken chain of calibrations between an asset and a legally recognized standard. Reverse traceability displays a list of items calibrated by calibration standard. This report can be used to determine the impact of a calibration standard being found out of tolerance.

Forward Traceability Report

MET/TEAM has both a forward and a reverse traceability report capability Starting with a Calibration Work Order, select the Standards/Accreditations tab. At the bottom of the tab are RT and FT options, reverse traceability and forward traceability respectively. Press the FT option to generate a Forward Traceability report.

Reverse Traceability Report

A reverse traceability report lists all UUTs that have been calibrated by a particular calibration standard. Similar to the Forward Traceability selection, locate the Standards/Accreditations tab on a Work Order. Then select the RT option.


Applications Available to the Licenses

The table below lists the names of the applications enabled by each different license.

Application Name | MET/CAL | 5500/CAL
MET/CAL Runtime | X |
MET/CAL Editor | X |


The Fluke Calibration Software Applications

The software is designed to assist users in conforming with ISO/IEC 17025, ISO‑9000, ANSI/NCSL Z540.1, ANSI/NCSL Z540.3 and other requirements. ISO and other standards bodies have defined a structured process flow for metrology. Adhering to that flow is the only way to ensure calibration traceability.

This software is designed to integrate into the traceable environment. It is important that managers, administrators and technicians read this chapter. All Metrology/Calibration personnel benefit from an understanding of these processes and requirements. Later, this chapter illustrates process flow.

MET/CAL Plus Software is a set of applications that automate the asset calibration and management process. This includes procedure execution, instrument control, results storage, report generation, and asset management. MET/CAL consists of a series of programs that work together to help manage the cal lab .

Software automation improves test consistency, reduces error and cuts the amount of time required to calibrate an instrument. MET/CAL Plus software also provides information storage and retrieval.

The MET/CAL Runtime and MET/CAL Editor applications allow a user to control calibration equipment on the IEEE-488 bus or RS‑232 serial port. This provides a way to verify and adjust a Unit Under Test (UUT) either through IEEE‑488 or serial interfaces. The MET/CAL Runtime and MET/CAL Editor applications can also be used in manual applications to ensure consistency of testing from technician to technician.

Table1-2 shows the icons for all applications available for installation. Note that the icons are in two groups: those representing Fluke programs, and those provided as third-party software, see Table 1-3. Applications that are subject to license management include a large check mark beside the description.

With the exception of Crystal Reports, all of these programs are members of the Fluke Metrology Software program group that the installation program creates on the administrator’s workstation.

Table 1-2. The Fluke Calibration Software Tool Set: Fluke-Developed Applications

 | MET/CAL and 5500/CAL Runtime As the primary MET/CAL and 5500/CAL application, the Runtime executes calibration procedures and saves the results. The MET/CAL Runtime program is used to execute calibration procedures. During a calibration, the procedure can control both the calibration standard and item being calibrated (UUT). During a test, UUT readings are collected and optionally, measurement uncertainty and guardband values are computed. Based on this information, MET/CAL can determine the pass/fail status of each test. When the procedure has finished, the calibration results are saved in the database. Calibration certificates and reports can then be printed. MET/CAL complies with ISO STD Z540.3. Procedure Writers and Operators can access this application. | ü
 | MET/CAL and 5500/CAL Editor The Editor helps create, edit, and compile MET/CAL or 5500/CAL procedures. Procedures are the programs that control the automated calibration of instruments. | ü
 | MET/TEAM Customer Portal The Customer Portal add-on is for the Servicing Facility to allow their customers to track assets, status of work, recalls and to view and print certificates. The Customer Portal has the same look and feel as MET/TEAM except the information is view only and limited for customers. | ü
 | Email Alerts The Email Alerts application is a tool installed by MET/TEAM that is used to send standardized emails based on events and information in the database. Note that MET/TEAM includes a built in email ReCall Escalation tool. The Email alerts provides functionality |
 | MET/TEAM and MET/TEAM Mobile This application provides access to the database using a web browser. This is the interface used by administrators to configure the system, manage users and security levels, customize data entry forms and field entries. In addition, it is used by data entry personnel to add assets to inventory, and record events like calibration, location changes and repair information. It Provides the mechanism for viewing and browsing data and has utilities for adding, editing, and running reports. | ü
üCheck mark indicates applications that are subject to license management.


MET/CAL License

When applied, a MET/CAL license grants access to the entire suite of applicable software programs available with MET/CAL Plus. These programs allow a metrology lab to calibrate, maintain and track equipment in conformance with various standards requirements, such as ISO-9000. 5500/CAL Runtime and Editor Programs, a subset of MET/CAL Runtime and MET/CAL Editor, are not accessible with a MET/CAL license.

All licenses for Fluke Metrology software must be applied using MET/TEAM. Reference the How to Apply a License Topic for additional details.


5500/CAL License

The 5500/CAL License limits the automated calibration programs to serial instrument interface only. 5500/CAL has its own Editor and Runtime programs and IEEE-488 cannot be used. However, the remaining suite of programs is accessible with this license.


Calibration Process Flow

As shipped, Fluke Metrology software is an effective tool for automation. Alternatively, it can be customized to better meet specific corporate guidelines for process flow and documentation.

The application design is based on the typical path of an instrument as it arrives, undergoes repair, maintenance or calibration, and finally is sent back out to the use location. Since this process may vary from company to company, customization tools are provided.


New Asset

Each piece of equipment or asset receives a unique identification number when first entered into the system. This asset number is used to create links between each section of the database relative to that specific instrument.

Figure 1-1. Process Flow 1: New Asset

The following numbered paragraphs discuss the path an asset follows through the calibration process. The process is charted in Figure 1-1.

  1. The new asset arrives on site.

  2. Vital information like the manufacturer, model and serial number, and description are recorded in the database.

    MET/TEAM is used to record information about the Type of asset, and also information about the specific asset itself. Recording common information at the Type level ensures data consistency and prevents entering the same data multiple times. Multiple assets can share the same Type.

  3. If necessary, the new asset is calibrated. This is done manually or by using MET/CAL Runtime.

  4. Calibration data is recorded in the database. This is done automatically with MET/CAL Runtime or manually, using the MET/TEAM application.

    If the asset is calibrated manually, or by an outside source, a calibration record can be added manually to the database. The MET/TEAM application will allow a user to add a calibration event and record applicable results data.

  5. If the asset does not pass calibration, it might be necessary to adjust or repair it. (see step 9). If the asset does pass calibration, it continues through the process.

  6. Most instrument calibrations must be documented. The easiest way to document a calibration event is to print a calibration report. If a calibration report is not required the unit can proceed to shipping.

  7. If a report is required, the desired report is selected and printed. Again, this can be done from MET/CAL Runtime or MET/TEAM.

    If reports are printed from MET/CAL Runtime, they are selected at the end of the procedure. At the conclusion of the calibration, a Work Order window will appear. It is from this window that reports are selected and printed.

  8. Whether documentation is printed or not, the asset is now ready to leave the calibration lab for its final destination.

  9. At Step 5, if the asset did not pass calibration, it leaves the normal flow so it can be adjusted or repaired.

  10. Repair or calibration adjustment results are recorded in the database as described previously, using either MET/TEAM or MET/CAL Runtime. Another attempt is made at calibration (back to Step 3). The asset will either proceed to the next step or continue in a loop until it passes or is removed from inventory.


Asset Recalled: Due for Calibration

The following chart follows the path of an instrument called out of inventory to be calibrated. While the process is similar to what a new instrument undergoes, the results are more critical. It is crucial that an instrument used as a standard to calibrate other instruments be found in tolerance when it is called up for calibration. If it is found out of tolerance then all calibrations that it has performed since the prior calibration date are suspect. In this situation all those suspect instruments may have to be recalled for calibration.

Figure 1-2. Process Flow 2: Asset Recalled, Due For Calibration

  1. Assets are assigned a calibration interval when they are entered into inventory. A Due for Calibration Report looks at this data to identify when an asset needs to be calibrated.

  2. The assets identified in the report are retrieved and brought to the lab.

  3. The asset is calibrated, either automatically using MET/CAL Runtime, or manually.

  4. Calibration data is recorded in the database. This is done automatically with MET/CAL Runtime or manually. At the end of an automated calibration procedure, the operator may be prompted either to save or to discard calibration data. If the save option is selected the calibration event is recorded in the database.

    If the asset is calibrated manually, a calibration record can be added to the database. The MET/TEAM application allows a user to add a calibration event and record applicable results data.

  5. If the asset passes calibration, it continues through the process as described in steps 6 through 8.

    If the asset does not pass calibration additional data must be collected before it continues through the process loop. A unit under test that is not used as a standard to calibrate other instruments can go through the repair and recalibrate loop represented by steps 12, 13 and 3. If the unit under test is used as a standard to calibrate other instruments a recall may be necessary. A traceability report can be run to determine if a UUT has calibrated other instruments.

  6. If an instrument used as a standard is found to be significantly out of tolerance a decision to recall or not must be made. Since the only data available is the last calibration record, it is assumed that the subject instrument has been out of tolerance since it was last calibrated.

    The definition of "significantly out of tolerance" varies from site to site. Tolerance is based on quality definitions and practices employed by different companies. Reports generated by Fluke Metrology Software cannot be used alone to make asset recall decisions.

  7. A reverse traceability report is run to determine which other assets may have been affected by the subject asset as shown in step 10.

  8. The owners of affected instruments are notified of the results so a recall decision can be made as shown in step 11.

  9. The subject instrument is adjusted or repaired as shown in step 12.

  10. Adjustment or repair data is entered into the database as shown in step 13 and calibration is again attempted.

  11. Once the instrument can be successfully calibrated a report is generated and the instrument is shipped back to the user.


Asset Recalled: Due for Maintenance

Some asset recall systems schedule periodic maintenance, a Due For Maintenance Report is used to locate all the assets due for maintenance. As assets reach their Maintenance Due dates, Fluke Metrology software helps manage their flow through the lab. The process is charted in Figure 1-3.

Figure 1-3. Process Flow 3: Asset Recalled, Due For Maintenance

The following paragraphs describe the activities that normally take place in the calibration laboratory when an asset is due for maintenance.

  1. Periodically, the laboratory runs a report designed to locate all assets due for maintenance. This may be a part of a formal preventive maintenance program, or a routine cleaning and inspection process.

  2. Based on the results of the Due for Maintenance Report, assets are recalled for maintenance. As assets reach their maintenance due dates, Fluke software helps manage their flow through the lab. Reports create work schedules while the MET/TEAM or MET/CAL Runtime applications create or update associated asset records.

  3. The required repair or scheduled maintenance is performed on the subject asset.

  4. Details of all work done is entered into the database. Maintenance records keep a complete history of every repair or maintenance that has been performed. The first record is created after the asset is entered into the database and a new record is added with each subsequent repair or maintenance event. The maintenance record is created from a form that can be used to track repair work, including parts used and related part and labor costs. The same form is used to track routine preventive maintenance requirements, such as cleaning a filter or changing fluids

  5. After the records are updated, need for a documenting report is assessed.

  6. The necessary documentation is printed.

  7. The asset is returned (shipped) to the required location


Safety Considerations

Calibration systems may generate or measure dangerous voltages. Both the operator and procedure author must be aware of possible hazards.

Warning!

To prevent possible electrical shock, fire, or personal injury:

  • Never use a screen saver when using the MET/CAL Runtime or MET/CAL Editor applications. Screen savers will hide the high voltage safety symbol. The MET/CAL Runtime and MET/CAL Editor programs control test instruments and can cause them to output dangerous voltage levels. The high voltage safety symbol indicates when dangerous voltage is present.
  • Use interconnect wiring and adapters rated for the highest voltage and current levels carried.
  • Never touch exposed conductive portions of signal interconnect wiring, even after instruments have been turned off.
  • Only touch the insulated portion of a connector. First disconnect the interconnect wiring at the source, then at the measurement side.
  • Always use insulated adjustment tools.
  • If the calibration program is abnormally terminated, verify that the front panels of source instruments indicate standby mode.
  • When writing procedures, make sure that procedures minimize the time during which dangerous voltages are applied.


Runtime Introduction

This section describes how to use the MET/CAL Runtime application.

The MET/CAL Runtime application is the central tool provided by the MET/CAL and 5500/CAL licenses, because this application executes procedures to actually calibrate instruments.

Each time a calibration begins, the procedure can present prompts for the operator to provide needed information, such as the asset number of the instrument being calibrated, or the temperature or other environmental factors. During the calibration, the screen might display illustrations showing test points, or forms providing an opportunity to enter a value, such as a UUT reading.

At the conclusion of a Calibration Procedure, you may see other prompts or displays, and you may be able to direct the system regarding how to deal with the output of the tests. You may be able to generate a Calibration Certificate or other report, or you may even be given the opportunity to discard the results if the test failed. All these possibilities depend on the particular way your system administrator has configured and customized the Fluke Metrology applications for your site. If you are not the administrator, be sure to speak with that individual before beginning any calibrations, so you know what to expect and how to respond appropriately.

This section can be helpful whether this is your first experience with MET/CAL Runtime, or whether you have previously worked with Fluke Calibration software.

You need a basic knowledge of the Windows graphical interface; for example, how to operate pull-down menus and dialog boxes, how to make selections from list boxes, and so on. This section does not provide any instruction in these topics.

This section assumes that your system is completely configured, and that you have installed some Calibration Procedures.

The remainder of this section discusses the following major topics:

  • Overview of the MET/CAL Runtime Application
  • Selecting a Calibration Procedure
  • Executing a Calibration Procedure
  • Post Run Results


Overview of the MET/CAL Runtime Application

The MET/CAL Runtime application allows you to select a procedure and run a calibration on a Unit Under Test (UUT). Figure 3-1 gives a high-level overview of how MET/CAL Runtime works when you run a procedure.

Figure 3-1. High-Level Overview of MET/CAL Runtime

The purpose of MET/CAL Runtime is to execute Calibration Procedures and save calibration results. Some of the information in this chapter requires an understanding of the Fluke procedure language. Therefore, this chapter includes some information about the MET/CAL procedure language.

Note that, while it is not necessary to understand the procedure language in order to use MET/CAL Runtime, an understanding of the basics of the language helps you understand how MET/CAL Runtime functions and, in particular, how its operation may vary depending on the procedure being executed. Refer to the this topic for an introduction to the MET/CAL procedure language.


Sequence of Events

This section presents a sequential outline of the major steps performed by MET/CAL Runtime. Most of these steps are described in more detail later in the chapter.

To execute the sequence of steps outlined below, start MET/CAL Runtime and choose Calibrate in the top-level menu. It may be helpful to actually run a procedure while reading this information to obtain a full understanding of the process.

The first step in the process, selecting a procedure, is initiated by the operator. All the remaining steps are done by the MET/CAL Runtime application, although some of the steps require operator involvement.

  1. Provide the required information using the SETUP view.

    1. Calibration procedure
    2. UUT Asset Number

  2. Select the RUN view and press the RUN button (or press F5).

  3. Check User Permissions for Required Database Fields. MET/CAL Runtime verifies that the user has permission to write to all required fields.

  4. The procedure or PXE is loaded and verified.

    The selected procedure and all required subprocedures , if any, are loaded into memory. No operator interaction is required in this step, but MET/CAL Runtime displays a sequence of one or more pop-ups that trace the loading of the procedure and/or the extracting of files from the PXE.

  5. Load Pictures

    If there are any picture files (.bmp, .png, jpg) required by the procedure, MET/CAL Runtime verifies that the specified files exist in the PXE file or in the active Picture Folder as defined in MET/CAL Configuration settings.

  6. Check Instrument Configuration

    Next, MET/CAL Runtime verifies that the system instruments required by the selected procedure are configured.

    If a required instrument isn't configured, it can be added to the configuration by pressing F12 to open the Instruments configuration. Verifying that required instruments are configured does not involve any communication with the actual instruments.

  7. Check Traceability

    For each required system instrument, user-configured system instrument, or manual standard, a traceability check is done to make sure the instrument is in cal.

    ALL of the instruments used in a calibration are considered to be "standards", and therefore all of them must meet the following rules:

    1. The standard must be in calibration before the instrument that is the current UUT. For each standard, only the most recent record meeting this criteria is used.
    2. Every standard must have passed its most recent calibration.
    3. The standard’s due date + due time must be in the future, beyond the due date and time of the current UUT. If the standard’s due date + due time is blank, then due date + due time is assumed to be infinity; it is never due for calibration.

  8. Check User Permissions for Database Asset Information

    MET/CAL Runtime verifies that the currently logged-in user has permission to write to those database fields that MET/CAL Runtime automatically updates for the specified asset. This verification is needed because MET/CAL automatically writes to the database at the conclusion of the calibration.

  9. Pre-Prompt Dialog

    A dialog prompts the user for associated information before procedure execution starts. This dialog is often used to prompt for temperature, humidity, and work order number. The dialog is configurable, however, and can be customized for each site.

    If you do not want to use the pre-prompt dialog, it can be turned off.

  10. Create Test Results Window

    The Test Results window is a separate window that shows a one-line, color-coded result line for each test step in the Calibration Procedure.

  11. Reset Internal Data

    This step prepares the system to execute the selected procedure. No interaction with the user is involved.

  12. Initialize IEEE-488 Boards

    This step is skipped for 5500/CAL, since it does not support IEEE-488 interfaces.

  13. Open Required Serial Ports

    MET/CAL Runtime next opens all serial ports referenced by the selected procedure.

  14. Test Required System Instruments

    MET/CAL Runtime performs an instrument-specific test for each required system instrument.

    If a system instrument fails its test, it is probably because it isn’t turned on or is not set to the configured address. In some cases, however, a system instrument may be broken, or the PC’s IEEE-488 bus or serial ports may be locked up or otherwise malfunctioning. If the instrument is turned on and set to the correct address, you can also reboot the PC before concluding that the instrument is malfunctioning.

    For system instruments configured on serial ports, the port configuration (specified using the Windows Control Panel) must agree with the instrument settings, and the cable must be of the correct type and pinout.

    No test is done for the UUT, for user-configured instruments, or for manual standards.

    A user-configured instrument is an instrument used as a calibration standard, and remotely controlled by MET/CAL, but for which there is no built-in driver.

  15. Clear Required System Instruments

    This step returns all required system instruments to a known, reset state prior to procedure execution.

  16. Execute Procedure

    After performing the foregoing preliminary steps, MET/CAL Runtime now executes the selected Calibration Procedure.

    A Calibration Procedure is a sequence of calibration test steps. Each test step involves setup steps followed by an evaluation. In many cases the setup steps involve prompts to the operator, and the evaluation may also involve an operator prompt.

    The sequence of steps executed and the types of prompts displayed to the operator are controlled by the MET/CAL procedure.

    To execute a procedure, MET/CAL starts at the first procedure statement and executes statements in the order they occur, except when one of the following two things occurs:

    1. The procedure jumps to a different step, or
    2. The operator uses the Post Test dialog to alter the execution sequence.

    The operator’s ability to alter the execution sequence of the procedure can be disabled by the procedure writer.

    Each test step generates a test result. By default, the results of each test step are shown to the operator in the Post Test dialog. However, it is common for procedures to be written so that the Post Test dialog appears only after a test step fails.

    More information on procedure execution, including descriptions of the different types of tests and operator prompts, is provided later in this chapter. Refer to the heading titled, "Procedure Execution".

  17. Clear Required System Instruments

    This step returns all required system instruments to a known, reset state following procedure execution.

  18. Close Required Serial Ports

    All serial ports referenced by the selected procedure are closed.

  19. Automatic Prompt to Operator: Remove All Connections

    An operator prompt display reminds the operator to remove all connections. You cannot configure or inhibit this prompt. It is a built-in feature of the MET/CAL Runtime application.

  20. Post-Prompt Dialog

    A dialog display prompts the user for associated information after procedure execution ends. This dialog is often used for displaying status information (such as the number of marginal PASS results, elapsed time, and so on), as well as to prompt for a remark that will be stored with the calibration results.

    You can configure the post-prompt dialog, and customize it for each site. It can be configured independently, based on whether the overall result of the calibration is PASS or FAIL.

    If you do not want to use the post-prompt dialog, it can be turned off.

  21. Post Run Work Order Review

    Upon completion of a procedure, the completed MET/TEAM Work Order is displayed in a MET/CAL embedded browser window. Use this dialog to print a report and/or a calibration sticker, to review the calibration results, adjust the Work Order Status or to discard the data by deleting the Work Order.

After the operator chooses Close to exit from the Work Order dialog, MET/CAL Runtime returns to its top-level menu and waits for further input from the user.

At this point, MET/CAL Runtime has completed the sequence for running one procedure, and the user can execute a different procedure, re-execute the same procedure, or exit from the application.


Main Runtime Window

When the MET/CAL Runtime application is launched, the login prompt is displayed. Enter your user name and password. After successful login, the main Runtime window is displayed.

The main Runtime window consists of three views: SETUP, RUN, and CONFIGURE. The selected view is highlighted along the top of the main window.

Menu

The main Runtime window also provides a menu for accessing the online help system and About dialog and a setting to toggle between LIVE and SIMULATION (demo) mode.

LIVE/SIMULATION Switch

When the LIVE/SIMULATION switch is set to SIMULATION, the Runtime application operates in simulation or demo mode. This can be useful when testing procedures. To perform valid calibrations, make sure this switch is set to LIVE mode.

Status Bar

Along the bottom of the main window is the status bar. The status bar shows status messages, the logged in user’s name, calibration start time, database connection, and software version information.

In order to perform a calibration, use the settings on the SETUP view to select a UUT and a procedure to run. Once the UUT and procedure are selected the RUN view becomes available. Use the RUN view to start the calibration and view the results. The CONFIGURE view is used to manage the application’s settings. It is recommended to review these settings prior to performing any calibrations.

MET/CAL Security Settings

In MET/TEAM, security settings can be setup for user interface controls in the MET/CAL Runtime based on the logged-in user’s group. In MET/TEAM, you can disable or enable buttons and features as well as making these items visible or invisible. After setting your desired security settings they will be manifested in the MET/CAL Runtime application.


SETUP View

The SETUP view allows the user to select the UUT and procedure to run. It is divided into three sections: Recent, UUT, and Procedure.

Recent Section

The Recent section displays a collapsible list of calibrations that have been started previously on this workstation. Calibrations are grouped by date and indicate how many calibrations were started on each date. Expanding a date reveals the details of the calibration including the time the calibration started, the UUT (asset) that was selected, the procedure that was started, the procedure’s instrument line that was selected, and for sectioned procedures the number of sections that were selected.

The Recent section also includes a SELECT button and a REMOVE button.

Selecting an item in the Recent section and clicking the SELECT button sets up the Runtime application to repeat that calibration by automatically selecting that UUT and procedure. The same thing can be accomplished by double-clicking an item in the Recent list.

  • To select only the UUT Asset, hold the Ctrl key while selecting an item in the Recent list.
  • To select only the Procedure, hold the Alt key while selecting an item in the Recent list.

To remove an item from the Recent section, select the item and click the REMOVE button. When all items for a date are removed, the date is also removed from this section.

UUT Section

The UUT section displays information about the asset to be calibrated including the asset number, model number, serial number, manufacturer and the asset’s current status.

UUT Selection

Select the UUT (asset) to calibrate using the buttons in the UUT section on the SETUP tab.

Click the SELECT button to display the Select Asset dialog. Select the asset to calibrate.

Once the UUT is selected, if there is one and only one MET/CAL procedure associated with the selected UUT, that procedure is automatically selected for use. If there is more than one MET/CAL procedure associated with the selected UUT or no procedures associated, the procedure to use must be selected manually by following the steps in Procedure Selection.

The UUT can also be selected using the Recent section, as explained above. Only one UUT can be selected for calibration.

To remove a UUT from the UUT section, select the UUT and click the REMOVE button. The UUT is removed from the list.

Procedure Section

The Procedure section displays information about the procedure to run. The information varies depending on whether it is a procedure executable (PXE) or a compiled procedure.

For compiled procedures, the first Instrument line, revision information, author, date, references and path items are displayed.

For a procedure executable, the procedure name, version information, author, company, copyright, package date, references and comments are displayed.

Procedure Selection

Select the procedure to use for the calibration using the buttons in the Procedure section on the SETUP tab. The procedure can also be selected using the Recent section as explained previously.

SELECT MET/TEAM PROCEDURE

The SELECT MET/TEAM PROCEDURE button allows the user to select a MET/CAL procedure in MET/TEAM that is associated with the selected UUT. This button is disabled until a UUT is selected. Clicking the SELECT MET/TEAM PROCEDURE button displays the Select MET/TEAM Procedure dialog. All MET/CAL procedures associated with the UUT are listed. Select the procedure to use and click the OK button. MET/CAL downloads the selected procedure file to the local file system and the Procedure section is populated with the PXE’s information.

SELECT PXE

The SELECT PXE button allows the user to browse the local file system and select an existing PXE file. Click the SELECT PXE button to display the Select Procedure Executable dialog. Select the PXE file to use and click the Open button. The Procedure section is populated with the PXE’s information.

SELECT COMPILED

The SELECT COMPILED button allows the user to select a compiled procedure from the current proc.dir. Click the SELECT COMPILED button to display the compiled procedure selector dialog. Select the compiled procedure to use and click the Select button. The Procedure section is populated with the compiled procedure information.

When the procedure is executed, you will be prompted to select a Work Order. The Service Type/Mode of the selected procedure must match the Service Type/Mode of the Work Order. If they do not match, procedure execution will not start and a message is displayed indicating a mismatch.


RUN View

The RUN view allows the user to start the calibration process and view the results. The RUN view is only accessible once the UUT and procedure have been selected. The RUN view is divided into four main sections: Procedure, Test Progress, Headers, and Results.

Procedure Section

The Procedure section is located in the upper left and displays information about the procedure being used. This is the same information as found in the Procedure section on the SETUP view and is shown on the RUN tab for reference only.

Headers Section

The Headers section is located in the upper right and consists of the RUN, STOP, and TERMINATE buttons as well as an area for displaying header and stimulus messages from the executing procedure. The Safety symbol is also displayed on the right side of the Headers section at appropriate times during a calibration.

To start a calibration, click the RUN button.

Once a procedure is running, it can be terminated immediately by clicking the TERMINATE button. A prompt is displayed to confirm terminating the calibration.

The calibration can also be stopped by clicking the STOP button. Stopping a procedure halts execution and displays the Procedure Step Terminated dialog.

This dialog provides the user with various options including continuing the calibration, repeating the last test, jumping to a different test, adding a remark, or terminating the calibration. The available options depend on the state of ASK flags that are set by the running procedure. Select the appropriate option on this dialog.

Test Progress Section

The Test Progress section is located below the Procedure section and displays the currently executing instrument line and the currently executing test number and the progress for that test for the executing procedure. The circular, blue progress bar fills up as each step in that test is executed.

If the procedure is a sectioned procedure a green progress bar will appear below the test progress section and the results and will show progress as the main sections of the procedure are completed.

Results Section

The Results section appears below the Headers section. This section is used to display the results of the calibration. This section also includes a button for exporting results to a file.

The UUT’s identification is displayed on a tab at the top of the Results section with that UUT’s calibration data and results in the grid below. Each column of the grid is explained below.

RESULT Column

The RESULT column indicates the status/result of each individual test. The following table indicates what each symbol in this column means:

Symbol | Meaning | Notes
 | Pass |
 | Pass Indeterminate |
 | Fail |
 | Fail Indeterminate |
 | Pass Marginal | This symbol is used when guardbanding is enabled and the UUT reading falls within the guardband area. <someone needs to verify the wording of this statement>

NO. Column

The NO. column indicates the test number.

RANGE Column

The RANGE column indicates range information.

UUT INDICATED Column

The UUT INDICATED column displays readings and values taken from the UUT.

SYSTEM ACTUAL Column

The SYSTEM ACTUAL column displays readings and values taken from the reference/standard.

C Column

The C column indicates…

MODIFIER Column

The MODIFIER column indicates…

ERROR Column

The ERROR column indicates…

%TOL Column

The %TOL column indicates…

Export to CSV

To export the results to a file, click the export button to the upper right of the grid. The file name defaults to the name of the UUT with “_data” appended. Select a location when prompted and click Save to export the results.


CONFIGURE View

The CONFIGURE view allows the user to configure instruments (standards and references) and change various application settings.

The left pane lists the categories for various settings. Selecting a category displays the settings associated with that category in the right pane. Refer to the following sections for more details on the settings in each category.

Most of these settings were previously only editable by shutting down the Runtime application and editing the MET/CAL configuration file in a text editor, then launching the Runtime application again. Now these settings are editable through the user interface and immediately take effect when the APPLY button is clicked. Clicking the DISCARD button discards any changes made and reverts any changed settings back to their previous values. After making changes to the settings, attempting to navigate to the SETUP or RUN views causes a prompt to be displayed asking if the changes should be saved or discarded. Select the appropriate option.

The APPLY and DISCARD buttons are disabled unless changes have been made to the current settings.

Configuration Settings

  • Instruments
  • Instrument Control
  • Instrument Configuration
  • Database
  • Simulation Mode
  • Files and Folders
  • Metrology
  • Post Test Dialog
  • Results
  • Runtime Configuration
  • Safety
  • Temperature and Humidity


Runtime Prompts

In addition to the prompts found in the SETUP, RUN, and CONFIGURE views, the MET/CAL Runtime may also generate the additional prompts below while running a procedure, depending on your configuration.

Reload/Refresh Button

If a MET/TEAM prompt screen (with the exception of the Sign In screen) does not display correctly within MET/CAL Runtime's embedded browser, click the Reload/Refresh button in the upper left corner as indicated by the red box in this image:

Pre-Run and Post-Run Screens

Select Work Order

A Select Work Order prompt may be presented if your installation is configured to support multiple Work Orders and MET/CAL is not permitted to create new Work Orders, and there are multiple open Work Orders for the selected UUT.

Pre-Prompt Screen

When MET/CAL is configured to display a Pre-Prompt, this is the typical/default Pre-Prompt screen. If the Prompt File MET/CAL Configuration setting points to an invalid prompt file, the entire Work Order will be displayed instead.

Post-Prompt Screen

When MET/CAL is configured to display a Pre-Prompt, this is the typical/default Post-Prompt screen. If the Prompt File MET/CAL Configuration setting points to an invalid prompt file, the entire Work Order will be displayed instead.

Edit Work Order

This is the Edit Work Order screen, which always appears at the end of a calibration, after the Post-Prompt dialog and after results have been written to the database.

MET/CAL Runtime Prompts

Slew Dialog

MATH FSC List Box

WAIT Dialogs

DISP Dialog

EVAL Dialog

SET Dialog

DRAW Dialog

OPBR Dialog

© 2015 Fluke Corporation


Procedure Selector

The procedure selector is provided to select procedures stored as individual *.pro files located in the procedure directory, as defined by the Procedure Folder (Compiled) MET/CAL Configuration setting. The active procedure directory displays on the top line of the selector. Use the [image] button to change to alternate procedure directories. The directory change alters the MET/CAL Configuration so that all subsequent runs of MET/CAL Runtime, MET/TEAM and the MET/CAL Editor will use the selected directory.

Use the Filter Records option on the top of the dialog to search for specific details in a procedure. The filter uses a simple text search to locate the information in the specific section of a procedure. Logic operations such as AND and OR are not supported. To view all available procedures press the Find button with no criteria in the filter.

The selector always displays empty without procedures or a search criteria. This is to prevent long delays when loading large procedures directories. After making a search selection, double click the desired procedure or press the Open button to complete the procedure selection. After the procedure is selected, the operation that initiated the selector will continue. Close the selector without a selection to cancel the operation that initiated the selector.

Field | Description
Instrument Line | Search for text in the instrument lines of procedures.
Reference | Search for text in the Standard and configuration lines of a procedure.
Author | Search for text in the author field of procedures.
Revision | Search for text in the Revision field of a procedures.
Date | Search for text in the Date field of a procedures.
Find procedures in the active procedure directory based on the search criteria. If there is no criteria, all procedures are listed in the selector.
Clears the search filter.
Open the procedure actively selected in the selector.

Change the active procedure directory. Changing the directory alters the Procedure Folder (Compiled) MET/CAL Configuration setting.

Use this option to hide one or more procedures actively selected in the Procedure Selector. Hidden procedures cannot be selected by the MET/CAL Runtime. Use this button to hide procedures, the check box in the list is for indication only and does not function as a selection.

To select multiple procedures to hide, hold down the CTRL key and click the individual procedures to hide. The SHIFT key can also be used to select multiple files. The difference is that SHIFT will select all procedures between the actively selected procedure and the next procedure selected. Note this is standard Windows behavior. The same multi-select operations apply to files and directories in Windows explorer and other applications that support multiple selections.

Use this option to un/hide one or more procedures actively selected in the Procedure Directory. Hidden procedures cannot be selected by the MET/CAL Runtime. Use this button to hide procedures, the check box in the list is for indication only and does not function as a selection.

Opening large procedure directories on a network share may take several minutes to load. It is recommended to work with multiple small repositories rather than one large one. If a procedure directory is switched to by mistake and the selector is taking a long time to load and cache the procedures, the loading can be canceled. During loading, a small stop icon appears next to the progress bar, on the right hand side at the bottom of the screen. Pressing that will abort the loading and a different proc.dir can be selected via the proc.dir button on the toolbar.


Prompt Dialogs

There are two configurable dialogs that normally are presented to the operator each time a procedure is executed. These dialogs are referred to as the pre-prompt dialog and the post-prompt dialog. The pre-prompt dialog displays after you select a procedure, but before procedure execution begins. The post-prompt dialog displays after procedure execution terminates.

Pre-Test Prompts

You can configure the pre-prompt dialog that appears after a procedure has been selected, but before the start of procedure execution.

Use the pre-prompt dialog to display read-only information, or to prompt the operator for information that will be written to the results or, in some cases, used during procedure execution.

The pre-prompt dialog is controlled by the Prompt File MET/CAL Configuration setting. This setting specifies the name of the file that controls the pre-prompt dialog.

To turn off the pre-prompt dialog, change the setting to "none".

An equivalent way to turn off the pre-prompt dialog is to edit the prompt file (default name promptdb.txt) and change it so that it contains no lines other than comments and blank lines. Any line that begins with a pound sign (#) or a semicolon (;) is a comment line.

The default pre-prompt dialog prompts the operator for the temperature, the humidity, the work order number, and asks whether the calibration seal on the UUT is intact. By modifying the pre-prompt file the administrator of the system can prompt for specific information.

If the value entered by the operator for a data item is to be written to the database, the value must be written to one of the fields of the calibration table, and it must not be a field that is automatically updated by the MET/CAL Runtime.

Normally all fields in the pre-prompt dialog are displayed in a single dialog. However, if the system is set up to prompt for a large number of items, a sequence of separate dialogs will appear until all necessary prompts have been shown.

See Customizing Prompts for additional details.

Post-Test Prompts

There are two post-prompt dialogs: the pass-prompt dialog and the fail-prompt dialog. After each procedure execution one or the other, but not both, of these dialogs is displayed.

If the overall result of the procedure is PASS, the pass-prompt dialog is displayed. If the overall result is FAIL, the fail-prompt dialog is displayed. The condition that determines an overall result of FAIL is that one or more of the individual tests has failed because the UUT is out of tolerance at that test point.

The pass-prompt and fail-prompt dialogs are separately configurable.

Use the post-prompt dialogs to display read-only information, or to prompt the operator for information that will be written to the results.

The pass-prompt dialog is controlled by the Pass Prompt File MET/CAL Configuration setting. This setting specifies the name of the file that controls the pass-prompt dialog.

Similarly, the fail-prompt dialog is controlled by the Fail Prompt File MET/CAL Configuration setting. This setting specifies the name of the file that controls the fail-prompt dialog.

To turn off the pass- or fail-prompt dialogs, you can change one or both settings to "none". Since the two dialogs are independently configurable, it’s possible (for example) to set up the system so that a post-prompt dialog appears when the overall result is FAIL, but not when the overall result is PASS.

As with the pre-prompt dialog, an equivalent way to turn off the post-prompt dialog is to edit the appropriate prompt file (default names are pass_db.txt and fail_db.txt), and change it so that it contains no lines other than comments and blank lines. Any line that begins with a pound sign (#) or a semicolon (;) is a comment line.

The default pass-prompt dialog shows the operator the number of marginal tests, the time it took to calibrate the UUT, the overall test result (PASS, FAIL, etc.), and asks the operator to indicate that the results are either "As Found" or "As Left", and to enter an optional comment.

Note that a "marginal test" is one where the test passed, but the error expressed as a percentage of the test tolerance is greater than the adjustment threshold. The adjustment threshold is a configurable parameter set in the procedure. It is typically set to 70%.

The default fail-prompt dialog is the same as the pass-prompt dialog, except that it also shows the total number of tests that failed.

However, as with the pre-prompt dialog, the post-prompt dialogs can be configured by the person who sets up the system. When you run a procedure, you may or may not see the information and prompts described for the default prompt dialogs.

If the value entered by the operator for a data item is to be written to the database, the value must be written to one of the fields of the calibration table, and it must not be a field that is automatically updated by the MET/CAL Runtime.

Normally all fields in the post-prompt dialog are displayed in a single dialog. However, if the system is set up to prompt for a large number of items, a sequence of separate dialogs will appear until all the prompts have been shown.

See Customizing Prompts for the Operator for additional information. There, you will find a detailed description of the format of pass-prompt and fail-prompt files, and other information about customizing them.


Runtime Keyboard Shortcuts

The keyboard shortcuts listed below are available for convenience and efficiency when using the MET/CAL Runtime.

Shortcut | Description
General Shortcuts
Alt+S | Selects the SETUP tab on the main window
Alt+R | Selects the RUN tab on the main window
Alt+C | Selects the CONFIGURE tab on the main window
F1 | Opens the online help system for the active view
SETUP VIEW: All shortcuts select the SETUP view, then...
Alt+U | Opens the dialog to select a UUT
Alt+O | Opens the dialog to select a PXE
Ctrl+Alt+O | Opens the dialog to select a compiled procedure
RUN VIEW: All shortcuts select the RUN view, then...
F5 | Starts procedure execution
Alt+F5 | Stops procedure execution
Alt+. or Esc | Terminates procedure execution
Alt+E | Exports data from the results grid to a CSV file
CONFIGURE VIEW: All shortcuts select the CONFIGURE view, then...
F12 | Selects the Instruments configuration option


Procedure Execution

This section describes how the MET/CAL Runtime application executes a MET/CAL procedure. The information following is mainly intended for the person who will be writing those procedures, or modifying a supplied procedure.

Some of the information in this section is repeated in the FSC Reference. As you prepare procedures for your site, refer to the FSC Reference for complete reference information about the FSCs that make up the MET/CAL procedure language. The descriptions that follow are provided to assist in giving an overview of MET/CAL Runtime’s procedure execution process.


Procedure Statements

Each MET/CAL procedure consists of a header followed by a sequence of procedure statements.

An individual procedure statement begins with a step number, followed by a Function Select Code (FSC). The FSC is a keyword that identifies the type of procedure statement.

Example:

1.001 5500 40 35.00V 0.72U 5kH SI 2W

In this statement the FSC is 5500, which identifies the statement as one that controls a Fluke 5500A calibrator.

Example:

1.001 DISP Set the Capacitance Decade to 4.70 nF.

In this statement the FSC is DISP, which identifies the statement as one that issues a prompt to the operator.

For a detailed description of the procedure header, see MET/CAL Procedure Header.


Step Numbers

As mentioned above, each procedure statement begins with a step number. The step number has two parts, as follows:

  • The major step number is the test number.
  • The minor step number defines the sequential position of the statement within that test.

You can see step numbers in a procedure by using the MET/CAL Editor application, or looking at the currently executing procedure using the Post Test List option.

Example:

3.020 5500 3.513V 50H SI S 2W

The above example is the 20th statement in test number 3.


Tests

Statements in a procedure are grouped by major step number into blocks that comprise individual tests.

A typical test has three parts:

  1. Connections
  2. Setups
  3. Evaluation

In a simple case, a single procedure statement performs all three parts of the test. For example:

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
  1.001  5700   400   350.0mV        2.9U          60H                     2W

This single statement (assuming the default state of the ASK flags), performs the following operations:

  1. Connection- An automatic connection message displays that prompts the operator to connect the UUT to the 5700A Output Terminals.
  2. Setup- An automatic range message displays that prompts the operator to set the UUT to the 400 mV AC Range.
  3. Setup - The 5700A is programmed to output 350 mV, 60 Hz with internal sense.
  4. Setup - The Slew dialog displays that prompts the operator to Adjust stimulus for a UUT reading of 350 mV at 60 Hz. When slewing is complete, System Actual is set to the final 5700A output voltage, and UUT Indicated is set to the value in the Nominal field.
  5. Evaluation- UUT Indicated is compared to System Actual, according to the specification in the Tolerance field, and test results are generated.

In many cases, however, a test is made up of multiple procedure statements. More information about the three parts of a test (connections, setups, and evaluation) is given below.


Connections

The operator performs connections under the direction of prompts that the procedure generates. Connection message prompts can be automatically generated by an instrument FSC or the connection (CON) FSC, or the person who writes the procedure can create the message prompts using the display (DISP) or picture (PIC) FSC.

Connection messages instruct the operator, or, in the case of the PIC FSC, show the operator graphically how to interconnect the UUT and the calibration standards. See Automatic Connections, Operator Information Prompt, and Pictorial Information Prompt in the section on run time prompts later in this chapter.

For a complete descriptions of the DISP, PIC, and CON FSCs see the FSC Reference chapter of the MET/CAL Reference Manual.


Setup UUT and Standards

Once the connections are made, a test typically requires one or more setups to be performed. Setups fall into one of three categories:

  1. Setting up the UUT.
  2. Setting up the standards required for the test.
  3. Setting up the memory registers containing UUT Indicated and System Actual, which are used to perform the test evaluation.

Setting up the UUT

The UUT is set up either manually by the operator or automatically by MET/CAL if it has remote control capability. Prompts to the operator to set up the UUT can be automatically generated by an instrument FSC or RNG FSC or by using the DISP, MESS, PIC, or SET FSCs. For example, the following statements would all generate the operator prompt Set UUT to the 10 MOhm range.

  1.001  RNG          10MZ
  1.002  5700   10    10.00000MZ     0.00410U                              2W
  2.001  DISP         Set UUT to the 10 MOhm range.

See the headings, Automatic Range Message, Automatic Test Setup Prompts, Automatic UUT Setup Prompts, and Operator Information Prompt in the section on run time prompts. For a complete description of instrument FSCs, RNG, DISP, MESS, PIC, and SET see the FSC Reference.

The IEEE FSC is used to set up UUTs with an IEEE-488 interface and the PORT FSC is used to set up UUTs with an RS-232 interface. The statement below uses the SCPI remote protocol to program a UUT with an IEEE-488 interface.

The UUT is a DMM. The SCPI commands select 2-wire Ohms and the 10 MOhm range. The IEEE-488.2 *OPC? (Operation Complete query) command is also sent to determine when the setup is complete.

When the setup is complete, the DMM returns a "1" which MET/CAL subsequently reads using the [I] special construction. The programming string is automatically terminated by MET/CAL using the IEEE-488 EOI (End or Identify) line.

1.025 IEEE FUNC "RES";:RES:RANG 10e+6;*OPC?[I]

If the UUT has a RS-232 interface, the same command could be sent using the PORT FSC. For serial UUTs the terminator must be specified. The terminator can be included at the end of the output string or declared globally using the [OTERM] special construction. In this case a carriage return is specified at the end of the output string using the [13] special construction.

1.025 PORT FUNC "RES";:RES:RANG 10e+6;*OPC?[13][I]

For a complete description, see IEEE and PORT in the FSC Reference.

Setting up Standards

MET/CAL can set up remotely programmable and manual standards. An instrument FSC is used to set up a standard for which there is a built-in MET/CAL driver. A device for which MET/CAL has a built-in driver is referred to as a System Instrument.

Example, Setting up a System Instrument:

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
  1.001  5700   400   350.0mV        2.9U          60H                     2W
  2.001  5700         350.0mV                      60H                  S  2W

The above statements set up the 5700A to output 350 mV at 60 Hz with internal sense (2-wire). Statement 1.001 will also set up the UUT range and perform an evaluation. Statement 2.001 only sets up the standard (MOD4 = S). Both statements will generate an automatic connection message unless otherwise inhibited using the ASK- FSC.

Remotely programmable standards for which there is no built-in driver are referred to as User-configured Instruments.

The IEEE and PORT FSCs are used to set up IEEE-488 and RS-232 controlled user-configured instruments, respectively. The IEEE and PORT FSCs must contain the correct protocol for controlling the standard, as described in the remote programming section of the instrument’s operating manual.

Example, Setting up a User-configured Instrument:

1.001 IEEE [@2812]:INST:NSEL 1;:VOLT 2;:CURR 1

The above statement sets up the PM 2812 DCV power supply channel 1 to 2 V with a current limit of 1 A.

Manual standards are set up by the operator under the direction of prompts generated by the DISP, MESS, and PIC FSCs.

Example, Setting up a manual standard:

1.001 DISP Set the 792A to the 220 mV range.


Setup Memory Registers

The correct memory registers must be set up with the values of UUT Indicated and System Actual for the test evaluation to be properly performed. These registers are automatically set up by instrument FSCs that perform an evaluation (MOD4 = blank) as shown in the simple 5700A example earlier in this section. However, there are many tests where an instrument FSC evaluation cannot be used. For these tests, one or more additional FSCs must be used to set up the UUT Indicated and System Actual values in the correct memory registers. This is the case for closed-loop tests and tests where the UUTs are not the same as the units of applied standard.

Example, closed-loop test:

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
  1.001  5700         10.0000V                                          S  2W
  1.002  IEEE         ?[I]
  1.003  MEMCX  20    10.000V        0.0005U

The action of each test step in the above example is detailed below:

  1. Setup - The 5700A is programmed to output 10 V DC and a value of 10 is stored in memory register MEM1.
  2. Setup - The UUT reading is read via the IEEE-488 bus and stored in memory register MEM.
  3. Setup - Swap the contents of registers MEM and MEM1. This is necessary so System Actual, the 5700 output, and UUT indicated, the UUT reading, are in the correct registers for the MEMC (memory compare) evaluation FSC.
  4. Evaluation - Compare the UUT Indicated to System Actual against the UUT specification in the Tolerance field.

Example, units of UUT parameter and applied parameter differ:

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
  1.001  5700         2V                           60H                  S  2W
# Get the 5700 accuracy at 2Vrms
  1.002  MATH         M[1] = ACCV2("Fluke 5700A", "Volts", 2.0, 60.0)
# Convert to Vp
  1.003  MATH         M[1] = M[1] * 2 * SQRT(2)
  1.004  ACC          2.828Vp        M1U
  1.005  IEEE         ?[I]
  1.006  MEMCX        2.0          0.045U        2.828Vp

The action of each test step in the above example is detailed below:

  1. Setup - The 5700A is programmed to output 2 Vrms at 60 Hz and store a value of 2 in memory register MEM1.
  2. Setup - Retrieve the voltage accuracy of the 5700A at 2 Vrms, 60 Hz from the 5700A accuracy file.
  3. Setup – Convert the accuracy in Vrms to Vp.
  4. Setup – Establish the system accuracy in volts peak for the 5700A output. 2.828 is stored in memory register MEM1, overwriting the value of 2 stored there in Step 1.
  5. Setup - Obtain the UUT reading and store it in memory register MEM.
  6. Evaluation - Compare the UUT Indicated (MEM) to the System Actual (MEMCX Nominal Value) against the UUT specification in the Tolerance field.

A number of FSCs can be used to set up memory registers. For a complete description of these FSCs, see ACC, MATH, MEM2, MEME, MEMI, and OPBR.

The IEEE and PORT FSCs can be used to set up memory registers MEM and MEM2 by using the [I] and [I$] special constructions respectively. Also see Use of Standard Memory Registers.


Evaluations

Each test ends with a test evaluation. The basic result of an evaluation is that the test passed or failed. Evaluations can be either numeric or Go-NoGo. Numeric evaluations save numeric data in the results for the test. Go-NoGo evaluations only save a pass or fail indication for the test.

Numeric Evaluation

  • A numeric evaluation is performed by the following FSCs:
  • An instrument FSC evaluation test where the standard is sourcing an output to the UUT and slew or keyboard entry mode is specified.
  • An instrument FSC evaluation test where the standard is measuring an output of the UUT.
  • The MEMC FSC.
  • The DOSE FSC when the user-written program appends the percent error for the test to dosdose.dat.

A numeric evaluation may have additional qualifiers that can be added to the evaluation result. For example, a marginal pass is an evaluation in which the error, expressed as a percentage of the test tolerance, is less than or equal to 100% (a configurable value), but greater than the threshold value (also configurable, but usually 70%).

Instrument FSC Evaluation Test

Instrument FSCs are FSCs that refer directly to system standards for which MET/CAL provides a built in driver. An evaluation test is specified for an instrument FSC when the MOD4 field is blank. An Instrument FSC Evaluation Test compares the System Actual to the UUT Indicated value for the test against the UUT specification in the Tolerance field.

Example, standard sourcing an output to the UUT:

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
  1.001  5700   400   350.0mV        3.9U          60H                     2W

The above statement will use the slew mode to obtain the UUT reading unless otherwise specified. When slew mode is used, the UUT Indicated value is taken from the Nominal field and the System Actual is the final slew value. See "Slew Dialog" for more information.

The keyboard entry mode is used if the K-flag is set when the statement is executed or the B-flag is set and the operator chooses keyboard when the Test Evaluation dialog is displayed. The K-flag and B-flag are set using the ASK+ FSC. For keyboard entry mode, the System Actual is the Nominal field value and the UUT Indicated is the value entered from the keyboard. See "Keyboard Entry Operator Prompt".

For a complete description of enabling and disabling keyboard entry and slew modes, refer to ASK+ and ASK- in the FSC Reference.

Example, standard measuring an output of the UUT:

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
  1.001  34401  400   350.0mV        3.9U          60H                     2W

In this example, where the standard is measuring an output of the UUT, the Nominal field is taken as the UUT Indicated output. The value measured by the standard is used as the System Actual.

MEMC/MEMCX FSCs

The MEMC and MEMCX FSCs perform a numeric evaluation similar to an instrument FSC evaluation test. However, unlike an instrument FSC, MEMC and MEMCX cannot measure the UUT output or obtain the UUT reading via slew or keyboard entry mode. The UUT data must be obtained prior to execution of the MEMC statement. The MEMC and MEMCX FSCs are typically used in closed-loop tests and tests where the UUT units are not the same as the units of the applied standard. They are also used for to perform the evaluation when the reference is a user-configured instrument or manual standard.

Example, closed-loop test:

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
  1.001  5700         10.0000V                                          S  2W
  1.002  IEEE         ?[I]
  1.003  MEMCX  20    10.0000V       0.0005U

The action of each test step in the above example is detailed below:

  1. Setup - The 5700A is programmed to output 10V DC and a value of 10 is stored in memory register MEM1.
  2. Setup - The UUT reading is read via the IEEE-488 bus and stored in memory register MEM.
  3. Evaluation - Uses the UUT Indicated, the System Actual, and the UUT specification in the Tolerance field to determine whether the test passed or failed.

Example, units of UUT parameter and applied parameter differ:

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
  1.001  5700         2V                           60H                  S  2W
# Get the 5700 accuracy at 2Vrms
  1.002  MATH         M[1] = ACCV2("Fluke 5700A", "Volts", 2.0, 60.0)
# Convert to Vp
  1.003  MATH         M[1] = M[1] * 2 * SQRT(2)
  1.004  ACC          2.828Vp       M1U
  1.005  IEEE         ?[I]
  1.006  MEMCX        2.0           0.045U        2.828Vp

The action of each test step in the above example is detailed below:

  1. Setup - The 5700A is programmed to output 2 Vrms at 60 Hz and store a value of 2 in memory register MEM1.
  2. Setup - Retrieve the voltage accuracy of the 5700A at 2 Vrms, 60 Hz from the 5700A accuracy file.
  3. Setup – Convert the accuracy in Vrms to Vp.
  4. Setup – Establish the system accuracy in volts peak for the 5700A output. 2.828 is stored in memory register MEM1, overwriting the value of 2 stored there in Step 1.
  5. Setup - Obtain the UUT reading and store it in memory register MEM.
  6. Evaluation - Compare the UUT Indicated (MEM) to the System Actual (MEMCX Nominal Value) against the UUT specification in the Tolerance field.

Example, User-configured Measurement Instrument

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
  1.001  IEEE         [@3458]DCV 10;ARANGE ON;TRIG HOLD
  1.002  IEEE         OUT 10V;OPER;*OPC?[I!]
  1.003  IEEE         [@3458]TRIG SGL[I]
  1.004  ACC          V              2.6P% 2e-6U
  1.005  MEMC         22          0.01U         10.00V

  1. Setup – The User-configured DMM (in this case a 3458A) to DCV, autorange, and trigger hold.
  2. Setup – The UUT is set to 10 V DC and operate.
  3. Setup – Obtain the reading from the User-configured DMM and store it in memory register MEM.
  4. Setup – Establish the system accuracy as 2.6 ppm of reading plus 2 µV. The ACC statement takes the Nominal value from MEM when the ACC Nominal field does not contain a value. In this case MEM is the User-configured DMM reading from step 3.
  5. Evaluation - Compare the UUT Indicated (MEMCX Nominal Value) to the System Actual (MEM) against the UUT specification in the Tolerance field.

DOSE FSC (Numeric Evaluation)

The DOSE FSC runs a user-provided program or batch file. The DOSE FSC behaves like a numeric evaluation when the user-written program or batch file appends the percent error for the test to dosdose.dat.

Go-NoGo Evaluation

A Go-NoGo evaluation is performed by the following FSCs:

  • An instrument FSC evaluation test where the standard is sourcing an output to the UUT and Go-NoGo mode is specified.
  • The EVAL FSC.
  • The PICE FSC.
  • The DOSE FSC when the user-written program does not append the percent error for the test to dosdose.dat.

Instrument FSC Evaluation Test

Instrument FSCs are FSCs that refer directly to system standards for which MET/CAL provides a built in driver. An evaluation test is specified for an instrument FSC when the MOD4 field is blank. An Instrument FSC Evaluation Test uses the System Actual, the UUT Indicated value for the test, and the UUT specification in the Tolerance field to determine whether the test passed or failed.

Example, Go-NoGo Instrument Evaluation Test.

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
  1.001  ASK+           G
  1.002  5700   400   350.0mV        3.9U          60H                     2W

The above statement will use the Go-NoGo evaluation if the G-flag is set when the statement is executed or the B-flag is set and the operator does not choose keyboard or slew when the Test Evaluation dialog is displayed. The G-flag and B-flag are set using the ASK+ FSC. When Go-NoGo mode is used, no numeric data for the test is stored in the results.

For a complete description of enabling and disabling Go-NoGo mode, refer to ASK+ and ASK- in the FSC Reference.

EVAL FSC

The EVAL FSC presents a message to the operator and typically waits for a YES or NO response. The operator’s response determines the result of the test (PASS or FAIL). See "Test Evaluation Prompt".

Example

1.001 EVAL Did the UUT display test pass?

PICE FSC

The PICE FSC displays a picture to the operator and waits for a YES or NO response. The operator’s response determines the result of the test (PASS or FAIL). See "Pictorial Information Prompt".

DOSE FSC (Go-NoGo Evaluation)

The DOSE FSC runs a user-provided program or batch file. The DOSE FSC behaves like a Go-NoGo evaluation when the user-written program or batch file appends PASS or FAIL for the test to dosdose.dat.

If neither PASS nor FAIL is appended, a pass condition is assumed.


Procedure Flow Control

When MET/CAL executes a procedure, it starts on the first line after the header and executes the lines in order until one of the following occur:

  1. The end of the procedure is reached.
  2. An END statement is executed.
  3. A JMP, JMPF, JMPT, JMPL, or JMPZ statement transfers control to a different procedure statement.
  4. A repeat statement (RPT) transfers control to Step 1 of the test.
  5. A CALL statement transfers control to a subprocedure.
  6. The operator alters the normal procedure execution sequence using the Post Test List, Repeat, Cancel, or Terminate options.

The OPBR (Operator Branch) FSC can be used with the JMPF, JMPT, or JMPL FSCs to perform a jump based on the operator’s response to a Yes/No prompt. See Test Decision Prompt under Runtime Prompts later in this section.


Post Test Module

When a MET/CAL procedure executes, a series of calibration tests is performed. As described earlier, each calibration test is made up of connection messages, setup steps, and an evaluation step. The evaluation step is always the last part of a test.

The MET/CAL Runtime application calls the Post Test module after each evaluation step. It also calls the Post Test Module after a system error, whether or not the error occurred in an evaluation step.

The Post Test module has three main functions:

  1. It resets the system instruments
  2. It generates results for the test that has just completed
  3. It displays the Post Test Dialog

System Instrument Reset

Whenever the Post Test module is called, whether because an error occurred, or because an evaluation step has been completed, one of the first things it does is reset the system instruments that are in use.

A system instrument is in use if the main procedure that is being executed, or any subprocedure it has called or may call, contains a reference to that system instrument. A reference is a use of an FSC that invokes the built-in driver for that instrument. For example, the Fluke 5700A is used by procedures that contain 5700 FSC statements. The statement need not have been executed in order for the instrument to be "in use."

It is possible to inhibit the normal resetting of the system instruments. To do this, clear the ASK 'Q' flag. Certain other ASK flags must be also clear (not set) in order to inhibit resetting of system instruments. Refer to the ASK+ and ASK- FSCs for details.

Post Test Dialog

This section describes the Post Test Dialog as shown in the figure below.

Post Test Summary

On the left-hand side, the Post-Test Summary dialog shows the following information:

Section 1

Test Field

The test field shows the test number and the test result. The test number is the major step number of the test. For example, test number 7 might look like the following:

  7.001  DISP         Connect...
  7.002  5700         1V             1%                                    2W

The test result is shown on the right-hand side of the Test field, and will be one of the following values:

  • PASS

    Indicates that the UUT is within the test tolerance at this test point, and is also within the adjustment threshold.

    The adjustment threshold is specified in the header of the main procedure being executed. The default value is 70%. If the error, expressed as a percentage of the tolerance, is less than the adjustment threshold the test result will be PASS.

  • MARGINAL PASS

    Indicates that the UUT is within the test tolerance at this test point, but not within the adjustment threshold.

    At some sites, the standard policy is to run the calibration adjustment procedure for a UUT if the UUT passes the verification procedure, but one or more test points generate a MARGINAL PASS result.

  • FAIL

    Indicates that the UUT is not within the test tolerance at the current test point, but is within the "significantly out of tolerance limit." See the description of this limit in the FAIL NOTIFY USER section below.

    The MET/CAL Configuration contains a setting named Pass 100% that allows the system to be configured with respect to whether or not a test is a PASS or a FAIL when the error is exactly equal to 100% of the test tolerance.

    • If checked, then the test result is MARGINAL PASS if the error is exactly equal to the test tolerance.
    • If unchecked, then the test result is FAIL if the error is exactly equal to the test tolerance.

    The default value (as distributed) is checked.

  • FAIL NOTIFY USER

    Indicates that the UUT is not within the test tolerance at the current test point, and also not within the "significantly out of tolerance limit."

    This limit is specified using the Out-of-Tolerance Limit MET/CAL Configuration setting.

    The purpose of the Out-of-Tolerance Limit setting is to allow a site to specify a limit above which a failing UUT is considered to be significantly out of tolerance, potentially requiring the recall of instruments recently calibrated or adjusted using the UUT in question.

    The default value of the Out-of-Tolerance Limit setting (as MET/CAL is distributed) is 100.0. This is a conservative setting, indicating that any UUT that fails at any test point will generate the FAIL NOTIFY USER test result.

Section 2

Error Field

The error is calculated as:

error = UUT Indicated – System Actual

If the NOMINAL units are dBm, the Nominal value is zero, the UUT Indicated value is zero, or the System Actual value is zero, the error is formatted as an absolute number.

Otherwise, the error is formatted as a percentage of either the UUT Indicated or the NOMINAL value, depending on the value of the Tolerance Reference MET/CAL Configuration setting.

For a Go/NoGo test the Error field is blank.

Error % Tol Field

For a numeric evaluation, this field shows the error expressed as a percentage of the test tolerance.

For a Go/NoGo evaluation this field is blank. This applies to instrument evaluations with ASK+ ‘G’ set, to EVAL statements, PICE statements, and to some DOSE statements.

Section 3

Range Field

The Range field shows the UUT range, as indicated in the RANGE field of the procedure statement just executed. The Range field shows "A" to indicate auto-range.

UUT Indicated Field

The UUT Indicated field shows the UUT Indicated value for the test. For a test in which the calibration standard is a stimulus device (like a Fluke 5700A), and the UUT is a measurement device (such as a Fluke 77), the UUT Indicated value is the reading taken by the UUT. If the test is a Go/NoGo test, the UUT Indicated field is blank on the Post Test dialog.

For a test in which the calibration standard is a measurement device (such as an HP 3458A), and the UUT is a stimulus device, the UUT Indicated value is the expected reading, as indicated in the NOMINAL field of the procedure statement that performed the evaluation step.

System Actual Field

The System Actual field shows the System Actual value for the test.

If the UUT is a measurement device, the System Actual is the true value applied to the UUT by the calibrator being used as a calibration standard.

If the UUT is a stimulus device, the System Actual is the measurement taken by the measurement device being used as the calibration standard.

MOD1 Field

The Post Test MOD1 field shows the information in the MOD1 field of the procedure evaluation step just executed. If you execute an evaluation step such as the following:

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
  1.001  5700         10kH           1%            1V                      2W

the evaluation is based on frequency (NOMINAL field), so you will see that MOD1 shows the voltage (1V in this example).

Section 4

Test Tolerance Field

The Test Tolerance field shows the test tolerance in units of the NOMINAL field. For example, suppose you execute the procedure evaluation step:

1.001 5700 100V 1% 2W

The test tolerance displayed in the Post Test dialog will be 1V, because 1V is 1% of 100V.

System Accuracy Field

The System Accuracy field shows the accuracy of the system instrument (calibration standard) used for the test.

For example, suppose you execute the following procedure evaluation step:

1.001 5700 200V 1% 2W

If the 90-day accuracy file for the 5700A is used, the system accuracy will be shown as 1.3mV. This is because in the accuracy file, for the 220V range, the tolerance is given as 6e-4 and the floor is 100e-6V. Note that the tolerance value in the accuracy file is a percentage.

The calculation is therefore:

system accuracy = 6e-4 * 0.01 * 200V + 100E-6V

... which is equal to 1.3mV, as shown in the Post Test dialog.

If the test in the procedure is a MEMC test in which the system accuracy is specified using an ACC statement, MET/CAL uses the value from the ACC statement and does not look up the system accuracy in one of the FSC-specific system accuracy files.

T.U.R. Field

The T.U.R. field shows the test uncertainty ratio for the test. The test uncertainty ratio is the ratio of the test tolerance to the system accuracy.

If the test tolerance or the system accuracy are specified in decibels (dBm), the quantity is converted to volts before it is used to calculate the T.U.R.

If the T.U.R. exceeds the TUR Limit specified in the MET/CAL Configuration settings, the Post Test dialog does not show the T.U.R. Rather, the dialog indicates that the T.U.R. is greater than the limit, and shows the limit.

The T.U.R. limit is specified by the TUR Limit setting in the MET/CAL Configuration. The default value for the limit is 4.0. The setting can be disabled by unchecking the box, which disables the calculation of the T.U.R. by the MET/CAL Runtime and MET/CAL Editor applications. If unchecked, the Post Test dialog does not show values in the Test Tolerance, System Accuracy, or T.U.R. fields.

Post Test Summary Dialog Buttons

On the right-hand side of the Post-Test Summary dialog are 8 buttons. These have the following functions:

Advance

Choosing Advance causes procedure execution to resume at the next step.

Repeat

The basic function of Repeat is to repeat the current step. The precise operation of Repeat depends on the current setting of the ASK 'P' flag in the procedure.

  • If the ‘P’ flag is set, the procedure is re-started at the current procedure line when the operator selects the Post Test Repeat option.
  • If the ‘P’ flag is not set, the procedure is re-started at the first statement of the current test. The step number of the first statement of the test has the form XX.001.

Note that when a test is repeated more than once (that is, executed more than twice), MET/CAL saves only the first and last results for that test step.

Cancel

Selecting Cancel is the same as Repeat (see above) except that when the operator chooses Cancel, the result of the canceled test is not saved. As with Repeat, the procedure step on which execution resumes is controlled by the current setting of the ASK ‘P’ flag.

The Post Test Cancel button can be disabled (grayed out) by not setting the ASK ‘X’ flag in the procedure. A MET/CAL Configuration setting named 'Enable Post Test CANCEL option, by default' controls the default state of the ASK ‘X’ flag.

  • If checked (or +), then the ASK ‘X’ flag will be set by default in a procedure that does not specify otherwise. This means that the Post Test Cancel button is enabled by default.
  • If unchecked (or –), then the ASK ‘X’ flag will not be set by default in a procedure that does not specify otherwise. This means that the Post Test Cancel button is disabled by default.

Default condition is checked, as MET/CAL is delivered.

Adjust

The Adjust button is enabled only if the error for the test just completed exceeds the adjustment threshold, and the procedure being executed contains an adjustment block for the current test step, and the ASK ‘J’ flag is set. There is some interaction between the ASK ‘J’, ‘A’, and ‘F’ flags. Refer to the ASK+ and ASK- FSC topics for details.

Procedures distributed by Fluke do not make use of in-line adjustment blocks. Separate verification and adjustment procedures are provided. When these procedures are used, the Adjust button will never be enabled.

Remark

Choosing Remark allows a remark of up to 32-characters to be entered. The entered remark is written to the results. Multiple remarks can be entered for one test step.

List

Choosing List causes a read-only listing of the current procedure to be displayed. When the listing is displayed, the current line (that is, the line just executed) is highlighted. The highlighted line can be changed using the Up Arrow, Down Arrow, Page Up, and Page Down keys, or by using the mouse to click on the line.

When MET/CAL Runtime first displays the listing, the input focus is on the Advance button. The Up Arrow, Down Arrow, Page Up, and Page Down keys will not work as expected until the focus has been moved to the list box that shows the procedure. This can be done using the Tab key, or by clicking on the list box.

The Procedure Listing window includes Advance and Terminate buttons. These are not the same as the Advance and Terminate buttons in the Post-Test Summary dialog. Choosing Advance in the Procedure Listing causes procedure execution to resume by executing the highlighted line.

It is important to realize that if you choose the Post Test List button, and then immediately choose Advance in the Procedure Listing window, you will re-execute the step that just completed. If you really just wanted to look at the procedure, and would like to resume execution as if you hadn't chosen List at all, you can choose Terminate in the Procedure Listing window, followed by Advance in the Post-Test Summary dialog, or you can move the highlighted line down one line in the Procedure Listing window, and then choose Advance there.

The ASK ‘L’ flag can be used to enable or disable the List option in the Post-Test Summary dialog.

Settings

Choosing the Settings button causes MET/CAL Runtime to display the last 18 settings created by the SET FSC. This allows the operator to verify that the UUT is set up correctly for the current test. This capability is used primarily in conjunction with calibration oscilloscopes. Refer to the SET FSC for details.

The Settings button is disabled unless one or more stored settings are available to be viewed.

Terminate

Choosing Terminate stops the execution of the procedure. Results generated before the procedure is terminated are not discarded, unless the operator subsequently chooses to discard them.

The Terminate button can be enabled or disabled by setting or clearing, respectively, the ASK ‘T’ flag. By disabling the Terminate and List options, a procedure writer can write a procedure that, barring errors, forces the operator to execute all of the tests in the procedure. Such a procedure should be carefully tested, however, because it can be difficult to terminate.


Test Results Window

As mentioned in the MET/CAL Runtime outline at the beginning of this chapter, the Test Results grid shows a one-line result for each test step in the Calibration Procedure. An icon is displayed to indicate the result of a test evaluation.

The contents of the Test Results grid are not cleared until a subsequent Calibration Procedure is started. That is, after you finish a Calibration Procedure and return to the top-level Run Time menu, you can still look at the results of the procedure in the Test Results grid. However, as soon as you start another procedure, or start to re-execute the same procedure, the Test Results grid is cleared.

The indicator icons in the Test Results grid are appear as follows:

indicates the test result is a PASS
indicates the test result is a MARGINAL PASS
indicates the test result is a FAIL

A PASS is a test in which the error, expressed as a percentage of the test tolerance, is less than or equal to the adjustment threshold.

A MARGINAL PASS is normally a test where the error, expressed as a percentage of the tolerance, is greater than the adjustment threshold, and less than or equal to 100%. The adjustment threshold is set in the header of the main procedure and is, by default, 70%.

A FAIL is normally a test in which the error, expressed as a percentage of the test tolerance, is greater than 100%.

The reason the above descriptions of MARGINAL PASS and FAIL say "normally" is that MET/CAL is configurable with respect to whether a test at exactly 100% of tolerance is considered a MARGINAL PASS or a FAIL.

  • If Pass 100% is checked in the MET/CAL Configuration settings, then exactly 100% of tolerance is regarded as a MARGINAL PASS and the error must be strictly greater than 100% in order for the test to be a FAIL.
  • If Pass 100% is unchecked, then exactly 100% of tolerance is a FAIL and the error must be strictly less than 100% in order for the test to be considered a PASS or MARGINAL PASS.

However, note that there may be cases when the value displayed in the %Tol field does not appear to agree with the PASS/FAIL result of the test. This happens when the actual error, expressed as a percentage of the tolerance, is rounded up or down and displayed as 100%. For example, if the error as a percentage of the tolerance is 99.9999%, it will be displayed as 100%, but the test will be a PASS (actually a MARGINAL PASS), even if Pass 100% is unchecked. This consideration is not specific to the Test Results grid. It also applies to the Post Test dialog (discussed elsewhere in this chapter), and to the formatted results that MET/CAL writes to the database.

If the operator terminates a test manually, the Test Results grid displays a one-line message indicating that the statement was terminated by the operator.

The Test Result grid can display a maximum of about 900 result lines from a single procedure run. If this limit is exceeded, the display functions as a first‑in/first‑out queue, always showing approximately the last 900 result lines. The content and format of the lines displayed in the Test Results grid are fixed and cannot be customized by the user.

For a normal instrument evaluation test, the Test Results grid shows:

RESULT | Test evaluation result
NO. | test step number
RANGE | UUT range (if specified)
UUT INDICATED | value indicated by UUT for test
SYSTEM ACTUAL | actual stimulus or measured value for test
C | Y if System Actual correct using a correction file, otherwise N
MODIFIER | MOD1 value from test, if any, -- often shows frequency
ERROR | absolute error (UUT Indicated - System Actual)
%TOL | error as a percentage of test tolerance

For evaluation steps based on EVAL, PICE, DOSE statements, or instrument Go/No Go evaluation steps, some of the information is not available, and the field will be blank in the Test Results grid.

For example, in a Go / No Go test the operator is simply asked if the UUT Indicated value is between a specified set of bounds. The answer is Yes or No, and does not indicate a numerical error. Because of this you will see OPER‑EVAL in the UUT Indicated column of the Test Results grid, and the Error and %Tol fields will be blank.


Safety Display

MET/CAL Runtime displays a safety indicator whenever a potentially dangerous voltage is being generated during procedure execution by one of the configured system instruments the procedure is using.

The safety indicator does not appear when a dangerous voltage is generated by a user-configured instrument, or by any instrument being controlled by the IEEE, IEEE2, SCPI, PORT, VISA, or LIB FSCs.

A dangerous voltage is any DC voltage greater than 60V, or any AC voltage greater than 42.4V (peak), unless modified in the MET/CAL Configuration settings.

Operators are cautioned not to rely only on MET/CAL's safety display as an indication of a dangerous voltage. There are two reasons for this:

  • First, instruments not under control by a built-in MET/CAL instrument driver do not cause the safety indicator to appear when a dangerous voltage is present.
  • Second, it is possible to manually override the setting of a calibrator so that it is generating an unsafe voltage without MET/CAL Runtime’s knowledge.

Always verify that instruments are in standby before touching the output terminals.

The MET/CAL Runtime application attempts to disable the operation of screen savers during procedure execution in order to prevent the safety indicator from being covered up by the screen saver display. However, some screen savers do not conform to the guidelines for screen savers, so it can happen that the safety indicator will be covered up by a screen saver.

Users are advised to disable screen savers when using the MET/CAL Runtime application to calibrate instruments.


Post Prompt Dialog

When a calibration is complete or the procedure is terminated, the MET/CAL Runtime displays the Post Prompt Dialog.

You can use the Post Prompt dialog to add administrative information necessary for the results. After adding the information, click OK. The figure below indicates typical information you can add to the results. Information entered on the Post Prompt Dialog can be included in the final calibration report.

Sample Post Prompt Dialog

The fields in the form may or may not be filled automatically, depending on how the prompt files are configured.


Post Run Results

After you close the Post Prompt dialog, the MET/CAL Runtime displays the completed MET/TEAM Work Order. All MET/TEAM Work Order functionality is available at this point in the test. Close the Work Order screen to complete the test. The Post Test Processing topic contains additional details related to Post Test Results.


Instruments

The Instruments category allows the user to configure references and standards for the workstation. The Instruments category is accessed from the Configure VIEW in MET/CAL Runtime or the Tools > MET/CAL Configuration Menu in MET/CAL Editor, or by pressing the F12 key at any time (except when a calibration is running). This category displays the instruments actively configured on the station. Each instrument in the configuration is uniquely identified by its instrument name shown in the list. Use the Add, Edit, and Delete buttons on the dialog to modify the configuration as required based on the available hardware.

You may access the Instruments category from only one application at a time., Runtime or Editor.

MET/CAL Runtimeand MET/CAL Editor maintain the list of configured instruments. The associated traceability information for configured instruments is stored in the database. Before you can use calibration instruments, you must identify which instruments are configured in the system. A configured instrument is a traceable calibration standard. There are three types of configured instruments: User Configured Instrument Dialog, System Instrument Dialog and Manual Instruments. When configuring a new instrument, remember to also add traceability information to the database.

The Instruments tab in the right pane lists all configured instruments. You can also specify which instrument is the frequency reference by selecting the checkbox in the row for the desired instrument. If there is no checkbox present, this instrument cannot be set as a frequency reference. The “Accuracy File Lookup Mode” is associated with the frequency reference.

Add Instrument

To add an instrument to the workstation, click the Add button. Locate the instrument to add and click the OK button.

The instrument’s configuration dialog is displayed. Configure the instrument’s settings and click OK to close the dialog and save the changes.

Edit Instrument

To edit an existing instrument, select the instrument in the Instruments list and click the Edit button. The instrument’s configuration dialog is displayed. Make the changes needed and click OK to close the dialog and save the changes.

To remove an existing instrument, select the instrument in the Instruments list and click the Delete button.

Delete Instrument

Delete a previously configured instrument. You must select an instrument in the current configuration list box before selecting Delete. The Delete button is grayed out when no instrument is selected in the list box.


Instrument Control

The Instrument Control category includes instrument communication related settings such as for RS-232 and IEEE-488 interfaces.

This configuration screen is accessible to both MET/CAL Runtime and MET/CAL Editor. The functionality is the same but the appearance may differ slightly. The MET/CAL Editor screen is contained within its own window and the buttons are labeled differently:

  • Apply/Discard buttons in MET/CAL Runtime
  • OK/Cancel buttons in MET/CAL Editor

Default RS-232 Port

Specifies the default serial port to be used for RS-232 controlled UUTs. None may be used when the COM port is specified by the VSET FSC PORT parameter, COM1 through COM16 are PC serial ports, and the remaining choices refer to the Fluke calibrator's SERIAL 2 TO UUT port.

IEEE-488 Num. Boards

Specifies the number of IEEE-488 boards configured in the system.

IEEE-488 Port 0 and Port 1 SRQ

Controls how MET/CAL handles the situation in which a device on IEEE-488 port is requesting service just prior to the start of procedure execution.

Error
MET/CAL does nothing. This means that Post Test will report that the first statement in the procedure was terminated by an SRQ. This is not very satisfactory when a user-configured system instrument always asserts a power-on SRQ and can't be configured otherwise. This option is provided for compatibility with previous versions of MET/CAL. It will turn off the whole check.
Prompt
Just prior to starting to execute a procedure MET/CAL will check to see if there's an SRQ on the IEEE-488 board. If there is, the addresses of all configured instruments listening on the port are serial polled until a device which acknowledges the SRQ is found. If such a device is found, and the SRQ condition was successfully cleared by the serial poll, the operator is prompted to see if he wishes to continue or to abort the procedure.
Clear
MET/CAL does the same thing it does for Prompt, except there's no prompt to the operator. That is, if the serial poll successfully clears the condition, MET/CAL goes forward as if it hadn't happened.

Default: Prompt

IEEE-488: "Find Listener" Delay (Optional)

MET/CAL searches the IEEE-488 bus (port 0) before initial procedure execution to determine the addresses of instruments on the bus, and to cross-check against the instrument configuration for the workstation.

For some devices, the IEEE-488 address search does not work correctly because the instrument is too slow to correctly handle the IEEE-488.2 "Find Listeners" protocol. In particular, the Data Proof 160B Scanner answers at multiple IEEE-488 addresses if the "Find Listeners" check is allowed to run too quickly.

IEEE2/SCPI Query Delay (Optional)

Specifies a delay used in IEEE2 and SCPI query operations. Any delay > 0 ms is executed after the command has been sent the expected SRQ has been received, but before a read operation to retrieve the instrument's response. Default = 20 ms.

8902/8903 Serial Poll Slow

Enables a special slowed down serial poll routine for HP 890x instruments. The value specifies the delay, in milliseconds, to be inserted into the middle of the serial poll. Legal values are 0 to 1000 ms, the default is 500 ms. Setting to 0 disables the feature altogether, causing the normal serial poll routine to be used. Note that the special slow serial poll routine is in any case applied only to HP 890x instruments, and then only if two or more of them are configured.

Pre-serial Poll Delay

Specify the delay to be used in MET/CAL's wait-for-SRQ retry loop. The delay affects both IEEE statements which use an SRQ construction and the built-in wait-for-SRQ operation used in the IEEE2 and SCPI FSCs. The default is zero (0).

The specified delay has no effect unless Serial Poll Retries is greater than zero. In other words, the specified delay takes effect only in situations where MET/CAL is waiting for an SRQ, an SRQ is detected, but the waited-for device does not acknowledge the SRQ when it is serial polled. The reason Serial Poll Retries must be at least one in order for this delay to be meaningful is that if MET/CAL has not been instructed to retry the serial poll, there's no point in delaying after the initial serial poll.

Also see SRQDELAY in the VSET FSC topic.

Post-serial Poll Delay

Specify the delay to be used prior to the initial serial poll in MET/CAL's wait-for-SRQ operation. This delay affects both IEEE statements which use an SRQ construction and the built-in wait-for-SRQ operation used in the IEEE2 and SCPI FSCs. The default is zero (0).

The preferred method to specify this delay is to use VSET and/or TSET statements to specify SRQHOLDOFF on an as-needed basis. The vast majority of instruments do in fact acknowledge the service request when immediately serial polled after an SRQ has been detected. Therefore, specifying a non-zero value here would unnecessarily penalize all instruments. (Of course, if the delay is very small, it might not be noticed.)

Serial Poll Retries

Specify the maximum number of serial poll retries in MET/CAL's wait-for-SRQ operation. This delay affects both IEEE statements which use an SRQ construction and the built-in wait-for-SRQ operation used in the IEEE2 and SCPI FSCs. The default is zero (0).

The general approach used by MET/CAL when it waits for an SRQ is as follows:

  1. Wait (up to a specified timeout) for the system to detect an SRQ. Any SRQ terminates this operation.
  2. As soon as an SRQ has been detected, serial poll the device from which the SRQ was expected. MET/CAL expects the device to respond, per the IEEE-488 standard, by returning a status byte in which the RQS bit is set.

Specifying a value greater than zero instructs MET/CAL to retry step (2), as needed, up to the specified number of times.

Retrying is useful only in cases where a device is slow to acknowledge the SRQ. It is not useful, however, if any of the following conditions occur:

  • An SRQ is detected from a device on a different IEEE-488 interface.
  • The waited-for device is not IEEE-488 compliant. I.e., the device generates and SRQ, but never acknowledges it by setting the RQS bit in the status byte.

Also see SRQRETRY in the VSET FSC topic.


Instrument Configuration

The Instrument Configuration category includes settings for many model-specific instruments as well as some general instrument related settings.

This configuration screen is accessible to both MET/CAL Runtime and MET/CAL Editor. The functionality is the same but the appearance may differ slightly. The MET/CAL Editor screen is contained within its own window and the buttons are labeled differently:

  • Apply/Discard buttons in MET/CAL Runtime
  • OK/Cancel buttons in MET/CAL Editor

The Instrument Configuration category has two tabs for settings.

Instrument Config Tab

2000 SRQ SDC (Optional)

Controls whether the Keithley 2000 driver clear function sends a Selected Device Clear (SDC) to the instrument after the non-error Service Request (SRQ) has been processed. Default = Unchecked.

2001/2002 SRQ SDC (Optional)

Controls whether the Keithley 2001 and 2002 driver clear function sends a Selected Device Clear (SDC) to the instrument after the non-error Service Request (SRQ) has been processed. Default = Unchecked.

34401A SRQ SDC (Optional)

Controls whether the HP 34401A driver clear function sends a Selected Device Clear (SDC) to the instrument after the non-error Service Request (SRQ) has been processed. Default = Unchecked.

34420A SRQ SDC (Optional)

Controls whether the HP 34420A driver clear function sends a Selected Device Clear (SDC) to the instrument after the non-error Service Request (SRQ) has been processed. Default = Unchecked.

4000(A), 4200(A), 47xx, 48xx(A) SRQ SDC (Optional)

Controls whether the Datron 4000(A), 4200(A), 47xx, 4800(A) driver clear function sends a Selected Device Clear (SDC) to the instrument after the non-error Service Request (SRQ) has been processed. Default = Unchecked.

E4418A/B, E4419A/B SRQ SDC (Optional)

Controls whether the HP/Agilent E4418A/B and E4419A/B driver clear function sends a Selected Device Clear (SDC) to the instrument after the non-error Service Request (SRQ) has been processed. Default = Unchecked.

8903 Model Suffix

Specifies the particular model of the user's HP 8903 (if any). The default is HP 8903B. The fact that the default is HP 8903B has no significance when there's no HP 8903 at all in the system. The reason it is necessary to have this parameter is that no method has been determined by which MET/CAL can query an HP 8903 to determine it's type (A, B, or E).The real need is simply to determine: Is it or is it not an HP 8903A? i.e., the code will not behave differently if set to B rather than E. (In the future, this could change, however.)

8901A/B Data Avail. Timeout (Optional)

Specifies the timeout used in the 8901A/B driver's measurement loop while waiting for Data Available (DAVL). The same timeout value is also used in the Tuned RF recalibration function. Default = 60 s.

525A/B

525A IEEE-488

Controls whether to allow the configuration of the Fluke 525A on an IEEE-488 interface.

Terminator IEEE-488 to RS-232 Converter

Specifies the input terminator for the 525A driver when the 525A is configured as an IEEE-488 device. If a 525A is controlled by an IEEE-488 to RS-232 converter, this must be set to CR.

Pressure Module Timeout

Specifies the time allowed for the 525A, 525B, and 7526A to identify an attached pressure module. The timeout applies to both 525A series and 700 series pressure modules. It has been determined (by testing) that the 525A takes up to 37 seconds to determine the ID of an attached pressure module after a switch from voltage mode to pressure mode (usually it takes 8 seconds, but some scenarios may trigger the 37 second time). Default > 37 s.

9100

Near Cal Due SRQ (Optional)

Controls whether or not the 9100 drivers display instrument-generated "Near Cal Due" service requests. If checked, the warning will be displayed once per procedure (regardless of how many times the instrument generates the service request). Default = Unchecked.

Past Cal Due SRQ (Optional)

Controls whether or not the 9100 drivers display instrument-generated "Past Cal Due" service requests. If checked, the warning will be displayed once per procedure (regardless of how many times the instrument generates the service request). Default = Unchecked.

Manufacturer

In the event that the manufacturer names accepted by the 9100 driver do not conform to firmware in the actual 9100 used, the manufacturer names may be overridden on a per-workstation basis by specifying them here.

Instrument Config (Continued) Tab

9500

Near Cal Due SRQ

Controls whether or not the 9500 drivers display instrument-generated "Near Cal Due" service requests. If checked, the warning will be displayed once per procedure (regardless of how many times the instrument generates the service request). Default = Unchecked.

Past Cal Due SRQ

Controls whether or not the 9500 drivers display instrument-generated "Past Cal Due" service requests. If checked, the warning will be displayed once per procedure (regardless of how many times the instrument generates the service request). Default = Unchecked.

Manufacturer

In the event that the manufacturer names accepted by the 9500 driver do not conform to firmware in the actual 9500 used, the manufacturer names may be overridden on a per-workstation basis by specifying them here.

N5532A/B

These parameters are used to set the frequency crossover points for Agilent N5532A sensor modules and are used in conjunction with the N5531 FSC. These settings may be overridden with VSET FSC statements. Refer to the N5532A portion of the VSET FSC topic for more information.

PM 668x

SRQ SDC

Controls whether the Philips PM 6680, PM 6681, and PM 6685 driver clear function sends a Selected Device Clear (SDC) to the instrument after the non-error Service Request (SRQ) has been processed. Default = Unchecked.

Driver SRQ delay (Optional)

Specifies the delay after certain SRQs in the 668x driver. For most users, no delay is needed. Default = 0 ms.


Database

The Database category includes settings related to the database connectivity. The Database category settings consist of the URL for the MET/TEAM server. Changing this setting will require a restart of the Runtime application. It is not common for this setting to be changed.

MET/TEAM Server URL

Define the URL to the MET/TEAM website. The same information entered into a web browser to access the MET/TEAM website should be entered in this parameter. The typical URL is the path to the Server PC followed by the port of the website. The website can be defined on the same PC, on an Intranet site or on an Internet site. In all cases the URL should represent the MET/TEAM landing page.

When running the server and MET/CAL on the same PC, the default website is: http://localhost:35853/


Simulation Mode

The Simulation Mode category includes settings related to running calibrations in simulation mode.

This configuration screen is accessible to both MET/CAL Runtime and MET/CAL Editor. The functionality is the same but the appearance may differ slightly. The MET/CAL Editor screen is contained within its own window and the buttons are labeled differently:

  • Apply/Discard buttons in MET/CAL Runtime
  • OK/Cancel buttons in MET/CAL Editor

Simulation mode can be toggled on or off using the LIVE/SIMULATION switch in the upper right on the main Runtime window. When running in simulation mode, the settings in this category are used.

Prompt for IEEE-488 Addresses

Determines whether the IEEE FSC should prompt the operator (when necessary) for the IEEE-488 address in demo mode. For compatibility with previous versions of MET/CAL, if this is not specified, the default is Yes.

Runtime Demo Prompt

Determines whether MET/CAL Runtime should display an informative prompt when a procedure is executed in demo mode.


Files and Folders

The Files and Folders category includes settings related to various files and folders that the application uses.

This configuration screen is accessible to both MET/CAL Runtime and MET/CAL Editor. The functionality is the same but the appearance may differ slightly. The MET/CAL Editor screen is contained within its own window and the buttons are labeled differently:

  • Apply/Discard buttons in MET/CAL Runtime
  • OK/Cancel buttons in MET/CAL Editor

The Files and Folders category has two tabs for settings: Files and Folders.

Files Tab

The Files tab consists of settings that reference various files that are used by the application.

Instrument Config. File

Where MET/CAL stores configured instrument information.

Error Log File

Where MET/CAL stores its error log file.

Fail Prompt File

Specifies the name of the post-run prompt file used when the overall result is a fail.

Guardbanding Init File

Specifies the location of the guardband initialization file. See the GB_INIT parameter of the VSET/TSET FSC for more information.

Guardbanding Table File

Specifies the location of the guardband table file. See the GB_TABLE parameter of the VSET/TSET FSC for more information.

Pass Prompt File

Specifies the name of the post-run prompt file used when the overall result is a pass.

Prompt File

Specifies file used for pre-run prompts.

Variable File

Variable file.

Folders Tab

The Folders tab consists of settings that reference various folders or directories that the application uses.

792A Data File Folder

Directory where MET/CAL looks for 792A data files.

Accuracy File Folder

Directory where MET/CAL looks for accuracy files.

Accuracy File Folder Primary (Optional)

Directory where MATH FSC ACCF functions look for accuracy files.

  • If the procedure specifies the full path name of a file, that specification takes precedence.
  • If the procedure does not specify the full path name and this directory is not specified, the Accuracy File Folder is used.

Correction File Folder

Directory where MET/CAL looks for correction files.

General INI Folder

Directory where MET/CAL looks for data files accessed using the RIF and WIF MATH FSC functions. Refer to the RIF/WIF Data Directory section for more information.

Instrument Info Folder

Directory where MET/CAL looks for the Instrument Information file named user_config_instr.ini used by the MATH FSC RINF and RINFE functions.

Math Info Folder

Directory where MET/CAL looks for math files.

Picture Folder

Directory where MET/CAL looks for picture files.

Procedure Folder (Compiled)

Default compiled procedure directory.

PXE Procedure Folder

Default PXE directory. This parameter is set and updated automatically by MET/CAL Runtime.

Shared Folder

Directory for shared MET/CAL files.

User Current Working Folder

Specifies the working directory for user programs. That is, it becomes the current directory for an executing user program. Unless otherwise specified (see User Program Folder), it also becomes the directory where MET/CAL looks for user programs (unless a full path or partial path specification is given in the procedure), and becomes the directory where the DOS/DOSE data file is created and accessed (see User Data Folder).

User Data Folder

Specifies the location of the DOS/DOSE data file. If specified, it takes precedence over any User Current Working Folder specification.

User Program Folder

Specifies the directory where user programs reside. If specified, it takes precedence over any User Current Working Folder specification.

This specification has no effect on a DOS or DOSE procedure statement which gives a full path specification for the user program. For example, this DOS statement executes the myprog.exe in c:\metcal regardless of what User Program Folder is specified: DOS C:\metcal\myprog.exe

If the DOS or DOSE statement provides a partial path specification, the partial path specification is relative to the User Program Folder specification (if any). For example, if this parameter specifies: C:\metcal, and a DOS statement in a procedure specifies: DOS exe\myprog.exe, then MET/CAL executes the program C:\metcal\exe\myprog.exe.

Workstation Folder

This is the directory where all workstation specific files and temporary files are stored. For example the workstation instrument configuration file is typically stored in this directory.


Metrology

The Metrology category includes settings related to the application’s process of taking measurements.

This configuration screen is accessible to both MET/CAL Runtime and MET/CAL Editor. The functionality is the same but the appearance may differ slightly. The MET/CAL Editor screen is contained within its own window and the buttons are labeled differently:

  • Apply/Discard buttons in MET/CAL Runtime
  • OK/Cancel buttons in MET/CAL Editor

The Metrology category has two tabs for settings.

Metrology Tab

Accuracy Check

Controls whether or not accuracy file headers are read and cross-checked against the database.

Yes
The following steps are performed:
  1. Determine the instrument name associated with the FSC (example FSC: 5700, instrument name: Fluke 5700A).
  2. Retrieve the asset number associated with the instrument name from the instrument configuration.
  3. Retrieve the calibration interval for the asset from the database.
  4. Search the MET/CAL accuracy file directory for an accuracy file with a header which contains the same instrument name and interval.
No
fsc.acc in the MET/CAL accuracy file directory is unconditionally used for accuracy information for the FSC specified.

Default: Yes

Enable Corrections when ASK C- is not specified in procedure

Allows the default state of the ASK C-flag to be set. For MET/CAL V4.2 and previous, this setting did not exist, and the default was ASK+ C. Therefore, for compatibility with previous versions of MET/CAL, if this parameter is not specified, the default is yes (ASK+ C). To change the default to ASK- C, it is necessary to set this parameter to No.

Exact Correction Value Lookup Match

Determines what is printed in the corrected column (C) in the test results grid when an exact match is obtained for the system actual value in a correction file. Default = No.

Yes
X is printed in the corrected column when an exact match is obtained.
No
Y is printed in the corrected column when an exact match is obtained.

Partial Path is Relative to Accuracy Directory

This setting pertains to file locations specified by the ACCF FSC.

Yes
Partial path names are taken to be relative to the Accuracy File Folder.
No
Partial path names are taken to be relative to the User Current Working Folder.

Pass 100%

Specifies whether a test passes at 100% of tolerance or not.

Revert to using MEM for MEMCX Nominal when (tol_ref = Nominal)

If checked, reverts to using MEM for the MEMCX Nominal when Tolerance Reference = Nominal.

Suppress Error Message when Reference Accuracy is Zero

Checking this box causes MET/CAL to suppress the error message generated when the reference accuracy is zero. Default = unchecked.

The purpose of the RefAcc() function is to retrieve the reference accuracy determined in a preceding setup statement in the current test. Prior to the introduction of RefAcc(), MET/CAL was forgiving about the situation where the reference accuracy is zero. The TSR calculation ignores a reference accuracy of zero. Since the reference accuracy is the denominator of the TSR, the rationale is that the TSR must be greater than 4, because an "infinitely accurate" reference has to be much more accurate than the UUT.

The measurement uncertainty calculation doesn't ignore the reference accuracy, but it's inconsequential in the sense that it simply contributes nothing to the overall measurement uncertainty calculation. That is, RSS(0, v1, v2, ...) is the same as RSS(v1, v2, ...). However, RefAcc() regards a zero reference accuracy as an error condition. This error condition is detected regardless of whether the procedure includes calls to the RefAcc() function.

This can be problematic when looking up the accuracy in a MET/CAL accuracy file where the reference instrument is a sensor (meter), the NOMINAL value is zero, and the instrument's specification does not include a floor component. An example of this problem occurs when using an Agilent 4418B power meter. A 4418 statement with "0pct" in the NOMINAL field causes an error message to be generated when MET/CAL attempts to lookup the accuracy of the 4418 at 0%.

Accuracy File Interval Conflict

Determines how to resolve conflicting accuracy files: error, use shortest cal interval, or use longest cal interval.

Measurement Uncertainty File Format

Specify the format of the measurement uncertainty output file. See the MFILE_FORMAT section of the VSET FSC for more information.

Self Calibration

Specifies the action MET/CAL takes it is determined that UUT asset number is the same as that of a required configured instrument.

Yes
The workstation is configured to unconditionally allow self-calibration.
No
The workstation is configured to unconditionally disallow self-calibration. If the UUT asset number is the same as the asset number of a required instrument, an error message is generated.
Warn
The workstation is configured to conditionally allow self-calibration. If the UUT asset number is the same as the asset number of a required instrument, the operator is prompted to see if procedure execution should be continued or aborted.

Tolerance Reference

Specifies the reference value for the calculation of the test tolerance. The default is UUT_Indicated. This setting has no effect unless the TOLERANCE field specifies the test tolerance as a percentage or PPM value. The following calculated quantities are affected by the Tolerance Reference setting:

  1. Test Tolerance

    If Nominal is selected, the test tolerance is calculated with respect to the Nominal value. If UUT_Indicated is selected, the test tolerance is calculated with respect to the UUT Indicated value. Example:

    Suppose you have a MET/CAL test like:

    ASK+ K
5500 10V 1%

    Suppose also that the UUT (a meter) reads 10.1V. If Nominal is selected, the test tolerance is ±0.1 V, because 0.1 V is 1% of 10 V. If UUT_Indicated is selected, the test tolerance is ±0.101, because 0.101 is 1% of 10.1 V.

  2. Test Uncertainty Ratio (T.U.R.)

    The test tolerance is the numerator of the T.U.R., so changing the test tolerance calculation changes the T.U.R.

  3. Error

    Except in some special cases (like dBm in the NOMINAL field), MET/CAL displays the error for a particular test as a percentage. If UUT_Indicated is selected, the error is displayed as a percentage of the UUT Indicated value. If Nominal is selected, the error is displayed as a percentage of the Nominal value.

  4. Error % Tol

    MET/CAL calculates the error for a test as the difference between the System Actual and the UUT Indicated. It then displays the error as a percentage of the test tolerance. Since the test tolerance is affected by the Tolerance Reference setting as described above, the error expressed as a percentage of the test tolerance is also affected by Tolerance Reference.

It is important to remember that Tolerance Reference makes a difference only for tests where the UUT Indicated and Nominal values are different.

If the system instrument is a source instrument (like a 5700A or 5500A), and the UUT is a meter, Tolerance Reference makes a difference for keyboard-entry (ASK+ K) and closed-loop tests, but does not make a difference for tests where the actual output of the calibrator is slewed until the meter reading matches the Nominal value.

Use Student's T

Controls whether or not to make use of the Student's T distribution in the measurement uncertainty calculation. (Actually, this parameter can be set at 3 levels: procedure, this setting, or database, and the precedence is in the order listed (highest to lowest).)

Yes
Indicates that the Student's T distribution should be used in the measurement uncertainty calculation, unless an overriding VSET specification exists in the procedure.
No
Indicates that the Student's T distribution should not be used in the measurement uncertainty calculation, unless an overriding VSET specification exists in the procedure.

UUT Confidence

Specifies the value of the confidence parameter used in the measurement uncertainty calculation. The confidence setting here may be overridden by the procedure using the VSET FSC.

Reference Accuracy Factor (Optional)

Controls a reference accuracy check done in the TUR calculation. The check is essentially this: if the reference accuracy is better than 1 part in the (inverse of the specified reference accuracy factor), then the TUR calculation is not done and zero is reported as the TUR value in the Results Table.

For example, if the reference accuracy factor is 1E-9, then the reference cannot have an accuracy better than 1 PPB if the TUR is to be calculated. The underlying purpose of this check is to prevent division by zero and floating overflow when the TUR is calculated.

Default = 1E-13.

Metrology (Continued) Tab

Database to Accuracy File Interval Match and Interval Match

Affects the matching of a cal interval for an asset, as read from the database, against a cal interval specification in an accuracy file header. These parameters are design to protect against units conversion problems which may arise in converting between days, months, and years. For example, one would like "1 year" to be the same as "360 days".

MATH FSC Conversion Precision

Specify the epsilon factor used in MATH comparisons which involve relational operators. The default value is 13 (i.e. 1E-13).

Internally, MET/CAL uses double-precision floating-point values to represent numeric register values. Because binary floating-point numbers cannot exactly represent many real numbers, and also because certain arithmetic operations and functions may not procedure exact results, there is a possibility that relational comparisons may produce unexpected results. Relational comparisons are comparisons which one of the relational operators: <, <=, >, >=, ==, !=.

To address this issue, the MATH FSC makes uses of an epsilon factor. With the "==" operator, for example, using the default epsilon factor means that two numbers will be considered by MET/CAL to be equal if they are within one part in 10^13 of one another. As a special case, setting this to zero causes relational comparisons to be done using exact double-precision floating-point arithmetic.

Out-of-Tolerance Limit

Specifies the Significantly Out-of-Tolerance limit. This limit sets the threshold above which a significantly Out-of-Tolerance (OOT) warning is generated to notify the user of the UUT about this condition. The most conservative value, and the one that Fluke recommends, is 100 (%), so that every Out-of-Tolerance condition causes a Notify User warning.

Checking the Enable box for the following parameters adds the associated parameter to the MET/CAL Initialization File. Unchecking the Enable box removes the parameter. See the following resources for important information about how this may impact MET/CAL procedure results:

  • Tutorial: Implement Measurement Uncertainty in a MET/CAL Procedure
  • Settings Inheritance section of the VSET help topic
  • Guardbanding.pdf manual, included with MET/CAL

Guardband Factor

Enable or disable, and define the guardband factor for use when the guardband method is Direct or MU. See the GBF section of the VSET help topic for more information. See the important note above about the effects of checking or unchecking the Enable box.

No. of Measurements for Uncertainty Calc.

Enable or disable, and specify the number of measurements to take for the measurement uncertainty calculation. See the NMEAS section of the VSET help topic for more information. See the important note above about the effects of checking or unchecking the Enable box.

No. of Measurements to Throw Away

Enable or disable, and specify the number of measurements to discard before starting the sequence of measurements to be saved for the measurement uncertainty calculation. See the NTHROW section of the VSET help topic for more information. See the important note above about the effects of checking or unchecking the Enable box.

No. of Significant Digits

Enable or disable, and specify the number of significant digits in the reported values of the expanded uncertainty (EXP_UNC), the standard uncertainty (STD_UNC), and the coverage factor (COV_FAC). See the NSD section of the VSET help topic for more information. See the important note above about the effects of checking or unchecking the Enable box.

TUR Limit

Enable or disable, and specify the Test Uncertainty Ratio (TUR) limit. If a TUR in a procedure is below the limit set, a warning is displayed when the statement is compiled. If this parameter is 0, no TUR warnings are generated. See the important note above about the effects of checking or unchecking the Enable box.

Traceability

User-Configured Instrument CLEAR sets Device Used

Executing a CLEAR FSC will not cause the instrument will not appear in the "standards used" list in the database results associated with the calibration record, unless this setting is checked. Default = unchecked.

User-Configured Instrument RESET sets Device Used

Executing a RESET FSC will not cause the instrument will not appear in the "standards used" list in the database results associated with the calibration record, unless this setting is checked. Default = unchecked.

In Calibration Is Required

Determines whether MET/CAL displays a prompt which asks the user if they wish to continue when a required instrument is out-of-cal. If this is not specified or set to No, a prompt is displayed which asks the user if they wish to continue with the out of cal instrument. If this is Yes, an out-of-cal instrument causes no warning or prompt.

Reference Serial No. Check

MET/CAL Runtime cross-checks the serial number of a connected system instrument against the serial number of the asset configured in the database, by default. This feature applies only to system references which allow the serial number to be remotely queried. It does not apply to user-configured references (i.e. references for which there is no MET/CAL FSC).

  • The serial number check is not performed in the MET/CAL Editor's Debug Mode.
  • The serial number check is not performed in Simulation Mode.

This setting has 3 legal values:

  1. Yes - Cross-check the serial number and abort the procedure if a serial number mismatch is detected.
  2. No - Do not cross-check the serial number.
  3. Warn - Cross-check the serial number. If a mismatch is detected present a dialog to give the user the option of aborting the procedure or ignoring the mismatch.

The default value is Yes. If you do not want MET/CAL to perform this check you must select No.


Post Test Dialog

The Post Test Dialog category includes settings related to the Post Test dialog.

Enable Post Test 'Cancel' option, by default

Control the default appearance of the Cancel button in the Post Test window. This setting may be overridden by the procedure using the ASK X-flag.

  • If this setting is checked, the Cancel button in the Post Test window is enabled.
  • If this setting is unchecked, the Cancel button in the Post Test window is disabled.

Enable Post Test 'Repeat' option, by default

Control the default appearance of the Repeat button in the Post Test window. This setting may be overridden by the procedure using the ASK Z-flag.

  • If this setting is checked, the Repeat button in the Post Test window is enabled.
  • If this setting is unchecked, the Repeat button in the Post Test window is disabled.

Post-Test List - Highlights Current Step (Optional)

Controls how the initial highlight is determined in the Post Test "List" option. If checked, the initial highlight is the current (i.e. just-executed) procedure step. If unchecked, the initial highlight is determining by searching backward from the just-executed step to find the first TARGET or TARGET -p, if any, or the start of the current major step.


Results

The Results category includes settings related to the display of calibration results.

This configuration screen is accessible to both MET/CAL Runtime and MET/CAL Editor. The functionality is the same but the appearance may differ slightly. The MET/CAL Editor screen is contained within its own window and the buttons are labeled differently:

  • Apply/Discard buttons in MET/CAL Runtime
  • OK/Cancel buttons in MET/CAL Editor

Blank Line in Results for Empty Brace {} (Optional)

Controls whether or not empty brace data causes a Results Table line to be generated. Default = Checked, which means that, by default, MET/CAL will generate a result table line based on empty brace data (e.g. HEAD {}).

Test Description Leading Spaces (Optional)

Determines whether the result variable Test Description should include prepended leading spaces based on the number of digits to the left of the decimal point in the specified RANGE field value. If the RANGE field is not specified, or no literal numeric RANGE field value is specified, no leading spaces are prepended, regardless of this setting.

Result Save Mode for Repeated Tests

Specifies the mode for saving repeated test results. Default = First and Last Result. Note: this setting may be overridden using the VSET FSC RSM parameter.

All Results
Save all executions
First and Last Result
Save first and last execution only
Last Result
Save last execution only


Runtime Configuration

The Runtime Configuration category includes settings that are specific to the Runtime application itself.

Display REMOVE ALL CONNECTIONS Message

Controls whether or not to display the "Please Remove All Connections.." message at procedure termination.

Evaluate Special Constructions in DOS/DOSE Statements

Controls whether or not MET/CAL special constructions should be evaluated when they appear in arguments to user programs in DOS/DOSE procedure statements.

Default: Yes

Measurement Uncertainty Setup and NOMSET Repeat

Control the behavior of instrument SETUP and NOMSET statements in MEMC and MEMCX tests on the second and subsequent pass through the test for the measurement uncertainty calculation. A VSET specification of MEMC_IRPT overrides this setting.

  • When checked, they are repeated.
  • When unchecked, they are skipped.

Pay attention to DOS/DOSE FSC program exit code

Specifies whether MET/CAL should pay attention to the exit code of a user program invoked by the DOS or DOSE FSC. An individual DOS or DOSE FSC statement may override this setting by specifying either -x (pay attention) or -i (ignore) as an argument on the procedure line. Default = Unchecked.

Procedure Section Selection

Set this property to "no" to prevent the Procedure Section Selection dialog from displaying. With the interface disabled, the operator will not be able to select sections and the procedure will run all sections as if there were no sections defined.

Reference measurement PLEASE WAIT (Optional)

Determines whether or not the MET/CAL meter drivers display a "Please wait"-type busy message while taking readings. Default = Checked.

Required Standard Prompt

Indicates whether or not MET/CAL Runtime should prompt for the asset numbers of required instruments whose asset numbers are not specified in the System Configuration File.

Show Required Instruments Dialog

Determines whether the list of required instruments is shown to the operator prior to procedure execution.

UUT Asset Number Prompt (Optional)

If checked, MET/CAL Runtime prompts for the asset number of the UUT before scanning the main and sub procedures to build the required instrument list. The setting has no effect on the MET/CAL Editor Debug Mode.

Replace Go-NoGo in Results Window

Text to replace "OPER-EVAL" in Test Results and Post Test windows.

Post Run Procedure

Name of the Post Run procedure.

System Type

Sets a system flag which is used to determine whether automatic range messages are generated with the "/div" (per division) suffix. Also affects the slew message generated by some instrument FSCs.

Display Language

Defines which language table to use to generate messages and populate program menus. Note that the MET/CAL Editor is not translated and will display in English regardless of this selection.

Runtime Prompt Beep

Beep On

Enables or disables one or more beeps when an operator message or prompt is displayed.

Allow User to Interrupt

Terminate the beep sequence when the user responds to the prompt. Specifying this without a Count indicates that beeping should continue until the user responds to the prompt, without any maximum number of beeps.

Delay

Inter-beep delay in seconds.

Count

Number of beeps.


Safety

The Safety category includes settings related to safety warnings that the software generates automatically.

This configuration screen is accessible to both MET/CAL Runtime and MET/CAL Editor. The functionality is the same but the appearance may differ slightly. The MET/CAL Editor screen is contained within its own window and the buttons are labeled differently:

  • Apply/Discard buttons in MET/CAL Runtime
  • OK/Cancel buttons in MET/CAL Editor

DC Voltage Safety Threshold

Specify the DC Voltage threshold at which the safety symbol appears.

Peak AC Voltage Safety Threshold

Specify the peak AC Voltage threshold at which the safety symbol appears.


Temperature and Humidity

The Temperature & Humidity category includes settings related to the collection and use of ambient temperature and humidity data.

This configuration screen is accessible to both MET/CAL Runtime and MET/CAL Editor. The functionality is the same but the appearance may differ slightly. The MET/CAL Editor screen is contained within its own window and the buttons are labeled differently:

  • Apply/Discard buttons in MET/CAL Runtime
  • OK/Cancel buttons in MET/CAL Editor

Data File

The full path name of the data file you specified when you configured the MCRHT Logger Program. Assuming that the MCRHT Logger Program configuration has been completed, the data file will already exist and you can browse for the data file by choosing the Browse button (...).

Asset

The asset number of the RHT. This does not need to be specified unless you choose to regard the RHT itself as a traceable asset for each calibration performed by the Runtime. Refer to the descriptions of the Traceability Check and Traceable Standard checkboxes below for additional information.

Serial Number

The serial number of the RHT. Serial Number and Data File are the two pieces of information which tie a MET/CAL workstation to a particular RHT. After you have specified a data file, the drop-down list associated with the Serial Number edit control will automatically include all RHT serial numbers contained in the specified file. If you have only one RHT, the drop-down list will show only a single serial number.

Runtime Use of RHT

This checkbox allows the usage of the RHT to be enabled or disabled on the workstation. If this box is not checked, the Runtime will make no use of the RHT data. Temperature and humidity values will not be associated automatically with each calibration event. When you disable usage of an RHT, MET/CAL does not discard configuration information.

Traceability Check

Indicate whether or not the Runtime should verify that the RHT is in calibration before starting procedure execution. If this box is checked, the asset number of the RHT must also be specified and asset information for the RHT must be maintained in the asset manager.

If traceability checking of the RHT is enabled and the RHT is out of cal, a message is displayed before procedure execution. If the workstation is configured to disallow calibration with standards which are out of cal, the message is an error and procedure execution is terminated. If the workstation is configured to allow calibration with out of cal standards, the message is a warning and the user is presented with the choice of either continuing or aborting the procedure.

Traceable Standard

Controls whether or not the RHT is included in the list of standards for a calibration event. If this box is checked, the asset number of the RHT must be specified and the Traceability Check box must also be checked. In other words, you cannot require that the RHT be included in the list of traceable standards for a calibration unless you also require that the traceability check of the RHT be performed to verify that the RHT is in cal. The Traceable Standard checkbox is grayed-out unless the Traceability Check box is selected.

Time Limit

The Time Limit check may be enabled or disabled by choosing the Time Limit checkbox. If a check appears in the box, the Time Limit check is enabled and you may specify the maximum time allowed between the most recent temperature and humidity readings and the current time (at the start of the calibration). The specified value cannot be less than the sampling interval for the chosen RHT.

If Runtime use of the RHT is enabled and the Time Limit check is enabled, the Runtime application acquires the most recent temperature and humidity values from the designated data file. The values are read from the data file just before the start of procedure execution. The timestamp associated with the values is compared to the current time. If the difference between the current time and the timestamp associated with the data values exceeds the specified Time Limit a warning prompt is generated. The user is presented with the choice of continuing or aborting the procedure. If the user elects to continue, the temperature and humidity values are logged with the calibration event in the usual way.

Temperature Delta

The Temperature Delta check may be enabled or disabled by choosing the Temperature Delta checkbox. If a check appears in the box, the Temperature Delta check is enabled and you may specify the maximum allowed temperature deviation between the beginning and the end of the calibration.

  • Choose the °C radio button to specify the Temperature Delta value in degrees Celsius.
  • Choose the °F radio button to specify the Temperature Delta value in degrees Fahrenheit.

This check is performed at the termination of procedure execution. If the temperature change exceeds the specified Temperature Delta value a warning prompt is displayed. The user is presented with option of aborting or continuing the procedure.

Humidity Delta

The Humidity Delta check may be enabled or disabled by choosing the Humidity Delta checkbox. If a check appears in the box, the Humidity Delta check is enabled and you may specify the maximum allowed humidity deviation between the beginning and the end of the calibration.

The Humidity Delta check is performed at the termination of procedure execution. If the humidity change exceeds the specified Humidity Delta value a warning prompt is displayed. The user is presented with option of aborting or continuing the procedure.


Customizing Prompts for the Operator

You must edit the prompt files to collect customized information that you want to have included in any type of results printout. You can edit the prompt files using the MET/CAL Editor’s "Open Text File" selection (File Menu) or using an external text editor. The prompt file names are defaults and can be changed as desired.

The MET/CAL Runtime application prompts the operator of the calibration system every time a calibration procedure is executed, if the system has been so configured. Prompts occur in the following instances:

Prompt | Prompt File | Description
Pre-run | promptdb_mt.txt | After pressing the START button to execute a procedure, but before the procedure actually starts up.
Post-run, Pass | pass_db_mt.txt | After completion of a procedure, where the UUT passes.
Post-run, Fail | fail_db_mt.txt | After completion of a procedure, where the UUT fails.

The presence of appropriate prompt files determines if one or more of these prompts occurs, and their content determines the type of information for which the operator is prompted.

When the operator enters a response, the text entered can be assigned to the name of a variable. The variable and the assigned string value are stored in a temporary variable file, variable.dat. The values can be recalled when results output is created. The temporary file is not erased after a procedure terminates; values can be "recalled" automatically when starting up another procedure, using special constructs in the prompt files.

The prompt at the beginning of execution of a calibration procedure is determined by the prompt file associated with the Prompt File MET/CAL Configuration setting. By default the file name is promptdb_mt.txt and is located in the METCAL\Shared\PromptFiles folder. Review the Prompt File Description section of this document for more details. The default content of the promptdb_mt.txt file is shown below:

[metteam]
CallSheets.cTemperature TEMP$
CallSheets.cHumidity    RH$
CallSheetEx.lField4     SEALS$
CallSheetEx.cField2     WO$

Disabling a Prompt

To disable a prompt, create a new text file with only this content inside:

[metteam]
none

We suggest saving this new file with a clear filename like empty_prompt_mt.txt. Select this new, empty file for the prompt(s) you would like to disable using the Files section of the MET/CAL Configuration settings.


Prompt File Description

Prompt String

The prompt string is the text that the user sees when the prompt screen appears. The prompt string is everything on the line up to the first colon (:). The colon is not included in the prompt string, but it must appear in the prompt file, otherwise there is an error.

When using MET/CAL with the MET/TEAM, the pre-prompts, pass-prompts, and fail-prompts are generated by the MET/TEAM application and hosted by MET/CAL within an embedded browser window. Since the prompts are handled by the MET/TEAM application, the format of the prompt files have changed relative to the MET/BASE related prompt files. Any field customization or user access defined in MET/TEAM is propagated to the prompt file. This includes the naming of the field as well as validation and display rules.

MET/TEAM comes with 3 default prompt files. These files serve as a useful reference on how to configure a prompt file.

  1. promptdb_mt.txt
  2. pass_db_mt.txt
  3. fail_db_mt.txt

Disable prompts by setting the first line of the file to the text "none". In this case the prompt will not display.

File Format

The first line of the prompt file must contain the line [metteam] to differentiate it from the legacy prompt file. Each additional line represents a single prompt. If the file contains more than 20 fields, the full MET/TEAM Work Order is displayed in place of the customized prompt screen. The format of the prompt file is the table name and field name separated by a period, optionally followed by a space and the variable to associate the field with. The format is:

Tablename.FieldnameVariable

Example:

CallSheets.cTemperature TEMP$

If the optional variable is provided, the initial value of the prompt is taken from the variable.dat file, and when the data in the prompt is saved the value is written back to the variable.dat file.

Supported Fields

The valid fields for prompt files are all the database fields associated with the following MET/TEAM tables. Refer to the MET/TEAM documentation for a full list of available fields in the tables.

  • Assets
  • AssetEx
  • CallSheets (Work Orders)
  • CallSheetEx (Work Order extended data)

Prompt field map of MET/BASE to MET/TEAM

Refer to the MET/TEAM documentation for a complete listing of all fields available on prompt screens. In general, any information accessed from a Work Order is available for access in the Pre and Post Test Prompts.

MET/BASE | MET/TEAM Equivalent
2302 Calibration Interval | CallSheets.cInterval
2303 Calibration Due Date | CallSheets.tMaintNextDate (combined with 2334)
2304 Calibration Reliability | CallSheets.cCallSheetNumber
2306 Scheduled Maintenance Date | CallSheetEx.cField1
2307 Calibration Technician | CallSheets.nAssignedTechUID and CallSheets.nTechnicianUID
2308 Found/Left | CallSheetEx.lField1 and CallSheetEx.lField2
2309 Calibration Labor Cost | CallSheetEx.nField1
2310 Calibration Time | CallSheets.nCost
2311 Calibration Temperature | CallSheets.cTemperature
2312 Calibration Relative Humidity | CallSheets.cHumidity
N/A | CallSheets.cPressure
2313 Calibration Shop | CallSheets.nWorkingFacilityUID
2314 Work Order | CallSheetEx.cField2
2322 Calibration Seals | CallSheetEx.lField4
2324 Calibration Time 1 | CallSheetEx.nField4
2326 Calibration Note 1 | CallSheets.mOOTNotes
2327 Calibration Technician 2 | CallSheets.nAssignedTechUID and CallSheets.nTechnicianUID
2328 Calibration Time 2 | CallSheetEx.nField5
2329 Maintenance Notes | CallSheetEx.cField6
2330 User Definable | CallSheetEx.cField7
2331 Calibration Interval Type | CallSheets.cIntervalUOM
2334 Due Time | CallSheets.tMaintNextDate (combined with 2303)
2341 Comments | CallSheets.mCallSheetNotes
2354 User Definable | CallSheetEx.cField17
2355 User Definable | CallSheetEx.cField18
2356 User Definable | CallSheetEx.cField19
2357 User Definable | CallSheetEx.cField20
2358 User Definable | CallSheetEx.cField21
2359 User Definable | CallSheetEx.cField22
2360 User Definable | CallSheetEx.cField23
2361 User Definable | CallSheetEx.cField24
2362 Reliability | CallSheetEx.nField15
2364 User Configured Character String | CallSheetEx.cField8
2365 User Configured Character String | CallSheetEx.cField9
2366 User Configured Character String | CallSheetEx.cField10
2367 User Configured Character String | CallSheetEx.cField11
2368 User Configured Character String | CallSheetEx.cField12
2369 User Configured Character String | CallSheetEx.cField13
2370 User Configured Character String | CallSheetEx.cField14
2371 User Configured Date | CallSheetEx.tField1
2372 User Configured Date | CallSheetEx.tField2
2373 User Configured Date | CallSheetEx.tField3
2374 User Configured Date | CallSheetEx.tField4
2375 User Configured Number | CallSheetEx.nField16
2376 User Configured Number | CallSheetEx.nField17
2377 User Configured Number | CallSheetEx.nField18
2378 User Configured Number | CallSheetEx.nField19
2379 User Configured Number | CallSheetEx.nField20
2382 Abeyance State | CallSheetEx.lField7
2383 Abeyance Interval | CallSheetEx.nField21
2384 | CallSheetEx.mField1
2385 | CallSheetEx.cField26
2386 | CallSheetEx.nField22
2387 | CallSheetEx.nField23
2388 | CallSheetEx.nField24
2389 | CallSheetEx.nField25
2390 | CallSheetEx.nField26
2391 | CallSheetEx.nField27
2392 | CallSheetEx.nField28
2393 | CallSheetEx.lField8
2394 | CallSheetEx.lField9
2395 | CallSheets.cCertificationNumber
2396 | CallSheets.nJobNumberUID
MET/BASE | MET/TEAM Equivalent
4201 Asset Number | Assets.cBarcode and Assets.cID
4202 Manufacturer | Assets.nManufacturerUID
4203 Model | Assets.cModelNumber
4204 Description | Assets.cDescription
4205 Fund | AssetEx.cField14
4206 Serial Number | Assets.cSerialNumber
4207 Options | AssetEx.cField15
4208 Instruction | AssetEx.cField16
4209 Trace | Assets.cStandardType
4210 Notes | AssetEx.cField17
4211 Note Name | AssetEx.cField18
4212 Note Date | AssetEx.tField5
4213 Note Location | AssetEx.cField19
4214 Storage Location | Assets.cPhysicalLocation
4215 Software Revision | AssetEx.cField20
4216 Firmware Revision | AssetEx.cField21
4217 Sub-Asset | AssetEx.cField22
4218 Owning Department | Assets.nDepartmentUID
4219 Cost | Assets.nItemCost
4220 Life | AssetEx.cField6
4221 New Date | Assets.tPurchaseDate
4222 Purchase Order Number | AssetEx.cField7
4223 Federal Stock Number | AssetEx.cField25
4224 Arrival Date | AssetEx.tField6
4225 Status | Assets.cDisposition
4228 Interval Type | Assets.cIntervalUOM
4229 Master Interval | Assets.cInterval
4230 Current Uses | Assets.nUseCount
4231 User Definable | AssetEx.cField1
4232 User Definable | AssetEx.cField2
4233 User Definable | AssetEx.cField3
4234 User Definable | AssetEx.cField4
4235 User Definable | AssetEx.cField5
4236 Date Record Modified | Assets.tAddTime
4237 Who Modified Record | Assets.nAddUserUID
4238 Date Record Created | Assets.tUpdateTime
4239 Who Created Record | Assets.nUpdateUserUID
4240 Segregate | Assets.nMaintenanceFacUID and Assets.nAssignedFacUID
4241 Default Calibration Procedure | AssetEx.cField23
4242 User Definable | AssetEx.cField24
4243 User Definable | AssetEx.cField26
4244 User Configured Character String | AssetEx.cField8
4245 User Configured Character String | AssetEx.cField9
4246 User Configured Character String | AssetEx.cField10
4247 User Configured Character String | AssetEx.cField11
4248 User Configured Character String | AssetEx.cField12
4249 User Configured Character String | AssetEx.cField13
4250 User Configured Date | AssetEx.tField1
4251 User Configured Date | AssetEx.tField2
4252 User Configured Date | AssetEx.tField3
4253 User Configured Date | AssetEx.tField4
4258 Abeyance State | Assets.lInAbeyance
4259 Abeyance Interval | Assets.nAbeyanceInterval
4260 | Assets.mNotes
4261 | AssetEx.cField31
4262 | AssetEx.cField32


Description of Accuracy Files (*.ACC)

Unless TUR checking is turned off, there must be one Accuracy File associated with each Instrument FSC. Accuracy files contain information on the specified accuracy of the instrument associated with the FSC.

Accuracy files may be empty. In this case, the Test Uncertainty Ratio checking must be disabled by unchecking the Enable box for TUR Limit MET/CAL Configuration setting.

The Procedure Compiler verifies that the requested value of parameters as stated in the FSC is possible. It also attempts to compute calibration accuracy ratios and issue a warning if the ratio of specified UUT tolerance to tolerance of the calibration system at the Nominal value drops below a constant value. This constant value is the one defined by the TUR Limit MET/CAL Configuration setting. The default value is 4.

The person who is writing your procedures should ensure that TUR warnings are not generated by verification steps.

However, during adjustment steps, warnings are commonplace and generally can be ignored. The reason is that calibration adjustments are typically made close to the resolution of the UUT, which can be well within the stated accuracy of the UUT. In the limit case, the reading is set right on, meaning zero tolerance. Given that any calibration instrument has at least some tolerance, a warning of insufficient Test Uncertainty Ratio is generated that can be ignored in such a case.

The TUR is defined as (Test Tolerance / System Accuracy).

The compile time and run time TUR calculations may not be identical. At compile time the Test Tolerance is determined as the distance from the specified Nominal to the closest tolerance limit, unless one of the limits is zero. For example, a +3U in the tolerance field (implying -0U tolerance) causes the Test Tolerance to be 3U.

At run time, the Test Tolerance is calculated as the distance from the UUT Indicated value to the tolerance limit that falls on the SAME side of the UUT Indicated value as the System Actual.

All accuracy files are located in the directory specified by the Accuracy File Folder MET/CAL Configuration Setting. Accuracy files are named as follows:

fsc.acc

Example:

5100.acc

Every Fluke calibration software package includes default accuracy files for all instruments in the system. These accuracy files reflect the performance of those calibration instruments in a systems environment over a period of 90 days. In most cases, no changes are needed.

Certain calibration instruments may have special calibrations, making it possible to achieve tighter specifications. By modifying the accuracy files, it is possible to inform the calibration system of these tighter specifications.

Note that the ACCF FSC modifies how the software handles accuracy files. For details, refer to the ACCF FSC help topic.


Accuracy File Formats

  • Accuracy files are ASCII files that can be modified using any text editor.
  • Each accuracy file must begin with a file header.
  • Text is case insensitive.
  • The file format is as follows. Each file is a sequence of sections. Each section consists of a MODE line, followed by one or more lines containing numeric data.

    A MODE line has the format:

    MODE: unit specifier [ flag flag ....]

  • The list of valid unit specifiers depends on the instrument. For example, valid unit specifiers for the 5100 FSC are volts, decibels, and amps.
  • Flags are also specific to each instrument. For the same 5100 FSC, valid flags are E (for accuracy enhancement) and O (for Divider Override).
  • A mode line may not have extraneous characters.
  • Mode lines are not user-configurable.
  • Numeric data lines containing the accuracy information for the stated MODE have the following format:

    nlb nub mlb mub tol floor res

    where:

    nlb is the nominal lower bound

    nub is the nominal upper bound

    mlb is the MOD1 lower bound

    mub is the MOD1 upper bound

    tol is the tolerance as a percentage of the nominal value (%)

    flr is the tolerance in absolute units (floor specification)

    res is the resolution of the instrument in absolute units or percent of nominal

  • The string "NA" may be used to indicate that a particular value is not applicable (i.e. not used).
  • The nominal bounds must always be specified.
  • The lower and upper bounds for Nominal and MOD1 are the legal lowest and highest values at which the instrument can be programmed. The lower and upper bounds themselves are legal values.
  • The tolerance and floor may both contain "NA" to indicate that a range is valid, but no accuracy is specified for that range.
  • If either tolerance or floor is "NA", both must be "NA."
  • The resolution is expressed either in absolute units or percent of the Nominal value. If expressed in percent, the resolution is terminated with the percent (%) sign. Resolution may be "NA."
  • The file may contain any number of blank lines or comment lines.
  • Comment lines have a pound sign (#) as the first non-white space character.
  • White space before the beginning of text or after the text of a line is not significant.

A section of the accuracy file for the 5520 FSC may appear as follows:

# Normal Output, Autorange
Mode: Volts
      -329.9999E-3     329.9999E-3            NA           NA        0.0015           1E-6      100E-9
         -3.299999        3.299999            NA           NA        0.0009           2E-6        1E-6
         -32.99999        32.99999            NA           NA        0.0010          20E-6       10E-6
         -329.9999        329.9999            NA           NA        0.0015         150E-6      100E-6
             -1020            1020            NA           NA        0.0015         1.5E-3        1E-3

# Auxiliary Output
Mode: Volts AX
       -329.999E-3      329.999E-3            NA           NA          0.03         350E-6        1E-6
          -3.29999         3.29999            NA           NA          0.03         350E-6       10E-6
                -7               7            NA           NA          0.03         350E-6      100E-6

# Auxiliary Output, Autorange
Mode: Amps
       -329.999E-6      329.999E-6            NA           NA         0.012          20E-9        1E-9
       -3.29999E-3      3.29999E-3            NA           NA         0.008          50E-9       10E-9
       -32.9999E-3      32.9999E-3            NA           NA         0.008         250E-9      100E-9
       -329.999E-3      329.999E-3            NA           NA         0.008         2.5E-6        1E-6
          -1.09999         1.09999            NA           NA         0.016          40E-6       10E-6
          -2.99999         2.99999            NA           NA         0.030          40E-6       10E-6

# Normal Output
Mode: Volts SI
              1E-3       33.470E-3           0.01         9.99        5.000         167E-6        1E-3
              1E-3       32.999E-3             10        44.99        0.060           6E-6        1E-6
              1E-3       32.999E-3             45        10E+3        0.012           6E-6        1E-6
              1E-3       32.999E-3          10E+3        20E+3        0.016           6E-6        1E-6
              1E-3       32.999E-3          20E+3        50E+3        0.080           6E-6        1E-6
              1E-3       32.999E-3          50E+3       100E+3        0.300          12E-6        1E-6
              1E-3       32.999E-3         100E+3       500E+3        0.600          50E-6        1E-6

           33.5E-3      330.500E-3           0.01         9.99        5.000        1.65E-3        1E-3
           33.0E-3      329.999E-3             10        44.99        0.025           8E-6        1E-6
           33.0E-3      329.999E-3             45        10E+3        0.014           8E-6        1E-6
           33.0E-3      329.999E-3          10E+3        20E+3        0.015           8E-6        1E-6
           33.0E-3      329.999E-3          20E+3        50E+3        0.030           8E-6        1E-6
           33.0E-3      329.999E-3          50E+3       100E+3        0.060          32E-6        1E-6
           33.0E-3      329.999E-3         100E+3       500E+3        0.160          70E-6        1E-6


Accuracy File Headers

Beginning with Version 6, each MET/CAL accuracy file must have a header. All accuracy files that are shipped with Version 6 will include valid headers. If you have created your own accuracy files you will have to add headers to these files.

Accuracy file headers allow MET/CAL to automatically associate the correct accuracy specifications with an instrument that is used as a calibration standard.

As in previous versions of MET/CAL, accuracy files are used only with supported system instruments. These are remotely-controlled calibration standards for which MET/CAL includes a built-in driver.

Examples of supported system instruments are the Fluke 5700A, Fluke 5500A, and the HP 3458A. Accuracy files are not used with user-configured instruments or with manual standards.

The accuracy file header should appear at the beginning of the accuracy file. Comments may precede the header.

The accuracy file header is used to specify the instrument name, calibration interval, confidence and asset.

Instrument Name

This is the system instrument name that is associated with the accuracy file. The name must agree exactly with the name of a supported system instrument. For example, "Fluke 5700A" is valid, but "Fluke 5700" is not.

The syntax for this parameter is:

instrument = name

Name recognition is case-insensitive.

The accuracy file header must include an instrument specification.

Calibration Interval

This is the calibration interval associated with the accuracy file. For example, if the file contains accuracies based on 90-day specs for a 5700A, the interval should be 90 days.

The syntax for this parameter is:

interval = interval numberinterval units

The interval number may be any number. Units may be specified in days, weeks, or months.

For days, interval units may be: "d", "da", "day", or "days"

For weeks, interval units may be: "w", "wk", "week", or "weeks"

For months, interval units may be: "m", "mo", "mon", "month", or "months"

Calibration interval recognition is case-insensitive.

The accuracy file header must include a calibration interval specification.

When MET/CAL compares the calibration interval that is specified in an accuracy file header to the calibration interval associated with an asset in the database, it considers the two intervals to be the same if they are within approximately 10% of one another. This method allows, for example, 365 days to be recognized as 12 months.

Confidence

The confidence parameter specifies a sigma value for use in the measurement uncertainty calculation. The syntax for this parameter is:

confidence = confidence value sigma

The confidence must be specified as a sigma value. It cannot be specified as a percentage. The word sigma is optional in the specification. If specified, recognition is case-insensitive.

The accuracy file header must include a confidence specification.

Asset

The asset parameter specifies an asset number that is associated with the accuracy file. The asset specification is optional. If specified, it indicates that the file should be used only with the specified asset.

The syntax for this parameter is:

asset = asset number

If specified, the asset number should be the same one entered in the database for the calibration asset.

Sample Accuracy File Headers

Each accuracy file header is delimited by the lines:

Begin Header
End Header

Header delimiter line recognition is not case sensitive.

An example of a complete accuracy file header is:

Begin Header
instrument = Fluke 5700A
interval   = 90 days
confidence = 2.58 sigma
End Header

An example of a the same header with an asset number specification is:

Begin Header
instrument = Fluke 5700A
interval   = 90 days
confidence = 2.58 sigma
asset      = 23-495A
End Header

Adding the asset specification in the example indicates that this accuracy file can be used only with asset 23-495A.

Avoid Accuracy File Header Conflicts

It is important to avoid accuracy file header conflicts. Two accuracy files in the MET/CAL accuracy directory may not specify the same instrument name and same calibration interval, unless you have included unique asset number specifications in one or both headers. In addition, if the procedure contains ACCF statements that refer to accuracy files not in the MET/CAL accuracy directory, the headers of those files must not conflict with the headers of any file in the MET/CAL accuracy directory, nor with the header of any other ACCF-specified file in the same procedure, or any called subprocedure.

The confidence specification in the accuracy file header cannot be used to distinguish two accuracy files which otherwise have the same header. This is because, although the confidence value is used in the measurement uncertainty calculation, it is not one of the selection criteria used to automatically associate an accuracy file to a configured calibration asset.


Creating Correction Files (*.COR)

One Correction File may be associated with any legacy Instrument FSC. Note: correction files do not work with Name = Value (NVI) FSCs. These files are optional. If used, they are located in the directory specified by the Correction File Folder MET/CAL Configuration setting. Correction files must have file names ending with .COR . Correction files contain information on special calibration points of the instrument associated with the instrument FSC. An electronic instrument is far more stable during a limited period of time than its stated accuracy indicates. By providing specific calibration points and reducing the calibration interval, the uncertainty of the calibration instrument under those conditions can be significantly reduced. This is the case in particular with AC voltage functions.

The presence of correction factors is indicated by the value of the Correction File Folder MET/CAL Configuration setting being set to something other than "none." The default is "none." If the Correction File Folder is identified, a search for correction factors is done. If no correction factors are known, the files can be blank.

If there is a directory named CORRECT, the MET/CAL Runtime application attempts to find the corrected value for the calibration instrument, and report this corrected value in the results.

If Correction files are used, the Accuracy file and Calibration Interval should also be changed to reflect the improved accuracy specifications.

To indicate that a correction has been applied, the software displays the corrected System Actual value in the Post Test Summary dialog, followed by the word (corrected) to the right of the System Actual value.

The Test Results window also indicates corrections. The corrected System Actual is shown in the System Actual column, and a Y appears in the C column.

You can access the correction indication in the formatted results using the C$ variable.


How Correction Files are Found and Named

The correctdir directory contains all correction files. Correction files are named as follows:

FSC.COR

Example:

5100.COR

The Fluke Metrology software package includes no default correction files. An example correction file for the 5200A is illustrated later in this chapter.


Interpolation Methods to Determine Corrections

The Correction file first identifies the modes for which corrections are available. For example, the corrections apply to the volts mode:

Mode: Volts

Any qualifiers, such as "O", are included. This is also the case with the mode information in the accuracy files:

Mode: Volts O

Within each mode, a number of ranges can be defined over which interpolations can be made. This includes the following:

  • A lower bound for NOMINAL (e.g., voltage)
  • An upper bound for NOMINAL (e.g., voltage)
  • A lower bound for MOD1 (e.g., frequency)
  • An upper bound for MOD1 (e.g., frequency)

This reflects calibration instruments containing ranges of voltage and frequency. Interpolations are generally not valid between different ranges of voltage and possibly frequency. Interpolations and extrapolations are generally valid as long as ranges do not change.

Each range lists a number of data points that can be used for interpolation. Data points are sorted by MOD1 value. After each MOD1 value, one or more Nominal values and their corrections follow. For example:

RANGE: 3 19.9999 100 10e3

MOD1: 100

3 3.0002, 10 9.99998 , 19 18.9997

MOD1: 1e3

3 3.0002, 10 10.0001 , 19 18.9999

You may have a single Nominal data point for a given MOD1 value and there may not be an identical Nominal data point for another MOD1 value. In that case, the NOMINAL and MOD1 values in the correction file must exactly match the values in the calibration procedure to determine the corrected value.

You may have a single Nominal data point for a given MOD1 value, and there may be an identical Nominal data point for another MOD1 value. In that case the Nominal data point value must exactly match the Nominal value in the calibration procedure in order to determine the corrected value.

You may only have data points for a single value of MOD1. In that case the MOD1 value in the correction file must exactly match the MOD1 value in the calibration procedure to determine the corrected value.

In all other cases, data points must be on a rectangular grid as a function of Nominal (voltage) and MOD1 (frequency) value. The data points must also be in sorted order: increasing values of nominal with increasing values of MOD1 values. (Refer to the example later in this chapter.)

The process of determining corrected values is as follows:

· Check to see if there is a range available over which interpolations can be done; if not, try the next range. Ranges may be overlapping. If all ranges fail, no correction is possible.

The accuracy file should reflect standard instrument accuracy for ranges not covered by the correction file. There may be overlapping ranges of correction. The most desirable range to be used for interpolation should be shown first in the correction file.

· Check to see if there is a data point that exactly matches both the Nominal value (e.g., voltage) and MOD1 value (e.g., frequency). If found, return the correction; if not, continue the interpolation process.

· Check to see if there are at least two data points with the same Nominal value but different MOD1 values (e.g., frequency) in the list of corrected values in the range selected.

1. Find the MOD1 values that are closest to the desired MOD1 value above and below the desired value of MOD1.

Selection of Data Points in a Range of the Correction File

If no MOD1 value below or above can be found, find the next MOD1 value above or below the desired value to be able to extrapolate.

Data Points and Desired Value Requiring Extrapolation

If extrapolating, find the difference between the closest Nominal value and the desired Nominal value, and the difference between the two reference Nominal values. If the ratio is more that 0.2, extrapolation is disallowed, and the correction within the range is not successful.

2. When suitable data points are found, compute by linear interpolation the corrected value of the nominal at the MOD1 value desired. If conditions are not satisfied, continue the interpolation process.

· Check to see if there are at least two data points with the same MOD1 value but different Nominal values (e.g., voltage), in the list of corrected values in the range selected. Find the Nominal values that are closest to the desired Nominal value. The data point selection is similar to the previous case where the Nominal value was fixed and where two values of MOD1 existed. If conditions are not satisfied, continue the interpolation process.

· Data points must be on a rectangular grid when the data points are plotted out as a function of Nominal (e.g., voltage) and MOD1 (e.g., frequency), unless the range contains just one or two data points. First, you search for two values of the MOD1 closest to the desired MOD1 value above and below the desired MOD1 value. Next, you search for the Nominal values above and below closest to the desired Nominal value.

Data Point Selection

If you cannot find two values of Nominal and/or two values of MOD1 above or below, find the closest values of Nominal and/or MOD1 both above or below, and try to extrapolate.

Data Point Selection and Extrapolation

The range of extrapolation is limited to 20% of the difference of Nominal or MOD1. If the desired value is not within that range, the extrapolation scheme fails, and no correction is applied. The interpolated correction value is computed as follows.

Correction Computation Method

1. Find the correction factors for the desired Nominal values at the lower and higher value of MOD1 (four correction factors).

2. Compute the two interpolated correction values for the desired Nominal value at the lower and higher value of MOD1 (result is two new correction factors).

3. Compute the correction at the desired combination of Nominal and MOD1 is found by linear interpolation from the new correction factors.


Using Correction Files

Usage of correct.exe

DOS -x correct.exe ini file name exists

Check to see correction file (name.cor) exists in the Correction File Folder as defined in the MET/CAL Configuration settings.

  • MEM1 is set to 1 if correction file exist
  • MEM1 is set to 0 if correction file does not exist

DOS -x correct ini file name init

Initialize a correction file. This operation copies the empty correction file FSC.new from the MET/CAL Correction Templates directory (cortemplates) to the MET/CAL correction file directory (correctdir). If FSC.cor already exists in the correction directory, it is backed up as FSC.bak in the correction directory.

DOS -x correct ini file name reset

Reset the GMT time stamp in a correction file to the current GMT. This operation does change any other data in the correction file.

DOS -x correct ini file name check [hours]

Check to see correction file is still within the time period specified (hr). If hours is not specified, the value of MEM is used.

DOS -x correct ini file name backup

Backup a correction file so it can then be modified safely.

DOS -x correct ini file name restore

Restore a backup version of a correction file.

DOS -x correct ini file name read "mode string" nominal [mod1]

Read a value from an existing correction file. Value is returned in MEM.

DOS -x correct ini file name insert "mode string" nominal [mod1] [-sensor|-source]

Insert a value into an existing correction file. The correction value must be stored in MEM1 prior to execution of the DOS statement. The value in MEM1 must be in the same units an the nominal value on the DOS FSC command line. For example, if nominal = "1kV" on the command line and the correction value is 1000.02V, the value in MEM1 must be 1.00002.

ini file is the full path name of the MET/CAL initialization file.

MATH     S[1] = IFILE()

A good practice is to wrap the path returned by IFILE() in double quotes, in case there is ever any whitespace in the path.

# Wrap in double quotes to handle paths which contain whitespace.
  1.001  MATH         S[1] = "\"" & IFILE() & "\""

name can be a recognized FSC name or the name of a user-configured device or manual standard.

mode string uses the MET/CAL rules for accuracy/correction file mode strings. The mode string must be valid for the name specified. The nominal and mod1 strings must contain a value immediately followed by a valid MET/CAL dimension. If the mod1 string is omitted, the correction file must contain NA in the MOD1 lower limit and upper limit fields for a successful insertion.

If mode string contains "Ohms" and name is one of the following, the nominal value is taken from memory register MEM in lieu of nominal on the DOS FSC statement line.

  • 4000
  • 4000A
  • 4700
  • 4705
  • 4707
  • 4708
  • 4800
  • 4800A
  • 4805
  • 4808
  • 5450
  • 5700
  • 5720

Note: The FSC is used for the above names, not the model number (e.g. "5720" for the Fluke 5720A, not "5720A".

The following statement is an example of a valid use of correct:

"-sensor" or "-source" is only necessary for user-configured device or manual standards. If name is a recognized instrument FSC, source vs. sensor is automatically determined.

DOS -x correct [S1] 5700 insert "Volts" 1V 1kH

DOS -x correct [S1] 436 insert "Watts" 100mW 10kH -sensor

However, the following statement is invalid because "Hz" is the MET/CAL units code for Hertz.

DOS -x correct [S1] 5700 insert "Volts" 1V 1kHz

Effects on Memory Registers

Correction values are used in the results reporting and loading MEM or MEM1, depending on the type of test (Evaluation, Setup, Nominal Set, Compare) and mode (Slew, Keyboard Entry, Go/No-Go).

The effect on memory locations MEM and MEM1 and the UUT Indicated and System Actual values is as follows:

    Evaluation Test:  MEM : no change

    (MOD4 = blank)    MEM1: Slew    : last slewed value (CORRECTED)

                            Keyboard: entered value

                            Go/No-Go: Nominal value (CORRECTED)

                                      Test limits are adjusted

             UUT Indicated: Slew    : Nominal value or MEM (Not Ohms)

                            Slew    : last slew value (Ohms)

                            Keyboard: entered value

                            Go/No-Go: OPER-EVAL

             System Actual: Slew    : last slewed value (Not Ohms) (CORRECTED)

                            Slew    : Nominal value or MEM value (Ohms) (CORRECTED)

                            Keyboard: Nominal value (CORRECTED)

                            Go/No-Go: Nominal value (CORRECTED)

    Setup Test:       MEM : no change

    (MOD4 = S)        MEM1: Nominal value or MEM (CORRECTED)

                            Calibrator output is not adjusted.

    Nominal Set Test: MEM : Slew    : last slewed value (MOD4 = N) (CORRECTED)

                      MEM1: no change

    Comparison Test:  MEM : no change

    (MOD4 = C)        MEM1: Slew    : last slewed value (CORRECTED)

             UUT Indicated: Slew    : MEM

             System Actual: Slew    : last slewed value (CORRECTED)


Rules for Correction Files

The following are the rules for correction files:

  • Correction Files are ASCII files that can be modified using any text editor.

  • Text is not case-sensitive.

  • The correction file may contain any number of blank lines or comment lines.

  • Comment lines have a pound sign ("#") as the first non-white space character.

  • White space before the beginning of text or after the text of a line is not significant.

  • Each file is a sequence of sections. Each section consists of a MODE line, followed by one or more ranges.

  • The MODE line has the following format:

  • MODE: unit specifier [ flag flag .....]

  • The list of valid unit specifiers depends on the instrument. For example, the valid unit specifiers for the 5100 FSC are Volts and Amps.

  • Flags are also specific to each instrument. For the same 5100 FSC, valid flags are E (for accuracy enhancement) and O (for Divider Override).

  • A MODE line may not have extraneous characters.

  • A range of values is defined by the following format:

    Range: nlb nub mub mub

    where:

    nlb is the Nominal lower bound

    nub is the Nominal upper bound

    mlb is the modifier lower bound

    mub is the modifier upper bound

    Example:

    Range: 2 19.99999 40 20

    The string "NA" may be used to indicate that a particular value for the modifier is not applicable and is not used.

  • The lower and upper bounds for Nominal and MOD1 must always be specified. They typically coincide with a range of a calibration instrument.

  • Data points associated with a range follow the Range definition starting with a new line. Data points are listed by increasing MOD1 (frequency) value. The MOD1 value for which data points are valid is shown by:

    MOD1: mvalue1

    Starting on the next line, Nominal data points and their corrections are shown. A comma "," separates each group of Nominal value and corrected value:

    nvalue1 cvalue1 , nvalue2 nvalue2 , ...

    A range and data points may be shown as:

    Range: 2 19.9999 40 2e3
Mod1: 100
3 3.0002 , 10 9.9998 , 19 18.9997
Mod2: 1e3
3  3.0002, 10 9.9999 , 19 19.00003


Example Correction File for 5200A

# Example Fluke 5200A Correction File (partial)

# 5200.COR

#

MODE: VOLTS

Range: 50e-3 119.9999e-3 50 100e3

MOD1: 50

50e-3 49.9998e-3, 100e-3 99.9976e-3

MOD1: 100

50e-3 50.0000e-3, 100e-3 100.0013e-3

MOD1: 200

50e-3 50.0002e-3, 100e-3 100.0023e-3

MOD1: 1e3

50e-3 50.0022e-3, 100e-3 100.0023e-3

MOD1: 2e3

50e-3 50.0023e-3, 100e-3 100.0030e-3

MOD1: 10e3

50e-3 50.0026e-3, 100e-3 100.0057e-3

MOD1: 20e3

50e-3 50.0033e-3, 100e-3 100.0033e-3

MOD1: 50e3

50e-3 50.0040e-3, 100e-3 100.0112e-3

MOD1: 100e3

50e-3 50.0020e-3, 100e-3 100.0263e-3

Range: 500e-3 1.99999 50 100e3

MOD1: 50

0.5 0.499998, 1.0 0.999976

Range: 3 11.99999 50 100e3

MOD1: 50

3.0 2.99989, 10 9.99970

Range: 30 119.9999 50 100e3

MOD1: 50

30 29.9997, 100 99.9992

Range: 300 1199.999 50 50e3

MOD1: 50

300 299.995, 1000 999.980


Editor Introduction

The MET/CAL Editor is a development tool for creating, editing and maintaining MET/CAL procedures. Version 8 introduced an all new MET/CAL Editor and incorporated many features requested in earlier versions of MET/CAL. The editor is built around the Microsoft Visual Studio Isolated Shell which is at the center of all development using Microsoft tools (C#, C++, VB.NET, etc).

Similar to the other tools in the MET/CAL Plus package, a valid user name and password is required to gain access to the editor. Further the user must be configured with the appropriate rights within MET/TEAM to be able to edit procedures. The log in dialog is displayed as the first step to running MET/CAL Editor.


What is a MET/CAL Procedure?

Procedures are the heart and soul of MET/CAL and are used by the MET/CAL Runtime program to perform a calibration. They are created, edited and maintained by the MET/CAL Editor. A MET/CAL procedure is a file containing MET/CAL commands called Function Select Codes or FSCs. FSCs are the key words in the MET/CAL procedure language. The MET/CAL Reference Guide contains a complete list of all of the FSCs. Pressing Ctrl+Space in MET/CAL Editor also displays a list of all available FSCs. Press F1 to access help specific to any FSC. Procedures are written for specific instruments and follow the manufacturer's written calibration procedure. Procedures sometimes call other procedures which are called sub-procedures. Procedures are flexible and can display graphic images and may use external text and data files.

Procedures are used by the MET/CAL Runtime program. The MET/CAL Runtime program executes the procedure, determines if the calibration has passed or failed. Calibration information is saved in MET/TEAM for later use. Reports containing the calibration data can be viewed or printed.


Customizing the Editor Display

The procedure editor has a very flexible environment that provides features to customize the look and feel of the editor. Each window within the editor can be docked to other windows side by side, top and bottom or as a tab. Individual windows can also be configured to float outside the window of the editor itself. The screen layout of the editor is persisted between uses of the program. After the display is customized, it will remain the same for all subsequent runs of the editor.

Depending on the development activity, having different layouts comes in very handy. Once the screen layout is customized, its settings can be easily saved (Exported), allowing you to switch back and forth between your favorite screen layouts. This is performed through the Tools > Import and Export Settings menu, which also allows you to reset to original settings.

Right click the main tool bar to enable or disable the supported toolbars.

There are several ways to alter the window layout. Access windows by using the menu bar. For example the Debug, Windows menu. When a window is open Rt-Click the menu title bar to display docking options. Double click the top of any docked window to automatically un-dock it.

Docking Windows

Click and drag the top of any window to display the docking options. The docking options are a group of individual icons that represent where a window will be docked. While dragging the window place the cursor over the desired docking option and release the mouse button. The window will dock depending on the selected docking option. The docking location shades on the display as the cursor is placed over the various docking options. The docking options change based on the window under the window that is being dragged.

Tip: Hold the Ctrl key while dragging windows to suppress the docking options, preventing accidental docking while quickly arranging the display.

Two Monitors – Multiple Procedures

The procedure editor functions on multiple monitors. Individual screens can be docked and displayed on separate monitors. We aware that when switching from more than 1 monitor to a single monitor that screens positioned on the second monitor will not be visible.

This screenshot shows the IDE window stretched across two high-resolution, widescreen monitors. Six docked, vertical tab groups are configured side-by-side; with three in the left monitor and three in the right. The spacing between tab groups was adjusted so that the left group of three meets the right group of three exactly where the two monitors physically come together, creating an invisible transition. Each tab group actually has two procedure files open per group, for a total of 12 files open and visible at the same time.

Single Monitor – Split Procedure plus Other Views

This screenshot was configured using one high-resolution, widescreen monitor, using a combination of docked, vertical and horizontal tab groups. The procedure window at the far left is in a vertical tab group; the procedure window is also split, showing two sections of the same procedure simultaneously. The remaining groups are all horizontal tab groups, one includes several views related to Debug Mode, the next group includes Task List, Error List, and Output. The final group includes the Solution Explorer and Properties window.

Single Monitor – Floating Windows

This screenshot shows how windows can be designed to float, instead of docked. Four procedure windows are floated, while the Solution Explorer and Properties windows remain docked in a horizontal tab group. Nearly all windows can be floated or docked, not just the procedures; you can even make floating tab groups!

Single Monitor – Minimized Tool Views

This screenshot shows a basic layout with vertical tab groups. The difference here is that several of the Tool Views have been minimized using Auto Hide. Four views have been minimized to the bottom of the screen, and two to the right. These can be viewed by mousing over them, clicking them, or in some cases they will be presented automatically as a result of Editor operations (like procedure compile errors).


Projects and Solutions

MET/CAL Editor Version 8 introduced a new capability called Projects that bundle together all of the procedures, subprocedures, images, external files, and other files used in a calibration procedure into a single location. A Project can be used to produce a Procedure Executable file (PXE) that can be run by the MET/CAL Runtime program. PXE files cannot be altered and their contents cannot be viewed, and they make it easy to distribute procedures to other workstations or labs.

The Project keeps all of the Project's required building blocks (i.e. dependencies) together. This is a departure from previous versions of MET/CAL which did not manage a procedure dependencies. Without a Project, it is up to the procedure author to ensure that all dependent files are located in the folders specified by the MET/CAL configuration options.

What is a MET/CAL Project

MET/CAL Projects are containers that procedure writers use to organize their procedures, subprocedures, images and other dependent files. The Project contains all of the building blocks need for a procedure to successfully run. The MET/CAL Editor can automatically create Projects from one or many existing procedures in a procedure directory (proc.dir) or from a procedure package (PKM) file. Projects may also be created manually, adding procedures and other building blocks one item at a time.

Each Project is limited to one main procedure. The main procedure file represents the entry point for all files in a Project. When a Procedure Executable created from the Project is selected in MET/CAL Runtime, only Instrument lines in the main procedure are listed for selection. The other procedures in a Project are accessed using CALL FSC statements. Reference the properties of a procedure file to specify a procedure file as the main procedure.

In previous versions of MET/CAL, subprocedures were often shared among several procedures. This is common when procedures are written for families of instruments or classes of instruments. While efficient, the lack of procedure management tools could allow a procedure writer to enhance a subprocedure for one instrument with no awareness that the subprocedure is shared by other procedures, negatively affecting the operation of a different procedure.

In this example, subprocedure 2 is used by two different procedures. Altering it to enhance procedure 1 could cause a problem in procedure 2 that may not be known until procedure 2 is actually used. If there is no record kept about the changes, debugging the problem may be difficult. The use of a procedure Project and compiling procedure executables will avoid this issue.

When a Project is opened in the MET/CAL Editor, all of the procedures, subprocedures, images and other required files are loaded into the MET/CAL Editor. In this example, the Tektronix TDS3014B Project has been opened. The Solution Explorer shows that the main procedure and its 5 subprocedures are available. A procedure or subprocedure can be opened for editing by clicking its name in the Solution Explorer. When the Project is saved, all of the Project files are saved as a group.

Solution

A Solution is used to maintain all files within the MET/CAL Editor. All files accessed in MET/CAL Editor are accessed through Solutions. The Solution may have 0 or more Projects. Files opened without a Project are listed in a Solution as "Miscellaneous Files". All files opened using the File >Open > Procedure menu are opened without Projects. Note the "(0 projects)" text that displays next to the Solution name. In 0 Projects mode, options to create a procedure executable or manage Project properties are not enabled.

This functionality closely resembles the behavior of 7.x versions of the MET/CAL Editor. Files are individually edited and accessed. Procedures and other files used by a procedure must be published to the proper location. For example, two procedures A and B are in the Solution and procedure A calls procedure B. Debugging of procedure A requires that procedure B be published to the active compiled procedure directory. When debugging a new window with the published source of procedure B will display while procedure A executes. In this case 2 windows for procedure B will display. When the debug session ends, compiled procedure window for procedure B will close.

A Solution that contains 1 or more Projects is a more typical use of a Solution. There is no relationship requirements amongst the Projects within a Solution. An example grouping is that one Project is used for an adjustment procedure of an instrument and another Project is used for the validation procedure of the same instrument. In this scenario the two Projects may share many of the same files so that editing the two Projects at the same time is convenient. Although the two Projects may share many of the same files, each Project must still have it's own reference to its required files. A Project can belong to more than one Solution.


Project Properties

All Projects have properties. When a project or a file in a project is selected in the Solution Explorer, the Project menu will contain a Properties item. The menu is named based on the active project selected in the solution explorer. The project properties are provided to associate information with all files in the project. Some of the information provided on the Properties dialog is presented in the MET/CAL Runtime when running a PXE procedure. Take this into consideration when changing the properties for a project.

Warnings will display when building a project if some of the properties are not updated. Other than the Publish File Type and Publish File Name selections, none of the options in the Project Properties dialog affect the operation of the procedure within the MET/CAL Editor. Below is an example project properties dialog:

Package

The meaning of each of the fields are explained in the table below.

Field | Definition
Author | Enter the name of the person or group responsible for creating the procedure.
Calibration Interval | Enter the calibration interval for this procedure.
Comments | Text used to describe the overall purpose of the procedure or any special actions that should be taken when using the procedure.
Company | Name of the company that owns the procedure
Copyright | The copyright date of the procedure package.
Package Date | The date stamp of the procedure. When importing procedures, this is the date field of the main procedure. The field must be manually updated by the user.
Procedure Execution Time | Enter the anticipated execution time for this procedure.
UUT Control Type | Enter the control type for the UUT.
UUT Type | Enter the type of UUT for this procedure.
Version

The version of the project and procedure package. Use the version for tracking and control purposes.

A compatible Version may be blank, any integer, or a decimal number formatted as major.minor.
Publish file name | The default file name of the procedure package.
Publish file type

The package type:

  • pxe- Procedure Executable file. PXEs can be directly executed by MET/CAL
  • pkm - Procedure Package file. Used for distribution of procedure source. A PKM cannot be run by MET/CAL. The files must be imported into the MET/CAL Editor and republished for use by MET/CAL Runtime. This is a legacy option provided for compatibility with prior versions. Distribution of procedure source is simplified by the Source zip file added to the \bin directory of a project during the Build process.
  • multi - All package types are automatically generated. When building the files are copied to the \Bin folder of the project. When publishing all packages are copied to the selected publish file folder. In addition to the package files a ZIP file for the project and all required files and a manifest XML file is included. The ZIP file can be used for easy distribution of the source code. The Manifest file contains a summary of the other details listed in the project properties. The Manifest file details are provided to allow external programs to mine specific hardware options are requirements of a PXE.

UUTs Supported

The information updating in this section is written to the Manifest file when the "Multi" option is used as the Publish file type. The information is available to allow external programs to easily determine what UUTs are supported by a PXE. The information in this section is not presented to the user when a PXE is executed nor are their warning generated if the content is left blank.

References Used

The information updating in this section is written to the Manifest file when the "multi" option is used as the Publish file type. The information is available to allow external programs to easily determine what references are supported by a PXE.

Tested With

The Tested With section is provided to assist in the validation process. When a procedure is validated with a particular UUT, the details of the instrument should be stored in this section. The information listed is written to the procedure manifest file when the "multi" option is used as the Publish file type. The information is available to allow external programs to easily determine what instruments were used to validate a PXE.

Validation

The validation information is presented to users that run PXEs from the MET/CAL Runtime. The information is provided as an aid to allow users to only run procedures that have been validated.

Field | Definition
Validated | True/False field to indicate if a procedure has been validated. Use the option to flag to PXE users when a procedure is acceptable to execute.
Validated by | The person(s) or group that verified the procedure.
Validation comment | Use the field to indicate the type or level of validation. "Z540.3, ISO17025" for example. There are no limits or specific requirements for the comment.
Validation date | The date that the package was validated. This date does not have to correspond

Licensing

The licensing is section is available only when a proprietary option is enabled. The licensing option prevents a PXE from running a system that does not contain the appropriate license.

Field | Definition
License GUID | The Globally Unique Identifier for the procedure executable. This item is used with a license file to create a proprietary PXE. Licensed PXEs cannot be used without the appropriate license file. The license file mechanism is proprietary and is not publicly available in this release of MET/CAL.
Licensed by | The name of the organization that is providing the license.
Licensed procedure | True/False to indicate if the procedure is licensed or not.
Licensed to | The name of the organization that is authorized to use the PXE.


Using Instrument Configuration Files in Projects

MET/CAL stores instrument configuration information in a Configuration File. Your workstation configuration may support different instruments than the requirements of the procedure you are developing. For example, your workstation may consist of a Fluke 5522A with the SC600 oscilloscope calibrator option, but the procedure you are developing for another department requires a Fluke 9500B Oscilloscope Calibrator with four 9530 Active Heads. In MET/CAL version 7 and prior, this scenario required the addition of the 9500B with active heads to your workstation's Configuration File to provide the Editor with the information required to successfully Compile Check the procedure code. Reconfiguring these instruments on your workstation was a required step during procedure development. Another challenge exists when working with Projects and Solutions, where a single Solution contains many Projects and each Project requires different reference devices.

Projects support adding Configuration Files as Existing Items. The suggested method to accomplish this is to use the MET/CAL Runtime or MET/CAL Editor Instrument Configuration menu to create the Project's required instrument configuration. Once the Configuration File has been created, copy it to another location, rename it appropriately, and add it to the project. All Compile Check and Build operations will now refer to the Configuration File attached to the project for required instrument information. MET/CAL Runtime and the MET/CAL Editor's Debug Mode will continue using the workstation's Configuration File.

Instrument configuration file names must begin with "config" and end with ".dat".

A "library" of Configuration Files may be created, allowing each file to be used within many projects. An example library may contain many Configuration Files, for example:

  • config_5502a.dat
  • config_5502a_5500a_coil.dat
  • config_5502a_52120a.dat
  • config_5502a_sc300.dat
  • config_5502a_sc600.dat
  • config_5520a.dat
  • config_5522a_sc600.dat
  • config_5720a.dat
  • config_5730a_5725a.dat
  • config_5730a_52120a_coil3kA.dat
  • config_9500_9510_5hd.dat
  • config_9500_9530_1hd.dat
  • config_9500_9530_5hd.dat
Compile check T.U.R.s are generated using the configuration file attached to the project. All other T.U.R.'s are generated using the workstation configuration file.


File Properties

All files accessed in the Solution Explorer contain properties specific to the file. Do not confuse the file properties with the Project Properties accessed through the Project menu. The file properties are provided to give the procedure author quick access to file specific details and operations. Files that are opened in a procedure project include additional file properties as compared to those opened as individual procedure files. The extended file properties are provided to alter the behavior of the procedure editor when projects are built. Reference the tables below for details on each of the properties.

File Properties for a file without a Project

File Properties for a file within a Project

Field | Definition
General
Name/File Name | The file name of the procedure. Directly re-name files in a procedure project using this field. Procedures that are outside of a project cannot be renamed using this property field. Instead use the File, Save As menu choice to rename the procedure file.
Date Created | File creation date. This property is not available in procedure projects.
Date Modified | Last file modification date and time. This property is not available in procedure projects.
File Path/Full Path | The full path to the file.
File Size | Size of the file on disc in bytes. This property is not available in procedure projects.
Read-only | True/False field indicating if a file is read only or not. Read only files cannot be saved. This property is not available in procedure projects.
Build Action

Determine wether or not to compile a procedure file when building the project. This property is not available outside of a procedure project. The choices are:

  • Compile: Compile the procedure when building. This option applies to *.mc and *.txt files only. The file must contain text that represents a MET/CAL procedure.
  • Content: Take no action on the file when building. This option is used for images, executables and other support files associated with a project. When debugging a large procedure project, it may be useful to flag incomplete procedures as Conent to allow the project to properly compile for testing purposes.
  • Embedded Resource: This option should not be used and currently has no function.
  • None: This option should not be used and currently has no function.
Custom Tool | This property is not used by the MET/CAL Editor.
Custom Tool Namespace | This property is not used by the MET/CAL Editor.
Exclude From Package

This is a True/False property that determines if a file is packaged into a PXE with the project or if the file is copied to the relevant Files and Folders path. The choices are:

  • TRUE: When building a project, do not copy the file into the PXE. When the project is Published, the file is copied to the directory specified by the relevant Files and Folders setting. Images are copied to the Picture Folder directory; procedures are copied to the Procedure Folder (Compiled) and are made available in the procedure selector, programs are copied to the current User Program Folder and other support files are copied to the User Data Folder. A project can be created such that all files are Excluded from the build.
  • FALSE: When building and publishing, the file is compressed and added to the PXE or PKM file.
Hidden Procedure | True/False field to indicate if a procedure is hidden to MET/CAL Runtime users. This option applies only to the specific case of a procedure file in a project flagged as Exclude From Build. Files outside of a procedure project are made visible and hidden by using the Procedure Selector.
Main Procedure | All projects are required to have a single Main procedure. The option applies only to procedure files marked with "Compile" as their Build Action. Instrument lines from the main procedure are presented to the MET/CAL Runtime user when executing a PXE. Setting this property to True forces a False condition for all other files in the project.
Sectioned Procedure | True/False field that determines if the specific procedure file contains sectioned procedure details. Only one procedure in a project can support procedure sectioning. Section details within any procedure are ignored unless this field is set to True.


Building and Publishing

MET/CAL Editor version 8 also introduced the concept of Building and Publishing procedures. These operations are now an integral part of procedure development and execution.

Procedures Without Projects

Procedures developed outside of projects do not support the build operation. These procedures are edited, debugged then published. Any procedure opened with the File > Open Procedure option is opened outside of a project. However, files in a procedure project can also be published as individual compiled procedure files. Only procedures that compile can be published.

Publishing the procedure adds it to the current or user selected compiled procedure directory. A publish operation is required to allow MET/CAL Runtime to execute the procedure. Select one or more procedures in the Solution Explorer prior to using the Build> Publish Procedure(s) option to publish more than one procedure at a time. Below is a general flow chart of editing and publishing a procedure that is not in a project.

  1. Open an existing procedure using the File > Open > Procedure menu choice, or create a new procedure with CTRL+N or File > New > Procedure File.
  2. Add text to the instrument line, and edit the procedure content.
  3. Press F9 to Compile Check the procedure. This process ensures that all procedure content is valid and that the procedure can be compiled.
  4. Test Run the procedure by using F5. Use the Debug Toolbar or short-cuts to control the debug process.
  5. Repeat steps 2-4 until the procedure meets expectations.
  6. Publish the procedure using the Build > Publish Selected Procedure(s) or Build > Publish Selected Procedure(s) To option to add the procedure to the compiled procedure directory.
  7. Use the Procedure Selector to hide procedures that should not be accessible by MET/CAL Runtime.
  8. Use the MET/CAL Runtime to launch the published procedure.

Building Procedure Projects

Procedure projects require a build operation prior to debugging or publishing the project. The build operation is automatically triggered when Start Debugging is selected, the Build > Publish Package option is used or when any of the direct build options are selected in the Build menu. The Build and Publish process does the following:

  1. Verifies that all procedures in the project compile without errors. Warnings do not prevent a compiling. Reference the Output window to view build process errors. The Status bar also updates with general progress information.
  2. Scans each procedure and verifies procedures referenced in CALL FSC statements are in the project. Even files market as Exclude from Build in the file properties must be in the project however they will not be added to the final PXE.
  3. Scans each procedure and verifies that each image referenced by a PIC FSC statement is in the project. If a variable is used to reference the image, the file cannot be verified. In this case, it is up to the user to ensure that the picture is included in the project or is in the active Picture Folder MET/CAL Configuration setting.
  4. Scans each procedure for DOS FSC statements and ensures that the application called by the statement is in the project. Similar to pictures, if a variable is used the program cannot be verified at build time. It is up to the user to ensure that the file is included in the project or is in the User Program Folder or the User Current Working Folder as defined in MET/CAL Configuration settings.
  5. All files in the project that are compressed and added to a zip file that is named the same as the Package File Name defined in the Project Properties dialog. The file is copied to the \bin directory relative to the active procedure project file.
    1. The zip file contains all relevant source files necessary to rebuild the Procedure Project. Use this file to transfer source to another user if it is necessary to rebuild the project on a system that does not have access to the original project files.
  6. Regardless of the Package Type selection in the Project Properties, a PXE file is also created in the \bin project sub directory. All debugging is performed by using the PXE file in this folder.
  7. If the Build operation was initiated by Start Debugging, the actively selected procedure will execute starting at the first line of code. Debug from Cursor will always begin at the current cursor point of the active procedure.
  8. When the Package Type selection in the Project Properties dialog is PKM and building was initiated by a Publish operation, a PKM file is also created in the \bin directory.
  9. When the Build > Publish Package option is used, the PKM or PXE file is copied to the target location selected by the user when the option was first pressed. Note publishing a package is effectively a file copy operation to move the package from the \bin directory to the MET/CAL Runtime working directory. The default folder is the current compiled procedure directory.
  10. For archival purposes, it is good practice to backup the project ZIP file with the PXE after publishing. This is a user specific operation that is not handled by the procedure editor.
Prior to publishing a PXE, ensure that all Project Properties are up to date. Regardless of changes to the procedure project, the PXE will remain unchanged over time. The properties in the PXE can be used to help to determine the state of the PXE when published and distinguish PXEs published from the same project at different times.

A flow chart of the Build/Publish sequence for procedures in a project is below.


Migrating Procedures from Version 7 and Prior to Version 8+

This section is provided to assist users upgrading from earlier versions of MET/CAL. Please review the Projects and Solutions topic to better understand the project and solution paradigm. Note that the use of Projects is not required in MET/CAL Editor 9.0. Users comfortable with the stand alone procedure paradigm can continue to developing without the use of a project.

Compiled Procedure Format

The compiled procedure format has not changed. MET/CAL has always used a compiled procedure format consisting of a proc.dir file and numbered .pro files (1.pro, 2.pro, 3.pro, etc.) for each procedure, in a flat directory structure. The MET/CAL Editor has always allowed procedures to be created, opened, edited, and saved to this compiled format. The format of the *.pro files has not changed with MET/CAL 9.0. As a result procedures created with MET/CAL Editor 9.0 can function on earlier versions of MET/CAL, as long as new functions are not employed which require version 8 (5522A FSC, LIB FSC, etc.).

Procedure Source Code as Text

While earlier versions of MET/CAL had the ability to maintain procedure source code as text files, many customers elected to save everything in the compiled procedure format since this was the default MET/CAL behavior. Pressing standard keyboard shortcuts like Ctrl+S saved procedures to the default proc.dir in compiled format, not to text files on a hard drive. Saving the same procedure as a text file required extra steps.

Solely using the compiled procedure format has a few drawbacks:

  1. Procedure edits are saved to the "live" procedure directory from which they were opened. Others users that share the procedure directory are immediately impacted by changes made. For better or for worse.
  2. Additional, manual steps were necessary to copy procedures to a temporary proc.dir before beginning development.
  3. Once development was finished, additional, manual steps were required to get the procedure copied back into the "live" directory.
  4. It is more cumbersome to return to a specific state of procedure execution when multiple individual procedure files can be edited over time. For example, it is may be difficult to determine the exact procedures used to calibrate an instrument 2 years ago.
  5. Source code could only be edited within the MET/CAL Editor, one procedure at a time.
    1. Powerful text manipulation tools could not be used to edit procedure source code.
    2. Find/Replace operations were limited to one procedure at a time.
  6. Revision control was nearly impossible to implement.

MET/CAL Editor 9.0 Paradigm:

  1. All procedures are saved as text files in UTF-8 format with a *.mc file extension.
  2. Default save operations (Ctrl+S) now save procedures as text files with a .mc file extension.
  3. Existing procedures that are opened or "imported" to the MET/CAL Editor are saved as .mc files.
  4. Files can be organized logically in directory paths, instead of having everything in a flat structure. This is not a requirement; users are welcome to save in a flat structure or a complex directory hierarchy.
  5. Procedures must be Published using the Build > Publish option to be available for use by MET/CAL Runtime.
  6. A new PXE file can be used to run a procedure. The file cannot be changed after it is created.
  7. It is much easier and faster to work with multiple procedures at once. The ability to search and modify multiple procedures at the same time is available with and without projects.
  8. The MET/CAL Editor includes powerful text manipulation tools.
    1. Eliminates reliance on external tools and applications.
    2. Find/Replace operations have been greatly expanded:
      1. Wildcards and regular expression matching are now supported.
      2. Quick Find/Replace operations now work in the Current Window, All Open Documents, the current Project, or the entire Solution.
      3. New Find/Replace In Files adds more powerful operations to match those in Quick Find/Replace, plus adds capability to work on closed files, and files located on a disk drive outside of the current Solution.
  9. External text manipulation tools can also be used on *.mc files, if desired.

How to Edit Procedures Without Projects

Open existing procedures using the File > Open > Procedure menu choice or create a new procedure using the File> New . Procedure menu choice. The previous keyboard shortcut CTRL+N is still available to create a new blank procedure. Procedures created in this way are maintained outside of projects. After a compiled procedure is opened, use the *.mc version of the procedure for all edits and to verify functionality in a test run. Publish the procedure to add it to the compiled procedure directory. Review Selecting a Procedure for additional details.

Importing Procedures to Projects

There are 3 ways to create projects from existing procedures. In all cases the import process does not alter the original files. After a project is created always use the Project Properties menu to customize the project properties. PXE files are the typical output of a procedure project. The project properties are visible to users in the MET/CAL Runtime when the PXE is selected.

  1. File > New > Project from Existing Procedure: Select one or more main procedures; check the "Exclude Hidden Procedures" box to filter the results, and hold Ctrl to select multiple procedures or Shift to select a range. The MET/CAL Editor will import all procedures referenced by CALL statements, pictures referenced by PIC and PICE statements and programs used by DOS and DOSE into a project. Images and programs referenced as variables are not imported automatically. By default procedures are converted to *.mc files and copied to the procedure project directory. Files that could not be located display with a caution symbol in the solution explorer.
  2. File >New > Project from Existing *.pkm File: Select a PKM file and a single main procedure from the PKM file. The editor will import all procedures referenced by CALL statements, pictures referenced by PIC and PICE statements and programs used by DOS and DOSE into a project. Images and programs referenced as variables are not imported automatically. By default procedures are converted to *.mc files and copied to the procedure project directory. Images and programs can be copied to the current Picture Folder or copied to the current project's directory. A prompt is provided during the import process to determine where the files will be imported. Files that could not be located display with a caution symbol in the solution explorer.
  3. File > New > Project: Create a new empty project. Right- click the project node in the solution explorer and choose the Add option to add new or existing files to the project. Alternatively use the Project menu to add files to the project. The project menu supports adding files only when the project node is selected in the solution explorer.

Test Run Procedures

The ability to test run a procedure is now maintained in the Debug menu. All features associated with Test Run functionality are described as Debugging in MET/CAL Editor 9.0. A toolbar and corresponding menu choices are available to enable and disable debugging. While debugging other windows can be viewed, however editing a procedure is not allowed.

Debug related windows do not automatically display when test running a procedure. It is up to the user to configure the display to view the desired windows when a debugging is active. Use the Debug > Windows menu choice to access windows to view the status of variables used in a procedure and the current test run status information.

Debugging procedures outside of a project is very similar to prior versions of MET/CAL. As long as the procedure is syntactically correct, debugging is supported. All procedures and files referenced by the procedure are assumed to be in the active Files and Folders paths. CALL FSC statements reference the active compiled procedure directory. This is the case even if the *.mc version of the compiled procedure is open in the solution. For this reason, break points can only be added to subprocedures after they are opened during the debug process.

Debugging a project always starts by building the procedure project to ensure that all dependencies are valid and that there are no errors in any procedures within the project. Use the View > Output menu option to display the Output Window that includes detailed status information on the build process. Any errors or warnings are displayed in the Output Window in addition to the Error and Warning Windows. To ignore a procedure in a project, select the specific procedure(s) in the Solution Explorer then access the file properties using F4. Choose Contentfor the Build Action property. In this case, any errors in the selected procedure are ignored and will not prevent the debug process from starting.

Changes to Common Functions
MET/CAL 7.X Menu | MET/CAL 8.x Menu
Test Run, Restart (F2) | Debug > Start Debugging (F5)
Test Run, Go (Alt+F2) | Debug > Debug from Cursor (Alt+F5)
Test Run, Show | There is no equivalent Test Run Dialog. The Debug > Windows menu includes options that display variable and status Window information.
Demo Mode | Debug > Simulation Mode menu choice
CTRL+I

Not supported. A default Instrument line is included in all new procedures. Additional instrument lines should be created by copy/paste action.

To test run a specific instrument line in a procedure, create a new temporary procedure that includes a CALL statement to the specific instrument line in the procedure.


File Types

The MET/CAL MET/CAL Editor creates and or modifies several file types. The supported extensions are listed in the table below. The user is not required to manually manipulate any of the files.

File Extension | Purpose
.mcsln | MET/CAL Editor Solution file which organizes projects, project items and solution items. Solution files are stored in the project directory or a specific solution directory. The location is determined by the New Project dialog.
.suo | Visual Studio Solution User Options file which is a structure storage or compound file stored in binary format solution layout (hidden file type). When a source control program is used or when sharing a procedure project, exclude this file as it is specific to the user authoring the procedure and it does not contain details related to the function of the procedure.
.mcproj | MET/CAL Editor Project file which organizes project items.
.pro | Old style MET/CAL procedure file.
.mc | MET/CAL procedure file stored in UTF-8 format. The file is plain text and can be opened in any text editor.
.cache | File used to make it faster to load .pro files. These files should not be modified by the user and are hidden by default.
.pkm | Packed procedure file. The file contains one or more procedures and support files. A *.pkm file can be created by altering the Publish Type property in the Project Properties dialog. A *.pkm file can be imported into a project by using the File, New Project from Existing *.pkm file option.
.mcz | Procedure package file. Contains one or more procedures and support files. A separate utility program (MCZ Installer) installs the procedure to the default procedure directory.
.pxe | MET/CAL procedure executable; cannot be edited. Produced when a Project is published; source Project is required to change a .pxe file.


Unicode Character Encoding

MET/CAL Editor 9.0 stores procedure files using UTF-8 format. UTF-8 is a Unicode format that supports universal transport of characters created on operating systems with different code pages. In effect, a procedure written and published to a PXE (or *.pro) on a Chinese version of Windows 7 will run and properly display the Chinese characters on a French operating system. In addition to portability, characters that were not previously supported in MET/CAL can now be used.

Part of the implementation of this functionality required that character length limits for lines and FSCs be converted to byte length limits. For example, the DISP FSC previously supported 56 characters, now it supports 56 bytes. The use of UTF-8 requires that some characters consume more than 1 byte. Therefore the number of characters and bytes will not always be the same. In general, characters above 128 ASCII will consume 2 bytes. This impacts many commonly used characters: ©, µ, °, ±, and ®, as well as characters with accents. Using these characters in a line will now count as 2 bytes although it is 1 character.

Although this further reduces the currently limited line length, this issue will impact a relatively small portion of procedures. Procedures that use ASCII art with 2 byte characters, "#±±±±±±±±±±±±±±±±....#" for example, have a much higher probability of being impacted. An audit of more than 6,000 procedure files (including the MET/CAL Gold Warranted Procedure library, and procedures created in China, Sweden, Germany and the Netherlands) found that approximately 10% of the procedure files would not compile when first opened on MET/CAL Editor 8+. However, these procedures will all run without modification in MET/CAL 8+. Of the 10% of the procedures that did not compile all of them had a problem with the line length. If comments are ignored, about 5% of the total procedures tested would not compile. The vast majority of line length issues in the procedure code were related to the DISP FSC.

Any MET/CAL statement (comments, FSCs, Instrument Lines, etc) that currently uses all available characters for the statement and includes a character that contains 2 bytes will have to be altered to compile in the new MET/CAL Editor. Specifically, the number of characters (bytes) will have to be reduced to accommodate the line length of the MET/CAL procedure language. The compile error message will clearly indicate the problem and include the number of characters that exceed the limit. Similar to any line length violation, the procedure author must reduce the number of characters on the statement before the procedure will compile.

A side benefit of using MET/CAL Editor 9.0 is that it will be possible to dramatically increase the line length limit on procedures in the very near future.

Procedure Compatibility

Procedures created in older versions of MET/CAL will run in MET/CAL 9.0 and will directly run without modification regardless of the characters used. The Unicode change only effects procedures compiled with MET/CAL Editor 9.0.

All working procedures in MET/CAL Runtime 7.X will continue to work in MET/CAL Runtime 9.0. The issue described above impacts editing and creating procedures.

With a few exceptions, procedures created with MET/CAL Editor 9.0 will also run on older versions of MET/CAL. Most exceptions occur when the procedure uses newer functions like the Library (LIB) or O_CAL FSCs that are not supported on the older version of MET/CAL.

Here is a simple example to clarify compatibility. Given two procedures A and B, each includes extended characters in the instrument lines. A = "Validation at 50 µV" and B = "Slew in µV". The execution of Procedure A calls procedure B using a CALL FSC statement. Both procedures were originally created in MET/CAL Editor 7.X and contain procedure statements that use special characters. Neither of the procedures use new FSCs created in MET/CAL Editor 9.0. The table below describes the scenarios in which editing the procedures in a particular version of the MET/CAL editor affect how the procedure will run in different versions of the MET/CAL Runtime.

Procedures With Special Characters in the Instrument Lines
Edited in 8.x | Edited in 7.X | Will Run in 8.x/9.x | Will Run in 7.X
 | A,B | YES | YES
A | B | YES | YES
B | A | YES | NO
A,B |  | YES | NO

Given the same procedures, A and B, assume the procedures do not have special characters in the Instrument lines. All other procedure content is the same.

Procedures Without Special Characters in the Instrument Lines
Edited in 8.x | Edited in 7.X | Will Run in 8.x/9.x | Will Run in 7.X
 | A,B | YES | YES
A | B | YES | YES
B | A | YES | YES
A,B |  | YES | YES

Display Items with 9.0 and 7.x Procedures

Below are images that represent how procedures with 2 byte characters compiled in MET/CAL Editor 9.0 but used in MET/CAL 7.x display. In most cases a special character is prefixed with a preceding character. For example:

  • MET/CAL Editor 9.0 Procedure

  • Publish the procedure with MET/CAL Editor 9.0 and open it using MET/CAL Editor 7.x. The leading character will display in front of the © symbol.

  • Procedure compiled with MET/CAL Editor 9.0 and run on MET/CAL Runtime 9.0.

  • Same procedure run on MET/CAL Runtime 7.x

  • Procedure compiled with MET/CAL Editor 7.x

  • Same procedure run on MET/CAL Runtime 9.0 with or without compiling the procedure with MET/CAL Editor 9.0. No change to the displayed characters


Main Editor Window

When the MET/CAL Editor application is launched, the login prompt is displayed. Enter your user name and password. After successful login, the main MET/CAL Editor window is displayed. The figure below and associated table describe the main parts of the procedure editor.

  1. Main menu bar: All functions supported by the editor are available in one of the menu items
  2. File Editor Window: An edit window is available for all active documents in the editor.
  3. Change Indicator: When a change is made to an open file, a yellow highlight displays next to the text and an asterisk appears next to the file name. When the file is Saved, the asterisk is removed and the changed text rows are highlighted in green. The highlights are removed after the file or project is closed.
  4. Variable Windows: Program variables and Ask Flags are displayed on individual windows. These windows are not displayed by default and are accessed by using the Debug > Windows menu. Variables cannot be modified using these windows.
  5. Output Window: Displays errors, warnings, and status messages when building and debugging procedures. Separate error and warning windows are also displayed when an error occurs.
  6. Debug Toolbar: Use this toolbar to enable and disable procedure debugging.
  7. Main Toolbar: Right click the toolbar to enable and disable other toolbars or to access the customization dialog.
  8. Solution Explorer: Focal point of the procedure editor. All files and projects opened in the editor are available in the Solution Explorer. Double click any item in the list to open the file. The active item selected controls the options available in the File and Project menus.
  9. File Properties: The properties related to the active file in the Solution Explorer displays in the properties window. The list of available properties differs for files in a project as compared to files opened outside of a project. In all cases the full path and file name is listed in the properties window.
  10. Test Run Status: The active procedure, HEAD, HEAD2, and stimulus information displays in this dialog. This screen is equivalent to the Test Run dialog in MET/CAL version 7 and prior.
  11. Status Bar: Relevant status information related to the current program operation displays in the status bar. Always refer to the status bar when a long operation is active.
  12. Quick Launch: Allows quick access to menus and other commands by simply typing in the name of the item.


Synopsis of Editor Functions

The MET/CAL Editor menu consists of familiar menu options and some that are new and specific to the MET/CAL MET/CAL Editor. The available top level menus listed in the table below.

Menu | Description
FILE | Menu options for file creating, opening, and closing Solutions, Projects, and procedure files, and options for printing, and exiting
EDIT | Menu options for performing common edit actions
VIEW | Menu options for viewing the multiple windows that are available
DEBUG | Menu options for displaying the MET/CAL variable windows, starting, stopping, pausing debugging, toggling breakpoints; the menu is only available when a Solution is open
PROJECT | Menu options for adding new or existing items to the current project or Solution and for opening the Project Properties window; the menu is only available when a Solution is open
BUILD | Menu options for building a solution, selection (a specific project or projects), batch building and publishing packages and procedures; the menu is only available when a Solution is open
TOOLS | Menu options for launching MET/CAL Runtime, configuring instruments, generating T.U.R. report, using the Library (LIB) FSC, importing and exporting settings, and setting options
WINDOW | Menu options for arranging the various windows
HELP | Menu options for FSC Help and About


Editor File Menu

The File Menu consists of options used to create, edit, and close Solutions, Projects, Procedures, and Files as well as Exit the MET/CAL Editor. The menu options and locations may differ depending on what is open and what has the focus. The table below details menu options, sub menu options, shortcut keys, action performed, and availability of the options.

File Menu | Sub Menu | Shortcut | Action
New
Project… | Ctrl+Shift+N | Displays the ‘New Project’ dialog from which you can select to create a MET/CAL Project within the new Solution or to create an empty (Blank Solution). After the project is created, right click the project node and use the appropriate Add option to add files to the project.
Project from Existing Procedure…

The Procedure Selector is used to select the starting procedure(s). If a single procedure is selected, the new project dialog is displayed to define the directory of the new project. If multiple procedures are selected, a dialog is presented to define the output directory for the project directories.

Options:

  • All externally referenced files (e.g. procedures, images and executable programs) associated with the selected procedure(s) can be imported into the new project(s) or referenced at their existing locations, as specified in Files and Folders.
  • When multiple procedures are selected, the output projects can be built automatically to generate a directory of PXEs representing the selected procedures. When the automated build is selected, a dialog is presented to define the output directory for the PXEs.
Project from Existing *.pkm file… | A new project dialog is displayed to define the directory of the new project. Next a standard file selection box is used to select the PKM file. The PKM file is expanded to list all procedures within it. Select the desired main procedure and the import process will extract all procedures, images and programs associated with it into the newly created project.
Procedure File… CTRL+N

Creates a new empty procedure *.mc file. Use the Save As menu choice to rename and or relocate the file. The procedure file is opened in a Miscellaneous Files node in the Solution Explorer.

Opening a new procedure in this way does not add it to the active project. Use the Project menu or right click the project in the Solution explorer to access Add options to add a procedure to a project.

Bitmap File…

Opens a new .BMP document. The bitmap file is opened in a Miscellaneous Files node in the Solution Explorer.

Use the Save As menu choice to rename and or relocate the file. Creating a new bitmap in this way does not add it to the active project. Use the Project menu or right click the project in the Solution explorer to access Add options to add a procedure to a project.

Text File… | Opens a new .TXT document ready for creating a new text file. The Solution Explorer tree shows "0 Projects" and a "Miscellaneous Files" folder. Procedures should not be created by using this option. This option is provided for general text editing and not for procedure creation.
Open
Project/Solution… | Ctrl+Shift+O | Displays the ‘Open Project’ dialog for navigating to and opening an existing Project or Solution file. Use the Recent Files option to quickly select recently used projects or solutions.
File… | Ctrl+O | Displays the ‘Open File’ dialog for navigating to and opening an existing file of any allowed type. Use this option to open existing procedure files, *.mc.
Procedure… Ctrl+Shift+P

Displays the Procedure Selector dialog used to open existing compiled procedures. Procedures opened in this way are always opened outside of a project. By default the procedure text file (*.mc) is opened in a MCFiles sub directory of the active procedure directory. Use the Save As menu choice to relocate the file if desired.

All future edits to the procedure should be made to the *.mc file. Use the Build > Publish Procedures menu choice to add the procedure to the compiled procedure directory.
Add
New Project… | Displays the ‘Add New Project’ dialog to add a project to the current solution. The option has the same function as File > New > Project.
Existing Project… | Displays the ‘Add Existing Project’ dialog for navigating to and opening an existing MET/CAL project. The selected project is then associated with the active solution.
Close | Closes the active document.
Close Solution | Closes all open documents. If one or more document are altered but unsaved a Save option is provided prior to closing the files.
Delete Compiled Procedure… | Use this option to delete compiled procedures from the active procedure directory. The Procedure Selector is used to select the desired procedure.
Save Selected Items | Ctrl+S | Saves the Solution or Project that is highlighted in the Solution Explorer. The text of the option changes based on the selected item.
Save Selected Items As… | Saves the Solution or Project that is highlighted in the Solution Explorer using the location and name provided by the user in the ‘Save File As’ dialog. The text of the option changes based on the selected item.
Advanced Save Options... | Allows the user to select advanced save options, such as encoding and line endings. For MET/CAL, these settings should always be Unicode (UTF-8 with signature) and Current Setting respectively.
Save All | Ctrl+Shift+S | Saves all the files in the Solution Explorer to their current locations. Procedure files are not compiled prior to saving.
Page Setup… | Displays the ‘Page Setup’ dialog for specifying printing options.
Print… | Ctrl+P | Displays the ‘Print’ dialog for selecting print options and printing the active document.
Recent Files | Displays a list of recently opened files. This is a convenient way of accessing files that are actively being edited.
Recent Projects and Solutions | Displays a list of recently opened Solutions and Projects.
Exit | Alt+F4 | Closes the program.


MET/CAL Editor Edit Menu

The Edit Menu consists of options used to perform editing tasks on Solutions, Projects, files opened as Documents, and the Task List Window. The menu options and locations may differ depending on what windows are open and the window with the active focus. The table below details menu options, sub menu options, shortcut keys, action performed, and availability of the options.

Edit Menu | Sub Menu | Shortcut | Action
Undo |  | Crtl+Z | Reveres to most recent edit. Only enabled when changes have been made to the active file.
Redo |  | Crtl+Y | Restores the changes that have been undone.
Cut |  | Crtl+X | Copies the selected text to the clip board. When the text is pasted to another location, the text in the original location is deleted.
Copy |  | Crtl+C | Creates a copy of the selected text in memory.
Remove |  | Del | Deletes the files or Project that is selected in the Solution Explorer.
Paste |  | Crtl+V | Inserts the contents of the clipboard at the selected location. The option is available only when data has been copied to the clipboard.
Delete |  | Del | Deletes the select text in the open window.
Insert Procedure Section Tag |  | Alt+T | Inserts a set of procedure section tags at the cursor position into the open window. The cursor must be placed on a LABEL FSC statement.
Continue Line |  | F6 | Performs a Continue Line operation in the open window.
Select All |  | Crtl+A | Selects all the text in the open window.
Find and Replace |  |  |
 | Quick Find | Ctrl+F | Searches for the user entered text.
 | Quick Replace | Ctrl+H | Searches for the user entered text and replaces this text with the user entered replacement text.
 | Find in Files | Ctrl+Shift+F | Searches for text in files and lists the files that match the search criteria in the Find Results window.
 | Replace in Files | Ctrl+Shift+H | Searches for the user entered text and replaces this text with the user entered replacement text.
Go To… |  | Crtl+G | Moves the cursor to the user entered line number in the active window
Insert File as Text… |  |  | Inserts user selected file at the current location in the active window.
Advanced |  |  |
 | Make Uppercase | Ctrl+Shift+U | Converts all lower case text in the user selected text to upper case.
 | Make Lowercase | Ctrl+U | Converts all upper case text in the user selected text to lower case.
 | Delete Horizontal White Space | Ctrl+K, Ctrl+\ | Deletes white space from the cursor position to the next character.
 | View White Space | Crtl+R, Ctrl+W | Displays white space as ". . . " in the active window.
 | Incremental Search | Ctrl+I | Allows searching through the active window for one or more characters interactively.
Bookmarks |  |  |
 | Toggle Bookmark | Ctrl+K,Ctrl+K | Sets or clears a bookmark at the current text location.
 | Enable All Bookmarks |  | Enables all of the set bookmarks (option is visible only when bookmarks are enable).
 | Enable Bookmark |  | Enables the set bookmark at the current cursor location.
 | Previous Bookmark | Ctrl+K,Ctrl+P | Moves the cursor to the nearest bookmark above the current cursor location in any document within the solution.
 | Next Bookmark | Ctrl+K,Ctrl+N | Advances the cursor to the nearest bookmark below the current cursor location in any document within the solution.
 | Clear Bookmarks | Ctrl+K,Ctrl+L | Deletes all bookmarks.
 | Previous Bookmark In Folder | Ctrl+Shift+K,Ctrl+Shift+P | Moves the cursor to the previous bookmark within the active folder defined in the Bookmarks window.
 | Next Bookmark in Folder | Ctrl+Shift+K,Ctrl+Shift+N | Moves the cursor to the next bookmark within the active folder defined in the Bookmarks window.
 | Previous Bookmark in Document |  | Moves the cursor to the nearest bookmark above the current cursor location in the active document.
 | Next Bookmark in Document |  | Advances the cursor to the nearest bookmark below the current cursor location in the active document.
 | Add Task List Shortcut | Ctrl+K,Ctrl+H | Adds a shortcut to the Task List window which can be used to jump to the specified line in the file.
 | Remove Task List Shortcut | Ctrl+K,Ctrl+H | Deletes a shortcut from the Task List window.
Outlining |  |  |
 | Toggle Outlining Expansion | Ctrl+M,Ctrl+M | Reverses the hidden or expanded state of the lines that have been "outlined" in the active Open File Window.
 | Toggle All Outlining | Ctrl+M,Ctrl+L | Reverses the hidden or expanded state of all lines that have been "outlined" in the active Open File Window.
 | Stop Outlining | Ctrl+M,Ctrl+P | Removes all effects of Hiding and Outlining; returns all lines of text to normal visible state.
 | Stop Hiding Current | Ctrl+M,Ctrl+U | Removes effects of Hiding and Outlining on the current selection; returns affected lines of text to normal visible state.
Intellisense |  |  |
 | Complete Word | Ctrl+Space | Complete the entry of the current keyword.


Editor View Menu

The table below describes the menu choices in the View menu of the MET/CAL Editor.

View Menu | Sub Menu | Shortcut | Action
Open |  |  | Open the actively selected item in the Solution Explorer.
Open With… |  |  | Provides options to open the selected file with editors other than the MET/CAL procedure editor.
Solution Explorer |  | Ctrl+W, S | Display the Solution Explorer window.
Bookmark Window |  | Ctrl+W, B | Displays the Bookmark window that includes all previously defined bookmarks.
Error List |  | Ctrl+W, E | Display the Error List window. The window displays automatically when an error is encountered.
Output |  | Ctrl+W, O | Display the Output window.
Task List |  | Ctrl+W, T | Display the Task List window.
Find Results |  |  |
 | Find Results 1 |  | Displays the first Find Results window.
 | Find Results 2 |  | Displays the second Find Results window.
Other Windows |  |  |
 | Web Browser | Ctrl+Alt+R | Open a new Web Browser window.
Toolbars |  |  |
 | Compare Files |  | Enable/Disable the Compare Files toolbar.
 | Image Editor |  | Enable/Disable the Image Editor toolbar.
 | MET/CAL Debug |  | Enable/Disable the MET/CAL Debug toolbar.
 | Standard |  | Enable/Disable the Standard toolbar.
 | Web Browser |  | Enable/Disable the Web Browser toolbar.
 | Customize… |  | Display the menu and toolbar customization dialog.
Full Screen |  | Shift+Alt+Enter | Maximize the display of the MET/CAL Editor window.
Navigate Backward |  | Ctrl+- | Move back to the most recently active window.
Navigate Forward |  | Ctrl+Shift+- | Move forward to windows used previously used. The item only applies if Navigate Backward was used.
Next Task |  |  | Move forward to the next task in the Task List.
Previous Task |  |  | Moves backwards to the previous task in the Task List.
Properties Window |  | F4 CTRL+W, P | Display the file properties dialog for the actively selected file in the Solution Explorer.
Property Pages |  | Shift+F4 | Display the Property Pages window for the selected project or solution.
Stop |  |  | Stop loading the current page in the Web Browser window.
Refresh |  |  | Reload the current page in the Web Browser window.


MET/CAL Editor Debug Menu

The Debug menu provides options useful for debugging a procedure. Use the Debug toolbar or shortcuts to quickly access common debug related features.

Debug Menu | Sub Menu | Shortcut | Action
Windows |  |  |
 | Show Numeric Registers Window | CTRL+D, N | Displays numeric registers and values for MEM, MEM1, and M1-255 registers. Variables only display after they are used by the procedure.
 | Show String Registers Window | CTRL+D, S | Displays all string registers s[n], MEM2 and all user defined string variables. Variables only display after they are used by the procedure.
 | Show Object Registers Window | CTRL+D, O | Displays object register values created using the Library (LIB) FSC. Variables only display after they are used by the procedure.
 | Show Ask Flag Window | CTRL+D, A | Displays the current state of the ASK flags in the procedure. For more information about the ASK flags, refer to the ASK+ and ASK- topics.
 | Show Test Run Status Window | CTRL+D, T | Display the Test Run Status window. The display is equivalent to the Test Run window in previous versions of MET/CAL. The active procedure, revision, head, status and stimulus information display on this window.
Trace |  |  |
 | IEEE-488 I/O |  | Display a trace window with communications details associated with the IEEE-488 interface.
 | RS-232 I/O |  | Display a trace window with communications details associated with the RS-232 interface.
 | Accuracy |  | Display a trace window associated with accuracy file output information.
Compile Check Procedure |  | F9 | Compile the procedure and display any errors in the Error and Output windows.
Simulation Mode |  |  | Check this option to run procedures without having instruments connected. Ordinarily, if a procedure attempts to communicate with an instrument, and no instrument is connected, the Editor generates a warning and the instrument will time out waiting for a response. Simulation mode runs the procedure as if the instruments actually are connected, but does not do a real I/O.
Start Debugging |  | F5, | Start debugging a procedure.
Debug From Cursor |  | ALT+F5, | Start debugging the procedure from the current cursor point. Variables from the most recent test run are maintained in memory.
Stop Debugging |  | SHIFTt+F5, | Immediately aborts the active debug session.
Run |  | CTRL+F5, | Debug the procedure in free run mode. The procedure runs continuously unless.
Step |  | F11, | Steps through the current line debugging.
Toggle Breakpoint |  |  | Breakpoints temporarily suspend procedure execution. Adds or removes a breakpoint to the currently selected line of procedure text. Also, clicking the border to the left of a procedure line will add or remove a breakpoint.
Delete All Breakpoints |  |  | Deletes all breakpoints that are set.


MET/CAL Editor Project Menu

The Project Menu is only visible and functional when a Project is open. Use the items in this menu to add files to projects and manipulate the properties of a project. The sub menus of the Project menu change depending on the active selection in the Solution Explorer. When a project is selected the items below are available.

Project Menu | Sub Menu | Shortcut | Action
Add New Item… | Ctrl+Shift+A | Displays the Add New Item dialog for adding a new MET/CAL Bitmap, MET/CAL Procedure, or text file to the current project in the solution.
Add Existing Item… | Shift+Alt+A | Displays the Add Exiting Item dialog for navigating out to and selecting an existing document to add to the current Solution.
Project Build Order | Displays the Project Dependencies dialog. Not used by MET/CAL.
Current Solution Properties…

Displays the Property Page dialog for the currently selected Project in the Solution Explorer and allows for editing of the Project Properties.

The project properties should not be confused with the file properties. Portions of the project properties are visible in MET/CAL Runtime when a PXE is selected.


MET/CAL Editor Build Menu

The Build Menu is for building Solutions, MET/CAL Projects, Publishing Packages, Procedures, and performing Batch Builds. This menu is only visible when a project is open in the Solution Explorer.

Build Menu | Sub Menu | Shortcut | Action
Build Solution | Ctrl+Shift+B | Builds each project associated with the active solution.
Build Project

Ctrl+Shift+P

 Builds the active MET/CAL project by compiling the procedure files and copying all procedure and related files to a \Bin sub directory relative to the project directory.
Batch Build… | Provides options to build selected projects in the active solution.
Publish Package… | Alt+P | Compresses all files in the project release directory into a package type based on the active project properties. PKM and PXE files are the supported package types.
Publish Selected Procedures Shift+Alt+P

Compiles and saves the procedure files selected in the Solution Explorer to the active compiled procedure directory. Select multiple files by holding down the Ctrl key and selected the desired procedure files in the Solution Explorer.

Publishing individual procedures does not perform a dependency check. If the procedure does not compile it is not saved to the procedure directory.

Publish Selected Procedures To… | Shift+Alt+T | Similar to the menu choice above, however users can choose the target compiled procedure directory opposed to using the current compiled procedure directory. Any directory can be selected. If a proc.dir file is located in the directory, the selected procedures are added it. If a proc.dir file is not present in the selected directory, a new proc.dir file is created.


MET/CAL Editor Tools Menu

The Tools Menu is for performing various MET/CAL specific actions and for using the Library FSC.

Tools Menu | Sub Menu | Shortcut | Action
Launch MET/CAL Runtime |  |  | Detects and launches the MET/CAL Runtime using the same login credentials used to log into the MET/CAL Editor.
Generate T.U.R Report |  | Ctrl+T | Generates a T.U.R Report based on the selected procedure.
Library FSC |  |  |
 | Component Definition Wizard… |  | Launches the Library FSC Component Definition Wizard and guides the user through the component definition process.
 | Rectify Definition Files |  | Verifies and corrects the formatting of the Library FSC definition files.
 | Merge Workstation/Solution Definition Files |  | Merges the contents of the workstation’s definition files with the definition files in the current solution.
 | Add/Update Definition Files in Solution |  | Adds and/or updates the Library FSC definition files in the current solution.
 | Insert STRUCT Code Snippet… |  | Generates a code snippet for a Library FSC STRUCT and inserts it into the current procedure (or copies it to the clipboard).
Automated Build... |  |  | Prompts user to select an input and an output directory, and then build all the projects in the selected input directory to the output directory without stopping for build errors.
External Tools… |  |  | Displays the External Tools dialog to manage Add-Ins used by the MET/CAL Editor. There are no external tools included with the default installation of the MET/CAL.
Import and Export Settings… |  |  | Displays the Import and Export Settings Wizard used to export, import, or reset the Visual Studio environment settings.
Customize |  |  | Used to customize menus and toolbars.
Options… |  |  | Displays the Options dialog for setting user selectable options in the MET/CAL Editor.


MET/CAL Editor Window Menu

The Windows Menu is used to open and layout files within an active solution. The word "Document" refers to an open file that can be edited (procedure file, help file, image file, etc). The word "Window" refers to any of the windows that can be viewed within the MET/CAL Editor (see Main Display). Many of the items listed below are available by manipulating windows using the mouse drag and drop or by right clicking the top of a window.

Window Menu | Sub Menu | Shortcut | Action
New Window |  |  | Creates a copy of the currently selected document that is highlighted in the Solution Explorer.
Split |  |  | Splits the currently selected highlighted document into two windows for ease of viewing.
Remove Split |  |  | Removes the split from the document being displayed.
Float |  |  | Undocks the currently selected window allowing it to be positioned wherever the user likes.
Float All |  |  | Undocks all docked windows allowing them to be positioned wherever the user likes.
Dock |  |  | Repositions a window to the upper right-hand corner of the editor screen.
Dock as Tabbed Document |  |  | Creates a "tab" window for the currently selected document or window.
Auto Hide |  |  | Applies to windows - when turned on, the window is minimized to the rightmost side of the Editor screen. To use the window, click on the icon. When Auto Hide is turned on, the window slides out of the way when another window is used. To turn off Auto Hide, click on the window, then the Window >Dock option.
Hide |  |  | Hides the currently selected window from the Editor screen. To display the window, select the View > Window option (does not apply to documents).
Auto Hide All |  |  | Applies to windows - when turned on, the all windows are minimized to the rightmost side of the Editor screen. To use the window, click on the icon. When Auto Hide is turned on, the window slides out of the way when another window or document is used. To turn off Auto Hide All, click on the window, then select the Window > Dock option.
New Horizontal Tab Group |  |  | Creates groups of tab documents (increases ease of viewing numerous tab documents) displaying and grouping the documents horizontally.
New Vertical Tab Group |  |  | Creates groups of tab documents (increases ease of viewing numerous tab documents) displaying and grouping the documents vertically.
Move to Next Tab Group |  |  | Moves focus to the next Tab Group.
Move to Previous Tab Group |  |  | Moves focus to the previous Tab Group.
Close All Documents |  |  | Closes all open documents.
Reset Window Layout |  |  | Resets the Editor screen to the default layout (Toolbar Window minimized on the left side of the screen and the Solution Explorer and Properties Windows open and docked to the right side of the screen).
List of open Documents |  |  | Brings the selected document to the top of the display and makes it active.
Windows… |  |  | Displays a list of documents contained in the current solution that can be selected, activated, or closed.


MET/CAL Editor Help Menu

The Help Menu provides options for opening the Help system and the About dialog.

Menu | Sub Menu | Shortcut | Action
MET/CAL Editor Help |  |  | Opens the help system to the MET/CAL Editor help topics.
FSC Help |  | F1 | Opens the help system to the topic for the currently selected FSC.
About MET/CAL Editor |  |  | Displays MET/CAL Editor About dialog.


Launching Other Applications

Unlike prior versions of MET/CAL, the MET/CAL Editor Tools menu cannot be customized. The menu is pre-designed to launch MET/CAL Runtime only. MET/TEAM must be launched using a desktop shortcut.

Launching MET/CAL Runtime using this option still requires a user login. For password security reasons, the log-in credentials associated with MET/TEAM cannot be passed between the programs.

Procedures can execute only when either MET/CAL Runtime or MET/CAL Editor are open. If both programs are running neither can be used to execute a procedure. As a result it is good practice to only run one of these programs at a time. The MET/CAL Editor also consumes a MET/CAL license. If both programs are active, two MET/CAL licenses would be consumed.


Editor Configuration

The Editor Configuration category includes settings related to the MET/CAL Editor.

Auto Insert Current User as Author

Controls whether or not the Editor automatically inserts the full name of the current user in procedure Author: lines which are automatically generated. Default is Checked.

Procedure Header Date: Include time (Optional)

If this box is checked, the current local time is appended to the date in the procedure header "DATE:" line when a procedure is compiled. Format: HH:MM:SS, 24-hour clock. Default = Checked.

Resume Debugging Search IEEE-488 Board 0

Determines whether or not IEEE-488 port 0 is always searched prior to procedure execution in Test Run. Default = Checked.

Unchecking this option causes Debug Mode to skip the bus search, except the first time and after a change to the instrument configuration.

String Register Variable Display

When viewing local variables in the MET/CAL Editor's String Registers window you can adjust how the local variables are displayed. If you want to see which subroutine level this local variable is associated with, set it to Show Subroutine Level. If you do not want to see the subroutine level, set it to Don't Show Subroutine Level. If you are set to not show the subroutine level and a local variable has the same name as a previous variable in a prior subroutine, only the current value in the current subroutine's scope will be shown.

Adjustment Threshold (Optional)

Specify the default adjustment threshold in the procedure header. Default = 70%.

Procedure Title (Left)

This text becomes the left portion of the first line in the header of a procedure.

Procedure Title (Right)

This text becomes the right portion of the first line in the header of a procedure.

Procedure Header Date: Format

Specifies the format for the date string in the procedure header. If anything goes wrong in attempting to format the date using the format string specified, MET/CAL silently reverts to the default (YYYY-MM-DD).

Format Descriptors
DD | day number
MM | month number
MON | 3-letter month name
MONTH | full month name
YY | 2-digit year number (for window 1970 - 2069)
YYYY | 4-digit year number

Rules:

  1. No format code may occur twice.
  2. At most one of { MM, MON, MONTH } may occur.
  3. At most one of { YY, YYYY } may occur.
  4. Other characters are copied unchanged.


T.U.R Report

The T.U.R. Report lets you create procedures with special comments that show the T.U.R. following each evaluation. A T.U.R. report helps you identify and address those tests where the application did not have enough information and either made an estimate or did not compute the T.U.R. These comments may indicate that the T.U.R. cannot be computed or was estimated based on range information. Also use the Debug > Trace > Accuracy menu to troubleshoot accuracy information when unexpected accuracy information is reported in the T.U.R report. To generate a T.U.R. report, proceed as follows:

  1. Open a procedure or use the one you are creating.

  2. If the procedure is not compiled, compile the procedure. A T.U.R. report cannot be generated for a non-executable procedure.

  3. From the Tools menu, select Generate T.U.R. Report.

  4. A message indicates that the report is being generated. Then, a new window shows the procedure with the T.U.R. information embedded in it as comment lines. The new window is named the same as the original procedure prefixed with T.U.R.

  5. If you want to save the procedure with T.U.R. information embedded, use File > Save As option on the open T.U.R. procedure.


LIB FSC Wizard

The Library FSC submenu in the Tools menu of the MET/CAL Editor provides access to features that support writing procedures that use the Library (LIB) FSC. The LIB FSC adds support for using Component Object Model (COM) components, Win32-style DLL library functions, user-defined data structures and arrays in MET/CAL procedures.

Using the LIB FSC to its full potential in a MET/CAL procedure requires that you do some things above and beyond what is required by most other FSCs. The LIB FSC is definitely an advanced FSC that you should not attempt to use without a good understanding of how it works and what is required. The following is a list of some of the things you should know about the LIB FSC before starting:

  • Component Object Model (COM) components (which includes ActiveX components) can be complex and very complicated to use. If you want to use a COM component in a procedure, you should have a good understanding of how the component works and how to use it properly by reading the manufacturer’s documentation before attempting to proceed.
  • Although not required, it is highly recommended that all COM components be defined using the Component Definition Wizard in order for the LIB FSC to understand how to interface with them. Refer to the Component Object Model (COM) Component Definitions section below for details on using the wizard.
  • Win32-style DLL functions can also be must be defined using the Component Definition Wizard in order for the LIB FSC to understand how to interface with them. Refer to the Win32-style Dynamic Link Library (DLL) Component Definitions section below for details on using the wizard.
  • COM components must be properly installed and registered on the workstations where the procedure is being written and on any computer where the procedure needs to run. DLL files must also be located in a folder where they can be found (either included in the project’s folder or in a folder referenced by the PATH environment variable).
  • In most cases, the LIB FSC files that contain COM component and DLL definition information must be included in the solution with your procedure. Refer to the Library FSC Definition Files section below for details on managing and including these files in the solution.
  • New capabilities have been added to the RESET FSC and a new FSC called CLEAR has been created to facilitate proper termination of MET/CAL procedures that utilize the LIB FSC. When writing a procedure that uses the LIB FSC, you need to understand how to use the RESET and/or CLEAR FSCs to accomplish this. Refer to the LIB, RESET, and CLEAR FSC documentation in the reference manual for more details on using these FSCs together.

The LIB FSC opens a whole new realm of possibilities for MET/CAL procedures to interface with other tools and applications that were not previously available. But with this new realm of possibilities comes a new set of challenges. Make sure you analyze and understand the risks of using these features before you begin.

To begin using the LIB FSC in a procedure, follow this basic process:

  1. Identify the COM components and/or Win32-style DLLs that you want to use in your procedure.
  2. Obtain and read the component’s and/or DLL’s manufacturer’s documentation on the proper usage.
  3. Make sure the COM components to use are properly installed on the development computer and any DLL files are located in a folder
  4. Use the Library FSC’s Component Definition Wizard to define the components and/or DLL functions. Use the Tools > Library FSC > Component Definition Wizard… menu option.
  5. Create your MET/CAL procedure project.
  6. Add the LIB FSC definition files to the solution using the Tools > Library FSC > Add/Update Definition Files in Solution… menu option.
  7. Write your procedure. Be sure to use the RESET and/or CLEAR FSCs where appropriate to ensure proper termination of the procedure.
  8. Debug your procedure using the Start Debugging (Test Run) features of the editor.

When distributing your procedure to other workstations, you must make sure any COM components and properly installed and registered on the workstations and any DLL files are either included with the procedure or are located on the workstation in a folder referenced by the PATH environment variable.


Component Definition Wizard

The Component Definition Wizard… menu option displays a utility that facilitates the identification and definition of Component Object Model (COM) components and Win32 DLL functions and data structures to be used in a MET/CAL procedure.

Although the LIB FSC does not require definitions for COM components by default, it is recommended that any COM component to be accessed from a MET/CAL procedure be defined and the statement "LIB SET REQ_DEF = 1" be added at the top of the procedure. Defining a COM component provides the following benefits:

  • More reliable runtime data type conversion. Without a definition, the runtime engine must make a best guess as to the data types of properties and arguments and return values of methods of COM components. This can lead to runtime errors and possible termination of procedure execution. When a COM component definition is provided, the runtime engine is able to determine if property, method and argument values are of the proper data type (i.e. numeric or string) and provide meaningful feedback to the user if there is a conflict.
  • Use of enumerations. When a COM component definition is created, any properties, methods or arguments that use enumerated values automatically have an enumeration definition created also. Enumeration values can then be used in place of a numeric literal value or instead of needing to assign a value to a register or named variable.

When using Win32 DLL functions in a MET/CAL procedure, definitions are required. If no definitions exist, a runtime error will be generated and procedure execution will terminate. Without definitions, the runtime engine is unable to perform necessary data type conversions for function arguments and return values. In addition, some Win32 DLL functions require either custom data structures or arrays as arguments. The Component Definition Wizard provides a way to define data structures also.

Component Object Model (COM) Component Definitions

Component Object Model (COM) component definitions are generated by selecting the Component Definition Wizard… option from the Library FSC submenu in the Tools menu of the MET/CAL Editor. The Library FSC – Component Definition Wizard dialog is displayed.

In order for a COM component to be used in a MET/CAL procedure, it must be properly installed and registered on the computer. The same is true for using the Component Definition Wizard to create the definition for the component.

To be proficient at using the wizard to create the definition for a COM component, it is strongly recommended that you become familiar with how to use that COM component in a programming language. Once you understand the nuances of how a particular COM component is used, using the wizard will become much easier. Simple examples of COM component usage in development environments such as Visual Basic are readily available on the internet and can be extremely helpful in gaining an understanding of how to implement the usage of a COM component in a MET/CAL procedure. Referencing the component manufacturer’s documentation is also recommended.

Select the Component Object Model (COM) component option and click Next.

If you want to create the definition for a new COM component, select the Automatically generate definition for a registered COM component option.

To manually modify the definition for a COM component that has been previously defined, select the Manually define properties and methods for a registered COM component option.

Generally it is not recommended to manually create or modify the definition of a COM component. However, there are certain instances where this may be necessary, such as to modify the return data type of a method or the data type of an argument when the automated wizard was unable to properly identify the correct data type.

After selecting the appropriate option, click Next.

If the Manually define properties and methods for a registered COM component option was selected, choose whether to Define properties and methods of a new COM component or Modify the existing definition of a COM component by selecting the appropriate option.

If the Modify the existing definition of a COM component option is selected, the drop-down list is populated with COM components that are currently defined. Select the component to work with from the drop-down list.

After selecting the appropriate option, click Next.


Manually Defining Properties and Methods

When selecting the Manually define properties and methods for a registered COM component option, the Library FSC – Manual Component Definition dialog is displayed.

Generally it is not recommended to manually create or modify the definition of a COM component. However, there are certain instances where this may be necessary, such as to modify the return data type of a method or the data type of an argument when the automated wizard was unable to properly identify the correct data type.

The name of the COM component is indicated in the COM component name box. This box is not editable when modifying the existing definition of a COM component. When creating a definition for a new COM component, enter the name by which the COM component is programmatically accessed.

This is the name by which the COM component will be instantiated in a procedure using the statement LIB COM variable = "component.name".

The Alias box indicates an alternate name for the COM component. This value is optional and may be left blank. Assigning an alias to a COM component allows that component to optionally be used in a MET/CAL procedure by referring to its alias instead of the formal name.

The Description box contains a description of the COM component. This is for informational purposes only and is optional.

The box on the right side of the dialog shows all of the properties and methods of the component that are currently defined. This view is updated automatically when adding or removing properties and methods from the COM component definition. Selecting a property or method in this box has no effect.

The Properties and Methods options allow properties and methods of the COM component to be selected using the accompanying drop-down list. The controls below these options change depending on which option is selected.

  • To add a new property or method to the COM component definition, select the Properties or Methods option accordingly and click the [image] button to the right of the drop-down list. Use the controls below to define the property or method name and other settings.
  • To remove an existing property or method from the COM component definition, select the Properties or Methods option, then select the property or method to remove from the drop-down list and click the [image] button to the right of the drop-down list.
  • To modify an existing property or method, select the Properties or Methods option, then select the property or method to modify from the drop-down list and use the controls below to modify the settings.

When finished, click the OK button to write the changes to the definition file. To discard all changes made, click the Cancel button. If you wish to save all changes without closing the dialog, click the Apply button.

Editing COM Component Method Settings

When the Methods option is selected, the controls below the drop-down list reflect appropriate settings for a method.

The Method name box indicates the name of the method. When defining a new method, enter the name of the method here.

The Method return data type drop-down list indicates the data type or enumeration associated with this method. When defining a new method, select the appropriate return data type or enumeration from the drop-down list. If the required enumeration is not in the drop-down list, select System.Int32 as the return data type and check the This data type is an enumeration checkbox.

The data types in the list consist of core Microsoft .NET data types and any currently defined enumerations. These data types may not match exactly the documentation provided by the COM component manufacturer. Therefore, it may be necessary to select the closest match when defining a new COM component method.

The Arguments grid displays a list of arguments for the selected method.

  • To add a new argument to the selected method, click the [image] button on the right side of the Arguments grid.
  • To remove an existing argument from the selected method, select the argument to remove and click the [image] button on the right side of the Arguments grid.

The grid indicates the argument name, data type, how the argument is to be passed to the method, whether or not the argument is optional, and whether the argument is an enumeration.

  • The Name field indicates the name of the argument. The name is arbitrary and only serves to help the user understand what value is expected to be passed.
  • The Data Type field indicates the expected data type of values to be passed for the argument. This setting is used to perform data type conversions when invoking the method.
  • The By Ref field indicates how the argument value gets passed into the method when invoked. If unchecked, the value for this argument is only passed into the method. If checked, a value may be passed in, but it is expected that the method will also return a value in this argument.
  • The Opt field indicates whether a value for this argument is required or optional. Optional arguments do not need to be provided when invoking the method. By definition, when an argument is marked as optional, all subsequent arguments must also be marked as optional.
  • The Enum field indicates whether this argument is an enumeration. If the required enumeration is not in the Data Type drop-down list, select System.Int32 as the data type and check the Enum checkbox.

Once the method settings are correct, you may select another method or property or save the changes by clicking the OK button or the Apply button.


Automatically Generating COM Properties

When selecting the Automatically generate definition for a registered COM component option, the Library FSC – COM Component dialog is displayed.

The Select the COM component to define drop-down list is populated with all of the registered COM components found on the computer. A typical computer may have thousands of registered COM components, however not all registered COM components are useable. Some commonly used COM components that may appear in the drop-down list and could be utilized in a MET/CAL procedure include:

  • Microsoft Excel Application (Excel.Application)
  • Microsoft Word Application (Word.Application)
  • Microsoft Outlook (Outlook.Application.14)
  • Internet Explorer (InternetExplorer.Application)
  • Adobe PDF Reader (AcroPDF.PDF)

The "friendly" name of the COM component is listed with the programmatic component name indicated in parentheses. The programmatic name is the name that the MET/CAL procedure needs to use to interface with the component using the LIB COM variable = "component.name" statement.

Many top level COM components such as the components listed above are in fact made up of many smaller COM components, each of which performs certain functions or tasks or store certain information. These smaller COM components are referred to as dependent or related components and are often referred to as children of the top level component. In order to fully use a COM component, all of the dependent or related components must be defined in addition to the top level component.

It is highly recommended that you use the COM component manufacturer’s documentation to become familiar with the component and all dependent/related child components before attempting to use it in a procedure or using the wizard to create the definitions. Having a basic understanding of the components and their usage will prove to be a huge benefit as you perform these tasks.

As an example, the Microsoft Excel Application component is a very complex component made up of many dozens of other COM components. For this reason, this component will be used in this section as an example of how to properly use the Library FSC wizard to create the definition of a COM component. The chart below is just a small piece of the Microsoft Excel object model showing the relationships between the application, workbooks, worksheets, charts, ranges and other components. Note that all of the dependent or related components may not be useable from a MET/CAL procedure.

The remainder of the settings on this dialog indicate how the wizard should attempt to create definitions for these dependent or related components.

Choose options for the selection of dependent/related components

These settings determine how the wizard behaves when it identifies dependent or related components that are children of the top level component.

Checking the Properties checkbox indicates the wizard should attempt to get a reference to a dependent or related component by accessing any readable properties of the top level component that have a data type that is a COM component. For example, the Excel.Application component has a property called Workbooks which provides access to a Microsoft.Office.Interop.Excel.Workbooks component, which holds a collection of all open workbooks in the application.

Checking the Methods checkbox indicates the wizard should attempt to get a reference to a dependent or related component by invoking any methods of the top level component that return a COM component. For example, the Excel.Application component has a method called Intersect() which returns a Microsoft.Office.Interop.Excel.Range component, which references a cell or range of cells on a worksheet.

Selecting the Always prompt to manually enter values for any arguments option instructs the wizard to display a dialog allowing the user to specify values for arguments to be passed into a property or method invocation. For example, when reading the Worksheets property of the Excel.Application component, an argument indicating which worksheet to access is required. Selecting this option allows the user to manually enter a value for this argument to use when attempting to read the Worksheets property. Using a generic, default value for this argument will likely fail.

Selecting the Attempt to use default values for any arguments option instructs the wizard to use generic, default values for any arguments required by a property or method invocation. While there are many occasions where this may be adequate, most situations may require the user to choose the values of arguments.

Argument values entered on dialogs displayed by the wizard as it attempts to define dependent/related components are not saved with the definitions of the properties and/or methods. These values are merely used once in an attempt to instantiate a dependent/related component for the purpose of creating the definition of that dependent/related component.

Once the selections have been made, click the Next button to proceed. If the selected component already exists in this workstation’s definition file, a prompt is displayed indicating the current definition will be overwritten by continuing. Click Yes to overwrite the current definition or click No to cancel this process.

Depending on the options selected on the Library FSC – COM Component dialog and the complexity of the selected COM component, the dialogs described in the following sections may or may not be displayed during the automated component definition process.

Select Dependent/Related Components

If the Always prompt to select which components to define option was selected on the Library FSC – Component Definition Wizard dialog and the selected COM component has one or more dependent/related COM components, the Library FSC – Select Dependent/Related Components dialog will be displayed.

This dialog lists all of the detected dependent/related components of the current component being defined (as indicated at the top of the dialog) and allows the user to select which dependent/related components the wizard should attempt to define. In order to reduce the time required to create the definitions and to simplify this process, it is recommended to select only the components that need to be accessed from a MET/CAL procedure.

Select the dependent/related components to define by simply clicking the desired items I the list. To unselect an item, simply click that item again.

For the Microsoft Excel application component, typical usage from a MET/CAL procedure only requires selecting the following dependent/related components:

  • Microsoft.Office.Interop.Excel.Range
  • Microsoft.Office.Interop.Excel.Sheets
  • Microsoft.Office.Interop.Excel.Workbook
  • Microsoft.Office.Interop.Excel.Workbooks

One other necessary component, Microsoft.Office.Interop.Excel.Worksheet, is actually missing from this list because there is no property or method of the Excel.Application component that has this component as a data type. This component is a dependent/related component of one or more of the components listed above and can be selected later as the wizard attempts to create the definitions for the above selected components.

Checking the View Options checkbox allows the user to modify the options selected on the Library FSC – Component Definition Wizard dialog.

Changing the options on this dialog applies only to dependent/related components (children, grandchildren, etc.) of the component indicated in the paragraph at the top of this dialog.

Refer to the Library FSC – Component Definition Wizard dialog section above for information regarding the usage of each of the options on this dialog.

Once the desired components have been selected, click the OK button to proceed.

Get Argument Values

The Library FSC – Get Argument Values dialog is displayed if the Always prompt to manually enter values for any arguments option was selected and the wizard is attempting to get a reference to a dependent/related COM component by getting the value of a property or invoking a method of another component.

Argument values entered on this dialog are not saved with the definition of the property/method. These values are merely used once in an attempt to instantiate the indicated dependent/related component for the purpose of creating the definition of that component.

This dialog allows the user to enter values for arguments to be used when getting the value of the indicated property or invoking the indicated method. The instructions at the top of the dialog indicate the name of the component the wizard is attempting to define. The Component name box indicates the name of the COM component being used. The Property name or Method name box indicates the name of the property or method that the wizard is attempting to use. The grid lists all of the arguments that the property or method accepts, including the argument names, expected data types, whether the arguments are optional or an enumeration, and provides a column for entering the value to be used.

If the user wants the wizard to skip attempting to use the indicated property or method to get a reference to the dependent/related component, simply click the Skip button.

Depending on the property or method being used, the wizard may or may not be able to successfully get a reference to the dependent/related component independent of the argument values specified on this dialog. This is because some components must be created first using other properties and/or methods before they can be accessed. Since it is impossible for the wizard to know this unique criteria for every COM component, the wizard includes an advanced component definition tool that is described later.

When entering a value for each argument, make sure the value entered is appropriate for the indicated data type for that argument (i.e. do not enter an alpha-numeric string if the data type column indicates System.Double, or do not enter a floating-point number if the data type column indicates System.Int32).

If the Opt column is checked for an argument, that argument is optional and entering a value in the Value column may not be necessary.

If the data type column indicates System.Object, such as with the Range property of the Excel.Application component, this typically indicates the argument is able to handle either alpha-numeric strings or numeric values. In this case, if you are entering an alpha-numeric string, it must be enclosed in double-quotes as shown in the dialog above.

When all necessary argument values are entered, click OK to proceed. The Library FSC – Get Argument Values dialog may be displayed many more times, depending on the success or failure of the wizard to get references to the selected components and the complexity of each component.

If the wizard is able to successfully get a reference to the indicated component using this property or method, the wizard will skip all other properties and/or methods that refer to the same dependent/related component. If not successful, however, the wizard will attempt to get a reference to this component using another property and/or method. Therefore, you may be prompted more than once to enter argument values as the wizard attempts to get a reference to the same component again.


COM Component Definition Results

Once the wizard has completed its initial pass over the selected COM components, the results are displayed in the Library FSC – COM Component dialog.

This dialog first displays a list of COM components that the wizard was able to successfully create definitions for. If the wizard was able to successfully define all selected components, click the Finish button to close the wizard.

Otherwise, click the Next button. A list of components that the wizard was unable to define is displayed. This list includes all selected components that were not defined as well as all components that were not selected.

Clicking the Advanced button on this dialog displays the Library FSC – Advanced COM Component dialog which allows the user to manually select methods and/or properties to invoke in any order necessary to create instances of components to be defined. This dialog is explained in the following section. Upon returning from the Library FSC – Advanced COM Component dialog, if there are still some dependent/related components that have not been defined, the items in the list turn red and clicking the Finish button causes a warning prompt to be displayed indicating there are still undefined components.

Click the Finish button to close the wizard.


Advanced COM Component

The Library FSC – Advance COM Component dialog provides a way for the user to manually select properties and methods of a COM component to invoke in an attempt to get references to dependent/related components from which a definition can be created.

The Component tree shows the base component that was initially selected. The Undefined components list indicates all of the dependent/related components that were identified but not defined either because they were not selected or because the wizard was unable to get a reference to them to create the definition. Items are removed from the Undefined components list as the wizard is able to define each component.

The Property and Method options determine the content of the drop-down list. To select a property to get the value of, select the Property option and select the desired property from the drop-down list. To invoke a method, select the Method option and select the desired method from the drop-down list. The Data type box indicates the selected property’s data type or the return value data type of the selected method. If the selected property or method does not return a COM component, the Invoke Property or Invoke Method button is disabled.

Once the desired property or method is selected, click the Invoke Property or Invoke Method button. The wizard will attempt to get the value of the selected property or invoke the selected method. If the property or method requires arguments, the Library FSC – Get Argument Values dialog is displayed. Information on the usage of this dialog can be found in the Get Argument Values section above.

If the wizard is successful in getting a reference to the selected component, the definition is created.

When all desired components have been defined, click the Close button to close the dialog.

As an example of how to properly use the Advanced COM Component wizard, let’s select the Microsoft Excel Application component to define the necessary dependent/related components for using Excel in a MET/CAL procedure. These are the components that we need to define:

  • Microsoft.Office.Interop.Excel.Range (Range)
  • Microsoft.Office.Interop.Excel.Sheets (Worksheets)
  • Microsoft.Office.Interop.Excel.Worksheet (Worksheet)
  • Microsoft.Office.Interop.Excel.Workbook (Workbook)
  • Microsoft.Office.Interop.Excel.Workbooks (Workbooks)

Here’s a brief explanation of what needs to be done to create a definition for all of these components:

  • The Range component refers to one or more cells on a worksheet and cannot be created until we have a reference to a Worksheet component.
  • The Worksheet component belongs to a Workbook and cannot be accessed until we either create or open a Workbook.
  • The Workbook component cannot be accessed until a workbook is opened or created. The Workbooks component contains a collection of all open workbook components.
  • In order to open or create a Workbook component, we need to invoke the Add() or Open() method on the Workbooks component. We can’t invoke those methods until we have a reference to the Workbooks component.

It is highly recommended that you use the COM component manufacturer’s documentation to become familiar with the component and all dependent/related child components before attempting to use it in a procedure or using the wizard to create the definitions. Having a basic understanding of the components and their usage will prove to be a huge benefit as you perform these tasks.

So, let’s start by getting a reference to a Workbooks component. We can do this by selecting the Excel.Application component in the component tree, selecting the Property option, then selecting the Workbooks property from the drop-down list and clicking the Invoke Property button:

A message is displayed indicating the Workbooks component was successfully created. The Workbooks component is then evaluated by the wizard to determine its dependent/related components. After a few seconds, a message is displayed indicating the Workbooks component definition has been written to the definition file. The Microsoft.Office.Interop.Excel.Workbooks component is added to the component tree as a child of the Excel.Application component and the Library FSC – Select Dependent/Related Components dialog is displayed.

The wizard will not be able to define the Workbook component yet, so click the Cancel button to close this dialog.

Now let’s create a new Workbook by invoking the Add() method of the Workbooks component. Select the Microsoft.Office.Interop.Excel.Workbooks component in the component tree, select the Method option, select the Add method from the drop-down list and click the Invoke Method button.

The Library FSC – Get Argument Values dialog is displayed because the Add() method has an optional Template argument. Click the OK button to continue without specifying a value for this argument.

A message is displayed indicating the Workbook component was successfully created. The Workbook component is then evaluated by the wizard to determine its dependent/related components. After a few seconds, a message is displayed indicating the Workbook component definition has been written to the definition file. The Microsoft.Office.Interop.Excel.Workbook component is added to the component tree as a child of the Microsoft.Office.Interop.Excel.Workbooks component and the Library FSC – Select Dependent/Related Components dialog is once again displayed.

Click the Cancel button to close this dialog.

Now let’s get a reference to the Worksheets component by invoking the Worksheets method of the Excel.Application component. Select the Excel.Application component in the component tree, select the Property option, select the Worksheets property from the drop-down list and click the Invoke Property button.

A message is displayed indicating the Worksheets component was successfully created. The Worksheets component is then evaluated by the wizard to determine its dependent/related components. After a few seconds, a message is displayed indicating the Worksheets component definition has been written to the definition file. The Microsoft.Office.Interop.Excel.Sheets component is added to the component tree as a child of the Excel.Application component and the Library FSC – Select Dependent/Related Components dialog is displayed.

Click Cancel to close this dialog.

Now let’s get a reference to a Worksheet component by selecting the Microsoft.Office.Interop.Excel.Sheets component in the component tree, selecting the Property option, then selecting the Item property from the drop-down list. Notice the data type associated with this property is System.Object instead of the expected Microsoft.Office.Interop.Excel.Worksheet type. More on this in a moment. Click the Invoke Property button.

The Library FSC – Get Argument Values dialog is displayed because the Item property requires an argument indicating the index of the Worksheet component to return. The Index argument is of type System.Object and may accept either a number or the name of the Worksheet. With this particular property, however, the name of the spreadsheet must be used. In the Value column for the Index argument, enter "Sheet1" (including the double-quotes) and click OK.

A message is displayed indicating the Worksheet component was successfully created.

At this point, the Library FSC – Component Name dialog is displayed. This dialog is only displayed when the data type of the selected property or the return type of the selected method is generic, such as System.Object. The component returned by the Item property is in fact a Microsoft.Office.Interop.Excel.Worksheet component. To update the data type definition for this property, enter Microsoft.Office.Interop.Excel.Worksheet in the box provided and click OK.

After a few seconds, a message is displayed indicating the Worksheet component definition has been written to the definition file. The Microsoft.Office.Interop.Excel.WorkSheet component is added to the component tree as a child of the Microsoft.Office.Interop.Excel.Sheets component and the Library FSC – Select Dependent/Related Components dialog is again displayed.

Select the Microsoft.Office.Interop.Excel.Range component and click OK. After a few more seconds, a message is displayed indicating the Range component was successfully written to the definition file and the Microsoft.Office.Interop.Excel.Range component is added to the component tree as a child of the Microsoft.Office.Interop.Excel.WorkSheet component . Because the Range component also has many dependent/related components, the Library FSC – Select Dependent/Related Components dialog is again displayed. Click Cancel to close this dialog.

The basic components required for using a Microsoft Excel spreadsheet in a MET/CAL procedure are now defined. Click the Close button on the Library FSC – Advanced COM Component dialog to close the wizard.

As you can see, the process of getting a reference to certain components can be a bit tricky and sometimes non-intuitive. Gaining a good understanding of how components are used in a programming environment is essential to being able to effectively using the Library FSC wizard to define COM components. If you wish to use other aspects of the Microsoft Excel application, you may use the wizard to define the components that you would like to interface with.


LIB FSC Win32 DLL Definitions

Win32-style dynamic link library (DLL) component definitions are generated by selecting the Component Definition Wizard… option from the Library FSC submenu in the Tools menu of the MET/CAL Editor. The Library FSC – Component Definition Wizard dialog is displayed.

In order for a Win32-style DLL component to be used in a MET/CAL procedure, it must be located somewhere on the computer. The same is true for using the Component Definition Wizard to create the definition for the component.

In order to create the definition for a Win32-style DLL component, it is strongly recommended that you obtain the proper documentation from the DLL manufacturer indicating the function return value data types and argument data types. Attempting to create definitions for Win32-style DLL functions without this documentation may not be possible.

Select the Win32-style Dynamic Link Library (DLL) option and click Next.

Select the Manually define functions found in a Win32-style DLL option and click Next.

Next, choose whether to Define the functions in a new Win32-style DLL or Modify the existing definition of a Win32-style DLL by selecting the appropriate option.

If the Modify the existing definition of a Win32-style DLL option is selected, the drop-down list is populated with DLLs that are currently defined. Select the component to work with from the drop-down list.

Click Next to continue.

Manually Defining Functions in a Win32-Style DLL

When selecting the Manually define functions found in a Win32-style DLL option, the Library FSC – Manual Component Definition dialog is displayed.

Manually creating the definition of the functions in a Win32-style DLL is required. You cannot use a Win32-style DLL function in a procedure without a definition.

The name of the Win32-style DLL file is indicated in the Library file name box. This box is not editable when modifying the existing definition of a Win32-style DLL. When creating a definition for a new Win32-style DLL, click the [image] button to the right of the Library file name box to select the DLL file. The Select Win32 DLL Library File dialog is displayed. Navigate to the location of the DLL file, select it and click Open. A prompt is displayed asking if the exported function names should be read in from this library. Click Yes. A message will be displayed indicating how many function names were read in from the library.

The Description box contains a description of the Win32-style DLL. This is for informational purposes only and is optional.

The box on the right side of the dialog shows all of the functions of the Win32-style DLL that have been read in from the DLL or are currently defined. This view is updated automatically when adding or removing functions from the DLL component definition. Selecting a function in this box has no effect.

The Get Exported Functions… button attempts to read in the list of exported functions from the selected Win32-style DLL. Reading in the exported functions will not overwrite currently defined functions. This feature should be used when defining a DLL for the first time or when attempting to restore a function that was previously removed from the definition.

The Define Structs… button provides a utility for defining user-defined data structures for use as data types with Win32-style DLL functions. This feature is described in the following sections.

  • To add a new function to the DLL component, click the [image] button to the right of the function drop-down list. Use the controls below to define the function name and other settings.
  • To remove an existing function from the DLL component definition, select the function to remove from the function drop-down list and click the [image] button to the right of the drop-down list.
  • To modify an existing function, select the function to modify from the function drop-down list and use the controls below to modify the settings.

When finished, click the OK button to write the changes to the definition file. To discard all changes made, click the Cancel button. If you wish to save all changes without closing the dialog, click the Apply button.

Editing Win32-style DLL Function Settings

The controls below the drop-down list reflect appropriate settings for a function.

The Function name box indicates the name of the function. When defining a new function, enter the name of the function here.

The Function return data type drop-down list indicates the data type associated with this function. When defining a new function, select the appropriate return data type from the drop-down list. If the function required a user-defined data structure that is not in the drop-down list, click the Define Structs… button to define the data structure. Data structures are added to the data type drop-down list automatically.

The data types in the list consist of typical Win32 (unmanaged) data types and any user-defined data structures and may not match exactly the documentation provided by the DLL manufacturer. Therefore, it may be necessary to select the closest match when defining a new function. New data types may be added to this list by modifying the file that serves as the source of this information. For details on modifying this file, refer to the Managing Win32 DLL Data Types section below.

The Arguments grid displays a list of arguments for the selected function.

  • To add a new argument to the selected function, click the [image] button on the right side of the Arguments grid.

  • To remove an existing argument from the selected function, select the argument to remove and click the [image] button on the right side of the Arguments grid.

The grid indicates the argument name, data type, and whether the argument is an array.

  • The Name field indicates the name of the argument. The name is arbitrary and only serves to help the user understand what value is expected to be passed.

  • The Data Type field indicates the expected data type of values to be passed for the argument. This setting is used to perform data type conversions when invoking the function. If an argument’s value is to be passed by reference (meaning if a value is expected to be returned in this argument), be sure to select a pointer data type (typically ends with "*"). In all cases, this selection should match the DLL manufacturer’s documentation. If the argument is a user-defined data structure that is not in the drop-down list, click the Define Structs… button to define the data structure. Data structures are added to the data type drop-down list automatically. If the argument is not a standard Win32 data type, either select the standard data type that is the closest match or refer to the section Managing Win32 DLL Data Types below for information on how to add additional user-defined data types to the drop-down list.

  • The Array field indicates whether this argument is an array. When this option is checked, the variable used for this argument must be declared using the LIB ARRAY statement.

Once the function settings are correct, you may select another function or save the changes by clicking the OK button or the Apply button.

Defining User-Defined Data Structures for Win32 Functions

Many Win32-style DLL functions require user-defined data structures as return values or as an argument to a function. Clicking the Define Structs… button on the Library FSC – Manual Component Definition dialog displays the Library FSC – Select Struct dialog.

Use this dialog to choose whether to Create a new struct definition or Use an existing struct definition by selecting the appropriate option.

If the Use an existing struct definition option is selected, the drop-down list is populated with user-defined structures that have been previously defined. Select the structure to work with from the drop-down list.

Click OK to display the Library FSC – Struct Definition dialog.

User-Defined Data Structures for Win32-style DLLs

The Library FSC – Struct Definition dialog allows data structures for use with Win32-style DLL functions to be defined.

The Struct name box indicates the name of the data structure. This box is disabled when editing the definition of an existing data structure. When creating a new data structure, enter the name here.

The name of the data structure is arbitrary. However, when creating a data structure for use with a Win32-style DLL, it is recommended to use the same name as found in the DLL manufacturer’s documentation to facilitate referencing the data structure for return values and/or argument data types.

The Members grid displays a list of members or fields of the data structure.

  • To add a new member to the data structure, click the [image] button on the right side of the Members grid.
  • To remove an existing member from the data structure, select the member to be removed and click the button on the right side of the Members grid.

The grid indicates the member name and data type.

  • The Name field indicates the name of the member or field. The name is arbitrary and only serves to help the user understand what value is expected in this member.
  • The Data Type field indicates the expected data type of the values to be stored in this member or field. This setting is used to perform data type conversions when passing this data structure as an argument or return value of a function. In all cases, this selection should match the DLL manufacturer’s documentation. If the argument is not a standard Win32 data type, either select the standard data type that is the closest match or refer to the section Managing Win32 DLL Data Types below for information on how to add additional user-defined data types to the drop-down list.

If the data type of a member of a structure is another user-defined data structure, you will not be able to use this data structure or any functions that require this structure in a MET/CAL procedure. MET/CAL currently does not support data structures that are embedded in other data structures.

Once the data structure is defined, save the changes by clicking the OK button.

Insert STRUCT Code Snippet

The Insert STRUCT Code Snippet… menu option generates a code snippet and inserts it into the cursor’s location in the current MET/CAL procedure if one is open. Otherwise, the code snippet is copied to the clipboard.

When using the LIB FSC to interface with Win32-style DLL functions that require a user-defined data structure, the data structure must be defined in the procedure from which the function is to be called. This feature facilitates the definition and writing of the procedure code to accomplish this.

User-defined data types can be used in a MET/CAL procedure by themselves to store sets of related data. It is not a requirement that data structures only be used with Win32-style DLL functions.

Selecting the Insert STRUCT Code Snippet… menu option displays the Library FSC – Select Struct dialog.

Use this dialog to choose whether to Create a new struct definition or Use an existing struct definition by selecting the appropriate option.

If the Create a new struct definition option is selected, click OK to display the Library FSC – Struct Definition dialog.

If the Use an existing struct definition option is selected, the drop-down list is populated with user-defined structures that have been previously defined. Select the structure to work with from the drop-down list. Click OK to generate the code snippet and insert it into the current procedure or copy it to the clipboard.

User-Defined Data Structures

When defining a data structure for standalone use in a MET/CAL procedure, the Library FSC – Struct Definition dialog allows the user to define data structures with members that do not require data types.

If a user-defined data structure is going to be used with a Win32-style DLL function, you must access the Library FSC – Struct Definition dialog by clicking the Define Struct… button on the Library FSC – Manual Component Definition dialog. Accessing the dialog that way allows data types to be specified for each member. Data types are required when using a data structure with a Win32-style DLL function.

The Struct name box indicates the name of the data structure. Enter the name for the data structure here.

The Members grid displays a list of members or fields of the data structure.

  • To add a new member to the data structure, click the [image] button on the right side of the Members grid.

  • To remove an existing member from the data structure, select the member to delete and click the [image] button on the right side of the Members grid.

    The grid indicates the member name only.

  • The Name field indicates the name of the member or field.

The Write to definition file checkbox indicates whether this definition should be saved to the definition file. If this is a one-time usage of this data structure, uncheck this box. If you wish to save this definition for use in other MET/CAL procedures, check this box.

Once the data structure is defined, click the OK button to generate the code snippet and insert it into the current procedure or copy it to the clipboard.


LIB FSC Definition Files

In most cases, using the LIB FSC in a procedure to access COM components and Win32-style DLL function requires the addition of a couple of support files to the procedure’s solution. These support files, commonly referred to as the Library FSC definition files, contain definitions of the components, functions and data structures to be used as well as necessary conversion information for Win32 data types. This section describes how to use and manage these definition files.

The definition files consist of two XML files:

  • libraryfsc.xml – This definition file contains the definitions for all COM components, DLL functions, enumerations and data structures that can be used by the LIB FSC. The content of this file is managed by the Library FSC Component Definition Wizard and should rarely be modified manually.
  • datatypemap.xml – This definition file contains mappings of data type information for Win32-style DLL functions and data structures. The content of this file should only need to be updated in certain situations explained in the Managing Win32-Style DLL Data Types section below.

When writing a procedure that uses the LIB FSC, the definition files typically must be added to the solution. Refer to the Adding Definition Files to a Solution section below for more information on adding the definition files to the solution. The only times when the definition files are not required to be added to the solution are when:

  • You are using a COM component and the "REQ_DEF" setting is set to "0". This is the default setting. However, it is highly recommended that you set this setting to "1" at the beginning of the procedure and include the definition files in the solution.
  • The procedure does not belong to a solution. In this case, the definition files in the shared folder are used.
  • You are only using the LIB FSC for data structures and arrays.

Adding Definition Files to a Solution

When writing a procedure that uses COM components and/or Win32-style DLLs, the definition files typically must be added to the solution, except in the special cases identified in the previous section.

The master copies of the definition files reside in the MET/CAL shared folder. The exact location of the shared folder depends on how MET/CAL was installed. When the definition files are added to a solution, the master files are copied to the solution folder and references to these copies are added to the solution.

To add the definition files to the current solution, select the Tools > Library FSC > Add/Update Definition Files in Solution menu option.

As the menu name implies, this option can also be used to update the contents of the definition files that belong to a solution. Anytime the Library FSC Component Definition Wizard is used, the changes to the definition files are recorded only in the master copy of the files in the shared folder. For these changes to be recognized by a procedure, the solution’s copy of the definition files must be updated. Selecting this menu option updates the solution’s definition files.

Merging Definition Files

When a solution that includes a copy of the definition files is being developed by multiple procedure writers, it is possible for the definition files in the solution to get out of sync with the definition files in the shared folder on any of the workstations, especially if the workstations are not part of the same network. The Tools > Library FSC > Merge Workstation/Solution Definition Files menu option should be used to merge the contents of the workstation’s master copy of the definition files with the solution’s copy of the files. Merging the definition files will keep both the solution’s copy and the master copy up to date.

It is strongly recommended that the definition files be merged every time you start working on a procedure in a solution to prevent the possible loss of definition information.

Rectify Definition Files

The majority of the content of the definition files is created by using the Library FSC Wizard. There are very few cases where you should be required to manually edit the contents of these files. However, on occasion it may be necessary to do so. In the case where the contents of the definition files has been manually edited, you should immediately use the Tools > Library FSC > Rectify Definition Files menu option. This menu option initiates a process that checks the content of the files and makes any necessary corrections to ensure that the LIB FSC will be able to locate definitions in the files.

Managing Win32-Style DLL Data Types

One of the critical functions of the definition files is to properly identify the data types of function return values and arguments for Win32-style DLL functions. Without proper definitions, the LIB FSC will fail when attempting to invoke DLL functions. Part of this definition information is a map from standard C/C++ programming language data types (the language that many Win32-style DLLs are written in), which are referred to as "unmanaged" data types, and their equivalent Microsoft .NET data types, which are referred to as "managed" data types.

The datatypemap.xml definition file serves this purpose. The content of this file should only need to be modified to add new data types or when absolutely necessary to resolve problems when the current mappings do not function as expected. It is highly recommended that you do not alter the contents of this file unless directed to do so. Any time this file is altered, you should use the Tools > Library FSC > Rectify Definition Files menu option to make sure the format of the file is legible by the LIB FSC.


Automated Build

The Automated Build feature is a tool to create packages from your MET/CAL projects in bulk. This tool will go through a specified directory and its subdirectories, building any projects that it finds into the selected output directory. This makes it easy to build all projects at once without requiring them to first be grouped them into solutions.

  1. Select "Automated Build…" from the "Tools" menu.

  2. Select the top level directory that contains all of the projects (.mcproj files) that you wish to build.

  3. Select the output directory for the build operations.

    1. If the selected directory is not empty, you will be notified and allowed to cancel at this point.

      If you proceed with a directory that is not empty, the directory contents will be deleted.

  4. The Editor will load each project file it encounters during the scan and attempt to perform a "multi" build. A multi build is the equivalent of setting the Project Property for "Publishing > Publish file type" to "multi". This build process produces the following output into the selected directory:

    1. One .pxe file package.

    2. One .zip of the project source.

    3. One manifest describing the contents of the packages.

  5. When the Automated Build completes, the output directory will also contain a log of the projects that built successfully and projects that failed to build.


Creating a New Procedure

From the main menu, select File > New > Procedure File (or press Ctrl+N) to create a new empty procedure named Proceduren.mc (where n is a number chosen by the MET/CAL Editor). This is the procedure source file and will contain the procedure in text form. The procedure is added to the Miscellaneous Files node and is not part of a Project. Use the File > Save As option to save the procedure file to a different folder, or with a different filename, if desired.

Creating a procedure in this fashion is equivalent to creating procedures in MET/CAL Editor version 7 and prior.

When the procedure edits are complete use the Build > Publish Procedure menu option to make the completed procedure available to MET/CAL Runtime for use in a test.

Add a Procedure to a Project

Refer to this image for each of the following instructions to add a new or existing procedure to an open Project.

Add a New Procedure

To add a new, blank procedure file to your open Project, right-click the Project name and select Add > New Item. Select the MET/CAL Procedure item from the list to create a blank MET/CAL procedure file. Optionally, specify the procedure file name to replace the default name.

Add an Existing Procedure

From Procedure File (*.mc)

To add a previously-created procedure file to your open Project, right-click the Project name and select Add > Existing Item from the menu. Browse to the procedure file and select it to add it to your project.

From a Procedure Directory (proc.dir)

To add a previously-created procedure file to your open Project, right-click the Project name and select Add > Item from Existing Procedure from the menu. Use the Procedure Selector to find the procedure and add it to your project. The MET/CAL Editor will automatically convert the selected procedure to a procedure file and save it to the same directory as the Project. The procedure file will be named after the selected procedure's INSTRUMENT line.


Naming a Procedure

The procedure name is the text stored in the INSTRUMENT line(s) of a procedure file. Up to six INSTRUMENT lines are supported in a single procedure file. CALL statements in an outside procedure can launch a procedure by referencing any of its instrument lines. Each INSTRUMENT line represents the name of the procedure. The MET/CAL Editor keeps track of all names (INSTRUMENT lines) and knows that all six names belong to one procedure source file.

Do not confuse the procedure name with the procedure source file name.

The default procedure created using File > New > Procedure (or Ctrl+N) includes a single INSTRUMENT line. Copy and paste this line to create additional INSTRUMENT lines. For more information about naming a procedure, refer to Naming a Procedure.

A name conflict exists if any of the possible six names of one procedure is the same as a name in another procedure. These problems may occur when you modify or create new procedures with names already in the Procedure Directory. The conflict error message will display when publishing the procedure to the compiled procedure directory.


Selecting and Opening a Procedure

Procedures that already exist as *.mc files can be opened using the File > Open > File menu choice. The File > Recent Files menu is also a useful shortcut to accessing procedures that have been recently used.

To open a procedure that was previously published to a legacy procedure directory (proc.dir), use the File > Open > Procedure menu. The Procedure Selector is used to find and select procedures. When a procedure is opened, the MET/CAL Editor attempts to automatically convert it to a procedure file with the *.mc file extension. The file will be named after the selected procedure's INSTRUMENT line. All subsequent procedure edits are saved to the *.mc file.

The compiled procedure in the procedure directory (proc.dir) is updated only when the *.mc file is published using the Build > Publish Selected Procedure(s) menu item.

Attempting to open a procedure from the procedure directory where a *.mc version of the procedure already exists will generate the dialog below. This is a warning to the user that their *.mc file will be overwritten with the contents of the selected procedure, from state where it was last published. The dialog includes information about the last time the file or procedure were edited, to help make the decision of which to open. If the *.mc file has been published recently, the date and times of the files will be similar and the contents of the files will be the same.

Any work previously saved to the *.mc file will be overwritten if you choose to open the procedure from the procedure directory.


Saving a Procedure

Starting with MET/CAL version 8, saving a procedure has a new meaning. Saving a procedure in all prior versions of MET/CAL directly modified the compiled procedure directory. When editing a *.mc file, the various file save options simply save the file or procedure project but do not modify the compiled procedure directory. The only way to update the compiled procedure directory is by using the Build > Publish Selected Procedure(s) and Build > Publish Selected Procedure(s) To options. Procedure files that cannot successfully complete a Compile Check may not be published but they may still be saved as text in the *.mc file format, allowing procedure edits to be saved as the author progresses.


Save Options and Changed Files

Save Options

The File > Save and File > Save As menu options vary based on the active selection in the Solution explorer. When an individual file is selected, the save operation is specific to the file. When a project or a solution is selected the save operation is specific to the project or solution.

Use the File > Save All option to save all items that have been altered in the current solution.

Changed Files

The Editor provides several different types of notifications to let the procedure author know when a file's contents have changed, and the location and nature of those changes. You can see the effects of change tracking by following a few steps:

  1. Open a file and make some changes to produce yellow bars and activate the asterisk.
  2. Save your file to change the yellow bars to green.
  3. Undo the change(s) to see the bars turn to orange.

Asterisk

Files that have changed include an asterisk after the file name on the file's edit dialog.

Color Bars

When a file is first opened, the margin area is blank. As you modify procedure code, color bars are provided to identify the location and state of a modified line using three different color indicators:

Yellow

Indicates that the line is different from the originally loaded file, and the changes have not yet been saved to disk.

Green

Yellow bars change to green when the file is saved. This indicates that the line(s) have been changed from the originally loaded file, and the changes have been saved to disk.

Orange

Indicates that your code matches the originally loaded file, but your changes that were saved to disk are different.


Printing a Procedure

The File > Print menu opens a dialog box that lets you print the current procedure. To print the procedure to a PDF, install a PDF printer and select it as the print device in the print dialog.

To print a procedure, proceed as follows:

  1. Open the procedure you want to print.
  2. From the File menu, select Print. A Print dialog box appears.
  3. Choose the options you want and select OK to print the active procedure.

The File > Page Setup option lets you change the type of printer used, the page orientation, and the paper size. Depending on the printer available in your system, this selection has additional options that let you send the file as an encapsulated postscript file, remove margins, and create and send a header. Advanced options allow you to send particular true type fonts and manipulate graphics in your document.


Hiding a Procedure

Hiding procedures makes them invisible to the MET/CAL Runtime. It is common to hide sub procedures or procedures under development. The Procedure Selector has features to hide and unhide procedures in the active Compiled Procedure directory.

In a procedure project use the file properties dialog and choose True as the Hidden Procedure option. In the case of a procedure project, the Hidden property is relevant only when the Package Type is a PKM file.


Deleting a Procedure

The File > Delete Compiled Procedures option in the MET/CAL Editor is provided to remove compiled procedures from the active procedure directory. Procedures deleted in this way are also removed from the hard disc so ensure that the proper procedure is selected when this option is used.

The Procedure Selector is provided to select procedures to delete. Select one or more procedures and press select to remove them from the procedure directory. A second confirmation message is presented before the procedures are removed. After the files are deleted they cannot be restored.


Change the Default Directory for Compiled Procedures

In MET/CAL Runtime, the Procedure Selector can all be used to change the default procedure directory. This directory represents the location of compiled procedures.


Using the Basic Edit Functions

The following paragraphs describe how to manipulate text within a procedure. These functions all start from the Edit menu. Equivalent keyboard short cuts are available to more efficiently use these edit features while altering a procedure. The edit options described below function on the active on the active procedure.

Undo/Redo

Use Undo or Redo to step back or forward through edits that have been made up to the last time that a file was saved.

Cut

Cut lets you cut selected text out of a procedure. Place your cursor at the beginning of the text you want to cut. Hold down the left mouse button and drag the cursor to highlight the text. Select Cut. The text is removed from the procedure and placed into the Windows clipboard, ready to be pasted.

Copy

Copy lets you copy selected text from one part of a written procedure to either another part of a procedure or a different procedure. To copy text, highlight the text you want to copy and select Copy. The text is copied into the Windows clipboard, ready to be pasted. Copy operations work on files in the Solution Explorer.

Paste

Paste lets you insert the contents of the Windows clipboard at the current cursor position. The cursor may be positioned within any document window. To paste text after you copied or cut it, place the cursor where you want the text placed. From the Edit menu, click Paste. The text is positioned after the cursor.

Delete

Delete lets you delete selected data from a document. This selection is different than the Cut selection because once you delete information from a document, it cannot be recovered. To delete text, highlight the text you want removed and press Delete. Pressing Delete when the cursor is on a blank line deletes the line.


Continue Line

Edit > Continue Line lets you mark the current line as a continuation of the previous line. This is useful for certain FSCs that allow multi-line statements. F6 is the shortcut for this function. Place the cursor on the line following the line that you wish to continue. Press F6 and the line numbers are automatically updated.

The use of the Continue Line function is common in DISP and LIB FSC statements. For more information about Continue Line, refer to the Continuation Statements topic.

Below is an example of a continued line statement.


Inserting a File

Edit > Insert File as Text... lets you insert the text of an external text file at the cursor position in the opened procedure. This is different from cut and paste or copy and paste. When you select a file that you want to insert into the new procedure, Insert File as Text copies and pastes everything in the source file. To insert a file, proceed as follows:

  1. From the Edit menu, select Insert File as Text.... The Insert dialog box opens.
  2. Select the file you want inserted into the active procedure, the select OK. The file is inserted into the active procedure and the dialog box closes.


Quick Find and Quick Replace

The MET/CAL Editor's Find and Replace operations allow you search for and optionally replace text within procedure files. The MET/CAL Editor searches forward or backward until the first occurrence of the text is found. The Find and Replace operations refer to procedure files as "Documents". The search operation can be performed on just the Current Block (Current Paragraph), the Current Document, All Open Documents, the Current Project, or the Entire Solution.

Find/Command Box

You can search for text from the Find/Command box in the MET/CAL Editor toolbar. Click in the box or press Ctrl+/ to select it, then specify the text to search. The last 20 items entered are retained and displayed them in a drop-down list. You can navigate through the list using the arrow keys.

When you specify text in the Find/Command box and then choose the ENTER key, the MET/CAL Editor searches the current document using the options that are specified in the Find in Files dialog box.

Quick Find

To quickly find text in a procedure, proceed as follows:

  1. From the menu, select Edit > Find and Replace > Quick Find or press Ctrl+F. The Find dialog box appears in the upper right corner of the active window.

  2. In the Find... field, type in the text you are looking for. Notice that the MET/CAL Editor highlights all matches for easy recognition.

    Select the text that you want to find before pressing Ctrl+F to pre-populate the Find... field.

  3. Choose any options you would like to use to control the search:

    1. Case sensitivity
    2. Whole word
    3. Regular expressions
    4. The scope of the search

  4. To start the search, click the arrow button to the right of the Find... box or press F3.

Find Next

Find Next provides an alternate way to continue searching for text that you have specified in the Find dialog box. Use Find Next when you want to use the Find command without displaying the Find dialog box, or when you are looking for the next occurrence of your search text. You must have previously specified text under the Find option for this to work.

  1. Press F3 to initiate the Find Next. The found text is highlighted in the procedure, but a Find dialog box does not appear.
  2. Continue to press F3to find the next item(s).

Find Previous

Find Previous works the same way as Find Next to find previous occurrences.

  1. Press Shift+F3 to initiate the Find Previous. The found text is highlighted in the procedure, but a Find dialog box does not appear.
  2. Continue to press Shift+F3to find previous item(s).

Quick Replace

Quick Replace works the same way as Quick Find, but includes an additional field to supply the Replace... text.

  1. From the menu, select Edit > Find and Replace > Quick Replace or press Ctrl+H. The Replace dialog box appears in the upper right corner of the active window.

  2. In the Find... field, type in the text you want to find. If you used the Find or Replace options in the current session, the text from the previous search is already there. Type over the text to search for a different string. The search supports wild card characters such as * and #. Notice that the MET/CAL Editor highlights all matches for easy recognition.

    Select the text that you want to find before pressing Ctrl+F to pre-populate the Find... field.

  3. Tab to the Replace... field, type the text you want to use as the replacement.

  4. Choose any options you would like to use to control the search:

    1. Case sensitivity
    2. Whole word
    3. Regular expressions
    4. The scope of the search

  5. To start the search, click the arrow button to the right of the Find... box or press F3. To replace text, click the Replace next icon near the Replace... field or press Alt+R. To replace all occurrences, click the Replace all icon or press Alt+A.

    Use Replace all with caution to prevent text from being replaced unintentionally.

Find in Files

To perform more advanced find and replace operations, refer to Find in Files and Replace in Files.


Find in Files

The Edit > Find and Replace > Find in Files option is very similar to the Quick Find choice. The difference is that all results to the find criteria are listed in a single output window. Double click any row in the find results window and the editor will open the selected file and place the cursor on the specific line. The Find Results window automatically displays in the location in which it was last accessed.

This is a very useful feature when attempting to make manual edits across multiple procedures. For example translating a procedure from English to French could be simplified by doing a Find in Files search for "DISP" statements. Double click each DISP state in the Find Results window and translate the affected text. The Find Results acts as a to-do list for the task.


Replace in Files

The Edit > Find and Replace > Replace in Files, option is very similar to the Quick Replace option. The key difference is that the results are listed in a separate window and there are options to limit the search to specific file types. Configure the Find and Replace operation and begin the process by using the Find Next, Replace or Replace All buttons.

Undo can be used on the replace option only when the affected file is opened in the editor. A warning is provided to support undo operations when affected files are not actively opened in the editor.

The results are output to the selected Find Results window. Double click any row to automatically open the affected file. The cursor is automatically paced on the line of the changed text.


Procedure Sectioning

Description

Procedure Sectioning support allows a procedure executable package to be run in separate sections to perform a single calibration. This makes it possible to perform a single calibration across multiple physical locations and/or different times, or with only a portion of the required hardware, and automatically combine the results into a single report. Section selection is often used to simplify troubleshooting, repeating discrete portions of a procedure that failed, and to run sections of a procedure based on available hardware. A sectioned procedure does not require standards to be configured for sections that are not selected. This functionality is supported as of MET/CAL 8.2 and MET/TEAM 2.0. MET/BASE 8.2 users can also use sectioned procedures, however there are no automated data combining features.

A sectioned procedure is created by adding labels and "tag" comments to an existing, functioning procedure that is part of a procedure project. Procedure Section Tags are a set of comment lines in one procedure in a project, which follow a specific syntax, and that tell the compiler that this section of the procedure can be skipped over when running the procedure from MET/CAL©. The boundaries of the section are defined by a LABEL statement for the start and end. If the section is skipped over at run time, the process jumps to the end label the same way as if a JMPL statement had been inserted into the procedure code. This feature is only applicable to procedures run in PXE format.

Procedure sectioning is not supported in *.txt procedure files; *.mc is required.

Section Tags do not alter the functionality of the procedure. They are present only to provide section details to the MET/CAL Runtime. The resultant procedure must be compiled to a Procedure Executable package and executed to review the Procedure Section Selection Dialog. The Section Selection dialog will display in both MET/CAL Runtime and MET/CAL Editor. The dialog includes section specific details defined by the procedure author. Selected sections are executed, those that are not selected are skipped. Procedure code not contained within a tagged section will always execute. For this reason it is not desirable to design a tagged procedure that generates results outside of a tagged section.

To disable the Procedure Sectioning dialog, uncheck the Procedure Section Selection MET/CAL Configuration setting. In this case the procedure will run from start to end as though there were no defined sections within the procedure.

When a MET/CAL procedure is launched by MET/TEAM, previously executed sections are presented in a bold text are not selected by default.

Below is an example of the sectioned procedure user interface. This is the first dialog presented when running a sectioned procedure, where the section user interface is enabled.

Procedure Section Selection

When MET/TEAM is used as the asset manager, all sections of a procedure are added to the same work order, regardless of when or where the procedure is executed. MET/TEAM includes features to quickly review the sections previously executed, remove unwanted sections and to limit the generation of a calibration certificate until all required sections are complete. The pre-installed calibration certificates will combine the data from all sections and separately group sections marked As Found compared to sections marked As Left.

Legacy Support

Sectioned procedure packages will continue to run in any version of MET/CAL that supports the procedure executable format (.pxe), assuming that the PXE does not use additional features that are unavailable in the prior version. However the section selection dialog in MET/CAL Runtime will not be available in versions prior to MET/CAL 8.2. The procedure will run ignoring the procedure section syntax.

The functionality is designed to work with procedures packaged in the PXE format. If a procedure with section tagging is saved to the legacy compiled procedure format, the procedure will run ignoring the procedure section syntax. The Section Selection dialog will not be displayed in MET/CAL Runtime when a legacy compiled procedure is used.

How to Define a Procedure Section

Sectioned procedures leverage the existing LABEL FSC mechanism to separate the procedure into sections. By themselves the labels operate as they always have in MET/CAL, but when combined with the new "section tagging syntax", the labels become sections of a procedure that can be run independently of other tagged sections of the procedure. Section tags are specially formatted comments that provide details for sections identified by the LABEL FSC.

Tests are grouped together in a section because they are usually run together, for example if they use the same standard. If, a Fluke 5500 is used, the labels may read something like this: TESTS_USING_FLUKE_5500_START and TESTS_USING_FLUKE_5500_END. The labels are added to the procedure at the beginning and end of the group of tests and will then be referenced in the tag comments.

Another example would be to group together tests that require the technician to manually enter measurement values, so that the section can be skipped when no technician is available, and run just the remainder of the procedure.

Only one procedure in the project can use the sectioning syntax. This procedure is identified by the Sectioned Procedure property. This property can be set for only one file in the project. Section details added to other files are ignored and the ALT+T tag short cut will generate a warning message .

To define a section, enter a starting and ending label around a block of procedure code. Use "START_" and "END_" as a prefix or "_START" and "_END" as a postfix to the label. Using this scheme is not required, however it will simplify the creation of tag comments.

A LABEL bound section can be turned into an independent procedure section by inserting tag comments that describe the section. Tag comments can be entered manually or by editing an auto-generated Procedure Section tag. Tag comments, like general comments in a procedure, start with the #-sign and are formatted in green. However, unlike general comments, the font changes to italic, to indicate the special function of tag comments.

Required Section Tag Comments

# Tag.Name = name text
# Tag.Start = beginning text
# Tag.End = ending text

where Tag.Name references a unique name for the tag within the procedure and Tag.Start and Tag.End reference the starting and ending labels that surround the group of tests, respectively.

Optional Section Tag Comments

# Tag.Prerequisites = semicolon separated list
# Tag.Description = description text
# Tag.ExecutionTimeInMinutes = estimated time in minutes (integer)
# Tag.Notes = notes text
# Tag.HasOperatorPrompts = Boolean
# Tag.IsRequired = Boolean

Section Tag Comment Descriptions
Tag | Value | Description
Tag.Name | name text | Required tag comment that represents the name for the tagged section. The tag comment must be unique to the package.
Tag.Start | beginning text | Required. This is the label that defines the beginning of the tagged section. Note labels are case-sensitive!
Tag.End | ending text | Required. This is the label that defines the end of the tagged section. Note labels are case-sensitive!
Tag.Prerequisites semicolon separated list

A semicolon separated list of Tag.Name sections required to be run before running this section. For example, a test may have a setup section that is required to run before running the test, there can be a warm-up time or a safety inspection step.

If a section is defined nested within another section, the parent section is assumed to be a prerequisite. In this case this element is not required.
Tag.Description | description text | A description of the section that is displayed in the section selector dialog. MET/CAL Runtime users can view this information prior to starting a procedure.
Tag.ExecutionTimeInMinutes estimated time in minutes (integer)

The estimated amount of time it takes to run the section. Enter an integer number that reflects a best-guess estimate in minutes for how long the section takes to run to completion, or an actual measured duration.

Entering execution times for all tag comments allows the technician to select sections to run, based on how much time is available for a procedure run. This is displayed in the section selector dialog. The summation of execution times is presented to the MET/CAL Runtime user as an estimate of the procedure execution time.
Tag.Notes | notes text | Notes for the test that are written to the CallSheetResults.mNotes field when the results are saved to MET/TEAM.
Tag.HasOperatorPrompts | Boolean | Displayed in the section selector as information to the operator to inform them if the section will prompt them for user input. Enter 1 for TRUE and 0 for FALSE. This is to assist the technician selecting sections to run based on operator availability.
Tag.IsRequired | Boolean | This marks a section as required in order to close the Work Order. Enter 1 for TRUE and 0 for FALSE. This does not require the section to be run each time the procedure is run, it only impacts when a MET/TEAM Work Order can be marked as complete. If the required section is run one or more times, the Work Order can be marked as complete. Use this property to ensure that critical sections of a procedure are always run. Sections that are not marked as required can be skipped. If this tag is not specified, the section is assumed to be required (TRUE).

Quick tip help is available when editing tag comments.

Inserting Auto-Generated Section Tag Comments

The MET/CAL Editor has a menu option on the Edit menu, that allows for inserting an auto-generated Procedure Section tag, at the starting label. The keyboard shortcut is Alt+T. When the section is bound by labels that begin with "START_" and "END_" or if the labels end with "_START" and "_END", Tag.Start and Tag.End are automatically populated. If the labels are not automatically populated manually enter the appropriate starting and ending label values along with the other relevant Tag details. Tag.Name, Tag.Start, and Tag.End are required tag comments for publishing the package. The remaining tag comments are optional and can be left blank or deleted if desired. The table below defines the list of available tag comments.

To insert the auto-generated tag comments into the procedure, first place the cursor at the starting label for the section and then press Alt+T or select the Insert Procedure Section Tag option.

The auto-generated set of tag comments includes all required and optional tag comments currently recognized by the compiler. The start label is automatically gleaned from the LABEL statement the tag is inserted at. If the start label value contains a START_ prefix or _START suffix, the end label in the procedure tag will default to a matching counter part with the same name but an END_ prefix or _END suffix, respectively.

Nested Sections

A nested section is one that includes tag comments that start and end within another section. Nested sections display as indented elements on the Section Selection Dialog. When running the procedure, if a nested section is selected, the parent section is automatically selected. Use nesting to group similar procedure elements. Do not include statements that will generate MET/CAL results within the parent section of a nested group.

The figure below is an example of a nested procedure. The tag comments were removed and the procedure text is indented for simplicity. Do not indent labels when nesting a procedure section. The minimum tag comments of Name, Start and End are required to properly define the procedure section.

Section Limitations

  • Legacy compiled procedures selected by using the Procedure Selector will not support Procedure Sectioning.
  • Procedure sections must be defined in a procedure project. The resultant PXE file launched by the MET/CAL Runtime will provide access to the section selection dialog.
  • Tag comments can only be placed in the procedure with the Sectioned Procedure property set to True.
  • Any procedure code outside the tag will be run each time the procedure is run regardless of the sections selected
  • Any results generated outside of a tagged section will generate a separate result section for each run.
  • Using the JMPL FSC to jump to a section that is not selected to run will cause the JMPL command to fail, terminating procedure execution.
  • Tag comments can be nested up to 4 layers deep. Nested tag comments beyond 4 layers are ignored.
  • Nested tag comments must begin and end within the same tag.

Verifying Section Tags

To validate the tag comments, publish the package to a PXE (ALT+P); Compile Check procedure (F9) will not validate tag comments. The compiler will post an error message if a tag comment contains an error, for example a typo (the trailing T was omitted).


Running a Sectioned Procedure

A PXE (Procedure Executable) that includes Procedure Sections has an augmented initialization dialog to facilitate the selection of the desired sections. When the procedure runs, only standards and supporting hardware required by the selected sections are required. Each completed section is individually flagged and written to the same Work Order.

A PXE can be run in one of four ways:

  • Double-click a PXE file to launch it within MET/CAL Runtime
  • Launch the procedure via MET/TEAM
  • From the MET/CAL Runtime SETUP view's Procedure area:
    • Click the SELECT PXE button
    • Click the SELECT MET/TEAM PROCEDURE button

In all cases, the operator is presented with the Procedure Section Selection dialog. From this screen they can see the properties of the Procedure Executable package, the sections available to run, and the properties for the selected section. Once the operator selects the tests to run and presses OK, the procedure execution proceeds as normal. When the test is complete the MET/TEAM Work Order Results tab will list each section of results individually.

  • Required sections are colored red.
  • To select all procedure tags, click the Select All button.
  • To unselect all procedure tags, click the Clear All button.
  • Once the desired sections are selected and unselected, click OK to start running the procedure.
  • Clicking Cancel aborts running the procedure.

Item | Description
1 | Instrument line selection. All instrument lines associated with the PXE are available for selection in this field.
2 | Project Properties associated with the PXE are displayed in this table. The items can be changed only by editing the original procedure project and creating a new PXE file.
3 | Tool-tip help on the currently selected PXE property element.
4 | All available sections of the PXE are presented in the list. If the PXE does not support sectioning or the Procedure Section Selection MET/CAL Configuration setting is not checked, the section view is hidden and the procedure will run from start to finish ignoring any section definition information.
5 | Summation of the time of all selected procedure sections. The time is defined by the procedure author and may differ from the actual execution time.
6 | Section Tag details specific to the currently selected section.
7 | Tool-tip help on the currently selected section tag property.


Sectioned Procedure in MET/TEAM

The Section Status button on MET/TEAM Work Orders is enabled when the Work Order includes data collected with sectioned procedures. Press the button to review a list of available sections and determine which sections have been completed. All sections flagged as Required must be completed before the Work Order can be closed. Review the MET/TEAM help system for additional details.

Calibration Results

The calibration results are saved to the MET/TEAM Work Order grouped by the section they were generated in. Results that were generated outside of a tagged section have a description of "MET/CAL Results". Results generated in a section have a description matching the Tag.Description of the tagged section. These results can be accessed via the Result tab of the MET/TEAM Work Order. Each run of a sectioned procedure will generate a new row of results. Results are never overwritten by MET/CAL.

  • The "Add Work Order Result" button can be used to launch the procedure from MET/TEAM if the type is setup correctly with the procedure
  • The "Delete Work Order Result" button will deleted the selected result group from the Work Order
  • The "View Work Order Result" button will display the detailed results


Procedure Sectioning Glossary

The following terms are used in this section to reference different aspects of the Procedure Sectioning feature:

Section | Group of tests that share a common requirement and should be run together, or may be skipped over.
Tag Comment | A statement at the starting label of a section. Example: # Tag.xxx = value
Procedure Section Tag | Or tag for short. Set of tag comments that define the boundaries, name and other attributes for a section.
Start and End Label | MET/CAL Procedure Language LABEL statements used to define the start and end of a section in the main procedure.


Compiling Procedures

The Procedure Compiler is integrated with MET/CAL Editor. The compiler checks the correctness of each procedure statement. Once the FSC is recognized, the compiler checks the correctness of individual fields within the line, and then the interdependencies of the lines.

The Compile menu displays selections that compile procedures forward and backwards, and individual lines of procedures. The Compile menu options are the following:

  • Check line
  • Next Error
  • Previous Error
  • Rewarn
  • TUR Report


Compile Checking a Procedure

The Debug > Compile Check Procedure (F9) checks the contents of the active procedure and reports errors in the Error window and warnings in the Warning window. The compile check does not check dependencies outside of the procedure file itself. Errors must be corrected before you can run the procedure. If no errors are present, the procedure is formatted and fields are lined up under the correct columns.

Procedure lines that contains an instrument evaluation FSC, the Test Uncertainty Ratio (T.U.R.) is calculated in most cases. If the T.U.R. is less than the TUR Limit MET/CAL Configuration setting, a warning message is generated and presented in the Warning window. T.U.R. warnings are not considered errors, and so do not prevent a procedure from being executable. The procedure writer must verify that the new procedure is adequate, and that the standards used are satisfactory for the calibration to be performed.

Automatic Line Check is operating as long as the MET/CAL Editor is not operating in Text Mode. The same checking as described above is performed on every procedure line as you enter it. When you press ENTER, the line check is triggered. If no errors are found, the line is formatted, and the cursor is placed on the next line ready for the next procedure statement.


Debugging Procedures

Debugging a procedure is the process of executing the procedure to see how it performs. The procedure does not have to be published to a PXE or the complied procedure directory to start debugging. Use the features in the Debug Menu to begin debugging and control the debug process. When you test run, you are not asked for pre- and post-calibration information, and no results are written to the database.

The procedure must be executable before debugging can begin. When working with procedures outside of a project, the there is no check for dependencies. As long as the procedure compiles debugging will begin when Start Debugging is selected.

When debugging a procedure project, all procedures in the project must compile and all dependencies must be valid and part of the project. In early stages of procedure development it is common for some procedures in the project to not compile or to have unreconciled dependencies. To enable debugging without resolving all issues in procedures, select all affected procedures in the Solution Explorer (use CTRL+Click to multi-select), press CTRL+W, P to display the file properties and choose Content as the Build Action property. This selection prevents the build process from attempting to compile the selected procedures. Make sure to change the build action back to Compile before publishing the procedure.

Debug from Cursor

Runs procedure from the line where the cursor is currently positioned. The operation does not reset global procedure data. Use the option when edits are required while a procedure debug run is active. Since edits are not allowed while debugging, the debug session must abort. After the edits are made, place the cursor at the desired location and choose the Debug > Debug from Cursor option.

When the procedure is completed or terminated, the values of certain parameters are remembered, so that the next time you execute the procedure, it is not necessary to repeat the test steps that establish those values.

For example, the ASK flags are typically defined close to the top of most procedures. You want to keep those settings even if you do not restart execution with the first line in the procedure. Remembering values provides the advantage of rerunning procedure segments with the test environment in the same condition each time. The first time you test run a procedure, start with those lines that assign values to those parameters.

The system remembers the following parameters:

  • ASK flags, created using the ASK- and ASK+ FSCs.
  • Memory variables MEM, MEM1, MEM2, and M1 through M255.
  • Values created with Instrument Setup FSCs (For example, MMFC, MCAL, and M606 FSCs).
  • MESS message buffers, created with the MESS FSC.
  • DRAW parameters, created with the DRAW FSC.
  • SET settings table, created with SET FSCs.


Configuration in Project

When a procedure is compiled, information in the header of the procedure is subject to change based on the local station hardware configuration and MET/CAL Editor Configuration settings. Specifically, the date, author, left and right titles and the test hardware listed in the configuration and standard lines may change when the procedure is compiled. These changes are flagged as changes to the procedure file even when there are no code changes in the body of the procedure. File changes based purely on different stations can make it difficult to track procedure file change history. In many cases, it is also desirable to publish procedures with consistent information regardless of the station used to develop the procedure.

A simple example occurs when using alias's in a procedure. If a procedure is developed to use DMM as an alias to an actual DMM, the local station configuration will define the specific DMM to use when running the procedure. If one station defines a Fluke 8846A as the DMM and another uses an Agilent 34401A, the procedure header will change when the procedure is compiled on the different stations. Note the change in the header in the figures below.

To prevent station specific setups from changing procedures add a config.dat file to the procedure project. The file must be marked as "Exclude from Package" in the file properties. The config.dat should contain the hardware details that you wish to preserve in the procedure. Its best to copy the stations config.dat file to the procedure project specific folder. Then add the file to the project by right-clicking the project label in the Solution Explorer and choosing add existing item.

Do not reference the station's config.dat file from the procedure project. Start by copying the station file to the procedure project folder.

Projects that are associated with a config.dat exhibit the following behavior:

  • Using F9 or the Debug > Compile Check Procedure menu will always compile procedures using the project's config.dat file.
  • All Build and Publish operations will compile procedures using the project's config.dat file.
  • All published procedures will use the local station configuration when executed in the MET/CAL Runtime.
  • All Debug Run (Test Run) operations will use the station's config.dat file. Similar to the MET/CAL Runtime, the actual setup on the local station is required to properly control station hardware. Any changes as a result of using the station's configuration are visible during the Debug Run. When the procedure terminates, all changes are automatically reverted back to the original state.

Procedures that are developed outside of a procedure project and procedure projects that do not include a config.dat will always use the local station config.dat. Any changes imposed by the local station are reflected as changes in the procedure file.


MET/CAL Reference Guide

Conventions

The MET/CAL Reference Manual uses the following special symbols and conventions:

numeric
The following are examples of valid numeric entries:
  • 123
  • +123
  • -12345
  • 12.3
  • +1.234
  • -0.12345
  • 1.23E+5
  • +123.4E-56
  • -12345.678E+90
integer
The following is an example of integer numbers with an implied decimal point.
  • 123
  • +123
  • -12345
terminals
Terminals symbols are the literal elements of MET/CAL language defined by a formal grammar.
nonterminal
Nonterminals represent a syntactic grammar fragment which is replaced by groups of terminal symbols.
Nonterminals are defined using the ::= symbol.
Example: sp ::= one or more spaces.
optional
Unbold square brackets indicate that data within them are optional.
literal
Bold square brackets indicate that data within them are literals (not optional).
filename
File names that are literal (not optional) are lowercase, bold.
Menu item
Application menu items, where each successive level of the menu is separated by a ">".
Example: File > New > Project
blank
This indicates that a field is blank or empty.
NA
This indicates Not Applicable.
Fields of MET/CAL instrument FSC statements
References to the fields of a MET/CAL instrument Function Selection Code (FSC) are upper-case, with monospace font and gray background; the same way they appear in the Editor.
Examples: RANGE, NOMINAL, and TOLERANCE.
Success
This indicates a successful condition.
Note
This indicates a note.
Warning or Caution
This indicates a warning or caution.
Error or Failure
This indicates an error or failure condition.


Detailed Description of a Procedure

The following example shows you what a procedure looks like. The descriptions of a procedure on the following topics relate back to this example. This example procedure performs a partial calibration verification of a Fluke 87 Digital Multimeter. The Fluke 5500A is used as a calibration source.

Copyright (c) (2014) Fluke Corporation.                  All rights reserved.
=============================================================================
INSTRUMENT:            Fluke 87: (1 year) CAL VER /5500 (Example)
DATE:                  2014-04-03 23:21:55
AUTHOR:                Fluke Calibration
REVISION:              $Revision: 1.0 $
ADJUSTMENT THRESHOLD:  70%
NUMBER OF TESTS:       6
NUMBER OF LINES:       63
CONFIGURATION:         Fluke 5500A
=============================================================================
#
#  Source:
#        Fluke 83,84,87 Multimeters Service Manual, PN 834168
#        April 1989, Rev 5, 3/96
#
# The 90 day specifications of the 5500A are used in TUR computations.
#
 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON

  1.001  ASK-   R     N              P                            A        V
  1.002  ASK+           K

  1.003  IF           NOT(VERSIONCHECK(8.0))
  1.004  END
  1.005  ENDIF

  1.006  CALL         Sub Display Copyright
  1.007  CALL         Sub High Voltage Safety Warning

  1.008  HEAD         TEST CONDITIONS
  1.009  DISP         - No specific warm-up time requirement.
  1.009  DISP         - Ambient temperature: 18°C - 28°C.
  1.009  DISP         - Relative humidity: less than 90%.

  1.010  HEAD         INITIAL INFORMATION
  1.011  CALL         Sub Select Failed Test Mode
  1.012  CALL         Sub Select Guardbanding & Ver Method (No NTHROW)

  1.013  RSLT         =
  1.014  PICE         -s "DISPLAY TEST" : 87dsp

  2.001  CALL         Sub Fluke 80 Series Rotary Switch Test

  2.002  RSLT         =
  2.003  HEAD         {AC VOLTAGE TESTS}
  2.004  RSLT         =
  2.005  HEAD         -2{400 mV Range}
  2.006  TARGET       -p
  2.007  DISP         Rotate the UUT function switch to VAC.
  2.008  TARGET       -m
  2.009  5500   400   350.0mV        0.7% 0.4U     60H            SI       2W
  3.001  5500   400   350.0mV        2.0% 0.4U     5kH            SI       2W

  4.001  RSLT         =
  4.002  HEAD         {AC MILLIAMP TESTS}
  4.003  RSLT         =
  4.004  HEAD         -2{400 mA Range}
  4.005  TARGET
  4.006  5500   400   350.0mA        1.0% 0.2U     60H            SI       2W
  5.001  5500   400   350.0mA        1.0% 0.2U     1kH            SI       2W

  6.001  END


Procedure Headers

The procedure is prefaced by a procedure header. Most procedure header statements are generated automatically by creating a new procedure file or by the procedure compiler. If you create or modify such lines manually, the compiler simply discards those lines and generates new header lines. The only header lines which allow the procedure writer to specify information are:

INSTRUMENT:           - specify name of procedure
AUTHOR:               - specify procedure writer
REVISION:             - specify procedure revision
ADJUSTMENT THRESHOLD: - specify threshold for marginal pass

Of these four lines, the only required entry is the procedure name. This image shows how the procedure header appears when editing a procedure.

Procedure Header Description

Title Line

The title line is constructed by the procedure compiler from the Procedure Title (Left) and Procedure Title (Right) entries in the MET/CAL Editor Configuration settings.

Separator Line

The separator line is a line of equals signs used to separate the title line from the following procedure header statements. A second separator line occurs before the column headers line at the end of the procedure header.

Instrument

The Instrument line specifies the name of the procedure. In the example procedure, the first name is Fluke 175: (1 yr) CAL VER /5500. Use names that uniquely identify the UUT for which you wrote the procedure. The name is used by an operator to select a procedure.

The name can be up to 55 characters long. Spaces are significant, but case (upper or lower) is not.

A procedure may have up to six distinct names and each name is specified on a separate Instrument line.

Date

The Date line shows the date on which the procedure was written or last edited. The system enters this information automatically. In the example procedure, the date is 20-May-94.

Author

The Author line may contain the name of the person who wrote the procedure. The Author line is an optional entry. In the example procedure, the author is Fluke Corporation.

Revision

The Revision line shows the current revision of the procedure. This is incremented exclusively by the procedure writer.

Adjustment Threshold

The adjustment threshold line is used to specify the adjustment threshold as a percentage of the tolerance. The default adjustment threshold is 70%. The procedure writer may specify a different threshold value here, there is no other way to modify the adjustment threshold. When a procedure is executed, any test for which the error (as a percentage of the tolerance) exceeds the adjustment threshold is designated a "marginal pass" instead of a "pass" (unless the test is a "fail").

Percent of tolerance (% TOL) is rounded off to the nearest 1%. Therefore, you see PASS 100% (if the result is between 99.5% and 100%) and FAIL 100% (if the result is greater than 100% and less than 100.5%).

In the example procedure, the default adjustment threshold value is 70%.

Number of Tests

This line indicates how many tests the procedure contains. A test is defined as a portion of the procedure that produces a result. In a procedure, a test is identified by the integer portion of the STEP number (described later). MET/CAL automatically computes and enters this number. The example procedure contains seven tests.

Number of Lines

The number of lines line specifies the total number of lines in the procedure. Executable procedure statements, procedure header lines, comment lines, and blank lines are all included in the total. The number of lines is computed automatically by the procedure compiler.

Configuration

The Configuration line specifies the instruments required by the procedure. In the example, the Fluke 5500A is the only required instrument. Each configured instrument used by the procedure has a corresponding configuration line in the procedure header. User-configured instruments referred to by alias in the procedure are included in the header configuration lines as well. Configuration lines are generated automatically by the procedure compiler.

Standard

The STD FSC causes MET/CAL to perform a traceability check for a manually controlled external standard used by the procedure. The MET/CAL procedure compiler (editor) generates a "STANDARD" statement in the header of a compiled procedure for each distinct instrument specified in an STD statement.

Column Headers

The column headers line is the last line of the procedure header. The line contains column headers appropriate for the fields of a MET/CAL instrument FSC procedure statement. The headers are STEP, FSC, RANGE, NOMINAL, TOLERANCE, MOD1, MOD2, MOD3, MOD4, and CON. The column headers line is automatically generated by the procedure compiler.


Naming a Procedure

Selecting File > New > Procedure File (or Ctrl+N) will open a blank procedure file template, with a single INSTRUMENT line in the header section of the procedure. To create a name for the procedure, type in the procedure name and press Enter to compile check the line or F9 to compile check the entire procedure file.

Calibration procedures can be designed to calibrate different instruments with similar calibration or verification requirements. For example, the procedures for the Fluke 73, 75, and 77 are similar, but there are slight differences. Instead of creating a different calibration procedure file for each model, it is possible to create one procedure file in which the execution of the procedure is controlled by the name selected. This single procedure file would have three procedure names, shown as follows in the header of the procedure:

INSTRUMENT:            Fluke 73
INSTRUMENT:            Fluke 75
INSTRUMENT:            Fluke 77

To create the additional procedure names, copy and paste the existing line and type in a new name or edit the existing name, or type INSTRUMENT on a blank procedure line and press F9 to compile check the procedure.

Observe the following rules for naming procedures:

  1. A procedure must have at least one name and may have up to six names. These names are displayed individually in the MET/CAL Procedure Directory after the procedure is stored.
  2. The JMPT and JMPF Function Selection Codes may be used to jump in a procedure in a manner dependent on the name selected.
  3. If the procedure to be edited is loaded from the Procedure Directory, the selected name of the procedure is set to the name by which it was chosen. This name is shown in the header of the MET/CAL Editor.
  4. If the procedure is created from scratch, no name is assigned until I is used to create an instrument line. The selected procedure, after compilation, is the name in the first INSTRUMENT line.


MET/CAL Procedure Body Statements

The remainder of the procedure beyond the header is called the procedure body. The procedure body consists of executable procedure lines that follow the header. Each executable MET/CAL procedure statement begins with a step number followed by an FSC (Function Selection Code). Step numbers are generated automatically and need not be entered by the procedure writer in most cases. (If a statement is a jump destination, a step number must be entered by the procedure writer.)

In the previous section, an FSC was defined as a code that informs the system of a task to be performed. All FSC statements have the following common properties:

Test Number

The integer portion of the number in the STEP field. A test is one or more statements with the same test number. Test numbers identify tests. A test is defined as a portion of a procedure that generates a test result.

Step Number

The entire number in the STEP field. The step number associated with each procedure test can be between n.001 and n .999. The step numbers are automatically assigned by the procedure compiler, although you can influence the numbering of lines in certain situations.

FSC Identifier

The FSC identifies the statement. It is the field following the STEP field. For example, DISP identifies a display statement, 5100 identifies a statement used to control the Fluke 5100B calibrator, and so on.


Procedure Line Length

Beginning with MET/CAL 8.2, up to 256 bytes are supported in a single procedure statement (characters below ASCII 128 count as one byte). This allows a procedure writer to create larger operator prompts such as DISP statements, on a single line instead of breaking it up into continued lines. Statements that appear in messages will automatically wrap as required to avoid truncating the message text. The additional length will also improve special character support, as there is now more room on a line to accommodate characters that take up more than a single byte. This line length change for procedures does not impact the procedure header; all header length limitations remain the same.

This change prevents compiled procedures written in 8.2 from running on previous versions of MET/CAL. Procedure Executables (PXE) written in 8.2 will work on 8.0 or newer versions of MET/CAL as long as the PXE does not contain unsupported FSC features and does not use long line lengths within the procedure. This change does not prevent procedures written in previous versions of MET/CAL from running on version 8.2 and newer.

The following procedure statements and FSCs support long line lengths:

  • Procedure comment lines
  • All "Name = Value" (NVI) FSCs (5730A, 9640A, O_CAL, 6100B, etc.)
  • Flow control FSCs:
    • IF / ELSEIF / ELSE / ENDIF
    • DO / UNTIL
    • WHILE / ENDW
    • JMPL and LABEL
  • ACCF
  • DOS / DOSE
  • DISP
  • HEAD (including HEAD -2)
  • MATH
  • MEM2
  • MEMI
  • MESS
  • OPBR
  • RSLT
  • TOL

Legacy Support (*.pro and *.pkm)

Compiled procedures (*.pro) and compiled procedure packages (*.pkm) created in 8.2 will not run in any previous version of MET/CAL. This is true regardless of the specific FSCs or the line length used in the procedures. The underlying format of the procedure is now different and is incompatible with all prior versions of MET/CAL. To use a procedure in written in 8.2 on a prior version of MET/CAL, it is necessary to access the process source code files (*.mc and *.txt). Copy and paste the contents into the prior version of MET/CAL, or open the file(s) directly, then remove any long line lengths or unsupported FSCs before attempting to Compile Check the procedure.

Procedure Executable Support (*.pxe)

Procedure Executables (.pxe) are not stored in the legacy compiled procedure format, and therefore are not impacted in the same way as compiled procedures. This format is backwards compatible with any version of MET/CAL that supports Procedure Executables, starting with 8.0. However, if a Procedure Executable created in 8.2 has lines longer than the legacy limit, or uses features that were not supported in the previous version, the procedure will not run in previous versions of MET/CAL. A procedure project's *.zip files will open directly in prior versions of the MET/CAL Editor. To use an 8.2 procedure project on a prior version of MET/CAL, expand the project's *.zip file into an empty directory on the host PC. Open the project file (*.mcproj) for the MET/CAL project. Compile the procedure or build the project to locate any long line lengths or unsupported features. Make any necessary changes to resolve the problem and then publish the procedure to create a new PXE or *.pro file.


General Rules of Function Selection Codes

This section describes the general rules of how the Function Selection Codes (FSCs) control the MET/CAL system. The topics covered in this discussion are:

  • What is a Function Selection Code?
  • Function Selection Code Types
  • Common FSC Properties (FSC Fields)
  • Rules for FSCs
  • Results Reporting
  • Special Constructions


What is a Function Selection Code?

A Function Selection Code (FSC) instructs the MET/CAL system to perform a task that is requested in a procedure. For example, the 5700 FSC instructs the system to provide a stimulus output from the Fluke 5700A Calibrator, while the DISP FSC directs the system to display a message to the operator during the execution of a calibration procedure.


Function Selection Code Types

MET/CAL has seven FSC types; the FSC categories are as follows:

  • Display Control
  • Evaluation
  • Instrument
  • Interface Control
  • Memory Register Operation
  • Procedure Control
  • Miscellaneous

Each FSC type performs a different function in the MET/CAL system. The following describes the function of each FSC type and, where appropriate, describes specific information required in the Range, Nominal, Tolerance, MOD1, MOD2, MOD3, MOD4, and CON fields. The use of these fields varies with the type of FSC. The requirements of the remaining fields are discussed in detail in the respective FSC sections of this manual.


Display Control FSCs

Display Control FSCs are used to present calibration instructions (e.g., Set Switch S1 to ON) or other information to the operator. This information is displayed on the screen of the Calibration System during execution of the calibration procedure. The following is a list of the display control FSCs for MET/CAL Calibration Software.

CON | Specify a connection from a calibration system instrument to the UUT.
DISP | Display a message.
DRAW | Define a stick figure representation of the UUT.
HEAD | Display a Header message during calibration procedure execution.
MESS | Define a message for EVAL, Measurement or Stimulus Setup test or Slew.
PIC | Display a Picture.
RNG | Specify a UUT Range message.
SET | Generate a list of UUT settings (usually used with oscilloscopes).

In addition to the general rules applicable to all FSCs (step numbers and adjustment procedure steps), the following general rules apply to Display Control FSCs:

  • RANGE, NOMINAL, TOLERANCE, MOD1, MOD2, MOD3, MOD4, and CON fields are not separate. Instead, the FSC-dependent information starts with the NOMINAL field column, and the rest of the line is a single undivided record.
  • Messages with up to eight lines can be created for the DISP, MESS, and SET FSCs. Each line of a multiline message is assigned identical step numbers.
  • Certain Special Constructions can be used with some of these FSCs. The description of the individual procedure control FSC contains information on which Special Constructions are allowed with that FSC.


Evaluation FSCs

Evaluation FSCs are non-instrument procedure statements that perform evaluations. These are used when a simple instrument evaluation statement is not adequate for the test. For example, if UUT units are not directly supported by an instrument FSC.

The following is a list of evaluation FSCs:

DOSE | Sets PASS or FAIL via a user program.
EVAL | Sets PASS or FAIL based on operator response to a YES/NO prompt.
MEMC Sets PASS or FAIL based on numeric comparison.
  • MEM = System Actual value
  • MEM1 = UUT Indicated value
MEMCX Sets PASS or FAIL based on numeric comparison. MEMCX is like MEMC, except that the UUT and Reference values are taken from the opposite locations (opposite with respect to MEMC).
  • MEM1 = System Actual
  • MEM = UUT Indicated
With MEMCX it is not necessary to precede a stimulus evaluation with a MEME statement to swap the MEM and MEM1 registers. Depending on the type of test, it is now always sufficient to use either a MEMC or MEMCX evaluation, without the preceding MEME statement.
PICE | Sets PASS or FAIL based on operator response to a YES/NO prompt displayed over a picture.

In addition to the general rules applicable to all FSCs (step numbers and adjustment procedure steps), the following general rules apply to Evaluation FSCs:

Certain Special Constructions can be used with some of these FSCs. The description of the individual procedure control FSC contains information on which Special Constructions are allowed with that FSC.


Instrument FSCs

Instrument FSCs control system calibration instruments. An Instrument FSC is used to apply a stimulus to, or take a measurement from, the UUT. The FSC may also generate automatic messages describing the signal connection between the calibration instrument and the UUT, and the UUT range required for the test. In addition, an instrument FSC may perform an evaluation that results in a PASS or FAIL condition.

When you enter information for a given FSC, you must enter the step number first, the FSC second. If no step number is entered, it is automatically inserted by the procedure compiler. Following the FSC code, other information for the FSC may be entered in an arbitrary order. When the statement is compiled, the compiler sorts the entries into the appropriate fields, where applicable.

In some situations, the order in which entries are made is significant. For example, in the 6060 FSC, if you enter the amplitude information before the frequency information, amplitude is stored in the NOMINAL field and frequency in the MOD1 field and an evaluation, if any, is based on the amplitude.

If you enter the frequency first and then amplitude, the frequency value is stored in the NOMINAL field and the amplitude information in the MOD1 field and an evaluation, if performed, is based on the frequency. The compiler sorting routine displays error messages if it cannot sort the line.

Calibrators
4000, M4000 | Datron 4000 Autocal Standard
4000A, M4000A | Datron 4000A Autocal Standard
4200, M4200 | Datron 4200 Autocal AC Standard
4200A, M4200A | Datron 4200A Autocal AC Standard
4700, M4700 | Datron 4700 Multifunction Calibrator
4705, M4705 | Datron 4705 Multifunction Calibrator
4707, M4707 | Datron 4707 Multifunction Calibrator
4708, M4708 | Datron 4708 Multifunction Calibrator
4800, M4800 | Wavetek/Datron 4800 Multifunction Calibrator
4800A, M4800A | Wavetek/Datron 4800A Multifunction Calibrator
4805, M4805 | Wavetek/Datron 4805 Multifunction Calibrator
4808, M4808 | Wavetek/Datron 4808 Multifunction Calibrator
5001, MCAL | Tektronix CG 5001 Calibration Generator
5011, M511 | Tegam/Tektronix CG 5011 Calibration Generator
5100 | Fluke 5100B Calibrator, DC and AC Voltage and Current
5130 | Fluke 5130A Calibrator, DC and AC Voltage and Current
RESF | Fluke 5100B or 5130A Calibrator, Resistance
WIDE | Fluke 5100B Calibrator, Wideband AC Voltage
5200 | Fluke 5200A AC Calibrator
5205 | Fluke 5205A and 5215A Power Amplifier controlled by a 5100B or 5130A
5220 | Fluke 5220A Transconductance Amplifier controlled by a 5100B or 5130A
52120A | Fluke 52120A Transconductance Amplifier
5320 | Fluke 5320A Electrical Safety Tester Calibrator
5440 | Fluke 5440B DC Calibrator
5450 | Fluke 5450A Resistance Calibrator
5500, M550 | Fluke 5500A Multi-Product Calibrator
5502A | Fluke 5502A Multi-Product Calibrator
5502E | Fluke 5502E Multi-Product Calibrator
5520, M5520 | Fluke 5520A Multi-Product Calibrator
5522A | Fluke 5522A Multi-Product Calibrator
5700, MMFC | Fluke 5700A Multifunction Calibrator
5720, M5720 | Fluke 5720A Multifunction Calibrator
5730A | Fluke 5730A High Performance Multifunction Calibrator
5800, M5800 | Fluke 5800A Oscilloscope Calibrator
5820, M5820 | Fluke 5820A Oscilloscope Calibrator
O_CAL Fluke Oscilloscope Calibrators
  • Fluke 5080A/SC
  • Fluke 5500A-SC
  • Fluke 5500A-SC300
  • Fluke 5502A-SC300
  • Fluke 5520A-SC300
  • Fluke 5502A-SC600
  • Fluke 5500A-SC600
  • Fluke 5520A-SC600
  • Fluke 5522A-SC600
  • Fluke 5520A-SC1100
  • Fluke 5522A-SC1100
  • Fluke 5800A (including 5 Channel and GHz options)
  • Fluke 5820A (including 5 Channel and GHz options)
P525 | Pressure Calibration using Fluke 525A
P700 | Pressure Calibration using Fluke 525A or 5520A
9000, M9000 | Wavetek/Datron 9000 Meter Calibration System
9100, M9100 | Wavetek/Datron 9100 Calibration System
9500, M9500 | Wavetek/Datron 9500 and Fluke 9500B Oscilloscope Calibrators
Transfer Standards
4950, M4950 | Wavetek 4950 Multifunction Transfer Standard
5790, ACMC | Fluke 5790A AC Measurement Standard
Counters \ Timers
53131, M53131 | Agilent/Hewlett-Packard 53131A Universal Counter
53132, M53132 | Agilent/Hewlett-Packard 53132A Universal Counter
53181, M53181 | Agilent/Hewlett-Packard 53181A Frequency Counter
5335, M5335 | Hewlett-Packard 5335A Universal Counter
6666, M666 | Philips PM 6666 Timer/Counter
6680, M680 | Fluke/Philips PM 6680 / PM 6680B or Wavetek 900 Timer/Counter
6681, M681 | Fluke/Philips PM 6681 or Wavetek 901 Timer/Counter
6685, M685 | Fluke/Philips PM 6685 or Wavetek 905 Timer/Counter
Electrical Power Standards
6100 | Fluke 6100A Electrical Power Standard
Loads
HP60 | Agilent/Hewlett-Packard 6060B DC Electronic Load
HP63 | Agilent/Hewlett-Packard 6063B DC Electronic Load
Phase Meters
6000 | Clarke-Hess 6000 Phase Meter
Multimeters
1271, M1271 | Wavetek/Datron 1271 Multimeter
1281, M1281 | Wavetek/Datron 1281 Multimeter
2000 | Keithley 2000 Multimeter
2001 | Keithley 2001 Multimeter
2002 | Keithley 2002 Multimeter
34401 | Agilent/Hewlett-Packard 34401 Multimeter
34420 | Agilent/Hewlett-Packard 34420 Multimeter
3458, M3458 | Agilent/Hewlett-Packard 3458A Digital Multimeter
45, M45 | Fluke 45 Dual Display Multimeter
8505 | Fluke 8505A Digital Multimeter
8506 | Fluke 8506A Thermal RMS Digital Multimeter
8508, M8508 | Fluke 8508A Reference Multimeter
8842 | Fluke 8842A Digital Multimeters
8845, M8845 | Fluke 8845A 5-1/2 Digit Precision Multimeter
8846, M8846 | Fluke 8846A 6-1/2 Digit Precision Multimeter
8920 | Fluke 8920A True RMS Voltmeter
Signal Generators
2024, M2024 | Marconi 2023, 2024, and IFR 2023A, 2024A AM/FM Signal Generators
5030 | Tegam/Tektronix SG 5030 Leveled Sine Wave Generator
5050 | Tegam SG 5050 Leveled Sine Wave Generator
6060, M606 | Fluke 6060A, 6060B, 6061A, 6062A, 6080A, and 6082A RF Signal Generators
8648, M8648 | Hewlett-Packard 8648A, 8648B, 8648C, and 8648D RF Signal Generators
SMY02, MSMY02 | Rohde & Schwarz SMY01, SMY02, and SMY43 RF Signal Generators
Function Generators
195, M195 | Wavetek 195 Universal Waveform Generator
3325, M3325 | Hewlett-Packard 3325A and 3325B Function Generators
33120, M33120 | Agilent 33120A Function Generator
33250, M33250 | Agilent 33250A Function Generator
39A, M39A | Wavetek 39A Universal Waveform Generator
5191 | Philips PM 5191 Function Generator
5192 | Philips PM 5192 Function Generator
5193 | Philips PM 5193 Function Generator
Power Meters
437, M437 | Hewlett- Packard 437B Power Meter and EPM-441A or E4418A in 437B emulation mode
4418, M4418 | Agilent E4418B Power Meter and Agilent/HP E4418A formally EPM-441A Power Meter
4419, M4419 | Agilent E4419B Power Meter and Agilent/HP E4419A formally EPM-442A Power Meter
EPM Controls the Agilent/HP EPM Series Power Meters:
  • EPM-441A
  • EPM-442A
  • E4418A
  • E4418B
  • E4419A
  • E4419B
  • N1913A
  • N1914A
RCL Meters
6304, M6304 | Fluke/Philips PM 6304 Programmable Automatic RCL Meter
6304C, M6304C | Fluke/Philips PM 6304C Programmable Automatic RCL Meter
6306, M6306 | Fluke/Philips PM 6306 Programmable Automatic RCL Meter
RF Analyzers
8901, M8901 | Hewlett-Packard 8901A and 8901B Modulation Analyzer
8902, M8902 | Hewlett-Packard 8902A Measuring Receiver and 8902S Microwave Measurement System
8903, M8903 | Hewlett-Packard 8903B Audio Analyzer and 8903E Distortion Analyzer
N5531 | Agilent N5531S Measuring Receiver
RF Reference Standard
9640 | Fluke 9640A and 9640A-LPN RF Reference Sources
LPNX | Fluke 9640A-LPNX RF Reference Source
Spectrum Analyzers
8560, M8560 | Hewlett-Packard 8560A, 8561A/B, 8562A/B, 8563A and 8560 E-Series Spectrum Analyzers
8566, M8566 | Hewlett-Packard 8566B Spectrum Analyzer
8568, M8568 | Hewlett-Packard 8568B Spectrum Analyzer
8590, M8590 | Hewlett-Packard 8590L, 8591E, 8592L, 8593E, 8594E, 8595E, and 8596E Spectrum Analyzers
PSA | Agilent E4440A, E4443A, E4445A, E4446A, E4447A, E4448A PSA Series Spectrum Analyzers

In addition to the general rules applicable to all FSCs (step numbers and adjustment procedure steps), the following general rules apply to Instrument FSCs:

Certain Special Constructions can be used with some of these FSCs. The description of the individual procedure control FSC contains information on which Special Constructions are allowed with that FSC.


Interface Control FSCs

The Interface Control FSCs provide direct control of a UUT using an IEEE-488 or serial interface. IEEE-488 or serial system calibration instruments may also be controlled when no FSC exists or the FSC does not support the desired instrument function.

IEEE | Direct control of a device on an IEEE-488 interface.
IEEE2 | Direct control of an IEEE-488.2 compliant device with built-in synchronization using Message Available (MAV) and Operation Complete (OPC) and error handling using Query Error (QYE), Device Dependent Error (DDE), Execution Error (EXE), and Command Error (CME).
PORT | Direct control of a device on a serial interface.
RESET, CLEAR | Specifies reset commands for user-configured instruments or the UUT
SCPI | Direct control of an SCPI compliant device with built-in synchronization using Message Available (MAV) and Operation Complete (OPC) and error handling using System Error Query (SYST:ERR?).

In addition to the general rules applicable to all FSCs (step numbers and adjustment procedure steps), the following general rules apply to the Interface Control FSCs.

  • Certain Special Constructions can be used with some of these FSCs. The description of the individual procedure control FSC contains information on which Special Constructions are allowed with that FSC.


Memory Register Operation FSCs

The Memory Register Operation FSCs store, retrieve, and maintain data stored in the data registers. The following FSCs are used in memory register operations:

MATH | Performs arithmetic operations using memory registers.
MEM2 | Manipulates the contents of the memory register MEM2.
MEME | Exchanges the values of memory registers MEM and MEM1.
MEMI | Displays a prompt for a number to be placed in memory register MEM.
MEM+ | Adds MEM1 or the specified value to memory register MEM.
MEM- | Subtracts MEM1 or the specified value from memory register MEM.
MEM* | Multiplies MEM by a the specified value or MEM1.
MEM/ | Divides MEM by a specified value or MEM1.

In addition to the general rules applicable to all FSCs (step numbers and adjustment procedure steps), the following general rules apply to Memory Register Operation FSCs:

  • Certain Special Constructions can be used with some of these FSCs. The description of the individual procedure control FSC contains information on which Special Constructions are allowed with that FSC.


Procedure Control FSCs

The Procedure Control FSCs control the flow of the procedure. These are transparent to the operator and do not perform tests or produce results. OPBR is the only exception; this FSC displays a prompt that requires a response. Refer to the OPBR FSC topic for more information on OPBR.

The following FSCs control procedures:

ASK+ | Sets one or more of the system flags.
ASK- | Unsets one or more of the system flags.
CALL | Calls one procedure from another.
DO, UNTIL | Conditional looping over procedure statements.
DOS | Calls a user program (also see DOSE under Evaluation FSCs).
IF,ELSEIF, ELSE,ENDIF | Conditional execution of procedure statements.
JMP | Jumps to a specified procedure step.
JMPF | Jumps to a specified procedure step if MEM1 is less than zero.
JMPT | Jumps to a specified procedure step if MEM1 is greater than zero.
JMPL | Branch to specified LABEL.
JMPZ | Jumps to a specified procedure step if MEM1 is equal to zero.
LABEL | Establishes target for JMPL.
OPBR | Presents a message that requests a response.
RPT | Repeats a test.
TARGET | Specifies jump destination for post test “Repeat” and “Cancel” options, and multiple measurements.
WAIT | Specifies a delay between procedure statements with an optional popup message and countdown timer.
WHILE, ENDW | Conditional looping over procedure statements.

In addition to the general rules applicable to all FSCs (step numbers and adjustment procedure steps), the following general rules apply to Procedure Control FSCs:

  • Certain Special Constructions can be used with some of these FSCs. The description of the individual procedure control FSC contains information on which Special Constructions are allowed with that FSC.


Miscellaneous FSCs

The following list contains various FSCs that have specific functions but do not belong to any other category:

ACC | Specifies the system accuracy for a MEMC or MEMCX FSC.
ACCF | Specifies an alternate accuracy file.
RESET, CLEAR | Specifies reset commands for user-configured instruments or the UUT.
FMT | The FMT FSC allows the procedure writer to override the default formatting of result quantities.
RSLT | Adds text to result files, with or without an operator prompt.
STD | Includes traceability information for manual instrument.
TOL | Specifies tolerance.
TSET | Assigns values for system parameters for current test only.
VSET | Assigns values for system parameters for all tests.

In addition to the general rules applicable to all FSCs (step numbers and adjustment procedure steps), the following general rules apply to Miscellaneous FSCs:

  • Certain Special Constructions can be used with some of these FSCs. The description of the individual procedure control FSC contains information on which Special Constructions are allowed with that FSC.


Adjustment Statements

If the instrument's actual performance is below the adjustment threshold, a normal PASS condition is recorded, and any adjustment statement immediately following are skipped. The value of the adjustment threshold (shown in the procedure header) is normally set to 70%.

If the instrument's actual performance is between the adjustment threshold and the full specified tolerance, a MARGINAL PASS condition is recorded, and any immediately following adjustment procedure lines are executed. This condition indicates that although the UUT is within specification, it is advisable to adjust the UUT so it is well within specification.

If the instrument's performance is out of tolerance, a FAIL condition is recorded and any immediately following adjustment procedure lines are executed. The adjustment may resolve the FAIL condition, so the UUT can PASS the calibration procedure. The following example illustrates how the adjustment portion of a procedure might appear:

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
  1.001  5700   10    10V            0.1% 0.1/                             2W

  1.002         5700  10V                                               S  2W
  1.003         DISP  Adjust R1 for a 10V Reading

Because the FSC is in the RANGE field, no UUT range information is allowed in an adjustment procedure step. To adjust a step, select Adjust while entering the line. After successfully compiling the line, the FSC is shown under the RANGE header. When you press Enter, the next line is an adjustment procedure line.

To change an adjustment procedure step back to a regular procedure step, select adjust anywhere in the line and recompile that line. The spaces are deleted in the line and the FSC is positioned in the FSC field.


Continuation Statements

Continue allows you to mark the current line as a continuation of the previous line. This is useful for certain FSCs which allow multi-line statements.

To create a multi-line statement, type in the first line of the statement and press . On the second line of the statement, press Edit > Continue Line (F6) to link the lines together. The FSC is automatically inserted if the following conditions occur:

  • The FSC field of the current line is empty.
  • The previous line was successfully compiled.
  • The FSC of the previous line can be part if a multi-line message.

In some cases, there are FSC-specific limits on the number of continuation lines per statement. An attempt to exceed these limits causes the compiler to display an appropriate error message.


Automatic Messages

The following messages are automatically displayed by MET/CAL unless defeated using an associated ASK+ or ASK- flag.

Connection Message

An automatic connection message is generated by an instrument FSC or the CON FSC. If the required connection from the UUT to the calibration system changes, the operator is asked to make the required disconnections and connections before proceeding. The automatic connection message may be disabled using ASK- V or ASK- W.

UUT Range Message

An automatic range message is generated by an instrument FSC for an evaluation test, nominal setup test, or comparison test (with a non-blank RANGE field) or the RNG FSC. If the UUT function or range has changed, you are asked to set the UUT to the new function and range. The automatic range message for a numeric value in the RANGE field is of the form:

Set UUT <MEM2> to the range value nominal prefix + units [AC|DC] range.

The automatic range message for autorange is of the form:

Set UUT <MEM2> to autorange function (based on nominal units).

If the D-flag is in effect the automatic range message is of the form:

Set UUT <MEM2> to range value nominal prefix + units/div.

The automatic range message may be disabled using ASK- R.

Slew Message

An automatic slew message is generated by an instrument FSC specifying a calibration instrument stimulus function in the following cases:

  1. An evaluation test is specified and any of the defaults ASK- B, ask- G, or ASK- K are in effect.

  2. A nominal setup test is specified.

    For discrete resistance specified using 4000, 4000A, 4700, 4705, 4707, 4708, 4800, 4800A, 4805, 4808, 5450, 5700, 5720, and RESF FSCs, the automatic slew message is:

    Adjust display to match UUT reading.

    For all other cases, the automatic slew message is of the form:

    Adjust stimulus for a UUT reading of nominal value + prefix + units.

    If the D-flag is in effect and the RANGE field specifies a numeric value, the automatic slew message is one of the following:

  3. Adjust stimulus for a UUT horizontal reading of nominal/range divisions (when the NOMINAL field specifies amplitude).

    Adjust stimulus for a UUT vertical reading of nominal/range markers/div (when the NOMINAL field specifies frequency or period).

    The automatic slew message may be disabled using ASK- N.

    UUT Setup Message

    An automatic UUT setup message is generated by an instrument FSC specifying a calibration instrument measurement function for an evaluation test, nominal setup test, or comparison test. The UUT setup message may be disabled using ASK- N.

    UUT Adjustment Message

    An automatic UUT adjustment message is generated by an instrument FSC specifying a setup test for a calibration instrument measurement function. The UUT adjustment message may be disabled using ASK- N.


RANGE Field

The RANGE field is a five-character field that specifies the Unit Under Test (UUT) range in units of the NOMINAL value. The format of the RANGE field is one of the following:

  • number
  • "A"
  • blank

The RANGE field causes an automatic range message to be generated when the procedure statement is executed. If the RANGE field is "A", "Autorange" is specified. Refer to Automatic Messages for more information. Note that the ASK FSC "R" flag can be used to disable automatic range messages, and the "D" flag can be used modify the range message.

A numeric RANGE field may be used for the following:

  • Calculating test tolerance. For more information, refer to the TOLERANCE Field Rules topic.
  • Generating automatic slew message for certain FSCs, i.e., the FSCs affected by the ASK 'D' flag.
  • Calculating the compile-time T.U.R. when the procedure statement does not specify a numeric NOMINAL value.
  • Controlling the formatting of certain results variables. For more information, refer to the section, Results Formatting.

Other rules:

  • To be compatible with earlier versions of MET/CAL, any RANGE field specification may include an appended "R". If the appended "R" is present, the procedure compiler removes the "R" when the procedure statement is formatted. The "R" does not affect the interpretation of the RANGE field.
  • No RANGE field entry is allowed in an instrument setup statement. An instrument setup statement is an instrument statement that contains an 'S' in the MOD4 field.
  • No RANGE field entry is allowed in a statement that appears in an adjustment block. Statements in an adjustment block are indented so that the FSC appears in the RANGE field.


NOMINAL Field

The NOMINAL field specifies the nominal value of the stimulus for a calibration instrument source function (e.g. AC Voltage) or the anticipated measurement value of a calibration instrument measurement function (e.g. Ohms). The NOMINAL field can be up to 14 characters long. The following example shows how the nominal value is entered:

[numeric][prefix]units

Recognized Units

Quantity | Units | Symbol
Amplitude | Decibels | D
Capacitance | Farads | F
Current, RMS or DC | Amps | A
Current peak | Amps peak | Ap
Current peak-to-peak | Amps peak-to-peak | App
Conductance | Siemens | Y
Duty Factor 1 | None | DF
Energy | Joules | J
Event Count | Cycles | c
Frequency | Hertz | H
Frequency Ratio 1 | None | H/H
Inductance | Henry | Hy
Percent 1 | na | pct
Phase | Degrees | deg
Power, RMS or DC | Watts | W
Power Ratio | Decibels | dB
Pressure | Pascals | Pa
Bars | bar
Centimeters of water | cmH2O
Feet or water | ftH20
Grams per sq. cm. | g/cm2
Inches of Mercury | inHg
Inches of water | inH20
Meters of Mercury | mHg
Meters of water | mH20
Pounds per sq. inch | psi
Quality Factor 1 | None | QF
Reactive Power | Volt-Amps Reactive | VAR
Resistance | Ohms | Z
Resistance Ratio 1 | None | Z/Z
Temperature | Degrees Celsius | degC
Degrees Fahrenheit | degF
Kelvins | K
Time or period | Seconds | T
Video Amplitude | IRE | IRE
Video Line Marker 1 | None | LM
Voltage, RMS or DC | Volts | V
Voltage offset | Volts | Voff
Voltage peak | Volts peak | Vp
Volts per Amp | Volts per Amp | V/A
Voltage peak-to-peak | Volts peak-to-peak | Vpp
Voltage Ratio 1 | None | V/V

  1. MET/CAL requires a units symbol to identify the quantity, even if the quantity is dimensionless (duty factor, frequency ratio, quality factor, resistance ratio, video line marker, and voltage ratio). Similarly, even though percent is not a unit, the symbol "pct" is used to satisfy MET/CAL'S requirement for a symbol.

    The actual units allowed are dependent on the FSC. Refer to the FSC sections for the allowed units for a particular FSC.

Recognized Prefixes

Prefix | Symbol | Multiple
pico | p | 1E-12
nano | n | 1E-9
micro | u | 1E-6
milli | m | 1E-3
kilo | k | 1E+3
mega | M | 1E+6
giga | G | 1E+9

With the exception of 'm' and 'M', case is not significant. For example, a procedure statement could specify 'NV' instead of 'nV' to indicate nanovolts. If a non-standard case is used to enter a prefix symbol (for example, 'N' for nano), the Procedure Compiler converts the symbol to the standard case.

For units of hertz or ohms, 'm' and 'M' are case significant. 'M' represents mega and 'm' represents milli.

When just units and an optional prefix (e.g., mV) are entered in the NOMINAL field, the value is taken from memory register MEM when the statement is executed.

If the NOMINAL field contains a single asterisk (*), the calibration instrument is set to a reset condition. Since this implies a Setup test, S is automatically inserted in the MOD4 field. Refer to the MOD4 Field Rules topic for more information.

When an instrument FSC is entered with all other fields blank, an asterisk is inserted automatically in the NOMINAL field and an 'S' is automatically inserted in the MOD4 field.

When the NOMINAL field contains only units and the MOD1 field is not blank, the MOD1 field must specify a value and vice versa.


TOLERANCE Field

The TOLERANCE field specifies the tolerance to which the UUT indicated value is evaluated. This field can be up to 13 characters long including spaces. Any combination of up to three of the following entries can be used:

Entry | Tolerance Specification
% | This tolerance is the percent of the nominal value.
/ | This tolerance is the percent of range as entered in the RANGE field. A numeric entry (not "A") in the RANGE field is required with this expression. See "Other Rules" below for information about autoranging.)
P% | This tolerance is in ppm of the nominal value.
P/ | This tolerance is in ppm of range as entered in the RANGE field. There must be a numeric entry in the RANGE field (not A) in order to use this expression.
U | Units are the same as used in the NOMINAL field; this includes the prefix. When the nominal unit is dBm the U value is assumed to be dB.
  • If the tolerance is unsigned, a ± tolerance is implied. For example, "1%" is equivalent to "+1% -1%".
  • If the tolerance is prefaced by +, the tolerance is specified in the positive direction from the nominal value; if prefaced by -, the tolerance is specified as negative from the nominal value.
  • A tolerance specification is not allowed with a setup (MOD4 = 'S") test or in an indented adjustment procedure step.
  • % of range (/) or ppm of range (P/) are not allowed when the RANGE field is blank or autorange.
  • If UUT tolerance is specified in an evaluation or comparison test, "TOL" is entered and the tolerance specified in the last executed TOL FSC applies. If no TOL FSC is present, the tolerance applied is zero units.
  • The tolerance value may be a literal numeric value or may refer to a numeric register. Valid numeric register specifications are M1, M2, ..., M255. If the value is not specified, the value is taken from MEM at runtime.
  • The unit conversion for dBm to dB is handled as follows:

where

Variable | Definition
W | Change in Watts
W% | Percentage of change in Watts
dB | Power ratio value in decibels
V | The variable is set to the Nominal value or the Evaluation quantity depending on the measurement type.


MOD1 Field

The MOD1 field specifies the frequency, period, or amplitude of a periodic signal, or the field is left blank.

If the MOD1 field contains the frequency or period, the NOMINAL field contains the amplitude and vice versa.

When the NOMINAL field contains only units and the MOD1 field is not blank, the MOD1 field must specify a value and vice versa.

The modifier value is entered as follows:

[numeric][prefix]units

As in the case of the nominal value, the units and allowed numeric value for the MOD1 field depend on the particular FSC. Refer to the FSC sections for detailed information on specific FSCs.

Recognized prefixes are the same as discussed under the NOMINAL field rules.


MOD2 Field

One or two characters can be in the MOD2 field. Refer to the FSC sections for detailed descriptions of each FSC.


MOD3 Field

One or two characters can be in the MOD3 field. Refer to the FSC sections for detailed descriptions of each FSC.


MOD4 Field

The MOD4 field of an instrument FSC specifies the type of test being performed and can contain only a single character. The following four types of tests are defined in the MET/CAL procedure language:

Evaluation Test (MOD4 field is blank).

FSC Stimulus function

Reference applies a known value to the UUT and MET/CAL checks that the UUT reading is within the specified tolerance.

Slew (except discrete resistance)

UUT Indicated | The value shown in the NOMINAL field or the value of memory register MEM if only units were specified in the NOMINAL field.
System Actual | The calibration instrument output when Advance is selected
MEM | Not affected by the slew evaluation
MEM1 | System Actual

Slew (discrete resistance: 5450A, 57xxA, 4000, 47xx, 48xx, & 51xx)

UUT Indicated | The value on the display when Advance is selected.
System Actual | The certified value of resistance as displayed on the front panel (5450A and 57xxA). The NOMINAL field value (4000, 4000A, 47xx, 48xx, and 51xxB).
MEM | Not affected by the slew evaluation
MEM1 | System Actual

Keyboard Entry

UUT Indicated | The value entered from the keyboard.
System Actual | The value shown in the NOMINAL field or the value of memory register MEM if only units were specified in the NOMINAL field.
MEM | Not affected by keyboard entry evaluation.
MEM1 | UUT Indicated

Go/No-Go

UUT Indicated | OPER-EVAL
System Actual | The value shown in the NOMINAL field or the value of memory register MEM if only units were specified in the NOMINAL field.
MEM | Not affected by the Go/No-Go evaluation.
MEM1
  • +1 indicating a PASS condition if YES was selected.
  • -1 indicating a FAIL condition if NO was selected.

FSC Measurement function

MET/CAL checks that a UUT output is within the specified tolerance.

UUT Indicated | The value shown in the NOMINAL field or the value of memory register MEM if only units were specified in the NOMINAL field.
System Actual | The actual UUT output as measured by the calibration instrument.
MEM | Not affected by the evaluation.
MEM1 | System Actual

Setup Test (MOD4 is 'S')

For a stimulus function, a Setup Test applies the nominal value to the UUT. For a measurement function, a Setup Test continually monitors a UUT output so that it may be adjusted to the specified nominal value.

FSC Stimulus function

A Setup Test applies the nominal value to the UUT.

MEM | Not affected by the setup test
MEM1 | The applied stimulus. This is the value specified in the NOMINAL field except for resistance from the 5700A and 5450A. For these calibrators, MET/CAL queries the instrument to determine the certified resistance which is then used instead of the value in the NOMINAL field.

FSC Measurement function

A Setup Test continually monitors a UUT output so that it may be adjusted to the specified nominal value.

MEM | Not affected by the setup test
MEM1 | The UUT output as measured just prior to selecting Advance.

Nominal Setup Test (MOD4 is 'N')

The Nominal Setup test does not perform an evaluation. The Nominal Setup test allows the output of a stimulus calibration function to be adjusted so that the UUT reads a nominal value. For a measurement calibration function, a single reading is taken. This value may be used later in a Comparison Test.

FSC Stimulus function

The Nominal Setup test allows the reference output to be slewed so that the UUT reads a nominal value. A tolerance field may be included to control the slew resolution and starting digit.

MEM | The calibration instrument output on selecting Advance.
MEM1 | Not affected by the test.

FSC Measurement function

A single reading is taken. This value may be used later in a Comparison Test.

MEM | The measured value.
MEM1 | Not affected by the test.

Comparison Test (MOD4 is 'C')

The Comparison Test is used in conjunction with the Nominal Setup test. The Comparison Test operates like an evaluation test, except that the value established by the Nominal Test is used as a reference for the evaluation, instead of the value specified in the NOMINAL field


CON Field

The CON field is a two-character field. The entries depend on the particular instrument FSC. Refer to the FSC sections for more information on individual FSCs.


Device Mapping

MET/CAL Device (FSC) System Instrument Name Mapping

Each instrument FSC has a corresponding "System Instrument" name. The MET/CAL Editor automatically generates a CONFIGURATION: line in the procedure header containing this System Instrument name when the FSC is compile checked (F9). Examples:

FSC(s) | System Instrument CONFIGURATION:
5502E | Fluke 5502E
5700/MMFC | Fluke 5720A

The default Instrument FSCs for the Fluke 5700A are 5700 and MMFC, but MET/CAL allows the 5700/MMFC FSCs to execute with a Fluke 5720A (or 5730A) via Device Mapping. For the most part, Instrument FSCs are allowed to Device Map to a System Instrument other than the default System Instrument for the FSC, if the mapped instrument is a superset in capability, specifications, and accuracy, over the default. For the example, the 5720A does everything the 5700A does, only more accurately. It is important to note that MET/CAL Instrument FSC accuracy file lookups will be performed against the configured, device-mapped instrument. In this example, the 5700/MMFC FSCs will look up 5720A accuracy information.

There are many System Instrument FSCs which will Device Map to a non-default System Instrument at execution time, without modification to the procedure. In many cases, device mapping allows a procedure written with older Instrument FSCs to execute with compatible, newer generation hardware.

FSC(s) Used System Instrument CONFIGURATION: "Device Mapped" System Instruments - Instrument Configuration (config.dat)
39A/M39A | Wavetek 39A | Wavetek 195
525/M525 | Fluke 525A | Fluke 525B | Fluke 7526A
525B/M525B | Fluke 525B | Fluke 7526A
1271/M1271 | Datron 1271 | Datron 1281
4000/M4000 | Datron 4000 | Datron 4000A
4040/M4040 | Tektronix DMM4040 | Tektronix DMM4050 | Fluke 8846A
4050/M4050 | Tektronix DMM4050 | Fluke 8846A
4200/M4200 | Datron 4200 | Datron 4200A
4418/M4418 | HP E4418B | HP E4419B | Agilent E4418B | Agilent E4419B
4419/M4419 | HP E4419B | Agilent E4419B
4700/M4700 | Datron 4700 | Datron 4708 | Datron 4800 | Datron 4800A | Datron 4808
4705/M4705 | Datron 4705 | Datron 4700 | Datron 4707 | Datron 4708 | Datron 4800 | Datron 4800A | Datron 4808
4707/M4707 | Datron 4707 | Datron 4708 | Datron 4808
4708/M4708 | Datron 4708 | Datron 4808
4800/M4800 | Datron 4800 | Datron 4707 | Datron 4708 | Datron 4800A | Datron 4808
4800A/M4800A | Datron 4800A | Datron 4707 | Datron 4708 | Datron 4808
4805/M4805 | Datron 4805 | Datron 4700 | Datron 4705 | Datron 4707 | Datron 4708 | Datron 4800 | Datron 4800A | Datron 4808
4808/M4808 | Datron 4808 | Datron 4708
5350/M5350 | HP 5350B | HP 5351B | HP 5352B
5351/M5351 | HP 5351B | HP 5352B
5502E | Fluke 5502E | Fluke 5502A | Fluke 5520A | Fluke 5522A
5502A | Fluke 5502A | Fluke 5520A | Fluke 5522A
5520/M5520 | Fluke 5520A | Fluke 5522A
5522A | Fluke 5522A | Fluke 5520A
5700/MMFC | Fluke 5700A | Fluke 5720A | Fluke 5730A
5720/M5720 | Fluke 5720A | Fluke 5730A
5800/M5800 | Fluke 5800A | Fluke 5820A
6100B | Fluke 6100B | Fluke 6105A
6304/M6304 | Fluke PM6304 | Fluke PM6304C
6680/M680 | Philips PM6680 | Philips PM6681
8845/M8845 | Fluke 8845A | Fluke 8846A
8846/M8846 | Fluke 8846A | Tektronix DMM4050
9000/M9000 | Datron 9000 | Datron 9100
9500 | Datron 9510 | Datron 9520 | Datron 9530
9500 | Datron 9520 | Datron 9530
9640 | Fluke 9640A | Fluke 9640A-LPNX
52131/M53131 | Agilent 53131A | Agilent 53132A
EPM | Agilent EPM | HP EPM-441A | HP EPM-442A | HP E4418A | HP E4419A | Agilent E4418B | Agilent E4419B
ML2437 | Anritsu ML2437A | Anritsu ML2438A
N5531 | Agilent N5531S | Agilent PSA
O_CAL | Fluke Ocal | Fluke 5080A1 | Fluke 5500A1 | Fluke 5502A1 | Fluke 5520A1 | Fluke 5522A1 | Fluke 5800A1 | Fluke 5820A1
  1. With an Oscilloscope Calibration option fitted.

FSC driver "Test" functions sometimes allow the FSC to control other instruments in addition to the default System Instrument and mapped System Instruments.

FSC(s) Used | System Instrument Configured | Instrument(s) which will also be recognized via Device Mapping:
39A/M39A | Wavetek 39A | Fluke 281 | Fluke 282 | Fluke 284 |  |  |  |
195/M195 | Wavetek 195 | Fluke 282 | Fluke 284 |  |  |  |  |
1271/M1271 | Datron 1271 | Fluke 1271 | Fluke 1281 |  |  |  |  |
1281/M1281 | Datron 1281 | Fluke 1281 |  |  |  |  |  |
2024/M2024 | Marconi 2024 | Marconi 2023 | IFR 2023A | IFR 2024A |  |  |  |
3325/M3325 | HP 3325B | HP 3325A |  |  |  |  |  |
3458/M3458 | HP 3458A | Agilent 3458A |  |  |  |  |  |
4800/M4800 | Datron 4800 | Wavetek 4800A | Wavetek 4808 |  |  |  |  |
4800A/M4800A | Datron 4800A | Wavetek 4808 |  |  |  |  |  |
4805/M4805 | Datron 4805 | Wavetek 4800 | Wavetek 4800A | Wavetek 4808 |  |  |  |
4808/M4808 | Datron 4808 | Wavetek 4708 |  |  |  |  |  |
5001/MCAL | Tektronix CG 5001 | Tektronix CG 551AP |  |  |  |  |  |
5011/M511 | Tektronix CG 5011 | Tegam CG 5011 |  |  |  |  |  |
5030 | Tektronix SG 5030 | Tegam SG 5030 |  |  |  |  |  |
5100 | Fluke 5100B | Fluke 5100A | Fluke 5101B | Fluke 5102B |  |  |  |
5191 | Philips PM 5191 | Fluke PM 5191 |  |  |  |  |  |
5192 | Philips PM 5192 | Fluke PM 5192 |  |  |  |  |  |
5193 | Philips PM 5193 | Fluke PM 5193 |  |  |  |  |  |
5205 | Fluke 5205A | Fluke 5215A |  |  |  |  |  |
5350/M5350 | HP 5350B | HP 5350A | HP 5351A | HP 5352A | HP 5350M | HP 5351M | HP 5352M |
5351/M5351 | HP 5351B | HP 5351A | HP 5352A | HP 5351M | HP 5352M |  |  |
5352/M5352 | HP 5352B | HP 5352A | HP 5352M |  |  |  |  |
5440 | Fluke 5440B | Fluke 5442A |  |  |  |  |  |
5500/M550 | Fluke 5500A | Fluke 5500E |  |  |  |  |  |
5700/MMFC | Fluke 5700A | Fluke 5700A/EP |  |  |  |  |  |
5720/M5720 | Fluke 5720A | Fluke 5700A/EP |  |  |  |  |  |
6060/M606 | Fluke 6060B | Fluke 6060A | Fluke 6061A | Fluke 6062A | Fluke 6080A | Fluke 6082A |  |
6666/M666 | Philips PM 6666 | Fluke PM 6666 |  |  |  |  |  |
6680/M680 | Philips PM 6680 | Fluke PM 6680 | Fluke PM 6681 | Fluke PM 6680B | Wavetek 900 | Wavetek 901 |  |
6681/M681 | Philips PM 6681 | Fluke PM 6681 | Wavetek 901 |  |  |  |  |
6685/M685 | Philips PM 6685 | Fluke PM 6685 | Wavetek 905 |  |  |  |  |
6690/M6690 | Fluke PM 6690 | Tektronix FCA3000 | Tektronix FCA3003 | Tektronix FCA3020 | Tektronix FCA3100 | Tektronix FCA3103 | Tektronix FCA3120 |
8505 | Fluke 8505A | Fluke 8502A |  |  |  |  |  |
8560/M8560 | HP 8560 | HP 8560A | HP 8562A | HP 8563A | HP 8561B | HP 8562B | HP 8560 E-Series |
8590/M8590 | HP 8590 | HP 8590L | HP 8591E | HP 8592L | HP 8593E | HP 8594E | HP 8595E | HP 8596E
8648 | HP 8648 | HP 8648A | HP 8648B | HP 8648C | HP 8648D |  |  |
8842 | Fluke 8842A | Fluke 8840A |  |  |  |  |  |
8901/M8901 | HP 8901B | HP 8901A | Agilent 8901B |  |  |  |  |
8902/M8902 | HP 8902A | HP 8902S | Agilent 8902A | Agilent 8902S |  |  |  |
8903/M8903 | HP 8903B | HP 8903A | HP 8903E |  |  |  |  |
9000/M9000 | Datron 9000 | Wavetek 9000 | Wavetek 9100 |  |  |  |  |
9100/M9100 | Datron 9000 | Wavetek 9100 | Fluke 9100 | Wavetek-Yokogawa 9100 |  |  |  |
9500/M9500 | Datron 9500 | Wavetek 9500 | Fluke 9500B | Wavetek-Yokogawa 9500 |  |  |  |
9640 | Fluke 9640 | Fluke 9640A-LPN | Fluke 9640A-LPNX |  |  |  |  |
34401 | HP 34401A | Agilent 34401A |  |  |  |  |  |
34420 | HP 34420A | Agilent 34420A |  |  |  |  |  |
53131/M53131 | Agilent 53131A | HP 53131A | HP 53132A |  |  |  |  |
53132/M53132 | Agilent 53132A | HP 53132A |  |  |  |  |  |
53181/M53181 | Agilent 53181A | HP 53181A |  |  |  |  |  |

Additional Information

Agilent and HP 53131A Counter/Timers

53131/M53131 statements will execute with either of the following configured:

  • Agilent 53131A
  • Agilent 53132A

Special Notes:

  1. The HP 53131A must be configured as Agilent 53131A.
  2. The HP 53132A must be configured as Agilent 53132A.

Agilent/HP EPM-441A, EPM-442A E4418A, E4419A, E4418B, E4419B, and Power Meters

4418/M4418 statements will execute with any of the following configured:

  • HP EPM-441A
  • HP EPM-442A
  • HP E4418A
  • HP E4419A
  • Agilent E4418B
  • Agilent E4419B

4419/M4419 statements will execute with any of the following configured:

  • HP EPM-442A
  • HP E4419A
  • Agilent E4419B

EPM statements will execute with any of the following configured:

  • HP EPM-441A1
  • HP EPM-442A
  • HP E4418A1
  • HP E4419A
  • Agilent E4418B1
  • Agilent E4419B
  • Agilent N1913A1
  • Agilent N1914A

1. If any channel B parameters are specified, these single channel meters will not Device Map.

Datron 4000 Autocal Standard

4000/M4000 statements will execute with either of the following configured:

  • Datron 4000
  • Datron 4000A

Datron 4200 AC Autocal AC Standard

4200/M4200 statements will execute with either of the following configured:

  • Datron 4200
  • Datron 4200A

Datron 4700, 4705, 4707, and 4708 Autocal Multifunction Standards

4700/M4700 statements will execute with any of the following configured:

  • Datron 4700
  • Datron 4707
  • Datron 4708
  • Datron 4800
  • Datron 4800A
  • Datron 4808

4705/M4705 statements will execute with any of the following configured:

  • Datron 4700
  • Datron 4705
  • Datron 4707
  • Datron 4708
  • Datron 4800
  • Datron 4800A
  • Datron 4808

4707/M4707 statements will execute with any of the following configured:

  • Datron 4707
  • Datron 4708
  • Datron 4808

4708/M4708 statements will execute with any of the following configured:

  • Datron 4708
  • Datron 4808

Fluke 5080A-SC, 55xxA-SC300, 55xxA-SC600, 55xxA-SC1100 Oscilloscope Calibration Options and 5800A, 5820A Oscilloscope Calibrators

O_CAL statements will execute with any of the following configured, dependent upon maximum frequency and parameters specified:

  • Fluke 5080A w/5080A-SC
  • Fluke 5500A w/5500A-SC300
  • Fluke 5500A w/5500A-SC600
  • Fluke 5502A w/5502A-SC300
  • Fluke 5502A w/5502A-SC600
  • Fluke 5520A w/5520A-SC300
  • Fluke 5520A w/5520A-SC600
  • Fluke 5520A w/5520A-SC1100
  • Fluke 5522A w/5522A-SC600
  • Fluke 5522A w/5522A-SC1100
  • Fluke 5800A
  • Fluke 5820A

Special Notes:

All functionality required to 100% check device mapping has not been implemented. For example, nearly all of the instrument capability which is not in the core set of O_CAL capabilities supported by ALL O_CAL => System Instrument Device Mapping is defined with an O_CAL FSC attribute. Attribute Examples:

    • ED (Edge Signal)
    • PU (Pulse Signal)
    • Etc.

Some variations in the mapped devices that are not equivalent, but are not called out with an attribute. For example, maximum voltage for Leveled Sine with 50 Ω output impedance.

Fluke 5502E Multiproduct Calibrator

5502E statements will execute with any of the following configured:

  • Fluke 5502E
  • Fluke 5502A
  • Fluke 5520A
  • Fluke 5522A

Fluke 5502A Multiproduct Calibrator

5502A statements will execute with any of the following configured:

  • Fluke 5502A
  • Fluke 5520A
  • Fluke 5522A

Fluke 5520A Multiproduct Calibrator

5520/M5520 statements will execute with any of the following configured:

  • Fluke 5520A
  • Fluke 5522A

Fluke 5522A Multiproduct Calibrator

5522A statements will execute with any of the following configured:

  • Fluke 5520A
  • Fluke 5522A

Fluke 5700A Multifunction Calibrator

5700/MMFC statements will execute with any of the following configured:

  • Fluke 5700A
  • Fluke 5720A
  • Fluke 5730A

Special Notes:

  1. The Fluke 5730A does not support the obsolete 5205A, 5215A, and 5220A amplifiers.

Fluke 5700A/EP and 5720A Multifunction Calibrators

5720/M5720A statements will execute with any of the following configured:

  • Fluke 5720A
  • Fluke 5730A

Special Notes:

  1. A Fluke 5700A/EP must be configured as Fluke 5720A.
  2. The Fluke 5730A does not support the obsolete 5205A, 5215A, and 5220A amplifiers.

Fluke 5800A Oscilloscope Calibrator

5800/M5800 statements will execute with either of the following configured:

  • Fluke 5800A
  • Fluke 5820A

Fluke and Philips PM 6680 and PM 6680B and Wavetek 900 and 901 Counter/Timers

6680/M680 statements will execute with either of the following configured:

  • Philips PM 6680
  • Philips PM 6681

Special Notes:

  1. The Fluke PM 6680, PM 6680B and Wavetek 900 must be configured as Philips PM 6680.
  2. The Fluke PM 6681 and PM 6681R and Wavetek 901 must be configured as Philips PM 6681.

Fluke and Philips PM 6304 and Fluke PM 6304C RCL Meters

6304/M6304 statements will execute with either of the following configured:

  • Fluke PM 6604
  • Fluke PM 6304C

Special Notes:

  1. The Philips PM 6304 must be configured as Fluke PM 6604.
  2. The Philips PM 6304C must be configured as Fluke PM 6604C.

Wavetek 39A and 195 Function Generators

39A/M39A statements will execute with either of the following configured:

  • Wavetek 39A
  • Wavetek 195

Special Notes:

  1. The Fluke 281 must be configured as Wavetek 39A.
  2. The Fluke 282 must be configured as Wavetek 195.

Wavetek and Datron/Wavetek 1271 Digital Multimeter

1271/M1271 statements will execute with either of the following configured:

  • Datron 1271
  • Datron 1281

Special Notes:

  1. The Wavetek 1271 must be configured as Datron 1271.
  2. The Wavetek 1281 must be configured as Datron 1281.

Wavetek and Datron/Wavetek 4800, 4800A, 4805, and 4808 Multifunction Calibrators

4800/M4800 statements will execute with any of the following configured:

  • Datron 4707
  • Datron 4708
  • Datron 4800
  • Datron 4800A
  • Datron 4808

4800A/M4800A statements will execute with any of the following configured:

  • Datron 4707
  • Datron 4708
  • Datron 4800A
  • Datron 4808

4805/M4805 statements will execute with any of the following configured:

  • Datron 4700
  • Datron 4705
  • Datron 4707
  • Datron 4708
  • Datron 4800
  • Datron 4805
  • Datron 4800A
  • Datron 4808

4808/M4808 statements will execute with either of the following configured:

  • Datron 4708
  • Datron 4808

Special Notes:

  1. The Wavetek and Datron/Wavetek 4800 must be configured as Datron 4800.
  2. The Wavetek and Datron/Wavetek 4800A must be configured as Datron 4800A.
  3. The Wavetek and Datron/Wavetek 4805 must be configured as Datron 4805.
  4. The Wavetek and Datron/Wavetek 4808 must be configured as Datron 4808.

Wavetek and Datron/Wavetek 9000 Meter Calibration System

9000/M9000 statements will execute with either of the following configured:

  • Datron 9000
  • Datron 9100

Special Notes:

  1. The Wavetek and Datron/Wavetek 9000 must be configured as Datron 9000.
  2. The Fluke, Wavetek, and Datron/Wavetek 9100 must be configured as Datron 9100.


Evaluation Test

An Evaluation test may perform one of two types of evaluation: a stimulus or a measurement evaluation.

For a stimulus evaluation, a calibrator applies a known value to the UUT and checks the UUT reading to determine if it is within the specified tolerance.

A measurement evaluation checks that a UUT output is within the specified tolerance.

The effects of the type of calibration instrument function, type of test, and method of UUT reading entry on UUT Indicated, System Actual, and the contents of MEM and MEM1 are described below.

Stimulus Functions

An example of this type of evaluation test is as follows:

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
  1.001  5500   400   350mV          0.1% 0.1/     60H            SI       2W

There are three ways to evaluate UUT performance when using stimulus-type calibration instruments:

  1. Slew the output until the UUT reads the nominal value, or slew the reading on the display to match the UUT reading. The latter method is used when the calibration instrument supplies only discrete values of resistance. This method provides detailed performance information and is least prone to operator error. The Slew method is used when any of the defaults ASK- B, ASK- G, or ASK- K is in effect. Refer to the description of these flags in the ASK FSC topic.
  2. Enter the UUT reading from the keyboard. The keyboard method is selected with ASK+ K. When ASK+ B is set, the operator has the option to select Keyboard entry.
  3. Select Yes if the UUT reading is within the range displayed on the screen; if not, select No. This method, called Go/No-Go testing, does not provide detailed performance information on the UUT but does minimize procedure execution time. The Go/No-Go method is selected when ASK+ G is in effect. When ASK+ B is set the operator has the option to select Go/No-Go.

If the UUT reading can be obtained under remote control via the IEEE-488 or RS-232C interface, a closed-loop verification is possible. Setup tests are used to apply the required stimuli. The PASS/FAIL evaluations of the readings are done with the MEMC FSC. Refer to the descriptions of the IEEE, PORT, and MEMC FSCs in the respective FSC sections for detailed information. Each method is explained in more detail below:

Note: Remote control of a UUT does not guarantee the reading can be obtained remotely. This is especially true for scopes.

Slew Evaluation (Except Discrete Resistance)

(ASK- B, ASK- G, ASK- K or optionally with ASK+ B)

Use the key or the mouse to select the desired button, then use either the mouse or key to slew the output of the calibration instrument. Refer to Figure 1. When the stimulus is adjusted sufficiently for the UUT to read the nominal value, select Advance to proceed to the next procedure step. The error is computed, and a PASS or FAIL condition is established for the test. Refer to Figure 4 to see the test result.

Slew Dialog Box (Except Discrete Resistance)

The following UUT Indicated and System Actual are reported in the Post-Test Summary and may be included in the results file depending on the results template used at the time the procedure is executed:

UUT Indicated
The value shown in the NOMINAL field or the value of memory register MEM if only units were specified in the NOMINAL field.
System Actual
The calibration instrument output when Advance is selected.

Values of memory registers MEM and MEM1:

MEM
Not affected by the slew evaluation.
MEM1
System Actual

Slew Evaluation (Discrete Resistance)

(ASK- B, ASK- G, ASK- K or optionally with ASK+ B)

When only discrete resistance values are available from calibration stimulus instruments, resistance cannot be slewed. When the slew method is used for discrete resistance, the value on the display is adjusted to exactly match the UUT. This includes the 4000, 4000A, 4700, 4705, 4707, 4708, 4800, 4800A, 4805, 4808, 5450, 5700, 5720, and RESF FSCs.

An example of this type of evaluation test is as follows:

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
  1.001  5700   10    10Z            0.1% 0.1/                             2W

Use the mouse or the key to slew the displayed reading as described before. When the value on the display matches the UUT reading, select Advance to go to the next procedure step. The error is computed and compared to the specified value in the procedure line.

Slew Dialog (Discrete Resistance)

The following UUT Indicated and System Actual are reported in the Post-Test Summary and may be included in the results file depending on the results template used at the time the procedure is executed:

UUT Indicated
This value on the display when Advance is selected.
System Actual
The actual calibration value of resistance for the 5450A, 5700A, and 5720A. The actual value is reported instead of the value in the NOMINAL field (e.g., 10.000012 instead of 10 Ω). The 4000, 4000A, 4700, 4705, 4707, 4708, 4800, 4800A, 4805, 4808, 5100B and 5130A do not support the ability to query the actual resistance; therefore, the NOMINAL value is used.

Values of memory registers MEM and MEM1:

MEM
Not affected by the slew evaluation.
MEM1
UUT Indicated.

Keyboard Evaluation (ASK+ K or optionally with ASK+ B)

When the keyboard method is used, you are prompted to enter the UUT reading.

Keyboard Entry Operator Prompt

After the UUT reading is entered, the error is computed. The test result appears as shown:

Post-Test Summary of a Slew or Keyboard Entry Instrument Evaluation

The following UUT Indicated and System Actual are reported in the Post-Test Summary and may be included in the results file depending on the results template used at the time the procedure was executed:

UUT Indicated
The value entered from the keyboard.
System Actual
The value shown in the NOMINAL field or the value of memory register MEM if only units were specified in the NOMINAL field.

Values of memory registers MEM and MEM1:

MEM
Not affected by keyboard entry evaluation.
MEM1
UUT Indicated.

Go/No-Go Evaluation (ASK+ G or optionally with ASK+ B)

When the Go/No-Go method is used, you are prompted to respond Yes or No based on whether the UUT reading is between the limits displayed in the dialog.

Go/No-Go Evaluation Test

These limits are determined from the tolerance information and depend on the adjustment threshold value if an adjustment procedure follows the evaluation step. For example, if no adjustment step follows, the limits are as follows:

349.25 mV and 350.75 mV

The exact UUT error cannot be computed, only a PASS/FAIL condition is determined, based on operator's response. The test result appears as shown in Figure 6.

Post-Test Summary of a Go/No-Go Instrument Evaluation

The following UUT Indicated and System Actual are reported in the Post-Test summary and may be included in the results file depending on the results template used at the time the procedure was executed:

UUT Indicated
OPER-EVAL.
System Actual
The value shown in the NOMINAL field or the value of memory register MEM if only units were specified in the NOMINAL field.

MEM and MEM1 updates:

MEM
Not affected by the Go/No-Go evaluation.
MEM1
+1 indicating a PASS condition if YES was selected. -1 indicating a FAIL condition if NO was selected.

Measurement Functions

An example of this type of evaluation test is as follows:

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
  1.001  8842   10    10Z            0.1% 0.1/                             2W

This example programs the 8842A to measure volts.

The operator is asked to set the UUT output to the NOMINAL value and place it in operate unless this automatic message is disabled by ASK- N (Figure 7).

When Advance is selected, the measurement is made and the operator is asked to put the UUT in standby unless this automatic message is disabled by ASK- N.

Test Setup Prompt

The error is computed and a PASS or FAIL condition is established for the test. The ASK B, G, and K-flags have no influence on this type of evaluation.

The following UUT Indicated and System Actual are reported in the Post-Test Summary and may be included in the results file depending on the results template used at the time the procedure is executed:

UUT Indicated
The value shown in the NOMINAL field or the value of memory register MEM if only units were specified in the NOMINAL field.
System Actual
The actual UUT output as measured by the calibration instrument.

Values of memory registers MEM and MEM1:

MEM
Not affected by the evaluation.
MEM1
System Actual.


Setup Test

For a stimulus function, a Setup Test applies the nominal value to the UUT. For a measurement function, a Setup Test continually monitors a UUT output as the UUT is adjusted to the specified nominal value.

Stimulus Function

The calibration instrument is set up to output the nominal value. The upper part of the display indicates the stimulus. No evaluations or results are generated, and procedure execution continues immediately with the next procedure statement.

The stimulus is removed when a reset statement for the same FSC is executed, e.g., "*" is in the nominal field, or when an evaluation FSC is completed and the step number increments, unless ASK- D is in effect.

Values of memory registers MEM and MEM1:

MEM
Not affected by the setup test.
MEM1
The applied stimulus. This is the value specified in the NOMINAL field except for resistance from the 5700A and 5450A. For these cases, MET/CAL queries the calibrator to determine the actual resistance which is then used instead of the value in the NOMINAL field (e.g., 10.000012 instead of 10Ω).

The following is an example of a stimulus Setup Test used during closed-loop verification of a UUT.

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
  1.001  IEEE         F1R3
  1.002  5700         10V                                               S  2W
  1.003  IEEE         ?[I]
  1.004  MEMCX  20    10.0000V       .005% .0003U

Explanation:

  1. The UUT is programmed to the desired function and range in step 1.001. Refer to the IEEE FSC topic for more detailed information on its operation.
  2. Step 1.002 causes the 5700A to apply 10V. After this step, MEM1 contains the value 10.
  3. In step 1.003, the system acquires the reading from the UUT and stores the result in register MEM.
  4. In step 1.004, the values stored in MEM and MEM1 are used to determine the UUT error and a PASS or FAIL condition is established for the test. Refer to the MEMCX FSC section for more detailed information on its operation.

Measurement Function

The operator is prompted to adjust the UUT to the NOMINAL value, unless the message has been disabled with ASK- N.

The system displays any pending MESS lines (refer to the MESS FSC topic for more information), and then displays the present measurement, which is continually updated. After the operator selects Advance, the next procedure line is executed.

UUT Setup Dialog

Values of memory registers MEM and MEM1:

MEM
Not affected by the setup test.
MEM1
The UUT output as measured just prior to selecting Advance.

The operator is asked to set the UUT output to the NOMINAL value and place it in operate unless this automatic message is disabled by ASK- N.

When Advance is selected, the measurement is made and the operator is asked to put the UUT in standby unless this automatic message is disabled by ASK- N.


Nominal Setup Test

The Nominal Setup test allows the output of a stimulus calibration function to be adjusted until the UUT reads a nominal value; it does not perform an evaluation. For a measurement calibration function, a single reading is taken. This value may be used later in a Comparison Test.

Stimulus Function

The ASK B, G, and K flags have no influence on the NOMINAL Setup test. You slew the system stimulus until the UUT reads the nominal value, as is done for the Slew evaluation test. However, no evaluation takes place and no results are generated. The following is an example of a stimulus Nominal Setup Test.

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
  1.001  5700   10    10V                                               N  2W

Stimulus Nominal Setup Dialog

Values of memory registers MEM and MEM1:

MEM
The calibration instrument output on selecting Advance.
MEM1
Not affected by the test.

Measurement Function

An example of this type of test is as follows:

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
  1.001  8842   10    10Z                                               N  2W

The calibration measurement instrument expects to measure the nominal value. You are asked to set the UUT output to the NOMINAL value and place it in Operate. When you select Advance, the measurement is taken and you are asked to put the UUT in standby. No evaluation takes place and no results are generated. The next procedure line is executed immediately afterwards.

Automatic Completion Message

This test can be used for frequency response testing initialization in conjunction with Comparison Tests.

Values of memory registers MEM and MEM1:

MEM
The measured value.
MEM1
Not affected by the test.


Comparison Tests

The Comparison Test is used in conjunction with the Nominal Setup Test. The Comparison Test operates like an evaluation test, except that the value established by the Nominal Setup Test is used as the reference for the evaluation, rather than the value specified in the NOMINAL field.

Stimulus Function

An example of this type of test is as follows:

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
  1.001  5500   400   350.0mV                      60H            SI    N  2W
  1.002  5500   400   350.0mV        0.1% 0.1/     1kH            SI    C  2W
  2.001  5500   400   350.0mV        0.1% 0.1/     100kH          SI    C  2W

Only the Slew method is used; ASK K, G, and B flags are ignored. See Slew Evaluation under Evaluation Tests - Stimulus Function described earlier in this section.

Measurement Function

An example of this type of test is as follows:

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
  1.001  8842   2     1.900V                       60H                  N  2W
  1.002  8842   2     1.900V         0.1% 0.1/     1kH                  C  2W
  2.001  8842   2     1.900V         0.1% 0.1/     10kH                 C  2W

The operator is asked to set the UUT output to the NOMINAL value and place it in Operate (Figure 7). When Advance is selected, the measurement is taken and the operator is asked to put the UUT in standby. These automatic messages may be disabled using ASK- N. If ASK- R and ASK- W are in effect, the automatic connection and range messages are also disabled. The UUT error is computed using the measurement and the reference value stored in MEM. A PASS or FAIL condition is then established for the test based on the limits specified in the tolerance field.


IEEE-488 Service Request (SRQ) Processing

The calibration system maintains a list of valid instruments and their IEEE-488 addresses. IEEE-488 SRQs are processed as follows:

  1. The SRQ is detected.
  2. MET/CAL checks to see if the SRQ was expected as a result of the IEEE FSC. If so, the serial poll is performed and the SRQ interrupt is cleared.

    3. If the SRQ was not expected as a result of the IEEE FSC, continue with step 3.

  3. The calibration instrument whose FSC is being executed is serial polled if it is on the IEEE-488 bus. If an error is reported, the Post Test screen comes up, indicates the error and asks you to do one of the following:
    • Repeat
    • Advance
    • Terminate

    If the calibration instrument whose FSC is being executed did not issue an SRQ, continue with step 4.

  4. The UUT is serial polled if the UUT is on the IEEE-488 bus. If the SRQ originated from the UUT, MET/CAL reports:

    5. Unexpected SRQ From UUT: address, SPL = value, value

    You have the same choices: repeat or skip the test, or terminate the procedure.

    If the UUT did not create the SRQ, continue with step 5.

  5. Perform a serial poll of the configured calibration instruments. If the SRQ was from one of these instruments, report the error. You have the choice to repeat the test, skip it, or terminate the procedure.

If the SRQ did not come from one of these configured instruments, test to see if the SRQ is still present. If the SRQ line is no longer asserted, continue with MET/CAL procedure execution. Otherwise, the procedure is aborted.


Instrument Resets

MET/CAL Runtime resets the calibration instruments under the following circumstances:

When MET/CAL is started, the following sequence is carried out:

  1. An IEEE-488 Interface Clear command is sent.
  2. Each system instrument required by the procedure receives a reset command.
  3. Any error that occurs as a result of a calibration instrument not responding is reported. If an error occurs, the following selections are available:

    1. Retry - Correct the hardware error and then select retry (e.g. turn the power on) .

    2. Abort - Aborts the calibration procedure.

    3. Ignore - Ignores the error and proceed without the instrument that reported the error. If the instrument is needed to perform a calibration step in the procedure, another error is reported and the operator can choose to go to the next calibration test or terminate the procedure.

      Selecting Ignore also removes this instrument from the list of configured instruments in the computer's memory. The only way to restore it is to force the application to reload the instrument configuration by editing it, or to close and then re-open the MET/CAL Runtime and MET/CAL Editor applications, which also reloads the instrument configuration.

      Implementing Procedure Sectioning eliminates this scenario.

At the completion or abnormal termination of every test in the calibration procedure (an evaluation), the following occurs:

  1. Stimulus calibration instruments are placed in Standby mode.
  2. Stimulus calibration instruments are reprogrammed to a safe voltage if necessary.

After termination of the procedure, the following occurs:

  1. An IEEE-488 Interface Clear command is sent.
  2. Each system instrument required by the procedure receives a reset command


Use of Standard Memory Registers

The following tables show how the standard memory locations, MEM, MEM1, UUT Indicated, and System Actual, are used.

Evaluation Tests

Function | MEM | MEM1 | UUT Indicated | System Actual
Stimulus, SLEW (Except Discrete Ohms) | No Change | Slew Value | Nominal Value | Slew Value
Stimulus, SLEW (4000, 4000A, 4700, 4705, 4707, 4708, 4800, 4800A, 4805, 4808, 5100B & 5130A Ohms) | No Change | Slew Value | Slew Value | Nominal Value
Stimulus, SLEW (5450A, 5700A, & 5720A Ohms) | No Change | Slew Value | Slew Value | Actual Resistance
Stimulus, Keyboard Entry | No Change | Entered Value | Entered Value | Nominal Value
Stimulus, Go/No-Go | No Change | +1 (PASS) -1 (FAIL) | OPER-EVAL | Nominal Value
Measurement | No Change | Measured Value | Nominal Value | Measured Value

Setup Tests

Function | MEM | MEM1 | UUT Indicated | System Actual
Stimulus (Except 5700A & 5450A Ohms) | No Change | Nominal Value | na | na
Stimulus (5700A & 5450A Ohms) | No Change | Real Value | na | na
Measurement | No Change | Measured Value when advance is selected | na | na

Nominal Setup Tests

Function | MEM | MEM1 | UUT Indicated | System Actual
Stimulus, SLEW | Slew Value | No Change | na | na
Measurement | Measured Value | No Change | na | na

Comparison Tests

Function | MEM | MEM1 | UUT Indicated | System Actual
Stimulus, SLEW (Except Discrete Ohms) | No Change | Slew Value | MEM | Slew Value
Stimulus, SLEW (Discrete Ohms) | No Change | Slew Value | Slew Value | MEM
Measurement | No Change | Measured Value | Nominal Value | Measured Value


Tolerance Computations

The tolerance definition is:

"The positive tolerance amount determines how much the UUT can read high (i.e., the true value can be the same amount lower) and the negative tolerance amount determines how much the UUT can read low (i.e. the true value applied or measured can be the same amount higher)."

Abbreviations and definitions are:

Abbreviation | Full Description | Definition
UI | UUT Indicated value | This is the value the UUT indicates after the test has been performed. It represents the value the UUT thinks it measures or applies.
SA | System Actual Value | This is the true value applied to the UUT (if the UUT is a measurement device) or measured by the calibration instrument (if the UUT is a stimulus device). This value is determined by an accurate calibration instrument in your system.
NV Nominal Value

The nominal value is the stated value in the calibration procedure line for an instrument FSC. Depending on the type of evaluation test, NV matches either UI or SA:

Type of test: NV:

  • Stimulus Slew, non-Ohms UI
  • Stimulus Slew, Fixed Ohms SA (may be corrected value)
  • Stimulus Keyboard entry SA (may be corrected value)
  • Stimulus Go/No-Go SA (may be corrected value)
  • Measurement FSC UI

In case of corrections (either in case of fixed Ohms calibration stimulus or use of correction files) the SA is typically close to the NV.

DE | Deviation | The deviation is simply the difference between UI and SA: DE = UI - SA
PTA Positive Tolerance Amount (from FSC Tolerance field)

The upper tolerance amount is how much the UUT can read high. The tolerance field in the procedure contains unsigned, plus ('+') signed and/or ('-') negative sign parts. The PTA consists of the unsigned and plus signed ('+') parts. For example, if the tolerance field shows:"1U -2U +3U", PT = 1 + 3 = 4U. When tolerances are expressed in percent of nominal ('%') or percent of range ('/'), ppm of nominal ('P%') or ppm of range ('P/'), the appropriate factor (0.01 or 0.000001) is applied to find the absolute tolerance contribution.

The variable tol_ref in the MET/CAL STARTUP file determines if the relative test tolerance computations are based on the UUT_Indicated value (as currently implemented) or the nominal value (as requested by some MET/CAL users). It should be noted that most specifications of DMMs are based on their reading, i.e. their UUT Indicated value. In many situations (all closed loop calibrations) this leads to the unexpected result that the tolerance band is not symmetrical around the fixed nominal value. The tol_ref variable allows symmetrical tolerances around the nominal value.

The tol_ref variable can assume one of two values:

tol_ref = UUT_INDICATED

tol_ref = NOMINAL

NTA Negative Tolerance Amount (from FSC Tolerance field)

The lower tolerance amount is how much the UUT can read low. The negative tolerance amount consists of the unsigned and minus ('-') parts. In the example shown: "1U -2U +3U", NT = 1 + 2 = 3U. The same rules for relative tolerance contributions as shown under the description of PT apply.

For TUR computations, the smallest of PTA and NTA is used, unless PTA or NTA is zero, in which the non-zero variable is used.

LL | Lower Limit | The lower limit represents the lowest value of the SA which will cause the outcome of a test to change from PASS to FAIL. LL = UI - PTA For Go/No-Go tests, the UI is unknown; in this case LL is defined relative to the SA: LL = SA - NTA
UL Upper Limit

The upper limit represents the highest value of the SA which will cause he outcome of a test to change from PASS to FAIL. UL = UI + NTA

For Go/No-Go tests, the UI is unknown; in this case UL is defined relative to the SA: UL = SA + PTA

In order to pass a test: LL < SA < UL The outcome of a test is marginal (assuming the adjustment threshold is at 70%) if:

UI - (UI - LL) * 0.7 < SA < UI + (UL - UI) * 0.7

ET Error as a percentage of tolerance

If DE > 0: ET = DE/PTA. If DE ≤ 0: ET = -DE/NTA.

For an asymmetrical test tolerance, the tolerance used to calculate the value of ET$ is either the PTA (Positive Tolerance Amount) or the NTA

(Negative Tolerance Amount). If the UUT "reads high", i.e., if UI ≥ SA, the PTA is chosen as the tolerance. If the UUT "reads low", i.e., if UI < SA, the NTA is chosen as the tolerance.

ER | Relative Error | Error relative to UI or NV, depending on the value of tol_ref. If NV, UI or SA is zero, the absolute error will be shown.
ST | System Tolerance | The uncertainty of the calibration instrument. For asymmetrical tolerances (e.g., the accuracy is expressed in dBm) the worst case is chosen.
TT | Test Tolerance | The uncertainty of the test. In case of non-linear units, conversion to linear units takes place. For asymmetrical tolerances, the test tolerance is chosen, which matches the deviation. For Go/No-Go tests, the lowest tolerance is chosen (to cause the worst case TUR).
TU Test Uncertainty Ratio

The TUR is: TU = TT/ST. If the tur_lim variable in the STARTUP file is not set to 'none', the result is compared to the assigned value for tur_lim. If TU > tur_lim, no output is generated. If TU ≤ tur_lim, the value of TU is reported.

The computation of tolerance variables as a result of the tol_ref variable is as follows:

The computation of tolerance variables as a result of the tol_ref variable is as follows:

quantity | tol_ref = UUT_INDICATED | tol_ref = NOMINAL
DE | UI - SA | same
ER | (UI - SA) / UI | (UI - SA) / NV
ET | DE / TOL | DE / TOL
LL | UI - TOL (TOL based on UI) | UI - TOL (TOL based on NV)
UL | UI + TOL (TOL based on UI) | UI + TOL (TOL based on NV)
ST | no change | same
TT | based on UI | based on NV
TU | based on UI | based on NV


Computing Test Uncertainty Ratio

The Test Uncertainty Ratio (TUR) is computed only after compilation or execution of a result-generating instrument FSC and the MEMC FSC. This computation is done both during the final pass of compilation and while executing the procedure. At compilation, the Test Tolerance is determined as the distance to the closest tolerance limit (unless one of the limits is zero.) For example, a +3U in the TOLERANCE field (implying -0U tolerance) will cause the Test Tolerance to be 3U. At execution, the TUR is calculated as the distance from the specified Nominal to the tolerance limit which falls on the same side of the Nominal as the System Actual.

MET/CAL gives a warning when the TUR drops below TUR Limit. The compilation still succeeds. For example, a test can specify that a 1% meter should be perfect. The test tolerance is therefore zero. Even a 10 ppm calibrator is not good enough to avoid the creation of a warning, since the TUR is also zero.

All accuracies of calibration instruments are symmetrical around the programmed nominal value. However, the tolerance of the test can specify different tolerances in the positive and negative directions. In that case, for the purposes of computing the TUR, the tightest tolerance is used. This means specifying the tolerance as +0.1% implies the negative tolerance is 0. This always results in a TUR warning of 0 that normally can be ignored.

Example TUR Calculation

  • UUT Indicated = 100V
  • Tolerance = -2U +1U
  • System Actual = 99V

The test tolerance on the lower side of the UUT Indicated is used because the System Actual is less than the Nominal. The test tolerance on the lower side of 100V is 2V, so the ERROR%TOL is 50%.

Instrument Evaluation Test with Known Nominal Value

The calibration system uncertainty is obtained from the information in the calibration instrument related Accuracy File.

The allowed tolerance for the test is derived from the procedure line. In the most common situation, the evaluation step appears in a fully defined test; for example:

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
  2.001  5700   10    10V            0.1% 0.1%                             2W

The allowed tolerance is 0.1% of nominal (10V) and 0.1% of range (10), so the total tolerance is 0.02V. The TUR is: test tolerance / calibration system uncertainty

If the TUR drops below TUR Limit, the calibration system reports the following as a warning during compilation:

  • The absolute value of the test tolerance.
  • The absolute value of the calibration system uncertainty.
  • The Test Uncertainty Ratio.

If the TUR drops below TUR Limit, the calibration system adds to the test result the value of the TUR.

All TURs are computed in linear scale units. Any nominal values or Accuracy File information expressed in dBm are first converted to volts. A warning includes the linear values.

The Test Uncertainty Ratio of a Comparison Test is computed using the stated Nominal value. It is possible for erroneous warnings to result from this assumption if the value stored in MEM and the NOMINAL field differ substantially.

Instrument Evaluation Test with Unknown Nominal Value

If the nominal value is not defined in the procedure, it is difficult or impossible to determine the TUR when the procedure is compiled. However, during calibration procedure execution, the TUR can be defined since the nominal value is known. Therefore, the reporting of the TUR being too low is the same as previously described.

During procedure compilation, the system attempts to estimate a worst case TUR for the test. The worst case occurs with the worst tolerance of the calibration system instrument and the minimum tolerance of the test. It is not possible to verify that the conditions assumed are indeed worst case, although they typically are. Some estimate can be made if at least the range is specified. Without that information, no TUR estimate is possible.

The allowed tolerance for the test cannot be totally derived from the procedure line. For example:

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
  2.001  5700   10    V              0.1% 0.1/                             2W

The allowed tolerance is 0.1% of nominal (the nominal value to be taken from memory register MEM) plus 0.1% of range (10), which amounts to 0.01V. In this case, the TUR is computed as follows:

TUR = (test tolerance with Nominal set to the Range value) / (calibration system uncertainty with Nominal set to Range value)

If this TUR value drops below TUR Limit, the calibration system reports the following as a warning:

  • Estimated absolute value of the test tolerance at the Range value.
  • Estimated absolute value of the calibration system accuracy at the Range value.
  • Estimated Test Uncertainty Ratio.

MEMCX FSC with Known Nominal Value

The MEMC FSC is used most often in closed loop calibration using a Setup FSC, followed by an IEEE FSC, a MEME, and a MEMC to determine the outcome of the test. For example:

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
  2.001  IEEE         F1R3
  2.002  5700         10.00V                                            S  2W
  2.003  IEEE         ?[I]
  2.004  MEMCX  10    V              0.1% 0.1/

  3.001  ...

The calibration system uncertainty is therefore generally determined by the last instrument Setup FSC preceding the MEMCX FSC. In this example it is step 2.001: the Setup test of the 5700 FSC. Whenever a Setup FSC is encountered, the MET/CAL compiler stores the calibration system uncertainty of this Setup test using the information of the Accuracy File of the related instrument, in this case the 5700A. This accuracy is used for computing the TUR when the MEMCX FSC line is being verified during compilation or executed during procedure execution.

The allowed tolerance for the test is derived from the MEMCX procedure line. According to the example, the allowed tolerance of the test is 0.01% of the nominal value (MEM1) plus 0.001% of the range (10) so that the total tolerance is 0.011. In this case

TUR = (test tolerance) / (stored calibration system uncertainty)

If the TUR drops below TUR Limit during procedure compilation, the calibration system reports the following as a warning:

  • The absolute value of the test tolerance.
  • The absolute value of the calibration system accuracy.
  • The Test Uncertainty Ratio.

During test execution, if the TUR drops below TUR Limit, the calibration system reports the value of the TUR.

Erroneous warning messages can be generated when the last Setup test is not the one that represents the calibration system accuracy.

MEMC FSC with Unknown Nominal Value

A MEMC FSC with an unknown nominal value is similar to the case of an instrument FSC with an unknown value. When you execute the procedure, the nominal value is known, and the TUR is reported, if it is below the TUR Limit value. During procedure compilation, a TUR may be estimated or an estimate may not be possible.

If no range information is provided, an estimate of the TUR cannot be defined during compilation and no estimate is made. Some estimate could be made if at least range information were present. The MEMC line in the previous example now appears as follows:

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
  1.001  MEMC   10    V              0.1% 0.1/

The calibration system accuracy is determined again by the last Setup test in the procedure, as was described earlier where the Nominal value of the MEMC FSC was defined. It is assumed that the nominal value is set to the range value.

The allowed tolerance for the test is 0.1% of nominal (the nominal value to be taken from memory register MEM) plus 0.1% of range (10), which amounts to 0.01V. In this case:

TUR = (test tolerance with Nominal set to the Range value) / (system uncertainty with Nominal set at the Range value)

If this TUR value drops below TUR Limit, the calibration system reports the following as a warning:

  • Estimated absolute value of the test tolerance at the range value.
  • Estimated absolute value of the stored calibration system uncertainty at the Range value.
  • Estimated Test Uncertainty Ratio.

Erroneous warning messages can be generated when the last Setup test is not the one that represents the calibration system accuracy.

Warnings are given only when the TUR drops below TUR Limit. The compilation is still successful. For example, a test can specify that a 1% meter should be right on. The test tolerance is therefore zero. Even a 10-ppm calibrator is not good enough to avoid the creation of a warning, since the TUR is also zero.

The Tolerance Reference MET/CAL Configurations setting determines if the relative test tolerance computations are based on the UUT_Indicated value (as currently implemented) or the Nominal value (as requested by some MET/CAL users). Most specifications of DMMs are based on their reading, i.e., their UUT Indicated value. In many situations (closed-loop calibrations), this leads to the unexpected result that the tolerance band is not symmetrical around the fixed Nominal value. The Tolerance Reference setting allows symmetrical tolerances around the Nominal value. The Tolerance Reference setting can assume one of two values: UUT_Indicated or Nominal, but only affects the portion of TOL that is % or PPM.


Special Constructions

A number of special constructions are used in Procedure Control FSCs, Display Control FSCs, PORT, IEEE, IEEE2, SCPI, and EVAL FSCs. The table below shows what the various special constructions are, how they are written, and what FSCs they are used with.

Special Constructions

IEEE-488 address | [@primary address[:secondary address]] | IEEE, IEEE2, SCPI
delay | [Dnumeric] | DISP, EVAL, HEAD, IEEE, MEMI, OPBR, PORT, RSLT, SET
draw | [DRAWx,y,view] | DISP, EVAL, OPBR, SET
input | [I$] > filename or [I] > filename | IEEE, IEEE2, PORT, SCPI
memory register | [MEM], [MEM1] or [MEM2] | DISP, EVAL, HEAD, IEEE, IEEE2, SCPI, MEMI, MEM2, MESS, OPBR, PORT, RSLT
integer | [positive integer] | DISP, EVAL, HEAD, IEEE, MEMI, MEM2, MESS, OPBR, PORT, RSLT
port configuration | [Pbaud rate],[parity],[data bits], [stop bits], [handshake] | PORT only
timeout | [Ttimeout] | IEEE, IEEE2, SCPI,PORT
wait for srq | [SRQtimeout,mask] or [SRQ ON|OFF] | IEEE only
serial poll | [SPLmask] | IEEE only
negate response | [N] | EVAL only
selected device clear | [SDC] | IEEE, IEEE2, SCPI
remote enable | [REN] | IEEE, IEEE2, SCPI
goto local | [GTL] | IEEE, IEEE2, SCPI
local lockout | [LLO ] | IEEE, IEEE2, SCPI
group execute trigger | [TRIG] | IEEE, IEEE2, SCPI
end of information | [EOI ON|OFF] | IEEE only
input terminator | [TERM number], [TERM 'char'], [TERM CR] or [TERM LF ] | IEEE, PORT
output terminator | [OTERM number], [OTERM ‘char’], [OTERM CR], [OTERM LF], [OTERM CRLF], [OTERM NONE], or [OTERM OFF] | PORT only
interface clear | [IFC port number] | IEEE, IEEE2, SCPI
inter-byte delay | [Sinter-byte delay] | IEEE, IEEE2, SCPI
variable | [Vvariable name] | DISP, HEAD, IEEE, IEEE2, SCPI, MEMI, MEM2, MESS, OPBR, PORT, RSLT, SET
output to file | [O < file name] | IEEE, IEEE2, SCPI, PORT
flush receive buffer | [CLR], [CLR ON], or [CLR OFF] | PORT only
serial address | [@port designator] | PORT only
default button | [NO] | OPBR only


Delay Construction

The special construct [Dinteger] causes a delay of the message line by integer milliseconds. The available range is 0 to 32767 milliseconds. The delay occurs at the position of the construct. If the construct is included on the same line with text (e.g. 1.001 DISP [D5000]Delay occurs after text), the delay will occur after the entire line of text is displayed, regardless of the placement of the construct within the text.

For example, the following procedure line first causes the word This to be displayed. Ten seconds later, the word message is added, followed five seconds later by is delayed.

  1.001  DISP         This
  1.001  DISP         [D10000]
  1.001  DISP         message
  1.001  DISP         [D5000]
  1.001  DISP         is delayed


Draw Construction

A drawing is defined by a "DRAW" statement together with a [DRAWx, y, view] construction. The drawing does not appear until a statement containing a [DRAWx, y, view] construction is executed.

The DRAW FSC allows you to display two rectangles, one within the other. These rectangles are intended to show the outline of the UUT and the location of an item of interest (such as an adjustment potentiometer.) For detailed information on the DRAW FSC, refer to its description in Chapter 2.

The DRAW construct positions a annunciator within a simple drawing of the UUT, as created by the DRAW FSC, to show the location of a control or an adjustment. The drawing can indicate the view (from the front, from the back, etc.)The drawing appears on the right side of the computer screen.

The DRAW construct includes three modifiers (par1, par2, and par3), and is entered as follows:

[DRAWpar1,par2,par3]

The three modifiers are optional; however, the commas must still be entered. The modifiers are used for the following purposes:

par1
Specifies the Y coordinate of the annunciator. This modifier is specified as a percentage of the height of the UUT box, measured up from the bottom edge.
Allowable range: 0 - 100, inclusive.
par2
Specifies the X coordinate of the annunciator. This modifier is specified as a percentage of the width of the UUT box, measured right from the left edge.
Allowable range: 0 - 100, inclusive.
par3
Indicates the desired view from the UUT: front (F), back (B), left side (L), right side ®, top (T), or bottom/underside (U).

Specifying 0 (zero) for par1 and par2 causes the UUT drawing to be displayed without an annunciator.


Memory Registers

MET/CAL provides a number of registers that can be used to store and retrieve values. The registers that are directly accessible are:

[MEM] | MEM is a global numeric memory register that stores a floating-point value. This construction causes the current value of memory register MEM to be inserted in the text in place of the construction.
[MEM1] | MEM1 is a global numeric memory register that stores a floating-point value. This construction causes the current value of memory register MEM1 to be inserted in the text in place of the construction.
[MEM2] | MEM2 is a global 4096-character string register. This construction causes the current value of memory register MEM2 to be inserted in the text in place of the construction.
[M1], [M2], [M3], …, [M255] | M[n] are global numeric memory registers that store a floating-point value. These constructions cause the value of the respective memory register M[n] to be inserted in the text in place of the construction.
[L1], [L2], [L3], …, [L32] | L[n] are local numeric memory registers that store a floating-point value. These constructions cause the value of the respective memory register L[n] to be inserted in the text in place of the construction.
[S1], [S2], [S3], …, [S32] | S[n] are global string registers (max 32767). These constructions cause the current value of memory register S[n] to be inserted in the text in place of the construction.
[SREG1], [SREG2], …, [SREG32] | Alternate form for S[1] through S[32]. This from is required when used in the IEEE, IEEE2, RESET, and SCPI FSC’s.

When included in a procedure statement, the value contained in the identified memory location replaces the related special construction during procedure execution. For example:

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
  1.001  DISP         [MEM] Volts are stored

Assuming that memory location MEM contains the value 2, "2 Volts are Stored" will be displayed during program execution:.


Numeric Literals

Numeric literals print ASCII characters during procedure execution. The syntax that provides this capability is [n]. The square brackets are included. This construction causes the ASCII character corresponding to the numeric to be printed or used. For example:

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
  1.001  DISP         [7]Safety Notice Follows

This construction causes the computer to beep when the message is displayed because 7 is the ASCII character for bell (BEL).

Since braces and square brackets are reserved for special constructions, they cannot be used literally in a procedure line. The following special constructions must be used to print braces or square brackets:

Construct | Prints
[91] | [ (left square bracket)
[93] | ] (right square bracket)
[123] | { (left brace)
[125] | } (right brace)


Variables

The Variable construction evaluates to the value of the named variable. The syntax for the variable construction is [Vvariable name]. The variable must, at run time, be present in the MET/CAL Variable File. The default name is VARIABLE.DAT. The following is an example:

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
  1.001  DISP         Current date is [V DATE$].


FSC Reference

The following sections describe each FSC in detail. The FSCs are presented in a logical but non-sequential order.

Instrument FSCs are arranged by manufacturer, then model number of model series. Several help topics may be available to control a single model number. For example the Fluke 5520A can be controlled by the 5520 FSC, M5520 auxiliary FSC, 5522A FSC (through device mapping), and O_CAL FSC.

The FSC help topic contains:

  • FSC name (e.g., 5520, 5700, 5730A)
  • FSC type (e.g., Instrument or Message)

The description of each FSC includes:

  • A general description.
  • The values each parameter field in the FSC can assume.
  • Use of the standard memory registers MEM, MEM1, and MEM2.
  • Additional information about the FSC.
  • One or more examples.
Flexible Standards is a MET/CAL technique that allows the operator to interchange one reference instrument with another, specially configured instrument of the same functional class, without necessitating procedure modification. This technique is best suited to those categories of remotely controllable standards that include many different models with essentially the same functionality. These are the types of instruments that have similar functional capabilities but likely have different range points, different specifications and different control commands. See the Flexible Standards application note included in the MET/CAL documentation directory.


DOS and DOSE

Procedure Control FSCs

Description

The DOS and DOSE FSCs run user-provided programs or batch files. The program may be an MS-DOS executable, Windows executable, MS-DOS batch file, or Windows PIF file. The difference between the DOS and DOSE FSCs is that DOSE is an evaluation FSC which generates a result.

Format

DOS [-arg] program

DOSE [-arg] program

Rules

  1. The program field length, plus any arguments, may occupy up to 240 bytes (characters below ASCII 128 occupy a single byte).

    Example:

    1.001 DOS USERPROG

    This statement will execute the user-provided program named "USERPROG.EXE".

    Example:

    1.002 DOS USER.BAT

    This statement will execute the user-provided batch file named "USER.BAT".

  2. By default, the program or batch file to be executed must be in the current directory or in one of the directories listed in the "PATH" environment variable. However, the location of the user program, and of the DOS/DOSE data file, can be controlled on a workstation by setting optional parameters in the MET/CAL configuration settings.

  3. Arguments

    1. Valid arguments are:

      2. -n | write all global numeric registers to data file
      -a | write all global numeric and string registers to data file
      -x | pay attention to user program's exit status
      -i | ignore user program's exit status
      -b | preserve leading and trailing spaces on strings
      -w | create console application without console window
      -u | ignore "user_prog_dir" (and "user_cwd") when searching for specified user program

    2. One or more arguments may be specified for a DOS or DOSE procedure statement. Arguments, if any, must follow the FSC ("DOS" or "DOSE") and precede the user program name.

      For example:

      DOS -n myprog.exe

      is valid, but

      DOS myprog.exe -n

      is not valid (unless "-n" is an argument you wish to pass to "myprog.exe").

    3. Arguments are case-sensitive.

    4. No argument may be specified more than once for the same statement.

    5. "-a" and "-n" may not both be specified for the same statement.

    6. "-x" and "-i" may not both be specified for the same statement.

    7. Each argument must be preceded and followed by one or more spaces.

    8. The "-b" argument is used if you want MET/CAL to retain leading and trailing spaces on string register values read from the data file ("dosdose.dat"). For example, if you specify a MEM2 value of " x ", MET/CAL will normally strip off the leading and trailing spaces and the value of MEM2 will be "x". If "-b" is specified, however, MEM2 will have the value " x " after the DOS or DOSE statement completes.

    9. "-w" is appropriate if the user program is a console application (as opposed to a normal Windows application) and you would like the user program to run without a console window. The "-w" argument may be used with user programs which have no user interface, i.e., programs which neither prompt for nor display operator information. The "-w" argument is valid only under WinNT, Win2000 and, probably, WinXP. The "-w" argument has no effect if it is applied to a user program which is not a console application. The "-w" argument requires MET/CAL V6.11 or later.

    10. The "-u" argument may be useful when invoking a Windows system program (for example, Microsoft Word ("WinWord.exe"), or the Windows media player). If the User Program Folder specifies a directory, but the procedure writer wishes to invoke a program not in the specified directory which can be found by searching the workstation's PATH environment variable, the procedure writer may wish to use "-u" to disable the requirement that user programs be found in the specified User Program Folder. This allows the procedure writer to invoke a program not in the User Program Folder, but without having to specify the full path name of that user program.

    More information on the "-n" and "-a" arguments is provided in the Data File section below.

    More information on the "-x" and "-i" arguments is available in the Exit Code section below.

  4. The program specifier may include optional command-line arguments and/or I/O redirection where appropriate. These arguments are not the same as the DOS/DOSE arguments described above. Program arguments appear after the user program name, and are simply passed to the user program.

    Example:

    1.003 DOS USER1.EXE 1.9 15.4 TMP.DAT

    The user-provided program "USER1.EXE" will be executed with two command-line arguments (1.9 and 15.4). Output will be directed to the file "TMP.DAT".

  5. The following special constructions may be used to specify arguments to the user program.

    1. [MEM], [MEM1], and [MEM2]
    2. [M1], [M2], ...
    3. [L1], [L2], ...
    4. [S1], [S2], ...
    5. [SREG1], [SREG2], ...
    6. [Vvariable]
    7. {text}

    This capability is new as of V6.00.

    Refer to on-line help for the MATH FSC for a description of MET/CAL's numeric and string registers.

    The constructions [SREG1], [SREG2], ..., are identical to [S1], [S2], ..., and are included only for compatibility with the IEEE, IEEE2, and SCPI FSCs.

    The evaluation of special constructions in user program arguments can be disabled by unchecking Evaluate Special Constructions in DOS/DOSE Statements in the MET/CAL Configuration settings, if necessary. In the unlikely event that a user program has command line arguments including literal bracket or brace characters ('[', ']', '{', or '}'), it will be necessary to disable special construction parsing for DOS and DOSE procedure statements.

    Example:

      1.004  MATH         M[3] = 2.97 ; S[5] = "-x"
  1.005  DOS          USER1 [S5] [M3]

    The user-provided program "USER1.EXE" will be executed with two command-line arguments. The first argument will be "-x", which is the value of register S[5]. The second argument will be "2.97", which is the value of register M[3].

Data File

Parameters are passed between MET/CAL and the user-written program by way of an ASCII data file named "dosdose.dat". Before executing the program specified in the DOS or DOSE statement, MET/CAL writes the current values of the MET/CAL memory registers into this file.

A user-written program may alter the values in this file. When MET/CAL resumes, it reads back the data file, and starts up with the values present at that time in "dosdose.dat". The file is then removed.

Optional arguments allow the procedure writer to control which memory register values are written to the data file.

The "-n" argument causes all of the global numeric registers to be written, instead of just the first 20.

The "-a" argument causes all of the numeric and all of the string registers to be written.

If neither "-n" nor "-a" are specified, the data file is compatible with MET/CAL 4.0 and previous.

The following table shows the effect of the "-n" and "-a" arguments on the data file:

Argument | MEM | MEM1 | MEM2 | M Registers | S Registers
none | yes | yes | yes | 1 - 20 | none
-n | yes | yes | yes | 1 - 255 | none
-a | yes | yes | yes | 1 - 255 | 1 - 32

If neither "-n" nor "-a" are specified, the registers are written in the order MEM, MEM1, MEM2, M[1], M[2], ..., M[20]. Each memory register value is written on a separate line.

If the "-n" argument is specified, the registers are written in the order MEM, MEM1, MEM2, M[1], M[2], ..., M[255]. Each memory register value is written on a separate line.

Local numeric registers (the 'L' registers) are not written to the data file, regardless of the DOS/DOSE FSC arguments. (The L registers were implemented after the MET/CAL V7.00 release.) If the "-a" argument is specified, the registers are written in the order MEM, MEM1, MEM2, M[1], M[2], ..., M[255], S[1], S[2], ..., S[32]. Up to M[255], each memory register value is written on a separate line. The S registers are written out using two lines for each register. The first line is an integer which specifies the length of the following string, and the second line is the string. An empty string is written as a single LINEFEED character, with the length set to 0.

Example:

Consider the procedure fragment:

  1.006  MATH         s[1] = "abc"
  1.007  MATH         S[3] = "defgh"
  1.008  DOS          -a <program>

The beginning of the string register section of the DOS/DOSE data file will look like:

3
abc
0
5
defgh
.
.
.

The "3" indicates that the length of the following string ("abc") is 3. The 0 indicates that S[2] is empty, the 5 indicates that the length of the following string

("defgh") is 5, and so on.

When the DOSE FSC is used, the user-written program must append either 1 or 2 lines to "dosdose.dat". The first appended line is a result text string (not more than 64 characters). It is included in the Post Test Summary. The second appended line is optional. If present, it may be "PASS" to indicate a PASS condition, "FAIL" to indicate a FAIL condition, or a floating-point number to indicate the percent error for the test. This information determines the pass/fail status of the evaluation as displayed in the Post Test Summary and written to the results. If the second appended line is omitted, the evaluation is a default PASS.

Note that the DOSE mechanism described above (the requirement that the user program append 1 or 2 lines to the data file, and the fact that MET/CAL uses that information to generate a PASS/FAIL result) is the only difference between the DOS and DOSE FSCs.

Exit Code

The procedure writer may control whether MET/CAL uses the exit code of the user program to determine if the user program succeeded or failed.

  • The "-i" and "-x" arguments may be used on individual DOS or DOSE statements to specify how the exit code is to be handled for that statement only. If "-i" is specified, MET/CAL ignores the exit code of the user program. This is compatible with MET/CAL 4.0 through 4.2 and, in fact, was the only option for those versions of the software. If "-x" is specified, MET/CAL uses the user program's exit code to determine whether or not the user program succeeded. If the user program returns zero, the execution is successful. Any non-zero return value is regarded as a failure of the user program.

    "Success" and "failure", as used here, do not refer to the PASS/FAIL status of the test. To control the PASS/FAIL status of an evaluation step involving a user program, you must use the DOSE FSC and write the appropriate test status into the "dosdose.dat" data file. This is discussed in more detail elsewhere in this help document.

If a user program fails (returns a non-zero value) and MET/CAL is configured to pay attention to the exit code (as discussed above), the behavior of the system is as follows:

  1. An error message displaying the name of the user program and the non-zero exit code is displayed.

  2. After the operator chooses "OK" to remove the error message, the Post Test dialog appears with a message indicating that the DOS or DOSE statement was terminated by the preceding error. At this point the operator may repeat the test, terminate the procedure, or use any of the other Post Test options.

With some versions of BASIC it may be difficult (or impossible) to control the exit code of the user program. If this problem arises, the simplest solution is to ignore the exit code as described above.

If the exit code of the user program cannot be easily controlled, but there is a need to handle user program errors, this can be dealt with by ignoring the user program's exit code, and using an available memory register as an error indicator. That is, the user program can write a known value into a predetermined register in the "dosdose.dat" file. The procedure can then be written to jump to an error handling section if the register contains the pre-defined error indication value after return from execution of the user program.

Configuration Settings

On networked systems conflicts can arise related to accessing the DOS/DOSE data file ("dosdose.dat"). On some systems the DOS/DOSE data file is created in the directory where the MET/CAL executables reside. If this directory is on a shared file system, two or more workstations running the MET/CAL Runtime or Editor at the same time may cause the DOS/DOSE data file to be created and/or accessed in the same directory at the same time, yielding unpredictable and incorrect results. In some cases this problem is solved by specifying a "Start In" directory on the local workstation in the properties for the application (MET/CAL Runtime or MET/CAL Editor). This solution, however, has the undesirable side-effect of forcing the report files ("*.rpt") and the validation files ("*.val") to also be in the "Start In" directory. To address this problem, there are three optional MET/CAL Configuration settings:

User Current Working Folder
This parameter specifies the working directory for user programs. That is, it becomes the current directory for an executing user program. Unless otherwise specified, it also becomes the directory where MET/CAL looks for user programs (unless a full path or partial path specification is given in the procedure), and becomes the directory where the DOS/DOSE data file is created and accessed.
User Data Folder
This parameter specifies the location of the DOS/DOSE data file. If specified, it takes precedence over any "user_cwd" specification.
User Program Folder
This parameter specifies the directory where user programs reside. If specified, it takes precedence over any "user_cwd" specification.

A User Program Folder specification has no effect on a DOS or DOSE procedure statement which gives a full path specification for the user program.

For example,

DOS C:\metcal\myprog.exe

This DOS statement executes the "myprog.exe" in "C:\metcal" regardless of what User Program Folder specifies. If the DOS or DOSE statement provides a partial path specification, the partial path specification is relative to the User Program Folder specification (if any). For example, if the User Program Folder specifies "C:\metcal" and a DOS statement in a procedure specifies DOS exe\myprog.exe then MET/CAL executes the program

"C:\metcal\exe\myprog.exe".

Typical upgrade users running networked systems who experience the problem described above should edit the settings on each workstation and set:

User Current Working Folder | C:\metcal\station
User Data Folder | C:\metcal\station
User Program Folder | shared directory for user programs

Compatibility: These three settings require MET/CAL V5.1 or later.

Additional Information

The following additional information is provided for procedure writers familiar with the MS-DOS and/or Windows programming environments.

  • If the program given in the DOS or DOSE statement specifies a batch file, or includes input/output redirection symbols ('', '', or '|'), MET/CAL uses the standard MS-DOS command interpreter "COMMAND.COM" to execute the batch file or executable program.
  • If the program specifies an executable program (with extension ".EXE" or ".COM"), and no input/output redirection is specified, MET/CAL executes the program directly. The program executes either as an MS-DOS program or as a Windows program, depending on how the executable was built.
  • The file name extension of the user-written program to be executed must be ".EXE", ".COM", ".BAT", or ".PIF". The extension must be explicitly specified in the DOS or DOSE statement if it is ".COM", ".BAT", or ".PIF". The extension is optional if it is ".EXE".
  • The DOS or DOSE FSCs cannot be used to directly execute commands which are built into the MS-DOS command interpreter ("command.com"). For example, the statement "DOS dir" will not work. However, "command.com" may be invoked to execute built in commands. For example, "DOS command.com /c dir" will invoke the MS-DOS command interpreter to execute the built in "dir" command.
  • If a user-written program displays information on the PC screen, the program should pause until the operator has had time to read the display. Otherwise, when MET/CAL resumes execution, information displayed by the user program may be destroyed or overwritten. If the user program is an MS-DOS batch file, the necessary pause can be accomplished by using a "pause" statement in the batch file.

    • Example:

    Create a batch file called "xyz.bat" which contains:

    DIR /W

    PAUSE

    Execute the following line in a MET/CAL procedure:

    DOS XYZ.BAT

    When the DOS statement is executed, an MS-DOS window will be created. A directory listing will be shown in the window (the output of the "DIR /W" command). This will be followed by the prompt:

    Press any key to continue . . .

    in the MS-DOS window. When the operator presses a key, the MS-DOS window will be closed, and MET/CAL will resume execution with the statement after the DOS statement.

  • The procedure writer may wish to use the Windows "PIF" editor to create a ".PIF" file to control the invocation of a user-written DOS or DOSE program. This allows individual control over whether the user-written program runs full screen or in a window, the window title, and other parameters.

    • Example:

    Suppose you have an MS-DOS batch file named "XYZ.BAT" which you wish to run in a window, with the window title "Enter Parameters". Start the Windows "PIF" editor. Set "Program Filename" to "COMMAND.COM", set "Window Title" to "Enter Parameters", set "Optional Parameters" to "/c XYZ.BAT", and under "Display Usage" choose "Windowed".

    Choose "Save As..." in the "File" menu and save the file as "XYZ.PIF".

    Then, in your MET/CAL procedure, enter the statement:

    DOS XYZ.PIF

Compatibility

In general, memory limitations are less evident in Windows MET/CAL that in DOS MET/CAL. If the user's PC Windows environment is configured to use disk storage as virtual memory, then memory used by the MET/CAL program itself can become available to the user program invoked by the DOS FSC. (In Windows 3.1, virtual memory configuration is done under "Control Panel" : "386 Enhanced" : "Virtual Memory".)

To retain compatibility with DOS MET/CAL, only the first 20 auxiliary memory registers
(M[1], M[2],..., M[20]) are written to "dosdose.dat" before execution of a DOS FSC unless the DOS or DOSE statement specifies one of the optional arguments "-n" or "-a".

In Windows MET/CAL the file name extension of the user-program must be explicitly specified unless the extension is ".EXE". (In DOS MET/CAL ".BAT" and ".COM" files could be executed without specifying the file name extension.)


EVAL

Evaluation FSC

Description

The EVAL FSC allows evaluations based on prompting the operator or evaluating a numeric expression. An operator-based EVAL presents a message to the operator and waits for a YES or NO response. The operator's response determines the result of the test (PASS or FAIL), and causes the value of MEM1 to be set to 1 or -1. An expression-based EVAL evaluates a numeric expression and, depending on whether the result is zero or not, determines the result of the test (PASS or FAIL), and causes the value of MEM1 to be set to 1 or -1.

Format

Operator-based EVAL statements have the format:

EVAL [prompt]

or

EVAL -s string expression : [prompt]

Expression-based EVAL statements have the format:

EVAL -e numeric expression : [result text]

Rules

  1. At most 62 characters may appear after the FSC ("EVAL").

  2. Operator-Based EVAL Statements

    If the form of the statement is:

    EVAL -s string expression : [prompt]

    the string expression is evaluated as a string-valued MATH expression, and the resulting string replaces the default result string associated with the evaluation. The default result string is "Result of Operator Evaluation".

    Example 1:

    MEM2 ="Test #1"
EVAL -s mem2 : Did test #1 pass or fail?

    or

    MATH s[1] = "Test #1"
EVAL -s s[1] : Did test #1 pass or fail?

    Please remember that the rules for string expression are defined by the MATH FSC. Thus memory register MEM2 is referred to here as MEM2, not as [MEM2] (which is the syntax used in FSCs which support MET/CAL special constructions).

    Example 2:

    MATH MEM2 ="Ch2"
EVAL -s MEM2 & " Test #1" : Did [MEM2] test #1 pass?

    Example 3:

    EVAL -s mem2 & " " & s[1] : Did test #1 pass or fail?

    In this example, the contents of S[1] are concatenated to the contents of MEM2, with a separating space character, and the resulting string will appear in the results instead of "Result of Operator Evaluation".

    The -s is case-insensitive, so -S is also ok.

    In an operator-based EVAL statement, the prompt is optional. The procedure writer should use the MESS FSC to define alternate prompt text when the prompt field in the EVAL statement is empty.

  3. Expression-Based EVAL Statements

    Expression-based EVAL statements are suitable for use in closed-loop procedures.

    The numeric expression may be any valid MATH expression.

    Here are some examples of valid expressions:

    mem

    mem < 10

    m[1]

    (2 * (m[3] + mem1)) > 1

    Refer to the documentation on the MATH FSC for a full description of valid expression syntax.

    Although a string-valued expression may be used, EVAL evaluates all expressions as numeric, so a string-valued expression is coerced to a numeric value.

    Compound expressions are not allowed. (In the MATH FSC you can write, for example, "MATH MEM = 3 ; MEM1 = 5, where the semicolon separates the parts of a compound assignment. This syntax is not supported in the EVAL statement.)

    The -e is case-insensitive, so -E is also ok.

    In an expression-based EVAL statement, the colon (:) which separates the expression from the result text is required. If you leave out the colon, the statement will be interpreted as an operator-based EVAL statement.

    The expression may not be empty.

    result text is a text string to be associated with the evaluation in the formatted results. That is, where it says "Result of Operator Evaluation" for an operator-based EVAL statement, it will say result text for an expression-based EVAL statement.

    If result text is not specified, the associated result text will be "Result of Expression Evaluation".

    Note that when result text is not specified, it is still necessary to specify a colon (:) after the expression.

    Example:

    The following example retrieves error information from an instrument.The instrument's response consists of an error number, followed by an error message, with a comma between the error number and the error message.

    The evaluation is a "pass" if the error number is a zero (no error). Otherwise the evaluation is a "fail".

    IEEE         SYST:ERR?[I$]
MATH         L[1] = FLD(MEM2, 1, ",")
MATH         S[1] = FLD(MEM2, 2, ",")
EVAL   -e L[1] == 0 : [S1]

    One important point illustrated in the example is that the math expression (between the -e and the :) is like a MATH FSC procedure statement. It must follow the syntax rules of the MATH FSC. Specifically, the square brackets used with 'M', 'L', and 'S' register references are an array subscripting operator. This use of square brackets is different from the traditional MET/CAL "special construction" usage. In a special construction the square brackets are used to delineate the construction, to distinguish it from the surrounding literal text (if any). Thus, in the example above, the [S1] (to the right of the :) is a special construction, whereas the L[1] in the math expression is an array reference.

  4. The following special constructions may be used in an EVAL statement:

    1. [N]
    2. [MEM], [MEM1], and [MEM2]
    3. [numeric]
    4. [Dnumeric]
    5. [DRAWx,y,view] (operator-based EVAL only)
    6. [Vvariable]
    7. {text}
    8. [M1], [M2], ...
    9. [L1], [L2], ...
    10. [S1], [S2], ...
    11. [SREG1], [SREG2], ...
    12. [Xhex list]

    The [N] special construction is specific to the EVAL FSC, and is described in detail in the rules below. For additional information, see the Special Constructions topic.

    The [DRAWx,y,view] is not allowed in an expression-based EVAL statement.

    In an expression-based EVAL statement all special constructions (if any are used) must occur in the result text part of the statement.

    The constructions [M1], [M2], ..., access the global numeric registers. The constructions [L1], [L2], ..., access the local numeric registers. Up to 12 significant digits are included in the numeric register value.

    Refer to the MATH FSC topic for additional information on the numeric registers.

    The constructions [S1], [S2], ..., access the string registers. Refer to the MATH FSC topic for additional information on the string registers.

    The constructions [SREG1], [SREG2], ..., are identical to [S1], [S2], ..., and are included only for compatibility with the IEEE FSC.

    When using the DELAY special construction, the EVAL prompt is displayed after the DELAY time has elapsed. Placement of the DELAY special construction does not matter.

    The EVAL statement limit of 240 characters applies to the original EVAL statement. When using MET/CAL versions prior to 8.2, the limit also applies to the evaluated text which results from replacing special constructions with the corresponding register values.

  5. In an operator-based EVAL, if the EVAL message does not contain an [N] special construction the operator's response is interpreted as follows:

    If the operator chooses YES:

    • The test result is PASS.
    • The value of MEM1 is set to 1.

    If the operator chooses NO:

    • The test result is FAIL.
    • The value of MEM1 is set to -1.

  6. In an operator-based EVAL, the [N] special construction may be used to negate the interpretation of the operator's answer as follows:

    If the operator chooses YES:

    • The test result is FAIL.
    • The value of MEM1 is set to -1.

    If the operator chooses NO:

    • The test result is PASS.
    • The value of MEM1 is set to 1.

    Example:

    The following example shows a case where the question to the operator is formulated as a negative, and the [N] construction is used to invert the normal interpretation of the response to achieve the desired test result.

      1.011  HEAD         {DISPLAY PIXELS}
  1.012  MESS         Press and hold the ON button. The
  1.012  MESS         UUT displays a uniform pixel
  1.012  MESS         pattern.  Visually check the pixel
  1.012  MESS         pattern for missing pixels. When
  1.012  MESS         done, release the ON button and the
  1.012  MESS         UUT will start normal operation.
  1.012  MESS
  1.013  EVAL   Are there any missing pixels? [N]

    If the operator answer YES to the question "Are there any missing pixels?", the test result is FAIL and MEM1 is set to -1. If the operator answers NO, the result is PASS and MEM1 is set to 1.

  7. In an expression-based EVAL, if the EVAL result text does not contain an [N] special construction the numeric result is interpreted as follows:

    If the result is not zero:

    • The test result is PASS
    • The value of MEM1 is set to 1.

    If the result is zero:

    • The test result is FAIL.
    • The value of MEM1 is set to -1.

    Example:

    The following example bases the evaluation result on the value in global numeric register M[5]. If the value of M[5] is non-zero, the result is PASS. If the value of M[5] is zero, the result is FAIL.

    1.001 EVAL -e M[5] : Evaluation based on M[5].

  8. In an expression-based EVAL, the [N] special construction may be used to negate the interpretation of the numeric result as follows:

    If the result is not zero:

    • The test result is FAIL.
    • The value of MEM1 is set to -1.

    If the result is zero:

    • The test result is PASS.
    • The value of MEM1 is set to 1.

  9. The EVAL FSC cannot occur in an adjustment block. (Evaluation statements are not allowed in adjustment blocks.)


MEME

Memory Register Operation FSC

Description

The primary use of the MEME FSC is to exchange memory registers MEM and MEM1.

Format

MEME

MEME numeric

MEME < index

MEME > index

Examples

Prior to MET/CAL version 6.1 MEME was typically used in conjunction with MEMC. In a closed-loop test in which the UUT was a meter, it was necessary to swap MEM and MEM1 in order to place the System Actual and UUT Indicated values in the proper registers prior to the execution of the MEMC statement. In versions 6.1 and later the MEME and MEMC statements should be replaced with an equivalent MEMCX statement. The example below shows how to do this. It is essential that this replacement be done if:

  1. Measurement uncertainty is calculated, and
  2. A TARGET or TARGET -m statement is used to cause the setup of the calibration standard to be skipped in the automatic measurement uncertainty loop. If both of the above conditions are true and MEMCX is not used in place of MEME & MEMC the measurement uncertainty calculation will generate incorrect results.

Prior to V6.1 it was necessary to write tests like:

  3.001  TARGET       -m
  3.002  5700         100.000mV                          S  2W
  3.003  IEEE         ?[I]
  3.004  MATH         MEM = MEM / 1e-3
  3.005  MEME
  3.006  MEMC   200   mV             0.011U

Note that when MEMC is used, as in the above example, the 5700 statement must be repeated with each iteration of the test to re-establish the value of MEM1 (System Actual).

For V6.1 and later, the above test can be re-written to use MEMCX as follows:

  3.001  5700         100.000mV                          S  2W
  3.002  TARGET       -m
  3.003  IEEE         ?[I]
  3.004  MATH         MEM = MEM / 1e-3
  3.005  MEMCX  200   100.000mV      0.011U

Note that when MEMCX is used, as in the above example, it is no longer necessary to re-establish the value of MEM1 (System Actual) in each iteration of the measurement uncertainty loop. This allows the "TARGET -m" statement to be placed after the 5700 statement (3.001).

Non-Preferred Functionality

The MEME FSC may also be used to perform the following functions.However, the equivalent functions can be performed in a more readable way using the MATH FSC.

  • Load a constant value into memory register MEM.
  • Copy MEM into one of the M[index] memory registers.
  • Copy an M[index] memory register into MEM.
Format | Action
MEME numeric | Assigns specified value to MEM.
MEME < | Copies register M[index] into MEM.
MEME >index | Copies MEM into register M[index].
MEME FSC | MATH FSC equivalent
MEME numeric | MATH MEM = numeric
MEME <index | MATH MEM = M[index]
MEME >index | MATH M[index] = MEM

See Also

  • Memory Registers
  • Special Constructions


MEMC and MEMCX

Evaluation FSCs

Description

The MEMC and MEMCX FSCs perform evaluations based on a comparison between the UUT Indicated value and the System Actual value.

For MEMC:

If the statement specifies a Nominal value, that value is used as the UUT Indicated value. If no value is specified in the NOMINAL field, the value of memory register MEM1 is used as the UUT Indicated value.

The value of memory register MEM is used as the System Actual value.

For MEMCX:

If the statement specifies a Nominal value, that value is used as the System Actual value. If no value is specified in the NOMINAL field, the value of memory register MEM1 is used as the System Actual value.

The value of memory register MEM is used as the UUT Indicated value.

Execution of a MEMC or MEMCX statement does not change the values of MEM or MEM1.

MEMCX is new with MET/CAL V6.1. With MEMCX it is no longer necessary to precede the evaluation with a MEME statement to swap the MEM and MEM1 registers. Depending on the type of test, it is always sufficient to use either a MEMC or MEMCX evaluation, without a preceding MEME statement. See the "Historical Note" in the EXAMPLE section (below) for more information.

Format

MEMC rangenominaltolerance mod1

MEMCX rangenominaltolerance mod1

Rules

RANGE

This field specifies the UUT range as described in the RANGE Field topic.

NOMINAL Field

The NOMINAL field is limited to 14 characters.

The format of the NOMINAL field is:

[value][string]

value is an NR1, NR2, or NR3-format number.

NR1-format is integer format (like "12").
NR2-format is fixed point format (like "15.3").
NR3-format is scientific notation (like "2.36E+3").

In a MEMC statement, the value specifies the UUT Indicated value which will be compared to the value stored in MEM. If value is not specified, the value of MEM1 is used.

In a MEMCX statement, the value specifies the System Actual value which will be compared to the value stored in MEM. If value is not specified, the value of MEM1 is used. Both value and string are optional. However, at least one of value and string must be specified.

Although the MEMC and MEMCX FSCs are similar in appearance to instrument evaluation statements, they use the registers MEM and MEM1 differently. In an instrument FSC, if no numerical quantity is specified in the NOMINAL field, the value is taken from MEM.

In the MEMC and MEMCX FSCs, the value is taken from MEM1. string cannot include blanks, and cannot end with 'R', 'r', '/', '%', 'U', or 'u'. The restriction on strings ending in 'R' or 'r' is a historical aspect of the MEMC/MEMCX parsing algorithm. All such strings are taken to be RANGE field values. To avoid the restriction place in the string value in single quotes. For example:

MEMC 1.00'bar' 1%

Similarly, the restriction on strings ending in 'U' or 'u' may be overcome using single quotes:

MEMC 1.00'U' 1%

For purposes of the measurement uncertainty calculation, the test uncertainty ratio calculation, and the generation and formatting of the V7 Results table result quantities, the string portion of the NOMINAL field is interpreted as a units prefix and a units string. Single quotes may be used to override the interpretation of the units prefix:

MEMC 1.00'micron' 1%

The string does not affect the numerical value used for the comparison. For example, "10mV" causes the value 10 to be used for the comparison.

In a MEMC statement, the procedure writer should ensure that the original UUT reading is in the same units as specified in the NOMINAL field of the MEMC FSC.

Similarly, in a MEMCX statement, the procedure writer should ensure that the original System Actual value is in the same units as specified in the NOMINAL field of the MEMCX FSC.

If the MEMC or MEMCX NOMINAL field specifies a value, or ASK- U is specified for the test, the specified string is appended to the UUT Indicated and System Actual values in the results generated for the test. In other cases, the units written to the results for the test are based on the previous instrument setup or ACC statement.

Very often the string consists of a prefix followed by units. However, that is not a requirement of the MEMC and MEMCX FSCs.

TOLERANCE

This field specifies the UUT tolerance as described in the TOLERANCE Field topic.

MOD1 Field

The MOD1 field is transferred directly to the results. Anything may be included in this field. Typically the frequency parameter of the test is entered here.

The length of the field cannot exceed 14 characters. The field must not end with R, /, %, or U, and "TOL" is not allowed.

Example

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
  1.001  5700         19V                                               S  2W
  1.002  IEEE         ?[I]
  1.003  MEMCX  20    19V            1% 1/

Explanation

The 5700 statement sets up the stimulus for the desired Nominal value. This value, 19, is stored in MEM1 when the 5700 statement executes.

The IEEE statement takes a reading from an IEEE-488 controlled UUT. The numeric result of the reading is stored in MEM. It is presumed in this example that the UUT reading is reported in volts.

The MEMCX FSC compares the System Actual value specified in the MEMCX NOMINAL field (which is the same as the value of the 5700 stimulus specified in the 5700 setup) with the value in MEM (which is the UUT Indicated value).

Historical Note

Prior to MET/CAL V6.1 the test in the above example would have been coded as follows:

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
  1.001  5700         19V                                               S  2W
  1.002  IEEE         ?[I]
  1.003  MEME
  1.004  MEMC   20    V              1% 1/

The reason for the difference is that the MEMCX statement did not exist in V6.01 and earlier. One problem with the old way is that it required the presence of a MEME statement before the MEMC statement. By interchanging the values of MEM and MEM1, the MEME stored the values to be compared in the appropriate places before the MEMC statement was evaluated. Specifically, since the 5700 setup statement stores the System Actual value in MEM1, this value must be moved into MEM, which is where MEMC looks for the System Actual. And since the [I] construct in the IEEE statement stores the UUT Indicated value in MEM, this value must be moved into MEM1, which is where MEMC looks for the UUT Indicated value. The old method generally works, but is potentially incompatible with the measurement uncertainty calculation. The fundamental issue is that using MEME to swap the MEM and MEM1 registers also makes it absolutely necessary to repeat the 5700 setup each time through the measurement uncertainty loop. (When the number of measurements for the measurement uncertainty calculation is greater than 1 MET/CAL automatically repeats the steps of each test the specified number of times.)

Thus, if the procedure writer were to re-code the old-style test as:

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
  1.001  5700         19V                                               S  2W
  1.002  TARGET       -m
  1.003  IEEE         ?[I]
  1.004  MEME
  1.005  MEMC   20    V              1% 1/

the test would now be incompatible with the measurement uncertainty calculation. The "optimization" of not repeating the 5700 setup each time through the uncertainty loop prevents the MET/CAL 5700 driver from re-establishing the System Actual value in MEM1, which leads to invalid values in MEM and MEM1 after the MEME. This in turn causes the calculated measurement uncertainty to be incorrect.

This potential problem with the measurement uncertainty calculation in MEMC-based tests provided the primary impetus for the creation of the MEMCX FSC. Since, for a test like the above example, it's no longer necessary to swap MEM and MEM1 before the MEMCX, the procedure writer is now free to skip the 5700 setup on the second and subsequent measurements:

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
  1.001  5700         19V                                               S  2W
  1.002  TARGET       -m
  1.003  IEEE         ?[I]
  1.004  MEMCX  20    19V            1% 1/


PICE

eeeiEvaluation FSC

Description

The PICE FSC displays a picture during procedure execution. The PICE FSC is similar to the PIC FSC. The difference is that PICE is an evaluation FSC. When a PICE statement is executed, the operator is presented with the choices: YES, NO, and TERMINATE. The operator may choose YES to indicate PASS, NO to indicate FAIL, or TERMINATE to abort the PICE statement.

Pictures, which may include text, are used to provide instructions to the operator. Pictures are used instead of text-only instructions to the operator in cases where a detailed description of a required connection, or adjustment, is difficult to present in text-only form. MET/CAL supports the following picture file formats:

.bmp | Bitmap
.jpg | JPEG (Joint Photographic Experts Group)
.gif | GIF (Graphics Interchange Format)
.ico | Icon
.tif | TIFF (Tagged Image File Format)
.png | PNG (Portable Network Graphics)

Picture editing software such as Microsoft Paint or Paint.NET may be used to create, edit, and convert picture files. If your unsure which format to use, PNG may be a good choice.

Format

PICE [expr] [picture file] [position/color] [text]

Square brackets indicate optional subfields; see the Rules section below.

Rules

  1. Text can be superimposed on the picture. Superimposed text can be located anywhere on the screen, with a number of foreground and background colors.
  2. A PICE statement consists of one or more PICE lines. The first PICE line must contain the name of the picture file. Subsequent lines, if any, are used to specify text to be overlaid on the picture and/or a MATH FSC-compatible string expression.
  3. Each PICE line may specify at most 1 text string to be overlaid on the displayed picture.
  4. The picture file, position/color, and text subfields may be entered in any order. The expr subfield, if present, must be the first subfield on the line.

Rules for the expr subfield

The expr subfield is an optional field that specifies a MATH FSC-compatible string expression. The result of evaluating the string expression is used to replace the default string "Result of Operator Evaluation" that appears in the Remark field of the Results Table, and also is shown in the Test Results window.

The syntax for the expr subfield is: -s expression:

The : is a separator that MET/CAL uses to distinguish the expression from following information on the PICE line. The : need not be specified if there no information following the string expression.

Example #1:

  1.001  MATH         msg = "Maximum Brightness"
  1.002  PICE         -s msg : f1.jpg

In this example the string expression msg and the picture file name f1.jpg occur on the same line. A : is therefore required to separate the two subfields.

Example #2:

  2.001  MATH         msg = "Maximum Brightness"
  2.002  PICE         f1.jpg
  2.002  PICE         -s msg

This example is equivalent to the first example, but since the string expression and the picture file name are specified on different lines of the same PICE statement, no : is required after the string expression. A single PICE statement may not specify more than one expr subfield. The expr subfield requires MET/CAL V7.20 SP2 or later.

Rules for the picture file subfield

This subfield is a single word which specifies the file name of the picture file to be displayed. The length including the step number and file name cannot exceed 256 characters. The name may not contain parentheses, double quotes, or blanks. The file name must be specified if the line is the first line of the PICE statement, and may not be specified if the line is not the first line of the PICE statement. All picture files must reside in the directory specified by the Picture Folder MET/CAL Configuration setting.

For example, if the Picture Folder is C:\metcal\pic, all picture files should be placed in C:\metcal\pic. The picture file name may or may not include the file extension. If the extension is specified, a file with the specified name and extension must exist in the Picture Folder. If the extension is not specified, MET/CAL searches for a file with one of the supported extensions. The search order is:

  1. .bmp
  2. .jpg
  3. .gif
  4. .ico
  5. .tif
  6. .png

Alternatively, the path of the picture file can be included with the file name. In this case, the path is hard coded in the procedure. If the file is not in this fixed location the picture will not display and an error will be generated.

Creating procedure projects that use pictures requires that the picture files be added to the project. Like all procedure project files, the picture files can reside in any location on the file system. It is recommended that all pictures files reside in the Picture Folder or in a project specific folder. When the procedure project is compiled into a PXE, all images are compiled into a single file along with the procedure source code. This allows the PXE to execute and display pictures on any supported MET/CAL station without any special setup.

A picture file name may contain certain embedded special constructions. By placing the file name in a string register the procedure writer may overcome the line length limitation, as well as the restriction against embedded spaces. The following example will work as long as the MET/CAL picture directory contains a file named Fluke 5700A Front Panel.jpg. However, note that using special constructions in picture file names prevents the normal pre-run check which verifies that pictures required by the procedure about to be executed are present in the MET/CAL picture directory.

  3.001  MATH         S[1] = "Fluke 5700A Front Panel"
  3.002  PIC          [S1].jpg

The following constructions are legal in picture file names:

  1. [L1], [L2], ...
  2. [M1], [M2], ...
  3. [MEM], [MEM1], and [MEM2]
  4. [S1], [S2], ...
  5. [SREG1], [SREG2], ...
  6. [Vvariable]

Rules for the position/color subfields

This subfield specifies the row and column at which to position the first character of the text string, as well as the foreground and background colors in which to display the text string.

The subfield has the format:

([row],[col],[color])

The enclosing parentheses must be included in the subfield. row specifies the row on which to display the text string. It is an integer between 0 and 23, or a '+' sign.

col specifies the column at which to start the text string. It is an integer between 0 and 79, or a '+' sign.The row and column positions are scaled to fit the size of the displayed picture. Even if the picture is very small, it is still considered to consist of 24 rows X 80 columns for purposes of positioning text overlays. However, since the font used to display the text is not scaled with the picture, care must be taken to ensure that adjacent rows of text do not overlap.

color has the format fg/bg where:

  • fg has the format: [L]|[l] color base
  • bg has the format: [L]|[l] color base

color base is one of the following:

  • B - blue
  • BL - black
  • BR - brown
  • C - cyan
  • G - green
  • M - magenta
  • R - red
  • W - white

These codes indicate a high intensity color. To specify a low intensity, precede the color code with 'L' or 'l'. The entire subfield may be omitted, but, if it is not, the parentheses and all commas are required.

The default: row = 0, col = 0, color is BL/W. The default is used when a specification is not included on the first line of a multiline PICE statement. On a line other than the first line, a missing specification causes the current value for that statement to be used.

If row is '+', the current row for the PICE statement is incremented by 1. If the current row is already 23, row is set to 0. If column is '+', the current column for the PICE statement is set to the column following the end of the previously displayed text string. If this is 79, the current column is set to 0.

Rules for the Text subfield

The format is "text"

Note that the double quotes must be included in the PIC statement. The length of the text string cannot exceed 54 (not counting the double quotes). In many cases however, the length is further limited by the fact that the PICE FSC is a display control-type FSC and the length of the body of a PICE line is limited to 56 characters.

The text string may contain double quote '"' characters. The last double quote on the line terminates the text string.

Example:

PICE (5,5,B/G) "Select "Volts""

The text that will appear on the picture is: Select "Volts".

The font used for text overlays is configurable. Choose "Picture Font" in the top-level "Configure" menu of the MET/CAL Editor or MET/CAL Runtime applications.

Inter-field Dependencies

It is illegal to specify a text string that, when displayed at the specified position, goes beyond column 79. In some cases this error is not detected until run time.

Execution of a PICE Statement

Execution of a multi-line PICE statement occurs when the MET/CAL Runtime system reaches the last line of the statement. Execution proceeds as follows:

  1. MET/CAL determines the full path name of the picture file. The Picture Folder path is prepended to the filename specified in the PICE statement. If the PICE statement name does not include an extension, the picture directory is searched to find a matching name with one of the supported extensions. If the search is successful, the extension is appended to the name.

  2. All specified text strings are displayed. Execution of an empty PICE line has no effect.

  3. "Yes", "No", and "Terminate" buttons are shown in the window in which the picture is displayed.

    If the operator chooses "Yes":

    • the test is a PASS
    • MEM1 is set to 1

    If the operator chooses "No":

    • the test is a FAIL
    • MEM1 is set to -1

    If the operator chooses "Terminate":

    • the PICE statement is aborted
    • the Post Test dialog appears

Unlike the EVAL FSC, PICE does not support the [N] special construction. With PICE there is no way to invert the sense of the YES/NO question. YES always indicates PASS and NO always indicates FAIL.

Note that since PICE sets MEM1 to +1 or -1, a subsequent JMPT or JMPF statement may be used to jump to a desired procedure location based on whether the test was a PASS or a FAIL.

  • If the picture file is not found, or is corrupted, an error occurs and the user is presented with the Post Test dialog. If a picture file is not present, the procedure will not start.
  • The picture may be resized as desired by the operator.

Compatibility

While overlaid text remains supported, MET/CAL versions 4.0 and later do not support DOS MET/CAL's interactive entry of text data when overlaid on a displayed picture. Procedure writers are advised to include text as an integral part of the picture itself. In other words, when a picture is created (using, for example, Windows Paint) any needed text should be created as part of the picture, not subsequently overlaid on the picture by adding text to the PICE statement in a MET/CAL procedure. This approach allows flexible text positioning, color selection, and font selection.

For compatibility with previous versions of MET/CAL, overlaid text is supported when it is entered directly in a PICE statement. However, it may be difficult to determine the proper row and column position for the text overlay.

The relative position of overlaid text in a picture remains the same when the picture is scaled down or up.

If an existing picture is reduced in size, space available for each row of overlaid text is correspondingly reduced. This can result in a situation in which a displayed text row is partially overwritten by the next row.

Examples

Picture Evaluation

3.003 PICE OnePict

Picture Evaluation with Custom Result Text

4.001 PICE -s "My Custom Result Text" : OnePict

Picture Evaluation with Overlaid Text

  5.001  PICE         psm-45 (1,47,LR/G) "Adjust R227 for a"
  5.001  PICE         (+,47,LR/G) "UUT reading of 190.0 mV."

  6.001  PICE         psm-45 (3,6,LR/LG) "Adjust R206 for a"
  6.001  PICE         (+,6,LR/LG) "UUT reading of 0.00 mV."

Picture Evaluation with Overlaid Text and Custom Result Text

  7.001  MATH         msg = "R227 Adjustment"
  7.002  PICE         -s msg : psm-45 (1,47,LR/G) "Adjust R227 for a"
  7.002  PICE         (+,47,LR/G) "UUT reading of 190.0 mV."


ML2437 and ML2438

Interface Control FSCs

Description

The ML2437 and ML2438 FSCs control the Anritsu ML2437A and ML2438A Power Meters. The ML2437 FSC may also be used to control ML2438A channel A. This capability allows a ML2437 based procedure to be executed without modification when a ML2438A is configured.

Power Sensors

The following power sensors are supported by the ML2437 and ML2438 FSCs:

    100 kHz 10 MHz 300 MHz   6 GHz   18 GHz  32 GHz  40 GHz 50 GHz 67 GHz
       |      |       |       |        |       |       |      |      |
                      < MA2411 ========================>
       <=============== MA2421 ========>
              <======== MA2422 ========>
              <======== MA2423 ================>
              <======== MA2424 ========================>
              <======== MA2425 ===============================>
              <======== MA2442 ========>
              <======== MA2444 ========================>
              <======== MA2445 ===============================>
              <======== MA2468>
              <======== MA2469 ========>
              <======== MA2472 ========>
              <======== MA2473 ================>
              <======== MA2474 ========================>
              <======== MA2475 ===============================>
              <======== MA2481>
              <======== MA2482 ========>
              <======== SC6230 ======================================>
              <======== SC7430 ======================================>
              <======== SC7570 ======================================>

Parameters

An NVI FSC statement consists of one or more parameters. A parameter consists of a name and a value. Each parameter must be separated by a semicolon and/or one or more spaces. A single NVI FSC statement can encompass more than one physical line as long as the line numbers are the same. However each parameter name and its value must occur on one line. A single line can accommodate up to 256 characters including the statement number and FSC. Note that characters above ASCII 128 count as 2 characters.

Syntax:

parameter[separatorparameter]

parameter::= [parameter_prefix]parameter_name[[sp]=[sp]parameter_value]

separator::= ;[sp] | sp

parameter_prefix ::=+ | @

sp::= one or more spaces

parameter_name::= see the Parameter Names section

parameter_value::=dimensionless number | dimensioned number | discrete_list

dimensionless number::=NRf

dimensioned number::=NRf[sp][prefix]units

discrete_list::=see the Parameter Names section

prefix::=y | z | a | f | p | n | u | m | k | M | G | T | P | E | Z | Y

Definitions:

|
Denotes "or" (i.e. A | B is A or B)
[ ]
Denotes an optional syntax element, except in examples. In examples [ ] enclose a special construction.
+
Designates the parameter as the Evaluation Quantity
@
Designates the parameter as the Modifier Quantity

Rules:

  1. One and only one parameter must be designated as the Evaluation Quantity in a ML2437/ML2438 Measure (default), Setup, or Read action.

  2. When a ML2437/ML2438 Measure (default) statement is executed, the ML2437A/ML2438A measurement is copied to memory register MEM in units of the Evaluation Quantity.

    Example:

    ML2437 +Power = 100 mW; Freq = 100 MHz

    or

    ML2437 +Power = 100 mW; Freq = 100 MHz; Measure

    If the ML2437A power measurement was 99.98 mW, MEM would be 99.98.

  3. When a ML2437/ML2438 Read statement is executed, the ML2437A/ML2438A measurement is copied to memory register MEM in units of the Evaluation Quantity designated in the previous Setup or Measure statement.

    Example:

    ML2437 +Power = 100 mW; Freq = 100 MHz; Setup

    ML2437 +Power = 100 mW; Freq = 100 MHz; Read

  4. At most one parameter may be designated as the Modifier Quantity in ML2437/ML2438 Measure or Setup.

  5. When a ML2437/ML2438 Measure is executed, the Modifier Quantity is concatenated to the Evaluation Quantity in the automatic message to setup the UUT. Note, the automatic message to setup the UUT is ot displayed when ASK- N is in effect.

    Examples:

    ASK+ N
ML2437 +Power = -10 dBm; @Freq = 100 MHz

    "Set UUT to source -10 dBm at 100 MHz."

    No Modifier Quantity designated.

    ML2437 +Power = -10 dBm; Freq = 100 MHz

    "Set UUT to source -10 dBm."

    Automatic UUT setup message inhibited.

    ASK- N
ML2437 +Power = -10 dBm; Freq = 100 MHz

    No automatic UUT setup generated.

  6. Parameter values may be taken from a MET/CAL memory register using special construction.

Parameter Names

Parameter names consist of single words or compound words. Each word in a parameter name can be entered in long form (as shown below), or in short form. The short form is the first 4 characters of the long form, with the following exceptions:

  1. If the long form is greater than four characters, and the last character or the short form is a vowel, the short form is three characters.
  2. If the long form is four characters or less, the short form is the long form even if it ends in a vowel.

Compound parameter names can be entered in any combination of long and short forms. Example, ExternalReferenceFrequency can be entered using any of the following forms:

  • PowerRatio
  • PowRatio
  • PowerRat
  • PowRat

Action Parameters

Action parameters specify the operation to be performed.

  • Calibrate
  • Connect
  • Local
  • Measure
  • Read
  • Reset
  • Setup
  • Zero

Rules:

  1. Only one action parameter is allowed per ML2437/ML2438 statement (single or mult-line).
  2. If an action is not specified, the default is Measure.

Primary Parameters

Primary parameters specify the measurement.

ML2437A

  • Power[A]

ML2438A

  • PowerA
  • PowerB
  • PowerDifferenceAB
  • PowerDifferenceBA
  • PowerRatioAB
  • PowerRatioBA

Rules:

  1. The primary parameter must be designated as the evaluation quantity.

Secondary Parameters

Secondary parameters are used for one or both of the following:

  1. Clarify the action.
  2. Configure the measurement specified by the primary parameter.

ML2437A

  • AverageCount[A]
  • AveragingMode[A]
  • CalibrationFactor[A]
  • CalibrationFactorSource[A]
  • CalibrationValueStartFrequency[A]
  • CalibrationValueStartVoltage[A]
  • CalibrationValueStopFrequency[A]
  • CalibrationValueStopVoltage[A]
  • DutyCycle[A]
  • LowLevelAveraging[A]
  • PowerSensor[A]
  • Settled[A]

ML2438A

  • AverageCountA
  • AverageCountB
  • AveragingModeA
  • AveragingModeB
  • CalibrationFactorA
  • CalibrationFactorB
  • CalibrationFactorSourceA
  • CalibrationFactorSourceB
  • CalibrationValueStartFrequencyA
  • CalibrationValueStartFrequencyB
  • CalibrationValueStartVoltageA
  • CalibrationValueStartVoltageB
  • CalibrationValueStopFrequencyA
  • CalibrationValueStopFrequencyB
  • CalibrationValueStopVoltageA
  • CalibrationValueStopVoltageB
  • DutyCycleA
  • DutyCycleB
  • LowLevelAveragingA
  • LowLevelAveragingB
  • PowerSensorA
  • PowerSensorB
  • SettledA
  • SettledB

Operating Mode

The action determines the operating mode.

Action Parameter | Operating Mode
Calibrate | Calibrate Power Meter
Connect | Determine automatic connection message
Measure (default) | Power Measurement
Read | Power Measurement
Reset | Reset Power Meter
Setup | Power Measurement
Zero | Zero Power Meter

Inter-Parameter Rules

If a parameter is not listed for a operating mode, it is not allowed.

Power Measurement Channel A

ML2437 FSC

Required Parameters

  • +Power[A]
  • PowerSensor[A]
  • Frequency[A]
Optional Parameters | Default
AverageCount[A] | 64
AveragingMode[A] | Off
CalibrationFactor | na
CalibrationFactorSource[A] | Frequency
DutyCycle[A] | tbd
LowLevelAveraging[A] | Off
Settled[A] | tbd

ML2438 FSC

Required Parameters

  • +PowerA
  • PowerSensorA
  • FrequencyA
Optional Parameters | Default
AverageCountA | 64
AveragingModeA | Off
CalibrationFactor | na
CalibrationFactorSourceA | Frequency
DutyCycleA | tbd
LowLevelAveragingA | Off
SettledA | tbd

Power Measurement Channel B

Required Parameters

  • +PowerB
  • PowerSensorB
  • FrequencyB
Optional Parameters | Default
AverageCountB | na
AveragingModeB | Off
CalibrationFactorB | na
CalibrationFactorSourceB | Frequency
DutyCycleB | tbd
LowLevelAveragingB | Off
SettledB | tbd

Power Difference (A-B) Measurement

Required Parameters

  • +PowerDifferenceAB
  • FrequencyA
  • FrequencyB
  • PowerA
  • PowerB
  • PowerSensorA
  • PowerSensorB
Optional Parameters | Default
AverageCountA | na
AverageCountB | na
AveragingModeA | Off
AveragingModeB | Off
CalibrationFactorA | na
CalibrationFactorB | na
CalibrationFactorSourceA | Frequency
CalibrationFactorSourceB | Frequency
DutyCycleA | tbd
DutyCycleB | tbd
LowLevelAveragingA | Off
LowLevelAveragingB | Off
SettledA | tbd
SettledB | tbd

Power Difference (B-A) Measurement

Required Parameters

  • +PowerDifferenceBA
  • FrequencyA
  • FrequencyB
  • PowerA
  • PowerB
  • PowerSensorA
  • PowerSensorB
Optional Parameters | Default
AverageCountA | na
AverageCountB | na
AveragingModeA | Off
AveragingModeB | Off
CalibrationFactorA | na
CalibrationFactorB | na
CalibrationFactorSourceA | Frequency
CalibrationFactorSourceB | Frequency
DutyCycleA | tbd
DutyCycleB | tbd
LowLevelAveragingA | Off
LowLevelAveragingB | Off
SettledA | tbd
SettledB | tbd

Power Ratio (A/B) Measurement

Required Parameters

  • +PowerRatioAB
  • FrequencyA
  • FrequencyB
  • PowerA
  • PowerB
  • PowerSensorA
  • PowerSensorB
Optional Parameters | Default
AverageCountA | na
AverageCountB | na
AveragingModeA | Off
AveragingModeB | Off
CalibrationFactorA | na
CalibrationFactorB | na
CalibrationFactorSourceA | Frequency
CalibrationFactorSourceB | Frequency
DutyCycleA | tbd
DutyCycleB | tbd
LowLevelAveragingA | Off
LowLevelAveragingB | Off
SettledA | tbd
SettledB | tbd

Power Ratio (B/A) Measurement

Required Parameters

  • +PowerRatioBA
  • FrequencyA
  • FrequencyB
  • PowerA
  • PowerB
  • PowerSensorA
  • PowerSensorB
Optional Parameters | Default
AverageCountA | na
AverageCountB | na
AveragingModeA | Off
AveragingModeB | Off
CalibrationFactorA | na
CalibrationFactorB | na
CalibrationFactorSourceA | Frequency
CalibrationFactorSourceB | Frequency
DutyCycleA | tbd
DutyCycleB | tbd
LowLevelAveragingA | Off
LowLevelAveragingB | Off
SettledA | tbd
SettledB | tbd

Calibrate, Zero

Required Parameters

  • PowerSensor[A] (ML2437 FSC)
  • PowerSensorA (ML2438 FSC)
  • PowerSensorB (ML2438 FSC)

Connect

Required Parameters

  • PowerSensor[A] (ML2437 FSC)
  • PowerSensorA (ML2438 FSC)
  • PowerSensorB (ML2438 FSC)

Parameter Definitions and Values

AverageCount

This parameter sets the average count.

Syntax:

ML2437 FSC: AverageCount[channel][sp]=[sp]nr1

ML2438 FSC: AverageCountchannel[sp]=[sp]nr1

channel ::= A | B

Rules:

  1. Legal values are: 1 to 512
  2. This parameter may only be specified when AverageCount = Moving or Repeat.

Examples:

AverageCount = 100

AverageCountA = 100

AverageCountB = 100

AveragingMode

This parameter sets the averaging mode.

Syntax:

ML2437 FSC: AveragingMode[channel][sp]=[sp]value

ML2438 FSC: AveragingModechannel[sp]=[sp]value

channel ::= A | B

value ::= Moving | Repeat | Auto

Rules:

  1. When AveragingMode is Moving or Repeat, AverageCount must also be specified.
  2. When this parameter is not specified, average is set to off.

Example:

AveragingMode = Auto

AveragingMode = Moving; AverageCount = 64

Calibrate

This parameter causes a power meter calibration sequence to be performed.

Syntax:

Calibrate

Examples:

Calibrate; PowerSensor = MA2474D

CalibrationFactor

This parameter specifies the calibration factor.

Syntax:

ML2437 FSC: CalibrationFactor[channel][sp]=[sp]value

ML2438 FSC: CalibrationFactorchannel[sp]=[sp]value

channel ::= A | B

value ::= numeric value[sp][prefix]units

units ::= % | dB

Rules:

  1. This parameter is required and may only be specified when CalibrationFactorSource = Manual.
  2. Legal values are 0.07 % to 150 % and -1.76 dB to +31.55 dB.

Example:

CalFactorSource = Manual; CalFactor = 99.0 %

CalibrationFactorSource

This parameter sets the source for power sensor calibrator factors.

Syntax:

ML2437 FSC: CalibrationFactorSource[channel][sp]=[sp]value

ML2438 FSC: CalibrationFactorSourcechannel[sp]=[sp]value

channel ::= A | B

value ::= Frequency | Manual | V/GHz

Rules:

  1. When this parameter is not specified, Frequency is the default.

Example:

CalFactorSource = V/GHz

CalibrationValueStartFrequency

This parameter sets the start frequency for the V/GHz calibration factor source.

Syntax:

ML2437 FSC: CalibrationValueStartFrequency[ch][sp]=[sp]value

ML2438 FSC: CalibrationValueStartFrequencych[sp]=[sp]value

ch ::= A | B

value ::= numeric value[sp][prefix]Hz

Rules:

  1. This parameter is required and may only be specified when CalibrationFactorSource = V/GHz.
  2. Legal values are 10 kHz to 122 GHz.
  3. CalibrationValueStartFrequency must be less than CalibrationValueStopFrequency.

Example:

CalibrationValueStartFrequency = 10 MHz

CalibrationValueStartVoltage

This parameter sets the start voltage for the V/GHz calibration factor source.

Syntax:

ML2437 FSC: CalibrationValueStartVoltage[ch][sp]=[sp]value

ML2438 FSC: CalibrationValueStartVoltagech[sp]=[sp]value

ch ::= A | B

value ::= numeric value[sp][prefix]V

Rules:

  1. This may only be specified when CalibrationFactorSource = V/GHz.
  2. Legal values are 10 kHz to 122 GHz.
  3. When this parameter is not specified, 0 V is the default.
  4. CalibrationValueStartVoltage must be less than CalibrationValueStopVoltage.

Example:

CalibrationValueStartVoltage = 1 V

CalibrationValueStopFrequency

This parameter sets the start frequency for the V/GHz calibration factor source.

Syntax:

ML2437 FSC: CalibrationValueStopFrequency[ch][sp]=[sp]value

ML2438 FSC: CalibrationValueStopFrequencych[sp]=[sp]value

ch ::= A | B

value ::= numeric value[sp][prefix]Hz

Rules:

  1. This parameter is required and may only be specified when CalibrationFactorSource = V/GHz.
  2. Legal values are 10 kHz to 122 GHz.
  3. CalibrationValueStopFrequency must be greater than CalibrationValueStartFrequency.

Example:

CalibrationValueStopFrequency = 40 GHz

CalibrationValueStopVoltage

This parameter sets the stop voltage for the V/GHz calibration factor source.

Syntax:

ML2437 FSC: CalibrationValueStopVoltage[ch][sp]=[sp]value

ML2438 FSC: CalibrationValueStopVoltagech[sp]=[sp]value

ch ::= A | B

value ::= numeric value[sp][prefix]V

Rules:

  1. This may only be specified when CalibrationFactorSource = V/GHz.
  2. Legal values are 10 kHz to 122 GHz.
  3. When this parameter is not specified, 10 V is the default.
  4. CalibrationValueStopVoltage must be greater than CalibrationValueStartVoltage.

Example:

CalibrationValueStopVoltage = 15 V

Connect

This parameter causes an automatic connection message to be generated when ASK+ W or ASK+ V is in effect. In addition, a connect statement will cause procedure header CONFIGURATION: lines to be generated, regardless of the state of the ASK W and ASK V flags.

Syntax:

Connect

Rules:

  1. When PowerSensor is specified, PowerSensor must also be specified.

Examples:

Connect; PowerSensor = MA2474D

DutyCycle

This parameter specifies the duty cycle.

Syntax:

ML2437 FSC: [@]DutyCycle[channel][sp]=[sp]value

ML2438 FSC: [@]DutyCyclechannel[sp]=[sp]value

channel ::= A | B

value ::= numeric value[sp]%

Rules:

  1. Legal values are 0.1 to 100 %.

Examples:

DutyCycle = 50 %

Frequency

This parameter specifies the expected frequency of the RF input signal.

Syntax:

ML2437 FSC: [@]Frequency[channel][sp]=[sp]value

ML2437 FSC: [@]Frequencychannel[sp]=[sp]value

channel ::= A | B

value ::= numeric value[sp][prefix]Hz

Rules:

  1. Legal values are based on the sensor module used:
    1. MA2411 300 MHz to 40 GHz
    2. MA2421 100 kHz to 18 GHz
    3. MA2422 10 MHz to 18 GHz
    4. MA2423 10 MHz to 32 GHz
    5. MA2424 10 MHz to 40 GHz
    6. MA2425 10 MHz to 50 GHz
    7. MA2442 10 MHz to 18 GHz
    8. MA2444 10 MHz to 40 GHz
    9. MA2445 10 MHz to 50 GHz
    10. MA2468 10 MHz to 6 GHz
    11. MA2469 10 MHz to 18 GHz
    12. MA2472 10 MHz to 18 GHz
    13. MA2473 10 MHz to 32 GHz
    14. MA2474 10 MHz to 40 GHz
    15. MA2475 10 MHz to 50 GHz
    16. MA2481 10 MHz to 6 GHz
    17. MA2482 10 MHz to 6 GHz
    18. MA2490 50 MHz to 8 GHz
    19. MA2491 50 MHz to 18 GHz
    20. SC6230 10 MHz to 67 GHz
    21. SC7430 10 MHz to 67 GHz
    22. SC7570 10 MHz to 67 GHz

Example:

Freq = 10 GHz

Local

This action puts the ML2437A/ML2438A in local mode.

Syntax:

Local

Rules:

  1. When Local is specified, no other parameters may be specified.

Examples:

Local

LowLevelAveraging

This parameter sets the auto low level averaging mode.

Syntax:

ML2437 FSC: LowLevelAveraging[channel][sp]=[sp]value

ML2438 FSC: LowLevelAveragingchannel[sp]=[sp]value

channel ::= A | B

value ::= Low | Medium | High

Rules:

  1. When this parameter is not specified, auto low level averaging is set to off.

Example:

LowLevelAveraging = Medium

Measure

This "Action" parameter causes the following:

  1. Setup the ML2437A/ML2438A for measurement of the parameter designated as the Evaluation Quantity.
  2. Initiate the measurement.
  3. Return the reading in memory register MEM in units of the designated Nominal parameter value.

Syntax:

Measure

Rules:

  1. When Measure is specified, Setup must not be specified.
  2. When neither Measure or Setup is specified, Measure is assumed.

Example:

ML2437 +Power = -10.00 dBm

Power

This parameter specifies the expected power of the RF input signal.

Syntax:

ML2437 FSC: [+]Power[channel][sp]=[sp]value

ML2438 FSC: [+]Powerchannel[sp]=[sp]value

channel ::= A | B

value ::= numeric value[sp][prefix]units

units ::= dBm | W | V

Rules:

  1. Legal values are based on the sensor module used.
    1. MA2411 -20 to +20 dBm, 10 uW to 100 mW
    2. MA2421 -30 to +20 dBm, 1 uW to 100 mW
    3. MA2422 -30 to +20 dBm, 1 uW to 100 mW
    4. MA2423 -30 to +20 dBm, 1 uW to 100 mW
    5. MA2424 -30 to +20 dBm, 1 uW to 100 mW
    6. MA2425 -30 to +20 dBm, 1 uW to 100 mW
    7. MA2442 -67 to +20 dBm, 200 pW to 100 mW
    8. MA2444 -67 to +20 dBm, 200 pW to 100 mW
    9. MA2445 -67 to +20 dBm, 200 pW to 100 mW
    10. MA2468 -60 to +20 dBm, 1 nW to 100 mW
    11. MA2469 -60 to +20 dBm, 1 nW to 100 mW
    12. MA2472 -70 to +20 dBm, 200 pW to 100 mW
    13. MA2473 -70 to +20 dBm, 200 pW to 100 mW
    14. MA2474 -70 to +20 dBm, 200 pW to 100 mW
    15. MA2475 -70 to +20 dBm, 200 pW to 100 mW
    16. MA2481 -60 to +20 dBm, 1 nW to 100 mW
    17. MA2482 -60 to +20 dBm, 1 nW to 100 mW
    18. MA2490 -60 to +20 dBm, 1 nW to 100 mW
    19. MA2491 -60 to +20 dBm, 1 nW to 100 mW
    20. SC6230 -30 to +20 dBm, 1 uW to 100 mW
    21. SC7430 -30 to +20 dBm, 1 uW to 100 mW
    22. SC7570 -30 to +20 dBm, 1 uW to 100 mW

Examples:

+Power = -10.00 dBm

PowerRatio

This parameter specifies the expected power ratio.

Syntax:

+PowerRatiomode[sp]=[sp]value

mode ::= AB (A divided by B) | BA (B divided by A)

value ::= linear ratio | logarithmic ratio

linear ratio ::= numeric value%

logarithmic ratio ::= numeric value[sp][prefix]dB

Rules:

  1. When this parameter is specified, it must be specified as the Evaluation Quantity (i.e. +PowerRatio).
  2. When PowerRatio is specified in %, linear ratio mode is selected.
  3. When PowerRatio is specified in dB, log ratio mode is selected.
  4. Legal values are: tbd

Example:

ML2438 +PowerRatio = 10 %

PowerDifference

This parameter specifies the expected power difference.

Syntax:

+PowerDifferencemode[sp]=[sp]valueunits

mode ::= AB (A minus B) | BA (B minus A)

units ::= dB | W | V

Rules:

  1. When this parameter is specified, it must be specified as the Evaluation Quantity (i.e. +PowerDifference).
  2. Legal values are: <tdb>

Example:

ML2438 +PowerDif = 10 mW

Read

This "Action" parameter causes the following:

  1. Initiate the measurement.
  2. Return the reading in memory register MEM.

Syntax:

Read

Rules:

  1. A ML2437/ML2438 Measure or Setup statement must precede a Read statement in the current test.
  2. The value in MEM is in units of the parameter designated as the Evaluation Quantity in the previous ML2437/ML2438 Measure or Setup statement.
  3. When Read is specified, no other parameters may be specified.

Examples:

ML2437 Read

Reset

This parameter resets the instrument.

Syntax:

Reset

Rules:

  1. When Reset is specified, no other parameters are allowed.

Examples:

Reset

PowerSensor

This parameter specifies the sensor module.

Syntax:

ML2437 FSC: PowerSensor[channel][sp]=[sp]value

ML2438 FSC: PowerSensorchannel[sp]=[sp]value

channel ::= A | B

value ::= MA2468A | MA2469A | MA2469B | MA2472A | MA2472D | MA2473A | MA2473D | MA2474A | MA2474D | MA2475A | MA2475D | MA2421A | MA2422B | MA2423B | MA2424B | MA2425B | MA2442A | MA2444A | MA2445A | MA2481A | MA2480/01

Example:

PowerSensor = MA2472D

Settled

This parameter specifies how long the power meter waits for the signal to settle.

Syntax:

ML2437 FSC: Settled[channel][sp]=[sp]value

ML2438 FSC: Settledchannel[sp]=[sp]value

channel ::= A | B

value ::= numeric value[sp]%

Rules:

  1. Legal values are 0.01 to 10 %.

Examples:

SettledA = 0.1 %

Setup

This "Action" parameter sets up the ML2437A/ML2438A for power measurement.

Syntax:

Setup

Rules:

  1. No measurement is performed.
  2. A Read "Action" must be specified in a subsequent ML2437/ML2438 statement to cause a measurement to be performed and to obtain the reading.
  3. When Setup is specified, Measure must not be specified.

Examples:

ML2437 Setup +Power = -10.00 dBm; Freq = 100 MHz

UUTSWR

This parameter specifies the UUT SWR for ML2437A/ML2438A power accuracy calculation.

Syntax:

UUTSWR[sp]=[sp]value

Example:

ML2438 UUTSWR = 2

Zero

This parameter causes a power meter zero sequence to be performed.

Syntax:

Zero

Rules:

  1. When Zero is specified, PowerMeter must also be specified.

Examples:

Zero; PowerSensor = MA2472D

Examples

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
# -----  Reset  -----
  1.001  ML2437       Reset
# -----  Zero and Calibrate -----
  1.002  DISP         Connect MA2472D to ML2437A sensor A.
  1.003  ML2437       Zero; PowerSensor = MA2472
  1.004  ML2437       Cal; PowerSensor = MA2472
# -----  Power Measurement  -----
  1.005  ML2437       PowerSensor = MA2472
  1.005  ML2437       +Power = -5 dBm; @Frequency = 300 MHz
  1.006  MEMC         -5.0dBm        1.0U          300MHz
# -----  Power Measurement, Channel B  -----
  2.001  ML2438       PowerSensorB = MA2474
  2.001  ML2438       +PowerB = -2.0 dBm; FreqB = 20 GHz
  2.002  MEMC         -2.0dBm        1.0U          20GHz


ML2530

Interface Control FSCs

Description

The ML2530 FSC controls the Anritsu ML2530 Calibration Receiver.

Parameters

An NVI FSC statement consists of one or more parameters. A parameter consists of a name and a value. Each parameter must be separated by a semicolon and/or one or more spaces. A single NVI FSC statement can encompass more than one physical line as long as the line numbers are the same. However each parameter name and its value must occur on one line. A single line can accommodate up to 256 characters including the statement number and FSC. Note that characters above ASCII 128 count as 2 characters.

Syntax:

parameter[separatorparameter]

parameter::= [parameter_prefix]parameter_name[[sp]=[sp]parameter_value]

separator::= ;[sp] | sp

parameter_prefix ::=+ | @

sp::= one or more spaces

parameter_name::= see the Parameter Names section

parameter_value::=dimensionless number | dimensioned number | discrete_list

dimensionless number::=NRf

dimensioned number::=NRf[sp][prefix]units

discrete_list::=see the Parameter Names section

prefix::=y | z | a | f | p | n | u | m | k | M | G | T | P | E | Z | Y

Definitions:

|
Denotes "or" (i.e. A | B is A or B)
[ ]
Denotes an optional syntax element, except in examples. In examples [ ] enclose a special construction.
+
Designates the parameter as the Evaluation Quantity
@
Designates the parameter as the Modifier Quantity

Rules:

  1. One and only one parameter must be designated as the Evaluation Quantity in a ML2530 Measure (default), Setup, or Read action.

  2. When a ML2530 Measure (default) statement is executed, the ML2530A measurement is copied to memory register MEM in units of the Evaluation Quantity.

    Example:

    ML2530 +Level = 100 uW; Freq = 100 MHz

    or

    ML2530 +Level = 100 uW; Freq = 100 MHz; Measure

    If the ML2530A level measurement was 99.9 uW, MEM would be 99.9.

  3. When a ML2530 Read statement is executed, the ML2530A measurement is copied to memory register MEM in units of the Evaluation Quantity designated in the previous Setup or Measure statement.

    Example:

    ML2530 +Level = 100 uW; Freq = 100 MHz; Setup

    ML2530 +Level = 100 uW; Freq = 100 MHz; Read

  4. At most one parameter may be designated as the Modifier Quantity in a ML2530 Measure or Setup.

  5. When a ML2530 Measure is executed, the Modifier Quantity is concatenated to the Evaluation Quantity in the automatic message to setup the UUT. Note, the automatic message to setup the UUT is not displayed when ASK- N is in effect.

    Examples:

    ASK+  N
ML2530  +Level = 100 uW; @Freq = 100 MHz

    "Set UUT to source 100 uW at 100 MHz."

    No Modifier Quantity designated.

    ML2530 +Level = 100 uW; Freq = 100 MHz

    "Set UUT to source 100 uW"

    Automatic UUT setup message inhibited.

    ASK-  N
ML2530  +Level = 100 uW; Freq = 100 MHz

    No automatic UUT setup generated.

  6. Parameter values may be taken from a MET/CAL memory register using a special construction.

Parameter Names

Parameter names consist of single words or compound words. Each word in a parameter name can be entered in long form (as shown below), or in short form. The short form is the first 4 characters of the long form, with the following exceptions:

  1. If the long form is greater than four characters, and the last character or the short form is a vowel, the short form is three characters.
  2. If the long form is four characters or less, the short form is the long form even if it ends in a vowel.

Compound parameter names can be entered in any combination of long and short forms. Example, NoSensorModuleRequired can be entered using any of the following forms:

  • NoSensModReq
  • NoSensModRequired
  • NoSensModuleReq
  • NoSensorModReq
  • NoSenModuleRequired
  • NoSensorModRequired
  • NoSensorModuleReq
  • NoSensorModuleRequired

Action Parameters

Action parameters specify the operation to be performed.

  • Calibrate
  • Local
  • Measure
  • Read
  • Reset
  • Setup
  • Zero

Rules:

  1. Only one action parameter is allowed per ML2530 statement (single or mult-line).
  2. If an action is not specified, the default is Measure.

Primary Parameters

Primary parameters specify the measurement.

  • Frequency
  • Level
  • RelativeLevel

Secondary Parameters

Secondary parameters are used for one or both of the following:

  1. Clarify the action.
  2. Configure the measurement.

Parameter list:

  • AverageCount
  • Bandwidth
  • FrequencySpan
  • Mode
  • NoSensorModuleRequired
  • Offset
  • Range
  • Range1ToRange2
  • Range2ToRange3
  • ReferenceLevel
  • SensorModule
  • SensorModuleToRange1

Operating Mode

The following actions determine the operating mode directly.

Action Parameter | Operating Mode
Calibrate | Calibrate sensor module or range
Local | Set ML2530A to local
Measure | Setup and Read
Read | Read level measurement
Reset | Reset ML2530A
Setup | Setup level measurement
Zero | Zero sensor module

Inter-Parameter Rules

If a parameter is not listed for a operating mode, it is not allowed.

Level Measurement

Absolute

Required Parameters

  • +Level
  • Frequency 1
  • FrequencySpan 2
Optional Parameters | Default
NoSensorModuleRequired | n/a

Relative

Required Parameters

  • +RelativeLevel
  • Frequency 1
  • FrequencySpan 2
  • ReferenceLevel 3,4
Optional Parameters | Default
AverageCount | 1
Bandwidth | auto
Mode | Monitor
Offset | na
Range | autorange
  1. Used to set the center frequency.
  2. Not allowed when Mode = ManualTuning.
  3. At one of ReferenceLevel or Offset must be specified.
  4. ReferenceLevel or may both be specified, but not both

Calibrate Range (absolute)

Required Parameters

  • SensorModuleToRange1 1
  • Range1ToRange2 1
  • Range2ToRange3 1
  • Level
  • Frequency
  1. Only one of SensorModuleToRange1, Range1ToRange2, or Range2ToRange3 may be specified.

Calibrate Range (relative)

Required Parameters

  • Range1ToRange2 1
  • Range2ToRange3 1
  • Level
  • Frequency
  • NoSensorModuleRequired
  1. Only one of Range1ToRange2 or Range2ToRange3 may be specified.

Calibrate Sensor Module

Required Parameters

  • SensorModule

Zero Sensor Module

Required Parameters

  • SensorModule

Parameter Definitions and Values

AverageCount

This parameter sets the average count.

Syntax

AverageCount[<sp>]=[<sp>]<nr1>

Rules

  1. Legal values are: 1 to 256
  2. If not specified, averaging is set 1.

Example

AverageCount = 100

Calibrate

This parameter causes a sensor module calibration sequence to be performed.

Syntax

Calibrate

Examples

Calibrate; SensorModule

Frequency

This parameter specifies the expected frequency of the RF input signal.

Syntax

[+|@]Frequency[<sp>]=[<sp>]<value>

<value> = <numeric value>[<sp>][<prefix>]Hz

Rules

  1. Frequency value is used to set the center frequency.
  2. Legal values are: 100 kHz to 3 GHz

Example

+Frequency = 120.0000 MHz

FrequencySpan

This parameter specifies the frequency span.

Syntax

FrequencySpan[<sp>]=[<sp>]<value>

<value> = <numeric value>[<sp>][<prefix>]Hz

Rules

  1. Legal values are: 10 kHz to 1 MHz
  2. This parameter is not allowed when Mode = ManualTuning.

Example

+FrequencySpan = 100 kHz

Level

This parameter specifies the expected level of the RF input signal.

Syntax

[+]Level[<sp>]=[<sp>]<value>

<value> = <numeric value>[<sp>][<prefix>]<units>

<units> = dBm | dBuV | W | V

Rules

  1. Legal values are: -140 dBm to +20 dBm

Example

+Level = -10.00 dBm

Local

This action puts the ML2530A in local mode.

Syntax

Local

Rules

  1. When Local is specified, no other parameters may be specified.

Examples

Local

Measure

This "Action" parameter causes the following:

  1. Setup the ML2530A for measurement of the parameter designated as the Evaluation Quantity.
  2. Initiate the measurement.
  3. Return the reading in memory register MEM in units of the designated Nominal parameter value.

Syntax

Measure

Rules

  1. When no action parameter is specified, Measure is the default.

Examples

The following statement are identical.

ML2530 +Level = 0.00 dBm

ML2530 +Level = 0.00 dBm; Measure

Mode

This parameter selects the mode.

Syntax

Mode[<sp>]=[<sp>]<value>

<value> = Monitor | ManualTuning

Rules

  1. If not specified, the default is ManualTuning.

Examples

Mode = Monitor

NoSensorModuleRequired

This parameter turns inhibits a absolute level measurement statement from requiring the MA2450A Sensor Module.

Syntax

NoSensorModuleRequired

Examples

NoSensorModuleRequired

Range

This parameter selects the input range.

Syntax

Range[<sp>]=[<sp>]<value>

<value> = <numeric value>[<sp>][<prefix>]dBm

Rules

  1. Legal values are:
    1. +20 dBm (range 1)
    2. -25 dBm (range 2)
    3. -70 dBm (range 3)
  2. If not specified, autorange is selected.

Examples

Range = -25 dBm

Range1ToRange2

This parameter is used to select calibration between range 1 and 2.

Syntax

Range1ToRange2

Examples

Calibrate; Range1ToRange2; Level = -30 dBm; Freq = 100 MHz

Range2ToRange3

This parameter is used to select calibration between range 2 and 3.

Syntax

Range2ToRange3

Examples

Calibrate; Range2ToRange3; Level = -75 dBm; Freq = 100 MHz

ReferenceLevel

This parameter sets the reference level for relative measurements.

Syntax

ReferenceLevel[<sp>]=[<sp>]<numeric value>[<sp>][<prefix>]<units>

<value> = <numeric value>[<sp>][<prefix>]<units>

<units> = dBm | dBuV | W | V

Example

RefLevel = [V RefLvl] dBm

Read

This "Action" parameter causes the following:

  1. Restart the measurement.
  2. Return the reading in memory register MEM.

Syntax

Read

Rules

  1. A ML2530 Measurement or Setup statement must precede a Read statement in the current test.
  2. The value in MEM is in units of the parameter designate as the Evaluation Quantity in the previous ML2530 Measure or Setup statement.

Example

<tbd>

RelativeLevel

This parameter specifies the expected relative level measurement. When this parameter is specified, it must be designated as the Evaluation Quantity.

Syntax

+RelativeLevel[<sp>]=[<sp>]<value>

<value> = <numeric value>[<sp>][<prefix>]dB

Rules

  1. Specifying "RelativeLevel" turns the reference level on.

  2. The reference level must be specified as follows:

    ReferenceLevel = <value>

  3. When this parameter is specified, it must be specified as the Evaluation Quantity.
  4. Legal values are: -180 to +60 dB

Example

+RelativeLevel = -3 dB; RefLev = -0.94 dBm

Reset

This parameter resets the ML2530A.

Syntax

Reset

Rules

  1. When Reset is specified, no other parameters are allowed.

Examples

Reset

SensorModule

This parameter is used to clarify the Calibrate and Zero actions.

Syntax

SensorModule

Examples

Cal; SensorModule

SensorModuleToRange1

This parameter is used to select calibration between sensor and range 1.

Syntax

SensorModuleToRange1

Examples

Calibrate; SensorModuleToRange1; Level = 0 dBm; Freq = 100 MHz

Setup

This "Action" parameter sets up the ML2530A for measurement of the parameter designated as the Evaluation Quantity.

Syntax

Setup

Rules

  1. No measurement is performed.
  2. A Read "Action" must be specified in a subsequent ML2530 statement to cause a measurement to be performed and to obtain the reading.

Example

<tbd>

Zero

This parameter causes a sensor module zero sequence to be performed.

Syntax

Zero

Rules

  1. When Zero is specified, PowerMeter must also be specified.

Examples

Zero; SensorModule

Examples

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON

# -----  Reset  -----
  1.001  ML2530       Reset

# -----  Sensor Module Zero -----
  1.002  ML2530       Zero; SensorModule

# -----  Sensor Module Calibration -----
  1.003  ML2530       Cal; SensorModule

# -----  Range Calibration -----
  1.004  ML2530       Cal; SensorModuleToRange1; Level = 0 dBm; Freq = 100 MHz
  1.005  ML2530       Cal; Range1ToRang2; Level = -30 dBm; Freq = 100 MHz
  1.006  ML2530       Cal; Range2ToRang3; Level = -75 dBm; Freq = 100 MHz

# -----  Level Measurement  -----
  1.007  TARGET       -p
  1.008  ML2530       Frequency = 10 MHz; FrequencySpan = 10 kHz
  1.008  ML2530       +Level = -10.00 dBm; Setup
  1.009  IEEE         CF10.01GHL15DMRF1[GTL]
  1.010  TARGET       -m
  1.011  ML2530       Frequency = 10 MHz; FrequencySpan = 10 kHz
  1.011  ML2530       +Level = -10.00 dBm; Read
  1.012  MEMC   25    -10.00dBm      1.00U


CH5500

Instrument FSC

Description

The CH5500 FSC controls the Clarke-Hess 5500 Phase Standard.

Parameters

A CH5500 statement consists of one or more parameters. A parameter consists of a name and a value. Each parameter must be separated by a semicolon and/or one or more spaces. A single CH5500 statement can encompass more than one physical line as long as the line numbers are the same. However each parameter name and its value must occur on one line. A single line can accommodate 256 characters including the statement number and FSC. Note that characters above ASCII 128 will count as 2 characters.

Syntax:

CH5500 parameter[separator parameter]

parameter::= [prefix]parameter name[sp]=[sp]parameter value

separator::= ;[sp] | SP

prefix ::= + | @

sp::= one or more spaces

parameter name ::= see PARAMETERS NAMES section below

parameter value::= see PARAMETERS NAMES section below

|
Denotes "or" (i.e. A | B is A or B)
[ ]
Denotes an optional syntax element, except in examples. In examples [ ] enclose a special construction.
+
Designates the parameter as the Evaluation Quantity
@
Designates the parameter as the Modifier Quantity

Rules:

  1. One and only one parameter must be designated as the Evaluation Quantity for a CH5500 Apply (default), Setup, or Operate action.

  2. When a CH5500 Apply or Setup statement is executed, the evaluation quantity is copied to memory register MEM1 in the units specified.

    Example:

      1.001  CH5500       RefAmpl = 5 V; VarAmpl = 5 V
  1.001  CH5500       +Phase = 180 deg; Freq = 10 kHz

    or

      1.002  CH5500       RefAmpl = 5 V; VarAmpl = 5 V
  1.002  CH5500       +Phase = 180 deg; Freq = 10 kHz; Apply

    MEM1 would be 180 after either statement executes.

      1.003  CH5500       RefAmpl = 5 V; VarAmpl = 5 V
  1.003  CH5500       +Freq = 10 kHz; Phase = 180 deg; Setup

    MEM1 would be 10 after the statement executes.

  3. At most one parameter may be designated as the Modifier Quantity for a CH5500 Apply, Setup, or Operate statement.
  4. Parameter values may be taken from a MET/CAL memory register using a special construction.

Parameter Names

Parameter names consist of single words or compound words. Each word in a parameter name can be entered in long form (as shown below), or in short form. The short form is the first 4 characters of the long form, with the following exceptions:

  1. If the long form is greater than four characters, and the last character or the short form is a vowel, the short form is three characters.
  2. If the long form is four characters or less, the short form is the long form even if it ends in a vowel. Compound parameter names can be entered in any combination of long and short forms. Example, ExternalReferenceFrequency can be entered using any of the following forms:
    • ReferenceAmplitude
    • RefAmpl
    • Frequency
    • Freq

Action Parameters

Action parameters specify the operation to be performed.

  • Apply
  • Local
  • Operate
  • Reset
  • Setup
  • Standby

Rules:

  1. Only one action parameter is allowed per CH5500 statement (single or mult-line).
  2. If an action is not specified, the default is Apply.

General Parameters

  • Frequency
  • Offset
  • Phase
  • ReferenceAmplitude
  • SecondAutozeroOff
  • VariableAmplitude

Inter-Parameter Rules

If a parameter is not listed, it is not allowed.

Evaluation Quantity: Phase

Required Parameters | Optional Parameters | Default
+Phase |  |
ReferenceAmplitude |  |
VariableAmplitude |  |
Frequency |  |
Offset |  | 0 deg
SecondAutozeroOff |  |

Evaluation Quantity: ReferenceAmplitude

Required Parameters | Optional Parameters | Default
+ReferenceAmplitude |  |
VariableAmplitude |  |
Frequency |  |
Phase |  |
Offset |  | 0 deg
SecondAutozeroOff |  |

Evaluation Quantity: VariableAmplitude

Required Parameters | Optional Parameters | Default
+VariableAmplitude |  |
ReferenceAmplitude |  |
Frequency |  |
Phase |  |
Offset |  | 0 deg
SecondAutozeroOff |  |

Evaluation Quantity: Frequency

Required Parameters | Optional Parameters | Default
+Frequency |  |
ReferenceAmplitude |  |
VariableAmplitude |  |
Phase |  |
Offset |  | 0 deg
SecondAutozeroOff |  |

Parameter Definitions and Values

Apply

This "Action" parameter causes the following:

  1. Setup the 5500 for an output.
  2. Turn the output on.
  3. Return the Evaluation Quantity in memory register MEM1 in units designated.

Syntax:

Apply

Rules:

  1. When neither Apply or Setup is specified, Apply is assumed.

Example:

  1.004  CH5500       RefAmpl = 5 V; VarAmpl = 5 V
  1.004  CH5500       +Phase = 180 deg; Freq = 10 kHz

Frequency

This parameter specifies the output frequency.

Syntax:

[+|@]Frequency[sp]=[sp]numeric value[sp][prefix]Hz

Rules:

  1. Legal values are: 1 Hz to 200 kHz

Example:

Freq = 10 kHz

Local

This "Action" puts the 5500 in local mode.

Syntax:

Local

Rules:

  1. When Local is specified, no other parameters may be specified.

Example:

Local

Offset

This parameter specifies the phase offset for relative phase output.

Syntax:

Offset[sp]=[sp]numeric value[sp][prefix]deg

Rules:

  1. Legal values are: -999.999 to +999.999 deg

Example:

Offset = 10 deg

Operate

This "Action" parameter turns the output on.

Syntax:

Operate

Rules:

  1. An Operate must be preceded by a Setup statement with identical parameters and values.

Examples:

  1.005  CH5500       RefAmpl = 5 V; VarAmpl = 5 V
  1.005  CH5500       +Phase = 180 deg; Freq = 10 kHz; Operate

This parameter specifies the phase difference between the Reference and Variable output signals.

Syntax:

[+]Phase[sp]=[sp]numeric value[sp][prefix]deg

Rules:

  1. Legal values are: 0 deg to ±999.999 deg

Examples:

+Phase = -10.00 deg

ReferenceAmplitude

This parameter specifies the amplitude of the Reference output.

Syntax:

[+|@]ReferenceAmplitude[sp]=[sp]numeric value[sp][prefix]V

Rules:

  1. Legal values are: 50 mV to 120 V

Examples:

RefAmpl = 1 V

Reset

This "Action" parameter resets the 5500.

Syntax:

Reset

Rules:

  1. When Reset is specified, no other parameters are allowed.

Examples:

Reset

Setup

This "Action" parameter sets up the 5500.

Syntax:

Setup

Rules:

  1. An Operate "Action" must be specified in a subsequent CH5500 statement to activate the output signals.

Examples:

  1.006  CH5500       RefAmpl = 5 V; VarAmpl = 5 V
  1.006  CH5500       +Phase = 180 deg; Freq = 10 kHz; Setup

This "Action" parameter turns the output off.

Syntax:

Standby

Rules:

  1. When Standby is specified, no other parameters are allowed.

Examples:

Standby

VariableAmplitude

This parameter specifies the amplitude of the Variable output.

Syntax:

[+|@]VariableAmplitude[sp]=[sp]numeric value[sp][prefix]V

Rules:

  1. Legal values are: 50 mV to 120 V

Examples:

VarAmpl = 1 V

SecondAutozeroOff

This parameter inhibits the second Autozero performed by the MET/CAL Runtime driver, as recommended by Clarke-Hess, to achive maximum accuracy.

Syntax:

SecondAutozeroOff

Example:

SecondAutozeroOff

Examples

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
# -----  Reset  -----
  1.007  CH5500       Reset
# -----  Standby  -----
  1.008  CH5500       Standby
# =====  Phase Meters (Clarke-Hess 6000)  =====
  1.009  CH5500       Freq  = 100 Hz; RefAmpl = 0.160 V
  1.009  CH5500       +Phase = -160.00 deg; @VarAmpl = 0.160 V
  1.010  WAIT         -t 30 Settling...
  1.011  CALL         Sub Clarke-Hess 6000 Set Range
  1.012  WAIT         -t 6 Settling...
  1.013  TARGET       -m
  1.014  IEEE         [SPL][I][D1000]
  1.015  MEMCX        -160.00°      0.05U         0.160V


6000

Instrument FSC

Description

The 6000 FSC programs the Clarke-Hess 6000 Phase Meter.

Functional Capability

Phase
-180.00 deg to 180.00 deg
0.00 deg to 360.00 deg
Frequency
5 Hz to 500 kHz
Amplitude
10 mV to 350 V RMS

Parameters

RANGE

This field specifies the UUT range as described in the RANGE Field topic.

NOMINAL

This field specifies the expected measured value or a reset. A reset causes the 6000 to perform an A/D cal.

  • Phase entered as [numeric][prefix]deg.
  • Reset entered as *.

Rules:

  1. When the Nominal field contains only units, the value is obtained from memory register MEM. In this case the MOD1 field MUST contain a value.

TOLERANCE

This field specifies the UUT tolerance as described in the TOLERANCE Field topic.

MOD1

This field specifies the frequency.

  • Frequency entered as [numeric][prefix]H.

Rules:

  1. When the MOD1 field contains only units, the value is obtained from memory register MEM. In this case the Nominal field MUST contain a value.

MOD2

This field specifies the measurement range and input waveform:

blank | 0 to 360 deg, sine
SI | -180 to 180 deg, sine
ZQ | 0 to 360 deg, square
SQ | -180 to 180 deg, square

MOD3

This field is used to enable and disable the internal filter banks.

-F | disable filters
blank | enable filters

MOD4

This field specifies the type of test being performed as described in the MOD4 Field topic.

CON

This field specifies the UUT connection.

2W 2 wire

Rules:

  1. If no CON field code is entered, 2W is automatically inserted in the CON field.

Use of Standard Memory Locations and Results Reporting

System memory locations MEM and MEM1 are used. For more information, refer to the Use of Standard Memory Registers topic.

Example

© 2015 Fluke Corporation


8100

Instrument FSC

Description

The 8100 FSC controls the Clarke-Hess 8100 Transconductance Amplifier.

Parameters

An NVI FSC statement consists of one or more parameters. A parameter consists of a name and a value. Each parameter must be separated by a semicolon and/or one or more spaces. A single NVI FSC statement can encompass more than one physical line as long as the line numbers are the same. However each parameter name and its value must occur on one line. A single line can accommodate up to 256 characters including the statement number and FSC. Note that characters above ASCII 128 count as 2 characters.

Syntax:

parameter[separatorparameter]

parameter::= [parameter_prefix]parameter_name[[sp]=[sp]parameter_value]

separator::= ;[sp] | sp

parameter_prefix ::=+ | @

sp::= one or more spaces

parameter_name::= see the Parameter Names section

parameter_value::=dimensionless number | dimensioned number | discrete_list

dimensionless number::=NRf

dimensioned number::=NRf[sp][prefix]units

discrete_list::=see the Parameter Names section

prefix::=y | z | a | f | p | n | u | m | k | M | G | T | P | E | Z | Y

Definitions:

|
Denotes "or" (i.e. A | B is A or B)
[ ]
Denotes an optional syntax element, except in examples. In examples [ ] enclose a special construction.
+
Designates the parameter as the Evaluation Quantity
@
Designates the parameter as the Modifier Quantity

Rules:

  1. One and only one parameter must be designated as the Evaluation Quantity for a 8100 Apply (default), Setup, or Operate action.

  2. When a 8100 Apply or Setup statement is executed, the evaluation quantity is copied to memory register MEM1 in the units specified.

    3. Example:

      1.001  8100         Range = 20 A
  1.001  8100         +Current = 20.0 A; @Freq = 10 kHz

    MEM1 would be 20 after either statement executes.

  3. At most one parameter may be designated as the Modifier Quantity for a 8100 Apply, Setup, or Operate statement.
  4. Parameter values may be taken from a MET/CAL memory register using a special construction.

Parameter Names

Parameter names consist of single words or compound words. Each word in a parameter name can be entered in long form (as shown below), or in short form. The short form is the first 4 characters of the long form, with the following exceptions:

  1. If the long form is greater than four characters, and the last character or the short form is a vowel, the short form is three characters.
  2. If the long form is four characters or less, the short form is the long form even if it ends in a vowel.

Compound parameter names can be entered in any combination of long and short forms. Example, Frequency can be entered using either of the following forms:

  • Frequency
  • Freq

Action Parameters

Action parameters specify the operation to be performed.

  • Apply
  • Local
  • Operate
  • Reset
  • Setup
  • Standby

Rules:

  • Only one action parameter is allowed per 8100 statement (single or mult-line).
  • If an action is not specified, the default is Apply.

General Parameters

  • Current
  • Frequency
  • Range

Inter-Parameter Rules

If a parameter is not listed, it is not allowed.

Parameter Name | Parameter Type | Default Value
+Current | Required | N/A
Range | Required | N/A
Frequency | Optional | DC

Parameter Definitions and Values

Apply

This "Action" parameter causes the following:

  1. Setup the 8100 for an output.
  2. Turn the output on.
  3. Return the Evaluation Quantity in memory register MEM1 in units designated.

Syntax:

Apply

Rules:

  • When neither Apply or Setup is specified, Apply is assumed.

Example:

  1.002  8100         Range = 20 A
  1.002  8100         +Current = 20.00 A; @Freq = 10 kHz

Current

This parameter specifies the expected output current.

Syntax:

+Current[sp]=[sp]numeric value[sp][prefix]A

Rules:

  1. Legal values are: 0 A to 100 A

Examples:

+Current = 50.00 A

Frequency

This parameter specifies the frequency.

Syntax:

@Frequency[sp]=[sp]numeric value[sp][prefix]Hz

Rules:

  1. Legal values are: 10 Hz to 100 kHz

Example:

@Freq = 10 kHz

Local

This "Action" puts the 8100 in local mode.

Syntax:

Local

Rules:

  1. When Local is specified, no other parameters may be specified.

Examples:

Local

Operate

This "Action" parameter turns the output on.

Syntax:

Operate

Rules:

  1. An Operate must be preceded by a Setup statement with identical parameters and values.

Examples:

  1.003  8100         Range = 20 A
  1.003  8100         +Current = 20.00 A; @Freq = 10 kHz; Operate

Range

This parameter specifies the current range.

Syntax:

Range[sp]=[sp]numeric value[sp][prefix]A

Rules:

  1. Legal values are: 2 mA, 20 mA, 0.2 A, 2 A, 20 A, and 100 A

Examples:

Range = 20 A

Reset

This "Action" parameter resets the 8100.

Syntax:

Reset

Rules:

  1. When Reset is specified, no other parameters are allowed.

Examples:

Reset

Setup

This "Action" parameter sets up the 8100.

Syntax:

Setup

Rules:

  1. An Operate "Action" must be specified in a subsequent 8100 statement to activate the output signals.

Examples:

  1.004  8100         Range = 20 A
  1.004  8100         +Current = 20.00 A; @Freq = 10 kHz; Setup

Standby

This "Action" parameter turns the output off.

Syntax:

Standby

Rules:

  1. When Standby is specified, no other parameters are allowed.

Examples:

Standby

Examples

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
# -----  Reset  -----
  1.005  8100         Reset

# -----  Standby  -----
  1.006  8100         Standby

  1.007  8100         Range = 20A
  1.007  8100         +Current = 20.00A; @Freq = 10kHz; Setup
  1.008  5520         1V                           10kH           SI    S  2W
# Get 5520A accuracy in percent.
  1.009  MATH         Acc5520 = REFACC() / MEM1 * 100 / CONF("Fluke 5520A")
  1.010  8100         Range = 20A
  1.010  8100         +Current = 20.00A; @Freq = 10kHz; Operate
# Get 8100 accuracy in percent.
  1.011  MATH         Acc8100 = REFACC() / MEM1 * 100
  1.012  MATH         Acc8100 = Acc8100 / CONF("Clarke-Hess 8100")
  1.013  MATH         L[1] = RSS2(Acc5520, Acc8100) * 2
  1.014  MATH         MEM = MEM1
  1.015  ACC    20    A              L1%
  1.016  TARGET       -m
  1.017  MEMI         Enter UUT reading in amps.
  1.018  MEMCX  100   A              0.5U          10kH


1271

Instrument FSC

Description

The 1271 FSC programs the Datron 1271 Multimeter to measure DC voltage, AC voltage, DC current, AC current, resistance and frequency.

The 1271 must have firmware version 2.03 or later.

High Speed AC (Option 10) specifications are always used for calculation of TUR at compile time. However, if the 1271 used is equipped with High Accuracy AC (Option 12), Option 12 specifications will be used at run time. When measurement uncertainty is enabled, the 1271 MOD3 field no longer controls the number of readings to throw away and the number of readings to average.

Functional Capability

Function | Nominal | MOD1 | MOD2 | MOD3
DC Voltage | -1100 V to 1100 V
AC Voltage 1,5 | 2 mV to 199.9999 mV | 1 Hz to 100 kHz
200 mV to 199.9999 V | 1 Hz to 1 MHz
200 V to 1100 V | 1 Hz to 100 kHz
40.969 dBm to -0.969 dBm | 1 Hz to 100 kHz | 5Z
-0.969 dBm to +59.031 dBm | 1 Hz to 1 MHz | 5Z
+59.031 dBm to +73.838 dBm | 1 Hz to 100 kHz | 5Z
-42.730 dBm to -2.730 dBm | 1 Hz to 100 kHz | 7Z
-2.730 dBm to +57.270 dBm | 1 Hz to 1 MHz | 7Z
+57.270 dBm to +72.077 dBm | 1 Hz to 100 kHz | 7Z
-51.761dBm to -11.761dBm | 1 Hz to 100 kHz | 6Z
-11.761dBm to +48.239 dBm | 1 Hz to 1 MHz | 6Z
+48.239 dBm to +63.046 dBm | 1 Hz to 100 kHz | 6Z
Resistance 2
True Ohms | 0 Ω to 199.999999 kOhm | OC
Normal Ohms | 0 Ω to 1.99999999 MΩ
Hi Ohms | 2 MΩ to 1.99999999 GΩ
DC Current 4 | -1.999999 A to 1.999999 A
AC Current 5 | 2 µA to 1.99999 A | 10 Hz to 5 kHz
Frequency 1,5,6 | 10 Hz* to 100 kHz | 2 mV to 1000 V
10 Hz* to 1 MHz | 200 mV to 199.9999 V
10 Hz* to 5 kHz | 2 µA to 1.5 A
*lower bound is 200Hz when MOD3 = FE (Fast Gate)
  1. Requires Option 10 or 12.
  2. Requires Option 20.
  3. Requires Options 20 and 30.
  4. Requires Options 10, 20, and 30 or Options 12, 20, and 30.
  5. Option 10 is limited to a minimum of 10Hz for all AC voltage.

Parameters

RANGE

This field specifies the UUT range as described in the RANGE Field topic.

NOMINAL

This field specifies the expected measured value or a reset.

  • Voltage (DC or RMS) entered as [numeric][prefix]V.
  • dBm entered as [numeric][prefix]D.
  • Current entered as [numeric][prefix]A.
  • Resistance entered as [numeric][prefix]Z.
  • Frequency entered as [numeric][prefix]H.
  • Reset entered as *.

Rules:

  • The NOMINAL field may specify frequency only when the MOD1 field specifies voltage or current.

TOLERANCE

This field specifies the UUT tolerance as described in the TOLERANCE Field topic.

MOD1

This field specifies frequency or amplitude for AC voltage or AC current measurements.

  • Frequency entered as numeric[prefix]H.
  • Voltage entered as numeric[prefix]V.
  • Current entered as numeric[prefix]A.
  • blank

Rules:

  • The MOD1 field may specify frequency only when the NOMINAL field specifies voltage or current.
  • The MOD1 field must specify voltage or current when the NOMINAL field specifies frequency.
  • The MOD1 field must be blank when the NOMINAL field specifies resistance.

Option 10

The AC filter is selected as follows:

Frequency | Filter
>= 1kHz | 1kHz High Pass Filter
< 1kHz and >= 360Hz | 360Hz High Pass Filter
< 360Hz and >= 40Hz | 40Hz High Pass Filter
< 40Hz | 10Hz High Pass Filter

Option 12

The AC filter is selected as follows:

Frequency | Filter
>= 100Hz | 100Hz High Pass Filter
< 100Hz and >= 40Hz | 40Hz High Pass Filter
< 40Hz and >= 10Hz | 10Hz High Pass Filter
< 10Hz | 1Hz High Pass Filter

MOD2

This field specifies one of the following:

  1. The load impedance that the AC voltage is referenced to, or
  2. Offset compensated resistance "TRUE OHMS" function.
5Z | 50 Ohm
7Z | 75 Ohm
6Z | 600 Ohm
OC | Enable offset compensated resistance "True OHMS".
blank | (see below)

Rules:

  • The MOD2 field may specify a reference impedance only when the NOMINAL field specifies decibels.
  • The MOD2 field may specify "OC" only when the NOMINAL field specifies a resistance less than 200 kΩ.
  • The MOD2 field must be blank for any of the following conditions:
    1. DC Voltage: The NOMINAL specifies voltage and the MOD1 field is blank.
    2. DC Current: The NOMINAL specifies current
    3. AC Current: The NOMINAL or MOD1 field specifies current

MOD3

Specifies the measurement mode. The measurement mode determines certain function settings, as well as the number of readings that are discarded and the number of readings that are averaged to obtain a measurement. The effect of the measurement mode on the programmed function is shown in the following table:

Function | F | blank | E | FE
DC Volts:
resolution | 6.5 digits | 6.5 digits | 8.5 digits | 8.5 digits
fast | on | off | off | on
reading rate | 50/s | 10/s | 1/10s | 1/6s
Readings
thrown away1 | 1 | 1 | 1 | 1
averaged1 | 5 | 1 | 1 | 1
AC Volts
resolution | 5.5 digits | 5.5 digits | 6.5 digits | 5.5 digits
TFER (option 12) | off | on | on | on
coupling:
< 40 Hz | DC | DC | DC | DC
>= 40 Hz | AC | AC | AC | AC
gate fast | on | on | on | on
reading rate:
Option 10:
>= 1 kHz | 20/s | 20/s | 20/s | 20/s
360 to 1 kHz | 8/s | 8/s | 8/s | 8/s
40 to 360 Hz | 1/s | 1/s | 1/s | 1/s
10 to 40 Hz | 1/5s | 1/5s | 1/5s | 1/5s
Option 12
>= 100 Hz | 2/s | 2/s | 1/s | 2/s
40 to 100 Hz | 1/2s | 1/2s | 1/2s | 1/2s
10 to 40 Hz | 1/2.5s | 1/2.5s | 1/2.5s | 1/2.5s
1 to 10 Hz | 1/25s | 1/25s | 1/25s | 1/25s
Readings:
thrown away1 | 1 | 1 | 1 | 1
averaged1 | 1 | 3 | 3 | 1
Frequency Measurement
gate fast | n/a | off | n/a | on
DC Current:
resolution | 6.5 digits | 5.5 digits | 6.5 digits | 5.5 digits
fast | on | off | off | on
reading rate | 50/s | 50/s | 10/s | 50/s
Readings:
thrown away1 | 1 | 1 | 2 | 1
averaged1 | 1 | 3 | 5 | 1
AC Current:
resolution | 5.5 digits | 5.5 digits | 5.5 digits | 5.5 digits
coupling:
< 40 Hz | DC | DC | DC | DC
>= 40 Hz | AC | AC | AC | AC
reading rate:
Option 10:
>= 1 kHz | 20/s | 20/s | 20/s | 20/s
360 to 1 kHz | 8/s | 8/s | 8/s | 8/s
40 to 360 Hz | 1/s | 1/s | 1/s | 1/s
10 to 40 Hz | 1/5s | 1/5s | 1/5s | 1/5s
Option 12:
>= 100 Hz | 4/s | 4/s | 4/s | 4/s
40 to 100 Hz | 1/s | 1/s | 1/s | 1/s
10 to 40 Hz | 1/5s | 1/5s | 1/5s | 1/5s
Readings:
thrown away1 | 1 | 1 | 2 | 1
averaged1 | 1 | 3 | 5 | 1
Frequency Measurement
gate fast | n/a | off | n/a | on
Resistance:
resolution:
True Ω (4-Wire only)
>= 0 Ω to < 200 kΩ | 6.5 digits | 6.5 digits | 7.5 digits | 6.5 digits
Normal Ω
>= 20 Ω to < 2 MΩ | 6.5 digits | 6.5 digits | 7.5 digits | 6.5 digits
HI Ω
>= 2 MΩ | 5.5 digits | 5.5 digits | 6.5 digits | 5.5 digits
fast | on | off | off | on
reading rate
< 2 MΩ | 50/s | 10/s | 1/2s | 50/s
>= 2 MΩ | 1000/s | 50/s | 10/s | 1000/s
<= 20 kΩ
Readings:
thrown away1 | 1 | 2 | 2 | 1
averaged1 | 3 | 4 | 4 | 1
>20 kΩ to <= 200 kΩ
Readings:
thrown away1 | 1 | 2 | 5 | 1
averaged1 | 3 | 4 | 4 | 1
>200 kΩ
Readings:
thrown away1 | 1 | 2 | 7 | 1
averaged1 | 3 | 4 | 5 | 1
  1. With measurement uncertainty disabled. Use VSET to set number of readings to throw away when measurement uncertainty is enabled.

MOD4

This field specifies the type of test being performed as described in the MOD4 Field topic.

CON

This field specifies the UUT connection.

2W | 2-wire
4W | 4-wire

Rules:

  • The CON field may specify a 4W only when the NOMINAL field specifies resistance.
  • The CON field must specify a 4W when the MOD2 field specifies Offset Compensated Resistance "OC" (True OHMS Function).

Use of Standard Memory Locations and Results Reporting

System memory locations MEM and MEM1 are used. For more information, refer to the Use of Standard Memory Registers topic.

Examples

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
# -----  Reset  -----
  1.001  1271         *                                                 S
# -----  DC Voltage  -----
  1.002  M1271  RNGLK 1V
  1.003  1271         10mV                                              N  2W
  1.004  M1271        *
  1.005  1271   A     -1000V         1% 0.1U                               2W
# -----  AC Voltage  -----
  2.001  1271   200   100V           1% 2/         10kH                    2W
# ---- dBm, 50 Ohms  ----
  3.001  1271         0.00D          0.1U          1kH            5Z       2W
# -----  DC Current  -----
  4.001  1271   10    1.00A          1000P%                                2W
# -----  AC Current  -----
  5.001  1271   2     mA             1%            1kH                     2W
# -----  Resistance  -----
  6.001  1271   100   256kZ          1%                                    4W
# -----  Frequency  -----
  7.001  1271   1     10.0kH         1% 2/         1V                      2W
  8.001  1271   10    1.00kH         1% 2/         10mA                    2W


M1271

Instrument FSC

Description

The M1271 FSC provides additional functions for the Datron 1271 Multimeter that are not addressed in the 1271 FSC. These functions include range locking, DC and Ohms filter, and guard.

Parameters

When a blank M1271 statement is entered, a "*" is inserted automatically in the NOMINAL field. See NOMINAL field parameter for a description of "*".

Range

This field specifies one of the following:

RNGLK | Range Lock
blank | field not applicable

Rules:

  • When the RANGE field specifies RNGLK, the NOMINAL field must specify the range selection value.

NOMINAL

This field specifies the locked range or reset.

  • Voltage range selection value entered as: [numeric][prefix]V
  • Current range selection value entered as: [numeric][prefix]A
  • Resistance range selection value entered as: [numeric][prefix]Z
  • "*" reset to default values

Rules:

  • The NOMINAL field may specify a range selection value only when the RANGE field specifies RNGLK.
Selection Value | Locked Range
Voltage
0 mV to 100 mV | 100 mV
>100 mV to 1 V | 1 V
>1 V to 10 V | 10 V
>10 V to 100 V | 100 V
>100 V to 1000 V | 1000 V
Current
0 μA to 100 μA | 100 μA
>100 μA to 1 mA | 1 mA
>1 mA to 10 mA | 10 mA
>10 mA to 100 mA | 100 mA
>100 mA to 1 A | 1 A
Resistance
0 Ω to 10 Ω | 10 Ω
>10 Ω to 100 Ω | 100 Ω
>100 Ω to 1 kΩ | 1 kΩ
>1 kΩ to 10 kΩ | 10 kΩ
>10 kΩ to 100 kΩ | 100 kΩ
>100 kΩ to 1 MΩ | 1 MΩ
>1 MΩ to 10 MΩ | 10 MΩ
>10 MΩ to 100 MΩ | 100 MΩ
>100 MΩ to 1 GΩ | 1 GΩ
  • A M1271 range lock specification only applies when a subsequent 1271 FSC specifies an applicable measurement function (see EXAMPLES below).
  • When a M1271 range lock is specified for the 10 Ohm range any subsequent 1271 FSCs, that specify resistance measurement (1271 Nominal units are Ohms "Z"), must also specify MOD2 = "OC" Offset Compensated Resistance (TRUE OHMS).
  • When the NOMINAL field specifies reset "*", all other fields must be blank.

TOLERANCE

This field is not used.

MOD1

This field is not used.

MOD2

This field is enables and disables the filter for DC voltage, DC current, and resistance measurements.

FL | enable filter
blank | disable filter

Rules:

  • The MOD2 field is ignored when the 1271 FSC specifies AC Voltage or AC Current measurement.

MOD3

This field is not used.

MOD4

This field is used to specify the guard connection:

G | remote guard
blank | local guard

CON

This field is not used.

Examples

#
  1.001 M1271 RNGLK 100mV
#
# 100mV range is locked
#
  1.002 1271 100mV 1% 2W
#
# 10mV range is locked
#
  2.001 1271 10mV 1% 1kH 2W
  3.001 1271 1kH 1% 10mV 2W
#
# Autorange is selected (M1271 FSC not applicable).
#
  4.001 1271 1uA 1% 2W
  5.001 1271 100uA 1% 1kH 2W
  6.001 1271 1kH 1% 100uA 2W
  7.001 1271 10Z 1% 2W
#
  8.001 M1271 RNGLK 100uA
#
# Autorange is selected (M1271 FSC not applicable).
#
  8.002 1271 100mV 1% N 2W
  9.001 1271 10mV 1% 1kH N 2W
 10.001 1271 1kH 1% 10mV 2W
#
# 100uA range is locked
#
 11.001 1271 100uA 1% N 2W
#
#100uA range is locked
#
 12.001 1271 100uA 1% 1kH N 2W
 13.001 1271 1kH 1% 100uA 2W
#
# Autorange is selected (M1271 FSC not applicable).
#
 14.001 1271 10Z 1% N 2W
#
 15.001 M1271 RNGLK 10Z
#
# Autorange is selected (M1271 FSC not applicable)
#
 15.002 1271 100mV 1% N 2W
 16.001 1271 10mV 1% 1kH N 2W
 17.001 1271 1uA 1% N 2W
 18.001 1271 100uA 1% 1kH N 2W
#
# 10 Ohm range is locked.
#
 19.001 1271 10Z 1% OC N 4W
#
# Autorange is selected for all subsequent 1271 FSCs.
#
 20.001 M1271 *


1281

Instrument FSC

Description

The 1281 FSC programs the Datron 1281 Multimeter to measure DC voltage, AC voltage, DC current, AC current, resistance and frequency.

The 1281 must have firmware version 3.06 or later.

When measurement uncertainty is enabled, the 1281 MOD3 field no longer controls the number of readings to throw away and the number of readings to average.

Functional Capability

Function | NOMINAL | MOD1 | MOD2 | MOD3
DC Voltage | -1100 V to 1100 V
AC Voltage 1 | 2 mV to 199.9999 mV | 1 Hz to 100 kHz
200 mV to 199.9999 V | 1 Hz to 1 MHz
200 V to 1100 V | 1 Hz to 100 kHz
-40.969 dBm to -0.969 dBm | 1 Hz to 100 kHz | 5Z
-0.969 dBm to +59.031 dBm | 1 Hz to 1 MHz | 5Z
+59.031 dBm to +73.838 dBm | 1 Hz to 100 kHz | 5Z
-42.730 dBm to -2.730 dBm | 1 Hz to 100 kHz | 7Z
-2.730 dBm to +57.270 dBm | 1 Hz to 1 MHz | 7Z
+57.270 dBm to +72.077 dBm | 1 Hz to 100 kHz | 7Z
-51.761 dBm to -11.761 dBm | 1 Hz to 100 kHz | 6Z
-11.761 dBm to +48.239 dBm | 1 Hz to 1 MHz | 6Z
+48.239 dBm to +63.046 dBm | 1 Hz to 100 kHz | 6Z
Resistance 2
True Ohms | 0 Ω to 199.999999 kΩ | OC
Normal Ohms | 0 Ω to 1.99999999 MΩ
Hi Ohms | 2 MΩ to 1.99999999 GΩ
DC Current 3 | -1.999999 A to 1.999999 A
AC Current 4 | 2 μA to 1.99999 A | 10 Hz to 5 kHz
Frequency 1 | 10 Hz* to 100 kHz | 2 mV to 1000 V
10 Hz* to 1 MHz | 200 mV to 199.9999 V
10 Hz* to 5 kHz | 2 μA to 1.5 A
  1. Requires Option 10.
  2. Requires Option 20.
  3. Requires Options 20 and 30.
  4. Requires Options 10, 20, and 30.

*lower bound is 200 Hz when MOD3 = FE (Fast Gate)

Parameters

RANGE

This field specifies the UUT range as described in the RANGE Field topic.

NOMINAL

This field specifies the expected measured value or a reset.

  • Voltage (DC or RMS) entered as [numeric][prefix]V.
  • dBm entered as [numeric][prefix]D.
  • Current entered as [numeric][prefix]A.
  • Resistance entered as [numeric][prefix]Z.
  • Frequency entered as [numeric][prefix]H.
  • Reset entered as *.

Rules:

  • The NOMINAL field may specify frequency only when the MOD1 field specifies voltage or current.

TOLERANCE

This field specifies the UUT tolerance as described in the TOLERANCE Field topic.

MOD1

This field specifies frequency or amplitude for AC voltage or AC current measurements.

  • Frequency entered as numeric[prefix]H.
  • Voltage entered as numeric[prefix]V.
  • Current entered as numeric[prefix]A.
  • blank

Rules:

  • The MOD1 field may specify frequency only when the NOMINAL field specifies voltage or current.
  • The MOD1 field must specify voltage or current when the NOMINAL field specifies frequency.
  • The MOD1 field must be blank when the NOMINAL field specifies resistance. The AC filter is selected as follows:
Frequency | Filter
>= 100 Hz | 100 Hz High Pass Filter
< 100 Hz and >= 40 Hz | 40 Hz High Pass Filter
< 40 Hz and >= 10 Hz | 10 Hz High Pass Filter
< 10 Hz | 1 Hz High Pass Filter

MOD2

  1. The load impedance that the AC voltage is referenced to, or
  2. Offset compensated resistance "TRUE OHMS" function.
5Z | 50 Ohm
7Z | 75 Ohm
6Z | 600 Ohm
OC | Enable offset compensated resistance "True OHMS".
blank | (see below)

Rules:

  • The MOD2 field may specify a reference impedance only when the NOMINAL or field specifies decibels.
  • The MOD2 field may specify "OC" only when the NOMINAL field specifies a resistance less than 200 kOhms.
  • The MOD2 must be blank for any of the following conditions:
    1. DC Voltage: The NOMINAL specifies voltage and the MOD1 field is blank.
    2. DC Current: The NOMINAL specifies current
    3. AC Current: The NOMINAL or MOD1 field specifies current

MOD3

Specifies the measurement mode. The measurement mode determines certain function settings, as well as the number of readings that are discarded and the number of readings that are averaged to obtain a measurement. The effect of the measurement mode on the programmed function is shown in the following table:

Function | F | blank | E | FE
DC Volts
resolution | 6.5 digits | 6.5 digits | 8.5 digits | 8.5 digits
fast | on | off | off | on
reading rate | 35/s | 2/s | 1/25s | 1/6s
Readings
thrown away 1 | 1 | 1 | 1 | 1
averaged 1 | 5 | 1 | 1 | 1
AC Volts
resolution | 5.5 digits | 5.5 digits | 6.5 digits | 5.5 digits
TFER | off | on | on | on
coupling
< 40Hz | DC | DC | DC | DC
>= 40 Hz | AC | AC | AC | AC
reading rate
>= 100 Hz | 4/s | 2/s | 2/s | 2/s
40 to 100 Hz | 1/s | 1/2s | 1/2s | 1/2s
10 to 40 Hz | 1/2.5s | 1/5s | 1/5s | 1/5s
1 to 10 Hz | 1/25s | 1/50s | 1/50s | 1/50s
Readings
thrown away 1 | 1 | 1 | 1 | 1
averaged 1 | 1 | 3 | 3 | 1
Frequency Measurement
gate fast | n/a | off | n/a | on
DC Current
resolution | 6.5 digits | 5.5 digits | 6.5 digits | 5.5 digits
fast | on | off | off | on
reading rate | 35/s | 35/s | 2/s | 35/s
Readings
thrown away 1 | 1 | 1 | 2 | 1
averaged 1 | 1 | 3 | 5 | 1
AC Current
resolution | 4.5 digits | 4.5 digits | 5.5 digits | 4.5 digits
coupling
< 40 Hz | DC | DC | DC | DC
>= 40 Hz | AC | AC | AC | AC
reading rate
>= 100 Hz | 4/s | 4/s | 2/s | 4/s
40 to 100 Hz | 1/s | 1/s | 1/2s | 1/s
10 to 40 Hz | 1/2.5s | 1/2.5s | 1/5s | 1/2.5s
Readings
thrown away 1 | 1 | 1 | 2 | 1
averaged 1 | 1 | 3 | 5 | 1
Frequency Measurement
gate fast | n/a | off | n/a | on
Resistance
resolution
True OHMS (4-Wire only)
>= 0 Ω to < 200 kΩ | 6.5 digits | 6.5 digits | 7.5 digits | 6.5 digits
Normal OHMS
>= 20 Ω to < 20 MΩ | 6.5 digits | 6.5 digits | 7.5 digits | 6.5 digits
HI OHMS
>= 20 MΩ | 5.5 digits | 5.5 digits | 6.5 digits | 5.5 digits
reading rate
< 20 Ω | 35/s | 1/6s | 1/6s | 1/6s
>= 20 Ω to < 20 MΩ | 35/s | 2/s | 1/6s | 2/s
>= 20 MΩ | 35/s | 2/s | 1/2s | 2/s
fast | on | off | off | on
<= 20 kΩ
Readings
thrown away 1 | 1 | 2 | 2 | 1
averaged 1 | 3 | 4 | 4 | 1
>20 kΩ to <= 200 kΩ
Readings
thrown away 1 | 1 | 2 | 5 | 1
averaged 1 | 3 | 4 | 4 | 1
>200 kΩ
Readings
thrown away 1 | 1 | 2 | 7 | 1
averaged 1 | 3 | 4 | 5 | 1
  1. With measurement uncertainty disabled. Use VSET to set number of readings to throw away when measurement uncertainty is enabled.

MOD4

This field specifies the type of test being performed as described in the MOD4 Field topic.

CON

This field specifies the UUT connection.

2W | 2-wire
4W | 4-wire

Rules:

  • The CON field may specify a 4W only when the NOMINAL field specifies resistance.
  • The CON field must specify a 4W when the MOD2 field specifies Offset Compensated Resistance "OC" (True OHMS Function).

Use of Standard Memory Locations and Results Reporting

System memory locations MEM and MEM1 are used. For more information, refer to the Use of Standard Memory Registers topic.

Examples

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
# ----- Reset -----
  1.001  1281         *                                                 S
# ----- DC Voltage -----
  1.002  M1281  RNGLK 1V
  1.003  1281         10mV                                              N  2W
  1.004  M1281        *
  1.005  1281   A     -1000V         1% 0.1U                               2W
# ----- AC Voltage -----
  2.001  1281   200   100V           1% 2/         10kH                    2W
# ---- dBm, 50 Ohms ----
  3.001  1281         0.00D          0.1U          1kH            5Z       2W
# ----- DC Current -----
  4.001  1281   10    1.00A          1000P%                                2W
# ----- AC Current -----
  5.001  1281   2     mA             1%            1kH                     2W
# ----- Resistance -----
  6.001  1281   100   256kZ          1%                                    4W
# ----- Frequency -----
  7.001  1281   1     10.0kH         1% 2/         1V                      2W
  8.001  1281   10    1.00kH         1% 2/         10mA                    2W


M1281

Instrument FSC

Description

The M1281 FSC provides additional functions for the Datron 1281 Multimeter that are not addressed in the 1281 FSC. These functions include range locking, DC and Ohms filter, and guard.

Parameters

When a blank M1281 statement is entered, a "*" is inserted automatically in the NOMINAL field. See NOMINAL field parameter for a description of "*".

Range

This field specifies one of the following:

RNGLK | Range Lock
blank | field not applicable

Rules:

  • When the RANGE field specifies RNGLK, the NOMINAL field must specify the range selection value.

NOMINAL

This field specifies the locked range or reset.

  • Voltage range selection value entered as: [numeric][prefix]V
  • Current range selection value entered as: [numeric][prefix]A
  • Resistance range selection value entered as: [numeric][prefix]Z
  • "*" reset to default values

Rules:

  • The NOMINAL field may specify a range selection value only when the RANGE field specifies RNGLK.
Selection Value | Locked Range
0 mV to 100 mV | 100 mV
> 100 mV to 1V | 1 V
> 1 V to 10 V | 10 V
> 10 V to 100 V | 100 V
> 100 V to 1000 V | 1000 V
0 μA to 100 μA | 100 μA
> 100 μA to 1 mA | 1 mA
> 1 mA to 10 mA | 10 mA
> 10 mA to 100 mA | 100 mA
> 100 mA to 1 A | 1 A
0 Ω to 10 Ω | 10 Ω
> 10 Ω to 100 Ω | 100 Ω
> 100 Ω to 1 kΩ | 1 kΩ
> 1 kΩ to 10 kΩ | 10 kΩ
> 10 kΩ to 100 kΩ | 100 kΩ
> 100 kΩ to 1 MΩ | 1 MΩ
> 1 MΩ to 10 MΩ | 10 MΩ
> 10 MΩ to 100 MΩ | 100 MΩ
> 100 MΩ to 1 GΩ | 1 GΩ
  • A M1281 range lock specification only applies when a subsequent 1281 FSC specifies an applicable measurement function (see EXAMPLES below).
  • When a M1281 range lock is specified for the 10 Ohm range any subsequent 1281 FSCs, that specify resistance measurement (1281 Nominal units are Ohms "Z"), must also specify MOD2 = "OC" Offset Compensated Resistance (TRUE OHMS).
  • When the NOMINAL field specifies reset "*", all other fields must be blank.

TOLERANCE

This field is not used.

MOD1

This field is not used.

MOD2

This field is enables and disables the filter for DC voltage,DC current, and resistance measurements.

FL | enable filter
blank | disable filter

Rules:

  • The MOD2 field is ignored when the 1281 FSC specifies AC Voltage or AC Current measurement.

MOD3

This field is not used.

MOD4

This field is used to specify the guard connection:

G | remote guard
blank | local guard

CON

This field is not used.

Examples

#
1.001 M1281 RNGLK 100mV
#
# 100mV range is locked
#
1.002 1281 100mV 1% 2W
#
# 10mV range is locked
#
2.001 1281 10mV 1% 1kH 2W
3.001 1281 1kH 1% 10mV 2W
#
# Autorange is selected (M1281 FSC not applicable)
#
4.001 1281 1uA 1% 2W
5.001 1281 100uA 1% 1kH 2W
6.001 1281 1kH 1% 100uA 2W
7.001 1281 10Z 1% 2W
#
8.001 M1281 RNGLK 100uA
#
# Autorange is selected (M1281 FSC not applicable)
#
8.002 1281 100mV 1% N 2W
9.001 1281 10mV 1% 1kH N 2W
10.001 1281 1kH 1% 10mV 2W
#
# 100uA range is locked
#
11.001 1281 100uA 1% N 2W
#
# 100uA range is locked
#
12.001 1281 100uA 1% 1kH N 2W
13.001 1281 1kH 1% 100uA 2W
#
# Autorange is selected (M1281 FSC not applicable)
#
14.001 1281 10Z 1% N 2W
#
15.001 M1281 RNGLK 10Z
#
# Autorange is selected (M1281 FSC not applicable)
#
15.002 1281 100mV 1% N 2W
16.001 1281 10mV 1% 1kH N 2W
17.001 1281 1uA 1% N 2W
18.001 1281 100uA 1% 1kH N 2W
#
# 10 Ohm range is locked
#
19.001 1281 10Z 1% OC N 4W
#
# Autorange is selected for all subsequent 1281 FSCs
#
20.001 M1281 *


4000 and 4000A

Instrument FSC

Description

The 4000 FSC controls Datron 4000 Autocal Standard. The 4000A FSC controls Datron 4000A Autocal Standard. The functions are supported:

  • DC Voltage
  • DC Current and Resistance with Option 20 installed

The M4000 and M4000A FSCs are used for control the following:

  • Range Locking
  • Safety Delay Override
  • Driver Settling Delay
The 4000 FSC can be used to control a 4000A. In this case the 4000A accuracy file will be used at run time.

Functional Capability

Function | NOMINAL
DC Voltage | -1200 V to 1200 V
DC Current 1 | -1.999999 A to 1.999999 A

Resistance 1

Conductance

0 Ω (Short), 1 Ω to 10 MΩ, 1 S to 100 nS (in decade steps)
  1. With Option 20 installed

Parameters

RANGE

This field specifies the UUT range as described in the RANGE Field topic.

NOMINAL

This field specifies one of the following.

  • Voltage entered as: [numeric][prefix]V
  • Current entered as [numeric][prefix]A.
  • Resistance entered as [numeric][prefix]Z.
  • Conductance entered as [numeric][prefix]Y.
  • Reset entered as *.

TOLERANCE

This field specifies the UUT tolerance as described in the TOLERANCE Field topic.

MOD1

This field is not used and must be blank.

MOD2

This field allows you to specify negative zero or the divider override feature of the calibration system.

-Z | Negative Zero
O | Divider Override

The internal divider allows a user to achieve higher levels of calibration accuracy in most circumstances; therefore the use of the divider is always automatically selected, where it is applicable.

The following table is shows effect of the MOD2 field

Function | NOMINAL | MOD2 | Effect
DC Volts | ≥20 V | blank | Low output impedance
DC Volts | <20 V | blank | 50 Ω output impedance
DC Volts | <20 V | O | Locked in 10 V range, low output impedance
DC Volts | 0.0 | -Z | Negative Zero output
DC Amps | 0.0 | -Z | Negative Zero output

Rules:

  1. The MOD2 field may specify Z only for DC Voltage or DC Current when the Nominal value is zero.

MOD3

This field is not used and must be blank.

MOD4

This field specifies the type of test being performed as described in the MOD4 Field topic.

CON

This field specifies the UUT connection.

2W | 2-wire
4W | 4-wire

Rules:

  1. 2W is automatically entered in the CON field when no CON field code is entered.
  2. The CON field may specify 4W only for resistance, conductance, and DC Voltage ≥200mV.

Use of Standard Memory Locations and Results Reporting

System memory locations MEM and MEM1 are used. For more information, refer to the Use of Standard Memory Registers topic.

Examples

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
  1.001  4000         *                                                 S
  1.002  4000   1000  1200V          1U 1/                                 2W
  2.001  4000   10    0V             1U                                    2W
  3.001  4000A  100   -22uA          10%                                   2W
  4.001  4000   10    20mV                                              N  2W
  4.002  4000   A     1Z             5%                                    4W


M4000 and M4000A

Instrument Setup FSC

Description

The M4000 and M4000A FSCs are used for control range locking, safety delay override, driver settling delay.

Parameters

Range

This field specifies one of the following:

RNGLK | Range Lock
blank | field not applicable

Nominal

This field specifies the range selection value or a reset to autorange.

  • Range selection value entered as [numeric][prefix]V, A, or Z
  • Reset (autorange) entered as "*"

Rules:

  1. "*" is automatically inserted in the NOMINAL field when a blank M4000 statement is entered.
  2. The NOMINAL field may specify a range selection value only when the RANGE field specifies RNGLK.
Range Selection Value | Locked Range
Voltage
0 µV to 100 µV | 100 µV
> 100 µV to 1 mV | 1 mV
> 1 mV to 10 mV | 10 mV
> 10 mV to 100 mV | 100 mV
> 100 mV to 1 V | 1 V
> 1 V to 10 V | 10 V
> 10 V to 100 V | 100 V
> 100 V to 1000 V | 1000 V
Current
0 µA to 100 µA | 100 µA
> 100 µA to 1 mA | 1 mA
> 1 mA to 10 mA | 10 mA
> 10 mA to 100 mA | 100 mA
> 100 mA to 1 A | 1 A
Resistance
0 Ω to 1 Ω | 1 Ω
> 1 Ω to 10 Ω | 10 Ω
> 10 Ω to 100 Ω | 100 Ω
> 100 Ω to 1 kΩ | 1 kΩ
> 1 kΩ to 10 kΩ | 10 kΩ
> 10 kΩ to 100 kΩ | 100 kΩ
> 100 kΩ to 1 MΩ | 1 MΩ
> 1 MΩ to 10 MΩ | 10 MΩ

Tolerance

This field is not used.

MOD1

This field is not used.

MOD2

This field controls the safety delay override and settling delay.

blank | Safety Delay Override off / wait for Output On SRQ
D0 | Safety Delay Override off / driver settling delay
D1 | Safety Delay Override on / driver settling delay
DX | Safety Delay Override on / no driver settling delay

Rules:

  1. MOD2 blank is for compatibility with MET/CAL 6.10, 6.11, and 6.11A. These versions of MET/CAL used the Output On SRQ to determine when the output was present. This required first setting the 4000 to standby for each 4000 statement.
  2. MOD2 D0 is the recommended mode for procedures used to calibrate manual DMMs.
  3. MOD2 D1 is the recommended mode for procedures used to calibrate remote controlled DMMs (i.e. closed-loop procedures).
  4. MOD2 DX is for procedure writers who wish to optimize performance by implementing their own settling delay using the IEEE or PORT FSC.
MOD2 4000 FSC Execution Sequence
blank
  1. Set the Safety Delay Override to Off (safety delay active).
  2. Set the 4000 to standby.
  3. Setup the 4000 to the desired state; function, range, etc.
  4. Set the 4000 to operate and wait for the Output On SRQ.
  5. Wait an additional 1 second.
D0
  1. Set the Safety Delay Override to Off (safety delay active).
  2. Setup the 4000 to the desired state; function, range, etc.
  3. Set the 4000 to operate.
  4. If DCV > 110V wait 3 seconds.
  5. Wait an additional 1 second.
D1
  1. Set the Safety Delay Override to On (safety delay inactive).
  2. Setup the 4000 to the desired state; function, range, etc.
  3. Set the 4000 to operate.
  4. Wait an additional 1 second
DX
  1. Set the Safety Delay Override to On (safety delay inactive).
  2. Setup the 4000 to the desired state; function, range, etc.
  3. Set the 4000 to operate.
When MOD2 is set to DX, the FSC does not perform ANY settling delay. Therefore when MOD2 DX is used in a closed-loop procedure, the procedure writer is responsible for implementing any required settling delay using the IEEE or PORT FSC.

MOD3

This field is not used.

MOD4

This field is not used.

CON

This field is not used.

Examples

See 4000 FSC.


4200 and 4200A

4200 and 4200 A Instrument FSCs

Description

The 4200 FSC controls Datron 4200 Autocal AC Standard.

The 4200A FSC controls Datron 4200A Autocal AC Standard.

The following functions are supported:

  • AC Voltage
  • AC Current with Option 30 installed

The M4200 and M4200A FSCs are used for control the following:

  • Range Locking
  • Safety Delay Override
  • Driver Settling Delay
The 4200 FSC can be used to control a 4200A. In this case the 4000A accuracy file will be used at run time.

Functional Capability

Function | Amplitude | Frequency
AC Voltage | 100 μV to 19.99999 V | 10 Hz to 1 MHz
20 V to 100 V | 10 Hz to 200 kHz
100 V to 199.9999 V | 10 Hz to 100 kHz 1
200 V to 1100 V | 45 Hz to 33 kHz
AC Current 2 | 100 μA to 1.999999 A | 10 Hz to 5 kHz
  1. V x Hz product not to exceed 20E+6
  2. Requires Option 30

Parameters

RANGE

This field specifies the UUT range as described in the RANGE Field topic.

NOMINAL

This field specifies one of the following.

  • Voltage (RMS) entered as: [numeric][prefix]V
  • Current entered as [numeric][prefix]A.
  • Frequency entered as [numeric][prefix]H.
  • Reset entered as *.

Rules:

  1. When the NOMINAL field specifies frequency or period, the MOD1 field must specify voltage or current.

TOLERANCE

This field specifies the UUT tolerance as described in the TOLERANCE Field topic.

MOD1

This field specifies one of the following:

  • Voltage (RMS) entered as: [numeric][prefix]V
  • Current entered as [numeric][prefix]A.
  • Frequency entered as [numeric][prefix]H.

Rules:

  1. The MOD1 field may specify frequency or period only when the NOMINAL field specifies voltage or current.
  2. The MOD1 field may specify voltage or current only when the NOMINAL field specifies frequency or period.

MOD2

This field is not used and must be blank.

MOD3

This field is not used and must be blank.

MOD4

This field specifies the type of test being performed as described in the MOD4 Field topic.

CON

This field specifies the UUT connection.

  • 2 W2-wire
  • 4 W4-wire

Rules:

  1. 2 W is automatically entered in the CON field when no CON field code is entered.
  2. The CON field may specify 4 W only for AC Voltage = 200 mV.

Use of Standard Memory Locations and Results Reporting

System memory locations MEM and MEM1 are used. For more information, refer to the Use of Standard Memory Registers topic.

Examples

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
  1.001  4200         *                                                 S
  1.002  4200   200   220mV          10%           50H                     2W
  2.001  4200   1000  1000V          1U            1kH                     4W
  3.001  4200   2     1.999A         1% 1/         1kH                     2W
  4.001  4200A        mV             0.1U          50H                     2W
  5.001  4200A        A              5%            1kH                     2W
  6.001  4200         1.999A                       1kH                  S  2W
  6.002  4200   10    20mV           0.5%          1kH                  C  2W


M4200 and M4200A

Auxiliary Instrument Setup FSCs

Description

The M4200 and M4200A FSCs are used for control range locking, safety delay override, driver settling delay.

Parameters

Range

This field specifies one of the following:

RNGLK | Range Lock
blank | field not applicable

Nominal

This field specifies the range selection value or a reset to autorange.

  • Range selection value entered as numeric[prefix]V or A
  • Reset (autorange) entered as “*”

Rules:

  1. “*” is automatically inserted in the NOMINAL field when a blank M4200 statement is entered.
  2. The NOMINAL field may specify a range selection value only when the RANGE field specifies RNGLK.
Range Selection Value | Locked Range
Voltage
0 mV to 1 mV | 1 mV
>1 mV to 10 mV | 10 mV
>10 mV to 100 mV | 100 mV
>100 mV to 1 V | 1 V
>1 V to 10 V | 10 V
>10 V to 100 V | 100 V
>100 V to 1000 V | 1000 V
Current
0 µA to 100 µA | 100 µA
>100 µA to 1 mA | 1 mA
>1 mA to 10 mA | 10 mA
>10 mA to 100 mA | 100 mA
>100 mA to 1 A | 1 A

Tolerance

This field is not used.

MOD1

This field is not used.

MOD2

This field controls the safety delay override and settling delay.

blank | Safety Delay Override off / wait for Output On SRQ
D0 | Safety Delay Override off / driver settling delay
D1 | Safety Delay Override on / driver settling delay
DX | Safety Delay Override on / no driver settling delay

Rules:

  1. MOD2 blank is for compatibility with MET/CAL 6.10, 6.11, and 6.11 A. These versions of MET/CAL used the Output On SRQ to determine when the output was present. This required first setting the 4200 to standby for each 4200 statement.
  2. MOD2 D0 is the recommended mode for procedures used to calibrate manual DMMS.
  3. MOD2 D1 is the recommended mode for procedures used to calibrate remote controlled DMMs (i.e. closed-loop procedures).
  4. MOD2 DX is for procedure writers who wish to optimize performance by implementing their own settling delay using the IEEE or PORT FSC.
MOD2 4200 FSC Execution Sequence
blank
  1. Set the Safety Delay Override to Off (safety delay active).
  2. Set the 4200 to standby.
  3. Setup the 4200 to the desired state; function, range, etc.
  4. Set the 4200 to operate and wait for the Output On SRQ.
  5. Wait an additional delay as defined below.
D0
  1. Set the Safety Delay Override to Off (safety delay active).
  2. Setup the 4200 to the desired state; function, range, etc.
  3. Set the 4200 to operate.
  4. If ACV > 110 V wait 3 seconds.
  5. Wait an additional delay as defined below.
D1
  1. Set the Safety Delay Override to On (safety delay inactive).
  2. Setup the 4200 to the desired state; function, range, etc.
  3. Set the 4200 to operate.
  4. Wait an additional delay as defined below.
DX
  1. Set the Safety Delay Override to On (safety delay inactive).
  2. Setup the 4200 to the desired state; function, range, etc.
  3. Set the 4200 to operate.
When MOD2 is set to DX, the FSC does not perform ANY settling delay. Therefore when MOD2 DX is used in a closed-loop procedure, the procedure writer is responsible for implementing any required settling delay using the IEEE or PORT FSC.

Additional Settling Delay

MOD2 blank, D0, & D1

frequency ≤33 Hz: | wait 10 seconds
frequency ≤330 Hz: | wait 3 seconds
otherwise: | wait 1 second

MOD3

This field is not used.

MOD4

This field is not used.

CON

This field is not used.

Examples

See 4200 FSC.


4700

4700 Instrument FSC

Description

The 4700 FSC controls the following functions of the Datron 4700 Multifunction Calibrator:

  • DC Voltage
  • AC Voltage
  • DC Current with Option 20
  • AC Current with Option 20
  • Resistance with Option 20
  • DC Current from the 4600 Transconductance Amplifier
  • AC Current from the 4600 Transconductance Amplifier

The M4700 FSC is used to control the following:

  • Range Locking
  • Safety Delay Override
  • Driver Settling Delay
The 4700 FSC can also be used to control a 4800, 4800A, 4707, 4708, or 4808. The accuracy file corresponding to the instrument that is actually configured is used at run time.

Functional Capability

Function | Amplitude | Frequency | MOD3
DC Voltage | -199.9999 V to 199.99999 V
-1100 V to 1100 V 1
AC Voltage | 90 uV to 19.99999 V | 10 Hz to 1 MHz
90 uV to 199.9999 V | 10 Hz to 100 kHz
90 uV to 1100 V 1 | 10 Hz to 33 kHz
DC Current | -1.999999 A to 1.999999 A 2 | BC
-11 A to 11 A 3,2
AC Current | 9 uA to 1.999999 A 2 | 10 Hz to 5 kHz | BC
100 mA to 11 A 3,2 | 10 Hz to 20 kHz
Resistance or Conductance 2 | 10 Ohm to 100 MOhm, 100 mS to 10 nS (in decade steps)
  1. Requires Option 10, 1000 V Ranges (DCV & ACV)
  2. Requires Option 20, DC Current, AC Current, and Resistance Functions
  3. Requires Option 60, 4600 Transconductance Amplifier

Parameters

RANGE

This field specifies the UUT range as described in the RANGE Field topic.

NOMINAL

This field specifies one of the following.

  • Voltage (DC or RMS) entered as: [numeric][prefix]V
  • Current entered as [numeric][prefix]A.
  • Resistance entered as [numeric][prefix]Z.
  • Conductance entered as [numeric][prefix]Y.
  • Frequency entered as [numeric][prefix]H.
  • Reset entered as *.

Rules:

  1. When the NOMINAL field specifies frequency or period, the MOD1 field must specify voltage or current.

TOLERANCE

This field specifies the UUT tolerance as described in the TOLERANCE Field topic.

MOD1

This field specifies one of the following for AC signals.

  • Voltage (RMS) entered as: [numeric][prefix]V
  • Current entered as [numeric][prefix]A.
  • Frequency entered as [numeric][prefix]H.
  • blank DC or not applicable

Rules:

  1. The MOD1 field may specify frequency or period only when the NOMINAL field specifies voltage or current.
  2. The MOD1 field may specify voltage or current only when the NOMINAL field specifies frequency or period.
  3. The MOD1 field must be blank when the NOMINAL field specifies resistance or conductance.

MOD2

This field allows you to specify negative zero for DC Voltage or DC Current.

-Z | Negative Zero
blank | All other amplitudes

Rules:

  1. The MOD2 field may specify Z only for DC Voltage or DC Current when the Nominal value is zero.

MOD3

This field specifies one of the following:

BC | use 4600 for current boost
blank | No boost or not applicable

Rules:

  1. If the current can be created only by the Boost Amplifier, BC is inserted automatically.

MOD4

This field specifies the type of test being performed as described in the MOD4 Field topic.

CON

This field specifies the UUT connection.

  • 2W2-wire
  • 4W4-wire

Rules:

  1. 2W is automatically entered in the CON field when no CON field code is entered.
  2. The CON field may specify 4W only for resistance, conductance, and DC Voltage and AC Voltage ≥ 200mV.

Use of Standard Memory Locations and Results Reporting

System memory locations MEM and MEM1 are used. For more information, refer to the Use of Standard Memory Registers topic.

Examples

  1.001  4700         *                                                 S
  1.002  4700   1000  1100V          1U 1/                                 2W
  2.001  4700   10    0V             1U                                    2W
  3.001  4700   200   220mV          10%           50H                     2W
  4.001  4700   1000  1100V          1U            1kH                     4W
  5.001  4700   100   -22uA          10%                                   2W
  6.001  4700   2     1.999A         1% 1/         1kH                     2W
  7.001  4700   A     mV             0.1U          50H                     2W
  8.001  4700   A     A              5%            1kH                     2W
  9.001  4700         1.999A                       1kH                  S  2W
  9.002  4700   10    20mV                         500H                 N  2W
  9.003  4700   10    20mV           0.5%          1kH                  C  2W
 10.001  4700   A     10Z            5%                                    4W


M4700

Auxiliary Instrument Setup FSC

Description

The M4700 FSC is used for control range locking, safety delay override, driver settling delay.

Parameters

RANGE

This field specifies one of the following:

RNGLK | Range Lock
blank | field not applicable

NOMINAL

This field specifies the range selection value or a reset to autorange.

  • Range selection value entered as numeric[prefix]V, A, or Z
  • Reset (autorange) entered as “*”

Rules:

  1. “*” is automatically inserted in the NOMINAL field when a blank M4000 statement is entered.
  2. The NOMINAL field may specify a range selection value only when the RANGE field specifies RNGLK.
Range Selection Value | Locked Range
0 μV to 100 μV | 100 μV DC, 1 mV AC
>100 μV to 1 mV | 1 mV
>1 mV to 10 mV | 10 mV
>10 mV to 100 mV | 100 mV
>100 mV to 1 V | 1 V
>1 V to 10 V | 10 V
>10 V to 100 V | 100 V
>100 V to 1000 V | 1000 V
0 μA to 100 μA | 100 μA
>100 μA to 1 mA | 1 mA
>1 mA to 10 mA | 10 mA
>10 mA to 100 mA | 100 mA
>100 mA to 1 A | 1 A
0 Ω to 10 Ω | 10 Ω
>10 Ω to 100 Ω | 100 Ω
>100 Ω to 1 kΩ | 1 kΩ
>1 kΩ to 10 kΩ | 10 kΩ
>10 kΩ to 100 kΩ | 100 kΩ
>100 kΩ to 1 MΩ | 1 MΩ
>1 MΩ to 10 MΩ | 10 MΩ
>10 MΩ to 100 MΩ | 100 MΩ

Tolerance

This field is not used.

MOD1

This field is not used.

MOD2

This field controls the safety delay override and settling delay.

blank | Safety Delay Override off / wait for Output On SRQ
D0 | Safety Delay Override off / driver settling delay
D1 | Safety Delay Override on / driver settling delay
DX | Safety Delay Override on / no driver settling delay

Rules:

  1. MOD2 blank is for compatibility with MET/CAL 6.10, 6.11, and 6.11A. These versions of MET/CAL used the Output On SRQ to determine when the output was present. This required first setting the 4700 to standby for each 4700 statement.
  2. MOD2 D0 is the recommended mode for procedures used to calibrate manual DMMs.
  3. MOD2 D1 is the recommended mode for procedures used to calibrate remote controlled DMMs (i.e. closed-loop procedures).
  4. MOD2 DX is for procedure writers who wish to optimize performance by implementing their own settling delay using the IEEE or PORT FSC.
MOD2 4700 FSC Execution Sequence
blank
  1. Set the Safety Delay Override to Off (safety delay active).
  2. Set the 4700 to standby.
  3. Setup the 4700 to the desired state; function, range, etc.
  4. Set the 4700 to operate and wait for the Output On SRQ.
  5. Wait an additional delay as defined below.
D0
  1. Set the Safety Delay Override to Off (safety delay active).
  2. Setup the 4700 to the desired state; function, range, etc.
  3. Set the 4700 to operate.
  4. If DCV or ACV > 110 V wait 3 seconds.
  5. Wait an additional delay as defined below.
D1
  1. Set the Safety Delay Override to On (safety delay inactive).
  2. Setup the 4700 to the desired state; function, range, etc.
  3. Set the 4700 to operate.
  4. Wait an additional delay as defined below.
DX
  1. Set the Safety Delay Override to On (safety delay inactive).
  2. Setup the 4700 to the desired state; function, range, etc.
  3. Set the 4700 to operate.
When MOD2 is set to DX, the FSC does not perform ANY settling delay. Therefore when MOD2 DX is used in a closed-loop procedure, the procedure writer is responsible for implementing any required settling delay using the IEEE or PORT FSC.

Additional Settling Delay

MOD2 blank, D0, & D1

DC Voltage, DC Current, & Resistance | wait 1 second
AC Voltage & AC Current |
frequency ≤ 33 Hz | wait 10 seconds
frequency ≤ 330 Hz | wait 3 seconds
otherwise | wait 1 second

MOD3

This field is not used.

MOD4

This field is not used.

CON

This field is not used.

Examples

See 4000 FSC.


4705

Instrument FSC

Description

The 4705 FSC controls the following functions of the Datron 4705 Multifunction Calibrator:

  • DC Voltage
  • AC Voltage
  • DC Current
  • AC Current
  • Resistance
  • DC Current from the 4600 Transconductance Amplifier
  • AC Current from the 4600 Transconductance Amplifier

The M4705 FSC is used to control the following:

  • Range Locking
  • Safety Delay Override
  • Driver Settling Delay
The 4705 FSC can also be used to control 4700, 4800, 4800A, 4707, 4708, or 4808. The accuracy file corresponding to the instrument that is actually configured is used at run time.

Functional Capability

Function | Amplitude | Frequency | MOD3

DC Voltage

-1100 V to 1100 V

AC Voltage

90 μV to 199.9999 V

10 Hz to 100 kHz
90 μV to 1100 V | 45 Hz to 33 kHz

DC Current

-1.99999 A to 1.99999 A

BC
-11 A to 11 A1

AC Current

9 μA to 1.99999 A

10 Hz to 5 kHz

BC
100 mA to 11 A1 | 10 Hz to 20 kHz

Resistance or Conductance

10 Ω to 100 MΩ, 100 mS to 10 nS (in decade steps)

  1. Requires 4600 Transconductance Amplifier

Parameters

RANGE

This field specifies the UUT range as described in the RANGE Field topic.

NOMINAL

This field specifies one of the following.

  • Voltage (DC or RMS) entered as: [numeric][prefix]V.
  • Current entered as [numeric][prefix]A.
  • Resistance entered as [numeric][prefix]Z.
  • Conductance entered as [numeric][prefix]Y.
  • Frequency entered as [numeric][prefix]H.
  • Reset entered as *.

Rules:

  1. When the NOMINAL field specifies frequency or period, the MOD1 field must specify voltage or current.

TOLERANCE

This field specifies the UUT tolerance as described in the TOLERANCE Field topic.

MOD1

This field specifies one of the following for AC signals.

  • Voltage (RMS) entered as: [numeric][prefix]V
  • Current entered as [numeric][prefix]A.
  • Frequency entered as [numeric][prefix]H.
  • blank DC or not applicable

Rules:

  1. The MOD1 field may specify frequency or period only when the NOMINAL field specifies voltage or current.
  2. The MOD1 field may specify voltage or current only when the NOMINAL field specifies frequency or period.
  3. The MOD1 field must be blank when the NOMINAL field specifies resistance or conductance.

MOD2

This field allows you to specify negative zero for DC Voltage or DC Current.

-Z | Negative Zero
blank | All other amplitudes

Rules:

  1. The MOD2 field may specify Z only for DC Voltage or DC Current when the Nominal value is zero.

MOD3

This field specifies one of the following:

BC | use 4600 for current boost
blank | No boost or not applicable

Rules:

  1. If the current can be created only by the Boost Amplifier, BC is inserted automatically.

MOD4

This field specifies the type of test being performed as described in the MOD4 Field topic.

CON

This field specifies the UUT connection.

  • 2W 2-wire
  • 4W 4-wire

Rules:

  1. 2W is automatically entered in the CON field when no CON field code is entered.
  2. The CON field may specify 4W only for resistance, conductance, and DC Voltage and AC Voltage = 200 mV.

Use of Standard Memory Locations and Results Reporting

System memory locations MEM and MEM1 are used. For more information, refer to the Use of Standard Memory Registers topic.

Examples

  1.001  4708         *                                                 S
  1.002  4708   1000  1100V          1U 1/                                 2W
  2.001  4708   10    0V             1U                                    2W
  3.001  4708   200   220mV          10%           50H                     2W
  4.001  4708   1000  1100V          1U            1kH                     4W
  5.001  4708   100   -22uA          10%                                   2W
  6.001  4708   2     1.999A         1% 1/         1kH                     2W
  7.001  4708   A     mV             0.1U          50H                     2W
  8.001  4708   A     A              5%            1kH                     2W
  9.001  4708         1.999A                       1kH                  S  2W
  9.002  4708   10    20mV                         500H                 N  2W
  9.003  4708   10    20mV           0.5%          1kH                  C  2W
 10.001  4708   A     10Z            5%                                    4W


M4705

Auxiliary Instrument Setup FSC

Description

The M4705 FSC is used for control range locking, safety delay override, driver settling delay.

Parameters

RANGE

This field specifies one of the following:

RNGLK | Range Lock
blank | field not applicable

NOMINAL

This field specifies the range selection value or a reset to autorange.

  • Range selection value entered as numeric[prefix]V, A, or Z
  • Reset (autorange) entered as “*”

Rules:

  1. “*” is automatically inserted in the NOMINAL field when a blank M4000 statement is entered.
  2. The NOMINAL field may specify a range selection value only when the RANGE field specifies RNGLK.
Range Selection Value | Locked Range
0 μV to 100 μV | 100 μV DC, 1 mV AC
>100 μV to 1 mV | 1 mV
>1 mV to 10 mV | 10 mV
>10 mV to 100 mV | 100 mV
>100 mV to 1 V | 1 V
>1 V to 10 V | 10 V
>10 V to 100 V | 100 V
>100 V to 1000 V | 1000 V
0 μA to 100 μA | 100 μA
>100 μA to 1 mA | 1 mA
>1 mA to 10 mA | 10 mA
>10 mA to 100 mA | 100 mA
>100 mA to 1 A | 1 A
0 Ω to 10 Ω | 10 Ω
>10 Ω to 100 Ω | 100 Ω
>100 Ω to 1 kΩ | 1 kΩ
>1 kΩ to 10 kΩ | 10 kΩ
>10 kΩ to 100 kΩ | 100 kΩ
>100 kΩ to 1 MΩ | 1 MΩ
>1 MΩ to 10 MΩ | 10 MΩ
>10 MΩ to 100 MΩ | 100 MΩ

TOLERANCE

This field is not used.

MOD1

This field is not used.

MOD2

This field controls the safety delay override and settling delay.

blank | Safety Delay Override off / wait for Output On SRQ
D0 | Safety Delay Override off / driver settling delay
D1 | Safety Delay Override on / driver settling delay
DX | Safety Delay Override on / no driver settling delay

Rules:

  1. MOD2 blank is for compatibility with MET/CAL 6.10, 6.11, and 6.11A. These versions of MET/CAL used the Output On SRQ to determine when the output was present. This required first setting the 4705 to standby for each 4705 statement.
  2. MOD2 D0 is the recommended mode for procedures used to calibrate manual DMMs.
  3. MOD2 D1 is the recommended mode for procedures used to calibrate remote controlled DMMs (i.e. closed-loop procedures).
  4. MOD2 DX is for procedure writers who wish to optimize performance by implementing their own settling delay using the IEEE or PORT FSC.
MOD2 4705 FSC Execution Sequence
blank
  1. Set the Safety Delay Override to Off (safety delay active).
  2. Set the 4705 to standby.
  3. Setup the 4705 to the desired state; function, range, etc.
  4. Set the 4705 to operate and wait for the Output On SRQ.
  5. Wait an additional delay as defined below.
D0
  1. Set the Safety Delay Override to Off (safety delay active).
  2. Setup the 4705 to the desired state; function, range, etc.
  3. Set the 4705 to operate.
  4. If DCV or ACV >110 V wait 3 seconds.
  5. Wait an additional delay as defined below.
D1
  1. Set the Safety Delay Override to On (safety delay inactive).
  2. Setup the 4705 to the desired state; function, range, etc.
  3. Set the 4705 to operate.
  4. Wait an additional delay as defined below.
DX
  1. Set the Safety Delay Override to On (safety delay inactive).
  2. Setup the 4705 to the desired state; function, range, etc.
  3. Set the 4705 to operate.
When MOD2 is set to DX, the FSC does not perform ANY settling delay. Therefore when MOD2 DX is used in a closed-loop procedure, the procedure writer is responsible for implementing any required settling delay using the IEEE or PORT FSC.

Additional Settling Delay

MOD2 blank, D0, & D1

DC Voltage, DC Current, & Resistance | wait 1 second
AC Voltage & AC Current |
frequency ≤ 330 Hz | wait 3 seconds
otherwise | wait 1 second

MOD3

This field is not used.

MOD4

This field is not used.

CON

This field is not used.

Examples

See 4000 FSC.


4707

Instrument FSC

Description

The 4707 FSC controls the following functions of the Datron 4707 Multifunction Calibrator:

  • DC Voltage
  • AC Voltage
  • DC Current with Option 27
  • AC Current with Option 27
  • Resistance with Option 27
  • DC Current from the 4600 Transconductance Amplifier
  • AC Current from the 4600 Transconductance Amplifier

The M4707 FSC is used to control the following:

  1. Range Locking
  2. Safety Delay Override
  3. Driver Settling Delay
The 4707 FSC can also be used to control a 4708 or 4808. The accuracy file corresponding to the instrument that is actually configured is used at run time.

Functional Capability

Function | Amplitude | Frequency | MOD3

DC Voltage

-199.9999 V to 199.99999 V
-1100 V to 1100 V 1

AC Voltage

90 μV to 19.99999 V

10 Hz to 1 MHz
90 μV to 199.9999 V | 10 Hz to 100 kHz
90 μV to 1100 V 1 | 10 Hz to 33 kHz

DC Current

-1.999999 A to 1.999999 A 2

BC
-11 A to 11 A 3,2

AC Current 2

9 uA to 1.999999 A

10 Hz to 5 kHz

BC

100 mA to 11 A 3,2 | 10 Hz to 20 kHz
Resistance or Conductance 2 | 10 Ω to 100 MΩ, 100 mS to 10 nS (in decade steps)
  1. Requires Option 17, 1000 V Ranges (DCV & ACV)
  2. Requires Option 27, DC Current, AC Current, and Resistance Functions
  3. Requires Option 60, 4600 Transconductance Amplifier

Parameters

RANGE

This field specifies the UUT range as described in the RANGE Field topic.

NOMINAL

This field specifies one of the following.

  • Voltage (DC or RMS) entered as: [numeric][prefix]V
  • Current entered as [numeric][prefix]A.
  • Resistance entered as [numeric][prefix]Z.
  • Conductance entered as [numeric][prefix]Y.
  • Frequency entered as [numeric][prefix]H.
  • Reset entered as *.

Rules:

  1. When the NOMINAL field specifies frequency or period, the MOD1 field must specify voltage or current.

TOLERANCE

This field specifies the UUT tolerance as described in the TOLERANCE Field topic.

MOD1

This field specifies one of the following for AC signals.

  • Voltage (RMS) entered as: [numeric][prefix]V
  • Current entered as [numeric][prefix]A.
  • Frequency entered as [numeric][prefix]H.
  • blank DC or not applicable

Rules:

  1. The MOD1 field may specify frequency or period only when the NOMINAL field specifies voltage or current.
  2. The MOD1 field may specify voltage or current only when the NOMINAL field specifies frequency or period.
  3. The MOD1 field must be blank when the NOMINAL field specifies resistance or conductance.

MOD2

This field allows you to specify negative zero for DC Voltage or DC Current.

-Z | Negative Zero
blank | All other amplitudes

Rules:

  1. The MOD2 field may specify Z only for DC Voltage or DC Current when the Nominal value is zero.

MOD3

This field specifies one of the following:

BC | Use 4600 for current boost
blank | No boost or not applicable

Rules:

  1. If the current can be created only by the Boost Amplifier,BC is inserted automatically.

MOD4

This field specifies the type of test being performed as described in the MOD4 Field topic.

CON

This field specifies the UUT connection.

  • 2W 2-wire
  • 4W 4-wire

Rules:

  1. 2W is automatically entered in the CON field when no CON field code is entered.
  2. The CON field may specify 4W only for resistance, conductance, and DC Voltage and AC Voltage ≥ 200 mV.

Use of Standard Memory Locations and Results Reporting

System memory locations MEM and MEM1 are used. For more information, refer to the Use of Standard Memory Registers topic.

Examples

  1.001  4707         *                                                 S
  1.002  4707   1000  1100V          1U 1/                                 2W
  2.001  4707   10    0V             1U                                    2W
  3.001  4707   200   220mV          10%           50H                     2W
  4.001  4707   1000  1100V          2U            1kH                     4W
  5.001  4707   100   -22uA          10%                                   2W
  6.001  4707   2     1.999A         1% 1/         1kH                     2W
  7.001  4707   A     mV             0.1U          50H                     2W
  8.001  4707   A     A              5%            1kH                     2W
  9.001  4707         1.999A                       1kH                  S  2W
  9.002  4707   10    20mV                         500H                 N  2W
  9.003  4707   10    20mV           1%            1kH                  C  2W
 10.001  4707   A     10Z            5%                                    4W


M4707

Auxiliary Instrument Setup FSC

Description

The M4707 FSC is used for control range locking, safety delay override, driver settling delay.

Parameters

RANGE

This field specifies one of the following:

RNGLK | Range Lock
blank | field not applicable

NOMINAL

This field specifies the range selection value or a reset to autorange.

  • Range selection value entered as numeric[prefix]V, A, or Z
  • Reset (autorange) entered as “*”

Rules:

  1. “*” is automatically inserted in the NOMINAL field when a blank M4000 statement is entered.
  2. The NOMINAL field may specify a range selection value only when the RANGE field specifies RNGLK.
Range Selection Value | Locked Range
0 μV to 100 μV | 100 μV DC, 1 mV AC
>100 μV to 1 mV | 1 mV
>1 mV to 10 mV | 10 mV
>10 mV to 100 mV | 100 mV
>100 mV to 1 V | 1 V
>1 V to 10 V | 10 V
>10 V to 100 V | 100 V
>100 V to 1000 V | 1000 V
0 μA to 100 uA | 100 μA
>100 μA to 1 mA | 1 mA
>1 mA to 10 mA | 10 mA
>10 mA to 100 mA | 100 mA
>100 mA to 1 A | 1 A
0 Ω to 10 Ω | 10 Ω
>10 Ω to 100 Ω | 100 Ω
>100 Ω to 1 kΩ | 1 kΩ
>1 kΩ to 10 kΩ | 10 kΩ
>10 kΩ to 100 kΩ | 100 kΩ
>100 kΩ to 1 MΩ | 1 MΩ
>1 MΩ to 10 MΩ | 10 MΩ
>10 MΩ to 100 MΩs | 100 MΩ

Tolerance

This field is not used.

MOD1

This field is not used.

MOD2

This field controls the safety delay override and settling delay.

blank | Safety Delay Override off / wait for Output On SRQ
D0 | Safety Delay Override off / driver settling delay
D1 | Safety Delay Override on / driver settling delay
DX | Safety Delay Override on / no driver settling delay

Rules:

  1. MOD2 blank is for compatibility with MET/CAL 6.10, 6.11, and 6.11A. These versions of MET/CAL used the Output On SRQ to determine when the output was present. This required first setting the 4707 to standby for each 4707 statement.
  2. MOD2 D0 is the recommended mode for procedures used to calibrate manual DMMs.
  3. MOD2 D1 is the recommended mode for procedures used to calibrate remote controlled DMMs (i.e. closed-loop procedures).
  4. MOD2 DX is for procedure writers who wish to optimize performance by implementing their own settling delay using the IEEE or PORT FSC.
MOD2 4707 FSC Execution Sequence
blank
  1. Set the Safety Delay Override to Off (safety delay active).
  2. Set the 4707 to standby.
  3. Setup the 4707 to the desired state; function, range, etc.
  4. Set the 4707 to operate and wait for the Output On SRQ.
  5. Wait an additional delay as defined below.
D0
  1. Set the Safety Delay Override to Off (safety delay active).
  2. Setup the 4707 to the desired state; function, range, etc.
  3. Set the 4707 to operate.
  4. If DCV or ACV > 110V wait 3 seconds.
  5. Wait an additional delay as defined below.
D1
  1. Set the Safety Delay Override to On (safety delay inactive).
  2. Setup the 4707 to the desired state; function, range, etc.
  3. Set the 4707 to operate.
  4. Wait an additional delay as defined below.
DX
  1. Set the Safety Delay Override to On (safety delay inactive).
  2. Setup the 4707 to the desired state; function, range, etc.
  3. Set the 4707 to operate.
When MOD2 is set to DX, the FSC does not perform ANY settling delay. Therefore when MOD2 DX is used in a closed-loop procedure, the procedure writer is responsible for implementing any required settling delay using the IEEE or PORT FSC.

Additional Settling Delay

MOD2 blank, D0, & D1

DC Voltage, DC Current & Resistance | wait 1 second
AC Voltage & AC Current: |
frequency ≤ 33Hz: | wait 10 seconds
frequency ≤ 330Hz: | wait 3 seconds
otherwise: | wait 1 second

MOD3

This field is not used.

MOD4

This field is not used.

CON

This field is not used.

Examples

See 4000 FSC.


4708

Instrument FSC

Description

The 4708 FSC controls the following functions of the Datron 4708 Multifunction Calibrator:

  • DC Voltage with Option 10 installed
  • AC Voltage with Option 20 installed
  • DC Current with Option 30 and Option 10 installed
  • AC Current with Option 30 and Option 20 installed
  • Resistance with Option 30 and Option 10 or 20 installed
  • DC Current from the 4600 Transconductance Amplifier
  • AC Current from the 4600 Transconductance Amplifier

The M4708 FSC is used to control the following:

  • Range Locking
  • Safety Delay Override
  • Driver Settling Delay
The 4708 FSC can also be used to control a 4808. The accuracy file corresponding to the instrument that is actually configured is used at run time.

Functional Capability

Function | Amplitude | Frequency | MOD3
DC Voltage 1 | -1100 V to 1100 V
AC Voltage 2 | 90 μV to 19.99999 V | 10 Hz to 1 MHz
90 μV to 100.0000 V | 10 Hz to 200 kHz
90 μV to 750 V | 10 Hz to 100 kHz
90 μV to 1100 V | 10 Hz to 33 kHz
DC Current 1,3 | -1.99999 A to 1.99999 A | BC
-11 A to 11 A 1,3,4
AC Current 2,3 | 9 μA to 1.99999 A | 10 Hz to 5 kHz | BC
100 mA to 11 A 2,3,4 | 10 Hz to 20 kHz
Resistance or Conductance 3 | 10 Ω to 100 MΩ, 100 mS to 10 nS (in decade steps)
  1. Requires Option 10, DC Voltage
  2. Requires Option 20, AC Voltage
  3. Requires Option 30, Ohms and Current
  4. Requires 4600 Transconductance Amplifier

Parameters

RANGE

This field specifies the UUT range as described in the RANGE Field topic.

NOMINAL

This field specifies one of the following.

  • Voltage (DC or RMS) entered as: [numeric][prefix]V
  • Current entered as [numeric][prefix]A.
  • Resistance entered as [numeric][prefix]Z.
  • Conductance entered as [numeric][prefix]Y.
  • Frequency entered as [numeric][prefix]H.
  • Reset entered as *.

Rules:

  1. When the NOMINAL field specifies frequency or period, the MOD1 field must specify voltage or current.

TOLERANCE

This field specifies the UUT tolerance as described in the TOLERANCE Field topic.

MOD1

This field specifies one of the following for AC signals.

  • Voltage (RMS) entered as: [numeric][prefix]V
  • Current entered as [numeric][prefix]A.
  • Frequency entered as [numeric][prefix]H.
  • blank DC or not applicable

Rules:

  1. The MOD1 field may specify frequency or period only when the NOMINAL field specifies voltage or current.
  2. The MOD1 field may specify voltage or current only when the NOMINAL field specifies frequency or period.
  3. The MOD1 field must be blank when the NOMINAL field specifies resistance or conductance.

MOD2

This field allows you to specify negative zero for DC Voltage or DC Current.

-Z | Negative Zero
blank | All other amplitudes

Rules:

  1. The MOD2 field may specify Z only for DC Voltage or DC Current when the Nominal value is zero.

MOD3

This field specifies one of the following:

BC | use 4600 for current boost
blank | No boost or not applicable

Rules:

  1. If the current can be created only by the Boost Amplifier, BC is inserted automatically.

MOD4

This field specifies the type of test being performed as described in the MOD4 Field topic.

CON

This field specifies the UUT connection.

  • 2W 2-wire
  • 4W 4-wire

Rules:

  1. 2W is automatically entered in the CON field when no CON field code is entered.
  2. The CON field may specify 4W only for resistance, conductance, and DC Voltage and AC Voltage ≥200mV.

Use of Standard Memory Locations and Results Reporting

System memory locations MEM and MEM1 are used. For more information, refer to the Use of Standard Memory Registers topic.

Examples

  1.001  4708         *                                                 S
  1.002  4708   1000  1100V          1U 1/                                 2W
  2.001  4708   10    0V             1U                                    2W
  3.001  4708   200   220mV          10%           50H                     2W
  4.001  4708   1000  1100V          1U            1kH                     4W
  5.001  4708   100   -22uA          10%                                   2W
  6.001  4708   2     1.999A         1% 1/         1kH                     2W
  7.001  4708   A     mV             0.1U          50H                     2W
  8.001  4708   A     A              5%            1kH                     2W
  9.001  4708         1.999A                       1kH                  S  2W
  9.002  4708   10    20mV                         500H                 N  2W
  9.003  4708   10    20mV           0.5%          1kH                  C  2W
 10.001  4708   A     10Z            5%                                    4W


M4708

Auxiliary Instrument Setup FSC

Description

The M4708 FSC is used for control range locking, safety delay override, driver settling delay.

Parameters

RANGE

This field specifies one of the following:

RNGLK | Range Lock
blank | Field not applicable

NOMINAL

This field specifies the range selection value or a reset to autorange.

  • Range selection value entered as numeric[prefix]V, A, or Z
  • Reset (autorange) entered as “*”

Rules:

  1. “*” is automatically inserted in the NOMINAL field when a blank M4000 statement is entered.
  2. The NOMINAL field may specify a range selection value only when the RANGE field specifies RNGLK.
Range Selection Value | Locked Range
0 μV to 100 μV | 100 μV DC, 1 mV AC
>100 μV to 1 mV | 1 mV
>1 mV to 10 mV | 10 mV
>10 mV to 100 mV | 100 mV
>100 mV to 1 V | 1 V
>1 V to 10 V | 10 V
>10 V to 100 V | 100 V
>100 V to 1000 V | 1000 V
0 μA to 100 μA | 100 μA
>100 μA to 1 mA | 1 mA
>1 mA to 10 mA | 10 mA
>10 mA to 100 mA | 100 mA
>100 mA to 1 A | 1 A
0 Ω to 10 Ω | 10 Ω
>10 Ω to 100 Ω | 100 Ω
>100 Ω to 1 kΩ | 1 kΩ
>1 kΩ to 10 kΩ | 10 kΩ
>10 kΩ to 100 kΩ | 100 kΩ
>100 kΩ to 1 MΩ | 1 MΩ
>1 MΩ to 10 MΩ | 10 MΩ
>10 MΩ to 100 MΩ | 100 MΩ

TOLERANCE

This field is not used.

MOD1

This field is not used.

MOD2

This field controls the safety delay override and settling delay.

blank | Safety Delay Override off / wait for Output On SRQ
D0 | Safety Delay Override off / driver settling delay
D1 | Safety Delay Override on / driver settling delay
DX | Safety Delay Override on / no driver settling delay

Rules:

  1. MOD2 blank is for compatibility with MET/CAL 6.10, 6.11, and 6.11A. These versions of MET/CAL used the Output On SRQ to determine when the output was present. This required first setting the 4708 to standby for each 4708 statement.
  2. MOD2 D0 is the recommended mode for procedures used to calibrate manual DMMs.
  3. MOD2 D1 is the recommended mode for procedures used to calibrate remote controlled DMMs (i.e. closed-loop procedures).
  4. MOD2 DX is for procedure writers who wish to optimize performance by implementing their own settling delay using the IEEE or PORT FSC.
MOD2 4708 FSC Execution Sequence
blank
  1. Set the Safety Delay Override to Off (safety delay active).
  2. Set the 4708 to standby.
  3. Setup the 4708 to the desired state; function, range, etc.
  4. Set the 4708 to operate and wait for the Output On SRQ.
  5. Wait an additional delay as defined below.
D0
  1. Set the Safety Delay Override to Off (safety delay active).
  2. Setup the 4708 to the desired state; function, range, etc.
  3. Set the 4708 to operate.
  4. If DCV or ACV > 110V wait 3 seconds.
  5. Wait an additional delay as defined below.
D1
  1. Set the Safety Delay Override to On (safety delay inactive).
  2. Setup the 4708 to the desired state; function, range, etc.
  3. Set the 4708 to operate.
  4. Wait an additional delay as defined below.
DX
  1. Set the Safety Delay Override to On (safety delay inactive).
  2. Setup the 4708 to the desired state; function, range, etc.
  3. Set the 4708 to operate.
When MOD2 is set to DX, the FSC does not perform ANY settling delay. Therefore when MOD2 DX is used in a closed-loop procedure, the procedure writer is responsible for implementing any required settling delay using the IEEE or PORT FSC.

Additional Settling Delay

MOD2 blank, D0, & D1

DC Voltage, DC Current, & Resistance: | wait 1 second
AC Voltage & AC Current |
frequency ≤ 33 Hz | wait 10 seconds
frequency ≤ 330 Hz | wait 3 seconds
otherwise | wait 1 second

MOD3

This field is not used.

MOD4

This field is not used.

CON

This field is not used.

Examples

See 4000 FSC.


4800

Instrument FSC

Description

The 4800 FSC controls the following functions of the Datron 4800 Multifunction Calibrator:

  • DC Voltage with Option 10 installed
  • AC Voltage with Option 20 installed
  • DC Current with Option 40 and Option 10 installed
  • AC Current with Option 40 and Option 20 installed
  • Resistance with Option 50 and Option 10 or 20 installed
  • DC Current from the 4600 Transconductance Amplifier (Option 60 with Option 40 and Option 10 installed in 4800)
  • AC Current from the 4600 Transconductance Amplifier (Option 60 with Option 40 and Option 20 installed in 4800)
  • Wideband AC Voltage with Option 70 installed

The M4800 FSC is used to control the following:

  • Range Locking
  • Safety Delay Override
  • Driver Settling Delay
The 4800 FSC can also be used to control a 4800A, 4707, 4708, or 4808. The accuracy file corresponding to the instrument that is actually configured is used at run time.

Functional Capability

Function | Amplitude | Frequency | MOD3
DC Voltage 1

-199.99999 V to 199.99999 V
-1100 V to 1100 V 1,3
AC Voltage

90 uV to 19.99999 V 2

10 Hz to 1 MHz
90 uV to 199.9999 V 2 | 10 Hz to 100 kHz
100 uV to 1100 V 2,3 | 10 Hz to 33 kHz
The maximum voltage increases linearly from 199.9999 V at 10 Hz to 1100 V at 40 Hz.
DC Current

-1.99999 A to 1.99999 A 4,1

 BC
-11 A to 11 A 6,4,1
AC Current

9 μA to 1.99999 A 4,2

10 Hz to 5 kHz

 BC
100 mA to 11 A 6,4,2 | 10 Hz to 20 kHz
Resistance or Conductance 5,1,2 | 10 Ω to 100 MΩ, 100 mS to 10 nS (in decade steps)
Wideband ACV 7 | 300 μV to 3.5 V | 10 Hz to 30 MHz | W
  1. Requires Option 10, DC Voltage
  2. Requires Option 20, AC Voltage
  3. Requires Option 30, 1000 V Range
  4. Requires Option 40, Current
  5. Requires Option 50, Resistance
  6. Requires Option 60, 4600 Transconductance Amplifier
  7. Requires Option 70, Wideband ACV

Parameters

RANGE

This field specifies the UUT range as described in the RANGE Field topic.

NOMINAL

This field specifies one of the following.

  • Voltage (DC or RMS) entered as: [numeric][prefix]V
  • Current entered as [numeric][prefix]A.
  • Resistance entered as [numeric][prefix]Z.
  • Conductance entered as [numeric][prefix]Y.
  • Frequency entered as [numeric][prefix]H.
  • Reset entered as *.

Rules:

  1. When the NOMINAL field specifies frequency or period, the MOD1 field must specify voltage, decibels, or current.

TOLERANCE

This field specifies the UUT tolerance as described in the TOLERANCE Field topic.

MOD1

This field specifies one of the following for AC signals.

  • Voltage (RMS) entered as: [numeric][prefix]V
  • Current entered as [numeric][prefix]A.
  • Frequency entered as [numeric][prefix]H.
  • blank DC or not applicable

Rules:

  1. The MOD1 field may specify frequency or period only when the NOMINAL field specifies voltage, decibels, or current.
  2. The MOD1 field may specify voltage, decibels, or current only when the NOMINAL field specifies frequency or period.
  3. The MOD1 field must be blank when the NOMINAL field specifies resistance or conductance.

MOD2

This field allows you to specify negative zero for DC Voltage or DC Current.

-Z | Negative Zero
blank | All other amplitudes

Rules:

  1. The MOD2 field may specify Z only for DC Voltage or DC Current when the Nominal value is zero.

MOD3

This field specifies one of the following:

BC | Use 4600 for current boost
W | Use Option 70, Wideband output for AC Voltage
blank | No boost, wideband, or not applicable

Rules:

  1. If the current can be created only by the Boost Amplifier, BC is inserted automatically.
  2. If the amplitude and frequency combination can only be created using Option 70, Wideband AC Voltage, W is inserted automatically in the MOD3 field.

MOD4

This field specifies the type of test being performed as described in the MOD4 Field topic.

CON

This field specifies the UUT connection.

  • 2W 2-wire
  • 4W 4-wire

Rules:

  1. 2W is automatically entered in the CON field when no CON field code is entered.
  2. The CON field may not specify 4W when any of the following conditions exist:
    1. DC Current
    2. AC Current
    3. AC or DC Voltage less than 200mV

Use of Standard Memory Locations and Results Reporting

System memory locations MEM and MEM1 are used. For more information, refer to the Use of Standard Memory Registers topic.

Examples

  1.001  4800         *                                                 S
  1.002  4800   1000  1100V          1U 1/                                 2W
  2.001  4800   10    0V             1U                                    2W
  3.001  4800   200   220mV          10%           50H                     2W
  4.001  4800   1000  1100V          1U            1kH                     4W
  5.001  4800   100   -22uA          10%                                   2W
  6.001  4800   2     1.999A         1% 1/         1kH                     2W
  7.001  4800   A     mV             0.1U          50H                     2W
  8.001  4800   A     A              5%            1kH                     2W
  9.001  4800         1.999A                       1kH                  S  2W
  9.002  4800   10    20mV                         500H                 N  2W
  9.003  4800   10    20mV           0.5%          1kH                  C  2W
 10.001  4800   A     10Z            5%                                    4W


M4800

Auxiliary Instrument Setup FSC

Description

The M4800 FSC is used for control range locking, safety delay override, driver settling delay.

Parameters

RANGE

This field specifies one of the following:

RNGLK | Range Lock
blank | Field not applicable

NOMINAL

This field specifies the range selection value or a reset to autorange.

  • Range selection value entered as numeric[prefix]V, A, or Z
  • Reset (autorange) entered as “*”

Rules:

  1. “*” is automatically inserted in the NOMINAL field when a blank M4000 statement is entered.
  2. The NOMINAL field may specify a range selection value only when the RANGE field specifies RNGLK.
Range Selection Value | Locked Range
0 μV to 100 uμV | 100 μV DC, 1 mV AC
>100 μV to 1 mV | 1 mV
>1 mV to 10 mV | 10 mV
>10 mV to 100 mV | 100 mV
>100 mV to 1 V | 1 V
>1 V to 10 V | 10 V
>10 V to 100 V | 100 V
>100 V to 1000 V | 1000 V
0 μA to 100 μA | 100 μA
>100 μA to 1 mA | 1 mA
>1 mA to 10 mA | 10 mA
>10 mA to 100 mA | 100 mA
>100 mA to 1 A | 1 A
0 Ω to 10 Ω | 10 Ω
>10 Ω to 100 Ω | 100 Ω
>100 Ω to 1 kΩ | 1 kΩ
>1 kΩ to 10 kΩ | 10 kΩ
>10 kΩ to 100 kΩ | 100 kΩ
>100 kΩ to 1 MΩ | 1 MΩ
>1 MΩ to 10 MΩ | 10 MΩ
>10 MΩ to 100 MΩ | 100 MΩ

TOLERANCE

This field is not used.

MOD1

This field is not used.

MOD2

This field controls the safety delay override and settling delay.

blank | Safety Delay Override off / wait for Output On SRQ
D0 | Safety Delay Override off / driver settling delay
D1 | Safety Delay Override on / driver settling delay
DX | Safety Delay Override on / no driver settling delay

Rules:

  1. MOD2 blank is for compatibility with MET/CAL 6.10, 6.11, and 6.11A. These versions of MET/CAL used the Output On SRQ to determine when the output was present. This required first setting the 4800 to standby for each 4800 statement.
  2. MOD2 D0 is the recommended mode for procedures used to calibrate manual DMMs.
  3. MOD2 D1 is the recommended mode for procedures used to calibrate remote controlled DMMs (i.e. closed-loop procedures).
  4. MOD2 DX is for procedure writers who wish to optimize performance by implementing their own settling delay using the IEEE or PORT FSC.
MOD2 4800 FSC Execution Sequence
blank
  1. Set the Safety Delay Override to Off (safety delay active).
  2. Set the 4800 to standby.
  3. Setup the 4800 to the desired state; function, range, etc.
  4. Set the 4800 to operate and wait for the Output On SRQ.
  5. Wait an additional delay as defined below.
D0
  1. Set the Safety Delay Override to Off (safety delay active).
  2. Setup the 4800 to the desired state; function, range, etc.
  3. Set the 4800 to operate.
  4. If DCV or ACV >110 V wait 3 seconds.
  5. Wait an additional delay as defined below.
D1
  1. Set the Safety Delay Override to On (safety delay inactive).
  2. Setup the 4800 to the desired state; function, range, etc.
  3. Set the 4800 to operate.
  4. Wait an additional delay as defined below.
DX
  1. Set the Safety Delay Override to On (safety delay inactive).
  2. Setup the 4800 to the desired state; function, range, etc.
  3. Set the 4800 to operate.
When MOD2 is set to DX, the FSC does not perform ANY settling delay. Therefore when MOD2 DX is used in a closed-loop procedure, the procedure writer is responsible for implementing any required settling delay using the IEEE or PORT FSC.

Additional Settling Delay

MOD2 blank, D0, & D1

DC Voltage, DC Current, & Resistance | wait 1 second
AC Voltage & AC Current |
frequency ≤ 33 Hz | wait 10 seconds
frequency ≤ 330 Hz | wait 3 seconds
otherwise | wait 1 second

MOD3

This field is not used.

MOD4

This field is not used.

CON

This field is not used.

Examples

See 4000 FSC.


4800A

Instrument FSC

Description

The 4800A FSC controls the following functions of the Datron 4800A Multifunction Calibrator:

  • DC Voltage
  • AC Voltage
  • DC Current
  • AC Current
  • Resistance
  • DC Current from the 4600 Transconductance Amplifier (Option 60)
  • AC Current from the 4600 Transconductance Amplifier (Option 60)
  • Wideband AC Voltage with Option 70 installed

The M4800A FSC is used to control the following:

  • Range Locking
  • Safety Delay Override
  • Driver Settling Delay
The 4800A FSC can also be used to control a 4707, 4708, or 4808. The accuracy file corresponding to the instrument that is actually configured is used at run time.

Functional Capability

Function | Amplitude | Frequency | MOD3

DC Voltage

-199.99999 V to 199.99999 V
-1100 V to 1100 V

AC Voltage

90 uV to 19.99999 V

10 Hz to 1 MHz
90 uV to 199.9999 V | 10 Hz to 100 kHz
100 uV to 1100 V | 10 Hz to 33 kHz
The maximum voltage increases linearly from 199.9999 V at 10 Hz to 1100 V at 40 Hz.

DC Current

-1.99999 A to 1.99999 A

BC
-11 A to 11 A 1

AC Current

9 μA to 1.99999 A

10 Hz to 5 kHz

BC
100 mA to 11 A 1 | 10 Hz to 20 kHz

Resistance or Conductance

10 Ω to 100 MΩ, 100 mS to 10 nS (in decade steps)

Wideband ACV

300 μV to 3.5 V 2

10 Hz to 30 MHz

W

  1. Requires Option 60, 4600 Transconductance Amplifier
  2. Requires Option 70, Wideband ACV

Parameters

RANGE

This field specifies the UUT range as described in the RANGE Field topic.

NOMINAL

This field specifies one of the following.

  • Voltage (DC or RMS) entered as: [numeric][prefix]V
  • Current entered as [numeric][prefix]A.
  • Resistance entered as [numeric][prefix]Z.
  • Conductance entered as [numeric][prefix]Y.
  • Frequency entered as [numeric][prefix]H.
  • Reset entered as *.

Rules:

  1. When the NOMINAL field specifies frequency or period, the MOD1 field must specify voltage, decibels, or current.

TOLERANCE

This field specifies the UUT tolerance as described in the TOLERANCE Field topic.

MOD1

This field specifies one of the following for AC signals.

  • Voltage (RMS) entered as: [numeric][prefix]V
  • Current entered as [numeric][prefix]A.
  • Frequency entered as [numeric][prefix]H.
  • blank DC or not applicable

Rules:

  1. The MOD1 field may specify frequency or period only when the NOMINAL field specifies voltage, decibels, or current.
  2. The MOD1 field may specify voltage, decibels, or current only when the NOMINAL field specifies frequency or period.
  3. The MOD1 field must be blank when the NOMINAL field specifies resistance or conductance.

MOD2

This field allows you to specify negative zero for DC Voltage or DC Current.

-Z | Negative Zero
blank | All other amplitudes

Rules:

  1. The MOD2 field may specify Z only for DC Voltage or DC Current when the Nominal value is zero.

MOD3

This field specifies one of the following:

BC | use 4600 for current boost
W | use Option 70, Wideband output for AC Voltage
blank | No boost, wideband, or not applicable

Rules:

  1. If the current can be created only by the Boost Amplifier, BC is inserted automatically.
  2. If the amplitude and frequency combination can only be created using Option 70, Wideband AC Voltage, W is inserted automatically in the MOD3 field.`

MOD4

This field specifies the type of test being performed as described in the MOD4 Field topic.

CON

This field specifies the UUT connection.

  • 2W 2-wire
  • 4W 4-wire

Rules:

  1. 2W is automatically entered in the CON field when no CON field code is entered.
  2. The CON field may not specify 4W when any of the following conditions exist:
    1. DC Current
    2. AC Current
    3. AC or DC Voltage less than 200 mV

Use of Standard Memory Locations and Results Reporting

System memory locations MEM and MEM1 are used. For more information, refer to the Use of Standard Memory Registers topic.

Examples

  1.001  4800A        *                                                 S
  1.002  4800A  1000  1100V          1U 1/                                 2W
  2.001  4800A  10    0V             1U                                    2W
  3.001  4800A  200   220mV          10%           50H                     2W
  4.001  4800A  1000  1100V          1U            1kH                     4W
  5.001  4800A  100   -22uA          10%                                   2W
  6.001  4800A  2     1.999A         1% 1/         1kH                     2W
  7.001  4800A  A     mV             0.1U          50H                     2W
  8.001  4800A  A     A              5%            1kH                     2W
  9.001  4800A        1.999A                       1kH                  S  2W
  9.002  4800A  10    20mV                         500H                 N  2W
  9.003  4800A  10    20mV           0.5%          1kH                  C  2W
 10.001  4800A  A     100Z           5%                                    4W


M4800a

Auxiliary Instrument Setup FSC

Description

The M4800A FSC is used for control range locking, safety delay override, driver settling delay.

Parameters

RANGE

This field specifies one of the following:

RNGLK | Range Lock
blank | Field not applicable

NOMINAL

This field specifies the range selection value or a reset to autorange.

  • Range selection value entered as numeric[prefix]V, A, or Z
  • Reset (autorange) entered as “*”

Rules:

  1. “*” is automatically inserted in the NOMINAL field when a blank M4000 statement is entered.
  2. The NOMINAL field may specify a range selection value only when the RANGE field specifies RNGLK.
Range Selection Value | Locked Range
0 μV to 100 uV | 100 μV DC, 1 mV AC
>100 μV to 1 mV | 1 mV
>1 mV to 10 mV | 10 mV
>10 mV to 100 mV | 100 mV
>100 mV to 1 V | 1 V
>1 V to 10 V | 10 V
>10 V to 100 V | 100 V
>100 V to 1000 V | 1000 V
0 μA to 100 μA | 100 μA
>100 μA to 1 mA | 1 mA
>1 mA to 10 mA | 10 mA
>10 mA to 100 mA | 100 mA
>100 mA to 1 A | 1 A
0 Ω to 10 Ω | 10 Ω
>10 Ω to 100 Ω | 100 Ω
>100 Ω to 1 kΩ | 1 kΩ
>1 kΩ to 10 kΩ | 10 kΩ
>10 kΩ to 100 kΩ | 100 kΩ
>100 kΩ to 1 MΩ | 1 MΩ
>1 MΩ to 10 MOΩ | 10 MΩ
>10 MΩ to 100 MΩ | 100 MΩ

TOLERANCE

This field is not used.

MOD1

This field is not used.

MOD2

This field controls the safety delay override and settling delay.

blank | Safety Delay Override off / wait for Output On SRQ
D0 | Safety Delay Override off / driver settling delay
D1 | Safety Delay Override on / driver settling delay
DX | Safety Delay Override on / no driver settling delay

Rules:

  1. MOD2 blank is for compatibility with MET/CAL 6.10, 6.11, and 6.11A. These versions of MET/CAL used the Output On SRQ to determine when the output was present. This required first setting the 4800A to standby for each 4800A statement.
  2. MOD2 D0 is the recommended mode for procedures used to calibrate manual DMMs.
  3. MOD2 D1 is the recommended mode for procedures used to calibrate remote controlled DMMs (i.e. closed-loop procedures).
  4. MOD2 DX is for procedure writers who wish to optimize performance by implementing their own settling delay using the IEEE or PORT FSC.
MOD2 4800A FSC Execution Sequence
blank
  1. Set the Safety Delay Override to Off (safety delay active).
  2. Set the 4800A to standby.
  3. Setup the 4800A to the desired state; function, range, etc.
  4. Set the 4800A to operate and wait for the Output On SRQ.
  5. Wait an additional delay as defined below.
D0
  1. Set the Safety Delay Override to Off (safety delay active).
  2. Setup the 4800A to the desired state; function, range, etc.
  3. Set the 4800A to operate.
  4. If DCV or ACV > 110V wait 3 seconds.
  5. Wait an additional delay as defined below.
D1
  1. Set the Safety Delay Override to On (safety delay inactive).
  2. Setup the 4800A to the desired state; function, range, etc.
  3. Set the 4800A to operate.
  4. Wait an additional delay as defined below.
DX
  1. Set the Safety Delay Override to On (safety delay inactive).
  2. Setup the 4800A to the desired state; function, range, etc.
  3. Set the 4800A to operate.
When MOD2 is set to DX, the FSC does not perform ANY settling delay. Therefore when MOD2 DX is used in a closed-loop procedure, the procedure writer is responsible for implementing any required settling delay using the IEEE or PORT FSC.

Additional Settling Delay

MOD2 blank, D0, & D1

DC Voltage, DC Current, & Resistance | wait 1 second
AC Voltage & AC Current |
frequency ≤ 33 Hz | wait 10 seconds
frequency ≤ 330 Hz | wait 3 seconds
otherwise | wait 1 second

MOD3

This field is not used.

MOD4

This field is not used.

CON

This field is not used.

Examples

See 4000 FSC.


4805

Instrument FSC

Description

The 4805 FSC controls the following functions of the Datron 4805 Multifunction Calibrator:

  • DC Voltage
  • AC Voltage
  • DC Current
  • AC Current
  • Resistance
  • DC Current from the 4600 Transconductance Amplifier (Option 60)
  • AC Current from the 4600 Transconductance Amplifier (Option 60)
  • Wideband AC Voltage with Option 70 installed

The M4805 FSC is used to control the following:

  • Range Locking
  • Safety Delay Override
  • Driver Settling Delay
The 4805 FSC can be used to control any 4700 Series or 4800 Series calibrator. The accuracy file corresponding to the instrument that is actually configured is used at run time.

Functional Capability

Function | Amplitude | Frequency | MOD3

DC Voltage

-1100 V to 1100 V

AC Voltage

90 μV to 199.9999 V

10 Hz to 100 kHz
90 μV to 1100 V | 10 Hz to 33 kHz
The maximum voltage decreases linearly from 1100 V at 40 Hz to 199.9999 V at 10 Hz.

DC Current

-1.99999 A to 1.99999 A

BC
-11 A to 11 A1

AC Current

9 μA to 1.99999 A

10 Hz to 5 kHz

BC
900 mA to 11 A1 | 10 Hz to 20 kHz

Resistance or Conductance

10 Ω to 100 MΩ, 100 mS to 10 nS (in decade steps)

Wideband ACV

300 μV to 3.5 V2

10 Hz to 30 MHz

W

  1. Requires Option 60, 4600 Transconductance Amplifier
  2. Requires Option 70, Wideband ACV
  3. Maximum voltage = 30 x freq - 100

Parameters

RANGE

This field specifies the UUT range as described in the RANGE Field topic.

NOMINAL

This field specifies one of the following.

  • Voltage (DC or RMS) entered as: [numeric][prefix]V
  • Current entered as [numeric][prefix]A.
  • Resistance entered as [numeric][prefix]Z.
  • Conductance entered as [numeric][prefix]Y.
  • Frequency entered as [numeric][prefix]H.
  • Reset entered as *.

Rules:

  1. When the NOMINAL field specifies frequency or period, the MOD1 field must specify voltage, decibels, or current.

TOLERANCE

This field specifies the UUT tolerance as described in the TOLERANCE Field topic.

MOD1

This field specifies one of the following for AC signals.

  • Voltage (RMS) entered as: [numeric][prefix]V
  • Current entered as [numeric][prefix]A.
  • Frequency entered as [numeric][prefix]H.
  • blank DC or not applicable

Rules:

  1. The MOD1 field may specify frequency or period only when the NOMINAL field specifies voltage, decibels, or current.
  2. The MOD1 field may specify voltage, decibels, or current only when the NOMINAL field specifies frequency or period.
  3. The MOD1 field must be blank when the NOMINAL field specifies resistance or conductance.

MOD2

This field allows you to specify negative zero for DC Voltage or DC Current.

-Z | Negative Zero
blank | All other amplitudes

Rules:

  1. The MOD2 field may specify Z only for DC Voltage or DC Current when the Nominal value is zero.

MOD3

This field specifies one of the following:

BC | Use 4600 for current boost
W | Use Option 70, Wideband output for AC Voltage
blank | No boost, wideband, or not applicable

Rules:

  1. If the current can be created only by the Boost Amplifier, BC is inserted automatically.
  2. If the amplitude and frequency combination can only be created using Option 70, Wideband AC Voltage, W is inserted automatically in the MOD3 field.

MOD4

This field specifies the type of test being performed as described in the MOD4 Field topic.

CON

This field specifies the UUT connection.

  • 2W 2-wire
  • 4W 4-wire

Rules:

  1. 2W is automatically entered in the CON field when no CON field code is entered.
  2. The CON field may not specify 4W when any of the following conditions exist:
    1. DC Current
    2. AC Current
    3. AC or DC Voltage less than 200 mV

Use of Standard Memory Locations and Results Reporting

System memory locations MEM and MEM1 are used. For more information, refer to the Use of Standard Memory Registers topic.

Examples

  1.001  4805         *                                                 S
  1.002  4805   1000  1100V          1U 1/                                 2W
  2.001  4805   10    0V             1U                                    2W
  3.001  4805   200   220mV          10%           50H                     2W
  4.001  4805   1000  1100V          3U            1kH                     4W
  5.001  4805   100   -22uA          10%                                   2W
  6.001  4805   2     1.999A         1% 1/         1kH                     2W
  7.001  4805   A     mV             0.1U          50H                     2W
  8.001  4805   A     A              5%            1kH                     2W
  9.001  4805         1.999A                       1kH                  S  2W
  9.002  4805   10    20mV                         500H                 N  2W
  9.003  4805   10    20mV           1%            1kH                  C  2W
 10.001  4805   A     1kZ            5%                                    4W


M4805

Auxiliary Instrument Setup FSC

Description

The M4805 FSC is used for control range locking, safety delay override, driver settling delay.

Parameters

RANGE

This field specifies one of the following:

RNGLK | Range Lock
blank | Field not applicable

NOMINAL

This field specifies the range selection value or a reset to autorange.

  • Range selection value entered as numeric[prefix]V, A, or Z
  • Reset (autorange) entered as “*”

Rules:

  1. “*” is automatically inserted in the NOMINAL field when a blank M4000 statement is entered.
  2. The NOMINAL field may specify a range selection value only when the RANGE field specifies RNGLK.
Range Selection Value | Locked Range
0 μV to 100 μV | 100 μV DC, 1 mV AC
>100 μV to 1 mV | 1 mV
>1 mV to 10 mV | 10 mV
>10 mV to 100 mV | 100 mV
>100 mV to 1 V | 1 V
>1 V to 10 V | 10 V
>10 V to 100 V | 100 V
>100 V to 1000 V | 1000 V
0 μA to 100 μA | 100 μA
>100 μA to 1 mA | 1 mA
>1 mA to 10 mA | 10 mA
>10 mA to 100 mA | 100 mA
>100 mA to 1 A | 1 A
0 Ω to 10 Ω | 10 Ω
>10 Ω to 100 Ω | 100 Ω
>100 Ω to 1 kΩ | 1 kΩ
>1 kΩ to 10 kΩ | 10 kΩ
>10 kΩ to 100 kΩ | 100 kΩ
>100 kΩ to 1 MΩ | 1 MΩ
>1 MΩ to 10 MΩ | 10 MΩ
>10 MΩ to 100 MΩ | 100 MΩ

TOLERANCE

This field is not used.

MOD1

This field is not used.

MOD2

This field controls the safety delay override and settling delay.

blank | Safety Delay Override off / wait for Output On SRQ
D0 | Safety Delay Override off / driver settling delay
D1 | Safety Delay Override on / driver settling delay
DX | Safety Delay Override on / no driver settling delay

Rules:

  1. MOD2 blank is for compatibility with MET/CAL 6.10, 6.11, and 6.11A. These versions of MET/CAL used the Output On SRQ to determine when the output was present. This required first setting the 4805 to standby for each 4805 statement.
  2. MOD2 D0 is the recommended mode for procedures used to calibrate manual DMMs.
  3. MOD2 D1 is the recommended mode for procedures used to calibrate remote controlled DMMs (i.e. closed-loop procedures).
  4. MOD2 DX is for procedure writers who wish to optimize performance by implementing their own settling delay using the IEEE or PORT FSC.
MOD2 4805 FSC Execution Sequence
blank
  1. Set the Safety Delay Override to Off (safety delay active).
  2. Set the 4805 to standby.
  3. Setup the 4805 to the desired state; function, range, etc.
  4. Set the 4805 to operate and wait for the Output On SRQ.
  5. Wait an additional delay as defined below.
D0
  1. Set the Safety Delay Override to Off (safety delay active).
  2. Setup the 4805 to the desired state; function, range, etc.
  3. Set the 4805 to operate.
  4. If DCV or ACV >110 V wait 3 seconds.
  5. Wait an additional delay as defined below.
D1
  1. Set the Safety Delay Override to On (safety delay inactive).
  2. Setup the 4805 to the desired state; function, range, etc.
  3. Set the 4805 to operate.
  4. Wait an additional delay as defined below.
DX
  1. Set the Safety Delay Override to On (safety delay inactive).
  2. Setup the 4805 to the desired state; function, range, etc.
  3. Set the 4805 to operate.
When MOD2 is set to DX, the FSC does not perform ANY settling delay. Therefore when MOD2 DX is used in a closed-loop procedure, the procedure writer is responsible for implementing any required settling delay using the IEEE or PORT FSC.

Additional Settling Delay

MOD2 blank, D0, & D1

DC Voltage, DC Current & Resistance: | wait 1 second
AC Voltage & AC Current |
frequency ≤ 33 Hz | wait 10 seconds
frequency ≤ 330 Hz | wait 3 seconds
otherwise: | wait 1 second

MOD3

This field is not used.

MOD4

This field is not used.

CON

This field is not used.

Examples

See 4000 FSC.


4808

Instrument FSC

Description

The 4808 FSC controls the following functions of the Datron 4808 Multifunction Calibrator:

  • DC Voltage with Option 10 installed
  • AC Voltage with Option 20 installed
  • DC Current with Option 40 and Option 10 installed
  • AC Current with Option 40 and Option 20 installed
  • Resistance with Option 50 and Option 10 or 20 installed
  • DC Current from the 4600 Transconductance Amplifier (Option 60 with Option 40 and Option 10 installed in 4808)
  • AC Current from the 4600 Transconductance Amplifier (Option 60 with Option 40 and Option 20 installed in 4808)
  • Wideband AC Voltage with Option 70 installed

The M4808 FSC is used to control the following:

  • Range Locking
  • Safety Delay Override
  • Driver Settling Delay
The 4808 FSC can also be used to control a 4708. The accuracy file corresponding to the instrument that is actually configured is used at run time.

Functional Capability

Function | Amplitude | Frequency | MOD3

DC Voltage1

-199.99999 V to 199.99999 V
-1100 V to 1100 V1,3

AC Voltage

90 uV to 19.99999 V2

10 Hz to 1 MHz
90 uV to 199.9999 V2 | 10 Hz to 100 kHz
100 uV to 1100 V2,3 | 10 Hz to 33 kHz
The maximum voltage increases linearly from 199.9999 V at 10 Hz to 1100 V at 40 Hz.

DC Current

-1.99999 A to 1.99999 A4,1

BC

-11 A to 11 A (6)(4)(1)

AC Current

9 uA to 1.99999 A4,2

10 Hz to 5 kHz

BC

100 mA to 11 A6,4,2 | 10 Hz to 20 kHz

Resistance or
Conductance

10 Ω to 100 MΩ, 100 mS to 10 nS
(in decade steps)5 &1 or 2

Wideband ACV7

300 uV to 3.5 V

10 Hz to 30 MHz

W

  1. Requires Option 10, DC Voltage
  2. Requires Option 20, AC Voltage
  3. Requires Option 30, 1000 V Range
  4. Requires Option 40, Current
  5. Requires Option 50, Resistance
  6. Requires Option 60, 4600 Transconductance Amplifier
  7. Requires Option 70, Wideband ACV

Parameters

RANGE

This field specifies the UUT range as described in the RANGE Field topic.

NOMINAL

This field specifies one of the following.

  • Voltage (DC or RMS) entered as: [numeric][prefix]V
  • Current entered as [numeric][prefix]A.
  • Resistance entered as [numeric][prefix]Z.
  • Conductance entered as [numeric][prefix]Y.
  • Frequency entered as [numeric][prefix]H.
  • Reset entered as *.

Rules:

  1. When the NOMINAL field specifies frequency or period, the MOD1 field must specify voltage,

decibels, or current.

TOLERANCE

This field specifies the UUT tolerance as described in the TOLERANCE Field topic.

MOD1

This field specifies one of the following for AC signals.

  • Voltage (RMS) entered as: [numeric][prefix]V
  • Current entered as [numeric][prefix]A.
  • Frequency entered as [numeric][prefix]H.
  • blank DC or not applicable

Rules:

  1. The MOD1 field may specify frequency or period only when the NOMINAL field specifies voltage, decibels, or current.
  2. The MOD1 field may specify voltage, decibels, or current only when the NOMINAL field specifies frequency or period.
  3. The MOD1 field must be blank when the NOMINAL field specifies resistance or conductance.

MOD2

This field allows you to specify negative zero for DC Voltage or DC Current.

-Z | Negative Zero
blank | All other amplitudes

Rules:

  1. The MOD2 field may specify Z only for DC Voltage or DC Current when the Nominal value is zero.

MOD3

This field specifies one of the following:

BC | use 4600 for current boost
W | use Option 70, Wideband output for AC Voltage
blank | No boost, wideband, or not applicable

Rules:

  1. If the current can be created only by the Boost Amplifier, BC is inserted automatically.
  2. If the amplitude and frequency combination can only be created using Option 70, Wideband AC Voltage, W is inserted automatically in the MOD3 field.

MOD4

This field specifies the type of test being performed as described in the MOD4 Field topic.

CON

This field specifies the UUT connection.

  • 2W 2-wire
  • 4W 4-wire

Rules:

  1. 2W is automatically entered in the CON field when no CON field code is entered.
  2. The CON field may not specify 4W when any of the following conditions exist:
    1. DC Current
    2. AC Current
    3. AC or DC Voltage less than 200 mV

Use of Standard Memory Locations and Results Reporting

System memory locations MEM and MEM1 are used. For more information, refer to the Use of Standard Memory Registers topic.

Examples

  1.001  4808         *                                                 S
  1.002  4808   1000  1100V          1U 1/                                 2W
  2.001  4808   10    0V             1U                                    2W
  3.001  4808   200   220mV          10%           50H                     2W
  4.001  4808   1000  1100V          1U            1kH                     4W
  5.001  4808   100   -22uA          10%                                   2W
  6.001  4808   2     1.999A         1% 1/         1kH                     2W
  7.001  4808   A     mV             0.1U          50H                     2W
  8.001  4808   A     A              5%            1kH                     2W
  9.001  4808         1.999A                       1kH                  S  2W
  9.002  4808   10    20mV                         500H                 N  2W
  9.003  4808   10    20mV           0.5%          1kH                  C  2W
 10.001  4808   A     10kZ           5%                                    4W


M4808

Auxiliary Instrument Setup FSC

Description

The M4808 FSC is used to control range locking, safety delay override, driver settling delay.

Parameters

RANGE

This field specifies one of the following:

RNGLK | Range Lock
blank | Field not applicable

NOMINAL

This field specifies the range selection value or a reset to autorange.

  • Range selection value entered as numeric[prefix]V, A, or Z
  • Reset (autorange) entered as “*”

Rules:

  1. “*” is automatically inserted in the NOMINAL field when a blank M4000 statement is entered.
  2. The NOMINAL field may specify a range selection value only when the RANGE field specifies RNGLK.
Range Selection Value | Locked Range
0 μV to 100 μV | 100 μV DC, 1 mV AC, 10 mV WB
>100 μV to 1 mV | 1 mV, 10 mV WB
>1 mV to 10 mV | 10 mV
>10 mV to 100 mV | 100 mV
>100 mV to 1 V | 1 V
>1 V to 10 V | 10 V
>10 V to 100 V | 100 V
>100 V to 1000 V | 1000 V
0 μA to 100 μA | 100 μA
>100 μA to 1 mA | 1 mA
>1 mA to 10 mA | 10 mA
>10 mA to 100 mA | 100 mA
>100 mA to 1 A | 1 A
0 Ω to 10 Ω | 10 Ω
>10 Ω to 100 Ω | 100 Ω
>100 Ω to 1 kΩ | 1 kΩ
>1 kΩ to 10 kΩ | 10 kΩ
>10 kΩ to 100 kΩ | 100 kΩ
>100 kOhm to 1 MOhm | 1 MΩ
>1 MΩ to 10 MΩ | 10 MΩ
>10 MΩ to 100 MΩ | 100 MΩ

TOLERANCE

This field is not used.

MOD1

This field is not used.

MOD2

This field controls the safety delay override and settling delay.

blank | Safety Delay Override off / wait for Output On SRQ
D0 | Safety Delay Override off / driver settling delay
D1 | Safety Delay Override on / driver settling delay
DX | Safety Delay Override on / no driver settling delay

Rules:

  1. MOD2 blank is for compatibility with MET/CAL 6.10, 6.11, and 6.11A. These versions of MET/CAL used the Output On SRQ to determine when the output was present. This required first setting the 4808 to standby for each 4808 statement.
  2. MOD2 D0 is the recommended mode for procedures used to calibrate manual DMMs.
  3. MOD2 D1 is the recommended mode for procedures used to calibrate remote controlled DMMs (i.e. closed-loop procedures).
  4. MOD2 DX is for procedure writers who wish to optimize performance by implementing their own settling delay using the IEEE or PORT FSC.
MOD2 4808 FSC Execution Sequence
blank
  1. Set the Safety Delay Override to Off (safety delay active).
  2. Set the 4808 to standby.
  3. Setup the 4808 to the desired state; function, range, etc.
  4. Set the 4808 to operate and wait for the Output On SRQ.
  5. Wait an additional delay as defined below.
D0
  1. Set the Safety Delay Override to Off (safety delay active).
  2. Setup the 4808 to the desired state; function, range, etc.
  3. Set the 4808 to operate.
  4. If DCV or ACV >110 V wait 3 seconds.
  5. Wait an additional delay as defined below.
D1
  1. Set the Safety Delay Override to On (safety delay inactive).
  2. Setup the 4808 to the desired state; function, range, etc.
  3. Set the 4808 to operate.
  4. Wait an additional delay as defined below.
DX
  1. Set the Safety Delay Override to On (safety delay inactive).
  2. Setup the 4808 to the desired state; function, range, etc.
  3. Set the 4808 to operate.
When MOD2 is set to DX, the FSC does not perform ANY settling delay. Therefore when MOD2 DX is used in a closed-loop procedure, the procedure writer is responsible for implementing any required settling delay using the IEEE or PORT FSC.

Additional Settling Delay

MOD2 blank, D0, & D1

DC Voltage, DC Current & Resistance | wait 1 second
AC Voltage & AC Current |
frequency ≤ 33 Hz | wait 10 seconds
frequency ≤ 330 Hz | wait 3 seconds
otherwise | wait 1 second

MOD3

This field is not used.

MOD4

This field is not used.

CON

This field is not used.

Examples

See 4808 FSC.


4950

Instrument FSC

Description

The 4950 FSC programs the Datron 4950 Multifunction Transfer Standard to measure DC voltage, AC voltage, DC current, AC current, resistance and frequency.

Functional Capability

BANDS ON (MOD2 = blank)

Range | Band | Amplitude | Frequency
DC Voltage
100 mV | 0 % | -15 mV to +15 mV
100 mV | 100 % | +85 mV to +115 mV
100 mV | 100 % | -115 mV to -85 mV
1 V | 0 % | -0.1 V to +0.1 V
1 V | 100 % | +0.9 V to +1.1 V
1 V | 100 % | -1.1 V to -0.9 V
10 V | 0 % | -1 V to +1 V
10 V | 100 % | +9 V to +11 V
10 V | 190 % | -11 V to -9 V
100 V | 0 % | -10 V to +10 V
100 V | 100 % | +90 V to +110 V
100 V | 100 % | -110 V to -90 V
1000 V | 0 % | -100 V to +100 V
1000 V | 100 % | +900 V to +1100 V
1000 V | 100 % | -1100 V to -900 V
AC Voltage
1 mV | 100 % | 0.85 mV to 1.15 mV | 9 Hz to 11 Hz
1 mV | 100 % | 0.85 mV to 1.15 mV | 18 Hz to 22 Hz
1 mV | 100 % | 0.85 mV to 1.15 mV | 27 Hz to 33 Hz
1 mV | 100 % | 0.85 mV to 1.15 mV | 36 Hz to 44 Hz
1 mV | 100 % | 0.85 mV to 1.15 mV | 46.25 Hz to 63.75 Hz
1 mV | 100 % | 0.85 mV to 1.15 mV | 270 Hz to 440 Hz
1 mV | 100 % | 0.85 mV to 1.15 mV | 0.9 kHz to 1.1 kHz
1 mV | 100 % | 0.85 mV to 1.15 mV | 18 kHz to 22 kHz
1 mV | 100 % | 0.85 mV to 1.15 mV | 27 kHz to 33 kHz
1 mV | 100 % | 0.85 mV to 1.15 mV | 45 kHz to 55 kHz
1 mV | 100 % | 0.85 mV to 1.15 mV | 90 kHz to 110 kHz
1 mV | 100 % | 0.85 mV to 1.15 mV | 270 kHz to 330 kHz
1 mV | 100 % | 0.85 mV to 1.15 mV | 450 kHz to 550 kHz
1 mV | 100 % | 0.85 mV to 1.15 mV | 0.9 MHz to 1.1 MHz
10 mV | 100 % | 8.5 mV to 11.5 mV | 9 Hz to 11 Hz
10 mV | 100 % | 8.5 mV to 11.5 mV | 18 Hz to 22 Hz
10 mV | 100 % | 8.5 mV to 11.5 mV | 27 Hz to 33 Hz
10 mV | 100 % | 8.5 mV to 11.5 mV | 36 Hz to 44 Hz
10 mV | 100 % | 8.5 mV to 11.5 mV | 46.25 Hz to 63.75 Hz
10 mV | 100 % | 8.5 mV to 11.5 mV | 270 Hz to 440 Hz
10 mV | 100 % | 8.5 mV to 11.5 mV | 0.9 kHz to 1.1 kHz
10 mV | 100 % | 8.5 mV to 11.5 mV | 18 kHz to 22 kHz
10 mV | 100 % | 8.5 mV to 11.5 mV | 27 kHz to 33 kHz
10 mV | 100 % | 8.5 mV to 11.5 mV | 45 kHz to 55 kHz
10 mV | 100 % | 8.5 mV to 11.5 mV | 90 kHz to 110 kHz
10 mV | 100 % | 8.5 mV to 11.5 mV | 270 kHz to 330 kHz
10 mV | 100 % | 8.5 mV to 11.5 mV | 450 kHz to 550 kHz
10 mV | 100 % | 8.5 mV to 11.5 mV | 0.9 MHz to 1.1 MHz
100 mV | 100 % | 85 mV to 115 mV | 9 Hz to 11 Hz
100 mV | 100 % | 85 mV to 115 mV | 18 Hz to 22 Hz
100 mV | 100 % | 85 mV to 115 mV | 27 Hz to 33 Hz
100 mV | 100 % | 85 mV to 115 mV | 36 Hz to 44 Hz
100 mV | 100 % | 85 mV to 115 mV | 46.25 Hz to 63.75 Hz
100 mV | 100 % | 85 mV to 115 mV | 270 Hz to 440 Hz
100 mV | 100 % | 85 mV to 115 mV | 0.9 kHz to 1.1 kHz
100 mV | 100 % | 85 mV to 115 mV | 18 kHz to 22 kHz
100 mV | 100% | 85 mV to 115 mV | 27 kHz to 33 kHz
100 mV | 100% | 85 mV to 115 mV | 45 kHz to 55 kHz
100 mV | 100% | 85 mV to 115 mV | 90 kHz to 110 kHz
100 mV | 100% | 85 mV to 115 mV | 270 kHz to 330 kHz
100 mV | 100% | 85 mV to 115 mV | 450 kHz to 550 kHz
100 mV | 100% | 85 mV to 115 mV | 0.9 MHz to 1.1 MHz
1 V | 100% | 0.9 V to 1.1 V | 9 Hz to 11 Hz
1 V | 100% | 0.9 V to 1.1 V | 18 Hz to 22 Hz
1 V | 100% | 0.9 V to 1.1 V | 27 Hz to 33 Hz
1 V | 100% | 0.9 V to 1.1 V | 36 Hz to 44 Hz
1 V | 100 % | 0.9 V to 1.1 V | 46.25 Hz to 63.75 Hz
1 V | 100 % | 0.9 V to 1.1 V | 270 Hz to 440 Hz
1 V | 100 % | 0.9 V to 1.1 V | 0.9 kHz to 1.1 kHz
1 V | 100 % | 0.9 V to 1.1 V | 18 kHz to 22 kHz
1 V | 100 % | 0.9 V to 1.1 V | 27 kHz to 33 kHz
1 V | 100 % | 0.9 V to 1.1 V | 45 kHz to 55 kHz
1 V | 100 % | 0.9 V to 1.1 V | 90 kHz to 110 kHz
1 V | 100 % | 0.9 V to 1.1 V | 270 kHz to 330 kHz
1 V | 100 % | 0.9 V to 1.1 V | 450 kHz to 550 kHz
1 V | 100 % | 0.9 V to 1.1 V | 0.9 MHz to 1.1 MHz
10 V | 100 % | 9 V to 11 V | 9 Hz to 11 Hz
10 V | 100 % | 9 V to 11 V | 18 Hz to 22 Hz
10 V | 100 % | 9 V to 11 V | 27 Hz to 33 Hz
10 V | 100 % | 9 V to 11 V | 36 Hz to 44 Hz
10 V | 100 % | 9 V to 11 V | 46.25 Hz to 63.75 Hz
10 V | 100 % | 9 V to 11 V | 270 Hz to 440 Hz
10 V | 100 % | 9 V to 11 V | 0.9 kHz to 1.1 kHz
10 V | 100 % | 9 V to 11 V | 18 kHz to 22 kHz
10 V | 100 % | 9 V to 11 V | 27 kHz to 33 kHz
10 V | 100 % | 9 V to 11 V | 45 kHz to 55 kHz
10 V | 100 % | 9 V to 11 V | 90 kHz to 110 kHz
10 V | 100 % | 9 V to 11 V | 270 kHz to 330 kHz
10 V | 100 % | 9 V to 11 V | 450 kHz to 550 kHz
10 V | 100 % | 9 V to 11 V | 0.9 MHz to 1.1 MHz
10 V | 190 % | 18 V to 19.5 V | 0.9 kHz to 1.1 kHz
100 V | 100 % | 90 V to 110 V | 9 Hz to 11 Hz
100 V | 100 % | 90 V to 110 V | 18 Hz to 22 Hz
100 V | 100 % | 90 V to 110 V | 27 Hz to 33 Hz
100 V | 100 % | 90 V to 110 V | 36 Hz to 44 Hz
100 V | 100 % | 90 V to 110 V | 46.25 Hz to 63.75 Hz
100 V | 100 % | 90 V to 110 V | 270 Hz to 440 Hz
100 V | 100 % | 90 V to 110 V | 0.9 kHz to 1.1 kHz
100 V | 100 % | 90 V to 110 V | 18 kHz to 22 kHz
100 V | 100 % | 90 V to 110 V | 27 kHz to 33 kHz
100 V | 100 % | 90 V to 110 V | 45 kHz to 55 kHz
100 V | 100 % | 90 V to 110 V | 90 kHz to 110 kHz
100 V | 100% | 90 V to 110 V | 180 kHz to 220 kHz
1000 V | 70% | 600 V to 800 V | 45 kHz to 55 kHz
1000 V | 70% | 600 V to 800 V | 90 kHz to 110 kHz
1000 V | 100% | 900 V to 1100 V | 9 Hz to 11 Hz
1000 V | 100% | 900 V to 1100 V | 18 Hz to 22 Hz
1000 V | 100% | 900 V to 1100 V | 27 Hz to 33 Hz
1000 V | 100% | 900 V to 1100 V | 36 Hz to 44 Hz
1000 V | 100% | 900 V to 1100 V | 46.25 Hz to 63.75 Hz
1000 V | 100 % | 900 V to 1100 V | 270 Hz to 440 Hz
1000 V | 100 % | 900 V to 1100 V | 0.9 kHz to 1.1 kHz
1000 V | 100 % | 900 V to 1100 V | 18 kHz to 22 kHz
1000 V | 100 % | 900 V to 1100 V | 27 kHz to 33 kHz
DC Current
100 μA | 0 % | -10 μA to +10 μA
100 μA | 100 % | +90 μA to +110 μA
100 μA | 100 % | -110 μA to -90 μA
1 mA | 0 % | -0.1 mA to +0.1 mA
1 mA | 100 % | +0.9 mA to +1.1 mA
1 mA | 100 % | -1.1 mA to -0.9 mA
10 mA | 0 % | -1 mA to +1 mA
10 mA | 100 % | +9 mA to +11 mA
10 mA | 100 % | -11 mA to -9 mA
100 mA | 0 % | -10 mA to +10 mA
100 mA | 100 % | +90 mA to +110 mA
100 mA | 100 % | -110 mA to -90 mA
1 A | 0 % | -0.1 A to +0.1 A
1 A | 100 % | +0.9 A to +1.1 A
1 A | 100 % | -1.1 A to -0.9 A
10 A 1 | 0 % | -1 A to +1 A
10 A 1 | 100 % | +9 A to +11 A
10 A 1 | 100 % | -11 A to -9 A
AC Current
100 μA | 100 % | 90 μA to 110 μA | 9 Hz to 11 Hz
100 μA | 100 % | 90 μA to 110 μA | 18 Hz to 22 Hz
100 μA | 100 % | 90 μA to 110 μA | 27 Hz to 33 Hz
100 μA | 100 % | 90 μA to 110 μA | 36 Hz to 44 Hz
100 μA | 100 % | 90 μA to 110 μA | 46.25 Hz to 63.75 Hz
100 μA | 100 % | 90 μA to 110 μA | 270 Hz to 440 Hz
100 μA | 100 % | 90 μA to 110 μA | 0.9 kHz to 1.1 kHz
100 μA | 100 % | 90 μA to 110 μA | 4.5 kHz to 5.5 kHz
100 μA | 100 % | 90 μA to 110 μA | 9 kHz to 11 kHz
100 μA | 100 % | 90 μA to 110 μA | 18 kHz to 22 kHz
100 μA | 100 % | 90 μA to 110 μA | 27 kHz to 33 kHz
1 mA | 100 % | 0.9 mA to 1.1 mA | 9 Hz to 11 Hz
1 mA | 100 % | 0.9 mA to 1.1 mA | 18 Hz to 22 Hz
1 mA | 100 % | 0.9 mA to 1.1 mA | 27 Hz to 33 Hz
1 mA | 100 % | 0.9 mA to 1.1 mA | 36 Hz to 44 Hz
1 mA | 100 % | 0.9 mA to 1.1 mA | 46.25 Hz to 63.75 Hz
1 mA | 100 % | 0.9 mA to 1.1 mA | 270 Hz to 440 Hz
1 mA | 100 % | 0.9 mA to 1.1 mA | 0.9 kHz to 1.1 kHz
1 mA | 100 % | 0.9 mA to 1.1 mA | 4.5 kHz to 5.5 kHz
1 mA | 100 % | 0.9 mA to 1.1 mA | 9 kHz to 11 kHz
1 mA | 100 % | 0.9 mA to 1.1 mA | 18 kHz to 22 kHz
1 mA | 100 % | 0.9 mA to 1.1 mA | 27 kHz to 33 kHz
10 mA | 100 % | 9 mA to 11 mA | 9 Hz to 11 Hz
10 mA | 100 % | 9 mA to 11 mA | 18 Hz to 22 Hz
10 mA | 100 % | 9 mA to 11 mA | 27 Hz to 33 Hz
10 mA | 100 % | 9 mA to 11 mA | 36 Hz to 44 Hz
10 mA | 100 % | 9 mA to 11 mA | 46.25 Hz to 63.75 Hz
10 mA | 100 % | 9 mA to 11 mA | 270 Hz to 440 Hz
10 mA | 100 % | 9 mA to 11 mA | 0.9 kHz to 1.1 kHz
10 mA | 100 % | 9 mA to 11 mA | 4.5 kHz to 5.5 kHz
10 mA | 100 % | 9 mA to 11 mA | 9 kHz to 11 kHz
10 mA | 100 % | 9 mA to 11 mA | 18 kHz to 22 kHz
10 mA | 100 % | 9 mA to 11 mA | 27 kHz to 33 kHz
100 mA | 100 % | 90 mA to 110 mA | 9 Hz to 11 Hz
100 mA | 100 % | 90 mA to 110 mA | 18 Hz to 22 Hz
100 mA | 100 % | 90 mA to 110 mA | 27 Hz to 33 Hz
100 mA | 100 % | 90 mA to 110 mA | 36 Hz to 44 Hz
100 mA | 100 % | 90 mA to 110 mA | 46.25 Hz to 63.75 Hz
100 mA | 100 % | 90 mA to 110 mA | 270 Hz to 440 Hz
100 mA | 100 % | 90 mA to 110 mA | 0.9 kHz to 1.1 kHz
100 mA | 100 % | 90 mA to 110 mA | 4.5 kHz to 5.5 kHz
100 mA | 100 % | 90 mA to 110 mA | 9 kHz to 11 kHz
100 mA | 100 % | 90 mA to 110 mA | 18 kHz to 22 kHz
100 mA | 100 % | 90 mA to 110 mA | 27 kHz to 33 kHz
1 A | 100 % | 0.9 A to 1.1 A | 9 Hz to 11 Hz
1 A | 100 % | 0.9 A to 1.1 A | 18 Hz to 22 Hz
1 A | 100 % | 0.9 A to 1.1 A | 27 Hz to 33 Hz
1 A | 100 % | 0.9 A to 1.1 A | 36 Hz to 44 Hz
1 A | 100 % | 0.9 A to 1.1 A | 46.25 Hz to 63.75 Hz
1 A | 100 % | 0.9 A to 1.1 A | 270 Hz to 440 Hz
1 A | 100 % | 0.9 A to 1.1 A | 0.9 kHz to 1.1 kHz
1 A | 100 % | 0.9 A to 1.1 A | 4.5 kHz to 5.5 kHz
1 A | 100 % | 0.9 A to 1.1 A | 9 kHz to 11 kHz
1 A | 100 % | 0.9 A to 1.1 A | 18 kHz to 22 kHz
1 A | 100% | 0.9 A to 1.1 A | 27 kHz to 33 kHz
10 A 1 | 100% | 9 A to 11 A | 9 Hz to 11 Hz
10 A 1 | 100% | 9 A to 11 A | 18 Hz to 22 Hz
10 A 1 | 100% | 9 A to 11 A | 27 Hz to 33 Hz
10 A 1 | 100% | 9 A to 11 A | 36 Hz to 44 Hz
10 A 1 | 100% | 9 A to 11 A | 46.25 Hz to 63.75 Hz
10 A 1 | 100% | 9 A to 11 A | 270 Hz to 440 Hz
10 A 1 | 100% | 9 A to 11 A | 0.9 kHz to 1.1 kHz
10 A 1 | 100% | 9 A to 11 A | 4.5 kHz to 5.5 kHz
10 A 1 | 100% | 9 A to 11 A | 9 kHz to 11 kHz
10 A 1 | 100 % | 9 A to 11 A | 18 kHz to 22 kHz
Resistance
10 Ω | 0 % | 0 Ω to 1 Ω
10 Ω | 10 % | 0 Ω to 2 Ω
10 Ω | 30 % | 2 Ω to 4 Ω
10 Ω | 100 % | 9 Ω to 11 Ω
10 Ω | 190 % | 18 Ω to 19.5 Ω
100 Ω | 0 % | 0 Ω to 10 Ω
100 Ω | 30 % | 20 Ω to 40 Ω
100 Ω | 100 % | 90 Ω to 110 Ω
100 Ω | 190 % | 180 Ω to 195 Ω
1 kΩ | 0 % | 0 kΩ to 0.1 kΩ
1 kΩ | 30 % | 0.2 kΩ to 0.4 kΩ
1 kΩ | 100 % | 0.9 kΩ to 1.1 kΩ
1 kΩ | 190 % | 1.8 kΩ to 1.95 kΩ
10 kOΩ | 0 % | 0 kΩ to 1 kΩ
10 kΩ | 30 % | 2 kΩ to 4 kΩ
10 kΩ | 100 % | 9 kΩ to 11 kΩ
10 kΩ | 190 % | 18 kΩ to 19.5 kΩ
100 kΩ | 0 % | 0 kΩ to 10 kΩ
100 kΩ | 30 % | 20 kΩ to 40 kΩ
100 kΩ | 100 % | 90 kΩ to 110 kΩ
100 kΩ | 190 % | 180 kΩ to 195 kΩ
1 MΩ | 0 % | 0 MΩ to 0.1 MΩ
1 MΩ | 30 % | 0.2 MΩ to 0.4 MΩs
1 MΩ | 100 % | 0.9 MΩ to 1.1 MΩ
1 MΩ | 190 % | 1.8 MΩ to 1.95 MΩ
10 MΩ | 0% | 0 MΩ to 1 MΩ
10 MΩ | 30% | 2 MΩ to 4 MΩ
10 MΩ | 100% | 9 MOhms to 11 MΩ
10 MΩ | 190% | 18 MΩ to 19.5 MΩ
100 MΩ | 0% | 0 MΩ to 10 MΩ
100 MΩ | 30% | 20 MΩ to 40 MΩ
100 MΩ | 100% | 90 MΩ to 110 MΩ

BANDS OFF (MOD2 = “O”)

Function | Amplitude | Frequency
DC Voltage | -1100 V to 1100 V
AC Voltage | 0.30 mV to 19.99999 V | 9 Hz to 1.1 MHz
20 V to 199.9999 V | 9 Hz to 220 kHz
200 V to 800 V | 9 Hz to 110 kHz
>800 V to 1100 V | 9 Hz to 33 kHz
Resistance | 0 Ω to 199.999999 MΩ
DC Current | -1.999999 A to 1.999999 A
-19.99999 A to 19.99999 A 1
AC Current | 30 μA to 1.999999 A | 10 Hz to 33 kHz
1.199999 A to 19.99999 A 1 | 10 Hz to 22 kHz
Frequency | 9 Hz to 1.1 MHz | 0.30 mV to 19.99999 V
9 Hz to 220 kHz | 20 V to 199.9999 V
9 Hz to 110 kHz | 200 V to 800 V
9 Hz to 33 kHz | >800 V to 1100 V
10 Hz to 33 kHz | 0.30 uA to 1.999999 A
10 Hz to 22 kHz | 1.199999 A to 11 A
  1. Requires 4953 AC/DC Shunt

Parameters

RANGE

This field specifies the UUT range as described in the RANGE Field topic.

NOMINAL

This field specifies the expected measured value or a reset.

  • Voltage (DC or RMS) entered as [numeric][prefix]V.
  • Current entered as [numeric][prefix]A.
  • Resistance entered as [numeric][prefix]Z.
  • Frequency entered as [numeric][prefix]H.
  • Reset entered as *.

Rules:

  1. The NOMINAL field may specify frequency only when the MOD1 field specifies voltage or current.

TOLERANCE

This field specifies the UUT tolerance as described in the TOLERANCE Field topic.

MOD1

This field specifies frequency or amplitude for AC voltage or AC current measurements.

  • Frequency entered as numeric[prefix]H.
  • Voltage entered as numeric[prefix]V.
  • Current entered as numeric[prefix]A.
  • blank not applicable

Rules:

  1. The MOD1 field may specify frequency only when the NOMINAL field specifies voltage or current.
  2. The MOD1 field must specify voltage or current when the NOMINAL field specifies frequency.
  3. The MOD1 field must be blank when the NOMINAL field specifies resistance.

MOD2

This field specifies one the band limits mode:

blank | Bands On
O | Override (Bands Off)

MOD3

This field specifies the accuracy mode for the measurement.

blank | High Accuracy mode
F | Low Accuracy mode
ZR | Perform input zero
MOD3 does not effect the accuracy of a frequency measurement. Therefore if MOD3 is left blank for frequency measurement execution time will be increased with no increase in accuracy.

Rules:

  1. The MOD3 field may specify ZR only under the following conditions:
    1. The Nominal value is zero or MEM is zero when the Nominal field does not contain a value, and
    2. The MOD1 field is blank (DC volts, DC amps, or ohms).

MOD4

This field specifies the type of test being performed as described in the MOD4 Field topic.

CON

This field specifies the UUT connection.

  • 2W 2-wire
  • 4W 4-wire

Rules:

  1. The CON may specify 2W only for either for the following conditions:
    1. DC Voltage, DC Current, AC Current, and Resistance measurement, or
    2. AC voltage and Frequency measurement when
      1. the M4950 Nominal field locks the 1 V or 10 V range and
      2. the M4950 MOD1 field is 300 kHz, 500 kHz, or 1 MHz.
  2. The CON may specify 4W only for AC Voltage, Frequency, or Resistance measurement.

Using the Datron 4950

In most respects the Datron 4950 functions like any other supported system instrument. However, since the 4950 is designed to internally take a sequence of measurements and return to the user the mean of the measurements and the standard error, MET/CAL handles the 4950 as a special case. When the number of measurements (see VSET NMEAS) is set to 1, and when the 4950 is in a mode in which the sample size is greater than 1, MET/CAL uses the standard error calculated by the 4950 as the basis for the determination of the standard deviation.

The calculation is:

Standard Deviation = Standard Error * (N ^ 0.5)

where N is the sample size.

Note that this operation is different from the normal operation when NMEAS is 1. Normally, when NMEAS is 1, no standard deviation is determined, which causes S1 to be zero, which in turn causes U2 to be based only on the UUT’s resolution.

It remains possible, even with the Datron 4950, for the procedure writer to override the default calculation. For example, if the procedure includes a VSET statement which directly specifies the value of S1, MET/CAL will no longer use the Standard Error calculated by the 4950, even if NMEAS is set to 1 and the 4950 sample size is greater than 1.

Setting NMEAS to any value greater than 1 disables the built-in use of the standard error calculated by the 4950. For example, suppose NMEAS is 5 and the 4950 is in high accuracy DCI mode. The sample size is 32, and the 4950 calculates the standard error, but MET/CAL will make no use of the calculated standard error in the measurement uncertainty calculation. Rather, in this case, MET/CAL will simply calculate the standard deviation of 5 readings (each of which is really based on 32 internal readings).

If the 4950 is used in a mode in which the sample size is 1 (for example, low accuracy ACV), the procedure writer should set the number of measurements to a value greater than 1 in order to include in the measurement uncertainty calculation the standard deviation of a sequence of measurements.

For additional information refer to the “Sample Size and Resolution” table on page 6-17 of the “Wavetek Model 4950 Multifunction Transfer Standard Instrument User’s Handbook” (December 1998).

Use of Standard Memory Locations and Results Reporting

System memory locations MEM and MEM1 are used. For more information, refer to the Use of Standard Memory Registers topic.

Examples

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON

  1.001  ASK-                                                              V
# -----  Number of Measurement to average in MET/CAL is set to one because
# -----  the 4950 internal number of samples and standard error are used
# -----  for the measurement uncertainty calculation.
  1.002  VSET         NMEAS = 1
# -----  Establish reset command for UUT.
  1.003  RESET        *CLS;*RST;*OPC?[I!]
# -----  Perform Input Zero
  1.004  M4950  RNGLK 100mV          0%
  1.005  4950         0mV                                            ZR N  2W
  1.006  ASK-         N
  1.007  M4950  RNGLK 1V             0%
  1.008  4950         0V                                             ZR N  2W
  1.009  M4950  RNGLK 10V            0%
  1.010  4950         0V                                             ZR N  2W
  1.011  M4950  RNGLK 100V           0%
  1.012  4950         0V                                             ZR N  2W
  1.013  M4950  RNGLK 1000V          0%
  1.014  4950         0V                                             ZR N  2W
  1.015  ASK+         N
  1.016  M4950  RNGLK 100uA          0%
  1.017  4950         0uA                                            ZR N  2W
  1.018  ASK-         N
  1.019  M4950  RNGLK 1mA            0%
  1.020  4950         0mA                                            ZR N  2W
  1.021  M4950  RNGLK 10mA           0%
  1.022  4950         0mA                                            ZR N  2W
  1.023  M4950  RNGLK 100mA          0%
  1.024  4950         0mA                                            ZR N  2W
  1.025  M4950  RNGLK 1A             0%
  1.026  4950         0A                                             ZR N  2W
  1.027  M4950  RNGLK 10A            0%
  1.028  4950         0A                                             ZR N  2W
  1.029  ASK+         N
  1.030  M4950  RNGLK 10Z            0%
  1.031  4950         0Z                                             ZR N  2W
  1.032  ASK-         N
  1.033  M4950  RNGLK 100Z           0%
  1.034  4950         0Z                                             ZR N  4W
  1.035  M4950  RNGLK 1kZ            0%
  1.036  4950         0kZ                                            ZR N  4W
  1.037  M4950  RNGLK 10kZ           0%
  1.038  4950         0kZ                                            ZR N  4W
  1.039  M4950  RNGLK 100kZ          0%
  1.040  4950         0kZ                                            ZR N  4W
  1.041  M4950  RNGLK 1MZ            0%
  1.042  4950         0MZ                                            ZR N  4W
  1.043  M4950  RNGLK 10MZ           0%
  1.044  4950         0MZ                                            ZR N  4W
  1.045  M4950  RNGLK 100MZ          0%
  1.046  4950         0MZ                                            ZR N  4W
  1.047  ASK-   R   Q                P                            F        V
# -----  DC Voltage
  1.048  DISP         Connect the 4950 Input Cable to the 5700A as follows:
  1.048  DISP         [32] 4950 Hi Lead to 5700A OUTPUT HI
  1.048  DISP         [32] 4950 Lo Lead to 5700A OUTPUT LO
  1.048  DISP         [32] 4950 I+ Lead to 5700A SENSE HI
  1.048  DISP         [32] 4950 I- Lead to 5700A SENSE LO
  1.049  IEEE         OUT 0V;OPER;*OPC?[I!]
  1.050  M4950  RNGLK 100mV          0%
  1.051  4950   220   0.00000mV      7P% 0.00075U                          2W
  2.001  IEEE         OUT 100mV;OPER;*OPC?[I!]
  2.002  M4950  RNGLK 100mV          100%
  2.003  4950   220   100.00000mV    7P% 0.00075U                          2W
  3.001  IEEE         *CLS;*RST;*OPC?[I!]
# -----  AC Voltage
  3.002  IEEE         OUT 1V,10Hz;OPER;*OPC?[I!]
  3.003  M4950  RNGLK 1V             100%          10H
  3.004  4950   2.2   1.000000V      550P% 100e-6U 10H                     4W
  4.001  IEEE         OUT 1V,10kHz;OPER;*OPC?[I!]
  4.002  M4950  RNGLK 1V             100%          10kH
  4.003  4950   2.2   1.000000V      75P% 7e-6U    10kH                    4W
  5.001  IEEE         *CLS;*RST;*OPC?[I!]
# -----  Resistance
  5.002  IEEE         OUT 0Ohm;EXTSENSE ON;OPER;*OPC?[I!]
  5.003  M4950  RNGLK 10Z            0%
  5.004  4950   0     0.0000000Z     0.0000500U                            4W
  6.001  IEEE         OUT 10Ohm;EXTSENSE ON;OPER;*OPC?[I!]OUT?[I]
  6.002  M4950  RNGLK 10Z            100%
  6.003  4950   10    Z              0.000028U                             4W
  7.001  IEEE         OUT 19Ohm;EXTSENSE ON;OPER;*OPC?[I!]OUT?[I]
  7.002  M4950  RNGLK 10Z            190%
  7.003  4950   19    Z              0.000026U                             4W
  8.001  IEEE         *CLS;*RST;*OPC?[I!]
# -----  DC Current
  8.002  DISP         Connect the 4950 Input cable to the 5700A as follows.
  8.002  DISP         [32] 4950 I+ Lead to 5700A OUTPUT HI
  8.002  DISP         [32] 4950 I- Lead to 5700A OUTPUT LO
  8.003  M4950  RNGLK 1mA            0%
  8.004  4950         0.000mA                                        F  N  2W
  8.005  IEEE         OUT 0mA;OPER;*OPC?[I!]
  8.006  4950   2.2   0.000mA        50P% 0.010U                           2W
  9.001  M4950  RNGLK 1mA            100%
  9.002  4950         1.000mA                                        F  N  2W
  9.003  IEEE         OUT 1mA;OPER;*OPC?[I!]
  9.004  4950   2.2   1.000mA        50P% 0.010U                           2W
 10.001  IEEE         *CLS;*RST;*OPC?[I!]
# -----  AC Current
 10.002  M4950  RNGLK 100mA          100%          10H
 10.003  4950         100.000mA                    10H               F  N  2W
 10.004  IEEE         OUT 100mA,10Hz;OPER;*OPC?[I!]
 10.005  4950   220   100.000mA      700P% 5e-6U   10H                     2W
 11.001  M4950  RNGLK 100mA          100%          1kH
 11.002  4950         100.000mA                    1kH               F  N  2W
 11.003  IEEE         OUT 100mA,1kHz;OPER;*OPC?[I!]
 11.004  4950   220   100.000mA      150P% 4e-6U   1kH                     2W
 12.001  IEEE         *CLS;*RST;*OPC?[I!]
# -----  4953 10A Current Shunt
 12.002  DISP         Connect the 4950 Input cable to 4953 Shunt as follows:
 12.002  DISP         [32] 4950 Hi Lead to 4953 Hi
 12.002  DISP         [32] 4950 Lo Lead to 4953 Lo
 12.002  DISP
 12.002  DISP         Connect the 5725A to the 4953 Shunt as follows:
 12.002  DISP         [32] 5725A CURRENT OUTPUT HI to 4953 I+
 12.002  DISP         [32] 5725A CURRENT OUTPUT LO to 4953 I-
 12.003  M4950  RNGLK 10A            100%
 12.004  4950         10.00000A                                      F  N  2W
 12.005  IEEE         OUT 10A;OPER;*OPC?[I!]
 12.006  4950   11    10.00000A      340P% 480e-9U                         2W
 13.001  M4950  RNGLK 10A            100%          40H
 13.002  4950         10.0000A                     40H               F  N  2W
 13.003  IEEE         OUT 10A,40Hz;OPER;*OPC?[I!]
 13.004  4950   11    10.0000A       400P% 170e-9U 40H                     2W
 14.001  M4950  RNGLK 10A            100%          5kH
 14.002  4950         10.0000A                     5kH               F  N  2W
 14.003  IEEE         OUT 10A,5kHz;OPER;*OPC?[I!]
 14.004  4950   11    10.0000A       850P% 380e-9U 5kH                     2W
 15.001  END


M4950

M4950 Auxiliary Instrument Setup FSC

Description

The M4950 FSC provides additional functions for the Datron 4950 Multimeter that are not addressed in the 4950 FSC. These functions include measurement range, percentage band, and guard.

Parameters

RANGE

This field must be RNGLK.

Rules:

  1. RNGLK is inserted automatically if no range field code is entered.

Nominal

This field specifies the locked range.

  • Voltage range selection value entered as: numeric[prefix]V
  • Current range selection value entered as: numeric[prefix]A
  • Resistance range selection value entered as: numeric[prefix]Z

Rules:

Function | M4950 Nominal | Locked Range
DC Voltage | >10 mV to 100 mV | 100 mV
 | >100 mV to 1 V | 1 V
 | >1 V to 10 V | 10 V
 | >10 V to 100 V | 100 V
 | >100 V to 1000 V | 1000 V
AC Voltage | 0 mV to 1 mV | 1 mV
 | >1 mV to 10 mV | 10 mV
 | >10 mV to 100 mV | 100 mV
 | >100 mV to 1 V | 1 V
 | >1 V to 10 V | 10 V
 | >10 V to 100 V | 100 V
 | >100 V to 1000 V | 1000 V
DC Current | 0 µA to 100 µA | 100 µA
 | >100 µA to 1 mA | 1 mA
 | >1 mA to 10 mA | 10 mA
 | >10 mA to 100 mA | 100 mA
 | >100 mA to 1 A | 1 A
 | >1 A to 10 A | 10 A
AC Current | 0 μA to 100 µA | 100 μA
 | >100 μA to 1 mA | 1 mA
 | >1 mA to 10 mA | 10 mA
 | >10 mA to 100 mA | 100 mA
 | >100 mA to 1 A | 1 A
 | >1 A to 10 A | 10 A
Resistance | 0 Ω to 10 Ω | 10 Ω
 | >10 Ω to 100 Ω | 100 Ω
 | >100 Ω to 1 kΩ | 1 kΩ
 | >1 kΩ to 10 kΩ | 10 kΩ
 | >10 kΩ to 100 kΩ | 100 kΩ
 | >100 kΩ to 1 MΩ | 1 MΩ
 | >1 MΩ to 10 MΩ | 10 MΩ
 | >10 MΩ to 100 MΩ | 100 MΩ

TOLERANCE

This field specifies the band selection value:

  • Band selection value entered as: 0 %, 10 %, 30 %, 70 %, 100 %, or 190 %.

Rules:

  1. See MOD1 field.
  2. The Tolerance field must be 0% when the 4950 FSC MOD3 field is ZR.

MOD1

This field specifies the frequency band center:

  • Band selection value entered as: numeric[prefix]H

Rules:

Function | Range Locked | M4950 Tolerance | M4950 MOD1
DC Voltage | 100 mV | 0 %, 100 % |
 | 1 V | 0 %, 100 % |
 | 10 V | 0 %, 100 %, 190 % |
 | 100 V | 0 %, 100 % |
 | 1000 V | 0 %, 100 % |
AC Voltage | 1 mV | 100 % | 10, 20, 30, 40, 55, 300 Hz, 1, 10, 20, 30, 50, 100, 300, 500 kHz, 1 MHz
 | 10 mV | 100 % | 10, 20, 30, 40, 55, 300 Hz 1, 10, 20, 30, 50, 100, 300, 500 kHz 1 MHz
 | 100 mV | 100 % | 10, 20, 30, 40, 55, 300 Hz 1, 10, 20, 30, 50, 100, 300, 500 kHz 1 MHz
 | 1 V | 100 % | 10, 20, 30, 40, 55, 300 Hz 1, 10, 20, 30, 50, 100, 300, 500 kHz 1 MHz
 | 10 V | 100 % | 10, 20, 30, 40, 55, 300 Hz 1, 10, 20, 30, 50, 100, 300, 500 kHz 1 MHz
 | 10 V | 190 % | 1 kHz
 | 100 V | 100 % | 10, 20, 30, 40, 55, 300 Hz 1, 10, 20, 30, 50, 100, 200 kHz
 | 1000 V | 70 % | 50, 100 kHz
 | 1000 V | 100 % | 10, 20, 30, 40, 55, 300 Hz 1, 10, 20, 30 kHz
DC Current | 100 μA | 0 %, 100 % |
 | 1 mA | 0 %, 100 % |
 | 10 mA | 0 %, 100 % |
 | 100 mA | 0 %, 100 % |
 | 1 A | 0 %, 100 % |
 | 10 A | 0 %, 100 % |
AC Current | 100 μA | 100 % | 10, 20, 30, 40, 55, 300 Hz 1, 5, 10, 20, 30 kHz
 | 1 mA | 100 % | 10, 20, 30, 40, 55, 300 Hz 1, 5, 10, 20, 30 kHz
 | 10 mA | 100 % | 10, 20, 30, 40, 55, 300 Hz 1, 5, 10, 20, 30 kHz
 | 100 mA | 100 % | 10, 20, 30, 40, 55, 300 Hz 1, 5, 10, 20, 30 kHz
 | 1 A | 100 % | 10, 20, 30, 40, 55, 300 Hz 1, 5, 10, 20, 30 kHz
 | 10 A | 100 % | 10, 20, 30, 40, 55, 300 Hz 1, 5, 10, 20 kHz
Resistance | 10 Ω | 0 %, 10 %, 30 %, 100 %, 190 % |
 | 100 Ω | 0 %, 30 %, 100 %, 190 % |
 | 1 kΩ | 0 %, 30 %, 100 %, 190 % |
 | 10 kΩ | 0 %, 30 %, 100 %, 190 % |
 | 100 kΩ | 0 %, 30 %, 100 %, 190 % |
 | 1 MΩ | 0 %, 30 %, 100 %, 190 % |
 | 10 MΩ | 0 %, 30 %, 100 %, 190 % |
 | 100 MΩ | 0 %, 30 %, 100 % |

MOD2

This field is not used.

MOD3

This field is not used.

MOD4

This field is used to specify the guard connection:

G Remote guard
blank

CON

This field is not used.

Examples

See 4950 FSC.


9000

Instrument FSC

Description

The 9000 FSC provides the means to control the following functions of the Datron 9000 Calibrator:

  • DC Voltage
  • AC Voltage (sine)
  • DC Current
  • AC Current (sine)
  • Resistance (resistance or conductance)
  • Frequency
  • Mark/Period (pulse)
  • % Duty (pulse)
  • Capacitance
  • Thermocouple Temperature
  • RTD Temperature

Functional Capability

DC Voltage | -1050 V to 1050 V
AC Voltage (Sine) | 0.000 V to 105 V | 10 Hz to 100 kHz
105.001 V to 350 V | 40 Hz to 30 kHz
320.01 V to 1050 V | 40 Hz to 30 kHz 1
DC Current | -20 A to 20 A
AC Current (Sine) | 0.00000 mA to 320 mA | 10 Hz to 30 kHz
0.32001 A to 20 A | 10 Hz to 10 kHz
Resistance | 0 Ω to 400 MΩ
2.5 nS to 2.49999 mS
Frequency 0.5 Hz to 10 MHz

+/-(0.01 Vp to 30 Vp)

|Vp| + |offset| < 30Vp
Mark/Period 0.6 μs to 2000.00 ms

+/-(0.01 Vp to 30 Vp)

|Vp| + |offset| < 30Vp
Pulse Width | 0.3 μs to 1999.99 ms
% Duty 0.05 % to 99.95 %

+/-(0.01 Vp to 30 Vp)

|Vp| + |offset| < 30Vp
Period | 0.6 μs to 2000.00 ms
Capacitance | 0.5 nF to 40 mF
RTD Temperature
Pt 385

-200 °C to 850 °C

100 Ω (fixed)
-328 °F to 1562 °F
7301 K to 1123.15 K
TC Temperature
Type K

-250 °C to 1350 °C

100 Ω (fixed)
-418 °F to 1832 °F
23.1 K to 1273.2 K
  1. Ramped to 10 kHz

Parameters

The following table describes the basic operating modes of the 9000 Calibrator in terms of the FSC fields listed. Only the combinations of field quantities listed below are allowed. These mode names are also used in other places in this section to clarify the rules for each parameter of the 9000 FSC.

Units Symbols
Units Symbol | Name | Quantity
A | Amps | current
App | Amps peak to peak | current
F | Farads | capacitance
H | Hertz | frequency
T | Time | period or pulse width
V | Volts | voltage
Vp | Volts peak | voltage
Vpp | Volts peak to peak voltage |
Y | Siemens | conductance
Z | Ohms | resistance
degC | degrees Celsius | temperature
degF | degrees Fahrenheit temperature |
K | Kelvin | temperature
9000 FSC NOMINAL, MOD1, MOD2, and CON Rules
9000 Mode (function) | 9000 NOMINAL | 9000 MOD1 | 9000 MOD2 1 | 9000 CON 2
DC Voltage | V | 2W
AC Voltage | V|Vpp | H|T | SI | 2W
H|T | V|Vpp | SI | 2W
DC Current | A | 2W
AC Current | A|App | H|T | SI | 2W
H|T | A|App | SI | 2W
Resistance | Z|Y | 2W|4W
Frequency | H|T | Vp | ZQ | 2W
Vp | H|T | ZQ | 2W
Mark/Period | H|T | Vp | PU | 2W
(pulse) | Vp | H|T | PU | 2W
% Duty (pulse) | pct | Vp | PU | 2W
Capacitance | F | 2W|4W
TC Temperature | degC|degF|K | _K | 2W
RTD Temperature | degC|degF|K | Z | R1 | 2W|4W
Blank entries in this table are significant and must be blank. FSC field inter-dependencies not expressed in this table are listed under "Rules" for the appropriate parameter.
  1. See MOD2 parameter for description of these specification codes.
  2. See CON parameter for description of these specification codes.

RANGE

This field specifies the UUT range as described in the RANGE Field topic.

NOMINAL

This field specifies the starting Nominal value of the stimulus output or expected UUT reading for the test entered as:

[numeric][prefix]units symbol

or "*" to specify a reset.

Rules:

  1. When the NOMINAL field contains only units, the value is obtained from memory register MEM. In this case the MOD1 field MUST contain a value if it is not blank.

TOLERANCE

This field specifies the UUT tolerance as described in the TOLERANCE Field topic.

MOD1

This field specifies the frequency, period, voltage, or current for AC Voltage or AC Current modes or the nominal resistance for RTD Temperature mode entered as:

[numeric][prefix]units symbol

Rules:

  1. When the MOD1 field contains only units, the value is obtained from memory register MEM. In this case the NOMINAL field MUST contain a value.
  2. For RTD Temperature, only a nominal resistance of 100 ohms is allowed.

MOD2

This field specifies the waveform, thermocouple, or RTD type.

blank | not applicable
SI | AC Voltage or AC Current (Sine)
_K | TC Temperature Mode (Type K)
R1 | RTD Temperature Mode (Pt 385)
PU | Pulse Mode (Mark/Period or % Duty)
ZQ | Frequency Mode (Hz)

Rules:

  1. SI is inserted automatically in the MOD2 field for AC Voltage, or AC Current (i.e. the MOD1 field is not blank) if no MOD2 code is entered.
  2. _K is inserted automatically in the MOD2 field for TC Temperature if no MOD2 code is entered.
  3. R1 is inserted automatically in the MOD2 field for RTD Temperature if no MOD2 code is entered.
  4. The M9000 RANGE and NOMINAL field must specify the pulse period or pulse repetition frequency when the MOD2 field specifies PU and the NOMINAL field specifies the pulse width.
  5. The M9000 RANGE and NOMINAL field must specify the pulse width when the MOD2 field specifies PU and the NOMINAL field specifies the pulse period or pulse repetition frequency.

MOD3

This field is used simply to make it easier to convert 55xxA based procedures to 9000 based procedures.

blank | not applicable
TC | Thermocouple simulation

Rules:

  1. TC is inserted automatically in the MOD3 field for TC Temperature if no MOD3 code is entered.

MOD4

This field specifies the type of test being performed as described in the MOD4 Field topic.

CON

This field specifies the UUT connection.

2W | 2-wire
4W | 4-wire

Rules:

  1. The CON field may specify 4W only for resistance, capacitance, and RTD temperature modes.

Use of Standard Memory Locations and Results Reporting

System memory locations MEM and MEM1 are used. For more information, refer to the Use of Standard Memory Registers topic.

Examples

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
# -----  Reset  -----
  1.001  M9000        *
  1.002  9000         *                                                 S
# -----  DC Voltage  -----
  1.003  9000   20    19.99mV        2% 0.04U                              2W
# -----  AC Voltage  -----
  2.001  9000   400   350.0mV        -2.8U +2.9U   60H            SI       2W
# -----  DC Current  -----
  3.001  9000   400   350mA          9U                                    2W
# -----  AC Current  -----
  4.001  9000         350.0mA                      60H            SI    S  2W
# -----  Resistance  -----
  4.002  9000   400   390.0Z         0.4% 0.1U                             4W
  5.001  9000   4     3.900MZ        0.05U                                 2W
# -----  Conductance  -----
  6.001  9000         2.50uY                                            N  2W
# -----  Capacitance ----
  6.002  9000   10    1.100uF        2% 0.002U                             2W
# -----  Frequency Function  -----
  7.001  9000         1kH                          1Vp            ZQ    S  2W
  7.002  M9000                                     1Voff
  7.003  9000         -1.00Vp                      1kH            ZQ    N  2W
# -----  Marker/Period (pulse) Function  -----
  7.004  M9000  PULSE 10uT
  7.005  9000         1mT                          1Vp            PU    S  2W
  7.006  M9000  PER   200mT
  7.007  9000         1mT                          1Vp            PU    S  2W
  7.008  M9000  PULSE 10uT                         -10Voff
  7.009  9000         -5.00Vp                      1kH            PU    N  2W
  7.010  M9000        *
# -----  TC Temperature  -----
  7.011  9000         50degC         1U                           _K TC    2W
# -----  RTD Temperature  -----
  8.001  9000         45degC                       100Z           R1    S  4W


M9000

M9000

Auxiliary Instrument Setup FSC

Description

The M9000 FSC provides the additional program functions for the Datron 9000 Calibrator which are not addressed by the 9000 FSC. The M9000 statement does not directly control the 9000 calibrator. M9000 works only in conjunction with the 9000 FSC.

Parameters

For a description of the 9000 Calibrator operating modes referred to in this section, see Table 1 in the 9000 Instrument FSC description.

RANGE

The RANGE field specifies the pulse width, pulse period, or pulse repetition frequency for Mark/Period mode.

• | PULSE | Pulse Width
• | PER | Pulse Period
• | blank | default or field not applicable

NOMINAL

The NOMINAL field specifies pulse width, pulse period, or reset.

  • Pulse Period entered as: [numeric][prefix]T
  • Pulse Width entered as: [numeric][prefix]H
  • Pulse Repetition Frequency entered as: [numeric][prefix]H
  • Reset entered as: *

When the NOMINAL field is not applicable it may be left blank.

Rules:

  • The NOMINAL field must specify the pulse period or pulse repetition frequency when the M9000 RANGE field is PER.
  • The NOMINAL field must specify the pulse width when the M9000 RANGE field is PULSE.
  • When the NOMINAL field does not specify a numeric value, the value is obtained from memory register MEM.
  • When the NOMINAL field specifies reset ("*"), all other fields must be blank.

TOLERANCE

This field is not used.

MOD1

This field specifies DC offset for Frequency or Mark/Period (pulse) mode, entered as: [numeric][prefix]Voff

Rules:

  • When the MOD1 field does not specify a numeric value, the value is obtained from memory register MEM.

MOD2

This field is not used.

MOD3

This field is not used.

MOD4

This field is not used.

CON

This field specifies the 9005 Work Mat connection for current or the UUT source current for Resistance and RTD Temperature modes. Temperature modes.

• C1 | 9005 Work Mat yellow lead (I+20A)
• C2 | 9005 Work Mat white lead (I+mA)
• LO | Low UUT source current
• HI | High UUT source current
• blank | Applicable default (C1 or LO)

Rules:

 | Mode (function) |  | M9000 CON | Connection
DC Current | [C1] | 9005 Work Mat Yel & Blk
 | C2 | 9005 Work Mat Wht & Blk
AC Current | [C1] | 9005 Work Mat Yel & Blk
 | C2 | 9005 Work Mat Wht & Blk
Mode (function) | 9000 Nominal | M9000 CON
Resistance | <40.001 Ohms | [LO]
 | ≥40.001 Ohms | [LO|HI]
 | Siemens (all) | [LO|HI]
RTD Temperature | <-149.29 degC | [LO]
 | ≥-149.30 degC | [LO|HI]
 | <-236.73 degF | [LO]
 | ≥-236.73 degF | [LO|HI]
 | <128.86 K | [LO]
 | ≥128.86 K | [LO|HI]

Examples

See 9000 FSC.


9500

Instrument FSC

Description

The 9500 FSC controls the following functions of the Fluke 9500 and 9500B, and the Wavetek 9500 Oscilloscope Calibrators:

  • DC Voltage
  • Square Voltage
  • Leveled Sine
  • Edge
  • Fast Edge
  • Time Markers
  • DC Current
  • Square Current
  • Composite Video
  • Linear Ramp
  • Zero Skew
  • Oscilloscope 50 Ω Input Impedance Overload Pulse
  • Oscilloscope Input Impedance Measurement
  • Trigger Signal
  • Pulse (9500B only)
You must configure the instrument as a "Datron 9500" as shown in the drop-down list in the "Add Instrument" configure dialog.

The M9500 FSC provides the additional program functions for the Datron 9500 and Fluke 9500B Oscilloscope Calibrators which are not addressed by the 9500 FSC.

  • Video Trigger
  • Edge Polarity
  • Signal Channel
  • Trigger Output Impedance
  • Trigger Channel
  • Pulse Width (9500B only)
  • Pulse Repetition Frequency (9500B only)
  • Pulse Period (9500B only)

Functional Capability

9500 Model | Maximum Frequency | Minimum Period
9500/400 | 400 MHz | 2.5 ns
9500(B)/600* | 600 MHz | 1.6666 ns
9500(B)/1100* | 1100 MHz | 909.09 ps
9500(B)/3200* | 3200 MHz | 312.50 ps
w/9560 Head | 6400 MHz | 156.25 ps
* (B) denotes 9500 and 9500B

Active Head* | Maximum Frequency | Minimum Period
9510 | 1.1 GHz | 909.09 ps
9520 | 1.1 GHz | 909.09 ps
9530 | 3.2 GHz | 312.50 ps
9550 | (see Fast Edge) |
9560 | 6.4 GHz | 256.25 ps
* See Determination of Active Head Requirement.

DC Voltage | Amplitude
Single Channel |
50 Ω term. | 0 V (Gnd) and ±(888 uV to 5.56 V)
1 MΩ term. | 0 V (Gnd) and ±(888 uV to 222.4 V)
Multi-channel (9500 B only) |
1 Ω term. | 0 V (Gnd) and ±(888 uV to 222.4 V)

Square Voltage | Amplitude | Frequency
Single Channel |  |
50 Ω term. | 35.521 uVpp to 5.56 Vpp | 10 Hz to 100 kHz
1 MΩ term. | 35.521 uVpp to 222.4 Vpp | 10 Hz to 100 kHz
Multi-channel (9500 B only) |  |
1 MΩ term. | 35.521 μVpp to 222.4 Vpp | 10 Hz to 100 kHz

Leveled Sine | Frequency | Amplitude
Single Channel |  |
50 Ω & 1 MΩ | 100 mHz to 550 MHz | 4.4401 mVpp to 5.560 Vpp
 | >550 MHz to 1.1 GHz | 4.4401 mVpp to 3.336 Vpp
50 Ω | >1.1 GHz to 2.5 GHz | 4.4401 mVpp to 3.336 Vpp
 | >2.5 GHz to 3.2 GHz | 4.4401 mVpp to 2.224 Vpp
 | >3.2 GHz to 6.4 GHz | 22.241 mVpp to 2.224 Vpp (9560 only)
Dual Channel |  |
50 Ω & 1 MΩ | 100 mHz to 550 MHz | 4.4401 mVpp to 2.780 Vpp
50 Ω | >550 MHz to 1.1 GHz | 4.4401 mVpp to 1.668 Vpp
 | >1.1 GHz to 3.2 GHz | 4.4401 mVpp to 1.668 Vpp (9560 only)

Low Edge | Amplitude | Frequency | Rise Time
50 Ω & 1 MΩ | 4.44 mVpp to 3.1 Vpp | 10 Hz to 2 MHz | ≤500 ps

High Edge | Amplitude | Frequency | Rise Time
50 Ω | 888 mVpp to 5.56 Vpp | 10 Hz to 100 kHz | ≤150 ns
1 MΩ | 888 mVpp to <100 Vpp | 10 Hz to 100 kHz | ≤150 ns
1 MΩ | 100 Vpp to 222.4 Vpp | 10 Hz to 100 kHz | ≤200 ns

Fast Edge | Amplitude | Frequency | Rise Time
9510 | not supported |  |
9520 and 9530 | 4.44 mVpp to 3.1 Vpp | 10 Hz to 2 MHz | ≤150 ps
9550 | 425 mVpp to 575 mVpp | 10 Hz to 1 MHz | ≤25 ps
9560 | 22.241 mVpp to 2.224 Vpp | 10 Hz to 1 MHz | ≤70 ps

Time Markers | Period | Amplitude
50 Ω |  |
Sine | 181.19 ps to 909.09 ps | 100 mVpp, 250 mVpp, 500 mVpp (9560 only)
Sine | 450.46 ps to 909.09 ps | 100 mVpp, 250 mVpp, 500 mVpp
Sine | 909.10 ps to 9 ns | 100 mVpp, 250 mVpp, 500 mVpp, 1 Vpp
Square | 9.0001 ns to 55.002 s | 100 mVpp, 250 mVpp, 500 mVpp, 1 Vpp
Pulse | 901.00 ns to 55.002 s | 100 mVpp, 250 mVpp, 500 mVpp, 1 Vpp
Triangle | 901.00 ns to 55.002 s | 100 mVpp, 250 mVpp, 500 mVpp, 1 Vpp
1 MΩ |  |
Sine | 450.46 ps to 909.09 ps | 100 mVpp, 250 mVpp, 500 mVpp
Sine | 909.10 ps to 9 ns | 100 mVpp, 250 mVpp, 500 mVpp, 1 Vpp
Square | 9.0001 ns to 55.002 s | 100 mVpp, 250 mVpp, 500 mVpp, 1 Vpp
Pulse | 901.00 ns to 55.002 s | 100 mVpp, 250 mVpp, 500 mVpp, 1 Vpp
Triangle | 901.00 ns to 55.002 s | 100 mVpp, 250 mVpp, 500 mVpp, 1 Vpp

DC Current | Amplitude
 | ±(88.8 μA to 111.2 mA)

Square Current | Amplitude | Frequency
 | 88.8 μApp to 111.2 mApp | 10 Hz to 100 kHz

Video | Amplitude | Video
NTSC | 0.3 Vpp | Black
 | 0.7 Vpp | Mid-Grey
 | 1.0 Vpp | White
PAL/SECAM | 0.3 Vpp | Black
 | 0.7 Vpp | Mid-Grey
 | 1.0 Vpp | White

Linear Ramp | Period | Amplitude
 | 3 s, 300 ms, 30 ms, 3 ms | 1 Vpp

Zero Skew | Frequency | Amplitude
 | 10 Hz to 100 MHz | 1 Vpp

Overload Pulse | Amplitude | Energy
 | ±(5 V to 20 V) | 1.6 J to 50.0 J

Function | UUT Input Impedance Measurement:
Resistance | 10 Ω to 150 Ω and 50 kΩ to 12 MΩ
Capacitance | 1 pF to 95 pF

Pulse (9500B only) | Pulse Width | Frequency | Amplitude
50 Ω | 1 ns to 100 ns | 1 kHz to 1 MHz | 1 Vpp

Parameters

Units Symbol | Name | Quantity
A | Amps | current
Ap | Amps peak | current
App | Amps peak to peak | current
F | Farads | capacitance
H | Hertz | frequency
J | Joule | energy
T | Time | period
V | Volts | voltage
Vp | Volts peak | voltage
Vpp | Volts peak to peak voltage |
Z | Ohms | resistance

9500 FSC NOMINAL, MOD1, MOD2, and MOD3 Rules
9500 Mode | 9500 NOMINAL | 9500 MOD1 | 9500 MOD21 | 9500 MOD3
DC Voltage | V
Square Voltage | V|Vp|Vpp | H|T | SQ|ZQ|ZN
H|T | V|Vpp | SQ|ZQ|ZN
Low Edge | V|Vp|Vpp | H|T | ED
H|T | V|Vpp | ED
High Edge | V|Vp|Vpp | H|T | HE
H|T | V|Vpp | HE
Fast Edge | V|Vp|Vpp | H|T | FE | [7 E|EF]
H|T | V|Vpp | FE | [7 E|EF]
Leveled Sine | V|Vp|Vpp | H|T | LS
H|T | V|Vpp | LS
Linear Ramp | Vpp | T | LR
T | Vpp | LR-
Time Marker | T|H | Vpp | M1|M2|M3|M4
DC Current | A
Square Current | A|Ap|App | H|T | SQ
H|T | A|App | SQ
Video | Vpp | F1|F2
Overload Pulse | V | J | OP
Zero Skew | H|T | Vpp | ZK | [PR]
Impedance Meas | Z|F | ZM
Pulse | H|T | Vpp | PU
  1. See MOD2 parameter for description of these specification codes and rules.

Blank entries in the above table are significant and must be blank. FSC field inter-dependencies not expressed in this table are listed under "Rules" for the appropriate parameter.

RANGE

This field specifies the UUT range as described in the RANGE Field topic.

NOMINAL

This field specifies the starting Nominal value of the stimulus output or expected UUT reading for the test entered as:

[numeric][prefix]units symbol

or "*" to specify a reset.

Rules:

  1. When the NOMINAL field contains only units, the value is obtained from the memory register MEM.
  2. When the NOMINAL field contains only units and the MOD1 field is not blank, the MOD1 field must specify a value.

TOLERANCE

This field specifies the UUT tolerance as described in the TOLERANCE Field topic.

MOD1

This field specifies frequency, period, voltage, or energy entered as:

[numeric][prefix]units symbol

Rules:

  1. When the MOD1 field contains only units, the value is obtained from memory register MEM. In this case the NOMINAL field MUST contain a value.

MOD2

This field specifies one of the following:

1. The waveform type for the voltage or specified in the NOMINAL or MOD1 field for AC Voltage.

blank | DC or not applicable
SQ | Squarewave (symmetrical)
ZQ | Squarewave (positive)
ZN | Squarewave (negative)
ED | Low-Edge signal
HE | High-Edge signal
FE | Fast-Edge signal
M1 | Triangle Marker signal
M2 | Square Marker signal
M3 | Pulse Marker signal
M4 | Sine Marker signal
LS | Leveled sine wave
F1 | NTSC composite video signal
F2 | PAL/SECAM composite video signal
LR | Linear Ramp
OP | Overload Pulse
ZK | Zero Skew

Rules:

  1. ZQ is inserted automatically in the MOD2 field for AC Voltage (i.e. the MOD1 field is not blank) if no MOD2 code is entered.
  2. SQ is inserted automatically in the MOD2 field for AC Current. (i.e. the MOD1 field is not blank) if no MOD2 code is entered.
  3. The MOD2 field may specify fast edge "FE", only when a 9520, 9530, or 9550 Active Head is configured on the signal channel specified in the M9500 FSC MOD2 field.
  4. When the MOD2 field specifies "ZK" (Zero Skew) the M9500 FSC TOLERANCE field must specify two, three, four, or five signal channels.

MOD3

This field specifies the calibrator mode:

blank | Not applicable
ZM | Input (UUT Impedance Measurement)
+V | Positive Video Polarity
-V | Negative Video Polarity
EF | Use 9550 Active Head for Fast Edge
7 E | Use 9560 Active Head for Fast Edge
PR | Use zero skew precision adjustments already performed and stored manually.

Rules:

  1. ZM is inserted automatically in the MOD3 field when the Nominal field units are Ohms or Farads.
  2. The MOD3 field must specify +V or -V when MOD2 is F1 or F2.
  3. The MOD3 field may specify EF only when the MOD2 field specifies FE.
  4. The MOD3 field may specify 7 E only when the MOD2 field specifies FE.
  5. The MOD3 field may specify PR only when the MOD2 field specifies ZK.

MOD4

This field specifies the type of test being performed as described in the MOD4 Field topic.

Additional Rules:

  1. The MOD4 field must specify S (Setup Test) when the MOD2 field specifies OP (Overload Pulse).

CON

This field specifies the UUT connection.

blank | 1 MΩ Termination
L | 50 Ω Termination
2 W | 2-Wire

Rules:

  1. 2 W is inserted automatically in the CON field when the MOD3 is ZM.
  2. The CON field must specify 2 W when the MOD3 field specifies ZM.
  3. The CON field must be blank (1 MΩ) for multi-channel DC Voltage (i.e., the M9500 TOLERANCE field specifies two or more signal channels).
  4. The CON field must be L for any of the following conditions:
    1. Nominal field specifies current.
    2. MOD1 field specifies current.
    3. The MOD2 field specifies fast edge (FE).
    4. The MOD2 field specifies overload pulse (OP).
    5. The MOD2 field specifies zero skew (ZK).
  5. L is inserted automatically in the CON field for any of the following conditions if no CON field code is entered:
    1. Nominal field specifies current.
    2. MOD1 field specifies current.
    3. The MOD2 field specifies fast edge (FE).
    4. The MOD2 field specifies overload pulse (OP).
    5. The MOD2 field specifies zero skew (ZK).

Use of Standard Memory Locations and Results Reporting

System memory locations MEM and MEM1 are used. For more information, refer to the Use of Standard Memory Registers topic.

Examples

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
# -----  Reset  -----
  1.001  M9500        *
  1.002  9500         *                                                 S
# -----  DC Voltage  -----
  1.003  9500   20    19.99mV        4%
# -----  AC Voltage (Positive Scope Square Wave)  -----
  2.001  9500   400   350.0mV        50U           60H            ZQ
# -----  AC Voltage (Negative Scope Square Wave)  -----
  3.001  9500         100Vpp                       1kH            ZN    S
# -----  AC Voltage (Frequency Test)  -----
  3.002  9500   1000  800.0H         0.1% 0.1U     300mV          ZQ
# -----  Low-Edge Signal (Scope Output)  -----
  4.001  9500         0.5Vpp                       500kH          ED    S  L
# -----  High-Edge Signal (Scope Output)  -----
  4.002  9500         100Vpp                       100kH          HE    S
  4.003  9500         100Vpp                       100kH          HE    S
# -----  Fast-Edge Signal (Scope Output)  -----
  4.004  M9500                       CH1
  4.005  9500         10mVpp                       1MH            FE    S  L
# -----  Triangle Marker Signal  -----
  4.006  M9500                       CH1
  4.007  9500         1uT                          1Vpp           M1    S  L
  4.008  M9500        *
# -----  Square Marker Signal  -----
  4.009  9500         1mT                          1Vpp           M2    S  L
# -----  Pulse Marker Signal  -----
  4.010  9500         5uT                          1Vpp           M3    S  L
# -----  Sinusoid Marker Signal  -----
  4.011  9500         2nT                          1Vpp           M4    S  L
# -----  NTSC Video  -----
  4.012  9500         1Vpp                                        F1 +V S  L
  4.013  M9500        *
# -----  PAL Video  -----
  4.014  9500         0.7Vpp                                      F2 -V S  L
# -----  Linear Ramp Signal  -----
  4.015  9500         300mT                        1Vpp           LR    S  L
# -----  Zero Skew Function  -----
  4.016  M9500                       CH1234
  4.017  9500         500kH                        1Vpp           ZK    S  L
# -----  Impedance Measurement (50 Ohm)  -----
  4.018  M9500        *
  4.019  9500         50Z            1U                              ZM    2W
# -----  Impedance Measurement (1 MOhm)  -----
  5.001  9500         1.000MZ        1U                              ZM    2W
# -----  Impedance Measurement (Capacitance)  -----
  6.001  9500         10pF                                           ZM N  2W
# -----  Overload Pulse  -----
  6.002  HEAD         {CH 1 50 Ohm OVERLOAD PROTECTION}
  6.003  DISP         Connect 9500 CH 1 Active Head to UUT CH 1.
  6.004  SET          VERTICAL MODE CH 1: ON
  6.004  SET          VERTICAL MODE CH 2: OFF
  6.004  SET          VERTICAL MODE CH 3: OFF
  6.004  SET          VERTICAL MODE CH 4: OFF
  6.004  SET          COUPLING CH 1 : 50 Ohm
  6.004  SET          VOLTS/DIV CH 1 : 1V
  6.004  SET          TRIGGER SOURCE : CH 1
  6.005  HEAD         CH 1 50 Ohm OVERLOAD PROTECTION: 5V test ~60s
# 5V at 30J = 60s duration.
  6.006  9500         5V                           30J            OP    S  L
  6.007  MATH         MEM2 = "No overload at 5V"
  6.008  EVAL   -s MEM2 : [N]Does the UUT display show "50 Ohm OVERLOAD"?
  7.001  SET          VOLTS/DIV CH 1 : 5V
  7.002  HEAD         CH 1 50 Ohm OVERLOAD PROTECTION: 20V test ~12.5s
# 20V at 50J = 6.25s. Spec is 10s so two setup statements are needed.
  7.003  9500         20V                          50J            OP    S  L
  7.004  9500         20V                          50J            OP    S  L
  7.005  MATH         MEM2 = "50 Ohm Overload at 20V"
  7.006  EVAL   -s MEM2 : Does the UUT display show "50 Ohm OVERLOAD"?

Determination of Active Head Requirement

MET/CAL attempts to determine the minimum capability active head which is required to execute a 9500 statement. For example the following statement specifies a 3.2 GHz, 1 Vpp, 50 Ω Leveled-sine wave signal from the 9500:

1.001 9500 3.2GH 1Vpp LS S L

This signal requires at least a 9530 Active Head. However at run time, the statement will also execute if a 9560 Active Head is physically used.

In addition MET/CAL also attempts to determine the output channel that the signal is routed to. If no explicit output channel is specified, channel 1 is presumed. Therefore the above statement, by itself, will generate the following entries in the procedure header:

CONFIGURATION:         Datron 9500 (G3)
CONFIGURATION:         Datron 9530 on channel 1

(G3) specifies that a 9500/3200 or 9500B/3200 is required.

The output channel may be specified using the M9500 FSC.

  1.001  M9500                       CH2
  1.001  9500         3.2GH                        1Vpp           LS    S  L

In this case, the entries in the procedure header would be:

CONFIGURATION:         Datron 9500 (C5,G3)
CONFIGURATION:         Datron 9530 on channel 2

Note the 9530 is now required on channel 2. (C5) has also been added since Option 5 (five channel output is required).

Now, the above process for determining the Active Head requirement works fine as long as MET/CAL can correctly determine the output channel that will be used at run time. However, problems can occur when MET/CAL procedure writers use a subprocedure to perform a particular test and then call the subprocedure for each UUT input channel.

The UUT is a four channel oscilloscope. The manufacturer's service manual lists the steps necessary to perform a bandwidth test. The manual then dictates that the test be performed on each input channel.

The procedure writer develops a channel independent subprocedure to perform a bandwidth test:

Copyright (c) (2014) Fluke Corporation.                  All rights reserved.
=============================================================================
INSTRUMENT:            Sub Bandwidth Test
DATE:                  2014-07-31 13:29:12
AUTHOR:                Fluke Calibration
REVISION:              $Revision: $
ADJUSTMENT THRESHOLD:  70%
NUMBER OF TESTS:       1
NUMBER OF LINES:       24
CONFIGURATION:         Datron 9500
CONFIGURATION:         Datron 9510 on channel 1
=============================================================================
 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
  1.001  HEAD         ANALOG BANDWIDTH
  1.002  HEAD         -2 Channel [V @Chan]
#                     .
#                     .
#                     .
  1.003  9500         0.600Vpp                     3MH            LS    S  L
#                     .
#                     .
#                     .
  1.004  END

Note the subprocedure header only requires a 9530 on channel 1, because no M9500 statement is included. The M9500 statement is omitted to make the subprocedure channel independent.

The procedure then writes a main procedure which calls the bandwidth subprocedure for each UUT channel.

Copyright (c) (2014) Fluke Corporation.                  All rights reserved.
=============================================================================
INSTRUMENT:            Main
DATE:                  2014-07-31 13:29:49
AUTHOR:                Fluke Calibration
REVISION:              $Revision: $
ADJUSTMENT THRESHOLD:  70%
NUMBER OF TESTS:       1
NUMBER OF LINES:       28
=============================================================================
 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON

  1.001  MATH         @Chan = 1
  1.002  M9500                       CH1
  1.003  CALL         Sub Bandwidth Test

  1.004  MATH         @Chan = 2
  1.005  M9500                       CH2
  1.006  CALL         Sub Bandwidth Test

  1.007  MATH         @Chan = 3
  1.008  M9500                       CH3
  1.009  CALL         Sub Bandwidth Test

  1.010  MATH         @Chan = 4
  1.011  M9500                       CH4
  1.012  CALL         Sub Bandwidth Test
  1.013  END

Note the main procedure header does not list a 9500 or any active heads as required. Now if the procedure is executed, the M9500 statements in the main procedure will designate the output channel to be used before each call to the subprocedure. The 9500 run time driver will use this information when the 9500 statement is executed to select the correct output channel. However when the driver attempts to designate the Active connected to this output channel as "used", an error will be generated. The error at this point is due to the MET/CAL Runtime driver attempting to use a traceable asset, the active head, which was not required by the main procedure or any subprocedure as indicated in the header.

To avoid this problem, the main or subprocedure header must contain configuration lines for the actual output channels that will be used. The most straight forward way to accomplish this is to include "dummy" statements in the main procedure that force the configuration lines to be generated.

Copyright (c) (2014) Fluke Corporation.                  All rights reserved.
=============================================================================
INSTRUMENT:            Main
DATE:                  2014-07-31 13:30:15
AUTHOR:                Fluke Calibration
REVISION:              $Revision: $
ADJUSTMENT THRESHOLD:  70%
NUMBER OF TESTS:       1
NUMBER OF LINES:       44
CONFIGURATION:         Datron 9500 (C5,G3)
CONFIGURATION:         Datron 9530 on channel 1
CONFIGURATION:         Datron 9530 on channel 2
CONFIGURATION:         Datron 9530 on channel 3
CONFIGURATION:         Datron 9530 on channel 4
=============================================================================
 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON

  1.001  IF           0
  1.002  M9500                       CH1
  1.003  9500         3GH                          1Vpp           LS    S  L
  1.004  M9500                       CH2
  1.005  9500         3GH                          1Vpp           LS    S  L
  1.006  M9500                       CH3
  1.007  9500         3GH                          1Vpp           LS    S  L
  1.008  M9500                       CH4
  1.009  9500         3GH                          1Vpp           LS    S  L
  1.010  ENDIF

  1.011  MATH         @Chan = 1
  1.012  M9500                       CH1
  1.013  CALL         Sub Bandwidth Test

  1.014  MATH         @Chan = 2
  1.015  M9500                       CH2
  1.016  CALL         Sub Bandwidth Test

  1.017  MATH         @Chan = 3
  1.018  M9500                       CH3
  1.019  CALL         Sub Bandwidth Test

  1.020  MATH         @Chan = 4
  1.021  M9500                       CH4
  1.022  CALL         Sub Bandwidth Test
  1.023  END


M9500

Instrument Setup FSC

Description

The M9500 FSC provides the additional program functions for the Datron 9500 and Fluke 9500B Oscilloscope Calibrators which are not addressed by the 9500 FSC.

  • Video Trigger
  • Edge Polarity
  • Signal Channel
  • Trigger Output Impedance
  • Trigger Channel
  • Pulse Width (9500B only)
  • Pulse Repetition Frequency (9500B only)
  • Pulse Period (9500B only)

Parameters

9500 NOMINAL, MOD1, MOD2, MOD3 and M9500 RANGE and NOMINAL Rules
9500 Mode | 9500 NOMINAL | 9500 MOD1 | 9500 MOD2 | 9500 MOD3 | M9500 RANGE | M9500 NOMINAL
Video | amplitude |  | F1|F2 | +V|-V | [COMP|FRAME] |
Low Edge | amplitude | freq|per | ED |  | [RISE|FALL] |
 | freq|per | amplitude | ED |  | [RISE|FALL] |
High Edge | amplitude | freq|per | HE |  | [RISE|FALL] |
 | freq|per | amplitude | HE |  | [RISE|FALL] |
Fast Edge | amplitude | freq|per | FE | [EF] | [RISE|FALL] |
 | freq|per | amplitude | FE | [EF] | [RISE|FALL] |
 | amplitude | freq|per | FE | 7E | [RISE] |
 | freq|per | amplitude | FE | 7E | [RISE] |
Pulse | width | 1Vpp | PU | PER |  | freq|per
 | freq|per | 1Vpp | PU | PULSE |  | width
Blank entries in the above table are significant and must be blank. FSC field inter-dependencies not expressed in this table are listed under "Rules" for the appropriate parameter.

RANGE

This field specifies one of the following:

COMP | Trigger Composite (Video)
FRAME | Trigger Frame (Video)
RISE | Polarity (Edge)
FALL | Polarity (Edge)
PULSE | Pulse Width (9500B only)
PER | Pulse Period (9500B only)
blank | field not applicable

NOMINAL

This field specifies one of the following:

  • Pulse Width entered as: [numeric][prefix]T or H
  • Pulse Period entered as: [numeric][prefix]T
  • Pulse Repetition Frequency entered as: [numeric][prefix]H
  • "*" reset to default values
  • blank field not applicable

TOLERANCE

This field selects the signal channel(s).

blank | CH 1
CH1 | CH 1
CH2 | CH 2
CH3 | CH 3
CH4 | CH 4
CH5 | CH 5
CH12 | CH 1 & CH 2
CH13 | CH 1 & CH 3
CH14 | CH 1 & CH 4
CH15 | CH 1 & CH 5
CH23 | CH 2 & CH 3
CH24 | CH 2 & CH 4
CH25 | CH 2 & CH 5
CH34 | CH 3 & CH 4
CH35 | CH 3 & CH 5
CH45 | CH 4 & CH 5
CH123 | CH 1, CH 2, & CH 3
CH124 | CH 1, CH 2, & CH 4
CH125 | CH 1, CH 2, & CH 5
CH134 | CH 1, CH 3, & CH 4
CH135 | CH 1, CH 3, & CH 5
CH145 | CH 1, CH 4, & CH 5
CH234 | CH 2, CH 3, & CH 4
CH235 | CH 2, CH 3, & CH 5
CH245 | CH 2, CH 4, & CH 5
CH345 | CH 3, CH 4, & CH 5
CH1234 | CH 1, CH 2, CH 3, & CH 4
CH1235 | CH 1, CH 2, CH 3, & CH 5
CH1245 | CH 1, CH 2, CH 4, & CH 5
CH1345 | CH 1, CH 3, CH 4, & CH 5
CH2345 | CH 2, CH 3, CH 4, & CH 5
CH12345 | CH 1, CH 2, CH 3, CH 4, & CH 5

Rules:

  1. Option 5 is required when the signal channel is 2, 3, 4, or 5.
  2. When the mode is Leveled Sine (9500 MOD2 is "LS") the M9500 TOLERANCE field may specify one or two signal channels.
  3. When the mode is Zero Skew (9500 MOD2 is "ZK") the Tolerance field must specify two, three, four, or five signal channels.
  4. When the mode is 1 MΩ DC Voltage (9500 NOMINAL units are V and 9500 MOD1, MOD2, and CON are blank) the Tolerance field may specify two, three, four, or five signal channels.
  5. For all other modes and 50 Ω DC Voltage) the TOLERANCE field may specify only one signal channel.
  6. When the mode is Leveled Sine or DC Voltage with multi-channel output, if any channel uses the 9560 Active Head, all other channels selected must also use a 9560 Active Head. Also see Determination of Active Head Requirement in the 9500 FSC help topic.

MOD1

This field is not used.

MOD2

This field is not used.

MOD3

This field is not used.

MOD4

This field specifies the trigger output impedance.

blank | 1 MΩ Termination
L | 50 Ω Termination

Rules:

  1. The MOD4 field must be blank when the CON field is blank.
  2. Option 5 is required when the CON field specifies a trigger channel and the MOD4 field is blank (1 MΩ termination).

CON

blank | Trigger Output off
1T1 | Trigger Output on Channel 1, Normal mode
2T1 | Trigger Output on Channel 1, 1/10 of output rate
3T1 | Trigger Output on Channel 1, 1/100 of output rate
1T2 | Trigger Output on Channel 2, Normal mode
2T2 | Trigger Output on Channel 2, 1/10 of output rate
3T2 | Trigger Output on Channel 2, 1/100 of output rate
1T3 | Trigger Output on Channel 3, Normal mode
2T3 | Trigger Output on Channel 3, 1/10 of output rate
3T3 | Trigger Output on Channel 3, 1/100 of output rate
1T4 | Trigger Output on Channel 4, Normal mode
2T4 | Trigger Output on Channel 4, 1/10 of output rate
3T4 | Trigger Output on Channel 4, 1/100 of output rate
1T5 | Trigger Output on Channel 5, Normal mode 1
2T5 | Trigger Output on Channel 5, 1/10 of output rate 1
3T5 | Trigger Output on Channel 5, 1/100 of output rate 1
  1. For a single channel 9500, channel 5 is the trigger channel. Use 1T5, 2T5, or 3T5 with MOD4 = “L” (50 Ω).

Rules:

  1. The CON field must be blank for any of the following conditions:
    1. The M9500 Tolerance field is blank.
    2. The M9500 Tolerance field specifies three or more output channels (zero skew).
    3. The 9500 MOD2 field specifies zero skew "ZK".
    4. The 9500 MOD3 field specifies impedance measurement "ZM".
  2. When a trigger output channel is specified the trigger channel number cannot be the same as a signal output channel specified in the Tolerance field.
  3. Option 5 is required when the trigger channel is 1, 2, 3, or 4.

Examples

See 9500 FSC.


45

Instrument FSC

Description

The 45 FSC programs the Fluke 45 Dual Display Multimeter to measure DC voltage, AC voltage, DC current, AC current, resistance, frequency, audio power, or decibels.

If the 45 is to be controlled via its serial port, do not use the PORT FSC port configuration special construction, [P9600,N,...], to set the baud rate, parity, etc. of the port used to control the 45. MET/CAL executes a “Test” function for each System Instrument prior to executing any procedure statements, therefore the settings of the port used to controlling the 45 must be set correctly before a procedure is executed. If the 45 is connected to a standard serial port (COM1, COM2, ..., COM16), select the “Ports” application in the Windows control panel to choose the proper settings.If the 45 is connected to the 5500A, 5520A, or 5800A UUT port, select the proper settings for the UUT Serial Port from the front panel of the calibrator.

The 45 setting “Echo Off” must be used for serial control by MET/CAL.

Functional Capability

Function | 45 NOMINAL | 45 MOD1 | 45 MOD3 | M45 NOMINAL
DC Voltage | -999.99 V to 999.99 V
DC Voltage w/6 kV Probe | -6 kV to 6 kV | F
DC Voltage w/40 kV Probe | +/-(1 kV to 40 kV) | G
AC Voltage 1 | 15 mV to 200 V | 10 Hz to 100 kHz
15 mV to 400 V | 10 Hz to 50 kHz
15 mV to 750 V | 10 Hz to 20 kHz
DC Current (100 mA Input) | -99.999 mA to 99.999 mA
DC Current (10 A Input) | -9.9999 A to 9.9999 A | E
AC Current (100 mA Input) | 1.5 mA to 99.999 mA | 20 Hz to 20 kHz
AC Current (10 A Input) | 0.5 A to 9.9999 A | 20 Hz to 2 kHz | E
Resistance | 0 Ohm to 98 MOhm
Frequency | 5 Hz to 20 kHz | 30 mV to 750 V
5 Hz to 50 kHz | 30 mV to 400 V
5 Hz to 100 kHz | 30 mV to 200 V
100 kHz to 300 kHz | 100 mV to 1
300 kHz to 1 MHz | 1 V to 1
Audio Power | 10 mW to 999.99 W | blank (DC) | 2,4,8, or 16
10 Hz to 100 kHz | Ohm
dBm | -77.45 dBm to 86.99 dBm | blank (DC) | 2 Ω
-9.49 dBm to 73.01 dBm | 10 Hz to 100 kHz
-9.49 dBm to 79.03 dBm | 10 Hz to 50 kHz
-9.49 dBm to 84.49 dBm | 10 Hz to 20 kHz
dBm | -80.46 dBm to 83.98 dBm | blank (DC) | 4 Ω
-12.50 dBm to 70.00 dBm | 10 Hz to 100 kHz
-12.50 dBm to 76.02 dBm | 10 Hz to 50 kHz
-12.50 dBm to 81.48 dBm | 10 Hz to 20 kHz
dBm | -83.47 dBm to 80.97 dBm | blank (DC) | 8 Ω
-15.51 dBm to 66.99 dBm | 10 Hz to 100 kHz
-15.51 dBm to 73.01 dBm | 10 Hz to 50 kHz
-15.51 dBm to 78.47 dBm | 10 Hz to 20 kHz
dBm | -86.48 dBm to 77.96 dBm | blank (DC) | 16 Ω
-18.52 dBm to 63.98 dBm | 10 Hz to 100 kHz
-18.52 dBm to 70.00 dBm | 10 Hz to 50 kHz
-18.52 dBm to 75.46 dBm | 10 Hz to 20 kHz
dBm | -91.43 dBm to 73.01 dBm | blank (DC) | 50 Ω
-23.47 dBm to 59.03 dBm | 10 Hz to 100 kHz
-23.47 dBm to 65.05 dBm | 10 Hz to 50 kHz
-23.47 dBm to 70.51 dBm | 10 Hz to 20 kHz
dBm | -93.19 dBm to 71.25 dBm | blank (DC) | 75 Ω
-25.23 dBm to 57.27 dBm | 10 Hz to 100 kHz
-25.23 dBm to 63.29 dBm | 10 Hz to 50 kHz
-25.23 dBm to 68.75 dBm | 10 Hz to 20 kHz
dBm | -94.12 dBm to 70.32 dBm | blank (DC) | 93 Ω
-26.16 dBm to 56.34 dBm | 10 Hz to 100 kHz
-26.16 dBm to 62.36 dBm | 10 Hz to 50 kHz
-26.16 dBm to 67.82 dBm | 10 Hz to 50 kHz
dBm | -94.85 dBm to 69.59 dBm | blank (DC) | 110 Ω
-26.89 dBm to 55.61 dBm | 10 Hz to 100 kHz
-26.89 dBm to 61.63 dBm | 10 Hz to 50 kHz
-26.89 dBm to 67.09 dBm | 10 Hz to 20 kHz
dBm | -95.37 dBm to 69.07 dBm | blank (DC) | 124 Ω
-27.41 dBm to 55.09 dBm | 10 Hz to 100 kHz
-27.41 dBm to 61.11 dBm | 10 Hz to 50 kHz
-27.41 dBm to 66.57 dBm | 10 Hz to 20 kHz
dBm | -95.41 dBm to 69.03 dBm | blank (DC) | 125 Ω
-27.45 dBm to 55.05 dBm | 10 Hz to 100 kHz
-27.45 dBm to 61.07 dBm | 10 Hz to 50 kHz
-27.45 dBm to 66.53 dBm | 10 Hz to 20 kHz
dBm | -95.74 dBm to 68.70 dBm | blank (DC) | 135 Ω
-27.78 dBm to 54.72 dBm | 10 Hz to 100 kHz
-27.78 dBm to 60.74 dBm | 10 Hz to 50 kHz
-27.78 dBm to 66.20 dBm | 10 Hz to 20 kHz
dBm | -96.20 dBm to 68.24 dBm | blank (DC) | 150 Ω
-28.24 dBm to 54.26 dBm | 10 Hz to 100 kHz
-28.24 dBm to 60.28 dBm | 10 Hz to 50 kHz
-28.24 dBm to 65.74 dBm | 10 Hz to 20 kHz
dBm | -98.42 dBm to 66.02 dBm | blank (DC) | 250 Ω
-30.46 dBm to 52.04 dBm | 10 Hz to 100 kHz
-30.46 dBm to 58.06 dBm | 10 Hz to 50 kHz
-30.46 dBm to 63.52 dBm | 10 Hz to 20 kHz
dBm | -99.21 dBm to 65.23 dBm | blank (DC) | 300 Ω
-31.25 dBm to 51.25 dBm | 10 Hz to 100 kHz
-31.25 dBm to 57.27 dBm | 10 Hz to 50 kHz
-31.25 dBm to 62.73 dBm | 10 Hz to 20 kHz
dBm | -101.43 dBm to 63.01 dBm | blank (DC) | 500 Ω
-33.47 dBm to 49.03 dBm | 10 Hz to 100 kHz
-33.47 dBm to 55.05 dBm | 10 Hz to 50 kHz
-33.47 dBm to 60.51 dBm | 10 Hz to 20 kHz
dBm | -102.22 dBm to 62.22 dBm | blank (DC) | 600 Ω
-34.26 dBm to 48.24 dBm | 10 Hz to 100 kHz
-34.26 dBm to 54.26 dBm | 10 Hz to 50 kHz
-34.26 dBm to 59.72 dBm | 10 Hz to 20 kHz
dBm | -103.47 dBm to 60.97 dBm | blank (DC) | 800 Ω
-35.51 dBm to 46.99 dBm | 10 Hz to 100 kHz
-35.51 dBm to 53.01 dBm | 10 Hz to 50 kHz
-35.51 dBm to 58.47 dBm | 10 Hz to 20 kHz
dBm | -103.98 dBm to 60.46 dBm | blank (DC) | 900 Ω
-36.02 dBm to 46.48 dBm | 10 Hz to 100 kHz
-36.02 dBm to 52.50 dBm | 10 Hz to 50 kHz
-36.02 dBm to 57.96 dBm | 10 Hz to 20 kHz
dBm | -104.44 dBm to 60.00 dBm | blank (DC) | 1 kΩ
-36.48 dBm to 46.02 dBm | 10 Hz to 100 kHz
-36.48 dBm to 52.04 dBm | 10 Hz to 50 kHz
-36.48 dBm to 57.50 dBm | 10 Hz to 20 kHz
dBm | -105.23 dBm to 59.21 dBm | blank (DC) | 1.2 kΩ
-37.27 dBm to 45.23 dBm | 10 Hz to 100 kHz | 1 kΩ
-37.27 dBm to 51.25 dBm | 10 Hz to 50 kHz
-37.27 dBm to 56.71 dBm | 10 Hz to 20 kHz
dBm | -113.47 dBm to 50.97 dBm | blank (DC) | 8 kΩ
-45.51 dBm to 36.99 dBm | 10 Hz to 100 kHz
-45.51 dBm to 43.01 dBm | 10 Hz to 50 kHz
-45.51 dBm to 48.47 dBm | 10 Hz to 20 kHz
  1. Volt-Hertz product not to exceed 1e6

Parameters

RANGE

This field specifies the UUT range as described in the RANGE Field topic.

NOMINAL

This field specifies the expected measured value or a reset.

  • Voltage (DC or RMS) entered as: [numeric][prefix]V
  • dBm entered as: [numeric][prefix]D
  • Audio Power entered as: [numeric][prefix]W
  • Current entered as [numeric][prefix]A
  • Resistance entered as [numeric][prefix]Z
  • Frequency entered as [numeric][prefix]H
  • Reset entered as *.

Rules:

  1. The NOMINAL field may specify audio power only when the M45 FSC specifies the reference impedance as 2, 4, 8, or 16 Ohms.
  2. The NOMINAL field may specify decibels only when the M45 FSC specifies the reference impedance.

TOLERANCE

This field specifies the UUT tolerance as described in the TOLERANCE Field topic.

MOD1

This field specifies frequency for AC voltage and AC current measurements or voltage for frequency measurements. See the NOMINAL field specification for allowed values and units.

  • Frequency entered as numeric[prefix]H
  • Voltage entered as: numeric[prefix]V
  • blank not applicable

Rules:

  1. The MOD1 field may specify voltage only when the NOMINAL field specifies frequency.
  2. The MOD1 field must be blank when the NOMINAL field specifies resistance or the MOD3 field specifies “F” or “G”.

MOD2

This field is not used.

MOD3

This field specifies one of the following:

E | Current measurement using the 10 A input.
F | DC Voltage measurement using 6 kV probe
G | DC Voltage measurement using 40 kV probe
blank | field not applicable

Rules:

  1. The MOD3 field may specify E only when the NOMINAL field specifies current.
  2. E is automatically inserted in the MOD3 field when current is specified in the NOMINAL field with a value greater than or equal to 100 mA.
  3. E may be specified for current lower than 100 mA to avoid connection changes.
  4. The MOD3 field may specify F or G only when the NOMINAL field specifies voltage.
  5. F is automatically inserted in the MOD3 field when DC Voltage is specified and the NOMINAL field value is greater than 1000 V and less than or equal to 6000 V.
  6. G is automatically inserted in the MOD3 field when DC Voltage is specified and the NOMINAL field value is greater than 6000 V.
  7. F or G may be specified at lower voltages to avoid connection changes.

MOD4

This field specifies the type of test being performed as described in the MOD4 Field topic.

CON

The Connection field specifies the UUT connection and is always 2-wire (2 W). 2W is inserted automatically in the CON field when no CON field code is entered.

Use of Standard Memory Locations and Results Reporting

System memory locations MEM and MEM1 are used. For more information, refer to the Use of Standard Memory Registers topic.

T.U.R. Calculation

Calculation of the Test Uncertainty Ratio (T.U.R.) for a “45” statement which specifies decibels (“D”) in the NOMINAL fields requires that the impedance from the “M45” statement be known. Because of this requirement, the compile time T.U.R. calculation in this case is not done until the “last pass” of the compiler runs. In other words, if you enter, using the MET/CAL editor, a “45” statement in which NOMINAL units are decibels and press Enter (or F8), no T.U.R. calculation will be done at that time. When you press F9 (“Next Error” function) to compile the entire procedure, the T.U.R. calculation will be done and a warning message, if appropriate, will be displayed.

Examples

# ----- Reset -----
  1.001  45           *                                                 S
# ----- DC Voltage -----
  1.002  45     20    19.99mV        2% 0.04U                              2W
# ----- AC Voltage -----
  2.001  45     400   350.0mV        -2.8U +2.9U   60H                     2W
# ----- dBm -----
  3.001  M45          50Z
  3.002  45           10D                          100H                 N  2W
# ----- Audio Power -----
  3.003  M45          8Z
  3.004  45           15W                          1kH                  N  2W
# ----- DC Current -----
  3.005  45     4000  3500mA         9U                              E     2W
# ----- AC Current -----
  4.001  45           35.00mA        0.37U         60H                     2W
# ----- Frequency -----
  5.001  45     1000  800.0H         0.1% 0.1U     300mV                   2W
# ----- Resistance -----
  6.001  45           390.0Z                                            S  2W


M45

Auxiliary Instrument Setup FSC

Description

The M45 FSC allows selection of the reference impedances supported by the Fluke 45 which cannot be specified in the 45 FSC MOD3 field.

Parameters

RANGE

This field is not used.

NOMINAL

This field specifies the reference impedance entered as: numeric[prefix]Z.

Allowed values are:

  • 2 Ω
  • 4 Ω
  • 8 Ω
  • 16 Ω
  • 50 Ω
  • 93 Ω
  • 110 Ω
  • 124 Ω
  • 125 Ω
  • 135 Ω
  • 150 Ω
  • 250 Ω
  • 300 Ω
  • 500 Ω
  • 600 Ω
  • 800 Ω
  • 900 Ω
  • 1 kΩ
  • 1.2 kΩ
  • 8 kΩ

TOLERANCE

This field is not used.

MOD1

This field is not used.

MOD2

This field is not used.

MOD3

This field is not used.

MOD4

This field is not used.

CON

This field is not used.


525

Instrument FSC

Description

The 525 FSC provides the means to control the following functions of the Fluke 525A Temperature / Pressure Calibrator:

  • DC Voltage Source
  • DC Current Source
  • Resistance Source and Measurement
  • RTD Source and Measurement
  • Thermocouple Source and Measurement

The 525 FSC may also be used to control a 525B. This capability allows a 525A based procedure to be executed without modification when a 525B is used.

The 525 FSC may also be used to control the primary functions of a 7526A. This capability allows a procedure using the 525/M525 FSCs to be executed without modification when a “Fluke 7526A” is configured and connected.

For pressure measurement, use P700 FSC (Fluke 700 Series pressure modules) or P525 FSC (Fluke 525A-Pxx Series pressure modules). The M525 FSC may be used to range lock DCV Source and Resistance Measurement functions.

MET/CAL can control the 525A using any of the following modes:

  1. Serial control of the 525A via its RS-232 port.

    For this mode, do not use the PORT FSC port configuration special construction, [P9600,N,...], to set the baud rate, parity, etc. of the port used to control the 525A. MET/CAL executes a "Test" function for each System Instrument prior to executing any procedure statements, therefore the settings of the port used to controlling the 525A must be set correctly before a procedure is executed. Select the "Ports" application in the Windows control panel to choose the proper settings for port to which the 525A is connected.

  2. IEEE-488 control of the 525A via its RS-232 port and an IEEE-488 to RS-232 translator (MET/CAL 6.11A and later).

    MET/CAL 6.11A
    No modifications are necessary. 525A IEEE-488 termination defaults to carriage return (CR).
    MET/CAL 7.0 and later
    Set the 525A/B Terminator IEEE-488 to RS-232 Converter MET/CAL Configuration setting to carriage return (CR).

  3. IEEE-488 control of the 525A via its IEEE-488 interface (MET/CAL 6.11A and later).

    MET/CAL 6.11A
    Set the 525A/B Terminator IEEE-488 to RS-232 Converter MET/CAL Configuration setting to End-Or-Identify (EOI).
    MET/CAL 7.0 and later
    No modifications are necessary. 525A IEEE-488 termination defaults to End-Or-Identify (EOI).

FUNCTIONAL CAPABILITY

DC Voltage Source: 0 V to 100 V
DC Current Source: 0 mA to 100 mA
Resistance Source: 5 Ω to 4000 Ω
Resistance Measurement: 0 Ω to 4000 Ω
RTD Source and Measurement:
100 Ohm Pt 385 | -200 °C to 800 °C (-328 °F to 1472 °F)
100 Ohm Pt 3926 | -200 °C to 630 °C (-328 °F to 1166 °F)
100 Ohm Pt JIS 3916 | -200 °C to 630 °C (-328 °F to 1166 °F)
200 Ohm Pt 385 | -200 d°C to 630 °C (-328 °F to 1166 °F)
500 Ohm Pt 385 | -200 °C to 630 °C (-328 °F to 1166 °F)
1000 Ohm Pt 385 | -200 °C to 630 °C (-328 °F to 1166 °F)
120 Ohm Ni | -80 °C to 260 °C (-112 °F to 500 °F)
10 Ohm Cu | -100 °C to 230 °C (-148 °F to 500 °F)
YSI400 | 15 °C to 50 °C ( 59 °F to 122 °F)
PRT Source and Measurement: -260 °C to 961.78 °C1
SPRT Measurement: -260 °C to 961.78 °C2
Thermocouple Source and Measurement
Type B | 600 °C to 1820 °C (1112 °F to 3308.0 °F)
Type C | 0 °C to 2316 °C ( 32 °F to 4200.8 °F)
Type E | -250 °C to 1000 °C (-418 °F to 1832.0 °F)
Type J | -210 °C to 1200 °C (-346 °F to 2192.0 °F)
Type K | -200 °C to 1372 °C (-328 °F to 2501.5 °F)
Type L | -200 °C to 900 °C (-328 °F to 1652.0 °F)
Type N | -200 °C to 1300 °C (-328 °F to 2372.0 °F)
Type R | 0 °C to 1767 °C ( 32 °F to 3212.5 °F)
Type S | 0 °C to 1767 °C ( 32 °F to 3212.5 °F)
Type T | -250 °C to 400 °C (-418 °F to 752.0 °F)
Type U | -200 °C to 600 °C (-328 °F to 1112.0 °F)
mV /° C | -10 mV to 75 mV
  1. Actual range depends upon coefficients entered.
  2. Actual range depends upon temperature probe used.

Parameters

RANGE

This field specifies the UUT range as described in the RANGE Field topic.

Nominal

This field specifies the voltage, current, temperature, or reset.

  • Voltage entered as: [numeric][prefix]V
  • Current entered as: [numeric][prefix]A
  • Resistance entered as: [numeric][prefix]Z
  • Temperature entered as: [numeric][prefix]degC, degF, or K
  • Reset entered as *.

Rules:

  1. When the NOMINAL field contains only units, the value is obtained from the memory register MEM.
  2. When the NOMINAL field units are ohms, the M525 RANGE and NOMINAL fields must specify the range to be used.

TOLERANCE

This field specifies the UUT tolerance as described in the TOLERANCE Field topic.

MOD1

This field is not used.

MOD2

This field specifies the temperature measurement or source type.

blank | DC Voltage, DC Current, or Resistance
_B | Type B thermocouple
_C | Type C thermocouple
_E | Type E thermocouple
_J | Type J thermocouple
_K | Type K thermocouple
_L | Type L thermocouple
_N | Type N thermocouple
_R | Type R thermocouple
_S | Type S thermocouple
_T | Type T thermocouple
_U | Type U thermocouple
R1 | 100 Ω Pt 385 RTD
R2 | 100 Ω Pt 3926 RTD
R3 | 120 Ω Ni RTD
R4 | 200 Ω Pt 385 RTD
R5 | 500 Ω Pt 385 RTD
R6 | 1 kΩ Pt 385 RTD
R7 | 100 Ω Pt JIS 3916 RTD
R8 | 10 Ω Cu RTD
P1 | PRT, constants table 1
P2 | PRT, constants table 2
P3 | PRT, constants table 3
P4 | PRT, constants table 4
P5 | PRT, constants table 5
RR | SPRT
Y4 | YSI400 thermistor

Rules:

  1. _K is inserted automatically in the MOD2 field for TC Calibration when no MOD2 code is entered.
  2. R1 is inserted automatically in the MOD2 field for RTD Calibration when no MOD2 code is entered.
  3. The MOD2 field must be blank when the Nominal field specifies voltage, current, or resistance.
  4. The MOD2 field may not be blank when the Nominal field specifies temperature.

MOD3

This field is used to specify source vs. measure for resistance, RTD, and thermocouple modes.

TM | Thermocouple Measurement
TC | Thermocouple Source
ZM | Resistance or RTD Measurement
blank | DC Voltage, DC Current, Resistance, or Temperature source.

Rules:

  1. The MOD3 field may specify ZM only when the Nominal field specifies resistance or the MOD3 field specifies a RTD type, PRT, or SPRT.
  2. The MOD3 field may specify TM or TC only when the MOD2 field specifies a thermocouple type.
  3. The MOD3 must be blank when the Nominal field specifies current.
  4. TM is automatically inserted in the MOD3 field when the MOD2 field specifies a thermocouple type and no MOD3 code is entered.
  5. ZM is automatically inserted in the MOD3 field when the MOD2 field is RR and no MOD3 code is entered.

MOD4

This field specifies the type of test being performed as described in the MOD4 Field topic.

CON

The Connection field specifies the UUT connection.

2W | 2-wire
4W | 4-wire

Rules:

525A Mode | CON
Voltage Source | 2W
mA Source | 2W
RTD/Ohms Source | 2W
RTD/Ohms Measure | 4W
TC Source/Measure | 2W
  1. 2W is inserted automatically in the CON field when no CON field code is entered, and the MOD3 field is TM or TC, or the MOD3 field is blank and the Nominal field specifies voltage, current, resistance, or temperature.
  2. 4W is inserted automatically in the CON field when no CON field code is entered, and the MOD3 field specifies ZM.

USE OF STANDARD MEMORY LOCATIONS AND RESULTS REPORTING

System memory locations MEM and MEM1 are used. For more information, refer to the Use of Standard Memory Registers topic.

EXAMPLES

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
# Reset
  1.001  525          *                                                 S
# DC Voltage
  1.002  525    2     1.999V         2% 0.04U                              2W
# DC Voltage w/Range Lock
  2.001  M525   RNGLK 1V
  2.002  525    400   350.0mV        1.9% 0.4U                             2W
  3.001  M525         *
# DC Voltage, TC Terminals
  3.002  525          35mV                                           TC S  2W
# DC Current
  3.003  525    1     1.00mA         1%                                    2W
  4.001  525    20    19.00mA        0.07U                                 2W
# Temperature Measurement
  5.001  525          1200.0degF                                  _J TM N  2W
# Temperature Source
  5.002  525          50degC         1%                           _K TC    2W
  6.001  525          45degC                                      R1    S  2W


M525

Auxiliary Instrument Setup FSC

Description

The M525 FSC is used to specify the following:

  • External thermocouple reference
  • Range locking for Volts Source or Ohms Source or Measurement

Parameters

RANGE

This field specifies one of the following:

  • TCREF External Thermocouple Reference
  • RNGLK Range Lock
  • blankfield not applicable

Rules:

  1. The Range field may specify RNGLK only under the following conditions:
    1. Volts Source - the 525 FSC Nominal field units are volts "V" and the 525 FSC MOD2 field is blank, or
    2. Ohms Source or Measurement - the 525 FSC Nominal field units are ohms "Z".
  2. The Range field must specify RNGLK for Ohms Source and Measurement (no autorange is supported).

NOMINAL

This field specifies a range lock selection value:

  • External thermocouple reference value (0 degC / 32 degF)
  • Range lock selection value
    • Voltage entered as numeric[prefix]V or
    • Resistance entered as numeric[prefix]Z
  • "*" Reset to defaults (autorange/internal TC ref)

Rules:

  1. The NOMINAL field may voltage or resistance only when the RANGE field specifies RNGLK.
Voltage | Locked Range
0 mV to 100 mV | 100 mV DC
> 100 mV to 1 V | 1 V DC
> 1 V to 10 V | 10 V DC
> 10 V to 100 V | 100 V DC
Resistance | Locked Range
0 Ω to 400 Ω | 400 Ω
> 400 Ω to 4000 Ω | 4000 Ω

TOLERANCE

This field is not used.

MOD1

This field is not used.

MOD2

This field is not used.

MOD3

This field is not used.

MOD4

This field is not used.

CON

This field is not used.

Examples

See 525 FSC.


525B

Instrument FSC

Description

The 525B FSC provides the means to control the following functions of the Fluke 525B Temperature / Pressure Calibrator:

  • DC Voltage Source
  • DC Current Source
  • Resistance Source and Measurement
  • RTD Source and Measurement
  • Thermocouple Source and Measurement

The M525B FSC may be used to range lock DCV Source and Resistance Measurement functions.

The 525B FSC may also be used to control the primary functions of a 7526A. This capability allows a procedure using the 525B/M525B FSCs to be executed without modification when a “Fluke 7526A” is configured and connected.

For pressure measurement, use P700 FSC (Fluke 700 Series pressure modules) or P525 FSC (Fluke 525A-Pxx Series pressure modules).

If the 525B is to be controlled via its serial port, do not use the PORT FSC port configuration special construction, [P9600,N,...], to set the baud rate, parity, etc. of the port used to control the 525B. MET/CAL executes a "Test" function for each System Instrument prior to executing any procedure statements, therefore the settings of the port used to controlling the 525B must be set correctly before a procedure is executed. If the 525B is connected to a standard serial port (COM1, COM2, ..., COM16), select the "Ports" application in the Windows control panel to choose the proper settings.

Functional Capability

Mode | Range
DC Voltage Source | 0V to 100V
DC Current Source | 0mA to 100mA
Resistance Source | 5 Ohms to 4000 Ohms
Resistance Measurement | 0 Ohms to 4000 Ohms
RTD Source and Measurement | 100 Ohm Pt 385 | -200 degC to 800 degC (-328 degF to 1472 degF)
100 Ohm Pt 3926 | -200 degC to 630 degC (-328 degF to 1166 degF)
100 Ohm Pt JIS 3916 | -200 degC to 630 degC (-328 degF to 1166 degF)
200 Ohm Pt 385 | -200 degC to 630 degC (-328 degF to 1166 degF)
500 Ohm Pt 385 | -200 degC to 630 degC (-328 degF to 1166 degF)
1000 Ohm Pt 385 | -200 degC to 630 degC (-328 degF to 1166 degF)
120 Ohm Ni | -80 degC to 260 degC (-112 degF to 500 degF)
10 Ohm Cu | -100 degC to 230 degC (-148 degF to 500 degF)
YSI400 | 15 degC to 50 degC ( 59 degF to 122 degF)
RTD Source and Measurement | 100 Ohm Pt 385 | -200 degC to 800 degC (-328 degF to 1472 degF)
100 Ohm Pt 3926 | -200 degC to 630 degC (-328 degF to 1166 degF)
100 Ohm Pt JIS 3916 | -200 degC to 630 degC (-328 degF to 1166 degF)
200 Ohm Pt 385 | -200 degC to 630 degC (-328 degF to 1166 degF)
500 Ohm Pt 385 | -200 degC to 630 degC (-328 degF to 1166 degF)
1000 Ohm Pt 385 | -200 degC to 630 degC (-328 degF to 1166 degF)
120 Ohm Ni | -80 degC to 260 degC (-112 degF to 500 degF)
10 Ohm Cu | -100 degC to 230 degC (-148 degF to 500 degF)
YSI400 | 15 degC to 50 degC ( 59 degF to 122 degF)
PRT Source and Measurement | -260 degC to 961.78 degC 1
SPRT Measurement | -260 degC to 961.78 degC 2
Thermocouple Source and Measurement | Type B | 600 degC to 1820 degC (1112 degF to 3308.0 degF)
Type C | 0 degC to 2316 degC ( 32 degF to 4200.8 degF)
Type E | -270 degC to 1000 degC (-418 degF to 1832.0 degF)
Type J | -210 degC to 1200 degC (-346 degF to 2192.0 degF)
Type K | -270 degC to 1372 degC (-328 degF to 2501.5 degF)
Type L | -200 degC to 900 degC (-328 degF to 1652.0 degF)
Type N | -270 degC to 1300 degC (-328 degF to 2372.0 degF)
Type R | -50 degC to 1767 degC ( 32 degF to 3212.5 degF)
Type S | -50 degC to 1767 degC ( 32 degF to 3212.5 degF)
Type T | -270 degC to 400 degC (-418 degF to 752.0 degF)
Type U | -200 degC to 600 degC (-328 degF to 1112.0 degF)
Type XB | -200 degC to 800 degC (-328 degF to 1472.0 degF)
Type BP | 0 degC to 2500 degC ( 32 degF to 4532.0 degF)
mV/degC | -10mV to 75mV
  1. Actual range depends upon coefficients entered.
  2. Actual range depends upon temperature probe used.

Parameters

RANGE

This field specifies the UUT range as described in the RANGE Field topic.

NOMINAL

This field specifies the voltage, current, temperature, or reset.

  • Voltage entered as: [numeric][prefix]V
  • Current entered as: [numeric][prefix]A
  • Resistance entered as: [numeric][prefix]Z
  • Temperature entered as: [numeric][prefix]degC, degF, or K
  • Reset entered as *.

Rules:

  1. When the NOMINAL field contains only units, the value is obtained from the memory register MEM.
  2. When the NOMINAL field units are ohms, the M525 RANGE and NOMINAL fields must specify the range to be used.

TOLERANCE

This field specifies the UUT tolerance as described in the TOLERANCE Field topic.

MOD1

This field is not used.

MOD2

This field specifies the temperature measurement or source type.

  • blank DC Voltage, DC Current, or Resistance
  • _B Type B thermocouple
  • _C Type C thermocouple
  • _E Type E thermocouple
  • _J Type J thermocouple
  • _K Type K thermocouple
  • _L Type L thermocouple
  • _N Type N thermocouple
  • _R Type R thermocouple
  • _S Type S thermocouple
  • _T Type T thermocouple
  • _U Type U thermocouple
  • _X Type XK thermocouple
  • _P Type BP thermocouple
  • R1 100 Ohm Pt 385 RTD
  • R2 100 Ohm Pt 3926 RTD
  • R3 120 Ohm Ni RTD
  • R4 200 Ohm Pt 385 RTD
  • R5 500 Ohm Pt 385 RTD
  • R6 1 kOhm Pt 385 RTD
  • R7 100 Ohm Pt JIS 3916 RTD
  • R8 10 Ohm Cu RTD
  • P1 PRT, constants table 1
  • P2 PRT, constants table 2
  • P3 PRT, constants table 3
  • P4 PRT, constants table 4
  • P5 PRT, constants table 5
  • RR SPRT
  • Y4 YSI400 thermistor

Rules:

  1. _K is inserted automatically in the MOD2 field for TC Calibration when no MOD2 code is entered.
  2. R1 is inserted automatically in the MOD2 field for RTD Calibration when no MOD2 code is entered.
  3. The MOD2 field must be blank when the Nominal field specifies voltage, current, or resistance.
  4. The MOD2 field may not be blank when the Nominal field specifies temperature.

MOD3

This field is used to specify source vs. measure for resistance, RTD, and thermocouple modes.

  • TM Thermocouple Measurement
  • TC Thermocouple Source
  • ZM Resistance or RTD Measurement
  • blank DC Voltage, DC Current, Resistance, or Temperature source.

Rules:

  1. The MOD3 field may specify ZM only when the Nominal field specifies resistance or the MOD3 field specifies a RTD type, PRT, or SPRT.
  2. The MOD3 field may specify TM or TC only when the MOD2 field specifies a thermocouple type.
  3. The MOD3 must be blank when the Nominal field specifies current.
  4. TM is automatically inserted in the MOD3 field when the MOD2 field specifies a thermocouple type and no MOD3 code is entered.
  5. ZM is automatically inserted in the MOD3 field when the MOD2 field is RR and no MOD3 code is entered.

MOD4

This field specifies the type of test being performed as described in the MOD4 Field topic.

CON

The Connection field specifies the UUT connection.

  • 2W 2-wire
  • 4W 4-wire

Rules:

525B Mode | CON
Voltage Source | 2W
mA Source | 2W
RTD/Ohms Source | 2W
RTD/Ohms Measure | 4W
TC Source/Measure | 4W
  1. 2W is inserted automatically in the CON field when no CON field code is entered, and the MOD3 field is TM or TC, or the MOD3 field is blank and the Nominal field specifies voltage, current, resistance, or temperature.
  2. 4W is inserted automatically in the CON field when no CON field code is entered, and the MOD3 field specifies ZM.

Use of Standard Memory Locations and Results Reporting

System memory locations MEM and MEM1 are used. For more information, refer to the Use of Standard Memory Registers topic.

Examples

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
# ----- Reset -----
  1.001  525B         *                                                 S
# ----- DC Voltage -----
  1.002  525B   2     1.999V         2% 0.04U                              2W
# ----- DC Voltage w/Range Lock -----
  2.001  M525B  RNGLK 1V
  2.002  525B   400   350.0mV        1.9% 0.4U                             2W
  3.001  M525B        *
# ----- DC Voltage, TC Terminals -----
  3.002  525B         35mV                                           TC S  2W
# ----- DC Current -----
  3.003  525B   1     1.00mA         1%                                    2W
  4.001  525B   20    19.00mA        0.07U                                 2W
# ----- Temperature Measurement -----
  5.001  525B         1200.0degF                                  _J TM N  2W
# ----- Temperature Source -----
  5.002  525B         50degC         1%                           _K TC    2W
  6.001  525B         45degC                                      R1    S  2W


M525B

Instrument FSC

Description

The M525B FSC is used to specify the following:

  • External thermocouple reference
  • Range locking for Volts Source or Ohms Source or Measurement

Parameters

RANGE

This field specifies one of the following:

  • TCREF External Thermocouple Reference
  • RNGLK Range Lock
  • blank field not applicable

Rules:

  1. The Range field may specify RNGLK only under the following conditions:
    1. Volts Source - the 525B FSC Nominal field units are volts "V" and the 525B FSC MOD2 field is blank,
    2. Ohms Source or Measurement - the 525B FSC Nominal field units are ohms "Z".
  2. The Range field must specify RNGLK for Ohms Source and Measurement (no autorange is supported).

NOMINAL

This field specifies a range lock selection value:

  • External thermocouple reference value (0 degC / 32 degF)
  • Range lock selection value

Voltage entered as numeric[prefix]V or

Resistance entered as numeric[prefix]Z

  • "*" Reset to defaults (autorange/internal TC ref)

Rules:

  1. The NOMINAL field may voltage or resistance only when the RANGE field specifies RNGLK.
Voltage | Locked Range
0 mV to 100 mV | 100 mV DC
> 100 mV to 1 V | 1 V DC
> 1 V to 10 V | 10 V DC
> 10 V to 100 V | 100 V DC
Resistance | Locked Range
0 Ω to 400 Ω | 400 Ω
> 400 Ω to 4000 Ω | 4000 Ω

TOLERANCE

This field is not used.

MOD1

This field is not used.

MOD2

This field is not used.

MOD3

This field is not used.

MOD4

This field is not used.

CON

This field is not used.

Examples

See 525B FSC.


P525

Instrument FSC

Description

The P525 FSC programs the Fluke 525A Temperature/Pressure Calibrator to measure pressure using a Fluke 525A-Pxx Series Pressure Module.

  • Fluke 525A Temperature/Pressure Calibrator
  • Fluke 525B Temperature/Pressure Calibrator
  • Fluke 7526A Precision Process Calibrator 1
  1. The 7526A FSC can also be used to control a 525A-Pxx Series Pressure Module connected to a 7526A.

Functional Capability

Model | Minimum | Maximum | Temperature
525A-P01 | 0.0 psi | 0.3613 psi |
 | 0.0 mmHg | 18.680 mmHg | @ 0 °C
 | 0.0 inHg | 0.7356 inHg | @ 32 °F
 | 0.0 inH2O | 10.000 inH2O | @ 39.2 °F
 | 0.0 inH2O | 10.018 inH2O | @ 68 °F
 | 0.0 ftH2O | 0.83340 ftH2O | @ 39.2 °F
 | 0.0 ftH2O | 0.83387 ftH2O | @ 68 °F
 | 0.0 mmH2O | 254.02 mmH2O | @ 4 °C
 | 0.0 mmH2O | 254.47 mmH2O | @ 20 °C
 | 0.0 cmH2O | 25.402 cmH2O | @ 4 °C
 | 0.0 cmH2O | 25.447 cmH2O | @ 20 °C
 | 0.0 mbar | 24.910 mbar |
 | 0.0 kPa | 2.4910 kPa |
 | 0.0 g/cm2 | 25.400 g/cm2 |
525A-P02 | 0.0 psi | 1.0000 psi |
 | 0.0 mmHg | 51.715 mmHg | @ 0 °C
 | 0.0 inHg | 1.0360 inHg | @ 32 °F
 | 0.0 inH2O | 27.680 inH2O | @ 39.2 °F
 | 0.0 inH2O | 27.729 inH2O | @ 68 °F
 | 0.0 ftH2O | 2.3067 ftH2O | @ 39.2 °F
 | 0.0 ftH2O | 2.3107 ftH2O | @ 68 °F
 | 0.0 mmH2O | 703.07 mmH2O | @ 4 °C
 | 0.0 mmH2O | 704.31 mmH2O | @ 20 °C
 | 0.0 cmH2O | 70.307 cmH2O | @ 4 °C
 | 0.0 cmH2O | 70.431 cmH2O | @ 20 °C
 | 0.0 mbar | 68.948 mbar |
 | 0.0 kPa | 6.8948 kPa |
 | 0.0 g/cm2 | 70.307 g/cm2 |
 | 0.0 mmH2O | 703.07 mmH2O | @ 4 °C
525A-P03 | 0.0 psi | 5.0000 psi |
 | 0.0 mmHg | 258.58 mmHg | @ 0 °C
 | 0.0 inHg | 10.180 inHg | @ 32 °F
 | 0.0 inH2O | 138.40 inH2O | @ 39.2 °F
 | 0.0 inH2O | 138.64 inH2O | @ 68 °F
 | 0.0 ftH2O | 11.533 ftH2O | @ 39.2 °F
 | 0.0 ftH2O | 11.554 ftH2O | @ 68 °F
 | 0.0 cmH2O | 351.53 cmH2O | @ 4 °C
 | 0.0 cmH2O | 352.16 cmH2O | @ 20 °C
 | 0.0 mH2O | 3.5153 mH2O | @ 4 °C
 | 0.0 mH2O | 3.5216 mH2O | @ 20 °C
 | 0.0 mbar | 344.73 mbar |
 | 0.0 kPa | 34.474 kPa |
 | 0.0 g/cm2 | 351.53 g/cm2 |
525A-P04/ 525A-PA4 | 0.0 psi | 15.000 psi |
 | 0.0 mmHg | 775.73 mmHg | @ 0 °C
 | 0.0 inHg | 30.540 inHg | @ 32 °F
 | 0.0 inH2O | 415.20 inH2O | @ 39.2 °F
 | 0.0 inH2O | 415.93 inH2O | @ 68 °F
 | 0.0 ftH2O | 34.600 ftH2O | @ 39.2 °F
 | 0.0 ftH2O | 34.661 ftH2O | @ 68 °F
 | 0.0 cmH2O | 1054.6 cmH2O | @ 4 °C
 | 0.0 cmH2O | 1056.5 cmH2O | @ 20 °C
 | 0.0 mH2O | 10.546 mH2O | @ 4 °C
 | 0.0 mH2O | 10.565 mH2O | @ 20 °C
 | 0.0 bar | 1.0342 bar |
 | 0.0 kPa | 103.42 kPa |
 | 0.0 kg/cm2 | 1.0546 kg/cm2 |
525A-P05 525A-PA5 | 0.0 psi | 30.000 psi |
 | 0.0 mHg | 1.5515 mHg |
 | 0.0 inHg | 61.081 inHg | @ 32 °F
 | 0.0 inH2O | 830.40 inH2O | @ 39.2 °F
 | 0.0 inH2O | 831.87 inH2O | @ 68 °F
 | 0.0 ftH2O | 69.200 ftH2O | @ 39.2 °F
 | 0.0 ftH2O | 69.322 ftH2O | @ 68 °F
 | 0.0 cmH2O | 2109.2 cmH2O | @ 4 °C
 | 0.0 cmH2O | 2112.9 cmH2O | @ 20 °C
 | 0.0 mH2O | 21.092 mH2O | @ 4 °C
 | 0.0 mH2O | 21.129 mH2O | @ 20 °C
 | 0.0 bar | 2.0684 bar |
 | 0.0 kPa | 206.84 kPa |
 | 0.0 kg/cm2 | 2.1092 kg/cm2 |
525A-P06/ 525A-PA6 | 0.0 psi | 100.00 psi |
 | 0.0 mHg | 5.1715 mHg |
 | 0.0 inHg | 203.60 inHg | @ 32 °F
 | 0.0 inH2O | 2768.0 inH2O | @ 39.2 °F
 | 0.0 inH2O | 2772.9 inH2O | @ 68 °F
 | 0.0 ftH2O | 230.67 ftH2O | @ 39.2 °F
 | 0.0 ftH2O | 231.07 ftH2O | @ 68 °F
 | 0.0 cmH2O | 7030.7 cmH2O | @ 4 °C
 | 0.0 cmH2O | 7043.1 cmH2O | @ 20 °C
 | 0.0 mH2O | 70.307 mH2O | @ 4 °C
 | 0.0 mH2O | 70.431 mH2O | @ 20 °C
 | 0.0 bar | 6.8948 bar |
 | 0.0 kPa | 689.48 kPa |
 | 0.0 kg/cm2 | 7.0307 kg/cm2 |
525A-P07/ 525A-PA7 | 0.0 psi | 500.00 psi |
 | 0.0 mHg | 25.858 mHg |
 | 0.0 inHg | 1018.0 inHg | @ 32 °F
 | 0.0 inH2O | 13840 inH2O | @ 39.2 °F
 | 0.0 inH2O | 13864 inH2O | @ 68 °F
 | 0.0 ftH2O | 1153.3 ftH2O | @ 39.2 °F
 | 0.0 ftH2O | 1155.4 ftH2O | @ 68 °F
 | 0.0 cmH2O | 35153 cmH2O | @ 4 °C
 | 0.0 cmH2O | 35216 cmH2O | @ 20 °C
 | 0.0 mH2O | 351.53 mH2O | @ 4 °C
 | 0.0 mH2O | 352.16 mH2O | @ 20 °C
 | 0.0 bar | 34.474 bar |
 | 0.0 MPa | 3.4474 MPa |
 | 0.0 kg/cm2 | 35.153 kg/cm2 |
525A-P08/ 525A-PA8 | 0.0 psi | 1000.0 psi |
 | 0.0 mHg | 51.715 mHg |
 | 0.0 inHg | 2036.0 inHg | @ 32 °F
 | 0.0 inH2O | 27680 inH2O | @ 39.2 °F
 | 0.0 inH2O | 27729 inH2O | @ 68 °F
 | 0.0 ftH2O | 2306.7 ftH2O | @ 39.2 °F
 | 0.0 ftH2O | 2310.7 ftH2O | @ 68 °F
 | 0.0 cmH2O | 70307 cmH2O | @ 4 °C
 | 0.0 cmH2O | 70431 cmH2O | @ 20 °C
 | 0.0 mH2O | 703.07 mH2O | @ 4 °C
 | 0.0 mH2O | 704.31 mH2O | @ 20 °C
 | 0.0 bar | 68.948 bar |
 | 0.0 MPa | 6.8948 MPa |
 | 0.0 kg/cm2 | 70.307 kg/cm2 |
525A-P29 | 0.0 psi | 3000.0 psi |
 | 0.0 mHg | 155.15 mHg |
 | 0.0 inHg | 6108.1 inHg | @ 32 °F
 | 0.0 inH2O | 83040 inH2O | @ 39.2 °F
 | 0.0 inH2O | 83187 inH2O | @ 68 °F
 | 0.0 ftH2O | 6920.0 ftH2O | @ 39.2 °F
 | 0.0 ftH2O | 6932.2 ftH2O | @ 68 °F
 | 0.0 cmH2O | 21092 cmH2O | @ 4 °C
 | 0.0 cmH2O | 21129 cmH2O | @ 20 °C
 | 0.0 kmH2O | 2.1092 kmH2O | @ 4 °C
 | 0.0 kmH2O | 2.1129 kmH2O | @ 20 °C
 | 0.0 bar | 206.84 bar |
 | 0.0 MPa | 20.684 MPa |
 | 0.0 kg/cm2 | 210.92 kg/cm2 |
525A-PV4 | -15.000 psi | 0.0 psi |
 | -775.73 mmHg | 0.0 mmHg | @ 0 °C
 | -30.540 inHg | 0.0 inHg | @ 32 °F
 | -415.20 inH2O | 0.0 inH2O | @ 39.2 °F
 | -415.93 inH2O | 0.0 inH2O | @ 68 °F
 | -34.600 ftH2O | 0.0 ftH2O | @ 39.2 °F
 | -34.661 ftH2O | 0.0 ftH2O | @ 68 °F
 | -1054.6 cmH2O | 0.0 cmH2O | @ 4 °C
 | -1056.5 cmH22O | 0.0 cmH2O | @ 20 °C
 | -10.546 mH2O | 0.0 mH2O | @ 4 °C
 | -10.565 mH2O | 0.0 mH2O | @ 20 °C
 | -1.0342 bar | 0.0 bar |
 | -103.42 kPa | 0.0 kPa |
 | -1.0546 kg/cm2 | 0.0 kg/cm2 |

Units Symbols

Units Symbol | Name
bar | bar
cmH2O | centimeters of water
ftH2O | feet of water
g/cm2 | grams per square centimeter
inH2O | inches of water
inHg | inches of mercury
mH2O | meters of water
mHg | meters of mercury
Pa | Pascal
psi | pounds per square inch

Parameters

RANGE

This field specifies the UUT range as described in the RANGE Field topic.

NOMINAL

This field specifies the expected measured value or a reset.

  • Pressure entered as: [numeric][prefix]units symbol
  • Reset entered as *.

TOLERANCE

This field specifies the UUT tolerance as described in the TOLERANCE Field topic.

MOD1

This field specifies the temperature of the water.

  • Temperature entered as numeric[prefix]°C or °F

Rules:

  1. The MOD1 field may specify temperature only when the NOMINAL field units are "inH2O", "ftH2O", "cmH2O", or "mH2O".
  2. Allowed values are 4 °C and 20 °C.

MOD2

This field is not used.

MOD3

This field is used to zero a pressure module.

"ZR" | zero pressure module
blank | not applicable

Rules:

  1. When the MOD3 field is "ZR" the MOD4 field must specify a Nominal Setup Test ("N").
  2. When the MOD3 field is blank the outcome of executing the statement is determined by the type of test specified in the MOD4 field.

MOD4

This field specifies the type of test being performed as described in the MOD4 Field topic.

CON

This field specifies the model number of the 700 Series Pressure Module used.

CON | Model Number
P01 | 525A-P01
P02 | 525A-P02
P03 | 525A-P03
P04 | 525A-P04
P05 | 525A-P05
P06 | 525A-P06
P07 | 525A-P07
P08 | 525A-P08
P29 | 525A-P29
PA4 | 525A-PA4
PA5 | 525A-PA5
PA6 | 525A-PA6
PA7 | 525A-PA7
PA8 | 525A-PA8
PV4 | 525A-PV4

Use of Standard Memory Locations and Results Reporting

System memory locations MEM and MEM1 are used. For more information, refer to the Use of Standard Memory Registers topic.

Examples

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
# -----  Reset  -----
  1.001  P525         *                                                 S
# -----  Zero  -----
  1.002  P525         0.00inH2O                    4degC             ZR N  PA4
# -----  Evaluation (Relative to zero measurement)  -----
  1.003  P525   10    5.00inH2O      0.15U         4degC                   PA4
  2.001  P525         0.0inH2O                     60degF            ZR N  P29
  2.002  P525         35.0inH2O      1.0U          60degF                  P29
  3.001  P525         0.000psi                                       ZR N  P05
  3.002  P525         0.300psi       4%                                    P05
  4.001  MEMI         Enter zero value for 525A-PA5 absolute pressure module.
  4.002  P525         mmHg                         0degC             ZR N  PA4
  4.003  P525   1000  754mmHg        2/            0degC                   PA4
  5.001  P525         0kg/cm2                                        ZR N  PV4
# -----  Setup Test  -----
  5.002  P525         -1.0kg/cm2                                        S  PV4


P700

Instrument FSC

Description

The P700 FSC programs the following instruments to measure pressure using a Fluke 700 Series Pressure Module:

  • Fluke 525A Temperature/Pressure Calibrator
  • Fluke 525B Temperature/Pressure Calibrator
  • Fluke 5520A Multi-Product Calibrator using 700PCK adapter
  • Fluke 5522A Multi-Product Calibrator using 700PCK adapter
  • Fluke 7526A Precision Process Calibrator1
  1. The 7526A FSC can also be used to control a 700 Series Pressure Module connected to a 7526A.

Functional Capability

Model | Minimum | Maximum | Temperature | Limitations
700P00 | 0.03613 psi | 0.0 psi |  |
 | 0.0 mmHg | 1.8680 mmHg | @ 0 °C |
 | 0.0 inHg | 0.07356 inHg | @ 32 °F |
 | 0.0 inH2O | 1.0000 inH2O | @ 39.2 °F |
 | 0.0 inH2O | 1.0011 inH2O | @ 60 °F | 552xA only
 | 0.0 inH2O | 1.0018 inH2O | @ 68 °F | 525A only
 | 0.0 ftH2O | 0.083340 ftH2O | @ 39.2 °F |
 | 0.0 ftH2O | 0.083323 ftH2O | @ 60 °F | 552xA only
 | 0.0 ftH2O | 0.083387 ftH2O | @ 68 °F | 525A only
 | 0.0 mmH2O | 25.402 mmH2O | @ 4 °C |
 | 0.0 mmH2O | 25.447 mmH2O | @ 20 °C | 525A only
 | 0.0 cmH2O | 2.5402 cmH2O | @ 4 °C | 525A only
 | 0.0 cmH2O | 2.5447 cmH2O | @ 20 °C | 525A only
 | 0.0 mbar | 2.4910 mbar |  |
 | 0.0 kPa | 0.24910 kPa |  |
 | 0.0 g/cm2 | 2.5400 g/cm2 |  |
700P01 | 0.0 psi | 0.3613 psi |  |
 | 0.0 mmHg | 18.680 mmHg | @ 0 °C |
 | 0.0 inHg | 0.7356 inHg | @ 32 °F |
 | 0.0 inH2O | 10.000 inH2O | @ 39.2 °F |
 | 0.0 inH2O | 10.011 inH2O | @ 60 °F | 552xA only
 | 0.0 inH2O | 10.018 inH2O | @ 68 °F | 525A only
 | 0.0 ftH2O | 0.83340 ftH2O | @ 39.2 °F |
 | 0.0 ftH2O | 0.83323 ftH2O | @ 60 °F | 552xA only
 | 0.0 ftH2O | 0.83387 ftH2O | @ 68 °F | 525A only
 | 0.0 mmH2O | 254.02 mmH2O | @ 4 °C |
 | 0.0 mmH2O | 254.47 mmH2O | @ 20 °C | 525A only
 | 0.0 cmH2O | 25.402 cmH2O | @ 4 °C | 525A only
 | 0.0 cmH2O | 25.447 cmH2O | @ 20 °C | 525A only
 | 0.0 mbar | 24.910 mbar |  |
 | 0.0 kPa | 2.4910 kPa |  |
 | 0.0 g/cm2 | 25.400 g/cm2 |  |
700P02/ 700P22 | 0.0 psi | 1.0000 psi |  |
 | 0.0 mmHg | 51.715 mmHg | @ 0 °C |
 | 0.0 inHg | 2.0360 inHg | @ 32 °F |
 | 0.0 inH2O | 27.680 inH2O | @ 39.2 °F |
 | 0.0 inH2O | 27.707 inH2O | @ 60 °F | 552xA only
 | 0.0 inH2O | 27.729 inH2O | @ 68 °F | 525A only
 | 0.0 ftH2O | 2.3067 ftH2O | @ 39.2 °F |
 | 0.0 ftH2O | 2.3090 ftH2O | @ 60 °F | 552xA only
 | 0.0 ftH2O | 2.3107 ftH2O | @ 68 °F | 525A only
 | 0.0 mmH2O | 703.07 mmH2O | @ 4 °C |
 | 0.0 mmH2O | 704.31 mmH2O | @ 20 °C | 525A only
 | 0.0 cmH2O | 70.307 cmH2O | @ 4 °C | 525A only
 | 0.0 cmH2O | 70.431 cmH2O | @ 20 °C | 525A only
 | 0.0 mbar | 68.948 mbar |  |
 | 0.0 kPa | 6.8948 kPa |  |
 | 0.0 g/cm2 | 70.307 g/cm2 |  |
700P03/700P23/700PA3 | 0.0 psi | 5.0000 psi |  |
 | 0.0 mmHg | 258.58 mmHg | @ 0 °C |
 | 0.0 inHg | 10.180 inHg | @ 32 °F |
 | 0.0 inH2O | 138.40 inH2O | @ 39.2 °F |
 | 0.0 inH2O | 138.54 inH2O | @ 60 °F | 552xA only
 | 0.0 inH2O | 138.64 inH2O | @ 68 °F | 525A only
 | 0.0 ftH2O | 11.533 ftH2O | @ 39.2 °F |
 | 0.0 ftH2O | 11.545 ftH2O | @ 60 °F | 552xA only
 | 0.0 ftH2O | 11.554 ftH2O | @ 68 °F | 525A only
 | 0.0 cmH2O | 351.53 cmH2O | @ 4 °C | 525A only
 | 0.0 cmH2O | 352.16 cmH2O | @ 20 °C | 525A only
 | 0.0 mH2O | 3.5153 mH2O | @ 4 °C | 525A only
 | 0.0 mH2O | 3.5216 mH2O | @ 20 °C | 525A only
 | 0.0 mbar | 344.74 mbar |  |
 | 0.0 kPa | 34.474 kPa |  |
 | 0.0 g/cm2 | 351.53 g/cm2 |  |
700P04/700PA3 700PA4 700PA3 | 0.0 psi | 15.000 psi |  |
 | 0.0 mmHg | 775.73 mmHg | @ 0 °C |
 | 0.0 inHg | 30.540 inHg | @ 32 °F |
 | 0.0 inH2O | 415.20 inH2O | @ 39.2 °F |
 | 0.0 inH2O | 415.61 inH2O | @ 60 °F | 552xA only
 | 0.0 inH2O | 415.93 inH2O | @ 68 °F | 525A only
 | 0.0 ftH2O | 34.600 ftH2O | @ 39.2 °F |
 | 0.0 ftH2O | 34.634 ftH2O | @ 60 °F | 552xA only
 | 0.0 ftH2O | 34.661 ftH2O | @ 68 °F | 525A only
 | 0.0 cmH2O | 1054.6 cmH2O | @ 4 °C | 525A only
 | 0.0 cmH2O | 1056.5 cmH2O | @ 20 °C | 525A only
 | 0.0 mH2O | 10.546 mH2O | @ 4 °C | 525A only
 | 0.0 mH2O | 10.565 mH2O | @ 20 °C | 525A only
 | 0.0 bar | 1.0342 bar |  |
 | 0.0 kPa | 103.42 kPa |  |
 | 0.0 kg/cm2 | 1.0546 kg/cm2 |  |
700P05/ 700PA5 | 0.0 psi | 30.000 psi |  |
 | 0.0 mHg | 1.5515 mHg |  |
 | 0.0 inHg | 61.081 inHg | @ 32 °F |
 | 0.0 inH2O | 830.40 inH2O | @ 39.2 °F |
 | 0.0 inH2O | 831.21 inH2O | @ 60 °F | 552xA only
 | 0.0 inH2O | 831.87 inH2O | @ 68 °F | 525A only
 | 0.0 ftH2O | 69.200 ftH2O | @ 39.2 °F |
 | 0.0 ftH2O | 69.269 ftH2O | @ 60 °F | 552xA only
 | 0.0 ftH2O | 69.322 ftH2O | @ 68 °F | 525A only
 | 0.0 cmH2O | 2109.2 cmH2O | @ 4 °C | 525A only
 | 0.0 cmH2O | 2112.9 cmH2O | @ 20 °C | 525A only
 | 0.0 mH2O | 21.092 mH2O | @ 4 °C |
 | 0.0 mH2O | 21.129 mH2O | @ 20 °C | 525A only
 | 0.0 bar | 2.0684 bar |  |
 | 0.0 kPa | 206.84 kPa |  |
 | 0.0 kg/cm2 | 2.1092 kg/cm2 |  |
700P06/ 700PA6 | 0.0 psi | 100.00 psi |  |
 | 0.0 mHg | 5.1715 mHg |  |
 | 0.0 inHg | 203.60 inHg | @ 32 °F |
 | 0.0 inH2O | 2768.0 inH2O | @ 39.2 °F |
 | 0.0 inH2O | 2770.7 inH2O | @ 60 °F | 552xA only
 | 0.0 inH2O | 2772.9 inH2O | @ 68 °F | 525A only
 | 0.0 ftH2O | 230.67 ftH2O | @ 39.2 °F |
 | 0.0 ftH2O | 230.90 ftH2O | @ 60 °F | 552xA only
 | 0.0 ftH2O | 231.07 ftH2O | @ 68 °F | 525A only
 | 0.0 cmH2O | 7030.7 cmH2O | @ 4 °C | 525A only
 | 0.0 cmH2O | 7043.1 cmH2O | @ 20 °C | 525A only
 | 0.0 mH2O | 70.307 mH2O | @ 4 °C |
 | 0.0 mH2O | 70.431 mH2O | @ 20 °C | 525A only
 | 0.0 bar | 6.8948 bar |  |
 | 0.0 kPa | 689.48 kPa |  |
 | 0.0 kg/cm2 | 7.0307 kg/cm2 |  |
700P27/ | 0.0 psi | 300.00 psi |  |
 | 0.0 mHg | 15.515 mHg |  |
 | 0.0 inHg | 610.81 inHg | @ 32 °F |
 | 0.0 inH2O | 8304.0 inH2O | @ 39.2 °F |
 | 0.0 inH2O | 8312.1 inH2O | @ 60 °F | 552xA only
 | 0.0 inH2O | 8318.7 inH2O | @ 68 °F | 525A only
 | 0.0 ftH2O | 692.00 ftH2O | @ 39.2 °F |
 | 0.0 ftH2O | 692.69 ftH2O | @ 60 °F | 552xA only
 | 0.0 ftH2O | 693.22 ftH2O | @ 68 °F | 525A only
 | 0.0 cmH2O | 21092 cmH2O | @ 4 °C | 525A only
 | 0.0 cmH2O | 21129 cmH2O | @ 20 °C | 525A only
 | 0.0 mH2O | 210.92 mH2O | @ 4 °C |
 | 0.0 mH2O | 211.29 mH2O | @ 20 °C | 525A only
 | 0.0 bar | 20.684 bar |  |
 | 0.0 kPa | 2068.4 kPa |  |
 | 0.0 kg/cm2 | 21.092 kg/cm2 |  |
700P07 | 0.0 psi | 500.00 psi |  |
 | 0.0 mHg | 25.858 mHg |  |
 | 0.0 inHg | 1018.0 inHg | @ 32 °F |
 | 0.0 inH2O | 13840 inH2O | @ 39.2 °F |
 | 0.0 inH2O | 13854 inH2O | @ 60 °F | 552xA only
 | 0.0 inH2O | 13864 inH2O | @ 68 °F | 525A only
 | 0.0 ftH2O | 1153.3 ftH2O | @ 39.2 °F |
 | 0.0 ftH2O | 1154.5 ftH2O | @ 60 °F | 552xA only
 | 0.0 ftH2O | 1155.4 ftH2O | @ 68 °F | 525A only
 | 0.0 cmH2O | 35153 cmH2O | @ 4 °C | 525A only
 | 0.0 cmH2O | 35216 cmH2O | @ 20 °C | 525A only
 | 0.0 mH2O | 351.53 mH2O | @ 4 °C |
 | 0.0 mH2O | 352.16 mH2O | @ 20 °C | 525A only
 | 0.0 bar | 34.474 bar |  |
 | 0.0 MPa | 3.4474 MPa |  |
 | 0.0 kg/cm2 | 35.153 kg/cm2 |  |
 | 700P08 | 0.0 psi 1000.0 psi |  |
 | 0.0 mHg | 51.715 mHg |  |
 | 0.0 inHg | 2036.0 inHg | @ 32 °F |
 | 0.0 inH2O | 27680 inH2O | @ 39.2 °F |
 | 0.0 inH2O | 27707 inH2O | @ 60 °F | 552xA only
 | 0.0 inH2O | 27729 inH2O | @ 68 °F | 525A only
 | 0.0 ftH2O | 2306.7 ftH2O | @ 39.2 °F |
 | 0.0 ftH2O | 2309.0 ftH2O | @ 60 °F | 552xA only
 | 0.0 ftH2O | 2310.7 ftH2O | @ 68 °F | 525A only
 | 0.0 cmH2O | 70307 cmH2O | @ 4 °C |
 | 0.0 cmH2O | 70431 cmH2O | @ 20 °C | 525A only
 | 0.0 mH2O | 703.07 mH2O | @ 4 °C |
 | 0.0 mH2O | 704.31 mH2O | @ 20 °C | 525A only
 | 0.0 bar | 68.948 bar |  |
 | 0.0 MPa | 6.8948 MPa |  |
 | 0.0 kg/cm2 | 70.307 kg/cm2 |  |
700P09 | 0.0 psi | 1500.0 psi |  |
 | 0.0 mHg | 77.573 mHg |  |
 | 0.0 inHg | 3054.0 inHg | @ 32 °F |
 | 0.0 inH2O | 41520 inH2O | @ 39.2 °F |
 | 0.0 inH2O | 41561 inH2O | @ 60 °F | 552xA only
 | 0.0 inH2O | 41593 inH2O | @ 68 °F | 525A only
 | 0.0 ftH2O | 3460.0 ftH2O | @ 39.2 °F |
 | 0.0 ftH2O | 3463.4 ftH2O | @ 60 °F | 552xA only
 | 0.0 ftH2O | 3466.1 ftH2O | @ 68 °F | 525A only
 | 0.0 kmH2O | 1.0546 kmH2O | @ 4 °C | 552xA only
 | 0.0 bar | 103.42 bar |  |
 | 0.0 MPa | 10.342 MPa |  |
 | 0.0 kg/cm2 | 105.46 kg/cm2 |  |
700PV3 | -5.0000 psi | 0.0 psi |  |
 | -258.58 mmHg | 0.0 mmHg | @ 0 °C |
 | -10.180 inHg | 0.0 inHg | @ 32 °F |
 | -138.40 inH2O | 0.0 inH2O | @ 39.2 °F |
 | -138.54 inH2O | 0.0 inH2O | @ 60 °F | 552xA only
 | -138.64 inH2O | 0.0 inH2O | @ 68 °F | 525A only
 | -11.533 ftH2O | 0.0 ftH2O | @ 39.2 °F |
 | -11.545 ftH2O | 0.0 ftH2O | @ 60 °F | 552xA only
 | -11.554 ftH2O | 0.0 ftH2O | @ 68 °F | 525A only
 | -351.53 cmH2O | 0.0 cmH2O | @ 4 °C | 525A only
 | -352.16 cmH2O | 0.0 cmH2O | @ 20 °C | 525A only
 | -3.5153 mH2O | 0.0 mH2O | @ 4 °C |
 | -3.5216 mH2O | 0.0 mH2O | @ 20 °C | 525A only
 | -344.74 mbar | 0.0 mbar |  |
 | -34.474 kPa | 0.0 kPa |  |
 | -351.53 g/cm2 | 0.0 g/cm2 |  |
700PV4 | -15.000 psi | 0.0 psi |  |
 | -775.73 mmHg | 0.0 mmHg | @ 0 °C |
 | -30.540 inHg | 0.0 inHg | @ 32 °F |
 | -415.20 inH2O | 0.0 inH2O | @ 39.2 °F |
 | -415.61 inH2O | 0.0 inH2O | @ 60 °F | 552xA only
 | -415.93 inH2O | 0.0 inH2O | @ 68 °F | 525A only
 | -34.600 ftH2O | 0.0 ftH2O | @ 39.2 °F |
 | -34.634 ftH2O | 0.0 ftH2O | @ 60 °F | 552xA only
 | -34.661 ftH2O | 0.0 ftH2O | @ 68 °F | 525A only
 | -1054.6 cmH2O | 0.0 cmH2O | @ 4 °C | 525A only
 | -1056.5 cmH2O | 0.0 cmH2O | @ 20 °C | 525A only
 | -10.546 mH2O | 0.0 mH2O | @ 4 °C |
 | -10.565 mH2O | 0.0 mH2O | @ 20 °C | 525A only
 | -1.0342 bar | 0.0 bar |  |
 | -103.42 kPa | 0.0 kPa |  |
 | -1.0546 kg/cm2 | 0.0 kg/cm2 |  |
700PD2 | -1.0000 psi | 1.0000 psi |  |
 | -51.715 mmHg | 51.715 mmHg | @ 0 °C |
 | -1.0360 inHg | 1.0360 inHg | @ 32 °F |
 | -27.680 inH2O | 27.680 inH2O | @ 39.2 °F |
 | -27.707 inH2O | 27.707 inH2O | @ 60 °F | 552xA only
 | -27.729 inH2O | 27.729 inH2O | @ 68 °F | 525A only
 | -2.3067 ftH2O | 2.3067 ftH2O | @ 39.2 °F |
 | -2.3090 ftH2O | 2.3090 ftH2O | @ 60 °F | 552xA only
 | -2.3107 ftH2O | 2.3107 ftH2O | @ 68 °F | 525A only
 | -703.07 mmH2O | 703.07 mmH2O | @ 4 °C |
 | -704.31 mmH2O | 704.31 mmH2O | @ 20 °C | 525A only
 | -70.307 cmH2O | 70.307 cmH2O | @ 4 °C | 525A only
 | -70.431 cmH2O | 70.431 cmH2O | @ 20 °C | 525A only
 | -68.948 mbar | 68.948 mbar |  |
 | -6.8948 kPa | 6.8948 kPa |  |
 | -70.307 g/cm2 | 70.307 g/cm2 |  |
700PD3 | -5.0000 psi | 5.0000 psi |  |
 | -258.58 mmHg | 258.58 mmHg | @ 0 °C |
 | -10.180 inHg | 10.180 inHg | @ 32 °F |
 | -138.40 inH2O | 138.40 inH2O | @ 39.2 °F |
 | -138.54 inH2O | 138.54 inH2O | @ 60 °F | 552xA only
 | -138.64 inH2O | 138.64 inH2O | @ 68 °F | 525A only
 | -11.533 ftH2O | 11.533 ftH2O | @ 39.2 °F |
 | -11.545 ftH2O | 11.545 ftH2O | @ 60 °F | 552xA only
 | -11.554 ftH2O | 11.554 ftH2O | @ 68 °F | 525A only
 | -351.53 cmH2O | 351.53 cmH2O | @ 4 °C | 525A only
 | -352.16 cmH2O | 3.5153 mH2O | @ 20 °C | 525A only
 | -3.5153 mH2O | 3.5153 mH2O | @ 4 °C |
 | -3.5153 mH2O | 3.5153 mH2O | @ 20 °C | 525A only
 | -344.74 mbar | 344.74 mbar |  |
 | -34.474 kPa | 34.474 kPa |  |
 | -351.53 g/cm2 | 351.53 g/cm2 |  |
700PD4 | -15.000 psi | 15.000 psi |  |
 | -775.73 mmHg | 775.73 mmHg | @ 0 °C |
 | -30.540 inHg | 30.540 inHg | @ 32 °F |
 | -415.20 inH2O | 415.20 inH2O | @ 39.2 °F |
 | -415.61 inH2O | 415.61 inH2O | @ 60 °F | 552xA only
 | -415.93 inH2O | 415.93 inH2O | @ 68 °F | 525A only
 | -34.600 ftH2O | 34.600 ftH2O | @ 39.2 °F |
 | -34.634 ftH2O | 34.634 ftH2O | @ 60 °F | 552xA only
 | -34.661 ftH2O | 34.661 ftH2O | @ 68 °F | 525A only
 | -1054.6 cmH2O | 1054.6 cmH2O | @ 4 °C | 525A only
 | -1056.5 cmH2O | 1056.5 cmH2O | @ 20 °C | 525A only
 | -10.546 mH2O | 10.546 mH2O | @ 4 °C |
 | -10.565 mH2O | 10.565 mH2O | @ 20 °C | 525A only
 | -1.0342 bar | 1.0342 bar |  |
 | -103.42 kPa | 103.42 kPa |  |
 | -1.0546 kg/cm2 | 1.0546 kg/cm2 |  |
700PD5 | -15.000 psi | 30.000 psi |  |
 | -775.73 mmHg | 1.5515 mHg |  |
 | -30.540 inHg | 61.081 inHg | @ 32 °F |
 | -415.20 inH2O | 830.40 inH2O | @ 39.2 °F |
 | -415.61 inH2O | 831.21 inH2O | @ 60 °F | 552xA only
 | -415.93 inH2O | 831.87 inH2O | @ 68 °F | 525A only
 | -34.600 ftH2O | 69.200 ftH2O | @ 39.2 °F |
 | -34.634 ftH2O | 69.269 ftH2O | @ 60 °F | 552xA only
 | -34.661 ftH2O | 69.322 ftH2O | @ 68 °F | 525A only
 | -1054.6 cmH2O | 2109.2 cmH2O | @ 4 °C | 525A only
 | -1056.5 cmH2O | 2112.9 cmH2O | @ 20 °C | 525A only
 | -10.546 mH2O | 21.092 mH2O | @ 4 °C |
 | -10.565 mH2O | 21.129 mH2O | @ 20 °C | 525A only
 | -1.0342 bar | 2.0684 bar |  |
 | -103.42 kPa | 206.84 kPa |  |
 | -1.0546 kg/cm2 | 2.1092 kg/cm2 |  |
700PD6 | -15.000 psi | 100.00 psi |  |
 | -775.73 mmHg | 5.1715 mHg |  |
 | -30.540 inHg | 203.60 inHg | @ 32 °F |
 | -415.20 inH2O | 2768.0 inH2O | @ 39.2 °F |
 | -415.61 inH2O | 2770.7 inH2O | @ 60 °F | 552xA only
 | -415.93 inH2O | 2772.9 inH2O | @ 68 °F | 525A only
 | -34.600 ftH2O | 230.67 ftH2O | @ 39.2 °F |
 | -34.634 ftH2O | 230.90 ftH2O | @ 60 °F | 552xA only
 | -34.661 ftH2O | 231.07 ftH2O | @ 68 °F | 525A only
 | -1054.6 cmH2O | 7030.7 cmH2O | @ 4 °C | 525A only
 | -1056.5 cmH2O | 7043.1 cmH2O | @ 20 °C | 525A only
 | -10.546 mH2O | 70.307 mH2O | @ 4 °C |
 | -10.565 mH2O | 70.431 mH2O | @ 20 °C | 525A only
 | -1.0342 bar | 6.8948 bar |  |
 | -103.42 kPa | 689.48 kPa |  |
 | -1.0546 kg/cm2 | 7.0307 kg/cm2 |  |
700PD7 | -15.000 psi | 200.00 psi |  |
 | -775.73 mmHg | 10.343 mHg |  |
 | -30.540 inHg | 407.20 inHg | @ 32 °F |
 | -415.20 inH2O | 5536.0 inH2O | @ 39.2 °F |
 | -415.61 inH2O | 5541.4 inH2O | @ 60 °F | 552xA only
 | -415.93 inH2O | 5545.8 inH2O | @ 68 °F | 525A only
 | -34.600 ftH2O | 461.33 ftH2O | @ 39.2 °F |
 | -34.634 ftH2O | 461.79 ftH2O | @ 60 °F | 552xA only
 | -34.661 ftH2O | 462.15 ftH2O | @ 68 °F | 525A only
 | -1054.6 cmH2O | 14061 cmH2O | @ 4 °C | 525A only
 | -1056.5 cmH2O | 14086 cmH2O | @ 20 °C | 525A only
 | -10.546 mH2O | 140.61 mH2O | @ 4 °C |
 | -10.565 mH2O | 140.86 mH2O | @ 20 °C | 525A only
 | -1.0342 bar | 13.790 bar |  |
 | -103.42 kPa | 1.3790 MPa |  |
 | -1.0546 kg/cm2 | 14.061 kg/cm2 |  |
700P29 | 0.0 psi | 3000.0 psi |  |
 | 0.0 mHg | 155.15 mHg |  | 552xA only
 | 0.0 inHg | 6108.1 inHg | @ 32 °F |
 | 0.0 inH2O | 83040 inH2O | @ 39.2 °F |
 | 0.0 inH2O | 83121 inH2O | @ 60 °F | 552xA only
 | 0.0 inH2O | 83187 inH2O | @ 68 °F | 525A only
 | 0.0 ftH2O | 6920.0 ftH2O | @ 39.2 °F | 552xA only
 | 0.0 ftH2O | 6926.9 ftH2O | @ 60 °F | 552xA only
 | 0.0 ftH2O | 6932.2 ftH2O | @ 68 °F | 525A only
 | 0.0 kmH2O | 2.1092 kmH2O | @ 4 °C | 552xA only
 | 0.0 bar | 206.84 bar |  |
 | 0.0 MPa | 20.684 MPa |  |
 | 0.0 kg/cm2 | 210.92 kg/cm2 |  |
700P30 | 0.0 psi | 5000.0 psi |  |
 | 0.0 mHg | 258.58 mHg |  | 552xA only
 | 0.0 inHg | 10180 inHg | @ 32 °F |
 | 0.0 kinH2O | 138400 inH2O | @ 39.2 °F | 552xA only
 | 0.0 kinH2O | 138540 inH2O | @ 60 °F | 552xA only
 | 0.0 ftH2O | 11533 ftH2O | @ 39.2 °F | 552xA only
 | 0.0 ftH2O | 11545 ftH2O | @ 60 °F | 552xA only
 | 0.0 kmH2O | 3.5153 kmH2O | @ 4 °C | 552xA only
 | 0.0 bar | 344.74 bar |  |
 | 0.0 MPa | 34.474 MPa |  |
 | 0.0 kg/cm2 | 351.53 kg/cm2 |  |
700P31 | 0.0 psi | 10000 psi |  |
 | 0.0 mHg | 517.15 mHg |  | 552xA only
 | 0.0 inHg | 20360 inHg | @ 32 °F |
 | 0.0 kinH2O | 276800 inH2O | @ 39.2 °F | 552xA only
 | 0.0 kinH2O | 277070 inH2O | @ 60 °F | 552xA only
 | 0.0 ftH2O | 23067 ftH2O | @ 39.2 °F | 552xA only
 | 0.0 ftH2O | 23090 ftH2O | @ 60 °F | 552xA only
 | 0.0 kmH2O | 7.0307 kmH2O | @ 4 °C | 552xA only
 | 0.0 bar | 689.48 bar |  |
 | 0.0 MPa | 68.948 MPa |  |
 | 0.0 kg/cm2 | 703.07 kg/cm2 |  |
Units Symbols
Units | Symbol Name
bar | bar
cmH2O | centimeters of water
ftH2O | feet of water
g/cm2 | grams per square centimeter
inH2O | inches of water
inHg | inches of mercury
mH2O | meters of water
mHg | meters of mercury
Pa | Pascal
psi | pounds per square inch

Parameters

RANGE

This field specifies the UUT range as described in the RANGE Field topic.

NOMINAL

This field specifies the expected measured value or zero value, or a reset.

  • Pressure entered as: [numeric][prefix]units symbol
  • Reset entered as *.

TOLERANCE

This field specifies the UUT tolerance as described in the TOLERANCE Field topic.

MOD1

This field specifies the temperature of the water.

  • Temperature entered as numeric[prefix]degC or degF

Rules:

  1. The MOD1 field may specify temperature only when the NOMINAL field units are "mHg", "inHg", "inH2O", "ftH2O", "cmH2O", or "mH2O".

  2. Allowed values are as follows:

525A Temperature Calibrator
Nominal Units | MOD1
mHg | 0 °C
inHg | 32 °F
inH2O | 39.2 °F or 68 °F
ftH2O | 39.2 °F or 68 °F
cmH2O | 4 °C or 20 °C
mH2O | 4 °C or 20 °C
552xA Multi-Product Calibrator
Nominal Units | MOD1
mHg | 0 °C
inHg | 32 °F
inH2O | 39.2 °F or 60 °F
ftH2O | 39.2 °F or 60 °F
mH2O | 4 °C

MOD2

This field is enables and disables the filter.

"FL" | enable filter 552xA only
blank | disable filter

MOD3

This field is used to zero a pressure module.

"ZR" | zero pressure module
"RL" | relative measurement to one taken with "ZR"
blank | 525A: same as "RL", 552 xA: no zero in effect

Rules:

  1. When the MOD3 field is "ZR" the MOD4 field must specify a Nominal Setup Test ("N").
  2. When the MOD3 field is blank the outcome of executing the statement is determined by the type of test specified in the MOD4 field.

MOD4

This field specifies the type of test being performed as described in the MOD4 Field topic.

CON

This field specifies the model number of the 700 Series Pressure Module used.

CON | Model Number
P00 | FLUKE-700P00
P01 | FLUKE-700P01
P02 | FLUKE-700P02
P03 | FLUKE-700P03
P04 | FLUKE-700P04
P05 | FLUKE-700P05
P06 | FLUKE-700P06
P07 | FLUKE-700P07
P08 | FLUKE-700P08
P09 | FLUKE-700P09
P22 | FLUKE-700P22
P23 | FLUKE-700P23
P24 | FLUKE-700P24
P27 | FLUKE-700P27
P29 | FLUKE-700P29
P30 | FLUKE-700P30
P31 | FLUKE-700P31
PA3 | FLUKE-700PA3
PA4 | FLUKE-700PA4
PA5 | FLUKE-700PA5
PA6 | FLUKE-700PA6
PD2 | FLUKE-700PD2
PD3 | FLUKE-700PD3
PD4 | FLUKE-700PD4
PD5 | FLUKE-700PD5
PD6 | FLUKE-700PD6
PD7 | FLUKE-700PD7
PV3 | FLUKE-700PV3
PV4 | FLUKE-700PV4

Use of Standard Memory Locations and Results Reporting

System memory locations MEM and MEM1 are used. For more information, refer to the Use of Standard Memory Registers topic.

Examples

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
# -----  Reset  -----
  1.001  P700         *                                                 S
# -----  Zero  -----
  1.002  P700         0.00inH2O                    4degC             ZR N  P01
# -----  Evaluation (Relative to zero measurement)  -----
  1.003  P700   10    5.00inH2O      0.15U         4degC             RL    P01
  2.001  P700         0.0inH2O                     60degF            ZR N  P23
  2.002  P700         35.0inH2O      1.0U          60degF            RL    P23
  3.001  P700         0.000psi                                    FL ZR N  P02
  3.002  P700         0.300psi       4%                           FL RL    P02
  4.001  MEMI         Enter zero value for 700PA5 absolute pressure module.
  4.002  P700         mmHg                         0degC          FL ZR N  PA5
  4.003  P700   1000  754mmHg        2/            0degC          FL RL    PA5
  5.001  P700         0kg/cm2                                        ZR N  PV4
# -----  Setup Test  -----
  5.002  P700         -1.0kg/cm2                                     RL S  PV4


2620T

Instrument FSC

Description

The 2620T FSC programs the Fluke 2620T Recording Thermometer.

Functional Capability

-196degC to 400degC (-320.8degF to 752degF)

Parameters

RANGE

This field specifies the UUT range as described in the RANGE Field topic.

NOMINAL

This field specifies the expected measured value or a reset.

  • Temperature entered as: [numeric][prefix]degC or degF
  • Reset entered as *.

TOLERANCE

This field specifies the UUT tolerance as described in the TOLERANCE Field topic.

MOD1

This is not used and must be blank.

MOD2

This is not used and must be blank.

MOD3

This is not used and must be blank.

MOD4

This field specifies the type of test being performed as described in the MOD4 Field topic.

CON

This is not used and must be blank.

Use of Standard Memory Locations and Results Reporting

System memory locations MEM and MEM1 are used. For more information, refer to the Use of Standard Memory Registers topic.

Examples

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
# ----- Reset -----
  1.001  2620T        *                                                 S
# ----- Evaluation Test -----
  1.002  2620T        23.0degC       0.1U
# ----- Setup Test -----
  2.001  2620T        100.0degC                                         S
# ----- Nominal Setup Test -----
  2.002  2620T  1     212.0degF                                         N
# ----- Comparison Test -----
  2.003  2620T  1     212.0degF      1% 0.1U                            C


2635T

Instrument FSC

Description

The 2635T FSC programs the Fluke 2635T Recording Thermometer.

Functional Capability

-196 °C to 400 °C (-320.8 °F to 752 °F)

Parameters

RANGE

This field specifies the UUT range as described in the RANGE Field topic.

NOMINAL

This field specifies the expected measured value or a reset.

  • Temperature entered as: [numeric][prefix]degC or degF
  • Reset entered as *.

TOLERANCE

This field specifies the UUT tolerance as described in the TOLERANCE Field topic.

MOD1

This is not used and must be blank.

MOD2

This is not used and must be blank.

MOD3

This is not used and must be blank.

MOD4

This field specifies the type of test being performed as described in the MOD4 Field topic.

CON

This is not used and must be blank.

Use of Standard Memory Locations and Results Reporting

System memory locations MEM and MEM1 are used. For more information, refer to the Use of Standard Memory Registers topic.

Examples

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
# ----- Reset -----
  1.001  2635T        *                                                 S
# ----- Evaluation Test -----
  1.002  2635T        23.0degC       0.1U
# ----- Setup Test -----
  2.001  2635T        100.0degC                                         S
# ----- Nominal Setup Test -----
  2.002  2635T  1     212.0degF                                         N
# ----- Comparison Test -----
  2.003  2635T  1     212.0degF      1% 0.1U                            C


5080A

Instrument FSC

Description

The 5080A FSC controls the Fluke 5080A Calibrator and the 5080A/MEG Option.

Use the O_CAL FSC to control the 5080A/SC Oscilloscope Calibration Option. Do not use the PORT FSC port configuration special construction, [P9600,N,...], to set the baud rate, parity, etc. of the port used to control the 5080A. MET/CAL executes a "Test" function for each System Instrument prior to executing any procedure statements, therefore the settings of the port used to controlling the 5080A must be set correctly before a procedure is executed. select the "Ports" application in the Windows control panel to choose the proper settings.

Parameters

A 5080A statement consists of one or more parameters. A parameter consists of a name and a value. Each parameter must be separated by a semicolon and/or one or more spaces. A single 5080A statement can encompass more than one physical line as long as the line numbers are the same. However each parameter name and its value must occur on one line. A single line can accommodate 256 characters including the statement number and FSC. Note that characters above ASCII 128 will count as 2 characters.

Syntax:

parameter[separatorparameter]

parameter ::= [prefix]parameter name[sp]=[sp]parameter value

separator ::= ;[sp] | sp

prefix ::= + | @

sp ::= one or more spaces

parameter name ::= see PARAMETERS NAMES section below

parameter value ::= see PARAMETERS NAMES section below

|
Denotes "or" (i.e. A | B is A or B)
[ ]
Denotes an optional syntax element, except in examples.
In examples [ ] enclose a special construction.
+
Designates the parameter as the Evaluation Quantity
@
Designates the parameter as the Modifier Quantity

Examples:

The following three 5080A statements are identical with respect to the 5080A:

Statement #1

1.001 5080A +Voltage = 240V; @Frequency = 50Hz

Statement #2

1.001 5080A Mode = AC_Voltage +Volt = 240.0 V @Freq = 50 Hz

Statement #3

  1.003  5080A        Apply
  1.003  5080A        Mode = AC_Voltage
  1.003  5080A        +Voltage = 240 V
  1.003  5080A        @Freq = 50 Hz

Rules:

  1. One and only one parameter must be designated as the Evaluation Quantity in a 5080A Apply, Setup, or Slew statement.
  2. At most one parameter may be designated as the Modifier Quantity in a 5080A Apply, Setup, or Slew statement.
  3. Parameter values may be taken from a MET/CAL memory register using a special construction.
  4. When a 5080A Apply statement is executed, the value of the Evaluation Quantity is copied to memory register MEM1 in specified units.

    Example:

    1.001 5080A Mode = AC_Voltage; +Volt = 240 V; @Freq = 50Hz; Apply

    after the 5080A statement is executed the value of MEM1 is 240.

  5. When a 5080A Operate statement is executed, the value of the Evaluation Quantity designated in the previous Setup or Apply statement is copied to memory register MEM1 in specified units.

    Example:

      1.005  5080A        Mode = AC_Volt; +Volt = 240V; @Freq = 50Hz; Setup
  1.006  5080A        Mode = AC_Volt; +Volt = 240V; @Freq = 50Hz; Operate

    After the 5080A Operate statement is executed the value of MEM1 is 240.

  6. When a 5080A Slew statement is executed, the Evaluation Quantity designates the slew quantity.
  7. When a 5080A Slew statement is executed, the final slew value is copied to memory register MEM1 in units of the Evaluation Quantity.

    Example:

    1.001 5080A +Volt = 240V; @Freq = 50Hz; Slew

    Operator slews the 5080A output to 241.5 V.

    After the 5080A Slew statement is executed the value of MEM is 241.5.

  8. When a 5080A Slew statement is executed, the Modifier Quantity is concatenated to the Evaluation Quantity in the automatic slew message. Note, the automatic slew message is not displayed when ASK- N is in effect.

    • Examples:

        1.008  ASK+         N
  1.009  5080A        +Volt = 120V; @Freq = 60Hz; Slew

      "Adjust stimulus for a UUT reading of 120 V at 60 Hz."

    • No Modifier Quantity designated.

      1.001 5080A Mode = AC_Volt; +Volt = 120V; Freq = 60Hz; Slew

      "Adjust stimulus for a UUT reading of 120 V."

    • Automatic slew message inhibited.

        1.011  ASK-         N
  1.012  5080A        +Volt = 120V; Freq = 60Hz; Slew

      No automatic slew message generated, use MESS FSC.

Parameter Names

Parameter names consist of single words or compound words. Each word in a parameter name can be entered in long form (as shown below), or in short form. The short form is the first 4 characters of the long form, with the following exceptions:

  1. If the long form is greater than four characters, and the last character or the short form is a vowel, the short form is three characters.
  2. If the long form is four characters or less, the short form is the long form even if it ends in a vowel. Compound parameter names can be entered in any combination of long and short forms. Example, ExternalReference can be entered using any of the following forms:
    • InductanceCompensation
    • InductanceComp
    • IndCompensation
    • IndComp

Action Parameters

  • Apply
  • Local
  • Operate
  • Read
  • Reset
  • Setup
  • Standby

General Parameters

  • AuxiliaryVoltage
  • Coil
  • Current
  • Earth
  • Frequency
  • InductanceCompensation
  • Lag
  • Lead
  • LeadCompensation
  • Lows
  • Mode
  • NonToroidalUUT
  • NormalVoltage
  • Period
  • Phase
  • Power
  • PF
  • Range
  • Resistance
  • ResistanceMultiplierOn
  • Short
  • TestCurrent
  • TestVoltage
  • ToroidalUUT
  • Turns
  • Voltage

INSTRUMENT MODE

If the 5080A operating mode is not specified, MET/CAL determines the mode based on occurance of the following parameters in the 5080A statement:

  • Current
  • Frequency
  • NormalVoltage
  • Period
  • Resistance
  • Voltage

Rules:

  • If Resistance is specified, the mode is Resistance.
  • If NormalVoltage and Frequency or Period are specified, the mode is Dual AC Voltage.
  • If NormalVoltage is specified without Frequency or Period, the mode is Dual DC Voltage.
  • If Voltage, Current, and Frequency or Period are specified, the mode is AC Power.
  • If Voltage are Current are specified without Frequency or Period, the mode is DC Power.
  • If Current and Frequency or Period are specified, but not Voltage, the mode is AC Current.
  • If Current is specified, but not Voltage, Frequency, and Period, the mode is DC Current.
  • If Current and Frequency or Period are specified, but not Voltage, the mode is AC Current.
  • If Current is specified, but not Voltage, Frequency, and Period, the mode is DC Current.
  • If Voltage and Frequency or Period are specified, but not Current, the mode is AC Voltage.
  • If Voltage is specified, but not Current, Frequency, and Period, the mode is DC Voltage.

MODE/PARAMETER RULES

DC VOLTAGE

Mode = DC_Voltage | DC_Volt | DCV

Parameter Name | Parameter Type | Default Value
Mode | Optional | DC_Voltage
Voltage | Required | N/A
Range | Optional | Autorange
Earth | Optional | Open
Apply | Setup | Operate | Slew | Optional | Apply

DC CURRENT

Mode = DC_Current | DC_Curr | DCA

Parameter Name | Parameter Type | Default Value
Voltage | Required | N/A
Mode | Optional | DC_Current
Range | Required | Autorange
Coil | Optional | NA
Turns | Optional | NA 1
ToroidalUUT | NonToroidalUUT | Optional | NA
Earth | Optional | Open
Apply | Setup | Operate | Slew | Optional | Apply
  1. Only allowed when Coil is specified.

RESISTANCE

Mode = Resistance | Res

Parameter Name | Parameter Type | Default Value
Mode | Optional | Resistance
Resistance | Required | N/A
LeadCompenstion | Optional | Off
Apply | Setup | Operate | Optional | Apply

AC VOLTAGE

Mode = AC_Voltage | AC_Volt | ACV

Parameter Name | Parameter Type | Default Value
Mode | Optional | AC_Voltage
Voltage | Required | N/A
Frequency | Period | Required | N/A
Range | Optional | autorange
Earth | Optional | Open
Apply | Setup | Operate | Slew | Optional | Apply

AC CURRENT

Mode = AC_Current | AC_Curr | ACA

Parameter Name | Parameter Type | Default Value
Mode | Optional | AC_Voltage
Current | Required | NA
Frequency | Period | Required | N/A
Range | Optional | Autorange
Coil | Optional | NA
Turns | Optional | NA 1
ToroidalUUT | NonToroidalUUT | Optional | NA 1
InductanceCompenstion | Optional | Off
Earth | Optional | Open
Apply | Setup | Operate | Slew | Optional | Apply
  1. Only allowed, and required, when Coil is specified.

DUAL DC VOLTAGE

Mode = DualDC_Voltage | DualDC_Volt | DualDCV

Parameter Name | Parameter Type | Default Value
Mode | Optional | DualDC_Voltage
NormalVoltage | Required | N/A
AuxiliaryVoltage | Required | N/A
Earth | Optional | Open
Lows | Optional | Tied
Apply | Setup | Operate | Slew | Optional | Apply

DUAL AC VOLTAGE

Mode = DualAC_Voltage | DualAC_Volt | DualACV

Parameter Name | Parameter Type | Default Value
Mode | Optional | DualAC_Voltage
NormalVoltage | Required | N/A
AuxiliaryVoltage | Required | N/A
Frequency | Period | Required | N/A
Phase | Optional | 0 deg
PF | Optional | 1
Lead | Lag | Optional | Lead 1
Earth | Optional | Open
Lows | Optional | Tied
Apply | Setup | Operate | Slew | Optional | Apply
  1. Only allowed when PF is specified.

DC POWER

Mode = DC_Power | DC_Pow

Parameter Name | Parameter Type | Default Value
Mode | Optional | DC_Power
Voltage | Required | N/A
Current | Required | N/A
Power | Optional | N/A
Coil | Optional | N/A
Turns | Optional | N/A 1
ToroidalUUT | NonToroidalUUT | Optional | N/A
Earth | Optional | Open
Lows | Optional | Tied
Apply | Setup | Operate | Slew | Optional | Apply 2
  1. Only allowed when Coil is specified.
  2. Slew not allowed when the evaluation quantity is Power

AC POWER

Mode = AC_Power | AC_Pow

Parameter Name | Parameter Type | Default Value
Mode | Optional | AC_Power
Voltage | Required | N/A
Current | Required | N/A
Frequency | Period | Required | N/A
Power | Optional | N/A
Phase | Optional | 0 deg
PF | Optional | 1
Lead | Lag | Optional | Lead 1
Coil | Optional | NA
Turns | Optional | NA 2
ToroidalUUT | NonToroidalUUT | Optional | NA 2
InductanceCompensation | Optional | Off
Earth | Optional | Open
Lows | Optional | Tied
Apply | Setup | Operate | Slew | Optional | Apply 3
  1. Only allowed when PF is specified.
  2. Only allowed, and required, when Coil is specified.
  3. Slew not allowed when the evaluation quantity is Power

LOW RESISTANCE (5080A/MEG)

Mode = LR | LowResistance

Evaluation Quantity: Resistance

Parameter Name | Parameter Type | Default Value
+Resistance | Required | N/A
TestCurrent | Optional | N/A
TestVoltage | Optional | N/A
Apply | Setup | Operate | Optional | Apply

Evaluation Quantity: TestCurrent

Parameter Name | Parameter Type | Default Value
+TestCurrent | Required | N/A
Resistance | Required | N/A
Setup | Operate | Read | Required | N/A
TestVoltage | Optional | N/A

Evaluation Quantity: TestVoltage

Parameter Name | Parameter Type | Default Value
+TestVoltage | Required | N/A
Resistance | Required | N/A
Setup | Operate | Read | Required | N/A
TestCurrent | Optional | N/A

HIGH RESISTANCE (5080A/MEG)

Mode = HR | HighResistance

Evaluation Quantity: Resistance (0 Ohms)

Parameter Name | Parameter Type | Default Value
+Resistance | Required | N/A
TestVoltage | Required | N/A
ResistanceMultiplierOn | Optional | Off
TestCurrent | Optional | N/A
Apply | Setup | Operate | Slew | Optional | Apply

Evaluation Quantity: Resistance (0 Ohms)

Parameter Name | Parameter Type | Default Value
+Resistance = 0 Ohms | Required | N/A
Short | Required | N/A
TestCurrent | Optional | NA
TestVoltage | Optional | N/A
Apply | Setup | Operate | Optional | Apply

Evaluation Quantity: TestCurrent

Parameter Name | Parameter Type | Default Value
+TestCurrent | Required | N/A
Resistance | Required | N/A
Setup | Operate | Read | Required | N/A
ResistanceMultiplierOn | Optional | N/A
Short | Optional | N/A
TestVoltage | Optional | N/A

Evaluation Quantity: TestVoltage

Parameter Name | Parameter Type | Default Value
+TestVoltage | Required | N/A
Resistance | Required | N/A
Setup | Operate | Read | Required | N/A
ResistanceMultiplierOn | Optional | NA
Short | Optional | N/A
TestCurrent | Optional | N/A

HIGH RESISTANCE FIXED (5080A/MEG)

Mode = HRF | HighResistanceFixed

Evaluation Quantity: Resistance

Parameter Name | Parameter Type | Default Value
+Resistance = 18.24 GOhm | Required | N/A
TestVoltage | Required | N/A
TestCurrent | Optional | N/A
Apply | Setup | Operate | Optional | Apply

Evaluation Quantity: TestCurrent

Parameter Name | Parameter Type | Default Value
+TestCurrent | Required | N/A
Resistance = 18.24 GOhm | Required | N/A
Low | Optional | Ground
TestVoltage | Optional | N/A
Apply | Setup | Operate | Optional | Apply

Evaluation Quantity: TestVoltage

Parameter Name | Parameter Type | Default Value
+TestVoltage | Required | N/A
Resistance = 18.24 GOhm | Required | N/A
TestCurrent | Optional | NA
Apply | Setup | Operate | Optional | N/A

PARAMETER DEFINITIONS AND VALUES

Apply

This action sets up the instrument and enables the output.

Syntax:

Apply

Rules:

  1. When Apply is specified, no other action may be specified.

Examples:

Apply

AuxiliaryVoltage

This parameter specifies the AUX output voltage for the following modes:

Dual DC Voltage

Dual AC Voltage

Syntax:

[+|@]AuxiliaryVoltage[sp]=[sp]numeric value[sp][prefix]V

Examples:

+AuxVoltage = 1 V

Coil

This parameter specifies a current coil.

Syntax:

Coil[sp]=[sp]value

value = 5500A/COIL |

9100_Option200 | 9100_Opt200 |

UserDefined | UserDef

Examples:

Coil = 5500A/COIL

Current

This parameter specifies the output current.

Syntax:

[+|@]Current[sp]=[sp]numeric value[sp][prefix]units

units = A | Ap | App

Examples:

Current = 2.5 A

Earth

This parameter specifies the earth connection.

Syntax:

Earth[sp]=[sp]value

value = On | Off

Examples:

Earth = On

Frequency

This parameter specifies the output frequency.

Syntax:

[+|@]Frequency[sp]=[sp]numeric value[sp][prefix]Hz

Rules:

When Frequency is specified, Period cannot be specified.

Examples:

@Freq = 50 Hz

InductanceCompensation

This parameter specifies the inductance compensation (LCOMP).

Syntax:

InductanceCompensation[sp]=[sp]value

value = On | Off

Examples:

IndComp = On

Lead / Lag

These parameters select the relationship between the NORMAL and AUX output waveforms when power factor (PF) is specified.

Syntax:

Lead | Lag

Rules:

  1. When Lead are mutually exclusive.

Examples:

Lead

LeadCompensation

This parameter selects the lead compensation.

Syntax:

LeadCompensation[sp]=[sp]value

value = 2W | 4W | 2Wire | 4Wire | Off

Examples:

LeadCompensation = 2W

Local

This action puts the 5080A in local mode.

Syntax:

Local

Rules:

  1. When Local is specified, no other parameters may be specified.

Examples:

Local

Lows

This parameter connects or disconnects the NORMAL LO and AUX LO terminals together.

Syntax:

Low[sp]=[sp]value

value = Open | Tied

Rules:

  1. When Lows is allowed, but not specified, the default is Tied.

Examples:

Lows = Open

Mode

This parameter selects the instrument mode.

Syntax:

Mode[sp]=[sp]value

value =
DC_Voltage | DC_Volt | DCV |
DC_Current | DC_Curr | DCA |
Resistance | Res |
AC_Voltage | AC_Volt | ACV
AC_Current | AC_Curr | ACA |
DualDC_Voltage | DualDC_Volt | DualDCV |
DualAC_Voltage | DualAC_Volt | DualACV |
DC_Power | DC_Pow |
AC_Power | AC_Pow |
LowResistance | LR |
HighResistance | HR

Rules:

If mode is not specified, the mode is determined as described in the section INSTRUMENT MODE at the top of this file.

Examples:

Mode = HV_Res

NonToroidalUUT

See ToroidalUUT / NonToroidalUUT.

NormalVoltage

This parameter specifies the NORMAL output voltage for the following modes:

  • Dual DC Voltage
  • Dual AC Voltage

Syntax:

[+|@]NormalVoltage[sp]=[sp]numeric value[sp][prefix]V

Examples:

+NormalVoltage = 240 V

Operate

This parameter turns the output on.

Syntax:

Operate

Rules:

  1. When Operate is specified, no other parameters are allowed.

Examples:

Operate

PF

This parameter specifies the power factor.

Syntax:

[+|@]PF[sp]=[sp]numeric value

Rules:

  1. When PF is specified, Lead or Lag must be specified.

Examples:

PF = 0.34; Lag

Period

This parameter specifies the output period.

Syntax:

[+|@]Period[sp]=[sp]numeric value[sp][prefix]s

Rules:

When Period is specified, Frequency cannot be specified.

Examples:

@Per = 1 ms

Phase

This parameter specifies the phase between the NORMAL and AUX waveforms.

Syntax:

[+|@]Phase[sp]=[sp]numeric value[sp][prefix]deg

Examples:

Phase = 30 deg

Power

This parameter specifies the expected power.

Syntax:

+Power[sp]=[sp]numeric value[sp][prefix]units

units = W | VA | VAR

Rules:

  1. When this parameter is specified, it must be designated as the Evaluation Quantity.

Examples:

+Power = 10 kVA

RANGE

This parameter specifies the range to range lock in DC Voltage and DC Current modes.

Syntax:

Range[sp]=[sp]numeric value[sp][prefix]units

units = A | V

Examples:

Range = 3.3 V

Reset

This parameter resets the 5080A.

Syntax:

Reset

Rules:

  1. When Reset is specified, no other parameters are allowed.

Examples:

Reset

Resistance

This parameter specifies the resistance.

Syntax:

Resistance[sp]=[sp]numeric value[sp][prefix]Ohm[s]

Examples:

Resistance = 100 Ohms

ResistanceMultiplierOn

This parameter selects the 5080A/MEG Multipier mode.

Syntax:

ResistanceMultiplierOn

Rules:

  1. When ResistanceMultiplierOn is specified, resistance must be the evaluation quantity.

Examples:

ResMultOn

Setup

This action causes the instrument to be setup only. The instrument remains in standby.

Syntax:

Setup

Rules:

  1. When Setup is specified, no other action may be specified.

Examples:

Setup

Short

This action selects the 5080A/MEG Short mode.

Syntax:

Short

Examples:

Short

Slew

This action sets up the intrument and enables the output. Slewing is then enabled for the parameter designated as the Evaluation Quantity (i.e. + prefix).

Syntax:

Slew

Rules:

  1. When Slew is specified, no other action may be specified.

Examples:

Slew

Standby

This action selects standby (output disabled).

Syntax:

Standby

Rules:

  1. When Standby is specified, no other parameters are allowed.

Examples:

Standby

TestCurrent

This parameter specifies one of the following:

  1. Expected test current, when Resistance is the specified evaluation quantity.
  2. Measured test current, when TestCurrent is the specified evaluation quantity.

Syntax:

[+]TestCurrent[sp]=[sp]numeric value[sp][prefix]A

Rules:

  1. Range of legal values is based on the selected resistance.

Examples:

TestCurrent = 10 mA

TestVoltage

This parameter specifies one of the following:

1. Expected test voltage, when Resistance is the specified evaluation quantity.

2. Measured test voltage, when TestVoltage is the specified evaluation quantity.

Syntax:

[+]TestVoltage[sp]=[sp]numeric value[sp][prefix]V

Rules:

  1. Range of legal values is based on the selected resistance.

Examples:

TestVoltage = 240 V

ToroidalUUT / NonToroidalUUT

These parameters specifie that the UUT design for calculation of the total reference accuracy.

Syntax:

ToroidalUUT | NonToroidal

Rules:

  1. When ToroidalUUT and NonToroidalUUT are mutually exclusive.
  2. When neither ToroidalUUT or NonToroidalUUT is specified, the default is non-toroidal.

Examples:

ToroidalUUT

Turns

This parameter specifies the number of turns in the current coil.

Syntax:

Turns[sp]=[sp]integer

Rules:

Coil | Turns
5500A/COIL | [50]
9100_Option200 | 10 or 50
UserDefined | 1 to 100

Examples:

Coil = 5500A/COIL

Coil = 5500A/COIL; Turns = 50

Coil = 9100_Option200; Turns = 10

Coil = UserDefined; Turns = 30

Voltage

This parameter specifies the NORMAL output voltage for the following modes:

AC Voltage

DC Power

AC Power

Syntax:

[+|@]Voltage[sp]=[sp]numeric value[sp][prefix]units

units = V | Vp | Vpp

Examples:

+Voltage = 240 V

Examples

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON

# -----Reset -----
  1.001  5080A        Reset

# -----Standby-----
  1.002  5080A        Standby

# -----DC Voltage -----
  1.003  5080A        +Voltage = -190.0 mV
  1.004  TARGET       -m
  1.005  MEMI         Enter UUT reading in millivolts DC:
  1.006  MEMCX  200   -190.0mV       1.0% 0.1U

# -----DC Current -----
  2.001  5080A        +Current = 19.00 mA
  2.002  TARGET       -m
  2.003  MEMI         Enter UUT reading in millamps DC:
  2.004  MEMCX  20    19.00mA        1.5% 0.01U

# -----DC Current (using 5500A/COIL)-----
  3.001  5080A        +Current = 41.0 A; Coil = 5500A/COIL
  3.002  TARGET       -m
  3.003  MEMI         Enter UUT reading in amps DC:
  3.004  MEMCX  400   41.0A          1.5% 0.5U

# -----DC Current (using 9100 Option 200 10-Turn Coil) -----
  4.001  5080A        +Current = 11.00 A; Coil = 9100_Opt200; Turns = 10
  4.002  TARGET       -m
  4.003  MEMI         Enter UUT reading in amps DC:
  4.004  MEMCX  40    11.00A         1.5% 0.05U

# -----DC Current (using 9100 Option 200 50-Turn Coil) -----
  5.001  5080A        +Current = 41.0 A; Coil = 9100_Opt200; Turns = 50
  5.002  TARGET       -m
  5.003  MEMI         Enter UUT reading in amps DC:
  5.004  MEMCX  400   41.0A          1.5% 0.5U

# -----Resistance-----
  6.001  5080A        +Resistance = 1.900 kOhms; LeadComp = 2W
  6.002  TARGET       -m
  6.003  MEMI         Enter UUT reading in kilohms:
  6.004  MEMCX  2     kOhms          1% 0.004U

# -----AC Voltage -----
  7.001  5080A        +Voltage = 19.00 V; Frequency = 50 Hz
  7.002  TARGET       -m
  7.003  MEMI         Enter UUT reading in volts AC:
  7.004  MEMCX  20    19.00V         1.5% 0.05U    50Hz

# -----AC Current -----
  8.001  5080A        +Current = 1.900 mA; Frequency = 500 Hz
  8.002  TARGET       -m
  8.003  MEMI         Enter UUT reading in millamps AC:
  8.004  MEMCX  2     1.900mA        2% 0.005U     500Hz

# -----AC Current (using 5500A/COIL)-----
  9.001  5080A        Coil = 5500A/COIL; NonToroidalUUT; IndComp = On
  9.001  5080A        +Current = 410 A; Frequency = 50 Hz
  9.002  TARGET       -m
  9.003  MEMI         Enter UUT reading in amps AC:
  9.004  MEMCX  2000  410A           1.5% 5U       50Hz

# -----AC Current (using 9100 Option 200 10-Turn Coil) -----
 10.001  5080A        Coil = 9100_Opt200; Turns = 10; IndComp = On
 10.001  5080A        +Current = 11.00 A; Frequency = 50 Hz
 10.002  TARGET       -m
 10.003  MEMI         Enter UUT reading in amps AC:
 10.004  MEMCX  40    11.00A         1.5% 0.05U    50Hz

# -----AC Current (using 9100 Option 200 50-Turn Coil) -----
 11.001  5080A        Coil = 9100_Opt200; Turns = 50; IndComp = On
 11.001  5080A        +Current = 410 A; Frequency = 60 Hz
 11.002  TARGET       -m
 11.003  MEMI         Enter UUT reading in amps AC:
 11.004  MEMCX  2000  410A           1.5% 5U       60Hz

# ----- Dual AC Voltage -----
 12.001  5080A        NormalVoltage = 5 V; Phase = 0 deg
 12.001  5080A        +AuxVoltage = 0.03 V; Frequency = 60 Hz
 12.002  MATH         L[1] = REFACC() / MEM1 * 100
 12.003  5080A        AuxVoltage = 0.03 V; Phase = 0 deg
 12.003  5080A        +NormalVoltage = 5 V; Frequency = 60 Hz
 12.004  MATH         L[2] = REFACC() / MEM1 * 100
 12.005  MATH         L[3] = RSS_L(1, 2)
 12.006  ACC          150W           L3%
 12.007  MEMI         Enter UUT reading in watts.
 12.008  MEMCX        150W           1% 4U

 13.001  5080A        NormalVoltage = 100 V; AuxVoltage = 150 mV
 13.001  5080A        +Phase = 157 deg; Frequency = 60 Hz
 13.002  MEMI         Enter UUT reading in degrees.
 13.003  MEMCX        157deg         2U

# -----AC Power (using 5500A/COIL) -----
 14.001  5080A        Coil = 5500A/COIL; NonToroidalUUT; IndComp = On
 14.001  5080A        Voltage = 380 V; Current = 100 A; Phase = 0 deg
 14.001  5080A        +Power = 38.00 kW; Frequency = 50 Hz
 14.002  TARGET       -m
 14.003  MEMI         Enter UUT reading in kilowatts:
 14.004  MEMCX  40    38.00kW        2.5% 0.05U

 15.001  5080A        Coil = 5500A/COIL; NonToroidalUUT; IndComp = On
 15.001  5080A        Voltage = 19 V; Current = 100 A; Phase = 0 deg
 15.001  5080A        +Power = 1900 VA; Frequency = 50 Hz
 15.002  TARGET       -m
 15.003  MEMI         Enter the UUT reading in volt-amps:
 15.004  MEMCX  4000  1900VA         80U

 16.001  5080A        Coil = 5500A/COIL; NonToroidalUUT; IndComp = On
 16.001  5080A        Voltage = 397.363 V; Current = 100 A; Phase = -73 deg
 16.001  5080A        +Power = +38.00 kVAR; Frequency = 50 Hz
 16.002  TARGET       -m
 16.003  MEMI         Enter UUT reading in kilovolts-amps reactive:
 16.004  MEMCX  40    +38.00k'VAR'   2.5% 0.05U

 17.001  5080A        Coil = 5500A/COIL; NonToroidalUUT; IndComp = On
 17.001  5080A        Voltage = 460.105 V; Current = 100 A
 17.001  5080A        +PF = 0.292; Frequency = 50 Hz; Lead
 17.002  TARGET       -m
 17.003  MEMI         Enter UUT power factor reading:
 17.004  MEMCX        0.292          0.050U

# -----AC Power (using 9100 Option 200 50-Turn Coil) -----
 18.001  5080A        Coil = 9100_Opt200; NonToroidalUUT; Turns = 50; IndComp = On
 18.001  5080A        Voltage = 44 V; Current = 100 A; Phase = 0 deg
 18.001  5080A        +Power = 4.40 kW; Frequency = 50 Hz
 18.002  TARGET       -m
 18.003  MEMI         Enter UUT reading in kilowatts:
 18.004  MEMCX  40    4.40kW         2.5% 0.05U

 19.001  5080A        Coil = 9100_Opt200; NonToroidalUUT; Turns = 50; IndComp = On
 19.001  5080A        Voltage = 380 V; Current = 100 A; Phase = 0 deg
 19.001  5080A        +Power = 38.00 kVA; Frequency = 50 Hz
 19.002  TARGET       -m
 19.003  MEMI         Enter UUT reading in kilovolt-amps:
 19.004  MEMCX  40    38.00kVA       2.5% 0.05U

 20.001  5080A        Coil = 9100_Opt200; NonToroidalUUT; Turns = 50; IndComp = On
 20.001  5080A        Voltage = 460.105 V; Current = 100 A; Phase = +73 deg
 20.001  5080A        +Power = -44.0 kVAR; Frequency = 50 Hz
 20.002  TARGET       -m
 20.003  MEMI         Enter UUT reading in kilovolts-amps reactive:
 20.004  MEMCX  400   -44.0k'VAR'    2.5% 0.5U

 21.001  5080A        Coil = 9100_Opt200; NonToroidalUUT; Turns = 50; IndComp = On
 21.001  5080A        Voltage = 19.8681 V; Current = 100 A
 21.001  5080A        +PF = 0.292; Frequency = 50 Hz; Lag
 21.002  TARGET       -m
 21.003  MEMI         Enter UUT power factor reading:
 21.004  MEMCX        0.292          0.050U
 22.001  END


5100

Instrument FSC

Description

The 5100 FSC programs the Fluke 5100B Calibrator to output DC voltage, AC voltage, DC current, and AC current. 5100B resistance is programmed using the RESF FSC. 5100B wideband AC voltage is programmed using the WIDE FSC.

Functional Capability

Function | NOMINAL | MOD1
DC Voltage | -1100 V to 1100 V
AC Voltage | 1 μV to 19.9999 V, -117 dBm to 28.239 dBm 2 | 50 Hz to 50 kHz1
1 μV to 110 V, -117 dBm to 43.046 dBm 2 | 50 Hz to 20 kHz1
1 μV to 1100 V, -117 dBm to 63.046 dBm 2 | 50 Hz to 1 kHz1
DC Current | ±(9 μA to 1.99999 A)
AC Current | 9 μA to 1.99999 A (accuracy specification up to 1 kHz only) | 50 Hz to 5 kHz1
  1. The value of frequency must have single-digit resolution. For example, 50 Hz or 60 Hz is allowed, but 55 Hz is not.
  2. All dBm values are into 600 Ohms.

Parameters

RANGE

This field specifies the UUT range as described in the RANGE Field topic.

NOMINAL

This field specifies the expected measured value or a reset.

  • Voltage (DC or RMS) entered as: [numeric][prefix]V
  • dBm entered as: [numeric][prefix]D
  • Current entered as [numeric][prefix]A.
  • Reset entered as *.

TOLERANCE

This field specifies the UUT tolerance as described in the TOLERANCE Field topic.

MOD1

This field specifies frequency for AC voltage and AC current.

  • Frequency entered as numeric[prefix]H.
  • blank DC

MOD2

This field allows you to specify the divider override feature of the calibration system. Divider Override is specified by entering the character 'O' for this field. The use of internal and external divider allows a user to achieve higher levels of calibration accuracy in most circumstances; therefore the use of the divider is always automatically selected, where it is applicable. There are two reasons to override the use of the divider.

  • The high burden property of the UUT requires divider override to maintain calibration accuracy.
  • Fewer operator interactions will be necessary and the feature of the (external) divider is not necessary, resulting in shorter calibration times. The following table is shows effect of the MOD2 field.
DC Volts | ≥20V | blank | Low output impedance
DC Volts | <20V | blank | 50 Ohm output impedance
DC Volts | <20V | O | Locked in 20V range, low output impedance
AC Volts | ≥2V | blank | Low output impedance
AC Volts | ≥20mV & <200mV | blank | 50 Ohm output impedance
AC Volts | <20mV | blank | External 1000:1 50 Ohm divider Reduced system noise levels
AC Volts | <20mV | O | Internal divider

An external 1000:1 divider is supplied with every calibration system, which uses the 5100B as a calibration source. This external divider is used to reduce the impact of system noise on the response of the UUT. If the bandwidth of the AC voltmeter function of the UUT is below 1MHz, the external divider is typically not necessary, however to calibrate wideband voltmeters, this external divider should be used.

MOD3

This field is used to specify accuracy enhancement. Accuracy enhancement in this case means that the output of the 5100B is measured by the typically higher accuracy voltmeter in the calibration system.

The value measured by the voltmeter is then used as a further reference to execute the procedure step. The exact operation depends on the type of test; refer to the information under MOD4 for more information on the type of tests. A regular and fast mode of accuracy enhancement can be selected. In the DC Voltage function, accuracy enhancement applies to almost the full range of allowed values (exception: 128V to 200V). In the AC Voltage mode, accuracy enhancement can only be used between 12.5 mV and 600V, assuming the external divider is not used. If the external divider is used for nominal values below 20 mV, accuracy enhancement can be selected to improve the accuracy at the input of the external divider. During Setup procedure steps only, another mode of accuracy enhancement is possible with the 8506A DMM. The output of the 5100B can be changed depending on the reading of the 8506A. Refer to the following accuracy enhancement information.

(blank) | (any) | No accuracy enhancement specified
-E | (any) | Prevent automatic accuracy enhancement
Eor EF | (blank) | Apply stimulus from 5100B, nominal value. Adjust manually the stimulus so that the UUT reads nominal. Read adjusted output with the voltmeter, compare the result to the UUT nominal value, and generate the result.
E | S | Apply the stimulus Adjust the stimulus to the nominal based on a reading by the voltmeter.
EF | S | Apply the stimulus The voltmeter measures the stimulus of the 5100B, and stores the reading in MEM1.

AUTOMATIC SELECTION OF ACCURACY ENHANCEMENT

Accuracy enhancement is specified automatically where the accuracy of the UUT requires the highest accuracy from the calibration system. Automatic accuracy enhancement selection is dependent on the mode (DC or AC Voltage), the Nominal Voltage (in NOMINAL field), and the specified Tolerance (in TOLERANCE field). The following information shows the conditions for automatic accuracy enhancement selection:

Volts DC | ≥0.02V | <0.02 %
Volts AC | ≥0.2V | <0.2 %

PREVENTION OF AUTOMATIC ACCURACY ENHANCEMENT SELECTION

Automatic insertion of accuracy enhancement is prevented by entering -E during entry of the 5100 procedure statement.

MOD4

This field specifies the type of test being performed as described in the MOD4 Field topic.

CON

This field specifies the UUT connection.

  • 2W 2-wire
  • 4W 4-wire

Rules:

  1. 2W is automatically inserted in the CON field when no CON field parameter is entered.

Use of Standard Memory Locations and Results Reporting

System memory locations MEM and MEM1 are used. For more information, refer to the Use of Standard Memory Registers topic.

Examples

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
# Reset
  1.001  5100         *                                                 S
# DC Voltage
  1.002  5100   1000  1000mV         0.05% 1U                              2W
  2.001  5100   2     -1.999V        1000P/                       O        2W
  3.001  5100   20    20mV           6%                           O  -E    2W
  4.001  5100   200   -20mV          0.019%                          E     2W
# AC Voltage
  5.001  5100   10    1mV            +1U -2U       50H                     2W
  6.001  5100   1000  1100V          +2U -4U       1kH                     2W
  7.001  5100   A     mV             100P%         50H                     2W
  8.001  5100   20    12.6mV         2%            1kH            O  E     2W
# dBm
  9.001  5100   10    10D            0.1U          50kH                    2W
# DC Current
 10.001  5100   2     1.999A         1%                                    2W
# AC Current
 11.001  5100   100   100uA          1% 1/         1kH                     2W
 12.001  5100         10uA                         50H                  S  2W
 12.002  5100   A     1.999A         -1U +0.1%     1kH                     2W


5205

Instrument FSC

Description

The 5205 FSC programs the Fluke 5205A or 5215A Power Amplifier via the Fluke 5100B Calibrator.

  • To use either of these amplifiers with the Fluke 5200A AC Calibrator, use the 5200 FSC.
  • To use either of these amplifiers with the Fluke 5700A Multifunction Calibrator, use the 5700 FSC.

Functional Capability

Function | NOMINAL | MOD1
DC Voltage | -1100 V to 1100 V 1
AC Voltage | 20V to 1100V, 28.24dBm to +63.046dBm 2 | 50 Hz to 50 kHz 3
  1. 5205A only.
  2. All values in dBm are into 600 Ohm.
  3. The value of frequency must have single-digit resolution. For example, 50 Hz or 60 Hz is allowed, but 55 Hz is not.

Parameters

RANGE

This field specifies the UUT range as described in the RANGE Field topic.

NOMINAL

This field specifies the amplitude or reset.

  • Voltage (DC or RMS) entered as: [numeric][prefix]V
  • dBm entered as: [numeric][prefix]D
  • Reset entered as *.

TOLERANCE

This field specifies the UUT tolerance as described in the TOLERANCE Field topic.

MOD1

This field specifies the frequency for AC Voltage.

  • Frequency entered as [numeric][prefix]H.
  • blank DC

MOD2

This field is not used.

MOD3

This field is not used.

MOD4

This field specifies the type of test being performed as described in the MOD4 Field topic.

CON

This field specifies the UUT connection.

2W 2-wire

Rules:

  1. 2W is automatically inserted in the CON field when no CON field parameter is entered.

Use of Standard Memory Locations and Results Reporting

System memory locations MEM and MEM1 are used. For more information, refer to the Use of Standard Memory Registers topic.

Examples

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
# ----- Reset -----
  1.001  5205         *                                                 S
  1.002  5205   1000  1100V          -5% 5000P/                            2W
  2.001  5205   60    63.046D        0.1U          50kH                    2W
  3.001  5205   A     1100V          5%            50kH                    2W
  4.001  5205   1000  1100V          5%            50kH                    2W
  5.001  5205         1100V                        50kH                 S  2W


5220

Instrument FSC

Description

The 5220 FSC programs the Fluke 5220A Transconductance Amplifier via the 5100B Calibrator.

  • To use the 5220A with the Fluke 5440B DC Calibrator, use the 5440 FSC.
  • To use the 5220A with the Fluke 5700A Multifunction Calibrator, use the 5700 FSC.

FUNCTIONAL CAPABILITY

Function | NOMINAL | MOD1
DC Current | -19.9999 A to 19.9999 A
AC Current | 1 A to 19.9999 A | 50 Hz to 5 kHz1
  1. The value of frequency must have single-digit resolution. For example, 50 Hz or 60 Hz is allowed, but 55 Hz is not.

Parameters

RANGE

This field specifies the UUT range as described in the RANGE Field topic.

Nominal

This field specifies the current or reset.

  • Current (DC or RMS) entered as: [numeric][prefix]A
  • Reset entered as *.

TOLERANCE

This field specifies the UUT tolerance as described in the TOLERANCE Field topic.

MOD1

This field specifies the frequency for AC Current.

  • Frequency entered as [numeric][prefix]H.
  • blank DC

MOD2

This field is not used.

MOD3

This field is not used.

MOD4

This field specifies the type of test being performed as described in the MOD4 Field topic.

CON

This field specifies the UUT connection.

2W 2-wire

Rules:

  1. 2W is automatically inserted in the CON field when no CON field parameter is entered.

Use of Standard Memory Locations and Results Reporting

System memory locations MEM and MEM1 are used. For more information, refer to the Use of Standard Memory Registers topic.

EXAMPLES

# ----- Reset -----
  1.001  5220         *                                                 S
  1.002  5220   20    -19A           -5% 4000P%                            2W
  2.001  5220   A     19A            5000P%        50H                     2W
  3.001  5220   10    2A             -5%           1kH                     2W
  4.001  5220   20    10A            5%            1kH                     2W
  5.001  5220         10A                          1kH                  S  2W
  5.002  5220         10A            5%            500H                 N  2W
  5.003  5220         10A            5%            1kH                  C  2W


RESF

Instrument FSC

Description

The RESF FSC provides fixed resistance or conductance from the Fluke 5100B Calibrator.

Functional Capability

1 Ohm to 10 MOhm (1S to 100nS) in decade steps

Parameters

RANGE

This field specifies the UUT range as described in the RANGE Field topic.

NOMINAL

This field specifies the resistance, conductance, or specifies a reset.

  • Resistance entered as: [numeric][prefix]V
  • Current entered as: [numeric][prefix]A
  • Reset entered as *.

TOLERANCE

This field specifies the UUT tolerance as described in the TOLERANCE Field topic.

MOD1

This field is not used.

MOD2

This selection is used to compensate for lead resistance in the two-wire ohms mode. If the character O (for Offset) is entered in this field, the contents of memory location MEM are used instead of the value in the NOMINAL field for comparison against the expected nominal value. To take advantage of this feature, use another DMM, e.g., 8506A, to measure the total of the lead resistance and the value of resistance being measured. Then store this measurement in MEM, and evaluate the UUT with the nominal value of resistance (with the O selection specified.) The following example tests the accuracy of a UUT at 100 ohms in two-wire mode:

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON

  1.004  ASK-   R
  1.005  HEAD         LOW RESISTANCE/HIGH CONDUCTANCE TEST
  1.006  RESF         100.0Z                                            S  2W
  1.007  DISP         Configure the 8506A as follows:
  1.007  DISP         8506A: Input-Hi to 8506A: Source-Hi
  1.007  DISP         8506A: Input-Lo to 8506A: Source-Lo
  1.007  DISP         Press the 4T Ohms button in to enable 4-wire ohms.
  1.008  IEEE         [@8506]G3?[I]
  1.009  MEME
  1.010  JMPT         1.013
  1.011  DISP         Press the FRONT/REAR select switch.
  1.012  JMP          1.008
  1.013  DISP         Connect the 5100B and the 8506A as follows:
  1.013  DISP         5100B: Output-Hi to 8506A: Input-Hi
  1.013  DISP         5100B: Output-Lo to 8506A: Input-Lo
  1.014  8506         100Z                                              N  4W
  1.015  MEME
  1.016  DISP         Disconnect the 8506A from the 5100B.
  1.016  DISP         Connect the 5100B and the UUT as follows:
  1.016  DISP         5100B: Output-Hi to UUT V/Ohms
  1.016  DISP         5100B: Output-Lo to UUT COMMON
  1.017  RESF         100Z           0.7% 0.2U                    O        2W

The explanation is as follows:

  • Step 1.004 disables the regular range and function messages.
  • Step 1.006 applies 100 ohms from the 5100B in the two-wire mode.
  • Step 1.007 wires the 8506A up in the four-wire mode, directly on its front panel input terminals.
  • Step 1.008 checks that the FRONT/REAR selection switch of the 8506A is in the FRONT position. If it is not, the operator is prompted as defined in step 1.011.
  • The output of the 5100B is now connected and then measured with the leads up to the front panel of the 8506A in steps 1.013 and 1.014. The result is stored in MEM1, then it is moved over to MEM in step 1.015.
  • The test leads are now moved over from the 8506A input to the UUT input in step 1.016.
  • The performance of the UUT is now evaluated against the value in MEM in step 1.017 (note the O selection).

MOD3

This field specifies the guard connection.

G | External guard connection is active
blank | Guard is internally shorted to low.

MOD4

This field specifies the type of test being performed as described in the MOD4 Field topic.

CON

This field specifies the UUT connection.

2w | 2-wire
4w | 4-wire

Rules:

  1. 2W is automatically inserted in the CON field when no CON field parameter is entered.
  2. 4W does not apply for 5100B resistance values over 10 kOhm.

Use of Standard Memory Locations and Results Reporting

System memory locations MEM and MEM1 are used. For more information, refer to the Use of Standard Memory Registers topic.

Examples

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
# -----  Reset -----
  2.001  RESF         *                                                 S
  2.002  RESF   100   100kZ          5.0%                                  2W
  3.001  RESF   10    10Z            500P%                                 4W
  4.001  RESF   10    10MZ           10000P/                               2W
  5.001  RESF   200   100Z           5.0%                                  4W
  6.001  RESF   10    Z              5.0U                                  4W
  7.001  RESF   10    1mY            4000P/                                4W
  8.001  RESF   1     0.1Y           5.0%                                  4W
  9.001  RESF   1     1Z             5%                                    4W
 10.001  RESF         1Z                                                S  4W


WIDE

Instrument FSC

Description

The WIDE FSC provides voltage from the 5100B-03 Wideband AC option installed in a 5100B Calibrator.

Functional Capability

NOMINAL | MOD1
270 μV to 3.1623 V, -58.362 dBm to +23 dBm | 10 Hz to 10 MHz

Parameters

RANGE

This field specifies the UUT range as described in the RANGE Field topic.

NOMINAL

This field specifies the amplitude or reset.

  • Voltage (RMS) entered as: [numeric][prefix]V
  • dBm entered as: [numeric][prefix]D
  • Reset entered as *.

TOLERANCE

This field specifies the UUT tolerance as described in the TOLERANCE Field topic.

MOD1

This field specifies the frequency entered as [numeric][prefix]H.

Rules:

  1. The value of frequency must have single-digit resolution. For example, 50H or 60H are allowed, but 55H is not.

MOD2

This field is not used.

MOD3

This field is not used.

MOD4

This field specifies the type of test being performed as described in the MOD4 Field topic.

CON

This field specifies the UUT connection. A 50 Ohm load is required. If the UUT does not have an internal 50 Ohm input impedance or termination, the procedure must inform the operator to connect such a device to the end of the BNC cable near the input of the UUT. The procedure writer can use the DISP FSC to create such a message.

2W 2-wire

Rules:

  1. 2W is automatically inserted in the CON field when no CON field parameter is entered.

Use of Standard Memory Locations and Results Reporting

System memory locations MEM and MEM1 are used. For more information, refer to the Use of Standard Memory Registers topic.

Examples

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
# ----- Reset -----
  1.001  WIDE         *                                                 S
  1.002  WIDE   10    3.1623V        1% 0.1U       10MH                    2W
  2.001  WIDE   A     -57.5D         2%            10H                     2W
  3.001  WIDE   A     V              1%            10kH                    2W
  4.001  WIDE   A     D              0.1U          20kH                    2W
  5.001  WIDE   1     1V             5%            10kH                    2W
# ----- Setup Test ----
  6.001  WIDE         1V                           10kH                 S  2W
  6.002  WIDE   1     1V                           10kH                 N  2W
  6.003  WIDE   1     1V             5%            20kH                 C  2W


5130

Instrument FSC

Description

The 5130 FSC instructs the system to request a voltage or current stimulus from the Fluke 5130A Calibrator. Ohms stimulus from the 5130A is obtained using the RESF FSC.

RANGE

Specifies the UUT range in units of the Nominal Value or Autorange.

Allowed entries: numeric, numericR, A, AR.

NOMINAL

Starting Nominal value of the 5130A output or reset: ('*').

Allowed values:

Volts, DC
-1100 V to +1100 V |  | (V)
Volts, AC
1 μV to 19.9999 V | 50 Hz to 50 kHz | (V)
20 V to 110 V | 50 Hz to 20 kHz | (V)
110 V to 1100 V | 50 Hz to 1 kHz | (V)
(All values of dBm are into 600 Ω)
-117 dBm to 28.239 dBm | 50 Hz to 50 kHz | (D)
117 dBm to 43.046 dBm | 50 Hz to 20 kHz | (D)
-117 dBm to 63.046 dBm | 50 Hz to 1 kHz | (D)
Amps, DC
9 μA to 1.99999 A |  | (A)
-1.99999 A to -9 μA |  | (A)
Amps, AC
9 μA to 1.99999 A | 50 Hz to 5 kHz | (A)
Note: accuracy specification up to 1 kHz only

TOLERANCE

Specifies the tolerances that UUT results are evaluated against. The tolerances should reflect the instrument specifications of the UUT at the Nominal value. Entries (3 max) used:

numeric% (% of reading) | numeric/ (% of range)
numericP% (PPM of reading) | numericP/ (PPM of range)
numericU (Units of nominal) | TOL (from last TOL FSC)

MOD1

Frequency of the Nominal value for AC Volts and Current. See also under Nominal. Allowed values and units:

MOD1 values | MOD1 units | Nominal values
50 Hz to 1 kHz | (H) | 1 μV to 1100 V
50 Hz to 20 kHz | (H) | 1 μV to 110 V
50 Hz to 50 kHz | (H) | 1 μV to 19.9999 V
50 Hz to 5 kHz | (H) | 9 μA to 1.99999 A

Additional note: The value of frequency must have single-digit resolution. For example 50H or 60H are allowed, but 55H is not.

MOD2

The MOD2 field allows you to specify the divider override feature of the calibration system. Divider Override is specified by entering the character 'O' for this field.

The use of internal and external divider allows a user to achieve higher levels of calibration accuracy in most circumstances; therefore the use of the divider is always automatically selected, where it is applicable. There are two sets of reasons to override the use of the divider.

  • The high burden property of the UUT requires divider override to maintain calibration accuracy.
  • Fewer operator interactions will be necessary and the feature of the (external) divider is not necessary, resulting in shorter calibration times.

In the following table is shown the entry in the MOD2 field, the mode of the 5130A, the Nominal value and the effect.

Entry | Mode | Nominal | Effect
(blank) | Volts DC | <20V | 50 Ω output impedance from 5130A
(blank) | Volts DC | ≥20V | Low output impedance from 5130A
(blank) | Volts AC | <20mV | External 1000:1 50 Ω divider used reduced system noise levels
(blank) | Volts AC | ≥20mV | 50 Ω output <200 mV impedance from 5130A
(blank) | Volts AC | ≥2V | Low output impedance from 5130A
O | Volts DC | <20V | 5130A fixed in 20 V range
O | Volts DC | ≥20V | Not applicable
O | Volts AC | <20mV | 5130A fixed in 2V range, external divider not used
O | Volts AC | ≥20mV | Not applicable

An external 1000:1 divider is supplied with every calibration system, which uses the 5130A as a calibration source. This external divider is used to reduce the impact of system noise on the response of the UUT. If the bandwidth of the AC voltmeter function of the UUT is below 1MHz, the external divider is typically not necessary, however to calibrate wideband voltmeters, this external divider should be used.

MOD3

Not used.

MOD4

Specifies the type of test being performed:

(blank) | Evaluation test
S | Setup test
N | Nominal Set test
C | Comparison test

CON

The CON field specifies the UUT connection. Possible entries are:

  • 2W for a 2-wire connection to the UUT, and
  • 4W for a 4-wire connection to the UUT.

If nothing is entered, the system will automatically insert 2W. In case of the Volts AC mode and the external 1000:1 divider is specified and

  • Nominal value is less than 20mV,
  • divider override (0) is not specified in the MOD2 field

the calibration system will solicit a connection to the terminals using the external AC Divider.

Four-wire (4W) stimulus is not applicable in some situations:

  • Volts DC, Nominal < 2V unless MOD2 is O
  • Volts AC, Nominal < 200mV
  • Current DC and AC

Use of Standard Memory Locations and Results Reporting

System memory locations MEM and MEM1 are used. For more information, refer to the Use of Standard Memory Registers topic.

Examples

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
  1.001  5130         *                                                 S
  1.002  5130   1000  1000mV         0.05% 1U                              2W
  2.001  5130   10    1mV            +1U -2U       50H                     2W
  3.001  5130   1000  1100V          +2U -4U       1kH                     2W
  4.001  5130   10    10D            0.1U          50kH                    2W
  5.001  5130   2     1.999A         1%                                    2W
  6.001  5130   20    10uA           1% 1/         50H                     2W
  7.001  5130         10uA                         50H                  S  2W
  7.002  5130   A     mV             100P%         50H                     2W
  8.001  5130   A     1.999A         -1U +0.1%     1kH                     2W
  9.001  5130   2     -1.999V        1000P/                       O        2W


5191

Instrument FSC

Description

The 5191 FSC programs the Fluke/Philips PM 5191 Function Generator to output sine, square, triangle, and sawtooth waveforms.

When the 5191 FSC is used to control a Fluke PM 5191, you must configure the instrument as an "Philips PM 5191" as shown in the drop-down list in the "Add Instrument" configure dialog.

Functional Capability

Function | Amplitude | Frequency | MOD3
DC Voltage | -10 V to 10 V |  |
Sine | 0 Vpp to 30 Vpp | 0.1 mHz to 2.147 MHz | SI
 | 0 V to 10.6 V
 | -45 dBm to +27 dBm
Square | 0 Vpp to 30 Vpp | 0.1 mHz to 2.147 MHz | SQ
 | 0 V to 15 V
 | -45 dBm to +30 dBm
Triangle | 0 Vpp to 30 Vpp | 0.1 mHz to 200 kHz | TI
 | 0 V to 8.6 V
 | -45 dBm to +25 dBm
Positive Sawtooth | 0 Vpp to 15 Vpp | 0.1 mHz to 20 kHz | ST
 | 0 V to 4.3 V
 | -45 dBm to +19 dBm
Negative Sawtooth | <0 Vpp to -15 Vpp | 0.1 mHz to 20 kHz | ST
 | <0 V to -4.3 V
 | dBm not available

Parameters

RANGE

This field specifies the UUT range as described in the RANGE Field topic.

NOMINAL

This field specifies the amplitude or frequency or period.

  • Voltage (DC or RMS) entered as: [numeric][prefix]V
  • Voltage (peak-to-peak) entered as: [numeric][prefix]Vpp
  • dBm entered as: [numeric][prefix]D
  • Frequency entered as [numeric][prefix]H.
  • Period entered as [numeric][prefix]T.
  • Reset entered as *.

Rules:

  1. A DC voltage offset can be programmed by specifying a Setup test. The MOD1 field must be blank. A DC voltage offset turns the AC voltage off. The DC voltage offset remains in effect until a reset (*) or the end of a test. Any AC voltage function must be reprogrammed after the DC voltage statement in the procedure.
  2. When the NOMINAL field specifies frequency or period, the MOD1 field must specify the amplitude.

TOLERANCE

This field specifies the UUT tolerance as described in the TOLERANCE Field topic.

MOD1

This field specifies amplitude or frequency or period for AC functions.

  • Voltage (RMS) entered as: [numeric][prefix]V
  • Voltage (peak-to-peak) entered as: [numeric][prefix]Vpp
  • dBm entered as: [numeric][prefix]D
  • Frequency entered as [numeric][prefix]H.
  • Period entered as [numeric][prefix]T.
  • blank DC

Rules:

  1. The MOD1 field may specify frequency only when the NOMINAL field specifies voltage or decibels.
  2. The MOD1 field may specify voltage only when the NOMINAL field specifies frequency or period.

MOD2

This field specifies whether "/div" is include in after the value in the automatic range message.

  • -D "/div" is not included
  • blank"/div" is included if ASK+ D is in effect

Rules:

  1. The MOD2 field is automatically set to -D for a Setup Test.

MOD3

This field specifies function (waveform type).

blank | DC Volts
SI | Sine
SQ | Square
TI | Triangle
ST | Sawtooth

Rules:

  1. The MOD3 field must be blank when the MOD1 field is blank.

MOD4

This field specifies the type of test being performed as described in the MOD4 Field topic.

CON

This field specifies the UUT connection.

blank | Open circuit
L | 50 Ohm

Rules:

  1. If the amplitude is expressed in dBm, the output is expected to be terminated and L is automatically inserted in the CON field. The procedure writer must use a DISP FSC to prompt the operator to terminate the output signal at the UUT.
  2. Termination affects the range of possible output signal values. The programmed voltage is corrected to obtain the nominal value across the 50 Ohm terminating resistor.

Use of Standard Memory Locations and Results Reporting

System memory locations MEM and MEM1 are used. For more information, refer to the Use of Standard Memory Registers topic.

Examples

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
# Reset
  1.001  5191         *                                                 S
# DC Voltage
  1.002  5191         1V                                          -D    S
# Sine w/1V DC offset
  1.003  5191   A     5V             1U            100kH          -D SI
# Square
  2.001  5191   1     10Vpp          10%           10kH           -D SQ
# Triangle
  3.001  5191   0.5   0.28Vpp        8/            100kH          -D TI
# Sine (decibels)
  4.001  5191   A     D              1U            100kH          -D SI    L
# Period
  5.001  5191   0.2   1T             1% 1/ 1U      1Vpp           -D SI


5192

Instrument FSC

Description

The 5192 FSC programs the Fluke/Philips PM 5192 Function Generator to output sine, square, triangle, and sawtooth waveforms.

When the 5192 FSC is used to control a Fluke PM 5192, you must configure the instrument as an "Philips PM 5192" as shown in the drop-down list in the "Add Instrument" configure dialog.

Functional Capability

Function | Amplitude | Frequency | MOD3
DC Voltage | -10 V to 10 V |  |
Sine | 0 Vpp to 20 Vpp | 0.1 mHz to 20 MHz | SI
 | 0 V to 7 V
 | -45 dBm to +24 dBm
Square | 0 Vpp to 20 Vpp | 0.1 mHz to 20 MHz | SQ
 | 0 V to 10 V
 | -13 dBm to +27 dBm
Triangle | 0 Vpp to 20 Vpp | 0.1 mHz to 200 MHz | TI
 | 0 V to 5.7 V
 | -45 dBm to +22 dBm
Positive Sawtooth | 0 Vpp to 10 Vpp | 0.1 mHz to 20 kHz | ST
 | 0 V to 2.8 V
 | -48 dBm to +16 dBm
Negative Sawtooth | <0 Vpp to -10 Vpp | 0.1 mHz to 20 kHz | ST
 | <0 V to -2.8 V
 | dBm not available

Parameters

RANGE

This field specifies the UUT range as described in the RANGE Field topic.

NOMINAL

This field specifies the amplitude or frequency or period.

  • Voltage (DC or RMS) entered as: [numeric][prefix]V
  • Voltage (peak-to-peak) entered as: [numeric][prefix]Vpp
  • dBm entered as: [numeric][prefix]D
  • Frequency entered as [numeric][prefix]H.
  • Period entered as [numeric][prefix]T.
  • Reset entered as *.

Rules:

  1. A DC voltage offset can be programmed by specifying a Setup test. The MOD1 field must be blank. A DC voltage offset turns the AC voltage off. The DC voltage offset remains in effect until a reset (*) or the end of a test. Any AC voltage function must be reprogrammed after the DC voltage statement in the procedure.
  2. When the NOMINAL field specifies frequency or period, the MOD1 field must specify the amplitude.

TOLERANCE

This field specifies the UUT tolerance as described in the TOLERANCE Field topic.

MOD1

This field specifies amplitude or frequency or period for AC functions.

  • Voltage (RMS) entered as: [numeric][prefix]V
  • Voltage (peak-to-peak) entered as: [numeric][prefix]Vpp
  • dBm entered as: [numeric][prefix]D
  • Frequency entered as [numeric][prefix]H.
  • Period entered as [numeric][prefix]T.
  • blank DC

Rules:

  1. The MOD1 field may specify frequency only when the NOMINAL field specifies voltage or decibels.
  2. The MOD1 field may specify voltage only when the NOMINAL field specifies frequency or period.

MOD2

This field specifies whether "/div" is include in after the value in the automatic range message.

  • -D"/div" is not included
  • blank"/div" is included if ASK+ D is in effect

Rules:

  1. The MOD2 field is automatically set to -D for a Setup Test.

MOD3

This field specifies function (waveform type).

  • blankDC Volts
  • SISine
  • SQSquare
  • TITriangle
  • STSawtooth

Rules:

  1. The MOD3 field must be blank when the MOD1 field is blank.

MOD4

This field specifies the type of test being performed as described in the MOD4 Field topic.

CON

This field specifies the UUT connection.

  • blankOpen circuit
  • L50 Ω

Rules:

  1. If the amplitude is expressed in dBm, the output is expected to be terminated and L is automatically inserted in the CON field. The procedure writer must use a DISP FSC to prompt the operator to terminate the output signal at the UUT.
  2. Termination affects the range of possible output signal values. The programmed voltage is corrected to obtain the nominal value across the 50 Ω terminating resistor.

Use of Standard Memory Locations and Results Reporting

System memory locations MEM and MEM1 are used. For more information, refer to the Use of Standard Memory Registers topic.

Examples

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
# Reset
  1.001  5192         *                                                 S
# DC Voltage
  1.002  5192         1V                                          -D    S
# Sine w/1V DC offset
  1.003  5192   A     5V             1U            100kH          -D SI
# Square
  2.001  5192   1     10Vpp          10%           10kH           -D SQ
# Triangle
  3.001  5192   0.5   0.28Vpp        8/            100kH          -D TI
# Sine (decibels)
  4.001  5192   A     D              1U            100kH          -D SI    L
# Period
  5.001  5192   0.2   1T             1% 1/ 1U      1Vpp           -D SI


5193

Instrument FSC

Description

The 5193 FSC programs the Fluke/Philips PM 5193 Function Generator to output sine, square, triangle, and sawtooth waveforms.

Functional Capability

Function | Amplitude | Frequency | MOD3
DC Voltage | -10 V to 10 V |  |
Sine | 0 Vpp to 20 Vpp | 0.1 mHz to 50 MHz | SI
 | 0 V to 7 V
 | -45 dBm to +24 dBm
Square | 0 Vpp to 20 Vpp | 0.1 mHz to 20 MHz | SQ
 | 0 V to 10 V
 | -13 dBm to +27 dBm
Triangle | 0 Vpp to 20 Vpp | 0.1 mHz to 200 MHz | TI
 | 0 V to 5.7 V
 | -45 dBm to +22 dBm
Positive Sawtooth | 0 Vpp to 10 Vpp | 0.1 mHz to 20 kHz | ST
 | 0 V to 2.8 V
 | -48 dBm to +16 dBm
Negative Sawtooth | <0 Vpp to -10 Vpp | 0.1 mHz to 20 kHz | ST
 | <0 V to -2.8 V
 | dBm not available

Parameters

RANGE

This field specifies the UUT range as described in the RANGE Field topic.

NOMINAL

This field specifies the amplitude or frequency or period.

  • Voltage (DC or RMS) entered as: [numeric][prefix]V
  • Voltage (peak-to-peak) entered as: [numeric][prefix]Vpp
  • dBm entered as: [numeric][prefix]D
  • Frequency entered as [numeric][prefix]H.
  • Period entered as [numeric][prefix]T.
  • Reset entered as *.

Rules:

  1. A DC voltage offset can be programmed by specifying a Setup test. The MOD1 field must be blank. A DC voltage offset turns the AC voltage off. The DC voltage offset remains in effect until a reset (*) or the end of a test. Any AC voltage function must be reprogrammed after the DC voltage statement in the procedure.
  2. When the NOMINAL field specifies frequency or period, the MOD1 field must specify the amplitude.

TOLERANCE

This field specifies the UUT tolerance as described in the TOLERANCE Field topic.

MOD1

This field specifies amplitude or frequency or period for AC functions.

  • Voltage (RMS) entered as: [numeric][prefix]V
  • Voltage (peak-to-peak) entered as: [numeric][prefix]Vpp
  • dBm entered as: [numeric][prefix]D
  • Frequency entered as [numeric][prefix]H.
  • Period entered as [numeric][prefix]T.
  • blank DC

Rules:

  1. The MOD1 field may specify frequency only when the NOMINAL field specifies voltage or decibels.
  2. The MOD1 field may specify voltage only when the NOMINAL field specifies frequency or period.

MOD2

This field specifies whether "/div" is include in after the value in the automatic range message.

  • -D "/div" is not included
  • blank "/div" is included if ASK+ D is in effect

Rules:

  1. The MOD2 field is automatically set to -D for a Setup Test.

MOD3

This field specifies function (waveform type).

blank | DC Volts
SI | Sine
SQ | Square
TI | Triangle
ST | Sawtooth

Rules:

  1. The MOD3 field must be blank when the MOD1 field is blank.

MOD4

This field specifies the type of test being performed as described in the MOD4 Field topic.

CON

This field specifies the UUT connection.

  • blankOpen circuit
  • L 50 Ω

Rules:

  1. If the amplitude is expressed in dBm, the output is expected to be terminated and L is automatically inserted in the CON field. The procedure writer must use a DISP FSC to prompt the operator to terminate the output signal at the UUT.
  2. Termination affects the range of possible output signal values. The programmed voltage is corrected to obtain the nominal value across the 50 Ω terminating resistor.

Use of Standard Memory Locations and Results Reporting

System memory locations MEM and MEM1 are used. For more information, refer to the Use of Standard Memory Registers topic.

Examples

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
# Reset
  1.001  5193         *                                                 S
# DC Voltage
  1.002  5193         1V                                          -D    S
# Sine w/1V DC offset
  1.003  5193   A     5V             1U            100kH          -D SI
# Square
  2.001  5193   1     10Vpp          10%           10kH           -D SQ
# Triangle
  3.001  5193   0.5   0.28Vpp        8/            100kH          -D TI
# Sine (decibels)
  4.001  5193   A     D              1U            100kH          -D SI    L
# Period
  5.001  5193   0.2   1T             1% 1/ 1U      1Vpp           -D SI


5200

Instrument FSC

Description

The 5200 FSC programs the Fluke 5200A AC Calibrator.

Functional Capability

NOMINAL | MOD1
100 mV to 119.9999 V, -77.78 dBm to +43.8 dBm 1 | 10 Hz to 1.199 MHz
120 V to 1100 V, 43.803 dBm to 63 dBm 2 | 10 Hz to 100 kHz
  1. Product of voltage and frequency not to exceed 107 when frequency >100 kHz.
  2. With 5205A or 5215A Power Amplifier.

Parameters

RANGE

This field specifies the UUT range as described in the RANGE Field topic.

NOMINAL

This field specifies the amplitude or reset.

  • Voltage (RMS) entered as: [numeric][prefix]V
  • dBm entered as: [numeric][prefix]D
  • Reset entered as *.

TOLERANCE

This field specifies the UUT tolerance as described in the TOLERANCE Field topic.

MOD1

This field specifies the frequency entered as [numeric][prefix]H.

MOD2

This field is not used.

MOD3

This field is not used.

MOD4

This field specifies the type of test being performed as described in the MOD4 Field topic.

CON

This field specifies the UUT connection.

  • 2W 2-wire
  • 4W 4-wire

Rules:

  1. 2W is automatically inserted in the CON field when no CON field parameter is entered.
  2. The CON field may specify 4W only when the amplitude is 0.12 V to 119.9999 V (-16.19 dBm to +43.8 dBm).

Use of Standard Memory Locations and Results Reporting

System memory locations MEM and MEM1 are used. For more information, refer to the Use of Standard Memory Registers topic.

Examples

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
# ----- Reset -----
  1.001  5200         *                                                 S
  1.002  5200   1     0.1mV          1U 1%         10H                     2W
  2.001  5200   100   10V            0.05U 1%      1MH                     2W
  3.001  5200   1000  1000V          1U 1% 1/      100kH                   2W
  4.001  5200   50    -77.78D        5U            10H                     2W
  5.001  5200   50    43.9D          0.1U          100H                    2W
  6.001  5200   50    D              1U            100kH                   2W
  7.001  5200   1     0.12V          +0.1U         10H                     2W


5320

Instrument FSC

Description

The 5320 FSC controls the Fluke 5320A Electrical Test Equipment Calibrator.

Parameters

A 5320 statement consists of one or more parameters. A parameter consists of a name and a value. Each parameter must be separated by a semicolon and/or one or more spaces. A single 5320 statement can encompass more than one physical line as long as the line numbers are the same. However each parameter name and its value must occur on one line. A single line can accommodate up to 256 characters including the statement number and FSC. Note that characters above ASCII 128 count as 2 characters.

Syntax:

5320 parameter[separaterparameter]

parameter ::= [prefix]parameter name[sp]=[sp]parameter value

separater ::= ;[sp] | sp

prefix ::= + | @

sp ::= one or more spaces

parameter name ::= see the Parameter Names section

parameter value ::= see the Parameter Names section

|
Denotes "or" (i.e. A | B is A or B)
[ ]
Denotes an optional syntax element, except in examples. In examples [ ] enclose a special construction.
+
Designates the parameter as the Evaluation Quantity
@
Designates the parameter as the Modifier Quantity

Examples:

The following three 5320 statements are identical with respect to the 5320A:

Statement #1

1.001 5320 Mode = Volt; +Volt = 240V; @Freq = 50Hz

Statement #2

1.001 5320 Mode = Volt +Voltage = 240.0 V @Frequency = 50 Hz

Statement #3

  1.001  5320         Apply
  1.001  5320         Mode = VoltageCalibrator
  1.001  5320         +Voltage = 240 V
  1.001  5320         @Freq = 50 Hz

Rules:

  1. One and only one parameter must be designated as the Evaluation Quantity in a 5320 Apply, Measure, Setup, or Slew statement.
  2. At most one parameter may be designated as the Modifier Quantity in a 5320 Apply, Measure, Setup, or Slew statement.
  3. Parameter values may be taken from a MET/CAL memory register using a special construction.
  4. When a 5320 Apply statement is executed, the value of the Evaluation Quantity is copied to memory register MEM1 in specified units.

    5. Example:

    1.001 5320 Mode = Volt; +Volt = 240 V; @Freq = 50Hz; Apply

    After the 5320 statement is executed the value of MEM1 is 240.

  5. When a 5320 Operate statement is executed, the value of the Evaluation Quantity designated in the previous Setup or Apply statement is copied to memory register MEM1 in specified units.

    6. Example:

      1.001 5320 Mode = Volt; +Volt = 240V; @Freq = 50Hz; Setup
  1.002 5320 Mode = Volt; +Volt = 240V; @Freq = 50Hz; Operate

    After the 5320 Operate statement is executed the value of MEM1 is 240.

  6. When a 5320 Slew statement is executed, the Evaluation Quantity designates the slew quantity.
  7. When a 5320 Slew statement is executed, the final slew value is copied to memory register MEM1 in units of the Evaluation Quantity.

    8. Example:

    1.001 5320 Mode = Volt; +Volt = 240V; @Freq = 50Hz; Slew

    Operator slews the 5320A output to 241.5 V. After the 5320 Slew statement is executed the value of MEM is 241.5.

  8. When a 5320 Slew statement is executed, the Modifier Quantity is concatenated to the Evaluation Quantity in the automatic slew message. Note, the automatic slew message is not displayed when ASK- N is in effect.

    9. Examples:

      1.001 ASK+ N
  1.002 5320 Mode = Volt; +Volt = 120V; @Freq = 60Hz; Slew

    "Adjust stimulus for a UUT reading of 120 V at 60 Hz."

    No Modifier Quantity designated.

    1.001 5320 Mode = Volt; +Volt = 120V; Freq = 60Hz; Slew

    "Adjust stimulus for a UUT reading of 120 V."

    Automatic slew message inhibited.

      1.001 ASK- N
  1.002 5320 Mode = Volt; +Volt = 120V; Freq = 60Hz; Slew

    No automatic slew message generated, use MESS FSC.

  9. When a 5320 Measure statement is executed, the 5320A measurement is copied to memory register MEM in units of the Evaluation Quantity.

    10. Example:

      1.001 5320 Mode = Meter; +Voltage = 240 V; @Freq = 50 Hz
  1.001 5320 Measure

    After the 5320 statement is executed, If the 5320A measurement was 239.5 V, MEM would be 239.5.

  10. When a 5320 Read statement is executed, the 5320A measurement is copied to memory register MEM in units of the Evaluation Quantity designated in the previous Setup or Measure statement.

    11. Example:

      1.001 5320 Mode = Meter; +Current = 20 A; @Freq = 50 Hz; Setup
  1.002 5320 Mode = Meter; +Current = 20 A; @Freq = 50 Hz; Read

    After the 5320 READ statement is executed, If the 5320A measurement was 239.5 V, MEM would be 239.5.

Parameter Names

Parameter names consist of single words or compound words. Each word in a parameter name can be entered in long form (as shown below), or in short form. The short form is the first 4 characters of the long form, with the following exceptions:

  1. If the long form is greater than four characters, and the last character or the short form is a vowel, the short form is three characters.
  2. If the long form is four characters or less, the short form is the long form even if it ends in a vowel.

Compound parameter names can be entered in any combination of long and short forms. Example, LeakageCurrent can be entered using any of the following forms:

  • LeakageCurrent
  • LeakageCurr
  • LeakCurrent
  • LeakCurr

Action Parameters

  • Apply
  • Local
  • Measure
  • Operate
  • Query
  • Read
  • Rescan
  • Reset
  • Setup
  • Standby

General Parameters

  • Current
  • Frequency
  • LeakageCurrent
  • LoadCurrent
  • LineVoltage
  • Low
  • MaximumCurrent
  • MaximumVoltage
  • Mode
  • PFC (Prospective Fault Current)
  • Power
  • Probe
  • RMultiplierInput
  • ResidualImpedance
  • ResidualImpedanceCorrection
  • Resistance
  • ResistanceMultiplierOn
  • Sense
  • SerialResistance
  • SeriesResistance
  • Short
  • TestCurrent
  • TestVoltage
  • TimeInterval
  • TransferResistance
  • TripCurrent
  • TripCurrentMultiplier
  • TripCurrentRecognitionLevel
  • TripTime
  • UUTOutputResistance
  • Voltage

Mode/Parameter Rules

If a parameter is not listed for a mode, it is not allowed.

LOW RESISTANCE

Mode = LR | LowResistance

Evaluation Quantity: Resistance > 0 Ohms

Parameter Name | Parameter Type | Default Value
+Resistance | Required | N/A
TestCurrent | Optional | N/A
TestVoltage | Optional | N/A
Low | Optional | Ground
Sense | Optional | 2-Wire
Setup | Operate | Apply | Slew | Optional | Apply

Evaluation Quantity: Resistance = 0 Ohms

Parameter Name | Parameter Type | Default Value
+Resistance | Required | N/A
Low | Optional | Ground
Short | Required | N/A
TestCurrent | Optional | N/A
TestVoltage | Optional | N/A
Setup | Operate | Apply | Optional | Apply

Evaluation Quantity: TestVoltage

Parameter Name | Parameter Type | Default Value
+TestVoltage | Required | N/A
Open | Required | N/A
Setup | Operate | Read | Required | N/A
Low | Optional | Ground
TestVoltage | Optional | N/A
Setup | Operate | Apply | Optional | Apply

Evaluation Quantity: MaximumVoltage

Parameter Name | Parameter Type | Default Value
+MaximumVoltage | Required | N/A
Low | Optional | Ground
Open | Required | N/A
Setup | Operate | Read | Required | N/A
TestCurrent | Optional | N/A
TestVoltage | Optional | N/A

HIGH RESISTANCE

Mode = HR | HighResistance

Parameter Name | Parameter Type | Default Value
+Resistance | Required | N/A
TestVoltage | Required | N/A
Setup | Operate | Apply | Slew | Optional | Apply
Low | Optional | Ground
ResistanceMultiplierOn | Optional | Off
TestCurrent | Optional | N/A

Evaluation Quantity: Resistance > 0 Ohms

Parameter Name | Parameter Type | Default Value
+Resistance = 0 Ohms | Required | N/A
Short | Required | N/A
TestVoltage | Required | N/A
Setup | Operate | Apply | Required | N/A
Low | Optional | Ground

Evaluation Quantity: TestVoltage

Parameter Name | Parameter Type | Default Value
+TestVoltage | Required | N/A
Resistance | Required | N/A
Setup | Operate | Read | Required | N/A
Low | Optional | Ground
TestCurrent | Optional | N/A
  1. Only allowed when ResistanceMultiplierOn is specified.

Evaluation Quantity: MaximumVoltage

Parameter Name | Parameter Type | Default Value
+MaximumVoltage | Required | N/A
TestCurrent | Optional | N/A
TestVoltage | Optional | N/A
Setup | Operate | Read | Optional | N/A
  1. Only allowed when ResistanceMultiplierOn is specified.

Evaluation Quantity: TestCurrent

Parameter Name | Parameter Type | Default Value
+TestCurrent | Required | N/A
Setup | Operate | Read | Required | N/A
Low | Optional | Ground
Resistance | Optional | N/A
Short | Optional | N/A
TestVoltage | Optional | N/A

Evaluation Quantity: MaximumCurrent

Parameter Name | Parameter Type | Default Value
+MaximumCurrent | Required | N/A
Short | Required | N/A
Setup | Operate | Read | Required | N/A
Low | Optional | Ground
Resistance = 0 Ohms | Optional | N/A
TestCurrent | Optional | N/A
TestVoltage | Optional | N/A

HIGH RESISTANCE FIXED

Mode = HRF | HighResistanceFixed

Evaluation Quantity: Resistance

Parameter Name | Parameter Type | Default Value
+Resistance = 100 GOhm | Required | N/A
TestVoltage | Required | N/A
Low | Optional | Ground
TestCurrent | Optional | N/A
Apply | Setup | Operate | Optional | Apply

Evaluation Quantity: TestVoltage

Parameter Name | Parameter Type | Default Value
+TestVoltage | Required | N/A
Resistance = 100 GOhm | Required | N/A
Low | Optional | Ground
TestCurrent | Optional | N/A
Apply | Setup | Operate | Optional | Apply

Evaluation Quantity: MaximumVoltage

Parameter Name | Parameter Type | Default Value
+MaximumVoltage | Required | N/A
Resistance = 100 GOhm | Required | N/A
Low | Optional | Ground
TestCurrent | Optional | N/A
TestVoltage | Optional | N/A
Apply | Setup | Operate |  | Apply

GROUND BOND RESISTANCE

Mode = GBR | GroundBondResistance

Evaluation Quantity: Resistance

Parameter Name | Parameter Type | Default Value
+Resistance | Required | N/A
TestCurrent | Optional | N/A
TestVoltage |  | N/A
Apply | Setup | Operate | Query |  | Apply

Evaluation Quantity: TestCurrent

Parameter Name | Parameter Type | Default Value
+TestCurrent | Required | N/A
Resistance | Required | N/A
Setup, Operate, Read | Required | N/A
TestVoltage | Optional | N/A

Evaluation Quantity: MaximumCurrent

Parameter Name | Parameter Type | Default Value
+MaximumCurrent | Required | N/A
Resistance | Required | N/A
Setup, Operate, Read | Required | N/A
TestCurrent | Optional | N/A
TestVoltage | Optional | N/A

Evaluation Quantity: TestVoltage

Parameter Name | Parameter Type | Default Value
+TestVoltage | Required | N/A
Open | Required | N/A
Setup, Operate, Read | Required | N/A
TestCurrent | Optional | N/A

Evaluation Quantity: MaximumVoltage

Parameter Name | Parameter Type | Default Value
+MaximumVoltage | Required | N/A
Open | Required | N/A
Setup, Operate, Read | Required | N/A
TestCurrent | Optional | N/A
TestVoltage | Optional | N/A

Ground Bond Transfer

Mode = GBTFR | GroundBondTransfer

Evaluation Quantity: TransferResistance

Parameter Name | Parameter Type | Default Value
+TransferResistance | Required | N/A
TestCurrent | Required | N/A
Resistance | Required | N/A
Setup, Operate, Read | Required | N/A

Evaluation Quantity: TestCurrent

Parameter Name | Parameter Type | Default Value
TestCurrent | Required | N/A
Resistance | Required | N/A
Setup, Operate, Read | Required | N/A

Evaluation Quantity: MaximumCurrent

Parameter Name | Parameter Type | Default Value
+MaximumCurrent | Required | N/A
Resistance | Required | N/A
Setup, Operate, Read | Required | N/A
TestCurrent | Optional | N/A

LINE IMPEDANCE, LOOP IMPEDANCE

Mode = Line | LineImpedance | Loop | LoopImpedance

Evaluation Quantity: Resistance

Parameter Name | Parameter Type | Default Value
+Resistance | Required | N/A
ResidualImpedance 1 | Required | N/A
ResidualImpedanceCorrection | Optional | Off
SerialResistance | Optional | SerialResistance
Apply | Setup | Operate | Query | Optional | Apply
  1. ResidualImpedance is only required, and can only be specified, when ResidualImpedanceCorrection is Manual.

Evaluation Quantity: TestCurrent

Parameter Name | Parameter Type | Default Value
+TestCurrent | Required | N/A
Resistance | Required | N/A
ResidualImpedance(1) | Required | N/A
Setup | Operate | Read | Required | N/A
ResidualImpedanceCorrection | Optional | Off
SerialResistance | Optional | Current value
  1. ResidualImpedance is only required, and can only be specified, when ResidualImpedanceCorrection is Manual.

Evaluation Quantity: PFC

Parameter Name | Parameter Type | Default Value
+PFC | Required | N/A
Resistance | Required | N/A
ResidualImpedance(1) | Required | N/A
Setup | Operate | Read | Required | N/A
ResidualImpedanceCorrection | Optional | Off
SerialResistance | Optional | Current value
TestVoltage | Optional | N/A
  1. ResidualImpedance is only required, and can only be specified, when ResidualImpedanceCorrection is Manual.

Rescan Action, Evaluation Quantity: NA

Parameter Name | Parameter Type | Default Value
Resistance | Required | N/A
ResidualImpedanceCorrection | Required | Scan | Comp
Rescan | Required | N/A

LEAKAGE CURRENT SUBSTITUTE

Mode = IDS | LeakageCurrentSubstitute

Parameter Name | Parameter Type | Default Value
+LeakageCurrent | Required | N/A
UUTOutputResistance | Required | N/A
Apply | Setup | Operate | Optional | Apply

LEAKAGE CURRENT PASSIVE, LEAKAGE CURRENT DIFFERENTIAL

Mode = IDP | LeakageCurrentPassive | IDD | LeakageCurrentDifferential

Parameter Name | Parameter Type | Default Value
+LeakageCurrent | Required | N/A
Setup | Operate | Read | Required | N/A

LEAKAGE CURRENT ACTIVE

Mode = IDA | LeakageCurrentActive

Parameter Name | Parameter Type | Default Value
+LeakageCurrent | Required | N/A
Setup | Operate | Required | N/A

RCD TRIP TIME

Mode = RCDT | RCDTripTime

Evaluation Quantity: TripTime

Parameter Name | Parameter Type | Default Value
+TripTime | Required | N/A
Setup | Operate | Query | Required | N/A
SeriesResistance | Optional | R01 (0.025 Ohms)
TripCurrent | Optional | N/A
TripCurrentMultiplier | Optional | 1
TripCurrentRecognitionLevel | Optional | 90 %

Evaluation Quantity: TripCurrent

Parameter Name | Parameter Type | Default Value
+TripCurrent | Required | N/A
Setup | Operate | Read | Required | N/A
SeriesResistance | Optional | R01 (0.025 Ohms)
TripCurrentMultiplier | Optional | 1
TripCurrentRecognitionLevel | Optional | 90 %
TripTime | Optional | N/A

Evaluation Quantity: LineVoltage

Parameter Name | Parameter Type | Default Value
+LineVoltage | Required | N/A
Setup | Operate | Read | Required | N/A
SeriesResistance | Optional | R01 (0.025 Ohms)
TripCurrentMultiplier | Optional | 1
TripCurrentRecognitionLevel | Optional | 90 %
TripTime | Optional | N/A

Evaluation Quantity: SeriesResistance

Parameter Name | Parameter Type | Default Value
+SeriesResistance | Required | N/A
Setup | Operate | Required | N/A
TripCurrentMultiplier | Optional | 1
TripCurrentRecognitionLevel | Optional | 90 %
TripTime | Optional | N/A

RCD TRIP CURRENT

Mode = RCDC | RCDTripCurrent

Evaluation Quantity: TripCurrent

Parameter Name | Parameter Type | Default Value
+TripCurrent | Required | N/A
Setup | Operate | Read | Required | N/A
SeriesResistance | Optional | R01 (0.025 Ohms)

Evaluation Quantity: MaximumCurrent

Parameter Name | Parameter Type | Default Value
+MaximumCurrent | Required | N/A
Setup | Operate | Read | Required | N/A
SeriesResistance | Optional | R01 (0.025 Ohms)
TripCurrent | Optional | N/A

Evaluation Quantity: LineVoltage

Parameter Name | Parameter Type | Default Value
+LineVoltage | Required | N/A
Setup | Operate | Read | Required | N/A
SeriesResistance | Optional | R01 (0.025 Ohms)
TripCurrent | Optional | N/A

Evaluation Quantity: SeriesResistance

Parameter Name | Parameter Type | Default Value
+SeriesResistance | Required | N/A
Setup | Operate | Required | N/A
TripCurrent | Optional | N/A

VOLTAGE CALIBRATOR

Mode = Volt | VoltageCalibrator

Evaluation Quantity: Voltage

Parameter Name | Parameter Type | Default Value
+Voltage | Required | N/A
Frequency | Optional | N/A
LoadCurrent | Optional | N/A
Low | Optional | Ground
Evaluation Quantity | Optional | Frequency

Evaluation Quantity: Frequency

Parameter Name | Parameter Type | Default Value
+Frequency | Required | N/A
Voltage | Optional | N/A
LoadCurrent | Optional | N/A
Low | Optional | Ground

Evaluation Quantity: LoadCurrent

Parameter Name | Parameter Type | Default Value
+LoadCurrent | Required | N/A
Voltage | Required | N/A
Measure | Setup | Read | Optional | N/A
Frequency | Optional | N/A
Low | Optional | Ground

MULTIMETER

Mode = Meter | Multimeter

Evaluation Quantity: Current

Parameter Name | Parameter Type | Default Value
+Current | Required | N/A
Measure | Setup | Read | Optional | N/A
Frequency | Optional | N/A
Probe | Optional | N/A

Evaluation Quantity: Voltage

Parameter Name | Parameter Type | Default Value
+Voltage | Required | N/A
Measure | Setup | Read | Required | N/A
Frequency | Optional | N/A
Probe | Optional | N/A

Evaluation Quantity: Power

Parameter Name | Parameter Type | Default Value
+Power | Required | N/A
Measure | Setup | Read | Required | N/A
Frequency | Optional | N/A
Probe | Optional | N/A

HIPOT LEAKAGE CURRENT

Mode = HIPL | HipotLeakageCurrent

Evaluation Quantity: LeakageCurrent

Parameter Name | Parameter Type | Default Value
+LeakageCurrent | Required | N/A
Measure | Setup | Read | Required | N/A
Frequency | Optional | N/A
Probe | Optional | N/A
TestVoltage | Optional | N/A

Evaluation Quantity: TestVoltage

Parameter Name | Parameter Type | Default Value
+TestVoltage | Required | N/A
Measure | Setup | Read | Required | N/A
Frequency | Optional | N/A
Probe | Optional | N/A

HIPOT TIMER

Mode = HIPT | HipotTimer

Evaluation Quantity: TimeInterval

Parameter Name | Parameter Type | Default Value
+TimeInterval | Required | N/A
Measure | Setup | Read | Required | N/A
Frequency | Optional | N/A
TestVoltage | Optional | N/A

Evaluation Quantity: TestVoltage

Parameter Name | Parameter Type | Default Value
+TestVoltage | Required | N/A
Measure | Setup | Read | Required | N/A
Frequency | Optional | N/A

Evaluation Quantity: MaximumVoltage

Parameter Name | Parameter Type | Default Value
+MaximumVoltage | Required | N/A
Measure | Setup | Read | Required | N/A
Frequency | Optional | N/A
TestVoltage |  |

Parameter Definitions and Values

Apply

This action sets up the instrument and enables the output.

Syntax:

Apply

Rules:

  1. When Apply is specified, no other action may be specified.

Examples:

Apply

Current

This parameter specifies one of the measured value of current for Multimeter mode.

Syntax:

[+]Current[sp]=[sp]numeric value[sp][prefix]A

Rules:

  1. Legal values are: 0 to 30 A
  2. When this parameter is specified, it must be designated as the Evaluation Quantity.

Examples:

Current = 2.5 A

Frequency

This parameter specifies the following:

Mode: VoltageCalibrator
Output frequency
Mode: Multimeter
Input signal frequency

Syntax:

[@]Frequency[sp]=[sp]numeric value[sp][prefix]Hz

Rules:

When this parameter is specified, AC mode is enabled.

Mode: VoltageCalibrator
Legal values are: 40 to 400 Hz
Mode: Multimeter
Legal values are: 0 to 2 kHz

Examples:

@Freq = 50 Hz

LeakageCurrent

This parameter specifies the leakage current.

Syntax:

Nominal Leakage Current

+LeakageCurrent[sp]=[sp]numeric value[sp][prefix]A

Rules:

  1. Legal values are: 0.1 to 30 mA
  2. When this parameter is specified, it must be designated as the Evaluation Quantity.

Examples:

LeakageCurrent = 10 mA

LineVoltage

This parameter specifies the measured line voltage.

Syntax:

+LineVoltage[sp]=[sp]numeric value[sp][prefix]V

Rules:

  1. Range of legal values is 110 to 240 V.

Examples:

+LineVoltage = 240 V

LoadCurrent

This parameter specifies the expected load (burden) current.

Syntax:

[+]LoadCurrent[sp]=[sp]numeric value[sp][prefix]A

Rules:

  1. Range of legal values is based on the mode (VAC or VDC) and output voltage range.

Examples:

+LoadCurrent = 10 mA

Local

This action puts the 5320A in local mode.

Syntax:

Local

Rules:

  1. When Local is specified, no other parameters may be specified.

Examples:

Local

Low

This parameter connects or disconnects the Lo terminal to/from GND terminal.

Syntax:

Low[sp]=[sp]value

value ::= Float | Ground

Examples:

Low = Float

MaximumCurrent

This parameter specifies the measured maximum test current.

Syntax:

+MaximumCurrent[sp]=[sp]numeric value[sp][prefix]A

Rules:

  1. Range of legal values is based on the selected resistance.

Examples:

+MaxCurrent = 10 mA

MaximumVoltage

This parameter specifies the measured maximum test voltage.

Syntax:

+MaximumVoltage[sp]=[sp]numeric value[sp][prefix]V

Rules:

  1. Range of legal values is based on the selected resistance.

Examples:

+MaxVoltage = 1000 V

Measure

This action sets up multimeter mode and and returns the measurement designated by the Evaluation Quantity.

Syntax:

Measure

Rules:

  1. When Measure is specified, no other action may be specified.

Examples:

Measure

Mode

This parameter selects the instrument mode.

Syntax:

Mode[sp]=[sp]value

where value ::=

GBR | GroundBondResistance
GBTFR | GroundBondTransfer
LR | LowResistance
HR | HighResistance
HRF | HighResistanceFixed
IDP | LeakageCurrentPassive
IDS | LeakageCurrentSubstitute
IDD | LeakageCurrentDifferential
IDA | LeakageCurrentActive
RCDT | RCDTripTime
RCDC | RCDTripCurrent
Line | LineImpedance
Loop | LoopImpedance
Volt | VoltageCalibrator
Meter | Multimeter

Examples:

Mode = GBR

Operate

This parameter turns the output on.

Syntax:

Operate

Rules:

  1. When Operate is specified, no other parameters are allowed.

Examples:

Operate

PFC

This parameter specifies the expected Prospective Fault Current.

Syntax:

+PFC[sp]=[sp]numeric value[sp][prefix]A

Rules:

  1. Legal values are: 0 A to 10 kA
  2. When this parameter is specified, it must be designated as the Evaluation Quantity.

Examples:

+PFC = 100 mA

Power

This parameter specifies the expected Phantom Power.

Syntax:

+Power[sp]=[sp]numeric value[sp][prefix]VA

Rules:

  1. Legal values are: 0 to 33 kVA
  2. When this parameter is specified, it must be designated as the Evaluation Quantity.

Examples:

+Power = 10 kVA

Probe

This parameter selects the 1000:1 Divider or 40 kV high voltage probe.

Syntax:

Probe[sp]=[sp]numeric value[sp][prefix]V

Rules:

  1. Legal values are 10kV and 40kV.

Examples:

Probe = 40 kV

Query

This returns the "true" value designated by the Evaluation Quantity.

Syntax:

Query

Rules:

  1. When Query is specified, no other parameters are allowed.

Examples:

Query

RMultiplierInput

This parameter specifies the input resistance of UUT sense terminal, when the R multiplier option is applied.

Syntax:

RMultiplierInput[sp]=[sp]numeric value[sp][prefix]Ohm[s]

Rules:

  1. Legal values are: 0 Ohms and 0.01 to 100 MOhm. Default is 0 Ohms
  2. RMultiplierInput is only allowed with ResistanceMultiplierOn.

Examples:

RMultiplierInput = 10 MOhm; ResistanceMultiplierOn

Read

This returns the measurement designated by the Evaluation Quantity.

Syntax:

Read

Rules:

  1. When Read is specified, no other parameters are allowed.

Examples:

Read

Reset

This parameter resets the instrument.

Syntax:

Reset

Rules:

  1. When Reset is specified, no other parameters are allowed.

Examples:

Reset

ResidualImpedance

This parameter specifies the manually entered residual impedance for line and loop impedance modes.

Syntax:

ResidualImpedance[sp]=[sp]numeric value[sp][prefix]Ohm[s]

Rules:

  1. Legal values are:0 to 20 Ohms
  2. ResidualImpedance is only allowed when ResidualImpedanceCorrection = Man or Manual.

Examples:

ResidualImpedance = 0.87 Ohm

ResidualImpedanceCorrection

This parameter specifies the type of residual impedance correction for Line Impedance mode.

Syntax:

ResidualImpedanceCorrection[sp]=[sp]value

value ::=

Man | Manual

Scan | Scanned (Requires 5320A/VLC)

Comp | Compensated

Rules:

  1. When ResidualImpedanceCorrection is not specified, correction is turned off.
  2. ResidualImpedanceCorrection = Compensated requires 5320A/VLC.

Examples:

ResidualImpedanceCorrection = Manual

Resistance

This parameter specifies the nominal resistance.

Syntax:

Resistance[sp]=[sp]numeric value[sp][prefix]Ohm[s]

Rules:

  1. Legal values depend on the operating mode (see 5320A specifications).

Examples:

Resistance = 100 mOhm

ResistanceMultiplierOn

This parameter turns on the resistance multiplier.

Syntax:

ResistanceMultiplierOn

Examples:

ResMultOn

  1.001  5320         Mode = HighResistance; ResistanceMultiplierOn
  1.001  5320         +Resistance = 50 GOhm; TestVolt = 250 V

Sense

This parameter selects 4-wire High Resistance

Syntax:

Sense[sp]=[sp]value

value ::= 2W | 4W | 2-Wire | 4-Wire

Examples:

Sense = 4-Wire

SerialResistance

This parameter specifies the Line/Loop Impedance serial resistance.

Syntax:

SerialResistance[sp]=[sp]value

value ::= numeric value[sp][prefix]Ohm[s]

Rules:

  1. Legal values are: 0.000 Ohms to 2.000 Ohm.
  2. If this parameter is not specified, the existing serial resistance is used.
  3. The only short form of this parameter is "SerialRes". "SerRes" is a short form of "SeriesResistance".

Examples:

SerialResistance = 0.27 Ohms

SeriesResistance

This parameter specifies the RCD series resistance.

Syntax:

[+]SeriesResistance[sp]=[sp]value

value ::= numeric value[sp][prefix]Ohm[s]

Rules:

  1. Legal values are:
    1. 25 mΩ (R01)
    2. 50 mΩ (R02)
    3. 100 mΩ (R03)
    4. 330 mΩ (R04)
    5. 500 mΩ (R05)
    6. 1.0 Ω (R06)
    7. 1.8 Ω (R07)
    8. 5.0 Ω (R08)
    9. 10 Ω (R09)
    10. 18 Ω (R10)
    11. 50 Ω (R11)
    12. 100 Ω (R12)
    13. 180 Ω (R13)
    14. 500 Ω (R14)
    15. 1000 Ω (R15)
    16. 1800 Ω (R16)
  2. If this parameter is not specified, the default is 25 mOhms (R01).

Examples:

SeriesResistance = 100 mΩ

Setup

This action causes the instrument to be setup only.

Mode: Multimeter
No reading is returned.
Mode: All other modes
The instrument remains in standby.

Syntax:

Setup

Rules:

  1. When Setup is specified, no other action may be specified.

Examples:

Setup

Short

This action selects the High or Low Resistance short.

Syntax:

Short

Examples:

Short

Slew

This action sets up the intrument and enables the output. Slewing is then enabled for the parameter designated as the Evaluation Quantity (i.e. + prefix).

Syntax:

Slew

Rules:

  1. When Slew is specified, no other action may be specified.

Examples:

Slew

Standby

This action selects standby (output disabled).

Syntax:

Standby

Rules:

  1. When Standby is specified, no other parameters are allowed.

Examples:

Standby

TestCurrent

This parameter specifies one of the following:

  • Expected test current, when Resistance is the specified evaluation quantity.
  • Measured test current, when TestCurrent is the specified evaluation quantity.

Syntax:

[+]TestCurrent[sp]=[sp]numeric value[sp][prefix]A

Rules:

  1. Range of legal values is based on the selected resistance.

Examples:

TestCurrent = 10 mA

TestVoltage

This parameter specifies one of the following:

  • Expected test voltage, when Resistance is the specified evaluation quantity.
  • Measured test voltage, when TestVoltage is the specified evaluation quantity.

Syntax:

[+]TestVoltage[sp]=[sp]numeric value[sp][prefix]V

Rules:

  1. Range of legal values is based on the selected resistance.

Examples:

TestVoltage = 240 V

TimeInterval

This parameter specifies the measured time interval in HIPOT Timer mode.

Syntax:

+TimeInterval[sp]=[sp]numeric value[sp][prefix]s

Rules:

  1. Range of legal values is 0.1 to 999 s.

Examples:

+TimeInterval = 10 s

TransferResistance

This parameter specifies the expected transfer resistance.

Syntax:

+TransferResistance[sp]=[sp]numeric value[sp][prefix]Ohm[s]

Rules:

  1. Legal values are 0 to 1 Ohm.

Examples:

TransferResistance = 100 mOhm

TripCurrent

This parameter specifies the nominal trip current.

Syntax:

+TripCurrent[sp]=[sp]numeric value[sp][prefix]A

Rules:

  1. When this parameter is specified, it must be designated as the Evaluation Quantity (i.e. +TripCurrent).
    2. Mode: RCD Trip Current
    Legal values are 10, 20, 30, 50, 100, 200, 300, 500 ms, 1, 2, & 3 A.
    Mode: RCD Trip Time
    Legal values are 10 mA to 3 A.

Examples:

+TripCurrent = 100 mA

TripCurrentMultiplier

This parameter specifies the muliplier of nominal trip current terminal.

Syntax:

TripCurrentMultiplier[sp]=[sp]value

value ::= 0.5 | 1 | 1.4 | 2 | 5

Rules:

  1. If this parameter is not specified, the default is 1.

Examples:

Multiplier = 2

TripCurrentRecognitionLevel

This parameter specifies the percentage level of recognition that trip current has reached nominal trip current level.

Syntax:

TripCurrentRecognitionLevel[sp]=[sp]value[sp]%

value ::= 5 | 30 | 60 | 75 | 90 | 100 | 120

Rules:

  1. If this parameter is not specified, the default is 90 %.

Examples:

TripCurrRecLevel = 75 %

TripTime

This parameter specifies the trip time for RCD Trip Time mode.

Syntax:

TripTime[sp]=[sp]numeric value[sp][prefix]s

Rules:

  1. Legal values are: 10, 20, 30, 50, 100, 200, 300, 500 ms, 1, 2, 3, & 5 s.

Examples:

TripTime = 50 ms

UUTOutputResistance

This parameter specifies the UUT output resistance for Leakage Current Substitute mode.

Syntax:

UUTOutputResistance[sp]=[sp]numeric value[prefix]Ohm[s]

Rules:

  1. Legal values are: 0 Ohms to 10 kOhms
  2. If this parameter is not specified, the default is 2000 Ohms.

Examples:

UUTOutputRes = 1000 Ohms

Voltage

This parameter specifies the following:

Mode: GBR, HR, HRF, Line, & Loop
Expected voltage applied to the selected resistance.
Mode: VoltageCalibrator
Output voltage
Mode: Multimeter
Expected voltage reading

Syntax:

Mode: GBR, LR, HR, HRF, Line, & Loop
Voltage[sp]=[sp]numeric value[sp][prefix]V
Mode: VoltageCalibrator & Multimeter
+Voltage[sp]=[sp]numeric value[sp][prefix]V

Rules:

Mode: GBR, HR, HRF, Line, & Loop
Maximum voltage is based on selected resistance.
Mode: VoltageCalibrator
Legal values are: 3 to 600 V
When this parameter is specified, it must be designated as the Evaluation Quantity (i.e. +Voltage).
Mode: Multimeter
Legal values are: 0 to 1100 V
When this parameter is specified, it must be designated as the Evaluation Quantity (i.e. +Voltage).

Examples:

+Voltage = 240 V

Voltage

This parameter specifies one of the following:

  • Expected current flowing through the selected resistance, when Resistance is the specified evaluation quantity for GBR, LR, HR, HRF, Line, or Loop mode.
  • Measured current flowing through the selected resistance, when Current is the specified evaluation quantity for GBR, LR, Line, or Loop mode.
  • Measured value of current for Multimeter mode.

Syntax:

[+]Current[sp]=[sp]numeric value[sp][prefix]A

Rules:

Mode: GBR, LR, HR, HRF, Line, & Loop
Range of legal values is based on the selected resistance.
Mode: Multimeter
Legal values are: 0 to 30 A
When this parameter is specified, it must be designated as the Evaluation Quantity.

Examples:

Current = 2.5 A

Examples

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
# -----Reset -----
  1.002  5320         Reset
# -----Standby -----
  1.003  5320         Standby
# ===== Multifunction Testers (Ex. Fluke 1651/1652/1653) =====
# ----- Voltage Calibrator -----
  1.004  DISP         Turn UUT rotary function switch to VOLTS (V).
  1.005  5320         +Voltage = 25.0 V; Freq = 50 Hz
  1.006  TARGET       -m
  1.007  MEMI         Enter UUT reading in volts:
  1.008  MEMCX  500   25.0V          0.8% 0.3U     50Hz
# ----- High Resistance -----
  2.001  DISP         Turn UUT rotary function switch to INSULATION (Riso).
  2.002  5320         Mode = HR; +Resistance = 2.50 MOhm; TestVolt = 1 kV
  2.003  TARGET       -m
  2.004  DISP         Press and hold the UUT TEST button.
  2.004  DISP
  2.004  DISP         UUT will initially beep.
  2.004  DISP         Release TEST button after
  2.004  DISP         UUT beeps a second time.
  2.005  MEMI         Enter UUT reading in megohms:
  2.006  MEMCX  50    MZ             3% 0.03U
# ----- Low Resistance -----
  3.001  DISP         Turn UUT rotary function switch to CONTINUITY (Rlo).
  3.002  5320         Mode = LR; +Resistance = 18.00 Ohms
  3.003  TARGET       -m
  3.004  DISP         Press and hold TEST button until reading updates.
  3.005  MEMI         Enter UUT reading in ohms:
  3.006  MEMCX  20    Z              1.5% 0.03U
# ----- Loop Impedance -----
  4.001  DISP         Turn UUT rotary function switch to LOOP (Zi).
  4.002  MEMI         Enter serial resistance (0.000 to 2.000 Ohms):
  4.003  5320         Mode = Loop; +Res = 1.80 Ohms; SerialRes = [MEM] Ohms
  4.003  5320         ResidualImpedanceCorrection = Compensated
  4.004  TARGET       -m
  4.005  DISP         Press and release the TEST button.
  4.005  DISP
  4.005  DISP         Wait until the TEST annunciator is no longer displayed.
  4.006  MEMI         Enter UUT reading in ohms:
  4.007  MEMCX  20    Z              3% 0.10U
  5.001  ASK-         N
# ----- RCDT (Trip Current) -----
  5.002  TSET         MEAS = SA; TDESC = 10mA x½ ~
# Get 5320A RCD current accuracy at 10 mA, x ½ multiplier and convert to
# percent.
  5.003  MATH         Name = "Fluke 5320A"
  5.004  MATH         Acc = ACCV2("Fluke 5320A", "Amps RCD Mult", 10E-3, 0.5)
  5.005  MATH         L[1] = (Acc / 10E-3) * 100
  5.006  TARGET       -p
  5.007  DISP         Turn UUT rotary function switch to RCD TIME (delta T).
  5.008  5320         Mode = RCDT; +TripCurrent = 10 mA; TripTime = 300 ms
  5.008  5320         TripCurrentMultiplier = 0.5; Setup
  5.009  DISP         Press F1 until 10 mA is displayed in the upper
  5.009  DISP         left-hand corner of the display.
  5.009  DISP
  5.009  DISP         Press F2 until x1/2 is displayed.
  5.009  DISP
  5.009  DISP         Press F3 until sinusoidal symbol is displayed.
  5.009  DISP
  5.009  DISP         Press F4 until 0° is displayed in the lower
  5.009  DISP         left-hand corner of the display.
  5.010  TARGET       -m
  5.011  5320         Mode = RCDT; +TripCurrent = 10 mA; TripTime = 300 ms
  5.011  5320         TripCurrentMultiplier = 0.5; Operate
  5.012  DISP         Press and release the TEST button.
  5.012  DISP
  5.012  DISP         Select Advance when TEST annunciator is no longer
  5.013  5320         Mode = RCDT; +TripCurrent = 10 mA; TripTime = 300 ms
  5.013  5320         TripCurrentMultiplier = 0.5; Read
  5.014  ACC    5.00  mA             L1%
  5.015  MEMC   1000  5.00mA         +10%
  6.001  TSET         MEAS = SA; TDESC = 30mA x1 ~
  6.002  TARGET       -p
  6.003  5320         Mode = RCDT; +TripCurrent = 30 mA; TripTime = 300 ms
  6.003  5320         TripCurrentMultiplier = 1; Setup
  6.004  DISP         Press F1 until 30 mA is displayed in the upper
  6.004  DISP         left-hand corner of the display.
  6.004  DISP
  6.004  DISP         Press F2 until x1 is displayed.
# Multiplier is x1. No ACC statement necessary.
  6.005  TARGET       -m
  6.006  5320         Mode = RCDT; +TripCurrent = 30 mA; TripTime = 300 ms
  6.006  5320         TripCurrentMultiplier = 1; Operate
  6.007  DISP         Press and release the TEST button.
  6.007  DISP
  6.007  DISP         Select Advance when TEST annunciator is no longer
  6.008  5320         Mode = RCDT; +TripCurrent = 30 mA; TripTime = 300 ms
  6.008  5320         TripCurrentMultiplier = 1; Read
  6.009  MEMC   1000  30.0mA         -10%
# ----- RCDT (Trip Time) -----
  7.001  5320         Mode = RCDT; TripCurrent = 30 mA; +TripTime = 30.0 ms
  7.001  5320         TripCurrentMultiplier = 1; Setup
  7.002  DISP         Press F1 until 30 mA is displayed in the upper
  7.002  DISP         left-hand corner of the display.
  7.003  TARGET       -m
  7.004  5320         Mode = RCDT; TripCurrent = 30 mA; +TripTime = 30.0 ms
  7.004  5320         TripCurrentMultiplier = 1; Operate
  7.005  DISP         Press and release the TEST button.
  7.006  5320         Standby
  7.007  MEMI         Enter UUT reading in milliseconds:
  7.008  MEMCX  100   30.0ms         1% 1.0U
# ===== Portable Appliance Tester (PAT) (Ex. Fluke 6200/6500) =====
# ----- GBR (Ground Bond Resistance) -----
  8.001  5320         Mode = GBR; +Resistance = 0.10 Ohm
  8.002  TARGET       -m
  8.003  DISP         Press BOND 200 mA.
  8.004  WAIT         -t 5 Waiting for measurement to complete...
  8.005  MEMI         Enter UUT reading in ohms:
  8.006  MEMCX        Z              2.5% 0.04U
# ----- Leakage Current Substitute -----
  9.001  5320         Mode = IDS; +LeakageCurrent = 0.25 mA
  9.001  5320         UUTOutputResistance = 2000 Ohms
  9.002  TARGET       -m
  9.003  DISP         Press I SUB.
  9.004  WAIT         -t 7 Waiting for UUT measurement to complete...
  9.005  MEMI         Enter UUT reading in milliamps:
  9.006  MEMCX        0.25mA         2.5% 0.03U
# ----- Leakage Current Passive -----
 10.001  TARGET       -p
 10.002  5320         Mode = IDP; +LeakageCurrent = 1.50 mA; Setup
 10.003  5320         Mode = IDP; +LeakageCurrent = 1.50 mA; Operate
 10.004  TARGET       -m
 10.005  DISP         Press I TOUCH and release (two fast beeps).
 10.005  DISP
 10.005  DISP         Press and hold I TOUCH, release after two beeps.
 10.005  DISP
 10.005  DISP         Release I TOUCH immediately after the second beep.
 10.006  WAIT         -t 5 Waiting for readings...
 10.007  5320         Mode = IDP; +LeakageCurrent = 1.50 mA; Read
 10.008  MATH         MEM1 = MEM
 10.009  MEMI         Enter UUT reading in milliamps:
 10.010  MEMCX        mA             4% 0.04U
# ----- Leakage Current Differential -----
 11.001  TARGET       -p
 11.002  5320         Mode = IDD; +LeakageCurrent = 0.25 mA; Setup
 11.003  5320         Mode = IDD; +LeakageCurrent = 0.25 mA; Operate
 11.004  TARGET       -m
 11.005  DISP         Press LOAD/LEAK and release (two fast beeps).
 11.005  DISP
 11.005  DISP         Press LOAD/LEAK again and hold for two beeps.
 11.005  DISP
 11.005  DISP         Select Advance now!
 11.006  WAIT         -t 5 Waiting for readings...
 11.007  5320         Mode = IDD; +LeakageCurrent = 0.25 mA; Read
 11.008  MATH         MEM1 = MEM
 11.009  MEMI         Enter UUT reading in milliamps:
 11.010  MEMCX        mA             4% 0.04U
# ----- Leakage Current Active -----
 12.001  5320         Mode = IDA; +LeakageCurrent = 0.25 mA
 12.002  TARGET       -m
 12.003  DISP         Press I SUB.
 12.004  WAIT         -t 7 Waiting for UUT measurement to complete...
 12.005  MEMI         Enter UUT reading in milliamps:
 12.006  MEMCX        0.25mA         2.5% 0.03U
# ----- Multimeter (Current Measurement) -----
 13.001  TARGET       -p
 13.002  5320         Mode = Meter; +Current = 0.3 A; Setup
 13.003  TARGET       -m
 13.004  DISP         Press LOAD/LEAK key for 3 s to initiate continuous mode.
 13.005  WAIT         -t 5 Waiting for power resistor to warmup...
 13.006  5320         Mode = Meter; +Current = 0.3 A; Read
 13.007  MATH         MEM1 = MEM
 13.008  DISP         Press STOP.
 13.009  MEMI         Enter UUT reading in amps:
 13.010  MEMCX        A              4% 0.2U
# ===== HIPOT (Ex. Quadtech Sentry 10) =====
# ----- HIPOT Leakage Current -----
 14.001  TSET         CPT = 5.00 mA; MEAS = SA
 14.002  TARGET       -p
 14.003  DISP         Connect Quadtech Sentry 10 and to the 5320A-LOAD and
 14.003  DISP         5320A as follows:
 14.003  DISP
 14.003  DISP         [32] 5320A METER INPUT A <===> Sentry 10 RTN/LOW
 14.003  DISP         [32] 5320A METER INPUT COM <=> 5320A-LOAD COM
 14.003  DISP         [32] 5320A METER INPUT V <===> 5320A-LOAD 40 mA/100 kOhm
 14.003  DISP
 14.003  DISP         [32] Sentry 10 OUTPUT <======> 5320A-LOAD 40 mA/100 kOhm
 14.003  DISP         [32] using a clip lead to single banana adapter.
 14.004  DISP         Press F1 (PROGRAM).
 14.004  DISP
 14.004  DISP         Press F3 (NEXT) to highlight mode.
 14.004  DISP         Press F1 (INC.) or F2 (DEC.) to select "AC" mode.
 14.004  DISP
 14.004  DISP         Press F3 (NEXT) to highlight VOLT value.
 14.004  DISP         Press F1 (INC.) or F2 (DEC.) to select VOLT :0.500kV
 14.004  DISP
 14.004  DISP         Press F3 (NEXT) to highlight HIGH value.
 14.004  DISP         Press F1 (INC.) or F2 (DEC.) to select HIGH :10.00mA
 14.004  DISP
 14.004  DISP         Press F3 (NEXT) to highlight TIME value.
 14.004  DISP         Press F1 (INC.) or F2 (DEC.) to select TIME : 5.0s
 14.004  DISP
 14.004  DISP         Press F4 (EXIT).
 14.005  5320         Mode = HIPL; TestVolt = 500 V; Freq = 60 Hz; Setup
 14.005  5320         +LeakageCurrent = 5.00 mA
 14.006  TARGET       -m
 14.007  DISP         Press START and then select Advance immediately.
 14.008  MATH         SAFEON("UUT", "1000V", "Sine")
 14.009  WAIT         -t 4 Settling...
 14.010  5320         Mode = HIPL; TestVolt = 500 V; Freq = 60 Hz; Read
 14.010  5320         +LeakageCurrent = 5.00 mA
 14.011  MATH         SysActual = MEM
 14.012  WAIT         [D1000]
 14.013  MEMI         Enter UUT reading in milliamps:
 14.014  MATH         SAFEOFF("UUT")
 14.015  MATH         MEM1 = MEM; MEM = SysActual
 14.016  MEMC   20    mA             1.5% 0.05U
 15.001  5320         Mode = HIPL; +TestVolt = 0.500 kV; Freq = 60 Hz; Setup
 15.002  TARGET       -m
 15.003  DISP         Press START and then select Advance immediately.
 15.004  MATH         SAFEON("UUT", "1000V", "Sine")
 15.005  WAIT         -t 4 Settling...
 15.006  5320         Mode = HIPL; +TestVolt = 0.500 kV; Freq = 60 Hz; Read
 15.007  WAIT         [D1000]
 15.008  MEMC         0.500kV        0.100U
# ----- HIPOT Timer -----
 16.001  TARGET       -p
 16.002  5320         Mode = HIPT; TestVolt = 500 V; Freq = 60 Hz; Setup
 16.002  5320         +TimeInterval = 5.0 s
 16.003  TARGET       -m
 16.004  DISP         Press START and then select Advance immediately.
 16.005  MATH         SAFEON("UUT", "1000V", "Sine")
 16.006  WAIT         -t 5 Settling...
 16.007  5320         Mode = HIPT; TestVolt = 500 V; Freq = 60 Hz; Read
 16.007  5320         +TimeInterval = 5.0 s
 16.008  MATH         SAFEOFF("UUT")
 16.009  MEMC         5.0s           1.0U
# ===== HIPOT (Ex. Slaughter 4320) =====
# ----- Ground Bond Transfer -----
 17.001  TSET         MEAS = SA
 17.002  5320         Mode = GBTFR; Res = 52 mOhms; TestCurr = 10 A
 17.002  5320         +TranRes = 52 mOhms; Setup
 17.003  DISP         Connect the 5320A TRANSFER LOAD ADAPTER to the 5320A.
 17.004  DISP         Disconnect the leads at the 5320A and short together.
 17.005  DISP         Press SET four times.
 17.005  DISP         Press "v" or "^" to select "Current = 10.0A".
 17.005  DISP
 17.005  DISP         Press SET.
 17.005  DISP         Press "v" or "^" to select "HI-Limit = 510mOhm".
 17.005  DISP
 17.005  DISP         Press SET three times.
 17.005  DISP         Press TEST to measure the lead offset.
 17.005  DISP
 17.005  DISP         Press EXIT.
 17.006  DISP         Connect the UUT to the 5320A TRANSFER LOAD ADAPTER as
 17.006  DISP         follows:
 17.006  DISP
 17.006  DISP         [32]  UUT  LOAD ADAPTER
 17.006  DISP         [32] CURRENT <============> 50 mOhm (green)
 17.006  DISP         [32] RETURN <============> COM
 17.007  5320         Mode = GBTFR; Res = 52 mOhms; TestCurr = 10 A
 17.007  5320         +TranRes = 52 mOhms; Operate
 17.008  TARGET       -m
 17.009  DISP         Press TEST and then select Advance immediately.
 17.010  WAIT         -t 5 Settling...
 17.011  MEMI         Wait until UUT measurement test cycle completes.
 17.011  MEMI
 17.011  MEMI         Enter UUT reading in milliohms:
 17.012  MATH         MEM1 = MEM
 17.013  5320         Mode = GBTFR; Res = 52 mOhms; TestCurr = 10 A
 17.013  5320         +TranRes = 52 mOhms; Read
 17.014  MEMC   1000  mZ             2% 2U         10A
 18.001  5320         Standby


5440

Instrument FSC

Description

The 5440 FSC programs the Fluke 5440B or 5442A DC Calibrator to output DC Voltage or DC Current from a Fluke 5220A Transconductance Amplifier controlled by a 5440B or 5442A.

When the 5440 FSC is used to control a 5442A, you must configure the instrument as a “Fluke 5440B” as shown in the drop-down list in the “Add Instrument” configure dialog.

Functional Capability

Function | Nominal
DC Voltage | -1100 V to 1100 V
DC Current | +/-(0.1m A to 20 A) with 5220A

Parameters

RANGE

This field specifies the UUT range as described in the RANGE Field topic.

NOMINAL

This field specifies the voltage, current, or reset.

  • Voltage entered as: [numeric][prefix]V
  • Current entered as: [numeric][prefix]A
  • Reset entered as *.

TOLERANCE

This field specifies the UUT tolerance as described in the TOLERANCE Field topic.

MOD1

This field is not used.

MOD2

This field allows you to specify the divider override feature of the calibration system. This selection is specified by entering the character “O”. This selection is only available when the divider output can be active (between -2.2 V and +2.2 V.)

The internal divider allows the user to achieve higher levels of calibration accuracy in most circumstances; therefore, the use of the divider is always automatically selected, where it is applicable. Reasons to override the use of the divider is the following:

  • The high burden property of the UUT requires divider override to maintain calibration accuracy. The output impedance of the 5440B is 50 ohms for programmed voltages below 2.2 V. Substantial errors could be introduced in the calibration of high burden meters as a result of this output impedance.
  • The resolution and accuracy of the 2.2 V range is adequate for the requirement. Operator time may be saved by not having to change connections from the normal output of the calibrator to the divided output (and back again at some later time).

MOD3

This field specifies the guard connection.

G | External guard connection is active
blank | Guard is internally shorted to low.

The guard active mode is appropriate for low level voltages where noise could affect the response of the unit under test.

MOD4

This field specifies the type of test being performed as described in the MOD4 Field topic.

CON

This field specifies the UUT connection.

2W | 2-wire
4W | 4-wire

Rules:

  1. 2W is automatically inserted in the CON field when no CON field parameter is entered.
  2. 4W is not applicable in the following situations:
    1. -2.2 V to 2.2 V unless divider override is specified (MOD2 is O).
    2. Current output from the 5220A.

Use of Standard Memory Locations and Results Reporting

System memory locations MEM and MEM1 are used. For more information, refer to the Use of Standard Memory Registers topic.

Examples

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
# -----  Reset  -----
  1.001  5440         *                                                 S
  1.002  5440   1000  1100V          +500P/ 4/                             2W
  2.001  5440         10mV           0.05U                                 2W
  3.001  5440   10    -2.2V          1%                           O        2W
  4.001  5440   10    10V            5%                              G     2W
  5.001  5440   10    10V            5%                                    2W
  6.001  5440         10V                                               S  2W
  6.002  5440         10V            5%                                 N  2W
  6.003  5440   10    10A            0.1U                                  2W
  7.001  5440   A     A              0.01U                                 2W


5450

Instrument FSC

Description

The 5450 FSC programs the Fluke 5450A Resistance Calibrator.

Functional Capability

  • 0 Ω (short)
  • 1 Ω to 100 MΩ, 1 S to 10 nS in decade steps
  • 1.9 Ω to 19 MΩ, 0.52631 S to 52.631 nS in decade steps

Parameters

RANGE

This field specifies the UUT range as described in the RANGE Field topic.

NOMINAL

This field specifies the resistance, conductance, or reset.

  • Resistance entered as: [numeric][prefix]Z
  • Conductance entered as: [numeric][prefix]Y
  • Reset entered as *.

TOLERANCE

This field specifies the UUT tolerance as described in the TOLERANCE Field topic.

MOD1

This field is not used.

MOD2

This selection is used to compensate for lead resistance in the two-wire ohms mode. If the character “O” (for Offset) is entered in this field, the contents of memory location MEM are used (instead of the value in the NOMINAL field) for comparison against the expected nominal value.

To take advantage of this feature, you need to measure the total of the lead resistance and the value of resistance, using another DMM, for example an 8506A. Then you store the measured value in MEM and evaluate the UUT with the nominal value of resistance (“O” selected.)

Example

Test the accuracy of a UUT at 100 ohms, two-wire mode.

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
  1.004  ASK-   R
  1.005  HEAD         LOW RESISTANCE/HIGH CONDUCTANCE TEST
  1.006  5450         100.0Z                                            S  2W
  1.007  DISP         Configure the 8506A as follows:
  1.007  DISP         8506A: Input-Hi to 8506A: Source-Hi
  1.007  DISP         8506A: Input-Lo to 8506A: Source-Lo
  1.007  DISP         Press the 4T Ohms button in to enable 4-wire ohms.
  1.008  IEEE         [@8506]G3?[I]
  1.009  MEME
  1.010  JMPT         1.013
  1.011  DISP         Press the FRONT/REAR select switch.
  1.012  JMP          1.008
  1.013  DISP         Connect the 5450A and the 8506A as follows:
  1.013  DISP         5450A: Output-Hi to 8506A: Input-Hi
  1.013  DISP         5450A: Output-Lo to 8506A: Input-Lo
  1.014  8506         100Z                                              N  4W
  1.015  MEME
  1.016  DISP         Disconnect the 8506A from the 5450A.
  1.016  DISP         Connect the 5450A and the UUT as follows:
  1.016  DISP         5450A: Output-Hi to UUT V/Ohms
  1.016  DISP         5450A: Output-Lo to UUT COMMON
  1.017  5450         100Z           0.7% 0.2U                    O        2W

  • Step 1.004 disables the regular range and function messages.
  • Step 1.006 applies 100 ohms from the 5450A in the two-wire mode.
  • Step 1.007 wires the 8506A up in the two-wire mode, directly on its front panel input terminals.
  • Step 1.008 checks if the FRONT/REAR selection switch of the 8506A is in the FRONT position. Otherwise, the operator is prompted as defined in step 1.011.
  • The output of the 5450A is now connected and then measured with the leads up to the front panel of the 8506A in steps 1.013 and 1.014. The result is stored in MEM1 and then moved over to MEM in step 1.015.
  • The test leads are now moved over from the 8506A input to the UUT input in step 1.016. The performance of the UUT is now evaluated against the value in MEM in step 1.017 (note the cbOrv selection).

MOD3

This field specifies the guard connection.

G | External guard connection is active
blank | Guard is internally shorted to low.

MOD4

This field specifies the type of test being performed as described in the MOD4 Field topic.

CON

This field specifies the UUT connection.

2W | 2-wire
4W | 4-wire
RW | 2-wire with 2-wire compensation turned on

Rules:

  1. 2W is automatically inserted in the CON field when no CON field parameter is entered.

Use of Standard Memory Locations and Results Reporting

System memory locations MEM and MEM1 are used. For more information, refer to the Use of Standard Memory Registers topic.

Examples

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
# -----  Reset  -----
  2.001  5450         *                                                 S
  2.002  5450   100   100kZ          5.0%                                  2W
  3.001  5450   10    10Z            500P%                                 4W
  4.001  5450   100   100MZ          1000P/                                2W
  5.001  5450   200   190Z           5.0%                                  RW
  6.001  5450   10    Z              5.0U                                  RW
  7.001  5450   10    1mY            4000P/                                4W
  8.001  5450   1     0.52631Y       5.0%                                  4W
  9.001  5450   1     1Z             5%                                    4W
 10.001  5450         1Z                                                S  4W


5500

Instrument FSC

Description

The 5500 FSC provides the means to control the following functions of the Fluke 5500A and 5500E Calibrators:

  • DC Voltage and DC Current
  • AC Voltage and AC Current (Sine, Square, Triangle, and Truncated Sine waveforms)
  • Synthesized Resistance and Capacitance
  • RTD and Thermocouple Calibration stimulus
  • Thermocouple measurement
  • Boosted AC Voltage using the 5725A Boost Amplifier.
  • Boosted DC and AC Current using the 5725A Boost Amplifier.
The 5500E must be configured as “Fluke 5500A”.

The 5725A must be connected to the 5500A in order to be controlled through the 5500 FSC.

When the M550 FSC is used in conjunction with the 5500 FSC the following additional 5500A functions may be controlled:

  • Dual DC and Dual AC Voltage (5500A only)
  • DC and AC Power stimulus (simultaneous voltage and current output (5500A only)
  • DC Voltage and DC Current range locking
  • DC Offset for AC Voltage
  • Duty Cycle for square waves
  • Phase for Dual Voltage and Power stimulus
  • Displacement Power Factor for Power stimulus
  • External Reference Temperature for Thermocouple Calibration and Measurement

The following functions are available with 5500A-SC300 Scope Option (5500A only):

  • DC Voltage
  • AC Voltage (Sine, Square, Triangle, Leveled Sine, Scope Square, Edge, Time Mark, and ScopeMeter waveforms)
  • Trigger Signal

The following functions are available with 5500A-SC600 Scope Option (5500A only):

  • DC Voltage
  • AC Voltage (Sine, Square, Triangle, Leveled Sine, Positive and Negative Scope Square, Edge, Time Mark, Pulse and Video waveforms)
  • Oscilloscope Input Impedance Measurement
  • Oscilloscope 50 Ohm Impedance Overload Protection Measurement
  • Trigger Signal
If the 5500A/5500E is to be controlled via its serial port, do not use the PORT FSC port configuration special construction, [P9600,N,...], to set the baud rate, parity, etc. of the port used to control the 5500A/5500E. MET/CAL executes a “Test” function for each System Instrument prior to executing any procedure statements, therefore the settings of the port used to controlling the 5500A/5500E must be set correctly before a procedure is executed. If the 5500A is connected to a standard serial port (COM1, COM2, ..., COM16), select the “Ports” application in the Windows control panel to choose the proper settings. If the 5500A is connected to the 5520A or 5800A UUT port, select the proper settings for the UUT Serial Port from the front panel of the calibrator.

Functional Capability (5500A/5500E NORMAL and AUX Outputs and 5725A Output)

Function | Amplitude | Frequency/Period | Misc
DC Voltage
Normal Output | -1000 V to 1000 V
TC Output | -329.9999 mV to 329.9999 mV
AC Voltage
Normal Output:
Sine, Boost Off | 1 mV to 33 mV | 0.01 Hz to 9.99 Hz | Vp + |Voff|≤80 mVp
34 mV to 330 mV | 0.01 Hz to 9.99 Hz | Vp + |Voff|≤800 mVp
0.4 V to 3.3 V | 0.01 Hz to 9.99 Hz | Vp + |Voff|≤8 Vp
4 V to 33 V | 0.01 Hz to 9.99 Hz | Vp + |Voff|≤50 Vp
1 mV to 32.999 mV | 10 Hz to 500 kHz | Vp + |Voff|≤80 mVp
33 mV to 329.999 mV | 10 Hz to 500 kHz | Vp + |Voff|≤800 mVp
0.33 V to 3.29999 V | 10 Hz to 500 kHz | Vp + |Voff|≤8 Vp
3.3 V to 32.9999 V | 10 Hz to 100 kHz | Vp + |Voff|≤55 Vp
33 V to 329.999 V | 45 Hz to 20 kHz
330 V to 1000 V | 45 Hz to 10 kHz
0.3 V to 3.3 V | 1 MHz, 2 MHz
-63.80 dBm to -7.29 dBm | 0.01 Hz to 9.99 Hz | Vp + |Voff|≤80 mVp
-27.28 dBm to -7.40 dBm | 0.01 Hz to 9.99 Hz | Vp + |Voff|≤800 mVp
-7.3 dBm to 12.7 dBm | 0.01 Hz to 9.99 Hz | Vp + |Voff|≤8 Vp
13 dBm to 32 dBm | 0.01 Hz to 9.99 Hz | Vp + |Voff|≤50 Vp
-57.78 dBm to -27.41 dBm | 10 Hz to 500 kHz | Vp + |Voff|≤80 mVp
-27.41 dBm to -7.41 dBm | 10 Hz to 500 kHz | Vp + |Voff|≤800 mVp
-7.41 dBm to 12.58 dBm | 10 Hz to 500 kHz | Vp + |Voff|≤8 Vp
12.59 dBm to 32.58 dBm | 10 Hz to 100 kHz | Vp + |Voff|≤55 Vp
32.59 dBm to 52.58 dBm | 45 Hz to 20 kHz
52.59 dBm to 62.21 dBm | 45 Hz to 10 kHz
-8 dBm to 12.7 dBm | 1 MHz, 2 MHz
Sine, Boost On | 100 V to 750 V | 45 Hz to 100 kHz
750 V to 1000 V | 45 Hz to 30 kHz
42.22 dBm to 59.71 dBm | 45 Hz to 100 kHz
59.72 dBm to62.21 dBm | 45 Hz to 30 kHz
Square 1 | 3 mVpp to 66 mVpp | 0.01 Hz to 9.99 Hz | Vp + |Voff|≤80 mVp
67 mVpp to 660 mVpp | 0.01 Hz to 9.99 Hz | Vp + |Voff|≤800 mVp
0.7 Vpp to 6.6 Vpp | 0.01 Hz to 9.99 Hz | Vp + |Voff|≤8 Vp
7 Vpp to 66 Vpp | 0.01 Hz to 9.99 Hz | Vp + |Voff|≤55 Vp
2.9 mVpp to 65.999 mVpp | 10 Hz to 100 kHz | Vp + |Voff|≤80 mVp
66 mVpp to 659.999 mVpp | 10 Hz to 100 kHz | Vp + |Voff|≤800 mVp
0.66 Vpp to 6.59999 Vpp | 10 Hz to 100 kHz | Vp + |Voff|≤8 Vp
6.6 Vpp to 66 Vpp | 10 Hz to 100 kHz | Vp + |Voff|≤55 vp
Triangle & Truncated Sine | 2.9 mVpp to 92.999 | 10 Hz to 100 kHz | Vp + |Voff|≤80 mVp
93 mVpp to 929.999 mVpp | Vp + |Voff|≤800 mVp
0.93 Vpp to 9.29999 Vpp | Vp + |Voff|≤8 Vp
9.3 Vpp to 93 Vpp | Vp + |Voff|≤55 Vp
DC Current
Aux. Output | -11 A to 11 A
5725A Output:
Boost Off | -2.19999 A to 2.19999 A
Boost On | -11 A to 11 A
AC Current
Aux Output, Sine:
no toroid | 29 uA to 330 mA | 0.01 Hz to 9.99 Hz
29 uA to 329.999 mA | 10 Hz to 10 kHz
0.33 A to 2.19999 A | 10 Hz to 5 kHz
2.2 A to 11 A
10-turn toroid | 0.29 mA to 3.29999 A | 10 Hz to 10 kHz
3.3 A to 21.9999 A | 10 Hz to 5 kHz
22 A to 110 A | 45 Hz to 1 kHz
30-turn toroid | 0.87 mA to 8.9997 A | 10 Hz to 10 kHz
9.9 A to 65.9997 A | 10 Hz to 5 kHz
66 A to 330 A | 45 Hz to 1 kHz
50-turn toroid | 1.45 mA to 16.49995 A | 10 Hz to 10 kHz
16.5 A to 109.9995 A | 10 Hz to 5 kHz
110 A to 550 A | 45 Hz to 1 kHz
Square | 47 uApp to 660 mApp | 0.01 Hz to 9.99 Hz
47 uApp to 659.999 mApp | 10 Hz to 10 kHz
0.66 App to 4.39999 App | 10 Hz to 5 kHz
4.4 App to 22 App | 45 Hz to 1 kHz
Triangle & Truncated Sine | 47 uApp to 930 mApp | 0.01 Hz to 9.99 Hz
47 uApp to 929.999 mApp | 10 Hz to 10 kHz
0.93 App to 6.19999 mApp | 10 Hz to 5 kHz
6.2 App to 31 App | 45 Hz to 1 kHz
5725A Output
Sine
no toroid:
Boost Off | 0.33 mA to 329.999 mA | 10 Hz to 10 kHz
0.33 A to 2.19999 A | 10 Hz to 5 kHz
Boost On | 1.5 A to 11 A | 45 Hz to 10 kHz
10-turn toroid:
Boost Off | 3.3 mA to 3.29999 A | 10 Hz to 10 kHz
3.3 A to 21.9999 A | 10 Hz to 5 kHz
Boost On | 15 A to 110 A | 45 Hz to 10 kHz
30-turn toroid
Boost Off | 9.9 mA to 8.9997 A | 10 Hz to 10 kHz
9.9 A to 65.9997 A | 10 Hz to 5 kHz
Boost On | 45 A to 330 A | 45 Hz to 10 kHz
50-turn toroid
Boost Off | 16.5 mA to 16.49995 A | 10 Hz to 10 kHz
16.5 A to 109.9995 A | 10 Hz to 5 kHz
Boost On | 75 A to 550 A | 45 Hz to 10 kHz
Square
Boost Off | 0.47 mApp to 659.999 mApp | 10 Hz to 10 kHz
0.66 App to 4.39999 App | 10 Hz to 5 kHz
Boost On | 4.4 App to 22 App | 45 Hz to 10 kHz
Triangle & Truncated Sine
Boost Off | 0.47 mApp to 929.999 mApp | 10 Hz to 10 kHz
0.93 App to 6.19999 App | 10 Hz to 5 kHz
Boost On | 6.2 App to 31 App | 45 Hz to 10 kHz
Synthesized Resistance
4-wire & 2-wire comp. | 0 Ohm to 109.999 kOhm
2-wire | 110 kOhm to 330 MOhm
Synthesized Capacitance
2-wire | 330 pF to 1100.00 uF
4-wire & 2-wire comp. | 110 nF to 1100.00 uF
RTD Calibration
100 Ω Pt 385 | -200 °C to 800 °C (-328 °F to 1472 °F)
200 Ω Pt 385 | -200 °C to 630 °C (-328 °F to 1166 °F)
500 Ω Pt 385 | -200 °C to 630 °C (-328 °F to 1166 °F)
1 kΩ Pt 385 | -200 °C to 630 °C (-328 °F to 1166 °F)
100 Ω Pt 3916 | -200 °C to 630 °C (-328 °F to 1166 °F)
100 Ω Pt 3926 | -200 °C to 630 °C (-328 °F to 1166 °F)
120 Ω Ni | -80 °C to 260 °C (-112 °F to 500 °F)
10 Ω Cu | -100 °C to 260 °C (-148 °F to 500 °F)
Thermocouple Calibration and Measurement
Type B | 600 °C to 1820 °C (1112 °F to 3308 °F)
Type C | 0 °C to 2316 °C (32 °F to 4201 °F)
Type E | -250 °C to 1000 °C (-418 °F to 1832 °F)
Type J | -210 d°C to 1200 °C (-410 °F to 2192 °F)
Type K | -200 °C to 1372 °C (-328 °F to 2502 °F)
Type L | -200 °C to 900 °C (-328 °F to 2502 °F)
Type N | -200 °C to 1300 °C (-328 °F to 2372 °F)
Type R | 0 °C to 1767 °C (32 °F to 3213 °F)
Type S | 0 d°C to 1767 °C (32 °F to 3213 °F)
Type T | -250 °C to 400 °C (-418 °F to 752 °F)
Type U | -200 °C to 600 °C (-328 °F to 1103 °F)
Dual DC Voltage: Amplitude
Normal Output | -1100 V to 1100 V
Aux Output | -3.3 V to 3.3 V
Dual AC Voltage
Normal Output 4
Sine 2
Boost Off | 1 mV to 1000 V | 10 Hz to 10 kHz
-57.78 dBm to 62.21 dBm | 10 Hz to 10 kHz
Boost On | 150 V to 1000 V | 40 Hz to 10 kHz
45.74 dBm to 62.21 dBm | 40 Hz to 10 kHz
Square | 2.9 mVpp to 66 Vpp | 10 Hz to 10 kHz
Triangle & Truncated Sine | 2.9 mVpp to 93 Vpp | 10 Hz to 10 kHz
Aux Output
Sine 2 | 10 mV to 330 mV | 0.01 Hz to 9.99 Hz
-27.28 dBm to -7.40 dBm | 0.01 Hz to 9.99 Hz
0.4 V to 3.3 V | 0.01 Hz to 9.99 Hz
-7.3 dBm to 12.7 dBm | 0.01 Hz to 9.99 Hz
10 mV to 3.3 V | 10 Hz to 10 kHz
-37.78 dBm to 12.58 dBm | 10 Hz to 10 kHz
Square | 29 mVpp to 6.6 Vpp | 0.01 Hz to 10 kHz
Triangle & Truncated Sine | 29 mVpp to 9.3 Vpp | 0.01 Hz to 10 kHz
DC Power
Normal Output | -1100 V to 1100 V
Aux Output | -11 A to 11 A
5725A Output
Boost Off | -2.19999 A to 2.19999 A
Boost On | -11 A to 11 A
AC Power
Normal Output 4
Sine 2
Boost Off | 1 mV to 1000 V | 3
-57.78 dBm to 62.21 dBm | 3
Boost On | 150 V to 1000 V | 3
45.74 dBm to 62.21 dBm | 3
Square | 2.9 mVpp to 65.9999 Vpp | 3
2.9 mVpp to 93 Vpp | 3
Triangle & Truncated Sine 2
Aux Output
no toroid | 0.33 mA to 330 mA | 0.01 Hz to 9.99 Hz
0.33 mA to 329.999 mA | 10 Hz to 10 kHz
0.33 A to 2.19999 A | 10 Hz to 5 kHz
2.2 A to 11 A | 45 Hz to 1 kHz
10-turn toroid | 0.29 mA to 3.29999 A | 10 Hz to 10 kHz
3.3 A to 21.9999 A | 10 Hz to 5 kHz
22 A to 110 A | 45 Hz to 1 kHz
30-turn toroid | 0.87 mA to 9.89997 A | 10 Hz to 10 kHz
9.9 A to 65.9997 A | 10 Hz to 5 kHz
66 A to 330 A | 45 Hz to 1 kHz
50-turn toroid | 1.45 mA to 16.49995 A | 10 Hz to 10 kHz
16.5 A to 109.9995 A | 10 Hz to 5 kHz
110 A to 550 A | 45 Hz to 1 kHz
Square | 47 mApp to 659.999 mApp | 10 Hz to 10 kHz
0.66 App to 4.39999 App | 10 Hz to 5 kHz
4.4 App to 22 App | 45 Hz to 1 kHz
Triangle & Truncated Sine | 47 mApp to 929.999 mApp | 10 Hz to 10 kHz
0.93 App to 6.19999 mApp | 10 Hz to 5 kHz
6.2 App to 31 App | 45 Hz to 1 kHz
5725A Output 4
Sine 2
Boost Off | 0.33 mA to 329.999 mA | 10 Hz to 10 kHz
0.33 A to 2.19999 A | 10 Hz to 5 kHz
Boost On | 1.5 A to 11 A | 45 Hz to 10 kHz
Square
Boost Off | 0.47 mA to 659.999 mApp | 10 Hz to 10 kHz
0.66 App to 4.39999 App | 10 Hz to 5 kHz
Boost On | 4.4 App to 22 App | 45 Hz to 10 kHz
Triangle & Truncated Sine
Boost Off | 0.47 mA to 929.999 mApp | 10 Hz to 10 kHz
0.93 App to 6.19999 App | 10 Hz to 5 kHz
Boost On | 6.2 App to 31 App | 45 Hz to 10 kHz
  1. A duty cycle of 1% to 99% may be specified for square waves. The default is 50%.
  2. When both waveforms are sine, either the Normal or Aux output may be specified to be a harmonic from 1 to 31.
  3. The frequency is the same for the voltage and the current, therefore the limits of the AC Voltage frequency are the same as those specified for the AC Current range selected.
  4. The phase between the two output signals may be specified from -180 degrees to +180 degrees.

Functional Capability (5500A SCOPE Output with Option 5500A-SC300 Installed)

Function | Amplitude | Frequency/Period | Misc
DC Voltage
50 Ω term. | -2.2 V to 2.2 V |  |
1 MΩ term. | -33 V to 33 V |  |
Scope Square Wave (zero based)
50 Ω term. | 1.8 mVpp to 2.2 Vpp | 10 Hz to 10 kHz |
1 MΩ term. | 1.8 mVpp to 55 Vpp | 10 Hz to 10 kHz |
Scopemeter Square Wave
1 MΩ term. | 95 Vpp to 105 Vpp | 10 Hz to 10 kHz |
Edge
50 Ω term. | 5 mVpp to 2.5 Vpp | 1 kHz to 1 MHz |
 | in a 1-(2.5)-5 sequence ±10 % |  |
Leveled Sine
50 Ω term. | 5 mVpp to 5.5 Vpp | 50 kHz to 350 MHz |
Time Markers
50 Ω term. |  | 1.8 ns to 2.2 ns |
 |  | 4.5 ns to 11 ns |
 |  | 18 ns to 22 ns |
 |  | 45 ns to 110 ns |
 |  | 180 ns to 1.1 us |
 |  | 1.8 us to 60 us |
 |  | 90 us to 12 ms |
 |  | 18 ms to 5.5 s |
Wavegen
Sine, Square, and Triangle Waveforms (zero centered) |  |  | Max AC + DC Offset
50 Ω term. | 1.8 mVpp to 10.9 mVpp | 10 Hz to 100 kHz | Vp + |Voff|≤12.5 mVp
 | 11 mVpp to 44.9 mVpp | 10 Hz to 100 kHz | Vp + |Voff|≤50.5 mVp
 | 45 mVpp to 109 mVpp | 10 Hz to 100 kHz | Vp + |Voff|≤125 mVp
 | 110 mVpp to 449 mVpp | 10 Hz to 100 kHz | Vp + |Voff|≤225 mVp
 | 0.45 Vpp to 1.09 Vpp | 10 Hz to 100 kHz | Vp + |Voff|≤1.25 Vp
 | 1.1 Vpp to 2.2 Vpp | 10 Hz to 100 kHz | Vp + |Voff|≤3.1 Vp
1 MΩ term. | 1.8 mVpp to 21.9 mVpp | 10 Hz to 100 kHz | Vp + |Voff|≤26 mVp
 | 22 mVpp to 89.9 mVpp | 10 Hz to 100 kHz | Vp + |Voff|≤100 mVp
 | 90 mVpp to 219 mVpp | 10 Hz to 100 kHz | Vp + |Voff|≤260 mVp
 | 220 mVpp to 899 mVpp | 10 Hz to 100 kHz | Vp + |Voff|≤1000 mVp
 | 0.9 Vpp to 6.59 Vpp | 10 Hz to 100 kHz | Vp + |Voff|≤6.6 Vp
 | 6.6 Vpp to 55 Vpp | 10 Hz to 100 kHz | Vp + |Voff|≤50 Vp

Functional Capability (5500A SCOPE Output with Option 5500A-SC600 Installed)

Function | Amplitude | Frequency/Period | Misc
DC Voltage
50 Ω term. | -6.599 V to 6.599 V |  |
1 MΩ term. | -130 V to 130 V |  |
AC Voltage
Scope Square Wave (zero based, positive and negative) |  |  |
50 Ω term. | 1.0 mVpp to 6.599 Vpp | 10 Hz to 10 kHz |
1 MΩ term. | 1.0 mVpp to 130 Vpp | 10 Hz to 10 kHz |
Edge
 | in a 1-(2.5)-5 seq ±10 % |  |
50 Ω term. | 5 mVpp to 2.5 Vpp | 900 Hz to 11 MHz |
w/Tunnel Diode Pulser |  |  |
Drive Signal | 11 Vpp to 2.5 Vpp | 900 Hz to 11 MHz |
Leveled Sine
50 Ω term. | 5 mVpp to 5.5 Vpp | 50 kHz to 600 MHz |
Time Markers
50 Ω term. |  |  |
Spike |  | 18 ns to 5.5 s |
Square |  | 7.5 ns to 5.5 s |
20% Duty Square 75ns to 34.99ms |  |  |
Sine |  | 1.8 ns to 17.9 ns |
Wavegen
Sine, Square, and Triangle Waveforms (zero centered) |  |  | Max AC + DC Offset
50 Ω term. | 1.8 mVpp to 10.9 mVpp | 10 Hz to 100 kHz | Vp + |Voff|≤12.5 mVp
 | 11 mVpp to 44.9 mVpp | 10 Hz to 100 kHz | Vp + |Voff|≤50.5 mVp
 | 45 mVpp to 109 mVpp | 10 Hz to 100 kHz | Vp + |Voff|≤125 mVp
 | 110 mVpp to 449 mVpp | 10 Hz to 100 kHz | Vp + |Voff|≤225 mVp
 | 0.45 Vpp to 1.09 Vpp | 10 Hz to 100 kHz | Vp + |Voff|≤1.25 Vp
 | 1.1 Vpp to 2.2 Vpp | 10 Hz to 100 kHz | Vp + |Voff|≤3.1 Vp
1 MΩ term. | 1.8 mVpp to 21.9 mVpp | 10 Hz to 100 kHz | Vp + |Voff|≤26 mVp
 | 22 mVpp to 89.9 mVpp | 10 Hz to 100 kHz | Vp + |Voff|≤100 mVp
 | 90 mVpp to 219 mVpp | 10 Hz to 100 kHz | Vp + |Voff|≤260 mVp
 | 220 mVpp to 899 mVpp | 10 Hz to 100 kHz | Vp + |Voff|≤1000 mVp
 | 0.9 Vpp to 6.59 Vpp | 10 Hz to 100 kHz | Vp + |Voff|≤6.6 Vp
 | 6.6 Vpp to 55 Vpp | 10 Hz to 100 kHz | Vp + |Voff|≤50 Vp
Video
 |  |  | Line Marker
NTSC | -150% to 150% |  | 1 to 262 Odd or Even
 | -1.5 Vp to 1.5 Vp |  | 1 to 262 Odd or Even
 | -140 IRE to 140 IRE |  | 1 to 262 Odd or Even
PAL | -150% to 150% |  | 1 to 622
 | -1.5 Vp to 1.5 Vp |  | 1 to 622
PAL-M | -150% to 150% |  | 1 to 262 Odd or Even
 | -1.5 Vp to 1.5 Vp |  |
 | -140 IRE to 140 IRE |  | 1 to 262 Odd or Even
SECAM | -150% to 150% |  | 1 to 622
 | -1.5 Vp to 1.5 Vp |  | 1 to 622
Pulse
 |  | Period | Pulse Width
50 Ω term. | 10 mVpp, 25 mVpp, | 200 ns to 22 ms | 2 ns to 500 ns
 | 100 mVpp, 250 mVpp, |  |
 | 1 Vpp, and 2.5 Vpp |  |
UUT Input Impedance Measurement (MEAS Z)
50 Ω | 40 Ω to 60 Ω |  |
1 MΩ | 500 kΩ to 1.5 MΩ |  |
Capacitance | 5 pF to 50 pF |  |
UUT 50 Ω Input Impedance Overload Protection Measurement (OVERLD)
DC | 5 V to 9 V |  |
AC | 5 V to 9 V | 1 kHz |

Parameters

The following table describes the basic operating modes of the 5500A/5500E Calibrator in terms of the FSC fields listed. Only the combinations of field quantities listed below are allowed. These mode names are also used in other places in this section to clarify the rules for each parameter of the 5500FSC.

5500A/5500E Operating Modes

5500A/5500E | 5500 Nominal | 5500 MOD1 | 5500 MOD3 1 | M550 Range | M550 Nominal | M550 MOD1
DC Voltage | voltage | TC | SC | S6 | E | [RNGLK | voltage]
AC Voltage | voltage | freq|period | BV | SC | S6 | E | [DC offset]
AC Voltage | freq|period | voltage | BV | [DC offset]
AC Voltage
(pulse) 		p-width voltage S6 PER period
period | voltage | S6 | PULSE | p-width
Period and pulse width (p-width) may be entered as a frequency in Hertz.
AC Voltage | duty cycle | freq|period | voltage | [DC offset]
AC Voltage
(time marks) 		freq|period SC | S6
DC Current | current | BC | BP | E | [RNGLK | current]
AC Current | current | freq/period | BC | BP | E
AC Current | freq|period | current | BC | BP
Resistance | resistance | E
Resistance | conductance | E
Capacitance | capacitance
RTD Cal | temperature
TC Cal | temperature | TC | [TCREF | temp.]
TC Meas | temperature | TM | TN | [TCREF | temp.]
Dual DC | voltage | AX | voltage
Voltage 2
Dual AC | voltage | freq|period | BV | AX | Hn | HXn | voltage
Voltage 2
Dual AC | freq|period voltage | BV | HXn | voltage
Voltage 2
Dual AC | freq | period voltage | AX | Hn | voltage
Voltage 2
Dual AC | phase | freq|period | BV | AX | Hn | HXn | voltage | voltage
Voltage 2
DC Power 2 | power | BC | BP | voltage
DC Power 2 | power | current
DC Power 2 | voltage | current
current | BC | BP | voltage
AC Power 2 | power | freq|period | BC | BP | Hn | HXn | LEAD | LAG | voltage
AC Power 2 | power | freq|period | BV | Hn | HXn | LEAD | LAG | current
AC Power 2 | current | freq|period | BC | BP | Hn | HXn | LEAD | LAG | voltage
AC Power 2 | voltage | freq|period | BV | Hn | HXn | LEAD | LAG | current
AC Power 2 | freq | period | current | BC | BP | Hn | LEAD | LAG] | voltage
AC Power 2 | freq | period voltage | BV | HXn | LEAD | LAG | current
AC Power 2 phase freq|period BC | BP [Hn | HXn | voltage current
AC Power 2 phase freq|period BV [Hn | HXn| current voltage
Video | percent | voltage | IRE | line marker | S6 | ODD | EVEN
Impedance Meas resistance |
capacitance 		ZM
Overload Meas | voltage | [freq] | OM | LIMIT | time
Blank entries in the above table are significant and must be blank. FSC field inter-dependencies not expressed in this table are listed under “Rules” for the appropriate parameter.
  1. See MOD3 parameter for description of these specification codes and rules.
  2. 5500A only

Units Symbols

Units Symbol | Name | Quantity
A | Amps | current
Ap | Amps peak | current
App | Amps peak to peak | current
D | dBm | decibels
F | Farads | capacitance
H | Hertz | frequency
IRE | IRE | video amplitude
LM | Line Marker | video line marker position
T | Time | period or pulse width
V | Volts | voltage or video amplitude
Vp | Volts peak | voltage
Vpp | Volts peak to peak | voltage
W | Watts | power
Y | Siemens | conductance
Z | Ohms | resistance
deg | degrees | phase
degC | degrees Celsius | temperature
degF | degrees Fahrenheit | temperature
pct | percent | duty cycle or video amplitude

5500 FSC NOMINAL, MOD1, MOD2, and MOD3 Rules

5500A/5500E Mode | 5500 NOMINAL | 5500 MOD1 | 5500 MOD2 1 | 5500 MOD3 2
DC Voltage | V | TC|E
AC Voltage | V|Vpp|D | H|T | SI | BV|E
V|Vpp | H|T | SQ|TI|TS | BV
Vp | H|T | SI | BV
Vp | H|T | SQ|TI|TS | BV
H|T | V|Vpp|D | SI | BV
H|T | V|Vpp | SQ|TI|TS | BV
pct | H|T | SI|SQ|TI|TS | BV
DC Current | A | BC|BP|E
AC Current | A|App | H|T | SI | BC|BP|E
A|App | H|T | SI|SQ|TI|TS | BC|BP
Ap | H|T | SI|SQ|TI|TS | BC|BP
H|T | A|App | SI|SQ|TI|TS | BC|BP
Resistance | Z|Y | E
Capacitance | F
RTD Cal | degC|degF | R1|R2|R3|R4|R5|R6|R7|R8
TC Cal | degC|degF | _B|_C|_E|_J|_K|_L|_N|_R|_S|_T|_U | TC
TC Meas | degC|degF | _B|_C|_E|_J|_K|_L|_N|_R|_S|_T|_U | TM|TN
Dual DC Voltage 3 | V | AX
Dual AC Voltage 3 | V|Vp|Vpp|D | H|T | SI | AX|BV
V|Vp|Vpp | H|T | SQ|TI|TS | AX
H|T | V|Vpp|D | SI | AX|BV
H|T | V|Vpp | SQ|TI|TS | AX
DC Power 3 | W|A | BC|BP
V
AC Power 3 | W | H|T | SI | BV|BC|BP
V|Vp|Vpp|D | H|T | SI | BV
V|Vp|Vpp | H|T | SQ|TI|TS
A|Ap|App | H|T | SI|SQ|TI|TS | BC|BP
H|T | V|Vpp|D | SI | BV
H|T | V|Vpp | SQ|TI|TS
H|T | A|App | SI|SQ|TI|TS | BC|BP
Blank entries in the above table are significant and must be blank. FSC field inter-dependencies not expressed in this table are listed under “Rules” for the appropriate parameter.
  1. See MOD2 parameter for description of these specification codes and rules.
  2. See MOD3 parameter for description of these specification codes and rules.
  3. 5500A only.

5500 FSC NOMINAL, MOD1, MOD2, and MOD3 Rules for 5500A-SC300

5500A Mode | 5500 NOMINAL | 5500 MOD1 | 5500 MOD2 1 | 5500 MOD3 2
DC Voltage (VOLT) | V | SC
AC Voltage (VOLT) | V|Vp|Vpp | H|T | ZQ|SM | SC
H|T | V|Vpp | ZQ|SM | SC
AC Voltage (EDGE) | V|Vp|Vpp | H|T | ED | SC
AC Voltage (LEVSINE) | V|Vp|Vpp | H|T | LS | SC
H|T | V|Vpp | LS | SC
AC Voltage (MARKER) | H|T | MK | SC
AC Voltage (WAVEGEN) | V|Vp|Vpp | H|T | SI|SQ|TI | SC
H|T | V|Vpp | SI|SQ|TI
Blank entries in the above table are significant and must be blank. FSC field inter-dependencies not expressed in this table are listed under “Rules” for the appropriate parameter.
  1. See MOD2 parameter for description of these specification codes and rules.
  2. See MOD3 parameter for description of these specification codes and rules.

5500 FSC NOMINAL, MOD1, MOD2, and MOD3 Rules for 5500A-SC600

5500A Mode | 5500 NOMINAL | 5500 MOD1 | 5500 MOD2 1 | 5500 MOD3 2
DC Voltage (VOLT) | V | S6
AC Voltage (VOLT) | V|Vp|Vpp | H|T | ZQ|ZN | S6
H|T | V|Vp|Vpp | ZQ|ZN | S6
AC Voltage (EDGE) | V|Vp|Vpp | H|T | ED | S6
H|T | V|Vpp | ED | S6
AC Voltage (LEVSINE) | V|Vp|Vpp | H|T | LS | S6
H|T | V|Vpp | LS | S6
AC Voltage (MARKER) | H|T | M1|M2|M3|M4 | S6
AC Voltage (WAVEGEN) | V|Vp|Vpp | H|T | SI|SQ|TI | S6
H|T | V|Vpp | SI|SQ|TI
AC Voltage (PULSE) | H|T | Vpp | PU | S6
Video (VIDEO) | pct|Vp|IRE | LM | F1|F3 | S6
pct|Vp | LM | F2|F4 | S6
Impedance Meas (MEAS Z) | Z | ZM
F | ZM
Overload Meas (OVERLD) | V | OM
Vpp | H | OM
Blank entries in the above table are significant and must be blank. FSC field interdependencies not expressed in this table are listed under “Rules” for the appropriate parameter.
  1. See MOD2 parameter for description of these specification codes and rules.
  2. See MOD3 parameter for description of these specification codes and rules.

RANGE

This field specifies the UUT range as described in the RANGE Field topic.

NOMINAL

This field specifies the starting Nominal value of the stimulus output or expected UUT reading for the test entered as:

[numeric][prefix]units symbol

or “*” to specify a reset.

Rules:

  1. The NOMINAL field may not specify frequency or period when any of the following sets of conditions exist:
    1. Dual AC Voltage is specified and either
      1. the M550 RANGE field specifies H and the M550 MOD3 field specifies AX or
      2. the M550 RANGE field specifies HX and the 5500 MOD3 field specifies AX.
    2. AC Power is specified and either
      1. the M550 RANGE field specifies H and the M550 NOMINAL field specifies current or
      2. the M550 RANGE field specifies HX and the M550 NOMINAL field specifies voltage.
    3. The MOD3 field specifies E.

  2. When the NOMINAL field specifies frequency or period and the M550 RANGE field specifies a harmonic (H or HX), the Keyboard Entry (ASK+ K) or Go/No-Go (ASK+ G) evaluation mode must be specified, Slew is not allowed.

    A duty cycle other than 50% may only be specified for square waveforms (MOD2 is SQ). Therefore keyboard entry and go-nogo evaluations may be performed at 50% duty cycle for non-square waveforms, but slew mode is not allowed. In addition the duty cycle is restricted to 50%, regardless of the type of waveform, when the DC offset is not zero.

  3. When the NOMINAL field specifies power and the value is slewed, if the M550 NOMINAL field specifies voltage, the voltage is held constant and a new value of current is computed by the 5500A. If the M550 NOMINAL field specifies current, the current is held constant and a new value of voltage is computed by the 5500A.
  4. When the NOMINAL field contains only units, the value is obtained from the memory register MEM.
  5. When the NOMINAL field contains only units and the MOD1 field is not blank, the MOD1 field must specify a value.

TOLERANCE

This field specifies the UUT tolerance as described in the TOLERANCE Field topic.

MOD1

This field specifies the frequency, period, voltage, or current for AC Voltage, AC Current, Dual AC Voltage, or AC Power modes entered as:

[numeric][prefix]units symbol

Rules:

  1. When the MOD1 field contains only units, the value is obtained from memory register MEM. In this case the NOMINAL field MUST contain a value.

MOD2

This field specifies one of the following:

  1. The waveform type for the voltage or current specified in the NOMINAL or MOD1 field for AC Voltage or AC Current.
  2. The waveform type for the voltage or current not specified in the M550 FSC NOMINAL field for AC Power or Dual AC Voltage.
  3. The thermocouple or RTD type for TC Measurement, TC Calibration, or RTD Calibration.
blank | DC or not applicable
SI | Sine wave (5500A and 5500A-SC300 and 5500A-SC600 Wavegen)
SQ | Square wave (5500A and 5500A-SC300 and 5500A-SC600 Wavegen)
TI | Triangle wave (5500A and 5500A-SC300 and 5500A-SC600 Wavegen)
TS | Truncated sine wave
_B | Type B thermocouple
_C | Type C thermocouple
_E | Type E thermocouple
_J | Type J thermocouple
_K | Type K thermocouple
_L | Type L thermocouple
_N | Type N thermocouple
_R | Type R thermocouple
_S | Type S thermocouple
_T | Type T thermocouple
_U | Type U thermocouple
R1 | 100 Ohm Pt385 RTD
R2 | 100 Ohm Pt3926 RTD
R3 | 120 Ohm Ni672 RTD
R4 | 200 Ohm Pt385 RTD
R5 | 500 Ohm Pt385 RTD
R6 | 1 kOhm Pt385 RTD
R7 | 100 Ohm Pt3916 RTD
R8 | 10 Ohm Cu427 RTD
ZQ | Positive square wave (5500A-SC300 & 5500A-SC600 AC Voltage)
ZN | Negative square wave (5500A-SC600 AC Voltage)
SM | ScopeMeter wave (5500A-SC300 AC Voltage)
ED | Edge signal (5500A-SC300 & 5500A-SC600)
LS | Leveled sine wave (5500A-SC300 & 5500A-SC600)
MK | Marker signal (5500A-SC300)
M1 | Spike Marker signal (5500A-SC600)
M2 | Square Marker signal (5500A-SC600)
M3 | 20% Duty Cycle Square Marker signal (5500A-SC600)
M4 | Sinusoid Marker signal (5500A-SC600)
PU | Pulse wave (5500A-SC600)
F1 | NTSC video signal (5500A-SC600)
F2 | PAL video signal (5500A-SC600)
F3 | PAL-M video signal (5500A-SC600)
F4 | SECAM video signal (5500A-SC600)

Rules:

  1. SI is inserted automatically in the MOD2 field for AC Voltage, AC Current, Dual AC Voltage, or AC Power (i.e. the MOD1 field is not blank) if no MOD2 code is entered.
  2. R1 is inserted automatically in the MOD2 field for RTD Calibration if no MOD2 code is entered.
  3. The M550 RANGE and NOMINAL field must specify the pulse wave period or frequency when the MOD2 field specifies PU and the NOMINAL field specifies the pulse width.
  4. The M550 RANGE and NOMINAL field must specify the pulse width when the MOD2 field specifies PU and the NOMINAL field specifies the pulse wave period or frequency.
  5. The M550 RANGE field must specify ODD or EVEN frame when the MOD2 field specifies F1 (NTSC video) or F3 (PAL-M video).

MOD3

This field specifies the calibrator output mode:

blank | Default for mode specified
AX | Auxiliary Voltage
BC | Boost Current
BP | Boost Port (Use Boost Amplifier port for non-boosted current)
BV | Boost Voltage
E | Extended Performance
TC | Thermocouple Cal
TM | Thermocouple Measurement (open TC detection on)
TN | Thermocouple Measurement (open TC detection off)
SC | 5500A-SC300 Scope Option
S6 | 5500A-SC600 Scope Option
ZM | 5500A-SC600 UUT Input Impedance Measurement
OM | 5500A-SC600 UUT 50 Ohm Input Overload Protection Measurement

Rules:

  1. The MOD3 field must specify AX when Dual DC Voltage or Dual AC Voltage is specified and the M550 FSC MOD3 field does not specify AX.
  2. The MOD3 field may specify BV only when the following conditions exist:
    1. AC Voltage, Dual AC Voltage, or AC Power is specified.
    2. The MOD2 field specifies SI.
    3. Voltage is specified in the NOMINAL or MOD1 field or the M550 MOD1 field or power is specified in the NOMINAL field and current is specified in the M550 NOMINAL field.
    4. The voltage specified in the NOMINAL or MOD1 field or the M550 MOD1 field or computed from the power specified in the NOMINAL field, the current specified in the M550 NOMINAL field, and any phase or power factor specified in the M550 TOLERANCE field, is within the range of the 5725A Boost Amplifier.
    5. The M550 FSC MOD3 field does not specify BV, BC, or BP.
  3. The MOD3 field may specify BC only when the following conditions exist:
    1. DC Current, AC Current, DC Power, or AC Power is specified.
    2. Current is specified in the NOMINAL or MOD1 field or the M550 MOD1 field or power is specified in the NOMINAL field and voltage is specified in the M550 NOMINAL field.
    3. The current specified or computed from the power specified in the NOMINAL field, the voltage specified in the M550 NOMINAL field, and any phase or power factor specified in the M550 TOLERANCE field, is within the range of the 5725A Boost Amplifier with boost on (see Table 1).
    4. The M550 FSC MOD3 field does not specify BC, BV, or BP.
  4. The MOD3 field may specify BP only when the following conditions exist:
    1. DC Current, AC Current, DC Power, or AC Power is specified.
    2. Current is specified in the NOMINAL or MOD1 field or the M550 MOD1 field or power is specified in the NOMINAL field and voltage is specified in the M550 NOMINAL field.
    3. The current specified or computed from the power specified in the NOMINAL field, the voltage specified in the M550 NOMINAL field, and any phase or power factor specified in the M550 TOLERANCE field, is within the range of the 5725A Boost Amplifier with boost off (see Table 1).
    4. The M550 FSC MOD3 field does not specify BC, BV, or BP.
  5. The MOD3 field may specify SC only when the 5500A-SC300 Scope option is configured.
  6. The MOD3 field may specify S6 only when the 5500A-SC600 Scope option is configured.
  7. SC is inserted automatically in the MOD3 field when the MOD2 field specifies ZQ, SM, ED, LS, or MK, and the 5500A-SC300 Scope Option is configured, and no MOD3 code is entered.
  8. S6 is inserted automatically in the MOD3 field when the MOD2 field specifies ZQ, ZN, ED, LS, PU, M1, M2, M3, M4, F1, F2, F3, or F4, and the 5500A-SC600 Scope Option is configured, and no MOD3 code is entered.
  9. The MOD3 field may specify E only when the 5500A/EP option is configured. For a full description of the 5500A/EP, see the on-line help for the 5500A when “Edit Configuration” (F12) is selected from within the MET/CAL Editor.
  10. The M550 FSC RANGE and NOMINAL fields must specify the time limit when the MOD3 field specifies OM.

MOD4

This field specifies the type of test being performed as described in the MOD4 Field topic.

Additional Rules:

  1. The MOD4 field must specify N (Nominal Setup Test) when the MOD3 field specifies OM (Overload Measurement).
  2. N is inserted automatically in the MOD4 field when the MOD3 field specifies OM and no MOD3 code is entered.

CON

This field specifies the UUT connection.

2W | 2-wire
3W | 3-wire
4W | 4-wire
CW | 2-wire ohms compensated at the UUT terminals
DV | 2-wire using the external AC Divider
TD | Tunnel Diode Pulser Drive signal enabled
T1 | 10-turn Toroid Coil
T3 | 30-turn Toroid Coil
T5 | 50-turn Toroid Coil
FT | 5500A/COIL and Toroidal UUT
FX | 5500A/COIL and Non-toroidal UUT
L | 50 Ω Termination
blank | 1 MΩ Termination

Rules:

  1. 2W is inserted automatically in the CON field when the MOD3 field does not specify SC or S6 and no CON field code is entered.
  2. The CON field may specify 3W only when the RTD Cal mode is specified.
  3. The CON field may specify CW or 4W only when RTD Cal, Resistance, or Capacitance mode is specified.
  4. The CON field may specify DV only when AC Voltage mode is specified, the MOD2 field specifies SI, the MOD3 field does not specify E and the NOMINAL or MOD1 field specifies a voltage of 22mV or less.
  5. The CON field may specify T1, T3, T5, FT, or FX only when the MOD3 field does not specify E and DC Current or DC Power mode is specified or AC Current mode is specified and the MOD2 field specifies SI or AC Power mode is specified and either
    1. the M550 NOMINAL field specifies voltage and the 5500 MOD2 field specifies SI, or
    2. the M550 NOMINAL field specifies current and the M550 MOD2 field specifies SI. Refer to the Fluke 31/33 Instruction Manual figure 7, page 32 for directions for constructing a suitable toroid coil.
  6. The CON field may specify L only when the MOD3 field specifies SC or S6 and the MOD2 field does not specify SM.
  7. The CON field must specify L when the MOD2 field specifies LS, ED, or MK, and the MOD3 field specifies SC.
  8. The CON field must specify L when the MOD2 field specifies LS, ED, or M1, M2, M3, M4, F1, F2, F3, or F4, and the MOD3 field specifies S6.
  9. L is inserted automatically in the CON field when the MOD2 field specifies LS, ED, or MK, the MOD3 field specifies SC and no CON field code is entered.
  10. L is inserted automatically in the CON field when the MOD2 field specifies LS, ED, or M1, M2, M3, M4, F1, F2, F3, or F4, the MOD3 field specifies S6 and no CON field code is entered.
  11. The CON field must specify 2W when the MOD3 field specifies ZM or OM.

Use of Standard Memory Locations and Results Reporting

System memory locations MEM and MEM1 are used. For more information, refer to the Use of Standard Memory Registers topic.

Examples

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
# ----- Reset -----
  1.001  M550         *
  1.002  5500         *                                                 S
# ----- DC Voltage -----
  1.003  M550                                                              FL
  1.004  5500   20    19.99mV        2% 0.04U                              2W
# ----- DC Voltage w/Range Lock -----
  2.001  M550   RNGLK 3V
  2.002  5500   400   350.0mV        1.9% 0.4U                             2W
  3.001  M550         *
# ----- DC Voltage, TC Terminals -----
  3.002  5500         35mV                                           TC S  2W
# ----- AC Voltage -----
  3.003  5500   400   350.0mV        -2.8U +2.9U   60H            SI       2W
# ----- AC Voltage w/5725A Boost -----
  4.001  5500   400   350.0V         7.4U          20kH           SI BV    2W
# ----- AC Voltage w/External AC Divider -----
  5.001  5500         -37.78D        0.1U          100H           SI       DV
# ----- AC Voltage (Frequency Test) -----
  6.001  5500   1000  800.0H         0.1% 0.1U     300mV          SI       2W
# ----- Square Wave w/DC Offset -----
  7.001  M550                                      0.5Voff
  7.002  5500         1Vpp                         1kH            SQ    S  2W
# ----- Square Wave w/Duty Cycle Specified -----
  7.003  M550                        35pct
  7.004  5500         1Vpp                         1kH            SQ    S  2W
# ----- Square Wave (Duty Cycle Test) ------
  7.005  M550         1Vpp
  7.006  5500         30pct          2U            500H           SQ       2W
  8.001  M550         *
# ----- Triangle Wave -----
  8.002  5500         13mVpp                       10kH           TI    S  2W
# ----- Truncated Sine Wave -----
  8.003  5500         2.5mApp                      5kH            TS    S  2W
# ----- DC Current -----
  8.004  5500   4000  3500mA         9U                                    2W
# ----- AC Current at 5725A Output, Boost Off -----
  9.001  5500         35.00mA        0.37U         60H            SI BP    2W
# ----- AC Current at 5725A Output, Boost On -----
 10.001  5500   10    10A            0.12U         1kH            SI BC    2W
# ----- Dual DC Voltage -----
 11.001  M550         10mV
 11.002  5500         100mV          3%                              AX    2W
# ----- Dual AC Voltage w/5725A Boost -----
 12.001  M550         1V                                          SI AX
 12.002  5500         350Vp                        10kH           SI BV S  2W
# ----- Dual AC Voltage (Phase Test) ------
 12.003  M550         1Vpp                         1Vpp           SQ AX
 12.004  5500         30deg          1U            60H            SQ       2W
# ----- Dual AC Voltage (Harmonics) ------
 13.001  M550   H2    100V                                        SI BV
 13.002  5500         0D             1U            60H            SI AX    2W
 14.001  M550   HX3   1Vpp                                        SI AX
 14.002  5500         1Vpp           1U            60H            SI       2W
 15.001  M550         *
# ----- DC Power (Volts and Amps) -----
 15.002  M550         1mV                                               O  FL
 15.003  5500         1mA            1%                                    2W
# ----- AC Power (Volts and Amps) -----
 16.001  M550         1mA            60deg                        SI
 16.002  5500         1V                           400H           SI    S  2W
# ----- AC Power (Watts and Volts) w/Displacement Power Factor -----
 16.003  M550   LEAD  1V             0.998                        SI
 16.004  5500   20    19mW           1%            60H            SI       2W
# ----- AC Power (Watts and Vpp) w/Phase Specified -----
 17.001  M550         1Vpp           -45deg                       SI
 17.002  5500   20    1mW            1U            400H           SI       2W
# ----- AC Power (Harmonics) ------
 18.001  M550   H2    45D                                         SI BV
 18.002  5500         100W           1U            60H            SI       2W
 19.001  M550   HX3   1mApp                                       SI
 19.002  5500         1Vpp           1U            60H            SI       2W
 20.001  M550         *
# ----- Resistance -----
 20.002  5500   400   390.0Z         0.4% 0.1U                             CW
 21.001  5500   4     3.900MZ        0.05U                                 2W
# ----- Capacitance ----
 22.001  5500   10    1.100uF        2% 0.002U                             2W
# ----- Temperature Measurement -----
 23.001  5500         1200.0degF                                  _J TM N  2W
# ----- Temperature Stimulus -----
 23.002  M550   TCREF 0degC
 23.003  5500         50degC         1%                           _K TC    2W
 24.001  M550         *
 24.002  5500         45degC                                      R1    S  3W

5500A-SC300 Scope Option

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
# ----- DC Voltage -----
  1.001  5500   20    19.99mV        4%                              SC
# ----- AC Voltage (Scope Square Wave) -----
  2.001  5500   400   350.0mV        50U           60H            ZQ SC
# ----- AC Voltage (ScopeMeter Wave) -----
  3.001  5500         100Vpp                       1kH            SM SC S
# ----- AC Voltage (Frequency Test) -----
  3.002  5500   1000  800.0H         0.1% 0.1U     300mV          ZQ SC
# ----- Edge Signal (Scope Output) -----
  4.001  5500         0.5Vpp                       1MH            ED SC S  L
# ----- Leveled Sine Wave -----
  4.002  5500         200mVpp                      50kH           LS SC S  L
# ----- Marker Signal -----
  4.003  M550                                                              2T
  4.004  5500         1uT                                         MK SC S  L
# ----- Wavegen -----
  4.005  5500         5V                           1kH            SI SC S
# ----- Wavegen w/DC Offset -----
  4.006  M550                                      0.5Voff
  4.007  5500         1Vpp                         1kH            TI SC S
  4.008  M550         *

5500A-SC600 Scope Option

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
# ----- DC Voltage -----
  1.001  5500   20    19.99mV        4%                              S6
# ----- AC Voltage (Positive Scope Square Wave) -----
  2.001  5500   400   350.0mV        50U           60H            ZQ S6
# ----- AC Voltage (Negative Scope Square Wave) -----
  3.001  5500         100Vpp                       1kH            ZN S6 S
# ----- AC Voltage (Frequency Test) -----
  3.002  5500   1000  800.0H         0.1% 0.1U     300mV          ZQ S6
# ----- Edge Signal (Scope Output) -----
  4.001  5500         0.5Vpp                       1MH            ED S6 S  L
# ----- Leveled Sine Wave -----
  4.002  5500         200mVpp                      50kH           LS S6 S  L
# ----- Spike Marker Signal -----
  4.003  M550                                                              2T
  4.004  5500         1uT                                         M1 S6 S  L
  4.005  M550         *
# ----- Square Marker Signal -----
  4.006  5500         1mT                                         M2 S6 S  L
# ----- 20% Duty Cycle Square Marker Signal -----
  4.007  5500         5uT                                         M3 S6 S  L
# ----- Sinusoid Marker Signal -----
  4.008  5500         2nT                                         M4 S6 S  L
# ----- Wavegen -----
  4.009  5500         5V                           1kH            SI S6 S
# ----- Wavegen w/DC Offset -----
  4.010  M550                                      0.5Voff
  4.011  5500         1Vpp                         1kH            TI S6 S
# ----- NTSC Video -----
  4.012  M550   ODD
  4.013  5500         1Vp                          262LM          F1 S6 S  L
  4.014  M550         *
# ----- PAL Video -----
  4.015  5500         50pct                        400LM          F2 S6 S  L
# ----- PAL-M Video -----
  4.016  M550   EVEN
  4.017  5500         -140IRE                      1LM            F3 S6 S  L
  4.018  M550         *
# ----- SECAM Video -----
  4.019  5500         -100pct                      622LM          F4 S6 S  L
# ----- Pulse Wave (Slew Pulse Width) -----
  4.020  M550   PER   200nT
  4.021  5500         5.0nT                        2.5Vpp         PU S6 N  L
# ----- Pulse Wave (Slew Pulse Repetition Frequency) -----
  4.022  M550   PULSE 10nT
  4.023  5500         1.00kH                       2.5Vpp         PU S6 N  L
  4.024  M550         *
# ----- Impedance Measurement (50 Ohm) -----
  4.025  5500         50Z            1U                              ZM    2W
# ----- Impedance Measurement (1 MOhm) -----
  5.001  5500         1.000MZ        1U                              ZM    2W
# ----- Impedance Measurement (Capacitance) -----
  6.001  5500         10pF                                           ZM N  2W
# ----- 50 Ohm Input Impedance Overload -----
  6.002  M550   LIMIT 10T
  6.003  5500         5V                                             OM N  2W
  6.004  EVAL   -e MEM == 0 : 50 Ohm overload protection trip not expected
  7.001  M550   LIMIT 10T
  7.002  5500         7V                                             OM N  2W
  7.003  EVAL   -e MEM : 50 Ohm overload protection trip expected


M550

Auxiliary Instrument Setup FSC

Description

The M550 FSC provides the additional program functions for the Fluke 5500A and 5500E Calibrators which are not addressed by the 5500 FSC. These functions include Range Locking, DC Offset, Thermocouple External Temperature Reference, Phase, Power Factor, Duty Cycle, voltage and/or current for power stimulus, and voltage of the second signal for dual voltage output.

The following functions are available with 5500A-SC600 Scope Option:

  • Time limit for UUT 50 Ohm input overload protection measurement.
  • Odd frame for NTSC or PAL-M video signals.
  • Trigger output

Parameters

For a description of the 5500A/5500E Calibrator operating modes referenced in this section, see Table 1 in the 5500 Instrument FSC description.

When a blank M550 statement is entered, a "*" is inserted automatically in the NOMINAL field. See NOMINAL field parameter for a description of "*".

Units Symbol | Name | Quantity
A | Amps | current
Ap | Amps peak | current
App | Amps peak to peak | current
D | dBm | decibels
H | Hertz | frequency
T | Time | period, pulse width, or time limit
V | Volts | voltage or video amplitude
Vp | Volts peak | voltage
Vpp | Volts peak to peak | voltage
Voff | Volts offset | DC offset
deg | degrees | phase
degC | degrees Celsius | temperature
degF | degrees Fahrenheit | temperature
pct | percent | duty cycle or video amplitude

M550 FSC RANGE, NOMINAL, MOD1, MOD2, and MOD3 Rules

5500A/5500E Mode | M550 RANGE | M550 NOMINAL | M550 TOL | M550 MOD1 | M550 MOD2 1 | M550 MOD3 2
DC Voltage | [RNGLK | V]
AC Voltage | [V|Vp|Vpp]
[V|Vpp] | Voff
[pct] | [Voff]
DC Current | [RNGLK | A]
TC Cal | [TCREF | degC|degF]
TC Meas | [TCREF | degC|degF]
Dual DC Voltage3 | V | [AX]
Dual AC Voltage3 | [Hn] | V|Vp|Vpp|D | [deg] | SI | [AX|BV]
[HXn] | V|Vp|Vpp|D | [deg] | SI | [AX|BV]
[Hn] | V|Vp|Vpp|D | [V|Vp|Vpp|D] | SI | [AX|BV]
[HXn] | V|Vp|Vpp|D | [V|Vp|Vpp|D] | SI | [AX|BV]
V|Vp|Vpp | [deg] | SQ|TI|TS | [AX]
V|Vp|Vpp | [V|Vp|Vpp] | SQ|TI|TS | [AX]
DC Power3 | V
A | [BC|BP]
AC Power3 | [LEAD|LAG] | V|Vp|Vpp|D | [dpf] | SI | [BV]
[LEAD|LAG] | A|Ap|App | [dpf] | SI | [BC|BP]
[Hn] | V|Vp|Vpp|D | [deg] | SI | [BV]
[HXn] | V|Vp|Vpp|D | [deg] | SI | [BV]
[Hn] | A|Ap|App | [deg] | SI | [BC|BP]
[HXn] | A|Ap|App | [deg] | SI | [BC|BP]
[Hn] | V|Vp|Vpp|D | [A|Ap|App] | SI | [BV]
[HXn] | V|Vp|Vpp|D | [A|Ap|App] | SI | [BV]
[Hn] | A|Ap|App | [V|Vp|Vpp|D] | SI | [BC|BP]
[HXn] | A|Ap|App | [V|Vp|Vpp|D]] | SI | [BC|BP]
V|Vp|Vpp|D | [deg] | SQ|TI|TS
V|Vp|App|D | [A|Ap|App] | SQ|TI|TS | [BC|BP]
  1. See MOD2 parameter for description of these specification codes and rules.
  2. See MOD3 parameter for description of these specification codes and rules.
  3. 5500E only.
Blank entries in the above table are significant and must be blank. FSC field inter-dependencies not expressed in this table are listed under "Rules" for the appropriate parameter.

5500 FSC NOMINAL, MOD1, MOD2, and MOD3 Rules for 5500A-SC300

M550 RANGE, NOMINAL, TOLERANCE, MOD1, MOD2, and MOD3 fields are not used for 5500A-SC300.

5500A Mode | M550 RANGE | M550 NOMINAL | M550 TOLERANCE | M550 MOD1 | M550 MOD2 | M550 MOD3
AC Voltage (WAVEGEN) |  |  |  | [OFFSET] |  |
AC Voltage (PULSE) | PER|PULSE | H|T |  |  |  |
Video (VIDEO) | [ODD|EVEN] |  |  |  |  |
Overload Meas (OVERLD) | LIMIT | T |  |  |  |
Blank entries in the above table are significant and must be blank. FSC field inter-dependencies not expressed in this table are listed under "Rules" for the appropriate parameter. M550 RANGE, NOMINAL, TOLERANCE, MOD1, MOD2, and MOD3 fields are not used for 5500A-SC600 operating modes not listed.

RANGE

This field specifies one of the following:

RNGLK | Range Lock
TCREF | Thermocouple Reference
LEAD | Leading
LAG | Lagging
Hn | Primary output is a harmonic, 1 to 51
HXn | Secondary output is a harmonic, 1 to 51
PULSE | Pulse Width
PER | Pulse Period
LIMIT | Time Limit (Overload Measurement)
ODD | Odd Frame (NTSC or PAL-M video)
EVEN | Even Frame (NTSC or PAL-M video)
blank | field not applicable

Rules:

  1. When the RANGE field specifies LEAD or LAG, the TOLERANCE field must specify the Displacement Power Factor.
  2. The primary output is always the Normal output. The secondary output is typically the Aux output, but may be the 5725A current output is the case of AC Power with boosted current.
  3. The RANGE field may specify PULSE or PER only when the 5500 FSC MOD2 field specifies PU.
  4. The RANGE field must specify PULSE or PER when the 5500 FSC MOD2 field specifies PU.
  5. The RANGE field may specify ODD or EVEN only when the 5500 FSC MOD2 field specifies F1 or F3.
  6. The RANGE field must specify ODD or EVEN when the 5500 FSC MOD2 field specifies F1 or F3.
  7. The RANGE field may not specify RNGLK when the 5500 MOD3 field specifies TC, SC, or S6.

NOMINAL

This field specifies one of the following:

  • Range lock selection value when RANGE field is RNGLK
  • Thermocouple Reference when RANGE field is TCREF
  • Pulse Period or Pulse Repetition Frequency when RANGE field is PER
  • Pulse Width when RANGE field is PULSE
  • Signal amplitude for AC Voltage, Dual DC Voltage, Dual AC Voltage,

DC Power, or AC Power

"*" | reset to default values
blank | field not applicable

Rules:

  1. The NOMINAL field may specify a Voltage or Current range selection value only when the RANGE field specifies RNGLK.
    2. Voltage Range Selection Value | Locked Range
    > 0mV to 330mV | 330mV DC
    > 330mV to 3.3V | 3.3V DC
    > 3.3V to 33V | 33V DC
    > 33V to 330V | 330V DC
    > 330V to 1020V | 1000V DC
    Current Range Selection Value | Locked Range
    0mA to 3.3mA | 3.3mA DC
    > 3.3mA to 33mA | 33mA DC
    > 33mA to 330mA | 330mA DC
    > 330mA to 2.2A | 2.2A DC
    > 2.2A to 11A | 11A DC1
    1. The 11A range may be locked only when the 5500 FSC MOD3 field does not specify BP (Boost Port).
  2. When the NOMINAL field specifies voltage and Dual DC Voltage or Dual AC Voltage mode is specified, either the MOD3 field must specify AX or the 5500 FSC MOD3 field must specify AX.
  3. The NOMINAL field may specify Thermocouple Reference only when the RANGE field specifies TCREF. In this case, the UUT is compensating for its thermocouple junction temperature and Thermocouple Reference should be set to the temperature of the UUT's junction. Thermocouple Reference must be in the same units as the temperature specified in the 5500 FSC NOMINAL field.
  4. When the NOMINAL field does not specify Thermocouple Reference, the 5500A/5500E internal reference is used and the UUT is not compensating for its thermocouple junction temperature.
  5. When the NOMINAL field contains only units, the value is taken from MEM.
  6. When the NOMINAL field contains only units and the MOD1 field is not blank, the MOD1 field must specify a value.
  7. When the NOMINAL field specifies reset "*", all other fields must be blank.

TOLERANCE

This field specifies phase or duty cycle entered as

numeric[prefix]units symbol or displacement power factor entered as numeric.

Rules:

  1. The TOLERANCE field may specify Displacement Power Factor only when the RANGE field specifies LEAD or LAG.
  2. The TOLERANCE field may specify Duty Cycle only when AC Voltage mode is specified, 5500 FSC MOD2 field specifies SQ, and the 5500 FSC MOD3 field is blank.

MOD1

This field specifies DC offset for AC Voltage or one amplitude for AC Power or Dual AC Voltage entered as:

[numeric][prefix]units symbol

Rules:

  1. The MOD1 field may specify voltage or current only when the 5500 NOMINAL field specifies phase.
  2. When the MOD1 field specifies voltage with units of "D", the 5500 FSC MOD2 field must specify SI.
  3. When the MOD1 field specifies voltage with units of "Vp" or "Vpp" or current with units of "Ap" or "App", the 5500 FSC MOD2 field must specify SI, SQ, TI, or TS.
  4. When the MOD1 field contains only units, the value is obtained from memory register MEM. In this case the NOMINAL field MUST contain a value.
  5. The MOD1 field may specify DC offset only when AC Voltage mode is specified, the 5500 FSC MOD3 field does not specify E, and the 5500 FSC NOMINAL field units are not decibels.
  6. When the MOD1 field specifies DC Offset, either the voltage specified in the 5500 NOMINAL or MOD1 field must be less than 33V or the DC Offset value must be zero.
  7. When the MOD1 field specified DC Offset and the 5500 FSC NOMINAL field specifies duty cycle, the specified DC Offset must be zero.
  8. When the MOD1 field specifies DC Offset other than 0V, and the TOLERANCE field specifies duty cycle, the duty must be 50%.
  9. When the MOD1 field specifies DC Offset and the 5500 FSC NOMINAL field specifies duty cycle, the specified DC Offset must be zero.

MOD2

This field specifies the waveform for the output specified in the NOMINAL field.

SI | Sine wave
SQ | Square wave
TI | Triangle wave
TS | Truncated sine wave
blank | DC or field not applicable

MOD3

This field specifies the calibrator output mode:

AX | Auxiliary Voltage
BV | Boost Voltage
BC | Boost Current
BP | Boost Port (Use Boost Amplifier port for non-boosted current)
blank | no boost, default port, or field not applicable

Rules:

  1. The MOD3 field must specify AX when Dual DC Voltage or Dual AC Voltage mode is specified and the 5500 FSC MOD3 field does not specify AX.
  2. The MOD3 field may specify BV only when the following conditions exist:
    1. AC Power or Dual AC Voltage mode is specified.
    2. The MOD2 field specifies "SI".
    3. Voltage is specified in the NOMINAL field.
    4. The voltage specified in the NOMINAL field is within the range of the 5725A Boost Amplifier.
    5. The 5500 FSC MOD3 field does not specify BV, BC, or BP.
  3. The MOD3 field may specify BC only when the following conditions exist:
    1. DC Power or AC Power mode is specified.
    2. The current is specified in the NOMINAL field.
    3. The specified current is within the range of the 5725A Boost Amplifier with boost on (see Table 1).
    4. The 5500 FSC MOD3 field does not specify BC, BV, or BP.
  4. The MOD3 field may specify BP only when the following conditions exist:
    1. DC Power or AC Power mode is specified.
    2. The current is specified in the NOMINAL field.
    3. The specified current is with the range of the 5725A Boost Amplifier with boost off (see Table 1).
    4. The 5500 FSC MOD3 field does not specify BC, BV, or BP.

MOD4

This field controls whether or not the NORMAL and AUX "LO" terminals are tied together for DC Power, AC Power, Dual DC Voltage, and Dual AC Voltage modes.

blank | Lows Shorted or field not applicable
O | Lows Open

Rules:

  1. The MOD4 field may specify "O" only when the mode is DC Power, AC Power, Dual DC Voltage, or Dual AC Voltage, and the M550 CON specifies "EL" or "FL".

CON

This field controls whether or not the NORMAL and AUX "LO" terminals are tied to Earth and the trigger output.

blank | default or field not applicable
EL | Low tied to Earth
FL | Floating Low
1T | Trigger Output on, Normal mode
2T | Trigger Output on, 1/10 of output rate
3T | Trigger Output on, 1/100 of output rate

Rules:

  1. The CON field specification is ignored, and a floating low is used, when any of the following conditions exist:
    1. Resistance, Capacitance, RTD Calibration, or Thermocouple Measurement mode is specified.
    2. AC Current or AC Power mode is specified with a current less than 330uA.
  2. A CON field specification of 1T, 2T, or 3T is only applicable (is ignored otherwise) when the 5500 MOD2 field specifies ZQ, ZN, ED, MK, M1, M2, M3, and M4.
  3. When the CON is field is blank, a floating low is used.

Examples

See 5500 FSC.


O_CAL

Description

The O_CAL FSC controls the following oscilloscope calibration options and oscilloscope calibrators:

  • 5080A/SC
  • 5500A-SC
  • 5500A-SC300
  • 5502A-SC300
  • 5520A-SC300
  • 5502A-SC600
  • 5500A-SC600
  • 5520A-SC600
  • 5522A-SC600
  • 5520A-SC1100
  • 5522A-SC1100
  • 5800A
  • 5820A

The actual hardware required is based on parameter and parameter values.

Frequency | 5500A-SC & 55x0A-SC300 | 55xxA-SC600 | 552xA-SC1100 | 5800A | 5820A
> 200 MHz | x | x | x | x | x
> 300 MHz |  | x | x | x | x
> 600 MHz |  |  | x | w/GHz | w/GHz
> 1100 MHz |  |  |  | w/GHz | w/GHz

Mode/Parameter | 5080A/SC | 5500A-SC & 5500A-SC300 | 5520A-SC300 & 5502A-SC300 | 55xxA-SC600 & 552xA-SC1100 | 5800A | 5820A
Voltage/Polarity |  | x |  | x | x | x
Edge/FastEdge |  |  |  |  | w/GHz | w/GHz
Edge/TDP |  |  |  | x | x | x
Marker/Shape | x |  | x | x | x | x
WaveGenerator |  | x | x | x | x | x
Video |  |  |  | x | x | x
Pulse/TriggerSkew |  |  |  |  | w/GHz | w/GHz
MeasureImpedance |  |  |  | x | x | x
MeasureVoltage |  |  |  |  |  | x
Current |  |  |  |  |  | x
Overload |  |  |  | x | x | x
Channel |  |  |  |  | w/5Ch | w/5Ch

Run Time

The O_CAL FSC is mapped to one of the following calibrators, in the order listed, if found in the instrument configuration:

  • 5820A with GHz Option
  • 5800A with GHz Option
  • 5820A
  • 5800A
  • 5522A with SC1100 installed
  • 5520A with SC1100 installed
  • 5522A with SC600 installed
  • 5520A with SC600 installed
  • 5502A with SC600 installed
  • 5500A with SC600 installed
  • 5520A with SC300 installed
  • 5502A with SC300 installed
  • 5500A with SC300 or SC installed
  • 5080A with SC installed

If none of the calibrators and/or options is configured, an error is generated.

Compile Time

The mapping selection is the same as for Run Time with the following exception. If none of the calibrator and/or options is configured, 5820A specifications are used for functionality, limits, and accuracy.

If the calibrator is to be controlled via its serial port, do not use the PORT FSC port configuration special construction, [P9600,N,...], to set the baud rate, parity, etc. of the port used to control the calibrator. MET/CAL executes a "Test" function for each System Instrument prior to executing any procedure statements, therefore the settings of the port used to controlling the calibrator must be set correctly before a procedure is executed. If the calibrator is connected to a standard serial port (COM1, COM2, ..., COM16), select the "Ports" application in the Windows control panel to choose the proper settings.

Parameters

An NVI FSC statement consists of one or more parameters. A parameter consists of a name and a value. Each parameter must be separated by a semicolon and/or one or more spaces. A single NVI FSC statement can encompass more than one physical line as long as the line numbers are the same. However each parameter name and its value must occur on one line. A single line can accommodate up to 256 characters including the statement number and FSC. Note that characters above ASCII 128 count as 2 characters.

Syntax:

parameter[separatorparameter]

parameter::= [parameter_prefix]parameter_name[[sp]=[sp]parameter_value]

separator::= ;[sp] | sp

parameter_prefix ::=+ | @

sp::= one or more spaces

parameter_name::= see the Parameter Names section

parameter_value::=dimensionless number | dimensioned number | discrete_list

dimensionless number::=NRf

dimensioned number::=NRf[sp][prefix]units

discrete_list::=see the Parameter Names section

prefix::=y | z | a | f | p | n | u | m | k | M | G | T | P | E | Z | Y

Definitions:

|
Denotes "or" (i.e. A | B is A or B)
[ ]
Denotes an optional syntax element, except in examples. In examples [ ] enclose a special construction.
+
Designates the parameter as the Evaluation Quantity
@
Designates the parameter as the Modifier Quantity

Examples:

The following three O_CAL statements are identical with respect to the O_CAL FSC:

Statement #1

  1.001  O_CAL        Mode = LeveledSine
  1.001  O_CAL        +Voltage = 600mVpp; @Frequency = 50kHz

Statement #2

1.002 O_CAL Mode = LevSine; +Volt = 600 mVpp; @Freq = 50 kHz

Statement #3

  1.003  O_CAL        Apply
  1.003  O_CAL        Mode = LeveledSine
  1.003  O_CAL        +Voltage = 600 mVpp
  1.003  O_CAL        @Frequency = 50 kHz

Rules:

  1. One and only one parameter must be designated as the Evaluation Quantity in a O_CAL Apply, Setup, or Slew statement.
  2. At most one parameter may be designated as the Modifier Quantity in a O_CAL Apply, Setup, or Slew statement.
  3. Parameter values may be taken from a MET/CAL memory register using a special construction.
  4. When a O_CAL Apply statement is executed, the value of the Evaluation Quantity is copied to memory register MEM1 in specified units. Example:

    1.001 O_CAL Mode = Volt; +Volt = 250 mV; Apply

    After the O_CAL statement is executed the value of MEM1 is 250.

  5. When a O_CAL Operate statement is executed, the value of the Evaluation Quantity designated in the previous Setup or Apply statement is copied to memory register MEM1 in specified units. Example:

    6.   1.001 O_CAL Mode = Volt; +Volt = 250 mV; Setup
  1.002 O_CAL Mode = Volt; +Volt = 250 mV; Operate

    After the O_CAL Operate statement is executed the value of MEM1 is 250.

  6. When a O_CAL Measure statement is executed, the value of the Evaluation Quantity is copied to memory register MEM in specified units. Example:

    1.001 O_CAL Mode = MeasImp; +Res = 1 MOhm; Measure

    After the O_CAL statement is executed the value of MEM is reading (Example 9.98).

  7. When a O_CAL Read statement is executed, the value of the Evaluation Quantity designated in the previous Setup or Measure statement is copied to memory register MEM in specified units. Example:

      1.001 O_CAL Mode = MeasImp; +Res = 1 MOhm; Setup
  1.001 O_CAL Mode = MeasImp; +Res = 1 MOhm; Read

    After the O_CAL statement is executed the value of MEM is reading (Example 1.01).

  8. When a O_CAL Slew statement is executed, the Evaluation Quantity designates the slew quantity.
  9. When a O_CAL Slew statement is executed, the final slew value is copied to memory register MEM1 in units of the Evaluation Quantity. Example:

    1.001 O_CAL Mode = Volt; +Volt = 50 mVpp; @Freq = 1 MHz; Slew

    Operator slews the O_CAL output to 50.15 mV. After the O_CAL Slew statement is executed the value of MEM is 50.15.

  10. When an O_CAL Slew statement is executed, the Modifier Quantity is concatenated to the Evaluation Quantity in the automatic slew message. Note, the automatic slew message is not displayed when ASK- N is in effect. Example:

      1.001 ASK+ N
  1.002 O_CAL Mode = LevSine; +Volt = 600mVpp; @Freq = 200MHz; Slew

    "Adjust stimulus for a UUT reading of 600 mVpp at 200 MHz."

    No Modifier Quantity designated.

    1.002 O_CAL Mode = LevSine; +Volt = 600mVpp; Freq = 200MHz; Slew

    "Adjust stimulus for a UUT reading of 600 mVpp."

    Automatic slew message inhibited.

      1.001 ASK- N
  1.002 O_CAL Mode = LevSine; +Volt = 600mVpp; Freq = 200MHz; Slew

    No automatic slew message generated, use MESS FSC.

Parameter Names

Parameter names consist of single words or compound words. Each word in a parameter name can be entered in long form (as shown below), or in short form. The short form is the first 4 characters of the long form, with the following exceptions:

  1. If the long form is greater than four characters, and the last character or the short form is a vowel, the short form is three characters.
  2. If the long form is four characters or less, the short form is the long form even if it ends in a vowel.

Compound parameter names can be entered in any combination of long and short forms. Example, ExternalReference can be entered using any of the following forms:

  • MeasureImpedance
  • MeasureImp
  • MeasImpedance
  • MeasImp

Action Parameters

  • Apply
  • Local
  • Operate
  • Read
  • Reset
  • Setup
  • Standby

General Parameters

  • Amplitude
  • Capacitance
  • Channel
  • Current
  • FallTime
  • FastEdge
  • Field
  • Format
  • Frequency
  • HV
  • LineMarker
  • Mode
  • Offset
  • OutputImpedance
  • Period
  • Polarity
  • PulseWidth
  • Resistance
  • RiseTime
  • Shape
  • TimeLimit
  • TripTime
  • TriggerChannel
  • TriggerOutput
  • TriggerRate
  • TriggerSkew
  • TunnelDiodePulser
  • Voltage
  • Waveform

Mode/Parameter Rules

VOLTAGE OUTPUT

Mode = Voltage | Volt

Required Parameters:

  • Mode
  • Voltage
  • OutputImpedance
Optional Parameters | Default
Frequency | Period | NA
HV | NA 1
Polarity | Positive 2
Channel | NA 3
TriggerChannel | NA 3
TriggerOutput | Off 4
Apply | Setup | Operate | Slew | Apply
  1. 5080A/SC, 5500A-SC, and 55x0A-SC300 only.
  2. 5500A-SC, 5500A-SC300, 55xxA-SC600, 552xA-SC1100, and 58xxA only.
  3. 58xxA with 5 Channel option only.
  4. 55xxA-SC600, 552xA-SC1100, and 58xxA only.

EDGE

Mode = Edge

Required Parameters:

  • Mode
  • Voltage
  • Frequency | Period
Optional Parameters | Default
RiseTime | NA
FallTime | NA
FastEdge | NA 1
Channel | NA 2
TriggerChannel | NA 2
TriggerOutput | Off
TunnelDiodePulser | NA 3
Apply | Setup | Operate | Slew | Apply
  1. 58xxA with GHz option only.
  2. 58xxA with 5 Channel option only.
  3. 55xxA-SC600, 552xA-SC1100, and 58xxA only.

LEVELED SINE WAVE

Mode = LeveledSine

Required Parameters:

  • Mode
  • Voltage | Amplitude
  • Frequency | Period
Optional Parameters | Default
Channel | NA 1
Apply | Setup | Operate | Slew | Apply
  1. 5800A and 5820A with 5 Channel option only.

TIME MARKER

Mode = Marker | Mark

Required Parameters:

  • Mode
  • Period | Frequency
Optional Parameters | Default
Channel | NA 1
TriggerChannel | NA 1
TriggerOutput | Off
TriggerRate | NA
Shape | Based on period/frequency 2
Apply | Setup | Operate | Slew | Apply
  1. 58xxA with 5 Channel option only.
  2. 5080A/SC, 5520A-SC300, 55xxA-SC600, 552xA-SC1100, and 58xxA only.

WAVE GENERATOR (5500A-SC, 55x0A-SC300, 55xxA-SC600, 552xA-SC1100, and 58xxA only)

Mode = WaveGenerator | WaveGen

Required Parameters:

  • Mode
  • Voltage
  • Frequency | Period
  • OutputImpedance
Optional Parameters | Default
Channel | NA 1
Offset | 0 V
Waveform | Sine
Apply | Setup | Operate | Slew | Apply
  1. 58xxA with 5 Channel option only.

VIDEO (55xxA-SC600, 552xA-SC1100, and 58xxA only)

Mode = Video | Vid

Required Parameters:

  • Mode
  • Amplitude | Voltage
  • LineMarker
  • Format
Optional Parameters | Default
Channel | NA 1
Field | NA
Polarity | Positive
Apply | Setup | Operate | Slew | Apply
  1. 5800A and 5820A with 5 Channel option only.

1 ns PULSE GENERATOR (55xxA-SC600, 552xA-SC1100, and 58xxA only)

Mode = Pulse | Puls

Required Parameters:

  • Mode
  • Voltage
  • Period | Frequency
  • PulseWidth
Optional Parameters | Default
Channel | NA 1
TriggerChannel | NA 1
TriggerOutput | Off
TriggerRate | NA
TriggerSkew | 0 ns 2
Apply | Setup | Operate | Slew | Apply
  1. 5800A and 5820A with 5 Channel option only.
  2. 58x0A with GHz option only.

OSCILLOSCOPE INPUT RESISTANCE AND CAPACITANCE MEASUREMENT (55xxA-SC600, 552xA-SC1100, 58xxA only)

Mode = MeasureImpedance | MeasureImp | MeasImpedance | MeasImp

Required Parameters:

  • Mode
  • Resistance | Capacitance
Optional Parameters | Default
Channel | NA 1
Measure | Setup | Read | Measure
  1. 5800A and 5820A with 5 Channel option only.

DC VOLTAGE MEASUREMENT (5820A only)

Mode = MeasureVoltage | MeasureVolt | MeasVoltage | MeasVolt

Required Parameters:

  • Mode
  • Voltage
Optional Parameters | Default
Channel | NA 1
Measure | Setup | Read | Measure
  1. 5820A with 5 Channel option only.

CURRENT OUTPUT

Mode = Current | Curr

Required Parameters:

  • Mode
  • Current
Optional Parameters | Default
Frequency | Period | NA
Channel | NA 1
Apply | Setup | Operate | Slew | Apply
  1. 5800A and 5820A with 5 Channel option only.

OVERLOAD MEASUREMENT (55xxA-SC600, 552xA-SC1100, and 58xxA only)

Mode = Overload | Over

Required Parameters:

  • Measure
  • Mode
  • Voltage
  • TimeLimit
  • TripTime
Optional Parameters | Default
Frequency | NA
Channel | NA 1
  1. 5800A and 5820A with 5 Channel option only.

Parameter Definitions and Values

Apply

Purpose | This action sets up the instrument and enables the output.
Syntax | Apply
Rules | When Apply is specified, no other action may be specified.
Example | Apply

Amplitude

Purpose | This parameter specifies the leveled sine amplitude in dBm, or the video signal amplitude in % or IRE.
Syntax | [+|@]Amplitude[sp]=[sp]numeric value[sp]units units ::= dBm | % | IRE
Rules | N/A
Example | +Amplitude = 150 %

Capacitance

Purpose | This parameter specifies the expected UUT input capacitance.
Syntax | +Capacitance[sp]=[sp]numeric value[sp][prefix]F
Rules | N/A
Example | +Capacitance = 50 pF

Channel

Purpose | This parameter specifies the output or input channel
Syntax | Channel[sp]=[sp]integer
Rules | Legal values are 1, 2, 3, 4, or 5.
Example | Channel = 2

Current

Purpose | This parameter specifies the output current.
Syntax | [+|@]Current[sp]=[sp]numeric value[sp][prefix]units units = A | Ap | App
Rules | Legal values are 1, 2, 3, 4, or 5.
Example | Current = 1000 uA

FallTime

Purpose | This parameter specifies the expected fall time.
Syntax | +FallTime[sp]=[sp]numeric value[sp][prefix]s
Rules | N/A
Example | +FallTime = 500 ps

FastEdge

Purpose | This parameter enables Fast Edge in Edge mode.
Syntax | FastEdge
Rules | N/A, Not supported for 5800A
Example | FastEdge

Field

Purpose | This parameter specified the video field.
Syntax | Field[sp]=[sp]field field = Even | Odd
Rules | N/A
Example | Field = Odd

Format

Purpose | This parameter specified the video format.
Syntax | Format[sp]=[sp]format format ::= NTSC | PAL | PAL-M | SECAM
Rules | N/A
Example | Format = NTSC

Frequency

Purpose | This parameter specifies the output frequency.
Syntax | [+|@]Frequency[sp]=[sp]numeric value[sp][prefix]Hz
Rules | When Frequency is specified, Period cannot be specified.
Example | @Freq = 50 Hz

HV

Purpose | This parameter specifies the 5080A/SC, 5500A-SC, and 55x0A-SC300 Voltage Mode with an amplitude from 95 to 105 Vpp. For a full description, see the Oscilloscope Calibration option documentation.
Syntax | HV
Rules | N/A
Example | HV

LineMarker

Purpose | This parameter specified the video line marker.
Syntax | LineMarker[sp]=[sp]integer
Rules | N/A
Example | LineMarker = 50

Local

Purpose | This action puts the calibrator in local mode.
Syntax | Local
Rules | When Local is specified, no other parameters may be specified
Example | Local

Mode

Purpose | This parameter selects the instrument mode.
Syntax | mode = Current | Curr | Edge | LeveledSine | LevSine | Marker | Mark | MeasureImpedance | MeasureImp | MeasImpedance | MeasImp | MeasureVoltage | MeasureVolt | MeasVolage | MeasVolt | Overload | Over | Pulse | Puls | Video | Vid | Voltage | Volt | WaveGenerator | WaveGen
Rules | N/A
Example | Mode = Video

Offset

Purpose | This parameter specifies the wave generator offset.
Syntax | [+|@]Offset[sp]=[sp]numeric value[sp][prefix]V
Rules | N/A
Example | +Offset = 1 V

Operate

Purpose | This parameter turns the output on.
Syntax | Operate
Rules | When Operate is specified, no other parameters are allowed.
Example | Operate

OutputImpedance

Purpose | This parameter specifies the output impedance.
Syntax | [@]OutputImpedance[sp]=[sp]numeric value[sp][prefix]Ohm[s]
Rules | Legal values are 50 Ohms and 1 MOhm
Example | OutpImp = 50 Ohms

Period

Purpose | This parameter specifies the period.
Syntax | [+|@]Period[sp]=[sp]numeric value[sp][prefix]s
Rules | When Period is specified, Frequency cannot be specified.
Example | @Per = 1 ms

Polarity

Purpose | This parameter specifies polarity of Voltage mode AC output or Video amplitude.
Syntax | Polarity[sp]=[sp]polarity polarity = Positive | Negative
Rules | N/A
Example | Polarity = Neg

PulseWidth

Purpose | This parameter specifies the pulse width.
Syntax | [+|@]Period[sp]=[sp]numeric value[sp][prefix]units units = Hz | s
Rules | N/A
Example | +PulseWidth = 100 ns

Reset

Purpose | This parameter resets the calibrator.
Syntax | Reset
Rules | When Reset is specified, no other parameters are allowed.
Example | Reset

Resistance

Purpose | This parameter specifies the expected UUT input resistance.
Syntax | Resistance[sp]=[sp]numeric value[sp][prefix]Ohm[s]
Rules | Legal values are 50 Ohms and 1 MOhm.
Example | Resistance = 1 MOhms

RiseTime

Purpose | This parameter specifies the expected rise time.
Syntax | +RiseTime[sp]=[sp]numeric value[sp][prefix]s
Rules | N/A
Example | +RiseTime = 700 ps

Setup

Purpose | This action causes the instrument to be setup only.
Mode

TC Measurement

  • No reading is Returned

All other modes

  • The instrument remains in standby.
Syntax | Setup
Rules | When Setup is specified, no other action may be specified.
Example | Setup

Shape

Purpose | This parameter specifies the Marker shape.
Syntax | Shape[sp]=[sp]shape shape = Sine|Spike|Spi|Square|Squ|Square20pctDuty|Squ20PctDuty
Rules | When Setup is specified, no other action may be specified.
Example | Shape = Spike

Slew

Purpose | This action sets up the intrument and enables the output. Slewing is then enabled for the parameter designated as the Evaluation Quantity (i.e. + prefix)
Syntax | Slew
Rules | When Slew is specified, no other action may be specified.
Example | Slew

Standby

Purpose | This action selects standby (output disabled).
Syntax | Standby
Rules | When Standby is specified, no other parameters are allowed.
Example | Standby

TimeLimit

Purpose | This parameter specifies the time limit for the 50 Ohm overload measurement
Syntax | TimeLimit[sp]=[sp]numeric value[sp][prefix]s
Rules | N/A
Example | TimeLimit = 10 s

TriggerChannel

Purpose | his parameter specifies the trigger channel.
Syntax | TriggerChannel[sp]=[sp]integer
Rules
  • Legal values are 1 or 5.
  • TriggerChannel requires TriggerOutput = On.
Example | TriggerChannel = 5

TriggerOutput

Purpose | This parameter turns the trigger output on or off.
Syntax | TriggerOutput[sp]=[sp]state state = On | Off
Rules | When TriggerOutput is not specified, the default is Off
Example | TriggerOutput = On

TriggerRate

Purpose | This parameter specifies the trigger rate as a percentage of the output frequency.
Syntax | TriggerRate[sp]=[sp]numeric value[sp]%
Rules
  • TriggerRate requires TriggerOutput = On
  • Legal values are 1, 10, and 100 %.
Example | TriggerRate = 10 %

TriggerSkew

Purpose | This parameter specifies the pulse trigger skew.
Syntax | [+|@]TriggerSkew[sp]=[sp]numeric value[sp][prefix]s
Rules | N/A
Example | TriggerSkew = 10 ns

TripTime

Purpose | This parameter specifies the expected trip time the 50 Ohm overload measurement.
Syntax | +TripTime[sp]=[sp]numeric value[sp][prefix]s
Rules | N/A
Example | +TripTime = 5 s

TunnelDiodePulser

Purpose | This parameter enables Tunnel Diode Pulser in Edge mode.
Syntax | TunnedDiodePulser
Rules | N/A
Example | TunnedDiodePulser

Voltage

Purpose

This parameter specifies one of the following:

  1. Output voltage
  2. Video amplitude in volts peak
  3. Expected reading
Syntax

[+|@]Voltage[sp]=[sp]numeric value[sp][prefix]units

units = V | Vp | Vpp
Rules | N/A
Example | +Voltage = 1 Vpp

Waveform

Purpose | This parameter specifies the waveform for Marker or Wave Generator mode.
Syntax | Waveform[sp]=[sp]waveform waveform = Sine | Square | Squ | Triangle | Tri
Rules | N/A
Example | Waveform = Squ

Examples

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
# ----- Reset -----
  1.004  O_CAL        Reset
# ----- Standby -----
  1.005  O_CAL        Standby
# ----- DC Voltage Output -----
  1.006  O_CAL        Mode = Volt; OutpImp = 50 Ohm
  1.006  O_CAL        +Volt = 20.0 mV
  1.007  TARGET       -m
  1.008  VISA         [D500]MEASU:MEAS1:MEAN?[I]
  1.009  MEMCX        20.0mV         5U
# ----- DC Voltage Output (58xxA with 5 Channel option only) -----
  2.001  O_CAL        Mode = Volt; OutpImp = 50 Ohm; Channel = 1
  2.001  O_CAL        +Volt = 20.0 mV
  2.002  TARGET       -m
  2.003  VISA         [D500]MEASU:MEAS1:MEAN?[I]
  2.004  MEMCX        20.0mV         5U
# ----- AC Voltage Output ------
  3.001  O_CAL        Mode = Volt; OutpImp = 50 Ohm
  3.001  O_CAL        +Volt = 20.0 mVpp; Freq = 1 kHz
  3.002  TARGET       -m
  3.003  VISA         [D500]MEASU:MEAS1:MEAN?[I]
  3.004  MEMCX        20.0mVpp       5U            1kHz
# ----- AC Voltage Output (58xxA with 5 Channel option only) ------
  4.001  O_CAL        Mode = Volt; OutpImp = 50 Ohm; TrigChan = 5
  4.001  O_CAL        +Volt = 20 mVpp; Freq = 1 kHz; TrigOutput = On
  4.002  TARGET       -m
  4.003  VISA         [D500]MEASU:MEAS1:MEAN?[I]
  4.004  MEMCX        20.0mVpp       5U            1kHz
# ----- Edge Mode (rise time) -----
  5.001  O_CAL        Mode = Edge
  5.001  O_CAL        +RiseTime = 250 ns; Volt = 25 mVpp; Freq = 1 MHz
  5.002  VISA         MEASU:MEAS1:SOU CH[V @Chan];TYPE RISETIME;STATE ON
  5.003  TARGET       -m
  5.004  VISA         [D500]MEASU:MEAS1:MEAN?[I]
  5.005  MATH         MEM = MEM * 1E+9
  5.006  EVAL   -E MEM < 12 : Rise Time: [MEM] ns < 12 ns
# ----- Edge Mode (fall time) -----
  6.001  O_CAL        Mode = Edge
  6.001  O_CAL        +FallTime = 250 ns; Volt = 25 mVpp; Freq = 1 MHz
  6.002  VISA         MEASU:MEAS1:SOU CH[V @Chan];TYPE RISETIME;STATE ON
  6.003  TARGET       -m
  6.004  VISA         [D500]MEASU:MEAS1:MEAN?[I]
  6.005  MATH         MEM = MEM * 1E+9
  6.006  EVAL   -E MEM < 12 : Fall Time: [MEM] ns < 12 ns
# ----- Edge Mode (tunnel diode pulser for Tektronix DPO7000 delta time test)
  7.001  PIC          dpo7k_delta_time_58x0_ch1.jpg
  7.002  IEEE2        TRIG:A:EDGE:SOU CH[V @Chan]
  7.003  O_CAL        Mode = Edge; TunnelDiodePulser
  7.003  O_CAL        +Volt = 80Vpp; Freq = 100 kHz
  7.004  WAIT         -t 2 System Settling ...
  7.005  IEEE2        TRIG:A:LEV 25E-3
  7.006  IEEE2        CH[V @Chan]:TER 50;SCA 100E-3;POS -2.5
  7.007  WAIT         -t 2 System Settling ...
  7.008  IEEE2        AUTOS EXEC
  7.009  IEEE2        ACQ:SAMP RT
  7.010  IEEE2        HOR:SCA 20E-9
  7.011  IEEE2        HOR:MODE:SAMPLER 5E+9
  7.012  IEEE2        ACQ:STATE STOP
  7.013  IEEE2        CH[V @Chan]:SCA 25E-3;POS -1.5
  7.013  IEEE2        MEASU:MEAS1:SOU1 CH[V @Chan];TYP PWI;STATE ON
  7.014  IEEE2        MEASU:REFL:METH ABS
  7.015  IEEE2        MEASU:REFL:ABS:MID 0.075
  7.016  IEEE2        MEASU:STATI:COUNT RESET
  7.017  IEEE2        MEASU:STATI:WEI 1000
  7.018  TARGET       -m
  7.019  IEEE2        ACQ:STATE RUN
  7.020  WAIT         -t 30 UUT Running...
  7.021  IEEE2        ACQ:STATE STOP
  7.022  IEEE2        MEASU:MEAS1:STDdev?[I]
  7.023  MATH         MEM = MEM * 1E+12
  7.024  MATH         Rslt = FMT(MEM, "%.1f") & " ps"
  7.025  MEM2         = Limit <= 12 ps, Result: [V Rslt]
  7.026  EVAL   -e MEM <= 12 : [MEM2]
# ----- Edge Mode (58xxA with 5 Channel option only) -----
  8.001  O_CAL        Mode = Edge; TrigOutput = On; TrigChan = 5
  8.001  O_CAL        +Volt = 25 mVpp; Freq = 1 MHz
  8.002  TARGET       -m
  8.003  VISA         [D500]MEASU:MEAS1:MEAN?[I]
  8.004  MEMCX        25.0mVpp       5U            1MHz
# ----- Leveled Sine -----
  9.001  O_CAL        Mode = LeveledSine
  9.001  O_CAL        +Volt = 30 mVpp; Freq = 50 kHz
  9.002  TARGET       -m
  9.003  VISA         [D500]MEASU:MEAS1:MEAN?[I]
  9.004  MEMCX        30.0mVpp       5U            50kHz
# ----- Marker Mode -----
 10.001  VISA         CH[V @Chan]:TER 50;SCA 500E-3
 10.002  VISA         HOR:SCA 20E-3
 10.003  VISA         TRIG:A:MOD NORM;TYPE EDGE
 10.004  VISA         TRIG:A:EDGE:SOU CH[V @Chan];COUP DC
 10.005  O_CAL        Mode = Marker; Shape = Squ
 10.005  O_CAL        +Per = 10 ns
 10.006  VISA         [D500]TRIG:A SETL
 10.007  VISA         CH[V @Chan]:POS 0
 10.008  VISA         HOR:MAI:DEL:MOD ON;TIM 80E-3
 10.009  VISA         HOR:SCA 400E-9
 10.010  MESS         Does the rising edge of the marker cross the center
 10.010  MESS         horizontal graticule line within ? divisions of
 10.010  MESS         center graticule?
 10.011  MEM2         = Limit : ? div @ 400 ns/div, 80 ms delay time
 10.012  EVAL   -s MEM2 :
# ----- Wave Generator -----
 11.001  DISP         Using a 50 Ohm coaxial cable to connect the UUT
 11.001  DISP         CH[V @Chan] to digital oscilloscope CH1 via a
 11.001  DISP         50 Ohm termination.
 11.002  DISP         Set the digital oscilloscope as following:
 11.002  DISP         ===============================================
 11.002  DISP         Function Setting
 11.002  DISP         ===============================================
 11.002  DISP         CH1 Veritical
 11.002  DISP         [32]Coupling DC
 11.002  DISP         [32]Scale 0.2V/Div
 11.002  DISP         [32]Input Impedance 1MOhm
 11.002  DISP         -----------------------------------------------
 11.002  DISP         Horizontal
 11.002  DISP         [32]Sweep 10us/Div
 11.002  DISP         -----------------------------------------------
 11.002  DISP         Trigger
 11.002  DISP         [32]Source CH1
 11.002  DISP         [32]Coupling DC
 11.002  DISP         [32]Slope Positive
 11.002  DISP         [32]Level 0 mV
 11.002  DISP         [32]Mode Auto
 11.003  O_CAL        Mode = WaveGen; OutpImp = 50 Ohm
 11.003  O_CAL        +Volt = 1.6 Vpp; Freq = 20 kHz; Waveform = Sine
 11.004  IEEE2        SOUR[V @Chan]:FUNC:SHAP SIN
 11.005  IEEE2        SOUR[V @Chan]:FREQ:CW 20KHz
 11.006  IEEE2        SOUR[V @Chan]:VOLT:LEV:IMM:AMPL 1.6V
 11.007  IEEE2        OUTP[V @Chan]:STAT ON
 11.008  OPBR         -z Does the digital oscilloscope show 2 cycles
 11.008  OPBR         in 10 divisions, continuous sine wave?
 11.009  EVAL   -e MEM1 : Sine Wave Output Test
# ----- NTSC Video -----
 12.001  O_CAL        Mode = Video; Format = NTSC; Polarity = Pos
 12.001  O_CAL        +Amplitude = 100 %; LineMarker = 10; Field = Even
 12.002  MEM2         =Does UUT show stable NTSC video signal?
 12.003  EVAL   -s "NTSC Video Signal Test" : [MEM2]
# ----- PAL Video -----
 13.001  O_CAL        Mode = Video; Format = PAL; Polarity = Neg
 13.001  O_CAL        +Amplitude = 100 %; LineMarker = 10; Field = Odd
 13.002  MEM2         =Does UUT show stable PAL video signal?
 13.003  EVAL   -s "PAL Video Signal Test" : [MEM2]
# ----- PAL-M Video -----
 14.001  O_CAL        Mode = Video; Format = PAL-M; Polarity = Pos
 14.001  O_CAL        +Amplitude = 100 %; LineMarker = 10; Field = Even
 14.002  MEM2         =Does UUT show stable PAL-M video signal?
 14.003  EVAL   -s "PAL-M Video Signal Test" : [MEM2]
# ----- SECAM Video -----
 15.001  O_CAL        Mode = Video; Format = SECAM; Polarity = Neg
 15.001  O_CAL        +Amplitude = 150 %; LineMarker = 622; Field = Even
 15.002  MEM2         =Does UUT show stable SECAM video signal?
 15.003  EVAL   -s "SECAM Video Signal Test" : [MEM2]
# ----- Pulse Generator -----
 16.001  O_CAL        Mode = Pulse; Voltage = 1.5 Vpp
 16.001  O_CAL        +PulseWidth = 100.0 ns; Period = 10 us
 16.002  VISA         MEASU:MEAS1:SOU CH[V @Chan];TYPE PLUSEWIDTH;STATE ON
 16.003  TARGET       -m
 16.004  VISA         [D500]MEASU:MEAS1:MEAN?[I]
 16.005  MATH         MEM = MEM * 1E+9
 16.006  MEMCX        100.0ns        23U           1.5Vpp
# ----- Pulse Generator (58xxA with 5 Channel option only) -----
 17.001  O_CAL        Mode = Pulse; Voltage = 1.5 Vpp
 17.001  O_CAL        TrigOutput = On; TrigRate = 100 %
 17.001  O_CAL        +PulseWidth = 100.0 ns; Period = 10 us
 17.002  VISA         MEASU:MEAS1:SOU CH[V @Chan];TYPE PLUSEWIDTH;STATE ON
 17.003  TARGET       -m
 17.004  VISA         [D500]MEASU:MEAS1:MEAN?[I]
 17.005  MATH         MEM = MEM * 1E+6
 17.006  MEMCX        100.0ns        23U           1.5Vpp
# ---- AC Current Mode ----
 18.001  O_CAL        Mode = Current; +Current = 1000 uA; Freq = 1 kHz
 18.002  TARGET       -m
 18.003  MEMI         Enter the UUT reading in microamps AC:
 18.004  MEMCX        1000uA         20U           1kHz
# ---- DC Current Mode ----
 19.001  O_CAL        Mode = Current; +Current = 1000 uA
 19.002  TARGET       -m
 19.003  MEMI         Enter the UUT reading in microamps DC:
 19.004  MEMCX        uA             20U
# ---- 50 Ohm Input Overload Pulse ----
 20.001  O_CAL        Mode = Overload; Volt = 5 V
 20.001  O_CAL        +TripTime = 5 s; TimeLimit = 10 s; Measure
 20.002  EVAL   -e MEM > 5 : Overload Pulse Test
# ---- Impedance Measurement ----
 21.001  O_CAL        Mode = ImpedanceMeas; +Res = 1.00 MOhm; Measure
 21.002  MEMC         1.00MOhm       0.03U
# ---- Capacitance Measurement ----
 22.001  O_CAL        Mode = ImpedanceMeas; +Cap = 50 pF; Measure
 22.002  MEMC         50pF           13.0U
# ---- Voltage Measurement ----
 23.001  O_CAL        Mode = VoltageMeas; +Volt = 5.0 V; Measure
 23.002  MEMC         5.0V           0.3U
# ---- Serial Trigger -----
 24.001  IEEE2        CH[V @Chan]:SCA 50E-3;TER 50
 24.002  IEEE2        HOR:SCA 200E-12
 24.003  IEEE2        DIS:STY DOT
 24.004  IEEE2        DIS:PERS VAR
 24.005  IEEE2        DIS:VAR 3
 24.006  O_CAL        Mode = LeveledSine
 24.006  O_CAL        +Volt = 400 mVpp; Freq = 1.5625 GHz
 24.007  WAIT         -t 3 UUT Settling...
 24.008  IEEE2        TRIG:A:TYPE COMM
 24.009  IEEE2        TRIG:A:COMM:SOU CH1
 24.010  IEEE2        TRIG:A:COMM:SOU:TYP RECOV
 24.011  IEEE2        TRIG:A:COMM:COD NRZ
 24.012  O_CAL        Mode = LeveledSine
 24.012  O_CAL        +Volt = 400 mVpp; Freq = 625 MHz
 24.013  IEEE2        TRIG:A:COMM:BITR 1.25E9
 24.014  IEEE2        TRIG:A SETL
 24.015  WAIT         -t 3 UUT Settling...
 24.016  OPBR         -z The UUT will attempt to acquire lock once. If the
 24.016  OPBR         input data is disrupted, removed, or heavily distorted,
 24.016  OPBR         the UUT may not acquire lock or may loose lock. If the
 24.016  OPBR         recovered clock is not locked to the incoming data, the
 24.016  OPBR         waveform display will not be stable.
 24.016  OPBR
 24.016  OPBR         Did the UUT display stablize?
 24.017  EVAL   -e MEM1 : 625 MHz @ 1.25 Gbaud


5502A and 5502E

Instrument FSCs

Description

The 5502E FSC controls the Fluke 5502E Calibrator.

The 5502A FSC controls the Fluke 5502A Calibrator.

Use the O_CAL FSC to control the 5502A-SC300 and 5502A-SC600 Oscilloscope Calibration Option.

The 5502E FSC may also be used to control a 5502A, 5520A, or 5522A. This capability allows a procedure written using the 5502E FSC to be executed without modification when a 5502A, 5520A, or 5522A is configured and connected.

The 5502A FSC may also be used to control a 5520A or 5522A. This capability allows a procedure written using the 5502E FSC to be executed without modification when a 5520A or 5522A is configured and connected.

If the 5502A or 5502E is to be controlled via its serial port, do not use the PORT FSC port configuration special construction, [P9600,N,...], to set the baud rate, parity, etc. of the port used to control the 5502A or 5502E. MET/CAL executes a "Test" function for each System Instrument prior to executing any procedure statements, therefore the settings of the port used to controlling the 5502A or 5502E must be set correctly before a procedure is executed. If the 5502A or 5502E is connected to a standard serial port (COM1, COM2, ..., COM16), select the "Ports" application in the Windows control panel to choose the proper settings.

Parameters

A 5502A and 5502E statement consists of one or more parameters. A parameter consists of a name and a value. Each parameter must be separated by a semicolon and/or one or more spaces. A single 5502A or 5502E statement can encompass more than one physical line as long as the line numbers are the same. However each parameter name and its value must occur on one line. A single line can accommodate 256 characters including the statement number and FSC. Note that characters above ASCII 128 will count as 2 characters.

Syntax:

5502A parameter[separatorparameter]

parameter ::= [prefix]parameter name[sp]=[sp]parameter value

separator ::= ;[sp] | sp

prefix ::= + | @

sp ::= one or more spaces

parameter name ::= see Parameter Names

parameter value ::= see Parameter Names

|
Denotes "or" (i.e. A | B is A or B)
[ ]
Denotes an optional syntax element, except in examples. In examples [ ] enclose a special construction.
+
Designates the parameter as the Evaluation Quantity
@
Designates the parameter as the Modifier Quantity

Examples:

The following three 5502A statements are identical with respect to the 5502A:

1.001 5502A +Voltage = 240V; @Frequency = 50Hz

1.001 5502A Mode = AC_Voltage +Volt = 240.0 V @Freq = 50 Hz

  1.001  5502A        Apply
  1.001  5502A        Mode = AC_Voltage
  1.001  5502A        +Voltage = 240 V
  1.001  5502A        @Freq = 50 Hz

Rules:

  1. One and only one parameter must be designated as the Evaluation Quantity in a 5502A or 5502E Apply, Setup, or Slew statement.
  2. At most one parameter may be designated as the Modifier Quantity in a 5502A or 5502E Apply, Setup, or Slew statement.
  3. Parameter values may be taken from a MET/CAL memory register using a special construction.
  4. When a 5502A or 5502E Apply statement is executed, the value of the Evaluation Quantity is copied to memory register MEM1 in specified units.

Example:

  • 1.001 5502A Mode = ACV; +Volt = 240 V; @Freq = 50Hz; Apply

    After the 5502A statement is executed the value of MEM1 is 240.

  • When a 5502A Operate statement is executed, the value of the Evaluation Quantity designated in the previous Setup or Apply statement is copied to memory register MEM1 in specified units.

    • Example:

      1.001 5502A Mode = Volt; +Volt = 240V; @Freq = 50Hz; Setup
  1.002 5502A Mode = Volt; +Volt = 240V; @Freq = 50Hz; Operate

    After the 5502A Operate statement is executed the value of MEM1 is 240.

  • When a 5502A Slew statement is executed, the Evaluation Quantity designates the slew quantity.
  • When a 5502A Slew statement is executed, the final slew value is copied to memory register MEM1 in units of the Evaluation Quantity.

    • Example:

    1.001 5502A +Volt = 240V; @Freq = 50Hz; Slew

    Operator slews the 5502A output to 241.5 V.

    After the 5502A Slew statement is executed the value of MEM is 241.5.

  • When a 5502A or 5502E Slew statement is executed, the Modifier Quantity is concatenated to the Evaluation Quantity in the automatic slew message. Note, the automatic slew message is not displayed when ASK- N is in effect.

    • Examples:

      1.001 ASK+ N
  1.002 5502A +Volt = 120V; @Freq = 60Hz; Slew

    "Adjust stimulus for a UUT reading of 120 V at 60 Hz."

    No Modifier Quantity designated.

    1.001 5502A Mode = Volt; +Volt = 120V; Freq = 60Hz; Slew

    "Adjust stimulus for a UUT reading of 120 V."

    Automatic slew message inhibited.

      1.001 ASK- N
  1.002 5502A +Volt = 120V; Freq = 60Hz; Slew

    No automatic slew message generated, use MESS FSC.

Parameter Names

Parameter names consist of single words or compound words. Each word in a parameter name can be entered in long form (as shown below), or in short form. The short form is the first 4 characters of the long form, with the following exceptions:

  1. If the long form is greater than four characters, and the last character or the short form is a vowel, the short form is three characters.
  2. If the long form is four characters or less, the short form is the long form even if it ends in a vowel.

Compound parameter names can be entered in any combination of long and short forms. Example, ExternalReference can be entered using any of the following forms:

  • InductanceCompensation
  • InductanceComp
  • IndCompensation
  • IndComp

Action Parameters

  • Apply
  • Local
  • Measure
  • Monitor
  • Operate
  • Read
  • Reset
  • Setup
  • Standby

General Parameters

  • Amplitude
  • AuxiliaryVoltage 1
  • AuxiliaryWaveform
  • Capacitance
  • Coil
  • Current
  • CurrentTerminal
  • DutyCycle
  • Earth
  • Frequency
  • Fundamental 1
  • Harmonic 1
  • Humidity
  • Impedance
  • InductanceCompensation
  • Lag 1
  • Lead 1
  • LeadCompensation
  • Lows 1
  • Mode
  • NominalResistance
  • NonToroidalUUT
  • NormalVoltage 1
  • NormalWaveform 1
  • Offset
  • OTCD
  • Period
  • Phase 1
  • Power 1
  • PF 1
  • RTD_Type
  • Range
  • ReferencePhase 1
  • Resistance
  • TC_Reference
  • TC_Type
  • Temperature
  • TemperatureScale (alternately TemperatureStandard)
  • ToroidalUUT
  • Turns
  • Voltage
  • Waveform

1. 5502A only

INSTRUMENT MODE

If the 5502A or 5502E operating mode is not specified, MET/CAL determines the mode based on occurrence of the following parameters in the 5502A or 5502E statement:

  • Current
  • Frequency
  • NormalVoltage
  • Period
  • Resistance
  • Voltage

Rules:

  1. If Resistance or Conductance is specified, the mode is Resistance.
  2. If Capacitance is specified, the mode is Capacitance.
  3. If Humidity is specified, the mode is Humidity Measurement.
  4. If Temperature and RTD_Type are specified, mode is RTD Source.
  5. If Temperature and TC_Type are specified, mode is TC Source.
  6. If NormalVoltage and Frequency or Period are specified, the mode is Dual AC Voltage.
  7. If NormalVoltage is specified without Frequency or Period, the mode is Dual DC Voltage.
  8. If Voltage, Current, and Frequency or Period are specified, the mode is AC Power.
  9. If Voltage are Current are specified without Frequency or Period, the mode is DC Power.
  10. If Current and Frequency or Period are specified, but not Voltage, the mode is AC Current.
  11. If Current is specified, but not Voltage, Frequency, and Period, the mode is DC Current.
  12. If Current and Frequency or Period are specified, but not Voltage, the mode is AC Current.
  13. If Current is specified, but not Voltage, Frequency, and Period, the mode is DC Current.
  14. If Voltage and Frequency or Period are specified, but not Current, the mode is AC Voltage.
  15. If Voltage is specified, but not Current, Frequency, and Period, the mode is DC Voltage.

Mode/Parameter Rules

DC VOLTAGE

Mode = DC_Voltage | DC_Volt | DCV

Required Parameters
Voltage
Optional Parameters | Default
Mode | DC_Voltage
Range | autorange
Earth | Off
Apply | Setup | Operate | Slew | Apply

DC CURRENT

Mode = DC_Current | DC_Curr | DCA

Required Parameters
Current
CurrentTerminal
Optional Parameters | Default
Mode | DC_Current
Range | 1
Coil | na
Turns | na
Earth | Off
Apply | Setup | Operate | Slew | Apply
  1. Autorange, Current = -2.99999 A to 2.99999 A, otherwise 20 A range locked.

RESISTANCE

Mode = Resistance | Res

Required Parameters
Resistance | Conductance
Optional Parameters | Default
Mode | Resistance
LeadCompensation | Off
Apply | Setup | Operate | Apply

AC VOLTAGE

Mode = AC_Voltage | AC_Volt | ACV

Required Parameters
Voltage | Amplitude
Frequency | Period
Optional Parameters | Default
Mode | AC_Voltage
Waveform | Sine
Range | autorange
Offset | 0 V
DutyCycle | 50 % 1
Impedance | NA 2,3
Earth | Off
ReferencePhase | na
Apply | Setup | Operate | Slew | Apply
  1. Only allowed when Waveform = Square
  2. Only allowed when Waveform = Sine
  3. Required when Amplitude is specified.

AC CURRENT

Mode = AC_Current | AC_Curr | ACA

Required Parameters
Current
CurrentTerminal
Frequency | Period
Optional Parameters | Default
Mode | AC_Voltage
Waveform | Sine
Range | autorange
Coil | na
Turns | na
ToroidalUUT | NonToroidalUUT | na 1
InductanceCompensation | Off
Earth | Off
ReferencePhase | na
Apply | Setup | Operate | Slew | Apply
  1. Only allowed, and required when Coil is specified

CAPACITANCE

Mode = Capacitance | Cap

Required Parameters
Capacitance
Optional Parameters | Default
Mode | Capacitance
LeadCompensation | Off
Apply | Setup | Operate | Apply

TC SOURCE

Mode = TC_Source | TC_Sour

Required Parameters
Temperature
TC_Type
Optional Parameters | Default
Mode | TC_Source
OTCD (Open TC Detection) | On
TemperatureScale | ITS-90
TC_Reference | Internal
Earth | Off
Apply | Setup | Operate | Apply

TC MEASUREMENT

Mode = TC_Measurement | TC_Meas

Required Parameters
Mode
Temperature
TC_Type
Optional Parameters | Default
OTCD (Open TC Detection) | On
TemperatureScale | ITS-90
TC_Reference | Internal
Measure | Monitor | Setup | Read | Measure

HUMIDITY MEASUREMENT

Mode = HumidityMeasurement | HumidityMeas | HumMeasurement | HumMeas

Required Parameters
Mode
Humidity
Optional Parameters | Default
Measure | Setup | Read | Measure

RTD SOURCE

Mode = RTD_Source | RTD_Sour

Required Parameters
Temperature
RTD_Type
NominalResistance
Optional Parameters | Default
Mode | RTD_Source
LeadCompensation | Off
Apply | Setup | Operate | Apply

DUAL DC VOLTAGE (5502A only)

Mode = DualDC_Voltage | DualDC_Volt | DualDCV

Required Parameters
NormalVoltage
AuxiliaryVoltage
Optional Parameters | Default
Mode | DualDC_Voltage
Earth | Off
Lows | Tied
Apply | Setup | Operate | Slew | Apply

DUAL AC VOLTAGE (5502A only)

Mode = DualAC_Voltage | DualAC_Volt | DualACV

Required Parameters
NormalVoltage
AuxiliaryVoltage
Frequency | Period
Optional Parameters | Default
Mode | DualAC_Voltage
NormalWaveform | Sine
AuxiliaryWaveform | Sine
Fundamental | Normal
Harmonic | 1
Phase | PF | 0 deg
Lead | Lag | Lead 1
Earth | Off
Lows | Tied
ReferencePhase | na
Apply | Setup | Operate | Slew | Apply
  1. Only allowed when PF is specified.

DC POWER (5502A only)

Mode = DC_Power | DC_Pow

Required Parameters
Voltage
Current
CurrentTerminal
Optional Parameters | Default
Mode | DC_Power
Power | na
Coil | na
Turns | na
Earth | Off
Lows | Tied
Apply | Setup | Operate | Slew 1 | Apply
  1. Slew not allowed when Power is specified.

AC POWER (5502A only)

Mode = AC_Power | AC_Pow

Required Parameters
Voltage
Current
CurrentTerminal
Frequency | Period
Optional Parameters | Default
Mode | AC_Power
NormalWaveform | Sine
AuxiliaryWaveform | Sine
Fundamental | Normal
Harmonic | 1
Power | na
Phase | PF | 0 deg
Lead | Lag | Lead 1
Coil | na
Turns | na
ToroidalUUT | NonToroidalUUT | na 2
InductanceCompensation | Off
Earth | Off
Lows | Tied
ReferencePhase | na
Apply | Setup | Operate | Slew 3 | Apply
  1. Only allowed when PF is specified.
  2. Only allowed, and required when Coil is specified
  3. Slew not allowed when Power is specified.

Parameter Definitions and Values

Amplitude

This parameter specifies the amplitude in dBm for AC Voltage mode.

Syntax:

[+|@]Amplitude[sp]=[sp]numeric value[sp][prefix]dBm

Examples:

Amplitude = +10.0 dBm

Apply

This action sets up the instrument and enables the output.

Syntax:

Apply

Rules:

  1. When Apply is specified, no other action may be specified.
  2. After an Apply statement is executed MEM1 contains the sourced value in units of the Evaluation Quantity.

Examples:

Apply

AuxiliaryVoltage (5502A only)

This parameter specifies the AUX output voltage for the following modes:

  • Dual DC Voltage
  • Dual AC Voltage

Syntax:

[+|@]AuxiliaryVoltage[sp]=[sp]numeric value[sp][prefix]V

Examples:

+AuxVoltage = 1 V

AuxiliaryWaveform (5502A only)

This parameter specifies the AUX waveform for the following modes:

  • DC Power
  • AC Power
  • Dual DC Voltage
  • Dual AC Voltage

Syntax:

AuxiliaryWaveform[sp]=[sp]waveform

waveform ::= Sine | Square | Triangle | TruncatedSine

Examples:

AuxWaveform = Tri

Capacitance

This parameter specifies the capacitance.

Syntax:

[+|@]Capacitance[sp]=[sp]numeric value[sp][prefix]F

Examples:

Capacitance = 100 nF

Conductance

This parameter specifies the expected conductance

Syntax:

[+|@]Conductance[sp]=[sp]numeric value[sp][prefix]S

Examples:

Capacitance = 0.01 nS

Coil

This parameter specifies a current coil.

Syntax:

Coil[sp]=[sp]value

value ::= 5500A/COIL |9100_Option200 | 9100_Opt200 | UserDefined | UserDef

Examples:

Coil = 5500A/COIL

Current

This parameter specifies the output current.

Syntax:

[+|@]Current[sp]=[sp]numeric value[sp][prefix]units

units ::= A | Ap | App

Examples:

Current = 2.5 A

CurrentTerminal

This parameter specifies a current output terminals.

Syntax:

CurrentTerminal[sp]=[sp]value

value ::= Auxiliary | Aux | 20A

Examples:

CurrentTerminal = 20A

DutyCycle

This parameter specifies the duty cycle for AC Voltage square waves.

Syntax:

[+|@]DutyCycle[sp]=[sp]numeric value[sp][prefix]%

Examples:

DutyCycle = 30 %

Earth

This parameter specifies the earth connection.

Syntax:

Earth[sp]=[sp]value

value ::= On | Off

Examples:

Earth = On

Frequency

This parameter specifies the output frequency.

Syntax:

[+|@]Frequency[sp]=[sp]numeric value[sp][prefix]Hz

Rules:

When Frequency is specified, Period cannot be specified.

Examples:

@Freq = 50 Hz

Fundamental (5502A only)

This parameter specifies which represents the fundamental when a harmonic is specified.

Syntax:

Fundamental[sp]=[sp]output

output ::= Normal | Auxiliary

Examples:

Fund = Norm

Harmonic (5502A only)

This parameter specifies the harmonic.

Syntax:

Harmonic[sp]=[sp]integer

Examples:

Harm = 3

Humidity

This parameter specifies the expected humidity measurement.

Syntax:

+Humidity[sp]=[sp]numeric value[sp][prefix]%

Examples:

Humidity = 75 %

Impedance

This parameter specifies the reference impedance for Amplitude in dBm.

Syntax:

Impedance[sp]=[sp]numeric value[sp][prefix]Ohm[s]

Examples:

Impedance = 50 Ohms

InductanceCompensation

This parameter specifies the inductance compensation (LCOMP).

Syntax:

InductanceCompensation[sp]=[sp]value

value ::= On | Off

Examples:

IndComp = On

Lead / Lag (5502A only)

These parameters select the relationship between the NORMAL and AUX output waveforms when power factor is specified.

Syntax:

Lead | Lag

Rules:

  1. When Lead are mutually exclusive.

Examples:

Lead

LeadCompensation

This parameter selects the lead compensation.

Syntax:

LeadCompensation[sp]=[sp]value

value ::= 2W | 4W | 2Wire | 4Wire | Off

Rules:

  1. 4W and 4Wire are not allowed in Capacitance mode.

Examples:

+Resistance = 0.0 Ohms; LeadCompensation = 4W

+Capacitance = 10.0 mF; LeadCompensation = 2W

Local

This action puts the 5502A or 5502E in local mode.

Syntax:

Local

Rules:

  1. When Local is specified, no other parameters may be specified.

Examples:

Local

Lows (5502A only)

This parameter connects or disconnects the NORMAL LO and AUX LO terminals together.

Syntax:

Lows[sp]=[sp]value

value ::= Open | Tied

Rules:

  1. When Lows is allowed, but not specified, the default is Tied.

Examples:

Lows = Open

Measure

This action sets up the instrument and returns the reading.

Syntax:

Measure

Rules:

  1. When Measure is specified, no other action may be specified.
  2. After a Measure statement is executed MEM contains the reading in units of the Evaluation Quantity.

Examples:

Measure

Mode

This parameter selects the instrument mode.

Syntax:

Mode[sp]=[sp]value

value ::= DC_Voltage | DC_Volt | DCV |

DC_Current | DC_Curr | DCA |

Resistance | Res |

AC_Voltage | AC_Volt | ACV |

AC_Current | AC_Curr | ACA |

Capacitance | Cap |

HumidityMeasurement | HumidityMeas | HumMeasurement | HumMeas

TC_Measurement | TC_Meas |

TC_Source | TC_Sour |

RTD_Source | RTD_Sour |

DualDC_Voltage 1 | DualDC_Volt 1|DualDCV 1 |

DualAC_Voltage 1 | DualAC_Volt 1 | DualACV 1 |

DC_Power 1 | DC_Pow 1 |

AC_Power 1 | AC_Pow 1

  1. 5502A only

Rules:

  1. If mode is not specified, the mode is determined as described in the section INSTRUMENT MODE at the top of this file.

Examples:

Mode = Cap

Monitor

This action sets up the instrument and continually displays the reading until the operator selects Advance or Terminate in the UUT Setup prompt.

Syntax:

Monitor

Rules:

  1. When Monitor is specified, no other action may be specified.
  2. After a Monitor statement MEM1 contains the reading in units of the Evaluation Quantity.

Examples:

Monitor

NonToroidalUUT

See ToroidalUUT / NonToroidalUUT.

NominalResistance

This parameter specifies the nominal resistance for RTD Source mode.

Syntax:

[@]NominalResistance[sp]=[sp]numeric value[sp][prefix]Ohm[s]

Examples:

NominalResistance = 100 Ohms

NormalVoltage (5502A only)

This parameter specifies the NORMAL output voltage for the following modes:

  • Dual DC Voltage
  • Dual AC Voltage

Syntax:

[+|@]NormalVoltage[sp]=[sp]numeric value[sp][prefix]units

units ::= V | Vp | Vpp

Examples:

+NormalVoltage = 240 V

NormalWaveform (5502A only)

This parameter specifies the NORMAL waveform for the following modes:

  • AC Power
  • Dual AC Voltage

Syntax:

NormalWaveform[sp]=[sp]waveform

waveform ::= Sine | Square | Triangle | TruncatedSine

Examples:

NormWave = Tri

Offset

This parameter specifies the DC offset.

Syntax:

[+|@]Offset[sp]=[sp]numeric value[sp][prefix]V

Examples:

+Offset = 1 V

Operate

This parameter turns the output on.

Syntax:

Operate

Rules:

  1. When Operate is specified, no other parameters are allowed.
  2. An Operate statement must be preceded by a Setup statement to setup the instrument.
  3. After an Operate statement is executed MEM1 contains the sourced value in units of the Evaluation Quantity.

Examples:

Operate

OTCD

This parameter specifies the state of Open Thermocouple Detection.

Syntax:

OTCD[sp]=[sp]value

value ::= On | Off

Rules:

  1. When OTCD is not specified, the default is On.

Examples:

OTCD = Off

Period

This parameter specifies the output period.

Syntax:

[+|@]Period[sp]=[sp]numeric value[sp][prefix]s

Rules:

  1. When Period is specified, Frequency cannot be specified.

Examples:

@Per = 1 ms

Phase

This parameter specifies the phase between the NORMAL and AUX waveforms.

Syntax:

[+|@]Phase[sp]=[sp]numeric value[sp][prefix]deg

Examples:

Phase = 30 deg

Power (5502A only)

This parameter specifies the expected power.

Syntax:

+Power[sp]=[sp]numeric value[sp][prefix]units

units ::= W | VA | VAR

Rules:

  1. When this parameter is specified, it must be designated as the Evaluation Quantity.

Examples:

+Power = 10 kVA

PF (5502A only)

This parameter specifies the power factor.

Syntax:

[+|@]PF[sp]=[sp]numeric value

Rules:

  1. When PF is specified, Lead or Lag must be specified.

Examples:

PF = 0.34; Lag

RTD_Type

This parameter specifies the RTD type.

Syntax:

RTD_Type[sp]=[sp]type

type ::= Pt385 | Pt3926 | Pt3916 | Ni672 | Cu427

Examples:

RTD_Type = Pt385; NominalResistance = 500 Ohms

RTD_Type = Ni672; NominalResistance = 120 Ohms

RTD_Type = Cu427; NominalResistance = 10 Ohms

Range

This parameter specifies the range to range lock in DC Voltage and DC Current modes.

Syntax:

Range[sp]=[sp]numeric value[sp][prefix]units

units ::= A | V

Examples:

Range = 3.3 V

Read

This action returns the reading.

Syntax:

Read

Rules:

  1. When Read is specified, no other action may be specified.
  2. A Read statement must be preceded by a Setup statement to setup the instrument.
  3. After a Read statement is executed MEM contains the reading in units of the Evaluation Quantity.

Examples:

Read

ReferencePhase (5502A only)

This parameter sets the reference phase.

Current modes.

Syntax:

ReferencePhase[sp]=[sp]numeric value[sp][prefix]deg

Examples:

RefPhase = Ext

Reset

This parameter resets the 5502A or 5502E.

Syntax:

Reset

Rules:

  1. When Reset is specified, no other parameters are allowed.

Examples:

Reset

Resistance

This parameter specifies the resistance.

Syntax:

[+|@]Resistance[sp]=[sp]numeric value[sp][prefix]Ohm[s]

Examples:

Resistance = 100 Ohms

Setup

This action causes the instrument to be setup only.

Syntax:

Setup

Rules:

  1. When Setup is specified, no other action may be specified.
  2. Mode: HumidityMeasurement and TC_Measurement
    1. No reading is returned.
  3. Mode: All other modes
    1. The instrument remains in standby.
    2. After a Setup statement is executed MEM1 contains the value to be sourced in units of the Evaluation Quantity.

Examples:

Setup

Slew

This action sets up the instrument and enables the output. Slewing is then enabled for the parameter designated as the Evaluation Quantity (i.e. + prefix).

Syntax:

Slew

Rules:

  1. When Slew is specified, no other action may be specified.

Examples:

Slew

Standby

This action selects standby (output disabled).

Syntax:

Standby

Rules:

  1. When Standby is specified, no other parameters are allowed.

Examples:

Standby

TC_Reference

This parameter specifies the external reference temperature.

Syntax:

TC_Reference[sp]=[sp]numeric value[sp][prefix]units

units ::= degC | degF

Examples:

TC_Reference = 21.0 degC

TC_Type

This parameter specifies the TC type.

Syntax:

TC_Type[sp]=[sp]type

type ::= B | C | E | J | K | N | R | S | T | U | _1mVdegC | _10uVdegC

Examples:

TC_Type = K

Temperature

This parameter specifies the temperature.

Syntax:

[+]Temperature[sp]=[sp]numeric value[sp][prefix]units

units ::= degC | degF

Examples:

Temperature = -100.0 degC

TemperatureScale (alternately TemperatureStandard)

This parameter specifies the temperature scale.

Syntax:

TemperatureScale[sp]=[sp]standard

standard ::= ITS_90 | IPTS_68

Examples:

TempScale = IPTS_68

ToroidalUUT / NonToroidalUUT

These parameters specify that the UUT design for calculation of the total reference accuracy when a coil is specified.

Syntax:

ToroidalUUT | NonToroidal

Rules:

  1. When ToroidalUUT and NonToroidalUUT are mutually exclusive.
  2. When neither ToroidalUUT or NonToroidalUUT is specified, the default is non-toroidal.

Examples:

ToroidalUUT

Turns

This parameter specifies the number of turns in the current coil.

Syntax:

Turns[sp]=[sp]integer

Rules:

Coil | Turns
5500A/COIL | 50
9100_Option200 | 10 or 50
UserDefined | 1 to 100

Examples:

Coil = 5500A/COIL

Coil = 5500A/COIL; Turns = 50

Coil = 9100_Option200; Turns = 10

Coil = UserDefined; Turns = 30

Voltage

This parameter specifies the NORMAL output voltage for the following modes:

  • DC Voltage
  • AC Voltage
  • DC Power
  • AC Power

Syntax:

[+|@]Voltage[sp]=[sp]numeric value[sp][prefix]units

units ::= V | Vp | Vpp

Examples:

+Voltage = 240 V

Waveform

This parameter specifies the NORMAL waveform for AC Voltage mode or the AUX waveform for AC Current mode.

Syntax:

Waveform[sp]=[sp]waveform

waveform ::= Sine | Square | Triangle | TruncatedSine

Examples:

Waveform = Squ

Examples

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
# -----  Reset  -----
  1.002  5502A        Reset

# -----  Standby  -----
  1.003  5502A        Standby

# -----  DC Voltage  -----
  1.004  5502A        +Voltage = -190.0 mV
  1.005  TARGET       -m
  1.006  MEMI         Enter UUT reading in millivolts DC:
  1.007  MEMCX  200   -190.0mV       1.0% 0.1U

# -----  DC Current  -----
  2.001  5502A        +Current = 19.00 mA; CurrentTerminal = Aux
  2.002  TARGET       -m
  2.003  MEMI         Enter UUT reading in millamps DC:
  2.004  MEMCX  20    19.00mA        1.5% 0.01U

# -----  DC Current (using 5500A/COIL)  -----
  3.001  5502A        Coil = 5500A/COIL; CurrentTerminal = Aux
  3.001  5502A        +Current = 41.0 A
  3.002  TARGET       -m
  3.003  MEMI         Enter UUT reading in amps DC:
  3.004  MEMCX  400   41.0A          1.5% 0.5U

# -----  DC Current (using 9100 Option 200 10-Turn Coil)  -----
  4.001  5502A        Coil = 9100_Opt200; Turns = 10
  4.001  5502A        +Current = 11.00 A; CurrentTerminal = Aux
  4.002  TARGET       -m
  4.003  MEMI         Enter UUT reading in amps DC:
  4.004  MEMCX  40    11.00A         1.5% 0.05U

# -----  DC Current (using 9100 Option 200 50-Turn Coil)  -----
  5.001  5502A        Coil = 9100_Opt200; Turns = 50
  5.001  5502A        +Current = 41.0 A; CurrentTerminal = Aux
  5.002  TARGET       -m
  5.003  MEMI         Enter UUT reading in amps DC:
  5.004  MEMCX  400   41.0A          1.5% 0.5U

# -----  Resistance  -----
  6.001  5502A        +Resistance = 1.900 kOhms; LeadComp = 2W
  6.002  TARGET       -m
  6.003  MEMI         Enter UUT reading in kilohms:
  6.004  MEMCX  2     kOhms          1% 0.004U

# -----  AC Voltage  -----
  7.001  5502A        +Voltage = 19.00 V; Frequency = 50 Hz
  7.002  TARGET       -m
  7.003  MEMI         Enter UUT reading in volts AC:
  7.004  MEMCX  20    19.00V         1.5% 0.05U    50Hz

# -----  AC Current  -----
  8.001  5502A        +Current = 1.900 mA; Freq = 500 Hz; CurrTerm = Aux
  8.002  TARGET       -m
  8.003  MEMI         Enter UUT reading in millamps AC:
  8.004  MEMCX  2     1.900mA        2% 0.005U     500Hz

# -----  AC Current (using 5500A/COIL)  -----
  9.001  5502A        Coil = 5500A/COIL; NonToroidalUUT; IndComp = On
  9.001  5502A        +Current = 125 A; Frequency = 50 Hz; CurrTerm = Aux
  9.002  TARGET       -m
  9.003  MEMI         Enter UUT reading in amps AC:
  9.004  MEMCX  2000  410A           1.5% 5U       50Hz

# -----  AC Current (using 9100 Option 200 10-Turn Coil)  -----
 10.001  5502A        Coil = 9100_Opt200; Turns = 10; IndComp = On
 10.001  5502A        +Current = 11.00 A; Frequency = 50 Hz; CurrTerm = Aux
 10.002  TARGET       -m
 10.003  MEMI         Enter UUT reading in amps AC:
 10.004  MEMCX  40    11.00A         1.5% 0.05U    50Hz

# -----  AC Current (using 9100 Option 200 50-Turn Coil)  -----
 11.001  5502A        Coil = 9100_Opt200; Turns = 50; IndComp = On
 11.001  5502A        +Current = 125 A; Frequency = 60 Hz; CurrTerm = Aux
 11.002  TARGET       -m
 11.003  MEMI         Enter UUT reading in amps AC:
 11.004  MEMCX  2000  410A           1.5% 5U       60Hz

# -----  Dual AC Voltage  -----
 12.001  5502A        NormalVoltage = 5 V; Phase = 0 deg
 12.001  5502A        +AuxVoltage = 0.03 V; Frequency = 60 Hz
 12.002  MATH         L[1] = REFACC() / MEM1 * 100
 12.003  5502A        AuxVoltage = 0.03 V; Phase = 0 deg
 12.003  5502A        +NormalVoltage = 5 V; Frequency = 60 Hz
 12.004  MATH         L[2] = REFACC() / MEM1 * 100
 12.005  MATH         L[3] = RSS_L(1, 2)
 12.006  ACC          150W           L3%
 12.007  MEMI         Enter UUT reading in watts.
 12.008  MEMCX        150W           1% 4U

 13.001  5502A        NormalVoltage = 100 V; AuxVoltage = 150 mV
 13.001  5502A        +Phase = 157 deg; Frequency = 60 Hz
 13.002  MEMI         Enter UUT reading in degrees.
 13.003  MEMCX        157deg         2U

# -----  AC Power (using 5500A/COIL)  -----
 14.001  5502A        Coil = 5500A/COIL; NonToroidalUUT; IndComp = On
 14.001  5502A        Voltage = 380 V; Current = 100 A; Phase = 0 deg
 14.001  5502A        +Power = 38.00 kW; Freq = 50 Hz; CurrTerm = Aux
 14.002  TARGET       -m
 14.003  MEMI         Enter UUT reading in kilowatts:
 14.004  MEMCX  40    38.00kW        2.5% 0.05U

 15.001  5502A        Coil = 5500A/COIL; NonToroidalUUT; IndComp = On
 15.001  5502A        Voltage = 19 V; Current = 100 A; Phase = 0 deg
 15.001  5502A        +Power = 1900 VA; Freq = 50 Hz; CurrTerm = Aux
 15.002  TARGET       -m
 15.003  MEMI         Enter the UUT reading in volt-amps:
 15.004  MEMCX  4000  1900VA         80U

 16.001  5502A        Coil = 5500A/COIL; NonToroidalUUT; IndComp = On
 16.001  5502A        Voltage = 397.363 V; Current = 100 A; Phase = -73 deg
 16.001  5502A        +Power = +38.00 kVAR; Freq = 50 Hz; CurrTerm = Aux
 16.002  TARGET       -m
 16.003  MEMI         Enter UUT reading in kilovolts-amps reactive:
 16.004  MEMCX  40    +38.00k'VAR'   2.5% 0.05U

 17.001  5502A        Coil = 5500A/COIL; NonToroidalUUT; IndComp = On
 17.001  5502A        Voltage = 460.105 V; Current = 100 A
 17.001  5502A        +PF = 0.292; Freq = 50 Hz; CurrTerm = Aux; Lead
 17.002  TARGET       -m
 17.003  MEMI         Enter UUT power factor reading:
 17.004  MEMCX        0.292          0.050U

# -----  AC Power (using 9100 Option 200 50-Turn Coil)  -----
 18.001  5502A        Coil = 9100_Opt200; Turns = 50; IndComp = On
 18.001  5502A        Voltage = 44 V; Current = 100 A; Phase = 0 deg
 18.001  5502A        +Power = 4.40 kW; Freq = 50 Hz; CurrTerm = Aux
 18.002  TARGET       -m
 18.003  MEMI         Enter UUT reading in kilowatts:
 18.004  MEMCX  40    4.40kW         2.5% 0.05U

 19.001  5502A        Coil = 9100_Opt200; Turns = 50; IndComp = On
 19.001  5502A        Voltage = 380 V; Current = 100 A; Phase = 0 deg
 19.001  5502A        +Power = 38.00 kVA; Freq = 50 Hz; CurrTerm = Aux
 19.002  TARGET       -m
 19.003  MEMI         Enter UUT reading in kilovolt-amps:
 19.004  MEMCX  40    38.00kVA       2.5% 0.05U

 20.001  5502A        Coil = 9100_Opt200; Turns = 50; IndComp = On
 20.001  5502A        Voltage = 460.105 V; Current = 100 A; Phase = +73 deg
 20.001  5502A        +Power = 44.0 kVAR; Freq = 50 Hz; CurrTerm = Aux
 20.002  TARGET       -m
 20.003  MEMI         Enter UUT reading in kilovolts-amps reactive:
 20.004  MEMCX  400   -44.0k'VAR'    2.5% 0.5U

 21.001  5502A        Coil = 9100_Opt200; Turns = 50; IndComp = On
 21.001  5502A        Voltage = 19.8681 V; Current = 100 A
 21.001  5502A        +PF = 0.292; Freq = 50 Hz; CurrTerm = Aux; Lag
 21.002  TARGET       -m
 21.003  MEMI         Enter UUT power factor reading:
 21.004  MEMCX        0.292          0.050U

# -----  Temperature  -----

# Thermocouple Source
 22.001  5502A        Mode = TC_Source; TC_Type = _10uVdegC
 22.001  5502A        +Temperature = 100.0 degC
 22.002  TARGET       -m
 22.003  MEMI         Enter UUT temperature reading in degrees C:
 22.004  MEMCX        100.0degC      1%

# Thermocouple Measurement
 23.001  DISP         Set the UUT to source 100 degrees C.
 23.002  TARGET       -m
 23.003  5502A        Mode = TC_Meas; TC_Type = K
 23.003  5502A        +Temperature = 100.0 degC; Measure
 23.004  MEMCX        100.0degC      1%

# RTD Source
 24.001  5502A        Mode = RTD_Source; RTD_Type = Pt385
 24.001  5502A        +Temperature = 100.0 degC; NominalResistance = 500 Ohms
 24.002  TARGET       -m
 24.003  MEMI         Enter UUT temperature reading in degrees C:
 24.004  MEMCX        100.0degC      1%


5520

Instrument FSC

Description

The 5520 FSC provides the means to control the following functions of the Fluke 5520A Calibrator:

  • DC Voltage and DC Current
  • AC Voltage and AC Current (Sine, Square, Triangle, and Truncated Sine waveforms)
  • Synthesized Resistance and Capacitance
  • RTD and Thermocouple Calibration stimulus
  • Thermocouple measurement
  • Humidity measurement

When the M5520 FSC is used in conjunction with the 5520 FSC the following additional 5520 functions may be controlled:

  • Dual DC and Dual AC Voltage
  • DC and AC Power stimulus (simultaneous voltage and current output)
  • DC Voltage and DC Current range locking
  • DC Offset for AC Voltage
  • Duty Cycle for square waves
  • Phase for Dual Voltage and Power stimulus
  • Displacement Power Factor for Power stimulus
  • External Reference Temperature for Thermocouple

Calibration and Measurement The following functions are available with SC300 Scope Option:

  • DC Voltage
  • AC Voltage (Sine, Square, Triangle, Leveled Sine, Scope Square, Edge, Time Mark, and ScopeMeter waveforms)
  • Trigger Signal

The following functions are available with SC600 or SC1100 Scope Option:

  • DC Voltage
  • AC Voltage (Sine, Square, Triangle, Leveled Sine, Positive and

Negative Scope Square, Edge, Time Mark, Pulse and Video waveforms)

  • Oscilloscope Input Impedance Measurement
  • Oscilloscope 50 Ohm Impedance Overload Protection Measurement
  • Trigger Signal

Pressure Measurement Use the P700 FSC to control a Fluke 700 Series Pressure Module connected to the 5520A rear panel connector labeled: "SERIAL 2 TO UUT", using the 700PCK.

The 5520 FSC may also be used to control a 5522A. This capability allows a 5520A based procedure to be executed without modification when a 5522A is configured. If the 5520 is to be controlled via its serial port, do not use the PORT FSC port configuration special construction, [P9600,N,...], to set the baud rate, parity, etc. of the port used to control the 5520. MET/CAL executes a "Test" function for each System Instrument prior to executing any procedure statements, therefore the settings of the port used to controlling the 5520 must be set correctly before a procedure is executed. If the 5520 is connected to a standard serial port (COM1, COM2, ..., COM16), select the "Ports" application in the Windows control panel to choose the proper settings. If the 5520 is connected to the 5500A or 5800A UUT port, select the proper settings for the UUT Serial Port from the front panel of the calibrator.

Functional Capability (NORMAL, AUX, and 20 A Outputs)

Function | Amplitude | Frequency/Period | Misc.
DC Voltage
Normal Output | -1020V to 1020V |  |
TC Output | -329.9999 mV to 329.9999 mV |  |
AC Voltage, Normal Output
Sine | 1 mV to 33 mV | 0.01 Hz to 9.99 Hz | Vp + |Voff|≤80 mVp
 | 34 mV to 330 mV | 0.01 Hz to 9.99 Hz | Vp + |Voff|≤800 mVp
 | 0.4 V to 3.3 V | 0.01 Hz to 9.99 Hz | Vp + |Voff|≤8 Vp
 | 4 V to 33 V | 0.01 Hz to 9.99 Hz | Vp + |Voff|≤50 Vp
 | 1 mV to 32.999 mV | 10 Hz to 500 kHz | Vp + |Voff|≤80 mVp
 | 33 mV to 329.999 mV | 10 Hz to 500 kHz | Vp + |Voff|≤800 mVp
 | 0.33 V to 3.29999 V | 10 Hz to 500 kHz | Vp + |Voff|≤8 Vp
 | 3.3 V to 32.9999 V | 10 Hz to 100 kHz | Vp + |Voff|≤55 Vp
 | 33 V to 329.999 V | 45 Hz to 100 kHz |
 | 330 V to 1020 V | 45 Hz to 10 kHz |
 | 0.3 V to 3.3 V | 1 MHz, 2MHz |
 | -63.80 dBm to -7.29 dBm | 0.01 Hz to 9.99 Hz | Vp + |Voff|≤80 mVp
 | -27.28 dBm to -7.40 dBm | 0.01 Hz to 9.99 Hz | Vp + |Voff|≤800 mVp
 | -7.3 dBm to 12.7 dBm | 0.01 Hz to 9.99 Hz | Vp + |Voff|≤8 Vp
 | 13 dBm to 32 dBm | 0.01 Hz to 9.99 Hz | Vp + |Voff|≤50 Vp
 | -57.78 dBm to -27.41 dBm | 10 Hz to 500 kHz | Vp + |Voff|≤80 mVp
 | -27.41 dBm to -7.41 dBm | 10 Hz to 500 kHz | Vp + |Voff|≤800 mVp
 | -7.41 dBm to 12.58 dBm | 10 Hz to 500 kHz | Vp + |Voff|≤8 Vp
 | 12.59 dBm to 32.58 dBm | 10 Hz to 100 kHz | Vp + |Voff|≤55 Vp
 | 32.59 dBm to 52.58 dBm | 45 Hz to 100 kHz |
 | 52.59 dBm to 62.39 dBm | 45 Hz to 10 kHz |
 | -8 dBm to 12.7 dBm | 1 MHz, 2 MHz |
Square 1 | 3 mVpp to 66 mVpp | 0.01 Hz to 9.99 Hz | Vp + |Voff|≤80 mVp
 | 67 mVpp to 660 mVpp | 0.01 Hz to 9.99 Hz | Vp + |Voff|≤800 mVp
 | 0.7 Vpp to 6.6 Vpp | 0.01 Hz to 9.99 Hz | Vp + |Voff|≤8 Vp
 | 7 Vpp to 66 Vpp | 0.01 Hz to 9.99 Hz | Vp + |Voff|≤55 Vp
 | 2.9 mVpp to 65.999 mVpp | 10 Hz to 100 kHz | Vp + |Voff|≤80 mVp
 | 66 mVpp to 659.999 mVpp | 10 Hz to 100 kHz | Vp + |Voff|≤800 mVp
 | 0.66 Vpp to 6.59999 Vpp | 10 Hz to 100 kHz | Vp + |Voff|≤8 Vp
 | 6.6 Vpp to 66 Vpp | 10 Hz to 100 kHz | Vp + |Voff|≤55 Vp
Triangle & Truncated Sine | 2.9 mVpp to 92.999 | 10 Hz to 100 kHz | Vp + |Voff|≤80 mVp
 | 93 mVpp to 929.999 mVpp | 10 Hz to 100 kHz | Vp + |Voff|≤800 mVp
 | 0.93 Vpp to 9.29999 Vpp | 10 Hz to 100 kHz | Vp + |Voff|≤8 Vp
 | 9.3 Vpp to 93 Vpp | 10 Hz to 100 kHz | Vp + |Voff|≤55 Vp
DC Current
Aux. Output | -2.99999 A to 2.99999 A |  |
20 A Output | -20.5 A to -3 A, 3 A to 20.5 A |  |
w/range lock | -20.5 A to 20.5 A |  |
AC Current, AUX Output, LCOMP OFF
Sine, no toroid | 29 μA to 330 mA | 0.01 Hz to 9.99 Hz |
 | 29 μA to 329.999 mA | 10 Hz to 30 kHz |
 | 0.33 A to 2.99999 A | 10 Hz to 10 kHz |
10-turn toroid | 0.29 mA to 3.29999 A | 10 Hz to 30 kHz |
 | 3.3 A to 29.9999 A | 10 Hz to 10 kHz |
30-turn toroid | 0.87 mA to 8.9997 A | 10 Hz to 30 kHz |
 | 9.9 A to 65.9997 A | 10 Hz to 10 kHz |
50-turn toroid | 1.45 mA to 16.49995 A | 10 Hz to 30 kHz |
 | 16.5 A to 109.9995 A | 10 Hz to 10 kHz |
Square | 47 μApp to 660 mApp | 0.01 Hz to 9.99 Hz |
 | 47 μApp to 5.99999 App | 10 Hz to 10 kHz |
Triangle & Truncated Sine | 47 μApp to 930 mApp | 0.01 Hz to 9.99 Hz |
 | 47 μApp to 8.49999 App | 10 Hz to 10 kHz |
AC Current, 20A Output, LCOMP OFF
Sine , no toroid | 3 A to 20.5 A | 45 Hz to 5 kHz |
10-turn toroid | 30 A to 205 A | 45 Hz to 5 kHz |
30-turn toroid | 90 A to 615 A | 45 Hz to 5 kHz |
50-turn toroid | 150 A to 1025 A | 45 Hz to 5 kHz |
Square | 6 App to 41 App | 45 Hz to 1 kHz |
Triangle & Truncated Sine | 8.5 App to 57 App | 45 Hz to 1 kHz |
AC Current, AUX Output, LCOMP ON
Sine, no toroid | 29 μA to 329.999 mA | 10 Hz to 1 kHz |
 | 0.33 A to 2.99999 A | 10 Hz to 440 Hz |
10-turn toroid | 0.29 mA to 3.29999 A | 10 Hz to 1 kHz |
 | 3.3 A to 29.9999 A | 10 Hz to 440 Hz |
30-turn toroid | 0.87 mA to 8.9997 A | 10 Hz to 1 kHz |
 | 9.9 A to 65.9997 A | 10 Hz to 440 Hz |
50-turn toroid | 1.45 mA to 16.49995A | 10 Hz to 1 kHz |
 | 16.5 A to 109.9995 A | 10 Hz to 440 Hz |
Square | 47 μApp to 659.999 mApp | 10 Hz to 1 kHz |
 | 0.66 App to 5.99999 App | 10 Hz to 440 Hz |
Triangle & Truncated Sine | 47 μApp to 929.999 mApp | 10 Hz to 1 kHz |
 | 0.93 App to 8.49999 App | 10 Hz to 440 Hz |
AC Current, 20A Output, LCOMP ON
Sine, no toroid | 3 A to 20.5 A | 45 Hz to 440 Hz |
10-turn toroid | 30 A to 205 A | 45 Hz to 440 Hz |
30-turn toroid | 90 A to 615 A | 45 Hz to 440 Hz |
50-turn toroid | 150 A to 1025 A | 45 Hz to 440 Hz |
Square | 6 App to 41 App | 45 Hz to 440 Hz |
Triangle & Truncated Sine | 8.5 App to 57 App | 45 Hz to 440 Hz |

Synthesized Resistance
4-wire & 2-wire comp. | 0 Ω to 109.999 kΩ
2-wire | 110 kΩ to 1100 MΩ
Synthesized Capacitance
2-wire | 330 pF to 110.00 mF
2-wire comp. | 110 nF to 110.00 mF

RTD Calibration
100 Ω Pt 385 | -200 °C to 800 °C (-328 °F to 1472 °F)
200 Ω Pt 385 | -200 °C to 630 °C (-328 °F to 1166 °F)
500 Ω Pt 385 | -200 °C to 630 °C (-328 °F to 1166 °F)
1 kΩ Pt 385 | -200 °C to 630 °C (-328 °F to 1166 °F)
100 Ω Pt 3916 | -200 °C to 630 °C (-328 °F to 1166 °F)
100 Ω Pt 3926 | -200 °C to 630 °C (-328 °F to 1166 °F)
120 Ω Ni | -80 °C to 260 °C (-112 °F to 500 °F)
10 Ω Cu | -100 °C to 260 °C (-148 °F to 500 °F)

Thermocouple Calibration and Measurement
Type B | 600 °C to 1820 °C (1112 °F to 3308 °F)
Type C | 0 °C to 2316 °C (32 °F to 4201 °F)
Type E | -250 °C to 1000 °C (-418 °F to 1832 °F)
Type J | -210 °C to 1200 °C (-410 °F to 2192 °F)
Type K | -200 °C to 1372 °C (-328 °F to 2502 °F)
Type L | -200 °C to 900 d°C (-328 °F to 2502 °F)
Type N | -200 °C to 1300 °C (-328 °F to 2372 °F)
Type R | 0 °C to 1767 °C (32 °F to 3213 °F)
Type S | 0 °C to 1767 °C (32 °F to 3213 °F)
Type T | -250 °C to 400 °C (-418 °F to 752 °F)
Type U | -200 °C to 600 °C (-328 °F to 1103 °F)

Function | Amplitude | Frequency/Period
Dual DC Voltage
Normal Output | 1020 V to 1020 V
Aux Output | -7 V to 7 V
Dual AC Voltage, Normal Output 4
Sine 2 | 1 mV to 1020 V | 10 Hz to 10 kHz
Square | 2.9 mVpp to 66 Vpp | 10 Hz to 10 kHz
Triangle & Truncated Sine | 2.9 mVpp to 93 Vpp | 10 Hz to 10 kHz
Dual AC Voltage, Aux Output
Sine 2 | 10 mV to 330 mV | 0.01 Hz to 9.99 Hz
0.4 V to 3.3 V | 0.01 Hz to 9.99 Hz
10 mV to 3.29999 V | 10 Hz to 30 kHz
3.3 V to 5 V | 10 Hz to 10 kHz
Square | 29 mVpp to 6.59999 Vpp | 0.01 Hz to 10 kHz
6.6 Vpp to 14 Vpp | 0.01 Hz to 1 kHz
Triangle & Truncated Sine | 29 mVpp to 9.29999 Vpp | 0.01 Hz to 10 kHz
9.3 Vpp to 14 Vpp | 0.01 Hz to 1 kHz
DC Power
Normal Output | -1020 V to 1020 V
Aux Output | -2.99999 A to 2.99999 A
20 A Output | -20.5 A to 20.5 A
AC Power, Normal Output 4
Sine 2 | 1mV to 1020V | 3
-57.78dBm to 62.39dBm | 3
Square | 2.9mVpp to 65.9999Vpp | 3
Triangle & Truncated Sine | 2.9mVpp to 93Vpp | 3
AC Power, Aux Output, LCOMP OFF
Sine, no toroid | 29 μA to 330 mA | 0.01 Hz to 9.99 Hz
29 μA to 329.999 mA | 10 Hz to 30 kHz
0.33 A to 2.99999 A | 10 Hz to 10 kHz
10-turn toroid | 0.29 mA to 3.29999 A | 10 Hz to 30 kHz
3.3 A to 29.9999 A | 10 Hz to 10 kHz
30-turn toroid | 0.87 mA to 8.9997 A | 10 Hz to 30 kHz
9.9 A to 65.9997 A | 10 Hz to 10 kHz
50-turn toroid | 1.45 mA to 16.49995 A | 10 Hz to 30 kHz
16.5 A to 109.9995 A | 10 Hz to 10 kHz
Square | 47 μApp to 660 mApp | 0.01 Hz to 9.99 Hz
47 μApp to 5.99999 App | 10 Hz to 10 kHz
Triangle & Truncated Sine | 47 μApp to 930 mApp | 0.01 Hz to 9.99 Hz
47 μApp to 8.49999 App | 10 Hz to 10 kHz
AC Power, 20 A Output, LCOMP OFF
Sine, no toroid | 3 A to 20.5 A | 45 Hz to 5 kHz
10-turn toroid | 30 A to 205 A | 45 Hz to 5 kHz
30-turn toroid | 90 A to 615 A | 45 Hz to 5 kHz
50-turn toroid | 150 A to 1025 A | 45 Hz to 5 kHz
Square | 6 App to 41 App | 45 Hz to 5 kHz
Triangle & Truncated Sine | 8.5 App to 57 App | 45 Hz to 5 kHz
AC Power, 20 A Output, LCOMP ON
Sine , no toroid | 29 μA to 329.999 mA | 10 Hz to 1 kHz
0.33 A to 2.99999 A | 10 Hz to 440 Hz
0.29 mA to 3.29999 A | 10 Hz to 1 kHz
10-turn toroid | 3.3 A to 29.9999 A | 10 Hz to 440 Hz
30-turn toroid | 0.87 mA to 8.9997 A | 10 Hz to 1 kHz
9.9 A to 65.9997 A | 10 Hz to 440 Hz
50-turn toroid | 1.45 mA to 16.49995 A | 10 Hz to 1 kHz
16.5 A to 109.9995 A | 10 Hz to 440 Hz
Square | 47 μApp to 659.999 mApp | 10 Hz to 1 kHz
0.66 App to 5.99999 App | 10 Hz to 440 Hz
Triangle & Truncated Sine | 47 μApp to 929.999 mApp | 10 Hz to 1 kHz
0.93 App to 8.49999 App | 10 Hz to 440 Hz
AC Power, 20 A Output, LCOMP ON
Sine , no toroid | 3 A to 20.5 A | 45 Hz to 440 Hz
10-turn toroid | 30 A to 205 A | 45 Hz to 440 Hz
30-turn toroid | 90 A to 615 A | 45 Hz to 440 Hz
50-turn toroid | 150 A to 1025 A | 45 Hz to 440 Hz
Square | 6 App to 41 App | 45 Hz to 440 Hz
Triangle & Truncated Sine | 8.5 App to 57 App | 45 Hz to 440 Hz
Humidity Meas.
  1. A duty cycle of 1% to 99% may be specified for square waves. The default is 50%.
  2. When both waveforms are sine, either the Normal or Aux output may be specified to be a harmonic from 1 to 31.
  3. The frequency is the same for the voltage and the current, therefore the limits of the AC Voltage frequency are the same as those specified for the AC Current range selected.
  4. The phase between the two output signals may be specified from -180 degrees to +180 degrees.

Functional Capability (Scope Output with Option SC300 Installed)

Function | Amplitude | Frequency | Misc.
DC Voltage
50 Ω term. | -2.2 V to 2.2 V |  |
1 MΩ term. | -33 V to 33 V |  |
AC Voltage
Scope Square Wave (zero based)
50 Ω term. | 1.8 mVpp to 2.2 Vpp | 10 Hz to 10 kHz |
1 MΩ term. | 1.8 mVpp to 55 Vpp | 10 Hz to 10 kHz |
ScopeMeter Square Wave
1 MΩ term. | 95 Vpp to 105 Vpp | 10 Hz to 10 kHz |
Edge
50 Ω term. | 5 mVpp to 2.5 Vpp | 1 kHz to 1 MHz | In a 1-(2.5)-5 sequence ±10%
Leveled Sine
50 Ω term. | 5 mVpp to 5.5 Vpp | 50 kHz to 350 MHz |
Time Markers |  |  | Period
50 Ω term. |  |  | 1.8 ns to 2.2 ns
 |  |  | 4.5 ns to 11 ns
 |  |  | 18 ns to 22 ns
 |  |  | 45 ns to 110 ns
 |  |  | 180 ns to 1.1 μs
 |  |  | 1.8 μs to 60 μs
 |  |  | 90 μs to 12 ms
 |  |  | 18 ms to 5.5 s
Wavegen
Sine, Square, and Triangle Waveforms (zero centered) |  |  | Max AC + DC Offset
50 Ω term. | 1.8 mVpp to 10.9 mVpp | 10 Hz to 100 kHz | Vp + |Voff|≤12.5 mVp
 | 11 mVpp to 44.9 mVpp | 10 Hz to 100 kHz | Vp + |Voff|≤50.5 mVp
 | 45 mVpp to 109 mVpp | 10 Hz to 100 kHz | Vp + |Voff|≤125 mVp
 | 110 mVpp to 449 mVpp | 10 Hz to 100 kHz | Vp + |Voff|≤225 mVp
 | 0.45 Vpp to 1.09 Vpp | 10 Hz to 100 kHz | Vp + |Voff|≤1.25 Vp
 | 1.1 Vpp to 2.2 Vpp | 10 Hz to 100 kHz | Vp + |Voff|≤3.1 Vp
1 MΩ term. | 1.8 mVpp to 21.9 mVpp | 10 Hz to 100 kHz | Vp + |Voff|≤26 mVp
 | 22 mVpp to 89.9 mVpp | 10 Hz to 100 kHz | Vp + |Voff|≤100 mVp
 | 90 mVpp to 219 mVpp | 10 Hz to 100 kHz | Vp + |Voff|≤260 mVp
 | 220 mVpp to 899 mVpp | 10 Hz to 100 kHz | Vp + |Voff|≤1000 mVp
 | 0.9 Vpp to 6.59 Vpp | 10 Hz to 100 kHz | Vp + |Voff|≤6.6 Vp
 | 6.6 Vpp to 55 Vpp | 10 Hz to 100 kHz | Vp + |Voff|≤50 Vp

Functional Capability (Scope Output with Option SC600 or SC1100 Installed)

Function | Amplitude | Frequency | Misc.
DC Voltage
50 Ω term. | -6.599 V to 6.599 V |  |
1 MΩ term. | -130 V to 130 V |  |
AC Voltage
Scope Square Wave (zero based, positive and negative)
50 Ω term. | 1.0 mVpp to 6.599 Vpp | 10 Hz to 10 kHz |
1 MΩ term. | 1.0 mVpp to 130 Vpp | 10 Hz to 10 kHz |
Edge
50 Ω term. | 5 mVpp to 2.5 Vpp | 900 Hz to 11 MHz | In a 1-(2.5)-5 seq ±10 %
w/Tunnel Diode Pulser Drive Signal | 11 Vpp to 2.5 Vpp | 900 Hz to 11 MHz |
Leveled Sine
50 Ω term. | 5 mVpp to 5.5 Vpp | 50 kHz to 600 MHz |
Time Markers
50 Ω term. | 5 mVpp to 3.5 Vpp | 600 MHz to1100 MHz |
Spike (SC1100 only) |  |  | Period
Square |  |  | 18 ns to 5.5 s
20% Duty |  |  | 7.5 ns to 5.5 s
Square |  |  | 75 ns to 34.99 ms
Sine |  |  | 1.8 ns to 17.9 ns (lower limit is 0.91ns for SC1100)
Wavegen
Sine, Square, and Triangle Waveforms (zero centered) |  |  | Max AC + DC Offset
50 Ω term. | 1.8 mVpp to 10.9 mVpp | 10 Hz to 100 kHz | Vp + |Voff|≤12.5mVp
 | 11 mVpp to 44.9 mVpp | 10 Hz to 100 kHz | Vp + |Voff|≤50.5mVp
 | 45 mVpp to 109 mVpp | 10 Hz to 100 kHz | Vp + |Voff|≤125mVp
 | 110 mVpp to 449 mVpp | 10 Hz to 100 kHz | Vp + |Voff|≤225mVp
 | 0.45 Vpp to 1.09 Vpp | 10 Hz to 100 kHz | Vp + |Voff|≤1.25Vp
 | 1.1 Vpp to 2.5 Vpp | 10 Hz to 100 kHz | Vp + |Voff|≤3.1Vp
1 MΩ term. | 1.8 mVpp to 21.9 mVpp | 10 Hz to 100 kHz | Vp + |Voff|≤26mVp
 | 22 mVpp to 89.9 mVpp | 10 Hz to 100 kHz | Vp + |Voff|≤100mVp
 | 90 mVpp to 219 mVpp | 10 Hz to 100 kHz | Vp + |Voff|≤260mVp
 | 220 mVpp to 899 mVpp | 10 Hz to 100 kHz | Vp + |Voff|≤1000mVp
 | 0.9 Vpp to 6.59 Vpp | 10 Hz to 100 kHz | Vp + |Voff|≤6.6Vp
 | 6.6 Vpp to 55 Vpp | 10 Hz to 100 kHz | Vp + |Voff|≤50Vp
Video |  |  | Line Marker
NTSC | -150 % to 150 % |  | 1 to 262 Odd or Even
 | -1.5 Vp to 1.5 Vp |  | 1 to 262 Odd or Even
 | -140 IRE to 140 IRE |  | 1 to 262 Odd or Even
PAL | -150 % to 150 % |  | 1 to 622
 | -1.5 Vp to 1.5 Vp |  | 1 to 622
PAL-M | -150 % to 150 % |  | 1 to 262 Odd or Even
 | -1.5 Vp to 1.5 Vp |  | 1 to 262 Odd or Even
 | -140 IRE to 140 IRE |  | 1 to 262 Odd or Even
SECAM | -150 % to 150 % |  | 1 to 622
 | -1.5 Vp to 1.5 Vp |  | 1 to 622
Pulse |  | Period | Pulse Width
50 Ohm term. | 10 mVpp, 25 mVpp, 100 mVpp, 250 mVpp, 1 Vpp, and 2.5 Vpp | 200 ns to 22 ms | 2 ns to 500 ns
UUT Input Impedance Measurement (MEAS Z)
50 Ω |  |  | 40 Ω to 60 Ω
1 MΩ |  |  | 500 kΩ to 1.5 MΩ
Capacitance |  |  | 5 pF to 50 pF
UUT 50 Ohm Input Impedance Overload Protection Measurement (OVERLD)
DC | 5 V to 9 V |  |
AC | 5 V to 9 V | 1 kHz |

Parameters

The following table describes the basic operating modes of the 5520 Calibrator in terms of the FSC fields listed. Only the combinations of field quantities listed below are allowed. These mode names are also used in other places in this section to clarify the rules for each parameter of the 5520 FSC.

5520 Operating Modes

5520 Mode | 5520 NOMINAL | 5520 MOD1 | 5520 MOD3 1 | M5520 RANGE | M5520 NOMINAL | M5520 MOD1
DC Voltage | voltage |  | [TC|SC|S6] | [RNGLK | voltage] |
AC Voltage | voltage | freq|period | [SC|S6] |  |  | [DC offset]
AC Voltage | freq|period voltage |  |  |  |  | [DC offset]
AC Voltage (pulse) | p-width period | voltage voltage | S6 S6 | PER PULSE | period p-width |
Period and pulse width (p-width) may be entered as a frequency in Hertz.
AC Voltage | duty cycle | freq|period |  |  | voltage | [DC offset]
AC Voltage (time marks) | freq|period |  | SC|S6 |  |  |
DC Current | current |  | [HC] | [RNGLK | current] |
AC Current | current | freq/period | [HC] |  |  |
AC Current | freq|period | current | [HC] |  |  |
Resistance | resistance |  |  |  |  |
Resistance | conductance |  |  |  |  |
Capacitance | capacitance |  |  |  |  |
RTD Cal | temperature |  |  |  |  |
TC Cal | temperature |  | TC | [TCREF | temp.] |
TC Meas | temperature |  | TM|TN | [TCREF | temp.] |
Humidity Meas | percent |  | HM |  |  |
Impedance Meas | resistance| capacitance |  | ZM |  |  |
Overload Meas | voltage | [freq] | OM | LIMIT | time |
Dual DC | voltage |  | [AX] |  |  | voltage
Dual AC | voltage | freq|period |  | [AX] | [Hn|HXn] | voltage
Dual AC | Voltage | freq|period |  |  | [HXn] | voltage
Dual AC | Voltage | freq|period | voltage | AX | [H<n] | voltage
Dual AC | phase | freq|period | voltage | [AX] | [Hn|HXn] | voltage
DC Power | power |  | [HC] |  |  | voltage
DC Power | power |  |  |  |  | current
DC Power | voltage |  |  |  |  | current
DC Power | current | [HC] |  |  |  | voltage
AC Power | power | freq|period |  |  | [Hn|HXn| LEAD|LAG] | voltage
AC Power | power | freq|period |  |  | [Hn|HXn| LEAD|LAG] | current
AC Power | current | freq|period [HC] |  |  | [Hn|HXn| LEAD|LAG] | voltage
AC Power | voltage | freq|period |  |  | [Hn|HXn| LEAD|LAG] | current
AC Power | freq|period | current | [HC] |  | [Hn| LEAD|LAG] | voltage
AC Power | freq|period | voltage |  |  | [HXn| LEAD|LAG] | current
AC Power | phase | freq|period |  |  | [Hn|HXn| | voltage
AC Power | phase | freq|period |  |  | [Hn|HXn| | current
Video | percent| voltage| IRE | line marker |  | S6 | [ODD|EVEN] |
Blank entries in the above table are significant and must be blank. FSC field inter-dependencies not expressed in this table are listed under "Rules" for the appropriate parameter. (1) See MOD3 parameter for description of these specification codes and rules.

Units Symbols

Units | Symbol Name | Quantity
A | Amps | current
Ap | Amps peak | current
App | Amps peak to peak | current
D | dBm | decibels
F | Farads | capacitance
H | Hertz | frequency
IRE | IRE | video amplitude
LM | Line Marker | video line marker position
T | Time | period or pulse width
V | Volts | voltage or video amplitude
Vp | Volts peak | voltage
Vpp | Volts peak to peak | voltage
W | Watts | power
Y | Siemens | conductance
Z | Ohms | resistance
deg | degrees | phase
degC | degrees Celsius | temperature
degF | degrees Fahrenheit | temperature
pct | percent | duty cycle, video amplitude, or humidity

5520 FSC NOMINAL, MOD1, MOD2, and MOD3 Rules

5520 Mode | 5520 NOMINAL | 5520 MOD1 | 5520 MOD2 1 | 5520 MOD3 2
DC Voltage | V | [TC]
AC Voltage | V|Vpp|D | H|T | SI
V|Vpp | H|T | SQ|TI|TS
Vp | H|T | SI
Vp | H|T | SQ|TI|TS
H|T | V|Vpp|D | SI
H|T | V|Vpp | SQ|TI|TS
pct | H|T | SI|SQ|TI|TS
DC Current | A | [HC] | [HC]
AC Current | A|App | H|T | SI
A|App | H|T | SI|SQ|TI|TS | [HC]
Ap | H|T | SI|SQ|TI|TS | [HC]
H|T | A|App | SI|SQ|TI|TS | [HC]
Resistance | Z|Y
Capacitance | F
RTD Cal | degC|degF | R1|R2|R3|R4|R5|R6|R7|R8
TC Cal | degC|degF | _B|_C|_E|_J|_K|_L|_N|_R|_S| TC _T|_U
TC Meas degC|degF _B|_C|_E|_J|_K|_L|_N|_R|_S| TM|TN|_T|_U|PB
Humidity Meas | pct | PB | HM
Dual DC Voltage | V | [AX]
Dual AC Voltage | V|Vp|Vpp|D | H|T | SI | [AX]
V|Vp|Vpp | SQ|TI|TS | [AX]
H|T | H|T | SI | [AX]
H|T | V|Vpp|D | SQ|TI|TS | [AX]
DC Power | W|A|V | V|Vpp | [HC]
AC Power | W | H|T | SI | [HC]
V|Vp|Vpp|D | H|T | SI
V|Vp|Vpp | H|T | SQ|TI|TS
A|Ap|App | H|T | SI|SQ|TI|TS | [HC]
H|T | V|Vpp|D | SI
H|T | V|Vpp | SQ|TI|TS
H|T | A|App | SI|SQ|TI|TS | [HC]
  1. See MOD2 parameter for description of these specification codes and rules.
  2. See MOD3 parameter for description of these specification codes and rules. 5520 FSC NOMINAL, MOD1, MOD2, and MOD3 Rules for SC300
Blank entries in the above table are significant and must be blank. FSC field inter-dependencies not expressed in this table are listed under "Rules" for the appropriate parameter.

5520 FSC Nominal, MOD1, MOD2, and MOD3 Rules for SC300

5520 Mode | 5520 NOMINAL | 5520 MOD1 | 5520 MOD2 1 | 5520 MOD3 2
DC Voltage (VOLT) | V | SC
AC Voltage (VOLT) | V|Vp|Vpp | H|T | ZQ|SM | SC
H|T | V|Vpp | ZQ|SM | SC
AC Voltage (EDGE) | V|Vp|Vpp | H|T | ED | SC
AC Voltage (LEVSINE) | V|Vp|Vpp | H|T | LS | SC
H|T | V|Vpp | LS | SC
AC Voltage (MARKER) | H|T | MK | SC
AC Voltage (WAVEGEN) | V|Vp|Vpp | H|T | SI|SQ|TI | SC
H|T | V|Vpp | SI|SQ|TI
  1. See MOD2 parameter for description of these specification codes and rules.
  2. See MOD3 parameter for description of these specification codes and rules.
Blank entries in the above table are significant and must be blank. FSC field inter-dependencies not expressed in this table are listed under "Rules" for the appropriate parameter.

5520 FSC NOMINAL, MOD1, MOD2, and MOD3 Rules for SC600 and SC1100

5520 Mode | 5520 NOMINAL | 5520 MOD1 | 5520 MOD2 1 | 5520 MOD3 2
DC Voltage (VOLT) | V | S6
AC Voltage (VOLT) | V|Vp|Vpp | H|T | ZQ|ZN | S6
H|T | V|Vpp | ZQ|ZN | S6
AC Voltage (EDGE) | V|Vp|Vpp | H|T | ED | S6
H|T | V|Vpp | ED | S6
AC Voltage (LEVSINE) | V|Vp|Vpp | H|T | LS | S6
H|T | V|Vpp | LS | S6
AC Voltage (MARKER) | H|T | M1|M2|M3|M4 | S6
AC Voltage (WAVEGEN) | V|Vp|Vpp | H|T | SI|SQ|TI | S6
H|T | V|Vpp | SI|SQ|TI
AC Voltage (PULSE) | H|T | Vpp | PU | S6
Video | pct|Vp|IRE | LM | F1|F3 | S6
(VIDEO) | pct|Vp | LM | F2|F4 | S6
Impedance Meas (MEAS Z) | Z | ZM | F | ZM
Overload Meas (OVERLD) | V | OM | Vpp | H
OM
  1. See MOD2 parameter for description of these specification codes and rules.
  2. See MOD3 parameter for description of these specification codes and rules.
Blank entries in the above table are significant and must be blank. FSC field inter-dependencies not expressed in this table are listed under "Rules" for the appropriate parameter.

RANGE

This field specifies the UUT range as described in the RANGE Field topic.

NOMINAL

This field specifies the starting Nominal value of the stimulus output or expected UUT reading for the test entered as:

[numeric][prefix]units symbol

or "*" to specify a reset.

Rules:

  1. The NOMINAL field may not specify frequency or period when any of the following sets of conditions exist:
    1. Dual AC Voltage is specified and either
      1. the M5520 RANGE field specifies H and the M5520 MOD3 field specifies AX or
      2. the M5520 RANGE field specifies HX and the 5520 MOD3 field specifies AX.
    2. AC Power is specified and either
      1. the M5520 RANGE field specifies H and the M5520 NOMINAL field specifies current or
      2. the M5520 RANGE field specifies HX and the M5520 NOMINAL field specifies voltage.
    3. The MOD3 field specifies E.
  2. When the NOMINAL field specifies frequency or period and the M5520 RANGE field specifies a harmonic (H or HX), the Keyboard Entry (ASK+ K) or Go/No-Go (ASK+ G) evaluation mode must be specified, Slew is not allowed.

    A duty cycle other than 50% may only be specified for square waveforms (MOD2 is SQ). Therefore keyboard entry and go-nogo evaluations may be performed at 50% duty cycle for non-square waveforms, but slew mode is not allowed. In addition the duty cycle is restricted to 50%, regardless of the type of waveform, when the DC offset is not zero.

  3. When the NOMINAL field specifies power and the value is slewed, if the M5520 NOMINAL field specifies voltage, the voltage is held constant and a new value of current is computed by the 5520.

    If the M5520 NOMINAL field specifies current, the current is held constant and a new value of voltage is computed by the 5520.

  4. When the NOMINAL field contains only units, the value is obtained from the memory register MEM.
  5. When the NOMINAL field contains only units and the MOD1 field is not blank, the MOD1 field must specify a value.

TOLERANCE

This field specifies the UUT tolerance as described in the TOLERANCE Field topic.

MOD1

This field specifies the frequency, period, voltage, or current for

AC Voltage, AC Current, Dual AC Voltage, or AC Power modes entered as:

[numeric][prefix]units symbol

Rules:

  1. When the MOD1 field contains only units, the value is obtained from memory register MEM. In this case the NOMINAL field MUST contain a value.

MOD2

This field specifies one of the following:

  1. The waveform type for the voltage or current specified in the NOMINAL or MOD1 field for AC Voltage or AC Current.
  2. The waveform type for the voltage or current not specified in the M5520 NOMINAL field for AC Power or Dual AC Voltage.
  3. The thermocouple or RTD type for TC Measurement, TC Calibration, or RTD Calibration.
blank | DC or not applicable
SI | Sine wave (5520 and SC300, SC600, and SC1100 Wavegen)
SQ | Square wave (5520 and SC300, SC600, and SC1100 Wavegen)
TI | Triangle wave (5520 and SC300, SC600, and SC1100 Wavegen)
TS | Truncated sine wave
PB | Temperature/Humidity Probe
_B | Type B thermocouple
_C | Type C thermocouple
_E | Type E thermocouple
_J | Type J thermocouple
_K | Type K thermocouple
_L | Type L thermocouple
_N | Type N thermocouple
_R | Type R thermocouple
_S | Type S thermocouple
_T | Type T thermocouple
_U | Type U thermocouple
R1 | 100 Ohm Pt385 RTD
R2 | 100 Ohm Pt3926 RTD
R3 | 120 Ohm Ni672 RTD
R4 | 200 Ohm Pt385 RTD
R5 | 500 Ohm Pt385 RTD
R6 | 1 kOhm Pt385 RTD
R7 | 100 Ohm Pt3916 RTD
R8 | 10 Ohm Cu427 RTD
ZQ | Positive square wave (SC300, SC600, & SC1100 AC Voltage)
ZN | Negative square wave (SC600 & SC1100 AC Voltage)
SM | ScopeMeter wave (SC300 AC Voltage)
ED | Edge signal (SC300, SC600, & SC1100)
LS | Leveled sine wave (SC300, SC600, & SC1100)
MK | Marker signal (SC300)
M1 | Spike Marker signal (SC600 & SC1100)
M2 | Square Marker signal (SC600 & SC1100)
M3 | 20% Duty Cycle Square Marker signal (SC600 & SC1100)
M4 | Sinusoid Marker signal (SC600 & SC1100)
PU | Pulse wave (SC600 & SC1100)
F1 | NTSC video signal (SC600 & SC1100)
F2 | PAL video signal (SC600 & SC1100)
F3 | PAL-M video signal (SC600 & SC1100)
F4 | SECAM video signal (SC600 & SC1100)

Rules:

  1. SI is inserted automatically in the MOD2 field for AC Voltage, AC Current, Dual AC Voltage, or AC Power (i.e. the MOD1 field is not blank) if no MOD2 code is entered.
  2. _K is inserted automatically in the MOD2 field for TC Measurement or TC Calibration if no MOD2 code is entered.
  3. R1 is inserted automatically in the MOD2 field for RTD Calibration if no MOD2 code is entered.
  4. The M5520 RANGE and NOMINAL field must specify the pulse wave period or frequency when the MOD2 field specifies PU and the NOMINAL field specifies the pulse width.
  5. The M5520 RANGE and NOMINAL field must specify the pulse width when the MOD2 field specifies PU and the NOMINAL field specifies the pulse wave period or frequency.
  6. The M5520 RANGE field must specify ODD or EVEN frame when the MOD2 field specifies F1 (NTSC video) or F3 (PAL-M video).

MOD3

This field specifies the calibrator output mode:

blank | Default for mode specified
AX | Auxiliary Voltage
HC | 20A Output
HM | Humidity Measurement
OM | SC600 or SC1100 UUT 50 Ohm Input Overload Protection

Measurement

S6 | SC600 or SC1100 Scope Option
SC | SC300 Scope Option
TC | Thermocouple Cal
TM | Thermocouple Measurement (open TC detection on)
TN | Thermocouple Measurement (open TC detection off)
ZM | SC600 or SC1100 UUT Input Impedance Measurement

Rules:

  1. The MOD3 field must specify AX when Dual DC Voltage or Dual AC Voltage is specified and the M5520 MOD3 field does not specify AX.
  2. The MOD3 field may specify SC only when the SC300 Scope option is configured.
  3. The MOD3 field may specify S6 only when the SC600 or SC1100 Scope option is configured.
  4. SC is inserted automatically in the MOD3 field when the MOD2 field specifies ZQ, SM, ED, LS, or MK, and the SC300 Scope Option is configured, and no MOD3 code is entered.
  5. S6 is inserted automatically in the MOD3 field when the MOD2 field specifies ZQ, ZN, ED, LS, PU, M1, M2, M3, M4, F1, F2, F3, or F4, and the SC600 or SC1100 Scope Option is configured, and no MOD3 code is entered.
  6. The M5520 RANGE and NOMINAL fields must specify the time limit when the MOD3 field specifies OM.

MOD4

This field specifies the type of test being performed as described in the MOD4 Field topic.

Additional Rules:

  1. The MOD4 field must specify N (Nominal Setup Test) when the MOD3 field specifies OM (Overload Measurement).
  2. N is inserted automatically in the MOD4 field when the MOD3 field specifies OM and no MOD3 code is entered.

CON

This field specifies the UUT connection.

2W | 2-wire
L2W | 2-wire w/load compensation enabled
3W | 3-wire
4W | 4-wire
CW | 2-wire ohms compensated at the UUT terminals
DV | 2-wire using the external AC Divider
TD | Tunnel Diode Pulser Drive signal enabled
T1 | 10-turn Toroid Coil
LT1 | 10-turn Toroid Coil w/load compensation enabled
T3 | 30-turn Toroid Coil
LT3 | 30-turn Toroid Coil w/load compensation enabled
T5 | 50-turn Toroid Coil
LT5 | 50-turn Toroid Coil w/load compensation enabled
FT | 5500A/COIL and Toroidal UUT
LFT | 5500A/COIL and Toroidal UUT w/load compensation enabled
FX | 5500A/COIL and Non-toroidal UUT
LFX | 5500A/COIL and Non-toroidal UUT w/load compensation enabled
L | 50 Ohm Termination
blank | 1 MOhm Termination

Rules:

  1. 2W is inserted automatically in the CON field when the MOD3 field does not specify SC or S6 and no CON field code is entered.
  2. The CON field may specify 3W only when the RTD Cal mode is specified.
  3. The CON field may specify CW only when RTD Cal, Resistance, or Capacitance mode is specified.
  4. The CON field may specify 4W only when RTD Cal, Resistance, or Capacitance mode is specified.
  5. The CON field may specify DV only when AC Voltage mode is specified, the MOD2 field specifies SI, the MOD3 field does not specify E and the NOMINAL or MOD1 field specifies a voltage of 22mV or less.
  6. The CON field may specify T1, T3, or T5 only when the MOD3 field does not specify E and DC Current or DC Power mode is specified or AC Current mode is specified and the MOD2 field specifies SI or AC Power mode is specified and either
    1. the M5520 NOMINAL field specifies voltage and the 5520 MOD2 field specifies SI or
    2. the M5520 NOMINAL field specifies current and the M5520 MOD2 field specifies SI.
  7. The CON field may specify L2W, LT1, LT3, LT5, LFT, or LFX only when the mode is AC Current or AC Power.
  8. The CON field may specify L only when the MOD3 field specifies SC or S6 and the MOD2 field does not specify SM.
  9. The CON field must specify L when the MOD2 field specifies LS, ED, or MK, and the MOD3 field specifies SC.
  10. The CON field must specify L when the MOD2 field specifies LS, ED, or M1, M2, M3, M4, F1, F2, F3, or F4, and the MOD3 field specifies S6.
  11. L is inserted automatically in the CON field when the MOD2 field specifies LS, ED, or MK, the MOD3 field specifies SC and no CON field code is entered.
  12. L is inserted automatically in the CON field when the MOD2 field specifies LS, ED, or M1, M2, M3, M4, F1, F2, F3, or F4, the MOD3 field specifies S6 and no CON field code is entered.
  13. The CON field must specify 2W when the MOD3 field specifies ZM, HM, or OM.

Use of Standard Memory Locations and Results Reporting

System memory locations MEM and MEM1 are used. For more information, refer to the Use of Standard Memory Registers topic.

Examples

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
# ----- Reset -----
  1.001  M5520        *
  1.002  5520         *                                                 S
# ----- DC Voltage -----
  1.003  5520   20    19.99mV        2% 0.04U                              2W
# ----- DC Voltage w/Range Lock -----
  2.001  M5520  RNGLK 3V
  2.002  5520   400   350.0mV        1.9% 0.4U                             2W
  3.001  M5520        *
# ----- DC Voltage, TC Terminals -----
  3.002  5520         35mV                                           TC S  2W
# ----- AC Voltage -----
  3.003  5520   400   350.0mV        -2.8U +2.9U   60H            SI       2W
# ----- AC Voltage w/External AC Divider -----
  4.001  5520         -37.78D        0.1U          100H           SI       DV
# ----- AC Voltage (Frequency Test) -----
  5.001  5520   1000  800.0H         0.1% 0.1U     300mV          SI       2W
# ----- Square Wave w/DC Offset -----
  6.001  M5520                                     0.5Voff
  6.002  5520         1Vpp                         1kH            SQ    S  2W
# ----- Square Wave w/Duty Cycle Specified -----
  6.003  M5520                       35pct
  6.004  5520         1Vpp                         1kH            SQ    S  2W
# ----- Square Wave (Duty Cycle Test) ------
  6.005  M5520        1Vpp
  6.006  5520         30pct          2U            500H           SQ       2W
  7.001  M5520        *
# ----- Triangle Wave -----
  7.002  5520         13mVpp                       10kH           TI    S  2W
# ----- Truncated Sine Wave -----
  7.003  5520         2.5mApp                      5kH            TS    S  2W
# ----- DC Current -----
  7.004  5520   1     1.00A          1%                                    2W
  8.001  5520   20    19.00A         0.07U                           HC    2W
# ----- Dual DC Voltage -----
  9.001  M5520        10mV
  9.002  5520         100mV          3%                              AX    2W
# ----- Dual AC Voltage -----
 10.001  M5520        1V                                          SI AX
 10.002  5520         141Vp                        10kH           SI    S  2W
# ----- Dual AC Voltage (Phase Test) ------
 10.003  M5520        1Vpp                         1Vpp           SQ AX
 10.004  5520         30deg          1U            60H            SQ       2W
# ----- Dual AC Voltage (Harmonics) ------
 11.001  M5520  H2    100V                                        SI
 11.002  5520         750mV          1U            60H            SI AX    2W
 12.001  M5520  HX3   1Vpp                                        SI AX
 12.002  5520         1Vpp           1U            60H            SI       2W
 13.001  M5520        *
# ----- DC Power (Volts and Amps) -----
 13.002  M5520        1mV                                               O  EL
 13.003  5520         1mA            1%                                    2W
# ----- AC Power (Volts and Amps) -----
 14.001  M5520        1mA            60deg                        SI
 14.002  5520         1V                           400H           SI    S  2W
# ----- AC Power (Watts and Volts) w/Displacement Power Factor -----
 14.003  M5520  LEAD  1V             0.998                        SI
 14.004  5520   20    19mW           1%            60H            SI       2W
# ----- AC Power (Watts and Vpp) w/Phase Specified -----
 15.001  M5520        1Vpp           -45deg                       SI
 15.002  5520   20    1mW            1U            400H           SI       2W
# ----- AC Power (Harmonics) ------
 16.001  M5520  H2    45V                                         SI
 16.002  5520         100W           1U            60H            SI       2W
 17.001  M5520  HX3   1mApp                                       SI
 17.002  5520         1Vpp           1U            60H            SI       2W
 18.001  M5520        *
# ----- Resistance -----
 18.002  5520   400   390.0Z         0.4% 0.1U                             CW
 19.001  5520   4     3.900MZ        0.05U                                 2W
# ----- Capacitance ----
 20.001  5520   10    1.100uF        2% 0.002U                             2W
# ----- Humidity Measurement -----
 21.001  5520         50.0pct                                     PB HM N  2W
# ----- Temperature Measurement -----
 21.002  5520         1200.0degF                                  _J TM N  2W
# ----- Temperature Stimulus -----
 21.003  M5520  TCREF 0degC
 21.004  5520         50degC         1%                           _K TC    2W
 22.001  M5520        *
 22.002  5520         45degC                                      R1    S  3W

SC300 Scope Option

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
# ----- DC Voltage -----
  1.001  5520   20    19.99mV        4%                              SC
# ----- AC Voltage (Scope Square Wave) -----
  2.001  5520   400   350.0mV        50U           60H            ZQ SC
# ----- AC Voltage (ScopeMeter Wave) -----
  3.001  5520         100Vpp                       1kH            SM SC S
# ----- AC Voltage (Frequency Test) -----
  3.002  5520   1000  800.0H         0.1% 0.1U     300mV          ZQ SC
# ----- Edge Signal (Scope Output) -----
  4.001  5520         0.5Vpp                       1MH            ED SC S  L
# ----- Leveled Sine Wave -----
  4.002  5520         200mVpp                      50kH           LS SC S  L
# ----- Marker Signal -----
  4.003  M5520                                                             2T
  4.004  5520         1uT                                         MK SC S  L
# ----- Wavegen -----
  4.005  5520         5V                           1kH            SI SC S
# ----- Wavegen w/DC Offset -----
  4.006  M5520                                     0.5Voff
  4.007  5520         1Vpp                         1kH            TI SC S
  4.008  M5520        *

SC600 and SC1100 Scope Options

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
# ----- DC Voltage -----
  1.001  5520   20    19.99mV        4%                              S6
# ----- AC Voltage (Positive Scope Square Wave) -----
  2.001  5520   400   350.0mV        50U           60H            ZQ S6
# ----- AC Voltage (Negative Scope Square Wave) -----
  3.001  5520         100Vpp                       1kH            ZN S6 S
# ----- AC Voltage (Frequency Test) -----
  3.002  5520   1000  800.0H         0.1% 0.1U     300mV          ZQ S6
# ----- Edge Signal (Scope Output) -----
  4.001  5520         0.5Vpp                       1MH            ED S6 S  L
# ----- Leveled Sine Wave -----
  4.002  5520         200mVpp                      50kH           LS S6 S  L
# ----- Spike Marker Signal -----
  4.003  M5520                                                             2T
  4.004  5520         1uT                                         M1 S6 S  L
  4.005  M5520        *
# ----- Square Marker Signal -----
  4.006  5520         1mT                                         M2 S6 S  L
# ----- 20% Duty Cycle Square Marker Signal -----
  4.007  5520         5uT                                         M3 S6 S  L
# ----- Sinusoid Marker Signal -----
  4.008  5520         2nT                                         M4 S6 S  L
# ----- Wavegen -----
  4.009  5520         5V                           1kH            SI S6 S
# ----- Wavegen w/DC Offset -----
  4.010  M5520                                     0.5Voff
  4.011  5520         1Vpp                         1kH            TI S6 S
# ----- NTSC Video -----
  4.012  M5520  ODD
  4.013  5520         1Vp                          262LM          F1 S6 S  L
  4.014  M5520        *
# ----- PAL Video -----
  4.015  5520         50pct                        400LM          F2 S6 S  L
# ----- PAL-M Video -----
  4.016  M5520  EVEN
  4.017  5520         -140IRE                      1LM            F3 S6 S  L
  4.018  M5520        *
# ----- SECAM Video -----
  4.019  5520         -100pct                      622LM          F4 S6 S  L
# ----- Pulse Wave (Slew Pulse Width) -----
  4.020  M5520  PER   200nT
  4.021  5520         5.0nT                        2.5Vpp         PU S6 N  L
# ----- Pulse Wave (Slew Pulse Repetition Frequency) -----
  4.022  M5520  PULSE 10nT
  4.023  5520         1.00kH                       2.5Vpp         PU S6 N  L
  4.024  M5520        *
# ----- Impedance Measurement (50 Ohm) -----
  4.025  5520         50Z            1U                              ZM    2W
# ----- Impedance Measurement (1 MOhm) -----
  5.001  5520         1.000MZ        1U                              ZM    2W
# ----- Impedance Measurement (Capacitance) -----
  6.001  5520         10pF                                           ZM N  2W
# ----- 50 Ohm Input Impedance Overload -----
  6.002  M5520  LIMIT 10T
  6.003  5520         5V                                             OM N  2W
  6.004  EVAL   -e MEM == 0 : 50 Ohm overload protection trip not expected
  7.001  M5520  LIMIT 10T
  7.002  5520         7V                                             OM N  2W
  7.003  EVAL   -e MEM : 50 Ohm overload protection trip expected


M5520

Instrument Setup FSC

Description

The M5520 FSC provides the additional program functions for the Fluke 5520A Calibrators which are not addressed by the 5520 FSC. These functions include Range Locking, DC Offset, Thermocouple External Temperature Reference, Phase, Power Factor, Duty Cycle, voltage and/or current for power stimulus, and voltage of the second signal for dual voltage output.

The following functions are available with SC600 Scope Option:

  • Time limit for UUT 50 Ohm input overload protection measurement.
  • Odd frame for NTSC or PAL-M video signals.
  • Trigger output

Parameters

For a description of the 5520 Calibrator operating modes referenced in this section, see Table 1 in the 5520 Instrument FSC description.

When a blank M5520 statement is entered, a "*" is inserted automatically in the NOMINAL field. See NOMINAL field parameter for a description of "*".

Units Symbols

Units Symbol | Name | Quantity
A | Amps | current
Ap | Amps peak | current
App | Amps peak to peak | current
D | dBm | decibels
H | Hertz | frequency
T | Time | period, pulse width, or time limit
V | Volts | voltage
Voff | Volts offset | DC offset
Vp | Volts peak | voltage
Vpp | Volts peak to peak | voltage
Z | Ohms | resistance
deg | degrees | phase
degC | degrees Celsius | temperature
degF | degrees Fahrenheit | temperature
pct | percent | duty cycle

M5520 FSC RANGE, NOMINAL, MOD1, MOD2, and MOD3 Rules

5520 Mode | M5520 RANGE | M5520 NOMINAL | M5520 TOL. | M5520 MOD1 | M5520 MOD2 1 | M5520 MOD3 2
DC Voltage | [RNGLK | V]
AC Voltage | [V|Vp|Vpp]
[V|Vpp] | Voff
[pct] | [Voff]
[IMPED | Ohms]
DC Current | [RNGLK | A]
TC Cal | [TCREF | degC|degF]
TC Meas | [TCREF | degC|degF]
Dual DC Voltage | V | [AX]
Dual AC Voltage | [Hn] | V|Vp|Vpp|D | [deg] | SI | [AX]
[HXn] | V|Vp|Vpp|D | [deg] | SI | [AX]
[Hn] | V|Vp|Vpp|D | [V|Vp|Vpp|D] | SI | [AX]
[HXn] | [V|Vp|Vpp|D | [V|Vp|Vpp|D] | SI | [AX]
V|Vp|Vpp | [deg] | SQ|TI|TS | [AX]
V|Vp|Vpp | [V|Vp|Vpp] | SQ|TI|TS | [AX]
DC Power | V
A | [HC]
AC Power [LEAD|LAG] V|Vp|Vpp|D [dpf] SI

[LEAD|LAG] | A|Ap|App | [dpf] | SI | [HC]
[Hn] | V|Vp|Vpp|D | [deg] | SI
[HXn] | V|Vp|Vpp|D | [deg] | SI
[Hn] | A|Ap|App | [deg] | SI | [HC]
[HXn] | A|Ap|App | [deg] | SI | [HC]
[Hn] | V|Vp|App|D | [A|Ap|App] | SI
[HXn] | V|Vp|Vpp|D | [A|Ap|App] | SI
[Hn] | A|Ap|App | [V|Vp|Vpp|D] | SI | [HC]
[HXn] | A|Ap|App | [V|Vp|Vpp|D] | SI | [HC]
V|Vp|Vpp | [deg] | SQ|TI|TS
V|Vp|Vpp | A|Ap|App | SQ|TI|TS
  1. See MOD2 parameter for description of these specification codes and rules.
  2. See MOD3 parameter for description of these specification codes and rules.
Blank entries in the above table are significant and must be blank. FSC field inter-dependencies not expressed in this table are listed under "Rules" for the appropriate parameter.

M5520 Nominal, MOD1, MOD2, and MOD3 Rules for SC300

M5520 RANGE, NOMINAL, TOLERANCE, MOD1, MOD2, and MOD3 fields are not used for SC300. M5520 NOMINAL, MOD1, MOD2, and MOD3 Rules for SC600

5500A Mode | M5520 RANGE | M5520 NOMINAL | M5520 TOLERANCE | M5520 MOD1 | M5520 MOD2 | M5520 MOD3
AC Voltage (WAVEGEN) |  |  |  | [OFFSET] |  |
AC Voltage (PULSE) | PER|PULSE | H|T |  |  |  |
Video (VIDEO) | [ODD|EVEN] |  |  |  |  |
Overload Meas (OVERLD) | LIMIT | T |  |  |  |
Blank entries in the above table are significant and must be blank. FSC field interdependencies not expressed in this table are listed under "Rules" for the appropriate parameter. M5520 RANGE, NOMINAL, TOLERANCE, MOD1, MOD2, and MOD3 fields are not used for SC600 operating modes not listed.

RANGE

This field specifies one of the following:

RNGLK | Range Lock
IMPED | Output Impedance
TCREF | Thermocouple Reference
LEAD | Leading
LAG | Lagging
Hn> | Primary output is a harmonic, 1 to 51
HXn> | Secondary output is a harmonic, 1 to 51
PULSE | Pulse Width
PER | Pulse Period
LIMIT | Time Limit (Overload Measurement)
ODD | Odd Frame (NTSC or PAL-M video)
EVEN | Even Frame (NTSC or PAL-M video)
blank | field not applicable

Rules:

  1. The RANGE field may not specify RNGLK when the 5520 MOD3 field specifies TC, SC, or S6.
  2. The RANGE field may specify IMPED only for AC Voltage mode when the amplitude is expressed in decibels.
  3. When the RANGE field specifies LEAD or LAG, the TOLERANCE field must specify the Displacement Power Factor.
  4. The primary output is always the Normal output. The secondary output is the Aux or 20A output.
  5. The RANGE field may specify PULSE or PER only when the 5520 MOD2 field specifies PU.
  6. The RANGE field must specify PULSE or PER when the 5520 MOD2 field specifies PU.
  7. The RANGE field may specify ODD or EVEN only when the 5520 MOD2 field specifies F1 or F3.
  8. The RANGE field must specify ODD or EVEN when the 5520 MOD2 field specifies F1 or F3.

NOMINAL

This field specifies one of the following entered as:

[numeric][prefix]units symbol

  • Range lock selection value in Volts or Amps
  • Output Impedance in Ohms
  • Thermocouple Reference
  • Pulse Period or Pulse Repetition Frequency
  • Pulse Width
  • Signal amplitude for AC Voltage, Dual DC Voltage, Dual AC Voltage, DC Power, or AC Power
"*" | reset to default values
blank | field not applicable

Rules:

  1. The NOMINAL field may specify a Voltage or Current range selection value only when the RANGE field specifies RNGLK.

    Voltage Range Selection Value | Locked Range
    > 0 mV to 330 mV | 330 mV DC
    > 330 mV to 3.3 V | 3.3 V DC
    > 3.3 V to 33 V | 33 V DC
    > 33 V to 330 V | 330 V DC
    > 330 V to 1020 V | 1000 V DC
    Current Range Selection Value | Locked Range
    0 mA to 3.3 mA | 3.3 mA DC
    > 3.3 mA to 33 mA | 33 mA DC
    > 33 mA to 330 mA | 330 mA DC
    > 330 mA to 3 A | 3A DC
    > 3 A to 20 A | 20A DC

    The NOMINAL field must specify the pulse period or pulse repetition frequency when the M5520 RANGE field is PER.

  2. The NOMINAL field must specify the pulse width when the M5520 RANGE field is PULSE.
  3. When the NOMINAL field specifies voltage and Dual DC Voltage or Dual AC Voltage mode is specified, either the MOD3 field must specify AX or the 5520 MOD3 field must specify AX.
  4. The NOMINAL field may specify Thermocouple Reference only when the RANGE field specifies TCREF. In this case, the UUT is compensating for its thermocouple junction temperature and Thermocouple Reference should be set to the temperature of the UUT's junction. Thermocouple Reference must be in the same units as the temperature specified in the 5520 NOMINAL field.
  5. When the NOMINAL field does not specify Thermocouple Reference, the 5520 internal reference is used and the UUT is not compensating for its thermocouple junction temperature.
  6. When the NOMINAL field contains only units, the value is taken from MEM.
  7. When the NOMINAL field contains only units and the MOD1 field is not blank, the MOD1 field must specify a value.
  8. When the NOMINAL field specifies reset "*", all other fields must be blank.

TOLERANCE

This field specifies phase or duty cycle entered as

numeric[prefix]units symbol or displacement power factor entered as numeric.

Rules:

  1. The TOLERANCE field may specify Displacement Power Factor only when the RANGE field specifies LEAD or LAG.
  2. The TOLERANCE field may specify Duty Cycle only when AC Voltage mode is specified, 5520 FSC MOD2 field specifies SQ, and the 5520 FSC MOD3 field is blank.

MOD1

This field specifies DC offset for AC Voltage or one amplitude for AC Power or Dual AC Voltage entered as:

[numeric][prefix]units symbol

Rules:

  1. The MOD1 field may specify voltage or current only when the 5520 NOMINAL field specifies phase.
  2. When the MOD1 field specifies voltage with units of "D", the 5520 MOD2 field must specify SI.
  3. When the MOD1 field specifies voltage with units of "Vp" or "Vpp" or current with units of "Ap" or "App", the 5520 MOD2 field must specify SI, SQ, TI, or TS.
  4. When the MOD1 field contains only units, the value is obtained from memory register MEM. In this case the NOMINAL field MUST contain a value.
  5. The MOD1 field may specify DC offset only when AC Voltage mode is specified and the 5520 NOMINAL field units are not decibels.
  6. When the MOD1 field specifies DC Offset, either the voltage specified in the 5520 NOMINAL or MOD1 field must be less than 33V or the DC Offset value must be zero.
  7. When the MOD1 field specified DC Offset and the 5520 NOMINAL field specifies duty cycle, the specified DC Offset must be zero.
  8. When the MOD1 field specifies DC Offset other than 0V, and the TOLERANCE field specifies duty cycle, the duty must be 50%.
  9. When the MOD1 field specifies DC Offset and the 5520 NOMINAL field specifies duty cycle, the specified DC Offset must be zero.

MOD2

This field specifies the waveform for the output specified in the NOMINAL field.

SI | Sine wave
SQ | Square wave
TI | Triangle wave
TS | Truncated sine wave
blank | DC or field not applicable

MOD3

This field specifies the calibrator output mode:

AX | Auxiliary Voltage
HC | 20A Output
blank | default port, or field not applicable

Rules:

  1. The MOD3 field must specify AX when Dual DC Voltage or Dual AC Voltage mode is specified and the 5520 MOD3 field does not specify AX.

MOD4

This field specifies the following:

  1. External guard
  2. Whether or not the NORMAL and AUX "LO" terminals are tied together for DC Power, AC Power, Dual DC Voltage, and Dual AC Voltage modes.
MOD4 | Lows | External Guard
blank | Shorted | Off
O | Open | Off
G | Shorted | On
X | Open | On

Rules:

  1. The MOD4 field may specify "O" or "X" only when the CON specifies "EL" or "FL".

CON

This field controls whether or not the NORMAL and AUX "LO" terminals are tied to Earth and the trigger output.

blank | default or field not applicable
EL | Low tied to Earth
FL | Floating Low
1T | Trigger Output on, Normal mode
2T | Trigger Output on, 1/10 of output rate
3T | Trigger Output on, 1/100 of output rate

Rules:

  1. The CON field specification is ignored, and a floating low is used when Resistance, Capacitance, RTD Calibration, or Thermocouple Measurement mode is specified.
  2. A CON field specification of 1T, 2T, or 3T is only applicable (is ignored otherwise) when the 5520 MOD2 field specifies ZQ, ZN, ED, MK, M1, M2, M3, and M4.
  3. When the CON is field is blank, a floating low is used.

Examples

See 5520 FSC.


5522A

Instrument FSC

Description

The 5522A FSC controls the Fluke 5522A Calibrator.

Use the O_CAL FSC to control the 5522A-SC600 and 5522A-SC1100 Oscilloscope Calibration Option.

Use the P700 FSC to control a Fluke 700 Series Pressure Module connected to the 5522A rear panel connector labeled: "SERIAL 2 TO UUT", using the 700PCK.

The 5522A FSC may also be used to control a 5520A. This capability allows a 5522A based procedure to be executed without modification when a 5520A is configured.

If the 5522A is to be controlled via its serial port, do not use the PORT FSC port configuration special construction, [P9600,N,...], to set the baud rate, parity, etc. of the port used to control the 5522A. MET/CAL executes a "Test" function for each System Instrument prior to executing any procedure statements, therefore the settings of the port used to controlling the 5522A must be set correctly before a procedure is executed. If the 5522A is connected to a standard serial port (COM1, COM2, ..., COM16), select the "Ports" application in the Windows control panel to choose the proper settings.

Parameters

An NVI FSC statement consists of one or more parameters. A parameter consists of a name and a value. Each parameter must be separated by a semicolon and/or one or more spaces. A single NVI FSC statement can encompass more than one physical line as long as the line numbers are the same. However each parameter name and its value must occur on one line. A single line can accommodate up to 256 characters including the statement number and FSC. Note that characters above ASCII 128 count as 2 characters.

Syntax:

parameter[separatorparameter]

parameter::= [parameter_prefix]parameter_name[[sp]=[sp]parameter_value]

separator::= ;[sp] | sp

parameter_prefix ::=+ | @

sp::= one or more spaces

parameter_name::= see the Parameter Names section

parameter_value::=dimensionless number | dimensioned number | discrete_list

dimensionless number::=NRf

dimensioned number::=NRf[sp][prefix]units

discrete_list::=see the Parameter Names section

prefix::=y | z | a | f | p | n | u | m | k | M | G | T | P | E | Z | Y

Definitions:

|
Denotes "or" (i.e. A | B is A or B)
[ ]
Denotes an optional syntax element, except in examples. In examples [ ] enclose a special construction.
+
Designates the parameter as the Evaluation Quantity
@
Designates the parameter as the Modifier Quantity

Examples:

The following three 5522A statements are identical with respect to the 5522A:

Statement #1

1.001 5522A +Voltage = 240V; @Frequency = 50Hz

Statement #2

1.001 5522A Mode = AC_Voltage +Volt = 240.0 V @Freq = 50 Hz

Statement #3

  1.001 5522A Apply
  1.001 5522A Mode = ACV
  1.001 5522A +Voltage = 240 V
  1.001 5522A @Freq = 50 Hz

Rules:

  1. One and only one parameter must be designated as the Evaluation Quantity in a 5522A Apply, Setup, or Slew statement.
  2. At most one parameter may be designated as the Modifier Quantity in a 5522A Apply, Setup, or Slew statement.
  3. Parameter values may be taken from a MET/CAL memory register using a special construction.
  4. When a 5522A Apply statement is executed, the value of the Evaluation Quantity is copied to memory register MEM1 in specified units.

    5. Example:

    1.001 5522A Mode = ACV; +Volt = 240 V; @Freq = 50Hz; Apply

    After the 5522A statement is executed the value of MEM1 is 240.

  5. When a 5522A Operate statement is executed, the value of the Evaluation Quantity designated in the previous Setup or Apply statement is copied to memory register MEM1 in specified units.

    6. Example:

      1.001 5522A Mode = Volt; +Volt = 240V; @Freq = 50Hz; Setup
  1.002 5522A Mode = Volt; +Volt = 240V; @Freq = 50Hz; Operate

    After the 5522A Operate statement is executed the value of MEM1 is 240.

  6. When a 5522A Slew statement is executed, the Evaluation Quantity designates the slew quantity.
  7. When a 5522A Slew statement is executed, the final slew value is copied to memory register MEM1 in units of the Evaluation Quantity.

    8. Example:

    1.001 5522A +Volt = 240V; @Freq = 50Hz; Slew

    Operator slews the 5522A output to 241.5 V.

    After the 5522A Slew statement is executed the value of MEM is 241.5.

  8. When a 5522A Slew statement is executed, the Modifier Quantity is concatenated to the Evaluation Quantity in the automatic slew message. Note, the automatic slew message is not displayed when ASK- N is in effect.

    9. Examples:

      1.001 ASK+ N
  1.002 5522A +Volt = 120V; @Freq = 60Hz; Slew

    "Adjust stimulus for a UUT reading of 120 V at 60 Hz."

    No Modifier Quantity designated.

    1.001 5522A Mode = Volt; +Volt = 120V; Freq = 60Hz; Slew

    "Adjust stimulus for a UUT reading of 120 V."

    Automatic slew message inhibited.

      1.001 ASK- N
  1.002 5522A +Volt = 120V; Freq = 60Hz; Slew

    No automatic slew message generated, use MESS FSC.

Parameter Names

Parameter names consist of single words or compound words. Each word in a parameter name can be entered in long form (as shown below), or in short form. The short form is the first 4 characters of the long form, with the following exceptions:

  1. If the long form is greater than four characters, and the last character or the short form is a vowel, the short form is three characters.
  2. If the long form is four characters or less, the short form is the long form even if it ends in a vowel.

Compound parameter names can be entered in any combination of long and short forms. Example, ExternalReference can be entered using any of the following forms:

  • InductanceCompensation
  • InductanceComp
  • IndCompensation
  • IndComp

Action Parameters

  • Apply
  • Local
  • Measure
  • Monitor
  • Operate
  • Read
  • Reset
  • Setup
  • Standby

General Parameters

  • Amplitude
  • AuxiliaryVoltage
  • AuxiliaryWaveform
  • Capacitance
  • Coil
  • Current
  • CurrentTerminal
  • DutyCycle
  • Earth
  • ExternalGuard
  • Frequency
  • Fundamental
  • Harmonic
  • Humidity
  • Impedance
  • InductanceCompensation
  • Lag
  • Lead
  • LeadCompensation
  • Lows
  • Mode
  • NominalResistance
  • NonToroidalUUT
  • NormalVoltage
  • NormalWaveform
  • Offset
  • OTCD
  • Period
  • Phase
  • Power
  • PF
  • RTD_Type
  • Range
  • ReferenceClock
  • ReferencePhase
  • Resistance
  • TC_Reference
  • TC_Type
  • Temperature
  • TemperatureScale (alternately TemperatureStandard)
  • ToroidalUUT
  • Turns
  • Voltage
  • Waveform

Instrument Mode

If the 5522A operating mode is not specified, MET/CAL determines the mode based on occurrence of the following parameters in the 5522A statement:

  • Current
  • Frequency
  • NormalVoltage
  • Period
  • Resistance
  • Voltage

Rules:

  1. If Resistance or Conductance is specified, the mode is Resistance.
  2. If Capacitance is specified, the mode is Capacitance.
  3. If Humidity is specified, the mode is Humidity Measurement.
  4. If Temperature and RTD_Type are specified, mode is RTD Source.
  5. If Temperature and TC_Type are specified, mode is TC Source.
  6. If NormalVoltage and Frequency or Period arespecified, the mode is Dual AC Voltage.
  7. If NormalVoltage is specified without Frequency or Period, the mode is Dual DC Voltage.
  8. If Voltage, Current, and Frequency or Period are specified, the mode is AC Power.
  9. If Voltage are Current are specified without Frequency or Period, the mode is DC Power.
  10. If Current and Frequency or Period are specified, but not Voltage, the mode is AC Current.
  11. If Current is specified, but not Voltage, Frequency, and Period, the mode is DC Current.
  12. If Current and Frequency or Period are specified, but not Voltage, the mode is AC Current.
  13. If Current is specified, but not Voltage, Frequency, and Period, the mode is DC Current.
  14. If Voltage and Frequency or Period are specified, but not Current, the mode is AC Voltage.
  15. If Voltage is specified, but not Current, Frequency, and Period, the mode is DC Voltage.

Mode/Parameter Rules

DC VOLTAGE

Mode = DC_Voltage | DC_Volt | DCV

Required Parameter(s):

  • Voltage
Optional Parameters | Default
Mode | DC_Voltage
Range | autorange
Earth | Off
ExternalGuard | Off
Apply | Setup | Operate | Slew | Apply

DC CURRENT

Mode = DC_Current | DC_Curr | DCA

Required Parameter(s):

  • Current
  • CurrentTerminal
Optional Parameters | Default
Mode | DC_Current
Range | 1
Coil | na
Turns | na
Earth | Off
ExternalGuard | Off
Apply | Setup | Operate | Slew | Apply
  1. Autorange, Current = -2.99999 A to 2.99999 A, otherwise 20 A range locked.

RESISTANCE

Mode = Resistance | Res

Required Parameter(s):

  • Resistance | Conductance
Optional Parameters | Default
Mode | Resistance
LeadCompensation | Off
ExternalGuard | Off
Apply | Setup | Operate | Apply

AC VOLTAGE

Mode = AC_Voltage | AC_Volt | ACV

Required Parameter(s):

  • Voltage | Amplitude
  • Frequency | Period
Optional Parameters | Default
Mode | AC_Voltage
Waveform | Sine
Range | autorange
Offset | 0 V
DutyCycle | 50 % 1
Impedance | NA 2,3
Earth | Off
ExternalGuard | Off
ReferenceClock | Internal
ReferencePhase | na
Apply | Setup | Operate | Slew | Apply
  1. Only allowed when Waveform = Square
  2. Only allowed when Waveform = Sine
  3. Required when Amplitude is specified.

AC CURRENT

Mode = AC_Current | AC_Curr | ACA

Required Parameter(s):

  • Current
  • CurrentTerminal
  • Frequency | Period
Optional Parameters | Default
Mode | AC_Voltage
Waveform | Sine
Range | autorange
Coil | na
Turns | na
ToroidalUUT | NonToroidalUUT | na 1
InductanceCompensation | Off
Earth | Off
ExternalGuard | Off
ReferenceClock | Internal
ReferencePhase | na
Apply | Setup | Operate | Slew | Apply
  1. Only allowed, and required when Coil is specified

CAPACITANCE

Mode = Capacitance | Cap

Required Parameter(s):

  • Capacitance
Optional Parameters | Default
Mode | Capacitance
LeadCompensation | Off
Apply | Setup | Operate | Apply

TC SOURCE

Mode = TC_Source | TC_Sour

Required Parameter(s):

  • Temperature
  • TC_Type
Optional Parameters | Default
Mode | TC_Source
OTCD (Open TC Detection) | On
TemperatureScale | ITS-90
TC_Reference | Internal
Earth | Off
Apply | Setup | Operate | Apply

TC MEASUREMENT

Mode = TC_Measurement | TC_Meas

Required Parameter(s):

  • Mode
  • Temperature
  • TC_Type
Optional Parameters | Default
OTCD (Open TC Detection) | On
TemperatureScale | ITS-90
TC_Reference | Internal
Measure | Monitor | Setup | Read | Measure

HUMIDITY MEASUREMENT

Mode = HumidityMeasurement | HumidityMeas | HumMeasurement | HumMeas

Required Parameter(s):

  • Mode
  • Humidity
Optional Parameters | Default
Measure | Setup | Read | Measure

RTD SOURCE

Mode = RTD_Source | RTD_Sour

Required Parameter(s):

  • Temperature
  • RTD_Type
  • NominalResistance
Optional Parameters | Default
Mode | RTD_Source
LeadCompensation | Off
Apply | Setup | Operate | Apply

DUAL DC VOLTAGE

Mode = DualDC_Voltage | DualDC_Volt | DualDCV

Required Parameter(s):

  • NormalVoltage
  • AuxiliaryVoltage

Optional Parameters | Default
Mode | DualDC_Voltage
Earth | Off
ExternalGuard | Off
Lows | Tied
Apply | Setup | Operate | Slew | Apply

DUAL AC VOLTAGE

Mode = DualAC_Voltage | DualAC_Volt | DualACV

Required Parameter(s):

  • NormalVoltage
  • AuxiliaryVoltage
  • Frequency | Period
Optional Parameters | Default
Mode | DualAC_Voltage
NormalWaveform | Sine
AuxiliaryWaveform | Sine
Fundamental | Normal
Harmonic | 1
Phase | PF | 0 deg
Lead | Lag | Lead 1
Earth | Off
ExternalGuard | Off
Lows | Tied
ReferenceClock | Internal
ReferencePhase | na
Apply | Setup | Operate | Slew | Apply
  1. Only allowed when PF is specified.

DC POWER

Mode = DC_Power | DC_Pow

Required Parameter(s):

  • Voltage
  • Current
  • CurrentTerminal
Optional Parameters | Default
Mode | DC_Power
Power | na
Coil | na
Turns | na
Earth | Off
ExternalGuard | Off
Lows | Tied
Apply | Setup | Operate | Slew 1 | Apply
  1. Slew not allowed when Power is specified.

AC POWER

Mode = AC_Power | AC_Pow

Required Parameter(s):

  • Voltage
  • Current
  • CurrentTerminal
  • Frequency | Period
Optional Parameters | Default
Mode | AC_Power
NormalWaveform | Sine
AuxiliaryWaveform | Sine
Fundamental | Normal
Harmonic | 1
Power | na
Phase | PF | 0 deg
Lead | Lag | Lead 1
Coil | na
Turns | na
ToroidalUUT | NonToroidalUUT | na 2
InductanceCompensation | Off
Earth | Off
ExternalGuard | Off
Lows | Tied
ReferenceClock | Internal
ReferencePhase | na
Apply | Setup | Operate | Slew 3 | Apply
  1. Only allowed when PF is specified.
  2. Only allowed, and required when Coil is specified
  3. Slew not allowed when Power is specified.

Parameter Definitions and Values

Amplitude

This parameter specifies the amplitude in dBm for AC Voltage mode.

Syntax:

[+|@]Amplitude[sp]=[sp]numeric value[sp][prefix]dBm

Examples:

Amplitude = +10.0 dBm

Apply

This action sets up the instrument and enables the output.

Syntax:

Apply

Rules:

  1. When Apply is specified, no other action may be specified.

Examples:

Apply

AuxiliaryVoltage

This parameter specifies the AUX output voltage for the following modes:

  • Dual DC Voltage
  • Dual AC Voltage

Syntax:

[+|@]AuxiliaryVoltage[sp]=[sp]numeric value[sp][prefix]V

Examples:

+AuxVoltage = 1 V

AuxiliaryWaveform

This parameter specifies the AUX waveform for the following modes:

  • DC Power
  • AC Power
  • Dual DC Voltage
  • Dual AC Voltage

Syntax:

AuxiliaryWaveform[sp]=[sp]waveform

waveform ::= Sine | Square | Triangle | TruncatedSine

Examples:

AuxWaveform = Tri

Capacitance

This parameter specifies the capacitance.

Syntax:

[+|@]Capacitance[sp]=[sp]numeric value[sp][prefix]F

Examples:

Capacitance = 100 nF

Conductance

This parameter specifies the expected conductance

Syntax:

[+|@]Conductance[sp]=[sp]numeric value[sp][prefix]S

Examples:

Capacitance = 0.01 nS

Coil

This parameter specifies a current coil.

Syntax:

Coil[sp]=[sp]value

value ::= 5500A/COIL | 9100_Option200 | 9100_Opt200 | UserDefined | UserDef

Examples:

Coil = 5500A/COIL

Current

This parameter specifies the output current.

Syntax:

[+|@]Current[sp]=[sp]numeric value[sp][prefix]units

units ::= A | Ap | App

Examples:

Current = 2.5 A

CurrentTerminal

This parameter specifies a current output terminals.

Syntax:

CurrentTerminal[sp]=[sp]value

value ::= Auxiliary | Aux | 20A

Examples:

CurrentTerminal = 20A

DutyCycle

This parameter specifies the duty cycle for AC Voltage square waves.

Syntax:

[+|@]DutyCycle[sp]=[sp]numeric value[sp][prefix]%

Examples:

DutyCycle = 30 %

Earth

This parameter specifies the earth connection.

Syntax:

Earth[sp]=[sp]value

value ::= On | Off

Examples:

Earth = On

ExternalGuard

This parameter specifies the external guard connection.

Syntax:

ExternalGuard[sp]=[sp]value

value ::= On | Off

Examples:

ExtGuard = On

Frequency

This parameter specifies the output frequency.

Syntax:

[+|@]Frequency[sp]=[sp]numeric value[sp][prefix]Hz

Rules:

  1. When Frequency is specified, Period cannot be specified.

Examples:

@Freq = 50 Hz

Fundamental

This parameter specifies which represents the fundemental when a harmonic is specified.

Syntax:

Fundamental[sp]=[sp]output

output = Normal | Auxiliary

Examples:

Fund = Norm

Harmonic

This parameter specifies the harmonic.

Syntax:

Harmonic[sp]=[sp]integer

Examples:

Harm = 3

Humidity

This parameter specifies the expected humidity measurement.

Syntax:

+Humidity[sp]=[sp]numeric value[sp][prefix]%

Examples:

Humidity = 75 %

Impedance

This parameter specifies the reference impedance for Amplitude in dBm.

Syntax:

Impedance[sp]=[sp]numeric value[sp][prefix]Ohm[s]

Examples:

Impedance = 50 Ohms

InductanceCompensation

This parameter specifies the inductance compensation (LCOMP).

Syntax:

InductanceCompensation[sp]=[sp]value

value ::= On | Off

Examples:

IndComp = On

Lead / Lag

These parameters select the relationship between the NORMAL and AUX output waveforms when power factor is specified.

Syntax:

Lead | Lag

Rules:

  1. When Lead are mutually exclusive.i

Examples:

Lead

LeadCompensation

This parameter selects the lead compensation.

Syntax:

LeadCompensation[sp]=[sp]value

value ::= 2W | 4W | 2Wire | 4Wire | Off

Rules:

  1. 4W and 4Wire are not allowed in Capacitance mode.

Examples:

+Resistance = 0.0 Ohms; LeadCompensation = 4W

+Capacitance = 10.0 mF; LeadCompensation = 2W

Local

This action puts the 5522A in local mode.

Syntax:

Local

Rules:

  1. When Local is specified, no other parameters may be specified.

Examples:

Local

Lows

This parameter connects or disconnects the NORMAL LO and AUX LO terminals together.

Syntax:

Low[sp]=[sp]value

value ::= Open | Tied

Rules:

  1. When Lows is allowed, but not specified, the default is Tied.

Examples:

Lows = Open

Mode

This parameter selects the instrument mode.

Syntax:

Mode[sp]=[sp]value

value ::= DC_Voltage | DC_Volt | DCV |

DC_Current | DC_Curr | DCA |

Resistance | Res |

AC_Voltage | AC_Volt | ACV |

AC_Current | AC_Curr | ACA |

Capacitance | Cap |

HumidityMeasurement | HumidityMeas | HumMeasurement | HumMeas

TC_Measurement | TC_Meas |

TC_Source | TC_Sour |

RTD_Source | RTD_Sour |

DualDC_Voltage | DualDC_Volt | DualDCV |

DualAC_Voltage | DualAC_Volt | DualACV |

DC_Power | DC_Pow |

AC_Power | AC_Pow

Rules:

  1. If mode is not specified, the mode is determined as described in the section INSTRUMENT MODE at the top of this file.

Examples:

Mode = Cap

Monitor

This action sets up the instrument and continually displays the reading until the operator selects Advance or Terminate in the UUT Setup prompt.

Syntax:

Monitor

Rules:

  1. When Monitor is specified, no other action may be specified.
  2. After a Monitor statement MEM1 contains the reading in units of the Evaluation Quantity.

Examples:

Monitor

NonToroidalUUT

See ToroidalUUT / NonToroidalUUT.

NominalResistance

This parameter specifies the nominal resistance for RTD Source mode.

Syntax:

[@]NominalResistance[sp]=[sp]numeric value[sp][prefix]Ohm[s]

Examples:

NominalResistance = 100 Ohms

NormalVoltage

This parameter specifies the NORMAL output voltage for the following modes:

  • Dual DC Voltage
  • Dual AC Voltage

Syntax:

[+|@]NormalVoltage[sp]=[sp]numeric value[sp][prefix]units

units ::= V | Vp | Vpp

Examples:

+NormalVoltage = 240 V

NormalWaveform

This parameter specifies the NORMAL waveform for the following modes:

  • AC Power
  • Dual AC Voltage

Syntax:

NormalWaveform[sp]=[sp]waveform

waveform ::= Sine | Square | Triangle | TruncatedSine

Examples:

NormWave = Tri

Offset

This parameter specifies the DC offset.

Syntax:

[+|@]Offset[sp]=[sp]numeric value[sp][prefix]V

Examples:

+Offset = 1 V

Operate

This parameter turns the output on.

Syntax:

Operate

Rules:

  1. When Operate is specified, no other parameters are allowed.

Examples:

Operate

OTCD

This parameter specifies the state of Open Thermocouple Detection.

Syntax:

OTCD[sp]=[sp]value

value ::= On | Off

Rules:

  1. When OTCD is not specified, the default is On.

Examples:

OTCD = Off

Period

This parameter specifies the output period.

Syntax:

[+|@]Period[sp]=[sp]numeric value[sp][prefix]s

Rules:

  1. When Period is specified, Frequency cannot be specified.

Examples:

@Per = 1 ms

Phase

This parameter specifies the phase between the NORMAL and AUX waveforms.

Syntax:

[+|@]Phase[sp]=[sp]numeric value[sp][prefix]deg

Examples:

Phase = 30 deg

Power

This parameter specifies the expected power.

Syntax:

+Power[sp]=[sp]numeric value[sp][prefix]units

units ::= W | VA | VAR

Rules:

  1. When this parameter is specified, it must be designated as the Evaluation Quantity.

Examples:

+Power = 10 kVA

PF

This parameter specifies the power factor.

Syntax:

[+|@]PF[sp]=[sp]numeric value

Rules:

  1. When PF is specified, Lead or Lag must be specified.

Examples:

PF = 0.34; Lag

RTD_Type

This parameter specifies the RTD type.

Syntax:

RTD_Type[sp]=[sp]type

type ::= Pt385 | Pt3926 | Pt3916 | Ni672 | Cu427

Examples:

RTD_Type = Pt385; NominalResistance = 500 Ohms

RTD_Type = Ni672; NominalResistance = 120 Ohms

RTD_Type = Cu427; NominalResistance = 10 Ohms

Range

This parameter specifies the range to range lock in DC Voltage and DC Current modes.

Syntax:

Range[sp]=[sp]numeric value[sp][prefix]units

units ::= A | V

Examples:

Range = 3.3 V

ReferenceClock

This parameter sets the state of the 10 MHz reference.

Current modes.

Syntax:

ReferenceClock[sp]=[sp]value

value ::= Internal | External

Examples:

RefClock = Ext

ReferencePhase

This parameter sets the reference phase.

Current modes.

Syntax:

ReferencePhase[sp]=[sp]numeric value[sp][prefix]deg

Examples:

RefPhase = Ext

Reset

This parameter resets the 5522A.

Syntax:

Reset

Rules:

  1. When Reset is specified, no other parameters are allowed.

Examples:

Reset

Resistance

This parameter specifies the resistance.

Syntax:

[+|@]Resistance[sp]=[sp]numeric value[sp][prefix]Ohm[s]

Examples:

Resistance = 100 Ohms

Setup

This action causes the instrument to be setup only.

Mode: HumidityMeasurement | TC_Measurement
No reading is returned.
Mode: All other modes
The instrument remains in standby.

Syntax:

Setup

Rules:

  1. When Setup is specified, no other action may be specified.

Examples:

Setup

Slew

This action sets up the intrument and enables the output. Slewing is then enabled for the parameter designated as the Evaluation Quantity (i.e. + prefix).

Syntax:

Slew

Rules:

  1. When Slew is specified, no other action may be specified.

Examples:

Slew

Standby

This action selects standby (output disabled).

Syntax:

Standby

Rules:

  1. When Standby is specified, no other parameters are allowed.

Examples:

Standby

TC_Reference

This parameter specifies the external reference temperature.

Syntax:

TC_Reference[sp]=[sp]numeric value[sp][prefix]units

units ::= degC | degF

Examples:

TC_Reference = 21.0 degC

TC_Type

This parameter specifies the TC type.

Syntax:

TC_Type[sp]=[sp]type

type ::= B | C | E | J | K | N | R | S | T | U | _1mVdegC | _10uVdegC

Examples:

TC_Type = K

Temperature

This parameter specifies the temperature.

Syntax:

[+]Temperature[sp]=[sp]numeric value[sp][prefix]units

units ::= degC | degF

Examples:

Temperature = -100.0 degC

TemperatureScale (alternately TemperatureStandard)

This parameter specifies the temperature scale.

Syntax:

TemperatureScale[sp]=[sp]standard

standard ::= ITS_90 | IPTS_68

Examples:

TempScale = IPTS_68

ToroidalUUT / NonToroidalUUT

These parameters specifie that the UUT design for calculation of the total reference accuracy when a coil is specified.

Syntax:

ToroidalUUT | NonToroidal

Rules:

  1. When ToroidalUUT and NonToroidalUUT are mutually exclusive.
  2. When neither ToroidalUUT or NonToroidalUUT is specified, the default is non-toroidal.

Examples:

ToroidalUUT

Turns

This parameter specifies the number of turns in the current coil.

Syntax:

Turns[sp]=[sp]integer

Rules:

Coil | Turns
5500A/COIL | [50]
9100_Option200 | 10 or 50
UserDefined | 1 to 100

Examples:

Coil = 5500A/COIL

Coil = 5500A/COIL; Turns = 50

Coil = 9100_Option200; Turns = 10

Coil = UserDefined; Turns = 30

Voltage

This parameter specifies the NORMAL output voltage for the following modes:

  • DC Voltage
  • AC Voltage
  • DC Power
  • AC Power

Syntax:

[+|@]Voltage[sp]=[sp]numeric value[sp][prefix]units

units ::= V | Vp | Vpp

Examples:

+Voltage = 240 V

Waveform

This parameter specifies the NORMAL waveform for AC Voltage mode or the AUX waveform for AC Current mode.

Syntax:

[sp]=[sp]waveform

waveform ::= Sine | Square | Triangle | TruncatedSine

Examples:

Waveform = Squ

Examples

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
# -----  Reset  -----
  1.001  5522A        Reset
# -----  Standby  -----
  1.002  5522A        Standby
# -----  DC Voltage  -----
  1.003  5522A        +Voltage = -190.0 mV
  1.004  TARGET       -m
  1.005  MEMI         Enter UUT reading in millivolts DC:
  1.006  MEMCX  200   -190.0mV       1.0% 0.1U
# -----  DC Current  -----
  2.001  5522A        +Current = 19.00 mA; CurrentTerminal = Aux
  2.002  TARGET       -m
  2.003  MEMI         Enter UUT reading in millamps DC:
  2.004  MEMCX  20    19.00mA        1.5% 0.01U
# -----  DC Current (using 5500A/COIL)  -----
  3.001  5522A        +Current = 41.0 A; Coil = 5500A/COIL; CurrTerm = Aux
  3.002  TARGET       -m
  3.003  MEMI         Enter UUT reading in amps DC:
  3.004  MEMCX  400   41.0A          1.5% 0.5U
# -----  DC Current (using 9100 Option 200 10-Turn Coil)  -----
  4.001  5522A        Coil = 9100_Opt200; Turns = 10;
  4.001  5522A        +Current = 11.00 A; CurrTerm = Aux
  4.002  TARGET       -m
  4.003  MEMI         Enter UUT reading in amps DC:
  4.004  MEMCX  40    11.00A         1.5% 0.05U
# -----  DC Current (using 9100 Option 200 50-Turn Coil)  -----
  5.001  5522A        Coil = 9100_Opt200; Turns = 50;
  5.001  5522A        +Current = 41.0 A; CurrTerm = Aux
  5.002  TARGET       -m
  5.003  MEMI         Enter UUT reading in amps DC:
  5.004  MEMCX  400   41.0A          1.5% 0.5U
# -----  Resistance  -----
  6.001  5522A        +Resistance = 1.900 kOhms; LeadComp = 2W
  6.002  TARGET       -m
  6.003  MEMI         Enter UUT reading in kilohms:
  6.004  MEMCX  2     kOhms          1% 0.004U
# -----  AC Voltage  -----
  7.001  5522A        +Voltage = 19.00 V; Frequency = 50 Hz
  7.002  TARGET       -m
  7.003  MEMI         Enter UUT reading in volts AC:
  7.004  MEMCX  20    19.00V         1.5% 0.05U    50Hz
# -----  AC Current  -----
  8.001  5522A        +Current = 1.900 mA; Frequency = 500 Hz; CurrTerm = Aux
  8.002  TARGET       -m
  8.003  MEMI         Enter UUT reading in millamps AC:
  8.004  MEMCX  2     1.900mA        2% 0.005U     500Hz
# -----  AC Current (using 5500A/COIL)  -----
  9.001  5522A        Coil = 5500A/COIL; NonToroidalUUT; IndComp = On
  9.001  5522A        +Current = 410 A; Frequency = 50 Hz; CurrTerm = 20A
  9.002  TARGET       -m
  9.003  MEMI         Enter UUT reading in amps AC:
  9.004  MEMCX  2000  410A           1.5% 5U       50Hz
# -----  AC Current (using 9100 Option 200 10-Turn Coil)  -----
 10.001  5522A        Coil = 9100_Opt200; Turns = 10; IndComp = On
 10.001  5522A        +Current = 11.00 A; Frequency = 50 Hz; CurrTerm = Aux
 10.002  TARGET       -m
 10.003  MEMI         Enter UUT reading in amps AC:
 10.004  MEMCX  40    11.00A         1.5% 0.05U    50Hz
# -----  AC Current (using 9100 Option 200 50-Turn Coil)  -----
 11.001  5522A        Coil = 9100_Opt200; Turns = 50; IndComp = On
 11.001  5522A        +Current = 410 A; Frequency = 60 Hz; CurrTerm = 20A
 11.002  TARGET       -m
 11.003  MEMI         Enter UUT reading in amps AC:
 11.004  MEMCX  2000  410A           1.5% 5U       60Hz
# -----  Dual AC Voltage  -----
 12.001  5522A        NormalVoltage = 5 V; Phase = 0 deg
 12.001  5522A        +AuxVoltage = 0.03 V; Frequency = 60 Hz
 12.002  MATH         L[1] = REFACC() / MEM1 * 100
 12.003  5522A        AuxVoltage = 0.03 V; Phase = 0 deg
 12.003  5522A        +NormalVoltage = 5 V; Frequency = 60 Hz
 12.004  MATH         L[2] = REFACC() / MEM1 * 100
 12.005  MATH         L[3] = RSS_L(1, 2)
 12.006  ACC          150W           L3%
 12.007  MEMI         Enter UUT reading in watts.
 12.008  MEMCX        150W           1% 4U
 13.001  5522A        NormalVoltage = 100 V; AuxVoltage = 150 mV
 13.001  5522A        +Phase = 157 deg; Frequency = 60 Hz
 13.002  MEMI         Enter UUT reading in degrees.
 13.003  MEMCX        157deg         2U
# -----  AC Power (using 5500A/COIL)  -----
 14.001  5522A        Coil = 5500A/COIL; NonToroidalUUT; IndComp = On
 14.001  5522A        Voltage = 380 V; Current = 100 A; Phase = 0 deg
 14.001  5522A        +Power = 38.00 kW; Frequency = 50 Hz; CurrTerm = Aux
 14.002  TARGET       -m
 14.003  MEMI         Enter UUT reading in kilowatts:
 14.004  MEMCX  40    38.00kW        2.5% 0.05U
 15.001  5522A        Coil = 5500A/COIL; NonToroidalUUT; IndComp = On
 15.001  5522A        Voltage = 19 V; Current = 100 A; Phase = 0 deg
 15.001  5522A        +Power = 1900 VA; Frequency = 50 Hz; CurrTerm = Aux
 15.002  TARGET       -m
 15.003  MEMI         Enter the UUT reading in volt-amps:
 15.004  MEMCX  4000  1900VA         80U
 16.001  5522A        Coil = 5500A/COIL; NonToroidalUUT; IndComp = On
 16.001  5522A        Voltage = 397.363 V; Current = 100 A; Phase = -73 deg
 16.001  5522A        +Power = +38.00 kVAR; Frequency = 50 Hz; CurrTerm = Aux
 16.002  TARGET       -m
 16.003  MEMI         Enter UUT reading in kilovolts-amps reactive:
 16.004  MEMCX  40    +38.00k'VAR'   2.5% 0.05U
 17.001  5522A        Coil = 5500A/COIL; NonToroidalUUT; IndComp = On
 17.001  5522A        Voltage = 460.105 V; Current = 100 A
 17.001  5522A        +PF = 0.292; Frequency = 50 Hz; Lead; CurrTerm = Aux
 17.002  TARGET       -m
 17.003  MEMI         Enter UUT power factor reading:
 17.004  MEMCX        0.292          0.050U
# -----  AC Power (using 9100 Option 200 50-Turn Coil)  -----
 18.001  5522A        Coil = 9100_Opt200; Turns = 50; IndComp = On
 18.001  5522A        Voltage = 44 V; Current = 100 A; Phase = 0 deg
 18.001  5522A        +Power = 4.40 kW; Frequency = 50 Hz; CurrTerm = Aux
 18.002  TARGET       -m
 18.003  MEMI         Enter UUT reading in kilowatts:
 18.004  MEMCX  40    4.40kW         2.5% 0.05U
 19.001  5522A        Coil = 9100_Opt200; Turns = 50; IndComp = On
 19.001  5522A        Voltage = 380 V; Current = 100 A; Phase = 0 deg
 19.001  5522A        +Power = 38.00 kVA; Frequency = 50 Hz; CurrTerm = Aux
 19.002  TARGET       -m
 19.003  MEMI         Enter UUT reading in kilovolt-amps:
 19.004  MEMCX  40    38.00kVA       2.5% 0.05U
 20.001  5522A        Coil = 9100_Opt200; Turns = 50; IndComp = On
 20.001  5522A        Voltage = 460.105 V; Current = 100 A; Phase = +73 deg
 20.001  5522A        +Power = -44.0 kVAR; Frequency = 50 Hz; CurrTerm = Aux
 20.002  TARGET       -m
 20.003  MEMI         Enter UUT reading in kilovolts-amps reactive:
 20.004  MEMCX  400   -44.0k'VAR'    2.5% 0.5U
 21.001  5522A        Coil = 9100_Opt200; Turns = 50; IndComp = On
 21.001  5522A        Voltage = 19.8681 V; Current = 100 A
 21.001  5522A        +PF = 0.292; Frequency = 50 Hz; Lag; CurrTerm = Aux
 21.002  TARGET       -m
 21.003  MEMI         Enter UUT power factor reading:
 21.004  MEMCX        0.292          0.050U


5700

Instrument FSC

Description

The 5700 FSC controls the following functions of the Fluke 5700A Multifunction Calibrator:

  • Voltage, current, or resistance stimulus
  • HF Voltage using the 5700A-03 Wideband AC Option
  • Voltage or current from the 5725A Precision Power Amplifier
  • Voltage from the 5205A or 5215A Power Amplifier
  • Current from the 5220A Transconductance Amplifier

The 5725A, 5205A, 5215A, or 5220A must be connected to the 5700A in order to be controlled via the 5700 FSC.

The 5700 FSC may also be used to control a 5700A/EP or 5720A. This capability allows a 5700A based procedure to be executed without modification when a 5700A/EP or 5720A is used.

When the 5700 and MMFC FSCs are used to control a 5700A/EP or 5720A, you must configure the instrument as an "Fluke 5720A" as shown in the drop-down list in the "Add Instrument" configure dialog.

Functional Capability

FUNCTION | Amplitude | Frequency | MOD3
DC Voltage | -1100 V to 1100 V
DC Voltage w/5205A Boost | ±(100 V to 1100 V) | B2
AC Voltage | 220 μV to 219.9999 V (-70.99307 dBm to 49.06693 dBm) | 10 Hz to 1.1999 MHz
- 5700A Series I | 220 V to 1100 V (49.06694 dBm to 63.04634 dBm) | 50 Hz to 1 kHz
- 5700A Series II | 220 V to 250 V (49.06694 dBm to 50.17729 dBm) | 15 Hz to 1 kHz
250.001 V to 1100 V (50.17732 dBm to 63.04634 dBm) | 50 Hz to 1 kHz
- w/5725A Boost | 220 V to 1100 V (49.06694 dBm to 59.71971 dBm) | 40 Hz to 100 kHz | B1
220 V to 750 V (49.06694 dBm to 63.04634 dBm) | 40 Hz to 30 kHz | B1
- w/5205A Boost | 220 V to 1100 V (49.06694 dBm to 63.04634 dBm) | 10 Hz to 100 kHz | B2
- w/5215A Boost | 220 V to 1100 V (49.06694 dBm to 63.04634 dBm) | 10 Hz to 100 kHz | B3
- w/5700A-03 Opt | 300 μV to 3.5 V (-57.44741 dBm to 23.89167 dBm) | 10 Hz to 30 MHz | W
DC Current | -2.199999 A to 2.199999 A
DC Current w/5725A Boost | -11 A to 11 A | B1
DC Current w/5220A Boost | -20 A to 20 A | B4
AC Current | 9 μA to 219.999 mA | 10 Hz to 10 kHz
220 mA to 2.199999 A | 40 Hz to 10 kHz Series I
220 mA to 2.199999 A | 10 Hz to 10 kHz Series II1
AC Current w/5725A Boost | 1 A to 11 A | 40 Hz to 10 kHz | B1
AC Current w/5220A Boost | 1 A to 20 A | 40 Hz to 5 kHz | B4
Resistance or Conductance | 0 Ω (short)
1 Ω to 100 MΩ, 1S to 10nS (in decade steps)
1.9 Ω to 19 MΩ, 0.52631S to 52.631 nS (in decade steps)
  1. No accuracy specification below 20 Hz.

Parameters

RANGE

This field specifies the UUT range as described in the RANGE Field topic.

NOMINAL

This field specifies one of the following.

  • Voltage (DC or RMS) entered as: [numeric][prefix]V
  • dBm entered as: [numeric][prefix]D
  • Current entered as [numeric][prefix]A.
  • Resistance entered as [numeric][prefix]Z.
  • Conductance entered as [numeric][prefix]Y.
  • Frequency entered as [numeric][prefix]H.
  • Reset entered as *.

Rules:

  1. When the NOMINAL field specifies frequency the MOD1 field must specify voltage, decibels, or current.

TOLERANCE

This field specifies the UUT tolerance as described in the TOLERANCE Field topic.

MOD1

This field specifies one of the following for AC signals.

  • Voltage (RMS) entered as: [numeric][prefix]V
  • dBm entered as: [numeric][prefix]D
  • Current entered as [numeric][prefix]A.
  • Frequency entered as [numeric][prefix]H.
  • blank DC or not applicable

Rules:

  1. The MOD1 field may specify frequency only when the NOMINAL field specifies voltage, decibels, or current.
  2. The MOD1 field may specify voltage, decibels, or current only when the NOMINAL field specifies frequency.
  3. The MOD1 field must be blank when the NOMINAL field specifies resistance or conductance.

MOD2

This field allows you to specify the divider override feature of the calibration system. Divider Override is specified by entering the character "O" for this field. The use of the internal and external divider allows a user to achieve higher levels of calibration accuracy in most circumstances. Therefore, the use of the divider is always automatically selected, where it is applicable. There are two reasons to override the use of the divider:

  • The high burden property of the UUT requires divider override to maintain calibration accuracy in the DC Volts mode.
  • Fewer operator interactions are necessary and the feature of the internal and external divider is not necessary, resulting in shorter calibration times.

The following information shows the entries in the MOD2 field, the mode of the 5700A, the Nominal value, and the effect.

Entry | Mode | Nominal | Effect
(blank) | Volts DC | < 220mV | 50 Ω output impedance from 5700A
(blank) | Volts DC | ≥220mV | Low output impedance from 5700A
(blank) | Volts AC | <22mV | External 1000:1 50 Ω divider used Reduced system noise levels, less accuracy
(blank) | Volts AC | ≥22mV | Low output impedance from 5700A
O | Volts DC | <220mV | 5700 A fixed in 2.2 V range
O | Volts DC | ≥220mV | Not applicable
O | Volts AC | <22mV | External divider not used, more wideband noise.
O | Volts AC | ≥22mV | Not applicable

Use of Divider Override in DC Voltage Mode

The output impedance of the 5700A is 50 ohms for programmed voltages below 220 mV in the DC Voltage mode. Substantial errors could be introduced in the calibration of high burden meters as a result of this output impedance.

In the DC Voltage mode, the internal divider of the 5700A can be overridden and fixed in the 2.2V range to calibrate these high burden meters. If the input impedance of the UUT has no impact on the accuracy of calibration, the divider override in DC Voltage should not be specified, since the calibration system uncertainty is less.

Use of Divider Override in AC Voltage Mode

The output impedance of the 5700A is low in any of the ranges. An external 1000:1 divider is supplied with every calibration system, that uses the 5700A as a calibration source. This external divider is used to reduce the impact of system noise on the response of the UUT. If the bandwidth of the AC voltmeter function of the UUT is below 1 MHz, the external divider is generally not necessary; however, to calibrate wideband voltmeters, this external divider should be used.

If the bandwidth of the AC function of the UUT is below 1 MHz, the external divider should be disabled by using the "O" selection in the MOD2 field. The calibration system uncertainty is less in this case.

MOD3

This field specifies one of the following:

B1 | use 5725A for voltage or current boost
B2 | use 5205A for voltage boost
B3 | use 5215A for voltage boost
B4 | use 5220A for current boost
W | use 5700A-03 Wideband output for AC Voltage
blank | No Boost, wideband, or not applicable

Rules:

  1. If the amplitude and frequency combination can be created only by the Boost Amplifier, B1, B2, B3, or B4 is inserted automatically. If there are two voltage boost amplifiers (e.g., 5725A and 5205A) configured in the system and both can provide the desired voltage/current combination, the 5725A has precedence and B1 is automatically inserted in the MOD3 field. If there are two current boost amplifiers (e.g., 5725A and 5220A) configured in the system and both can provide the desired current, the 5725A again has precedence and B1 is automatically inserted in the MOD3 field.
  2. If the amplitude and frequency combination can only be created using the 5700A-03 Wideband AC option, W is inserted automatically in the MOD3 field.

MOD4

This field specifies the type of test being performed as described in the MOD4 Field topic.

CON

This field specifies the UUT connection.

2W | 2-wire
4W | 4-wire
CW | 2-wire ohms compensated at the UUT terminals
RW | 2-wire ohms compensated at the 5700A terminals

Rules:

  1. 2W is automatically entered in the CON field when no CON field code is entered.
    1. DC Voltage < 22mV (unless MOD2 is O)
    2. AC Voltage < 220mV
    3. DC Current
    4. AC Current
    5. 100 MOhm Resistance
  2. The CON field may specify CW or RW only for resistance less than or equal to 19 kOhm.
  3. MET/CAL displays an automatic connection message to use the external 1000:1 divider when the following conditions exist:
    1. AC Voltage mode is specified and the amplitude is less than 22mV
    2. The MOD2 does not specify divider override (O)
    3. The automatic message has not been disabled using ASK- V.
If ASK- V is in effect and conditions 1 and 2 exist it is of paramount importance that the procedure write explicitly generate a connection message for the external divider using the DISP FSC. Failure to do so could result in damage to the UUT and possible bodily injury.

Use of Standard Memory Locations and Results Reporting

System memory locations MEM and MEM1 are used. For more information, refer to the Use of Standard Memory Registers topic.

Examples

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
  1.001  5700         *                                                 S
  1.002  5700   1000  1100V          1U 1/                                 2W
  2.001  5700   10    0V             1U                                    2W
  3.001  5700   200   220mV          10%           50H                     2W
  4.001  5700   1000  1100V          1U            1kH                     4W
  5.001  5700   1     -47.12D        0.1U          50H                     2W
  6.001  5700   100   63.045D        0.5U          1kH                     2W
  7.001  5700   100   -22uA          10%                                   2W
  8.001  5700   2     1.999A         1% 1/         1kH                     2W
  9.001  5700   A     mV             0.1U          50H                     2W
 10.001  5700   A     A              5%            1kH                     2W
 11.001  5700         1.999A                       1kH                  S  2W
 11.002  5700   10    20mV                         500H                 N  2W
 11.003  5700   10    20mV           0.5%          1kH                  C  2W
 12.001  5700   A     1Z             5%                                    CW


MMFC

Instrument Setup FSC

The MMFC FSC programs the 5700A Multifunction Calibrator for special functions. All special functions are reset when another MMFC FSC is used. The new set-up defined by the MMFC FSC becomes effective with the next occurrence of the 5700 FSC.

Parameters

RANGE

Not used.

NOMINAL

Specifies the Phase in degrees from the Variable Phase Reference Output of the 5700A, relative to the normal output, or a reset of the MMFC FSC to the default parameters. The phase is entered as:

sign phase o

A reset of the MMFC parameters is accomplished by entering an asterisk ('*'). Allowed values and units:

-180 degrees to +180 degrees (o)

  • If the Nominal field is blank, the variable phase is OFF.
  • The sign may be '+', '-', or blank.

TOLERANCE

Not used.

MOD1

Specifies the 5700A range that the nominal values will use in all succeeding 5700 FSCs using the Range Lock capability of the 5700A.

  • The range used will be the one that provides the highest resolution of the value entered in the range field of the MMFC FSC. Note that the value indicated by the range name cannot be generated by that range. For example, the maximum value in the 2.2V range is 2.1999999V, not 2.2V.
  • Only DC voltage and DC current can be range locked.
  • 5700 FSC statements which don't specify Nominal values in DC voltage or current will ignore this field.
  • DC voltage outputs may have either positive or negative polarity, so the true range of possible outputs is -1100V to +1100V. The same is true for current, so the range of possible outputs is -2.2A to +2.2A

  • The range to be range locked is entered as: nominal_value_in_range prefix units

    The prefix can be the same as specified for the NOMINAL and MOD1 field of any instrument FSC.

  • Function, allowed values for nominal_value_in_range and units:

    Volts, DC | -1100 V to + 1100 V | (V)
    Amps, DC | -2.2 A to + 2.2 A | (A)

  • The following 5700A ranges allow range locking:

    Function | MMFC MOD1 Value | Range Locked
    DC Voltage | -219.99999 mV to -219.99999 mV | 220 mV
    -2.1999999 V to -220.00000 mV | 2.2 V
    220.00000 mV to 2.1999999 V | 2.2 V
    -10.999999 V to -2.2000000 V | 11 V
    2.2000000 V to 10.999999 V | 11 V
    -21.999999 V to -11.000000 V | 22 V
    11.000000 V to 21.999999 V | 22 V
    -219.99999 V to -22.000000 V | 220 V
    22.000000 V to 219.99999 V | 220 V
    -1100.0000 V to -220.00000 V | 1100 V
    220.00000 V to 1100.0000 V | 1100 V
    DC Current | -219.99999 μA to 219.99999 uA | 220 uA
    -2.1999999 mA to -220.00000 μA | 2.2 mA
    220.00000 μA to 2.1999999 mA | 2.2 mA
    -21.999999 mA to -2.2000000 mA | 22 mA
    2.2000000 mA to 21.999999 mA | 22 mA
    -219.99999 mA to -22.000000 mA | 220 mA
    22.000000 mA to 219.99999 mA | 220 mA
    -2.2000000 A to 220.00000 mA | 2.2 A
    220.00000 mA to 2.2000000 A | 2.2 A

MOD2

Allows specification of the guard connection. If 'G' is specified, the external guard connection becomes active. If nothing is entered the guard is internally shorted to low. The guard active mode is appropriate for low level voltages where noise could affect the response of the unit under test.

MOD3

Specifies Phase Lock. Enter 'PL' when AC voltage or current are to use external phase lock.

MOD4

Not used.

CON

Specifies which output terminals are to be used in the Current Mode of operation. The following entries should be used as a function of the terminals to be used:

CON entry | Output terminals
C1 | Normal output terminals
C2 | AUX output terminals
C3 | 5725A output terminals
  • Current greater than 2.2A will always come out of the appropriate Boost terminals.
  • If the field is left blank, the default will be the value of the CON field in the previous MMFC FSC and if there is none, the default 'C1' is assumed.

Miscellaneous

  • No memory location is affected by the MMFC FSC.
  • There are no automatic messages associated with the MMFC FSC.
  • Certain combinations of entries in MMFC FSC and 5700 FSCs that follow, are inappropriate. The interrelationships of the 5700 and MMFC FSCs are NOT verified during backup or compilation of the procedure. Incorrect combinations may result in error messages during procedure execution.

Examples

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
  2.001  MMFC         180o                                           PL    C1
  6.002  MMFC         -180o                                          PL    C2


5720

Instrument FSC

Description

The 5720 FSC controls the following functions of the Fluke 5720A Multifunction Calibrator:

  • Voltage, current, or resistance stimulus
  • HF Voltage using the 5700A-03 Wideband AC Option
  • Voltage or current from the 5725A Precision Power Amplifier
  • Voltage from the 5205A or 5215A Power Amplifier
  • Current from the 5220A Transconductance Amplifier

The 5725A, 5205A, 5215A, or 5220A must be connected to the 5720A in order to be controlled via the 5720 FSC.

When the 5720 and M5720 FSCs are used to control a 5700A/EP, you must configure the instrument as an "Fluke 5720A" as shown in the drop-down list in the "Add Instrument" configure dialog.

Functional Capability

Function | Amplitude | Frequency | MOD3
DC Voltage | -1100 V to 1100 V
DC Voltage w/5205A Boost | ±(100 V to 1100 V) | B2
AC Voltage | 220 uV to 219.9999 V, | 10 Hz to 1.1999 MHz
-70.99307 dBm to 49.06693 dBm
220 V to 250 V, | 15 Hz to 1 kHz
49.06694 dBm to 50.17729 dBm
250.001 V to 1100 V, | 50 Hz to 1 kHz
50.17732 dBm to 63.04634 dBm
AC Voltage w/5725A Boost | 220 V to 1100 V, | 40 Hz to 100 kHz | B1
49.06694 dBm to 59.71971 dBm
220 V to 750 V, | 40 Hz to 30 kHz | B1
49.06694 dBm to 63.04634 dBm
AC Voltage w/5205A Boost | 220 V to 1100 V, | 10 Hz to 100 kHz | B2
49.06694 dBm to 63.04634 dBm
AC Voltage w/5215A Boost | 220 V to 1100 V, | 10 Hz to 100 kHz | B3
49.06694 dBm to 63.04634 dBm
AC Voltage w/5700A-03 Opt | 300 μV to 3.5 V, | 10 Hz to 30 MHz | W
-57.44741 dBm to 23.89167 dBm
DC Current | -2.199999 A to 2.199999A
DC Current w/5725A Boost | -11 A to 11 A | B1
DC Current w/5220A Boost | -20 A to 20 A | B4
AC Current

9 μA to 219.999 mA

10 Hz to 10 kHz
220 mA to 2.199999 A | 40 Hz to 10 kHz Series I
220 mA to 2.199999A | 10 Hz to 10 kHz Series II1
AC Current w/5725A Boost | 1 A to 11 A | 40 Hz to 10 kHz | B1
AC Current w/5220A Boost | 1 A to 20 A | 40 Hz to 5 kHz | B4
Resistance or Conductance

0 Ω (short)
1 Ω to 100 MΩ, 1S to 10 nS (in decade steps)
1.9 Ω to 19 MΩ, 0.52631 S to 52.631 nS (in decade steps)
  1. No accuracy specification below 20 Hz.

Parameters

RANGE

This field specifies the UUT range as described in the RANGE Field topic.

NOMINAL

This field specifies one of the following.

  • Voltage (DC or RMS) entered as: [numeric][prefix]V
  • dBm entered as: [numeric][prefix]D
  • Current entered as [numeric][prefix]A.
  • Resistance entered as [numeric][prefix]Z.
  • Conductance entered as [numeric][prefix]Y.
  • Frequency entered as [numeric][prefix]H.
  • Reset entered as *.

Rules:

  1. When the NOMINAL field specifies frequency the MOD1 field must specify voltage, decibels, or current.

TOLERANCE

This field specifies the UUT tolerance as described in the TOLERANCE Field topic.

MOD1

This field specifies one of the following for AC signals.

  • Voltage (RMS) entered as: [numeric][prefix]V
  • dBm entered as: [numeric][prefix]D
  • Current entered as [numeric][prefix]A.
  • Frequency entered as [numeric][prefix]H.
  • blank DC or not applicable

Rules:

  1. The MOD1 field may specify frequency when the NOMINAL field specifies voltage, decibels, or current.
  2. The MOD1 field may specify voltage, decibels, or current only when the NOMINAL field specifies frequency.
  3. The MOD1 field must be blank when the NOMINAL field specifies resistance or conductance.

MOD2

This field allows you to specify the divider override feature of the calibration system. Divider Override is specified by entering the character "O" for this field. The use of the internal and external divider allows a user to achieve higher levels of calibration accuracy in most circumstances. Therefore, the use of the divider is always automatically selected, where it is applicable. There are two reasons to override the use of the divider:

  • The high burden property of the UUT requires divider override to maintain calibration accuracy in the DC Volts mode.
  • Fewer operator interactions are necessary and the feature of the internal and external divider is not necessary, resulting in shorter calibration times.

The following information shows the entries in the MOD2 field, the mode of the 5720A, the Nominal value, and the effect.

Entry | Mode | Nominal | Effect
blank | Volts DC | < 220 mV | 50 Ω output impedance from 5720A
blank | Volts DC | ≥ 220mV | Low output impedance from 5720A
blank | Volts AC | < 22 mV | External 1000:150 Ω divider used Reduced system noise levels, less accuracy
blank | Volts AC | ≥ 22 mV | Low output impedance from 5720A
O | Volts DC | < 220 mV | 5720A fixed in 2.2 V range
O | Volts DC | ≥ 220 mV | Not applicable
O | Volts AC | < 22 mV | External divider not used, more wideband noise.
O | Volts AC | ≥ 22 mV | Not applicable

Use of Divider Override in DC Voltage Mode

The output impedance of the 5720A is 50 Ω for programmed voltages below 220 mV in the DC Voltage mode. Substantial errors could be introduced in the calibration of high burden meters as a result of this output impedance.

In the DC Voltage mode, the internal divider of the 5720A can be overridden and fixed in the 2.2V range to calibrate these high burden meters. If the input impedance of the UUT has no impact on the accuracy of calibration, the divider override in DC Voltage should not be specified, since the calibration system uncertainty is less.

Use of Divider Override in AC Voltage Mode

The output impedance of the 5720A is low in any of the ranges. An external 1000:1 divider is supplied with every calibration system, that uses the 5720A as a calibration source. This external divider is used to reduce the impact of system noise on the response of the UUT. If the bandwidth of the AC voltmeter function of the UUT is below 1 MHz, the external divider is generally not necessary; however, to calibrate wideband voltmeters, this external divider should be used.

If the bandwidth of the AC function of the UUT is below 1 MHz, the external divider should be disabled by using the "O" selection in the MOD2 field. The calibration system uncertainty is less in this case.

MOD3

This field specifies one of the following:

B1 | use 5725A for voltage or current boost
B2 | use 5205A for voltage boost
B3 | use 5215A for voltage boost
B4 | use 5220A for current boost
W | use 5700A-03 Wideband output for AC Voltage
blank | No Boost, wideband, or not applicable

Rules:

  1. If the amplitude and frequency combination can be created only by the Boost Amplifier, B1, B2, B3, or B4 is inserted automatically. If there are two voltage boost amplifiers (e.g., 5725A and 5205A) configured in the system and both can provide the desired voltage/current combination, the 5725A has precedence and B1 is automatically inserted in the MOD3 field. If there are two current boost amplifiers (e.g., 5725A and 5220A) configured in the system and both can provide the desired current, the 5725A again has precedence and B1 is automatically inserted in the MOD3 field.
  2. If the amplitude and frequency combination can be created only the 5700A-03 Wideband AC option, W is inserted automatically in the MOD3 field.

MOD4

This field specifies the type of test being performed as described in the MOD4 Field topic.

CON

This field specifies the UUT connection.

2W | 2-wire
4W | 4-wire
CW | 2-wire Ω compensated at the UUT terminals
RW | 2-wire Ω compensated at the 5720 A terminals

Rules:

  1. 2W is automatically entered in the CON field when no CON field code is entered.
  2. The CON field may not specify 4W when any of the following conditions exist:
    1. DC Voltage < 22 mV (unless MOD2 is O)
    2. AC Voltage < 220 mV
    3. DC Current
    4. AC Current
    5. 100 MΩ Resistance
  3. The CON field may specify CW or RW only for resistance less than or equal to 19 kΩ.

  4. MET/CAL displays an automatic connection message to use the external 1000:1 divider when the following conditions exist:

    1. AC Voltage mode is specified and the amplitude is less than 22 mV
    2. The MOD2 does not specify divider override (O)
    3. The automatic message has not been disabled using ASK- V.
    If ASK- V is in effect and conditions a and b exist, it is of paramount importance that the procedure writer explicitly generate a connection message for the external divider using the DISP FSC. Failure to do so could result in damage to the UUT and possible bodily injury.

Use of Standard Memory Locations and Results Reporting

System memory locations MEM and MEM1 are used. For more information, refer to the Use of Standard Memory Registers topic.

Examples

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
  1.001  5720         *                                                 S
  1.002  5720   1000  1100V          1U 1/                                 2W
  2.001  5720   10    0V             1U                                    2W
  3.001  5720   200   220mV          10%           50H                     2W
  4.001  5720   1000  1100V          1U            1kH                     4W
  5.001  5720   1     -47.12D        0.1U          50H                     2W
  6.001  5720   100   63.045D        0.5U          1kH                     2W
  7.001  5720   100   -22uA          10%                                   2W
  8.001  5720   2     1.999A         1% 1/         1kH                     2W
  9.001  5720   A     mV             0.1U          50H                     2W
 10.001  5720   A     A              5%            1kH                     2W
 11.001  5720         1.999A                       1kH                  S  2W
 11.002  5720   10    20mV                         500H                 N  2W
 11.003  5720   10    20mV           0.5%          1kH                  C  2W
 12.001  5720   A     1Z             5%                                    CW


M5720

Instrument Setup FSC

Description

The M5720 FSC programs the 5720A Multifunction Calibrator for special functions. All special functions are reset when another M5720 FSC is used. The new set-up defined by the M5720 FSC becomes effective with The next occurrence of the 5720 FSC.

Parameters

RANGE

Not used.

NOMINAL

Specifies the Phase in degrees from the Variable Phase Reference Output of the 5720A, relative to the normal output, or a reset of the M5720 FSC to the default parameters. The phase is entered as:

sign phase o

A reset of the M5720 parameters is accomplished by entering an asterisk ('*'). Allowed values and units:

-180 degrees to +180 degrees (o)

  • If the Nominal field is blank, the variable phase is OFF.
  • The sign may be '+', '-', or blank.

TOLERANCE

Not used.

MOD1

Specifies the 5720A range that the nominal values will use in all succeeding 5720 FSCs using the Range Lock capability of the 5720A.

  • The range used will be the one that provides the highest resolution of the value entered in the range field of the M5720 FSC. Note that the value indicated by the range name cannot be generated by that range. For example, the maximum value in the 2.2V range is 2.1999999V, not 2.2V.
  • Only DC voltage and DC current can be range locked.
  • 5720 FSC statements which don't specify Nominal values in DC voltage or current will ignore this field.
  • DC voltage outputs may have either positive or negative polarity, so the true range of possible outputs is -1100V to +1100V. The same is true for current, so the range of possible outputs is -2.2A to +2.2A
  • The range to be range locked is entered as: nominal_value_in_range prefix units The prefix can be the same as specified for the NOMINAL and MOD1 field of any instrument FSC.

  • Function, allowed values for nominal_value_in_range and units:

    Volts, DC | -1100V to + 1100V | (V)
    Amps, DC | -2.2A to + 2.2A | (A)

  • The following 5720A ranges allow range locking:

    M5720 | MOD1 Value | Range Locked
    DC Voltage | -219.99999 mV to -219.99999 mV | 220 mV
    -2.1999999 V to -220.00000 mV | 2.2 V
    220.00000 mV to 2.1999999 V | 2.2 V
    2.2000000 V to 10.999999 V | 11 V
    -21.999999 V to -11.000000 V | 22 V
    11.000000 V to 21.999999 V | 22 V
    -219.99999 V to -22.000000 V | 220 V
    22.000000 V to 219.99999 V | 220 V
    -1100.0000 V to -220.00000 V | 1100 V
    220.00000 V to 1100.0000 V | 1100 V
    DC Current | -219.99999 μA to 219.99999 μA | 220 μA
    -2.1999999 mA to -220.00000 μA | 2.2 mA
    220.00000 μA to 2.1999999 mA | 2.2 mA
    -21.999999 mA to -2.2000000 mA | 22 mA
    2.2000000 mA to 21.999999 mA | 22 mA
    -219.99999 mA to -22.000000 mA | 220 mA
    22.000000 mA to 219.99999 mA | 220 mA
    -2.2000000 A to 220.00000 mA | 2.2 A
    220.00000m A to 2.2000000 A | 2.2 A

MOD2

Allows specification of the guard connection. If 'G' is specified, the external guard connection becomes active. If nothing is entered the guard is internally shorted to low. The guard active mode is appropriate for low level voltages where noise could affect the response of the unit under test.

MOD3

Specifies Phase Lock. Enter 'PL' when AC voltage or current are touse external phase lock.

MOD4

Not used.

CON

Specifies which output terminals are to be used in the Current Mode of operation. The following entries should be used as a function of the terminals to be used:

CON entry | Output terminals
C1 | Normal output terminals
C2 | AUX output terminals
C3 | 5725A output terminals
  • Current greater than 2.2A will always come out of the appropriate Boost terminals.
  • If the field is left blank, the default will be the value of the CON field in the previous M5720 FSC and if there is none, the default 'C1' is assumed.

Miscellaneous

  • No memory location is affected by the M5720 FSC.
  • There are no automatic messages associated with the M5720 FSC.
  • Certain combinations of entries in M5720 FSC and 5720 FSCs that follow, are inappropriate. The interrelationships of the 5720 and M5720 FSCs are NOT verified during backup or compilation of the procedure. Incorrect combinations may result in error messages during procedure execution.

Examples

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
  2.001  M5720        180o                                           PL    C1
  6.002  M5720        -180o                                          PL    C2


5730A

Instrument FSC

Description

The 5730A FSC controls the Fluke 5730A Calibrator.

If the 5730A is to be controlled via its serial port, do not use the PORT FSC port configuration special construction, [P9600,N,...], to set the baud rate, parity, etc. of the port used to control the 5730A. MET/CAL executes a "Test" function for each System Instrument prior to executing any procedure statements, therefore the settings of the port used to controlling the 5730A must be set correctly before a procedure is executed. If the 5730A is connected to a standard serial port (COM1, COM2, ..., COM16), select the "Ports" application in the Windows control panel to choose the proper settings.

When a 5080A, 5500A, 5502A, 5502E, 5520A, or 5522A is configured for serial control, the MET/CAL driver automatically sets the calibrator to Computer Mode with linefeed (LF) only termination. This is not possible for the 5730A, since there are separate commands for selecting Computer Mode for the DB9 RS-232 port and the USB port. Since the Windows interface is COMn for both physical ports, there is no way for MET/CAL to determine if serial control is via the DB9 RS-232 or USB port. Therefore, the 5730A must be set to the proper interface DB9 RS-232 or USB AND Computer Mode, LF Termination from the front panel prior to running MET/CAL.

Parameters

An NVI FSC statement consists of one or more parameters. A parameter consists of a name and a value. Each parameter must be separated by a semicolon and/or one or more spaces. A single NVI FSC statement can encompass more than one physical line as long as the line numbers are the same. However each parameter name and its value must occur on one line. A single line can accommodate up to 256 characters including the statement number and FSC. Note that characters above ASCII 128 count as 2 characters.

Syntax:

parameter[separatorparameter]

parameter::= [parameter_prefix]parameter_name[[sp]=[sp]parameter_value]

separator::= ;[sp] | sp

parameter_prefix ::=+ | @

sp::= one or more spaces

parameter_name::= see the Parameter Names section

parameter_value::=dimensionless number | dimensioned number | discrete_list

dimensionless number::=NRf

dimensioned number::=NRf[sp][prefix]units

discrete_list::=see the Parameter Names section

prefix::=y | z | a | f | p | n | u | m | k | M | G | T | P | E | Z | Y

Definitions:

|
Denotes "or" (i.e. A | B is A or B)
[ ]
Denotes an optional syntax element, except in examples. In examples [ ] enclose a special construction.
+
Designates the parameter as the Evaluation Quantity
@
Designates the parameter as the Modifier Quantity

Examples:

The following three 5730A statements are identical with respect to the 5730A:

Statement #1

1.001 5730A +Voltage = 240 V; @Frequency = 50 Hz

Statement #2

1.001 5730A Mode = AC_Voltage +Volt = 240.0 V @Freq = 50 Hz

Statement #3

1.001 5730A Apply
1.001 5730A Mode = ACV
1.001 5730A +Voltage = 240 V
1.001 5730A @Freq = 50 Hz

Rules:

  1. One and only one parameter must be designated as the Evaluation Quantity in a 5730A Apply, Setup, or Slew statement.
  2. At most one parameter may be designated as the Modifier Quantity in a 5730A Apply, Setup, or Slew statement.
  3. Parameter values may be taken from a MET/CAL memory register using a special construction.
  4. When a 5730A Apply statement is executed, the value of the Evaluation Quantity is copied to memory register MEM1 in specified units.

    5. Example:

    1.001 5730A Mode = ACV; +Volt = 240 V; @Freq = 50 Hz; Apply

    After the 5730A statement is executed the value of MEM1 is 240.

  5. When a 5730A Operate statement is executed, the value of the Evaluation Quantity designated in the previous Setup or Apply statement is copied to memory register MEM1 in specified units.

    6. Example:

    1.001 5730A Mode = Volt; +Volt = 240 V; @Freq = 50 Hz; Setup
1.002 5730A Mode = Volt; +Volt = 240 V; @Freq = 50 Hz; Operate

    After the 5730A Operate statement is executed the value of MEM1 is 240.

  6. When a 5730A Slew statement is executed, the Evaluation Quantity designates the slew quantity.
  7. When a 5730A Slew statement is executed, the final slew value is copied to memory register MEM1 in units of the Evaluation Quantity.

    8. Example:

    1.001 5730A +Volt = 240V; @Freq = 50Hz; Slew

    Operator slews the 5730A output to 241.5 V.

    After the 5730A Slew statement is executed the value of MEM is 241.5.

  8. When a 5730A Slew statement is executed, the Modifier Quantity is concatenated to the Evaluation Quantity in the automatic slew message. Note, the automatic slew message is not displayed when ASK- N is in effect.

    9. Examples:

    1.001 ASK+ N
1.002 5730A +Volt = 120 V; @Freq = 60 Hz; Slew

    "Adjust stimulus for a UUT reading of 120 V at 60 Hz."

    No Modifier Quantity designated.

    1.001 5730A Mode = Volt; +Volt = 120 V; Freq = 60 Hz; Slew

    "Adjust stimulus for a UUT reading of 120 V."

    Automatic slew message inhibited.

    1.001 ASK- N
1.002 5730A +Volt = 120 V; Freq = 60 Hz; Slew

    No automatic slew message generated, use MESS FSC.

Parameter Names

Parameter names consist of single words or compound words. Each word in a parameter name can be entered in long form (as shown below), or in short form. The short form is the first 4 characters of the long form, with the following exceptions:

  1. If the long form is greater than four characters, and the last character or the short form is a vowel, the short form is three characters.
  2. If the long form is four characters or less, the short form is the long form even if it ends in a vowel.

Compound parameter names can be entered in any combination of long and short forms. Example, ExternalReference can be entered using any of the following forms:

  • InductanceCompensation
  • InductanceComp
  • IndCompensation
  • IndComp

Action Parameters

  • Apply
  • Local
  • Operate
  • Reset
  • Setup
  • Slew
  • Standby

General Parameters

  • Amplitude
  • Boost
  • BoostCount
  • BurdenVoltage
  • Coil
  • Current
  • CurrentTerminal
  • ExternalGuard
  • ExternalSense
  • Flatness
  • Frequency
  • InductanceCompensation
  • LeadCompensation
  • LeadResistance
  • Load
  • Mode
  • NonToroidalUUT
  • Period
  • Range
  • ReferenceFrequency
  • Resistance
  • ToroidalUUT
  • UUT_Current
  • Voltage

Instrument Mode

If the 5730A operating mode is not specified, MET/CAL determines the mode based on occurrence of the following parameters in the 5730A statement:

  • Current
  • Frequency
  • Period
  • Resistance
  • Voltage

Rules:

  1. If Resistance or Conductance is specified, the mode is Resistance.
  2. If Current and Frequency or Period are specified, the mode is AC Current.
  3. If Current is specified, but not Frequency or Period, the mode is DC Current.
  4. If Voltage and Frequency or Period are specified, the mode is AC Voltage.
  5. If Voltage is specified, but not Frequency or Period, the mode is DC Voltage.

Mode/Parameter Rules

DC VOLTAGE

Mode = DC_Voltage | DC_Volt | DCV

Required Parameters
Voltage
Optional Parameters | Default
Mode | DC_Voltage
Range 1 | autorange
ExternalGuard | Off
ExternalSense | Off
Apply | Setup | Operate | Slew | Apply
  1. Not allowed when CurrentTerminal = 52120A

DC CURRENT

Mode = DC_Current | DC_Curr | DCA

Required Parameters
Current
CurrentTerminal
Optional Parameters | Default
Mode | DC_Current
Range | autorange 1
Boost | off 2
BoostCount | na 3
BurdenVoltage | na
Coil | na
ExternalGuard | Off 1
Load | na
Apply | Setup | Operate | Slew | Apply
  1. Not allowed when CurrentTerminal = 52120A
  2. Only allowed, when CurrentTerminal = 5725A and Range = 11 A or CurrentTerminal = 52120A
  3. Only allowed when CurrentTerminal = 52120A

RESISTANCE

Mode = Resistance | Res

Required Parameters
Resistance | Conductance
Optional Parameters | Default
Mode | Resistance
LeadCompensation | Off
LeadResistance | na 1
ExternalSense | Off
ExternalGuard | Off
UUT_Current | na 2
Apply | Setup | Operate | Apply
  1. Required when LeadCompensation = 2Wire and Resistance is < 100 k
  2. Required when LeadCompensation = 2Wire and Resistance is < 1 k

To compute reference accuracy/system uncertainty, UUT_Current must be specified.

AC VOLTAGE

Mode = AC_Voltage | AC_Volt | ACV

Required Parameters
Voltage | Amplitude
Frequency | Period
Optional Parameters | Default
Mode | AC_Voltage
Boost | Off
ExternalGuard | Off
ExternalSense | Off
Apply | Setup | Operate | Slew | Apply

AC CURRENT

Mode = AC_Current | AC_Curr | ACA

Required Parameters
Current
CurrentTerminal
Frequency | Period
Optional Parameters | Default
Mode | AC_Current
Range | autorange 1
Boost | off 2
BoostCount | na 3
Coil | na
ToroidalUUT | NonToroidalUUT | na 4
InductanceCompensation | Off 3
ExternalGuard | Off 1
Apply | Setup | Operate | Slew | Apply
  1. Only allowed when CurrentTerminal = 5725A and only Range = 11 A is allowed
  2. Only allowed, when CurrentTerminal = 5725A and Range = 11 A or CurrentTerminal = 52120A
  3. Only allowed when CurrentTerminal = 52120A
  4. Only allowed, and required when Coil is specified

WIDEBAND AC VOLTAGE

Mode = WidebandAC_Voltage | WidebandAC_Volt | WidAC_Voltage | WidAC_Volt | WidebandACV | WidACV

Required Parameters
Mode
Voltage | Amplitude
Frequency | Period
Optional Parameters | Default
Flatness | na 1
FlatnessReferenceFrequency | na 1
Apply | Setup | Operate | Slew | Apply
  1. Only one can be specified

Parameter Definitions and Values

Amplitude

This parameter specifies the amplitude in dBm for AC Voltage mode.

Syntax:

[+|@]Amplitude[sp]=[sp]numeric value[sp][prefix]dBm

Examples:

Amplitude = +10.0 dBm

Apply

This action sets up the instrument and enables the output.

Syntax:

Apply

Rules:

  1. When Apply is specified, no other action may be specified.

Examples:

Apply

Boost

This parameter turns boost on or off.

Syntax:

Boost[sp]=[sp]value

value = On | Off

Rules:

  1. Boost is automatically turned on when CurrentTerminal = 5725A and Range = 11 A.
  2. Boost is automatically turned on when CurrentTerminal = 52120A_High or 52120A_Low.

Examples:

Boost = On

BurdenVoltage

This parameter specifies the burden voltage for computation of DC current uncertainty adder.

Syntax:

BurdenVoltage[sp]=[sp]numeric value[sp][prefix]V

Rules:

  1. Legal values are: 0 to 1.0E+6 V

Examples:

BurdenVoltage = 1 V

Conductance

This parameter specifies the expected conductance

Syntax:

[+|@]Conductance[sp]=[sp]numeric value[sp][prefix]S

Rules:

  1. Legal values are: 10, 100 nS, 1, 10, 100 µS, 1, 10, 100 mS, 1 S

Examples:

Conductance = 10.00 nS

Coil

This parameter specifies a current coil.

Syntax:

Coil[sp]=[sp]value

value ::= 52120A/COIL3kA | 52120A/COIL6kA

Examples:

Coil = 52120A/COIL3kA

Current

This parameter specifies the output current.

Syntax:

[+|@]Current[sp]=[sp]numeric value[sp][prefix]units

units ::= A | Ap | App

Examples:

Current = 2.5 A

CurrentTerminal

This parameter specifies a current output terminals.

Syntax:

CurrentTerminal[sp]=[sp]value

value ::= Normal | Norm | Auxiliary | Aux | 5725A | 52120A_High | 52120A_Low

Examples:

CurrentTerminal = Aux

ExternalGuard

This parameter specifies the external guard connection.

Syntax:

ExternalGuard[sp]=[sp]value

value ::= On | Off

Examples:

ExtGuard = On

ExternalSense

This parameter specifies the external guard connection.

Syntax:

ExternalSense[sp]=[sp]value

value ::= On | Off

Examples:

ExtSense = On

Flatness

This parameter causes a 5730A statement to return only the flatness accuracy at the specified frequency.

Syntax:

Flatness

Rules:

When Flatness is specified, FlatnessReferenceFrequency cannot be specified.

Examples:

FlatRefFreq = 1 kHz

FlatnessReferenceFrequency

This parameter causes a 5730A statement to return the flatness accuracy at the specified frequency plus the absolute accuracy at the reference frequency.

Syntax:

[@]FlatnessReferenceFrequency[sp]=[sp]numeric value[sp][prefix]Hz

Rules:

  1. When FlatnessReferenceFrequency is specified, Flatness cannot be specified.

Examples:

FlatRefFreq = 1 kHz

Frequency

This parameter specifies the output frequency.

Syntax:

[+|@]Frequency[sp]=[sp]numeric value[sp][prefix]Hz

Rules:

  1. When Frequency is specified, Period cannot be specified.

Examples:

@Freq = 50 Hz

InductanceCompensation

This parameter specifies the inductance compensation (LCOMP).

Syntax:

InductanceCompensation[sp]=[sp]value

value ::= On | Off

Examples:

IndComp = On

LeadCompensation

This parameter selects the lead compensation.

Syntax:

LeadCompensation[sp]=[sp]value

value ::= 2W | 2Wire | Off

Examples:

+Resistance = 0.0 Ohms; LeadCompensation = 2W

LeadResistance

This parameter selects the lead resistance.

Syntax:

LeadResistance[sp]=[sp]numeric value[sp][prefix]Ohm[s]

Rules:

  1. Legal values are 0.1 and 1 .
  2. LeadResistance is required when LeadCompensation = 2Wire

Examples:

LeadResistance = 0.1 Ohm; LeadCompensation = 2Wire

Load

This parameter specifies the load for computation of DC current uncertainty adder.

Syntax:

Load[sp]=[sp]numeric value[sp][prefix]Ohm[s]

Rules:

  1. Legal values are: 0 to tbd Ohms

Examples:

Load = 1 Ohm

Local

This action puts the 5730A in local mode.

Syntax:

Local

Rules:

  1. When Local is specified, no other parameters may be specified.

Examples:

Local

Mode

This parameter selects the instrument mode.

Syntax:

Mode[sp]=[sp]value

value ::= DC_Voltage | DC_Volt | DCV |

DC_Current | DC_Curr | DCA |

Resistance | Res |

AC_Voltage | AC_Volt | ACV |

AC_Current | AC_Curr | ACA |

WidebandAC_Voltage | WidAC_Voltage |WidebandAC_Volt | WidAC_Volt |

WidebandACV | WidACV

Rules:

  1. If mode is not specified, the mode is determined as described in the section INSTRUMENT MODE at the top of this file.

Examples:

Mode = WidebandACV

NonToroidalUUT

See ToroidalUUT / NonToroidalUUT.

Operate

This parameter turns the output on.

Syntax:

Operate

Rules:

  1. When Operate is specified, no other parameters are allowed.

Examples:

Operate

Period

This parameter specifies the output period.

Syntax:

[+|@]Period[sp]=[sp]numeric value[sp][prefix]s

Rules:

  1. When Period is specified, Frequency cannot be specified.

Examples:

@Per = 1 ms

Range

This parameter specifies the range to range lock in DC Voltage and DC Current modes.

Syntax:

Range[sp]=[sp]numeric value[sp][prefix]units

units ::= A | V

Rules:

  1. Range is not allowed for DC Current mode using a 52120A.
  2. When CurrentTerminal = 5720A and Range = 11 A, Boost = 5725A is required.

Examples:

Range = 3.3 V

Reset

This parameter resets the 5730A.

Syntax:

Reset

Rules:

  1. When Reset is specified, no other parameters are allowed.

Examples:

Reset

Resistance

This parameter specifies the resistance.

Syntax:

[+|@]Resistance[sp]=[sp]numeric value[sp][prefix]Ohm[s]

Rules:

  1. Legal values are: 0, 1, 1.9, 10, 19, 100, 190 , 1, 1.9, 10, 19, 100, 190 k, 1, 1.9, 10, 19, 100 M

Examples:

Resistance = 100 Ohms

Setup

This action causes the instrument to be setup only.

Syntax:

Setup

Rules:

  1. When Setup is specified, no other action may be specified.

Examples:

Setup

Slew

This action sets up the instrument and enables the output. Slewing is then enabled for the parameter designated as the Evaluation Quantity (i.e. + prefix).

Syntax:

Slew

Rules:

  1. When Slew is specified, no other action may be specified.
  2. The Slew is not allowed when Mode = Resistance.

Examples:

Slew

Standby

This action selects standby (output disabled).

Syntax:

Standby

Rules:

  1. When Standby is specified, no other parameters are allowed.

Examples:

Standby

ToroidalUUT / NonToroidalUUT

These parameters specify that the UUT design for calculation of the total reference accuracy when a coil is specified.

Syntax:

ToroidalUUT | NonToroidal

Rules:

  1. When ToroidalUUT and NonToroidalUUT are mutually exclusive.
  2. When neither ToroidalUUT or NonToroidalUUT is specified, the default is non-toroidal.

Examples:

ToroidalUUT

UUT_Current

This parameter specifies the UUT source current for Resistance mode.

Syntax:

UUU_Current[sp]=[sp]numeric value[sp][prefix]A

Examples:

UUT_Current = 500 uA

Voltage

This parameter specifies the output voltage:

Syntax:

[+|@]Voltage[sp]=[sp]numeric value[sp][prefix]units

units ::= V | Vp | Vpp

Examples:

+Voltage = 240 V

Examples

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
# -----  Reset  -----
  1.001  5730A        Reset

# -----  Standby  -----
  1.002  5730A        Standby

# -----  DC Voltage  -----
  1.003  5730A        +Voltage = -190.0 mV
  1.004  TARGET       -m
  1.005  MEMI         Enter UUT reading in millivolts DC:
  1.006  MEMCX  200   -190.0mV       1.0% 0.1U

# -----  DC Current  -----
#        Same as MMFC/M5720 CON field "C1"
  2.001  5730A        +Current = 100.00 mA; CurrentTerminal = Normal

#        Same as MMFC/M5720 CON field "C2"
  2.002  5730A        +Current = 19.00 mA; CurrentTerminal = Aux
  2.003  TARGET       -m
  2.004  MEMI         Enter UUT reading in millamps DC:
  2.005  MEMCX  20    19.00mA        1.5% 0.01U

# -----  DC Current using 5725A
#        Same as MMFC/M5720 CON field "C3"
  3.001  5730A        +Current = 100.00 mA; CurrentTerminal = 5725A

#        Same as 5700/5720 MOD3 field "B1"
  3.002  5730A        +Current = 10.000 A; CurrentTerminal = 5725A

# -----  DC Current using 52120A
  3.003  5730A        +Current = 1.000 A; CurrentTerminal = 52120A_Low
  3.004  5730A        +Current = 50.00 A; CurrentTerminal = 52120A_High

# -----  DC Current (using 52120A and 52120A/COIL3KA)  -----
  3.005  5730A        CurrentTerminal = 52120A_High
  3.005  5730A        +Current = 100.0 A; Coil = 52120A/COIL3KA
  3.006  TARGET       -m
  3.007  MEMI         Enter UUT reading in amps DC:
  3.008  MEMCX  400   100.0A         1.5% 0.5U

# -----  DC Current (using 52120A and 52120A/COIL6KA)  -----
  4.001  5730A        CurrentTerminal = 52120A_High
  4.001  5730A        +Current = 4000 A; Coil = 52120A/COIL6KA
  4.002  TARGET       -m
  4.003  MEMI         Enter UUT reading in amps DC:
  4.004  MEMCX  400   4000A          1.5% 05U

# -----  Resistance  -----
#        Same as 5700/5720 FSC CON field "2W")
  5.001  5730A        +Resistance = 100.0 MOhms; UUT_Current = 0.8 uA

  5.002  5730A        LeadComp = Off
  5.002  5730A        +Resistance = 100.0 MOhms; UUT_Current = 0.8 uA

#        Same as 5700/5720 FSC CON field "RW")
  5.003  5730A        LeadComp = 2W
  5.003  5730A        +Resistance = 190.00 Ohms; UUT_Current = 8 mA

#        Same as 5700/5720 FSC CON field "CW")
  5.004  5730A        LeadComp = 2W; ExtSense = On
  5.004  5730A        +Resistance = 190.00 Ohms; UUT_Current = 8 mA

#        Same as 5700/5720 FSC CON field "4W")
  5.005  5730A        LeadComp = 2W; ExtSense = On
  5.005  5730A        +Res = 1.900 kOhms; UUT_Current = 8 mA
  5.006  TARGET       -m
  5.007  MEMI         Enter UUT reading in kilohms:
  5.008  MEMCX  2     kOhms          1% 0.004U

# -----  AC Voltage  -----
  6.001  5730A        +Voltage = 19.00 V; Frequency = 50 Hz
  6.002  TARGET       -m
  6.003  MEMI         Enter UUT reading in volts AC:
  6.004  MEMCX  20    19.00V         1.5% 0.05U    50Hz

# -----  AC Current  -----
#        Same as MMFC/M5720 CON field "C1"
  7.001  5730A        +Curr = 1.900 mA; Frequency = 500 Hz; CurrTerm = Norm
  7.002  TARGET       -m
  7.003  MEMI         Enter UUT reading in millamps AC:
  7.004  MEMCX  2     1.900mA        2% 0.005U     500Hz

#        Same as MMFC/M5720 CON field "C2"
  8.001  5730A        +Curr = 30.000 mA; Frequency = 1 kHz; CurrTerm = Aux

# -----  AC Current using 5725A
#        Same as MMFC/M5720 CON field "C3"
  8.002  5730A        +Curr = 30.000 mA; Frequency = 1 kHz; CurrTerm = 5725A
#        Same as 5700/5720 MOD3 field "B1"
  8.003  5730A        +Current = 10.000 A; Frequency = 1 kHz; CurrTerm = 5725A

# -----  AC Current using 52120A
  8.004  5730A        CurrentTerminal = 52120A_Low
  8.004  5730A        +Current = 10.000 A; Frequency = 1 kHz
  8.005  5730A        CurrentTerminal = 52120A_High
  8.005  5730A        +Current = 100.00 A; Frequency = 50 Hz

# -----  AC Current (using 52120A and 52120A/COIL3KA)  -----
  8.006  5730A        CurrentTerminal = 52120A_High
  8.006  5730A        Coil = 52120A/COIL3KA; NonToroidalUUT
  8.006  5730A        +Current = 410 A; Frequency = 50 Hz; IndComp = On
  8.007  TARGET       -m
  8.008  MEMI         Enter UUT reading in amps AC:
  8.009  MEMCX  2000  410A           1.5% 5U       50Hz

# -----  Wideband AC Voltage)  -----
#        Same as 5700/5720 MOD3 field "W"
  9.001  5730A        Mode = WidebandACV
  9.001  5730A        +Voltage = 10.00 mV; Frequency = 10 MHz
  9.002  5730A        Mode = WidebandACV
  9.002  5730A        +Amplitude = -2.0 dBm; Frequency = 10 MHz


5790

Instrument FSC

Description

The 5790 FSC programs the Fluke 5790A AC Measurement Standard perform the following measurements:

  • AC Voltage from Input 1 or Input 2
  • AC/DC and AC/AC Voltage transfer measurement
  • HF AC Voltage using the Wideband option
  • AC/DC Current transfer measurement on Input 1 using one of the A40 current shunts and the 792A-7004 adapter or one of the A40A current shunts and the 792A-7004 adapter and A45-4004 adapter cable.
  • AC/DC Current transfer measurements on the Shunt Input using one of the A40 current shunts, a Pomona Model 1829 banana plug splice, and a Pomona cable model 1368-A-18 or one of the A40A current shunts and a Pomona cable model 5268-C-12.

Functional Capability

Mode | Amplitude | Frequency | MOD2
DC Voltage | ±(700 μV to 1000 V) | I1
DC Voltage | ±(700 μV to 1000 V) | I2
AC Voltage | 700 μV to 1000 V | 10 Hz to 1 MHz | I1
AC Voltage | 700 μV to 1000 V | 10 Hz to 1 MHz | I2
AC Voltage w/5790A-03 Opt | 700 μV to 1 V | 10 Hz to 30 MHz | W
DC Current | -20 A to 20 A1 | I1
AC Current | 0 A to 20 A1 | 10 Hz to 100 kHz | I1
  1. Actual range depends on the actual A40 or A40A current shunt used.

Parameters

RANGE

This field specifies the UUT range as described in the RANGE Field topic.

NOMINAL

This field specifies the expected measured value or a reset.

  • Voltage (DC or RMS) entered as: [numeric][prefix]V
  • Current entered as [numeric][prefix]A.
  • Frequency entered as [numeric][prefix]H.
  • Reset entered as *.

Rules:

  1. When the NOMINAL field specifies frequency, the MOD1 field must specify voltage or current.
  2. When the NOMINAL field specifies current, only a Setup or Nominal Setup Test is allowed. You cannot perform an Evaluation Test in this mode, only AC/DC current transfer measurements.

TOLERANCE

This field specifies the UUT tolerance as described in the TOLERANCE Field topic.

MOD1

This field specifies one of the following for AC signals.

  • Frequency entered as [numeric][prefix]H.
  • Voltage (RMS) entered as: [numeric][prefix]V
  • Current entered as [numeric][prefix]A.
  • blank DC

Rules:

  1. The MOD1 field may specify frequency only when the NOMINAL field specifies voltage or current.
  2. The MOD1 field may specify voltage or current only when the NOMINAL field specifies frequency.

MOD2

The MOD2 field specifies the input to be used.

I1 | Input 1
I2 | Input 2
SH | Shunt
W | Wideband

Rules:

  1. The MOD2 field value must be explicitly entered. No default value is automatically inserted in the MOD2 field and the field may not be blank.

MOD3

The MOD3 field controls the digital filter of the 5790A.

-F | OFF | -> | 1 sample/reading
F | FAST | -> | 4 samples/reading
blank | MEDIUM | -> | 16 samples/reading
E | SLOW | -> | 32 samples/reading

Rules:

  1. The 5790A has different modes of operation, which allow higher levels of accuracy at longer measurement times. Refer to the 5790A Operator Manual for detailed information on the different types of measurements and their properties.
  2. Readings on the 700 mV range and above have an extra digit of resolution in modes E and "blank." However, the digital filter restart does not use this extra digit when evaluating the sample window. For more information about the digital filter restart, refer to the help file for the ACMS FSC and the 5790A Operator Manual.

MOD4

This field specifies the type of test being performed as described in the MOD4 Field topic.

CON

This field specifies the type of test to be performed.

2W | Standard measurement
XF | Transfer measurement

Rules:

  1. 2W is automatically entered in the CON field when no CON field code is entered.
  2. The AC/DC or AC/AC transfer measurement capability (AC Voltage connected to Input 1 and DC Reference Voltage connected to Input 2) is supported in a single 5790 FSC statement when the CON field specifies XF. However, it may be desirable to implement the transfer function using multiple FSC statements.

Use of Standard Memory Locations and Results Reporting

System memory locations MEM and MEM1 are used. For more information, refer to the Use of Standard Memory Registers topic.

Transfer Measurements

In the following example. A Fluke 5440A is used to supply the DC reference voltage at Input 2 and the UUT on Input 1. The AC output of the UUT is measured and verified to be within 25 ppm.

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
  3.018  ASK-   R     N                                                    W
  3.019  DISP         Connect the 5440B Output to the 5790A Input 2.
  3.019  DISP
  3.019  DISP         Connect the UUT Output to the 5790A Input 1.
  3.020  DISP         Setup the UUT to 1V @ 1kHz and Operate.
  3.021  5440         1.000000V                                         S  2W
  3.022  5790         1.000000V                    1kH            I1 E  N  XF
  3.023  MATH         M[1] = MEM
  3.024  5440         -1.000000V                                        S  2W
  3.025  5790         1.000000V                    1kH            I1 E  N  XF
  3.026  MATH         MEM = (M[1] + MEM) / 2
  3.027  5440         *                                                 S
  3.028  DISP         Set the UUT to Standby.
  3.029  MEMC         1.000000V      0.000025U     1kH

Current Measurements

Current measurement is accomplished using an A40 or A40A and measuring the voltage drop across the shunt. AC currents are determined through comparison with a known DC or AC current.

If automatic connection messages are enabled, MET/CAL prompts you for the appropriate A40 current shunt. The shunt value is selected based on the nominal field value. You can override this feature by using the ACMS FSC to manually select a different shunt value (See ACMS FSC). In the following example, the AC current function of a

Fluke 5700A is tested using the DC current of the same 5700A. It is assumed that the DC current is in calibration and meets the manufacturer's specification.

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
  4.001  ASK-   R     N                                                    W
  4.002  ACMS                                                        F
  4.003  HEAD         AC CURRENT: {22 mA Range}
  4.004  DISP         Connect the 5700A Output terminals to the 5790A
  4.004  DISP         INPUT 1 using a Pomona cable #1368-A-18, an A40-20mA
  4.004  DISP         current shunt, and a 792A-7004 current shunt adapter.

# Enter A40-20 mA AC-DC difference (in percent).
  4.005  MEMI         Enter A40-20mA shunt AC-DC difference at 100 Hz (%):
# L[32] contains A40-20 mA AC-DC difference, converted to proper decimal.
  4.006  MATH         L[32] = MEM / 100
# Apply +DC.
  4.007  IEEE         OUT 20mA;OPER
# Take +DC reading with 5790A.
  4.008  5790         20.00000mA                                  I1 E  N  2W
# Store +DC reading in L[1].
  4.009  MATH         L[1] = MEM
# Apply -DC.
  4.010  IEEE         OUT -20mA;OPER
# Take -DC reading with 5790A.
  4.011  5790         -20.00000mA                                 I1 E  N  2W
# Compute mean DC from ±DC readings.
  4.012  MATH         L[2] = (L[1] + ABS(MEM)) / 2
# Apply AC.
  4.013  IEEE         OUT 20mA,100Hz;OPER
# Take AC reading with 5790A.
  4.014  5790         20.00000mA                   100H           I1 E  N  2W
# Set source to standby.
  4.015  IEEE         STBY
# Apply A40-20 mA shunt AC-DC difference to measured AC value.
  4.016  MATH         L[3] = MEM - (MEM * L[32])
# Compute AC value based on nominal & difference between ±DC and corrected AC.
  4.017  MATH         MEM = (20E-3 - (20E-3 * (1 - (L[3] / L[2])))) / 1E-3
  4.018  MEMC         20.00000mA     140P% 0.0004U 100H


ACMS

Instrument Setup FSC

The ACMS FSC programs the 5790A Multifunction Calibrator for special functions. All special functions are reset when another ACMS FSC is used. The new set-up defined by the ACMS FSC becomes effective with the next occurrence of the 5790 FSC.

Parameters

RANGE

Not used.

NOMINAL

Specifies the A40 current shunt that will be used for current measurements. Automatic connection messages, if enabled, will reflect the selected shunt. This feature is useful when the standard A40 shunt, for a particular measurement value, is not available.

The following Fluke current shunts are supported:

  • A40-10mA
  • A40-20mA
  • A40-30mA
  • A40-50mA
  • A40-100mA
  • A40-200mA
  • A40-300mA
  • A40-500mA
  • A40-1A
  • A40-2A
  • A40-3A
  • A40-5A
  • A40-10A
  • A40-20A
  1. A reset of the ACMS parameters is accomplished by entering an asterisk ('*').
  2. If the nominal field is blank, the appropriate A40 shunt will be selected by MET/CAL at runtime and the appropriate connection message will be issued.

TOLERANCE

Not used.

MOD1

Specifies the 5790A range that the nominal values will use in all succeeding 5790 FSCs using the Range Lock capability of the 5790A.

  • The range used will be the one that provides the highest resolution of the value entered in the MOD1 field of the ACMS FSC.
  • DC voltage values may have either positive or negative polarity, so the true range of possible outputs is -1000V to +1000V. (The range will be selected based on the absolute value of the entry.)

  • The range to be range locked is entered as:

    nominal_value_in_range prefix units

    The prefix can be the same as specified for the nominal and MOD1 field of any instrument FSC.

  • Function | Allowed Values for nominal_value_in_range | Units
    Volts | -1000V to + 1000V | (V)

  • Default is no range locking.

MOD2

Allows specification of the guard connection. If 'G' is specified, the external guard connection becomes active. If nothing is entered the guard is internally shorted to low. The guard active mode is appropriate for low level voltages where noise could affect the response of the unit under test. Default is no guard connection.

MOD3

Specifies Digital Filter Reset.

Entry | DFR setting | # counts
F | FINE | 10
M | MEDIUM | 100 (default)
C | COARSE | 1000

The digital filter specification selects the number of samples that will be averaged to produce a single 5790A reading. The digital filter reset value selects the maximum deviation, in counts, allowed between any two readings in the sample window. If the reset value is exceeded, the window is flushed and the instrument begins sampling until the window is full. The ACMS FSC MOD3 field is not used when the 5790 FSC MOD3 field is "-F" (digital filter off).

MOD4

Not used.

CON

Not used.

Miscellaneous

  • No memory location is affected by the ACMS FSC.

Examples

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
  2.001  ACMS         100mA                                       G  F
  2.002  5790         100mA                                       SH E  N  2W
  3.001  ACMS                                                        C
  3.002  5790         1V             25P%          1MH            I1 F     2W
  4.001  ACMS         *


5800

Instrument FSC

Description

The 5800 FSC provides the means to control the following functions of the Fluke 5800A Oscilloscope Calibrator:

  • DC Voltage
  • AC Voltage (Sine, Square, Triangle, Leveled Sine, Positive and Negative Scope Square, Edge, Fast Edge, Time Mark, Pulse and Video waveforms)
  • Oscilloscope Input Impedance Measurement
  • Oscilloscope 50 Ω Impedance Overload Protection Measurement
  • Trigger Signal
The 5800 FSC may also be used to control a 5820A. This capability allows a 5800A based procedure to be executed without modification when a 5820A is configured.
If the 5800A is to be controlled via its serial port, do not use the PORT FSC port configuration special construction, [P9600,N,...], to set the baud rate, parity, etc. of the port used to control the 5800A. MET/CAL executes a "Test" function for each System Instrument prior to executing any procedure statements. Therefore, the settings of the port used to controlling the 5800A must be set correctly before a procedure is executed. If the 5800A is connected to a standard serial port (COM1, COM2, ..., COM16), select the "Ports" application in the Windows control panel to choose the proper settings. If the 5800A is connected to the 5800A or 5520A UUT port, select the proper settings for the UUT Serial Port from the front panel of the calibrator.

Functional Capability

DC Voltage | Amplitude
50 Ω term. | -6.599 V to 6.59 9V
1 MΩ term. | -130 V to 130 V
AC Voltage | Amplitude | Frequency
Scope Square Wave (zero based, positive and negative)
50 Ω term. | 1.0 mVpp to 6.599 Vpp | 10 Hz to 10 kHz
1 MΩ term. | 1.0 mVpp to 130 Vpp | 10 Hz to 10 kHz
DC Current1 | Amplitude
100 μA to 100 mA
AC Current1 | Amplitude
100 μA to 100 mA | 10 Hz to 10 kHz
Edge | Amplitude in a 1-(2.5)-5 seq ±10% | Frequency
50 Ω term. | 5 mVpp to 2.5 Vpp | 900 Hz to 11 MHz
w/Tunnel Diode Pulser
Drive Signal | 11 Vpp to 2.5 Vpp | 900 Hz to 11 MHz
Fast Edge2 | Amplitude | Frequency
50 Ω term. | 250 mVpp fixed | 900 Hz to 1 MHz
Leveled Sine | Amplitude | Frequency
50 Ω term. | 5 mVpp to 5.5 Vpp | 50 kHz to 600 MHz
5 mVpp to 3.5 Vpp | 50 kHz to 2.4 GHz2
Time Markers | Period
50 Ω term.
Spike | 18 ns to 5.5 s
Square | 7.5 ns to 5.5 s
20% Duty | 75 ns to 34.99 ms
Square | 1.8 ns to 17.9 ns
Sine | 450 ps to 17.9 ns2
Wavegen | Ampltidue | Frequency | Max AC + DC Offset
Sine, Square, and Triangle Waveforms (zero centered)
50 Ω term. | 1.8 mVpp to 10.9 mVpp | 10 Hz to 100 kHz | Vp + |Voff|≤12.5mVp
11 mVpp to 44.9 mVpp | 10 Hz to 100 kHz | Vp + |Voff|≤50.5mVp
45 mVpp to 109 mVpp | 10 Hz to 100 kHz | Vp + |Voff|≤125mVp
110 mVpp to 449 mVpp | 10 Hz to 100 kHz | Vp + |Voff|≤225mVp
0.45 Vpp to 1.09 Vpp | 10 Hz to 100 kHz | Vp + |Voff|≤1.25Vp
1.1 Vpp to 2.2 Vpp | 10 Hz to 100 kHz | Vp + |Voff|≤3.1 Vp
1 MΩ term. | 1.8 mVpp to 21.9 mVpp | 10 Hz to 100 kHz | Vp + |Voff|≤6 mVp
22 mVpp to 89.9 mVpp | 10 Hz to 100 kHz | Vp + |Voff|≤100 mVp
90 mVpp to 219 mVpp | 10 Hz to 100 kHz | Vp + |Voff|≤260 mVp
220 mVpp to 899 mVpp | 10 Hz to 100 kHz | Vp + |Voff|≤1000 mVp
0.9 Vpp to 6.59 Vpp | 10 Hz to 100 kHz | Vp + |Voff|≤6.6 Vp
6.6 Vpp to 55 Vpp | 10 Hz to 100 kHz | Vp + |Voff|≤50 Vp
Video | Amplitude | Line Marker
NTSC | -150 % to 150 % | 1 to 262 Odd or Even
-1.5 Vp to 1.5 Vp | 1 to 262 Odd or Even
-140 IRE to 140 IRE | 1 to 262 Odd or Even
PAL | -150 % to 150 % | 1 to 622
-1.5 Vp to 1.5 Vp | 1 to 622
PAL-M | -150 % to 150 % | 1 to 262 Odd or Even
-1.5 Vp to 1.5 Vp | 1 to 262 Odd or Even
-140 IRE to 140 IRE | 1 to 262 Odd or Even
SECAM | -150 % to 150 % | 1 to 622
-1.5 Vp to 1.5 Vp | 1 to 622
Pulse | Amplitude | Period | Pulse Width
Old Pulse Board
50 Ω term. | 10 mVpp, 25 mVpp, 100 mVpp, 250 mVpp, 1 Vpp, and 2.5 Vpp | 200 ns to 22 ms | 2 ns to 500 ns
New Pulse Board
50 Ω term.

15 mVpp, 60 mVpp, 150 mVpp, 600 mVpp, and 1.5 Vpp

 200 ns to 22 ms 400 ps to 500 ns
-10 ns to +30 ns skew variation2
UUT Input Impedance Measurement (MEAS Z)
50 Ω | 40 Ω to 60 Ω
1 MΩ | 500 kΩ to 1.5 MΩ
Capacitance | 5 pF to 50 pF
UUT 50 Ω Input Impedance Overload Protection Measurement (OVERLD):
DC | 5 V to 9 V
AC | 5 V to 9 V | 1 kHz
  1. 5800A/BW only
  2. 5800A/BW and 5800A-GHz only

Parameters

The following table describes the basic operating modes of the 5800A Oscilloscope Calibrator in terms of the FSC fields listed. Only the combinations of field quantities listed below are allowed.These mode names are also used in other places in this section to clarify the rules for each parameter of the 5800 FSC.

5800A Operating Modes

5800A Mode | 5800 NOMINAL | 5800 MOD1 | 5800 MOD3 1 | M5800 RANGE | M5800 NOMINAL | M5800 MOD1 | M5800 MOD3
DC Voltage (volt mode) | voltage | S6
AC Voltage (volt mode) | voltage | freq|per | S6
AC Voltage (pulse) | p-width2 | voltage | S6 | PER | period
p-width2 | voltage | S6 | PER | period | [skew | SK]
p-width | voltage | S6 | SKEW | skew | period | PR
period2 | voltage | S6 | PULSE | p-width
period2 | voltage | S6 | PULSE | p-width | [skew | SK]
period2 | voltage | S6 | SKEW | skew | p-width | PL
skew2 | voltage | S6 | PER | period | p-width | PL
skew | voltage | S6 | PULSE | p-width | period | PR
AC Voltage (wavegen) | voltage | freq|per | S6 | [offset]
AC Voltage (wavegen) | freq|per | voltage | S6 | [offset]
AC Voltage (time marks) | freq|per | S6
DC Current2 | current | S6
AC Current2 | current | freq|per | S6
freq|per | current | S6
Video percent| line marker S6 [ODD|EVEN]
voltage| IRE
Impedance Meas | res|cap | ZM
Overload Meas | voltage | [freq] | OM | LIMIT | time
  1. See MOD3 parameter for description of these specification codes and rules.
  2. 5800A/BW only
Period and pulse width (p-width) may be entered as a frequency in Hertz.
Blank entries in the above table are significant and must be blank. FSC field inter-dependencies not expressed in this table are listed under "Rules" for the appropriate parameter.

Units Symbols

Units Symbol | Name | Quantity
A | Amps | current
Ap | Amps peak | current
App | Amps peak to peak | current
F | Farads | capacitance
H | Hertz | frequency
IRE | IRE | video amplitude
LM | Line Marker | video line marker position
T | Time | period, pulse width, or skew
V | Volts | voltage or video amplitude
Vp | Volts peak | voltage
Vpp | Volts peak to peak | voltage
Z | Ohms | resistance
pct | percent | video amplitude

5800 FSC NOMINAL, MOD1, MOD2, and MOD3 Rules

5800A Mode | 5800 NOMINAL | 5800 MOD1 | 5800 MOD21 | 5800 MOD32
DC Voltage (VOLT) | V | S6
AC Voltage (VOLT) | V|Vp|Vpp | H|T | ZQ|ZN
H|T | V|Vpp | ZQ|ZN
AC Voltage (EDGE) | H|T | H|T | ED | S6
V|Vp|Vpp | V|Vpp | ED | S6
AC Voltage (FAST EDGE) | H|T | H|T | FE | S6
V|Vp|Vpp | V|Vpp | FE | S6
AC Voltage (LEVSINE) | H|T | H|T | LS | S6
V|Vp|Vpp | V|Vpp | LS | S6
AC Voltage (MARKER) | H|T | M1|M2|M3|M4 | S6
AC Voltage (WAVEGEN) | H|T | H|T | SI|SQ|TI | S6
V|Vp|Vpp | V|Vp|Vpp | SI|SQ|TI
AC Voltage (PULSE) | H|T | Vpp | PU | S6
DC Current3 (CURR) | A | S6
AC Current3 (CURR) | H|T | H|T | ZQ | S6
A|Ap|App | A|App | ZQ | S6
Video (VIDEO) | pct|Vp|IRE | LM | F1|F3 | S6
pct|Vp | LM | F2|F4 | S6
Impedance Meas (MEAS Z) | Z | ZM
F | ZM
Overload Meas (OVERLD) | V | OM
Vpp | H | OM
  1. See MOD2 parameter for description of these specification codes and rules.
  2. See MOD3 parameter for description of these specification codes and rules.
  3. 5800A/BW only.
Blank entries in the above table are significant and must be blank. FSC field inter-dependencies not expressed in this table are listed under "Rules" for the appropriate parameter.

RANGE

This field specifies the UUT range as described in the RANGE Field topic.

NOMINAL

This field specifies the starting Nominal value of the stimulus output or expected UUT reading for the test entered as:

[numeric][prefix]units symbol

or "*" to specify a reset.

Rules:

  1. When the NOMINAL field contains only units, the value is obtained from the memory register MEM.
  2. When the NOMINAL field contains only units and the MOD1 field is not blank, the MOD1 field must specify a value.

TOLERANCE

This field specifies the UUT tolerance as described in the TOLERANCE Field topic.

MOD1

This field specifies frequency, period, or voltage entered as:

[numeric][prefix]units symbol

Rules:

  1. When the MOD1 field contains only units, the value is obtained from memory register MEM. In this case the NOMINAL field MUST contain a value.

MOD2

This field specifies one of the following:

The waveform type for the voltage or specified in the NOMINAL or MOD1 field for AC Voltage.

blank | DC or not applicable
SI | Sine wave (Wavegen)
SQ | Square wave (Wavegen)
TI | Triangle wave (Wavegen)
ZQ | Positive square wave (AC Voltage)
ZN | Negative square wave (AC Voltage)
ED | Edge signal
FE | Fast Edge signal (requires 5800A-GHz Option)
LS | Leveled sine wave
M1 | Spike Marker signal
M2 | Square Marker signal
M3 | 20% Duty Cycle Square Marker signal
M4 | Sinusoid Marker signal
PU | Pulse wave
F1 | NTSC video signal
F2 | PAL video signal
F3 | PAL-M video signal
F4 | SECAM video signal

Rules:

  1. SI is inserted automatically in the MOD2 field for AC Voltage (i.e. the MOD1 field is not blank) if no MOD2 code is entered.
  2. ZQ is inserted automatically in the MOD2 field for AC Current. (i.e. the MOD1 field is not blank) if no MOD2 code is entered.
  3. The M5800 RANGE and NOMINAL field must specify the pulse wave period or frequency when the MOD2 field specifies PU and the NOMINAL field specifies the pulse width.
  4. The M5800 RANGE and NOMINAL field must specify the pulse width when the MOD2 field specifies PU and the NOMINAL field specifies the pulse wave period or frequency.
  5. The M5800 RANGE field must specify ODD or EVEN frame when the MOD2 field specifies F1 (NTSC video) or F3 (PAL-M video).

MOD3

This field specifies the calibrator output mode:

S6 | Default
ZM | UUT Input Impedance Measurement
blank | NA

Rules:

  1. S6 is inserted automatically in the MOD3 field when the MOD2 field specifies ZQ, ZN, ED, LS, PU, M1, M2, M3, M4, F1, F2, F3, or F4, and no MOD3 code is entered.
  2. The M5800 FSC RANGE and NOMINAL fields must specify the time limit when the MOD3 field specifies OM.

MOD4

This field specifies the type of test being performed as described in the MOD4 Field topic.

Additional Rules:

  1. The MOD4 field must specify N (Nominal Setup Test) when the MOD3 field specifies OM (Overload Measurement).
  2. N is inserted automatically in the MOD4 field when the MOD3 field specifies OM and no MOD3 code is entered.

CON

This field specifies the UUT connection.

2W | 2-wire
TD | Tunnel Diode Pulser Drive signal enabled
L | 50 Ω Termination
blank | 1 MΩ Termination

Rules:

  1. 2W is inserted automatically in the CON field when the MOD3 field does not specify SC or S6 and no CON field code is entered.
  2. The CON field may specify TD only when the MOD2 field specifies ED.
  3. The CON field may specify L only when the MOD3 field specifies S6.
  4. The CON field must specify L when the MOD2 field specifies LS, ED, or M1, M2, M3, M4, F1, F2, F3, or F4.
  5. L is inserted automatically in the CON field when the MOD2 field specifies LS, ED, or M1, M2, M3, M4, F1, F2, F3, or F4, and no CON field code is entered.
  6. The CON field must specify 2W when the MOD3 field specifies ZM or OM.
  7. The CON field must be blank when the NOMINAL or MOD1 field specifies current.

Use of Standard Memory Locations and Results Reporting

System memory locations MEM and MEM1 are used. For more information, refer to the Use of Standard Memory Registers topic.

Examples

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
# ----- Reset -----
  1.001  M5800        *
  1.002  5800         *                                                 S
# ----- DC Voltage -----
  1.003  5800   20    19.99mV        4%                              S6
# ----- AC Voltage (Positive Scope Square Wave) -----
  2.001  5800   400   350.0mV        50U           60H            ZQ S6
# ----- AC Voltage (Negative Scope Square Wave) -----
  3.001  5800         100Vpp                       1kH            ZN S6 S
# ----- AC Voltage (Frequency Test) -----
  3.002  5800   1000  800.0H         0.1% 0.1U     300mV          ZQ S6
# ----- Edge Signal (Scope Output) -----
  4.001  5800         0.5Vpp                       1MH            ED S6 S  L
# ----- Leveled Sine Wave -----
  4.002  5800         200mVpp                      50kH           LS S6 S  L
# ----- Spike Marker Signal -----
  4.003  M5800                                                             2T
  4.004  5800         1uT                                         M1 S6 S  L
  4.005  M5800        *
# ----- Square Marker Signal -----
  4.006  5800         1mT                                         M2 S6 S  L
# ----- 20% Duty Cycle Square Marker Signal -----
  4.007  5800         5uT                                         M3 S6 S  L
# ----- Sinusoid Marker Signal -----
  4.008  5800         2nT                                         M4 S6 S  L
# ----- Wavegen -----
  4.009  5800         5V                           1kH            SI S6 S
# ----- Wavegen w/DC Offset -----
  4.010  M5800                                     0.5Voff
  4.011  5800         1Vpp                         1kH            TI S6 S
# ----- Wavegen w/Duty Cycle Specified -----
  4.012  M5800                       35pct
  4.013  5800         1Vpp                         1kH            SQ S6 S
# ----- NTSC Video -----
  4.014  M5800  ODD
  4.015  5800         1Vp                          262LM          F1 S6 S  L
  4.016  M5800        *
# ----- PAL Video -----
  4.017  5800         50pct                        400LM          F2 S6 S  L
# ----- PAL-M Video -----
  4.018  M5800  EVEN
  4.019  5800         -140IRE                      1LM            F3 S6 S  L
  4.020  M5800        *
# ----- SECAM Video -----
  4.021  5800         -100pct                      622LM          F4 S6 S  L
# ----- Pulse Wave (Slew Pulse Width) -----
  4.022  M5800  PER   200nT
  4.023  5800         5.0nT                        1Vpp           PU S6 N  L
# ----- Pulse Wave (Slew Pulse Repetition Frequency) -----
  4.024  M5800  PULSE 10nT
  4.025  5800         1.00kH                       1Vpp           PU S6 N  L
  4.026  M5800        *
# ----- Impedance Measurement (50 Ohm) -----
  4.027  5800         50Z            1U                              ZM    2W
# ----- Impedance Measurement (1 MOhm) -----
  5.001  5800         1.000MZ        1U                              ZM    2W
# ----- Impedance Measurement (Capacitance) -----
  6.001  5800         10pF                                           ZM N  2W
# ----- 50 Ohm Input Impedance Overload -----
  6.002  M5800  LIMIT 10T
  6.003  5800         5V                                             OM N  2W
  6.004  EVAL   -e MEM == 0 : 50 Ohm overload protection trip not expected
  7.001  M5800  LIMIT 10T
  7.002  5800         7V                                             OM N  2W
  7.003  EVAL   -e MEM : 50 Ohm overload protection trip expected


M5800

Instrument Setup FSC

Description

The M5800 FSC provides the additional program functions for the Fluke 5800A Oscilloscope Calibrator which are not addressed by the 5800 FSC.

  • Time limit for UUT 50 Ohm input overload protection measurement.
  • Odd frame for NTSC or PAL-M video signals.
  • Channel selection for 5800A-5 Five Channel Output Option
  • Trigger output and rate

Parameters

5800/M5800 Rules for 5800A Pulse Mode
5800 NOMINAL | M5800 RANGE | M5800 NOMINAL | M5800 MOD1 | M5800 MOD3
pulse period | PULSE | pulse width |  |
pulse width | PER | pulse period |  |
5800/M5800 Rules for 5800A/BW Pulse Mode
5800 NOMINAL | M5800 RANGE | M5800 NOMINAL | M5800 MOD1 | M5800 MOD3
pulse period | PULSE | pulse width | [trigger skew | SK]
pulse period | SKEW | trigger skew | pulse width | PL
pulse width | PER | pulse period | [trigger skew | SK]
pulse width | SKEW | trigger skew | pulse period | PR
trigger skew | PER | pulse period | pulse width | PL
trigger skew | PULSE | pulse width | pulse period | PR

RANGE

This field specifies one of the following:

PULSE | Pulse Width
PER | Pulse Period
SKEW | Trigger Skew
LIMIT | Time Limit (Overload Measurement)
ODD | Odd Frame (NTSC or PAL-M video)
EVEN | Even Frame (NTSC or PAL-M video)
blank | field not applicable

Rules:

  1. The RANGE field may specify ODD or EVEN only when the 5800 FSC MOD2 field specifies F1 or F3.
  2. The RANGE field must specify ODD or EVEN when the 5800 FSC MOD2 field specifies F1 or F3.
  3. See table in Parameters section for pulse mode rules.

NOMINAL

This field specifies one of the following:

  • Pulse Width entered as: [numeric][prefix]T or H
  • Pulse Period entered as: [numeric][prefix]T
  • Pulse Repetition Frequency entered as: [numeric][prefix]H
  • Trigger Skew entered as: [numeric][prefix]T or H
  • Time Limit entered as: [numeric][prefix]T
  • "*" reset to default values
  • blank field not applicable

Rules:

  1. The NOMINAL field must specify the time limit when the RANGE field is LIMIT.
  2. The NOMINAL field must be blank when the RANGE field is ODD or EVEN.
  3. When the NOMINAL field contains only units, the value is taken from MEM.
  4. When the NOMINAL field specifies reset *, all other fields must be blank.
  5. See table in Parameters section for pulse mode rules.

TOLERANCE

This field is not used.

MOD1

This field specifies one of the following:

  • DC Offset entered as: [numeric][prefix]Voff
  • Pulse Width entered as: [numeric][prefix]T or H
  • Pulse Period entered as: [numeric][prefix]T
  • Pulse Repetition Frequency entered as: [numeric][prefix]H
  • Trigger Skew entered as: [numeric][prefix]T or H
  • blank field not applicable

Rules:

  1. When the MOD1 field contains only units, the value is obtained from memory register MEM. In this case the NOMINAL field MUST contain a value.
  2. The MOD1 field may specify DC offset only when AC Voltage mode is specified and the 5800 FSC MOD2 field specifies SI, SQ or TI.
  3. The MOD1 field must specify the pulse width when the MOD3 field specifies PL.
  4. The MOD1 field must be blank when the RANGE field specifies ODD, EVEN, or LIMIT.
  5. See table in Parameters section for pulse mode rules.

MOD2

This field selects the signal output channel when the 5800A-5 Five channel output option is installed.

C1 | Channel 1
C2 | Channel 2
C3 | Channel 3
C4 | Channel 4
C5 | Channel 5
blank |

MOD3

This field specifies one of the following:

PL | Pulse Width
PR | Pulse Period
SK | Trigger Skew
blank |

Rules:

  1. See table in Parameters section.

MOD4

This field is not used.

CON

This field controls the trigger output. The following codes require the 5800A-5 Five Channel Output Option:

blank | Trigger Output off
1T | Trigger Output on Channel 5, Normal mode
2T | Trigger Output on Channel 5, 1/10 of output rate
3T | Trigger Output on Channel 5, 1/100 of output rate
1T1 | Trigger Output on Channel 1, Normal mode
2T1 | Trigger Output on Channel 1, 1/10 of output rate
3T1 | Trigger Output on Channel 1, 1/100 of output rate
1T5 | Trigger Output on Channel 5, Normal mode
2T5 | Trigger Output on Channel 5, 1/10 of output rate
3T5 | Trigger Output on Channel 5, 1/100 of output rate

Rules:

M5800 FSC MOD2 and CON Field Rules
MOD2 | CON
blank | blank | 1T | 2T | 3T
C1 | blank | 1T5 | 2T5 | 3T5
C2 | C3 | C4 | blank | 1T1 | 2T1 | 3T1 | 1T5 | 2T5 | 3T5
C5 | blank | 1T1 | 2T1 | 3T1
  1. If MOD1 is not blank (i.e. skew is specified), the CON field must not be blank.
  2. A CON field specification of 1T, 2T, 3T, 1T1, 2T1, 3T1, 1T5, 2T5, and 3T5 is only applicable (is ignored otherwise) when the 5800 MOD2 field specifies ZQ, ZN, ED, MK, M1, M2, M3, and M4.

Examples

See 5800 FSC.


5820

Instrument FSC

Description

The 5820 FSC provides the means to control the following functions of the Fluke 5820A Oscilloscope Calibrator:

  • DC Voltage
  • AC Voltage (Sine, Square, Triangle, Leveled Sine, Positive and Negative Scope Square, Edge, Time Mark, Pulse and Video waveforms)
  • DC Current
  • AC Current
  • Oscilloscope Input Impedance Measurement
  • Oscilloscope 50 Ohm Impedance Overload Protection Measurement
  • DC Voltage Measurement
  • Trigger Signal
If the 5820A is to be controlled via its serial port, do not use the PORT FSC port configuration special construction, [P9600,N,...], to set the baud rate, parity, etc. of the port used to control the 5820A. MET/CAL executes a "Test" function for each System Instrument prior to executing any procedure statements. Therefore, the settings of the port used to controlling the 5820A must be set correctly before a procedure is executed. If the 5820A is connected to a standard serial port (COM1, COM2, ..., COM16), select the "Ports" application in the Windows control panel to choose the proper settings. If the 5820A is connected to the 5500A or 5520A UUT port, select the proper settings for the UUT Serial Port from the front panel of the calibrator.

Functional Capability

Function | Amplitude | Frequency | Misc.
DC Voltage
50 Ω term. | -6.599 V to 6.599 V
1 MΩ term. | -130 V to 130 V
AC Voltage
Scope Square Wave (zero based, positive and negative)
50 Ω term. | 1.0 mVpp to 6.599 Vpp | 10 Hz to 10 kHz
1 MΩ term. | 1.0 mVpp to 130 Vpp | 10 Hz to 10 kHz
DC Current
100 uA to 100 mA
AC Current
100 uA to 100 mA | 10 Hz to 100 kHz
Edge
50 Ω term. | 5 mVpp to 2.5 Vpp in a 1-(2.5)-5 seq +/-10% | 900 Hz to 11 MHz
w/Tunnel Diode Pulser Drive Signal | 11 Vpp to 2.5 Vpp | 900 Hz to 11 MHz
Leveled Sine
50 Ω term. | 5 mVpp to 5.5 Vpp | 50 kHz to 600 MHz
5 mVpp to 3.5 Vpp | 50 kHz to 2.4 GHz 1
Fast Edge 1
50 Ω term. | 250 mVpp fixed | 900 Hz to 1 MHz
Time Markers
50 Ω term. | Period
Spike | 18 ns to 5.5 s
Square | 7.5 ns to 5.5 s
20 % Duty Square | 75 ns to 34.99 ms
Sine | 1.8 ns to 17.9 ns
Spike | 450 ps to 17.9 ns 1
Wavegen
Sine, Square, and Triangle Waveforms (zero centered)
50 Ω term. | 1.8 mVpp to 10.9 mVpp | 10 Hz to 100 kHz | Vp + |Voff|≤12.5 mVp
11 mVpp to 44.9 mVpp | Vp + |Voff|≤50.5 mVp
45 mVpp to 109 mVpp | Vp + |Voff|≤125 mVp
110 mVpp to 449 mVpp | Vp + |Voff|≤225 mVp
0.45 Vpp to 1.09 Vpp | Vp + |Voff|≤1.25Vp
1.1 Vpp to 2.2 Vpp | Vp + |Voff|<≤3.1Vp
1 MΩ term. | 1.8 mVpp to 21.9 mVpp | 10 Hz to 100 kHz | Vp + |Voff|≤26mVp
22 mVpp to 89.9 mVpp | Vp + |Voff|≤100mVp
90 mVpp to 219 mVpp | Vp + |Voff|≤260mVp
220 mVpp to 899 mVpp | Vp + |Voff|≤1000mVp
0.9 Vpp to 6.59 Vpp | Vp + |Voff|≤6.6Vp
6.6 Vpp to 55 Vpp | Vp + |Voff|≤50Vp
Video | Line Marker
NTSC | -150 % to 150 % | 1 to 262 Odd or Even
-1.5 Vp to 1.5 Vp
-140IRE to 140IRE
PAL | -150 % to 150 % | 1 to 622
-1.5 Vp to 1.5 Vp
PAL-M | -150 % to 150 % | 1 to 262 Odd or Even
-1.5 Vp to 1.5 Vp
-140IRE to 140IRE
SECAM | -150 % to 150 % | 1 to 622
-1.5 Vp to 1.5 Vp
Pulse | Period | Pulse Width
50 Ω term. | 15 mVpp, 60 mVpp, | 200 ns to 22 ms | 400 ps to 500 ns
150 mVpp, 600 mVpp, and 1.5V pp | -10 ns to +30 ns skew variation 1
UUT Input Impedance Measurement (MEAS Z)
50 Ω | 40 Ω to 60 Ω
1 MΩ | 500 kΩ to 1.5 MΩ
Capacitance | 5 pF to 50 pF
UUT Voltage Measurement (MEAS V)
1 MΩ | -10 V to +10 V DC
UUT 50 Ω Input Impedance Overload Protection Measurement (OVERLD)
DC | 5 V to 9 V
AC | 5 V to 9 V | 1 kHz
  1. With 5800A-GHz option.

Parameters

The following table describes the basic operating modes of the 5820A Oscilloscope Calibrator in terms of the FSC fields listed. Only the combinations of field quantities listed below are allowed. These mode names are also used in other places in this section to clarify the rules for each parameter of the 5820 FSC.

Operating Modes

5820A Mode | 5820 NOMINAL | 5820 MOD1 | 5820 MOD3 1 | M5820 RANGE | M5820 NOMINAL | M5820 MOD1 | M5820 MOD3
DC Voltage (volt mode) | voltage | S6
AC Voltage (volt mode) | freq|per | S6
AC Voltage (pulse) | p-width 2 | voltage | S6 | PER | period
p-width 2 | PER | period | [skew | SK]
p-width | SKEW | skew | period | PR
period 2 | PULSE | p-width
period 2 | PULSE | p-width | [skew | SK]
period 2 | SKEW | skew | p-width | PL
skew 2 | PER | period | p-width | PL
skew | PULSE | p-width | period | PR
Note, period and pulse width (p-width) may be entered as a frequency in Hertz.
AC Voltage (wavegen) | voltage | freq|per | S6 | [offset]
freq|per | voltage
AC Voltage (time marks) | freq|per | S6
DC Current | current | S6
AC Current | current freq|per | freq|per current | S6
Video | percent| voltage| IRE | line marker | S6 | [ODD|EVEN]
Impedance Meas | res|cap | ZM
Voltage Meas | voltage | VM
Overload Meas | voltage | [freq] | OM | LIMIT | time
  1. See MOD3 parameter for description of these specification codes and rules.
Blank entries in the above table are significant and must be blank. FSC field inter-dependencies not expressed in this table are listed under "Rules" for the appropriate parameter.

Units Symbols

Units Symbol | Name | Quantity
A | Amps | current
Ap | Amps peak | current
App | Amps peak to peak | current
F | Farads | capacitance
H | Hertz | frequency
IRE | IRE | video amplitude
LM | Line Marker | video line marker position
T | Time | period, pulse width, or skew
V | Volts | voltage or video amplitude
Vp | Volts peak | voltage
Vpp | Volts peak to peak | voltage
Z | Ohms | resistance
pct | percent | video amplitude

5820 FSC NOMINAL, MOD1, MOD2, and MOD3 Rules

5820A Mode | 5820 NOMINAL | 5820 MOD1 | 5820 MOD2 1 | 5820 MOD3 2
DC Voltage (VOLT) | V | S6
AC Voltage (VOLT) | V|Vp|Vpp | H|T | ZQ|ZN | S6
H|T | V|Vpp
AC Voltage (EDGE) | V|Vp|Vpp | H|T | ED | S6
H|T | V|Vpp
AC Voltage (FAST EDGE) | V|Vp|Vpp | FE | S6 | S6
H|T
AC Voltage (LEVSINE) | V|Vp|Vpp | H|T | LS | S6
H|T | V|Vpp
AC Voltage (MARKER) | H|T | M1|M2|M3|M4 | S6
AC Voltage (WAVEGEN) | V|Vp|Vpp | H|T | SI|SQ|TI | S6
H|T | V|Vp|Vpp
AC Voltage (PULSE) | H|T | Vpp | PU | S6
DC Current (CURR) | A | S6
AC Current (CURR) | A|App | H|T | ZQ | S6
H|T | A|Ap|App
Video (VIDEO) | pct|Vp|IRE | LM | F1|F3 | S6
pct|Vp | F2|F4
Impedance Meas (MEAS Z) | Z | ZM
F
Voltage Meas (MEAS V) | V | VM
Overload Meas (OVERLD) | V | H | OM
Vpp
  1. See MOD2 parameter for description of these specification codes and rules.
  2. See MOD3 parameter for description of these specification codes and rules.
Blank entries in the above table are significant and must be blank. FSC field inter-dependencies not expressed in this table are listed under "Rules" for the appropriate parameter.

RANGE

This field specifies the UUT range as described in the RANGE Field topic.

NOMINAL

This field specifies the starting Nominal value of the stimulus output or expected UUT reading for the test entered as:

[numeric][prefix]units symbol

or "*" to specify a reset.

Rules:

  1. When the NOMINAL field contains only units, the value is obtained from the memory register MEM.
  2. When the NOMINAL field contains only units and the MOD1 field is not blank, the MOD1 field must specify a value.

TOLERANCE

This field specifies the UUT tolerance as described in the TOLERANCE Field topic.

MOD1

This field specifies frequency, period, or voltage entered as:

[numeric][prefix]units symbol

Rules:

  1. When the MOD1 field contains only units, the value is obtained from memory register MEM. In this case the NOMINAL field MUST contain a value.

MOD2

This field specifies one of the following:

The waveform type for the voltage or specified in the NOMINAL or MOD1 field for AC Voltage.

blank | DC or not applicable
SI | Sine wave (Wavegen)
SQ | Square wave (Wavegen)
TI | Triangle wave (Wavegen)
ZQ | Positive square wave (AC Voltage)
ZN | Negative square wave (AC Voltage)
ED | Edge signal
FE | Fast Edge signal (requires 5800A-GHz Option)
LS | Leveled sine wave
M1 | Spike Marker signal
M2 | Square Marker signal
M3 | 20% Duty Cycle Square Marker signal
M4 | Sinusoid Marker signal
PU | Pulse wave
F1 | NTSC video signal
F2 | PAL video signal
F3 | PAL-M video signal
F4 | SECAM video signal

Rules:

  1. SI is inserted automatically in the MOD2 field for AC Voltage (i.e. the MOD1 field is not blank) if no MOD2 code is entered.
  2. ZQ is inserted automatically in the MOD2 field for AC Current. (i.e. the MOD1 field is not blank) if no MOD2 code is entered.
  3. The M5820 RANGE and NOMINAL field must specify the pulse wave period or frequency when the MOD2 field specifies PU and the NOMINAL field specifies the pulse width.
  4. The M5820 RANGE and NOMINAL field must specify the pulse width when the MOD2 field specifies PU and the NOMINAL field specifies the pulse wave period or frequency.
  5. The M5820 RANGE field must specify ODD or EVEN frame when the MOD2 field specifies F1 (NTSC video) or F3 (PAL-M video).

MOD3

This field specifies the calibrator output mode:

S6 | Default
OM | UUT 50 Input Overload Protection Measurement
ZM | UUT Input Impedance Measurement
VM | UUT Voltage Measurement
blank | NA

Rules:

  1. S6 is inserted automatically in the MOD3 field when the MOD2 field specifies ZQ, ZN, ED, FE, LS, PU, M1, M2, M3, M4, F1, F2, F3, or F4, and no MOD3 code is entered.
  2. The M5800 FSC RANGE and NOMINAL fields must specify the time limit when the MOD3 field specifies OM.

MOD4

This field specifies the type of test being performed as described in the MOD4 Field topic.

Additional Rules:

  1. The MOD4 field must specify N (Nominal Setup Test) when the MOD3 field specifies OM (Overload Measurement).
  2. N is inserted automatically in the MOD4 field when the MOD3 field specifies OM and no MOD3 code is entered.

CON

This field specifies the UUT connection.

2W | 2-wire
TD | Tunnel Diode Pulser Drive signal enabled
L | 50 Ohm Termination
blank | 1 MOhm Termination

Rules:

  1. 2W is inserted automatically in the CON field when the MOD3 field does not specify SC or S6 and no CON field code is entered.
  2. The CON field may specify TD only when the MOD2 field specifies ED.
  3. The CON field may specify L only when the MOD3 field specifies S6.
  4. The CON field must specify L when the MOD2 field specifies LS, M1, M2, M3, M4, F1, F2, F3, or F4.
  5. The CON field must specify L or TD when the MOD2 field specifies ED.
  6. L is inserted automatically in the CON field when the MOD2 field specifies LS, ED, FE, M1, M2, M3, M4, F1, F2, F3, or F4, and no CON field code is entered.
  7. The CON field must specify 2W when the MOD3 field specifies ZM or OM.
  8. The CON field must be blank when the NOMINAL or MOD1 field specifies current.

Use of Standard Memory Locations and Results Reporting

System memory locations MEM and MEM1 are used. For more information, refer to the Use of Standard Memory Registers topic.

Examples

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
# ----- Reset -----
  1.001  M5820        *
  1.002  5820         *                                                 S
# ----- DC Voltage -----
  1.003  5820   20    19.99mV        4%                              S6
# ----- AC Voltage (Positive Scope Square Wave) -----
  2.001  5820   400   350.0mV        50U           60H            ZQ S6
# ----- AC Voltage (Negative Scope Square Wave) -----
  3.001  5820         100Vpp                       1kH            ZN S6 S
# ----- AC Voltage (Frequency Test) -----
  3.002  5820   1000  800.0H         0.1% 0.1U     300mV          ZQ S6
# ----- DC Current -----
  6.003  5820   2     1.000mA        4%                              S6
# ----- AC Current (Positive Scope Square Wave) -----
  7.001  5820   2     1.000mA        4%            60H            ZQ S6
# ----- AC Current (Negative Scope Square Wave)-----
  8.001  5820   2     1.000mA        4%            60H            ZN S6
# ----- Edge Signal (Scope Output) -----
  4.001  5820         0.5Vpp                       1MH            ED S6 S  L
# ----- Leveled Sine Wave -----
  4.002  5820         200mVpp                      50kH           LS S6 S  L
# ----- Spike Marker Signal -----
  4.003  M5820                                                             2T
  4.004  5820         1uT                                         M1 S6 S  L
  4.005  M5820        *
# ----- Square Marker Signal -----
  4.006  5820         1mT                                         M2 S6 S  L
# ----- 20% Duty Cycle Square Marker Signal -----
  4.007  5820         5uT                                         M3 S6 S  L
# ----- Sinusoid Marker Signal -----
  4.008  5820         2nT                                         M4 S6 S  L
# ----- Wavegen -----
  4.009  5820         5V                           1kH            SI S6 S
# ----- Wavegen w/DC Offset -----
  4.010  M5820                                     0.5Voff
  4.011  5820         1Vpp                         1kH            TI S6 S
# ----- NTSC Video -----
  4.012  M5820  ODD
  4.013  5820         1Vp                          262LM          F1 S6 S  L
  4.014  M5820        *
# ----- PAL Video -----
  4.015  5820         50pct                        400LM          F2 S6 S  L
# ----- PAL-M Video -----
  4.016  M5820  EVEN
  4.017  5820         -140IRE                      1LM            F3 S6 S  L
  4.018  M5820        *
# ----- SECAM Video -----
  4.019  5820         -100pct                      622LM          F4 S6 S  L
# ----- Pulse Wave (Slew Pulse Width) -----
  4.020  M5820  PER   200nT
  4.021  5820         5.0nT                        1.5Vpp         PU S6 N  L
# ----- Pulse Wave (Slew Pulse Repetition Frequency) -----
  4.022  M5820  PULSE 10nT
  4.023  5820         1.00kH                       1.5Vpp         PU S6 N  L
  4.024  M5820        *
# ----- Impedance Measurement (50 Ohm) -----
  4.025  5820         50Z            1U                              ZM    2W
# ----- Impedance Measurement (1 MOhm) -----
  5.001  5820         1.000MZ        1U                              ZM    2W
# ----- Impedance Measurement (Capacitance) -----
  6.001  5820         10pF                                           ZM N  2W
# ----- Voltage Measurement -----
  6.002  5820         2.5V           0.1U                            VM N  2W
# ----- 50 Ohm Input Impedance Overload -----
  6.003  M5820  LIMIT 10T
  6.004  5820         5V                                             OM N  2W
  6.005  EVAL   -e MEM == 0 : 50 Ohm overload protection trip not expected
  7.001  M5820  LIMIT 10T
  7.002  5820         7V                                             OM N  2W
  7.003  EVAL   -e MEM : 50 Ohm overload protection trip expected


M5820

Instrument Setup FSC

Description

The M5820 FSC provides the additional program functions for the Fluke 5820A Oscilloscope Calibrator which are not addressed by the 5820 FSC.

  • Time limit for UUT 50 Ohm input overload protection measurement.
  • Odd frame for NTSC or PAL-M video signals.
  • Channel selection for 5800A-5 Five Channel Output Option
  • Trigger output and rate

Parameters

5820/M5820 Rules for 5820A Pulse Mode

5820 NOMINAL | M5820 RANGE | M5820 NOMINAL | M5820 MOD1 | M5820 MOD3
pulse period | PULSE | pulse width | [trigger skew | SK]
pulse period | SKEW | trigger skew | pulse width | PL
pulse width | PER | pulse period | [trigger skew | SK]
pulse width | SKEW | trigger skew | pulse period | PR
trigger skew | PER | pulse period | pulse width | PL
trigger skew | PULSE | pulse width | pulse period | PR

RANGE

This field specifies one of the following:

PULSE | Pulse Width
PER | Pulse Period
SKEW | Trigger Skew
LIMIT | Time Limit (Overload Measurement)
ODD | Odd Frame (NTSC or PAL-M video)
EVEN | Even Frame (NTSC or PAL-M video)
blank | field not applicable

Rules:

  1. The RANGE field may specify ODD or EVEN only when the 5820 FSC MOD2 field specifies F1 or F3.
  2. The RANGE field must specify ODD or EVEN when the 5820 FSC MOD2 field specifies F1 or F3.
  3. See table in "PARAMETERS" section for pulse mode rules.

NOMINAL

This field specifies one of the following:

  • Pulse Width entered as: [numeric][prefix]T or H
  • Pulse Period entered as: [numeric][prefix]T
  • Pulse Repetition Frequency entered as: [numeric][prefix]H
  • Trigger Skew entered as: [numeric][prefix]T or H
  • Time Limit entered as: [numeric][prefix]T
  • "*" reset to default values
  • blank field not applicable

Rules:

  1. The NOMINAL field must specify the time limit when the RANGE field is LIMIT.
  2. The NOMINAL field must be blank when the RANGE field is ODD or EVEN.
  3. When the NOMINAL field contains only units, the value is taken from MEM.
  4. When the NOMINAL field specifies reset *, all other fields must be blank.
  5. See table in "PARAMETERS" section for pulse mode rules.

TOLERANCE

This field is not used.

MOD1

This field specifies one of the following:

  • DC Offset entered as: [numeric][prefix]Voff
  • Pulse Width entered as: [numeric][prefix]T or H
  • Pulse Period entered as: [numeric][prefix]T
  • Pulse Repetition Frequency entered as: [numeric][prefix]H
  • Trigger Skew entered as: [numeric][prefix]T or H
  • blank field not applicable

Rules:

  1. When the MOD1 field contains only units, the value is obtained from memory register MEM. In this case the NOMINAL field MUST contain a value.
  2. The MOD1 field may specify DC offset only when AC Voltage mode is specified and the 5820 FSC MOD2 field specifies SI, SQ or TI.
  3. The MOD1 field must specify the pulse width when the MOD3 field specifies PL.
  4. The MOD1 field must be blank when the RANGE field specifies ODD, EVEN, or LIMIT.
  5. See table in "PARAMETERS" section for pulse mode rules.

MOD2

This field selects the signal output channel when the 5800A-5

Five channel output option is installed.

C1 | Channel 1
C2 | Channel 2
C3 | Channel 3
C4 | Channel 4
C5 | Channel 5
blank |

MOD3

This field specifies one of the following:

PL | Pulse Width
PR | Pulse Period
SK | Trigger Skew
blank |

Rules:

  1. See table in "PARAMETERS" section.

MOD4

This field is not used.

CON

This field controls the trigger output. The following codes require the 5800A-5 Five Channel Output Option:

blank | Trigger Output off
1T | Trigger Output on Channel 5, Normal mode
2T | Trigger Output on Channel 5, 1/10 of output rate
3T | Trigger Output on Channel 5, 1/100 of output rate
1T1 | Trigger Output on Channel 1, Normal mode
2T1 | Trigger Output on Channel 1, 1/10 of output rate
3T1 | Trigger Output on Channel 1, 1/100 of output rate
1T5 | Trigger Output on Channel 5, Normal mode
2T5 | Trigger Output on Channel 5, 1/10 of output rate
3T5 | Trigger Output on Channel 5, 1/100 of output rate

Rules:

M5820 FSC MOD2 and CON Field Rules

MOD2 | CON
blank | blank | 1T | 2T | 3T
C1 | blank | 1T5 | 2T5 | 3T5
C2 | C3 | C4 | blank | 1T1 | 2T1 | 3T1 | 1T5 | 2T5 | 3T5
C5 | blank | 1T1 | 2T1 | 3T1
  1. If MOD1 is not blank (i.e. skew is specified), the CON field must not be blank.
  2. A CON field specification of 1T, 2T, 3T, 1T1, 2T1, 3T1, 1T5, 2T5, and 3T5 is only applicable (is ignored otherwise) when the 5820 MOD2 field specifies ZQ, ZN, ED, MK, M1, M2, M3, and M4.

Examples

See 5820 FSC


6060

Instrument FSC

Description

The 6060 FSC programs the frequency and amplitude of the Fluke or Gigatronics 6060A, 6060B, 6061A, 6062A, 6080A 1, or 6082A 1 RF Signal Generators. The M606 FSC may be used to program the modulation frequency and AM depth or FM deviation.

  1. The 6080A and 6082A must be in 6060 emulation mode in order to be programmed using the 6060 FSC.

Functional Capability

Parameters

The 6060 FSC programs the 6060A, 6060B, 6061A, 6062A, 6080A, and 6082A which all have different frequency ranges. You have to verify the capability of the instrument, which is actually in the system against the value specified. If you violate the limitations of the generator, you will get an error message while executing the procedure.

Frequency

6060A: 100 kHz to 1050 MHz, 952.3809 ps to 10 µs

6060B: 10 kHz to 1050 MHz, 952.3809 ps to 100 µs

6061A: 10 kHz to 1050 MHz, 952.3809 ps to 100 µs

6062A: 100 kHz to 2100 MHz, 476.1905 ps to 10 µs

6080A: 10 kHz to 1056 MHz, 946.9697 ps to 100 µs

6081A: 100 kHz to 2100 MHz 1, 476.1905 ps 1 to 10 µs

  1. Maximum frequency of the 6082A is limited to that of the 6062A.

Amplitude

0.1 μV to 1 V

0.283 μVpp to 2.82 Vpp

-127 dBm to +13 dBm

RANGE

This field specifies the UUT range as described in the RANGE Field topic.

NOMINAL

This field specifies the frequency, period, or amplitude of the output signal, or a reset. The 6060 FSC can contain frequency or period information in the NOMINAL field and amplitude information in the MOD1 field or vice-versa. The order in which this information is provided determines which information is contained in either field.

  • Frequency entered as: [numeric][prefix]H
  • Period entered as: [numeric][prefix]T
  • Voltage (RMS) entered as: [numeric][prefix]V
  • Voltage (peak-to-peak) entered as:[numeric][prefix]Vpp
  • dBm entered as: [numeric][prefix]D
  • Reset entered as *.

Rules:

  1. When the NOMINAL field specifies the frequency or period, the MOD1 field must specify the amplitude.
  2. When the NOMINAL field specifies the amplitude, the MOD1 field must specify the frequency of period.
  3. When the NOMINAL field contains only units the value is taken from MEM.

TOLERANCE

This field specifies the UUT tolerance as described in the TOLERANCE Field topic.

MOD1

  • Voltage (RMS) entered as: [numeric][prefix]V
  • Voltage (peak-to-peak) entered as: [numeric][prefix]Vpp
  • dBm entered as: [numeric][prefix]D
  • Frequency entered as: [numeric][prefix]H
  • Period entered as: [numeric][prefix]T

Rules:

  1. When the MOD1 field specifies the amplitude, the NOMINAL field must specify the frequency of period.
  2. When the MOD1 field specifies the frequency or period, the NOMINAL field must specify the amplitude.
  3. When the MOD1 field contains only units the value is taken from MEM.

MOD2

This field specifies whether "/div" is include in after the value in the automatic range message.

-D | "/div" is not included
blank | "/div" is included if ASK+ D is in effect

Rules:

  1. The MOD2 field is automatically set to -D for a Setup Test.

MOD3

This field is not used.

MOD4

This field specifies the type of test being performed as described in the MOD4 Field topic.

CON

This field is not used. The signal generator always expects a 50 Ohm termination.

Use of Standard Memory Locations and Results Reporting

System memory locations MEM and MEM1 are used. For more information, refer to the Use of Standard Memory Registers topic.

Examples

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
  1.001  ASK-                                                              W
  1.002  ASK+     D
# -----  Reset  -----
  1.003  6060         *                                                 S
  1.004  6060   A     -127D          1U            100kH          -D
  2.001  6060   1     0.1uV          1%            1050MH         -D
  3.001  6060   0.5   0.38uVpp       1/            100kH
  4.001  6060   A     D              1U            100kH          -D
  5.001  6060         uV             1%            100kH          -D
  6.001  6060   50    10uT           1% 1/ 1U      -127D
  7.001  6060   0.2   1nT            1% 1/ 1U      1Vpp
# -----  Oscilloscope Bandwidth Testing  -----
#
# Line 8.001 enables the automatic range and adjustment messages with the
# "/div" modifier.
# Line 8.002 instructs the operator to perform the proper connection.
# Line 8.003 generates the following range message:
#     Set UUT to 10us/div.
# Line 8.004 sets the MEM2 string register to "Channel 1".
# Line 8.005 generates the following automatic range and adjustment messages:
#     Set UUT Channel 1 to 20mV/div.
#     Adjust stimulus for a UUT reading of 6 divisions.
# Line 8.006 disables automatic adjustment messages.
# Line 8.007 specifies a message to be displayed upon execution of line 8.008.
# Line 8.008 sets the generator to the final amplitude from line 8.005 and a
# starting frequency of 5 MHz. The message specified on line 8.007 is then
# displayed which instructs the operator to slew the frequency until the
# amplitude displayed on the UUT is 3dB (4.2 div.) down from the original
# peak-to-peak amplitude of 6 divisions. Note the tolerance is negative to
# reflect that the bandwidth should be more than the nominal value (creating
# a negative error).
#
  8.001  ASK+   R D   N
  8.002  DISP         Connect the 6060B to the UUT Channel1
  8.003  RNG          1uT
  8.004  MEM2         =Channel 1
  8.005  6060   20    120mVpp                      100kH                N
  8.006  ASK-         N
  8.007  MESS         Adjust stimulus for a UUT reading of 4.2 divisions.
  8.008  6060         5MH            -50%          mVpp           -D
  9.001  MESS


M606

Instrument Setup FSC

Description

The M606 FSC provides the additional program functions for the Fluke 6060A, 6060B, 6061A or 6062A Synthesized Signal Generators, which are not addressed by the 6060 FSC. These functions are

  • Modulation Frequency
  • AM Depth
  • FM Deviation

RANGE

This field is not used.

NOMINAL

The Nominal field specifies the Modulation Frequency or a reset.

  • Modulation Frequency entered as [numeric][prefix]H or T.
  • Reset entered as *.

Rules:

  1. Allowed values are 400Hz or 1000Hz.
  2. If just nominal units are entered, the nominal value will be that of the content of memory register MEM plus the units specified.
  3. An asterisk ('*') in the Nominal field resets all previous settings created with the M606 FSC.

TOLERANCE

This field is not used.

MOD1

The MOD1 field specifies the AM Depth or FM Deviation.

  • AM Depth entered as numeric%.
  • FM Deviation entered as numeric[prefix]H or T.

Rules:

  1. AM Depth limits are 0 to 90%.
  2. FM Deviation limits depend upon the carrier and modulation frequency as shown in the table below:
Carrier Frequency | FM Deviation (lesser of)
10 kHz to 0.4 MHz | 100 Hz to 99.9 kHz and (1000 x fo -100) / 3
0.4 MHz to 245 MHz | 100 Hz to 99.9 kHz and (2 x fm x (fo + 800))
245 MHZ to 1050 MHz | 100 Hz to 99.9 kHz and 2 x fm x fo
fo = Carrier Frequency fm = Modulation Frequency

MOD2

This field is not used.

MOD3

This field is not used.

MOD4

This field is not used.

CON

This field is not used.

Miscellaneous

  • The MET/CAL Editor cannot always check the correctness of the M606 entry with the 6060 FSC entries that follow. If the combination of parameters are not valid, an error message will occur when the procedure is executed. Procedures using the M606 FSC should be carefully tested.
  • The Pulse Modulation capability of the 6062A is not supported in MET/CAL calibration software.

Examples

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
# AM Modulation
  1.001  M606         *
  1.002  M606         400H                         0%
  1.003  6060   10    0D             1U            10MH
  2.001  M606         *
  2.002  M606         1000H                        90%
  2.003  6060   10    0D             1U            10MH
# FM Modulation
  3.001  M606         *
  3.002  M606         400H                         100H
  3.003  6060   10    0D             0.11U         200kH
  4.001  M606         *
  4.002  M606         1000H                        99.9kH
  4.003  6060   10    0D             0.1U          1000MH


6100

Instrument FSC

Description

The 6100 FSC controls the Fluke 6100A Electrical Power Standard Master unit and up to three Fluke 6101A Electrical Power Standard Auxiliary Units.

Parameters

An NVI FSC statement consists of one or more parameters. A parameter consists of a name and a value. Each parameter must be separated by a semicolon and/or one or more spaces. A single NVI FSC statement can encompass more than one physical line as long as the line numbers are the same. However each parameter name and its value must occur on one line. A single line can accommodate up to 256 characters including the statement number and FSC. Note that characters above ASCII 128 count as 2 characters.

Syntax:

parameter[separatorparameter]

parameter::= [parameter_prefix]parameter_name[[sp]=[sp]parameter_value]

separator::= ;[sp] | sp

parameter_prefix ::=+ | @

sp::= one or more spaces

parameter_name::= see the Parameter Names section

parameter_value::=dimensionless number | dimensioned number | discrete_list

dimensionless number::=NRf

dimensioned number::=NRf[sp][prefix]units

discrete_list::=see the Parameter Names section

prefix::=y | z | a | f | p | n | u | m | k | M | G | T | P | E | Z | Y

Definitions:

|
Denotes "or" (i.e. A | B is A or B)
[ ]
Denotes an optional syntax element, except in examples. In examples [ ] enclose a special construction.
+
Designates the parameter as the Evaluation Quantity
@
Designates the parameter as the Modifier Quantity

Rules:

  1. One and only one parameter must be designated as the Evaluation Quantity value in a 6100 Setup (default) statement.
  2. When a 6100 statement is executed, the value of the Evaluation Quantity is copied to memory register MEM1 in base units.
    3. For Energy Counting, the reading is returned in memory register MEM.

    Example:

    1.001 6100 +L1IAC = 100 mA; L1IRange = 250 mA; Frequency = 60 Hz

    After the 6100 statement is executed the value of MEM1 is 100.

  3. At most one parameter may be designated as the Modifier Quantity in a 6100 Setup (default) statement.
  4. Parameter values may be taken from a MET/CAL memory register using a special construction.

Example: Setup 6100A 'V' channel to 100 V, 'I' channel to 5 A

  1.001  6100         L1VRange = 168 V; L1IRange = 5 A
  1.001  6100         L1VAC = 100 V; L1IAC = 5 A
  1.001  6100         +L1Power = 500 W; Freq = 60 Hz

or

  1.001  6100         L1VAC    = 100 V  L1IAC = 5 A
  1.001  6100         +L1Power = 500 W  Freq  = 60 Hz

or

  1.001  6100         Freq     = 60Hz
  1.001  6100         L1VRange = 168V
  1.001  6100         L1VAC    = 100V
  1.001  6100         L1IRange = 5A
  1.001  6100         L1IAC    = 5A
  1.001  6100         +L1Power = 500W

Parameter Names

Parameter names consist of single words or compound words.Each word in a parameter name can be entered in long form (as shown below), or in short form.The short form is the first 4 characters of the long form, with the following exceptions:

  1. If the long form is greater than four characters, and the last character or the short form is a vowel, the short form is three characters.
  2. If the long form is four characters or less, the short form is the long form even if it ends in a vowel.

The following abbreviations are used in the parameter names and definitions below.

  • ph (phase) L1 | L2 | L3 | N
  • ch(channel) V | I

Action Parameters

  • Apply
  • Local
  • Measure (Energy Counting only)
  • Operate
  • Read (Energy Counting only)
  • Reset
  • Setup
  • Standby

System Global Parameters

  • Frequency
  • OutputROscillator
  • OutputRampMode
  • OutputSense
  • ReferenceOutput
  • SetupReset

Energy Counting Parameters

  • Channel
  • Energy
  • EnergyMode
  • Error
  • GatingPullupResistance
  • GatingSignalLevel
  • GatingSignalType
  • MaintainVoltage
  • OutputConstant
  • PulseCounts
  • ReferenceConstant
  • ReferenceInputFilter
  • ReferencePullupResistance
  • ReferenceSource
  • Registration
  • TestDuration
  • TestPulseSource
  • UseInternalPullup
  • UUT_Constant
  • UUT_InputFilter
  • UUT_PullupResistance
  • UUT_Source
  • WarmupDuration
  • WarmupPulseSource

Phase Specific / Channel Global Parameters

  • phPower
  • phPowerFactor

Phase Specific / I Channel Global Parameters

  • phICoil
  • phIUUTCurrentClamp
  • phIUUTInputCouping

DC Mode Parameters

  • phchRange
  • phchDC
  • phchFluctuateDC

AC Mode Parameters

  • phchRange
  • phchAC
  • phchPhase
  • phchOffset
  • phIBandwidth

-- Flicker --

  • phchFlickerDepth
  • phchFlickerFrequency
  • phchFlickerShape
  • phchFlickerDuty
  • phchFlickerPst

-- Dips and Swells --

  • phchDipChangeTo
  • phchDipRampIn
  • phchDipPeriod
  • phchDipRampOut
  • phchDipEndDelay
  • phchDipTriggerInput
  • phchDipTriggerHoldOff
  • phchDipTriggerODelay

Harmonic Mode Parameters

  • VoltageHarmonicUnits
  • CurrentHarmonicUnits
  • phchRange
  • phchRMSAmplitude
  • phchAmplitudeHarmonicn, n = 1 to 100
  • phchPhaseHarmonicn, n = 1 to 100
  • phchOffset
  • phIBandwidth

Fluctuating harmonics

  • phchFluctuateHarmonicn, n = 1 to 100
  • phchFluctuationDepth
  • phchFluctuationFrequency
  • phchFluctuationShape
  • phchFluctuationDuty

Interharmonics

  • phchIHarmonicAmplitudeA
  • phchIHarmonicFrequencyA
  • phchIHarmonicAmplitudeB
  • phchIHarmonicFrequencyB

Flicker

  • phchFlickerDepth
  • phchFlickerFrequency
  • phchFlickerShape
  • phchFlickerDuty
  • phchFlickerPst

Dips and Swells

  • phchDipChangeTo
  • phchDipRampIn
  • phchDipPeriod
  • phchDipRampOut
  • phchDipEndDelay
  • phchDipTriggerInput
  • phchDipTriggerHoldOff
  • phchDipTriggerODelay

Parameter Definitions and Values

phchAC

This parameter specifies an AC signal. This is accomplished by setting the RMS value to the value specified and turning and harmonics 2 through 100 off.

Syntax:

phchAC[sp]=[sp]dim quan

dim quan ::= value[sp][prefix]units

ph ::= L1 | L2 | L3 | N

ch ::= V | I

value ::= numeric value

units ::= V | A

Rules:

  1. When phVAC is specified the voltage channels are set to "Absolute RMS"
  2. When phIAC is specified the current channels are set to "Absolute RMS"
  3. See "AC Mode Parameters" above for a list of other parameters that are allowed for the phase and channel specified.

Examples:

L1VAC = 110 V

L3IAC = [M5] mA

phchAmplitudeHarmonicn

This parameter specifies the amplitude of a harmonic.

Syntax:

phchAmplitudeHarmonicn[sp]=[sp]dim quan

dim quan ::= value[sp][prefix]units

ph ::= L1 | L2 | L3 | N

ch ::= V | I

n ::= 1..100

value ::= numeric value

units ::= V | A | % | dB

Rules:

  1. When units are dB or %, prefix is not allowed.
  2. phVAmplitudeHarmonicn, 2 - 100 and offset for all phases must have the same units.

  3. phIAmplitudeHarmonicn, 2 - 100 and offset for all phases must have the same units.

    Voltage Channel
    VoltHarmUnit | phVRMSAmpl | phVAmplHarm1 | phVAmplHarm2-100 & phVOffset
    ABS | not allowed | volts (V) | volts (V)
    PRMS | volts (V) | not allowed | percent (%)
    PFund | not allowed | volts (V) | percent (%)
    dBDown | not allowed | volts (V) | decibels (dB)
    Current Channel (current)
    CurrHarmUnit | phVRMSAmpl | phVAmplHarm1 | phVAmplHarm2-100 & phIOffset
    ABS | not allowed | amps (A) | amps (A)
    PRMS | amps (A) | not allowed | percent (%)
    PFund | not allowed | amps (A) | percent (%)
    dBDown | not allowed | amps (A) | decibels (dB)
    Current Channel (voltage)
    CurrHarmUnit | phVRMSAmpl | phVAmplHarm1 | phVAmplHarm2-100 & phIOffset
    ABS | not allowed | volts (V) | volts (V)
    PRMS | volts (V) | not allowed | percent (%)
    PFund | not allowed | volts (V) | percent (%)
    dBDown | not allowed | volts (V) | decibels (dB)

  4. See "Harmonics Mode Parameters" above for a list of other parameters that are allowed for the phase and channel specified.

phchDC

This parameter sets the specified phase and channel to output a DC signal. This accomplished as follows:

  1. Clear all harmonics on the specified phase and channel.
  2. Set harmonic 1 (fundamental) amplitude to zero.
  3. Set harmonic 0 (DC Offset) to the specified value.

Syntax

phchDC[sp]=[sp]dim quan

dim quan ::= value[sp][prefix]units

ph ::= L1 | L2 | L3 | N

ch ::= V | I

value ::= numeric value

units ::= V | A

Rules

  1. When phVDC is specified the voltage channels are set to "Absolute RMS"
  2. When phIDC is specified the current channels are set to "Absolute RMS"
  3. See "DC Mode Parameters" above for a list of other parameters that are allowed for the phase and channel specified.

Examples

L1VDC = 10 V

NIDC = [MEM] mA

phchDipChangeTo

This parameter sets the Dips and Swells "Change To" value.

Syntax:

phchDipChangeTo[sp]=[sp]percent quan

ph ::= L1 | L2 | L3 | N

ch::= V | I

value ::= numeric value

Rules:

  1. See "Harmonics Mode Parameters" above for a list of other parameters that are allowed for the phase and channel specified.

Examples:

L1VDipChangeTo = 10 %

phchDipEndDelay

phchDipPeriod

phchDipRampIn

phchDipRampOut

These parameters set the Dips and Swells End Delay, Period, Ramp In, and Ramp Out values.

Syntax:

phchDipEndDelay[sp]=[sp]dim quan

phchDipPeriod[sp]=[sp]dim quan

phchDipRampIn[sp]=[sp]dim quan

phchDipRampOut[sp]=[sp]dim quan

dim quan ::= value[sp][prefix]units

ph::= L1 | L2 | L3 | N

ch::= V | I

value::= numeric value

units::= s | c (cycles)

Rules:

  • When units ::= c, prefix is not allowed.
  • See "Harmonics Mode Parameters" above for a list of other parameters that are allowed for the phase and channel specified.

Examples:

L1VDipEndDelay = 10 ms

L1VDipEndDelay = 3 c

L1VDipPeriod = 10 ms

L1VDipPeriod = 3 c

L1VDipRampIn = 10 ms

L1VDipRampIn = 3 c

L1VDipRampOut = 10 ms

L1VDipRampOut = 3 c

phchDipTriggerHoldOff

This parameter sets the Dips and Swells "Start (Trig Input)" value.

Syntax:

phchDipTriggerHoldOff[sp]=[sp]dim quan

dim quan::=value[sp][prefix]units

ph ::=L1 | L2 | L3 | N

ch ::=V | I

value ::=numeric value

units ::=deg | s | c (cycles)

Rules:

  1. When units ::= c, prefix is not allowed.
  2. See "Harmonics Mode Parameters" above for a list of other parameters that are allowed for the phase and channel specified.

Examples:

L1VDipTriggerHoldOff = 10 ms

L1VDipTriggerHoldOff = 3 c

L1VDipTriggerHoldOff = 10 deg

phchDipTriggerInput

This parameter sets the trigger used to determine the event that starts the dip or swell.

Syntax:

phchDipTriggerInput[sp]=[sp]value

ph ::=L1 | L2 | L3 | N

ch ::=V | I

value ::=Free | EOne | ERepeat

Free
Free running dips/swells
EOne
One dip/swell trigger from an external source
ERepeat
Continuous dips/swells trigger from an external source.

Rules:

  1. See "Harmonics Mode Parameters" above for a list of other parameters that are allowed for the phase and channel specified.

Examples:

L1VDipTriggerInput = ERep

phchDipTriggerODelay

This parameter sets the delay before the output trigger is generated, following the completion of a dip or swell.

Syntax:

phchDipTriggerODelay[sp]=[sp]value

ph ::=L1 | L2 | L3 | N

ch ::=V | I

value ::=numeric value

units ::=s | c (cycles)

Rules:

  1. When units ::= c, prefix is not allowed.
  2. See "Harmonics Mode Parameters" above for a list of other parameters that are allowed for the phase and channel specified.

Examples:

L1VDipTriggerODelay = 10 ms

L1VDipTriggerODelay = 3 c

phchFlickerDepth

This parameter sets the flicker modulation depth expressed as a percentage of the voltage waveform RMS amplitude.

Syntax:

phchFlickerDepth[sp]=[sp]percent quan

percent quan ::= value[sp][prefix]%

ph ::=L1 | L2 | L3 | N

ch ::=V | I

value ::=numeric value

Rules:

  1. See "Harmonics Mode Parameters" above for a list of other parameters that are allowed for the phase and channel specified.

Examples:

L1VFlickerDepth = 10 %

phchFlickerDuty

This parameter sets the flicker duty cycle for rectangular modulation.

Syntax:

phchFlickerDuty[sp]=[sp]percent quan

percent quan ::= value[sp][prefix]%

ph ::=L1 | L2 | L3 | N

ch ::=V | I

value ::=numeric value

Rules:

  1. See "Harmonics Mode Parameters" above for a list of other parameters that are allowed for the phase and channel specified.

Examples:

L1VFlickerDuty = 10 %

phchFlickerFrequency

This parameter sets the flicker modulation frequency.

Syntax:

phchFlickerFrequency[sp]=[sp]dim quan

dim quan = value[sp][prefix]Hz

ph ::=L1 | L2 | L3 | N

ch ::=V | I

value ::=numeric value

Rules:

  1. See "Harmonics Mode Parameters" above for a list of other parameters that are allowed for the phase and channel specified.

Examples:

L1VFlickerFrequency = 1 kHz

phchFlickerPst

This parameter is used to query the flicker perception level, short term, computed by the 6100A.

Syntax:

phchFlickerPst[sp]=[sp]value

ph ::=L1 | L2 | L3 | N

ch ::=V | I

value ::=numeric value

Rules:

  1. Since Pst is a "query only" parameter, specifying this parameter is only useful when it is designated as the Evaluation Quantity.
  2. See "Harmonics Mode Parameters" above for a list of other parameters that are allowed for the phase and channel specified.

Examples:

+L1VFlickerPst = 1.00

phchFlickerShape

This parameter sets the flicker modulation shape.

Syntax:

phchFlickerShape[sp]=[sp]value

ch ::=V | I

value ::= Rect | Rectangle | Rectangular | Sin | Sine | Sinusoid | Sinusodial | Squ | Square

Rect
Sets the modulation waveform to be rectangular.
Sin
Sets the modulation waveform to be sinusoidal.
Squ
Sets the modulation waveform to be square.

Rules:

  1. See "Harmonics Mode Parameters" above for a list of other parameters that are allowed for the phase and channel specified.

Examples:

L1VFlickerShape = Square

phchFluctuateDC

This parameter turns on/off DC fluctuation.

Syntax:

phchFluctuateDC[sp]=[sp]value

ph ::=L1 | L2 | L3 | N

ch ::=V | I

value ::=On | Off

Examples:

L1VFluctuateDC = On

phchFluctuateHarmonicn

This parameter turns on/off the fluctuation of harmonic n. oscillator signal.\

Syntax:

phchFluctuateHarmonicn[sp]=[sp]value

ph ::= L1 | L2 | L3 | N

ch ::=V | I

n ::=1..100

value ::=On | Off

Examples:

L1VFluctuateHarmonic9 = On

phchFluctuationDepth

This parameter sets the fluctuating harmonics modulation depth expressed as a percentage of the voltage waveform RMS amplitude.

Syntax:

phchFluctuationDepth[sp]=[sp]percent quan

percent quan ::= value[sp][prefix]%

ph ::=L1 | L2 | L3 | N

ch ::=V | I

value ::=numeric value

Rules:

  1. See "Harmonics Mode Parameters" above for a list of other parameters that are allowed for the phase and channel specified.

Examples:

L1VFluctuationDepth = 10 %

phchFluctuationFrequency

This parameter sets the fluctuating harmonics modulation frequency.

Syntax:

phchFluctuationFrequency[sp]=[sp]value

ph ::=L1 | L2 | L3 | N

ch ::=V | I

value ::=numeric value

Rules:

  1. See "Harmonics Mode Parameters" above for a list of other parameters that are allowed for the phase and channel specified.

Examples:

L1VFluctuationFrequency = 1 kHz

phchFluctuationShape

This parameter sets the fluctuating harmonics modulation shape.

Syntax:

phchFluctuationShape[sp]=[sp]value

ch ::=V | I

value ::=Rect | Rectangle | Rectangular | Sin | Sine | Sinusoid | Sinusodial | Squ | Square

Rect
Sets the modulation waveform to be rectangular.
Sin
Sets the modulation waveform to be sinusoidal.
Squ
Sets the modulation waveform to be square.

Rules:

  1. See "Harmonics Mode Parameters" above for a list of other parameters that are allowed for the phase and channel specified.

Examples:

L1VFluctuationShape = Square

phchIharmonicAmplitudeA

phchIharmonicAmplitudeB

These parameters sets the interharmonic A and B amplitudes.

Syntax:

phchIharmonicAmplitudeA[sp]=[sp]dim quan

phchIharmonicAmplitudeB[sp]=[sp]dim quan

dim quan ::= value[sp][prefix]units

ph ::=L1 | L2 | L3 | N

ch ::=V | I

value ::=numeric value

units ::=V | A

Rules:

  1. When ch = V, units must be V.
  2. See "Harmonics Mode Parameters" above for a list of other parameters that are allowed for the phase and channel specified.

Examples:

L1VIHarmonicAmplitudeA = 1 V

L1IIHarmonicAmplitudeB = 100 mA

phchIharmonicFrequencyA

phchIharmonicFrequencyB

These parameters sets the interharmonic A and B frequencies.

Syntax:

phchIharmonicFrequencyA[sp]=[sp]dim quan

phchIharmonicFrequencyB[sp]=[sp]dim quan

dim quan ::= value[sp][prefix]Hz

ph ::=L1 | L2 | L3 | N

ch ::=V | I

value ::=numeric value

Rules:

  1. See "Harmonics Mode Parameters" above for a list of other parameters that are allowed for the phase and channel specified.

Examples:

L1IHarmonicFrequencyB = 375 Hz

phchInputCoupling

This parameter specifies the type of UUT input coupling.

Syntax:

phchUUTInputCoupling[sp]=[sp]value

ph ::= L1 | L2 | L3 | N

value ::=DC | AC (default)

Rules:

  1. See "Harmonics Mode Parameters" above for a list of other parameters that are allowed for the phase and channel specified.

Examples:

L1VUUTInputCoupling = DC

phchOffset

This parameter sets the DC Offset.

Syntax:

phchOffset[sp]=[sp]dim quan

dim quan ::= value[sp][prefix]units

ph ::=L1 | L2 | L3 | N

ch ::=V | I

value ::=numeric value

units ::=V | A

Rules:

  1. When ch = V, units must be V.
  2. See "Harmonics Mode Parameters" above for a list of other parameters that are allowed for the phase and channel specified.

Examples:

L1VOffset = 10 mV

NIOffset = [M20] mV

phchPhaseHarmonicn

This parameter specifies the phase of a harmonic.

Syntax:

phchPhaseHarmonicn[sp]=[sp]dim quan

dim quan ::= value[sp][prefix]units

ph ::=L1 | L2 | L3 | N

ch ::=V | I

n ::=1..100

value ::=numeric value

units ::=deg | rad

Rules:

  1. L1VPhaseHarmonic1 is not allowed. It is always 0 deg.

  2. n = 1

    3. Same as phchPhase.

  3. n = 2 through 100

    4. ch = V:Phase of specified voltage harmonic relative to the voltage fundamental on the same phase.

    ch = I:Phase of specified current harmonic relative to the current fundamental on the same phase.

  4. See "Harmonics Mode Parameters" above for a list of other parameters that are allowed for the phase and channel specified.

phchPhase

This parameter specifies the phase of the fundamental.

Syntax:

phchPhase[sp]=[sp]dim quan

dim quan ::= value[sp][prefix]units

ph::= L1 | L2 | L3 | N

ch ::=V | I

value ::=numeric value

units ::=deg | rad

Rules:

  1. L1VPhase is not allowed.It is always 0 deg.
  2. ch = V:Phase of voltage channel relative to L1 voltage fundamental.
  3. ch = I:Phase of current channel relative to voltage fundaments on the same phase.
  4. See "AC Mode Parameters" above for a list of other parameters that are allowed for the phase and channel specified.

phchRange

This parameter specifies the output range.

Syntax:

phchRange[sp]=[sp]dim quan

dim quan ::= value[sp][prefix]units

ph ::=L1 | L2 | L3 | N

ch ::=V | I

value ::=numeric value

units ::=V | A

Values are:

16, 33, 78, 168, 336, & 1008 V voltage channel (ch = 'V')

0.25, 0.5, 1, 2, 5, 10, 20, 80 A, or 0.25, 1.5, 10 V current channel (ch = 'I')

Rules:

  1. If phchRange is not specified, the range for phase and channel is selected based on the following parameters, in the order shown:
    1. phchAC | phchDC
    2. phchRMS
    3. phchAmplitudeHarmonic1

Examples:

NVRange = 168 V

L1IRange = 500 mA

L3IRange = 5 A

phchRMSAmplitude

This parameter specifies the RMS amplitude.

Syntax:

phchRMSAmplitude[sp]=[sp]dim quan

dim quan ::= value[sp][prefix]units

ph ::=L1 | L2 | L3 | N

ch ::=V | I

value ::=numeric value

units ::= V | A

Rules:

Voltage Channel
VoltHarmUnit | phVRMSAmpl | phVAmplHarm1 | phVAmplHarm2-100 & phVOffset
ABS | not allowed | volts (V) | volts (V)
PRMS | volts (V) | not allowed | percent (%)
PFund | not allowed | volts (V) | percent (%)
dBDown | not allowed | volts (V) | decibels (dB)
Current Channel (current)
CurrHarmUnit | phVRMSAmpl | phVAmplHarm1 | phVAmplHarm2-100 & phIOffset
ABS | not allowed | amps (A) | amps (A)
PRMS | amps (A) | not allowed | percent (%)
PFund | not allowed | amps (A) | percent (%)
dBDown | not allowed | amps (A) | decibels (dB)
Current Channel (voltage)
CurrHarmUnit | phVRMSAmpl | phVAmplHarm1 | phVAmplHarm2-100 & phIOffset
ABS | not allowed | volts (V) | volts (V)
PRMS | volts (V) | not allowed | percent (%)
PFund | not allowed | volts (V) | percent (%)
dBDown | not allowed | volts (V) | decibels (dB)
  1. See "Harmonics Mode Parameters" above for a list of other parameters that are allowed for the phase and channel specified.

Examples:

L1VRMSAmpl = 110 V

ph IBandwidth

This parameter specifies the current bandwidth.

Syntax:

phIBandwidth[sp]=[sp]dim quan

dim quan ::= value[sp][prefix]Hz

ph ::=L1 | L2 | L3 | N

value::= numeric value

Rules:

  1. See "Harmonics Mode Parameters" above for a list of other parameters that are allowed for the phase and channel specified.

Examples:

L1IBandwidth = 1.5 kHz

phICoil

This parameter specifies a current coil connected to the current output terminals.

Syntax:

phICoil[sp]=[sp]value

ph ::= L1 | L2 | L3 | N

value::= 5500A/Coil | 5500ACoil | 9100/Coil_X10 | 9100Coil_X10 | 9100/Coil_X50 | 9100Coil_X50

Rules:

  1. See "Harmonics Mode Parameters" above for a list of other parameters that are allowed for the phase and channel specified.

Examples:

L1ICoil = 5500A/Coil

phIUUTCurrentClamp

This parameter specifies the type of UUT current clamp.

Syntax:

phIUUTCurrentClamp[sp]=[sp]value

ph ::=L1 | L2 | L3 | N

value ::= Toroidal | Non-toroidal

Rules:

  1. See "Harmonics Mode Parameters" above for a list of other parameters that are allowed for the phase and channel specified.

Examples:

6100  L1ICoil         = 5500A/COIL
6100  L1IUUTCurrClamp = Toroidal
6100  L1IRange        = 10A
6100  +L1IAC          = 500.0A

phPower

This parameter is used to specify a phase's power.

Syntax:

phPower[sp]=[sp]dim quan

dim quan ::= value[sp][prefix]units

ph ::=L1 | L2 | L3 | N

value ::= numeric value

units ::=W | VA

Rules:

  1. Since power is a "query only" parameter, specifying this parameter is only useful when it is designated as the Evaluation Quantity.
  2. If voltage and current are specified for the phase and channel this parameter will return the power as computed by the 6100A.

phPowerFactor

This parameter is used to specify a phase's power factor.

Syntax:

+phPowerFactor[sp]=[sp]value

ph ::= L1 | L2 | L3 | N

value ::= numeric value

Rules:

  1. If not specified, the default is absolute.
  2. When specified, this parameter must be the evaluation quantity.

Apply

This action sets up the instrument and enables the output.

Syntax:

Apply

Rules:

  1. Apply is not allowed in Energy Counting Mode. For Energy Counting mode use Measure or Setup, Operate, and Read.
  2. Apply is the default, when Energy Counting is not specified, and no action parameter is specified.
  3. When Apply is specified, no other action may be specified.

Examples:

Apply

Channel

This parameter specifies the Energy Counting MUT channel.

Syntax:

Channel[sp]=[sp]1

Rules:

  1. Only ENERGY COUNTING INPUTS 1 is supported.

Energy

This parameter specifies the expected energy.

Syntax:

+Energy[sp]=[sp]dim quan

dim quan ::= numeric value[sp][prefix]units

units ::= Wh | VAh | VARh

Rules:

  1. When Energy is specified it must be the evaluation quantity.

EnergyMode

This parameter specifies the energy mode.

Syntax:

EnergyMode[sp]=[sp]value

value ::= CountedTimed | CountedTim | CounTimed | CounTim | Gated | Gat

Rules:

  1. If not specified, the default is CountedTimed.

Error

This parameter specifies the expected percent error in Energy Counting mode.

Syntax:

+Error[sp]=[sp]dim quan

dim quan = numeric value[sp][prefix]%

Rules:

  • When Error is specified it must be the evaluation quantity.

Frequency

This parameter specifies the fundamental frequency.

Syntax:

Frequency[sp]=[sp]dim quan

dim quan ::= numeric value[sp][prefix]Hz

Rules:

  1. When the frequency is greater than 850 Hz, no channel may specify Harmonics mode.

GatingPullupResistance

This parameter specifies the gating pullup resistance for Energy Counting mode.

Syntax:

GatingPullupResistance[sp]=[sp]value

value ::= numeric value[sp][prefix]Ohm[s]

Rules:

  1. Legal values are 150 Ohms and 1 kOhm.

GatingsignalLevel

This parameter specifies the gating signal level for Energy Counting mode.

Syntax:

GatingsignalLevel[sp]=[sp]value

value ::= High | Low

Rules:

  1. If not specified, the default is Low.

GatingsignalType

This parameter specifies the gating signal type for Energy Counting mode.

Syntax:

GatingsignalType[sp]=[sp]value

value ::= Pulse | Puls | Level | Lev

Rules:

  1. If not specified, the default is Level.

Local

This action puts the calibrator in local mode.

Syntax:

Local

Rules:

  1. When Local is specified, no other parameters may be specified.

Examples:

Local

MaintainVoltage

This parameter specifies whether or not to set the instrument to standby when Energy Counting is complete.

Syntax:

MaintainVoltage

Rules:

  1. If not specified, the default is Standby when Energy Counting is complete.

Measure

This action sets up and initiates Energy Counting. When energy counting is complete, the measurement designated by the Evaluation Quantity is returned in memory register MEM.

Syntax:

Measure

Rules:

  1. When Energy Counting is specified, and no action is specified, Measure is the default.
  2. When Measure is specified, no other action may be specified.

Examples:

Measure

Operate

This parameter turns the output on.

Syntax:

Operate

Rules:

  1. When Operate is specified, no other parameters are allowed.

Examples:

Operate

OutputConstant

This parameter specifies the conversion constant for the Pulse Output.

Syntax:

OutputConstant[sp]=[sp]numeric value[sp][prefix]units

units ::= i/Wh | Wh/i

OutputROscillator

This parameter specifies the state of the instrument's reference oscillator signal.

Syntax:

OutputROscillator[sp]=[sp]value

value ::= On | Off

Rules:

  1. If not specified, the default is off.

OutputRampMode

This parameter specifies the Output 'On' Soft Start Ramp Period.

Syntax:

OutputRampMode[sp]= [sp]value

value ::= Fast | Slow

Rules:

  1. Fast is 10 milliseconds
  2. Slow is 2 seconds
  3. If not specified, the default Fast.

OutputSense

This parameter specifies the state of the instrument's sense capability for all voltage channels.

Syntax:

OutputSense[sp]=[sp]value

value ::= On (4-wire) | Off (2-wire)

Rules:

  1. If not specified, the default is on.

PulseCounts

This parameter specifies the expected pulse counts in Energy Counting mode.

Syntax:

+PulseCounts[sp]=[sp]dim quan

dim quan ::= numeric value[sp][prefix]count[s]

Rules:

  1. When PulseCounts is specified it must be the evaluation quantity.

Read

This action initiates Energy Counting.When energy counting is complete, the measurement designated by the Evaluation Quantity is returned in memory register MEM.

Syntax:

Read

Rules:

  1. When Read is specified, no other action may be specified.

Examples:

Read

ReferenceConstant

This parameter specifies the reference conversion constant for Energy Counting mode.

Syntax:

ReferenceConstant[sp]=[sp]numeric value[sp][prefix]units

units ::= i/Wh | Wh/i

ReferenceInputFilter

This parameter specifies whether or not to enable reference input de-bounce for Energy Counting mode.

Syntax:

ReferenceInputFilter

Rules:

  1. If not specified, the default is disable de-bounce.

ReferenceOutput

This parameter specifies the Reference Output frequency.

Syntax:

ReferenceOutput[sp]=[sp]dim quan

dim quan ::= value[sp][prefix]Hz

value ::= numeric value

Rules:

  1. Legal values are 10 and 20 MHz.
  2. If not specified, the default is off.

ReferencePullupResistance

This parameter specifies the reference pullup resistance for Energy Counting mode.

Syntax:

ReferencePullupResistance[sp]=[sp]value

value ::= numeric value[sp][prefix]Ohm[s]

Rules:

  1. Legal values are 150 Ohms and 1 kOhm.

ReferenceSource

This parameter specifies the reference source for Energy Counting mode.

Syntax:

ReferenceSource[sp]= [sp]value

value ::= Ch 6 | SumCh 456 | MeanCh 456 | MeanCh 56 | Main

Rules:

  1. If not specified, the default Main.

Registration

This parameter specifies the expected percent registration in Energy Counting mode.

Syntax:

+Registration[sp]=[sp]numeric value[sp][prefix]%

Rules:

  1. When Registration is specified it must be the evaluation quantity.

Reset

This parameter resets the instrument.

Syntax:

Reset

Rules:

  1. When Reset is specified, no other parameters are allowed.

Examples:

Reset

Setup

This action causes the instrument to be setup only

Syntax:

Setup

Rules:

  1. When Setup is specified, no other action may be specified.

Examples:

Setup

SetupReset

This parameter specifies whether the instrument is reset before each Apply or Setup action.

Syntax:

SetupReset[sp]=[sp]value

value ::= On | Off

Rules:

  1. If not specified, the default is on.

Standby

This action selects standby (output disabled).

Syntax:

Standby

Rules:

  1. When Standby is specified, no other parameters are allowed.

Examples:

Standby

TestDuration

This parameter specifies the Energy Counting test duration.

Syntax:

TestDuration[sp]=[sp]numeric value[sp][prefix]s

Rules:

  1. Legal values are 2 to 2E+6 seconds.

TestPulseSource

This parameter specifies the test pulse source for Energy Counting mode.

Syntax:

TestPulseSource[sp]=[sp]value

value ::= Ch 1 | Ch 6 | SumCh 456 | MeanCh 456 | MeanCh 56 | Main

Rules:

  1. If not specified, the default Ch 1.

UseInternalPullup

This parameter specifies whether the Pulse Output uses the internal pullup resistor.

Syntax:

UseInternalPullup

UUT_Constant

This parameter specifies the MUT conversion constant for Energy Counting mode.

Syntax:

UUT_Constant[sp]=[sp]numeric value[sp][prefix]units

units ::= i/Wh | Wh/i

UUT_InputFilter

This parameter specifies whether or not to enable MUT input de-bounce for Energy Counting mode.

Syntax:

UUT_InputFilter

Rules:

  1. If not specified, the default is disable de-bounce.

UUT_PullupResistance

This parameter specifies the MUT pullup resistance for Energy Counting mode.

Syntax:

UUT_PullupResistance[sp]=[sp]value

value ::= numeric value[sp][prefix]Ohm[s]

Rules:

  1. Legal values are 150 Ohms and 1 kOhm.

WarmupDuration

This parameter specifies the Energy Counting warm-up duration.

Syntax:

WarmupDuration[sp]=[sp]numeric value[sp][prefix]s

Rules:

  1. Legal values are 2 to 2E+6 seconds.

WarmupPulseSource

This parameter specifies the warm-up pulse source for Energy Counting mode.

Syntax:

WarmupPulseSource[sp]=[sp]value

value ::= Ch 1 | Ch 6 | SumCh 456 | MeanCh 456 | MeanCh 56 | Main

Rules:

  1. If not specified, the default Ch 1.

Examples

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
#
# -----  DC Voltage (Voltage Channel)  -----
#
  1.001  RSLT         =
  1.002  HEAD         DC VOLTAGE:{ 20 V Range}
  1.003  TARGET
  1.004  6100         +L1VDC = 5.0V
  1.005  MEMI         Enter UUT reading in volts DC:
  1.006  MEMCX  20    5.0V           2% 0.5U
#
# -----  DC Current (Current Channel)  -----
#
  2.001  HEAD         DC CURRENT:{ 5 A Range}
  2.002  TARGET       -p
  2.003  IEEE2        CURR:MODE:ELEM1 DC
  2.004  IEEE2        CURR:RANGE:ELEM1 5
  2.005  6100         +L1IDC = 5.0000A
  2.006  WAIT         [D1000]
  2.007  TARGET       -m
  2.008  IEEE2        [D500]MEAS:VAL?[I$]
  2.009  MATH         MEM = FLD(MEM2, 2, ",")
  2.010  MEMCX  5     5.0000A        0.04% 0.08/
#
# -----  DC Voltage (Current Channel), UUT input is 1 mV/A  -----
#
  3.001  RSLT         =
  3.002  HEAD         DC CURRENT:{ 2000 A Range}
# Get 6100A current channel accuracy and convert to ppm.
  3.003  MATH         S[1] = "Fluke 6100A"
  3.004  MATH         L[1] = ACCV(S[1], "DC 10V AUX", 1000e-3)
  3.005  MATH         M[1] = (M[1] / 1000e-3) * 1e6
  3.006  TARGET
  3.007  6100         +L1IDC = 1000mV
  3.008  ACC          1000A          M1P%
  3.009  MEMI         Enter UUT reading in amps DC.
  3.010  MEMCX  2000  1000A          2% 4U
#
# -----  AC Voltage (Voltage Channel)  -----
#
  4.001  RSLT         =
  4.002  HEAD         AC VOLTAGE:{ 200 V Range}
  4.003  TARGET
  4.004  6100         +L1VAC = 130.0V; Freq = 60Hz
  4.005  MEMI         Enter UUT reading in volts RMS:
  4.006  MEMCX  200   130.0V         0.5% 0.2U     60H
#
# -----  AC Current (Current Channel)  -----
#
  5.001  HEAD         AC CURRENT:{ 10 A Range}
  5.002  TARGET       -p
  5.003  IEEE2        CURR:MODE:ELEM1 RMS
  5.004  IEEE2        CURR:RANGE:ELEM1 10
  5.005  6100         +L1IAC = 10.000A  @Freq = 50Hz
  5.006  WAIT         [D1000]
  5.007  TARGET       -m
  5.008  IEEE2        [D500]MEAS:VAL?[I$]
  5.009  MATH         MEM = FLD(MEM2, 2, ",")
  5.010  MEMCX  10    10.000A        0.03% 0.05/   50H
#
# -----  AC Voltage (Current Channel), UUT input is 1 mV/A  -----
#
  6.001  RSLT         =
  6.002  HEAD         AC CURRENT:{ 1000 A Range}
# Get 6100A current channel accuracy and convert to ppm.
  6.003  MATH         L[1] = ACCV2(S[1], "Sine 1.5V AUX", 670e-3, 60)
  6.004  MATH         M[1] = (M[1] / 670e-3) * 1e6
  6.005  TARGET
  6.006  6100         +L1IAC = 670mV; Freq = 60Hz
  6.007  ACC          670A           M1P%
  6.008  MEMI         Enter UUT reading in amps RMS.
  6.009  MEMCX  1000  670A           0.5% 3U       60H
#
# -----  DC Power (Current Channel Current)
#
  7.001  RSLT         =
  7.002  HEAD         DC POWER:{ 60 V, 1 A}
  7.003  TARGET       -p
  7.004  IEEE2        VOLT:RANGE:ELEM[M14] 60
  7.005  IEEE2        VOLT:MODE:ELEM[M14] DC
  7.006  IEEE2        CURR:RANGE:ELEM[M14] 1
  7.007  IEEE2        CURR:MODE:ELEM[M14] DC
  7.008  6100         L1VDC    = 60V  L1IDC = 1A
  7.008  6100         +L1Power = 60.00W
  7.009  TARGET       -m
  7.010  IEEE2        [D500]MEAS:VAL?[I$]
  7.011  MATH         MEM = FLD(MEM2, 3, ",")
  7.012  MEMCX  60    W              0.08% 0.12/
#
# -----  AC Power (Current Channel Current)
#
  8.001  MEM2         =
  8.002  HEAD         AC POWER:{ PF -0.5}
  8.003  TARGET
  8.004  6100         L1VAC    = 100V      L1IAC = 5A
  8.004  6100         +L1Power = 250.00W  Freq  = [M15]Hz  L1IPhase = 120deg
  8.005  MEMI         Enter UUT reading in watts.
  8.006  MEMCX  250   W              0.04% 0.04/
#
  9.001  MEM2         =100 V, 2 A @ 400 Hz, Phase 45 deg
  9.002  HEAD         AC POWER:{ 100 V, 2 A @ 400 Hz, Phase 45 deg}
  9.003  TARGET       -p
  9.004  6100         CurrHarmUnits = PRMS
  9.004  6100         Freq          = 400Hz
  9.004  6100         L1VRMSAmpl    = 100V
  9.004  6100         L1IRMSAmpl    = 2A
  9.004  6100         L1IPhase      = 45deg
  9.004  6100         L1IAmplHarm3  = 20%
  9.004  6100         L1IAmplHarm15 = 5%
  9.004  6100         +L1Power      = 138.376W
  9.005  TARGET       -m
  9.006  IEEE2        [D500]MEAS:VAL?[I$]
  9.007  MATH         MEM = FLD(MEM2, 3, ",")
  9.008  MEMCX  138.4 W              0.169U        400H
#
# -----  AC Power (Current Channel Voltage), UUT input is 1 mV/A
#
 10.001  RSLT         =
 10.002  RSLT         =100 V, 150 A @ 60 Hz
# Get 6100A voltage channel accuracy and convert to ppm.
 10.003  MATH         L[1] = ACCV2(S[1], "Sine 168V", 100, 60)
 10.004  MATH         M[1] = (L[1] / 100) * 1e6
# Get 6100A current channel accuracy and convert to ppm.
 10.005  MATH         L[2] = ACCV2(S[1], "Sine 0.25V AUX", 150e-3, 60)
 10.006  MATH         M[2] = (M[2] / 150e-3) * 1e6
# Convert phase to radians.
 10.007  MATH         L[4] = RAD(157)
# Get 6100A current to voltage channel phase accuracy and convert to ppm.
 10.008  MATH         L[5] = ACCV2(S[1], "Phase I-V 0.25V V>40%", 150e-3, 60)
# Convert to ppm.
 10.009  MATH         L[3] = (1 - COS(L[4] + RAD(L[5])) / COS(L[4])) * 1e6
# Calculate RSS of voltage channel, current channel, and phase accuracies.
 10.010  MATH         M[1] = RSS3(L[1], L[2], L[3])
 10.011  TARGET
 10.012  6100         L1VAC = 100V; L1IAC = 150mV; Freq = 60Hz
 10.012  6100         +L1Power = 13.8kW; L1IPhase = 157deg
 10.013  ACC          13.8kW         M1P%
 10.014  MEMI         Enter UUT reading in kilowatts.
 10.015  MEMCX        13.8kW         1% 0.4U       60H

 11.001  6100         L1VAC = 100V; L1IAC = 150mV; Freq = 60Hz
 11.001  6100         +L1Power = 15.0kVA; L1IPhase = 157deg
 11.002  ACC          15.0kVA        M1P%
 11.003  MEMI         Enter UUT reading in kilovolt-amps.
 11.004  MEMCX        15.0kVA        1% 0.4U       60H

 12.001  6100         L1VAC = 100V; L1IAC = 150mV; Freq = 60Hz
 12.001  6100         +L1Power = 5.9kVAR; L1IPhase = 157deg
 12.002  ACC          5.9k'VAR'      M1P%
 12.003  MEMI         Enter UUT reading in units of kVAR.
 12.004  MEMCX        5.9k'VAR'      1% 0.4U       60H
#
# -----  Harmonic Amplitude -----
#
 13.001  RSLT         =
 13.002  HEAD         HARMONICS:{ 10.000 V @ 100 Hz, Harmonic 25}
 13.003  TARGET       -p
 13.004  6100         L1VRange       = 168V     L1IRange   = 21A
 13.004  6100         L1VAmplHarm1   = 100V     L1IRMSAmpl = 10A
 13.004  6100         +L1VAmplHarm25 = 10.000V  Freq       = 100Hz
 13.005  TARGET       -m
 13.006  IEEE2        [D500]MEAS:VAL?[I$]
 13.007  MATH         MEM = FLD(MEM2, 26, ",")
 13.008  MEMCX  168   10.000V        2.0% 0.05/    2.5kH
#
# -----  Flicker Analysis -----
#
 14.001  RSLT         =
 14.002  HEAD         {FLICKER ANALYSIS}
 14.003  TSET         TDESC = [MEM2]
 14.004  6100         L1VAC           = 230V
 14.004  6100         Frequency       = 50Hz
 14.004  6100         L1VFlickerShape = Square
 14.004  6100         L1VFlickerFreq  = 58.3mHz
 14.004  6100         L1VFlickerDepth = 1.459%
 14.004  6100         +L1VFlickerPST  = 1
 14.005  IEEE2        FLICKER:INIT
 14.006  WAIT         -t 30 Waiting for UUT...
 14.007  IEEE2        FLICKER:START
 14.008  WAIT         -t 10:10 Waiting for UUT...
 14.009  TARGET       -m
 14.010  IEEE2        [D500]MEAS:VAL?[I$]
 14.011  MATH         MEM = FLD(MEM2, 9, ",")
 14.012  MEMCX  1     ''             0.05U         58.3mH

 15.001  END


6100B and 6105A

Instrument FSC

Description

The 6100B FSC controls the Fluke 6100B Electrical Power Standard Master unit and up to three Electrical Power Standard Auxiliary Units.

The 6105A FSC controls the Fluke 6105A Electrical Power Standard Master unit and up to three Electrical Power Standard Auxiliary Units. A procedure using 6100B statements will execute without modification when a 6105A is configured and connected. The accuracy of the 6105A will be used at run time.

Reference accuracy for auxiliary units is only calculated when the model used as an auxiliary unit has the same specified accuracy as the master unit.

Examples:

6100B (L1) and 6100B/6101B (L2), 6100B/6101B (L3), 6100B/6101B (N)

6105A (L1) and 6105A/6106A (L2), 6105A/6106A (L3), 6105A/6106A (N)

Reference accuracy always calculated

6100B (L1) and 6105A/6106A (L2), 6105A/6106A (L3), 6105A/6106A (N)

6105A (L1) and 6100B/6101B (L2), 6100B/6101B (L3), 6100B/6101B (N)

Reference accuracy NOT calculated for energy, or any L2, L3, or N parameter specified as the evaluation quantity.

Voltage can be maintained for parasitic UUTs, until a current range change is required. The calibrator is not able to maintain the voltage output while changing current ranges, and must be placed in Standby before changing ranges. For details, see SetupReset and MaintainVoltage below.

Parameters

An NVI FSC statement consists of one or more parameters. A parameter consists of a name and a value. Each parameter must be separated by a semicolon and/or one or more spaces. A single NVI FSC statement can encompass more than one physical line as long as the line numbers are the same. However each parameter name and its value must occur on one line. A single line can accommodate up to 256 characters including the statement number and FSC. Note that characters above ASCII 128 count as 2 characters.

Syntax:

parameter[separatorparameter]

parameter::= [parameter_prefix]parameter_name[[sp]=[sp]parameter_value]

separator::= ;[sp] | sp

parameter_prefix ::=+ | @

sp::= one or more spaces

parameter_name::= see the Parameter Names section

parameter_value::=dimensionless number | dimensioned number | discrete_list

dimensionless number::=NRf

dimensioned number::=NRf[sp][prefix]units

discrete_list::=see the Parameter Names section

prefix::=y | z | a | f | p | n | u | m | k | M | G | T | P | E | Z | Y

Definitions:

|
Denotes "or" (i.e. A | B is A or B)
[ ]
Denotes an optional syntax element, except in examples. In examples [ ] enclose a special construction.
+
Designates the parameter as the Evaluation Quantity
@
Designates the parameter as the Modifier Quantity

Rules:

  1. One and only one parameter must be designated as the Evaluation Quantity value in a 6100B/6105A Setup (default) statement.
  2. When a 6100B/6105A statement is executed, the value of the Evaluation Quantity is copied to memory register MEM1 in base units.
    3. For Energy Counting, the reading is returned in memory register MEM.

    Example:

    1.001 6100B +L1IAC = 100 mA; L1IRange = 250 mA; @Frequency = 1 kHz

    After the 6100B statement is executed the value of MEM1 is 100.

  3. At most one parameter may be designated as the Modifier Quantity in a 6100B Setup (default) statement.
  4. Parameter values may be taken from a MET/CAL memory register using a special construction.

    5. Example:

    Setup 6100B 'V' channel to 100 V, 'I' channel to 5 A

      1.002  6100B        L1VRange = 180 V; L1IRange = 5 A
  1.002  6100B        L1VAC = 100 V; L1IAC = 5 A
  1.002  6100B        +L1Power = 500 W; Freq = 60 Hz

    or

      1.003  6100B        L1VAC = 100 V L1IAC = 5 A
  1.003  6100B        +L1Power = 500 W Freq = 60 Hz

    or

      1.004  6100B        Freq  = 60Hz
  1.004  6100B        L1VRange  = 180V
  1.004  6100B        L1VAC  = 100V
  1.004  6100B        L1IRange  = 5A
  1.004  6100B        L1IAC  = 5A
  1.004  6100B        +L1Power  = 500W

Parameter Names

Parameter names consist of single words or compound words.Each word in a parameter name can be entered in long form (as shown below), or in short form.The short form is the first 4 characters of the long form, with the following exceptions:

  1. If the long form is greater than four characters, and the last character or the short form is a vowel, the short form is three characters.
  2. If the long form is four characters or less, the short form is the long form even if it ends in a vowel.

The following abbreviations are used in the parameter names and definitions below.

ph (phase)
L1 | L2 | L3 | N
ch (channel)
V | I

Action Parameters

  • Apply
  • Local
  • Operate
  • Reset
  • Setup
  • Standby

System Global Parameters

  • Frequency
  • OutputROscillator
  • OutputRampTime
  • OutputSense
  • ReferenceOutput
  • SetupReset

Energy Counting Parameters

  • Channel
  • Energy
  • EnergyMode
  • Error
  • GatingPullupResistance
  • GatingSignalLevel
  • GatingSignalType
  • MaintainVoltage
  • OutputConstant
  • PulseCounts
  • ReferenceConstant
  • ReferenceInputFilter
  • ReferencePullupResistance
  • ReferenceSource
  • Registration
  • TestDuration
  • TestPulseSource
  • UseInternalPullup
  • UUT_Constant
  • UUT_InputFilter
  • UUT_PullupResistance
  • UUT_Source
  • WarmupDuration
  • WarmupPulseSource

Phase Specific / Channel Global Parameters

  • phPower
  • phPowerFactor

Phase Specific / I Channel Global Parameters

  • phICoil
  • phICurrentTerminals
  • phIUUTCurrentClamp
  • phIUUTInputCouping

DC Mode Parameters

  • phchRange
  • phchDC
  • phchFluctuateDC

AC Mode Parameters

  • phchRange
  • phchAC
  • phchPhase
  • phchOffset
  • phIBandwidth

Flicker

  • phchFlickerDepth
  • phchFlickerFrequency
  • phchFlickerShape
  • phchFlickerDuty
  • phchFlickerPst

Dips and Swells

  • phchDipChangeTo
  • phchDipRampIn
  • phchDipPeriod
  • phchDipRampOut
  • phchDipEndDelay
  • phchDipTriggerInput
  • phchDipTriggerHoldOff
  • phchDipTriggerODelay

Harmonic Mode Parameters

VoltageHarmonicUnits, CurrentHarmonicUnits

  • phchRange
  • phchRMSAmplitude
  • phchAmplitudeHarmonicn, n = 1 to 100
  • phchPhaseHarmonicn, n = 1 to 100
  • phchOffset
  • phIBandwidth

Fluctuating Harmonics

  • phchFluctuateHarmonicn, n = 1 to 100
  • phchFluctuationDepth
  • phchFluctuationFrequency
  • phchFluctuationShape
  • phchFluctuationDuty

Interharmonics

  • phchIHarmonicAmplitudeA
  • phchIHarmonicFrequencyA
  • phchIHarmonicAmplitudeB
  • phchIHarmonicFrequencyB

Flicker

  • phchFlickerDepth
  • phchFlickerFrequency
  • phchFlickerShape
  • phchFlickerDuty
  • phchFlickerPst

Dips and Swells

  • phchDipChangeTo
  • phchDipRampIn
  • phchDipPeriod
  • phchDipRampOut
  • phchDipEndDelay
  • phchDipTriggerInput
  • phchDipTriggerHoldOff
  • phchDipTriggerODelay

Parameter Definitions and Values

phchAC

This parameter specifies an AC signal.This is accomplished by setting the RMS value to the value specified and turning and harmonics 2 through 100 off.

Syntax:

phch AC[sp]=[sp]dim quan

dim quan ::= value[sp][prefix]units

ph | ::= L1 | L2 | L3 | N
ch | ::= V | I
value | ::= numeric value
units | ::= V | A

Rules:

  1. When phVAC is specified the voltage channels are set to "Absolute RMS"
  2. When phIAC is specified the current channels are set to "Absolute RMS"
  3. See "AC Mode Parameters" above for a list of other parameters that are allowed for the phase and channel specified.

Examples:

L1VAC = 110 V

L3IAC = [M5] mA

phchAmplitudeHarmonicn

This parameter specifies the amplitude of a harmonic.

Syntax:

phch AmplitudeHarmonic n [sp]=[sp]dim quan

dim quan ::= value[sp][prefix]units

ph | ::= L1 | L2 | L3 | N
ch | ::= V | I
n | ::= 1..100
value | ::= numeric value
units | ::= V | A | % | dB

Rules:

  1. When units are dB or %, prefix is not allowed.
  2. phVAmplitudeHarmonicn, 2 - 100 and offset for all phases must have the same units.
  3. phIAmplitudeHarmonicn, 2 - 100 and offset for all phases must have the same units.
    4. Voltage Channel
VoltHarmUnit | phVRMSAmpl | phVAmplHarm1 | phVAmplHarm 2-100 & phVOffset
ABS | not allowed | volts (V) | volts (V)
PRMS | volts (V) | not allowed | percent (%)
PFund | not allowed | volts (V) | percent (%)
dBDown | not allowed | volts (V) | decibels (dB)
    Current Channel (current)
CurrHarmUnit | phVRMSAmpl | phVAmplHarm1 | phVAmplHarm 2-100 & phIOffset
ABS | not allowed | amps (A) | amps (A)
PRMS | amps (A) | not allowed | percent (%)
PFund | not allowed | amps (A) | percent (%)
dBDown | not allowed | amps (A) | decibels (dB)
    Current Channel (voltage)
CurrHarmUnit | phVRMSAmpl | phVAmplHarm1 | phVAmplHarm 2-100 & phIOffset
ABS | not allowed | volts (V) | volts (V)
PRMS | volts (V) | not allowed | percent (%)
PFund | not allowed | volts (V) | percent (%)
dBDown | not allowed | volts (V) | decibels (dB)

  4. See "Harmonics Mode Parameters" above for a list of other parameters that are allowed for the phase and channel specified.

phchDC

This parameter sets the specified phase and channel to output a DC signal.This accomplished as follows:

  1. Clear all harmonics on the specified phase and channel.
  2. Set harmonic 1 (fundamental) amplitude to zero.
  3. Set harmonic 0 (DC Offset) to the specified value.

Syntax:

phchDC[sp]=[sp]dim quan

dim quan ::= value[sp][prefix]units

ph | ::= L1 | L2 | L3 | N
ch | ::= V | I
value | ::= numeric value
units | ::= V | A

Rules:

  1. When phVDC is specified the voltage channels are set to "Absolute RMS"
  2. When phIDC is specified the current channels are set to "Absolute RMS"
  3. See "DC Mode Parameters" above for a list of other parameters that are allowed for the phase and channel specified.

Examples:

L1VDC = 10 V

NIDC = [MEM] mA

phchDipChangeTo

This parameter sets the Dips and Swells "Change To" value.

Syntax:

phchDipChangeTo[sp]=[sp]percent quan

percent quan ::= value[sp][prefix]%

ph | ::= L1 | L2 | L3 | N
ch | ::= V | I
value | ::= numeric value

Rules:

  1. See "Harmonics Mode Parameters" above for a list of other parameters that are allowed for the phase and channel specified.

Examples:

L1VDipChangeTo = 10 %

phchDipEndDelay, phchDipPeriod, phchDipRampIn, phchDipRampOut

These parameters set the Dips and Swells End Delay, Period, Ramp In, and Ramp Out values.

Syntax:

phchDipEndDelay[sp]=[sp]dim quan

phchDipPeriod[sp]=[sp]dim quan

phchDipRampIn[sp]=[sp]dim quan

phchDipRampOut[sp]=[sp]dim quan

dim quan ::= value[sp][prefix]units

ph | ::= L1 | L2 | L3 | N
ch | ::= V | I
value | ::= numeric value
units | ::= s | c (cycles)

Rules:

  1. When units ::= c, prefix is not allowed.
  2. See "Harmonics Mode Parameters" above for a list of other parameters that are allowed for the phase and channel specified.

Examples:

L1VDipEndDelay = 10 ms

L1VDipEndDelay = 3 c

L1VDipPeriod = 10 ms

L1VDipPeriod = 3 c

L1VDipRampIn = 10 ms

L1VDipRampIn = 3 c

L1VDipRampOut = 10 ms

L1VDipRampOut = 3 c

phchDipTriggerHoldOff

This parameter sets the Dips and Swells "Start (Trig Input)" value.

Syntax:

phchDipTriggerHoldOff[sp]=[sp]dim quan

dim quan ::= value[sp][prefix]units

ph | ::= L1 | L2 | L3 | N
ch | ::= V | I
value | ::= numeric value
units | ::= deg | s | c (cycles)

Rules:

  1. When units ::= c, prefix is not allowed.
  2. See "Harmonics Mode Parameters" above for a list of other parameters that are allowed for the phase and channel specified.

Examples:

L1VDipTriggerHoldOff = 10 ms

L1VDipTriggerHoldOff = 3 c

L1VDipTriggerHoldOff = 10 deg

phchDipTriggerInput

This parameter sets the trigger used to determine the event that starts the dip or swell.

Syntax:

phchDipTriggerInput[sp]=[sp]value

ph | ::= L1 | L2 | L3 | N
ch | ::= V | I
value | ::= Free | EOne | ERepeat
Free | Free running dips/swells
EOne | One dip/swell trigger from an external source
ERepeat | Continuous dips/swells trigger from an external source.

Rules:

  1. See "Harmonics Mode Parameters" above for a list of other parameters that are allowed for the phase and channel specified.

Examples:

L1VDipTriggerInput = ERep

phchDipTriggerODelay

This parameter sets the delay before the output trigger is generated,following the completion of a dip or swell.

Syntax:

phchDipTriggerODelay[sp]=[sp]value

dim quan ::= value[sp][prefix]units

ph | ::= L1 | L2 | L3 | N
ch | ::= V | I
value | ::= numeric value
units | ::= s | c (cycles)

Rules:

  1. When units ::= c, prefix is not allowed.
  2. See "Harmonics Mode Parameters" above for a list of other parameters that are allowed for the phase and channel specified.

Examples:

L1VDipTriggerODelay = 10 ms

L1VDipTriggerODelay = 3 c

phchFlickerDepth

This parameter sets the flicker modulation depth expressed as a percentage of the voltage waveform RMS amplitude.

Syntax:

phchFlickerDepth[sp]=[sp]percent quan

percent quan ::= value[sp][prefix]%

ph | ::= L1 | L2 | L3 | N
ch | ::= V | I
value | ::= numeric value

Rules:

  1. See "Harmonics Mode Parameters" above for a list of other parameters that are allowed for the phase and channel specified.

Examples:

L1VFlickerDepth = 10 %

phchFlickerDuty

This parameter sets the flicker duty cycle for rectangular modulation.

Syntax:

phchFlickerDuty[sp]=[sp]percent quan

percent quan ::= value[sp][prefix]%

ph | ::= L1 | L2 | L3 | N
ch | ::= V | I
value | ::= numeric value

Rules:

  1. See "Harmonics Mode Parameters" above for a list of other parameters that are allowed for the phase and channel specified.

Examples:

L1VFlickerDuty = 10 %

phchFlickerFrequency

This parameter sets the flicker modulation frequency.

Syntax:

phchFlickerFrequency[sp]=[sp]dim quan

dim quan ::= value[sp][prefix]Hz

ph | ::= L1 | L2 | L3 | N
ch | ::= V | I
value | ::= numeric value

Rules:

  1. See "Harmonics Mode Parameters" above for a list of other parameters that are allowed for the phase and channel specified.

Examples:

L1VFlickerFrequency = 1 kHz

phchFlickerPst

This parameter is used to query the flicker perception level, short term, computed by the calibrator.

Syntax:

phchFlickerPst[sp]=[sp]value

ph | ::= L1 | L2 | L3 | N
ch | ::= V | I
value | ::= numeric value

Rules:

  1. Since Pst is a "query only" parameter, specifying this parameter is only useful when it is designated as the Evaluation Quantity.
  2. See "Harmonics Mode Parameters" above for a list of other parameters that are allowed for the phase and channel specified.

Examples:

+L1VFlickerPst = 1.00

phchFlickerShape

This parameter sets the flicker modulation shape.

Syntax:

phchFlickerShape[sp]=[sp]value

ph | ::= L1 | L2 | L3 | N
ch | ::= V | I
value | ::= Rect | Rectangle | Rectangular | Sin | Sine | Sinusoid | Sinusodial | Squ | Square
Rect | Sets the modulation waveform to be rectangular.
Sin | Sets the modulation waveform to be sinusoidal.
Squ | Sets the modulation waveform to be square.

Rules:

  1. See "Harmonics Mode Parameters" above for a list of other parameters that are allowed for the phase and channel specified.

Examples:

L1VFlickerShape = Square

phchFluctuateDC

This parameter turns on/off DC fluctuation.

Syntax:

phchFluctuateDC[sp]=[sp]value

ph | ::= L1 | L2 | L3 | N
ch | ::= V | I
value | ::= On | Off

Examples:

L1VFluctuateDC = On

phchFluctuateHarmonicn

This parameter turns on/off the fluctuation of harmonic n.oscillator signal.

Syntax:

phchFluctuateHarmonicn [sp]=[sp]value

ph | ::= L1 | L2 | L3 | N
ch | ::= V | I
n | ::= 1..100
value | ::= On | Off

Examples:

L1VFluctuateHarmonic9 = On

phchFluctuationDepth

This parameter sets the fluctuating harmonics modulation depth expressed as a percentage of the voltage waveform RMS amplitude.

Syntax:

phchFluctuationDepth[sp]=[sp]percent quan

percent quan ::= value[sp][prefix]%

ph | ::= L1 | L2 | L3 | N
ch | ::= V | I
value | ::= numeric value

Rules:

  1. See "Harmonics Mode Parameters" above for a list of other parameters that are allowed for the phase and channel specified.

Examples:

L1VFluctuationDepth = 10 %

phchFluctuationFrequency

This parameter sets the fluctuating harmonics modulation frequency.

Syntax:

phchFluctuationFrequency[sp]=[sp]value

dim quan ::= value[sp][prefix]Hz

ph | ::= L1 | L2 | L3 | N
ch | ::= V | I
value | ::= numeric value

Rules:

  1. See "Harmonics Mode Parameters" above for a list of other parameters that are allowed for the phase and channel specified.

Examples:

L1VFluctuationFrequency = 1 kHz

phchFluctuationShape

This parameter sets the fluctuating harmonics modulation shape.

Syntax:

phchFluctuationShape[sp]=[sp]value

ph | ::= L1 | L2 | L3 | N
ch | ::= V | I
value | ::= Rect | Rectangle | Rectangular | Sin | Sine | Sinusoid | Sinusodial | Squ | Square
Rect | Sets the modulation waveform to be rectangular.
Sin | Sets the modulation waveform to be sinusoidal.
Squ | Sets the modulation waveform to be square.

Rules:

  1. See "Harmonics Mode Parameters" above for a list of other parameters that are allowed for the phase and channel specified.

Examples:

L1VFluctuationShape = Square

phchIharmonicAmplitudeA, phchIharmonicAmplitudeB

These parameters sets the interharmonic A and B amplitudes.

Syntax:

phchIharmonicAmplitudeA[sp]=[sp]dim quan

phchIharmonicAmplitudeB[sp]=[sp]dim quan

dim quan ::= value[sp][prefix]units

ph | ::= L1 | L2 | L3 | N
ch | ::= V | I
value | ::= numeric value
units | ::= V | A

Rules:

  1. When ch= V, units must be V.
  2. See "Harmonics Mode Parameters" above for a list of other parameters that are allowed for the phase and channel specified.

Examples:

L1VIHarmonicAmplitudeA = 1 V

L1IIHarmonicAmplitudeB = 100 mA

phchIharmonicFrequencyA, phchIharmonicFrequencyB

These parameters sets the interharmonic A and B frequencies.

Syntax:

phchIharmonicFrequencyA[sp]=[sp]dim quan

phchIharmonicFrequencyB[sp]=[sp]dim quan

dim quan ::= value[sp][prefix]Hz

ph | ::= L1 | L2 | L3 | N
ch | ::= V | I
value | ::= numeric value

Rules:

  1. See "Harmonics Mode Parameters" above for a list of other parameters that are allowed for the phase and channel specified.

Examples:

L1IIHarmonicFrequencyB = 375 Hz

phchInputCoupling

This parameter specifies the type of UUT input coupling.

Syntax:

phchUUTInputCoupling[sp]=[sp]value

ph | ::= L1 | L2 | L3 | N
value | ::= DC | AC (default)

Rules:

  1. See "Harmonics Mode Parameters" above for a list of other parameters that are allowed for the phase and channel specified.

Examples:

L1VUUTInputCoupling = DC

phchOffset

This parameter sets the DC Offset.

Syntax:

phchOffset[sp]=[sp]dim quan

dim quan ::= value[sp][prefix]units

ph | ::= L1 | L2 | L3 | N
ch | ::= V | I
value | ::= numeric value
units | ::= V | A

Rules:

  1. When ch= V, units must be V.
  2. See "Harmonics Mode Parameters" above for a list of other parameters that are allowed for the phase and channel specified.

Examples:

L1VOffset = 10 mV

NIOffset = [M20] mV

phchPhaseHarmonicn

This parameter specifies the phase of a harmonic.

Syntax:

phchPhaseHarmonicn [sp]=[sp]dim quan

dim quan ::= value[sp][prefix]units

ph | ::= L1 | L2 | L3 | N
ch | ::= V | I
n | ::= 1..100
value | ::= numeric value
units | ::= deg | rad

Rules:

  1. L1VPhaseHarmonic1 is not allowed. It is always 0 deg.
  2. n = 1 Same as phchPhase.
  3. n = 2 through 100 ch = V:Phase of specified voltage harmonic relative to the voltage fundamental on the same phase. ch = I:Phase of specified current harmonic relative to the current fundamental on the same phase.
  4. See "Harmonics Mode Parameters" above for a list of other parameters that are allowed for the phase and channel specified.

phchPhase

This parameter specifies the phase of the fundamental.

Syntax:

phchPhase[sp]=[sp]dim quan

dim quan ::= value[sp][prefix]units

ph | ::= L1 | L2 | L3 | N
ch | ::= V | I
value | ::= numeric value
units | ::= deg | rad

Rules:

  1. L1VPhase is not allowed. It is always 0 deg.
  2. ch = V:Phase of voltage channel relative to L1 voltage fundamental.
  3. ch = I:Phase of current channel relative to voltage fundaments on the same phase.
  4. See "AC Mode Parameters" above for a list of other parameters that are allowed for the phase and channel specified.

phchRange

This parameter specifies the output range.

Syntax:

phchRange[sp]=[sp]dim quan

dim quan ::= value[sp][prefix]units

ph | ::= L1 | L2 | L3 | N
ch | ::= V | I
value | ::= numeric value
units | ::= V | A

Values are:

23, 45, 90, 180, 360, 650*, & 1008 V voltage channel (ch= 'V')

*6105A only

0.25, 0.5, 1, 2, 5, 10, 20, 50, 80 A, or 0.25, 1.5, 10 Vcurrent channel (ch= 'I')

Rules:

  1. If phchRange is not specified, the range for phase and channel is selected based on the following parameters, in the order shown:
    1. phchAC | phchDC
    2. phchRMS
    3. phchAmplitudeHarmonic1

Examples:

NVRange = 180 V

L1IRange = 500 mA

L3IRange = 5 A

phchRMSAmplitude

This parameter specifies the RMS amplitude.

Syntax:

phchRMSAmplitude[sp]=[sp]dim quan

dim quan ::= value[sp][prefix]units

ph | ::= L1 | L2 | L3 | N
ch | ::= V | I
value | ::= numeric value
units | ::= V | A

Rules:

Voltage Channel
VoltHarmUnit | ph VRMSAmpl | ph VAmplHarm1 | ph VAmplHarm2-100 & ph VOffset
ABS | not allowed | volts (V) | volts (V)
PRMS | volts (V) | not allowed | percent (%)
PFund | not allowed | volts (V) | percent (%)
dBDown | not allowed | volts (V) | decibels (dB)
Current Channel (current)
CurrHarmUnit | phVRMSAmpl | phVAmplHarm1 | phVAmplHarm2-100 & phIOffset
ABS | not allowed | amps (A) | amps (A)
PRMS | amps (A) | not allowed | percent (%)
PFund | not allowed | amps (A) | percent (%)
dBDown | not allowed | amps (A) | decibels (dB)
Current Channel (voltage)
CurrHarmUnit | ph VRMSAmpl | phVAmplHarm1 | phVAmplHarm2-100 & phIOffset
ABS | not allowed | volts (V) | volts (V)
PRMS | volts (V) | not allowed | percent (%)
PFund | not allowed | volts (V) | percent (%)
dBDown | not allowed | volts (V) | decibels (dB)
  1. See "Harmonics Mode Parameters" above for a list of other parameters that are allowed for the phase and channel specified.

Examples:

L1VRMSAmpl = 110 V

ph IBandwidth

This parameter specifies the current bandwidth.

Syntax:

phIBandwidth[sp]=[sp]dim quan

dim quan ::= value[sp][prefix]Hz

ph ::= L1 | L2 | L3 | N

value ::= numeric value

Rules:

  1. See "Harmonics Mode Parameters" above for a list of other parameters that are allowed for the phase and channel specified.

Examples:

L1IBandwidth = 1.5 kHz

ph ICoil

This parameter specifies a current coil connected to the current output terminals.

Syntax:

phICoil[sp]=[sp]value

ph ::= L1 | L2 | L3 | N

value ::= 5500A/Coil | 5500ACoil | 9100/Coil_X10 | 9100Coil_X10 | 9100/Coil_X50 | 9100Coil_X50

Rules:

  1. See "Harmonics Mode Parameters" above for a list of other parameters that are allowed for the phase and channel specified.

Examples:

L1ICoil = 5500A/Coil

phICurrentTerminals

This command selectes where the up-to-21A signal is routed for this phase.

Syntax:

phICurrentTerminals[sp]=[sp]value

value ::= Upper | Lower

Examples:

L2ICurrTerm = Lower

phIUUTCurrentClamp

This parameter specifies the type of UUT current clamp.

Syntax:

phIUUTCurrentClamp[sp]=[sp]value

ph | ::= | L1 | L2 | L3 | N
value | ::= | Toroidal | Non-toroidal

Rules:

  1. See "Harmonics Mode Parameters" above for a list of other parameters that are allowed for the phase and channel specified.

Examples:

  1.005  6100B        L1ICoil = 5500A/Coil
  1.005  6100B        L1IBandwidth = 1.5 kHz
  1.005  6100B        L1IUUTCurrClamp = Toroidal
  1.005  6100B        L1IRange = 10A
  1.005  6100B        Frequency = 60 Hz
  1.005  6100B        +L1IAC = 500.0 A

phPower

This parameter is used to specify a phase's power.

Syntax:

phPower[sp]=[sp]dim quan

dim quan ::= value[sp][prefix]units

ph | ::= | L1 | L2 | L3 | N
value | ::= | numeric value
units | ::= | W | VA

Rules:

  1. Since power is a "query only" parameter, specifying this parameter is only useful when it is designated as the Evaluation Quantity.
  2. If voltage and current are specified for the phase and channel this parameter will return the power as computed by the calibrator.

ph PowerFactor

This parameter is used to specify a phase's power factor.

Syntax:

+phPowerFactor[sp]=[sp]value

ph | ::= | L1 | L2 | L3 | N
value | ::= | numeric value

Rules:

  1. If not specified, the default is absolute.
  2. When specified, this parameter must be the evaluation quantity.

Apply

This action sets up the instrument and enables the output.

Syntax:

Apply

Rules:

  1. Apply is not allowed in Energy Counting Mode. For Energy Counting mode use Measure or Setup, Operate, and Read.
  2. Apply is the default, when Energy Counting is not specified, and no action parameter is specified.
  3. When Apply is specified, no other action may be specified.

Examples:

Apply

Channel

This parameter specifies the Energy Counting MUT channel.

Syntax:

Channel[sp]=[sp]1

Rules:

  1. Only ENERGY COUNTING INPUTS 1 is supported.

Energy

This parameter specifies the expected energy.

Syntax:

+Energy[sp]=[sp]dim quan

dim quan | ::= | numeric value[sp][prefix]units
units | ::= | Wh | VAh | VARh

Rules:

  1. When Energy is specified it must be the evaluation quantity.

EnergyMode

This parameter specifies the energy mode.

Syntax:

EnergyMode[sp]=[sp]value

value ::= CountedTimed | CountedTim | CounTimed | CounTim | Gated | Gat

Rules:

  1. If not specified, the default is CountedTimed.

Error

This parameter specifies the expected percent error in Energy Counting mode.

Syntax:

+Error[sp]=[sp]dim quan

dim quan ::= numeric value[sp][prefix]%

Rules:

  1. When Error is specified it must be the evaluation quantity.

Frequency

This parameter specifies the fundamental frequency.

Syntax:

Frequency[sp]=[sp]dim quan

dim quan ::= numeric value[sp][prefix]Hz

Rules:

  1. When the frequency is greater than 850 Hz, no channel may specify Harmonics mode.

GatingPullupResistance

This parameter specifies the gating pullup resistance for Energy Counting mode.

Syntax:

GatingPullupResistance[sp]=[sp]value

value ::= numeric value[sp][prefix]Ohm[s]

Rules:

  1. Legal values are 150 Ohms and 1 kOhm.

GatingsignalLevel

This parameter specifies the gating signal level for Energy Counting mode.

Syntax:

GatingsignalLevel[sp]=[sp]value

value ::= High | Low

Rules:

  1. If not specified, the default is Low.

GatingsignalType

This parameter specifies the gating signal type for Energy Counting mode.

Syntax:

GatingsignalType[sp]=[sp]value

value ::= Pulse | Puls | Level | Lev

Rules:

  1. If not specified, the default is Level.

Local

This action puts the calibrator in local mode.

Syntax:

Local

Rules:

  1. When Local is specified, no other parameters may be specified.

Examples:

Local

MaintainVoltage

This parameter specifies whether or not to set the instrument to standby when Energy Counting is complete.

Syntax:

MaintainVoltage

Rules:

  1. If not specified, the default is Standby when Energy Counting is complete.

See Also:

SetupReset

Measure

This action sets up and initiates Energy Counting. When energy counting is complete, the measurement designated by the Evaluation Quantity is returned in memory register MEM.

Syntax:

Measure

Rules:

  1. When Energy Counting is specified, and no action is specified, Measure is the default.
  2. When Measure is specified, no other action may be specified.

Examples:

Measure

Operate

This parameter turns the output on.

Syntax:

Operate

Rules:

  1. When Operate is specified, no other parameters are allowed.

Examples:

Operate

OutputConstant

This parameter specifies the conversion constant for the Pulse Output.

Syntax:

OutputConstant[sp]=[sp]numeric value[sp][prefix]units

units ::= i/Wh | Wh/i

OutputROscillator

This parameter specifies the state of the instrument's reference oscillator signal.

Syntax:

OutputROscillator[sp]=[sp]value

value ::= On | Off

Rules:

  1. If not specified, the default is off.

OutputRampTime

This parameter specifies the output ramp time.

Syntax:

OutputRampTime[sp]=[sp]dim quan

dim quan ::= numeric value[sp][prefix]s

Rules:

  1. Legal values are 0 to 10 s.
  2. If not specified, the default is 10 ms.

Examples:

OutputRampTime = 2 s

OutputSense

This parameter specifies the state of the instrument's sense capability for all voltage channels.

Syntax:

OutputSense[sp]=[sp]value

value ::= On (4-wire) | Off (2-wire)

Rules:

  1. If not specified, the default is on.

PulseCounts

This parameter specifies the expected pulse counts in Energy Counting mode.

Syntax:

+PulseCounts[sp]=[sp]dim quan

dim quan ::= numeric value[sp][prefix]count[s]

Rules:

  1. When PulseCounts is specified it must be the evaluation quantity.

Read

This action initiates Energy Counting.When energy counting is complete, the measurement designated by the Evaluation Quantity is returned in memory register MEM.

Syntax:

Read

Rules:

  1. When Read is specified, no other action may be specified.

Examples:

Read

ReferenceConstant

This parameter specifies the reference conversion constant for Energy Counting mode.

Syntax:

ReferenceConstant[sp]=[sp]numeric value[sp][prefix]units

units ::= i/Wh | Wh/i

ReferenceInputFilter

This parameter specifies whether or not to enable reference input de-bounce for Energy Counting mode.

Syntax:

ReferenceInputFilter

Rules:

  1. If not specified, the default is disable de-bounce.

ReferenceOutput

This parameter specifies the Reference Output frequency.

Syntax:

ReferenceOutput[sp]=[sp]dim quan

dim quan ::= value[sp][prefix]Hz

value ::= numeric value

Rules:

  1. Legal values are 10 and 20 MHz.
  2. If not specified, the default is off.

ReferencePullupResistance

This parameter specifies the reference pullup resistance for Energy Counting mode.

Syntax:

ReferencePullupResistance[sp]=[sp]value

value ::= numeric value[sp][prefix]Ohm[s]

Rules:

  1. Legal values are 150 Ohms and 1 kOhm.

ReferenceSource

This parameter specifies the reference source for Energy Counting mode.

Syntax:

ReferenceSource[sp]= [sp]value

value ::= Ch6 | SumCh456 | MeanCh456 | MeanCh56 | Main

Rules:

  1. If not specified, the default Main.

Registration

This parameter specifies the expected percent registration in Energy Counting mode.

Syntax:

+Registration[sp]=[sp]numeric value[sp][prefix]%

Rules:

  1. When Registration is specified it must be the evaluation quantity.

Reset

Syntax:

Reset

Rules:

  1. When Reset is specified, no other parameters are allowed.

Examples:

Reset

Setup

This action causes the instrument to be setup only.

Syntax:

Setup

Rules:

  1. When Setup is specified, no other action may be specified.

Examples:

Setup

SetupReset

This parameter specifies whether the instrument is reset before each Apply or Setup action.

Syntax:

SetupReset[sp]=[sp]value

value ::= On | Off

Rules:

  1. If not specified, the default is on.

See Also:

MaintainVoltage

TestDuration

This parameter specifies the Energy Counting test duration.

Syntax:

TestDuration[sp]=[sp]numeric value[sp][prefix][units]

Rules:

  1. Legal units are s, minute, minutes, hour, hours, c (cyles/pulses), and Wh.
  2. Legal values are 2 to 2E+6 seconds.

TestPulseSource

This parameter specifies the test pulse source for Energy Counting mode.

Syntax:

TestPulseSource[sp]=[sp]value

value ::= Ch1 | Ch6 | SumCh456 | MeanCh456 | MeanCh56 | Main

Rules:

  1. If not specified, the default is Ch1.

UseInternalPullup

This parameter specifies whether the Pulse Output uses the internal pullup resistor.

Syntax:

UseInternalPullup

UUT_Constant

This parameter specifies the MUT conversion constant for Energy Counting mode.

Syntax:

UUT_Constant[sp]=[sp]numeric value[sp][prefix]units

units ::= i/Wh | Wh/i

UUT_InputFilter

This parameter specifies whether or not to enable MUT input de-bounce for Energy Counting mode.

Syntax:

UUT_InputFilter

Rules:

  1. If not specified, the default is disable de-bounce.

UUT_PullupResistance

This parameter specifies the MUT pullup resistance for Energy Counting mode.

Syntax:

UUT_PullupResistance[sp]=[sp]value

value ::= numeric value[sp][prefix]Ohm[s]

Rules:

  1. Legal values are 150 Ohms and 1 kOhm.

WarmupDuration

This parameter specifies the Energy Counting warm-up duration.

Syntax:

WarmupDuration[sp]=[sp]numeric value[sp][prefix][units]

Rules:

  1. Legal units are s, minute, minutes, hour, hours, c (cyles/pulses), and Wh.
  2. Legal values are 2 to 2E+6 seconds.

WarmupPulseSource

This parameter specifies the warm-up pulse source for Energy Counting mode.

Syntax:

WarmupPulseSource[sp]=[sp]value

value ::= Ch1 | Ch6 | SumCh456 | MeanCh456 | MeanCh56 | Main

Rules:

  1. If not specified, the default Ch1.

Examples

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
#
# ----- DC Voltage (Voltage Channel) -----
#
  1.006  RSLT         =
  1.007  HEAD         DC VOLTAGE:{ 20 V Range}
  1.008  TARGET
  1.009  6100B        +L1VDC = 5.0V
  1.010  MEMI         Enter UUT reading in volts DC:
  1.011  MEMCX  20    5.0V           2% 0.5U
#
# ----- DC Current (Current Channel) -----
#
  2.001  HEAD         DC CURRENT:{ 5 A Range}
  2.002  TARGET       -p
  2.003  IEEE2        CURR:MODE:ELEM1 DC
  2.004  IEEE2        CURR:RANGE:ELEM1 5
  2.005  6100B        +L1IDC = 5.0000A
  2.006  WAIT         [D1000]
  2.007  TARGET       -m
  2.008  IEEE2        [D500]MEAS:VAL?[I$]
  2.009  MATH         MEM = FLD(MEM2, 2, ",")
  2.010  MEMCX  5     5.0000A        0.04% 0.08/
#
# ----- DC Voltage (Current Channel), UUT input is 1 mV/A -----
#
  3.001  RSLT         =
  3.002  HEAD         DC CURRENT:{ 2000 A Range}
# Get 6100B current channel accuracy and convert to ppm.
  3.003  MATH         S[1] = "Fluke 6100B"
  3.004  MATH         L[1] = ACCV(S[1], "DC 10V AUX", 1) * 1e6
  3.005  TARGET
  3.006  6100B        +L1IDC = 1000mV
  3.007  ACC          1000A          L1P%
  3.008  MEMI         Enter UUT reading in amps DC.
  3.009  MEMCX  2000  1000A          2% 4U
#
# ----- AC Voltage (Voltage Channel) -----
#
  4.001  RSLT         =
  4.002  HEAD         AC VOLTAGE:{ 200 V Range}
  4.003  TARGET
  4.004  6100B        +L1VAC = 130.0V; Freq = 60Hz
  4.005  MEMI         Enter UUT reading in volts RMS:
  4.006  MEMCX  200   130.0V         0.5% 0.2U     60H
#
# ----- AC Current (Current Channel) -----
#
  5.001  HEAD         AC CURRENT:{ 10 A Range}
  5.002  TARGET       -p
  5.003  IEEE2        CURR:MODE:ELEM1 RMS
  5.004  IEEE2        CURR:RANGE:ELEM1 10
  5.005  6100B        +L1IAC = 10.000A @Freq = 50Hz
  5.006  WAIT         [D1000]
  5.007  TARGET       -m
  5.008  IEEE2        [D500]MEAS:VAL?[I$]
  5.009  MATH         MEM = FLD(MEM2, 2, ",")
  5.010  MEMCX  10    10.000A        0.03% 0.05/   50H
#
# ----- AC Voltage (Current Channel), UUT input is 1 mV/A -----
#
  6.001  RSLT         =
  6.002  HEAD         AC CURRENT:{ 1000 A Range}
# Get 6100B current channel accuracy and convert to ppm.
  6.003  MATH         L[1] = ACCV2(S[1], "Sine 1.5V AUX", 670e-3, 60)
  6.004  MATH         M[1] = (M[1] / 670e-3) * 1e6
  6.005  TARGET
  6.006  6100B        +L1IAC = 670mV; Freq = 60Hz
  6.007  ACC          670A           M1P%
  6.008  MEMI         Enter UUT reading in amps RMS.
  6.009  MEMCX  1000  670A           0.5% 3U       60H
#
# ----- DC Power (Current Channel Current)
#
  7.001  RSLT         =
  7.002  HEAD         DC POWER:{ 60 V, 1 A}
  7.003  TARGET       -p
  7.004  IEEE2        VOLT:RANGE:ELEM[M14] 60
  7.005  IEEE2        VOLT:MODE:ELEM[M14] DC
  7.006  IEEE2        CURR:RANGE:ELEM[M14] 1
  7.007  IEEE2        CURR:MODE:ELEM[M14] DC
  7.008  6100B        L1VDC = 60V L1IDC = 1A
  7.008  6100B        +L1Power = 60.00W
  7.009  TARGET       -m
  7.010  IEEE2        [D500]MEAS:VAL?[I$]
  7.011  MATH         MEM = FLD(MEM2, 3, ",")
  7.012  MEMCX  60    W              0.08% 0.12/
#
# ----- AC Power (Current Channel Current)
#
  8.001  MEM2         =
  8.002  HEAD         AC POWER:{ PF -0.5}
  8.003  TARGET
  8.004  6100B        L1VAC = 100V L1IAC = 5A
  8.004  6100B        +L1Power = 250.00W Freq = [M15]Hz L1IPhase = 120deg
  8.005  MEMI         Enter UUT reading in watts.
  8.006  MEMCX  250   W              0.04% 0.04/   #
  9.001  MEM2         =100 V, 2 A @ 400 Hz, Phase 45 deg
  9.002  HEAD         AC POWER:{ 100 V, 2 A @ 400 Hz, Phase 45 deg}
  9.003  TARGET       -p
  9.004  6100B        CurrHarmUnits = PRMS
  9.004  6100B        Freq = 400Hz
  9.004  6100B        L1VRMSAmpl = 100V
  9.004  6100B        L1IRMSAmpl = 2A
  9.004  6100B        L1IPhase = 45deg
  9.004  6100B        L1IAmplHarm3 = 20%
  9.004  6100B        L1IAmplHarm15 = 5%
  9.004  6100B        +L1Power = 138.376W
  9.005  TARGET       -m
  9.006  IEEE2        [D500]MEAS:VAL?[I$]
  9.007  MATH         MEM = FLD(MEM2, 3, ",")
  9.008  MEMCX  138.4 W              0.169U        400H
#
# ----- AC Power (Current Channel Voltage), UUT input is 1 mV/A
#
 10.001  RSLT         =
 10.002  RSLT         =100 V, 150 A @ 60 Hz
# Get 6100B voltage channel accuracy and convert to ppm.
 10.003  MATH         L[1] = ACCV2(S[1], "Sine 168V", 100, 60)
 10.004  MATH         M[1] = (L[1] / 100) * 1e6
# Get 6100B current channel accuracy and convert to ppm.
 10.005  MATH         L[2] = ACCV2(S[1], "Sine 0.25V AUX", 150e-3, 60)
 10.006  MATH         M[2] = (M[2] / 150e-3) * 1e6
# Convert phase to radians.
 10.007  MATH         L[4] = RAD(157)
# Get 6100B current to voltage channel phase accuracy and convert to ppm.
 10.008  MATH         L[5] = ACCV2(S[1], "Phase I-V 0.25V V>40%", 150e-3, 60)
# Convert to ppm.
 10.009  MATH         L[3] = (1 - COS(L[4] + RAD(L[5])) / COS(L[4])) * 1e6
# Calculate RSS of voltage channel, current channel, and phase accuracies.
 10.010  MATH         M[1] = RSS3(L[1], L[2], L[3])
 10.011  TARGET
 10.012  6100B        L1VAC = 100V; L1IAC = 150mV; Freq = 60Hz
 10.012  6100B        +L1Power = 13.8kW; L1IPhase = 157deg
 10.013  ACC          -13.8kW        M1P%
 10.014  MEMI         Enter UUT reading in kilowatts.
 10.015  MEMCX        -13.8kW        1% 0.4U       60H
 11.001  6100B        L1VAC = 100V; L1IAC = 150mV; Freq = 60Hz
 11.001  6100B        +L1Power = 15.0kVA; L1IPhase = 157deg
 11.002  ACC          15.0kVA        M1P%
 11.003  MEMI         Enter UUT reading in kilovolt-amps.
 11.004  MEMCX        15.0kVA        1% 0.4U       60H
 12.001  6100B        L1VAC = 100V; L1IAC = 150mV; Freq = 60Hz
 12.001  6100B        +L1Power = 5.9kVAR; L1IPhase = 157deg
 12.002  ACC          5.9k'VAR'      M1P%
 12.003  MEMI         Enter UUT reading in units of kVAR.
 12.004  MEMCX        5.9k'VAR'      1% 0.4U       60H
#
# ----- Harmonic Amplitude -----
#
 13.001  RSLT         =
 13.002  HEAD         HARMONICS:{ 10.000 V @ 100 Hz, Harmonic 25}
 13.003  TARGET       -p
 13.004  6100B        L1VRange = 180V L1IRange = 21A
 13.004  6100B        L1VAmplHarm1 = 100V L1IRMSAmpl = 10A
 13.004  6100B        +L1VAmplHarm25 = 10.000V Freq = 100Hz
 13.005  TARGET       -m
 13.006  IEEE2        [D500]MEAS:VAL?[I$]
 13.007  MATH         MEM = FLD(MEM2, 26, ",")
 13.008  MEMCX  168   10.000V        2.0% 0.05/    2.5kH
#
# ----- Flicker Analysis -----
#
 14.001  RSLT         =
 14.002  HEAD         {FLICKER ANALYSIS}
 14.003  TSET         TDESC = [MEM2]
 14.004  6100B        L1VAC = 230V
 14.004  6100B        Frequency = 50Hz
 14.004  6100B        L1VFlickerShape = Square
 14.004  6100B        L1VFlickerFreq = 58.3mHz
 14.004  6100B        L1VFlickerDepth = 1.459%
 14.004  6100B        +L1VFlickerPST = 1
 14.005  IEEE2        FLICKER:INIT
 14.006  WAIT         -t 30 Waiting for UUT...
 14.007  IEEE2        FLICKER:START
 14.008  WAIT         -t 10:10 Waiting for UUT...
 14.009  TARGET       -m
 14.010  IEEE2        [D500]MEAS:VAL?[I$]
 14.011  MATH         MEM = FLD(MEM2, 9, ",")
 14.012  MEMCX  1     ''             0.05U         58.3mH
#
# ----- Energy Counting using RM-10 -----
#
 15.001  RSLT         =
 15.002  HEAD         {COUNTED/TIMED MODE}
 15.003  RSLT         =
 15.004  HEAD         -2{ Accumulated Energy}: Wh
 15.005  RSLT         =[32] Watt-hour
 15.006  TARGET       -p
 15.007  DISP         Connect the 6105A to the UUT as follows:
 15.007  DISP
 15.007  DISP         [32] 6105A                            UUT
 15.007  DISP         [32] VOLTAGE OUTPUT HI -------------- POTENTIAL
 15.007  DISP         [32] VOLTAGE OUTPUT LO -------------- POTENTIAL O
 15.007  DISP
 15.007  DISP         [32] CURRENT OUTPUT HI -------------- A CURRENT
 15.007  DISP         [32] CURRENT OUTPUT LO -------------- A O
 15.007  DISP
 15.007  DISP         [32] ENERGY INPUTS 1 ---------------- OUTPUT
 15.007  DISP
 15.007  DISP         [32] ENERGY GATE IN/OUT (on rear) --- INPUT
 15.007  DISP
 15.007  DISP         Connect line power to UUT AUXILIARY POWER.
 15.008  DISP         Press UUT SELECT button until "WATT HOUR" is displayed.
 15.008  DISP
 15.009  DISP         Press RESET on the UUT.
 15.010  TARGET       -m
 15.011  6105A        EnergyMode = CountedTimed
 15.011  6105A        L1VAC = 120 V; L1IAC = 5 A; Freq = 60 Hz
 15.011  6105A        WarmupDuration = 3 s; TestDuration = 6 s
 15.011  6105A        UUT_Constant = 0.00001 Wh/i
 15.011  6105A        +Energy = 1.00000 Wh; Measure
 15.012  MEMC         Wh             .05% .00000U
 16.001  HEAD         -2 Accumulated Energy: VAh
 16.002  RSLT         =[32] Volt-Amp-hour
 16.003  TARGET
 16.004  6105A        EnergyMode = CountedTimed
 16.004  6105A        L1VAC = 120 V; L1IAC = 5 A; Freq = 60 Hz
 16.004  6105A        WarmupDuration = 3 s; TestDuration = 6 s
 16.004  6105A        UUT_Constant = 0.00001 Wh/i
 16.004  6105A        +Energy = 1.00000 VAh; Measure
 16.005  MEMC         VAh            .05% .00000U
 17.001  HEAD         -2 Accumulated Energy: VARh
 17.002  RSLT         =[32] VAR-hour
 17.003  TARGET       -p
 17.004  DISP         Press UUT SELECT button until "VAR HOUR" is displayed.
 17.004  DISP
 17.005  TARGET       -m
 17.006  6105A        EnergyMode = CountedTimed
 17.006  6105A        L1VAC = 120 V; L1IAC = 5 A; Freq = 60 Hz
 17.006  6105A        L1IPhase = -90 deg
 17.006  6105A        WarmupDuration = 3 s; TestDuration = 6 s
 17.006  6105A        UUT_Constant = 0.00001 Wh/i
 17.006  6105A        +Energy = 1.00000 VARh; Measure
 17.007  MEMC         VARh           .05% .00000U
 18.001  HEAD         -2 Accumulated Energy: % Error
 18.002  RSLT         =[32] % Error
 18.003  TARGET       -p
 18.004  DISP         Press UUT SELECT button until "WATT HOUR" is displayed.
 18.004  DISP
 18.005  TARGET       -m
 18.006  6105A        EnergyMode = CountedTimed
 18.006  6105A        L1VAC = 120 V; L1IAC = 5 A; Freq = 60 Hz
 18.006  6105A        WarmupDuration = 3 s; TestDuration = 6 s
 18.006  6105A        UUT_Constant = 0.00001 Wh/i
 18.006  6105A        +Error = 0.00 %; Measure
 18.007  MEMC         0.00'%'        0.05U
 19.001  HEAD         -2 Accumulated Energy: % Registration
 19.002  RSLT         =[32] % Registration
 19.003  TARGET
 19.004  6105A        EnergyMode = CountedTimed
 19.004  6105A        L1VAC = 120 V; L1IAC = 5 A; Freq = 60 Hz
 19.004  6105A        WarmupDuration = 3 s; TestDuration = 6 s
 19.004  6105A        UUT_Constant = 0.00001 Wh/i
 19.004  6105A        +Registration = 100.00 %; Measure
 19.005  MEMC         100.00'%'      0.05U
 20.001  HEAD         -2 Accumulated Energy: Wh using Gate Output
 20.002  RSLT         =[32] Watt-hour using Gate Output
 20.003  TARGET
 20.004  DISP         Press RESET on the UUT.
 20.005  6105A        EnergyMode = CountedTimed
 20.005  6105A        L1VAC = 120 V; L1IAC = 5 A; Freq = 60 Hz
 20.005  6105A        WarmupDuration = 3 s; TestDuration = 6 s
 20.005  6105A        GatingSignalType = Pulse; GatingSignalLevel = High
 20.005  6105A        UUT_Constant = 0.00001 Wh/i
 20.005  6105A        +Energy = 1.00000 Wh; Measure
 20.006  MEMI         Enter UUT reading in watt-hours.
 20.007  MEMC         1.00000Wh      .05% .00000U
 21.001  RSLT         =
 21.002  HEAD         -2{ Pulse Counts}
 21.003  TARGET
 21.004  6105A        EnergyMode = CountedTimed
 21.004  6105A        L1VAC = 120 V; L1IAC = 5 A; Freq = 60 Hz
 21.004  6105A        WarmupDuration = 3 s; TestDuration = 6 s
 21.004  6105A        UUT_Constant = 0.00001 Wh/i
 21.004  6105A        +PulseCounts = 100000 counts; Measure
 21.005  MEMC         counts         0.05% 0U
 22.001  HEAD         -2 Pulse Counts: Using Gate Output
 22.002  RSLT         =[32] Pulse Counts using Gate Output
 22.003  TARGET
 22.004  DISP         Press RESET on the UUT.
 22.005  6105A        EnergyMode = CountedTimed
 22.005  6105A        L1VAC = 120 V; L1IAC = 5 A; Freq = 60 Hz
 22.005  6105A        WarmupDuration = 3 s; TestDuration = 6 s
 22.005  6105A        GatingSignalType = Pulse; GatingSignalLevel = High
 22.005  6105A        UUT_Constant = 0.00001 Wh/i
 22.005  6105A        +PulseCounts = 100000 counts; Measure
 22.006  MEMC         counts         0.05% 0U
 23.001  END


7526A

Instrument FSC

Description

The 7526A FSC controls the Fluke 7526A Precision Process Calibrator.

If the 7526A is to be controlled via its serial port, do not use the PORT FSC port configuration special construction, [P9600,N,...], to set the baud rate, parity, etc. of the port used to control the 7526A. MET/CAL executes a "Test" function for each System Instrument prior to executing any procedure statements, therefore the settings of the port used to controlling the 7526A must be set correctly before a procedure is executed. If the 7526A is connected to a standard serial port (COM1, COM2, ..., COM16), select the "Ports" application in the Windows control panel to choose the proper settings.

Parameters

An NVI FSC statement consists of one or more parameters. A parameter consists of a name and a value. Each parameter must be separated by a semicolon and/or one or more spaces. A single NVI FSC statement can encompass more than one physical line as long as the line numbers are the same. However each parameter name and its value must occur on one line. A single line can accommodate up to 256 characters including the statement number and FSC. Note that characters above ASCII 128 count as 2 characters.

Syntax:

parameter[separatorparameter]

parameter::= [parameter_prefix]parameter_name[[sp]=[sp]parameter_value]

separator::= ;[sp] | sp

parameter_prefix ::=+ | @

sp::= one or more spaces

parameter_name::= see the Parameter Names section

parameter_value::=dimensionless number | dimensioned number | discrete_list

dimensionless number::=NRf

dimensioned number::=NRf[sp][prefix]units

discrete_list::=see the Parameter Names section

prefix::=y | z | a | f | p | n | u | m | k | M | G | T | P | E | Z | Y

Definitions:

|
Denotes "or" (i.e. A | B is A or B)
[ ]
Denotes an optional syntax element, except in examples. In examples [ ] enclose a special construction.
+
Designates the parameter as the Evaluation Quantity
@
Designates the parameter as the Modifier Quantity

Examples:

The following three 7526A statements are identical with respect to the 7526A:

Statement #1

1.001 7526A +Voltage = 100.0V

Statement #2

1.002 7526A Mode = DC_Voltage; +Volt = 100.0 V

Statement #3

  1.003  7526A        Apply
  1.003  7526A        Mode = DC_Volt
  1.003  7526A        +Voltage = 100.0 V

Rules:

  1. One and only one parameter must be designated as the Evaluation Quantity in a 7526A Apply, Measure, Read, Setup, or Slew statement.
  2. At most one parameter may be designated as the Modifier Quantity in a 7526A Apply, Measure, Read, Setup, or Slew statement.
  3. Parameter values may be taken from a MET/CAL memory register or named variables using a special construction.
  4. When a 7526A Measure or Read statement is executed, the reading associated with the evaluation quantity is copied to memory register MEM in specified units.
  5. In combination modes, the primary output or reading is copied to MEM1 in specified units.
  6. In combination modes the reference accuracy is the RSS of the primary and isolated accuracy.

Example:

1.001 7526A +Resistance = 100Ohms; Measure

The 7526A read 99.98 Ohms. After the 7526A statement is executed the value of MEM is 99.98.

Example:

  1.004  7526A        Temperature = 100 degC; TC_Type = J
  1.004  7526A        +IsolatedCurrent = 12.0 mA; LoopPower = On; Measure

The 7526A read 11.9 mA. After the 7526A statement is executed the value of MEM is 11.9, MEM1 is 100.

When a 7526A Apply, Setup, or Operate statement is executed, the value of the Evaluation Quantity is copied to memory register MEM1 in specified units.

Example:

  1.005  7526A        +Volt = 100 mV; Setup
  1.006  7526A        +Volt = 100 mV; Operate

After the 7526A Operate statement is executed the value of MEM1 is 100.

When a 7526A Slew statement is executed, the Evaluation Quantity designates the slew quantity.

When a 7526A Slew statement is executed, the final slew value is copied to memory register MEM in units of the Evaluation Quantity.

Example:

1.001 7526A +Curr = 20mA; Slew

Operator slews the 7526A output to 24.1 mA.

After the 7526A Slew statement is executed the value of MEM is 24.1.

When a 7526A Slew statement is executed, the Modifier Quantity is concatenated to the Evaluation Quantity in the automatic slew message. Note, the automatic slew message is not displayed when ASK- N is in effect.

Examples:

  1.008  ASK+         N
  1.009  7526A        +Volt = 100V; Slew

"Adjust stimulus for a UUT reading of 100 V."

No Modifier Quantity designated.

1.010 7526A Mode = DC_Volt; +Volt = 100V; Slew

"Adjust stimulus for a UUT reading of 100 V."

Automatic slew message inhibited.

  1.011  ASK-         N
  1.012  7526A        +Volt = 100V; Slew

No automatic slew message generated, use MESS FSC.

Parameter Names

Parameter names consist of single words or compound words. Each word in a parameter name can be entered in long form (as shown below), or in short form. The short form is the first 4 characters of the long form, with the following exceptions:

  1. If the long form is greater than four characters, and the last character or the short form is a vowel, the short form is three characters.
  2. If the long form is four characters or less, the short form is the long form even if it ends in a vowel.

Compound parameter names can be entered in any combination of long and short forms. Example, ExternalReference can be entered using any of the following forms:

  • IsolatedCurrent
  • IsoltatedCurr
  • IsolCurrent
  • IsolCurr

Action Parameters

  • Apply
  • Local
  • Measure
  • Monitor
  • Operate
  • Query
  • Read
  • Reset
  • Setup
  • Slew
  • Standby
  • Start
  • Zero

General Parameters

  • Current
  • Curve
  • HartResistor
  • IsolatedCurrent
  • IsolatedPressure
  • IsolatedRange
  • IsolatedReferenceTemperature
  • IsolatedVoltage
  • LoopPower
  • Mode
  • NominalResistance
  • Pressure
  • PressureModule
  • Range
  • ReferenceTemperature
  • Resistance
  • RTD_Type
  • SwitchState
  • TC_Reference
  • TC_Type
  • Temperature
  • Voltage

Instrument Mode

If Mode is not specified, MET/CAL determines the mode based on occurrence of the following parameters in the 7526A statement:

Parameters | Action | Mode
Voltage | na | DC_Voltage
Current | na | DC_Current
Resistance | Apply, Setup, or not specified | RTD_Out
Resistance | Measure, Monitor, or Read | RTD_In
Temperature and RTD_Type | Apply, Setup, or not specified | RTD_Out
Temperature and RTD_Type | Measure, Monitor, or Read | RTD_In
Temperature and TC_Type | Apply or not specified | TC_Out
Temperature and TC_Type | Measure, Monitor, or Read | TC_In
Voltage and TC_Type | Apply or not specified | TC_Out
Voltage and TC_Type | Measure, Monitor, or Read | TC_In
Pressure | na | Pressure
IsolatedVoltage | na | IsolatedVoltage
IsolatedCurrent | na | IsolatedCurrent
IsolatedPressure | na | IsolatedPressure
Voltage and IsolatedVoltage | na | DC_VoltageIsolatedVoltage
Voltage and IsolatedCurrent | na | DC_VoltageIsolatedCurrent
Voltage and IsolatedPressure | na | DC_VoltageIsolatedPressure
Current and IsolatedVoltage | na | DC_CurrentIsolatedVoltage
Current and IsolatedCurrent | na | DC_CurrentIsolatedCurrent
Current and IsolatedPressure | na | DC_CurrentIsolatedPressure
Resistance and IsolatedVoltage | na | RTD_OutIsolatedVoltage
Resistance and IsolatedCurrent | na | RTD_OutIsolatedCurrent
Resistance and IsolatedPressure | na | RTD_OutIsolatedPressure
Temperature, RTD_Type, and IsolatedVoltage | na | RTD_OutIsolatedVoltage
Temperature, RTD_Type, and IsolatedCurrent | na | RTD_OutIsolatedCurrent
Temperature, RTD_Type, and IsolatedPressure | na | RTD_OutIsolatedPressure
Temperature, TC_Type, and IsolatedVoltage | na | TC_OutIsolatedVoltage
Temperature, TC_Type, and IsolatedCurrent | na | TC_OutIsolatedCurrent
Temperature, TC_Type, and IsolatedPressure | na | TC_OutIsolatedPressure
Pressure and IsolatedVoltage | na | PressureIsolatedVoltage
Pressure and IsolatedCurrent | na | PressureIsolatedCurrent
Pressure and IsolatedPressure | na | PressureIsolatedPressure

Mode/Parameter Rules

DC VOLTAGE SOURCE

Mode = DC_Voltage

Required Parameters

  • Voltage
Optional Parameters | Default
Mode | DC_Voltage
Range | autorange
Apply | Setup | Operate | Slew | Apply

DC CURRENT SOURCE

Mode = DC_Current

Required Parameters

  • Current
Optional Parameters | Default
Mode | DC_Current
Apply | Setup | Operate | Slew | Apply

RESISTANCE SOURCE

Mode = RTD_Out

Required Parameters

  • Resistance
  • Range
Optional Parameters | Default
Mode | RTD_Out
Apply | Setup | Operate | Apply

RESISTANCE MEASUREMENT

Mode = RTD_In

Required Parameters

  • Mode
  • Range
  • Resistance
  • Measure | Monitor | Read | Zero
Optional Parameters | Default
Range | Based on Resistance

RTD SOURCE

Mode = RTD_Out

Required Parameters

  • Temperature
  • RTD_Type
  • NominalResistance 1
  • Curve 2
Optional Parameters | Default
Mode | RTD_Out
Apply | Setup | Operate | Apply

RTD MEASUREMENT

Mode = RTD_In

Required Parameters

  • Mode
  • Temperature
  • RTD_Type
  • NominalResistance 1
  • Curve 2
  • Measure | Monitor | Read

TC SOURCE

Mode = TC_Out

Required Parameters

  • Temperature | Voltage
  • TC_Type
Optional Parameters | Default
Mode | TC_Out
TC_Reference | Internal
Apply | Apply

TC MEASUREMENT

Mode = TC_In

Required Parameters

  • Mode
  • Temperature | Voltage
  • TC_Type
  • Measure | Monitor | Read | Zero 1
  1. Zero is only legal for voltage
Optional Parameters | Default
TC_Reference | Internal

PRESSURE MEASUREMENT

Mode = Pressure

Required Parameters

  • Pressure
  • PressureModule
  • Measure | Monitor | Read | Zero
Optional Parameters | Default
Mode | Pressure
ReferenceTemperature 3 | na

ISOLATED VOLTAGE MEASUREMENT

Mode = IsolatedVoltage

Required Parameters

  • IsolatedVoltage
  • Range
  • Measure | Monitor | Read
Optional Parameters | Default
Mode | IsolatedVoltage

ISOLATED CURRENT MEASUREMENT

Mode = IsolatedCurrent

Required Parameters

  • IsolatedCurrent
  • Measure | Monitor | Read
Optional Parameters | Default
Mode | IsolatedCurrent
HartResistor | Off
LoopPower | Off

ISOLATED PRESSURE MEASUREMENT

Mode = IsolatedPressure

Required Parameters

  • IsolatedPressure
  • PressureModule
  • Measure | Monitor | Read
Optional Parameters | Default
Mode | IsolatedPressure
IsolatedReferenceTemperature 3 | na

DC VOLTAGE SOURCE & ISOLATED VOLTAGE MEASUREMENT

Mode = DC_VoltageIsolatedVoltage

Required Parameters

  • Voltage
    • IsolatedVoltage
    • IsolatedRange
  • Measure | Operate | Read
Optional Parameters | Default
Mode | DC_VoltageIsolatedVoltage
Range | autorange

DC VOLTAGE SOURCE & ISOLATED CURRENT MEASUREMENT

Mode = DC_VoltageIsolatedCurrent

Required Parameters

  • Voltage
    • IsolatedCurrent
  • Measure | Operate | Read
Optional Parameters | Default
Mode | DC_VoltageIsolatedCurrent
Range | autorange
HartResistor | Off
LoopPower | Off

DC VOLTAGE SOURCE & ISOLATED PRESSURE MEASUREMENT

Mode = DC_VoltageIsolatedPressure

Required Parameters

  • Voltage
    • IsolatedPressure
    • PressureModule
  • Measure | Operate | Read
Optional Parameters | Default
Mode | DC_VoltageIsolatedPressure
Range | autorange
IsolatedReferenceTemperature 3 | na

DC CURRENT SOURCE & ISOLATED VOLTAGE MEASUREMENT

Mode = DC_CurrentIsolatedVoltage

Required Parameters

  • Current
    • IsolatedVoltage
    • IsolatedRange
  • Measure | Operate | Read
Optional Parameters | Default
Mode | DC_CurrentIsolatedVoltage

DC CURRENT SOURCE & ISOLATED CURRENT MEASUREMENT

Mode = DC_CurrentIsolatedCurrent

Required Parameters

  • Current
    • IsolatedCurrent
  • Measure | Operate | Read
Optional Parameters | Default
Mode | DC_CurrentIsolatedCurrent
HartResistor | Off
LoopPower | Off

DC CURRENT SOURCE & ISOLATED PRESSURE MEASUREMENT

Mode = DC_CurrentIsolatedPressure

Required Parameters

  • Current
    • IsolatedPressure
    • PressureModule
  • Measure | Operate | Read
Optional Parameters | Default
Mode | DC_CurrentIsolatedPressure
HartResistor | Off
LoopPower | Off
IsolatedReferenceTemperature 3 | na

RESISTANCE SOURCE & ISOLATED VOLTAGE MEASUREMENT

Mode = RTD_OutIsolatedVoltage

Required Parameters

  • Resistance
  • Range
    • IsolatedVoltage
    • IsolatedRange
  • Measure | Operate | Read
Optional Parameters | Default
Mode | RTD_OutIsolatedVoltage

RESISTANCE SOURCE & ISOLATED CURRENT MEASUREMENT

Mode = RTD_OutIsolatedCurrent

Required Parameters

  • Resistance
  • Range
    • IsolatedCurrent
  • Measure | Operate | Read
Optional Parameters | Default
Mode | RTD_OutIsolatedCurrent
HartResistor | Off
LoopPower | Off

RESISTANCE SOURCE & ISOLATED PRESSURE MEASUREMENT

Mode = RTD_OutIsolatedPressure

Required Parameters

  • Resistance
  • Range
    • IsolatedPressure
    • PressureModule
  • Measure | Operate | Read
Optional Parameters | Default
Mode | RTD_OutIsolatedPressure
IsolatedReferenceTemperature 3 | na

RESISTANCE MEASUREMENT & ISOLATED VOLTAGE MEASUREMENT

Mode = RTD_InIsolatedVoltage

Required Parameters

  • Mode
  • Resistance
  • Range
    • IsolatedVoltage
    • IsolatedRange
  • Measure | Monitor | Read

RESISTANCE MEASUREMENT & ISOLATED CURRENT MEASUREMENT

Mode = RTD_InIsolatedCurrent

Required Parameters

  • Mode
  • Resistance
  • Range
    • IsolatedCurrent
  • Measure | Monitor | Read
Optional Parameters | Default
HartResistor | Off
LoopPower | Off

RESISTANCE MEASUREMENT & ISOLATED PRESSURE MEASUREMENT

Mode = RTD_InIsolatedPressure

Required Parameters

  • Mode
  • Resistance
  • Range
    • IsolatedPressure
    • PressureModule
  • Measure | Monitor | Read
Optional Parameters | Default
Mode | ResistanceIsolatedPressure
IsolatedReferenceTemperature 3 | na

RTD SOURCE & ISOLATED VOLTAGE MEASUREMENT

Mode = RTD_OutIsolatedVoltage

Required Parameters

  • Temperature
  • RTD_Type
  • NominalResistance
    • IsolatedVoltage
    • IsolatedRange
  • Measure | Operate | Read
Optional Parameters | Default
Mode | RTD_OutIsolatedVoltage

RTD SOURCE & ISOLATED CURRENT MEASUREMENT

Mode = RTD_OutIsolatedCurrent

Required Parameters

  • Temperature
  • RTD_Type
  • NominalResistance
    • IsolatedCurrent
  • Measure | Operate | Read
Optional Parameters | Default
Mode | RTD_OutIsolatedCurrent
HartResistor | Off
LoopPower | Off

RTD SOURCE & ISOLATED PRESSURE MEASUREMENT

Mode = RTD_OutIsolatedPressure

Required Parameters

  • Temperature
  • RTD_Type
  • NominalResistance
    • IsolatedPressure
    • PressureModule
  • Measure | Operate | Read
Optional Parameters | Default
Mode | RTD_OutIsolatedPressure
IsolatedReferenceTemperature 3 | na

RTD MEASURE & ISOLATED VOLTAGE MEASUREMENT

Mode = RTD_InIsolatedVoltage

Required Parameters

  • Mode
  • Temperature
  • RTD_Type
  • NominalResistance
    • IsolatedVoltage
    • IsolatedRange
  • Measure | Monitor | Read

RTD MEASURE & ISOLATED CURRENT MEASUREMENT

Mode = RTD_InIsolatedCurrent

Required Parameters

  • Mode
  • Temperature
  • RTD_Type
  • NominalResistance
    • IsolatedCurrent
  • Measure | Monitor | Read
Optional Parameters | Default
HartResistor | Off
LoopPower | Off

RTD MEASURE & ISOLATED PRESSURE MEASUREMENT

Mode = RTD_InIsolatedPressure

Required Parameters

  • Mode
  • Temperature
  • RTD_Type
  • NominalResistance
    • IsolatedPressure
    • PressureModule
  • Measure | Monitor | Read
Optional Parameters | Default
IsolatedReferenceTemperature 3 | na

TC SOURCE & ISOLATED VOLTAGE MEASUREMENT

Mode = TC_OutIsolatedVoltage

Required Parameters

  • Temperature
  • TC_Type
    • IsolatedVoltage
    • IsolatedRange
  • Measure | Monitor | Read
Optional Parameters | Default
Mode | TC_OutIsolatedVoltage
TC_Reference | Internal

TC SOURCE & ISOLATED CURRENT MEASUREMENT

Mode = TC_OutIsolatedCurrent

Required Parameters

  • Temperature
  • TC_Type
    • IsolatedCurrent
  • Measure | Monitor | Read
Optional Parameters | Default
Mode | TC_OutIsolatedCurrent
TC_Reference | Internal
HartResistor | Off
LoopPower | Off

TC SOURCE & ISOLATED PRESSURE MEASUREMENT

Mode = TC_OutIsolatedPressure

Required Parameters

  • Temperature
  • TC_Type
    • IsolatedPressure
    • PressureModule
  • Measure | Monitor | Read
Optional Parameters | Default
Mode | TC_OutIsolatedPressure
TC_Reference | Internal
IsolatedReferenceTemperature 3 | na

TC MEASURE & ISOLATED VOLTAGE MEASUREMENT

Mode = TC_InIsolatedVoltage

Required Parameters

  • Mode
  • Temperature
  • TC_Type
    • IsolatedVoltage
    • IsolatedRange
  • Measure | Monitor | Read
Optional Parameters | Default
TC_Reference | Internal

TC MEASURE & ISOLATED CURRENT MEASUREMENT

Mode = TC_InIsolatedCurrent

Required Parameters

  • Mode
  • Temperature
  • TC_Type
    • IsolatedCurrent
  • Measure | Monitor | Read
Optional Parameters | Default
TC_Reference | Internal
HartResistor | Off
LoopPower | Off

TC MEASURE & ISOLATED PRESSURE MEASUREMENT

Mode = TC_OutIsolatedPressure

Required Parameters

  • Mode
  • Temperature
  • TC_Type
    • IsolatedPressure
    • PressureModule
  • Measure | Monitor | Read
Optional Parameters | Default
TC_Reference | Internal
IsolatedReferenceTemperature 3 | na

PRESSURE MEASUREMENT & ISOLATED VOLTAGE MEASUREMENT

Mode = PressureIsolatedVoltage

Required Parameters

  • Mode
  • Pressure
  • PressureModule
    • IsolatedVoltage
    • IsolatedRange
  • Measure | Monitor | Read
Optional Parameters | Default
ReferenceTemperature 1 | na

PRESSURE MEASUREMENT & ISOLATED CURRENT MEASUREMENT

Mode = PressureIsolatedCurrent

Required Parameters

  • Mode
  • Pressure
  • PressureModule
    • IsolatedCurrent
  • Measure | Monitor | Read
Optional Parameters | Default
ReferenceTemperature 1 | na
HartResistor | Off
LoopPower | Off

PRESSURE MEASUREMENT ON PRIMARY AND ISOLATED DISPLAYS

Mode = PressureIsolatedPressure

Required Parameters

  • Mode
  • Pressure
    • IsolatedPressure
  • PressureModule
  • Measure | Monitor | Read
Optional Parameters | Default
ReferenceTemperature 1 | na
IsolatedReferenceTemperature 1 | na

DC VOLTAGE SOURCE SWITCH TEST

Mode = DC_VoltageSwitchTest

Required Parameters

  • Mode
  • Voltage
  • Start | Query
Optional Parameters | Default
Range | autorange
SwitchState 4 | na

DC CURRENT SOURCE SWITCH TEST

Mode = DC_CurrentSwitchTest

Required Parameters

  • Mode
  • Current
  • Start | Query
Optional Parameters | Default
SwitchState 4 | na

RESISTANCE SOURCE SWITCH TEST

Mode = RTD_OutSwitchTest

Required Parameters

  • Mode
  • Resistance
  • Range
  • Start | Query
Optional Parameters | Default
SwitchState 4 | na

RESISTANCE MEASUREMENT SWITCH TEST

Mode = RTD_InSwitchTest

Required Parameters

  • Mode
  • Resistance
  • Range
  • Start | Query
Optional Parameters | Default
SwitchState 4 | na

RTD SOURCE SWITCH TEST

Mode = RTD_OutSwitch Test

Required Parameters

  • Mode
  • Temperature
  • RTD_Type
  • NominalResistance 1
  • Curve 2
  • Start | Query
Optional Parameters | Default
SwitchState 4 | na

RTD MEASUREMENT SWITCH TEST

Mode = RTD_InSwitchTest

Required Parameters

  • Mode
  • Temperature
  • RTD_Type
  • NominalResistance 1
  • Curve 2
  • Start | Query
Optional Parameters | Default
SwitchState 4 | na

TC SOURCE SWITCH TEST

Mode = TC_OutSwitchTest

Required Parameters

  • Mode
  • Temperature | Voltage
  • TC_Type
  • Start | Query
Optional Parameters | Default
TC_Reference | Internal
SwitchState 4 | na

TC MEASUREMENT SWITCH TEST

Mode = TC_InSwitchTest

Required Parameters

  • Mode
  • Temperature
  • TC_Type
  • Start | Query
Optional Parameters | Default
TC_Reference | Internal
SwitchState 4 | na

PRESSURE MEASUREMENT SWITCH TEST

Mode = PressureSwitchTest

Required Parameters

  • Mode
  • Pressure
  • PressureModule
  • Start | Query
Optional Parameters | Default
Mode | Pressure
ReferenceTemperature 3 | na
SwitchState 4 | na

Footnotes

  1. Only required when Temperature is specified and RTD_Type is Pt385,Pt3626, Pt3916, Ni672, or Cu427.
  2. Only required when RTD_Type = UserDefined.
  3. Required when pressure units are [m]mHg, cmH2O, [m]mH2O, inH2O, or ftH2O.
  4. Only allowed, and required, when Action is Query.

Parameter Definitions and Values

Apply

This action sets up the instrument and enables the output.

Syntax:

Apply

Rules:

  1. When Apply is specified, no other action may be specified.
  2. After an Apply statement is executed MEM1 contains the sourced value in units of the Evaluation Quantity.

Examples:

Apply

Current

This parameter specifies the primary current.

Syntax:

[+]Current[sp]=[sp]numeric value[sp][prefix]A

Examples:

Current = 4 mA

HartResistor

This parameter turns the HART resistor on or off on the isolated milliamp range.

Syntax:

HartResistor[sp]=[sp]value

value ::= On | Off

Rules:

  1. When HartResistor is not specified, the default is Off.

Examples:

HartResistor = On

IsolatedCurrent

This parameter specifies the expected isolated current measurement.

Syntax:

[+]IsolatedCurrent[sp]=[sp]numeric value[sp][prefix]V

Examples:

+IsolatedCurrent = 20 mA

IsolatedPressure

This parameter specifies the expected pressure measurement on the Isolated display.

Syntax:

[+]IsolatedPressure[sp]=[sp]numeric value[sp][prefix]units

units ::= bar | cmH2O | ftH2O | gm/cm2 | inH2O | mH2O | mHg | Pa | psi

Rules:

  1. When units arecmH2O, ftH2O, inH2O, mH2O, or mHg, ReferenceTemperature must be specified.

Examples:

+IsolatedPressure = 1 psi

IsolatedRange

This parameter specifies the range for Isolated Voltage.

Syntax:

IsolatedRange[sp]=[sp]numeric value[sp][prefix]V

Examples:

IsolatedRange = 10 V

IsolatedReferenceTemperature

This parameter specifies the reference temperature for pressure measurement in height of mercury or water.

Syntax:

[@]IsolatedReferenceTemperature[sp]=[sp]numeric value[sp][prefix]units

units ::= degC | degF

Rules:

  1. Legal values are 0, 4, and 20 °C and 60 °F.

Examples:

+IsolatedPressure = 0 inH2O; @IsolatedReferenceTemperature = 20 degC

IsolatedVoltage

This parameter specifies the expected isolated voltage measurement.

Syntax:

[+]IsolatedVoltage[sp]=[sp]numeric value[sp][prefix]V

Examples:

+IsolatedVoltage = 100 mV

Local

This action puts the 7526A in local mode.

Syntax:

Local

Rules:

  1. When Local is specified, no other parameters may be specified.

Examples:

Local

LoopPower

This parameter turns the 14 V loop power on or off on the isolated milliamp range.

Syntax:

LoopPower[sp]=[sp]value

value ::= On | Off

Rules:

  1. When LoopPower is not specified, the default is Off.

Examples:

LoopPower = On

Measure

This action sets up the instrument and returns the reading.

Syntax:

Measure

Rules:

  1. When Measure is specified, no other action may be specified.
  2. If Mode is Primary (Source) and Isolated, the instrument is put in Operate.
  3. After a Measure statement memory registers are updated as follows:
    1. MEM contains the reading in units of the Evaluation Quantity.
    2. If Mode is Primary and Isolated, MEM1 contains the Primary value in specified units.

Examples:

Measure

Mode

This parameter selects the mode.

Syntax:

Mode[sp]=[sp]value

Primary only

value::=DC_Voltage 1 | DC_Current 1 | RTD_In | RTD_Out | TC_In | TC_Out | Pressure 1

Isolated only

value::=IsolatedVoltage 1| IsolatedCurrent 1| IsolatedPressure 1

Primary and Isolated

value::=DC_VoltageIsolatedVoltage 1| DC_VoltageIsolatedCurrent 1| DC_VoltageIsolatedPressure 1 | DC_VoltageSwitchTest 1| DC_CurrentIsolatedVoltage 1 | DC_CurrentIsolatedCurrent 1| DC_CurrentIsolatedPressure 1 | DC_CurrentSwitchTest 1| PressureIsolatedVoltage 1| PressureIsolatedCurrent 1| PressureIsolatedPressure 1| PressureSwitchTest 1| RTD_InIsolatedVoltage 1| RTD_InIsolatedCurrent 1| RTD_InIsolatedPressure 1| RTD_InSwitchTest 1| RTD_OutIsolatedVoltage 1| RTD_OutIsolatedCurrent 1| RTD_OutIsolatedPressure 1| RTD_OutSwitchTest 1| TC_InIsolatedVoltage 1| TC_InIsolatedCurrent 1| TC_InIsolatedPressure 1| TC_InSwitchTest 1| TC_OutIsolatedVoltage 1 | TC_OutIsolatedCurrent 1 | TC_OutIsolatedPressure 1 | TC_OutSwitchTest 1

  1. Each subword can be abbreviated as follows:

    Parameter Name | Abbreviation
    Current | Curr
    DC_Current | DC_Curr
    DC_Voltage | DC_Volt
    Isolated | Isol
    Pressure | Pres
    Switch | Swit
    Voltage | Volt

Examples:

PresIsolVolt

Rules:

  1. If mode is not specified, the mode is determined as described in the section INSTRUMENT MODE at the top of this file.

Examples:

Mode = DC_Voltage

Monitor

This action sets up the instrument and continually displays the reading until the operator selects Advance or Terminate in the UUT Setup prompt.

Syntax:

Monitor

Rules:

  1. When Monitor is specified, no other action may be specified.
  2. If Mode is Primary (Source) and Isolated, the instrument is put in Operate.
  3. After a Monitor statement MEM1 contains the reading in units of the Evaluation Quantity.

Examples:

Monitor

NominalResistance

This parameter specifies the nominal resistance for RTD Source and Measurement modes.

Syntax:

NominalResistance[sp]=[sp]numeric value[sp][prefix]Ohm[s]

Rules:

  1. NominalResistance cannot be taken from a memory register or named variable.

Examples:

NominalResistance = 100 Ohms

Operate

This parameter turns the output on.

Syntax:

Operate

Rules:

  1. When Operate is specified, no other parameters are allowed.

Examples:

Operate

Pressure

This parameter specifies the expected pressure measurement on the Primary display.

Syntax:

[+]Pressure[sp]=[sp]numeric value[sp][prefix]units

units ::= psi | inH2O | cmH2O | mH2O | bar | Pa | inHg | mHg | gm/cm2

Rules:

  1. When units arecmH2O, ftH2O, inH2O, mH2O, or mHg, ReferenceTemperature must be specified.

Examples:

+Pressure = 1 psi

PressureModule

This parameter specifies the pressure module.

Syntax:

PressureModule[sp]=[sp]model

model ::= 700P00 | 700P01 | 700P02 | 700P03 | 700P04 | 700P05 | 700P06 | 700P07 | 700P08 | 700P09 | 700P22 | 700P23 | 700P24 | 700P27 | 700P29 | 700P30 | 700P31 | 700PA3 | 700PA4 | 700PA5 | 700PA6 | 700PV3 | 700PV4 | 700PD2 | 700PD3 | 700PD4 | 700PD5 | 700PD6 | 700PD7 | 525A-P01 | 525A-P02 | 525A-P03 | 525A-P04 | 525A-P05 | 525A-P06 | 525A-P07 | 525A-P08 | 525A-P29 | 525A-PA4 | 525A-PA5 | 525A-PA6 | 525A-PA7 | 525A-PA8 | 525A-PV4

Rules:

  1. PressureModule cannot be taken from a memory register or named variable.

Examples:

+Pressure = 1 psi

Query

This parameter is used to retrieve a Switch Test result.

Syntax:

Query

Examples:

Mode = SwitchTest; +Temperature = 0.0 degC; SwitchState = Closed; Query

Range

This parameter specifies the range for DC Voltage, RTD Out , and RTD In.

Syntax:

Range[sp]=[sp]numeric value[sp][prefix]units

units ::= V | Ohms

Examples:

Range = 10 V

Read

This action returns the reading.

Syntax:

Read

Rules:

  1. When Read is specified, no other action may be specified.
  2. After a Read statement memory registers are updated as follows:
    1. MEM contains the reading in units of the Evaluation Quantity.
    2. If Mode is Primary and Isolated, MEM1 contains the Primary value in specified units.

Examples:

Read

ReferenceTemperature

This parameter specifies the reference temperature for pressure measurement in height of mercury or water.

Syntax:

[@]ReferenceTemperature[sp]=[sp]numeric value[sp][prefix]units

units ::= degC | degF

Rules:

  1. Legal values are 0, 4, and 20 °C and 60 °F.

Examples:

+Pressure = 0 inH2O; @ReferenceTemperature = 20 degC

Reset

This parameter resets the 7526A.

Syntax:

Reset

Rules:

  1. When Reset is specified, no other parameters are allowed.

Examples:

Reset

Resistance

This parameter specifies the primary resistance.

Syntax:

[+]Resistance[sp]=[sp]numeric value[sp][prefix]Ohm[s]

Examples:

Resistance = 100 Ohms

RTD_Type

This parameter specifies the RTD type.

Syntax:

RTD_Type[sp]=[sp]type

type ::= Pt385 | Pt3926 | Pt3916 | Ni672 | Cu427 | SPRT | YSI-400 | UserDefined | UserDef

Rules:

  1. SPRT is only allowed when Mode = RTD_In.

After a Setup state Examples:

RTD_Type = Pt385; NominalResistance = 500 Ohms

RTD_Type = Ni672; NominalResistance = 120 Ohms

RTD_Type = Cu427; NominalResistance = 10 Ohms

Setup

This action causes the instrument to be setup only.

Syntax:

Setup

Rules:

  1. When Setup is specified, no other action may be specified.
  2. The instrument remains in standby, unless it is already in operate.
  3. After a Setup statement is executed MEM1 contains the value to be sourced in units of the Evaluation Quantity.

Examples:

Setup

Slew

This action sets up the instrument and enables the output. Slewing is then enabled for the parameter designated as the Evaluation Quantity (i.e. + prefix).

Syntax:

Slew

Rules:

  1. When Slew is specified, no other action may be specified.

Examples:

Slew

Standby

This action selects standby (output disabled).

Syntax:

Standby

Rules:

  1. When Standby is specified, no other parameters are allowed.

Examples:

Standby

SwitchState

This parameter specifies the Switch Test query.

Syntax:

SwitchState[sp]=[sp]state

state ::= Closed | Clos | Open | Deadband | Dead

Examples:

SwitchState = Closed

TC_Reference

This parameter specifies the external reference temperature.

Syntax:

TC_Reference[sp]=[sp]value

value ::= Internal | External

Examples:

TC_Reference = Ext

TC_Type

This parameter specifies the TC type.

Syntax:

TC_Type[sp]=[sp]type

type ::= B | C | E | J | K | L | N | R | S | T | U | XK | BP | _1mVdegC

Examples:

TC_Type = K

Temperature

This parameter specifies the primary temperature.

Syntax:

[+]Temperature[sp]=[sp]numeric value[sp][prefix]units

units ::= degC | degF

Examples:

Temperature = -100.0 degC

Voltage

This parameter specifies the primary voltage.

Syntax:

[+]Voltage[sp]=[sp]numeric value[sp][prefix]V

Examples:

+Voltage = 100 V

Zero

This action Zeros the pressure module, TC mV, or RTD ohms.

Syntax:

Zero

Rules:

  1. When Zero is specified, no other action may be specified.

Examples:

Zero

Examples

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
# -----  Reset
  1.004  7526A        Reset

# -----  Standby
  1.005  7526A        Standby

# -----  Figure 2-1. DC Voltage Output Connections
  1.006  7526A        +Voltage = 190.0 mV
  1.007  TARGET       -m
  1.008  MEMI         Enter UUT reading in millivolts DC:
  1.009  MEMCX  200   190.0mV        1.0% 0.1U

# -----  Figure 2-2. DC Current Output Connections
  2.001  7526A        +Current = 19.00 mA
  2.002  TARGET       -m
  2.003  MEMI         Enter UUT reading in millamps DC:
  2.004  MEMCX  20    19.00mA        1.5% 0.01U

# -----  Figure 2-3. RTD/Ω Input Connection
  3.001  7526A        Range = 4000 Ohm
  3.001  7526A        +Resistance = 1.900 kOhms; Measure
  3.002  TARGET       -m
  3.003  7526A        Range = 4000 Ohm
  3.003  7526A        +Resistance = 1.900 kOhms; Read
  3.004  MEMC   2     kOhms          1% 0.004U

# -----  Figure 2-4. RTD/Ω Output Connection
  4.001  7526A        Range = 400 Ohm
  4.001  7526A        +Resistance = 19.00 Ohms
  4.002  TARGET       -m
  4.003  MEMI         Enter UUT reading in kilohms:
  4.004  MEMCX  20    Ohms           1% 0.04U

# -----  Thermocouple Input Connection
  5.001  RSLT         =
  5.002  HEAD         {CALIBRATOR}
  5.003  RSLT         =
  5.004  HEAD         -2{K TYPE THERMOCOUPLE}
  5.005  7526A        +Temperature = -325 degF; TC_Type = K; Measure
  5.006  DISP         Press the CALIB key (calibrator function).
  5.007  DISP         Select Type K thermocouple, °F, and 1 ° resolution.
  5.008  DISP         Connect 7526A TC terminals to the UUT T1 terminal
  5.008  DISP         (top left side), using a Type K extension cable.
  5.009  DISP         When instructed to enter a value to the UUT...
  5.009  DISP         first press CHANGE/ENTER, enter the value, then press
  5.009  DISP         CHANGE/ENTER.
  5.010  DISP         Enter -325
  5.011  WAIT         -t 2 Setting...
  5.012  TARGET       -m
  5.013  WAIT         [D1000]
  5.014  7526A        +Temperature = -325 degF; TC_Type = K; Read
  5.015  MEMC         -325degF       0.1% 1U

# -----  Thermocouple Output Connection
  6.001  RSLT         =
  6.002  HEAD         {METER}
  6.003  RSLT         =
  6.004  HEAD         -2{J TYPE THERMOCOUPLE}
  6.005  DISP         Select Type J thermocouple.
  6.006  DISP         Connect 7526A TC terminals to the UUT T2 terminal
  6.006  DISP         (top right side), using a Type J extension cable.
  6.007  7526A        +Temperature = -200.0 degC; TC_Type = J; Apply
  6.008  WAIT         -t 5 Setting...
  6.009  TARGET       -m
  6.010  MEMI         Enter UUT reading in degrees Celsius:
  6.011  MEMCX        -200.0degC     0.1% 0.6U

# -----  Figure 2-7. Pressure Module Connection

# -----  Figure 4-1. P/I Transmitter

# -----  Figure 4-2. I/P Transmitter

# -----  Figure 4-3. V/I Transmitter

# -----  Figure 4-4. RTD Test

# -----  RTD Transmitter
  7.001  DISP         [32]                       Note
  7.001  DISP
  7.001  DISP         This procedure assumes that the UUT as been setup
  7.001  DISP         to the following using a Fluke Documenting Process
  7.001  DISP         Calibrator:
  7.001  DISP
  7.001  DISP         [32] Sensor:  100 Ω Pt385 RTD
  7.001  DISP         [42] Sensing: 4-Wire Sensing
  7.001  DISP         [42] Units:   °C
  7.001  DISP         [42] Range:   0 to 600

  7.002  DISP         Connect the UUT to the 7526A as follows:
  7.002  DISP
  7.002  DISP         [32] UUT SNSR            7526A
  7.002  DISP         [32]    pin 1 -----> RTD/Ω OUTPUT HI
  7.002  DISP         [32]    pin 2 -----> RTD/Ω OUTPUT LO
  7.002  DISP         [32]    pin 3 -----> RTD/Ω OUTPUT LO
  7.002  DISP         [32]    pin 4 -----> RTD/Ω OUTPUT HI
  7.002  DISP
  7.002  DISP         [32] UUT PWR/SIG       7526A
  7.002  DISP         [32]      +   -----> Isolated HI
  7.002  DISP         [32]      -   -----> Isolated LO

  7.003  TSET         NMEAS = 3
  7.004  7526A        Temp =   0.0 degC; RTD_Type = Pt385; NomRes = 100 Ohms
  7.004  7526A        +IsolatedCurrent =  4.0 mA; LoopPower = On; Measure
  7.005  WAIT         -t 5 Settling...
  7.006  TARGET       -m
  7.007  WAIT         [D1000]
  7.008  7526A        Temp =   0.0 degC; RTD_Type = Pt385; NomRes = 100 Ohms
  7.008  7526A        +IsolatedCurrent =  4.0 mA; LoopPower = On; Read
  7.009  MEMC         4.0mA          0.1U

  8.001  TSET         NMEAS = 3
  8.002  7526A        Temp = 600.0 degC; RTD_Type = Pt385; NomRes = 100 Ohms
  8.002  7526A        +IsolatedCurrent = 20.0 mA; LoopPower = On; Measure
  8.003  WAIT         -t 5 Settling...
  8.004  TARGET       -m
  8.005  WAIT         [D1000]
  8.006  7526A        Temp = 600.0 degC; RTD_Type = Pt385; NomRes = 100 Ohms
  8.006  7526A        +IsolatedCurrent = 20.0 mA; LoopPower = On; Read
  8.007  MEMC         20.0mA         1.5%

# -----  Figure 4-6. Thermocouple Test

# -----  Thermocouple Transmitter
  9.001  DISP         Connect the 7526A to the UUT as follows:
  9.001  DISP
  9.001  DISP         [32] 7526A              UUT
  9.001  DISP         [32] Isolated HI -----> Sd +
  9.001  DISP         [32] Isolated LO -----> Sd -
  9.001  DISP         [32] TC Terminals ----> NI terminals¹
  9.001  DISP
  9.001  DISP         1. Ensure correct polarity, using Type J wires.

  9.002  DISP         [32]                   Note
  9.002  DISP
  9.002  DISP         The following Zero and Span adjustments will be
  9.002  DISP         automatically repeated until both are within spec:
  9.002  DISP         ±0.1 full-scale accuracy.
  9.002  DISP
  9.002  DISP         [32] Span:  4.00 ±0.02 mA
  9.002  DISP         [32] Span: 20.00 ±0.02 mA

  9.003  DO
  9.004  HEAD         ZERO ADJUSTMENT
  9.005  TARGET
  9.006  MESS         Adjust the Z potentiometer to read 4.00 mA.
  9.007  7526A        Temperature =   0.0 degF; TC_Type = J; LoopPower = On
  9.007  7526A        +IsolatedCurrent = 4.00 mA; Monitor

  9.008  HEAD         SPAN ADJUSTMENT
  9.009  TARGET
  9.010  MESS         Adjust the S potentiometer to read 20.00 mA.
  9.011  7526A        Temperature = 200.0 degF; TC_Type = J; LoopPower = On
  9.011  7526A        +IsolatedCurrent = 20.00 mA; Monitor

  9.012  HEAD         VERIFY ADJUSTMENT
  9.013  7526A        Temperature =   0.0 degF; TC_Type = J; LoopPower = On
  9.013  7526A        +IsolatedCurrent = 4.00 mA; Measure
  9.014  MATH         L[1] = (MEM >= 3.98) && (MEM <= 4.02)
  9.015  7526A        Temperature = 200.0 degF; TC_Type = J; LoopPower = On
  9.015  7526A        +IsolatedCurrent = 20.00 mA; Measure
  9.016  MATH         L[2] = (MEM >= 19.98) && (MEM <= 20.02)
  9.017  UNTIL        L[1] && L[2]

# -----  Figure 4-8. RTD Indicator

# -----  Figure 4-9. Precision Current Trip

# -----  Figure 4-10. I/I Isolator/Transmitter

# -----  Figure 4-11. Precision Temperature Measurement with Probe

# -----  Temperature Switch Test
  9.018  RSLT         =
  9.019  HEAD         {TEMPERATURE SWITCH TEST: EUROTHERM 92}
  9.020  TARGET
  9.021  TSET         NTHROW = 0; NMEAS = 1
  9.022  DISP         Connect a EUROTHERM 92 to the 7526A as follows:
  9.022  DISP
  9.022  DISP         [32]    7526A             EUROTHERM 92
  9.022  DISP         [32] Isolated HI -----> ALARM 2 N/O (pin 1)
  9.022  DISP         [32] Isolated LO -----> ALARM 2 Com (pin 2)
  9.022  DISP         [32] TC Terminals ----> T/C (pins 9 & 10) (1)
  9.022  DISP
  9.022  DISP         (1) Ensure correct polarity.
  9.023  DISP         Connect the EUROTHERM 92 to line power as follows:
  9.023  DISP
  9.023  DISP         [32] EUROTHERM 92         Line Power
  9.023  DISP         [32] neutral (pin 11) ---> Neutral
  9.023  DISP         [32] line (pin 12) ------> Load (1)
  9.023  DISP
  9.023  DISP         (1) Use an in-line 1 A, 125 V fuse.
  9.024  DISP         [32]                    NOTE
  9.024  DISP
  9.024  DISP         This procedure expects that the EUROTHERM 92 is
  9.024  DISP         configured with the following settings: (1)
  9.024  DISP
  9.024  DISP         Configuration Code
  9.024  DISP
  9.024  DISP         1st (left) and 2nd digits (alarm 1 and 2 functions)
  9.024  DISP         [32] Non-latching operation
  9.024  DISP         [32] C Full scale low alarm
  9.024  DISP         [32] E Full scale high alarm
  9.024  DISP
  9.024  DISP         3rd digit (input sensor type)
  9.024  DISP         [32] 5 K--Chromel®/Alumel®
  9.024  DISP
  9.024  DISP         4th digit (right digit)
  9.024  DISP         [32] 0 °C, AL1 & 2, No Power Fail Alarm
  9.024  DISP
  9.024  DISP         (1) See the Model 92 Alarm Unit Installation and
  9.024  DISP         Operation Manual for steps to configure these settings.

  9.025  7526A        Mode = TC_Out; TC_Type = K
  9.025  7526A        +Temperature = 190.0 degC; Apply
  9.026  DISP         Reset the EUROTHERM 92 by momentarily shorting
  9.026  DISP         pins 6 and 7.

  9.027  TARGET       -m
  9.028  7526A        Mode = TC_OutSwitchTest; TC_Type = K
  9.028  7526A        +Temperature = 190.0 degC; Start

# Increase temperature from 100 to 300 °C in 10 ° steps.
  9.029  MATH         Temperature = 190;

  9.030  DO
  9.031  MATH         Temperature = Temperature + 0.1
  9.032  7526A        Mode = TC_Out; TC_Type = K
  9.032  7526A        +Temperature = [V Temperature] degC; Apply
  9.033  WAIT         -t 5 Settling...
  9.034  UNTIL        Temperature >= 210

# Decrease temperature back to 100 °C.
  9.035  DO
  9.036  MATH         Temperature = Temperature - 0.1
  9.037  7526A        Mode = TC_Out; TC_Type = K
  9.037  7526A        +Temperature = [V Temperature] degC; Apply
  9.038  WAIT         -t 5 Settling...
  9.039  UNTIL        Temperature <= 190

  9.040  7526A        Mode = TC_OutSwitchTest; SwitchState = Deadband
  9.040  7526A        +Temperature = 0.0 degC; TC_Type = K; Query
  9.041  MEMC         0.0degC        1.0U

# -----  Figure 4-13. Pressure Switch Test
 10.001  RSLT         =
 10.002  HEAD         {PRESSURE SWITCH TEST: OMEGA PSW 800 Series}
 10.003  TARGET
 10.004  DISP         Connect a 700P07 pressure module to the manifold
 10.004  DISP         and 7526A pressure port.
 10.005  DISP         Connect UUT to the manifold and 7526A Isolated
 10.005  DISP         input (polarity is not important).
 10.006  DISP         Make sure the vent on the pump is open.
 10.007  7526A        Pressure = 0 psi; PressureModule = 700P07; Zero
 10.008  DISP         Close the vent on the pump.
 10.009  TARGET       -m
 10.010  7526A        Mode = PressureSwitchTest; PressureModule = 700P07
 10.010  7526A        +Pressure = 100.00 psi; Start
 10.011  DISP         The top of the isolated display will read “CLOSE”.
 10.011  DISP
 10.011  DISP         Apply pressure with the pump slowly until the switch
 10.011  DISP         opens.
 10.011  DISP
 10.011  DISP         When the switch is open, “OPEN” will be shown.
 10.011  DISP
 10.011  DISP         [32]                    NOTE
 10.011  DISP
 10.011  DISP         When you pressurize the UUT, it must be done slowly
 10.011  DISP         to make sure the readings are accurate.
 10.012  DISP         Bleed the pump slowly until the pressure switch closes.
 10.012  DISP
 10.012  DISP         The top of the isolated display will now read,
 10.012  DISP         “SW OPENED AT”
 10.013  7526A        Mode = PressureSwitchTest; PressureModule = 700P07
 10.013  7526A        +Pressure = 100.00 psi; SwitchState = Deadband; Query
 10.014  MEMC         0.00psi        1.0U


8505

Instrument FSC

Description

The 8505 FSC programs the Fluke 8505A or 8502A Multimeter to measure DC voltage, AC voltage, DC current, AC current, resistance, or conductance.

Functional Capability

Do not use the 8505 FSC when measuring current on closed loop procedures or when ASK- N is true. Using this FSC could cause damage to the Fluke 8505A. Use the IEEE FSC (as shown below) to program the 8505A setup prior to outputting any current from the UUT.

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
  1.001  IEEE         [@8505]I
# The following IEEE FSC programs the UUT to source 50 mA.
  1.002  IEEE         50mA;OPER
  1.003  IEEE         [@8505]?[I]
# Convert to milliamps
  1.004  MATH         MEM = MEM * 1000
  1.005  MEMC         50mA           1%

Function | NOMINAL | MOD1 | MOD2
DC Voltage | -1200 V to 1200 V |  |
AC Voltage | 1 mV to 1000 V | 10 Hz to 1 MHz |
DC Current | -1.28 A to 1.28 A |  |
AC Current | 0 A to 1.28 A | 10 Hz to 1 MHz |
Resistance | 0 Ω to 265 MΩ |  |
Conductance | >3.8 nS |  |
dBm | -46.99 dBm to 73.01 dBm | 10 Hz to 1 MHz | 5Z
dBm | -48.75 dBm to 71.24 dBm | 10 Hz to 1 MHz | 7Z
dBm | -54.77 dBm to 65.22 dBm | 10 Hz to 1 MHz | 3Z
dBm | -57.78 dBm to 62.21 dBm | 10 Hz to 1 MHz | 6Z

Parameters

RANGE

This field specifies the UUT range as described in the RANGE Field topic.

NOMINAL

This field specifies the expected measured value or a reset.

  • Voltage (DC or RMS) entered as: [numeric][prefix]V
  • dBm entered as: [numeric][prefix]D
  • Current entered as [numeric][prefix]A.
  • Resistance entered as [numeric][prefix]Z.
  • Conductance entered as [numeric][prefix]Y.
  • Reset entered as *.

Rules:

  1. The NOMINAL field may specify decibels only when the MOD2 field specifies the reference impedance.

TOLERANCE

This field specifies the UUT tolerance as described in the TOLERANCE Field topic.

MOD1

This field specifies frequency for AC voltage and AC current measurements or voltage for frequency and period measurements.

Frequency entered as [numeric][prefix]H.

blanknot applicable

Rules:

  1. The MOD1 field may specify frequency only when the NOMINAL field specifies voltage or decibels.
  2. The MOD1 field must be blank when the NOMINAL field specifies resistance or conductance.
  3. The product of the voltage and frequency must be less than 2 * 107.

MOD2

This field specifies the load impedance that the AC voltage is referenced to when expressed in dBm.

5Z | 50 Ω
7Z | 75 Ω
3Z | 300 Ω
6Z | 600 Ω
blank | field not applicable

Rules:

  1. The MOD2 field may specify a reference impedance only when the NOMINAL field specifies decibels.
  2. 6Z is inserted automatically in the MOD2 field when the NOMINAL field specifies decibels and no MOD2 code is entered.

MOD3

This field specifies the coupling mode of the 8502A or 8505A.

blank | DC coupled AC mode
F | AC coupled
FE | AC coupled, 1024 samples/reading, slow filter
MET/CAL was designed to use the RMS AC converter (option -09). If the Averaging AC converter (option - 01) is used, F must be selected; otherwise, and error will occur when executing the procedure.

MOD4

This field specifies the type of test being performed as described in the MOD4 Field topic.

CON

This field specifies the UUT connection.

2W | 2-wire
4W | 4-wire

Rules:

  1. The CON field may specify a 4W only when the NOMINAL field specifies resistance less than 256 kOhm.
  2. 2W is inserted automatically in the CON field when no CON field code is entered.

Use of Standard Memory Locations and Results Reporting

System memory locations MEM and MEM1 are used. For more information, refer to the Use of Standard Memory Registers topic.

Examples

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
# ----- Reset -----
  2.001  8505         *                                                 S
# ----- DC Voltage -----
  2.002  8505   A     -1100V         1% 0.1U                               2W
# ----- AC Voltage -----
  3.001  8505   A     1000V          1%            10kH                    2W
# ----- dBm -----
  4.001  8505   100   10D            2% 0.1U       1kH            6Z       2W
# ----- Conductance -----
  5.001  8505   20    10nY           -1% +5%                               2W
  6.001  8505   20    10uY           1%                                    2W
# ----- Resistance -----
  7.001  8505   100   256kZ          1%                                    2W
# ----- Setup Test -----
  8.001  8505         1V                           10kH                 S  2W
# ----- Nominal Setup Test ----
  8.002  8505   2     1V                           10kH                 N  2W
# ----- Comparison Test -----
  8.003  8505   2     1V             1% 0.1U       20kH                 C  2W


8506

Instrument FSC

Description

The 8506 FSC programs the Fluke 8506A True RMS Digital Multimeter to measure DC voltage, AC voltage, DC current, resistance, or conductance.

Functional Capability

Do not use the 8506 FSC when measuring current on closed loop procedures or when ASK- N is true. Using this FSC could cause damage to the Fluke 8506A. Use the IEEE FSC (as shown below) to program the 8506A setup prior to outputting any current from the UUT.

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
  1.001  IEEE         [@8506]I
# The following IEEE FSC programs the UUT to source 50 mA.
  1.002  IEEE         50mA;OPER
  1.003  IEEE         [@8506]?[I]
# Convert to milliamps
  1.004  MATH         MEM = MEM * 1000
  1.005  MEMC         50mA           1%

Function | NOMINAL | MOD1 | MOD2
FUNCTION | NOMINAL | MOD1 | MOD2
DC Voltage | -1200 V to 1200 V
AC Voltage | 1 mV to 600 V (1010V) 1 | 10 Hz to 1 MHz
DC Current | -1.28 A to 1.28 A
Resistance | 0 Ω to 265 MΩ
Conductance | >3.8 nS
dBm | -46.99 dBm to 68.57 dBm (73.09 dBm) 1 | 10 Hz to 1 MHz | 5Z
dBm | -48.75 dBm to 66.81 dBm (71.33 dBm) 1 | 10 Hz to 1 MHz | 7Z
dBm | -54.77 dBm to 60.79 dBm (65.31 dBm) 1 | 0 Hz to 1 MHz | 3Z
dBm | -57.78 dBm to 57.78 dBm (62.30 dBm) 1 | 10 Hz to 1 MHz | 6Z
  1. (kV) specified in the CONFIG.DAT file.

Parameters

RANGE

This field specifies the UUT range as described in the RANGE Field topic.

NOMINAL

This field specifies the expected measured value or a reset.

  • Voltage (DC or RMS) entered as: [numeric][prefix]V
  • dBm entered as: [numeric][prefix]D
  • Current entered as [numeric][prefix]A.
  • Resistance entered as [numeric][prefix]Z.
  • Conductance entered as [numeric][prefix]Y.
  • Reset entered as *.

Rules:

  1. The NOMINAL field may specify decibels only when the MOD2 field specifies the reference impedance.

TOLERANCE

This field specifies the UUT tolerance as described in the TOLERANCE Field topic.

MOD1

This field specifies frequency for AC voltage and AC current measurements or voltage for frequency and period measurements.

Frequency entered as [numeric][prefix]H.

blank not applicable

Rules:

  1. The MOD1 field may specify frequency only when the NOMINAL field specifies voltage or decibels.
  2. The MOD1 field must be blank when the NOMINAL field specifies resistance or conductance.
  3. The product of the voltage and frequency must be less than 107.

MOD2

This field specifies the load impedance that the AC voltage is referenced to when expressed in dBm.

5Z | 50 Ω
7Z | 75 Ω
3Z | 300 Ω
6Z | 600 Ω
blank | field not applicable

Rules:

  1. The MOD2 field may specify a reference impedance only when the NOMINAL field specifies decibels.
  2. 6Z is inserted automatically in the MOD2 field when the NOMINAL field specifies decibels and no MOD2 code is entered.

MOD3

This field specifies DC and AC operating modes which allow higher levels of accuracy at longer measurement times. Refer to the 8506A Instruction Manual for detailed information on the different types of measurements and their properties.

Function | MOD3 | Operating Mode | Samples/Reading | Filter | Coupling
DC Voltage | blank | normal | 128 | Fast | na
DC Voltage | E 1 | AVG | 1024 | Slow | na
AC Voltage | blank 2 | ENH'D | ~2 | na | DC
AC Voltage | F 2 | ENH'D | ~2 | na | AC
AC Voltage | E 3 | HI ACCUR | na | na | DC
AC Voltage | FE 3 | HI ACCUR | na | na | AC
AC Voltage | G 4 | NORMAL | ~2 | na | AC
  1. This mode of operation will result in an improved noise floor and specification.
  2. In this mode of operation the 8506A takes a single reading in the "HI ACCUR" mode and stores a correction factor (requires approximately 6 seconds). After the initial reading, the 8506A operates at approximately 2 readings/second applying the correction factor to each reading. In a stable environment, this results in the 8506A making measurements to the same accuracy as the "HI ACCUR" mode for a period of 5 minutes. If the input changes by more then +/-1%, the measurement process begins again with a single "HI ACCUR" measurement.
  3. The advantage of this mode is that every measurement involves a correction factor, and therefore, the best possible specifications are maintained regardless of time, environment, and level. A full measurement cycle takes 6 seconds.
  4. In this mode accuracy is limited to approximately 0.5%.

MOD4

This field specifies the type of test being performed as described in the MOD4 Field topic.

CON

This field specifies the UUT connection.

2W | 2-wire
4W | 4-wire

Rules:

  1. The CON field may specify a 4W only when the NOMINAL field specifies resistance less than 256 kOhm.
  2. 2W is inserted automatically in the CON field when no CON field code is entered.

Use of Standard Memory Locations and Results Reporting

System memory locations MEM and MEM1 are used. For more information, refer to the Use of Standard Memory Registers topic.

Examples

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
# ----- Reset -----
  2.001  8506         *                                                 S
# ----- DC Voltage -----
  2.002  8506   A     -1100V         1% 0.1U                               2W
# ----- AC Voltage -----
  3.001  8506   A     600V           1%            10kH                    2W
  4.001  8506   1     1V             1% 0.01U      10kH                    2W
  5.001  8506   10    10V            1% 1/ 1P%     1kH               E     2W
  6.001  8506   10    10D            0.1U          1kH            6Z FE    2W
  7.001  8506   10    10V            1/ 1P%        1kH               E     2W
  8.001  8506   10    10D            0.1U          1kH            6Z F     2W
  9.001  8506   10    10D            0.2U          1kH            6Z E     2W
# ----- dBm -----
 10.001  8506   A     0D             0.1U          1kH            5Z       2W
 11.001  8506   A     -25D           0.1U          10kH           7Z       2W
 12.001  8506   -30   -26D           0.1U          100kH          3Z       2W
 13.001  8506   A     60.791D        0.1U          10kH           3Z       2W
 14.001  8506   A     0D             0.1U          1kH            6Z       2W
# ----- Conductance -----
 15.001  8506   10    3.82nY         1%                                    2W
# ----- Resistance -----
 16.001  8506   100   256kZ          2%                                    4W
# ----- Setup Test -----
 17.001  8506         1V                           10kH                 S  2W
# ----- Nominal Setup Test ----
 17.002  8506   2     1V                           10kH                 N  2W
# ----- Comparison Test -----
 17.003  8506   2     1V             1% 0.1U       20kH                 C  2W


8508

Instrument FSC

Description

The 8508 FSC programs the Fluke 8508A Reference Multimeter to measure DC voltage, AC voltage, DC current, AC current, resistance, frequency, and temperature. Measurements can be made using the front or rear terminals. Difference, ratio, and deviation measurements may also be performed using the front and rear terminals.

The following auxiliary functions are provided by the M8508 FSC:

  • Range Locking
  • Rolling Average
  • Block Average
  • Settling Delay
  • Filter for DC Voltage, DC Current, and Resistance
  • Fast Mode for DC Voltage, DC Current, and Resistance
  • DC Coupling for AC Voltage and AC Current
  • External Guard
  • Transfer Mode Off for AC Voltage
  • Low Current Resistance for Normal and True Ohms

Functional Capability

Function | Nominal | MOD1 | MOD2
DC Voltage | -1050 V to 1050 V
AC Voltage | 2 mV to 199.9999 V | 1 Hz to 1 MHz
200 V to 1050 V | 1 Hz to 100 kHz
-40.969 dBm to +59.031 dBm | 1 Hz to 1 MHz | 5Z
+59.031 dBm to +73.434 dBm | 1 Hz to 100 kHz | 5Z
-42.730 dBm to +57.270 dBm | 1 Hz to 1 MHz | 7Z
+57.270 dBm to +71.673 dBm | 1 Hz to 100 kHz | 7Z
-51.761 dBm to +48.239 dBm | 1 Hz to 1 MHz | 6Z
+48.239 dBm to +62.642 dBm | 1 Hz to 100 kHz | 6Z
Resistance
True Ohms | 0 Ω to 19.9999999 kΩ | OC
Normal Ohms | 0 Ω to 1.99999999 GΩ | NO
HV Ohms | 2 MΩ to 19.9999999 GΩ | HI
DC Current | -19.999999 A to 19.999999 A 1
AC Current | 2 μA to 19.99999 mA | 1 Hz to 100 kHz
20 mA to 1.999999 A | 1 Hz to 30 kHz
2 A to 19.99999 A 2 | 1 Hz to 10 kHz
Frequency
ACV | 10 Hz 3 to 100 kHz | 7 mV to 1050 V
10 Hz 3 to 1 MHz | 7 mV to 199.9999 V
ACI | 10 Hz 3 to 100 kHz | 2 μA to 19.99999 mA
10 Hz 3 to 30 kHz | 2 μA to 1.999999 A
10 Hz 3 to 10 kHz | 2 μA to 19.99999 A 2
PRT | -200 °C to 1000 °C 4
  1. Rear inputs are limited to ±1.999999 A
  2. Rear inputs are limited to 1.999999 A
  3. Lower bound is 200 Hz when MOD3 = D4 or FE (Fast Gate)
  4. Compiler limits only. Physical limits depend upon actual PRT.

Parameters

RANGE

This field specifies the UUT range as described in the RANGE Field topic.

NOMINAL

This field specifies the expected measured value or a reset.

  • Voltage (DC or RMS) entered as [numeric][prefix]V
  • Voltage Difference entered as [numeric][prefix]V
  • Voltage Ratio entered as [numeric][prefix]V/V or pct
  • Voltage Deviation entered as [numeric][prefix]pct
  • dBm entered as [numeric][prefix]D
  • Current entered as [numeric][prefix]A
  • Resistance entered as [numeric][prefix]Z
  • Resistance Difference entered as [numeric][prefix]Z
  • Resistance Ratio entered as [numeric][prefix]Z/Z or pct
  • Resistance Deviation entered as [numeric][prefix]pct
  • Frequency entered as [numeric][prefix]H
  • Period entered as [numeric][prefix]T
  • Temperature entered as [numeric][prefix]degC, degF, or K
  • Reset entered as *

Rules:

  1. The NOMINAL field may specify frequency only when the MOD1 field specifies voltage or current.

When the NOMINAL field specifies frequency or period, the AC filter is selected as follows:

Frequency (1/period) | Filter
≥ 110 Hz | 100 Hz High Pass Filter
<110 Hz and ≥41 Hz | 40 Hz High Pass Filter
<41 Hz and 11 Hz | 10 Hz High Pass Filter
<11 Hz | 1 Hz High Pass Filter

TOLERANCE

This field specifies the UUT tolerance as described in the TOLERANCE Field topic.

MOD1

This field specifies frequency or amplitude for AC voltage or AC current measurements.

  • Frequency entered as [numeric][prefix]H
  • Voltage entered as [numeric][prefix]V
  • Current entered as [numeric][prefix]A
  • blank not applicable

Rules:

  1. The MOD1 field may specify frequency only when the NOMINAL field specifies voltage or current.
  2. The MOD1 field must specify voltage or current when the NOMINAL field specifies frequency.
  3. The MOD1 field must be blank when the NOMINAL field specifies resistance. When the MOD1 field specifies frequency, the AC filter is selected as follows:
Frequency | Filter
≥100 Hz | 100 Hz High Pass Filter
<100 Hz and ≥40 Hz | 40 Hz High Pass Filter
<40 Hz and 10 Hz | 10 Hz High Pass Filter
<10 Hz | 1 Hz High Pass Filter

Note: For best accuracy DC coupling should be used for frequencies of 100 Hz and below (See 8508 MOD3 and M8508 FSC MOD3 field descriptions).

MOD2

This field specifies one of the following:

  1. The load impedance that the AC voltage is referenced to, or
  2. Resistance measurement type: HV Ohms, Normal Ohms, or True Ohms
  3. PRT accuracy data to use in the 8508A accuracy file.
5Z | 50 Ω
6Z | 600 Ω
7Z | 75 Ω
HI | HV ohms
NO | Normal ohms
OC | True ohms
P1 | PRT 1, User Defined (default: Fluke 8508 A-PRT or Hart 5626)
P2 | PRT 2, User Defined (default: Fluke 8508 A-SPRT or Hart 5699)
P3 | PRT 3, User Defined
P4 | PRT 4, User Defined
P5 | PRT 5, User Defined
P6 | PRT 6, User Defined
P7 | PRT 7, User Defined
P8 | PRT 8, User Defined
P9 | PRT 9, User Defined
blank | (see below)

Rules:

  1. The MOD2 field may specify a reference impedance only when the NOMINAL field specifies dBm.
  2. When MOD2 field specifies HI (HV Ohms), the M8508 FSC must lock the 20 MΩ, 200 MΩ, 2 GΩ, or 20 GΩ range.
  3. When MOD2 field specifies NO (Normal Ohms), the NOMINAL field is ≥ 20 MΩ, and the M8508 FSC CON field specifies LOI (low current), the M8508 FSC must lock the 200 MΩ or 2 GΩ range.
  4. The MOD2 field may specify a PRT only when the NOMINAL field specifies temperature.
  5. The MOD2 must be blank for any of the following conditions:
    1. DC Voltage: The NOMINAL specifies voltage and the MOD1 field is blank.
    2. DC Current: The NOMINAL specifies current
    3. AC Current: The NOMINAL or MOD1 field specifies current
  6. If the NOMINAL field specifies resistance and no MOD2 code is entered, NO is automatically entered in the MOD2 field.
  7. If the NOMINAL field specifies temperature and no MOD2 code is entered, P1 is automatically entered in the MOD2 field.

MOD3

The MOD3 field Specifies the measurement resolution or input zero.

D4 | 4.5 digit resolution
D5 | 5.5 digit resolution
D6 | 6.5 digit resolution
D7 | 7.5 digit resolution
D8 | 8.5 digit resolution
ZR | Perform input zero

Rules:

Function | D4 | D5 | D6 | D7 | D8
DC Voltage |  | x |  | x | x
AC Voltage |  | x | x |  |
DC Current |  | x | x | x |
AC Current |  | x | x |  |
Normal Ohms |  | x | x | x | x
True Ohms |  | x | x | x | x
HV Ohms |  | x | x | x | x
Temperature |  | x | x | x | x
Frequency |  | x | x |  |
  • When the MOD3 field specifies Dn, the M8508 FSC must be used to specify fast on, DC coupling, and low current resistance, and ACV transfer mode off.
  • When the 8508A is range locked (see M8508 FSC) and MOD3 specifies ZR, a range zero is performed, otherwise a function zero is performed.
  • When the MOD3 field specifies ZR and the MOD1 field is not blank (ACV or ACI), the M8508 MOD3 field must be DC (DC Coupling).

The following MOD3 codes are for compatibility with the 1271/1281 and other DMM FSCs. These MOD3 codes should not be used when measurement uncertainty is enabled, or when direct control of measurement resolution, fast mode, or coupling is required.

blank | Default measurement mode
E | Enhanced measurement mode
F | Fast measurement mode
FE | Fast Enhanced measurement mode

Rules:

F | blank | E | FE
DC Volts
resolution | 6.5 digits | 6.5 digits | 8.5 digits | 8.5 digits
fast | off | off | off | on
Readings
thrown away 1 | 1 | 1 | 1 | 1
averaged 1 | 5 | 1 | 1 | 1
AC Volts
resolution | 5.5 digits | 5.5 digits | 6.5 digits | 5.5 digits
TFER | on | on | on | on
coupling
<40 Hz | DC | DC | DC | DC
≥40 Hz | AC | AC | AC | AC
gate fast | on | on | on | on
Readings
thrown away 1 | 1 | 1 | 1 | 1
averaged 1 | 1 | 3 | 3 | 1
DC Current
resolution | 6.5 digits | 5.5 digits | 6.5 digits | 5.5 digits
fast | on | off | off | on
Readings
thrown away 1 | 1 | 1 | 2 | 1
averaged 1 | 1 | 3 | 5 | 1
AC Current
resolution | 5.5 digits | 5.5 digits | 5.5 digits | 5.5 digits
coupling
<40 Hz | DC | DC | DC | DC
≥40 Hz | AC | AC | AC | AC
Readings
thrown away 1 | 1 | 1 | 2 | 1
averaged 1 | 1 | 3 | 5 | 1
Resistance
resolution | 6.5 digits | 6.5 digits | 7.5 digits | 6.5 digits
fast | on | off | off | on
Readings
thrown away 1 | 1 | 2 | 2 | 1
averaged 1 | 3 | 4 | 4 | 1
>20 kΩ to ≤200 kΩ
Readings
thrown away 1 | 1 | 2 | 5 | 1
averaged 1 | 3 | 4 | 4 | 1
>200 kΩ
Readings
thrown away 1 | 1 | 2 | 7 | 1
averaged 1 | 3 | 4 | 5 | 1
Frequency
gate fast | n/a | off | n/a | on
resolution | n/a | 6.5 digits | n/a | 4.5 digits
coupling
<40 Hz | n/a | DC | n/a | DC
≥40 Hz | n/a | AC | n/a | AC
Readings
thrown away 1 | n/a | 1 | n/a | 1
averaged 1 | n/a | 3 | n/a | 1
  1. With measurement uncertainty disabled. When measurement uncertainty is enabled, use VSET FSC to set number of readings to throw away and average.

MOD4

This field specifies the type of test being performed as described in the MOD4 Field topic.

CON

This field specifies the UUT connection.

2W | Selects 2-wire, front inputs
3W | Selects 3-wire, front inputs
4W | Selects 4-wire, front inputs
2WR | Selects 2-wire, rear inputs
3WR | Selects 3-wire, rear inputs
4WR | Selects 4-wire, rear inputs
DIV | Selects ratio (front / rear), 2-wire
DI4 | Selects ratio (front / rear), 4-wire
SUB | Selects difference (front - rear), 2-wire
SU4 | Selects difference (front - rear), 4-wire
DEV | Selects deviation |(front - rear) / rear|, 2-wire
DE4 | Selects deviation |(front - rear) / rear|, 4-wire

Rules:

Function | Nominal | MOD1 | CON
DC Voltage | V |  | 2W|4W|2WR
DC Voltage Ratio | V/V | pct |  | DIV|DI4*
DC Voltage Difference | V |  | SUB|SU4*
DC Voltage Deviation | pct |  | DEV|DE4*
AC Voltage | V | D | H | 2W|4W|2WR
AC Voltage Ratio | V/V | pct | H | DIV|DI4*
AC Voltage Difference | V | H | SUB|SU4*
AC Voltage Deviation | pct | H | DEV|DE4*
Frequency | H | V | 2W|4W|2WR
Frequency | H | A | 2W|2WR
Period | T | V | 2W|4W|2WR
Period | T | A | 2W|2WR
Normal Ohms | Z |  | 2W|4W|2WR|4WR
Normal Ohms Ratio | Z/Z | pct |  | DIV|DI4
Normal Ohms Difference | Z |  | SUB|SU4
Normal Ohms Deviation | pct |  | DEV|DE4
HV Ohms | Z |  | 2W|4W|2WR|4WR
HV Ohms Ratio | Z/Z | pct |  | DIV|DI4
HV Ohms Difference | Z |  | SUB|SU4
HV Ohms Deviation | pct |  | DEV|DE4
True Ohms | Z |  | 4W|4WR
True Ohms Ratio | Z/Z | pct |  | DI4
True Ohms Difference | Z |  | SU4
True Ohms Deviation | pct |  | DE4
DC Current | A |  | 2W|2WR
AC Current | A | H | 2W|2WR
Temperature | degC | degF | K |  | 2W|3W|4W|2WR|3WR|4WR
* 4-wire front, 2-wire rear
  • If the NOMINAL field specifies temperature and no CON field code is entered, 4W is automatically entered in the CON field. Otherwise if the NOMINAL field is not temperature and no CON field code is entered, 2W is automatically entered.

Use of Standard Memory Locations and Results Reporting

System memory locations MEM and MEM1 are used. For more information, refer to the Use of Standard Memory Registers topic.

Examples

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON

# ----- Reset -----
  1.001  8508         *                                                 S
# ----- DC Voltage -----
  1.002  M8508  RNGLK 2V
  1.003  8508         10mV                                              N  2W
  1.004  M8508        *
  1.005  8508   A     -1000V         1% 0.1U                               2W
# ----- AC Voltage -----
  2.001  8508   200   100V           1% 2/         10kH                    2W
# ---- dBm, 50 Ohms ----
  3.001  8508         0.00D          0.1U          1kH            5Z       2W
# ----- DC Current -----
  4.001  8508   10    1.00A          1000P%                                2W
# ----- AC Current -----
  5.001  8508   2     mA             1%            1kH                     2W
# ----- Resistance -----
  6.001  8508   100   256kZ          1%                           NO       4W
# ----- Frequency -----
  7.001  8508   1     10.0kH         1% 2/         1V                      2W
  8.001  8508   10    1.00kH         1% 2/         10mA                    2W

The following procedure may be used to load PRT identity and coefficients into the 8508 A:

1.001  HEAD         PRELIMINARY INFORMATION
1.002  DISP         This utility allows the operator to review,
1.002  DISP         delete, or add new SPRT/PRT probe identities
1.002  DISP         and associated characteristics in the 8508A
1.002  DISP         non-volatile memory.

1.003  MATH         Id = lbNew("8508A SPRT/PRT")
1.004  MATH         lbText(Id, "Select operation to be performed.")
1.005  MATH         LbConf(Id, "-Sel")
1.006  MATH         lbAddV(Id, "Review", "@Review")
1.007  MATH         lbAddV(Id, "Delete", "@Delete")
1.008  MATH         lbAddV(Id, "Insert", "@Insert")

1.009  HEAD         Fluke 8508A SPRT/PRT Probe Utility

1.010  DO
1.011  MATH         lbShow(Id)
1.012  MATH         Count = lbSelCount(Id)

1.013  IF           Count  > 0
1.014  MATH         @Action = lbGetSel(Id, 1)

1.015  IF           @Insert
1.016  CALL         Sub Fluke 8508A SPRT/PRT Insert Coefficients
1.017  ELSE
1.018  CALL         Sub Fluke 8508A SPRT/PRT Select Probe
1.019  ENDIF

1.020  ENDIF        ; Count  > 0

1.021  UNTIL        Count == 0


M8508

Auxiliary Instrument Setup FSC

Description

The M8508 FSC provides the following functions for the Fluke 8508A Multimeter:

  • Range Locking
  • Rolling Average
  • Block Average
  • Settling Delay
  • Filter for DC Voltage, DC Current, and Resistance
  • Fast Mode for DC Voltage, DC Current, and Resistance
  • DC Coupling for AC Voltage and AC Current
  • External Guard
  • Transfer Mode for AC Voltage
  • Low Current Resistance for Normal and True Ohms

Parameters

When a blank M8508 statement is entered, a "*" is inserted automatically in the NOMINAL field. See NOMINAL field parameter for a description of "*".

RANGE

This field specifies one of the following:

PRT | PRT Identity
RNGLK | Range Lock
blank | field not applicable

Rules:

  1. When the RANGE field specifies PRT, the PRT identity is taken memory register MEM2.
  2. When the RANGE field specifies RNGLK, the NOMINAL field must specify the range selection value.
  3. The RANGE field must specify RNGLK, when the 8508 FSC MOD2 specifies HI (HV Ohms).
  4. The RANGE field must specify RNGLK, when the 8508 FSC MOD2 specifies NO (Normal Ohms), the 8508 FSC Nominal field is ≥ 20 MΩ, and the M8508 CON field specifies LOI (low current).

NOMINAL

This field specifies the locked range or reset.

  • Voltage range selection value entered as: [numeric][prefix]V
  • Current range selection value entered as: [numeric][prefix]A
  • Resistance range selection value entered as: [numeric][prefix]]Z
  • "*" reset to default values

Rules:

  1. The NOMINAL field may specify a range selection value only when the RANGE field specifies RNGLK.

    Selection Value | Locked Range
    0 mV to 200 mV | 200 mV
    > 200 mV to 2 V | 2 V
    > 2 V to 20 V | 20 V
    > 20 V to 200 V | 200 V
    > 200 V to 1050 V | 1050 V
    0 μA to 200 μA | 200 μA
    > 200 μA to 2 mA | 2 mA
    > 2 mA to 20 mA | 20 mA
    > 20 mA to 200 mA | 200 mA
    > 200 mA to 2 A | 2 A
    > 2 A to 20 A | 20 A (front inputs only)
    0 Ω to 2 Ω | 2 Ω
    > 2 Ω to 20 Ω | 20 Ω
    > 20 Ω to 200 Ω | 200 Ω
    > 200 Ω to 2 kΩ | 2 kΩ
    > 2 kΩ to 20 kΩ | 20 kΩ
    > 20 kΩ to 200 kΩ | 200 kΩ
    > 200 kΩ to 2 MΩ | 2 MOΩ
    > 2 MΩ to 20 MΩ | 20 MΩ
    > 20 MΩ to 200 MΩ | 200 MΩ
    > 200 MΩ to 2 GΩ | 2 GΩ
    > 2 GΩ to 20 GΩ | 20 GΩ

  2. A M8508 range lock specification only applies when a subsequent 8508 FSC specifies an applicable measurement function (see Examples below).

  3. The NOMINAL field must be greater then 2 MΩ when the 8508 FSC MOD2 field is HI (HV Ohms).
  4. When the NOMINAL field specifies reset "*", all other fields must be blank.

TOLERANCE

This field enables and disables averaging.

mavg | m reading rolling average
nblk | n reading block average

Rules:

  1. Allowed values for m are 4, 8, 16, 32, and 64
  2. Allowed values for n are 1 to 9999.

MOD1

This field specifies the settling delay.

  • Settling delay entered as [numeric][prefix]T.
  • blank Default for function and range

Rules:

  1. Allowed values for delay are 0 s to 65,000 s.

MOD2

This field enables and disables the filter for DC voltage, DC current, and resistance measurements.

FL | Enable filter
blank | Disable filter

Rules:

  1. The MOD2 field must be blank when the 8508 FSC MOD2 field specifies Offset Compensated True Ohms "OC".
  2. The MOD2 field is ignored when the 8508 FSC specifies AC Voltage, AC Current, or temperature measurement.

MOD3

This field enables and disables fast mode or DC coupling.

FS | Fast on, AC coupling
DC | Fast off, DC coupling
blank | Fast off, AC coupling

Rules:

  1. The MOD3 field must be blank when the 8508 FSC MOD3 field is blank, E, F, or FE.
  2. MOD3 FS is ignored when the 8508 FSC specifies AC Voltage, AC Current, or temperature measurement.
  3. MOD3 DC is ignored when the 8508 FSC specifies DC Voltage, AC Current, resistance, or temperature measurement.

MOD4

This field is used to specify the guard connection:

G | Enable remote guard
blank | Enable local guard

CON

This field enables low current resistance or turns off AC transfer mode.

LOI | low current resistance
NOT | ACV transfer mode off
blank | normal current resistance

Rules:

  1. The CON field must be blank when the 8508 FSC specifies AC Voltage and the 8508 FSC MOD3 field is blank, E, F, or FE (see 8508 FSC MOD3 description).
  2. The CON field must be blank when the 8508 FSC MOD2 field is HI (HV Ohms).
  3. The CON field is ignored when the 8508 FSC specifies DC Voltage, DC Current, AC Current, or temperature.

Examples

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
#
  1.001  M8508  RNGLK 200mV
#
#  200mV range is locked
#
  1.002  8508         100mV          1%                                    2W
#
#  200mV range is locked
#
  2.001  8508         10mV           1%            1kH                     2W
  3.001  8508         1kH            1%            10mV                    2W
#
#  Autorange is selected (M8508 FSC not applicable).
#
  4.001  8508         1uA            1%                                    2W
  5.001  8508         100uA          1%            1kH                     2W
  6.001  8508         1kH            1%            100uA                   2W
  7.001  8508         10Z            1%                            OC      4W
#
  8.001  M8508  RNGLK 200uA
#
#  Autorange is selected (M8508 FSC not applicable).
#
  8.002  8508         100mV          1%                                 N  2W
  8.003  8508         10mV           1%            1kH                  N  2W
  8.004  8508         1kH            1%            10mV                    2W
#
#  200uA range is locked
#
  9.001  8508         100uA          1%                                 N  2W
#
#  200uA range is locked
#
  9.002  8508         100uA          1%            1kH                  N  2W
  9.003  8508         1kH            1%            100uA                   2W
#
# Autorange is selected (M8508 FSC not applicable).
#
 10.001  8508         10Z            1%                           OC    N  4W
#
 10.002  M8508  RNGLK 20Z
#
#  Autorange is selected (M8508 FSC not applicable).
#
 10.003  8508         100mV          1%                                 N  2W
 10.004  8508         10mV           1%            1kH                  N  2W
 10.005  8508         1uA            1%                                 N  2W
 10.006  8508         100uA          1%            1kH                  N  2W
#
#  20 Ohm range is locked.
#
 10.007  8508         10Z            1%                           OC    N  4W
#
#  Autorange is selected for all subsequent 8508 FSCs.
#
 10.008  M8508        *


8842

Instrument FSC

Description

The 8842 FSC programs the Fluke 8842A Digital Multimeters to measure DC voltage, AC voltage, DC current, AC current, resistance, and conductance. High voltage probes extend the DC voltage range to 40 kV.

The 8842 FSC will not work with 8842 A's with firmware version 3.0. Firmware version 3.0 does not set the Data Available bit in the status byte, which is required by MET/CAL.

Functional Capability

Function | NOMINAL | MOD1 | MOD2 | MOD3
DC Voltage | -1000 V to 1000 V
DC Voltage w/6 kV Probe | -6 kV to 6 kV | F
DC Voltage w/40 kV Probe | ±(1 kV to 40 kV) | G
AC Voltage 1 | 1 mV to 700 V | 20 Hz to 100 kHz
DC Current | -1.99999 A to 1.99999 A
AC Current | 100 mA to 1.99999 A | 20 Hz to 5 kHz
Resistance | 0 Ohm to 19.9999 MOhm
Conductance | >50 nS
dBm 1 | -46.99 dBm to 69.91 dBm | 20 Hz to 100 kHz | 5Z
dBm 1 | -48.75 dBm to 68.15 dBm | 20 Hz to 100 kHz | 7Z
dBm 1 | -54.77 dBm to 62.13 dBm | 20 Hz to 100 kHz | 3Z
dBm 1 | -57.78 dBm to 59.12 dBm | 20 Hz to 100 kHz | 6Z
  1. Volt-Hertz product not to exceed 2 x 107.

Parameters

RANGE

This field specifies the UUT range as described in the RANGE Field topic.

NOMINAL

This field specifies the expected measured value or a reset.

  • Voltage (DC or RMS) entered as: [numeric][prefix]V
  • dBm entered as: [numeric][prefix]D
  • Current entered as [numeric][prefix]A.
  • Resistance entered as [numeric][prefix]Z.
  • Conductance entered as [numeric][prefix]Y.
  • Reset entered as *.

Rules:

  1. The NOMINAL field may specify decibels only when the MOD2 field specifies the reference impedance.

TOLERANCE

This field specifies the UUT tolerance as described in the TOLERANCE Field topic.

MOD1

This field specifies frequency for AC voltage and AC current measurements or voltage for frequency measurements. See the NOMINAL field specification for allowed values and units.

  • Frequency entered as numeric[prefix]H.
  • blank not applicable

Rules:

  1. The MOD1 field must be blank when the NOMINAL field specifies resistance or conductance.

MOD2

This field specifies the load impedance that the AC voltage is referenced to.

5Z | 50 Ω
7Z | 75 Ω
3Z | 300 Ω
6Z | 600 Ω
blank | field not applicable

Rules:

  1. The MOD2 field may specify a reference impedance only when the NOMINAL field specifies decibels.

MOD3

This field specifies one of the following:

F | DC Voltage measurement using 6 kV probe
G | DC Voltage measurement using 40 kV probe
blank | field not applicable

Rules:

  1. The MOD3 field may specify F or G only when the NOMINAL field specifies voltage.
  2. F is automatically inserted in the MOD3 field when DC Voltage is specified and the NOMINAL field value is greater than 1000 V and less than or equal to 6000 V.
  3. G is automatically inserted in the MOD3 field when DC Voltage is specified and the NOMINAL field value is greater than 6000 V.
  4. F or G may be specified at lower voltages to avoid connection changes.

MOD4

This field specifies the type of test being performed as described in the MOD4 Field topic.

CON

This field specifies the UUT connection.

2W | 2-wire
4W | 4-wire

Rules:

  1. The CON field may specify a 4 W only when the NOMINAL field specifies resistance.
  2. If 2 W is specified for a nominal value below 20 Ohm, the measurement is taken on the 200 Ohm range. 4 W must be specified if the 20 Ohm range is to be used.

Use of Standard Memory Locations and Results Reporting

System memory locations MEM and MEM1 are used. For more information, refer to the Use of Standard Memory Registers topic.

Examples

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
# ----- Reset -----
  1.001  8842         *                                                 S
# ----- DC Voltage -----
  1.002  8842   10    10V            1% 0.01U                              2W
  2.001  8842   2     1kV            5%                              F     2W
  3.001  8842   10    6kV            1%                              F     2W
  4.001  8842   100   40kV           20%                             G     2W
# ----- AC Voltage -----
  5.001  8842   1000  650V           5%            30kH                    2W
  6.001  8842   1     1V             1% 0.01U      10kH                    2W
# ----- dBm -----
  7.001  8842   A     69.268D        0.1U          1kH            5Z       2W
# ----- DC Current -----
  8.001  8842   4000  350mA          9U                                    2W
# ----- AC Current -----
  9.001  8842   2     1A             3%            60H                     2W
# ----- Resistance -----
 10.001  8842   100   10MZ           1%                                    2W
# ----- Conductance -----
 11.001  8842   100   100nY          5%                                    2W
# ----- Setup Test -----
 12.001  8842         1V                           10kH                 S  2W
# ----- Nominal Setup Test -----
 12.002  8842   1     1V                           10kH                 N  2W
# ----- Comparison Test -----
 12.003  8842   1     1V             1% 0.1U       20kH                 C  2W


8845 and 8846

Instrument FSC

Description

The 8845 and 8846 FSCs program the Fluke 8845A and 8846A Multimeters to measure DC voltage, AC voltage, dBm, decibels, DC current, AC current, resistance, frequency, period, capacitance (8846A only), and temperature (8846A only).

The following auxiliary functions are provided by the M8845 and M8846 FSCs:

  • Range Locking
  • Reference Impedance (also see 8845/8846 FSC MOD2)
  • dB Reference

If the 8845A/46A is to be controlled via its serial port, do not use the PORT FSC port configuration special construction, [P9600,N,...], to set the baud rate, parity, etc. of the port used to control the 8845A/46A. MET/CAL executes a "Test" function for each System Instrument prior to executing any procedure statements, therefore the settings of the port used to controlling the 8845A/46A must be set correctly before a procedure is executed. If the 8845A/46A is connected to a standard serial port (COM1, COM2, ..., COM16), select the "Ports" application in the Windows control panel to choose the proper settings. If the 8845A/46A is connected to the 5500A, 5520A, 5800A, or 5820A UUT port, select the proper settings for the UUT Serial Port from the front panel of the calibrator.

Functional Capability

Function | NOMINAL | MOD1
DC Voltage | -1000 V to 1000 V
AC Voltage | 0.1 mV to 750 V (8845A) | 3 Hz to 300 kHz 1
0.1 mV to 1000 V (8846A) | 3 Hz to 300 kHz 1
dBm | Limits are based ACV range and reference impedance specified:

Ref. Impedance

(see MOD2 & M884x FSC)

2, 4, 8, 16, 50, 75, 93, 110, 124, 125, 135, 150, 250, 300, 500, 600, 800, 900 Ω,

1, 1.2, & 8 kΩ
dB | Limits are based ACV limits
Resistance | 0 Ω to 199.99999 MΩ (8845A)
0 Ω to 1.9999999 GΩ (8846A)
DC Current | -10 A to 10 A
AC Current | 1 µA to 10 A | 3 Hz to 10 kHz
Frequency | 3 Hz to 300 kHz | 100 mV to 750 V (8845A, 1)
3 Hz to 1 MHz | 100 mV to 750 V (8846A, 1)
Period | 1 µs to 330 ms | 100 mV to 750 V (1)
Capacitance (8846A) | 100 pF to 199.9 mF
Temperature (8846A) | -200 °C to 600 °C
  1. V-Hz product not to exceed 8E+7

Parameters

RANGE

This field specifies the UUT range as described in the RANGE Field topic.

NOMINAL

This field specifies the expected measured value or a reset.

  • Voltage (DC or RMS) entered as [numeric][prefix]V
  • dBm entered as [numeric][prefix]D
  • Decibels entered as [numeric][prefix]dB
  • Resistance entered as [numeric][prefix]Z
  • Current entered as [numeric][prefix]A
  • Frequency entered as [numeric][prefix]H
  • Period entered as [numeric][prefix]T
  • Capacitance entered as [numeric][prefix]F (8846 FSC only)
  • Temperature entered as [numeric][prefix]degC, degF, or K (8846)
  • Reset entered as *

Rules:

  1. When the NOMINAL field units are dBm the 8845/8846 MOD2 field or the M8845/M8846 NOMINAL field must specify the reference impedance.
  2. When the NOMINAL field units are decibels the M8845/M8846 NOMINAL field must specify the reference value.
  3. When the NOMINAL field units are degC, degF, or Kelvin, the MOD2 field must specify the RTD type.
  4. When the NOMINAL field contains only units, the value is obtained from the memory register MEM.

TOLERANCE

This field specifies the UUT tolerance as described in the TOLERANCE Field topic.

MOD1

This field specifies frequency or amplitude for AC voltage, dBm, decibels, or AC current measurements.

  • Frequency entered as numeric[prefix]H
  • Voltage entered as numeric[prefix]V
  • blank not applicable

Rules:

  1. The MOD1 field may specify frequency only when the NOMINAL field specifies voltage, dBm, or decibels, or current.
  2. The MOD1 field must specify voltage when the NOMINAL field specifies frequency or period.
  3. The MOD1 field must be blank when the NOMINAL field specifies resistance, capacitance, or temperature.

MOD2

This field specifies the reference impedance (1) that the AC voltage is reference to for dBm or decibels, or the RTD type for temperature measurement.

3Z | 300 Ohm
5Z | 50 Ohm
6Z | 600 Ohm
7Z | 75 Ohm
R1 | 100 Ohm Pt 385 RTD (8846 FSC only)
blank | Not applicable
  1. Additional reference impedance values may be specified using the M8845/46 FSC.

Rules:

  1. The MOD2 field may specify a reference impedance only when the NOMINAL field specifies dBm.
  2. The MOD2 field must specify a reference impedance only when the NOMINAL field specifies dBm and the MOD3 field specifies the voltage measurement resolution.
  3. The MOD2 field may specify a RTD type only when the NOMINAL field specifies degC, degF, or K.

MOD3

This field specifies the resolution.

D4 | 4.5 digits
D5 | 5.5 digits
D6 | 6.5 digits
RS | Reference Set
RL | Relative
blank | Not applicable

Rules:

  1. The MOD3 field must be blank when the NOMINAL field units are farads.
  2. The MOD3 field may specify a Reference Set only when the NOMINAL field specifies capacitance.
  3. The MOD3 field may specify a Relative only when the NOMINAL field specifies capacitance.

MOD4

This field specifies the type of test being performed as described in the MOD4 Field topic.

CON

This field specifies the UUT connection.

2W | Selects 2-wire
4W | Selects 4-wire

Rules:

  1. The CON field may specify a 4W only when the NOMINAL field specifies resistance or temperature.
  2. 2W is inserted automatically in the CON field when no CON field code is entered.

Use of Standard Memory Locations and Results Reporting

System memory locations MEM and MEM1 are used. For more information, refer to the Use of Standard Memory Registers topic.

Examples

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON

  1.001  ASK-                              U

# -----  Reset -----
  1.002  M8846        *
  1.003  8846         *                                                 S

# -----  DC Voltage  -----
  1.004  8846         1.000V         0.001U                                2W
  2.001  M8846  RNGLK 10V
  2.002  8846         1.00V          0.01U                                 2W
  3.001  M8846        *

# -----  AC Voltage  -----
  3.002  8846         100.0mV        0.1U          1kH                     2W

# -----  2-Wire Resistance  -----
  4.001  8846         1.0000MZ       0.0010U                               2W

# -----  4-Wire Resistance  -----
  5.001  8846         100.00Z        1.00U                                 4W

# -----  DC Current  -----
  6.001  8846         1.0000mA       0.0100U                               2W
  7.001  8846         10.000A        0.100U                                2W

# -----  AC Current  -----
  8.001  8846         10.000mA       0.100U        10kH                    2W
  9.001  8846         10.000A        0.100U        1kH                     2W

# -----  Frequency  -----
 10.001  8846         100.00kH       1%            100mV                   2W

# -----  Period  -----
 11.001  8846         10.000mT       0.001U        1V                      2W

# -----  dBm  -----
 12.001  8846         -7.00D         1.00U         1kH            5Z       2W
 13.001  M8846  IMPED 50Z
 13.002  8846         -7.00D         1.00U         1kH                     2W
 14.001  M8846        *

# -----  dB  -----
# Get reference value.
 14.002  M8846  IMPED 50Z
 14.003  8846         -10.00D        1.00U         1kH                     2W
# Put reference value in MEM for M8846 statement.
 15.001  MATH         MEM = MEM1
 15.002  M8846  DBREF D
 15.003  8846         10.00dB        1.00U         1kH                     2W

# -----  Capacitance  -----
# Set reference value.
 16.001  8846         0nF                                            RS N  2W
# Take relative measurement.
 16.002  8846         1.000nF        0.100U                          RL    2W

# -----  Temperature (100 Ohm Pt 385)  -----
 17.001  8846         -190.0degC     1.0U                         R1       4W

# -----  DC Voltage Ratio  -----
 18.001  HEAD         DC VOLTAGE RATIO:  10 V / 2 V
 18.002  MATH         Input = "10V"; L[1] = BASE(Input);
 18.003  MATH         Ref   = "2V";  L[2] = BASE(Ref)
 18.004  MATH         NPLC  = "10"
 18.005  MATH         DevName = "Fluke 8846A"
 18.006  MATH         AccMode = "Volts NPLC " & NPLC
# Establish reset state for UUT.
 18.007  RESET        *RST;*OPC?[I!]
 18.008  SCPI         [@8846]CONF:DC:RATIO;:VOLT:DC:NPLC [V NPLC]
 18.009  TARGET       -p
 18.010  DISP         Connect the UUT to the 8846A as follows:
 18.010  DISP
 18.010  DISP         UUT                8846A
 18.010  DISP         NORMAL HI <------> INPUT HI
 18.010  DISP         NORMAL LO <------> INPUT LO
 18.010  DISP         AUX HI <---------> SENSE HI
 18.010  DISP         AUX LO <---------> SENSE LO
 18.011  IEEE2        OUT [V Input],[V Ref];OPER;*OPC?[I!]
# Get accuracy of input and reference voltage measurements.
 18.012  MATH         L[3] = ACCV(DevName, AccMode, L[1])
 18.013  MATH         L[4] = ACCV(DevName, AccMode, L[2])
# Convert to ppm.
 18.014  MATH         L[3] = L[3] / L[1] / 1E-6
 18.015  MATH         L[4] = L[4] / L[2] / 1E-6
# Accuracy is +/- (Input accuracy + Reference accuracy), where Input
# accuracy = DC Voltage accuracy for the HI to LO Input (in ppm of the
# Input voltage), and Reference accuracy = DC Voltage accuracy for the
# HI to LO (Sense) Reference (in ppm of the Reference voltage).
 18.016  MATH         L[5] = L[3] + L[4]
 18.017  TARGET       -m
 18.018  SCPI         [@8846]INIT
 18.019  SCPI         [@8846]FETCH?[I]
 18.020  ACC          ''             L5P%
 18.021  MEMC         5.00           0.01U


M8845 and M8846

Instrument FSC

Description

The M8845 and M8846 FSCs provide the following functions for the Fluke 8845A and 8846A Multimeters:

  • dB Reference
  • dBm Reference Impedance
  • Range Lock
  • NPLC
  • AC Detector Band (Filter)
  • External Trigger

Parameters

When a blank M8845/M8846 statement is entered, a "*" is inserted automatically in the NOMINAL field. See NOMINAL field parameter for a description of "*".

RANGE

This field specifies one of the following:

DBREF | dB Reference
IMPED | dBm Reference Impedance
RNGLK | Range Lock
blank | Not applicable

Rules:

  1. When the RANGE field specifies IMPED, the NOMINAL field must specify the reference impedance in ohms.
  2. When the RANGE field specifies RNGLK, the NOMINAL field must specify the range selection value.

NOMINAL

This field specifies the dB reference, dBm reference impedance, range lock selection value, or reset.

  • dB Reference entered as: numeric[prefix]D
  • dBm Reference Impedance entered as: numeric[prefix]Z
  • Voltage range entered as: numeric[prefix]V
  • Current range entered as: numeric[prefix]A
  • Resistance range entered as: numeric[prefix]Z
  • Capacitance range entered as: numeric[prefix]F
  • "*" Reset to default values

Rules:

  1. The NOMINAL field may specify a dB reference value only when the RANGE field is "DBREF".
  2. The NOMINAL field must specify a dB reference value when the 8845/8846 FSC NOMINAL field specifies dB.
  3. The NOMINAL field may specify a dBm reference impedance only when the RANGE field is "IMPED".
  4. The NOMINAL field must specify a dBm reference impedance when the 8845/8846 FSC NOMINAL field specifies dBm and the 8845/8846 FSC MOD2 field is not 3Z, 5Z, 6Z, or 7Z.
  5. Allowed values for dBm reference impedance are: 2 Ohm, 4 Ohm, 8 Ohm, 16 Ohm, 50 Ohm, 75 Ohm, 93 Ohm, 100 Ohm, 110 Ohm, 124 Ohm, 125 Ohm, 135 Ohm, 150 Ohm, 250 Ohm, 300 Ohm, 500 Ohm, 600 Ohm, 800 Ohm, 900 Ohm, 1 kOhm, 1.2 kOhm, and 8 kOhm.

  6. The NOMINAL field may specify a range only when the RANGE field specifies RNGLK.

    7. Legal Ranges:

    100 mV | 100 µA 3 | 10 Ohm 3 | 1 nF 3
    1 V | 1 mA 3 | 100 Ohm | 10 nF 3
    10 V | 10 mA | 1 kOhm | 100 nF 3
    100 V | 100 mA | 10 kOhm | 1 uF 3
    750 V 1 | 400 mA | 100 kOhm | 10 uF 3
    1000 V 2 | 1 A | 1 MOhm | 100 uF 3
    3 A | 10 MOhm | 1 mF 3
    10 A | 100 MOhm | 10 mF 3
    1 GOhm 3 | 100 mF 3
    1. 8845A ACV
    2. 8845A DCV, 8846A DCV & ACV
    3. 8846A only

  7. A M8845/M8846 range lock specification only applies when a subsequent 8845/8846 FSC specifies an applicable measurement function.

TOLERANCE

This field specifies the number of power line cycles for DC measurements.

  • NPLC entered as: numeric[prefix]NPLC
  • blank Reset to default values (10 NPLC)

Rules:

  1. Allowed values for NPLC are: 0.02, 0.2, 1, 10, 100.

MOD1

This field specifies the Detector band (filter) for AC measurements.

  • Detector band entered as: [numeric][prefix]H
  • blank Reset to default value or not applicable

Rules:

  1. Allowed values are 3 Hz, 20 Hz, and 200 Hz.
  2. When the detector band is not specified, the default is 20 Hz.
  3. When the MOD1 field contains only units, the value is obtained from the memory register MEM.

MOD2

This field is not used.

MOD3

This field is not used.

MOD4

This field specifies external trigger.

  • "X" External trigger
  • blank Bus trigger

CON

This field is not used.


8920

Instrument FSC

Description

The 8920 FSC programs the Fluke 8920A True RMS Voltmeter using the Fluke 1120A IEEE-488 translator and the -520 IEEE-488 Interface. Normally a MET/CAL instrument FSC will program the required instrument setup for a measurement. However, because the 8920A is a talk only device (cannot be programmed), a reading is taken to determine the current measurement units.

If the current units do not agree with the units in the NOMINAL field (Volts or dBm), an automatic message is generated to prompt the operator to select the correct display mode on the 8920A front panel. In addition, if the NOMINAL field units are dBm, and the current 8920A dBm reference value does not agree with the reference specified by the MOD2 field, an automatic message is also generated to prompt the operator to select the correct reference value.

It is not possible for MET/CAL to determine the current 8920A range and function (AC or AC+DC and filter on or off). The DISP FSC must be used to prompt the operator to perform any changes to the function and range settings.

Functional Capability

MEAS. MODE | NOMINAL | MOD1 | MOD2 | FUNCTION
DC Voltage | 180 μV to 700 V |  |  | AC+DC
AC Voltage | 180 μV to 700 V | 2 Hz to 30 MHz |  | AC or AC+DC
dBm | -61.88 dBm to 69.91 dBm | 2 Hz to 30 MHz | 5Z | AC or AC+DC
 | -63.65 dBm to 68.15 dBm | 2 Hz to 30 MHz | 7Z | AC or AC+DC
 | -69.67 dBm to 62.13 dBm | 2 Hz to 30 MHz | 3Z | AC or AC+DC
 | -72.68 dBm to 62.13 dBm | 2 Hz to 30 MHz | 6Z | AC or AC+DC

Parameters

RANGE

This field specifies the UUT range as described in the RANGE Field topic.

NOMINAL

This field specifies the expected measured value or a reset.

  • Voltage (DC or RMS) entered as: [numeric][prefix]V
  • dBm entered as: [numeric][prefix]D
  • Reset entered as *.

Rules:

  1. The NOMINAL field may specify decibels only when the MOD2 field specifies the reference impedance.

TOLERANCE

This field specifies the UUT tolerance as described in the TOLERANCE Field topic.

MOD1

This field specifies frequency for AC voltage.

  • Frequency entered as numeric[prefix]H.
  • blank DC

MOD2

This field specifies the load impedance that the AC voltage is referenced to.

5Z | 50 Ω
7Z | 75 Ω
3Z | 300 Ω
6Z | 600 Ω
blank | field not applicable

Rules:

  1. The MOD2 field may specify a reference impedance only when the NOMINAL field specifies decibels.
  2. 6Z is automatically inserted in the MOD2 field if no MOD2 field impedance code is entered.

MOD3

This field specifies the coupling for AC Voltage.

F | AC
blank | AC+DC

AC accuracy is better when using the AC mode (MOD3 = F).

Rules:

  1. The MOD3 field may specify F (AC) only when the MOD1 field specifies a frequency (AC Voltage).

MOD4

This field specifies the type of test being performed as described in the MOD4 Field topic.

CON

This field specifies the UUT connection and is always 2-wire (2 W). 2 W is inserted automatically in the CON field when no CON field code is entered.

Use of Standard Memory Locations and Results Reporting

System memory locations MEM and MEM1 are used. For more information, refer to the Use of Standard Memory Registers topic.

Examples

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
# -----  Reset  -----
  1.001  8920         *                                                 S
# -----  DC Voltage  -----
  1.002  DISP         Set the 8920A FUNCTION to AC+DC.
  1.003  8920   1000  650V           10%                                   2W
# -----  AC Voltage  -----
  2.001  DISP         Set the 8920A FUNCTION to AC.
  2.002  8920   10    10V            1% 0.1U       100kH             F     2W
  3.001  8920   1     1V             1% 0.1U       10kH                    2W
# -----  dBm  -----
  4.001  8920   A     50D            1U            1kH            6Z F     2W
# -----  Setup Test  -----
  5.001  8920         1V                           10kH              F  S  2W
# -----  Nominal Setup Test  -----
  5.002  8920   1     1V                           10kH                 N  2W
# -----  Comparison Test  -----
  5.003  8920   1     1V             1% 1U         20MH                 C  2W


9100

Instrument FSC

Description

The 9100 FSC controls the following functions of the Fluke and Wavetek 9100 Calibration System:

  • DC Voltage
  • AC Voltage (sine, square, pulse, triangle, trapezoid, impulse)
  • DC Current
  • AC Current (sine, square, pulse, triangle, trapezoid, impulse)
  • Resistance (resistance or conductance)
  • Frequency
  • Mark/Period (pulse)
  • % Duty (pulse)
  • Capacitance
  • Thermocouple Temperature
  • RTD Temperature

9100 with Option 135 (High Voltage Resistance)

  • Insulation
  • Continuity

9100 with Option 250 or Option 600 (250 MHz or 600 MHz Scope Module):

  • Square
  • DC Voltage
  • Leveled Sine
  • Edge Signal
  • Marker Signal

9100 with Option PWR (Power Module):

  • DC Power (voltage & current or dual voltage)
  • AC Power (voltage & current or dual voltage)
  • AC Harmonics
You must configure the instrument as a "Datron 9100" as shown in the drop-down list in the "Add Instrument" configure dialog.

Functional Capability

DC Voltage
-1050 V to 1050 V
AC Voltage
Sine | 0 V to 105 V | 10 Hz to 100 kHz
105.001 V to 320 V | 40 Hz to 30 kHz
320.01 V to 800 V | 40 Hz to 30 kHz
800.01 V to 1050 V | 40 Hz to 20 kHz
Square | 0 V to 147.9 V | 10 Hz to 1 kHz
147.9 V to 500 V | 45 Hz to 65 Hz
Impulse | 0 V to 78.05 V | 10 Hz to 1 kHz
78.05 V to 500 V | 45 Hz to 65 Hz
Triangle | 0 V to 85.7 V | 10 Hz to 1 kHz
85.7 V to 500 V | 45 Hz to 65 Hz
Trapezoid | 0 V to 131.9 V | 10 Hz to 1 kHz
131.9 V to 500 V | 45 Hz to 65 Hz
DC Current
-20 A to 20 A
±(3.2001 A to 200 A) 1
±(16.001 A to 1000 A) 2
AC Current
Sine | 0 mA to 320 mA | 10 Hz to 30 kHz
0.32001 A to 20 A | 10 Hz to 10 kHz
3.2001 A to 200 A | 10 Hz to 440 Hz 1
16.001 A to 1000 A | 10 Hz to 440 Hz 2
Square | 0 mA to 18 A | 10 Hz to 1 kHz
3.2001 A to 180 A | 10 Hz to 440 Hz 1
16.001 A to 900 A | 10 Hz to 440 Hz 2
Impulse | 0 mA to 15 A | 10 Hz to 1 kHz
3.2001 A to 150 A | 10 Hz to 440 Hz 1
16.001 A to 750 A | 10 Hz to 440 Hz 2
Triangle | 0 mA to 16.3 A | 10 Hz to 1 kHz
3.2001 A to 163 A | 10 Hz to 440 Hz 1
16.001 A to 815 A | 10 Hz to 440 Hz 2
Trapezoid | 0 mA to 19.2 A | 10 Hz to 1 kHz
3.2001 A to 192 A | 10 Hz to 440 Hz 1
16.001 A to 960 A | 10 Hz to 440 Hz 2
Resistance
0 Ω to 400 MΩ
2.5 nS to 2.5 mS
Frequency
0.5 Hz to 10 MHz

±(0.01 Vp to 30 Vp)*

*|Vp| + |offset| < 30 Vp
Mark/Period
0.6 us to 2000.00 ms

±(0.01 Vp to 30 Vp)*

*|Vp| + |offset| < 30 Vp
Pulse Width | 0.3 us to 1999.99 ms
% Duty
0.05% to 99.95%

+/-(0.01 Vp to 30 Vp)*

*|Vp| + |offset| < 30 Vp
Period | 0.6 us to 2000.00 ms
Capacitance
0.5 nF to 40 mF
RTD Temperature
Pt 385 | -200 °C to 850 °C | 10 Ω to 2 kΩ
Pt 392 | -200 °C to 630 °C | 10 Ω to 2 kΩ
TC Temperature
Type B | 0 °C to 1820 °C
Type C | 0 °C to 2320 °C
Type E | -250 °C to 1000 °C
Type J | -210 °C to 1200 °C
Type K | -250 °C to 1372 °C
Type L | -200 °C to 900 °C
Type N | -200 °C to 1300 °C
Type R | 0 °C to 1767 °C
Type S | 0 °C to 1767 °C
Type T | -250 °C to 400 °C
  1. Requires Option 200 (10-Turn Current Coil)
  2. Requires Option 200 (50-Turn Current Coil)

Option 135 (High Voltage Resistance)
Insulation | 100 kΩ to 2 GΩ
 | 0 V to 1350 V
 | 1 μA to 2.3 mA
Continuity | 0 Ω to 4 kΩ
 | 100 µA to 350 mA
Option PWR (Power Module)
DC Power
Primary Output | -1050 V to 1050 V
Aux Output
Voltage | 0 V to 7.5 V (1,5)
Current | ±(3.21 A to 200 A) 2
±(16.01 A to 1 kA) 3
AC Power
Primary Output
Sine | 0 V to 105 V | 10 Hz to 3 kHz 4
105.001 V to 1050 V | 40 Hz to 3 kHz 4
Square | 0 V to 147.936 V | 10 Hz to 1 kHz 4
147.937 V to 500 V | 45 Hz to 65 H 4
Impulse | 0 V to 78.059 V | 10 Hz to 1 kHz 4
78.060 V to 500 V | 45 Hz to 65 H 4
Triangle | 0 V to 85.732 V | 10 Hz to 1 kHz 4
85.733 V to 500 V | 45 Hz to 65 Hz 4
Trapezoid | 0 V to 130.958 V | 10 Hz to 1 kHz 4
130.959 V to 500 V | 45 Hz to 65 Hz 4
Aux Output
Sine
Voltage | 0.32 mV to 7.5 V | 10 Hz to 3 kHz 1,4,5
Current | 0 A to 20 A | 10 Hz to 3 kHz 4
3.21 A to 200 A | 10 Hz to 440 Hz 2,4
16.01 A to 1 kA | 10 Hz to 440 Hz 3,4
Square
Voltage | 0 V to 4.5 V | 10 Hz to 1 kHz 1,4,5
Current | 0 mA to 18 A | 10 Hz to 1 kHz 4
3.21 A to 180 A | 10 Hz to 440 Hz 2,4
16.01 A to 900 A | 10 Hz to 440 Hz 3,4
Impulse
Voltage | 0 V to 2.38 V | 10 Hz to 1 kHz 1,4,5
Current | 0 mA to 15 A | 10 Hz to 1 kHz 4
3.21 A to 150 A | 10 Hz to 440 Hz 2,4
16.01 A to 750 A | 10 Hz to 440 Hz 3,4
Triangle
Voltage | 0 V to 2.61 V | 10 Hz to 1 kHz 1,4,5
Current | 0 mA to 16.3 A | 10 Hz to 1 kHz 4
3.21 A to 163 A | 10 Hz to 440 Hz 2,4
16.01 A to 815 A | 10 Hz to 440 Hz 3,4
Trapezoid
Voltage | 0 V to 4.02 V | 10 Hz to 1 kHz 1,4,5
Current | 0 mA to 19.2 A | 10 Hz to 1 kHz 4
3.21 A to 192 A | 10 Hz to 440 Hz 2,4
16.01 A to 960 A | 10 Hz to 440 Hz 3,4
Phase | -180 deg to 180 deg
AC Harmonic
Primary Output
Sine | 0 V to 1050 V | 50, 60, or 400 Hz 4
Aux Output
Sine
Voltage | 0.32 mV to 7.5 V | 50, 60, or 400 Hz 4
Current | 0 A to 20 A | 50, 60, or 400 Hz 4
3.21 A to 200 A | 50, 60, or 400 Hz 2,4
16.01 A to 1 kA | 50 or 60 Hz
Phase | -180 deg to 180 deg
Harmonic | 1 to 40
  1. Using appropriate V/A scale factor.
  2. Requires Option 200 (10-Turn Current Coil)
  3. Requires Option 200 (50-Turn Current Coil)
  4. Actual maximum frequency is the lower of the maximum frequency for the primary channel signal and the maximum frequency for the auxiliary channel signal.
  5. An auxiliary channel output voltage is obtained by specifying a current and a V/A scale factor. The range of legal scale factors is 45 uV to 10 mV. The allowed current range is then computed from the scale factor and the aux voltage range.

Option 250 and Option 600 (Scope Calibrators)
Square
1 MΩ term. | 4.44 mVpp to 133.44 Vpp | 1 kHz/1 ms
50 Ω term. | 4.44 mVpp to 3.336 Vpp | 1 kHz/1 ms
DC Voltage
1 MΩ term. | ±(4.44 mV to 133.44 V) |
50 Ω term. | ±(4.44 mV to 2.78 V) |
Leveled Sine
1 MΩ term. | 4.44 mVpp to 133.44 Vpp | 10 Hz to 49.999 kHz
 | 4.44 mVpp to 133.44 Vpp | 20.001 us to 100 ms
50 Ω term. | 10 Hz to 49.999 kHz |
 | 4.44 mVpp to 5.56 Vpp | 20.001 us to 100 ms
50 Ω term. | 10.656 mVpp to 5.56 Vpp | 50 kHz to 250 MHz
 | 10.656 mVpp to 5.56 Vpp | 1.6666 ns to < 100 ms
50 Ω term. | 10.656 mVpp to 3.336 Vpp | > 250 MHz to 600 MHz
 | 10.656 mVpp to 3.336 Vpp | 4.0000 ns to 1.6665 ns
Edge
1 MΩ term. | 88.8 mVpp to 55.6 Vpp | 100 Hz to 100 kHz* or
 |  | 10 us to 10 ms*
50 Ω term. | 88.8 mVpp to 1.112 Vpp | 100 Hz to 10 MHz* or
 |  | 0.1 us to 10 ms*
Marker (50 Ω only)
 | 4.0000 ns to 5.5005 s 1 | 0.1, 0.2, 0.5 & 1 Vpp
 | 0.1818 Hz to 250 MHz 1 | 0.1, 0.2, 0.5 & 1 Vpp
 | 1.6666 ns to 5.5005 s 2 | 0.1, 0.2, 0.5 & 1 Vpp
 | 0.1818 Hz to 600 HHz 2 | 0.1, 0.2, 0.5 & 1 Vpp
*in a 1-2-5 sequence

Parameters

The following table describes the basic operating modes of the 9100 Calibrator in terms of the FSC fields listed. Only the combinations of field quantities listed below are allowed. These mode names are also used in other places in this section to clarify the rules for each parameter of the 9100 FSC.

Units Symbols
Units Symbol | Name | Quantity
A | Amps | current
App | Amps peak to peak | current
F | Farads | capacitance
H | Hertz | frequency
K | Kelvin | temperature
T | Time | period or pulse width
V | Volts | voltage
VA | Volt-Amps | power
VAR | Volt-Amps reactive power |
Vp | Volts peak |
Vpp | Volts peak to peak voltage |
W | Watts | power
Y | Siemens | conductance
Z | Ohms | resistance
deg | degrees | phase
degC | degrees Celsius | temperature
degF | degrees Fahrenheit temperature |
pct | duty cycle | percent
9100 FSC NOMINAL, MOD1, MOD2, MOD3, and CON Rules
9100 Mode | 9100 NOMINAL | 9100 MOD1 | 9100 MOD2 1 | 9100 MOD3 2 | 9100 CON 3
DC Voltage | V | 2W
AC Voltage | V|Vpp | H|T | SI|SQ|IP|TI|TZ | 2W
H|T | V|Vpp | SI|SQ|IP|TI|TZ | 2W
DC Current | A | 2W|T1|T5
AC Current | A|App | H|T | SI|SQ|IP|TI|TZ | 2W|T1|T5
Resistance | Z|Y | 2W|4W
Frequency | H|T | Vp | ZQ | 2W
Vp | H|T | ZQ | 2W
Mark/Period (pulse) | H|T | Vp | PU | 2W
Vp | H|T | PU | 2W
% Duty (pulse) | pct | Vp | PU | 2W
Capacitance | F | 2W|4W
TC Temperature | degC|degF|K | _B|_C|_E|_J|_K| _L|_N|_R|_S|_T | TC | 2W
RTD Temperature | degC|degF|K | Z | R1|R9 | 2W|4W
DC Power | W|V | PR | 2W|T1|T5
A | AX | 2W|T1|T5
AC Power | W|VA|VAR | H|T | SI | PR | 2W|T1|T5
V|Vpp | H|T | SI|SQ|IP|TI|TZ | PR | 2W|T1|T5
A|App | H|T | SI|SQ|IP|TI|TZ | AX | 2W|T1|T5
H|T | V|Vpp | SI|SQ|IP|TI|TZ | PR | 2W|T1|T5
deg | H|T | SI|SQ|IP|TI|TZ | PR | 2W|T1|T5
AC Harmonic | V|Vpp | H | SI | MN|MX | 2W|T1|T5
A|App | H | SI | MX | 2W|T1|T5
H | V|Vpp | SI | MN | 2W|T1|T5
deg | H | SI | MN | 2W|T1|T5
Scope (Square) | V|Vpp | H|T | ZQ | SC | [L]
H|T | V|Vpp | ZQ | SC | [L]
Scope (DCV) | V | SC | [L]
Scope (Leveled Sine) | V|Vpp | H|T | LS | SC | [L]
H|T | V|Vpp | LS | SC | [L]
Scope (Edge) | V|Vpp | H|T | ED | SC | [L]
H|T | V|Vpp | ED | SC | [L]
Scope (Marker) | H|T | Vpp | MK | SC | L
Insulation | Z | [SE] | HV | 2W
V|A | Z | SE | HV | 2W
Continuity | Z | [SE] | CO | 4W
A | Z | SE | CO | 4W
Blank entries in the above table are significant and must be blank. FSC field inter-dependencies not expressed in this table are listed under "Rules" for the appropriate parameter.
  1. See MOD2 parameter for description of these specification codes.
  2. See MOD3 parameter for description of these specification codes.
  3. See CON parameter for description of these specification codes.

RANGE

This field specifies the UUT range as described in the RANGE Field topic.

NOMINAL

This field specifies the starting Nominal value of the stimulus output or expected UUT reading for the test entered as:

[numeric][prefix]units symbol

or "*" to specify a reset.

Rules:

  1. When the NOMINAL field units are "W" (Watts), the M9100 NOMINAL field must specify the auxiliary channel current.
  2. When the NOMINAL field units are "deg" (phase), the M9100 MOD1 field must specify the primary channel voltage.
  3. When the NOMINAL field contains only units, the value is obtained from memory register MEM.

TOLERANCE

This field specifies the UUT tolerance as described in the TOLERANCE Field topic.

MOD1

This field specifies the frequency, period, voltage, or current for AC Voltage, AC Current, Dual AC Voltage, or AC Power modes entered as:

[numeric][prefix]units symbol

Rules:

  1. When the MOD1 field contains only units, the value is obtained from memory register MEM.

MOD2

This field specifies the waveform, thermocouple, or RTD type or source vs. sense (read) for High Voltage Resistance mode.

blank | not applicable
SI | AC Voltage, Current, or Power Modes (Sine)
SQ | AC Voltage, Current, or Power Modes (Square)
IP | AC Voltage, Current, or Power Modes (Impulse)
TI | AC Voltage, Current, or Power Modes (Triangle)
TZ | AC Voltage, Current, or Power Modes (Trapezoid)
_B | TC Temperature Mode (Type B)
_C | TC Temperature Mode (Type C)
_E | TC Temperature Mode (Type E)
_J | TC Temperature Mode (Type J)
_K | TC Temperature Mode (Type K)
_L | TC Temperature Mode (Type L)
_N | TC Temperature Mode (Type N)
_R | TC Temperature Mode (Type R)
_S | TC Temperature Mode (Type S)
_T | TC Temperature Mode (Type T)
R1 | RTD Temperature Mode (Pt 385)
R9 | RTD Temperature Mode (Pt 392)
PU | Pulse Mode (Mark/Period or % Duty)
ZQ | Frequency Mode (Hz) or Scope Mode (Square)
LS | Scope Mode (Leveled Sine)
ED | Scope Mode (Edge signal)
MK | Scope Mode (Marker signal)
SE | Insulation or Continuity Mode (Sense "Read" Nominal value)

Rules:

  1. SI is inserted automatically in the MOD2 field for AC Voltage, AC Current, or AC Power mode (i.e. the MOD1 field is not blank) if no MOD2 code is entered.
  2. _K is inserted automatically in the MOD2 field for TC Temperature if no MOD2 code is entered.
  3. R1 is inserted automatically in the MOD2 field for RTD Temperature if no MOD2 code is entered.
  4. The M9100 RANGE and NOMINAL field must specify the pulse period or pulse repetition frequency when the MOD2 field specifies PU and the NOMINAL field specifies the duty cycle or pulse width.
  5. The M9100 RANGE and NOMINAL field must specify the pulse width when the MOD2 field specifies PU and the NOMINAL or MOD1 field specifies the pulse period or pulse repetition frequency.

MOD3

This field specifies the calibrator option required or TC. In addition, for Power mode, the channel associated with the MOD2 field and the amplitude specified in the 9100 NOMINAL or M9100 MOD1 field. TC is supported simply to make it easier to convert 55xxA based procedures to 9000 based procedures.

PR | Option PWR (Power Module) Power mode Primary channel
AX | Option PWR (Power Module) Power mode Auxiliary channel
MN | Option PWR (Power Module) Harmonic mode Primary channel
MX | Option PWR (Power Module) Harmonic mode Auxiliary channel
SC | Option 250 or Option 600 (Scope Calibrator)
HV | Option 135 (High Voltage Resistance) Insulation mode
CO | Option 135 (High Voltage Resistance) Continuity mode
TC | Thermocouple simulation
blank | No option required

Rules:

9100 & M9100 NOMINAL, MOD1, and MOD3 Rules
Mode (function) | NOMINAL | MOD1 | MOD3 | NOMINAL | MOD1 | MOD3
 | 9100 |  |  | M9100
DC Power | V |  | PR | A |  | AX
 | A |  | AX | V |  | PR
AC Power | W|VA|VAR|V|Vpp | H|T | PR | A|App | [deg] | AX
 | A|App | H|T | AX | V|Vpp | [deg] | PR
 | H|T | V|Vpp | PR | A|App | [deg] | AX
 | deg | H|T | PR | A|App | V|Vpp | AX
AC Harmonic | H|T | MN | A|App|V|Vpp | [deg] | MX
 | A|App|V|Vpp | H|T | MX | V|Vpp | [deg] | MN
 | H|T | V|Vpp | MX | A|App|V|Vpp | [deg] | MX
 | deg | H|T | MN | A|App|V|Vpp | V|Vpp | MX
Insulation | Z |  | HV |  |  |
 | A | Z | HV |  |  |
 | V | Z | HV |  |  |
Continuity | Z |  | CO |  |  |
 | A | Z | CO |  |  |
TC Temperature | degC|degF |  | TC |  |  |
Blank entries in this table are significant and must be blank.

MOD4

This field specifies the type of test being performed as described in the MOD4 Field topic.

CON

This field specifies the UUT connection.

2W | 2-wire
4W | 4-wire
T1 | Option 200 10-turn Toroid Coil
T5 | Option 200 50-turn Toroid Coil
L | 50 Ohm Termination (scope modes only)
blank | 1 MOhm Termination (scope modes only)

Rules:

  1. The CON field may specify 4W only for Resistance, Capacitance, RTD Temperature, or High Voltage Resistance mode.
  2. The CON field may specify T1 or T5 only under the following conditions:
    1. DC Current or AC Current mode, or
    2. DC Power or AC Power mode and the M9100 Tolerance field does not specify a V/A scale factor, or
    3. AC Harmonic mode and either the 9100 Nominal field or the M9100 Nominal field specifies current.
  3. The CON field may specify L or be blank only for scope modes.
  4. The CON field must be L for Scope Marker mode.
  5. L is inserted automatically in the CON field for Scope Marker mode if no CON field code is entered.

Use of Standard Memory Locations and Results Reporting

System memory locations MEM and MEM1 are used. For more information, refer to the Use of Standard Memory Registers topic.

Examples

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
# -----  Reset  -----
  1.001  M9100        *
  1.002  9100         *                                                 S
# -----  DC Voltage  -----
  1.003  9100   20    19.99mV        2% 0.04U                              2W
# -----  AC Voltage (sine)  -----
  2.001  9100   400   350.0mV        -2.8U +2.9U   60H            SI       2W
# -----  AC Voltage (square)  -----
  3.001  9100         1V                           1kH            SQ    S  2W
# -----  AC Voltage (impulse)  -----
  3.002  9100         1V                           1kH            IP    S  2W
# -----  AC Voltage (triangle)  -----
  3.003  9100         13mVpp                       100H           TI    S  2W
# -----  AC Voltage (trapezoid)  -----
  3.004  9100         1V                           1kH            TZ    S  2W
# -----  DC Current  -----
  3.005  9100   400   350mA          9U                                    2W
# -----  AC Current (sine)  -----
  4.001  9100         350.0mA                      60H            SI    S  2W
# -----  AC Current (square)  -----
  4.002  9100         1mA                          1kH            SQ    S  2W
# -----  AC Current (impulse)  -----
  4.003  9100         100mA                        1kH            IP    S  2W
# -----  AC Current (triangle)  -----
  4.004  9100         13mApp                       440H           TI    S  2W
# -----  AC Current (trapezoid)  -----
  4.005  9100         1mA                          1kH            TZ    S  2W
# -----  Resistance  -----
  4.006  9100   400   390.0Z         0.4% 0.1U                             4W
  5.001  9100   4     3.900MZ        0.05U                                 2W
# -----  Conductance  -----
  6.001  9100         2.50uY                                            N  2W
# -----  Capacitance ----
  6.002  9100   10    1.100uF        2% 0.002U                             2W
# -----  Frequency Function  -----
  7.001  9100         1kH                          1Vp            ZQ    S  2W
  7.002  M9100                                     1Voff
  7.003  9100         -1.00Vp                      1kH            ZQ    N  2W
# -----  Marker/Period (pulse) Function  -----
  7.004  M9100  PULSE 10uT
  7.005  9100         1mT                          1Vp            PU    S  2W
  7.006  M9100  PER   200mT
  7.007  9100         1mT                          1Vp            PU    S  2W
  7.008  M9100  PULSE 10uT                         -10Voff
  7.009  9100         -5.00Vp                      1kH            PU    N  2W
# -----  % Duty (pulse) Function  -----
  7.010  M9100  PER   200mT
  7.011  9100         0.5pct                       1Vp            PU    S  2W
# -----  TC Temperature  -----
  7.012  M9100  TS68
  7.013  9100         50degC         1U                           _K TC    2W
# -----  RTD Temperature  -----
  8.001  9100         45degC                       100Z           R1    S  4W

# ==============================  Option 135  ================================

  8.002  DISP         Set UUT to MOhm, 250V.
  8.003  M9100                                                             HI
  8.004  9100         1.0mA                        250kZ          SE HV N  2W
  8.005  EVAL   -e MEM > 1.0 : Current [MEM]mA
  9.001  9100         250.0V         20%           250kZ          SE HV    2W
 10.001  DISP         Set UUT to MOhm, 500V
 10.002  M9100                                                             SP
 10.003  9100         1.0mA                        500kZ          SE HV N  2W
 10.004  EVAL   -e MEM > 1.0 : Current [MEM]mA
 11.001  9100         500.0V         20%           500kZ          SE HV    2W
 12.001  DISP         Set UUT to MOhm, 1000V
 12.002  M9100                                                             SP
 12.003  9100         1.0mA                        1MZ            SE HV N  2W
 12.004  EVAL   -e MEM > 1.0 : Current [MEM]mA
 13.001  9100         1000V          20%           1MZ            SE HV    2W
 14.001  DISP         Set UUT to LO Ohm.
 14.002  M9100                                                             HI
 14.003  9100         1.000mA                      1kZ            SE CO N  4W
 14.004  EVAL   -e MEM > 1.0 : Current [MEM]mA
 15.001  M9100        *

# ==========================  Option 250 & 600  ==============================

# -----  DC Voltage  -----
 15.002  9100   20    19.99mV        4%                              SC
# -----  Square Voltage  -----
 16.001  9100   400   350.0mV        50U           1kH            ZQ SC
# -----  Edge Signal  -----
 17.001  9100         0.5Vpp                       1MH            ED SC S  L
# -----  Leveled Sine Wave  -----
 17.002  9100         200mVpp                      50kH           LS SC S  L
 17.003  9100         1.00MH         1%            100mVpp        LS SC    L
# -----  Marker Signal  -----
 18.001  9100         1uT                          0.2Vpp         MK SC S  L

# ===============================  Option PWR  ===============================

# -----  DC Power  -----
 18.002  M9100        1V                                             PR
 18.003  9100         1.000A                                         AX S  2W
 18.004  M9100        10A            45uV/A                          AX
 18.005  9100         1W                                             PR S  2W
 18.006  M9100        10A                                            AX
 18.007  9100         1.000kW                                        PR S  2W
# -----  DC Power w/Option 200 10-turn coil  -----
 18.008  M9100        100A                                           AX
 18.009  9100         10.00kW                                        PR S  T1
# -----  DC Power w/Option 200 50-turn coil  -----
 18.010  M9100        500A                                           AX
 18.011  9100         -100.0kW                                       PR S  T5

# -----  AC Power (Watts)  -----
 18.012  M9100        10A                          0deg           SI AX
 18.013  9100         1W                           1kH            SI PR S  2W

# -----  AC Power (Watts), UUT with 1mV/A Current Clamp input  -----
 18.014  RSLT         =
 18.015  RSLT         =100 V, 150 A @ 60 Hz
 18.016  MATH         L[1] = ACCV2("Datron 9100", S[1], 150, 60)
 18.017  MATH         L[1] = (L[1] / 150) * 100
 18.018  MATH         L[2] = ACCV2("Datron 9100", "Volts SI", 100, 60)
 18.019  MATH         L[2] = (L[2] / 100) * 100
# Compute phase accuracy in percent.
 18.020  MATH         L[4] = ACCV2("Datron 9100", "Phase SI V", 100, 60)
 18.021  MATH         L[5] = ACCV2("Datron 9100", "Phase SI V AUX", 0.15, 60)
 18.022  MATH         L[3] = L[4] + L[5]
 18.023  MATH         L[3] = (L[3] / 157) * 100
# ACC tolerance is RSS of the NORMAL & AUX voltage accuracies + phase adder.
 18.024  MATH         M[1] = RSS3(L[1], L[2], L[3])
 18.025  M9100        150A           1mV/A         157.0deg       SI AX
 18.026  TARGET
 18.027  9100         100V                         60H            SI PR S  2W
 18.028  ACC          -13.8kW        M1%
 18.029  MEMI         Enter UUT reading in kilowatts.
 18.030  MEMCX        -13.8kW        1% 0.4U

# -----  AC Power (VA), UUT with 1mV/A Current Clamp input  -----
 19.001  9100         100V                         60H            SI PR S  2W
 19.002  ACC          15.0kVA        M1%
 19.003  MEMI         Enter UUT reading in kilovolt-amps.
 19.004  MEMCX        15.0kVA        1% 0.4U

# -----  AC Power (VAR), UUT with 1mV/A Current Clamp input  -----
 20.001  9100         100V                         60H            SI PR S  2W
 20.002  ACC          5.9k'VAR'      M1%
 20.003  MEMI         Enter UUT reading in units of kVAR.
 20.004  MEMCX        5.9k'VAR'      1% 0.4U

# -----  AC Power (Phase), UUT with 1mV/A Current Clamp input  -----
 21.001  MATH         L[1] = ACCV2("Datron 9100", "Phase SI V", 100, 60)
 21.002  MATH         L[2] = ACCV2("Datron 9100", "Phase SI V AUX", 0.15, 60)
 21.003  MATH         M[1] = L[1] + L[2]
 21.004  M9100        150A           1mV/A         100V           SI AX
 21.005  TARGET
 21.006  9100         157deg                       60H            SI PR S  2W
 21.007  ACC          157deg         M1U
 21.008  MEMI         Enter UUT reading in degrees.
 21.009  MEMCX        157deg         2U

# -----  AC Harmonic  -----
 22.001  RSLT         =
 22.002  HEAD         { 9th HARMONIC}: Amps
 22.003  TARGET
 22.004  M9100  HX9   7V                           30deg          SI MN
 22.005  9100         20mV                         60H            SI MX S  2W
 22.006  DISP         Move the cursor to the 9th harmonic.
 22.007  ACC          20.0A          M1%
 22.008  MEMI         Enter UUT reading in amps.
 22.009  MEMCX  A     20.0A          3% 0.3U       60H

 23.001  M9100  HX9   20mV                         7V             SI MX
 23.002  9100         30deg                        60H            SI MN S  2W
 23.003  ACC          30deg          M1U
 23.004  MEMI         Enter UUT reading in degrees.
 23.005  MEMCX        30deg          9U            60H


M9100

Auxiliary Instrument Setup FSC

Description

The M9100 FSC provides the additional program functions for the Datron 9100 Calibrator which are not addressed by the 9100 FSC.

Parameters

For a description of the 9100 Calibrator operating modes referenced in this section, see the 9100 Instrument FSC description.

Units Symbols
Units Symbol | Name | Quantity
A | Amps | current
App | Amps peak to peak | current
H | Hertz | frequency
T | Time | period or pulse width
V | Volts | voltage
Voff | Volts offset | DC offset
Vpp | Volts peak to peak voltage |
V/A | Volts per Amp | scale factor (see Tolerance field)
deg | degrees | phase
M9100 FSC RANGE, NOMINAL, TOLERANCE, MOD1, MOD2, and MOD3 Rules
Mode (function) | RANGE | NOMINAL | TOL | MOD1 | MOD2 | MOD3
Frequency | [Voff] |  |  |  |  |
Mark/Period (pulse) | PER|PULSE | T|H |  | [Voff] |  |
% Duty (pulse) | PER | T|H |  | [Voff] |  |
RTD Temperature | [TS68|TS90] |  |  |  |  |
TC Temperature | [TS68|TS90] |  |  |  |  |
DC Power |  | V | [V/A] |  |  | PR
 |  | A | [V/A] |  |  | AX
AC Power |  | V|Vpp | [V/A] | [deg] | SI|SQ|IP|TI|TZ | PR
 |  | A|App | [V/A] | [deg] | SI|SQ|IP|TI|TZ | AX
 | A|App |  | [V/A] | [V|Vpp] | SI|SQ|IP|TI|TZ | AX
AC Harmonic | HXn | V|Vpp |  | [deg] | SI | MN
 | HXn | A|App|V|Vpp |  | [deg] | SI | MX
 | HXn | A|App|V|Vpp |  | [V|Vpp] | SI | MX
Scope Edge | RISE|FALL |  |  |  |  |
Blank entries in the above table are significant and must be blank. FSC field inter-dependencies not expressed in this table are listed under "Rules" for the appropriate parameter.

RANGE

This field specifies one of the following:

HXn | Selects harmonic on auxiliary channel, 1 to 40
PULSE | Pulse Width
PER | Pulse Period
RISE | Polarity (Edge)
FALL | Polarity (Edge)
TS68 | TS68 temperature scale
TS90 | TS90 temperature scale
blank | default or field not applicable

Rules:

  1. For RTD and TC Temperature modes, if the RANGE field does not specify the temperature scale, the default is TS90.
  2. For Scope Edge mode, if the RANGE field does not specify RISE or FALL, the default is RISE.
  3. The RANGE field may only specify FALL for Edge mode when the 9100 FSC CON field specifies 50 Ohm output impedance "L".
  4. The RANGE field must specify PULSE or PER when the 9100 MOD2 field is PU.

NOMINAL

This field specifies one of the following entered as:

[numeric][prefix]units symbol

  • Pulse Period or Pulse Repetition Frequency
  • Pulse Width
  • Signal amplitude for the % Duty function by the MOD3 field.
  • Signal amplitude for the power or harmonic mode channel specified by the MOD3 field.
  • "*" reset to default values
  • blank field not applicable

Rules:

  1. The NOMINAL field must specify the pulse period or pulse repetition frequency when the M9100 RANGE field is PER.
  2. The NOMINAL field must specify the pulse width when the M9100 RANGE field is PULSE.
  3. When the NOMINAL field contains only units, the value is obtained from memory register MEM.
  4. When the NOMINAL field specifies reset "*", all other fields must be blank.

TOLERANCE

This field is used to specify the scale factor applied to the auxiliary channel, when in 'auxiliary voltage' power mode, to calculate the effective voltage on the auxiliary channel.

This field is entered as:[numeric][prefix]V/A

Rules:

  1. When the TOLERANCE field contains only units, the value is obtained from memory register MEM.

MOD1

This field specifies one of the following:

  1. DC offset for Frequency or Mark/Period (pulse) mode or
  2. The phase for AC Power or AC Harmonic mode or
  3. The primary voltage for AC Power or AC Harmonic mode when the 9100 NOMINAL field specifies phase.

Values are entered as:

[numeric][prefix]units symbol

Rules:

  1. The MOD1 field may specify voltage or current only when the 9100 NOMINAL field specifies phase.
  2. The MOD1 field may specify DC offset only for Frequency and Mark/Period (pulse), and % Duty (pulse) modes.
  3. When the MOD1 field is blank the DC offset is set to zero.
  4. When the MOD1 field contains only units, the value is obtained from memory register MEM.

MOD2

This field specifies the waveform for the power mode channel specified by the MOD3 field.

blank | DC
SI | Sine
SQ | Square
IP | Impulse
TI | Triangle
TZ | Trapezoid

MOD3

This field specifies the channel associated with the Power mode parameters specified in the NOMINAL and MOD2 fields.

PR | Power mode Primary channel
AX | Power mode Auxiliary channel
MN | Harmonic mode Primary channel
MX | Harmonic mode Auxiliary channel
blank | not applicable

Rules:

  1. See 9100 MOD3 field rules.

MOD4

This field is not used.

CON

This field specifies the 9105 Work Mat connection for current or the UUT source current for Resistance, Capacitance, and RTD Temperature modes.

C1 | 9105 Work Mat yellow lead (I+20A)
C2 | 9105 Work Mat white lead (I+mA)
LO | Low UUT source current
HI | High UUT source current
SP | Super High UUT source current
blank | Applicable default (C1 or LO)

Rules:

Mode (function) | 9100 CON | M9100 CON | Connection
DC Current | 2W | [C1] | 9105 Work Mat Yel & Blk
 | 2W | C2 | 9105 Work Mat Wht & Blk
 | T1|T5 | [C1] | 9100 I+ & I-
AC Current | 2W | [C1] | 9105 Work Mat Yel & Blk
 | 2W | C2 | 9105 Work Mat Wht & Blk
 | T1|T5 | [C1] | 9100 I+ & I-
Resistance | 2W|4W | [LO|HI|SP] | 9105 Work Mat Red & Blk
Capacitance | 2W|4W | [LO|SP] | 9105 Work Mat Red & Blk
RTD Temperature | 2W|4W | [LO|HI|SP] | 9105 Work Mat Red & Blk
Continuity | 4W | [HI|SP] | 9100 HI & LO Terminals
 |  |  | 9100 I+ & I- as sense-
Insulation | 2W | [HI|SP] | 9100 HI & LO Terminals

Examples

See 9100 FSC.


9640, LPN, LPNX, 96040A and 96270A

Instrument FSCs

Description

The FSCs control the following Fluke RF Reference Sources:

FSC | System Instrument Name
9640 1 | Fluke 9640A
LPN 2 | Fluke 9640A-LPN
LPNX 3 | Fluke 9640A-LPNX
96040A 4 | Fluke 96040A
96270A | Fluke 96270A
  1. A 9640 FSC will execute without modification with a 9640A-LPN, 9640A-LPNX, 96040A, or 96270A configured and connected.
  2. A LPN FSC will execute without modification with a 9640A-LPNX, 96040A, or 96270A configured and connected.
  3. A LPNX FSC will execute without modification with a 96040A or 96270A configured and connected.
  4. A 96040A FSC will execute without modification with a 96270A configured and connected.

Parameters

An NVI FSC statement consists of one or more parameters. A parameter consists of a name and a value. Each parameter must be separated by a semicolon and/or one or more spaces. A single NVI FSC statement can encompass more than one physical line as long as the line numbers are the same. However each parameter name and its value must occur on one line. A single line can accommodate up to 256 characters including the statement number and FSC. Note that characters above ASCII 128 count as 2 characters.

Syntax:

parameter[separatorparameter]

parameter::= [parameter_prefix]parameter_name[[sp]=[sp]parameter_value]

separator::= ;[sp] | sp

parameter_prefix ::=+ | @

sp::= one or more spaces

parameter_name::= see the Parameter Names section

parameter_value::=dimensionless number | dimensioned number | discrete_list

dimensionless number::=NRf

dimensioned number::=NRf[sp][prefix]units

discrete_list::=see the Parameter Names section

prefix::=y | z | a | f | p | n | u | m | k | M | G | T | P | E | Z | Y

Definitions:

|
Denotes "or" (i.e. A | B is A or B)
[ ]
Denotes an optional syntax element, except in examples. In examples [ ] enclose a special construction.
+
Designates the parameter as the Evaluation Quantity
@
Designates the parameter as the Modifier Quantity

Example(s):

The following 9640/LPNX statements are identical with respect to the instrument:

  1.001  9640         +Level = 3 dBm; @Freq = 500 MHz; OutputImp = 50 Ohm

  1.002  MATH         L[1] = 500
  1.003  LPNX         +Level = 3 dBm; @Freq = [L1] MHz; OutputImp = 50 Ohm

  1.004  MATH         M[1] = 3
  1.005  9640         Apply
  1.005  9640         +Level = [M1] dBm
  1.005  9640         @Freq = 500 MHz
  1.005  9640         OutputImp = 50 Ohm

Rules:

  1. One and only one parameter must be designated as the Evaluation Quantity in a Apply (default), Setup, or Slew statement.
  2. When an Apply (default) statement is executed, the value of the Evaluation Quantity is copied to memory register MEM1 in base units.

    Example:

    9640 +Freq = 500 MHz; Level = 3 dBm; OutputImp = 50 Ohm

    or

    9640 Apply; +Freq = 500 MHz; Level = 3 dBm; OutputImp = 50 Ohm

    After the 9640 statement is executed the value of MEM1 is 500.

  3. When an Operate statement is executed, the value of the Evaluation Quantity designated in the previous Setup or Apply statement is copied to memory register MEM1 in base units.

    Example:

    LPNX Setup; +Freq = 500 MHz; Level = 3 dBm; OutpImp = 50 Ohm

    LPNX Operate; +Freq = 500 MHz; Level = 3 dBm; OutpImp = 50 Ohm

    After the LPNX Operate statement is executed the value of MEM1 is 500.

    The Setup by itself DOES NOT copy the Evaluation Quantity to MEM1. Only a subsequent Operate action will do this.
  4. When a Slew statement is executed, the Evaluation Quantity designates the slew quantity.
  5. When a Slew statement is executed, the final slew value is copied to memory register MEM in base units.

    Example:

    9640 Slew; +Freq = 500 MHz; Level = 3 dBm; OutpImp = 50 Ohm

    Operator slews the 9640A output to 501.23 MHz.

    After the 9640 Slew statement is executed the value of MEM is 501.23.

  6. At most one parameter may be designated as the Modifier Quantity in a Apply (default), Setup, or Slew statement.
  7. When a Slew statement is executed, the Modifier Quantity is concatenated to the Evaluation Quantity in the automatic slew message. Note, the automatic slew message is not displayed when ASK- N is in effect.

    Example(s):

      1.006  ASK+         N
  1.007  LPNX         Slew; +Freq = 500 MHz; @Level = 3 dBm; OutpImp = 50 Ohm

    "Adjust stimulus for a UUT reading of 500 MHz at 3 dBm."

    No Modifier Quantity designated.

    LPNX Slew; +Freq = 500 MHz; Level = 3 dBm; OutpImp = 50 Ohm

    "Adjust stimulus for a UUT reading of 500 MHz."

    Automatic slew message inhibited.

      1.006  ASK+         N
  1.007  LPNX         Slew; +Freq = 500 MHz; @Level = 3 dBm; OutpImp = 50 Ohm

    No automatic slew message generated, use MESS FSC.

  8. Parameter values may be taken from a MET/CAL memory register using a special construction.

Parameter Names

Parameter names consist of single words or compound words. Each word in a parameter name can be entered in long form (as shown below), or in short form. The short form is the first 4 characters of the long form, with the following exceptions:

  1. If the long form is greater than four characters, and the last character or the short form is a vowel, the short form is three characters.
  2. If the long form is four characters or less, the short form is the long form even if it ends in a vowel.

Compound parameter names can be entered in any combination of long and short forms. Example, ExternalReferenceFrequency can be entered using any of the following forms:

  • ExtRefFreq
  • ExtRefFrequency
  • ExtReferenceFreq
  • ExtReferenceFrequency
  • ExternalRefFreq
  • ExternalRefFrequency
  • ExternalReferenceFreq
  • ExternalReferenceFrequency

Action Parameters

  • Abort
  • Apply
  • Calibrate 3
  • Continue
  • Local
  • Measure
  • Operate
  • Pause
  • Read
  • Setup
  • Slew
  • Standby
  • Trigger
  • Zero 3

General Parameters

  • Bandwidth
  • ExternalReferenceFrequency
  • Frequency
  • GateTime 2
  • InputImpedance 3
  • Level 1,2
  • LPN
  • Mode
  • OffsetFrequency
  • OutputImpedance 2
  • PhaseNoise
  • Range 3
  • ReferenceFrequencyOutput
  • ResidualFM
  • TimebaseAccuracyOff

Modulation Parameters

  • AMDepth 1,2
  • ExternalCoupling
  • FMDeviation 1,2
  • Frequency 1,2
  • ModulationFrequency 1,2
  • ModulationWaveform
  • PMDeviation 1,2

Sweep Parameters

  • CenterFrequency
  • FrequencySpan
  • StartFrequency
  • StopFrequency
  • SweepDwellTime
  • SweepMode
  • SweepSquelchOn
  • SweepStep
  • SweepType
  • TriggerEdge
  • TriggerSource
  • TriggerOutputOn

96270A Only Parameters

  • AverageCount1
  • AverageCount2
  • CaptureRange
  • Expiration
  • InterpolateMethod
  • NumberOfPoints
  • Output
  • OutputClamp
  • PowerSensor1
  • PowerSensor2
  • PowerSplitter
  • Profile
  • ReferencePlane
  • SensorLeveling
  • SourceSWR
  • UUTSWR

Parameter Names Footnotes:

  1. May be designated as the Evaluation Quantity.
  2. May be designated as the Modifier Quantity.
  3. 96270A only.

Instrument Mode

MET/CAL determines the instrument operating mode based on occurrence of the following parameters in the FSC statement:

  • AMDepth
  • FMDeviation
  • CenterFrequency
  • FrequencySpan
  • StartFrequency
  • StopFrequency

Rules:

  1. If AMDepth occurs sequentially in A FSC statement before any of the other parameters listed above, the mode is AM.
  2. If FMDeviation occurs sequentially in A FSC statement before any of the other parameters listed above, the mode is FM.
  3. If CenterFrequency, FrequencySpan, StartFrequency, or StopFrequency occurs sequentially in A FSC statement before any of the other parameters listed above, the mode is Sweep.
  4. If none of the parameters listed above occur in the FSC statement, the mode is Sine.

Mode/Parameter Rules

If a parameter is not listed for a mode, it is not allowed. Some optional parameters may become required based on the inclusion or value of another parameter.

Sine (9640, LPN, LPNX, & 96040A FSCs, Leveling Head)

Required Parameters:

  • Frequency
  • Level
  • OutputImpedance
Optional Parameters | Default Values
Apply | Operate | Setup | Slew | Apply
Bandwidth 1 | N/A
ExternalReferenceFrequency | Internal
Mode | Sine
OffsetFrequency 2 | N/A
PhaseNoise | N/A
ReferenceFrequencyOutput | Off
ResidualFM | N/A
TimebaseAccuracyOff | N/A
  1. Bandwidth is required when ResidualFM is specified.
  2. OffsetFrequency is required when PhaseNoise is specified.

Sine (96270A FSC, Leveling Head and Microwave Output Direct)

Required Parameters:

  • Frequency
  • Level
Optional Parameters | Default Values
Apply | Operate | Setup | Slew | Apply
Bandwidth 1 | N/A
Expiration 4,8 | N/A
ExternalReferenceFrequency | Internal
InterpolateMethod 4,8 | Linear
Mode | Sine
OffsetFrequency 2 | N/A
Output | LevelingHead
OutputImpedance 3 | N/A
PhaseNoise | N/A
PowerSensor1 5,8 | PowerSensor2 6,8 | N/A
Profile 7,8 | N/A
ReferenceFrequencyOutput | Off
ReferencePlane 7,8 | N/A
ResidualFM | N/A
TimebaseAccuracyOff | N/A
  1. Bandwidth is required when ResidualFM is specified.
  2. OffsetFrequency is required when PhaseNoise is specified.
  3. Required when Output = LevelingHead.
  4. Requires Profile.
  5. Required when ReferencePlane = Sensor1Direct.
  6. Required when ReferencePlane = Sensor2Direct.
  7. Profile and ReferencePlane are mutually required.
  8. Not allowed when PhaseNoise or ResidualFM is specified.

Sine (96270A FSC, Microwave Splitter/Sensor using Sensor Leveling)

Required Parameters:

  • Frequency
  • Level
  • Output = uW_SplitterSensor
  • PowerSensor1 | PowerSensor2
  • SensorLeveling
Optional Parameters | Default Values
Apply | Operate | Setup | Slew | Apply
CaptureRange | N/A
ExternalReferenceFrequency | Internal
Mode | Sine
OutputClamp | N/A
ReferenceFrequencyOutput | Off
TimebaseAccuracyOff | N/A
UUTSWR | N/A

Sine (96270A FSC, Microwave Splitter/Sensor using Sensor Leveling with a Profile)

Required Parameters:

  • Frequency
  • Level
  • Output = uW_SplitterSensor
  • PowerSensor1
  • PowerSensor2
  • Profile
  • ReferencePlane
  • SensorLeveling 1,2
  • Splitter
  1. SensorLeveling = 1 required when ReferencePlane = Sensor2Leveled1
  2. SensorLeveling = 2 required when ReferencePlane = Sensor1Leveled2
Optional Parameters | Default Values
Apply | Operate | Setup | Slew | Apply
CaptureRange | N/A
Expiration | N/A
ExternalReferenceFrequency | Internal
InterpolateMethod | Linear
Mode | Sine
OutputClamp | N/A
ReferenceFrequencyOutput | Off
ReferencePlane | N/A
TimebaseAccuracyOff | N/A
UUTSWR | N/A

Amplitude Modulation

Required Parameters:

  • AMDepth
  • Frequency
  • Level
  • Mode
Optional Parameters | Default Value
Apply | Operate | Setup | Slew | Apply
ExternalCoupling | AC
ExternalReferenceFrequency | Internal
ModulationFrequency | N/A
ModulationWaveform | Sine
OutputImpedance | N/A
ReferenceFrequencyOutput | Off
TimebaseAccuracyOff | N/A

Amplitude Modulation (96270A FSC using a Profile)

Required Parameters:

  • AMDepth
  • Frequency
  • Level
  • Mode
  • PowerSensor1 | PowerSensor2
  • Profile
  • ReferencePlane
Optional Parameters | Default Value
Apply | Operate | Setup | Slew | Apply
Expiration | N/A
ExternalCoupling | AC
ExternalReferenceFrequency | Internal
ModulationFrequency | N/A
ModulationWaveform | Sine
OutputImpedance | N/A
ReferenceFrequencyOutput | Off
TimebaseAccuracyOff | N/A

Frequency Modulation

Required Parameters:

  • FMDeviation
  • Frequency
  • Level
  • Mode
Optional Parameters | Default Value
Apply | Operate | Setup | Slew | Apply
Bandwidth | N/A
ExternalReferenceFrequency | Internal
ExternalCoupling | AC
ModulationFrequency | N/A
ModulationWaveform | Sine
OutputImpedance | N/A
ReferenceFrequencyOutput | Off
TimebaseAccuracyOff | N/A

Phase Modulation

Required Parameters:

  • PMDeviation
  • Frequency
  • Level
  • Mode
Optional Parameters | Default Value
Apply | Operate | Setup | Slew | Apply
ExternalReferenceFrequency | Internal
ModulationFrequency | N/A
ModulationWaveform | Sine
OutputImpedance | N/A
ReferenceFrequencyOutput | Off
TimebaseAccuracyOff | N/A

Sweep

Required Parameters:

  • CenterFrequency 1
  • FrequencySpan 1
  • Level
  • Mode
  • StartFrequency 1
  • StopFrequency 1
  • SweepStep
  1. Either CenterFrequency and FrequencySpan or StartFrequency and StopFrequency is required, but only either is allowed, not both.
Optional Parameters | Default Value
Apply | Operate | Setup | Apply
ExternalReferenceFrequency | Internal
Output | LevelingHead
OutputImpedance 2 | N/A
ReferenceFrequencyOutput | Off
SweepDwellTime | 100 ms
SweepMode | Continuous
SweepSquelchOn | Off
SweepType | Linear
TriggerOutputOn | Off
TriggerEdge | Rising
TriggerSource | Internal
TimebaseAccuracyOff | N/A
  1. Trigger is only allowed for single sweep.
  2. Required when Output = LevelingHead.

Frequency Counter

Required Parameters:

  • Frequency
  • GateTime
  • Level
  • Measure | Read | Setup
  • Mode
  • Range
Optional Parameters | Default Value
Level | N/A
ExternalReferenceFrequency | Internal
InputImpedance | N/A 1
ReferenceFrequencyOutput | Off
  1. Optional when Range = 300 MHz, required when Range = 50 MHz.

Power Meter (96270A only)

Required Parameters:

  • Frequency
  • Measure | Read | Setup
  • Mode
  • Power
  • PowerSensor1 | PowerSensor2
Optional Parameters | Default Value
AverageCount1 | AverageCount2 | Auto

96270A Self-Characterization (Creating a Profile)

Required Parameters:

  • Calibrate
  • Level
  • NumberOfPoints
  • Profile
  • ReferencePlane
  • StartFrequency
  • StopFrequency
Optional Parameters | Default Value
Output | LevelingHead
OutputImpedance | N/A
PowerSensor1 1 | N/A
PowerSensor2 2 | N/A
PowerSplitter | N/A
  1. Required when ReferencePlane = Sensor1Direct, Sensor1Leveled2, or Sensor2Leveled1.
  2. Required when ReferencePlane = Sensor2Direct, Sensor1Leveled2, or Sensor2Leveled1.

96270A Zero Power Meter

Required Parameters:

  • PowerSensor1 | PowerSensor2
  • Zero

Parameter Definitions and Values

AMDepth

This parameter sets the output mode to AM and selects sets the AM depth.

Syntax:

[parameter prefix]AMDepth[sp]=[sp]numeric value[sp][prefix]%

Rules:

  1. Legal values are: 0.1 % to 99 %

Example(s):

+AMDepth = 30.0%

+AMDepth = [L1] %

Abort

This parameter stops a sweep.

Syntax:

Abort

Rules:

  1. When Abort is specified, no other parameters are allowed.
  2. If a Abort action is executed when no active sweep is present, an error will occur.

Example(s):

Abort

Apply

This parameter causes the instrument to be setup to the state specified by the remaining parameters listed. The output is also turned on.

Syntax:

Apply

Example(s):

Apply

AverageCount1 & AverageCount2

This parameter specifies the SENSOR 1 and SENSOR 2 average count for Power Meter mode.

Syntax:

AverageCountn[sp]=[sp]integer

n ::= 1|2

Rules:

  1. Legal values are: 1, 2, 4, 8, 16, 32, 64, 128, 256, 512, 1024, 2048, 4096, 8192, 16384, and 32768

Example(s):

AverageCount1 = 16

Bandwidth

This parameter specifies the bandwidth when ResidualFM is the evaluation quantity.

Syntax:

[@]Bandwidth[sp]=[sp]NRf[sp][prefix]Hz

Rules:

  1. Legal values are:1 Hz to 100 MHz

Example(s):

Bandwidth = 100 Hz

Calibrate

This parameter causes the 96270A to characterize the output using a single power sensor (Direct) or a splitter and two power sensors (Splitter/Sensor). See "Profile Self Measure (Self Characterization)" in the 96270A Operators Manual.

Syntax:

Calibrate

Example(s):

Calibrate

CaptureRange

This parameter sets the capture range for 96270A sensor leveling.

Syntax:

CaptureRange[sp]=[sp]numeric value[sp][prefix]dB

Rules:

  1. Legal values are: 0 to +150 dB

Example(s):

CaptureRange = 100 dB

CenterFrequency

This parameter sets the output mode to sweep and sets the center frequency for the sweep.

Syntax:

CenterFrequency[sp]=[sp]numeric value[sp][prefix]Hz

Rules:

  1. Legal values are: 9 Hz to 4.024 GHz

Example(s):

CenterFreq = 100 MHz

Continue

This parameter resumes a paused sweep.

Syntax:

Continue

Rules:

  1. When Continue is specified, no other parameters are allowed.
  2. If a FSC Continue statement is executed when no "pause" sweep is present, an error will occur.

Example(s):

Continue

Expiration

This parameter sets the duration of time for which a 96270A profile is valid. An run time error will occur if the profile comment line date and time plus this specified time has been exceeded.

Syntax:

Expiration[sp]=[sp]numeric value[sp][prefix]Hour[s]

Rules:

  1. Legal values are: 0 to 168 hours

Example(s):

Expiration = 2 hours

ExternalReferenceFrequency

This parameter sets the reference oscillator source to external and reference oscillator external frequency to the value specified. If this parameter is not specified, the reference oscillator source is

set to internal.

Syntax:

ExternalReferenceFrequency[sp]=[sp]numeric value[sp][prefix]Hz

Rules:

  1. Legal values are: 1 MHz to 20 MHz in 1 MHz steps

Example(s):

ExtRefFreq = 10 MHz

GateTime

This parameter sets the frequency counter gate time.

Syntax:

GateTime[sp]=[sp]numeric value[sp][prefix]s

Rules:

  1. Legal values are: 0.2, 2, 20, and 80 s

Example(s):

GateTime = 2 s

FMDeviation

This parameter sets the output mode to FM and sets the FM deviation.

Syntax:

[parameter prefix]FMDeviation[sp]=[sp]numeric value[sp][prefix]Hz

Rules:

  1. Legal values are: 9 MHz to 4.024 GHz

Example(s):

+FMDev = 5.00 kHz

Frequency

This parameter establishes the expected frequency of the input signal.

Syntax:

[parameter prefix]Frequency[sp]=[sp]numeric value[sp][prefix]Hz

Rules:

  1. Legal values are:
    1. 1 mHz to 4.024 GHz (Leveling Head)
    2. 1 mHz to 27 GHz (96270A Microwave Direct)
    3. 1 kHz to 27 GHz (96270A Microwave Splitter/Sensor)
    4. 0.9 MHz to 50.1 MHz (9640A, 9640A-LPN, 9640A-LPNX, & 96040A Frequency Counter)
    5. 0.9 MHz to 310 MHz (96270A Frequency Counter)

Example(s):

+Freq = 1 MHz

FrequencySpan

This parameter sets the output mode to sweep and sets the frequency span for sweep.

Syntax:

FrequencySpan[sp]=[sp]numeric value[sp][prefix]Hz

Rules:

  1. Legal values are: 100 kHz to 4.024 GHz

Example(s):

FreqSpan = 9 MHz

ExternalCoupling

This parameter sets the external modulation coupling.

Syntax:

ExternalCoupling[sp]=[sp]value

value ::= AC|DC

Example(s):

ExtCoup = DC

InputImpedance

This parameter establishes the expected frequency of the input signal.

Syntax:

[parameter prefix]InputImpedance[sp]=[sp]numeric value[sp][prefix]Ohms

Rules:

  1. Legal values are 10 kΩ or 50 Ω

Example(s):

+InputImpedance= 10 kOhm

InterpolateMethod

This parameter sets the 96270A profile interpolate method.

Syntax:

InterpolateMethod[sp]=[sp]value

value ::= Linear|Smooth

Rules:

  1. If this parameter is specified, reference accuracy will not be calculated. The FSC assumes that you did not characterize at this frequency.

Example(s):

InterpolateMethod = Smooth

Level

This parameter sets the power level of the output.

Syntax:

[parameter prefix]Level[sp]=[sp]numeric value[sp][prefix]units

units::=dBm|W|V|Vpp|dBuV

Rules:

  1. Legal values are:
    Impedance | Level
    50 Ohms | -130 dBm to 24 dBm 1
    75 Ohms | -130 dBm to 18 dBm 1
    1. Sine and sweep modes. See instrument specifications for modulation mode limits and amplitude vs. frequency restrictions.

Example(s):

@Level = -2.00 dBm

Local

This action puts the instrument in local mode.

Syntax:

Local

Rules:

  1. When Local is specified, no other parameters may be specified.

Example(s):

Local

LPN (Obsolete)

This parameter causes a 9640 statement to require a 9640A-LPN. This parameter is no longer necessary. If a 9640A-LPN is required, use the LPN FSC.

Syntax:

LPN

Rules:

  1. This parameter is only allowed with the 9640 FSC.

Example(s):

LPN

Measure

This parameter sets up the instrument and takes a measurement.

Syntax:

Measure

Rules:

  1. Measure is only allowed when Mode = FrequencyCounter.

Example(s):

Measure

Mode

This parameter selects the operating mode.

Syntax:

Mode[sp]=[sp]value

value ::= Sine|AM|FM|PM|Sweep|FrequencyCounter|PowerMeter

Rules:

  1. When this parameter is not specified, the default is Sine
  2. PowerMeter is only supported by 96270A FSC.

Example(s):

Mode = Sweep

ModulationFrequency

This parameter sets the modulation frequency of the AM or FM.

Syntax:

[parameter prefix]ModulationFrequency[sp]=[sp]numeric value[sp][prefix]Hz

Rules:

  1. Legal values are:
    Type | Waveform | ModFreq
    AM | Sine | 20 Hz to 220 kHz
    AM | Triangle | 20 Hz to 10 kHz
    FM | Sine | 20 Hz to 300 kHz
    PM | Sine | 20 Hz to 300 kHz

Example(s):

ModFreq = 1 kHz

ModulationWaveform

This parameter sets the shape of the modulation of the AM or FM.

Syntax:

ModulationWaveform[sp]=[sp]value

value::=Sine|Triangle|External

Rules:

  1. Triangle is only allowed for AM.

Example(s):

ModWav = Sine

NumberOfPoints

This parameter specifies the number of points in the profile created during 96270A Self-characterization (FSC Calibrate action) .

Syntax:

NumberOfPointssp]=[sp]numeric value

Rules:

  1. Legal values are: 3 to 5000

Example(s):

NumberOfPoints = 34

OffsetFrequency

This parameter specifies the offset frequency from the carrier when PhaseNoise is the evaluation quantity.

Syntax:

[@]OffsetFrequency[sp]=[sp]numeric value[sp][prefix]Hz

Rules:

  1. Legal values are: 1 Hz to 100 MHz

Example(s):

OffsetFrequency = 10 kHz

Operate

This parameter turns the output on.

Syntax:

Operate

Rules:

  1. A FSC statement with the Operate action must be preceded by a FSC statement with the Setup action in order to program the instrument to the desired state.
  2. Operate is not allowed when Mode = FrequencyCounter.

Example(s):

Operate

Output

This parameter specifies the 96270A output.

Syntax:

Output[sp]=[sp]value

value::=LevelingHead|uW_Direct|uW_SplitterSensor

Example(s):

Output = uW_SplitterSensor

OutputClamp

This parameter specifies the output clamp for 96270A sensor leveling.

Syntax:

OutputClamp[sp]=[sp]numeric value[sp][prefix]dBm

Rules:

  1. Legal values are: -4 to +24 dBm (Std), -130 to +24 dBm (Option LL)

Example(s):

OutputClamp = 24 dBm

OutputImpedance

This parameter specifies the output impedance. The specified output impedance is used to determine whether a 9640A-50 Ω or 9640A-75 Ω head is required.

Syntax:

OutputImpedance[sp]=[sp]numeric value[sp][prefix]Ohm[s]

Rules:

  1. Legal values are: 50 and 75 Ohms

Example(s):

OutputImpedance = 50 Ohms

Pause

This parameter pauses a sweep.

Syntax:

Pause

Rules:

  1. When Pause is specified, no other parameters are allowed.
  2. If a FSC Pause statement is executed when no active sweep is present, an error will occur.

Example(s):

Pause

PhaseNoise

This parameter is used to indicate that phase noise is the test quantity.

Syntax:

+PhaseNoise[sp]=[sp]numeric value[sp][prefix]]dBc/Hz

Rules:

  1. Legal values are: -200 to 0 dBc/Hz
  2. When PhaseNoise is specified, it must be designated as the evaluation quantity (+PhaseNoise).

Example(s):

+PhaseNoise = -105 dBc/Hz

PMDeviation

This parameter sets the output mode to PM and sets the PM deviation.

Syntax:

[parameter prefix]PMDeviation[sp]=[sp]numeric value[sp][prefix]rad

Rules:

  1. Legal values are: 0.1 mrad to 1 krad

Example(s):

+FMDev = 5.00 kHz

Power

This parameter specifies the expected measurement in 96270A Power Meter mode.

Syntax:

+Power[sp]=[sp]numeric value[sp][prefix]units

units::=dBm|W|V|Vpp|dBuV

Rules:

  1. Legal values depend on the actual power sensor used.
  2. Power must be designated as the evaluation quantity (+Power).

Example(s):

OutputImpedance = 50 Ohms

PowerSensor1 & PowerSensor2

This parameter specifies the required power sensor model number.

Syntax:

PowerSensorn[sp]=[sp]value

n ::= 1|2

value::=NRP-Z51|NRP-Z52|NRP-Z55.03|NRP-Z55.04|NRP-Z56|NRP-Z57|NRP-Z58

Rules:

  1. The model number of the connected power sensor must be the same as the specified model number.
  2. The serial number of the connected power sensor must be the same as the serial number of the configured power sensor.

Example(s):

PowerSensor1 = NRP-Z55.03

PowerSplitter

This parameter specifies the required power splitter model number.

Syntax:

PowerSplitter[sp]=[sp]value

value::=11667A|11667B|UserDefined

Example(s):

PowerSplitter = 11667B

Profile

This parameter specifies the 96270A profile. Specifying Profile = 1 creates profile "METCAL1" in the 96270A .

Syntax:

Profile[sp]=[sp]integer

Rules:

  1. Legal values are 1 to 30.

Example(s):

Profile = 5

Range

This parameter establishes the expected frequency of the input signal.

Syntax:

[parameter prefix]Range[sp]=[sp]numeric value[sp][prefix]Hz

Rules:

  1. Legal values are 50 MHz or 300 MHz.

Example(s):

+Range = 300 MHz

Read

This parameter takes a measurement.

Syntax:

Read

Rules:

  1. A Read action must be preceded by a Setup action in order to program the instrument to frequency counter or power meter mode.

Example(s):

Read

ReferenceFrequencyOutput

This parameter enables the reference frequency output and sets the frequency to the value specified. If this parameter is not specified, the reference frequency output is disabled.

Syntax:

ReferenceFrequencyOutput[sp]=[sp]numeric value[sp][prefix]Hz

Rules:

  1. Legal values are: 1 MHz and 10 MHz

Example(s):

ReferenceFrequencyOutput = 10 MHz

ReferencePlane

This parameter specifies the 96270A reference plane.

Syntax:

ReferencePlane[sp]=[sp]value

value::=Sensor1Direct|Sensor2Direct|Sensor1Leveled2|Sensor2Leveled1

Example(s):

ReferencePlane = Sensor1Leveled2

Reset

This parameter resets the instrument.

Syntax:

Reset

Rules:

  1. When Reset is specified, no other parameters are allowed.

Example(s):

Reset

ResidualFM

This parameter is used to indicate that residual FM is the test quantity.

Syntax:

+ResidualFM[sp]=[sp]numeric value[sp][prefix]Hz

Rules:

  1. Legal values are: 0 Hz to 10 MHz

Example(s):

+ResidualFM = 1.5 Hz

SensorLeveling

This parameter specifies the 96270A SENSORS port to be used for sensor leveling.

Syntax:

SensorLeveling[sp]=[sp]n

n ::= 1|2

Example(s):

SensorLeveling = 2

Setup

This parameter causes the instrument to be setup to the state specified by the remaining parameters listed. The output is not turned on. A measurement is not performed.

Syntax:

Setup

Rules:

  1. A FSC statement with the Setup action must be followed by a FSC statement with the Operate action in order to turn the output on, if it is currently off.

Example(s):

Setup

Slew

This parameter causes the instrument to be setup to the state specified by the remaining parameters listed. The output is turned on, and slewing is enabled for the parameter designated as the Evaluation Quantity (+) prefix.

Syntax:

Slew

Example(s):

Slew

SourceSWR

This parameter specifies the source SWR for use by the 96270A FSC reference accuracy calculation. This parameter may be used to override the 96270A FSC's reference accuracy lookup value.

Syntax:

SourceSWR[sp]=[sp]NRf

Rules:

  1. Legal values are: 1 to 10

Example(s):

SourceSWR = 1.1

Standby

This parameter turns the output off.

Syntax:

Standby

Rules:

  1. When Standby is specified, no other parameters are allowed.

Example(s):

Standby

StartFrequency

This parameter sets the sweep start frequency or the 96270A Self-characterization (Calibrate action) start frequency.

Syntax:

StartFrequency[sp]=[sp]numeric value[sp][prefix]Hz

Rules:

  1. Legal values are: 9 Hz to 4.024 GHz

Example(s):

StartFreq = 1 MHz

StopFrequency

This parameter sets the sweep stop frequency or the 96270A Self-characterization (Calibrate action) stop frequency.

Syntax:

StopFrequency[sp]=[sp]numeric value[sp][prefix]Hz

Rules:

  1. Legal values are: 9 Hz to 4.024 GHz

Example(s):

StopFreq = 10 MHz

SweepDwellTime

This parameter sets the amount of time spent at each point during a sweep.

Syntax:

SweepDwellTime[sp]=[sp]numeric value[sp][prefix]s

Rules:

  1. Legal values are: 20 ms to 10 s

Example(s):

SweepDwellTime = 100 ms

SweepMode

This parameter sets the sweep mode.

Syntax:

SweepMode[sp]=[sp]value

value ::= Continuous|Single

Example(s):

SweepMode = Cont

SweepSquelchOn

This parameter enables sweep squelch.

Syntax:

SweepSquelch

Rules:

  1. When SweepSquelchOn is specified, sweep squelch is enabled.
  2. When SweepSquelchOn is not specified, sweep squelch is disabled.

Example(s):

SweSquOn

SweepStep

This parameter sets the sweep step.

Syntax:

SweepStep[sp]=[sp]numeric value[sp][prefix]units

units ::= |SPS|SPD|Hz|ppm|%

Rules:

  1. Legal values are: 0.1 Hz to 4 GHz
  2. If SweepType is Linear, SweepStep units must be Steps Per Sweep ("SPS"), Hertz ("Hz"), parts per million ("ppm"), or percent ("%").
  3. If SweepType is Logarithmic, SweepStep units must be Steps Per Sweep ("SPS") or Steps Per Decade ("SPD").

Example(s):

SweepStep = 10 SPD

SweepType

This parameter sets the sweep type.

Syntax:

SweepType[sp]=[sp]value

value ::= Linear | Logarithmic

Example(s):

SweepType = Log

TimebaseAccuracyOff

This parameter is used when it is only desired to synchronize the instrument with the UUT, without an absolute accuracy determination.

Syntax:

TimebaseAccuracyOff

Example(s):

TimebaseAccuracyOff

Trigger

This parameter initiates a single sweep.

Syntax:

Trigger

Rules:

  1. When Trigger is specified, no other parameters are allowed.
  2. Trigger must only follow single sweep apply or setup and operate statements.

Example(s):

Trigger

TriggerOutputOn

This parameter enables the trigger output signal.

Syntax:

TriggerOutputOn

Rules:

  1. TriggerOutputOn may only be specified when TriggerSource is internal (default).
  2. When TriggerOutputOn is specified, the trigger output is enabled.
  3. When TriggerOutputOn is not specified, the trigger output is disabled.

Example(s):

TrigOutpOn

TriggerEdge

This parameter sets the sweep trigger slope.

Syntax:

TriggerEdge[sp]=[sp]value

value = Rising|Falling

Example(s):

TrigEdge = Ris

TriggerSource

This parameter sets the sweep trigger source.

Syntax:

TriggerSource[sp]=[sp]value

value ::= Internal|External

Example(s):

TrigSource = Int

UUTSWR

This parameter is optional, but required by the FSC to compute power level reference accuracy when using sensor leveling, with or without a profile.

Syntax:

UUTSWRsp=spnumeric value

Rules:

  1. Legal numeric values are: 1 to 10

Example:

UUTSWR = 1.07

Zero

This parameter causes the 96270A to zero a power sensor connected to SENSORS 1 or SENSORS 2.

Syntax:

Zero

Example(s):

Zero

Examples

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON

# Sine Mode, evaluation quantity, frequency, 50 Ohm Leveling Head.
  1.001  9640         +Freq = 1 GHz; Level = -10 dBm; OutputImp = 50 Ohms

# Sine Mode, evaluation quantity, frequency, 75 Ohm Leveling Head.
  1.002  9640         +Freq = 2 GHz; Level = -10 dBm; OutputImp = 75 Ohms

# Sine Mode, evaluation quantity, level.
  1.003  LPN          +Level = -10 dBm; Freq = 50 MHz; OutputImp = 50 Ohms

# Sine Mode, evaluation quantity, frequency, 10 MHz External Reference used
# for Timebase accuracy.
  1.004  LPN          ExtRefFreq = 10 MHz
  1.004  LPN          +Freq = 1.5 GHz; Level = -10 dBm; OutputImp = 50 Ohms

# Sine Mode, evaluation quantity, frequency, 10 MHz External Reference used
# for synchronizing purposes only.
  1.005  LPNX         ExtRefFreq = 10 MHz; TimebaseAccOff
  1.005  LPNX         +Freq = 1.5 GHz; Level = -10 dBm; OutputImp = 50 Ohms

# Sine Mode, evaluation quantity, frequency, 10 MHz External Reference used
# for synchronizing purposes only.
  1.006  96040A       ExtRefFreq = 10 MHz; TimebaseAccOff
  1.006  96040A       +Freq = 1.5 GHz; Level = -10 dBm; OutputImp = 50 Ohms

# FM Mode, FM Deviation evaluation quantity, 10 Hz Sine Modulation.
  1.008  96270A       Frequency = 10 MHz; Level = -10 dBm; OutputImp = 50 Ohms
  1.008  96270A       +FMDeviation = 10 Hz; Mode = FM; ModFreq = 1 kHz

# Sweep Mode (Continuous)
  1.009  9640         Mode = Sweep
  1.009  9640         StartFreq = 10 MHz; StopFreq = 3 GHz; SweepStep = 10 MHz
  1.009  9640         SweepDwellTime = 100 ms; SweepSquelchOn
  1.009  9640         +Level = -10 dBm; OutputImpedance = 50 Ohms

# Pause sweep
  1.010  9640         Pause

# Continue sweep
  1.011  9640         Continue

# Stop sweep
  1.012  9640         Reset

# Sweep Mode (Single)
  1.013  9640         Mode = Sweep; SweepMode = Single
  1.013  9640         StartFreq = 10 MHz; StopFreq = 3 GHz; SweepStep = 10 MHz
  1.013  9640         +Level = -10 dBm; OutputImpedance = 50 Ohms

  1.014  9640         Trigger

# Wait for sweep to complete.
  1.015  DO
  1.016  WAIT         [D100]
  1.017  SCPI         [@9640]SWEEP:PROGRESS?[I]
  1.018  MATH         MEM2 = FMT(MEM, "%3.0f")
  1.019  HEAD         SWEEP: [MEM2] % Complete
  1.020  SCPI         [@9640]STAT:OPER:COND?[I]
  1.021  UNTIL        NOT(BIT(3, MEM))

  1.022  HEAD
  1.023  DISP         Sweep complete!

# 96270A Zero Power Meters
  1.024  96270A       PowerSensor1 = NRP-Z55.03; Zero
  1.025  96270A       PowerSensor2 = NRP-Z55.03; Zero

# 96270A Self-Characterization (Leveling Head using Power Sensor 1)
  1.026  96270A       Output = LevelingHead; OutputImp = 50 Ohms
  1.026  96270A       RefPlane = Sensor1
  1.026  96270A       PowerSensor1 = NRP-Z55.03
  1.026  96270A       StartFrequency = 1 GHz; StopFrequency = 4 GHz
  1.026  96270A       Level = -10 dBm; NumberOfPoints = 16
  1.026  96270A       Profile = 1; Calibrate

# Use the profile.
  1.027  96270A       RefPlane = Sensor1; Profile = 1
  1.027  96270A       PowerSensor1 = NRP-Z55.03; OutputImp = 50 Ohms
  1.027  96270A       +Level = -10 dBm; Frequency = 1 GHz

# 96270A Self-Characterization (Leveling Head using Power Sensor 2)
  1.028  96270A       Output = LevelingHead; OutputImp = 50 Ohms
  1.028  96270A       RefPlane = Sensor2; PowerSensor2 = NRP-Z55.03
  1.028  96270A       StartFrequency = 100 MHz; StopFrequency = 1000 MHz
  1.028  96270A       Level = 0 dBm; NumberOfPoints = 10
  1.028  96270A       Profile = 2; Calibrate

# Use the profile.
  1.029  96270A       RefPlane = Sensor2; Profile = 2
  1.029  96270A       PowerSensor2 = NRP-Z55.03; OutputImp = 50 Ohms
  1.029  96270A       +Level = 0 dBm; Frequency = 100 MHz

# 96270A Self-Characterization (Microwave Output using Power Sensor 1 Direct)
  1.030  96270A       Output = uW_Direct; RefPlane = Sensor1
  1.030  96270A       PowerSensor1 = NRP-Z55.03
  1.030  96270A       StartFrequency = 10 GHz; StopFrequency = 20 GHz
  1.030  96270A       Level = +1 dBm; NumberOfPoints = 11
  1.030  96270A       Profile = 3; Calibrate

# Use the profile.
  1.031  96270A       Output = uW_Direct
  1.031  96270A       RefPlane = Sensor1; Profile = 3
  1.031  96270A       PowerSensor1 = NRP-Z55.03
  1.031  96270A       +Level = +1 dBm; Frequency = 10 GHz

# 96270A Self-Characterization (Microwave Output using Power Sensor 2 Direct)
  1.032  96270A       Output = uW_Direct; RefPlane = Sensor2
  1.032  96270A       PowerSensor2 = NRP-Z55.03
  1.032  96270A       StartFrequency = 1 GHz; StopFrequency = 10 GHz
  1.032  96270A       Level = -1 dBm; NumberOfPoints = 11
  1.032  96270A       Profile = 4; Calibrate

# Use the profile.
  1.033  96270A       Output = uW_Direct
  1.033  96270A       RefPlane = Sensor2; Profile = 4
  1.033  96270A       PowerSensor2 = NRP-Z55.03
  1.033  96270A       +Level = -1 dBm; Frequency = 1 GHz

# 96270A Self-Characterization (Microwave Output PS 1 leveled by PS 2))
  1.034  96270A       Output = uW_SplitterSensor; RefPlane = Sensor1Leveled2
  1.034  96270A       PowerSensor1 = NRP-Z55.03; PowerSensor2 = NRP-Z55.03
  1.034  96270A       PowerSplitter = 11667B
  1.034  96270A       StartFrequency = 0.35 GHz; StopFrequency = 3.65 GHz
  1.034  96270A       Level = 0 dBm; NumberOfPoints = 34
  1.034  96270A       Profile = 5; Calibrate

# 96270A Self-Characterization (Microwave Output PS 2 leveled by PS 1))
  1.035  96270A       Output = uW_SplitterSensor; RefPlane = Sensor2Leveled1
  1.035  96270A       PowerSensor1 = NRP-Z55.03; PowerSensor2 = NRP-Z55.03
  1.035  96270A       PowerSplitter = 11667B
  1.035  96270A       StartFrequency = 3.65 GHz; StopFrequency = 26.45 GHz
  1.035  96270A       Level = 0 dBm; NumberOfPoints = 115
  1.035  96270A       Profile = 6; Calibrate

# 96270A Sensor Leveling using Power Sensor 1
  1.036  96270A       Output = uW_SplitterSensor; SensorLeveling = 1
  1.036  96270A       PowerSensor1 = NRP-Z55.03; PowerSplitter = 11667B
  1.036  96270A       +Level = 0 dBm; Frequency = 10 GHz

# Frequency Counter
  1.037  TARGET       -p
  1.038  96270A       Mode = FreqCounter; GateTime = 0.2 s
  1.038  96270A       Range = 50 MHz; InputImpedance = 10 kOhms
  1.038  96270A       +Freq = 10.0000000 MHz; Level = 1 Vpp; Setup
  1.039  TARGET       -m
  1.040  96270A       Mode = FreqCounter; GateTime = 0.2 s
  1.040  96270A       Range = 50 MHz; InputImpedance = 10 kOhms
  1.040  96270A       +Freq = 10.0000000 MHz; Level = 1 Vpp; Read
  1.041  MEMC         10.0000000MHz  10P%          0dBm


52120A

Instrument FSC

Description

The 52120A FSC controls the Fluke 52120A Transconductance Amplifier.

Parameters

A 52120A statement consists of one or more parameters. A parameter consists of a name and a value. Each parameter must be separated by a semicolon and/or one or more spaces. A single 52120A statement can encompass more than one physical line as long as the line numbers are the same. However each parameter name and its value must occur on one line. A single line can accommodate 256 characters including the statement number and FSC. Note that characters above ASCII 128 will count as 2 characters.

Syntax

52120A parameter[separator parameter]

parameter ::= [prefix]parameter name[sp]=[sp]parameter value

separator ::= ;[sp] | sp

prefix ::= + | @

sp ::= one or more spaces

parameter name ::= see Parameter Names

parameter value ::= see Parameter Names

|
Denotes "or" (i.e. A | B is A or B)
[ ]
Denotes an optional syntax element, except in examples. In examples [ ] enclose a special construction.
+
Designates the parameter as the Evaluation Quantity
@
Designates the parameter as the Modifier Quantity

Rules

  1. One and only one parameter must be designated as the Evaluation Quantity for a 52120A Apply (default), Setup, or Operate action.
  2. When a 52120A Apply or Setup statement is executed, the evaluation quantity is copied to memory register MEM1 in the units specified.

Example

  1.001  52120A       InputType = Voltage
  1.001  52120A       CurrentRange = 20 A; CurrentTerminal = High
  1.001  52120A       +Current = 20.0 A; @Frequency = 10 kHz

MEM1 would be 20 after either statement executes.

  • At most one parameter may be designated as the Modifier Quantity for a 52120A Apply, Setup, or Operate statement.
  • Parameter values may be taken from a MET/CAL memory register using a special construction.

Parameter Names

Parameter names consist of single words or compound words. Each word in a parameter name can be entered in long form (as shown below), or in short form. The short form is the first 4 characters of the long form, with the following exceptions:

  1. If the long form is greater than four characters, and the last character or the short form is a vowel, the short form is three characters.
  2. If the long form is four characters or less, the short form is the long form even if it ends in a vowel.

Compound parameter names can be entered in any combination of long and short forms. Example, Frequency can be entered using either of the following forms:

  • Frequency
  • Freq

Action Parameters

Action parameters specify the operation to be performed.

  • Apply
  • Local
  • Operate
  • Reset
  • Setup
  • Standby

Rules:

  1. Only one action parameter is allowed per 52120A statement (single or mult-line).
  2. If an action is not specified, the default is Apply.

General Parameters

  • Coil
  • Current
  • CurrentRange
  • CurrentTerminal
  • Frequency
  • InductanceCompensation
  • InputType

Inter-Parameter Rules

If a parameter is not listed, it is not allowed.

Parameter Name | Parameter Type | Default Value
[+|@]Current | Required | N/A
CurrentTerminal | Required | N/A
InputType | Required | N/A
Coil | Optional | N/A
CurrentRange | Optional | 2A
[+|@]Frequency | Optional | DC
InductanceCompensation | Optional | Off

Parameter Definitions and Values

Apply

Purpose

This "Action" parameter causes the following:

  1. Setup the 52120A for an output.
  2. Turn the output on.
  3. Return the Evaluation Quantity in memory register MEM1 in units designated.
Syntax | Apply
Rules | When neither Apply or Setup is specified, Apply is assumed.
Example
  1.001  52120A       CurrTerm = High; CurrRange = 120 A; InputType = Volt
  1.001  52120A       +Current = 20.00 A; @Freq = 10 kHz

Coil

Purpose | This parameter specifies a current coil.
Syntax | Coil[sp]=[sp]coil coil ::= 52120A/COIL3KA | 52120A/COIL6KA
Rules |
Example | Coil = 52120A/COIL3KA

Current

Purpose | This parameter specifies the expected output current.
Syntax | [+|@]Current[sp]=[sp]numeric value[sp][prefix]A
Rules | Legal are based on CurrentRange and Coil
Example | +Current = 50.00 A

Frequency

Purpose | This parameter specifies the frequency.
Syntax | [+|@]Frequency[sp]=[sp]numeric value[sp][prefix]Hz
Rules | Legal values are 10 Hz to 10 kHz.
Example | @Frequency = 10 kHz

InductanceCompensation

Purpose | This parameter specifies the state of L COMP.
Syntax | InductanceCompensation[sp]=[sp]state state = On | Off
Rules | Frequency upper limit is 1 kHz when InductanceCompensation = On.
Example | InductanceComp = On

InputType

Purpose | This parameter specifies the input control signal type.
Syntax | InputType[sp]=[sp]type type = Voltage | Current
Rules | None
Example | InputType = Voltage

Local

Purpose | This "Action" parameter put the 52120A in local mode.
Syntax | Local
Rules | None
Example | Local

Operate

Purpose | This "Action" parameter puts the amplifier in Operate.
Syntax | Operate
Rules | Operate DOES NOT setup the amplifier.
Example
  1.002  52120A       CurrTerm = High; CurrRange = 120 A; InputType = Volt
  1.002  52120A       +Current = 20.00 A; @Freq = 10 kHz; Operate

Reset

Purpose | This "Action" parameter resets the amplifier.
Syntax | Setup
Rules | None
Example | Reset

Standby

Purpose | This "Action" parameter puts the amplifier in Standby.
Syntax | Standby
Rules | None
Example | Standby

Examples

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
  1.002  HEAD         AC CURRENT
  1.003  HEAD         -2 1000 A Range
  1.004  TARGET       -p
  1.005  DISP         Connect the 5522A to the 52120A as follows:
  1.005  DISP
  1.005  DISP         [32]  5522A    52120A
  1.005  DISP         [32] NORMAL HI <------> INPUT HI
  1.005  DISP         [32] NORMAL LO <------> INPUT LO
  1.006  DISP         Connect the 52120A to the 52120A/COIL3KA as follows:
  1.006  DISP
  1.006  DISP         [32]        52120A          52120A/COIL3KA
  1.006  DISP         [32] HIGH CURRENT OUTPUT HI <------> Red Terminal
  1.006  DISP         [32] HIGH CURRENT OUTPUT LO <------> Black Terminal
  1.006  DISP
  1.006  DISP         Clamp the UUT around the 5500A/COIL.
  1.007  5522A        +Voltage = 0.4 V; Frequency = 10 Hz
  1.008  MATH         L[1] = REFACC() / MEM1 * 100 / CONF(Cal)
  1.009  52120A       InputType = Voltage
  1.009  52120A       CurrentTerminal = High; CurrentRange = 20 A
  1.009  52120A       Coil = 52120A/COIL3KA;  InductanceComp = On
  1.009  52120A       +Current = 100.0 A; Frequency = 10 Hz
  1.010  MATH         L[2] = REFACC() / MEM1 * 100 / CONF(Amp)
  1.011  MATH         L[3] = RSS2(L[1], L[2]) * 2
  1.012  ACC          100.0A         L3%
  1.013  TARGET       -m
  1.014  MEMI         Enter UUT reading in amps AC:
  1.015  MEMCX  1000  100.0A         2% 0.5U       10Hz

  2.001  HEAD         iFlex CURRENT
  2.002  HEAD         -2 1000 A Range
  2.003  TARGET       -p
  2.004  DISP         Rotate the UUT switch to iFlex function.
  2.005  DISP         Move the test lead from 5522A AUX HI to 20A.
  2.006  TARGET       -m
  2.007  RSLT         =
  2.008  HEAD         -2{1000 A Range}
  2.009  TARGET       -p
  2.010  DISP         Rotate the UUT function switch to iFlex.
  2.011  DISP         Connect the 52120A to the 52120A/COIL6KA as follows:
  2.011  DISP
  2.011  DISP         [32]        52120A          52120A/COIL6KA
  2.011  DISP         [32] HIGH CURRENT OUTPUT HI <------> Red Terminal
  2.011  DISP         [32] HIGH CURRENT OUTPUT LO <------> Black Terminal
  2.011  DISP
  2.012  DISP         Connect the Flexible Current Probe to the UUT.
  2.012  DISP
  2.012  DISP         Loop the Flexible Current Probe around the 5500A/COIL.
  2.013  TARGET       -m
  2.014  5522A        +Voltage = 0.2 V; Frequency = 50 Hz
  2.015  MATH         L[1] = REFACC() / MEM1 * 100 / CONF(Cal)
  2.016  52120A       InputType = Voltage
  2.016  52120A       CurrentTerminal = High; CurrentRange = 2 A
  2.016  52120A       Coil = 52120A/COIL6KA;  InductanceComp = On
  2.016  52120A       +Current = 10.0 A; Frequency = 50 Hz
  2.017  MATH         L[2] = REFACC() / MEM1 * 100 / CONF(Amp)
  2.018  MATH         L[3] = RSS2(L[1], L[2]) * 2
  2.019  ACC          10.0A          L3%
  2.020  TARGET       -m
  2.021  MEMI         Enter UUT reading in amps AC:
  2.022  MEMCX  1000  10.0A          3% 0.5U       50H

  3.001  RSLT         =
  3.002  HEAD         {FREQUENCY}
  3.003  RSLT         =
  3.004  HEAD         -2 {500 Hz Range}
  3.005  TARGET       -p
  3.006  DISP         Press the Hz push button.
  3.007  5502E        +Frequency = 5.0 Hz; Current = 0.03 A; CurrTerm = Aux
  3.008  52120A       InputType = Current
  3.008  52120A       CurrentTerminal = High; CurrentRange = 2 A
  3.008  52120A       Coil = 52120A/COIL6KA;  InductanceComp = On
  3.008  52120A       +Current = 15 A; Frequency = 10.0 Hz
# Repeat calibrator statement again to establish reference accuracy for test.
  3.009  5502E        +Frequency = 5.0 Hz; Current = 0.03 A; CurrTerm = Aux
  3.010  TARGET       -m
  3.011  MEMI         Enter UUT reading in Hertz:
  3.012  MEMCX  2500  5.0Hz          0.5% 0.5U     15A


6304 and 6304C

Instrument FSC

Description

The 6304 and 6304C FSCs program the Fluke PM 6304 and PM 6304C Programmable Automatic RCL Meter to resistance, capacitance, inductance, impedance, quality factor, dissipation factor, phase angle, voltage, or current.

If the PM 6304 is to be controlled via its serial port, do not use the PORT FSC port configuration special construction, [P9600,N,...], to set the baud rate, parity, etc. of the port used to control the PM 6304. MET/CAL executes a "Test" function for each System Instrument prior to executing any procedure statements, therefore the settings of the port used to controlling the PM 6304 must be set correctly before a procedure is executed. If the PM 6304 is connected to a standard serial port (COM1, COM2, ..., COM16), select the "Ports" application in the Windows control panel to choose the proper settings. If the PM 6304 is connected to the 5500A, 5520A, 5800A, 5820A UUT port, select the proper settings for the UUT Serial Port from the front panel of the calibrator.

Use the following for serial flow control:

  • PC COMM Port via Windows Control Panel
    • Flow Control: Hardware
  • Fluke 55xxA UUT Setup
    • STALL
    • cts/rts

Functional Capability

Impedance/Resistance | 0 Ω to 200 MΩ (AC), 50 MΩ (DC, PM 6304)
Capacitance | 0 pF to 31.8 F
Inductance | 0 μH to 637 μH
Quality Factor | 0 to 1000
Dissipation Factor | 0 to 1000
Phase Angle | -179 deg to 180 deg
Voltage | 0.1 μV to 2 V
Current | 0.005 μA to 10 mA

If the instrument indicates an underrange or overrange condition MET/CAL sets the measurement value returned as follows:

  • underrange: -200e+33
  • overrange: +200e+33

Parameters

RANGE

This field specifies the UUT range as described in the RANGE Field topic.

NOMINAL

This field specifies the expected measured value or a reset.

  • Impedance/Resistance entered as [numeric][numeric]Z.
  • Capacitance entered as [numeric][numeric]F.
  • Inductance entered as [numeric][numeric]Hy.
  • Quality Factor entered as [numeric][numeric]qf.
  • Dissipation Factor entered as [numeric][numeric]df.
  • Phase Angle entered as [numeric][numeric]deg.
  • Voltage (DC or RMS) entered as: [numeric][numeric]V
  • Current entered as [numeric][numeric]A.
  • Reset entered as *.

TOLERANCE

This field specifies the UUT tolerance as described in the TOLERANCE Field topic.

MOD1

This field specifies the test signal frequency.

  • Frequency entered as: [numeric][prefix]H
  • blank DC (PM 6304 only)

Rules:

  1. Allowed values are:
    1. 50, 60, 100, and 120 Hz
    2. 200 Hz to 20 kHz in 100 Hz steps
    3. 100 kHz
  2. 1kHz is automatically inserted in the 6404C MOD1 if test frequency is entered.

MOD2

This field is not used.

MOD3

This field specifies Zero Trim.

  • ZR Zero Trim
  • blank field not applicable

Rules:

  1. The MOD3 field may specify ZR only when the MOD4 field specifies "N" (Nominal Setup test).

MOD4

This field specifies the type of test being performed as described in the MOD4 Field topic.

CON

This field specifies the UUT connection and is always 4-wire (4W). 4W is inserted automatically in the CON field when no CON field code is entered.

Use of Standard Memory Locations and Results Reporting

System memory locations MEM and MEM1 are used. For more information, refer to the Use of Standard Memory Registers topic.

Examples

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
# -----  Reset  -----
  1.001  6304C        *                                                 S
# -----  Test Signal Amplitude  -----
  1.002  M6304C       1V
# -----  Zero Trim (Open Circuit)  -----
  1.003  DISP         SEPARATE the LCR meter test cables
  1.003  DISP         for the "Open Circuit" TRIM.
  1.003  DISP
  1.003  DISP         Press "Advance" ready.
  1.004  6304C        350.0pF                      1kH               ZR N  4W
# -----  Zero Trim (Short Circuit)  -----
  1.005  DISP         SHORT the LCR Meter test cables (using a COPPER short)
  1.005  DISP         for the "Short Circuit" TRIM.
  1.005  DISP
  1.005  DISP         Press "Advance" when ready.
  1.006  6304C        300.00nF                     1kH               ZR N  4W
# -----  Capacitance  -----
  1.007  IEEE         OUT 350pF;OPER;*OPC?[I!]
  1.008  6304C        350.0pF        0.38% 10U     1kH                     4W
  2.001  RSLT         =
# -----  Impedance / Resistance AC  -----
  2.002  M6304        1V
  2.003  6304         0.000Z         0.010U        50H                     4W
  3.001  6304         100.00kZ       5%            50H                     4W
# -----  Quality Factor  -----
  4.001  6304         0.008QF        0.005U        50H                     4W
  5.001  6304         124QF          5U            1kH                     4W
# -----  Dissipation Factor  -----
  6.001  6304         0.008DF        0.005U        1kH                     4W
  7.001  6304         131DF          5U            50H                     4W
# -----  Phase Angle  -----
  8.001  6304         -90.0deg       1.0U          1kH                     4W
# -----  Voltage  -----
  9.001  6304         0.91V          0.01U         1kH                     4W
 10.001  6304         0.843V         0.01U         1kH                     4W
# -----  Current  -----
 11.001  6304         0.90mA         0.01U         1kH                     4W
 12.001  6304         5.30mA         0.1U          1kH                     4W
# -----  Inductance  -----
 13.001  6304         25.00uHy       5%            1kH                     4W
 14.001  6304         230.00uHy      5%            1kH                     4W
# -----  Range Hold  -----
 15.001  M6304  HOLD  1V
 15.002  6304         1.0000uF                     100H                 N  4W
# -----  AC Test Signal Amplitude  -----
 15.003  M6304        50mV
 15.004  6304         1.0000uF                     100H                 N  4W
 15.005  M6304        2V
 15.006  6304         1.0000uF                     100H                 N  4W
 15.007  M6304        1V
 15.008  6304         1.0000uF                     100H                 N  4W
# -----  Internal Bias Voltage  -----
 15.009  M6304        1V                           2V                      INT
 15.010  6304         1.0000uF                     100H                 N  4W
# -----  External Bias Voltage  -----
 15.011  M6304        1V                           1V                      EXT
 15.012  6304         1.0000uF                     100H                 N  4W
# -----  Fast Mode  -----
 15.013  M6304        1V                                             FS
 15.014  6304         1.0000uF                     1kH                  N  4W
# -----  Serial Measurement Mode  -----
 15.015  M6304        1V                                                S
 15.016  6304         1.0000uF                     100H                 N  4W
# -----  Parallel Measurement Mode  -----
 15.017  M6304        1V                                                P
 15.018  6304         1.0000uF                     100H                 N  4W
# -----  Auto Measurement Mode  -----
 15.019  M6304        1V
 15.020  6304         1.0000uF                     100H                 N  4W


M6304 and M6304C

Instrument Setup FSC

Description

The M6304 and M6304C FSCs are used to specify the following:

  • Range Hold On/Off
  • Test Signal Level
  • DC Bias
  • Fast Mode On/Off
  • DC Bias Source Int/Ext
The PM 6304 AVERAGE command is not supported. The PM 630x driver uses SINGLE mode, however the AVERAGE command is only allowed in CONTINUOUS mode. To control the number of readings which are averaged, set NMEAS using the VSET or TSET FSC.

Parameters

RANGE

This field specifies whether RANGE HOLD is on or off.

HOLD | Turn RANGE HOLD on
blank | Turn RANGE HOLD off

NOMINAL

This field specifies the test signal level.

  • Voltage entered as: [numeric][prefix]V

Rules:

  1. Allowed values are:

    LEVEL | AC | DC (PM 6304 only)
    LO | 50 mV | 300 mV
    NORMAL | 1 V | 1 V
    HI | 2 V | 2 V
  2. 1 V is automatically inserted in the NOMINAL field if no test signal level is entered.
  3. If the Nominal field does not contain a value the value is taken from memory register MEM.

TOLERANCE

This field is not used.

MOD1

This field optionally specifies a DC bias for an AC test signal.

  • Voltage entered as: [numeric][prefix]V
  • blank DC bias off

Rules:

  1. The MOD1 field may specify voltage only when the 6304 FSC MOD1 field specifies frequency.
  2. If the MOD1 field does not contain a value the value is taken from memory register MEM.

MOD2

This field is not used.

MOD3

This field specifies whether FAST MODE is on or off.

FS | Turn FAST MODE on
blank | Turn FAST MODE off

MOD4

This field specifies the measurement mode.

S | Serial
P | Parallel
blank | Auto

CON

This field specifies whether the MOD1 DC bias is an internal or external.

  • INTInternal DC Bias
  • EXTExternal DC Bias
  • blank no DC bias

Rules:

6304 CON | 6304 MOD1
INT | 0 V or 2 V
EXT | 0 V to 40 V
  1. The CON field may specify INT or EXT only when the M6304 FSC MOD1 field specifies a DC bias.


6306

Instrument FSC

Description

The 6306 FSC programs the Fluke PM 6306 Programmable Automatic RCL Meter to resistance, capacitance, inductance, impedance, quality factor, dissipation factor, phase angle, voltage, or current.

If the PM 6306 is to be controlled via its serial port, do not use the PORT FSC port configuration special construction, [P9600,N,...], to set the baud rate, parity, etc. of the port used to control the PM 6306. MET/CAL executes a "Test" function for each System Instrument prior to executing any procedure statements, therefore the settings of the port used to controlling the PM 6306 must be set correctly before a procedure is executed. If the PM 6306 is connected to a standard serial port (COM1, COM2, ..., COM16), select the "Ports" application in the Windows control panel to choose the proper settings. If the PM 6306 is connected to the 5500A, 5520A, 5800A, 5820A UUT port, select the proper settings for the UUT Serial Port from the front panel of the calibrator.

Use the following for serial flow control:

  • PC COMM Port via Windows Control Panel
    • Flow Control: Hardware
  • Fluke 55xxA UUT Setup
    • STALL
    • cts/rts

Functional Capability

Impedance/Resistance | 0 Ω to 200 MΩ (AC), 50 MΩ (DC)
Capacitance | 0 pF to 31.8 F
Inductance | 0 μH to 637 μH
Quality Factor | 0 to 1000
Dissipation Factor | 0 to 1000
Phase Angle | -179 deg to 180 deg
Voltage | 0.1 μV to 2 V
Current | 0.005 μA to 10 mA

If the instrument indicates an underrange or overrange condition MET/CAL sets the measurement value returned as follows:

  • underrange: -200e+33
  • overrange: +200e+33

Parameters

RANGE

This field specifies the UUT range as described in the RANGE Field topic.

NOMINAL

This field specifies the expected measured value or a reset.

  • Impedance/Resistance entered as [numeric][prefix]Z.
  • Capacitance entered as [numeric][prefix]F.
  • Inductance entered as [numeric][prefix]Hy.
  • Quality Factor entered as [numeric][prefix]qf.
  • Dissipation Factor entered as [numeric][prefix]df.
  • Phase Angle entered as [numeric][prefix]deg.
  • Voltage (DC or RMS) entered as: [numeric][prefix]V
  • Current entered as [numeric][prefix]A.
  • Reset entered as *.

TOLERANCE

This field specifies the UUT tolerance as described in the TOLERANCE Field topic.

MOD1

This field specifies the test signal frequency.

  • Frequency entered as: [numeric][prefix]H
  • blank DC

Rules:

  1. Allowed values are:
    1. 50, 60, 100, and 120 Hz
    2. 200 Hz to 100 kHz in 100 Hz steps
    3. 100 kHz to 1 MHz in 1 kHz steps

MOD2

This field is not used.

MOD3

This field specifies Zero Trim.

ZR | Zero Trim
blank | field not applicable

Rules:

  1. The MOD3 field may specify ZR only when the MOD4 field specifies "N" (Nominal Setup test).

MOD4

This field specifies the type of test being performed as described in the MOD4 Field topic.

CON

This field specifies the UUT connection and is always 4-wire (4W).4W is inserted automatically in the CON field when no CON field code is entered.

Use of Standard Memory Locations and Results Reporting

System memory locations MEM and MEM1 are used. For more information, refer to the Use of Standard Memory Registers topic.

Examples

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
# -----  Reset  -----
  1.001  6306         *                                                 S
# -----  Test Signal Amplitude  -----
  1.002  M6306        1V
# -----  Zero Trim (Open Circuit)  -----
  1.003  DISP         SEPARATE the LCR meter test cables
  1.003  DISP         for the "Open Circuit" TRIM.
  1.003  DISP
  1.003  DISP         Press "Advance" ready.
  1.004  6306         350.0pF                      1kH               ZR N  4W
# -----  Zero Trim (Short Circuit)  -----
  1.005  DISP         SHORT the LCR Meter test cables (using a COPPER short)
  1.005  DISP         for the "Short Circuit" TRIM.
  1.005  DISP
  1.005  DISP         Press "Advance" when ready.
  1.006  6306         300.00nF                     1kH               ZR N  4W
# -----  Capacitance  -----
  1.007  IEEE         OUT 350pF;OPER;*OPC?[I!]
  1.008  6306         350.0pF        0.38% 10U     1kH                     4W
  2.001  RSLT         =
# -----  Impedance / Resistance AC  -----
  2.002  M6306        1V
  2.003  6306         0.000Z         0.010U        50H                     4W
  3.001  6306         100.00kZ       5%            50H                     4W
# -----  Quality Factor  -----
  4.001  6306         0.008QF        0.005U        50H                     4W
  5.001  6306         124QF          5U            1kH                     4W
# -----  Dissipation Factor  -----
  6.001  6306         0.008DF        0.005U        1kH                     4W
  7.001  6306         131DF          5U            50H                     4W
# -----  Phase Angle  -----
  8.001  6306         -90.0deg       1.0U          1kH                     4W
# -----  Voltage  -----
  9.001  6306         0.91V          0.01U         1kH                     4W
 10.001  6306         0.843V         0.01U         1kH                     4W
# -----  Current  -----
 11.001  6306         0.90mA         0.01U         1kH                     4W
 12.001  6306         5.30mA         0.1U          1kH                     4W
# -----  Inductance  -----
 13.001  6306         25.00uHy       5%            1kH                     4W
 14.001  6306         230.00uHy      5%            1kH                     4W
# -----  Range Hold  -----
 15.001  M6306  HOLD  1V
 15.002  6306         1.0000uF                     100H                 N  4W
# -----  AC Test Signal Amplitude  -----
 15.003  M6306        50mV
 15.004  6306         1.0000uF                     100H                 N  4W
 15.005  M6306        2V
 15.006  6306         1.0000uF                     100H                 N  4W
 15.007  M6306        1V
 15.008  6306         1.0000uF                     100H                 N  4W
# -----  Internal Bias Voltage  -----
 15.009  M6306        1V                           2V                      INT
 15.010  6306         1.0000uF                     100H                 N  4W
# -----  External Bias Voltage  -----
 15.011  M6306        1V                           1V                      EXT
 15.012  6306         1.0000uF                     100H                 N  4W
# -----  Fast Mode  -----
 15.013  M6306        1V                                             FS
 15.014  6306         1.0000uF                     1kH                  N  4W
# -----  Serial Measurement Mode  -----
 15.015  M6306        1V                                                S
 15.016  6306         1.0000uF                     100H                 N  4W
# -----  Parallel Measurement Mode  -----
 15.017  M6306        1V                                                P
 15.018  6306         1.0000uF                     100H                 N  4W
# -----  Auto Measurement Mode  -----
 15.019  M6306        1V
 15.020  6306         1.0000uF                     100H                 N  4W


M6306

Instrument Setup FSC

Description

The M6306 FSC is used to specify the following:

  • Range Hold On/Off
  • Test Signal Level
  • Test Fixture Capacitance
  • DC Bias
  • Fast Mode On/Off
  • DC Bias Source Int/Ext
The PM 6306 AVERAGE command is not supported. The PM 630x driver uses SINGLE mode, however the AVERAGE command is only allowed in CONTINUOUS mode. To control the number of readings which are averaged, set NMEAS using the VSET or TSET FSC.

Parameters

RANGE

This field specifies whether RANGE HOLD is on or off.

HOLD | Turn RANGE HOLD on
blank | Turn RANGE HOLD off

NOMINAL

This field specifies the test signal level.

  • Voltage entered as: [numeric][prefix]V

Rules:

  1. Allowed values are: 0.05V to 2.00V with a resolution of 0.01V.
  2. 1V is automatically inserted in the NOMINAL field if no test signal level is entered.
  3. If the Nominal field does not contain a value the value is taken from memory register MEM.

TOLERANCE

This field specifies the test fixture capacitance.

  • Capacitance entered as: [numeric][prefix]F
  • blank fixture capacitance not programmed

Rules:

  1. Allowed values are: 50pF to 1050pF.
  2. If the Tolerance field does not contain a value the value is taken from memory register MEM.

MOD1

This field optionally specifies a DC bias for an AC test signal.

  • Voltage entered as: numeric[prefix]V
  • blank DC bias off

Rules:

  1. The MOD1 field may specify voltage only when the 6306 FSC MOD1 field specifies frequency.
  2. If the MOD1 field does not contain a value the value is taken from memory register MEM.

MOD2

This field is not used.

MOD3

This field specifies whether FAST MODE is on or off.

FS | Turn FAST MODE on
blank | Turn FAST MODE off

MOD4

This field specifies the measurement mode.

S | Serial
P | Parallel
blank | Auto

CON

This field specifies whether the MOD1 DC bias is an internal or external.

INT | Internal DC Bias
EXT | External DC Bias
blank | no DC bias

Rules:

6306 CON | 6306 MOD1
INT | 0.1V to 10V
EXT | 0.1V to 40V
  1. The CON field may specify INT or EXT only when the M6306 FSC MOD1 field specifies a DC bias.


6520

Instrument FSC

Description

The 6520 FSC programs the Guildline 6520 Teraohmmeter to measure resistance or current. MET/CAL requires 6520 firmware revision G or later. See M6520 FSC for additional 6520 settings.

Dangerous voltages can be present at the source connector.

IEEE-488 Control

To configure the 6520 for IEEE-488 control using the factory default address, perform the following steps from 6520 front panel top level menu...

  1. Select "Measure" softkey.
  2. Select "Ohms" or "Current" softkey.
  3. Select "Setup" softkey.
  4. Select "Profiles" softkey.
  5. Press the up or down arrow key, as necessary, until the "GPIB" is highlighted.
  6. Select "Select" softkey.

RS-232 Control

To configure the 6520 for RS-232 control using the factory default settings, perform the following steps from 6520 front panel top level menu...

  1. Select "Measure" softkey.
  2. Select "Ohms" or "Current" softkey.
  3. Select "Setup" softkey.
  4. Select "Profiles" softkey.
  5. Press the up or down arrow key, as necessary, until the "RS232" is highlighted.
  6. Select "Select" softkey.

Do not use the PORT FSC port configuration special construction, [P9600,N,8,1,X], to set the baud rate, parity, data bits, stop bits, and flow control. MET/CAL executes a "Test" function for each System Instrument prior to executing any procedure statements, therefore the settings of the port used to controlling the 6520 must be set correctly before a procedure is executed. If the 6520 is connected to a standard serial port (COM1, COM2, ..., COM16), use the Windows control panel to choose the proper settings. If the 6520 is connected to the 5500A, 5520A, 5800A, or 5820A UUT port, select the proper settings for the UUT Serial Port from the front panel of the calibrator.

Functional Capability

Resistance 100 kΩ to 100,000 TΩ

Current +/-(10 fA to 10 mA)

Parameters

RANGE

This field specifies the UUT range as described in the RANGE Field topic.

NOMINAL

This field specifies the expected measured value or a reset.

  • Resistance entered as [numeric][prefix]Z.
  • Current entered as [numeric][prefix]A.
  • Reset entered as *.

Rules:

  1. When the NOMINAL field units are amps, the M6520 FSC MOD4 field must specify positive or negative polarity (+ or -).
  2. When the NOMINAL field specifies positive amps, the M6520 FSC MOD4 field must specify positive polarity ('+').
  3. When the NOMINAL field specifies negative amps, the M6520 FSC MOD4 field must specify negative polarity ('-').
  4. When the NOMINAL field contains only units, the value is obtained from the memory register MEM.

TOLERANCE

This field specifies the UUT tolerance as described in the TOLERANCE Field topic.

MOD1

This field is not used.

MOD2

This field is not used.

MOD3

This field is not used.

MOD4

This field specifies the type of test being performed as described in the MOD4 Field topic.

CON

This field specifies the UUT connection.

  • 3W 3-wire

Rules:

  1. 3W is automatically inserted in the CON field if no valid CON field code is entered.

Use of Standard Memory Locations and Results Reporting

System memory locations MEM and MEM1 are used. For more information, refer to the Use of Standard Memory Registers topic.

Examples

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
  1.001  ASK-   R     N              P                            F        V
# -----  Reset  -----
  1.002  M6520        *
  1.003  6520         *                                                 S
# -----  Ohms Measurement  -----
  1.004  DISP         Connect the 6520 SOURCE and INPUT leads to the Decade
  1.004  DISP         Resistor Hi and Lo terminals, respectively. Connect the
  1.004  DISP         shield of both leads to the Decade Resistor ground
  1.004  DISP         terminal.
  1.004  DISP
  1.004  DISP         The gound and Lo terminal of the Decade Resistor must
  1.004  DISP         NOT be strapped together.

  1.005  DISP         Set the Decade Resistor to 100 kOhms.
# -----  Autoange  -----
  1.006  M6520  MAX   10V
  1.007  6520   100   100.000kZ                                         N  3W
# -----  Manual Ranging  -----
  1.008  M6520  TEST  10V                                         C3 T3
  1.009  6520   100   100.000kZ                                         N  3W
# -----  Positive Polarity  -----
  1.010  M6520                                                          +
  1.011  6520   100   100.000kZ                                         N  3W
# -----  Negative Polarity  -----
  1.012  M6520                                                          -
  1.013  6520   100   100.000kZ                                         N  3W
# -----  Evalutation Tests  -----
  1.014  6520   100   100.000kZ      0.1%                                  3W
  2.001  DISP         Set the Decade Resistor to 1 MOhm.
  2.002  6520   1     1.00000MZ      0.1%                                  3W
  3.001  DISP         Set the Decade Resistor to 10 MOhms.
  3.002  6520   10    10.0000MZ      0.1%                                  3W
  4.001  6520         *                                                 S

  4.002  DISP         Disconnect the 6520 from the Decade Resistor.
  4.003  DISP         Connect the 6520 SOURCE and INPUT leads to a 1000 MOhm
  4.003  DISP         Test Resistor Hi and Lo terminals, respectively. Connect
  4.003  DISP         the shield of both leads to the Test Resistor ground
  4.003  DISP         terminal.
  4.003  DISP
  4.003  DISP         The gound and Lo terminal of the Test Resistor must
  4.003  DISP         NOT be strapped together.

  4.004  MEMI         Enter certified value of the Test Resistor (in MOhms):
  4.005  M6520        *
  4.006  6520   1000  MZ             0.1% 0.00U                            3W
# -----  Current Measurement  -----
  5.001  DISP         Connect the 6520 INPUT lead to the current source.
# Set the 6520 to amps to prevent an overcompliance error from current source.
  5.002  IEEE         [@6520]MEAS:UNIT AMPS
# -----  Autoange  -----
  5.003  DISP         Set the current source to 10 uA DC.
  5.004  M6520                                                          +
  5.005  6520   10    10.0000uA      1%                                    3W
  6.001  DISP         Set the current source to -10 uA DC.
  6.002  M6520                                                          -
  6.003  6520   10    -10.0000uA     1%                                    3W
# -----  Manual Ranging  -----
  7.001  DISP         Set the current source to 100 uA DC.
  7.002  M6520                                                    C3 T3 +  ON
  7.003  6520   100   100.000uA      1%                                    3W
  8.001  DISP         Set the current source to -100 uA DC.
  8.002  M6520                                                    C3 T3 -  ON
  8.003  6520   100   -100.000uA     1%                                    3W
  9.001  DISP         Set the current source to 1 mA DC.
  9.002  M6520                                                    C3 T3 +  ON
  9.003  6520   1     1.00000mA      1%                                    3W
 10.001  DISP         Set the current source to -1 mA DC.
 10.002  M6520                                                    C3 T3 -  ON
 10.003  6520   1     -1.00000mA     1%                                    3W
 11.001  DISP         Set the current source to 10 mA DC.
 11.002  M6520                                                    C3 T3 +  ON
 11.003  6520   10    10.0000mA      1%                                    3W
 12.001  DISP         Set the current source to -10 mA DC.
 12.002  M6520                                                    C3 T3 -  ON
 12.003  6520   10    -10.0000mA     1%                                    3W


437

Instrument FSC

Description

The 437 FSC programs the Hewlett-Packard 437B Power Meter. The 437 FSC can also program the Hewlett-Packard E4418A (previously EPM-441A) Power Meter when it is in 437B language emulation mode The driver automatically sets the E4418A to 437B language emulation mode.

Functional Capability

Function | 437 MOD3 | 437 NOMINAL | 437 MOD1 | M437 NOMINAL
RF Power 1

RF

-70 dBm to +44 dBm

100 kHz to 110 GHz
100 pW to 25 W
Zero sensor | ZR | 0 W | 100 kHz to 110 GHz
Zero and Cal. sensor | CP | 1 μW to 1 mW | 50 MHz | 0 to 100 %
  1. NOMINAL (Power) and MOD1 (frequency) ranges depend upon the power sensor model used (see M437 MOD1 field): 25 W Sensors

Model | Power Range | Frequency Range
25 W Sensors
8481B | 0 to +44 dBm (1mW to 25W) | 10 MHz to 18.0 GHz
8482B | 0 to +44 dBm (1mW to 25W) | 100 kHz to 4.2 GHz
3 W Sensors
8481H | -10 to +35 dBm (100 μW to 3 W) | 10 MHz to 18.0 GHz
8482H | -10 to +35 dBm (100 μW to 3 W) | 100 kHz to 4.2 GHz
100 mW Sensors
8481A | -30 to +20 dBm (1μW to 100 mW) | 10 MHz to 18.0 GHz
8482A | -30 to +20 dBm (1μW to 100 mW) | 100 kHz to 4.2 GHz
8483A | -30 to +20 dBm (1μW to 100 mW) | 100 kHz to 2.0 GHz
8485A | -30 to +20 dBm (1μW to 100 mW) | 50 MHz to 26.5 GHz
R8486A | -30 to +20 dBm (1μW to 100 mW) | 26.5 MHz to 40 GHz
Q8486A | -30 to +20 dBm (1μW to 100 mW) | 33 MHz to 50 GHz
W8486A | -30 to +20 dBm (1μW to 100 mW) | 75 MHz to 110 GHz
8487A | -30 to +20 dBm (1μW to 100 mW) | 50 MHz to 50 GHz
High Sensitivity Sensors
8481D | -70 to -20 dBm (100 pW to 10 μW) | 10 MHz to 18.0 GHz
8484A | -70 to -20 dBm (100 pW to 10 μW) | 10 MHz to 18.0 GHz
8485D | -70 to -20 dBm (100 pW to 10 μW) | 50 MHz to 26.5 GHz
R8486D | -70 to -20 dBm (100 pW to 10 μW) | 26.5 MHz to 40 GHz
Q8486D | -70 to -20 dBm (100 pW to 10 μW) | 33 MHz to 50 GHz
8487D | -70 to -20 dBm (100 pW to 10 μW) | 50 MHz to 50 GHz

Parameters

RANGE

This field specifies the UUT range as described in the RANGE Field topic.

NOMINAL

This field specifies the expected measured value or a reset.

  • RF Power entered as [numeric][prefix]W or D.
  • Reset entered as *.

Rules:

  • When the Nominal field contains only units, the value is obtained from memory register MEM. In this case the MOD1 field MUST contain a value.

TOLERANCE

This field specifies the UUT tolerance as described in the TOLERANCE Field topic.

MOD1

This field specifies the frequency.

  • Frequency entered as [numeric][prefix]H.
  • blank not applicable

Rules:

  • When the MOD1 field contains only units, the value is obtained from memory register MEM. In this case the Nominal field MUST contain a value.

MOD2

This field is not used.

MOD3

This field specifies the measurement type:

RF | RF Power
ZR | Zero sensor
CP | Zero and Calibrate sensor

Rules:

  • See Functional Capability table.
  • RF is inserted in the MOD3 field when no legal MOD3 field code is entered.
  • The MOD3 field may specify ZR and CP only for a Nominal Setup Test (MOD4 = N). However MEM is not update when MOD3 is ZR or CP.
  • When the MOD3 field specifies CP the M437 NOMINAL field must specify the reference calibration factor.

MOD4

This field specifies the type of test being performed as described in the MOD4 Field topic.

CON

This field is always blank.

Use of Standard Memory Locations and Results Reporting

System memory locations MEM and MEM1 are used. For more information, refer to the Use of Standard Memory Registers topic.

Examples

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
# ----- Reset -----
  1.001  M437         *
  1.002  437          *                                                 S
# ----- Specify table for Power Sensor Data -----
# ----- Assume factory default table (#5) for 8482A ----
  1.003  M437                                      HP8482A        T5
# ----- Zero and Calibrate sensor -----
  1.004  DISP         Connect the HP 8482A Power Sensor to the 437B.
  1.005  MEMI         Enter sensor's reference calibration factor in percent.
  1.006  M437         pct                          HP8482A        T5
  1.007  DISP         Connect the sensor to the 1mW/50MHz POWER REF Output.
  1.008  437          1mW                          50MH              CP N
# ----- Power Measurement (dBm) -----
  1.009  M437                        F4            HP8482A        T5
  1.010  DISP         Connect the 437B Power Sensor to Sig. Gen. RF Output.
  1.011  437          -30.00D        3.00U         100MH             RF
  2.001  437          -20.00D        1.00U         100MH             RF
  3.001  437          -10.00D        1.00U         100MH             RF
  4.001  437          0.00D          1.00U         100MH             RF
  5.001  437          10.00D         1.00U         100MH             RF
# ----- Power Measurement (Watts) -----
  6.001  437          1.00uW         20%           100MH             RF
  7.001  437          10.00uW        5%            100MH             RF
  8.001  437          100.0uW        5%            100MH             RF
  9.001  437          1.000mW        5%            100MH             RF
 10.001  437          10.00mW        5%            100MH             RF
# ----- Low Resolution -----
 11.001  M437   LOW                  F128          HP8482A
 11.002  437          0.0D                         300MH             RF S
# ----- Mid Resolution -----
 11.003  M437   MID                  F128          HP8482A
 11.004  437          0.00D                        300MH             RF S
# ----- High Resolution -----
 11.005  M437   HIGH                 F128          HP8482A
 11.006  437          0.000D                       300MH             RF S
# ----- Filter -----
 11.007  M437                        F1            HP8482A
 11.008  437          -1.00D                       150MH             RF N
 11.009  M437   HIGH                 F512          HP8482A
 11.010  437          -2.000D                      150MH             RF N


M437

Instrument Setup FSC

Description

The M437 FSC provides the additional program functions for Hewlett-Packard 437B which are not addressed by the 437 FSC. These functions include resolution, calibration factor, filter, and calibration factor table number.

RANGE

This field specifies the resolution.

LOW | 0.1dB (log), 1% full scale (linear)
MID | 0.01dB (log), 0.1% full scale (linear)
HIGH | 0.001dB (log), 0.01% full scale (linear)
blank | Default

Rules:

  • When the Range field is blank the power-on default resolution is used, which is "MID".

NOMINAL

This field specifies the reference calibration factor or a reset.

  • Reference Calibration Factor entered as: [numeric][prefix]pct.
  • "*" Reset
  • blank Not applicable

Rules:

  • Legal values for reference calibration factor are 0 to 100%.
  • When the NOMINAL field does not specify a value, the value is taken from memory register MEM.
  • When the NOMINAL field specifies a reset the following default values are selected:
Resolution: | MID
Filter: | Auto
Cal. Factor Table: | 0

TOLERANCE

This field specifies the filter.

  • Number of readings to average entered as: Faverage.
  • blank Default

Rules:

  • Legal values for average are: 1, 2, 4, 8,... 512.
  • When the TOLERANCE field is blank auto filter mode is selected.

MOD1

This field specifies the power sensor used entered as:

[HP]model number. Legal entries are:

  • HP8481A
  • HP8481B
  • HP8481D
  • HP8481H
  • HP8482A
  • HP8482B
  • HP8482H
  • HP8483A
  • HP8484A
  • HP8485A
  • HP8485D
  • HP8487A
  • HP8487D
  • HPQ8486A
  • HPQ8486D
  • HPR8486A
  • HPR8486D
  • HPW8486A

Rules:

  • The MOD1 field must specify the power sensor model number except when the NOMINAL field specifies a reset '*'.

MOD2

This field specifies the power sensor calibration factor table to be used.

Cal factor table entered as: | T[table number]
blank | Default

Rules:

  • Legal values for table number are: 0-9
  • When the MOD1 field does not specify a value, the value is taken from memory register MEM2 as an ASCII integer.
  • When the MOD1 field is blank table 0 is selected.

MOD3

This field is not used.

MOD4

This field is not used.

CON

This field is not used.

Examples

Refer to 437 FSC.


3325

Instrument FSC

Description

The 3325 FSC programs the Hewlett-Packard 3325B and 3325A Function Generators to output sine, square, triangle, positive ramp, and negative ramp waveforms.

When the 3325 and M3325 FSCs are used to control an HP 3325A, you must configure the instrument as an "HP 3325B" as shown in the drop-down list in the "Add Instrument" configure dialog. Note on 3325B serial control If the 3325B is to be controlled via its serial port, do not use the PORT FSC port configuration special construction, [P9600,N,...], to set the baud rate, parity, etc. of the port used to control the 3325B. MET/CAL executes a "Test" function for each System Instrument prior to executing any procedure statements. Therefore the settings of the port used to control the 3325B must be set correctly before a procedure is executed. If the 3325B is connected to a standard serial port (COM1, COM2, ..., COM16), use the "Ports" application in the Windows Control Panel to choose the proper settings. If the 3325B is connected to the 5500A, 5520A, 5800A, or 5820A UUT port, select the proper settings for the UUT Serial Port from the front panel of the calibrator.

Functional Capability

Function Amplitude 1 Frequency 2

DC Voltage

-5 V to 5 V

Sine

1 mVpp to 10 Vpp

1 μHz to 20.999999999 MHz

0.354 mV to 3.536 V
-56.02 dBm to +23.98 dBm

Square

1 mVpp to 10 Vpp

1 μHz to 10.999999999 MHz

0.5 mV to 5 V

Triangle

1 mVpp to 10 Vpp

1 μHz to 10.999999999 kHz

0.289 mV to 2.887 V

Positive Ramp

1 mVpp to 10 Vpp

1 μHz to 10.999999999 kHz

0.289 mV to 2.887 V

Negative Ramp

-1 mVpp to -10 Vpp

1 μHz to 10.999999999 kHz

-0.289 mV to -2.887 V
  1. Amplitude limits are increased by 4x when high voltage (opt 002) is enabled.
  2. Frequency is limited to 1MHz for sin and square when the high voltage (opt 002) is enabled.

Parameters

RANGE

This field specifies the UUT range as described in the RANGE Field topic.

NOMINAL

This field specifies the starting Nominal value of the stimulus output or expected UUT reading for the test.

  • Voltage (DC or RMS) entered as: [numeric][prefix]V
  • Voltage (Peak-to-Peak) entered as: [numeric][prefix]Vpp
  • dBm entered as: [numeric][prefix]D
  • Frequency entered as: [numeric][prefix]H
  • Period entered as: [numeric][prefix]T

Rules:

  • The NOMINAL field may specify dBm only when the MOD2 field specifies SI.
  • The NOMINAL field may specify Voltage peak-to-peak, Frequency, or Period only when the MOD2 field specifies SI, SQ, TI, +R or -R.
  • When the NOMINAL field contains only units, the value is obtained from the memory register MEM.
  • When the NOMINAL field contains only units and the MOD1 field is not blank, the MOD1 field must specify a value.

TOLERANCE

This field specifies the UUT tolerance as described in the TOLERANCE Field topic.

MOD1

This field specifies amplitude or frequency or period for AC functions.

  • Voltage (RMS) entered as: [numeric][prefix]V
  • Voltage (Peak-to-Peak) entered as: [numeric][prefix]Vpp
  • dBm entered as: [numeric][prefix]D
  • Frequency entered as [numeric][prefix]H.
  • Period entered as [numeric][prefix]T.
  • blank DC

Rules:

  • The MOD1 field may specify dBm only when the MOD2 field specifies SI.
  • The MOD1 field may specify frequency or period only when the NOMINAL field specifies voltage or decibels.
  • The MOD1 field may specify voltage or decibels only when the NOMINAL field specifies frequency or period.
  • When the MOD1 field contains only units, the value is obtained from memory register MEM. In this case the NOMINAL field MUST contain a value.

MOD2

This field specifies the function (waveform type).

blank | DC Volts
SI | Sine
SQ | Square
TI | Triangle
+R | Positive Ramp
-R | Negative Ramp

Rules:

  • SI is inserted automatically in the MOD2 field when the MOD1 field is not blank and no MOD2 code is entered.

MOD3

This field is used to set the high voltage option.

HV | Enabled
blank | Disabled

Rules:

  • The MOD3 field may specify HV only when the NOMINAL or MOD1 field specifies voltage (i.e. decibels are not allowed with HV).

MOD4

This field specifies the type of test being performed as described in the MOD4 Field topic.

CON

This field specifies the UUT connection.

blank | Unterminated
L | 50 Ohm termination

Rules:

  • The CON field must be blank when the MOD3 field is HV.
  • The CON field must be L when the MOD3 field is blank.
  • L is automatically inserted in the CON field when the MOD3 field is blank.
  • When the CON field is L the output is expected to be terminated with 50 Ohms. This can be accomplished by using a 50 Ohm terminator at the UUT or setting the UUT input impedance to 50 Ohms.
  • If ASK- W or ASK- V is in effect, the procedure writer must use a DISP FSC to prompt the operator to terminate the output signal at the UUT.

Use of Standard Memory Locations and Results Reporting

System memory locations MEM and MEM1 are used. For more information, refer to the Use of Standard Memory Registers topic.

Examples

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
# -----  Reset -----
  1.001  3325         *                                                 S
# -----  DC Voltage -----
  1.002  3325   20    19.99mV        2% 0.04U                              L
  2.001  3325   400   350.0mV        1.9% 0.4U                             L
# -----  Sine Wave -----
  3.001  3325   400   350.0mV        -2.8U +2.9U   60H            SI       L
  4.001  3325   400   3.500V         7.4U          20kH           SI       L
  5.001  3325         -37.78D        0.01U         100H           SI       L
# -----  Square Wave w/DC offset -----
  6.001  M3325                                     0.5Voff
  6.002  3325         1Vpp                         1kH            SQ    S  L
# -----  Triangle Wave -----
  6.003  M3325                                     0Voff
  6.004  3325         13mVpp                       10kH           TI    S  L
# -----  Positive Ramp -----
  6.005  3325         1.0Vpp                       5kH            +R    S  L
# -----  Negative Ramp -----
  6.006  3325         1.0Vpp                       5kH            -R    S  L
# -----  Frequency -----
  6.007  3325   1000  800.0H         0.1% 0.1U     300mV          SI       L
# -----  High Voltage -----
  7.001  3325         40.00Vpp                     2kH            SQ HV S


M3325

Instrument Setup FSC

Description

The M3325 FSC is used to specify DC Offset for AC waveforms of the 3325B or 3325A.

Parameters

RANGE

This field is not used.

NOMINAL

This field is not used.

TOLERANCE

This field is not used.

MOD1

This field specifies the DC Offset entered as: [numeric][prefix]Voff

Rules:

• A DC offset specification is ignored when the 3325 FSC specifies DC Voltage.

• Specify 0.0Voff to turn off a DC offset.

• If the MOD1 field does not contain a value the value is taken from memory register MEM.

MOD2

This field is not used.

MOD3

This field is not used.

MOD4

This field is not used.

CON

This field is not used.

Examples

See 3325 FSC.


3458

Instrument FSC

Description

The 3458 FSC programs the Agilent and Hewlett-Packard 3458A Multimeters to measure DC voltage, AC voltage, DC current, AC current, resistance, frequency, period, or decibels.

When the 3458 and M3458 FSCs are used to control an Agilent 3458A, you must configure the instrument as an "HP 3458A" as shown in the drop-down list in the "Add Instrument" configure dialog.

Functional Capability

Function | NOMINAL | MOD1 | MOD2 | MOD3
DC Voltage | -1050 V to 1050 V |  |  | [F|E|FE]
AC Voltage | 500 uV to 742 V |  | 10 Hz to 2 MHz | [FE]
 | 500 uV to 742 V |  | 20 Hz to 10 MHz | F
 | 1 mV to 742 V |  | 1 Hz to 2 MHz | E
DC Current | -1.2A to 1.2A |  |  | [F|E|FE]
AC Current | 5uA to 1.2A |  | 10 Hz to 100 kHz | [F|E|FE]
Resistance | 0 Ω to 1.2 GΩ |  | [O] | [F|E|FE]
Frequency | 1 Hz to 10 MHz |  | 1 mV to 742 V | [FE]
dBm | -53.01 dBm to 70.41 dBm | 10Hz to 2MHz | 5Z | [FE]
 | -53.01 dBm to 70.41 dBm | 20Hz to 10MHz | 5Z | F
 | -46.99 dBm to 70.41 dBm | 1Hz to 2MHz | 5Z | E
 | -54.77 dBm to 68.65 dBm | 10Hz to 2MHz | 7Z | [FE]
 | -54.77 dBm to 68.65 dBm | 20Hz to 10MHz | 7Z | F
 | -54.77 dBm to 68.65 dBm | 1Hz to 2MHz | 7Z | E
 | -60.79 dBm to 62.63 dBm | 10Hz to 2MHz | 3Z | [FE]
 | -60.79 dBm to 62.63 dBm | 20Hz to 10MHz | 3Z | F
 | -54.77 dBm to 62.63 dBm | 1Hz to 2MHz | 3Z | E
 | -63.80 dBm to 59.92 dBm | 10Hz to 2MHz | 6Z | [FE]
 | -63.80 dBm to 59.92 dBm | 20Hz to 10MHz | 6Z | F
 | -57.78 dBm to 59.92 dBm | 1Hz to 2MHz | 6Z | E
The AC Voltage input range is extended to 1500Vp if the kilovolt option is installed.

Parameters

RANGE

This field specifies the UUT range as described in the RANGE Field topic.

NOMINAL

This field specifies the expected measured value or a reset.

  • Voltage (DC or RMS) entered as:[numeric][prefix]V
  • dBm entered as: [numeric][prefix]D
  • Current entered as [numeric][prefix]A.
  • Resistance entered as [numeric][prefix]Z.
  • Frequency entered as [numeric][prefix]H.
  • Period entered as [numeric][prefix]T.
  • Reset entered as *.

Rules:

  • The NOMINAL field may specify decibels only when the MOD2 field specifies the reference impedance.

TOLERANCE

This field specifies the UUT tolerance as described in the TOLERANCE Field topic.

MOD1

This field specifies frequency for AC voltage and AC current measurements or voltage for frequency and period measurements.

  • Frequency entered as numeric[prefix]H.
  • Period entered as numeric[prefix]T.
  • Voltage entered as: numeric[prefix]V
  • dBm entered as: numeric[prefix]D
  • Current entered as numeric[prefix]A.
  • blank not applicable

Rules:

  • The MOD1 field may specify frequency or period only when the NOMINAL field specifies voltage or decibels.
  • The MOD1 field may specify voltage, decibels, or current only when the NOMINAL field specifies frequency or period.
  • The MOD1 field must be blank when the NOMINAL field specifies resistance.

MOD2

This field specifies one of the following:

1. The load impedance that the AC voltage is referenced to or

2. A code which overrides the automatic enabling of the offset compensated Ohms function.

7Z | 75 Ω
3Z | 300 Ω
6Z | 600 Ω
O | Override (disable) offset compensated Ohms
blank | field not applicable

Rules:

  • The MOD2 field may specify a reference impedance only when the NOMINAL field specifies decibels.
  • The MOD2 field may specify override only when the NOMINAL field specifies resistance.

MOD3

Specifies the measurement mode. The measurement mode determines certain function settings, as well as the number of readings that are discarded and the number of readings that are averaged to obtain a measurement. The effect of the measurement mode on the programmed function is shown in the following table:

F | blank | E | FE
DC Volts
number of powerline cycles | 10 | 100 | 100 | 100
Readings:
thrown away | 1 | 1 | 1 | 1
averaged 1 | 1 | 3 | 5 | 1
Autozero | On | On | On | On
DC Current
number of powerline cycles | 10 | 100 | 100 | 100
Readings:
thrown away | 1 | 1 | 2 | 1
averaged 1 | 1 | 3 | 5 | 1
Autozero | On | On | On | On
Ohms (2-Wire and 4-Wire)
number of powerline cycles | 10 | 100 | 100 | 100
≤ 19 kΩs
Readings
thrown away 1 | 1 | 2 | 2 | 1
averaged 1 | 3 | 4 | 4 | 1
>19 kΩs to ≤ 190 kΩs
Readings
thrown away | 1 | 2 | 5 | 1
averaged 1 | 3 | 4 | 4 | 1
>190 kΩs
Readings
thrown away | 1 | 2 | 7 | 1
averaged 1 | 3 | 4 | 5 | 1
Autozero | On | On | On | On
Offset Compensation
< 12 kΩ | On | On | On | On
≥ 12 kΩ | Off | Off | Off | Off
AC Volts
Conversion | Random Samp. | Analog RMS | Synchronous | Analog RMS
Bandwidth | 20 Hz to 10 MHz | 10 Hz to 2 MHz | 1 Hz to 2 MHz | 10 Hz to 2 MHz
Readings
thrown away 1 | 1 | 1 | 1 | 1
averaged 1 | 1 | 3 | 3 | 1
Resolution | default | default | 0.001 | default
Level Filter, AC Volts only | default | default | On <75 kHz | default
Off ≥75 kHz
Sync. Source | N/A | N/A | Level, Hold | N/A
AC Current
number of powerline cycles | 10 | 100 | 100 | 100
Readings
thrown away 1 | 1 | 1 | 2 | 1
averaged 1 | 1 | 3 | 5 | 1
Frequency
Readings
thrown away 1 | N/A | 1 | N/A | 1
averaged 1 | N/A | 3 | N/A | 1
Level Filter, AC Volts only | default | On < 75 kHz | default | On < 75 kHz
Off ≥ 75 kHz | Off ≥ 75 kHz
Period
Readings
thrown away 1 | N/A | 1 | N/A | 1
averaged 1 | N/A | 3 | N/A | 1
AC Volts only Level Filter | default | On > 13.3 μs | default | On > 13.3 μs
Off ≤ 13.3 μs | Off ≤ 13.3 μs
  1. With measurement uncertainty disabled. When measurement uncertainty is enabled, use VSET FSC to set number of readings to throw away and average.

MOD4

This field specifies the type of test being performed as described in the MOD4 Field topic.

CON

This field specifies the UUT connection.

2W | 2-wire
4W | 4-wire

Rules:

  • The CON field may specify a 4W only when the NOMINAL field specifies resistance.

Use of Standard Memory Locations and Results Reporting

System memory locations MEM and MEM1 are used. For more information, refer to the Use of Standard Memory Registers topic.

Examples

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
# ----- Reset -----
  1.001  3458         *                                                 S
# ----- DC Voltage -----
  1.002  3458   A     -1000V         1% 0.1U                               2W
# ----- AC Voltage -----
  2.001  3458   200   100V           1% 2/         10kH                    2W
# ----- dBm -----
  3.001  3458   100   56.62D         2% 0.1U       1kH            6Z       2W
# ----- DC Current -----
  4.001  3458   10    1.00A          1000P%                                2W
# ----- AC Current -----
  5.001  3458   2     mA             1%            1kH                     2W
# ----- Resistance -----
  6.001  3458   100   256kZ          1%                                    2W
# ----- Frequency -----
  7.001  3458         800.0H         0.1% 0.1U     300mV                   2W


M3458

Instrument Setup FSC

Description

The M3458 FSC provides range locking for the Hewlett-Packard 3458A Multimeter.

Parameters

When a blank M3458 statement is entered, a "*" is inserted automatically in the NOMINAL field. See NOMINAL field parameter for a description of "*".

RANGE

This field specifies one of the following:

RNGLK | Range Lock
blank | field not applicable

Rules:

  • When the RANGE field specifies RNGLK, the NOMINAL field must specify the range selection value.

NOMINAL

This field specifies one of the following:

  • Voltage range selection value entered as: numeric[prefix]V
  • Current range selection value entered as: numeric[prefix]A
  • Resistance range selection value entered as: numeric[prefix]Z
  • "*" reset to default values

Rules:

  • The NOMINAL field may specify a range selection value only when the RANGE field specifies RNGLK.
Selection Value | Locked Range
-12 mV to 12 mV | 100 mV DC, 10 mV AC
-120 mV to < -12 mV | 100 mV
> 12 mV to 120 mV | 100 mV
-1.2 V to < -120 mV | 1 V
> 120 mV to 1.2 V | 1 V
-12 V to < -1.2 V | 10 V
> 1.2 V to 12 V | 10 V
-120 V to < -12 V | 100 V
> 12 V to 120 V | 100 V
-1050 V to < -120 V | 1000 V
> 120 V to 1050 V | 1000 V
-0.12 uA to 0.12 uA | 0.1 μA DC, 100 μA AC
-1.2 μA to < -0.12 μA | 1 μA DC, 100 μA AC
> 0.12 μA to 1.2 μA | 1 μA DC, 100 μA AC
- 12 μA to < -1.2 μA | 10 μA DC, 100 μA AC
> 1.2 μA to 12 μA | 10 μA DC, 100 μA AC
-120 μA to < -12 μA | 100 μA
> 12 μA to 120 μA | 100 μA
-1.2 mA to < -120 uA | 1 mA
> 120 μA to 1.2 mA | 1 mA
-12 mA to < -1.2 mA | 10 mA
> 1.2 mA to 12 mA | 10 mA
-120 mA to < -12 mA | 100 mA
> 12 mA to 120 mA | 100 mA
-1.2 A to < -120 mA | 1 A
> 120 mA to 1.2 A | 1 A
0 OΩ to 12 Ω | 10 Ω
> 12 Ω to 120 Ω | 100 Ω
> 120 Ω to 1.2 kΩ | 1 kΩ
> 1.2 kΩ to 12 kΩ | 10 kΩ
> 12 kΩ to 120 kΩ | 100 kΩ
> 120 kΩ to 1.2 MΩ | 1 MΩ
> 1.2 MΩ to 12 MΩ | 10 MΩ
> 12 MΩ to 120 MΩ | 100 MΩ
> 120 MΩ to 1.2 GΩ | 1 GΩ
  • A M3458 range lock specification only applies when a subsequent 3458 FSC specifies an applicable measurement function (see EXAMPLES below).
  • When the NOMINAL field specifies reset "*", all other fields must be blank.

TOLERANCE

This field is not used.

MOD1

This field is not used.

MOD2

This field is not used.

MOD3

This field is not used.

MOD4

This field is not used.

CON

This field is not used.

Examples

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
#
  1.001  M3458  RNGLK 10mV
#
# 100mV range is locked
#
  1.002  3458         100mV          1%                                    2W
#
# 10mV range is locked
#
  2.001  3458         10mV           1%            1kH                     2W
  3.001  3458         1kH            1%            10mV                    2W
#
# Autorange is selected (M3458 FSC not applicable).
#
  4.001  3458         1uA            1%                                    2W
  5.001  3458         100uA          1%            1kH                     2W
  6.001  3458         1kH            1%            100uA                   2W
  7.001  3458         10Z            1%                                    2W
#
  8.001  M3458  RNGLK 1uA
#
# Autorange is selected (M3458 FSC not applicable).
#
  8.002  3458         100mV          1%                                 N  2W
  8.003  3458         10mV           1%            1kH                  N  2W
  8.004  3458         1kH            1%            10mV                    2W
#
# 1uA range is locked
#
  9.001  3458         1uA            1%                                 N  2W
#
# 100uA range is locked
#
  9.002  3458         100uA          1%            1kH                  N  2W
  9.003  3458         1kH            1%            100uA                   2W
#
# Autorange is selected (M3458 FSC not applicable).
#
 10.001  3458         10Z            1%                                 N  2W
#
 10.002  M3458  RNGLK 10Z
#
# Autorange is selected (M3458 FSC not applicable).
#
 10.003  3458         100mV          1%                                 N  2W
 10.004  3458         10mV           1%            1kH                  N  2W
 10.005  3458         1uA            1%                                 N  2W
 10.006  3458         100uA          1%            1kH                  N  2W
#
# 10 Ohm range is locked.
#
 10.007  3458         10Z            1%                                 N  2W
#
# Autorange is selected for all subsequent 3458 FSCs.
#
 10.008  M3458        *


5335

Instrument FSC

Description

The 5335 FSC programs the Hewlett-Packard 5335A Universal Counter to measure frequency, frequency ratio, period, time interval, phase, pulse width, duty factor, rise and fall time,= and DC voltage. Not all 5335A capabilities are supported. To program unsupported functions, use the IEEE FSC.

Parameters

The following table shows the relationship between the supported 5335A measurement functions and the FSC fields listed.

Function | MOD3 | NOMINAL | MOD1
Frequency A | FA | 0 Hz to 200 MHz | 75 mVpp to 50 Vpp
37.5 mVp to 25 Vp
26.5 mVrms to 17.7 Vrms
Frequency C 1 | FC | 150 MHz to 1.3 GHz | 10 mV to 12 V
-27 dBm to +35 dBm
Ratio A/B | FR | 10-9 to 1015 | 75 mVpp to 50 Vpp
37.5 mVp to 25 Vp
26.5 mVrms to 17.7 Vrms
Period A | PA | 10 ns to 107 s | 75 mVpp to 50 Vpp
37.5 mVp to 25 Vp
26.5 mVrms to 17.7 Vrms
Time Interval A-B | TI | 0 ns to 107 s | 75 mVpp to 50 Vpp
37.5 mVp to 25 Vp
26.5 mVrms to 17.7 Vrms
Phase A-B | PR | -180 deg to +360 deg | 0.01 Hz to 160 MHz
Pulse Width A | WA | 5 ns to 107 | 75 mVpp to 50 Vpp
37.5 mVp to 25 Vp
26.5 mVrms to 17.7 Vrms
Duty Cycle A | DA | 1% to 99% | 0 Hz to 100 MHz
Rise/Fall Time A | RF | 20 ns to 10 ms | 500 mVpp to 50 Vpp
250 mVp to 25 Vp
177 mVrms to 17.7 Vrms
DC Voltmeter 2 | -1000 V to 1000 V | blank
  1. Requires Option 030: 1.3 GHz C Channel
  2. Requires Option 020: DC Digital Voltmeter

RANGE

This field specifies the UUT range as described in the RANGE Field topic.

NOMINAL

This field specifies the expected measured value or a reset.

  • Frequency entered as [numeric][prefix]H.
  • Frequency Ratio entered as [numeric][prefix]H/H.
  • Period entered as [numeric][prefix]T.
  • Time Interval entered as [numeric][prefix]T.
  • Phase entered as [numeric][prefix]deg.
  • Pulse Width entered as [numeric][prefix]T.
  • Duty Cycle entered as [numeric][prefix]pct.
  • Rise or Fall Time entered as [numeric][prefix]T.
  • Voltage entered as [numeric][prefix]V.
  • Reset entered as *.

Rules:

  1. If no NOMINAL field value is entered and all other fields are blank, an * is automatically inserted.

TOLERANCE

This field specifies the UUT tolerance as described in the TOLERANCE Field topic.

MOD1

For measurements of frequency, frequency ratio, period, time interval, pulse width and rise/ fall time, this field specifies the expected amplitude. For measurements of phase, duty factor, voltage min/max of AC and voltage peak-to-peak, this field specifies the expected frequency. For measurements of voltage min/max of DC, this field should be blank.

  • Voltage (RMS) entered as: [numeric][prefix]V
  • Voltage (Peak) entered as: [numeric][prefix]Vp
  • Voltage (Peak-to-Peak) entered as: [numeric][prefix]Vpp
  • Voltage (into 50 Ohms, dBm) entered as: [numeric][prefix]D
  • Frequency entered as [numeric][prefix]H.
  • blank

Rules:

  1. For Ratio A/B (FR) measurements, the MOD1 field specifies the expected amplitude on channel A, not channel B.

MOD2

This field is not used.

MOD3

This field specifies the measurement function:

FC | Frequency C
PA | Period A
FR | Ratio A/B
TI | Time Interval A to B
WA | Pulse Width A
RF | Rise or Fall Time A
PR | Phase A Relative to B
DA | Duty Cycle A
blank | DC Voltage

Rules:

  1. The MOD3 field may specify Frequency C (FC) only when the Option 030: 1.3GHz C Channel C is installed.
  2. FA is automatically inserted in the MOD3 field when the Nominal field units are Hertz and no legal MOD3 code is entered.
  3. FR is automatically inserted in the MOD3 field when the Nominal field units are Hertz/Hertz and no legal MOD3 code is entered.
  4. PA is automatically inserted in the MOD3 field when the Nominal field units are seconds and no legal MOD3 code is entered.
  5. PR is automatically inserted in the MOD3 field when the Nominal field units are degrees and no legal MOD3 code is entered.
  6. DA is automatically inserted in the MOD3 field when the Nominal field units are percent and no legal MOD3 code is entered.

MOD4

This field specifies the type of test being performed as described in the MOD4 Field topic.

CON

The Connection field specifies the UUT connection.

blank | 1 MOhm Input Impedance
L | 50 Ohm Input Impedance
2W | 2-Wire

Rules:

MOD3 | CON
blank | 2W
not blank | L or blank
  1. The CON field may specify L for MOD3 = FA, PA, FR, TI, WA, RF, PR, or DA, only when Option 040 “Programmable Input Amplifiers” is not installed.
  2. L is inserted automatically in the CON field when the MOD3 field specifies Frequency C (FC) and no legal CON field code is entered.
  3. 2W is inserted automatically in the CON field when the MOD3 field is blank and no legal CON field code is entered.

Use of Standard Memory Locations and Results Reporting

System memory locations MEM and MEM1 are used. For more information, refer to the Use of Standard Memory Registers topic.

Examples

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
# ----- Reset -----
  1.001  M5335        *
  1.002  5335         *                                                 S
# ----- Frequency A -----
  1.003  M5335  ChA                                150kH
  1.004  5335         10.000kH       1%            1Vpp              FA
# ----- Frequency C -----
  2.001  5335         1GH            0.1%          -1D               FC    L
# ----- Period A -----
  3.001  M5335        *
  3.002  5335         1.000mT        0.003U        5V                PA
# ----- Ratio A/B -----
  4.001  M5335  ChA                                               AC
  4.002  M5335  ChB                                               DC
  4.003  5335         10H/H          1%            1Vpp              FR
# ----- Time Interval A to B -----
  5.001  M5335  COM   20T            0.2V          0.8V           DC ++    X1
  5.002  5335         10.00T         0.02U         1Vpp              TI
# ----- Pulse Width A -----
  6.001  M5335        *
  6.002  5335         300uT          5%            5Vp               WA
# ----- Rise Time A -----
  7.001  5335         100nT          5%            1Vpp              RF
# ----- Phase A relative to B -----
  8.001  M5335        *
  8.002  5335         30deg          1U            10kH              PR    L
# ----- Duty Cycle A -----
  9.001  5335         30.0pct        2%            100H              DA


M5335

Auxiliary Instrument Setup FSC

Description

The M5335 FSC provides the additional program functions for Channel A and Channel B of the Hewlett-Packard 5335A Universal Counter which are not addressed by the 5335 FSC. These functions include Common B via A, gate time, and trigger slope. Input coupling, attenuation, and impedance along with the trigger level and channel A low-pass filter may also be specified if Option 040 “Programmable Input Amplifiers” is installed in the counter.

Parameters

Option 040 not installed

RANGE | NOMINAL | TOL | MOD1 | MOD2 | MOD3 | CON
 | * |  |  |  |  |
 | gate time |  |  |  |  |
ChA | [gate time] |  |  |  | [slope] |
ChA | [gate time] |  |  |  | [slope] |
COM | [gate time] |  |  |  | [slope] |

Option 040 installed

RANGE | NOMINAL | TOL | MOD1 | MOD2 | MOD3 | CON
 | * |  |  |  |  |
 | gate time |  |  |  |  |
ChA | [gate time] | [level] | [LP filter] | [coupling] | [slope] | [attn]
ChA | [gate time] | [level] |  | [coupling] | [slope] | [attn]
COM | [gate time] | [level] | [level] | [coupling] | [slope] | [attn]
Blank entries in the above table are significant and must be blank. [] denotes optional and | denotes “or”. FSC field interdependencies not expressed in this table are listed under “Rules” for the appropriate parameter.

Channel specific parameters are not “sticky”. For example, if a M5335 FSC specifies channel A trigger level and then a subsequent M5335 FSC specifies channel slope and attenuation, the trigger level field will be viewed and blank and auto level will be selected.

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
  1.001  M5335  ChA                  1.0V
  1.002  M5335  ChA                                                  +     X10
  1.003  M5335  ChA                  1.0V                            +     X10

Statements 1.001 and 1.002 should be combined as statement 1.003 to preserve the trigger level specification.

RANGE

This field specifies the Channel.

ChA | Channel A
ChB | Channel B
COM | Common B via A
blank |

Rules:

  1. M5335 FSC parameters, other than gate time are ignored under the following conditions:
    1. The RANGE field specifies Channel B and the 5335 FSC specifies Frequency A, Period A, Pulse Width A, or DC Voltmeter (5335 MOD3 field is FA, PA, WA, or blank respectively).
    2. The RANGE field specifies Common B via A and the 5335 FSC specifies a measurement function other than Time Interval A-B (5335 MOD3 field is not TI).
    3. The 5335 FSC specifies Frequency C (MOD3 field is FC).

NOMINAL

This field specifies one the following:

  • Gate Time entered as: numeric[prefix]T.
  • Allowed values are: 100ns to 1e7s.
  • “*” Reset to defaults
  • blank

Rules:

  1. This field is ignored and GATE MODE MIN is selected when the 5335 MOD3 field is any of the following:
    2. TI | Time Interval A to B
WA | Pulse Width A
RF | Rise or Fall Time A
PR | Phase A Relative to B
  2. This field is ignored when the 5335 MOD3 field is blank.
  3. Gate Time is not channel specific. It may be specified in a separate M5335 statement or in conjunction with a channel A or channel B specification. Either way, the last Gate Time specification prior to a 5335 statement is used.
    4. Gate Time | Gate Mode
100 μs to 20 ms | Fast
20 ms to 30 s | Normal

TOLERANCE

This field specifies one of the following:

  • The Channel A or B Trigger Level entered as numeric[prefix]V.
  • blank Auto Level (default) or not applicable.

Rules:

  1. Allowed values for trigger level are -5V to +5V.
  2. The TOLERANCE field specifies the channel A trigger level when the RANGE field specifies Channel A or Common B via A.
  3. The TOLERANCE field specifies the channel B trigger level when the RANGE field specifies Channel B.
  4. The TOLERANCE field must be blank when the RANGE field is blank or Option 040, “Programmable Input Amplifiers”, is not installed.
  5. Auto Level is specified when the TOLERANCE field is blank and the RANGE field specifies Channel A or Common B via A.

MOD1

This field specifies one of the following:

  • The Channel A Low-Pass Filter entered as: numeric[prefix]H.
  • The Channel B Trigger Level entered as numeric[prefix]V.
  • blank Auto Level (default) or not applicable.

Rules:

  1. Allowed values for trigger level are -5V to +5V.
  2. Allowed value for channel A low-pass filter is 150kHz.
  3. The MOD1 field may specify the channel A low-pass filter only when the RANGE field specifies channel A.
  4. When the MOD1 field specifies the channel A low-pass filter, the value must be 150kHz.
  5. The MOD1 field may specify the channel B trigger level only when the RANGE specifies Common B via A.
  6. The MOD1 field must be blank when the RANGE field is blank or Option 040, “Programmable Input Amplifiers” is not installed.

MOD2

This field specifies the input coupling:

  • AC
  • DC
  • blank Default
5335 MOD3 | Description | Default Coupling
FA | Frequency A | AC
FC | Frequency C | na
PA | Period A | AC
FR | Ratio A/B | AC
WA | Pulse Width A | DC
TI | Time Interval A-B | DC
PR | Phase A-B | AC
DA | Duty Cycle A | DC
RF | Rise Time A | DC
blank | DC Volts | na

Rules:

  1. The MOD2 field must be blank if Option 040 “Programmable Input Amplifiers” is not installed.
  2. Default values are used when one of the following conditions exists:
    1. No M5335 statement has been executed.
    2. The last M5335 statement executed was a M5335 Reset.
    3. The M5335 MOD2 field is blank and the M5335 RANGE field specifies Channel A, Channel B, or Common B via A.
  3. The MOD2 field must be blank when the RANGE field is blank.

MOD3

This field specifies the trigger slope:

+ | Positive, Channel A or B
- | Negative, Channel A or B
++ | Positive Channel A and B
+- | Positive Channel A, Negative Channel B
-+ | Negative Channel A, Positive Channel B
-- | Negative Channel A and B
blank |

Rules:

  1. The MOD3 field must be blank when the RANGE field is blank.
  2. The MOD3 field may specify “+” or “-” only when the RANGE field specifies Channel A (CHA) or Channel B (CHB).
  3. The MOD3 field may specify “++”, “+-”, “-+”, or “--” only when the RANGE field specifies Common B via A (COM).
  4. When the MOD3 field is blank and the RANGE is ChA, ChB, or COM, the trigger level is the last programmed value or the front panel setting.

MOD4

This field is not used.

CON

This field specifies the Attenuation. Legal entries are:

  • X1 (default)
  • X10
  • blank

Rules:

  1. The CON field must be blank when Option 040 “Programmable Input Amplifiers” is not installed.
  2. The CON field must be blank when the RANGE is blank.
  3. When the CON field is blank and the RANGE is ChA, ChB, or COM, the attenuation is the last programmed value or the front panel setting.

Examples

Refer to 5335 FSC.


5350

Instrument FSC

Description

The 5350, 5351, and 5352 FSCs programs the Hewlett-Packard 5350A/B/M, 5351A/B/M, and 5352A/B/M Microwave Frequency Counters, respectively.

The 5350 FSC may also be used to control a 5351A/B/M or 5352A/B/M. This capability allows a 5350 based procedure to be executed without modification when a 5351B or 5352B is configured.

Similarly, a 5351 FSC may be used to control a 5352A/B/M. This capability allows a 5351 based procedure to be executed without modification when a 5352B is configured.

An exception to the above occurs when a 5350 or 5351 statement Input 1 amplitude exceeds +7 dBm. In this case Option 006 "Limiter". is required. Since Option 006 is not available for the 5352A/B/M, a procedure which requires Option 006 will NOT execute with a 5352B configured.

A 5350A or 5350M must be configured as an "HP 5350B" as shown in the drop-down list in the "Add Instrument" configure dialog. Similarly, a 5351A or 5351M must be configured as an "HP 5351B", and a 5352A or 5352M must be configured as an "HP 5352B".

Parameters

The following table shows the relationship between the supported 5350 series measurement functions and the FSC fields listed.

Applying in excess of +7 dBm to units not equipped with Option 006 will cause extensive ($$$) damage!

Input 1 (MOD2 = "I1")

5350A, 5350B & 5350M Frequency (NOMINAL) | Amplitude (MOD1)
500.0 MHz to 12.4 GHz | -32 dBm to +7.0 dBm
500.0 MHz to 20.0 GHz | -27 dBm to +7.0 dBm
Option 006 "Limiter"(M5350 MOD3 = "LM")
500.0 MHz to 6.0 GHz | +3 dBm to +39.0 dBm
6.0 GHz to 12.4 GHz | +3 dBm to +36.0 dBm
12.4 GHz to 18.0 GHz | +4 dBm to +36.0 dBm
18.0 GHz to 20.0 GHz | +4 dBm to +34.8 dBm

5351A, 5351B, & 5351M Frequency (NOMINAL) | Amplitude (MOD1)
500.0 MHz to 12.4 GHz | -32 dBm to +7.0 dBm
500.0 MHz to 20.0 GHz | -27 dBm to +7.0 dBm
500.0 MHz to 26.5 GHz | -16 dBm to +7.0 dBm
Option 006 "Limiter"(M5351 MOD3 = "LM")
500.0 MHz to 6.0 GHz | +3 dBm to +39.0 dBm
6.0 GHz to 12.4 GHz | +3 dBm to +36.0 dBm
12.4 GHz to 18.0 GHz | +4 dBm to +36.0 dBm
18.0 GHz to 20.0 GHz | +4 dBm to +34.8 dBm
20.0 GHz to 26.5 GHz | +5 dBm to +34.8 dBm

5352A, 5352B, & 5352M Frequency (NOMINAL) | Amplitude (MOD1)
500.0 MHz to 46.0 GHz | -25 dBm to +7.0 dBm

Input 2 (MOD2 = "I2")

Frequency (NOMINAL) | Amplitude (MOD1)
10.0 Hz to 80.0 MHz | 25 mVrms to 1 Vrms (1 MOhm)
10.0 MHz to 525.0 MHz | -20 dBm to +10 dBm (50 Ohm)

RANGE

This field specifies the UUT range as described in the RANGE Field topic.

NOMINAL

This field specifies the expected measured value or a reset.

  • Frequency entered as [numeric][prefix]H
  • Reset entered as *.

Rules:

  1. If no NOMINAL field value is entered and all other fields are blank, an * is automatically inserted.

TOLERANCE

This field specifies the UUT tolerance as described in the TOLERANCE Field topic.

MOD1

This field specifies the expected amplitude of the frequency to be measured.

  • Voltage (RMS) entered as: [numeric][prefix]V
  • Voltage (into 50 Ohms, dBm) entered as: [numeric][prefix]D

Rules:

  1. For Input 1 measurements, the MOD1 field must be in dBm.
  2. For Input 2 measurements, the MOD1 field may be in Volts or dBm.

MOD2

This field specifies the input channel:

I1 | Input 1
I2 | Input 2

Rules:

  1. I1 is inserted automatically in MOD3 when the Nominal field is >525 MHz.

MOD3

This field is not used.

MOD4

This field specifies the type of test being performed as described in the MOD4 Field topic.

CON

The Connection field specifies the UUT connection.

L | 50 Ohm Input Impedance
blank | 1 MOhm Input Impedance

Rules:

  1. L is inserted automatically in the CON field when the MOD2 field is I1.
  2. CON may be blank only when the MOD2 field is I2 and the Nominal field is between 10 Hz and 80 MHz.

Use of Standard Memory Locations and Results Reporting

System memory locations MEM and MEM1 are used. For more information, refer to the Use of Standard Memory Registers topic.

Examples

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
# -----  Reset  -----
  1.001  M5350        *
  1.002  5350         *                                                 S
# -----  Frequency Input 1, Automatic Measurement Mode  -----
  1.003  5350         10GH           0.1%          2D             I1       L
# -----  Frequency Input 1, Manual Measurement Mode  -----
  2.001  M5350                                                             MAN
  2.002  5350         10GH           0.1%          2D             I1       L
# -----  Frequency Input 1, 1 MHz resolution  -----
  3.001  M5350        1MH
  3.002  5350         10.000GH       0.1%          2D             I1       L
# -----  Frequency Input 1, FM Rate, Low  -----
  4.001  M5350                                                             LOW
  4.002  5350         10GH           0.1%          2D             I1       L
# -----  Frequency Input 2, 1 MOhm input impedance  -----
  5.001  M5350        *
  5.002  5350         10kH           1%            1V             I2
# -----  Frequency Input 2, High Resolution  -----
  6.001  M5350                                                    HI
  6.002  5350         100.000H       1%            1V             I2


HP60 and HP63

Instrument FSCs

Description

The HP60 and HP63 FSCs program the Hewlett-Packard 6060B and 6063B Electronic Loads, respectively, for constant current, constant voltage, and constant resistance modes of operation.

Functional Capability

FSC | Model | Current | Voltage | Resistance
HP60 | 6060B | 0 A to 60 A | 3 V to 60 V | 0.033 Ω to 10 kΩ
HP63 | 6063B | 0 A to 10 A | 3 V to 240 V | 0.20 Ω to 50 kΩ

Parameters

RANGE

This field specifies the UUT range as described in the RANGE Field topic.

NOMINAL

This field specifies the reading that is expected from the measurement (or reset "*").

  • Voltage entered as: [numeric][prefix]V
  • Current entered as: [numeric][prefix]A
  • * reset

Rules:

  1. The NOMINAL field may specify voltage only when the MOD1 field specifies Constant Current or Constant Resistance mode.
  2. The NOMINAL field may specify current only when the MOD1 field specifies Constant Voltage or Constant Resistance mode.

TOLERANCE

This field specifies the UUT tolerance as described in the TOLERANCE Field topic.

MOD1

This field specifies the operating mode of the device.

  • Constant Current entered as: [numeric][prefix]A
  • Constant Voltage entered as: [numeric][prefix]V
  • Constant Resistance entered as: [numeric][prefix]Z

MOD2

This field is not used.

MOD3

This field is not used.

MOD4

This field specifies the type of test being performed as described in the MOD4 Field topic.

CON

This field specifies the UUT connection and is always 2-wire (2W). 2W is inserted automatically in the CON field when no CON field code is entered.

Use of Standard Memory Locations and Results Reporting

System memory locations MEM and MEM1 are used. For more information, refer to the Use of Standard Memory Registers topic.

Examples

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON

# -----  Reset
  1.001  HP60         *                                                 S

# -----  Voltage verification (UUT in CV mode, 6060B in CC mode)
# no load
  1.002  HP60         3V             0.23U         0A                      2W
  2.001  HP60         30V            0.34U         0A                      2W
  3.001  HP60         58V            0.45U         0A                      2W
# sink current (load regulation)
  4.001  HP60         3V             0.23U         1A                      2W
  5.001  HP60         30V            0.34U         1A                      2W
  6.001  HP60         58V            0.45U         1A                      2W

# -----  Current verification (UUT in CC mode, 6060B in CV mode)
# short
  7.001  HP60         0.2A           0.85U         3V                      2W
  8.001  HP60         1A             1.5U          3V                      2W
  9.001  HP60         1.8A           0.45U         3V                      2W
# regulated shunt
 10.001  HP60         0.2A           0.85U         10V                     2W
 11.001  HP60         1A             1.5U          10V                     2W
 12.001  HP60         1.8A           0.45U         10V                     2W


8560

Instrument FSC

Description

The 8560 FSC supports the Hewlett-Packard 8560A, 8562A, 8563A, 8561B, 8562B, and 8560E-Series Spectrum Analyzers. The parameters associated with the frequency domain may be specified in two different ways, in conjunction with the 8560 FSC:

  1. Center Frequency and Frequency Span
  2. Start and Stop Frequency

In both modes, the amplitude or frequency obtained from a peak search is returned. Optionally, the peak search operation may be disabled, allowing amplitude measurement at a specified frequency (see MOD3 below).

Functional Capability

Function | 8560 NOMINAL | 8560 MOD1
8560A, 8560E
Peak Amplitude | -134 dBm to +30 dBm | 30 Hz to 2.9 GHz
Peak Frequency | 30 Hz to 2.9 GHz | -134 dBm to +30 dBm1
8561A, 8561B, 8561E
Peak Amplitude | -134 dBm to +30 dBm | 30 Hz to 6.5 GHz
Peak Frequency | 30 Hz to 6.5 GHz | -134 dBm to +30 dBm1
8562E
Peak Amplitude | -134 dBm to +30 dBm | 30 Hz to 13.2 GHz
Peak Frequency | 30 Hz to 13.2 GHz | -134 dBm to +30 dBm1
8562A, 8562B, 8563A, 8563E
Peak Amplitude | -134 dBm to +30 dBm | 9 kHz to 26.5 GHz
-134 dBm to +30 dBm | 30 Hz to 26.5 GHz1
Peak Frequency | 9 kHz to 26.5 GHz | -134 dBm to +30 dBm
30 Hz to 26.5 GHz | -134 dBm to +30 dBm1
8564E
Peak Amplitude | -134 dBm to +30 dBm | 9 kHz to 40 GHz
-134 dBm to +30 dBm | 30 Hz to 40 GHz (1)
Peak Frequency | 9 kHz to 40 GHz | -134 dBm to +30 dBm
30 Hz to 40 GHz | -134 dBm to +30 dBm1
8565E
Peak Amplitude | -134 dBm to +30 dBm | 9 kHz to 50 GHz
-134 dBm to +30 dBm | 30 Hz to 50 GHz1
Peak Frequency | 9 kHz to 50 GHz | -134 dBm to +30 dBm
30 Hz to 50 GHz | -134 dBm to +30 dBm1
  1. Requires Option 006

Parameters

RANGE

This field specifies the UUT range as described in the RANGE Field topic.

NOMINAL

This field specifies the expected measured value or a reset.

  • dBm entered as: [numeric][prefix]D
  • Decibels entered as: [numeric][prefix]dB
  • Frequency entered as: [numeric][prefix]H
  • Reset entered as *.

Rules:

  1. When Nominal units are "D" (dBm), MOD1 units must be "H" (hertz).
  2. When Nominal units are "dB" (decibels), MOD1 units must be "H" (hertz).
  3. When Nominal units are "H" (hertz), MOD1 units must be "D" (dBm).
  4. When the Nominal field contains only units, the value is obtained from memory register MEM. In this case the MOD1 field MUST contain a value.
  5. When the Nominal field specifies frequency, the value is used to initially set the center frequency.
  6. When the Nominal field specifies decibels, the MOD2 field must be "MK".

TOLERANCE

This field specifies the UUT tolerance as described in the TOLERANCE Field topic.

MOD1

This field specifies the amplitude or frequency.

Frequency entered as: [numeric][prefix]H

Amplitude entered as: [numeric][prefix]D

blank not applicable

Rules:

  1. When the MOD1 field contains only units, the value is obtained from memory register MEM. In this case the NOMINAL field MUST contain a value.
  2. When the MOD1 field specifies a frequency AND the M8560 FSC DOES NOT specify START, the value is used to initially set the center frequency.
  3. When the MOD1 field specifies a frequency AND the M8560 FSC DOES specify START, the value is used to set the marker frequency at which to take an amplitude measurement.
  4. When the MOD1 field specifies a 0 Hz, the MET/CAL Runtime driver leaves the delta marker at the frequency of the reference marker.
  5. When the MOD1 field specifies a 0 Hz, the MOD2 field must be "MK" and the MOD3 field must be "AF".

MOD2

This field enables the delta markers.

MK Turns on delta markers

Rules:

  1. When the MOD3 field specifies MK, the NOMINAL field units must be decibels ("dB").
  2. An 8560 FSC with MOD2 "MK" does not setup the instrument. A preceding 8560 statement with MOD2 blank must occur to setup the instrument and establish the reference marker.
  3. Use a 8560 reset statement 8560 * to turn off delta markers.

MOD3

This field enables/disables the marker peak search function.

AF Returns amplitude at specified MOD1 frequency

Rules:

  1. When the MOD3 field specifies AF, an associated M8560 FSC MUST specify the start and stop frequencies. SPAN is NOT legal with AF.
  2. When the MOD3 field specifies AF, the NOMINAL field units must be dBm ("D") or decibels ("dB").

MOD4

This field specifies the type of test being performed as described in the MOD4 Field topic.

CON

This field is always blank.

Use of Standard Memory Locations and Results Reporting

System memory locations MEM and MEM1 are used. For more information, refer to the Use of Standard Memory Registers topic.

Examples

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
# ----- Reset -----
  1.001  M8560        *
  1.002  8560         *                                                 S
# ----- Log Scale -----
  1.003  M8560  SCALE 5dB
# ----- RBW -----
  1.004  M8560  RESBW 1kH
# ----- VBW -----
  1.005  M8560  VIDBW 1kH
# ----- Video Averaging -----
  1.006  M8560  VIDAV 10avg
# ----- Span -----
  1.007  M8560  SPAN  1MH
# ----- Sweep Time, Reference Level, 10 MHz External -----
#
#       Note, Ref Level and 10 MHz Ext are not "sticky", so they MUST be
#       specified in the last M8560 statement prior to the 8560 statement.
  1.008  M8560        1T                           0D                   X
# ----- Peak Search: Marker Amplitude & Center Freq specified -----
  1.009  8560         -30.00D        120U          50MH
  2.001  8560         -30.00D        120U          100MH
  3.001  8560         -30.00D        120U          150MH
  4.001  8560         -30.00D        120U          200MH
# ----- Peak Search: Marker Amplitude, Start & Stop specified -----
  5.001  M8560  START 40MH                         60MH
  5.002  8560         -30.00D        120U          50MH
  6.001  M8560  START 90MH                         100MH
  6.002  8560         -30.00D        120U          100MH
  7.001  M8560  START 140MH                        160MH
  7.002  8560         -30.00D        120U          150MH
  8.001  M8560  START 190MH                        210MH
  8.002  8560         -30.00D        120U          200MH
# ----- Marker Amplitude: Start, Stop and Marker Frequency specified -----
  9.001  M8560  START 40MH                         60MH
  9.002  8560         -30.00D        120U          50MH              AF
# ----- Marker Frequency Counter on with 10 kHz resolution -----
 10.001  M8560  MKCTR 10kH
# ----- Delta Markers -----
 10.002  M8560  START 0.9999GH                     1.0001GH
 10.003  M8560                                     19D
 10.004  TARGET       -p
 10.005  8560         19D                          1.0GH             AF N
 10.006  IEEE         CF11.0GHL1+19DMXPEP0RF1[D200]
 10.007  TARGET       -m
 10.008  IEEE         P0[D200]
 10.009  8560         1.0GH                        19D                  N
 10.010  IEEE         XP
 10.011  8560         -80.0dB        -0.0U +100.0U 1.0GH          MK AF


M8560

M8560

Instrument Setup FSC

Description

The M8560 FSC is used to specify the RF attenuation, marker frequency counter, RBW, log scale, frequency span, start and stop frequency, video averaging, VBW, sweep time, and external reference oscillator for the Hewlett-Packard 8560A, 8562A, 8563A, 8561B, 8562B, and 8560 E-Series Spectrum Analyzers.

RANGE

This field identifies the value in the Nominal field.

Rules:

Range | Nominal | MOD1
ATTEN | RF Attenuation | [Reference Level]
MKCTR | Frequency Resolution | [Reference Level]
RESBW | RBW | [Reference Level]
SCALE | Log Scale | [Reference Level]
SPAN | Frequency Span | [Reference Level]
START | Start Frequency | Stop Frequency
VIDAV | Video Averaging | [Reference Level]
VIDBW | VBW | [Reference Level]
blank | Sweep Time | [Reference Level]
blank | Reset "*" | blank

NOMINAL

This field specifies one of the following:

  • RF Attenuation entered as: [numeric][prefix]dB
  • Marker Frequency Counter resolution as: [numeric][prefix]Hz
  • RBW entered as: [numeric][prefix]H
  • Log Scale as: [numeric][prefix]dB
  • Frequency Span entered as: [numeric][prefix]H
  • Start Frequency entered as: [numeric][prefix]H
  • Video Average Count entered as: [numeric][prefix]avg
  • VBW entered as: [numeric][prefix]H
  • Sweep Time entered as: [numeric][prefix]T
  • "*" Reset

Rules:

  • See above table under Range field.
  • Legal values for RF attenuation are:

0, 10, 20, 30, 40, 50, 60, and 70 dB

  • Legal values for marker frequency counter resolution are:

1, 10, 100 Hz,

1, 10, 100 kHz,

1 MHz

  • Legal values for RBW are:

10, 30, 100, and 300 Hz, 1, 3, 10, 30, 100, and 300 kHz, 1 and 3 MHz

  • Legal values for log scale are: 1, 2, 5, and 10 dB
  • Legal values for frequency span are: 0 Hz (Fixed Tuned Receiver mode) and 30 Hz to 50 GHz (1).
  • Legal values for start frequency are: 30 Hz to 50 GHz (1).
  • Legal values for video average count are: 1 to 999
  • Legal values for VBW are: 1, 3, 10, 30, 100, and 300 Hz, 1, 3, 10, 30, 100, and 300 kHz, 1 and 3 MHz
  • Legal values for sweep time are: 50 ms to 100 ks
  • When the NOMINAL field does not specify a value, the value is taken from memory register MEM.
  • Consecutive M8560 FSCs may be used to specify a combination of these parameters for a single 8560 measurement.
  • Parameter values stay in effect until a M8560 reset is executed or a new value for the parameter is specified.
  • When the NOMINAL field specifies a reset the following default values are selected:
Frequency Span: | Maximum
Log Scale | 10 dB
Marker Freq. Counter: | Off
Reference Level: | 0 dBm
RBW: | Coupled
RF Attenuation: | Coupled
Start Frequency: | na
Stop Frequency: | na
Sweep Time: | Coupled
Video Averaging: | Off
VBW: | Coupled
1. Actual limit is based on model used.

TOLERANCE

This field is not used.

MOD1

This field specifies the reference level or the stop frequency.

  • Reference Level entered as [numeric][prefix]D.
  • Stop Frequency entered as [numeric][prefix]H.

Rules:

  • Note, reference level is not "sticky". When the MOD1 field is blank the reference level is "unset".
  • Legal values for reference level are -120 dBm to 30 dBm.
  • Legal values for stop frequency are 30 Hz to 50 GHz (1).
  • The stop frequency must be greater than or equal to the start frequency.
  • When the MOD1 field does not specify a value, the value is taken from memory register MEM.

1. Actual limit is based model used.

MOD2

This field is not used.

MOD3

This field is not used.

MOD4

This field specifies that an external reference oscillator is to be used:

• | X | External Reference Oscillator
• | blank |

Rules:

  • An M8560 reset statement, NOMINAL field is an "*", must be used to re-select the internal reference once the external reference is selected.

CON

This field is not used.

Examples

Refer to 8560 FSC.


8566

Instrument FSC

Description

The 8566 FSC supports the Hewlett-Packard 8566B Spectrum Analyzer. The parameters associated with the frequency domain may be specified in two different ways, in conjunction with the M8566 FSC:

  1. Center Frequency and Frequency Span
  2. Start and Stop Frequency

In both modes, the amplitude or frequency obtained from a peak search is returned. Optionally, the peak search operation may be disabled, allowing amplitude measurement at a specified frequency (see MOD3 below). The 8566 FSC does not support the 8566A because the 8566A does not support SRQ on completion of peak search. Peak search is the primary function supported in the MET/CAL spectrum analyzer FSCs.

Functional Capability

Function | NOMINAL | MOD1
Peak Amplitude | -134 dBm to +30 dBm | 100 Hz to 1.0 MHz
 | -134 dBm to +30 dBm | 1.0 MHz to 2.5 GHz
 | -132 dBm to +30 dBm | 2.0 GHz to 5.8 GHz
 | -125 dBm to +30 dBm | 5.8 GHz to 12.5 GHz
 | -119 dBm to +30 dBm | 12.5 GHz to 18.6 GHz
 | -114 dBm to +30 dBm | 18.6 GHz to 22.0 GHz
Peak Frequency | 100 Hz to 1.0 MHz | -134 dBm to +30 dBm
 | 1.0 MHz to 2.5 GHz | -134 dBm to +30 dBm
 | 2.0 GHz to 5.8 GHz | -132 dBm to +30 dBm
 | 5.8 GHz to 12.5 GHz | -125 dBm to +30 dBm
 | 12.5 GHz to 18.6 GHz | -119 dBm to +30 dBm
 | 18.6 GHz to 22.0 GHz | -114 dBm to +30 dBm

Parameters

RANGE

This field specifies the UUT range as described in the RANGE Field topic.

NOMINAL

This field specifies the expected measured value or a reset.

  • dBm entered as: [numeric][prefix]D
  • Decibels entered as: [numeric][prefix]dB
  • Frequency entered as: [numeric][prefix]H
  • Reset entered as *.

Rules:

  1. When Nominal units are "D" (dBm), MOD1 units must be "H" (hertz).
  2. When Nominal units are "dB" (decibels), MOD1 units must be "H" (hertz).
  3. When Nominal units are "H" (hertz), MOD1 units must be "D" (dBm).
  4. When the NOMINAL field contains only units, the value is obtained from memory register MEM. In this case the MOD1 field MUST contain a value.
  5. In addition to specifying the expected measured value, when the NOMINAL field specifies amplitude, the value is used to set the reference level.
  6. Likewise, when the NOMINAL field specifies frequency, the value is used to initially set the center frequency.
  7. When the NOMINAL field specifies decibels, the MOD2 field must be "MK".

TOLERANCE

This field specifies the UUT tolerance as described in the TOLERANCE Field topic.

MOD1

This field specifies the amplitude or frequency.

Frequency entered as [numeric][prefix]H.

Amplitude entered as [numeric][prefix]D.

blank not applicable

Rules:

  1. When the MOD1 field contains only units, the value is obtained from memory register MEM. In this case the NOMINAL field MUST contain a value.
  2. When the MOD1 field specifies a frequency AND the M8566 FSC DOES NOT specify START, the value is used to initially set the center frequency.
  3. When the MOD1 field specifies a frequency AND the M8566 FSC DOES specify START, the value is used to set the marker frequency at which to take an amplitude measurement.
  4. When the MOD1 field specifies amplitude, the value is used to set the reference level.
  5. When the MOD1 field specifies a 0 Hz, the MET/CAL Runtime driver leaves the delta marker at the frequency of the reference marker.
  6. When the MOD1 field specifies a 0 Hz, the MOD2 field must be "MK" and the MOD3 field must be "AF".

MOD2

This field enables the delta markers.

MK | Turns on delta markers
blank | No change

Rules:

  1. When the MOD3 field specifies MK, the NOMINAL field units must be decibels ("dB").
  2. An 8566 FSC with MOD2 "MK" does not setup the instrument. A preceding 8566 statement with MOD2 blank must occur to setup the instrument and establish the reference marker.
  3. Use a 8566 reset statement 8566 * to turn off delta markers.

MOD3

This field enables/disables the marker peak search function.

AF | Returns amplitude at specified MOD1 frequency
blank | Peak search enabled

Rules:

  1. When the MOD3 field specifies AF, an associated M8566 FSC MUST specify the start and stop frequencies. SPAN is NOT legal with AF.
  2. When the MOD3 field specifies AF, the NOMINAL field units must be dBm ("D").

MOD4

This field specifies the type of test being performed as described in the MOD4 Field topic.

CON

This field is always blank.

Use of Standard Memory Locations and Results Reporting

System memory locations MEM and MEM1 are used. For more information, refer to the Use of Standard Memory Registers topic.

Examples

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
# -----  Reset  -----
  1.001  M8566        *
  1.002  8566         *                                                 S
# -----  Log Scale  -----
  1.003  M8566  SCALE 5dB
# -----  RBW  -----
  1.004  M8566  RESBW 1kH
# -----  VBW  -----
  1.005  M8566  VIDBW 1kH
# -----  Video Averaging  -----
  1.006  M8566  VIDAV 10avg
# -----  Span  -----
  1.007  M8566  SPAN  1MH
# -----  Peak Search: Marker Amplitude & Center Freq specified  -----
  1.008  8566         -30.00D        120U          50MH
  2.001  8566         -30.00D        120U          100MH
  3.001  8566         -30.00D        120U          150MH
  4.001  8566         -30.00D        120U          200MH
# -----  Peak Search: Marker Amplitude, Start & Stop specified  -----
  5.001  M8566  START 40MH                         60MH
  5.002  8566         -30.00D        120U          50MH
  6.001  M8566  START 90MH                         100MH
  6.002  8566         -30.00D        120U          100MH
  7.001  M8566  START 140MH                        160MH
  7.002  8566         -30.00D        120U          150MH
  8.001  M8566  START 190MH                        210MH
  8.002  8566         -30.00D        120U          200MH
# -----  Marker Amplitude: Start, Stop and Marker Frequency specified  -----
  9.001  M8566  START 40MH                         60MH
  9.002  8566         -30.00D        120U          50MH              AF
# -----  Delta Markers  -----
 10.001  M8566  START 0.9999GH                     1.0001GH
 10.002  M8566                                     19D
 10.003  TARGET       -p
 10.004  8566         19D                          1.0GH             AF N
 10.005  IEEE         CF11.0GHL1+19DMXPEP0RF1[D200]
 10.006  TARGET       -m
 10.007  IEEE         P0[D200]
 10.008  8566         1.0GH                        19D                  N
 10.009  IEEE         XP
 10.010  8566         -80.0dB        -0.0U +100.0U 1.0GH          MK AF


M8566

Instrument Setup FSC

Description

The M8566 FSC is used to specify the RF attenuation, RBW, log scale, frequency span, start and stop frequency, video averaging, VBW and sweep time.

RANGE

This field identifies the value in the Nominal field.

Rules:

Range | Nominal | MOD1
ATTEN | RF Attenuation | [Reference Level]
RESBW | RBW | [Reference Level]
SCALE | Log Scale | [Reference Level]
SPAN | Frequency Span | [Reference Level]
START | Start Frequency | Stop Frequency
VIDAV | Video Averaging | [Reference Level]
VIDBW | VBW | [Reference Level]
blank | Sweep Time | [Reference Level]
blank | Reset "*" | blank

NOMINAL

This field specifies one of the following:

  • Frequency Span entered as: [numeric][prefix]H
  • RF Attenuation entered as: [numeric][prefix]dB
  • RBW entered as: [numeric][prefix]H
  • Log Scale as: [numeric][prefix]dB
  • Start Frequency entered as: [numeric][prefix]H
  • Video Average Count entered as: [numeric][prefix]avg
  • Sweep Time entered as: [numeric][prefix]T
  • VBW entered as: [numeric][prefix]H
  • "*" Reset

Rules:

  1. See above table under Range field.
  2. Legal values for RF attenuation are: 0, 10, 20, 30, 40, 50, 60, and 70 dB.
  3. Legal values for frequency span are: 0 Hz (Fixed Tuned Receiver mode) and 100 Hz to 22 GHz
  4. Legal values for RBW are: 10 Hz, 30 Hz, 100 Hz, 300 Hz, 1 kHz, 3 kHz, 10 kHz, 30 kHz, 100 kHz, 300 kHz, 1 MHz, and 3 MHz.
  5. Legal values for log scale are: 1, 2, 5, and 10 dB
  6. Legal values for start frequency are: 100 Hz to 22 GHz
  7. Legal values for sweep time are: 50 ms to 1.5 ks
  8. Legal values for VBW are: 1, 3, 10, 30, 100, and 300 Hz, 1, 3, 10, 30, 100, and 300 kHz, 1 and 3 MHz
  9. When the NOMINAL field does not specify a value, the value is taken from memory register MEM.
  10. Consecutive M8566 FSCs may be used to specify a combination of these parameters for a single 8566B measurement.
  11. Parameter values stay in effect until a M8566 reset is executed or a new value for the parameter is specified.

  12. When the NOMINAL field specifies a reset the following default values are selected:

    Frequency Span: 2.9 GHz
    Log Scale 10 dB
    Reference Level: 0.0 dBm
    RBW: Coupled
    RF Attenuation: Coupled
    Sweep Time: Coupled
    Start Frequency: na
    Stop Frequency: na
    Video Averaging: Off
    VBW: Coupled

TOLERANCE

This field is not used.

MOD1

This field specifies the reference level or the stop frequency.

  • Reference Level entered as [numeric][prefix]D.
  • Stop Frequency entered as [numeric][prefix]H.

Rules:

  1. Note, reference level is not "sticky". When the MOD1 field is blank the reference level is "unset".
  2. Legal values for reference level are -89.9 dBm to +30.0 dBm.
  3. Legal values for stop frequency are 100 Hz to 22 GHz.
  4. The stop frequency must be greater than or equal to the start frequency.
  5. When the MOD1 field does not specify a value, the value is taken from memory register MEM.

MOD2

This field is not used.

MOD3

This field is not used.

MOD4

This field is not used.

CON

This field is not used.

Examples

Refer to 8566 FSC.


8568

Instrument FSC

Description

The 8568 FSC supports the Hewlett-Packard 8568B Spectrum Analyzer. The parameters associated with the frequency domain may be specified in two different ways, in conjunction with the M8568 FSC:

  1. Center Frequency and Frequency Span
  2. Start and Stop Frequency

In both modes, the amplitude or frequency obtained from a peak search is returned. Optionally, the peak search operation may be disabled, allowing amplitude measurement at a specified frequency (see MOD3 below). The 8568 FSC does not support the 8568A because the 8568A does not support SRQ on completion of peak search. Peak search is the primary function supported in the MET/CAL spectrum analyzer FSCs.

Functional Capability

Function | NOMINAL | MOD1
Peak Amplitude | -135 dBm to 30 dBm | 100 Hz to 1.5 GHz
Peak Frequency | 100 Hz to 1.5 GHz | -135 dBm to 30 dBm

Parameters

RANGE

This field specifies the UUT range as described in the RANGE Field topic.

NOMINAL

This field specifies the expected measured value or a reset.

  • Amplitude entered as [numeric][prefix]D.
  • Frequency entered as [numeric][prefix]H.
  • Reset entered as *.

Rules:

  1. When Nominal units are "D" (dBm), MOD1 units must be "H" (hertz).
  2. When Nominal units are "H" (hertz), MOD1 units must be "D" (dBm).
  3. When the Nominal field contains only units, the value is obtained from memory register MEM. In this case the MOD1 field MUST contain a value.
  4. In addition to specifying the expected measured value, when the Nominal field specifies amplitude, the value is used to set the reference level.
  5. Likewise, when the Nominal field specifies frequency, the value is used to initially set the center frequency.

TOLERANCE

This field specifies the UUT tolerance as described in the TOLERANCE Field topic.

MOD1

This field specifies the amplitude or frequency.

  • Frequency entered as [numeric][prefix]H.
  • Amplitude entered as [numeric][prefix]D.
  • blank not applicable

Rules:

  1. When the MOD1 field contains only units, the value is obtained from memory register MEM. In this case the Nominal field MUST contain a value.
  2. When the MOD1 field specifies a frequency AND the M8568 FSC DOES NOT specify START, the value is used to initially set the center frequency.
  3. When the MOD1 field specifies a frequency AND the M8568 FSC DOES specify START, the value is used to set the marker frequency at which to take an amplitude measurement.
  4. When the MOD1 field specifies amplitude, the value is used to set the reference level.

MOD2

This field specifies the input to be used.

I1 | Input 1
I2 | Input 2

Rules:

  • When no valid MOD1 code is entered, I2 is automatically inserted in the MOD2 field.

MOD3

This field enables/disables the marker peak search function.

AF | Returns amplitude at specified MOD1 frequency
blank | Peak search enabled

Rules:

  1. When the MOD3 field specifies AF, an associated M8590 FSC MUST specify the start and stop frequencies. SPAN is NOT legal with AF.
  2. When the MOD3 field specifies AF, the Nominal field units must be dBm ("D").

MOD4

This field specifies the type of test being performed as described in the MOD4 Field topic.

CON

This field is always blank.

Use of Standard Memory Locations and Results Reporting

System memory locations MEM and MEM1 are used. For more information, refer to the Use of Standard Memory Registers topic.

Examples

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
# ----- Reset -----
  1.001  M8568        *
  1.002  8568         *                                                 S
# ----- Log Scale -----
  1.003  M8568  SCALE 5dB
# ----- RBW -----
  1.004  M8568  RESBW 1kH
# ----- VBW -----
  1.005  M8568  VIDBW 1kH
# ----- Video Averaging -----
  1.006  M8568  VIDAV 10avg
# ----- Span -----
  1.007  M8568  SPAN  1MH
# ----- Peak Search: Marker Amplitude & Center Freq specified -----
  1.008  8568         -30.00D        120U          50MH           I2
  2.001  8568         -30.00D        120U          100MH          I2
  3.001  8568         -30.00D        120U          150MH          I2
  4.001  8568         -30.00D        120U          200MH          I2
# ----- Peak Search: Marker Amplitude, Start & Stop specified -----
  5.001  M8568  START 40MH                         60MH
  5.002  8568         -30.00D        120U          50MH           I2
  6.001  M8568  START 90MH                         100MH
  6.002  8568         -30.00D        120U          100MH          I2
  7.001  M8568  START 140MH                        160MH
  7.002  8568         -30.00D        120U          150MH          I2
  8.001  M8568  START 190MH                        210MH
  8.002  8568         -30.00D        120U          200MH          I2
# ----- Marker Amplitude: Start, Stop and Marker Frequency specified -----
  9.001  M8568  START 40MH                         60MH
  9.002  8568         -30.00D        120U          50MH           I2 AF
# ----- Delta Markers -----
 10.001  M8568  START 0.9999GH                     1.0001GH
 10.002  M8568                                     19D
 10.003  TARGET       -p
 10.004  8568         19D                          1.0GH          I2 AF N
 10.005  IEEE         CF11.0GHL1+19DMXPEP0RF1[D200]
 10.006  TARGET       -m
 10.007  IEEE         P0[D200]
 10.008  8568         1.0GH                        19D            I2    N


M8568

M8568

Instrument Setup FSC

Description

The M8568 FSC is used to specify the RF attenuation, RBW, log scale, frequency span, start and stop frequency, video averaging, VBW, and sweep time.

RANGE

This field identifies the value in the Nominal field.

Rules:

Range | Nominal | MOD1
ATTEN | RF Attenuation | [Reference Level]
RESBW | RBW | [Reference Level]
SCALE | Log Scale | [Reference Level]
SPAN | Frequency Span | [Reference Level]
START | Start Frequency | Stop Frequency
VIDAV | Video Averaging | [Reference Level]
VIDBW | VBW | [Reference Level]
blank | Sweep Time | [Reference Level]
blank | Reset "*" | blank

NOMINAL

This field specifies one of the following:

  • RF Attenuation entered as: [numeric][prefix]dB
  • RBW entered as: [numeric][prefix]H
  • Log Scale as: [numeric][prefix]dB
  • Frequency Span entered as: [numeric][prefix]H
  • Start Frequency entered as: [numeric][prefix]H
  • Video Average Count entered as: [numeric][prefix]avg
  • VBW entered as: [numeric][prefix]H
  • Sweep Time entered as: [numeric][prefix]T
  • "*" Reset

Rules:

  • See above table under Range field.
  • Legal values for frequency span are: 0 Hz (Fixed Tuned Receiver mode) and 100 Hz to 1.5 GHz
  • Legal values for RF attenuation are: 0, 10, 20, 30, 40, 50, 60, and 70 dB
  • Legal values for RBW are: 10, 30, 100, and 300 Hz, 1, 3, 10, 30, 100, and 300 kHz, 1 and 3 MHz
  • Legal values for log scale are: 1, 2, 5, and 10 dB
  • Legal values for start frequency are: 100 Hz to 1.5 GHz
  • Legal values for video average count are: 1 to 999
  • Legal values for sweep time are: 20 ms to 1.5 ks
  • Legal values for VBW are: 1, 3, 10, 30, 100, and 300 Hz, 1, 3, 10, 30, 100, and 300 kHz, 1 and 3 MHz
  • When the NOMINAL field does not specify a value, the value is taken from memory register MEM.
  • Consecutive M8568 FSCs may be used to specify a combination of these parameters for a single 8568B measurement.
  • Parameter values stay in effect until in effect until a M8568 reset is executed or a new value for the parameter is specified.
  • When the NOMINAL field specifies a reset the following default values are selected:
Frequency Span: | 1.5 GHz
Log Scale | 10 dB
Reference Level: | 0.0 dBm
RBW: | Coupled
RF Attenuation: | Coupled
Start Frequency: | na
Stop Frequency: | na
Sweep Time: | Coupled
Video Averaging: | Off
VBW: | Coupled
1. 0 Hz selects "Fixed Tunsed Receiver" mode.

TOLERANCE

This field is not used.

MOD1

This field specifies the reference level or the stop frequency.

  • Reference Level entered as [numeric][prefix]D.
  • Stop Frequency entered as [numeric][prefix]H.

Rules:

  • Note, reference level is not "sticky". When the MOD1 field is blank the reference level is "unset".
  • Legal values for reference level are -89.9 dBm to +30.0 dBm.
  • Legal values for stop frequency are 100 Hz to 1.5 GHz.
  • The stop frequency must be greater than or equal to the start frequency.
  • When the MOD1 field does not specify a value, the value is taken from memory register MEM.

MOD2

This field is not used.

MOD3

This field is not used.

MOD4

This field is not used.

CON

This field is not used.

Examples

Refer to 8568 FSC.


8590

Instrument FSC

Description

The 8590 FSC supports the Hewlett-Packard 8590(), 8591(), 8592 L, 8593(), 8594(), 8595(), and 8596() Spectrum Analyzers. The parameters associated with the frequency domain may be specified in two different ways, in conjunction with the M8590 FSC:

  1. Center Frequency and Frequency Span
  2. Start and Stop Frequency

In both modes, the amplitude or frequency obtained from a peak search is returned. Optionally, the peak search operation may be disabled, allowing amplitude measurement at a specified frequency (see MOD3 below).

Functional Capability

Function | 8590 NOMINAL | 8590 MOD1
8590L, 8591E
Peak Amplitude | -134 dBm to +30 dBm | 9 kHz to 1.8 GHz
Peak Frequency | 9 kHz to 1.8 GHz | -134 dBm to +30 dBm
8592L, 8593E
Peak Amplitude | -134 dBm to +30 dBm | 9 kHz to 22.0 GHz
-134 dBm to +30 dBm | 9 kHz to 26.5 GHz1
Peak Frequency | 9 kHz to 22.0 GHz | -134 dBm to +30 dBm
9 kHz to 26.5 GHz | -134 dBm to +30 dBm1
8594E
Peak Amplitude | -134 dBm to +30 dBm | 9 kHz to 2.9 GHz
Peak Frequency | 9 kHz to 2.9 GHz | -134 dBm to +30 dBm
8595E
Peak Amplitude | -134 dBm to +30 dBm | 9 kHz to 6.5 GHz
Peak Frequency | 9 kHz to 6.5 GHz | -134 dBm to +30 dBm
8596E
Peak Amplitude | -134 dBm to +30 dBm | 9 kHz to 6.5 GHz
Peak Frequency | 9 kHz to 6.5 GHz | -134 dBm to +30 dBm
  1. Requires Option 026/027

Parameters

RANGE

This field specifies the UUT range as described in the RANGE Field topic.

NOMINAL

This field specifies the expected measured value or a reset.

  • dBm entered as: [numeric][prefix]D
  • Decibels entered as: [numeric][prefix]dB
  • Frequency entered as: [numeric][prefix]H
  • Reset entered as *.

Rules:

  1. When Nominal units are "D" (dBm), MOD1 units must be "H" (hertz).
  2. When Nominal units are "H" (hertz), MOD1 units must be "D" (dBm).
  3. When the Nominal field contains only units, the value is obtained from memory register MEM. In this case the MOD1 field MUST contain a value.
  4. In addition to specifying the expected measured value, when the Nominal field specifies amplitude, the value is used to set the reference level.
  5. Likewise, when the Nominal field specifies frequency, the value is used to initially set the center frequency.
  6. When the Nominal field specifies decibels, the MOD2 field must be "MK".

TOLERANCE

This field specifies the UUT tolerance as described in the TOLERANCE Field topic.

MOD1

This field specifies the amplitude or frequency.

  • Frequency entered as: [numeric][prefix]H
  • Amplitude entered as: [numeric][prefix]D
  • blank not applicable

Rules:

  1. When the MOD1 field contains only units, the value is obtained from memory register MEM. In this case the Nominal field MUST contain a value.
  2. When the MOD1 field specifies a frequency AND the M8590 FSC DOES NOT specify START, the value is used to initially set the center frequency.
  3. When the MOD1 field specifies a frequency AND the M8590 FSC DOES specify START, the value is used to set the marker frequency at which to take an amplitude measurement.
  4. When the MOD1 field specifies amplitude, the value is used to set the reference level.
  5. When the MOD1 field specifies a 0 Hz, the MET/CAL Runtime driver leaves the delta marker at the frequency of the reference marker.
  6. When the MOD1 field specifies a 0 Hz, the MOD2 field must be "MK" and the MOD3 field must be "AF".

MOD2

This field enables the delta markers.

MK | Turns on delta markers
blank | No change

Rules:

  1. When the MOD3 field specifies MK, the Nominal field units must be decibels ("dB").
  2. An 8590 FSC with MOD2 "MK" does not setup the instrument. A preceeding 8590 statement with MOD2 blank must occur to setup the instrument and establish the reference marker.
  3. Use a 8590 reset statement "8590 *" to turn off delta markers.

MOD3

This field enables/disables the marker peak search function.

AF | Returns amplitude at specified MOD1 frequency
blank | Peak search enabled

Rules:

  1. When the MOD3 field specifies AF, an associated M8590 FSC MUST specify the start and stop frequencies. SPAN is NOT legal with AF.
  2. When the MOD3 field specifies AF, the Nominal field units must be dBm ("D").

MOD4

This field specifies the type of test being performed as described in the MOD4 Field topic.

CON

This field is always blank.

Use of Standard Memory Locations and Results Reporting

System memory locations MEM and MEM1 are used. For more information, refer to the Use of Standard Memory Registers topic.

Examples

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
# ----- Reset -----
  1.001  M8590        *
  1.002  8590         *                                                 S
# ----- Log Scale -----
  1.003  M8590  SCALE 5dB
# ----- RBW -----
  1.004  M8590  RESBW 1kH
# ----- VBW -----
  1.005  M8590  VIDBW 1kH
# ----- Video Averaging -----
  1.006  M8590  VIDAV 10avg
# ----- Span -----
  1.007  M8590  SPAN  1MH
# ----- Peak Search: Marker Amplitude & Center Freq specified -----
  1.008  8590         -30.00D        120U          50MH
  2.001  8590         -30.00D        120U          100MH
  3.001  8590         -30.00D        120U          150MH
  4.001  8590         -30.00D        120U          200MH
# ----- Peak Search: Marker Amplitude, Start & Stop specified -----
  5.001  M8590  START 40MH                         60MH
  5.002  8590         -30.00D        120U          50MH
  6.001  M8590  START 90MH                         100MH
  6.002  8590         -30.00D        120U          100MH
  7.001  M8590  START 140MH                        160MH
  7.002  8590         -30.00D        120U          150MH
  8.001  M8590  START 190MH                        210MH
  8.002  8590         -30.00D        120U          200MH
# ----- Marker Amplitude: Start, Stop and Marker Frequency specified -----
  9.001  M8590  START 40MH                         60MH
  9.002  8590         -30.00D        120U          50MH              AF
# ----- Marker Frequency Counter on with 10 kHz resolution -----
 10.001  M8590  MKCTR 10kH
# ----- Delta Markers -----
 10.002  M8590  START 0.9999GH                     1.0001GH
 10.003  M8590                                     19D
 10.004  TARGET       -p
 10.005  8590         19D                          1.0GH             AF N
 10.006  IEEE         CF11.0GHL1+19DMXPEP0RF1[D200]
 10.007  TARGET       -m
 10.008  IEEE         P0[D200]
 10.009  8590         1.0GH                        19D                  N
 10.010  IEEE         XP
 10.011  8590         -80.0dB        -0.0U +100.0U 1.0GH          MK AF


M8590

Auxiliary Instrument Setup FSC

Description

The M8590 FSC is used to specify the RF attenuation, marker frequency counter, RBW, log scale, frequency span, start and stop frequency, video averaging, VBW, sweep time, and external reference oscillator.

Range

This field identifies the value in the Nominal field.

Rules:

Range | Nominal | MOD1
ATTEN | RF Attenuation | [Reference Level]
MKCTR | Frequency Resolution | [Reference Level]
RESBW | RBW | [Reference Level]
SCALE | Log Scale | [Reference Level]
SPAN | Frequency Span | [Reference Level]
START | Start Frequency | Stop Frequency
VIDAV | Video Averaging | [Reference Level]
VIDBW | VBW | [Reference Level]
blank | Sweep Time | [Reference Level]
blank | Reset "*" | blank

Nominal

This field specifies one of the following:

  • RF Attenuation entered as: [numeric][prefix]dB
  • Marker Frequency Counter resolution as: [numeric][prefix]Hz
  • RBW entered as: [numeric][prefix]H
  • Log Scale as: [numeric][prefix]dB
  • Frequency Span entered as: [numeric][prefix]H
  • Start Frequency entered as: [numeric][prefix]H
  • Video Average Count entered as: [numeric][prefix]avg
  • VBW entered as: [numeric][prefix]H
  • Sweep Time entered as: [numeric][prefix]T
  • "*" Reset

Rules:

  1. See above table under Range field.
  2. Legal values for RF attenuation are: 0, 10, 20, 30, 40, 50, 60, and 70 dB
  3. Legal values for marker frequency counter resolution are: 1, 10, 100 Hz, 1, 10, 100 kHz
  4. Legal values for RBW are: 1, 3, 10, 30, 100, and 300 kHz, 1 and 3 MHz
  5. Legal values for frequency span are: 0 Hz (Fixed Tuned Receiver mode) and 30 Hz to 26.5 GHz1
  6. Legal values for start frequency are: 9 kHz to 26.5 GHz1
  7. Legal values for sweep time are: 20 ms to 100 s
  8. Legal values for video average count are: 1 to 16384
  9. Legal values for VBW are: 30, 100, and 300 Hz, 1, 3, 10, 30, 100, and 300 kHz, 1 MHz
  10. When the NOMINAL field does not specify a value, the value is taken from memory register MEM.
  11. Consecutive M8590 FSCs may be used to specify a combination of these parameters for a single 8590 measurement.
  12. Parameter values stay in effect until a M8590 reset is executed or a new value for the parameter is specified.
  13. When the NOMINAL field specifies a reset the following default values are selected:
Frequency Span | Maximum
Log Scale | 10 dB
Marker Freq. Counter | Off
Reference Level: 0 dBm
RBW: Coupled
RF Attenuation: Coupled
Start Frequency: na
Stop Frequency: na
Sweep Time: Coupled
Video Averaging: Off
VBW: Coupled
  1. Upper bound depends upon actual spectrum analyzer used (see 8590 FSC).

TOLERANCE

This field is not used.

MOD1

This field specifies the reference level or the stop frequency.

  • Reference Level entered as [numeric][prefix]D.
  • Stop Frequency entered as [numeric][prefix]H.

Rules:

  1. Note, reference level is not "sticky". When the MOD1 field is blank the reference level is "unset".
  2. Legal values for reference level are -134 dBm to 30 dBm.
  3. Legal values for stop frequency are 9 kHz to 26.5 GHz (upper bound depends upon actual spectrum analyzer used, see 8590 FSC)
  4. The stop frequency must be greater than or equal to the start frequency.
  5. When the MOD1 field does not specify a value, the value is taken from memory register MEM.

MOD2

This field is not used.

MOD3

This field is not used.

MOD4

This field is not used.

CON

This field is not used.

Examples

Refer to 8590 FSC.


8648

8648

8648 Instrument FSC

Description

The 8648 FSC programs amplitude and frequency of the Hewlett-Packard 8648 A/B/C/D Signal Generators.

Functional Capability

Model | Frequency | Std | Amplitude 1
Opt 1EA | Opt 1EA & 1E6
8648A | 100 kHz to 1000 MHz | +10 dBm | NA | NA
8648B | 9 kHz to <100 kHz | +13 dBm | +17 dBm | +13 dBm
≥100 kHz to <100 MHz | +13 dBm | +20 dBm | +13 dBm
≥100 MHz to ≤1000 MHz | +13 dBm | +20 dBm | +18 dBm
>1000 MHz to ≤1500 MHz | +13 dBm | +19 dBm | +17 dBm
>1500 MHz to 2000 MHz | +13 dBm | +17 dBm | +15 dBm
8648C | 9 kHz to < 100 kHz | +13 dBm | +17 dBm | +13 dBm
≥100 kHz to < 100 MHz | +13 dBm | +20 dBm | +13 dBm
≥100 MHz to ≤1000 MHz | +13 dBm | +20 dBm | +18 dBm
>1000 MHz to ≤1500 MHz | +13 dBm | +19 dBm | +17 dBm
>1500 MHz to ≤2100 MHz | +13 dBm | +17 dBm | +15 dBm
>2100 MHz to ≤2500 MHz | +13 dBm | +15 dBm | +13 dBm
> 2500 MHz to ≤3200 MHz | +10 dBm | +13 dBm | +11 dBm
8648D | 9 kHz to <100 kHz | +13 dBm | +17 dBm | +13 dBm
≥100 kHz to <100 MHz | +13 dBm | +20 dBm | +13 dBm
≥100 MHz to ≤1000 MHz | +13 dBm | +20 dBm | +18 dBm
>1000 MHz to ≤1500 MHz | +13 dBm | +19 dBm | +17 dBm
>1500 MHz to ≤2100 MHz | +13 dBm | +17 dBm | +15 dBm
>2100 MHz to ≤2500 MHz | +13 dBm | +15 dBm | +13 dBm
>2500 MHz to ≤4000 MHz | +10 dBm | +13 dBm | +11 dBm
  1. Minimum amplitude is -136 dBm for all models and all option configurations. Option 1 EA - High power (HP 8648 B/C/D only) Option 1 E6 - Pulse modulation (HP 8648 B/C/D only)

Parameters

RANGE

This field specifies the UUT range as described in the RANGE Field topic.

NOMINAL

This field specifies the amplitude, frequency, period,or reset.

  • Amplitude entered as: [numeric][prefix]D, V, or Vpp.
  • Frequency entered as [numeric][prefix]H.
  • Period entered as [numeric][prefix]T.
  • Reset entered as *.

Rules:

  1. When the NOMINAL field specifies the amplitude, the MOD1 field must specify the frequency or period.
  2. When the NOMINAL field specifies the frequency or period, the MOD1 field must specify the amplitude.

TOLERANCE

This field specifies the UUT tolerance as described in the TOLERANCE Field topic.

MOD1

This field specifies the amplitude, frequency, or period.

  • Frequency entered as [numeric][prefix]H.
  • Period entered as [numeric][prefix]T.
  • Amplitude entered as: [numeric][prefix]D, V, or Vpp.

Rules:

  1. When the MOD1 field specifies the frequency or period, the NOMINAL field must specify the amplitude.
  2. When the MOD1 field specifies the amplitude, the NOMINAL field must specify the frequency or period.

MOD2

This field specifies whether "/div" is include in after the value in the automatic range message.

-D | "/div" is not included
blank | "/div" is included if ASK+ D is in effect

Rules:

  1. The MOD2 field is automatically set to -D for a Setup Test.

MOD3

This field is not used.

MOD4

This field specifies the type of test being performed as described in the MOD4 Field topic.

CON

This field is specifies which output port is used for the signal.

CH1 | Fluke 58xxA Channel 1
CH2 | Fluke 58xxA Channel 2
CH3 | Fluke 58xxA Channel 3
CH4 | Fluke 58xxA Channel 4
CH5 | Fluke 58xxA Channel 5
blank | 8648 A/B/C/D RF Output

Rules:

  1. The CON field may specify CH1 or CH5 only when a Fluke 5800A or 5820A is configured.
  2. The CON field may specify CH2, CH3, or CH4 only when a Fluke 5800A or 5820A is configured with the 5800A-5 Five Channel option.

Use of Standard Memory Locations and Results Reporting

System memory locations MEM and MEM1 are used. For more information, refer to the Use of Standard Memory Registers topic.

Examples

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
  1.001  ASK-                              U
# ----- Reset -----
  1.002  8648         *                                                 S
  1.003  8648   A     -42.95D        1U            100MH          -D
  2.001  8648         100mV                        550MH          -D    S
  2.002  8648   0.5   28mV           5U            100MH
  3.001  8648   A     D              1U            100MH          -D
  4.001  8648         V              1%            100MH          -D
  5.001  8648   50    10uT           1% 1/ 1U      -35D
  6.001  8648   200   100nT          1% 1/ 1U      100mV
# ----- Oscilloscope bandwidth test -----
  7.001  ASK-                                                     F        W
  7.002  ASK+     D
  7.003  DISP         Connect the 8648 to UUT channel 1.
  7.004  DISP         Set UUT to 20us/div.
  7.005  8648   20    120mVpp                      100kH                N  CH1
  7.006  ASK-         N
  7.007  MESS         Adjust stimulus for a UUT vertical reading of 4.2 div.
  7.008  8648         5MH            -100%         mVpp           -D       CH1
  8.001  MESS
  8.002  ASK+         N
  8.003  END


M8648

Auxiliary Instrument Setup FSC

Description

The M8648 FSC provides the additional program functions for the Hewlett-Packard 8648 A/B/C/D RF Signal Generators which are not addressed by the 8648 FSC. These functions are:

  • Modulation Frequency
  • AM Depth
  • FM Deviation
  • Phase Deviation

RANGE

Not used.

NOMINAL

The NOMINAL field specifies the modulation frequency or a reset.

Modulation Frequency:

When the NOMINAL field is used to specify the modulation frequency, the format is [numeric][prefix]H. Allowed values are 400 Hz or 1000 Hz, or 10 Hz to 20 kHz with Option 1 E2.

If just units are entered, the value is taken from memory register MEM at run time.

Reset

To specify a reset, enter an asterisk (*) in the NOMINAL field. This resets all previous settings created with the M8648 FSC.

TOLERANCE

Not used.

MOD1

The MOD1 field specifies the AM depth, FM deviation, or phase deviation.

AM Depth

AM depth is entered as [numeric][prefix]pct. AM depth limits are 0 to 100%; output ≤ 4 dBm.

FM Deviation

FM deviation is entered as [numeric][prefix]H. FM deviation depends upon the carrier and modulation frequencies as shown in the table below:

Modulation Frequency > 25 Hz
Carrier Frequency | FM Deviation
<249 MHz | 0 to 200 kHz
<501 MHz | 0 to 100 kHz
<1001 MHz | 0 to 200 kHz
<2001 MHz | 0 to 400 kHz
≤4000 MHz | 0 to 800 kHz

Phase Deviation

Phase deviation is entered as [numeric][prefix]rad. Phase deviation depends upon the carrier and modulation frequencies as shown in the table below:

Modulation Frequency &gt; 20 Hz
Carrier Frequency | Phase Deviation
< 249 MHz | 0 to 10 radians
< 501 MHz | 0 to 5 radians
< 1001 MHz | 0 to 10 radians
< 2001 MHz | 0 to 20 radians
≤4000 MHz | 0 to 40 radians

MOD2

Not used.

MOD3

Not used.

MOD4

Not used.

CON

Not used.

Examples

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
# AM Modulation
  1.001  M8648        *
  1.002  M8648        400H                         0pct
  1.003  8648   10    0D             1U            10MH
  2.001  M8648        *
  2.002  M8648        1000H                        90pct
  2.003  8648   10    0D             1U            10MH
# FM Modulation
  3.001  M8648        *
  3.002  M8648        400H                         100H
  3.003  8648   10    0D             0.11U         200kH
  4.001  M8648        *
  4.002  M8648        1000H                        99.9kH
  4.003  8648   10    0D             0.1U          1000MH


8901

Instrument FSC

Description

The 8901 FSC programs the Hewlett-Packard 8901A and 8901B Modulation Analyzers to measure AM, FM, and Phase Modulation, Carrier Frequency, RF Level, and Tuned RF Level.

When the 8901 and M8901 FSCs are used to control an HP 8901A, you must configure the instrument as an "HP 8901B" as shown in the drop-down list in the "Add Instrument" configure dialog.

Functional Capability

Function | 8901 MOD3 | 8901 NOMINAL | 8901 MOD1 | M8901 NOMINAL
AM | AM | 0 to 99% | 150 kHz to 10 MHz | 20 Hz to 10 kHz
AM | 0 to 99% | 10 MHz to 1300 MHz | 20 Hz to 100 kHz
FM | FM | 0 Hz to 40 kHz | 150 kHz to 10 MHz | 20 Hz to 10 kHz
FM | 0 Hz to 400 kHz | 10 MHz to 1300 MHz | 20 Hz to 200 kHz
PM1 | PM | 0 rad to 400 rad | 10 MHz to 1300 MHz | 200 Hz to 20 kHz
Frequency | FA | 150 kHz to 650 MHz | -25 dBm to 30 dBm | (12 mV to 7 V)
FA | >650 MHz to 1300 MHz | -20 dBm to 30 dBm | (22 mV to 7 V)
RF Level2 | RF | 1 mW to 1 W | 150 kHz to 1300 MHz
RF Power3 | RF | 10 uW to 1 W | 100 kHz to 2.6 GHz
RF | -20 dBm to +30 dBm | 100 kHz to 2.6 GHz
Tuned RF Level2 | TL | 1 mW to 1 W | 150 kHz to 1300 MHz
Tuned RF Level3 | TL | 10 uW to 1 W | 100 kHz to 1300 MHz
TL | -20 dBm to +30 dBm | 100 kHz to 1300 MHz
AM Calibration | CA | 100.00 %
FM Calibration | CF | 100.00 %
Power Zero3 | ZR | 0.0 W | 100 kHz to 2.6 GHz
Power Zero and Calibrate3 | CP | 1.00 mW | 50 MHz
  1. Actual allowed Phase Modulation is dependent upon modulation frequency according to the graph in the 8901A Operating Manual.
  2. 8901 A
  3. 8901 B

Parameters

RANGE

This field specifies the UUT range as described in the RANGE Field topic.

NOMINAL

This field specifies the expected measured value or a reset.

  • AM Depth entered as: [numeric][prefix]pct.
  • FM Deviation entered as: [numeric][prefix]H.
  • Phase Deviation entered as [numeric][prefix]rad.
  • RF Level or Tuned RF Level entered as [numeric][prefix]W.
  • RF Power entered as [numeric][prefix]W or D.
  • Frequency entered as [numeric][prefix]H.
  • Reset entered as *.

Rules:

  1. See Functional Capability table.
  2. When the Nominal field contains only units, the value is obtained from memory register MEM. In this case the MOD1 field MUST contain a value.

TOLERANCE

This field specifies the UUT tolerance as described in the TOLERANCE Field topic.

MOD1

This field specifies carrier frequency or amplitude.

  • Carrier Frequency entered as [numeric][prefix]H.
  • Amplitude entered as [numeric][prefix]D or V.
  • blank not applicable

Rules:

  1. See Functional Capability table.
  2. When the MOD1 field contains only units, the value is obtained from memory register MEM. In this case the Nominal field MUST contain a value.

MOD2

This field is used to specifying tuning.

TU | Tune frequency
blank | Do not tune or not applicable

Rules:

  1. When the MOD2 field specifies TU, the MOD1 field is used as the tune frequency.
  2. The MOD2 field my specify TU only for modulation measurements, RF power measurements, and tuned RF level measurements (MOD3 = AM, FM, PM, RF, or TL).

MOD3

This field specifies the measurement type:

AM | AM Measurement
FM | FM Measurement
PM | Phase Measurement
FA | Frequency Measurement
RF | RF Level
TL | Tuned RF Level
CA | Calibrate AM (8901 A Requires Opt 010)
CF | Calibrate FM (8901 A Requires Opt 010)
ZR | Zero (8901 B only)
CP | Zero and Calibrate RF Power (8901 B only)

Rules:

  1. See Functional Capability table.
  2. The MOD3 field may specify CA, CF, ZR, and CP only for a Nominal Setup Test (MOD4 = N).

MOD4

This field specifies the type of test being performed as described in the MOD4 Field topic.

CON

This field is always blank.

Use of Standard Memory Locations and Results Reporting

System memory locations MEM and MEM1 are used. For more information, refer to the Use of Standard Memory Registers topic.

Examples

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
# ----- Reset -----
  1.001  8901         *                                                 S
# ----- AM -----
  1.002  M8901        400H                                        H0 L0
  1.003  8901         20pct          5U            750kH             AM
# ----- FM -----
  2.001  M8901        1kH                                         H0 L2    P+
  2.002  8901         35.0H          +100%         5MH               FM
# ----- Phase -----
  3.001  8901         15.0rad        1.0U          5MH               PM
# ----- RF Level -----
  4.001  M8901        *
  4.002  8901         50.0mW         0.2U          102.5MH           RF
# ----- Frequency -----
  5.001  8901         102.5MH        0.1U          10D               FA


M8901

Auxiliary Instrument Setup FSC

Description

The M8901 FSC provides the additional program functions for Hewlett-Packard 8901A/B which are not addressed by the 8901 FSC. These functions include modulation frequency, special functions, FM de-emphasis, high-pass filter, low-pass filter, and detector.

Parameters

RANGE

This field is used not used.

NOMINAL

This field specifies the Modulation Frequency or a reset.

Modulation Frequency entered as: [numeric][prefix]H.

"*" Reset

blank

Rules:

  1. When the M8901 FSC Nominal field specifies a Modulation Frequency of 0 Hz, the 8901 MOD3 field is "AM", Residual AM accuracy is returned for the measurement.

  2. When the M8901 FSC Nominal field specifies a Modulation Frequency of 0 Hz, the 8901 MOD3 field is "FM", Residual FM accuracy is returned for the measurement.

  3. When the M8901 FSC Nominal field specifies a reset the following parameter values are set:

    High-Pass Filter

    All Off

    Low-Pass Filter

    All Off

    Special Functions

    Off or Zero Suffix setting, which ever applies

TOLERANCE

This field is used to specify special functions.

Special function entered as: numericSP.

blank not applicable

Rules:

  1. Special Function codes supported:

    Tolerance Field | Special Function
    1.0 SP to 1.6 SP | Input Attenuation
    2.0 SP to 2.3 SP | Modulation Range
    3.0 SP to 3.4 SP | IF Frequency and Input High-Pass Filter
    4.0 SP to 4.2 SP | Tune Mode
    5.0 SP to 5.1 SP | Audio Peak Detector Time Constant
    6.0 SP to 6.2 SP | AM ALC Response Time
    7.0 SP to 7.2 SP | Frequency Resolution
    8.0 SP to 8.8 SP | Error Disable
    15.0 SP | Display E12 if Oven Cold
    16.0 SP to 16.1 SP | AM Calibration
    17.0 SP to 17.1 SP | FM Calibration

  2. See the 8901B Operator's Manual for a description of individual Special Function codes.

  3. Multiple M8901 statements may be used to specify more than one special function for a measurement. A special function specification is retained until a M8901 reset is executed. However the actual special function settings of the 8901 are only updated when a 8901 statement is executed.

  4. MET/CAL does not check to make sure that a special function specified is compatible with other 8901 settings specified in the 8901 and M8901 FSCs.

MOD1

This field specifies FM De-Emphasis.

FM De-Emphasis entered as: [numeric][prefix]T.

blank Pre-Display and FM De-Emphasis off

Rules:

  1. Allowed values are: 25 us, 50 us, 75 us, and 750 us.
  2. Pre-Display is turned on whenever De-Emphasis is specified.
  3. The M8901 MOD1 field may only specify FM De-Emphasis when the 8901 MOD3 field specifies FM.

MOD2

This field specifies the High-Pass Filter:

H0 | All Off
H1 | 50 Hz
H2 | 300 Hz

Rules:

  1. H0 is automatically inserted in the MOD2 field if no MOD2 field code is entered.

MOD3

This field specifies the Low-Pass Filter:

L0 | All Off
L1 | 3 kHz
L2 | 15 kHz
L3 | >20 kHz

Rules:

  1. L0 is automatically inserted in the MOD3 field if no MOD3 field code is entered.

MOD4

This field is not used.

CON

This field specifies the Detector:

P+ | Peak +
P- | Peak -
P+- | Peak +-/2 (8901 B only)
HLD | Peak Hold
AVG | Average (RMS Calibrated)
blank | Not applicable

Rules:

8901 MOD3 | M8901 NOMINAL | M8901 CON
AM | mod-freq | P+, P-, P+-, HLD, AVG, RMS
FM | mod-freq | P+, P-, P+-, HLD, AVG, RMS
PM | mod-freq | P+, P-, P+-, HLD, AVG, RMS
FA | blank | blank
RF | blank | blank
TL | blank | blank
CA | mod-freq | blank
CF | mod-freq | blank
CP | blank | blank

Examples

Refer to 8901 FSC.


8902

Instrument FSC

Description

The 8902 FSC programs the Hewlett-Packard 8902A Measuring Receiver and 8902S Microwave Measurement System to measure AM, FM, and Phase Modulation, Carrier Frequency, RF Power, Tuned RF Level, and Audio Distortion, Frequency, and Level.

The 8902S is an 8902A with a 11792A Sensor Module, and a 11793A Microwave Converter.

Functional Capability

Function | 8902 MOD3 | 8902 NOMINAL | 8902 MOD1 | M8902 NOMINAL
AM | AM | 0 to 99% | 150 kHz to <10 MHz | 20 Hz to 10 kHz
AM | 0 to 99% | 10 MHz to 1300 MHz 3 | 20 Hz to 10 kHz
FM | FM | 0 Hz to 40 kHz | 150 kHz to <10 MHz | 20 Hz to 100 kHz
FM | 0 Hz to 400 kHz | 10 MHz to 1300 MHz 3 | 20 Hz to 200 kHz
PM 1 | PM | 0 rad to 400 rad | 150 kHz to <10 MHz | 200 Hz to 10 kHz
PM | 0 rad to 400 rad | 10 MHz to 1300 MHz 3 | 200 Hz to 20 kHz
Frequency | FA | 150 kHz to 650 MHz | -25 dBm to 30 dBm (12 mV to 7 V)
FA | >650 MHz to 1300 MHz 3 | -20 dBm to 30 dBm (22 mV to 7 V)
RF Power 2 | RF | 10 µW to 1 W | 100 kHz to 2.6 GHz 3
RF | -20 dBm to +30 dBm | 100 kHz to 2.6 GHz 3
Tuned RF Level | TL | 10 µW to 1 mW | 2.5 MHz to 1300 MHz 3
TL | -127 dBm to 0 dBm | 2.5 MHz to 1300 MHz 3
Audio Dist | AD | 0.01% to 100% | 380 Hz to 420 Hz
AD | -80 dB to 0 dB 4 | 380 Hz to 420 Hz
AD | 0.01% to 100% | 0.95 kHz to 1.05 kHz
AD | -80 dB to 0 dB 4 | 0.95 kHz to 1.05 kHz
Audio Freq | AF | 20 Hz to 600 kHz | 100 mV to 4 V
AF | 20 Hz to 600 kHz | -20 dBm to 12.04 dBm 4
Audio Level | AL | 100 mV to 4 V | 50 Hz to 40 kHz
AL | -20 dBm to 12.04 dBm 4 | 50 Hz to 40 kHz
AM Calibration | CA | 100.00%
FM Calibration | CF | 100.00%
Power Zero only | ZR | 0.0 W | 100 kHz to 2.6 GHz 3
Power Zero and Calibrate | CP | 1.00 mW | 50 MHz
  1. Actual allowed Phase Modulation is dependent upon modulation frequency according to the graph in the 8902A Operating Manual.
  2. With HP 11722A Sensor Module
  3. 8902S: 50 MHz to 26.5 GHz
  4. Relative to 1 kOhm.

Parameters

RANGE

This field specifies the UUT range as described in the RANGE Field topic.

NOMINAL

This field specifies the expected measured value or a reset.

  • AM Depth entered as: [numeric][prefix]pct.
  • FM Deviation entered as: [numeric][prefix]H.
  • Phase Deviation entered as [numeric][prefix]rad.
  • Frequency entered as [numeric][prefix]H.
  • RF Power entered as [numeric][prefix]W or D.
  • Tuned RF Level entered as [numeric][prefix]W or D.
  • Relative Tuned RF Level entered as [numeric][prefix]dB.
  • Audio Distortion entered as [numeric][prefix]pct or dB.
  • Audio Frequency entered as [numeric][prefix]H.
  • Audio Level entered as [numeric][prefix]V or D.
  • Reset entered as *.

Rules:

  1. See Functional Capability table.
  2. When the NOMINAL field contains only units, the value is obtained from memory register MEM. In this case the MOD1 field MUST contain a value.

TOLERANCE

This field specifies the UUT tolerance as described in the TOLERANCE Field topic.

MOD1

This field specifies the carrier frequency or amplitude.

  • Carrier Frequency entered as [numeric][prefix]H.
  • Amplitude entered as [numeric][prefix]D or V.
  • blank not applicable

Rules:

  1. See Functional Capability table.
  2. When the MOD1 field contains only units, the value is obtained from memory register MEM. In this case the NOMINAL field MUST contain a value.

MOD2

This field is used to specifying tuning.

TU | Tune frequency
blank | Do not tune or not applicable

Rules:

  1. When the MOD2 field specifies TU, the MOD1 field is used as the tune frequency.
  2. The MOD2 field my specify TU only for modulation measurements, RF power measurements, and tuned RF level measurements (MOD3 = AM, FM, PM, RF, or TL).

MOD3

This field specifies the measurement type:

AM | AM Measurement
FM | FM Measurement
RF | RF Power
TL | Tuned RF Level
RS | Tuned RF Level (set reference)
FA | Frequency Measurement
AD | Audio Distortion Measurement
AF | Audio Frequency Measurement
AL | Audio Level Measurement
CA | Calibrate AM
CF | Calibrate FM
ZR | Zero
CP | Zero and Calibrate RF Power

Rules:

  1. See Functional Capability table.
  2. The MOD3 field may specify RS, CA, CF, ZR, and CP only for a Nominal Setup Test (MOD4 = N).

MOD4

This field specifies the type of test being performed as described in the MOD4 Field topic.

CON

This field is always blank.

Use of Standard Memory Locations and Results Reporting

System memory locations MEM and MEM1 are used. For more information, refer to the Use of Standard Memory Registers topic.

Examples

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
# ----- Reset -----
  1.001  M8902        *
  1.002  8902         *                                                 S

# ----- AM Calibration -----
  1.003  8902         100.00pct                                      CA N

# ----- FM Calibration -----
  1.004  8902         100.00pct                                      CF N

# ----- RF Power Calibration -----
  1.005  DISP         Connect the HP 11722A Sensor Module to the HP 8902A
  1.005  DISP         CALIBRATION RF POWER OUTPUT.
  1.006  HEAD         HP 8902A ZERO/CAL in Progress, Please Wait ...
  1.007  8902         1mW                          50MH              CP N
  1.008  HEAD         HP 8902A ZERO/CAL operations completed.
  1.009  DISP         Remove the HP 11722A Sensor Module from the HP 8902A
  1.009  DISP         CALIBRATION RF POWER OUTPUT and connect it to the UUT.

# ----- Frequency Measurement -----
  1.010  8902         120MH                        11D               FA N

# ----- 8902A RF Power Measurement and Tuned RF Level Measurement -----
  1.011  RSLT         =
  1.012  HEAD         {RF LEVEL ACCURACY TEST}
  1.013  RSLT         =(Nominal Output @ Frequency)
  1.014  RSLT         =
  1.015  HEAD         RF LEVEL ACCURACY TEST (3 MHz)
  1.016  TARGET       -p
  1.017  SCPI         FREQ:CW 3 MHZ;:POW:AMPL 13 DBM;:OUTP:STAT ON
  1.018  TARGET       -m
  1.019  8902   130   13.0D          1.0U          3MH               RF

  2.001  SCPI         FREQ:CW 3 MHZ;:POW:AMPL 10 DBM;:OUTP:STAT ON
  2.002  TARGET       -m
  2.003  8902   130   10.0D          1.0U          3MH               RF

  3.001  SCPI         FREQ:CW 3 MHZ;:POW:AMPL 4 DBM;:OUTP:STAT ON
  3.002  TARGET       -m
  3.003  8902   130   4.0D           1.0U          3MH               RF

  4.001  SCPI         FREQ:CW 3 MHZ;:POW:AMPL -5.9 DBM;:OUTP:STAT ON
  4.002  TARGET       -m
  4.003  8902   130   -5.9D          1.0U          3MH            TU TL

  5.001  SCPI         FREQ:CW 3 MHZ;:POW:AMPL -15.9 DBM;:OUTP:STAT ON
  5.002  TARGET       -m
  5.003  8902   130   -15.9D         1.0U          3MH               TL

  6.001  SCPI         FREQ:CW 3 MHZ;:POW:AMPL -25.9 DBM;:OUTP:STAT ON
  6.002  TARGET       -m
  6.003  8902   130   -25.9D         1.0U          3MH               TL

  7.001  SCPI         FREQ:CW 3 MHZ;:POW:AMPL -35.9 DBM;:OUTP:STAT ON
  7.002  TARGET       -m
  7.003  8902   130   -35.9D         1.0U          3MH               TL

  8.001  SCPI         FREQ:CW 3 MHZ;:POW:AMPL -45.9 DBM;:OUTP:STAT ON
  8.002  TARGET       -m
  8.003  8902   130   -45.9D         1.0U          3MH               TL

  9.001  SCPI         FREQ:CW 3 MHZ;:POW:AMPL -55.9 DBM;:OUTP:STAT ON
  9.002  TARGET       -m
  9.003  8902   130   -55.9D         1.0U          3MH               TL

 10.001  SCPI         FREQ:CW 3 MHZ;:POW:AMPL -65.9 DBM;:OUTP:STAT ON
 10.002  TARGET       -m
 10.003  8902   130   -65.9D         1.0U          3MH               TL

 11.001  SCPI         FREQ:CW 3 MHZ;:POW:AMPL -75.9 DBM;:OUTP:STAT ON
 11.002  TARGET       -m
 11.003  8902   130   -75.9D         1.0U          3MH               TL

 12.001  SCPI         FREQ:CW 3 MHZ;:POW:AMPL -85.9 DBM;:OUTP:STAT ON
 12.002  TARGET       -m
 12.003  8902   130   -85.9D         1.0U          3MH               TL

 13.001  SCPI         FREQ:CW 3 MHZ;:POW:AMPL -95.9 DBM;:OUTP:STAT ON
 13.002  TARGET       -m
 13.003  8902   130   -95.9D         1.0U          3MH               TL

 14.001  SCPI         FREQ:CW 3 MHZ;:POW:AMPL -96 DBM;:OUTP:STAT ON
 14.002  TARGET       -m
 14.003  8902   130   -96.0D         1.0U          3MH               TL

 15.001  SCPI         FREQ:CW 3 MHZ;:POW:AMPL -105.9 DBM;:OUTP:STAT ON
 15.002  TARGET       -m
 15.003  8902   130   -105.9D        1.0U          3MH               TL

 16.001  SCPI         FREQ:CW 3 MHZ;:POW:AMPL -106 DBM;:OUTP:STAT ON
 16.002  TARGET       -m
 16.003  8902   130   -106.0D        1.0U          3MH               TL

 17.001  SCPI         FREQ:CW 3 MHZ;:POW:AMPL -115.9 DBM;:OUTP:STAT ON
 17.002  TARGET       -m
 17.003  8902   130   -115.9D        1.0U          3MH               TL

 18.001  SCPI         FREQ:CW 3 MHZ;:POW:AMPL -116 DBM;:OUTP:STAT ON
 18.002  TARGET       -m
 18.003  8902   130   -116.0D        1.0U          3MH               TL

 19.001  SCPI         FREQ:CW 3 MHZ;:POW:AMPL -125.9 DBM;:OUTP:STAT ON
 19.002  TARGET       -m
 19.003  8902   130   -125.9D        1.0U          3MH               TL

 20.001  SCPI         FREQ:CW 3 MHZ;:POW:AMPL -126 DBM;:OUTP:STAT ON
 20.002  TARGET       -m
 20.003  8902   130   -126.0D        1.0U          3MH               TL

 21.001  SCPI         FREQ:CW 3 MHZ;:POW:AMPL -127 DBM;:OUTP:STAT ON

# ----- 8902S RF Power Measurement and Tuned RF Level Measurement -----
 21.002  RSLT         =
 21.003  HEAD         RF LEVEL ACCURACY TEST ({Carrier Frequency: 4000 MHz})
 21.004  TARGET       -p
 21.005  SCPI         FREQ:CW 4000 MHZ;:POW:AMPL 13 DBM;:OUTP:STAT ON
 21.006  IEEE         [@8340]CW4120.53MZPL+8DBRF1
 21.007  M8902        4120.53MH      27.3SP                       H0 L0
 21.008  8902         4000MH                       13D               FA N
 21.009  TARGET       -m
 21.010  8902         13.0D                        4000MH            RF N
 21.011  MEMC   130   13.0D          2.0U

 22.001  SCPI         FREQ:CW 4000 MHZ;:POW:AMPL 10 DBM;:OUTP:STAT ON
 22.002  IEEE         [@8340]CW4120.53MZPL+8DBRF1
 22.003  TARGET       -m
 22.004  8902         10.0D                        4000MH            RF N
 22.005  MEMC   130   10.0D          2.0U

 23.001  SCPI         FREQ:CW 4000 MHZ;:POW:AMPL 4 DBM;:OUTP:STAT ON
 23.002  IEEE         [@8340]CW4120.53MZPL+8DBRF1
 23.003  TARGET       -m
 23.004  8902         4.0D                         4000MH            RF N
 23.005  MEMC   130   4.0D           2.0U

 24.001  SCPI         FREQ:CW 4000 MHZ;:POW:AMPL -5.9 DBM;:OUTP:STAT ON
 24.002  IEEE         [@8340]CW4120.53MZPL+8DBRF1
 24.003  TARGET       -m
 24.004  8902         -5.9D                        4000MH         TU TL N
 24.005  MEMC   130   -5.9D          2.0U

 25.001  SCPI         FREQ:CW 4000 MHZ;:POW:AMPL -15.9 DBM;:OUTP:STAT ON
 25.002  IEEE         [@8340]CW4120.53MZPL+8DBRF1
 25.003  TARGET       -m
 25.004  8902         -15.9D                       4000MH            TL N
 25.005  MEMC   130   -15.9D         2.0U

 26.001  SCPI         FREQ:CW 4000 MHZ;:POW:AMPL -25.9 DBM;:OUTP:STAT ON
 26.002  IEEE         [@8340]CW4120.53MZPL+8DBRF1
 26.003  TARGET       -m
 26.004  8902         -25.9D                       4000MH            TL N
 26.005  MEMC   130   -25.9D         2.0U

 27.001  SCPI         FREQ:CW 4000 MHZ;:POW:AMPL -35.9 DBM;:OUTP:STAT ON
 27.002  IEEE         [@8340]CW4120.53MZPL+8DBRF1
 27.003  TARGET       -m
 27.004  8902         -35.9D                       4000MH            TL N
 27.005  MEMC   130   -35.9D         2.0U

 28.001  SCPI         FREQ:CW 4000 MHZ;:POW:AMPL -45.9 DBM;:OUTP:STAT ON
 28.002  IEEE         [@8340]CW4120.53MZPL+8DBRF1
 28.003  TARGET       -m
 28.004  8902         -45.9D                       4000MH            TL N
 28.005  MEMC   130   -45.9D         2.0U

 29.001  SCPI         FREQ:CW 4000 MHZ;:POW:AMPL -55.9 DBM;:OUTP:STAT ON
 29.002  IEEE         [@8340]CW4120.53MZPL+8DBRF1
 29.003  TARGET       -m
 29.004  8902         -55.9D                       4000MH            TL N
 29.005  MEMC   130   -55.9D         2.0U

# ----- 8902A AM Measurement -----
 30.001  RSLT         =
 30.002  HEAD         AM ACCURACY TEST (+4 dBm): {Carrier Frequency: 2 MHz}
 30.003  TARGET       -p
 30.004  TSET         TDESC = AM Depth: 10%
 30.005  SCPI         FREQ:CW 2 MHZ;:AM:DEPT 10 PCT;:AM:SOUR INT
 30.006  SCPI         AM:INT:FREQ 1 KHZ;:AM:STAT ON
 30.007  SCPI         POW:AMPL 4 DBM;:OUTP:STAT ON
# Set 8902A for 1 kHz mod frequency, 300 Hz (LP), 15 kHz (HP) filters, +Peak.
 30.008  M8902        1kH                                         H2 L2    P+
 30.009  TARGET       -m
 30.010  8902         10.0pct        2.0U          2MH               AM

 31.001  TSET         TDESC = AM Depth: 30%
 31.002  SCPI         FREQ:CW 2 MHZ;:AM:DEPT 30 PCT;:AM:SOUR INT
 31.003  SCPI         AM:INT:FREQ 1 KHZ;:AM:STAT ON
 31.004  SCPI         POW:AMPL 4 DBM;:OUTP:STAT ON
 31.005  M8902        1kH                                         H2 L2    P+
 31.006  TARGET       -m
 31.007  8902         30.0pct        3.0U          2MH               AM

 32.001  TSET         TDESC = AM Depth: 60%
 32.002  SCPI         FREQ:CW 2 MHZ;:AM:DEPT 60 PCT;:AM:SOUR INT
 32.003  SCPI         AM:INT:FREQ 1 KHZ;:AM:STAT ON
 32.004  SCPI         POW:AMPL 4 DBM;:OUTP:STAT ON
 32.005  M8902        1kH                                         H2 L2    P+
 32.006  TARGET       -m
 32.007  8902         60.0pct        4.5U          2MH               AM

# ----- 8902A FM Measurement -----
 33.001  RSLT         =
 33.002  HEAD         {FM ACCURACY PERFORMANCE TEST}
 33.003  RSLT         =Modulation Source: INT 1 kHz
 33.004  RSLT         =
 33.005  HEAD         FM ACCURACY TEST ({Carrier Frequency: 0.25 MHz})
 33.006  TSET         TDESC = 5 kHz Deviation
 33.007  TARGET       -p
 33.008  SCPI         FREQ:CW .25 MHZ;:FM:DEV 5 KHZ;:FM:SOUR INT
 33.009  SCPI         FM:INT:FREQ 1 KHZ;:FM:STAT ON
 33.010  SCPI         POW:AMPL 4 DBM;:OUTP:STAT ON
 33.011  M8902        1kH                                         H2 L2    P+
 33.012  TARGET       -m
 33.013  8902         5.000kH        0.180U        0.25MH            FM

 34.001  TSET         TDESC = 10 kHz Deviation
 34.002  SCPI         FREQ:CW .25 MHZ;:FM:DEV 10 KHZ;:FM:SOUR INT
 34.003  SCPI         FM:INT:FREQ 1 KHZ;:FM:STAT ON
 34.004  SCPI         POW:AMPL 4 DBM;:OUTP:STAT ON
 34.005  TARGET       -m
 34.006  8902         10.000kH       0.330U        0.25MH            FM

# ----- 8902S FM Measurement -----
 35.001  RSLT         =
 35.002  HEAD         FM ACCURACY TEST ({Carrier Frequency: 1500 MHz})
 35.003  TSET         TDESC = 5 kHz Deviation
 35.004  TARGET       -p
 35.005  SCPI         FREQ:CW 1500 MHZ;:FM:DEV 5 KHZ;:FM:SOUR INT
 35.006  SCPI         FM:INT:FREQ 1 KHZ;:FM:STAT ON
 35.007  SCPI         POW:AMPL 4 DBM;:OUTP:STAT ON
# Set 8340B LO output to required frequency (1620.53 MHz) and level (+8 dBm).
 35.008  IEEE         [@8340]CW1620.53MZPL+8DBRF1
 35.009  M8902        1620.53MH      27.3SP                       H0 L0
 35.010  M8902        1kH                                         H2 L2    P+
 35.011  TARGET       -m
 35.012  8902         5.000kH        0.210U        1500MH            FM

 36.001  TSET         TDESC = 10 kHz Deviation
 36.002  SCPI         FREQ:CW 1500 MHZ;:FM:DEV 10 KHZ;:FM:SOUR INT
 36.003  SCPI         FM:INT:FREQ 1 KHZ;:FM:STAT ON
 36.004  SCPI         POW:AMPL 4 DBM;:OUTP:STAT ON
 36.005  IEEE         [@8340]CW1620.53MZPL+8DBRF1
 36.006  M8902        1620.53MH      27.3SP                       H0 L0
 36.007  M8902        1kH                                         H2 L2    P+
 36.008  TARGET       -m
 36.009  8902         10.000kH       0.360U        1500MH            FM

 37.001  RSLT         =
 37.002  HEAD         FM ACCURACY TEST ({Carrier Frequency: 2000 MHz})
 37.003  TSET         TDESC = 5 kHz Deviation
 37.004  TARGET       -p
 37.005  SCPI         FREQ:CW 2000 MHZ;:FM:DEV 5 KHZ;:FM:SOUR INT
 37.006  SCPI         FM:INT:FREQ 1 KHZ;:FM:STAT ON
 37.007  SCPI         POW:AMPL 4 DBM;:OUTP:STAT ON
 37.008  IEEE         [@8340]CW2120.53MZPL+8DBRF1
 37.009  M8902        2120.53MH      27.3SP                       H0 L0
 37.010  M8902        1kH                                         H2 L2    P+
 37.011  TARGET       -m
 37.012  8902         5.000kH        0.210U        2000MH            FM

# ----- 8902A PM Measurement & Audio Distortion Measurement -----
 38.001  RSLT         =
 38.002  HEAD         {PHASE MODULATION DISTORTION PERFORMANCE TEST}
 38.003  RSLT         =Modulation Source: INT 1 kHz
 38.004  RSLT         =
 38.005  RSLT         =5 Radians Deviation
 38.006  HEAD         PM DISTORTION TEST (Carrier Frequency: 0.25 MHz)
 38.007  TSET         TDESC = 0.25 MHz Carrier
 38.008  TARGET       -p
 38.009  SCPI         FREQ:CW 0.25 MHZ;:PM:DEV 5 RAD;:PM:SOUR INT
 38.010  SCPI         PM:INT:FREQ 1 KHZ;:PM:STAT ON
 38.011  SCPI         POW:AMPL 4 DBM;:OUTP:STAT ON
 38.012  M8902        1kH                                         H2 L2    P+
 38.013  8902         5.00rad                      0.25MH            PM N
 38.014  M8902                                                    H2 L2    D5
 38.015  TARGET       -m
 38.016  8902         0.01pct        1.00U         1kH               AD

# ----- AM Audio Distortion -----
 39.001  M8902        1kH                                         H2 L2    P+
 39.002  8902         30.0pct                      2MH               AM N
 39.003  M8902                                                    H2 L2    D5
 39.004  TARGET       -m
 39.005  8902         0.01pct        +2.00U        1kH               AD

# ----- FM Audio Distortion -----
 40.001  M8902        1kH                                         H2 L2    P+
 40.002  8902         5.000kH                      10MH              FM N
 40.003  M8902                                                    H2 L2    D5
 40.004  TARGET       -m
 40.005  8902         0.01pct        +1.00U        1kH               AD

# ----- External Audio Distortion -----
 41.001  IEEE         FREQ 1E3;AMPLT 2
 41.002  M8902                                                    H0 L0 X
 41.003  8902         0.01pct        +2.00U        1kH               AD

# ----- External Audio Level -----
 42.001  IEEE         FREQ 1E3;AMPLT 2
 42.002  M8902                                                    H0 L0 X
 42.003  8902   100   0.3535V        20%           1kH               AL

# ----- External Audio Frequency -----
 43.001  IEEE         FREQ 50;AMPLT 2
 43.002  M8902                                                    H0 L0 X
 43.003  8902         50.000H        1%            2V                AF

# ----- Relative Tuned RF Level -----
 44.001  HEAD         0 dBm REFERENCE: 10 MHz
 44.002  DISP         Set UUT to 0 dB.
 44.003  6060         0D                           10MH           -D    S  L

# Disable relative mode.
 44.004  M8902                       26.0SP                       H0 L0
 44.005  8902         0D                           10MH           TU RS N
 44.006  HEAD         10 dB @ 10 MHz
 44.007  DISP         Set UUT to 10 dB.
 44.008  6060         0D                           10MH           -D    S  L

# Enable relative mode.
 44.009  M8902                       26.1SP                       H0 L0
# 44.010  8902         10.0dB                       10MH              TL N
 44.010  MATH         MEM = ABS(MEM)
 44.011  ACC    10    dB             0.02U
 44.012  MATH         MEM = MEM1
 44.013  MEMC         10.0dB         0.1U          10MH
 45.001  END

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
 45.002  HEAD         PRELIMINARY INSTRUCTIONS
 45.003  DISP         Connect the 11722A Sensor Module to the 8902A.

 45.004  DO
 45.005  DISP         When you select Advance, the non-volatile cal factor
 45.005  DISP         table will be cleared.  This will cause Error 15 to
 45.005  DISP         displayed on the 8902A front.  Error 15 will continue
 45.005  DISP         to be displayed following entry of each cal factor,
 45.005  DISP         until all cal factors are entered.

# Set to RF POWER mode & clear the non-volatile cal factor storage table.
 45.006  IEEE         [@8902]M4T037.9SP[D1000]

 45.007  HEAD         ENTER REF CAL FACTOR
# Enter the reference calibration factor.
 45.008  MEMI         Cal Factor for REF position cal factor (%).
 45.009  MATH         MEM2 = FMT(MEM, "%7.2f")
 45.010  IEEE         [@8902]37.3SP[MEM2]CF[D1000]

 45.011  HEAD         ENTER CAL FACTORS
 45.012  MATH         CF = 1

# Enter cal factors...
 45.013  DO
 45.014  MEMI         Frequency for cal factor #[V CF] (MHz).
 45.015  MATH         FreqMHz = FMT(MEM, "%8.2f")
 45.016  MEMI         Cal factor for [MEM] MHz (%).
 45.017  MATH         CalFactor = FMT(MEM, "%7.2f")
 45.018  IEEE         [@8902]37.3SP[V FreqMHz]MZ[V CalFactor]CF[D1000]
 45.019  MATH         CF = CF + 1
 45.020  UNTIL        CF > 10

 45.021  8902         *                                                 S

# Select RF Power measurement.
 45.022  IEEE         [@8902][D3000]M4T0[D1000]

# Verify that the cal factors were successfully stored in the table.
 45.023  HEAD         VERIFY REF CAL FACTOR
 45.024  IEEE         [@8902][TERM LF]37.5SPCF[I]
 45.025  OPBR         -z Is REF position cal factor [MEM] MHz?
 45.026  MATH         Error = NOT(MEM1)

 45.027  IF           NOT(Error)
 45.028  HEAD         VERIFY CAL FACTORS
 45.029  MATH         CF = 1

# Enter cal factors...
 45.030  DO
 45.031  IEEE         [@8902][TERM LF]37.6SPFR[I]
 45.032  MATH         FreqMHz = MEM / 1E+6
 45.033  IEEE         [@8902][TERM LF]CF[I]
 45.034  OPBR         -z Is [V FreqMHz] MHz cal factor [MEM]%?
 45.035  MATH         Error = NOT(MEM1)
 45.036  MATH         CF = CF + 1
 45.037  UNTIL        (CF > 10) || Error

 45.038  ENDIF        ; NOT(Error)

 45.039  IF           Error
 45.040  HEAD         ERROR
 45.041  OPBR         -z All cal factors were not successfully downloaded.
 45.041  OPBR
 45.041  OPBR         Do you wish to try again?
 45.042  MATH         Done = NOT(MEM1)
 45.043  ENDIF

 45.044  UNTIL        Done

 45.045  HEAD         DONE
 45.046  DISP         All cal factors have been successfully downloaded.
 45.047  END

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
  1.001  HEAD         RF LEVEL ACCURACY ABOVE 1.3 GHz
# Clear all calibration factors.
  1.002  IEEE         [@8902]39.9SP
  1.003  HEAD         SET 0 dB REFERENCE @ 1500 MHz
  1.004  DISP         Set the UUT to 10 dB.
  1.005  8648         1500MH                       5D             -D    S
  1.006  IEEE         [@8340]CW1620.53MZPL8DBRF1
  1.007  M8902                       26.0SP                       H0 L0
# Set IF Freq: 455 kHz, Wide IF Filter: 200 kHz, Narrow IF & RF High-Pass in.
  1.008  M8902                       3.7SP                        H0 L0
# Set input attenuation to 10 dB.
  1.009  M8902                       1.9SP                        H0 L0
# Specify LO frequency.
  1.010  M8902        1620.53MH      27.3SP                       H0 L0
  1.011  8902         1500MH                       5D                FA N
# Re-tune the 8902A and set the 0 dB reference.
  1.012  8902         0.00D                        MH             TU RS N

  1.013  HEAD         ATTENUATION: 10 dB @ 1500 MHz
  1.014  DISP         Set the UUT to 10 dB.
  1.015  8648         1500MH                       5D             -D    S
  1.016  IEEE         [@8340]CW1620.53MZPL8DBRF1
  1.017  M8902                       26.1SP                       H0 L0
  1.018  TARGET       -m
  1.019  8902         -10.00dB       0.2U          1500MH            TL

  2.001  HEAD         ATTENUATION: 20 dB @ 1500 MHz
  2.002  DISP         Set the UUT to 20 dB.
  2.003  8648         1500MH                       5D             -D    S
  2.004  IEEE         [@8340]CW1620.53MZPL8DBRF1
  2.005  TARGET       -m
  2.006  8902         -20.00dB       0.4U          1500MH            TL

  3.001  HEAD         ATTENUATION: 30 dB @ 1500 MHz
  3.002  DISP         Set the UUT to 30 dB.
  3.003  8648         1500MH                       5D             -D    S
  3.004  IEEE         [@8340]CW1620.53MZPL8DBRF1
  3.005  TARGET       -m
  3.006  8902         -30.00dB       0.5U          1500MH            TL

  4.001  HEAD         ATTENUATION: 40 dB @ 1500 MHz
  4.002  DISP         Set the UUT to 40 dB.
  4.003  8648         1500MH                       5D             -D    S
  4.004  IEEE         [@8340]CW1620.53MZPL8DBRF1
  4.005  TARGET       -m
  4.006  8902         -40.00dB       0.7U          1500MH            TL

  5.001  HEAD         ATTENUATION: 50 dB @ 1500 MHz
  5.002  DISP         Set the UUT to 50 dB.
  5.003  8648         1500MH                       5D             -D    S
  5.004  IEEE         [@8340]CW1620.53MZPL8DBRF1
  5.005  TARGET       -m
  5.006  8902         -50.00dB       0.8U          1500MH            TL

  6.001  END


M8902

Auxiliary Instrument Setup FSC

Description

The M8902 FSC provides the additional program functions for Hewlett-Packard 8902A which are not addressed by the 8902 FSC. These functions include modulation frequency, 8902S Local Oscillator (LO) frequency, special functions, FM de-emphasis, high-pass filter, low-pass filter, and detector.

RANGE

This field is used not used.

NOMINAL

This field specifies the Modulation Frequency or a reset.

Modulation Frequency entered as: [numeric][prefix]H.

Local Oscillator Frequency enter as: [numeric][prefix]H.

"*" Reset

blank

Rules:

  1. When the M8902 FSC Nominal field specifies a Modulation Frequency of 0 Hz, the 8902 MOD3 field is "AM", Residual AM accuracy is returned for the measurement.
  2. When the M8902 FSC Nominal field specifies a Modulation Frequency of 0 Hz, the 8902 MOD3 field is "FM", Residual FM accuracy is returned for the measurement.
  3. When a frequency is entered in the Nominal field, it is interpreted as follows: If the M8902 Tolerance field is 27.3SP the Nominal field value is assumed to be the LO frequency applied to the 11793A Microwave Converter. In all other cases, the Nominal value is assumed to be the modulation frequency.
  4. Allowed values for LO Frequency are 1300MHz to 26.5GHz.

  5. When the M8902 FSC Nominal field specifies a reset the following parameter values are set:

    High-Pass Filter | All Off
    Low-Pass Filter | All Off
    Special Functions | Off or Zero Suffix setting, which ever applies

TOLERANCE

This field is used to specify special functions.

Special function entered as: numericSP.

blank not applicable

Rules:

  1. Special Function codes supported:

    Tolerance Field | Special Function
    1.0SP to 1.9SP | Input Attenuation & Gain
    2.0SP to 2.4SP | Audio Range Selection
    3.0SP to 3.8SP | RF and IF Filters
    4.0SP to 4.7SP | Tune RF Level Sync., Average Detector, & Display Averaging
    5.0SP to 5.1SP | Audio Detector Response
    6.0SP to 6.2SP | Automatic Level Control
    7.0SP to 7.4SP | RF Frequency Resolution
    8.0SP to 8.8SP | Error Message Disable Control
    9.0SP to 9.7SP | IF Gain
    10.0SP to 10.5SP | RF Power Range
    15.0SP | Display E12 if Oven Cold
    16.0SP to 16.1SP | AM Calibration
    17.0SP to 17.1SP | FM Calibration
    23.0SP to 23.1SP | External LO (Option 030 only)
    26.0SP to 26.1SP | Relative Tuned RF Level Measurement
    27.0SP to 27.3SP | Frequency Offset Mode (8902S only)
    32.0SP to 32.2SP | Increased Resolution (Option 050 only)

  2. See the 8902A Operator's Manual for a description of individual Special Function codes.

  3. Multiple M8902 statements may be used to specify more than one special function for a measurement. A special function specification is retained until a M8902 reset is executed. However the actual special function settings of the 8902 are only updated when a 8902 statement is executed.

  4. In general, MET/CAL does not check to make sure that a special function specified is compatible with other 8902 settings specified in the 8902 and M8902 FSCs. The exception is special function 27.3, which is used to enter and enable the 8902S frequency offset mode. When the Tolerance field specifies 27.3SP, the M8902 Nominal field must specify the frequency of the local oscillator applied to the 11793A Microwave Converter.

MOD1

This field specifies FM De-Emphasis.

FM De-Emphasis entered as: [numeric][prefix]T.

blank NA or Pre-Display and FM De-Emphasis off

Rules:

  1. Allowed values of FM De-Emphasis are: 25us, 50us, 75us, and 750us.
  2. Pre-Display is turned on whenever De-Emphasis is specified.
  3. The M8902 MOD1 field may only specify FM De-Emphasis when the 8902 MOD3 field specifies FM.

MOD2

This field specifies the High-Pass Filter:

H0 | All Off
H1 | 50 Hz
H2 | 300 Hz

Rules:

  1. H0 is automatically inserted in the MOD2 field if no MOD2 field code is entered.

MOD3

This field specifies the Low-Pass Filter:

L0 | All Off
L1 | 3 kHz
L2 | 15 kHz
L3 | >20 kHz

Rules:

  1. L0 is automatically inserted in the MOD3 field if no MOD3 field code is entered.

MOD4

This field specifies the external audio input.

X | External Audio Input
blank |

CON

This field specifies the Detector:

P+ | Peak +
P- | Peak -
P+- | Peak +-/2
HLD | Peak Hold
AVG | Average (RMS Calibrated)
RMS | RMS
D5 | 1 kHz DISTN
D6 | 400 Hz DISTN
blank | Not applicable

Rules:

8902 MOD3 | M8902 NOMINAL | M8902 CON
AM | mod-freq | P+, P-, P+-, HLD, AVG, RMS
FM | mod-freq | P+, P-, P+-, HLD, AVG, RMS
PM | mod-freq | P+, P-, P+-, HLD, AVG, RMS
FA | blank | blank
RF | blank | blank
TL | blank | blank
AF | blank | blank
AD | blank | RMS, D5, D6
CA | mod-freq | blank
CF | mod-freq | blank
CP | blank | blank

Examples

Refer to 8902 FSC.


8903

Instrument FSC

Description

The 8903 FSC programs the Hewlett-Packard 8903A or 8903B Audio Analyzer to measure AC Level, DC Level, Distortion, and Signal-to-Noise Ratio and the Hewlett-Packard 8903E Distortion Analyzer to measure AC Level, DC Level, and Distortion.

When the 8903 and M8903 FSCs are used to control an HP 8903A or 8903E, you must configure the instrument as an "HP 8903B" as shown in the drop-down list in the "Add Instrument" configure dialog. In addition, select the correct 8903 Model Suffix in the MET/CAL Configuration setting to match the instrument you are using.

Functional Capability

FUNCTION | MOD3 | NOMINAL | MOD1

AC Level

AL

0.0001 mV to 300 V

20 Hz to 150 kHz

AL | -160 dBm to +30 dBm | 20 Hz to 150 kHz
DC Level | DL | 0 V to 300 V
Frequency | AF | 20 Hz to 150 kHz | 5 mV to 300 V
AF | 20 Hz to 150 kHz | -46.02 dBm to +49.54 dBm
Distortion | AD | 0% to 100% | 20 Hz to 100 kHz
AD | -99.99 dB to 0 dB | 20 Hz to 100 kHz
Source 1 | 0.6 mV to 6 V | 20 Hz to 100 kHz
-62.21 dBm to 17.78 dBm | 20 Hz to 100 kHz
  1. 8903B only. To use the source and a measurement function simultaneously, simply apply the source with a 8903 Setup statement (MOD4 = S) followed by a 8903 statement specifying the measurement function desired. The source will be turned off when an evaluation occurs except when ASK- Q is in effect.

Parameters

RANGE

This field specifies the UUT range as described in the RANGE Field topic.

NOMINAL

This field specifies the expected measured value or a reset.

  • AC Level entered as: [numeric][prefix]V or D.
  • DC Level entered as: [numeric][prefix]V.
  • Frequency entered as: [numeric][prefix]H.
  • Distortion entered as: [numeric][prefix]pct or dB.
  • Source Amplitude entered as: [numeric][prefix]V or D.

Rules:

  • See Functional Capability table.
  • When the NOMINAL field contains only units, the value is obtained from memory register MEM. In this case the MOD1 field MUST contain a value.

TOLERANCE

This field specifies the UUT tolerance as described in the TOLERANCE Field topic.

MOD1

This field specifies the frequency.

Frequency entered as [numeric][prefix]H.

Source Frequency entered as: [numeric][prefix]H.

blank not applicable

Rules:

  1. See Functional Capability table.
  2. When the MOD1 field contains only units, the value is obtained from memory register MEM. In this case the NOMINAL field MUST contain a value.

MOD2

This field is not used.

MOD3

This field specifies the measurement type:

AD | Distortion
AF | Frequency
AL | AC Level
DL | DC Level
blank | Source

Rules:

  1. See Functional Capability table.

MOD4

This field specifies the type of test being performed as described in the MOD4 Field topic.

CON

This field specifies the source output impedance.

L | 50 Ω
blank | 600 Ω or not applicable

Rules:

  • The CON field must be blank when the MOD3 field is not blank (analyzer).

Use of Standard Memory Locations and Results Reporting

System memory locations MEM and MEM1 are used. For more information, refer to the Use of Standard Memory Registers topic.

Examples

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
# -----  Reset  -----
  1.001  M8903        *
  1.002  8903         *                                                 S
  1.003  DISP         Connect 8902A MODULATION OUTPUT to the 8903B INPUT HIGH.
  1.003  DISP
  1.003  DISP         Connect 8903B OUTPUT HIGH to the UUT MOD INPUT.
  1.003  DISP
  1.003  DISP         Ensure that both the HP 8903B INPUT and OUTPUT "FLOAT"
  1.003  DISP         switches are set for 'grounded' operation.
  1.004  M8902        1kH                                         H0 L0    P+-
  1.005  M8903                                                    H0 L2    RMS
# -----  Source  -----
  1.006  8903         1.4142V                      1kH                  S
  1.007  8902         30.0pct                      0.4MH             AM N
# -----  Distortion  -----
  1.008  8903         0.000pct       1.5U          1kH               AD
  2.001  M8903        *
# -----  AC Level  -----
  2.002  8903         10.0mV         0.2U          400H              AL
  3.001  8903         -10D                         400H              AL N
# -----  DC Level  -----
  3.002  8903         35.0V          +100%                           DL


M8903

Auxiliary Instrument Setup FSC

Description

The M8903 FSC provides the additional program functions for Hewlett-Packard 8903B and 8903E which are not addressed by the 8903 FSC. These functions include special functions, plug-in and low-pass filters, and detector.

RANGE

This field is used not used.

NOMINAL

This field specifies a reset.

"*" | Reset
blank | Not applicable

Rules:

  1. When the M8903 FSC Nominal field specifies a reset the following parameter values are set:

    Source | Off
    Plug-in Filters | Off
    Low-Pass Filter | All Off
    Detector | RMS
    Special Functions | Off or Zero Suffix setting, which ever applies

TOLERANCE

This field is used to specify special functions.

Special Function entered as: numericSP.

blank not applicable

Rules:

  1. Special Function codes supported:

    Tolerance Field | Special Function
    1.0SP to 1.19SP | Input Level Range (except DC Level)
    2.0SP to 2.4SP | Input Level Range (DC Level only)
    3.0SP to 3.4SP | Post Notch Gain
    5.0SP to 5.7SP | Post Notch Detector Response
    6.0SP to 6.1SP | Notch Tuning
    8.0SP to 8.3SP | Error Disable
    12.0SP to 12.9SP | Signal-to-Noise Measurements Delay
    14.0SP to 14.1SP | Time Between Measurements
    16.0SP to 16.1SP | Signal-to-Noise Display Resolution
    19.0SP to 19.NNNSP | Display Level in Watts

  2. See the 8903B Operator's Manual for a description of individual Special Function codes.

  3. Multiple M8903 statements may be used to specify more than one special function for a measurement. A special function specification is retained until a M8903 reset is executed. However the actual special function settings of the 8903 are only updated when a 8903 statement is executed.
  4. MET/CAL does not check to make sure that a special function specified is compatible with other 8903 settings specified in the 8903 and M8903 FSCs.

MOD1

This field is not used.

MOD2

This field specifies the Plug-in HP/BP Filters:

H0 | All Off
H1 | Left Plug-in Filter on
H2 | Right Plug-in Filter on

Rules:

  1. H0 is automatically inserted in the MOD2 field if no MOD2 field code is entered.

MOD3

This field specifies the Low-Pass Filter:

L0 | All Off
L1 | 30kHz
L2 | 80kHz

Rules:

  1. L0 is automatically inserted in the MOD3 field if no MOD3 field code is entered.

MOD4

This field is not used.

CON

This field specifies the Detector:

RMS | RMS
AVG | Average

Rules:

  1. RMS is automatically inserted in the CON field if no CON field code is entered.

Examples

Refer to 8903 FSC.


33120

Instrument FSC

Description

The 33120 FSC programs the Hewlett-Packard 33120A Function Generator to output sine, square, triangle, positive ramp, and negative ramp waveforms.

If the 33120A is to be controlled via its serial port, do not use the PORT FSC port configuration special construction, [P9600,N,...], to set the baud rate, parity, etc. of the port used to control the 33120A. MET/CAL executes a "Test" function for each System Instrument prior to executing any procedure statements, therefore the settings of the port used to controlling the 33120A must be set correctly before a procedure is executed. The 33120A does not support standard hardware flow control using the RS-232C request-to-send (RTS) and clear-to-send (CTS) lines. If the 33120A is connected to a standard serial port (COM1, COM2, ..., COM16), select the "Ports" application in the Windows control panel to choose the proper settings. Select "Flow Control = None". Selecting "Hardware" sets RTS/CTS flow control. The 33120A uses DTR/DSR hardware flow control. The MET/CAL 33120A driver will automatically set DTR/DSR flow control (i.e. DTR/DSR is supported at a lower level even though the Control Panel does not support direct selection of DTR/DSR flow control). The 33120A cannot be connected to the 5500A, 5520A, 5800A, or 5820A UUT "Pass-Through" Serial port. These calibrators do not support the DTR/DSR hardware flow control required for communication with the 33120A.

Functional Capability

Waveform | Frequency
Sine | 100 μHz to 15 MHz
Square | 100 μHz to 15 MHz
Triangle | 100 μHz to 100 kHz
Positive Ramp | 100 μHz to 100 kHz
Negative Ramp | 100 μHz to 100 kHz
Exponential Rise | 100 μHz to 5 MHz
Exponential Fall | 100 μHz to 5 MHz
Sync | 100 μHz to 5 MHz
Cardiac | 100 μHz to 5 MHz

Output Termination | Amplitude
50 Ohm | ±5V (DC), 50mVpp to 10Vpp (AC)
Open Circuit | ±10V (DC), 100mVpp to 20Vpp (AC)

Parameters

RANGE

This field specifies the UUT range as described in the RANGE Field topic.

NOMINAL

This field specifies the starting Nominal value of the stimulus output or expected UUT reading for the test.

  • Voltage (DC or RMS) entered as: [numeric][prefix]V
  • Voltage (Peak-to-Peak) entered as: [numeric][prefix]Vpp
  • dBm entered as: [numeric][prefix]D
  • Frequency entered as: [numeric][prefix]H
  • Period entered as: [numeric][prefix]T

Rules:

  • The NOMINAL field may specify dBm only when the MOD2 field specifies SI.
  • The NOMINAL field may specify Voltage peak-to-peak, Frequency, or Period only when the MOD2 field specifies SI, SQ, TI, +R, -R, +X, -X, SY, CD, or OI (i.e. MOD2 is not blank).
  • When the NOMINAL field contains only units, the value is obtained from the memory register MEM.
  • When the NOMINAL field contains only units and the MOD1 field is not blank, the MOD1 field must specify a value.

TOLERANCE

This field specifies the UUT tolerance as described in the TOLERANCE Field topic.

MOD1

This field specifies amplitude or frequency or period for AC functions.

  • Voltage (RMS) entered as: [numeric][prefix]V
  • Voltage (Peak-to-Peak) entered as: [numeric][prefix]Vpp
  • dBm entered as: [numeric][prefix]D
  • Frequency entered as [numeric][prefix]H.
  • Period entered as [numeric][prefix]T.
  • blank DC or Noise

Rules:

  • The MOD1 field may specify dBm only when the MOD2 field specifies SI.
  • The MOD1 field must be blank when the MOD2 field specifies OI (Noise).
  • The MOD1 field may specify frequency or period only when the NOMINAL field specifies voltage or decibels.
  • The MOD1 field may specify voltage or decibels only when the NOMINAL field specifies frequency or period.
  • When the MOD1 field contains only units, the value is obtained from memory register MEM. In this case the NOMINAL field MUST contain a value.

MOD2

This field specifies the function (waveform type).

SI | Sine
SQ | Square
TI | Triangle
+R | Positive Ramp
-R | Negative Ramp
+X | Exponential Rise
-X | Exponential Fall
SY | Sync Signal
CD | Cardiac Signal
OI | Noise

Rules:

  • SI is inserted automatically in the MOD2 field when the MOD1 field is not blank and no MOD2 code is entered.
  • The MOD2 field must be blank or OI when the MOD1 field is blank (i.e. DC Voltage or Noise is specified).

MOD3

This field is not used.

MOD4

This field specifies the type of test being performed as described in the MOD4 Field topic.

CON

This field specifies the UUT connection.

L 50 Ohm termination

Rules:

  • When the CON field is L the output is expected to be terminated with 50 Ohms. This can be accomplished by using a 50 Ohm terminator at the UUT or setting the UUT input impedance to 50 Ohms.
  • L is automatically inserted the CON field when the amplitude in the Nominal or MOD1 field is expressed in dBm.
  • If ASK- W or ASK- V is in effect, the procedure writer must use a DISP FSC to prompt the operator to terminate the output signal at the UUT.

Use of Standard Memory Locations and Results Reporting

System memory locations MEM and MEM1 are used. For more information, refer to the Use of Standard Memory Registers topic.

Examples

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
# ----- Reset -----
  1.001  33120        *                                                 S
# ----- DC Voltage -----
  1.002  33120  2     1.9V           2% 0.4U                               L
# ----- Sine Wave -----
  2.001  33120  400   3.500V         7.4U          20kH           SI       L
  3.001  33120        -10D           1U            100H           SI       L
# ----- Square Wave w/DC offset -----
  4.001  M33120       0.5Voff
  4.002  33120        1Vpp                         1kH            SQ    S  L
# ----- Triangle Wave -----
  4.003  M33120       *
  4.004  33120        75mVpp                       10kH           TI    S  L
# ----- Positive Ramp -----
  4.005  33120        1.0Vpp                       100kH          +R    S  L
# ----- Negative Ramp -----
  4.006  33120        1.0Vpp                       5MH            -R    S
# ----- Frequency -----
  4.007  33120  1000  800.0H         0.1% 0.1U     300mV          SI


M33120

Instrument Setup FSC

Description

The M33120 FSC is used to specify modulation, modulation frequency, AM depth, FM deviation, duty cycle, and DC offset. The M33120 FSC is ignored when the 33120 FSC specifies DC voltage.

Functional Capability

Modulation Frequency | 10 mHz to 20 kHz (AM), 10 kHz (FM)
AM Depth: | 0 % to 120 %
FM Deviation: | 10 mHz to 7.5 MHz
Duty cycle: | 20 % to 80 % ≤ 5 MHz, 40 % to 60 % > 5 MHz.
DC Offset: | 0 V to 5 V (50 Ω), 0 V to 10 V (open circuit) restricted by: |Voff| + (Vpp / 2) ≤ Vmax and |Voff| ≤ 2 x Vpp

Parameters

RANGE

This field specifies one of the following:

INT | Internal modulation source
EXT | External modulation source
blank | no modulation

Rules:

  • The Range field must "INT" or "EXT" when the Nominal field specifies modulation frequency.

NOMINAL

This field specifies one of the following:

  • Modulation Frequency is entered as [numeric][prefix]H.
  • DC Offset entered as: [numeric][prefix]Voff
"*" | reset to default values
blank | no modulation and no DC offset

Rules:

  • The Nominal field must specify the modulation frequency when the Range field specifies "INT" or "EXT".
  • If the Nominal field does not contain a value the value is taken from memory register MEM.

TOLERANCE

This field is not used.

MOD1

The MOD1 field specifies the following:

  • AM Depth entered as: [numeric][prefix]pct.
  • FM Deviation entered as: [numeric][prefix]H.
  • Duty Cycle entered as: [numeric][prefix]pct.
blank no modulation and 50% Duty Cycle (square wave only)

Rules:

  • The MOD1 field must specify AM depth when the Range field specifies an external modulation source.
  • The MOD1 field must specify AM depth or FM deviation when the Range field specifies an internal modulation source.
  • When two frequency values are entered for a M33120 FSC, the first is taken to be the Modulation Frequency and the second is taken to be the FM deviation.
  • When the MOD1 field specifies FM deviation, the deviation must be less than or equal to the frequency specified in the 33120 FSC Nominal or MOD1 field.
  • When a frequency value and a percent value are entered for a M33120 FSC, the frequency is taken to be the Modulation Frequency and the percent is taken to be the AM depth.
  • When a percent value is entered without also entering a frequency value, the percent is taken to be duty cycle.
  • The M33120 MOD1 field may specify duty cycle only when the 33120 FSC MOD2 field is "SQ" (square wave).
  • If the MOD1 field does not contain a value the value is taken from memory register MEM.

MOD2

This field is not used.

MOD3

This field is not used.

MOD4

This field is not used.

CON

This field is not used.

Examples

See 33120 FSC.


33220

Instrument FSC

Description

The 33220 FSC programs the Agilent 33220A Function Generator to output DC volts and sine, square, ramp, pulse, noise, exponential rise, exponential fall, sync, and cardiac waveforms.

The 33220A must be connected to GPIB port 0. USB and Ethernet control of the 33220A is not supported.

Functional Capability

Waveform | Characteristics
Sine |
Frequency | 1 µHz to 20 MHz
Square |
Frequency | 1 µHz to 20 MHz
Ramp, Triangle |
Frequency | 1 µHz to 200 kHz
Duty Cycle | 0% to 100%
 | 50%: triangle
 | 0%: negative ramp
 | 100%: positive ramp
Pulse |
Period | 200 ns to 2000 s, 500 µHz to 5 MHz
Width | 20 ns to 10 s
Edge Time | 5 ns to 100 ns
Exponential Rise | 1 µHz to 6 MHz
Exponential Fall | 1 µHz to 6 MHz
Sync | 1 µHz to 6 MHz
Cardiac | 1 µHz to 6 MHz
Noise | 9 MHz bandwidth

Amplitude
+/-5 V (DC, 50 Ohm)
+/-10 V (DC, open circuit)
10 mVpp to 10 Vpp (AC, 50 Ohm)
20 mVpp to 20 Vpp (AC, open circuit)

Parameters

RANGE

This field specifies the UUT range as described in the RANGE Field topic.

NOMINAL

This field specifies the starting Nominal value of the stimulus output or expected UUT reading for the test.

  • Voltage (DC or RMS) entered as: [numeric][prefix]V
  • Voltage (Peak-to-Peak) entered as: [numeric][prefix]Vpp
  • Decibels entered as: [numeric][prefix]D
  • Frequency entered as: [numeric][prefix]H
  • Period entered as: [numeric][prefix]T
  • Pulse Width entered as: [numeric][prefix]T or H

Rules:

  • The NOMINAL field may specify Voltage peak-to-peak, Frequency, or Period only when the MOD2 field specifies SI, SQ, LR, TI, +R, -R, +X, -X, SY, CD, or OI (i.e MOD2 is not blank).
  • The NOMINAL field may specify Decibels only when the MOD2 field specifies SI.
  • The NOMINAL field may specify Pulse Width only when the MOD2 field specifies PU.
  • When the NOMINAL field contains only units, the value is obtained from the memory register MEM.
  • When the NOMINAL field contains only units and the MOD1 field is not blank, the MOD1 field must specify a value.

TOLERANCE

This field specifies the UUT tolerance as described in the TOLERANCE Field topic.

MOD1

This field specifies amplitude or frequency or period for AC functions.

  • Voltage (RMS) entered as: [numeric][prefix]V
  • Voltage (Peak-to-Peak) entered as: [numeric][prefix]Vpp
  • Decibels entered as: [numeric][prefix]D
  • Frequency entered as [numeric][prefix]H.
  • Period entered as [numeric][prefix]T.
  • blank DC or Noise

Rules:

  • The MOD1 field may specify Decibels only when the MOD2 field specifies SI.
  • The MOD1 field must be blank when the MOD2 field specifies OI (Noise).
  • The MOD1 field may specify frequency or period only when the NOMINAL field specifies voltage or decibels.
  • The MOD1 field may specify voltage or decibels only when the NOMINAL field specifies frequency, period, or pulse width.
  • When the MOD1 field contains only units, the value is obtained from memory register MEM. In this case the NOMINAL field MUST contain a value.

MOD2

This field specifies the function (waveform type).

SI | Sine
SQ | Square
LR | Ramp (general)
TI | Triangle (same as LR with 50% duty cycle)
+R | Positive Ramp (same as LR with 100% duty cycle)
-R | Negative Ramp (same as LR with 0% duty cycle)
PU | Pulse
OI | Noise
+X | Exponential Rise
-X | Exponential Fall
SY | Sync Signal
CD | Cardiac Signal
blank | DC Volts

Rules:

  • SI is inserted automatically in the MOD2 field when the MOD1 field is not blank and no MOD2 code is entered.
  • The MOD2 field must be blank or OI when the MOD1 field is blank (i.e. DC Voltage or Noise is specified).

MOD3

This field specifies the waveform polarity.

PI | Polarity Inverted
blank | Polarity Normal

Rules:

  • The MOD3 field must be blank when the MOD2 field is blank (DCV).

MOD4

This field specifies the type of test being performed as described in the MOD4 Field topic.

CON

This field specifies the UUT connection.

L | Terminated (see M33220 CON field description)
blank | Unterminated (open circuit)

Rules:

  • When the CON field is L the output is expected to be terminated. This can be accomplished by using a terminator at the UUT or setting the UUT input impedance. The default termination is 50 Ohms. 75, 300, or 600 Ohm termination may be selected using the M33220 FSC.
  • L is automatically inserted the CON field when the amplitude in the Nominal or MOD1 field is expressed in dBm.
  • If ASK- W or ASK- V is in effect, the procedure writer must use a DISP FSC to prompt the operator to terminate the output signal at the UUT.

Use of Standard Memory Locations and Results Reporting

System memory locations MEM and MEM1 are used. For more information, refer to the Use of Standard Memory Registers topic.

Examples

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
# -----  Reset -----
  1.001  M33220       *
  1.002  33220        *                                                 S
# -----  DC Voltage -----
  1.003  33220  2     1.9V           2% 0.4U                               L
# -----  Sine Wave -----
  2.001  33220  400   3.500V         7.4U          20kH           SI       L
  3.001  33220        -10D           1U            100H           SI       L
# -----  Square Wave w/DC offset -----
  4.001  M33220                                    0.5Voff
  4.002  33220        1Vpp                         1kH            SQ    S  L
# -----  Ramp Wave -----
  4.003  33220        75mVpp                       10kH           LR    S  L
# -----  Triangle Wave -----
  4.004  M33220       *
  4.005  33220        75mVpp                       10kH           TI    S  L
# -----  Positive Ramp -----
  4.006  33220        1.0Vpp                       100kH          +R    S  L
# -----  Negative Ramp -----
  4.007  33220        1.0Vpp                       100kH          -R    S  L
# -----  Pulse -----
  4.008  M33220 PULSE 10uT           5nT
  4.009  33220        1Vpp                         1mT            PU    S  L
# -----  Exponential Rise -----
  4.010  M33220       *
  4.011  33220        1Vpp                         1kH            +X    S  L
# -----  Exponential Fall -----
  4.012  33220        1Vpp                         1kH            -X    S  L
# -----  Sync -----
  4.013  33220        1Vpp                         1kH            SY    S  L
# -----  Cardiac -----
  4.014  33220        1Vpp                         1kH            CD    S  L
# -----  Noise -----
  4.015  33220        1Vpp                                        OI    S  L
# -----  Frequency -----
  4.016  33220  1000  800.0H         0.1% 0.1U     300mV          SI       L
# -----  Burst using IEEE FSC ----
# -----  Pulse Period : 1us
# -----  Pulse Width : 10ns
# -----  Transition Time : 5ns
# -----  High : 1V
# -----  Low : 0V
# -----  Number of Cycles : 2
# -----  Interval Period : 100us
  5.001  IEEE         [@33220]PULS:PER 1E-6;WIDT 10e-9;TRAN 5e-9
  5.002  IEEE         [@33220]VOLT:LOW 0;HIGH 1
  5.003  IEEE         [@33220]BURST:STATE ON;MODE TRIG;NCYC 2;INT:PER 100e-6
  5.004  IEEE         [@33220]OUTP ON;*OPC?[I!]


33250

Instrument FSC

Description

The 33250 FSC programs the Agilent 33250A Function Generator to output DC volts and sine, square, ramp, pulse, noise, exponential rise, exponential fall, sync, and cardiac waveforms.

If the 33250A is to be controlled via its serial port, do not use the PORT FSC port configuration special construction, [P9600,N,...], to set the baud rate, parity, etc. of the port used to control the 33250A. MET/CAL executes a "Test" function for each System Instrument prior to executing any procedure statements, therefore the settings of the port used to controlling the 33250A must be set correctly before a procedure is executed.

Functional Capability

Waveform | Characteristics
Sine |
Frequency: | 1 μHz to 80 MHz
Square |
Frequency: | 1 μHz to 80 MHz
Ramp |
Frequency: | 1 μHz to 1 MHz
Duty Cycle: | 0 % to 100 %
 | 50 %: triangle
 | 0 %: negative ramp
 | 100 %: positive ramp
Pulse |
Period: | 20 ns to 2000 s, 500 uHz to 50 MHz
Width: | 8 ns to 1999.9 s
Edge Time: | 5 ns to 1 ms
Exponential Rise | 1 μHz to 25 MHz
Exponential Fall | 1 μHz to 25 MHz
Sync | 1 μHz to 25 MHz
Cardiac | 1 μHz to 25 MHz
Noise | 50 MHz bandwidth

Amplitude
± 5 V (DC)
10 mVpp to 10 Vpp (AC, 50 Ω)
20 mVpp to 20 Vpp (AC, open circuit)

Parameters

RANGE

This field specifies the UUT range as described in the RANGE Field topic.

NOMINAL

This field specifies the starting Nominal value of the stimulus output or expected UUT reading for the test.

  • Voltage (DC or RMS) entered as: [numeric][prefix]V
  • Voltage (Peak-to-Peak) entered as: [numeric][prefix]Vpp
  • dBm entered as: [numeric][prefix]D
  • Frequency entered as: [numeric][prefix]H
  • Period entered as: [numeric][prefix]T
  • Pulse Width entered as: [numeric][prefix]T or H

Rules:

  • The NOMINAL field may specify Voltage peak-to-peak, Frequency, or Period only when the MOD2 field specifies SI, SQ, LR, TI, +R, -R, +X, -X, SY, CD, or OI (i.e. MOD2 is not blank).
  • The NOMINAL field may specify dBm only when the MOD2 field specifies SI.
  • The NOMINAL field may specify Pulse Width only when the MOD2 field specifies PU.
  • When the NOMINAL field contains only units, the value is obtained from the memory register MEM.
  • When the NOMINAL field contains only units and the MOD1 field is not blank, the MOD1 field must specify a value.

TOLERANCE

This field specifies the UUT tolerance as described in the TOLERANCE Field topic.

MOD1

This field specifies amplitude or frequency or period for AC functions.

  • Voltage (RMS) entered as: [numeric][prefix]V
  • Voltage (Peak-to-Peak) entered as: [numeric][prefix]Vpp
  • dBm entered as: [numeric][prefix]D
  • Frequency entered as [numeric][prefix]H.
  • Period entered as [numeric][prefix]T.
  • blank DC or Noise

Rules:

  • The MOD1 field may specify dBm only when the MOD2 field specifies SI.
  • The MOD1 field must be blank when the MOD2 field specifies OI (Noise).
  • The MOD1 field may specify frequency or period only when the NOMINAL field specifies voltage or decibels.
  • The MOD1 field may specify voltage or decibels only when the NOMINAL field specifies frequency, period, or pulse width.
  • When the MOD1 field contains only units, the value is obtained from memory register MEM. In this case the NOMINAL field MUST contain a value.

MOD2

This field specifies the function (waveform type).

SI | Sine
SQ | Square
LR | Ramp (general)
TI | Triangle (same as LR with 50% duty cycle)
+R | Positive Ramp (same as LR with 100% duty cycle)
-R | Negative Ramp (same as LR with 0% duty cycle)
PU | Pulse
OI | Noise
+X | Exponential Rise
-X | Exponential Fall
SY | Sync Signal
CD | Cardiac Signal
blank | DC Volts

Rules:

  • SI is inserted automatically in the MOD2 field when the MOD1 field is not blank and no MOD2 code is entered.
  • The MOD2 field must be blank or OI when the MOD1 field is blank (i.e. DC Voltage or Noise is specified).

MOD3

This field specifies the waveform polarity.

PI | Polarity Inverted
blank | Polarity Normal

Rules:

  • The MOD3 field must be blank when the MOD2 field is blank (DCV).

MOD4

This field specifies the type of test being performed as described in the MOD4 Field topic.

CON

This field specifies the UUT connection.

L | Terminated (see M33250 CON field description)
blank | Unterminated (open circuit)

Rules:

  • When the CON field is L the output is expected to be terminated. This can be accomplished by using a terminator at the UUT or setting the UUT input impedance. The default termination is 50 Ω. 75, 300, or 600 Ω termination may be selected using the M33250 FSC.
  • L is automatically inserted the CON field when the amplitude in the Nominal or MOD1 field is expressed in dBm.
  • If ASK- W or ASK- V is in effect, the procedure writer must use a DISP FSC to prompt the operator to terminate the output signal at the UUT.

Use of Standard Memory Locations and Results Reporting

System memory locations MEM and MEM1 are used. For more information, refer to the Use of Standard Memory Registers topic.

Examples

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
# -----  Reset -----
  1.001  M33250       *
  1.002  33250        *                                                 S
# -----  DC Voltage -----
  1.003  33250  2     1.9V           2% 0.4U                               L
# -----  Sine Wave -----
  2.001  33250  400   3.500V         7.4U          20kH           SI       L
  3.001  33250        -10D           1U            100H           SI       L
# -----  Square Wave w/DC offset -----
  4.001  M33250                                    0.5Voff
  4.002  33250        1Vpp                         1kH            SQ    S  L
# -----  Ramp Wave -----
  4.003  33250        75mVpp                       10kH           LR    S  L
# -----  Triangle Wave -----
  4.004  M33250       *
  4.005  33250        75mVpp                       10kH           TI    S  L
# -----  Positive Ramp -----
  4.006  33250        1.0Vpp                       100kH          +R    S  L
# -----  Negative Ramp -----
  4.007  33250        1.0Vpp                       1MH            -R    S  L
# -----  Pulse -----
  4.008  M33250 PULSE 10uT           5nT
  4.009  33250        1Vpp                         1mT            PU    S  L
# -----  Exponential Rise -----
  4.010  M33250       *
  4.011  33250        1Vpp                         1kH            +X    S  L
# -----  Exponential Fall -----
  4.012  33250        1Vpp                         1kH            -X    S  L
# -----  Sync -----
  4.013  33250        1Vpp                         1kH            SY    S  L
# -----  Cardiac -----
  4.014  33250        1Vpp                         1kH            CD    S  L
# -----  Noise -----
  4.015  33250        1Vpp                                        OI    S  L
# -----  Frequency -----
  4.016  33250  1000  800.0H         0.1% 0.1U     300mV          SI       L
# -----  Burst using IEEE FSC ----
# -----  Pulse Period: 1us
# -----  Pulse Width: 10ns
# -----  Transition Time: 5ns
# -----  High : 1V
# -----  Low : 0V
# -----  Number of Cycles: 2
# -----  Interval Period: 100us
  5.001  IEEE         [@33250]PULS:PER 1E-6;WIDT 10e-9;TRAN 5e-9
  5.002  IEEE         [@33250]VOLT:LOW 0;HIGH 1
  5.003  IEEE         [@33250]BURST:STATE ON;MODE TRIG;NCYC 2;INT:PER 100e-6
  5.004  IEEE         [@33250]OUTP ON;*OPC?[I!]


M33250

Instrument Setup FSC

Description

The M33250 FSC is used to specify parameters not otherwise specified in the 33250 FSC.

Functional Capability

Pulse Width: | 8 ns to 1999.9 s
Pulse Period: | 20 ns to 2000 s
PRF: | 500 uHz to 50 MHz
Modulation Source: | internal or external
Modulation Frequency: | 2 mHz to 20 kHz
AM Depth: | 0 % to 120 %
FM Deviation: | 5 Hz to 40.05 MHz
FSK "hop" Frequency: | 1 μHz to 80 MHz
FSK Rate: | 2 mHz to 100 kHz (internal)
 | 2 mHz to 1 MHz (external)
Duty cycle:
Square | 20 % to 80 % ≤ 25 MHz
 | 40 % to 60 % > 25 MHz & ≤50 MHz
 | 50 % > 50 MHz
Ramp | 0 % to 100 %
DC Offset: | -5 V to 5 V restricted by:
 | |Voff| + (Vpp / 2) ≤ Vmax and
 | |Voff| ≤ 2 x Vpp
Frequency Reference: | internal or external
Output Termination | 50, 75, 300, 600 Ω

Parameters

Units Symbols

Units Symbol | Name | Quantity
H | Hertz | frequency, PRF, 1 / pulse width, modulation frequency, FM deviation, FSK rate, or FSK “hop” frequency
T | Time | period, pulse width, or edge time
pct | percent | duty cycle or AM depth
Voff | Volts offset | DC offset

Modulated Waveforms

Modulation | RANGE | NOMINAL | TOLERANCE | MOD3
AM Modulation | INT|EXT | H | pct |
FM Modulation | INT|EXT | H | H |
FSK Modulation | INT|EXT | H | H | F
Note: blank entries in the above table are significant and must be blank. FSC field inter-dependencies not expressed in this table are listed under "Rules" for the appropriate parameter.

Unmodulated Waveforms

Waveform | 33250 MOD2 | M33250 RANGE | M33250 NOMINAL | M33250 TOLERANCE | M33250 MOD1
Square | SQ |  |  | [pct] | [Voff]
Linear Ramp | LR |  |  | [pct] | [Voff]
Triangle | TI
Positive Ramp | -R
Negative Ramp | +R
Pulse | PU | PER|PULSE | T|H | T | [Voff]
Noise OI |  |  |  |  |
Exp Rise | +X |  |  | [Voff] |
Exp Fall | -X |  |  |  | [Voff]
Cardiac | CD |  |  |  | [Voff]
Note: blank entries in the above table are significant and must be blank. FSC field inter-dependencies not expressed in this table are listed under "Rules" for the appropriate parameter.

RANGE

This field specifies one of the following:

EXT | External modulation source
INT | Internal modulation source
PE | Pulse period or Pulse Repetition Frequency
PULSE | Pulse width
blank | not applicable

NOMINAL

This field specifies one of the following:

  • Pulse Width entered as [numeric][prefix]T or H.
  • Pulse Period entered as [numeric][prefix]T.
  • Pulse Repetition Frequency (PRF) entered as [numeric][prefix]H.
  • Modulation Frequency entered as [numeric][prefix]H.
  • FSK Rate entered as [numeric][prefix]H.
  • "*" reset to default values
  • blank not applicable

Rules:

  • If the Nominal field does not contain a value the value is taken from memory register MEM.

TOLERANCE

This field specifies one of the following:

  • Duty Cycle or Ramp Symmetry entered as: [numeric][prefix]pct.
  • Edge Time entered as: [<numerix>][prefix]T.
  • AM Depth entered as: [numeric][prefix]pct.
  • FM Deviation entered as: [numeric][prefix]H.
  • FSK "hop" frequency entered as: [numeric][prefix]H.
  • blank 50% Square Duty Cycle, 100% Ramp Symmetry, no modulation

Rules:

  • If the Tolerance field does not contain a value the value is taken from memory register MEM.
  • If the Range field is PER or PULSE and the no edge time is entered 5nT is automatically entered in the Tolerance field.
  • A percentage entered in the tolerance field is interpreted as follows:
Waveform | 33250 MOD2 | M33250 RANGE | M33250 TOLERANCE (pct)
Square | SQ |  | duty cycle
Linear Ramp | LR |  | symmetry
(na) | (na) | INT|EXT | AM Depth

MOD1

The MOD1 field specifies the following:

  • DC Offset entered as: [numeric][prefix]Voff
  • blank no DC offset, or not applicable

Rules:

  • If the MOD1 field does not contain a value the value is taken from memory register MEM.

MOD2

This field is not used.

MOD3

This field is used to specify Frequency-Shift Keying (FSK) modulation.

F | Enable FSK modulation
blank | FM modulation or not applicable

Rules:

  • If the MOD3 field may specify FSK ("F") only when the Tolerance field specifies a "hop" frequency.

This field is not used.

CON

The CON field is used to specify the output termination:

5Z | 50 Ohm
7Z | 75 Ohm
3Z | 300 Ohm
6Z | 600 Ohm
blank | see rules below

Rules:

  • The M33250 CON field must be blank when the 33250 FSC CON field is blank.
  • When the M33250 CON field is blank and the 33250 FSC CON field is "L", the output termination is 50 Ohm.

Examples

See 33250 FSC.


34401

Instrument FSC

Description

The 34401 FSC programs the Agilent and HP 34401A Multimeters to measure DC voltage, AC voltage, DC current, AC current, resistance, conductance, frequency, and period.

When the 34401 FCS is used to control an Agilent 34401A, you must configure the instrument as an "HP 34401A" as shown in the drop-down list in the "Add Instrument" configure dialog. The 34401A remote language must be set to SCPI when the 34401A is to be controlled using the 34401 FSC.

To set or verify that the 34401A language is set to SCPI, perform the following steps via the 34401A front panel:

  1. Press "Shift" then MENU On/Off.
  2. Press ">" arrow key until "E: I/O MENU" is displayed.
  3. Press "v" arrow key to enter I/O MENU.
  4. Press ">" arrow key until "5: LANGUAGE" is displayed.
  5. Press "v" arrow key to enter LANGUAGE.
  6. Press ">" arrow key until "SCPI" is displayed.

If the 34401A is to be controlled via its serial port, do not use the PORT FSC port configuration special construction, [P9600,N,...], to set the baud rate, parity, etc. of the port used to control the 34401A. MET/CAL executes a "Test" function for each System Instrument prior to executing any procedure statements, therefore the settings of the port used to controlling the 34401A must be set correctly before a procedure is executed.

The 34401A does not support standard hardware flow control using the RS-232C request-to-send (RTS) and clear-to-send (CTS) lines.

If the 34401A is connected to a standard serial port (COM1, COM2, ..., COM16), select the "Ports" application in the Windows control panel to choose the proper settings. Select "Flow Control = None". Selecting "Hardware" sets RTS/CTS flow control. The 34401A uses DTR/DSR hardware flow control. The MET/CAL 34401A driver will automatically set DTR/DSR flow control (i.e. DTR/DSR is supported at a lower level even though the Control Panel does not support direct selection of DTR/DSR flow control). The 34401A cannot be connected to the 5500A, 5520A, 5800A, or 5820A UUT "Pass-Through" Serial port. These calibrators do not support the DTR/DSR hardware flow control required for communication with the 34401A.

Functional Capability

Function | NOMINAL | MOD1 | MOD2
DC Voltage | -1000 V to 1000 V
AC Voltage 1 | 0.1 mV to 750 V | 3 Hz to 300 kHz
DC Current | -3 A to 3 A
AC Current | 1 μA to 3 A | 3 Hz to 5 kHz
Resistance | 0 Ω to 119.9999 MΩ
Conductance | >8.4 nS
Frequency | 3 Hz to 300 kHz | 100 mV to 750 V
Period | 3.3 μs to 0.33 s | 100 mV to 750 V
dBm 1 | -66.98 dBm to 70.51 dBm | 3 Hz to 300 kHz | 5Z
-68.75 dBm to 68.75 dBm | 7Z
-74.77 dBm to 62.73 dBm | 3Z
-77.78 dBm to 59.71 dBm | 6Z
  1. Volt-Hertz product not to exceed 87.

Parameters

RANGE

This field specifies the UUT range as described in the RANGE Field topic.

NOMINAL

This field specifies the expected measured value or a reset.

  • Voltage (DC or RMS) entered as: [numeric][prefix]V
  • dBm entered as: [numeric][prefix]D
  • Current entered as [numeric][prefix]A.
  • Resistance entered as [numeric][prefix]Z.
  • Conductance entered as [numeric][prefix]Y.
  • Frequency entered as [numeric][prefix]H.
  • Period entered as [numeric][prefix]T.
  • Reset entered as *.

Rules:

  • The NOMINAL field may specify decibels only when the MOD2 field specifies the reference impedance.

TOLERANCE

This field specifies the UUT tolerance as described in the TOLERANCE Field topic.

MOD1

This field specifies frequency for AC voltage and AC current measurements or voltage for frequency or period measurements.

  • Frequency entered as numeric[prefix]H.
  • Voltage entered as numeric[prefix]V.
  • blank not applicable

Rules:

  • The MOD1 field must be blank when the NOMINAL field specifies resistance or conductance.
  • The MOD1 field may specify frequency only when the NOMINAL field specifies voltage or current.
  • The MOD1 field must specify voltage when the NOMINAL field specifies frequency or period.

MOD2

This field specifies the load impedance that the AC voltage is referenced to.

5Z | 50 Ohm
7Z | 75 Ohm
3Z | 300 Ohm
6Z | 600 Ohm
blank | field not applicable

Rules:

  • The MOD2 field may specify a reference impedance only when the NOMINAL field specifies decibels.

MOD3

This field is not used.

MOD4

This field specifies the type of test being performed as described in the MOD4 Field topic.

CON

This field specifies the UUT connection.

2W | 2-wire
4W | 4-wire

Rules:

  • The CON field may specify a 4W only when the NOMINAL field specifies resistance or conductance.

Use of Standard Memory Locations and Results Reporting

System memory locations MEM and MEM1 are used. For more information, refer to the Use of Standard Memory Registers topic.

Examples

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
# -----  Reset -----
  1.001  34401        *                                                 S
# -----  DC Voltage -----
  1.002  34401  10    10V            1% 0.01U                              2W
# -----  AC Voltage -----
  2.001  34401  1000  650V           5%            30kH                    2W
  3.001  34401  1     1V             1% 0.01U      10kH                    2W
# -----  dBm -----
  4.001  34401  A     60.0D          0.1U          1kH            5Z       2W
# -----  DC Current -----
  5.001  34401  4000  350mA          9U                                    2W
# -----  AC Current -----
  6.001  34401  2     1A             3%            60H                     2W
# -----  Resistance -----
  7.001  34401  100   10MZ           1%                                    2W
# -----  Conductance -----
  8.001  34401  100   100nY          5%                                    2W
# -----  Setup Test -----
  9.001  34401        1V                           10kH                 S  2W
# -----  Nominal Setup Test -----
  9.002  34401  1     1V                           10kH                 N  2W
# -----  Comparison Test -----
  9.003  34401  1     1V             1% 0.1U       20kH                 C  2W


34420

Instrument FSC

Description

The 34420 FSC programs the Agilent and Hewlett-Packard 34420A Multimeters to measure DC voltage, DC voltage ratio, DC voltage difference, Resistance, and temperature. The 34420 FSC is also used to program the 34420/SPRT and 34420/PRT to measure temperature.

When the 34420 FSC is used to control an Agilent 34420A, you must configure the instrument as an "HP 34420A" as shown in the drop-down list in the "Add Instrument" configure dialog If the 34420A is to be controlled via its serial port, do not use the PORT FSC port configuration special construction, [P9600,N,...], to set the baud rate, parity, etc. of the port used to control the 34420A. MET/CAL executes a "Test" function for each System Instrument prior to executing any procedure statements, therefore the settings of the port used to controlling the 34420A must be set correctly before a procedure is executed.

The 34420A does not support standard hardware flow control using the RS-232C request-to-send (RTS) and clear-to-send (CTS) lines.

If the 34420A is connected to a standard serial port (COM1, COM2, ..., COM16), select the "Ports" application in the Windows control panel to choose the proper settings. Select "Flow Control = None". Selecting "Hardware" sets RTS/CTS flow control. The 34420A uses DTR/DSR hardware flow control. The MET/CAL 34420A driver will automatically set DTR/DSR flow control (i.e. DTR/DSR is supported at a lower level even though the Control Panel does not support direct selection of DTR/DSR flow control).

The 34420A cannot be connected to the 5500A, 5520A, 5800A, or 5820A UUT "Pass-Through" Serial port. These calibrators do not support the DTR/DSR hardware flow control required for communication with the 34420A.

Functional Capability

Function | NOMINAL | MOD2
DC Voltage | -119.99999 V to 119.99999 V
DC Voltage Ratio (Ch1/Ch2) | -11999999 to 11999999
DC Voltage Difference (Ch1-Ch2) | -119.99999 V to 119.99999 V | VD
Resistance | 0 Ω to 1.1999999 MΩ
Low Power Resistance | 0 Ω to 1.1999999 MΩ | LP
Voltage Limited Resistance | 0 Ω to 119.99999 Ω | VL
Temperature
100 Ω Pt 385 RTD | -200 °C to 630 °C | R1
200 Ω Pt 385 RTD | -200 °C to 630 °C | R4
500 Ω Pt 385 RTD | -200 °C to 630 °C | R5
1 kΩ Pt 385 RTD | -200d °C to 630 °C | R6
100 Ω Pt 3916 RTD | -200 °C to 630 °C | R7
Rosemount 162CE SPRT 1 | -200 °C to 661 °C | RR
Hart Scientific 5628 PRT 2 | -200 °C to 660 °C | RH
Type B TC | +350 °C to 1820 °C | _B
Type E TC | -200 °C to 10000 °C | _E
Type J TC | -200 °C to 760 °C | _J
Type K TC | -200 °C to 1372 °C | _K
Type N TC | -200 °C to 1300 °C | _N
Type R TC | 0 °C to 1767 °C | _R
Type S TC | 0 °C to 1767 °C | _S
Type T TC | -250 °C to 400 °C | _T
  1. 34420/SPRT only
  2. 34420/PRT only

Parameters

RANGE

This field specifies the UUT range as described in the RANGE Field topic.

NOMINAL

This field specifies the expected measured value or a reset.

  • Voltage entered as: [numeric][prefix]V
  • Voltage Ratio entered as: [numeric][prefix]V/V
  • Voltage Difference entered as: [numeric][prefix]V
  • Resistance entered as [numeric][prefix]Z
  • Temperature entered as: [numeric][prefix]degC or degF
  • Reset entered as *.

Rules:

  1. The NOMINAL field may specify temperature only when the MOD2 field specifies a RTD or thermocouple type.

TOLERANCE

This field specifies the UUT tolerance as described in the TOLERANCE Field topic.

MOD1

This is not used and must be blank.

MOD2

This field is used to override offset compensation for Ohms, to select Low Power or Voltage Limited Resistance, or to specify the RTD or thermocouple type for temperature measurement.

LP | Low Power Resistance
VL | Voltage Limited Resistance
VD | Voltage Difference
R1 | 100 Ω Pt 385 RTD
R4 | 200 Ω Pt 385 RTD
R5 | 500 Ω Pt 385 RTD
R6 | 1 kΩ Pt 385 RTD
R7 | 100 Ω Pt 3916 RTD
RR | Rosemount 162CE Standard Platinum Resistance Thermometer
RH | Hart Scientific 5628 Platinum Resistance Thermometer
_B | Type B thermocouple
_E | Type E thermocouple
_J | Type J thermocouple
_K | Type K thermocouple
_N | Type N thermocouple
_R | Type R thermocouple
_S | Type S thermocouple
_T | Type T thermocouple
blank | field not applicable

Rules:

  1. The MOD2 field may specify offset compensation override "O" only when the NOMINAL field specifies resistance.
  2. The MOD2 field may specify LP or VL only when the NOMINAL field specifies resistance.
  3. The MOD2 field may specify VD when the NOMINAL field specifies voltage.
  4. The MOD2 field may specify a RTD or thermocouple type only when the NOMINAL field specifies temperature.

MOD3

This field Specifies the measurement mode. The measurement mode determines certain function settings, as well as the number of readings that are discarded and the number of readings that are

averaged to obtain a measurement. The effect of the measurement mode on the programmed function is shown in the following table:

F | blank | E | FE
DC Volts
number of powerline cycles | 10 | 100 | 200 | 100
Readings
thrown away 1 | 1 | 1 | 1 | 1
averaged 1 | 1 | 3 | 5 | 1
Ohms (2-Wire and 4-Wire)
number of powerline cycles | 10 | 100 | 200 | 100
<= 19 kΩ
Readings
thrown away 1 | 1 | 2 | 2 | 1
averaged 1 | 3 | 4 | 4 | 1
>19 kΩ to <= 190 kΩ
Readings
thrown away 1 | 1 | 2 | 5 | 1
averaged 1 | 3 | 4 | 4 | 1
>190 kΩ
Readings
thrown away 1 | 1 | 2 | 7 | 1
averaged 1 | 3 | 4 | 5 | 1
Temperature (Thermocouples)
number of powerline cycles | 10 | 100 | 200 | 100
Readings
thrown away 1 | 1 | 1 | 1 | 1
averaged 1 | 1 | 3 | 5 | 1
Temperature (RTD's, SPRT, and PRT)
number of powerline cycles | 10 | 100 | 200 | 100
Readings
thrown away 1 | 1 | 2 | 2 | 1
averaged 1 | 3 | 4 | 4 | 1
  1. With measurement uncertainty disabled. When measurement uncertainty is enabled, use VSET FSC to set number of readings to throw away and average.

MOD4

This field specifies the type of test being performed as described in the MOD4 Field topic.

CON

This field specifies the UUT connection.

2W | 2-wire
4W | 4-wire

Rules:

  1. The CON field may specify a 4W only when the NOMINAL field specifies resistance or the MOD2 field specifies a RTD type.
  2. The CON field may must specify 4W when the MOD2 field specifies Lower Power resistance (LP), Voltage Limited resistance (VL) or an RTD type.
  3. 4W is inserted automatically in the CON field when the MOD2 field specifies LP, VL, or an RTD type and no CON field code is entered.

Use of Standard Memory Locations and Results Reporting

System memory locations MEM and MEM1 are used. For more information, refer to the Use of Standard Memory Registers topic.

Examples

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
# ----- Reset -----
  1.001  34420        *                                                 S
# ----- DC Voltage -----
  1.002  34420  10    10V            1% 0.01U                              2W
# ----- DC Voltage Ratio -----
  2.001  34420        0.1V/V         0.01U                                 2W
# ----- DC Voltage Difference -----
  3.001  34420        10uV           1U                           VD       2W
# ----- Resistance -----
  4.001  34420  100   100kZ          1%                                    2W
# ----- Low Power Resistance -----
  5.001  34420  10    10Z            0.1U                         LP       4W
# ----- Low Power Resistance -----
  6.001  34420  10    10Z            0.1U                         VL       4W
# ----- Temperature RTD -----
  7.001  34420        23.0degC       0.1U                         R1       4W
# ----- Temperature TC -----
  8.001  34420        23.0degC       0.1U                         _K       2W
# ----- Setup Test -----
  9.001  34420        1V                                                S  2W
# ----- Nominal Setup Test -----
  9.002  34420  1     1V                                                N  2W
# ----- Comparison Test -----
  9.003  34420  1     1V             1% 0.1U                            C  2W


53131 and 53132

Instrument FSC

Description

The 53131 and 53132 FSCs program the Agilent or Hewlett-Packard 53131A and 53132A Universal Counters to measure frequency, frequency ratio, period, time interval, phase, pulse width, duty cycle, rise and fall time, and maximum, minimum, and peak-to-peak voltage. All 5313xA capabilities are not supported. To program unsupported functions, use the IEEE or SCPI FSC.

The 53131 FSC may also be used to control a 53132A. This capability allows a 53131A based procedure to be executed without modification when a 53132A is configured. If channel 3 is used, the pre-scaler model must be the same.

Parameters

The following table shows the relationship between the supported 5313xA measurement functions and the FSC fields listed.

Function | MOD3 | NOMINAL | MOD1
Frequency Ch 1 FA

0.1 Hz to 100 MHz

20 mVrms to 5 Vrms 1
100 MHz to 200 MHz | 30 mVrms to 5 Vrms 1
200 MHz to 225 MHz | 40 mVrms to 5 Vrms 1

Frequency Ch 3

(Opt. 030)

FC

100 MHz to 2.7 GHz

-27 dBm to +19 dBm

>2.7 GHz to 3 GHz | -21 dBm to +13 dBm

Frequency Ch 3

(Opt. 050)

FC 200 MHz to 5 GHz -23 dBm to +13 dBm

Frequency Ch 3

(Opt. 124)

FC 200 MHz to 12.4 GHz -23 dBm to +13 dBm
Ratio Ch 1/2 | FR | 10 -10 to 10 11 | 2
Period Ch 1 | PA | 4.44 ns to 10 s | 2
Time Interval 1-2 | TI | 1ns to 10 5 | 2
Phase Ch 1-2 | PR | -180 deg to +360 deg | 0.1 Hz to 225 MHz
Pulse Width Ch 1 | WA | 5 ns to 10 5s | 2
Duty Factor Ch 1 | DA | 0 to 1 | 0.1 Hz to 225 MHz
Rise/Fall Time Ch 1 | RF | 5 ns to 105 s | 2
Voltage Max Ch 1 MX

-5.1 V to 5.1 V 1

blank (DC)

-5.1 Vp to 5.1 Vp 1 | 100 Hz to 30 MHz
Voltage Min Ch 1 MN

-5.1 V to 5.1 V 1

blank (DC)

-5.1 Vp to 5.1 Vp 1 | 100 Hz to 30 MHz

Voltage Peak-to-Peak Ch 1

PP 0 Vpp to10.2 Vpp 1 100 Hz to 30 MHz
  1. Values shown are for X1 attenuator setting. Multiply all values by 10 when using the X10 attenuator setting.
  2. Same amplitude restrictions as frequency measurement.

RANGE

This field specifies the UUT range as described in the RANGE Field topic.

Nominal

This field specifies the expected measured value or a reset.

  • Frequency entered as [numeric][prefix]H.
  • Frequency Ratio entered as [numeric][prefix]H/H.
  • Period entered as [numeric][prefix]T.
  • Time Interval entered as [numeric][prefix]T.
  • Phase entered as [numeric][prefix]deg.
  • Pulse Width entered as [numeric][prefix]T.
  • Duty Cycle entered as [numeric][prefix]df.
  • Rise or Fall Time entered as [numeric][prefix]T.
  • Voltage max or min entered as [numeric][prefix]V or Vp.
  • Voltage peak-to-peak entered as [numeric][prefix]Vpp.
  • Reset entered as *.

Rules:

  1. If no NOMINAL field value is entered and all other fields are blank, an * is automatically inserted.

TOLERANCE

This field specifies the UUT tolerance as described in the TOLERANCE Field topic.

MOD1

For measurements of frequency, frequency ratio, period, time interval, pulse width and rise/ fall time, this field specifies the expected amplitude. For measurements of phase, duty cycle, and peak voltage of AC, this field specifies the expected frequency. For measurements of DC peak voltage this field must be blank.

  • Voltage (RMS) entered as: numeric[prefix]V
  • Voltage (Peak) entered as: numeric[prefix]Vp
  • Voltage (Peak-to-Peak) entered as: numeric[prefix]Vpp
  • Voltage (into 50 Ohms, dBm) entered as: numeric[prefix]D
  • Frequency entered as numeric[prefix]H.
  • blank

Rules:

  1. For Ratio Channel 1/2 (FR) measurements, the MOD1 field specifies the expected amplitude on channel 1, not channel 2.
  2. For Pulse Width Channel 1 (WA) measurements, the MOD1 field must be voltage peak or voltage peak-to-peak.

MOD2

This field specifies the trigger slope as follows:

+A | Positive slope triggering, AC coupled
-A | Negative slope triggering, AC coupled
+D | Positive slope triggering, DC coupled
-D | Negative slope triggering, DC coupled
blank |

Rules:

  1. When the MOD2 field is blank, the trigger slope and coupling for channel 1 and 2 default to values determined by the measurement function unless otherwise specified using the M5313x FSC.
  2. +A is inserted automatically in the MOD2 field when the MOD3 field specifies Frequency Ch 3 (FC).

MOD3

This field specifies the measurement function:

FA | Frequency Channel 1
FC | Frequency Channel 3
PA | Period Channel 1
FR | Ratio Channel 1/2
TI | Time Interval Channel 1 to Channel 2
WA | Pulse Width Channel 1
RF | Rise or Fall Time Channel 1
PR | Phase Channel 1 Relative to Channel 2
DA | Duty Factor Channel 1
MX | Maximum Voltage Channel 1
MN | Minimum Voltage Channel 1
PP | Volts Peak-to-Peak Voltage Channel 1

Rules:

  1. When MOD3 is "RF" and channel 1 trigger slope is positive, a rise time measurement is performed. When channel 1 trigger slope is negative a fall time measurement is performed.
  2. The MOD3 field may specify Frequency Channel 3 (FC) only when option 030, 050, or 124 is installed.

MOD4

This field specifies the type of test being performed as described in the MOD4 Field topic.

CON

The Connection field specifies the UUT connection.

L | 50 Ohm Input Impedance
blank | 1 MOhm Input Impedance

Rules:

  1. L is inserted automatically in the CON field when the MOD3 field specifies Frequency Channel 3 (FC).

USE OF STANDARD MEMORY LOCATIONS AND RESULTS REPORTING

System memory locations MEM and MEM1 are used. For more information, refer to the Use of Standard Memory Registers topic.

EXAMPLES

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
# Reset
  1.001  M53132       *
  1.002  53132        *                                                 S
# Frequency Channel 1
  1.003  M53132 ChA                                100kH
  1.004  53132        10.000kH       1%            1Vpp           +A FA
# Frequency Channel 3
  2.001  53132        1GH            0.1%          -1D            +A FC    L
# Period Channel 1
  3.001  M53132       *
  3.002  53132        1.000mT        0.003U        5V             +A PA
# Ratio Channel 1/2
  4.001  M53132 ChA                                               AC
  4.002  M53132 ChB                                               DC
  4.003  53132        10H/H          1%            1Vpp              FR
# Time Interval Channel 1 to 2
  5.001  M53132 COM   20T            0.2V          0.8V           DC ++    X1
  5.002  53132        10.00T         0.02U         1Vpp              TI
# Pulse Width Channel 1
  6.001  M53132       *
  6.002  53132        300uT          5%            5Vp            -A WA
# Rise Time Channel 1
  7.001  53132        100nT          5%            1Vpp              RF
# Phase Channel 1 relative to Channel 2
  8.001  M53132       *
  8.002  53132        30deg          1U            10kH              PR    L
# Duty Cycle Channel 1
  9.001  53132        0.3DF          2%            100H              DA


M53131 and M53132

Auxiliary Instrument Setup FSC

Description

The M53131 and M53132 FSCs provide the additional program functions for Channel 1 and 2 of the Agilent/Hewlett-Packard 53131A and 53132A Universal Counters which are not addressed by the 53131 and 53132 FSCs. These functions include Common 2 via 1, Gate Time, Trigger Level, Trigger Sensitivity, Trigger Slope, Input Coupling, Input Impedance, and Input Attenuation.

Range

This field specifies the Channel.

  • ChA Channel 1
  • ChB Channel 2
  • COM Common 2 via 1
  • blank

Rules:

The M5313x statement is ignored under the following conditions:

  1. The RANGE field specifies channel 2 and the 5313x FSC specifies Frequency Ch 1, Period Ch 1, Pulse Width Ch 1, or Peak Voltage Ch 1, (5313x MOD3 field is FA, PA, WA, or MX respectively).
  2. The RANGE field specifies Common 2 via 1 and the 5313x FSC specifies a measurement function other than Time Interval 1-2 (5313x MOD3 field is not TI).
  3. The 5313x FSC specifies Frequency Ch 3 (53131 MOD3 field is FC).

Nominal

This field specifies one the following:

  • Gate Time entered as: numeric[prefix]T. Allowed values are: 1ms to 1000s.
  • "*" Reset to Auto Mode
  • blank

Rules:

  1. Gate Time is not channel specific. It may be specified in a separate M5313x statement or in conjunction with a channel 1 or channel 2 specification. Either way, the last Gate Time specification prior to a 5313x statement is used.
  2. Gate Time is only applicable when the 5313x FSC MOD3 field is one of the following:
    • FA Frequency Channel 1
    • FC Frequency Channel 3
    • PA Period Channel 1
    • FR Ratio Channel 1/2

Tolerance

This field specifies one of the following:

  • The Channel 1 or 2 Trigger Level entered as numeric[prefix]V.
  • blank Auto Level (default) or not applicable.

Rules:

CON Field | Allowed values, TOLERANCE field | Resolution
X1 | -5.125 V to +5.125 V | 0.005 V
X10 | -51.25 V to +51.25 V | 0.05 V
  1. The TOLERANCE field specifies the channel 1 trigger level when the RANGE field specifies Channel 1 or Common Ch 2 via 1.
  2. The TOLERANCE field specifies the channel 2 trigger level when the RANGE field specifies Channel 2.
  3. The TOLERANCE field must be blank when the RANGE field is blank.
  4. Auto Level is specified when the TOLERANCE field is blank and the RANGE field specifies Channel 1 or Common Ch 2 via 1.
  5. Auto Level causes the attenuation, and trigger level to be automatically controlled for both channel 1 and 2.
  6. The TOLERANCE field specification is ignored when the 5313x FSC specifies Auto Level (5313x MOD2 field is not blank).
  7. If the TOLERANCE field does not contain a value the value is taken from memory register MEM.

MOD1

This field specifies one of the following:

  • The Channel 1 Low-Pass Filter entered as: numeric[prefix]H.
  • The Channel 2 Trigger Level entered as [numeric][prefix]V.
  • blankAuto Level (default) or not applicable.

Rules:

CON Field | Allowed values, TOLERANCE field | Allowed values, MOD1 field | Resolution
X1 | -5.125 V to +5.125 V | -5.125 V to +5.125 V | 0.005 V
X10 | -51.25 V to +51.25 V | -51.25 V to +51.25 V | 0.05 V
  1. The MOD1 field may specify the channel 1 low-pass filter only when the RANGE field specifies channel 1.
  2. When the MOD1 field specifies the channel 1 low-pass filter, the value must be 100kHz.
  3. The MOD1 field may specify the channel 2 trigger level only when the RANGE specifies Common channel 2 via 1.
  4. The MOD1 field must be blank when the RANGE field is blank or Auto Level is specified by the 5313x FSC (5313x MOD2 field is not blank).
  5. The MOD1 field specification is ignored when the MOD1 field specifies the channel 2 trigger level and the 5313x FSC specifies Auto Level (53131 MOD2 field is not blank).
  6. If the MOD1 field does not contain a value the value is taken from memory register MEM.

MOD2

This field specifies the input coupling and sensitivity:

  • ALAC Coupling, Low Sensitivity
  • ACAC Coupling, Medium Sensitivity
  • AHAC Coupling, High Sensitivity
  • DLDC Coupling, Low Sensitivity
  • DCDC Coupling, Medium Sensitivity
  • DHDC Coupling, High Sensitivity
  • blank Default Coupling, Medium Sensitivity
5313x MOD3 field | 53131 MOD1 | Field Coupling
FA (Frequency Ch 1) | NA | AC
FC (Frequency Ch 3) | NA | NA
PA (Period Ch 1) | NA | AC
FR (Ratio Ch 1/2) | NA | AC
WA (Pulse Width Ch 1) | NA | DC
TI (Time Interval Ch 1-2) | NA | DC
PR (Phase Ch 1-2) | NA | AC
DA (Duty Cycle Ch 1) | NA | DC
RF (Rise Time Ch 1) | NA | DC
MX (Peak Voltage Ch 1) | <100Hz | DC
 | ≥100Hz | AC

Rules:

Default values are used when the 5313x FSC does not specify the input coupling (5313x MOD2 field is blank) and one of the following conditions exists:

  1. No M5313x statement has been executed.
  2. The last M5313x statement executed was a M53131 Reset.
  3. The M5313x MOD2 field is blank and the M53131 RANGE field specifies Channel 1, Channel 2, or Common Ch 2 via 1.
    • The MOD2 field must be blank when the RANGE field is blank.
    • The MOD2 field must specify AC when TOLERANCE field specifies the trigger sensitivity.
    • The MOD2 field must specify DC when TOLERANCE field specifies the trigger level.
    • The MOD2 field specification is ignored when the 5313x FSC specifies the input coupling (5313x MOD2 field is not blank).

MOD3

This field specifies the trigger slope:

  • +Positive, Channel 1 or 2
  • -Negative, Channel 1 or 2
  • ++Positive, Channel 1 and 2
  • +-Positive, Channel 1, Negative Channel 2
  • -+Negative, Channel 1, Positive Channel 2
  • Negative, Channel 1 and 2
  • blank

Rules:

  1. The MOD3 field must be blank when the RANGE field is blank.
  2. The MOD3 field may specify "+" or "-" only when the RANGE field specifies Channel 1 (ChA) or Channel 2 (ChB).
  3. The MOD3 field may specify "++", "+-", "-+", or "" only when the RANGE field specifies Common Ch 2 via 1 (COM).
  4. The MOD3 field specification is ignored when the 5313x FSC specifies the trigger slope (5313x MOD2 field is not blank).

MOD4

This field specifies that an external reference oscillator is to be used:

  • X External Reference Oscillator
  • blank

Rules:

  1. A M5313x reset statement, NOMINAL field is an "*", must be used to re-select the internal reference once the external reference is selected.

CON

This field specifies the Attenuation. Legal entries are:

  • X1 (default)
  • X10
  • blank

Rules:

  1. The CON field must be blank when the RANGE is blank.
  2. The CON field must not be blank when the TOLERANCE field specifies the trigger sensitivity or level.
  3. The CON field specification is ignored when the 5313x FSC specifies Auto Level (5313x MOD2 field is not blank).

Examples

Refer to 53131 or 53132 FSC.


53181

Instrument FSC

Description

The 53181 FSC programs the Agilent/Hewlett-Packard 53181A RF Counter to measure frequency, frequency ratio, period, and maximum, minimum, and peak-to-peak voltage.

Parameters

The following table shows the relationship between the supported 53181A measurement functions and the FSC fields listed.

Function | MOD3 | NOMINAL Value | MOD1 Value
Frequency Ch 1 | FA | 0.1 Hz to 100 MHz | 20 mVrms to 5 Vrms 1
100 MHz to 200 MHz | 30 mVrms to 5 Vrms 1
200 MHz to 225 MHz | 40 mVrms to 5 Vrms 1

Frequency Ch 2

(Opt. 015)

 FC 100 MHz to 1.5 GHz -27 dBm to +19 dBm

Frequency Ch 2

(Opt. 030)

 FC 100 MHz to 2.7 GHz -27 dBm to +19 dBm
>2.7 GHz to 3 GHz | -21 dBm to +13 dBm

Frequency Ch 2

(Opt. 050)

 FC 200 MHz to 5 GHz -23 dBm to +13 dBm

Frequency Ch 2

(Opt. 124)

 FC 200 MHz to 12.4 GHz -23 dBm to +13 dBm
Ratio Ch 2/1 | FR | 10-10 to 1011 | 2
Period Ch 1 | PA | 4.44 ns to 10 s | 2
Voltage Max Ch 1 | MX | -5.1 V to 5.1 V 1 | blank (DC)
-5.1 Vp to 5.1 Vp 1 | 100 Hz to 30 MHz
Voltage Min Ch 1 | MN | -5.1 V to 5.1 V 1 | blank (DC)
-5.1 Vp to 5.1 Vp 1 | 100 Hz to 30 MHz
Voltage Peak-to-Peak Ch 1 | PP | 0 Vpp to 10.2 Vpp 1 | 100 Hz to 30 MHz
  1. Values shown are for X1 attenuator setting. Multiply all values by 10 when using the X10 attenuator setting.
  2. Same amplitude restrictions as frequency measurement.

RANGE

This field specifies the UUT range as described in the RANGE Field topic.

Nominal

This field specifies the expected measured value or a reset.

  • Frequency entered as [numeric][prefix]H
  • Frequency Ratio entered as [numeric][prefix]H/H
  • Period entered as [numeric][prefix]T
  • Voltage (RMS) entered as: [numeric][prefix]V
  • Voltage (Peak) entered as: [numeric][prefix]Vp
  • Reset entered as *.

Rules:

  1. If no NOMINAL field value is entered and all other fields are blank, an * is automatically inserted.

TOLERANCE

This field specifies the UUT tolerance as described in the TOLERANCE Field topic.

MOD1

For all measurements except peak voltage, this field specifies the amplitude. For peak voltage, this field specifies the frequency of an AC signal.

  • Voltage (RMS) entered as: [numeric][prefix]V
  • Voltage (Peak) entered as: [numeric][prefix]Vp
  • Voltage (Peak-to-Peak) entered as: [numeric][prefix]Vpp
  • Voltage (into 50 Ohms, dBm) entered as: [numeric][prefix]D
  • Frequency entered as numeric[prefix]H

Rules:

  1. For Ratio C/A (FR) measurements, the MOD1 field specifies the expected amplitude on channel 1, not channel 2.

MOD2

This field specifies the trigger slope as follows:

+A | Positive
-A | Negative
blank |

Rules:

  1. When the MOD2 field is blank, the trigger slope defaults to positive unless specified otherwise using the M53181 FSC.
  2. +A is inserted automatically in the MOD2 field when the MOD3 field specifies Frequency Ch 2 (FC).MOD3

This field specifies the measurement function:

FA | Frequency Channel 1
FC | Frequency Channel 2
PA | Period Channel 1
FR | Ratio Channel 2/1
MX | Maximum Voltage Channel 1
MN | Minimum Voltage Channel 1
PP | Peak-to-Peak Voltage Channel 1

Rules:

  1. The MOD3 field may specify Frequency Ch 2 (FC) and Ratio 2/1 (FR) only when a High Frequency Input, 53181A option 015, 030, 050, or 124 is installed.

MOD4

This field specifies the type of test being performed as described in the MOD4 Field topic.

CON

The Connection field specifies the UUT connection.

L | 50 Ohm Input Impedance
blank | 1 MOhm Input Impedance

Rules:

  1. For Ratio 2/1 (FR) measurements, the CON field specifies the impedance of the channel 1 input, not the channel 2 input.
  2. L is inserted automatically in the CON field when the MOD3 field specifies Frequency Ch 2 (FC).

USE OF STANDARD MEMORY LOCATIONS AND RESULTS REPORTING

System memory locations MEM and MEM1 are used. For more information, refer to the Use of Standard Memory Registers topic.

EXAMPLES

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
# Reset
  1.001  M53181       *
  1.002  53181        *                                                 S
# Frequency Ch 1
  1.003  M53181 ChA                  100mV         100kH          DC       X1
  1.004  53181        10kH           1%            1Vpp              FA
# Frequency Ch 2
  2.001  53181        200MH          0.1%          2D             +A FC    L
# Period Ch 1
  3.001  M53181       *
  3.002  53181        1.000mT        0.003U        5V                PA
# Ratio Ch 2/1
  4.001  53181        10H/H          1%            1Vpp              FR


M53181

Auxiliary Instrument Setup FSC

Description

The M53181 FSC provides the additional program functions for Channel 1 of the Agilent/Hewlett-Packard 53181A RF Counter which are not addressed by the 53181 FSC. These functions include Gate Time, and Channel 1 Trigger Level, Trigger Sensitivity, and Low-pass Filter.

RANGE

This field specifies the Channel.

  • ChA Channel 1
  • blank

Rules:

  1. ChA is inserted automatically when the RANGE field is left blank and the TOLERANCE field specifies the channel 1 trigger sensitivity or the MOD1 field specifies the channel 1 low-pass filter.
  2. M53181 specifications other than gate time are ignored when the 53181 FSC specifies Frequency Ch 2 (53181 MOD3 field is FC).

NOMINAL

This field specifies one of the following:

  • Gate Time entered as numeric[prefix]T. Allowed values are 1ms to 1000s
  • "*"Reset to defaults
  • blank

TOLERANCE

This field specifies one of the following:

  • The Trigger Level entered as [numeric][prefix]V.
  • blank Auto Level (default)

Rules:

CON Field | Allowed values TOLERANCE field | Resolution
X1 | -5.125 V to +5.125 V | 0.005 V
X10 | -51.25 V to +51.25 V | 0.05 V
  1. The TOLERANCE field specification is ignored when the 53181 FSC specifies Auto Level (53181 MOD2 field is not blank).
  2. If the TOLERANCE field does not contain a value the value is taken from memory register MEM.

MOD1

This field specifies one of the following:

  • Channel 1 low-pass filter entered as: numeric[prefix]H.
  • blank

Rules:

  1. When the MOD1 field specifies the Channel 1 low-pass filter, the value must be 100kH.
  2. A M53181 reset statement, NOMINAL field is an "*", must be used to disable the Channel 1 low-pass filter once it is enabled.

MOD2

This field specifies the input coupling and sensitivity:

AL | AC Coupling, Low Sensitivity
AC | AC Coupling, Medium Sensitivity
AH | AC Coupling, High Sensitivity
DL | DC Coupling, Low Sensitivity
DC | DC Coupling, Medium Sensitivity
DH | DC Coupling, High Sensitivity
blank | Default Coupling, Medium Sensitivity

MOD3

This field specifies the trigger slope:

+ | Positive (default)
- | Negative
blank |

Rules:

  1. The MOD3 field specification is ignored when the 53181 FSC specifies the trigger slope (53181 MOD2 field is not blank).

MOD4

This field specifies that an external reference oscillator is to be used:

  • X External Reference Oscillator
  • blank

Rules:

  1. A M53181 reset statement, NOMINAL field is an "*", must be used to re-select the internal reference once the external reference is selected.

CON

This field is not used.

Examples

See 53181 FSC.


4418

Instrument FSC

Description

The 4418 FSC programs the Agilent E4418B and Agilent/HP E4418A (formally EPM-441A) Power Meters. Procedures written using the 4418/M4418 FSCs will also execute when an Agilent E4419B or Agilent/HP E4419A (formally EPM-442A) is used. For additional information about the models supported, see Device Mapping.

In this case channel A is used. A single procedure may use up to 8 different power sensors during the course of procedure execution. If channel A of the dual channel power is used, the limit is 4 different sensors.

When the power meter contains firmware with major revision 3 or later, the instrument driver uses the SERV:SENS:TYPE? command to determine if the power sensor specified in the most recently executed M4418 FSC is in fact connected to the power meter. For E-Series power sensors, the command returns the actual power sensor model connected to the power meter. For 8480-Series power sensors only the suffix A, B, D, or H is returned so the check can only detect a sensor with an incorrect power range.

When ASK+ W or ASK+ V is specified, automatic connection messages for calibrating the power sensor include any required attenuators and adapters to properly connect the power sensor to the power meter POWER REF output.

If the E4418B is to be controlled via its serial port, do not use the PORT FSC port configuration special construction, [P9600,N,...], to set the baud rate, parity, etc. of the port used to control the E4418B. MET/CAL executes a "Test" function for each System Instrument prior to executing any procedure statements. Therefore the settings of the port used to control the E4418B must be set correctly before a procedure is executed.

If the E4418B is connected to a standard serial port (COM1, COM2, ..., COM16), use the "Ports" application in the Windows Control Panel to choose the proper settings. If the E4418B is connected to the 5500A, 5520A, 5800A, or 5820A UUT port, select the proper settings for the UUT Serial Port from the front panel of the calibrator. The following settings have been shown to work when controlling a E4418B via the RS-232 interface E4418B.

DTR/DSR: | On
CTS/RTS: | On
Tx Pacing: | On
Rx Pacing: | On
Windows COMM port setting
Flow Control: | Xon / Xoff

Functional Capability

Function | 4418 MOD3 | 4418 NOMINAL | 4418 MOD1
RF Power 1 | RF | -70 dBm to +44 dBm | 100 kHz to 110 GHz
RF | 100 pW to 25 W | 100 kHz to 110 GHz
Zero sensor | ZR | 0 W | 100 kHz to 110 GHz
Zero and Cal. sensor | CP | 1 μW to 1 mW | 50 MHz
  1. NOMINAL (Power) and MOD1 (frequency) ranges depend upon the power sensor model used (see M4418 MOD1 field): E-Series E441XA CW Power Sensors

Model | Power Range | Frequency Range
E-Series E441XA Power Sensors
E4412A | -70 to +20 dBm (100 pW to 100 mW) | 10 MHz to 18.0 GHz
E4413A | -70 to +20 dBm (100 pW to 100 mW) | 50 MHz to 26.5 GHz
E-Series E9300 Average Power Sensors
E9300A | -60 to +20 dBm (1 nW to 100 mW) | 10 MHz to 18.0 GHz
E9301A | -60 to +20 dBm (1 nW to 100 mW) | 10 MHz to 6.0 GHz
E9304A | -60 to +20 dBm (1 nW to 100 mW) | 9 kHz to 6.0 GHz
E9300B | -30 to +44 dBm (1 μW to 25 W) | 10 MHz to 18.0 GHz
E9301B | -30 to +44 dBm (1 μW to 25 W) | 10 MHz to 6.0 GHz
E9300H | -50 to +30 dBm (10 nW to 1 W) | 10 MHz to 18.0 GHz
E9301H | -50 to +30 dBm (10 nW to 1 W) | 10 MHz to 6.0 GHz
8480-Series Power Sensors
25 W Sensors
8481B | 0 to +44 dBm (1 mW to 25 W) | 10 MHz to 18.0 GHz
8482B | 0 to +44 dBm (1 mW to 25 W) | 100 kHz to 4.2 GHz
3 W Sensors
8481H | -10 to +35 dBm (100 μW to 3 W) | 10 MHz to 18.0 GHz
8482H | -10 to +35 dBm (100 μW to 3 W) | 100 kHz to 4.2 GHz
100 mW Sensors
8481A | -30 to +20 dBm (1 μW to 100 mW) | 10 MHz to 18.0 GHz
8482A | -30 to +20 dBm (1 μW to 100 mW) | 100 kHz to 4.2 GHz
8483A | -30 to +20 dBm (1 μW to 100 mW) | 100 kHz to 2.0 GHz
8485A | -30 to +20 dBm (1 μW to 100 mW) | 50 MHz to 26.5 GHz
Opt 033 | -30 to +20 dBm (1 μW to 100 mW) | 50 MHz to 33 GHz
R8486A | -30 to +20 dBm (1 μW to 100 mW) | 26.5 MHz to 40 GHz
Q8486A | -30 to +20 dBm (1 μW to 100 mW) | 33 MHz to 50 GHz
V8486A | -30 to +20 dBm (1 μW to 100 mW) | 50 GHz to 75 GHz
W8486A | -30 to +20 dBm (1 μW to 100 mW) | 75 MHz to 110 GHz
8487A | -30 to +20dBm (1 μW to 100 mW) | 50 MHz to 50 GHz
10 μW High Sensitivity Sensors
8481D | -70 to -20 dBm (100 pW to 10 uW) | 10 MHz to 18.0 GHz
8484A | -70 to -20 dBm (100 pW to 10 uW) | 10 MHz to 18.0 GHz
8485D | -70 to -20 dBm (100 pW to 10 uW) | 50 MHz to 26.5 GHz
Opt 033 | -70 to -20 dBm (100 pW to 10 uW) | 50 MHz to 33 GHz
R8486D | -70 to -20 dBm (100 pW to 10 uW) | 26.5 MHz to 40 GHz
Q8486D | -70 to -20 dBm (100 pW to 10 uW) | 33 MHz to 50 GHz
8487D | -70 to -20 dBm (100 pW to 10 uW) | 50 MHz to 50 GHz

Parameters

RANGE

This field specifies the UUT range as described in the RANGE Field topic.

Nominal

This field specifies the expected measured value or a reset.

  • RF Power entered as [numeric][prefix]W or D.
  • Relative Power entered as [numeric][prefix]pct or dB.
  • Reset entered as *.

Rules:

  1. When the Nominal field contains only units, the value is obtained from memory register MEM. In this case the MOD1 field MUST contain a value.

TOLERANCE

This field specifies the UUT tolerance as described in the TOLERANCE Field topic.

MOD1

This field specifies the frequency.

  • Frequency entered as [numeric][prefix]H.
  • blank not applicable

Rules:

  1. When the MOD1 field contains only units, the value is obtained from memory register MEM. In this case the Nominal field MUST contain a value.

MOD2

This field is not used.

MOD3

This field specifies the measurement type:

ZR | Zero sensor
CP | Zero and Calibrate sensor
RS | Set reference
RL | Relative
RF | RF Power

Rules:

  1. The MOD3 field may specify ZR or CP only for a Nominal Setup Test (MOD4 = N). However MEM is not updated when MOD3 is ZR or CP.
  2. When the MOD3 field is ZR, CP, RS, or RF, the Nominal field units must be watts "W" or dBm "D".
  3. When the MOD3 field is RL, Nominal field units must be percent "pct" or ratio "dB".
  4. When the Nominal field units are watts "W" or dBm "D" and no MOD3 field code is entered, RF is inserted automatically in the MOD3 field.
  5. When the Nominal field units are percent "pct" or ratio "dB" and no MOD3 field code is entered, RL is inserted automatically in the MOD3 field.

MOD4

This field specifies the type of test being performed as described in the MOD4 Field topic.

CON

This field is specifies the input channel.

  • CH1 Channel A

Rules:

  1. If no CON field code is specified, CH1 is automatically entered in the CON field.

Use of Standard Memory Locations and Results Reporting

System memory locations MEM and MEM1 are used. For more information, refer to the Use of Standard Memory Registers topic.

Examples

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
  1.001  ASK-   R     N              P     U                      F
# Use MET/CAL's automatic connection message for connection to Power ref.
  1.002  ASK+                                                              V
# Zero and Calibrate
  1.003  DISP         Connect the HP 8481A Power Sensor to the E4418B.
  1.004  MEMI         Enter sensor’s reference calibration factor in percent.
  1.005  M4418  F256  8481A          pct
  1.006  4418         1mW                          50MH              CP N  CH1
# Turn off automatic connection messages
  1.007  ASK-   R   Q N              P     U                      F        V
# Absolute Power Measurement: dBm
# Assume factory default table for HP 8481A Power Sensor Data.
  1.008  M4418  F4    8481A
  1.009  DISP         Connect the 8481A to the 6060 RF Output.
  1.010  IEEE         [@6060]AP-30DB,FR100E6HZ
  1.011  4418         -30.00D        3.00U         100MH             RF    CH1
  2.001  IEEE         [@6060]AP10DB,FR100E6HZ
  2.002  4418         10.00D         1.00U         100MH             RF    CH1
# Relative Power Measurement: dB
  3.001  IEEE         [@6060]AP10DB,FR100E6HZ
  3.002  4418         10.00D                       100MH             RS N  CH1
  3.003  IEEE         [@6060]AP0DB
  3.004  4418         -9.00dB        2.00U         100MH             RL    CH1
# Absolute Power Measurement: Watts
  4.001  IEEE         [@6060]AP-30DB,FR100E6HZ[D2000]
  4.002  4418         1.00uW         25%           100MH             RF    CH1
  5.001  IEEE         [@6060]AP10DB,FR100E6HZ
  5.002  4418         10.00mW        5%            100MH             RF    CH1
# Relative Power Measurement: %
  6.001  IEEE         [@6060]AP10DB,FR100E6HZ
  6.002  4418         10.00mW                      100MH             RS N  CH1
  6.003  IEEE         [@6060]AP0DB,FR100E6HZ
  6.004  4418         10.00pct       5%            100MH             RL    CH1
# Filter: Off
  7.001  M4418  F256  8481A
  7.002  IEEE         [@6060]AP-1DB,FR150E6HZ
  7.003  4418         -1.00D                       150MH             RF N  CH1
# Filter: 1
  7.004  M4418  F1    8481A
  7.005  IEEE         [@6060]AP-1DB,FR150E6HZ
  7.006  4418         -1.00D                       150MH             RF N  CH1
# Filter: 1024
  7.007  M4418  F1024 8481A
  7.008  IEEE         [@6060]AP-2DB,FR150E6HZ
  7.009  4418         -2.000D                      150MH             RF N  CH1

Copyright 2012 Fluke Calibration, All rights reserved.      MET/CAL Procedure
=============================================================================
INSTRUMENT:            Agilent E441xA/B: Store 8480 Series Cal Factors IEEE
INSTRUMENT:            HP EPM-441A/442A: Store 8480 Series Cal Factors IEEE
DATE:                  2012-02-29 16:30:41
AUTHOR:                Fluke Calibration
REVISION:              $Revision: 2605 $
ADJUSTMENT THRESHOLD:  70%
NUMBER OF TESTS:       1
NUMBER OF LINES:       349
CONFIGURATION:         Agilent E4418B
=============================================================================
#
# This procedure is used to store cal factors for an 8480 series power sensor
# in a E4418B, E4419B, E4418A (EPM-441A), or E4419A (EPM-442A) power meter.
#
# Author:
#        DAC, DFM
#
# Source:
#        HP EPM-441A/442A Power Meters Programming Guide, HP Part No.
#        E4418-90025, March 1998
#
# Compatibility:
#        MET/CAL 7.01 SP1 or later
#
# Subprocedure:
#        None
#
# The Procedure was tested using:
#
#        Model No.    : E4419A
#        Serial No.   : US38260572
#        Options      : None
#        Firmware Rev.: A2.08.01
#
# Registers Used:
#        L[1] - Number of cal factors to be entered (excluding ref cal factor)
#        L[2] - Frequency of cal factor to be entered
#        L[4] - Frequency from existing cal factor table data
#        L[5] - Flag to skip table selection if choice garbled and reentered
#        MEM1 - Cal factor counter
#
#        S[1] - List of cal factors from the selected table.
#        S[2] - List of cal factor frequencies from the selected table.
#        S[3] - Specific cal factors from the selected table.
#        S[4] - Specific cal factor frequencies from the selected table.
#        S[5] - Frequencies associated with cal factors during entry.
#        S[6] - Reference and other Cal Factors.
#
#        The cal factor table has the following format:
#
#        Frequency S[5]   Cal Factors S[6]
#        --------------   ----------------
#              --          ref cal factor
#         frequency 1       cal factor 1
#         frequency 2       cal factor 2
#         frequency 3       cal factor 3
#             .                  .
#             .                  .
#         frequency n       cal factor n
#
# The following rules apply:
#   o The number of frequency points must be one less than the number of cal
#     points.  This is verified when the sensor calibration table is selected.
#   o The frequencies must be entered in ascending order.
#   o All frequencies are truncated to a multiple of 1 kHz.
#   o Maximum of 81 cal points (including reference cal factor) are allowed.
#
# Note, this procedure has no explict error checking of 441x remote commands.
# When used with MET/CAL 7.0 or later, configuring a E4418B or E4419B
# establishes the alias 441x.  If a command in an IEEE FSC in this procedure
# causes an error, it is caught by the SRQ handler in the MET/CAL 441x driver.
#
 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON

  1.001  HEAD         PRELIMINARY INFORMATION
  1.002  DISP         This utility allows the operator to review, delete, or
  1.002  DISP         insert power sensor calibration factor data for either
  1.002  DISP         standard HP 8480-series units or for entry of 'custom'
  1.002  DISP         data for other types at the users discretion.
  1.002  DISP
  1.002  DISP         Since the tables used for both channels are identical,
  1.002  DISP         in the case of the E4419B (EPM-442A), this utility may
  1.002  DISP         be used for both 1 and 2 channel units.

  1.003  HEAD         MAIN MENU
  1.004  DISP         At the following menu prompt, select the desired mode.

  1.005  DO
  1.006  LABEL        MAIN_MENU
  1.007  MEMI         Enter: (1) Review (2) Delete (3) Insert (4) Exit

  1.008  IF           MEM == 1
  1.009  MATH         MEM2 = PUTV("CF_Function", "REVIEW")
  1.010  ELSEIF       MEM == 2
  1.011  MATH         MEM2 = PUTV("CF_Function", "DELETE")
  1.012  ELSEIF       MEM == 3
  1.013  MATH         MEM2 = PUTV("CF_Function", "INSERT")
  1.014  ENDIF

  1.015  UNTIL        (MEM > 0) && (MEM <= 4)

  1.016  JMPL         END                          MEM == 4
  1.017  MATH         MEM2 = GETV("CF_Function")
  1.018  OPBR         You have chosen to [MEM2] cal factor table data.
  1.018  OPBR
  1.018  OPBR         Is this correct?
  1.019  JMPL         MAIN_MENU                    MEM1 < 0
  1.020  JMPL         INVOKE_FUNCTION              L[5] > 0

  1.021  HEAD         CAL FACTOR TABLE NAMES
  1.022  DISP         The E-series Power Meters contain 20 predefined sensor
  1.022  DISP         calibration table names for power sensors. They are:
  1.022  DISP
  1.022  DISP         [32]   DEFAULT      HP8483A      R8486A      HP8487A
  1.022  DISP         [32]   HP8481A      HP8481D      Q8486A
  1.022  DISP         [32]   HP8482A      HP8485A      R8486D
  1.022  DISP
  1.022  DISP         plus 10 tables named "CUSTOM_0" through "CUSTOM_9".

  1.023  DISP         At the following prompt, enter the EXACT name of the
  1.023  DISP         cal factor table of interest.
  1.023  DISP
  1.023  DISP         Enter the table name corresponding to the sensor type
  1.023  DISP         being used (use the "HP8482A" table for the 8482B and
  1.023  DISP         and 8482H sensors, and the "HP8481D" table for 8484A
  1.023  DISP         sensors), "DEFAULT" for performance testing, or use a
  1.023  DISP         'custom' table for non-standard applications.

  1.024  LABEL        SELECT_TABLE
  1.025  HEAD         SELECT CAL FACTOR TABLE

  1.026  DO
  1.027  MEM2         Please enter cal factor table name:
# Store entered cal factor table name in S[32].
  1.028  MATH         S[32] = MEM2
# Retrieve names of available cal factor tables from power meter.
  1.029  IEEE         [@441x]MEMORY:CATALOG:TABLE?[I$]
# Look for presence of specified table in list of pre-defined tables.
  1.030  MATH         MEM = FINDI(MEM2, S[32], 1)

  1.031  IF           MEM
# If name (or any portion of it) is found, check for EXACT match.
  1.032  MATH         MEM2 = SUB(MEM2, MEM, 7)

  1.033  IF           ZCMPI(MEM2, S[32]) == 0
# If entered name is a subset, e.g., HP8482 instead of HP8482A, show error.
  1.034  DISP         An INCOMPLETE cal factor table name was specified.
  1.034  DISP
  1.034  DISP         Select "Advance" to review table names.
# Set MEM = 0 so DO/UNTIL loop will function.
  1.035  MATH         MEM = 0
  1.036  ENDIF

  1.037  ELSE
  1.038  DISP         An INCORRECT cal factor table name was specified.
  1.038  DISP
  1.038  DISP         Select "Advance" to review table names.
  1.039  ENDIF

  1.040  IF           MEM == 0
  1.041  DISP         Please review the following list of available cal factor
  1.041  DISP         table names. Select "Advance" when ready to re-enter.
  1.041  DISP
  1.041  DISP         [32]   DEFAULT      HP8485A      CUSTOM_0      CUSTOM_5
  1.041  DISP         [32]   HP8481A      HP8487A      CUSTOM_1      CUSTOM_6
  1.041  DISP         [32]   HP8482A      R8486A       CUSTOM_2      CUSTOM_7
  1.041  DISP         [32]   HP8483A      Q8486A       CUSTOM_3      CUSTOM_8
  1.041  DISP         [32]   HP8481D      R8486D       CUSTOM_4      CUSTOM_9
  1.042  ENDIF

  1.043  UNTIL        MEM

# Reset table selection flag.
  1.044  MATH         L[5] = 0
# Select cal factor table of interest.
  1.045  IEEE         [@441x]MEM:TABL:SEL "[SREG32]"

  1.046  LABEL        INVOKE_FUNCTION
# Retrieve desired mode.
  1.047  MATH         MEM2 = GETV("CF_Function")
# Jump to desired mode previously selected.
  1.048  JMPL         DATA_REVIEW                  ZCMPI(MEM2, "REVIEW")
  1.049  JMPL         DATA_DELETE                  ZCMPI(MEM2, "DELETE")
  1.050  JMPL         DATA_INSERT                  ZCMPI(MEM2, "INSERT")
  1.051  DISP         Functional mode desired not found!
  1.051  DISP
  1.051  DISP         Select "Advance" to reselect desired function.
# At this point, table already selected. Set flag to skip table selection.
  1.052  MATH         L[5] = 1
  1.053  JMPL         MAIN_MENU

  1.054  LABEL        DATA_REVIEW
  1.055  HEAD         REVIEW CAL FACTOR DATA
  1.056  IEEE         [@441x]MEMORY:TABLE:GAIN?[I$]
# Store retrieved cal factors from selected table in S[1].
  1.057  MATH         S[1] = MEM2
  1.058  MATH         MEM2 = FLD(S[1], 1, ",") ; MEM2 = FMT(MEM2, "%5.1f")
  1.059  HEAD         SELECTED CAL FACTOR TABLE: [S32]
  1.060  DISP         SENSOR TYPE: [S32]
  1.060  DISP
  1.060  DISP         The Reference Cal Factor is: [MEM2] %
# Retrieve the number of cal points for the selected sensor type.
  1.061  IEEE         [@441x]MEMORY:TABLE:FREQ:POINTS?[I]
  1.062  MATH         L[1] = MEM
# Retrieve a list of cal factor frequencies for the selected sensor type.
  1.063  IEEE         [@441x]MEMORY:TABLE:FREQ?[I$]
# Store retrieved cal factor frequencies from selected table in S[2].
  1.064  MATH         S[2] = MEM2
# Initialize frequency/cal factor pointer.
  1.065  MATH         L[2] = 0

  1.066  DO
# Increment pointer to next frequency/cal factor pair.
  1.067  MATH         L[2] = L[2] + 1
# Extract cal factor and format the returned value.
  1.068  MATH         S[3] = FLD(S[1], L[2], ",") ; S[3] = FMT(S[3], "%5.2f")
# Extract frequency and convert value (in base units) to MHz.
  1.069  MATH         L[4] = FLD(S[2], L[2], ",") ; S[4] = (L[4] / 1E+6)
# Format the returned frequency value.
  1.070  MATH         S[4] = FMT(S[4], "%8.1f")
  1.071  DISP         [32] SENSOR TYPE: [S32]
  1.071  DISP
  1.071  DISP         [32] FREQUENCY         CAL FACTOR
  1.071  DISP         [S4] MHz          [S3] %
  1.072  UNTIL        L[2] == L[1]

  1.073  HEAD         CAL FACTOR DATA REVIEW FINISHED
  1.074  OPBR         Do you wish to DELETE the cal factor data for the
  1.074  OPBR         [S32] table just reviewed?
  1.075  JMPL         DATA_DELETE                  MEM1 > 0
  1.076  JMPL         REPEAT?

  1.077  LABEL        DATA_DELETE
  1.078  HEAD         DELETE CAL FACTOR DATA

  1.079  IF           ZCMPI(S[32], "DEFAULT")
  1.080  OPBR         You have chosen to DELETE the DEFAULT cal factor table.
  1.080  OPBR
  1.080  OPBR         The DEFAULT cal factor table is used for performance
  1.080  OPBR         testing of the power meter and normally is NOT changed.
  1.080  OPBR
  1.080  OPBR         ARE YOU SURE you want to DELETE the DEFAULT table?
  1.080  OPBR
  1.080  OPBR         (Once deleted, the table data CANNOT be recovered.)

  1.081  ELSE
  1.082  OPBR         You have chosen to DELETE the cal factor table
  1.082  OPBR         named [S32].
  1.082  OPBR
  1.082  OPBR         ARE YOU SURE?
  1.082  OPBR
  1.082  OPBR         (Once deleted, the table data CANNOT be recovered.)
  1.083  ENDIF

  1.084  JMPL         SELECT_TABLE                 MEM1 < 0
  1.085  IEEE         [@441x]MEMORY:CLEAR:TABLE

  1.086  HEAD         [S32] CAL FACTOR TABLE DATA DELETED
  1.087  OPBR         Do you wish to INSERT cal factor data for the
  1.087  OPBR         [S32] table just deleted?
  1.088  JMPL         DATA_INSERT                  MEM1 > 0
  1.089  JMPL         REPEAT?

  1.090  LABEL        DATA_INSERT
  1.091  HEAD         INSERT CAL FACTOR DATA
  1.092  DISP         At the following prompt, begin the insertion of cal
  1.092  DISP         factor table data by first entering the reference
  1.092  DISP         cal factor.
  1.092  DISP
  1.092  DISP         Subsequently, you will then be prompted for the total
  1.092  DISP         number of frequency points to be entered followed by
  1.092  DISP         the entry of the actual frequency and cal factor data.

  1.093  HEAD         REFERENCE CAL FACTOR ENTRY
  1.094  MEMI         Enter (50 MHz) Reference Cal Factor in percent:
  1.095  MATH         S[6] = "MEM:TABLE:GAIN " & MEM & ","

  1.096  LABEL        NUMBER_OF_CAL_FACTORS
  1.097  HEAD         NUMBER OF CAL FACTORS ENTRY
  1.098  MEMI         Enter the total number of frequency/cal factors:
  1.099  JMPL         INITIALIZE_DATA              MEM > 0 && MEM <= 80
  1.100  DISP         CAL FACTOR TABLE SIZE EXCEEDED!
  1.100  DISP
  1.100  DISP         The maximum number of table entries allowed
  1.100  DISP         (excluding the reference cal factor) is 80.
  1.100  DISP
  1.100  DISP         Press "Advance" and re-enter the total number
  1.100  DISP         of points.
  1.101  JMPL         NUMBER_OF_CAL_FACTORS

  1.102  LABEL        INITIALIZE_DATA
  1.103  MATH         L[1] = MEM
  1.104  MATH         L[2] = 0
  1.105  MATH         S[5] = "MEM:TABLE:FREQ "
  1.106  MATH         MEM1 = 1

  1.107  LABEL        ENTER_CAL_FACTOR
  1.108  HEAD         CAL FACTOR [MEM1] FREQUENCY ENTRY
  1.109  MEMI         Enter frequency (in MHz) for cal factor [MEM1]:
  1.110  JMPL         CONTINUE_CAL_FACTOR          MEM > L[2]
  1.111  DISP         The previous cal factor frequency entered was:
  1.111  DISP         [L2] MHz.
  1.111  DISP
  1.111  DISP         The cal factor frequency just entered was:
  1.111  DISP         [MEM] MHz.
  1.111  DISP
  1.111  DISP         Cal factor frequencies MUST be entered in
  1.111  DISP         ascending order!
  1.112  JMPL         ENTER_CAL_FACTOR

  1.113  LABEL        CONTINUE_CAL_FACTOR
  1.114  HEAD         CAL FACTOR [MEM1] PERCENTAGE ENTRY
  1.115  MATH         L[2] = MEM
  1.116  MATH         S[5] = S[5] & (MEM * 1E+6)
  1.117  MEMI         Enter cal factor for [MEM] MHz in percent:
  1.118  MATH         S[6] = S[6] & MEM
  1.119  MATH         MEM1 = MEM1 + 1
  1.120  JMPL         STORE_CAL_FACTORS            MEM1 > L[1]
  1.121  MATH         S[5] = S[5] & ","
  1.122  MATH         S[6] = S[6] & ","
  1.123  JMPL         ENTER_CAL_FACTOR

  1.124  LABEL        STORE_CAL_FACTORS
  1.125  IEEE         [@441x][SREG5]
  1.125  IEEE         [@441x][SREG6]
  1.126  HEAD         [S32] CAL FACTOR TABLE DATA STORED
  1.127  OPBR         Cal factors entered were successfully stored.
  1.127  OPBR
  1.127  OPBR         Do you wish to REVIEW the [S32] cal factor table
  1.127  OPBR         for the data just entered?
  1.128  JMPL         DATA_REVIEW                  MEM1 > 0
  1.129  JMPL         END

  1.130  LABEL        REPEAT?
  1.131  HEAD
  1.132  OPBR         Do you wish to review, delete, or insert data
  1.132  OPBR         for ANOTHER model of power sensor?
  1.133  JMPL         MAIN_MENU                    MEM1 > 0
  1.134  JMPL         END

  1.135  LABEL        ERROR
  1.136  DISP         [MEM2]

  1.137  LABEL        END
  1.138  HEAD
  1.139  IEEE         [@441x]*RST
  1.140  END


M4418

Instrument Setup FSC

Description

The M4418 FSC allows specification of programming functions of the Agilent E4418B and Agilent/HP E4418A (formerly EPM-441A) not covered by the 4418 FSC.

RANGE Field

The RANGE field specifies the filter.

Number of readings to average entered as: Faverage.

Rules:

  1. Legal values for average are: 0, 1, 2, 4, 8,... 1024.
  2. When the RANGE field is F0, filter is turned off and trigger delay is set to off.
  3. When the RANGE field is F1, F2, ..., F1024, filter is turned on and trigger delay is set to on.
  4. When no valid RANGE field is entered, F256 is automatically inserted in the RANGE field.

NOMINAL Field

The NOMINAL field specifies the power sensor model number.

Rules:

Supported model numbers are:

  • E4412A (formerly ECP-E18A)
  • E4413A (formerly ECP-E26A)
  • E9300A
  • E9300B
  • E9300H
  • E9301A
  • E9301B
  • E9301H
  • E9304A
  • 8481A
  • 8481B
  • 8481D
  • 8481H
  • 8482A
  • 8482B
  • 8482H
  • 8483A
  • 8484A
  • 8485A
  • 8485D
  • Q8486A
  • Q8486D
  • R8486A
  • R8486D
  • V8486A
  • W8486A
  • 8487A
  • 8487D

TOLERANCE Field

The TOLERANCE field specifies the calibration factor or sensor calibration table name when the NOMINAL field specifies an 8480 series power sensor.

  • Calibration Factor entered as: [numeric][prefix]pct.
  • Sensor Calibration Table name: entered as: "table_name"
  • blank NOMINAL field specifies a E-series power sensor

Rules:

  1. The TOLERANCE field must be blank when the NOMINAL field specifies an E-series power sensor.
  2. Legal values for the calibration factor are 0% ("0pct") to 100% ("100pct").
  3. When the TOLERANCE field specifies only % ("pct"), without a numeric value, the calibration factor is taken from memory register MEM.
  4. When the NOMINAL field specifies an 8040 series power sensor and no calibration factor or sensor calibration table name is specified, the default table for the sensor is used (see the E4418B Programming Manual). The word "Default" (without double quotes) may optionally be specified in the TOLERANCE field to indicate that the default table for the sensor is to be used. This is equivalent to leaving the TOLERANCE field blank.

MOD1

Not used.

MOD2

Not used.

MOD3

Not used.

MOD4

Not used.

CON

Not used.

Examples

In statement 1.003, the name of the sensor calibration table is "TBL_2":

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
# ----- E-series power sensors -----
  1.001  M4418  F128  E4412A
# ----- 8480 series power sensors -----
  1.002  M4418  F512  8481A          99.72pct
# ----- 8480 series power sensors -----
  1.003  M4418  F512  8481A          "TBL_2"

Also refer to the on-line help for the 4418 FSC.


4419

Instrument FSC

Description

The 4419 FSC programs the Agilent E4419B and Agilent/HP E4419A (formally EPM-442A) Power Meters. For additional information about the models supported, see Device Mapping.

A single procedure may use up to 4 different power sensors on each channel during the course of procedure execution. A power sensor may not be swapped from channel A to channel B during procedure execution. Channel A and channel B can use the same model power sensor, however they must be physically unique assets.

When the power meter contains firmware with major revision 3 or later, the instrument driver uses the SERV:SENS[1|2]:TYPE? command to determine if the power sensor(s) specified in the most recently executed M4418 FSC is in fact connected to the power meter. For E-Series power sensors, the command returns the actual power sensor model connected to the power meter.

For 8480-Series power sensors only the suffix A, B, D, or H is returned so the check can only detect a sensor with an incorrect power range. When ASK+ W or ASK+ V is specified, automatic connection messages for calibrating the power sensor include any required attenuators and adapters to properly connect the power sensor to the power meter POWER REF output.

Note on E4419B serial control If the E4419B is to be controlled via its serial port, do not use the PORT FSC port configuration special construction, [P9600,N,...], to set the baud rate, parity, etc. of the port used to control the E4419B. MET/CAL executes a "Test" function for each System Instrument prior to executing any procedure statements. Therefore the settings of the port used to control the E4419B must be set correctly before a procedure is executed. If the E4419B is connected to a standard serial port (COM1, COM2, ..., COM16), use the "Ports" application in the Windows Control Panel to choose the proper settings. If the E4419B is connected to the 5500A, 5520A, 5800A, or 5820A UUT port, select the proper settings for the UUT Serial Port from the front panel of the calibrator. The following settings have been shown to work when controlling a E4419B via the RS-232 Interface. E4419B

DTR/DSR: | On
CTS/RTS: | On
Tx Pacing: | On
Rx Pacing: | On
Windows COMM port setting
Flow Control: | Xon / Xoff

Functional Capability

Function | 4419 MOD3 | 4419 Nominal | 4419 MOD1
RF Power1 | RF | -70 dBm to +44 dBm | 100 kHz to 110 GHz
 |  | 100 pW to 25 W
Zero sensor | ZR | 0 W | 100kHz to 110GHz
Zero and Cal. sensor | CP | 1 μW to 1 mW | 50 MHz
NOMINAL (Power) and MOD1 (frequency) ranges depend upon the power sensor model used (see M4419 NOMINAL and MOD1 fields):

Model | Power Range | Frequency Range
E-Series E441XA CW Power Sensors
E4412A | -70 to +20 dBm (100pW to 100mW) | 10 MHz to 18.0 GHz
E4413A | -70 to +20 dBm (100pW to 100mW) | 50 MHz to 26.5 GHz
E-Series E9300 Average Power Sensors
E9300A | -60 to +20 dBm (1 nW to 100 mW) | 10 MHz to 18.0 GHz
E9301A | -60 to +20 dBm (1 nW to 100 mW) | 10 MHz to 6.0 GHz
E9304A | -60 to +20 dBm (1 nW to 100 mW) | 9 kHz to 6.0 GHz
E9300B | -30 to +44 dBm (1 uW to 25 W) | 10 MHz to 18.0 GHz
E9301B | -30 to +44 dBm (1 uW to 25 W) | 10 MHz to 6.0 GHz
E9300H | -50 to +30 dBm (10 nW to 1 W) | 10 MHz to 18.0 GHz
E9301H | -50 to +30 dBm (10 nW to 1 W) | 10 MHz to 6.0 GHz
8480-Series Power Sensors
25 W Sensors
8481B | 0 to +44 dBm (1 mW to 25 W) | 10 MHz to 18.0 GHz
8482B | 0 to +44 dBm (1 mW to 25 W) | 100 kHz to 4.2 GHz
3 W Sensors
8481H | -10 to +35 dBm (100 μW to 3 W) | 10 MHz to 18.0 GHz
8482H | -10 to +35 dBm (100 μW to 3 W) | 100 kHz to 4.2 GHz
100 mW Sensors
8481A | -30 to +20 dBm (1 μW to 100 mW) | 10 MHz to 18.0 GHz
8482A | -30 to +20 dBm (1 μW to 100 mW) | 100 kHz to 4.2 GHz
8483A | -30 to +20 dBm (1 μW to 100 mW) | 100 kHz to 2.0 GHz
8485A | -30 to +20 dBm (1 μW to 100 mW) | 50 MHz to 26.5 GHz
Opt 033 | -30 to +20 dBm (1 μW to 100 mW) | 50 MHz to 33 GHz
R8486A | -30 to +20 dBm (1 μW to 100 mW) | 26.5 MHz to 40 GHz
Q8486A | -30 to +20 dBm (1 μW to 100 mW) | 33 MHz to 50 GHz
V8486A | -30 to +20 dBm (1 μW to 100 mW) | 50 GHz to 75 GHz
W8486A | -30 to +20 dBm (1 μW to 100 mW) | 75 MHz to 110 GHz
8487A | -30 to +20 dBm (1 μW to 100 mW) | 50 MHz to 50 GHz
10 μW High Sensitivity Sensors
8481D | -70 to -20 dBm (100 pW to 10 μW) | 10 MHz to 18.0 GHz
8484A | -70 to -20 dBm (100 pW to 10 μW) | 10 MHz to 18.0 GHz
8485D | -70 to -20 dBm (100 pW to 10 μW) | 50 MHz to 26.5 GHz
Opt 033 | -70 to -20 dBm (100 pW to 10 μW) | 50 MHz to 33 GHz
R8486D | -70 to -20 dBm (100 pW to 10 μW) | 26.5 MHz to 40 GHz
Q8486D | -70 to -20 dBm (100 pW to 10 μW) | 33 MHz to 50 GHz
8487D | -70 to -20 dBm (100 pW to 10 μW) | 50 MHz to 50 GHz

Parameters

4419 FSC NOMINAL, MOD2, MOD3, CON Rules

Measurement | Nominal | MOD2 | MOD3 | CON
Zero A | W |  | ZR | CH1
Zero B | W |  | ZR | CH2
Zero & Cal A | W |  | CP | CH1
Zero & Cal B | W |  | CP | CH2
Power A (set ref) | W | D |  | RS | CH1
Power B (set ref) | W | D |  | RS | CH2
Power A (relative) | W | D |  | RL | CH1
Power B (relative) | W | D |  | RL | CH2
Power A (absolute) | W | D |  | RF | CH1
Power B (absolute) | W | D |  | RF | CH2
Difference A-B (set ref) | W | D | -D | RS | CH1
Difference B-A (set ref) | W | D | -D | RS | CH2
Difference A-B (relative) | W | D | -D | RL | CH1
Difference B-A (relative) | W | D | -D | RL | CH2
Difference A-B (absolute) | W | D | -D | RF | CH1
Difference B-A (absolute) | W | D | -D | RF | CH2
Ratio A/B (set ref) | dB | pct | RT | RS | CH1
Ratio B/A (set ref) | dB | pct | RT | RS | CH2
Ratio A/B (relative) | dB | pct | RT | RL | CH1
Ratio B/A (relative) | dB | pct | RT | RL | CH2
Ratio A/B (absolute) | dB | pct | RT | RF | CH1
Ratio B/A (absolute) | dB | pct | RT | RF | CH2
Note, blank entries in the above table are significant and must be blank. FSC field interdependencies not expressed in this table are listed under "Rules" for the appropriate parameter.

RANGE

This field specifies the UUT range as described in the RANGE Field topic.

NOMINAL

This field specifies the expected measured value or a reset.

  • RF Power entered as [numeric][prefix]W or D.
  • RF Power Difference entered as [numeric][prefix]W or D.
  • RF Power Ratio entered as [numeric][prefix]pct or dB.
  • Relative Power entered as [numeric][prefix]pct or dB.
  • Relative Difference entered as [numeric][prefix]pct or dB.
  • Relative Ratio entered as [numeric][prefix]pct or dB.
  • RF Power entered as [numeric][prefix]W or D.
  • Reset entered as *.

Rules:

  1. When the Nominal field contains only units, the value is obtained from memory register MEM. In this case the MOD1 field MUST contain a value.

TOLERANCE

This field specifies the UUT tolerance as described in the TOLERANCE Field topic.

MOD1

This field specifies the frequency.

  • Frequency entered as [numeric][prefix]H.
  • blank not applicable

Rules:

  1. For difference and ratio measurements, the frequency of the channel A and channel B signals is presumed to be the same.
  2. When the MOD1 field contains only units, the value is obtained from memory register MEM. In this case the Nominal field MUST contain a value.

MOD2

This field is used to specify a difference or ratio measurement.

-D | Difference A-B or B-A
RT | Ratio A/B or B/A
blank | not applicable

Rules:

  1. The MOD2 field must be blank except for difference and ratio measurements.
  2. If no MOD2 field code is specified and the Nominal field units are dB or pct, RT is automatically entered in the MOD2 field.

MOD3

This field specifies the measurement type:

ZR | Zero sensor
CP | Zero and Calibrate sensor
RS | Set reference
RL | Relative
RF | Absolute

Rules:

  1. The MOD3 field may specify ZR or CP only for a Nominal Setup Test (MOD4 = N). However MEM is not updated when MOD3 is ZR or CP.
  2. When the MOD3 field is ZR, CP, RS, or RF, the Nominal field units must be watts "W" or dBm "D".
  3. When the MOD2 field is blank or -D and the MOD3 field is ZR, CP, RS, or RF, the Nominal field units must be watts "W" or dBm "D".
  4. When the MOD2 field is RT, Nominal field units must be percent "pct" or ratio "dB".
  5. When the MOD3 field is RL, Nominal field units must be percent "pct" or ratio "dB".
  6. When the Nominal field units are watts "W" or dBm "D" and no MOD3 field code is entered, RF is inserted automatically in the MOD3 field.
  7. When the Nominal field units are percent "pct" or ratio "dB" and no MOD3 field code is entered, RL is inserted automatically in the MOD3 field.

MOD4

This field specifies the type of test being performed as described in the MOD4 Field topic.

CON

This field is specifies the input channel(s).

CH1 | Channel A
CH2 | Channel B

Rules:

  1. If no CON field code is specified, CH1 is automatically entered in the CON field.

Use of Standard Memory Locations and Results Reporting

System memory locations MEM and MEM1 are used. For more information, refer to the Use of Standard Memory Registers topic.

Examples

  1.001  ASK-   R     N              P     U                      F
# Use MET/CAL's automatic connection message for connection to Power ref.
  1.002  ASK+                                                              V
# Zero and Calibrate (Ch A)
  1.003  DISP         Connect the HP 8481A Power Sensor to the E4419B Ch A.
  1.004  MEMI         Enter sensor’s reference calibration factor in percent.
  1.005  M4419  F256  8481A          pct
  1.006  4419         1mW                          50MH              CP N  CH1
# Turn off automatic connection messages
  1.007  ASK-   R   Q N              P     U                      F        V
# Absolute Power Measurement (Ch A): dBm
# Assume factory default table for HP 8481A Power Sensor Data.
  1.008  M4419  F4    8481A
  1.009  DISP         Connect the Ch A 8481A to the 6060 RF Output.
  1.010  IEEE         [@6060]AP-30DB,FR100E6HZ
  1.011  4419         -30.00D        3.00U         100MH             RF    CH1
  2.001  IEEE         [@6060]AP10DB,FR100E6HZ
  2.002  4419         10.00D         1.00U         100MH             RF    CH1
# Relative Power Measurement (Ch A): dB
  3.001  IEEE         [@6060]AP10DB,FR100E6HZ
  3.002  4419         10.00D                       100MH             RF N  CH1
  3.003  IEEE         [@6060]AP0DB
  3.004  4419         -9.00dB        2.00U         100MH             RL    CH1
# Absolute Power Measurement (Ch A): Watts
  4.001  IEEE         [@6060]AP-30DB,FR100E6HZ[D2000]
  4.002  4419         1.00uW         25%           100MH             RF    CH1
  5.001  IEEE         [@6060]AP10DB,FR100E6HZ
  5.002  4419         10.00mW        5%            100MH             RF    CH1
# Relative Power Measurement (Ch A): %
  6.001  IEEE         [@6060]AP10DB,FR100E6HZ
  6.002  4419         10.00mW                      100MH             RF N  CH1
  6.003  IEEE         [@6060]AP0DB,FR100E6HZ
  6.004  4419         10.00pct       5%            100MH             RL    CH1
# Filter (Ch A): Off
  7.001  M4419  F256  8481A
  7.002  IEEE         [@6060]AP-1DB,FR150E6HZ
  7.003  4419         -1.00D                       150MH             RF N  CH1
# Filter (Ch A): 1
  7.004  M4419  F1    8481A
  7.005  IEEE         [@6060]AP-1DB,FR150E6HZ
  7.006  4419         -1.00D                       150MH             RF N  CH1
# Filter (Ch A): 1024
  7.007  M4419  F1024 8481A
  7.008  IEEE         [@6060]AP-2DB,FR150E6HZ
  7.009  4419         -2.000D                      150MH             RF N  CH1

# Use MET/CAL's automatic connection message for connection to Power ref.
  7.010  ASK+                                                              V
# Zero and Calibrate (Ch B)
  7.011  DISP         Connect the HP 8481A Power Sensor to the E4419B Ch B.
# Zero and Calibrate sensor
  7.012  MEMI         Enter sensor’s reference calibration factor in percent.
  7.013  M4419  F256  8481A          pct           8481A          pct
  7.014  4419         1mW                          50MH              CP N  CH2
# Turn off automatic connection messages
  7.015  ASK-   R   Q N              P     U                      F        V
# Absolute Power Measurement (Ch B): dBm
# Assume factory default table for HP 8481A Power Sensor Data.
  7.016  M4419  F4    8481A                        8481A
  7.017  DISP         Connect the Ch A 8481A to the 6060 RF Output.
  7.018  IEEE         [@6060]AP-20DB,FR100E6HZ
  7.019  4419         -20.00D        1.00U         100MH             RF    CH2
  8.001  IEEE         [@6060]AP0DB,FR100E6HZ
  8.002  4419         0.00D          1.00U         100MH             RF    CH2
# Relative Power Measurement (Ch B): dB
  9.001  IEEE         [@6060]AP10DB,FR100E6HZ
  9.002  4419         10.00D                       100MH             RS N  CH2
  9.003  IEEE         [@6060]AP0DB,FR100E6HZ
  9.004  4419         -9.00dB        2.00U         100MH             RL    CH2
# Absolute Power Measurement (Ch B): Watts
 10.001  IEEE         [@6060]AP-10DB,FR100E6HZ
 10.002  4419         100.0uW        5%            100MH             RF    CH2
 11.001  IEEE         [@6060]AP10DB,FR100E6HZ
 11.002  4419         10.00mW        5%            100MH             RF    CH2
# Relative Power Measurement (Ch B): %
 12.001  IEEE         [@6060]AP10DB,FR100E6HZ
 12.002  4419         10.00mW                      100MH             RS N  CH2
 12.003  IEEE         [@6060]AP0DB,FR100E6HZ
 12.004  4419         10.00pct       5%            100MH             RL    CH2

# Use MET/CAL's automatic connection message for connection to power ref.
 13.001  ASK+                                                              V
# Zero and Calibrate (Ch A)
 13.002  MEMI         Enter 8485A reference calibration factor in percent.
 13.003  M4419  F256  8485A          pct
 13.004  4419         W                            50MH              CP N  CH1
# Zero and Calibrate (Ch B)
 13.005  MEMI         Enter 8481A reference calibration factor in percent.
 13.006  M4419  F256  8485A          pct           8481A          pct
 13.007  4419         1mW                          50MH              CP N  CH2
# Turn off automatic connection messages
 13.008  ASK-   R   Q N              P     U                      F        V
 13.009  DISP         Connect Ch A 8485A to 9500 Ch1 Active Head.
 13.009  DISP         Connect Ch B 8481A to the 6060 RF Output.
# Assume factory default table for 8485A and 8481A Power Sensor Data.
 13.010  M4419  F4    8485A                        8481A
# Absolute Power Difference (Ch A - Ch B): dBm
 13.011  IEEE         [@9500]FUNC SIN;:ROUT:SIGN:PATH CH1;IMP 50
 13.011  IEEE         [@9500]VOLT 2;:FREQ 50e6;:OUTP:STAT ON;*OPC?[I!]
 13.012  IEEE         [@6060]AP2DB,FR50E6HZ
 13.013  4419         9.25D          0.20U         50MH           -D RF    CH1
# Relative Power Difference (Ch A - Ch B): dB
 14.001  IEEE         [@9500]FUNC SIN;:ROUT:SIGN:PATH CH1;IMP 50
 14.001  IEEE         [@9500]VOLT 2;:FREQ 50e6;:OUTP:STAT ON;*OPC?[I!]
 14.002  IEEE         [@6060]AP2DB,FR50E6HZ
 14.003  4419         9.54D                        50MH           -D RS N  CH1
 14.004  IEEE         [@6060]AP-10DB
 14.005  4419         0.71dB         0.20U         50MH           -D RL    CH1
# Absolute Power Difference (Ch B - Ch A): dBm
 15.001  IEEE         [@9500]FUNC SIN;:ROUT:SIGN:PATH CH1;IMP 50
 15.001  IEEE         [@9500]VOLT 2;:FREQ 50e6;:OUTP:STAT ON;*OPC?[I!]
 15.002  IEEE         [@6060]AP12DB,FR50E6HZ
 15.003  4419         7.65D          0.20U         50MH           -D RF    CH2
# Relative Power Difference (Ch B - Ch A): dB
 16.001  IEEE         [@9500]FUNC SIN;:ROUT:SIGN:PATH CH1;IMP 50
 16.001  IEEE         [@9500]VOLT 2;:FREQ 50e6;:OUTP:STAT ON;*OPC?[I!]
 16.002  IEEE         [@6060]AP12DB,FR50E6HZ
 16.003  4419         7.65D                        50MH           -D RS N  CH2
 16.004  IEEE         [@9500]FUNC SIN;:ROUT:SIGN:PATH CH1;IMP 50
 16.004  IEEE         [@9500]VOLT 1;:FREQ 50e6;:OUTP:STAT ON;*OPC?[I!]
 16.005  IEEE         [@6060]AP10DB
 16.006  4419         1.07dB         0.20U         50MH           -D RL    CH2
# Absolute Power Difference (Ch A - Ch B): Watts
 17.001  IEEE         [@9500]FUNC SIN;:ROUT:SIGN:PATH CH1;IMP 50
 17.001  IEEE         [@9500]VOLT 2;:FREQ 50e6;:OUTP:STAT ON;*OPC?[I!]
 17.002  IEEE         [@6060]AP10DB,FR50E6HZ
 17.003  4419         0.00mW         0.20U         50MH           -D RF    CH1
# Relative Power Difference (Ch A - Ch B): %
 18.001  IEEE         [@9500]FUNC SIN;:ROUT:SIGN:PATH CH1;IMP 50
 18.001  IEEE         [@9500]VOLT 2;:FREQ 50e6;:OUTP:STAT ON;*OPC?[I!]
 18.002  IEEE         [@6060]AP2DB,FR50E6HZ
 18.003  4419         8.41mW                       50MH           -D RS N  CH1
 18.004  IEEE         [@6060]AP-10DB
 18.005  4419         118pct         2%            50MH           -D RL    CH1
# Absolute Power Difference (Ch B - Ch A): Watts
 19.001  IEEE         [@9500]FUNC SIN;:ROUT:SIGN:PATH CH1;IMP 50
 19.001  IEEE         [@9500]VOLT 2;:FREQ 50e6;:OUTP:STAT ON;*OPC?[I!]
 19.002  IEEE         [@6060]AP10DB,FR50E6HZ
 19.003  4419         0.00mW         0.20U         50MH           -D RF    CH2
# Relative Power Difference (Ch B - Ch A): Watts
 20.001  IEEE         [@9500]FUNC SIN;:ROUT:SIGN:PATH CH1;IMP 50
 20.001  IEEE         [@9500]VOLT 2;:FREQ 50e6;:OUTP:STAT ON;*OPC?[I!]
 20.002  IEEE         [@6060]AP2DB,FR50E6HZ
 20.003  4419         -8.41mW                      50MH           -D RS N  CH2
 20.004  IEEE         [@6060]AP-10DB
 20.005  4419         118pct         2%            50MH           -D RL    CH2
# Absolute Power Ratio (Ch A / Ch B): dB
 21.001  IEEE         [@9500]FUNC SIN;:ROUT:SIGN:PATH CH1;IMP 50
 21.001  IEEE         [@9500]VOLT 2;:FREQ 50e6;:OUTP:STAT ON;*OPC?[I!]
 21.002  IEEE         [@6060]AP2DB,FR50E6HZ
 21.003  4419         8.00dB         0.20U         50MH           RT RF    CH1
# Relative Power Ratio (Ch A / Ch B): dB
 22.001  IEEE         [@9500]FUNC SIN;:ROUT:SIGN:PATH CH1;IMP 50
 22.001  IEEE         [@9500]VOLT 2;:FREQ 50e6;:OUTP:STAT ON;*OPC?[I!]
 22.002  IEEE         [@6060]AP2DB,FR50E6HZ
 22.003  4419         8.00dB                       50MH           RT RS N  CH1
 22.004  IEEE         [@6060]AP1DB
 22.005  4419         1.00dB         0.20U         50MH           RT RL    CH1
# Absolute Power Ratio (Ch B / Ch A): dB
 23.001  IEEE         [@9500]FUNC SIN;:ROUT:SIGN:PATH CH1;IMP 50
 23.001  IEEE         [@9500]VOLT 2;:FREQ 50e6;:OUTP:STAT ON;*OPC?[I!]
 23.002  IEEE         [@6060]AP2DB,FR50E6HZ
 23.003  4419         -8.00dB        0.20U         50MH           RT RF    CH2
# Relative Power Ratio (Ch B / Ch A): dB
 24.001  IEEE         [@9500]FUNC SIN;:ROUT:SIGN:PATH CH1;IMP 50
 24.001  IEEE         [@9500]VOLT 2;:FREQ 50e6;:OUTP:STAT ON;*OPC?[I!]
 24.002  IEEE         [@6060]AP2DB,FR50E6HZ
 24.003  4419         -8.00dB                      50MH           RT RS N  CH2
 24.004  IEEE         [@6060]AP1DB
 24.005  4419         -1.00dB        0.20U         50MH           RT RL    CH2
# Absolute Power Ratio (Ch A / Ch B): %
 25.001  IEEE         [@9500]FUNC SIN;:ROUT:SIGN:PATH CH1;IMP 50
 25.001  IEEE         [@9500]VOLT 2;:FREQ 50e6;:OUTP:STAT ON;*OPC?[I!]
 25.002  IEEE         [@6060]AP7DB,FR50E6HZ
 25.003  4419         200pct         3%            50MH           RT RF    CH1
# Relative Power Ratio (Ch A / Ch B): %
 26.001  IEEE         [@9500]FUNC SIN;:ROUT:SIGN:PATH CH1;IMP 50
 26.001  IEEE         [@9500]VOLT 2;:FREQ 50e6;:OUTP:STAT ON;*OPC?[I!]
 26.002  IEEE         [@6060]AP10DB,FR50E6HZ
 26.003  4419         100pct                       50MH           RT RS N  CH1
 26.004  IEEE         [@6060]AP7DB
 26.005  4419         200pct         3%            50MH           RT RL    CH1
# Absolute Power Ratio (Ch B / Ch A): %
 27.001  IEEE         [@9500]FUNC SIN;:ROUT:SIGN:PATH CH1;IMP 50
 27.001  IEEE         [@9500]VOLT 2;:FREQ 50e6;:OUTP:STAT ON;*OPC?[I!]
 27.002  IEEE         [@6060]AP7DB,FR50E6HZ
 27.003  4419         49.8pct        3%            50MH           RT RF    CH2
# Relative Power Ratio (Ch B / Ch A): %
 28.001  IEEE         [@9500]FUNC SIN;:ROUT:SIGN:PATH CH1;IMP 50
 28.001  IEEE         [@9500]VOLT 2;:FREQ 50e6;:OUTP:STAT ON;*OPC?[I!]
 28.002  IEEE         [@6060]AP10DB,FR50E6HZ
 28.003  4419         100pct                       50MH           RT RS N  CH2
 28.004  IEEE         [@6060]AP7DB
 28.005  4419         49.8pct        3%            50MH           RT RL    CH2

 29.001  HEAD         ABSOLUTE POWER RATIO (Ch A / Ch B): %
# Select filter 16, Ch A E4412A, Ch B 8481A
 29.002  M4419  F16   E4412A                       8481A
 29.003  DISP         Connect E4412A power sensor to E4419B Channel A.
 29.003  DISP         Connect 8481A power sensor to E4419B Channel B.
# Zero and calibrate power sensors.
 29.004  4419         1mW                          50MH              CP N  CH1
 29.005  4419         1mW                          50MH              CP N  CH2
 29.006  ASK-                                                              V
 29.007  DISP         Connect Ch A 8485A to 9500 Ch1 Active Head.
 29.008  DISP         Connect Ch B 8481A to the 6060 RF Output.
# Set 9500B to 10mW
 29.009  IEEE         [@9500]FUNC SIN;:ROUT:SIGN:PATH CH1;IMP 50
 29.009  IEEE         [@9500]VOLT 2;:FREQ 50e6;:OUTP:STAT ON;*OPC?[I!]
# Set 6060B to 5mW
 29.010  IEEE         [@6060]AP7DB,FR50E6HZ
# Get E4419B power ratio measurement in percent.
 29.011  4419         200pct                       50MH           RT RF N  CH1
# Get E4419B spec for E4412A measuring 10mW, 50MHz with filter 16.
 29.012  MATH         S[1] = "Agilent E4419B"
 29.013  MATH         S[2] = "Watts E441XA F16"
 29.014  MATH         M[1] = ACCV2(S[1], S[2], 10e-3, 50e6)
# Convert to percent.
 29.015  MATH         M[1] = M[1] / 10e-3 * 100
# Get E4419B spec for 8481A measuring 5mW, 50MHz with filter 16.
 29.016  MATH         S[2] = "Watts 100mW F16"
 29.017  MATH         M[2] = ACCV2(S[1], S[2], 5e-3, 50e6)
# Convert to percent.
 29.018  MATH         M[2] = M[2] / 5e-3 * 100
# Compute E4419B ratio accuracy in percent.
 29.019  MATH         M[3] = RSS2(M[1], M[2])
 29.020  ACC          200pct         M3%
 29.021  MEMC         200pct         10%           50MH

# This procedure is used to store cal factors for an 8480 series power sensor
# in a E4418B, E4419B, E4418A (EPM-441A), or E4419A (EPM-442A) power meter.
#
# Source:
#        HP EPM-441A/442A Power Meters Programming Guide
#        HP Part No. E4418-90025, March 1998
#
# Compatibility:
#        MET/CAL 7.0 or later
#
# Subprocedure:
#        None
#
# Registers Used:
#        M[1] - # of cal factors to be entered (excluding ref cal factor)
#        MEM1 - Cal factor counter
#        S[1] - Frequencies associated with cal factors.
#        S[2] - Ref Cal Factor and Cal Factors
#
# The cal factor table has the following format:
#
#        Frequency S[1]              Cal Factors S[2]
#        --------------              ----------------
#             --                     ref cal factor
#        frequency 1                 cal factor 1
#        frequency 2                 cal factor 2
#        frequency 3                 cal factor 3
#             .                           .
#             .                           .
#        frequency n                 cal factor n
#
# The following rules apply:
#
# 1) The number of frequency points must be one less than the number of cal
#    points. This is verified when the sensor calibration table is selected.
# 2) The frequencies must be in ascending order.
# 3) All frequencies are truncated to a multiple of 1 kHz.
# 4) Maximum of 81 cal points are allowed.
#
# Note, this procedure has no explicit error checking of 441x remote commands.
# When used with MET/CAL 7.0 or later, configuring a E4418B or E4419B
# establishes the alias 441x. If a command in an IEEE FSC in this procedure
# causes an error, it is caught by the SRQ handler in the MET/CAL 441x driver.

 30.001  HEAD         ENTER CAL FACTOR TABLE NAME
 30.002  MEM2         Enter cal factor table name:
 30.003  IEEE         [@441x]MEM:TABLE:SELECT "[MEM2]"
 30.004  HEAD         ENTER REFERENCE CAL FACTOR
 30.005  MEMI         Enter reference cal factor in percent:
 30.006  MATH         S[2] = "MEM:TABLE:GAIN " & MEM & ","
 30.007  LABEL        ENTER_NUMBER_CAL_FACTORS
 30.008  HEAD         ENTER NUMBER CAL FACTORS
 30.009  MEMI         Enter number of cal factors:
 30.010  JMPL         CONTINUE_NUM_CAL_FACTORS     MEM <= 80

 30.011  DISP         Number of cal factors must <= 80.
 30.012  JMPL         ENTER_CAL_FACTOR

 30.013  LABEL        CONTINUE_NUM_CAL_FACTORS
 30.014  MATH         M[1] = MEM
 30.015  MATH         M[2] = 0
 30.016  MATH         S[1] = "MEM:TABLE:FREQ "
 30.017  MATH         MEM1 = 1

 30.018  LABEL        ENTER_CAL_FACTOR
 30.019  MEMI         Enter frequency #[MEM1] in hertz:
 30.020  JMPL         CONTINUE_CAL_FACTOR          MEM > M[2]
 30.021  DISP         Frequencies must be entered in ascending order.
 30.022  JMPL         ENTER_CAL_FACTOR

 30.023  LABEL        CONTINUE_CAL_FACTOR
 30.024  MATH         M[2] = MEM
 30.025  MATH         S[1] = S[1] & MEM
 30.026  MEMI         Enter cal factor #[MEM1] in percent:
 30.027  MATH         S[2] = S[2] & MEM
 30.028  MATH         MEM1 = MEM1 + 1
 30.029  JMPL         STORE_CAL_FACTORS            MEM1 > M[1]

 30.030  MATH         S[1] = S[1] & ","
 30.031  MATH         S[2] = S[2] & ","
 30.032  JMPL         ENTER_CAL_FACTOR

 30.033  LABEL        STORE_CAL_FACTORS
 30.034  IEEE         [@441x][SREG1]
 30.034  IEEE         [@441x][SREG2]
 30.035  DISP         Cal factors successfully stored.
 30.036  JMPL         END

 30.037  LABEL        ERROR
 30.038  DISP         [MEM2]

 30.039  LABEL        END
 30.040  END


M4419

Auxiliary Instrument Setup FSC

Description

The M4419 FSC allows specification of programming functions of the Agilent E4419B and Agilent/HP E4419A (formerly EPM-442A) not covered by the 4419 FSC.

RANGE Field

The RANGE field specifies the filter.

  • Number of readings to average entered as: Faverage.

Rules:

  1. Legal values for average are: 0, 1, 2, 4, 8, ..., 1024.
  2. When the RANGE field is F0, filter is turned off and trigger delay is set to off.
  3. When the RANGE field is F1, F2, ..., F1024, filter is turned on and trigger delay is set to on.
  4. When no valid RANGE field is entered, F256 is automatically inserted in the RANGE field.

NOMINAL Field

The NOMINAL field specifies the channel A power sensor model number.

Rules:

  1. Supported model numbers are:
    • E4412A (formerly ECP-E18A)
    • E4413A (formerly ECP-E26A)
    • E9300A
    • E9300B
    • E9300H
    • E9301A
    • E9301B
    • E9301H
    • E9304A
    • 8481A
    • 8481B
    • 8481D
    • 8481H
    • 8482A
    • 8482B
    • 8482H
    • 8483A
    • 8484A
    • 8485A
    • 8485D
    • Q8486A
    • Q8486D
    • R8486A
    • R8486D
    • V8486A
    • W8486A
    • 8487A
    • 8487D

TOLERANCE Field

The TOLERANCE field specifies the channel A calibration factor or channel A sensor calibration table name when the NOMINAL field specifies an 8480 series power sensor.

  • Channel A Calibration Factor entered as: [numeric][prefix]pct.
  • Channel A Sensor Calibration Table Name: entered as: “table_name”
  • blank NOMINAL field specifies an E-series power sensor.

Rules:

  1. The TOLERANCE field must be blank when the NOMINAL field specifies an E-series power sensor.
  2. Legal values for calibration factor are 0 to 100%.
  3. When the TOLERANCE field specifies only % (“pct”), without a numeric value, the cal factor is taken from memory register MEM.
  4. When the NOMINAL field specifies an 8040 series power sensor and the TOLERANCE field does not specify a calibration factor or sensor calibration table name, the default table for the sensor is used (see the E4419B Programming Manual).

The word “Default” (without enclosing double quotes) may be entered in the TOLERANCE field to indicate that the default table for the sensor is to be used. This is equivalent to leaving the field blank. However, in the case where a calibration table name is specified for channel B (in MOD2 through CON), it is necessary to explicitly enter “Default” in the TOLERANCE field if the default table for the sensor is to be used for channel A. (Otherwise, MET/CAL assumes the specified table name is for channel A.)

MOD1

The MOD1 field specifies the channel B power sensor model number.

Rules:

  1. Same as NOMINAL field rules (see above).

MOD2, MOD3, MOD4, & CON

The MOD2 through CON fields are combined and used to specify the channel B calibration factor or sensor calibration table name when the MOD1 field specifies an 8480 series power sensor.

Channel B Calibration Factor entered as: [numeric][prefix]pct.

Channel B Sensor Calibration Table Name: entered as: “tablename”

blank NOMINAL field specifies a E-series power sensor

Rules:

  1. The MOD2 through CON fields must be blank when the MOD1 field specifies an E-series power sensor.
  2. Legal values for calibration factor are 0 to 100%.
    • When the MOD2 through CON fields specify only % (“pct”), no value, the cal factor is taken from memory register MEM.
    • When the MOD1 field specifies an 8040 series power sensor and the MOD2 through CON fields do not specify a calibration factor or sensor calibration table name, the default table for the sensor is used (see the E4419B Programming Manual).
  3. The word “Default” (without enclosing double quotes) may optionally be entered to indicate that the default table for the sensor is to be used. (Specifying “Default” is equivalent to leaving the field blank.)

Examples

# ----- E-series power sensors -----
  1.001  M4419  F128  E4412A                       E4413A
# ----- 8480 series power sensors -----
  1.002  M4419  F512  8481A          99.72pct      8485A          99.83pct
# ----- 8480 series power sensors -----
  1.003  M4419  F512  8481A          "TBL_2"       8485A          "TBL_3"

In statement 1.003 above the name of the channel A sensor calibration table is “TBL_2” and the name of the channel B sensor calibration table is “TBL_3”.

# ----- 8480 series power sensors -----
  1.004  M4419  F512  8481A          Default       8485A          "TBL_3"

In statement 1.004 above the default table is used for the channel A sensor and and the name of the channel B sensor calibration table is “TBL_3”.

Also refer to the on-line help for the 4419 FSC.


EPM

Description

The EPM FSC controls the Agilent/HP EPM Series Power Meters:

  • EPM-441A
  • EPM-442A
  • E4418A
  • E4418B
  • E4419A
  • E4419B
  • N1913A
  • N1914A

Note on E4418B and E4419B serial control:

If an E441xB is to be controlled via its serial port, do not use the PORT FSC port configuration special construction, [P9600,N,...], to set the baud rate, parity, etc. of the port used to control the E441xB. MET/CAL executes a "Test" function for each System Instrument prior to executing any procedure statements. Therefore, the settings of the port used to control the E441xB must be set correctly before a procedure is executed. If the E441xB is connected to a standard serial port (COM1, COM2, ..., COM16), use the "Ports" application in the Windows Control Panel to choose the proper settings. If the E4419B is connected to the 5500A, 5520A, 5522A, 5800A, or 5820A UUT port, select the proper settings for the UUT Serial Port from the front panel of the calibrator.

The following settings have been shown to work when controlling an E441xB via the RS-232 interface.

E441xB

DTR/DSR: On

CTS/RTS: On

Tx Pacing: On

Rx Pacing: On

Windows COMM port setting

Flow Control: Xon / Xoff

Power Sensors

The following power sensors are supported by the EPM FSC:

                    kHz       MHz                     GHz
                 --------|-----------|-------------------------------------
                 9  100  10  50 300  2  4.2  6   18 26.5 33  40  50  75 110
                 |   |   |   |   |   |   |   |   |   |   |   |   |   |   |
  -70 to -20 dBm         <======== 8481D ========>
        "                    <========== 8485D =======---> OPT 033
        "                    <============== 8487D ==============>
  -70 to +20 dBm         <======= E4412A ========>
        "                    <======== E4413A =======>
  -60 to +20 dBm         <===== E9301A ======>
        "        <========== E9304A ==========---> OPT H18
        "                <========= E9300A ======>
        "                    <=== E9300A OPT H24 ===>
        "        <========== U2004A =========>
        "                <===== U2001A ======>
        "                <======= U2000A ========>
        "                    <======= U2002A ======>
  -50 to +30 dBm         <===== E9301H ======>
        "                <======= E9300H ========>
        "        <========== E9304A ==========---> OPT H19
        "                    <=== E9300A OPT H25 ===>
        "                <===== U2001H ======>
        "                <======= U2000H ========>
        "                    <======= U2002H ======>
  -35 to +20 dBm     <======= N8482A ========>
        "                <======= N8481A ========>
        "                <========= N8485A ===========---> OPT 033
        "                                            <=N8486AR>
        "                                                <N8486AQ>
        "                    <============= N8487A ==============>
        "                <=============== N8488A ===================>
  -30 to +20 dBm     <==== 8483A ====> (75 ohm)
        "            <====== 8482A ======>
        "            <== N8482A OPT CFT =>
        "                <======== 8481A ========>
        "                <==== N8481A OPT CFT ===>
        "                    <========== 8485A =======---> OPT 033
        "                    <====== N8485A OPT CFT ==---> OPT 033
        "                    <============== 8487A ==============>
        "                    <========== N8487A OPT CFT =========>
        "                                            <=R8486A>
        "                                            <=======> (N8486AR OPT CFT)
        "                                                <=Q8486A>
        "                                                <=======> (N8486AQ OPT CFT)
        "                                                      <=====> (V8486A)
        "                                                            <=====> (W8486A)
  -30 to +44 dBm         <===== E9301B ======>
        "                <======= E9300B ========>
        "                <===== U2001B ======>
        "                <======= U2000B ========>
  -15 to +35 dBm     <===== N8482H ======>
        "                <======= N8481H ========>
  -10 to +35 dBm     <====== 8482H ======>
        "            <== N8482H OPT CFT =>
        "                <======== 8481H ========>
        "                <==== N8481H OPT CFT ===>
   -5 to +44 dBm     <===== N8482B ======>
        "                <======= N8481B ========>
    0 to +44 dBm     <====== 8482B ======>
        "            <== N8482B OPT CFT =>
        "                <======== 8481B ========>
        "                <=== N8481B OPT CFT ====>

Rules:

  1. EPM-44xA, E441xA, and E441xB require firmware version A1.04.00 (single channel models or A2.04.00 (dual channel models) or later to support E93xxA sensors.
  2. EPM-44xA, E441xA, and E441xB require firmware version A1.06.00 (single channel models or A2.06.00 (dual channel models) or later to support E93xxB/H sensors.
  3. EPM-44xA, E441xA, and E441xB require firmware version A1.09.00 (single channel models or A2.09.00 (dual channel models) or later to support N84xxA sensors.
  4. EPM-44xA, E441xA, and E441xB require firmware version A1.09.01 (single models or A2.09.01 (dual channel models) or later to support N84xxB/H,channel N8487A, and N8486AR/Q sensors.

Parameters

An EPM statement consists of one or more parameters. A parameter consists of a name and a value. Each parameter must be separated by a semicolon and/or one or more spaces. A single EPM statement can encompass more than one physical line as long as the line numbers are the same. However, each parameter name and its value must occur on one line. A single line can accommodate up to 256 characters including the statement number and FSC. Note that characters above ASCII 128 count as 2 characters.

Syntax:

EPM parameter[separatorparameter]

parameter ::= [prefix]parameter name[sp]=[sp]parameter value

separator ::= ;[sp] | sp

prefix ::= + | @

sp ::= one or more spaces

parameter name ::= see PARAMETERS NAMES section below

parameter value ::= see PARAMETERS NAMES section below

|
Denotes "or" (i.e. A | B is A or B)
[ ]
Denotes an optional syntax element, except in examples. In examples [ ] enclose a special construction.
+
Designates the parameter as the Evaluation Quantity
@
Designates the parameter as the Modifier Quantity

Rules:

  1. One and only one parameter must be designated as the Evaluation Quantity in an EPM Measure (default), Setup, or Read action.
  2. When an EPM Measure (default) statement is executed, the EPM measurement is copied to memory register MEM in units of the Evaluation Quantity.

    Example:

    EPM +PowerA = 100 mW; Freq = 100 MHz

    or

    EPM +PowerA = 100 mW; Freq = 100 MHz; Measure

    If the EPM power measurement was 99.98 mW, MEM would be 99.98.

  3. When an EPM Read statement is executed, the EPM measurement is copied to memory register MEM in units of the Evaluation Quantity designated in the previous Setup or Measure statement

    4. Example:

    EPM +PowerA = 100 mW; Freq = 100 MHz; Setup

    EPM +PowerA = 100 mW; Freq = 100 MHz; Read

  4. At most one parameter may be designated as the Modifier Quantity in an EPM Measure or Setup.
  5. When an EPM Measure is executed, the Modifier Quantity is concatenated to the Evaluation Quantity in the automatic message to setup the UUT. Note, the automatic message to setup the UUT is not displayed when ASK- N is in effect.

    6. Examples:

    ASK+ N
EPM +PowerA = -10 dBm; @Freq = 100 MHz

    "Set UUT to source -10 dBm at 100 MHz."

    No Modifier Quantity designated.

    EPM +PowerA = -10 dBm; Freq = 100 MHz

    "Set UUT to source -10 dBm."

    Automatic UUT setup message inhibited.

    ASK- N
EPM +PowerA = -10 dBm; Freq = 100 MHz

    No automatic UUT setup generated.

  6. Parameter values may be taken from a MET/CAL memory register using a special construction.

Parameter Names

Parameter names consist of single words or compound words. Each word in a parameter name can be entered in long form (as shown below), or in short form. The short form is the first 4 characters of the long form, with the following exceptions:

  1. If the long form is greater than four characters, and the last character or the short form is a vowel, the short form is three characters.
  2. If the long form is four characters or less, the short form is the long form even if it ends in a vowel.

Compound parameter names can be entered in any combination of long and short forms. Example, ExternalReferenceFrequency can be entered using any of the following forms:

  • PowerRatio
  • PowRatio
  • PowerRat
  • PowRat

Action Parameters

Action parameters specify the operation to be performed.

  • Apply
  • Local
  • Measure
  • Read
  • Reset
  • Setup
  • Standby
  • Zero
  • Zero_and_Cal

Rules:

  1. Only one action parameter is allowed per EPM statement (single or mult-line).
  2. If an action is not specified, the default is Measure.

Primary Parameters

Primary parameters specify the measurement or output.

  • Powerchannel
  • PowerDifferencechannelchannel
  • PowerRatiochannelchannel
  • PowerReferencePower

Rules:

  1. The primary parameter must be designated as the evaluation quantity.

Secondary Parameters

Secondary parameters are used for one or both of the following:

  1. Clarify the action.
  2. Configure the measurement specified by the primary parameter.
  • AverageCountchannel
  • CalibrationFactorchannel
  • CalibrationFactorTablechannel
  • Frequencychannel
  • PowerReferenceFrequency
  • PowerReferenceRear
  • PowerSensorchannel
  • ReadingRatechannel
  • StepDetectionchannel
  • ZeroTypeExternalchannel
  • ZeroTypeInternalchannel

Operating Mode

The action determines the operating mode.

Action Parameter | Operating Mode
Measure (default) | Power Measurement
Read | Power Measurement
Reset | Reset Power Meter
Setup | Power Measurement
Zero | Zero Power Meter
Zero_and_Cal | Zero and Cal Power Meter

Inter-Parameter Rules

If a parameter is not listed for an operating mode, it is not allowed.

Power Measurement

Required Parameters
+Powerch
PowerSensorch
Frequencych
SourceSWR_ch
ZeroTypeExternalch 1
ZeroTypeInternalch 1
Optional Parameters | Default
AverageCountch | na
CalibrationFactorch | na
CalibrationFactorTablech | Standard table for PowerSensorch 2
PowerReferenceRear | Front
ReadingRatech | Normal
StepDetectionch | On
  1. Only required when ch is 'C' or 'D'.
  2. 8480 Series and N8480 Series w/Option CFT power sensors only.

Power Difference (ch1-ch2) Measurement

Required Parameters
+PowerDifferencech1ch2
Frequencych1
Frequencych2
Powerch1
Powerch2
PowerSensorch1
PowerSensorch2
SourceSWR_ch1
SourceSWR_ch2
ZeroTypeExternalch1 1
ZeroTypeExternalch2 2
ZeroTypeInternalch1 1
ZeroTypeInternalch2 2
Optional Parameters | Default
AverageCountch1 | na
AverageCountch2 | na
CalibrationFactorch1 | na
CalibrationFactorch2 | na
CalibrationFactorTablech1 | Standard table for PowerSensorch1 3
CalibrationFactorTablech2 | Standard table for PowerSensorch2 3
PowerReferenceRear | Front
ReadingRatech1 | Normal
ReadingRatech2 | Normal
StepDetectionch1 | On
StepDetectionch2 | On
  1. Only required when ch1 is 'C' or 'D'.
  2. Only required when ch2 is 'C' or 'D'.
  3. 8480 Series and N8480 Series w/Option CFT power sensors only.

Power Ratio (ch1/ch2) Measurement

Required Parameters
+PowerRatioch1ch2
Frequencych1
Frequencych2
Powerch1
Powerch2
PowerSensorch1
PowerSensorch2
SourceSWR_ch1
SourceSWR_ch2
ZeroTypeExternalch1 1
ZeroTypeExternalch2 2
ZeroTypeInternalch1 1
ZeroTypeInternalch2 2
Optional Parameters | Default
AverageCountch1 | na
AverageCountch2 | na
CalibrationFactorch1 | na
CalibrationFactorch2 | na
CalibrationFactorTablech1 | Standard table for PowerSensorch13
CalibrationFactorTablech2 | Standard table for PowerSensorch23
PowerReferenceRear | Front
ReadingRatech1 | Normal
ReadingRatech2 | Normal
StepDetectionch1 | On
StepDetectionch2 | On
  1. Only required when ch1 is 'C' or 'D'.
  2. Only required when ch2 is 'C' or 'D'.
  3. 8480 Series and N8480 Series w/Option CFT power sensors only.

Zero

Required Parameters
PowerSensorch
ZeroTypeExternalch 1
ZeroTypeInternalch 1
  1. Only required when ch is 'C' or 'D'.

Zero, Zero_and_Cal

Required Parameters
PowerSensorch
Optional Parameters | Default
CalibrationFactorch 1 | na
CalibrationFactorTablech 1 | Standard table for PowerSensorch
PowerReferenceRear | Front
  1. 8480 Series and N8480 Series w/Option CFT power sensors only.

Power Reference Output 1

Required Parameters
+PowerReferencePower = 0 dBm | 1 mW
PowerReferenceFrequency = 50 MHz

Optional Parameters | Default
PowerReferenceRear | Front
  1. This mode is used to turn on and off the POWER REF independent of sensor calibration. The POWER REF is automatically turned on and off during execution of Zero_and_Cal mode.

Parameter Definitions and Values

Apply

This "Action" parameter turns on the POWER REF output.

Syntax:

Apply

Rules:

  1. No measurement is performed.

Examples:

EPM +PowerRefPower = 0 dBm; PowerRefFreq = 50 MHz; Apply

AverageCountchannel

This parameter sets the filter length.

Syntax:

EPM AverageCountchannel[sp]=[sp]<NR1>

channel ::= A | B | C | D

Rules:

  1. Legal values are: 1 to 1024
  2. When AverageCountch is not specified, averaging is disabled.

Example:

AverageCountA = 100

AverageCountB = 100

CalibrationFactorchannel

This parameter specifies the calibration factor.

Syntax:

EPM CalibrationFactorchannel[sp]=[sp]value[prefix]units

channel ::= A | B

value ::= NR3

prefix ::= SI prefix

units ::= % | dB

Rules:

  1. This parameter does not support N8480 series (without Option CFT) or U2000 series power sensors.
  2. Legal values are 1 % to 150 % and -100 dB to +100 dB.

Example:

CalFactorA = 99.0 %

CalibrationFactorTablechannel

This parameter specifies the sensor calibration table to be used during a specific measurement or calibration.

Cal factor tables have a one-to-one correspondence with a specific sensor for which the data within it applies. For example, if a two channel power meter is used with an 8481A power sensor on both channels, the 8481A table can only be used correctly with one of the sensors.

Syntax:

EPM CalibrationFactorTablechannel[sp]=[sp]value

channel ::= A | B

value ::= 8481A | 8482A | 8483A | 8485A | 8487A |

Q8486A |R8486A | V8486A | W8486A | 8481D | 8485D | 8487D | Q8486D | R8486D |

N8481A | N8482A | N8485A | N8487A |

N8481B | N8482B | N8481H | N8482H |

N8486AQ | N8486AR |

Customn | Custn |

Default | Def

n ::= 0 to 9

Rules:

  • CalFactorTable N191xA EPM-44xA/E441xA/E441xB
    Value | Table Name | Table Name
    8481A 1 | "8481A" | "HP8481A"
    8482A 2 | "8482A" | "HP8482A"
    8483A | "8483A" | "HP8483A"
    8481D | "8481D" | "HP8481D"
    8485A | "8485A" | "HP8485A"
    8485A-033 3 | "8485A-033" | "HP8485A-033"
    8485D 3 | "8485A" | "HP8485A"
    8485D-033 3 | "8485D-033" | "HP8485D-033"
    Q8486A | "Q8486A" | "Q8486A"
    Q8486D 3 | "Q8486D" | "Q8486D"
    R8486A | "R8486A" | "R8486A"
    R8486D | "R8486D" | "R8486D"
    V8486D 3 | "V8486D" | "V8486D"
    W8486D 3 | "W8486D" | "W8486D"
    8487A | "8487A" | "HP8487A"
    8487D 3 | "8487D" | "HP8487D"
    N8481A_CFT 3 | "N8481A" | "N8481A"
    N8481B_CFT 3 | "N8481B" | "N8481B"
    N8481H_CFT 3 | "N8481H" | "N8481H"
    N8482A_CFT 3 | "N8482A" | "N8482A"
    N8482B_CFT 3 | "N8482B" | "N8482B"
    N8482H_CFT 3 | "N8482H" | "N8482H"
    N8485A_CFT 3 | "N8485A" | "N8485A"
    N8485A-033_CFT 3 | "N8485A-033" | "N8485A-033"
    N8486AQ_CFT 3 | "N84856AQ" | "N84856AQ"
    N8486AR_CFT 3 | "N84856AR" | "N84856AR"
    N8487A_CFT 3 | "N8487A" | "N8487A"
    Custom0 | Cust0 | "CUSTOM_0" | "CUSTOM_0"
    Custom1 | Cust1 | "CUSTOM_0" | "CUSTOM_0"
    Custom2 | Cust2 | "CUSTOM_0" | "CUSTOM_0"
    Custom3 | Cust3 | "CUSTOM_0" | "CUSTOM_0"
    Custom4 | Cust4 | "CUSTOM_0" | "CUSTOM_0"
    Custom5 | Cust5 | "CUSTOM_0" | "CUSTOM_0"
    Custom6 | Cust6 | "CUSTOM_0" | "CUSTOM_0"
    Custom7 | Cust7 | "CUSTOM_0" | "CUSTOM_0"
    Custom8 | Cust8 | "CUSTOM_0" | "CUSTOM_0"
    Custom9 | Cust9 | "CUSTOM_0" | "CUSTOM_0"
    Default | Def 4 | "DEFAULT" | "DEFAULT"
    1. The 8481B and 8481H use the same data as the 8481A.
    2. The 8482B and 8482H use the same data as the 8482A.
    3. Not a predefined table name. An existing table must be re-named.
    4. DEFAULT is a sensor calibration table in which the reference cal factor and calibration factors are 100%.
  • This parameter not applicable to Power Sensors whose calibration factor information is internally stored, e.g., N848xA (except those with Option CFT) and U2000 series models.
  • If no calibration factor table is specified and the calibration factor source is frequency (default), the calibration factor table matching the specified power sensor will be used.
  • If the specified cal factor table name does not exist the power meter will generate an error at runtime.

Examples:

CalibrationFactorTable = 8481A

Frequencychannel

This parameter specifies the expected frequency of the RF input signal.

Syntax:

EPM [@]Frequencychannel[sp]=[sp]value[sp][prefix]Hz

channel ::= A | B | C | D

value ::= NR3

prefix ::= SI prefix

Rules:

  1. Legal values are based on the sensor module used:
    • 8481A/B/D/H 10.0 MHz to 18.0 GHz
    • 8482A/B/H 100.0 kHz to 4.2 GHz
    • 8483A 100.0 kHz to 2.0 GHz
    • 8485A/D 50.0 MHz to 26.5 GHz
    • 8485A/D OPT 033 50.0 MHz to 33.0 GHz
    • 8487A/D 50.0 MHz to 50.0 GHz
    • R8486A/D 26.5 MHz to 40.0 GHz
    • Q8486A/D 33.0 MHz to 50.0 GHz
    • V8486A 50.0 GHz to 75.0 GHz
    • W8486A 75.0 GHz to 110.0 GHz
    • E4412A 10.0 MHz to 18.0 GHz
    • E4413A 50.0 MHz to 26.5 GHz
    • E9300A/B/H 10.0 MHz to 18.0 GHz
    • E9300A OPT H24 50.0 MHz to 24.0 GHz
    • E9300A OPT H25 50.0 MHz to 24.0 GHz
    • E9301A/B/H 10.0 MHz to 6.0 GHz
    • E9304A 9.0 kHz to 6.0 GHz
    • E9304A OPT H18 9.0 kHz to 18.0 GHz
    • E9304A OPT H19 9.0 kHz to 18.0 GHz
    • N8481A/B/H 10.0 MHz to 18.0 GHz
    • N8481A OPT CFT 10.0 MHz to 18.0 GHz
    • N8481B OPT CFT 10.0 MHz to 18.0 GHz
    • N8481H OPT CFT 10.0 MHz to 18.0 GHz
    • N8482A/B/H 100.0 kHz to 6.0 GHz
    • N8482A OPT CFT 100.0 kHz to 6.0 GHz
    • N8482B OPT CFT 100.0 kHz to 6.0 GHz
    • N8482H OPT CFT 100.0 kHz to 6.0 GHz
    • N8485A 10.0 MHz to 26.5 GHz
    • N8485A OPT CFT 10.0 MHz to 26.5 GHz
    • N8485A OPT 033 10.0 MHz to 33.0 GHz
    • N8485A OPT 033,CFT 10.0 MHz to 33.0 GHz
    • N8486AR 26.5 GHz to 40.0 GHz
    • N8486AR OPT CFT 26.5 GHz to 40.0 GHz
    • N8486AQ 33.0 GHz to 50.0 GHz
    • N8486AQ OPT CFT 33.0 GHz to 50.0 GHz
    • N8487A 50.0 MHz to 50.0 GHz
    • N8487A OPT CFT 50.0 MHz to 50.0 GHz
    • N8488A 10.0 MHz to 70.0 GHz
    • U2000A/B/H 10.0 MHz to 18.0 GHz
    • U2001A/B/H 10.0 MHz to 6.0 GHz
    • U2002A/H 50.0 MHz to 24.0 GHz
    • U2004A 9.0 kHz to 6.0 GHz

Example:

Freq = 10 GHz

StepDetectionchannel

This parameter enables or disables step detection.

Syntax:

EPM StepDetectionchannel[sp]=[sp]value

channel ::= A | B | C | D

value ::= On | Off

Rules:

  1. If StepDetectionch is not specified, the default is on.

Examples:

StepDetB = Off

Local

This action puts the EPM in local mode.

Syntax:

Local

Rules:

  1. When Local is specified, no other parameters may be specified.

Examples:

Local

Measure

This "Action" parameter causes the following:

  1. Setup the EPM for measurement of the parameter designated as the Evaluation Quantity.
  2. Initiate the measurement.
  3. Return the reading in memory register MEM in units of the designated Nominal parameter value.

Syntax:

Measure

Rules:

  1. When Measure is specified, Setup must not be specified.
  2. When neither Measure or Setup is specified, Measure is assumed.

Example:

EPM +PowerA = -10.00 dBm

Powerchannel

This parameter specifies the expected power of the RF input signal.

Syntax:

EPM [+]Powerchannel[sp]=[sp]value[sp][prefix]units

channel ::= A | B | C | D

value ::= NR3

prefix ::= SI prefix

units ::= dBm | W

Rules:

  1. Legal values are based on the sensor module used.
    • 8481A, -30 dBm to +20 dBm, 1 uW to 100 mW
    • 8481B, 0 dBm to +44 dBm, 1 mW to 25 W
    • 8481D, -70 dBm to -20 dBm, 100 pW to 10 uW
    • 8481H, -10 dBm to +35 dBm, 100 uW to 3 W
    • 8482A, -30 dBm to +20 dBm, 1 uW to 100 mW
    • 8482B, 0 dBm to +44 dBm, 1 mW to 25 W
    • 8482H, -10 dBm to +35 dBm, 100 uW to 3 W
    • 8483A, -30 dBm to +20 dBm, 1 uW to 100 mW
    • 8485A, -30 dBm to +20 dBm, 1 uW to 100 mW
    • 8485A OPT 033, -30 dBm to +20 dBm, 1 uW to 100 mW
    • 8485D, -70 dBm to -20 dBm, 100 pW to 10 uW
    • 8485D OPT 033, -70 dBm to -20 dBm, 100 pW to 10 uW
    • 8487A, -30 dBm to +20 dBm, 1 uW to 100 mW
    • 8487D, -70 dBm to -20 dBm, 100 pW to 10 uW
    • R8486A, -30 dBm to +20 dBm, 1 uW to 100 mW
    • R8486D, -70 dBm to -20 dBm, 100 pW to 10 uW
    • Q8486A, -30 dBm to +20 dBm, 1 uW to 100 mW
    • Q8486D, -70 dBm to -20 dBm, 100 pW to 10 uW
    • V8486A, -30 dBm to +20 dBm, 1 uW to 100 mW
    • W8486A, -30 dBm to +20 dBm, 1 uW to 100 mW
    • E4412A, -70 dBm to +20 dBm, 100 pW to 100 mW
    • E4413A, -70 dBm to +20 dBm, 100 pW to 100 mW
    • E9300A, -60 dBm to +20 dBm, 1 nW to 100 mW
    • E9300A OPT H24, -60 dBm to +20 dBm, 1 nW to 100 mW
    • E9300A OPT H25, -50 dBm to +30 dBm, 10 nW to 1 W
    • E9300B, -30 dBm to +44 dBm, 1 uW to 25 W
    • E9300H, -50 dBm to +30 dBm, 10 nW to 1 W
    • E9301A, -60 dBm to +20 dBm, 1 nW to 100 mW
    • E9301B, -30 dBm to +44 dBm, 1 uW to 25 W
    • E9301H, -50 dBm to +30 dBm, 10 nW to 1 W
    • E9304A, -60 dBm to +20 dBm, 1 nW to 100 mW
    • E9304A OPT H18, -60 dBm to +20 dBm, 1 nW to 100 mW
    • E9304A OPT H19, -50 dBm to +30 dBm, 10 nW to 1 W
    • N8481A, -35 dBm to +20 dBm, 316 nW to 100 mW
    • N8481A OPT CFT, -30 dBm to +20 dBm, 1 uW to 100 mW
    • N8481B, - 5 dBm to +44 dBm, 316 uW to 25 W
    • N8481B OPT CFT, 0 dBm to +44 dBm, 1 mW to 25 W
    • N8481H, -15 dBm to +35 dBm, 31 uW to 3 W
    • N8481H OPT CFT, -10 dBm to +35 dBm, 100 uW to 3 W
    • N8482A, -35 dBm to +20 dBm, 316 nW to 100 mW
    • N8482A OPT CFT, -30 dBm to +20 dBm, 1 uW to 100 mW
    • N8482B, - 5 dBm to +44 dBm, 316 uW to 25 W
    • N8482B OPT CFT, 0 dBm to +44 dBm, 1 mW to 25 W
    • N8482H, -15 dBm to +35 dBm, 31 uW to 3 W
    • N8482H OPT CFT, -10 dBm to +35 dBm, 100 uW to 3 W
    • N8485A, -35 dBm to +20 dBm, 316 nW to 100 mW
    • N8485A OPT CFT, -30 dBm to +20 dBm, 1 uW to 100 mW
    • N8485A OPT 033,CFT, -30 dBm to +20 dBm, 1 uW to 100 mW
    • N8485A OPT 033, -35 dBm to +20 dBm, 316 nW to 100 mW
    • N8486AR, -35 dBm to +20 dBm, 316 nW to 100 mW
    • N8486AR OPT CFT, -30 dBm to +20 dBm, 1 uW to 100 mW
    • N8486AQ, -35 dBm to +20 dBm, 316 nW to 100 mW
    • N8486AQ OPT CFT, -30 dBm to +20 dBm, 1 uW to 100 mW
    • N8487A, -35 dBm to +20 dBm, 316 nW to 100 mW
    • N8487A OPT CFT, -30 dBm to +20 dBm, 1 uW to 100 mW
    • N8488A, -35 dBm to +20 dBm, 316 nW to 100 mW
    • U2000A, -60 dBm to +20 dBm, 1 nW to 100 mW
    • U2000B, -30 dBm to +44 dBm, 1 uW to 25 W
    • U2000H, -50 dBm to +30 dBm, 10 nW to 1 W
    • U2001A, -60 dBm to +20 dBm, 1 nW to 100 mW
    • U2001B, -30 dBm to +44 dBm, 1 uW to 25 W
    • U2001H, -50 dBm to +30 dBm, 10 nW to 1 W
    • U2002A, -60 dBm to +20 dBm, 1 nW to 100 mW
    • U2002H, -50 dBm to +30 dBm, 10 nW to 1 W
    • U2004A, -60 dBm to +20 dBm, 1 nW to 100 mW

Examples:

+PowerA = -10.00 dBm

PowerDifferencechannels

This parameter specifies the expected power difference.

Syntax:

EPM +PowerDifferencechannels[sp]=[sp]value[prefix]units

channels ::= AB (A minus B) | AC (A minus C) | AD (A minus D) |

BA (B minus A) | BC (B minus C) | BD (B minus D) |

CA (C minus A) | CB (C minus B) | CD (C minus D) |

DA (D minus A) | DB (D minus B) | DC (D minus C)

value ::= NR3

prefix ::= SI prefix

units ::= dBm | W

Rules:

  1. When this parameter is specified, it must be specified as the Evaluation Quantity (i.e. +PowerDifference).
  2. Legal values are: -1000 to +1000

Example:

EPM +PowerDif = 10 mW

PowerRatiochannels

This parameter specifies the expected power ratio.

Syntax:

EPM +PowerRatiochannels[sp]=[sp]value[prefix]units

channels ::= AB (A divided B) | AC (A divided C) | AD (A divided D) |

BA (B divided A) | BC (B divided C) | BD (B divided D) |

CA (C divided A) | CB (C divided B) | CD (C divided D) |

DA (D divided A) | DB (D divided B) | DC (D divided C)

value ::= NR3

prefix ::= SI prefix

units ::= dB | %

Rules:

  1. When this parameter is specified, it must be specified as the Evaluation Quantity (i.e. +PowerRatio).
  2. When PowerRatio is specified in %, linear ratio mode is selected.
  3. When PowerRatio is specified in dB, log ratio mode is selected.
  4. Legal values are: -1000 to +1000

Example:

EPM +PowerRatio = 10 %

PowerReferenceFrequency

This is the POWER REF frequency.

Syntax:

EPM PowerReferenceFrequency[sp]=[sp]value[prefix]Hz

prefix ::= SI prefix

Rules:

  1. prefixvalue must evaluate to 50E+6 Hz (i.e. 50 MHz).

Example:

EPM PowerRefFreq = 50 MHz

PowerReferencePower

This is the POWER REF amplitude.

Syntax:

EPM +PowerReferencePower[sp]=[sp]value[prefix]units

prefix ::= SI prefix

units ::= dBm | W

Rules:

  1. value must be zero when units are dBm.
  2. value and prefix must evaluate to 0.001 when units are W.

Example:

EPM +PowerRefPower = 0 dBm

PowerReferenceRear

This indicates that the rear POWER REF is used.

Syntax:

EPM PowerReferenceRear

Rules:

  1. When PowerReferenceRear is specified for a difference or ratio measurement, it is assumed that both power sensors were calibrated using the rear POWER REF output.

Read

This "Action" parameter causes the following:

  1. Initiate the measurement.
  2. Return the reading in memory register MEM.

Syntax:

Read

Rules:

  1. An EPM Measure or Setup statement must precede a Read statement in the current test.
  2. The value in MEM is in units of the parameter designated as the Evaluation Quantity in the previous EPM Measure or Setup statement.
  3. When Read is specified, no other parameters may be specified.

Examples:

EPM Read

ReadingRatechannel

This parameter specifies the reading rate.

Syntax:

EPM ReadingRatechannel[sp]=[sp]value

channel ::= A | B | C | D

value ::= Normal (20 readings/s) | x2 (40 readings/s)

Rules:

  1. If ReadingRatech is not specified, the default is Normal.

Example:

EPM ReadingRate = x2

Reset

This parameter resets the instrument.

Syntax:

Reset

Rules:

  1. When Reset is specified, no other parameters are allowed.

Examples:

EPM Reset

PowerSensorchannel

This parameter specifies the sensor module.

Syntax:

EPM PowerSensorchannel[sp]=[sp]power sensor

channel ::= A | B | C | D

power sensor ::= 8481A | 8482A | 8483A | 8485A | 8485A-033 | 8487A |

8481B | 8482B |

8481H | 8482H |

8485D | 8485D-033 | 8487D | R8486D | Q8486D |

R8486A | Q8486A | V8486A | W8486A |

N8481A | N8481A_CFT | N8482A | N8482A_CFT |

N8485A | N8485A_CFT | N8485A-033 | N8485A-033_CFT |

N8487A | N8487A_CFT | N8488A |

N8481B | N8481B_CFT | N8482B | N8482B_CFT |

N8481H | N8481H_CFT | N8482H | N8482H_CFT |

N8486AR | N8486AR_CFT |

N8486AQ | N8486AQ_CFT |

E4412A | E4413A |

E9300A | E9300A-H24 | E9300A-H25 | E9301A |

E9304A | E9304A_H18 | E9304A_H19 |

E9300B | E9301B |

E9300H | E9301H |

U2000A | U2001A | U2002A | U2004A |

U2000B | U2001B |

U2000H | U2001H | U2002H

Rules:

  1. Channel must be A or B, when power sensor is an 8480, N8480, E4400, or E9300 series sensor.
  2. Channel must be C or D, when power sensor is an U2000 series sensor.

Example:

PowerSensorA = N8481A

Setup

This "Action" parameter sets up the EPM for power measurement.

Syntax:

Setup

Rules:

  1. No measurement is performed.
  2. A Read "Action" must be specified in a subsequent EPM statement to cause a measurement to be performed and to obtain the reading.
  3. When Setup is specified, Measure must not be specified.

Examples:

EPM Setup; +PowerA = -10.00 dBm; Freq = 100 MHz

SourceSWRchannel

This parameter specifies the source SWR for EPM power accuracy calculation.

Syntax:

EPM SourceSWR_channel[sp]=[sp]value

channel ::= A | B | C | D

Example:

EPM SourceSWR_A = 2

Standby

This "Action" parameter turns off the POWER REF output.

Syntax:

Standby

Rules:

  1. No measurement is performed.

Examples:

EPM Standby

Zero

This parameter causes a power meter zero sequence to be performed.

Syntax:

Zero

Rules:

  1. When Zero is specified, Power Sensor must also be specified.

Examples:

EPM Zero; PowerSensorA = N8485A_CFT

EPM Zero; PowerSensorD = U2001B; ZeroTypeExtD

ZeroTypeExternalchannel

This parameter specifies external zero.

Syntax:

EPM ZeroTypeExternalchannel

channel ::= C | D

Rules:

  1. ZeroTypeInternalC or ZeroTypeExternalC when zeroing or performing a measurement involving channel C.
  2. ZeroTypeInternalD or ZeroTypeExternalD when zeroing or performing a measurement involving channel D.

Examples:

Zero; PowerSensorC = U2000A; ZeroTypeExtC

ZeroTypeInternalchannel

This parameter specifies internal zero.

Syntax:

EPM ZeroTypeInternalchannel

channel ::= C | D

Rules:

  1. ZeroTypeInternalC or ZeroTypeExternalC when zeroing or performing a measurement involving channel C.
  2. ZeroTypeInternalD or ZeroTypeExternalD when zeroing or performing a measurement involving channel D.

Examples:

Zero; PowerSensorD = U2001A; ZeroTypeIntD

Examples

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
# Reset
  1.001  EPM          Reset

  1.002  ASK-   R     N              P     U                      F
# Use MET/CAL's automatic connection message for connection to Power ref.
  1.003  ASK+                                                              V

# Zero & Cal
  1.004  DISP         Connect N8482A CFT to Channel A.
  1.005  EPM          Zero_and_Cal; PowerSensorA = N8482A_CFT

# Turn off automatic connection messages
  1.006  ASK-   R   Q N              P     U                      F        V

# The EPM POWER REF is used as the source for the following examples.

# Cal Factor
  1.007  EPM          +PowRefPower = 1.00 mW; PowRefFreq = 50 MHz; Apply
  1.008  TARGET       -m
  1.009  EPM          PowerSensorA = N8482A_CFT; CalFactorA = 96.5 %
  1.009  EPM          SourceSWR_A = 2
  1.009  EPM          +PowerA = 1.00 mW; FrequencyA = 50 MHz

# Cal Factor Table
  1.010  EPM          +PowRefPower = 1.00 mW; PowRefFreq = 50 MHz; Apply
  1.011  TARGET       -m
  1.012  EPM          PowerSensorA = N8482A_CFT; CalFactorTableA = N8482A_CFT
  1.012  EPM          SourceSWR_A = 2
  1.012  EPM          +PowerA = 1.00 mW; FrequencyA = 50 MHz

# Normal Mode
  1.013  TARGET       -p
  1.014  EPM          +PowRefPower = 1.00 mW; PowRefFreq = 50 MHz; Apply
  1.015  TARGET       -m
  1.016  EPM          PowerSensorA = N8482A_CFT
  1.016  EPM          SourceSWR_A = 2
  1.016  EPM          +PowerA = 1.00 mW; FrequencyA = 50 MHz
  1.017  MEMC         1.00mW         0.10U         50MHz

  2.001  TARGET       -p
  2.002  EPM          +PowRefPower = 1.00 mW; PowRefFreq = 50 MHz; Apply
  2.003  TARGET       -m
  2.004  EPM          PowerSensorB = N8485A
  2.004  EPM          SourceSWR_B = 2
  2.004  EPM          +PowerB = 1.00 mW; FrequencyB = 50 MHz
  2.005  MEMC         1.00mW         0.10U         50MHz

  3.001  TARGET       -p
  3.002  EPM          +PowRefPower = 1.00 mW; PowRefFreq = 50 MHz; Apply
  3.003  TARGET       -m
  3.004  EPM          PowerSensorC = U2000A; ZeroTypeInternalC
  3.004  EPM          SourceSWR_C = 2
  3.004  EPM          +PowerC = 1.00 mW; FrequencyC = 50 MHz
  3.005  MEMC         1.00mW         0.10U         50MHz

  4.001  TARGET       -p
  4.002  EPM          +PowRefPower = 1.00 mW; PowRefFreq = 50 MHz; Apply
  4.003  TARGET       -m
  4.004  EPM          PowerSensorD = U2001A; ZeroTypeInternalD
  4.004  EPM          SourceSWR_D = 2
  4.004  EPM          +PowerD = 1.00 mW; FrequencyD = 50 MHz
  4.005  MEMC         1.00mW         0.10U         50MHz

# Average Mode
  5.001  EPM          +PowRefPower = 1.00 mW; PowRefFreq = 50 MHz; Apply
  5.002  TARGET       -m
  5.003  EPM          PowerSensorA = N8482A_CFT
  5.003  EPM          SourceSWR_A = 2; AverageCountA = 1
  5.003  EPM          +PowerA = 1.00 mW; FrequencyA = 50 MHz
  5.004  MEMC         1.00mW         0.10U         50MHz

  6.001  EPM          +PowRefPower = 1.00 mW; PowRefFreq = 50 MHz; Apply
  6.002  TARGET       -m
  6.003  EPM          PowerSensorA = N8482A_CFT
  6.003  EPM          SourceSWR_A = 2; AverageCountA = 1024
  6.003  EPM          +PowerA = 1.00 mW; FrequencyA = 50 MHz
  6.004  MEMC         1.00mW         0.10U         50MHz

# Step Detection
#        On (default)
  7.001  EPM          +PowRefPower = 1.00 mW; PowRefFreq = 50 MHz; Apply
  7.002  TARGET       -m
  7.003  EPM          PowerSensorA = N8482A_CFT; AverCountA = 1
  7.003  EPM          SourceSWR_A = 2
  7.003  EPM          +PowerA = 1.00 mW; FrequencyA = 50 MHz
  7.004  MEMC         1.00mW         0.10U         50MHz

#        On (specifed)
  8.001  EPM          +PowRefPower = 1.00 mW; PowRefFreq = 50 MHz; Apply
  8.002  TARGET       -m
  8.003  EPM          PowerSensorA = N8482A_CFT; AverCountA = 1
  8.003  EPM          SourceSWR_A = 2; StepDetectionA = On
  8.003  EPM          +PowerA = 1.00 mW; FrequencyA = 50 MHz
  8.004  MEMC         1.00mW         0.10U         50MHz

#        Off
  9.001  EPM          +PowRefPower = 1.00 mW; PowRefFreq = 50 MHz; Apply
  9.002  TARGET       -m
  9.003  EPM          PowerSensorA = N8482A_CFT; AverCountA = 1
  9.003  EPM          SourceSWR_A = 2; StepDetectionA = Off
  9.003  EPM          +PowerA = 1.00 mW; FrequencyA = 50 MHz
  9.004  MEMC         1.00mW         0.10U         50MHz

# Reading Rate
#        Normal (default)
 10.001  EPM          +PowRefPower = 1.00 mW; PowRefFreq = 50 MHz; Apply
 10.002  TARGET       -m
 10.003  EPM          PowerSensorA = N8482A_CFT
 10.003  EPM          SourceSWR_A = 2
 10.003  EPM          +PowerA = 1.00 mW; FrequencyA = 50 MHz
 10.004  MEMC         1.00mW         0.10U         50MHz

#        Normal (specified)
 11.001  EPM          +PowRefPower = 1.00 mW; PowRefFreq = 50 MHz; Apply
 11.002  TARGET       -m
 11.003  EPM          PowerSensorA = N8482A_CFT
 11.003  EPM          SourceSWR_A = 2; ReadingRateA = Normal
 11.003  EPM          +PowerA = 1.00 mW; FrequencyA = 50 MHz
 11.004  MEMC         1.00mW         0.10U         50MHz

#        x2
 12.001  EPM          +PowRefPower = 1.00 mW; PowRefFreq = 50 MHz; Apply
 12.002  TARGET       -m
 12.003  EPM          PowerSensorA = N8482A_CFT
 12.003  EPM          SourceSWR_A = 2; ReadingRateA = x2
 12.003  EPM          +PowerA = 1.00 mW; FrequencyA = 50 MHz
 12.004  MEMC         1.00mW         0.10U         50MHz

# Trigger Delay
#        On (default)
 13.001  EPM          +PowRefPower = 1.00 mW; PowRefFreq = 50 MHz; Apply
 13.002  TARGET       -m
 13.003  EPM          PowerSensorA = N8482A_CFT
 13.003  EPM          SourceSWR_A = 2
 13.003  EPM          +PowerA = 1.00 mW; FrequencyA = 50 MHz
 13.004  MEMC         1.00mW         0.10U         50MHz

#        On (specifed)
 14.001  EPM          +PowRefPower = 1.00 mW; PowRefFreq = 50 MHz; Apply
 14.002  TARGET       -m
 14.003  EPM          PowerSensorA = N8482A_CFT
 14.003  EPM          SourceSWR_A = 2; TriggerDelayA = On
 14.003  EPM          +PowerA = 1.00 mW; FrequencyA = 50 MHz
 14.004  MEMC         1.00mW         0.10U         50MHz

#        Off
 15.001  EPM          +PowRefPower = 1.00 mW; PowRefFreq = 50 MHz; Apply
 15.002  TARGET       -m
 15.003  EPM          PowerSensorA = N8482A_CFT
 15.003  EPM          SourceSWR_A = 2; TriggerDelayA = Off
 15.003  EPM          +PowerA = 1.00 mW; FrequencyA = 50 MHz
 15.004  MEMC         1.00mW         0.10U         50MHz

 16.001  DISP         Connect the Channel A N8482A CFT to Calibrator SCOPE
 16.001  DISP         output using adapter supplied with power sensor.
 16.001  DISP
 16.001  DISP         Connect N8485A to Channel B.

 16.002  EPM          Zero_and_Cal; PowerSensorB = N8485A

# Difference A-B
#        Linear
 16.003  EPM          +PowerRefPower = 1 mW; PowerRefFrequency = 50 MHz; Apply
 16.004  O_CAL        Mode = LeveledSine; +Ampl = +10 dBm; Freq = 50 MHz
 16.005  TARGET       -m
 16.006  EPM          SourceSWR_A = 2; SourceSWR_B = 2
 16.006  EPM          PowerA =  1 mW; FreqA = 50 MHz; PowSensorA = N8482A_CFT
 16.006  EPM          PowerB = 10 mW; FreqB = 50 MHz; PowSensorB = N8485A
 16.006  EPM          +PowerDifferenceAB = -9.00 mW
 16.007  MEMC         -9.00mW        0.50U

#        Log
 17.001  EPM          +PowerRefPower = 1 mW; PowerRefFrequency = 50 MHz; Apply
 17.002  O_CAL        Mode = LeveledSine; +Ampl = +10 dBm; Freq = 50 MHz
 17.003  TARGET       -m
 17.004  EPM          SourceSWR_A = 2; SourceSWR_B = 2
 17.004  EPM          PowerA =   0 dBm; FreqA = 50 MHz; PowSensA = N8482A_CFT
 17.004  EPM          PowerB = +10 dBm; FreqB = 50 MHz; PowSensB = N8485A
 17.004  EPM          +PowerDifferenceAB = 10.00 dBm
 17.005  MEMC         10.00dB        1.00U

# Difference B-A
#        Linear
 18.001  EPM          +PowerRefPower = 1 mW; PowerRefFrequency = 50 MHz; Apply
 18.002  O_CAL        Mode = LeveledSine; +Ampl = +10 dBm; Freq = 50 MHz
 18.003  TARGET       -m
 18.004  EPM          SourceSWR_A = 2; SourceSWR_B = 2
 18.004  EPM          PowerA =  1 mW; FreqA = 50 MHz; PowSensorA = N8482A_CFT
 18.004  EPM          PowerB = 10 mW; FreqB = 50 MHz; PowSensorB = N8485A
 18.004  EPM          +PowerDifferenceBA = +9.00 mW
 18.005  MEMC         +9.00mW        0.50U

#        Log
 19.001  EPM          +PowerRefPower = 1 mW; PowerRefFrequency = 50 MHz; Apply
 19.002  O_CAL        Mode = LeveledSine; +Ampl = +10 dBm; Freq = 50 MHz
 19.003  TARGET       -m
 19.004  EPM          SourceSWR_A = 2; SourceSWR_B = 2
 19.004  EPM          PowerA =   0 dBm; FreqA = 50 MHz; PowSensA = N8482A_CFT
 19.004  EPM          PowerB = +10 dBm; FreqB = 50 MHz; PowSensB = N8485A
 19.004  EPM          +PowerDifferenceBA = 10.00 dBm
 19.005  MEMC         10.00dB        1.00U

# Difference A-C
#        Linear
 20.001  EPM          +PowerRefPower = 1 mW; PowerRefFrequency = 50 MHz; Apply
 20.002  O_CAL        Mode = LeveledSine; +Ampl = +10 dBm; Freq = 50 MHz
 20.003  TARGET       -m
 20.004  EPM          SourceSWR_A = 2; SourceSWR_C = 2
 20.004  EPM          PowerA =  1 mW; FreqA = 50 MHz; PowSensorA = N8482A_CFT
 20.004  EPM          PowerC = 10 mW; FreqC = 50 MHz; PowSensorC = U2000A
 20.004  EPM          ZeroTypeInternalC
 20.004  EPM          +PowerDifferenceAC = -9.00 mW
 20.005  MEMC         -9.00mW        0.50U

#        Log
 21.001  EPM          +PowerRefPower = 1 mW; PowerRefFrequency = 50 MHz; Apply
 21.002  O_CAL        Mode = LeveledSine; +Ampl = +10 dBm; Freq = 50 MHz
 21.003  TARGET       -m
 21.004  EPM          SourceSWR_A = 2; SourceSWR_C = 2
 21.004  EPM          PowerA =   0 dBm; FreqA = 50 MHz; PowSensA = N8482A_CFT
 21.004  EPM          PowerC = +10 dBm; FreqC = 50 MHz; PowSensC = U2000A
 21.004  EPM          ZeroTypeInternalC
 21.004  EPM          +PowerDifferenceAC = 10.00 dBm
 21.005  MEMC         10.00dB        1.00U

# Difference A-D
#        Linear
 22.001  EPM          +PowerRefPower = 1 mW; PowerRefFrequency = 50 MHz; Apply
 22.002  O_CAL        Mode = LeveledSine; +Ampl = +10 dBm; Freq = 50 MHz
 22.003  TARGET       -m
 22.004  EPM          SourceSWR_A = 2; SourceSWR_D = 2
 22.004  EPM          PowerA =  1 mW; FreqA = 50 MHz; PowSensorA = N8482A_CFT
 22.004  EPM          PowerD = 10 mW; FreqD = 50 MHz; PowSensorD = U2001A
 22.004  EPM          ZeroTypeInternalD
 22.004  EPM          +PowerDifferenceAD = -9.00 mW
 22.005  MEMC         -9.00mW        0.50U

#        Log
 23.001  EPM          +PowerRefPower = 1 mW; PowerRefFrequency = 50 MHz; Apply
 23.002  O_CAL        Mode = LeveledSine; +Ampl = +10 dBm; Freq = 50 MHz
 23.003  TARGET       -m
 23.004  EPM          SourceSWR_A = 2; SourceSWR_D = 2
 23.004  EPM          PowerA =   0 dBm; FreqA = 50 MHz; PowSensA = N8482A_CFT
 23.004  EPM          PowerD = +10 dBm; FreqD = 50 MHz; PowSensD = U2001A
 23.004  EPM          ZeroTypeInternalD
 23.004  EPM          +PowerDifferenceAD = 10.00 dBm
 23.005  MEMC         10.00dB        1.00U

# Ratio A/B
#        Linear
 24.001  EPM          +PowerRefPower = 1 mW; PowerRefFrequency = 50 MHz; Apply
 24.002  O_CAL        Mode = LeveledSine; +Ampl = +10 dBm; Freq = 50 MHz
 24.003  TARGET       -m
 24.004  EPM          SourceSWR_A = 2; SourceSWR_B = 2
 24.004  EPM          PowerA =  1 mW; FreqA = 50 MHz; PowSensorA = N8482A_CFT
 24.004  EPM          PowerB = 10 mW; FreqB = 50 MHz; PowSensorB = N8485A
 24.004  EPM          +PowerRatioAB = 10.0 %
 24.005  MEMC         10.0pct        1.0U

#        Log
 25.001  EPM          +PowerRefPower = 1 mW; PowerRefFrequency = 50 MHz; Apply
 25.002  O_CAL        Mode = LeveledSine; +Ampl = +10 dBm; Freq = 50 MHz
 25.003  TARGET       -m
 25.004  EPM          SourceSWR_A = 2; SourceSWR_B = 2
 25.004  EPM          PowerA =   0 dBm; FreqA = 50 MHz; PowSensA = N8482A_CFT
 25.004  EPM          PowerB = +10 dBm; FreqB = 50 MHz; PowSensB = N8485A
 25.004  EPM          +PowerRatioAB = -10.00 dB
 25.005  MEMC         -10.00dB       0.50U

# Ratio B/A
#        Linear
 26.001  EPM          +PowerRefPower = 1 mW; PowerRefFrequency = 50 MHz; Apply
 26.002  O_CAL        Mode = LeveledSine; +Ampl = +10 dBm; Freq = 50 MHz
 26.003  TARGET       -m
 26.004  EPM          SourceSWR_A = 2; SourceSWR_B = 2
 26.004  EPM          PowerA =  1 mW; FreqA = 50 MHz; PowSensorA = N8482A_CFT
 26.004  EPM          PowerB = 10 mW; FreqB = 50 MHz; PowSensorB = N8485A
 26.004  EPM          +PowerRatioBA = 1.0E+3 %
 26.005  MEMC         1.0E+3pct      100U

#        Log
 27.001  EPM          +PowerRefPower = 1 mW; PowerRefFrequency = 50 MHz; Apply
 27.002  O_CAL        Mode = LeveledSine; +Ampl = +10 dBm; Freq = 50 MHz
 27.003  TARGET       -m
 27.004  EPM          SourceSWR_A = 2; SourceSWR_B = 2
 27.004  EPM          PowerA =   0 dBm; FreqA = 50 MHz; PowSensA = N8482A_CFT
 27.004  EPM          PowerB = +10 dBm; FreqB = 50 MHz; PowSensB = N8485A
 27.004  EPM          +PowerRatioBA = +10.00 dB
 27.005  MEMC         +10.00dB       0.50U

# Ratio A/C
#        Linear
 28.001  EPM          +PowerRefPower = 1 mW; PowerRefFrequency = 50 MHz; Apply
 28.002  O_CAL        Mode = LeveledSine; +Ampl = +10 dBm; Freq = 50 MHz
 28.003  TARGET       -m
 28.004  EPM          SourceSWR_A = 2; SourceSWR_C = 2
 28.004  EPM          PowerA =  1 mW; FreqA = 50 MHz; PowSensorA = N8482A_CFT
 28.004  EPM          PowerC = 10 mW; FreqC = 50 MHz; PowSensorC = U2000A
 28.004  EPM          ZeroTypeInternalC
 28.004  EPM          +PowerRatioAC = 1.0E+3 %
 28.005  MEMC         1.0E+3pct      100U

#        Log
 29.001  EPM          +PowerRefPower = 1 mW; PowerRefFrequency = 50 MHz; Apply
 29.002  O_CAL        Mode = LeveledSine; +Ampl = +10 dBm; Freq = 50 MHz
 29.003  TARGET       -m
 29.004  EPM          SourceSWR_A = 2; SourceSWR_C = 2
 29.004  EPM          PowerA =  0 dBm; FreqA = 50 MHz; PowSensorA = N8482A_CFT
 29.004  EPM          PowerC = 10 dBm; FreqC = 50 MHz; PowSensorC = U2000A
 29.004  EPM          ZeroTypeInternalC
 29.004  EPM          +PowerRatioAC = +10.00 dB
 29.005  MEMC         +10.00dB       0.50U

# Ratio A/D
#        Linear
 30.001  EPM          +PowerRefPower = 1 mW; PowerRefFrequency = 50 MHz; Apply
 30.002  O_CAL        Mode = LeveledSine; +Ampl = +10 dBm; Freq = 50 MHz
 30.003  TARGET       -m
 30.004  EPM          SourceSWR_A = 2; SourceSWR_D = 2
 30.004  EPM          PowerA =  1 mW; FreqA = 50 MHz; PowSensorA = N8482A_CFT
 30.004  EPM          PowerD = 10 mW; FreqD = 50 MHz; PowSensorD = U2001A
 30.004  EPM          ZeroTypeInternalD
 30.004  EPM          +PowerRatioAD = 1.0E+3 %
 30.005  MEMC         1.0E+3pct      100U

#        Log
 31.001  EPM          +PowerRefPower = 1 mW; PowerRefFrequency = 50 MHz; Apply
 31.002  O_CAL        Mode = LeveledSine; +Ampl = +10 dBm; Freq = 50 MHz
 31.003  TARGET       -m
 31.004  EPM          SourceSWR_A = 2; SourceSWR_D = 2
 31.004  EPM          PowerA =  0 dBm; FreqA = 50 MHz; PowSensorA = N8482A_CFT
 31.004  EPM          PowerD = 10 dBm; FreqD = 50 MHz; PowSensorD = U2001A
 31.004  EPM          ZeroTypeInternalD
 31.004  EPM          +PowerRatioAD = +10.00 dB
 31.005  MEMC         +10.00dB       0.50U


ESA

Instrument FSC

Description

The ESA FSC controls the Agilent/HP E4401B, E4402B, E4404B, E4405B, and E4407A ESA-E Series, and E4403B, E4408B, and E4411B ESA-L Series Spectrum Analyzers. The ESA FSC supports the following measurement modes:

  • Spectrum Analysis

Parameters

An NVI FSC statement consists of one or more parameters. A parameter consists of a name and a value. Each parameter must be separated by a semicolon and/or one or more spaces. A single NVI FSC statement can encompass more than one physical line as long as the line numbers are the same. However each parameter name and its value must occur on one line. A single line can accommodate up to 256 characters including the statement number and FSC. Note that characters above ASCII 128 count as 2 characters.

Syntax:

parameter[separatorparameter]

parameter::= [parameter_prefix]parameter_name[[sp]=[sp]parameter_value]

separator::= ;[sp] | sp

parameter_prefix ::=+ | @

sp::= one or more spaces

parameter_name::= see the Parameter Names section

parameter_value::=dimensionless number | dimensioned number | discrete_list

dimensionless number::=NRf

dimensioned number::=NRf[sp][prefix]units

discrete_list::=see the Parameter Names section

prefix::=y | z | a | f | p | n | u | m | k | M | G | T | P | E | Z | Y

Definitions:

|
Denotes "or" (i.e. A | B is A or B)
[ ]
Denotes an optional syntax element, except in examples. In examples [ ] enclose a special construction.
+
Designates the parameter as the Evaluation Quantity
@
Designates the parameter as the Modifier Quantity

Rules:

  1. One and only one parameter must be designated as the Evaluation Quantity in a ESA Measure (default) or Setup statement.
  2. When a ESA Measure (default) statement is executed, the ESA measurement is copied to memory register MEM in units of the Evaluation Quantity.

    3. Example:

    ESA          CenterFreq = 100 MHz; FreqSpan = 500 kHz
ESA          RefLevel = 10 dBm; PeakSearch; MarkerToCenterFreq
ESA          +Ampl = 4 dBm; InputAtt = 20 dB

    or

    ESA          CenterFreq = 100 MHz; FreqSpan = 500 kHz
ESA          RefLevel = 10 dBm; PeakSearch; MarkerToCenterFreq
ESA          +Ampl = 4 dBm; InputAtt = 20 dB; Measure

    If the ESA frequency measurement was 99.99989 MHz, MEM would be 99.99989.

  3. When a ESA Read statement is executed, the ESA measurement is copied to memory register MEM in units of the Evaluation Quantity designated in the previous Setup or Measure statement.

    4. Example:

    ESA          CenterFreq = 100 MHz; FreqSpan = 500 kHz
ESA          RefLevel = 10 dBm; PeakSearch; MarkerToCenterFreq
ESA          +Ampl = 4 dBm; InputAtt = 20 dB; Setup

    ESA          CenterFreq = 100 MHz; FreqSpan = 500 kHz
ESA          RefLevel = 10 dBm; PeakSearch; MarkerToCenterFreq
ESA          +Ampl = 4 dBm; InputAtt = 20 dB; Read

  4. At most one parameter may be designated as the Modifier Quantity in a ESA Measure or Setup.
  5. When a ESA Measure is executed, the Modifier Quantity is concatenated to the Evaluation Quantity in the automatic message to setup the UUT. Note, the automatic message to setup the UUT is not displayed when ASK- N is in effect.

    6. Examples:

    ASK+  N
ESA          @CenterFreq = 100 MHz; FreqSpan = 500 kHz
ESA          RefLevel = 10 dBm; PeakSearch; MarkerToCenterFreq
ESA          +Ampl = 4 dBm; InputAtt = 20 dB

    "Set UUT to source 4 dBm at 100 MHz."

    No Modifier Quantity designated.

    ESA          CenterFreq = 100 MHz; FreqSpan = 500 kHz
ESA          RefLevel = 10 dBm; PeakSearch; MarkerToCenterFreq
ESA          +Ampl = 4 dBm; InputAtt = 20 dB

    "Set UUT to source 4 dBm."

    Automatic UUT setup message inhibited.

    ASK-  N
ESA          CenterFreq = 100 MHz; FreqSpan = 500 kHz
ESA          RefLevel = 10 dBm; PeakSearch; MarkerToCenterFreq
ESA          +Ampl = 4 dBm; InputAtt = 20 dB

    No automatic UUT setup generated.

  6. Parameter values may be taken from a MET/CAL memory register using a special construction.

Parameter Names

Parameter names consist of single words or compound words. Each word in a parameter name can be entered in long form (as shown below), or in short form. The short form is the first 4 characters of the long form, with the following exceptions:

  1. If the long form is greater than four characters, and the last character or the short form is a vowel, the short form is three characters.
  2. If the long form is four characters or less, the short form is the long form even if it ends in a vowel.

Compound parameter names can be entered in any combination of long and short forms. For example, FrequencyCounterResolution can be entered using any of the following forms:

  • FrequencyCounterResolution
  • FrequencyCounterRes
  • FrequencyCounResolution
  • FrequencyCounRes
  • FreqCounterResolution
  • FreqCounterRes
  • FreqCounResolution
  • FreqCounRes

Action Parameters

  • Connect
  • Local
  • Measure
  • Read
  • Reset
  • Setup

Parameters

  • All
  • Amplitude 1,2
  • AmplitudeScale
  • AverageCount
  • AverageType
  • CenterFrequency
  • Frequency 1,2
  • FrequencyCounterOn
  • FrequencyCounterResolution
  • FrequencyOffset
  • FrequencySpan
  • InputAttenuation
  • MarkerFrequency
  • MarkerToCenterFrequency
  • Mode
  • PeakSearch
  • PeakSearchMode
  • PeakSearchType
  • PreamplifierOn
  • RBW
  • RF
  • RFCoupling
  • RadioStd
  • ReferenceLevel
  • StartFrequency
  • StopFrequency
  • SweepPoints
  • SweepTime
  • TimebaseAccuracyOff
  • VBW
  • VBW_RBWRatio
  1. May be designated as the Evaluation Quantity.
  2. May be designated as the Modifier Quantity.

Operating Mode

The operating mode is determine as follows:

  1. If the "Calibrate" is specified, the Operating Mode is "Calibrate".
  2. Otherwise if "Mode" is specified, the operating is mode is the value specified.
  3. Otherwise the operating mode is Spectrum Analysis.

Operating Mode/Parameter Rules

If a parameter is not listed for a mode, it is not allowed.

Action | Default
Calibrate | Connect | Measure | Read | Reset | Setup | Measure

Spectrum Analysis

Parameter Name | Parameter Type | Default Value
+Frequency 1 | Required | N/A
CenterFrequency and FrequencySpan 2 | Required | N/A
StartFrequency and StopFrequency 2 | Required | N/A
AverageCount | Optional | Off, 100 averages
AverageType | Optional | Auto (LogPower)
FrequencyCounterOn | Optional | Off
FrequencyOffset | Optional | 0 Hz
MarkerFrequency | Optional | N/A
MarkerToCenterFrequency | Optional | N/A
Mode | Optional | SpectrumAnalyzer
PeakSearch | Optional | Off
PreamplifierOn | Optional | Off
RBW | Optional | Auto
RBW_VBWRatio | Optional | Auto
RFCoupling | Optional | ESA model specific
RadioStd | Optional | None
ReferenceLevel | Optional | Determined by analyzer
SweepPoints | Optional | 601
SweepTime 3 | Optional | ESA model specific (see SweepTime)
VBW | Optional | Auto
  1. Only one Evaluation Quantity (measurement) may be specified.
  2. Either CenterFrequency and FrequencySpan or StartFrequency and StopFrequency must be specified, but not both.
  3. AutoSweepTime and SweepTime are mutually exclusive.

Calibrate

Parameter Name | Parameter Type | Default Value
All 1 | Required | N/A
RF 1 | Required | N/A
  1. All is the default, when RF is not specified.

Connect

Parameter Name | Parameter Type | Default Value
Frequency | Required | N/A

Parameter Definitions and Values

All

This parameter specifies a full calibration sequence.

Syntax:

All

Rules:

  1. When All is specified, Calibrate must also be specified.

Examples:

Calibrate; All

Amplitude

This parameter specifies the expected amplitude. When this parameter is specified, it must be designated as the Evaluation Quantity.

Syntax:

+Amplitude[sp]=[sp]value

value ::= numeric value[sp][prefix]units

units ::= dBm | V

Rules:

  1. When this parameter is specified, it must be specified as the Evaluation Quantity.
  2. Legal values are:
    • 500 kHz to 3.05 GHz
      • -113 dBm to +30 dBm (without preamp, ESA Option 1DS)
      • -129 dBm to +16 dBm (with preamp, ESA Option 1DS)
    • 3.05 GHz to 6.6 GHz
      • -113 dBm to +30 dBm
    • 6.6 GHz to 13.2 GHz
      • -104 dBm to +30 dBm
    • 13.2 GHz to 19.2 GHz
      • -93 dBm to +30 dBm
    • 19.2 GHz to 26.5 GHz
      • -85 dBm to +30 dBm

Example:

+Ampl = -10.00 dBm

AmplitudeScale

This parameter specifies the vertical amplitude scale.

Syntax:

+AmplitudeScale[sp]=[sp]value

value ::= numeric value[sp][prefix]dB/div

Example:

+AmplScale = 10 dB/div

AverageCount

This parameter specifies the average count. When this parameter is specified, average is enabled.

Syntax:

AverageCount[sp]=[sp]numeric value

Rules:

  1. Legal values are: 1 to 8192

Example:

AverageCount = 32

AverageType

This parameter specifies the average type.

Syntax:

AverageType[sp]=[sp]value

value ::= LogPower | LogPow | Power | Pow | Video | Vid | Voltage | Volt

Rules:

  1. If not specified, the default is LogPower.

Example:

AvgType = Video

Calibrate

This parameter causes a calibration sequence to be performed.

Syntax:

Calibrate [RF]

Rules:

  1. When RF is not specified, the default is all.

Examples:

Calibrate

Calibrate; All (same as above)

Calibrate; RF

CenterFrequency

This parameter sets the center frequency.

Syntax:

[@]CenterFrequency[sp]=[sp]numeric value[sp][prefix]Hz

Rules:

  1. Legal values are based on the ESA model:

    ESA-E Series
    E4401B | 100 Hz to 1.5 GHz
    E4402B | 100 Hz to 3 GHz
    E4404B | 9 kHz to 6.7 GHz
    E4405B | 100 Hz to 13.2 GHz
    E4407B | 100 Hz to 26.5 GHz
    ESA-L Series
    E4411B | 9 kHz to 1.5 GHz
    E4403B | 9 kHz to 3 GHz
    E4408B | 9 kHz to 26.5 GHz

Examples:

CenterFreq = 1 GHz

Connect

This parameter causes an automatic connection message to be generate when ASK+ W or ASK+ V is in effect. In addition, a connect statement will cause a procedure header CONFIGURATION: line to be generated, regardless of the state of the ASK W and ASK V flags.

Syntax:

Connect

Rules:

  1. When Connect is specified, Frequency and must also be specified.

Examples:

Connect; Freq = 10 MHz

Frequency

This parameter specifies the expected frequency of the RF input signal.

Syntax:

[+|@]Frequency[sp]=[sp]value

value ::= numeric value[sp][prefix]Hz

Rules:

  1. Legal values are based on the ESA model:

    ESA-E Series
    E4401B | 100 Hz to 1.5 GHz
    E4402B | 100 Hz to 3 GHz
    E4404B | 9 kHz to 6.7 GHz
    E4405B | 100 Hz to 13.2 GHz
    E4407B | 100 Hz to 26.5 GHz
    ESA-L Series
    E4411B | 9 kHz to 1.5 GHz
    E4403B | 9 kHz to 3 GHz
    E4408B | 9 kHz to 26.5 GHz

Example:

+Freq = 120.0000MHz

FrequencyCounterOn

This parameter enables the frequency counter.

Syntax:

FrequencyCounterOn

Example:

FrequencyCounterOn

FrequencyCounterResolution

This parameter specifies the frequency counter resolution.

Syntax:

FrequencyCounterResolution[sp]=[sp]value

value ::= numeric value[sp][prefix]Hz

Rules:

  1. Legal values are: 1, 10, 100 Hz, 1, 10, 100 kHz

Example:

FreqCounterRes = 10 Hz

FrequencyOffset

This parameter specifies the frequency offset.

Syntax:

FrequencyOffset[sp]=[sp]value

value ::= numeric value[sp][prefix]Hz

Rules:

  1. Legal values are: 10 Hz to 100 MHz

Example:

FrequencyOffset = 10 kHz

FrequencySpan

This parameter sets the frequency span.

Syntax:

[@]FrequencySpan[sp]=[sp]numeric value[sp][prefix]Hz

Rules:

  1. 0 Hz selects Zero Span

  2. Legal values are based on the ESA model:

    ESA-E Series
    E4401B | 100 Hz to 1.5 GHz
    E4402B | 100 Hz to 3 GHz
    E4404B | 9 kHz to 6.7 GHz
    E4405B | 100 Hz to 13.2 GHz
    E4407B | 100 Hz to 26.5 GHz
    ESA-L Series
    E4411B | 9 kHz to 1.5 GHz
    E4403B | 9 kHz to 3 GHz
    E4408B | 9 kHz to 26.5 GHz

Examples:

StartFreq = 1 GHz

MarkerFrequency

This parameter specifies the ...

Syntax:

+MarkerFrequency[sp]=[sp]value

value ::= numeric value[sp][prefix]Hz

Rules:

  1. When this parameter is specified, it must be specified as the Evaluation Quantity.
  2. Legal values are based on ESA model used.

Example:

+MarkerFreq = 110 MHz

Local

This action puts the ESA in local mode.

Syntax:

Local

Rules:

  1. When Local is specified, no other parameters may be specified.

Examples:

Local

Measure

This "Action" parameter causes the following:

  1. Setup the ESA for measurement of the parameter designated as the Evaluation Quantity.
  2. Initiate the measurement.
  3. Return the reading in memory register MEM in units of the designated Nominal parameter value.

Syntax:

Measure

Rules:

  1. When Measure is specified, Setup must not be specified.
  2. When neither Measure or Setup is specified, Measure is assumed.

Mode

This parameter specifies the operating mode.

Syntax:

Mode[sp]=[sp]value

value ::= SpecAn | SpectrumAnalysis

Rules:

  1. If not specified, the default is SpectrumAnalysis.

Example:

Mode = SpecAn

PeakSearch

This parameter specifies that a peak search be performed.

Syntax:

PeakSearch

Example:

PeakSearch

PreamplifierOn

This parameter anables the preamplifier.

Syntax:

PreamplifierOn

Example:

PreamplifierOn

RBW (Resolution Bandwidth)

This parameter turns auto RBW off an sets the resolution bandwidth.

Syntax:

RBW[sp]=[sp]value

value ::= numeric value[sp][prefix]Hz

Rules:

  1. Legal values are:
    1. 1, 3, 10, 30, 100, and 300 Hz,
    2. 1, 3, 10, 30, 100, and 300 kHz,
    3. 1, 3, and 8 MHz
  2. If not specified, the RBW is set to auto.

RF

This parameter specifies ESA RF calibration.

Syntax:

RF

Example:

Cal; RF

RFCoupling

This parameter specifies the RF input coupling.

Syntax:

RFCoupling[sp]=[sp]value

value ::= AC | DC

Rules:

  1. If not specified, the default is AC.

Example:

RFCoupling = DC

RadioStd

This parameter specifies the radio standard.

Syntax:

RadioStd[sp]=[sp]value

value::= | 3GPP W-CDMA | |
 | Bluetooth | |
 | DVB-T G/PAL/NICAM | |
 | DVB-T I/PAL/NICAM | |
 | DVB-T L/SECAM/NICAM | |
 | FCC Part 15 Subpart F | |
 | GSM/EDGE | |
 | IS-95A | |
 | IS-95C | |
 | J-STD-008 | |
 | NADC | |
 | PDC | |
 | S-DMB System E | |
 | TETRA | |
 | UWB Indoor | |
 | W-LAN 802.11a | |
 | W-LAN 802.11b | |
 | W-LAN 802.11g | |
 | W-LAN HiperLAN/2 | |
 | cdma2000 DS | |
 | cdma2000 MC-1X | |
 | cdma2000 MC-3X |

Rules:

  1. If not specified, the default value is: None

Example:

RadioStd = Bluetooth

Read

This "Action" parameter causes the following:

  1. Initiate the measurement.
  2. Return the reading in memory register MEM.

Syntax:

Read

Rules:

  1. A ESA Measurement or Setup statement must precede a Read statement in the current test.
  2. The value in MEM is in units of the parameter designate as the Evaluation Quantity in the previous ESA Measure or Setup statement.
  3. When Read is specified, no other parameters may be specified.

Examples:

ESA Read

ReferenceLevel

This parameter specifies the reference level.

Syntax:

ReferenceLevel[sp]=[sp]numeric value[sp]units

units ::= dBm | dBc/Hz

Rules:

  1. Spectrum Analyzer mode
    1. Legal values are: tdb
  2. Phase Noise Log Plot mode
    1. Legal values are: -200 dBc/Hz to 200 dBc/Hz
  3. Phase Noise Monitor mode
    1. Legal values are: -170 dBm to 30 dBm

Example:

ReferenceLevel = 10 dBm

Reset

This parameter resets the instrument.

Syntax:

Reset

Rules:

  1. When Reset is specified, no other parameters are allowed.

Examples:

Reset

Setup

This "Action" parameter sets up the ESA for measurement of the parameter designated as the Evaluation Quantity.

Syntax:

Setup

Rules:

  1. No measurement is performed.
  2. A Read "Action" must be specified in a subsequent ESA statement to cause a measurement to be performed and to obtain the reading.
  3. When Setup is specified, Measure must not be specified.

Examples:

ESA Setup +FMDev = 100 kHz

StartFrequency

This parameter sets the start frequency.

Syntax:

[@]StartFrequency[sp]=[sp]numeric value[sp][prefix]Hz

Rules:

  1. Legal values are based on the ESA model:

    ESA-E Series
    E4401B | 100 Hz to 1.5 GHz
    E4404B | 9 kHz to 6.7 GHz
    E4405B | 100 Hz to 13.2 GHz
    E4407B | 100 Hz to 26.5 GHz
    ESA-L Series
    E4411B | 9 kHz to 1.5 GHz
    E4403B | 9 kHz to 3 GHz
    E4408B | 9 kHz to 26.5 GHz

Examples:

StartFreq = 1 GHz

StopFrequency

This parameter sets the stop frequency.

Syntax:

[@]StopFrequency[sp]=[sp]numeric value[sp][prefix]Hz

Rules:

  1. Legal values are based on the ESA model:

    ESA-E Series
    E4401B | 100 Hz to 1.5 GHz
    E4404B | 9 kHz to 6.7 GHz
    E4405B | 100 Hz to 13.2 GHz
    E4407B | 100 Hz to 26.5 GHz
    ESA-L Series
    E4411B | 9 kHz to 1.5 GHz
    E4403B | 9 kHz to 3 GHz
    E4408B | 9 kHz to 26.5 GHz

Examples:

StopFreq = 1 GHz

SweepPoints

This parameter specifies the number of points per sweep.

Syntax:

SweepPoints[sp]=[sp]numeric value

Rules:

  1. Legal values are: 101 to 8192
  2. If not specified, the default value is: 601

Example:

SweepPoints = 2000

SweepTime

This parameter specifies the sweep time.

Syntax:

SweepTime[sp]=[sp]numeric value[sp][prefix]s

Rules:

  1. Legal values are:
    1. Zero span: 1 µs to 6000 s
    2. Swept spans: 1 ms to 2000 s

  2. If not specified, the default value is:

    ESA-E Series
    E4401B | tbd ms
    E4402B | tbd ms
    E4404B | tbd ms
    E4405B | tbd ms
    E4407B | tbd ms
    ESA-L Series
    E4403B | tbd ms
    E4408B | tbd ms
    E4411B | tbd ms

Example:

SweepTime = 200 ms

TimebaseAccuracyOff

This parameter is used when it is only desired to synchronize the ESA with the UUT, without an absolute accuracy determination.

Syntax:

TimebaseAccuracyOff

Examples:

TimebaseAccuracyOff

VBW (Video Bandwidth)

This parameter turns auto VBW off an sets the video bandwidth.

Syntax:

VBW[sp]=[sp]value

value ::= numeric value[sp][prefix]Hz

Rules:

  1. Legal values are:
    1. 1, 3, 10, 30, 100, and 300 Hz,
    2. 1, 3, 10, 30, 100, and 300 kHz,
    3. 1, 3, 8, and 50 MHz
  2. If not specified, the VBW is set to auto.

VBW_RBWRatio

This parameter specifies the video to resolution bandwidth ratio.

Syntax:

VBW_RBWRatio[sp]=[sp]numeric value

Rules:

  1. Legal values are: 0.001 to 10

Example:

VBW_RBWRatio = 0.1

Examples

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON

  1.001  MATH         Device = "Agilent ESA"

# -----  Spectrum Analysis Mode: Harmonics  -----
  1.002  TSET         TDESC = 2 MHz, 2 harmonic
  1.003  TARGET       -p
# Set UUT output parameters.
  1.004  SCPI         FREQ:CW 2MHZ;:POW:AMPL 4 DBM;:OUTP:STAT ON
# Measure amplitude of fundamental.
  1.005  ESA          InputAttenuation = 20 dB
  1.005  ESA          RBW = 10 kHz; VBW = 30 kHz; RefLevel = 10 dBm
  1.005  ESA          CenterFreq = 2 MHz; FreqSpan = 500 kHz
  1.005  ESA          +Ampl = 4 dBm; PeakSearch; MarkerToCenterFreq
  1.006  MATH         RefLvl = MEM
# Retrieve uncertainty for above measurement and normalize.
  1.007  MATH         L[1] = ACCV2(Device, "Freq Resp", MEM, 2)
  1.008  MATH         L[1] = L[1] / @Conf
  1.009  TARGET       -m
# Measure amplitude of harmonic.
  1.010  ESA          InputAttenuation = 20 dB
  1.010  ESA          RBW = 10 kHz; VBW = 30 kHz; RefLevel = 10 dBm
  1.010  ESA          CenterFreq = 4 MHz; FreqSpan = 500 kHz
  1.010  ESA          +Ampl = -26 dBm; PeakSearch; MarkerToCenterFreq
# Retrieve scale fidelity uncertainty for above measurements and normalize.
  1.011  MATH         L[2] = ACCV2(Device, "Log Scale Fidelity", MEM, 2)
  1.012  MATH         L[2] = L[2] / @Conf
  1.013  MATH         L[3] = ACCV2(Device, "Log Scale Fidelity", MEM, 2)
  1.014  MATH         L[3] = L[3] / @Conf
# RSS all individual measurement uncertainty components and expand.
  1.015  MATH         L[4] = RSS3(L[1], L[2], L[3]) * 2
# Computed expanded uncertainty shown in ACC.
# Compute harmonic level (dBc).
  1.016  MATH         MEM = MEM - RefLvl
  1.017  ACC    -30   dBc            L4U
  1.018  MEMC         -30.0dBc       -0.0U +100.0U

# -----  Spectrum Analysis Mode: Spurious  -----
  2.001  TSET         TDESC = 242 MHz (274 MHz Spur)
  2.002  MATH         Freq = 242 * 1E+6; Spur = 274 * 1E+6
  2.003  TARGET       -p
# Set UUT output parameters.
  2.004  SCPI         FREQ:CW 242MHZ;:POW:AMPL 4DBM
  2.004  SCPI         OUTP:STAT ON
# Measure amplitude of fundamental.
  2.005  ESA          InputAttenuation = 20 dB
  2.005  ESA          RBW = 1 kHz; VBW = 1 kHz; RefLevel = 10 dBm
  2.005  ESA          CenterFreq = 242 MHz; FreqSpan = 500 kHz
  2.005  ESA          +Ampl = 4 dBm; PeakSearch; MarkerToCenterFreq
# Store fundamental reference level in M[1].
  2.006  MATH         RefLvl = MEM
# Specify correct 856x frequency response mode string for unit being used.
# Retrieve uncertainty for above measurement and normalize.
  2.007  MATH         L[1] = ACCV2(Device, "Freq Resp", MEM, Freq) / @Conf
  2.008  TARGET       -m
# Measure amplitude of spur.
  2.009  ESA          InputAttenuation = 20 dB
  2.009  ESA          RBW = 1 kHz; VBW = 1 kHz; RefLevel = 10 dBm
  2.009  ESA          CenterFreq = 274 MHz; FreqSpan = 500 kHz
  2.009  ESA          +Ampl = -51 dBm; PeakSearch; MarkerToCenterFreq
# Compute harmonic level (dBc).
  2.010  MATH         MEM = MEM - RefLvl
# Retrieve uncertainty for above measurement and normalize.
  2.011  MATH         L[2] = ACCV2(Device, "Freq Resp", MEM, Spur) / @Conf
# Specify correct scale fidelity mode string for unit being used.
# Retrieve scale fidelity uncertainty for above measurements.
  2.012  MATH         L[3] = ACCV2(Device, "Log Scale Fidelity", MEM, Spur)
  2.013  MATH         L[3] = L[3] / @Conf
# RSS all individual measurement uncertainty componenets
  2.014  MATH         L[4] = RSS3(L[1], L[2], L[3]) * 2
# Computed expanded uncertainty shown in ACC.
  2.015  ACC    -55   dBc            L4U
  2.016  MEMC         -55.0dBc       -0.0U +75.0U


PSA

Instrument FSC

Description

The PSA FSC controls the Agilent E4440A, E4443A, E4445A, E4446A, E4447A, and E4448A PSA Series Spectrum Analyzers, except Option 233 "PSA Measuring Receiver System". For Option 233 measurements use the N5531 FSC. The PSA FSC supports the following measurement modes

  • Spectrum Analysis
  • Phase Noise (Requires Option 226)

Parameters

An NVI FSC statement consists of one or more parameters. A parameter consists of a name and a value. Each parameter must be separated by a semicolon and/or one or more spaces. A single NVI FSC statement can encompass more than one physical line as long as the line numbers are the same. However each parameter name and its value must occur on one line. A single line can accommodate up to 256 characters including the statement number and FSC. Note that characters above ASCII 128 count as 2 characters.

Syntax:

parameter[separatorparameter]

parameter::= [parameter_prefix]parameter_name[[sp]=[sp]parameter_value]

separator::= ;[sp] | sp

parameter_prefix ::=+ | @

sp::= one or more spaces

parameter_name::= see the Parameter Names section

parameter_value::=dimensionless number | dimensioned number | discrete_list

dimensionless number::=NRf

dimensioned number::=NRf[sp][prefix]units

discrete_list::=see the Parameter Names section

prefix::=y | z | a | f | p | n | u | m | k | M | G | T | P | E | Z | Y

Definitions:

|
Denotes "or" (i.e. A | B is A or B)
[ ]
Denotes an optional syntax element, except in examples. In examples [ ] enclose a special construction.
+
Designates the parameter as the Evaluation Quantity
@
Designates the parameter as the Modifier Quantity

Rules

  1. One and only one parameter must be designated as the Evaluation Quantity in a PSA Measure (default) or Setup statement.
  2. When a PSA Measure (default) statement is executed, the PSA measurement is copied to memory register MEM in units of the Evaluation Quantity.

    Example

    PSA          CenterFreq = 100 MHz; FreqSpan = 500 kHz
PSA          RefLevel = 10 dBm; PeakSearch; MarkerToCenterFreq
PSA          +Ampl = 4 dBm; InputAtt = 20 dB

    or

    PSA          CenterFreq = 100 MHz; FreqSpan = 500 kHz
PSA          RefLevel = 10 dBm; PeakSearch; MarkerToCenterFreq
PSA          +Ampl = 4 dBm; InputAtt = 20 dB; Measure

    If the PSA frequency measurement was 99.99989 MHz, MEM would be 99.99989.

  3. When a PSA Read statement is executed, the PSA measurement is copied to memory register MEM in units of the Evaluation Quantity designated in the previous Setup or Measure statement.

    Example

    PSA          CenterFreq = 100 MHz; FreqSpan = 500 kHz
PSA          RefLevel = 10 dBm; PeakSearch; MarkerToCenterFreq
PSA          +Ampl = 4 dBm; InputAtt = 20 dB; Setup

    PSA          CenterFreq = 100 MHz; FreqSpan = 500 kHz
PSA          RefLevel = 10 dBm; PeakSearch; MarkerToCenterFreq
PSA          +Ampl = 4 dBm; InputAtt = 20 dB; Read

  4. At most one parameter may be designated as the Modifier Quantity in a PSA Measure or Setup.

  5. When a PSA Measure is executed, the Modifier Quantity is concatenated to the Evaluation Quantity in the automatic message to setup the UUT. Note, the automatic message to setup the UUT is not displayed when ASK- N is in effect.

    Examples

    ASK+  N
PSA          @CenterFreq = 100 MHz; FreqSpan = 500 kHz
PSA          RefLevel = 10 dBm; PeakSearch; MarkerToCenterFreq
PSA          +Ampl = 4 dBm; InputAtt = 20 dB

    "Set UUT to source 4 dBm at 100 MHz."

    No Modifier Quantity designated.

    PSA          CenterFreq = 100 MHz; FreqSpan = 500 kHz
PSA          RefLevel = 10 dBm; PeakSearch; MarkerToCenterFreq
PSA          +Ampl = 4 dBm; InputAtt = 20 dB

    "Set UUT to source 4 dBm."

    Automatic UUT setup message inhibited.

    ASK-  N
PSA          CenterFreq = 100 MHz; FreqSpan = 500 kHz
PSA          RefLevel = 10 dBm; PeakSearch; MarkerToCenterFreq
PSA          +Ampl = 4 dBm; InputAtt = 20 dB

    No automatic UUT setup generated.

  6. Parameter values may be taken from a MET/CAL memory register using a special construction.

Parameter Names

Parameter names consist of single words or compound words. Each word in a parameter name can be entered in long form (as shown below), or in short form. The short form is the first 4 characters of the long form, with the following exceptions

  1. If the long form is greater than four characters, and the last character or the short form is a vowel, the short form is three characters.
  2. If the long form is four characters or less, the short form is the long form even if it ends in a vowel.

Compound parameter names can be entered in any combination of long and short forms. For example, ModulationFrequency can be entered using any of the following forms

  • ReferenceLevelOffset
  • ReferenceLevelOffs
  • ReferenceLevOffset
  • ReferenceLevOffs
  • RefLevelOffset
  • RefLevelOffs
  • RefLevOffset
  • RefLevOffs

Action Parameters

  • Calibrate
  • Connect
  • Local
  • Measure
  • Read
  • Reset
  • Setup

Parameters

  • ADC
  • All
  • Amplitude 1,2
  • AmplitudeScale
  • AutoSweepTime
  • AutoSweepType
  • AverageCount
  • AverageType
  • CenterFrequency
  • ExternalReferenceFrequency
  • Frequency 1,2
  • FrequencyCounterOn
  • FrequencyCounterResolution
  • FrequencyOffset
  • FrequencySpan
  • Gain
  • IF
  • IF_Flatness
  • InputAttenuation
  • MarkerFrequency
  • MarkerToCenterFrequency
  • Mode
  • NormalizedReferencePosition
  • PeakSearch
  • PhaseNoise
  • PreamplifierOn
  • RBW
  • RF
  • RFCoupling
  • RadioStd
  • ReferenceFrequencyOutput
  • ReferenceLevel
  • ReferenceLevelOffset
  • ReferencePosition
  • Smoothing
  • SpanRBWRatio
  • StartFrequency
  • StopFrequency
  • SweepPoints
  • SweepTime
  • SweepType
  • TimebaseAccuracyOff
  • VBW
  • VBW_RBWRatio
  • uwPreselectorOff
  • uwPreselectorOn
  1. May be designated as the Evaluation Quantity.
  2. May be designated as the Modifier Quantity.

Operating Mode

The operating mode is determine as follows

  1. If the "Calibrate" is specified, the Operating Mode is "Calibrate".
  2. Otherwise if "Mode" is specified, the operating is mode is the value specified.
  3. Otherwise the operating mode is Spectrum Analysis.

Operating Mode/Parameter Rules

If a parameter is not listed for a mode, it is not allowed.

Action | Default
Calibrate | Connect | Measure | Read | Reset | Setup | Measure

Spectrum Analysis

Parameter Name | Parameter Type | Default Value
+Amplitude 1 | Required | N/A
+Frequency 1 | Required | N/A
CenterFrequency and FrequencySpan 2 | Required | N/A
StartFrequency and StopFrequency 2 | Required | N/A
AutoSweepTime 3 | Optional | Normal
AutoSweepType | Optional | tbd
AverageCount | Optional | Off, 100 averages
AverageType | Optional | Auto (LogPower)
ExternalReferenceFrequency | Optional | Internal
FrequencyCounterOn | Optional | Off
FrequencyOffset | Optional | 0 Hz
MarkerFrequency | Optional | na
MarkerToCenterFrequency | Optional | na
Mode | Optional | SpectrumAnalyzer
NormalizedReferencePosition | Optional | tbd
PeakSearch | Optional | Off
PreamplifierOn | Optional | Off
RBW | Optional | Auto
RBW_VBWRatio | Optional | Auto
RFCoupling | Optional | AC
RadioStd | Optional | None
ReferenceFrequencyOutput | Optional | Off
ReferenceLevel | Optional | Determined by analyzer
SpanRBWRatio | Optional | Auto
SweepPoints | Optional | 601
SweepTime 3 | Optional | PSA model specific (see SweepTime)
SweepType | Optional | Auto
VBW | Optional | Auto
Timeout | Optional | sweep time + (sweep time + average count + 10 s
uwPreselectorOff | Optional | Off
uwPreselectorOn | Optional | Off
  1. Only one Evaluation Quantity (measurement) may be specified.
  2. Either CenterFrequency and FrequencySpan or StartFrequency and StopFrequency must be specified, but not both.
  3. AutoSweepTime and SweepTime are mutually exclusive.

Phase Noise

Parameter Name | Parameter Type | Default Value
+PhaseNoise | Required | N/A
CenterFrequency | Required | N/A
FrequencyOffset | Required | N/A
Measure | Required | N/A
Mode = PhaseNoise | Required | N/A
Amplitude | Optional | N/A
AverageCount | Optional | N/A (average mode off)
ExternalReferenceFrequency | Optional | Internal
FrequencySpan | Optional | 100 Hz to upper limit of PSA
RFCoupling | Optional | AC
ReferenceFrequencyOutput | Optional | Off
ReferenceLevel | Optional | -70 dBc/Hz
Smoothing | Optional | Off
SpanRBWRatio | Optional | N/A (span to RBW ratio mode off)
VBW_RBWRatio | Optional | 1

Calibrate

Parameter Name | Parameter Type | Default Value
Calibrate | Required | N/A
ADC | Required | N/A
All1 | Required | N/A
Gain1 | Required | N/A
IF1 | Required | N/A
IF_Flatness1 | Required | N/A
RF1 | Required | N/A
  1. All is the default, when ADC, Gain, IF, IF_Flatness, or RF is not specified.

Connect

Parameter Name | Parameter Type | Default Value
Input | Required | N/A
Frequency | Required | N/A

Parameter Definitions and Values

ADC

This parameter specifies an alignment of the ADC circuitry.

Syntax:

ADC

Rules

  1. When ADC is specified, Calibrate must also be specified.

Examples:

Calibrate; ADC

All

This parameter specifies a full calibration sequence.

Syntax:

All

Rules

  1. When All is specified, Calibrate must also be specified.

Examples:

Calibrate; All

Amplitude

This parameter specifies the expected amplitude. When this parameter is specified, it must be designated as the Evaluation Quantity.

Syntax:

+Amplitude[sp]=[sp]value

value ::= numeric value[sp][prefix]units

units ::= dBm | V

Rules:

  1. When this parameter is specified, it must be specified as the Evaluation Quantity.
  2. Legal values are:
    • 500 kHz to 3.05 GHz
      • -113 dBm to +30 dBm (without preamp, PSA Option 1DS)
      • -129 dBm to +16 dBm (with preamp, PSA Option 1DS)
    • 3.05 GHz to 6.6 GHz
      • -113 dBm to +30 dBm
    • 6.6 GHz to 13.2 GHz
      • -104 dBm to +30 dBm
    • 13.2 GHz to 19.2 GHz
      • -93 dBm to +30 dBm
    • 19.2 GHz to 26.5 GHz
      • -85 dBm to +30 dBm

Example:

+Ampl = -10.00 dBm

AmplitudeScale

This parameter specifies the vertical amplitude scale.

Syntax:

+AmplitudeScale[sp]=[sp]value

value ::= numeric value[sp][prefix]dB/div

Example:

+AmplScale = 10 dB/div

AutoSweepTime

This parameter specifies the auto sweep time mode.

Syntax:

AutoSweepTime[sp]=[sp]value

value ::= Normal | Accuracy

Rules:

  1. If not specified, the default is Normal
  2. AutoSweepTime and SweepTime are mutually exclusive.

Example:

AutoSweepTime = Acc

AutoSweepType

This parameter specifies the auto sweep type mode.

Syntax:

AutoSweepType[sp]=[sp]value

value ::= DynamicRange | Speed

Rules:

  1. If not specified, the default is tbd.

Example:

AutoSweepType = DynRang

AverageCount

This parameter specifies the average count. When this parameter is specified, average is enabled.

Syntax:

AverageCount[sp]=[sp]numeric value

Rules:

  1. Legal values are: 1 to 8192

Example:

AverageCount = 32

Calibrate

This parameter causes a calibration sequence to be performed.

Syntax:

Calibrate

Rules:

  1. When ADC, Gain, IF, IF_Flatness, or RF is not specified, the default is all.

Examples:

Calibrate

Calibrate; All (same as above)

Calibrate; RF

CenterFrequency

This parameter sets the center frequency.

Syntax:

[@]CenterFrequency[sp]=[sp]numeric value[sp][prefix]Hz

Rules:

  1. Legal values are based on the PSA model:

    E4440A | 3 Hz to 26.5 GHz
    E4443A | 3 Hz to 6.76 GHz
    E4445A | 3 Hz to 13.2 GHz
    E4446A | 3 Hz to 44.0 GHz
    E4447A | 3 Hz to 42.98 GHz
    E4448A | 3 Hz to 50.0 GHz

Examples:

CenterFreq = 1 GHz

Connect

This parameter causes an automatic connection message to be generate when ASK+ W or ASK+ V is in effect. In addition, a connect statement will cause a procedure header CONFIGURATION: line to be generated, regardless of the state of the ASK W and ASK V flags.

Syntax:

Connect

Rules:

  1. When Connect is specified, Input and must also be specified.
  2. When Connect is specified, Frequency and must also be specified.

Examples:

Connect; Input = RF; Freq = 10 MHz

ExternalReferenceFrequency

This parameter enables external reference lock and sets the external frequency reference frequency. If this parameter is not specified, external frequency lock is disabled.

Syntax:

ExternalReferenceFrequency[sp]=[sp]value

value ::= numeric value[sp][prefix]Hz

Rules:

  1. Legal values are: 1 MHz to 30 MHz
  2. If not specified, internal frequency reference is used.

Example:

ExtRefFreq = 10 MHz

Frequency

This parameter specifies the expected frequency of the RF input signal.

Syntax:

[+|@]Frequency[sp]=[sp]value

value ::= numeric value[sp][prefix]Hz

Rules:

  1. Legal values are based on the PSA model:

    E4440A | 3 Hz to 26.5 GHz
    E4443A | 3 Hz to 6.76 GHz
    E4445A | 3 Hz to 13.2 GHz
    E4446A | 3 Hz to 44.0 GHz
    E4447A | 3 Hz to 42.98 GHz
    E4448A | 3 Hz to 50.0 GHz

Example:

+Freq = 120.0000MHz

FrequencyCounterOn

This parameter enables the frequency counter.

Syntax:

FrequencyCounterOn

Example:

FrequencyCounterOn

FrequencyCounterResolution

This parameter specifies the frequency counter resolution.

Syntax:

FrequencyCounterResolution[sp]=[sp]value

value ::= numeric value[sp][prefix]Hz

Rules:

  1. Legal values are: 1, 10, 100 Hz, 1, 10, 100 kHz

Example:

FreqCounterRes = 10 Hz

FrequencyOffset

This parameter specifies the frequency offset.

Syntax:

FrequencyOffset[sp]=[sp]value

value ::= numeric value[sp][prefix]Hz

Rules:

  1. Legal values are: 10 Hz to 100 MHz

Example:

FrequencyOffset = 10 kHz

FrequencySpan

This parameter sets the frequency span.

Syntax:

[@]FrequencySpan[sp]=[sp]numeric value[sp][prefix]Hz

Rules:

  1. 0 Hz selects Zero Span

  2. Legal values are based on the PSA model

    E4440A | 3 Hz to 26.5 GHz
    E4443A | 3 Hz to 6.76 GHz
    E4445A | 3 Hz to 13.2 GHz
    E4446A | 3 Hz to 44.0 GHz
    E4447A | 3 Hz to 42.98 GHz
    E4448A | 3 Hz to 50.0 GHz

Examples:

StartFreq = 1 GHz

Input

This parameter sets the input for a Connect statement.

Syntax:

Input[sp]=[sp]RF

Example:

Input = RF

MarkerFrequency

This parameter specifies the ...

Syntax:

+MarkerFrequency[sp]=[sp]value

value ::= numeric value[sp][prefix]Hz

Rules:

  1. When this parameter is specified, it must be specified as the Evaluation Quantity.
  2. Legal values are based on PSA model used.

Example:

+MarkerFreq = 110 MHz

Local

This action puts the PSA in local mode.

Syntax:

Local

Rules:

  1. When Local is specified, no other parameters may be specified.

Examples:

Local

Measure

This "Action" parameter causes the following

  1. Setup the PSA for measurement of the parameter designated as the Evaluation Quantity.
  2. Initiate the measurement.
  3. Return the reading in memory register MEM in units of the designated Nominal parameter value.

Syntax:

Measure

Rules

  1. When Measure is specified, Setup must not be specified.
  2. When neither Measure or Setup is specified, Measure is assumed.

Mode

This parameter specifies the operating mode.

Syntax:

Mode[sp]=[sp]value

value ::= SpecAn | SpectrumAnalysis | PhaseNoiseLogPlot

Rules:

  1. If not specified, the default is SpectrumAnalysis.

Example:

Mode = PhaseNoiseLogPlot

NormalizedReferencePosition

This parameter specifies the normalized reference position.

Syntax:

NormalizedReferencePosition[sp]=[sp]numeric value

Rules:

  1. Legal values are: 0, 1, 2, 3, 4, 5, 6, 7, 8, 9, & 10

Example:

NormalizedReferencePosition = 4

PeakSearch

This parameter specifies that a peak search be performed.

Syntax:

PeakSearch

Example:

PeakSearch

PhaseNoise

This parameter specifies the expected phase noise of the input signal.

Syntax:

+PhaseNoise[sp]=[sp]value

value ::= numeric value[sp]dBc/Hz

Example:

+PhaseNoise = -132 dBc/Hz

PreamplifierOn

This parameter anables the preamplifier.

Syntax:

PreamplifierOn

Example:

PreamplifierOn

RBW (Resolution Bandwidth)

This parameter turns auto RBW off an sets the resolution bandwidth.

Syntax:

RBW[sp]=[sp]value

value ::= numeric value[sp][prefix]Hz

Rules:

  1. Legal values are:
    1. 1, 3, 10, 30, 100, and 300 Hz,
    2. 1, 3, 10, 30, 100, and 300 kHz,
    3. 1, 3, and 8 MHz
  2. If not specified, the RBW is set to auto.

RF

This parameter specifies PSA RF calibration.

Syntax:

RF

Example:

Cal; RF

RFCoupling

This parameter specifies the RF input coupling.

Syntax:

RFCoupling[sp]=[sp]value

value ::= AC | DC

Rules:

  1. If not specified, the default is AC.

Example:

RFCoupling = DC

RadioStd

This parameter specifies the radio standard.

Syntax:

RadioStd[sp]=[sp]value
value ::= | 3GPP W-CDMA | |
 | DVB-T G/PAL/NICAM | |
 | DVB-T I/PAL/NICAM | |
 | DVB-T L/SECAM/NICAM | |
 | FCC Part 15 Subpart F | |
 | GSM/EDGE | |
 | IS-95A | |
 | IS-95C | |
 | J-STD-008 | |
 | NADC | |
 | PDC | |
 | S-DMB System E | |
 | TETRA | |
 | UWB Indoor | |
 | W-LAN 802.11a | |
 | W-LAN 802.11b | |
 | W-LAN 802.11g | |
 | W-LAN HiperLAN/2 | |
 | cdma2000 DS | |
 | cdma2000 MC-1X | |
 | cdma2000 MC-3X |

Rules:

  1. If not specified, the default value is: None

Example:

RadioStd = Bluetooth

Read

This "Action" parameter causes the following

  1. Initiate the measurement.
  2. Return the reading in memory register MEM.

Syntax:

Read

Rules

  1. A PSA Measurement or Setup statement must precede a Read statement in the current test.
  2. The value in MEM is in units of the parameter designate as the Evaluation Quantity in the previous PSA Measure or Setup statement.
  3. When Read is specified, no other parameters may be specified.

Examples:

PSA Read

ReferenceFrequencyOutput

This parameter enables the reference frequency output and sets the frequency to the value specified. If this parameter is not specified, the reference frequency output is disabled.

Syntax:

ReferenceFrequencyOutput[sp]=[sp]dim quan

dim quan ::= value[sp][prefix]Hz

value::= numeric value | register reference

Rules:

  1. Legal values are: 10 MHz

Examples:

ReferenceFrequencyOutput = 10 MHz

ReferenceLevel

This parameter specifies the reference level.

Syntax:

ReferenceLevel[sp]=[sp]numeric value[sp]units

units ::= dBm | dBc/Hz

Rules

  • Spectrum Analyzer mode
    • Legal values are: tbd
  • Phase Noise Log Plot mode
    • Legal values are: -200 dBc/Hz to 200 dBc/Hz
  • Phase Noise Monitor mode
    • Legal values are: -170 dBm to 30 dBm

Example:

ReferenceLevel = 10 dBm

Reset

This parameter resets the instrument.

Syntax:

Reset

Rules:

  1. When Reset is specified, no other parameters are allowed.

Examples:

Reset

Setup

This "Action" parameter sets up the PSA for measurement of the parameter designated as the Evaluation Quantity.

Syntax:

Setup

Rules

  1. No measurement is performed.
  2. A Read "Action" must be specified in a subsequent PSA statement to cause a measurement to be performed and to obtain the reading.
  3. When Setup is specified, Measure must not be specified.

Examples:

PSA Setup +FMDev = 100 kHz

Smoothing

This parameter specifies the amount of smoothing that is done after the measurement has been completed.

Syntax:

Smoothing[sp]=[sp]numeric value%

Rules

  1. Legal values are: 0 to 16 %
  2. Default value: 4 %

Example:

Smoothing = 10 %

SpanRBWRatio

This parameter specifies the ratio of the span to the resolution bandwidth.

Syntax:

SpanRBWRatio[sp]=[sp]numeric value

Rules

  1. Legal values are: 2 to 1000
  2. When this parameter is specified, span to RBW ratio mode is set to manual.
  3. Default value: 106

Example:

SpanRBWRatio = 100

StartFrequency

This parameter sets the start frequency.

Syntax:

[@]StartFrequency[sp]=[sp]numeric value[sp][prefix]Hz

Rules:

  1. Legal values are based on the PSA model:

    E4440A | 3 Hz to 26.5 GHz
    E4443A | 3 Hz to 6.76 GHz
    E4445A | 3 Hz to 13.2 GHz
    E4446A | 3 Hz to 44.5 GHz
    E4447A | 3 Hz to 42.98 GHz
    E4448A | 3 Hz to 51.0 GHz

Examples:

StartFreq = 1 GHz

StopFrequency

This parameter sets the stop frequency.

Syntax:

[@]StopFrequency[sp]=[sp]numeric value[prefix]Hz

Rules:

  1. Legal values are based on the PSA model:

    E4440A | 3 Hz to 26.5 GHz
    E4443A | 3 Hz to 6.76GHz
    E4445A | 3 Hz to 13.2 GHz
    E4446A | 3 Hz to 44.5 GHz
    E4447A | 3 Hz to 42.98 GHz
    E4448A | 3 Hz to 51.0 GHz

Examples:

StopFreq = 1 GHz

SweepPoints

This parameter specifies the number of points per sweep.

Syntax:

SweepPoints[sp]=[sp]numeric value

Rules:

  1. Legal values are: 101 to 8192
  2. If not specified, the default value is: 601

Example:

SweepPoints = 2000

SweepTime

This parameter specifies the sweep time.

Syntax:

SweepTime[sp]=[sp]numeric value[sp][prefix]s

Rules:

  1. Legal values are:

    Zero span | 1 us to 6000 s
    Swept spans | 1 ms to 2000 s

  2. If not specified, the default value is:

    E4440A | 66.24 ms
    E4443A | 11.16 ms
    E4445A | 22.00 ms
    E4446A | 110.00 ms
    E4447A | tbd ms
    E4448A | 125.00 ms

Example:

SweepTime = 200 ms

SweepType

This parameter specifies the sweep type.

Syntax:

SweepType[sp]=[sp]

value ::= Auto | FFT | Manual

Rules:

  1. If not specified, the default value is: Auto

Example:

SweepType = FFT

TimebaseAccuracyOff

This parameter is used when it is only desired to synchronize the PSA with the UUT, without an absolute accuracy determination.

Syntax:

TimebaseAccuracyOff

Examples:

TimebaseAccuracyOff

VBW (Video Bandwidth)

This parameter turns auto VBW off an sets the video bandwidth.

Syntax:

VBW[sp]=[sp]value

value ::= numeric value[sp][prefix]Hz

Rules:

  1. Legal values are:
    1. 1, 3, 10, 30, 100, and 300 Hz,
    2. 1, 3, 10, 30, 100, and 300 kHz,
    3. 1, 3, 8, and 50 MHz
  2. If not specified, the VBW is set to auto.

VBW_RBWRatio

This parameter specifies the video to resolution bandwidth ratio.

Syntax:

VBW_RBWRatio[sp]=[sp]numeric value

Rules:

  1. Legal values are: 0.001 to 10

Example:

VBW_RBWRatio = 0.1

uwPreselectorOff

This parameter turns the microwave preselector off.

Syntax:

uwPreselectorOff

Rules:

  1. If this parameter is not specified, the microwave preselector is turned off.

Example:

uwPreselectorOff

uwPreselectorOn

This parameter turns the microwave preselector on.

Syntax:

uwPreselectorOn

Rules:

  1. If this parameter is not specified, the microwave preselector is turned off.

Example:

uwPreselectorOn

Examples

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON

  1.001  MATH         Device = "Agilent PSA"

# -----  Spectrum Analysis Mode: Harmonics  -----
  1.002  TSET         TDESC = 2 MHz, 2 harmonic
  1.003  TARGET       -p
# Set UUT output parameters.
  1.004  SCPI         FREQ:CW 2MHZ;:POW:AMPL 4 DBM;:OUTP:STAT ON
# Measure amplitude of fundamental.
  1.005  PSA          Mode = SpectrumAnalysis
  1.005  PSA          InputAttenuation = 20 dB
  1.005  PSA          ExtRefFreq = 10 MHz; TimebaseAccOff
  1.005  PSA          RBW = 10 kHz; VBW = 30 kHz; RefLevel = 10 dBm
  1.005  PSA          CenterFreq = 2 MHz; FreqSpan = 500 kHz
  1.005  PSA          +Ampl = 4 dBm; PeakSearch; MarkerToCenterFreq
  1.006  MATH         RefLvl = MEM
# Retrieve uncertainty for above measurement and normalize.
  1.007  MATH         L[1] = ACCV2(Device, "Freq Resp", MEM, 2)
  1.008  MATH         L[1] = L[1] / @Conf
  1.009  TARGET       -m
# Measure amplitude of harmonic.
  1.010  PSA          InputAttenuation = 20 dB
  1.010  PSA          ExtRefFreq = 10 MHz; TimebaseAccOff
  1.010  PSA          RBW = 10 kHz; VBW = 30 kHz; RefLevel = 10 dBm
  1.010  PSA          CenterFreq = 4 MHz; FreqSpan = 500 kHz
  1.010  PSA          +Ampl = -26 dBm; PeakSearch; MarkerToCenterFreq
# Retrieve scale fidelity uncertainty for above measurements and normalize.
  1.011  MATH         L[2] = ACCV2(Device, "Log Scale Fidelity", MEM, 2)
  1.012  MATH         L[2] = L[2] / @Conf
  1.013  MATH         L[3] = ACCV2(Device, "Log Scale Fidelity", MEM, 2)
  1.014  MATH         L[3] = L[3] / @Conf
# RSS all individual measurement uncertainty components and expand.
  1.015  MATH         L[4] = RSS3(L[1], L[2], L[3]) * 2
# Computed expanded uncertainty shown in ACC.
# Compute harmonic level (dBc).
  1.016  MATH         MEM = MEM - RefLvl
  1.017  ACC    -30   dBc            L4U
  1.018  MEMC         -30.0dBc       -0.0U +100.0U

# -----  Spectrum Analysis Mode: Spurious  -----
  2.001  TSET         TDESC = 242 MHz (274 MHz Spur)
  2.002  MATH         Freq = 242 * 1E+6; Spur = 274 * 1E+6
  2.003  TARGET       -p
# Set UUT output parameters.
  2.004  SCPI         FREQ:CW 242MHZ;:POW:AMPL 4DBM
  2.004  SCPI         OUTP:STAT ON
# Measure amplitude of fundamental.
  2.005  PSA          InputAttenuation = 20 dB
  2.005  PSA          ExtRefFreq = 10 MHz; TimebaseAccOff
  2.005  PSA          RBW = 1 kHz; VBW = 1 kHz; RefLevel = 10 dBm
  2.005  PSA          CenterFreq = 242 MHz; FreqSpan = 500 kHz
  2.005  PSA          +Ampl = 4 dBm; PeakSearch; MarkerToCenterFreq
# Store fundamental reference level in M[1].
  2.006  MATH         RefLvl = MEM
# Specify correct 856x frequency response mode string for unit being used.
# Retrieve uncertainty for above measurement and normalize.
  2.007  MATH         L[1] = ACCV2(Device, "Freq Resp", MEM, Freq) / @Conf
  2.008  TARGET       -m
# Measure amplitude of spur.
  2.009  PSA          InputAttenuation = 20 dB
  2.009  PSA          ExtRefFreq = 10 MHz; TimebaseAccOff
  2.009  PSA          RBW = 1 kHz; VBW = 1 kHz; RefLevel = 10 dBm
  2.009  PSA          CenterFreq = 274 MHz; FreqSpan = 500 kHz
  2.009  PSA          +Ampl = -51 dBm; PeakSearch; MarkerToCenterFreq
# Compute harmonic level (dBc).
  2.010  MATH         MEM = MEM - RefLvl
# Retrieve uncertainty for above measurement and normalize.
  2.011  MATH         L[2] = ACCV2(Device, "Freq Resp", MEM, Spur) / @Conf
# Specify correct scale fidelity mode string for unit being used.
# Retrieve scale fidelity uncertainty for above measurements.
  2.012  MATH         L[3] = ACCV2(Device, "Log Scale Fidelity", MEM, Spur)
  2.013  MATH         L[3] = L[3] / @Conf
# RSS all individual measurement uncertainty componenets
  2.014  MATH         L[4] = RSS3(L[1], L[2], L[3]) * 2
# Computed expanded uncertainty shown in ACC.
  2.015  ACC    -55   dBc            L4U
  2.016  MEMC         -55.0dBc       -0.0U +75.0U

# -----  Phase Noise Mode  -----
  3.001  TSET         TDESC = 120 MHz
  3.002  TARGET       -p
  3.003  IEEE         [SDC]FR120MZAP0DMR3
  3.004  TARGET       -m
  3.005  PSA          Mode = PhaseNoiseLogPlot
  3.005  PSA          CenterFreq = 120 MHz  FreqSpan = 50 kHz
  3.005  PSA          FreqOffset = 20 kHz   RFCoupling = DC
  3.005  PSA          +PhaseNoise = -124.00 dBc/Hz  ExtRefFreq = 10 MHz
  3.006  MEMC         -124.00dBc/Hz  -0U +1000%


N5531

Instrument FSC

Description

The N5531 FSC controls the Agilent PSA Option 233 "N5531S Measuring Receiver System". The N5531S Measuring Receiver System supports the following operating modes:

  • Frequency Counter
  • Tuned RF Level
  • Absolute RF Power
  • AM Depth
  • FM Deviation
  • PM Deviation
  • Modulation Rate
  • Modulation Distortion
  • Modulation SINAD
  • Audio Frequency 1
  • Audio AC Level 1
  • Audio Distortion 1
  • Audio SINAD 1
  • Calibrate Power Meter
  • Zero Power Meter
  • Zero and Calibrate Power Meter
  1. Requires PSA Option 107 "Audio Input"

N5532A Sensor Modules

N5531 FSC statements which specify Absolute RF Power or Tuned RF Level measurement require a power meter and sensor module. Prior to either of these measurements, the following steps must be performed.

  1. Connect the sensor module to the PSA.
  2. Load the cal factors for the sensor module into the PSA.
  3. Connect the sensor module to the power meter reference output.
  4. Zero the power meter.
  5. Cal the power meter.
  6. Disconnect the sensor module from the power meter reference output.
  7. Connect the sensor module to the UUT.

The following N5532A options are supported by the N5531 FSC:

  100 kHz    10 MHz    30 MHz    50 MHz    4.2 GHz    18 GHz  26.5 GHz  50 GHz
     |         |         |         |          |         |         |        |
     |<============== N5532A-504 ============>|         |         |        |
               |<============== N5532A-518 ============>|         |        |
                         |<============== N5532A-526 ============>|        |
                                   |<============= N5532A-550 ============>|

Therefore, depending upon the test frequencies required by the UUT, more than one sensor module may be required and the above steps will have to be performed more than once. The point at which the sensor module must be changed is dependent upon the actual sensor modules used.

Example: 20 MHz to 50 GHz Signal Generator

A single N5532A option is not available that covers all frequencies required. This frequency range requires either a N5532A-504 and N5532A-550 or a N5532A-518 and N5532A-550. The sensor module can be changed anywhere from 50 MHz to 4.2 GHz for a N5532A-504 and N5532A-550, and 50 MHz to 18 GHz for a N5532A-518 and N5532A-550. The N5531 FSC is designed to allow N5531 RF Power and Tuned RF Level statements to be written without specifying a particular N5532A sensor module option. This feature allows a single procedure to be written that will execute with either a N5532A-504 and N5532A-550 configured or a N5532A-518 and N5532A-550 configured.

When the N5531 FSC determines that the sensor module must be changed, messages to the operator and commands to the PSA are automatically generated to perform the seven steps outlined above.

The N5531 FSC uses the following criteria to determine when the sensor module must be changed:

  1. The specified frequency range of each sensor module option as shown above.
  2. A custom frequency range for each sensor module option specified in the MET/CAL Configuration setting. *
  3. A custom frequency range for each sensor module option specified in a VSET or TSET statement. *

* See the following parameters in VSET / TSET FSC help topic:

  • N5532A-504
  • N5532A-518
  • N5532A-526
  • N5532A-550
  • SensorChange

The following procedure fragment uses the automatic sensor module selection feature of the N5531 FSC (1). Note that the procedure header configuration line does not specify a N5532A option. Instead, the configuration line specifies a range of frequencies that the sensor modules must cover.

CONFIGURATION:         Agilent PSA (50.0 GHz,233)
CONFIGURATION:         Agilent EPM
CONFIGURATION:         Agilent N5532A (10.0 MHz - 50.0 GHz)
=============================================================================
 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON

  1.001  ASK+                                                              V

  1.002  IF           0
  1.003  N5531        Connect; Input = RF; Freq = 50 GHz
  1.003  N5531        SensorModule = N5532A
  1.004  ENDIF

  1.005  RSLT         =
  1.006  HEAD         RF LEVEL ACCURACY ({Carrier Frequency: 20 MHz})
  1.007  MATH         CM(1, "RF OUPUT")
  1.008  TARGET       -p
  1.009  N5531        Connect; Input = RF; Freq = 20 MHz
  1.009  N5531        SensorModule = N5532A
# First setup to 30 dB attenuation to prevent IF Overload.
  1.010  N5531        +Freq = 20 MHz; Power = 13 dBm; InputAtt = 30 dB; Setup
  1.011  SCPI         POW:AMPL 13DBM;:FREQ:CW 20MHZ;:OUTP:STAT ON
  1.012  N5531        +Freq = 20 MHz; Power = 13 dBm; InputAtt = 30 dB; Read
  1.013  MATH         FreqMHz = MEM
  1.014  TARGET       -m
  1.015  N5531        SensorModule = N5532A; InputAtt = 30 dB
  1.015  N5531        +Power = 13 dBm; Freq = [V FreqMHz] MHz
  1.016  MEMC   130   13.0dBm        1.0U
#          .
#          .
#          .
#          .

  2.001  RSLT         =
  2.002  HEAD         RF LEVEL ACCURACY ({Carrier Frequency: 50 MHz})
  2.003  TARGET       -p
  2.004  N5531        +Freq = 50 GHz; Power = 13 dBm; InputAtt = 30 dB; Setup
  2.005  SCPI         POW:AMPL 13DBM;:FREQ:CW 50GHZ;:OUTP:STAT ON
  2.006  N5531        +Freq = 50 GHz; Power = 13 dBm; InputAtt = 30 dB; Read
  2.007  MATH         FreqGHz = MEM
  2.008  TARGET       -m
  2.009  N5531        SensorModule = N5532A; InputAtt = 30 dB
  2.009  N5531        +Power = 13 dBm; Freq = [V FreqGHz] GHz
  2.010  MEMC   130   13.0dBm        1.0U

Explanation of Procedure Steps

Step 1.001

ASK+ V (or ASK+ W) enables the following:

  1. Automatic N5532A sensor module connection messages.
  2. Automatic messages to prompt operator to load sensor module cal factors.

Step 1.003

This statement forces the procedure header CONFIGURATION: line to include the maximum sensor module frequency required by the procedure.

Since N5531S RF Power measurement must be tuned, the Frequency parameter value must come from a register (steps 1.015 and 2.009). When a parameter value comes from a register, MET/CAL only knows the value when the statement is executed, not when it is compiled. Therefore, statement 2.009 will not, by itself, cause the necessary CONFIGURATION: line to be generate.

Step 1.007

The MATH FSC CM "Connection Message" function is used to annotate the automatic connection message, generated by the N5531 FSC, to connect the sensor module to the UUT. See MATH FSC help topic for explanation of CM function.

Step 1.009

This statement forces automatic connection messages for the sensor module selected for 30 MHz RF Power or Tuned RF Level statements.

The N5531S only requires a power meter and sensor module for absolute RF Power and Tuned RF Level measurements. However since RF Power and Tuned RF Level require a "tune" frequency, a N5531S frequency measurement must first be performed (steps 1.012 and 2.006). A N5531S frequency measurement generates an automatic connection message to connect the UUT to the PSA RF INPUT unless a sensor module is already connected. A N5531 Connect statement allows a procedure writer to force connection of sensor module before statements that actual require a sensor module.

Sensor Module Change

When the automatic sensor module selection feature of the N5531 FSC determines that a sensor module change is necessary, the following messages and actions are generated:

  1. Prompt the operator to determine if the cal factors for the sensor module have been loaded.
    1. If the cal factors have not been loaded, prompt the operator for the path to the cal factors file (i.e. "A:\CFDATA.XML").
    2. If the cal factors path includes "A:", prompt the operator to insert the disk containing the file.
  2. If there is an existing connection to the PSA RF INPUT, prompt the operator to remove the connection. This includes sensor modules or direct connections.
  3. Prompt the operator to connect the sensor module to the PSA.
  4. Prompt the operator to connect the sensor module to the power meter reference output.
  5. Zero and cal the power meter.
  6. Prompt the operator to disconnect the sensor module from the power meter reference output.
  7. Prompt the operator to connect the sensor module to the UUT.

Parameters

An NVI FSC statement consists of one or more parameters. A parameter consists of a name and a value. Each parameter must be separated by a semicolon and/or one or more spaces. A single NVI FSC statement can encompass more than one physical line as long as the line numbers are the same. However each parameter name and its value must occur on one line. A single line can accommodate up to 256 characters including the statement number and FSC. Note that characters above ASCII 128 count as 2 characters.

Syntax:

parameter[separatorparameter]

parameter::= [parameter_prefix]parameter_name[[sp]=[sp]parameter_value]

separator::= ;[sp] | sp

parameter_prefix ::=+ | @

sp::= one or more spaces

parameter_name::= see the Parameter Names section

parameter_value::=dimensionless number | dimensioned number | discrete_list

dimensionless number::=NRf

dimensioned number::=NRf[sp][prefix]units

discrete_list::=see the Parameter Names section

prefix::=y | z | a | f | p | n | u | m | k | M | G | T | P | E | Z | Y

Definitions:

|
Denotes "or" (i.e. A | B is A or B)
[ ]
Denotes an optional syntax element, except in examples. In examples [ ] enclose a special construction.
+
Designates the parameter as the Evaluation Quantity
@
Designates the parameter as the Modifier Quantity

Rules:

  1. One and only one parameter must be designated as the Evaluation Quantity in a N5531 Measure (default), Setup, or Read action.

  2. When a N5531 Measure (default) statement is executed, the N5531S measurement is copied to memory register MEM in units of the Evaluation Quantity.

    Example:

    N5531  Freq = 100 MHz; Power = -10 dBm
N5531  +FMDev = 5 kHz; ModFreq = 1 kHz

    or

    N5531  Freq = 100 MHz; Power = -10 dBm
N5531  +FMDev = 5 kHz; ModFreq = 1 kHz; Measure

    If the N5531S FM deviation measurement was 4.99 kHz, MEM would be 4.99.

  3. When a N5531 Read statement is executed, the N5531S measurement is copied to memory register MEM in units of the Evaluation Quantity designated in the previous Setup or Measure statement.

    Example:

    N5531  Freq = 100 MHz; Power = -10 dBm
N5531  +FMDev = 5 kHz; ModFreq = 1 kHz; Setup

    N5531  Freq = 100 MHz; Power = -10 dBm
N5531  +FMDev = 5 kHz; ModFreq = 1 kHz; Read

  4. At most one parameter may be designated as the Modifier Quantity in a N5531 Measure or Setup.

  5. When a N5531 Measure is executed, the Modifier Quantity is concatenated to the Evaluation Quantity in the automatic message to setup the UUT. Note, the automatic message to setup the UUT is not displayed when ASK- N is in effect.

    Examples:

    ASK+  N
N5531  Freq = 100 MHz; Power = -10 dBm
N5531  +AMDepth = 30 %; @ModFreq = 400 Hz

    "Set UUT to source 30 % at 100 MHz."

    No Modifier Quantity designated.

    N5531  Freq = 100 MHz; Power = -10 dBm
N5531  +AMDepth = 30 %; ModFreq = 400 Hz

    "Set UUT to source 30 %."

    Automatic UUT setup message inhibited.

    ASK-  N
N5531  Freq = 100 MHz; Power = -10 dBm
N5531  +AMDepth = 30 %; ModFreq = 400 Hz

    No automatic UUT setup generated.

  6. Parameter values may be taken from a MET/CAL memory register using a special construction.

Parameter Names

Parameter names consist of single words or compound words. Each word in a parameter name can be entered in long form (as shown below), or in short form. The short form is the first 4 characters of the long form, with the following exceptions:

  1. If the long form is greater than four characters, and the last character or the short form is a vowel, the short form is three characters.
  2. If the long form is four characters or less, the short form is the long form even if it ends in a vowel.

Compound parameter names can be entered in any combination of long and short forms. Example, ExternalReferenceFrequency can be entered using any of the following forms:

  • ExtRefFreq
  • ExtRefFrequency
  • ExtReferenceFreq
  • ExtReferenceFrequency
  • ExternalRefFreq
  • ExternalRefFrequency
  • ExternalReferenceFreq
  • ExternalReferenceFrequency

Action Parameters

Action parameters specify the operation to be performed.

  • Calibrate
  • Connect
  • Local
  • Measure
  • Read
  • Reset
  • Setup
  • Zero
  • Zero_and_Cal

Rules:

  1. Only one action parameter is allowed per N5531 statement (single or mult-line).
  2. If an action is not specified, the default is Measure.

Primary Parameters

Primary parameters specify the measurement.

  • AMDepth
  • AMDepthRatio
  • AudioACLevel
  • AudioACLevelRatio
  • AudioDistortion
  • AudioDistortionRatio
  • AudioFrequency
  • AudioFrequencyRatio
  • AudioSINAD
  • AudioSINADRatio
  • FMDeviation
  • FMDeviationRatio
  • Frequency
  • FrequencyRatio
  • Level
  • LevelRatio
  • ModulationDistortion
  • ModulationDistortionRatio
  • ModulationFrequency
  • ModulationFrequencyRatio
  • ModulationSINAD
  • ModulationSINADRatio
  • PMDeviation
  • PMDeviationRatio
  • Power
  • PowerRatio
  • RelativeLevel
  • ResidualAM
  • ResidualFM
  • ResidualPM

Rules:

  1. The primary parameter must be designated as the evaluation quantity.

Secondary Parameters

Secondary parameters are used for one or both of the following:

  1. Clarify the action.
  2. Configure the measurement specified by the primary parameter.
  • AudioRange
  • AutoTuneOff
  • AverageAccuracy
  • AverageCount
  • AverageType
  • BWMode
  • De-emphasis
  • Detector
  • ExternalReferenceFrequency
  • GateTime
  • HPF (High-pass Filter)
  • IFBW (IF Bandwidth)
  • Input
  • InputAttenuation
  • LPF (Low-pass Filter)
  • PeakHoldOn
  • PowerMeter
  • PreamplifierOn
  • RBW (Resolution Bandwidth)
  • RFInputRanging
  • RangeHoldOn
  • RatioReference
  • ReferenceFrequencyOutput
  • ReferenceLevel
  • SensorModule
  • SetReference
  • Timeout
  • uwPreselectorOff

Operating Mode

The following actions determine the operating mode directly.

Action Parameter | Operating Mode
Calibrate | Calibrate Power Meter
Connect | Determine automatic connection message
Reset | Reset PSA
Zero | Zero Power Meter
Zero_and_Cal | Zero and Calibrate Power Meter

For all other actions the operating mode is determined by the primary parameter as follows:

Primary Parameter | Operating Mode
AMDepth | AM Depth
AMDepthRatio | AM Depth
AudioACLevel | Audio AC Level
AudioACLevelRatio | Audio AC Level
AudioDistortion | Audio Distortion
AudioDistortionRatio | Audio Distortion
AudioFrequency | Audio Frequency
AudioFrequencyRatio | Audio Frequency
AudioSINAD | Audio SINAD
AudioSINADRatio | Audio SINAD
FMDeviation | FM Deviation
FMDeviationRatio | FM Deviation
Frequency | Frequency Counter
FrequencyRatio | Frequency Counter
Level | Tuned RF Level
LevelRatio | Tuned RF Level
ModulationDistortion | Modulation Distortion
ModulationDistortionRatio | Modulation Distortion
ModulationFrequency | Modulation Frequency
ModulationFrequencyRatio | Modulation Frequency
ModulationSINAD | Modulation SINAD
ModulationSINADRatio | Modulation SINAD
PMDeviation | Phase Deviation
PMDeviationRatio | Phase Deviation
Power | Absolute RF Power
PowerRatio | Absolute RF Power
RelativeLevel | Tuned RF Level

Inter-Parameter Rules

If a parameter is not listed for a operating mode, it is not allowed.

Frequency Counter

Required Parameters

  • +Frequency 1
  • +FrequencyRatio 1,2
  • RatioReference 3
  • Power
  1. Either Frequency or FrequencyRatio is required, but not both.
  2. FrequencyRatio is only allowed with the Read action and can only occur following a Frequency Measure statement.
  3. RatioReference is only required if the FrequencyRatio is specified.
Optional Parameters | Default
AutoTuneOff | na (auto tuning on)
AverageCount | 25
AverageType | Off
ExternalReferenceFrequency | Internal
GateTime | Auto
InputAttenuation | depends upon input signal
ModulationFrequency | 0 Hz
PreamplifierOn | Off
RBW | 100 Hz
RFInputRanging | Auto
ReferenceFrequencyOutput | Off
SensorModule | No sensor module required
Timeout | 1000 s
uwPreselectorOff | On

Tuned RF Level

Required Parameters

  • +Level 1
  • +LevelRatio 2
  • +RelativeLevel 3
  • Frequency
  • RatioReference 4
  • SensorModule 5
  1. Either Level, LevelRatio, or RelativeLevel is required, but only one.
  2. LevelRatio is only allowed with the Read action and can only occur following a Level Measure statement.
  3. RelativeLevel is only allowed with the Read action and can only occur following a Level Measure statement with SetReference specified.
  4. RatioReference is only required if the LevelRatio is specified.
  5. SensorModule is only required for absolute measurement (Level or LevelRatio is specified, and SetReference is not specified).
Optional Parameters | Default
AverageAccuracy | Normal
AverageCount | 25
ExternalReferenceFrequency | Internal
InputAttenuation | depends upon input signal
IFBW | 10 Hz
PreamplifierOn | Off
RFInputRanging | Auto
RangeHoldOn | Off
ReferenceFrequencyOutput | Off
ReferenceLevel 1 | na
SensorModule | Automatic Selection
SetReference | na
Timeout | 1000 s
uwPreselectorOff | On
  1. Required for accuracy calculation on all TRFL read statements following the starting TRFL statement (see TRFL in Examples).

Absolute RF Power

Required Parameters

  • +Power 1
  • +PowerRatio 1,2
  • RatioReference 3
  • SensorModule
  • Frequency
  1. Either Power or PowerRatio is required, but not both.
  2. PowerRatio is only allowed with the Read action and can only occur following a Power Measure statement.
  3. RatioReference is only required if the PowerRatio is specified.
Optional Parameters | Default
AverageCount | 25
ExternalReferenceFrequency | Internal
InputAttenuation | depends upon input signal
PreamplifierOn | Off
RFInputRanging | Auto
ReferenceFrequencyOutput | Off
Timeout | 1000 s
uwPreselectorOff | On

AM Depth

Required Parameters

  • +AMDepth 1
  • +AMDepthRatio 1,2
  • +ResidualAM 1
  • Frequency
  • ModulationFrequency
  • Power
  • RatioReference 3
  1. AMDepth, AMDepthRatio, or ResidualAM is required, but only one.
  2. AMDepthRatio is only allowed with the Read action and can only occur following a AMDepth Measure statement.
  3. RatioReference is only required if the AMDepthRatio is specified.
Optional Parameters | Default
AverageCount | 25
AverageType | Off
BWMode | Auto
Detector | Peak+
ExternalReferenceFrequency | Internal
HPF | 20 Hz
IFBW | Auto
InputAttenuation | depends upon input signal
LPF | Off
PeakHoldOn | Off
PreamplifierOn | Off
RFInputRanging | Auto
ReferenceFrequencyOutput | Off
Timeout | 1000 s
uwPreselectorOff | On

FM Deviation

Required Parameters

  • +FMDeviation 1
  • +FMDeviationRatio 1,2
  • +ResidualFM 1
  • RatioReference 3
  • ModulationFrequency
  • Frequency
  • Power
  1. FMDeviation, FMDeviationRatio, or ResidualFM is required, but only one.
  2. FMDeviationRatio is only allowed with the Read action and can only occur following a FMDeviation Measure statement.
  3. RatioReference is only required if the FMDeviationRatio is specified.
Optional Parameters | Default
AverageCount | 25
AverageType | Off
BWMode | Auto
De-emphasis | Off
Detector | Peak+
ExternalReferenceFrequency | Internal
HPF | 20 Hz
IFBW | Auto
InputAttenuation | depends upon input signal
LPF | Off
PeakHoldOn | Off
PreamplifierOn | Off
ReferenceFrequencyOutput | Off
RFInputRanging | Auto
Timeout | 1000 s
uwPreselectorOff | On

PM Deviation

Required Parameters

  • +PMDeviation 1
  • +PMDeviationRatio 1,2
  • +ResidualPM 1
  • RatioReference 3
  • ModulationFrequency
  • Frequency
  • Power
  1. PMDeviation, PMDeviationRatio, or ResidualPM is required, but only one.
  2. PMDeviationRatio is only allowed with the Read action and can only occur following a PMDeviation Measure statement.
  3. RatioReference is only required if the PMDeviationRatio is specified.
Optional Parameters | Default
AverageCount | 25
AverageType | Off
BWMode | Auto
De-emphasis | Off
Detector | Peak+
ExternalReferenceFrequency | Internal
HPF | 20 Hz
IFBW | Auto
InputAttenuation | depends upon input signal
LPF | Off
PeakHoldOn | Off
PreamplifierOn | Off
ReferenceFrequencyOutput | Off
RFInputRanging | Auto
Timeout | 1000 s
uwPreselectorOff | On

Modulation Rate

Required Parameters

  • +ModulationFrequency 1
  • +ModulationFrequencyRatio 1,2
  • RatioReference 3
  • AMDepth | FMDeviation | PMDeviation
  • Frequency
  • Power
  1. Either ModulationFrequency or ModulationFrequencyRatio is required, but not both.
  2. ModulationFrequencyRatio is only allowed with the Read action and can only occur following a ModulationFrequency Measure statement.
  3. RatioReference is only required if the ModulationFrequencyRatio is specified.
Optional Parameters | Default
AverageCount | 25
AverageType | Off
BWMode | Auto
De-emphasis | Off
Detector | Peak+
ExternalReferenceFrequency | Internal
HPF | 20 Hz
IFBW | Auto
InputAttenuation | depends upon input signal
LPF | Off
PeakHoldOn | Off
PreamplifierOn | Off
ReferenceFrequencyOutput | Off
RFInputRanging | Auto
Timeout | 1000 s
uwPreselectorOff | On

Modulation Distortion

Required Parameters

  • +ModulationDistortion 1
  • +ModulationDistortionRatio 1,2
  • RatioReference 3
  • AMDepth | FMDeviation | PMDeviation
  • ModulationFrequency
  • Frequency
  • Power
  1. Either ModulationDistortion or ModulationDistortionRatio is required, but not both.
  2. ModulationDistortionRatio is only allowed with the Read action and can only occur following a ModulationDistortion Measure statement.
  3. RatioReference is only required if the ModulationDistortionRatio is specified.
Optional Parameters | Default
AverageCount | 25
AverageType | Off
BWMode | Auto
De-emphasis | Off
Detector | Peak+
ExternalReferenceFrequency | Internal
HPF | 20 Hz
IFBW | Auto
InputAttenuation | depends upon input signal
LPF | Off
PeakHoldOn | Off
PreamplifierOn | Off
ReferenceFrequencyOutput | Off
RFInputRanging | Auto
Timeout | 1000 s
uwPreselectorOff | On

Modulation SINAD

Required Parameters

  • +ModulationSINAD 1
  • +ModulationSINADRatio 1,2
  • RatioReference 3
  • AMDepth | FMDeviation | PMDeviation
  • ModulationFrequency
  • Frequency
  • Power
  1. Either ModulationSINAD or ModulationSINADRatio is required, but not both.
  2. ModulationSINADRatio is only allowed with the Read action and can only occur following a ModulationSINAD Measure statement.
  3. RatioReference is only required if the ModulationSINADRatio is specified.
Optional Parameters | Default
AverageCount | 25
AverageType | Off
BWMode | Auto
De-emphasis | Off
Detector | Peak+
ExternalReferenceFrequency | Internal
HPF | 20 Hz
IFBW | Auto
InputAttenuation | depends upon input signal
LPF | Off
PeakHoldOn | Off
PreamplifierOn | Off
ReferenceFrequencyOutput | Off
RFInputRanging | Auto
Timeout | 1000 s
uwPreselectorOff | On

Audio Frequency

Required Parameters

  • +AudioFrequency 1
  • +AudioFrequencyRatio 1,2
  • RatioReference 3
  • AudioACLevel
  1. Either AudioFrequency or AudioFrequencyRatio is required, but not both.
  2. AudioFrequencyRatio is only allowed with the Read action and can only occur following a AudioFrequency Measure statement.
  3. RatioReference is only required if the AudioFrequencyRatio is specified.
Optional Parameters | Default
AudioRange | R4
AverageCount | 25
AverageType | Off
ExternalReferenceFrequency | Internal
HPF | 20 Hz
LPF | Off
ReferenceFrequencyOutput | Off
Timeout | 1000 s

Audio AC Level

Required Parameters

  • +AudioACLevel 1
  • +AudioACLevelRatio 1,2
  • RatioReference 3
  • AudioFrequency
  1. Either AudioACLevel or AudioACLevelRatio is required, but not both.
  2. AudioACLevelRatio is only allowed with the Read action and can only occur following a AudioACLevel Measure statement.
  3. RatioReference is only required if the AudioACLevelRatio is specified.
Optional Parameters | Default
AudioRange | R4
AverageCount | 25
AverageType | Off
ExternalReferenceFrequency | Internal
HPF | 20 Hz
LPF | Off
ReferenceFrequencyOutput | Off
Timeout | 1000 s

Audio Distortion

Required Parameters

  • +AudioDistortion 1
  • +AudioDistortionRatio 1,2
  • RatioReference 3
  • AudioFrequency
  • AudioACLevel
  1. Either AudioDistortion or AudioDistortionRatio is required, but not both.
  2. AudioDistortionRatio is only allowed with the Read action and can only occur following a AudioDistortion Measure statement.
  3. RatioReference is only required if the AudioDistortionRatio is specified.
Optional Parameters | Default
AudioRange | R4
AverageCount | 25
AverageType | Off
ExternalReferenceFrequency | Internal
HPF | 20 Hz
LPF | Off
ReferenceFrequencyOutput | Off
Timeout | 1000 s

Audio SINAD

Required Parameters

  • +AudioSINAD 1
  • +AudioSINADRatio 1,2
  • RatioReference 3
  • AudioFrequency
  • AudioACLevel
  1. Either AudioSINAD or AudioSINADRatio is required, but not both.
  2. AudioSINADRatio is only allowed with the Read action and can only occur following a AudioSINAD Measure statement.
  3. RatioReference is only required if the AudioSINADRatio is specified.
Optional Parameters | Default
AudioRange | R4
AverageCount | 25
AverageType | Off
ExternalReferenceFrequency | Internal
HPF | 20 Hz
LPF | Off
ReferenceFrequencyOutput | Off
Timeout | 1000 s

Calibrate, Zero, Zero_and_Cal

Required Parameters

  • PowerMeter

Connect

Required Parameters

  • Input 1
Optional Parameters | Default
SensorModule | na
Frequency | na
  1. When Input = RF, Frequency is required.

Parameter Definitions and Values

AMDepth

This parameter specifies the expected AM modulation of the RF input signal. When this parameter is specified, it must be designated as the Evaluation Quantity. This automatically selects AM Depth measurement mode.

Syntax:

+AMDepth[sp]=[sp]value

value ::= numeric value[sp]units

units ::= percent | decibels

percent ::= %

decibels ::= [prefix]dB

Rules:

  1. When this parameter is specified, it must be specified as the Evaluation Quantity (i.e. +AMDepth).
  2. Legal values are:

Example:

+AMDepth = 30.0%

AMDepthRatio

This parameter specifies the expected AM modulation ratio. When this parameter is specified, it must be designated as the Evaluation Quantity. This automatically selects AM Depth measurement mode.

Syntax:

+AMDepthRatio[sp]=[sp]value

value ::= linear ratio | logarithmic ratio

linear ratio ::= numeric value%

logarithmic ratio ::= numeric value[sp][prefix]dB

Rules:

  1. When this parameter is specified, it must be specified as the Evaluation Quantity (i.e. +AMDepthRatio).
  2. When AMDepthRatio is specified in %, linear ratio mode is selected.
  3. When AMDepthRatio is specified in dB, log ratio mode is selected.
  4. Legal values are: tbd

Example:

+AMDepthRatio = tbd

AudioACLevel

This parameter specifies the expected level of the audio input signal. When this parameter is designated as the Evaluation Quantity, Audio AC Level measurement mode is selected.

Syntax:

[+|@]AudioACLevel[sp]=[sp]value

value ::= numeric value[sp][prefix]V

Rules:

  1. Audio AC Level measurement requires PSA Option 107 ("Audio Input").
  2. Legal values are: tbd

Example:

+AudioACLevel = tbd

AudioACLevelRatio

This parameter specifies the expected audio AC level ratio. When this parameter is specified, it must be designated as the Evaluation Quantity. This automatically selects Audio AC Level measurement mode.

Syntax:

+AudioACLevelRatio[sp]=[sp]value

value ::= linear ratio | logarithmic ratio

linear ratio ::= numeric value%

logarithmic ratio ::= numeric value[sp][prefix]dB

Rules:

  1. When this parameter is specified, it must be specified as the Evaluation Quantity (i.e. +AudioACLevelRatio).
  2. When AudioACLevelRatio is specified in %, linear ratio mode is selected.
  3. When AudioACLevelRatio is specified in dB, log ratio mode is selected.
  4. Legal values are: tbd

Example:

+AudioACLevelRatio = tbd

AudioDistortion

This parameter specifies the expected distortion of the audio input signal. When this parameter is specified, it must be designated as the Evaluation Quantity. This automatically selects Audio Distortion measurement mode.

Syntax:

+AudioDistortion[sp]=[sp]value

value ::= numeric value[sp]units

units ::= percent | decibels

percent ::= %

decibels ::= [prefix]dB

Rules:

  1. When this parameter is specified, it must be specified as the Evaluation Quantity (i.e. +AudioDist).
  2. Audio Distortion measurement requires PSA Option 107 ("Audio Input").
  3. Legal values are: tbd

Example:

+AudioDist = tbd

AudioDistortionRatio

This parameter specifies the expected audio distortion ratio. When this parameter is specified, it must be designated as the Evaluation Quantity. This automatically selects Audio Distortion measurement mode.

Syntax:

+AudioDistortionRatio[sp]=[sp]value

value ::= linear ratio | logarithmic ratio

linear ratio ::= numeric value%

logarithmic ratio ::= numeric value[sp][prefix]dB

Rules:

  1. When this parameter is specified, it must be specified as the Evaluation Quantity (i.e. +AudioDistortionRatio).
  2. When AudioDistortionRatio is specified in %, linear ratio mode is selected.
  3. When AudioDistortionRatio is specified in dB, log ratio mode is selected.
  4. Legal values are: tbd

Example:

+AudioDistortionRatio = tbd

AudioFrequency

This parameter specifies the expected frequency of the audio input signal. When this parameter is designated as the Evaluation Quantity, Audio Frequency measurement is selected.

Syntax:

[+|@]AudioFrequency[sp]=[sp]value

value ::= numeric value[sp][prefix]Hz

Rules:

  1. Audio Frequency measurement requires PSA Option 107 ("Audio Input").
  2. Legal values are: tbd

Example:

+AudioFreq = tbd

AudioFrequencyRatio

This parameter specifies the expected audio frequency ratio. When this parameter is specified, it must be designated as the Evaluation Quantity. This automatically selects Audio Frequency measurement mode.

Syntax:

+AudioFrequencyRatio[sp]=[sp]value

value ::= linear ratio | logarithmic ratio

linear ratio ::= numeric value%

logarithmic ratio ::= numeric value[sp][prefix]dB

Rules:

  1. When this parameter is specified, it must be specified as the Evaluation Quantity (i.e. +AudioFrequencyRatio).
  2. When AudioFrequencyRatio is specified in %, linear ratio mode is selected.
  3. When AudioFrequencyRatio is specified in dB, log ratio mode is selected.
  4. Legal values are: tbd

Example:

+AudioFrequencyRatio = tbd

AudioRange

This parameter sets the measurement range of the Audion Input (Option 107).

Syntax:

AudioRange[sp]=[sp]value

value ::= R0 | R1 | R2 | R3 | R4

Example:

AudioRange = R3

AudioSINAD

This parameter specifies the expected SINAD of the Audio input signal. When this parameter is specified, it must be designated as the Evaluation Quantity. This automatically selects Audio SINAD measurement mode.

Syntax:

+AudioSINAD[sp]=[sp]value

value ::= numeric value[sp]units

units ::= percent | decibels

percent ::= %

decibels ::= [prefix]dB

Rules:

  1. When this parameter is specified, it must be specified as the Evaluation Quantity (i.e. +AudioSINAD).
  2. Audio SINAD measurement requires PSA Option 107 ("Audio Input").
  3. Legal values are: tbd

Example:

+AudioSINAD = tbd

AudioSINADRatio

This parameter specifies the expected audio SINAD ratio. When this parameter is specified, it must be designated as the Evaluation Quantity. This automatically selects Audio SINAD measurement mode.

Syntax:

+AudioSINADRatio[sp]=[sp]value

value ::= linear ratio | logarithmic ratio

linear ratio ::= numeric value%

logarithmic ratio ::= numeric value[sp][prefix]dB

Rules:

  1. When this parameter is specified, it must be specified as the Evaluation Quantity (i.e. +AudioSINADRatio).
  2. When AudioSINADRatio is specified in %, linear ratio mode is selected.
  3. When AudioSINADRatio is specified in dB, log ratio mode is selected.
  4. Legal values are: tbd

Example:

+AudioSINADRatio = tbd

AutoTuneOff

This parameter turns off auto tuning frequency counter mode.

Syntax:

AutoTuneOff

Rules:

  1. When this is parameter is specified, the Frequency parameter value is used as the tune frequency.
  2. When this parameter is not specified, is auto tuning is used.

Examples:

Auto Tuning

+Freq = 100 MHz

Manual Tuning

+Freq = 100 MHz; AutoTuneOff

AverageAccuracy

This parameter sets the average accuracy.

Syntax:

AverageAccuracy[sp]=[sp]value

value ::= Normal | High

Rules:

  1. If not specified, the default is Normal.

Example:

AverageAcc = High

AverageCount

This parameter sets the average count.

Syntax:

AverageCount[sp]=[sp]nr1

Rules:

  1. Legal values are: 1 to 8192
  2. If not specified, the default value is 25.

Example:

AverageCount = 100

AverageType

This parameter sets the average type. When this parameter is not specified, the average type is set to off.

Syntax:

AverageType[sp]=[sp]value

value ::= Off | Normal | Exponential | PeakHold

Example:

AverageType = Norm

BWMode

This parameter sets the bandwidth mode. When this parameter is not specified, the bandwidth mode is set to auto.

Syntax:

BWMode[sp]=[sp]value

Operating Mode | value
AM Depth | Auto | Manual | Minimal
FM Deviation | Auto | Manual
Modulation Distortion | Auto | Manual | Minimal
Modulation Frequency | Auto | Manual | Minimal
Modulation SINAD | Auto | Manual | Minimal
PM Deviation | Auto | Manual

Example:

BWMode = Manual

Calibrate

This parameter causes a power meter calibration sequence to be performed.

Syntax:

Calibrate

Rules:

  1. When Calibrate is specified, PowerMeter must also be specified.

Examples:

Calibrate; PowerMeter

Connect

This parameter causes an automatic connection message to be generate when ASK+ W or ASK+ V is in effect. In addition, a connect statement will cause procedure header CONFIGURATION: lines to be generated, regardless of the state of the ASK W and ASK V flags.

Syntax:

Connect

Rules:

  1. When Connect is specified, Input must also be specified.
  2. When SensorModule is specified, Frequency must also be specified.

Examples:

Connect; Input = Audio

Connect; Input = RF; Freq = 10 MHz

Connect; Input = RF; Freq = 100 kHz; SensorModule = N5532A

Connect; Input = RF; Freq = 26.5 GHz; SensorModule = N5532A

Detector

This parameter sets the detector.

Syntax:

Detector[sp]=[sp]value

value ::= Peak+ | Peak- | Peak+-/2 | RMS

Rules:

  1. "Detector = RMS" is the only specification allowed for the following measurement modes.
    1. Audio AC Level
    2. Audio Distortion
    3. Audio Frequency
    4. Audio SINAD

Examples:

Detector = Peak+-/2

De-emphasis

This parameter sets the FM De-Emphasis.

Syntax:

De-emphasis[sp]=[sp]value

value ::= None | numeric value[sp][prefix]s

Rules:

  1. Legal values are: 25 us, 50 us, 75 us, & 750 us
  2. If not specified, the default value is off.

ExternalReferenceFrequency

This parameter enables external reference lock and sets the external frequency reference frequency. If this parameter is not specified, external frequency lock is disabled.

Syntax:

ExternalReferenceFrequency[sp]=[sp]value

value ::= numeric value[sp][prefix]Hz

Rules:

  1. Legal values are: 1 MHz to 30 MHz
  2. If not specified, internal frequency reference is used.

Example:

ExtRefFreq = 10 MHz

FMDeviation

This parameter specifies the expected FM modulation of the RF input signal. When this parameter is specified, it must be designated as the Evaluation Quantity. This automatically selects FM Deviation measurement mode.

Syntax:

+FMDeviation[sp]=[sp]value

value ::= numeric value[sp][prefix]Hz

Rules:

  1. When this parameter is specified, it must be specified as the Evaluation Quantity (i.e. +FMDeviation).
  2. Legal values are:

Example:

+FMDev = 5.00kHz

FMDeviationRatio

This parameter specifies the expected FM deviation ratio. When this parameter is specified, it must be designated as the Evaluation Quantity. This automatically selects FM Deviation measurement mode.

Syntax:

+FMDeviationRatio[sp]=[sp]value

value ::= linear ratio | logarithmic ratio

linear ratio ::= numeric value%

logarithmic ratio ::= numeric value[sp][prefix]dB

Rules:

  1. When this parameter is specified, it must be specified as the Evaluation Quantity (i.e. +FMDeviationRatio).
  2. When FMDeviationRatio is specified in %, linear ratio mode is selected.
  3. When FMDeviationRatio is specified in dB, log ratio mode is selected.
  4. Legal values are: tbd

Example:

+FMDeviationRatio = tbd

Frequency

This parameter specifies the expected frequency of the RF input signal. When this parameter is designated as the Evaluation Quantity, Frequency Counter measurement mode is selected.

Syntax:

[+|@]Frequency[sp]=[sp]value

value ::= numeric value[sp][prefix]Hz

Rules:

  1. For Tuned RF Level and all modulation modes, the frequency value is used to set the center frequency.
  2. Legal values are based on the PSA model and sensor module used:
    1. E4440A: 3 Hz to 26.5 GHz
    2. E4443A: 3 Hz to 6.76 GHz
    3. E4445A: 3 Hz to 13.2 GHz
    4. E4446A: 3 Hz to 44.5 GHz
    5. E4447A: 3 Hz to 42.98 GHz
    6. E4448A: 3 Hz to 51.0 GHz
    7. N5532A Option 504: 100 kHz to 4.2 GHz
    8. N5532A Option 518: 10 MHz to 18.0 GHz
    9. N5532A Option 526: 30 MHz to 26.5 GHz
    10. N5532A Option 550: 50 MHz to 50.0 GHz

Example:

+Freq = 120.0000MHz

FrequencyRatio

This parameter specifies the expected frequency ratio. When this parameter is specified, it must be designated as the Evaluation Quantity. This automatically selects Frequency Counter measurement mode.

Syntax:

+FrequencyRatio[sp]=[sp]value

value ::= linear ratio | logarithmic ratio

linear ratio ::= numeric value%

logarithmic ratio ::= numeric value[sp][prefix]dB

Rules:

  1. When this parameter is specified, it must be specified as the Evaluation Quantity (i.e. +FrequencyRatio).
  2. When FrequencyRatio is specified in %, linear ratio mode is selected.
  3. When FrequencyRatio is specified in dB, log ratio mode is selected.
  4. Legal values are: tbd

Example:

+FrequencyRatio = tbd

GateTime

This parameter disables auto gate time and sets the gate time over which frequency counter measures the signal. If this parameter is not specified , auto gate time is enabled.

Syntax:

GateTime[sp]=[sp]value

value ::= numeric value[sp][prefix]s

Rules:

  1. Legal values are:

HPF (High-pass Filter)

This parameter sets the high-pass frequency filter.

Syntax:

HPF[sp]=[sp]value

value ::= numeric value[sp][prefix]Hz

Rules:

  1. Legal values are: 20 Hz, 50 Hz, & 300 Hz.
  2. If not specified, the default value is 20 Hz.

IFBW (IF Bandwidth)

This parameter disables auto bandwidth mode and sets the IF bandwidth.

Syntax:

IFBW[sp]=[sp]value

value ::= numeric value[sp][prefix]Hz

Rules:

Mode | Legal Values | Default
AM Depth | 10 Hz to 1 MHz | 1 MHz
FM Deviation | 10 Hz to 1 MHz | 1 MHz
Modulation Distortion | 10 Hz to 1 MHz | 1 MHz
Modulation Rate | 10 Hz to 1 MHz | 1 MHz
Modulation SINAD | 10 Hz to 1 MHz | 1 MHz
PM Deviation | 10 Hz to 1 MHz | 1 MHz
Tuned RF Level | 10 and 75 Hz | 10 Hz

Example:

IFBW = 75 Hz

Input

This parameter sets the input for a Connect statement.

Syntax:

Input[sp]=[sp]value

value ::= Audio | RF

Example:

Input = RF

InputAttenuation

This parameter sets the RF input attenuation.

Syntax:

InputAttenuation[sp]=[sp]numeric value[sp][prefix]dB

Rules:

  1. Legal values are: 0 dB to 70 dB in whole (integer) steps.
  2. If not specified, the value depends upon the input signal.

Example:

InputAttenuation = 30 dB

LPF (Low-pass Filter)

This parameter sets the low-pass frequency filter.

Syntax:

LPF[sp]=[sp]numeric value[sp][prefix]Hz

Rules:

  1. Legal values are: 3 kHz, 15 kHz, 30 kHz, & 300 kHz.

Level

This parameter specifies the expected level of the RF input signal. When this parameter is specified, it must be designated as the Evaluation Quantity. This automatically selects Tuned RF Level measurement mode.

Syntax:

+Level[sp]=[sp]value

value ::= numeric value[sp][prefix]units

units ::= W | dBm | V

Rules:

  1. When this parameter is specified, it must be specified as the Evaluation Quantity.
  2. PSA Option 123 is required to perform Level measurements above 3 GHz.
  3. Legal values are:
    1. 500 kHz to 3.05 GHz
      1. -113 dBm to +30 dBm (without preamp, PSA Option 1DS)
      2. -129 dBm to +16 dBm (with preamp, PSA Option 1DS)
    2. 3.05 GHz to 6.6 GHz
      1. -113 dBm to +30 dBm
    3. 6.6 GHz to 13.2 GHz
      1. -104 dBm to +30 dBm
    4. 13.2 GHz to 19.2 GHz
      1. -93 dBm to +30 dBm
    5. 19.2 GHz to 26.5 GHz
      1. -85 dBm to +30 dBm

Example:

+Level = -10.00dBm

LevelRatio

This parameter specifies the expected level ratio. When this parameter is specified, it must be designated as the Evaluation Quantity. This automatically selects Tuned RF Level measurement mode.

Syntax:

+LevelRatio[sp]=[sp]value

value ::= linear ratio | logarithmic ratio

linear ratio ::= numeric value%

logarithmic ratio ::= numeric value[sp][prefix]dB

Rules:

  1. When this parameter is specified, it must be specified as the Evaluation Quantity (i.e. +LevelRatio).
  2. When LevelRatio is specified in %, linear ratio mode is selected.
  3. When LevelRatio is specified in dB, log ratio mode is selected.
  4. Legal values are: tbd

Example:

+LevelRatio = tbd

Local

This action puts the N5531S in local mode.

Syntax:

Local

Rules:

  1. When Local is specified, no other parameters may be specified.

Examples:

Local

Measure

This "Action" parameter causes the following:

  1. Setup the N5531S for measurement of the parameter designated as the Evaluation Quantity.
  2. Initiate the measurement.
  3. Return the reading in memory register MEM in units of the designated Nominal parameter value.

Syntax:

Measure

Rules:

  1. When Measure is specified, Setup must not be specified.
  2. When neither Measure or Setup is specified, Measure is assumed.

Examples:

N5531 ModFreq = 1 kHz; Power = 4 dBm; Measure
N5531 +FMDev = 5.000 kHz; Freq = [V FreqMHz] MHz

N5531 ModFreq = 1 kHz; Power = 4 dBm
N5531 +FMDev = 5.000 kHz; Freq = [V FreqMHz] MHz

ModulationDistortion

This parameter specifies the expected modulation distortion of the RF input signal. When this parameter is specified, it must be designated as the Evaluation Quantity. This automatically selects Modulation Distortion measurement mode.

Syntax:

+ModulationDistortion[sp]=[sp]value

value ::= numeric value[sp]units

units ::= percent | decibels

percent ::= %

decibels ::= [prefix]dB

Rules:

  1. When this parameter is specified, it must be specified as the Evaluation Quantity (i.e. +ModDist).
  2. Legal values are:
    1. -80 to 0 dB
    2. 0.01% to 100%

Example:

+ModDist = 1.0%

ModulationDistortionRatio

This parameter specifies the expected modulation distortion ratio. When this parameter is specified, it must be designated as the Evaluation Quantity. This automatically selects Modulation Distortion measurement mode.

Syntax:

+ModulationDistortionRatio[sp]=[sp]value

value ::= linear ratio | logarithmic ratio

linear ratio ::= numeric value%

logarithmic ratio ::= numeric value[sp][prefix]dB

Rules:

  1. When this parameter is specified, it must be specified as the Evaluation Quantity (i.e. +ModulationDistortionRatio).
  2. When ModulationDistortionRatio is specified in %, linear ratio mode is selected.
  3. When ModulationDistortionRatio is specified in dB, log ratio mode is selected.
  4. Legal values are: tbd

Example:

+ModulationDistortionRatio = tbd

ModulationSINAD

This parameter specifies the expected modulation SINAD of the RF input signal. When this parameter is specified, it must be designated as the Evaluation Quantity. This automatically selects Modulation SINAD measurement mode.

Syntax:

+ModulationSINAD[sp]=[sp]value

value ::= numeric value[sp]units

units ::= percent | decibels

percent ::= %

decibels ::= [prefix]dB

Rules:

  1. When this parameter is specified, it must be specified as the Evaluation Quantity (i.e. +ModSINAD).
  2. Legal values are: tbd

Example:

+ModSINAD = tbd

ModulationSINADRatio

This parameter specifies the expected modulation SINAD ratio. When this parameter is specified, it must be designated as the Evaluation Quantity. This automatically selects Modulation SINAD measurement mode.

Syntax:

+ModulationSINADRatio[sp]=[sp]value

value ::= linear ratio | logarithmic ratio

linear ratio ::= numeric value%

logarithmic ratio ::= numeric value[sp][prefix]dB

Rules:

  1. When this parameter is specified, it must be specified as the Evaluation Quantity (i.e. +ModulationSINADRatio).
  2. When ModulationSINADRatio is specified in %, linear ratio mode is selected.
  3. When ModulationSINADRatio is specified in dB, log ratio mode is selected.
  4. Legal values are: tbd

Example:

+ModulationSINADRatio =

ModulationFrequency

This parameter specifies the expected modulation frequency of the RF input signal. When this parameter is designated as the Evaluation Quantity, Modulation Rate measurement is selected.

Syntax:

[+|@]ModulationFrequency[sp]=[sp]value

value ::= numeric value[sp][prefix]Hz

Rules:

  1. Legal values are: 200 Hz to 300 kHz

Example:

+ModFreq = 400.0Hz

ModulationFrequencyRatio

This parameter specifies the expected modulation frequency ratio. When this parameter is specified, it must be designated as the Evaluation Quantity. This automatically selects Modulation Frequency measurement mode.

Syntax:

+ModulationFrequencyRatio[sp]=[sp]value

value ::= linear ratio | logarithmic ratio

linear ratio ::= numeric value%

logarithmic ratio ::= numeric value[sp][prefix]dB

Rules:

  1. When this parameter is specified, it must be specified as the Evaluation Quantity (i.e. +ModulationFrequencyRatio).
  2. When ModulationFrequencyRatio is specified in %, linear ratio mode is selected.
  3. When ModulationFrequencyRatio is specified in dB, log ratio mode is selected.
  4. Legal values are: tbd

Example:

+ModulationFrequencyRatio = tbd

PMDeviation

This parameter specifies the expected phase modulation of the RF input signal. When this parameter is specified, it must be designated as the Evaluation Quantity. This automatically selects PM Deviation measurement mode.

Syntax:

+PMDeviation[sp]=[sp]value

value ::= numeric value[sp][prefix]units

units ::= deg | rad

Rules:

  1. When this parameter is specified, it must be specified as the Evaluation Quantity (i.e. +PMDev).
  2. Legal values are:

Example:

+PMDev = 5.00rad

PMDeviationRatio

This parameter specifies the expected PM deviation ratio. When this parameter is specified, it must be designated as the Evaluation Quantity. This automatically selects PM Deviation measurement mode.

Syntax:

+PMDeviationRatio[sp]=[sp]value

value ::= linear ratio | logarithmic ratio

linear ratio ::= numeric value%

logarithmic ratio ::= numeric value[sp][prefix]dB

Rules:

  1. When this parameter is specified, it must be specified as the Evaluation Quantity (i.e. +PMDeviationRatio).
  2. When PMDeviationRatio is specified in %, linear ratio mode is selected.
  3. When PMDeviationRatio is specified in dB, log ratio mode is selected.
  4. Legal values are: tbd

Example:

+PMDeviationRatio = tbd

PeakHoldOn

This parameter turns the peak hold on.

Syntax:

PeakHoldOn

Rules:

  1. PeakHoldOn is only allowed when Detector = Peak+ or Peak-.
  2. When this parameter is not specified, the default is Off.

Example:

PeakHoldOn

Power

This parameter specifies the expected power of the RF input signal. When this parameter is designated as the Evaluation Quantity, Absolute RF Power measurement mode is selected.

Syntax:

[+|@]Power[sp]=[sp]value

value ::= numeric value[sp][prefix]units

units ::= dBm | W | V

Rules:

  1. The accompanying frequency or tuned frequency is dependent on the sensor module fitted as follows:
    1. N5532A Option 504: 100 kHz to 4.2 GHz
    2. N5532A Option 518: 10 MHz to 18.0 GHz
    3. N5532A Option 526: 30 MHz to 26.5 GHz
    4. N5532A Option 550: 50 MHz to 50.0 GHz
  2. Legal values are: -20 to +30 dBm

Examples:

+Power = -10.00 dBm

PowerMeter

This parameter qualifies the Calibrate and Zero action parameters.

Syntax:

PowerMeter

Rules:

  1. When PowerMeter is specified, Calibrate or Zero must also be specified.

Examples:

Calibrate; PowerMeter

-- or --

Zero; PowerMeter

PowerRatio

This parameter specifies the expected power ratio. When this parameter is specified, it must be designated as the Evaluation Quantity. This automatically selects Absolute RF Power measurement mode.

Syntax:

+PowerRatio[sp]=[sp]value

value ::= linear ratio | logarithmic ratio

linear ratio ::= numeric value%

logarithmic ratio ::= numeric value[sp][prefix]dB

Rules:

  1. When this parameter is specified, it must be specified as the Evaluation Quantity (i.e. +PowerRatio).
  2. When PowerRatio is specified in %, linear ratio mode is selected.
  3. When PowerRatio is specified in dB, log ratio mode is selected.
  4. Legal values are: tbd

Example:

+PowerRatio = tbd

PreamplifierOn

This parameter turns on the 100 kHz to 3 GHz internal preamplifier.

Syntax:

PreamplifierOn

Rules:

  1. When this parameter is not specified, the preamplifier is turned off.

Example:

PreamplifierOn

RBW

This parameter sets the resolution bandwidth used for frequency and tuned RF level measurement.

Syntax:

RBW[sp]=[sp]value

value ::= numeric value[sp][prefix]Hz

Rules:

  1. Legal values are: 1 Hz to 80 MHz
  2. If not specified, the default value is 100 Hz.

RFInputRanging

This parameter selects the RF input ranging.

Syntax:

RFInputRanging[sp]=[sp]value

value ::= Auto | Manual

Rules:

  1. If not specified, the default is RFInputRanging = Auto.

Example:

RFInputRanging = Manual

RangeHold

This parameter enables/disables range hold.

Syntax:

RangeHold[sp]=[sp]value

value ::= Off | On

Rules:

  1. If not specified, the default is Off.

RatioReference

This parameter sets the display mode to ratio and sets the ratio reference.

Syntax:

RatioReference[sp]=[sp]numeric value[sp][prefix]units

Rules:

  1. units must be same as the units of the evaluation quantity.

Example:

RatioReference = 1 GHz

ReferenceLevel

This parameter establishes the reference level necessary to calculate absolute tuned RF level accuracy when the input power is between minimum and the residual noise threshold.

Syntax:

ReferenceLevel[sp]=[sp]numeric value[sp][prefix]units

Rules:

  1. units must be same as the units of the evaluation quantity.

Example:

RefLevel = [V RefLvl]

Read

This "Action" parameter causes the following:

  1. Initiate the measurement.
  2. Return the reading in memory register MEM.

Syntax:

Read

Rules:

  1. A N5531 Measurement or Setup statement must precede a Read statement in the current test.
  2. The value in MEM is in units of the parameter designate as the Evaluation Quantity in the previous N5531 Measure or Setup statement.
  3. When Read is specified, no other parameters may be specified.

Examples:

N5531 ModFreq = 1 kHz; Power = 4 dBm; Read
N5531 +FMDev = 5.000 kHz; Freq = [V FreqMHz] MHz

ReferenceFrequencyOutput

This parameter enables the reference frequency output and sets the frequency to the value specified. If this parameter is not specified, the reference frequency output is disabled.

Syntax:

ReferenceFrequencyOutput[sp]=[sp]dim quan

dim quan ::= value[sp][prefix]Hz

value ::= numeric value | <register reference>

Rules:

  1. Legal values are: 10 MHz

Examples:

ReferenceFrequencyOutput = 10 MHz

RelativeLevel

This parameter specifies the expected relative tuned RF level measurement. When this parameter is specified, it must be designated as the Evaluation Quantity. This automatically selects Tuned RF Level measurement mode.

Syntax:

+RelativeLevel[sp]=[sp]value

value ::= numeric value[sp][prefix]dB

Rules:

  1. SetReference must be specified in a previous Tuned RF Level statement to establish the reference level for the relative level.
  2. When this parameter is specified, it must be specified as the Evaluation Quantity.
  3. PSA Option 123 is required to perform Level measurements above 3 GHz.
  4. Legal values are: tbd

Example:

+RelativeLevel = -3 dB

Reset

This parameter resets the instrument.

Syntax:

Reset

Rules:

  1. When Reset is specified, no other parameters are allowed.

Examples:

Reset

ResidualAM

This parameter specifies the expected residual AM of the RF input signal. When this parameter is specified, it must be designated as the Evaluation Quantity. This automatically selects AM Depth measurement mode.

Syntax:

+ResidualAM[sp]=[sp]value

value ::= numeric value[sp]units

units ::= percent | decibels

percent ::= %

decibels ::= [prefix]dB

Rules:

  1. When this parameter is specified, it must be specified as the Evaluation Quantity (i.e. +ResidualAM).
  2. Legal values are:

Example:

+ResidualAM = 0.0%

ResidualFM

This parameter specifies the expected residual FM of the RF input signal. When this parameter is specified, it must be designated as the Evaluation Quantity. This automatically selects FM Deviation measurement mode.

Syntax:

+ResidualFM[sp]=[sp]value

value ::= numeric value[sp]Hz

Rules:

  1. When this parameter is specified, it must be specified as the Evaluation Quantity (i.e. +ResidualFM).
  2. Legal values are:

Example:

+ResidualFM = 0.0 Hz

ResidualPM

This parameter specifies the expected residual PM of the RF input signal. When this parameter is specified, it must be designated as the Evaluation Quantity. This automatically selects PM Deviation measurement mode.

Syntax:

+ResidualPM[sp]=[sp]value

value ::= numeric value[sp][prefix]units

units ::= deg | rad

Rules:

  1. When this parameter is specified, it must be specified as the Evaluation Quantity (i.e. +ResidualPM).
  2. Legal values are:

Example:

+ResidualPM = 0.0 rad

SensorModule

This specifies the sensor module to be used for Absolute RF Power and Tuned RF Level measurement.

Syntax:

SensorModule[sp]=[sp]value

value ::= N5532A | N5532A-504 | N5532A-518 | N5532A-526 | N5532A-550

Rules:

  1. If not specified, the sensor module is based on required frequency and the sensor modules configured for the PSA.
  2. N5532A is only used for a Connect statements.

Example:

SensorModule = N5532A-526

SetReference

This parameter causes the current measurement to be used as the ratio reference.

Syntax:

SetReference

Example:

SetRef

Setup

This "Action" parameter sets up the N5531S for measurement of the parameter designated as the Evaluation Quantity.

Syntax:

Setup

Rules:

  1. No measurement is performed.
  2. A Read "Action" must be specified in a subsequent N5531 statement to cause a measurement to be performed and to obtain the reading.
  3. When Setup is specified, Measure must not be specified.

Examples:

N5531 ModFreq = 1 kHz; Power = 4 dBm; Setup
N5531 +FMDev = 5.000 kHz; Freq = [V FreqMHz] MHz

TimebaseAccuracyOff

This parameter is used when it is only desired to synchronize the PSA with the UUT, without an absolute accuracy determination.

Syntax:

TimebaseAccuracyOff

Examples:

TimebaseAccuracyOff

Timeout

This parameter specifies the measurement timeout.

Syntax:

Timeout[sp]=[sp]value

value ::= numeric value[sp][prefix]s

Rules:

  1. Legal values are: 100 ms to 1800 s

Example:

Timeout = 10 s

uwPreselectorOff

This parameter turns the microwave preselector off.

Syntax:

uwPreselectorOff

Rules:

  1. When this parameter is not specified the microwave preselector is turned on.

Example:

uwPreselectorOff

Zero

This parameter causes a power meter zero sequence to be performed.

Syntax:

Zero

Rules:

  1. When Zero is specified, PowerMeter must also be specified.

Examples:

Zero; PowerMeter

Zero_and_Cal

This parameter causes a power meter zero sequence to be performed, followed by the power meter calibration sequence.

Syntax:

Zero_and_Cal

Rules:

  1. When Zero_and_Cal is specified, PowerMeter must also be specified.

Examples:

Zero_and_Cal; PowerMeter

Examples

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON

# -----  Reset  -----

  1.001  N5531        Reset

# -----  Automatic Connection Message  -----

  1.002  MATH         CM(1, "RF OUTPUT")
  1.003  N5531        Connect; Input = RF
  1.003  N5531        SensorModule = N5532A; Freq = 4000 MHz

# -----  Frequency Counter  -----

# The Frequency Counter is used to tune the N5531S in the following examples.

# -----  Absolute RF Power and Tuned RF Level  -----

# First setup to 30 dB attenuation to prevent IF Overload.
  1.004  MATH         FreqMHz = 4000
  1.005  TARGET       -p
  1.006  SCPI         POW:AMPL 13DBM;:FREQ:CW 4000MHZ;:OUTP:STAT ON
  1.007  TARGET       -m
  1.008  N5531        ExtRefFreq = 10 MHz; TimebaseAccOff
  1.008  N5531        Freq = [V FreqMHz] MHz; SensorModule = Same
  1.008  N5531        +Power = 13 dBm; InputAtt = 30 dB
  1.009  MEMC   130   13.0dBm        1.0U

  2.001  SCPI         POW:AMPL 10DBM;:FREQ:CW 4000MHZ;:OUTP:STAT ON
  2.002  TARGET       -m
  2.003  N5531        ExtRefFreq = 10 MHz; TimebaseAccOff
  2.003  N5531        Freq = [V FreqMHz] MHz; SensorModule = Same
  2.003  N5531        +Power = 10 dBm; InputAtt = 30 dB
  2.004  MEMC   130   10.0dBm        1.0U

  3.001  SCPI         POW:AMPL 4DBM;:FREQ:CW 4000MHZ;:OUTP:STAT ON
  3.002  TARGET       -m
  3.003  N5531        ExtRefFreq = 10 MHz; TimebaseAccOff
  3.003  N5531        Freq = [V FreqMHz] MHz; SensorModule = Same
  3.003  N5531        +Power = 4 dBm; InputAtt = 20 dB
  3.004  MEMC   130   4.0dBm         1.0U

  4.001  SCPI         POW:AMPL -5.9DBM;:FREQ:CW 4000MHZ;:OUTP:STAT ON
  4.002  N5531        ExtRefFreq = 10 MHz; TimebaseAccOff
  4.002  N5531        Freq = [V FreqMHz] MHz; SensorModule = Same
  4.002  N5531        +Level = -5.9 dBm; Setup
  4.003  TARGET       -m
  4.004  N5531        ExtRefFreq = 10 MHz; TimebaseAccOff
  4.004  N5531        Freq = [V FreqMHz] MHz; SensorModule = Same
  4.004  N5531        +Level = -5.9 dBm; Read
  4.005  MEMC   130   -5.9dBm        1.0U

# Store reference level for accuracy calculation of the subsequent TRFL tests.
  5.001  MATH         RefLvl = MEM

  5.002  SCPI         POW:AMPL -15.9DBM;:FREQ:CW 4000MHZ;:OUTP:STAT ON
  5.003  TARGET       -m
  5.004  N5531        ExtRefFreq = 10 MHz; TimebaseAccOff
  5.004  N5531        Freq = [V FreqMHz] MHz; SensorModule = Same
  5.004  N5531        +Level = -15.9 dBm; RefLevel = [V RefLvl] dBm; Read
  5.005  MEMC   130   -15.9dBm       1.0U

  6.001  SCPI         POW:AMPL -25.9DBM;:FREQ:CW 4000MHZ;:OUTP:STAT ON
  6.002  TARGET       -m
  6.003  N5531        ExtRefFreq = 10 MHz; TimebaseAccOff
  6.003  N5531        Freq = [V FreqMHz] MHz; SensorModule = Same
  6.003  N5531        +Level = -25.9 dBm; RefLevel = [V RefLvl] dBm; Read
  6.004  MEMC   130   -25.9dBm       1.0U

  7.001  SCPI         POW:AMPL -35.9DBM;:FREQ:CW 4000MHZ;:OUTP:STAT ON
  7.002  TARGET       -m
  7.003  N5531        ExtRefFreq = 10 MHz; TimebaseAccOff
  7.003  N5531        Freq = [V FreqMHz] MHz; SensorModule = Same
  7.003  N5531        +Level = -35.9 dBm; RefLevel = [V RefLvl] dBm; Read
  7.004  MEMC   130   -35.9dBm       1.0U

  8.001  SCPI         POW:AMPL -45.9DBM;:FREQ:CW 4000MHZ;:OUTP:STAT ON
  8.002  TARGET       -m
  8.003  N5531        ExtRefFreq = 10 MHz; TimebaseAccOff
  8.003  N5531        Freq = [V FreqMHz] MHz; SensorModule = Same
  8.003  N5531        +Level = -45.9 dBm; RefLevel = [V RefLvl] dBm; Read
  8.004  MEMC   130   -45.9dBm       1.0U

  9.001  SCPI         POW:AMPL -55.9DBM;:FREQ:CW 4000MHZ;:OUTP:STAT ON
  9.002  TARGET       -m
  9.003  N5531        ExtRefFreq = 10 MHz; TimebaseAccOff
  9.003  N5531        Freq = [V FreqMHz] MHz; SensorModule = Same
  9.003  N5531        +Level = -55.9 dBm; RefLevel = [V RefLvl] dBm; Read
  9.004  MEMC   130   -55.9dBm       1.0U

 10.001  SCPI         POW:AMPL -65.9DBM;:FREQ:CW 4000MHZ;:OUTP:STAT ON
 10.002  TARGET       -m
 10.003  N5531        ExtRefFreq = 10 MHz; TimebaseAccOff
 10.003  N5531        Freq = [V FreqMHz] MHz; SensorModule = Same
 10.003  N5531        +Level = -65.9 dBm; RefLevel = [V RefLvl] dBm; Read
 10.004  MEMC   130   -65.9dBm       1.0U

 11.001  SCPI         POW:AMPL -75.9DBM;:FREQ:CW 4000MHZ;:OUTP:STAT ON
 11.002  TARGET       -m
 11.003  N5531        ExtRefFreq = 10 MHz; TimebaseAccOff
 11.003  N5531        Freq = [V FreqMHz] MHz; SensorModule = Same
 11.003  N5531        +Level = -75.9 dBm; RefLevel = [V RefLvl] dBm; Read
 11.004  MEMC   130   -75.9dBm       1.0U

 12.001  SCPI         POW:AMPL -85.9DBM;:FREQ:CW 4000MHZ;:OUTP:STAT ON
 12.002  TARGET       -m
 12.003  N5531        ExtRefFreq = 10 MHz; TimebaseAccOff
 12.003  N5531        Freq = [V FreqMHz] MHz; SensorModule = Same
 12.003  N5531        +Level = -85.9 dBm; RefLevel = [V RefLvl] dBm; Read
 12.004  MEMC   130   -85.9dBm       1.0U

 13.001  SCPI         POW:AMPL -95.9DBM;:FREQ:CW 4000MHZ;:OUTP:STAT ON
 13.002  TARGET       -m
 13.003  N5531        ExtRefFreq = 10 MHz; TimebaseAccOff
 13.003  N5531        Freq = [V FreqMHz] MHz; SensorModule = Same
 13.003  N5531        +Level = -95.9 dBm; RefLevel = [V RefLvl] dBm; Read
 13.004  MEMC   130   -95.9dBm       1.0U

 14.001  SCPI         POW:AMPL -96DBM;:FREQ:CW 4000MHZ;:OUTP:STAT ON
 14.002  TARGET       -m
 14.003  N5531        ExtRefFreq = 10 MHz; TimebaseAccOff
 14.003  N5531        Freq = [V FreqMHz] MHz; SensorModule = Same
 14.003  N5531        +Level = -96 dBm; RefLevel = [V RefLvl] dBm; Read
 14.004  MEMC   130   -96.0dBm       1.0U

 15.001  SCPI         POW:AMPL -105.9DBM;:FREQ:CW 4000MHZ
 15.002  SCPI         OUTP:STAT ON
 15.003  TARGET       -m
 15.004  N5531        ExtRefFreq = 10 MHz; TimebaseAccOff
 15.004  N5531        Freq = [V FreqMHz] MHz; SensorModule = Same
 15.004  N5531        +Level = -105.9 dBm; RefLevel = [V RefLvl] dBm; Read
 15.005  MEMC   130   -105.9dBm      1.0U

 16.001  SCPI         POW:AMPL -106DBM;:FREQ:CW 4000MHZ;:OUTP:STAT ON
 16.002  TARGET       -m
 16.003  N5531        ExtRefFreq = 10 MHz; TimebaseAccOff
 16.003  N5531        Freq = [V FreqMHz] MHz; SensorModule = Same
 16.003  N5531        +Level = -106 dBm; RefLevel = [V RefLvl] dBm; Read
 16.004  MEMC   130   -106.0dBm      1.0U

 17.001  SCPI         POW:AMPL -115.9DBM;:FREQ:CW 4000MHZ
 17.002  SCPI         OUTP:STAT ON
 17.003  TARGET       -m
 17.004  N5531        ExtRefFreq = 10 MHz; TimebaseAccOff
 17.004  N5531        Freq = [V FreqMHz] MHz; SensorModule = Same
 17.004  N5531        +Level = -115.9 dBm; RefLevel = [V RefLvl] dBm; Read
 17.005  MEMC   130   -115.9dBm      1.0U

 18.001  SCPI         POW:AMPL -116DBM;:FREQ:CW 4000MHZ;:OUTP:STAT ON
 18.002  TARGET       -m
 18.003  N5531        ExtRefFreq = 10 MHz; TimebaseAccOff
 18.003  N5531        Freq = [V FreqMHz] MHz; SensorModule = Same
 18.003  N5531        +Level = -116 dBm; RefLevel = [V RefLvl] dBm; Read
 18.004  MEMC   130   -116.0dBm      1.0U

 19.001  SCPI         POW:AMPL -125.9DBM;:FREQ:CW 4000MHZ
 19.002  SCPI         OUTP:STAT ON
 19.003  TARGET       -m
 19.004  N5531        ExtRefFreq = 10 MHz; TimebaseAccOff
 19.004  N5531        Freq = [V FreqMHz] MHz; SensorModule = Same
 19.004  N5531        +Level = -125.9 dBm; RefLevel = [V RefLvl] dBm; Read
 19.005  MEMC   130   -125.9dBm      1.0U

 20.001  SCPI         POW:AMPL -126DBM;:FREQ:CW 4000MHZ;:OUTP:STAT ON
 20.002  TARGET       -m
 20.003  N5531        ExtRefFreq = 10 MHz; TimebaseAccOff
 20.003  N5531        Freq = [V FreqMHz] MHz; SensorModule = Same
 20.003  N5531        +Level = -126 dBm; RefLevel = [V RefLvl] dBm; Read
 20.004  MEMC   130   -126.0dBm      1.0U

 21.001  SCPI         POW:AMPL -127DBM;:FREQ:CW 4000MHZ;:OUTP:STAT ON
 21.002  TARGET       -m
 21.003  N5531        ExtRefFreq = 10 MHz; TimebaseAccOff
 21.003  N5531        Freq = [V FreqMHz] MHz; SensorModule = Same
 21.003  N5531        +Level = -127 dBm; RefLevel = [V RefLvl] dBm; Read
 21.004  MEMC   130   -127.0dBm      1.0U

# -----  AM Depth  -----

 22.001  TSET         TDESC = AM Depth: 10%
 22.002  TARGET       -p
 22.003  N5531        ExtRefFreq = 10 MHz; TimebaseAccOff
 22.003  N5531        Power = -6 dBm; InputAtt = 10 dB
 22.003  N5531        +Freq = 1000 MHz; Setup
 22.004  SCPI         FREQ:CW 1000MHZ;:AM:DEPT 10 PCT;:AM:SOUR INT
 22.005  SCPI         AM:INT:FREQ 1 KHZ;:AM:STAT ON
 22.006  SCPI         POW:AMPL -6DBM;:OUTP:STAT ON
 22.007  N5531        ExtRefFreq = 10 MHz; TimebaseAccOff
 22.007  N5531        Power = -6 dBm; InputAtt = 10 dB
 22.007  N5531        +Freq = 1000 MHz; Read
 22.008  MATH         FreqMHz = MEM
 22.009  TARGET       -m
 22.010  N5531        ExtRefFreq = 10 MHz; TimebaseAccOff
 22.010  N5531        HPF = 300 Hz; LPF = 15 kHz; BWMode = Man; IFBW = 1 MHz
 22.010  N5531        Power = -6 dBm; InputAtt = 10 dB
 22.010  N5531        Freq = [V FreqMHz] MHz; ModFreq = 1 kHz
 22.010  N5531        +AMDepth = 10.0 %;
 22.011  MEMC         10.0pct        2.0U

# -----  FM Deviation  -----

 23.001  TSET         TDESC = FM Deviation: 5 kHz
 23.002  TARGET       -p
 23.003  N5531        ExtRefFreq = 10 MHz; TimebaseAccOff
 23.003  N5531        Power = 4 dBm; InputAtt = 20 dB
 23.003  N5531        +Freq = 1500 MHz; Setup
 23.004  SCPI         FREQ:CW 1500MHZ;:FM:DEV 5 KHZ;:FM:SOUR INT
 23.005  SCPI         FM:INT:FREQ 1 KHZ;:FM:STAT ON
 23.006  SCPI         POW:AMPL 4 DBM;:OUTP:STAT ON
 23.007  N5531        ExtRefFreq = 10 MHz; TimebaseAccOff
 23.007  N5531        Power = 4 dBm; InputAtt = 20 dB
 23.007  N5531        +Freq = 1500 MHz; Read
 23.008  MATH         FreqMHz = MEM
 23.009  TARGET       -m
 23.010  N5531        ExtRefFreq = 10 MHz; TimebaseAccOff
 23.010  N5531        HPF = 300 Hz; LPF = 15 kHz
 23.010  N5531        ModFreq = 1 kHz; Power = 4 dBm; InputAtt = 20 dB;
 23.010  N5531        +FMDev = 5.000 kHz; Freq = [V FreqMHz] MHz
 23.011  MEMC         5.000kH        0.210U

# -----  Modulation Distortion (AM)  -----

 24.001  TSET         TDESC = AM Depth: 30%
 24.002  TARGET       -p
 24.003  N5531        ExtRefFreq = 10 MHz; TimebaseAccOff
 24.003  N5531        Power = +4 dBm; InputAtt = [V @AttndB] dB
 24.003  N5531        +Freq = 400 MHz; Setup
 24.004  SCPI         FREQ:CW 400MHZ;:AM:DEPT 30 PCT;:AM:SOUR INT
 24.005  SCPI         AM:INT:FREQ 1 KHZ;:AM:STAT ON
 24.006  SCPI         POW:AMPL +4DBM;:OUTP:STAT ON
 24.007  N5531        ExtRefFreq = 10 MHz; TimebaseAccOff
 24.007  N5531        Power = +4 dBm; InputAtt = [V @AttndB] dB
 24.007  N5531        +Freq = 400 MHz; Read
 24.008  MATH         FreqMHz = MEM
 24.009  TARGET       -m
 24.010  N5531        ExtRefFreq = 10 MHz; TimebaseAccOff
 24.010  N5531        HPF = 300 Hz; LPF = 15 kHz
 24.010  N5531        Power = -6 dBm; InputAtt = [V @AttndB] dB
 24.010  N5531        Freq = [V FreqMHz] MHz; ModFreq = 1 kHz;
 24.010  N5531        +ModDist = 0 %; AMDepth = 30 %
 24.011  MEMC         0.00pct        -2.00U

# -----  Audio Frequency  -----

 25.001  N5531        +AudioFreq = 400 Hz; AudioACLevel = 1 V; Setup
 25.002  IEEE         [SDC]FR100KZAP+7DMAM50PCS2
 25.003  TARGET       -m
 25.004  N5531        +AudioFreq = 400 Hz; AudioACLevel = 1 V; Read
 25.005  MEMC   1000  400H           2%

# -----  Power Ratio (%)  -----

 26.001  SCPI         INST SINE;:POW -10;:FREQ 50E+6;:OUTP ON
# Get tune frequency for subsequent measurements at 50 MHz.
 26.002  N5531        SensorModule = Same
 26.002  N5531        +Freq = 50 MHz; Power = -10 dBm
 26.003  MATH         Freq = MEM
 26.004  N5531        SensorModule = Same
 26.004  N5531        +Power = -10 dBm; Freq = [V Freq] MHz
 26.005  MATH         Ref = MEM
 26.006  SCPI         INST SINE;:POW -7;:FREQ 50E+6;:OUTP ON
 26.007  N5531        Freq = [V Freq] MHz; SensorModule = Same
 26.007  N5531        +PowerRatio = 199.5 %; RatioRef = [V Ref] dBm; Read
 26.008  MEMC         199.5pct       3.0U

# -----  Power Ratio (dB)  -----

 27.001  SCPI         INST SINE;:POW -10;:FREQ 50E+6;:OUTP ON
 27.002  N5531        SensorModule = Same
 27.002  N5531        +Power = -10 dBm; Freq = [V Freq] MHz
 27.003  MATH         Ref = MEM
 27.004  SCPI         INST SINE;:POW +10;:FREQ 50E+6;:OUTP ON
 27.005  N5531        Freq = [V Freq] MHz; SensorModule = Same
 27.005  N5531        +PowerRatio = 20.0 dB; RatioRef = [V Ref] dBm; Read
 27.006  MEMC         20.0dB         0.1U

# -----  Tuned RF Level Ratio (dB)  -----

 28.001  SCPI         INST SINE;:POW -5;:FREQ 50E+6;:OUTP ON
 28.002  N5531        SensorModule = Same
 28.002  N5531        +Level = -5 dBm; Freq = [V Freq] MHz
 28.003  MATH         Ref = MEM
 28.004  SCPI         INST SINE;:POW -40;:FREQ 50E+6;:OUTP ON
 28.005  N5531        Freq = [V Freq] MHz; SensorModule = Same
 28.005  N5531        +LevelRatio = -35.0 dB; RatioRef = [V Ref] dBm; Read
 28.006  MEMC         -35.0dB        0.1U

# -----  Frequency Ratio (%)  -----

 29.001  SCPI         INST SINE;:FREQ 100E+6;:POW -10;:OUTP ON
# Get tune frequency for subsequent measurements at 100 MHz.
 29.002  N5531        SensorModule = Same
 29.002  N5531        +Freq = 100 MHz; Power = -10 dBm
 29.003  MATH         Freq = MEM
 29.004  SCPI         INST SINE;:FREQ 10E+6;:POW -10;:OUTP ON
 29.005  N5531        Power = -10 dBm; SensorModule = Same
 29.005  N5531        +FreqRatio = 10.000 %; RatioRef = [V Freq] MHz; Read
 29.006  MEMC         10.000pct      0.001U

# -----  AM Depth Ratio (%)  -----

 30.001  SCPI         INST AM;:AM:INT:FREQ 400;:AM:DEPT 80;STAT ON
 30.002  SCPI         FREQ 100E+6;:POW -10;:OUTP ON
 30.003  N5531        Freq = [V Freq] MHz; Power = -10 dBm
 30.003  N5531        +AMDepth = 80 %; ModFreq = 400 Hz
 30.004  MATH         Ref = MEM
 30.005  SCPI         INST AM;:AM:INT:FREQ 400;:AM:DEPT 20;STAT ON
 30.006  SCPI         FREQ 100E+6;:POW -10;:OUTP ON
 30.007  N5531        Freq = [V Freq] MHz; Power = -10 dBm; ModFreq = 400 Hz
 30.007  N5531        +AMDepthRatio = 25.0 %; RatioRef = [V Ref] %; Read
 30.008  MEMC         25.0pct        0.1U

# -----  FM Deviation Ratio (%)  -----

 31.001  SCPI         INST FM;:FM:INT:FREQ 1E+3;:FM:DEV 40E+3;STAT ON
 31.002  SCPI         FREQ 100E+6;:POW -10;:OUTP ON
 31.003  N5531        Freq = [V Freq] MHz; Power = -10 dBm
 31.003  N5531        +FMDev = 40 kHz; ModFreq = 1 kHz
 31.004  MATH         Ref = MEM
 31.005  SCPI         INST FM;:FM:INT:FREQ 1E+3;:FM:DEV 8E+3;STAT ON
 31.006  SCPI         FREQ 100E+6;:POW -10;:OUTP ON
 31.007  N5531        Freq = [V Freq] MHz; Power = -10 dBm; ModFreq = 1 kHz
 31.007  N5531        +FMDevRatio = 20.0 %; RatioRef = [V Ref] kHz; Read
 31.008  MEMC         20.0pct        0.1U

# -----  PM Deviation Ratio (dB)  -----

 32.001  SCPI         INST PM;:PM:INT:FREQ 1E+3;:PM:DEV 10;STAT ON
 32.002  SCPI         FREQ 1E+9;:POW -10;:OUTP ON
# Get tune frequency for subsequent measurements at 1 GHz.
 32.003  N5531        +Freq = 1 GHz; Power = -10 dBm
 32.004  MATH         Freq = MEM
 32.005  N5531        Freq = [V Freq] GHz; Power = -10 dBm
 32.005  N5531        +PMDev = 10 rad; ModFreq = 1 kHz
 32.006  MATH         Ref = MEM
 32.007  SCPI         INST PM;:PM:INT:FREQ 1E+3;:PM:DEV 1000;STAT ON
 32.008  SCPI         FREQ 1E+9;:POW -10;:OUTP ON
 32.009  N5531        Freq = [V Freq] GHz; Power = -10 dBm; ModFreq = 400 Hz
 32.009  N5531        +PMDevRatio = 40.0 dB; RatioRef = [V Ref] rad; Read
 32.010  MEMC         40.0dB         0.1U

# -----  Modulation Frequency (Rate) Ratio (%)  -----

 33.001  SCPI         INST AM;:AM:INT:FREQ 400;:AM:DEPT 20;STAT ON
 33.002  SCPI         FREQ 100E+6;:POW -10;:OUTP ON
# Get tune frequency for subsequent measurements at 100 MHz.
 33.003  N5531        +Freq = 100 MHz; Power = -10 dBm
 33.004  MATH         Freq = MEM
 33.005  N5531        Freq = [V Freq] MHz; Power = -10 dBm
 33.005  N5531        +ModFreq = 400 Hz; AMDepth = 20 %
 33.006  MATH         Ref = MEM
 33.007  SCPI         INST AM;:AM:INT:FREQ 1E+3;:AM:DEPT 20;STAT ON
 33.008  SCPI         FREQ 100E+6;:POW -10;:OUTP ON
 33.009  N5531        Freq = [V Freq] MHz; Power = -10 dBm
 33.009  N5531        AMDepth = 20 %
 33.009  N5531        +ModFreqRatio = 250.000 %; RatioRef = [V Ref] Hz; Read
 33.010  MEMC         250.000pct     0.001U

# -----  Modulation Frequency (Rate) Ratio (dB)  -----

 34.001  SCPI         INST FM;:FM:INT:FREQ 400;:FM:DEV 10E+3;STAT ON
 34.002  SCPI         FREQ 100E+6;:POW -10;:OUTP ON
 34.003  N5531        Freq = [V Freq] MHz; Power = -10 dBm
 34.003  N5531        +ModFreq = 400 Hz; FMDev = 10 kHz
 34.004  MATH         Ref = MEM
 34.005  SCPI         INST FM;:FM:INT:FREQ 1000;:FM:DEV 10E+3;STAT ON
 34.006  SCPI         FREQ 100E+6;:POW -10;:OUTP ON
 34.007  N5531        Freq = [V Freq] MHz; Power = -10 dBm
 34.007  N5531        FMDev = 10 kHz
 34.007  N5531        +ModFreqRatio = 8.0 dB; RatioRef = [V Ref] Hz; Read
 34.008  MEMC         8.0dB          0.1U

# -----  Modulation Distortion Ratio (%)  -----

 35.001  SCPI         INST AM;:AM:INT:FREQ 400;:AM:DEPT 20;STAT ON
 35.002  SCPI         FREQ 100E+6;:POW -10;:OUTP ON
 35.003  N5531        Freq = [V Freq] MHz; Power = -10 dBm
 35.003  N5531        +ModDist = 0 %; ModFreq = 400 Hz; AMDepth = 20 %
 35.004  MATH         Ref = MEM
 35.005  SCPI         INST AM;:AM:INT:FREQ 400;:AM:DEPT 20;STAT ON
 35.006  SCPI         FREQ 1E+9;:POW -10;:OUTP ON
# Get tune frequency for distortion measurement at 1 GHz.
 35.007  N5531        +Freq = 1 GHz; Power = -10 dBm
 35.008  N5531        Freq = [MEM] GHz; Power = -10 dBm
 35.008  N5531        ModFreq = 400 Hz; AMDepth = 20 %
 35.008  N5531        +ModDistRatio = 75.0 %; RatioRef = [V Ref] %; Read
 35.009  MEMC         80.0pct        10U

# -----  Modulation SINAD Ratio (dB)  -----

 36.001  SCPI         INST AM;:AM:INT:FREQ 400;:AM:DEPT 20;STAT ON
 36.002  SCPI         FREQ 100E+6;:POW -10;:OUTP ON
# Get tune frequency for SINAD measurement at 100 MHz.
 36.003  N5531        +Freq = 10 MHz; Power = -10 dBm
 36.004  N5531        Freq = [MEM] MHz; Power = -10 dBm
 36.004  N5531        +ModSINAD = 0 dB; ModFreq = 400 Hz; AMDepth = 20 %
 36.005  MATH         Ref = MEM
 36.006  SCPI         INST AM;:AM:INT:FREQ 400;:AM:DEPT 20;STAT ON
 36.007  SCPI         FREQ 1E+9;:POW -10;:OUTP ON
# Get tune frequency for SINAD measurement at 1 GHz.
 36.008  N5531        +Freq = 1 GHz; Power = -10 dBm
 36.009  N5531        Freq = [MEM] GHz; Power = -10 dBm
 36.009  N5531        ModFreq = 400 Hz; AMDepth = 20 %
 36.009  N5531        +ModSINADRatio = 0 dB; RatioRef = [V Ref] dB; Read
 36.010  MEMC         0dB            5U

# -----  Audio Frequency Ratio (%)  -----

 37.001  IEEE2        OUT 1V,400Hz;OPER
 37.002  N5531        +AudioFreq = 400 Hz; AudioACLevel = 1 V
 37.003  MATH         Ref = MEM
 37.004  IEEE2        OUT 1V,1kHz;OPER
 37.005  N5531        AudioACLevel = 1 V
 37.005  N5531        +AudioFreqRatio = 250.000 %; RatioRef = [V Ref] Hz; Read
 37.006  MEMC         250.000pct     0.001U

# -----  Audio AC Level Ratio (%)  -----

 38.001  IEEE2        OUT 1V,400Hz;OPER
 38.002  N5531        +AudioACLevel = 1 V; AudioFreq = 400 Hz
 38.003  MATH         Ref = MEM
 38.004  IEEE2        OUT 0.5V,400Hz;OPER
 38.005  N5531        AudioFreq = 400 Hz
 38.005  N5531        +AudioACLevelRatio = 50 %; RatioRef = [V Ref] V; Read
 38.006  MEMC         50.0pct        0.1U

# -----  Audio Distortion Ratio (dB)  -----

 39.001  IEEE2        OUT 1V,400Hz;OPER
 39.002  N5531        AudioACLevel = 1 V; AudioFreq = 400 Hz
 39.002  N5531        +AudioDistortion = 0.01 %
 39.003  MATH         Ref = MEM
 39.004  IEEE2        OUT 0.5V,1kHz;OPER
 39.005  N5531        AudioACLevel = 1 V; AudioFreq = 1 kHz
 39.005  N5531        +AudioDistortionRatio = 1 dB; RatioRef = [V Ref] %; Read
 39.006  MEMC         2.5dB          1.0U

# -----  Audio SINAD Ratio (dB)  -----

 40.001  IEEE2        OUT 1V,1kHz;OPER
 40.002  N5531        AudioACLevel = 1 V; AudioFreq = 1 kHz
 40.002  N5531        +AudioSINAD = 0 dB
 40.003  MATH         Ref = MEM
 40.004  IEEE2        OUT 0.5V,400Hz;OPER
 40.005  N5531        AudioACLevel = 1 V; AudioFreq = 400 Hz
 40.005  N5531        +AudioSINADRatio = 1 dB; RatioRef = [V Ref] dB; Read
 40.006  MEMC         -4.5dB         1.0U


2000

Instrument FSC

Description

The 2000 FSC programs the Keithley 2000 Multimeter to measure DC voltage, AC voltage, DC current, AC current, resistance, conductance, frequency, period, and temperature.

If the 2000 is to be controlled via its serial port, do not use the PORT FSC port configuration special construction, [P9600,N,...], to set the baud rate, parity, etc. of the port used to control the 2000. MET/CAL executes a "Test" function for each System

Instrument prior to executing any procedure statements, therefore the settings of the port used to controlling the 2000 must be set correctly before a procedure is executed. If the 2000 is connected to a standard serial port (COM1, COM2, ..., COM16) select the "Ports" application in the Windows control panel to choose the proper settings. If the 2000 is connected to the 5500A, 5520A, or 5800A UUT port, select the proper settings for the UUT Serial Port from the front panel of the calibrator.

Functional Capability

Function | NOMINAL | MOD1 | MOD2
DC Voltage | -1000 V to 1000 V
AC Voltage 1 | 0.1 mV to 750 V | 3 Hz to 300 kHz
DC Current | -3 A to 3 A
AC Current | 1 μA to 3 A | 3 Hz to 5 kHz
Resistance | 0 Ω to 119.9999 MΩ
Conductance | >8.4 nS
Frequency | 3 Hz to 300 kHz | 100 mV to 750 V
Period | 3.3 μs to 0.33 s | 100 mV to 750 V
dBm 1 | -66.98 dBm to 70.51 dBm | 3 Hz to 300 kHz | 5Z
dBm 1 | -68.75 dBm to 68.75 dBm | 3 Hz to 300 kHz | 7Z
dBm 1 | -74.77 dBm to 62.73 dBm | 3 Hz to 300 kHz | 3Z
dBm 1 | -77.78 dBm to 59.71 dBm | 3 Hz to 300 kHz | 6Z
Temperature 2
Type J TC | -200 degC to 760 degC | _J
Type K TC | -200 degC to 1372 degC | _K
Type T TC | -200 degC to 400 degC | _T
  1. Volt-Hertz product not to exceed 8e7.
  2. Temperature measurement requires 2001-TCSCAN card.

Parameters

RANGE

This field specifies the UUT range as described in the RANGE Field topic.

NOMINAL

This field specifies the expected measured value or a

reset.

  • Voltage (DC or RMS) entered as: [numeric][prefix]V
  • dBm entered as: [numeric][prefix]D
  • Current entered as [numeric][prefix]A.
  • Resistance entered as [numeric][prefix]Z.
  • Conductance entered as [numeric][prefix]Y.
  • Frequency entered as [numeric][prefix]H.
  • Period entered as [numeric][prefix]T.
  • Temperature entered as: [numeric][prefix]degC or degF
  • Reset entered as *.

Rules:

  • The NOMINAL field may specify decibels only when the MOD2 field specifies the reference impedance.
  • The NOMINAL field may specify temperature only when the MOD2 field specifies a thermocouple type.

TOLERANCE

This field specifies the UUT tolerance as described in the TOLERANCE Field topic.

MOD1

This field specifies frequency for AC voltage and AC current measurements or voltage for frequency or period measurements.

  • Frequency entered as [numeric][prefix]H.
  • Voltage entered as [numeric][prefix]V.
  • blank

Rules:

  • The MOD1 field must be blank when the NOMINAL field specifies resistance, conductance, or temperature.
  • The MOD1 field may specify frequency only when the NOMINAL field specifies voltage or current.
  • The MOD1 field must specify voltage when the NOMINAL field specifies frequency or period.

MOD2

This field specifies the load impedance that the AC voltage is referenced to for decibels or the RTD or thermocouple type for temperature measurement.

5Z | 50 Ω
7Z | 75 Ω
3Z | 300 Ω
6Z | 600 Ω
_J | Type J thermocouple
_K | Type K thermocouple
_T | Type T thermocouple
blank | field not applicable

Rules:

  • The MOD2 field may specify a reference impedance only when the NOMINAL field specifies decibels.
  • The MOD2 field may specify a RTD or thermocouple only when the NOMINAL field specifies temperature.

MOD3

This field is not used

MOD4

This field specifies the type of test being performed as described in the MOD4 Field topic.

CON

This field specifies the UUT connection.

2W | 2-wire
4W | 4-wire

Rules:

  • The CON field may specify a 4W only when the NOMINAL field specifies resistance or conductance.

Use of Standard Memory Locations and Results Reporting

System memory locations MEM and MEM1 are used. For more information, refer to the Use of Standard Memory Registers topic.

Examples

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
# -----  Reset  -----
  1.001  2000         *                                                 S
# -----  DC Voltage  -----
  1.002  2000   10    10V            1% 0.01U                              2W
# -----  AC Voltage  -----
  2.001  2000   1000  650V           5%            30kH                    2W
  3.001  2000   1     1V             1% 0.01U      10kH                    2W
# -----  dBm  -----
  4.001  2000   A     60.0D          0.1U          1kH            5Z       2W
# -----  DC Current  -----
  5.001  2000   4000  350mA          9U                                    2W
# -----  AC Current  -----
  6.001  2000   2     1A             3%            60H                     2W
# -----  Resistance  -----
  7.001  2000   100   10MZ           1%                                    2W
# -----  Conductance  -----
  8.001  2000   100   100nY          5%                                    2W
# -----  Setup Test  -----
  9.001  2000         1V                           10kH                 S  2W
# -----  Nominal Setup Test  -----
  9.002  2000   1     1V                           10kH                 N  2W
# -----  Comparison Test  -----
  9.003  2000   1     1V             1% 0.1U       20kH                 C  2W


2001

Instrument FSC

Description

The 2001 FSC programs the Keithley 2001 Multimeter to measure DC voltage, AC voltage, DC current, AC current, resistance, conductance, frequency, and temperature.

Functional Capability

Function | NOMINAL | MOD1 | MOD2
DC Voltage | -1100 V to 1100 V
AC Voltage 1 | 100 nV to 775 V | 1 Hz to 2 MHz
AC Coupling | >200 Hz
AC+DC Coupling | >200 Hz
DC Current | -2.1 A to 2.1 A
AC Current | 100 pA to 2.1 A | 1 Hz to 100 kHz
Resistance | 0 Ω to 1.05 GΩ
Conductance | >952400 nS
Frequency 1 | 1 Hz to 5 MHz | 60m V to 775 V
5 MHz to 15 MHz | 350 mV to 775 V
1 Hz to 5 MHz | 150 μA to 2.1 A
dBm 1 | -126.9 dBm to 70.79 dBm | 1 Hz to 2 MHz | 5Z
-128.7 dBm to 69.03 dBm | 1 Hz to 2 MHz | 7Z
-134.7 dBm to 63.01 dBm | 1 Hz to 2 MHz | 3Z
-137.7 dBm to 60.00 dBm | 1 Hz to 2 MHz | 6Z
Temperature 2
D100 RTD | -200 °C to 630 °C | RD
F100 RTD | -200 °C to 630 °C | R0
Pt100 RTD | -200 °C to 630 °C | RP
Pt385 RTD | -200 °C to 630 °C | R1
Pt3916 RTD | -200 °C to 630 °C | R7
SPRT | -200 °C to 630 °C | RR
Type J TC | -200 °C to 760 °C | _J
Type K TC | -200 °C to 1372 °C | _K
Type T TC | -200 °C to 400 °C | _T
Type E TC | -200 °C to 10000 °C | _E
Type R TC | 0 °C to 1768 °C | _R
Type S TC | 0 °C to 1768 °C | _S
Type B TC | +350 °C to 1820 °C | _B
  1. Volt-Hertz product not to exceed 2e7.
  2. Temperature measurement using a thermocouple requires an external thermocouple card.

Parameters

RANGE

This field specifies the UUT range as described in the RANGE Field topic.

NOMINAL

This field specifies the expected measured value or a reset.

  • Voltage (DC or RMS) entered as: [numeric][prefix]V
  • dBm entered as: [numeric][prefix]D
  • Current entered as [numeric][prefix]A
  • Resistance entered as [numeric][prefix]Z
  • Conductance entered as [numeric][prefix]Y
  • Frequency entered as [numeric][prefix]H
  • Temperature entered as: [numeric][prefix]degC or degF
  • Reset entered as *.

Rules:

  • The NOMINAL field may specify decibels only when the MOD2 field specifies the reference impedance.
  • The NOMINAL field may specify temperature only when the MOD2 field specifies a RTD or thermocouple type.
  • The NOMINAL field must specify a resistance, or equivalent conductance, less than or equal to 21 kΩ when the MOD2 field specifies offset compensation override "O".

TOLERANCE

This field specifies the UUT tolerance as described in the TOLERANCE Field topic.

MOD1

This field specifies frequency for AC voltage and AC current measurements or voltage for frequency or period measurements.

  • Frequency entered as numeric[prefix]H
  • Voltage entered as numeric[prefix]V
  • Current entered as numeric[prefix]A
  • blank

Rules:

  • The MOD1 field must be blank when the NOMINAL field specifies resistance, conductance, or temperature.
  • The MOD1 field may specify frequency only when the NOMINAL field specifies voltage or current.
  • The MOD1 field must specify voltage or current when the NOMINAL field specifies frequency.

MOD2

This field specifies the load impedance that the AC voltage is referenced to for decibels or the RTD or thermocouple type for temperature measurement.

O | Override offset compensation for Ohms
7Z | 75 Ω
3Z | 300 Ω
6Z | 600 Ω
R0 | F100 RTD
R1 | 100 Ω Pt 385 RTD
R7 | 100 Ω Pt 3916 RTD
RD | D100 RTD
RP | Pt100 RTD
RR | SPRT
_J | Type J thermocouple
_K | Type K thermocouple
_T | Type T thermocouple
_E | Type E thermocouple
_R | Type R thermocouple
_S | Type S thermocouple
_B | Type B thermocouple
blank | field not applicable

Rules:

  • The MOD2 field may specify offset compensation override "O" only when the NOMINAL field specifies resistance or conductance.
  • The MOD2 field may specify a reference impedance only when the NOMINAL field specifies decibels.
  • The MOD2 field may specify a thermocouple, RTD, or SPRT only when the NOMINAL field specifies temperature.

MOD3

This field Specifies the measurement mode. The measurement mode determines certain function settings, as well as the number of readings that are discarded and the number of readings that are averaged to obtain a measurement. The effect of the measurement mode on the programmed function is shown in the following table:

F | blank | E
DC Volts

Number of powerline cycles

 1 10 10
Resolution | 6.5 digits | 6.5 digits | 7.5 digits
Readings:
thrown away | 1 | 1 | 1
averaged | 1 | 3 | 5
Autozero | On | On | On
DC Current

Number of powerline cycles

 1 10 10
Resolution | 6.5 digits | 6.5 digits | 7.5 digits
Readings:
thrown away | 1 | 1 | 2
averaged | 1 | 3 | 5
Autozero | On | On | On
Ohms (2-Wire and 4-Wire)

Number of powerline cycles

 1 10 10
Resolution | 6.5 digits | 6.5 digits | 7.5 digits
Readings:
thrown away | 1 | 2 | 2
averaged | 3 | 4 | 5
Autozero | On | On | On

Offset Compensation
<= 21 kΩ | On | On | On
> 21 kΩ | Off | Off | Off
AC Volts

Number of powerline cycles

 N/A 1 10
Resolution | N/A | 5.5 digits | 6.5 digits
Readings:
thrown away | N/A | 1 | 1
averaged | N/A | 3 | 3
Autozero | On | On | On
AC Current

Number of powerline cycles

 N/A 1 10
Resolution | N/A | 5.5 digits | 6.5 digits
Readings:
thrown away | N/A | 1 | 1
averaged | N/A | 3 | 3
Autozero | On | On | On
Frequency
Resolution | N/A | 5 digits | N/A
Readings:
thrown away | N/A | 1 | N/A
averaged | N/A | 1 | N/A
Autozero | Off | Off | Off
Temperature

Number of powerline cycles

 N/A 1 10
Readings
thrown away | N/A | 1 | 1
averaged | N/A | 3 | 3
Resolution
D100 RTD | N/A | 0.001 °C | 0.001 °C
F100 RTD | N/A | 0.001 °C | 0.001 °C
Pt100 RTD | N/A | 0.001 °C | 0.001 °C
Pt385 RTD | N/A | 0.001 °C | 0.001 °C
Pt3916 RTD | N/A | 0.001 °C | 0.001 °C
SPRT | N/A | 0.001 °C | 0.001 °C
Type J TC | N/A | 0.1 °C | 0.1 °C
Type K TC | N/A | 0.1 °C | 0.1 °C
Type T TC | N/A | 0.1 °C | 0.1 °C
Type E TC | N/A | 0.1 °C | 0.1 °C
Type R TC | N/A | 1 °C | 1 °C
Type S TC | N/A | 1 °C | 1 °C
Type B TC | N/A | 1 °C | 1 °C
Autozero | On | On | On
  1. With measurement uncertainty disabled. When measurement uncertainty is enabled, use VSET FSC to set number of readings to throw away and average.

Rules:

  • The MOD3 field may specify "E" only when the NOMINAL field specifies voltage, decibels, current, resistance, conductance, or temperature.
  • The MOD3 field may specify "F" only when the MOD1 field is blank (DC) and the NOMINAL field specifies voltage, current, resistance, or conductance.

MOD4

This field specifies the type of test being performed as described in the MOD4 Field topic.

CON

This field specifies the UUT connection.

2W | 2-wire
3W | 3-wire
4W | 4-wire

Rules:

  • The CON field may specify a 3W only when the MOD2 filed specifies a RTD type.
  • The CON field may specify a 4W only when the NOMINAL field specifies resistance or conductance and the resistance is <= 2.1 MΩ.

Use of Standard Memory Locations and Results Reporting

System memory locations MEM and MEM1 are used. For more information, refer to the Use of Standard Memory Registers topic.

Examples

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
# ----- Reset -----
  1.001  2001         *                                                 S
# ----- DC Voltage -----
  1.002  2001   10    10V            1% 0.01U                              2W
# ----- AC Voltage -----
  2.001  2001   1000  650V           5%            30kH                    2W
  3.001  2001   1     1V             1% 0.01U      10kH                    2W
# ----- dBm -----
  4.001  2001   A     60.0D          0.1U          1kH            5Z       2W
# ----- DC Current -----
  5.001  2001   4000  350mA          9U                                    2W
# ----- AC Current -----
  6.001  2001   2     1A             3%            60H                     2W
# ----- Resistance -----
  7.001  2001   100   10MZ           1%                                    2W
# ----- Conductance -----
  8.001  2001   100   100nY          5%                                    2W
# ----- Setup Test -----
  9.001  2001         1V                           10kH                 S  2W
# ----- Nominal Setup Test -----
  9.002  2001   1     1V                           10kH                 N  2W
# ----- Comparison Test -----
  9.003  2001   1     1V             1% 0.1U       20kH                 C  2W


2002

Instrument FSC

Description

The 2002 FSC programs the Keithley 2002 Multimeter to measure DC voltage, AC voltage, DC current, AC current, resistance, conductance, frequency, or temperature.

Functional Capability

Function | NOMINAL | MOD1 | MOD2
DC Voltage | -1100 V to 1100 V
AC Voltage 1
AC Coupling | 100 nV to 775 V | 1 Hz to 2 MHz
AC+DC | > 200 Hz
Coupling | <= 200 Hz
DC Current | -2.1 A to 2.1 A
AC Current | 100 pA to 2.1 A | 1 Hz to 100 kHz
Resistance | 0 Ohm to 1.05 GOhm
Conductance | >952400 nS
Frequency 1 | 1 Hz to 5 MHz | 60 mV to 775 V
5 MHz to 15 MHz | 350 mV to 775 V
1 Hz to 5 MHz | 150 uA to 2.1 A
dBm 1 | -126.9 dBm to 70.79 dBm | 1 Hz to 2 MHz | 5Z
-128.7 dBm to 69.03 dBm | 1 Hz to 2 MHz | 7Z
-134.7 dBm to 63.01 dBm | 1 Hz to 2 MHz | 3Z
-137.7 dBm to 60.00 dBm | 1 Hz to 2 MHz | 6Z
Temperature 2
D100 RTD | -200 degC to 630 degC | RD
F100 RTD | -200 degC to 630 degC | R0
Pt100 RTD | -200 degC to 630 degC | RP
Pt385 RTD | -200 degC to 630 degC | R1
Pt3916 RTD | -200 degC to 630 degC | R7
SPRT | -200 degC to 630 degC | RR
Type J TC | -200 degC to 760 degC | _J
Type K TC | 200 degC to 1372 degC | _K
Type T TC | -200 degC to 400 degC | _T
Type E TC | -200 degC to 10000 degC | _E
Type R TC | 0 degC to 1768 degC | _R
Type S TC | 0 degC to 1768 degC | _S
Type B TC | +350 degC to 1820 degC | _B
  1. Volt-Hertz product not to exceed 27.
  2. Temperature measurement using a thermocouple requires an external thermocouple card.

Parameters

RANGE

This field specifies the UUT range as described in the RANGE Field topic.

NOMINAL

This field specifies the expected measured value or areset.

  • Voltage (DC or RMS) entered as: [numeric][prefix]V
  • dBm entered as: [numeric][prefix]D
  • Current entered as [numeric][prefix]A
  • Resistance entered as [numeric][prefix]Z
  • Conductance entered as [numeric][prefix]Y
  • Frequency entered as [numeric][prefix]H
  • Temperature entered as: [numeric][prefix]degC or degF
  • Reset entered as *.

Rules:

  • The NOMINAL field may specify decibels only when the MOD2 field specifies the reference impedance.
  • The NOMINAL field may specify temperature only when the MOD2 field specifies a RTD or thermocouple type.
  • The NOMINAL field must specify a resistance, or equivalent conductance, less than or equal to 21 kOhms when the MOD2 field specifies offset compensation override "O".

TOLERANCE

This field specifies the UUT tolerance as described in the TOLERANCE Field topic.

MOD1

This field specifies frequency for AC voltage and AC current measurements or voltage for frequency or period measurements.

  • Frequency entered as numeric[prefix]H.
  • Voltage entered as numeric[prefix]V.
  • Current entered as numeric[prefix]A.
  • blank

Rules:

  • The MOD1 field must be blank when the NOMINAL field specifies resistance, conductance, or temperature.
  • The MOD1 field may specify frequency only when the NOMINAL field specifies voltage or current.
  • The MOD1 field must specify voltage or current when the NOMINAL field specifies frequency.

MOD2

This field specifies the load impedance that the AC voltage is referenced to for decibels or the RTD or thermocouple type for temperature measurement.

O | Override offset compensation for Ohms
5Z | 50 Ohm
7Z | 75 Ohm
3Z | 300 Ohm
6Z | 600 Ohm
R0 | F100 RTD
R1 | 100 Ohm Pt 385 RTD
R7 | 100 Ohm Pt 3916 RTD
RD | D100 RTD
RP | Pt100 RTD
RR | SPRT
_J | Type J thermocouple
_K | Type K thermocouple
_T | Type T thermocouple
_E | Type E thermocouple
_R | Type R thermocouple
_S | Type S thermocouple
_B | Type B thermocouple
blank | field not applicable

Rules:

  • The MOD2 field may specify offset compensation override "O" only when the NOMINAL field specifies resistance or conductance.
  • The MOD2 field may specify a reference impedance only when the NOMINAL field specifies decibels.
  • The MOD2 field may specify a thermocouple, RTD, or SPRT only when the NOMINAL field specifies temperature.

MOD3

This field Specifies the measurement mode. The measurement mode determines certain function settings, as well as the number of readings that are discarded and the number of readings that are averaged to obtain a measurement. The effect of the measurement mode on the programmed function is shown in the following table:

F | blank | E
DC Volts
Number of powerline cycles | 1 | 1 | 10
Resolution | 7.5 digits | 7.5 digits | 8.5 digits
Readings
thrown away | 1 | 1 | 1
averaged | 1 | 10 | 10
Autozero | Synchronous | Synchronous | Synchronous
DC Current
Number of powerline cycles | 1 | 1 | 10
Resolution | 6.5 digits | 6.5 digits | 7.5 digits
Readings
thrown away | 1 | 1 | 1
averaged | 1 | 1 | 10
Autozero | Normal | Normal | Normal
Ohms (2-Wire and 4-Wire)
Number of powerline cycles | 1 | 1 | 10
Resolution | 7.5 digits | 7.5 digits | 8.5 digits
Readings
thrown away | 1 | 1 | 1
averaged | 1 | 10 | 10
Autozero | Normal | Normal | Synchronous
Offset Compensation
<= 21 kΩ | On | On | On
>21 kΩ | Off | Off | Off
AC Volts
Number of powerline cycles | N/A | 1 | 10
Resolution | N/A | 5.5 digits | 6.5 digits
Readings
thrown away | N/A | 1 | 1
averaged | N/A | 1 | 1
Autozero | Normal | Normal | Normal
AC Current
Number of powerline cycles | N/A | 1 | 10
Resolution | N/A | 5.5 digits | 6.5 digits
Readings
thrown away | N/A | 1 | 1
averaged | N/A | 1 | 1
Autozero | Normal | Normal | Normal
Frequency
Number of powerline cycles | N/A | 1 | N/A
Resolution | N/A | 5 digits | N/A
Readings
thrown away | N/A | 1 | N/A
averaged | N/A | 1 | N/A
Autozero | Off | Off | Off
Temperature
Number of powerline cycles | N/A | 1 | 10
Readings
thrown away | N/A | 1 | 1
averaged | N/A | 1 | 1
Resolution
D100 RTD | N/A | 0.001 °C | 0.001 °C
F100 RTD | N/A | 0.001 °C | 0.001 °C
Pt100 RTD | N/A | 0.001 °C | 0.001 °C
Pt385 RTD | N/A | 0.001 °C | 0.001 °C
Pt3916 RTD | N/A | 0.001 °C | 0.001 °C
SPRT | N/A | 0.001 °C | 0.001 °C
Type J TC | N/A | 0.1 °C | 0.1 °C
Type K TC | N/A | 0.1 °C | 0.1 °C
Type T TC | N/A | 0.1 °C | 0.1 °C
Type E TC | N/A | 0.1 °C | 0.1 °C
Type R TC | N/A | 1 °C | 1 °C
Type S TC | N/A | 1 °C | 1 °C
Type B TC | N/A | 1 °C | 1 °C
Autozero | Normal | Normal | Normal
  1. With measurement uncertainty disabled. When measurement uncertainty is enabled, use VSET FSC to set number of readings to throw away and average.

Rules:

  • The MOD3 field may specify "E" only when the NOMINAL field specifies voltage, decibels, current, resistance, conductance, or temperature.
  • The MOD3 field may specify "F" only when the MOD1 field is blank (DC) and the NOMINAL field specifies voltage, current, resistance, or conductance.

MOD4

This field specifies the type of test being performed as described in the MOD4 Field topic.

CON

This field specifies the UUT connection.

2W | 2-wire
3W | 3-wire
4W | 4-wire

Rules:

  • The CON field may specify a 3 W only when the MOD2 field specifies a RTD type.
  • The CON field may specify a 4 W only when the NOMINAL field specifies resistance or conductance and the resistance is <= 2.1 MOhms.

Use of Standard Memory Locations and Results Reporting

System memory locations MEM and MEM1 are used. For more information, refer to the Use of Standard Memory Registers topic.

Examples

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
# ----- Reset -----
  1.001  2002         *                                                 S
# ----- DC Voltage -----
  1.002  2002   10    10V            1% 0.01U                              2W
# ----- AC Voltage -----
  2.001  2002   1000  650V           5%            30kH                    2W
  3.001  2002   1     1V             1% 0.01U      10kH                    2W
# ----- dBm -----
  4.001  2002   A     60.0D          0.1U          1kH            5Z       2W
# ----- DC Current -----
  5.001  2002   4000  350mA          9U                                    2W
# ----- AC Current -----
  6.001  2002   2     1A             3%            60H                     2W
# ----- Resistance -----
  7.001  2002   100   10MZ           1%                                    2W
# ----- Conductance -----
  8.001  2002   100   100nY          5%                                    2W
# ----- Setup Test -----
  9.001  2002         1V                           10kH                 S  2W
# ----- Nominal Setup Test -----
  9.002  2002   1     1V                           10kH                 N  2W
# ----- Comparison Test -----
  9.003  2002   1     1V             1% 0.1U       20kH                 C  2W


2024

2024 Instrument FSC

Description

The 2024 FSC programs amplitude and frequency of the Marconi 2023 and 2024 and IFR 2023A and 2024A AM/FM Signal Generators.

When the 2024 FSC is used to control a Marconi 2023 or IFR 2023A or 2024A you must configure the instrument as an "Marconi 2024" as shown in the drop-down list in the "Add Instrument" configure dialog. Note on serial control If the 202x is to be controlled via its serial port, do not use the PORT FSC port configuration special construction, [P9600,N,...], to set the baud rate, parity, etc. of the port used to control the 202x. MET/CAL executes a "Test" function for each System Instrument prior to executing any procedure statements. Therefore the settings of the port used to control the 202x must be set correctly before a procedure is executed. If the 202x is connected to a standard serial port (COM1, COM2, ..., COM16), use the "Ports" application in the Windows Control Panel to choose the proper settings. If the 202x is connected to the 5500A, 5520A, 5800A, or 5820A UUT port, select the proper settings for the UUT Serial Port from the front panel of the ca librator.

Functional Capability

Model | Frequency | Amplitude
2023 | 9kHz to 1.2GHz | -137dBm to +13dBm (+25dBm Option 3)
2024 | 9kHz to 2.4GHz | -137dBm to +13dBm (+25dBm Option 3)

Parameters

RANGE

This field specifies the UUT range as described in the RANGE Field topic.

NOMINAL

This field specifies the amplitude, frequency, period, or reset.

  • Amplitude entered as: [numeric][prefix]D, V, or Vpp.
  • Frequency entered as [numeric][prefix]H.
  • Period entered as [numeric][prefix]T.
  • Reset entered as *.

Rules:

  • When the NOMINAL field specifies the amplitude, the MOD1 field must specify the frequency or period.
  • When the NOMINAL field specifies the frequency or period, the MOD1 field must specify the amplitude.

TOLERANCE

This field specifies the UUT tolerance as described in the TOLERANCE Field topic.

MOD1

This field specifies the amplitude, frequency, or period.

  • Frequency entered as [numeric][prefix]H.
  • Period entered as [numeric][prefix]T.
  • Amplitude entered as: [numeric][prefix]D, V, or Vpp.

Rules:

  • When the MOD1 field specifies the frequency or period, the NOMINAL field must specify the amplitude.
  • When the MOD1 field specifies the amplitude, the NOMINAL field must specify the frequency or period.

MOD2

This field specifies whether "/div" is include in after the value in the automatic range message.

  • -D "/div" is not included
  • blank "/div" is included if ASK+ D is in effect

Rules:

  • The MOD2 field is automatically set to -D for a Setup Test.

MOD3

This field is not used.

MOD4

This field specifies the type of test being performed as described in the MOD4 Field topic.

CON

This field is specifies which output port is used for the signal.

CH1 | Fluke 58xxA Channel 1
CH2 | Fluke 58xxA Channel 2
CH3 | Fluke 58xxA Channel 3
CH4 | Fluke 58xxA Channel 4
CH5 | Fluke 58xxA Channel 5
blank | 2024 RF Output

Rules:

  • The CON field may specify CH1 or CH5 only when a Fluke 58xxA is configured.
  • The CON field may specify CH2, CH3, or CH4 only when a Fluke 58xxA is configured with the 5800A-5 Five Channel option.

Use of Standard Memory Locations and Results Reporting

System memory locations MEM and MEM1 are used. For more information, refer to the Use of Standard Memory Registers topic.

Examples

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
# ----- Reset -----
  1.001  2024         *                                                 S
  1.002  2024   A     -42.95D        1U            100kH          -D
  2.001  2024         100mV                        550MH          -D    S
  2.002  2024   0.5   28mVpp         5U            100kH          -D
  3.001  2024   A     D              1U            100kH          -D
  4.001  2024         V              1%            100kH          -D
  5.001  2024   50    10uT           1% 1/ 1U      -35D
  6.001  2024   200   100nT          1% 1/ 1U      1Vpp
# ----- Oscilloscope bandwidth test -----
  7.001  ASK-                                                     F        W
  7.002  ASK+     D
  7.003  DISP         Connect the 5800A to UUT channel 1.
  7.004  DISP         Set UUT to 20us/div.
  7.005  2024   20    120mVpp                      100kH                N  CH1
  7.006  ASK-         N
  7.007  MESS         Adjust stimulus for a UUT vertical reading of 4.2 div.
  7.008  2024         5MH            -100%         mVpp           -D       CH1
  8.001  MESS
  8.002  ASK+         N


M2024

Instrument Setup FSC

Description

The M2024 FSC provides the additional program functions for the Marconi 2023 and 2024 and IFR 2023A and 2024A AM/FM Signal Generators which are not addressed by the 2024 FSC. These functions are: Modulation Frequency, AM Depth, FM Deviation, and Phase Deviation.

Parameters

RANGE

Not used.

NOMINAL

The NOMINAL field specifies the modulation frequency or a reset. Modulation Frequency:

When the NOMINAL field is used to specify the modulation frequency, the format is [numeric][prefix]H. Allowed values are 10Hz to 20kHz. If just units are entered, the value is taken from memory register MEM at run time.

Reset:

To specify a reset, enter an asterisk (*) in the NOMINAL field. This resets all previous settings created with the M2024 FSC.

TOLERANCE

Not used.

MOD1

The MOD1 field specifies the AM depth, FM deviation, or phase deviation. The MOD1 field cannot be blank in an 2024 statement.

AM Depth: AM depth is entered as numeric[prefix]pct. AM depth limits are 0 to 99.9%.

FM Deviation: FM deviation is entered as numeric[prefix]H. FM deviation limits are 0 to 100kHz.

Phase Deviation: Phase deviation is entered as numeric[prefix]rad. Phase

deviation limits are 0 to 10 radians.

MOD2

Not used.

MOD3

Not used.

MOD4

Not used.

CON

Not used.

Examples

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
# AM Modulation
  1.001  M2024        *
  1.002  M2024        400H                         0pct
  1.003  2024   10    0D             1U            10MH
  2.001  M2024        1000H                        90pct
  2.002  2024   10    0D             1U            10MH
# FM Modulation
  3.001  M2024        400H                         100H
  3.002  2024   10    0D             0.11U         200kH
  4.001  M2024        1000H                        99.9kH
  4.002  2024   10    0D             0.1U          1000MH
# Phase Modulation
  5.001  M2024        400H                         2rad
  5.002  2024   10    0D             0.11U         200kH
  6.001  M2024        1000H                        10rad
  6.002  2024   10    0D             0.1U          1000MH


6666

Instrument FSC

Description

The 6666 FSC programs the Philips PM 6666 Timer/Counter to measure frequency, frequency ratio, period, time interval and voltage max and min.

Parameters

The following table shows the relationship between the supported PM 6666 measurement functions and the FSC fields listed.

FUNCTION | MOD3 | NOMINAL Value | MOD1 Value
Frequency A | FA | 0.1 Hz to 120 MHz | 1
Frequency C (Opt PM 9608) FC

70 MHz to 900 MHz

10 mV to 12 V
-27 dBm to +35 dBm
900 MHz to 1.1 GHz | 15 mV to 12 V
-24 dBm to +35 dBm
1.1 GHz to 1.3 GHz | 40 mV to 12 V
-15 dBm to +35 dBm
Ratio A/B | FR | 1x10-7 to 2x109 | 1
Period A | PA | 8 ns to 2x108 | 1
Time Interval A-B | TI | 100 ns to 2x108 | 1
Voltage Max A MX -51 V to 51 V

blank (DC) or
100 Hz to 50 MHz
Voltage Min A MN -51 V to 51 V

blank (DC) or
100 Hz to 50 MHz
  1. The allowed voltage is based upon the input frequency:
    1. 0.1 Hz to 440 Hz 20m Vrms to 350 Vp
    2. 440 Hz to 1 MHz 20m Vrms to 2
    3. 1 MHz to 30 MHz 20m Vrms to 8 Vrms
    4. 30 MHz to 120 MHz 40m Vrms to 8 Vrms
  2. The voltage upper bound is determined by the line defined by {(440Hz, 350 Vp), (1 MHz, 8Vrms)}.

RANGE

This field specifies the UUT range as described in the RANGE Field topic.

NOMINAL

This field specifies the expected measured value or a reset.

  • Frequency entered as [numeric][prefix]H.
  • Frequency Ratio entered as [numeric][prefix]H/H.
  • Period entered as [numeric][prefix]T.
  • Time Interval entered as [numeric][prefix]T.
  • Voltage entered as [numeric][prefix]V.
  • Reset entered as *.

Rules:

  1. The NOMINAL field may specify the units symbol "H" only when the MOD3 field specifies Frequency A (FA) or Frequency C (FC).
  2. The NOMINAL field may specify the units symbol "H/H" only when the MOD3 field specifies Ratio A/B (FR).
  3. The NOMINAL field may specify the units symbol "T" only when the MOD3 field specifies Period A (PA) or Time Interval A-B (TI).
  4. The NOMINAL field may specify the units symbol "V" only when the MOD3 specifies Voltage Max A (MX) or Voltage Min A (MN).
  5. If no NOMINAL field value is entered and all other fields are blank, an * is automatically inserted.

TOLERANCE

This field specifies the UUT tolerance as described in the TOLERANCE Field topic.

MOD1

This field specifies the expected amplitude.

  • Voltage (RMS) entered as: [numeric][prefix]V
  • Voltage (Peak) entered as: [numeric][prefix]Vp
  • Voltage (Peak-to-Peak) entered as: [numeric][prefix]Vpp
  • Voltage (into 50 Ohms, dBm) entered as: [numeric][prefix]D
  • Frequency entered as [numeric][prefix]H.
  • blank

Rules:

  1. The MOD1 field may specify the units symbol "V" only when the MOD3 field does not specify Voltage Max A (MX) or Voltage Min A (MN).
  2. The input signal is assumed to be sinusoid when the MOD1 field specifies the units symbol "V".
  3. The MOD1 field may specify the units symbol "Vp" only when the MOD3 field specifies Frequency A (FA), Period A (PA), Frequency A/B (FR), or Time Interval A-B (TI).
  4. The MOD1 field may specify the units symbol "Vpp" only when the MOD3 field specifies Frequency A (FA), Period A (PA), Frequency A/B (FR), or Time Interval A-B (TI).
  5. The MOD1 field may specify the units symbol "D" only when the MOD3 field specifies Frequency C (FC).
  6. The MOD1 field may be blank or specify the units symbol "H" only when the MOD3 field specifies Voltage Max A (MX) or Voltage Min A (MN).

MOD2

This field specifies the trigger slope as follows:

+A | Positive slope triggering, AC coupled
-A | Negative slope triggering, AC coupled
+D | Positive slope triggering, DC coupled
-D | Negative slope triggering, DC coupled
blank |

Rules:

  1. When the MOD2 field is blank, the trigger slope and coupling for channel A and B default to values determined by the measurement function unless specified otherwise using the M666 FSC.
  2. The MOD2 field must specify +A when the MOD3 field specifies Frequency C (FC).
  3. +A is inserted automatically in the MOD2 field when the MOD3 field specifies Frequency C (FC).

MOD3

This field specifies the measurement function:

FA | Frequency A
FC | Frequency C
PA | Period A
FR | Ratio A/B
TI | Time Interval A to B
MX | Voltage Max A
MN | Voltage Min A

Rules:

  1. The MOD3 field may specify Frequency C (FC) only when the High Frequency Input, option PM 9608 is installed. This is indicated in the CONFIG.DAT file as 6666(HF).

MOD4

This field specifies the type of test being performed as described in the MOD4 Field topic.

CON

This field specifies the UUT connection.

blank | MΩ Input Impedance
L | 50 Ω Input Impedance
2W | 2-Wire

Rules:

  1. The CON field may only specify "L" when the MOD3 field specifies Frequency C (FC).
  2. L is inserted automatically in the CON field when the MOD3 field specifies Frequency C (FC).
  3. 2W is allowed for compatibility with previous versions of MET/CAL.

Use of Standard Memory Locations and Results Reporting

System memory locations MEM and MEM1 are used. For more information, refer to the Use of Standard Memory Registers topic.

Examples

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
# -----  Reset  -----
  1.001  M666         *
  1.002  6666         *                                                 S
# -----  Frequency A  -----
  1.003  6666         10.000kH       1%            1Vpp           +A FA
# -----  Frequency C  -----
  2.001  6666         100MH          0.1%          1V             +A FC    L
# -----  Period A  -----
  3.001  6666         1.000mT        0.003U        5V             +A PA
# -----  Ratio A/B  -----
  4.001  M666   ChA                                               AC
  4.002  M666   ChB                                               DC
  4.003  6666         10H/H          1%            1Vpp              FR
# -----  Time Interval A to B (Rise Time)  -----
  5.001  M666   COM   10T            0.1V          0.9V           DC ++    X1
  5.002  6666         1.00uT         0.02U         1Vpp              TI
# -----  Time Interval A to B (Pulse Width)  -----
  6.001  M666   COM   10T            100mV         100mV          DC +-    X1
  6.002  6666         1.00uT         0.02U         1Vpp              TI


M666

Auxiliary Instrument Setup FSC

Description

The M666 FSC provides the additional program functions for Channel A and Channel B of the Philips PM 6666 Timer/Counter which are not addressed by the 6666 FSC. These functions include Common B via A, Measuring Time, Trigger Level (DC coupling), Trigger Sensitivity (AC coupling), Input Coupling, Trigger Slope, and Input Attenuation.

RANGE

This field specifies the Channel.

ChA | Channel A
ChB | Channel B
COM | Common B via A
blank |

Rules:

  1. The M666 statement is ignored under the following conditions:
  2. The RANGE field specifies Channel B and the 6666 FSC specifies Frequency A, Period A, Voltage Max A, or Voltage Min A (6666 MOD3 field is FA, PA, MX, or MN respectively).
  3. The RANGE field specifies Common B via A and the 6666 FSC specifies a measurement function other than Time Interval A-B (6666 MOD3 field is not TI).
  4. The 6666 FSC specifies Frequency C (6666 MOD3 field is FC).

NOMINAL

This field specifies one the following:

  • Measuring Time entered as: numeric[prefix]T. Allowed values are: 0 or 10ms to 10s with a resolution of 10ms. 0 selects SINGLE-measuring mode.
  • "*" Reset to defaults
  • blank

Rules:

  1. Measuring Time is not channel specific. It may be specified in a separate M666 statement or in conjunction with a channel A, channel B, or Common B via A specification. Either way, the last Measuring Time specification prior to a 6666 statement is used.
  2. The PM 6666 truncates all values to the nearest 10 ms. For example specifying 7.34567T is the same as specifying 7.34T.

TOLERANCE

This field specifies one of the following:

  • The Channel A or B Trigger Sensitivity or Level entered as numeric[prefix]V.
  • blank Auto Level (default) or not applicable.

Rules:

MOD2 Field | CON Field | Allowed Values TOLERANCE field | Resolution Field
AC | x1 | 20mV, 50mV, 100mV | NA
AC | x10 | 0.2V, 0.5V, 1.0V | NA
DC | x1 | -5.10V to +5.10V | 0.02 V
DC | x10 | -51.0V to +51.0V | 0.2 V
  1. The TOLERANCE field specifies the channel A trigger sensitivity or level when the RANGE field specifies Channel A or Common B via A.
  2. The TOLERANCE field specifies the channel B trigger sensitivity or level when the RANGE field specifies Channel B.
  3. The TOLERANCE field must be blank when the RANGE field is blank.
  4. Auto Level is specified when the TOLERANCE field is blank and the RANGE field specifies Channel A or Common B via A.
  5. Auto Level causes the attenuation, and trigger sensitivity or level to be automatically controlled for both Input A and Input B.
  6. The TOLERANCE field specification is ignored when the 6666 FSC specifies Auto Level (6666 MOD2 field is not blank).

MOD1

This field specifies one of the following:

  • The Channel B Trigger Sensitivity or Level enteredas numeric[prefix]V.
  • blank Auto Level (default) or not applicable.

Rules:

MOD2 | CON Field | Allowed Values TOLERANCE Field | Allowed Values MOD1 | Resolution Field
AC | x1 | 20mV, 50mV, 100mV | 20mV, 50mV, 100mV | NA
AC | x10 | 0.2V, 0.5V, 1.0V | 0.2V, 0.5V, 1.0V | NA
DC | x1 | -5.10V to +5.10V | -5.10V to +5.10V | 0.02 V
DC | x10 | -51.0V to +51.0V | -51.0V to +51.0V | 0.2 V
  1. The MOD1 field may specify the channel B trigger level or sensitivity only when the RANGE field specifies Common B via A(COM).
  2. The MOD1 field must be blank when the RANGE field is blank or Auto Level is specified (TOLERANCE field is blank).
  3. The MOD1 field specification is ignored when the 6666 FSC specifies Auto Level (6666 MOD2 field is not blank).

MOD2

This field specifies the input coupling:

  • AC
  • DC
  • blank
Default Coupling
6666 MOD3 Field | 6666 MOD1 Field | Coupling
FA (Frequency A) | NA | AC
FC (Frequency C) | NA | NA
PA (Period A) | NA | AC
FR (Ratio A/B) | NA | AC
TI (Time Interval A-B) | NA | DC
MX (Voltage Max A) | <100 Hz | DC
 | ≥100 Hz | AC
MN (Voltage Min A) | <100 Hz | DC
 | ≥100 Hz | AC

Rules:

  1. Default values are used when the 6666 FSC does not specify the input coupling (6666 MOD2 field is blank) and one of the following conditions exists:
    1. No M666 statement has been executed.
    2. The last M666 statement executed was a M666 Reset.
    3. The M666 MOD2 field is blank and the M666 RANGE field specifies Channel A, Channel B, or Common B via A.
  2. The MOD2 field must be blank when the RANGE field is blank.
  3. The MOD2 field must specify AC when the TOLERANCE field specifies the trigger sensitivity.
  4. The MOD2 field must specify DC when the TOLERANCE field specifies the trigger level.
  5. The MOD2 field specification is ignored when the 6666 FSC specifies the input coupling (6666 MOD2 field is not blank).

MOD3

This field specifies the trigger slope:

+ | Positive, Channel A or B
- | Negative, Channel A or B
++ | Positive Channel A and B
+- | Positive Channel A, Negative Channel B
-+ | Negative Channel A, Positive Channel B
-- | Negative Channel A and B
blank |

Rules:

  1. The MOD3 field must be blank when the RANGE field is blank.
  2. The MOD3 field may specify "+" or "-" only when the RANGE field specifies Channel A (CHA) or Channel B (CHB).
  3. The MOD3 field may specify "++", "+-", "-+", or "--" only when the RANGE field specifies Common B via A (COM).
  4. The MOD3 field specification is ignored when the 6666 FSC specifies the trigger slope (6666 MOD2 field is not blank).

MOD4

This field is not used.

CON

This field specifies the Attenuation. Legal entries are:

  • X1 (default)
  • X10
  • blank

Rules:

  1. The CON field must be blank when the RANGE is blank.
  2. The CON field must not be blank when the TOLERANCE field specifies the trigger sensitivity or level.
  3. The CON field specification is ignored when the 6666 FSC specifies Auto Level (6666 MOD2 field is not blank).

Examples

Refer to 6666 FSC


6680

Instrument FSC

Description

The 6680 FSC programs the Fluke/Philips PM 6680 and Wavetek 900 Timer/Counter to measure frequency, frequency ratio, period, time interval, phase, pulse width, duty factor, rise and fall time, voltage min and max, and voltage peak-to- peak. Not all PM 6680/900 capabilities are supported. To program unsupported functions, use the SCPI or IEEE FSC.

The 6680 FSC may also be used to control a PM 6681 or Wavetek 901. This capability allows a PM 6680 based procedure to be executed without modification when a PM 6681 is configured. If the C channel is used, the pre-scaler model must be the same. When the 6680 and M680 FSCs are used to control a Fluke PM 6680B or Wavetek 900, you must configure the instrument as a "Philips PM 6680" as shown in the drop-down list in the "Add Instrument" configure dialog. Similarly, when the 6680 and M680 FSCs are used to control a Fluke or Philips PM 6681 or Wavetek 901, you must configure the instrument as a "Philips PM 6681" as shown in the drop-down list in the "Add Instrument" configure dialog.

Parameters

The following table shows the relationship between the supported PM 6680 measurement functions and the FSC fields listed.

FUNCTION | MOD3 | NOMINAL | MOD1
Frequency A | FA | 10-10 Hz to 225 MHz | 60 mVpp to 100 Vpp
 |  |  | 30 mVp to 50 Vp
 |  |  | 22 mVrms to 35 Vrms
Frequency C (PM 6680 Opt PM 9621) | FC | 70 MHz to 900 MHz | 10 mV to 12 V
 |  |  | -27 dBm to +35 dBm
 |  | > 900 MHz to 1.1 GHz | 15 mV to 12V
 |  |  | -24 dBm to +35 dBm
 |  | >1.1 GHz to 1.3 GHz | 40 mV to 12 V
 |  |  | -15 dBm to +35 dBm
Frequency C (PM 6680 Opt PM 9624) | FC | 100 MHz to <300 MHz | 20 mV to 12 V
 |  |  | -21 dBm to +35 dBm
 |  | 300 MHz to 2.5 GHz | 10 mV to 12 V
 |  |  | -27 dBm to +35 dBm
 |  | > 2.5 GHz to 2.7 GHz | 20 mV to 12 V
 |  |  | -21 dBm to +35 dBm
Frequency C (PM 6680 Opt PM 9625) | FC | 150 MHz to < 300 MHz | 20 mV to 1 V
 |  |  | -21 dBm to +13 dBm
 |  | 300 MHz to 2.5 GHz | 10 mV to 1 V
 |  |  | -27 dBm to +13 dBm
 |  | > 2.5 GHz to 3.7 GHz | 15 mV to 1 V
 |  |  | -24 dBm to +13 dBm
 |  | > 3.7GHz to 4.2 GHz | 25 mV to 1 V
 |  |  | -19 dBm to +13 dBm
 |  | > 4.2 GHz to 4.5 GHz | 50 mV to 1 V
 |  |  | -13 dBm to +13 dBm
Ratio A/B | FR | 10-9 to 1015 | 60 mVpp to 100 Vpp
 |  |  | 30 mVp to 50 Vp
 |  |  | 22 mVrms to 35 Vrms
Period A | PA | 6 ns to 1010 s | 60 mVpp to 100 Vpp
 |  |  | 30 mVp to 50 Vp
 |  |  | 22 mVrms to 35 Vrms
Time Interval A-B | TI | 0 ns to 1010 s | 60 mVpp to 100 Vpp
 |  |  | 30 mVp to 50 Vp
 |  |  | 22 mVrms to 35 Vrms
Phase A-B | PR | -180° to +360° | 0.01 Hz to 160 MHz
Pulse Width A | WA | 3 ns to 5 ns | 90 mVpp to 100 Vpp
 |  |  | 45m Vp to 50 Vp
 |  | > 5 ns to 1010 s | 60 mVpp to 100 Vpp
 |  |  | 30 mVp to 50 Vp
Duty Factor A | DA | 0 to 1 | 0.01 Hz to 160 MHz
Rise/Fall Time A | RF | 3 ns to 1010 s | 500 mVpp to 100 Vpp
 |  |  | 250 mVp to 50 Vp
Voltage Max A | MX | -51 V to 51 V | blank (DC)
 |  | 51 Vp to 51 Vp | 100 Hz to 120 MHz
Voltage Min A | MN | -51 V to 51 V | blank (DC)
 |  | 51 Vp to 51 Vp | 100 Hz to 120 MHz
Voltage Peak-to-Peak A | PP | 0 Vpp to102 Vpp | 100 Hz to 120 MHz

RANGE

This field specifies the UUT range as described in the RANGE Field topic.

NOMINAL

This field specifies the expected measured value or a reset.

  • Frequency entered as [numeric][prefix]H.
  • Frequency Ratio entered as [numeric][prefix]H/H.
  • Period entered as [numeric][prefix]T.
  • Time Interval entered as [numeric][prefix]T.
  • Phase entered as [numeric][prefix]deg.
  • Pulse Width entered as [numeric][prefix]T.
  • Duty Factor entered as [numeric][prefix]df.
  • Rise or Fall Time entered as [numeric][prefix]T.
  • Voltage max or min entered as [numeric][prefix]V or Vp.
  • Voltage peak-to-peak entered as [numeric][prefix]Vpp.
  • Reset entered as *.

Rules:

  1. When the NOMINAL field contains only units, the value is obtained from the memory register MEM.
  2. If no NOMINAL field value is entered and all other fields are blank, an * is automatically inserted.

TOLERANCE

This field specifies the UUT tolerance as described in the TOLERANCE Field topic.

MOD1

For measurements of frequency, frequency ratio, period, time interval, pulse width and rise/ fall time, this field specifies the expected amplitude. For measurements of phase, duty factor, voltage min/max of AC and voltage peak-to-peak, this field specifies the expected frequency. For measurements of voltage min/max

of DC, this field should be blank.

  • Voltage (RMS) entered as: [numeric][prefix]V
  • Voltage (Peak) entered as: [numeric][prefix]Vp
  • Voltage (Peak-to-Peak) entered as: [numeric][prefix]Vpp
  • Voltage (into 50 Ω, dBm) entered as: [numeric][prefix]D
  • Frequency entered as [numeric][prefix]H.
  • blank

Rules:

  1. For Ratio A/B (FR) measurements, the MOD1 field specifies the expected amplitude on channel A, not channel B.

MOD2

This field specifies the trigger slope as follows:

+A | Positive slope triggering, AC coupled
-A | Negative slope triggering, AC coupled
+D | Positive slope triggering, DC coupled
-D | Negative slope triggering, DC coupled
blank |

Rules:

  1. When the MOD2 field is blank, the trigger slope and coupling for channel A and B default to values determined by the measurement function unless otherwise specified using the M680 FSC.
  2. +A is inserted automatically in the MOD2 field when the MOD3 field specifies Frequency C (FC).

MOD3

This field specifies the measurement function:

FA | Frequency A
FC | Frequency C
PA | Period A
FR | Ratio A/B
TI | Time Interval A to B
WA | Pulse Width A
RF | Rise or Fall Time A
PR | Phase A Relative to B
DA | Duty Factor A
MX | Voltage Max A
MN | Voltage Min A
PP | Voltage Peak-to-Peak A

Rules:

  1. When MOD3 is "RF" and channel A trigger slope is positive, a rise time measurement is performed. When channel A trigger slope is negative a fall time measurement is performed.
  2. The MOD3 field may specify Frequency C (FC) only when a High Frequency Input, PM 6680 option PM 9621, PM 9624, or PM 9625 or 900 Option 10 is installed.

MOD4

This field specifies the type of test being performed as described in the MOD4 Field topic.

CON

This field specifies the UUT connection.

blank | MOhm Input Impedance
L | 50 Ohm Input Impedance
2W | 2-Wire

Rules:

  1. L is inserted automatically in the CON field when the MOD3 field specifies Frequency C (FC).
  2. 2W is allowed for compatibility with previous versions of MET/CAL.

Use of Standard Memory Locations and Results Reporting

System memory locations MEM and MEM1 are used. For more information, refer to the Use of Standard Memory Registers topic.

Examples

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
# -----  Reset  -----
  1.001  M680         *
  1.002  6680         *                                                 S
# -----  Frequency A  -----
  1.003  M680   ChA                                100kH
  1.004  6680         10.000kH       1%            1Vpp           +A FA
# -----  Frequency C  -----
  2.001  6680         1GH            0.1%          -1D            +A FC    L
# -----  Period A  -----
  3.001  M680         *
  3.002  6680         1.000mT        0.003U        5V             +A PA
# -----  Ratio A/B  -----
  4.001  M680   ChA                                               AC
  4.002  M680   ChB                                               DC
  4.003  6680         10H/H          1%            1Vpp              FR
# -----  Time Interval A to B  -----
  5.001  M680   COM   20T            0.2V          0.8V           DC ++    X1
  5.002  6680         10.00T         0.02U         1Vpp              TI
# -----  Pulse Width A  -----
  6.001  M680         *
  6.002  6680         300uT          5%            5Vp            -A WA
# -----  Rise Time A  -----
  7.001  6680         100nT          5%            1Vpp              RF
# -----  Phase A relative to B  -----
  8.001  M680         *
  8.002  6680         30deg          1U            10kH              PR    L
# -----  Duty Factor A  -----
  9.001  6680         0.30DF         2%            100H              DA


M680

Auxiliary Instrument Setup FSC

Description

The M680 FSC provides the additional program functions for Channel A and Channel B of the Fluke/Philips PM 6680 Timer/Counter which are not addressed by the 6681 FSC. These functions include Common B via A, Measuring Time, Trigger Level, Trigger Slope, Input Coupling, Input Impedance, and Input Attenuation.

RANGE

This field specifies the Channel.

ChA | Channel A
ChB | Channel B
COM | Common B via A
blank |

Rules:

  1. The M680 statement is ignored under the following conditions:
    1. The RANGE field specifies Channel B and the 6680 FSC specifies Frequency A, Period A, Pulse Width A, Voltage Max A, or Voltage Min A (6680 MOD3 field is FA, PA, WA, MX, or MN respectively).
    2. The RANGE field specifies Common B via A and the 6680 FSC specifies a measurement function other than Time Interval A-B (6680 MOD3 field is not TI).
    3. The 6680 FSC specifies Frequency C (6680 MOD3 field is FC).

NOMINAL

This field specifies one the following:

  • Measuring Time entered as: [numeric][prefix]T. Allowed values are: 0.8, 1.6, 3.2, 6.4, 12.8 and 50us to 400s.
  • "*" Reset to defaults
  • blank

Rules:

  1. Measuring Time is not channel specific. It may be specified in a separate M680 statement or in conjunction with a channel A or channel B specification. Either way, the last Measuring Time specification prior to a 6680 statement is used.

TOLERANCE

This field specifies one of the following:

  • The Channel A or B Trigger Level entered as [numeric][prefix]V.
  • blank Auto Level (default) or not applicable.

Rules:

CON Field | Allowed values TOLERANCE | Resolution field
X1 | -5.10V to +5.10V | 0.02V
X10 | -51.0V to +51.0V | 0.2V
  1. The TOLERANCE field specifies the channel A trigger level when the RANGE field specifies Channel A or Common B via A.
  2. The TOLERANCE field specifies the channel B trigger level when the RANGE field specifies Channel B.
  3. The TOLERANCE field must be blank when the RANGE field is blank.
  4. Auto Level is specified when the TOLERANCE field is blank and the RANGE field specifies Channel A or Common B via A.
  5. Auto Level causes the attenuation, and trigger level to be automatically controlled for both Input A and Input B.
  6. The TOLERANCE field specification is ignored when the 6680 FSC specifies Auto Level (6680 MOD2 field is not blank).
  7. If the TOLERANCE field does not contain a value the value is taken from memory register MEM.

MOD1

This field specifies one of the following:

  • The Channel A Low-Pass Filter entered as: [numeric][prefix]H.
  • The Channel B Trigger Level entered as [numeric][prefix]V.
  • blank Auto Level (default) or not applicable.

Rules:

CON Field | Allowed values TOLERANCE | Allowed values MOD1 field | Resolution MOD1 field
X1 | -5.10 V to +5.10 V | -5.10V to +5.10 V | 0.02 V
X10 | -51.0 V to +51.0 V | -51.0V to +51.0 V | 0.2 V
  1. The MOD1 field may specify the channel A low-pass filter only when the RANGE field specifies channel A.
  2. When the MOD1 field specifies the channel A low-pass filter, the value must be 100kHz.
  3. The MOD1 field may specify the channel B trigger level only when the RANGE specifies Common B via A.
  4. The MOD1 field must be blank when the RANGE field is blank.
  5. The MOD1 field specification is ignored when the MOD1 field specifies the channel B trigger level and the 6680 FSC specifies Auto Level (6680 MOD2 field is not blank).
  6. If the MOD1 field does not contain a value the value is taken from memory register MEM.

MOD2

This field specifies the input coupling:

AC
DC
blank
Default Coupling
6680 MOD3 Field | 6680 MOD1 Field | Coupling
FA (Frequency A) | NA | AC
FC (Frequency C) | NA | NA
PA (Period A) | NA | AC
FR (Ratio A/B) | NA | AC
WA (Pulse Width A) | NA | DC
TI (Time Interval A-B) | NA | DC
PR (Phase A-B) | NA | AC
DA (Duty Factor A) | NA | DC
RF (Rise Time A) | NA | DC
MX (Voltage Max A) | <100Hz | DC
 | >=100Hz | AC
MN (Voltage Min A) | <100Hz | DC
 | >=100Hz | AC

Rules:

  1. Default values are used when the 6680 FSC does not specify the input coupling (6680 MOD2 field is blank) and one of the following conditions exists:
    1. No M680 statement has been executed.
    2. The last M680 statement executed was a M680 Reset.
    3. The M680 MOD2 field is blank and the M680 RANGE field specifies Channel A, Channel B, or Common B via A.
  2. The MOD2 field must be blank when the RANGE field is blank.
  3. The MOD2 field must specify AC or DC when TOLERANCE field specifies the trigger level.
  4. The MOD2 field specification is ignored when the 6680 FSC specifies the input coupling (6680 MOD2 field is not blank).

MOD3

This field specifies the trigger slope:

+ | Positive, Channel A or B
- | Negative, Channel A or B
++ | Positive Channel A and B
+- | Positive Channel A, Negative Channel B
-+ | Negative Channel A, Positive Channel B
-- | Negative Channel A and B
blank |

Rules:

  1. The MOD3 field must be blank when the RANGE field is blank.
  2. The MOD3 field may specify "+" or "-" only when the RANGE field specifies Channel A (CHA) or Channel B (CHB).
  3. The MOD3 field may specify "++", "+-", "-+", or "--" only when the RANGE field specifies Common B via A (COM).
  4. The MOD3 field specification is ignored when the 6680 FSC specifies the trigger slope (6680 MOD2 field is not blank).

MOD4

This field specifies that an external reference oscillator is to be used:

X | External Reference Oscillator
blank |

Rules:

  1. A M680 reset statement, NOMINAL field is an "*", must be used to re-select the internal reference once the external reference is selected.

CON

This field specifies the Attenuation. Legal entries are:

X1 (default)
X10
blank

Rules:

  1. The CON field must be blank when the RANGE is blank.
  2. The CON field must not be blank when the TOLERANCE field specifies the trigger level.
  3. The CON field specification is ignored when the 6680 FSC specifies Auto Level (6680 MOD2 field is not blank).

Examples

Refer to 6680 FSC.


6681

Instrument FSC

Description

The 6681 FSC programs the Fluke/Philips PM 6681 and Wavetek 901 Timer/Counters to measure frequency, frequency ratio, period, time interval, phase, pulse width, duty factor, rise and fall time, voltage min and max, and voltage peak-to-peak. All PM 6681/901 capabilities are not supported. To program unsupported functions, use the SCPI or IEEE FSC.

When the 6681 and M681 FSCs are used to control a Fluke PM 6681 or Wavetek 901, you must configure the instrument as a "Philips PM 6681" as shown in the drop-down list in the "Add Instrument" configure dialog.

Parameters

The following table shows the relationship between the supported PM 6681/901 measurement functions and the FSC fields listed.

Function | MOD3 | NOMINAL | MOD1
Frequency A | FA | 10-10 Hz to 300 MHz | 60 mVpp to 100 Vpp
 |  |  | 30 mVp to 50 Vp
 |  |  | 22 mVrms to 35 Vrms
Frequency C (PM 6681 Opt PM 9621) | FC | 70 MHz to 900 MHz | 10 mV to 12 V
 |  |  | -27 dBm to +35 dBm
 |  | >900 MHz to 1.1 GHz | 15 mV to 12 V
 |  |  | -24 dBm to +35 dBm
 |  | >1.1 GHz to 1.3 GHz | 40 mV to 12 V
 |  |  | -15 dBm to +35 dBm
Frequency C (PM 6681 Opt PM 9624) | FC | 100 MHz to <300 MHz | 20 mV to 12 V
 |  |  | -21 dBm to +35 dBm
 |  | 300 MHz to 2.5 GHz | 10 mV to 12 V
 |  |  | -27 dBm to +35 dBm
 |  | >2.5 GHz to 2.7 GHz | 20 mV to 12 V
 |  |  | -21 dBm to +35 dBm
Frequency C (PM 6681 Opt PM 9625) | FC | 150 MHz to <300 MHz | 20 mV to 1 V
 |  |  | -21 dBm to +13 dBm
 |  | 300 MHz to 2.5 GHz | 10 mV to 1 V
 |  |  | -27 dBm to +13 dBm
 |  | >2.5 GHz to 3.7 GHz | 15 mV to 1 V
 |  |  | -24 dBm to +13 dBm
 |  | >3.7 GHz to 4.2 GHz | 25 mV to 1 V
 |  |  | -19 dBm to +13 dBm
 |  | >4.2 GHz to 4.5 GHz | 50 mV to 1 V
 |  |  | -13 dBm to +13 dBm
Frequency C (PM 6681 Opt PM 9638) | FC | 300 MHz to <500 MHz | 20 mV to 7 V
 |  |  | -21 dBm to +30 dBm
 |  | 500 MHz to 3.0 GHz | 10 mV to 7 V
 |  |  | -27 dBm to +30 dBm
 |  | >3.0 GHz to 4.5 GHz | 20 mV to 7 V
 |  |  | -21 dBm to +30 dBm
 |  | >4.5 GHz to 6.0 GHz | 40 mV to 7 V
 |  |  | -15 dBm to +30 dBm
 |  | >6.0 GHz to 8.0 GHz | 80 mV to 7 V
 |  |  | -9 dBm to +30 dBm
Ratio A/B | FR | 109 to 1015 | 60 mVpp to 100 Vpp
 |  |  | 30 mVp to 50 Vp
 |  |  | 22 mVrms to 35 Vrms
Period A | PA | 6 ns to 1010 s | 60 mVpp to 100 Vpp
 |  |  | 30 mVp to 50 Vp
 |  |  | 22 mVrms to 35 Vrms
Time Interval A-B | TI | 0 ns to 1010 s | 60 mVpp to 100 Vpp
 |  |  | 30 mVp to 50 Vp
 |  |  | 22 mVrms to 35 Vrms
Phase A-B | PR | -180 ° to +360 ° | 0.01 Hz to 160 MHz
Pulse Width A | WA | 3 ns to 5 ns | 90 mVpp to 100 Vpp
 |  |  | 45 mVp to 50 Vpp
 |  | >5 ns to 1010 s | 60 mVpp to 100 Vpp
 |  |  | 30 mVp to 50 Vp
Duty Factor A | DA | 0 to 1 | 0.01 Hz to 160 MHz
Rise/Fall Time A | RF | 3 ns to 1010 s | 250 mVpp to 100 Vpp
 |  |  | 125 mVp to 50 Vp
Voltage Max A | MX | -51 V to 51 V | blank (DC)
 |  |  | 1 Hz to 120 MHz
Voltage Min A | MN | -51 V to 51 V | blank (DC)
 |  |  | 1 Hz to 120 MHz
Voltage Peak-to-Peak A | PP | 0 Vpp to 102 Vpp | 1 Hz to 120 MHz

RANGE

This field specifies the UUT range as described in the RANGE Field topic.

NOMINAL

This field specifies the expected measured value or a reset.

  • Frequency entered as [numeric][prefix]H.
  • Frequency Ratio entered as [numeric][prefix]H/H.
  • Period entered as [numeric][prefix]T.
  • Time Interval entered as [numeric][prefix]T.
  • Phase entered as [numeric][prefix]deg.
  • Pulse Width entered as [numeric][prefix]T.
  • Duty Factor entered as [numeric][prefix]df.
  • Rise or Fall Time entered as [numeric][prefix]T.
  • Voltage max or min entered as [numeric][prefix]V or Vp.
  • Voltage peak-to-peak entered as [numeric][prefix]Vpp.
  • Reset entered as *.

Rules:

  1. When the NOMINAL field contains only units, the value is obtained from the memory register MEM.
  2. If no NOMINAL field value is entered and all other fields are blank, an * is automatically inserted.

TOLERANCE

This field specifies the UUT tolerance as described in the TOLERANCE Field topic.

MOD1

For measurements of frequency, frequency ratio, period, time interval, pulse width and rise/ fall time, this field specifies the expected amplitude. For measurements of phase, duty factor, voltage min/max of AC and voltage peak-to-peak, this field specifies the expected frequency. For measurements of voltage min/max of DC, this field should be blank.

  • Voltage (RMS) entered as: numeric[prefix]V
  • Voltage (Peak) entered as: numeric[prefix]Vp
  • Voltage (Peak-to-Peak) entered as: numeric[prefix]Vpp
  • Voltage (into 50 Ohms, dBm) entered as: numeric[prefix]D
  • Frequency entered as numeric[prefix]H.
  • blank

Rules:

  1. For Ratio A/B (FR) measurements, the MOD1 field specifies the expected amplitude on channel A, not channel B.

MOD2

This field specifies the trigger slope as follows:

+A | Positive slope triggering, AC coupled
-A | Negative slope triggering, AC coupled
+D | Positive slope triggering, DC coupled
-D | Negative slope triggering, DC coupled
blank |

Rules:

  1. When the MOD2 field is blank, the trigger slope and coupling for channel A and B default to values determined by the measurement function unless otherwise specified using the M681 FSC.
  2. +A is inserted automatically in the MOD2 field when the MOD3 field specifies Frequency C (FC).

MOD3

This field specifies the measurement function:

FA | Frequency A
FC | Frequency C
PA | Period A
FR | Ratio A/B
TI | Time Interval A to B
WA | Pulse Width A
RF | Rise or Fall Time A
PR | Phase A Relative to B
DA | Duty Factor A
MX | Voltage Max A
MN | Voltage Min A
PP | Voltage Peak-to-Peak A

Rules:

  1. When MOD3 is "RF" and channel A trigger slope is positive, a rise time measurement is performed. When channel A trigger slope is negative a fall time measurement is performed.
  2. The MOD3 field may specify Frequency C (FC) only when a High Frequency Input, PM 6681 option PM 9621, PM 9624, PM 9625, or PM 9638 or 901 Option 20 is installed.

MOD4

This field specifies the type of test being performed as described in the MOD4 Field topic.

CON

This field specifies the UUT connection.

blank | 1 MΩ Input Impedance
L | 50 Ω Input Impedance
2W | 2-Wire

Rules:

  1. L is inserted automatically in the CON field when the MOD3 field specifies Frequency C (FC).
  2. 2W is allowed for compatibility with previous versions of MET/CAL.

Use of Standard Memory Locations and Results Reporting

System memory locations MEM and MEM1 are used. For more information, refer to the Use of Standard Memory Registers topic.

Examples

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
# ----- Reset -----
  1.001  M681         *
  1.002  6681         *                                                 S
# ----- Frequency A -----
  1.003  M681   ChA                                100kH
  1.004  6681         10.000kH       1%            1Vpp           +A FA
# ----- Frequency C -----
  2.001  6681         300MH          0.1%          -1D            +A FC    L
# ----- Period A -----
  3.001  M681         *
  3.002  6681         1.000mT        0.003U        5V             +A PA
# ----- Ratio A/B -----
  4.001  M681   ChA                                               AC
  4.002  M681   ChB                                               DC
  4.003  6681         10H/H          1%            1Vpp              FR
# ----- Time Interval A to B -----
  5.001  M681   COM   20T            0.2V          0.8V           DC ++    X1
  5.002  6681         10.00T         0.02U         1Vpp              TI
# ----- Pulse Width A -----
  6.001  M681         *
  6.002  6681         300uT          5%            5Vp            -A WA
# ----- Rise Time A -----
  7.001  6681         100nT          5%            1Vpp              RF
# ----- Phase A relative to B -----
  8.001  M681         *
  8.002  6681         30deg          1U            10kH              PR    L
# ----- Duty Factor A -----
  9.001  6681         0.30DF         2%            100H              DA


M681

Instrument Setup FSC

Description

The M681 FSC provides the additional program functions for Channel A and Channel B of the Fluke/Philips PM 6681 Timer/Counter which are not addressed by the 6681 FSC. These functions include Common B via A, Measuring Time, Trigger Level, Trigger Slope, Input Coupling, Input Impedance, and Input Attenuation.

RANGE

This field specifies the Channel.

ChA | Channel A
ChB | Channel B
COM | Common B via A
blank |

Rules:

  1. The M681 statement is ignored under the following conditions:
    1. The RANGE field specifies Channel B and the 6681 FSC specifies Frequency A, Period A, Pulse Width A, Voltage Max A, or Voltage Min A (6681 MOD3 field is FA, PA, WA, MX, or MN respectively).
    2. The RANGE field specifies Common B via A and the 6681 FSC specifies a measurement function other than Time Interval A-B (6681 MOD3 field is not TI).
    3. The 6681 FSC specifies Frequency C (6681 MOD3 field is FC).

NOMINAL

This field specifies one the following:

  • Measuring Time entered as: [numeric][prefix]T.

    • Allowed values are: 0.8, 1.6, 3.2, 6.4, and 12.8us and 50us to 400s.

  • "*" Reset to defaults
  • blank

Rules:

  1. Measuring Time is not channel specific. It may be specified in a separate M681 statement or in conjunction with a channel A or channel B specification. Either way, the last Measuring Time specification prior to a 6681 statement is used.

TOLERANCE

This field specifies one of the following:

The Channel A or B Trigger Level entered as [numeric][prefix]V.
blank Auto Level (default) or not applicable.

Rules:

CON Field | Allowed values TOLERANCE field | Resolution
X1 | -5.10 V to +5.10 V | 0.02 V
X10 | -51.0 V to +51.0 V | 0.2 V
  1. The TOLERANCE field specifies the channel A trigger level when the RANGE field specifies Channel A or Common B via A.
  2. The TOLERANCE field specifies the channel B trigger level when the RANGE field specifies Channel B.
  3. The TOLERANCE field must be blank when the RANGE field is blank.
  4. Auto Level is specified when the TOLERANCE field is blank and the RANGE field specifies Channel A or Common B via A.
  5. Auto Level causes the attenuation and trigger level to be automatically controlled for both Input A and Input B.
  6. The TOLERANCE field specification is ignored when the 6681 FSC specifies Auto Level (6681 MOD2 field is not blank).
  7. If the TOLERANCE field does not contain a value the value is taken from memory register MEM.

MOD1

This field specifies one of the following:

The Channel A Low-Pass Filter entered as: numeric[prefix]H.
The Channel B Trigger Level entered as [numeric][prefix]V.
blankAuto Level (default) or not applicable.

Rules:

CON Field | Allowed values TOLERANCE field | Allowed values MOD1 | Resolution field
X1 | -5.10 V to +5.10 V | -5.10 V to +5.10 V | 0.02 V
X10 | -51.0 V to +51.0 V | -51.0 V to +51.0 V | 0.2 V
  1. The MOD1 field may specify the channel A low-pass filter only when the RANGE field specifies channel A.
  2. When the MOD1 field specifies the channel A low-pass filter, the value must be 100kHz.
  3. The MOD1 field may specify the channel B trigger level only when the RANGE specifies Common B via A.
  4. The MOD1 field must be blank when the RANGE field is blank or Auto Level is specified by the 6681 FSC (6681 MOD2 field is not blank).
  5. The MOD1 field specification is ignored when the MOD1 field specifies the channel B trigger level and the 6681 FSC specifies Auto Level (6681 MOD2 field is not blank).
  6. If the MOD1 field does not contain a value the value is taken from memory register MEM.

MOD2

This field specifies the input coupling:

  • AC
  • DC
  • blank

Rules:

Default Coupling
6681 MOD3 Field | 6681 MOD1 Field | Coupling
FA (Frequency A) | NA | AC
FC (Frequency C) | NA | NA
PA (Period A) | NA | AC
FR (Ratio A/B) | NA | AC
WA (Pulse Width A) | NA | DC
TI (Time Interval A-B) | NA | DC
PR (Phase A-B) | NA | AC
DA (Duty Factor A) | NA | DC
RF (Rise Time A) | NA | DC
MX (Voltage Max A) | <100 Hz | DC
 | ≥100 Hz | AC
MN (Voltage Min A) | <100 Hz | DC
 | ≥100 Hz | AC

Rules:

  2. Default values are used when the 6681 FSC does not specify the input coupling (6681 MOD2 field is blank) and one of the following conditions exists:
    1. No M681 statement has been executed.
    2. The last M681 statement executed was a M681 Reset.
    3. The M681 MOD2 field is blank and the M6816681 RANGE field specifies Channel A, Channel B, or Common B via A.
  3. The MOD2 field must be blank when the RANGE field is blank.
  4. The MOD2 field must specify AC or DC when TOLERANCE field specifies the trigger level.
  5. The MOD2 field specification is ignored when the 6681 FSC specifies the input coupling (6681 MOD2 field is not blank).

MOD3

This field specifies the trigger slope:

+ | Positive, Channel A or B
- | Negative, Channel A or B
++ | Positive Channel A and B
+- | Positive Channel A, Negative Channel B
-+ | Negative Channel A, Positive Channel B
-- | Negative Channel A and B
blank |

Rules:

  1. The MOD3 field must be blank when the RANGE field is blank.
  2. The MOD3 field may specify "+" or "-" only when the RANGE field specifies Channel A (CHA) or Channel B (CHB).
  3. The MOD3 field may specify "++", "+-", "-+", or "--" only when the RANGE field specifies Common B via A (COM).
  4. The MOD3 field specification is ignored when the 6681 FSC specifies the trigger slope (6681 MOD2 field is not blank).

MOD4

This field specifies that an external reference oscillator is to be used:

X | External Reference Oscillator
blank |

Rules:

  1. A M681 reset statement, NOMINAL field is an "*", must be used to re-select the internal reference once the external reference is selected.

CON

This field specifies the Attenuation. Legal entries are:

  • X1 (default)
  • X10
  • blank

Rules:

  1. The CON field must be blank when the RANGE is blank.
  2. The CON field must not be blank when the TOLERANCE field specifies the trigger level.
  3. The CON field specification is ignored when the 6681 FSC specifies Auto Level (6681 MOD2 field is not blank).

Examples

Refer to 6681 FSC.


6685

Instrument FSC

Description

The 6685 FSC programs the Fluke/Philips PM 6685 or Wavetek 905 Timer/Counter to measure frequency, frequency ratio, period, pulse width, and duty factor. When the 6685 and M685 FSCs are used to control a Fluke PM 6685 or Wavetek 905, you must configure the instrument as a "Philips PM 6685" as shown in the drop-down list in the "Add Instrument" configure dialog.

Parameters

The following table shows the relationship between the supported PM 6685 measurement functions and the FSC fields listed.

Function | MOD3 | NOMINAL Value | MOD1 Value
Frequency A | FA | 10 Hz to 300 MHz | 30 mVpp to 70 Vpp
 |  |  | 15 mVp to 35 Vp
 |  |  | 10 mVrms to 25 Vrms
Frequency C (PM 6685 Opt PM 9621) | FC | 70 MHz to 900 MHz | 10 mV to 12V
 |  |  | -27 dBm to +35 dBm
 |  | >900 MHz to 1.1 GHz | 15 mV to 12 V
 |  |  | -24 dBm to +35 dBm
 |  | >1.1GHz to 1.3 GHz | 40 mV to 12 V
 |  |  | -15 dBm to +35 dBm
Frequency C (PM 6685 Opt PM 9624) | FC | 100 MHz to <300 MHz | 20 mV to 12 V
 |  |  | -21 dBm to +35 dBm
 |  | 300 MHz to 2.5 GHz | 10 mV to 12 V
 |  |  | -27 dBm to +35 dBm
 |  | >2.5 GHz to 2.7 GHz | 20 mV to 12 V
 |  |  | -21 dBm to +35 dBm
Frequency C (PM 6685 Opt PM 9625) | FC | 150 MHz to <300 MHz | 20 mV to 1 V
 |  |  | -21 dBm to +13 dBm
 |  | 300 MHz to 2.5 GHz | 10 mV to 1 V
 |  |  | -27 dBm to +13 dBm
 |  | >2.5 GHz to 3.7 GHz | 15 mV to 1 V
 |  |  | -24 dBm to +13 dBm
 |  | >3.7 GHz to 4.2 GHz | 25 mV to 1 V
 |  |  | -19 dBm to +13 dBm
 |  | >4.2 GHz to 4.5 GHz | 50 mV to 1 V
 |  |  | -13 dBm to +13 dBm
Frequency C (PM 6681 Opt PM 9638) | FC | 300 MHz to <500 MHz | 20 mV to 7 V
 |  |  | -21 dBm to +30 dBm
 |  | 500 MHz to 3.0 GHz | 10 mV to 7 V
 |  |  | -27 dBm to +30 dBm
 |  | >3.0 GHz to 4.5 GHz | 20 mV to 7 V
 |  |  | -21 dBm to +30 dBm
 |  | >4.5 GHz to 6.0 GHz | 40 mV to 7 V
 |  |  | -15 dBm to +30 dBm
 |  | >6.0 GHz to 8.0 GHz | 80 mV to 7 V
 |  |  | -9 dBm to +30 dBm
Ratio C/A | FR | 10-7 to 1010 | 30 mVpp to 70 Vpp
 |  |  | 15 mVp to 35 Vp
 |  |  | 10 mVrms to 25 Vrms
Period A | PA | 6 ns to 100 ms | 30 mVpp to 70 Vpp
 |  |  | 15 mVp to 35 Vp
 |  |  | 10 mVrms to 25 Vrms
Pulse Width A | WA | 3 ns to 10 ms | 100 mVpp to 70 Vpp
 |  |  | 50 mVp to 35 Vp
Duty Factor A | DA | 0 to 1 | 50 Hz to 160 MHz

RANGE

This field specifies the UUT range as described in the RANGE Field topic.

NOMINAL

This field specifies the expected measured value or a reset.

  • Frequency entered as [numeric][prefix]H.
  • Frequency Ratio entered as [numeric][prefix]H/H.
  • Period entered as [numeric][prefix]T.
  • Pulse Width entered as [numeric][prefix]T.
  • Duty Factor entered as [numeric][prefix]df.
  • Reset entered as *.

Rules:

  1. When the NOMINAL field contains only units, the value is obtained from the memory register MEM.
  2. If no NOMINAL field value is entered and all other fields are blank, an * is automatically inserted.

TOLERANCE

This field specifies the UUT tolerance as described in the TOLERANCE Field topic.

MOD1

For all measurements except duty factor, this field specifies the expected amplitude. For measurements of duty factor, this field specifies the expected frequency.

  • Voltage (RMS) entered as: [numeric][prefix]V
  • Voltage (Peak) entered as: [numeric][prefix]Vp
  • Voltage (Peak-to-Peak) entered as: [numeric][prefix]Vpp
  • Voltage (into 50 Ohms, dBm) entered as: [numeric][prefix]D
  • Frequency entered as numeric[prefix]H.

Rules:

  1. For Ratio C/A (FR) measurements, the MOD1 field specifies the expected amplitude on channel A, not channel C.

MOD2

This field specifies the trigger slope as follows:

+A | Positive
-A | Negative
blank |

Rules:

  1. When the MOD2 field is blank, the trigger slope defaults to positive unless specified otherwise using the M685 FSC.
  2. +A is inserted automatically in the MOD2 field when the MOD3 field specifies Frequency C (FC).

MOD3

This field specifies the measurement function:

FA | Frequency A (default)
FC | Frequency C
FR | Ratio C/B
PA | Period A
WA | Pulse Width A
DA | Duty Factor A

Rules:

  1. The MOD3 field may specify Frequency C (FC) and Ratio C/A (FR) only when a High Frequency Input, PM 6685 option PM 9621, PM 9624, PM 9625, or PM 9638 or 905 Option 10 is installed.

MOD4

This field specifies the type of test being performed as described in the MOD4 Field topic.

CON

This field specifies the UUT connection.

blank | 1MΩ Input Impedance
L | 50 Ω Input Impedance
2W | 2-Wire

Rules:

  1. For Ratio C/A (FR) measurements, the CON field specifies the impedance of the channel A input, not the channel C input.
  2. L is inserted automatically in the CON field when the MOD3 field specifies Frequency C (FC).
  3. 2W is allowed for compatibility with previous versions of MET/CAL.

Use of Standard Memory Locations and Results Reporting

System memory locations MEM and MEM1 are used. For more information, refer to the Use of Standard Memory Registers topic.

Examples

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
# ----- Reset -----
  1.001  M685         *
  1.002  6685         *                                                 S
# ----- Frequency A -----
  1.003  M685   ChA                  100mV         100kH
  1.004  6685         10kH           1%            1Vpp              FA
# ----- Frequency C -----
  2.001  6685         300MH          0.1%          2D             +A FC    L
# ----- Period A -----
  3.001  M685         *
  3.002  6685         1.000mT        0.003U        5V                PA
# ----- Ratio C/A -----
  4.001  6685         10H/H          1%            1Vpp              FR
# ----- Pulse Width A -----
  5.001  6685         300uT          5%            5Vp               WA
# ----- Duty Factor A -----
  6.001  6685         0.30DF         2%            100H              DA


M685

Instrument Setup FSC

Description

The M685 FSC provides the additional program functions for Channel A of the Fluke/Philips PM 6685 Timer/Counter which are not addressed by the 6685 FSC. These functions include Measuring Time, and Channel A Trigger Sensitivity and Low-pass Filter.

RANGE

This field specifies the Channel.

ChA | Channel A
blank |

Rules:

  1. ChA is inserted automatically when the RANGE field is left blank and the TOLERANCE field specifies the channel A trigger sensitivity or the MOD1 field specifies the channel A low-pass filter.
  2. The M685 statement is ignored when the 6685 FSC specifies Frequency C (6685 MOD3 field is FC).

NOMINAL

This field specifies one of the following:

  • Measuring Time entered as [numeric][prefix]T. Allowed values are 800ns, 1.6us, 3.2us, 6.4us, 12.8us, and 50us to 400s.
  • "*" Reset to defaults
  • blank

TOLERANCE

This field specifies one of the following:

  • Channel A Trigger Sensitivity entered as [numeric][prefix]V.
  • blank Auto Level (default)

Rules:

  1. Allowed values for trigger sensitivity are 27.12 mV to 75.4 V.
  2. The TOLERANCE field specification is ignored when the 6685 FSC specifies Auto Level (6685 MOD2 field is not blank).
  3. If the TOLERANCE field does not contain a value the value is taken from memory register MEM.

MOD1

This field specifies one of the following:

  • Channel A low-pass filter entered as: numeric[prefix]H.
  • blank

Rules:

  1. When the MOD1 field specifies the Channel A low-pass filter, the value must be 100kH.
  2. A M685 reset statement, NOMINAL field is an "*", must be used to disable the Channel A low-pass filter once it is enabled.

MOD2

This field is not used.

MOD3

This field specifies the Channel A trigger slope:

+ | Positive (default)
- | Negative
blank |

Rules:

  1. The MOD3 field specification is ignored when the 6685 FSC specifies the trigger slope (6685 MOD2 field is not blank).

MOD4

This field specifies that an external reference oscillator is to be used:

blank

Rules:

  1. A M685 reset statement, NOMINAL field is an "*", must be used to re-select the internal reference once the external reference is selected.

CON

This field is not used.

Examples

See 6685 FSC.


6690

Instrument FSC

Description

The 6690 FSC programs the Fluke PM 6690 Timer/Counter to measure frequency, frequency ratio, period, time interval, phase, pulse width, duty factor, rise and fall time, voltage min and max, and voltage peak-to- peak. All PM 6690 capabilities are not supported. To program unsupported functions, use the SCPI or IEEE FSC.

The 6690 FSC can also be used to control the Tektronix FCA3000 and FCA3100 Series Timer/Counters, by configuring as shown in this table:

Device Name | Configure As...
Tektronix FCA3000 | "Fluke PM 6690"
Tektronix FCA3003 | "Fluke PM 6690" with PM 6690/6xx (100 MHz - 3 GHz) Channel C
Tektronix FCA3020 | "Fluke PM 6690" with PM 6690/8xx (200 MHz - 20 GHz) Channel C
Tektronix FCA3100 | "Fluke PM 6690"
Tektronix FCA3103 | "Fluke PM 6690" with PM 6690/6xx (100 MHz - 3 GHz) Channel C
Tektronix FCA3120 | "Fluke PM 6690" with PM 6690/8xx (200 MHz - 20 GHz) Channel C

Parameters

The following table shows the relationship between the supported PM 6690 measurement functions and the FSC fields listed.

Function | MOD3 | NOMINAL | MOD1
Frequency A | FA | 0.001 Hz to 300 MHz | 30 mVpp to 10 Vpp 1

Frequency C

(PM 6690/6xx)

 FC 100 MHz to 300 MHz 20 mV to 12 V
300 MHz to 2.5 GHz | 10 mV to 12 V
2.5 GHz to 2.7 GHz | 20 mV to 12 V
2.7 GHz to 3.0 GHz | 40 mV to 12 V

Frequency C

(PM 6690/7xx)

 FC 0.2 GHz to 0.5 GHz 20 mV to 7 V
0.5 GHz to 3.0 GHz | 10 mV to 7 V
3.0 GHz to 4.5 GHz | 20 mV to 7 V
4.5 GHz to 6.0 GHz | 40 mV to 7 V
6.0 GHz to 8.0 GHz | 80 mV to 7 V

Frequency C

(PM 6690/9xx)

 FC 0.2 GHz to 0.5 GHz 20 mV to 7 V
0.5 GHz to 3.0 GHz | 10 mV to 7 V
3.0 GHz to 4.5 GHz | 20 mV to 7 V
4.5 GHz to 6.0 GHz | 40 mV to 7 V
6.0 GHz to 8.0 GHz | 80 mV to 7 V
8.0 GHz to 14.0 GHz | ?? mV to 7 V
Period A | PA | 3.3 ns to 1000 s | 30 mVpp to 10 Vpp 1
Ratio A/B | FR | 1E-9 to 1E+11 | 30 mVpp to 10 Vpp 1
Time Interval A-B | TI | 0 ns to 1E+6 s | 30 mVpp to 10 Vpp 1
Pulse Width A | WA | 1.6 ns to 1E+6 s | 30 mVpp to 10 Vpp 1
Rise/Fall Time A | RF | 700 ps to 1000 s | 30 mVpp to 10 Vpp 1
Phase A-B | PR | -180 deg to +360 deg | 0.01 Hz to 160 MHz
Duty Factor A | DA | 0.000001 to 0.999999 | 0.1 Hz to 300 MHz
Voltage Max A | MX | -5 V to 5 V 1 | blank (DC)
-5 Vp to 5 Vp 1 | 1 Hz to 300 MHz
Voltage Min A | MN | -5 V to 5 V 1 | blank (DC)
-5 Vp to 5 Vp 1 | 1 Hz to 300 MHz
Vpp A | PP | 0 Vpp to 10 Vpp 1 | 1 Hz to 300 MHz
  1. X1 attenuation. Multiply limits by 10 for X10 attenuation.

RANGE

This field specifies the UUT range as described in the RANGE Field topic.

NOMINAL

This field specifies the expected measured value or a reset.

  • Frequency entered as [numeric][prefix]H.
  • Frequency Ratio entered as [numeric][prefix]H/H.
  • Period entered as [numeric][prefix]T.
  • Time Interval entered as [numeric][prefix]T.
  • Phase entered as [numeric][prefix]deg.
  • Pulse Width entered as [numeric][prefix]T.
  • Duty Factor entered as [numeric][prefix]df.
  • Rise or Fall Time entered as [numeric][prefix]T.
  • Voltage max or min entered as [numeric][prefix]V or Vp.
  • Voltage peak-to-peak entered as [numeric][prefix]Vpp.
  • Reset entered as *.

Rules:

  1. When the NOMINAL field contains only units, the value is obtained from the memory register MEM.
  2. If no NOMINAL field value is entered and all other fields are blank, an * is automatically inserted.

TOLERANCE

This field specifies the UUT tolerance as described in the TOLERANCE Field topic.

MOD1

For measurements of frequency, frequency ratio, period, time interval, pulse width and rise/ fall time, this field specifies the expected amplitude. For measurements of phase, duty factor, voltage min/max of AC and voltage peak-to-peak, this field specifies the expected frequency. For measurements of voltage min/max of DC, this field should be blank.

  • Voltage (RMS) entered as: numeric[prefix]V
  • Voltage (Peak) entered as: numeric[prefix]Vp
  • Voltage (Peak-to-Peak) entered as: numeric[prefix]Vpp
  • Voltage (into 50 Ohms, dBm) entered as: numeric[prefix]D
  • Frequency entered as numeric[prefix]H.
  • blank

Rules:

  1. For Ratio A/B (FR) measurements, the MOD1 field specifies the expected amplitude on channel A, not channel B.

MOD2

This field specifies the trigger slope as follows:

  • +A Positive slope triggering, AC coupled
  • -A Negative slope triggering, AC coupled
  • +D Positive slope triggering, DC coupled
  • -D Negative slope triggering, DC coupled
  • blank

Rules:

  1. When the MOD2 field is blank, the trigger slope and coupling for channel A and B default to values determined by the measurement function unless otherwise specified using the M6690FSC.
  2. +A is inserted automatically in the MOD2 field when the MOD3 field specifies Frequency C (FC).

MOD3

This field specifies the measurement function:

  • FA Frequency A
  • FC Frequency C
  • PA Period A
  • FR Ratio A/B
  • TI Time Interval A to B
  • WA Pulse Width A
  • RF Rise or Fall Time A
  • PR Phase A Relative to B
  • DA Duty Factor A
  • MX Voltage Max A
  • MN Voltage Min A
  • PP Voltage Peak-to-Peak A

Rules:

  1. When MOD3 is "RF" and channel A trigger slope is positive, a rise time measurement is performed. When channel A trigger slope is negative a fall time measurement is performed.
  2. The MOD3 field may specify Frequency C (FC) only when a High Frequency Input, PM6690/6xx, PM6690/7xx, or PM6690/9xx is installed.

MOD4

This field specifies the type of test being performed as described in the MOD4 Field topic.

CON

This field specifies the UUT connection.

blank | 1 MΩ Input Impedance
L | 50 Ω Input Impedance

Rules:

  1. L is inserted automatically in the CON field when the MOD3 field specifies Frequency C (FC).

Use of Standard Memory Locations and Results Reporting

System memory locations MEM and MEM1 are used. For more information, refer to the Use of Standard Memory Registers topic.

Examples

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
# ----- Reset -----
  1.001  M6690        *
  1.002  6690         *                                                 S
# ----- Frequency A -----
  1.003  M6690  ChA                                100kH
  1.004  6690         10.000kH       1%            1Vpp           +A FA
# ----- Frequency C -----
  2.001  6690         200MH          0.1%          -1D            +A FC    L
# ----- Period A -----
  3.001  M6690        *
  3.002  6690         1.000mT        0.003U        5V             +A PA
# ----- Ratio A/B -----
  4.001  M6690  ChA                                               AC
  4.002  M6690  ChB                                               DC
  4.003  6690         10H/H          1%            1Vpp              FR
# ----- Time Interval A to B -----
  5.001  M6690  COM   20T            0.2V          0.8V           DC ++    X1
  5.002  6690         10.00T         0.02U         1Vpp              TI
# ----- Pulse Width A -----
  6.001  M6690        *
  6.002  6690         300uT          5%            5Vp            -A WA
# ----- Rise Time A -----
  7.001  6690         100nT          5%            1Vpp              RF
# ----- Phase A relative to B -----
  8.001  M6690        *
  8.002  6690         30deg          1U            10kH              PR    L
# ----- Duty Factor A -----
  9.001  6690         0.30DF         2%            100H              DA


M6690

Instrument FSC

Description

The M6690 FSC provides the additional program functions for Channel A and Channel B of the Frequency Counter/Timer/Analyzer which are not addressed by the 6690 FSC. These functions include:

  • Common B via A
  • Measuring Time
  • Trigger Level
  • Trigger Slope
  • Input Coupling
  • Input Impedance
  • Input Attenuation

RANGE

This field specifies the Channel.

  • ChA Channel A
  • ChB Channel B
  • COM Common B via A
  • blank

Rules:

  1. The M6690 statement is ignored under the following conditions:

    1. The RANGE field specifies Channel B and the 6690 FSC specifies Frequency A, Period A, Pulse Width A, Voltage Max A, or Voltage Min A (6690 MOD3 field is FA, PA, WA, MX, or MN respectively).
    2. The RANGE field specifies Common B via A and the 6690 FSC specifies a measurement function other than Time Interval A-B (6690 MOD3 field is not TI).
    3. The 6690 FSC specifies Frequency C (6690 MOD3 field is FC).

NOMINAL

This field specifies one the following:

  • Measuring Time entered as: numeric[prefix]T. Allowed 20 ns to 1000 s
  • "*" Reset to defaults
  • blank

Rules:

  1. Measuring Time is not channel specific. It may be specified in a separate M6690 statement or in conjunction with a channel A or channel B specification. Either way, the last Measuring Time specification prior to a 6690 FSC statement is used.

TOLERANCE

This field specifies one of the following:

  • The Channel A or B Trigger Level entered as [numeric][prefix]V.
  • blank Auto Level (default) or not applicable.

Rules:

CON Field | Allowed values TOLERANCE Field | Resolution
X1 | -5.000 V to +5.000 V | 1 mV
X10 | -50.00 V to +50.00 V | 10 mV
  1. The TOLERANCE field specifies the channel A trigger level when the RANGE field specifies Channel A or Common B via A.
  2. The TOLERANCE field specifies the channel B trigger level when the RANGE field specifies Channel B.
  3. The TOLERANCE field must be blank when the RANGE field is blank.
  4. Auto Level is specified when the TOLERANCE field is blank and the RANGE field specifies Channel A or Common B via A.
  5. Auto Level causes the attenuation and trigger level to be automatically controlled for both Input A and Input B.
  6. The TOLERANCE field specification is ignored when the 6690 FSC specifies Auto Level (6690 MOD2 field is not blank).
  7. If the TOLERANCE field does not contain a value the value is taken from memory register MEM.

MOD1

This field specifies one of the following:

  • The Channel A Low-Pass Filter entered as: numeric[prefix]H.
  • The Channel B Trigger Level entered as [numeric][prefix]V.
  • blankAuto Level (default) or not applicable.

Rules:

CON Field | Allowed values TOLERANCE Field | Allowed Values MOD1 Field | Resolution
X1 | -5.000 V to +5.000 V | -5.000 V to +5.000 V | 1 mV
X10 | -50.00 V to +50.00 V | -50.00 V to +50.00 V | 10 mV
  1. The MOD1 field may specify the channel A low-pass filter only when the RANGE field specifies channel A.
  2. When the MOD1 field specifies the channel A low-pass filter, the value must be 100 kHz.
  3. The MOD1 field may specify the channel B trigger level only when the RANGE specifies Common B via A.
  4. The MOD1 field must be blank when the RANGE field is blank or Auto Level is specified by the 6690 FSC (6690 MOD2 field is not blank).
  5. The MOD1 field specification is ignored when the MOD1 field specifies the channel B trigger level and the 6690 FSC specifies Auto Level (6690 MOD2 field is not blank).
  6. If the MOD1 field does not contain a value the value is taken from memory register MEM.

MOD2

This field specifies the input coupling:

  • AC
  • DC
  • blank
Table 3: Default Coupling
6690 FSC MOD3 Field | 6690 FSC MOD1 Field | Coupling
FA (Frequency A) | NA | AC
FC (Frequency C) | NA | NA
PA (Period A) | NA | AC
FR (Ratio A/B) | NA | AC
WA (Pulse Width A) | NA | DC
TI (Time Interval A-B) | NA | DC
PR (Phase A-B) | NA | AC
DA (Duty Factor A) | NA | DC
RF (Rise Time A) | NA | DC
MX (Voltage Max A) | < 100 Hz | DC
 | ≥ 100 Hz | AC
MN (Voltage Min A) | < 100 Hz | DC
 | ≥ 100 Hz | AC

Rules:

  1. Default values are used when the 6690 FSC does not specify the input coupling (6690 MOD2 field is blank) and one of the following conditions exists:
    1. No M6690 statement has been executed.
    2. The last M6690 statement executed was a M6690 Reset.
    3. The M6690 MOD2 field is blank and the M66906690 RANGE field specifies Channel A, Channel B, or Common B via A.
  2. The MOD2 field must be blank when the RANGE field is blank.
  3. The MOD2 field must specify AC or DC when TOLERANCE field specifies the trigger level.
  4. The MOD2 field specification is ignored when the 6690 FSC specifies the input coupling (6690 MOD2 field is not blank).

MOD3

This field specifies the trigger slope:

+ | Positive, Channel A or B
- | Negative, Channel A or B
++ | Positive Channel A and B
+- | Positive Channel A, Negative Channel B
-+ | Negative Channel A, Positive Channel B
-- | Negative Channel A and B
blank |

Rules:

  1. The MOD3 field must be blank when the RANGE field is blank.
  2. The MOD3 field may specify "+" or "-" only when the RANGE field specifies Channel A (CHA) or Channel B (CHB).
  3. The MOD3 field may specify "++", "+-", "-+", or "--" only when the RANGE field specifies Common B via A (COM).
  4. The MOD3 field specification is ignored when the 6690 FSC specifies the trigger slope (6690 MOD2 field is not blank).

MOD4

This field specifies that an external reference oscillator is to be used:

  • X External Reference Oscillator
  • blank

Rules:

  1. A M6690 reset statement, NOMINAL field is an "*", must be used to re-select the internal reference once the external reference is selected.

CON

This field specifies the Attenuation. Legal entries are:

  • X1 (default)
  • X10
  • blank

Rules:

  1. The CON field must be blank when the RANGE is blank.
  2. The CON field must not be blank when the TOLERANCE field specifies the trigger level.
  3. The CON field specification is ignored when the 6690 FSC specifies Auto Level (6690 MOD2 field is not blank).

Examples

Refer to 6690 FSC.


SMY02

Instrument FSC

Description

The SMY02 FSC programs amplitude and frequency of the Rohde & Schwarz SMY01, SMY02, SMY43 Signal Generators.

Functional Capability

Model | Frequency | Amplitude 1
SMY01 | 9 kHz to 1040 MHz | -140 dBm to +13 dBm
SMY02 | 9 kHz to 2080 MHz | -140 dBm to +13 dBm
SMY43 | 9 kHz to 2080 MHz | -140 dBm to +13 dBm
  1. +19dBm with Option B43

Parameters

RANGE

This field specifies the UUT range as described in the RANGE Field topic.

NOMINAL

This field specifies the amplitude, frequency, period, or reset.

  • Amplitude entered as: [numeric][prefix]D, V, or Vpp.
  • Frequency entered as [numeric][prefix]H.
  • Period entered as [numeric][prefix]T.
  • Reset entered as *.

Rules:

  1. When the NOMINAL field specifies the amplitude, the MOD1 field must specify the frequency or period.
  2. When the NOMINAL field specifies the frequency or period, the MOD1 field must specify the amplitude.

TOLERANCE

This field specifies the UUT tolerance as described in the TOLERANCE Field topic.

MOD1

This field specifies the amplitude, frequency, or period.

  • Frequency entered as [numeric][prefix]H.
  • Period entered as [numeric][prefix]T.
  • Amplitude entered as: [numeric][prefix]D, V, or Vpp.

Rules:

  1. When the MOD1 field specifies the frequency or period, the NOMINAL field must specify the amplitude.
  2. When the MOD1 field specifies the amplitude, the NOMINAL field must specify the frequency or period.

MOD2

This field specifies whether "/div" is include in after the value in the automatic range message.

-D | "/div" is not included
blank | "/div" is included if ASK+ D is in effect

Rules:

  1. The MOD2 field is automatically set to -D for a Setup Test.

MOD3

This field is not used.

MOD4

This field specifies the type of test being performed as described in the MOD4 Field topic.

CON

This field is specifies which output port is used for the signal.

CH1 | Fluke 58xxA Channel 1
CH2 | Fluke 58xxA Channel 2
CH3 | Fluke 58xxA Channel 3
CH4 | Fluke 58xxA Channel 4
CH5 | Fluke 58xxA Channel 5
blank | SMYxx RF Output

Rules:

  1. The CON field may specify CH1 or CH5 only when a Fluke 5800A is configured.
  2. The CON field may specify CH2, CH3, or CH4 only when a Fluke 5800A is configured with the 5800A-5 Five Channel option.

Use of Standard Memory Locations and Results Reporting

System memory locations MEM and MEM1 are used. For more information, refer to the Use of Standard Memory Registers topic.

Examples

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
# -----  Reset  -----
  1.001  SMY02        *                                                 S
  1.002  SMY02  A     -42.95D        1U            100kH          -D
  2.001  SMY02        100mV                        550MH          -D    S
  2.002  SMY02  0.5   28mVpp         5U            100kH          -D
  3.001  SMY02  A     D              1U            100kH          -D
  4.001  SMY02        V              1%            100kH          -D
  5.001  SMY02  50    10uT           1% 1/ 1U      -35D
  6.001  SMY02  200   100nT          1% 1/ 1U      1Vpp
# -----  Oscilloscope bandwidth test  -----
  7.001  ASK-                                                     F        W
  7.002  ASK+     D
  7.003  DISP         Connect the 5800A channel 1 to UUT channel 1.
  7.004  DISP         Set UUT to 20us/div.
  7.005  SMY02  20    120mVpp                      100kH                N  CH1
  7.006  ASK-         N
  7.007  MESS         Adjust stimulus for a UUT vertical reading of 4.2 div.
  7.008  SMY02        5MH            -100%         mVpp           -D       CH1
  8.001  MESS
  8.002  ASK+         N


MSMY02

Auxiliary Instrument Setup FSC

Description

The MSMY02 FSC provides the additional program functions for the Rohde & Schwarz SMY01, SMY02, and SMY34 Signal Generators which are not addressed by the SMY02 FSC. These functions are: Modulation Frequency, AM Depth, FM Deviation, and Phase Deviation.

RANGE

Not used.

NOMINAL

The NOMINAL field specifies the modulation frequency or a reset.

Modulation Frequency:

When the NOMINAL field is used to specify the modulation frequency, the format is [numeric][prefix]H. Allowed values are 1 Hz to 500 kHz.

If just units are entered, the value is taken from memory register MEM at run time.

Reset

To specify a reset, enter an asterisk (*) in the NOMINAL field. This resets all previous settings created with the MSMY02 FSC.

TOLERANCE

Not used.

MOD1

The MOD1 field specifies the AM depth, FM deviation, or phase deviation. The MOD1 field cannot be blank in an SMY02 statement.

AM Depth

AM depth is entered as numeric[prefix]pct. AM depth limits are 0 to 100%.

FM Deviation

FM deviation is entered as numeric[prefix]H.

FM deviation depends upon the carrier frequency as shown in the table below:

Carrier Frequency | FM Deviation
< 65 MHz | 0 to 10.0 MHz
< 130 MHz | 0 to 1.25 MHz
< 260 MHz | 0 to 2.50 MHz
< 520 MHz | 0 to 5.00 MHz
< 1040 MHz | 0 to 10.0 MHz
< 2080 MHz | 0 to 20.0 MHz

Phase Deviation

Phase deviation is entered as numeric[prefix]rad.

Phase deviation depends upon the carrier frequency as shown in the table below:

Carrier Frequency | Phase Deviation
< 65 MHz | 0 to 200 rad
< 130 MHz | 0 to 25 rad
< 260 MHz | 0 to 50 rad
< 520 MHz | 0 to 100 rad
< 1040 MHz | 0 to 200 rad
< 2080 MHz | 0 to 400 rad

MOD2

Not used.

MOD3

Not used.

MOD4

Not used.

CON

Not used.

Examples

# AM Modulation
  1.001  MSMY02       *
  1.002  MSMY02       400H                         0pct
  1.003  SMY02  10    0D             1U            10MH
  2.001  MSMY02       1000H                        90pct
  2.002  SMY02  10    0D             1U            10MH
# FM Modulation
  3.001  MSMY02       400H                         100H
  3.002  SMY02  10    0D             0.11U         200kH
  4.001  MSMY02       1000H                        99.9kH
  4.002  SMY02  10    0D             0.1U          1000MH
# Phase Modulation
  5.001  MSMY02       400H                         2rad
  5.002  SMY02  10    0D             0.11U         200kH
  6.001  MSMY02       1000H                        10rad
  6.002  SMY02  10    0D             0.1U          1000MH


5001

Instrument FSC

Description

The 5001 FSC programs the Tektronix CG 5001 or CG 551AP Calibration Generator to provide the following:

  • Voltage to check vertical and horizontal gain.
  • Current to check current probes and amplifiers.
  • Edges to check the transient response of amplifiers and attenuator networks.
  • Markers & Slewed Edge to check the timing accuracy of horizontal sweep rates.
  • Comparator Test to check the accuracy of calibratoroutputs.
When the 5001 and MCAL FSCs are used to control an CG 551AP, you must configure the instrument as an "Tektronix CG5001" as shown in the drop-down list in the "Add Instrument" configure dialog.

Functional Capability

Function | Nominal | MOD1
Amplitude Mode: Voltage | 40 mVpp to 80 mVpp 3 | 10 Hz, 100 Hz, 1 kHz, 10 kHz
100 mVpp to 5 Vpp 3 | DC, 10 Hz, 100 Hz, 1 kHz, 10 kHz, 100 kHz
6 Vpp to 10 Vpp 2 | DC, 10 Hz, 100 Hz, 1 kHz, 10 kHz, 100 kHz
12 Vpp to 200 Vpp 2 | DC, 10 Hz, 100 Hz, 1 kHz, 10 kHz
Amplitude Mode: Current | 1 mApp to 100 mApp | DC, 10 Hz, 100 Hz, 1 kHz, 10 kHz, 100 kHz, 1 MHz
Amplitude Mode: Edge | 20 mVpp to 1 Vpp 1 | 10 Hz, 100 Hz, 1 kHz, 10 kHz, 100 kHz, 1 MHz
1.2 Vpp to 100 Vpp 2 | 10 Hz, 100 Hz, 1 kHz, 10 kHz, 100 kHz
Amplitude Mode: Fast Edge | 1.1 Vpp 1 | 100 Hz, 1 kHz, 10 kHz, 100 kHz
Amplitude Mode: Comparator | 100 mVpp to 100 Vpp | DC, 10 Hz, 100 Hz, 1 kHz, 10 kHz, 100 kHz
Timing Mode: Slewed Edge 0.4 ns & 0.5 ns - 10 ns
2.5 GHz to 100 MHz 1
Timing Mode: Markers 10 ns to 5 s,
100 MHz to 0.2 Hz 1
  1. 50 Ω Load
  2. ≥1 MΩ Load
  3. 50 Ω or ≥1 MΩ Load

Parameters

RANGE

This field specifies the UUT range as described in the RANGE Field topic.

NOMINAL

This field specifies the voltage or current for Amplitude Mode or the period or frequency for Timing

Mode.

  • Voltage entered as: [numeric][prefix]Vpp
  • Current entered as [numeric][prefix]A.
  • Period entered as [numeric][prefix]T.
  • Frequency entered as [numeric][prefix]H.
  • Reset entered as *.

Rules:

  1. Amplitude Mode cardinal values are within the specified range and a decade value of one of the following factors: 1, 1.2, 1.5, 1.6, 2, 2.5, 3, 4, 5, 6, 7, or 8.
  2. The Timing Mode cardinal values are within the specified range and a decade value of one of 1, 2, or 5.
  3. The NOMINAL field entries must be within 9.9% of these cardinal values.
  4. For Edge (MOD3 = E) and Fast Edge (MOD3 = FE) modes, the edge polarity is selected as follows:
    • NOMINAL > 0 = Positive Edge
    • NOMINAL < 0 = Negative Edge

TOLERANCE

This field specifies the UUT tolerance as described in the TOLERANCE Field topic.

MOD1

This field specifies the frequency for Amplitude Mode.

  • Frequency entered as numeric[prefix]H.
  • blank not applicable

Rules:

  1. The MOD1 field may specify frequency only when the NOMINAL field specifies voltage or current.

MOD2

This field specifies whether "/div" is include in after the value in the automatic range message.

  • -D"/div" is not included
  • blank"/div" is included if ASK+ D is in effect

Rules:

  1. The MOD2 field is automatically set to -D for a Setup Test.

MOD3

This field specifies the function when Amplitude Mode is specified and the NOMINAL field units are volts:

blank | Voltage or not applicable
E | Edge
FE | Fast Edge
CO | Comparator

Rules:

  1. The MOD2 field must be blank when the NOMINAL field units are not volts.

MOD4

This field specifies the type of test being performed as described in the MOD4 Field topic.

CON

This field specifies the input impedance that should be present at the Unit Under Test (UUT).

blank1 | MΩ or greater
L | 50 Ω

Rules:

  1. The CON field must be blank for:
    1. Voltage > 5 Vpp
    2. Current
    3. Edge > 1.1 Vpp
    4. Slewed Edge (5001 only)
    5. Markers
  2. The CON field may be either L or blank for comparator tests with voltage <5 Vpp.
  3. When the CON field is L, the procedure writer must instruct the operator to select the 50 Ω input impedance on the UUT or instruct the operator to use a 50 Ω termination at the UUT.

Use of Standard Memory Locations and Results Reporting

System memory locations MEM and MEM1 are used. For more information, refer to the Use of Standard Memory Registers topic.

Examples

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
# ----- Reset -----
  1.001  5001         *                                                 S
# ----- Amplitude Mode: Current -----
  1.002  5001         100mA          0.1%          100kH          -D
# ----- Amplitude Mode: Voltage -----
  2.001  5001   5     40uVpp         1%            10H            -D
# ----- Amplitude: Edge -----
  3.001  5001   100   20mVpp         1%            1kH            -D E     L
# ----- Amplitude Mode: Fast Edge -----
  4.001  5001         1.1Vpp                       10kH           -D FE S  L
# ----- Timing Mode: Slewed Edge -----
  4.002  5001   5     2.5GH          1%
# ----- Timing Mode: Markers -----
  5.001  5001   10    10nT           1%
# ----- Amplitude Mode: Comparator Function -----
  6.001  5001   10    100mVpp        1%            1kH               CO


MCAL

Instrument Setup FSC

Description

The MCAL FSC provides additional program functions for the Tektronix CG 5001 and CG 551AP Calibration Generator, not addressed in the 5001 FSC.

  • The special functions specified by the MCAL FSC will become effective in the first 5001 FSC that follows the MCAL FSC and remain in effect until they are disabled or changed by another MCAL FSC.
  • To return back to the original settings, use:

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
  1.001  MCAL         10P                          15,0E                   1T

Parameters

RANGE

Not used.

NOMINAL

The Nominal field specifies the minimum repetition rate that the CG5001 is allowed to use for the Markers mode before switching to the Slewed Edge mode.

  • This value is entered by: repetition rateP
  • The allowed values are expressed in nanoseconds and must be one of 10, 20, 50, 100, or 200.
  • If no value is entered, the default value of 10P (for 10ns) is automatically entered.

TOLERANCE

Not used.

MOD1

The MOD1 field specifies the number of edges and how far the first edge is shifted from the trigger pulse for the Slewed Edge mode. These values are entered in the following format:

number of edges,number of shiftsE

  • The allowed values for the number of edges are integers ranging from 1 to 15.
  • The allowed values for the number shifts are integers ranging from -99 to +99.
  • If no value is entered for the first parameter (no comma is entered), then a default value of 15,number of shiftsE is entered.
  • If no value is entered for the second parameter, than a default value of number of edges,0E is entered.
  • If no value is entered at all, then a default value of 15,0E is entered.

MOD2

The MOD2 specifies that every tenth pulse of the Marker mode is to be accentuated.

  • This function is entered by entering the character 'M' in the MOD2 field.
  • If nothing is entered then the Magnifier is disabled.
  • M may be used with 5001 nominal values greater than 1 us or less than 1 MHz.

MOD3

The MOD3 field specifies whether narrow markers should be used for slow marker repetition rates.

  • The narrow markers functions are selected by entering the character 'N' in this field.
  • If nothing is entered, the markers are returned to their normal widths.
  • N may be used with nominal values between 10us to 5s.

MOD4

The MOD4 field specifies a 100ns delay between the trigger and the fast-edge pulse. This delay is useful for oscilloscopes that have no internal delay between the trigger and vertical amplifier inputs.

  • This delay is programmed by entering a 'D' in this field.
  • If nothing is entered, the 100ns delay is disabled.

CON

The CON field specifies the Trigger Rate for all functions except the Slewed Edge function. Allowed entries are:

CON entry | Effect
0T | Turn off the trigger
1T | Turn on trigger in Normal Mode
2T | Turn on trigger at x .1 of output rate
3T | Turn on trigger at x .01 of output rate
The default value entered is ‘1T’.

Miscellanoues

The interrelationships between the MCAL and 5001 FSCs are not verified when the procedure is compiled. Errors reported during procedure execution may occur as a result of improper parameter combinations.

Use Of Standard Memory Locations

The content of standard memory registers is not affected by the MCAL FSC.

Automatic Messages

There are no automatic messages created with the MCAL FSC.

Examples

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
  1.002  MCAL         10P                          15,0E                   1T
  1.003  MCAL         10P                          15,0E          M  N  D  1T


5011

Instrument FSC

Description

The 5011 FSC programs the Tegam and Tektronix CG 5011 Calibration Generators to provide the following:

  • Voltage to check vertical and horizontal gain.
  • Current to check current probes and amplifiers.
  • Edges to check the transient response of amplifiers and attenuator networks.
  • Markers to check the timing accuracy of horizontal sweep rates.
  • Comparator Test to check the accuracy of calibrator outputs.
When the 5011 and M511 FSCs are used to control a Tegam CG 5011, you must configure the instrument as an "Tekronix CG5011" as shown in the drop-down list in the "Add Instrument" configure dialog.

Functional Capability

Function | Nominal | MOD1
Amplitude Mode: Voltage | 40 mVpp to 80 mVpp 3 | 10 Hz, 100 Hz, 1 kHz, 10 kHz
100 mVpp to 5 Vpp 3 | DC, 10Hz, 100Hz, 1kHz, 10kHz, 100kHz
6 Vpp to 10 Vpp 2 | DC, 10Hz, 100Hz, 1kHz, 10kHz, 100kHz
12 Vpp to 200 Vpp 2 | DC, 10 Hz, 100 Hz, 1 kHz, 10 kHz
Amplitude Mode: Current | 1 mApp to 100 mApp | DC, 10 Hz, 100 Hz, 1 kHz, 10 kHz,100 kHz, 1 MHz
Amplitude Mode: Edge | 20 mVpp to 1 Vpp 1 | 10 Hz, 100 Hz, 1 kHz, 10 kHz, 100 kHz, 1 MHz
1.2 Vpp to 100 Vpp 2 | 10 Hz, 100 Hz, 1 kHz, 10 kHz, 100 kHz
Amplitude Mode Fast Edge: 1.1 Vpp 1 100 Hz, 1 kHz, 10 kHz, 100 kHz
Amplitude Mode: Comparator | 100 mVpp to 100 Vpp | DC, 10 Hz, 100 Hz, 1 kHz, 10 kHz, 100 kHz
Timing Mode: Markers | 0.5 ns to 5 s
  1. 50 Ω Load
  2. ≥1 MΩ Load
  3. 50 Ω or ≥1 MΩ Load

Parameters

RANGE

This field specifies the UUT range as described in the RANGE Field topic.

NOMINAL

This field specifies the voltage or current for Amplitude Mode or the period or frequency for Timing

Mode.

  • Voltage entered as: [numeric][prefix]Vpp
  • Current entered as [numeric][prefix]A.
  • Period entered as [numeric][prefix]T.
  • Frequency entered as [numeric][prefix]H.
  • Reset entered as *.

Rules:

  1. Amplitude Mode cardinal values are within the specified range and a decade value of one of the following factors: 1, 1.2, 1.5, 1.6, 2, 2.5, 3, 4, 5, 6, 7, or 8.
  2. The Timing Mode cardinal values are within the specified range and a decade value of one of 1, 2, or 5.
  3. The NOMINAL field entries must be within 9.9% of these cardinal values.
  4. For Edge (MOD3 = E) and Fast Edge (MOD3 = FE) modes, the edge polarity is selected as follows:
    • NOMINAL >0Positive Edge
    • NOMINAL <0Negative Edge

TOLERANCE

This field specifies the UUT tolerance as described in the TOLERANCE Field topic.

MOD1

This field specifies the frequency for Amplitude Mode.

  • Frequency entered as [numeric][prefix]H.
  • blank not applicable

Rules:

  1. The MOD1 field may specify frequency only when the NOMINAL field specifies voltage or current.

MOD2

This field specifies whether "/div" is include in after the value in the automatic range message.

  • -D"/div" is not included
  • blank"/div" is included if ASK+ D is in effect

Rules:

  1. The MOD2 field is automatically set to -D for a Setup Test.

MOD3

This field specifies the function when Amplitude Mode

is specified and the NOMINAL field units are volts:

E | Edge
FE | Fast Edge
CO | Comparator

Rules:

  • The MOD2 field must be blank when the NOMINAL field units are not volts.

MOD4

This field specifies the type of test being performed as described in the MOD4 Field topic.

CON

This field specifies the input impedance that should be present at the Unit Under Test (UUT).

L 50 Ω

Rules:

  1. The CON field must be blank for:
    • Voltage > 5 Vpp
    • Current
    • Edge > 1.1 Vpp
    • Markers
  2. The CON field may be either L or blank for comparator tests with voltage <5 Vpp.
  3. When the CON field is L, the procedure writer must instruct the operator to select the 50 Ω input impedance on the UUT or instruct the operator to use a 50 Ω termination at the UUT.

Use of Standard Memory Locations and Results Reporting

System memory locations MEM and MEM1 are used. For more information, refer to the Use of Standard Memory Registers topic.

Examples

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
# Reset
  1.001  5011         *                                                 S
# Amplitude Mode: Current
  1.002  5011         100mA          0.1%          100kH          -D
# Amplitude Mode: Voltage
  2.001  5011   5     40uVpp         1%            10H            -D
# Amplitude: Edge
  3.001  5011   100   20mVpp         1%            1kH            -D E     L
# Amplitude Mode: Fast Edge
  4.001  5011         1.1Vpp                       10kH           -D FE S  L
# Timing Mode: Markers
  4.002  5011   10    0.5nT          1%
# Amplitude Mode: Comparator Function
  5.001  5011   10    100mVpp        1%            1kH               CO


M511

Auxiliary Instrument Setup FSC

Description

The M511 FSC provides additional program functions for the Tegam and Tektronix CG 5011 Calibration Generator, not addressed in the 5011 FSC.

  • The special functions specified by the M511 FSC will become effective in the first 5011 FSC that follows the M511 FSC and remain in effect until they are disabled or changed by another M511 FSC.
  • To return back to the original settings, use:

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
  1.001  M511                                                              1T

Parameters

RANGE

Not used.

NOMINAL

Not used.

TOLERANCE

Not used.

MOD1

Not used.

MOD2

The MOD2 specifies that every tenth pulse of the Marker mode is to be accentuated.

  • This function is entered by entering the character 'M' in the MOD2 field.
  • If nothing is entered then the Magnifier is disabled.
  • M may be used with 5011 nominal values greater than 1 us or less than 1 MHz.

MOD3

The MOD3 field specifies whether narrow markers should be used for slow marker repetition rates.

  • The narrow markers functions are selected by entering the character 'N' in this field.
  • If nothing is entered, the markers are returned to their normal widths.
  • N may be used with nominal values between 10us to 5s.

MOD4

The MOD4 field specifies a 100ns delay between the trigger and the fast-edge pulse. This delay is useful for oscilloscopes that have no internal delay between the trigger and vertical amplifier inputs.

  • This delay is programmed by entering a 'D' in this field.
  • If nothing is entered, the 100ns delay is disabled.

CON

The CON field specifies the Trigger Rate for all functions. Allowed entries are:

CON entry | Effect
0T | Turn off the trigger
1T | Turn on trigger in Normal Mode
2T | Turn on trigger at x .1 of output rate
3T | Turn on trigger at x .01 of output rate
The default value entered is '1T'.

MISCELLANEOUS

The interrelationships between the M511 and 5011 FSCs are not verified when the procedure is compiled. Errors reported during procedure execution may occur as a result of improper parameter combinations.

USE OF STANDARD MEMORY LOCATIONS

The content of standard memory registers is not affected by the M511 FSC.

AUTOMATIC MESSAGES

There are no automatic messages created with the M511 FSC.

Examples

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
  1.002  M511                                                              1T
  1.003  M511                                                     M  N  D  1T


M4050

Instrument FSC

Description

The M4040 and M4050 FSC provides the following functions for the Tektronix DMM4040 and DMM4050 Multimeters:

  • dB Reference
  • dBm Reference Impedance
  • Range Lock
  • NPLC
  • AC Detector Band (Filter)
  • External Trigger

Parameters

When a blank M4040/M4050 statement is entered, a "*" is inserted automatically in the NOMINAL field. See NOMINAL field parameter for a description of "*".

RANGE

This field specifies one of the following:

  • DBREF dB Reference
  • IMPED dBm Reference Impedance
  • RNGLK Range Lock
  • blank Not applicable

Rules:

  1. When the RANGE field specifies IMPED, the NOMINAL field must specify the reference impedance in ohms.
  2. When the RANGE field specifies RNGLK, the NOMINAL field must specify the range selection value.

NOMINAL

This field specifies the dB reference, dBm reference impedance, range lock selection value, or reset.

  • dB Reference entered as: numeric[prefix]D
  • dBm Reference Impedance entered as: numeric[prefix]Z
  • Voltage range entered as: numeric[prefix]V
  • Current range entered as: numeric[prefix]A
  • Resistance range entered as: numeric[prefix]Z
  • Capacitance range entered as: numeric[prefix]F
  • "*" Reset to default values

Rules:

  1. The NOMINAL field may specify a dB reference value only when the RANGE field is "DBREF".
  2. The NOMINAL field must specify a dB reference value when the 4040/4050 FSC Nominal field specifies dB.
  3. The NOMINAL field may specify a dBm reference impedance only when the RANGE field is "IMPED".
  4. The NOMINAL field must specify a dBm reference impedance when the 4040/4050 FSC Nominal field specifies dBm and the 4040/4050 FSC MOD2 field is not 3Z, 5Z, 6Z, or 7Z.
  5. Allowed values for dBm reference impedance are: 2 Ohm, 4 Ohm, 8 Ohm, 16 Ohm, 50 Ohm, 75 Ohm, 93 Ohm, 100 Ohm, 110 Ohm, 124 Ohm, 125 Ohm, 135 Ohm, 150 Ohm, 250 Ohm, 300 Ohm, 500 Ohm, 600 Ohm, 800 Ohm, 900 Ohm, 1 kOhm, 1.2 kOhm, and 8 kOhm.
  6. The NOMINAL field may specify a range only when the RANGE field specifies RNGLK.

Legal Ranges:

Voltage | Current | Resistance | Capacitance
100 mV | 100 µA 3 | 10 Ω 3 | 1 nF 3
1 V | 1 mA 3 | 100 Ω | 10 nF 3
10 V | 10 mA | 1 kΩ | 100 nF 3
100 V | 100 mA | 10 kΩ | 1 µF 3
750 V 1 | 400 mA | 100 kΩ | 10 µF 3
1000 V 2 | 1 A | 1 MΩ | 100 µF 3
3 A | 10 MΩ | 1 mF 3
10 A | 100 MΩ | 10 mF 3
1 GΩ 3 | 100 mF 3
  1. DMM4040 ACV
  2. DMM4040 DCV, DMM4050 DCV & ACV
  3. DMM4050 only
  • A M4040/M4050 range lock specification only applies when a subsequent 4040/4050 FSC specifies an applicable measurement function.

TOLERANCE

This field specifies the number of power line cycles for DC measurements.

  • NPLC entered as: numeric[prefix]NPLC
  • blank Reset to default values (10 NPLC)

Rules:

  1. Allowed values for NPLC are: 0.02, 0.2, 1, 10, 100.

MOD1

This field specifies the Detector band (filter) for AC measurements.

  • Detector band entered as: [numeric][prefix]H
  • blank Reset to default value or not applicable

Rules:

  1. Allowed values are 3 Hz, 20 Hz, and 200 Hz.
  2. When the detector band is not specified, the default is 20 Hz.
  3. When the MOD1 field contains only units, the value is obtained from the memory register MEM.

MOD2

This field is not used.

MOD3

This field is not used.

MOD4

This field specifies external trigger.

  • "X" External trigger
  • blank Bus trigger

CON

This field is not used.


4020

Instrument FSC

Description

The 4020 FSC programs the Tektronix DMM4020 Multimeter to measure DC voltage, AC voltage, DC current, AC current, resistance, frequency, audio power, or decibels.

Do not use the PORT FSC port configuration special construction, [P9600,N,...], to set the baud rate, parity, etc. of the port used to control the DMM4020. MET/CAL executes a "Test" function for each System Instrument prior to executing any procedure statements, therefore the settings of the port used to controlling the DMM4020 must be set correctly before a procedure is executed. If the DMM4020 is connected to a standard serial port (COM1, COM2, ..., COM16), select the "Ports" application in the Windows control panel to choose the proper settings. If the DMM4020 is connected to the 5500A, 5520A, 5800A, or 5820A UUT port, select the proper settings for the UUT Serial Port from the front panel of the calibrator.

The DMM4020 setting "Echo Off" must be used for serial control by MET/CAL.

Functional Capability

Function | 4020 NOMINAL | 4020 MOD1 | 4020 MOD2 | M4020 NOMINAL
DC Voltage | -1000 to 1000 V
AC Voltage 1 | 15 mV to 750 V | 20 Hz to 100 kHz
Resistance | 0 Ohm to 100 MOhm
DC Current (200 mA Input) | -199.999 to 199.999 mA
DC Current (10 A Input) | -10 to 10 A
AC Current (200 mA Input) | 1.5 to 199.999 mA | 20 Hz to 2 kHz
AC Current (10 A Input) | 0.5 to 10 A | 20 Hz to 2 kHz
Frequency | 20 Hz to 1 MHz | 100 mV to 750 V 1
Audio Power | 0.01 to 9999.99 W | 20 Hz to 100 kHz | 2,4,8, or 16 Ω
dBm | -93.010 to +84.490 dBm | 20 Hz to 100 kHz | 2 Ω
-96.020 to +81.480 dBm | 20 Hz to 100 kHz | 4 Ω
-99.030 to +78.470 dBm | 20 Hz to 100 kHz | 8 Ω
-102.041 to +75.460 dBm | 20 Hz to 100 kHz | 16 Ω
-106.989 to +70.511 dBm | 20 Hz to 100 kHz | 50 Ω
-106.989 to +70.511 dBm | 20 Hz to 100 kHz | 5 Z or | 50 Ω
-108.750 to +68.750 dBm | 20 Hz to 100 kHz | 7Z or | 75 Ω
-109.684 to +67.816 dBm | 20 Hz to 100 kHz | 93 Ω
-110.413 to +67.087 dBm | 20 Hz to 100 kHz | 110 Ω
-110.934 to +66.567 dBm | 20 Hz to 100 kHz | 124 Ω
-110.969 to +66.532 dBm | 20 Hz to 100 kHz | 125 Ω
-111.303 to +66.197 dBm | 20 Hz to 100 kHz | 135 Ω
-111.760 to +65.740 dBm | 20 Hz to 100 kHz | 150 Ω
-113.979 to +63.521 dBm | 20 Hz to 100 kHz | 250 Ω
-114.771 to +62.730 dBm | 20 Hz to 100 kHz | 3Z or | 300 Ω
-116.989 to +60.511 dBm | 20 Hz to 100 kHz | 500 Ω
-117.781 to +59.710 dBm | 20 Hz to 100 kHz | 6Z or | 600 Ω
-119.030 to +58.470 dBm | 20 Hz to 100 kHz | 800 Ω
-119.542 to +57.958 dBm | 20 Hz to 100 kHz | 900 Ω
-120.000 to +57.501 dBm | 20 Hz to 100 kHz | 1000 Ω
-120.791 to +56.709 dBm | 20 Hz to 100 kHz | 1200 Ω
-129.030 to +48.470 dBm | 20 Hz to 100 kHz | 8000 Ω
  1. Volt-Hertz product not to exceed 8 x 107.

Parameters

RANGE

This field specifies the UUT range as described in the RANGE Field topic.

NOMINAL

This field specifies the expected measured value or a reset.

  • Voltage (DC or RMS) entered as: [numeric][prefix]V
  • dBm entered as: [numeric][prefix]D
  • Audio Power entered as: [numeric][prefix]W
  • Current entered as [numeric][prefix]A.
  • Resistance entered as [numeric][prefix]Z.
  • Frequency entered as [numeric][prefix]H.
  • Reset entered as *.

Rules:

  1. The NOMINAL field may specify audio power only when the M4020 FSC specifies the reference impedance as 2, 4, 8, or 16 Ohms.
  2. The NOMINAL field may specify decibels only when the M4020 FSC specifies the reference impedance.

TOLERANCE

This field specifies the UUT tolerance as described in the TOLERANCE Field topic.

MOD1

This field specifies frequency for AC voltage and AC current measurements or voltage for frequency measurements. See the NOMINAL field specification for allowed values and units.

  • Frequency entered as numeric[prefix]H.
  • Voltage entered as: numeric[prefix]V
  • blank not applicable

Rules:

  1. The MOD1 field may specify voltage only when the NOMINAL field specifies frequency.

MOD2

This field is not used.

MOD3

This field specifies one of the following:

  • HC Current measurement using the 10 A input.
  • blank field not applicable

Rules:

  1. The MOD3 field may specify HC only when the NOMINAL field specifies current.
  2. HC is automatically inserted in the MOD3 field when current is specified in the NOMINAL field with a value greater than or equal to 199.999 mA.
  3. HC may be specified for current lower than 200 mA to avoid connection changes.

MOD4

This field specifies the type of test being performed as described in the MOD4 Field topic.

CON

The Connection field specifies the UUT connection and is always 2-wire (2W). 2W is inserted automatically in the CON field when no CON field code is entered.

Use of Standard Memory Locations and Results Reporting

System memory locations MEM and MEM1 are used. For more information, refer to the Use of Standard Memory Registers topic.

Examples

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
# ----- Reset -----
  1.001  4020         *                                                 S
# ----- DC Voltage -----
  1.002  4020   20    19.99mV        2% 0.04U                              2W
# ----- AC Voltage -----
  2.001  4020   400   350.0mV        -2.8U +2.9U   60H                     2W
# ----- dBm -----
  3.001  M4020  IMPED 50Z            SLOW
  3.002  4020         10D                          100H                 N  2W
# ----- Audio Power -----
  3.003  M4020  IMPED 8Z             SLOW
  3.004  4020         15W                          1kH                  N  2W
# ----- DC Current -----
  3.005  4020   4000  3500mA         9U                              HC    2W
 # ----- AC Current -----
  4.001  4020         35.00mA        0.37U         60H                     2W
# ----- Frequency -----
  5.001  4020   1000  800.0H         0.1% 0.1U     300mV                   2W
# ----- Resistance -----
  6.001  4020         390.0Z                                            S  4W


5030

Instrument FSC

Description

The 5030 FSC programs the Tegam and Tektronix SG 5030 Leveled Sine Wave Generators.

When the 5030 FSC is used to control a Tegam CG 5030, you must configure the instrument as an "Tekronix SG5030" as shown in the drop-down list in the "Add Instrument" configure dialog.

Functional Capability

  • Amplitude:1.59 V to 1.94 V, 4.5 mVpp to 5.5 Vpp, -49.95 dBm to +18.75 dBm
  • Frequency or Period: 0.1 Hz to 550 MHz, 1.8182 ns to 10 s

Parameters

RANGE

This field specifies the UUT range as described in the RANGE Field topic.

NOMINAL

This field specifies the amplitude, frequency, period, or reset.

  • Voltage (RMS) entered as: [numeric][prefix]V
  • Voltage (peak-to-peak) entered as: [numeric][prefix]Vpp
  • Voltage (into 50 Ω, dBm) entered as: [numeric][prefix]D
  • Frequency entered as [numeric][prefix]H.
  • Period entered as [numeric][prefix]T.
  • Reset entered as *.

Rules:

  1. When the NOMINAL field specifies the amplitude, the MOD1 field must specify the frequency or period.
  2. When the NOMINAL field specifies the frequency or period, the MOD1 field must specify the amplitude.

TOLERANCE

This field specifies the UUT tolerance as described in the TOLERANCE Field topic.

MOD1

This field specifies the amplitude, frequency, or period.

  • Frequency entered as [numeric][prefix]H.
  • Period entered as [numeric][prefix]T.
  • Voltage (RMS) entered as: [numeric][prefix]V
  • Voltage (peak-to-peak) entered as: [numeric][prefix]Vpp
  • Voltage (into 50 Ω, dBm) entered as: [numeric][prefix]D

Rules:

  1. When the MOD1 field specifies the frequency or period, the NOMINAL field must specify the amplitude.
  2. When the MOD1 field specifies the amplitude, the NOMINAL field must specify the frequency or period.

MOD2

This field specifies whether "/div" is include in after the value in the automatic range message.

  • -D "/div" is not included
  • blank"/div" is included if ASK+ D is in effect

Rules:

  1. The MOD2 field is automatically set to -D for a Setup Test.

MOD3

This field is not used.

MOD4

This field specifies the type of test being performed as described in the MOD4 Field topic.

CON

This field is specifies which output port is used for the signal.

CH1 | Fluke 58xxA Channel 1
CH2 | Fluke 58xxA Channel 2
CH3 | Fluke 58xxA Channel 3
CH4 | Fluke 58xxA Channel 4
CH5 | Fluke 58xxA Channel 5
blank | 5030 Leveling Head

Rules:

  1. The CON field may specify CH1 or CH5 only when a Fluke 58xxA is configured.
  2. The CON field may specify CH2, CH3, or CH4 only when a Fluke 58xxA is configured with the 5800A-5 Five Channel option.

Use of Standard Memory Locations and Results Reporting

System memory locations MEM and MEM1 are used. For more information, refer to the Use of Standard Memory Registers topic.

Examples

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
# ----- Reset -----
  1.001  5030         *                                                 S
  1.002  5030   A     -42.95D        1U            100kH          -D
  2.001  5030         100mV                        550MH          -D    S
  2.002  5030   0.5   28mVpp         5U            100kH          -D
  3.001  5030   A     D              1U            100kH          -D
  4.001  5030         V              1%            100kH          -D
  5.001  5030   50    10uT           1% 1/ 1U      -35D
  6.001  5030   200   100nT          1% 1/ 1U      1Vpp
# ----- Oscilloscope bandwidth test -----
  7.001  ASK-                                                     F        W
  7.002  ASK+     D
  7.003  DISP         Connect the SG 5030 to UUT channel 1.
  7.004  DISP         Set UUT to 20us/div.
  7.005  5030   20    120mVpp                      100kH                N
  7.006  ASK-         N
  7.007  MESS         Adjust stimulus for a UUT vertical reading of 4.2 div.
  7.008  5030         5MH            -100%         mVpp           -D
  8.001  MESS
  8.002  ASK+         N
  8.003  END


5050

Instrument FSC

Description

The 5050 FSC programs the Tegam SG 5050 Leveled Sine Wave Generator.

Functional Capability

  • Amplitude: 1.59 V to 1.94 V, 4.5 mVpp to 5.5 Vpp, -49.95 dBm to +18.75 dBm
  • Frequency or Period: 0.1 Hz to 2.5 GHz, 0.4 ns to 10 s

Parameters

RANGE

This field specifies the UUT range as described in the RANGE Field topic.

NOMINAL

This field specifies the amplitude, frequency, period, or reset.

  • Voltage (RMS) entered as: [numeric][prefix]V
  • Voltage (peak-to-peak) entered as: [numeric][prefix]Vpp
  • Voltage (into 50 Ohms, dBm) entered as: [numeric][prefix]D
  • Frequency entered as [numeric][prefix]H.
  • Period entered as [numeric][prefix]T.
  • Reset entered as *.

Rules:

  1. When the NOMINAL field specifies the amplitude, the MOD1 field must specify the frequency or period.
  2. When the NOMINAL field specifies the frequency or period, the MOD1 field must specify the amplitude.

TOLERANCE

This field specifies the UUT tolerance as described in the TOLERANCE Field topic.

MOD1

This field specifies the amplitude, frequency, or period.

  • Frequency entered as [numeric][prefix]H.
  • Period entered as [numeric][prefix]T.
  • Voltage (RMS) entered as: [numeric][prefix]V
  • Voltage (peak-to-peak) entered as: [numeric][prefix]Vpp
  • Voltage (into 50 Ohms, dBm) entered as: [numeric][prefix]D

Rules:

  1. When the MOD1 field specifies the frequency or period, the NOMINAL field must specify the amplitude.
  2. When the MOD1 field specifies the amplitude, the NOMINAL field must specify the frequency or period.

MOD2

This field specifies whether "/div" is include in after the value in the automatic range message.

  • -D "/div" is not included
  • blank"/div" is included if ASK+ D is in effect

Rules:

  1. The MOD2 field is automatically set to -D for a Setup Test.

MOD3

This field is not used.

MOD4

This field specifies the type of test being performed as described in the MOD4 Field topic.

CON

This field is specifies which output port is used for the signal.

CH1 | Fluke 58xxA Channel 1
CH2 | Fluke 58xxA Channel 2
CH3 | Fluke 58xxA Channel 3
CH4 | Fluke 58xxA Channel 4
CH5 | Fluke 58xxA Channel 5
blank | 5050 Leveling Head

Rules:

  1. The CON field may specify CH1 or CH5 only when a Fluke 58xxA is configured.
  2. The CON field may specify CH2, CH3, or CH4 only when a Fluke 58xxA is configured with the 5800A-5 Five Channel option.

Use of Standard Memory Locations and Results Reporting

System memory locations MEM and MEM1 are used. For more information, refer to the Use of Standard Memory Registers topic.

Examples

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
# ----- Reset -----
  1.001  5050         *                                                 S
  1.002  5050   A     -42.95D        1U            100kH          -D
  2.001  5050         100mV                        550MH          -D    S
  2.002  5050   0.5   28mVpp         5U            100kH          -D
  3.001  5050   A     D              1U            100kH          -D
  4.001  5050         V              1%            100kH          -D
  5.001  5050   50    10uT           1% 1/ 1U      -35D
  6.001  5050   200   100nT          1% 1/ 1U      1Vpp
# ----- Oscilloscope bandwidth test -----
  7.001  ASK-                                                     F        W
  7.002  ASK+     D
  7.003  DISP         Connect the SG 5050 to UUT channel 1.
  7.004  DISP         Set UUT to 20us/div.
  7.005  5050   20    120mVpp                      100kH                N
  7.006  ASK-         N
  7.007  MESS         Adjust stimulus for a UUT vertical reading of 4.2 div.
  7.008  5050         5MH            -100%         mVpp           -D
  8.001  MESS
  8.002  ASK+         N
  8.003  END


195

Instrument FSC

Description

The 195 FSC programs the Wavetek 195 Universal Waveform Generator to output DC voltage, or sine, square, triangle, positive ramp, negative ramp, and pulse waveforms. The 195 FSC can also program the following:

  • Fluke 282 2 Channel 40 MS/s Arbitrary Waveform Generator
  • Fluke 284 4 Channel 40 MS/s Arbitrary Waveform Generator

The Fluke 282 and 284 must be configured as "Wavetek 195".

If a Wavetek 195 (without option 001) or Fluke 282 is used and the M195 FSC specifies channel 3 or 4, a run time error will occur.

If the 195 is to be controlled via its serial port, do not use the PORT FSC port configuration special construction, [P9600,N,...], to set the baud rate, parity, etc. of the port used to control the 195. MET/CAL executes a "Test" function for each System Instrument prior to executing any procedure statements. Use the Windows Control Panel to set the port configuration as follows:

Baud Rate: | 9600 Data
Bits: | 8
Parity: | None
Stop Bits: | 1
Flow Control: | Xon/Xoff

Press the Utility button on the 195 front panel. Press the right arrow below the knob until "Remote" can be selected using one of the softkeys on the left side of the display. Select the following settings:

interface: | RS232
baud rate: | 9600

Functional Capability

Waveform | Frequency
Sine | 0.1 mHz to 16 MHz
Square | 0.1 mHz to 16 MHz
Triangle | 0.1 mHz to 100 kHz
Positive Ramp | 0.1 mHz to 100 kHz
Negative Ramp | 0.1 mHz to 100 kHz
Pulse
Period | 100 ns to 100 s
Width | 25 ns to 99.99 s
Output Level
2.5 mV to 10Vpp into 50 Ω
5.0 mV to 20Vpp open circuit

Parameters

RANGE

This field specifies the UUT range as described in the RANGE Field topic.

Nominal

This field specifies the starting Nominal value of the stimulus output or expected UUT reading for the test.

  • Voltage (DC or RMS) entered as: [numeric][prefix]V
  • Voltage (Peak) entered as: [numeric][prefix]Vp
  • Voltage (Peak-to-Peak) entered as: [numeric][prefix]Vpp
  • dBm entered as: [numeric][prefix]D
  • Frequency entered as: [numeric][prefix]H
  • Period entered as: [numeric][prefix]T

Rules:

  • The NOMINAL field may specify dBm only when the MOD2 field specifies SI.
  • The NOMINAL field may specify Voltage peak-to-peak, Frequency, or Period only when the MOD2 field specifies SI, SQ, TI, +R, -R, or PU (i.e. MOD2 is not blank).
  • When the NOMINAL field contains only units, the value is obtained from the memory register MEM.
  • When the NOMINAL field contains only units and the MOD1 field is not blank, the MOD1 field must specify a value.

TOLERANCE

This field specifies the UUT tolerance as described in the TOLERANCE Field topic.

MOD1

This field specifies amplitude or frequency or period for AC functions.

  • Voltage (RMS) entered as: [numeric][prefix]V
  • Voltage (Peak) entered as: [numeric][prefix]Vp
  • Voltage (Peak-to-Peak) entered as: [numeric][prefix]Vpp
  • dBm entered as: [numeric][prefix]D
  • Frequency entered as [numeric][prefix]H.
  • Period entered as [numeric][prefix]T.
  • blank

Rules:

  • The MOD1 field may specify dBm only when the MOD2 field specifies SI.
  • The MOD1 field may specify frequency or period only when the NOMINAL field specifies voltage or decibels.
  • The MOD1 field may specify voltage or decibels only when the NOMINAL field specifies frequency or period.
  • When the MOD1 field contains only units, the value is obtained from memory register MEM. In this case the NOMINAL field MUST contain a value.

MOD2

This field specifies the function (waveform type).

blank | DC Volts
SI | Sine
SQ | Square
TI | Triangle
+R | Positive Ramp
-R | Negative Ramp
PU | Pulse

Rules:

  • When the MOD2 field is PU, the M195 RANGE field must specify PER or PULSE.
  • SI is inserted automatically in the MOD2 field when the MOD1 field is not blank and no MOD2 code is entered.
  • The MOD2 field must be blank when the MOD1 field is blank (i.e. DC Voltage is specified).

MOD3

This field is not used.

MOD4

This field specifies the type of test being performed as described in the MOD4 Field topic.

CON

This field specifies the UUT connection.

L | 50 Ohm termination
blank | High Impedance

Rules:

  • When the CON field specifies "L" the output is expected to be terminated with 50 Ohms. This can be accomplished by using a 50 Ohm terminator at the UUT or setting the UUT input impedance to 50 Ohms.
  • If ASK- W or ASK- V is in effect, the procedure writer must use a DISP FSC to prompt the operator to terminate the output signal at the UUT.

Use of Standard Memory Locations and Results Reporting

System memory locations MEM and MEM1 are used. For more information, refer to the Use of Standard Memory Registers topic.

Examples

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
# -----  Reset  -----
  1.001  195          *                                                 S
# -----  DC Voltage  -----
  1.002  195          1.00V                                             S  L
# -----  Sine Wave  -----
  1.003  195    400   2.5Vp          -2.8U +2.9U   60H            SI       L
  2.001  195    400   3.500Vp        7.4U          20kH           SI       L
  3.001  195          -37.78D                      100H           SI    S  L
# -----  Square Wave w/DC offset  -----
  3.002  M195                                      0.5Voff                 CH1
  3.003  195          1Vp                          1kH            SQ    S  L
# -----  Triangle Wave  -----
  3.004  M195         *
  3.005  195          13mVp                        10kH           TI    S  L
# -----  Positive Ramp  -----
  3.006  195          1.0Vp                        100kH          +R    S  L
# -----  Negative Ramp  -----
  3.007  195          1.0Vp                        20kH           -R    S  L
# -----  Pulse  -----
  3.008  M195   PER   1uT                                                  CH1
  3.009  195          100nT                        1Vp            PU    S  L
  3.010  M195         *
# -----  Frequency  -----
  3.011  195          800.0H                       300mV          SI    S  L
# -----  Simultaneous Output  -----
  3.012  M195                                                              CH1
  3.013  195          1Vpp                         1kH            SI    S  L
  3.014  M195                                                              CH2
  3.015  195          1Vpp                         2kH            SQ    S  L
  3.016  M195                                                              CH3
  3.017  195          1Vpp                         4kH            TI    S  L
  3.018  M195                                                              CH4
  3.019  195          1Vpp                         8kH            +R    S  L
# -----  Phase-setting Between Channels  -----
  3.020  M195                                                        MS    CH3
  3.021  195          3Vpp                         1kH            SI    S  L
  3.022  M195                        30deg                           SL    CH4
  3.023  195          3Vpp                         1kH            SI    S  L
  3.024  END


M195

Auxiliary Instrument Setup FSC

Description

The M195 FSC is used to specify pulse period, pulse width, and DC offset, channel mode (master/slave), and output channel.

Functional Capability

Pulse Period: | 100ns to 100s
Pulse Width: | 25ns to 99.99s
DC Offset: | 0V to 5V into 50 Ω
 | 0V to 10V open circuit restricted by:
 | |Voff| + |Vp| = Vmax

Parameters

RANGE

This field specifies one of the following:

  • PULSEPulse Width
  • PERPulse Period
  • blank

NOMINAL

This field specifies one of the following:

  • Pulse Width entered as: [numeric][prefix]T
  • Pulse Period entered as: [numeric][prefix]T
  • "*" reset to default values
  • blank

Rules:

  • The NOMINAL field must specify the pulse width when the RANGE field is PULSE.
  • The NOMINAL field must specify the pulse period when the RANGE field is PER.
  • If the Nominal field does not contain a value the value is taken from memory register MEM.

TOLERANCE

The Tolerance field specifies the phase of the specified channel relative to the master channel.

  • Phase entered as: [numeric][prefix]deg
  • blank

Rules:

  • The Tolerance field may specify the phase only when the MOD3 field is "SL" (Slave).
  • When the MOD4 is field is SL and no phase is specified, 0deg is automatically insert in the tolerance field.

MOD1

The MOD1 field specifies the following:

  • DC Offset entered as: [numeric][prefix]Voff
  • blank

Rules:

  • If the MOD1 field does not contain a value the value is taken from memory register MEM.

MOD2

This field is not used.

MOD3

The MOD3 field specifies the channel mode:

  • MSMaster
  • SLSlave
  • blank

Rules:

  • If the MOD3 field must be blank when the RANGE field is PULSE or PER.

MOD4

This field is not used.

CON

This field specifies the output channel.

  • CH1
  • CH2
  • CH3
  • CH4

Rules:

  • If no valid CON field code is entered, CH1 is automatically inserted in the CON field.

Examples

See 195 FSC.


39A

Instrument FSC

Description

The 39A FSC programs the Wavetek 39A Universal Waveform Generator to output DC voltage, or sine, square, triangle, positive ramp, negative ramp, and pulse waveforms. The 39A FSC can also program Channel 1 of the following:

  • Wavetek 195 Universal Waveform Generator
  • Fluke 281 1 Channel 40 MS/s Arbitrary Waveform Generator
    • Must be configured as "Wavetek 39A"
  • Fluke 282 2 Channel 40 MS/s Arbitrary Waveform Generator
    • Must be configured as a "Wavetek 195"
  • Fluke 284 4 Channel 40 MS/s Arbitrary Waveform Generator
    • Must be configured as a "Wavetek 195"

If the 39A is to be controlled via its serial port, do not use the PORT FSC port configuration special construction, [P9600,N,...], to set the baud rate, parity, etc. of the port used to control the 39A. MET/CAL executes a "Test" function for each System Instrument prior to executing any procedure statements. Use the Windows Control Panel to set the port configuration as follows:

Baud Rate: | 9600
Data Bits: | 8
Parity: | None
Stop Bits: | 1
Flow Control: | Xon/Xoff

Press the Utility button on the 39A front panel. Press the right arrow below the knob until "Remote" can be selected using one of the softkeys on the left side of the display. Select the following settings:

interface: RS232

baud rate: 9600

Functional Capability

Waveform | Frequency
Sine | 0.1 mHz to 16 MHz
Square | 0.1 mHz to 16 MHz
Triangle | 0.1 mHz to 100 kHz
Positive Ramp | 0.1 mHz to 100 kHz
Negative Ramp | 0.1 mHz to 100 kHz
Pulse
Period | 100 ns to 100 s
Width | 25 ns to 99.99 s
Output Level
2.5 mV to 10 Vpp into 50 Ω
5.0mV to 20Vpp open circuit

Parameters

RANGE

This field specifies the UUT range as described in the RANGE Field topic.

NOMINAL

This field specifies the starting Nominal value of the stimulus output or expected UUT reading for the test.

  • Voltage (DC or RMS) entered as: [numeric][prefix]V
  • Voltage (Peak) entered as: [numeric][prefix]Vp
  • Voltage (Peak-to-Peak) entered as: [numeric][prefix]Vpp
  • dBm entered as: [numeric][prefix]D
  • Frequency entered as: [numeric][prefix]H
  • Period entered as: [numeric][prefix]T

Rules:

  1. The NOMINAL field may specify dBm only when the MOD2 field specifies SI.
  2. The NOMINAL field may specify Voltage peak-to-peak, Frequency, or Period only when the MOD2 field specifies SI, SQ, TI, +R, -R, or PU (i.e. MOD2 is not blank).
  3. When the NOMINAL field contains only units, the value is obtained from the memory register MEM.
  4. When the NOMINAL field contains only units and the MOD1 field is not blank, the MOD1 field must specify a value.

TOLERANCE

This field specifies the UUT tolerance as described in the TOLERANCE Field topic.

MOD1

This field specifies amplitude or frequency or period for AC functions.

  • Voltage (RMS) entered as: [numeric][prefix]V
  • Voltage (Peak) entered as: [numeric][prefix]Vp
  • Voltage (Peak-to-Peak) entered as: [numeric][prefix]Vpp
  • dBm entered as: [numeric][prefix]D
  • Frequency entered as [numeric][prefix]H.
  • Period entered as [numeric][prefix]T.
  • blank DC

Rules:

  1. The MOD1 field may specify dBm only when the MOD2 field specifies SI.
  2. The MOD1 field may specify frequency or period only when the NOMINAL field specifies voltage or decibels.
  3. The MOD1 field may specify voltage or decibels only when the NOMINAL field specifies frequency or period.
  4. When the MOD1 field contains only units, the value is obtained from memory register MEM. In this case the NOMINAL field MUST contain a value.

MOD2

This field specifies the function (waveform type).

blank | DC Volts
SI | Sine
SQ | Square
TI | Triangle
+R | Positive Ramp
-R | Negative Ramp
PU | Pulse

Rules:

  1. When the MOD2 field is PU, the M39A RANGE field must specify PER or PULSE
  2. SI is inserted automatically in the MOD2 field when the MOD1 field is not blank and no MOD2 code is entered.
  3. The MOD2 field must be blank when the MOD1 field is blank (i.e. DC Voltage is specified).

MOD3

This field is not used.

MOD4

This field specifies the type of test being performed as described in the MOD4 Field topic.

CON

This field specifies the UUT connection.

L | 50 Ω termination
blank | High Impedance

Rules:

  1. When the CON field specifies "L" the output is expected to be terminated with 50 Ω. This can be accomplished by using a 50 Ω terminator at the UUT or setting the UUT input impedance to 50 Ω.
  2. If ASK- W or ASK- V is in effect, the procedure writer must use a DISP FSC to prompt the operator to terminate the output signal at the UUT.

Use of Standard Memory Locations and Results Reporting

System memory locations MEM and MEM1 are used. For more information, refer to the Use of Standard Memory Registers topic.

Examples:

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON

# ----- Reset -----
  1.001  39A          *                                                 S
# ----- DC Voltage -----
  1.002  39A          1.00V                                             S  L
# ----- Sine Wave -----
  1.003  39A    400   2.5Vp          -2.8U +2.9U   60H            SI       L
  2.001  39A    400   3.500Vp        7.4U          20kH           SI       L
  3.001  39A          -37.78D                      100H           SI    S  L
# ----- Square Wave w/DC offset -----
  3.002  M39A                                      0.5Voff
  3.003  39A          1Vp                          1kH            SQ    S  L
# ----- Triangle Wave -----
  3.004  M39A         *
  3.005  39A          13mVp                        10kH           TI    S  L
# ----- Positive Ramp -----
  3.006  39A          1.0Vp                        100kH          +R    S  L
# ----- Negative Ramp -----
  3.007  39A          1.0Vp                        20kH           -R    S  L
# ----- Pulse -----
  3.008  M39A   PER   1uT
  3.009  39A          100nT                        1Vp            PU    S  L
  3.010  M39A         *
# ----- Frequency -----
  3.011  39A          800.0H                       300mV          SI    S  L


M39A

Instrument Setup FSC

Description

The M39A FSC is used to specify pulse period, pulse width, and DC offset. The M39A FSC is ignored when the 39A FSC specifies DC voltage.

Functional Capability

Pulse Period | 100ns to 100s
Pulse Width | 25ns to 99.99s
DC Offset: | 0V to 5V into 50 Ohms 0V to 10V open circuit restricted by: |Voff| + |Vp| ≤ Vmax

Parameters

RANGE

This field specifies one of the following:

PULSE | Pulse Width
PER | Pulse Period
blank | field not applicable

NOMINAL

This field specifies one of the following:

  • Pulse Width entered as: [numeric][prefix]T
  • Pulse Period entered as: [numeric][prefix]T
  • "*" reset to default values
  • blank not applicable

Rules:

  1. The NOMINAL field must specify the pulse width when the RANGE field is PULSE.
  2. The NOMINAL field must specify the pulse period when the RANGE field is PER.
  3. If the Nominal field does not contain a value the value is taken from memory register MEM.

TOLERANCE

This field is not used.

MOD1

The MOD1 field specifies the following:

  • DC Offset entered as: [numeric][prefix]Voff
  • blank no offset

Rules:

  1. If the MOD1 field does not contain a value the value is taken from memory register MEM.

MOD2

This field is not used.

MOD3

This field is not used.

MOD4

This field is not used.

CON

This field is not used.

Examples

See 39A FSC.


395

Instrument FSC

Description

The 395 FSC programs the Wavetek 395 Arbitrary Waveform Generator to output DC voltage, periodic random noise, or sine, square, triangle, positive ramp, and negative ramp waveforms.

If the 395 is to be controlled via its serial port, do not use the PORT FSC port configuration special construction, [P9600,N,...], to set the baud rate, parity, etc. of the port used to control the 395. MET/CAL executes a "Test" function for each System Instrument prior to executing any procedure statements. Use the Windows Control Panel to set the port configuration as follows:

Baud Rate: | 9600
Data Bits: | 8
Parity: | None
Stop Bits: | 1
Flow Control: | Hardware

Press F3 "RS-232".

Press F7 "setup" and select the following settings:

echo | off
handshake: | on
timeout: | 2.0 sec
baud: | 9600

Functional Capability

Waveform | Frequency
Sine | 1 μHz to 40 MHz
Square | 1 μHz to 50 MHz
Triangle | 1 μHz to 10 MHz
Positive Ramp | 1 μHz to 2 MHz
Negative Ramp | 1 μHz to 2 MHz

Output Termination | Amplitude
50 Ω | ±5 V (DC), -5 Vp to 5 Vp (AC)

Parameters

RANGE

This field specifies the UUT range as described in the RANGE Field topic.

NOMINAL

This field specifies the starting Nominal value of the stimulus output or expected UUT reading for the test.

  • Voltage (DC or RMS) entered as: [numeric][prefix]V
  • Voltage (Peak) entered as: [numeric][prefix]Vp
  • Voltage (Peak-to-Peak) entered as: [numeric][prefix]Vpp
  • dBm entered as: [numeric][prefix]D
  • Frequency entered as: [numeric][prefix]H
  • Period entered as: [numeric][prefix]T

Rules:

  1. The NOMINAL field may specify dBm only when the MOD2 field specifies SI.
  2. The NOMINAL field may specify Voltage peak-to-peak, Frequency, or Period only when the MOD2 field specifies SI, SQ, TI, +R, -R, PU, or OI (i.e. MOD2 is not blank).
  3. When the NOMINAL field contains only units, the value is obtained from the memory register MEM.
  4. When the NOMINAL field contains only units and the MOD1 field is not blank, the MOD1 field must specify a value.

TOLERANCE

This field specifies the UUT tolerance as described in the TOLERANCE Field topic.

MOD1

This field specifies amplitude or frequency or period for AC functions.

  • Voltage (RMS) entered as: [numeric][prefix]V
  • Voltage (Peak) entered as: [numeric][prefix]Vp
  • Voltage (Peak-to-Peak) entered as: [numeric][prefix]Vpp
  • dBm entered as: [numeric][prefix]D
  • Frequency entered as [numeric][prefix]H.
  • Period entered as [numeric][prefix]T.
  • blank DC or Noise

Rules:

  1. The MOD1 field may specify dBm only when the MOD2 field specifies SI.
  2. The MOD1 field must be blank when the MOD2 field specifies OI (Noise).
  3. The MOD1 field may specify frequency or period only when the NOMINAL field specifies voltage or decibels.
  4. The MOD1 field may specify voltage or decibels only when the NOMINAL field specifies frequency or period.
  5. When the MOD1 field contains only units, the value is obtained from memory register MEM. In this case the NOMINAL field MUST contain a value.

MOD2

This field specifies the function (waveform type).

blank | DC Volts
SI | Sine
SQ | Square
TI | Triangle
+R | Positive Ramp
-R | Negative Ramp
PU | Pulse
OI | Periodic Random Noise

Rules:

  1. When the MOD2 field is PU, the M395 RANGE field must specify PER or PULSE.
  2. SI is inserted automatically in the MOD2 field when the MOD1 field is not blank and no MOD2 code is entered.
  3. The MOD2 field must be blank or OI when the MOD1 field is blank (i.e. DC Voltage or Noise is specified).

MOD3

This field is not used.

MOD4

This field specifies the type of test being performed as described in the MOD4 Field topic.

CON

This field specifies the UUT connection.

L 50 Ω termination

Rules:

  1. L is automatically inserted the CON field when no CON field code in entered.
  2. The output is expected to be terminated with 50 Ω. This can be accomplished by using a 50 Ω terminator at the UUT or setting the UUT input impedance to 50 Ω.
  3. If ASK- W or ASK- V is in effect, the procedure writer must use a DISP FSC to prompt the operator to terminate the output signal at the UUT.

Use of Standard Memory Locations and Results Reporting

System memory locations MEM and MEM1 are used. For more information, refer to the Use of Standard Memory Registers topic.

Examples

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
# ----- Reset -----
  1.001  395          *                                                 S
# ----- DC Voltage -----
  1.002  395          1.00V                                             S  L
# ----- Sine Wave -----
  1.003  395    400   2.5Vp          -2.8U +2.9U   60H            SI       L
  2.001  395    400   3.500Vp        7.4U          20kH           SI       L
  3.001  395          -37.78D                      100H           SI    S  L
# ----- Square Wave w/DC offset -----
  3.002  M395                                      0.5Voff
  3.003  395          1Vp                          1kH            SQ    S  L
# ----- Triangle Wave -----
  3.004  M395         *
  3.005  395          13mVp                        10kH           TI    S  L
# ----- Positive Ramp -----
  3.006  395          1.0Vp                        100kH          +R    S  L
# ----- Negative Ramp -----
  3.007  395          1.0Vp                        20kH           -R    S  L
# ----- Pulse -----
  3.008  M395   PER   1uT
  3.009  395          10nT                         1Vp            PU    S  L
  3.010  M395         *
# ----- Frequency -----
  3.011  395          800.0H                       300mV          SI    S  L
# ----- AM Modulation -----
  3.012  M395         1kH                          10pct
  3.013  395          950kH                        1Vp            SI    S  L
# ----- FM Modulation -----
  3.014  M395         1kH                          10kH
  3.015  395          1MH                          1Vp            SI    S  L


M395

Instrument Setup FSC

Description

The M395 FSC is used to specify modulation, modulation frequency, AM depth, FM deviation, and DC offset. The M395 FSC is ignored when the 395 FSC specifies DC voltage.

Functional Capability

Pulse Period | 100ns to 10s
Pulse Width | 10ns to 9.99s
Modulation Frequency: | 1Hz to 40MHz
AM Depth: | 0% to 200%
FM Deviation: | 1Hz to 40MHz
DC Offset: | 0V to 5V into 50 Ohms restricted by: |Voff| + |Vp| ≤ Vmax

Parameters

RANGE

This field specifies one of the following:

PULSE | Pulse Width
PER | Pulse Period
blank | field not applicable

NOMINAL

This field specifies one of the following:

  • Pulse Width entered as: [numeric][prefix]T
  • Pulse Period entered as: [numeric][prefix]T
  • Modulation Frequency is entered as [numeric][prefix]H.
  • "*" reset to default values
  • blank not applicable

Rules:

  1. The NOMINAL field must specify the pulse width when the RANGE field is PULSE.
  2. The NOMINAL field must specify the pulse period when the RANGE field is PER.
  3. If the Nominal field does not contain a value the value is taken from memory register MEM.

TOLERANCE

This field is not used.

MOD1

The MOD1 field specifies the following:

  • DC Offset entered as: [numeric][prefix]Voff
  • AM Depth entered as: [numeric][prefix]pct.
  • FM Deviation entered as: [numeric][prefix]H.
  • blank no modulation

Rules:

  1. The MOD1 field must specify AM depth or FM deviation when the Nominal field specifies a modulation frequency.
  2. When two frequency values are entered for a M395 FSC, the first is taken to be the Modulation Frequency and the second is taken to be the FM deviation.
  3. When the MOD1 field specifies FM deviation, the deviation must be less than or equal to the frequency specified in the 395 FSC Nominal or MOD1 field.
  4. When a frequency value and a percent value are entered for a M395 FSC, the frequency is taken to be the Modulation Frequency and the percent is taken to be the AM depth.
  5. If the MOD1 field does not contain a value the value is taken from memory register MEM.

MOD2

This field is not used.

MOD3

This field is not used.

MOD4

This field is not used.

CON

This field is not used.

Examples

See 395 FSC.


MATH FSC

Memory Register Operation FSC

Table of Contents

  • Description
  • Format
  • Rules
    • Registers & Variables
    • Operators
    • Variables
  • Function Overview (each of these opens as a separate, dedicated topic)
    • Accuracy Functions
    • Binary Read Functions
    • Database Functions
    • Date and Time Functions
    • File Functions
    • Fluke 792A Data Access Functions
    • General Numeric Functions
    • Initialization File Functions
    • List Box Window Functions
    • Numeric Conversion Functions
    • Humidity / Temperature Sensor Functions
    • Slew Functions
    • String Functions
    • Trig Functions
    • Units Functions
    • Miscellaneous Functions
  • Literal Values
  • Value Conversions
  • Operator Precedence
  • Restrictions
  • Error Handling
  • Relational Operators and Floating-Point Comparisons
  • RIF/WIF Data Directory
  • DOS FSC Executable to MATH FSC Function Cross-Reference
  • Examples

Description

The MATH FSC evaluates arithmetic and string expressions and assigns the result to a specified memory register.

Format

MATH memory register = expression

Multiple assignments may be included in a single MATH statement, separated by semicolons.

Rules

Each line of the FSC statement may contain up to 256 bytes, including the step number and the FSC text. Characters below ASCII 128 occupy one byte.

Registers & Variables

The memory register must be one of:

MEM | global numeric register
MEM1 | global numeric register
M[1], M[2], ..., M[255] | global numeric registers
L[1], L[2], ..., L[32] | local numeric registers
MEM2 | global string register
S[1], S[2], ..., S[32] | global string registers
variable | named variable

The index of a numeric register (M[index] or Lindex]) or a string register (S[index]) must be a literal integer. It cannot be an expression. For example, "M[MEM + 3]" is not a legal construction in a MATH statement.

MEM, MEM1, M[1], M[2], ..., M[255] are global numeric registers.

Local numeric registers (the 'L' registers) are local to each procedure call. L registers are set to zero on entry into a procedure. After the return from a subprocedure back to the calling procedure, the L registers return to the values they had in the calling procedure prior to the subprocedure call.

(The L registers do not exist in MET/CAL V7.00 and prior.)

MEM2, S[1], S[2], ..., and S[32] are global string registers. MEM2 is limited to 4096 characters. The S registers cannot exceed 32767 characters each, subject to available memory.

Beginning with V7.20 the MATH FSC supports variables. See the Variables section below for a detailed description.

Operators

The MATH FSC supports the following binary operators:

Operation | Symbol
addition | +
subtraction | -
multiplication | *
division | /
exponentiation | ^
string concatenation | &
less than | <
less than or equal to | <=
greater than | >
greater than or equal to | >=
equal to | ==
not equal to | !=
logical AND | &&
logical OR | ||

The relational operators (<, <=, >, >=, ==, and !=) evaluate to 1 or 0, depending on whether the relation is true or false. For example, MATH MEM1 = MEM < 10 sets MEM1 to 1 if the value of MEM is less than 10, and sets MEM1 to 0 if the value of MEM is greater than or equal to 10.

The logical operators (&&, ||) expect numeric operands. Non-zero operand values have a truth value of TRUE. Zero operand values have a truth value of FALSE. The logical operators adhere to the standard definitions:

(TRUE  && TRUE)  is TRUE
(TRUE  && FALSE) is FALSE
(FALSE && TRUE)  is FALSE
(FALSE && FALSE) is FALSE
(TRUE  || TRUE)  is TRUE
(TRUE  || FALSE) is TRUE
(FALSE || TRUE)  is TRUE
(FALSE || FALSE) is FALSE

Procedures which make use of any of the operators "<=", ">=", "==", and "!=" should be tested carefully. There is some risk of unexpected behavior due to internal floating-point rounding in numerical calculations. Refer to Relational Operators and Floating-Point Comparisons for additional information.

Variables

In MET/CAL V7.20 and later the MATH FSC supports named variables.

  1. Variable names have a maximum length of 32 characters. Examples:

    MATH abcdefghijklmnopqrstuvwxyzABCDEF = 5

    MATH abcdefghijklmnopqrstuvwxyzABCDEFG = 5

    The first statement is legal, the second is not.

    Procedure writers should choose names which are descriptive, but not so long that the procedure line length limit prevents programming the desired expressions.

  2. Variable names are alpha-numeric plus underscore; symbols and special characters are not permitted. The first character of a name cannot be a digit.

    Examples:

    Legal statements:

    MATH a = 10

    MATH a_b = 11

    MATH a5 = 12

    Illegal statements:

    MATH a@ = 10

    MATH 3a = 12

  3. Both global and local variables are supported. Global variables are distinguished from locals by name. The rule is that any variable name which begins with an at sign ('@') is global. All other variables are local.

    Examples:

    MATH @voltage = 10.0

    MATH current = 2.0

    "@voltage" is global because it begins with an '@'.

    "current" is local because it does not begin with an '@'.

  4. All named variables are string variables. However, they may be used in contexts where numeric values are expected, as long as the string value can be converted to numeric form. MET/CAL does the conversion automatically.

    Examples:

    The following statements are equivalent:

    MATH x = "10"

    MATH y = 10

    Both "x" and "y" may be used in contexts which expect a numeric value:

    MATH z = x + 3

    MATH q = y + 3

    However, it is not valid to use a non-numeric value in a context which expects a numeric value:

    MATH t5 = "xyz"

    MATH alpha = t5 + 9

    When the assignment "alpha = t5 + 9" is performed MET/CAL will generate a run time error.

  5. Variable names are case-sensitive.

    Examples:

    MATH s = "abc"

    MATH S = "xyz"

    "s" and "S" are different variables.

  6. Variable names do not have to be different from function names.

    Example:

    MATH cos = cos(1.2)

    This statement is valid. MET/CAL distinguishes variable names from function names by context. However, it's probably best not to give variables names which are the same as function names, because it may make the procedure less readable.

  7. Variables may be used in all contexts which accept MATH expressions. This includes MATH, EVAL, JMPL, IF, WHILE, and UNTIL procedure statements.

  8. The [V ...] construction is used to display or access the value of a named variable in contexts which accept special constructions.

    Example:

    MATH count = 10

    DISP The count is [V count]

    The [V ...] construction may be used with global variables as well.

    Example:

    MATH @count = 10

    DISP The count is [V @count]

    Name/value FSCs (VSET, TSET, 6100, 9640, ...) may also use the [V ...] construction to specify the value of a parameter.

  9. For debugging purposes the Test Run "S-Reg" window displays the values of variables.

    Globals variables follow the 'S' registers. The globals are shown in alphabetical order in the "S-Reg" window.

    Local variables follow the globals and are also shown in alphabetical order.

    For local variables the subprocedure nesting level is normally indicated by the "S-Reg" window. This display method is controlled by the "TestRunLVarDisplay" initialization file parameter. Legal values for "TestRunLVarDisplay" are:

    1. Level
    2. Tab
    3. Left

    If "TestRunLVarDisplay" is set to "Level", the subprocedure nesting level is shown before the local variable name. "Level" is the default. If you don't assign a value for "TestRunLVarDisplay" in your initialization file, MET/CAL uses this method.

    Example:

    MATH x = 5

    If the assignment above occurs in the main procedure the Test Run "S-Reg" window will show:

    1 : x = 5

    If the assignment occurs in a subprocedure called by the main procedure the Test Run "S-Reg" window will show:

    2 : x = 5

    If "TestRunLVarDisplay" is set to "Tab", the subprocedure nesting level is indicated by indentation.

    Example:

    If the Test Run "S-Reg" window shows:

    x = 5 xx = 10 xxx = 15

    it indicates that the first assignment is at level 1 (main procedure), the second assignment is at level 2 (subprocedure called by main), and the third assigment is at level 3 (subprocedure called by subprocedure called by main), and so on.

    If "TestRunLVarDisplay" is set to "Left", the subprocedure nesting level is not indicated in the Test Run S-Reg window.

Literal Values

Literal values may be numeric or string values. Numeric values may be integer, fixed-point or floating-point.

integer | 23
fixed-point | 3.56
floating-point | 2.4E+3

String values must be enclosed in double quotes.

String values may not contain embedded NUL characters (zero).

Literal strings may include the following backslash escape sequences:

\r | carriage return
\n | linefeed
\\ | backslash
\" | double quote
\ddd | decimal integer (where ddd = 001 to 255)
\xdd | hex integer (where xdd = x01 to xFF)
UNC paths are supported and may be entered directly, or by using the backslash escape character above. Both of these examples are functionally identical:
  • \\server\share\file.txt
  • \\\\server\\share\\file.txt

Value Conversions

Each operator has an expected type for its operands, each function has an expected type for its arguments, and each destination register has a type.

Implicit conversions from strings to integers, and vice versa, are automatically done as needed during expression evaluation. A string is converted to a numeric value by searching for the first numeric character (including '+', '-', and '.') and converting the number which begins at that point. A run time error results if the string does not contain a numeric value.

MATH MEM = "abc1.4xyz"

After the statement is executed, the value of MEM will be 1.4. When an implicit conversion from a numeric value to a string value is done, MET/CAL formats the numeric value to retain up to 6 significant digits.

If a procedure has a requirement for a conversion which results in a different number of significant digits, the FMT function should be used to explicitly specify the conversion.

Example:

MATH MEM = 13579.24
MATH MEM2 = MEM
DISP MEM2 = [MEM2]

The implicit conversion which occurs when the assignment MEM2 = MEM is done retains only 6 significant digits. If you display the value of MEM2 after this conversion you will see "13579.2".

The 7th significant digit, '4', has been discarded. To retain all significant digits in this example, use the FMT function:

MATH MEM = 13579.24
MATH MEM2 = FMT(MEM, "%.10g")
DISP MEM2 = [MEM2]

In the example above, the format descriptor "%.10g" causes up to 10 significant digits to be retained. When you display MEM2 you will now see "13579.24", which has 7 significant digits. The format descriptor should be chosen so as to retain at least as many as the required number of significant digits.

Operator Precedence

The following table shows operator precedence from highest to lowest. Operators at the same level have the same precedence and are evaluated left to right.

Level 1 (Highest) | ^
Level 2 | *, /
Level 3 | +, -, &
Level 4 | <, <=, >, >=, ==, !=
Level 5 | &&, ||

The default precedence of an operator may be overridden by using parentheses to group sub-expressions.

Example:

MATH MEM = (M[1] + M[2]) * (M[3] - M[4])

This expression is evaluated as follows:

  1. The sum of M[1] and M[2] is calculated.
  2. The difference between M[3] and M[4] is calculated.
  3. The result of step 1 is multiplied by the result of step 2.
  4. The result of step 3 is stored in MEM.

Note that the expression in the example above would not be the same if the parentheses were removed.

Restrictions

Unary sign operators may not precede non-literal values.

For example, "MATH MEM = 1 - -MEM1" is illegal.

Instead, write: "MATH MEM = 1 - (-1 * MEM1)".

Unary sign operators may precede literal values, however. For example, "MATH MEM = 1 - -3" is legal.

Array indices must be literal numeric values.

For example, "MATH MEM = M[MEM1]" is illegal.

Error Handling

Division by zero is not allowed. A run time error results if division by zero occurs.

Run time errors occur if function parameters are out of range or otherwise illegal.

Relational Operators and Floating-Point Comparisons

Internally, MET/CAL uses double-precision floating-point values to represent numeric register values. Because binary floating-point numbers cannot exactly represent many real numbers, and also because certain arithmetic operations and functions may not produce exact results, there is a possibility that relational comparisons may produce unexpected results. Relational comparisons are comparisons with one of the relational operators: <, <=, >, >=, ==, !=.

To address this issue, the MATH FSC makes uses of an "epsilon factor". The default value of this factor is 1E-13. With the "==" operator, for example, using the default epsilon factor means that two numbers will be considered by MET/CAL to be equal if they are within one part in 10^13 of one another.

Here's an example of a situation where the epsilon factor makes a difference. Consider the expression in the IF statement:

IF ((9.7 + 0.1 + 0.1 + 0.1) == 10.0)

In normal mathematics we would expect this expression to be true, because (9.7 + 0.1 + 0.1 + 0.1) is in fact equal to 10. However, on a typical binary computer (PC) which implements double-precision floating-point arithmetic, it happens that (9.7 + 0.1 + 0.1 + 0.1) evaluates to 9.999999999999998, not to 10. A system which implements exact floating-point comparisons will therefore evaluate the relational expression ((9.7 + 0.1 + 0.1 + 0.1) == 10.0) as false.

By applying the epsilon factor to the comparison, MET/CAL's MATH FSC will evaluate ((9.7 + 0.1 + 0.1 + 0.1) == 10.0) to true. This is because 10 and 9.999999999999998, although not identical, are within one part in 10^13 of one another.

The VSET/TSET parameter, MATH_EPSILON, may be used to change the epsilon factor. Setting MATH_EPSILON to zero causes relational comparisons to be made without an epsilon factor. Otherwise, MATH_EPSILON values between 1E-15 and 1E-5 are valid. The epsilon factor may also be set using the MATH FSC Conversion Precision MET/CAL Configuration setting.

Use of an epsilon factor in MATH relational comparisons is a V7.10 feature. V7.01 SP1 and prior do not implement this feature. (To be more precise, V7.01q or later of MET/CAL Runtime and MET/CAL Editor is required for this feature to be present.)

RIF/WIF Data Directory

The directory used for data files accessed using the RIF and WIF MATH FSC functions may be specified using the General INI Folder MET/CAL Configuration setting.

In addition to directly specifying the directory to be used by RIF and WIF it's also legal to use the General INI Folder to specify that one of the directories used for user programs in connection with the DOS and DOSE FSCs be used. The syntax for this is:

General INI Folder | @user_data_dir (User Data Folder)
General INI Folder | @user_prog_dir (User Program Folder)
General INI Folder | @user_cwd (User Current Working Folder)

The General INI Folder setting, if any, is not used in cases where the procedure directly specifies the full path name of the data file. Any file name which begins with a '/', a '\', or a single letter followed by a ':', is considered to be a full path name.

Here are some examples of full path names:

  • \metcal\rifdata.ini
  • /metcal/rifdata.ini
  • C:\metcal\rifdata.ini

If no General INI Folder is specified and the procedure does not specify the full path name of the data file, the file must be placed in the Windows directory on the workstation. (In general, however, one should avoid placing MET/CAL-specific data files in the Windows directory. Using the General INI Folder setting is recommended.)

DOS FSC Executable to MATH FSC Function Cross-Reference

Several stand-alone executables have been used in the past to perform various functions by calling them with the DOS FSC. Over the years, some of the more commonly functions used functions have been implemented in the MATH FSC. This table provides a cross-reference from the executable to the MATH FSC function:

DOS FSC | MATH FSC | Notes
792_acdc.exe | Get792 | Requires new electronic format 792A data file from Fluke Calibration Standards Lab.
appendline.exe | Append | Append contents of MEM2 to an ASCII file.
get_acdc.exe | Read * | Fluke Calibration has developed subprocedures that use RIF to get A40 AC-DC Difference.
get_cdf.exe | FindCSV | Get single, comma-delimited string from specified file.
get_cert_val.exe | Read * | Fluke Calibration has developed subprocedures that use RIF to get 742A certified values.
get_err.exe | Read * | Get error data stored by “put_err.exe”.
get_sn.exe | SN | Get serial number in data file (see 792_acdc.exe and get_acdc.exe).
get_val.exe | Read * | Get real value for nominal value specified.
gettime.exe | Utime | Get number of seconds since 01/01/1970.
ini_val.exe | INI | Retrieves the value of a specified MET/CAL initialization file parameter.
itime.exe | ULDate | Get formatted date & time to seconds since 01/01/1970.
mak_file.exe | Write | Create a file.
put_err.exe | Append * | Put voltage & frequency error data on a given range into a file.
roll_off.exe | Read * | Get roll off for an attenuator at a given frequency.
* These executable encapsulate a file search algorithm using independent values "passed in" via DOSDOSE.DAT. A procedure using the MATH READ() function must also include code to search the file in an equivalent fashion.

Examples

  1.001 MATH MEM = MEM + M[1] + M[20]
  1.002 MATH M[3] = 7
  1.003 MATH MEM1 = M[2] / M[3]
  1.004 MATH MEM = MEM * MEM1 - 4.321
# Assign the string value xyz to string register 1.
  1.005 MATH S[1] = xyz
# Assign the concatenation of the string in S[1] with abc to MEM2.
  1.006 MATH MEM2 = S[1] & abc
# Calculate the square root of 2.
  1.007 MATH MEM = SQRT(2)
# Swap M[10] and M[11], using M[1] as a temporary register.
  1.008 MATH M[1] = M[10]; M[10] = M[11]; M[11] = M[1]


MATH FSC Accuracy Functions

Accuracy Specification Lookup
Primary Device (Instrument-based) | Auxiliary Device (Instrument-based) | (File-based) | Description
ACCV | ACCVA | ACCF | 1-parameter
ACCV2 | ACCV2A | ACCF2 | 2-parameter
ACCVF | ACCVFA | ACCFF | 1-parameter floor
ACCVF2 | ACCVF2A | ACCFF2 | 2-parameter floor
ACCVG | ACCVGA | ACCFG | 1-parameter gain
ACCVG2 | ACCVG2A | ACCFG2 | 2-parameter gain
ACCVGP | ACCVGPA | ACCFGP | 1-parameter gain in percent
ACCVGP2 | ACCVGP2A | ACCFGP2 | 2-parameter gain in percent
CONF | CONFA | CONFF | get accuracy file confidence value

Other Accuracy Functions
ACCNAME | return accuracy file name
REFACC | return accuracy from last setup

Primary Device Accuracy Specification Lookup (Instrument-based)

ACCV

Purpose: Reads a MET/CAL accuracy file to determine the system accuracy for the specified device, with the specified "mode", and the specified lookup value.
Quick Proto: acc = ACCV(device, mode, val)
Result Type:

numeric

The return value is the system accuracy, in base units. The accuracy is calculated from the accuracy file values as:

acc = 0.01 * gain * |val| + flr

where gain is the accuracy file gain value, flr is the accuracy file floor value, and val is the specified lookup value (argument 3).

Error Handling Same as ACCF2
Argument Type:

String, String, Numeric

  1. Device name; must be a configured instrument (system instrument*, user-configured instrument, or manual standard).
  2. Accuracy file mode string. Selects the appropriate section of the accuracy file.
System instruments are either primary devices or secondary devices Accuracy for a secondary device is stored in the accuracy file for the primary device. For example the 5725A Current Output accuracy is stored in the accuracy file of the controlling calibrator: 5700A or 5720A.
Compatibility: Requires V6.11c or later.
Example:

MATH MEM = ACCV("Fluke 5700A", "Volts", 5.0)

After execution of the ACCV call, MEM will contain the 5700 accuracy, in volts DC, at 5V.

Usage: ACCV may be used in conjunction with the ACC FSC to lookup a cal interval-dependent system accuracy value for use in the T.U.R. and measurement uncertainty calculations. When used with a user-configured instrument, the user (or procedure writer) is responsible for providing the necessary accuracy files.

ACCV2

Purpose:

ACCV2 reads a MET/CAL accuracy file to determine the system accuracy for the specified device, with the specified "mode", and the specified lookup values.

ACCV2 is like ACCV, except there are two numeric parameters which control the accuracy lookup.

Quick Proto: acc = ACCV2(device, mode, val1, val2)
Result Type:

numeric

The return value is the system accuracy, in base units. The accuracy is calculated from the accuracy file values as:

acc = 0.01 * gain * |val| + flr

where gain is the accuracy file gain value, flr is the accuracy file floor value, and val is the specified lookup value (argument 3).

Error Handling:

The following conditions prevent the execution of ACCV2. An error message is generated in each case.

  1. Device not configured.
  2. Device asset not specified.
  3. Device not in database.
  4. No accuracy file for specified device, asset, and cal interval.
  5. Duplicate accuracy files for specified device, asset, and cal interval.
  6. Accuracy data not found in accuracy file.
  7. Accuracy data set to "NA".
  8. Syntax error in accuracy file.
  9. Accuracy Check MET/CAL Configuration setting unchecked.
Argument Type:

String, String, Numeric, Numeric

  1. Device name; must be a configured instrument (system instrument*, user-configured instrument, or manual standard).
  2. Accuracy file mode string. Selects the appropriate section of the accuracy file.
  3. Numeric value at which the system accuracy is to be determined.
  4. Auxiliary numeric lookup control.
    1. Typically specifies the frequency when the accuracy is determined for an AC section of the accuracy file.
    2. For an instrument specified in terms of frequency, this parameter may specify an amplitude.
System instruments are either primary devices or secondary devices Accuracy for a secondary device is stored in the accuracy file for the primary device. For example the 5725A Current Output accuracy is stored in the accuracy file of the controlling calibrator: 5700A or 5720A.
Compatibility: Requires V6.11c or later.
Example:
MATH MEM2 = "Fluke 5700A"
MATH MEM = ACCV2(MEM2, "Volts", 5., 1E+3)

After execution of the ACCV2 call, MEM will contain the 5700 accuracy, in volts AC, at 5 V, 1 kHz.

Usage: ACCV2 may be used in conjunction with the ACC FSC to lookup a cal interval-dependent system accuracy value for use in the T.U.R. and measurement uncertainty calculations. When used with a user-configured instrument, the user (or procedure writer) is responsible for providing the necessary accuracy files.

ACCVF

Purpose: ACCVF reads a MET/CAL accuracy file to determine the floor component of the system accuracy for the specified device, with the specified "mode", and the specified lookup value.
Quick Proto: floor = ACCVF(device, mode, val)
Result Type:

numeric

The return value is the floor component of the system accuracy, in base units. The floor spec is the value specified in column 6 of a MET/CAL accuracy file.

Error Handling: Same as ACCV.
Argument Type:

String, String, Numeric

  1. Device name; must be a configured instrument (system instrument*, user-configured instrument, or manual standard).
  2. Accuracy file mode string. Selects the appropriate section of the accuracy file.
  3. Numeric value at which the floor component of the system accuracy is to be determined.
*Note, system instruments are either primary devices or secondary devices Accuracy for a secondary device is stored in the accuracy file for the primary device. For example the 5725A Current Output accuracy is stored in the accuracy file of the controlling calibrator: 5700A or 5720A.
Compatibility: Requires V7.20 or later.
Example:
MATH dev = "Fluke 5700A"
MATH mode = "Volts"
MATH v = 5.0
MATH flr = ACCVF(dev, mode, v)

After execution of the ACCVF call, the value of the variable "flr" will be the 5700 VDC floor accuracy at 5 V.

ACCVF2

Purpose: ACCVF2 reads a MET/CAL accuracy file to determine the floor component of the system accuracy for the specified device, with the specified "mode", and the specified lookup values. ACCVF2 is like ACCVF, except there are two numeric parameters which control the accuracy lookup.
Quick Proto: floor = ACCVF2(device, mode, val1, val2)
Result Type:

numeric

The return value is the floor component of the system accuracy, in base units. The floor spec is the value specified in column 6 of a MET/CAL accuracy file.

Error Handling: Same as ACCV2.
Argument Type:

String, String, Numeric, Numeric

  1. Device name; must be a configured instrument (system instrument*, user-configured instrument, or manual standard).
  2. Accuracy file mode string. Selects the appropriate section of the accuracy file.
  3. Numeric value at which the floor component of the system accuracy is to be determined.
  4. Auxiliary numeric lookup control.
    1. Typically specifies the frequency when the floor accuracy is determined for an AC section of the accuracy file.
    2. For an instrument specified in terms of frequency, this parameter may specify an amplitude.
*Note, system instruments are either primary devices or secondary devices Accuracy for a secondary device is stored in the accuracy file for the primary device. For example the 5725A Current Output accuracy is stored in the accuracy file of the controlling calibrator: 5700A or 5720A.
Compatibility: Requires V7.20 or later.
Example:
MATH dev = "Fluke 5700A"
MATH mode = "Volts B1"
MATH v = 1000.0
MATH freq = 25E+3
MATH flr = ACCVF2(dev, mode, v, freq)

After execution of the ACCVF2 call, the value of the variable "flr" will be the 5700 VAC floor accuracy at 1000 V, 25 kHz, using the 5725A boost amp.

ACCVG

Purpose: ACCVG reads a MET/CAL accuracy file to determine the gain component of the system accuracy for the specified device, with the specified "mode", and the specified lookup value.
Quick Proto: gain = ACCVG(device, mode, val)
Result Type:

numeric

The return value is the gain component of the system accuracy, in base units. In a MET/CAL accuracy file, the gain error is specified (as a percentage) in column 5. The value returned by ACCVG is calculated as:

acc = 0.01 * gain * |val|
Error Handling: Same as ACCV.
Argument Type:

String, String, Numeric

  1. Device name; must be a configured instrument (system instrument*, user-configured instrument, or manual standard).
  2. Accuracy file mode string. Selects the appropriate section of the accuracy file.
  3. Numeric value at which the gain component of the system accuracy is to be determined.
*Note, system instruments are either primary devices or secondary devices Accuracy for a secondary device is stored in the accuracy file for the primary device. For example the 5725A Current Output accuracy is stored in the accuracy file of the controlling calibrator: 5700A or 5720A.
Compatibility: Requires V7.20 or later.
Example:
MATH dev = "Fluke 5700A"
MATH mode = "Volts"
MATH v = 5.0
MATH gain = ACCVG(dev, mode, v)

After execution of the ACCVG call, the value of the variable "gain" will be the 5700 VDC gain accuracy at 5 V.

ACCVG2

Purpose:

ACCVG2 reads a MET/CAL accuracy file to determine the gain component of the system accuracy for the specified device, with the specified "mode", and the specified lookup values.

ACCVG2 is like ACCVG, except there are two numeric parameters which control the accuracy lookup.

Quick Proto: gain = ACCVG2(device, mode, val1, val2)
Result Type:

numeric

The return value is the gain component of the system accuracy, in base units. In a MET/CAL accuracy file, the gain error is specified (as a percentage) in column 5. The value returned by ACCVG2 is calculated as:

acc = 0.01 * gain * |val|

where val is the 3rd argument in the call to ACCVG2. Error Handling: Same as ACCV2.

Argument Type:

String, String, Numeric, Numeric

  1. Device name; must be a configured instrument (system instrument*, user-configured instrument, or manual standard).
  2. Accuracy file mode string. Selects the appropriate section of the accuracy file.
  3. Numeric value at which the system accuracy is to be determined.
  4. Auxiliary numeric lookup control.
    1. Typically specifies the frequency when the gain accuracy is determined for an AC section of the accuracy file.
    2. For an instrument specified in terms of frequency, this parameter may specify an amplitude.
*Note, system instruments are either primary devices or secondary devices Accuracy for a secondary device is stored in the accuracy file for the primary device. For example the 5725A Current Output accuracy is stored in the accuracy file of the controlling calibrator: 5700A or 5720A.
Compatibility: Requires V7.20 or later.
Example:
MATH dev = "Fluke 5700A"
MATH mode = "Volts B1"
MATH v = 1000.0
MATH freq = 25E+3
MATH gain = ACCVG2(dev, mode, v, freq)

After execution of the ACCVG2 call, the value of the variable "gain" will be the 5700 VAC gain accuracy at 1000 V, 25 kHz, using the 5725A boost amp.

ACCVGP

Purpose: ACCVGP reads a MET/CAL accuracy file to determine the gain component of the system accuracy for the specified device, with the specified "mode", and the specified lookup value.
Quick Proto: gain = ACCVGP(device, mode, val)
Result Type:

Numeric

The return value is the gain component of the system accuracy, as entered in the accuracy file. In a MET/CAL accuracy file, the gain error is specified in column 5.
Error Handling Same as ACCV
Argument Type:

String, String, Numeric

  1. Device name; must be a configured instrument (system instrument*, user-configured instrument, or manual standard).
  2. Accuracy file mode string. Selects the appropriate section of the accuracy file.
  3. Numeric value at which the gain component of the system accuracy is to be determined.
*Note, system instruments are either primary devices or secondary devices Accuracy for a secondary device is stored in the accuracy file for the primary device. For example the 5725A Current Output accuracy is stored in the accuracy file of the controlling calibrator: 5700A or 5720A.
Compatibility: Requires V8.0 or later
Example:
MATH dev = "Fluke 5700A"
MATH mode = "Volts"
MATH v = 5.0
MATH gain = ACCVG(dev, mode, v)

After execution of the ACCVG call, the value of the variable "gain" will be the 5700 VDC gain accuracy at 5V in percent.

ACCVGP2

Purpose: ACCVGP reads a MET/CAL accuracy file to determine the gain component of the system accuracy for the specified device, with the specified "mode", and the specified lookup value.
Quick Proto: gain = ACCVGP(device, mode, val)
Result Type:

Numeric

The return value is the gain component of the system accuracy, as entered in the accuracy file. In a MET/CAL accuracy file, the gain error is specified in column 5.

where val is the 3rd argument in the call to ACCVGP2.
Error Handling Same as ACCV
Argument Type:

String, String, Numeric, Numeric

  1. Device name; must be a configured instrument (system instrument*, user-configured instrument, or manual standard).
  2. Accuracy file mode string. Selects the appropriate section of the accuracy file.
  3. Numeric value at which the system accuracy is to be determined.
  4. Auxiliary numeric lookup control.
    1. Typically specifies the frequency when the gain accuracy is determined for an AC section of the accuracy file.
    2. For an instrument specified in terms of frequency, this parameter may specify an amplitude.
*Note, system instruments are either primary devices or secondary devices Accuracy for a secondary device is stored in the accuracy file for the primary device. For example the 5725A Current Output accuracy is stored in the accuracy file of the controlling calibrator: 5700A or 5720A.
Compatibility: Requires V8.0 or later
Example:
MATH dev = "Fluke 5700A"
MATH mode = "Volts B1"
MATH v = 1000.0
MATH freq = 25E+3
MATH gain = ACCVG2(dev, mode, v, freq)

After execution of the ACCVG2 call, the value of the variable "gain" will be the 5700 VAC gain accuracy at 1000 V, 25 kHz, using the 5725A boost amp.

CONF

Purpose: CONF returns the confidence value from the header of the accuracy file associated with a specified device.
Result Type:

Numeric

The return value is the confidence value from the accuracy file header. The confidence is expressed as a "sigma" value. For example, 2.58 means 2.58 sigma.
Error Handling

The following conditions prevent the execution of CONF. An error message is generated in each case.

  1. Device not configured.
  2. Device asset not specified.
  3. Device not in database.
  4. No accuracy file for specified device, asset, and cal interval.
  5. Duplicate accuracy files for specified device, asset, and cal interval.
  6. Accuracy Check MET/CAL Configuration setting unchecked.
Argument Type:

String

  1. Device name; must be either a supported system instrument* (like "Fluke 5700A") or a user-configured device.
*Note, system instruments are either primary devices or secondary devices. Accuracy for a secondary device is stored in the accuracy file for the primary device. For example the 5725A Current Output accuracy is stored in the accuracy file of the controlling calibrator: 5700A or 5720A.
Compatibility: Requires 6.11f or later.
See Also ACCV, ACCV2
Example:

MATH MEM = CONF("Fluke 5700A")

After execution of the CONF call, MEM will contain the confidence value from the Fluke 5700A accuracy file.
Usage:

When used with ACCV or ACCV2, CONF may be used to normalize the system accuracy to one-sigma for use in the measurement uncertainty calculation.

For example, a sequence of statements like:

MATH S[1] = "Agilent XYZ"
MATH S[2] = "Volts"
MATH M[1] = ACCV(S[1], S[2], 5.)
MATH M[2] = CONF(S[1])
MATH M[3] = M[1] / M[2]
VSET SYS_ACC = [M3]

may be used to look up the accuracy of the user-configured instrument "Agilent XYZ" at 5 VDC, determine the associated confidence of the spec, normalize to 1 sigma, and assign the normalized value to SYS_ACC for use in the measurement uncertainty calculation.

When used with a user-configured instrument, the user (or procedure writer) is responsible for providing the necessary accuracy files.

Auxiliary Device Accuracy Specification Lookup (Instrument-based)

ACCVA

Purpose: Reads a MET/CAL accuracy file to determine the system accuracy for the specified device, with the specified "mode", and the specified lookup value.
Quick Proto: acc = ACCVA(primary device, auxiliary device, mode, val)
Result Type:

numeric

The return value is the system accuracy, in base units. The accuracy is calculated from the accuracy file values as:

acc = 0.01 * gain * |val| + flr

where gain is the accuracy file gain value, flr is the accuracy file floor value, and val is the specified lookup value (argument 3).

Error Handling Same as ACCF2A
Argument Type:

String, String, String, Numeric

  1. Primary device name; must be a configured system instrument.
  2. Auxiliary device name; must be configured as an auxiliary device to the primary.
  3. Accuracy file mode string. Selects the appropriate section of the accuracy file.
  4. Numeric value at which the system accuracy is to be determined.
Compatibility: Requires version 8.3.1 or later.
Example:

MATH MEM = ACCVA("Fluke 5502A", "Fluke 5500A/COIL", "Non-toroidal", 150)

After execution of the ACCVA call, MEM will contain the coil's accuracy, in amps DC, at 150 A.
Usage: ACCVA may be used in conjunction with the ACC FSC to lookup a cal interval-dependent system accuracy value for use in the T.U.R. and measurement uncertainty calculations. When used with a user-configured instrument, the user (or procedure writer) is responsible for providing the necessary accuracy files.

ACCV2A

Purpose:

ACCV2A reads a MET/CAL accuracy file to determine the system accuracy for the specified device, with the specified "mode", and the specified lookup values.

ACCV2A is like ACCVA, except there are two numeric parameters which control the accuracy lookup.

Quick Proto: acc = ACCV2A(primary device, auxiliary device, mode, val1, val2)
Result Type:

numeric

The return value is the system accuracy, in base units. The accuracy is calculated from the accuracy file values as:

acc = 0.01 * gain * |val| + flr

where gain is the accuracy file gain value, flr is the accuracy file floor value, and val is the specified lookup value (argument 3).

Error Handling:

The following conditions prevent the execution of ACCV2A. An error message is generated in each case.

  1. Device not configured.
  2. Device asset not specified.
  3. Device not in database.
  4. No accuracy file for specified device, asset, and cal interval.
  5. Duplicate accuracy files for specified device, asset, and cal interval.
  6. Accuracy data not found in accuracy file.
  7. Accuracy data set to "NA".
  8. Syntax error in accuracy file.
  9. Accuracy Check MET/CAL Configuration setting unchecked.
Argument Type:

String, String, String, Numeric, Numeric

  1. Primary device name; must be a configured system instrument.
  2. Auxiliary device name; must be configured as an auxiliary device to the primary.
  3. Accuracy file mode string. Selects the appropriate section of the accuracy file.
  4. Numeric value at which the system accuracy is to be determined.
  5. Auxiliary numeric lookup control.
    1. Typically specifies the frequency when the accuracy is determined for an AC section of the accuracy file.
    2. For an instrument specified in terms of frequency, this parameter may specify an amplitude.
Compatibility: Requires version 8.3.1 or later.
Example:

MATH MEM = ACCV2A("Fluke 5502A", "Fluke 5500A/COIL", "Toroidal", 50, 400)

After execution of the ACCV2A call, MEM will contain the coil's accuracy in amps AC, at 50 A, 400 Hz.

Usage: ACCV2A may be used in conjunction with the ACC FSC to lookup a cal interval-dependent system accuracy value for use in the T.U.R. and measurement uncertainty calculations. When used with a user-configured instrument, the user (or procedure writer) is responsible for providing the necessary accuracy files.

ACCVFA

Purpose: ACCVFA reads a MET/CAL accuracy file to determine the floor component of the system accuracy for the specified device, with the specified "mode", and the specified lookup value.
Quick Proto: floor = ACCVFA(primary device, auxiliary device, mode, val)
Result Type:

numeric

The return value is the floor component of the system accuracy, in base units. The floor spec is the value specified in column 6 of a MET/CAL accuracy file.

Error Handling: Same as ACCVA.
Argument Type:

String, String, String, Numeric

  1. Primary device name; must be a configured system instrument.
  2. Auxiliary device name; must be configured as an auxiliary device to the primary.
  3. Accuracy file mode string. This string selects the appropriate section of the accuracy file.
  4. Numeric value at which the floor component of the system accuracy is to be determined.
Compatibility: Requires version 8.3.1 or later.
Example:
MATH primary = "Fluke 5502A"
MATH aux = "Fluke 5500A/COIL"
MATH mode = "Non-toroidal"
MATH a = 5
MATH flr = ACCVFA(primary, aux, mode, a)

After execution of the ACCVFA call, the value of the variable "flr" will be the coil's floor accuracy at 5 A.

ACCVF2A

Purpose: ACCVF2A reads a MET/CAL accuracy file to determine the floor component of the system accuracy for the specified device, with the specified "mode", and the specified lookup values. ACCVF2A is like ACCVFA, except there are two numeric parameters which control the accuracy lookup.
Quick Proto: floor = ACCVF2A(primary device, auxiliary device, mode, val1, val2)
Result Type:

numeric

The return value is the floor component of the system accuracy, in base units. The floor spec is the value specified in column 6 of a MET/CAL accuracy file.

Error Handling: Same as ACCV2A.
Argument Type:

String, String, String, Numeric, Numeric

  1. Primary device name; must be a configured system instrument.
  2. Auxiliary device name; must be configured as an auxiliary device to the primary.
  3. Accuracy file mode string. Selects the appropriate section of the accuracy file.
  4. Numeric value at which the floor component of the system accuracy is to be determined.
  5. Auxiliary numeric lookup control.
    1. Typically specifies the frequency when the floor accuracy is determined for an AC section of the accuracy file.
    2. For an instrument specified in terms of frequency, this parameter may specify an amplitude.
Compatibility: Requires version 8.3.1 or later.
Example:
MATH primary = "Fluke 5502A"
MATH aux = "Fluke 5500A/COIL"
MATH mode = "Non-toroidal"
MATH a = 1000
MATH freq = 400
MATH flr = ACCVF2(primary, aux, mode, a, freq)

After execution of the ACCVF2 call, the value of the variable "flr" will be the coil's floor accuracy at 1000 A, 400 Hz.

ACCVGA

Purpose: ACCVGA reads a MET/CAL accuracy file to determine the gain component of the system accuracy for the specified device, with the specified "mode", and the specified lookup value.
Quick Proto: gain = ACCVGA(primary device, auxiliary device, mode, val)
Result Type:

numeric

The return value is the gain component of the system accuracy, in base units. In a MET/CAL accuracy file, the gain error is specified (as a percentage) in column 5. The value returned by ACCVG is calculated as:

acc = 0.01 * gain * |val|
Error Handling: Same as ACCVA.
Argument Type:

String, String, String, Numeric

  1. Primary device name; must be a configured system instrument.
  2. Auxiliary device name; must be configured as an auxiliary device to the primary.
  3. Accuracy file mode string. Selects the appropriate section of the accuracy file.
  4. Numeric value at which the gain component of the system accuracy is to be determined.
Compatibility: Requires version 8.3.1 or later.
Example:
MATH primary = "Fluke 5502A"
MATH aux = "Fluke 5500A/COIL"
MATH mode = "Non-toroidal"
MATH a = 50
MATH MEM2 = ACCVG(primary, aux, mode, a)

After execution of the ACCVGA call, MEM2 will contain the coil's gain accuracy at 50 A.

ACCVG2A

Purpose:

ACCVG2A reads a MET/CAL accuracy file to determine the gain component of the system accuracy for the specified device, with the specified "mode", and the specified lookup values.

ACCVG2A is like ACCVGA, except there are two numeric parameters which control the accuracy lookup.

Quick Proto: gain = ACCVG2A(primary device, auxiliary device, mode, val1, val2)
Result Type:

numeric

The return value is the gain component of the system accuracy, in base units. In a MET/CAL accuracy file, the gain error is specified (as a percentage) in column 5. The value returned by ACCVG2 is calculated as:

acc = 0.01 * gain * |val|

where val is the 3rd argument in the call to ACCVG2A.
Error Handling: Same as ACCV2A.
Argument Type:

String, String, String, Numeric, Numeric

  1. Primary device name; must be a configured system instrument.
  2. Auxiliary device name; must be configured as an auxiliary device to the primary.
  3. Accuracy file mode string. Selects the appropriate section of the accuracy file.
  4. Numeric value at which the system accuracy is to be determined.
  5. Auxiliary numeric lookup control.
    1. Typically specifies the frequency when the gain accuracy is determined for an AC section of the accuracy file.
    2. For an instrument specified in terms of frequency, this parameter may specify an amplitude.
Compatibility: Requires version 8.1.3 or later.
Example:
MATH primary = "Fluke 5502A"
MATH aux = "Fluke 5500A/COIL"
MATH mode = "Non-toroidal"
MATH a = 1000
MATH freq = 400
MATH MEM2 = ACCVG2A(primary, aux, mode, a, freq)

After execution of the ACCVG2 call, MEM2 will contain the coil's gain accuracy at 1000 A, 400 Hz.

ACCVGPA

Purpose: ACCVGPA reads a MET/CAL accuracy file to determine the gain component of the system accuracy for the specified device, with the specified "mode", and the specified lookup value.
Quick Proto: gain = ACCVGPA(primary device, auxiliary device, mode, val)
Result Type:

Numeric

The return value is the gain component of the system accuracy, as entered in the accuracy file. In a MET/CAL accuracy file, the gain error is specified in column 5.
Error Handling: Same as ACCVA
Argument Type:

String, String, String, Numeric

  1. Primary device name; must be a configured system instrument.
  2. Auxiliary device name; must be configured as an auxiliary device to the primary.
  3. Accuracy file mode string. Selects the appropriate section of the accuracy file.
  4. Numeric value at which the gain component of the system accuracy is to be determined.
Compatibility: Requires version 8.3.1 or later
Example:
MATH primary = "Fluke 5502A"
MATH aux = "Fluke 5500A/COIL"
MATH mode = "Non-toroidal"
MATH a = 50
MATH MEM2 = ACCVGA(primary, aux, mode, a)

After execution of the ACCVGA call, MEM2 will contain the coil's gain accuracy at 50 A in percent.

ACCVGP2A

Purpose: ACCVGPA reads a MET/CAL accuracy file to determine the gain component of the system accuracy for the specified device, with the specified "mode", and the specified lookup value.
Quick Proto: gain = ACCVGPA(primary device, auxiliary device, mode, val)
Result Type:

Numeric

The return value is the gain component of the system accuracy, as entered in the accuracy file. In a MET/CAL accuracy file, the gain error is specified in column 5.

where val is the 3rd argument in the call to ACCVGP2A.
Error Handling Same as ACCVA
Argument Type:

String, String, String, Numeric

  1. Primary device name; must be a configured system instrument.
  2. Auxiliary device name; must be configured as an auxiliary device to the primary.
  3. Accuracy file mode string. Selects the appropriate section of the accuracy file.
  4. Numeric value at which the system accuracy is to be determined.
  5. Auxiliary numeric lookup control.
    1. Typically specifies the frequency when the gain accuracy is determined for an AC section of the accuracy file.
    2. For an instrument specified in terms of frequency, this parameter may specify an amplitude.
Compatibility: Requires version 8.3.1 or later
Example:
MATH primary = "Fluke 5502A"
MATH aux = "Fluke 5500A/COIL"
MATH mode = "Non-toroidal"
MATH a = 1000
MATH freq = 400
MATH MEM2 = ACCVG2(primary, aux, mode, a, freq)

After execution of the ACCVG2 call, MEM2 will contain the coil's gain accuracy at 1000 A, 400 Hz.

CONFA

Purpose: CONFA returns the confidence value from the header of the accuracy file associated with a specified device.
Result Type:

Numeric

The return value is the confidence value from the accuracy file header. The confidence is expressed as a "sigma" value. For example, 2.58 means 2.58 sigma.
Error Handling

The following conditions prevent the execution of CONFA. An error message is generated in each case.

  1. Device not configured.
  2. Device asset not specified.
  3. Device not in database.
  4. No accuracy file for specified device, asset, and cal interval.
  5. Duplicate accuracy files for specified device, asset, and cal interval.
  6. Accuracy Check MET/CAL Configuration setting unchecked.
Argument Type:

String, String

  1. Primary device name; must be a configured system instrument.
  2. Auxiliary device name; must be configured as an auxiliary device to the primary.
Compatibility: Requires 6.11f or later.
See Also ACCVA, ACCV2A
Example:

MATH MEM = CONFA("Fluke 5502A", "Fluke 5500A/COIL")

After execution of the CONFA call, MEM will contain the accuracy file's confidence value for the Fluke 5500A/COIL configured as an auxiliary device to the Fluke 5502A.
Usage:

When used with other functions, CONFA may be used to normalize the system accuracy to one-sigma for use in the measurement uncertainty calculation. For example, a sequence of statements like:

MATH primary = "Fluke 96270A"
MATH aux = "Agilent 11667A"
MATH mode = "Output SWR"
MATH f = 20E+9
MATH acc = ACCVA(primary, aux, mode, f)
MATH conf = CONFA(primary, aux)
MATH L[1] = acc / conf
VSET SYS_ACC = [L1]

may be used to look up the accuracy of the Agilent 11667A power splitter, configured as an auxiliary device to the Fluke 96270A, at 20 GHz, determine the associated confidence of the spec, normalize to 1 sigma, and assign the normalized value to SYS_ACC for use in the measurement uncertainty calculation.

Accuracy Specification Lookup (File-based)

ACCF

Purpose: ACCF reads a specified MET/CAL accuracy file to determine the system accuracy with the specified "mode", and the specified lookup value.
Quick Proto: acc = ACCF(file, mode, val)
Result Type:

numeric

The return value is the system accuracy, in base units. The accuracy is calculated from the accuracy file values as:

acc = 0.01 * gain * |val| + flr

where gain is the accuracy file gain value, flr is the accuracy file floor value, and val is the specified lookup value (argument 3).
Error Handling:

The following conditions prevent the execution of ACCF. An error message is generated in each case.

  1. Accuracy file not found.
  2. Accuracy data not found in accuracy file.
  3. Accuracy data set to "NA".
  4. Syntax error in accuracy file.
  5. Accuracy Check MET/CAL Configuration setting unchecked.
Argument Type:

String, String, Numeric

  1. Accuracy file name.
    1. If the name is not a full path name, the optional MET/CAL Configuration setting Accuracy File Folder Primary specifies the directory.
    2. If Accuracy File Folder Primary is not specified, the MET/CAL Configuration setting Accuracy File Folder specifies the directory (unless Partial Path is Relative to Accuracy Directory is unchecked).
  2. Accuracy file mode string. Selects the appropriate section of the accuracy file.
  3. Numeric value at which the system accuracy is to be determined.
Compatibility: Requires V7.20z or later.
Example:

MATH MEM = ACCF("5700.acc", "Volts", 5.0)

After execution of the ACCF call, MEM will contain the 5700 accuracy, in volts DC, at 5.0 V.
Usage:

ACCF may be used in conjunction with the ACC FSC to lookup a cal interval-dependent system accuracy value for use in the T.U.R. and measurement uncertainty calculations.

When used with a user-configured instrument, the user (or procedure writer) is responsible for providing the necessary accuracy files.

ACCF2

Purpose:

ACCF2 reads a MET/CAL accuracy file to determine the system accuracy with the specified "mode", and the specified lookup values.

ACCF2 is like ACCF, except there are two numeric parameters which control the accuracy lookup.

Quick Proto: acc = ACCF2(file, mode, val1, val2)
Result Type:

Numeric

The return value is the system accuracy, in base units. The accuracy is calculated from the accuracy file values as:

acc = 0.01 * gain * |val| + flr

where gain is the accuracy file gain value, flr is the accuracy file floor value, and val is the specified lookup value (argument 3).

Error Handling:

The following conditions prevent the execution of ACCF2. An error message is generated in each case.

  1. Accuracy file not found.
  2. Accuracy data not found in accuracy file.
  3. Accuracy data set to "NA".
  4. Syntax error in accuracy file.
  5. Accuracy Check MET/CAL Configuration setting unchecked.
Argument Type:

String, String, Numeric, Numeric

  1. Accuracy file name.

    1. If the name is not a full path name, the optional MET/CAL Configuration setting "Accuracy File Folder Primary" specifies the directory.
    2. If "Accuracy File Folder Primary" is not specified, the MET/CAL Configuration setting "Accuracy File Folder" specifies the directory (unless "Partial Path is Relative to Accuracy Directory" is unchecked).

  2. Accuracy file mode string. Selects the appropriate section of the accuracy file.

  3. Numeric value at which the system accuracy is to be determined.

  4. Auxiliary numeric lookup control.

    1. Typically specifies the frequency when the accuracy is determined for an AC section of the accuracy file.
    2. For an instrument specified in terms of frequency, this parameter may specify an amplitude.
Compatibility: Requires V7.20z or later.
Example:
MATH f = "5700.acc"
MATH MEM = ACCF2(f, "Volts", 5.0, 1E+3)

After execution of the ACCF2 call, MEM will contain the 5700 accuracy, in volts AC, at 5 V, 1 kHz.
Usage:

ACCF2 may be used in conjunction with the ACC FSC to lookup a cal interval-dependent system accuracy value for use in the T.U.R. and measurement uncertainty calculations.

When used with a user-configured instrument, the user (or procedure writer) is responsible for providing the necessary accuracy files.

ACCFF

Purpose: ACCFF reads a MET/CAL accuracy file to determine the floor component of the system accuracy with the specified "mode", and the specified lookup value.
Quick Proto: floor = ACCFF(file, mode, val)
Result Type:

numeric

The return value is the floor component of the system accuracy, in base units. The floor spec is the value specified in column 6 of a MET/CAL accuracy file.

Error Handling: Same as ACCF.
Argument Type:

String, String, Numeric

  1. Accuracy file name.

    1. If the name is not a full path name, the optional MET/CAL Configuration setting "Accuracy File Folder Primary" specifies the directory.
    2. If "Accuracy File Folder Primary" is not specified, the MET/CAL Configuration setting "Accuracy File Folder" specifies the directory (unless "Partial Path is Relative to Accuracy Directory" is unchecked).

  2. Accuracy file mode string. Selects the appropriate section of the accuracy file.

  3. Numeric value at which the floor component of the system accuracy is to be determined

Compatibility: Requires V7.20z or later.
Example:
MATH mode = "Volts"
MATH v = 5.0
MATH flr = ACCFF(file, mode, v)

After execution of the ACCFF call, the value of the variable "flr" will be the 5700 VDC floor accuracy at 5V.

ACCFF2

Purpose:

ACCFF2 reads a MET/CAL accuracy file to determine the floor component of the system accuracy with the specified "mode", and the specified lookup values.

ACCFF2 is like ACCFF, except there are two numeric parameters which control the accuracy lookup.

Quick Proto: floor = ACCFF2(file, mode, val1, val2)
Result Type:

numeric

The return value is the floor component of the system accuracy, in base units. The floor spec is the value specified in column 6 of a MET/CAL accuracy file. Error Handling: Same as ACCF2.

Argument Type:

String, String, Numeric, Numeric

  1. Accuracy file name.

    1. If the name is not a full path name, the optional MET/CAL Configuration setting "Accuracy File Folder Primary" specifies the directory.
    2. If "Accuracy File Folder Primary" is not specified, the MET/CAL Configuration setting "Accuracy File Folder" specifies the directory (unless "Partial Path is Relative to Accuracy Directory" is unchecked).

  2. Accuracy file mode string. Selects the appropriate section of the accuracy file.

  3. Numeric value at which the floor component of the system accuracy is to be determined.

  4. Auxiliary numeric lookup control.

    1. Typically specifies the frequency when the floor accuracy is determined for an AC section of the accuracy file.
    2. For an instrument specified in terms of frequency, the fourth parameter may specify an amplitude.
Compatibility: Requires V7.20z or later.
Example:
MATH file = "5700.acc"
MATH mode = "Volts B1"
MATH v = 1000.0
MATH freq = 25E+3
MATH flr = ACCFF2(file, mode, v, freq)

After execution of the ACCFF2 call, the value of the variable flr will be the 5700 VAC floor accuracy at 1000 V, 25 kHz, using the 5725A boost amp.

ACCFG

Purpose: ACCFG reads a MET/CAL accuracy file to determine the gain component of the system accuracy with the specified "mode", and the specified lookup value.
Quick Proto: gain = ACCFG(file, mode, val)
Result Type:

numeric

The return value is the gain component of the system accuracy, in base units. In a MET/CAL accuracy file, the gain error is specified (as a percentage) in column 5. The value returned by ACCVG is calculated as:

acc = 0.01 * gain * |val|

Error Handling: Same as ACCF.
Argument Type:

String, String, Numeric

  1. Accuracy file name.

    1. If the name is not a full path name, the optional MET/CAL Configuration setting "Accuracy File Folder Primary" specifies the directory.
    2. If "Accuracy File Folder Primary" is not specified, the MET/CAL Configuration setting "Accuracy File Folder" specifies the directory (unless "Partial Path is Relative to Accuracy Directory" is unchecked).

  2. Accuracy file mode string. Selects the appropriate section of the accuracy file.

  3. Numeric value at which the gain component of the system accuracy is to be determined.

Compatibility: Requires V7.20z or later.
Example:
MATH file = "5700.acc"
MATH mode = "Volts"
MATH v = 5.0
MATH gain = ACCFG(file, mode, v)

After execution of the ACCFG call, the value of the variable "gain" will be the 5700 VDC gain accuracy at 5V.

ACCFG2

Purpose: ACCFG2 reads a MET/CAL accuracy file to determine the gain component of the system accuracy with the specified "mode", and the specified lookup values. ACCFG2 is like ACCFG, except there are two numeric parameters which control the accuracy lookup.
Quick Proto: gain = ACCFG2(file, mode, val1, val2)
Result Type:

numeric

The return value is the gain component of the system accuracy, in base units. In a MET/CAL accuracy file, the gain error is specified (as a percentage) in column 5. The value returned by ACCVG2 is calculated as:

acc = 0.01 * gain * |val|

where val is the 3rd argument in the call to ACCVG2.

Error Handling: Same as ACCF2.
Argument Type:

String, String, Numeric, Numeric

  1. Accuracy file name.

    1. If the name is not a full path name, the optional MET/CAL Configuration setting "Accuracy File Folder Primary" specifies the directory.
    2. If "Accuracy File Folder Primary" is not specified, the MET/CAL Configuration setting "Accuracy File Folder" specifies the directory (unless "Partial Path is Relative to Accuracy Directory" is unchecked).

  2. Accuracy file mode string. Selects the appropriate section of the accuracy file.

  3. Numeric value at which the system accuracy is to be determined.

  4. Auxiliary numeric lookup control.

    1. Typically specifies the frequency when the gain accuracy is determined for an AC section of the accuracy file.
    2. For an instrument specified in terms of frequency, this parameter may specify an amplitude.
Compatibility: Requires V7.20z or later.
Example:
MATH file = "5700"
MATH mode = "Volts B1"
MATH v = 1000.0
MATH freq = 25E+3
MATH gain = ACCFG2(file, mode, v, freq)

After execution of the ACCFG2 call, the value of the variable "gain" will be the 5700 VAC gain accuracy at 1000V, 25 kHz, using the 5725A boost amp.

ACCFGP

Purpose: ACCFGP reads a MET/CAL accuracy file to determine the gain component of the system accuracy with the specified "mode", and the specified lookup value.
Quick Proto: gain = ACCFGP(file, mode, val)
Result Type:

Numeric

The return value is the gain component of the system accuracy, as entered in the accuracy file. In a MET/CAL accuracy file, the gain error is specified in column 5.
Error Handling Same as ACCF
Argument Type:

String, String, Numeric

  1. Accuracy file name.

    1. If the name is not a full path name, the optional MET/CAL Configuration setting "Accuracy File Folder Primary" specifies the directory.
    2. If "Accuracy File Folder Primary" is not specified, the MET/CAL Configuration setting "Accuracy File Folder" specifies the directory (unless "Partial Path is Relative to Accuracy Directory" is unchecked).

  2. Accuracy file mode string. Selects the appropriate section of the accuracy file.

  3. Numeric value at which the gain component of the system accuracy is to be determined.
Compatibility: Requires V8.0 or later
Example:
MATH file = "5700.acc"
MATH mode = "Volts"
MATH v = 5.0
MATH gain = ACCFGP(file, mode, v)

After execution of the ACCFG call, the value of the variable "gain" will be the 5700 VDC gain accuracy at 5V in percent.

ACCFGP2

Purpose:

ACCFGP2 reads a MET/CAL accuracy file to determine the gain component of the system accuracy with the specified "mode", and the specified lookup values.

ACCFGP2 is like ACCFGP, except there are two numeric parameters which control the accuracy lookup.
Quick Proto: gain = ACCFGP2(file, mode, val1, val2)
Result Type:

Numeric

The return value is the gain component of the system accuracy, as entered in the accuracy file. In a MET/CAL accuracy file, the gain error is specified in column 5. Where val is the 3rd argument in the call to ACCVGP2.
Error Handling Same as ACCF2
Argument Type:

String, String, Numeric,Numeric

  1. Accuracy file name.

    1. If the name is not a full path name, the optional MET/CAL Configuration setting "Accuracy File Folder Primary" specifies the directory.
    2. If "Accuracy File Folder Primary" is not specified, the MET/CAL Configuration setting "Accuracy File Folder" specifies the directory (unless "Partial Path is Relative to Accuracy Directory" is unchecked).

  2. Accuracy file mode string. Selects the appropriate section of the accuracy file.

  3. Numeric value at which the system accuracy is to be determined.

  4. Auxiliary numeric lookup control.

    1. Typically specifies the frequency when the gain accuracy is determined for an AC section of the accuracy file.
    2. For an instrument specified in terms of frequency, this parameter may specify an amplitude.
Compatibility: Requires V8.0 or later
Example:
MATH file = "5700"
MATH mode = "Volts B1"
MATH v = 1000.0
MATH freq = 25E+3
MATH gain = ACCFG2(file, mode, v, freq)

After execution of the ACCFG2 call, the value of the variable "gain" will be the 5700 VAC gain accuracy at 1000V, 25 kHz, using the 5725A boost amp.

CONFF

Purpose: CONFF returns the confidence value from the header of a specified accuracy file.
Result Type:

numeric

The return value is the confidence value from the accuracy file header. The confidence is expressed as a "sigma" value. For example, 2.58 means 2.58 sigma.

Argument Type:

String

  1. Accuracy file name.

    1. If the name is not a full path name, the optional MET/CAL Configuration setting "Accuracy File Folder Primary" specifies the directory.
    2. If "Accuracy File Folder Primary" is not specified, the MET/CAL Configuration setting "Accuracy File Folder" specifies the directory (unless "Partial Path is Relative to Accuracy Directory" is unchecked).
Compatibility: Requires V7.20A or later.
See Also: CONF
Example:

MATH MEM = CONFF("5700.acc")

After execution of the CONFF call, MEM will contain the confidence value from the Fluke 5700A accuracy file.

Usage:

When used with ACCF or ACCF2, CONFF may be used to normalize the system accuracy to one-sigma for use in the measurement uncertainty calculation. For example, a sequence of statements like:

MATH file = "5700.acc"
MATH mode = "Volts"
MATH acc = ACCF(file, mode, 5.)
MATH conf = CONFF(file)
MATH L[1] = acc / conf
VSET SYS_ACC = [L1]

may be used to look up the accuracy of the Fluke 5700A at 5 volts, determine the associated confidence of the spec, normalize to 1 sigma, and assign the normalized value to SYS_ACC for use in the measurement uncertainty calculation.

This example is unrealistic because there's not much reason to use these functions with an accuracy file for an instrument for which MET/CAL provides a built-in FSC. A more realistic example would be based on accessing an accuracy file for a user-configured reference.

Other Accuracy Functions

ACCNAME

Purpose: ACCNAME returns the name of the accuracy file that MET/CAL uses for a specified instrument.
Quick Proto: FileName = AccName(InstrumentName)
Result Type:

String

The return value is the full path name of the accuracy file for the specified instrument.

Argument Type:

String

The argument is an instrument name.

Example: MATH FileName = AccName("Fluke 5700A")
Error Handling:

If the desired asset does not exist in the database the following errors will display:

  • E9474: Device "Fluke 5700A" (asset "B1440") does not exist in database.
  • E1896: FSC MATH: Unable to determine accuracy file name for ACCNAME, ACCV, ACCV2, or CONF.

If the desired asset exists in the database but there is no valid accuracy file available, these errors are displayed:

  • E136: Can't find accuracy file for "Fluke 5700A" (asset "B1440") (cal interval 12 month(s)).
  • E1896: FSC MATH: Unable to determine accuracy file name for ACCNAME, ACCV, ACCV2, or CONF.
Compatibility: Requires V7.20u or later.

REFACC

Purpose: REFACC returns the reference accuracy determined in a preceding setup statement in the current test.
Quick Proto: Acc = REFACC()
Result Type:

Numeric

The return value is the reference accuracy determined by a preceding setup statement in the test. The value is in linearized base units. REFACC returns -1 when the value is not available.
Argument Type: None
Example #1:
  1.001  ASK-   R     N              P                            F        V
# Expected current: 90.0 A
# Shunt resistance: 10 mOhms
# Expected reading: 0.90 V
  1.002  MATH         ShuntRes = 0.01
  1.003  8846         0.90V                                             N  2W
# Get 8846A voltage reading accuracy in base units.
  1.004  MATH         L[1] = REFACC()
# Convert accuracy from volts to %.
  1.005  MATH         L[1] = L[1] / MEM * 100
# Compute System Actual in amps.
  1.006  MATH         MEM = MEM / ShuntRes
  1.007  ACC          90.0A          L1%
  1.008  MEMC         90.0A          0.1U
Example #2:
  2.001  5700         1.000V         1%                                    2W
  3.001  MATH         Acc = REFACC

The call above will fail because REFACC cannot be used after an evaluation. In this example, UNC("Sys_Acc") should be used instead of REFACC.
Usage:

The primary use for REFACC is in situations where a test involves the use of multiple reference instruments, and at least one reference instrument is controlled using a built-in instrument FSC.

The procedure writer may use REFACC to obtain the accuracy calculated by the MET/CAL driver, then combine that value (for example, using the RSS function) with other reference accuracy components. The combined reference accuracy should then be established for the test using an ACC statement.
Restrictions:
  1. REFACC cannot be used to retrieve the accuracy after an evaluation (instrument FSC, MEMC, or MEMCX).
  2. REFACC cannot be used for instrument FSC measurement functions, when the MOD1 value is taken from MEM. The measurement function in the runtime driver overwrites MEM with the reading.
Example:
  3.002  MATH         MEM = 0.9
  3.003  8846         V                            60H                  N  2W
Error Handling:

If no setup-determined reference accuracy value is available the return value is (-1.0).

Procedure writers should test the return value after a call to REFACC. A negative value indicates that the value is not available.

The procedure must take appropriate actions to handle that situation. Examples of situations where the reference accuracy value is unavailable are:

  1. ASK- U in effect.
  2. No setup statement in test.
  3. Reference is a user-configured instrument.
Compatibility: Requires V7.20w or later.
See Also: ACCV, ACCV2, UNC


MATH FSC Binary Read Functions

BRB | convert 1 byte to 32-bit integer
BRI | convert 4 bytes to 32-bit integer
BRN | return binary buffer byte count
BRS | convert range of bytes to string
BRW | convert 2 bytes to 16-bit integer
BRX | convert range of bytes to printable hex

BRB

Purpose: | Converts 1 byte in the internal binary buffer, at a specified index, to a 32-bit integer. BRB is used in conjunction with the "IB" construction in the PORT FSC. The "IB" construction is used to read binary data from a serial instrument, and store the data in an internal buffer. The buffer size is 4096 bytes.
Quick Proto: | val = BRB(index)
Result Type: | Numeric The return value is the integer value of the specified byte.
Argument Type: | numeric The argument specifies the index of the binary buffer byte to be converted.
Error Handling: | If the specified index is less than 1 or greater than the size of the binary buffer an error message is generated.
Compatibility: | Requires V7.20 or later.
Usage: | Procedure writers should generally use the "BRN" function to check the number of bytes in the binary buffer before calling "BRB". This is the only way to avoid asking "BRB" to convert a byte not written by the preceding binary read operation.
Example: | MATH ByteVal = BRB(8) Suppose the 8th byte in the binary buffer contains an ASCII linefeed character. In that case ByteVal will be set to 10. This is because an ASCII linefeed character is equivalent to a decimal 10. (The binary value is 00001010.)

BRI

Purpose: | Converts 4 bytes in the internal binary buffer, at a specified index, to a 32-bit integer. BRI is useful with serial instruments which transmit data in the form of unsigned 32-bit binary integers. BRI is used in conjunction with the "IB" construction in the PORT FSC. The "IB" construction is used to read binary data from a serial instrument, and store the data in an internal buffer. The buffer size is 4096 bytes.
Quick Proto: | val = BRI(index)
Result Type: | Numeric The return value is unsigned 32-bit integer represented by the 4 bytes starting at the specified index.
Argument Type: | numeric The argument specifies the starting index of the binary buffer bytes to be converted.
Error Handling: | If the specified index is less than 1 or greater than the size of the binary buffer, minus 3, an error message is generated.
Compatibility: | Requires V7.20 or later.
Usage: | Procedure writers should generally use the "BRN" function to check the number of bytes in the binary buffer before calling "BRI". This is the only way to avoid asking "BRI" to convert bytes not written by the preceding binary read operation.
Example: | IntVal = BRI(4) IntVal will be set to the unsigned 32-bit integer value represented by bytes 4, 5, 6, and 7 in the internal binary buffer.

BRN

Purpose: | Returns the number of bytes in the internal binary buffer. BRN is used in conjunction with the "IB" construction in the PORT FSC. The "IB" construction is used to read binary data from a serial instrument, and store the data in an internal buffer. The buffer size is 4096 bytes.
Quick Proto: | count = BRN()
Result Type: | numeric The return value is the number of bytes in the binary data buffer.
Argument Type: | None
Compatibility: | Requires V7.20 or later.
Example: | MATH n = BRN()

BRS

Purpose:

Converts a specified number of bytes in the internal binary buffer, starting at a specified index, to a printable string.

BRS is used in conjunction with the "IB" construction in the PORT FSC. The "IB" construction is used to read binary data from a serial instrument, and store the data in an internal buffer. The buffer size is 4096 bytes.

Quick Proto: str = BRS(index, count)
Result Type:

String

The return value is a printable string containing the requested number of bytes, starting at the a specified index in the binary buffer. Non-printable characters (less than decimal 32 or equal to decimal 127) are replaced by the corresponding ASCII mnemonic, enclosed by '<' and '>'. For example, a linefeed character (decimal 10) will appear as "LF" in the string returned by BRS.

Extended characters (with the high bit set) are considered printable. However, due to various character set, font, display device, and operating system issues, not all extended characters will appear as expected in printed form.

Argument Type:

Numeric, Numeric

The first argument specifies the starting index of the binary buffer bytes to be converted to string form. The second argument specifies the number of bytes to include in the string.

Error Handling:

If the specified index is less than

1 or greater than the size of the binary buffer, minus the specified count, an error message is generated.

Compatibility: Requires V7.20 or later.
Usage: Procedure writers should generally use the "BRN" function to check the number of bytes in the binary buffer before calling "BRS". This is the only way to avoid asking "BRS" to convert bytes not written by the preceding binary read operation.
Example:

n = BRN() str = BRS(1, n)

Suppose the number of bytes in the binary buffer is 10, and those bytes are:

'1'

'.'

'2'

'E'

'-'

'3'

' '

'm'

'V'

linefeed (decimal 10)

The string returned by BRS will be:

"1.2E-3 mVLF"

BRW

Purpose: | Converts 2 bytes in the internal binary buffer, at a specified index, to a 32-bit integer. BRI is useful with serial instruments which transmit data in the form of unsigned 16-bit binary integers. BRW is used in conjunction with the "IB" construction in the PORT FSC. The "IB" construction is used to read binary data from a serial instrument, and store the data in an internal buffer. The buffer size is 4096 bytes.
Quick Proto: | val = BRW(index)
Result Type: | numeric The return value is an unsigned 16-bit integer represented by the 2 bytes starting at the specified index.
Argument Type: | Numeric The argument specifies the starting index of the binary buffer bytes to be converted.
Error Handling: | If the specified index is less than 1 or greater than the size of the binary buffer, minus 1, an error message is generated.
Compatibility: | Requires V7.20 or later.
Usage: | Procedure writers should generally use the "BRN" function to check the number of bytes in the binary buffer before calling "BRW". This is the only way to avoid asking "BRW" to convert bytes not written by the preceding binary read operation.
Example: | WVal = BRW(10) WVal will be set to the unsigned 16-bit integer value represented by bytes 10 and 11 in the internal binary buffer.

BRX

Purpose:

Converts a specified number of bytes in the internal binary buffer, starting at a specified index, to a printable string showing the values in hexadecimal format.

BRX is used in conjunction with the "IB" construction in the PORT FSC. The "IB" construction is used to read binary data from a serial instrument, and store the data in an internal buffer. The buffer size is 4096 bytes.

Quick Proto: HexStr = BRX(index, count)
Result Type:

String

The return value is a printable string, in hex format, containing the requested number of bytes, starting at the a specified index in the binary buffer.

Argument Type:

Numeric, Numeric

The first argument specifies the starting index of the binary buffer bytes to be converted to hex string form.

The second argument specifies the number of bytes to include in the hex-format string.

Error Handling:

If the specified index is less than

1 or greater than the size of the binary buffer, minus the specified count, an error message is generated.

Compatibility: Requires V7.20 or later.
Usage: Procedure writers should generally use the "BRN" function to check the number of bytes in the binary buffer before calling "BRX". This is the only way to avoid asking "BRX" to convert too few or too many bytes.
Example:

hex = BRX(3, 2)

If the 3rd and 4th bytes in the binary buffer are a carriage return, followed by a linefeed, the string returned by BRX will be:

"0D0A"

"0D" is the hex format representation of a carriage return (decimal 13).

"0A" is the hex format representation of a linefeed (decimal 10).


MATH FSC Database Functions

CAL | return Calibration Table field value
INV | return Inventory Table field value
NCAL | return number of cal records for asset
SN | return serial number of specified asset

CAL

Purpose:

Returns the value of a specified

Calibration Table field, for a specified cal record of a specified asset.

The first argument specifies the asset number (string) of the instrument for which the specified Calibration Table value is to be retrieved.

The second argument specifies the record number. Records are numbered from 1 to NREC, where record 1 is the oldest record and record NREC is the most recent.

It is possible to access the records in reverse order by specifying a negative record number: (-1) refers to the most recent record. (-2) refers to the 2nd most recent. And so on.

The third argument specifies a Calibration Table field number. An error message is generated if the specified field number is not a valid Calibration Table field

Result Type: String
Argument Type: String, Numeric, Numeric
Compatibility: Requires V7.11p or later.
Example:

MATH MEM2 = CAL("Sample-5700", 5, 2342)

This examples assumes there's an asset with the asset number "Sample-5700" in the database. The value of field 2342 in the 5th calibration record will be stored in MEM2 when the call to CAL completes.

INV

Purpose:

Returns the value of a specified Inventory Table field, for a specified asset.

The first argument specifies the asset number (string) of the instrument for which the specified Inventory Table value is to be retrieved.

The second argument specifies an Inventory Table field number. An error message is generated if the specified field number is not a valid Inventory Table field. Valid field numbers are 4201 to 4263, excluding 4227.

4299 is also valid.

Note also that function "INV" does not allow field 4260 to be retrieved.

Result Type: String
Argument Type: String, Numeric
Compatibility: Requires V7.00d or later.
Example:

MATH MEM2 = INV("Sample-5700", 4206)

This examples assumes there's an asset with the asset number "Sample-5700" in the database. Inventory Table field 4202 is the manufacturer name field.

The value of MEM2 will be "Fluke" after the call to "INV" shown in this example has been executed.

NCAL

Purpose: | Returns the number of cal records for a specified asset. The first argument specifies the asset number (string) of the instrument for which the specified Calibration Table value is to be retrieved.
Result Type: | Numeric
Argument Type: | String
Compatibility: | Requires V7.11p or later.
Example: | MATH MEM = NCAL("Sample-5700") This examples assumes there's an asset with the asset number "Sample-5700" in the database.

SN

Purpose: | Returns the serial number of a specified asset. The argument specifies the asset number (string) of the instrument for which the serial number is to be fetched from the database Inventory Table.
Result Type: | String
Argument Type: | String
Compatibility: | Requires V7.00d or later.
Example: | MATH MEM2 = SN("Sample-5700") (This examples assumes there's an asset with the asset number "Sample-5700" in the database.)


MATH FSC Date and Time Functions

CTIME | convert time formatted as HH:MM:SS to seconds
DATE | return current date in specified format
FTIME | convert seconds to formatted time (HH:MM:SS)
TIME | return current time as HH:MM:SS
UGDATE | convert UTC date to seconds since 1/1/1970 UTC
UGDT | convert seconds since 1/1/1970 to UTC date/time
ULDATE | convert local date to seconds since 1/1/1970 UTC
ULDT | convert seconds since 1/1/1970 to local date/time
UTIME | return current time in seconds since 1/1/1970 UTC

CTIME

Purpose: | Converts a time string formatted as HH:MM:SS to an equivalent number of seconds. The format DD:HH:MM:SS is also supported, where DD is a number of days. All components (days, hours, minutes, seconds) are optional, but colons may be required to make the time string unambiguous. For example, "1:" means 1 minute. If you simply specify "1", it means 1 second.
Result Type: | Numeric
Argument Type: | String
Compatibility: | Requires V7.00d or later.
Example: | MATH MEM = CTIME("1:10:15") In this example the time string, representing 1 hour, 10 minutes, and 15 seconds will be converted to the equivalent number of seconds (4215). The value 4215 will be stored in the register MEM.
See Also: | FTIME and UTIME

DATE

Purpose:

Returns the current date. The argument is a string which controls the date format. The following format descriptors may be used:

DD - day number

MM - month number

MON - 3-letter month name

MONTH - full month name

YY - 2-digit year number (window 1970 - 2069)

YYYY - 4-digit year number

No format descriptor may occur more than once in a format control string. At most one of { MM, MON, MONTH } may occur in a format control string. At most one of { YY, YYYY } may occur.

Characters which do not match a valid format descriptor are copied unchanged to the formatted date string. Format descriptors are case-insensitive.

Result Type: String
Argument Type: String
Compatibility: Requires V6.00 or later. Month names are English-only in V6.00.
Example 1:

MATH S[5] = date("DD/MM/YY")

This produces a date string like "04/20/99" and stores it in string register S[5].

Example 2:

MATH MEM2 = date("month dd, yyyy")

This produces a formatted date like "April 20, 1999" and stores it in string register MEM2.

FTIME

Purpose: | Converts a specified number of seconds into a formatted time string with the form HH:MM:SS. Values representing a non-integer number of seconds are truncated to the next smallest whole number of seconds. For example, "FTIME(2.7)" is the same as "FTIME(2.0)". Both calls produce "00:00:02".
Result Type: | String
Argument Type: | Numeric
Compatibility: | Requires V6.11m or later.
Example: | MATH MEM2 = FTIME(14370) In this example the MEM2 string register will contain "03:59:30", representing 3 hours, 59 minutes, and 30 seconds.
See Also: | UTIME and CTIME

TIME

Purpose: | Returns the current time. The format of the time string is HH:MM:SS. The hour number (HH) is a number in the range 00 to 23. The minute and second numbers (MM and SS) are numbers in the range 00 to 59.
Result Type: | String
Argument Type: | None
Compatibility: | Requires V6.00 or later.
Example: | MATH S[5] = TIME() This produces a time string like "10:12:59" and stores it in string register S[5].

UGDATE

Purpose: Converts a UTC-relative date to elapsed seconds since Jan 01 1970 UTC.
Quick Proto: nsec = UGDATE(date)
Result Type:

numeric

The return value is the number of seconds elapsed since Jan 01 1970.

Argument Type:

string

The argument is a formatted date string.

Various formats are supported, but refer to the "Caution:" section below before using ambiguous formats.

Example:

nsec = UGDATE("2008-03-15")

The call above returns the number of seconds from midnight Jan 01 1970 UTC to midnight Mar 15 2008 UTC.

(The value is 1,205,535,600 seconds.)

Usage:

The primary purpose of UGDATE is to facilitate date comparisons.

Converting two dates to seconds elapsed since 1970 allows a numeric comparison to be done to determine which date is earlier and which is later.
Caution:
  1. UGDATE is valid only for years between 1970 and 2038.
  2. UGDATE supports flexible date formats.

    3. However, to avoid problems, use 4-digit years and unambiguous formats. The format YYYY-MM-DD conforms to the ISO 8601 standard and is widely accepted. Formats that use English month names, or 3-letter abbreviations, are also accepted.

    "03-Mar-2008", "March 03, 2008".

    A value like "03/04/2008" is always taken to be MM/DD/YYYY, never DD/MM/YYYY. This date representation is ambiguous and therefore not recommended.

  3. The UGDATE return value does not include leap seconds added to the calendar after 1969.
Error Handling:
  1. If the formatted date string is not recognized as a valid date an error message is generated and the MATH statement containing the UGDATE call is terminated.
  2. If the specified date is not between 1970 and 2038 a negative value is returned.
Compatibility: Requires V7.20z or later.
See Also: ULDATE

UGDT

Purpose:

Converts a value representing seconds since Jan 01, 1970 UTC to a formatted date and time string. The date format is controlled by the second argument.

The time format is always HH:MM:SS. The converted value represents Coordinated Universal Time (UTC), also known as Greenwich Mean Time (GMT).

The first argument is a numeric value interpreted as a number of seconds since Jan 01, 1970 UTC. The second argument is a string which controls the date format. The following format descriptors may be used:

  • DD - day number
  • MM - month number
  • MON - 3-letter month name
  • MONTH - full month name
  • YY - 2-digit year number (window 1970 - 2069)
  • YYYY - 4-digit year number

No format descriptor may occur more than once in a format control string.

At most one of { MM, MON, MONTH } may occur in a format control string. At most one of { YY, YYYY } may occur.

Characters which do not match a valid format descriptor are copied unchanged to the formatted date string.

Format descriptors are case-insensitive.

Result Type: String
Argument Type: Numeric, String
Compatibility: Requires V7.00g or later.
See Also: UTIME, ULDT, DATE
Example:

MATH MEM2 = UGDT(1E+9, "month dd, yyyy")

MEM2 will contain the string

"September 09, 2001 01:46:40", representing the date and time one billion seconds after midnight Jan 01, 1970 UTC.

ULDATE

Purpose:

Converts a local time-relative date to elapsed seconds since Jan 01 1970 UTC.

The difference between ULDATE and UGDATE is that the ULDATE return value includes an offset to compensate for the local timezone.

For example, if you call ULDATE in Seattle (and DST is not in effect), there's a 28800 second offset added to the return value to compensate for the 8-hour difference between GMT and PST.

Quick Proto: nsec = ULDATE(date)
Result Type:

numeric

The return value is the number of seconds elapsed between the specified date (local time) and Jan 01 1970 UTC.

Argument Type:

string

The argument is a formatted date string.

Various formats are supported, but refer to the "Caution:" section below before using ambiguous formats.

Example:

nsec = ULDATE("2008-03-15")

This example assumes that PST is in effect.

If you are in a different timezone, or DST (daylight savings time) is in effect, results will be different.

The call above returns the number of seconds from midnight Jan 01 1970 UTC to midnight Mar 15 2008 PST. (The value is 1,205,564,400 seconds.)

Usage:

The primary purpose of ULDATE is to facilitate date comparisons.

Converting two dates to seconds elapsed since 1970 allows a numeric comparison to be done to determine which date is earlier and which is later.

Caution:
  1. ULDATE is valid only for years between 1970 and 2038.
  2. ULDATE supports flexible date formats.

    3. However, to avoid problems, use 4-digit years and unambiguous formats.

    The format YYYY-MM-DD conforms to the ISO 8601 standard and is widely accepted.

    Formats that use English month names, or 3-letter abbreviations, are also accepted.

    Examples:

    "03-Mar-2008", "March 03, 2008".

    A value like "03/04/2008" is always taken to be MM/DD/YYYY, never DD/MM/YYYY This date representation is ambiguous and therefore not recommended.

  3. The ULDATE return value does not include leap seconds added to the calendar after 1969.
Error Handling:
  1. If the formatted date string is not recognized as a valid date an error messsage is generated and the MATH statement containing the ULDATE call is terminated.
  2. If the specified date is not between 1970 and 2038 a negative value is returned.
Compatibility: Requires V7.20z or later.
See Also: UGDATE

ULDT

Purpose:

Converts a value representing seconds since Jan 01, 1970 UTC to a formatted date and time string.

The date format is controlled by the second argument. The time format is always HH:MM:SS. The converted value represents local time, as defined by the time zone settings on the workstation.

The first argument is a numeric value interpreted as a number of seconds since Jan 01, 1970 UTC. The second argument is a string which controls the date format. The following format descriptors may be used:

  • DD - day number
  • MM - month number
  • MON - 3-letter month name
  • MONTH - full month name
  • YY - 2-digit year number (window 1970 - 2069)
  • YYYY - 4-digit year number

No format descriptor may occur more than once in a format control string. At most one of { MM, MON, MONTH } may occur in a format control string.

At most one of { YY, YYYY } may occur. Characters which do not match a valid format descriptor are copied unchanged to the formatted date string. Format descriptors are case-insensitive.

Result Type: String
Argument Type: Numeric, String
Compatibility: Requires V7.00g or later.
See Also: UTIME, ULDT, DATE
Example:

MATH MEM2 = ULDT(1E+9, "month dd, yyyy")

If the PC on which the ULDT function call above is executed is set to PST (Pacific Standard Time), MEM2 will contain the string "September 08, 2001 18:46:40", representing the PST date and time one billion seconds after midnight Jan 01, 1970 UTC.

UTIME

Purpose: | Returns the current time in seconds since midnight Jan 01, 1970 UTC (coordinated universal time).
Result Type: | Numeric
Argument Type: | None
Compatibility: | Requires V6.11 or later.
Example: | MATH M[1] = UTIME()


MATH FSC File Functions

APPEND | append line to file
CLOSE | close file
DELETE | delete line from file
EOF | determine if file is positioned at end of file
EXISTS | determine if a specified file exists
FindCSV | find CSV line (case-sensitive)
FindCSVi | find CSV line (case-insensitive)
FindCSVn | find indexed CSV line (case-sensitive)
FindCSVni | find indexed CSV line (case-insensitive)
FLEN | get length of specified file
INSERT | insert line in file before specified line
ISDIR | determine if a specified file is a directory
ISORD | determine if a specified file is an ordinary file
LINECOUNT | count lines of specified file
MTIME | determine last modification time of file
PXETEMP | return the full path to the temp directory of the PXE. All non procedure files associated with the PXE are stored in this directory. Use this method to access those files. When the PXE completes, the files are removed. This function is not supported when running a compiled procedure.
READ | read specified line from file
REPLACE | replace line in file
WRITE | write line to file after specified line

APPEND

Purpose:

Appends a line to a file.

If the file does not exist, it is first created. The line is automatically CRLF-terminated. This function should be used with line-oriented text files. It is not intended for writing binary data.
Quick Proto: APPEND(file, line)
Result Type:

Numeric (or void)

The return value is 1 on success, 0 on error.
Argument Type:

String, String

The first argument is the name of the file to which the line is to be appended.

If the specified file name is not a full path name, the file location may be specified by the optional MET/CAL Configuration settings:

  1. Math Info Folder (1st choice)
  2. Workstation Folder (2nd choice)
  3. User Current Working Folder (3rd choice)

The second argument is the line to append.
Example: APPEND("c:/file.txt", "abc")

The call to APPEND above appends the line "abc" to the file "file.txt" on the "C:" drive.
Compatibility: Requires V7.20r or later.
See Also: DELETE, INSERT, READ, REPLACE, WRITE

CLOSE

Purpose: Closes a specified file. CLOSE may be used to close a file that was opened due to a prior call to APPEND, INSERT, READ, REPLACE, or WRITE.
Quick Proto: CLOSE(file)
Result Type:

Numeric (or void)

The return value is 1 if the function call succeeds.

The return value is 0 if the function call fails.
Argument Type:

String

The argument specifies the name of the file to be closed.
Example:

MATH file = "c:/metcal/mfile.txt"
MATH append(file, "abc")
MATH close(file)
Usage:

MET/CAL automatically closes files opened by APPEND, INSERT, READ, REPLACE, or WRITE when a procedure terminates. In general, there's no reason to call "close". However, MET/CAL holds up to 8 files open and the contents of the file are buffered in memory during procedure execution. This makes reading and writing faster. The primary use of "close", therefore, is to force the file contents to be written to disk so that the file may be accessed by another process before the MET/CAL procedure has terminated.
Error Handling: An error message is generated if the specified file is open but MET/CAL is unable to close the file. If the specified file was never opened in the first place, MET/CAL ignores the call to CLOSE.
Compatibility: V7.20A or later.
See Also: APPEND, INSERT, READ, REPLACE, WRITE

DELETE

Purpose: | Deletes a specified line in a specified file. The line number must be between 1 and the number of lines in the file. The file must exist before DELETE can be used to delete an existing line. This function should be used with line-oriented text files.
Quick Proto: | DELETE(file, LineNumber)
Result Type: | Numeric (or void) The return value is 1 on success, 0 on error.
Argument Type: | String, Numeric The first argument is the name of the file from which the line is to be deleted. The second argument is the line number of the line to be deleted.
Example: | DELETE("c:/file.txt", 4) The call to DELETE above deletes line 4 in the file c:/file.txt.
Compatibility: | Requires V7.20r or later.
See Also: | APPEND, INSERT, READ, REPLACE, WRITE

EOF

Purpose: Determines if a file is positioned at end of file.
Quick Proto: AtEOF = EOF(FileName)
Result Type:

Numeric

The return value is 1 if the specified file is positioned at EOF. The return value is 0 if the specified file is not positioned at EOF. If the file is not open (because there have been no calls to APPEND, DELETE, INSERT, LINECOUNT, READ, REPLACE, or WRITE), the return value is zero (i.e., not at EOF).
Argument Type:

String

The argument is the name of the file to test.

If the specified file name is not a full path name, the file location may be specified by the optional MET/CAL Configuration settings:

  1. Math Info Folder (1st choice)
  2. Workstation Folder (2nd choice)
  3. User Current Working Folder (3rd choice)
Example:

Suppose you have a file named "c:/file.txt" with 2 lines:

abc

def

MATH f = "c:/file.txt"
MATH line1 = READ(f, 1)
MATH eof = EOF(f)
DISP Line 1 = [v line1], EOF = [v eof]
MATH line2 = READ(f, 2)
MATH eof = EOF(f)
DISP Line 2 = [v line2], EOF = [v eof]

Running the test procedure above generates:

Line 1 = abc, EOF = 0

Line 2 = def, EOF = 1

Note that after the 2nd line has been read, EOF returns 1, indicating that there are no more lines to read.
Usage:

EOF is designed to be used in conjunction with READ. After a call to READ, EOF may be called to determine if the file is positioned at EOF. When the file is positioned at EOF it indicates that the line just read was the last line of the file.
Compatibility: Requires V7.20t or later.
See Also: APPEND, DELETE, INSERT, LINECOUNT, READ, REPLACE, WRITE EXISTS

EXISTS

Purpose:

Determines if a specified file or folder exists.

This function does not distinguish files based on the file type. For example, directories (i.e., "folders") exist just like ordinary files.
Quick Proto:
Result Type:

Numeric

  • The return value is 1 if the specified file exists.
  • The return value is 0 if the specified file does not exist.
Error Handling If one or both of the specified L-register indices are out of range an error message is generated.
Argument Type:

String

The argument is the path to the file or directory to be tested.
Compatibility: Requires 7.11 or later.
See Also: ISORD, ISDIR
Example:

# Read the configured Math Info Folder from metcal.ini.
  1.001  MATH         MathFileDir = INI("startup", "mathfiledir")
# Concatenate the mathfiledir with the filename to be tested.
  1.002  MATH         Path = MathFileDir & "\\MyFile.txt"

  1.003  IF           EXISTS(Path)
  1.004  DISP         File Exists:
  1.004  DISP         "[V Path]"
  1.005  ELSE
  1.006  DISP         File Does Not Exist:
  1.006  DISP         "[V Path]"
  1.007  ENDIF

Running the above procedure fragment causes a message to be displayed indicating whether or not the file "MyFile.txt" exists in the configured Math Info Folder.

FINDCSV, FINDCSVI

Purpose: Finds a line in a file containing comma-separated values. A line matches if the first N values on the line are the same as the values in the provided comma-separated list. FindCSV is case-sensitive. FindCSVi is case-insensitive.
Quick Proto: n = FindCSV(file, csv, start, var)
Argument Type:

String, String, Numeric, String

  1. Argument #1 is the file name.
  2. Argument #2 is a string containing a comma-separated list of values to be matched. Spaces before and after the commas are ignored.
  3. Argument #3 is the line at which to start the search.
  4. Argument #4 is the name of a variable that will hold the matching line (if any).

The variable name must be enclosed in double quotes (see example).
Result Type:

numeric

The return value is the line number of the first matching line. If no matching line is found the return value is zero.
Example:

Given the following file ("ex.txt"), with contents:

a, b, c

d, e, f,

g, h, i

j, k, l

MATH fn = "ex.txt"
MATH csv = "g, h"
MATH n = FindCSV(fn, csv, 1, "v")

the call to FindCSV above will return 3 (the line number of the matching line), and assign "g, h, i" as the value of the variable "v".
Usage:

Matching is based on string comparisons, not on numeric values. Therefore, for example, a CSV string like "1.0, 2.0" will not match a line in the file that begins with "1, 2". Compatibility:

Requires V7.20B or later.
See Also: FindCSVn, FindCSVni

FINDCSVN, FINDCSVNI

Purpose:

Finds a line in a file containing comma-separated values at specified indices.

FindCSVn is case-sensitive.

FindCSVni is case-insensitive.
Quick Proto: n = FindCSVn(file, csv, csn, start, var)
Result Type:

numeric

The return value is the line number of the first matching line. If no matching line is found the return value is zero.
Argument Type:

String, String, String, Numeric, String

  1. Argument #1 is the file name.
  2. Argument #2 is a string containing a comma-separated list of values to be matched. Spaces before and after the commas are ignored.
  3. Argument #3 is a comma-separated list of the corresponding position(s) for each value in argument #2.
  4. Argument #4 is the line at which to start the search.
  5. Argument #5 is the name of a variable that will hold the matching line (if any).

The variable name must be enclosed in double quotes (see example).
Example:

Given the following file ("ex.txt"):

a, b, c

d, e, f,

g, h, i

j, k, l

MATH fn = "ex.txt"
MATH csv = "g, i"
MATH csn = "1, 3"
MATH n = FindCSVn(fn, csv, csn, 1, "v")

Therefore, in the above example, "g" corresponds to the first CSV on the line. "i" corresponds to the third CSV on the line.

Therefore, in the above example: "g" corresponds to the first CSV on the line. "i" corresponds to the third CSV on the line.

The call to FindCSVn above will return 3 (the line number of the matching line), and assign "g, h, i" as the value of the variable "v".
Usage: Matching is based on string comparisons, not on numeric values. Therefore, for example, a CSV string like "1.0, 2.0" will not match a line in the file that begins with "1, 2".
Compatibility: Requires V7.20B or later.
See Also: FindCSV, FindCSVi

FLEN

Purpose: Determines the length of a specified file.
Result Type:

Numeric

The return value is the length of the file.

If the file does not exist the return value is (-1).
Argument Type:

String

The argument specifies the name of the file.
Compatibility: Requires V7.11 or later.
Example:

Suppose you have a file named:

H:\mydata\data.dat" on the H: drive.

MATH MEM2 = "H:\\mydata\\data.dat"
MATH L[1] = FLEN(MEM2)

Running the statements above will cause the length, in bytes, of the file to stored in local register L[1].

INSERT

Purpose:

Inserts a line in a file before a specified line number.

The line number must be between 1 and the number of lines in the file. The file must exist before INSERT can be used to insert lines into it.

The new line is automatically CRLF-terminated. This function should be used with

line-oriented text files. It is not intended for writing binary data.
Quick Proto: INSERT(file, line, LineNumber)
Result Type:

Numeric (or void)

The return value is 1 on success, 0 on error.
Argument Type:

String, String, Numeric

  1. The first argument is the name of the file in which the line is to be inserted.
  2. The second argument is the line to insert.
  3. The third argument is the line number before which to insert the new line.
Example:

INSERT("c:/file.txt", "abc", 4)

The call to INSERT above inserts the line "abc" into the file "c:/file.txt" before line 4.
Compatibility: Requires V7.20r or later.
See Also: APPEND, DELETE, READ, REPLACE, WRITE

ISDIR

Purpose: Determines if a specified file is a directory.
Result Type:

Numeric

  • The return value is 1 if the specified file is a directory.
  • The return value is 0 if the specified file is not a directory.
Argument Type:

String

The argument is the name of the file to be tested.
Compatibility: Requires V7.11 or later.
See Also: EXISTS, ISORD
Example:

  1.001 MATH S[1] = "C:\\MyData"
  1.002 IF ISDIR(S[1])
  1.003 DISP File "[S1]" Is a Directory
  1.004 ELSE
  1.005 DISP File "[S1]" Is Not a Directory
  1.006 ENDIF

Running the above procedure fragment causes a message to be displayed indicating whether or not the file "C:\MyData" is a directory.

ISORD

Purpose:

Determines if a specified file is an ordinary file.

An ordinary file is, generally, any data file, program file, text file, etc., which is not a directory (folder). Some file system support other file types like sockets and device special files.

These are also not ordinary file.
Result Type:

Numeric

  • The return value is 1 if the specified file is an ordinary file.
  • The return value is 0 if the specified file is not an ordinary file.
Argument Type:

String

The argument is the name of the file to be tested.
Compatibility: Requires V7.11 or later.
See Also: EXISTS, ISDIR
Example:

  1.001 MATH S[1] = "C:\\MyData"
  1.002 IF ISORD(S[1])
  1.003 DISP File "[S1]" Is an Ordinary File
  1.004 ELSE
  1.005 DISP File "[S1]" Is Not an Ordinary File
  1.006 ENDIF

Running the above procedure fragment causes a message to be displayed indicating whether or not the file "C:\MyData" is an ordinary file.

LINECOUNT

Purpose: Count lines of file.
Quick Proto: count = LineCount(filename)
Result Type:

Numeric

The return value is the number of lines in the file.
Argument Type:

String

The argument is the file name. If the specified file name is not a full path name, the file location may be specified by the optional MET/CAL Configuration settings:

  1. Math Info Folder (1st choice)
  2. Workstation Folder (2nd choice)
  3. User Current Working Folder (3rd choice)
Example: MATH n = LineCount("c:/file.txt")
Error Handling: If an error occurs reading the file, or the file does not exist, an error message is generated and the line count is set to zero.
Compatibility: Requires V7.20t or later.
See Also: APPEND, DELETE, INSERT, READ, REPLACE, WRITE LINREG

MTIME

Purpose: Determines the modification time of a specified file.
Result Type:

Numeric

  • The return value is the modification time of the file, expressed in seconds elapsed since midnight Jan 01 1970 UTC.
  • If the file does not exist the return value is zero.
Argument Type:

String

The argument specifies the name of the file.
Compatibility: Requires V7.11 or later.
See Also:

UGDT, ULDT

Functions UGDT and ULDT may be used to convert the MTIME return value into a printable date and time string if necessary.
Example:

Suppose you have a file named "H:\mydata\data.dat" on your H: drive.

MATH MEM2 = "H:\\mydata\\data.dat"
MATH L[1] = MTIME(MEM2)

Running the statements above will cause the modification time of the file to stored in local register L[1].

PXETEMP

Purpose | Returns the full path to the active PXE temporary storage directory, for access to non-procedure files stored within a PXE. All files in a PXE, other than procedures, are extracted to a temporary directory while a PXE is running. The directory is purged when the PXE terminates. This parameter is not required to access DOS programs stored within the PXE.
Result Type | String
Argument Type | None
Compatibility | Requires 8.0 or later. Will only function when running a procedure executable in the MET/CAL Runtime or when debugging a procedure project in the MET/CAL Editor, where a non-procedure file is part of the source project (i.e. Build Action = Content).
Example

  1.001 MATH Path = PXETEMP() & "content.xlsx"
  1.002 DISP PXETEMP Path: [V Path]

READ

Purpose:

Reads a specified line from a file.

The line number must be between 1 and the number of lines in the file. The file must exist before READ can be used to read lines from it. This function should be used with line-oriented text files.

It is not intended for reading binary data. The maximum number of characters per line is 32767 (not including the terminator). The line terminator is an ASCII linefeed character (decimal 10, hex 0A). ASCII Carriage Returns (decimal 13, hex 0D) are ignored.
Quick Proto: Line = READ(file, LineNumber)
Result Type:

String

The return value is the specified line. If the specified line does not exist the return value is an empty string. If an error occurs an error message is generated and the return value is NULL.
Argument Type:

String, Numeric

  1. The first argument is the name of the file from which to read.

    If the specified file name is not a full path name, the file location may be specified by the optional MET/CAL Configuration settings:

    1. Math Info Folder (1st choice)
    2. Workstation Folder (2nd choice)
    3. User Current Working Folder (3rd choice)

  2. The second argument is the number of the line to read.
Example:

MATH line = READ("c:/file.txt", 4)

The call to READ above reads line 4 from the file "c:/file.txt".
Compatibility: Requires V7.20r or later.
Usage:

READ is more efficient when used to read lines in ascending order.

Jumping around in the file is not an error, but should be expected to be slower, especially with large files.
See Also: APPEND, DELETE, INSERT, LINECOUNT, REPLACE, WRITE

REPLACE

Purpose:

Replaces a specified line in a specified file.

The line number must be between 1 and the number of lines in the file.

The file must exist before REPLACE can be used to replace an existing line.

The new line is automatically CRLF-terminated.

This function should be used with line-oriented text files. It is not intended for writing binary data.
Quick Proto: REPLACE(file, line, LineNumber)
Result Type:

Numeric (or void)

The return value is 1 on success, 0 on error.
Argument Type:

String, String, Numeric

  1. The first argument is the name of the file in which the line is to be replaced.
  2. The second argument is the replacement line.
  3. The third argument is the line number of the line to be replaced.
Example:

REPLACE("c:/file.txt", "def", 4)

The call to REPLACE above replace line 4 in the file "c:/file.txt" with the new line "abc".
Compatibility: Requires V7.20r or later.
See Also: APPEND, DELETE, INSERT, READ, WRITE RHT_HUMIDITY

WRITE

Purpose:

Writes a line to a file after a specified line number.

The line number must be between 1 and the number of lines in the file. The file must exist before WRITE can be used to write lines to it. The new line is automatically CRLF-terminated. This function should be used with line-oriented text files.

It is not intended for writing binary data.
Quick Proto: WRITE(file, line, LineNumber)
Result Type:

Numeric (or void)

The return value is 1 on success, 0 on error.
Argument Type:

String, String, Numeric

  1. The first argument is the name of the file to which the line is to be written.

    If the specified file name is not a full path name, the file location may be specified by the optional MET/CAL Configuration settings:

    1. Math Info Folder (1st choice)
    2. Workstation Folder (2nd choice)
    3. User Current Working Folder (3rd choice)

  2. The second argument is the line to write.

  3. The third argument is the line number after which to write the new line.
Example:

WRITE("c:/file.txt", "abc", 4)

The call to WRITE above writes the line "abc" to the file "c:/file.txt" after line 4.
Compatibility: Requires V7.20r or later.
See Also: APPEND, DELETE, INSERT, READ, REPLACE


MATH FSC Fluke 792A Data Access Functions

CalDate792 | get calibration date from Fluke 792A data file
Get792 | get data value from Fluke 792A data file
Open792 | open, read, and check Fluke 792A data file
SN792 | get serial number from Fluke 792A data file

CalDate792

Purpose: | CalDate792 returns the calibration date from a Fluke 792A data file.
Quick Proto: | CalDate = CalDate792()
Result Type: | String
Error Handling |
Argument Type: | None
Compatibility: | Requires 7.20y or later.
See Also | Get792, Open792, SN792
Example: | MATH CalDate = CalDate792()
Caution: | The Fluke 792A data file must conform to the format specified by the Fluke Calibration Standards Lab.

GET792

Purpose: Get792 returns an interpolated AC-DC difference value from a Fluke 792A data file.
Quick Proto: val = Get792(range, voltage, frequency)
Result Type:

Numeric

The value returned by Get792 is the result of a 2-dimensional interpolation of the voltage and frequency values specified in the data file.

The range value must be an exact match.

Voltage interpolations are linear if the voltage is less than 0.6 V or the frequency is greater than 100 Hz. Otherwise, interpolations are proportional to the square of the voltage.

Frequency interpolations are linear if the voltage is less than 0.6 V or the frequency is greater than 100 Hz. Otherwise, interpolations are proportional to the inverse square of the frequency.
Error Handling
Argument Type:

String, String, String

  1. The first argument specifies the range value.
  2. The second argument specifies the voltage value.
  3. The third argument specifies the frequency value.

All arguments must specified a dimensioned strings. The format is:

numeric val[prefix]units]

Only SI units symbols are supported.
Compatibility: Requires 7.20y or later.
See Also: CalDate792, Open792, SN792

Example:

MATH r = "220 mV"
MATH v = "80 mV"
MATH f = "500 Hz"
MATH acdc = Get792(r, v, f)
Caution: The Fluke 792A data file must conform to the format specified by the Fluke Calibration Standards Lab.

Open792

Purpose: Open792 opens a Fluke 792A data file.
Quick Proto: Open792(filename)
Result Type:

Numeric (or void)

  • The return value is 1 if the function succeeds.
  • The return value is 0 if the function fails.
Argument Type:

String

The argument specifies the name of the Fluke 792A data file. If the name is a full path name, the file is opened using the specified name. If the name is not a full path name, the specified name is appended to the 792A Data File Folder MET/CAL Configuration setting.

Example:

Caution:

MATH Open792("990017.dat")

The Fluke 792A data file must conform to the format specified by the Fluke Calibration Standards Lab.

Compatibility: Requires V7.20y or later.
See Also: CalDate792, Get792, SN792

SN792

Purpose: | SN792 returns the serial number from a Fluke 792A data file.
Quick Proto: | sn = SN792()
Result Type: | String
Argument Type: | None.
Example: | MATH sn = SN792()
Caution: | The Fluke 792A data file must conform to the format specified by the Fluke Calibration Standards Lab.
Compatibility: | Requires V7.20y or later.
See Also: | Open792, Get792, CalDate792


MATH FSC General Numeric Functions

ABS | absolute value
AVG | average of global registers
AVG_L | average of local registers
BIT | test a specified bit
CEIL | smallest integer greater than or equal to value
CRND | round number to multiple of specified increment
EXP | e (base of natural logarithms) raised to power
FRND | round to specified number of significant digits
INT | largest integer less than or equal to argument
INTERP | linear interpolation
LINREG | compute linear regression
LN | natural logarithm
LOG | base 10 logarithm
MAX | maximum of global registers
MAX_L | maximum of local registers
MAX2 | maximum of two values
MIN | minimum of global registers
MIN_L | minimum of local registers
MIN2 | minimum of two values
MISMATCHSWR | Computes mismatch uncertainty.
NOT | Boolean inverse
POW | raise value to power (same as '^' operator)
RND | round number to nearest integer
RSS | root sum square of global registers
RSS_L | root sum square of local registers
RSS2 | root sum square of two values
RSS3 | root sum squate of three values
SDEV | standard deviation of global registers
SDEV_L | standard deviation of local registers
SGN | arithmetic sign of number
SQRT | square root
SUM | sum of global registers
SUM_L | sum of local registers

ABS

Purpose: Computes the absolute value of its argument.
Quick Proto: absval = ABS(val)
Result Type: numeric
Argument Type: numeric
Example:

MATH MEM = -1.23
MATH L[1] = ABS(MEM)

After execution of the call to ABS the value of L[1] will be +1.23.

AVG

Purpose: Computes the average of a set of numbers. The function arguments specify the indices of a range of global numeric registers the values of which are to be averaged.
Quick Proto: average = AVG(starting M-Reg index, ending M-Reg index)
Result Type: Numeric
Error Handling
Argument Type: Numeric, Numeric
Compatibility: Requires 7.00 or later.
See Also
Example:

MATH M[5] = 25
MATH M[6] = 45
MATH M[7] = 20
MATH MEM = AVG(5, 7)

After the last MATH statement executes the value of MEM will be 30.

AVG_L

Purpose: Computes the average of a set of numbers. The function arguments specify the indices of a range of local numeric registers the values of which are to be averaged.
Quick Proto: average = AVG_L(starting L-Reg index, ending L-Reg index)
Result Type: Numeric
Error Handling
Argument Type: Numeric, Numeric
Compatibility: Requires 7.00b or later.
See Also
Example:

MATH L[5] = 25
MATH L[6] = 45
MATH L[7] = 20
MATH MEM = AVG_L(5, 7)

After the last MATH statement executes the value of MEM will be 30.

BIT

Purpose:

Tests a specified bit in a specified value. Bits are numbered from the LSB (bit 0) to the MSB. The first argument specifies the bit number. The second argument is the value to test.

Both arguments are converted to unsigned integers before the test. If the specified bit is set, the result value is 1. If the specified bit is not set, the result value is 0. The bit number must be in the range 0 to 31.

Result Type: Numeric
Argument Type: Numeric, Numeric
Compatibility: Requires V6.01 or later.
Example:

IEEE2 *ESR?[I]
MATH L[1] = BIT(0, MEM)

The IEEE2 statement reads the Extended Status Register (ESR) of a IEEE-488.2 compatible device. The MATH statements checks the Operation Complete (OPC), bit 0 of the ESR. If OPC is true L[1] is set to 1. If OPC is false L[1] is set to 0.

CEIL

Purpose: | Computes the smallest integer greater than or equal to its argument.
Result Type: | Numeric
Argument Type: | Numeric
Example: | MATH L[1] = CEIL(MEM)

CRND

Purpose: Rounds a number to the closest multiple of a specified increment. The increment must be a positive number.
Quick Proto: RndVal = CRND(Val, Incr)
Result Type: numeric
Argument Type:

Numeric, Numeric

  1. The first argument is the value to be rounded.
  2. The second argument is the rounding increment.
Compatibility: Requires V7.20r or later.
Example 1:

MATH MEM = CRND(1.234, 0.01)

CRND rounds 1.234 to 1.23.

Example 2:

MATH MEM = CRND(94.0, 10)

CRND rounds 94.0 to 90.

See Also: FRND

EXP

Purpose: | Computes the value of e (the base of natural logarithms) raised to a specified power.
Result Type: | Numeric
Argument Type: | Numeric
Example: | MATH M[1] = EXP(2.0) The value of e is approximately 2.71828182846, so the square of e is approximately 7.38905609893, which is the value that M[1] will have after the above statement is executed.

FRND

Purpose:

Rounds a number to a specified number of significant digits.

FRND cannot be used to increase the number of significant digits in a number.

(Use function FMT to control the formatting of numbers for display.) It is important to understand that FRND controls the number of significant digits in a number. This is not, in general, the same as controlling the number of digits to the right of the decimal point.

If the specified number of significant digits is less than 1, FRND uses 1 as the requested number of significant digits. If the specified number of significant digits is greater than 16, FRND uses 16 as the requested number of significant digits.

Quick Proto: RndVal = FRND(Val, NSD)
Result Type: Numeric
Argument Type:

Numeric, Numeric

  1. The first argument is the value to be rounded.
  2. The second argument is the number of significant digits in the rounded value.
Compatibility: Requires V7.01d or later.
Example 1:

MATH MEM = FRND(1.234567, 4)
DISP [MEM]

The displayed value will be "1.235".
Example 2:

MATH MEM = FRND(123.4567, 4)
DISP [MEM]

The displayed value will be "123.5".

See Also: CRND

INT

Purpose: | Computes the largest integer less than or equal to its argument.
Result Type: | Numeric
Argument Type: | Numeric
Example: | MATH L[1] = INT(MEM)

INTERP

Purpose:

INTERP linearly interpolates between 2 specified points at a specified x-value.

The formula for linear interpolation is:

y = y1 + (x - x1) * ((y2 - y1) / (x2 - x1))

INTERP may also be used to extrapolate values on the line defined by (x1, y1) and (x2, y2).

Quick Proto: y = INTERP(x1, y1, x2, y2, x)
Result Type:

Numeric

The return value is the y-coordinate of the interpolated point on the line defined by (x1, y1) and (x2, y2).

Argument Type:

Numeric, Numeric, Numeric, Numeric, Numeric

  1. 1st argument is x-coord of 1st point.
  2. 2nd argument is y-coord of 1st point.
  3. 3rd argument is x-coord of 2nd point.
  4. 4th argument is y-coord of 2nd point.
  5. 5th argument is x-coord of point at which to interpolate.
Example:

MATH y = INTERP(1, 1, 3, 5, 2)

The call to INTERP shown above linearly interpolates between the two points (1,1) and (3,5) at 2. The result (y) is equal to 3.

Caution: Procedure writers should exercise caution when extrapolating because large extrapolations are often not statistically valid.
Error Handling: If x1 and x2 are the same value an error message is generated.
Compatibility: Requires V7.20t or later.

LINREG

Purpose: Compute linear regression from a set of (X,Y) points. The calculation uses a least square fit to determine the line that best fits the data points.
Quick Proto: LinReg(x, y, "slope", "intercept")
Result Type:

Numeric (or void) The return value is 1 if the function succeeds. The return value is 0 if the function fails.

(However, since any error in the function aborts the procedure step, there's no need to check the return value of the function.)

Argument Type:

String, String, String, String

  1. Argument #1 is a comma-separated list of X-values.
  2. Argument #2 is a comma-separated list of Y-values.
  3. Argument #3 is the name of the variable where the calculated slope is stored.
  4. Argument #4 is the name of the variable where the calculated intercept is stored.

Example:

MATH x = "1,2,3"
MATH y = "8,9,10"
MATH LinReg(x, y, "slope", "intercept")

After LinReg returns the value of the variable "slope" will be 1, and the value of "intercept" will be 7.

The 3 specified data points (1,8), (2,9), and (3,10) represent a line with a slope of 1 (i.e., a line at 45 degrees) and a y-intercept of 7.

(This example is overly simple because the 3 points all lie on the same line. It is intended only to illustrate how to call the function.)

Usage:

There are various methods for generating the comma-separated lists containing the X-values and the Y-values. If you already have the values stored in the M-registers or the L-registers, you can use the CSV and/or CSV_L functions to generate the list.

The 3rd and 4th function arguments are variable names, not variable values. Therefore, in general, you must enclose the names in double quotes in the call to "LinReg". (An exception to this would be if you were to store the name of the variable as the value of a different variable.)

Caution:

Not all data sets are best modeled by a linear least squares fit. In some cases higher order polynomial fits are more appropriate.

(You cannot use the "LinReg" function to perform higher order fits.) European number formats are not supported.

For example, you cannot specify a value list like

"1,2;2,37;4,4".

The list has to be represented like "1.2,2.37,4.4".

Error Handling:

All input parameters must be non-empty strings.

The number of X-values must be the same as the number of Y-values, and there must be at least two data points. All values in the CSV lists must be numeric, and no values may be missing.

An input set of (X,Y) data points that are best fit by a vertical line cannot be accommodated by "LinReg". The algorithm will attempt to divide by zero, generating an error message and aborting the function call.

Compatibility: Requires V7.20B or later.
See Also: CSV, CSV_L

LN

Purpose: | Computes the natural logarithm of its argument.
Result Type: | Numeric
Argument Type: | Numeric
Example: | MATH L[1] = LN(MEM)

LOG

Purpose: | Computes the base 10 logarithm of its argument.
Result Type: | Numeric
Argument Type: | Numeric
Example: | MATH L[1] = LOG(MEM)

MAX

Purpose:

Computes the maximum of a set of numbers.

The function arguments specify the indices of a range of global numeric registers for which the maximum is to be determined.

Result Type: Numeric
Argument Type: Numeric, Numeric
Example:

MATH M[5] = 25
MATH M[6] = 45
MATH M[7] = 20
MATH MEM = MAX(5, 7)

After the last MATH statement executes the value of MEM will be 45.

MAX_L

Purpose:

Computes the maximum of a set of numbers.

The function arguments specify the indices of a range of local numeric registers for which the maximum is to be determined.

Result Type: Numeric
Argument Type: Numeric, Numeric
Compatibility: Requires V7.00b or later.
Example:

MATH L[5] = 25
MATH L[6] = 45
MATH L[7] = 20
MATH MEM = MAX_L(5, 7)

After the last MATH statement executes the value of MEM will be 45.

MAX2

Purpose: Computes the maximum of two values.
Result Type: Numeric
Argument Type: Numeric, Numeric
Example:

MATH M[5] = 3.7
MATH M[6] = 4.1
MATH MEM = MAX2(M[5], M[6])

After the last MATH statement executes the value of MEM will be 4.1.

MIN

Purpose:

Computes the minimum of a set of numbers.

The function arguments specify the indices of a range of global numeric registers for which the minimum is to be determined.

Result Type: Numeric
Argument Type: Numeric, Numeric
Example:

MATH M[5] = 25
MATH M[6] = 45
MATH M[7] = 20
MATH MEM = MIN(5, 7)

After the last MATH statement executes the value of MEM will be 20.

MIN_L

Purpose:

Computes the minimum of a set of numbers.

The function arguments specify the indices of a range of local numeric registers for which the minimum is to be determined.

Result Type: Numeric
Argument Type: Numeric, Numeric
Compatibility: Requires V7.00b or later.
Example:

MATH L[5] = 25
MATH L[6] = 45
MATH L[7] = 20
MATH MEM = MIN_L(5, 7)

After the last MATH statement executes the value of MEM will be 20.

MIN2

Purpose: Computes the minimum of two values.
Result Type: Numeric
Argument Type: Numeric, Numeric
Example:

MATH M[5] = 3.7
MATH M[6] = 4.1
MATH MEM = MIN2(M[5], M[6])

After the last MATH statement executes the value of MEM will be 3.7.

MISMATCHSWR

Purpose: Computes mismatch uncertainty.
Result Type: Numeric
Argument Type: Numeric, Numeric
Example:

MATH SourceSWR = 1.2; SensorSWR = 1.18
MATH MismatchUnc = MismatchSWR(SourceSWR, SensorSWR)
DISP Mismatch Uncertainty: [V MismatchUnc] %

NOT

Purpose:

Performs a Boolean inversion of it's argument.

  • If the argument is zero, NOT returns 1.
  • If the argument is non-zero, NOT returns 0.
Note: There are no cases where NOT must be used, but there are some situations where procedure readability may be improved by using NOT.
Result Type: Numeric
Argument Type: Numeric
Compatibility: Requires V7.11u or later.
Example:

MATH MEM = NOT(ZCMP("A", "B"))

ZCMP returns 0 because "A" and "B" are not the same. Therefore the value assigned to MEM will be 1.

POW

Purpose: | Raises a specified value to a specified power. (The exponentiation operator, "^", may also be used to raise a value to a power. For example, "pow(5,2) is equivalent to "5^2".)
Result Type: | Numeric
Argument Type: | Numeric, Numeric
Example: | MATH MEM = POW(5, 2) After this statement executes the value of MEM will be 25.

RND

Purpose: | Rounds a number to the nearest integer.
Result Type: | Numeric
Argument Type: | Numeric
Example: | MATH L[1] = RND(MEM) RSS

RSS

Purpose:

Computes the RSS (square root of sum of squares) of a set of numbers.

The function arguments specify the global numeric register indices of a range of numeric values to be included in the RSS calculation.

Result Type: Numeric
Argument Type:

Numeric, Numeric

  1. The first argument is the starting index of the sequence of global numeric registers.
  2. The second argument is the ending index of the sequence of global numeric registers.
Compatibility: Requires V7.00b or later.
Example:

  1.001 MATH M[5] = 5; M[6] = 4
  1.002 MATH M[7] = 2; M[8] = 7; M[9] = 12
  1.003 MATH MEM = RSS(5, 9)

The call to RSS sets the value of MEM to 15.4272486205.

RSS_L

Purpose:

Computes the RSS (square root of sum of squares) of a set of numbers.

The function arguments specify the local numeric register indices of a range of numeric values to be included in the RSS calculation.

Result Type: Numeric
Argument Type:

Numeric, Numeric

  1. The first argument is the starting index of the sequence of local numeric registers.
  2. The second argument is the ending index of the sequence of local numeric registers.
Compatibility: Requires V7.00b or later.
Example:

  1.001 MATH L[5] = 5; L[6] = 4
  1.002 MATH L[7] = 2; L[8] = 7; L[9] = 12
  1.003 MATH MEM = RSS_L(5, 9)

The call to RSS_L sets the value of MEM to 15.4272486205.

RSS2

Purpose: | Calculates the RSS (square root of the sum of the squares) of two specified numbers.
Result Type: | Numeric
Argument Type: | Numeric, Numeric
Compatibility: | Requires V6.01 or later.
Example: | MATH MEM = RSS2(3, 4) Executing the MATH statement above results in MEM being set to 5, because the 3^2 + 4^2 is 25, and the square root of 25 is 5.

RSS3

Purpose: | Calculates the RSS (square root of the sum of the squares) of three specified numbers.
Result Type: | Numeric
Argument Type: | Numeric, Numeric, Numeric
Compatibility: | Requires V6.01 or later.
Example: | MATH MEM = RSS3(2, 3, 6) Executing the MATH statement above results in MEM being set to 7, because the 2^2 + 3^2 + 6^2 is 49, and the square root of 49 is 7.

SDEV

Purpose:

Computes the standard deviation of a set of numbers.

The function arguments specify the indices of a range of global numeric registers the values of which are to be included in the calculation of the standard deviation.

Quick Proto: val = SDEV(StartIndex, EndIndex)
Result Type: Numeric
Argument Type:

Numeric, Numeric

  1. The first argument specifies the index of the first M register to include in the standard deviation calculation.
  2. The second argument specifies the index of the last M register to include in the standard deviation calculation.
Example:

  1.001 MATH M[5] = 10
  1.002 MATH M[6] = 11
  1.003 MATH M[7] = 10
  1.004 MATH M[8] = 11
  1.005 MATH MEM = SDEV(5, 8)

After the last MATH statement executes the value of MEM will be 0.5774.

SDEV_L

Purpose:

Computes the standard deviation of a set of numbers.

The function arguments specify the indices of a range of local numeric registers the values of which are to be included in the calculation of the standard deviation.

SDEV_L is the same as SDEV, except that it uses the L registers rather than the M registers.

Quick Proto: val = SDEV_L(StartIndex, EndIndex)
Result Type: Numeric
Argument Type:

Numeric, Numeric

  1. The first argument specifies the index of the first L register to include in the standard deviation calculation.
  2. The second argument specifies the index of the last L register to include in the standard deviation calculation.
Compatibility: Requires V7.00b or later.
Example:

  1.001 MATH L[5] = 10
  1.002 MATH L[6] = 11
  1.003 MATH L[7] = 10
  1.004 MATH L[8] = 11
  1.005 MATH MEM = SDEV_L(5, 8)

After the last MATH statement executes the value of MEM will be 0.5774.

SGN

Purpose: | Determines the arithmetic sign of a number. Returns 1 for positive numbers, -1 for negative numbers, and 0 for zero.
Result Type: | Numeric
Argument Type: | Numeric
Example: | MATH L[1] = SGN(MEM)

SQRT

Purpose: | Computes the square root of its argument.
Result Type: | Numeric
Argument Type: | Numeric
Example: | MATH L[1] = SQRT(MEM)

SUM

Purpose:

Computes the sum of a set of numbers.

The function arguments specify the indices of a range of global numeric registers the values of which are to be added.

Quick Proto: SUM(starting M-Reg index, ending M-Reg index)
Result Type: Numeric
Argument Type: Numeric, Numeric
Compatibility: Requires V7.01s or later.
Example:

  1.001 MATH M[5] = 25
  1.002 MATH M[6] = 45
  1.003 MATH M[7] = 20
  1.004 MATH MEM = SUM(5, 7)

After the last MATH statement executes the value of MEM will be 90.

SUM_L

Purpose:

Computes the sum of a set of numbers.

The function arguments specify the indices of a range of local numeric registers the values of which are to be added.

Quick Proto: SUM(starting L-Reg index, ending L-Reg index)
Result Type: Numeric
Argument Type: Numeric, Numeric
Compatibility: Requires V7.01s or later.
Example:

  1.001 MATH L[5] = 1.1
  1.002 MATH L[6] = 2.2
  1.003 MATH L[7] = 3.3
  1.004 MATH MEM = SUM_L(5, 7)

After the last MATH statement executes the value of MEM will be 5.6.


MATH FSC Humidity and Temperature Sensor Functions

RHT_HUMIDITY | return last RHT relative humidity
RHT_TEMP | return last RHT temperature
RHT_TIME | return last RHT timestamp

RHT_HUMIDITY

Purpose: | Returns the most recent RHT relative humidity. A run time error occurs if RHT use is not enabled on the workstation on which the procedure is being executed, or if RHT parameters in the Temperature and Humidity MET/CAL Configuration settings are incorrect, or if RHT data values in the RHT data file are invalid or inaccessible.
Result Type: | Numeric
Argument Type: | None
Compatibility: | Requires V6.11 or later.
Example: | MATH M[1] = RHT_HUMIDITY()

RHT_TEMP

Purpose: | Returns the most recent RHT temperature. Temperature units are either degC or degF, depending on the configuration of the RHT. A run time error occurs if RHT use is not enabled on the workstation on which the procedure is being executed, or if RHT parameters in the Temperature and Humidity MET/CAL Configuration settings are incorrect, or if RHT data values in the RHT data file are invalid or inaccessible.
Result Type: | Numeric
Argument Type: | None
Compatibility: | Requires V6.11 or later.
Example: | MATH M[1] = RHT_TEMP()

RHT_TIME

Purpose: | Returns the most recent RHT timestamp in seconds since midnight Jan 01, 1970 UTC (coordinated universal time). A run time error occurs if RHT use is not enabled on the workstation on which the procedure is being executed, or if RHT parameters in the Temperature and Humidity MET/CAL Configuration settings are incorrect, or if RHT data values in the RHT data file are invalid or inaccessible.
Result Type: | Numeric
Argument Type: | None
Compatibility: | Requires V6.11 or later.
Example: | MATH M[1] = RHT_TIME()


MATH FSC Initialization File Functions

DFILE | return full path of MET/CAL DOS/DOSE data file
IFILE | return full path of MET/CAL ini file
INI | return value of MET/CAL ini file parameter
RIF | return value of specified ini file parameter
RINF | read instrument information file
RINFE | read instrument information file, w/ error msg
WIF | write value of specified ini file parameter

Initialization files created or edited manually (outside of MET/CAL's built-in functions) must meet these requirements.

  1. The first line of the *.ini file must be blank, or contain a comment.
  2. Save the *.ini file with UTF-8 encoding. In Windows Notepad, encoding is selected from the File > Save As... via drop-down.

DFILE

Purpose:

Returns the full path name of the MET/CAL DOS/DOSE data file. This function may be used to pass the DOS/DOSE data file name to a user program to be invoked with the DOS or DOSE FSC.
Result Type: String
Argument Type: None
Compatibility: Requires V6.00 or later.
Example:

MATH S[5] = DFILE()
DOS USER1 [S5]

In this example the full path name of the DOS/DOSE data file is stored in string register S[5], and then passed as the first (and only) argument to the user program USER1.

IFILE

Purpose

Returns the full path name of the MET/CAL initialization file. This function may be used to pass the initialization file name to a user program to be invoked with the DOS or DOSE FSC.

The MET/CAL initialization file should no longer be edited manually. Use the MET/CAL Configuration settings instead.
Result Type | String
Argument Type | None
Compatibility | Requires V6.00 or later
Example | MATH S[5] = IFILE()

INI

Purpose:

Retrieves the value of a specified MET/CAL initialization file parameter. This function takes two arguments.

  1. The first argument specifies the initialization file section (case-insensitive).
  2. The second argument specifies the initialization file parameter (case-insensitive).

The return value is an empty string if the specified parameter does not exist in the specified section, or if the parameter exists but has no value. One use of this function is to pass values from the initialization file to user program invoked with the DOS (or DOSE) FSC.
Result Type: String
Argument Type: String, String
Compatibility: Requires V6.00 or later.
Example:

MATH M[10] = INI("startup", "tur_lim")

In this example, the value of the "tur_lim" parameter (usually 4.0) is stored in numeric register M[10]. "tur_lim" specifies the T.U.R. limit used by MET/CAL.

Note also that "INI" has a string return value, but in this example the return value is assigned to a numeric register. The MATH FSC automatically converts the string value to a numeric value when necessary.

RIF

Purpose:

Reads the value of a specified initialization file parameter. This function has three arguments.

  1. The first argument is the initialization file name.
  2. The second argument is the section name (case-insensitive).
  3. The third argument is the parameter name (case-insensitive).

The return value is an empty string if the file does not exist, or the specified parameter does not exist in the specified section, or if the parameter exists but has no value.

The file name is usually case-insensitive, but it depends on the file system. For example, if you are reading a file on a Unix server, the file name will be case-sensitive.
Quick Proto: val = RIF(ini file, section, param)
Result Type: String
Argument Type: String, String, String
Compatibility: Requires V7.01s or later.
Directory: Refer to the RIF/WIF Data Directory section for a description of how to specify the directory where MET/CAL accesses data files used with the RIF and WIF MATH functions.
Example:

  1.001 MATH S[10] = "c:\\metcal\\test.ini"
  1.002 MATH MEM2 = RIF(S[10], "abc", "xyz")

In this example the value of parameter "xyz" in section "abc" of file "c:\metcal\test.ini" is retrieved.

The file name is stored first in string register S[10] to save space on the line which calls "RIF". (This is optional. You only have to do this if the MATH statement gets too long.) Note also that when a file name includes backslash characters, you must specify two backslashes to indicate a single literal backslash in a MET/CAL string register value. Suppose the file test.ini looks like this: [abc]

xyz = 23.6 mV

Then the value of MEM2 after the call to RIF will be "23.6 mV".

RINF

Purpose:

Reads the value of a specified parameter in the instrument information file (user_config_instr.ini). This function has two arguments.

  1. The first argument is the section name (case-insensitive).
  2. The second argument is the parameter name (case-insensitive).

The return value is an empty string if the file does not exist, or the specified parameter does not exist in the specified section, or if the parameter exists but has no value.

The name and location of the instrument information file are specified using the Instrument Info Folder MET/CAL Configuration setting.

RINF does not generate an error message if there's no value for the specified parameter in the specified section of the instrument information file.
Quick Proto: val = RINF(section, param)
Result Type: String
Argument Type: String, String
Compatibility: Requires V7.11 or later.
Example:

MATH MEM2 = RINF("abc", "xyz")

In this example the value of parameter "xyz" in section "abc" of the instrument information file is retrieved. Suppose the file instrument information file contains: [abc]

xyz = 23.6 mV

Then the value of MEM2 after the call to RINF will be "23.6 mV".

RINFE

Purpose:

Reads the value of a specified parameter in the instrument information file. This function has two arguments:

  1. The first argument is the section name (case-insensitive).
  2. The second argument is the parameter name (case-insensitive).

The return value is an empty string if the file does not exist, or the specified parameter does not exist in the specified section, or if the parameter exists but has no value.

The name and location of the instrument information file are specified using the Instrument Info Folder MET/CAL Configuration setting.

RINFE is the same as RINF, except that it generates an error message if the specified parameter value cannot be found.
Quick Proto:

val = RINFE(section, param)
Result Type: String
Argument Type: String, String
Compatibility: Requires V7.11 or later.
Example:

MATH MEM2 = RINFE("abc", "xyz")

In this example the value of parameter "xyz" in section "abc" of the instrument information file is retrieved. Suppose the file instrument information file contains:

[abc]

xyz = 23.6 mV

Then the value of MEM2 after the call to RINFE will be "23.6 mV".

WIF

Purpose:

Writes the value of a specified initialization file parameter. Attempts to create the initialization file, if it does not exist.

This function has four arguments.

  1. The first argument is the initialization file name.
  2. The second argument is the section name (case-insensitive).
  3. The third argument is the parameter name (case-insensitive).
  4. The fourth argument is the parameter value.
  • The return value is 0 if the call to WIF fails.
  • The return value is 1 if the call to WIF succeeds.

The file name is usually case-insensitive, but it depends on the file system. For example, if you are writing to a file on a Unix server, the file name will be case-sensitive.
Result Type: String (or Void)
Argument Type: String, String, String, String
Compatibility: Requires V7.01s or later.
Directory: Refer to the RIF/WIF Data Directory section for a description of how to specify the directory where MET/CAL accesses data files used with the RIF and WIF MATH functions.
Example 1:

  1.001 MATH S[10] = "c:\\metcal\\test.ini"
  1.002 MATH MEM2 = WIF(S[10], "abc", "x", "20")

In this example the value of parameter "x" in section "abc" of file C:\metcal\test.ini is written. The file name is stored first in string register S[10] to save space on the line which calls "RIF". (This is optional; you only have to do this if the MATH statement gets too long.)

Note also that when a file name includes backslash characters, you must specify two backslashes to indicate a single literal backslash in a MET/CAL string register value. After the call to WIF, test.ini will contain:

[abc]

x = 20
Example 2:

It may be desirable to store temporary device characterization information in an initialization file. If this characterization data is temporary, the DOS FSC can delete the file:

  1.001 MATH S[10] = "c:\\metcal\\test.ini"
  1.002 MATH WIF(S[10], "abc", "x", "20")
  1.003 DOS -u -w cmd /c del "[SREG10]"

This example also shows that it is legal to ignore the function return value.


MATH FSC List Box Functions

lbAdd | add item to list box
lbAddList | add list of items to list box
lbAddV | add item to list box, with associated variable
lbButton | add button to list box window
lbButtonFocus | set default button (with keyboard focus)
lbClose | close list box window
lbConf | configure list box window
lbGetSel | get name of n-th selected list box item
lbGetSelX | get index of n-th selected list box item
lbNew | create new list box window
lbRepl | replace item in list box
lbReplV | replace item with associated variable in list box
lbResp | get user's text response
lbSel | initially select list box item (by name)
lbSelCount | get count of selected list box items
lbSelX | initially select list box item (by index)
lbShow | display list box window
lbText | add text line to list box window
lbUnSel | remove initial selection of item (by name)
lbUnSelX | remove initial selection of item (by index)

lbAdd

Purpose: Add item to list box.
Quick Proto: lbAdd(ID, list box item)
Result Type: Numeric (or Void): 1 on success, 0 on error.
Argument Type:

Numeric, String

  1. The 1st argument is the list box ID.
  2. The 2nd argument is the list box item name to be added.
Compatibility: Requires V7.20 SP1 or later
See Also: lbAddV, lbAddList; use lbRepl to remove an item
Example:
MATH lbAdd(id, "A")
MATH lbAdd(id, "B")
MATH lbAdd(id, "C")

The 3 calls above configure the specified list box window to include 3 list box items ("A", "B", and "C").

lbAddList

Purpose: Add list of items to list box.
Quick Proto: lbAddList(ID, list box item list)
Result Type: Numeric (or Void): 1 on success, 0 on error.
Argument Type:

Numeric, String

  1. The 1st argument is the list box ID.
  2. The 2nd argument is a comma-separated list of list box items to be added.
Compatibility: Requires V7.20 SP1 or later
See Also: lbAdd, lbAddV; use lbRepl to remove an item
Example:

MATH lbAddList(id, "A,B,C")

The call above configures the specified list box window to include 3 list box items ("A", "B", and "C").

lbAddV

Purpose:

Add item to list box, with associated variable.

Variables associated with selected list box items are set to 1 automatically when the user closes the list box window

Variables associated with non-selected list box items are set to "0" automatically when the user closes the list box window.
Quick Proto: lbAddV(ID, list box item, var name)
Result Type: Numeric (or Void): 1 on success, 0 on error.
Argument Type:

Numeric, String, String

  1. The 1st argument is the list box ID.
  2. The 2nd argument is the list box item name to be added.
  3. The 3rd argument is the name of a variable associated with the item.
Example:

MATH id = lbNew("lbAddV Example")
MATH lbAddV(id, "A", "varA")
MATH lbAddV(id, "B", "varB")
MATH lbAddV(id, "C", "varC")
MATH op = lbShow(id)

The 3 calls to "lbAddV" above configure the specified list box window to include 3 list box items ("A", "B", and "C").

In addition, a named variable is associated with each list box item. If the user selects "B" then, when "lbShow" returns, "varB" will automatically be set to "1". "varA" and "varC" will automatically be set to "0".
Compatibility: Requires V7.20 SP1 or later
See Also: lbAdd, lbAddList; use lbRepl to remove an item

lbButton

Purpose: Add button(s) to list box window (maximum of 8).
Quick Proto: lbButton(ID, button label)
Result Type: Numeric (or Void): 1 on success, 0 on error.
Argument Type:

Numeric, String

  1. The 1st argument is the list box ID.
  2. The 2nd argument is the button label.
Example:

MATH lbButton(id, "B1")
MATH lbButton(id, "B2")
MATH lbButton(id, "B3")

The calls above configure the specified list box window to display 3 buttons ("B1", "B2", and "B3"), rather than the default Advance and Terminate buttons.
Compatibility: Requires V7.20 SP1 or later.
See Also: lbButtonFocus

lbButtonFocus

Purpose:

Specify default button with initial input focus.

By default, the first button gets the input focus. This means that if you just type Enter without clicking on a button or using the Tab or Arrow Keys to move the focus, the first button is chosen.
Quick Proto: lbButton(ID, button index)
Result Type: Numeric (or Void): 1 on success, 0 on error.
Argument Type:

Numeric, Numeric

  1. The 1st argument is the list box ID.
  2. The 2nd argument is the 1-based index of the button that receives the initial input focus.
Example:

MATH lbButtonFocus(id, 2)

The call above puts the initial focus on the 2nd button.
Error Handling: An error message is generated if the index is less than 1 or greater than the maximum number of allowed buttons.
Usage:

If the specified index does not exceed the maximum number of allowed buttons, but does not correspond to a configured button, the call to "lbButtonFocus" is ignored, and the first button remains the default button.

Calls to "lbButtonFocus" are ignored if the list box window includes a list box or single-line text entry area. In other words, "lbButtonFocus" is useful only with list box windows that contain only buttons and, optionally, multi-line read-only text, and, optionally, a window title line.
Compatibility: Requires V7.20 SP2 or later.
See Also: lbButton, lbClose

lbClose

Purpose: | Close list box window. Closing list box windows is optional. When the window is closed, all internal memory allocated for the list box is released. If the procedure writer does not call "lbClose", MET/CAL will release allocated memory when the procedure terminates.
Quick Proto: | lbClose(ID)
Result Type: | Numeric (or Void).
Argument Type: | Numeric The argument is the list box ID.
Example: | MATH lbClose(id)
Compatibility: | Requires V7.20 SP1 or later
See Also: | lbConf

lbConf

Purpose:

Configure list box window attributes. Each support attribute name may be preceded by a plus sign ('+') or a minus sign ('-').

  • '+' selects the attribute.
  • '-' deselects the attribute.
Supported
attributes:
border (default: +border)
+border causes the scrollable text area to include a thin border.
-border suppresses the border.
Suppressing the border does not change the background color in the scrollable text area. The background color in the scrollable text area will probably be different from the background color of the list box window itself. This depends on the Windows color configuration on the PC.
This configuration option requires MET/CAL V7.20C or later.
edit (default: -edit)
+edit configures the list box window to include a single-line text entry area.
list (default: +list)
+list configures the list box window to include a list box.
listf (default: -listf)
+listf forces the keyboard focus to the list box.
This attribute is relevant only when +edit is specified, otherwise the keyboard focus is automatically on the list box.
It is not necessary to specify both +list and +listf because +listf automatically implies +list.
mess (default: -mess)
+mess configures the list box window to include any current MESS FSC messages in the scrollable text area.
multi (default: -multi)
+multi configures the list box window to include a multi-selection list box.
ok (default: -ok)
+ok configures the list box window to display OK and Cancel buttons instead of Advance and Terminate.
search (default: -search)
+search configures the list box window to include a Search button used to search the list box items. (This option is useful only when the list box has many items.)
sel (default: +sel)
+sel configures the list box window to initially select (highlight) the first item in the list box.
selreq (default: -selreq)
+selreq configures the list box window to require the user to make a list box selection.
sort (default: -sort)
+sort configures the list box window to show list box items in sorted order. Otherwise, list box items are shown in the order in which they are added.
term (default: see below)
+term configures the list box window to return to the Post Test window when the user choose the Terminate button.
The default is +term when default buttons (Advance and Terminate) are used.
The default is -term when non-default buttons are used. When +term is used with non-default buttons, the right-most button, other than Search, is considered to be the terminate button.
+term is ignored if the list box window has only a single non-Search button.
text (default: -text)
+text configures the list box window to include a scrollable, read-only text area above the list box. However, adding text lines to the list box window automatically configures +text.
Quick Proto: lbConf(ID, attribute list)
Result Type: Numeric: 1 on success, 0 on error.
Argument Type:

Numeric, String

  1. The 1st argument is the list box ID.
  2. The 2nd argument specifies a comma-separated list of one or more list box window attribute names.
Example:

MATH id = lbNew("List Box Example")
MATH lbConf(id, "+multi,+sort")
...

The call to "lbConf" above causes the list box to be configured as a multi-selection list box in which the list box items are shown in sorted order.
Compatibility: Requires V7.20 SP1 or later
See Also:

lbGetSel

Purpose: Get n-th selected list box item.
Quick Proto: lbGetSel(ID, index)
Result Type:

String

The return value is the selected list box item with the specified selection index.
Argument Type:

String, Numeric

  1. The 1st argument is the list box ID.
  2. The 2nd argument is the 1-based selection index of the item to be retrieved.

For example, if the user selects three list box items, the first selected item has selection index 1, the 2nd selected item has selection index 2, and the 3rd selected item has selection index 3.

Example:

  1.001 MATH id = lbNew("List Box Example")
  1.002 MATH lbAddList(id, "A,B,C,D")
  1.003 MATH lbConf(id, "+SelReq, +multi")
  1.004 MATH lbShow(id)

  1.005 IF lbSelCount(id) > 1
  1.006 MATH item2 = lbGetSel(id, 2)
  1.007 ENDIF

The example procedure fragment above creates a new list box window, adds 4 items to the list box, configures the window to require at least one list box selection, displays the window and waits for the user to select one or more items. If the user selects more than one item, "lbSelCount" is called to retrieve the name of the 2nd selected item.
Compatibility: Requires V7.20 SP1 or later
See Also: lbGetSelX, lbSelCount

lbGetSelX

Purpose: Get index of n-th selected list box item.
Quick Proto: lbGetSelX(ID, index)
Result Type:

Numeric

The return value is the 1-based index of the list box item with the specified selection index. The return value is the 1-based index relative to the order in which the items are added to the list box. If the list box is configured with the "+Sort" attribute, the index relative to the display order may be different.
Argument Type:

String, Numeric

  1. The 1st argument is the list box ID.
  2. The 2nd argument is the 1-based selection index of the item to be retrieved.

For example, if the user selects three list box items, the first selected item has index 1, the 2nd selected item has index 2, and the 3rd selected item has index 3.
Example:

  1.001 MATH id = lbNew("List Box Example")
  1.002 MATH lbAddList(id, "A,B,C,D")
  1.003 MATH lbConf(id, "+SelReq")
  1.004 MATH lbShow(id)

  1.005 IF lbSelCount(id) > 1
  1.006 MATH index = lbGetSelX(id, 2)
  1.007 ENDIF

The example procedure fragment above creates a new list box window, adds 4 items to the list box, configures the window to require at least one list box selection, displays the window and waits for the user to select one or more items.

If the user selects more than one item, lbSelCount is called to retrieve the index of the 2nd selected item. If the user selects the items "A" and "C" the call to lbGetSelX will return 3 (because the list box index of "C" is 3).
Compatibility: Requires V7.20 SP1 or later
See Also: lbGetSelX, lbSelCount

lbNew

Purpose: | Create new list box window. Creating a list box window is a necessary first step, but it doesn't add items to the list box, or cause the window to be displayed.
Quick Proto: | ID = lbNew(title string)
Result Type: | Numeric The return value is the list box ID of the new list box window. The ID is an integer value used as a list box window handle in all subsequent calls that access the list box window.
Argument Type: | String The argument specifies the list box window title string.
Example: | MATH id = lbNew("Choose UUT Model") The call above creates a new list box window with the title "Choose UUT Model".
Compatibility: | Requires V7.20 SP1 or later
See Also: | lbClose

lbRepl

Purpose: Replace item in list box.
Quick Proto: lbRepl(ID, original, replacement)
Result Type: Numeric (or Void): 1 on success, 0 on error.
Argument Type:

Numeric, String, String

  1. The 1st argument is the list box ID.
  2. The 2nd argument is the list box item name to be replaced.
  3. The 3rd argument is the replacement list box item name.

If the replacement item is an empty string, the item specified by the original string is removed from the list box.
Example:

MATH lbAddList(id, "A,B,C")
MATH lbShow(id)
MATH lbRepl(id, "B", "X")
MATH lbShow(id)

The list box window is first shown with 3 list box items, "A", "B", and "C". The call to "lbRepl" then changes the "B" to "X". When the list box window is redisplayed it will have "A", "X", and "C" in the list box.
Compatibility: Requires V7.20 SP2 or later.
See Also: lbReplV

lbReplV

Purpose: Replace item in list box.
Quick Proto: lbRepl(ID, variable, replacement)
Result Type: Numeric (or Void): 1 on success, 0 on error.
Argument Type:

Numeric, String, String

  1. The 1st argument is the list box ID.
  2. The 2nd argument is the name of the variable associated with the list box item to be replaced.
  3. The 3rd argument is the replacement list box item name.

If the replacement item is an empty string, the item specified by the variable name string is removed from the list box.
Example:

MATH lbAddV(id, "A", "v1")
MATH lbAddV(id, "B", "v2")
MATH lbAddV(id, "C", "v3")
MATH lbShow(id)
MATH lbReplV(id, "v2", "X")
MATH lbShow(id)

The list box window is first shown with 3 list box items, "A", "B", and "C". The call to "lbRepl" then changes the item associated with the variable "v2" to an "X". When the list box window is redisplayed it will have "A", "X", and "C" in the list box.
Usage: "lbReplV" does not change the name of the variable associated with an item. It changes the list box item name itself. The associated variable name is unchanged. (You can change the name of an associated variable by calling lbAddV with an existing list box item name and a new variable name.)
Compatibility: Requires V7.20 SP2 or later.
See Also: lbAddV, lbRepl

lbResp

Purpose:

Get user's text response.

The list box window must be configured with +Edit in order to use lbResp
Quick Proto: response = lbResp(ID)
Result Type:

String

The return value is a text string containing text entered by the user in the single-line text entry area.
Argument Type:

Numeric

The argument is the list box ID.
Example:

MATH id = lbNew("Example")
MATH lbConf(id, "+edit,-list")
MATH lbText(id, "Please enter a response:")
MATH lbShow(id)
MATH response = lbResp(id)
DISP User Entered: [v response]

The example above creates a list box window that includes a single-line text entry area. (The window does not include a list box.) The text string Please enter a response: is shown in the scrollable text area. The users response is retrieve using a call to lbResp, and the response string is then displayed using a DISP statement
Compatibility: Requires V7.20 SP1 or later
See Also: lbSel

lbSel

Purpose:

Initially select list box item (by name).

By default, the first list box item will be selected (highlighted) when the window is displayed. If the list box is configured as a multi-selection list box ("+multi"), multiple calls to "lbSel" may be made to initially highlight more than one list box item.

If the list box is single-selection, only the last call to "lbSel" (or lbSelX) will be effective.
Quick Proto: lbSel(ID, item name)
Result Type: Numeric (or Void): 1 on success, 0 on error.
Argument Type:

Numeric, String

  1. The 1st argument is the list box ID.
  2. The 2nd argument is the name of the list box item to initially select when the list box window is displayed.

Example:

MATH id = lbNew("lbSel Example")
MATH lbAddList(id, "A,B,C,D,E")
MATH lbSel(id, "C")
MATH lbShow(id)

The example above creates a new list box window, configures the list box to contain 5 items ("A", "B", "C", "D", and "E"), selects the 3rd item ("C") to be initially highlighted when the window is displayed, and displays the window.
Compatibility: Requires V7.20 SP1 or later
See Also: lbSelX, lbSelCount

lbSelCount

Purpose: Get count of selected list box items.
Quick Proto: count = lbSelCount(ID)
Result Type:

Numeric

The return value is the number of selected items. The number of selected items will never exceed 1 unless the list box is configured as a multi-selection list box ("+multi").
Argument Type:

Numeric

The argument is the list box ID.
Example:

  1.001 MATH id = lbNew("lbSelCount Example")
  1.002 MATH lbConf(id, "+multi")
  1.003 MATH lbAddList(id, "A,B,C,D,E,F,G")
  1.004 MATH lbShow(id)
  1.005 MATH SelCount = lbSelCount(id)
  1.006 MATH i = 1

  1.007 WHILE i ≤ SelCount
  1.008 MATH str = lbGetSel(id, i)
  1.009 DISP Selected String #[v i] = [v str]
  1.010 MATH i = i + 1
  1.011 ENDW

The example above configures a multi-selection list box with 7 items, then retrieves and displays the users selections.
Compatibility: Requires V7.20 SP1 or later
See Also: lbSelX

lbSelX

Purpose:

Initially select list box item (by index).

By default, the first list box item will be selected (highlighted) when the window is displayed.

If the list box is configured as a multi-selection list box (+multi), multiple calls to lbSelX may be made to initially highlight more than one list box item.

If the list box is single-selection, only the last call to "lbSelX" (or "lbSel") will be effective.
Quick Proto: lbSelX(ID, item index)
Result Type: Numeric (or Void): 1 on success, 0 on error.
Argument Type:

Numeric, String

  1. The 1st argument is the list box ID.
  2. The 2nd argument is the index of the list box item to initially select when the list box window is displayed. The index is a 1-based index relative to order in which the items are added.
Example:

MATH id = lbNew("lbSelX Example")
MATH lbAddList(id, "A,B,C,D,E")
MATH lbSelX(id, 4)
MATH lbShow(id)

The example above creates a new list box window, configures the list box to contain 5 items ("A", "B", "C", "D", and "E"), selects the 4th item ("D") to be initially highlighted when the window is displayed, and displays the window.
Compatibility: Requires V7.20 SP1 or later
See Also: lbSel, lbShow

lbShow

Purpose:

.

Display list box window. "lbShow" displays a list box window and waits for the user's response. The user's response consists of either:

  1. Choosing one or more list box items, then choosing one of the buttons in the list box window, or
  2. Entering a response into the single-line text entry area, then choosing one of the buttons in the list box window.

Before a list box window can be displayed it must first be created using lbNew, then configured using various other functions such as lbAdd, lbAddList, lbText, and lbConf.
Quick Proto: ButtonVal = lbShow(ID)
Result Type:

The return value is the button index of the button chosen by the user.

Buttons are numbered 1, 2, 3, ..., left to right. If the "+term" option is configured, the last button (not including the "Search" button) causes a direct return to the Post Test window.

"+term" is the default when default buttons (Advance and Terminate) are used.
Argument Type:

Numeric

The argument is the list box ID.
Example:

MATH id = lbNew("lbShow Example")
MATH lbAddList(id, "A,B,C,D,E")
MATH op = lbShow(id)

This example creates a new list box window, adds 5 items to the list box, then displays the list box window and waits for the user's response.
Compatibility: Requires V7.20 SP1 or later
See Also: lbText

lbText

Purpose: Add text line to list box window.
Quick Proto: lbText(ID, text line)
Result Type: Numeric (or Void)
Argument Type:

Numeric, String

  1. The 1st argument is the list box ID.
  2. The 2nd argument is a line of text to be added to the scrollable, read-only text display area at the top of the list box window.
Example:

MATH id = lbNew("lbText Example")
MATH lbText(id, "Choose one of the items")
MATH lbText(id, "in the list box below:")
MATH lbAddList(id, "A,B,C,D,E")
MATH lbShow(id)

The example above creates a list box window containing two lines of text above the list box.
Compatibility: Requires V7.20 SP1 or later
See Also:

lbUnSel

Purpose:

Remove initial selection of item (by name).

"lbUnSel" is useful only when re-using an existing list box window and changing the set of initially highlighted list box items.
Quick Proto: lbUnSel(ID, item name)
Result Type: Numeric (or Void): 1 on success, 0 on error.
Argument Type:

Numeric, String

  1. The 1st argument is the list box ID.
  2. The 2nd argument is the name of the list box item to initially deselect when the list box window is displayed.

Example:

MATH id = lbNew("lbSel Example")
MATH lbAddList(id, "A,B,C,D,E")
MATH lbSel(id, "C")
MATH lbShow(id)
...
MATH lbUnSel(id, "C")
MATH lbSel(id, "D")
MATH lbShow(id)

The example above creates a new list box window, configures the list box to contain 5 items ("A", "B", "C", "D", and "E"), selects the 3rd item ("C") to be initially highlighted when the window is displayed, and displays the window. The list box window is then reconfigured so that "D" is initially highlighted instead of "C".
Compatibility: Requires V7.20 SP1 or later
See Also: lbUnSelX

lbUnSelX

Purpose:

Remove initial selection of item (by index).

"lbUnSelX" is useful only when re-using an existing list box window and changing the set of initially highlighted list box items.
Quick Proto: lbUnSelX(ID, item index)
Result Type: Numeric (or Void): 1 on success, 0 on error.
Argument Type:

Numeric, String

  1. The 1st argument is the list box ID.
  2. The 2nd argument is the index of the list box item to initially deselect when the list box window is displayed.

Example:

MATH id = lbNew("lbSel Example")
MATH lbAddList(id, "A,B,C,D,E")
MATH lbSelX(id, 3)
MATH lbShow(id)
...
MATH lbUnSelX(id, 3)
MATH lbSelX(id, 4)
MATH lbShow(id)

The example above creates a new list box window, configures the list box to contain 5 items ("A", "B", "C", "D", and "E"), selects the 3rd item ("C") to be initially highlighted when the window is displayed, and displays the window. The list box window is then reconfigured so that the 4th item ("D") is initially highlighted instead of the 3rd item ("C").
Compatibility: Requires V7.20 SP1 or later.
See Also: lbUnSel

Examples

The procedure example below produces the following list box. The user is then asked to confirm their selection, and the procedure repeats in a DO/UNTIL loop until their choice is confirmed.

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON

# Create a new list box window.
  1.001  MATH         id = LBNEW("Choose your Favorite Color")
# Add text lines to the list box window.
  1.002  MATH         LBTEXT(id, "Choose your favorite color from the")
  1.003  MATH         LBTEXT(id, "choices below:")
# Configure the list box window to:
#   1) Display OK and Cancel buttons instead of Advance and Terminate.
#   2) Require the user to make a list box selection.
#   3) Show list box items in sorted order instead of the order added.
  1.004  MATH         LBCONF(id, "+ok, +selreq, +sort")
# Add a comma-separated list of colors to the available choices.
  1.005  MATH         LBADDLIST(id, "Red,Yellow,Blue")
# Add individual colors to the list of available choices.
  1.006  MATH         LBADD(id, "Purple")
  1.007  MATH         LBADD(id, "Orange")
  1.008  MATH         LBADD(id, "Green")

# Repeat the list box selection until the correct color is confirmed.
  1.009  DO
# Display the list box window.
  1.010  MATH         LBSHOW(id)
# Get the name of the selected list box item.
  1.011  MATH         Selection = LBGETSEL(id, 1)
# Display the selected color and request confirmation.
  1.012  OPBR         -z You selected [V Selection] as your favorite color.
  1.012  OPBR
  1.012  OPBR         Is this correct?
  1.013  UNTIL        MEM1

# Store the selection in an appropriately named variable for later use.
  1.014  MATH         FavoriteColor = Selection
  1.015  END


MATH FSC Numeric Conversion Functions

CTOI | ASCII character to decimal equivalent
DBMTOV | dBm to volts (RMS)
DBMTOW | dBm to watts
DBTOPCTV | dB to percentage (voltage ratio)
DBTOPCTV_D | dB to percentage (voltage ratio delta)
DBTOPCTW | dB to percentage (power ratio)
DBTOPCTW_D | dB to percentage (power ratio delta)
DEG | radians to degrees
DEGC | degrees F to degrees C
DEGF | degrees C to degrees F
NUM | extract 1st numeric value from string
NUMN | extract n-th numeric value from string
PCTTODBV | percentage to dB (voltage ratio)
PCTTODBV_D | percentage to dB (voltage ratio delta)
PCTTODBW | percentage to dB (power ratio)
PCTTODBW_D | percentage to dB (power ratio delta)
RAD | degrees to radians
VTODBM | volts RMS to dBm
WTODBM | watts to dBm

CTOI

Purpose: | Converts an ASCII character to its decimal equivalent.
Result Type: | Numeric
Argument Type: | String If the string argument is a multi-character string, CTOI converts only the first character.
Compatibility: | Requires V6.11b or later.
Example: | MATH MEM = CTOI("x") After the above assignment takes place, the value of MEM will be 120, because 120 is the decimal equivalent of the ASCII character lower-case 'x'.

DBMTOV

Purpose: Converts from dBm to volts (RMS).
Note: The conversion is correct for sine waves only.
Result Type: Numeric (Vrms)
Argument Type:

Numeric (dBm), Numeric (ohms)

  1. The first argument is the dBm value to be converted.
  2. The second argument is the reference impedance (ohms).
Compatibility: Requires V6.11i or later.
Example:

MATH MEM = DBMTOV(10.0, 600.0)

In this example DBMTOV will return the Vrms equivalent to 10 dBm at 600 ohms.

DBMTOW

Purpose: | Converts from dBm to watts.
Result Type: | Numeric (W)
Argument Type: | Numeric (dBm) The argument is the dBm value to be converted.
Compatibility: | Requires V7.01f or later.
Example: | MATH MEM = DBMTOW(0.1) In this example DBMTOW will return the watts equivalent to 0.1.

DBTOPCTV

Purpose: | Converts voltage ratio in dB to percentage. The formula used to perform the conversion is: p = 100 * (10 ^ (d/20)) where "d" is the dB value, and "p" is the calculated equivalent percentage.
Result Type: | Numeric (%)
Argument Type: | Numeric (dB) The argument is the dB value to be converted.
Compatibility: | Requires V7.11h or later.
Example: | MATH MEM = DBTOPCTV(-5) In this example DBTOPCTV will return the percentage equivalent to a -5 dB voltage ratio (approximately 56.2341%).
See Also: | DBTOPCTV_D

DBTOPCTV_D

Purpose:

Converts voltage ratio delta in dB to percentage.

The formula used to perform the conversion is:

p = 100 * ((10 ^ (d/20)) - 1)

where "d" is the dB delta, and "p" is the calculated equivalent percentage change.

Result Type: Numeric (%)
Argument Type:

Numeric (dB)

The argument is the dB delta value to be converted.

Compatibility: Requires V7.20 SP1 or later.
Example:

Suppose you wish to determine the output voltage of a 3 dB attenuator as a percentage of the input voltage. Because the voltage is being attenuated, a negative dB value must be specified.

MATH pct = DBTOPCTV_D(-3)

In this example DBTOPCTV_D will return approximately 29.21 %, indicating that the output voltage of the attenuator is 70.79 % of the input voltage (100% - 29.21%).

See Also: DBTOPCTV

DBTOPCTW

Purpose: | Converts power ratio in dB to percentage. The formula used to perform the conversion is: p = 100 * (10 ^ (d/10)) where "d" is the dB value, and "p" is the calculated equivalent percentage change.
Result Type: | Numeric (%)
Argument Type: | Numeric (dB) The argument is the dB value to be converted.
Compatibility: | Requires V7.11h or later.
Example: | MATH MEM = DBTOPCTW(-5) In this example DBTOPCTW will return the percentage equivalent to a -5 dB power ratio (approximately 31.6228%).

DBTOPCTW_D

Purpose: | Converts power ratio delta in dB to percentage. The formula used to perform the conversion is: p = 100 * ((10 ^ (d/10)) - 1) where "d" is the dB delta, and "p" is the calculated equivalent percentage change.
Result Type: | Numeric (%)
Argument Type: | Numeric (dB) The argument is the dB delta value to be converted.
Compatibility: | Requires V7.20 SP1 or later.
See Also: | DBTOPCTW

DEG

Purpose: | Converts from radians to degrees.
Result Type: | Numeric (degrees)
Argument Type: | Numeric (radians)
Example: | MATH MEM = DEG(3.141592653589) The value of MEM in the example will be 180 because 180 degrees is equivalent to PI radians.

DEGC

Purpose: | Converts from degrees F to degrees C.
Result Type: | Numeric (degrees Celsius)
Argument Type: | Numeric (degrees Fahrenheit)
Example: | MATH M[1] = DEGC(MEM)

DEGF

Purpose: | Converts from degrees C to degrees F.
Result Type: | Numeric (degrees Fahrenheit)
Argument Type: | Numeric (degrees Celsius)
Example: | MATH M[1] = DEGF(MEM)

NUM

Purpose:

NUM extract the 1st numeric value from a string.

The embedded numeric value maybe:

  1. NR1 (for example, "5"),
  2. NR2 (for example, "3.97"), or
  3. NR3 (for example, "23.3E-3")
Quick Proto: val = NUM(string)
Result Type:

numeric

The return value is the first embedded numeric value in the string.

Argument Type:

string

The argument is a string containing at least one embedded numeric value.

Example:

MATH v = NUM("abc1.2def")

The call to NUM above assigns the value 1.2 to the variable "v".

Error Handling: If the string does not contain any embedded numeric values an error message is generated and the return value is zero.
Compatibility: Requires V7.20u or later.
See Also: NUMN

NUMN

Purpose:

NUMN extracts the n-th embedded numeric value from a string.

The embedded numeric values maybe:

  1. NR1 (for example, "5"),
  2. NR2 (for example, "3.97"), or
  3. NR3 (for example, "23.3E-3")

As a special case, NUMN counts the number of embedded numeric values in the string when the second argument is zero.

Quick Proto: val = NUMN(string, n)
Result Type:

numeric

If n is greater than zero the return value is the n-th embedded numeric value in the string. If n is zero the return value is the count of discrete numeric values in the string. Argument Type:

string, numeric

  1. The first argument is the string containing at least n embedded numeric values.
  2. The second argument is either:
    1. the position index (ordinal number) of the numeric value to extract, or
    2. zero (when using NUMN to count the numeric values).
Examples:

MATH v = NUMN("abc1.2def3.4ghi5.6jkl", 2)

The call to NUMN above assigns the value 3.4 to the variable "v" because 3.4 is the 2nd embedded numeric value in the string.

MATH v = NUMN("abc1.2def3.4ghi5.6jkl", 0)

The call to NUMN above assigns the value 3 to the variable "v" because the string contains 3 embedded numeric values (namely 1.2, 3.4, and 5.6).

Error Handling: If the string does not contain at least n embedded numeric values an error message is generated and the return value is zero.
Compatibility: Requires V7.20u or later.
See Also: NUM

PCTTODBV

Purpose: | Converts voltage ratio in % to dB. The formula used to perform the conversion is: d = 20 * LOG10(p/100) where "d" is the dB value, and "p" is the calculated equivalent percentage.
Result Type: | Numeric (dB)
Argument Type: | Numeric (%) The argument is the percentage value to be converted.
Compatibility: | Requires V7.11h or later.
Example: | MATH MEM = PCTTODBV(56.2341) In this example PCTTODBV will return the dB equivalent to a 56.2341% voltage ratio (approximately -5 dB).
See Also: | PCTTODBV_D

PCTTODBV_D

Purpose: | Converts voltage ratio delta in % to dB. The formula used to perform the conversion is: d = 20 * LOG10(1 + (p/100)) where "d" is the dB delta, and "p" is the calculated equivalent percentage change.
Result Type: | Numeric (dB)
Argument Type: | Numeric (%) The argument is the percentage delta value to be converted.
Compatibility: | Requires V7.20 SP1 or later.
Example: | Suppose the output voltage of an amplifier is 25% greater than the input voltage. MATH dB = PCTTODBV_D(25) In this example PCTTODBV_D will return approximately 1.94 dB, indicating that the amplifier produces a 1.94 dB gain.
See Also: | PCTTODBV

PCTTODBW

Purpose: | Converts power ratio in % to dB. The formula used to perform the conversion is: d = 10 * LOG10(p/100) where "d" is the dB value, and "p" is the calculated equivalent percentage.
Result Type: | Numeric (dB)
Argument Type: | Numeric (%) The argument is the percentage value to be converted.
Compatibility: | Requires V7.11h or later.
Example: | MATH MEM = PCTTODBW(31.6228) In this example PCTTODBW will return the dB equivalent to a 31.6228% power ratio (approximately -5 dB).
See Also: | PCTTODBW_D

PCTTODBW_D

Purpose: | Converts power ratio delta in % to dB. The formula used to perform the conversion is: d = 10 * LOG10(1 + (p/100)) where "d" is the dB delta, and "p" is the calculated equivalent percentage change.
Result Type: | Numeric (dB)
Argument Type: | Numeric (%) The argument is the percentage delta value to be converted.
Compatibility: | Requires V7.20 SP1 or later.
Example: | Suppose the output power of an attenuator is 40% less than the input power. MATH dB = PCTTODBW_D(40) In this example PCTTODBW_D will return approximately 1.46 dB, indicating that the attenuator produces a 1.46 dB power loss.
See Also: | PCTTODBW

RAD

Purpose: | Converts from degrees to radians.
Result Type: | Numeric (radians)
Argument Type: | Numeric (degrees)
Example: | MATH MEM = DEG(180.0) (The value of MEM in the example will be 3.141592653589 because PI radians is equivalent to 180 degrees.)

VTODBM

Purpose: Converts from volts RMS to dBm.
Note: The conversion is correct for sine waves only.
Result Type: Numeric (dBm)
Argument Type:

Numeric (Vrms), Numeric (ohms)

  1. The first argument is the RMS voltage value to be converted.
  2. The second argument is the reference impedance (ohms).
Compatibility: Requires V6.11i or later.
Example:

MATH MEM = VTODBM(100.0, 50.0)

In this example VTODBM will return the dBm value equivalent to 100 V at 50 ohms.

WTODBM

Purpose: | Converts from watts to dBm.
Quick Proto: | dBm = WTODBM(watts)
Result Type: | Numeric (dBm) The return value is the dBm equivalent of the watts value passed as an argument to WTODBM.
Argument Type: | Numeric (W) The argument is the power value, in watts, to be converted to dBm.
Compatibility: | Requires V7.01f or later.
Example: | MATH MEM = WTODBM(2.0) In this example WTODBM will return the dBm value equivalent to 2 W.


MATH FSC Slew Functions

SLEW | invoke slew dialog
SLEWINIT | initialize slew dialog
SLEWMSG | specify messages for slew dialog
SLEWOP | get last slew operation
SLEWSCALE | specify scale factor for slew dialog
SLEWSTART | specify highlighted digit for slew dialog

SLEW

Purpose:

SLEW is the main function in a family of functions used to display

MET/CAL's slew dialog for use with user-configured reference instruments. SLEW cannot be used as a standalone function. It must be used in conjunction with other slew-related functions to configure and control the slew dialog. The following outline shows the required method of using the slew functions:

  1. Set up slew dialog by specifying messages, scale factor, and highlighted digit.
  2. Initialize slew dialog.
  3. Begin slew loop.
  4. Call SLEW to display slew dialog.
  5. Call SLEWOP to get op code from slew dialog.
  6. End slew loop.

Deviation from the general approach shown in the outline above may lead to unexpected or confusing procedure behavior.

Quick Proto: NewVal = SLEW(Val, NDR)
Result Type:

Numeric

The return value is the new value to which the user has slewed.

Argument Type:

Numeric, Numeric

  1. The first argument is the value to be slewed.
  2. The second argument specifies the number of digits to the right of the decimal point to be displayed in the value being slewed.
Compatibility: Requires V7.20 or later.
See Also: SLEWINIT, SLEWMSG, SLEWOP, SLEWSCALE,
Example:

  1.001  MATH         SLEWSTART(2)
  1.002  MATH         SLEWSCALE(1)
  1.003  MATH         Msg = "Adjust Stimulus for a UUT Reading of 1 V"
  1.004  MATH         SLEWMSG(0, Msg)
  1.005  MATH         SLEWMSG(1, "")
  1.006  MATH         SLEWMSG(2, "V")
  1.007  MATH         SLEWMSG(3, "")
  1.008  MATH         SLEWINIT()
  1.009  MATH         val = 1.2345

  1.010  DO
  1.011  MATH         val = SLEW(val, 4)
  1.012  MATH         op = SLEWOP()

  1.013  IF           (op == -1) || (op == 1)
# <Add Code Here to Program the
# User-Configured Reference with
# the New Value>
  1.014  ENDIF

  1.015  UNTIL        (op == 0) || (op == 2) || (op == 3)

In the example the initially highlighted digit in the slew value will be '3', because the call to SLEWSTART sets the index to 2. The scale factor is set to 1, indicating that the slew value is to be left unscaled.

The units of the slew value are volts ("V"), and the message "Adjust Stimulus for a UUT Reading of 1 V" will appear at the top of the slew dialog. The starting slew value is set to 1.2345. The DO ... UNTIL loop includes calls to SLEW and SLEWOP, and continues until the operator chooses "Advance" (0), chooses "Terminate" (2), or an error occurs (3).

The IF ... ENDIF section inside the DO ... UNTIL loop is used to handle the cases where the operator increments or decrements the slew value, but does not choose "Advance" or "Terminate" in the slew dialog. When the value is modified the procedure writer must construct an appropriate command for the user-configured reference instrument and send the command to the instrument using an IEEE, IEEE2, SCPI, or PORT statement in the procedure. This part of the procedure is specific to the particular reference instrument being used, and is therefore not shown in the example above.

The 3 comments in the example should be replaced with the appropriate instrument command to program the instrument to the slewed-to value.

SLEWINIT

Purpose: | Initializes the slew dialog. Values and strings specified using SLEWSTART, SLEWSCALE, and SLEWMSG are passed to the internal slew dialog function in preparation for displaying the slew dialog. The call to SLEWINIT should appear after the calls to SLEWSTART, SLEWSCALE, and SLEWMSG, but before the slew loop where SLEW and SLEWOP are called.
Quick Proto: | SLEWINIT()
Result Type: | Numeric The return value is always 1 and can be ignored.
Compatibility: | Requires V7.20 or later.
See Also: | SLEW, SLEWMSG, SLEWOP, SLEWSCALE, SLEWSTART
Example: | See function SLEW for an example which illustrates the use of SLEWINIT.

SLEWMSG

Purpose:

Specify message lines for the slew dialog.

The messages appear at the top of the slew dialog, or in the area on the right side of the slew dialog, above the Advance and Terminate buttons.

Quick Proto: SLEWMSG(MessageNumber, Message)
Result Type:

Numeric (or void)

The return value is 0 or 1. Zero indicates that the message number was invalid, or some other internal error occurred.

Argument Type:

Numeric, String

The first argument is the message number.

The number must be 0, 1, 2, or 3.

Message number 0 appears at the top of the slew dialog. Messages 1, 2, and 3 appear on 3 lines on the right side of the dialog, above the Advance and Terminate buttons.

Compatibility: Requires V7.20 or later.
See Also: SLEW, SLEWINIT, SLEWOP, SLEWSCALE, SLEWSTART
Example:

  1.001 MATH Msg = "Adjust Stimulus for a UUT Reading of 1 V"
  1.002 MATH SLEWMSG(0, Msg)
  1.003 MATH SLEWMSG(1, "")
  1.004 MATH SLEWMSG(2, "V")
  1.005 MATH SLEWMSG(3, "")

The first message ("Adjust Stimulus for a UUT Reading of 1 V") will appear at the top of the slew dialog. Messages 1 and 3 are empty. Message 2 specifies the units of the value being slewed, and appear on the middle line of the message area on the right side of the slew dialog.

SLEWOP

Purpose:

Retrieves the result of the last slew operation.

SLEWOP should be called in the procedure slew loop, immediately after the call to SLEW.

Quick Proto: op = SLEWOP()
Result Type:

Numeric

The following return values are defined:

  • -1 value decremented
  • 0 operator chose Advance
  • +1 value incremented
  • +2 operator chose Terminate
  • +3 error
Argument Type: None
Compatibility: Requires V7.20 or later.
See Also: SLEW, SLEWINIT, SLEWMSG, SLEWSCALE, SLEWSTART
Example: See function SLEW for an example which illustrates the use of SLEWOP.

SLEWSCALE

Purpose: | Specifies a scale factor applied to the value displayed in the slew dialog. The scale factor is used as a divisor applied to the slew value.
Quick Proto: | SLEWSCALE(ScaleFactor)
Result Type: | Numeric (or void) The return value is always 1.
Argument Type: | Numeric. The argument specifies the scale factor.
Compatibility: | Requires V7.20 or later.
See Also: | SLEW, SLEWINIT, SLEWMSG, SLEWOP, SLEWSTART
Example: | Suppose the value to be slewed is specified as "1.2345". Setting the scale factor as follows: MATH SLEWSCALE(0.1) will cause the value displayed in the slew dialog to be "12.3450".

SLEWSTART

Purpose: | Specifies the initially highlighted digit for the slew dialog.
Quick Proto: | SLEWSTART(index)
Result Type: | Numeric (0 or 1) (or void). A zero return value indicates that the specified position index is not valid.
Argument Type: | Numeric The argument specifies the position index in the slew value of the highlighted digit. To highlight a digit to the right of the decimal point, specify an index between +1 and +11. To highlight a digit to the left of the decimal point, specify an index between -1 and -8. Compatibility: Requires V7.20 or later.
See Also: | SLEW, SLEWINIT, SLEWMSG, SLEWOP, SLEWSCALE
Example: | SLEWSTART(3) If the value to be slewed is "1.98765", the highlighted digit will be the '7', because it's the 3rd digit to the right of the decimal point.


MATH FSC String Functions

CMP | case-sensitive string comparison, returns -1 or 1
CMPI | case-insensitive version of CMP
CSV | convert M-registers to CSV list
CSV_L | convert L-registers to CSV list
DEL | delete named variable
EMPTY | determine if string variable is empty or null
FIND | index of n-th occurrence of specified substring
FINDI | case-insensitive version of FIND
FLD | extract specified field
FMT | format number
ISVAR | determine if named variable exists
IS_NUM | determine if string is a single number
IS_NUM_LEAD | determine if string begins with a number
IS_NUM_SUB | determine if string contains embedded number
ITOC | convert decimal integer to ASCII equivalent
LEN | return string length
NULL | determine if string variable is null
PAD | append spaces to make string specified length
PADB | prepend spaces to make string specified length
REPL | replace substring with specified string
STRIP | strip leading and trailing spaces from string
STRIPL | strip leading spaces from string
STRIPT | strip trailing spaces from string
SUB | substring of specified length starting at index
ZCMP | case-sensitive string comparison, returns 0 or 1
ZCMPI | case-insensitive version of ZCMP

CMP, CMPI

Purpose:

String comparison.

  • CMP is case-sensitive.
  • CMPI is case-insensitive.

May be used in conjunction with JMPF.
Result Type:

Numeric

The return value is 1 if the strings are the same. The return value is -1 if the strings are different.
Argument Type:

String, String

  1. Argument #1 is the 1st comparison string.
  2. Argument #2 is the 2nd comparison string.
Example 1:

  1.001  IEEE2        *TST?[I$]
  1.002  MATH         MEM1 = CMP(MEM2, "0")
Example 2:

  1.001  IEEE2        *IDN?[I$]
  1.002  MATH         S[1] = FLD(MEM2, 2, ",")
  1.003  MATH         MEM1 = CMPI(MEM2, "8508A")
See Also ZCMP, ZCMPI

CSV

Purpose: Convert a specified range of M-registers into a string containing a comma-separated list of values.
Quick Proto: csv_list = CSV(index1, index2)
Result Type:

String

The result is a string containing a comma-separated list of the values in the specified registers.
Error Handling If one or both of the specified M-register indices are out of range an error message is generated.
Argument Type:

Numeric, Numeric

  1. The first argument is the first register index. The index must be between 1 and 255.
  2. The second argument is the second register index. The index must be between 1 and 255.
Compatibility: Requires 7.20B or later.
See Also: CSV_L
Example:

  1.001  MATH         M[3] = 1.2
  1.002  MATH         M[4] = 2.7
  1.003  MATH         M[5] = 8.2
  1.004  MATH         list = CSV(3, 5)

The return value from the call to "CSV" in this example is the string "1.2,2.7,8.2".
Usage:

Conversion of double-precision floating-point M-register values to string form is performed with a format the preserves up to 15 decimal digits. Function FRND may be used prior to the call to CSV if rounding is required.

Trailing zeros are not preserved in the formatted values.

If the first index is larger than the second index CSV places the values in the list in reverse order.

CSV_L

Purpose: Convert a specified range of L-registers into a string containing a comma-separated list of values.
Quick Proto: csv_l = CSV_L(index1, index2)
Result Type:

String

The result is a string containing a comma-separated list of the values in the specified registers.
Error Handling If one or both of the specified L-register indices are out of range an error message is generated.
Argument Type:

Numeric, Numeric

  1. The first argument is the first register index. The index must be between 1 and 32.
  2. The second argument is the second register index. The index must be between 1 and 32.
Compatibility: Requires 7.20B or later.
See Also: CSV
Example:

  1.001  MATH         L[3] = 1.2
  1.002  MATH         L[4] = 2.7
  1.003  MATH         L[5] = 8.2
  1.004  MATH         list = CSV_L(3, 5)

The return value from the call to "CSV_L" in this example is the string "1.2,2.7,8.2".
Usage:

Conversion of double-precision floating-point L-register values to string form is performed with a format the preserves up to 15 decimal digits. Function FRND may be used prior to the call to CSV_L if rounding is required.

Trailing zeros are not preserved in the formatted values.

If the first index is larger than the second index CSV_L places the values in the list in reverse order.

DEL

Purpose: Deletes a named variable.
Result Type:

String (or void)

DEL returns the value of the variable being deleted. In normal usage, however, the return value of DEL will be ignored (as illustrated in the examples below).
Argument Type:

String

The argument is the name of the variable to be deleted. Usually the name should be specified as a literal string.
Compatibility: Requires V7.20 or later.
Example 1:

  1.001  MATH         x = 5
  1.002  MATH         DEL("x")

The call to DEL remove the variable named "x".
Example 2:

  1.001  MATH         y = "x"
  1.002  MATH         x = 5
  1.003  MATH         DEL(y)

The call to DEL in this example also removes the variable named "x", as in Example 1. This is because the value of the variable named "y" is "x". In order to remove the variable named "y", use:

1.003 MATH DEL("y")

Usage:

DEL has limited utility. In general there is no need to delete named variables. Possible reasons for removing named variables are:

  1. To remove variables which are no longer used from the Test Run S-Reg window.
  2. To prevent subsequent access to a variable after it is no longer needed. For example:

  1.001  MATH         x = 5
  1.002  MATH         DEL("x")
  1.003  MATH         y = x + 10

In this example a run time error will occur when the 3rd MATH statement is executed. This is because the variable "x" no longer exists.

DEL may be used only with "named variables". You cannot use DEL to delete an 'S', 'M', or 'L' register. You also cannot use DEL to delete MEM, MEM1, MEM2, or a variable cache variable.

EMPTY

Purpose: EMPTY tests a string variable to determine if the value is an empty string or null. The function must be used on a previously defined variable. If the variable has not been created this method will generate an error and the procedure will terminate.
Result Type:

Numeric

  • EMPTY returns 1 if the value of the specified string variable is empty or null.
  • Empty returns 0 if the value of the specified string variable is neither empty nor null.
Argument Type:

String

The argument is a string variable, or string-valued expression.
Compatibility: Requires V7.20 or later.
See Also: NULL, ISVAR
Example 1:

  1.001  MATH         abc = ""

  1.002  IF           EMPTY(abc)
  1.003  DISP         "abc" is empty
  1.004  ENDIF

In this example the DISP statement will execute and print:

"abc" is empty

because the assignment in the MATH statement explicitly assigns an empty string as the value of named variable "abc".
Example 2:

  1.001  IEEE         *OPT?[I$]

  1.002  IF           EMPTY(MEM2)
  1.003  RSLT         =No UUT options are installed.
  1.004  ELSE
  1.005  RSLT         =Installed options: [MEM2]
  1.006  ENDIF

This example queries a UUT for installed options. If the UUT response contains nothing (i.e. an empty string), the IF condition in step 1.002 evaluates to TRUE, which uses the RSLT FSC to write "No UUT options are installed" to the results in step 1.003.

Otherwise, the ELSE condition executes and step 1.005 writes the list of installed options to the results.
Usage:

An empty string is a string which exists but has zero length. Null strings are not quite the same. Examples of null strings are:

  1. An 'S' register value before any assignment to the register has been made.
  2. The return value of certain string-based functions when an error or lookup failure occurs. (For example, if you call RIF and the parameter you are looking for does not exist in the fill, RIF returns a NULL string as its return value.)

In most cases procedure writers do not have to be concerned about the distinction between empty strings and null strings.

Function EMPTY hides the distinction between empty strings and null strings, because it returns 1 in either case.

FIND, FINDI

Purpose:

Returns the index of the n-th occurrence of a specified substring in a specified string.

  • FIND is case-sensitive.
  • FINDI is case-insensitive.
Quick Proto 1: Index = FIND(str, substr, occurrence#)
Quick Proto 2: Count = FIND(str, substr, 0)
Result Type:

Numeric

The return value is the 1-based index in the string of the specified occurrence of the substring. If the specified occurrence is not found the return value is zero. If FIND is called with the occurrence number set to 0, the return value is the number of occurrences of the specified substring in the specified string.
Arguments:

String, String, Numeric

  1. Argument #1 is the string to be searched.
  2. Argument #2 is the substring for which to search.
  3. Argument #3 is the number of the desired occurrence.
Example 1:

  1.001  MATH         S[5] = "abcABCabc"
  1.002  MATH         MEM = FIND(S[5], "abc", 2)

After the second math statement is executed the value of MEM will be 7, since 7 is the index of the beginning of the second occurrence of "abc".
Example 2:

1.001 MATH MEM = FIND("abcdef", "z", 1)

Since "z" does not occur in "abcdef", MEM will be set to zero.
Example 3:

1.001 MATH MEM = FIND("a,b,c,d", ",", 0)

Since the 3rd argument is zero, MEM will be set to 3, because there are 3 commas in "a,b,c,d".
Example 4:

  1.001  MATH         S[5] = "abcABCabc"
  1.002  MATH         MEM = FINDI(S[5], "ABC", 2)

After the second math statement is executed the value of MEM will be 4, since 4 is the index of the beginning of the second occurrence of "ABC" (case-insensitive).
Compatibility: FINDI Requires V6.01 or later.

FLD

Purpose:

Extracts a specified field from a string.

  1. The first argument is the string from which the field is to be extracted.
  2. The second argument specifies which field to extract.(The first field is number 1.)
  3. The third argument is a string which specifies the field separator.
Result Type: String
Argument Type: String, Numeric, String
Example 1:

  1.001  MATH         S[1] = "FLUKE,5500A,6320007,NONE+1.2"
  1.002  MATH         MEM2 = FLD(S[1], 2, ",")

After this statement executes the value of MEM2 will be "5500A".
Example 2:

# Setup RS232-communication
  1.001  PORT         [P1200,N,8,1,X]
# Enable the SERVICE-mode of the ScopeMeter test tool.
  1.002  PORT         EX110,0[13][I]
  1.003  PORT         FLUKPHIL[13][I]
# Query Scopemeter Cal Fields; returns Total Cal Fields
  1.004  PORT         QN[13][I][I$]
# Extract field two from the string of comma-separated values.
  1.005  MATH         MEM = FLD(MEM2, 2, ",")
  1.006  DISP         Field Two: "[MEM]"

FMT

Purpose:

Formats a number. Format specifiers have the form:

%width.precisioncode

width is the minimum number of characters.

  • If the value to be printed is shorter than this number, the result is padded with blank spaces.
  • The value is not truncated even if the result is larger.

precision is the precision of the result.

  • For floating point numbers (codes 'e' and 'f'), this is the number of digits after the decimal point (6, by default).
  • For code 'g', this is the maximum number of significant digits. This will impact not just the value after the decimal place but the entire number.
  • If the number provided has more precision than is given, it will round.

code is 'f', 'e', or 'g':

  • 'e' - floating point number using scientific notation.
  • 'f' - floating point number using decimal representation.
  • 'g' - general; uses 'f' or 'e', whichever is more compact.
Result Type: String
Argument Type: Numeric, String
Example 1:

1.001 MATH MEM2 = FMT(1.234567, "%4.2f")

After this statement executes the value of MEM2 will be "1.23".
Example 2:

1.007 MATH MEM2 = FMT(93000000.0, "%g")

After this statement executes the value of MEM2 will be "9.3E+007".
Example 3:

  1.001  MATH         pi = 3.14159265359
  1.002  MATH         e = FMT(pi, "%.5e")
  1.003  MATH         f = FMT(pi, "%.5f")
  1.004  MATH         g = FMT(pi, "%.5g")

After these statements execute, the values will be:

e = "3.14159E+000"

f = "3.14159"

g = "3.1416"

IS_NUM

Purpose:

Determines if a string is entirely numeric.

  • The return value is 1 if the string is entirely numeric.
  • Otherwise the return value is 0.
Result Type: Numeric
Argument Type: String
Compatibility: Requires V7.10b or later.

Examples:

The examples in the group below show strings which are entirely numeric (so IS_NUM will return 1).

1.001 MATH L[1] = IS_NUM("3.2e+5")

1.002 MATH L[1] = IS_NUM("3.2")

1.003 MATH L[1] = IS_NUM(".2e+5")

1.004 MATH L[1] = IS_NUM("3")

The examples in the group below show strings which are not entirely numeric (so IS_NUM will return 0).

1.005 MATH L[1] = IS_NUM("3.2e+5x")

1.006 MATH L[1] = IS_NUM(" 5")

1.007 MATH L[1] = IS_NUM("3.2 ")

1.008 MATH L[1] = IS_NUM("a23")

1.009 MATH L[1] = IS_NUM("")

IS_NUM_LEAD

Purpose:

Determines if a string begins with a number. The return value is 1 if the string begins with a number. Otherwise the return value is 0.

Note: Leading spaces are non-numeric characters. A string which begins with one or more spaces will cause IS_NUM_LEAD to return 0.
Result Type: Numeric
Argument Type: String
Compatibility: Requires V7.10b or later.
Examples:

The examples in the group below show strings which begin with a number (so IS_NUM_LEAD will return 1).

1.001 MATH L[1] = IS_NUM_LEAD("3.2e+5 mV")

1.002 MATH L[1] = IS_NUM_LEAD("3.2x")

1.003 MATH L[1] = IS_NUM_LEAD(".2e+5,3.5e-4")

1.004 MATH L[1] = IS_NUM_LEAD("3")

The examples in the group below show strings which do not begin with a number (so IS_NUM_LEAD will return 0).

1.005 MATH L[1] = IS_NUM_LEAD(" 3.2e+5")

1.006 MATH L[1] = IS_NUM_LEAD("x5")

1.007 MATH L[1] = IS_NUM_LEAD("voltage=3.2 ")

1.008 MATH L[1] = IS_NUM_LEAD("a23.7")

1.009 MATH L[1] = IS_NUM_LEAD("")

IS_NUM_SUB

Purpose:

Determines if a string contains an embedded number.

  • The return value is 1 if the string contains an embedded number.
  • Otherwise the return value is 0. (Any string which includes at least one digit is considered to contain an embedded number.)
Result Type: Numeric
Argument Type: String
Compatibility: Requires V7.10b or later.
Examples

The examples in the group below show strings which contain an embedded number (so IS_NUM_SUB will return 1).

1.001 MATH L[1] = IS_NUM_SUB("3.2e+5 mV")

1.002 MATH L[1] = IS_NUM_SUB(":3.2xyz")

1.003 MATH L[1] = IS_NUM_SUB("Fluke 5700A")

1.004 MATH L[1] = IS_NUM_SUB("3,4,5,6")

The examples in the group below show strings which do not contain an embedded number (so IS_NUM_SUB will return 0).

1.005 MATH L[1] = IS_NUM_SUB(" ")

1.006 MATH L[1] = IS_NUM_SUB("Fluke")

1.007 MATH L[1] = IS_NUM_SUB("")

ISVAR

Purpose: ISVAR determines if a named variable exists.
Result Type:

Numeric

  • ISVAR returns 1 if the specified variable exists.
  • ISVAR returns 0 if the specified variable does not exist.
Argument Type:

String

The argument is a string variable, or string-valued expression. In general, the argument passed to ISVAR should be a literal string.
Compatibility: Requires V7.20 or later.
See Also: EMPTY, NULL
Usage 1:

Example:

  1.001  MATH         x = 3

  1.002  IF           ISVAR("x")
  1.003  DISP         "x" exists
  1.004  ENDIF

  1.005  IF           ISVAR("y")
  1.006  DISP         "y" exists
  1.007  ENDIF

In this example the first DISP statement will execute and print:

"x" exists because when the assignment "x = 3" was executed the variable "x" was created.

The second DISP statement will not execute because no assignment to "y" has been made, so "y" does not exist.
Usage 2:

ISVAR is used only with "named variables". It is not used with any of the following:

  • 'L' registers
  • 'M' registers
  • 'S' registers
  • MEM
  • MEM1
  • MEM2
  • variable cache variables
  • variable file variables

A named variable does not exist if:

  1. It has never been assigned to, or
  2. It has been assigned to, but was subsequently removed using the DEL function.

It is important to remember that the argument passed to ISVAR is a variable name. ISVAR("x") is not the same as ISVAR(x).

Consider what happens if you do this:

  1.001  MATH         x = "abc"

  1.002  IF           ISVAR(x)
  1.003  DISP         Exists.
  1.004  ELSE
  1.005  DISP         Does not exist.
  1.006  ENDIF

When you run this procedure you will see:

"Does not exist."

The reason is that the value of the variable "x" is "abc". Therefore the call to ISVAR is testing to see if there's a variable named "abc". Since, in the example above, no assigment to "abc" has been made, abc does not exist.

ITOC

Purpose: | Converts a decimal integer to its ASCII character equivalent. ITOC returns an empty string if the specified decimal value is not between 0 and 255. If the specified decimal value is not an integer, ITOC truncates the non-integer portion of the value before performing the conversion.
Result Type: | String
Argument Type: | Numeric
Compatibility: | Requires V6.11b or later.
Example: | MATH MEM2 = ITOC(120) After the above assignment takes place, the value of MEM2 will be "x", because 120 is the decimal equivalent of the ASCII character lower-case 'x'.

LEN

Purpose: | Computes the length of a string.
Result Type: | Numeric
Argument Type: | String
Example: | 1.001 MATH L[1] = LEN(MEM2)

NULL

Purpose: NULL tests a string variable to determine if the value is a null string.
Result Type:

Numeric

NULL returns 1 if the value of the specified string variable is null. NULL returns 0 if the value of the specified string variable is non-NULL.
Argument Type:

String

The argument is a string variable, or string-valued expression.
Compatibility: Requires V7.20 or later.
See Also: EMPTY, ISVAR
Example:

  1.001  IF           NULL(S[1])
  1.002  DISP         S[1] is null
  1.003  ENDIF

In this example the DISP statement will execute and print: S[1] is null because no value has been assigned to S[1].
Usage:

An empty string is a string which exists but has zero length. Null strings are not quite the same.

Examples of null strings are:

  1. An 'S' register value before any assignment to the register has been made.
  2. The return value of certain string-based functions when an error or lookup failure occurs. (For example, if you call RIF and the parameter you are looking for does not exist in the fill, RIF returns a NULL string as its return value.)

In most cases procedure writers do not have to be concerned about the distinction between empty strings and null strings.

Function EMPTY hides the distinction between empty strings and null strings, because it returns 1 in either case. In most cases procedure writers will find that EMPTY is a more useful function than NULL.

PAD

Purpose:

Adds spaces to the end of a string to make the string a specified length.

  1. The 1st argument is the input string.
  2. The 2nd argument is the result string length.

The length cannot be less than 1.

PAD will not shorten a string.

Therefore, if the target length is less than or equal to the length of the initial string the return string will simply be a copy of the original string. If the input string is NULL or empty

PAD simply generates a string containing the specified number of spaces.
Quick Proto: string = PAD(string, length)
Result Type: String
Argument Type: String, Numeric
Compatibility: Requires V7.10b or later.
See Also: PADB
Example:

1.001 MATH S[1] = PAD("abc", 5)

The value of S[1] will be "abc ".

PADB

Purpose:

Adds spaces to the beginning of a string to make the string a specified length.

  1. The 1st argument is the input string.
  2. The 2nd argument is the result string length.

The length cannot be less than 1.

PADB will not shorten a string. Therefore, if the target length is less than or equal to the length of the initial string the return string will simply be a copy of the original string.

If the input string is NULL or empty PADB simply generates a string containing the specified number of spaces.
Quick Proto: string = PAD(string, length)
Result Type: String
Argument Type: String, Numeric
Compatibility: Requires V7.10b or later.
See Also: PAD
Example:

1.001 MATH S[1] = PADB("abc", 5)

The value of S[1] will be " abc".

REPL

Purpose:

Replaces a specified substring with a specified replacement string.

  1. Argument 1 is the substring.
  2. Argument 2 is the replacement string
  3. Argument 3 is the original string.

REPL does not modify the original string.

It makes a copy and performs the indicated replacement in the copy. (If you wish to modify the original string, assign the REPL return value back to the original string.)

If the substring is not found in the original string REPL simply returns the original string. It's an error if any of the input arguments is NULL.

However, empty strings are allowed.
Quick Proto: new str = REPL(sub, repl, orig str)
Argument Type: String, String, String
Result Type: String
Compatibility: V7.10c or later is required.

Example:

  1.001  MATH         S[1] = "voltage = <v> mV"
  1.002  MATH         S[1] = REPL("<v>", "20.0", s[1])

The call above produces the string: voltage = 20.0 mV

STRIP

Purpose: | STRIP strips leading and trailing spaces from a string.
Quick Proto: | str = STRIP(string)
Result Type: | string The return value is a copy of the original string, but with leading and trailing spaces (if any) removed.
Argument Type: | string The argument is the string from which leading and trailing spaces are to be stripped.
Example: | 1.001 MATH s = STRIP(" a b c ") The call to STRIP above assigns the value "a b c" to the variable "s". The 3 leading spaces and the 3 trailing spaces have been removed. The embedded spaces (between 'a' and 'b', and between 'b' and 'c') are still there.
Compatibility: | Requires V7.20u or later.
See Also: | STRIPL, STRIPT

STRIPL

Purpose: | STRIPL strips leading spaces from a string.
Quick Proto: | str = STRIPL(string)
Result Type: | string The return value is a copy of the original string, but with leading spaces (if any) removed.
Argument Type: | string The argument is the string from which leading spaces are to be stripped.
Example: | 1.001 MATH s = STRIPL(" a b c ") The call to STRIPL above assigns the value "a b c " to variable "s". The 3 leading spaces have been removed. The embedded spaces (between 'a' and 'b', and between 'b' and 'c'), and the trailing spaces, are still there.
Compatibility: | Requires V7.20u or later.
See Also: | STRIP, STRIPT

STRIPT

Purpose: | STRIPT strips trailing spaces from a string.
Quick Proto: | str = STRIPT(string)
Result Type: | string The return value is a copy of the original string, but with trailing spaces (if any) removed.
Argument Type: | string The argument is the string from which trailing spaces are to be stripped.
Example: | 1.001 MATH s = STRIPT(" a b c ") The call to STRIPT above assigns the value " a b c" to variable "s". The 3 trailing spaces have been removed. The leading spaces, and the embedded spaces (between a and b, and between b and c), are still there.
Compatibility: | Requires V7.20u or later.
See Also: | STRIP, STRIPL

SUB

Purpose:

Extracts a substring of a specified length starting at a specified index.

  1. The first argument is the string from which the substring is to be extracted.
  2. The second argument is the 1-based starting index of the substring.
  3. The third argument is the length of the substring.
Quick Proto: SUB(string, index, substring length)
Result Type: String
Argument Type: String, Numeric, Numeric
Example:

1.001 MATH MEM2 = SUB("abcdef", 2, 3)

After this statement the value of MEM2 will be "bcd".

ZCMP, ZCMPI

Purpose:

String comparison. ZCMP is the same as CMP except that it returns 0 instead of -1 when the strings are different.

  • ZCMP is case-sensitive
  • ZCMPI is case-insensitive

It is often convenient to use ZCMP or ZCMPI in conjunction with an IF, ELSEIF, WHILE, UNTIL, JMPL or JMPZ.
Quick Proto: ZCMP(String1, String2)
Result Type:

Numeric

The return value is 1 if the two strings are the same, based on a case-sensitive comparison. The return value is 0 if the two strings are not the same, based on a case-sensitive comparison.
Argument Type:

String, String

The first argument is the first string to compare. The second argument is the second string to compare.
Example 1:

  1.001  MATH         S[1] = "ABC"
  1.002  MATH         S[2] = "ABCD"
  1.003  MATH         MEM = ZCMP(S[1], S[2])

In this example, MEM will be set to zero, because the two strings being compared are not the same.
Example 2:

  1.001  MATH         S[1] = "abc"
  1.002  MATH         S[2] = "ABC"
  1.003  MATH         MEM = ZCMPI(S[1], S[2])

In this example, MEM will be set to 1, because the two strings being compared are the same, except for case.


MATH FSC Trigonometry Functions

ACOS | arccosine
ASIN | arcsine
ATAN | arctangent
COS | cosine
COSH | hyperbolic cosine
SIN | sine
SINH | hyperbolic sine
TAN | tangent
TANH | hyperbolic tangent

ACOS

Purpose: | Computes the arccosine of its argument.
Quick Proto: | val = ACOS(rval)
Result Type: | Numeric (radians)
Argument Type: | Numeric (radians)
Example: | MATH M[2] = ACOS(M[1])

ASIN

Purpose: | Computes the arcsine of its argument.
Quick Proto: | val = ASIN(rval)
Result Type: | Numeric (radians)
Error Handling |
Argument Type: | Numeric (radians)
Compatibility: | Requires V8.0 or later
See Also |
Example: | MATH M[2] = ASIN(M[1])

ATAN

Purpose: | Computes the arctangent of its argument.
Quick Proto: | tval = ATAN(rval)
Result Type: | Numeric (radians)
Error Handling |
Argument Type: | Numeric (radians)
Compatibility: | Requires V7.00 or later.
See Also |
Example: | MATH M[2] = ATAN(M[1])

COS

Purpose: | Computes the cosine of its argument.
Result Type: | Numeric (radians)
Argument Type: | Numeric (radians)
Example: | MATH L[1] = COS(MEM)

COSH

Purpose: | Computes the hyperbolic cosine of its argument.
Quick Proto: |
Result Type: | Numeric (radians)
Error Handling |
Argument Type: | Numeric (radians)
Compatibility: | Requires 7.00 or later.
See Also | COS
Example: | MATH L[1] = COSH(MEM)

SIN

Purpose: | Computes the sine of its argument.
Result Type: | Numeric (radians)
Argument Type: | Numeric (radians)
Example: | MATH L[1] = SIN(MEM)

SINH

Purpose: | Computes the hyperbolic sine of its argument.
Result Type: | Numeric (radians)
Argument Type: | Numeric (radians)
Example: | MATH L[1] = SINH(MEM)

TAN

Purpose: | Computes the tangent of its argument.
Result Type: | Numeric (radians)
Argument Type: | Numeric (radians)
Example: | MATH L[1] = TAN(MEM)

TANH

Purpose: | Computes the hyperbolic tangent of its argument.
Result Type: | Numeric (radians)
Argument Type: | Numeric (radians)
Example: | MATH L[1] = TANH(MEM)


MATH FSC Units Functions

BASE | convert dimensioned number to base units
ENGR | convert dimensioned number to engineering units
ENGR_NSD | convert value to engineering units with NSD
IS_DIM | Is string valid dimensioned number?
IS_UNIT | Does dimensioned number have specified units?
PSCALE | get prefix-based scalar from dimensioned number
UNIT | extract units symbol from dimensioned number
UPREFIX | extract units prefix from dimensioned number

The following tables of prefixes and units are supported by the functions in this help topic. Note: the unit codes used by legacy instrument FSCs are not always the same, and therefore may not be supported by these functions.

Prefix |  | Scalar
'Y' | yotta | 1.0E+24
'Z' | zetta | 1.0E+21
'E' | exa | 1.0E+18
'P' | peta | 1.0E+15
'T' | tera | 1.0E+12
'G' | giga | 1.0E+9
'M' | mega | 1.0E+6
'k' | kilo | 1.0E+3
'm' | milli | 1.0E-3
'µ' or 'u' | micro | 1.0E-6
'n' | nano | 1.0E-9
'p' | pico | 1.0E-12
'f' | femto | 1.0E-15
'a' | atto | 1.0E-18
'z' | zepto | 1.0E-21
'y' | yocto | 1.0E-24

Unit | Description
A | ampere
Ap | amps peak
App | amps peak-to-peak
bar | bar
Bq | becquerel
C | coulomb
c | cycles
cd | candela
cmH2O | centimeters of water
count | count
counts | count
dB | decibel
dB/div | decibels per division
dBc/Hz | decibel change per hertz
dBm | dBm
dBmV | dB millivolts
dBuV | dB micovolts
dBmW | dB milliwatts
deg | degree (not a real unit)
degC | degree Celsius
degF | degree Fahrenheit
F | farad
ftH2O | feet of water
g | gram
g/cm2 | grams per centimeter squared
Gy | gray
h | henry
hour | hour
hours | hour
Hz | hertz
Hz/V | hertz per volt
i/Wh | impulses per watt-hour
inH2O | hour
inHg | inches of mercury
IRE | Institute of Radio Engineers
J | joule
K | kelvin
kat | katal
l | liter
lm | lumen
lx | lux
meter | meter
mH2O | meters of water
mHg | meters of mercury
minute | minute
minutes | minute
mol | mole
N | newton
Ohm | ohm
ohm | ohm
Ohms | ohm
ohms | ohm
Pa | pascal
PCT | percentage (pseudo-unit)
pct | percentage (pseudo-unit)
PPB | parts per billion (pseudo-unit)
ppb | parts per billion (pseudo-unit)
PPM | parts per million (pseudo-unit)
ppm | parts per million (pseudo-unit)
SPS |
sps |
PSI | pounds per square inch
psi | pounds per square inch
rad | radian
rad/V |
s | second
S | siemens
s/div |
SPD |
spd |
sr | steradian
Sv | sievert
T | sievert
V | volt
Vp | volts peak
Vpp | volts peak-to-peak
VA | volt-amp
VAh | volt-amp-hour
VAR | volt-amp-reactive
VARh | volt-amp-reactive-hour
V/div | volts per division
W | watt
Wb | weber
Wh/i | watt-hour per impulse
Wh | watt-hour
% | percentage (pseudo-unit)
%/V | percent per volt

BASE

Purpose: | Given a string which represents a dimensioned number, BASE converts the value to base units.
Result Type: | numeric
Argument Type: | String
Compatibility: | Requires V7.11 or later.
Example: | MATH MEM = BASE("34.5 mV") After the call to BASE the value of MEM will be 0.0345.

ENGR

Purpose:

ENGR converts a string representing a dimensioned quantity to SI prefix / engineering units format. "Engineering units" format is like scientific notation, except that the exponent is alway an integer multiple of 3.

For example, the value "1.23E+4" (in scientific notation) would be expressed as "12.3E+3" in engineering format. The format produced by ENGR is a variant of engineering format.

The difference is that when the exponent is equivalent to one of the standard SI units prefixes (such as 'm' (milli), 'k' (kilo), 'M' (mega), etc.), the exponent is replaced by the corresponding SI units prefix. Therefore, continuing the example, a dimensioned quantity like "1.23E+4 V" will be reformatted to "12.3 kV".
Quick Proto: u = ENGR(dimq)
Result Type:

string

The return value is a string representing the original dimensioned value, but converted to SI prefix / engineering units format.
Argument Type:

string

The argument is a string representing a dimensioned quantity.
Examples:

MATH u = ENGR("2000.7100 V")

The return value is "2.0007100 kV".

MATH u = ENGR("2000 mV")

The return value is "2.000 V".

MATH u = ENGR("12345.6 kV")

The return value is "12.3456 MV".
Usage: ENGR preserves the number of significant digits in the input string. All digits (except leading zeroes and digits in the exponent, if any) are considered to be significant.
Caution:

The units specified in the input argument must be recognized by MET/CAL. Error Handling: An error message is generated and a NULL string is returned if:

  1. The units are not valid (recognized by MET/CAL).
  2. No numeric value is specified in the dimensioned quantity string.
Compatibility: Requires V7.20v or later.
See Also: ENGR_NSD

ENGR_NSD

Purpose: ENGR_NSD converts a numeric value, a units string, and an integer specifying the number of significant digits to SI prefix / engineering format. ENGR_NSD produces the same format as ENGR. Refer to ENGR for a description of SI prefix / engineering units format.
Quick Proto: u = ENGR_NSD(val, units, nsd)
Result Type:

string

The return value is a string representing the original value and units, but converted to SI prefix / engineering units format, with the specified number of significant digits.
Argument Type:

numeric, string, numeric

  1. The first argument is a numeric value.
  2. The second argument is a units string. The units string may include an SI units prefix. The units must be recognized by MET/CAL.
  3. The third argument specifies the number of significant digits.
Example:

MATH u = ENGR_NSD(1.2345E-4, "mV", 8)

The return value is "123.45000 nV". Notice that there are 8 significant digits in the output value, even though the input value does not show 8 digits. Working through the conversion in detail:

1.2345E-4 mv

= 1.2345000E-4 mv (with NSD=8)

= 0.00012345000 mV

= 0.00000012345000 V

= 123.45000E-9 V

= 123.45000 nV
Error Handling:

An error message is generated and a NULL string is returned if:

  1. The units are not valid (recognized by MET/CAL).
  2. No numeric value is specified in the dimensioned quantity string.
Compatibility: Requires V7.20v or later.
See Also: ENGR

IS_DIM

Purpose:

Determines if a string represents a valid dimensioned number.

The return value is 1 if the string is a valid dimensioned number. Otherwise the return value is 0.
Result Type: Numeric
Argument Type: String
Compatibility: Requires 7.11 or later.
Example:

The examples in the group below show strings which are valid dimensioned numbers (so IS_DIM will return 1).

# Valid representation of 1.2 femtovolts.
  1.001 MATH MEM = IS_DIM("1.2 fV")

The examples in the group below show strings which are not valid dimensioned numbers (so IS_DIM will return 0).

# Numeric part not valid.
  1.001 MATH MEM = IS_DIM("1x2 mV")
# Units prefix not valid.
  1.002 MATH MEM = IS_DIM("1.2 qV")
# Units symbol not valid.
  1.003 MATH MEM = IS_DIM("1.2 mX")

IS_UNIT

Purpose:

Determines if a dimensioned number string contains a specified valid units symbol.

The return value is 1 if the units are valid and match the specified units symbol. Otherwise the return value is 0.

IS_UNIT is designed to compare a specified valid units symbol with a valid dimensioned number. It is not designed to determine if a dimensioned number contains a valid units symbol. A call to IS_UNIT with an invalid dimensioned number results in a run time error which terminates the procedure statement.
Result Type: Numeric
Argument Type: String, String
Quick Proto: Boolean = IS_UNIT(dim num, units symbol)
Compatibility: Requires V7.11 or later.

Examples:

MATH MEM = IS_UNIT("1.2 mV", "V")

In the example above the return value is 1 because "V" is a valid units symbol, and the units symbol in the dimensioned number (first argument) is the same as the specified units (second argument).

MATH MEM = IS_UNIT("1.2 mX", "V")

In the example above the return value is 0 because "X" is not a valid units symbol.

MATH MEM = IS_UNIT("1.2 mA", "V")

In the example above the return value is 0 because "V" does not match the units in the dimensioned number.

PSCALE

Purpose:

Given a string which represents a dimensioned number, PSCALE returns the numeric scalar which corresponds to the units prefix.

The return value is the value by which you would multiply the numeric part of the dimensioned number to convert the value to base units. The table above shows the correspondence.

Note on micro: The Windows character set character mu (decimal 181) is equivalent to 'u' for the purposes of function PSCALE.
Result Type: Numeric
Argument Type: String
Compatibility: Requires V7.11 or later.
Example:

MATH MEM = PSCALE("34.5 mV")

After the call to PSCALE the value of MEM will be 1.0E-3.

UNIT

Purpose:

Given a string which represents a dimensioned number, UNIT returns the units symbol. The UNIT function regards the units symbols in the table above as valid.

Except as shown in the table above, units symbols are case-sensitive. Some of the symbols are used with dimensionless numbers and are not technically units symbols. However, for some purposes it may be useful to work with such symbols when representing ratio quantities.
Result Type:

String

The result value is a string which is equal to the units symbol in the provided dimensioned number.
Argument Type:

String

The argument is a string which represents a dimensioned number. The format of a dimensioned number is:

nprefixunits

where:

n::= numeric value

prefix::= SI units prefix

units::= units symbol
Compatibility: Requires V7.11 or later.
See Also: UPREFIX
Example:

MATH MEM2 = UNIT("34.5 mV")

After the call to UNIT the value of MEM2 will be "V".

UPREFIX

Purpose:

Given a string which represents a dimensioned number, UPREFIX returns the units prefix symbol. The UPREFIX supports the SI units prefixes in the table above.

Note on micro: UPREFIX accepts as input a lowercase ''u' to represent micro. However, the return value is a Greek mu character (decimal 181 in the Windows characters set). Units prefixes are case-sensitive.
Result Type:

String

The result value is a string which is equal to the units prefix in the provided dimensioned number.
Argument Type:

String

The argument is a string which represents a dimensioned number. The format of a dimensioned number is:

n prefixunits

where:

n ::= numeric value

prefix ::= SI units prefix

units ::= units symbol
Compatibility: Requires V7.11 or later.
See Also: UNIT
Example:

MATH MEM2 = UPREFIX("34.5 mV")

After the call to UNIT the value of MEM2 will be "m".


MATH FSC Miscellaneous Functions

ADJTHR | return adjustment threshold
ASSET | return asset number of instrument
ASSETC | return asset number of instrument on a channel
CM | specify connection message substring
COMLIST | return list of COM ports on PC
DEMO | returns 1 if running in Demo Mode
FAIL | returns 1 if last evaluation failed, otherwise 0
GET | get value from MET/CAL variable cache
GETV | get value from MET/CAL variable file
INSTR | return instrument name for specified alias
LGET | get value of specified local numeric register
LSET | assign value to specified local numeric register
MGET | get value of specified global numeric register
MSET | assign value to specified global numeric register
PASS | returns 1 if last evaluation passed, otherwise 0
PROC | return name of currently executing procedure
PSUB | Is string a substring of name of executing proc?
PSUBI | case-insensitive version of PSUB
PUT | store value in MET/CAL variable cache
PUTV | store value in MET/CAL variable file
SAFEON | specify potentially dangerous signal
SAFEOFF | clear potentially dangerous signal
SGET | get value of specified global string register
SSET | assign value to specified global string register
UNC | return uncertainty parameter from last evaluation
UNCV | return measurement from last evaluation
UUT | return asset number of UUT
VERS | return MET/CAL version string
VERSIONCHECK | check specified version against current version
VGET | return value of VSET parameter

ADJTHR

Purpose:

Returns the adjustment threshold value.

The value returned by ADJTHR is the value from the header of the main procedure.

It may be different from the value specified in the header of a subprocedure.
Quick Proto: threshold = ADJTHR()
Result Type: Numeric (percentage)
Argument Type: None
Example:

MATH MEM = ADJTHR()
DISP Adjustment Threshold = [MEM]%
Compatibility: Requires V7.10 or later.

ASSET

Purpose: | Returns the asset number of a specified instrument. If the instrument is not configured, or no asset number is specified in the System Configuration File, the return value is an empty string. In the special case of an instrument configured on a channel, use function "ASSETC" instead.
Quick Proto: | AssetNumber = ASSET(InstrumentName)
Result Type: | String
Argument Type: | String The argument specifies the name of a configured instrument.
Compatibility: | Requires V6.01 or later.
See Also: | MATH function "ASSETC"
Example: | MATH S[1] = ASSET("Fluke 5700A")

ASSETC

Purpose: | Returns the asset number of a specified instrument configured on a specified channel. If the instrument is not configured, or no asset number is specified in the System Configuration File, the return value is an empty string. For instruments not configured on a channel, set the channel (2nd argument) to zero, or use function "ASSET".
Quick Proto: | AssetNumber = ASSETC(InstrName, Chan)
Result Type: | String
Argument Type: | String, Numeric The first argument is the name of a configured instrument. The second argument is a channel number.
Compatibility: | Requires V6.10 or later.
See Also: | MATH function "ASSET"
Example: | MATH S[1] = ASSETC("Fluke 9560", 2)

CM

Purpose:

Specify a connection message substring.

A connection message substring is used to replace a corresponding descriptor in an automatic connection message.

Connection message substrings are used to convert generic automatic connection messages to UUT-specific automatic connection messages.
Quick Proto: CM(substr number, substr)
Result Type:

String (or void)

If the connection message substring number is between 1 and 8, the return value is the previous value of the connection message substring.

If the connection message substring number is zero, the return value is an empty string.

To reset all CM substrings specify:

MATH CM(0, "")

Error Handling
Argument Type:

Numeric, String

The first argument is a connection message substring number. The number must be between 0 and 8. Numbers between 1 and 8 refer to a single connection message substring. Zero is a special case which refers to all connection message substrings.
Compatibility: Requires 7.20 or later.
See Also
Example:

Unless inhibited, a procedure statement like this:

5700 1.000V 1%

generates a pop-up connection message which says:

Connect: UUT to 5700A Output Terminals

Internally, this message is stored as "UUT @1 to 5700A Output Terminals".

If the procedure includes a statement like this:

MATH CM(1, "Input HI")

The displayed connection message will appear as:

Connect: UUT Input HI to 5700A Output Terminals

Notice that the descriptor "@1" has been replaced by the specified connection message substring "Input HI".

COMLIST

Purpose: Return a comma-separated list of COM ports on the PC.
Quick Proto: list = ComList()
Result Type:

String

The return value is a comma-separated list of the names of COM ports on the PC on which MET/CAL is running. If there are no COM ports on the PC, the return value is an empty string. (This is not an error condition.)

Argument Type: None
Example:

MATH list = ComList()

If the PC on which MET/CAL is running has COM ports COM1, COM2, and COM6, the string returned by "ComList" will be "COM1,COM2,COM6".

Usage:

One way to make use of "ComList" is to follow these steps:

  1. Call "ComList" to get a list of COM ports.
  2. Use the MATH FSC list box functions to present the list to the operator.
  3. Assign the user's list box selection to a procedure variable.
  4. Use a VSET or TSET "PORT" parameter specification to override the default UUT COM port based on the user's selection.
  5. Use the PORT FSC (without a literal COM port address) to control an instrument on the selected COM port. This approach may have some utility when an instrument is connected to the PC using a serial-to-USB adapter. In that case, the COM port is a virtual COM port, and, without looking at the Windows Control Panel's "Device Manager" dialog, it may not be clear what the COM port number of the virtual port is.
Caution: "ComList" enumerates only standard COM ports (COM1, COM2, ..., COM16). It does not test for Fluke 55xx/58xx calibrator UUT ports (COM5500, COM5520, COM5522, COM5800, COM5820).
Compatibility: Requires V7.20C or later.

DEMO

Purpose: Determines if MET/CAL is running in demo mode.
Quick Proto: mode = DEMO()
Result Type:

Numeric

  • The return value is 1 if MET/CAL is in demo mode.
  • The return value is 0 if MET/CAL is not in demo mode.
Argument Type: None
Example:

IF DEMO()
DISP Demo Mode
ELSE
DISP Real Mode
ENDIF

FAIL

Purpose:

Returns 1 if the most recent evaluation failed, otherwise 0.

It is important to note that execution of an instrument setup statement (e.g., 5700 1V S) clears the internal result status bit. This means that if "FAIL" is used to determine the result of the last evaluation, the determination must be made before the next instrument setup statement.

Result Type: Numeric
Argument Type: None
Compatibility: Requires V6.01d or later.
Example 1: MATH L[1] = FAIL()
Example 2:

5700 1V 0.01%

IF FAIL()
DISP Fail
ELSE
DISP Pass
ENDIF

GET

Purpose:

Get value from MET/CAL variable cache.

If the name does not exist in the variable cache, or the value is empty, the return value is an empty string. Variable names are case-sensitive. The variable cache is an internal cache which may be used to store and retrieve string and numeric values during procedure execution.

The variable cache is never saved as a disk file, and there's no access to the variable cache outside of the "GET" and "PUT" MATH FSC functions. The variable cache is re-initialized at the start of each procedure execution. (The variable cache is not reinitialized when "Go" in the Editor Test Run menu is used.)

Result Type: String
Argument Type: String
See Also: MATH function "PUT"
Compatibility:

Officially requires V7.10 or later.

(In actual fact "get" is supported in MET/CAL Runtime and MET/CAL Editor versions built after 2003/11/14.)

With the introduction of named variables in V7.20 there is no longer any reason to use the "GET" function. "GET" remains supported for backwards compatibility. Example:

MATH MEM = get("temperature")

GETV

Purpose:

Get value from MET/CAL variable file.

If the name does not exist in the variable file, or the value is empty, the return value is an empty string. All variable names must end with '$'. However, if the '$' is omitted in a MATH statement, it is automatically added before the value is retrieved.

Variable names are case-insensitive. The MET/CAL variable file is cached (in memory) during normal program operation. It is used by the pre-prompt and post-prompt dialogs, and accessed by the [V...] special construction.

Result Type:

String

Argument Type: String
See Also: MATH function "PUTV"
Compatibility: Requires V6.00 or later.
Example: MATH MEM2 = GETV("PROC_NAME$")

INSTR

Purpose: | Returns the device name of the configured instrument which has a specified alias. If no device has the specified alias INSTR returns an empty string. It is an error to specify a NULL or empty alias.
Result Type: | String
Argument Type: | String
Compatibility: | Requires V7.10b or later.
Example: | MATH S[1] = INSTR("5700") Assuming there's a configured Fluke 5700A, with the alias "5700", the call to INSTR in this example will return "Fluke 5700A".

LGET

Purpose:

Retrieves a value from a specified local numeric register.

For simple L-register access it is not necessary to use LGET.

For example, to store the value of L[5] into MEM one can simply write:

MATH MEM = L[5]

LGET is useful only when the index of the L register is itself stored in another register.

If, for example, the index is in MEM, you cannot write:

MATH MEM = L[MEM]

but you can write:

MATH MEM = LGET(MEM)

Result Type: Numeric
Argument Type:

Numeric

The argument specifies an L-register index.

Compatibility: Requires V7.11 or later.
See Also: LSET, MGET, MSET, SGET, SSET
Example:

MATH L[2] = 4
MATH L[1] = 2
MATH L[3] = LGET(L[1])

After the MATH statements above execute the value of L[3] will be 4.

LSET

Purpose:

Assigns a value to a specified local numeric register.

For simple L-register assignment it is not necessary to use LSET. For example, to store the value 15.3 into L[5] one can simply write:

MATH L[5] = 15.3

LSET is useful only when the index of the L register is itself stored in another register. If, for example, the index is in MEM, you cannot write:

MATH L[MEM] = 15.3

but you can write:

MATH LSET(MEM, 15.3)

Result Type:

Numeric (or Void)

The return value is the previous value of the assigned-to L register. However, the MATH FSC parser allows the LSET return value to be ignored.

Argument Type:

Numeric, Numeric

The first argument specifies an L-register index.

The second argument specifies the value to be assigned to the specified L register.

Compatibility: Requires V7.11 or later.
See Also: LGET, MGET, MSET, SGET, SSET
Example:

MATH MEM = 10
MATH LSET(MEM, 2.56)

After the MATH statements above execute the value of L[10] will be 2.56.

MGET

Purpose:

Retrieves a value from a specified global numeric register.

For simple M-register access it is not necessary to use MGET.

For example, to store the value of M[5] into MEM one can simply write:

MATH MEM = M[5] MGET

is useful only when the index of the M register is itself stored in another register.

If, for example, the index is in MEM, you cannot write:

MATH MEM = M[MEM]

but you can write:

MATH MEM = MGET(MEM)

Result Type: Numeric
Argument Type:

Numeric

The argument specifies an M-register index.

Compatibility: Requires V7.11 or later.
See Also: LGET, LSET, MSET, SGET, SSET
Example:

MATH M[2] = 4
MATH M[1] = 2
MATH M[3] = MGET(M[1])

After the MATH statements above execute the value of M[3] will be 4.

MSET

Purpose:

Assigns a value to a specified global numeric register.

For simple M-register assignment it is not necessary to use MSET. For example, to store the value 15.3 into M[5] one can simply write:

MATH M[5] = 15.3

MSET is useful only when the index of the M register is itself stored in another register.

If, for example, the index is in MEM, you cannot write:

MATH M[MEM] = 15.3

but you can write:

MATH MSET(MEM, 15.3)

Result Type:

Numeric (or Void)

The return value is the previous value of the assigned-to M register.

However, the MATH FSC parser allows the MSET return value to be ignored.

Argument Type:

Numeric, Numeric

The first argument specifies an M-register index.

The second argument specifies the value to be assigned to the specified M register.

Compatibility: Requires V7.11 or later.
See Also: LGET, LSET, MGET, SGET, SSET
Example:

MATH MEM = 10
MATH MSET(MEM, 2.56)

After the MATH statements above execute the value of M[10] will be 2.56.

PASS

Purpose:

Returns 1 if most recent evaluation passed, otherwise 0.

It is important to note that execution of an instrument setup statement (e.g., 5700 1V S) clears the internal result status bit.

This means that if "PASS" is used to determine the result of the last evaluation, the determination must be made before the next instrument setup statement. When using function "PASS" it is important to be aware that since MET/CAL keeps track internally of failures, the absence of a failure defines a "pass".

Therefore, "PASS" will return 1 if the previous evaluation was not a "fail". This means that "PASS" returns 1 when there has been no previous evaluation, or when a subsequent instrument setup has cleared the internal memory of the result of the last evaluation.

Result Type: Numeric
Argument Type: None
Compatibility: Requires V7.00k or later.
Example 1: MATH M[1] = PASS()
Example 2:

5700 1V 0.01%
JMPL ON_PASS PASS()
DISP FAIL
END

LABEL ON_PASS
DISP PASS
END
See Also:

MATH function "FAIL".

"PASS" is simply the opposite of "FAIL". In some cases using function "PASS", rather than "FAIL", may improve procedure readability.

PROC

Purpose: | Returns the name of the currently executing procedure. If the currently executing procedure is a subprocedure, the name of the subprocedure is returned.
Result Type: | String
Argument Type: | None
Compatibility: | Requires V7.00 or later.
Example: | MATH MEM2 = PROC()

PSUB, PSUBI

Purpose:

Determines if a specified string is a substring of the name of the currently executing procedure.

PSUB is case-sensitive. PSUBI is case-insensitive. If the currently executing procedure is a subprocedure, the name of the subprocedure is used for the comparison.

In many cases, PSUB may be used to replace JMPT and JMPF procedure statements, which have the disadvantage of using procedure step numbers as jump destinations.

Result Type:

Numeric

The return value is 1 if the specified argument is a substring of the current procedure name.

If the argument is not a substring the return value is 0.

Argument Type:

String

Argument #1 is the substring for which to search in the name of the executing procedure or subprocedure.

Example 1: JMPL L1 PSUB("3458 Verification")
Example 2: JMPL L1 PSUBI("3458 verification")
Compatibility: Requires V7.00 or later.

PUT

Purpose:

Store value in MET/CAL variable cache.

  1. The first argument is the variable name.
  2. The second argument is the variable value.

The return value is the previous value of the variable being stored. If the variable does not yet exist in the variable cache the return value is NULL.

Variable names are case-sensitive. The variable cache is an internal cache which may be used to store and retrieve string and numeric values during procedure execution.

The variable cache is never saved as a disk file, and there's no access to the variable cache outside of the "GET" and "PUT" MATH FSC functions. The variable cache is re-initialized at the start of each procedure execution.

(The variable cache is not reinitialized when "Go" in the Editor Test Run menu is used.) Unlike most MATH FSC functions, MET/CAL allows the "PUT" function to be used as a "void" function.

That is, it is not necessary to specify a destination for the return value. (The return value is never ignored, however, when the "PUT" function is used as part of a MATH expression in a JMPL, IF, WHILE, or UNTIL statement.)

Result Type: String (or Void)
Argument Type: String, String
See Also: MATH function "GET"
Compatibility:

Officially requires V7.10 or later.

(In actual fact "PUT" is supported in MET/CAL Runtime and MET/CAL Editor versions built after 2003/11/14. However, the ability to use the function as a "void" function with no return value is not supported prior to V7.10.)

With the introduction of named variables in V7.20 there is no longer any reason to use the "PUT" function. "PUT" remains supported for backwards compatibility.
Examples:

Example 1:

MATH MEM2 = PUT("temperature", 23.2)

Example 2:

MATH PUT("temperature", "23.2 degC")

In the 2nd example the "PUT" function is used as a "void" function. The return value is ignored.

PUTV

Purpose:

Store value in MET/CAL variable file.

  1. The first argument is the variable name.
  2. The second argument is the variable value.

The return value is the previous value, if any, of the variable.

The variable name may refer to an existing variable, or may cause the creation of a new variable.

All variable names must end with '$'.

However, if the '$' is omitted in a MATH statement, it is automatically added before the value is stored. Variable names are case-insensitive. The MET/CAL variable file is cached (in memory) during normal program operation.

It is used by the pre-prompt and post-prompt dialogs, and accessed by the [V...] special construction. The MET/CAL variable file contains lines which have a maximum of 511 characters.

This includes the terminating linefeed character, as well as the equals sign ('=') used to separate the name from the value.

The MATH FSC, therefore, does not allow the combined length of the name and value strings for a variable to exceed 509 characters.

Result Type: String (or Void)
Argument Type: String, String
See Also: MATH function "GETV"
Compatibility:

Requires V6.00 or later.

The ability to use "PUTV" as a "void" function requires V7.10 or later.

Example:

MATH S[32] = PUTV("Humidity", S[30])

The above example assumes that string register S[30] contains the formatted relative humidity value.

Caution:

Function "PUTV" must be used with caution.

Modifying the value of a variable written automatically by the MET/CAL run system may cause unforeseen changes in the results.

SAFEOFF

Purpose:

SAFEOFF is used to inform MET/CAL that a potentially dangerous voltage generated by the UUT or a user-configured reference is no longer present.

If the safety symbol (OSHA lighting bolt warning graphic) has been displayed (based on a call to SAFEON) for a particular device, the graphic will be removed when SAFEOFF is called.
Quick Proto: SAFEOFF(device)
Result Type: Numeric (or Void)
Argument Type:

String

The argument specifies the instrument name.

The name must be either UUT or the name of a configured instrument

(The INSTR function may be used to obtain a device name from an alias if necessary.)
Compatibility: Requires V7.20 or later.
See Also: SAFEON, INSTR
Example:

  1.001 HEAD DC VOLTAGE: 330 V Range
  1.002 M8508 RNGLK 1000V FS
  1.003 TOL 0.0055% 500E-6U
  1.004 TARGET -p
  1.005 MATH SAFEON("UUT", "300 V", "")
  1.006 IEEE2 OUT 300 V;OPER
  1.007 TARGET -m
  1.008 8508 300 300.0000V TOL D7 2W
  2.001 MATH SAFEOFF("UUT")

In this example the UUT is generating an unsafe voltage (300 VDC). The lightning bolt graphic will appear when SAFEON is called. The graphic will be removed when the call to SAFEOFF occurs.

SAFEON

Purpose:

.

SAFEON is used to inform MET/CAL that a potentially dangerous voltage generated by the UUT or a user-configured reference is present.

The "safety symbol" (OSHA lighting bolt warning graphic) is displayed if the specified signal exceeds the danger threshold. The SAFEON function interacts with the RESET FSC in the following manner:

When MET/CAL executes a reset command specified in a RESET statement, it is presumed that the instrument is being reset to a safe state.

Therefore, if the lightning bolt graphic is displayed at the time that the reset command is executed, the graphic is removed

This means that if the procedure contains a RESET statement for a particular instrument it is not necessary to call the SAFEOFF function to remove a signal specified using SAFEON. If multiple unsafe signals are present at the same time, multiple calls to SAFEON may be made. The lightning bolt graphic will not be removed until all unsafe signals have been removed.

Quick Proto: SAFEON(device, value, waveform)
Result Type: Numeric (or Void)
Argument Type:

String, String, String

  1. The first argument specifies the instrument name.

    The name must be either "UUT" or the name of a configured instrument.

    (The INSTR function may be used to obtain a device name from an alias if necessary.)

  2. The second argument specifies a dimensioned value, including units prefix and units symbol. (The prefix is optional.)

  3. The third argument specifies the waveform. For DC voltages specify an empty string ("") as the waveform. Valid waveforms are:

    • edge
    • fast edge
    • impulse
    • leveled sine (or lev sine)
    • linear ramp
    • +ramp
    • -ramp
    • sawtooth
    • scopemeter
    • sine
    • square (or sq)
    • trapezoid
    • triangle
    • truncated sine (or trunc sine)

When the specified units are volts rms ("V") or volts peak-to-peak ("Vpp"), MET/CAL uses the specified waveform to convert to an equivalent peak AC voltage.

By default, the maximum safe peak AC voltage is 42.4. Values greater than that threshold value will cause the lightning bolt graphic to appear during procedure execution.

(The lightning bolt does not appear in demo mode.)

Compatibility: Requires V7.20 or later.
See Also: SAFEOFF, INSTR
Example:

  1.001 RESET STBY;*OPC?[I!]
  1.002 HEAD DC VOLTAGE: 330 V Range
  1.003 M8508 RNGLK 1000V FS
  1.004 TARGET -p
  1.005 MATH SAFEON("UUT", "300 V", "")
  1.006 IEEE2 OUT 300 V;OPER
  1.007 TARGET -m
  1.008 TOL 0.0055% 500E-6U
  1.009 8508 300 300.0000V TOL D7 2W

In this example the UUT is generating an unsafe voltage (300 VDC). The lightning bolt graphic will appear when SAFEON is called. The graphic will be removed when the RESET-specified reset command is executed.

SGET

Purpose:

Retrieves the value of a specified global string register.

For simple S-register access it is not necessary to use SGET.

For example, to store the value of S[5] into MEM2 one can simply write:

MATH MEM2 = S[5]

SGET is useful only when the index of the S register is itself stored in another register.

If, for example, the index is in MEM, you cannot write:

MATH MEM2 = S[MEM]

but you can write:

MATH MEM2 = SGET(MEM)
Result Type: String
Argument Type:

Numeric

The argument specifies an S-register index.

Compatibility: Requires V7.11 or later.
See Also: LGET, LSET, MGET, MSET, SSET
Example:

  1.001 MATH S[2] = "ABC"
  1.002 MATH L[1] = 2
  1.003 MATH S[3] = SGET(L[1])

After the MATH statements above execute the value of S[3] will be "ABC".

SSET

Purpose:

Assigns a value to a specified global string register.

For simple S-register assignment it is not necessary to use SSET.

For example, to store the value "abc" into S[5] one can simply write:

MATH S[5] = "abc"

SSET is useful only when the index of the S register is itself stored in another register.

If, for example, the index is in MEM, you cannot write:

MATH S[MEM] = "abc"

but you can write:

MATH SSET(MEM, "abc")
Result Type:

String (or Void)

The return value is the previous value of the assigned-to S register. However, the MATH FSC parser allows the SSET return value to be ignored.

Argument Type:

Numeric, Numeric

  1. The first argument specifies an S-register index.
  2. The second argument specifies the value to be assigned to the specified S register.
Compatibility: Requires V7.11 or later.
See Also: LGET, LSET, MGET, MSET, SGET
Example:

  1.001 MATH MEM = 10
  1.002 MATH SSET(MEM, "mV")

After the MATH statements above execute the value of S[10] will be "mV".

UNC

Purpose:

Retrieve specified uncertainty parameter value from most recent evaluation.

It is important to realize that values returned by UNC are always for the most recently completed evaluation step.

You cannot query the system to determine values for the uncertainty calculation which is currently underway. Values which are dimensioned quantities are returned in base units (for example, volts, not millivolts).

Result Type: Numeric
Argument Type:

String

The following arguments are valid:

  • "C1", "C2", "C3", "C4", "C5", "C6", "C7", "C8", "C9", "C10"
  • "CONF"
  • "COV_FAC"
  • "DF"
  • "DF1", "DF2", "DF3", "DF4", "DF5", "DF6", "DF7", "DF8", "DF9", "DF10"
  • "EXP_UNC"
  • "F"
  • "NMEAS"
  • "NTHROW"
  • "RSS"
  • "S1", "S2"
  • "SDEV"
  • "STD_UNC"
  • "SYS_ACC"
  • "U1", "U2", "U3", "U4", "U5", "U6", "U7", "U8", "U9", "U10"
  • "UUT_RES"

Refer to the VSET help file for an explanation of the parameters. Argument values are case-insensitive.

Compatibility: Requires V6.11d or later.
Error Handling: An attempt to access a parameter value when the measurement uncertainty calculation was disabled for the most recent evaluation results in a run time error.

Example:

  1.001 ASK+ K
  1.002 VSET NMEAS = 5
  1.003 5700 1.000V S 2W
  1.004 TARGET -m
  1.005 IEEE UUT_COMMAND[I]
  1.006 MEMCX 1.000V 0.01%
  2.001 MATH MEM = UNC("SDEV")
  2.002 DISP Standard Deviation = [MEM]

In this example the measurement in test #1 is repeated 5 times. After the MEMCX evaluation has completed, the "UNC" function is then used to retrieve the standard deviation ("SDEV") calculated as part of the measurement uncertainty calculation for test #1.

UNCV

Purpose:

Retrieve specified measurement value, or average value, from most recent evaluation.

It is important to realize that values returned by UNCV are always for the most recently completed evaluation step.

You cannot query the system to determine values for the uncertainty calculation which is currently underway. UNCV cannot be used if the measurement uncertainty calculation is not enabled. Values returned by UNCV are in specified units.

For example, if an instrument evaluation FSC specifies "mV" in the NOMINAL field, the measurement values returned by UNCV will be in millivolts, not volts.

Result Type: Numeric
Argument Type:

Numeric

The argument specifies the index of the measurement.

To retrieve a specific individual value, the index must be between 1 and NMEAS. As a special case, specifying an index of zero causes UNCV to return the average of the values.

Compatibility:

Requires V6.11d or later.

Requires V7.00 or later to specify 0 as the function argument.

Error Handling:

An attempt to access a measurement value when the measurement uncertainty calculation was disabled for the most recent evaluation results in a run time error.

Example:

  1.001 ASK+ K
  1.002 VSET NMEAS = 3
  1.003 5700 1.000V S 2W
  1.004 TARGET -m
  1.005 IEEE UUT_COMMAND[I]
  1.006 MEMCX 1.000V 0.01%
  2.001 MATH M[1] = UNCV(1)
  2.002 MATH M[2] = UNCV(2)
  2.003 MATH M[3] = UNCV(3)
  2.004 DISP The three measurements are:
  2.004 DISP 1) [M1]
  2.004 DISP 2) [M2]
  2.004 DISP 3) [M3]
  2.005 MATH MEM = UNCV(0)
  2.006 DISP Average measurement = [MEM]

In this example the measurement in test #1 is repeated 3 times. After the MEMCX evaluation has completed, the "UNCV" function is then used to retrieve the 3 measurements.

(These are the measurements MET/CAL averages to determine the UUT Indicated value, and from which the standard deviation is determined as part of the measurement uncertainty calculation.) The UNCV function is then called again, with an index of zero, to retrieve the average measurement.

UUT

Purpose: | Returns the asset number of the UUT. When running a procedure using the MET/CAL Editor's Test Run function the asset number of the UUT is unknown. In this case the UUT function returns an empty string.
Result Type: | String
Argument Type: | None
Compatibility: | Requires V7.11h or later.
See Also: | MATH functions "ASSET" and "ASSETC"
Example: | MATH S[1] = UUT()

VERS

Purpose: | Returns MET/CAL version string.
Result Type: | String
Argument Type: | None
Example 1: | MATH MEM2 = VERS()
Example 2: | MATH MEM = VERS() In the second example, the version string is converted to numeric form. This allows the version number to be tested in a relational expression.

VERSIONCHECK

Purpose:

Compares a required MET/CAL version to the running version.

Generates an error message if the running version is older than the required version.

Quick Proto: VersionCheck(version)
Result Type: None
Argument Type:

String

The argument specifies the required MET/CAL version. The leading 'V' is optional. Note that the suffix letter, if any, is case-sensitive.

For example, V7.20b is not the same as V7.20B.

Example: MATH VersionCheck("V7.20")
Usage:

If the version check fails MET/CAL generates an error message showing both the required version and the running version.

After the user closes the error message window the Post Test "Procedure Step Terminated" window appears. At that point the user should choose the "Terminate" button to terminate the procedure.

Choosing Advance is not recommended because the procedure most likely makes use of MET/CAL features not available in the executing version of MET/CAL

Compatibility: V7.20A or later
See Also: VERS

VGET

Purpose:

Get value of VSET parameter. Refer to the VSET help file for a list of VSET parameter names.

The value is returned as it was entered in a VSET or TSET statement. If no value has been assigned to the specified parameter the return value is an empty string.

Quick Proto: ParamVal = VGET(ParamName)
Result Type:

String

The return value is a string representing the value of the specified VSET parameter.

Argument Type:

String

The argument is the parameter name.

Parameter names are case-insensitive.

Example:

  1.001 VSET NMEAS = 5
  1.002 TSET NMEAS = 10
  1.003 MATH nm = VGET("NMEAS")
  1.004 DISP NMEAS = [v nm]
  1.005 EVAL yes or no
  2.001 MATH nm = VGET("NMEAS")
  2.002 DISP NMEAS = [v nm]

DISP statement 1.004 will display "NMEAS=10", because "10" is the value established by the TSET statement for test #1.

DISP statement 2.002 will display "NMEAS=5", because after the end of test #1 the value of NMEAS reverts to the value established in VSET statement 1.001.

Compatibility: Requires V7.20 or later.


MEM2

Memory Register Operation FSC

Description

The MEM2 FSC assigns a value to memory register MEM2. MEM2 is a string register which may contain up to 4096 characters.

Format

MEM2 string or

MEM2 = string

Rules

  1. A MEM2 statement may contain up to 32 lines.

  2. If string is preceded by an equals sign ('=`), the string is copied directly into MEM2.

    The string, before any special constructions are evaluated, is limited to 240 bytes per line. Characters below ASCII 128 count as one byte. The evaluated string is limited by the length of MEM2 (4096 characters).

    Example:

    1.001 MEM2 =ABC

    This statement causes the string "ABC" to be copied into MEM2. In the case of a multiline MEM2 statement used to assign a value to the register MEM2 only the first line of the statement should begin with an equals sign.

    Example:

      1.001   MEM2 =ABC
  1.001   MEM2 DEF

    This statement causes the string "ABCDEF" to be copied into MEM2.

  3. If string is not preceded by an equals sign ('='), the string is used as a prompt to the operator. The response entered by the operator is copied into MEM2.

    The unevaluated string entered in the MEM2 statement is limited to 56 characters per line. The evaluated string, used as an operator prompt, is limited to 1023 characters. The operator's response is limited by the length of MEM2 (4096 characters).

    Example:

      1.001 MEM2   Enter the current temperature.
  1.002 DISP   Current temperature is [MEM2].

    Since the MEM2 string does not begin with an equal sign (=), the operator is prompted to "Enter the current temperature." The operator's response is stored (as a text string) in MEM2. The DISP statement then displays the response. To display a two-line prompt use two-line MEM2 statement.

    Example:

      1.001 MEM2   Enter 3 temperature values.
  1.001 MEM2   Use commas to separate the values.

  4. The following special constructions may be used in a MEM2 statement:
    1. [MEM], [MEM1], and [MEM2]
    2. [numeric]
    3. [Vvariable]
    4. {text}
    5. [M1], [M2], ...
    6. [L1], [L2], ...
    7. [S1], [S2], ...
    8. [SREG1], [SREG2], ...
    9. [Xhex list]

    Refer to Special Constructions for details.

    The constructions [M1], [M2], ..., access the global numeric registers. The constructions [L1], [L2], ..., access the local numeric registers. Up to 12 significant digits are included in the numeric register value. Refer to the MATH FSC on-line help for additional information on the numeric registers. The constructions [S1], [S2], ..., access the string registers.

    Refer to the MATH FSC on-line help for additional information on the string registers.

    The constructions [SREG1], [SREG2], ..., are identical to [S1], [S2], ..., and are included only for compatibility with the IEEE, IEEE2, and SCPI FSCs.


MEM* (Non-preferred)

Memory Register Operation FSC

REMAINS FOR COMPATIBILITY ONLY. USE MATH FSC INSTEAD.

Description

The MEM* FSC multiplies MEM by a specified value. If the value is omitted, MEM is multiplied by MEM1. The result of the multiplication is stored back in MEM.

Format

MEM* value or MEM*

Rules

  1. If value is a numeric constant, MEM is multiplied by the specified value.

    Example:

    MATH	MEM = 3
MEM*	2
DISP	MEM = [MEM]

    The MATH statement assigns the value 3 to MEM.

    The MEM* statement multiplies MEM by 2.

    The value of MEM is now 6. The DISP statement displays the updated value of MEM.

  2. If value is blank, MEM is multiplied by MEM1.

    Example:

    MATH	MEM = 3.5
MATH	MEM1 = 6
MEM*
DISP	MEM = [MEM]

    The MATH statements set MEM to 3.5 and MEM1 to 6. The MEM*statement multiplies the two values, storing the result in MEM. The value of MEM is now 21. The DISP statement displays the updated value of MEM.

  3. The MEM* statement is retained for compatibility with older versions of MET/CAL. Equivalent MATH FSC statements are easier to read:

    MEM* Statement Equivalent MATH Statement

    MEM* 5

    MATH MEM = MEM * 5

    MEM*

    MATH MEM = MEM * MEM1


MEM+ (Non-preferred)

Memory Register Operation FSC

REMAINS FOR COMPATIBILITY ONLY. USE MATH FSC INSTEAD.

Description

The MEM+ FSC adds a specified value to MEM. If the value is omitted, the value of MEM1 is added to MEM.

Format

MEM+ value or MEM+

Rules

  1. If value is a numeric constant, the specified value is added to MEM.

    Example:

    MATH	MEM = 3
MEM+	1
DISP	MEM = [MEM]

    The MATH statement assigns the value 3 to MEM. The MEM+ statement adds 1 to MEM. The value of MEM is now 4. The DISP statement displays the updated value of MEM.

  2. If value is blank, the value of MEM1 is added to MEM.

    Example:

    MATH	MEM = 3.5
MATH	MEM1 = 4.2
MEM+
DISP	MEM = [MEM]

    The MATH statements set MEM to 3.5 and MEM1 to 4.2. The MEM+ statement adds the two values, storing the result in MEM. The value of MEM is now 7.7. The DISP statement displays the updated value of MEM.

  3. The MEM+ statement is retained for compatibility with older versions of MET/CAL. Equivalent MATH statements are easier to read:

    MEM+ Statement | Equivalent MATH Statement
    MEM+ 5 | MATH MEM = MEM + 5
    MEM+ | MATH MEM = MEM + MEM1


MEM- (Non-preferred)

Memory Register Operation FSC

REMAINS FOR COMPATIBILITY ONLY. USE MATH FSC INSTEAD.

Description

The MEM- FSC subtracts a specified value from MEM. If the value is omitted, the value of MEM1 is subtracted from MEM.

Format

MEM- value or MEM-

Rules

  1. If value is a numeric constant, the specified value is subtracted from MEM.

    2. Example:

      1.001  MATH         MEM = 3
  1.002  MEM-         1
  1.003  DISP         MEM = [MEM]

    The MATH statement assigns the value 3 to MEM. The MEM- statement subtracts 1 from MEM. The value of MEM is now 2. The DISP statement displays the updated value of MEM.

  2. If value is blank, the value of MEM1 is subtracted from MEM.

    Example:

      1.004  MATH         MEM = 9.5
  1.005  MATH         MEM1 = 4.2
  1.006  MEM-
  1.007  DISP         MEM = [MEM]

    The MATH statements set MEM to 9.5 and MEM1 to 4.2. The MEM- statement subtracts MEM1 from MEM, storing the result in MEM.

    The value of MEM is now 5.3. The DISP statement displays the updated value of MEM.

  3. The MEM- statement is retained for compatibility with older versions of MET/CAL. Equivalent MATH statements are easier to read, as shown by these MEM- statements followed by equivalent MATH statement examples:

    1.001 MEM- 5
    1.001 MATH MEM = MEM - 5

    2.001 MEM-
    2.001 MATH MEM = MEM - MEM1


MEM/ (Non-preferred)

Memory Register Operation FSC

REMAINS FOR COMPATIBILITY ONLY. USE MATH FSC INSTEAD.

Description

The MEM/ FSC divides MEM by a specified value. If the value is omitted, MEM is divided by MEM1. The result of the division is stored back in MEM.

Format

MEM/ value or MEM/

Rules

  1. If value is a numeric constant, MEM is divided by the specified value.

    Example:

    MATH	MEM = 6
MEM/	2
DISP	MEM = [MEM]

    The MATH statement assigns the value 6 to MEM. The MEM/ statement multiplies MEM by 2. The value of MEM is now 3. The DISP statement displays the updated value of MEM.

  2. If value is blank, MEM is multiplied by MEM1.

    Example:

    MATH	MEM = 8.4
MATH	MEM1 = 2
MEM/
DISP	MEM = [MEM]

    The MATH statements set MEM to 8.4 and MEM1 to 2. The MEM/ statement divides MEM by MEM1, storing the result in MEM. The value of MEM is now 4.2. The DISP statement displays the updated value of MEM.

  3. If the divisor is zero, a run time error occurs, terminating execution of the MEM/ statement. The value of MEM is unchanged.

  4. The MEM/ statement is retained for compatibility with older versions of MET/CAL. Equivalent MATH statements are easier to read:

    MEM/ Statement | Equivalent MATH Statement
    MEM/ 5 | MATH MEM = MEM / 5
    MEM/ | MATH MEM = MEM / MEM1


IEEE

Interface Control FSC

Description

The IEEE FSC is used to control IEEE-488 instruments. Both UUTs and system calibration instruments may be controlled. The IEEE FSC may be used to control system calibration instruments which are not directly supported by MET/CAL. It may also be used to control supported instruments in cases where the built-in MET/CAL driver does not provide the required function.

Format

IEEE message

Rules

  1. An IEEE statement may include multiple lines.

  2. A maximum of 256 characters is allowed in a single IEEE message including the step and FSC name. Note that characters above 128 ASCII count as 2 characters.

  3. A MET/CAL system may include 0, 1, or 2 IEEE-488 interfaces. In a system with two IEEE-488 interfaces, board 0 is reserved for system calibration instruments, and board 1 is reserved for the UUT. In a system with one IEEE-488 interface, board 0 is used for both system calibration instruments and the UUT.

  4. Leading and trailing blanks in a message are ignored.

  5. When an IEEE statement is executed, characters in the message which are not part of a special construction (enclosed by square brackets) are written to the currently addressed device on the IEEE-488 bus.

  6. The following special constructions may be used in an IEEE statement:

    [@address] | select address as current address
    [number] | write number (ASCII) to current address
    {text} | send braced text to result file as well
    [Ddelay] | delay execution for delay milliseconds
    [EOI ON|OFF] | enable/disable assertion of EOI on a write
    [GTL] | puts an instrument into local control state
    [IFCport] | causes an Interface Clear on specified port
    [I] | read number from current address, store in MEM
    [I$] | read string from current address, store in MEM2
    [I > filename] | read from current address, write to file
    [I >> filename] | read from current address, append to file
    [I!] | read from current address, discard data
    [Lnreg] | write value of local numeric register to current address
    [LLO] | disable instrument front panel controls
    [Mnreg] | write value of numeric register to current address
    [MEM] | write value of register MEM to current address
    [MEM1] | write value of register MEM1 to current address
    [MEM2] | write contents of register MEM2 to current address
    [O < file] | read from file, write to current address
    [REN] | sets the Remote Enable line on the IEEE-488 bus
    [SDC] | sends a Selected Device Clear to current address
    [Sinter-byte delay] | sets delay between transmitted characters
    [SPLmask] | serial polls current address
    [SREGnreg] | write value of string register to current address
    [SRQtimeout,mask] | wait for IEEE Service Request
    [SRQ ON|OFF] | enable/disable UUT Service Request processing
    [Tnumber] | sets bus timeout to number milliseconds
    [TERMnumber] | sets terminator character to number (ASCII)
    [TERM 'c'] | sets terminator character to c (character)
    [TERM CR] | sets terminator character to Carriage Return
    [TERM LF] | sets terminator character to Line Feed
    [TERM NONE] | indicates there is no terminator character
    [TERM OFF] | indicates there is no terminator character
    [TRIG] | triggers instrument at current address
    [Vvariable] | write value of variable to current address
    [Xhex list] | write bytes (specified in ASCII hex format) to current address

    Constructions [Ddelay], [MEM], [MEM1], [MEM2], [number], [Vvariable], and {text} are used by a number of FSCs and are described in Special Constructions.

    Except for [Mnreg], [Lnreg], and [SREGsreg], the rest of the constructions in the list above are either specific to the IEEE FSC, or are used only by IEEE, IEEE2, SCPI, and PORT.

    Detailed descriptions of these constructions, including [Mnreg], [Lnreg], and [SREGsreg] are provided in the sections below.

IEEE-488 Bus Addresses

A special IEEE construct is used to identify the IEEE-488 bus address of the instrument to receive the IEEE command; actual IEEE-488 addresses can be used or symbolic IEEE-488 addresses. IEEE-488 bus addresses are specified as follows:

[@primary address:secondary address]

  1. If only a primary address is specified, secondary addressing will not be used.

  2. If IEEE-488 port 1 is used, add 100 to the instrument address. For example, if the instrument address is 1 and the instrument is connected to IEEE port 1, it is addressed in the IEEE FSC as [@101].

  3. Addresses 0 and 100 cannot be used.

  4. There is no preset default for IEEE addresses. Once an address is specified, it becomes the default address until another address is assigned.

  5. A procedure line can specify a change of address within a single IEEE FSC message line.

  6. If no default address is established in the first IEEE FSC which requires sending out a command string to an instrument or obtain a reading from an instrument, one of two things can happen:

    1. If a second IEEE-488 port is available, MET/CAL software will attempt to find the address automatically.
    2. The operator will be prompted for the IEEE-488 bus default address to be used.
    If a UUT with a remote IEEE-488 interface is connected with an IEEE-488 port of the calibration system, you have to make sure that its address does NOT conflict with any of the addresses used by the calibration instruments in the system. Where possible you should have all your calibration instruments on one IEEE-488 port and leave the other solely for the use by a UUT, so address conflicts never occur.

    Refer to the instructions in the Configuration Manual for information on IEEE-488 addresses used. Generally IEEE-488 address 10 is left unused by calibration instruments.

  7. Under the following conditions, the MET/CAL software will automatically find the IEEE-488 address of a UUT:

    1. The IEEE-488 address was not specified in a previous IEEE FSC.
    2. The searching is done on an IEEE FSC that would normally prompt for the UUT address.
    3. The UUT is by itself on port 1 (the secondary port).

    The first device found on the second port is assumed to be the UUT. Searching starts at IEEE-488 address 1 and ends at address 30.

    Address 0 cannot be searched since this address is reserved for the IEEE-488 card of the Instrument Controller.

    Symbolic bus addresses are shown as [@alias]. Symbolic names enhance readability of the procedure.

IEEE-488 Bus Input Commands

The following special constructs are available which perform an input from the specified address.

[I]
The special construct [I] performs an input from the current address. Data strings returned by a remotely controlled instrument normally contain just a numeric value. In a few cases units are also sent. The non-numeric characters are deleted from the string. The numeric value is stored as the contents of memory register MEM. The current contents of MEM are overwritten.
[I$]
The special construct [I$] performs an input from the current address. The input is an alphanumeric string, and it is stored in memory register MEM2, overwriting the current contents of that memory register. The MEM2 register is 4096 characters long.
[I > filename]
This special construct stores the returned information in a file with the name filename. Any existing file is overwritten. This construct should be used, if the returned string is expected to be longer than 4096 characters. The MATH FSC contains functions to read the file, process the file contents, and return relevant information to MET/CAL.
If a full path is given, the file is written to this path. However if only the filename is given, the file is written to the directory specified in the User Data Folder setting.
[I >> filename]
This special construct appends the returned information to a file with the name filename. If the file does not exist, then it will be created. This construct should be used, if the returned string is expected to be longer than 4096 characters. The MATH FSC contains functions to read the file, process the file contents, and return relevant information to MET/CAL.
If a full path is given, the file is written to this path. However if only the filename is given, the file is written to the directory specified in the User Current Working Folder setting.
[I!]
This construction is the same as [I$], except that the data message read from the instrument is not stored in MEM2, or any other MET/CAL register. [I!] is appropriate only when it is necessary to read and discard a data message.
The TERM special construction is used to define the terminator character for IEEE-488 data messages sent by an instrument to the controller. This construction does not affect messages written by the controller to an instrument.
The specified terminator remains in effect for the duration of the procedure, unless it is explicitly changed under procedure control. The terminator applies to all subsequent IEEE, IEEE2, and SCPI statements. For a system with two IEEE-488 boards, the terminator applies to both boards 0 and 1. Note also that the terminator applies whether or not the device from which the data message is read is addressed using an address alias.
The practical consequence of this design is that if a procedure uses IEEE, IEEE2, or SCPI statements to communicate with two or more instruments, and if those instruments do not all share the same terminator, the procedure writer must directly set the appropriate terminator prior to reading data from each instrument.
Valid TERM special constructions are:
[TERMnumber]
number is a decimal integer between 0 and 255, but not 64.
[TERM 'c']
'c' is any printable character other than '@'. There must be exactly one character between the quotes, i.e. one cannot say: "[TERM ' x ']" and expect the blanks to be ignored. The case of the character between quotes IS case sensitive (in general special constructs are case insensitive).
[TERM CR]
Specifies that the terminator character is Carriage Return. This is equivalent to "[TERM 13]".
[TERM LF]
Specifies that the terminator character is Line Feed. This is equivalent to "[TERM 10]".
[TERM NONE]
Specifies that there is no terminator character. In this case the instrument must assert EOI to indicate the end of the message.
[TERM OFF]
Specifies that there is no terminator character. In this case the instrument must assert EOI to indicate the end of the message. This is just an alternate form for "[TERM NONE]".

IEEE-488 Bus Output commands

  • Alphanumeric characters, not part of a special construct will be sent to the addressed instrument. The strings are always terminated by an EOI (no CR or LF). Each line of a multiple line message will be terminated this way.

  • Braces ('{' and '}') or square brackets ('[' and ']') can not be entered literally, since they are used to define special constructs for the IEEE FSC (see the following paragraph).

  • The EOI special construct is used to disable or enable the assertion of EOI to terminate an IEEE-488 data message written by the controller to an IEEE-488 instrument using the IEEE FSC. The EOI special construct has no affect on data messages read by the controller from an IEEE-488 instrument. Allowed EOI special constructs are:

    [EOI ON] and [EOI OFF]

  • The "Slow" special construction specifies the inter-byte delay between characters sent from the controller to the instrument when the IEEE FSC is used. The format is:

    [Sinter-byte delay]

    where inter-byte delay is an integer between 0 and 65536.

    The inter-byte delay is the number of milliseconds to delay between bytes when a data message consisting of 2 or more bytes is written to an IEEE-488 instrument by a MET/CAL IEEE statement.

    The default is 0. The delay, if a non-zero value is specified, affects only the current IEEE statement. It is reset to the default at thebeginning of each new IEEE statement.

    There is no delay before the first byte, or after the last byte, of the data message. If such a delay is required, the procedure writer should use the [Ddelay] construct.

    This construct is used to be able to support older non-compatible IEEE-488 interfaces (e.g. DATA PROOF scanners).

  • Output from a file directly to the instrument: Special construct is [Ofilename] ('O' for Output). The contents of the file filename are sent over the IEEE-488 bus.

  • The following other special constructs may be used:

    [MEM], [MEM1], and [MEM2]

    The contents of memory register MEM, MEM1 or MEM2 will be included in the IEEE command string.

    [number]

    The character with the ASCII value of number will be included in the IEEE command string.

    The [number] construct should be used to output braces and brackets.

    [Ddelay]

    The [Ddelay] special construct will cause a delay of the message line by delay milliseconds (delay is between 0 and 3600000).

    In MET/CAL V6.00 and earlier, the maximum delay is 32767 ms. V6.01 or later is required for delays from 32768 ms to 3600000 ms.

    When using the DELAY special construction, the IEEE command is executed after the DELAY time has elapsed.

    {text}

    Text in braces in addition to being used in the IEEE command string, is copied literally into the results file (without numerical substitutions for [MEM] for example).

    [Vvariable name]

    This construct evaluates to the value of the named variable. The variable must, at run time, be present in the MET/CAL variable file (default name "VARIABLE.DAT").

    Example:

    IEEE [V DATE$]?

    [Mnreg]

    The value of the specified global numeric register is included in the IEEE command string.

    The constructions [M1], [M2], ..., refer to the global numeric registers. Up to 12 significant digits are included in the value. Refer to the MATH FSC on-line help for additional information on the global numeric registers.

    [Lnreg]

    The value of the specified local numeric register is included in the IEEE command string.

    The constructions [L1], [L2], ..., refer to local numeric registers. Up to 12 significant digits are included in the value. Refer to the MATH FSC on-line help for additional information on the local numeric registers.

    [SREGsreg]

    The contents of the specified string register are included in the IEEE command string.

    The constructions [SREG1], [SREG2], ..., refer to the string registers. Refer to the MATH FSC on-line help for additional information on the string registers.

    Other FSCs, like DISP, EVAL, OPBR, HEAD, and others, support the [Ssreg] special construction. [Ssreg] is identical to [SREGsreg], but cannot be used in the IEEE FSC, because [Sn] is used to specify an inter-byte delay.

IEEE-488 Bus Timeout, SRQ and Serial Polls

A number of special constructs are available to specify IEEE-488 bus timeouts, wait for SRQs and perform a Serial Poll on the IEEE-488 bus. These constructs are unique to the IEEE FSC.

[Ttimeout]

This construct sets the timeout of the IEEE-488 bus to the specified number of milliseconds. If the timeout is set to zero, there is no timeout. The specified timeout must be between 0 and 1000000 ms. The default timeout is 15 seconds. The timeout specification affects only the current IEEE FSC statement.

The National Instruments device driver for IEEE-488 interfaces does not support all discrete timeout values (with millisecond resolution). The following table shows the actual timeout which corresponds to each possible specified timeout value:

Specified Timeout | Actual Timeout
0 ms | none
1 ms | 1 ms
2 to 3 ms | 3 ms
4 to 10 ms | 10 ms
11 to 30 ms | 30 ms
31 to 100 ms | 100 ms
101 to 300 ms | 300 ms
301 to 1000 ms | 1 s
1001 to 3000 ms | 3 s
3001 to 10000 ms | 10 s
10001 to 30000 ms | 30 s
30001 to 100000 ms | 100 s
100001 to 300000 ms | 300 s
300001 to 1000000 ms | 1000 s

[SRQ timeout,mask]

This construct causes the calibration system to wait for an IEEE Service Request from the device at the default IEEE-488 address (on either IEEE port if both are installed and configured). The timeout entry specifies the maximum time to wait in milliseconds (range 0 to 86,400,000). The mask expression is ANDed to the serial poll status byte and the result is stored in memory register MEM.

If 0 or no timeout is specified, there is no timeout.

The range of possible mask values is from 0 to 255. The mask entry is optional. If no mask is specified, a mask of 255 decimal is assumed. The serial poll status byte is always ANDed with the mask and the result is stored in memory register MEM.

This construct disables any other SRQ interrupts.

If the timeout is exceeded, then the following error message will be displayed:

Timed out waiting for SRQ from device at address ##.

where ## will be replaced by the current IEEE FSC default address.

After an SRQ is detected MET/CAL determines whether or not the SRQ was generated by the device at the current IEEE-488 default address.

Note that when the SRQ was generated by the expected device the serial poll done by MET/CAL to determine that fact will clear the RQS status bit. If the SRQ did not come from the default address, the error message:Unexpected SRQ from device at address ##. will be displayed and the program will present the Post Test Summary dialog, just as if the operator had pressed Terminate.

To specify a mask without a timeout the syntax is either:

[SRQ 0, mask] or

[SRQ , mask]

Procedure writers should be cautious when specifying an infinite timeout. If the waited-for SRQ does not occur, you may, in effect, lock up the application.

[SRQ ON] and [SRQ OFF]

This special SRQ related construct allows you to deal with a power up SRQ by a UUT, before an IEEE statement has been performed and the UUT address determined.

Rules:

[SRQ ON] and [SRQ OFF] are illegal unless the system has two IEEE-488 boards or is in Demo Mode. These constructs do not work if the UUT and the calibration instruments share the same IEEE-488 port.

The current UUT address must not be a port 0 address. Example:

IEEE [SRQ OFF]
IEEE [@24] xyz
IEEE [SRQ ON]
IEEE [@115] def

will generate a run time error when the fourth IEEE statement is executed. At that time when the [SRQ ON] statement is evaluated, the current UUT address is 24. The solution may be to specify [@115] before the [SRQ ON] and then write "def".

If no UUT address is currently set at the time an [SRQ ON] occurs, it triggers an automatic search and/or prompt for the UUT address. [SRQ OFF] does not have this effect.

[SPLmask]

This special construct does a Serial Poll on the most recently addressed instrument. The mask is ANDed to the serial poll status byte and the result is stored in memory register MEM. Legal values for mask are 0 to 255. Additional notes:

The range of possible values is from 0 to 255. If no mask numeric is specified, then a mask of 255 decimal is assumed. The serial poll status byte is always ANDed with the mask and the result stored in memory register MEM.

The SPL instruction may or may not clear the RQS bit. This is UUT dependent.

IEEE-488 Bus SDC, REN, GTL, LLO, TRIG and IFC Commands

The following additional IEEE-488 bus functions can be controlled through the special constructs in the IEEE FSC:

[SDC]
This construct sends a Selected device clear to the last instrument addressed with the IEEE FSC. It sends the bus commands UNL, UNT, MLA(address), SDC.
[REN]
This construct sets the Remote Enable line on the IEEE-488 bus. It sends the commands REN, UNL, UNT, MLA(address).
[GTL]
This construct will set an instrument into the local control state. Typically this means that front panel controls are activated. It sends the commands UNL, UNT, MLA(address), GTL.
[LLO]
This construct typically disables front panel controls and any "Return To Local" function button that may be on an instrument. It sends the commands REN, LLO.
[TRIG]
This construct addresses and then triggers an instrument. It sends out the commands UNL, UNT, MLA(address), GET.
[IFCport number]
The IFC special construct causes an IEEE-488 Interface Clear on a specified IEEE-488 port. In MET/CAL only port 1 (the UUT port) can use IFC. The only legal option therefore is [IFC 1].
[O < filename]
The contents of the specified file are included in the IEEE command string.
If a full path is given, the file is read from this path. However if only the filename is given, the file read from the directory specified in the User Data Folder setting.

Miscellaneous

During procedure execution, the MET/CAL calibration software depends heavily on the configuration table and the information about the IEEE-488 boards in the STARTUP file needs to be absolutely correct, and does no error checking on this input. If the information is wrong, unexpected errors may occur or the system may hang. This is especially important in cases where SRQs may occur.

If you are experiencing problems of this type, check first the following values in the Startup file (refer to the information on the Startup file in the Configuration Manual for appropriate values):

  • ib_type =
  • ib_dmachan =
  • ib_intlevel =
  • ib_ioaddr =

Also check the IEEE-488 addresses in the configuration file to make sure they are correct.

When the calibration system is in the Demo Mode, no actual interactions on the IEEE bus will take place. The effect of the IEEE FSC in this mode is as follows:

  • If an IEEE input is expected, the user will be prompted to enter the expected reading.
  • The SRQ and SPL constructs are ignored.

Examples

  1.001  IEEE         [@124]VR1?[I][D500]?[I]
  1.002  IEEE         {[@1][MEM][MEM1][MEM2]}
  1.003  IEEE         {[@1][MEM][MEM1][MEM2]}
  1.004  IEEE         {[@1][127][D5000][T15000]}
  1.005  IEEE         [SRQ 30000]
  1.006  IEEE         [SPL 255]
  1.007  IEEE         [I][I$]


IEEE2 and SCPI

Interface Control FSC

Description

The IEEE2 FSC is used to control instruments which are IEEE-488.2 compliant.

The SCPI FSC is used to control instruments which are SCPI (Standard Commands for Programmable Instruments) and IEEE-488.2 compliant.

The IEEE2 and SCPI FSCs provide "built-in" sequence control and error handling that is not automatically provided by the IEEE FSC. The SCPI FSC is identical to the IEEE2 FSC with the exception of improved error reporting made possible by the SCPI error query (SYSTem:ERRor?).

Sequence and error handling is facilitated by utilization of the IEEE 488.1 Service Request (SRQ) and IEEE 488.2 standardization of certain bits in the IEEE 488.1 status byte (STB), sometimes referred to as the "serial poll byte". Specifically the IEEE2 and SCPI FSCs use the IEEE 488.2 Event Status Bit (ESB) and Message Available bit (MAV) in the STB to determine when events have completed, if an error has occurred, and/or data is available. A detailed description of the IEEE-488 sequences generated by the IEEE2 and SCPI FSCs is described below.

Both UUTs and system calibration instruments may be controlled.

The IEEE2 and SCPI FSCs may be used to control system calibration instruments which are not directly supported by MET/CAL. It may also be used to control supported instruments in cases where the built-in MET/CAL driver does not provide the required function.

Format

IEEE2 message

SCPI message

Rules

  • A maximum of 256 characters is allowed in a single IEEE2/SCPI message including the step and FSC name.
  • Leading and trailing blanks in a message are ignored.
  • A message is composed of one of more program messages separated by a semicolon.
  • A program message is viewed by MET/CAL as either a command or a query.
  • A program message is query if a question mark '?' occurs anywhere is the program message.
  • A query causes the instrument to put a response in its output buffer, a command does not.
The IEEE-488.2 Trigger Command ("*TRG") performs the same function as the IEEE-488.1 Group Execute Trigger command (GET).

IEEE-488.1 GET causes all listening devices to perform a predefined action.

Therefore it is entirely possible that an instrument will perform an action that includes a query when it receives *TRG. However since *TRG does not contain a question mark MET/CAL will handle *TRG as a command, not as a query and a query error or bus timeout will occur.

If *TRG generates a response, you must do one of the following:

  1. Use an alternate command sequence to trigger the response.

    1.001 SCPI INIT;:FETCH?[I$]

  2. Use the Group Execute Trigger special construction [TRIG] to trigger the response.

    1.001 SCPI [TRIG][I$]

  3. Use the IEEE FSC in lieu of the IEEE2 or SCPI FSCs.

    1.001 IEEE *TRG[I$]

  • The order of program messages must uphold the syntax and semantic rules of IEEE-488.2 (and SCPI for the SCPI FSC).
  • The order of program messages must uphold and any device dependent rules imposed by the instrument.
  • A command must not follow a query without first executing an input special construction ([I], [I!], or [I$]).

Correct:

1.001 SCPI *RST;*IDN?[I$]

or

1.001 SCPI *IDN?[I$]*RST

Incorrect (this sequence will cause a query error):

1.001 SCPI *IDN?;*RST[I$]

SCPI FSC only

At most one query may follow one or more commands prior to an input special construction ([I], [I!], or [I$]).

Allowed:

1.001 SCPI VOLT:DC:RANG:AUTO ON;:VOLT:DC:RANG?[I$]

or

1.001  SCPI         VOLT:DC:RANG:AUTO ON
1.001  SCPI         VOLT:DC:RANG?;RANG:AUTO?[I$]

Not Allowed:

1.001 SCPI VOLT:DC:RANG:AUTO ON;:VOLT:DC:RANG?;RANG:AUTO?[I$]

IEEE2 or SCPI Special Constructions as Part, or All of a Command or Query

The following special constructions may be used in an IEEE2/SCPI statement as part, or all of a command or query. When the special construction is evaluated the result becomes part of the current IEEE-488.2 or SCPI command or query being assembled.

[MEM] | add value of register MEM
[MEM1] | add value of register MEM1
[MEM2] | add value of register MEM2
[Mnreg] | add value of numeric register
[Lnreg] | add value of local numeric register
[number] | add number (ASCII)
[SREGnreg] | add value of string register to command or query
[Xhex list] | add values (specified in ASCII hex format)
[V variable] | add value of variable

IEEE2 or SCPI Special Constructions

The following special constructions may be used in an IEEE2/SCPI statement. To perform the operation described. When any of these special constructions is encountered, any pending command or query being assembled is first sent to the instrument before the special construction is executed.

[@address] | select address as current address
[SDC] | sends a Selected Device Clear to current address
[Sinter-byte delay] | sets delay between transmitted characters
[Ddelay] | delay execution for delay milliseconds When using the DELAY special construction, the IEEE2 and SCPI commands are executed after the DELAY time has elapsed
[GTL] | puts an instrument into local control state
[IFC port] | causes an Interface Clear on specified port
[I] | read number from current address, store in MEM
[I!] | read from current address, discard data
[I$] | read string from current address, store in MEM2
[I > filename] | read from current address, write to file
[I >> filename] | read from current address, append to file
[LLO] | disable instrument front panel controls
[O file] | read from file, write to current address
[REN] | sets the Remote Enable line on the IEEE-488 bus
[Tnumber] | sets bus and "wait for SRQ" timeout to number milliseconds
[TRIG] | triggers instrument at current address

IEEE2 or SCPI, Special Constructions Not Allowed

The following special constructions which may be used in an IEEE statement, are not allowed in an IEEE2 or SCPI statement:

[EOI ON|OFF] | enable/disable assertion of EOI on a write
[SPL mask] | serial polls current address
[SRQ timeout,mask] | wait for IEEE-488 Service Request
[SRQ ON|OFF] | enable/disable UUT Service Request processing
[TERM number] | sets terminator character to number (ASCII)
[TERM 'c'] | sets terminator character to c (character)
[TERM CR] | sets terminator character to Carriage Return
[TERM LF] | sets terminator character to Line Feed
[TERM NONE] | indicates there is no terminator character
[TERM OFF] | indicates there is no terminator character

Curly Braces

{text} send braced text to result file as well
Special constructions should not be enclosed in { }. If a special construction [ ] is enclosed in { }, the unevaluated special construction will written directly to the results.

Example:

1.001  MATH         M[1] = 2
1.002  SCPI         {INP[M2]:SLOPE NEG}

The IEEE-488 bus command will be "INP2:SLOPE NEG", however the string written to the results will be "INP2[M2]:SLOPE NEG".

See IEEE FSC for a detailed description of special constructions.

Message Processing

Each message is processed from left to right. A string of characters is assembled either directly from the characters in the message or evaluated special constructions until one of the command or query terminating special constructions is encountered or the end of the statement is reached. The assembled string of characters is then divided into individual program messages. A program message is one or more characters separated by a semicolon as described in the IEEE-488.2 standard.

Each program message is evaluated to determine if it is a command or a query. A query is any program message that contains a question mark "?". All other program messages are assumed to be commands. Sequential commands and sequential queries are then re-assembled in to a separate command string and query string. Command strings and query strings are then sent to the instrument in separate End-Or-Identify (EOI) terminated write operations. The following examples show how the resulting command and query strings are executed by the IEEE2 and SCPI FSCs.

Examples

Definitions

The following IEEE-488.2 mnemonics are used in the examples in this section.

SRQ | Service Request
SRE | Service Request Enable register
STB | Status Byte
RQS | bit 6 - Request Service
ESB | bit 5 - Event Status Bit
MAV | bit 4 - Message Available
ESE | Event Status Enable register
ESR | Event Status Register
CME | bit 5 - Command Error
EXE | bit 4 - Execution Error
DDE | bit 3 - Device Dependent Error
QYE | bit 2 - Query Error
OPC | bit 0 - Operation Complete

Simple Command (Fluke 55xxA and 57xxA Calibrators)

1.001 IEEE2 OUT 1V,1kHz;OPER

Processing:

  1. Break message in to individual program messages.

    2. OUT 1V,1kHz

    OPER

  2. Re-assemble individual command and query strings. In this case only commands are present.

    3. OUT 1V,1kHz;OPER

  3. Assemble string to send to the instrument.

    4. *CLS;*SRE 96;*ESE 61;OUT 1V,1kHz;OPER;*OPC

    *CLS clears status registers and output buffer (see IEEE-488.2).

    *SRE 96 sets the SRE to RQS (64) and ESB (32).

    *ESE 61 sets the ESE to CME (32), EXE (16), DDE (8), QYE (4), and OPC (1).

    *OPC sets OPC when all pending operations are complete.

  4. Wait for an SRQ. The Fluke 55xxA and 57xxA calibrators will set OPC and assert a SRQ when their output is settled. If an SRQ does not occur within 15 seconds (default), display an error message.
  5. If an SRQ occurred, serial poll the instrument to which the command was sent to determine if it was the one requesting service.
  6. If the instrument was the device that asserted the SRQ check to see if the ESB is set in the STB. If not, display an error.
  7. If ESB is set in the STB, send *ESR? to read the ESR.
  8. If any of CME, EXE, DDE, or QYE is set, an error has occurred. If this is the IEEE2 FSC, display an appropriate error message. If this is the SCPI FSC, send SYST:ERR? and display the returned message until the instrument returns "0,"No error"".
  9. If no error bits are set in the ESR, check to see if the OPC bit is set.
  10. If OPC is not set display an error.
  11. If OPC is set, proceed with execution of the next procedure statement.

Simple Query (IEEE-488.2 Identification Query)

1.001 IEEE2 *IDN?[I$]

or

1.001 SCPI *IDN?[I$]

Processing:

  1. Break message in to individual program messages:

    2. *IDN?

  2. Re-assemble individual command and query strings:

    3. *IDN?

  3. Assemble string to send to the instrument:

    4. *CLS;*SRE 112;*ESE 60;*IDN?

    *CLS clears status registers and output buffer (see IEEE-488.2).

    *SRE 112 sets the SRE to RQS (64), ESB (32), and MAV (16).

    *ESE 60 sets the ESE to CME (32), EXE (16), DDE (8), and QYE (4).

  4. Wait for an SRQ. If an SRQ does not occur within 15 seconds (default), display an error message.
  5. If an SRQ occurred, serial poll the instrument to which the command was sent to determine if it was the one requesting service.
  6. If the instrument was the device that asserted the SRQ check to see if MAV is set in the STB.
  7. If MAV is set in the STB, read the contents of the output buffer.
  8. If ESB is set in the STB, send *ESR? to read the ESR.
  9. If any of CME, EXE, DDE, or QYE is set, an error has occurred. If this is the IEEE2 FSC, display an appropriate error message. If this is the SCPI FSC, send SYST:ERR? and display the returned message until the instrument returns "0,"No error"".
  10. If the MAV bit is set in the STB, store string read from the device in step 7 to memory register MEM2.
  11. Execute the [I$] special construction.
    • If MAV is set in the STB, copy the string read from the device in step 7 to memory register MEM2.
    • If MAV is not set display an error.

Command and Query (IEEE-488.2 Reset and Self-Test Query)

  1.001  MATH         MEM = 1
  1.002  IEEE2        *RST;*TST?[I]
  1.003  EVAL   -e MEM == 0 : Self Test

or

  2.001  MATH         MEM = 1
  2.002  SCPI         *RST;*TST?[I]
  2.003  EVAL   -e MEM == 0 : Self Test

Processing:

  1. Break message in to individual program messages.

    2. *RST

    *TST?

  2. Re-assemble individual command and query strings.

    3. *RST

    *TST?

  3. Assemble string to send to the instrument (see "Simple Command" above).

    4. *CLS;*SRE 96;*ESE 61;*RST;*OPC

  4. Wait for an SRQ. If an SRQ does not occur within 15 seconds (default), display an error message.
  5. If an SRQ occurred, serial poll the instrument to which the command was sent to determine if it was the one requesting service.
  6. If the instrument was the device that asserted the SRQ check to see if the ESB is set in the STB. If not, display an error.
  7. If ESB is set in the STB, send *ESR? to read the ESR.
  8. If any of CME, EXE, DDE, or QYE is set, an error has occurred. If this is the IEEE2 FSC, display an appropriate error message. If this is the SCPI FSC, send SYST:ERR? and display the returned message until the instrument returns "0,"No error"".
  9. If no error bits are set in the ESR, check to see if the OPC bit is set.
  10. If OPC is not set display an error.
  11. If OPC is set, proceed with execution of the query.
  12. Assemble string to send to the instrument (See "Simple Query" above):

    13. *CLS;*SRE 112;*ESE 60;*TST?

  13. Wait for an SRQ. If an SRQ does not occur within 15 seconds (default), display an error message.
  14. If an SRQ occurred, serial poll the instrument to which the command was sent to determine if it was the one requesting service.
  15. If MAV is set in the STB, read the contents of the output buffer.
  16. If ESB is set in the STB, send *ESR? to read the ESR.
  17. If any of CME, EXE, DDE, or QYE is set, an error has occurred. If this is the IEEE2 FSC, display an appropriate error message. If this is the SCPI FSC, send SYST:ERR? and display the returned message until the instrument returns "0,"No error"".
  18. If the MAV bit is set in the STB, store string read from the device in step 7 to memory register MEM2.
  19. Execute the [I] special construction.
    • If MAV is set in the STB, search the string read from the device in step 15 for the first occurrence of a NR1, NR2, or NR3 number. Convert the NRx numeric string to a floating number and store in memory register MEM.
    • If MAV is not set display an error.

Considerations:

In this example if self test fails, an Execution Error (EXE) or Device Dependent Error (DDE) will occur which results in an SRQ. The SRQ will cause an error message to be displayed as described in step 17 above. However the SRQ will also terminate execution of the statement and the input special construction [I] will not be executed and MEM will not be updated. This is why MEM is set to 1 prior to the IEEE2 or SCPI FSC. Therefore if the operator selects Advance in the post test dialog displayed after the error messages are displayed, the EVAL statement generates a FAIL result. If self test passes, the instrument returns a 0 and the EVAL statement generates a PASS result.


PORT

Interface Control FSC

Description

The PORT FSC is used to transfer data through serial (RS232-C) ports.

Serial ports which may be used are COM1, COM2, COM3, COM4, ..., COM16, COM5500, COM5502E, COM5502A, COM5520, COM5522, COM5800, and COM5820.

  • "COM5500" designates the 5500A UUT port, and is available only if the system includes a Fluke 5500A.
  • "COM5502E" designates the 5500A UUT port, and is available only if the system includes a Fluke 5502E.
  • "COM5502A" designates the 5500A UUT port, and is available only if the system includes a Fluke 5502A.
  • "COM5520" designates the 5520A UUT port, and is available only if the system includes a Fluke 5520A.
  • "COM5522" designates the 5522A UUT port, and is available only if the system includes a Fluke 5522A.
  • "COM5800" designates the 5800A UUT port, and is available only if the system includes a Fluke 5800A.
  • "COM5820" designates the 5820A UUT port, and is available only if the system includes a Fluke 5820A.

Availability of the other serial ports depends on the PC. Many PCs have COM1 and COM2. In some cases it may be possible to use a USB to serial converter to create virtual COM ports in addition to the built-in COM ports.

Format

PORT message

Rules

Default Port

The Default Port is set by selecting "Default Serial Port" under the "Configure" menu item in the MET/CAL Editor and MET/CAL Runtime applications. The Default Port may be COM1, COM2, COM3, COM4, ..., COM16, COM5500, COM5502E, COM5502A, COM5520, COM5522, COM5800, COM5820, or NONE. The default port is used by PORT statements in procedures which do not otherwise specify a serial port.

Default Configuration

Default configuration for all serial ports except COM5500, COM5502E, COM5502A, COM5520, COM5522, COM5800, and COM5820 is maintained by Windows. This information may be accessed or modified by selecting "Ports" in the Windows "Control Panel".

If the default serial port is COM5500, COM5502E, COM5502A, COM5520, COM5522, COM5800, or COM5820, there is no provision for specifying a default configuration. In other words, the default is the setting maintained by the corresponding Fluke calibrator (5500A, 5502E, 5502A, 5520A, 5522A, 5800A, or 5820A).

When a MET/CAL procedure executes, each serial port required by the procedure is initially set to the specified default configuration.

PORT Statement

The message of each PORT statement specifies one or both of the following:

1. Data to be written to the currently addressed serial port.

2. Special constructions which control read from, configuring or addressing a serial port, or provide functions not related to the serial port. Special constructions are delimited by square brackets ('[' ... ']').

The body of each PORT line may contain up to 240 characters. A PORT statement may consist of multiple PORT lines.

There are two ways to indicate that a line is a continuation line. The first way is to assign the same step number to consecutive PORT lines. The second way is to mark the line as a continuation line by using the Edit : Continue function (F6) in the MET/CAL editor. (The procedure compiler will then automatically assign identical step numbers to continuation lines.)

Output Messages

Alphanumeric characters which are not part of a special construction are written directly to the serial port.

Example:

"PORT abc[13]"

causes the string "abc", followed by a Carriage Return terminator, to be written to the UUT.

Message Termination

Termination of Input Messages:

By default, MET/CAL considers any character which precedes the space character (HEX 20) in the ASCII sequence to be a message terminator. The termination character is usually a CR (Carriage Return) or LF (Linefeed). By using the TERM special construction, described below, the procedure writer can specify a single character terminator. A terminator specified using the TERM special construction remains in effect until it is changed or reset, and affects all serial I/O controlled by PORT statements in the procedure, even if more than one serial port is used. It does not affect serial I/O done by MET/CAL's built-in device drivers, nor does it affect serial I/O specified in RESET statements.

Termination of Output Messages:

Message termination depends on the requirements of the serial device. In general, the message must be terminated by a CR or LF, or both. This may be accomplished by including the necessary terminators in the output message using the special constructs:

  • [13] for CR
  • [10] for LF

Another way to specify the output terminator is to use the "OTERM" special construction." A terminator specified using the OTERM construction applies to all subsequent serial output using PORT statements with the executing procedure (including any called subprocedures), until the output terminator is changed or reset.

Braces and Brackets

Braces ('{' and '}') and square brackets ('[' and ']') cannot be entered literally, since they are used to define special constructions for the PORT FSC (see below). Use the [numeric] special construction (described below) to include braces and brackets in the output message.

(The [Xhex list] construction may also be used for this purpose.)

Including Brace Data in Results

Text in a PORT statement enclosed in braces is copied literally to the results file. Special constructions embedded in the brace data are not evaluated before the enclosed text is transferred to the results file.

Example:

PORT {abc[MEM]xyz}

The literal string "abc[MEM]xyz" is written to the results file. [MEM] is not replaced with the value of MEM.

Special Constructions

The PORT FSC supports the following special constructions:

[@port] | select port as current port
[CLOSE] | close the current port
[CLR] | flush receive queue of current port
[CLR ON|OFF] | enable/disable auto flush of receive queue
[Ddelay] | delay execution for delay milliseconds When using the DELAY special construction, the PORT command is executed after the DELAY time has elapsed
[I] | read number from current port, store in MEM
[I$] | read string from current port, store in MEM2
[I > file] | read from current port, write to file
[I >> file] | read from current port, append to file
[I!] | read from current port, discard data
[IB counttimeout]] | binary read [IB count timeoutfile]] - binary read, write to file
[IB counttimeoutfile]] | binary read, append to file
[Lnreg] | write value of local numeric register nreg to current port
[Mnreg] | write value of global numeric register nreg to current port
[MEM] | write value of register MEM to current port
[MEM1] | write value of register MEM1 to current port
[MEM2] | write value of register MEM2 to current port
[numeric] | write number (ASCII) to current port
[O file] | read from file, write to current port
[OTERM n|'c'|CR|LF|CRLF|NONE] | set output terminator
[Pparams] | configure port
[REOPEN] | close and re-open current port
[Ssreg] | write value of string register sreg to current port
[SREGsreg] | write value of string register sreg to current port
[Ttimeout] | set timeout for current port
[TERM n|'c'|CR|LF|NONE|OFF] | set input terminator
[Vvariable] | write value of variable to current port
[Xhex list] | write hex values to current port Each special construction is described in detail below.

Port Addressing

The [@port] special construction is used to select the current port.

For example, the statement "PORT [@COM1]abc[@COM2]xyz" first writes "abc" to COM1, then write "xyz" to COM2.

port may be COM1, COM2, COM3, COM4, ..., COM16, COM5500, COM5502E, COM5502A, COM5520, COM5522, COM5800, COM5820, or a valid device alias. Device aliases are specified in the System Configuration File (usually named "config.dat"). (Type F12 in the MET/CAL Editor to modify the system configuration.)

Like the IEEE, IEEE2, and SCPI FSCs, the PORT FSC distinguishes between the UUT port and the system port. If the [@port] construction specifies a literal COM port name (e.g., COM1), the specified port becomes the UUT port and the system port. All subsequent serial I/O performed by PORT statements in the current procedure will use the specified port (until changed using a subsequent [@port] special construction). On the other hand, if the [@port] specifies a port by way of an alias, only the system port is changed. This address remains in effect only for the current PORT statement (which may be a multi-line statement). The following example clarifies the distinction:

  1.001  PORT         [@COM1]aaa
  1.002  PORT         [@45]bbb
  1.002  PORT         ccc
  1.003  PORT         ddd

The procedure above causes the following sequence of events to occur:

  1. When the first line executes, "aaa" is written to COM1.
  2. When the second line executes, "bbb" is written to the device whose alias is "45".
  3. When the third line executes, "ccc" is written to the device whose alias is "45". Note that this line is a continuation line.
  4. When the last line executes, "ddd" is written to COM1. Since line 1.003 begins a new PORT statement, and does not specify a serial port address, the current address returns to the UUT port specified in 1.001.

When a procedure begins execution, the UUT port is the port designated by the Default Port setting. All serial I/O controlled by PORT statements refers to this default port, unless the procedure specifies otherwise.

Example:

  1.001  PORT         aaa
  1.002  PORT         [@45]bbb
  1.003  PORT         ccc
  1.004  PORT         [@COM1]ddd
  1.005  PORT         eee

Suppose the Default Port is COM2. The procedure above causes the following sequence of events to occur:

  1. When 1.001 executes, "aaa" is written to COM2 (the default port).
  2. When 1.002 executes, "bbb" is written to the device whose alias is "45".
  3. When 1.003 executes, "ccc" is written to COM2 (the default port).
  4. When 1.004 executes, "ddd" is written to COM1. COM1 becomes the current UUT port.
  5. When 1.005 executes, "eee" is written to COM1, which is now the current UUT port (as a result of 1.004).

Clearing the Input Buffer

The [CLR] special construction causes the serial port input buffer for the current port to be immediately cleared. Any unread characters in the input buffer are simply discarded.

Note on UUT-Generated Prompts:

Some UUTs may use a protocol designed for communication with a terminal, rather than under program control. Such UUTs may generate a "ready-for-command" prompt string. In such cases the [CLR] special construction can be used to flush the input buffer. An alternative to the [CLR] construction is to use [I!] to simply read (and discard) the prompt string. This method may be better than [CLR] in cases where timing is uncertain and it is necessary to wait for the prompt string to become available.

Enabling / Disabling Automatic Input Buffer Clearing

The [CLR OFF] special construction is used to disable automatic clearing of the input buffer after each terminated message is read.

[CLR OFF] is the default. That is, each procedure begins execution with automatic clearing disabled.

The [CLR ON] special construction is used to enable automatic clearing of the serial port input buffer after each terminated message is read.

A [CLR ON] or [CLR OFF] special construction remains in effect until procedure execution terminates, or a subsequent [CLR ON] or [CLR OFF] special construction is executed.

[CLR ON] is supported for compatibility with previous versions of MET/CAL. Procedure writers using the PORT FSC should be aware that it may be difficult to obtain reliable results when automatic buffer clearing is enabled. The difficulty is due to a lack of synchronization between clearing the input buffer and reading characters sent by the serial instrument. In other words, at the time the buffer is cleared, some or all of the characters may not yet have been read. Timing depends on the baud rate, the speed of the PC, and other hardware and software parameters.

The best way to deal with a serial instrument which sends messages containing embedded terminators is to leave automatic buffer clearing disabled ([CLR OFF]) and explicitly read each terminated data message.

Example:

Suppose the UUT response is:

90E-2<CR><LF>=><CR><LF>

The Fluke 45 is an example of an instrument which sends such a response. From the Fluke 45's point of view the response contains two terminated messages. The terminator is <CR><LF>. Notice, however, that the response is seen by MET/CAL as 4 distinct messages:

  1. 90E-2<CR>
  2. <LF>
  3. =><CR>
  4. <LF>

A MET/CAL procedure fragment which illustrates how to deal with this response:

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
  1.001  HEAD         {DIRECT VOLTAGE PERFORMANCE VERIFICATION}
  1.002  PORT         TRIGGER 3;VDC;RATE S;RANGE 1[10]
  1.003  DISP         [32] Connect 5500A and UUT as follows.
  1.003  DISP         [32]    5500A NORMAL HI to 45 V Ohm
  1.003  DISP         [32]    5500A NORMAL LO to 45 COM
  1.004  5500         0.000mV                                           S  2W
  1.005  PORT         *TRG;VAL1?[10][I]
  1.006  MATH         MEM = MEM * 1000
  1.007  MEMCX  100   0.000mV        0.006U

  2.001  5500         90.000mV                                          S  2W
  2.002  PORT         [CLR]*TRG;VAL1?[10][I]
  2.003  MATH         MEM = MEM * 1000
  2.004  MEMCX  100   90.000mV       0.024U

In this example the UUT is a Fluke 45. The first PORT statement sets up the UUT. The seconds PORT statement (4.005) triggers a reading and reads the response. The second 5500 setup statement (5.001) provides a sufficient delay so that when the third PORT statement (5.002) executes the remaining characters sent by the Fluke 45 (LF=CRLF) are already in the input buffer. The third PORT statement then clears the input buffer (using the [CLR] construction), thus discarding the characters in the input buffer. At that point the third PORT statement triggers and reads a second reading.

In some procedures it may be necessary to use the delay construction in a procedure to ensure that sufficient time elapses before the [CLR] construction is executed. This depends on the baud rate, the length of the message being read from the serial instrument, and the inherent delay caused by the procedure statements between the reading of the response up to the first terminator and triggering the next response.

Delay

The special construction [Dnumeric] is used to specify a delay in milliseconds. The specified number of milliseconds must be between 0 and 3600000. When MET/CAL evaluates a [Dnumeric] special construction it simply pauses for the specified number of milliseconds before proceeding with any subsequent input or output specified in the PORT statement. In MET/CAL V6.00 and earlier, the maximum delay is 32767 ms. V6.01 or later is required for delays from 32768 ms to 3600000 ms.

Example:

PORT CMD1[13][D1000][I]

In this example the string "CMD1", followed by a CR, is written to the current port. A one second delay then occurs, after which a value is read from the device attached to the current port.

Numeric Input

The [I] special construction is used to perform numeric input from the current serial port. When an [I] special construction is encountered in a PORT statement, MET/CAL reads a string from the serial device, strips leading non-numeric characters from the string, converts the numeric part of the string to a floating-point value, and stores the result in the global numeric memory register MEM. The prior value in MEM is overwritten. Non-numeric characters, if any, which follow the numeric portion of the string are ignored.

See also the section on message termination.

String Input

The [I$] special construction is used to perform string input from the current serial port. When an [I$] special construction is encountered in a PORT statement, MET/CAL reads a string (up to 4096 characters) from the serial device, and stores the string in the global string register MEM2. The prior contents of MEM2 are overwritten. If the input string is too long for MEM2, an error message is generated.

See also the section on message termination.

Reading from a UUT and Writing to a File

The [I >filename] special construction causes MET/CAL to read from the device connected to the current serial port, and write the characters read to the specified file. If the specified file already exists, it is overwritten. MET/CAL does not restrict the length of the input message when the [I filename] special construction is used. For complex messages which exceed the length of MEM2, this special construction can be used in conjunction with a user-written program, called by a DOS or DOSE FSC, to parse and evaluate the input string.

See also the section on message termination.

Reading from a UUT and Appending to a File

The [I filename] special construction causes MET/CAL to read from the device connected to the current serial port, and append the characters read to the specified file. If the specified file does not exist, it is created. MET/CAL does not restrict the length of the input message when the [I >filename] special construction is used. For complex messages which exceed the length of MEM2, this special construction can be used in conjunction with a user-written program, called by a DOS or DOSE FSC, to parse and evaluate the input string. See also the section on message termination.

Reading from a Serial Instrument and Discarding the Data

The [I!] construction is the same as [I$], except that the data message read from the instrument is not stored in MEM2, or any other MET/CAL register. [I!] is appropriate only when it is necessary to read and discard a data message.

Example:

PORT [@DMM]REMS;FUNC1?[10][I$][I!]

In this example, the serial instrument (a DMM with the address alias "DMM") requires a linefeed terminator. This is why the command "REMS;FUNC1?" is followed by "[10]" -- 10 is the decimal representation of the ASCII linefeed character.

The first part of the response is read into MEM2 using the [I$] construction. However, supposing the instrument terminates its message with CR (carriage return) and LF (linefeed), the LF is read and discarded using the [I!] construction.

Including Memory Register MEM in Output Messages

The special construction [MEM] causes the value of the MEM register to be included in the output message. (The value of MEM is converted to ASCII form before being written to the serial device.)

Including Memory Register MEM1 in Output Messages

The special construction [MEM1] causes the value of the MEM1 register to be included in the output message. (The value of MEM1 is converted to ASCII form before being written to the serial device.)

Including Memory Register MEM2 in Output Messages

The special construction [MEM2] causes the contents of the MEM2 string register to be included in the output message.

Including Special or Non-Printable Characters in Output Messages

The [numeric] special construction may be used to specify the decimal value of any ASCII character. This is useful for characters which have special significance to the PORT FSC (e.g., '{', '}', '[', ']'), as well as for non-printable characters (e.g., CR, LF).

Examples:

PORT [13] | write Carriage Return (CR)
PORT [10] | write Linefeed (LF)
PORT [91] | write Left Bracket ('[')
PORT [93] | write Right Bracket (']')
PORT [123] | write Left Brace ('{')
PORT [125] | write Right Brace ('}')

The [Xhex list] construction may be used to specify characters in ASCII hex format. For example, "PORT [XFFFFFF]" will cause 3 bytes, each with a decimal value of 255, to be written to the current serial port. This construction is useful for certain atypical devices which require binary programming data, and which document the programming command in ASCII hex format.

Transferring Data from a File to the UUT

The [O filename] special construction causes MET/CAL to read data from the specified file, and write it to the current serial port. This special construction may be useful when the message to be sent to the UUT is too long for MEM2 (which has a maximum string length of 4096). filename in the above special construction is to be replaced with the actual name of an MS-DOS file containing the data to be written to the UUT.

Port Configuration

The special construction [P[port,]baud rate,parity,data bits,stop bits,handshake] is used to configure a serial port. When MET/CAL evaluates a Port Configuration special construction, it overrides the default configuration parameters specified in the Windows Control Panel or, for COM5500, COM5502E, COM5502A, COM5520, COM5522, COM5800, or COM5820, in the corresponding Fluke calibrator (5500A, 5502E, 5502A, 5520A, 5522A, 5800A, or 5820A). The new configuration remains in effect until procedure termination, or until a subsequent Port Configuration special construction is executed.

  • For COM5500 the new configuration remains in effect until changed using the front panel of the Fluke 5500A or until a subsequent Port Configuration special construction for COM5500 is executed.
  • For COM5502E the new configuration remains in effect until changed using the front panel of the Fluke 5502E or until a subsequent Port Configuration special construction for COM5502E is executed.
  • For COM5502A the new configuration remains in effect until changed using the front panel of the Fluke 5502A or until a subsequent Port Configuration special construction for COM5502A is executed.
  • For COM5520 the new configuration remains in effect until changed using the front panel of the Fluke 5520A or until a subsequent Port Configuration special construction for COM5520 is executed.
  • For COM5522 the new configuration remains in effect until changed using the front panel of the Fluke 5522A or until a subsequent Port Configuration special construction for COM5522 is executed.
  • For COM5800 the new configuration remains in effect until changed using the front panel of the Fluke 5800A or until a subsequent Port Configuration special construction for COM5800 is executed.
  • For COM5820 the new configuration remains in effect until changed using the front panel of the Fluke 5820A or until a subsequent Port Configuration special construction for COM5820 is executed.

The following shows the allowed values for the 6 parameters:

port
COM1, COM2, COM3, COM4, COM5, COM6, COM7, COM8, COM9, COM10, COM11, COM12, COM13, COM14, COM15, COM16, COM5500, COM5502E, COM5502A, COM5520, COM5522, COM5800, COM5820, or blank

This parameter is optional. If omitted, the currently addressed port is configured. Specifying the port in this special construction does not select it as the current port. If port is not specified, the following comma must be omitted.

baud rate
50, 75, 110, 134, 150, 200, 300, 600, 1200, 1800, 2000, 2400, 3600, 4800, 7200, 9600, 19200, 38400, 56000, 57600, 128000, 115200, 230400, 256000

The procedure writer must ensure that the specified baud rate is compatible with the serial instrument and the PC serial interface.

If the serial port being configured is COM5500, COM5502E, COM5502A, COM5520, COM5522, COM5800, or COM5820 the baud rate is further restricted to 300, 600, 1200, 2400, 4800 or 9600. Specifying a baud rate which would be legal for COM1, COM2, COM3, COM4, ..., COM16, but is illegal for COM5500, COM5502E, COM5502A, COM5520, COM5522, COM5800, or COM5820 results in a run time error when the PORT statement is executed.

parity
'N' (none),
'E' (even),
'O' (odd),
'M' (mark),
'S' (space)
data bits
5, 6, 7, 8
stop bits
1, 2
handshake
'X' (X-ON/X-OFF)
'H' (hardware - using RTS & CTS)
'D' (hardware - using DTR & DSR)
'N' (none)
'R' (X-ON/X-OFF - with RTS line high)
The 'R' handshake code requires MET/CAL V7.11p or later.

Examples:

[P1200,N,8,1,N]

[PCOM2,9600,E,7,1,X]

If a parameter is omitted, the value is not changed. For example, "[P9600,,,,]" changes only the baud rate.

Except for the optional port designator (first parameter), the commas which separate the fields must always be specified.

Time-Out

The [Tnumber] special construction is used to set the time-out for the current port, in milliseconds. The number must be an integer between 0 and 32767. A response from the UUT is expected within the specified time.

On output, a timeout will occur if the serial device being written to fails to accept a character within the specified time.

Setting the time-out to zero ("PORT [T0]") disables the time-out, i.e., the PORT statement will never time-out. When a MET/CAL procedure starts, the time-out is initialized to zero (infinite). If it is then set by the procedure, it retains the new value until it is re-set or the procedure terminates.

For hardware handshaking, an infinite timeout on output is not supported. The receiving device must accept each character within 65535 milliseconds.

Note also that when a procedure is re-started from the editor (using Control-R), the PORT time-out is not re-initialized to zero.

Including the Value of a MET/CAL Variable in the Output Message

The special construction [V variable name] evaluates to the value of the specified variable. At run time, the variable must be present in the MET/CAL variable file (default name "VARIABLE.DAT").

Example:

PORT [V DATE$]?

Close or Re-Open Port

The special construction [REOPEN] causes the current serial port to be closed and re-opened. It is re-opened in a way which preserves the current configuration (baud rate, etc.). If the current port is not already open, or is COM5500, COM5502E, COM5502A, COM5520, COM5522, COM5800, or COM5820, the [REOPEN] construction has no effect.

This construction is supported in MET/CAL V5.0 and later.

It may be useful as a way to clear pending error conditions on UUTs with unreliable serial interfaces.

In MET/CAL V7.00 and later [REOPEN] has been improved so that it establishes the current serial port if the current serial port is not known at the time of execution of the [REOPEN] construction.

Example:

PORT [REOPEN]

The special construction [CLOSE] closes the current serial port. The port may later be opened again by using the PORT FSC to configure the port in same fashion required at the beginning of a procedure. This construction can be used for serial instruments which must be powered down during the procedure.

USB plug-and-play device disconnection should occur at the UUT end of the cable, if possible. This reduces the chance of reconnecting the USB cable to a different port on the computer, which may cause the COM port assignment to change.

Example:

  1.007  PORT         [CLOSE]
  1.008  DISP         Disconnect USB cable from PC.
  1.008  DISP
  1.008  DISP         Disconnect the UUT from mains power.
                      <perform required operations here>
  1.010  DISP         Re-connect the USB cable to the same PC USB port from
  1.010  DISP         which was previously disconnected.
  1.011  WAIT         -t 5 Waiting for Windows Plug-n-Play to update...
  1.012  PORT         [P115200,N,8,1,N][T3000][TERM LF]

Including a Numeric Register Value in Output Messages

The special constructions [M1], [M2], ..., cause the value of the specified global numeric register to be included in the output message. The special constructions [L1], [L2], ..., cause the value of the specified local numeric register to be included in the output message. (The register value is converted to ASCII before being written to the serial device.) The numeric value may include up to 12 significant digits. See the MATH FSC on-line help for more information on the numeric registers.

Example:

PORT [M5]

Including a String Register Value in Output Messages

The special constructions [S1], [S2], ..., cause the contents of the specified string register to be included in the output message. See the MATH FSC on-line help for more information on the string registers.

Example:

PORT [S12]

Including a String Register Value in Output Messages (SREG Form)

The special constructions [SREG1], [SREG2], ..., cause the contents of the specified string register to be included in the output message. See the MATH FSC on-line help for more information on the string registers.

The constructions [SREG1], [SREG2], ..., are identical to [S1], [S2], ..., and are included in the PORT FSC only for compatibility with the IEEE, IEEE2, and SCPI FSCs.

Example:

PORT [SREG23]

Specifying the Input Terminator

The TERM special construction has a number of different forms:

[TERMn] | sets input terminator to number n (ASCII)
[TERM 'c'] | sets input terminator to c (character)
[TERM CR] | sets input terminator to Carriage Return
[TERM LF] | sets input terminator to Linefeed
[TERM NONE] | sets default input terminator ( HEX 20)
[TERM OFF] | sets default input terminator ( HEX 20)

A procedure which does not specify the input terminator uses default input termination. The default is that any character less than 20 (hex) is considered an input message terminator. Thus, if a serial instrument always terminates its message with CR+LF, two input operations are required to fully read the response. The first input operation reads the response up to and including the CR (carriage return), and the second input operation reads the LF (linefeed).

A procedure which specifies an input terminator in a PORT statement does not affect serial input done by MET/CAL's built-in device drivers.

A specified input terminator does affect, however, all subsequent read operations initiated by PORT statements.

The input terminator is not specific to a particular serial port.

For example:

PORT [TERM LF]
PORT [@COM1][I$]
PORT [@COM2][I$]

In the example above, the [TERM LF] applies to input from both COM1 and COM2.

There is no interaction between the input terminator specified in a PORT statement and the input terminator for read operations set up by RESET statements. A procedure writer who wishes to use the RESET FSC to reset a user-configured serial instrument should specify the input terminator in the RESET statement for the instrument, or rely on default input termination when the RESET command is executed.

The '@' character cannot be used as an input terminator.

Specifying the Output Terminator

The OTERM special construction has a number of different forms:

[OTERM n] | sets output terminator to number n (ASCII)
[OTERM 'c'] | sets output terminator to c (character)
[OTERM CR] | sets output terminator to Carriage Return
[OTERM LF] | sets output terminator to Linefeed
[OTERM CRLF] | sets output terminator to CR + LF
[OTERM NONE] | disables the output terminator
[OTERM OFF] | disables the output terminator

A procedure which does not specify the output terminator must append the necessary terminator to each data message written to the serial device.

A procedure which specifies an output terminator in a PORT statement does not affect serial output done by MET/CAL's built-in device drivers, nor does it affect serial output done using the RESET FSC.

A specified terminator does affect, however, all subsequent write operations initiated by PORT statements. The terminator is not specific to a particular serial port.

For example:

PORT [OTERM LF]
PORT [@COM1]ABC
PORT [@COM2]DEF

In the example above, the [OTERM LF] applies to output to both COM1 and COM2. There is no interaction between the output terminator specified in a PORT statement and the output terminator set up by RESET statements. A procedure writer who wishes to use the RESET FSC to reset a user-configured serial instrument should specify the output terminator in the RESET statement for the instrument. This can be done by using the OTERM special construction, or by simply appending the required termination characters to the reset command.

Binary Read

As of version 7.20, the PORT FSC has a "binary read" capability.

Most serial instruments read and write ASCII messages, and properly terminate messages sent, usually with CR, LF, or CR-LF. For these instruments the binary read construction is not needed, and the the [I] and [I$] constructions may be used.

Binary read is useful with serial instruments that:

  1. Communicate using binary data such as 16-bit integers, 32-bit integers, and 8-byte floating point values, or
  2. do not terminate messages, or
  3. use non-standard message termination.

The syntax of the binary read construction is:

[IB count [timeout] [>[>] file name]]

where:

count | is a positive integer byte count or "*"
timeout | is a positive integer interbyte timeout in milliseconds (1 to 32767 ms)
file | is a file name

Data read using the binary read construction are stored in an internal array which is accessible using MATH FSC functions. The following MATH functions are available:

  • brb - convert 1 byte to 32-bit integer at specified byte offset
  • bri - convert 4 bytes to 32-bit integer starting at specified byte offset
  • brn - return current binary buffer byte count
  • brs - convert specified range of bytes to a string
  • brw - convert 2 bytes to 16-bit integer starting at specified byte offset
  • brx - convert specified range of bytes in binary buffer to printable hex

Refer to the MATH FSC Binary Read help topic for more information on these functions.

The count specified in a binary read ("IB") construction is the number of bytes to read.

If the number of bytes to read is variable or unknown, the count can be specified as "*". In that case MET/CAL reads until a timeout occurs. The timeout which terminates the read operation is not regarded as an error condition by MET/CAL.

The binary read construction makes use of two separate timeouts. The timeout which applies to the interval between the execution of the IB construction and the reading of the first byte from the instrument is set using the normal [T timeout] construction. The timeout that is, optionally, specified as the second parameter in an IB construction controls the interbyte timeout, i.e., the timeout between bytes read after the first byte has been read.

The difference in the two timeouts is important because having a longer timeout prior to reading the first byte allows the instrument to respond to the command which generates the instrument's response. A much shorter interbyte timeout is appropriate for subsequent bytes in the response message, however, because, once the instrument begins sending response bytes, the reading rate is controlled by the baud rate of the instrument.

Examples

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
  2.005  PORT         [P1200,N,8,1,N][T3000]V?[I]
  2.006  PORT         [D1000]Get[I]


VISA

Description

The VISA FSC is used to control UUT's that can be accessed using the National Instruments Visa (NI-VISA).

The VISA FSC is used to control the UUT when specific reference to the remote control interface used is not desired. Example: The UUT has a number of remote control interface options, GPIB (IEEE-488), RS-232, USB, and LAN (Ethernet). For this case, it might be desirable to write a single procedure for the UUT that would work regardless of which remote control option were selected.

Supported interfaces include:

  • GPIB (IEEE-488)
  • Serial (RS-232)*
  • LAN "TCP/IP" (Ethernet), VXI-11 compliance required
  • USB, USBTMC compliance required

When the VISA FSC is used to control a UUT with interface options that include RS-232 the VISA statement must include an output terminator (input terminator for the UUT). Since the same input data parser is typically used for the input data stream, regardless of the interface, including an output terminator will have NO adverse effect even when GPIB or USBTMC is used. See OTERM special construction below.

Format

VISA message

Rules

  • A VISA statement may include multiple lines.
  • A maximum of 240 characters is allowed in a single VISA message. Characters above ASCII 128 will count as 2 characters towards the line length limit of 256.
  • Leading and trailing blanks in a message are ignored.
  • When an VISA statement is executed, characters in the message which are not part of a special construction (enclosed by square brackets) are written to the currently addressed device.
  • The following special constructions may be used in a VISA statement:
Construction | Description
{text} | Send text to result file as well as UUT
[Ddelay] | Delay execution for delay milliseconds When using the DELAY special construction, the VISA command is executed after the DELAY time has elapsed
[MEM] | Write value of register MEM to UUT
[MEM1] | Write value of register MEM1 to UUT
[MEM2] | Write contents of register MEM2 to UUT
[Mnreg] | Write value of numeric register to UUT
[Lnreg] | Write value of local numeric register to UUT
[Snreg] | Write contents of string register to UUT
[SREGnreg] | Same as [Snreg]
[V variable] | Write value of variable to UUT
[number] | Write number (ASCII) to UUT
[X hex list] | Write bytes (ASCII hex format) to UUT
[OTERM CR] | Send carriage return after data message
[OTERM LF] | Send linefeed following message
[OTERM CRLF] | Send CR and LF following message
[OTERM 'c'] | Send character c following message
[OTERM byte val] | Send number ASCII ollowing message
[OTERM NONE] | Turn off OTERM
[I] | Read number from UUT, store in MEM
[I$] | Read string from UUT, store in MEM2
[I!] | Read from UUT and discard
[TERM CR] | Set input terminator to Carriage Return
[TERM LF] | Set input terminator to Line Feed
[TERM 'c'] | Set input terminator to c (character)
[TERM byte val] | Set input terminator to byte val
[TERM NONE] | Indicate there is no terminator character
[TERM OFF] | Indicate there is no terminator character
[Tnumber] | Set timeout to number milliseconds

Constructions [Ddelay], [MEM], [MEM1], [MEM2], [number], [V variable], and {text} are used by a number of FSCs and are described in Special Constructions.

Except for [Mnreg], [Lnreg], and [SREGsreg], the rest of the constructions in the list above are shared with the IEEE, IEEE2, SCPI, and PORT FSCs.

Descriptions of these constructions, including [Mnreg], [Lnreg], and [SREGsreg] are provided in the sections below.

Input Special Constructions

The following special constructs are available which perform an input from the UUT.

[I]

The input string is scanned for a numeric value. The numeric value is stored in memory register MEM. Leading non-numeric characters are skipped. Trailing non-numeric values are ignored. If no numeric value is found MEM is set to zero.

Examples:

Input string | MEM
"DCV100mV" | 100
"DCV" | 0
"0.1" | 0.1
"10uV,1kHz" | 10E-6
MEM is a double precision floating point register, not a string. The presentation in the second column above is only symbolic.

[I$]

The input is an alphanumeric string, and it is stored in memory register MEM2, overwriting the current contents of that memory register. The MEM2 register is 4096 characters long.

[I!]

This construction is the same as [I$], except that the data message read from the instrument is not stored in MEM2, or any other MET/CAL register. [I!] is appropriate only when it is necessary to read and discard a data message.

[I > filename]

This special construct stores the returned information in a file with the name filename. Any existing file is overwritten. This construct should be used, if the returned string is expected to be longer than 4096 characters. The DOS FSC is used to call a program, which processes the string and returns relevant information in the MET/CAL memory registers.

If a full path is given, the file is written to this path. However if only the filename is given, the file is written to the User Data Folder specified in the MET/CAL Configuration settings.

[I >> filename]

This special construct appends the returned information to a file with the name filename. If the file does not exist, then it will be created. This construct should be used, if the returned string is expected to be longer than 4096 characters. The DOS FSC is used to call a program which processes the string and returns relevant information in the MET/CAL memory registers.

If a full path is given, the file is written to this path. However if only the filename is given, the file is written to the User Data Folder specified in the MET/CAL Configuration settings.

  • The TERM special construction is used to define the terminator character for data messages sent by the UUT to the PC. This construction does not affect messages written by the PC to the UUT.

The specified terminator remains in effect for the duration of the procedure, unless it is explicitly changed under procedure control. The terminator applies to all subsequent VISA statements.

Valid TERM special constructions are:

[TERM CR]

Specifies that the terminator character is Carriage Return. This is equivalent to [TERM 13].

[TERM LF]

Specifies that the terminator character is Line Feed. This is equivalent to [TERM 10].

[TERM 'c']

'c' is any printable character other than '@'. There must be exactly one character between the quotes, i.e. one cannot say: [TERM ' x '] and expect the blanks to be ignored. The case of the character between quotes IS case sensitive (in general special constructs are case insensitive).

[TERM number]

number is a decimal integer between 0 and 255, but not 64.

[TERM NONE] and [TERM OFF]

Specifies that there is no terminator character.

For GPIB, USBTMC, and VXI-11, the input will terminate when EOI is asserted. For RS-232, input will terminate upon receipt of any character with a value < 20 hex.

Output Special Constructions

  • Alphanumeric characters, not part of a special construct will be sent to the UUT. The strings are always terminated by a EOI when the interface is GPIB, TCP/IP (VXI-11), and USBTMC.
  • Braces ('{' and '}') or square brackets ('[' and ']') can not be entered literally, since they are used to define special constructs for the VISA FSC (see the following paragraph).

  • The following other special constructs may be used:

    {text}

    Text in braces in addition to being used in the VISA command string, is copied literally into the results file (without numerical substitutions for [MEM] for example).

    [Ddelay]

    The [Ddelay] special construct will cause a delay of the message line by delay milliseconds (delay is between 0 and 3600000).

    [MEM], [MEM1], and [MEM2]

    The contents of memory register MEM, MEM1 or MEM2 will be included in the VISA command string.

    [Mnreg]

    The value of the specified global numeric register is included in the VISA command string.

    The constructions [M1], [M2], ..., refer to the global numeric registers. Up to 12 significant digits are included in the value. Refer to the MATH FSC on-line help for additional information on the global numeric registers.

    [Lnreg]

    The value of the specified local numeric register is included in the VISA command string.

    The constructions [L1], [L2], ..., refer to local numeric registers. Up to 12 significant digits are included in the value. Refer to the MATH FSC on-line help for additional information on the local numeric registers.

    [S<sreg>] and [SREG<sreg>]

    The contents of the specified string register are included in the VISA command string.

    The constructions [S1], [SREG1], [S2], [SREG2], ..., refer to the string registers. Refer to the MATH FSC on-line help for additional information on the string registers.

    [V <variable name>]

    This construct evaluates to the value of the named variable.

    Example: VISA [V Cmd]

    [number]

    The character with the ASCII value of number will be included in the VISA command string.

    The [number] construct should be used to output braces and brackets.

    Example:

    Special Character Construction Output
    [91] [
    [93] ]
    [123] {
    [125] }
  • The OTERM special construction is used to define the terminator character to be sent following the data messages sent to the UUT. This construction does not affect messages written by the UUT to the PC.

The specified terminator remains in effect for the duration of the procedure, unless it is explicitly changed under procedure control. The terminator applies to all subsequent VISA statements.

Valid OTERM special constructions are:

[OTERM CR]

Specifies that a Carriage Return be sent to the UUT following each data message. This is equivalent to [OTERM 13].

[OTERM LF]

Specifies that Line Feed be sent to the UUT following each data message. This is equivalent to [OTERM 10].

[OTERM CRLF]

Specifies that Carriage Return and Line Feed be sent to the UUT following each data message.

[OTERM 'c']

<'c'> is any printable character other than '@'. There must be exactly one character between the quotes, i.e. one cannot say: "[OTERM ' x ']" and expect the blanks to be ignored. The case of the character between quotes IS case sensitive (in general special constructs are case insensitive).

[OTERM number]

number is a decimal integer between 0 and 255, but not 64.

[OTERM NONE]

Turns off a previous [OTERM CR], [OTERM LF], [OTERM CRLF], [OTERM 'c'], or [OTERM number] specification.

For GPIB, USBTMC, and VXI-11, the last character in the data message will terminatre with EOI asserted. However if a procedure written using the VISA FSC is expected to execute using RS-232 as well as GPIB, USBTMC, or VXI-11, the OTERM special construction should be used.

Timeout

[Ttimeout]

This construct sets the timeout to the specified number of milliseconds. If the timeout is set to zero, there is no timeout. The specified timeout must be between 0 and 1000000 ms. The default timeout is 15 seconds. The timeout specification affects only the current VISA FSC statement.

Examples

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
# Reset: IEEE-488.2, USBTMC-USB488, and VXI-11 which uses 488.2 commands.
  1.001  VISA         *RST
# Reset: RS-232C which uses 488.2 commands.
  1.002  VISA         [OTERM LF]*RST
# Id: IEEE-488.2, USBTMC-USB488, and VXI-11 which uses 488.2 commands.
  1.003  VISA         *IDN?[I$]
# Id: RS-232C which uses 488.2 commands.
  1.004  VISA         [OTERM LF]*IDN?[TERM LF][I$]


CON

Display Control Help

Description

The CON FSC invokes a standard connection message to prompt the operator to make a change to the UUT's connections. There are two reasons why, in some cases, an automatic connection message might be used in preference to a message generated using a DISP statement:

  • The message format is identical to the format of automatic connection messages generated by MET/CAL instrument drivers.
  • When automatic connection messages are used, MET/CAL remembers the list of current connections. This allows the automatic generation of disconnection messages when new connections are made, and also precludes the generation of redundant connection messages.

However, because automatic connection messages are worded in a general way (that is, they are not specific to a particular UUT), most procedure writers use the DISP FSC to construct messages which refer directly to the particular UUT being calibrated.

The CON FSC refers to connection messages by number. Each connection message has a number. Connection messages (and the associated numbers) are shown below in the CONNECTION MESSAGES section.

When the CON FSC is used to generate connection and disconnection messages, MET/CAL cannot verify that instruments to which connections are to be made are in a safe state. The procedure writer must ensure that instruments are in STANDBY or are not generating unsafe voltages before prompting the operator to make connections or disconnections.

Format

CON connection code message list

or

CON 0

Rules

  1. The connection code field may be '=', '+', or '-'. It determines the interpretation of the following message list as shown in the table below:

    2. '=' - message list specifies connections to be made

    '+' - message list specifies connections to be added

    '-' - message list specifies connections to be removed

    The difference between making a connection ('=') and adding a connection ('+') is that '=' first causes a disconnection message for all present connections, followed by a connection message for the new connections. '+', on the other hand, presumes that present connections are to remain, and simply generates a prompt to add the new connections.

    When the connection code is '+' or '-', the message list must be non-empty. When the connection code is '=', the message list may be empty. In this case, an empty message list causes a prompt to disconnect all present connections.

  2. The message list is a list of 1 or more connection message numbers, separated by commas.
  3. The statement "CON 0" may be used to generate a disconnection message for all connections. This statement is equivalent to "CON =".

Example:

CON =47

CON =48

CON +49

CON -48, 49

The first CON statement prompts the operator to make the connection indicated by connection message number 47. The second CON statement first causes a prompt to disconnect 47, followed by a prompt to connect 48. The third CON statement causes a prompt to connect 49. Note that, since the connection code is '+', it does not first trigger a disconnection message for 48. The fourth CON statement generates a disconnection message for 48 and 49.

Compatibility

For compatibility with previous versions of MET/CAL, the list of connection message numbers may be specified in binary-coded decimal format. Using this method, 53 is the maximum number which can be specified. Refer to 7411B or 7411C manuals for further information.

See Also

The ASK- W and V flags may be used to disable automatic connection messages. This applies to messages specified in CON statements, as well as to messages generated by MET/CAL instrument drivers. Refer to the ASK+ and ASK- FSC Reference for more information.

Examples

Additional CON FSC examples are shown below.

Example 1:

CON =9,10

Disconnect any other connection, then prompt to connect the UUT to 5100B Output and 5100B Sense (if they are not already connected).

Example 2:

CON +21

Adds a connection from the UUT to the 5450 Sense.

Example 3:

CON -21

Disconnect the UUT from the 5450 Sense.

Example 4:

CON =

CON 0

Remove all connections (both forms allowed).

Example 5:

CON 1024

Connect the UUT to 5100B Wideband (old BCD format).

Connection Messages

Message 5
UUT to CG 5001 Output using Comparator Head
Message 6
UUT to CG 5001 Output using Pulse Head
Message 7
UUT to CG 5001 TRIGGER Output
Message 8
UUT to 5100B Output Terminals using external AC Divider
Message 9
UUT to 5100B Output Terminals
Message 10
UUT to 5100B Sense Terminals
Message 11
UUT to 5100B Wideband Output
Message 12
UUT to 5220A Current Output Terminals
Message 13
5205A Output Cable to UUT
Message 14
UUT to 5200A Output Terminals
Message 15
UUT to 5200A Sense Terminals
Message 16
5215A Output Cable to UUT
Message 17
UUT to 5440B Divider Terminals
Message 18
UUT to 5440B Guard Terminal
Message 19
UUT to 5440B Output Terminals
Message 20
UUT to 5440B Sense Terminals
Message 21
UUT to 5450A Sense Terminals
Message 22
UUT to 5450A Output Terminals
Message 23
UUT to 5450A Guard Terminal
Message 25
UUT to 6060 RF Output
Message 29
UUT to 8502/5 Ohms Sense Terminals
Message 30
UUT to 8502/5 Ohms Source Terminals
Message 32
UUT to 8506A Volts Input Terminals
Message 33
UUT to 8506A Amps Input Terminals
Message 44
UUT to IEEE-488 Port 1
Message 45
UUT to COM1
Message 46
UUT to 5220A Current Output Terminals
Message 47
UUT to 5700A Output Terminals
Message 48
UUT to 5700A Sense Terminals
Message 49
UUT to 5700A Aux Current Output
Message 50
UUT to 5700A Wideband Output
Message 51
UUT to 5700A Guard Terminal
Message 52
UUT to 5700A Output Terminals using external AC Divider
Message 53
UUT to 5725A Current Output Terminals
Message 54
UUT to 5220A Current Output Terminals
Message 55
5205A Output Cable to UUT
Message 56
5215A Output Cable to UUT
Message 57
5215A Output Cable to UUT
Message 58
UUT to 8502/5 Volts Input Terminals
Message 59
UUT to 8502/5 Amps Input Terminals
Message 60
UUT to 8506A Ohms Sense Terminals
Message 61
UUT to 8506A Ohms Source Terminals
Message 62
UUT to 8842A Input Terminals using 40 kV Probe
Message 63
UUT to 8842A Input Terminals using 6 kV Probe
Message 64
UUT to 8842A Input Terminals
Message 65
UUT to 8842A Sense Terminals
Message 66
UUT to 8842A 2A and LO Input Terminals
Message 67
UUT to 3458A Input Terminals
Message 68
UUT to 3458A Sense Terminals
Message 69
UUT to 3458A 1A and LO Input Terminals
Message 70
UUT to CG 5011 Output using Comparator Head
Message 71
UUT to CG 5011 Output using Pulse Head
Message 72
UUT to CG 5011 TRIGGER Output
Message 73
UUT to PM 5191 Output
Message 74
UUT to 8920A Input
Message 75
UUT to PM 6666 Input A
Message 76
UUT to PM 6666 Input C
Message 77
UUT to PM 6666 Input A (for Ratio A/B measurement)
Message 78
UUT to PM 6666 Input B (for Ratio A/B measurement)
Message 79
UUT to PM 6666 Input A (for Time Interval A-B measurement)
Message 80
UUT to PM 6666 Input B (for Time Interval A-B measurement)
Message 81
UUT to SG 5030 OUTPUT using Leveling Head
Message 82
UUT to 5790A Input 1, reference voltage to 5790A Input 2
Message 83
UUT to 5790A Input 2, reference voltage to 5790A Input 1
Message 84
UUT to 5790A Input 1
Message 85
UUT to 5790A Input 2
Message 86
UUT to 5790A WIDEBAND Input
Message 87
UUT to 5790A Shunt Input using A40-10mA shunt & 5790A-7001 adapter
Message 88
UUT to 5790A Shunt Input using A40-20mA shunt & 5790A-7001 adapter
Message 89
UUT to 5790A Shunt Input using A40-30mA shunt & 5790A-7001 adapter
Message 90
UUT to 5790A Shunt Input using A40-50mA shunt & 5790A-7001 adapter
Message 91
UUT to 5790A Shunt Input using A40-100mA shunt & 5790A-7001 adapter
Message 92
UUT to 5790A Shunt Input using A40-200mA shunt & 5790A-7001 adapter
Message 93
UUT to 5790A Shunt Input using A40-300mA shunt & 5790A-7001 adapter
Message 94
UUT to 5790A Shunt Input using A40-500mA shunt & 5790A-7001 adapter
Message 95
UUT to 5790A Shunt Input using A40-1A shunt & 5790A-7001 adapter
Message 96
UUT to 5790A Shunt Input using A40-2A shunt & 5790A-7001 adapter
Message 97
UUT to 5790A Shunt Input using A40-3A shunt & 5790A-7001 adapter
Message 98
UUT to 5790A Shunt Input using A40-5A shunt & 5790A-7001 adapter
Message 99
UUT to 5790A Shunt Input using A40A-10A shunt & 5790A-7001 adapter
Message 100
UUT to 5790A Shunt Input using A40A-20A shunt & 5790A-7001 adapter
Message 101
UUT to PM 6680 Input A
Message 102
UUT to PM 6680 Input C
Message 103
UUT to PM 6680 Input A (for Ratio A/B measurement)
Message 104
UUT to PM 6680 Input B (for Ratio A/B measurement)
Message 105
UUT to PM 6680 Input A (for Time Interval A-B measurement)
Message 106
UUT to PM 6680 Input B (for Time Interval A-B measurement)
Message 107
UUT to 5790A SHUNT Input
Message 108
UUT to 5790A Input 1 using 792A-7004 adapter
Message 109
UUT to 5790A Input 1 using A40-10mA shunt & 792A-7004 adapter
Message 110
UUT to 5790A Input 1 using A40-20mA shunt & 792A-7004 adapter
Message 111
UUT to 5790A Input 1 using A40-30mA shunt & 792A-7004 adapter
Message 112
UUT to 5790A Input 1 using A40-50mA shunt & 792A-7004 adapter
Message 113
UUT to 5790A Input 1 using A40-100mA shunt & 792A-7004 adapter
Message 114
UUT to 5790A Input 1 using A40-200mA shunt & 792A-7004 adapter
Message 115
UUT to 5790A Input 1 using A40-300mA shunt & 792A-7004 adapter
Message 116
UUT to 5790A Input 1 using A40-500mA shunt & 792A-7004 adapter
Message 117
UUT to 5790A Input 1 using A40-1A shunt & 792A-7004 adapter
Message 118
UUT to 5790A Input 1 using A40-2A shunt & 792A-7004 adapter
Message 119
UUT to 5790A Input 1 using A40-3A shunt & 792A-7004 adapter
Message 120
UUT to 5790A Input 1 using A40-5A shunt & 792A-7004 adapter
Message 121
UUT to 5790A Input 1 using A40A-10A shunt & 792A-7004 adapter
Message 122
UUT to 5790A Input 1 using A40A-20A shunt & 792A-7004 adapter
Message 123
UUT to 5790A GUARD Terminal
Message 124
UUT to Fluke 45 Volt-Ohm-Diode and COM Input Terminals
Message 125
UUT to Fluke 45 100mA and COM Input Terminals
Message 126
UUT to Fluke 45 10A and COM Input Terminals
Message 127
UUT to Fluke 45 Volt and COM Terminals using 6 kV Probe
Message 128
UUT to Fluke 45 Volt and COM Terminals using 40 kV Probe
Message 129
5205A Output Cable to UUT
Message 130
UUT to 5500A NORMAL Output Terminals using external AC Divider
Message 131
UUT to 5500A NORMAL Output Terminals
Message 132
UUT to 5500A AUX Output Terminals
Message 133
UUT to 5500A SCOPE Output
Message 134
UUT to 5500A TRIG OUT
Message 135
UUT to 5500A GUARD Terminal
Message 136
UUT to 5500A TC Terminals
Message 137
UUT to 5500A TC Terminals using copper wire
Message 138
UUT to 5500A TC Terminals using type B thermocouple wire
Message 139
UUT to 5500A TC Terminals using type C thermocouple wire
Message 140
UUT to 5500A TC Terminals using type E thermocouple wire
Message 141
UUT to 5500A TC Terminals using type J thermocouple wire
Message 142
UUT to 5500A TC Terminals using type K thermocouple wire
Message 143
UUT to 5500A TC Terminals using type N thermocouple wire
Message 144
UUT to 5500A TC Terminals using type R thermocouple wire
Message 145
UUT to 5500A TC Terminals using type S thermocouple wire
Message 146
UUT to 5500A TC Terminals using type T thermocouple wire
Message 147
Type B Thermocouple Standard to 5500A TC Terminals
Message 148
Type C Thermocouple Standard to 5500A TC Terminals
Message 149
Type E Thermocouple Standard to 5500A TC Terminals
Message 150
Type J Thermocouple Standard to 5500A TC Terminals
Message 151
Type K Thermocouple Standard to 5500A TC Terminals
Message 152
Type N Thermocouple Standard to 5500A TC Terminals
Message 153
Type R Thermocouple Standard to 5500A TC Terminals
Message 154
Type S Thermocouple Standard to 5500A TC Terminals
Message 155
Type T Thermocouple Standard to 5500A TC Terminals
Message 156
UUT to 5500A NORMAL and AUX Terminals (3-wire configuration)
Message 157
UUT to 5725A Current Output Terminals
Message 158
UUT to PM 6681 Input A
Message 159
UUT to PM 6681 Input C
Message 160
UUT to PM 6681 Input A (for Ratio A/B measurement)
Message 161
UUT to PM 6681 Input B (for Ratio A/B measurement)
Message 162
UUT to PM 6681 Input A (for Time Interval A-B measurement)
Message 163
UUT to PM 6681 Input B (for Time Interval A-B measurement)
Message 164
UUT to PM 6685 Input A
Message 165
UUT to PM 6685 Input C
Message 166
UUT to PM 6685 Input C (for Ratio C/A measurement)
Message 167
UUT to PM 6685 Input A (for Ratio C/A measurement)
Message 168
UUT to HP 6060B Input Terminals
Message 169
UUT to HP 6063B Input Terminals
Message 170
UUT to PM 5192 Output
Message 171
UUT to PM 5193 Output
Message 172
UUT to COM2
Message 173
UUT to COM3
Message 174
UUT to COM4
Message 175
UUT to 5500A UUT serial port
Message 176
UUT to 5130A Output Terminals using external AC Divider
Message 177
UUT to 5130A Output Terminals
Message 178
UUT to 5130A Sense Terminals
Message 179
UUT to 5220A Current Output Terminals
Message 180
5205A Output Cable to UUT
Message 181
5215A Output Cable to UUT
Message 182
UUT to 5720A Output Terminals
Message 183
UUT to 5720A Sense Terminals
Message 184
UUT to 5720A Aux Current Output
Message 185
UUT to 5720A Wideband Output
Message 186
UUT to 5720A Guard Terminal
Message 187
UUT to 5720A Output Terminals using external AC Divider
Message 188
UUT to 5500A TC Terminals using type L thermocouple wire
Message 189
UUT to 5500A TC Terminals using type U thermocouple wire
Message 190
Type L Thermocouple Standard to 5500A TC Terminals
Message 191
Type U Thermocouple Standard to 5500A TC Terminals
Message 192
UUT to 34401A Input Terminals
Message 193
UUT to 34401A Sense Terminals
Message 194
UUT to 34401A 3A and LO Input Terminals
Message 195
UUT to 2000 Input Terminals
Message 196
UUT to 2000 Sense Terminals
Message 197
UUT to 2000 3A and LO Input Terminals
Message 198
UUT to 2001 Input Terminals
Message 199
UUT to 2001 Sense Terminals
Message 200
UUT to 2001 2A and LO Input Terminals
Message 201
UUT to 2002 Input Terminals
Message 202
UUT to 2002 Sense Terminals
Message 203
UUT to 2002 2A and LO Input Terminals
Message 204
UUT to 2001 Input and Sense Terminals (3-wire configuration)
Message 205
UUT to 2002 Input and Sense Terminals (3-wire configuration)
Message 206
UUT to 34420A Channel 1 using Low Thermal Input Cable
Message 207
UUT to 34420A Channel 2 using Low Thermal Input Cable
Message 208
UUT to 5500A SCOPE Output using Tunnel Diode Pulser
Message 209
UUT to SG 5050 OUTPUT using Leveling Head
Message 210
UUT to 3325B Output
Message 211
UUT to 3325B Output with 50 Ohm termination
Message 212
UUT to 5520A NORMAL Output Terminals using external AC Divider
Message 213
UUT to 5520A NORMAL Output Terminals
Message 214
UUT to 5520A AUX Output Terminals
Message 215
UUT to 5520A SCOPE Output
Message 216
UUT to 5520A TRIG OUT
Message 217
UUT to 5520A GUARD Terminal
Message 218
UUT to 5520A TC Terminals
Message 219
UUT to 5520A TC Terminals using copper wire
Message 220
UUT to 5520A TC Terminals using type B thermocouple wire
Message 221
UUT to 5520A TC Terminals using type C thermocouple wire
Message 222
UUT to 5520A TC Terminals using type E thermocouple wire
Message 223
UUT to 5520A TC Terminals using type J thermocouple wire
Message 224
UUT to 5520A TC Terminals using type K thermocouple wire
Message 225
UUT to 5520A TC Terminals using type L thermocouple wire
Message 226
UUT to 5520A TC Terminals using type N thermocouple wire
Message 227
UUT to 5520A TC Terminals using type R thermocouple wire
Message 228
UUT to 5520A TC Terminals using type S thermocouple wire
Message 229
UUT to 5520A TC Terminals using type T thermocouple wire
Message 230
UUT to 5520A TC Terminals using type U thermocouple wire
Message 231
Type B Thermocouple Standard to 5520A TC Terminals
Message 232
Type C Thermocouple Standard to 5520A TC Terminals
Message 233
Type E Thermocouple Standard to 5520A TC Terminals
Message 234
Type J Thermocouple Standard to 5520A TC Terminals
Message 235
Type K Thermocouple Standard to 5520A TC Terminals
Message 236
Type L Thermocouple Standard to 5520A TC Terminals
Message 237
Type N Thermocouple Standard to 5520A TC Terminals
Message 238
Type R Thermocouple Standard to 5520A TC Terminals
Message 239
Type S Thermocouple Standard to 5520A TC Terminals
Message 240
Type T Thermocouple Standard to 5520A TC Terminals
Message 241
Type U Thermocouple Standard to 5520A TC Terminals
Message 242
UUT to 5520A NORMAL and AUX Terminals (3-wire configuration)
Message 243
UUT to 5520A UUT serial port
Message 244
UUT to 5520A SCOPE Output using Tunnel Diode Pulser
Message 245
UUT to 5520A 20A Current Terminals
Message 246
1mV/deg C Temperature Probe to 5520A TC Terminals
Message 247
1mV/deg F Temperature Probe to 5520A TC Terminals
Message 248
1mV/%%rh Humidity Probe to 5520A TC Terminals
Message 249
UUT to 5800A Channel 1
Message 250
UUT to 5800A Channel 2
Message 251
UUT to 5800A Channel 3
Message 252
UUT to 5800A Channel 4
Message 253
UUT to 5800A Channel 5
Message 255
UUT to 5800A Channel 1 using Tunnel Diode Pulser
Message 256
UUT to 5800A Channel 2 using Tunnel Diode Pulser
Message 257
UUT to 5800A Channel 3 using Tunnel Diode Pulser
Message 258
UUT to 5800A Channel 4 using Tunnel Diode Pulser
Message 259
UUT to 5800A Channel 5 using Tunnel Diode Pulser
Message 260
UUT to 5800A Channel 1 as trigger output
Message 261
UUT to 5800A Channel 5 as trigger output
Message 262
UUT to 700P01 Differential Pressure Module
Message 263
UUT to 700P02 Differential Pressure Module
Message 264
UUT to 700P22 Differential Pressure Module
Message 265
UUT to 700P03 Differential Pressure Module
Message 266
UUT to 700P23 Differential Pressure Module
Message 267
UUT to 700P04 Differential Pressure Module
Message 268
UUT to 700P24 Differential Pressure Module
Message 269
UUT to 700P05 Gage Pressure Module
Message 270
UUT to 700P06 Gage Pressure Module
Message 271
UUT to 700P07 Gage Pressure Module
Message 272
UUT to 700P08 Gage Pressure Module
Message 273
UUT to 700P09 Gage Pressure Module
Message 274
UUT to 700PA3 Absolute Pressure Module
Message 275
UUT to 700PA4 Absolute Pressure Module
Message 276
UUT to 700PA5 Absolute Pressure Module
Message 277
UUT to 700PA6 Absolute Pressure Module
Message 278
UUT to 700PV3 Vacuum Module
Message 279
UUT to 700PV4 Vacuum Module
Message 280
UUT to 700PD2 Dual Pressure Module
Message 281
UUT to 700PD3 Dual Pressure Module
Message 282
UUT to 700PD4 Dual Pressure Module
Message 283
UUT to 700PD5 Dual Pressure Module
Message 284
UUT to 700PD6 Dual Pressure Module
Message 285
UUT to 700PD7 Dual Pressure Module
Message 286
UUT to 700P29 High Pressure Module
Message 287
UUT to 700P30 High Pressure Module
Message 288
UUT to 700P31 High Pressure Module
Message 289
700P01 Differential Pressure Module for zero measurement
Message 290
700P02 Differential Pressure Module for zero measurement
Message 291
700P22 Differential Pressure Module for zero measurement
Message 292
700P03 Differential Pressure Module for zero measurement
Message 293
700P23 Differential Pressure Module for zero measurement
Message 294
700P04 Differential Pressure Module for zero measurement
Message 295
700P24 Differential Pressure Module for zero measurement
Message 296
700P05 Gage Pressure Module for zero measurement
Message 297
700P06 Gage Pressure Module for zero measurement
Message 298
700P07 Gage Pressure Module for zero measurement
Message 299
700P08 Gage Pressure Module for zero measurement
Message 300
700P09 Gage Pressure Module for zero measurement
Message 301
700PA3 Absolute Pressure Module for zero measurement
Message 302
700PA4 Absolute Pressure Module for zero measurement
Message 303
700PA5 Absolute Pressure Module for zero measurement
Message 304
700PA6 Absolute Pressure Module for zero measurement
Message 305
700PV3 Vacuum Module for zero measurement
Message 306
700PV4 Vacuum Module for zero measurement
Message 307
700PD2 Dual Pressure Module for zero measurement
Message 308
700PD3 Dual Pressure Module for zero measurement
Message 309
700PD4 Dual Pressure Module for zero measurement
Message 310
700PD5 Dual Pressure Module for zero measurement
Message 311
700PD6 Dual Pressure Module for zero measurement
Message 312
700PD7 Dual Pressure Module for zero measurement
Message 313
700P29 High Pressure Module for zero measurement
Message 314
700P30 High Pressure Module for zero measurement
Message 315
700P31 High Pressure Module for zero measurement
Message 316
UUT to 8901A Input
Message 317
8901A Input to 8901A Calibration Output
Message 318
11722A Sensor Module to UUT
Message 319
11722A Sensor Module to 8901B AM/FM Calibration Output
Message 320
11722A Sensor Module to 8902A AM/FM Calibration Output
Message 321
11722A Sensor Module to 8901B RF Power Calibration Output
Message 322
11722A Sensor Module to 8902A RF Power Calibration Output
Message 323
UUT to 8903B Input High
Message 324
UUT to 8903E Input High
Message 325
UUT to 8903B Output High
Message 326
UUT to 4000 Hi and Lo Output Terminals
Message 327
UUT to 4000 I+ and I- Output Terminals
Message 328
UUT to 4000 I+ and I- as Sense Terminals
Message 329
UUT to 4200 Hi and Lo Output Terminals
Message 330
UUT to 4200 I+ and I- Output Terminals
Message 331
UUT to 4200 I+ and I- as Sense Terminals
Message 332
UUT to 4600 I+ and I- Output Terminals
Message 333
UUT to 4700 Hi and Lo Output Terminals
Message 334
UUT to 4700 I+ and I- Output Terminals
Message 335
UUT to 4700 I+ and I- as Sense Terminals
Message 336
UUT to 4708 Hi and Lo Output Terminals
Message 337
UUT to 4708 I+ and I- Output Terminals
Message 338
UUT to 4708 I+ and I- as Sense Terminals
Message 339
UUT to 8648 RF Output
Message 340
UUT to 2023 RF Output
Message 341
UUT to 2024 RF Output
Message 342
UUT to SYM01 RF Output
Message 343
UUT to SYM02 RF Output
Message 344
8481B Power Sensor to UUT
Message 345
8482B Power Sensor to UUT
Message 346
8481B Power Sensor to Power Ref Output
Message 347
8482B Power Sensor to Power Ref Output
Message 348
8481H Power Sensor to UUT
Message 349
8482H Power Sensor to UUT
Message 350
8481H Power Sensor to Power Ref Output
Message 351
8482H Power Sensor to Power Ref Output
Message 352
8481A Power Sensor to UUT
Message 353
8482A Power Sensor to UUT
Message 354
8483A Power Sensor to UUT
Message 355
8485A Power Sensor to UUT
Message 356
8487A Power Sensor to UUT
Message 357
Q8486A Power Sensor to UUT
Message 358
R8486A Power Sensor to UUT
Message 359
W8486A Power Sensor to UUT
Message 360
8481A Power Sensor to Power Ref Output
Message 361
8482A Power Sensor to Power Ref Output
Message 362
8483A Power Sensor to Power Ref Output
Message 363
8485A Power Sensor to Power Ref Output
Message 364
8487A Power Sensor to Power Ref Output
Message 365
Q8486A Power Sensor to Power Ref Output
Message 366
R8486A Power Sensor to Power Ref Output
Message 367
W8486A Power Sensor to Power Ref Output
Message 368
8481D Power Sensor to UUT
Message 369
8484A Power Sensor to UUT
Message 370
8485D Power Sensor to UUT
Message 371
8487D Power Sensor to UUT
Message 372
Q8486D Power Sensor to UUT
Message 373
R8486D Power Sensor to UUT
Message 374
8481D Power Sensor to Power Ref Output using 30dB attenuator
Message 375
8484A Power Sensor to Power Ref Output using 30dB attenuator
Message 376
8485D Power Sensor to Power Ref Output using 30dB attenuator
Message 377
8487D Power Sensor to Power Ref Output using 30dB attenuator
Message 378
Q8486D Power Sensor to Power Ref Output using 30dB attenuator
Message 379
R8486D Power Sensor to Power Ref Output using 30dB attenuator
Message 380
UUT to 5335A Input A
Message 381
UUT to 5335A Input C
Message 382
UUT to 5335A Input A (for Ratio A/B measurement)
Message 383
UUT to 5335A Input B (for Ratio A/B measurement)
Message 384
UUT to 5335A Input A (for Time Interval A-B measurement)
Message 385
UUT to 5335A Input B (for Time Interval A-B measurement)
Message 386
UUT to 5335A DCV and COM Input Terminals
Message 387
UUT to 856X Input
Message 388
UUT to 8566B RF Input
Message 389
UUT to 8568B Signal Input 1
Message 390
UUT to 8568B Signal Input 2
Message 391
UUT to 859X Input
Message 392
UUT to 5820A Channel 1
Message 393
UUT to 5820A Channel 2
Message 394
UUT to 5820A Channel 3
Message 395
UUT to 5820A Channel 4
Message 396
UUT to 5820A Channel 5
Message 397
UUT to 5820A Channel 1 using Tunnel Diode Pulser
Message 398
UUT to 5820A Channel 2 using Tunnel Diode Pulser
Message 399
UUT to 5820A Channel 3 using Tunnel Diode Pulser
Message 400
UUT to 5820A Channel 4 using Tunnel Diode Pulser
Message 401
UUT to 5820A Channel 5 using Tunnel Diode Pulser
Message 402
UUT to 5820A Channel 1 as trigger output
Message 403
UUT to 5820A Channel 5 as trigger output
Message 404
Insert 2620T Temperature Probe
Message 405
Insert 2635T Temperature Probe
Message 406
UUT to 33120A Output
Message 407
UUT to 33120A Output with 50 Ohm termination
Message 408
Insert Rosemount 162CE SPRT Probe
Message 409
Insert Hart Scientific 5628 PRT Probe
Message 410
UUT to 9500 Channel 1 Active Head
Message 411
UUT to 9500 Channel 2 Active Head
Message 412
UUT to 9500 Channel 3 Active Head
Message 413
UUT to 9500 Channel 4 Active Head
Message 414
UUT to 9500 Channel 5 Active Head
Message 415
UUT to 9500 Channel 1 Trigger Cable
Message 416
UUT to 9500 Channel 2 Trigger Cable
Message 417
UUT to 9500 Channel 3 Trigger Cable
Message 418
UUT to 9500 Channel 4 Trigger Cable
Message 419
UUT to 9500 Channel 5 Trigger Cable
Message 420
UUT Probe to 9500 Channel 1 Active Head using Current Loop Assembly
Message 421
UUT Probe to 9500 Channel 2 Active Head using Current Loop Assembly
Message 422
UUT Probe to 9500 Channel 3 Active Head using Current Loop Assembly
Message 423
UUT Probe to 9500 Channel 4 Active Head using Current Loop Assembly
Message 424
UUT Probe to 9500 Channel 5 Active Head using Current Loop Assembly
Message 425
UUT to 4800 Hi and Lo Output Terminals
Message 426
UUT to 4800 I+ and I- Output Terminals
Message 427
UUT to 4800 I+ and I- as Sense Terminals
Message 428
UUT to 4805 Hi and Lo Output Terminals
Message 429
UUT to 4805 I+ and I- Output Terminals
Message 430
UUT to 4805 I+ and I- as Sense Terminals
Message 431
UUT to 4808 Hi and Lo Output Terminals
Message 432
UUT to 4808 I+ and I- Output Terminals
Message 433
UUT to 4808 I+ and I- as Sense Terminals
Message 434
UUT to 4705 Hi and Lo Output Terminals
Message 435
UUT to 4705 I+ and I- Output Terminals
Message 436
UUT to 4705 I+ and I- as Sense Terminals
Message 437
UUT to 4707 Hi and Lo Output Terminals
Message 438
UUT to 4707 I+ and I- Output Terminals
Message 439
UUT to 4707 I+ and I- as Sense Terminals
Message 440
UUT to 1271 Hi and Lo Input Terminals
Message 441
UUT to 1271 I+ and I- as Sense Terminals
Message 442
UUT to 1271 I+ and I- Input Terminals
Message 443
UUT to 1281 Hi and Lo Input Terminals
Message 444
UUT to 1281 I+ and I- as Sense Terminals
Message 445
UUT to 1281 I+ and I- Input Terminals
Message 446
UUT to 4950 Hi and Lo Input Terminals
Message 447
UUT to 4950 I+ and I- as Sense Terminals
Message 448
UUT to 4950 I+ and I- Input Terminals
Message 449
4953 AC/DC Shunt Hi and Lo Terminals to 4950 Hi and Lo Terminals
Message 450
UUT to 4953 I+ and I- Input Terminals
Message 451
UUT to 9005 Red Lead (Hi and sH)
Message 452
UUT to 9005 Black Lead (sH and LI-)
Message 453
UUT to 9005 Yellow Lead (I+20A)
Message 454
UUT to 9005 White Lead (I+mA)
Message 455
UUT to 9005 TC Terminals
Message 456
UUT to 9105 Red Lead (Hi and sH)
Message 457
UUT to 9105 Black Lead (sH and LI-)
Message 458
UUT to 9105 Yellow Lead (I+20A)
Message 459
UUT to 9105 White Lead (I+mA)
Message 460
UUT to 9105 Thermocouple Adapter
Message 461
UUT to 9100 Hi and Lo Output Terminals
Message 462
UUT to 9100 I+ and I- Output Terminals
Message 463
Option 200 10-Turn coil to 9100 I+ and I- Output Terminals.
Clamp UUT around the center of the coil.
Message 464
Option 200 50-Turn coil to 9100 I+ and I- Output Terminals.
Clamp UUT around the center of the coil.
Message 465
UUT to 9100 SIG OUT (on rear).
Message 466
UUT to 525A Hi and Lo Volts Source Terminals
Message 467
UUT to 525A Hi and Lo mA Source Terminals
Message 468
UUT to 525A Hi and Lo RTD/Ohms Source Terminals
Message 469
UUT to 525A Hi and Lo RTD/Ohms Measure Terminals
Message 470
UUT to 525A Hi and Lo RTD/Ohms Sense Terminals
Message 471
UUT to 525A TC Terminal
Message 472
UUT to 525A TC Terminals using copper wire
Message 473
UUT to 525A TC Terminals using type B thermocouple wire
Message 474
UUT to 525A TC Terminals using type C thermocouple wire
Message 475
UUT to 525A TC Terminals using type E thermocouple wire
Message 476
UUT to 525A TC Terminals using type J thermocouple wire
Message 477
UUT to 525A TC Terminals using type K thermocouple wire
Message 478
UUT to 525A TC Terminals using type L thermocouple wire
Message 479
UUT to 525A TC Terminals using type N thermocouple wire
Message 480
UUT to 525A TC Terminals using type R thermocouple wire
Message 481
UUT to 525A TC Terminals using type S thermocouple wire
Message 482
UUT to 525A TC Terminals using type T thermocouple wire
Message 483
UUT to 525A TC Terminals using type U thermocouple wire
Message 484
Type B Thermocouple Standard to 525A TC Terminals
Message 485
Type C Thermocouple Standard to 525A TC Terminals
Message 486
Type E Thermocouple Standard to 525A TC Terminals
Message 487
Type J Thermocouple Standard to 525A TC Terminals
Message 488
Type K Thermocouple Standard to 525A TC Terminals
Message 489
Type L Thermocouple Standard to 525A TC Terminals
Message 490
Type N Thermocouple Standard to 525A TC Terminals
Message 491
Type R Thermocouple Standard to 525A TC Terminals
Message 492
Type S Thermocouple Standard to 525A TC Terminals
Message 493
Type T Thermocouple Standard to 525A TC Terminals
Message 494
Type U Thermocouple Standard to 525A TC Terminals
Message 495
100 Ohm Pt 385 RTD Standard to 525A RTD Measure and Sense Terminals
Message 496
100 Ohm Pt 3926 RTD Standard to 525A RTD Measure and Sense Terminals
Message 497
120 Ohm Ni RTD Standard to 525A RTD Measure and Sense Terminals
Message 498
200 Ohm Pt 385 RTD Standard to 525A RTD Measure and Sense Terminals
Message 499
500 Ohm Pt 385 RTD Standard to 525A RTD Measure and Sense Terminals
Message 500
1 kOhm Pt 385 RTD Standard to 525A RTD Measure and Sense Terminals
Message 501
100 Ohm Pt 3916 RTD Standard to 525A RTD Measure and Sense Terminals
Message 502
10 Ohm Cu Standard to 525A RTD Measure and Sense Terminals
Message 503
PRT Standard to 525A RTD Measure and Sense Terminals
Message 504
SPRT Standard to 525A RTD Measure and Sense Terminals
Message 505
YSI400 Standard to 525A RTD Measure and Sense Terminals
Message 506
UUT to 525A-P02 Differential Pressure Module
Message 507
UUT to 525A-P05 Gage Pressure Module
Message 508
UUT to 525A-P06 Gage Pressure Module
Message 509
UUT to 525A-P07 Gage Pressure Module
Message 510
UUT to 525A-P08 Gage Pressure Module
Message 511
UUT to 525A-P29 High Pressure Module
Message 512
UUT to 525A-PA4 Absolute Pressure Module
Message 513
UUT to 525A-PA6 Absolute Pressure Module
Message 514
UUT to 525A-PA7 Absolute Pressure Module
Message 515
UUT to 525A-PA8 Absolute Pressure Module
Message 516
UUT to 525A-PV4 Vacuum Module
Message 517
525A-P02 Differential Pressure Module for zero measurement
Message 518
525A-P05 Gage Pressure Module for zero measurement
Message 519
525A-P06 Gage Pressure Module for zero measurement
Message 520
525A-P07 Gage Pressure Module for zero measurement
Message 521
525A-P08 Gage Pressure Module for zero measurement
Message 522
525A-P29 High Pressure Module for zero measurement
Message 523
525A-PA4 Absolute Pressure Module for zero measurement
Message 524
525A-PA6 Absolute Pressure Module for zero measurement
Message 525
525A-PA7 Absolute Pressure Module for zero measurement
Message 526
525A-PA8 Absolute Pressure Module for zero measurement
Message 527
525A-PV4 Vacuum Module for zero measurement
Message 528
UUT to 395 Output with 50 Ohm termination
Message 529
UUT to 33250A Output
Message 530
UUT to 33250A Output with 50 Ohm termination
Message 531
UUT to 8508A Front Input Terminals
Message 532
UUT to 8508A Front Sense Terminals
Message 533
UUT to 8508A Front 20A and LO Input Terminals
Message 534
E4412A to UUT
Message 535
E4412A to Power Ref
Message 536
E4413A to UUT
Message 537
E4413A to Power Ref
Message 538
E9300A to UUT
Message 539
E9300A to Power Ref
Message 540
E9300B to UUT
Message 541
E9300B to Power Ref
Message 542
E9300H to UUT
Message 543
E9300H to Power Ref
Message 544
E9301A to UUT
Message 545
E9301A to Power Ref
Message 546
E9301B to UUT
Message 547
E9301B to Power Ref
Message 548
E9301H to UUT
Message 549
E9301H to Power Ref
Message 550
E9304A to UUT
Message 551
E9304A to Power Ref


DISP

Display Control FSC

Description

The DISP FSC is used to display a message to the operator during procedure execution. When a DISP statement is executed, a dialog appears showing the specified message, and containing Advance and Terminate buttons.

If the operator chooses Advance, execution continues with the next procedure statement. If the operator chooses Terminate, the current step is terminated, and the Post Test dialog appears.

Format

DISP message

Rules

  1. A single DISP statement may contain up to 32 lines.

  2. Each line of a DISP statement may contain up to 256 bytes, including the step number and the FSC text. Characters below ASCII 128 occupy one byte.

  3. When the character length for a single line is exceed in a procedure, the additional characters are truncated

  4. The following special constructions may be used in a DISP statement:

    1. [MEM], [MEM1], and [MEM2]
    2. [numeric]
    3. [Dnumeric]
    4. [DRAWx,y,view]
    5. [Vvariable]
    6. {text}
    7. [M1], [M2], ...
    8. [L1], [L2], ...
    9. [S1], [S2], ...
    10. [SREG1], [SREG2], ...
    11. [Xhex list]

    Refer to Special Constructions for additional detail.

    The constructions [M1], [M2], ..., access the global numeric registers. The constructions [L1], [L2], ..., access the local numeric registers. Up to 12 significant digits are included in the numeric register value. Refer to the MATH FSC on-line help for additional information on the numeric registers.

    The constructions [S1], [S2], ..., access the string registers. Refer to the MATH FSC on-line help for additional information on the string registers.

    The constructions [SREG1], [SREG2], ..., are identical to [S1], [S2], ..., and are included only for compatibility with the IEEE, IEEE2, and SCPI FSCs.

    When using the DELAY special construction, the DISP message is displayed after the DELAY time has elapsed. Placement of the DELAY special construction does not matter, even for multi-line DISP statements.

Examples

  1.011  DISP         Set the PM 3055 Ch.1 vertical attenuation to 1V/div.
  1.011  DISP         Set the PM 3055 time base to 5ms/div.
  1.011  DISP
  1.011  DISP         Trigger Ch.1 on the inductive pickup waveform.

The example above shows a 4 line DISP statement. (The fact that all 4 lines have the same step number indicates that it is a single statement, rather than 4 separate DISP statements.)

1.001 DISP [D1000] The value of MEM is [MEM].

This example illustrates the use of special constructions. The [D1000] construction causes a delay of 1 second (1000 milliseconds), and then displays the value of memory register MEM.

Special constructions ( [ ... ] ) may be enclosed in braces ( { ... } ), but such enclosed special constructions are not evaluated and stored in the results. For example, the following DISP statements will cause "Ch[MEM] 20mV/div" to be stored in the results, not "Ch1 20mV/div":

  12.001 MATH       MEM = 1
  12.002 HEAD       Ch[MEM] Tests
  12.003 DISP       Set attenuation:  {Ch[MEM] 20mV/div}

To solve this problem, the RSLT FSC should be used to store text with embedded special constructions in the results as shown below:

  12.001 MATH       MEM = 1
  12.002 HEAD       Ch[MEM] Tests
  12.003 DISP       Set attenuation:  Ch[MEM] 20mV/div
  12.004 RSLT       =Ch[MEM] 20mV/div


DRAW

Display Control FSC

Description

The DRAW FSC is used to set up a simple sketch of an instrument. Execution of a DRAW statement does not display the sketch, however. The sketch is displayed when a DRAW special construction in an EVAL, DISP, OPBR or SET statement is executed.

The sketch consists of an outer rectangle, an inner rectangle, and an enunciator. The outer rectangle represents the outline of an instrument (the UUT). The inner rectangle represents the UUT's front panel display. The enunciator identifies the location of an adjustment or connection.

Before the sketch can be displayed, the following information must be specified:

  1. The position (in the front view) of the upper right corner of the outer rectangle.
  2. The position (in the side view) of the upper right corner of the outer rectangle.
  3. The position of the upper left corner of the inner rectangle.
  4. The position of the lower right corner of the inner rectangle.
  5. The position of the enunciator.
  6. The view (front, back, left, right, top, and bottom).

Items 1, 2, 3, and 4 are specified in the DRAW statement, as described in the Format and Rules sections below.

Items 5 and 6 are specified in the DRAW special construction. Refer to Special Constructions for details on the DRAW special construction.

The DRAW special construction allows any of 6 different views to be specified (front, back, left, right, top, and bottom). The inner rectangle and enunciator are not shown unless the front view is selected.

Format

DRAW p1p2p3 p4p5 p6p7 p8

p1::= position of top edge of outer rectangle (front, back views)

p2::= position of right edge of outer rectangle (front, back views)

p3::= position of top edge of outer rectangle (side views)

p4::= position of right edge of outer rectangle (side views)

p5::= position of top edge of inner rectangle

p6::= position of left edge of inner rectangle

p7::= position of bottom edge of inner rectangle

p8::= position of right edge of inner rectangle

All parameters are integers (nr1 format).

Rules

  1. p1 and p2 specify the position of the upper-right corner of the outer rectangle, in the front and back views.
  2. p1 specifies the UUT front top row number. It must be between 2 and 11.
  3. p2 specifies the UUT front right column number. It must be between 58 and 78.
  4. p3 and p4 specify the position of the upper-right corner of the outer rectangle, in the left, right, top, and bottom views.
  5. p3 specifies the UUT side top row number. It must be between 2 and 11.
  6. p4 specifies the UUT side right column number. It must be between 58 and 78.
  7. p5, p6, p7, and p8 specify the positions of the upper-left and lower-right corners of the inner rectangle.
  8. p5 specifies the position of the top edge of the inner rectangle, expressed as a percentage of the height of the outer rectangle, with respect to the bottom of the outer rectangle. p5 must be between 0 and 100, and must be greater than p7.
  9. p6 specifies the position of the left edge of the inner rectangle, expressed as a percentage of the width of the outer rectangle, with respect to the left edge of the outer rectangle. p6 must be between 0 and 100, and must be less than p8.
  10. p7 specifies the position of the bottom edge of the inner rectangle, expressed as a percentage of the height of the outer rectangle, with respect to the bottom of the outer rectangle. p7 must be between 0 and 100, and must be less than p5.
  11. p8 specifies the position of the right edge of the inner rectangle, expressed as a percentage of the width of the outer rectangle, with respect to the left edge of the outer rectangle. p8 must be between 0 and 100, and must be greater than p6.
  12. The bottom row and left column positions of the outer rectangle are fixed (in all views).

Compatibility

  • The DRAW FSC is not recommended in MET/CAL 4.0. It is supported to provide compatibility with previous versions of MET/CAL.
  • The display created using the DRAW FSC and DRAW special construction is very simple: two rectangles and a small circle, with no text annotation. Procedure writer's are advised to create pictures which more accurately depict the UUT. Pictures may be created using the Windows Paint, or your preferred image editing program. Picture may be displayed in MET/CAL using the PIC and PICE FSCs.
  • Previous versions of the MET/CAL editor supported interactive entry of the parameters in a DRAW statement. The MET/CAL 4.0 editor does not support interactive parameter entry.

Examples

    STEP  FSC  RANGE NOMINAL TOLERANCE MOD1 MOD2  3  4  CON
    1.001 DRAW         6 78  6 77       80  5 20 60
    1.002 DISP       Local/Remote switch [DRAW10,20,F]
      2.001 DRAW         6100  6 78       80 25 20 60
    2.002 DISP       Adjustment R1 is here [DRAW34,24,L]


MEMI

Memory Register Operation FSC

Description

The MEMI FSC prompts the operator for a number. The number entered by the operator is stored in memory register MEM.

Format

MEMI message

Rules

  1. The MEMI message is displayed as a prompt to the operator.

  2. Each line of a MEMI statement may contain up to 256 bytes, including the step and the FSC. Characters below ASCII 128 count as one byte.

  3. A MEMI statement may contain up to 32 lines.

  4. In a multiline MEMI statement the text on each MEMI line becomes a separate line in the prompt text displayed to the operator.

  5. The operator must enter a numeric value in response to the MEMI prompt. If the operator's response is blank or includes non-numeric characters, the prompt dialog is redisplayed. As a decimal symbol the MEMI FSC accepts either a decimal point ('.') or a comma (',').

  6. After a valid response has been entered by the operator, the entered value is stored in memory register MEM.

  7. The following special constructions may be used in a MEMI statement:

    1. [MEM], [MEM1], and [MEM2]
    2. [numeric]
    3. [Ddelay]
    4. {text}
    5. [M1], [M2], ...
    6. [L1], [L2], ...
    7. [S1], [S2], ...
    8. [SREG1], [SREG2], ...
    9. [Xhex list]

    Refer to Special Constructions for details.

    The constructions [M1], [M2], ..., access the global numeric registers. The constructions [L1], [L2], ..., access the local numeric registers. Up to 12 significant digits are included in the numeric register value. Refer to the MATH FSC on-line help for additional information on the numeric registers. The constructions [S1], [S2], ..., access the string registers. Refer to the MATH FSC on-line help for additional information on the string registers.

    The constructions [SREG1], [SREG2], ..., are identical to [S1], [S2], ..., and are included only for compatibility with the IEEE FSC.

    Embedded [Ddelay] constructions, if any, are evaluated before the prompt is displayed. This is true even if the MEMI statement is a multiline statement and one or more [Ddelay] constructions occur on MEMI lines which are not the first line of the statement.

    When using the DELAY special construction, the MEMI prompt is displayed after the DELAY time has elapsed. Placement of the DELAY special construction does not matter, even for multi-line MEMI statements.

  8. If the prompt text (after special constructions are evaluated) exceeds 1023 characters, the displayed text is truncated to 1023 characters. Linefeed characters automatically inserted to separate lines of the prompt text are counted against the 1023 character limit.

Examples

  3.015  MEMI       Enter UUT reading in ohms:

  1.001  MEMI       Please enter the amplitude
  1.001  MEMI       of the signal.


MESS

Display Control FSC

Description

The MESS FSC is used to store messages for later display. There are 6 situations in which the stored messages are displayed:

  • When an instrument FSC Evaluation Test is performed in slew mode.
  • When an instrument FSC Evaluation Test is performed in go-nogo mode.
  • When an instrument FSC Nominal Setup Test (stimulus only) is performed.
  • When an instrument FSC Comparison Test (stimulus only) is performed.
  • When an instrument FSC Setup Test (measurement only) is performed.
  • When an EVAL FSC (without -e flag) is executed.

The MESS FSC is typically used to supplement or replace the default messages.

FORMAT

MESS message

RULES

  • A MESS message statement may contain a maximum of 256 bytes. Characters below ASCII 128 count as one byte.
  • A MESS statement may contain up to 8 lines. The text will automatically wrap between lines as required to prevent truncating text.
  • The regular automatic message shown during slewing or in a measurement Setup Test can be disabled using the ASK- N FSC command. In that case only the MESS messages are shown.

Example:

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
  1.001  ASK-         N
  1.002  MESS         Replacement for slew message.
  1.003  5700         1V             1%                                    2W

When the 5700 statement is executed, the slew dialog will appear to allow the operator to slew the output of the 5700 calibrator. Since the ASK 'N' flag is disabled, the normal slew message ("Adjust stimulus for a UUT reading of 1 V.") will not appear. The specified MESS message will appear as a replacement (though not in the same place on the screen).

  • A 1-line MESS statement with a blank message clears the existing MESS messages (if any) from internal storage.
  • A blank MESS line which is part of a multi-line MESS statement does not clear MESS messages. It causes a blank line to appear when the MESS messages are displayed.
  • Each MESS statement causes previous MESS messages to be overwritten.

Example:

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
  1.001  MESS         abc
  1.001  MESS         def
  1.002  EVAL   yes or no

  2.001  MESS         xyz
  2.002  EVAL   x or y

The second MESS statement (2.001) overwrites the 2 MESS messages which were stored by the first MESS statement (1.001). Thus, when the second EVAL statement is executed, the displayed MESS messages will consist of the single line "xyz".

  • The following special constructions may be used in a MESS statement:
    1. [MEM], [MEM1], and [MEM2]
    2. [numeric]
    3. [Vvariable]
    4. {text}
    5. [M1], [M2], ...
    6. [L1], [L2], ...
    7. [S1], [S2], ...
    8. [SREG1], [SREG2], ...
    9. [Xhex list]

Refer to Special Constructions for details.

The constructions [M1], [M2], ..., access the global numeric registers. The constructions [L1], [L2], ..., access the local numeric registers. Up to 12 significant digits are included in the numeric register value. Refer to the MATH FSC on-line help for additional information on the numeric registers. The constructions [S1], [S2], ..., access the string registers. Refer to the MATH FSC on-line help for additional information on the string registers.

The constructions [SREG1], [SREG2], ..., are identical to [S1], [S2], ..., and are included only for compatibility with the IEEE, IEEE2, and SCPI FSCs.

[] special constructions may be enclosed in {}, but will not be evaluated and stored in the results. For example, the following MESS statement will cause "Ch[MEM] trigger slope positive" to be stored in the results, not "Ch1 trigger slope positive".

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
  1.001  MATH         MEM = 1
  1.002  HEAD         Ch[MEM] Tests
  1.003  MESS         Set {Ch[MEM] trigger slope positive}
  1.004  EVAL   is Ch[MEM] triggered?

The RSLT FSC should be used to store text with embedded [] special constructions in the results as shown below:

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
  1.001  MATH         MEM = 1
  1.002  HEAD         Ch[MEM] Tests
  1.003  RSLT         =Ch[MEM] trigger slope positive
  1.004  MESS         Set Ch[MEM] trigger slope positive
  1.005  EVAL   is Ch[MEM] triggered?


OPBR

Procedure Control FSC

Description

The OPBR FSC presents a message to the operator. The operator must respond by choosing YES or NO. MEM1 is set to 1 if the operator chooses YES, and set to -1 (or 0 if the "-z" argument is specified), when the operator chooses NO. The OPBR FSC is often used in conjunction with a JMPF or JMPT statement to perform a jump based on the value of MEM1.

Format

OPBR [-z] message

Rules

  1. An OPBR message may contain up to 245 bytes. Characters below ASCII 128 count as one byte.

  2. An OPBR statement may contain up to 32 lines.

  3. The operator's response to the OPBR message determines the value of MEM1 as follows:

    If the "-z" argument is not specified:

    Operator Response | MEM1 Value
    YES | +1
    NO | -1

    If the "-z" argument is specified:

    Operator Response | MEM1 Value
    YES | +1
    NO | 0

    See the next paragraph for a description of the "-z" argument.

  4. The procedure writer may optionally specify the "-z" argument on the first line of an OPBR statement. Specifying "-z" causes MET/CAL to assign the value zero to MEM1 when the operator chooses "No" in response to the OPBR prompt. When "-z" is specified there must be a space after the 'z' unless the entire line is simply "OPBR -z". The "-z" argument is not supported in V7.11 or earlier versions of MET/CAL. The addition of support for the "-z" argument is not backwards compatible, but only existing OPBR statements which begin with "-z " on the first line are affected by the change.

  5. The following special constructions may be used in an OPBR statement:

    1. [MEM], [MEM1], and [MEM2]
    2. [numeric]
    3. [Ddelay]
    4. [DRAWx,y,view]
    5. [Vvariable]
    6. {text}
    7. [M1], [M2], ...
    8. [L1], [L2], ...
    9. [NO]
    10. [S1], [S2], ...
    11. [SREG1], [SREG2], ...
    12. [Xhex list]

    Refer to Special Constructions for details.

    The constructions [M1], [M2], ..., access the global numeric registers. The constructions [L1], [L2], ..., access the local numeric registers. Up to 12 significant digits are included in the numeric register value. Refer to the MATH FSC on-line help for additional information on the numeric registers.

    The [NO] construction changes the default button in the OPBR prompt dialog from "Yes" to "No". This can be useful when the expected response is "No" rather than "Yes", because it allows the operator to simply press the "Enter" button in order to choose "No". The [NO] construction affects only the OPBR statement in which it appears. The default button is "Yes" for any OPBR statement which does not contain a [NO] construction. (The [NO] construction is new with V6.00.)

    The constructions [S1], [S2], ..., access the string registers. Refer to the MATH FSC on-line help for additional information on the string registers.

    The constructions [SREG1], [SREG2], ..., are identical to [S1], [S2], ..., and are included only for compatibility with the IEEE, IEEE2, and SCPI FSCs.

    When using the DELAY special construction, the OPBR prompt is displayed after the DELAY time has elapsed. Placement of the DELAY special construction does not matter.

Examples

Example 1

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
  1.001  OPBR         This test requires the following equipment:
  1.001  OPBR         Function Generator: Philips PM 5133/5134 or equiv.
  1.001  OPBR         Oscilloscope:       Philips PM 3055 or equivalent
  1.001  OPBR
  1.001  OPBR         Do you wish to perform the test?
  1.002  JMPT         1.005
  1.003  RSLT         = ****** NOT TESTED ******
  1.004  JMP          1.006
  1.005  CALL         Sub Fluke 86,88 Inductive Pickup (1 year) CAL VER
  1.006  END

The example above illustrates a typical use of OPBR. The operator is presented with a list of required equipment for a test. If the equipment is available, the operator chooses YES, which causes MEM1 to be set to 1. The JMPT statement then causes a jump to 47.007 which calls a subprocedure to perform the desired test.

If the equipment is not available, the operator chooses NO, which causes MEM1 to be set to -1. The JMPT statement does not then jump to 47.007. Execution proceeds to 47.005, which writes "****** NOT TESTED ******" in the results, and then to 47.006 which jumps around the CALL statement.

Example 2

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
  1.001  OPBR         -z Do you wish to include the IR communication
  1.001  OPBR         port test?
  1.002  MATH         PUT("Test_IR_Port", MEM1)

In this example the "-z" argument is specified. If the operator choose "No", MEM1 is set to 0, and 0 is saved as the value of the "Test_IR_Port" in the MET/CAL variable cache.

If the operator choose "Yes", MEM1 is set to 1, and 1 is saved as the value of the "Test_IR_Port" in the MET/CAL variable cache.


PIC

Display Control FSC

Description

The PIC FSC displays a picture during procedure execution. Pictures, which may include text, are used to provide instructions to the operator. Pictures are used instead of text-only instructions to the operator in cases where a detailed description of a required connection, or adjustment is difficult to present in text-only form.

MET/CAL supports the following picture file formats:

.bmp | Bitmap
.jpg | JPEG (Joint Photographic Experts Group)
.gif | GIF (Graphics Interchange Format)
.ico | Icon
.tif | TIFF (Tagged Image File Format)
.png | PNG (Portable Network Graphics)

Picture editing software such as Microsoft Paint or the MET/CAL MET/CAL Editor may be used to create, edit, and convert picture files. If your unsure which format to use, PNG may be a good choice.

FORMAT

PIC [picture file] [position/color] [text]

RULES

  1. Text can be superimposed on the picture. Superimposed text can be located anywhere on the screen, with a number of foreground and background colors.

  2. A PIC statement consists of one or more PIC lines. The first PIC line must contain the name of the picture file. Subsequent lines, if any, are used to specify text to be overlaid on the picture.

  3. Each PIC line may specify at most 1 text string.

  4. A PIC line has the format:

    PIC [picture file] [position/color] [text]

    (Square brackets indicate optional subfields.)

    1. The picture file, position/color, and text subfields may be entered in any order.
    2. Rules for the picture file subfield:

      3. This subfield is a single word which specifies the file name of the picture file to be displayed. The length including the step number and file name cannot exceed 256 characters. The name may not contain parentheses, double quotes, or blanks. The file name must be specified if the line is the first line of the PIC statement, and may not be specified if the line is not the first line of the PIC statement.

      By default all picture files are assumed to reside in the Picture Folder.

      Alternatively, the path of the picture file can be included with the file name. In this case, the path is hard coded in the procedure. If the file is not in this fixed location the picture will not display and an error will be generated.

      Creating procedure projects that use pictures requires that the picture files be added to the project. Like all procedure project files, the picture files can reside in any location on the file system. It is recommended that all pictures files reside in the Picture Folder or in a project specific folder. When the procedure project is compiled into a PXE, all images are compiled into a single file along with the procedure source code. This allows the PXE to execute and display pictures on any supported MET/CAL station without any special setup.

      The picture file name may or may not include the file extension. If the extension is specified, a file with the specified name and extension must exist in the MET/CAL picture directory. If the extension is not specified, MET/CAL searches for a file with one of the supported extensions. The search order is: .bmp, .jpg, .gif, .ico, .tif, .png.

      A picture file name may contain certain embedded special constructions. By placing the file name in a string register the procedure writer may overcome line length limitation, as well as the restriction against embedded spaces. For example:

      MATH S[1] = "Fluke 5700A Front Panel"
PIC [S1].jpg

      will work as long as the MET/CAL picture directory contains a file named "Fluke 5700A Front Panel.jpg".

      However, note that using special constructions in picture file names prevents the normal pre-run check which verifies that pictures required by the procedure about to be executed are present in the MET/CAL picture directory.

      The following constructions are legal in picture file names:

      1. [L1], [L2], ...
      2. [M1], [M2], ...
      3. [MEM], [MEM1], and [MEM2]
      4. [S1], [S2], ...
      5. [SREG1], [SREG2], ...
      6. [Vvariable]

    3. Rules for the position/color subfield:

      4. This subfield specifies the row and column at which to position the first character of the text string, as well as the foreground and background colors in which to display the text string. The subfield has the format:

      ([row],[col],[color])

      The enclosing parentheses must be included in the subfield.

      row specifies the row on which to display the text string. It is an integer between 0 and 23, or a '+' sign.

      col specifies the column at which to start the text string. It is an integer between 0 and 79, or a '+' sign.

      In MET/CAL 4.0, the row and column positions are scaled to fit the size of the displayed picture. Even if the picture is very small, it is still considered to consist of 24 rows X 80 columns for purposes of positioning text overlays. However, since the font used to display the text is not scaled with the picture, care must be taken to ensure that adjacent rows of text do not overlap.

      color has the format fg/bg where:

      fg has the format: ['L']|['l'] color base

      bg has the format: ['L']|['l'] color base

      color base is one of:

      • B - blue
      • BL - black
      • BR - brown
      • C - cyan
      • G - green
      • M - magenta
      • R - red
      • W - white

      These codes indicate a high intensity color. To specify a low intensity, precede the color code with 'L' or 'l'.

      The entire subfield may be omitted, but, if it is not, the parentheses and all commas are required.

      The default: row = 0, col = 0, color is BL/W. The default is used when a specification is not included on the first line of a multi-line PIC statement.

      On a line other than the first line, a missing specification causes the current value for that statement to be used.

      If row is '+', the current row for the PIC statement is incremented by 1. If the current row is already 23, row is set to 0. If column is '+', the current column for the PIC statement is set to the column following the end of the previously displayed text string. If this is 79, the current column is set to 0.

    4. Rules for the Text subfield:

      5. The format is "text"

      Note that the double quotes must be included in the PIC statement. The length of the text string cannot exceed 54 (not counting the double quotes). In many cases however, the length is further limited by the fact that the PIC FSC is a display control-type FSC and the length of the body of a PIC line is limited to 56 characters.

      The text string can contain double quote '"' characters. The last double quote on the line terminates the text string.

      Example:

      PIC (5,5,B/G) "Select "Volts""

      The text which will appear on the picture is: Select "Volts".

      The font used for text overlays is configurable. Choose "Picture Font" in the top-level "Configure" menu of the MET/CAL Editor or MET/CAL Runtime applications.

    5. Interfield Dependencies

      6. It is illegal to specify a text string, which, when displayed at the specified position, goes beyond column 79. In some cases this error is not detected until run time.

  5. Execution of a PIC Statement

    Execution of a multi-line PIC statement occurs when the MET/CAL Runtime system reaches the last line of the statement. Execution proceeds as follows:

    1. MET/CAL determines the full path name of the picture file. The Picture Folder is prepended to the name specified in the PIC statement. If the PIC statement name does not include an extension, the picture directory is searched to find a matching name with one of the supported extensions, and, if the search is successful, the extension is appended to the name.
    2. All specified text strings are displayed. Execution of an empty PIC line has no effect.
    3. "Advance" and "Terminate" buttons are shown in the window in which the picture is displayed.

  6. If the picture file is not found, or is corrupted, an error occurs and the user is presented with the Post Test dialog. If a required picture file is not present, the procedure will not start.

  7. The picture may be resized as desired by the operator.

Compatibility

MET/CAL 4.0 does not support interactive entry of text data to be overlaid on a displayed picture. Procedure writers are encouraged to include text as an integral part of the picture itself. In other words, when a picture is created (using, for example, Windows Paintbrush) any needed text should be created as part of the picture, not subsequently overlaid on the picture by adding text to the PIC statement in a MET/CAL procedure. This approach allows flexible text positioning, color selection, and font selection.

For compatibility with previous versions of MET/CAL, overlaid text is supported when it is entered directly in a PIC statement. However, it may be difficult to determine the proper row and column position for the text overlay.

The relative position of overlaid text in a picture remains the same when the picture is scaled down or up.

If an existing picture is reduced in size, space available for each row of overlaid text is correspondingly reduced. This can result in a situation in which a displayed text row is partially overwritten by the next row.

Examples

1.001 PIC OnePict

  1.002  PIC          psm-45 (1,47,LR/G) "Adjust R227 for a"
  1.002  PIC          (2,47,LR/G) "UUT reading of 190.0mV."

  1.003  PIC          psm-45 (3,6,LR/LG) "Adjust R 206 for a"
  1.003  PIC          (4,6,LR/LG) "UUT reading of 0.00mV."


RSLT

Miscellaneous FSC

Description

The RSLT FSC is used to enter information in the MET/CAL results file. The RSLT FSC has two modes of operation, depending on the first character of the text entry being the equals ('=') sign.

  • In the first mode of operation with the first character NOT being the equals ('=') sign, the RSLT FSC displays the indicated message and then prompts the operator for a response. This allows the operator to make a detailed response to the RSLT message. The entire operator response is then placed in the results file.
  • If the first character is the equals ('=') sign, the RSLT information can be used to directly enter information into the results file. This mode is transparent to the operator.

Format

RSLT prompt

or

RSLT=message

Rules

  1. If the body of the RSLT statement begins with an equals sign ('='), the text which follows the equals sign is entered in the results file.

    Example:

    1.012  RSLT         =Waveform Test <2V
  1.013  EVAL   Is the waveform less than 2V?

    When the above statements are executed, two individual rows are written to the results:

    Waveform Test <2V

    Result of Operator Evaluation PASS

    If the operator selects YES, or

    Waveform Test <2V

    Result of Operator Evaluation FAIL

    if the operator selects NO.

    This can also be accomplished as follows:

    1.012  MEM2         =Waveform Test <2V
1.013  EVAL   -s MEM2 : Is the waveform less than 2V?

    In this case the one of the following single rows is written to the results depending upon the operator response.

    Waveform Test <2V PASS

    or

    Waveform Test <2V FAIL

  2. If the body of the RSLT statement does not begin with an equals sign ('='), the body of the result statement is used as a prompt to the operator. The operator's response is entered into the results file.

  3. A maximum of 240 bytes are allowed in the body of the RSLT statement. Characters below ASCII 128 count as one byte.

  4. The following special constructions may be used in an RSLT statement:

    • [numeric]
    • [Dnumeric]
    • [M1], [M2], ...
    • [L1], [L2], ...
    • [MEM1]
    • [MEM2]
    • [MEM]
    • [S1], [S2], ...
    • [SREG1], [SREG2], ...
    • [Vvariable]
    • [Xhex list]
    • {text}

    Refer to Special Constructions for details.

    The constructions [M1], [M2], ..., access the global numeric registers. The constructions [L1], [L2], ..., access the local numeric registers. Up to 12 significant digits are included in the numeric register value. Refer to the MATH FSC on-line help for additional information on the numeric registers. The constructions [S1], [S2], ..., access the string registers. Refer to the MATH FSC on-line help for additional information on the string registers.

    The constructions [SREG1], [SREG2], ..., are identical to [S1], [S2], ..., and are included only for compatibility with the IEEE, IEEE2, and SCPI FSCs.

    When using the DELAY special construction, the RSLT statement is executed after the DELAY time has elapsed. Placement of the DELAY special construction does not matter.

  5. Special constructions which appear in a RSLT statement are evaluated before being written to the results file.

Examples

Example 1:

STEP   FSC RANGE NOMINAL   TOLERANCE     MOD1 MOD2  3  4 CON
1.001 ACMS                               3mV
1.002 5790      3.00000mV                1kH     W  F  N  2W
1.003 RSLT      = 3mV @ 1kHz Reference reading = [MEM]mV

The result of the 5790 Nominal Setup test is stored in MEM. The RSLT statement then substitutes the value of MEM for the special construction [MEM], and writes the resulting text to the result file. If the value of MEM is 3.00002, the results file will contain:

3mV @ 1kHz Reference reading = 3.00002mV

Example 2:

MATH	MEM = 4
RSLT	Enter {Reason Code for ERROR [MEM]:}

When the RSLT statement is executed, the operator will be prompted with:

Enter Reason Code for ERROR 4:

Suppose the operator responds by entering "Short R2". The results file will then contain:

Reason Code for Error 4: Short R2


SET

Display Control FSC

Description

The SET FSC generates a list of settings for complex UUT set-ups. When a SET statement is executed, a specified message is displayed, and also stored internally. Stored settings are recalled when the "Settings" option is chosen in the Post Test Summary. The SET FSC may be used to specify a heading, a setting, or an automatic setting. These are described in detail below.

Format

SET name: setting

or

SET name:

or

SET name

or

SET

Rules

  1. The body of the SET statement is limited to 234 bytes. Characters below ASCII 128 occupy one byte.

    The total length of the name plus setting is limited to 32 bytes when Compile Checking a procedure in the MET/CAL Editor.

    At runtime, if the total length of the name plus setting exceeds 128 bytes (after special constructions are evaluated), an error will be generated.

  2. The internal settings table is large enough for 18 entries. If a new entry is added to a full table, the first (oldest) entry is deleted, and the new entry is added at the bottom of the table (it becomes the newest entry).

  3. The following special constructions may be used in a SET statement:

    1. [MEM], [MEM1], and [MEM2]
    2. [numeric]
    3. [Dnumeric]
    4. [DRAWx,y,view]
    5. [Vvariable]
    6. {text}
    7. [M1], [M2], ...
    8. [L1], [L2], ...
    9. [S1], [S2], ...
    10. [SREG1], [SREG2], ...
    11. [Xhex list]

    Refer to Special Constructions for details.

    If the DELAY special construction is used, the SET message is displayed immediately but the buttons on the prompt are only displayed after the DELAY time has elapsed.

    For multi-line SET statements, placing a DELAY special construction on a specific line causes the SET message to wait for the specified DELAY time after displaying that line before continuing to the next line. The buttons are displayed only after all SET lines have been displayed and all DELAY times have elapsed.

    Example:

    SET Setting: [V VAR$].

  4. If the ASK- S command is in effect, SET FSC messages are not displayed. However, the settings table is updated. The operator may view the settings table by choosing "Settings" in the Post Test Summary.

  5. The remaining rules are defined by which form is used:

SET name: setting

If a SET statement has this form, the specified name and setting are stored in the internal settings table, according to the following rules:

  1. If the name matches a name already in the table, and the settings are different, the old setting in the table associated with that name is replaced by the new setting, and no new entry is created. After the table has been updated, the name and the new setting are displayed to the operator.

  2. If the name matches an existing name in the table, and the new setting is the same as the existing setting, no change is made to the table, and the setting is not displayed to the operator.

  3. The setting length is limited to between 1 and 32 bytes, depending on the length of the name. Characters below ASCII 128 occupy one byte.

  4. Leading spaces in the specified setting are preserved. This allows settings to be lined up in the Post Test Summary "Settings" table.

  5. Note that the space which immediately follows the colon is required. If a space is not present immediately after the colon, the colon is taken to be part of the name. If the specified setting is '*', the setting is an automatic setting. In this case the following rules apply:

    1. The current range is entered as the setting for that name in the settings table. (The current range is determined by the most-recently executed instrument FSC with a non-empty RANGE field, or the last-executed RNG statement.)
    2. The setting is displayed to the operator only if the range is known. This applies both to the execution of the SET statement and to the Post Test Summary "Settings" display.
    3. Whenever the current range changes, the value of the setting in the settings table is updated to match the current range.

SET name:

If a SET statement has this form, the entry for the specified name is deleted from the internal settings table. If the specified name does not match a name in the table, the statement is ignored.

SET name

In this case the name is considered to be a heading. Each time a SET statement specifies a heading, a new entry is made to the internal table.

It is possible to have duplicate headings in the table. Headings cannot be deleted from the table, except by clearing the entire settings table, or when more than 18 entries are added to the table, causing early entries to be discarded. Headings are useful way to group related settings.

Examples:

SET Vertical Mode Controls
SET Triggering Controls

SET

An empty SET statement (or one which contains special constructions only) causes the internal settings table to be cleared. All existing entries are discarded.

Examples

  2.005 SET        Ch1 Volts/Div: 5mV[DRAW60,15,F]
  3.007 SET        Vertical Deflection Tests [D10000]
  4.008 SET        Sensitivity Volts/Div: *


WAIT

Miscellaneous FSC

Description

The WAIT FSC is used to specify a programmed delay. There are three ways to use a WAIT statement:

  • To display a pop-up window which includes a procedure-specified message and a count-down timer showing hours, minutes, and seconds.
  • To generate a pop-up window which remains displayed for a specified number of milliseconds.
  • To delay procedure execution for a specified number of milliseconds, but without a pop-up message window.

Format

The WAIT statement has the following forms:

WAIT [-a] -t timemessage

WAIT [message][delay]

time ::= count-down time in the form HH:MM:SS.

message ::= text message which appears in a pop-up window.

delay ::= delay time in milliseconds.

Brackets indicate optionality in the formats shown above.

The syntax used to specify an optional delay is:

[Dnumber of milliseconds]

where here the brackets ('[' and ']') are literal characters required by MET/CAL's usual special construction syntax. (This is shown more clearly in some of the examples below.)

Rules

  1. If the WAIT statement includes a "-t" argument, the "-t" must be followed by a count-down time specification in the form HH:MM:SS.

    2. Example 1:

    WAIT -t 1:10:30 Please Standby...

    A window containing the message "Please Standby..." will appear with a count-down timer starting at 1 hour, 10 minutes, and 30 seconds.

    The hours and minutes fields are optional in an HH:MM:SS time specification.

    Example 2:

    WAIT -t 10:30 Please Standby...

    The count-down time will begin at 0 hours, 10 minutes, and 30 seconds.

    Example 3:

    WAIT -t 45 Please Standby...

    The count-down time will begin at 0 hours, 0 minutes, and 45 seconds.

  2. If the WAIT statement includes the "-a" argument, the pop-up window includes an "Advance" button. During procedure execution, when the operator chooses "Advance" in the WAIT window, the count-down delay terminates immediately and the procedure continues with the next procedure statement. This is not an error condition.

    3. Example 4:

    WAIT -a -t 5:00 Please Standby...

  3. The WAIT statement may contain at most one "-t" specification and at most one "-a" specification. The "-t" and "-a" arguments may appear in any order, but both must precede the message portion of the statement, if any.
  4. Spaces after the "-t" argument and before the HH:MM:SS time specification are optional.

  5. The WAIT statement may include special constructions. The constructions may appear in the HH:MM:SS time specification, or in the message text specification. Legal constructions are:

    • [n]
    • [Ddelay]
    • [Mn]
    • [MEM1]
    • [MEM2]
    • [MEM]
    • [Sn]
    • [SREGn
    • [Vvariable]
    • [Xhex list]

    When special constructions are used in the HH:MM:SS time specification, the result of evaluating the constructions must produce a valid HH:MM:SS time value.

    Example 5:

    MATH MEM2 = "15:20"
WAIT -t [MEM2] Please Standby...

    Example 6:

    MATH MEM2 = "Please Standby"
WAIT -t 15:20 [MEM2]

    The [Ddelay] construction may not be used in a WAIT statement which specifies the count-down time using the "-t" argument.

    If the DELAY special construction is placed before the message, the WAIT message is displayed after the DELAY time has elapsed, and the WAIT message closes after 1.2 seconds.

    If the DELAY special construction is placed after the message, the WAIT message is displayed immediately and closes after the DELAY time has elapsed.

    If DELAY special constructions are placed both before and after the message, the WAIT message is displayed after first DELAY time has elapsed and closes after the last DELAY time has elapsed.

  6. If the WAIT statement does not contain a "-t" argument, text specified in the WAIT statement appears in a pop-up window, but the window does not include a count-down time display. When used in this mode, the WAIT statement will typically include a delay special construction to control the duration of the delay. If a delay is not specified a default delay of 1.2 seconds is used. Note also that the minimum delay for a pop-up message is 1.2 seconds.Therefore, a statement like:

    7. WAIT Please Standby[D500]

    will display the "Please Standby" message for 1.2 seconds. (500 milliseconds is below the minimum.) The only way to use WAIT to generate a delay less than 1.2 seconds is to use the statement without a pop-up message.

    In addition, since the statement is evaluated left to right, if the statement includes text for a pop-up window, the delay construction must appear after the message text in the procedure statement.

    When no "-t" argument is specified, "-a" should not be used, because pressing "Advance" will not terminate the evaluation of the [Ddelay] construction which controls the duration of the pop-up window.

    Example 7:

    WAIT Please Standby...[D3000]

    The message "Please Standby" will be displayed in a pop-up window for 3000 milliseconds.

    Example 8:

    WAIT [D250]

    A 250 millisecond delay occurs when the statement is executed. There's no pop-up window, because no message is specified.

    An empty WAIT statement is not illegal but is, in effect, ignored when it is executed.

    Example 9:

    WAIT

    Since neither a delay nor a message are specified this statement has no effect.

  7. Two-line messages are possible as shown in the following example:

    8. Example 10:

    MATH S[1] = "Please standby while\n"
MATH S[2] = "the instrument warms up."
MATH S[3] = S[1] & S[2]
WAIT -a -t 10:11:12 [S3]

    This method should not be used to construct pop-up messages which contain more than two lines, because the WAIT FSC window is not automatically sized and cannot accommodate more than two text lines.


CALL

Procedure Control FSC

Description

The CALL FSC allows a procedure to call a subprocedure. The called subprocedure terminates when the end of the subprocedure is reached. At that point, execution of the calling procedure resumes at the first statement after the CALL statement.

Format

CALL procedure name

Rules

  1. A maximum of 55 bytes is allowed in the procedure name field. Characters below ASCII 128 occupy one byte.

  2. Blank spaces preceding or following the procedure name are ignored.

  3. The comparison between the name of the called subprocedure and names in the MET/CAL Procedure directory is case-insensitive.

  4. Each called subprocedure must exist as a separate, compiled MET/CAL procedure file. There is no actual distinction between main procedures and subprocedures. Any procedure can call any other procedure. A procedure should not call itself, directly or indirectly, unless the procedure writer ensures that procedure termination is handled properly.

  5. The maximum procedure call nesting depth is 8.

  6. Most internal data values maintained by MET/CAL are global. This applies to memory registers (MEM, MEM1, MEM2, M[1], M[2], ...), ASK flags, SET FSC messages, and DRAW parameters. These data values are available on entry into a called procedure, and, on exit from the subprocedure, retain their most recently assigned values, whether or not the assignment occurred in the called procedure.

    Example:

    INSTRUMENT:            main
  1.001  MATH         MEM = 29
  1.002  CALL         sub
  1.003  DISP         MEM = [MEM]

    INSTRUMENT:            sub
  1.001  DISP         sub:  MEM = [MEM]
  1.002  MATH         MEM = 11

    In the example above, the main procedure sets MEM to 29. It then calls the procedure "sub". "sub" displays the value of MEM, which is still 29, and then sets MEM to 11 before it returns. When the main procedure resumes, it displays the updated value of MEM (now 11).

Examples

  1.001  CALL         Fluke 8050A AC Gain Adjustment
  1.002  CALL         Fluke 8050A AC Zero Adjustment


END

Procedure Control FSC

Description

The END FSC is used to terminate procedure execution. An END statement may occur at any point in a procedure. It may have a step number, and may be the destination of a jump statement. No information is allowed after the FSC in an END statement. An END statement is not required in a procedure, since simply executing the last statement in a procedure has the effect of terminating execution (unless, of course, the last statement is a jump or a call statement).

Format

END

Example

  1.001  DISP         This is a test.
  1.002  END


IF, ELSE, ELSEIF, and ENDIF

Procedure Control FSC

Description

The IF, ELSE, ELSEIF, and ENDIF FSCs are used to specify conditional execution of procedure sections.

These FSCs may be used to improve procedure readability and procedure maintainability.

Format

IF [expression]

ELSE [comment]

ELSEIF [expression]

ENDIF [comment]

Rules

  1. The expression in an IF or ELSEIF statement may be any valid math expression, as defined by the MATH FSC. Note that the expression cannot be an assignment. That is, IF and ELSEIF cannot be used to change the value of a register. The rule is that anything valid on the right-hand side of an assignment in a MATH statement is also valid as a expression (space permitting).

  2. An IF statement must always be paired with a following ELSE, ELSEIF, or ENDIF statement.

  3. An ELSE statement must always be paired with a following ENDIF statement.

  4. An ELSEIF statement must always be paired with a following ELSE or ENDIF statement.

  5. When an IF statement executes, if the expression evaluates to a non-zero value, control transfers to the following statement. If the expression evaluates to zero, control transfers to the associated ELSE, ELSEIF, or ENDIF statement.

  6. When an ELSE statement executes, control transfers to the following statement if the preceding associated IF or ELSEIF statement expression evaluated to zero. Otherwise, control transfers to the associated ENDIF statement.

  7. When an ELSEIF statement executes, if the preceding associated IF or ELSEIF statement expression evaluated to a non-zero value, control transfers immediately to the following associated ELSEIF or ENDIF statement. Otherwise, if the ELSEIF expression evaluates to a non-zero value, control transfers to the following statement. Otherwise, control transfers to the following associated ELSEIF or ENDIF statement.

  8. ELSE and ENDIF statements may be followed by optional comments on the same line. The comment must be preceded by a valid comment symbol ('#' or ';').

  9. The expression in a IF or ELSEIF statement is evaluated as a numeric expression. If the specified expression produces a string value, the string is converted to numeric form for purposes of the IF or ELSEIF statement. In general, this is not recommended, because it usually makes the procedure less readable.

  10. Proper program structure should be maintained. Jumping directly into or out of an IF ... ELSEIF ... ELSE ... ENDIF procedure block is not recommended. (It is not illegal to do so, however. If a procedures jumps into such a block, execution continues as if the preceding part of the block were not present.)

  11. Each line of the FSC statement may contain up to 256 bytes, including the step number and the FSC text. Characters below ASCII 128 occupy one byte.

Examples

Example 1:

  1.001  MEMI         Enter an integer:

  1.002  IF           (MEM > 5)
  1.003  DISP         [MEM] is greater than 5
  1.004  ELSE
  1.005  DISP         [MEM] is less than or equal to 5
  1.006  ENDIF

The first DISP statement (1.003) will be executed if an integer greater than 5 is entered.

The second DISP statement (1.005) will be executed if an integer less than or equal to 5 is entered.

Example 2:

  1.007  MEMI         Enter an integer:

  1.008  IF           (MEM == 1)
  1.009  DISP         value is 1
  1.010  ELSEIF       (MEM == 2)
  1.011  DISP         value is 2
  1.012  ELSEIF       (MEM == 3)
  1.013  DISP         value is 3
  1.014  ELSEIF       (MEM > 3)
  1.015  DISP         value is greater than 3
  1.016  ELSE
  1.017  DISP         value is less than 1
  1.018  ENDIF

Example 3:

  1.019  ASK-   R   Q N              P J             C                     V

  1.020  OPBR         Do you want this procedure to PAUSE on failed tests?

  1.021  IF           MEM1 > 0
  1.022  ASK+                                          X
  1.023  ASK-                                                     F
  1.024  ELSE
  1.025  ASK-                                                     A
  1.026  ENDIF

Example 4:

  1.027  IF           PSUBI("Fluke 185")
  1.028  TOL          0.4U
  1.029  ELSE
  1.030  TOL          0.5U
  1.031  ENDIF

  1.032  MEMCX  500   50.0mV         TOL           60H


JMP

Procedure Control FSC

Description

The JMP FSC is used to perform unconditional jumps in a MET/CAL procedure, or to perform conditional jumps based on the PASS/FAIL status of the most recent evaluation step. For a conditional jump, the most recent evaluation may be an instrument evaluation, MEMC, EVAL, PICE, or DOSE statement.

FORMAT

JMP step number condition

where condition is one of:

  • blank
  • PASS
  • FAIL

Rules:

  1. If condition is blank the specified step is unconditionally executed next.

    Example:

      1.001  JMP          1.003
  1.002  DISP         This statement won't be executed.
  1.003  DISP         This statement will be executed.

    When statement 1.001 is executed, an unconditional jump to 1.003 occurs. 1.002 will not be executed.

    +If condition is PASS, the specified step is executed next if the result of the most recent evaluation was PASS. If the result of the most recent evaluation was FAIL, execution continues with the procedure statement immediately following the JMP statement.

    Example:

      1.001  EVAL   YES or NO
  2.001  JMP          2.004          PASS
  2.002  DISP         Operator selected NO
  2.003  JMP          2.005
  2.004  DISP         Operator selected YES
  2.005  END

    In this example the first statement is an operator evaluation (EVAL statement).

    If the operator chooses YES, the evaluation is a PASS. When statement 2.001 is executed, a jump to DISP statement 2.004 occurs, and a message is displayed indicating that the operator selected YES.

    If the operator chooses NO, the evaluation is a FAIL. When statement 2.001 is executed, no jump occurs. Execution continues with 2.002 which displays a message indicating that that the operator selected NO. 2.003 is executed next, which causes an unconditional jump to the END statement.

  2. If condition is FAIL, the specified step is executed next if the result of the most recent evaluation was FAIL. If the result of the most recent evaluation was PASS, execution continues with the procedure statement immediately following the JMP statement.

    Example:

      1.001  EVAL   YES or NO
  2.001  JMP          2.004          FAIL
  2.002  DISP         Operator selected YES
  2.003  JMP          2.005
  2.004  DISP         Operator selected NO
  2.005  END

    In this example the first statement is an operator evaluation (EVAL statement). If the operator chooses YES, the evaluation is a PASS. When statement 2.001 is executed, no jump occurs. Execution continues with 2.002 which displays a message indicating that the operator selected YES. 2.003 is executed next, which causes an unconditional jump to the END statement.

    If the operator chooses NO, the evaluation is a FAIL. When statement 2.001 is executed, a jump to DISP statement 2.004 occurs, and a message is displayed indicating that the operator selected NO.

  3. If a conditional JMP statement is executed, and no preceding evaluations have been performed, the JMP statement is executed as if the most recent evaluation resulted in a PASS.
  4. If the jump destination (step number) is omitted from a JMP statement, the destination defaults to the end of the procedure. This terminates execution of the active procedure.
  5. Jump destination step numbers must be between 1.001 and 999.999.
  6. If the minor step number is omitted, the procedure compiler automatically inserts .001 as the minor step number.


JMPF

Procedure Control FSC

Description

The JMPF FSC is used to perform a conditional jump based on the value of MEM1 or based on the selected procedure name.

The selected procedure name is the name under which the currently executing procedure is running. If the executing procedure is the main procedure, the selected name is the name which was chosen in the procedure selection dialog. If the currently executing procedure is a subprocedure, the selected name is the name by which the subprocedure was called.

Format

JMPF [step number] [procedure name] where procedure name may be blank or may specify a MET/CAL procedure name.

Rules

  1. If procedure name is blank, JMPF jumps if the value of MEM1 is less than zero. If the value of MEM1 is greater than or equal to zero, execution continues with the statement immediately following the JMPF statement.

    Example:

    1.001 OPBR	YES or NO
1.002 JMPF	1.005
1.003 DISP	Operator selected YES
1.004 JMP	1.006
1.005 DISP	Operator selected NO
1.006 END

    When an operator branch (OPBR) statement is executed, MEM1 is set to 1 if the operator answers YES, and is set to -1 if the operator answers NO.

    In the example above, if the operator selects YES, MEM1 is set to 1. The JMPF statement therefore does not jump to 1.005. Instead, execution continues with the statement which immediately follows the JMPF statement. This is 1.003, a DISP statement which displays a message indicating that the operator selected YES. Next, when 1.004 is executed, the procedure jumps unconditionally to 1.006.

    If the operator selects NO, MEM1 is set to -1. Since MEM1 is less than zero, the JMPF statement (1.002) causes a JUMP to 1.005 to occur. 1.005 is a DISP statement which displays a message indicating that the operator selected NO.

  2. If procedure name is not blank, JMPF jumps if the name of the active procedure does not match the name specified in the JMPF statement. If the selected procedure name matches the name specified in the JMPF statement, execution continues with the statement immediately following the JMPF statement.

    Example:

    Suppose the main procedure contains the following CALL statement:

    CALL Sub A

    Suppose the called subprocedure contains:

    INSTRUMENT:	Sub A
INSTRUMENT:	Sub B
1.001 JMPF	1.004	Sub B
1.002 DISP	Selected Procedure Name is "Sub B"
1.003 JMP	1.005
1.004 DISP	Selected Procedure Name is not "Sub B".
1.005 END

    The subprocedure has two names: "Sub A" and "Sub B".

    When the CALL Sub A statement is executed in the main procedure, subprocedure execution begins with "Sub A" as the selected name.

    When the JMPF statement executes, the name of the selected procedure name ("Sub A") is compared to the procedure name specified in the JMPF statement ("Sub B"). Since the names do not match, a jump to 1.004 occurs. 1.004 is a DISP statement which displays a message indicating that the selected procedure name is not "Sub B".

    If the main procedure had called the subprocedure using the name "Sub B" instead of "Sub A", the selected name would have matched the name in the JMPF statement, and the jump to 1.004 would not have occurred.

    The mechanism illustrated in this example may be useful when a single procedure is used for a family of closely related UUTs. For example, a single procedure could be written for the Fluke 73, 75, and 77 DMMs. The procedure could be given 3 names, one for each model number. The JMPF (and JMPT) FSCs can then be used to do conditional jumps based on the model number.

  3. If a jump destination (step number) is not specified, a jump to the end of the active procedure occurs. This terminates execution of the active procedure.
  4. Jump destination step numbers must be between 1.001 and 999.999.
  5. If the minor step number is omitted, the procedure compiler automatically inserts .001 as the minor step number.

  6. The procedure name field in a JMPF statement is limited to 41 characters. If a JMPF statement specifies a 41-character procedure name, and the name of the active procedure is longer than 41 characters, MET/CAL considers the names to be the same if the first 41 characters of the active procedure name match the name specified in the JMPF statement.

    Example:

    INSTRUMENT:	This procedure name contains more than 41 characters.
1.001	JMPF	1.004         This procedure name contains more than 41
1.002	DISP	Names match.
1.003	JMP	1.005
1.004	DISP	Names do not match.

    When the JMPF statement is executed, the name specified in the JMPF statement matches the name of the procedure, even though the full procedure name does not fit in the JMPF statement. Since the names match, the jump to 1.004 does not occur. 1.002 DISP is therefore executed, which displays a message indicating that the names match.


JMPL

Procedure Control FSC

Description

The JMPL FSC is used to perform conditional jumps in a MET/CAL procedure.

Each JMPL statement specifies a jump destination label and an optional MATH expression. If there is an expression, and it evaluates to a non-zero value, a jump to the specified label is done when the JMPL statement executes. If there is an expression and it evaluates to zero, procedure execution continues with the statement following the JMPL statement. If there's no expression, an unconditional jump to the specified label is done when the JMPL statement executes.

JMPL must be used in conjunction with the LABEL FSC. Only the LABEL FSC can specify the JMPL destination.

JMPL has two advantages over other MET/CAL jump-type FSCs:

  1. The jump destination is specified as a label rather than a step number. This means that when the procedure compiler compiles the procedure, the literal jump destination doesn't change, as it may with JMP, JMPF, JMPT, and JMPZ. This may assist procedure writing and procedure readability.
  2. The expression which defines the jump condition may be any MATH expression. This may improve readability and flexibility in specifying the jump condition.

Format

JMPL label [expression]

Rules

  1. The label may contain any characters except blanks and nuls (zero).
  2. The label and the expression, taken together are limited to 256 bytes, including one or more spaces to separate the label from the expression. Characters below ASCII 128 count as one byte.
  3. When the JMPL statement executes, the jump is done only if the expression evaluates to a non-zero value, or if there's no expression.
  4. The expression may be any valid math expression, as defined by the MATH FSC. Note that the expression in a JMPL statement cannot be an assignment. That is, JMPL cannot be used to change the value of a register. The rule is that anything valid on the right-hand side of an assignment in a MATH statement is also valid as a JMPL expression (space permitting).
  5. Every JMPL statement must have exactly one jump destination. A procedure cannot be executable if the jump destination is missing, or if there are multiple jump destinations (that is, multiple LABEL statements which specify the same label).
  6. The expression in a JMPL statement is evaluated as a numeric expression. If the specified expression produces a string value, the string is converted to numeric form for purposes of the JMPL statement. In general, this is not recommended, because it usually makes the procedure less readable.

Examples

Example 1:

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
         JMPL         abc     m[4] < 12
         .
         .
         .
         LABEL        abc

In this example the procedure jumps to the LABEL statement if the value in the M[4] register is less than 12.


JMPT

Procedure Control FSC

Description

The JMPT FSC is used to perform a conditional jump based on the value of MEM1 or based on the selected procedure name.

The selected procedure name is the name under which the currently executing procedure is running. If the executing procedure is the main procedure, the selected name is the name which was chosen in the procedure selection dialog. If the currently executing procedure is a subprocedure, the selected name is the name by which the subprocedure was called.

Format

JMPT [step number] [procedure name]

where procedure name may be blank or may specify a MET/CAL procedure name.

Rules

  1. If procedure name is blank, JMPT jumps if the value of MEM1 is greater than zero. If the value of MEM1 is less than or equal to zero, execution continues with the statement immediately following the JMPT statement.

    Example:

      1.001  OPBR         YES or NO
  1.002  JMPT         1.005
  1.003  DISP         Operator selected NO
  1.004  JMP          1.006
  1.005  DISP         Operator selected YES
  1.006  END

    When an operator branch (OPBR) statement is executed, MEM1 is set to 1 if the operator answers YES, and is set to -1 if the operator answers NO.

    If the operator selects YES, MEM1 is set to 1. Since MEM1 is greater than zero, the JMPT statement (1.002) causes a JUMP to 1.005 to occur. 1.005 is a DISP statement which displays a message indicating that the operator selected YES.

    If the operator selects NO, MEM1 is set to -1. Since MEM1 is less than or equal to zero, the JMPT statement does not jump to 1.005. Instead, execution continues with the statement which immediately follows the JMPT statement. This is 1.003, a DISP statement which displays a message indicating that the operator selected NO. Next, when 1.004 is executed, the procedure jumps unconditionally to 1.006.

  2. If procedure name is not blank, JMPT jumps if the name of the active procedure matches the name specified in the JMPT statement. If the selected procedure name does not match the name specified in the JMPT statement, execution continues with the statement immediately following the JMPT statement.

    Example:

    Suppose the main procedure contains the following CALL statement:

    CALL Sub B

    Suppose the called subprocedure contains:

    INSTRUMENT:            Sub A
INSTRUMENT:            Sub B
  1.001  JMPT         1.004          Sub B
  1.002  DISP         Selected Procedure Name is not "Sub B"
  1.003  JMP          1.005
  1.004  DISP         Selected Procedure Name is "Sub B".
  1.005  END

    The subprocedure has two names: "Sub A" and "Sub B". When the "CALL Sub B" statement is executed in the main procedure, subprocedure execution begins with "Sub B" as the selected name.

    When the JMPT statement executes, the name of the selected procedure name ("Sub B") is compared to the procedure name specified in the JMPT statement ("Sub B"). Since the names match, a jump to 1.004 occurs. 1.004 is a DISP statement which displays a message indicating that the selected procedure name is "Sub B".

    If the main procedure had called the subprocedure using the name "Sub A" instead of "Sub B", the selected name would not have matched the name in the JMPT statement, and the jump to 1.004 would not have occurred. The mechanism illustrated in this example may be useful when a single procedure is used for a family of closely related UUTs. For example, a single procedure could be written for the Fluke 73, 75, and 77 DMMs. The procedure could be given 3 names, one for each model number. The JMPT (and JMPF) FSCs can then be used to do conditional jumps based on the model number.

  3. If a jump destination (step number) is not specified, a jump to the end of the active procedure occurs. This terminates execution of the active procedure.
  4. Jump destination step numbers must be between 1.001 and 999.999.
  5. If the minor step number is omitted, the procedure compiler automatically inserts .001 as the minor step number.
  6. The procedure name field in a JMPT statement is limited 41 characters. Characters above ASCII 128 count as 2. If a JMPT statement specifies a 41-character procedure name, and the name of the active procedure is longer than 41 characters, MET/CAL considers the names to be the same if the first 41 characters of the active procedure name match the name specified in the JMPT statement.

    Example:

    INSTRUMENT:            This procedure name contains more than 41 characters.
  1.001  JMPT         1.004          This procedure name contains more than 41
  1.002  DISP         Names do not match.
  1.003  JMP          1.005
  1.004  DISP         Names match.

    When the JMPT statement is executed, the name specified in the JMPT statement matches the name of the procedure, even though the full procedure name does not fit in the JMPT statement. Since the names match, the jump to 1.004 occurs. 1.004 DISP is therefore executed, which displays a message indicating that the names match.


JMPZ

JMPZ

Procedure Control FSC

Description

The JMPZ FSC is used to perform a conditional jump based on the value of MEM1. If the value of MEM1 is zero, JMPZ causes a jump to the specified jump destination (step number). An optional tolerance for the comparison may be specified.

FORMAT

JMPZ step number tolerance where tolerance may be blank, or may specify a numeric expression followed by the letter 'U'.

RULES

• If tolerance is blank, JMPZ jumps to the specified jump destination only if the value of MEM1 is exactly zero.

• If tolerance is not blank, JMPZ jumps to the specified destination if the value of MEM1 is within the specified tolerance of zero.

Example:

JMPZ

1.002

.0001U

When this statement is executed, the jump to 1.002 will occur if the value of MEM1 is between -0.0001 and +0.0001.

MEM1 is stored internally as a floating-point number. When a computer compares two floating-point numbers for exact equality, the comparison may be unreliable due to small round-off errors introduced in the process of performing calculations. Whether such round-off errors are present depends on the numbers, and the sequence of operations, involved. To eliminate the possibility of unexpected results using a JMPZ statement, procedure writers are advised to always specify a small tolerance.

  • When a tolerance is specified, only the absolute value is significant.

Example:

JMPZ | 1.002 | +1E6
JMPZ | 1.002 | -1E6

The above two statements are equivalent. In both cases, the jump will be performed if the value of MEM1 is within 1E6 of zero.

  • The tolerance, if specified, may be a simple number or any numeric expression compatible with the MATH FSC. Refer to the on-line help for the MATH FSC for information about expression syntax. When the tolerance is specified as a numeric expression, the expression may not contain spaces. The length of the expression, not counting the trailing 'U', is limited to 41 characters.

Examples:

JMPZ

2.001

MEMU

In this example, the numeric expression is "MEM". The jump will be done if, at run time, the value of MEM1 is within +/-MEM of zero.

JMPZ

2.001

M[1]+.001U

In this example, the numeric expression is "M[1]+.001". The jump will be done if, at run time, the value of MEM is within +/-(M[1]+.001) of zero.

The ability to specify tolerance as a numeric expression was added in MET/CAL V5.0. Prior to V5.0, the tolerance could be expressed only as a simple number.

  • If a jump destination (step number) is not specified, a jump to the end of the procedure occurs. This terminates execution of the procedure.
  • Jump destination step numbers must be between 1.001 and 999.999.
  • If the minor step number is omitted, the procedure compiler automatically inserts .001 as the minor step number.


LABEL

Miscellaneous FSC

Description

The LABEL FSC is used to specify a label which can serve as the jump destination for a JMPL statement.

Format

LABEL label

Rules

  1. Any string of characters, not including blanks and nuls (zero), may be used as a label.
  2. The LABEL FSC restricts labels to 240 bytes. Characters below ASCII 128 count as one byte. As a practical matter, the maximum label length is shorter than 240 bytes. This is because the label is only useful as a JMPL destination, and the JMPL statement usually specifies both a label and a MATH expression in 240 bytes or less. Refer to the JMPL manual for more information.
  3. Labels are case-sensitive.

Examples

Example 1:

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
  1.001  JMPL         abc     mem < 10
  1.002  DISP         no
  1.003  END
  1.004  LABEL        abc
  1.005  DISP         yes

In this example the procedure jumps to 1.004 and then prints "yes" if MEM is less than 10. Otherwise the procedure prints "no". Note that the step number of the jump destination (1.004 in this example) makes no difference. The important point is that the body of the LABEL statement (here "abc") matches the destination specified in the JMPL statement.


RPT

Procedure Control FSC

Description

The RPT FSC causes an unconditional jump to the first step of the current test.

Format

RPT

Rules

  1. RPT can be used only in an adjustment block.
  2. The RPT FSC causes the entire test to be repeated. Frequently, special set-up instructions are given using, for example, the DISP FSC. These set-up instructions precede the evaluation step. Since RPT jumps to the first step of the test (i.e., the statement with minor step number 001), the set-up instructions are also repeated. If this is undesirable, a JMP statement which jumps directly to the evaluation step may be used instead of a RPT statement.


TARGET

Miscellaneous FSC

Description

The TARGET FSC is used to specify a jump destination to be used in conjunction with the Post Test Repeat and Cancel options, and/or with Multiple Measurement mode.

Format

TARGET [-m] [-p]

Rules

The purpose of the TARGET FSC is to more conveniently allow a MET/CAL test to be written so that one or more initial statements of the test are executed only the first time the test is executed.

(Recall that a test in the MET/CAL procedure language is a group of one or more statements which all have the same major step number. Each test is terminated by an evaluation step.)

This facility may be useful in multiple measurement mode, if one or more connection messages, HEAD statements, RSLT statements, and so on, are appropriate only for the first execution of the test. It also may be useful in conjunction with the Post Test "Repeat" and "Cancel" options.

TARGET -m

The "-m" option specifies the repeat target in multiple measurement mode.

TARGET -p

The "-p" option specifies the repeat target for the Post Test Repeat and Cancel options. The ASK 'P' flag affects the Repeat and Cancel options as follows:

If the ASK 'P' flag is set (ASK+ P), no jump is performed when Repeat or Cancel are chosen. That is choosing Repeat or Cancel in the Post Test dialog causes the current statement to be re-executed. If the ASK 'P' flag is not set (ASK- P), choosing Repeat or Cancel in the Post Test dialog, causes execution to resume at the closest preceding TARGET statement in the same test which specifies the "-p" option.

Note that an empty TARGET statement implicitly specifies "-p". If the test does not include a TARGET statement which specifies "-p", or an empty TARGET statement, execution resumes at the first statement of the test.

Empty TARGET Statement

An empty TARGET statement is equivalent to TARGET -m -p. That is, it specifies a target used both for Post Test Repeat/Cancel and for Multiple Measurement mode.

Examples

STEP  FSC    RANGE NOMINAL TOLERANCE MOD1 MOD2  3  4  CON
1.001 ASK-                 P
1.002 EVAL   Test #1

2.001 DISP         Message #1
2.002 TARGET
2.003 DISP         Message #2
2.004 EVAL   Test #2

If the user chooses "No" in response to the "Test #2" EVAL prompt, causing the test to fail, the Post Test dialog will be displayed. If the user then chooses "Repeat" or "Cancel" in the Post Test dialog, procedure execution will resume at line 2.002. (If the TARGET statement weren't there, execution would resume at 2.001.)

Note also that if the line 2.002 in the above example were changed to TARGET -m, it would have no effect on the Post Test "Repeat" and "Cancel" options. It would be as if the TARGET statement weren't there, and execution would resume at 2.001.


WHILE, ENDW, DO, and UNTIL

Procedure Control FSCs

Description

The WHILE, ENDW, DO, and UNTIL FSCs are used to loop over a specified block of procedure statements until a specified condition is true.

Format

WHILE expression

ENDW comment

DO comment

UNTIL expression

Rules

  1. The expression in a WHILE or UNTIL statement may be any valid math expression, as defined by the MATH FSC. Note that the expression cannot be an assignment. That is, WHILE and UNTIL cannot be used to change the value of a register. The rule is that anything valid on the right-hand side of an assignment in a MATH statement is also valid as a expression (space permitting).

  2. A WHILE statement must always be paired with a following ENDW statement.

  3. A DO statement must always be paired with a following UNTIL statement.

  4. When a WHILE statement executes, if the expression evaluates to a non-zero value, control transfers to the following statement. If the expression evaluates to zero, control transfers to the associated ENDW statement.

  5. When an ENDW statement executes, control transfers to the following statement if the previous evaluation of the WHILE expression resulted in zero. Otherwise, control transfers back to the associated WHILE statement.

  6. When a DO statement executes control transfers to the following statement.

  7. When an UNTIL statement executes, if the expression evaluates to a non-zero value, control transfers to the associated DO statement. Otherwise, control transfers to the statement following the UNTIL statement.

  8. ENDW and DO statements may be followed by optional comments on the same line. The comment must be preceded by a valid comment symbol ('#' or ';').

  9. The expression in a WHILE or UNTIL statement is evaluated as a numeric expression. If the specified expression produces a string value, the string is converted to numeric form for purposes of the WHILE or UNTIL statement. In general, this is not recommended, because it usually makes the procedure less readable.

  10. Proper program structure should be maintained. Jumping directly into or out of a WHILE ... ENDW procedure block, or a DO ... UNTIL procedure block, is not recommended. (It is not illegal to do so, however. If a procedures jumps into such a block, execution continues as if the preceding part of the block were not present.)

  11. It is very important for procedure writers to recognize that in general one should not write a procedure which loops over one or more evaluation steps. Such loops are legal programming constructs, but usually will not generate the expected results, because MET/CAL involves all executions of an evaluation step (as identified by the step number) as repetitions of the same test.

  12. Each line of the FSC statement may contain up to 256 bytes, including the step number and the FSC text. Characters below ASCII 128 occupy one byte.

Examples

Example 1

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
  1.001  MATH         MEM = 10

  1.002  WHILE        (MEM > 0)
  1.003  HEAD         [MEM][D1000]
  1.004  MATH         MEM = MEM - 1
  1.005  ENDW

This procedure fragment will execute the loop 10 times while it counts down the value of MEM.

Example 2

  1.006  MATH         MEM = 0

  1.007  DO
  1.008  HEAD         [MEM][D1000]
  1.009  MATH         MEM = MEM + 1
  1.010  UNTIL        (MEM == 10)

This procedure fragment will execute the loop 10 times while it counts up the value of MEM.


ACC

Miscellaneous FSC

Description

The ACC FSC enables MET/CAL to calculate a Test Uncertainty Ratio for a user-configured system instrument by allowing the procedure writer to specify the reference accuracy. The ACC FSC must be used in conjunction with an associated MEMC or MEMCX statement.

Format

ACC rangenominaltolerance [mod1] [con]

Rules

+ RANGE Field

The RANGE field in the ACC FSC has two uses. First, it can be referred to by the TOLERANCE field. For example, a TOLERANCE specification of "1/" indicates 1% of the RANGE value. The second use is as a stand-in for the ACC NOMINAL value at compile time. If the ACC FSC does not directly specify a NOMINAL value, but does specify a RANGE value, the compile-time T.U.R. calculation uses the RANGE value in place of the NOMINAL value. The RANGE field is optional. For compatibility with other FSCs, the RANGE field may contain a number or an 'A' (for AUTORANGE), however an 'A' in the ACC RANGE field has no effect.

The ACC RANGE field is compatible with the RANGE field in an instrument FSC. Refer to the RANGE field rules section under "Instrument FSCs" in Chapter 1 of the MET/CAL Procedure Language Reference Manual.

+ NOMINAL Field

The NOMINAL field specifies the value at which the system accuracy is to be determined. If the ACC NOMINAL does not specify a numeric value, the NOMINAL value is taken from memory register MEM at runtime. Like MEMC and MEMCX, the ACC FSC allows an arbitrary units string to be specified in the NOMINAL field. When an ACC FSC is paired with a MEMC or MEMCX statement, the units string in the ACC NOMINAL field documents the procedure and is used when the System Actual, UUT Indicated, System Tolerance, and Test Tolerance are printed in the Post Test summary and results. As with MEMC and MEMCX, MET/CAL does not evaluate any units prefix specified in the ACC NOMINAL field. The NOMINAL values in the ACC and MEMC or MEMCX statements are presumed to be in the same units.

The general format for the NOMINAL field of the ACC FSC is:

[value]string

The following rules apply to the ACC NOMINAL field:

  1. string need not be present if there is a numerical value.
  2. string may be any text string, with the following restrictions:
    1. The string cannot contain blanks.
    2. The last character in the string cannot be a '/', '%' or 'U'.
    3. A field consisting of a number followed by 'R' or 'r' is identified as a RANGE field.
    4. A field which is simply "R" or "r" is identified as a RANGE field.
  3. string does not affect the NOMINAL value used to calculate the reference accuracy. The procedure writer must ensure that the NOMINAL values given in the ACC and associated MEMC or MEMCX statement are in commensurate units. Otherwise, the T.U.R. calculation will be incorrect.
  4. A maximum of 14 characters is allowed in the NOMINAL field.
  5. The value is specified in floating-point format (NR3). It may contain a sign, a decimal point, and may be expressed in scientific notation (E-format).

+ TOLERANCE Field

The TOLERANCE field specifies the tolerance used to calculate the reference accuracy. The tolerances may be specified with respect to the ACC NOMINAL value, with respect to the ACC RANGE value, in absolute units, or in some combinations of these three ways. The tolerances should reflect the instrument specifications of the user-configured system instrument at the specified NOMINAL value.

An asymmetrical tolerance specification has no purpose when used in an ACC statement. The maximum deviation from the ACC NOMINAL will be taken to be the reference accuracy when an asymmetrical specification is given. For example,

ACC 10V +1% -2%

specifies an asymmetrical tolerance in which the upper deviation is 0.1V and the lower deviation is 0.2V. The system accuracy is the maximum of the two deviations, which is 0.2V. The TOLERANCE field is limited to 14 characters and may contain up to 3 subfields. Allowed formats for the subfields are:

[val]% | % of NOMINAL
[val]/ | % of RANGE
[val]P% | PPM of NOMINAL
[val]P/ | PPM of RANGE
[val]U | Units of NOMINAL
TOL | use TOLERANCE spec in last "TOL" FSC

val, if specified, may be a literal numeric value or may specify a numeric register in the form Mi where i is the register index (1 to 255). If val is not specified, the tolerance value is taken from numeric register MEM.

Examples:

ACC 10V M23%

In this example the tolerance is specified as a percentage of the NOMINAL (10V) and the tolerance value is taken from numeric register M[23] at run time.

ACC 10V U

In this example the tolerance is specified in absolute units (in this case volts) and the tolerance value is taken from numeric register MEM at run time.

+ MOD1 Field

The MOD1 field in an ACC statement may optionally be used to specify an impedance value.The syntax is:

value[units prefix]Z

MET/CAL V7.20 SP1 or later is required to specify the impedance in MOD1. An ACC impedance specification is used only when the linearization method is +V (in the CON field) and the NOMINAL

units are dBm.

+ CON Field

The CON field in an ACC statement may optionally be used to specify a linearization method.

MET/CAL V7.20 SP1 or later is required to specify the linearization method in CON.

The following linearization methods are valid:

+V
When NOMINAL units are dBm +V causes linearization to voltage.
When NOMINAL units are dB +V causes linearization to percentage (voltage ratio).
(Refer to MATH FSC documentation for the "DBTOPCTV_D" function for additional information about this conversion.)
+DV
When NOMINAL units are dB +DV causes linearization to percentage (voltage ratio delta).
+W
When NOMINAL units are dBm +W causes linearization to power (watts).
When NOMINAL units are dB +W causes linearization to percentage (power ratio).
+DW
When NOMINAL units are dB +DW causes linearization to percentage (power ratio delta).
(Refer to MATH FSC documentation for the “DBTOPCTW_D” function for additional information about this conversion.)

Refer also to the VSET parameter "LogLin". "LogLin" provides an alternate method of specifying the linearization method. An ACC specification allows the compile time Test Uncertainty Ratio to be calculated, whereas "LogLin" is a run time-only specification.On the other hand, using VSET to specify "LogLin" supports dynamic specification (where the value is taken from a register or variable), whereas using the ACC CON field does not support dynamic specification. (The procedure writer should use either ACC or VSET, as appropriate.)

+ Memory Registers

Execution of an ACC statement causes the ACC NOMINAL value to be copied into memory register MEM1. The ACC NOMINAL value is the numeric value specified in the ACC NOMINAL field. If no numeric value is specified in the ACC NOMINAL field, the value is taken from memory register MEM. The ACC FSC does not change the value of the other MET/CAL memory registers (MEM, MEM2, M[1], ..., M[255]). Note than the ACC FSC functions in the same manner as an Instrument SETUP statement with regard to its effect on MEM1.

Examples

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
# Reference is a source (System Instrument)
  1.001  5700         2V                           60H                  S  2W
  1.002  MATH         MEM = MEM1 * 1.414
# Get 5700A accuracy at 2V, 60Hz and convert to volts peak.
  1.003  MATH         M[1] = ACCV2("Fluke 5700A", "Volts", 2.0, 60.0)
  1.004  MATH         M[1] = M[1] * 1.414
  1.005  ACC          Vp             M1U
  1.006  DISP         Press the MIN MAX button.
  1.006  DISP         Press the BEEPER button to display maximum values.
  1.007  MEMI         Enter UUT reading in volts peak:
  1.008  MEMCX        Vp             0.045U
# Reference is a sensor (User-configured Instrument)
  2.001  IEEE         [@DMM]DCV 10;ARANGE ON;NPLC 10;MATH OFF;AZERO ON
  2.001  IEEE         [@DMM]FIXEDZ OFF;MEM OFF;DELAY -1;NDIG 6;NRDGS 1,AUTO
  2.001  IEEE         [@DMM]TARM AUTO;TRIG HOLD
  2.002  IEEE         OUT 10V;OPER;*OPC?[I!]
  2.003  IEEE         [@DMM]TRIG SGL[I!]TRIG SGL[I]
  2.004  ACC          V              2.6P% 2e-6U
  2.005  MATH         MEM = MEM1
  2.006  MEMC         10.00V         0.01U

The linkage between an ACC statement and an associated MEMC or MEMCX statement is disabled when ASK- U is in effect. (This works in the same manner as the association between an instrument SETUP statement and a MEMC or MEMCX statement.) When ASK- U is set, ACC statements have no effect. An ACC statement which is not paired with a MEMC or MEMCX statement in the same test has no effect. If an ACC FSC is paired with a MEMC or MEMCX statement, and an instrument Setup statement (MOD4 = 'S') or Nominal Setup statement (MOD4 = 'N') appears in the test as well, the ACC statement has priority over the instrument Setup or Nominal Setup statement in specifying the reference accuracy.

Example

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
  3.001  ACC          8.000V         0.0025U
  3.002  5700         8.000V                                            S  2W
  3.003  IEEE         [@UUT]?[I]
  3.004  MEMCX        8.000V         0.01%

In this example, the reference accuracy is .0025. It is not based on looking up the accuracy of the 5700A at 8 V in the appropriate MET/CAL accuracy file, as it would be if the ACC statement were not there.

Results may be unpredictable if a MEMC or MEMCX test includes 2 or more ACC or Instrument Setup or Nominal Setup statements and the state of the ASK 'U' flag is changed between those statements.


ACCF

Miscellaneous Instrument FSC

Description

The ACCF FSC allows an alternate accuracy file for a particular instrument FSC to be specified.

CAUTION #1 - Compile Time TURs vs. Run Time TURs

Procedure writers should carefully read the NOTES section below before using the ACCF FSC. Unless procedures are written to follow the guidelines indicated below, compile time and run time test uncertainty ratio (TUR) calculations may not agree.

CAUTION #2 - Measurement Uncertainty

When ACCF is used MET/CAL does not read the accuracy file header (if any). Specifically, this means that when MET/CAL normalizes the reference accuracy to 1 sigma, it uses a default confidence value (2 sigma), rather than the confidence specified in the accuracy file. If measurement uncertainty is enabled, then when any accuracy file containing specifications with a confidence other than 2 sigma is used, the procedure writer must also include in the procedure a VSET statement to directly specify the confidence. For example:

VSET CONF = 2.58

Should be used if the confidence is 99%.

Format

ACCF FSCAccuracy File

Rules

  1. FSC Field

    The FSC field specifies the name of the instrument FSC to which the alternate accuracy file applies.

  2. Accuracy File Field

    The Accuracy File field specifies the name of the alternate accuracy file, or restores the default accuracy file selection.

    • If the name is a full path specification, MET/CAL uses the name exactly as specified. (A full path specification is one which begins with a slash or backslash, or begins with a drive specifier like "C:".)
    • If the name is a partial path specification, the name is, by default, taken to be relative to the MET/CAL Accuracy File Folder. The Accuracy File Folder is specified in the MET/CAL Configuration settings.
    • See also: Partial Path is Relative to Accuracy Directory MET/CAL Configuration setting.

    MET/CAL expects the alternate accuracy file to be located in the Accuracy File Folder. If the Accuracy File field specifies "*" it indicates that the default accuracy file for the specified FSC is to be used for subsequent statements.

  3. Field Order

    The order of the fields is important. The FSC field must precede the Accuracy File field.

  4. Each line of the FSC statement may contain up to 256 bytes, including the step number and the FSC text. Characters below ASCII 128 occupy one byte.

Important Note on Compile Time Assumptions

The compile time system assumes that ACCF statements, if any, for a particular instrument FSC exist in the same procedure as the instrument FSC statement, and precede the instrument statement in the procedure. Procedure writers are strongly encouraged to write procedures which conform to these assumptions. Otherwise, TURs calculated at compile time will not agree with TURs calculated at run time.

"Compile time" includes pressing Enter, Debug > Compile Check Procedure (F9), starting the Editor's Debug Mode, generating TUR reports, and building or publishing a project or solution.

Specifically, procedure writers should adhere to the following rules:

  1. Do not write procedures in which an ACCF statement is intended to apply to an instrument FSC in another procedure (either the calling procedure or a called subprocedure).

    2. For example, do not write a procedure like this:

    INSTRUMENT: main
ACCF 5700 5700_95.90D
CALL sub

INSTRUMENT: sub
5700 1V .001%

    At run time, the ACCF-specified accuracy file will be used when the TUR calculation for the 5700 statement in the subprocedure is done, because the runtime is based on execution order. But at compile time, when the system searches back from the 5700 statement in the subprocedure for ACCF statements, none will be found and the default accuracy file will therefore be used.

    And do not, for example, write a procedure like this:

    INSTRUMENT: main
CALL sub_accf
5700 1V .001%

INSTRUMENT: sub_accf
ACCF 5700 5700_95.90D

    As in the preceding example, the runtime and compile time systems will not do the same TUR calculation. At compile time, when the 5700 statement in the main procedure is compiled, the system will use the default accuracy file, since it has no way of knowing that the subprocedure contains an ACCF statement. (Remember that when the main procedure is compiled the subprocedure need not exist.) But at run time the system will call the subprocedure first, execute the ACCF statement, and then, when the 5700 statement in the main procedure is executed, use the alternate accuracy file to do the TUR calculation.

  2. Do not write procedures in which jump statements are used to jump to an ACCF statement, which is then followed by a jump back to an instrument statement. For example, the following procedure could produce different compile time and run time TUR calculations:

    3. INSTRUMENT:            test
1.001  JMP          2.002
1.002  5700         1V             0.001%
2.001  JMP          2.004
2.002  ACCF   5700  5700_95.90D
2.003  JMP          1.002
2.004  END

    At compile time MET/CAL will search back from the 5700 statement and, not finding any ACCF statements, use the default accuracy file. At run time MET/CAL will execute the indicated JMP statements, execute the ACCF statement before the 5700 statement, and therefore use the alternate accuracy file to do the runtime TUR calculation.

Examples

Example 1

STEP  FSC  RANGE NOMINAL TOLERANCE MOD1 MOD2  3  4  CON
1.001 ACCF 5700  5700_95.90D
1.002 5700       1V      .001%

In this example an alternate accuracy file for the Fluke 5700A is specified. The accuracy file name is 5700_95.90D. Since the name is not a path specification, MET/CAL expects to find the file in the Accuracy File Folder.

When MET/CAL calculates the test uncertainty ratio (TUR) for the 5700 statement, the system uncertainty will be determined by looking in 5700_95.90D instead of the default accuracy file (5700.ACC).

Example 2

STEP  FSC  RANGE NOMINAL TOLERANCE MOD1 MOD2  3  4  CON
1.001 ACCF 5700  C:\ACC\5700.ACC
1.002 5700       1V      .001%

This is the same as the first example except that the ACCF statement specifies a full path name for the alternate accuracy file. MET/CAL will use the accuracy file name exactly as specified. It will not look in the MET/CAL accuracy directory.

Example 3

STEP  FSC  RANGE NOMINAL TOLERANCE MOD1 MOD2  3  4  CON
1.001 5700       1V      .001%
2.001 ACCF 5700  5700_95.90D
2.002 5700       1V      .001%
3.001 ACCF 5700  *
3.002 5700       1V      .001%

When the first 5700 statement is executed, the default accuracy file will be used, because, at that point, no ACCF statement has been executed. When the second 5700 statement is executed, the alternate accuracy file (5700_95.90D) specified in the ACCF statement will be used. When the third 5700 statement is executed, MET/CAL will use the default accuracy file. This is because the ACCF 5700 * statement restored use of the default 5700 accuracy file.


ASK+ and ASK-

Procedure Control FSCs

Description

The ASK+ and ASK- FSCs enable and disable the MET/CAL system control flags. The effect of each system flag is summarized below.

The procedure writer must make certain that safety is not compromised.

Quick Reference

Automatic Messages

The following flags control the display of messages during procedure execution.

Flag | Controls display of automatic... | Default setting
W | Connection messages, excl. divider | ASK+ W
V | Connection messages | ASK+ V
R | UUT range message | ASK+ R
S | SET FSC messages | ASK+ S
N | Instructions to perform test | ASK+ N
M | MOD1 value with test instructions | ASK+ M
D | Meter or Oscilloscope message format | 1
  1. The default value of the D-flag depends on the type of calibration system. The default is:
    • ASK- D for a meter calibration system
    • ASK+ D for a scope calibration system

If the System Type MET/CAL Configuration setting is "Meter", the workstation is configured as a meter calibration system. If the System Type setting is "Oscilloscope", the workstation is configured as an oscilloscope calibration system.

Stimulus Evaluation Statement Options

The following flags are used to select the method by which an operator enters a UUT Indicated value during procedure execution.

Flag | Controls evaluation mode | Default setting
G | Go/No-GO | ASK- G
B | Go/No-Go with Slew and Kybd Options | ASK- B
K | Keyboard entry | ASK- K

The G, B, and K flags are mutually exclusive. When the G, B, and K flags are all disabled, slew mode is used.

Post Test Options

The following flags determine which options in the Post Test dialog are enabled.

Flag | Enable / Disable | Default setting
A,F | Display of Post Test dialog | ASK+ A
L | List option | ASK+ L
P | Repeat current step option | ASK+ P
X | Cancel option | configurable
Z | Repeat option | configurable
J | Adjust option | ASK+ J
T | Terminate option | ASK+ T

Miscellaneous

Flag | Enable / Disable | Default setting
C | Use correction file (if it exists) | configurable
Q | Reset after completion of test | ASK+ Q
U | TUR checking | ASK+ U

General Characteristics

  • Entering a blank ASK+ statement results in the following:

    • ASK+ R D Q N B P J S U M C X Z A L T W

  • Entering a blank ASK- statement results in the following:

    • ASK- R D N B P J S U M C X Z A L T W

The Q-flag is not affected by ASK- blank.
  • Only the state of the flags specified in an ASK+ or ASK- statement is affected unless there is a relationship between the state of a specified flag and one or more unspecified flags. Relationships between flags are explained in detail in the paragraphs below.
  • The D, R, and Q flags are not allowed in an ASK+ or ASK- FSC in an adjustment block.
  • The state of the flags is preserved from procedure to subprocedure and vice versa.

A-FLAG

The A and F flags control whether or not the Post Test dialog is displayed upon completion of an evaluation step.

  • ASK+ A causes the Post Test dialog to be displayed after an evaluation.
  • ASK- A prevents the display of the Post Test dialog after an evaluation.
  • ASK- F prevents the display of the Post Test dialog upon a PASS condition. The Post Test dialog will be displayed if the test fails.
  • The ASK+ A and ASK+ F statements have the same effect.
  • The default is: ASK+ A

The table below shows the combined effect of the A, F, and J flags.

In a PASS condition, the J-flag has no effect.

In a FAIL condition, the J-flag has an effect only when there is an adjustment block following the evaluation statement.

 | ASK+ J | ASK- J
ASK+ A, ASK+ F, or ASK- F | Adjust option enabled in Post Test dialog for a FAIL condition. | Adjust option disabled in Post Test dialog. Adjustment block automatically executed for FAIL condition upon selecting Advance.
ASK- A | No Post Test dialog. Adjustment block can never be executed! | Adjustment block automatically executed upon FAIL condition.

B-FLAG

The B-flag controls the Go/No-Go with Slew and Keyboard Entry options for a stimulus function instrument evaluation or comparison test.

  • ASK+ B enables Go/No-Go with Slew and Keyboard Entry options.
  • ASK- B disables the B, G, and K flags, resulting in a slew test.
  • The default is: ASK- B

C-FLAG

The C-flag is used to enable or disable the MET/CAL correction mechanism.

  • ASK+ C enables corrections
  • ASK- C disables corrections
  • The default state of the C-flag is configurable using the ASK C-Flag MET/CAL Configuration setting.

In order for a correction to be performed the following conditions must apply:

  1. The C-Flag must be enabled.
  2. A correction file must exist.
  3. The System Actual value to be corrected must match a range specified in the correction file.

During procedure execution, The Test Results dialog indicates whether a correction was performed for each test listed.

D-FLAG

The D-flag controls whether or not automatic range messages use the scope "units/division" format (nominal divided by range in nominal units of measure per division). See the R-Flag.

  • ASK+ D enables scope format for automatic range messages.
  • ASK- D disables scope format for automatic range messages.
  • The default value of the D-flag depends on the type of calibration system:
    • ASK- D for a meter calibration system and
    • ASK+ D for a scope calibration system.

The calibration system type is determined by the System Type MET/CAL Configuration setting.

  • Meter = meter calibration
  • Oscilloscope = oscilloscope calibration.

The default System Type setting for new MET/CAL installations is "Meter". The System Type has no effect other than to determine the default state of the ASK 'D' flag.

Example:

The following example shows the effect of the ASK 'D' flag on automatic range messages generated for four "6060" statements. The first two "6060" statements (1.002 and 1.003) are executed with ASK- D in effect. The second two "6060" statements (1.005 and 1.006) are executed with ASK+ D in effect. The automatic range message associate with each "6060" statement is shown immediately after the procedure line. Notice that the automatic range messages for the second two "6060" statements are appropriate for scope calibration (because ASK+ D is in effect).

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
  1.001  ASK-     D
  1.002  6060   2     0.8V                         1MH                  N
Range Message:  Set UUT to the 2 V AC range.
  1.003  6060   10    10nT                         0.8V                 N
Range Message:  Set UUT to the 10 ns range.
  1.004  ASK+     D
  1.005  6060   2     0.8V                         1MH                  N
Range Message:  Set UUT to 2 V/div.
  1.006  6060   10    10nT                         0.8V                 N
Range Message:  Set UUT to 10 ns/div.

  • Some FSCs allow "-D" to be specified in the MOD2 field. When specified, "-D" in the MOD2 field overrides the ASK 'D' flag.
    • For MET/CAL versions 6.10 and earlier, the effect of the ASK 'D' flag on automatic slew messages varies for different FSCs. Most instrument FSCs do not take the ASK 'D' flag into account when constructing automatic slew messages.

F-FLAG

The A-flag and F-flag control whether or not the Post Test dialog is displayed upon completion of an evaluation step.

  • ASK+ A causes the Post Test dialog to be displayed unconditionally after an evaluation.
  • ASK- A prevents the Post Test dialog from being displayed after an evaluation.
  • ASK- F prevents the display of the Post Test dialog upon a PASS condition. The Post Test dialog will be displayed upon a FAIL condition.
  • The ASK+ A and ASK+ F commands have the same effect.
  • The default is: ASK+ A

The table below shows the combined effect of the A, F, and J flags.

In a PASS condition, the J flag has no effect. In a FAIL condition, the J flag has an effect only when there is an adjustment block following the evaluation statement.
 | ASK+ J | ASK- J
ASK+ A, ASK+ F, or ASK- F | Adjust option enabled in Post Test dialog for a FAIL condition. | Adjust option disabled in Post Test dialog. Adjustment block automatically executed for FAIL condition upon selecting Advance.
ASK- A | No Post Test dialog. Adjustment block can never be executed! | Adjustment block automatically executed upon FAIL condition.

G-FLAG

The G-flag controls the use of Go/No-Go for a stimulus function instrument evaluation or comparison test.

  • ASK+ G enables Go/No-Go.
  • ASK- G disables the B, G, and K flags, resulting in a slew test.
  • The default is: ASK- G

The J-flag controls the appearance of the Adjust option in the Post Test dialog. Refer to the description of Post Test options in the User's Manual for more information. Note that the J-flag has no effect unless (1) the test result is FAIL, and (2) an adjustment block follows the evaluation statement.

  • ASK+ J enables the Adjust option in the Post Test dialog.
  • ASK- J disables the Adjust option in the Post Test dialog.
  • The default is: ASK+ J

The table below shows the combined effect of the A, F, and J flags.

 | ASK+ J | ASK- J
ASK+ A, ASK+ F, or ASK- F | Adjust option enabled in Post Test dialog for a FAIL condition. | Adjust option disabled in Post Test dialog. Adjustment block automatically executed for FAIL condition upon selecting Advance.
ASK- A | No Post Test dialog. Adjustment block can never be executed | Adjustment block automatically executed upon FAIL condition.

K-FLAG

The K-flag controls the use of Keyboard Entry for a stimulus function instrument evaluation or comparison test.

  • ASK+ K enables Keyboard Entry.
  • ASK- K disables the B, G, and K flags, resulting in a slew test.
  • The default is: ASK- K

L-FLAG

  • ASK+ L enables the List option in the Post Test dialog.
  • ASK- L disables the List option in the Post Test dialog.
  • The default is: ASK+ L

M-FLAG

The M-flag controls the appearance of the MOD1 field information in the automatic messages which describe to the operator how to perform the test. Refer to the section describing Automatic Messages in the MET/CAL Procedure Language Reference Manual for more information.

  • ASK+ M enables inclusion of MOD1 information in messages.
  • ASK- N disables inclusion of MOD1 information in messages.
  • The default is: ASK+ M

N-FLAG

The N-flag controls the appearance of automatic messages which describe to the operator how to perform the test. Refer to the section describing Automatic Messages in the MET/CAL Procedure Language Reference Manual for more information.

  • ASK+ N enables automatic messages which instruct the operator how to perform a test.
  • ASK- N disables automatic messages which instruct the operator how to perform a test.
  • The default is: ASK+ N

P-FLAG

The P-flag determines the statement at which a test is re-started after the operator selects "Repeat" or "Cancel" in the Post Test dialog.

  • ASK+ P causes the procedure to be re-started at the current procedure line when the operator selects the Post Test "Repeat" or "Cancel" option. Beginning with MET/CAL V7.20v, MET/CAL ignores the ASK+ P setting if the evaluation statement is MEMC or MEMCX. For MEMC or MEMCX MET/CAL behaves as if ASK- P is always set. (This is the default operation. Users may configure MET/CAL to use the old method by setting "ask_p_memc_memcx = yes" in the [Startup] section of the MET/CAL initialization file if desired.

Users who do this should keep in mind, however, that repeating a MEMC or MEMCX test by repeating only the single MEMC or MEMCX procedure line accomplishes nothing, because MET/CAL just compares the same two numbers again, leaving the test result unchanged.)

  • ASK- P normally causes the procedure to be re-started at the first statement of the current test when the operator selects the Post Test "Repeat" or "Cancel" option. (The step number of the first statement of the test has the form XX.001.) If the current test contains a TARGET statement which specifies a jump destination to be used in conjunction with the Post Test "Repeat" and "Cancel" options, execution resumes at the TARGET statement rather than at the first statement of the test. Refer to on-line help for the TARGET FSC for additional information.
  • The default is: ASK+ P

Q-FLAG

The Q-flag controls the reset of calibration instruments after a test.

  • ASK+ Q enables the reset of calibration instruments after a test. ASK+ Q is forced if any of ASK+ R, ASK+ N, ASK+ W, or ASK+ V are active.
  • ASK- Q disables the reset of calibration instruments after a test. ASK- Q takes effect only if ASK- R, ASK- N, and ASK- W or ASK- R, ASK- N, and ASK- V are in effect.
  • The default is: ASK+ Q
The procedure writer should carefully evaluate every procedure using ASK- Q for safety, potential overload conditions and potential for damaging calibration instruments and the UUT. Problems may occur when setting up a new function or range in the UUT while the stimulus of the previous test is still applied.

R-FLAG

The R-flag controls the appearance of automatic UUT range messages generated by the RNG (Range) FSC or instrument FSCs, when MOD4 is not "S". Refer to the section describing Automatic Messages in the MET/CAL Reference Manual for more information.

  • ASK+ R enables automatic UUT range messages.
  • ASK- R disables automatic UUT range messages.
  • The default is: ASK+ R

S-FLAG

The S-flag controls the appearance of all automatic messages defined by the SET FSC. Refer to the SET FSC in the FSC Reference for more information.

  • ASK+ S enables all automatic messages defined by the SET FSC.
  • ASK- S disables all automatic messages defined by the SET FSC.
  • The default is: ASK+ S

T-FLAG

The T-flag controls the appearance of the Terminate option in the Post Test dialog. Refer to the description of Post Test options in the User's Manual for more information.

  • ASK+ T enables the Terminate option in the Post Test dialog.
  • ASK- T disables the Terminate option in the Post Test dialog.
  • The default is: ASK+ T
The procedure writer is advised not to specify ASK- T before a procedure has been thoroughly tested. When ASK-T is in effect, it may be difficult to terminate a procedure.

U-FLAG

The T-flag controls Test Uncertainty Ratio (TUR) checking. Refer to the description of the TUR calculation in the User's Manual for more information.

  • ASK+ U enables TUR checking.
  • ASK- U disables TUR checking.
  • The default is: ASK+ U

In order for TUR checking to be performed the TUR Limit MET/CAL Configuration setting must not equal zero.

V-FLAG

The V-flag controls the appearance of automatic connection messages.

  • ASK+ V enables all automatic connection messages, including those related to the External AC Divider and High Voltage Probes. ASK+ V and ASK+ W have the same effect.
  • ASK- V disables all automatic connection messages, including those related to the External AC Divider and High Voltage Probes.
  • The default is: ASK+ V
The automatic connection and disconnection messages for the External AC Divider and High Voltage Probes are disabled when ASK- V is active. If no alternate messages are created by the procedure writer, the operator may damage the UUT or calibration equipment.
The procedure writer must make absolutely sure that no safety or fire hazard is present during the execution of the procedure; when ASK- V is active, the system will assume that a connection was made to the port that was active at the time that the signal is applied.

W-FLAG

The W-flag controls the appearance of automatic connection messages.

  • ASK+ W enables all automatic connection messages, including those related to the External AC Divider and High Voltage Probes. ASK+ W and ASK+ V have the same effect.
  • ASK- W disables all automatic connection messages, except those related to the External AC Divider and High Voltage Probes.
  • The default is: ASK+ W
The procedure writer must make absolutely sure that no safety or fire hazard is present during the execution of the procedure; when ASK- W is active, the system will assume that a connection was made to the port that was active at the time that the signal is applied.

X-FLAG

The X-flag controls the appearance of the Cancel option in the Post Test dialog. Refer to the description of Post Test options for more information.

  • ASK+ X enables the Cancel option in the Post Test dialog.
  • ASK- X disables the Cancel option in the Post Test dialog.

The default state of the X-flag is configurable using the Enable Post Test CANCEL option, by default MET/CAL Configuration setting.

  • If this setting is checked, the X-flag defaults to ASK+ X (enabled).
  • If this setting is unchecked, the X-flag defaults to ASK- X (disabled).

If the procedure step terminates abnormally, the Post Test Cancel option is always disabled, regardless of the state of the X-flag. This applies both to termination due to an error and termination by the operator. In these cases no test result was generated, so there's nothing to be canceled. If desired, use the Post Test Repeat option to retry the test.

Z-FLAG

The Z-flag controls the appearance of the Repeat button in the Post Test window.

  • ASK+ Z enables the Repeat button in the Post Test window.
  • ASK- Z disables the Repeat button in the Post Test window.

The default state of the Z-flag is configurable using the Enable Post Test REPEAT option, by default MET/CAL Configuration setting.

Compatibility: MET/CAL version 7.20f or later.

Examples

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
  1.001  ASK+   R D   N G            P J S         M              A  L  T  W
  1.002  ASK+   R       G                                         A

Additional Information

The information below may help procedure writers in interpreting the Test Run "ASK" dialog.

Internally, each ASK flag is a single bit which is either set (1) or clear (0). The Test Run "ASK" dialog displays a vertical list of flags in which a check box is used to show the state of each flag. If a box is checked, this indicates that the corresponding ASK flag is set. If a box is not checked, this indicates that the corresponding ASK flag is clear.

In all cases except as noted in rules 1 to 7 below, "ASK+ flag" sets flag and does nothing else, and "ASK- flag" clears flag and does nothing else. For example, "ASK+ X" sets the 'X' flag and has no side-effects involving other flags, and "ASK- X" clears the 'X' flag and has no side-effects involving other flags. The following rules explain the cases in which setting or clearing an ASK flag has side-effects involving other ASK flags:

  1. ASK- A clears A and clears F.

    ASK- F clears A and sets F.

    A and F cannot both be specified in a single ASK- statement.

  2. ASK- B clears B, clears G, and clears K.

    ASK- G clears B, clears G, and clears K.

    ASK- K clears B, clears G, and clears K.

    At most one of B, G, and K can be specified in a single ASK- statement.

  3. ASK- W clears W and sets V.

    ASK- V clears V and clears W.

    W and V cannot both be specified in a single ASK-statement.

  4. ASK+ A sets A and clears F.

    ASK+ F sets A and clears F.

    A and F cannot both be specified in a single ASK- statement.

  5. ASK+ B sets B, clears G, clears K.

    ASK+ G sets G, clears B, clears K.

    ASK+ K sets K, clears B, clears G.

    At most one of B, G, and K can be specified in a single ASK+ statement.

  6. ASK+ W sets W and sets V.

    ASK+ V sets W and sets V.

    W and V cannot both be specified in a single ASK+ statement.

  7. ASK+ R sets R and sets Q.

    ASK+ N sets N and sets Q.

    ASK+ W sets W and sets Q.

    ASK+ A sets A and sets Q.

    In other words, setting R, N, W, or A automatically sets Q. This means that a statement like ASK+ R will cancel a preceding ASK- Q statement. However, it is still the case that:

    ASK+ R

    ASK- Q

    leaves Q unset.


RESET and CLEAR

Interface Control FSC

Description

The RESET/CLEAR FSC is used to specify a reset/clear operation for the UUT or a User-configured Instrument. This operation can either be a command string to execute, or a procedure to call. The execution of a RESET/CLEAR statement saves the specified command string or procedure to call in internal memory.

The RESET operation is performed when either of the following occurs:

  • The Post Test is displayed. 1
  • The procedure terminates. 2

The CLEAR operation is performed when the following occurs:

  • The procedure terminates. 2

Footnotes:

  1. Post Test is displayed under the following conditions:
    1. After each evaluation step, unless system instrument reset is disabled using MET/CAL ASK flags (see ask.hlp).
    2. After an error during procedure execution.
  2. A procedure terminates when any of the following occur:
    1. Execution of END statement in the main procedure.
    2. Execution of last statement in the main procedure.
    3. The operator selects Terminate in a prompt (Ex. DISP, OPBR, or Post Test).
    4. The operator selects Stop Debugging in the Editor.
    5. The operator selects Break in the MET/CAL Runtime.

Format

RESET [address] [command]

CLEAR [address] [command]

RESET -c [procedure]

CLEAR -c [procedure]

Rules

Allowed Number of Lines Per Statement

Each RESET/CLEAR statement is limited to a single line.

Allowed Number of Commands Per Address

For each address, at most one RESET/CLEAR command is active at a particular time.

Allowed Number of Addresses Per Statement

Unless the RESET/CLEAR statement applies to the UUT, each RESET/CLEAR statement must specify a single address, and the address must precede the RESET/CLEAR command.

If the RESET/CLEAR statement applies to the UUT, the address may be omitted. MET/CAL will automatically send the specified reset command to the UUT when system instruments are reset.

Resetting UUTs

The RESET/CLEAR statement is designed to be used with user-configured instruments or with UUTs.

One way to reset a UUT is to specify the UUT address in the RESET/CLEAR statement. This works, but makes the procedure less portable.

A better way, not available until V6.1, is to omit the address from the RESET/CLEAR statement altogether. Omitting the address indicates that the reset command applies to the UUT, which may be either IEEE-488 or serial.

There's an implicit assumption here that for a particular execution of a particular calibration procedure, there will not be multiple UUTs. MET/CAL does not enforce this assumption, however. If a procedure contains both PORT and IEEE statements which communicate with devices other than by way of an address alias, there will be, in effect, two UUTs. In this case the reset command will be sent to the serial device only.

If there's no remotely-controlled UUT at all, a RESET/CLEAR statement in which the address is omitted is ignored. (However, the reset command may become active later in the procedure if a UUT has been established at that time.)

Resetting System Instruments

If a RESET/CLEAR command is specified for a system instrument (i.e., an instrument for which MET/CAL has a built-in driver), the command will be executed in addition to the built-in reset function. Thus, the built-in reset for a system instrument cannot be replaced by specifying a new reset command with the RESET/CLEAR FSC.

As a general rule, the RESET/CLEAR FSC should be used only with user-configured instruments, not with system instruments.

Address Syntax

The address syntax is the same as it is in IEEE and PORT statements. The format is @address, where address is an IEEE-488 address, serial address, or alias string which refers to a configured instrument.

Examples:

[@10] specifies IEEE-488 address 10

[@COM1] specifies the serial port COM1

[@xyz] an alias for a configured IEEE-488 or serial instrument

[@10:5] specifies primary IEEE-488 address 10, secondary address 5

Clearing a Reset/Clear Command or procedure

The command/procedure is optional. A RESET/CLEAR statement which specifies an address, but no command, clears the previously specified RESET/CLEAR command, if any. A RESET/CLEAR -c statement which specifies no procedure, clears the previously specified RESET/CLEAR procedure.

It is important to be aware that clearing a reset command using a statement like:

RESET [@10]

is not the same as specifying "*" as the reset command:

RESET [@10] *

The second statement sends a "*" to the instrument at IEEE-488 address 10 after each evaluation. It does not remove the reset command from internal memory, as the first statement does.

Note also that an empty RESET/CLEAR statement can be used to clear the UUT reset command.

Maximum Command Length

A maximum of 256 characters is allowed in a RESET/CLEAR statement for the address and command, step and FSC taken together.

If a reset command is too long for the space available, the procedure writer can use the MATH FSC and the built-in string registers (MEM2, S[1], S[2], ...) to construct a longer reset command, and then use the appropriate special construction in the RESET/CLEAR statement.

Example:

  1.001  MATH         S[1] = "0123456789012345678901234567890123456789"
  1.002  MATH         S[1] = S[1] & "0123456789012345678901234567890123456789"
  1.003  RESET        [SREG1]

The total string length of the reset command must not exceed 1023 characters.

Handling of Spaces

Leading and trailing blanks are ignored. Spaces between the address and the command are also ignored.

Spaces embedded in the command are not ignored, however. For example:

RESET [@10] a b

When the RESET/CLEAR command is executed, "a b" will be sent to the IEEE-488 device at address 10.

Command Syntax

A RESET/CLEAR command consists of literal text and embedded special constructions. Special constructions are always delimited with brackets ('[' and ']'). When a RESET/CLEAR command is executed, characters in the command which are not part of a special construction are written to the specified device.

In general, special constructions are evaluated as they are encountered. However, unlike IEEE and PORT statements, some special constructions are evaluated when the RESET/CLEAR statement is executed, while others are evaluated when the RESET/CLEAR command is executed.

The special constructions which are evaluated when the RESET/CLEAR statement is executed are those constructions which refer to memory registers, plus the [V variable] construction.

This is an important distinction which must be understood by procedure writers who make use of the RESET/CLEAR statements with embedded special constructions.

Example:

  1.001  MATH         MEM2 = "*RST"
  1.002  RESET        [@10] [MEM2][SDC]
  1.003  MATH         MEM2 = "ABC"
  1.004  5700         1V             1%                                    2W

The value of register MEM2 is inserted in the command when the RESET/CLEAR statement is executed. This value is "*RST". The RESET/CLEAR command is therefore "*RST[SDC]". This command will be sent to the device at IEEE-488 address 10 after each evaluation. When MEM2 is changed from "*RST" to "ABC", after the RESET/CLEAR statement, this change does not affect the RESET/CLEAR command, which will be executed after the 5700 statement. The [SDC] construction (selected device clear) is evaluated each time the RESET/CLEAR command is executed.

Command Termination

In general, the same rules apply as for the IEEE and PORT FSCs.

For IEEE-488 instruments, EOI termination is the default, and is sufficient for most instruments.

For serial instruments there are two approaches.

The first approach is to explicitly specify the terminator after the data message. Typically, serial instruments expect a linefeed ([10]), carriage return ([13]), or both as a terminator.

The second approach is to use the OTERM special construction to specify the terminator. Note that if this approach is used, a separate OTERM construction must be specified in each RESET/CLEAR statement.

Error Handling

As with the built-in reset commands which MET/CAL automatically uses for system instruments (like the Fluke 5700A), reset commands specified using the RESET/CLEAR FSC cause the procedure to be aborted if an error occurs in executing the RESET/CLEAR command.

Procedure writers who use the RESET/CLEAR FSC must therefore carefully test procedures to make sure that the RESET/CLEAR command is reliable.

Special Constructions

The RESET/CLEAR FSC supports most of the special constructions allowed by the IEEE and PORT FSCs.

Constructions that are legal only for IEEE-488 instruments cannot be used with serial instruments.

Constructions that are legal only for serial instruments cannot be used with IEEE-488 instruments.

If the address is specified as a literal IEEE-488 or serial address (i.e., not as an alias), compile time checks prevent incorrect special construction specifications.

If the address is an alias, some of the special construction error checks are deferred until run time.

The following special constructions may be used in the command portion of a RESET/CLEAR statement:

Constructions Evaluated on RESET/CLEAR Statement Execution

  • MEM write value of register MEM to specified address
  • MEM1 write value of register MEM1 to specified address
  • MEM2 write value of register MEM2 to specified address
  • Mn write value of global numeric register to specified address
  • Ln write value of local numeric register to specified address
  • SREGn write value of string register to specified address
  • Vvariable write value of variable to specified address
  • {text} send text enclosed in braces to result file

Constructions Evaluated on RESET/CLEAR Command Execution

Constructions Used with IEEE-488 and Serial Instruments
  • Ddelay delay execution for delay milliseconds
  • I! read number from specified address, discarding the data read
  • numeric write number (ASCII) to specified address
  • O < file read from file, write to specified address
  • Tnumeric set timeout to numeric milliseconds
  • TERM number set terminator character to number (ASCII)
  • TERM 'c' set terminator character to c (character)
  • TERM CR set terminator character to Carriage Return
  • TERM LF set terminator character to Line Feed
  • TERM NONE no terminator (IEEE-488) default termination (serial)
  • TERM OFF same as TERM NONE
  • OTERM number set output terminator character to number (ASCII)
  • OTERM 'c' set output terminator character to c (character)
  • OTERM CR set output terminator character to Carriage Return
  • OTERM LF set output terminator character to Linefeed
  • OTERM CRLF set output terminator character to Carriage Return + Linefeed
  • OTERM NONE no output terminator
  • OTERM OFF no output terminator

The I! construction was added for use with the RESET/CLEAR statement, because I and I$ modify the memory registers (MEM and MEM2, respectively), and this side-effect is, in general, not acceptable in the context of a reset command which executes after each evaluation. The I! construction is also available for use in IEEE and PORT statements.

When using the DELAY special construction, the RESET and CLEAR command executions will occur at the designated times after the DELAY time has elapsed.

Constructions Used Only with IEEE-488 Instruments
  • EOI ON | OFF enable/disable assertion of EOI on write
  • GTL put instrument in local control state
  • IFC port interface clear on specified port
  • LLO disable instrument front panel controls
  • REN assert Remote Enable line on the IEEE-488 bus
  • SDC sends Selected Device Clear to specified address
  • S delay set delay between transmitted characters
  • SPL mask serial poll specified address
  • SRQdelay,mask wait for IEEE Service Request
  • SRQ ON | OFF enable/disable UUT Service Request processing
  • TRIG trigger instrument at specified address

The SPL and SRQ constructions are allowed, but are not recommended for use in RESET/CLEAR statements, because they cause the value of memory register MEM to be modified when the RESET/CLEAR command is executed.

The timeout and terminator specifications, if any, are maintained independently of corresponding specifications in IEEE statements, if any.

Constructions Used Only with Serial Instruments
  • CLR flush receive queue of specified port
  • Pparams configure port
  • REOPENclose and re-open the specified port

The P construction (port configuration) must be used with caution, because it interacts with the PORT statements in the procedure. In general, it's best to configure the port using either the Windows Control Panel, or a PORT statement at the beginning of the procedure.

The timeout specification, if any, is maintained independently of the corresponding specification in PORT statements, if any.

Refer to the IEEE FSC for additional details on special constructions used with IEEE-488 instruments.

Refer to the PORT FSC for additional details on special constructions used with serial instruments.

Examples

RESET FSC

Specify reset command to send when Post Test dialog is displayed or the procedure terminates. This command disables the UUT output.

Command Form (UUT)

UUT is a SCPI compliant source device with the ability to enable and disable the output:

4.001 RESET OUTPUT:STATE OFF;*OPC?[I!]

UUT is a Fluke 55xxA or 57xxA calibrator.

4.002 RESET STBY;*OPC?[I!]

Procedure Form (UUT)

UUT is a NI PXI-4130 Source/Measure Unit (SMU). This procedure uses the LIB FSC to call uut.niDCPower_ConfigureOutputEnabled with viFalse to turn off the UUT.

4.003 RESET -c Sub NI DC Power Output Off LIB

CLEAR FSC

Specify clear command to execute when procedure terminates. This command resets the UUT.

Command Form (UUT)

4.004 CLEAR *RST;*OPC?[I!]

Procedure Form (UUT)

This procedure uses the LIB FSC to call niDCPower_close, which frees the handle to niDCPower_32.dll.

4.005 CLEAR -c Sub NI DC Power Close LIB

Command Form (User-configured Instrument)

User-configured Instrument is a Fluke 2620A, controlled by the PORT FSC. This command resets the Fluke 2620A.

4.006 CLEAR [@2620]REMS;*RST[10][I!][I!][D1000]


FMT

Miscellaneous FSC

Description

The FMT FSC allows the procedure writer to override the default formatting of result quantities. Formatting specified in an FMT statement affects only how the result value is formatted in the database Results Table.

The FMT FSC has no effect on how formatted values appear in:

  • The Post Test window,
  • The Test Results window, or
  • The CalResults table (legacy results).

Formatting directives specified using an FMT statement do affect reports generated using Crystal Reports, but only if the report retrieves the formatted data values from the Results Table and does not subsequently modify the format.

The FMT FSC cannot be used to format strings. It used for numeric formatting only.

The FMT FSC must be used with care. Specifying a rigid format using a FMT statement overrides MET/CAL's default formatting. In cases where the default formatting is dynamically based on information known to the procedure run time system, using the FMT FSC may have an adverse effect. For example, Variable Quantity (VARQ) is, by default, formatted in such a way that the number of digits tracks the UUT's resolution. Overriding the default will cause the VARQ formatting to be fixed. It will no longer track UUT Resolution.

Rules

  1. The general form of a FMT statement is:

    FMT name = value

    where name is a recognized parameter name selected from the parameter list and value is a valid format descriptor.

    Separate sections below describe valid format descriptors and list supported parameter names.

    The value portion of a FMT FSC specification is not checked for correctness when the procedure statement is compiled. An invalid format descriptor results in a run time error, or in an incorrectly formatted (or blank) value in the Results Table.

    All procedures using the FMT FSC should be carefully tested to ensure correct operation.

  2. A FMT statement may contain multiple assignments on a single line:

    FMT name1 = value1 name2 = value2 ...

    The procedure line length limits the number of assignments which may be made on a single line.

  3. All string comparisons are case-insensitive, and spaces before or after the equals sign in an assignment are not significant.

  4. A FMT specification of a parameter persists for the duration of a procedure's execution until it is either overridden or reset in a subsequent FMT statement.

  5. A FMT parameter specification can always be reset by assigning the special value "*". When a FMT-specified parameter is reset, it is as if the procedure had never had a specification for that parameter. In other words, formatting of the specified result quantity reverts to default formatting.

  6. Special Constructions

    A FMT parameter value specification may include one or more MET/CAL special constructions. The following special constructions are supported:

    • [MEM], [MEM1], and [MEM2]
    • [M1], [M2], ...
    • [L1], [L2], ...
    • [S1], [S2], ...
    • [SREG1], [SREG2], ...
    • [Vvariable]
    • [numeric]

    Refer to the Special Constructions topic for more information.

    The constructions [M1], [M2], ..., access the global numeric registers. The constructions [L1], [L2], ..., access the local numeric registers. Up to 12 significant digits are included in the numeric register value. Refer to the MATH FSC on-line help for additional information on the numeric registers.

    The constructions [S1], [S2], ..., access the string registers. Refer to the MATH FSC on-line help for additional information on the string registers.

    The constructions [SREG1], [SREG2], ..., are identical to [S1], [S2], ..., and are included only for compatibility with the IEEE, IEEE2, and SCPI FSCs.

    The two primary reasons for using a special construction in a FMT parameter value specification are:

    1. To allow the parameter value to be calculated using the MATH FSC.
    2. To allow the operator to be prompted for the parameter value.

    When using special constructions in a FMT statement, it is important for the procedure writer to realize that doing so prevents the MET/CAL compile time system from checking the value to make sure it's valid. This means that an error in the value specification will result in a run time error. In some cases it may be difficult or impossible for the operator to correct such a mistake, and procedure execution may be terminated, or the results may be invalidated.

    Special constructions cannot be used in FMT parameter names, only in parameter values.

Parameter List

The following result quantities may be formatted using the FMT FSC:

  • C1 - Sensitivity Coefficient for U1
  • C2 - Sensitivity Coefficient for U2
  • C3 - Sensitivity Coefficient for U3
  • C4 - Sensitivity Coefficient for U4
  • C5 - Sensitivity Coefficient for U5
  • C6 - Sensitivity Coefficient for U6
  • C7 - Sensitivity Coefficient for U7
  • C8 - Sensitivity Coefficient for U8
  • C9 - Sensitivity Coefficient for U9
  • C10 - Sensitivity Coefficient for U10
  • CS1 - Sensitivity Coefficient for S1
  • CS2 - Sensitivity Coefficient for S2
  • CORR - Correction Amount
  • COV_FAC - Coverage Factor
  • CPT - Cardinal Point
  • DEV - Deviation
  • DF - Combined Degrees of Freedom
  • DF1 - Degrees of Freedom for U1
  • DF2 - Degrees of Freedom for U2
  • DF3 - Degrees of Freedom for U3
  • DF4 - Degrees of Freedom for U4
  • DF5 - Degrees of Freedom for U5
  • DF6 - Degrees of Freedom for U6
  • DF7 - Degrees of Freedom for U7
  • DF8 - Degrees of Freedom for U8
  • DF9 - Degrees of Freedom for U9
  • DF10 - Degrees of Freedom for U10
  • DFS1 - Degrees of Freedom for S1 (component of U2)
  • DFS2 - Degrees of Freedom for S2 (component of U2)
  • ERR - Error
  • EXPV - Expected Value
  • EXP_UNC - Expanded Uncertainty
  • F - Student's T Factor
  • FIXQ - Fixed Quantity
  • GLL - Guardbanded Lower Limit
  • GNG - Lower and Upper Bounds in Go/No Go Prompt Window
  • GUL - Guardbanded Upper Limit
  • LL - Lower Limit
  • MEAS - Measurement
  • MOD1 - MOD1
  • MV - Measurement Values
  • NOM - Nominal
  • NTT - Negative Test Tolerance
  • PTT - Positive Test Tolerance
  • REL_ERR - Relative Error
  • S1 - S1
  • S2 - S2
  • SA - System Actual
  • SCF - System Coverage Factor
  • SDEV - Standard Deviation
  • STD_UNC - Standard Uncertainty
  • SYS_ACC - System Accuracy
  • TEST_TOL - Test Tolerance
  • TOL_ERR - Tolerance Error
  • TUR - Test Uncertainty Ratio
  • U1 - Uncertainty Component
  • U2 - Uncertainty Component
  • U3 - Uncertainty Component
  • U4 - Uncertainty Component
  • U5 - Uncertainty Component
  • U6 - Uncertainty Component
  • U7 - Uncertainty Component
  • U8 - Uncertainty Component
  • U9 - Uncertainty Component
  • U10 - Uncertainty Component
  • UI - UUT Indicated
  • UL - Upper Limit
  • UUT_RANGE - UUT Range
  • UUT_RES - UUT Resolution
  • VARQ - Variable Quantity

Format Descriptors

The following numeric format descriptors are supported:

F-Format

F-Format formats a floating point number in fixed format.

Syntax is:

%.precisionf

precision specifies the number of digits to the right of the decimal point.

precision must be an integer value between 1 and 15.

Do not specify an uppercase 'F' in an F-Format format descriptor. Uppercase 'F' is not supported.

E-Format

E-Format formats a floating point number in scientific notation.

Syntax is:

%.precisionE

or

%.precisione

Specifying an uppercase 'E' causes the resulting number to use an uppercase 'E'.

Specifying an lowercase 'e' causes the resulting number to use an uppercase 'e'.

precision specifies the number of digits to the right of the decimal point.

precision must be an integer value between 1 and 15.

G-Format

G-Format is a hybrid of E-Format and F-Format. E-Format is used if the exponent is less than -4 or exceeds the stated precision. Trailing zeros are stripped off the fractional part of the result. The decimal point itself is omitted unless it is followed by at least one non-zero digit.

Syntax is:

%.precisionG

or

%.precisiong

Specifying an uppercase 'G' causes the resulting number to use an uppercase 'E' (but only when the number is such that E-Format is used).

Specifying an lowercase 'g' causes the resulting number to use an lowercase 'e' (but only when the number is such that E-Format is used).

precision specifies the number of significant digits (except when trailing zeros are omitted).

precision must be an integer value between 1 and 15.

Examples

Example 1

FMT VARQ = %.5f

This statement overrides the formatting of the Variable Quantity. VARQ values will appear in the database Results Table in fixed format, with 6 digits to the right of the decimal point.

For example, if the VARQ value is 12.34, the value will be formatted as:

12.34000

(Remember: Don't uses an uppercase 'F'. It doesn't work!)

Example 2

FMT VARQ = %.5E

This statement overrides the formatting of the Variable Quantity. VARQ values will appear in the database Results Table in scientific notation, with 5 significant digits.

For example, if the VARQ value is 12.34, the value will be formatted as:

1.23400E+001

Example 3

FMT VARQ = %.5g

This statement overrides the formatting of the Variable Quantity. VARQ values will appear in the database Results Table in either fixed format or scientific notation, depending on the magnitude of the number and on the stated precision.

For example, if the VARQ value is 12.34, the value will be formatted as:

12.34

Notice that even though the number of significant digits requested is 5, because trailing zeros are stripped, only 4 digits appear in the formatted number.


HEAD

Display Control FSC

Description

The HEAD FSC is used to display a one-line message during procedure execution. The message appears just below the procedure name in the main run time window, and remains displayed until it is subsequently overwritten, or util the procedure terminates. A HEAD message is not an operator prompt -- no operator action is required in response to a HEAD message.

Format

HEAD message

HEAD -2 message

Rules

  1. Each line of the FSC statement may contain up to 256 bytes, including the step number and the FSC text. Characters below ASCII 128 occupy one byte.

  2. When a HEAD statement is executed, the HEAD message displayed by a previously executed HEAD statement, if any, is overwritten.

  3. A HEAD statement with a blank message causes the displayed HEAD message to be erased.

  4. A HEAD statement which begins with "-2" causes the message to be displayed in a second HEAD message area, below the primary HEAD message area in the MET/CAL Runtime window. This allows a MET/CAL procedure to specify both primary and secondary HEAD messages. Compatibility: Support for "HEAD -2" requires MET/CAL V7.20 SP1 or later.

  5. The following special constructions may be used in a HEAD statement:

    1. [MEM], [MEM1], and [MEM2]
    2. [numeric]
    3. [<D<numeric>]
    4. [Vvariable]
    5. {text}
    6. [M1], [M2], ...
    7. [L1], [L2], ...
    8. [S1], [S2], ...
    9. [SREG1], [SREG2], ...
    10. [Xhex list]

    Refer to Special Constructions for details.

    The constructions [M1], [M2], ..., access the global numeric registers. The constructions [L1], [L2], ..., access the local numeric registers. Up to 12 significant digits are included in the numeric register value.

    Refer to the MATH FSC on-line help for additional information on the numeric registers. The constructions [S1], [S2], ..., access the string registers. Refer to the MATH FSC on-line help for additional information on the string registers.

    The constructions [SREG1], [SREG2], ..., are identical to [S1], [S2], ..., and are included only for compatibility with the IEEE, IEEE2, and SCPI FSCs.

  6. Delay Special Construction

    1. If the DELAY special construction is placed before the HEAD message text, any existing HEAD message is cleared and the new message is displayed once the DELAY time has elapsed.

      HEAD [D2000]Executing test

    2. If the DELAY special construction is placed after the HEAD message text, the HEAD message is updated immediately and then the DELAY time is processed.

      HEAD Executing test[D2000]

    3. If there are one or more DELAY special constructions interlaced with the message text, all of the DELAY times are summed and the concatenated HEAD message is displayed after the total DELAY time has elapsed.

      HEAD Executing test[D1000] Please wait[D1000]

      This is a change from MET/CAL v8.x and earlier where the HEAD message would be displayed one secton at a time with the appropriate delay between section.

    4. There is a special case where the HEAD statement can be used to "ring the bell" with a DELAY between each "ring".

      HEAD [7][D250][7][D250][7][D250]

Examples

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
  1.001  HEAD         DC Voltage Tests
  1.002  HEAD         Test delay [D32767].
  1.003  HEAD         {AC Voltage Tests}
  1.004  HEAD         CH[MEM] Attenuator Tests

[] special constructions may be enclosed in {}, but will not be evaluated and stored in the results. For example, the following HEAD statements will cause "Ch[MEM] Tests" to be stored in the results, not "Ch1 Tests".

  1.001  MATH         MEM = 1
  1.002  HEAD         {Ch[MEM] Tests}

The RSLT FSC should be used to store text with embedded [] special constructions in the results as shown below:

  1.001  MATH         MEM = 1
  1.002  HEAD         Ch[MEM] Tests
  1.003  RSLT         =Ch[MEM] Tests

This example shows how the HEAD FSC may be used to gain an operators attention when a connection change is required, utilizing the ASCII bell character. This example dings the bell 5 times, separated by 250 ms between each ding:

  1.002  HEAD         [7][D250][7][D250][7][D250][7][D250][7]


LIB (Library) FSC

Description

The LIB FSC is used to allow interaction with Component Object Model (COM) components and Win32 Dynamic Link Libraries (DLLs). The LIB FSC also provides support for arrays and user-defined data structures. Interacting with external programs using the LIB FSC is an advanced topic and will be a challenge for users that are not familiar with using DLLs or COM objects in other programming languages. The documentation provided in this help file is specific to MET/CAL. Documentation for the specific DLL or COM object is also required.

The syntax of the LIB FSC varies depending on its specific usage. The following sections indicate the valid syntax for common uses of the LIB FSC.

Contents

  • Important Notes
  • Communicating with NI PXI hardware
  • COM Component Syntax
  • Win32 DLL Syntax
  • Array Syntax
  • Data Structure Syntax
  • Array of Data Structures Syntax
  • Rules
  • Special Constructions
  • Examples
    • Excel Spreadsheet Example
    • National Instruments DLL Example

Important Notes

The LIB FSC is currently the only FSC that recognizes object variables that reference COM components, Win32 DLLs, arrays and data structures. In order to use the values from array and data structure variables with other FSCs, values must first be copied from the objects referenced by the object variables to standard MET/CAL registers or named variables.

Once an object variable has been assigned using the LIB FSC, that variable holds a reference to the component, library, array or data structure. Object variables may be reassigned at any time. However, once an object variable is reassigned, the object that it previously referenced is destroyed and cannot be accessed again. Any LIB FSC object variable can be reassigned to reference any other component, library,array or data structure.

The RESET and CLEAR FSCs should be used in conjunction with the LIB FSC to perform clean-up tasks, especially when using the LIB FSC to interface with instruments. The RESET FSC should be used to ensure the instrument gets put into a safe operational state while the CLEAR FSC should be used to terminate connections with COM components or call any clean-up related functions. The "-c" flag has been added to the RESET and CLEAR FSCs to facilitate this need.

When debugging a procedure that has uses objects created by the LIB FSC, the Debug From Cursor option should be used sparingly. The issue is that when the procedure terminates, the RESET and CLEAR FSCs should destroy any LIB FSC object variables. Other variables are not cleared from memory. In this case you cannot assume that using Debug From Cursor will allow access to variables that are storing LIB FSC objects. The recommended solution is to start the procedure from the beginning. The alternative is to copy and paste the object initialization code, including the RESET and CLEAR options used with the object, to the section of code that you wish to start debugging from. The copied code should be removed after the troubleshooting is complete.

When setting properties of a COM component that are of the Boolean data type, the LIB FSC automatically interprets the values "True" and "False" as their equivalent Boolean values.

When using the LIB FSC to invoke functions of a Win32 DLL, the definition for each function to be invoked MUST be defined using the Library FSC Component Definition Wizard. The wizard must also be used to define any data structures that need to be passed as an argument to a Win32 DLL function. For more information on using the Library FSC Component Definition Wizard, refer to the MET/CAL User Guide.

When using the LIB FSC to interface with COM components, it is highly recommended, though not required, to use the Library FSC Component Definition Wizard to define the available properties and methods of each COM component. If you chose not to use the wizard to define the COM components, the MET/CAL compilers "REQ_DEF" setting must be set to "0" (LIB SET REQ_DEF = 0). However, with "REQ_DEF" set to "0", you are not permitted to use enumerated values in the procedure code.

Arrays are zero based, meaning the index of the first element in an array is [0] and the nth element in the array is [n-1]. Each element of an array is capable of storing any value, numeric or string, and can be changed at any time. You can store a numeric in element 1, string in element 2, etc. It does not matter. However, when you are getting the value of an array element and assigning it to a register, you must be sure the register is capable of storing that value.

Like arrays, each member of a data structure is capable of storing any value, numeric or string, and can be changed at any time. However, when using data structures with Win32 DLL functions, each member of the structure must have a specific data type assigned to it using the Library FSC Component Definition Wizard. If the value stored in a member of the structure is not compatible with the assigned data type, a failure message will be generated at runtime when the function is invoked.

Communicating with NI PXI hardware

To successfully communicate with an NI PXI module, a developer must understand the task API (Application Program Interface). A task is like a file. Open the task, do the desired operations, close the task. This sequence applies regardless of what software is used to communicate with the PXI module.

In MET/CAL, the LIB FSC is simply used to access the task API in the corresponding DLL for the module (e.g. ni_dmm32.dll).

  1. Use the LIB FSC to open a task. The function returns a handle.
  2. Use the handle to perform necessary operations (e.g. Setup, Initiate, Fetch, Get Error Status, ...).
  3. Use the handle to close the task.

Once a task is open and a handle is returned, the task stays open until it is explicitly closed or the application is terminated.

Simply terminating the procedure will NOT close the task. This is why all Fluke Calibration warranted PXI procedures include a CLEAR -c statement with a subprocedure name that closes the task. This subprocedure is automatically called when the procedure terminates normally, or by the operator selecting Terminate.

If you encounter task name conflict errors, assume that the task was not properly closed.

PXI procedures can be difficult to debug in the MET/CAL Editor. The CLEAR -c statement must be included for the reasons stated above. However, if the developer stops debugging and resumes without re-executing a LIB statement to re-open the task, an undefined handle error will occur. The mode Fluke developers use is to keep a copy of the LIB statement that opens the task in Notepad. When developing a PXI procedure, temporarily paste the statement in the procedure where you wish to resume debugging to re-open the task. After debugging, remove all temporary LIB statements used to open the task except the initial one.

COM Component Syntax

Create a COM Object

Instantiate a COM component and assign it to a variable. Before any methods of properties of a COM component can be accessed, the COM component must first be instantiated.

LIB COM object variable[sp]=[sp]component nameterm

object variable | Any legal variable name as defined in the MATH FSC's Variables section. Object variables are independent from named variables created using the MATH FSC and are only recognized by the LIB FSC. Only one "." can be used when defining the object name. For example, "excel.application.workbook" is not supported. In short nested objects must be individually referenced by parent object variables. See the example below.
sp | One or more spaces.
component name | Name of COM component to instantiate. Can use a string register, named variable, or a literal. String literals must be enclosed in double quotes. COM component names are typically formatted as "library.component" where "library" indicates the name of the library or file that contains the component and "component" is the name of the component to instantiate. Examples include Microsoft Excel ("Excel.Application"), Adobe Acrobat Reader ("AcroPDF.PDF"), or the Microsoft Scripting File System Object ("Scripting.FileSystemObject").
term | Statement terminator. The semi-colon character is used ";"

Examples

To instantiate the Microsoft Excel application COM component and assign it to a variable named "excel", use the following code:

1.001 LIB COM excel = "Excel.Application";

or

  1.002  MATH         excelapp = "Excel.Application"
  1.003  LIB          COM excel = excelapp;

A separate variable must be used to instantiate objects that are nested within a parent object to avoid using more than one "." within a COM declaration statement. The code snippet below will compile however it will not execute.

1.001 LIB COM workbooks = "Excel.Application.Workbooks";

Instead, use an intermediate variable. The code snippet below will compile and execute. The variable "workbooks" will be set to the Workbooks object of the Excel Application object.

  1.005  LIB          COM excel = "Excel.Application";
  1.006  LIB          COM workbooks = "excel.Workbooks";

Read a Property from a COM Object

Get the value of a property of a COM component. Before doing this, the COM component must be instantiated (see above).

LIB variable[sp]=[sp]object variable.property name[index]term

variable | Any MET/CAL register or named variable. The register or variable must be capable of storing the value that the property returns (i.e. numeric or string value). If the property returns a reference to another COM component, this variable will be created as an object variable.
sp | One or more spaces.
object variable | Any legal variable name that references a COM component created using a statement as described above.
property name | COM component property name from which the value is the to be read.
index | If the property is an array, indicates the element of the array to get. The index must be enclosed in square brackets and can be a MET/CAL register, named variable or literal value. String literals must be enclosed in double quotes.
term | Statement terminator. The semi-colon character is used ";"

Examples

To get the value of the property "Visible" from the "excel" component created above and assign it to a register or named variable, use the following code:

1.001 LIB isVisible = excel.Visible;

or

1.001 LIB L[1] = excel.Visible;

To get the value of the nth element of an array property named "Data" from a component and assign it to a register or named variable, use the following code:

  1.009  MATH         index = some_value
  1.010  LIB          value = component.Data[index];

Set a Property of a COM Object

Set the value of a property of a COM component. Before doing this, the COM component must be instantiated (see above).

LIB object variable.property name[index][sp]=[sp]valueterm

object variable | Any legal variable name that references a COM component created using a statement as described above.
property name | COM component property name to set.
index | If the property is an array, indicates the element of the array to set. The index must be enclosed in square brackets and can be a MET/CAL register, named variable or literal value. String literals must be enclosed in double quotes.
sp | One or more spaces.
value | Any MET/CAL register, named variable or literal value. The register, variable or literal value must be compatible with the data type associated with the property (i.e. numeric or string value). String literals must be enclosed in double quotes.
term | Statement terminator. The semi-colon character is used ";"

Examples

To set the value of the property "Visible" of the "excel" component created above to the boolean value "True", use the following code: (note that the LIB FSC automatically interprets "True" and "False" when working with Boolean data types)

1.001 LIB excel.Visible = True;

To set the value of the property "FileType" of the "myComponent" component to the enumerated value "TextFile", use the following code: (note that in order to use enumerated values, the LIB FSC setting"REQ_DEF" must be set to "1" in the procedure using the statement "LIB SET REQ_DEF = 1", the data type for the property to set must be an enumeration, and the enumeration values must be defined in the definition file)

1.001 LIB myComponent.FileType = TextFile;

To set the value of the nth element of an array property named "Data" from a component to a value stored in a register or named variable, use the following code:

  1.011  MATH         index = some_value
  1.012  MATH         value = some_value
  1.013  LIB          component.Data[index] = value;

Call a Function in a COM Object

Invoke a method of a COM component. Before doing this, the COM component must be instantiated (see above).

LIB [variable[sp]=[sp]]object variable.method name([argument list])term

variable | Any MET/CAL register or named variable. The register or variable must be capable of storing the value that the method returns (i.e. numeric or string value). If the method does not return a value or the return value does not need to be stored, this is omitted along with the "=" sign.
sp | One or more spaces.
object variable | Any legal variable name that references a COM component created using a statement as described above.
method name | Name of the COM component method to invoke.
argument list | argument[separatorargument list].
separator | , | [sp],[sp]
argument | Any MET/CAL register, named variable or literal value. String literals must be enclosed in double quotes.
term | Statement terminator. The semi-colon character is used ";"

EXAMPLES

To invoke the "Quit" method, which takes no arguments and does not return a value, of the "excel" component created above, use the following code:

1.001 LIB excel.Quit();

To invoke the "Display" method, which takes 3 arguments (numeric,string, numeric) and returns a numeric value, of a component referenced by the object variable "myComponent", use the following code:

1.001 LIB return = myComponent.Display(4, "Message to display.", 0);

To invoke the same method as above using named variables and/or registers, and ignoring the return value, use the following code:

  1.014  MATH         M[45] = 4
  1.015  MATH         myMessage = "Message to display."
  1.016  MATH         buttons = 0
  1.017  LIB          myComponent.Display([M45], myMessage, buttons);

Reference an Object within a COM Object

Get a reference to a related or dependent COM component from a property or method of another COM component. Before doing this, the COM component must be instantiated (see above).

LIB COM <new object variable>[sp]=[sp]object variable.property or methodterm

new object variable | Any legal variable name as defined in the MATH FSC's Variables section. Object variables are independent from named variables created using the MATH FSC and are only recognized by the LIB FSC.
object variable | An existing object variable that references a COM component.
sp | One or more spaces.
property or method | property name[index] | method name([argument list])
property name | COM component property name to get.
index | If the property is an array, indicates the element of the array to set. The index must be enclosed in square brackets and can be a MET/CAL register, named variable or literal value. String literals must be enclosed in double quotes.
method name | Name of the COM component method to invoke.
argument list | argument[separatorargument list].
separator | , | [sp],[sp]
argument | Any MET/CAL register, named variable or literal value. String literals must be enclosed in double quotes.
term | Statement terminator. The semi-colon character is used ";"

Examples

To get a reference to the Workbooks component which is accessible through the "Workbooks" property of the "excel" component created above, use the following code:

1.001 LIB COM workbooks = excel.Workbooks;

To get a reference to the "A1" cell on the active worksheet of the "excel" component created above using the "Range" property, use the following code:

1.001 LIB COM a1cell = excel.Range["A1"];

Win32 DLL Syntax

When using the LIB FSC to work with Win32 DLLs, there are various operations that can be performed.

Load DLL

Load the DLL and assign it to a variable. Before any functions of a DLL can be invoked, the DLL must first be loaded.

LIB DLL object variable[sp]=[sp]library nameterm

object variable | Any legal variable name as defined in the MATH FSC's Variables section. Object variables are independent from named variables created using the MATH FSC and are only recognized by the LIB FSC.
sp | One or more spaces.
library name | File name of the Win32 DLL to load. Can use a string register, named variable, or a literal. String literals must be enclosed in double quotes. The DLL file MUST reside in a folder referenced by the computer's "PATH" environment variable.
term | Statement terminator. The semi-colon character is used ";"

Examples

To load the National Instruments Win32 DLL "niScope_32.dll" located in the folder "C:\Program Files\IVI Foundation\IVI\bin" and assign it to a variable named "niDll", use the following code:

  1.018  MATH         dllName = "C:\\Program Files\\IVI Foundation\\"
  1.019  MATH         dllName = dllName & "IVI\\bin\\niScope_32.dll"
  1.020  LIB          DLL niDll = dllName;

To load the Win32 DLL file "7pcklib.dll" which is located in the project folder or in a folder referenced by the computer's "PATH" environment variable, and assign it to a variable named "myDll", use the following code:

1.001 LIB DLL myDll = "7pcklib.dll";

Call a DLL Function

Invoke a function in the DLL. Before doing this, the DLL must be loaded (see above).

LIB [variable[sp]=[sp]]object variable.function name([argument list])term

variable | Any MET/CAL register or named variable. The register or variable must be capable of storing the value that the function returns (i.e. numeric or string value). If the function does not return a value or the return value does not need to be stored, this is omitted along with the "=" sign.
sp | One or more spaces.
object variable | Any legal variable name that references a DLL loaded using a statement as described above.
function name | Name of the DLL function to invoke.
argument list | argument[separatorargument list]
separator | , | [sp],[sp]
argument | Any MET/CAL register, named variable, array or data structure variable or literal value. String literals must be enclosed in double quotes.
term | Statement terminator. The semi-colon character is used ";"

Examples

To invoke the "niScope_init()" method, which takes 4 arguments (string, Boolean, Boolean, numeric) and returns a numeric value, of the "niDll" library loaded above, use the following code:

  1.021  MATH         VI_TRUE = 1
  1.022  MATH         VI_FALSE = 0
  1.023  LIB          status = niDll.niScope_init("Dev1", VI_TRUE, VI_FALSE, session);

or

  1.024  MATH         devName = "Dev1"
  1.025  MATH         id = 1
  1.026  MATH         reset = 0
  1.027  LIB          status = niDll.niScope_init(devName, id, reset, session);

To invoke the "niScope_Close" method, which takes one argument (numeric) and ignore the return value, of the "niDll" library loaded above, use the following code:

1.001 LIB niDll.niScope_Close(session);

Array Syntax

When using the LIB FSC to work with arrays, there are various operations that can be performed.

Create an Array

Create a simple array and assign it to a variable. Before an array can be used, it must be created.

LIB ARRAY NEW array variablesizeterm

NEW | Keyword to create a new instance of the array. New is only used to create the array.
array variable | Any legal variable name as defined in the MATH FSC's Variables section. Array variables are independent from named variables created using the MATH FSC and are only recognized by the LIB FSC.
size | Number of elements in the array. Can be any MET/CAL register, named variable or numeric literal value. Must be enclosed in square brackets (i.e. [10] or [mySize]).
term | Statement terminator. The semi-colon character is used ";"

Examples

To create an array of 100 elements and assign it to the variable "myArray", use the following code:

1.001 LIB ARRAY NEW myArray[100];

or

  1.028  MATH         size = 100
  1.029  LIB          ARRAY NEW myArray[size];

Read Values From an Array

Get the value of an element in a simple array. Before you can access the elements of an array, the array must be created (see above).

LIB variable[sp]=[sp]array variableindexterm

variable | Any MET/CAL register or named variable. The register or variable must be capable of storing the value that the array element contains (i.e. numeric or string value).
sp | One or more spaces
array variable | Any legal variable name that references an array created using a statement as described above.
index | Index of the array element to get. Can be any MET/CAL register, named variable or numeric literal value. Must be enclosed in square brackets (i.e. [10] or [index]).
term | Statement terminator. The semi-colon character is used ";"

Examples

To get the 47th element of the array "myArray" and assign it to the variable "myValue", use the following code (note arrays are zero based, therefore you must use [n - 1] to access the nth element):

1.001 LIB myValue = myArray[46];

or

  1.030  MATH         index = 46
  1.031  LIB          myValue = myArray[index];

Set Values to an Array

Set the value of an element in a simple array. Before you can access the elements of an array, the array must be created (see above).

LIB array variableindex[sp]=[sp]valueterm

array variable | Any legal variable name that references an array created using a statement as described above.
index | Index of the array element to get. Can be any MET/CAL register, named variable or numeric literal value. Must be enclosed in square brackets (i.e. [10] or [index]).
sp | One or more spaces
value | Any MET/CAL register, named variable or literal value. String literals must be enclosed in double quotes.
term | Statement terminator. The semi-colon character is used ";"

Examples

To set the 23rd element of the array "myArray" to the value 100, use the following code (note arrays are zero based, therefore you must use [n - 1] to access the nth element):

1.001 LIB myArray[99] = 100;

or

  1.032  MATH         value = 100
  1.033  MATH         index = 99
  1.034  LIB          myArray[index] = value;

To set the 1st element of the array myArray to the string value "This is a test", use the following code (note arrays are zero based, therefore you must use [n - 1] to access the nth element):

1.001 LIB myArray[0] = "This is a test";

or

  1.035  MATH         myTestMessage = "This is a test"
  1.036  MATH         index = 0
  1.037  LIB          myArray[index] = myTestMessage;

Data Structure Syntax

When using the LIB FSC to work with data structures, there are various operations that can be performed.

Define a Data Structure

Define a data structures members/fields. Before a data structure can be used, it must be defined. The MET/CAL Editor Tools menu, Library FSC, Insert Struct Code Snippet option provides a wizard to create and insert a data structure.

LIB STRUCT structure name[sp]{[sp]fields[sp]}term

structure name | Any legal variable name that will be used to reference the data structure definition.
sp | One or more spaces
fields | field[sp][,[sp]fields]
field | Any legal variable name that will be used to identify a field of the data structure. Each field name in a data structure must be unique.
term | Statement terminator. The semi-colon character is used ";"

Examples

To define a data structure with five fields named Field1, Field2, etc. and give the structure the name of "myDataStructure", use the following code:

1.001 LIB STRUCT myDataStructure {Field1,Field2,Field3,Field4,Field5};

Assigning a Variable to a Data Structure

Create an instance of a data structure and assign it to a variable. Before you can create an instance of a data structure, the data structure must be defined (see above).

LIB STRUCT NEW structure variablespOFspstructure nameterm

structure variable | Any legal variable name that will be used to reference an instance of the data structure.
sp | One or more spaces
structure name | Variable name referencing a data structure that has been defined using the code in the previous section
term | Statement terminator. The semi-colon character is used ";"

Examples

To create an instance of the data structure "myDataStructure" and assign it to the variable "myData", use the following code:

1.001 LIB STRUCT NEW myData OF myDataStructure;

Read Data from a Field in a Data Structure

Get the value of a member/field of a data structure instance. Before you can access the members of a data structure instance, you must create an instance of the data structure and assign it to a variable (see above).

LIB variable[sp]=[sp]structure variable.fieldterm

variable | Any MET/CAL register or named variable. The register or variable must be capable of storing the value that the data structure field contains (i.e. numeric or string value).
sp | One or more spaces
structure variable | Any legal variable name that references an instance of a data structure.
field | Any valid field that belongs to the referenced data structure.
term | Statement terminator. The semi-colon character is used ";"

Examples

To get the value of the "Field1" field of the data structure referenced by the "myData" variable and assign it to the variable "myValue", use the following code:

1.001 LIB myValue = myData.Field1;

Set Data to a Field in a Data Structure

Set the value of a member/field of a data structure instance. Before you can access the members of a data structure instance, you must create an instance of the data structure and assign it to a variable (see above).

LIB structure variable.field[sp]=[sp]valueterm

structure variable | Any legal variable name that references an instance of a data structure.
field | Any valid field that belongs to the referenced data structure.
sp | One or more spaces
value | Any MET/CAL register, named variable or literal value. String literals must be enclosed in double quotes.
term | Statement terminator. The semi-colon character is used ";"

Examples

To set the value of the "Field5" field of the data structure referenced by the "myData" variable, use the following code:

1.001 LIB myData.Field5 = "Pass";

or

  1.038  MATH         value = 100
  1.039  LIB          myData.Field5 = value;

Array of Data Structures Syntax

When using the LIB FSC to work with arrays of data structures, there are various operations that can be performed.

Create Data Structure Array

Create an array of the data structure and assign it to a variable. Before you can create an array of a data structure, the data structure must be defined (see above).

LIB ARRAY NEW array variablesizespOFspstructure nameterm

array variable | Any legal variable name as defined in the MATH FSC's Variables section. Array variables are independent from named variables created using the MATH FSC and are only recognized by the LIB FSC.
size | Number of elements in the array. Can be any MET/CAL register, named variable or numeric literal value. Must be enclosed in square brackets (i.e. [10] or [mySize]).
sp | One or more spaces
structure name | Variable name referencing a data structure that has been previously defined..
term | Statement terminator. The semi-colon character is used ";"

Examples

To create an array of 100 elements of the data structure "myDataStructure" and assign it to the variable "myDataArray", use the following code:

  1.040  LIB          STRUCT myDataStructure {Field1,Field2,Field3,Field4,Field5};
  1.041  LIB          ARRAY NEW myDataArray[100] OF myDataStructure;

or

  1.042  MATH         size = 100
  1.043  LIB          STRUCT myDataStructure {Field1,Field2,Field3,Field4,Field5};
  1.044  LIB          ARRAY NEW myDataArray[size] OF myDataStructure;

Read from a Field in the Data Structure Array

Get the value of a member/field of a data structure of an element in an array. Before you can access the members of a data structure array, you must create an array of the data structure and assign it to a variable (see above).

LIB variable[sp]=[sp]array variableindex.fieldterm

variable | Any MET/CAL register or named variable. The register or variable must be capable of storing the value that the array element contains (i.e. numeric or string value).
sp | One or more spaces
array variable | Any legal variable name that references an array of data structures created using a statement as described in the previous section.
index | Index of the array element to get. Can be any MET/CAL register, named variable or numeric literal value. Must be enclosed in square brackets (i.e. [10] or [index]).
field | Any valid field that belongs to the referenced data structure.
term | Statement terminator. The semi-colon character is used ";"

Examples

To get the value stored in the "Field3" field of the 10th element of the array "myDataArray" and assign it to the variable "myValue", use the following code (note arrays are zero based, therefore you must use [n - 1] to access the nth element):

1.001 LIB myValue = myDataArray[9].Field3;

or

  1.045  MATH         index = 9
  1.046  LIB          myValue = myDataArray[index].Field3;

Write Data to a Field in the Data Structure Array

Set the value of a member/field of a data structure of an element in an array. Before you can access the members of a data structure array, you must create an array of the data structure and assign it to a variable (see above).

LIB array variableindex.field[sp]=[sp]valueterm

array variable | Any legal variable name that references an array of data structures created using a statement as described in the previous section.
index | Index of the array element to get. Can be any MET/CAL register, named variable or numeric literal value. Must be enclosed in square brackets (i.e. [10] or [index]).
field | Any valid field that belongs to the referenced data structure.
sp | One or more spaces
value | Any MET/CAL register, named variable or literal value. String literals must be enclosed in double quotes.
term | Statement terminator. The semi-colon character is used ";"

Examples

To set the "Field2" field of the 4th element of the array "myDataArray" to the value 65, use the following code (note arrays are zero based, therefore you must use [n - 1] to access the nth element):

1.001 LIB myDataArray[3].Field2 = 65;

or

  1.047  MATH         value = 65
  1.048  MATH         index = 3
  1.049  LIB          myDataArray[index].Field2 = value;

Rules

Allowed number of lines per statement

All LIB FSC statements can be split over multiple lines as needed to accommodate line length limitations in MET/CAL. When using multi-line statements, the splits must occur at logical points in the statement (i.e. you cannot split a variable name in half, etc.) The statement terminator character ";" must only appear at the end of the last line of the multi-line statement to mark the end of the statement. For string literals that need to be split over multiple lines, you should create a named variable using the MATH FSC. You may not split a statement into multiple lines in the middle of a string literal. Each line in a multi-line statement MUST have the same line number.

Examples of Valid Multi-Line Statements

  1.050  LIB          result = myComponent.SomeMethod
  1.050  LIB          (argument1, argument2, argument3);
  1.051  LIB          result =
  1.051  LIB          myComponent.SomeMethod(
  1.051  LIB          argument1,argument2,
  1.051  LIB          argument3);
  1.052  LIB          STRUCT  myDataStructure {
  1.052  LIB          Field1, Field2, Field3,
  1.052  LIB          Field4, Field5 };

Examples of Invalid Multi-Line Statements

# Not permitted to split a string literal!
  1.010 LIB     result = myComponent.SomeMethod("This is
  1.010 LIB     a test", argument2);
# All lines must have the same line number!
  1.012 LIB     result = myComponent.SomeMethod
  1.013 LIB     (argument1, argument2, argument3);
# Only the last line can have the termination character!
  1.020 LIB     result = myComponent.SomeMethod;
  1.020 LIB     (argument1, argument2, argument3);

Error Handling

The LIB FSC includes some settings that are configurable during procedure compilation and/or execution to assist the MET/CAL procedure writer in writing code to handle errors. These settings and their usage are described in detail below.

Syntax

The syntax to use for changing the value of a LIB FSC setting is as follows:

LIB SET setting[sp]=[sp]valueterm

setting | One of the valid LIB FSC settings (i.e. REQ_DEF, ERR_SUPPRESS, etc.)
sp | One or more spaces
value | Any MET/CAL register, named variable or literal value. String literals must be enclosed in double quotes.
term | Statement terminator. The semi-colon character is used ";"

The syntax to use for getting the value of a LIB FSC setting is as follows:

LIB GET variable[sp]=[sp]settingterm

variable | Any MET/CAL register or named variable. The register or variable must be capable of storing the value that the setting contains (i.e. numeric or string value).
sp | One or more spaces
setting | One of the valid LIB FSC settings (i.e. ERR_SUPPRESS, REQ_DEF, etc.)
term | Statement terminator. The semi-colon character is used ";"

Valid Settings

Setting: REQ_DEF

Determines whether the definition file must contain a definition for COM components. Valid settings are:

0 | Definition file is not required to contain definitions for COM components (default)
1 | Definition file must contain definitions for all COM components. Use the Component Definition Wizard to create the definition for all COM components and add the defintion file to the project.

Examples

To set the REQ_DEF setting in a MET/CAL procedure to require all COM components to have a definition, use the following code:

1.001 LIB SET REQ_DEF = 1;

To set the REQ_DEF setting in a MET/CAL procedure to allow COM components to be used without requiring a definition, use the following code:

1.001 LIB SET REQ_DEF = 0;

Setting: ERR_SUPPRESS

Determines whether a runtime exception (error) generated by the LIB FSC will cause procedure execution to halt or allow it to continue. Valid settings are:

0 | Runtime errors cause procedure execution to halt (default)
1 | Runtime errors are suppressed and will not cause procedure execution to halt. Error messages can be retrieved using the ERR_MSG value of the LIB FSC (see below)..

The LIB FSC may generate a runtime exception for various reasons including, but not limited to:

  • Attempting to load a Win32 DLL file that is not located in the expected folder or is not found in any of the folders referenced by the "PATH" environment variable.
  • Attempting to invoke a Win32 DLL function that has not been defined using the Component Definition Wizard.
  • Attempting to pass a data structure that has not been defined using the Component Definition Wizard to a Win32 DLL function.
  • Attempting to create a COM component that is not properly installed and/or registered on the computer.
  • Attempting to invoke a method or access a property of a COM component that does not exist.
  • Attempting to invoke a method or access a property of a COM component that exists but has not been defined using the Component Definition Wizard when the LIB FSC's REQ_DEF setting is set to "1".
  • Attempting to invoke a method or access a property of a COM component that exists but has not been defined using the Component Definition Wizard when the LIB FSC's REQ_DEF setting is set to "1".
  • Attempting to invoke a method or access a property of a COM component that exists but has not been defined using the Component Definition Wizard when the LIB FSC's REQ_DEF setting is set to "1".
  • Passing invalid data to a Win32 DLL function or COM component method (i.e. passing a non-numeric value to a function that requires a numeric value).
  • Using an index that exceeds the bounds of an ARRAY variable.
  • Attempting to access a field of a STRUCT that does not exist.

Examples

To set the ERR_SUPPRESS setting in a MET/CAL procedure to force procedure execution to halt when a LIB FSC statement generates an error, use the following code:

1.001 LIB SET ERR_SUPPRESS = 0;

To set the ERR_SUPPRESS setting in a MET/CAL procedure to allow procedure execution to continue after a LIB FSC statement generates an error, use the following code:

1.001 LIB SET ERR_SUPPRESS = 1;

Setting: ERR_MSG

Contains the message for the last runtime error that occurred. Reading this setting causes it to reset. This setting is read-only!

Examples

To get the message for the last error generated by the LIB FSC, use the following code:

1.001 LIB GET errorMsg = ERR_MSG;

Special Constructions

The LIB FSC recognizes the use of the following special constructions:

[MEM] | Write value of register MEM to specified address
[MEM1] | Write value of register MEM1 to specified address
[MEM2] | Write value of register MEM2 to specified address
[Mnreg] | Write value of global numeric register to specified address
[Lnreg] | Write value of local numeric register to specified address
[SREGnreg] | Write value of string register to specified address
[Vvariable] | Write value of variable to specified address

Examples

In addition to the examples shown below, the MET/CAL installer includes example projects showing how the LIB FSC to perform a variety of operations in greater detail than what can be included here. The examples can be found in the MET/CAL shared directory, in the .\proc\projects subdirectory.

Examples include:

  1. A full performance verification procedure for a National Instruments PXI-4130 Source Measure Unit (SMU).
  2. Plotting values from a procedure using Microsoft Excel, simulating a spectrum analyzer frequency response test.
  3. Interacting with a Microsoft Excel OEM uncertainty calculation spreadsheet, which includes writing data from MET/CAL to Excel, performing calculations, then returning the results from Excel back to MET/CAL.
  4. Using WIN32 System Information Functions

Excel Spreadsheet Example

The following simple example code demonstrates how to access an Excel spreadsheet from within a MET/CAL procedure using the LIB FSC and also how to properly use the CLEAR FSC to make sure Excel gets closed at the end of the procedure execution.

Copyright (c) (2014) Fluke Corporation.                  All rights reserved.
=============================================================================
INSTRUMENT:            Test Microsoft Excel Application
DATE:                  2014-04-14 15:37:34
AUTHOR:                Fluke Calibration
REVISION:
ADJUSTMENT THRESHOLD:  70%
NUMBER OF TESTS:       1
NUMBER OF LINES:       31
=============================================================================
 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
# Setup clean-up process
  1.001  CLEAR        -c     Sub Cleanup Excel
# Open an instance of Excel and make it visible
  1.002  LIB          COM excel = "Excel.Application";
  1.003  LIB          excel.Visible = True;
# Create a new empty workbook
  1.004  LIB          COM workbooks = excel.Workbooks;
  1.005  LIB          workbooks.Add();
# Select Sheet3 in the workbook
  1.006  LIB          COM worksheets = excel.Worksheets;
  1.007  LIB          COM worksheet = worksheets.item["Sheet3"];
  1.008  LIB          worksheet.Select();
# Select cell C5 in the selected worksheet
  1.009  MATH         myCell = "C5"
  1.010  LIB          COM selectedCell = worksheet.Range[myCell];
  1.011  LIB          selectedCell.Select();
# Write some text to the selected cell
  1.012  MATH         message = "This is a test!"
  1.013  LIB          selectedCell.FormulaR1C1 = message;
  1.014  END

Copyright (c) (2014) Fluke Corporation.                  All rights reserved.
=============================================================================
INSTRUMENT:            Sub Cleanup Excel
DATE:                  2014-04-14 15:39:28
AUTHOR:                Fluke Calibration
REVISION:
ADJUSTMENT THRESHOLD:  70%
NUMBER OF TESTS:       1
NUMBER OF LINES:       17
=============================================================================
# This subprocedure gets called by the CLEAR FSC when the main procedure
# terminates.
 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
# Disable Save prompt and close Excel
  1.001  LIB          excel.DisplayAlerts = False;
  1.002  LIB          excel.Quit();
  1.003  END

National Instruments DLL Example

The following examples describe how to interact with

Example: Get handle to nidcpower_32.dll

  1.053  MEM2         Open NI Measurement & Automation Explorer and determine
  1.053  MEM2         the resource name of the UUT.
  1.053  MEM2
  1.053  MEM2         The resource name is the string to the right of PXI-4130
  1.053  MEM2         in the tree view, under "Devices and Interfaces".
  1.053  MEM2
  1.053  MEM2         Enter UUT resource name (Ex. PXI1Slot2).
  1.054  MATH         ResourceName = MEM2
  1.055  LIB          DLL uut = "nidcpower_32.dll";
  1.056  LIB          @Status = uut.niDCPower_init(ResourceName, 0, 1, @vi);

Example: Call niDCPower_ConfigureOutputFunction to select channel 0 DC Voltage

# Source: Attribute Value Defines in nidcpower.h (DC Voltage = 1000 + 6).
  1.057  LIB          @Status = uut.niDCPower_ConfigureOutputFunction(@vi, 0, 1006);

Example: Call niDCPower_error_message to get error when return status is not equal to zero

  1.057  LIB          @Status = uut.niDCPower_ConfigureOutputFunction(@vi, 0, 1006);

  1.058  IF           @Status
  1.059  LIB          uut.niDCPower_error_message(@vi, @Status, Message);
  1.060  OPBR         -z [V @Method]
  1.060  OPBR
  1.060  OPBR         [V Message]
  1.060  OPBR
  1.060  OPBR         Select Yes to try again.
  1.060  OPBR         Select No to continue.
  1.060  OPBR         Select Terminate to abort the procedure.
  1.061  ENDIF

Example: Call niDCPower_close to close the handle. This LIB statement should be put in a subprocedure that is invoked whenever the procedure terminates. This is accomplished by including the subprocedure name in a CLEAR FSC statement in the main procedure.

1.062 LIB @Status = uut.niDCPower_close(@vi);

1.063 CLEAR -c Sub NI PXI-4130 Terminate LIB


RNG

Display Control FSC

Description

The RNG FSC is used to generate a message which prompts the operator to set the UUT to a specified RANGE. The RNG FSC may be used in place of a DISP FSC for two reasons:

  • Messages generated by the RNG FSC have the same format as automatic range messages.
  • MET/CAL remembers the specified range. If a subsequent range message (whether automatic or generated by a RNG statement) is identical to the previous range message, the display of the message is inhibited.

Refer to "Automatic Messages" in the MET/CAL Reference Manual for a description of automatic range messages.

Format

RNG range [AC] [-D]

Rules

  1. The range is specified as:

    2. [range value]prefixunits

    range value is an NR3-format number.

    If range value is not specified, the message defaults to Autorange.

    prefix is a MET/CAL units prefix code:

    p | pico
n | nano
u | micro
m | milli
k | kilo
M | mega
G | giga
Except for 'm' and 'M', prefix codes are case-insensitive.

    units is a MET/CAL units code:

    A | amps
A/A | amps / amps (amps ratio)
Ap | amps peak
App | amps peak-to-peak
bar | bar
cmH2O | centimeters of water
D | dBm
dB | decibels
deg | degrees
degC | degrees Celsius
degF | degrees Fahrenheit
df | duty factor
F | farads
ftH2O | feet of water
g/cm2 | grams per centimeter squared
H | hertz
H/H | hertz / hertz (frequency ratio)
IRE | IRE
inH2O | inches of water
inHg | inches of Mercury
J | joules
K | Kelvin
LM | line marker
mH2O | meters or water
mHg | meters or mercury
Pa | Pascals
pct | percent
psi | pounds per square inch
rad | radians
T | seconds
V | volts
VA | volt-amps
VAR | volt-amp reactive
Voff | volts offset
Vp | volts peak
Vpp | volts peak-to-peak
V/A | volts / amps
V/V | volts / volts (volts ratio)
W | watts
Y | siemens
Z | ohms
Z/Z | ohms / ohms (ohms ratio)

  2. AC/DC Specification

    3. IF "AC" is specified, the range message will indicate that the signal is an AC signal. It is illegal to specify "AC" unless the units are amps, amps peak, amps peak-to-peak, volts, volts peak, or volts peak-to-peak.

    Example:

    RNG 10V AC

    The RNG statement above will cause the following automatic range message to be constructed:

    "Set UUT to the 10V AC range."

    If "AC" is not specified, DC is assumed.

  3. Per Division Specification

    4. "-D" may be specified in a RNG statement to prevent inclusion of the 'per division' indicator in the range message.

    Normally, when an automatic range message is constructed, the ASK 'D' flag determines whether a 'per division' indicator is added to the message. The 'per division' indicator is used in scope calibration. It is included in the range message when ASK+ D is specified. Adding "-D" to a RNG statement has no effect of the ASK 'D'flag is not set (i.e., if ASK- D is specified). Refer to the ASK FSC Reference for more information on the ASK 'D' flag.

    Example:

    ASK+ D
RNG 10V
RNG 5V -D

    The first RNG statement generates the message:

    "Set UUT to 10V/div."

    "/div" is included in the messages because ASK+ D is in effect, and "-D" is not specified in the RNG statement.

    The second RNG statement generates the message:

    "Set UUT to the 5V DC range."

    Although ASK+ D is still in effect, inclusion of "/div" in the message has been suppressed because "-D" is specified in the RNG statement.

  4. Inclusion of MEM2

    5. If the MEM2 string register is non-empty, MEM2 is included in the range message. (This applies to automatic range messages as well as messages generated by the RNG FSC.)

    Example:

    ASK+ D
MEM2 =CH1
RNG 10V

    The RNG statement generates the range message:

    "Set UUT CH1 to 10V/div."

    Notice that the value of MEM2 has been added to the message (after the word "UUT").


STD

Miscellaneous FSC

Description

The STD FSC is used by a procedure writer to indicate that a manual standard is a traceable reference.

Format

STD standard

Rules

  • standard is the name of an instrument used as a manual standard. A maximum of 29 characters is allowed.
  • Leading and trailing spaces are ignored.
  • The MET/CAL Editor generates a "STANDARD" statement in the header of a compiled procedure for each distinct instrument specified in an STD statement.
  • Before starting execution of a procedure, MET/CAL retrieves the asset number associated with each standard from the MET/CAL Instrument Configuration. MET/CAL then queries the last calibration record for the asset in the database to determine if the standard is in cal or out of cal.

    • If the standard is not configured, or an asset number is not associated with the standard, the MET/CAL Runtime cannot execute the procedure. The MET/CAL Editor Test Run does not require manual standards to be configured in order to execute a procedure.

  • For each STD statement executed, the name of the standard (standard) is added to the list of standards used.

Examples

=============================================================================
INSTRUMENT:            STD FSC
DATE:                  2002-05-08
AUTHOR:                Fluke Calibration
REVISION:              1.0
ADJUSTMENT THRESHOLD:  70%
NUMBER OF TESTS:       1
NUMBER OF LINES:       22
STANDARD:              Fluke 792A
STANDARD:              Fluke 80K6 High Voltage Probe
=============================================================================
 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
  1.001  STD          Fluke 792A

  1.002  OPBR         Do you wish to perform the high voltage test?
  1.003  JMPL         END            MEM1 < 0

  1.004  STD          Fluke 80K6 High Voltage Probe

  1.005  LABEL        END
  1.006  END

When the above procedure is executed in MET/CAL Runtime, both standards must be configured with an associated asset number. However, if the operator chooses not to perform the high voltage test, only the Fluke 792A will be included in the list of standards used.


TOL

Miscellaneous FSC

Description

The TOL FSC is used to specify a test tolerance which will be used in subsequent instrument, MEMC, MEMCX, or ACC statements. When an instrument, MEMC, MEMCX, or ACC statement which contains "TOL" in its TOLERANCE field is executed, the tolerance specified in the most recently executed TOL statement is used. The specified tolerance should conform to the specifications of the UUT at the reference value.

Tolerance specifications in a TOL statement follow the same conventions used in the TOLERANCE field of an instrument FSC. The TOL FSC is useful when the instrument FSC TOLERANCE field is too narrow to hold the desired tolerance specification. The TOL FSC may also be used in cases where a single tolerance specification applies to more than one test.

Format

TOLtol spec tol spec tol spec ...

Rules

  • A maximum of 244 bytes are allowed in the body of the TOL statement (including spaces used to separate sub-fields). Characters below ASCII 128 occupy one byte.
  • A TOL statement may contain 0 or more tol spec sub-fields. Sub-fields are separated by 1 or more blanks.
  • Each tol spec sub-field must adhere to the format conventions which apply to the TOLERANCE field of an instrument FSC. Formats are shown in the following table:
Format | Meaning
[val]% | % of Nominal value
[val]/ | % of Range value
[val]P% | PPM of Nominal value
[val]P/ | PPM of Range value
[val]U | Units of Nominal unless the nominal unit is dBm. In this case dB is assumed to be unit of measure of the value entered.

val, if specified, may be a literal numeric value (NR3), a global numeric register in the form Mi where i is a register index, or a local numeric register in the form Li where i is a register index.

If val is not specified, the tolerance value is taken from numeric register MEM. (There is no way to use numeric register MEM1 to specify the tolerance value.)

It is important to realize that when a tolerance value is taken from a numeric register, the value is taken at the time of execution of the evaluation FSC, not at the time of execution of the TOL FSC. See "Example 3" in the EXAMPLES section below.

Examples:

TOL M23%

In this example the tolerance is specified as a percentage of the NOMINAL and the tolerance value is taken from global numeric register M[23] at run time.

TOL U

In this example the tolerance is specified in absolute units and the tolerance value is taken from numeric register MEM at run time.

Refer to the MET/CAL Reference Manual for more information on the TOLERANCE field and the tolerance computations.

Examples

Example 1:

STEP  FSC  RANGE NOMINAL TOLERANCE MOD1 MOD2  3  4  CON
2.005 TOL        0.001% 0.002/ 0.000001U
2.006 5700 10    10V     TOL                         2W

In this example, the desired tolerance specification is too long to fit in the TOLERANCE field of the 5700 statement. A TOL FSC is therefore used before the 5700 statement to specify the tolerance. In the 5700 statement, "TOL" is entered in the TOLERANCE field. This indicates that the tolerance specified in the most recently executed TOL statement is to be used to calculate the test tolerance when the 5700 statement executes.

Example 2:

STEP  FSC  RANGE NOMINAL TOLERANCE MOD1 MOD2  3  4  CON
1.001 TOL        3%
1.002 5700 1     1V      TOL                         2W
2.001 5700 10    10V     TOL                         2W
3.001 5700 100   100V    TOL                         2W

This example illustrates a case in which a single tolerance specification applies to multiple tests. The 3 5700 statements all use the same tolerance specification (3%).

Example 3:

STEP  FSC  RANGE NOMINAL TOLERANCE MOD1 MOD2  3  4  CON
3.001 MATH M[5] = 0.001
3.002 TOL        M5%
3.003 MATH M[5] = 0.002
3.004 5700 10    10V     TOL                         2W

This example illustrates that the tolerance at the time of the 5700 evaluation step will be 0.002%, not 0.001%. The TOL FSC specification is evaluated when the 5700 evaluation occurs, not when the TOL FSC itself executes.


VSET and TSET

Miscellaneous FSCs

Description

The VSET and TSET FSCs are general purpose FSCs used to assign values to certain system parameters.

Assignments made in a VSET statement are global in the sense that they affect all subsequent steps in the execution of a procedure, whether those steps are in the main procedure or in a subprocedure, and remain in effect until overridden or reset by another VSET statement.

Assignments made in a TSET statement are valid only for the current test. After each evaluation all TSET-specified parameters are returned to their VSET-specified, default, or unset values, whichever applies.

Many VSET / TSET parameters are related to the measurement uncertainty calculation. This on-line help file contains general information about the measurement uncertainty calculation which will be of interest even when the procedure does not include any VSET or TSET statements. Introduced with MET/CAL V7.10 are a number of new parameters related to guardbanding. The parameters are covered here in the VSET / TSET help file, but a more complete discussion of guardbanding is available in a separate document, "Guardbanding.pdf".

Parameter Summary

The following table lists all supported VSET and TSET parameters. For full information on each parameter refer to the Parameter List section or just click on the parameter name. It is important to be aware of Settings Inheritance, described just below this table.

ACCRED | accreditation flag
ALL | special parameter used to reset all parameters
C1, ..., C10 | sensitivity coefficients
CONF | confidence value
CORREQ | configure correction requirement
COV_FAC | coverage factor *
CPT | cardinal point
CS1, CS2 | sensitivity coefficients for S1 and S2
DF | effective degrees of freedom
DF1, ..., DF10 | individual degrees of freedom values
DFS1, DFS2 | degrees of freedom values for S1 and S2
EXP_UNC | expanded uncertainty
F | student's T factor
GB | guardband method
GBF | guardband factor
GB_INIT | guardband initialization file
GB_MODE | guardband table lookup mode
GB_OVERFLOW | guardband "overflow" control
GB_PTS | guardband Post Test Summary mode
GB_RESULT | guardband procedure result mode
GB_TABLE | guardband table
GB_TOL_ERR | guardband tolerance error calculation control
IEEE2_SRE_RQS | controls RQS in SRE register in IEEE2 & SCPI
IMPED | impedance
KCONF | specifies confidence for expanded uncertainty
LogLin | specify units for log-to-linear conversion
MATH_EPSILON | specifies epsilon factor for MATH comparisons
MEAS | measurement quantity for MEMC or MEMCX w/o NOM *
MEASURE_ONLY | flag to disable meter setup in meter drivers
MEMC_IRPT | control instrument statements in MEMC or MEMCX tests
MFILE | name of measurement uncertainty output file
MFILE_FORMAT | measurement uncertainty output file format
N5532A-504 | set frequency range for N5532A-504 sensor module
N5532A-518 | set frequency range for N5532A-518 sensor module
N5532A-526 | set frequency range for N5532A-526 sensor module
N5532A-550 | set frequency range for N5532A-550 sensor module
NMEAS | number of measurements
NOMCOR | controls correction lookup for fixed ohms
NSD | number of significant digits *
NTHROW | number of measurements to discard
PORT | specify default UUT COM port
REMCON | control "Please Remove All Connections" message
RESETUUT | control RESET FSC-specified reset of UUT
RSM | controls result saving mode for repeated tests
S1 | (SDEV / (N ^ 0.5)) * F
S2 | (UUT_RES * 0.5) / (3 ^ 0.5)
SensorChange | control automatic sensor module change
SLEWSTART | specify starting slew digit for certain FSCs
SRQDELAY | wait-for-SRQ retry loop delay
SRQHOLDOFF | initial wait-for-SRQ delay
SRQRETRY | maximum number of wait-for-SRQ retries
STD_UNC | standard uncertainty
SYS_ACC | accuracy of system instrument
TDESC | test description
TOL_REF | SYSTEM_ACTUAL, NOMINAL, or UUT_INDICATED
TSTEP | Test Step 2 (override)
U1, U2, U3, ..., U10 | uncertainty components
U2M | method for determining U2
UCONF | UUT specification confidence (for guardbanding)
UFMT | control formatting of uncertainty values
USE_ST | enables use of Student's T to determine F *
UUT_RES | absolute resolution of UUT
WS | Welch-Satterthwaite flag

Settings Inheritance

Many VSET and TSET FSC parameters can also be set via the database and MET/CAL Configuration settings. Whenever the same parameter is specified in more than one location, they are processed in order of precedence. Typically, they are by way of:

  1. Built-in calculation
  2. TSET
  3. VSET
  4. Guardbanding Initializaton File (applicable parameters only, see the Guardbanding.pdf manual)
  5. MET/CAL Configuration settings
  6. Database (i.e. MET/TEAM System Defaults)
  7. Default value

The parameters are available in the database, via MET/TEAM System Defaults:

Parameter | Description | System Default Name | Notes
COV_FAC | Coverage Factor | Uncert Coverage Factor |
NMEAS | Number of Measurements | Uncert Num Meas | As shipped, the number of measurements is set to zero in the database. That is, the measurement uncertainty calculation is not enabled by default. This parameter should normally not be set at the database level for this reason.
NSD | Number of Significant Digits | Uncert Sign Digits |
USE_ST | Use Student's T | Use Student T | This parameter should normally not be set at the database level since it only applies if you enable measurement uncertainty at the procedure level.

It is important to understand that resetting a VSET parameter by assigning the special value "*" to the parameter using a VSET statement causes the parameter value to revert to the value specified in the MET/CAL Configuration setting or database (if there is one).

Rules

  1. VSET and TSET support exactly the same set of parameters. In the remainder of this document, unless stated otherwise, all information about VSET parameters should be assumed to apply to TSET as well.

  2. The general form of a VSET statement is:

    VSET name = value

    where name is a recognized parameter name selected from the parameter list (see below), and value is a valid value for the specified parameter.

  3. A VSET statement may contain multiple assignments on a single line:

    VSET name1 = value1 name2 = value2 ...

    The procedure line length limits the number of assignments which may be made on a single line.

    A semi-colon (';') may be used to terminate the value specifier. Using semi-colons is optional and has no effect on the meaning of the procedure statement. In some cases using semi-colons may make the procedure statement easier to read.

  4. All string comparisons are case-insensitive, and spaces before or after the equals sign in an assignment are not significant.

  5. A VSET specification of a parameter persists for the duration of a procedure's execution until it is either overridden or reset in a subsequent VSET or TSET statement. A TSET specification of a parameter resets upon execution of an evaluation statement, and therefore persists only for the duration of the current test. For this reason, TSET specifications must be placed after a TARGET -p statement.

    If the procedure writer and/or operator jump past or otherwise skip VSET or TSET statements, they will not be executed and therefore will not be in effect until they are executed.

  6. A VSET or TSET parameter specification can always be reset by assigning the special value "*". In the case of TSET, using "*" to reset the specification has limited usefulness, because the parameter will be reset automatically at the end of the current evaluation step.

    When a VSET-specified parameter is reset, it is as if the procedure had never had a specification for that parameter. In other words, the determination of the parameter value reverts to being based on one of the other specification methods for that parameter (see Rule above).

  7. Special Constructions

    A VSET parameter value specification may include one or more MET/CAL special constructions. The following special constructions are supported:

    • [MEM], [MEM1], and [MEM2]
    • [M1], [M2], ...
    • [L1], [L2], ...
    • [S1], [S2], ...
    • [SREG1], [SREG2], ...
    • [Vvariable]
    • [numeric]
    • [Xhex list]

    Refer to Special Constructions for more information.

    The constructions [M1], [M2], ..., access the global numeric registers. The constructions [L1], [L2], ..., access the local numeric registers. Up to 12 significant digits are included in the numeric register value. Refer to the MATH FSC on-line help for additional information on the numeric registers. The constructions [S1], [S2], ..., access the string registers. Refer to the MATH FSC on-line help for additional information on the string registers.

    The constructions [SREG1], [SREG2], ..., are identical to [S1], [S2], ..., and are included only for compatibility with the IEEE, IEEE2, and SCPI FSCs.

    The two primary reasons for using a special construction in a VSET or TSET parameter value specification are:

    1. To allow the parameter value to be calculated using the MATH FSC.
    2. To allow the operator to be prompted for the parameter value.

    For example, to prompt the operator for the value of the VSET parameter NMEAS, include the procedure statements:

    1.001  MEMI         Please enter the number of measurements:
1.002  VSET         NMEAS = [MEM]

    When using special constructions in a VSET statement, it is important for the procedure writer to realize that doing so prevents the MET/CAL compile time system from checking the value to make sure it's valid. This means that an error in the value specification will result in a runtime error. In some cases it may be difficult or impossible for the operator to correct such a mistake, and procedure execution may be terminated or the results may be invalidated.

    Special constructions cannot be used in VSET parameter names, only in parameter values.

Notes:

Exponentiation
In this document the caret symbol (^) is used to indicate exponentiation. For example, "3 ^ 0.5" means "3 to the 1/2 power", which is the square root of 3.
Units
Please refer to the UNITS section near the end of this help file for important information about using VSET to override values of physical quantities.
Measurement Uncertainty Hints
Refer to Measurement Uncertainty Hints near the end of this help topic for general information about enabling and using the measurement uncertainty calculation.
Datron 4950
Refer to the section Using the Datron 4950 for a description of how to use the Datron 4950 in conjunction with the measurement uncertainty calculation.

Parameter List

ACCRED

ACCRED allows the procedure writer to designate one or more tests in a procedure as "accredited" or "non-accredited". The intent is to allow procedure writers to comply with reporting requirements which mandate that accredited tests be distinguished from non-accredited tests.

ACCRED may be specified only in the procedure. Legal values are 0 ("No"), 1 ("Yes"), or any integer between 2 and 32767. Values other than 0 and 1 may be useful if it is necessary to distinguish between different types of accredited calibrations. Default = 0.

ACCRED has no effect on the measurement uncertainty calculation, or any other aspect of procedure execution. To make use of the accreditation flag in a report, use Crystal Reports to access the "accred" field in the database Results Table. (ACCRED has no effect on, and is not recorded in, the "Cal Results" table used in V6 Legacy Results.)

Example 1:

1.001  5700         1.00V          1%                                    2W
2.001  TSET         ACCRED = Yes
2.002  5700         10.00V         1%                                    2W
3.001  5700         100.00V        1%                                    2W

The procedure fragment above shows 3 tests. The first and third are non-accredited. The second is accredited.

Example 2:

INSTRUMENT:            Fluke 77 Verification

  1.001  VSET         ACCRED = Yes
  ...

In this example, a VSET statement which sets ACCRED to "Yes" is included at the top of the procedure. This causes all tests in the procedure to be designated as accredited.

ALL

ALL is a special parameter name used to refer to all VSET/TSET parameters. The only legal value for the ALL parameter is "*".

This statement resets all VSET / TSET parameters:

VSET ALL = *

This statement must be used with caution because it resets all settings made up to the point of execution of the VSET ALL = * statement. The settings being reset include any settings made in the calling procedure as well as in the current procedure.

The statement TSET ALL = * is allowed, but not very useful. It causes all current TSET settings to be reset. However, because TSET is defined to apply only to the current test, the TSET settings will be automatically reset when the test step terminates.

Compatibility: ALL requires V7.11h or later.

C1, C2, ..., C10, CS1, CS2

C1, C2, ..., C10, CS1, CS2 specify sensitivity coefficients used in the measurement uncertainty calculation. For all sensitivity coefficients the default value is 1.0.

By default, MET/CAL V7 calculates the standard uncertainty as:

Standard Uncertainty = RSS(C1*U1, C2*U2, ..., C10*U10)

If neither U2 nor C2 are directly specified in a VSET or TSET statement, C2 is calculated from CS1, S1, CS2, and S2.

If CS1 and CS2 are both allowed to default to 1, the calculated value of C2 will be 1 as well.

Thus, if the procedure writer does not specify values for any sensitivity coefficients, the calculation of standard uncertainty simplifies to the calculation used in MET/CAL V6:

Standard Uncertainty = RSS(U1, U2, U3, ..., U10)

The sensitivity coefficients are partial derivatives which appear in the standard formula for calculating standard uncertainty. The partial derivatives describe how the output estimate varies with changes in the values of the input estimates. The MET/CAL procedure interpreter does not have the information which would be required to directly evaluate the partial derivatives. However, the metrologist may externally determine the partial derivatives and directly specify the resulting sensitivity coefficients.

Sensitivity coefficients are also used in Welch-Satterthwaite mode when the effective degrees of freedom is calculated.

CONF

The CONF parameter allows a Confidence to be specified for use in the measurement uncertainty calculation. The Confidence is a statistical measure of the confidence associated with the specifications given for a calibration standard. The Confidence must be specified as a sigma value, not as a percentage. For example, if the specifications for a calibration standard are stated as having a 99% confidence, the Confidence should be set to 2.58, which is the equivalent sigma value. In cases where the confidence associated with the specification of a calibration standard is unknown, you may wish to use 1.73 (that is, 3 ^ 0.5). This is a conservative choice based on the assumption of a rectangular distribution.

The Confidence is used to calculate Normalized System Accuracy.

Recall that Standard Uncertainty = RSS(U1, U2, U3, ..., U10)

where U1 is the Normalized System Accuracy, calculated as System Accuracy / Confidence.

The System Accuracy is the accuracy of the calibration standard, and is usually determined by looking up the value in a MET/CAL accuracy file.

Similar to standard Settings Inheritance, there are three (3) ways to specify Confidence:

  1. Accuracy File Header

    The Confidence is a required part of the accuracy file header. When MET/CAL looks up the specifications of a supported system instrument in an accuracy file, it also reads the Confidence from the accuracy file header. Unless overridden in a VSET statement or the MET/CAL Configuration settings, the value from the accuracy file is used in the measurement uncertainty calculation.

    When the ACCF FSC is used to specify an alternate accuracy file, the confidence value from the accuracy file header (if any) is not used to normalize the reference accuracy. Instead, the default confidence value (2 sigma) is used. Use VSET to directly specify the confidence if ACCF is used with an accuracy file for which the confidence is not 2 sigma.

  2. VSET Statement

  3. MET/CAL Configuration settings

    It is possible to specify the Confidence in the MET/CAL Configuration settings. In general, however, it is not advisable because the specification overrides all confidence specifications in all accuracy file headers, and will be used globally in the measurement uncertainty calculation unless overridden at the procedure level using a VSET statement.

Example

VSET conf = 2.58

CORREQ

CORREQ allows the procedure writer to require that a correction be performed for designated tests. Legal values for CORREQ are "Yes", "No", and "Exact", interpreted as follows:

Yes
If the ASK 'C' flag is set, terminate the step with an error if a correction was not performed.
No (default)
If the ASK 'C' flag is set, but a correction was not performed, do not terminate the step. (This is the way MET/CAL worked unconditionally prior to V7.11 SP1.)
Exact
If the ASK 'C' flag is set, terminate the step with an error if an exact correction was not performed.

CORREQ has no effect if the statement is not of the right type, regardless of the state of the ASK 'C' flag. For example, EVAL and Go / No Go tests cannot be corrected.

CORREQ cannot be specified in the MET/CAL Configuration settings.

Compatibility: Requires V7.20 or later.

COV_FAC

It is important to understand Settings Inheritance since this parameter may be set in a variety of ways.

COV_FAC specifies the Coverage Factor used to calculate the Expanded Uncertainty as:

Coverage Factor * Standard Uncertainty

By convention, the value typically used for the coverage factor is 2. This is MET/CAL's default value used when COV_FAC is not specified anywhere else.

Example:

VSET COV_FAC = 1.8

In MET/CAL version 6 or later, the coverage factor is one of three quantities which can be written to the results. Use the MET/CAL variable MU_COV$ in the format file, usually rslt_db.frm, to cause the coverage factor to be included in the result line for each test. (If the measurement uncertainty is not calculated for a particular test, MU_COV$ will be blank.)

There is no provision in version 6.0 or later for automatically determining the coverage factor as a function of the number of degrees of freedom.

CPT

CPT is used to specify the cardinal point of a test. The Cardinal Point of a test is normally determined automatically as follows:

If the test is an instrument FSC evaluation step, the Cardinal Point is the Nominal.

If the test is a MEMC or MEMCX evaluation:

If a literal numeric value is specified in the MEMC or MEMCX NOMINAL field, that value is the Cardinal Point. If no literal numeric value is specified in the MEMC or MEMCX NOMINAL field, and there's an ACC statement in the test, the Cardinal Point is the ACC Nominal value.

If no literal numeric value is specified in the MEMC or MEMCX NOMINAL field, and there's no ACC statement in the test, but there is an instrument FSC setup statement in the test, the Cardinal Point is the Nominal value of the instrument FSC setup statement. If no literal numeric value is specified in the MEMC or MEMCX NOMINAL field, and there's no ACC statement in the test, and no instrument FSC setup statement in the test, the Cardinal Point is the Fixed Quantity. (The Fixed Quantity is the test comparison value which does not have the potential to vary.)

However, for some tests the automatic determination of the Cardinal Point, as described above, is not adequate and a direct specification of the Cardinal Point, using a VSET or TSET statement, is required.

Example

Suppose the UUT is a decade resistance device. The Cardinal Point of a particular test may be 1 kOhm, but the characterized resistance at that cardinal point may be 1.00001 kOhm. The UUT Indicated value will therefore be 1.00001 kOhm, and the System Actual value will be the reading taken by the meter being used to verify the decade resistance device. Notice that neither the UUT Indicated nor the System Actual, which are the test comparison values, are the same as the 1 kOhm cardinal point. The procedure writer may therefore specify:

TSET CPT = 1.000kOhm

Cardinal Point is written directly to the V7 Results Table. Cardinal Point is also used to construct the Test Description, unless overridden by a direct specification of Test Description. In some cases Fixed Quantity (another V7 result parameter) depends on Cardinal Point.

DF

DF specifies the effective degrees of freedom for the measurement uncertainty calculation. DF is used only when the Welch-Satterthwaite mode is enabled (refer to WS). By default, DF is the estimated effective degrees of freedom based on the Welch-Satterthwaite approximation. The Welch-Satterthwaite formula makes use of the individual uncertainty components, the sensitivity coefficients, and the per-component degrees of freedom values. However, the procedure writer may override the calculated DF value by directly specifying the effective degrees of freedom in a VSET or TSET statement.

DF cannot be specified in the MET/CAL Configuration settings.

Legal values for DF are any numeric value or the string "INF", which designates infinity. Procedure writers should take care not to specify an inappropriate value for the effective degrees of freedom.

DF1, DF2, ..., DF10, DFS1, DFS2

DF1, DF2, ..., DF10, DFS1, DFS2 are the per-component degrees of freedom values. In other words, for each uncertainty component, U1, U2, U3, ..., U10 there's an associated number of degrees of freedom. Similarly DFS1 is the degrees of freedom value associated with S1, and DFS2 is the degrees of freedom value associated with S2.

DF1, DF2, ..., DF10, DFS1, DFS2 are used only when the Welch-Satterthwaite mode is enabled.

Legal values for DF1, DF2, ..., DF10, DFS1, DFS2 are any numeric value or the string "INF". "INF" designates infinity. By default DF2 is derived from DFS1, DFS2, CS1, CS2, and U2. For DF1, DF3, ..., and DF10 the default value is "INF" (infinite degrees of freedom). The default value for DFS2 is "INF".The default value for DFS1 is (NMEAS - 1). Procedure writers should take care not to specify inappropriate values for the per-component degrees of freedom.

A direct specification of DF2 overrides the uses of DFS1 and DFS2.

The DF1, DF2, ..., DF10, DFS1, DFS2 are used in the Welch-Satterthwaite approximation to determine the effective degrees of freedom.

DF1, DF2, ..., DF10, DFS1, DFS2 cannot be specified in the MET/CAL Configuration settings.

Example:

TSET DF1 = 8

TSET DF3 = 100

In this example, the degrees of freedom for the (Type B) uncertainty of the reference is set to 8. (DF1 is associated with U1, and U1 is the uncertainty component derived from the reference instrument in the test.)

The degrees of freedom for the optional U3 uncertainty component is set to 100.

DF2 is not directly set, and so defaults to NMEAS - 1.

A DF1, DF2, ..., DF10, DFS1, DFS2 specification makes no contribution to the uncertainty calculation unless the corresponding uncertainty component and corresponding sensitivity coefficient are both non-zero.

Values for DF1, DF2, ..., DF10 are saved in the V7 Results Table.

Values for DFS1 and DFS2 are not available in the Results Table, but are available in the MFILE (if the procedure enables the generation of that file).

Compatibility: DFS1 and DFS2 require V7.01 or later.

EXP_UNC

EXP_UNC is the expanded measurement uncertainty. If measurement uncertainty is enabled, MET/CAL normally calculates the expanded uncertainty as:

EXP_UNC = STD_UNC * COV_FAC

where STD_UNC is the standard uncertainty and COV_FAC is the coverage factor.

However, it is possible to directly specify the expanded uncertainty in a procedure by using a VSET statement. This overrides the built-in calculation of expanded uncertainty.

Example:

VSET EXP_UNC = 0.01

Setting EXP_UNC directly is appropriate when MET/CAL's built-in measurement uncertainty calculation does not yield correct results for a particular test, and where the procedure writer has externally determined the uncertainty.

To reset the overriding of EXP_UNC, use the standard VSET reset convention:

VSET EXP_UNC = *

Directly specifying the value of the expanded uncertainty in this way removes any dependency on the measured values, number of measurements, UUT resolution, confidence value, and Student's T distribution, for those tests. The dependency is removed only for the expanded uncertainty, however, not for the standard uncertainty, which will still be calculated in the normal way, unless its calculation is also overridden using a VSET statement.

In general, in cases where the procedure writer has calculated the measurement uncertainty externally, it will usually make more sense to use VSET to override STD_UNC and, possibly, COV_FAC, and allow MET/CAL to continue to calculate the expanded uncertainty as:

EXP_UNC = STD_UNC * COV_FAC

F

F is a factor based on the Student's T distribution and the number of degrees of freedom. Recall that the basic measurement uncertainty calculation is:

Standard Uncertainty = RSS(U1, U2, U3, ..., U10)

where U2 = RSS(S1, S2)

and where S1 = (SDEV / (NMEAS ^ 0.5)) * F

SDEV is the standard deviation of the measurements, NMEAS is the number of measurements, and S2 is based on the resolution of the UUT.

Unless overridden or disabled, the value of F is determined per Table G.2 of Annex G of the document ANSI/NCSL Z540-2-1997. The values of F used by MET/CAL are exactly half the values shown in the 95.45% column of Table G.2.

MET/CAL uses the simplifying assumption that the number of degrees of freedom is one less than the number of measurements (NMEAS). If this assumption is not acceptable, it may be possible for the metrologist / procedure writer to directly calculate F and override MET/CAL's built-in determination of F (see below).

Overriding F

There are two ways to override the value of F:

  1. F can be specified in the MET/CAL Configuration settings. However, specifying F in this way is of limited use because it applies to all measurement uncertainty calculations, regardless of the number of measurements, unless overridden at the procedure level in a VSET statement. (If you don't want to use the factor F at all in the measurement uncertainty calculation, see the section "Disabling F" below.)
  2. F can be directly specified at the procedure level in a VSET statement. A VSET specification of F overrides the normal built-in calculation of F, and also overrides a MET/CAL Configuration setting, if any. It does not, however, enable the use of F if it is disabled.

Example:

VSET F = 1.5

Disabling F

Some metrologists believe that the calculation of S1 should be simply:

S1 = (SDEV / (NMEAS ^ 0.5))

To disable the use of F in the calculation of S1, set the USE_ST parameter to "no". This can be done at the database, workstation, or procedure level. See the description of USE_ST below.

GB

Guardbanding is disabled by default. GB specifies the guardband method. The following parameter values are supported:

DIRECT
The DIRECT method causes MET/CAL to tighten the specification limits by a a specified factor. The factor is specified using the GBF parameter.
MU
MU is the measurement uncertainty method. The guardbanded test limits are determined by tightening the specification limits by an amount equal to the expanded measurement uncertainty.
The measurement uncertainty calculation must be enabled to use the MU guardband method.
The MU method may be modified by specifying a guardband factor. For example, if GBF is 0.8, the guardband limits will be determined by tightening the specification limits by 80% of the expanded measurement uncertainty.
NTUR
NTUR is a table-based guardband method in which the lookup parameter is the normalized test uncertainty ratio. The normalized test uncertainty ratio is calculated as:
normalized UUT spec / std uncertainty The normalized UUT specification is determined by dividing the stated UUT specification by a confidence factor. The UCONF parameter is used to specify the confidence. (The default is 2.0).
OFF
OFF unconditionally disables guardbanding.
Specifying "VSET GB = OFF" is useful if you specify a default guardbanding method in the guardbanding initialization file or the the MET/CAL Configuration settings, and wish to selectively disable guardbanding for a particular procedure or for particular tests within a procedure.
"OFF" is not supported in V7.10 and V7.11. You must have version V7.11b or later to use the "OFF" GB parameter value.
RDS
RDS is the root difference square guardband method.

The RDS method tightens the specification limits by:

SQRT(TOL^2 - EMU^2)

where "TOL" is the UUT specification and "EMU" is the expanded measurement uncertainty.

TSR
TSR is the test specification ratio method.
This is a table-based method where the lookup parameter is the TSR.

TSR is defined as:

(UUT spec) / (reference accuracy)

TUR
TUR is the test uncertainty ratio method.
This is a table-based method where the lookup parameter is the TUR.
This is the real TUR, not the TSR, which MET/CAL has traditionally called the "TUR".

TUR, for guardbanding, is defined as:

(UUT spec) / (EMU)

where EMU is the expanded measurement uncertainty.

Specifying VSET GB = * disables the procedure-based guardbanding specification and the method reverts to the metcal.ini setting, as described in Guardbanding.pdf. In the absence of a metcal.ini setting, the guardbanding method reverts to the guardbanding initialization file specification. In the absence of both, this statement will disable guardbanding (i.e. in this case, this is the same as VSET GB = OFF).

GBF

GBF specifies the guardband factor and is only used when the guardband method is DIRECT or MU.

When the guardband method is DIRECT, GBF species the factor by which to tighten the specification limits to produce the guardband limits. GBF must be specified when the guardband method is DIRECT.

When the guardband method is MU, GBF specifies a factor applied to the expanded measurement uncertainty prior to calculating the guardband limits from the specification limits. In other words the spec limits are tightened by:

EMU * GBF

where EMU is the expanded measurement uncertainty and GBF is the guardband factor.

When the guardband method is MU, GBF defaults to 1.0.

GB_INIT

GB_INIT specifies the name of the guardband initialization file. The specified file may be placed on a network drive, allowing multiple workstations to share the same guardbanding parameters.

A metcal.ini file setting overrides the guardband initialization file setting.

For example, if the guardband method is set to DIRECT in the guardband initialization file but also set to MU in metcal.ini, the method will be MU for all procedures run on the workstation (assuming that the procedure does not directly specify GB using VSET or TSET statements).

GB_MODE

GB_MODE specifies the guardband table lookup mode. GB_MODE applies only to table-based methods (TSR, TUR, NTUR). The choices are:

STEP
Interpret the guardband table as a step function. If a lookup value falls between two rows of the table, use the row with the smaller lookup value.
INTERP
Linearly interpolate between rows of the guardband table when a lookup value falls between two rows.

GB_OVERFLOW

GB_OVERFLOW configures the handling of a guardbanding overflow condition when the guardbanding method is MU. An overflow condition occurs when the calculated uncertainty of the measurement exceeds the tolerance of the test. Recall that when the method is MU, the guardbanded test limits are determined by tightening the specification limits by an amount equal to the expanded measurement uncertainty. Therefore, if the expanded measurement uncertainty exceeds the test tolerance it is not possible to tighten the test limits by the required amount. This is because a test cannot have a test tolerance less than zero.

There are two situations which, individually or in combination, may give rise to an overflow condition:

  • Large standard deviation caused by UUT values that vary excessively when NMEAS is greater than 1, causing a large measurement uncertainty.
  • If the reference is inadequate relative to the UUT (i.e., the Test Uncertainty Ratio is close to or even less than 1), the reference accuracy may dominate the calculated measurement uncertainty. In this case the test is not metrologically sound.

GB_OVERFLOW allows the procedure writer or system administrator to configure how MET/CAL handles an overflow condition. There are 4 choices for the GB_OVERFLOW value:

LIMIT
When GB_OVERFLOW is set to LIMIT, an overflow condition causes MET/CAL to set the guardbanded test tolerance to zero. This prevents the test from passing outright, but allows Pass Indeterminate, Fail Indeterminate, and Fail as possible test results.
LIMIT_W
LIMIT_W is the same as LIMIT, except that a runtime warning is generated to notify the operator that a guardbanding overflow condition has occurred.
DISABLE
When GB_OVERFLOW is set to DISABLE, MET/CAL handles an overflow condition by turning guardbanding off for the test.
DISABLE_W
DISABLE_W is the same as DISABLE, except that a runtime warning is generated to notify the operator that a guardband overflow condition has occurred.

The default value of GB_OVERFLOW is LIMIT_W. In addition to being specified in the procedure in a VSET or TSET statement, GB_OVERFLOW may also be specified in metcal.ini or in the guardbanding initialization file.

When a guardbanding overflow condition occurs, MET/CAL annotates the guardbanding method name in the database by appending the overflow indicator "*". In other words, the method name in the Results Table will be "MU *" instead of "MU". Report writers may make use of the "*" annotation to flag test results which are doubtful due to a guardbanding overflow.

Compatibility: GB_OVERFLOW is not supported in V7.11 SP1 or prior versions. The first released version of MET/CAL which supports GB_OVERFLOW is V7.20.

GB_PTS

GB_PTS is used to control Post Test Summary window when guardbanding is enabled. Procedures often include an ASK- F specification. The effect of this is to cause the Post Test Summary window to be shown after each test with a FAIL result, but not after test with a PASS result. When guardbanding is enabled the situation is more complex. For a guardbanded test, the result is PASS, PASS INDETERMINATE, FAIL INDETERMINATE, or FAIL. GB_PTS allows the procedure writer to configure the operation of MET/CAL in this respect.

Legal values for GB_PTS are:

F
Post Test Summary is shown only after a FAIL result.
Post Test Summary is not shown after a PASS, PASS INDETERMINATE, or FAIL INDETERMINATE result.
P
Post Test Summary is suppressed after a PASS result.
Post Test Summary is shown after a FAIL, FAIL INDETERMINATE, or PASS INDETERMINATE result.
PF
Suppress Post Test Summary after a PASS or PASS INDETERMINATE result.
Display Post Test Summary after a FAIL or FAIL INDETERMINATE result.
RESULT
Causes the GB_PTS parameter to take the same value as the GB_RESULT parameter.

The following table shows how the GB_PTS value and the test result determine whether or not the Post Test Summary is shown:

Test Result
GB_PTS | Pass | Pass Indeterminate | Fail Indeterminate | Fail
F | No | No | No | Yes
P | No | Yes | Yes | Yes
PF | No | No | Yes | Yes

GB_PTS may be specified in metcal.ini or in the guardbanding initialization file, as well as using VSET and/or TSET statements. The default value for GB_PTS is RESULT.

Specifying VSET GB_PTS = * causes the GB_PTS specification to be as it would be without any procedure specification of GB_PTS.

GB_PTS is not supported in MET/CAL V7.10 and V7.11. You must have V7.11b or later to use the GB_PTS parameter. In V7.10 and V7.11 the behavior of the software with regard to the Post Test Summary display after a guardbanded test is equivalent to a GB_PTS = P specification.

GB_PTS has no effect on tests to which guardbanding cannot be applied (e.g., EVAL tests, go / no go tests, and operator-terminated tests).

GB_PTS also has no effect if the ASK 'A' flag is used to configure the system to always display (ASK+ A), or never display (ASK- A), the Post Test Summary.

GB_RESULT

GB_RESULT specifies the guardband procedure result mode. GB_RESULT allows the overall result determination method to be configured in cases where guardbanding produces one or more "indeterminate" results. The choices are:

P
Specifying P causes MET/CAL to interpret indeterminate results as PASS results for purposes of determining the overall procedure result.
PF
Specifying PF causes MET/CAL to interpret pass indeterminate results as PASS results for purposes of determining the overall procedure result, and interpret fail indeterminate results as FAIL results for purposes of determining the overall procedure result. In otherwords, the overall result is determined just as if guardbanding was not enabled in the first place.
F
Specifying F causes MET/CAL to interpret indeterminate results as FAIL results for purposes of determining the overall procedure result.

The GB_RESULT default value is PF.

GB_TABLE

GB_TABLE specifies the name of the guardband table. The guardband table is a simple text file containing two columns of numbers.

  1. Column one specifies lookup parameter values.
  2. Column two specifies guardband factor values.

Comment lines may be specified by preceding the line with a '#' or a ';' character.

The GB_MODE parameter controls whether MET/CAL interpolates between rows of the table.

  • If a lookup value is less than the value in the first row, the guardband factor from the first row is used.
  • If a lookup value is greater than the value in the last row, the guardband factor from the last row is used.

The table is used only for the TSR, TUR, and NTUR table-based methods. Here's a very simple example:

#TSR GBF
1.0 0.4
2.0 0.6
3.0 0.8
4.0 1.0

Suppose the guardband method is TSR and the guardband mode is STEP. If the TSR is less than 2, the guardband factor will be 0.4.

  • If the TSR is greater than or equal to 2, but less than 3, the guardband factor will be 0.6.
  • If the TSR is greater than or equal to 3, but less than 4, the guardband factor will be 0.8.
  • If the TSR is greater than or equal to 4, but less than 4, the guardband factor will be 1.0 (that is, in effect, no guardbanding).

The table above is just an example -- not a recommended guardband algorithm.

GB_TOL_ERR

GB_TOL_ERR determines how MET/CAL calculates the Tolerance Error when guardbanding is enabled. The Tolerance Error is the error of a test expressed as a percentage of the Test Tolerance. The Tolerance Error is shown in the Post Test window (if enabled) after each test, shown in the Test Results window, and saved in the database Results Table. In the Post Test window the Tolerance Error is on the row labeled "Error % Tol".

  • In the Test Results window the Tolerance Error is in the column labeled "%Tol".
  • In the Results Table the Tolerance Error value is in the column labeled "tol_err".

GB_TOL_ERR allows the procedure writer or system administrator to configure whether the Tolerance Error calculation is based on the specified limits for the test or on the guardbanded pass limits.

There are 2 choices for the GB_TOL_ERR value:

SPEC

When GB_TOL_ERR is set to SPEC, MET/CAL uses the limits based on the UUT's specified tolerance as the basis for the Tolerance Error calculation.

For example, suppose:

Reference Value | = 10.0 V
UUT Value | = 10.1 V
Test Tolerance | = 2 %
Expanded Uncertainty | = 0.05 V
Guardbanding Method | = MU

then:

Upper Spec Limit | = 10.2 V
Guardbanded Upper Limit | =10.15 V
Tolerance Error | = 50 %

50 % comes from the fact that the actual error (0.1 V) is 50 % of the UUT's specified tolerance (0.2 V).

GB_PASS

When GB_TOL_ERR is set to GB_PASS, MET/CAL uses the guardbanded pass limits as the basis for the Tolerance Error calculation. Continuing with the previous example, suppose:

UUT Value | = 10.1 V
Test Tolerance | = 2 %
Expanded Uncertainty | = 0.05 V
Guardbanding Method | = MU

then:

Upper Spec Limit | = 10.2 V
Guardbanded Upper Limit | = 10.15 V
Tolerance Error | = 67 %

67 % comes from the fact that the actual error (0.1 V) is 67 % of the guardbanded tolerance (0.15 V).

The default value of GB_TOL_ERR is SPEC. In addition to being able to be specified in the procedure in a VSET or TSET statement, GB_TOL_ERR may also be specified in the MET/CAL Configuration settings or in the guardbanding initialization file.

Compatibility: GB_TOL_ERR is not supported in V7.20 or prior versions. Versions of MET/CAL that supported guardbanding, up to and including V7.20s, calculated Tolerance Error based on the guardbanded pass limits. This was equivalent to GB_TOL_ERR = GB_PASS, but there was no ability to configure the setting.

IEEE2_SRE_RQS

IEEE2_SRE_RQS controls whether or not the RQS bit is set in the SRE register by the IEEE2 and SCPI FSCs. Legal values for IEEE2_SRE_RQS are "Yes" and "No". The default, used when IEEE2_SRE_RQS is not specified, is "No". Parameter values are interpreted as follows:

Yes
Setting IEEE2_SRE_RQS to "Yes" causes MET/CAL to set the RQS bit (bit 6) in the SRE register prior to a query or command using the IEEE2 or SCPI FSCs.
No
Setting IEEE2_SRE_RQS to "No" causes MET/CAL not to set the RQS bit (bit 6) in the SRE register prior to a query or command using the IEEE2 or SCPI FSCs.

Compatibility: Requires V7.20v or later.

Prior to the implementation of the IEEE2_SRE_RQS parameter, the IEEE2 and SCPI FSCs always set the RQS bit in the SRE (Service Request Enable) register. The RQS bit in the SRE register is a "don't care" bit. That is, it shouldn't make any difference whether or not the RQS bit in the SRE register is set. However, at least one instrument has been discovered that regards having RQS set in the SRE register as an error.

Technically, the instrument does not comply with the IEEE-488.2 standard. In any event, beginning with V7.20v, MET/CAL has been changed so that it doesn't set RQS in the SRE register when IEEE2 and SCPI statements are executed. Although it should never be necessary to do so (if all instruments rigorously comply with the 488.2 standard) procedure writers may use the IEEE2_SRE_RQS parameter to force the setting of RQS if an instrument is found that requires this setting.

IMPED

IMPED specifies the impedance value (in ohms) used when MET/CAL converts dBm values to volts (rms). Linearization of logarithmic units is required in order to calculate the measurement uncertainty and the test accuracy ratio. Any value between 0.0 and 1.0E6 is legal. It is the procedure writer's responsibility to specify an appropriate value (e.g. 50, 75). The default value is 50.

IMPED cannot be used to override MET/CAL's built-in knowledge of the impedance of a reference when linearization of a dBm value is required. For example, a MET/CAL test which includes a 5700A setup statement followed by a MEMCX statement to perform an evaluation, where the units of the NOMINAL field are dBm, uses the appropriate 5700A impedance value. An impedance value specified using the IMPED parameter will be ignored in this context. A VSET/TSET IMPED specification is appropriate in a test which includes an ACC statement to specify the reference accuracy in dBm, followed by a MEMC or MEMCX statement in which the evaluation quantity units are dBm. IMPED may be specified in a VSET or TSET statement, but not in the MET/CAL Configuration settings.

Example:

TSET IMPED = 75.0

Compatibility: Requires V7.20b or later.

KCONF

KCONF specifies the confidence at which the expanded uncertainty is to be reported when Welch-Satterthwaite mode is enabled. Legal values for KCONF are:

  • 68.27%, 1s, 1sigma
  • 90.00%
  • 95.00%
  • 95.45%, 2s, 2sigma
  • 99.00%
  • 99.73%, 3s, 3sigma

Multiple values on each item above are equivalent. KCONF has no effect unless Welch-Satterthwaite mode is enabled, and the coverage factor (COV_FAC) is not directly specified in the procedure or MET/CAL Configuration settings.

In Welch-Satterthwaite mode, MET/CAL determines the effective degrees of freedom (DF), and then looks up the coverage factor in a T-distribution table at the specified confidence (KCONF). For example, for 6 degrees of freedom with 95.45% (2 sigma) confidence, the coverage factor is 2.52. The default value for KCONF is 2 sigma.

LogLin

The LogLin parameter is used to specify the target unit used for linearization of a logarithmic unit.

In most cases MET/CAL uses built-in FSC-specific defaults to decide how to linearize a logarithmic quantity. However, there are two situations in which it is necessary to specify a LogLin value:

  1. When the context of the test requires a non-default linearization method. For example, 9640A-based tests in which the evaluation quantity units are dBm use dBm-to-watts linearization by default. In cases where dBm-to-volts linearization is required, it is necessary to include a "LogLin = V" specification in the test.
  2. When the test involves a user-configured reference and the system accuracy is specified using an ACC statement or direct VSET specification. In this case MET/CAL lacks built-in information to guide the linearization of dBm, thus making a procedure-level specification required.

Legal value for LogLin are:

V
Specifying "LogLin = V" instructs MET/CAL to linearize dBm to volts (rms).
You may also use the alternate forms "LogLin = volts" and "LogLin = Vrms". These are equivalent to "LogLin = V".
If you include a "LogLin = V" specification in a test, it may also be necessary to specify an impedance value (using the VSET/TESET IMPED parameter).
An IMPED specification is required if MET/CAL cannot determine the impedance based on an instrument setup statement in the test, and the default impedance (50 ohms) is not correct for the test.

If the units are dB, rather than dBm, MET/CAL converts voltage ratio to percentage using the formula

p = 100 * (10 ^ (d/20))

where "d" is the dB value, and "p" is the calculated equivalent percentage.

W
Specifying "LogLin = W" instructs MET/CAL to linearize dBm to watts.
You may also use the alternate form "LogLin = watts". This is equivalent to "LogLin = W".

If the units are dB, rather than dBm, MET/CAL converts power ratio to percentage using the formula

p = 100 * (10 ^ (d/10))

where "d" is the dB value, and "p" is the calculated equivalent percentage.

DV

Specifying "LogLin = DV" causes MET/CAL to linearize a voltage ratio delta specified in dB to percentage using the formula:

p = 100 * ((10 ^ (d/20)) - 1)

where "d" is the dB delta, and "p" is the calculated equivalent percentage change.

DW

Specifying "LogLin = DW" causes MET/CAL to linearize a power ratio delta specified in dB to percentage using the formula:

p = 100 * ((10 ^ (d/10)) - 1)

where "d" is the dB delta, and "p" is the calculated equivalent percentage change.

Example:

TSET LogLin = V

Compatibility: Requires V7.20b or later.

MATH_EPSILON

MATH_EPSILON specifies the epsilon factor used in MATH comparisons which involve relational operators. Any value between 1E-15 and 1E-5 is legal. The default value is 1E-13. As a special case, setting MATH_EPSILON to zero causes relational comparisons to be done using exact double-precision floating-point arithmetic.

The MATH_EPSILON parameter is not supported in V7.01 SP1 or earlier.

The epsilon factor affects numeric relational comparisons in the MATH FSC, as well as other FSCs which use the MATH expression parser (for example, IF, JMPL, WHILE...). Refer to the MATH FSC's Relational Operators and Floating-Point Comparisons section for more information.

MEAS

MEAS is a parameter which can be set to "SA" or "UI". The default is "UI" if MEAS is not specified. MEAS affects the measurement uncertainty calculation when the evaluation step is a MEMC or MEMCX statement in which a numeric NOMINAL value is not specified.

The problem which MEAS is designed to address is that for some MEMC or MEMCX evaluations it is not possible to determine from procedure information whether the UUT Indicated or the System Actual is the measurement. This ambiguity does not arise when a literal numeric value is specified in the MEMC NOMINAL field because, in that case, the UUT Indicated (NOMINAL) is a constant and the System Actual must be the measurement. Similarly, the ambiguity does not arise when a literal numeric value is specified in the MEMCX NOMINAL field because, in that case, the System Actual (NOMINAL) is a constant and the UUT Indicated must be the measurement. However, when there's no numeric MEMC or MEMCX NOMINAL, it can go either way.

In the case where the standard is a meter, the System Actual is the measurement (i.e., the System Actual is the parameter which can vary each time through the measurement uncertainty loop), and the System Actual is therefore the parameter which must be averaged, and must be used to calculate the standard deviation of the measurements.

On the other hand, if the standard is a source device, the system actual is the output (stimulus) of the source, and does not vary, so the measurement is the UUT Indicated value. These considerations apply both to manual procedures, as well as to procedures where the standard and/or UUT are remotely controlled using IEEE, IEEE2, SCPI, or PORT statements.

Compatibility: Requires V6.01 or later

Example:

VSET MEAS = SA

MEASURE_ONLY

MEASURE_ONLY is a parameter which can be set to "Yes" or "No". If MEASURE_ONLY is "Yes", MET/CAL meter drivers do not re-setup the meter on the 2nd and subsequent measurements of a sequence of measurements. This can speed up execution of certain meter-based procedures when NMEAS is greater than 1.

It is up to the metrologist and/or procedure writer to determine whether the increased speed compromises the measurement uncertainty calculation. Re-setting up the meter prior to each measurement will, if nothing else, slow down the procedure and may slightly increase the chance of seeing significant deviations from one measurement to the next.

There are two ways to specify MEASURE_ONLY:

  1. MET/CAL Configuration settings

    MEASURE_ONLY can be specified in the MET/CAL Configuration settings. Legal values are "yes" and "no".

    The MET/CAL Configuration settings, if any, applies to all executions of MET/CAL meter drivers when NMEAS is greater than 1 and the current measurement is not the first measurement in a sequence of measurements, unless overridden at the procedure level in a VSET statement.

  2. VSET Statement

    MEASURE_ONLY can be specified at the procedure level in a VSET statement.

    Example:

    VSET MEASURE_ONLY = Yes

    A VSET specification of MEASURE_ONLY overrides a MET/CAL Configuration setting, if any, and remains in effect for the duration of the procedure until changed or reset in a subsequent VSET statement.

MEASURE_ONLY defaults to "No".

MEMC_IRPT

MEMC_IRPT is a parameter which can be set to "Yes" to "No". If MEMC_IRPT is "Yes", instrument SETUP and NOMSET statements in MEMC and MEMCX tests are, by default, repeated on the second and subsequent pass through the test for the measurement uncertainty calculation.

If MEMC_IRPT is "No", instrument SETUP and NOMSET statements in MEMC and MEMCX tests are, by default, skipped on the second and subsequent pass through the test for the measurement uncertainty calculation.

MEMC_IRPT may be specified in the MET/CAL Configuration settings. A VSET specification of MEMC_IRPT overrides a MET/CAL Configuration setting.

If MEMC_IRPT is not specified in the MET/CAL Configuration settings or in the procedure, it defaults to "Yes". A "TARGET" or "TARGET -m" statement in a MEMC or MEMCX test overrides a MEMC_IRPT specification. It is critical for a procedure writer to understand that a test which has the structure:

1.001  HEAD         Stimulus Instrument Setup Statement
1.002  IEEE         ...
1.003  MEME
1.004  MEMC         Units w/o Numeric NOMINAL ...

must, for measurement uncertainty to work properly, re-execute the instrument setup statement prior to each measurement. Failure to meet this requirement, either by setting MEMC_IRPT to "No", or by inserting a TARGET or TARGET -m statement after X.001, causes the System Actual value to be incorrectly reported in the results.

The underlying problem is that the MEME statement interchanges MEM and MEM1 each time through the measurement uncertainty loop. Because of this the instrument setup statement must be allowed to re-establish the System Actual in register MEM1 at the beginning of each loop execution.

Compatibility: Requires V6.01 or later.

MFILE

MFILE, if set, specifies the name of the optional measurement uncertainty output file. The measurement uncertainty output file contains intermediate data used in the measurement uncertainty calculation. The file may be useful for understanding, validating, or trouble-shooting the calculation. There is a choice of formats for the output file. Refer to the description of the MFILE_FORMAT parameter below for an explanation of the file formats.

If the file name is a full path specification, the name is used as specified. If the file name is a partial path specification, or a simple file name (base name + extension), the name is taken to be relative the user data directory, if any, specified in the MET/CAL Configuration settings. If no user data directory is specified, the name is used as specified, even if it is not a full path specification. The user data directory can be specified using the User Data Folder MET/CAL Configuration Setting. If the name of the output file is changed during a procedure run, the currently open output file, if any, is closed, and the new file is opened.

Output can be enabled for selected tests by specifying a value for MFILE before the first test for which output is to be generated, and then resetting MFILE ("VSET MFILE=*") after the last test for which output is to be generated.

If the specified output file already exists, measurement uncertainty data are appended to it. MET/CAL will never delete or clear a measurement uncertainty output file.

If the measurement uncertainty calculation is not enabled, no data are written to the output file.

The output file, if any, is automatically closed at the termination of procedure execution.

Example:

1.001  ASK+           K
1.002  VSET         NMEAS = 5
1.003  VSET         MFILE = meas.txt
1.004  5700         1.00V          1%                                    2W

MFILE may be specified in the MET/CAL Configuration settings, if desired. If MFILE is specified in the MET/CAL Configuration settings, measurement uncertainty data for all procedure executions, for which the measurement uncertainty calculation is enabled, are written to the specified file. In this case a VSET MFILE specification in a procedure can redirect the data to a different file, but cannot turn off the output. Executing a "VSET MFILE = *" statement will cause output to revert to the file specified in the MET/CAL Configuration settings.

Compatibility: Requires V6.10 or later.

MFILE_FORMAT

MFILE_FORMAT specifies the format of the measurement uncertainty output file. There are four format choices:

  1. DELIM
  2. DELIM-Q
  3. DELIM-STD
  4. VERBOSE

The default is DELIM. However, a per-workstation default can be specified in the MET/CAL Configuration settings. If MFILE_FORMAT is specified in the MET/CAL Configuration settings, the specified value is used as the format unless overridden by a VSET specification at the procedure level.

DELIM Format
If MFILE_FORMAT is set to DELIM, the output file contains one line of separated data values for each test. Values which are not set in the calculation are left blank in the output file.
The first line of the file contains column headers which can be used to identify the data values.
The DELIM format is designed for importation into other programs (e.g., Microsoft Excel). It is not designed to be easy to read with a plain text editor. Columns will not necessarily line up from row to row, nor will they necessarily line up with the column headers.
In DELIM format the list separator and decimal separator are based on system locale settings. In the United States the list separator will typically be a comma and the decimal separator will typically be a period.
In Europe the decimal separator will typically be a comma, so a comma is not a good choice for the list separator when DELIM format is used. A semi-colon might make a good list separator in this case.
DELIM-Q Format
DELIM-Q format is the same as DELIM format except that all value, including column headers, are surrounded by double quotes.
When DELIM-Q is used, it may be possible to have the system locale list separator the same as the system local decimal separator. For example, the system could be configured so that the comma was used for both separators, and, in that case, programs like Microsoft Excel will still be able to read the file.
DELIM-STD Format
DELIM-STD format is the same as DELIM format except that the system locale settings are not used to determine the list separator and the decimal separator.
In DELIM-STD format the list separator is always a comma and the decimal separator is always a period.
DELIM-STD is identical to DELIM for a typical PC in the United States.
VERBOSE Format
If MFILE_FORMAT is set to VERBOSE, the output file contains one multi-line record for each test step.
The format of each line is name = value, where name is the parameter name and value is the numeric data value. Values which are not set in the calculation are shown as "N/A" in the output file.
The system locale information is used to determine the decimal separator. In all formats numeric values are shown with up to 10 significant digits.

In all formats the output file contains the following data items for each test:

  • Step Number
  • Welch-Statterthwaite Flag
  • Asset
  • Start Date, Start Time
  • UUT Indicated, System Actual
  • Expanded Uncertainty, Standard Uncertainty
  • Confidence
  • Coverage
  • F
  • System Accuracy
  • S1, S2
  • Standard Deviation
  • RSS
  • U1, U2, U3, U4, U5, U6, U7, U8, U9, U10
  • C1, C2, C3, C4, C5, C6, C7, C8, C9, C10
  • CS1, CS2
  • DF
  • DF1, DF2, DF3, DF4, DF5, DF6, DF7, DF8, DF9, DF10
  • DFS1, DFS2
  • UUT Resolution
  • NThrow, Number of Measurements
  • Value #1, Value #2, Value #n where n is the number of measurements.

In VERBOSE format, the output file also contains a timestamp for each record, as well as a blank line used to separate records.

The "Asset", "Start Date", and "Start Time" data items are available only in MET/CAL Runtime, not in MET/CAL Editor Debug Mode. In MET/CAL Runtime, the "Start Date" format is YYYY-MM-DD and the "Start Time" format is HH:MM:SS.

Example:

1.001  ASK+           K
1.002  VSET         NMEAS = 5
1.003  VSET         MFILE = meas.txt
1.004  VSET         MFILE_FORMAT = VERBOSE
1.005  5700         1.00V          1%                                    2W

Compatibility:

Requires V6.10 or later.

DF, DF1, ..., DF10, C1, ..., C10, and Welch-Satterthwaite Flag require V7.00b or later.

DFS1, DFS2, CS1, and CS2 require V7.01 or later.

N5532A-504, N5532A-518, N5532A-526, N5532A-550

These parameters are used to set the frequency cross-over points for the Agilent N5532A sensor modules. The parameters are used in conjunction with the N5531 FSC. Legal parameter values have the form:

lower bound - upper bound

where lower bound and upper bound are frequency values. The units specifier is a required part of the value specification.

Example:

VSET N5532A-504 = 100 kHz - 3 GHz

The bounds specified for any parameter must be within the physical limits of the sensor. The limits are:

N5532A-504 | 100 kHz - 4.2 GHz
N5532A-518 | 10 MHz - 18 GHz
N5532A-526 | 30 MHz - 26.5 GHz
N5532A-550 | 50 MHz - 50 GHz

The presence of one or more of these parameters in a procedure does not imply that the specified sensor is required by the procedure. The purpose of these parameters is to allow a procedure writer, when writing an N5531S-based procedure, to specify the frequency at which to automatically switch from one sensor module to another, in accordance with UUT or measurement uncertainty requirements. If the procedure specifies frequency ranges for two or more of the N5532A sensors, it is OK if the ranges overlap. However, if the workstation has configured two or more sensors for which the specified frequency ranges overlap, MET/CAL chooses the lower-numbered sensor to perform the test.

Example

Suppose the workstation has an N5531S and 3 sensor modules: N5532A-504, N5532A-518, and N5532A-526.

Suppose the procedure requires frequencies from 100 MHz to 10 GHz and includes the VSET statements:

VSET N5532A-504 = 100 kHz - 3 GHz

VSET N5532A-518 = 3 GHz - 10 GHz

VSET N5532A-526 = 3 GHz - 10 GHz

When the frequency exceeds 3 GHz, MET/CAL will automatically prompt the operator to disconnect the 504 and connect the 518. The procedure will make no use of the 526 because the 518 covers all required frequencies above 3 GHz.

These parameters may also be specified in the MET/CAL Configuration settings.

If no frequency range specification exists anywhere, MET/CAL uses the physical limits of the sensors to define the frequency cross-over points.

Example

Suppose the workstation has an N5531S, an N5532A-504, and a N5532A-518. If no N5532A or N5532A-518 exists in the procedure or MET/CAL Configuration setting, all tests which require a sensor module between 100 kHz and 4.2 GHz will use the 504. Tests above 4.2 GHz will use the 518.

Specifications of these parameters in the MET/CAL Configuration settings may not specify overlapping frequency ranges. In this respect, a MET/CAL Configuration setting is different from a VSET or TSET specification. The reason for the difference is that the MET/CAL Configuration setting is based on workstation requirements, whereas the procedure specification is based on UUT requirements.

Example:

Suppose the workstation has an N5531S, an N5532A-504, and a N5532A-518. If the system administrator decides that for all N5531S-based procedures which use the N5532A sensor modules, the system should switch from the 504 to the 518 for all tests above 3 GHz, the MET/CAL Configuration settings should be modified to include:

N5532A-504 = 100 kHz - 3 GHz

N5532A-518 = 3 GHz - 18 GHz

The design of the N5531 FSC and the N5532A sensor module VSET parameters allows procedures to be written which do not hard code the requirement for a particular sensor for particular tests. To make use of this capability, N5531-based procedures must be written to use automatic connection messages, and must not use the N5531 FSC in a way which requires a specific sensor module.

Compatibility: Requires V7.20 or later.

See Also:

  • N5531 FSC help topic
  • VSET SensorChange parameter

NMEAS

It is important to understand Settings Inheritance since NMEAS may be set in a variety of ways.

NMEAS specifies the number of measurements to take for the measurement uncertainty calculation. Legal values for NMEAS range from 0 to 1000. Setting NMEAS to zero disables the measurement uncertainty calculation.

The basic measurement uncertainty calculation is: Standard Uncertainty = RSS(U1, U2, U3, ..., U10)

where U2 is calculated as: U2 = RSS(S1, S2)

and where S1 is calculated as: S1 = (SDEV / (NMEAS ^ 0.5)) * F

In other words, S1 is based on the standard deviation of a series of measurements, where the number of measurements is specified using the NMEAS parameter.

Although it is legal to set NMEAS to 1, notice that this means that the standard deviation is, in effect, zero. This, in turn, means that U2 becomes just S2, and the entire 2nd uncertainty component is then based only on the UUT resolution. In general, it is therefore not a good idea to set NMEAS to 1. However, there may be some cases where it is acceptable to do so. One such case involves the pre-calculation of S1 or U2, which can then be directly specified at the procedure level.

A second case where setting NMEAS to 1 may be acceptable is when the accuracy of the standard is sufficiently greater than the resolution of the UUT so that any practical sequence of measurements is very likely to result in a standard deviation of zero (i.e., where all measurements are the same).

When NMEAS is set to a value greater than 1, MET/CAL automatically repeats each test step the specified number of times, unless the test step is incompatible with the measurement uncertainty calculation.

FSC parameters like the 3458 FSC's MOD 3 field specify the measurement mode, number of readings to discard, and number of readings to average. The MOD3 settings for number of readings to discard and average will be overridden by NMEAS and NTHROW settings when measurement uncertainty.

Incompatible test steps are:

  1. EVAL, DOSE, and PICE

    These are Go / No Go evaluations. There are no numerical measurements on which to base the uncertainty calculation.

  2. Tests where ASK+ K Not Set

    When an instrument evaluation step is performed, MET/CAL supports three distinct measurement modes:

    1. Keyboard Entry

      This is the only mode that supports measurement uncertainty calculation.

    2. Slewing

      Not compatible with the measurement uncertainty calculation because by slewing the calibrator until the UUT reading matches an expected value, one would produce a series of measurement (UUT readings) in which all values were the same. The standard deviation would therefore be zero, the calculated uncertainty would not be valid. A future version of MET/CAL may support slewing in the measurement uncertainty calculation by taking the standard deviation of the sequence of calibrator output values. In V6.0, however, this is not supported.

    3. Go / No Go

      Not compatible with the measurement uncertainty calculation for the same reason as the EVAL, DOSE, and PICE FSCs. There is no sequence of numerical measurements on which to base the standard deviation calculation.

  3. Tests where ASK+ U Not Set

    Although the Test Uncertainty Ratio (T.U.R.) calculation is not strictly dependent on the measurement uncertainty calculation, both calculations normally require that a MET/CAL accuracy file be accessed to determine the accuracy of the standard. Since, in the current implementation, clearing the ASK 'U' flag (ASK- U) disables access to accuracy files, it disables the measurement uncertainty calculation as well as the T.U.R. calculation.

    Note, however, than when ASK- U is in effect, the measurement will still be repeated the specified number of times, and the reported UUT Indicated value will be the average of the sequence of measurements. The measurement uncertainty will not be calculated, however, and MU_STD$, MU_EXP$, and MU_COV$ will be blank.

    As previously mentioned, when NMEAS is greater than 1, MET/CAL automatically repeats each test step the specified number of times, unless the test is incompatible with the measurement uncertainty calculation (see above). It is important to understand how MET/CAL determines which procedure statements to repeat when it automatically repeats a test step.

Rules

  1. If the procedure test contains a blank TARGET statement or a TARGET -m statement, the TARGET statement defines the sequence point for beginning the 2nd and subsequent repetitions of a test step.

  2. If the statement is a source (stimulus) or sensor (meter) instrument evaluation step, and there's no applicable TARGET statement in the test, only the instrument evaluation statement is repeated.

    Example:

    1.001  DISP         Please connect A to B.
1.002  5700         1V             1%                                    2W

    In this example the test consists of two procedure statements, When the measurement is automatically repeated, only the 5700 statement will be executed

  3. If the test step is a MEMC or MEMCX evaluation, and there's no applicable TARGET statement in the test, the repeat target is determined by scanning forward from the first statement of the test until one of the following statements is found:

    • IEEE, IEEE2, SCPI, or PORT
    • INSTR SENSOR SETUP or NOMSET
    • JMP, JMPF, JMPL, JMPT, or JMPZ
    • MATH
    • MEM*, MEM+, MEM-, or MEM/
    • MEM2 or MEMI

    This implies that the following statements are skipped over in the scan to find the repeat target for the measurement uncertainty calculation in a MEMC or MEMCX test:

    • ASK+/ASK-
    • CON
    • DISP
    • DRAW
    • HEAD
    • INSTR SRC SETUP or NOMSET
    • MESS
    • PIC
    • RNG
    • RSLT
    • SET
    • STD
    • TOL

The procedure writer must be aware of how MET/CAL automatically determines repeat targets for the measurement uncertainty calculation, and add TARGET or TARGET -m statements as needed if the automatic determination is not adequate for a particular test.

Examples

Standard VSET Statement:

VSET NMEAS = 5

Specifying 0 disables the measurement uncertainty calculation for all tests following this statement:

VSET NMEAS = 0

Reset any prior NMEAS specification:

VSET NMEAS = *

NOMCOR

NOMCOR is used to determine the correction lookup value used by MET/CAL for discrete resistance and conductance tests using a calibrator that stores internal corrections for resistance values.

The following FSCs are affected by NOMCOR:

  • 4000A
  • 4700
  • 4705
  • 4707
  • 4708
  • 4800
  • 4800A
  • 4805
  • 4808
  • 5450
  • 5700
  • 5720

Legal Values

NOMCOR = Yes

When NOMCOR is "Yes" MET/CAL uses the Nominal value of the test, rather than the System Actual value, as the correction lookup value when the test is a discrete resistance or conductance test using a calibrator that stores internal corrections for resistance values.

NOMCOR = No

When NOMCOR is "No" MET/CAL uses the System Actual value as the correction lookup value for a discrete resistance or conductance test with a calibrator that stores internal corrections for resistance values.

"No" is the default value of NOMCOR, so there's no reason to specify "NOMCOR = No" except to change a previous "NOMCOR = Yes" specification in the same procedure.

NOMCOR applies only when MET/CAL corrections are enabled (ASK+ C).

NOMCOR cannot be specified in the MET/CAL Configuration settings.

Compatibility: Requires V7.20B or later.

NSD

It is important to understand Settings Inheritance since NSD may be set in a variety of ways.

NSD is used to specify the number of significant digits in the reported values of the expanded uncertainty (EXP_UNC), the standard uncertainty (STD_UNC), and the coverage factor (COV_FAC).

The number of significant digits may be specified at any time during procedure execution using the VSET FSC. When the number of significant digits is specified in a VSET statement, the specification remains in effect until it is changed or reset using a subsequent VSET statement. The number of significant digits may also be specified on a per-workstation basis using the No. of Significant Digits MET/CAL Configuration setting. Lastly, the number of significant digits may also be specified on a per-site basis in the database. To do this start the "Metrology Database Customization and Configuration" application and choose "Uncertainty..." in the top-level "Configure" menu.

The default is 6 significant digits if no NSD specification exists. NSD allows the number of significant digits to be specified, but does not provide full formatting control of the uncertainty values. In V6.10 the measurement uncertainty values are always shown in base units, using scientific notation (E-format). The units are referenced to the NOMINAL units, but they are not shown with the uncertainty value. For example, if the NOMINAL value is specified in mV, the uncertainty values are reported in volts (not millivolts), and the units are not shown.

Compatibility: Requires V6.10 or later.

NTHROW

NTHROW specifies the number of measurements to be discarded before the sequence of measurements to be saved and used in the measurement uncertainty calculation. The NTHROW parameter setting has no effect if the measurement uncertainty calculation is not enabled. For example, a procedure includes:

VSET NMEAS = 0

VSET NTHROW = 1

will ignore the NTHROW specification.

In V6.00 and V6.01 NTHROW affects only MET/CAL's meter drivers. Corresponding FSCs are: 2000, 2001, 2002, 34401, 34420, 3458, 437, 45, 5335, 5790, 6666, 6680, 6681, 6685, 8505, 8506, 8560, 8566, 8568, 8590, 8842, 8901, 8902, 8903, 8920, HP60, HP63, and P700.

In V6.10 NTHROW applies to all evaluations.

Legal values for NTHROW are -1 to 100.

If NTHROW is -1, meter drivers are compatible with V5.1 and earlier. In some cases this means that the driver will take and discard some number of readings, possibly dependent on the value of the MOD3 field. Refer to on-line help for individual meter-type FSCs for details.

If NTHROW is 0, no readings are discarded.

There are two ways to specify NTHROW:

  1. MET/CAL Configuration setting

  2. VSET Statement NTHROW can be specified at the procedure level in a VSET statement.

    Example:

    VSET NTHROW = 3

The default value of NTHROW is -1. That is, if NTHROW is not specified, the meter drivers run in "compatibility mode".

NTHROW does not directly affect the measurement uncertainty calculation. However, to the extent that it is necessary to discard one or more initial meter readings in order to get a reliable reading, NTHROW certainly can affect the sequence of readings, and thereby change the standard deviation and affect the calculated measurement uncertainty.

PORT

PORT specifies the default COM port. The PORT parameter allows the procedure writer to override the normal default UUT COM port specification in the MET/CAL Configuration settings.

The normal default UUT COM port must be set to NONE for this parameter to function correctly.

The following values are legal:

  • COM1
  • COM2
  • COM3
  • COM4
  • COM5
  • COM6
  • COM7
  • COM8
  • COM9
  • COM10
  • COM11
  • COM12
  • COM13
  • COM14
  • COM15
  • COM16
  • COM5500
  • COM5502E
  • COM5502A
  • COM5520
  • COM5522
  • COM5800
  • COM5820

Compatibility: Requires V7.20C or later

REMCON

REMCON controls the "Please Remove All Connections..." message which appears after the termination of a calibration procedure. Legal values are "yes" and "no".

If REMCON is "yes", the "Please Remove All Connections..." message is displayed at the termination of procedure execution.

If REMCON is "no" the message is not displayed.

There are two ways to specify REMCON:

  1. MET/CAL Configuration settings

  2. VSET Statement

    Example:

    VSET REMCON = no

REMCON defaults to "yes".

Compatibility: Requires V6.11g or later.

RESETUUT

RESETUUT is used to control the RESET FSC-specified reset of the UUT in certain situations.

Legal Values:

RESETUUT = Yes
Causes a RESET FSC-specified UUT reset to be executed whenever the normal Post Test reset of instrument is performed.
"Yes" is the default value of "RESETUUT", so there's no reason to specify "RESETUUT = Yes" except to change a previous "RESETUUT = No" specification in the same procedure.
RESETUUT = No
Causes a RESET FSC-specified UUT reset to be inhibited in certain situations. In order for the reset to be inhibited the following conditions must apply:
  1. The Post Test window is not shown.
  2. The ASK 'N' flag is not set.
  3. The ASK 'R' flag is not set.
  4. The ASK 'Q' flag is not set.
  5. The ASK 'W' and/or ASK 'V' flags are set. The basic idea behind specifying "RESETUUT = No" is to allow a procedure to use MET/CAL's built-in automatic connection message, but nevertheless run with "ASK- Q" in effect. Normally, if automatic connection messages are enabled (using ASK+ W or ASK+ V), the effect of an "ASK- Q" specification is overridden.
This design is due to safety considerations. That is, MET/CAL should not prompt the operator to make or break connections, unless the instruments have been reset to a safe state. This basic design is not compromised by the "RESETUUT" parameter, because it does not affect system or user-configured reference instruments.

For example, if you write a procedure like this:

1.001  ASK+                                                              W
1.002  ASK-   R   Q N
1.003  5700         80.0V          1%                                    2W

MET/CAL will reset the Fluke 5700A to a safe state prior to generating an automatic prompt to disconnect the UUT from the 5700A. This will happen regardless of the value assigned to the RESETUUT parameter.

The intended use of the RESETUUT parameter is in cases where the UUT should be reset to a safe state at the end of a procedure, or perhaps at designated points in the procedure, but where there are multiple adjacent tests where the UUT must be left in operate from one test to the next. Below is an example of using the RESETUUT parameter:

1.001  ASK-   R   Q N              P                            A
1.002  RESET        STBY;*OPC?[10][I!]
1.003  VSET         RESETUUT = No
1.004  PORT         [T3000]OPER;*OPC?[10][I!]
1.005  EVAL   -e 1 :

2.001  PORT         [T3000]OPER?[10][I]

This example uses automatic connection messages (by default).

When the EVAL statement executes, MET/CAL would normally execute the RESET FSC-specified command. That's because, even though "ASK- Q" is specified, the use of automatic connection messages overrides the '-Q' flag.

However, in the example above, because "RESETUUT = No", MET/CAL will inhibit the execution of the RESET command when the EVAL statement executes.

RSM

RSM (Result Save Mode) controls the method MET/CAL uses to save repeated test results.

Legal Values

RSM = All
All executions of each test are saved in the database Results Table.
RSM = FirstLast
Only the first and last executions of each test are saved in the database Results Table.
RSM = Last
Only the last execution of each test is saved in the database Results Table.

Parameter Specification

There are two ways to specify RSM:

  1. MET/CAL Configuration settings

  2. VSET or TSET Statement

Legacy Results

RSM has no effect on the "Cal Results" database table. In the "Cal Results" database table the first and last executions of each test are saved. This is compatible with MET/CAL V6 and prior.

Test Results

RSM has no effect on the "Test Results" window in Run Time or Test Run.

Default Value

The default value for RSM is "FirstLast". The default applies when neither the MET/CAL Configuration settings, nor the procedure, specifies a value for RSM. Note that, by default, MET/CAL V7 is compatible with V6 and prior.

Recommended Usage

Although MET/CAL allows RSM to be specified at the procedure level (using a VSET statement), in general, the method for saving results should be established on a per-site or per-workstation basis.

MET/CAL V7.00 does not, however, support a per-site specification (for example, by allowing the mode to be specified in the database). Therefore, users who wish to change the default are advised to make the required change in the MET/CAL Configuration settings on each workstation.

Example

1.001  VSET         RSM = All
1.002  5700         1.00V          0.01%                                 2W
2.001  VSET         RSM = FirstLast
2.002  5700         1.00V          0.01%                                 2W
3.001  VSET         RSM = Last
3.002  5700         1.00V          0.01%                                 2W

The procedure fragment above contains 3 tests (evaluation steps): 1.002, 2.002, and 3.002. Assume the operator executes each evaluation step 3 times. All 3 executions of 1.002 will be saved in the Results Table. For 2.002, 2 executions, the first and the last, will be saved. For 3.002, only the last execution will be saved.

Compatibility: Requires V7.00 or later.

S1

The basic measurement uncertainty calculation is:

Standard Uncertainty = RSS(U1, U2, U3, ..., U10)

where U2 is calculated as U2 = RSS(S1, S2)

and where S1 is normally calculated as S1 = (SDEV / (NMEAS ^ 0.5)) * F

In other words, S1 is normally based on the standard deviation of a series of measurements, where the number of measurements is specified using the NMEAS parameter. However, it is possible to use a VSET statement override the normal calculation of S1 at the procedure level and directly assign its value.

Example:

VSET S1 = 0.1

To reset the overriding of S1, use the standard VSET reset convention:

VSET S1 = *

If a VSET statement is used to override the value of S1 for one or more tests, this removes any dependency on the number of measurements in the measurement uncertainty calculation for those tests. The procedure writer should, in that case, set NMEAS to 1, unless it is specifically expected that the UUT Indicated value be reported as an average of values rather than as a single measurement.

S2

The basic measurement uncertainty calculation is:

Standard Uncertainty = RSS(U1, U2, U3, ..., U10)

where U2 is calculated as U2 = RSS(S1, S2)

and where S2 is normally calculated as S2 = (UUT_RES * 0.5) / (3 ^ 0.5)

In other words, S2 is normally a function of the UUT resolution. However, it is possible to use a VSET statement override the normal calculation of S2 at the procedure level and directly assign its value.

Example:

VSET S2 = 0.05

To reset the overriding of S2, use the standard VSET reset convention:

VSET S2 = *

If a VSET statement is used to override the value of S2 for one or more tests, this removes any dependency on the UUT resolution in the measurement uncertainty calculation for those tests.

SensorChange

The SensorChange parameter allows the procedure writer to prevent MET/CAL from automatically changing sensor modules. SensorChange is used in conjunction with the N5531 FSC. By default, MET/CAL automatically prompts the operator to change sensor modules at the frequency cross-over points specified using the N5531A-504, N5531A-518, N5531A-526, and N5531A-550 parameters, or, in the absence of such a specification, at the frequency cross-over points defined by the physical limits of the Agilent N5531A-504, N5531A-518, N5531A-526, and N5531A-550 sensor modules.

Legal values for SensorChange are "Yes" and "No". The default, used when SensorChange is not specified, is "Yes". Parameter values are interpreted as follows:

Yes
Allow MET/CAL to automatically decide when to switch N5532A power sensors based on (a) configuration, (b) procedure frequency requirements, and (c) optional N5532A frequency bands specified in MET/CAL TSET statements, VSET statements, or the MET/CAL Configuration settings.
No
Inhibit MET/CAL's automatic sensor changing algorithm. If a single, configured sensor module covers all frequencies specified in the procedure, use that sensor for the entire procedure.

The advantage of setting SensorChange to "No" is that it may reduce the number of connections, thus speeding up procedure execution. The potential disadvantage is that it may increase measurement uncertainties at certain frequencies. This trade-off must be evaluated by the procedure writer and/or metrologist.

SensorChange cannot be specified in the MET/CAL Configuration settings.

Compatibility: Requires V7.20 or later.

See Also:

  1. VSET N5532A-504, N5531A-518, N5531A-526, N5531A-550
  2. N5531 FSC Help

SLEWSTART

SLEWSTART is used to specify the initially highlighted digit in the slew dialog when the dialog is invoked by a name/value instrument FSC which supports slewing. The specified digit must be between -11 and 11. Zero is legal but has no effect.

  • A positive value highlights a digit to the right of the decimal point.
  • A negative value highlights a digit to the left of the decimal point.

Compatibility: SLEWSTART requires V7.20 or later.

In the V7.20 release the only FSC which uses the SLEWSTART parameter is 9640.

Example:

TSET SLEWSTART = 3

The TSET specification above causes the 9640 slew dialog to highlight the 3rd digit to the right of the decimal point.

The SLEWSTART VSET/TSET parameter should not be confused with the "SlewStart" MATH FSC function. The "SlewStart" MATH FSC function is one of a group of MATH functions used to configure and invoke the MET/CAL slew dialog for use with a user-configured instrument.

SRQDELAY

SRQDELAY is used to specify the delay, in milliseconds, to be used in MET/CAL's wait-for-SRQ retry loop. The specified delay must be between 0 and 1000 milliseconds. The delay affects both IEEE statements which use an SRQ construction and the built-in wait-for-SRQ operation used in the IEEE2 and SCPI FSCs.

The specified delay has no effect unless SRQRETRY is used to specify a maximum number of retries which is greater than zero. In other words, the delay specified by SRQDELAY takes effect only in situations where MET/CAL is waiting for an SRQ, an SRQ is detected, but the waited-for device does not acknowledge the the SRQ when it is serial polled. The reason SRQRETRY must be at least one in order for SRQDELAY to be meaningful, is that if MET/CAL has not been instructed to retry the serial poll, there's no point in delaying after the initial serial poll.

The default for SRQDELAY is 0 (zero). That is, by default there's no delay in the serial poll retry loop.

It's also possible to specify SRQDELAY in the MET/CAL Configuration settings.

See Also: SRQHOLDOFF and SRQRETRY.

Compatibility: SRQDELAY requires V7.11p or later.

SRQHOLDOFF

SRQHOLDOFF is used to specify the delay, in milliseconds, to be used prior to the initial serial poll in MET/CAL's wait-for-SRQ operation. The specified delay must be between 0 and 1000 milliseconds. The holdoff delay affects both IEEE statements which use an SRQ construction and the built-in wait-for-SRQ operation used in the IEEE2 and SCPI FSCs.

The default for SRQHOLDOFF is 0 (zero). That is, by default there's no initial delay in the wait-for-SRQ serial poll. It's also possible to specify SRQHOLDOFF in the MET/CAL Configuration settings. Note, however, that the preferred method is to use VSET and/or TSET statements to specify SRQHOLDOFF on an as-needed basis. The vast majority of instruments do in fact acknowledge the service request when immediately serial polled after an SRQ has been detected. Therefore, specifying a non-zero value for SRQHOLDOFF in the MET/CAL Configuration settings would unnecessarily penalize all instruments. (Of course, if the delay is very small, it might not be noticed.)

See Also: SRQDELAY and SRQRETRY.

Compatibility: SRQHOLDOFF requires V7.11p or later.

SRQRETRY

SRQRETRY is used to specify the maximum number of serial poll retries in MET/CAL's wait-for-SRQ operation. SRQRETRY affects both IEEE statements which use an SRQ construction and the built-in wait-for-SRQ operation used in the IEEE2 and SCPI FSCs. The general approach used by MET/CAL when it waits for an SRQ is as follows:

  1. Wait (up to a specified timeout) for the system to detect an SRQ. Any SRQ terminates this operation.
  2. As soon as an SRQ has been detected, serial poll the the device from which the SRQ was expected. MET/CAL expects the device to respond, per the IEEE-488 standard, by returning a status byte in which the RQS bit is set.

Specifying an SRQRETRY value greater than zero instructs MET/CAL to retry step (2), as needed, up to SRQRETRY times. SRQRETRY must be between 0 and 100. The default value is zero. Retrying is useful only in cases where a device is slow to acknowledge the SRQ. It is not useful, however, if any of the following conditions occur:

  • An SRQ is detected from a device on a different IEEE-488 interface.
  • The waited-for device is not IEEE-488 compliant. I.e., the device generates and SRQ, but never acknowledges it by setting the RQS bit in the status byte.

SRQRETRY may also be specified in the MET/CAL Configuration settings.

See Also: SRQDELAY and SRQHOLDOFF.

Compatibility: SRQRETRY requires V7.11p or later.

STD_UNC

The basic measurement uncertainty calculation is:

STD_UNC = RSS(U1, U2, U3, ..., U10)

where STD_UNC is the standard uncertainty.

However, it is possible to use a VSET statement override the normal calculation of STD_UNC at the procedure level and directly assign its value.

Example:

VSET STD_UNC = 0.05

To reset the overriding of STD_UNC, use the standard VSET reset convention:

VSET STD_UNC = *

Overriding the normal calculation of STD_UNC is appropriate only where the procedure writer has externally determined the measurement uncertainty associated with a test. Directly specifying the value of the standard uncertainty in this way removes any dependency on the measured values, number of measurements, UUT resolution, confidence value, and Student's T distribution, for those tests. The only subsequent calculation performed using the specified standard uncertainty is:

EXP_UNC = STD_UNC * COV_FAC

where EXP_UNC is the Expanded Uncertainty, and

where COV_FAC is the Coverage Factor.

Refer to the descriptions of EXP_UNC and COV_FAC in this on-line help file for more information.

SYS_ACC

The basic measurement uncertainty calculation is:

Standard Uncertainty = RSS(U1, U2, U3, ..., U10)

where U1 is the Normalized System Accuracy, calculated as SYS_ACC / CONF

where SYS_ACC is the system accuracy and where CONF is the confidence.

System Accuracy is represented in absolute units (e.g., 0.1 V), and Confidence is expressed as a sigma value (e.g., 2.58 sigma).

Normally the System Accuracy is looked up in a MET/CAL accuracy file. The accuracy file used is typically selected automatically, based on the instrument (the calibration standard), and the calibration interval specified for the particular configured standard in use. (The ACCF FSC can be used to force the use of a particular accuracy file.)

However, it is possible to use a VSET statement override the normal determination of SYS_ACC at the procedure level and directly assign its value.

Example:

VSET SYS_ACC = 0.01

To reset the overriding of SYS_ACC, use the standard VSET reset convention:

VSET SYS_ACC = *

It is important to understand that using a VSET statement to override the determination of the system accuracy does not affect the T.U.R. calculation, which is still based on the accuracy file lookup. An alternative approach, which can be used in closed-loop, MEMC or MEMCX-based tests, is to use the ACC FSC to directly specify the system accuracy in a way which affects both the T.U.R. and the measurement uncertainty. Using VSET to specify the System Accuracy is particularly useful in cases where MET/CAL's built-in accuracy file lookup is not adequate to determine the accuracy of a standard.

For example, counter accuracies typically cannot be represented as:

(percentage of NOMINAL) + floor

The procedure writer may wish to directly specify the system accuracy in these cases in order to allow the measurement uncertainty calculation to proceed.

TDESC

TDESC specifies the Test Description. The default value of Test Description is a string constructed by appending MOD1 to the Cardinal Point of the test, with an intervening "at sign" ('@'). (That is, by default, Test Description is similar to the V6 Legacy Results variable FN$.) The MOD1 part of Test Description is always taken from the evaluation statement of the test, never from a preceding instrument setup or ACC statement.

To override the default, Test Description may be directly specified using a VSET or TSET statement in a procedure.

Example:

TSET TDESC = 1.00 mV, 10 kHz, square

In V6 Legacy Results, FN$ would have the value "1.00mV @ 10kHz".

The specified Test Description is written to the database, where it is available for use in calibration reports.

TSTEP

TSTEP allows a procedure writer to override MET/CAL's Test Step 2 result quantity. Test Step 2 is a field in the Results Table in the database. By default, Test Step 2 contains the test step number in a form compatible with "legacy results".(Legacy results are pre-V7.00 results.) The Test Step 2 field in the Results Table is mostly equivalent to TN$ in legacy results.

Default values for Test Step 2 contain (up to) the last 2 components of the test step. Minor step numbers are not included in Test Step 2. Each major step number is zero-padded to 4 characters on the left.

Examples of Test Step 2 values generated (by default) are:

Example 1: 0005

Example 2: 0015-0004

The V7 Results Table also contains a field named "Test Step" that contains the full test step number from the procedure (including both major and minor step numbers, and showing all subprocedure levels back to the main procedure).

Test Step 2 is therefore not needed in most cases, and may safely be overridden.

The TSTEP parameter allows the procedure writer to associate an arbitrary tag (a string up to 16 characters) with a procedure step. The intent of TSTEP is to provide a mechanism to manually associate a unique tag with a particular test in a procedure. The tag may then be used for "data mining" purposes in the future, to analyze accumulated result data stored in the MET/CAL database. The problem with using Test Step or Test Step 2 for data mining is if that intervening changes to the procedure are made that add, delete, or re-order the tests in the procedure, MET/CAL regenerates the procedure's step numbers. That makes the MET/CAL-generated test step number an unreliable lookup key. In other words, the same test number in the Results Table may refer to a different test from one calibration record to the next.

For example, consider a procedure with 2 tests:

Test 1: 1 V

Test 2: 10 V

If a decision is made to add a new test between Test 1 and Test 2:

Test 1: 1 V

Test 2: 5 V

Test 3: 10 V

then extracting data for Test 2 from the Results Table will extract data for the 10 V test before the procedure change, but will extract data for the 5 V test after the change. The other approach to this problem is to extract data from the Results Table based on test parameters. However, this is often problematic because not all test parameters are recorded in the Results Table.

For example, MET/CAL does not automatically record whether a test is a 2-wire test, or a 4-wire test, nor does it record the waveform (sine, square, ...), and so on.

By using TSTEP an organization may assign a unique tag to a test in order to avoid the limitations described above.

Here's a simple (not-too-realistic) example:

1.001  TSET         TSTEP = 1VDC_4W
1.002  5700         1.000V         1%                                    4W
2.001  TSET         TSTEP = 5VDC_4W
2.002  5700         5.000V         1%                                    4W
3.001  TSET         TSTEP = 10VDC_4W
3.002  5700         10.000V        1%                                    4W

Compatibility: Requires V7.20B or later.

TOL_REF

Legal values for TOL_REF are "SYSTEM_ACTUAL", "NOMINAL", and "UUT_INDICATED". TOL_REF is normally specified on a per-workstation basis in the MET/CAL Configuration settings. However, it is possible to use a VSET or TSET statement to override the MET/CAL Configuration setting of TOL_REF.

Example:

VSET TOL_REF = SYSTEM_ACTUAL

To reset the overriding of TOL_REF, use the standard VSET reset convention:

VSET TOL_REF = *

The TOL_REF parameter specifies the reference value for the calculation of the test tolerance. The TOL_REF setting has no effect unless the TOLERANCE field specifies the test tolerance as a percentage or PPM value. The following calculated quantities are affected by the TOL_REF setting:

  1. Test Tolerance

    If TOL_REF is set to SYSTEM_ACTUAL, the test tolerance is calculated with respect to the reference value of the test. The reference value is the same as the result quantity referred to as "System Actual" by MET/CAL.

    In most tests SYSTEM_ACTUAL and NOMINAL refer to the same value. However, there are cases where the values are different. Examples are tests where a correction is applied, where slewing is used to adjust the value of the reference, and where an instrument internally uses a reference value different from the Nominal value of the test (such as fixed ohms in a Fluke 5700A). If TOL_REF is set to NOMINAL, the test tolerance is calculated with respect to the Nominal value.

    If TOL_REF is set to UUT_INDICATED, the test tolerance is calculated with respect to the UUT Indicated value.

    Example:

    Suppose you have a MET/CAL test like:

    1.001  ASK+           K
1.002  5500         10V            1%                                    2W

    Suppose also that the UUT (a meter) reads 10.1V.

    If TOL_REF is SYSTEM_ACTUAL the test tolerance is +/- 0.1 V, because 0.1V is 1% of 10 V.

    (However, if a correction were to applied to the 5500A output, using MET/CAL's built-in correction mechanism, the test tolerance would be +/- 1% of the corrected output value.)

    If TOL_REF is NOMINAL the test tolerance is +/- 0.1 V, because 0.1 V is 1% of 10 V.

    If TOL_REF is UUT_INDICATED the test tolerance is +/- 0.101, because 0.101 is 1% of 10.1 V.

  2. Test Uncertainty Ratio (T.U.R.)

    The test tolerance is the numerator of the T.U.R., so changing the test tolerance calculation changes the T.U.R.

  3. Error

    Except in some special cases (like dBm in the NOMINAL field), MET/CAL displays the error for a particular test as a percentage.

    If TOL_REF is SYSTEM_ACTUAL, the error is displayed as a percentage of the System Actual value.

    If TOL_REF is NOMINAL, the error is displayed as a percentage of the Nominal value.

    If TOL_REF is UUT_INDICATED, the error is displayed as a percentage of the UUT Indicated value.

  4. Error % Tol

    MET/CAL calculates the error for a test as the difference between the System Actual and the UUT Indicated. It then displays the error as a percentage of the test tolerance. Since the test tolerance is affected by the TOL_REF setting, as described above, the error expressed as a percentage of the test tolerance is also affected by TOL_REF.

Compatibility:

In MET/CAL V7.20 and later the recommended setting for TOL_REF is SYSTEM_ACTUAL. TOL_REF = NOMINAL is non-preferred, but is correct if tests are written in such a way that the Nominal value is the same as the System Actual. That implies that neither slewing nor corrections are in use. TOL_REF = UUT_INDICATED is not recommended.

UCONF

UCONF specifies the confidence associated with the UUT's specification. This parameter was introduced first in MET/CAL V7.10. It is used only in connection with guardbanding. The measurement uncertainty calculation makes no use of UCONF. UCONF is used when the guardband method is NTUR. It is used to normalize the UUT spec, which is the numerator of the NTUR. (The denominator is the standard measurement uncertainty, i.e., the 1-sigma value.) MET/CAL uses 2.0 as the default UCONF value.

UFMT

UFMT is used to specify the formatting of uncertainty-related, dimensioned values. There are 4 legal values for the UFMT parameter:

SCI
Uncertainty-related dimensioned values are formatted in scientific notation. SCI is the default, and is the way the formatting was always done prior to V7.20.
ENGR (deprecated in MET/CAL version 8)
Uncertainty-related dimensioned values are formatted in "engineering format". This means that the format is E-format, the exponent is an integer multiple of 3, and the mantissa is greater than or equal to 1.0 and strictly less than 1000.0.
PREFIX
PREFIX is a variant of ENGR. The difference is that instead of showing the number in E-format, the format is fixed point, and the exponent is replaced by an SI units prefix.

For example, if the value in ENGR format is:

12.3e-003 V

then the value in PREFIX format will be:

12.3 mV

NOM
NOM format forces the value to have the same prefix as the Nominal value of the test.

For example, given a procedure statement like:

5700 1.000mV 1%

then setting UFMT = NOM will force all uncertainty-related dimensioned values to be formatted in mV.

Procedure writers and report writers must be aware that this may result in the loss of significant digits. For example, suppose the Nominal is specified in kV, and the uncertainty is 1 mV. This means that the uncertainty is 0.000001 kV. If the number of significant digits (NSD) is set to 2, then the uncertainty will appears as 0.00 kV in the Results Table.

Procedure writers and report writers should be aware that all supported formats except SCI have the potential of inherent ambiguity with respect to the number of signficant digits. For example, using the PREFIX format, if a reported uncertainty value is "100 mV" it's not possible, without knowing the value of NSD, to know if the zeros are signficant. There are 3 possible interpretations:

  1. The value has been rounded to the nearest 100, and neither zero is significant.
  2. The value has been rounded to the nearest 10, the first zero is significant but the 2nd zero is not.
  3. The value has been rounded to the nearest 1, and both zeros are significant.

Limitations:

UFMT applies only to values written to the Results Table.

  1. It does not affect legacy results (the CalResults table).
  2. It does not affect the Standard Uncertainty displayed in the Post Test window.
  3. It does not affect values written to a file specified using the MFILE VSET parameter.

Compatibility: UFMT requires V7.20 or later.

U1

The basic measurement uncertainty calculation is: Standard Uncertainty = RSS(U1, U2, U3, ..., U10)

where U1 is the Normalized System Accuracy, calculated as:

SYS_ACC / CONF

where SYS_ACC is the system accuracy and where CONF is the confidence. However, it is possible to use a VSET statement to override the normal determination of U1 and directly assign its value.

Example:

VSET U1 = 0.03

To reset the overriding of U1, use the standard VSET reset convention:

VSET U1 = *

When U1 is directly specified in a VSET statement the calculated measurement uncertainty no longer depends on the System Accuracy or Confidence, both of which are usually based on accuracy file lookup.

U2

The basic measurement uncertainty calculation is: Standard Uncertainty = RSS(U1, U2, U3, ..., U10)

where U2 is calculated as: U2 = RSS(S1, S2)

and where S1 is normally calculated as: S1 = (SDEV / (NMEAS ^ 0.5)) * F

and where S2 is normally calculated as: S2 = (UUT_RES * 0.5) / (3 ^ 0.5)

However, it is possible to use a VSET statement to override the normal determination of U2 and directly assign its value.

Example:

VSET U2 = 0.016

To reset the overriding of U2, use the standard VSET reset convention:

VSET U2 = *

When U2 is directly specified in a VSET statement the calculated measurement uncertainty no longer depends on the measured values, the number of measurements, the Student's T distribution, or the UUT resolution.

Directly specifying U2 is appropriate in cases where the procedure writer or metrologist has determined that MET/CAL should calculate measurement uncertainty using the usual RSS (root sum square) calculation, including the normalized system accuracy component, and, possibly, optional uncertainty components U3, U4, ..., U10, but where the usual (empirical) determination of uncertainty component U2 based on the standard deviation of the measured values and the resolution of the UUT (Unit Under Test) is incorrect or inappropriate.

U3, U4, U5, U6, U7, U8, U9, and U10

The basic measurement uncertainty calculation is: STD_UNC = RSS(U1, U2, U3, ..., U10)

where STD_UNC is the Standard Uncertainty, and where U3, U4, ..., U10 are optional uncertainty components which can be directly specified to augment the measurement uncertainty calculation. Each value must be specified at 1 sigma.

U3, U4, ..., U10 can be directly specified using a VSET statement. The default value for each of these components is zero. Thus, in the absence of a VSET statement to assign non-zero values to one or more of these optional uncertainty components, they make no contribution to the RSS (root sum square) calculation, and therefore no contribution to the measurement uncertainty.

Recall also that the Expanded Uncertainty is calculated as: EXP_UNC = STD_UNC * COV_FAC. Thus, a specification of U3, U4, ..., and/or U10 affects both the Standard Uncertainty (STD_UNC) and the Expanded Uncertainty (EXP_UNC).

Example:

VSET U3 = 0.1

To reset the VSET specification of an optional uncertainty component use, for example:

VSET U3 = *

It is up to the metrologist or procedure writer to decide when it is appropriate to assign values to the optional uncertainty components U1, U2, U3, ..., U10. In general, these optional uncertainty components are intended for Type B uncertainties. These uncertainties are not directly based on the sequence of measured values, the accuracy of the main calibration standard, or the resolution of the UUT, because those uncertainty components are incorporated in U1 and U2, which are, typically, automatically calculated by MET/CAL. As stated in ANSI/NCSL Z540-2-1997, information used to determine Type B uncertainties includes:

  • previous measurement data
  • knowledge of relevant behavior and properties of materials and instruments
  • manufacturer's specifications
  • calibration certificates
  • uncertainties assigned to reference data taken from handbooks

In practice, sources of additional, optional uncertainty components may include:

  • test leads
  • terminators
  • attenuators
  • power splitters
  • thermocouples
  • other signal conditioners
  • environmental factors (temperature, humidity)

In some cases it may be appropriate to leave all optional uncertainty components unassigned (i.e., set to zero). For example, if you are using a Fluke 5720 to calibrate a Fluke 10 DMM, the resolution of the UUT may well dominate the measurement uncertainty calculation, and any uncertainty contribution from, say, test leads, will probably be negligible. On the other hand, if you are using, for example, an HP 3458A to measure a precision resistor, uncertainty due to test leads and temperature fluctuations in the lab may be important.

U2M

It is important to understand Settings Inheritance since U2M may be set in a variety of ways.

U2M specifies the method used to calculate the U2 uncertainty component. Legal values are "RSS" and "SINGLE".

U2 is the uncertainty component which directly expresses the uncertainty associated with the unit under test (UUT). There are two source of uncertainty which relate directly to the UUT.

First, there is the standard deviation of the measurements. The standard deviation is non-zero only if two or more measurements were taken, and not all measurements are the same. MET/CAL uses the uncertainty sub-components S1 to express the uncertainty due to the standard deviation of the readings.

Recall that:

S1 = (SDEV / (NMEAS ^ 0.5)) * F

The second uncertainty sub-component related to the UUT is the uncertainty associated with the resolution of the UUT. This is sub-component called S2. Recall that, by default:

S2 = (UUT_RES * 0.5) / (3 ^ 0.5)

Method 1: U2M = RSS

When the specified method is "RSS", U2 is calculated as:

U2 = RSS(S1, S2)

Method 2: U2M = SINGLE

When the specified method is "SINGLE", U2 is equal to either S1 or S2. If the standard deviation of the measurements is non-zero, U2 is set to S1. Otherwise, when the standard deviation is zero, U2 is set to S2. In other words, when U2M is "SINGLE":

IF (SDEV > 0)

U2 = S1

ELSE

U2 = S2

MET/CAL V6 always used the "RSS" method, because the U2M parameter did not exist, and there was no option. In MET/CAL V7, the procedure writer may specify either "RSS" or "SINGLE". The default is "RSS".

Example:

VSET U2M = SINGLE

USE_ST

The USE_ST parameter is used to enable or disable the use of the Student's T distribution to determine the factor F used in the measurement uncertainty calculation. Legal values for USE_ST are "Yes" and "No". The basic measurement uncertainty calculation is: Standard Uncertainty = RSS(U1, U2, U3, ..., U10)

where U2 = RSS(S1, S2)

and where S1 = (SDEV / (NMEAS ^ 0.5)) * F

Recall that F is a factor based on the Student's T distribution and the number of degrees of freedom. (In MET/CAL's uncertainty calculation the simplifying assumption is made that the number of degrees of freedom is one less than number of measurements.) When USE_ST is set to "Yes", the factor F is determined, unless overridden or disabled, per Table G.2 of Annex G of the document ANSI/NCSL Z540-2-1997. The values of F used by MET/CAL are exactly half the values shown in the 95.45% column of Table G.2.

When USE_ST is set to "No", the factor F is set to 1.0, so the calculation of S1 becomes simply:

S1 = (SDEV / (NMEAS ^ 0.5))

By default (as distributed) MET/CAL V6.0 sets USE_ST to "No". In other words, the factor F is set to 1 and it is presumed that the Coverage Factor (COV_FAC), typically set to 2, and used to determine the Expanded Uncertainty based on the Standard Uncertainty, is sufficient to incorporate the confidence in the standard deviation of the measured values as a function of the number of measurements. When NMEAS is 10 or more, F is close to 1 in any case, and so this presumption would appear to be justified. For small NMEAS values, on the other hand, the Student's

T-based F value can be significant (for example, F is 6.985 when NMEAS is 2), and the decision as to whether it's appropriate to set F to 1 unconditionally or not has to be based on the judgement of the metrologist. Based on comments from various European and American sources, it was determined that the best approach for MET/CAL is to provide the option and allow each site to decide how to implement this aspect of the uncertainty calculation.

There are three ways to set USE_ST:

  1. Database

    As shipped, USE_ST is set to "No" in the V6.0 database. That is, the use of the Student's T-based factor F in the uncertainty calculation is, by default, not enabled.

  2. MET/CAL Configuration settings

  3. VSET Statement

    For example:

    VSET USE_ST = yes

    To reset a VSET specification of USE_ST specify:

    VSET USE_ST = *

USE_ST is non-preferred in version 7. USE_ST is supported in MET/CAL version 7 or later, for compatibility with MET/CAL version 6. It is recommended that USE_ST be set to "No" when using MET/CAL 7 or later.

UUT_RES

The basic measurement uncertainty calculation is:

Standard Uncertainty = RSS(U1, U2, U3, ..., U10) where U2 is calculated as:

U2 = RSS(S1, S2) and where S1 is normally calculated as:

S1 = (SDEV / (NMEAS ^ 0.5)) * F and where S2 is normally calculated as:

S2 = (UUT_RES * 0.5) / (3 ^ 0.5)

Unless overridden, MET/CAL attempts to infer the UUT's resolution based on information in the procedure. (Actually, MET/CAL has always done this, but prior to V6.0 the inferred information was used only to control the formatting of certain result variables.) In V6.0, the resolution is needed to determine the measurement uncertainty.

If the automatically determined UUT resolution is incorrect or inadequate, the procedure writer can directly specify the UUT resolution in a VSET statement.

For example:

VSET UUT_RES = .0001

The UUT resolution is expressed in absolute units (Volts, Amps, etc.)

To reset the overriding of UUT_RES, use the standard VSET reset convention:

VSET UUT_RES = *

The following description explains how MET/CAL attempts to infer the UUT resolution based on procedure information. Procedure writers should attempt to understand what happens, because in some cases it may be necessary to override the automatic determination of the UUT resolution in order ensure correctness of the measurement uncertainty calculation.

  1. If the test evaluation step is an instrument FSC statement:

    1. If the NOMINAL value is specified in the procedure statement:

      The UUT resolution is based on the specified NOMINAL value.

    2. If the NOMINAL value is taken from MEM:

      • If the test tolerance is specified in absolute units ('U') and there are 1 or more digits to the right of the decimal point, the UUT resolution is based on the specified test tolerance.
      • If the test tolerance is not specified in absolute units ('U') or there no digits to the right of the decimal point, an attempt is made to guess the UUT resolution based on the NOMINAL value. The algorithm involves formatting the NOMINAL value with up to 10 significant digits, and then counting the number of digits to the right of the decimal point.

  2. If the test evaluation step is a MEMC or MEMCX statement:

    1. If the MEMC or MEMCX statement specifies a literal numeric value in the NOMINAL field, the UUT resolution is based on the number of digits to the right of the decimal point in the MEMC or MEMCX NOMINAL value.
    2. Otherwise, if the test contains a prior ACC statement, and T.U.R. checking is enabled, and there's a literal numeric value in the ACC NOMINAL field, the UUT resolution is based on the number of digits to the right of the decimal point in the ACC NOMINAL value.
    3. Otherwise, if the test contains a prior instrument setup statement, and T.U.R. checking is enabled, and there's a literal numeric value in the NOMINAL field of the setup statement, the UUT resolution is based on the number of digits to the right of the decimal point in the setup statement's NOMINAL value.
    4. Otherwise, if the MEMC or MEMCX TOLERANCE field specifies a tolerance in absolute units ('U'), and there are one or more digits to the right of the decimal point, the UUT resolution is based on the number of digits to the right of the decimal point in the tolerance field specification.
    5. Otherwise, an attempt is made to guess the resolution of the UUT based on the NOMINAL value. The algorithm involves formatting the NOMINAL value with up to 10 significant digits, and then counting the number of digits to the right of the decimal point. In this case the NOMINAL value is determined as follows:
      • If there's a prior ACC statement in the test and T.U.R. checking is enabled, use the ACC NOMINAL value.
      • Otherwise, if there's a prior instrument setup statement in the test, and T.U.R. checking is enabled, use the setup NOMINAL value.
      • Otherwise, use the system actual value, which, since the current statement is a MEMC or MEMCX statement, is just the value in memory register MEM at the time of the MEMC or MEMCX statement's execution.

WS

WS is a flag parameter used to enable or disable the Welch-Satterthwaite mode for the measurement uncertainty calculation.

Legal values for WS are 1 (or "Yes") and 0 (or "No"). When enabled, the Welch-Satterthwaite formula is used to approximate the effective degrees of freedom. The effective degrees of freedom, together with a specified confidence (KCONF), is then used to determine the coverage factor. The coverage factor is looked up in a t-distribution table. The t-distribution table used in MET/CAL is taken from "Guidelines on the Evaluation and Expression of Measurement Uncertainty", SAC-SINGLAS TECHNICAL GUIDE 1, 2nd Edition, March 2001.

If the calculated value for the effective degrees of freedom is not in the t-distribution table, MET/CAL linearly interpolates the t-distribution value at the specified output confidence. If the effective degrees of freedom value is greater than 100, but not infinity, the value for 100 is used. When Welch-Satterthwaite mode is enabled, the coverage factor used to calculate expanded uncertainty from standard uncertainty is based on the t-distribution table referred to above, unless overridden at the procedure or MET/CAL Configuration settings level by a direct specification of COV_FAC. Note that the database specification of the coverage factor is ignored when WS is set to "Yes" (or "1").

For a detailed explanation of the Welch-Satterthwaite formula, refer to page 15 of SAC-SINGLAS TECHNICAL GUIDE 1, 2nd Edition. You may also wish to refer to http://www.itl.nist.gov/div898/handbook/mpc/section5/mpc571.htm for information on the Welch-Satterthwaite formula. USE_ST, which controls whether or not the t-distribution-based factor F should be used to calculate S1, should be set to "No" (the default) when Welch-Satterthwaite mode is enabled.

Units

All VSET specifications are in base units. Many of the quantities which can be specified in a VSET statement refer to quantities with physical units (voltage, current, frequency, etc.). A VSET specification of a dimensioned quantity is always taken to be a base units specification, with the units determined by reference to a corresponding instrument setup or evaluation statement.

Example:

1.001  VSET         U3 = 0.001
1.002  5700         10mV           0.1%                                  2W

In this example, the optional uncertainty component, U3, is set to 0.001 V. Note that U3 is not 0.001 mV, even though the NOMINAL field in the 5700 statement specifies mV.

dBm Specifications are Linearized

For tests where the UUT indicates a value specified in dBm or where the standard is programmed or specified in dBm, MET/CAL linearizes all dBm values by converting to RMS Volts before calculating the uncertainty.

All VSET specifications which apply to dBm tests must be in Vrms.

Example:

1.001  VSET         NMEAS = 5
1.002  VSET         U3 = 0.0025
1.003  5700         10D            0.1%          10kH                    2W

The 5 dBm measurements are converted to Vrms before the mean and standard deviation are calculated. The optional uncertainty component U3 is taken to be a Vrms specification, even though the units of the evaluation quantity are dBm ("D").

For dBm tests, the reported average value and reported uncertainty are converted back to dBm, but the internal calculations are done in terms of RMS voltage.

Measurement Uncertainty Hints

To enable the measurement uncertainty calculation in V6.0, the following requirement must be satisfied:

  1. Number of Measurements

    2. The number of measurements must be set to a number greater than or equal to 1. For example:

    VSET NMEAS = 5

  2. ASK+ K

    Measurement uncertainty is not calculated unless the ASK 'K' flag is set.

  3. Reference Accuracy

    Measurement uncertainty is not calculated unless reference accuracy is established.

  4. Reporting Measurement Uncertainty

    V7 Results

    The V7 Results Table includes many measurement uncertainty-related values:

    • Degrees of Freedom
    • Degrees of Freedom 1, 2, ..., 10
    • Expanded Uncertainty
    • Number of Measurements
    • Nthrow
    • Sensitivity 1, 2, 3, ..., 10
    • Standard Deviation
    • Standard Uncertainty
    • Student's T Factor
    • Student's T Flag
    • System Accuracy
    • System Coverage Factor
    • S1
    • S2
    • Uncertainty Component 1, 2, 3, ..., 10
    • Welch-Satterthwaite Flag

    In addition, the database includes the raw measurement values. For example, if NMEAS is 10, there are 10 individual measurements which make up the reported average measurement and which are used to determine the standard deviation. The 10 measurements are stored in the database.

    V6 Legacy Results

    In V6 Legacy Results, the measurement uncertainty variables which can be written to results are:

    • MU_STD$ - standard uncertainty
    • MU_EXP$ - expanded uncertainty
    • MU_COV$ - coverage factor

    To write one or more of these quantities to the formatted result line (C2501) you must modify the "rslt_db.frm" (default name) format file. For example, TU$ (the T.U.R.) could be replaced by "MU_EXP$". This would also require a change to the column header in the Crystal Reports report file. The standard uncertainty is also shown in the Post Test dialog when that dialog appears. The measurement uncertainty is not shown in the Test Results window.

  5. Using the MEMC FSC Measurement uncertainty can be calculated for tests which perform MEMC evaluations, however:

    1. If the MEMC test contains a MEME statement to swap the values of register MEM and MEM1, do not place a TARGET or TARGET -m statement after the statements which set up the standard. Otherwise, incorrect values of System Actual and/or UUT Indicated will be reported, and the calculated measurement uncertainty will be incorrect.
    2. For some MEMC tests it is necessary to tell the system which quantity is the measurement quantity. This is done by specifying "MEAS = SA" or "MEAS = UI". Refer to the description of the VSET MEAS parameter for additional information. Remember that VSET parameter values persist for the duration of procedure execution until changed or reset. For this reason, it may be better to use TSET to specify MEAS.

Using the Datron 4950

In most respects the Datron 4950 functions like any other supported system instrument. However, since the 4950 is designed to internally take a sequence of measurements and return to the user the mean of the measurements and the standard error, MET/CAL handles the 4950 as a special case. When the number of measurements (NMEAS) is set to 1, and when the 4950 is in a mode in which the sample size is greater than 1, MET/CAL uses the standard error calculated by the 4950 as the basis for the determination of the standard deviation.

The calculation is:

Standard Deviation = Standard Error * (N ^ 0.5) where N is the sample size. Note that this operation is different from the normal operation when NMEAS is 1. Normally, when NMEAS is 1, no standard deviation is determined, which causes S1 to be zero, which in turn causes U2 to be based only on the UUT's resolution.

It remains possible, even with the Datron 4950, for the procedure writer to override the default calculation. For example, if the procedure includes a VSET statement which directly specifies the value of S1, MET/CAL will no longer use the Standard Error calculated by the 4950, even if NMEAS is set to 1 and the 4950 sample size is greater than 1.

Setting NMEAS to any value greater than 1 disables the built-in use of the standard error calculated by the 4950. For example, suppose NMEAS is 5 and the 4950 is in high accuracy DCI mode. The sample size is 32, and the 4950 calculates the standard error, but MET/CAL will make no use of the calculated standard error in the measurement uncertainty calculation. Rather, in this case, MET/CAL will simply calculate the standard deviation of 5 readings (each of which is really based on 32 internal readings).

If the 4950 is used in a mode in which the sample size is 1 (for example, low accuracy ACV), the procedure writer should set the number of measurements to a value greater than 1 in order to include in the measurement uncertainty calculation the standard deviation of a sequence of measurements.

For additional information refer to the "Sample Size and Resolution" table on page 6-17 of the "Wavetek Model 4950 Multifunction Transfer Standard Instrument User's Handbook" (December 1998).


How to Access MET/SUPPORT

Fluke Calibration Metrology Software is supported by a highly skilled and conscientious team of professionals who are available to answer questions, help solve unique problems, and assist in troubleshooting in the event you run into difficulties. Click here to register.


Telephone Support

Some free telephone support is available, but only to registered users of Fluke Calibration software. Be sure to register your software as soon as possible so you can make use of this service should the need arise. Within the United States, toll free telephone support is available from 8:00 AM to 4:30 PM, Pacific Standard Time at +1 (800) 825-7411.

Priority support is available to any current MET/SUPPORT Gold Support customer. A special-access line is included in the Gold program information pamphlet. To call Fluke Calibration from anywhere in the world, call +1 (425) 446-5400.


Mail, E-mail, and FAX Support

Contact Fluke Calibration Support by mail, E-mail, and FAX:

FLUKE Corporation

P.O. Box 9090

Attention: MET/SUPPORT, M/S 275G

Everett, WA 98206-9090

E-mail: softwaresupport@flukecal.com

FAX: +1 (425) 446-5992


Before You Call Technical Support

You may be able to discover the answer for yourself, so take the steps that follow before you call for support:

  • Check the manual
  • Check the online help

If you do find it necessary to call for assistance, take a few moments to jot down some information. If this information is readily available, the support person can more quickly get to the exact details of the difficulty and will be able to resolve the issue more efficiently.

  • Product name, applicable licenses, version and serial numbers
  • Manual title, part number and version
  • Operating system and version
  • Network information if applicable
  • List of steps necessary to recreate the problem
  • Version of Crystal Reports


Worldwide Support

For more information on worldwide MET/SUPPORT™, please contact the Fluke Calibration office nearest you (Table 1) or your local representative.

Contact List

Location | Phone | Fax
Canada | 1-905-890-7600 | 1-905-890-6866
China | 86-10-6-512-3435 | 86-10-6-516-3437
UK/Europe | 44 1603-256600 | 44-1603-256688
Japan | 81-3-3434-0181 | 81-3-3434-0170
Singapore | 65-276-5161 | 65-276-5759
United States | 1-800-825-7411 | 1-425-446-5992
All other locations | 1-425-446-6476 | 1-425-446-5992

Web Support

Fluke Calibration provides a website exclusively for the Metrology Software user. This site provides the most current phone numbers, downloadable procedures, reports, application notes, and other pertinent information. To access this support site:

  1. Enter http://support.fluke.com/register in your browser's URL address input box.
  2. Enter met-support in the "Name of the Site where you want to go:" box.
  3. Click Register.
  4. Complete the registration questionnaire.

Approval of your registration should be complete within one or two days. You will receive an email notice of your Web/Support user name, password and the Web/Support site address.


Software Operation

Refer to the MET/TEAM help system for details on the features and functions available in MET/TEAM. This help system refers to specific MET/TEAM setup details only as it pertains to MET/CAL. See the Quick Start topic for an overview of the required MET/TEAM setup steps to run a MET/CAL procedure.

When MET/TEAM is installed according to the client/server (network)or stand-alone model, the installation program creates a "Fluke\METCAL\Shared" directory in the "All Users" directory structure.

The Shared directory must be sharable by all clients. In a network installation, the directory is on a designated drive on the server. All of the client workstations on the network use the executable programs and other files stored in this shared directory. Which files are accessed depends on the applications chosen during the client installation. However, all users must have the ability to read from and write to the Metcal directory to ensure access to applications. In a stand-alone installation the Metcal directory is installed on a designated hard drive. The directory is usually not shared because the stand-alone system probably has a single user.


Database Communication

In network installations, MET/CAL Runtime communicates with MET/TEAM using a standardized web request protocol and does not directly communicate with the SQL Server database. Communicating directly with the MET/TEAM website ensures that consistent validation rules are applied to database updates. Field customization and Data Checks defined in MET/TEAM are automatically used by MET/CAL Runtime prompts and results updates.


User Profiles

Fluke Calibration Software is designed for several different types of users: Users are added and removed from the database by using the MET/TEAM Setup, User option. At some sites, one person may perform all the functions. At other sites tasks may be divided among separate individuals or groups.

A MET/TEAM user must be associated with the MET/CAL Run Procedures group in order to run a MET/CAL procedure. Associate the user with other groups to give the user rights to edit and delete procedures and to alter the MET/CAL instrument configuration.

  • MET/CAL Edit Procedures: Provides user permissions to create new procedures and edit existing procedures in the MET/CAL MET/CAL Editor.
  • MET/CAL Run Procedures: Provides user permissions to run a compiled procedure or a procedure executable (pxe) in the MET/CAL Runtime.
  • MET/CAL Delete Procedures: Provides user permissions to delete existing MET/CAL procedures using the procedure editor.
  • MET/CAL Configure Run Time Instruments: Provides user permissions to change the instrument configuration.


You are here: Asset Management > Special Rules for Customization > Special Rules for Customization

Special Rules for Customization

© 2015 Fluke Corporation


You are here: Asset Management > System Customization Using the Set Up Menu > System Customization Using the Set Up Menu

System Customization Using the Set Up Menu

© 2015 Fluke Corporation


Report Introduction

A fundamental reason for collecting information in a database is so you can retrieve it later and view trends and patterns within the data. Fluke MET/BASE applications give you a number of ways to see your data, from viewing it on the display to printing out multi-page reports.

Crystal Reports software enables you to design report templates (.rpt files) for Fluke Calibration Software. The MET/TEAM server and MET/CAL client installations include the supported Run Time files. Several report templates are distributed with the installation. Use them as-is or customize them.

Fluke Calibration Software is supplied with a series of Sample Reports that support the general usage philosophy of the product. It is impossible for Fluke to provide reports that will satisfy every situation. Therefore, the sample reports are provided as examples that you can modify as your requirements dictate. If these reports are used unmodified, as supplied by Fluke, it is your responsibility to verify that they provide the output that your circumstances require. They were created and can be modified with Crystal Reports Professional, which is supplied with the base software package.

Fluke Calibration Software comes with several calibration reports. These reports are designed to satisfy the needs of a typical calibration laboratory. You can easily accomplish minor changes by editing one of the supplied reports.

All reports must reside on the server in the appropriate folder in order to be available to MET/TEAM. Refer to the MET/TEAM documentation for details on the reporting directory structure.


Database Table Structures

Fluke Metrology software uses a relational database consisting of many tables interrelated by key fields. The software uses some of the tables internally, and you should rarely, if ever, need to access them. The primary tables for producing reports on assets are as follows:

mt.customers | Information about your customers.
mt.inventory | Information about your assets.
mt.calibration | Latest and historical information about all Calibration events.
mt.calresults | Step by step test results for Calibration events.
mt.standards | All of the standards used to perform calibrations.
mt.location | The place where the asset is currently located
mt.repair | Historical information about an asset’s Maintenance events.

How to Interpret the Table Structure

One of the sample reports included in the shared MET/CAL directory is called TBLDEFS.RPT. This report gives a complete definition of all of the tables used in MET/CAL. Print this report and have it handy when creating a report from scratch as it has the field descriptions for all of the tables you will be using. If you perform any customization, this report will show the customization you have done.

The report does not describe all the tables in the database. The database engine uses system tables, and the software itself creates and maintains a number of tables for its own internal uses. Even of the tables shown, only some fields will be of interest to you. However, for effective report writing, you need some basic information about the position of fields, their contents, and some customization information.

For example, assume that you wanted to produce the report that you just printed, showing the current system customization. By looking at the table structure, you can see the Customization table contains the kind of information that such a report might contain. By knowing such things as the maximum possible length the field, you can format your report to present the data clearly.

The Customization table contains information about field-level customization. The column names represent a particular field attribute (not a number.) Attributes define each field; the Customization table stores the present settings. Actually, the database uses some preset field attributes (e.g., FLDNUM for field number and DATALEN for data length). You can only make changes to the attributes via the customization interface.

The center column of each table has a short description of the intended use for the field. The description may be an actual field title or a few words to relay the idea behind including the field on the form. The last column gives the data type and byte size of the field. The data types are Character, Date, DOUBle, INTeger, and TimeStamp. Date fields contain only month, day, and year, while the TS field adds hour, minute, and second.

The arrows show the internal linkages within the relational database. Two fields (CTAG and MTAG) carry linking information. The links are not customizable, and you cannot affect their action externally. The software maintains the links automatically.

Stored Procedures

A number of stored procedures are provided as a part of the Fluke Calibration Software package. You can find the input and output parameters of these stored procedures by running the report PROCPARM.RPT. This will generate the tables as they exist when the product is shipped. Not all of the reports supplied with Fluke Metrology software access the base tables directly. Instead, a technique has been developed to run a "stored procedure." Stored procedures run within the database. They scan the base tables for information, and return this information to the report writer program for formatting and printing.

A stored procedure is a series of SQL commands stored in the database. There are several reasons for storing such a series of commands in the database. Following are the most important benefits from using this approach:

  • First, the stored procedure runs in the database itself, so network traffic is significantly reduced. After it executes, the stored procedure returns only the requested data to the client. This makes the stored procedure run much faster than the equivalent request coming from a report searching the base tables. It also uses the network bandwidth much more efficiently.
  • Secondly, the stored procedure pre-processes the information, so the amount of data returned is only a subset of the entire body of information contained in the Calibration database. As a consequence, the sorting and grouping done by the report is minimized, resulting in speedier, more efficient operation.
  • Finally, Crystal Reports does not perform multiple SELECT statements, so if you need multiple records from more than one tables in the database, the best solution is to use a stored procedure.

Fluke provides the following stored procedures with the software.

mc_assets | Provides information for a specific asset.
mc_cal_due | Provides a list of instruments due for calibration.
mc_cal_loc_due | Provides a list of instruments due for calibration with location included.
mc_cal_loc_due_range | Provides a list of instruments due for calibration with location included based on a start and end date.
mcctagresult | Used primarily for MET/CAL Runtime calibration reports. Uses ctag to identify a particular cal event.
mcresult | Prompts for asset number, start date, end date. Returns information about one or more cal events.
mccalresult | Gets inventory, cal summary, stds, and results for a CTAG.
mcctagresloc | Used primarily for MET/CAL Runtime calibration reports with location information. Uses ctag to identify a particular cal event.
mccalresloc | Gets inv, cal summary, stds, results and loc for a CTAG.
mcltag | Gets location info for an ltag.
mcmtag | Gets inventory for an mtag.
mcktag | Gets customer info for a ktag.
mcrtag | Gets maintenance info for an rtag.
mcltaginventory | Gets location and inventory info for an ltag.
mcrtaginventory | Gets maintenance and inventory info for an rtag.
mcmtagcustomer | Gets inventory and customer for an mtag.
rep_tech | Returns information about repair events based on repair tech and start and end date.
rep_asset | Returns information about repair events based on asset number based on start and end date.
mcktaginventory | Gets inventory and customer info for a ktag. (multiple rows)

How to Interpret the Results Structures

The supplied report PROCPARM.RPT illustrates the structures of the results information returned by the stored procedures. You will need this information if you wish to use a stored procedure to filter and supply needed information.

After customization, it might be appropriate for you to run PROCPARM.RPT to generate a corrected version of the information.

MET/CAL Runtime reports can be set up to run automatically upon completion of a Calibration Procedure. Those reports that are based on the MCCALRESULT stored procedure automatically supply the ctag value, since MET/CAL Runtime has just assigned it.

When a report is designed for use only as a MET/CAL Runtime report, it takes one argument (the ctag that the Calibration Procedure has just assigned). If you wish to run a MET/CAL Runtime report later (as if it were a General report), it will ask for an asset number and a calibration event. This is the only time a MET/CAL Runtime report prompts for information, and prompting for the asset number and calibration event is an automatic function in this case.

Another Fluke-supplied stored procedure, MCResult, takes three arguments: the asset number of interest, and a beginning and ending date. This procedure is intended to be used for General Reports, because only through the report prompting mechanism can the dates be supplied to the procedure.


Implement Measurement Uncertainty in a MET/CAL Procedure

Before implementing measurement uncertainty in a MET/CAL procedure, there are a few topics which must be understood and their relationship to measurement uncertainty must be considered:

  • Abstraction
  • Requirements
  • Inheritance

This topic will also reveal tips an tricks, common pitfalls, and some advanced concepts for measurement uncertainty calculation in MET/CAL.

Abstraction

Abstraction is a technique for managing the complexity of computer systems. It works by establishing a level of complexity on which a person interacts with the system, suppressing the more complex details below the current level.

For example, this simple two line MET/CAL procedure will perform several tasks on our behalf:

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
  1.001  ASK+           K
  1.002  5520   10    10.00A         1%            50H            SI HC    2W

  1. At runtime, MET/CAL looks up the configured System Instrument's (e.g. Fluke 5520A) asset number in the database to verify it is in calibration, and to obtain relevant calibration and identification information.

  2. The asset number can be part of the instrument configuration, or if the asset number is left blank, the MET/CAL Runtime application will prompt the user for input.

  3. An identification query (*IDN?) is sent to the device which returns its Manufacturer, Model, Serial Number, and Firmware revision.

  4. The serial number is parsed out and compared with the serial number from the database to ensure that the unit on the bus is the correct unit configured.

  5. The FSC, MOD3, and CON field values determine the test setup.

  6. The RANGE, NOMINAL, and MOD1 field values determine the UUT Range and Function settings.

  7. The 5520A outputs 10 Amps at 50 Hz Sine on the 20A output.

  8. Stability and Error indicators are monitored to ensure a stable output.

  9. The operator is prompted to enter the UUT reading (per ASK+ K):

  10. The 5520A is set to Standby for a safe state.

  11. The UUT reading is evaluated against the tolerance limits.

  12. A pass / fail decision is made based on the given criteria.

How does abstraction relate to measurement uncertainty?

  • We need to understand how MET/CAL computes uncertainty
  • We need to know how the values are derived
  • We need to know how to control the values
  • We need to know how to verify the final result

Expanded Measurement Uncertainty

Where k is the coverage factor and uc is the combined standard uncertainty.

Combined Standard Uncertainty

Normalized System Uncertainty

u1 = System Accuracy / Confidence

u2 =

Requirements

To enable measurement uncertainty calculation in a MET/CAL procedure, these minimum requirements must be met:

  • ASK+ K
  • NMEAS > 0
  • Must establish Reference Accuracy (Instrument FSC, ACC FSC, VSET)
  • Cannot use ASK- U

Recommendations:

  • Define and use an MFILE, at least for the procedure debugging and verification process:

    2.001 VSET MFILE = My_MFILE.csv

    MFILE data will be appended to an existing file. If you leave this parameter enabled in a published procedure, a very large file may be generated.

  • The procedure author should control all uncertainty variables (see Inheritance below).
  • Utilize the Editor’s Accuracy Trace Mode for an inside view of MET/CAL accuracy abstractions.
  • Know the process/procedure and uncertainties before automating.

Inheritance

Uncertainty parameters used by MET/CAL's uncertainty engine may be defined in multiple locations: database, MET/CAL Configuration settings, other measurement uncertainty or guardbanding initialization files, and within the procedure using the VSET/TSET FSCs. These settings are applied using a defined hierarchy where the procedure's parameters take highest priority and override any settings defined previously.

To prevent unexpected results caused by parameters defined at the database, settings, or other levels, it is highly recommended that procedure writers control uncertainty parameters at the procedure level using the VSET/TSET FSCs. Failure to do so may produce unexpected results, as shown in this comparison of three different methods and their expanded uncertainties:

 |  | Default | Student T | WS
Combined Standard Uncertainty | Uc | 12.16E+3 | 16.90E+3 | 12.16E+3
Effective Degrees of Freedom | Veff |  |  | 5.2
Coverage Factor | k | 2.00 | 2.00 | 2.63
Expanded Uncertainty |  | 24.32E-3 | 33.8E-3 | 31.95E-3

Examples

Single test point using a Fluke 5520A

  1.001  ASK+           K
  1.002  VSET         MFILE = MFILE.csv
  1.003  VSET         TOL_REF = SYSTEM_ACTUAL
  1.004  VSET         NSD = 2
  1.005  VSET         COV_FAC = 2
  1.006  VSET         USE_ST = NO
  1.007  VSET         WS = NO
  1.008  VSET         KCONF = 2sigma
  1.009  VSET         NMEAS = 5
  1.010  VSET         NTHROW = 0
  1.011  5520   10    10.00A         1.2% 0.02U    50H            SI HC    2W

Sample 11 SAC Technical Guide 1, Second Edition, March 2001

An electronic weighing machine with a scale of range, 0 to 60 kg and resolutions of 0.01 kg was calibrated by direct comparison method, using a set of OIML class M2 standard weight.

Prior to calibration, the weighing machine was adjusted at full load using a standard weight according to the manufacturer procedure. The repeatability of the weighing machine was determined at near zero, half-full load, full load and the pool standard deviation was obtained. Normally the scale reading of the weighing machine would be calibrated by placing standard weights on the receptor in increasing increments of about 10% of the full capacity. In this example the measurement uncertainty for the weighing machine is calculated at the full-applied load.

During the calibration, when the 60 kg standard weight applied on the weighing machine it indicated 59.99 kg

Uncertainty Budget Table
Source of Uncertainty | Symbol (xi) | Type | Uncertainty Value | Probability Distribution | Coverage Factor | Standard Uncertainty u(xi) | Sensitivity coefficient (ci) | |ci| x u(xi) | Degrees of freedom (v)
Standard weight from calibration | Mc | B | 1.8 g | Normal | 2 | 0.9 g | 1 | 0.9 g | inf.
Standard weight drift | Md | B | 0.3 g | Rectangular | SQRT(3) | 0.173 g | 1 | 0.173 g | inf.
Resolution of scale reading | Eres | B | 5 g | Rectangular | SQRT(3) | 2.9 g | 1 | 2.9 g | inf.
Air buoyancy effect on scale reading | Eb | B | 0.55 g | Rectangular | SQRT(3) | 0.318 g | 1 | 0.318 g | inf.
Repeatability of scale reading | Erep | A | 10 g | - | - | 10 g | 1 | 10 g | 27

# Set the System Accuracy based on the calibration of the weights
  1.001  TSET         SYS_ACC = 1.8; CONF = 2; DF1 = 200
  1.002  TSET         S1 = 10; DFS1 = 27

# Override default resolution
  1.003  MATH         Resolution = 5 / SQRT(3)
  1.004  TSET         S2 = [V Resolution]; DFS2 = 200

# Set U3 to normalized uncertainty for air buoyancy
  1.005  MATH         Air_Buoyancy = 0.55 / SQRT(3)
  1.006  TSET         U3 = [V Air_Buoyancy]; DF3 = 200

# Set U4 to normalized uncertainty for drift of the weights
  1.007  MATH         Drift = 0.3 / SQRT(3)
  1.008  TSET         U4 = [V Drift]; DF4 = 200

# UUT indicated 59.99 kg with 60 kg applied.
  1.009  MATH         MEM = 59.99
  1.010  MEMCX        60.00kg        1%


Glossary

Accuracy File
An Accuracy File contains information about the accuracy specification of an instrument associated with an FSC. Unless TUR checking is disabled, there must be one Accuracy File associated with each instrument FSC that is being used in a calibration procedure.
As Found/As Left
As Found/As Left represents a calibration philosophy about how calibration is performed. MET/BASE supports three basic philosophies. Which philosophy you choose determines how the Found/Left field (2308) is used.
ASK Flags
Procedure flags that affect automatic operation and/or messages when the procedure executes.
asset
A single piece of equipment; each asset is numbered, and the number is used for identifying the asset throughout the database.
backend data
Any data residing on a server.
backup
It is important to make regular backups of your database files in case of media failure. A backup is a copy of the database file (mtrack.db) and may also include a copy of the transaction log file (mtrack.log). You can make backups using the SQL Anywhere backup utility or other archiving software of your choice.
Build
A build operation applies to projects in the MET/CAL Procedure Editor. The build process compiles all procedures in a project and verifies that all dependencies are valid. Projects are automatically built before debugging or creating a package.
client
The term client is widely-used to mean several different things. Without modification, it may mean for example, "client application", or "client workstation". Just as with the term "server", the word requires modification, otherwise if may be ambiguous whether it refers to a program or to the computer on which the program is running.
client application
An application that executes on the workstation and interacts with the user.
client computer, client workstation
A computer that accesses shared network resources provided by another computer (called a server). Also referred to as a workstation or client machine.
client/server
A term generally applied to a software architecture in which processing functions are segmented into independent collections of services and requesters on a single machine or segmented among several machines.
client/server computing
A mode of distributed network computing in which an application is executed cooperatively by two computers. The client application (the front end) executes on a workstation, while the data engine (the back end or data server) runs on a second computer.
COM
Acronym for the Component Object Model. This is a software to software communication mechanism that alows one program to dynamically interact with another. Not to be confused to COM Port.
COM Port
Serial communications port on a host PC or instrument. Serial interfaces are also referred to as RS232 ports.
confirm password
Passwords never display, so when you get a new password, you must type it twice. This is a safety measure, and it helps you to remember the new password.
copy data
A configurable attribute of a field that specifies whether the data in the field is to be copied forward to the next record to simplify data entry. For example, when first setting up a system, you might set field 4202 (manufacturer) to copy forward while you key in all the assets made by a particular manufacturer.
Correction File
A file that contains information on special calibration points of the instrument associated with the instrument FSC. Specific calibration points can be used to reduce the uncertainty for a shortened calibration period.
CTAG
A unique field in the database that serves to link a calibration event to test results generated during the event and to the standards used. Also see mtag and rtag.
customization
The process of selecting operating parameters and defaults to personalize the system for a particular site. For example, the default name of a field may not be the same words as you generally use, so field titles can be changed (customized) to something more familiar to the personnel at the site.
data server
Also called a database server; a computer for storing programs and data shared by users on a network. A database server provides database intelligence such as transaction processing, indexing, transaction logging and security, while a file server offers operating system-type file and print capabilities.
Database Administrator
The database administrator is a person responsible for maintaining the database. The database administrator is generally responsible for all changes to customization, for managing users and their access levels, and for backing up the database. Also see System Administrator.
database engine
Software such as SQL Serveror Sybase SQL Anywhere Server that provides highperformance database access to requests for data. Part of the server software package.
default data
A configurable attribute of a field that specifies what text is to appear in the field when the form is opened.
directory
A computer term denoting a subdivision of media that can contain other directories or files. Also called a folder.
field types
Represents the data type of a field in the database. Fields are one of the following types: Decimal, Integer, Alphanumeric, Date, Time, Boolean.
file server
A computer for storing programs and data shared by users on a network. A file server offers operating system-type file and print capabilities, while a database server provide database intelligence such as transaction processing, indexing, logging and security. Also see server, client.
focus
In working with forms and tables, a field is said to have focus if it is currently the field that can be edited, or have information placed into it. Focus is always on one of the fields of a form, and there is usually some visual indication of the field having the focus.
folder
A computer term denoting a subdivision of media that can contain other folders or files. Also called a directory.
forward traceability
The term refers to the ability of a calibration laboratory to trace an instrument's calibration credibility back to a national, recognized, legal standard.
FSC
Function Selection Code, a keyword in the MET/CAL procedure language. The FSC instructs the Run Time system to perform a task requested by a procedure. For example, the 5700 FSC instructs the system to provide a stimulus output from the Fluke 5700A Calibrator.
GPIB
General Purpose Interface Bus is the acronym for this type of interface. The IEEE consortium adopted this interface as a standard that is now referred to as IEEE-488.
history
A database contains information about an asset that changes over time. There is only one Inventory record per asset, but there may be any number of history records. The three types of history records are the Calibration, Location, and Maintenance (Repair).
IEEE-488
A parallel communications interface commonly used to control instruments from a desktop computer. MET/CAL supports National Instruments IEEE-488 interfaces. This interface type is also referred to as GPIB.
import
In a general sense, the word "import" means to bring something from one environment into the current environment. Used in relation to Fluke Metrology Software, the word refers to the process and the specific steps one
initial data entry
Initial access or initial data entry refers to the first time that the Inventory data is entered (a new asset), or the first time that Calibration, Location, or Repair data is entered (the first calibration).
length
The horizontal dimension. In MET/CAL and MET/TRACK forms, the number of characters that a value can contain.
License
A software license is the proof of your agreement with Fluke regarding your proper use of our Software.
linked validation
Feature allowing multiple fields to be entered simultaneously. Validation data is associated with a base field and is entered into the linked fields automatically. In the customization editor, the validation entry is the name of the base field. Linked fields are indicated by the name of the base field, a colon, and the number of the column from which data is to be taken.
Local Area Network (LAN)
Two or more computers connected to a network that is limited to an area such as a single office building and does not extend across public rights-of-way.
Manual Standard
A standard is a configured instrument with no remote interface. Standards are specified in a MET/CAL procedure using the STD Function Selection Code.
migration
Migrating data is similar to importing it, but with significant differences. Importing data implies bringing it from a source other than Fluke Metrology Software. On the other hand, migrating data just means bringing in data from a DOS or Legacy version of MET/CAL or MET/TRACK.
MTAG
A special field in the database that serves to link tables to one another so that all the information about a particular calibration event can be retrieved. The mtag links an asset to the Calibration, Location, and History tables. Any time a new asset is added to the Inventory table, the software automatically assigns a new mtag link. Also see ctag and rtag.
network driver
A network driver is the software logically located between the operating system and the network card, which allows applications to communicate to the network card.
network operating system
An operating system optimized for server deployment, such as Microsoft Windows NT Server Edition. Typically used on the file server and/or data server.An operating system optimized for server deployment, such as Microsoft Windows NT Server Edition.
normal data entry
Normal access or normal data entry occurs any time the Inventory data is changed, or any time (after the first time) the operator accesses Calibration, Location, or Repair data.
NULL
The NULL value is a special value for a database entry, different from any other valid value for any data type. The NULL value represents missing or inapplicable information.
ODBC driver
A dynamic link library (DLL) used to connect a specific Open Database Connectivitydata source with a client application.
ODBC driver manager
Provides the interface from the host language to the specific back-end data source driver.
old password
Changing a password requires you to know the original password. This is a security measure to protect the data that you put into the system. If you have forgotten your password, you cannot get a new one using this menu. You must have a new password assigned by your Administrator.
Open Database Connectivity (ODBC)
The Open Database Connectivity (ODBC) interface, defined by Microsoft Corporation, is a standard interface to database management systems in the Windows and Windows NT environments.
operator access level
A number in the range 0 - 5 that designates the tasks the operator is authorized to perform. There must be at least one level 5 operator. This level has full permissions to customize the system, set up other operators, assign their permission levels, and so on.
password
A word or set of characters that confirms your identity. The password is never displayed or printed for anyone.
pkm
Procedure package file that contains one or more procedures and dependent files. The file is intended for distribution of procedures.
primary device
A primary device is a configured system instrument controlled directly via the IEEE-488 bus or serial port. There is a corresponding Function Selection Code in the MET/CAL procedure language that is used to control the device. For example, the 5500 Function Selection Code is used to control the Fluke 5500A.
proc.dir
Active MET/CAL compiled procedure directory. The location of this file and corresponding procedure folder is maintained by the procdir parameter in the metcal.ini file.
Project
A container for all procedure and support files required to execute a calibration procedure.
purge
To delete an asset from the database. Only level 4 and 5 operators can purge assets. When purged, the entire history of the asset is removed. Standards cannot be purged. Purging is done on the Inventory form.
pxe
Procedure executable file used by the MET/CAL Run Time. A pxe is a self contained file that typically includes all dependencies to execute a procedure. A pxe cannot be altered after it is created. A new pxe must be created using the procedure source code.
query
Commonly, a formalized instruction to a database to either return a set of records or perform a specified action on a set of records as specified in the query. Also, the name of one of the MET/BASE applications, so called because it provides an interface for users to seek information from the database.
replication
For databases, a process by which the changes to data in one database (including creation, updating, and deletion of records) are also applied to the corresponding records in other databases.
reverse traceability
To trace those instruments that a subject instrument calibrated directly, or indirectly. Also see traceability and forward traceability.
RTAG
A special field in the database that serves to links a maintenance event to the results generated during the event and to the standards used. The rtag is the unique identifier that the software assigns to each maintenance or repair event. Also see ctag and mtag.
secondary device
A secondary device is a system instrument controlled by a primary device. Secondary devices are not connected directly to the IEEE-488 bus or to a serial port. MET/CAL controls secondary devices only by way of the associated primary device.
segregate
A subdivision of the database that permits restricting user access to a particular subset of data.
server
The term server is widely used to mean several different things. Whenever the word "server" is used without modification in this help system, it means the system designed to share data with client applications; servers and clients are often connected over a network.
Solution Explorer
The window within the procedure editor that lists all files that are actively open. Multiple projects and individual files accessible int he Solution Explorer.
SQL Server
A relational database management system that is capable of supporting hundreds of simultaneous users, depending on your application and hardware environment.
Standard (1) (Measurement Standard)
An object, artifact, instrument, system, or experiment that stores, embodies, or otherwise provides a physical quantity that serves as the basis for measurements of that quantity. For example, If we are calibrating a Fluke 87 (the UUT) in the RunTime, a standard could be a Fluke 5700. See forward traceability.
Standard (2) (Paper Standard or Protocol)
A document that describes the operations and processes that must be performed in order for a particular end to be achieved. In Europe, the term "protocol" is preferred to avoid confusion with a physical (measurement) standard. For example, ISO Guide 25 describes the requirements for a calibration laboratory.
standard security
Uses SQL Server’s own login validation process for all connections. To log into a SQL Server, each user must provide a valid login ID and password.
Stored Procedure (SP)
Stored procedures are programs kept in the database itself. They can be called from client applications. Stored procedures provide a way of providing uniform access to important functions automatically, as the procedure is held in the database, not in each client application.
Structured Query Language (SQL)
A database query and programming language. SQL is commonly pronounced “sequel” and was originally developed for IBM mainframe computers. There is an ANSI-standard for SQL.
System Administrator
The system administrator (SA) is the person responsible for the administrative and operational functions that are independent of any particular application, and is likely to be a person with a comprehensive overview of the environment. Not to be confused with the Database Administrator.
system instrument
A system instrument is an instrument that is directly supported by MET/CAL. A system instrument is either a primary device or a secondary device.
table
The basic unit of data storage in a relational database. A table stores data in records (rows) and fields (columns) and usually contains information on a particular category of things, such as employees or parts. Also called a base table.
TCP/IP
Transmission Control Protocol/Internet Protocol (TCP/IP) is a network protocol supported by SQL Anywhere.
tool
One of the programs that make up the application. MET/CAL features the following tools: Runtime, Editor, Manual Entry, Database Setup, and Workstation. MET/TRACK has these tools: Manual Entry, Import Data, and Database Setup.
trace report
A report that establishes an instrument’s traceability. MET/TRACK provides forward and reverse traceability for an asset to a selectable depth. Also see forward traceability and reverse traceability.
traceability
Traceability represents an unbroken chain of comparisons from the measurement being made, to a recognized, national, legal standard. Also see forward traceability and reverse traceability.
transaction log
A log storing all changes made to a database, in the order in which they are made. In the event of a media failure on a database file, the transaction log is essential for database recovery. Therefore for optimal security, the transaction log should be kept on a different device from the database files.
transaction log mirror
An identical copy of the transaction log file, maintained at the same time. Every time a database change is written to the transaction log file, it is also written to the transaction log mirror file. A mirror file should be kept on a separate device from the transaction log, so that if either device fails, the other copy of the log keeps the data safe for recovery.
TUR
Test Uncertainty Ratio, the specified uncertainty of the test instrument divided by the uncertainty of the calibrating instrument. A reliable TUR is obtained only when the specifications for the two instruments are correlated according to their respective uncertainty specifications and confidence intervals.
uncertainty
An estimate of the possible error in a measurement. More precisely, an estimate of the range of values which contains the true value of a measured quantity. Uncertainty is usually reported in terms of the probability that the true value lies within a stated range of values.
user
A unique name assigned to a login ID for the purpose of allowing a user to have access to a database. The abilities a user has within a database depend on the permissions granted to the user name. User names are assigned by the Administrator. .
user configured instrument
A user-configured instrument has no built-in MET/CAL driver (Function Selection Code). User-configured instruments are controlled using the IEEE or PORT FSC
validation
Validation restricts the data allowed in a field to a set of authorized, or valid, values. The software uses validation files to store the allowed values. These files are specified on a field-per-field basis as a part of customization; each field's validation file has a unique name, by default, the field number.


Add Instrument Dialog

The system instrument list box provides a list of the system instruments that are currently not configured.

Enter the instrument name of the system instrument, user-configured instrument, or standard that you want to add to the configuration. If you are adding a system instrument, you can select an instrument from the list box. Based on the selection or entry, a second dialog displays providing options to configure the instrument.

The instrument name is used by MET/CAL to uniquely identify a configured device. MET/CAL recognizes instruments as primary or secondary devices. The rules for instrument names are listed below:

  • Instrument name is restricted to 29 characters.
  • Characters must be printable.
  • Leading and trailing blanks are not allowed.
  • Two or more configured instruments may not have the same name.

See Also:

  • User Configured Instrument Dialog
  • System Instrument Dialog


Calibrate

In addition to configuring the required instruments, two pieces of information must be provided before running a MET/CAL procedure: Asset being calibrated, and Procedure to use for the calibration. These selections are made in the MET/CAL Runtime SETUP view, then the procedure is executed in the RUN view. This arrangement allows a procedure to re-ran as needed to complete the calibration.

SETUP

Before running a procedure, two pieces of information must be supplied using the SETUP view:

  1. UUT Asset - click the SELECT button under the UUT column to select the asset being calibrated

  2. Procedure - Up to three types of procedures may be selected using the drop-down menu in the Procedure column. Your configuration may not display all three choices, and the drop-down will not be present if your configuration only allows one choice.

    1. SELECT MET/TEAM PROCEDURE
    2. SELECT PXE
    3. SELECT FROM PROC.DIR

Selecting the Asset

Click the SELECT button to display the MET/TEAM Find Asset dialog and search for the UUT asset. The asset must be present in MET/TEAM before the calibration process can continue.

Use the search criteria of the Select Asset screen to narrow the asset search. Pressing Cancel at this point aborts the calibration.

Selecting the Procedure

Depending on your configuration, up to three methods may be available for selecting the procedure:

SELECT MET/TEAM PROCEDURE

This method allows you to select a procedure as-configured in MET/TEAM. Some pre-requisites must be met:

  • The UUT Asset must be selected before clicking this button
  • A valid MET/CAL procedure must be configured in MET/TEAM, as described here.

SELECT PXE

Navigate to the Procedure Executable file.

SELECT FROM PROC.DIR

If you are using a legacy procedure (SELECT FROM PROC.DIR), use the Procedure Selector to select the procedure.

RUN

After selecting the UUT Asset and Procedure using the SETUP view, select the RUN view and click the RUN button (or just press F5) to begin procedure execution.

If a PXE procedure was selected, the associated properties display along with the Select instrument line to run dialog. The instrument line(s) of the PXE's main procedure will display in drop down list on the left of the screen. Choose the Instrument Line and any expected procedure sections then press OK. The Procedure Section selection is only available on procedures designed with Sectioning Syntax.

Follow the instructions in the procedure to complete the test.


Configuration Dialog

The Edit Configuration Dialog box accessed from the CONFIGURE view in MET/CAL Runtime or the Tools Menu in the MET/CAL Editor, displays the instruments that are actively configured on the station. Each instrument in the configuration is uniquely identified by its instrument name shown in the list. Use the buttons on the dialog to modify the configuration as required based on the available hardware.

MET/CAL maintains the list of configured instruments. Associated traceability information for configured instruments is stored in the database. Before you can use calibration instruments, you must identify which instruments are configured in the system. A configured instrument is a traceable calibration standard. There are three types of configured instruments: User Configured Instrument Dialog, System Instrument Dialog and Manual Instruments. When configuring a new instrument, remember to also add traceability information to the database.

Add Instrument

Add an instrument to the configuration. When you add an instrument, you will be prompted for the instrument name to add to the configuration. If you add a system instrument, you can simply select one from the list of system instruments that are not yet configured. The Add button is grayed out when the maximum number of instruments are configured. After you select one, you are immediately placed into the Edit Instrument dialog box, described next

Edit Instrument

Edit a previously configured instrument. You must select an instrument in the current configuration list box before selecting Edit. The Edit button is grayed out when no instrument is selected in the list box.

Delete Instrument

Delete a previously configured instrument. You must select an instrument in the current configuration list box before selecting Delete. The Delete button is grayed out when no instrument is selected in the list box.


Configuration File

config = instrument_configuration_file

File where MET/CAL stores configured instrument information.


Default COM Port Dialog

The Default RS-232 Port MET/CAL Configuration setting is used to designate a default serial port. PORT statements in procedures that do not explicitly specify a serial port use the default.

Options

COM1 - COM16

Availability of these serial ports depends on your PC hardware configuration. Most PCs do not have COM Ports by default. Instead USB to RS-232 adapters are used to emulate COM Ports. Always reference the Device Manager of the Host PC to properly identify the port on the adapter to the COM port selection. Most PC’s have COM1 and COM2. If a selection is grayed out, the port is already is use by another device such as the mouse, or the port does not exist in your PC. For example, the figure below displays the 4 ports of a USB to RS-232 adapter. Although the ports are physically labeled 1-4, the host PC recognizes the ports as COM11 - COM14. To communicate with the instrument connected to COM3 of the adapter, you would select COM13 in the RS-232 configuration dialog or use COM13 in PORT FSC statements.

COM5500, COM5520, COM5800, and COM5820

The Fluke 55xx and 58xx Series Calibrators have a UUT pass-through serial port. If a selection is grayed out, the respective calibrator is not configured, or another device has configured its UUT serial port.

The calibrator UUT port is of the type DCE (Data Communication Equipment), whereas the standard PC serial port is DTE (Data Terminal Equipment). Connection to the two types of ports requires different cables. For example, if a DTE type instrument such as a Fluke 45 is connected to COM1, a DB9 female to DB9 female null-modem cable is required. If the same instrument is connected to COM5500, a DB9 female to DB9 male straight through cable is required.


IEEE-488 Boards

The MET/CAL Runtime Options menu and the MET/CAL Editor Tools menu both contain the IEEE-Board Selection dialog. Use this option to configure the number of IEEE-488 boards used on the system.

Specify the number of boards to use with MET/CAL. When more than 1 board is in use it is assumed that the first board is connected to the DUT and the second board is connected to the reference and other system standards.


Inserting LABEL Statements

The first step to implementing the Procedure Section feature in a procedure is to surround applicable sections of the procedure with LABEL statements, indicating the Start and End of each section.

Tests are grouped together in a section because they are usually run together, for example if they use the same standard. If a Fluke 5500 is used, the labels may read like this: TESTS_USING_FLUKE_5500_START and TESTS_USING_FLUKE_5500_END. The labels are added to the procedure at the beginning and end of the group of tests and will then be referenced in the tag comments.

Another example would be to group together tests that require the technician to manually enter measurement values, so that the section can be skipped when no technician is available, and run just the remainder of the procedure.

Example:


Instruments

Instruments

The Configure menu provides a way to change the system instrument configuration. When you select Instruments, a small dialog box appears that contains a listing of all the currently configured instruments.

The following list describes the function of the buttons:

Add | Opens a second dialog box listing all the instrument FSCs available. From this, select the instrument you wish to add to the configuration. After you select one, you are immediately placed into the Edit Instrument dialog box, described next.
Edit | Only available when one of the currently configured instruments is selected, (or opens automatically as a result of selecting an instrument to add). Opens a dialog box permitting port selection, alias assignment if desired, and specification of any options.
Delete | Deletes an instrument from the configured instrument list.

MET/CAL maintains the list of configured instruments. Associated traceability information for configured instruments is stored in the database.

Before you can use calibration instruments, you must identify which instruments are configured in the system.

A configured instrument is a traceable calibration standard. There are three types of configured instruments:

System Instruments

A system instrument is an instrument for which the Fluke Metrology software provides a built-in instrument driver. For each system instrument there is a corresponding FSC in the procedure language. For example, the "5700" FSC is used to control the Fluke 5700A.

Fluke Metrology software supports over 30 different system instruments.

User-Configured Instruments

A user-configured instrument is one that is remotely controlled, but has no built-in driver. A procedure writer uses the PORT and IEEE FSCs to control user-configured instruments.

The PORT FSC is used for instruments with a serial interface (RS-232) and the IEEE FSC is used for instruments with an IEEE-488 interface.

You do not need to make an instrument user-configured in order to communicate with the instrument using a Calibration Procedure. There are two advantages in using a user-configured instrument:

· A user-configured instrument can have an address and an alias. The alias is a symbolic name by which a procedure can refer to the instrument. Using an alias improves procedure readability and portability.

· A user-configured instrument is traceable and can be used in reports. Before starting a procedure that uses a user-configured instrument, the software first checks to make sure the instrument is in cal.

Also note that user-configured instrument specifications are subject to the same format and syntax rules as system devices, with the following additional restrictions:

· A user-configured device cannot have attached secondary devices.

A user-configured device cannot have optional attribute specifiers.

Manual Instruments

A manual instrument is one that is not remotely controlled by the system, but is used as a calibration standard, so it must be traceable. Manual instruments can encompass a wide range of device types. Examples include the Fluke 792A AC/DC Transfer Standard, the Fluke A40 Current Shunts, or a manual device such as a micrometer. The STD (Standard) FSC is used in a Calibration Procedure to require that an instrument be configured as a manual instrument standard. The DISP (Display) FSC is then used to inform the operator of setting or connection changes required when using the standard during execution of the calibration procedure.

When configuring a new instrument, remember to also add traceability information to the database.


Manual Instruments

Manual Instruments

A manual instrument is one that is not remotely controlled by the system, but is used as a calibration standard, so it must be traceable. Manual instruments can encompass a wide range of device types. Examples include the Fluke 792A AC/DC Transfer Standard, the Fluke A40 Current Shunts, or a manual device such as a micrometer. The STD (Standard) FSC is used in a Calibration Procedure to require that an instrument be configured as a manual instrument standard. The DISP (Display) FSC is then used to inform the operator of setting or connection changes required when using the standard during execution of the calibration procedure.


Migrating Procedures from 7.X to 8.0

This section is provided to assist users upgrading from earlier versions of MET/CAL. Please review the Projects and Solutions topic to better understand the project and solution paradigm. Note that the use of Projects is not required in MET/CAL 8.x. Users comfortable with the stand alone procedure paradigm can continue to developing without the use of a project.

Compiled Procedure Format

The compiled procedure format has not changed. MET/CAL has always used a compiled procedure format consisting of a proc.dir file and numbered .pro files (1.pro, 2.pro, 3.pro, etc.) for each procedure, in a flat directory structure. The MET/CAL Editor has always allowed procedures to be created, opened, edited, and saved to this compiled format. The format of the *.pro files has not changed with MET/CAL 8.x. As a result procedures created with MET/CAL 8.x can function on earlier versions of MET/CAL, as long as new functions are not employed which require version 8 (5522A FSC, LIB FSC, etc.).

Procedure Source Code as Text

While earlier versions of MET/CAL had the ability to maintain procedure source code as text files, many customers elected to save everything in the compiled procedure format since this was the default MET/CAL behavior. Pressing standard keyboard shortcuts like Ctrl+S saved procedures to the default proc.dir in compiled format, not to text files on a hard drive. Saving the same procedure as a text file required extra steps.

Solely using the compiled procedure format has a few drawbacks:

  1. Procedure edits are saved to the "live" procedure directory from which they were opened. Others users that share the procedure directory are immediately impacted by changes made. For better or for worse.
  2. Additional, manual steps were necessary to copy procedures to a temporary proc.dir before beginning development.
  3. Once development was finished, additional, manual steps were required to get the procedure copied back into the "live" directory.
  4. It is more cumbersome to return to a specific state of procedure execution when multiple individual procedure files can be edited over time. For example, it is may be difficult to determine the exact procedures used to calibrate an instrument 2 years ago.
  5. Source code could only be edited within the Editor, one procedure at a time.
    1. Powerful text manipulation tools could not be used to edit procedure source code.
    2. Find/Replace operations were limited to one procedure at a time.
  6. Revision control was nearly impossible to implement.

MET/CAL Editor 8 Paradigm:

  1. All procedures are saved as text files in UTF-8 format with a *.mc file extension.
  2. Default save operations (Ctrl+S) now save procedures as text files with a .mc file extension.
  3. Existing procedures that are opened or "imported" to the new Editor are saved as .mc files.
  4. Files can be organized logically in directory paths, instead of having everything in a flat structure. This is not a requirement. Users are welcome to save in a flat structure or a complex directory hierarchy.
  5. Procedures must be Published using the Build > Publish Procedure(s) option to be available for use by MET/CAL Runtime.
  6. A new PXE file can be used to run a procedure. The file cannot be changed after it is created.
  7. It is much easier and faster to work with multiple procedures at once. The ability to search and modify multiple procedures at the same time is available with and without projects.
  8. The new Editor includes powerful text manipulation tools.
    1. Eliminates reliance on external tools and applications.
    2. Find/Replace operations have been greatly expanded:
      1. Wildcards and regular expression matching are now supported.
      2. Quick Find/Replace operations now work in the Current Window, All Open Documents, the current Project, or the entire Solution.
      3. New Find/Replace In Files adds more powerful operations to match those in Quick Find/Replace, plus adds capability to work on closed files, and files located on a disk drive outside of the current Solution.
  9. External text manipulation tools can also be used on .mc files, if desired.

How to Edit Procedures Without Projects

Open existing procedures using the File, Open Procedure menu choice or create a new procedure using the File, New Procedure menu choice. The previous keyboard shortcut CTRL+N is still available to create a new blank procedure. Procedures created in this way are maintained outside of projects. After a compiled procedure is opened, use the *.mc version of the procedure for all edits and to verify functionality in a test run. Publish the procedure to add it to the compiled procedure directory. Review Selecting a Procedure for additional details.

Importing Procedures to Projects

There are 3 ways to create projects from existing procedures. In all cases the import process does not alter the original files. After a project is created always use the Project Properties menu to customize the project properties. PXE files are the typical output of a procedure project. The project properties are visible to users in the MET/CAL Runtime when the PXE is selected.

  1. File > New Project from Existing Procedure: Select one or more main procedures; check the "Exclude Hidden Procedures" box to filter the results, and hold Ctrl to select multiple procedures or Shift to select a range. The Editor will import all procedures referenced by CALL statements, pictures referenced by PIC and PICE statements and programs used by DOS and DOSE into a project. Images and programs referenced as variables are not imported automatically. By default procedures are converted to *.mc files and copied to the procedure project directory. Files that could not be located display with a caution symbol in the solution explorer.
  2. File >New Project from Existing *.pkm File: Select a PKM file and a single main procedure from the PKM file. The editor will import all procedures referenced by CALL statements, pictures referenced by PIC and PICE statements and programs used by DOS and DOSE into a project. Images and programs referenced as variables are not imported automatically. By default procedures are converted to *.mc files and copied to the procedure project directory. Images and programs can be copied to the Folders defined in the MET/CAL Configuration or copied to the current project directory. A prompt is provided during the import process to determine where the files will be imported. Files that could not be located display with a caution symbol in the solution explorer.
  3. File > New Project: Create a new empty project. Right click the project node in the solution explorer and choose the Add option to add new or existing files to the project. Alternatively use the Project menu to add files to the project. The project menu supports adding files only when the project node is selected in the solution explorer.

Test Run Procedures

The ability to test run a procedure is now maintained in the Debug menu. All features associated with Test Run functionality are described as Debugging in MET/CAL 8.x. A toolbar and corresponding menu choices are available to enable and disable debugging. While debugging other windows can be viewed, however editing a procedure is not allowed.

Debug related windows do not automatically display when test running a procedure. It is up to the user to configure the display to view the desired windows when a debugging is active. Use the Debug> Windows menu choice to access windows to view the status of variables used in a procedure and the current test run status information.

Debugging procedures outside of a project is very similar to prior versions of MET/CAL. As long as the procedure is syntactically correct, debugging is supported. All procedures and files referenced by the procedure are assumed to be in the paths defined by MET/CAL Configuration settings. CALL FSC statements reference the active compiled procedure directory. This is the case even if the *.mc version of the compiled procedure is open in the solution. For this reason, break points can only be added to Sub procedures after they are opened during the debug process.

Debugging a project always starts by building the procedure project to ensure that all dependencies are valid and that there are no errors in any procedures within the project. Use the View > Output menu option to display the Output Window that includes detailed status information on the build process. Any errors or warnings are displayed in the Output Window in addition to the Error and Warning Windows. To ignore a procedure in a project, select the specific procedure(s) in the Solution Explorer then access the file properties using F4. Choose Contentfor the Build Action property. In this case, any errors in the selected procedure are ignored and will not prevent the debug process from starting.

Changes to Common Functions
MET/CAL 7.X Menu | MET/CAL 8.x Menu
Test Run, Restart (F2) | Debug > Start Debugging (F5)
Test Run, Go (Alt+F2) | Debug > Debug from Cursor (Alt+F5)
Test Run, Show | There is no equivalent Test Run Dialog. The Debug > Windows menu includes options that display variable and status Window information.
Demo Mode | Debug > Simulation Mode menu choice
CTRL+I

Not supported. A default Instrument line is included in all new procedures. Additional instrument lines should be created by copy/paste action.

To test run a specific instrument line in a procedure, create a new temporary procedure that includes a CALL statement to the specific instrument line in the procedure.


Post-Prompt Dialogs

There are two post-prompt dialogs: the pass-prompt dialog and the fail-prompt dialog. After each procedure execution one or the other, but not both, of these dialogs is displayed.

If the overall result of the procedure is PASS, the pass-prompt dialog is displayed. If the overall result is FAIL, the fail-prompt dialog is displayed. The condition that determines an overall result of FAIL is that one or more of the individual tests has failed because the UUT is out of tolerance at that test point.

The pass-prompt and fail-prompt dialogs are separately configurable.

Use the post-prompt dialogs to display read-only information, or to prompt the operator for information that will be written to the results.

The Pass Prompt parameter in the MET/CAL Configuration settings specifies the name of the file that controls the pass-prompt dialog.

Similarly, the Fail Prompt parameter in the MET/CAL Configuration settings specifies the name of the file that controls the fail-prompt dialog.

To turn off the pass- or fail-prompt dialogs, you can change one or both parameters to "none". Since the two dialogs are independently configurable, it’s possible (for example) to set up the system so that a post-prompt dialog appears when the overall result is FAIL, but not when the overall result is PASS.

As with the pre-prompt dialog, an equivalent way to turn off the post-prompt dialog is to edit the appropriate prompt file and change it so that it contains no lines other than comments and blank lines. Any line that begins with a pound sign (#) or a semicolon (;) is a comment line.

The default pass-prompt dialog shows the operator the number of marginal tests, the time it took to calibrate the UUT, the overall test result (PASS, FAIL, etc.), and asks the operator to indicate that the results are either "As Found" or "As Left", and to enter an optional comment.

Note that a "marginal test" is one where the test passed, but the error expressed as a percentage of the test tolerance is greater than the adjustment threshold. The adjustment threshold is a configurable parameter set in the procedure. It is typically set to 70%.

The default fail-prompt dialog is the same as the pass-prompt dialog, except that it also shows the total number of tests that failed.

However, as with the pre-prompt dialog, the post-prompt dialogs can be configured by the person who sets up the system. When you run a procedure, you may or may not see the information and prompts described for the default prompt dialogs.

If the value entered by the operator for a data item is to be written to the database, the value must be written to one of the fields of the calibration table, and it must not be a field that is automatically updated by the MET/CAL Runtime.

Normally all fields in the post-prompt dialog are displayed in a single dialog. However, if the system is set up to prompt for a large number of items, a sequence of separate dialogs will appear until all the prompts have been shown.

Refer to Customizing Prompts for the Operatorfor additional information. There, you will find a detailed description of the format of pass-prompt and fail-prompt files, and other information about customizing them.


Post-Run Prompts and the As Found / As Left Feature

The purpose of field 2308, Found/Left, is to permit you to mark each calibration event with a tag specifying the point in your process that the event occurred. The tags specify whether the calibration results indicate the condition of the instrument at the time it arrived, at the time it left, or both.

Refer to the Configuring the System section for complete information about how to use the As Found / As Left feature. There, you will find a discussion that explains how to use the feature in conjunction with the Pass/Fail field to create a reliability profile for your assets.


Post Test Dialog

This section describes the Post Test Dialog as shown in the figure below.

Post Test Summary

On the left-hand side, the Post-Test Summary dialog shows the following information:

Section 1

Test Field

The test field shows the test number and the test result. The test number is the major step number of the test. For example, test number 7 might look like the following:

  7.001  DISP         Connect...
  7.002  5700         1V             1%                                    2W

The test result is shown on the right-hand side of the Test field, and will be one of the following values:

  • PASS

    Indicates that the UUT is within the test tolerance at this test point, and is also within the adjustment threshold.

    The adjustment threshold is specified in the header of the main procedure being executed. The default value is 70%. If the error, expressed as a percentage of the tolerance, is less than the adjustment threshold the test result will be PASS.

  • MARGINAL PASS

    Indicates that the UUT is within the test tolerance at this test point, but not within the adjustment threshold.

    At some sites, the standard policy is to run the calibration adjustment procedure for a UUT if the UUT passes the verification procedure, but one or more test points generate a MARGINAL PASS result.

  • FAIL

    Indicates that the UUT is not within the test tolerance at the current test point, but is within the "significantly out of tolerance limit." See the description of this limit in the FAIL NOTIFY USER section below.

    The MET/CAL Configuration contains a parameter named Pass 100% that allows the system to be configured with respect to whether or not a test is a PASS or a FAIL when the error is exactly equal to 100% of the test tolerance.

    • If the Pass 100% box is checked, the test result is MARGINAL PASS if the error is exactly equal to the test tolerance.
    • If the Pass 100% box is unchecked, the test result is FAIL if the error is exactly equal to the test tolerance.

    The default state (as distributed) is Checked.

  • FAIL NOTIFY USER

    Indicates that the UUT is not within the test tolerance at the current test point, and also not within the "significantly out of tolerance limit."

    This limit is specified using the Out-of-Tolerance Limit setting in the MET/CAL Configuration.

    The purpose of this setting is to allow a site to specify a limit above which a failing UUT is considered to be significantly out of tolerance, potentially requiring the recall of instruments recently calibrated or adjusted using the UUT in question.

    The default value (as MET/CAL is distributed) is 100.0. This is a conservative setting, indicating that any UUT that fails at any test point will generate the FAIL NOTIFY USER test result.

Section 2

Error Field

The error is calculated as:

error = UUT Indicated – System Actual

If the NOMINAL units are dBm, the Nominal value is zero, the UUT Indicated value is zero, or the System Actual value is zero, the error is formatted as an absolute number.

Otherwise, the error is formatted as a percentage of either the UUT Indicated or the NOMINAL value, depending on the value of the Tolerance Reference MET/CAL Configuration setting.

For a Go/NoGo test the Error field is blank.

Error % Tol Field

For a numeric evaluation, this field shows the error expressed as a percentage of the test tolerance.

For a Go/NoGo evaluation this field is blank. This applies to instrument evaluations with ASK+ ‘G’ set, to EVAL statements, PICE statements, and to some DOSE statements.

Section 3

Range Field

The Range field shows the UUT range, as indicated in the RANGE field of the procedure statement just executed. The Range field shows "A" to indicate auto-range.

UUT Indicated Field

The UUT Indicated field shows the UUT Indicated value for the test. For a test in which the calibration standard is a stimulus device (like a Fluke 5700A), and the UUT is a measurement device (such as a Fluke 77), the UUT Indicated value is the reading taken by the UUT. If the test is a Go/NoGo test, the UUT Indicated field is blank on the Post Test dialog.

For a test in which the calibration standard is a measurement device (such as an HP 3458A), and the UUT is a stimulus device, the UUT Indicated value is the expected reading, as indicated in the NOMINAL field of the procedure statement that performed the evaluation step.

System Actual Field

The System Actual field shows the System Actual value for the test.

If the UUT is a measurement device, the System Actual is the true value applied to the UUT by the calibrator being used as a calibration standard.

If the UUT is a stimulus device, the System Actual is the measurement taken by the measurement device being used as the calibration standard.

MOD1 Field

The Post Test MOD1 field shows the information in the MOD1 field of the procedure evaluation step just executed. If you execute an evaluation step such as the following:

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
  1.001  5700         10kH           1%            1V                      2W

the evaluation is based on frequency (NOMINAL field), so you will see that MOD1 shows the voltage (1V in this example).

Section 4

Test Tolerance Field

The Test Tolerance field shows the test tolerance in units of the NOMINAL field. For example, suppose you execute the procedure evaluation step:

1.001 5700 100V 1% 2W

The test tolerance displayed in the Post Test dialog will be 1V, because 1V is 1% of 100V.

System Accuracy Field

The System Accuracy field shows the accuracy of the system instrument (calibration standard) used for the test.

For example, suppose you execute the following procedure evaluation step:

1.001 5700 200V 1% 2W

If the 90-day accuracy file for the 5700A is used, the system accuracy will be shown as 1.3mV. This is because in the accuracy file, for the 220V range, the tolerance is given as 6e-4 and the floor is 100e-6V. Note that the tolerance value in the accuracy file is a percentage.

The calculation is therefore:

system accuracy = 6e-4 * 0.01 * 200V + 100E-6V

... which is equal to 1.3mV, as shown in the Post Test dialog.

If the test in the procedure is a MEMC test in which the system accuracy is specified using an ACC statement, MET/CAL uses the value from the ACC statement and does not look up the system accuracy in one of the FSC-specific system accuracy files.

T.U.R. Field

The T.U.R. field shows the test uncertainty ratio for the test. The test uncertainty ratio is the ratio of the test tolerance to the system accuracy.

If the test tolerance or the system accuracy are specified in decibels (dBm), the quantity is converted to volts before it is used to calculate the T.U.R.

If the T.U.R. exceeds the TUR Limit specified in the MET/CAL Configuration settings, the Post Test dialog does not show the T.U.R. Rather, the dialog indicates that the T.U.R. is greater than the limit, and shows the limit.

The T.U.R. limit is specified by the TUR Limit setting in MET/CAL Configuration. The default value for the limit is 4.0. The TUR Limit can also be disabled by unchecking the Enable box, which disables the calculation of the T.U.R. by the MET/CAL Runtime and MET/CAL Editor applications. If disabled, the Post Test dialog does not show values in the Test Tolerance, System Accuracy, or T.U.R. fields.

Post Test Summary Dialog Buttons

On the right-hand side of the Post-Test Summary dialog are 8 buttons. These have the following functions:

Advance

Choosing Advance causes procedure execution to resume at the next step.

Repeat

The basic function of Repeat is to repeat the current step. The precise operation of Repeat depends on the current setting of the ASK 'P' flag in the procedure.

  • If the ‘P’ flag is set, the procedure is re-started at the current procedure line when the operator selects the Post Test Repeat option.
  • If the ‘P’ flag is not set, the procedure is re-started at the first statement of the current test. The step number of the first statement of the test has the form XX.001.

Note that when a test is repeated more than once (that is, executed more than twice), MET/CAL saves only the first and last results for that test step.

Cancel

Selecting Cancel is the same as Repeat (see above) except that when the operator chooses Cancel, the result of the canceled test is not saved. As with Repeat, the procedure step on which execution resumes is controlled by the current setting of the ASK ‘P’ flag.

The Post Test Cancel button can be disabled (grayed out) by not setting the ASK ‘X’ flag in the procedure. A MET/CAL Configuration setting 'Enable Post Test CANCEL option, by default' controls the default state of the ASK ‘X’ flag.

  • If the box ix checked (or +), then the ASK ‘X’ flag will be set by default in a procedure that does not specify otherwise. This means that the Post Test Cancel button is enabled by default.
  • If the box is unchecked (or –), then the ASK ‘X’ flag will not be set by default in a procedure that does not specify otherwise. This means that the Post Test Cancel button is disabled by default.

Default condition is checked, as MET/CAL is delivered.

Adjust

The Adjust button is enabled only if the error for the test just completed exceeds the adjustment threshold, and the procedure being executed contains an adjustment block for the current test step, and the ASK ‘J’ flag is set. There is some interaction between the ASK ‘J’, ‘A’, and ‘F’ flags. Refer to the ASK+ and ASK- FSC topics for details.

Procedures distributed by Fluke do not make use of in-line adjustment blocks. Separate verification and adjustment procedures are provided. When these procedures are used, the Adjust button will never be enabled.

Remark

Choosing Remark allows a remark of up to 32-characters to be entered. The entered remark is written to the results. Multiple remarks can be entered for one test step.

List

Choosing List causes a read-only listing of the current procedure to be displayed. When the listing is displayed, the current line (that is, the line just executed) is highlighted. The highlighted line can be changed using the Up Arrow, Down Arrow, Page Up, and Page Down keys, or by using the mouse to click on the line.

When MET/CAL Runtime first displays the listing, the input focus is on the Advance button. The Up Arrow, Down Arrow, Page Up, and Page Down keys will not work as expected until the focus has been moved to the list box that shows the procedure. This can be done using the Tab key, or by clicking on the list box.

The Procedure Listing window includes Advance and Terminate buttons. These are not the same as the Advance and Terminate buttons in the Post-Test Summary dialog. Choosing Advance in the Procedure Listing causes procedure execution to resume by executing the highlighted line.

It is important to realize that if you choose the Post Test List button, and then immediately choose Advance in the Procedure Listing window, you will re-execute the step that just completed. If you really just wanted to look at the procedure, and would like to resume execution as if you hadn't chosen List at all, you can choose Terminate in the Procedure Listing window, followed by Advance in the Post-Test Summary dialog, or you can move the highlighted line down one line in the Procedure Listing window, and then choose Advance there.

The ASK ‘L’ flag can be used to enable or disable the List option in the Post-Test Summary dialog.

Settings

Choosing the Settings button causes MET/CAL Runtime to display the last 18 settings created by the SET FSC. This allows the operator to verify that the UUT is set up correctly for the current test. This capability is used primarily in conjunction with calibration oscilloscopes. Refer to the SET FSC for details.

The Settings button is disabled unless one or more stored settings are available to be viewed.

Terminate

Choosing Terminate stops the execution of the procedure. Results generated before the procedure is terminated are not discarded, unless the operator subsequently chooses to discard them.

The Terminate button can be enabled or disabled by setting or clearing, respectively, the ASK ‘T’ flag. By disabling the Terminate and List options, a procedure writer can write a procedure that, barring errors, forces the operator to execute all of the tests in the procedure. Such a procedure should be carefully tested, however, because it can be difficult to terminate.


Pre-Prompt Dialog

You can configure the pre-prompt dialog that appears after a procedure has been selected, but before the start of procedure execution.

Use the pre-prompt dialog to display read-only information, or to prompt the operator for information that will be written to the results or, in some cases, used during procedure execution.

The pre-prompt dialog is controlled by the Prompt File MET/CAL Configuration setting. This setting specifies the name of the file that controls the pre-prompt dialog.

To turn off the pre-prompt dialog, the system administrator can change the setting to "none."

An equivalent way to turn off the pre-prompt dialog is to edit the prompt file (default name promptdb.txt) and change it so that it contains no lines other than comments and blank lines. Any line that begins with a pound sign (#) or a semicolon (;) is a comment line.

The default pre-prompt dialog prompts the operator for the temperature, the humidity, the work order number, and asks whether the calibration seal on the UUT is intact. By modifying the pre-prompt file the administrator of the system can prompt for specific information.

If the value entered by the operator for a data item is to be written to the database, the value must be written to one of the fields of the calibration table, and it must not be a field that is automatically updated by the MET/CAL Runtime.

Normally all fields in the pre-prompt dialog are displayed in a single dialog. However, if the system is set up to prompt for a large number of items, a sequence of separate dialogs will appear until all necessary prompts have been shown.

Refer to the heading Customizing Prompts topic for additional details.


Procedure Date Format (Optional)

proc_date_format = string

proc_date_format specifies the format for the date string in the procedure header.

Example:

proc_date_format = MM/DD/YYYY

If anything goes wrong in attempting to format the date using the format string specified by proc_date_format, silently revert to the default (YYYY-MM-DD).

Format descriptors:

DD | day number
MM | month number
MON | 3-letter month name
MONTH | full month name
YY | 2-digit year number (for window 1970 - 2069)
YYYY | 4-digit year number

Rules:

  1. No format code may occur twice.
  2. At most one of { MM, MON, MONTH } may occur.
  3. At most one of { YY, YYYY } may occur.
  4. Other characters are copied unchanged.


Trace Modes

The MET/CAL Editor contains a Debug, Trace option with selectable menus to enable and disable specific trace options. Use the trace options to display low level execution detail in the Output Window while debugging a Procedure. The trace options can be selected individually or all together. The check mark is added or removed each time that a trace menu item is selected.

Trace Option

Description

IEEE-488 I/O

Displays IEEE-488 interface command and response strings generated or received upon execution of the FSC. Any service requests (SRQs) which occurred between execution of the FSC and the next FSC are also displayed.

Applicable FSCs: IEEE, IEEE2, SCPI, RESET, CLEAR, and instrument FSCs that use instruments that are configured for IEEE communication

RS-232 I/O

Displays RS-232 interface command and response strings generated or received upon execution of the FSC.

Applicable FSCs: PORT, RESET, CLEAR, and instrument FSCs that use instruments that are configured for RS232 communication

Accuracy

Displays accuracy lookup information and computed accuracy for the FSC. Use this trace option to troubleshoot accuracy related issues (see TUR Report).

Applicable FSCs: All instrument FSC and MATH FSC accuracy functions.

Below is an example output of an IEEE trace. Note instrument I/O begins before the first line of procedure execution. Any instrument communication issues or unexpected responses would be listed in the Output Window.


Run Time Prompts

Automatic Connection and Disconnection Message Prompts

Automatic connection and disconnection message prompts are generated by instrument FSCs and the CON (connection) FSC. Automatic connection messages generally have limited utility, because MET/CAL builds them with only the information contained in the CON (UUT connection) field of an instrument FSC. For example, the following statements would generate the subsequent automatic connection and disconnection messages:

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
  1.001  5500   4     3.500V         0.034U        60H            SI       2W
  2.001  5500         100.0mA        1.2U                                  2W

The automatic disconnection message prompt is displayed when the UUT connection changes. In this case, the 5500A NORMAL outputs are used for voltage, however, the AUX outputs are used for current.

Statement 1.001 specifies an AC voltage with a 2-wire connection to the UUT. This is enough information for MET/CAL to determine that the 5500A NORMAL output terminals must be used. However, this is not enough information to determine exactly which UUT terminals must be connected to the 5500A NORMAL output terminals. Typically, a procedure writer inhibits automatic connection and disconnection messages using the ASK- FSC, and instead uses a more descriptive prompt using the DISP or PIC FSCs. See the headings titled, "Operator Information Prompt" and "Pictorial Information Prompt" later in this chapter.

Example:

  1.001  DISP         Connect the 5500A to the UUT as follows:
  1.001  DISP         5500A NORMAL Output Hi to UUT V-Ohm-Diode
  1.001  DISP         5500A NORMAL Output Lo to UUT Common

For a complete description of enabling and disabling automatic connection and disconnection messages, refer to the ASK+ and ASK- FSC topic.

Automatic Range Message Prompt

Automatic range message prompts are generated by instrument FSCs and the RNG (range) FSCs. Automatic range messages are built by MET/CAL using the information contained in the RANGE field of the instrument FSC and the NOMINAL and MOD1 fields of the RNG FSC. For example, the following 5500 and RNG statements would generate the same automatic range message (shown immediately after the fragment):

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
  1.001  5500   4     3.500V         0.056U        1kH            SI       2W
  2.001  RNG          4V                           AC

For more information on UUT range messages, see the following topics:

  • RANGE Field
  • UUT Range Message
  • RNG FSC

For a complete description of enabling and disabling automatic range messages refer to the ASK+ and ASK- FSC topic.

Automatic Test Setup Prompts

Automatic test setup prompts are generated by an instrument FSC evaluation test, nominal setup test, or comparison test that is measuring an output of the UUT. For example the following 34401 statement would generate the subsequent automatic test setup prompts:

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
  1.001  34401        1.00V                                             N  2W

After the 34401A takes the measurement, the following automatic test setup prompt is generated:

For a complete description of enabling and disabling automatic test setup prompts refer to the ASK+ and ASK- FSC topic.

Automatic UUT Setup Prompt

An automatic UUT setup prompt is generated by an instrument FSC setup test that is monitoring an output of the UUT. For example the following 34401 statement would generate the following automatic UUT setup prompt:

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
  1.001  34401        1.00V                                             S  2W

For a complete description of enabling and disabling the automatic test setup prompt, refer to the ASK+ and ASK- FSC topic. For an explanation of how to create a message to annotate or replace the automatic UUT setup message, see the MESS FSC.

Slew Dialog

The slew dialog is a pop-up screen that is created by an instrument FSC evaluation test, nominal setup test, or comparison test when the calibration instrument is applying an output to the UUT. The slew dialog is the default mode for evaluation tests and comparison tests. The slew dialog is always displayed for nominal setup tests. When the slew dialog is displayed, it is used to perform one of the two functions enumerated below:

  1. Slewing the Calibrator Output

    2. If the calibration instrument allows incremental changes of its output around the nominal value, then, as the operator changes the displayed value of the slew screen, the number shown reflects the actual calibrator output. The operator slews (adjusts) the display until the UUT is reading the nominal value as closely as possible. If the statement is an evaluation test or comparison test, MET/CAL can then calculate the deviation from the nominal required to make the UUT read the value and report the error of the UUT.

    Example:

     STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
  1.001  5700         1.00V          0.01U                                 2W

    Slewing the Calibrator Output

  2. Matching the UUT Display

    3. If the calibration instrument cannot incrementally change its value, like 5700A resistance, slew acts differently. The operator adjusts the displayed value in the slew screen to match the reading shown on the UUT’s display. MET/CAL uses this information to calculate the UUT error.

    Example:

     STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
  1.001  5700         1.00kZ         0.01U                                 4W

    Figure 3-4. Matching the UUT Display

For more information on the slew dialog, see the following topics:

  • Stimulus Function under "Evaluation Test"
  • Stimulus Function under "Nominal Setup Test"

For information on configuring the slew message, see the following topics:

  • Slew Message
  • MESS FSC

Keyboard entry or Go-NoGo mode can be selected in lieu of slew mode using the appropriate ASK flags (see Keyboard Entry Operator Prompt and Test Evaluation Prompt in this section).

For a complete description of enabling and disabling slew mode refer to the ASK+ and ASK- FSC topic.

Keyboard Entry Operator Prompt

The keyboard entry operator prompt is a pop-up screen that is created by an instrument FSC evaluation test, nominal setup test, or comparison test to enter the UUT reading. The operator prompt is used when the keyboard entry evaluation mode is selected. The following is an example instrument evaluation test with keyboard entry mode selected:

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
  1.001  ASK+           K
  1.002  5700         1.00V          0.01U                                 2W

The ASK+ K statement specifies keyboard entry mode for the 5700 evaluation test. This causes the following dialog to be displayed, prompting the operator for the UUT reading:

For more information about the Keyboard Entry Operator prompt, see the Instrument FSCs topic.

Memory Register Operator Prompts

Memory register prompts are pop-up screens that prompt the operator to enter data for the MEM and MEM2 registers. The MEMI FSC is used to display a prompt for the value of MEM. The MEM2 FSC is used to display a prompt for the value of the MEM2 register.

The MEMI FSC can be used to prompt for the UUT reading, like the keyboard entry prompt does for instrument FSC. Specifically, the MEMI FSC must be used to obtain the UUT reading when its units are not the same as those of the standard. This situation is illustrated in the following procedure fragment:

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
  1.001  5700         2V                           60H                  S  2W
  1.002  DISP         Press the MIN MAX button.
  1.002  DISP         Press BEEPER button to display maximum values.
  1.003  MATH         MEM = ACCV2("Fluke 5700A", "Volts", 2.0, 60.0)
  1.004  MATH         M[1] = 2 * SQRT(2) * MEM
  1.005  ACC          2.828Vp        M1U
  1.006  MEMI         Enter UUT reading in volts peak:
  1.007  MEMCX        2.828Vp        0.045U

Note that the UUT reading is in volts peak even though the setup of the standard is specified in volts RMS. If a 5700 evaluation test had been used instead of a 5700 setup test, the UUT reading would have been incorrectly entered in volts RMS. The following shows the MEMI prompt that would be generated by the above procedure fragment:

For a complete description of creating memory register prompts, see the MEMI and MEM2 FSCs. Descriptions of the other FSCs used in the above example can also be found in the FSC Reference.

Test Decision Prompt

The test decision prompt is a pop-up screen that is created by the OPBR FSC. The test decision prompt is used for yes/no conditional prompts. The OPBR FSC does not perform an evaluation. The following example OPBR statements create the example dialog immediately following:

  1.001  OPBR         Have any components been replaced?
  1.001  OPBR         (Note: the hardware adjustments may be skipped
  1.001  OPBR         unless the ScopeMeter test tool has been repaired.
  1.001  OPBR         If adjustments S6, S7, S8 or S9 fail, also
  1.001  OPBR         restart the MET/CAL procedure and perform H1..H4.)

For a complete description of creating the test decision prompt, see the OPBR FSC. A description of the JMPT FSC can also be found in the FSC Reference.

Test Evaluation Prompt

The test evaluation prompt is a pop-up screen that is created by an instrument FSC evaluation test or the EVAL FSC. In the case of an instrument FSC, the test evaluation prompt is generated only when the Go-NoGo evaluation of the UUT reading is selected. The following is an example instrument evaluation test with Go-NoGo mode selected:

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
  1.001  ASK+           G
  1.002  5700         1.00V          0.01U                                 2W

The ASK+ G statement specifies Go-NoGo mode for the 5700 evaluation Test.

Following is another example instrument evaluation test with Go-NoGo mode selected:

 STEP    FSC    RANGE NOMINAL        TOLERANCE     MOD1        MOD2  3  4 CON
  1.001  ASK+           B
  1.002  5700         1.00V          0.01U                                 2W

The ASK+ B statement also specifies Go-NoGo evaluation of the UUT reading, but allows the operator to optionally select either keyboard entry or slew evaluation mode.

The EVAL FSC is used for Go-NoGo evaluations that cannot otherwise be performed using an instrument FSC Go-NoGo evaluation.

Example EVAL FSC:

  1.001  DISP         Plug a test lead into the V Ohm Diode terminal,
  1.001  DISP         and touch the probe to the 10A terminal.
  1.002  EVAL   Does UUT indicate between 0.1 and 0.5?

For more information about the test evaluation prompt, see Instrument FSCs and the EVAL and MESS FSCs. A description of the DISP FSC can also be found in the FSC Reference.

Test Information Prompt

The test information prompt is a pop-up screen created by the DISP FSC. The test information prompt is used to present the operator with textual information that does not require a Yes or No response.

  1.001  DISP         Press the MIN MAX button.
  1.001  DISP         Press the BEEPER button to display maximum values.

For a complete description of creating the test information prompt, see the DISP FSC.

Pictorial Information Prompt

The pictorial information prompt is a pop-up screen that contains a picture and is created by the PIC and PICE FSCs. Pictorial information is used instead of text. The pictorial-style prompt is normally only used in those cases when instructions to the operator would require a detailed description of a required calibration step that would be difficult to present in text-only form.

The PIC FSC is used for connections and setups, whereas the PICE FSC also performs a test evaluation.

Example PIC FSC:

1.001 PIC 55_s3_cw

PIC Pictoral Information Prompt

Example PICE FSC:

1.001 PICE 7x-3_dsp

PICE Pictorial Information Prompt

For a complete description of creating the pictorial information prompt, see the PIC and PICE FSCs.

UUT Setting Prompt

The UUT setting prompt is a pop-up screen that contains a list of UUT setups. The prompt is generated by the SET FSC and is typically used in procedures for oscilloscopes when a large number of setups is required, or the steps are unusually complex.

Example:

  1.001  SET          VOLTS/DIV CH 1 : 1V
  1.001  SET          VOLTS/DIV CH 2 : 1V
  1.001  SET          TIME/DIV : 10us
  1.001  SET          Input Coupling CH 1 : 1 MOhm GND
  1.001  SET          Input Coupling CH 2 : 1 MOhm GND
  1.001  SET          ADD : Off
  1.001  SET          INVERT : Off
  1.001  SET          ALT/CHOP : ALT

For a complete description of creating the UUT setting prompt, see the SET FSC.


Help Menu

Use the Help menu to access the MET/CAL help system within MET/CAL Runtime or to view the About dialog. The dialog provides useful version details and user permission information.


System Instrument Dialog

A system instrument is an instrument for which the Fluke Metrology software provides a built-in instrument driver. For each system instrument there is a corresponding FSC in the procedure language. For example, the "5700" FSC is used to control the Fluke 5700A. Fluke Metrology software supports a variety of different system instruments.

A unique System Instrument Dialog box appears for each supported system instrument. The 5500A dialog box shown in the example displays most of the commonly used options. The choices in top portion of the display are consistent with the choices on the User Configured Instrument Dialog.

Refer to the documentation of the specific instrument to get more details on the options provided in the configuration dialog.

Scope Option
Option button used if the calibrator you are configuring has 5500A-SC300 or 5500A-SC600 oscilloscope calibration.
Extended Performance
The 5500A/EP option is a stand-alone switch matrix that is used in conjunction with a Fluke 5500A and an HP3458A multimeter to enhance and extend the calibration capabilities of the 5500A.
In practice, a MET/CAL procedure is generated which characterizes the 5500A and 5500A/EP combination using the 3458A. The test results generated by this procedure are used to create a MET/CAL correction file for the calibrator. The accuracy of this enhanced system is then limited by the 24-hour stability of the 5500A. The resulting system is capable of performing complete adjustment and verification procedures for most 5 1/2 and 6 digit multimeters.
The 5500A/EP option is, for the most part, transparent to the MET/CAL system. However; it is important to mention that the switchbox allows simulated 4-wire ohms measurements to 100 MΩ. To support this extension of the 5500A, the 4-wire resistance mode in the MET/CAL accuracy file (5500EP.ACC), has been extended. In addition, if the 5500A/EP option is selected during configuration, the MET/CAL procedure compiler and run system will allow 5500 FSC statements with MOD3 = E to include the extended 4-wire resistance ranges.
Auxiliary Device - 5725A
Check box used if a Fluke 5725A amplifier is controlled by the calibrator you are configuring. When used a specific asset number can be used to link the use of the standard with the calibration results.
Wideband
Check box used if the calibrator you are configuring has option 5100B-03 or 5700A-03, Wideband AC voltage.
5 Channel Option
Check box used if the calibrator you are configuring has option 5800A-5, Five Channel Output.
2.5 GHz Option
Check box used if the calibrator you are configuring has option 5800A-GHz, the 2.5 GHz Option.
Bundeswehr
Check box used if you are configuring a Fluke 5800A/BW.
1000V AC
Check box used if you are configuring a Fluke 8506A/CT with 1000V AC range.
Channel C
Check box used if the counter you are configuring has option PM 9608B – 1.3 GHz HF Input, PM 9621 – 1.3 GHz Input C, PM 9624 – 2.7 GHz Input C, or PM 9625 – 4.5 GHz Input C.
High Voltage Option
Check box used if the HP 3325B you are configuring has option 002, High Voltage Output or if the HP 3458A has the kilovolt option.
DC Voltmeter
Check box used if the HP 5335B you are configuring has option 020, DC Voltmeter.
Programmable Input Amplifiers
Check box used if the HP 5335B you are configuring has option 040, Programmable Input Amplifiers.


User Configured Instrument Dialog

A user-configured instrument is one that is remotely controlled, but has no built-in driver. A procedure writer uses the PORT and IEEE FSCs to control user-configured instruments. The PORT FSC is used for instruments with a serial interface (RS-232) and the IEEE FSC is used for instruments with an IEEE-488 interface. When None is selected as the Remote Interface type the configuration is for a Manual Instrument.

You do not need to make an instrument user-configured in order to communicate with the instrument using a Calibration Procedure. There are two advantages in using a user-configured instrument:

  • A user-configured instrument can have an address and an alias. The alias is a symbolic name by which a procedure can refer to the instrument. Using an alias improves procedure readability and portability.

  • A user-configured instrument is traceable and can be used in reports. Before starting a procedure that uses a user-configured instrument, the software first checks to make sure the instrument is in cal. Also note that user-configured instrument specifications are subject to the same format and syntax rules as system devices, with the following additional restrictions:

    • A user-configured device cannot have attached secondary devices.
    • A user-configured device cannot have optional attribute specifiers.

The instrument dialog box is used to add and edit configured instruments. The dialog will change based on the type of instrument being configured. System instruments each have a custom dialog that provides options specific to the instrument. The image below is used for manual standards and user configured instruments.

The choices of the dialog are explained below.

Asset Number

The asset number is the control number that uniquely identifies the instrument.

  • The asset number is restricted to 60 characters.
  • Characters must printable.
  • A question mark and leading and trailing blanks are not allowed.
  • Lowercase characters are converted to uppercase as they are entered.
  • Two or more configured instruments may not have the same asset number.

Remote Interface

  • Select IEEE-488 if the system instrument or user-configured instrument you are configuring is controlled via the IEEE-488 bus.
  • Select Serial if the system instrument or user-configured instrument you are configuring is controlled serially.
  • Select None if you are configuring a standard.
  • The IEEE-488 and Serial buttons are grayed out when editing a previously configured standard.
  • The None button is grayed out for system instruments and editing a user-configured instrument.

IEEE-488 Address

  • Select the address of the system instrument or user-configured instrument you are configuring if it is controlled via the IEEE-488 bus. You may enter the address literally or select an available address from the list by choosing the down arrow.
  • The address must be an integer between 1 and 30.
  • If an address is not on the list, another device is already configured at that address.
  • The IEEE-488 address selection is grayed out when the remote interface you select is Serial or None.

Serial Port

Select one of these buttons if the system instrument or user-configured instrument you are configuring is controlled serially.

  • An individual button is grayed out if the hardware does not exist, the port is being used by another device such as a mouse, or another device is already configured to use that COM port.
  • These buttons are grayed out when the remote interface selected is IEEE-488 or None.
  • COM5500, COM5520, COM5800, and COM5820 buttons if included, refer to the UUT Serial Port on the respective Fluke calibrator.

Alias

The alias is an optional symbolic name, which may be used in place of the literal device address in an IEEE or PORT procedure statement. Any system instrument or a user-configured instrument may have an alias. Aliases are subject to the following rules:

  • The alias string is restricted to 7 characters.
  • All characters must be alphanumeric or an underscore.
  • The alias must not conflict with legal IEEE-488 or serial address specifiers. For example, "23" and "COM2" are not legal alias strings (because 23 is a legal IEEE-488 address, and COM2 is a legal serial address).
  • Alias strings are not case sensitive.
  • Two or more configured instruments may not have the same alias.

FSC

This is the list of Function Selection Codes (FSCs) that are used to control this instrument.


Hardware Configuration

The MET/CAL Editor Tools menu contains several options to configure hardware on the current MET/CAL station. These options are the same as the options in the MET/CAL Options menu.

See Also:

Procedure Editor Tools Menu

Instrument Configuration


Database Basics

MET/CAL Plus uses an industry standard SQL database engine from Sybase, Inc. The SQL database engine is a true relational database, which means:

  • It represents all information in the database as tables.
  • The tables have records contained in rows, and fields contained in columns.
  • A set of these tables forms the database.
  • A data engine (or data server, or server) is the only program that accesses the data file. The data engine controls all read, write and access, independently from the client applications. Sybase SQL provides the high level language to define, query, modify and control the data in the relational database.

A relationship can be established between these tables. The relationship is the heart of a relational database. The relationship is a logical meaningful connection between two or more separate tables. An example of a relational database would be one used by a bank to differentiate between customers and accounts.

For example, the customer table name John Doe is related to the account table and shows a relationship between John Doe’s address and telephone data and his accounts.

This same table relationship is used in MET/CAL Plus. Each record is an asset, usually represented by a number, and is located in the Inventory Table. The Asset Number is the default index (unique identifier) used by MET/CAL Plus. To provide the link between tables, fields have been created in MET/CAL Plus called MTAG, CTAG, RTAG, and LTAG.

.

When an asset is added to the inventory table using the MET/TRACK, a unique identifier tag (CTAG) is assigned to the asset. This tag becomes the linking between the other tables such as Repair, Calibration, Location, and Calresults.

When the asset is calibrated, a unique identifier tag (CTAG) is created for each calibration and is used to link tables such as Calresults and Standards to the asset calibration. The calibration MTAG is created when the calibration record is saved. In the figure below, an asset with an MTAG of 124 has been calibrated on 12/12/98 and was assigned a CTAG of 253. When it was calibrated on 12/12/99, it was assigned a CTAG of 282.

Similarly, a unique identifier (RTAG) is created when an asset is added to the Maintenance table and (LTAG) is created when an asset is added to the Location table.


MET/TRACK License

A MET/TRACK License also provides limited access to programs. The data entry, database customization and system configuration applications are the same as those enabled by MET/CAL or 5500/CAL licenses, however there is no access to automated calibration applications with a MET/TRACK license.

All licenses for Fluke Metrology software must be applied using MET/TRACK. Reference the How to Apply a License Topic for additional details.


Sample Exercise: MET/TRACK Basics

This section provides an overview of basic MET/TRACK operation.

MET/TRACK Toolbar

MET/TRACK has a toolbar to provide single-click access to the MET/TRACK add or edit screens.

The toolbar can also be used to search for information in the database. In this example, MET/TRACK would search for all records where the user name is "Brown, Robert".

The MET/TRACK tool bar can be enabled or disabled by selecting Tools > Preferences > Toolbar from the main menu.

Toolbar Searching

In addition to toolbar searching, MET/TRACK has a more powerful search capability. Select Search > Search Engine from the main menu.

The scope of the search is set by entering search filter values for a field. Each field has a drop down list of values in the field. This feature simplifies searching by finding values that actually exist in the database. After entering the search terms, press Enter or click the search icon.

In this example, we will search for all items assigned to Robert Brown. In addition, we will further limit the search to just the instruments where the manufactures names begin with the letter "F". Note that the wildcard character ("?") is used. The wildcard represents any character or characters.

The Instrument Browser

The results of a search are displayed in the Instrument Browser. This powerful form provides access to all vital information about an instrument.

The search has returned two instruments. Use the navigation buttons to view each record. The screen contain a "core" list of basic information on the left. More detailed information is available on the right, and can be accessed by clicking the tabs.

The location screen shows that this instrument has two location records which can be viewed by clicking the location navigation buttons.

Running Reports

MET/TRACK includes reports that can help run and manage the calibration lab. The Crystal Reports runtime engine is included with the MET/CAL Sample Version, but the report writer tools for adding or altering reports is not included in the sample version. Select Reports > Run Installed Reports from the main menu.

To run a report, make a selection and click the report preview button or click the print button. When a report is previewed, it is displayed in the report viewer.

The viewer has navigation and search tools to find information of interest. Reports can be exported for other lab needs. The icon in the upper left portion of the report viewer can be clicked to export to Microsoft Excel® or other file formats.

Database Organization

The primary record for an item is its inventory record. The calibration, location and maintenance historical records are linked to it. This allows the search engine and the reporting tools to quickly pull information together to form a complete picture of the status and history of an item. See also: Database Table Structures.

MET/TRACK Customizing

MET/TRACK is easily customized to better meet the needs of a calibration lab. Customization is a task reserved for the MET/CAL system manager. To log in as the system manager, select File > Login as a New User from the main menu. Use "MT" as both the User ID and the Password.

Further information is available at Basic Customizing Techniques.


Software Components

Two major components make up the Fluke Calibration Software product offering:

  1. MET/BASE is the core product. However, MET/BASE is not functional until a second component is in place.
  2. The User License is the second component. A License enables particular applications. The licenses available are called MET/CAL, 5500/CAL, and MET/TRACK. Which license or licenses applied determines which applications can be accessed. Client software can be installed on an unlimited number of workstations. However, the database keeps track of how many applications that can be started at any given time, depending upon the number of applied licenses. This type of license is called a "floating license."